Namespaces

Namespaces
Namespace | Description
Autodesk.RevitAddIns |
Autodesk.RevitAddInsManager |
Send comments on this topic to Autodesk


Autodesk.RevitAddIns Namespace

Classes
 | Class | Description
Public class | AddInManifestUtility | This static class provides access to read the contents of manifests from Revit .addin files.
Public class | RevitAddInApplication | Represents a Revit external application.
Public class | RevitAddInCommand | Represents a Revit external command.
Public class | RevitAddInDBApplication | Represents a Revit DB external application.
Public class | RevitAddInItem | Represents a single Revit Add-In.
Public class | RevitAddInManifest | Represents the contents of a single .addin file.
Public class | RevitProduct | Represents an installed instance of Revit on the local machine.
Public class | RevitProductUtility | Provides access to installed versions of Revit on the local machine.
Enumerations
 | Enumeration | Description
Public enumeration | AddInArchitecture | Defines the operating system architectures recognized by the Add-In utility.
Public enumeration | Discipline | Describes the conditions under which a particular external command will be visible in the Revit UI.
Public enumeration | LanguageType | Defines the language type of Revit Add-In.
Public enumeration | ProductType | An enumerated type containing the possible Revit product types.
Public enumeration | RevitVersion | Defines the versions of Revit supported by the Add-In utility.
Public enumeration | VisibilityMode | Describes the conditions under which a particular external command will be visible in the Revit UI.
Public enumeration | WarningType | Defines types of warnings issued by Revit related to Add-In failures.


AddInArchitecture Enumeration

Defines the operating system architectures recognized by the Add-In utility.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AddInArchitecture
Public Enumeration AddInArchitecture
public enum class AddInArchitecture
type AddInArchitecture
Members
Member name | Value | Description
OS32bit | 1 | 32-bit operating system.
OS64bit | 2 | 64-bit operating system.
See Also

Reference

Autodesk.RevitAddIns Namespace


AddInManifestUtility Class

This static class provides access to read the contents of manifests from Revit .addin files.
Inheritance Hierarchy
SystemObject
Autodesk.RevitAddInsAddInManifestUtility

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class AddInManifestUtility
Public NotInheritable Class AddInManifestUtility
public ref class AddInManifestUtility sealed
[<SealedAttribute>]
type AddInManifestUtility = class end

The AddInManifestUtility type exposes the following members.

Constructors
 | Name | Description
Public method | AddInManifestUtility | Initializes a new instance of the AddInManifestUtility class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetRevitAddInBundleManifests |
 | GetRevitAddInManifest | Reads an AddInManifest from the input .addin file.
 | GetRevitAddInManifests |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


AddInManifestUtility Constructor

Initializes a new instance of the AddInManifestUtility class

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public AddInManifestUtility()
Public Sub New
public:
AddInManifestUtility()
new : unit -> AddInManifestUtility
See Also

Reference

AddInManifestUtility Class


AddInManifestUtility Methods

The AddInManifestUtility type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetRevitAddInBundleManifests |
 | GetRevitAddInManifest | Reads an AddInManifest from the input .addin file.
 | GetRevitAddInManifests |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AddInManifestUtility Class


AddInManifestUtility.GetRevitAddInBundleManifests Method

RevitAddInUtility 2025.3 API

AddInManifestUtilityGetRevitAddInBundleManifests Method

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public static List GetRevitAddInBundleManifests(
    void revitVersion,
    RevitAddInManifest osString,
    string invalidFormatManifestDictionary
)
Public Shared Function GetRevitAddInBundleManifests (
    revitVersion As Void,
    osString As RevitAddInManifest,
    invalidFormatManifestDictionary As String
) As List
public:
static List^ GetRevitAddInBundleManifests(
    void revitVersion,
    RevitAddInManifest^ osString,
    String^ invalidFormatManifestDictionary
)
static member GetRevitAddInBundleManifests :
        revitVersion : unit *
        osString : RevitAddInManifest *
        invalidFormatManifestDictionary : string -> List

Parameters

revitVersion Void
osString RevitAddInManifest
invalidFormatManifestDictionary String

Return Value

ListT
See Also

Reference

AddInManifestUtility Class


AddInManifestUtility.GetRevitAddInManifest Method

AddInManifestUtilityGetRevitAddInManifest Method

Reads an AddInManifest from the input .addin file.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RevitAddInManifest GetRevitAddInManifest(
    string fileName
)
Public Shared Function GetRevitAddInManifest (
    fileName As String
) As RevitAddInManifest
public:
static RevitAddInManifest^ GetRevitAddInManifest(
    String^ fileName
)
static member GetRevitAddInManifest :
        fileName : string -> RevitAddInManifest

Parameters

fileName String
The full path to a .addin file.

Return Value

RevitAddInManifest
The AddInManifest read from the file.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when input argument is .
ArgumentException | Thrown when file name is incorrect (it is not a .addin file), or when the .addin file has an unrecognized format.
See Also

Reference

AddInManifestUtility Class


AddInManifestUtility.GetRevitAddInManifests Method

AddInManifestUtilityGetRevitAddInManifests Method

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public static List GetRevitAddInManifests(
    void folderPath,
    RevitAddInManifest invalidFormatManifestDictionary
)
Public Shared Function GetRevitAddInManifests (
    folderPath As Void,
    invalidFormatManifestDictionary As RevitAddInManifest
) As List
public:
static List^ GetRevitAddInManifests(
    void folderPath,
    RevitAddInManifest^ invalidFormatManifestDictionary
)
static member GetRevitAddInManifests :
        folderPath : unit *
        invalidFormatManifestDictionary : RevitAddInManifest -> List

Parameters

folderPath Void
invalidFormatManifestDictionary RevitAddInManifest

Return Value

ListT
See Also

Reference

AddInManifestUtility Class


Discipline Enumeration

Describes the conditions under which a particular external command will be visible in the Revit UI.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Discipline
Public Enumeration Discipline
public enum class Discipline
type Discipline
Members
Member name | Value | Description
Any | 0 | The command is available in all possible disciplines.
Architecture | 1 | The command is available in the Architecture discipline.
Electrical | 64 | The command is available in the Electrical discipline.
ElectricalAnalysis | 1,024 | The command is available in the ElectricalAnalysis discipline.
EnergyAnalysis | 16 | The command is available in the EnergyAnalysis discipline.
MassingAndSite | 8 | The command is available in the Massing and Site discipline.
Mechanical | 32 | The command is available in the Mechanical discipline.
MechanicalAnalysis | 256 | The command is available in the MechanicalAnalysis discipline.
Piping | 128 | The command is available in the Piping discipline.
PipingAnalysis | 512 | The command is available in the PipingAnalysis discipline.
StructuralAnalysis | 4 | The command is available in the StructuralAnalysis discipline.
Structure | 2 | The command is available in the Structure discipline.
Remarks
Note that there are a few conditions where the Revit API framework prevents commands from being available always:
  1. When the user has another Revit command active, e.g. creating Windows, Doors, or editing sketches.
  2. When the active view is in perspective mode, or when the view is a Walkthrough, Drawings Lists, View Lists, Note Blocks, View Lists, etc.
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


LanguageType Enumeration

Defines the language type of Revit Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LanguageType
Public Enumeration LanguageType
public enum class LanguageType
type LanguageType
Members
Member name | Value | Description
Brazilian_Portuguese | 14 | Brazilian Portuguese.
Chinese_Simplified | 6 | Chinese Simplified.
Chinese_Traditional | 7 | Chinese Traditional.
Czech | 11 | Czech.
Dutch | 5 | Dutch.
English_GB | 15 | English GB.
English_USA | 0 | English USA.
French | 3 | French.
German | 1 | German.
Hungarian | 13 | Hungarian.
Italian | 4 | Italian.
Japanese | 8 | Japanese.
Korean | 9 | Korean.
Polish | 12 | Polish.
Russian | 10 | Russian.
Spanish | 2 | Spanish.
Unknown | -1 | Unknown.
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


ProductType Enumeration

An enumerated type containing the possible Revit product types.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ProductType
Public Enumeration ProductType
public enum class ProductType
type ProductType
Members
Member name | Value | Description
Architecture | 0 | Architecture.
MEP | 2 | MEP.
Revit | 3 | Revit.
Structure | 1 | Structure.
Unknown | 4 | Unknown.
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


RevitAddInApplication Class

Represents a Revit external application.
Inheritance Hierarchy
SystemObject
Autodesk.RevitAddInsRevitAddInItem
Autodesk.RevitAddInsRevitAddInApplication

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitAddInApplication : RevitAddInItem
Public Class RevitAddInApplication
    Inherits RevitAddInItem
public ref class RevitAddInApplication : public RevitAddInItem
type RevitAddInApplication =
    class
        inherit RevitAddInItem
    end

The RevitAddInApplication type exposes the following members.

Constructors
 | Name | Description
Public method | RevitAddInApplication | Creates a new instance of the external application info class.
Top
Properties
 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem)
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem)
Public property | Name | Application name.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem)
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


RevitAddInApplication Constructor

Creates a new instance of the external application info class.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitAddInApplication(
    string name,
    string assembly,
    Guid addInId,
    string fullClassName,
    string vendorId
)
Public Sub New (
    name As String,
    assembly As String,
    addInId As Guid,
    fullClassName As String,
    vendorId As String
)
public:
RevitAddInApplication(
    String^ name,
    String^ assembly,
    Guid addInId,
    String^ fullClassName,
    String^ vendorId
)
new :
        name : string *
        assembly : string *
        addInId : Guid *
        fullClassName : string *
        vendorId : string -> RevitAddInApplication

Parameters

name String
The application name.
assembly String
The path and file name for the application assembly.
addInId Guid
The unique identifier for the application.
fullClassName String
The class name that implements IExternalApplication.
vendorId String
The vendor id.
See Also

Reference

RevitAddInApplication Class


RevitAddInApplication Properties

The RevitAddInApplication type exposes the following members.

Properties
 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem)
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem)
Public property | Name | Application name.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem)
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem)
Top
See Also

Reference

RevitAddInApplication Class


RevitAddInApplication.Name Property

RevitAddInApplicationName Property

Application name.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
See Also

Reference

RevitAddInApplication Class


RevitAddInApplication Methods

The RevitAddInApplication type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevitAddInApplication Class


RevitAddInCommand Class

Represents a Revit external command.
Inheritance Hierarchy
SystemObject
Autodesk.RevitAddInsRevitAddInItem
Autodesk.RevitAddInsRevitAddInCommand

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitAddInCommand : RevitAddInItem
Public Class RevitAddInCommand
    Inherits RevitAddInItem
public ref class RevitAddInCommand : public RevitAddInItem
type RevitAddInCommand =
    class
        inherit RevitAddInItem
    end

The RevitAddInCommand type exposes the following members.

Constructors
 | Name | Description
Public method | RevitAddInCommand | Creates a new instance of the Add-In command info class.
Top
Properties
 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem)
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this command.
Public property | Description | The short description and short tooltip for the command.
Public property | Discipline | The modes in which the external command will be visible.
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem)
Public property | LanguageType | The language type of Revit Add-In.
Public property | LargeImage | The path to the large image for the command button.
Public property | LongDescription | The text shown in the extended command tooltip.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem)
Public property | Text | The text displayed on the external command button.
Public property | TooltipImage | The image shown in the extended command tooltip.
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem)
Public property | VisibilityMode | The modes in which the external command will be visible.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


RevitAddInCommand Constructor

Creates a new instance of the Add-In command info class.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitAddInCommand(
    string assembly,
    Guid addInId,
    string fullClassName,
    string vendorId
)
Public Sub New (
    assembly As String,
    addInId As Guid,
    fullClassName As String,
    vendorId As String
)
public:
RevitAddInCommand(
    String^ assembly,
    Guid addInId,
    String^ fullClassName,
    String^ vendorId
)
new :
        assembly : string *
        addInId : Guid *
        fullClassName : string *
        vendorId : string -> RevitAddInCommand

Parameters

assembly String
The path and file name for the command assembly.
addInId Guid
The unique identifier for the command.
fullClassName String
The class name that implements IExternalCommand.
vendorId String
The vendor id.
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand Properties

The RevitAddInCommand type exposes the following members.

Properties
 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem)
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this command.
Public property | Description | The short description and short tooltip for the command.
Public property | Discipline | The modes in which the external command will be visible.
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem)
Public property | LanguageType | The language type of Revit Add-In.
Public property | LargeImage | The path to the large image for the command button.
Public property | LongDescription | The text shown in the extended command tooltip.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem)
Public property | Text | The text displayed on the external command button.
Public property | TooltipImage | The image shown in the extended command tooltip.
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem)
Public property | VisibilityMode | The modes in which the external command will be visible.
Top
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand.AvailabilityClassName Property

RevitAddInCommandAvailabilityClassName Property

The full class name for the class providing the entry point to decide availability of this command.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AvailabilityClassName { get; set; }
Public Property AvailabilityClassName As String
    Get
    Set
public:
property String^ AvailabilityClassName {
    String^ get ();
    void set (String^ value);
}
member AvailabilityClassName : string with get, set

Property Value

String
Remarks
This is the class implementing IExternalCommandAvailability interface.
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand.Description Property

RevitAddInCommandDescription Property

The short description and short tooltip for the command.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

String
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand.Discipline Property

RevitAddInCommandDiscipline Property

The modes in which the external command will be visible.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public Discipline Discipline { get; set; }
Public Property Discipline As Discipline
    Get
    Set
public:
property Discipline Discipline {
    Discipline get ();
    void set (Discipline value);
}
member Discipline : Discipline with get, set

Property Value

Discipline
Remarks
There is 1 set of mode where visibility can be set: Visibility affected by the availability of a certain discipline.
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand.LanguageType Property

RevitAddInCommandLanguageType Property

The language type of Revit Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public LanguageType LanguageType { get; set; }
Public Property LanguageType As LanguageType
    Get
    Set
public:
property LanguageType LanguageType {
    LanguageType get ();
    void set (LanguageType value);
}
member LanguageType : LanguageType with get, set

Property Value

LanguageType
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand.LargeImage Property

RevitAddInCommandLargeImage Property

The path to the large image for the command button.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LargeImage { get; set; }
Public Property LargeImage As String
    Get
    Set
public:
property String^ LargeImage {
    String^ get ();
    void set (String^ value);
}
member LargeImage : string with get, set

Property Value

String
Remarks
This image will be shown on the button in the External Tools pulldown. The image should be 32 x 32 pixels. If the image is larger it will be adjusted to fit the button.
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand.LongDescription Property

RevitAddInCommandLongDescription Property

The text shown in the extended command tooltip.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LongDescription { get; set; }
Public Property LongDescription As String
    Get
    Set
public:
property String^ LongDescription {
    String^ get ();
    void set (String^ value);
}
member LongDescription : string with get, set

Property Value

String
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand.Text Property

RevitAddInCommandText Property

The text displayed on the external command button.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

String
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand.TooltipImage Property

RevitAddInCommandTooltipImage Property

The image shown in the extended command tooltip.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TooltipImage { get; set; }
Public Property TooltipImage As String
    Get
    Set
public:
property String^ TooltipImage {
    String^ get ();
    void set (String^ value);
}
member TooltipImage : string with get, set

Property Value

String
Remarks
Recommended image size is 304 * 188 pixels.
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand.VisibilityMode Property

RevitAddInCommandVisibilityMode Property

The modes in which the external command will be visible.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisibilityMode VisibilityMode { get; set; }
Public Property VisibilityMode As VisibilityMode
    Get
    Set
public:
property VisibilityMode VisibilityMode {
    VisibilityMode get ();
    void set (VisibilityMode value);
}
member VisibilityMode : VisibilityMode with get, set

Property Value

VisibilityMode
Remarks
There are 2 sets of modes where visibility can be set: Visibility affected by the type of active document.
See Also

Reference

RevitAddInCommand Class


RevitAddInCommand Methods

The RevitAddInCommand type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevitAddInCommand Class


RevitAddInDBApplication Class

Represents a Revit DB external application.
Inheritance Hierarchy
SystemObject
Autodesk.RevitAddInsRevitAddInItem
Autodesk.RevitAddInsRevitAddInDBApplication

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitAddInDBApplication : RevitAddInItem
Public Class RevitAddInDBApplication
    Inherits RevitAddInItem
public ref class RevitAddInDBApplication : public RevitAddInItem
type RevitAddInDBApplication =
    class
        inherit RevitAddInItem
    end

The RevitAddInDBApplication type exposes the following members.

Constructors
 | Name | Description
Public method | RevitAddInDBApplication | Creates a new instance of the external DB application info class.
Top
Properties
 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem)
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem)
Public property | LoadInDedicatedRevitWorkerOnly | Indicates whether or not a "dedicated to request" RevitWorker process will load this add-in.
Public property | LoadInRevitWorker | Indicates whether or not a RevitWorker process will load this add-in.
Public property | Name | DB Application name.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem)
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


RevitAddInDBApplication Constructor

Creates a new instance of the external DB application info class.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitAddInDBApplication(
    string name,
    string assembly,
    Guid addInId,
    string fullClassName,
    string vendorId
)
Public Sub New (
    name As String,
    assembly As String,
    addInId As Guid,
    fullClassName As String,
    vendorId As String
)
public:
RevitAddInDBApplication(
    String^ name,
    String^ assembly,
    Guid addInId,
    String^ fullClassName,
    String^ vendorId
)
new :
        name : string *
        assembly : string *
        addInId : Guid *
        fullClassName : string *
        vendorId : string -> RevitAddInDBApplication

Parameters

name String
The DB application name.
assembly String
The path and file name for the DB application assembly.
addInId Guid
The unique identifier for the application.
fullClassName String
The class name that implements IExternalDBApplication.
vendorId String
The vendor id.
See Also

Reference

RevitAddInDBApplication Class


RevitAddInDBApplication Properties

The RevitAddInDBApplication type exposes the following members.

Properties
 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem)
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem)
Public property | LoadInDedicatedRevitWorkerOnly | Indicates whether or not a "dedicated to request" RevitWorker process will load this add-in.
Public property | LoadInRevitWorker | Indicates whether or not a RevitWorker process will load this add-in.
Public property | Name | DB Application name.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem)
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem)
Top
See Also

Reference

RevitAddInDBApplication Class


RevitAddInDBApplication.LoadInDedicatedRevitWorkerOnly Property

RevitAddInDBApplicationLoadInDedicatedRevitWorkerOnly Property

Indicates whether or not a "dedicated to request" RevitWorker process will load this add-in.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadInDedicatedRevitWorkerOnly { get; set; }
Public Property LoadInDedicatedRevitWorkerOnly As Boolean
    Get
    Set
public:
property bool LoadInDedicatedRevitWorkerOnly {
    bool get ();
    void set (bool value);
}
member LoadInDedicatedRevitWorkerOnly : bool with get, set

Property Value

Boolean
Remarks
The default is false.
See Also

Reference

RevitAddInDBApplication Class


RevitAddInDBApplication.LoadInRevitWorker Property

RevitAddInDBApplicationLoadInRevitWorker Property

Indicates whether or not a RevitWorker process will load this add-in.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadInRevitWorker { get; set; }
Public Property LoadInRevitWorker As Boolean
    Get
    Set
public:
property bool LoadInRevitWorker {
    bool get ();
    void set (bool value);
}
member LoadInRevitWorker : bool with get, set

Property Value

Boolean
Remarks
The default is false.
See Also

Reference

RevitAddInDBApplication Class


RevitAddInDBApplication.Name Property

RevitAddInDBApplicationName Property

DB Application name.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
See Also

Reference

RevitAddInDBApplication Class


RevitAddInDBApplication Methods

The RevitAddInDBApplication type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevitAddInDBApplication Class


RevitAddInItem Class

Represents a single Revit Add-In.
Inheritance Hierarchy
SystemObject
Autodesk.RevitAddInsRevitAddInItem
Autodesk.RevitAddInsRevitAddInApplication
Autodesk.RevitAddInsRevitAddInCommand
Autodesk.RevitAddInsRevitAddInDBApplication

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitAddInItem
Public Class RevitAddInItem
public ref class RevitAddInItem
type RevitAddInItem = class end

The RevitAddInItem type exposes the following members.

Properties
 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier.
Public property | AllowLoadingIntoExistingSession | The flag of loading permission.
Public property | Assembly | The file path for the assembly which defines the Add-In.
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In.
Public property | ProductDescription | The product description.
Public property | ProductImage | The product image.
Public property | ProductVersion | The product version.
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user.
Public property | VendorDescription | The vendor description.
Public property | VendorId | The vendor id.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


RevitAddInItem Properties

The RevitAddInItem type exposes the following members.

Properties
 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier.
Public property | AllowLoadingIntoExistingSession | The flag of loading permission.
Public property | Assembly | The file path for the assembly which defines the Add-In.
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In.
Public property | ProductDescription | The product description.
Public property | ProductImage | The product image.
Public property | ProductVersion | The product version.
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user.
Public property | VendorDescription | The vendor description.
Public property | VendorId | The vendor id.
Top
See Also

Reference

RevitAddInItem Class


RevitAddInItem.AddInId Property

RevitAddInItemAddInId Property

The id for the Add-In. Each add-in must be assigned a unique identifier.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid AddInId { get; set; }
Public Property AddInId As Guid
    Get
    Set
public:
property Guid AddInId {
    Guid get ();
    void set (Guid value);
}
member AddInId : Guid with get, set

Property Value

Guid
See Also

Reference

RevitAddInItem Class


RevitAddInItem.AllowLoadingIntoExistingSession Property

RevitAddInItemAllowLoadingIntoExistingSession Property

The flag of loading permission.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowLoadingIntoExistingSession { get; set; }
Public Property AllowLoadingIntoExistingSession As Boolean
    Get
    Set
public:
property bool AllowLoadingIntoExistingSession {
    bool get ();
    void set (bool value);
}
member AllowLoadingIntoExistingSession : bool with get, set

Property Value

Boolean
See Also

Reference

RevitAddInItem Class


RevitAddInItem.Assembly Property

RevitAddInItemAssembly Property

The file path for the assembly which defines the Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Assembly { get; set; }
Public Property Assembly As String
    Get
    Set
public:
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}
member Assembly : string with get, set

Property Value

String
See Also

Reference

RevitAddInItem Class


RevitAddInItem.FullClassName Property

RevitAddInItemFullClassName Property

The full class name for the class providing the entry point into the Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullClassName { get; set; }
Public Property FullClassName As String
    Get
    Set
public:
property String^ FullClassName {
    String^ get ();
    void set (String^ value);
}
member FullClassName : string with get, set

Property Value

String
Remarks
This is the class implementing IExternalCommand or IExternalApplication.
See Also

Reference

RevitAddInItem Class


RevitAddInItem.ProductDescription Property

RevitAddInItemProductDescription Property

The product description.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductDescription { get; set; }
Public Property ProductDescription As String
    Get
    Set
public:
property String^ ProductDescription {
    String^ get ();
    void set (String^ value);
}
member ProductDescription : string with get, set

Property Value

String
See Also

Reference

RevitAddInItem Class


RevitAddInItem.ProductImage Property

RevitAddInItemProductImage Property

The product image.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductImage { get; set; }
Public Property ProductImage As String
    Get
    Set
public:
property String^ ProductImage {
    String^ get ();
    void set (String^ value);
}
member ProductImage : string with get, set

Property Value

String
See Also

Reference

RevitAddInItem Class


RevitAddInItem.ProductVersion Property

RevitAddInItemProductVersion Property

The product version.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductVersion { get; set; }
Public Property ProductVersion As String
    Get
    Set
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}
member ProductVersion : string with get, set

Property Value

String
See Also

Reference

RevitAddInItem Class


RevitAddInItem.SuppressedWarning Property

RevitAddInItemSuppressedWarning Property

A startup failure which, if it occurs, will be suppressed from the user.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public WarningType SuppressedWarning { get; set; }
Public Property SuppressedWarning As WarningType
    Get
    Set
public:
property WarningType SuppressedWarning {
    WarningType get ();
    void set (WarningType value);
}
member SuppressedWarning : WarningType with get, set

Property Value

WarningType
Remarks
When Revit attempts to start an Add-In and fails to do so, it will show a message to the user about the error. Users have the option to ignore that error in the future. This property is used to represent the user's choice to ignore an error. Note that if a different error occurs for the Add-In, it will still be shown to the user.
See Also

Reference

RevitAddInItem Class


RevitAddInItem.VendorDescription Property

RevitAddInItemVendorDescription Property

The vendor description.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VendorDescription { get; set; }
Public Property VendorDescription As String
    Get
    Set
public:
property String^ VendorDescription {
    String^ get ();
    void set (String^ value);
}
member VendorDescription : string with get, set

Property Value

String
Remarks
This should be a string that the user can use to identify the vendor.
See Also

Reference

RevitAddInItem Class


RevitAddInItem.VendorId Property

RevitAddInItemVendorId Property

The vendor id.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VendorId { get; set; }
Public Property VendorId As String
    Get
    Set
public:
property String^ VendorId {
    String^ get ();
    void set (String^ value);
}
member VendorId : string with get, set

Property Value

String
Remarks
This is required by add-in application.
See Also

Reference

RevitAddInItem Class


RevitAddInItem Methods

The RevitAddInItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevitAddInItem Class


RevitAddInManifest Class

Represents the contents of a single .addin file.
Inheritance Hierarchy
SystemObject
Autodesk.RevitAddInsRevitAddInManifest

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitAddInManifest
Public Class RevitAddInManifest
public ref class RevitAddInManifest
type RevitAddInManifest = class end

The RevitAddInManifest type exposes the following members.

Constructors
 | Name | Description
Public method | RevitAddInManifest | Constructs a new empty manifest.
Top
Properties
 | Name | Description
Public property | AddInApplications | The collection of all external applications in the manifest.
Public property | AddInCommands | The collection of all external commands in the manifest.
Public property | AddInDBApplications | The collection of all external DB applications in the manifest.
Public property | FullName | The full path and file name which is associated with the manifest.
Public property | Name | The file name which is associated with the manifest.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Save | Saves the information in the manifest to its associated .addin file location.
Public method | SaveAs | Saves the information in the manifest as a new .addin file..
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The manifest contains a collection of external commands and external applications listed in the .addin file.
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


RevitAddInManifest Constructor

Constructs a new empty manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitAddInManifest()
Public Sub New
public:
RevitAddInManifest()
new : unit -> RevitAddInManifest
See Also

Reference

RevitAddInManifest Class


RevitAddInManifest Properties

The RevitAddInManifest type exposes the following members.

Properties
 | Name | Description
Public property | AddInApplications | The collection of all external applications in the manifest.
Public property | AddInCommands | The collection of all external commands in the manifest.
Public property | AddInDBApplications | The collection of all external DB applications in the manifest.
Public property | FullName | The full path and file name which is associated with the manifest.
Public property | Name | The file name which is associated with the manifest.
Top
See Also

Reference

RevitAddInManifest Class


RevitAddInManifest.AddInApplications Property

RevitAddInManifestAddInApplications Property

The collection of all external applications in the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public List AddInApplications { get; }
Public ReadOnly Property AddInApplications As List
    Get
public:
property List^ AddInApplications {
    List^ get ();
}
member AddInApplications : List with get

Property Value

ListT
See Also

Reference

RevitAddInManifest Class


RevitAddInManifest.AddInCommands Property

RevitAddInManifestAddInCommands Property

The collection of all external commands in the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public List AddInCommands { get; }
Public ReadOnly Property AddInCommands As List
    Get
public:
property List^ AddInCommands {
    List^ get ();
}
member AddInCommands : List with get

Property Value

ListT
See Also

Reference

RevitAddInManifest Class


RevitAddInManifest.AddInDBApplications Property

RevitAddInManifestAddInDBApplications Property

The collection of all external DB applications in the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public List AddInDBApplications { get; }
Public ReadOnly Property AddInDBApplications As List
    Get
public:
property List^ AddInDBApplications {
    List^ get ();
}
member AddInDBApplications : List with get

Property Value

ListT
See Also

Reference

RevitAddInManifest Class


RevitAddInManifest.FullName Property

RevitAddInManifestFullName Property

The full path and file name which is associated with the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullName { get; }
Public ReadOnly Property FullName As String
    Get
public:
property String^ FullName {
    String^ get ();
}
member FullName : string with get

Property Value

String
See Also

Reference

RevitAddInManifest Class


RevitAddInManifest.Name Property

RevitAddInManifestName Property

The file name which is associated with the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

RevitAddInManifest Class


RevitAddInManifest Methods

The RevitAddInManifest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Save | Saves the information in the manifest to its associated .addin file location.
Public method | SaveAs | Saves the information in the manifest as a new .addin file..
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevitAddInManifest Class


RevitAddInManifest.Save Method

RevitAddInManifestSave Method

Saves the information in the manifest to its associated .addin file location.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Exceptions
Exception | Condition
ArgumentNullException | Thrown when FullName is or empty.
ArgumentException | Thrown when FullName is incorrect (it is not a .addin file). Or there are no external commands or applications to write to manifest file.
XmlException | The operation would not result in a well formed XML document (for example, no document element or duplicate XML declarations).
See Also

Reference

RevitAddInManifest Class


RevitAddInManifest.SaveAs Method

RevitAddInManifestSaveAs Method

Saves the information in the manifest as a new .addin file..

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveAs(
    string fileName
)
Public Sub SaveAs (
    fileName As String
)
public:
void SaveAs(
    String^ fileName
)
member SaveAs :
        fileName : string -> unit

Parameters

fileName String
The full path and file name which is associated with the manifest.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when file name argument is or empty.
ArgumentException | Thrown when file name is incorrect (it is not a .addin file). Or there are no external commands or applications to write to manifest file.
XmlException | The operation would not result in a well formed XML document (for example, no document element or duplicate XML declarations).
See Also

Reference

RevitAddInManifest Class


RevitProduct Class

Represents an installed instance of Revit on the local machine.
Inheritance Hierarchy
SystemObject
Autodesk.RevitAddInsRevitProduct

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitProduct
Public Class RevitProduct
public ref class RevitProduct
type RevitProduct = class end

The RevitProduct type exposes the following members.

Properties
 | Name | Description
Public property | AllUsersAddInFolder | The folder path in which .addin files associated to all users will be located for this product.
Public property | Architecture | The system architecture of this Revit product installation.
Public property | CurrentUserAddInFolder | The folder path in which .addin files associated to the current user will be located for this product.
Public property | InstallLocation | The folder path where this Revit product is installed.
Public property | Name | User-visible name for this Revit product. such as : 'Autodesk Revit Architecture 2010'.
Public property | Product | The product type.
Public property | ProductCode | The id used to locate and identify the Revit product from the registry.
Public property | ReleaseSubVersion | The string for the release sub versions.
Public property | Subversion | The release subversion.
Public property | Version | The version for this Revit product. Such as: '2010'.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


RevitProduct Properties

The RevitProduct type exposes the following members.

Properties
 | Name | Description
Public property | AllUsersAddInFolder | The folder path in which .addin files associated to all users will be located for this product.
Public property | Architecture | The system architecture of this Revit product installation.
Public property | CurrentUserAddInFolder | The folder path in which .addin files associated to the current user will be located for this product.
Public property | InstallLocation | The folder path where this Revit product is installed.
Public property | Name | User-visible name for this Revit product. such as : 'Autodesk Revit Architecture 2010'.
Public property | Product | The product type.
Public property | ProductCode | The id used to locate and identify the Revit product from the registry.
Public property | ReleaseSubVersion | The string for the release sub versions.
Public property | Subversion | The release subversion.
Public property | Version | The version for this Revit product. Such as: '2010'.
Top
See Also

Reference

RevitProduct Class


RevitProduct.AllUsersAddInFolder Property

RevitProductAllUsersAddInFolder Property

The folder path in which .addin files associated to all users will be located for this product.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AllUsersAddInFolder { get; }
Public ReadOnly Property AllUsersAddInFolder As String
    Get
public:
property String^ AllUsersAddInFolder {
    String^ get ();
}
member AllUsersAddInFolder : string with get

Property Value

String
See Also

Reference

RevitProduct Class


RevitProduct.Architecture Property

RevitProductArchitecture Property

The system architecture of this Revit product installation.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public AddInArchitecture Architecture { get; }
Public ReadOnly Property Architecture As AddInArchitecture
    Get
public:
property AddInArchitecture Architecture {
    AddInArchitecture get ();
}
member Architecture : AddInArchitecture with get

Property Value

AddInArchitecture
See Also

Reference

RevitProduct Class


RevitProduct.CurrentUserAddInFolder Property

RevitProductCurrentUserAddInFolder Property

The folder path in which .addin files associated to the current user will be located for this product.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentUserAddInFolder { get; }
Public ReadOnly Property CurrentUserAddInFolder As String
    Get
public:
property String^ CurrentUserAddInFolder {
    String^ get ();
}
member CurrentUserAddInFolder : string with get

Property Value

String
See Also

Reference

RevitProduct Class


RevitProduct.InstallLocation Property

RevitProductInstallLocation Property

The folder path where this Revit product is installed.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InstallLocation { get; }
Public ReadOnly Property InstallLocation As String
    Get
public:
property String^ InstallLocation {
    String^ get ();
}
member InstallLocation : string with get

Property Value

String
See Also

Reference

RevitProduct Class


RevitProduct.Name Property

RevitProductName Property

User-visible name for this Revit product. such as : 'Autodesk Revit Architecture 2010'.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

RevitProduct Class


RevitProduct.Product Property

RevitProductProduct Property

The product type.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductType Product { get; }
Public ReadOnly Property Product As ProductType
    Get
public:
property ProductType Product {
    ProductType get ();
}
member Product : ProductType with get

Property Value

ProductType
See Also

Reference

RevitProduct Class


RevitProduct.ProductCode Property

RevitProductProductCode Property

The id used to locate and identify the Revit product from the registry.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ProductCode { get; }
Public ReadOnly Property ProductCode As Guid
    Get
public:
property Guid ProductCode {
    Guid get ();
}
member ProductCode : Guid with get

Property Value

Guid
See Also

Reference

RevitProduct Class


RevitProduct.ReleaseSubVersion Property

RevitProductReleaseSubVersion Property

The string for the release sub versions.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReleaseSubVersion { get; }
Public ReadOnly Property ReleaseSubVersion As String
    Get
public:
property String^ ReleaseSubVersion {
    String^ get ();
}
member ReleaseSubVersion : string with get

Property Value

String
Remarks
SubVersion releases may have additional APIs and functionality not available in the standard customer releases. Add-ins written to support standard Revit releases should be compatible with Subversion releases, but add-ins written specifically targeting new features in Subversion releases would not be compatible with the standard releases.
See Also

Reference

RevitProduct Class


RevitProduct.Subversion Property

RevitProductSubversion Property

The release subversion.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint Subversion { get; }
Public ReadOnly Property Subversion As UInteger
    Get
public:
property unsigned int Subversion {
    unsigned int get ();
}
member Subversion : uint32 with get

Property Value

UInt32
See Also

Reference

RevitProduct Class


RevitProduct.Version Property

RevitProductVersion Property

The version for this Revit product. Such as: '2010'.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitVersion Version { get; }
Public ReadOnly Property Version As RevitVersion
    Get
public:
property RevitVersion Version {
    RevitVersion get ();
}
member Version : RevitVersion with get

Property Value

RevitVersion
See Also

Reference

RevitProduct Class


RevitProduct Methods

The RevitProduct type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevitProduct Class


RevitProductUtility Class

Provides access to installed versions of Revit on the local machine.
Inheritance Hierarchy
SystemObject
Autodesk.RevitAddInsRevitProductUtility

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RevitProductUtility
Public NotInheritable Class RevitProductUtility
public ref class RevitProductUtility sealed
[<SealedAttribute>]
type RevitProductUtility = class end

The RevitProductUtility type exposes the following members.

Constructors
 | Name | Description
Public method | RevitProductUtility | Initializes a new instance of the RevitProductUtility class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetAllInstalledRevitProducts | Gets a list of Revit products installed on this machine.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


RevitProductUtility Constructor

Initializes a new instance of the RevitProductUtility class

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitProductUtility()
Public Sub New
public:
RevitProductUtility()
new : unit -> RevitProductUtility
See Also

Reference

RevitProductUtility Class


RevitProductUtility Methods

The RevitProductUtility type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetAllInstalledRevitProducts | Gets a list of Revit products installed on this machine.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevitProductUtility Class


RevitProductUtility.GetAllInstalledRevitProducts Method

RevitProductUtilityGetAllInstalledRevitProducts Method

Gets a list of Revit products installed on this machine.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public static List GetAllInstalledRevitProducts()
Public Shared Function GetAllInstalledRevitProducts As List
public:
static List^ GetAllInstalledRevitProducts()
static member GetAllInstalledRevitProducts : unit -> List

Return Value

ListT
Remarks
This operation parses the registry for necessary information about the installation(s). An incomplete or incorrect installation of Revit may not be returned correctly by this utility.
See Also

Reference

RevitProductUtility Class


RevitVersion Enumeration

Defines the versions of Revit supported by the Add-In utility.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RevitVersion
Public Enumeration RevitVersion
public enum class RevitVersion
type RevitVersion
Members
Member name | Value | Description
Revit2011 | 1 | Revit 2011.
Revit2012 | 2 | Revit 2012.
Revit2013 | 3 | Revit 2013.
Revit2014 | 4 | Revit 2014.
Revit2015 | 5 | Revit 2015.
Revit2016 | 6 | Revit 2016.
Revit2017 | 7 | Revit 2017.
Revit2018 | 8 | Revit 2018.
Revit2019 | 9 | Revit 2019.
Revit2020 | 10 | Revit 2020.
Revit2021 | 11 | Revit 2021.
Revit2022 | 12 | Revit 2022.
Revit2023 | 13 | Revit 2023.
Revit2024 | 14 | Revit 2024.
Revit2025 | 15 | Revit 2025.
Unknown | -1 | Unknown.
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


VisibilityMode Enumeration

Describes the conditions under which a particular external command will be visible in the Revit UI.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum VisibilityMode
<FlagsAttribute>
Public Enumeration VisibilityMode
[FlagsAttribute]
public enum class VisibilityMode
[<FlagsAttribute>]
type VisibilityMode
Members
Member name | Value | Description
AlwaysVisible | 0 | The command is available in all possible modes supported by the Revit API.
NotVisibleInFamily | 2 | The command is invisible when there is a family document active.
NotVisibleInProject | 1 | The command is invisible when there is a project document active.
NotVisibleWhenNoActiveDocument | 4 | The command is invisible when there is no active document.
Remarks
Note that there are a few conditions where the Revit API framework prevents commands from being available always:
  1. When the user has another Revit command active, e.g. creating Windows, Doors, or editing sketches.
  2. When the active view is in perspective mode, or when the view is a Walkthrough, Drawings Lists, View Lists, Note Blocks, View Lists, etc.
  3. When the user is editing an in-place family.
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


WarningType Enumeration

Defines types of warnings issued by Revit related to Add-In failures.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WarningType
Public Enumeration WarningType
public enum class WarningType
type WarningType
Members
Member name | Value | Description
ClassNotFound | 1 | Revit could not find the indicated class in the assembly file.
GUIDConflict | 4 | There is another add-in which registered the same Id (GUID).
InvalidFormatClientId | 9 | Revit could not interop.
InvalidRegenerationAttributeError | 13 | Not a valid regeneration attribute.
InvalidTransactionAttributeError | 12 | Not a valid transaction attribute.
NoApplicationName | 8 | Missing the required value of the Name node for application add-in.
NoAssembly | 7 | Missing the required value of the Assembly node.
NoClientId | 6 | Missing the required value of the ClientId node.
NoFullClassName | 5 | Missing the required value of the FullClassName node.
NoVendorId | 14 | Missing the required value of the VendorId node.
NoWarning | 0 | There is no warning in this AddIn.
UncaughtException | 3 | Unhandled exceptions were caught when the AddIn was executed.
UncaughtExceptionInAvailabilityClass | 11 | Unhandled exceptions were caught when the availability command was executed.
WrongAssemblyPath | 2 | Revit could not find the assembly file.
WrongAvailabilityClass | 10 | Revit could not invoke IExternalCommandAvailability correctly.
See Also

Reference

Autodesk.RevitAddIns Namespace
Send comments on this topic to Autodesk


Autodesk.RevitAddInsManager Namespace

Classes
 | Class | Description
Public class | AddInItemSettings | This class represents the settings of an Add-in registered with Revit.
Public class | AddInsManagerSettings | This class contains the settings to enable/disable loading of Add-ins registered with Revit. Not all Add-ins can be disabled, some Add-ins installed with Revit will always be loaded.


AddInItemSettings Class

This class represents the settings of an Add-in registered with Revit.
Inheritance Hierarchy
SystemObject
Autodesk.RevitAddInsManagerAddInItemSettings

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AddInItemSettings
Public Class AddInItemSettings
public ref class AddInItemSettings
type AddInItemSettings = class end

The AddInItemSettings type exposes the following members.

Properties
 | Name | Description
Public property | Disabled | True if loading of this Add-in is disabled by the user, false otherwise.
Public property | GUID | The ID of the Add-in.
Public property | LoadTime | The last loading time of the Add-in is in milliseconds.
Public property | Name | The name of the Add-in.
Public property | Vendor | The vendor of the Add-in.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.RevitAddInsManager Namespace


AddInItemSettings Properties

The AddInItemSettings type exposes the following members.

Properties
 | Name | Description
Public property | Disabled | True if loading of this Add-in is disabled by the user, false otherwise.
Public property | GUID | The ID of the Add-in.
Public property | LoadTime | The last loading time of the Add-in is in milliseconds.
Public property | Name | The name of the Add-in.
Public property | Vendor | The vendor of the Add-in.
Top
See Also

Reference

AddInItemSettings Class
Autodesk.RevitAddInsManager Namespace


AddInItemSettings.Disabled Property

AddInItemSettingsDisabled Property

True if loading of this Add-in is disabled by the user, false otherwise.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Disabled { get; set; }
Public Property Disabled As Boolean
    Get
    Set
public:
property bool Disabled {
    bool get ();
    void set (bool value);
}
member Disabled : bool with get, set

Property Value

Boolean
See Also

Reference

AddInItemSettings Class
Autodesk.RevitAddInsManager Namespace


AddInItemSettings.GUID Property

AddInItemSettingsGUID Property

The ID of the Add-in.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GUID { get; set; }
Public Property GUID As Guid
    Get
    Set
public:
property Guid GUID {
    Guid get ();
    void set (Guid value);
}
member GUID : Guid with get, set

Property Value

Guid
See Also

Reference

AddInItemSettings Class
Autodesk.RevitAddInsManager Namespace


AddInItemSettings.LoadTime Property

AddInItemSettingsLoadTime Property

The last loading time of the Add-in is in milliseconds.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LoadTime { get; set; }
Public Property LoadTime As Integer
    Get
    Set
public:
property int LoadTime {
    int get ();
    void set (int value);
}
member LoadTime : int with get, set

Property Value

Int32
See Also

Reference

AddInItemSettings Class
Autodesk.RevitAddInsManager Namespace


AddInItemSettings.Name Property

AddInItemSettingsName Property

The name of the Add-in.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
See Also

Reference

AddInItemSettings Class
Autodesk.RevitAddInsManager Namespace


AddInItemSettings.Vendor Property

AddInItemSettingsVendor Property

The vendor of the Add-in.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Vendor { get; set; }
Public Property Vendor As String
    Get
    Set
public:
property String^ Vendor {
    String^ get ();
    void set (String^ value);
}
member Vendor : string with get, set

Property Value

String
See Also

Reference

AddInItemSettings Class
Autodesk.RevitAddInsManager Namespace


AddInItemSettings Methods

The AddInItemSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AddInItemSettings Class
Autodesk.RevitAddInsManager Namespace


AddInsManagerSettings Class

This class contains the settings to enable/disable loading of Add-ins registered with Revit. Not all Add-ins can be disabled, some Add-ins installed with Revit will always be loaded.
Inheritance Hierarchy
SystemObject
Autodesk.RevitAddInsManagerAddInsManagerSettings

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AddInsManagerSettings
Public Class AddInsManagerSettings
public ref class AddInsManagerSettings
type AddInsManagerSettings = class end

The AddInsManagerSettings type exposes the following members.

Properties
 | Name | Description
Public property | DisableAllAddIns | True to disable loading of all Add-ins that are allowed to be disabled, false otherwise.
Top
Methods
 | Name | Description
Public method | CreateAddInItemSettings | Creates new AddInItemSettings for an Add-in with the specified Guid.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | Get | Returns AddInsManagerSettings for the current Windows user.
Public method | GetAddInItemSettings | Returns AddInItemSettings if the manager stores the settings for Add-in identified by the Guid, otherwise.
Public method | GetAllAddInItemSettings | Returns all AddInItemSettings.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Save | Saves current AddInsManagerSettings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.RevitAddInsManager Namespace


AddInsManagerSettings Properties

The AddInsManagerSettings type exposes the following members.

Properties
 | Name | Description
Public property | DisableAllAddIns | True to disable loading of all Add-ins that are allowed to be disabled, false otherwise.
Top
See Also

Reference

AddInsManagerSettings Class
Autodesk.RevitAddInsManager Namespace


AddInsManagerSettings.DisableAllAddIns Property

AddInsManagerSettingsDisableAllAddIns Property

True to disable loading of all Add-ins that are allowed to be disabled, false otherwise.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DisableAllAddIns { get; set; }
Public Property DisableAllAddIns As Boolean
    Get
    Set
public:
property bool DisableAllAddIns {
    bool get ();
    void set (bool value);
}
member DisableAllAddIns : bool with get, set

Property Value

Boolean
See Also

Reference

AddInsManagerSettings Class
Autodesk.RevitAddInsManager Namespace


AddInsManagerSettings Methods

The AddInsManagerSettings type exposes the following members.

Methods
 | Name | Description
Public method | CreateAddInItemSettings | Creates new AddInItemSettings for an Add-in with the specified Guid.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | Get | Returns AddInsManagerSettings for the current Windows user.
Public method | GetAddInItemSettings | Returns AddInItemSettings if the manager stores the settings for Add-in identified by the Guid, otherwise.
Public method | GetAllAddInItemSettings | Returns all AddInItemSettings.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Save | Saves current AddInsManagerSettings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AddInsManagerSettings Class
Autodesk.RevitAddInsManager Namespace


AddInsManagerSettings.CreateAddInItemSettings Method

AddInsManagerSettingsCreateAddInItemSettings Method

Creates new AddInItemSettings for an Add-in with the specified Guid.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public AddInItemSettings CreateAddInItemSettings(
    Guid guid,
    string name,
    string vendor
)
Public Function CreateAddInItemSettings (
    guid As Guid,
    name As String,
    vendor As String
) As AddInItemSettings
public:
AddInItemSettings^ CreateAddInItemSettings(
    Guid guid,
    String^ name,
    String^ vendor
)
member CreateAddInItemSettings :
        guid : Guid *
        name : string *
        vendor : string -> AddInItemSettings

Parameters

guid Guid
The Guid of the Add-in item.
name String
The Name of the Add-in item.
vendor String
The Vendor of the Add-in item.

Return Value

AddInItemSettings
Returns created AddInItemSettings.
Exceptions
Exception | Condition
InvalidOperationException | Throws when AddInItemSettings for the specified Guid is already present.
Remarks
Not all Add-ins can be disabled, some Add-ins installed with Revit will always be loaded.
See Also

Reference

AddInsManagerSettings Class
Autodesk.RevitAddInsManager Namespace


AddInsManagerSettings.Get Method

AddInsManagerSettingsGet Method

Returns AddInsManagerSettings for the current Windows user.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AddInsManagerSettings Get()
Public Shared Function Get As AddInsManagerSettings
public:
static AddInsManagerSettings^ Get()
static member Get : unit -> AddInsManagerSettings

Return Value

AddInsManagerSettings
See Also

Reference

AddInsManagerSettings Class
Autodesk.RevitAddInsManager Namespace


AddInsManagerSettings.GetAddInItemSettings Method

AddInsManagerSettingsGetAddInItemSettings Method

Returns AddInItemSettings if the manager stores the settings for Add-in identified by the Guid, otherwise.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public AddInItemSettings GetAddInItemSettings(
    Guid guid
)
Public Function GetAddInItemSettings (
    guid As Guid
) As AddInItemSettings
public:
AddInItemSettings^ GetAddInItemSettings(
    Guid guid
)
member GetAddInItemSettings :
        guid : Guid -> AddInItemSettings

Parameters

guid Guid
The Guid of the Add-in item.

Return Value

AddInItemSettings
Remarks
The returned object can be used to change the settings of the Add-in item. To save changes call Save.
See Also

Reference

AddInsManagerSettings Class
Autodesk.RevitAddInsManager Namespace


AddInsManagerSettings.GetAllAddInItemSettings Method

AddInsManagerSettingsGetAllAddInItemSettings Method

Returns all AddInItemSettings.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<AddInItemSettings> GetAllAddInItemSettings()
Public Function GetAllAddInItemSettings As IList(Of AddInItemSettings)
public:
IList<AddInItemSettings^>^ GetAllAddInItemSettings()
member GetAllAddInItemSettings : unit -> IList<AddInItemSettings>

Return Value

IList AddInItemSettings
Remarks
Returned objects can be used to change the settings of Add-in items. To save changes call Save.
See Also

Reference

AddInsManagerSettings Class
Autodesk.RevitAddInsManager Namespace


AddInsManagerSettings.Save Method

AddInsManagerSettingsSave Method

Saves current AddInsManagerSettings.

Namespace: Autodesk.RevitAddInsManager
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
See Also

Reference

AddInsManagerSettings Class
Autodesk.RevitAddInsManager Namespace