Namespaces
Send Feedback
Structural Analysis and Code Checking API Reference Guide

Namespaces

Namespace | Description
Autodesk.CodeChecking |
Autodesk.CodeChecking.Concrete |
Autodesk.Revit.DB.CodeChecking |
Autodesk.Revit.DB.CodeChecking.Attributes |
Autodesk.Revit.DB.CodeChecking.Documentation |
Autodesk.Revit.DB.CodeChecking.Engineering |
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete |
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete.ConcreteTypes |
Autodesk.Revit.DB.CodeChecking.Engineering.Tools |
Autodesk.Revit.DB.CodeChecking.LoadCombination |
Autodesk.Revit.DB.CodeChecking.Storage |
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination |
Autodesk.Revit.DB.ExtensibleStorage.Framework |
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes |
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation |
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes |
Autodesk.Revit.DB.ResultsBuilder |
Autodesk.Revit.DB.ResultsBuilder.Storage |
Autodesk.Revit.UI.CodeChecking |
Autodesk.Revit.UI.CodeChecking.LoadCombination |
Autodesk.Revit.UI.ExtensibleStorage.Framework |
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes |


Autodesk.CodeChecking Namespace

Autodesk.CodeChecking Namespace
Send Feedback

Classes

 | Class | Description
Public class | Utils | Class include static functions with the simple utilities.


Utils Class

Utils Class
Members See Also Send Feedback
Class include static functions with the simple utilities.

Namespace: Autodesk.CodeChecking
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class Utils

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking..::..Utils

See Also

Utils Members
Autodesk.CodeChecking Namespace


Utils Members

[image]

Structural Analysis and Code Checking API Reference Guide
Utils Members
Utils Class Constructors Methods See Also Send Feedback

The Utils type exposes the following members.

Constructors

 | Name | Description
Public method | Utils | The Utils object constructor

Methods

 | Name | Description
 | ConvexHull |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Utils Class
Autodesk.CodeChecking Namespace


Utils Constructor

Utils Constructor
Utils Class See Also Send Feedback
The Utils object constructor

Namespace: Autodesk.CodeChecking
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Utils()

See Also

Utils Class
Autodesk.CodeChecking Namespace


Utils Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Utils Methods
Utils Class See Also Send Feedback

The Utils type exposes the following members.

Methods

 | Name | Description
 | ConvexHull |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Utils Class
Autodesk.CodeChecking Namespace


ConvexHull Method

Utils..::..ConvexHull Method
Utils Class See Also Send Feedback

Namespace: Autodesk.CodeChecking
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public static List<int> ConvexHull(
    IEnumerable<Point2D> vPoints
)

Parameters

vPoints
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Point2D >)>)>

See Also

Utils Class
Autodesk.CodeChecking Namespace


Autodesk.CodeChecking.Concrete Namespace

Autodesk.CodeChecking.Concrete Namespace
Send Feedback

Classes

 | Class | Description
Public class | Concrete | Represents the class for concrete behaviors definition.
Public class | Geometry | Represents the class for a concrete cross-section geometry definition.
Public class | Point2D | Describes a point in a two dimensional cartesian space.
Public class | RCArgumentException |
Public class | RCException |
Public class | RCExceptionData |
Public class | RCExceptionDataDoubleRecord |
Public class | RCExceptionDataRecord |
Public class | RCExceptionDataStringRecord |
Public class | RCExceptionDataXMLNameRecord |
Public class | RCSolver |
Public class | Rebar | Describes a rebar in the context of Autodesk.CodeChecking.Concrete.
Public class | SetOfForces | Describes the set of internal forces: AxialForce(N), MomentX(Mx) and MomentY(My).
Public class | Steel | Represents the class for steel behaviors definition.

Interfaces

 | Interface | Description
Public interface | IRCException |

Enumerations

 | Enumeration | Description
Public enumeration | Axis | Classification of axis.
Public enumeration | ConcreteExceptionEnum | Classification of exceptions that could be thrown during creation of the concrete parameters.
Public enumeration | ResultType | Classification of the type of results returned by the solver.
Public enumeration | SteelExceptionEnum | Classification of exceptions that could be thrown in time of creation the concrete parameters.
Public enumeration | StressDiagramType | Classification of concrete stress-strain relationships.
Public enumeration | XMLName |


Axis Enumeration

Axis Enumeration
See Also Send Feedback
Classification of axis.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum Axis

Members

Member name | Value | Description
x | 0 | x'-axis.
y | 1 | y'-axis.

Remarks

The internal forces are described in coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.

See Also

Autodesk.CodeChecking.Concrete Namespace


Concrete Class

Concrete Class
Members See Also Send Feedback
Represents the class for concrete behaviors definition.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class Concrete : IRCSolverMember, IDisposable

Remarks

Including parameters of concrete and methods for calculating the stress in concrete for a given strain.
The parameters should be defined in base units for example [m],[N], or [pound],[in].
All set values for concrete, steel, geometry and internal forces should have some consistent units.

Inheritance Hierarchy

System..::..Object
IRCSolverMember
Autodesk.CodeChecking.Concrete..::..Concrete

See Also

Concrete Members
Autodesk.CodeChecking.Concrete Namespace


Concrete Members

[image]

Structural Analysis and Code Checking API Reference Guide
Concrete Members
Concrete Class Constructors Methods Properties See Also Send Feedback

The Concrete type exposes the following members.

Constructors

 | Name | Description
Public method | Concrete | The default Concrete class constructor

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Concrete
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetStrainStressModelBiLinear | Sets all appropriate parameters for a bi-linear stress-strain relationship.
Public method | SetStrainStressModelLinear | Sets all appropriate parameters for a linear stress-strain relationship.
Public method | SetStrainStressModelParabolicRectangular | Sets all appropriate parameters for a parabola-rectangle stress-strain relationship.
Public method | SetStrainStressModelPowerRectangular | Sets all appropriate parameters for a power-rectangle stress-strain relationship.
Public method | SetStrainStressModelRectangular | Sets all appropriate parameters for a simplified model with rectangular stress distribution.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DesignStrength | The DesignStrength property represents the design strenght of concrete.
Public property | EffectiveHeightReductionFactor | The EffectiveHeightReductionFactor property represents the reduction factor of the compression zone height.
Public property | ModulusOfElasticity | The ModulusOfElasticity property represents the concrete modulus of elasticity (Young modulus).
Public property | Power | The Power property represents the power for an power-linar stress-strain relationship.
Public property | StrainRelationChangeOver | The StrainRelationChangeOver property represents the strain which changes the type of stress-strain relationship.
Public property | StrainStressModel | The StrainStressModel property represents the type of stress-strain relationship.
Public property | StrainUltimateLimit | The StrainUltimateLimit property represents the value of maximum strain.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


Concrete Constructor

Concrete Constructor
Concrete Class See Also Send Feedback
The default Concrete class constructor

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Concrete()

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


Concrete Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Concrete Methods
Concrete Class See Also Send Feedback

The Concrete type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetStrainStressModelBiLinear | Sets all appropriate parameters for a bi-linear stress-strain relationship.
Public method | SetStrainStressModelLinear | Sets all appropriate parameters for a linear stress-strain relationship.
Public method | SetStrainStressModelParabolicRectangular | Sets all appropriate parameters for a parabola-rectangle stress-strain relationship.
Public method | SetStrainStressModelPowerRectangular | Sets all appropriate parameters for a power-rectangle stress-strain relationship.
Public method | SetStrainStressModelRectangular | Sets all appropriate parameters for a simplified model with rectangular stress distribution.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


Dispose Method

Concrete..::..Dispose Method
Concrete Class See Also Send Feedback
Releases all resources used by the Concrete

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


SetStrainStressModelBiLinear Method

Concrete..::..SetStrainStressModelBiLinear Method
Concrete Class See Also Send Feedback
Sets all appropriate parameters for a bi-linear stress-strain relationship.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetStrainStressModelBiLinear(
    double designStrength,
    double strainUltimateLimit,
    double modulusOfElasticity,
    double strainRelationChangeOver
)

Parameters

designStrength
Type: System..::..Double
The concrete design strength.
Unit: [force per length^2].
strainUltimateLimit
Type: System..::..Double
The concrete strain at failure.
Unit: [dimensionless].
modulusOfElasticity
Type: System..::..Double
The concrete modulus of elasticity (Young modulus).
Unit: [force per length^2]
strainRelationChangeOver
Type: System..::..Double
The concrete strain value which changes the type of stress-strain relationship.
Unit: [dimensionless].

Remarks

The parameters should be defined in base units for example [m],[N], or [pound],[in].
All set values for concrete, steel, geometry and internal forces should have some consistent units.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


SetStrainStressModelLinear Method

Concrete..::..SetStrainStressModelLinear Method
Concrete Class See Also Send Feedback
Sets all appropriate parameters for a linear stress-strain relationship.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetStrainStressModelLinear(
    double designStrength,
    double strainUltimateLimit,
    double modulusOfElasticity
)

Parameters

designStrength
Type: System..::..Double
The concrete design strength.
Unit: [force per length^2].
strainUltimateLimit
Type: System..::..Double
The concrete strain at failure.
Unit: [dimensionless].
modulusOfElasticity
Type: System..::..Double
The concrete modulus of elasticity (Young modulus).
Unit: [force per length^2]

Remarks

The parameters should be defined in base units for example [m],[N], or [pound],[in].
All set values for concrete, steel, geometry and internal forces should have some consistent units.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


SetStrainStressModelParabolicRectangular Method

Concrete..::..SetStrainStressModelParabolicRectangular Method
Concrete Class See Also Send Feedback
Sets all appropriate parameters for a parabola-rectangle stress-strain relationship.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetStrainStressModelParabolicRectangular(
    double designStrength,
    double strainUltimateLimit,
    double modulusOfElasticity,
    double strainRelationChangeOver
)

Parameters

designStrength
Type: System..::..Double
The concrete design strength.
Unit: [force per length^2].
strainUltimateLimit
Type: System..::..Double
The concrete strain at failure.
Unit: [dimensionless].
modulusOfElasticity
Type: System..::..Double
The concrete modulus of elasticity (Young modulus).
Unit: [force per length^2]
strainRelationChangeOver
Type: System..::..Double
The concrete strain value which changes the type of stress-strain relationship.
Unit: [dimensionless].

Remarks

The parameters should be defined in base units for example [m],[N], or [pound],[in].
All set values for concrete, steel, geometry and internal forces should have some consistent units.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


SetStrainStressModelPowerRectangular Method

Concrete..::..SetStrainStressModelPowerRectangular Method
Concrete Class See Also Send Feedback
Sets all appropriate parameters for a power-rectangle stress-strain relationship.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetStrainStressModelPowerRectangular(
    double designStrength,
    double strainUltimateLimit,
    double modulusOfElasticity,
    double strainRelationChangeOver,
    double power
)

Parameters

designStrength
Type: System..::..Double
The concrete design strength.
Unit: [force per length^2].
strainUltimateLimit
Type: System..::..Double
The concrete strain at failure.
Unit: [dimensionless].
modulusOfElasticity
Type: System..::..Double
The concrete modulus of elasticity (Young modulus).
Unit: [force per length^2]
strainRelationChangeOver
Type: System..::..Double
The concrete strain value which changes the type of stress-strain relationship.
Unit: [dimensionless].
power
Type: System..::..Double
The power for power function of stress-strain (1.0 - strain^power) relationship.
Unit: [dimensionless].

Remarks

The parameters should be defined in base units for example [m],[N], or [pound],[in].
All set values for concrete, steel, geometry and internal forces should have some consistent units.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


SetStrainStressModelRectangular Method

Concrete..::..SetStrainStressModelRectangular Method
Concrete Class See Also Send Feedback
Sets all appropriate parameters for a simplified model with rectangular stress distribution.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetStrainStressModelRectangular(
    double designStrength,
    double strainUltimateLimit,
    double modulusOfElasticity,
    double effectiveHeightReductionFactor
)

Parameters

designStrength
Type: System..::..Double
The concrete design strength.
Unit: [force per length^2].
strainUltimateLimit
Type: System..::..Double
The concrete strain at failure.
Unit: [dimensionless].
modulusOfElasticity
Type: System..::..Double
The concrete modulus of elasticity (Young modulus).
Unit: [force per length^2]
effectiveHeightReductionFactor
Type: System..::..Double
The reduction factor of the compression zone height.
Unit: [dimensionless].

Remarks

The parameters should be defined in base units for example [m],[N], or [pound],[in].
All set values for concrete, steel, geometry and internal forces should have some consistent units.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


Concrete Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Concrete Properties
Concrete Class See Also Send Feedback

The Concrete type exposes the following members.

Properties

 | Name | Description
Public property | DesignStrength | The DesignStrength property represents the design strenght of concrete.
Public property | EffectiveHeightReductionFactor | The EffectiveHeightReductionFactor property represents the reduction factor of the compression zone height.
Public property | ModulusOfElasticity | The ModulusOfElasticity property represents the concrete modulus of elasticity (Young modulus).
Public property | Power | The Power property represents the power for an power-linar stress-strain relationship.
Public property | StrainRelationChangeOver | The StrainRelationChangeOver property represents the strain which changes the type of stress-strain relationship.
Public property | StrainStressModel | The StrainStressModel property represents the type of stress-strain relationship.
Public property | StrainUltimateLimit | The StrainUltimateLimit property represents the value of maximum strain.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


DesignStrength Property

Concrete..::..DesignStrength Property
Concrete Class See Also Send Feedback
The DesignStrength property represents the design strenght of concrete.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double DesignStrength { get; set; }

Field Value

Gets or sets concrete design strength

Remarks

Unit: [force per length^2].
Concrete design strength should be in base units for example [Pa] or [psi].
Typical values are in the range between 1000000 and 6000000 [Pa] or 3000 and 10000 [psi].
The return value will be in the same unit which has been used for strength measurement and should be consistent with units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The concrete strength must be greater than 0.0.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


EffectiveHeightReductionFactor Property

Concrete..::..EffectiveHeightReductionFactor Property
Concrete Class See Also Send Feedback
The EffectiveHeightReductionFactor property represents the reduction factor of the compression zone height.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double EffectiveHeightReductionFactor { get; set; }

Field Value

Gets or sets the reduction factor of the compression zone height.

Remarks

Unit: [dimensionless].
This parameter is taken into account only for a simplified model with rectangular stress distribution StressDiagType.Rectangular.
Typical values are in the range between 0.8 and 1.0.

Exceptions

Exception | Condition
System..::..ArgumentException | Reduction factor of the compression zone must be in the range between 0 and 1.0.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


ModulusOfElasticity Property

Concrete..::..ModulusOfElasticity Property
Concrete Class See Also Send Feedback
The ModulusOfElasticity property represents the concrete modulus of elasticity (Young modulus).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double ModulusOfElasticity { get; set; }

Field Value

Gets or sets the value of the concrete modulus of elasticity (Young modulus).

Remarks

Unit: [force per length^2].
Modulus of elasticity (Young modulus) should be in base units for example [Pa] or [psi].
Typical values are in the range between 25000000000 and 40000000000 [Pa] or 3000000 and 5700000 [psi].
This value is used for the calculation of equivalent (transformed) characteristic of the reinforced section.
The return value will be in the same unit which has been used for strength measurement and should be consistent with units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The concrete Young modulus (modulus of elasticity) must be greater than 0.0.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


Power Property

Concrete..::..Power Property
Concrete Class See Also Send Feedback
The Power property represents the power for an power-linar stress-strain relationship.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double Power { get; set; }

Field Value

Gets or sets power for an power-linar stress-strain relationship.

Remarks

Unit: [dimensionless].
Power parameter is taken into account only for power-linar relationship.
Typical values are in the range between 1.4 and 2.0. When power is equal to 2.0, a better approach is to use the parabola-rectangle relationship.

Exceptions

Exception | Condition
System..::..ArgumentException | The poawe should be greater than 1.0.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


StrainRelationChangeOver Property

Concrete..::..StrainRelationChangeOver Property
Concrete Class See Also Send Feedback
The StrainRelationChangeOver property represents the strain which changes the type of stress-strain relationship.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double StrainRelationChangeOver { get; set; }

Field Value

Gets or sets the value of the concrete strain which changes the type of stress-strain relationship.

Remarks

Unit: [dimensionless].
StrainRelationChangeOver parameter is taken into account only for models with more than one stress-strain relationships:
- Linear-rectangle.
- Parabola-rectangle.
- Exponential-rectangle.
Typical values are in the range between 0.00175 and 0.0026. .

Exceptions

Exception | Condition
System..::..ArgumentException | The relationship changeover must be greater than 0.0

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


StrainStressModel Property

Concrete..::..StrainStressModel Property
Concrete Class See Also Send Feedback
The StrainStressModel property represents the type of stress-strain relationship.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public StressDiagramType StrainStressModel { get; set; }

Field Value

Gets or sets the type of stress-strain relationship.

Remarks

Available stress-strain relationship are described by the StressDiagType enumeration.
For ULS, most common used relationships are rectangular and parabolic.
For SLS, most common used relationship is linear.
All the parameters required by the choosen relationship should be set using dedicated methods:
SetStrainStressModelRectangular
SetStrainStressModelLinear
SetStrainStressModelParabolicRectangular
SetStrainStressModelBiLinear

Exceptions

Exception | Condition
System..::..ArgumentException | Unsupported stress-strain relationship.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


StrainUltimateLimit Property

Concrete..::..StrainUltimateLimit Property
Concrete Class See Also Send Feedback
The StrainUltimateLimit property represents the value of maximum strain.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double StrainUltimateLimit { get; set; }

Field Value

Gets or sets the value of the concrete strain at failure. Unit: [dimensionless].

Remarks

StrainUltimateLimit parameter is taken into account for all models. Typical values are in the range between 0.0028 and 0.0035.

Exceptions

Exception | Condition
System..::..ArgumentException | The concrete strain at failure must be greater than 0.0.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace


ConcreteExceptionEnum Enumeration

ConcreteExceptionEnum Enumeration
See Also Send Feedback
Classification of exceptions that could be thrown during creation of the concrete parameters.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum ConcreteExceptionEnum

Members

Member name | Value | Description
DesignStrength | 0 | The concrete design strength must be greater than 0.0.
StrainUltimateLimit | 1 | The concrete strain at failure must be greater than 0.0.
ModulusOfElasticity | 2 | The concrete Young modulus (modulus of elasticity) must greater than 0.0.
StressDiagType | 3 | Unsupported stress-strain relationship.
Power | 4 | The power should be greater than 1.0.
StrainRelationChangeOver | 5 | The relationship changeover must be less than the ultimate strain
EffectiveHeightReductionFactor | 6 | The reduction factor of the compression zone height must be in the range between 0 and 1.0.

See Also

Autodesk.CodeChecking.Concrete Namespace


Geometry Class

Geometry Class
Members See Also Send Feedback
Represents the class for a concrete cross-section geometry definition.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class Geometry : IRCSolverMember, IEnumerable,
    IDisposable

Remarks

Including the description of the geometrical contour (section shape) and properties.
The geometrical contour is based on points in a 2D space (Point2D).
Contour must be defined in the same coordinate system as rebars.

Inheritance Hierarchy

System..::..Object
IRCSolverMember
Autodesk.CodeChecking.Concrete..::..Geometry

See Also

Geometry Members
Autodesk.CodeChecking.Concrete Namespace


Geometry Members

[image]

Structural Analysis and Code Checking API Reference Guide
Geometry Members
Geometry Class Constructors Methods Properties See Also Send Feedback

The Geometry type exposes the following members.

Constructors

 | Name | Description
Public method | Geometry()()()() | The default Geometry class constructor
Public method | Geometry(Double) | The class constructor for a circular cross section.
Public method | Geometry(Double, Double) | The class constructor for a rectangular cross section.
Public method | Geometry(Double, Double, Double, Double) | The class constructor for a T cross section.

Methods

 | Name | Description
Public method | Add | Adds a new point into the concrete cross section contour collection of points.
Public method | Clear | Remove all points from the concrete cross section contour collection of points.
Public method | Dispose | Releases all resources used by the Geometry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | IEnumerable standard implementation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | isClockwiseOrientation | Check if the contour has a clockwise orientation.
Public method | Point | Gets a specific point from the concrete cross section contour collection of points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | Gets the value of contour area.
Public property | CenterOfInertia | Gets coordinates of the center of inertia of the concrete cross section.
Public property | Count | Gets the number of points describing the concrete cross section contour.
Public property | MomentOfInertiaX | Gets the value of the moment of inertia of the concrete cross section.
Public property | MomentOfInertiaY | Gets the value of the moment of inertia of the concrete cross section.
Public property | Perimeter | Gets the value of contour perimeter.

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


Geometry Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
Geometry Constructor
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Geometry()()()() | The default Geometry class constructor
Public method | Geometry(Double) | The class constructor for a circular cross section.
Public method | Geometry(Double, Double) | The class constructor for a rectangular cross section.
Public method | Geometry(Double, Double, Double, Double) | The class constructor for a T cross section.

See Also

Geometry Class
Geometry Members
Autodesk.CodeChecking.Concrete Namespace


Geometry Constructor

Geometry Constructor
Geometry Class See Also Send Feedback
The default Geometry class constructor

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Geometry()

Remarks

This constructor could used to define a concrete cross section based on contour

See Also

Geometry Class
Geometry Overload
Autodesk.CodeChecking.Concrete Namespace


Geometry Constructor (Double)

Geometry Constructor (Double)
Geometry Class See Also Send Feedback
The class constructor for a circular cross section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Geometry(
    double diameter
)

Parameters

diameter
Type: System..::..Double
The diameter of the circle.
Unit: [length].

Remarks

Internal representation of the circular cross-section is regular a 18-gon (octadecagon).
The area of the polygon is equal to circle (Pi()*diameter^2)/4.
The center of the circle is in the center of coordinate system x=0, y=0 and the contour has a counterclockwise orientation.

See Also

Geometry Class
Geometry Overload
Autodesk.CodeChecking.Concrete Namespace


Geometry Constructor (Double, Double)

Geometry Constructor (Double, Double)
Geometry Class See Also Send Feedback
The class constructor for a rectangular cross section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Geometry(
    double height,
    double width
)

Parameters

height
Type: System..::..Double
The height of the rectangular cross-section.
Unit: [length].
width
Type: System..::..Double
The width of the rectangular cross-section.
Unit: [length].

Remarks

The bottom left corner is in the center of coordinate system x=0, y=0 and the contour has a counterclockwise orientation.

See Also

Geometry Class
Geometry Overload
Autodesk.CodeChecking.Concrete Namespace


Geometry Constructor (Double, Double, Double, Double)

Geometry Constructor (Double, Double, Double, Double)
Geometry Class See Also Send Feedback
The class constructor for a T cross section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Geometry(
    double heightTotal,
    double heightFlange,
    double widthBottom,
    double widthTop
)

Parameters

heightTotal
Type: System..::..Double
The total height of the cross-section.
Unit: [length].
heightFlange
Type: System..::..Double
The height of the flange (flange thickness).
Unit: [length].
widthBottom
Type: System..::..Double
The width of the web (web thickness).
Unit: [length].
widthTop
Type: System..::..Double
The width of the flange (top of the section).
Unit: [length].

Remarks

The bottom left corner is in the center of coordinate system x=0, y=0 and the contour has a counterclockwise orientation.

See Also

Geometry Class
Geometry Overload
Autodesk.CodeChecking.Concrete Namespace


Geometry Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Geometry Methods
Geometry Class See Also Send Feedback

The Geometry type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a new point into the concrete cross section contour collection of points.
Public method | Clear | Remove all points from the concrete cross section contour collection of points.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | IEnumerable standard implementation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | isClockwiseOrientation | Check if the contour has a clockwise orientation.
Public method | Point | Gets a specific point from the concrete cross section contour collection of points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


Add Method

Geometry..::..Add Method
Geometry Class See Also Send Feedback
Adds a new point into the concrete cross section contour collection of points.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void Add(
    double x,
    double y
)

Parameters

x
Type: System..::..Double
The x-coordinate of the contour point Point2D.
Unit: [length].
y
Type: System..::..Double
The y-coordinate of the contour point Point2D.
Unit: [length].

Remarks

Points should be described in base units for example [m] or [in] and in the same coordinate system as rebars.

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


Clear Method

Geometry..::..Clear Method
Geometry Class See Also Send Feedback
Remove all points from the concrete cross section contour collection of points.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void Clear()

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


Dispose Method

Geometry..::..Dispose Method
Geometry Class See Also Send Feedback
Releases all resources used by the Geometry

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


GetEnumerator Method

Geometry..::..GetEnumerator Method
Geometry Class See Also Send Feedback
IEnumerable standard implementation.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()

Return Value

Return standard enumerator for geometry points collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


isClockwiseOrientation Method

Geometry..::..isClockwiseOrientation Method
Geometry Class See Also Send Feedback
Check if the contour has a clockwise orientation.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public bool isClockwiseOrientation()

Return Value

Return true if the contour has a clockwise orientation.

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


Point Method

Geometry..::..Point Method
Geometry Class See Also Send Feedback
Gets a specific point from the concrete cross section contour collection of points.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Point2D Point(
    int index
)

Parameters

index
Type: System..::..Int32
Index of a point in the contour points collection.

Return Value

Returns given point as Point2D.

Exceptions

Exception | Condition
System..::..ArgumentException | Index must be less than Count

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


Geometry Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Geometry Properties
Geometry Class See Also Send Feedback

The Geometry type exposes the following members.

Properties

 | Name | Description
Public property | Area | Gets the value of contour area.
Public property | CenterOfInertia | Gets coordinates of the center of inertia of the concrete cross section.
Public property | Count | Gets the number of points describing the concrete cross section contour.
Public property | MomentOfInertiaX | Gets the value of the moment of inertia of the concrete cross section.
Public property | MomentOfInertiaY | Gets the value of the moment of inertia of the concrete cross section.
Public property | Perimeter | Gets the value of contour perimeter.

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


Area Property

Geometry..::..Area Property
Geometry Class See Also Send Feedback
Gets the value of contour area.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double Area { get; }

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


CenterOfInertia Property

Geometry..::..CenterOfInertia Property
Geometry Class See Also Send Feedback
Gets coordinates of the center of inertia of the concrete cross section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Point2D CenterOfInertia { get; }

Return Value

Returns the center of inertia as a Point2D.

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


Count Property

Geometry..::..Count Property
Geometry Class See Also Send Feedback
Gets the number of points describing the concrete cross section contour.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public int Count { get; }

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


MomentOfInertiaX Property

Geometry..::..MomentOfInertiaX Property
Geometry Class See Also Send Feedback
Gets the value of the moment of inertia of the concrete cross section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double MomentOfInertiaX { get; }

Remarks

The x' axis is parallel to the x axis in which the geometry and rebars have been defined.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


MomentOfInertiaY Property

Geometry..::..MomentOfInertiaY Property
Geometry Class See Also Send Feedback
Gets the value of the moment of inertia of the concrete cross section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double MomentOfInertiaY { get; }

Remarks

The y' axis is parallel to the y axis in which the geometry and rebars have been defined.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


Perimeter Property

Geometry..::..Perimeter Property
Geometry Class See Also Send Feedback
Gets the value of contour perimeter.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double Perimeter { get; }

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace


IRCException Interface

IRCException Interface
Members See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public interface IRCException

See Also

IRCException Members
Autodesk.CodeChecking.Concrete Namespace


IRCException Members

[image]

Structural Analysis and Code Checking API Reference Guide
IRCException Members
IRCException Interface Methods Properties See Also Send Feedback

The IRCException type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |

Properties

 | Name | Description
Public property | MethodName |
Public property | RCDataRecords |
Public property | RCSolver |

See Also

IRCException Interface
Autodesk.CodeChecking.Concrete Namespace


IRCException Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IRCException Methods
IRCException Interface See Also Send Feedback

Methods

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |

See Also

IRCException Interface
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method

[image]

Structural Analysis and Code Checking API Reference Guide
IRCException..::..AddRecord Method
IRCException Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |

See Also

IRCException Interface
IRCException Members
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, Enum)

IRCException..::..AddRecord Method (Enum, Enum)
IRCException Interface See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
void AddRecord(
    Enum text,
    Enum value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..Enum

See Also

IRCException Interface
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, Double)

IRCException..::..AddRecord Method (Enum, Double)
IRCException Interface See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
void AddRecord(
    Enum text,
    double value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..Double

See Also

IRCException Interface
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, String)

IRCException..::..AddRecord Method (Enum, String)
IRCException Interface See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
void AddRecord(
    Enum text,
    string value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..String

See Also

IRCException Interface
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


IRCException Properties

[image]

Structural Analysis and Code Checking API Reference Guide
IRCException Properties
IRCException Interface See Also Send Feedback

The IRCException type exposes the following members.

Properties

 | Name | Description
Public property | MethodName |
Public property | RCDataRecords |
Public property | RCSolver |

See Also

IRCException Interface
Autodesk.CodeChecking.Concrete Namespace


MethodName Property

IRCException..::..MethodName Property
IRCException Interface See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
Enum MethodName { get; set; }

See Also

IRCException Interface
Autodesk.CodeChecking.Concrete Namespace


RCDataRecords Property

IRCException..::..RCDataRecords Property
IRCException Interface See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
List<RCExceptionDataRecord> RCDataRecords { get; set; }

See Also

IRCException Interface
Autodesk.CodeChecking.Concrete Namespace


RCSolver Property

IRCException..::..RCSolver Property
IRCException Interface See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
Object RCSolver { get; set; }

See Also

IRCException Interface
Autodesk.CodeChecking.Concrete Namespace


Point2D Class

Point2D Class
Members See Also Send Feedback
Describes a point in a two dimensional cartesian space.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class Point2D

Remarks

In the Autodesk.CodeChecking.Concrete, the two dimensional space is related to a cross-section.
The X and Y axes of the righ-hand oriented coordinate system with axis Z perpendicular to the cross-section.
All objects (geometry, rebars, internal forces) must be described in the same coordinate system.

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking.Concrete..::..Point2D

See Also

Point2D Members
Autodesk.CodeChecking.Concrete Namespace


Point2D Members

[image]

Structural Analysis and Code Checking API Reference Guide
Point2D Members
Point2D Class Constructors Methods Properties See Also Send Feedback

The Point2D type exposes the following members.

Constructors

 | Name | Description
Public method | Point2D | The class constructor for a Point2D. Creates a point with in x, y.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | X | The X property represents the x-coordinate of the point.
Public property | Y | The Y property represents the y-coordinate of the point.

See Also

Point2D Class
Autodesk.CodeChecking.Concrete Namespace


Point2D Constructor

Point2D Constructor
Point2D Class See Also Send Feedback
The class constructor for a Point2D. Creates a point with in x, y.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Point2D(
    double x,
    double y
)

Parameters

x
Type: System..::..Double
The x-coordinate of the point.
Unit: [length].
y
Type: System..::..Double
The y-coordinate of the point.
Unit: [length].

See Also

Point2D Class
Autodesk.CodeChecking.Concrete Namespace


Point2D Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Point2D Methods
Point2D Class See Also Send Feedback

The Point2D type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Point2D Class
Autodesk.CodeChecking.Concrete Namespace


Point2D Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Point2D Properties
Point2D Class See Also Send Feedback

The Point2D type exposes the following members.

Properties

 | Name | Description
Public property | X | The X property represents the x-coordinate of the point.
Public property | Y | The Y property represents the y-coordinate of the point.

See Also

Point2D Class
Autodesk.CodeChecking.Concrete Namespace


X Property

Point2D..::..X Property
Point2D Class See Also Send Feedback
The X property represents the x-coordinate of the point.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double X { get; set; }

Field Value

Gets or sets the x-coordinate of the point.

Remarks

Unit: [length].

See Also

Point2D Class
Autodesk.CodeChecking.Concrete Namespace


Y Property

Point2D..::..Y Property
Point2D Class See Also Send Feedback
The Y property represents the y-coordinate of the point.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double Y { get; set; }

Field Value

Gets or sets the y-coordinate of the point.

Remarks

Unit: [length].

See Also

Point2D Class
Autodesk.CodeChecking.Concrete Namespace


RCArgumentException Class

RCArgumentException Class
Members See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class RCArgumentException : ArgumentException,
    IRCException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
System..::..ArgumentException
Autodesk.CodeChecking.Concrete..::..RCArgumentException

See Also

RCArgumentException Members
Autodesk.CodeChecking.Concrete Namespace


RCArgumentException Members

[image]

Structural Analysis and Code Checking API Reference Guide
RCArgumentException Members
RCArgumentException Class Constructors Methods Properties See Also Send Feedback

The RCArgumentException type exposes the following members.

Constructors

 | Name | Description
Public method | RCArgumentException(Object) | Initializes a new instance of the RCArgumentException class
Public method | RCArgumentException(Object, String) | Initializes a new instance of the RCArgumentException class
Public method | RCArgumentException(Object, String, String) | Initializes a new instance of the RCArgumentException class
Public method | RCArgumentException(Object, String, String, Exception) | Initializes a new instance of the RCArgumentException class

Methods

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from ArgumentException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | MethodName |
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | RCDataRecords |
Public property | RCSolver |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RCArgumentException Class
Autodesk.CodeChecking.Concrete Namespace


RCArgumentException Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
RCArgumentException Constructor
RCArgumentException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RCArgumentException(Object) | Initializes a new instance of the RCArgumentException class
Public method | RCArgumentException(Object, String) | Initializes a new instance of the RCArgumentException class
Public method | RCArgumentException(Object, String, String) | Initializes a new instance of the RCArgumentException class
Public method | RCArgumentException(Object, String, String, Exception) | Initializes a new instance of the RCArgumentException class

See Also

RCArgumentException Class
RCArgumentException Members
Autodesk.CodeChecking.Concrete Namespace


RCArgumentException Constructor (Object)

RCArgumentException Constructor (Object)
RCArgumentException Class See Also Send Feedback
Initializes a new instance of the RCArgumentException class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCArgumentException(
    Object rcSolver
)

Parameters

rcSolver
Type: System..::..Object

See Also

RCArgumentException Class
RCArgumentException Overload
Autodesk.CodeChecking.Concrete Namespace


RCArgumentException Constructor (Object, String)

RCArgumentException Constructor (Object, String)
RCArgumentException Class See Also Send Feedback
Initializes a new instance of the RCArgumentException class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCArgumentException(
    Object rcSolver,
    string message
)

Parameters

rcSolver
Type: System..::..Object
message
Type: System..::..String

See Also

RCArgumentException Class
RCArgumentException Overload
Autodesk.CodeChecking.Concrete Namespace


RCArgumentException Constructor (Object, String, String)

RCArgumentException Constructor (Object, String, String)
RCArgumentException Class See Also Send Feedback
Initializes a new instance of the RCArgumentException class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCArgumentException(
    Object rcSolver,
    string message,
    string paramName
)

Parameters

rcSolver
Type: System..::..Object
message
Type: System..::..String
paramName
Type: System..::..String

See Also

RCArgumentException Class
RCArgumentException Overload
Autodesk.CodeChecking.Concrete Namespace


RCArgumentException Constructor (Object, String, String, Exception)

RCArgumentException Constructor (Object, String, String, Exception)
RCArgumentException Class See Also Send Feedback
Initializes a new instance of the RCArgumentException class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCArgumentException(
    Object rcSolver,
    string message,
    string paramName,
    Exception exception
)

Parameters

rcSolver
Type: System..::..Object
message
Type: System..::..String
paramName
Type: System..::..String
exception
Type: System..::..Exception

See Also

RCArgumentException Class
RCArgumentException Overload
Autodesk.CodeChecking.Concrete Namespace


RCArgumentException Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RCArgumentException Methods
RCArgumentException Class See Also Send Feedback

The RCArgumentException type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from ArgumentException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RCArgumentException Class
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method

[image]

Structural Analysis and Code Checking API Reference Guide
RCArgumentException..::..AddRecord Method
RCArgumentException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |

See Also

RCArgumentException Class
RCArgumentException Members
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, Enum)

RCArgumentException..::..AddRecord Method (Enum, Enum)
RCArgumentException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual void AddRecord(
    Enum text,
    Enum value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..Enum

Implements

IRCException..::..AddRecord(Enum, Enum)

See Also

RCArgumentException Class
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, Double)

RCArgumentException..::..AddRecord Method (Enum, Double)
RCArgumentException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual void AddRecord(
    Enum text,
    double value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..Double

Implements

IRCException..::..AddRecord(Enum, Double)

See Also

RCArgumentException Class
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, String)

RCArgumentException..::..AddRecord Method (Enum, String)
RCArgumentException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual void AddRecord(
    Enum text,
    string value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..String

Implements

IRCException..::..AddRecord(Enum, String)

See Also

RCArgumentException Class
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCArgumentException Properties

[image]

Structural Analysis and Code Checking API Reference Guide
RCArgumentException Properties
RCArgumentException Class See Also Send Feedback

The RCArgumentException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | MethodName |
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | RCDataRecords |
Public property | RCSolver |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RCArgumentException Class
Autodesk.CodeChecking.Concrete Namespace


MethodName Property

RCArgumentException..::..MethodName Property
RCArgumentException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual Enum MethodName { get; set; }

Implements

IRCException..::..MethodName

See Also

RCArgumentException Class
Autodesk.CodeChecking.Concrete Namespace


RCDataRecords Property

RCArgumentException..::..RCDataRecords Property
RCArgumentException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual List<RCExceptionDataRecord> RCDataRecords { get; set; }

Implements

IRCException..::..RCDataRecords

See Also

RCArgumentException Class
Autodesk.CodeChecking.Concrete Namespace


RCSolver Property

RCArgumentException..::..RCSolver Property
RCArgumentException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual Object RCSolver { get; set; }

Implements

IRCException..::..RCSolver

See Also

RCArgumentException Class
Autodesk.CodeChecking.Concrete Namespace


RCException Class

RCException Class
Members See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class RCException : Exception,
    IRCException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.CodeChecking.Concrete..::..RCException

See Also

RCException Members
Autodesk.CodeChecking.Concrete Namespace


RCException Members

[image]

Structural Analysis and Code Checking API Reference Guide
RCException Members
RCException Class Constructors Methods Properties See Also Send Feedback

The RCException type exposes the following members.

Constructors

 | Name | Description
Public method | RCException(Object) | Initializes a new instance of the RCException class
Public method | RCException(Object, String) | Initializes a new instance of the RCException class
Public method | RCException(Object, String, Exception) | Initializes a new instance of the RCException class

Methods

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | MethodName |
Public property | RCDataRecords |
Public property | RCSolver |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RCException Class
Autodesk.CodeChecking.Concrete Namespace


RCException Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
RCException Constructor
RCException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RCException(Object) | Initializes a new instance of the RCException class
Public method | RCException(Object, String) | Initializes a new instance of the RCException class
Public method | RCException(Object, String, Exception) | Initializes a new instance of the RCException class

See Also

RCException Class
RCException Members
Autodesk.CodeChecking.Concrete Namespace


RCException Constructor (Object)

RCException Constructor (Object)
RCException Class See Also Send Feedback
Initializes a new instance of the RCException class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCException(
    Object rcSolver
)

Parameters

rcSolver
Type: System..::..Object

See Also

RCException Class
RCException Overload
Autodesk.CodeChecking.Concrete Namespace


RCException Constructor (Object, String)

RCException Constructor (Object, String)
RCException Class See Also Send Feedback
Initializes a new instance of the RCException class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCException(
    Object rcSolver,
    string message
)

Parameters

rcSolver
Type: System..::..Object
message
Type: System..::..String

See Also

RCException Class
RCException Overload
Autodesk.CodeChecking.Concrete Namespace


RCException Constructor (Object, String, Exception)

RCException Constructor (Object, String, Exception)
RCException Class See Also Send Feedback
Initializes a new instance of the RCException class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCException(
    Object rcSolver,
    string message,
    Exception exception
)

Parameters

rcSolver
Type: System..::..Object
message
Type: System..::..String
exception
Type: System..::..Exception

See Also

RCException Class
RCException Overload
Autodesk.CodeChecking.Concrete Namespace


RCException Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RCException Methods
RCException Class See Also Send Feedback

The RCException type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RCException Class
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method

[image]

Structural Analysis and Code Checking API Reference Guide
RCException..::..AddRecord Method
RCException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |

See Also

RCException Class
RCException Members
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, Enum)

RCException..::..AddRecord Method (Enum, Enum)
RCException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual void AddRecord(
    Enum text,
    Enum value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..Enum

Implements

IRCException..::..AddRecord(Enum, Enum)

See Also

RCException Class
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, Double)

RCException..::..AddRecord Method (Enum, Double)
RCException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual void AddRecord(
    Enum text,
    double value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..Double

Implements

IRCException..::..AddRecord(Enum, Double)

See Also

RCException Class
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, String)

RCException..::..AddRecord Method (Enum, String)
RCException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual void AddRecord(
    Enum text,
    string value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..String

Implements

IRCException..::..AddRecord(Enum, String)

See Also

RCException Class
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCException Properties

[image]

Structural Analysis and Code Checking API Reference Guide
RCException Properties
RCException Class See Also Send Feedback

The RCException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | MethodName |
Public property | RCDataRecords |
Public property | RCSolver |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RCException Class
Autodesk.CodeChecking.Concrete Namespace


MethodName Property

RCException..::..MethodName Property
RCException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual Enum MethodName { get; set; }

Implements

IRCException..::..MethodName

See Also

RCException Class
Autodesk.CodeChecking.Concrete Namespace


RCDataRecords Property

RCException..::..RCDataRecords Property
RCException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual List<RCExceptionDataRecord> RCDataRecords { get; set; }

Implements

IRCException..::..RCDataRecords

See Also

RCException Class
Autodesk.CodeChecking.Concrete Namespace


RCSolver Property

RCException..::..RCSolver Property
RCException Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public virtual Object RCSolver { get; set; }

Implements

IRCException..::..RCSolver

See Also

RCException Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionData Class

RCExceptionData Class
Members See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class RCExceptionData

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking.Concrete..::..RCExceptionData

See Also

RCExceptionData Members
Autodesk.CodeChecking.Concrete Namespace


RCExceptionData Members

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionData Members
RCExceptionData Class Constructors Methods Properties See Also Send Feedback

The RCExceptionData type exposes the following members.

Constructors

 | Name | Description
Public method | RCExceptionData | Initializes a new instance of the RCExceptionData class

Methods

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Records |

See Also

RCExceptionData Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionData Constructor

RCExceptionData Constructor
RCExceptionData Class See Also Send Feedback
Initializes a new instance of the RCExceptionData class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCExceptionData()

See Also

RCExceptionData Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionData Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionData Methods
RCExceptionData Class See Also Send Feedback

The RCExceptionData type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RCExceptionData Class
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionData..::..AddRecord Method
RCExceptionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |

See Also

RCExceptionData Class
RCExceptionData Members
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, Enum)

RCExceptionData..::..AddRecord Method (Enum, Enum)
RCExceptionData Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void AddRecord(
    Enum text,
    Enum value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..Enum

See Also

RCExceptionData Class
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, Double)

RCExceptionData..::..AddRecord Method (Enum, Double)
RCExceptionData Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void AddRecord(
    Enum text,
    double value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..Double

See Also

RCExceptionData Class
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


AddRecord Method (Enum, String)

RCExceptionData..::..AddRecord Method (Enum, String)
RCExceptionData Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void AddRecord(
    Enum text,
    string value
)

Parameters

text
Type: System..::..Enum
value
Type: System..::..String

See Also

RCExceptionData Class
AddRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCExceptionData Properties

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionData Properties
RCExceptionData Class See Also Send Feedback

The RCExceptionData type exposes the following members.

Properties

 | Name | Description
Public property | Records |

See Also

RCExceptionData Class
Autodesk.CodeChecking.Concrete Namespace


Records Property

RCExceptionData..::..Records Property
RCExceptionData Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public List<RCExceptionDataRecord> Records { get; set; }

See Also

RCExceptionData Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataDoubleRecord Class

RCExceptionDataDoubleRecord Class
Members See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class RCExceptionDataDoubleRecord : RCExceptionDataRecord

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking.Concrete..::..RCExceptionDataRecord
Autodesk.CodeChecking.Concrete..::..RCExceptionDataDoubleRecord

See Also

RCExceptionDataDoubleRecord Members
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataDoubleRecord Members

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataDoubleRecord Members
RCExceptionDataDoubleRecord Class Constructors Methods Properties See Also Send Feedback

The RCExceptionDataDoubleRecord type exposes the following members.

Constructors

 | Name | Description
Public method | RCExceptionDataDoubleRecord()()()() | Initializes a new instance of the RCExceptionDataDoubleRecord class
Public method | RCExceptionDataDoubleRecord(Enum, Double) | Initializes a new instance of the RCExceptionDataDoubleRecord class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | (Inherited from RCExceptionDataRecord.)
Public property | Value |
Public property | ValueString | (Overrides RCExceptionDataRecord..::..ValueString.)

See Also

RCExceptionDataDoubleRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataDoubleRecord Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataDoubleRecord Constructor
RCExceptionDataDoubleRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RCExceptionDataDoubleRecord()()()() | Initializes a new instance of the RCExceptionDataDoubleRecord class
Public method | RCExceptionDataDoubleRecord(Enum, Double) | Initializes a new instance of the RCExceptionDataDoubleRecord class

See Also

RCExceptionDataDoubleRecord Class
RCExceptionDataDoubleRecord Members
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataDoubleRecord Constructor

RCExceptionDataDoubleRecord Constructor
RCExceptionDataDoubleRecord Class See Also Send Feedback
Initializes a new instance of the RCExceptionDataDoubleRecord class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCExceptionDataDoubleRecord()

See Also

RCExceptionDataDoubleRecord Class
RCExceptionDataDoubleRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataDoubleRecord Constructor (Enum, Double)

RCExceptionDataDoubleRecord Constructor (Enum, Double)
RCExceptionDataDoubleRecord Class See Also Send Feedback
Initializes a new instance of the RCExceptionDataDoubleRecord class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCExceptionDataDoubleRecord(
    Enum name,
    double value
)

Parameters

name
Type: System..::..Enum
value
Type: System..::..Double

See Also

RCExceptionDataDoubleRecord Class
RCExceptionDataDoubleRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataDoubleRecord Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataDoubleRecord Methods
RCExceptionDataDoubleRecord Class See Also Send Feedback

The RCExceptionDataDoubleRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RCExceptionDataDoubleRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataDoubleRecord Properties

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataDoubleRecord Properties
RCExceptionDataDoubleRecord Class See Also Send Feedback

The RCExceptionDataDoubleRecord type exposes the following members.

Properties

 | Name | Description
Public property | Name | (Inherited from RCExceptionDataRecord.)
Public property | Value |
Public property | ValueString | (Overrides RCExceptionDataRecord..::..ValueString.)

See Also

RCExceptionDataDoubleRecord Class
Autodesk.CodeChecking.Concrete Namespace


Value Property

RCExceptionDataDoubleRecord..::..Value Property
RCExceptionDataDoubleRecord Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double Value { get; set; }

See Also

RCExceptionDataDoubleRecord Class
Autodesk.CodeChecking.Concrete Namespace


ValueString Property

RCExceptionDataDoubleRecord..::..ValueString Property
RCExceptionDataDoubleRecord Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public override string ValueString { get; }

See Also

RCExceptionDataDoubleRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataRecord Class

RCExceptionDataRecord Class
Members See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public abstract class RCExceptionDataRecord

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking.Concrete..::..RCExceptionDataRecord
Autodesk.CodeChecking.Concrete..::..RCExceptionDataDoubleRecord
Autodesk.CodeChecking.Concrete..::..RCExceptionDataStringRecord
Autodesk.CodeChecking.Concrete..::..RCExceptionDataXMLNameRecord

See Also

RCExceptionDataRecord Members
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataRecord Members

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataRecord Members
RCExceptionDataRecord Class Constructors Methods Properties See Also Send Feedback

The RCExceptionDataRecord type exposes the following members.

Constructors

 | Name | Description
Public method | RCExceptionDataRecord()()()() | Initializes a new instance of the RCExceptionDataRecord class
Public method | RCExceptionDataRecord(Enum) | Initializes a new instance of the RCExceptionDataRecord class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name |
Public property | ValueString |

See Also

RCExceptionDataRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataRecord Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataRecord Constructor
RCExceptionDataRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RCExceptionDataRecord()()()() | Initializes a new instance of the RCExceptionDataRecord class
Public method | RCExceptionDataRecord(Enum) | Initializes a new instance of the RCExceptionDataRecord class

See Also

RCExceptionDataRecord Class
RCExceptionDataRecord Members
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataRecord Constructor

RCExceptionDataRecord Constructor
RCExceptionDataRecord Class See Also Send Feedback
Initializes a new instance of the RCExceptionDataRecord class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCExceptionDataRecord()

See Also

RCExceptionDataRecord Class
RCExceptionDataRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataRecord Constructor (Enum)

RCExceptionDataRecord Constructor (Enum)
RCExceptionDataRecord Class See Also Send Feedback
Initializes a new instance of the RCExceptionDataRecord class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCExceptionDataRecord(
    Enum name
)

Parameters

name
Type: System..::..Enum

See Also

RCExceptionDataRecord Class
RCExceptionDataRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataRecord Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataRecord Methods
RCExceptionDataRecord Class See Also Send Feedback

The RCExceptionDataRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RCExceptionDataRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataRecord Properties

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataRecord Properties
RCExceptionDataRecord Class See Also Send Feedback

The RCExceptionDataRecord type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | ValueString |

See Also

RCExceptionDataRecord Class
Autodesk.CodeChecking.Concrete Namespace


Name Property

RCExceptionDataRecord..::..Name Property
RCExceptionDataRecord Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Enum Name { get; set; }

See Also

RCExceptionDataRecord Class
Autodesk.CodeChecking.Concrete Namespace


ValueString Property

RCExceptionDataRecord..::..ValueString Property
RCExceptionDataRecord Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public abstract string ValueString { get; }

See Also

RCExceptionDataRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataStringRecord Class

RCExceptionDataStringRecord Class
Members See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class RCExceptionDataStringRecord : RCExceptionDataRecord

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking.Concrete..::..RCExceptionDataRecord
Autodesk.CodeChecking.Concrete..::..RCExceptionDataStringRecord

See Also

RCExceptionDataStringRecord Members
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataStringRecord Members

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataStringRecord Members
RCExceptionDataStringRecord Class Constructors Methods Properties See Also Send Feedback

The RCExceptionDataStringRecord type exposes the following members.

Constructors

 | Name | Description
Public method | RCExceptionDataStringRecord()()()() | Initializes a new instance of the RCExceptionDataStringRecord class
Public method | RCExceptionDataStringRecord(Enum, String) | Initializes a new instance of the RCExceptionDataStringRecord class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | (Inherited from RCExceptionDataRecord.)
Public property | Value |
Public property | ValueString | (Overrides RCExceptionDataRecord..::..ValueString.)

See Also

RCExceptionDataStringRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataStringRecord Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataStringRecord Constructor
RCExceptionDataStringRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RCExceptionDataStringRecord()()()() | Initializes a new instance of the RCExceptionDataStringRecord class
Public method | RCExceptionDataStringRecord(Enum, String) | Initializes a new instance of the RCExceptionDataStringRecord class

See Also

RCExceptionDataStringRecord Class
RCExceptionDataStringRecord Members
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataStringRecord Constructor

RCExceptionDataStringRecord Constructor
RCExceptionDataStringRecord Class See Also Send Feedback
Initializes a new instance of the RCExceptionDataStringRecord class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCExceptionDataStringRecord()

See Also

RCExceptionDataStringRecord Class
RCExceptionDataStringRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataStringRecord Constructor (Enum, String)

RCExceptionDataStringRecord Constructor (Enum, String)
RCExceptionDataStringRecord Class See Also Send Feedback
Initializes a new instance of the RCExceptionDataStringRecord class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCExceptionDataStringRecord(
    Enum name,
    string value
)

Parameters

name
Type: System..::..Enum
value
Type: System..::..String

See Also

RCExceptionDataStringRecord Class
RCExceptionDataStringRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataStringRecord Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataStringRecord Methods
RCExceptionDataStringRecord Class See Also Send Feedback

The RCExceptionDataStringRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RCExceptionDataStringRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataStringRecord Properties

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataStringRecord Properties
RCExceptionDataStringRecord Class See Also Send Feedback

The RCExceptionDataStringRecord type exposes the following members.

Properties

 | Name | Description
Public property | Name | (Inherited from RCExceptionDataRecord.)
Public property | Value |
Public property | ValueString | (Overrides RCExceptionDataRecord..::..ValueString.)

See Also

RCExceptionDataStringRecord Class
Autodesk.CodeChecking.Concrete Namespace


Value Property

RCExceptionDataStringRecord..::..Value Property
RCExceptionDataStringRecord Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public string Value { get; set; }

See Also

RCExceptionDataStringRecord Class
Autodesk.CodeChecking.Concrete Namespace


ValueString Property

RCExceptionDataStringRecord..::..ValueString Property
RCExceptionDataStringRecord Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public override string ValueString { get; }

See Also

RCExceptionDataStringRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataXMLNameRecord Class

RCExceptionDataXMLNameRecord Class
Members See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class RCExceptionDataXMLNameRecord : RCExceptionDataRecord

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking.Concrete..::..RCExceptionDataRecord
Autodesk.CodeChecking.Concrete..::..RCExceptionDataXMLNameRecord

See Also

RCExceptionDataXMLNameRecord Members
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataXMLNameRecord Members

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataXMLNameRecord Members
RCExceptionDataXMLNameRecord Class Constructors Methods Properties See Also Send Feedback

The RCExceptionDataXMLNameRecord type exposes the following members.

Constructors

 | Name | Description
Public method | RCExceptionDataXMLNameRecord()()()() | Initializes a new instance of the RCExceptionDataXMLNameRecord class
Public method | RCExceptionDataXMLNameRecord(Enum, Enum) | Initializes a new instance of the RCExceptionDataXMLNameRecord class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | (Inherited from RCExceptionDataRecord.)
Public property | Value |
Public property | ValueString | (Overrides RCExceptionDataRecord..::..ValueString.)

See Also

RCExceptionDataXMLNameRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataXMLNameRecord Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataXMLNameRecord Constructor
RCExceptionDataXMLNameRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RCExceptionDataXMLNameRecord()()()() | Initializes a new instance of the RCExceptionDataXMLNameRecord class
Public method | RCExceptionDataXMLNameRecord(Enum, Enum) | Initializes a new instance of the RCExceptionDataXMLNameRecord class

See Also

RCExceptionDataXMLNameRecord Class
RCExceptionDataXMLNameRecord Members
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataXMLNameRecord Constructor

RCExceptionDataXMLNameRecord Constructor
RCExceptionDataXMLNameRecord Class See Also Send Feedback
Initializes a new instance of the RCExceptionDataXMLNameRecord class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCExceptionDataXMLNameRecord()

See Also

RCExceptionDataXMLNameRecord Class
RCExceptionDataXMLNameRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataXMLNameRecord Constructor (Enum, Enum)

RCExceptionDataXMLNameRecord Constructor (Enum, Enum)
RCExceptionDataXMLNameRecord Class See Also Send Feedback
Initializes a new instance of the RCExceptionDataXMLNameRecord class

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public RCExceptionDataXMLNameRecord(
    Enum name,
    Enum value
)

Parameters

name
Type: System..::..Enum
value
Type: System..::..Enum

See Also

RCExceptionDataXMLNameRecord Class
RCExceptionDataXMLNameRecord Overload
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataXMLNameRecord Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataXMLNameRecord Methods
RCExceptionDataXMLNameRecord Class See Also Send Feedback

The RCExceptionDataXMLNameRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RCExceptionDataXMLNameRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCExceptionDataXMLNameRecord Properties

[image]

Structural Analysis and Code Checking API Reference Guide
RCExceptionDataXMLNameRecord Properties
RCExceptionDataXMLNameRecord Class See Also Send Feedback

The RCExceptionDataXMLNameRecord type exposes the following members.

Properties

 | Name | Description
Public property | Name | (Inherited from RCExceptionDataRecord.)
Public property | Value |
Public property | ValueString | (Overrides RCExceptionDataRecord..::..ValueString.)

See Also

RCExceptionDataXMLNameRecord Class
Autodesk.CodeChecking.Concrete Namespace


Value Property

RCExceptionDataXMLNameRecord..::..Value Property
RCExceptionDataXMLNameRecord Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Enum Value { get; set; }

See Also

RCExceptionDataXMLNameRecord Class
Autodesk.CodeChecking.Concrete Namespace


ValueString Property

RCExceptionDataXMLNameRecord..::..ValueString Property
RCExceptionDataXMLNameRecord Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public override string ValueString { get; }

See Also

RCExceptionDataXMLNameRecord Class
Autodesk.CodeChecking.Concrete Namespace


RCSolver Class

RCSolver Class
Members See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class RCSolver : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking.Concrete..::..RCSolver

See Also

RCSolver Members
Autodesk.CodeChecking.Concrete Namespace


RCSolver Members

[image]

Structural Analysis and Code Checking API Reference Guide
RCSolver Members
RCSolver Class Methods See Also Send Feedback

The RCSolver type exposes the following members.

Methods

 | Name | Description
 | CreateNewSolver | Creates a new solver according geometry and defaults parameters for the concrete and steel.
Public method | Dispose | Releases all resources used by the RCSolver
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetArea | Gets the value of the area.
Public method | GetCenterOfInertia | Gets the coordinates of center of inertia.
Public method | GetConcrete | Gets the copy of parameters describing concrete behavior.
Public method | GetConcreteStressArea | Gets area of the compressed part of the section.
Public method | GetGeometry | Gets the copy of cross-section geometry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInternalForces | Gets the set of internal forces.
Public method | GetMomentFirstX | Gets the value of first moment of inertia.
Public method | GetMomentFirstY | Gets the value of first moment of inertia.
Public method | GetMomentOfInertiaX | Gets the value of moment of inertia.
Public method | GetMomentOfInertiaY | Gets the value of moment of inertia.
Public method | GetNeutralAxisAngle | Gets the angle between the neutral axis normal and the x-axis
Public method | GetNeutralAxisDistance | Gets the distance from the concrete section gravity center to neutral axis.
Public method | GetRebars | Gets the copy of set of reinforcement bars.
Public method | GetSteel | Gets the copy ofparameters describing steel behaviors.
Public method | GetStrain | Gets strain at a given point.
Public method | GetStrainMax | Gets maximum strain.
Public method | GetStrainMin | Gets minimum strain.
Public method | GetStress | Gets stress at a given point.
Public method | GetStressGravityCenter | Gets the coordinates center of inertia for stresses.
Public method | GetStressMax | Gets maximum strain.
Public method | GetStressMin | Gets minimum stress.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetConcrete | Sets necessary parameters describing concrete behaviors.
Public method | SetGeometry | Sets the cross-section geometry.
Public method | SetRebars |
Public method | SetSteel | Sets necessary parameters describing reinforcement steel behaviors.
Public method | SolveForces(ResultType, Double, Double) | Calculates resistance forces according to acting strain
Public method | SolveForces(ResultType, Double, Double, Double) | Calculates forces according to acting strain
Public method | SolveResistance | Calculates resistance according to acting design forces
Public method | SolveResistanceF | Calculates resistance moment according to acting design moment
Public method | SolveResistanceM | Calculates resistance moment according to acting design axial forces.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


RCSolver Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RCSolver Methods
RCSolver Class See Also Send Feedback

The RCSolver type exposes the following members.

Methods

 | Name | Description
 | CreateNewSolver | Creates a new solver according geometry and defaults parameters for the concrete and steel.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetArea | Gets the value of the area.
Public method | GetCenterOfInertia | Gets the coordinates of center of inertia.
Public method | GetConcrete | Gets the copy of parameters describing concrete behavior.
Public method | GetConcreteStressArea | Gets area of the compressed part of the section.
Public method | GetGeometry | Gets the copy of cross-section geometry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInternalForces | Gets the set of internal forces.
Public method | GetMomentFirstX | Gets the value of first moment of inertia.
Public method | GetMomentFirstY | Gets the value of first moment of inertia.
Public method | GetMomentOfInertiaX | Gets the value of moment of inertia.
Public method | GetMomentOfInertiaY | Gets the value of moment of inertia.
Public method | GetNeutralAxisAngle | Gets the angle between the neutral axis normal and the x-axis
Public method | GetNeutralAxisDistance | Gets the distance from the concrete section gravity center to neutral axis.
Public method | GetRebars | Gets the copy of set of reinforcement bars.
Public method | GetSteel | Gets the copy ofparameters describing steel behaviors.
Public method | GetStrain | Gets strain at a given point.
Public method | GetStrainMax | Gets maximum strain.
Public method | GetStrainMin | Gets minimum strain.
Public method | GetStress | Gets stress at a given point.
Public method | GetStressGravityCenter | Gets the coordinates center of inertia for stresses.
Public method | GetStressMax | Gets maximum strain.
Public method | GetStressMin | Gets minimum stress.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetConcrete | Sets necessary parameters describing concrete behaviors.
Public method | SetGeometry | Sets the cross-section geometry.
Public method | SetRebars |
Public method | SetSteel | Sets necessary parameters describing reinforcement steel behaviors.
Public method | SolveForces(ResultType, Double, Double) | Calculates resistance forces according to acting strain
Public method | SolveForces(ResultType, Double, Double, Double) | Calculates forces according to acting strain
Public method | SolveResistance | Calculates resistance according to acting design forces
Public method | SolveResistanceF | Calculates resistance moment according to acting design moment
Public method | SolveResistanceM | Calculates resistance moment according to acting design axial forces.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


CreateNewSolver Method

RCSolver..::..CreateNewSolver Method
RCSolver Class See Also Send Feedback
Creates a new solver according geometry and defaults parameters for the concrete and steel.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public static RCSolver CreateNewSolver(
    Geometry geometry
)

Parameters

geometry
Type: Autodesk.CodeChecking.Concrete..::..Geometry
The Geometry object.

Return Value

New solver object

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


Dispose Method

RCSolver..::..Dispose Method
RCSolver Class See Also Send Feedback
Releases all resources used by the RCSolver

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetArea Method

RCSolver..::..GetArea Method
RCSolver Class See Also Send Feedback
Gets the value of the area.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetArea(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determine which type of area will be returned, repectively for rebar, concrete or equivalent section (transformed)

Return Value

Returns the area for rebar, concrete or section.
Unit: [length*length].

Remarks

Unit depends to the units used to define concrete, steel, geometry and internal forces.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetCenterOfInertia Method

RCSolver..::..GetCenterOfInertia Method
RCSolver Class See Also Send Feedback
Gets the coordinates of center of inertia.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Point2D GetCenterOfInertia(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of moment to be returned, repectively for rebar, concrete or equivalent section (transformed).

Return Value

Returns the center of inertia point as Point2D.

Return Value

Returns the center of inertia point as Point2D.

Remarks

Unit depends to the units used to define concrete, steel, geometry and internal forces.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetConcrete Method

RCSolver..::..GetConcrete Method
RCSolver Class See Also Send Feedback
Gets the copy of parameters describing concrete behavior.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Concrete GetConcrete()

Return Value

Gets the copy of Concrete object.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetConcreteStressArea Method

RCSolver..::..GetConcreteStressArea Method
RCSolver Class See Also Send Feedback
Gets area of the compressed part of the section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetConcreteStressArea()

Return Value

Returns area of concrete in compression.
Unit: [length*length].

Remarks

Section returned is reduced by holes due to the reinforcement in compression. Unit depends to the units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Calculation are not performed

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetGeometry Method

RCSolver..::..GetGeometry Method
RCSolver Class See Also Send Feedback
Gets the copy of cross-section geometry.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Geometry GetGeometry()

Return Value

Gets the copy of Geometry object.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetInternalForces Method

RCSolver..::..GetInternalForces Method
RCSolver Class See Also Send Feedback
Gets the set of internal forces.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public SetOfForces GetInternalForces(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of internal forces could be taken into account: for rebar, concrete or equivalent section (transformed).

Return Value

Returned set is adequate for Rebar, Concrete or Section area. Includes axial force and moments around x-axis and y-axis.

Remarks

Unit depends to the units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Calculation are not performed

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetMomentFirstX Method

RCSolver..::..GetMomentFirstX Method
RCSolver Class See Also Send Feedback
Gets the value of first moment of inertia.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetMomentFirstX(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of moment to be returned: for rebar, concrete or equivalent section (transformed)

Return Value

Returns the value first monet of of inertia calculated around x' axis for rebar, concrete or section.
Unit: [length^3]

Remarks

The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
Unit depends to the units used to define concrete, steel, geometry and internal forces

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetMomentFirstY Method

RCSolver..::..GetMomentFirstY Method
RCSolver Class See Also Send Feedback
Gets the value of first moment of inertia.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetMomentFirstY(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of moment to be returned: for rebar, concrete or equivalent section (transformed)

Return Value

Returns the value first moment of inertia calculated around y' axis for rebar, concrete or section.
Unit: [length^3]

Remarks

The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
Unit depends to the units used to define concrete, steel, geometry and internal forces

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetMomentOfInertiaX Method

RCSolver..::..GetMomentOfInertiaX Method
RCSolver Class See Also Send Feedback
Gets the value of moment of inertia.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetMomentOfInertiaX(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determine which type of moment to be returned, repectively for rebar, concrete or equivalent section (transformed)

Return Value

Returns the value of moment of inertia calculated around x' axis for rebar, concrete or section.
Unit: [length^4].

Remarks

The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
Unit depends to the units used to define concrete, steel, geometry and internal forces

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetMomentOfInertiaY Method

RCSolver..::..GetMomentOfInertiaY Method
RCSolver Class See Also Send Feedback
Gets the value of moment of inertia.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetMomentOfInertiaY(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of moment to be returned, repectively for rebar, concrete or equivalent section (transformed)

Return Value

Returns the value of moment of inertia calculated around y' axis for rebar, concrete or section.
Unit: [length^4].

Remarks

The y' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
Unit depends to the units used to define concrete, steel, geometry and internal forces

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetNeutralAxisAngle Method

RCSolver..::..GetNeutralAxisAngle Method
RCSolver Class See Also Send Feedback
Gets the angle between the neutral axis normal and the x-axis

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetNeutralAxisAngle()

Return Value

Returns angle between the vector perpendicular to neutral axis and the x-axis.
The sense of the vector indicate direction to the most tension fiber.
Unit: [dimensionless].

Exceptions

Exception | Condition
 | Calculation are not performed.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetNeutralAxisDistance Method

RCSolver..::..GetNeutralAxisDistance Method
RCSolver Class See Also Send Feedback
Gets the distance from the concrete section gravity center to neutral axis.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetNeutralAxisDistance()

Return Value

Returns distance from gravity center of contour to neutral axis.
Unit: [length].

Remarks

Neutral axis divides the part of the compression from the tension.
This is line where the strain changes sign.
Unit depends to the units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Calculation are not performed.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetRebars Method

RCSolver..::..GetRebars Method
RCSolver Class See Also Send Feedback
Gets the copy of set of reinforcement bars.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public List<Rebar> GetRebars()

Return Value

Gets the copy of List of Rebar.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetSteel Method

RCSolver..::..GetSteel Method
RCSolver Class See Also Send Feedback
Gets the copy ofparameters describing steel behaviors.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Steel GetSteel()

Return Value

Gets the copy of Steel object.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetStrain Method

RCSolver..::..GetStrain Method
RCSolver Class See Also Send Feedback
Gets strain at a given point.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetStrain(
    ResultType resType,
    int index
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of strain to be returned: for rebar or concrete only.
index
Type: System..::..Int32
index of a point given from the contour or a given rebar.

Return Value

Returns strain in concrete or rebar at point given from the contour or rebar index.
Unit: [dimensionless]

Remarks

This method could be used only for concrete and rebars, for section, this method throws exception.
If calculation are not performed, this method throws exception as well.

Exceptions

Exception | Condition
 | Calculation are not performed
System..::..ArgumentException | This method could be used only for concrete and rebars.
System..::..ArgumentException | Index must be less than Count.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetStrainMax Method

RCSolver..::..GetStrainMax Method
RCSolver Class See Also Send Feedback
Gets maximum strain.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetStrainMax(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of strain to be returned: for rebar or concrete only.

Return Value

Returns maximum strain in concrete or in the rebar.

Remarks

This method could be used only for concrete and rebars, for section, this method throws exception.
If calculation are not performed, this method throws exception as well.

Exceptions

Exception | Condition
 | Calculation are not performed
System..::..ArgumentException | This method could be used only for concrete and rebars.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetStrainMin Method

RCSolver..::..GetStrainMin Method
RCSolver Class See Also Send Feedback
Gets minimum strain.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetStrainMin(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of strain to be returned: for rebar or concrete only.

Return Value

Returns minimum strain in concrete or in the rebar.

Remarks

This method could be used only for concrete and rebars, for section, this method throws exception.
If calculation are not performed, this method throws exception as well.

Exceptions

Exception | Condition
 | Calculation are not performed
System..::..ArgumentException | This method could be used only for concrete and rebars.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetStress Method

RCSolver..::..GetStress Method
RCSolver Class See Also Send Feedback
Gets stress at a given point.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetStress(
    ResultType resType,
    int id
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of stress to be returned: for rebar or concrete only.
id
Type: System..::..Int32
Id of the contour or a given rebar.

Return Value

Returns the stress in concrete or rebar at point given by contour or rebar Id.
Unit: [force per length^2]

Remarks

This method could be used only for concrete and rebars, for section, this method throws exception.
If calculation are not performed, this method throws exception as well.
Unit depends to the units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Calculation are not performed
 | This method could be used only for concrete and rebars.
System..::..ArgumentException | Index must be less than Count.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetStressGravityCenter Method

RCSolver..::..GetStressGravityCenter Method
RCSolver Class See Also Send Feedback
Gets the coordinates center of inertia for stresses.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Point2D GetStressGravityCenter(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of stresses could be taken into account: for rebar, concrete or equivalent section (transformed).

Return Value

Returns the center of inertia point for stresses as aPoint2D.

Return Value

Returns the center of inertia point as Point2D.

Exceptions

Exception | Condition
 | Calculation were not performed

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetStressMax Method

RCSolver..::..GetStressMax Method
RCSolver Class See Also Send Feedback
Gets maximum strain.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetStressMax(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of stress to be returned: for rebar or concrete only.

Return Value

Returns maximum stress in concrete or in the rebar.

Remarks

This method could be used only for concrete and rebars, for section, this method throws exception.
If calculation are not performed, this method throws exception as well.

Exceptions

Exception | Condition
 | Calculation are not performed
System..::..ArgumentException | This method could be used only for concrete and rebars.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


GetStressMin Method

RCSolver..::..GetStressMin Method
RCSolver Class See Also Send Feedback
Gets minimum stress.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetStressMin(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of stress to be returned: for rebar or concrete only.

Return Value

Returns minimum strain in concrete or in the rebar.

Remarks

This method could be used only for concrete and rebars, for section, this method throws exception.
If calculation are not performed, this method throws exception as well.

Exceptions

Exception | Condition
 | Calculation are not performed
System..::..ArgumentException | This method could be used only for concrete and rebars.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


SetConcrete Method

RCSolver..::..SetConcrete Method
RCSolver Class See Also Send Feedback
Sets necessary parameters describing concrete behaviors.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetConcrete(
    Concrete concrete
)

Parameters

concrete
Type: Autodesk.CodeChecking.Concrete..::..Concrete
The Concrete object.

Exceptions

Exception | Condition
System..::..ArgumentException | The concrete strength must be greater than 0.0.
System..::..ArgumentException | The concrete strain at failure must be greater than 0.0.
System..::..ArgumentException | The concrete modulus of elasticity (Young modulus) must greater than 0.0.
System..::..ArgumentException | The power should be greater than 1.0.
System..::..ArgumentException | The reduction factor of the compression zone height must be in the range between 0 and 1.0.
System..::..ArgumentException | The power must be greater than 1.0.
System..::..ArgumentException | The relationship changeover must be less than the ultimate strain.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


SetGeometry Method

RCSolver..::..SetGeometry Method
RCSolver Class See Also Send Feedback
Sets the cross-section geometry.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetGeometry(
    Geometry geometry
)

Parameters

geometry
Type: Autodesk.CodeChecking.Concrete..::..Geometry
The Geometry object.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


SetRebars Method

RCSolver..::..SetRebars Method
RCSolver Class See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetRebars(
    IEnumerable<Rebar> vRebar
)

Parameters

vRebar
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Rebar >)>)>

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


SetSteel Method

RCSolver..::..SetSteel Method
RCSolver Class See Also Send Feedback
Sets necessary parameters describing reinforcement steel behaviors.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetSteel(
    Steel steel
)

Parameters

steel
Type: Autodesk.CodeChecking.Concrete..::..Steel
The Steel object.

Exceptions

Exception | Condition
System..::..ArgumentException | The steel strength must be greater than 0.0.
System..::..ArgumentException | The steel strain at failure must be greater than 0.0.
System..::..ArgumentException | The steel modulus of elasticity (Young modulus) must greater than 0.0.
System..::..ArgumentException | The hardening factor for inclined top branch must be greater than 1.0 , for horizontal branch must be equal 1.0.
System..::..ArgumentException | The steel strain at failure can't be less than the design strength divided by modulus of elasticity.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


SolveForces Method

[image]

Structural Analysis and Code Checking API Reference Guide
RCSolver..::..SolveForces Method
RCSolver Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SolveForces(ResultType, Double, Double) | Calculates resistance forces according to acting strain
Public method | SolveForces(ResultType, Double, Double, Double) | Calculates forces according to acting strain

See Also

RCSolver Class
RCSolver Members
Autodesk.CodeChecking.Concrete Namespace


SolveForces Method (ResultType, Double, Double)

RCSolver..::..SolveForces Method (ResultType, Double, Double)
RCSolver Class See Also Send Feedback
Calculates resistance forces according to acting strain

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public SetOfForces SolveForces(
    ResultType resType,
    double topStrain,
    double bottomStrain
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of resistance to be returned: for rebar, concrete or equivalent section (transformed).
topStrain
Type: System..::..Double
Strain at the top of the section (on the extreme point of cross-section on the positive side of y axis).
Unit: [dimensionless].
bottomStrain
Type: System..::..Double
Strain at the bottom of section (on extreme point of cross-section on the negative side of y axis).
Unit: [dimensionless].

Remarks

The resistance forces could be read by GetInternalForces method.
Top and Bottom mean points of cross section with the maximum and minimum y coordinate.
Other information about state of failure could be read using dedicated methods.

Exceptions

Exception | Condition
System..::..ArgumentException | Top strain greater than ultimate concrete strain.
System..::..ArgumentException | Bottom strain greater than ultimate concrete strain.
System..::..ArgumentException | Top strain greater than ultimate steel strain.
System..::..ArgumentException | Bottom strain greater than ultimate steel strain.

See Also

RCSolver Class
SolveForces Overload
Autodesk.CodeChecking.Concrete Namespace


SolveForces Method (ResultType, Double, Double, Double)

RCSolver..::..SolveForces Method (ResultType, Double, Double, Double)
RCSolver Class See Also Send Feedback
Calculates forces according to acting strain

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public SetOfForces SolveForces(
    ResultType resType,
    double maxStrain,
    double minStrain,
    double angle
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of resistance to be returned: for rebar, concrete or equivalent section (transformed).
maxStrain
Type: System..::..Double
Maximum strain in the concrete section.
Unit: [dimensionless].
minStrain
Type: System..::..Double
Minimum strain in the concrete section.
Unit: [dimensionless].
angle
Type: System..::..Double
Angle between the vector perpendicular to neutral axis and the x-axis.
The sense of the vector indicate the direction to the most tensioned fiber.
Unit: [dimensionless].

Remarks

The resistance forces could be read by GetInternalForces method.
Other information about state of failure could be read using dedicated methods.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
Autodesk.CodeChecking.Concrete..::..IRCException | Minimum strain greater than maximum strain.
Autodesk.CodeChecking.Concrete..::..IRCException | Minimum strain greater than ultimate concrete strain.
Autodesk.CodeChecking.Concrete..::..IRCException | Maximum strain greater than ultimate steel strain.
Autodesk.CodeChecking.Concrete..::..IRCException | Minimum strain greater than ultimate steel strain.
Autodesk.CodeChecking.Concrete..::..IRCException | Rotation angle should be in the range between 0 and 2.0*Pi.

See Also

RCSolver Class
SolveForces Overload
Autodesk.CodeChecking.Concrete Namespace


SolveResistance Method

RCSolver..::..SolveResistance Method
RCSolver Class See Also Send Feedback
Calculates resistance according to acting design forces

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SolveResistance(
    double designAxialForce,
    double designMomentX,
    double designMomentY
)

Parameters

designAxialForce
Type: System..::..Double
The acting design axial force.
Unit: [force].
designMomentX
Type: System..::..Double
The acting design moment around x-axis.
Unit: [force*length].
designMomentY
Type: System..::..Double
The acting design moment around y-axis.
Unit: [force*length]

Remarks

The forces are described in the coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
designAxialForce - Axial force. The compresion have positive sign.
designMomentX - The bending moment around x'-axis.
designMomentY - The bending moment around y'-axis.
The resistance forces could be read by GetInternalForces method.
The resistance force has the same eccentricities than acting forces.
Other information about state of failure could be read using dedicated methods.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Internal error in the SolveResistance method

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


SolveResistanceF Method

RCSolver..::..SolveResistanceF Method
RCSolver Class See Also Send Feedback
Calculates resistance moment according to acting design moment

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SolveResistanceF(
    double actingMoment,
    Axis axis,
    bool resultAsPositive
)

Parameters

actingMoment
Type: System..::..Double
The acting moment.
Unit: [force*length].
axis
Type: Autodesk.CodeChecking.Concrete..::..Axis
Determinates which beanding moment is acting around x-axis or y-axis.
resultAsPositive
Type: System..::..Boolean
Determinates singn of result. Resistance axial force should be calculate as negative or positive.

Remarks

The design forces are described in the coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
resistanceMoment - The bending moment. The axis around moment was calculated is determined by BendingMomentDefinition.
The resistance moment is the same as acting moment, the moment on the second direction is equal 0.0.
The resistance forces could be read by GetInternalForces method.
Other information about state of failure could be read using dedicated methods.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Internal error in the SolveResistanceF method

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


SolveResistanceM Method

RCSolver..::..SolveResistanceM Method
RCSolver Class See Also Send Feedback
Calculates resistance moment according to acting design axial forces.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SolveResistanceM(
    double actingAxialForce,
    Axis axis,
    bool resultAsPositive
)

Parameters

actingAxialForce
Type: System..::..Double
The acting axial force.
Unit: [force].
axis
Type: Autodesk.CodeChecking.Concrete..::..Axis
Determinates which beanding moment is acting. Bending around x-axis or y-axis.
resultAsPositive
Type: System..::..Boolean
Determinates singn of result. Resistance bending moment should be calculate as negative or positive.

Remarks

The forces are described in the coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
The resistance axial force are the same as acting forces, the moment on the second direction is equal 0.0; The positive axial force gives compression. The resistance forces could be read by GetInternalForces method.
Other information about state of failure could be read using dedicated methods.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Internal error in the SolveResistanceM method

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace


Rebar Class

Rebar Class
Members See Also Send Feedback
Describes a rebar in the context of Autodesk.CodeChecking.Concrete.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class Rebar

Remarks

In this context a rebar is described by a point in the 2D space (Point2D) and his area. The rebars must be described in the same coordinate system as the cross-section geometry.

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking.Concrete..::..Rebar

See Also

Rebar Members
Autodesk.CodeChecking.Concrete Namespace


Rebar Members

[image]

Structural Analysis and Code Checking API Reference Guide
Rebar Members
Rebar Class Constructors Methods Properties See Also Send Feedback

The Rebar type exposes the following members.

Constructors

 | Name | Description
Public method | Rebar | The Rebar class constructor. Creates the rebar with coordinates x,y and area.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | The Position property represents the the area of the rebar.
Public property | Position | The Position property represents the the position of the center of rebar.
Public property | X | The X property represents the x-coordinate of the point.
Public property | Y | The Y property represents the y-coordinate of the point.

See Also

Rebar Class
Autodesk.CodeChecking.Concrete Namespace


Rebar Constructor

Rebar Constructor
Rebar Class See Also Send Feedback
The Rebar class constructor. Creates the rebar with coordinates x,y and area.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Rebar(
    double x,
    double y,
    double area
)

Parameters

x
Type: System..::..Double
The x-coordinate of the center of rebar.
Unit: [length].
y
Type: System..::..Double
The y-coordinate of the center of rebar.
Unit: [length].
area
Type: System..::..Double
The area of the rebar.
Unit: [length^2]

Exceptions

Exception | Condition
System..::..ArgumentException | Rebar area must be greater than 0.0

See Also

Rebar Class
Autodesk.CodeChecking.Concrete Namespace


Rebar Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Rebar Methods
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Rebar Class
Autodesk.CodeChecking.Concrete Namespace


Rebar Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Rebar Properties
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Properties

 | Name | Description
Public property | Area | The Position property represents the the area of the rebar.
Public property | Position | The Position property represents the the position of the center of rebar.
Public property | X | The X property represents the x-coordinate of the point.
Public property | Y | The Y property represents the y-coordinate of the point.

See Also

Rebar Class
Autodesk.CodeChecking.Concrete Namespace


Area Property

Rebar..::..Area Property
Rebar Class See Also Send Feedback
The Position property represents the the area of the rebar.
Gets or sets the area of the rebar.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double Area { get; set; }

Remarks

Unit: [length^2].

Exceptions

Exception | Condition
System..::..ArgumentException | Rebar area must be greater than 0.0

See Also

Rebar Class
Autodesk.CodeChecking.Concrete Namespace


Position Property

Rebar..::..Position Property
Rebar Class See Also Send Feedback
The Position property represents the the position of the center of rebar.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Point2D Position { get; set; }

Field Value

Gets or sets a point in the 2D space (Point2D) describing the position of the center of rebar.

See Also

Rebar Class
Autodesk.CodeChecking.Concrete Namespace


X Property

Rebar..::..X Property
Rebar Class See Also Send Feedback
The X property represents the x-coordinate of the point.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double X { get; set; }

Field Value

Gets or sets the x-coordinate of the center of rebar.

Remarks

Unit: [length].

See Also

Rebar Class
Autodesk.CodeChecking.Concrete Namespace


Y Property

Rebar..::..Y Property
Rebar Class See Also Send Feedback
The Y property represents the y-coordinate of the point.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double Y { get; set; }

Field Value

Gets or sets the y-coordinate of the center of rebar.

Remarks

Unit: [length].

See Also

Rebar Class
Autodesk.CodeChecking.Concrete Namespace


ResultType Enumeration

ResultType Enumeration
See Also Send Feedback
Classification of the type of results returned by the solver.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum ResultType

Members

Member name | Value | Description
Rebars | 0 | To be used when only results for rebars are required.
Concrete | 1 | To be used when only results for concrete are required.
Section | 2 | To be used in typical situation, when all results (for rebars and concrete) are required.

Remarks

Section defines a full set of results for the reinforced concrete section. It's a typical situation.
For Rebars and Concrete only results for the concrete and rebars are available.

See Also

Autodesk.CodeChecking.Concrete Namespace


SetOfForces Class

SetOfForces Class
Members See Also Send Feedback
Describes the set of internal forces: AxialForce(N), MomentX(Mx) and MomentY(My).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class SetOfForces

Remarks

The internal forces are described in coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
AxialForce(N) - The compresion have positive sign.
MomentX(Mx) - The bending moment around x'-axis.
MomentY(My) - The bending moment around y'-axis.

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking.Concrete..::..SetOfForces

See Also

SetOfForces Members
Autodesk.CodeChecking.Concrete Namespace


SetOfForces Members

[image]

Structural Analysis and Code Checking API Reference Guide
SetOfForces Members
SetOfForces Class Constructors Methods Fields See Also Send Feedback

The SetOfForces type exposes the following members.

Constructors

 | Name | Description
Public method | SetOfForces()()()() | The default SetOfForces class constructor.
Public method | SetOfForces(Double, Double, Double) | The SetOfForces class constructor with AxialForce, MomentX and MomentY values set as parameter.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | AxialForce | The AxialForce field represents the axial force (N). The compresion have positive sign.
Public field | MomentX | The MomentX field represents the bending moment around x'-axis.
Public field | MomentY | The MomentY field represents the bending moment around y'-axis.

See Also

SetOfForces Class
Autodesk.CodeChecking.Concrete Namespace


SetOfForces Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SetOfForces Constructor
SetOfForces Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetOfForces()()()() | The default SetOfForces class constructor.
Public method | SetOfForces(Double, Double, Double) | The SetOfForces class constructor with AxialForce, MomentX and MomentY values set as parameter.

See Also

SetOfForces Class
SetOfForces Members
Autodesk.CodeChecking.Concrete Namespace


SetOfForces Constructor

SetOfForces Constructor
SetOfForces Class See Also Send Feedback
The default SetOfForces class constructor.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public SetOfForces()

Remarks

All internal forces are set to 0.0.

See Also

SetOfForces Class
SetOfForces Overload
Autodesk.CodeChecking.Concrete Namespace


SetOfForces Constructor (Double, Double, Double)

SetOfForces Constructor (Double, Double, Double)
SetOfForces Class See Also Send Feedback
The SetOfForces class constructor with AxialForce, MomentX and MomentY values set as parameter.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public SetOfForces(
    double n,
    double mx,
    double my
)

Parameters

n
Type: System..::..Double
The axial force.
Unit: [force].
mx
Type: System..::..Double
The bending moment around x-axis.
Unit: [force*length].
my
Type: System..::..Double
The bending moment around y-axis.
Unit: [force*length].

Remarks

The internal forces are described in coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
AxialForce(N) - The compresion have positive sign.
MomentX(Mx) - The bending moment around x'-axis.
MomentY(My) - The bending moment around y'-axis.
The units should be consistent for concrete, steel, geometry and internal forces.

See Also

SetOfForces Class
SetOfForces Overload
Autodesk.CodeChecking.Concrete Namespace


SetOfForces Fields

[image]

Structural Analysis and Code Checking API Reference Guide
SetOfForces Fields
SetOfForces Class See Also Send Feedback

The SetOfForces type exposes the following members.

Fields

 | Name | Description
Public field | AxialForce | The AxialForce field represents the axial force (N). The compresion have positive sign.
Public field | MomentX | The MomentX field represents the bending moment around x'-axis.
Public field | MomentY | The MomentY field represents the bending moment around y'-axis.

See Also

SetOfForces Class
Autodesk.CodeChecking.Concrete Namespace


AxialForce Field

SetOfForces..::..AxialForce Field
SetOfForces Class See Also Send Feedback
The AxialForce field represents the axial force (N). The compresion have positive sign.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double AxialForce

See Also

SetOfForces Class
Autodesk.CodeChecking.Concrete Namespace


MomentX Field

SetOfForces..::..MomentX Field
SetOfForces Class See Also Send Feedback
The MomentX field represents the bending moment around x'-axis.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double MomentX

See Also

SetOfForces Class
Autodesk.CodeChecking.Concrete Namespace


MomentY Field

SetOfForces..::..MomentY Field
SetOfForces Class See Also Send Feedback
The MomentY field represents the bending moment around y'-axis.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double MomentY

See Also

SetOfForces Class
Autodesk.CodeChecking.Concrete Namespace


SetOfForces Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SetOfForces Methods
SetOfForces Class See Also Send Feedback

The SetOfForces type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SetOfForces Class
Autodesk.CodeChecking.Concrete Namespace


Steel Class

Steel Class
Members See Also Send Feedback
Represents the class for steel behaviors definition.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class Steel : IRCSolverMember, IDisposable

Remarks

Including parameters of steel and method for calculating the stress in steel for the given strain. The parameters should be defined in base units for example [m],[N], or [pound],[in]. All set values should have consistent units. The units should be the same for concrete, steel, geometry and internal forces.

Inheritance Hierarchy

System..::..Object
IRCSolverMember
Autodesk.CodeChecking.Concrete..::..Steel

See Also

Steel Members
Autodesk.CodeChecking.Concrete Namespace


Steel Members

[image]

Structural Analysis and Code Checking API Reference Guide
Steel Members
Steel Class Constructors Methods Properties See Also Send Feedback

The Steel type exposes the following members.

Constructors

 | Name | Description
Public method | Steel | The default Steel class constructor

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Steel
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetModelIdealElastoPlastic | Sets all appropriate parameters for steel with horizontal top branch (Ideal elasto-plactic behaviour).
Public method | SetModelWithHardening | Sets all appropriate parameters for steel with inclined top branch (plastic with hardening).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DesignStrength | The DesignStrength property represents the design strenght of steel (design yield strength).
Public property | HardeningFactor | The HardeningFactor property represents the value of steel hardening over the plastic behaviour.
Public property | ModulusOfElasticity | The ModulusOfElasticity property represents the steel modulus of elasticity (Young modulus).
Public property | StrainUltimateLimit | The StrainUltimateLimit property represents the value of maximum steel strain.

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


Steel Constructor

Steel Constructor
Steel Class See Also Send Feedback
The default Steel class constructor

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Steel()

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


Steel Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Steel Methods
Steel Class See Also Send Feedback

The Steel type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetModelIdealElastoPlastic | Sets all appropriate parameters for steel with horizontal top branch (Ideal elasto-plactic behaviour).
Public method | SetModelWithHardening | Sets all appropriate parameters for steel with inclined top branch (plastic with hardening).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


Dispose Method

Steel..::..Dispose Method
Steel Class See Also Send Feedback
Releases all resources used by the Steel

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


SetModelIdealElastoPlastic Method

Steel..::..SetModelIdealElastoPlastic Method
Steel Class See Also Send Feedback
Sets all appropriate parameters for steel with horizontal top branch (Ideal elasto-plactic behaviour).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetModelIdealElastoPlastic(
    double designStrength,
    double strainUltimateLimit,
    double modulusOfElasticity
)

Parameters

designStrength
Type: System..::..Double
The steel design strength.
Unit: [force per length^2].
strainUltimateLimit
Type: System..::..Double
The steel strain at failure.
Unit: [dimensionless].
modulusOfElasticity
Type: System..::..Double
The steel modulus of elasticity (Young modulus).
Unit: [force per length^2]

Remarks

The values should be in the base unit and it should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The steel design strength must be greater than 0.0.
System..::..ArgumentException | The steel design strain at failure must be greater than 0.0.
System..::..ArgumentException | The steel Young modulus (modulus of elasticity) must greater than 0.0.
System..::..ArgumentException | The steel strain at failure can't be less than the design strength divided by the modulus of elasticity

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


SetModelWithHardening Method

Steel..::..SetModelWithHardening Method
Steel Class See Also Send Feedback
Sets all appropriate parameters for steel with inclined top branch (plastic with hardening).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetModelWithHardening(
    double designStrength,
    double strainUltimateLimit,
    double modulusOfElasticity,
    double hardeningFactor
)

Parameters

designStrength
Type: System..::..Double
The steel design strength.
Unit: [force per length^2].
strainUltimateLimit
Type: System..::..Double
The steel strain at failure.
Unit: [dimensionless].
modulusOfElasticity
Type: System..::..Double
The steel Modulus of elasticity (Young modulus).
Unit: [force per length^2]
hardeningFactor
Type: System..::..Double
Value of the hardening between strain equals to design strength divided by the modulus of elasticity and the ultimate limit of steel strain.
Unit: [dimensionless].

Remarks

The values should be in the base unit and it should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The steel design strength must be greater than 0.0.
System..::..ArgumentException | The steel strain at failure must be greater than 0.0.
System..::..ArgumentException | The steel Young modulus (modulus of elasticity) must greater than 0.0.
System..::..ArgumentException | The hardening factor for inclined top branch must be greater than 1.0 , for horizontal branch must be equal to 1.0
System..::..ArgumentException | The steel strain at failure can't be less than the design strength divided by the modulus of elasticity

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


Steel Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Steel Properties
Steel Class See Also Send Feedback

The Steel type exposes the following members.

Properties

 | Name | Description
Public property | DesignStrength | The DesignStrength property represents the design strenght of steel (design yield strength).
Public property | HardeningFactor | The HardeningFactor property represents the value of steel hardening over the plastic behaviour.
Public property | ModulusOfElasticity | The ModulusOfElasticity property represents the steel modulus of elasticity (Young modulus).
Public property | StrainUltimateLimit | The StrainUltimateLimit property represents the value of maximum steel strain.

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


DesignStrength Property

Steel..::..DesignStrength Property
Steel Class See Also Send Feedback
The DesignStrength property represents the design strenght of steel (design yield strength).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double DesignStrength { get; set; }

Field Value

Gets or sets the steel design strength (design yield strength).

Remarks

Unit: [force per length^2].
Design strength should be in base units for example[Pa]. Typical values are in the range between 200000000 and 500000000[Pa] or 30000 and 75000 [psi].
The return value will be in the same unit which has been used.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The steel design strength must be greater than 0.0.

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


HardeningFactor Property

Steel..::..HardeningFactor Property
Steel Class See Also Send Feedback
The HardeningFactor property represents the value of steel hardening over the plastic behaviour.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double HardeningFactor { get; set; }

Field Value

Gets or sets the value of hardening factor between the strain equal to the design strength divided by the modulus of elasticity and the ultimate limit of steel strain.

Remarks

Unit: [dimensionless].
Typical values are in the range between 1.0 and 1.05.
Hardening factor equal to 1.0 means an ideal elasto-plastic steel with horizontal branch, greater than 1.0 an inclined top branch steel with hardening on plastic side.

Exceptions

Exception | Condition
System..::..ArgumentException | The hardening factor for inclined top branch must be greater than 1.0 , for horizontal branch must be equal 1.0

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


ModulusOfElasticity Property

Steel..::..ModulusOfElasticity Property
Steel Class See Also Send Feedback
The ModulusOfElasticity property represents the steel modulus of elasticity (Young modulus).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double ModulusOfElasticity { get; set; }

Field Value

Gets or sets value of the steel modulus of elasticity (Young modulus).

Remarks

Unit: [length^4].
The steel modulus of elasticity (Young modulus) should be in base units for example [Pa],[psi].
Typical values are 200000000000[Pa] 29000000[psi].
This value is used for calculating changeover of stress-strain relationship and equivalent (transformed) characteristic of the reinforced section.
The return value will be in the same unit which has been used.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The concrete Young modulus (modulus of elasticity) must greater than 0.0.

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


StrainUltimateLimit Property

Steel..::..StrainUltimateLimit Property
Steel Class See Also Send Feedback
The StrainUltimateLimit property represents the value of maximum steel strain.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double StrainUltimateLimit { get; set; }

Field Value

Gets or sets the value of the steel strain at failure

Remarks

Unit: [dimensionless].
Typical values are in the range between 0.005 and 0.1.

Exceptions

Exception | Condition
System..::..ArgumentException | The concrete strain at failure must be greater than 0.0.

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace


SteelExceptionEnum Enumeration

SteelExceptionEnum Enumeration
See Also Send Feedback
Classification of exceptions that could be thrown in time of creation the concrete parameters.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum SteelExceptionEnum

Members

Member name | Value | Description
DesignStrength | 0 | The steel design strength must be greater than 0.0
StrainUltimateLimit | 1 | The steel strain at failure must be greater than 0.0. The steel strain at failure can't be less than the design strength divided by the modulus of elasticity.
ModulusOfElasticity | 2 | The steel modulus of elasticity (Young modulus ) must greater than 0.0
HardeningFactor | 3 | The hardening factor cannot be less than 1.0

See Also

Autodesk.CodeChecking.Concrete Namespace


StressDiagramType Enumeration

StressDiagramType Enumeration
See Also Send Feedback
Classification of concrete stress-strain relationships.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum StressDiagramType

Members

Member name | Value | Description
Rectangular | 0 | Simplified model with rectangular stress distribution. Usage of a constant value of stress along the reduced height.
Linear | 1 | Stress with linear relationship to strain. Usage of the typical SLS model.
Bilinear | 2 | Stress with Bi-linear relationship to strain. Linear part from 0.0 to strain relationship changeover value, constant part from strain relationship changeover to the ultimate limit of the strain.
ParabolicRectangular | 3 | Stress with Parabola-rectangle relationship to strain. Parabolic part (1.0 - strain^2) from 0.0 to strain relationship changeover value, constant part from strain relationship changeover value to the ultimate limit of the strain.
PowerRectangular | 4 | Stress with Power-rectangle relationship to strain. Power part (1.0 - strain^x) from 0.0 to strain relationship changeover value, constant part from strain relationship changeover value to the ultimate limit of the strain.

See Also

Autodesk.CodeChecking.Concrete Namespace


XMLName Enumeration

XMLName Enumeration
See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum XMLName

Members

Member name | Value | Description
Unknown | 0 |
Output | 1 |
Input | 2 |
InputSegment | 3 |
Concrete | 4 |
type | 5 |
concData | 6 |
DesignStrength | 7 |
EffectiveHeightReductionFactor | 8 |
Power | 9 |
ModulusOfElasticity | 10 |
StrainRelationChangeOver | 11 |
StrainStressModel | 12 |
StrainUltimateLimit | 13 |
Steel | 14 |
steelData | 15 |
HardeningFactor | 16 |
Geometry | 17 |
Point2D | 18 |
x | 19 |
y | 20 |
Reinforcement | 21 |
Rebar | 22 |
area | 23 |
diam | 24 |
cm | 25 |
mm | 26 |
runTest | 27 |
endTest | 28 |
testTime | 29 |
totalTestTime | 30 |
iterations | 31 |
name | 32 |
SolveForces | 33 |
SolveInternalForces | 34 |
SolveBarsForces | 35 |
topStrain | 36 |
bottomStrain | 37 |
SolveResistance | 38 |
SolveResistanceF | 39 |
SolveResistanceM | 40 |
designAxialForce | 41 |
designMomentX | 42 |
designMomentY | 43 |
resistanceMoment | 44 |
resistanceAxialForce | 45 |
axis | 46 |
direction | 47 |
X | 48 |
Y | 49 |
GetResult | 50 |
ConcreteParameters | 51 |
SteelParameters | 52 |
GeometryParameters | 53 |
ReinforcementParameters | 54 |
CrossSectionCharacteristics | 55 |
Area | 56 |
CenterOfInertia | 57 |
MomentOfInertiaX | 58 |
MomentOfInertiaY | 59 |
ResistanceResult | 60 |
ConcreteResult | 61 |
ConcreteStressArea | 62 |
ConcreteStressGravityCenter | 63 |
SteelResult | 64 |
SteelArea | 65 |
SteelCenterOfInertia | 66 |
SteelMomentOfInertiaX | 67 |
SteelMomentOfInertiaY | 68 |
RcSectionResult | 69 |
EquivalentArea | 70 |
EquivalentCenterOfInertia | 71 |
EquivalentMomentOfInertiaX | 72 |
EquivalentMomentOfInertiaY | 73 |
EquivalentGravityCenter | 74 |
InternalAxialForce | 75 |
InternalMomentX | 76 |
InternalMomentY | 77 |
NeutralAxisAngle | 78 |
NeutralAxisDist | 79 |
StrainMin | 80 |
StrainMax | 81 |
StrainSteelMax | 82 |
StrainSteelMin | 83 |
AllParameters | 84 |
SectionC | 85 |
SectionR | 86 |
SectionT | 87 |
d | 88 |
b | 89 |
h | 90 |
hf | 91 |
bf | 92 |
Error | 93 |

See Also

Autodesk.CodeChecking.Concrete Namespace


Autodesk.Revit.DB.CodeChecking Namespace

Autodesk.Revit.DB.CodeChecking Namespace
Send Feedback

Classes

 | Class | Description
Public class | Error | Represents error notification
Public class | Info | Represents information notification
Public class | MultiStructureServer | The base class for all servers that support more than one category or material.
Public class | Notification | Represents the base class for all notifications
Public class | NotificationService | The center via which it is possible to register notifications
Public class | ProgressBreak | Represents progress break requirement
Public class | ProgressBreakException | The exception used for breaking current action
Public class | ProgressEnd | Informs about end of current action
Public class | ProgressNotification | Base class for all progress notifications
Public class | ProgressStart | Informs about progress start.
Public class | ProgressStatus | Informs about progress status.
Public class | ProgressStatusAllCodes | Informs about all codes.
Public class | ProgressStatusCode | Informs about progress status.
Public class | ProgressStatusCodeSummary | Informs about progress status.
Public class | ProgressStep | Informs about progress next step.
Public class | Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> | Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform. It is dedicated for servers which provides one description for labels and results.
Public class | ServerException | Represents server exception
Public class | Service | Represents the main service in the Code Checking Platform. It manages all Code Checking servers.
Public class | ServiceData | Represents data used for exchanging information between Service and servers.
Public class | Tools | Helper class for common operations
Public class | Warning | Represents warning notification

Interfaces

 | Interface | Description
Public interface | ICodeCheckingServer | The base interface for all Code Checking servers

Delegates

 | Delegate | Description
Public delegate | NotificationAddedHandler | The delagate for notifying about new notification in the system.

Enumerations

 | Enumeration | Description
Public enumeration | ExecutionContext | Describes execution context of CodeChecking platform.
Public enumeration | NotificationLevel | Represents the level of notification


Error Class

Error Class
Members See Also Send Feedback
Represents error notification

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Error : Notification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..Error

See Also

Error Members
Autodesk.Revit.DB.CodeChecking Namespace


Error Members

[image]

Structural Analysis and Code Checking API Reference Guide
Error Members
Error Class Constructors Methods Properties See Also Send Feedback

The Error type exposes the following members.

Constructors

 | Name | Description
Public method | Error | Initializes a new instance of the Error class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Overrides Notification..::..Level.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

Error Class
Autodesk.Revit.DB.CodeChecking Namespace


Error Constructor

Error Constructor
Error Class See Also Send Feedback
Initializes a new instance of the Error class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Error()

See Also

Error Class
Autodesk.Revit.DB.CodeChecking Namespace


Error Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Error Methods
Error Class See Also Send Feedback

The Error type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Error Class
Autodesk.Revit.DB.CodeChecking Namespace


Error Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Error Properties
Error Class See Also Send Feedback

The Error type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Overrides Notification..::..Level.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

Error Class
Autodesk.Revit.DB.CodeChecking Namespace


Level Property

Error..::..Level Property
Error Class See Also Send Feedback
Gets the level of notification.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override NotificationLevel Level { get; }

See Also

Error Class
Autodesk.Revit.DB.CodeChecking Namespace


ExecutionContext Enumeration

ExecutionContext Enumeration
See Also Send Feedback
Describes execution context of CodeChecking platform.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ExecutionContext

Members

Member name | Value | Description
Verification | 0 | Verification of current state of the model

See Also

Autodesk.Revit.DB.CodeChecking Namespace


ICodeCheckingServer Interface

ICodeCheckingServer Interface
Members See Also Send Feedback
The base interface for all Code Checking servers

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ICodeCheckingServer : IExternalServer

See Also

ICodeCheckingServer Members
Autodesk.Revit.DB.CodeChecking Namespace


ICodeCheckingServer Members

[image]

Structural Analysis and Code Checking API Reference Guide
ICodeCheckingServer Members
ICodeCheckingServer Interface Methods See Also Send Feedback

The ICodeCheckingServer type exposes the following members.

Methods

 | Name | Description
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one.
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one.
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one.
Public method | GetCalculationParamSchema | Returns schema for calculation parameters.
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity.
Public method | GetDefaultLabel | Returns default value of label entity.
Public method | GetDescription | (Inherited from IExternalServer.)
Public method | GetLabelSchema | Returns schema for labels.
Public method | GetName | (Inherited from IExternalServer.)
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package.
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.
Public method | GetResultsSchema | Returns schema for results.
Public method | GetServerId | (Inherited from IExternalServer.)
Public method | GetServiceId | (Inherited from IExternalServer.)
Public method | GetSupportedCategories | Returns the list of supported categories.
Public method | GetSupportedMaterials | Returns the list of supported materials.
Public method | GetVendorId | (Inherited from IExternalServer.)
Public method | GetVersion | Gets the version of code checking server.
Public method | IsContextSupported | Determines whether specified context is supported.
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load cases and combinations, they will be exposed on the dialog.
Public method | ResultBuilderPackagesAsInputData | Determines whether Results Builder packages will be treated as input data.
Public method | Verify | Runs calculation.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


ICodeCheckingServer Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ICodeCheckingServer Methods
ICodeCheckingServer Interface See Also Send Feedback

The ICodeCheckingServer type exposes the following members.

Methods

 | Name | Description
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one.
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one.
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one.
Public method | GetCalculationParamSchema | Returns schema for calculation parameters.
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity.
Public method | GetDefaultLabel | Returns default value of label entity.
Public method | GetDescription | (Inherited from IExternalServer.)
Public method | GetLabelSchema | Returns schema for labels.
Public method | GetName | (Inherited from IExternalServer.)
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package.
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.
Public method | GetResultsSchema | Returns schema for results.
Public method | GetServerId | (Inherited from IExternalServer.)
Public method | GetServiceId | (Inherited from IExternalServer.)
Public method | GetSupportedCategories | Returns the list of supported categories.
Public method | GetSupportedMaterials | Returns the list of supported materials.
Public method | GetVendorId | (Inherited from IExternalServer.)
Public method | GetVersion | Gets the version of code checking server.
Public method | IsContextSupported | Determines whether specified context is supported.
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load cases and combinations, they will be exposed on the dialog.
Public method | ResultBuilderPackagesAsInputData | Determines whether Results Builder packages will be treated as input data.
Public method | Verify | Runs calculation.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


ConvertCalcParamsToCurrentVersion Method

ICodeCheckingServer..::..ConvertCalcParamsToCurrentVersion Method
ICodeCheckingServer Interface See Also Send Feedback
Converts old version of calculation parameters entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Entity ConvertCalcParamsToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version of calculation parameters entity.
document
Type: Document
The document.

Return Value

The newest version of calculation parameters entity.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


ConvertLabelToCurrentVersion Method

ICodeCheckingServer..::..ConvertLabelToCurrentVersion Method
ICodeCheckingServer Interface See Also Send Feedback
Converts old version of label entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Entity ConvertLabelToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version of label entity.
document
Type: Document
The document.

Return Value

The newest version of label entity.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


ConvertResultToCurrentVersion Method

ICodeCheckingServer..::..ConvertResultToCurrentVersion Method
ICodeCheckingServer Interface See Also Send Feedback
Converts old version of result entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Entity ConvertResultToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version of result entity.
document
Type: Document
The document.

Return Value

The newest version of result entity.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


GetCalculationParamSchema Method

ICodeCheckingServer..::..GetCalculationParamSchema Method
ICodeCheckingServer Interface See Also Send Feedback
Returns schema for calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Schema GetCalculationParamSchema()

Return Value

Calculation parameters schema.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


GetDefaultCalcParams Method

ICodeCheckingServer..::..GetDefaultCalcParams Method
ICodeCheckingServer Interface See Also Send Feedback
Returns default value of calculation parameters entity.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Entity GetDefaultCalcParams(
    Document document
)

Parameters

document
Type: Document

Return Value

The default value.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


GetDefaultLabel Method

ICodeCheckingServer..::..GetDefaultLabel Method
ICodeCheckingServer Interface See Also Send Feedback
Returns default value of label entity.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Entity GetDefaultLabel(
    Document document,
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

document
Type: Document
The document.
material
Type: StructuralAssetClass
The material.
category
Type: BuiltInCategory
The category.

Return Value

The default value.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


GetLabelSchema Method

ICodeCheckingServer..::..GetLabelSchema Method
ICodeCheckingServer Interface See Also Send Feedback
Returns schema for labels.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Schema GetLabelSchema(
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

material
Type: StructuralAssetClass
The material.
category
Type: BuiltInCategory
The category.

Return Value

Labels schema.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


GetOutputPackageResultTypes Method

ICodeCheckingServer..::..GetOutputPackageResultTypes Method
ICodeCheckingServer Interface See Also Send Feedback
Gets the output package result types. This information is needed to create proper ResultsBuilder Package.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
ResultsPackageTypes GetOutputPackageResultTypes()

Return Value

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


GetOutputPackageUnitSystem Method

ICodeCheckingServer..::..GetOutputPackageUnitSystem Method
ICodeCheckingServer Interface See Also Send Feedback
Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
UnitsSystem GetOutputPackageUnitSystem()

Return Value

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


GetResultsSchema Method

ICodeCheckingServer..::..GetResultsSchema Method
ICodeCheckingServer Interface See Also Send Feedback
Returns schema for results.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Schema GetResultsSchema(
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

material
Type: StructuralAssetClass
category
Type: BuiltInCategory

Return Value

Results schema.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


GetSupportedCategories Method

ICodeCheckingServer..::..GetSupportedCategories Method
ICodeCheckingServer Interface See Also Send Feedback
Returns the list of supported categories.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
IList<BuiltInCategory> GetSupportedCategories(
    StructuralAssetClass material
)

Parameters

material
Type: StructuralAssetClass

Return Value

List of categories.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


GetSupportedMaterials Method

ICodeCheckingServer..::..GetSupportedMaterials Method
ICodeCheckingServer Interface See Also Send Feedback
Returns the list of supported materials.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
IList<StructuralAssetClass> GetSupportedMaterials()

Return Value

List of materials.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


GetVersion Method

ICodeCheckingServer..::..GetVersion Method
ICodeCheckingServer Interface See Also Send Feedback
Gets the version of code checking server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
int GetVersion()

Return Value

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


IsContextSupported Method

ICodeCheckingServer..::..IsContextSupported Method
ICodeCheckingServer Interface See Also Send Feedback
Determines whether specified context is supported.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool IsContextSupported(
    ExecutionContext context
)

Parameters

context
Type: Autodesk.Revit.DB.CodeChecking..::..ExecutionContext
The context.

Return Value

true if context supported ; otherwise, false.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


LoadCasesAndCombinationsSupport Method

ICodeCheckingServer..::..LoadCasesAndCombinationsSupport Method
ICodeCheckingServer Interface See Also Send Feedback
Determines whether server supports load cases and combinations, they will be exposed on the dialog.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool LoadCasesAndCombinationsSupport()

Return Value

true if load combinations are supported; otherwise, false.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


ResultBuilderPackagesAsInputData Method

ICodeCheckingServer..::..ResultBuilderPackagesAsInputData Method
ICodeCheckingServer Interface See Also Send Feedback
Determines whether Results Builder packages will be treated as input data.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool ResultBuilderPackagesAsInputData()

Return Value

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


Verify Method

ICodeCheckingServer..::..Verify Method
ICodeCheckingServer Interface See Also Send Feedback
Runs calculation.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void Verify(
    ServiceData data
)

Parameters

data
Type: Autodesk.Revit.DB.CodeChecking..::..ServiceData
The current data.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace


Info Class

Info Class
Members See Also Send Feedback
Represents information notification

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Info : Notification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..Info

See Also

Info Members
Autodesk.Revit.DB.CodeChecking Namespace


Info Members

[image]

Structural Analysis and Code Checking API Reference Guide
Info Members
Info Class Constructors Methods Properties See Also Send Feedback

The Info type exposes the following members.

Constructors

 | Name | Description
Public method | Info | Initializes a new instance of the Info class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Overrides Notification..::..Level.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

Info Class
Autodesk.Revit.DB.CodeChecking Namespace


Info Constructor

Info Constructor
Info Class See Also Send Feedback
Initializes a new instance of the Info class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Info()

See Also

Info Class
Autodesk.Revit.DB.CodeChecking Namespace


Info Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Info Methods
Info Class See Also Send Feedback

The Info type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Info Class
Autodesk.Revit.DB.CodeChecking Namespace


Info Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Info Properties
Info Class See Also Send Feedback

The Info type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Overrides Notification..::..Level.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

Info Class
Autodesk.Revit.DB.CodeChecking Namespace


Level Property

Info..::..Level Property
Info Class See Also Send Feedback
Gets the level of notification.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override NotificationLevel Level { get; }

See Also

Info Class
Autodesk.Revit.DB.CodeChecking Namespace


MultiStructureServer Class

MultiStructureServer Class
Members See Also Send Feedback
The base class for all servers that support more than one category or material.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class MultiStructureServer : ICodeCheckingServer,
    IExternalServer

Remarks

It is strongly connected with DataStructurAttributes:ResultStructureAttribute, LabelStructureAttribute, CalculationParamsStructureAttribute

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..MultiStructureServer
Autodesk.Revit.DB.CodeChecking.Documentation..::..MultiStructureServer

See Also

MultiStructureServer Members
Autodesk.Revit.DB.CodeChecking Namespace


MultiStructureServer Members

[image]

Structural Analysis and Code Checking API Reference Guide
MultiStructureServer Members
MultiStructureServer Class Methods See Also Send Feedback

The MultiStructureServer type exposes the following members.

Methods

 | Name | Description
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one.
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one.
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationParamSchema | Returns schema for calculation parameters.
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity.
Public method | GetDefaultLabel | Returns default value of label entity.
Public method | GetDescription | Implement this method to return a description of the server.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSchema | Returns schema for labels.
Public method | GetName | Implement this method to return the name of the server.
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package.
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.
Public method | GetResultsSchema | Returns schema for results.
Public method | GetServerId | Implement this method to return the id of the server.
Public method | GetServiceId | Implement this method to return the id of the service.
Public method | GetSupportedCategories | Returns the list of supported categories.
Public method | GetSupportedMaterials | Returns the list of supported materials.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server.
Public method | GetVersion | Gets the version of code checking server.
Public method | IsContextSupported | Determines whether specified context is supported.
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load combinations, they will be exposed on the dialog.
Public method | ResultBuilderPackagesAsInputData | Determines whether server supports load combinations, they will be exposed on the dialog.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Runs calculation.

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


MultiStructureServer Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MultiStructureServer Methods
MultiStructureServer Class See Also Send Feedback

The MultiStructureServer type exposes the following members.

Methods

 | Name | Description
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one.
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one.
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationParamSchema | Returns schema for calculation parameters.
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity.
Public method | GetDefaultLabel | Returns default value of label entity.
Public method | GetDescription | Implement this method to return a description of the server.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSchema | Returns schema for labels.
Public method | GetName | Implement this method to return the name of the server.
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package.
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.
Public method | GetResultsSchema | Returns schema for results.
Public method | GetServerId | Implement this method to return the id of the server.
Public method | GetServiceId | Implement this method to return the id of the service.
Public method | GetSupportedCategories | Returns the list of supported categories.
Public method | GetSupportedMaterials | Returns the list of supported materials.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server.
Public method | GetVersion | Gets the version of code checking server.
Public method | IsContextSupported | Determines whether specified context is supported.
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load combinations, they will be exposed on the dialog.
Public method | ResultBuilderPackagesAsInputData | Determines whether server supports load combinations, they will be exposed on the dialog.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Runs calculation.

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


ConvertCalcParamsToCurrentVersion Method

MultiStructureServer..::..ConvertCalcParamsToCurrentVersion Method
MultiStructureServer Class See Also Send Feedback
Converts old version of calculation parameters entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity ConvertCalcParamsToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version of calculation parameters entity.
document
Type: Document
The document.

Return Value

The newest version of calculation parameters entity.

Implements

ICodeCheckingServer..::..ConvertCalcParamsToCurrentVersion(Entity, Document)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


ConvertLabelToCurrentVersion Method

MultiStructureServer..::..ConvertLabelToCurrentVersion Method
MultiStructureServer Class See Also Send Feedback
Converts old version of label entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity ConvertLabelToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version of label entity.
document
Type: Document
The document.

Return Value

The newest version of label entity.

Implements

ICodeCheckingServer..::..ConvertLabelToCurrentVersion(Entity, Document)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


ConvertResultToCurrentVersion Method

MultiStructureServer..::..ConvertResultToCurrentVersion Method
MultiStructureServer Class See Also Send Feedback
Converts old version of result entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity ConvertResultToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version of result entity.
document
Type: Document
The document.

Return Value

The newest version of result entity.

Implements

ICodeCheckingServer..::..ConvertResultToCurrentVersion(Entity, Document)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetCalculationParamSchema Method

MultiStructureServer..::..GetCalculationParamSchema Method
MultiStructureServer Class See Also Send Feedback
Returns schema for calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Schema GetCalculationParamSchema()

Return Value

Calculation parameters schema.

Implements

ICodeCheckingServer..::..GetCalculationParamSchema()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetDefaultCalcParams Method

MultiStructureServer..::..GetDefaultCalcParams Method
MultiStructureServer Class See Also Send Feedback
Returns default value of calculation parameters entity.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity GetDefaultCalcParams(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

The default value.

Implements

ICodeCheckingServer..::..GetDefaultCalcParams(Document)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetDefaultLabel Method

MultiStructureServer..::..GetDefaultLabel Method
MultiStructureServer Class See Also Send Feedback
Returns default value of label entity.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity GetDefaultLabel(
    Document document,
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

document
Type: Document
The document.
material
Type: StructuralAssetClass
The material.
category
Type: BuiltInCategory
The category.

Return Value

The default value.

Implements

ICodeCheckingServer..::..GetDefaultLabel(Document, StructuralAssetClass, BuiltInCategory)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetDescription Method

MultiStructureServer..::..GetDescription Method
MultiStructureServer Class See Also Send Feedback
Implement this method to return a description of the server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string GetDescription()

Return Value

Description of the server.

Implements

IExternalServerGetDescription()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetLabelSchema Method

MultiStructureServer..::..GetLabelSchema Method
MultiStructureServer Class See Also Send Feedback
Returns schema for labels.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Schema GetLabelSchema(
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

material
Type: StructuralAssetClass
category
Type: BuiltInCategory

Return Value

Labels schema.

Implements

ICodeCheckingServer..::..GetLabelSchema(StructuralAssetClass, BuiltInCategory)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetName Method

MultiStructureServer..::..GetName Method
MultiStructureServer Class See Also Send Feedback
Implement this method to return the name of the server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string GetName()

Return Value

Name of the server.

Implements

IExternalServerGetName()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetOutputPackageResultTypes Method

MultiStructureServer..::..GetOutputPackageResultTypes Method
MultiStructureServer Class See Also Send Feedback
Gets the output package result types. This information is needed to create proper ResultsBuilder Package.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual ResultsPackageTypes GetOutputPackageResultTypes()

Return Value

Implements

ICodeCheckingServer..::..GetOutputPackageResultTypes()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetOutputPackageUnitSystem Method

MultiStructureServer..::..GetOutputPackageUnitSystem Method
MultiStructureServer Class See Also Send Feedback
Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual UnitsSystem GetOutputPackageUnitSystem()

Return Value

Implements

ICodeCheckingServer..::..GetOutputPackageUnitSystem()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetResultsSchema Method

MultiStructureServer..::..GetResultsSchema Method
MultiStructureServer Class See Also Send Feedback
Returns schema for results.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Schema GetResultsSchema(
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

material
Type: StructuralAssetClass
category
Type: BuiltInCategory

Return Value

Results schema.

Implements

ICodeCheckingServer..::..GetResultsSchema(StructuralAssetClass, BuiltInCategory)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetServerId Method

MultiStructureServer..::..GetServerId Method
MultiStructureServer Class See Also Send Feedback
Implement this method to return the id of the server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract Guid GetServerId()

Return Value

The id of the server.

Implements

IExternalServerGetServerId()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetServiceId Method

MultiStructureServer..::..GetServiceId Method
MultiStructureServer Class See Also Send Feedback
Implement this method to return the id of the service.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual ExternalServiceId GetServiceId()

Return Value

The id of the service to which the server belongs.

Implements

IExternalServerGetServiceId()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetSupportedCategories Method

MultiStructureServer..::..GetSupportedCategories Method
MultiStructureServer Class See Also Send Feedback
Returns the list of supported categories.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract IList<BuiltInCategory> GetSupportedCategories(
    StructuralAssetClass material
)

Parameters

material
Type: StructuralAssetClass

Return Value

List of categories.

Implements

ICodeCheckingServer..::..GetSupportedCategories(StructuralAssetClass)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetSupportedMaterials Method

MultiStructureServer..::..GetSupportedMaterials Method
MultiStructureServer Class See Also Send Feedback
Returns the list of supported materials.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract IList<StructuralAssetClass> GetSupportedMaterials()

Return Value

List of materials.

Implements

ICodeCheckingServer..::..GetSupportedMaterials()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetVendorId Method

MultiStructureServer..::..GetVendorId Method
MultiStructureServer Class See Also Send Feedback
Implement this method to return the id of the vendor of the server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string GetVendorId()

Return Value

Vendor Id of the server.

Implements

IExternalServerGetVendorId()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


GetVersion Method

MultiStructureServer..::..GetVersion Method
MultiStructureServer Class See Also Send Feedback
Gets the version of code checking server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual int GetVersion()

Return Value

Implements

ICodeCheckingServer..::..GetVersion()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


IsContextSupported Method

MultiStructureServer..::..IsContextSupported Method
MultiStructureServer Class See Also Send Feedback
Determines whether specified context is supported.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool IsContextSupported(
    ExecutionContext context
)

Parameters

context
Type: Autodesk.Revit.DB.CodeChecking..::..ExecutionContext
The context.

Return Value

true if context supported ; otherwise, false.

Implements

ICodeCheckingServer..::..IsContextSupported(ExecutionContext)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


LoadCasesAndCombinationsSupport Method

MultiStructureServer..::..LoadCasesAndCombinationsSupport Method
MultiStructureServer Class See Also Send Feedback
Determines whether server supports load combinations, they will be exposed on the dialog.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool LoadCasesAndCombinationsSupport()

Return Value

true if load combinations are supported; otherwise, false.

Implements

ICodeCheckingServer..::..LoadCasesAndCombinationsSupport()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


ResultBuilderPackagesAsInputData Method

MultiStructureServer..::..ResultBuilderPackagesAsInputData Method
MultiStructureServer Class See Also Send Feedback
Determines whether server supports load combinations, they will be exposed on the dialog.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool ResultBuilderPackagesAsInputData()

Return Value

true if load combinations are supported; otherwise, false.

Implements

ICodeCheckingServer..::..ResultBuilderPackagesAsInputData()()()()

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


Verify Method

MultiStructureServer..::..Verify Method
MultiStructureServer Class See Also Send Feedback
Runs calculation.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract void Verify(
    ServiceData data
)

Parameters

data
Type: Autodesk.Revit.DB.CodeChecking..::..ServiceData
The current data.

Implements

ICodeCheckingServer..::..Verify(ServiceData)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace


Notification Class

Notification Class
Members See Also Send Feedback
Represents the base class for all notifications

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Notification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..Error
Autodesk.Revit.DB.CodeChecking..::..Info
Autodesk.Revit.DB.CodeChecking..::..ProgressNotification
Autodesk.Revit.DB.CodeChecking..::..Warning

See Also

Notification Members
Autodesk.Revit.DB.CodeChecking Namespace


Notification Members

[image]

Structural Analysis and Code Checking API Reference Guide
Notification Members
Notification Class Methods Properties See Also Send Feedback

The Notification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets the level of notification.
Public property | Message | Gets or sets the message.
Public property | Session | Gets or sets the session for which notification was made.
Public property | Source | Gets or sets the source of notification.

See Also

Notification Class
Autodesk.Revit.DB.CodeChecking Namespace


Notification Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Notification Methods
Notification Class See Also Send Feedback

The Notification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Notification Class
Autodesk.Revit.DB.CodeChecking Namespace


Notification Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Notification Properties
Notification Class See Also Send Feedback

The Notification type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets the level of notification.
Public property | Message | Gets or sets the message.
Public property | Session | Gets or sets the session for which notification was made.
Public property | Source | Gets or sets the source of notification.

See Also

Notification Class
Autodesk.Revit.DB.CodeChecking Namespace


Level Property

Notification..::..Level Property
Notification Class See Also Send Feedback
Gets the level of notification.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract NotificationLevel Level { get; }

See Also

Notification Class
Autodesk.Revit.DB.CodeChecking Namespace


Message Property

Notification..::..Message Property
Notification Class See Also Send Feedback
Gets or sets the message.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Message { get; set; }

Field Value

The message.

See Also

Notification Class
Autodesk.Revit.DB.CodeChecking Namespace


Session Property

Notification..::..Session Property
Notification Class See Also Send Feedback
Gets or sets the session for which notification was made.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid Session { get; set; }

Field Value

The session.

See Also

Notification Class
Autodesk.Revit.DB.CodeChecking Namespace


Source Property

Notification..::..Source Property
Notification Class See Also Send Feedback
Gets or sets the source of notification.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Source { get; set; }

Field Value

The source.

See Also

Notification Class
Autodesk.Revit.DB.CodeChecking Namespace


NotificationAddedHandler Delegate

NotificationAddedHandler Delegate
See Also Send Feedback
The delagate for notifying about new notification in the system.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public delegate void NotificationAddedHandler(
    Notification notification
)

Parameters

notification
Type: Autodesk.Revit.DB.CodeChecking..::..Notification
The new notification.

See Also

Autodesk.Revit.DB.CodeChecking Namespace


NotificationLevel Enumeration

NotificationLevel Enumeration
See Also Send Feedback
Represents the level of notification

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum NotificationLevel

Members

Member name | Value | Description
error | 0 | Error
warning | 1 | Warning
info | 2 | Information

See Also

Autodesk.Revit.DB.CodeChecking Namespace


NotificationService Class

NotificationService Class
Members See Also Send Feedback
The center via which it is possible to register notifications

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static class NotificationService

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..NotificationService

See Also

NotificationService Members
Autodesk.Revit.DB.CodeChecking Namespace


NotificationService Members

[image]

Structural Analysis and Code Checking API Reference Guide
NotificationService Members
NotificationService Class Methods Events See Also Send Feedback

The NotificationService type exposes the following members.

Methods

Name | Description
AddError | Adds the error.
AddInfo | Adds the info.
AddSynchronizationInfo | Adds the information about synchronization.
AddWarning | Adds the warning.
EndSession | Ends the current session.
GetNotifications()()()() | Gets the list of notifications in current session.
GetNotifications(Guid) | Gets the list of notifications in session.
ProgressAllCodes | Progresses all codes.
ProgressBreak | Break current action requirement.
ProgressBreakInvoked | Informs if there was progress break requirment invoked.
ProgressEnd | Informs that progress has ended.
ProgressNotification | Informs that there was made additional step in current progress.
ProgressStart | Informs that progress of some action has started.
ProgressStatus | Informs that there was made additional step in current progress.
ProgressStep | Informs that there was made additional step in current progress.
ProgressTitle | Informs that there was made additional step in current progress.
StartNewSession()()()() | Starts the new session.
StartNewSession(Guid) | Starts the new session.

Events

Name | Description
NotificationAdded | Occurs when notification was added.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


NotificationService Methods

[image]

Structural Analysis and Code Checking API Reference Guide
NotificationService Methods
NotificationService Class See Also Send Feedback

The NotificationService type exposes the following members.

Methods

Name | Description
AddError | Adds the error.
AddInfo | Adds the info.
AddSynchronizationInfo | Adds the information about synchronization.
AddWarning | Adds the warning.
EndSession | Ends the current session.
GetNotifications()()()() | Gets the list of notifications in current session.
GetNotifications(Guid) | Gets the list of notifications in session.
ProgressAllCodes | Progresses all codes.
ProgressBreak | Break current action requirement.
ProgressBreakInvoked | Informs if there was progress break requirment invoked.
ProgressEnd | Informs that progress has ended.
ProgressNotification | Informs that there was made additional step in current progress.
ProgressStart | Informs that progress of some action has started.
ProgressStatus | Informs that there was made additional step in current progress.
ProgressStep | Informs that there was made additional step in current progress.
ProgressTitle | Informs that there was made additional step in current progress.
StartNewSession()()()() | Starts the new session.
StartNewSession(Guid) | Starts the new session.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


AddError Method

NotificationService..::..AddError Method
NotificationService Class See Also Send Feedback
Adds the error.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void AddError(
    string message,
    string source
)

Parameters

message
Type: System..::..String
The message.
source
Type: System..::..String
The source.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


AddInfo Method

NotificationService..::..AddInfo Method
NotificationService Class See Also Send Feedback
Adds the info.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void AddInfo(
    string message,
    string source
)

Parameters

message
Type: System..::..String
The message.
source
Type: System..::..String
The source.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


AddSynchronizationInfo Method

NotificationService..::..AddSynchronizationInfo Method
NotificationService Class See Also Send Feedback
Adds the information about synchronization.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void AddSynchronizationInfo(
    string message,
    string source,
    bool synchronize
)

Parameters

message
Type: System..::..String
The message.
source
Type: System..::..String
The source.
synchronize
Type: System..::..Boolean
if set to true synchronization will be performed.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


AddWarning Method

NotificationService..::..AddWarning Method
NotificationService Class See Also Send Feedback
Adds the warning.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void AddWarning(
    string message,
    string source
)

Parameters

message
Type: System..::..String
The message.
source
Type: System..::..String
The source.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


EndSession Method

NotificationService..::..EndSession Method
NotificationService Class See Also Send Feedback
Ends the current session.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void EndSession()

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


GetNotifications Method

[image]

Structural Analysis and Code Checking API Reference Guide
NotificationService..::..GetNotifications Method
NotificationService Class See Also Send Feedback

Overload List

Name | Description
GetNotifications()()()() | Gets the list of notifications in current session.
GetNotifications(Guid) | Gets the list of notifications in session.

See Also

NotificationService Class
NotificationService Members
Autodesk.Revit.DB.CodeChecking Namespace


GetNotifications Method

NotificationService..::..GetNotifications Method
NotificationService Class See Also Send Feedback
Gets the list of notifications in current session.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<Notification> GetNotifications()

Return Value

See Also

NotificationService Class
GetNotifications Overload
Autodesk.Revit.DB.CodeChecking Namespace


GetNotifications Method (Guid)

NotificationService..::..GetNotifications Method (Guid)
NotificationService Class See Also Send Feedback
Gets the list of notifications in session.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<Notification> GetNotifications(
    Guid session
)

Parameters

session
Type: System..::..Guid
The session.

Return Value

See Also

NotificationService Class
GetNotifications Overload
Autodesk.Revit.DB.CodeChecking Namespace


ProgressAllCodes Method

NotificationService..::..ProgressAllCodes Method
NotificationService Class See Also Send Feedback
Progresses all codes.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ProgressAllCodes(
    Dictionary<string, string> allCodes,
    bool throwProgressBreakException
)

Parameters

allCodes
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
All codes.
throwProgressBreakException
Type: System..::..Boolean
if set to true [throw progress break exception].

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreak Method

NotificationService..::..ProgressBreak Method
NotificationService Class See Also Send Feedback
Break current action requirement.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ProgressBreak()

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreakInvoked Method

NotificationService..::..ProgressBreakInvoked Method
NotificationService Class See Also Send Feedback
Informs if there was progress break requirment invoked.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool ProgressBreakInvoked()

Return Value

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressEnd Method

NotificationService..::..ProgressEnd Method
NotificationService Class See Also Send Feedback
Informs that progress has ended.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ProgressEnd()

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressNotification Method

NotificationService..::..ProgressNotification Method
NotificationService Class See Also Send Feedback
Informs that there was made additional step in current progress.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ProgressNotification(
    string message,
    string source,
    bool throwProgressBreakException
)

Parameters

message
Type: System..::..String
The message.
source
Type: System..::..String
The source.
throwProgressBreakException
Type: System..::..Boolean
if set to true the ProgressBreakException will be thrown if there is such requirement on the stack.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStart Method

NotificationService..::..ProgressStart Method
NotificationService Class See Also Send Feedback
Informs that progress of some action has started.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ProgressStart(
    string title,
    int stepsCount,
    string source
)

Parameters

title
Type: System..::..String
The title.
stepsCount
Type: System..::..Int32
The number of steps.
source
Type: System..::..String
The source.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatus Method

NotificationService..::..ProgressStatus Method
NotificationService Class See Also Send Feedback
Informs that there was made additional step in current progress.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ProgressStatus(
    string status,
    string source,
    bool throwProgressBreakException
)

Parameters

status
Type: System..::..String
The status.
source
Type: System..::..String
The source.
throwProgressBreakException
Type: System..::..Boolean
if set to true [throw progress break exception].

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStep Method

NotificationService..::..ProgressStep Method
NotificationService Class See Also Send Feedback
Informs that there was made additional step in current progress.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ProgressStep(
    string message,
    string source,
    bool throwProgressBreakException
)

Parameters

message
Type: System..::..String
The message.
source
Type: System..::..String
The source.
throwProgressBreakException
Type: System..::..Boolean
if set to true the ProgressBreakException will be thrown if there is such requirement on the stack.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressTitle Method

NotificationService..::..ProgressTitle Method
NotificationService Class See Also Send Feedback
Informs that there was made additional step in current progress.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ProgressTitle(
    string title,
    string source,
    bool throwProgressBreakException
)

Parameters

title
Type: System..::..String
The title.
source
Type: System..::..String
The source.
throwProgressBreakException
Type: System..::..Boolean
if set to true [throw progress break exception].

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


StartNewSession Method

[image]

Structural Analysis and Code Checking API Reference Guide
NotificationService..::..StartNewSession Method
NotificationService Class See Also Send Feedback

Overload List

Name | Description
StartNewSession()()()() | Starts the new session.
StartNewSession(Guid) | Starts the new session.

See Also

NotificationService Class
NotificationService Members
Autodesk.Revit.DB.CodeChecking Namespace


StartNewSession Method

NotificationService..::..StartNewSession Method
NotificationService Class See Also Send Feedback
Starts the new session.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void StartNewSession()

See Also

NotificationService Class
StartNewSession Overload
Autodesk.Revit.DB.CodeChecking Namespace


StartNewSession Method (Guid)

NotificationService..::..StartNewSession Method (Guid)
NotificationService Class See Also Send Feedback
Starts the new session.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void StartNewSession(
    Guid session
)

Parameters

session
Type: System..::..Guid
The session identifier.

See Also

NotificationService Class
StartNewSession Overload
Autodesk.Revit.DB.CodeChecking Namespace


NotificationService Events

[image]

Structural Analysis and Code Checking API Reference Guide
NotificationService Events
NotificationService Class See Also Send Feedback

The NotificationService type exposes the following members.

Events

Name | Description
NotificationAdded | Occurs when notification was added.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


NotificationAdded Event

NotificationService..::..NotificationAdded Event
NotificationService Class See Also Send Feedback
Occurs when notification was added.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static event NotificationAddedHandler NotificationAdded

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreak Class

ProgressBreak Class
Members See Also Send Feedback
Represents progress break requirement

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ProgressBreak : ProgressNotification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..ProgressNotification
Autodesk.Revit.DB.CodeChecking..::..ProgressBreak

See Also

ProgressBreak Members
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreak Members

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressBreak Members
ProgressBreak Class Constructors Methods Properties See Also Send Feedback

The ProgressBreak type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressBreak | Initializes a new instance of the ProgressBreak class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

ProgressBreak Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreak Constructor

ProgressBreak Constructor
ProgressBreak Class See Also Send Feedback
Initializes a new instance of the ProgressBreak class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ProgressBreak()

See Also

ProgressBreak Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreak Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressBreak Methods
ProgressBreak Class See Also Send Feedback

The ProgressBreak type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProgressBreak Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreak Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressBreak Properties
ProgressBreak Class See Also Send Feedback

The ProgressBreak type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

ProgressBreak Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreakException Class

ProgressBreakException Class
Members See Also Send Feedback
The exception used for breaking current action

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ProgressBreakException : Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.DB.CodeChecking..::..ProgressBreakException

See Also

ProgressBreakException Members
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreakException Members

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressBreakException Members
ProgressBreakException Class Constructors Methods Properties See Also Send Feedback

The ProgressBreakException type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressBreakException | Initializes a new instance of the ProgressBreakException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProgressBreakException Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreakException Constructor

ProgressBreakException Constructor
ProgressBreakException Class See Also Send Feedback
Initializes a new instance of the ProgressBreakException class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ProgressBreakException()

See Also

ProgressBreakException Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreakException Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressBreakException Methods
ProgressBreakException Class See Also Send Feedback

The ProgressBreakException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ProgressBreakException Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressBreakException Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressBreakException Properties
ProgressBreakException Class See Also Send Feedback

The ProgressBreakException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProgressBreakException Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressEnd Class

ProgressEnd Class
Members See Also Send Feedback
Informs about end of current action

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ProgressEnd : ProgressNotification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..ProgressNotification
Autodesk.Revit.DB.CodeChecking..::..ProgressEnd

See Also

ProgressEnd Members
Autodesk.Revit.DB.CodeChecking Namespace


ProgressEnd Members

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressEnd Members
ProgressEnd Class Constructors Methods Properties See Also Send Feedback

The ProgressEnd type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressEnd | Initializes a new instance of the ProgressEnd class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

ProgressEnd Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressEnd Constructor

ProgressEnd Constructor
ProgressEnd Class See Also Send Feedback
Initializes a new instance of the ProgressEnd class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ProgressEnd()

See Also

ProgressEnd Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressEnd Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressEnd Methods
ProgressEnd Class See Also Send Feedback

The ProgressEnd type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProgressEnd Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressEnd Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressEnd Properties
ProgressEnd Class See Also Send Feedback

The ProgressEnd type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

ProgressEnd Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressNotification Class

ProgressNotification Class
Members See Also Send Feedback
Base class for all progress notifications

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class ProgressNotification : Notification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..ProgressNotification
Autodesk.Revit.DB.CodeChecking..::..ProgressBreak
Autodesk.Revit.DB.CodeChecking..::..ProgressEnd
Autodesk.Revit.DB.CodeChecking..::..ProgressStart
Autodesk.Revit.DB.CodeChecking..::..ProgressStatus
Autodesk.Revit.DB.CodeChecking..::..ProgressStep

See Also

ProgressNotification Members
Autodesk.Revit.DB.CodeChecking Namespace


ProgressNotification Members

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressNotification Members
ProgressNotification Class Methods Properties See Also Send Feedback

The ProgressNotification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Overrides Notification..::..Level.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

ProgressNotification Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressNotification Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressNotification Methods
ProgressNotification Class See Also Send Feedback

The ProgressNotification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProgressNotification Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressNotification Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressNotification Properties
ProgressNotification Class See Also Send Feedback

The ProgressNotification type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Overrides Notification..::..Level.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

ProgressNotification Class
Autodesk.Revit.DB.CodeChecking Namespace


Level Property

ProgressNotification..::..Level Property
ProgressNotification Class See Also Send Feedback
Gets the level of notification.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override NotificationLevel Level { get; }

See Also

ProgressNotification Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStart Class

ProgressStart Class
Members See Also Send Feedback
Informs about progress start.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ProgressStart : ProgressNotification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..ProgressNotification
Autodesk.Revit.DB.CodeChecking..::..ProgressStart

See Also

ProgressStart Members
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStart Members

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStart Members
ProgressStart Class Constructors Methods Properties See Also Send Feedback

The ProgressStart type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressStart | Initializes a new instance of the ProgressStart class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | Gets or sets the code.
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | NumberOfSteps | Number of predicted steps of the process.
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title.

See Also

ProgressStart Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStart Constructor

ProgressStart Constructor
ProgressStart Class See Also Send Feedback
Initializes a new instance of the ProgressStart class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ProgressStart()

See Also

ProgressStart Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStart Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStart Methods
ProgressStart Class See Also Send Feedback

The ProgressStart type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProgressStart Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStart Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStart Properties
ProgressStart Class See Also Send Feedback

The ProgressStart type exposes the following members.

Properties

 | Name | Description
Public property | Code | Gets or sets the code.
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | NumberOfSteps | Number of predicted steps of the process.
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title.

See Also

ProgressStart Class
Autodesk.Revit.DB.CodeChecking Namespace


Code Property

ProgressStart..::..Code Property
ProgressStart Class See Also Send Feedback
Gets or sets the code.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Code { get; set; }

Field Value

The code.

See Also

ProgressStart Class
Autodesk.Revit.DB.CodeChecking Namespace


NumberOfSteps Property

ProgressStart..::..NumberOfSteps Property
ProgressStart Class See Also Send Feedback
Number of predicted steps of the process.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int NumberOfSteps { get; set; }

See Also

ProgressStart Class
Autodesk.Revit.DB.CodeChecking Namespace


Title Property

ProgressStart..::..Title Property
ProgressStart Class See Also Send Feedback
Gets or sets the title.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Title { get; set; }

Field Value

The title.

See Also

ProgressStart Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatus Class

ProgressStatus Class
Members See Also Send Feedback
Informs about progress status.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ProgressStatus : ProgressNotification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..ProgressNotification
Autodesk.Revit.DB.CodeChecking..::..ProgressStatus
Autodesk.Revit.DB.CodeChecking..::..ProgressStatusAllCodes
Autodesk.Revit.DB.CodeChecking..::..ProgressStatusCode
Autodesk.Revit.DB.CodeChecking..::..ProgressStatusCodeSummary

See Also

ProgressStatus Members
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatus Members

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatus Members
ProgressStatus Class Constructors Methods Properties See Also Send Feedback

The ProgressStatus type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressStatus | Initializes a new instance of the ProgressStatus class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | Gets or sets the code.
Public property | Errors | Gets or sets the errors.
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Messages | Gets or sets the messages.
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title.
Public property | Warnings | Gets or sets the warnings.

See Also

ProgressStatus Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatus Constructor

ProgressStatus Constructor
ProgressStatus Class See Also Send Feedback
Initializes a new instance of the ProgressStatus class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ProgressStatus()

See Also

ProgressStatus Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatus Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatus Methods
ProgressStatus Class See Also Send Feedback

The ProgressStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProgressStatus Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatus Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatus Properties
ProgressStatus Class See Also Send Feedback

The ProgressStatus type exposes the following members.

Properties

 | Name | Description
Public property | Code | Gets or sets the code.
Public property | Errors | Gets or sets the errors.
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Messages | Gets or sets the messages.
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title.
Public property | Warnings | Gets or sets the warnings.

See Also

ProgressStatus Class
Autodesk.Revit.DB.CodeChecking Namespace


Code Property

ProgressStatus..::..Code Property
ProgressStatus Class See Also Send Feedback
Gets or sets the code.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Code { get; set; }

Field Value

The code.

See Also

ProgressStatus Class
Autodesk.Revit.DB.CodeChecking Namespace


Errors Property

ProgressStatus..::..Errors Property
ProgressStatus Class See Also Send Feedback
Gets or sets the errors.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<string> Errors { get; set; }

Field Value

The errors.

See Also

ProgressStatus Class
Autodesk.Revit.DB.CodeChecking Namespace


Messages Property

ProgressStatus..::..Messages Property
ProgressStatus Class See Also Send Feedback
Gets or sets the messages.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<string> Messages { get; set; }

Field Value

The messages.

See Also

ProgressStatus Class
Autodesk.Revit.DB.CodeChecking Namespace


Title Property

ProgressStatus..::..Title Property
ProgressStatus Class See Also Send Feedback
Gets or sets the title.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Title { get; set; }

Field Value

The title.

See Also

ProgressStatus Class
Autodesk.Revit.DB.CodeChecking Namespace


Warnings Property

ProgressStatus..::..Warnings Property
ProgressStatus Class See Also Send Feedback
Gets or sets the warnings.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<string> Warnings { get; set; }

Field Value

The warnings.

See Also

ProgressStatus Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusAllCodes Class

ProgressStatusAllCodes Class
Members See Also Send Feedback
Informs about all codes.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ProgressStatusAllCodes : ProgressStatus

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..ProgressNotification
Autodesk.Revit.DB.CodeChecking..::..ProgressStatus
Autodesk.Revit.DB.CodeChecking..::..ProgressStatusAllCodes

See Also

ProgressStatusAllCodes Members
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusAllCodes Members

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatusAllCodes Members
ProgressStatusAllCodes Class Constructors Methods Properties See Also Send Feedback

The ProgressStatusAllCodes type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressStatusAllCodes | Initializes a new instance of the ProgressStatusAllCodes class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllCodes | Gets or sets all codes.
Public property | Code | Gets or sets the code. (Inherited from ProgressStatus.)
Public property | Errors | Gets or sets the errors. (Inherited from ProgressStatus.)
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Messages | Gets or sets the messages. (Inherited from ProgressStatus.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title. (Inherited from ProgressStatus.)
Public property | Warnings | Gets or sets the warnings. (Inherited from ProgressStatus.)

See Also

ProgressStatusAllCodes Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusAllCodes Constructor

ProgressStatusAllCodes Constructor
ProgressStatusAllCodes Class See Also Send Feedback
Initializes a new instance of the ProgressStatusAllCodes class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ProgressStatusAllCodes()

See Also

ProgressStatusAllCodes Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusAllCodes Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatusAllCodes Methods
ProgressStatusAllCodes Class See Also Send Feedback

The ProgressStatusAllCodes type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProgressStatusAllCodes Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusAllCodes Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatusAllCodes Properties
ProgressStatusAllCodes Class See Also Send Feedback

The ProgressStatusAllCodes type exposes the following members.

Properties

 | Name | Description
Public property | AllCodes | Gets or sets all codes.
Public property | Code | Gets or sets the code. (Inherited from ProgressStatus.)
Public property | Errors | Gets or sets the errors. (Inherited from ProgressStatus.)
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Messages | Gets or sets the messages. (Inherited from ProgressStatus.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title. (Inherited from ProgressStatus.)
Public property | Warnings | Gets or sets the warnings. (Inherited from ProgressStatus.)

See Also

ProgressStatusAllCodes Class
Autodesk.Revit.DB.CodeChecking Namespace


AllCodes Property

ProgressStatusAllCodes..::..AllCodes Property
ProgressStatusAllCodes Class See Also Send Feedback
Gets or sets all codes.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Dictionary<string, string> AllCodes { get; set; }

Field Value

All codes.

See Also

ProgressStatusAllCodes Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusCode Class

ProgressStatusCode Class
Members See Also Send Feedback
Informs about progress status.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ProgressStatusCode : ProgressStatus

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..ProgressNotification
Autodesk.Revit.DB.CodeChecking..::..ProgressStatus
Autodesk.Revit.DB.CodeChecking..::..ProgressStatusCode

See Also

ProgressStatusCode Members
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusCode Members

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatusCode Members
ProgressStatusCode Class Constructors Methods Properties See Also Send Feedback

The ProgressStatusCode type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressStatusCode | Initializes a new instance of the ProgressStatusCode class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | Gets or sets the code. (Inherited from ProgressStatus.)
Public property | Errors | Gets or sets the errors. (Inherited from ProgressStatus.)
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Messages | Gets or sets the messages. (Inherited from ProgressStatus.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title. (Inherited from ProgressStatus.)
Public property | Warnings | Gets or sets the warnings. (Inherited from ProgressStatus.)

See Also

ProgressStatusCode Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusCode Constructor

ProgressStatusCode Constructor
ProgressStatusCode Class See Also Send Feedback
Initializes a new instance of the ProgressStatusCode class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ProgressStatusCode()

See Also

ProgressStatusCode Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusCode Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatusCode Methods
ProgressStatusCode Class See Also Send Feedback

The ProgressStatusCode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProgressStatusCode Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusCode Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatusCode Properties
ProgressStatusCode Class See Also Send Feedback

The ProgressStatusCode type exposes the following members.

Properties

 | Name | Description
Public property | Code | Gets or sets the code. (Inherited from ProgressStatus.)
Public property | Errors | Gets or sets the errors. (Inherited from ProgressStatus.)
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Messages | Gets or sets the messages. (Inherited from ProgressStatus.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title. (Inherited from ProgressStatus.)
Public property | Warnings | Gets or sets the warnings. (Inherited from ProgressStatus.)

See Also

ProgressStatusCode Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusCodeSummary Class

ProgressStatusCodeSummary Class
Members See Also Send Feedback
Informs about progress status.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ProgressStatusCodeSummary : ProgressStatus

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..ProgressNotification
Autodesk.Revit.DB.CodeChecking..::..ProgressStatus
Autodesk.Revit.DB.CodeChecking..::..ProgressStatusCodeSummary

See Also

ProgressStatusCodeSummary Members
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusCodeSummary Members

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatusCodeSummary Members
ProgressStatusCodeSummary Class Constructors Methods Properties See Also Send Feedback

The ProgressStatusCodeSummary type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressStatusCodeSummary | Initializes a new instance of the ProgressStatusCodeSummary class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | Gets or sets the code. (Inherited from ProgressStatus.)
Public property | Errors | Gets or sets the errors. (Inherited from ProgressStatus.)
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Messages | Gets or sets the messages. (Inherited from ProgressStatus.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title. (Inherited from ProgressStatus.)
Public property | Warnings | Gets or sets the warnings. (Inherited from ProgressStatus.)

See Also

ProgressStatusCodeSummary Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusCodeSummary Constructor

ProgressStatusCodeSummary Constructor
ProgressStatusCodeSummary Class See Also Send Feedback
Initializes a new instance of the ProgressStatusCodeSummary class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ProgressStatusCodeSummary()

See Also

ProgressStatusCodeSummary Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusCodeSummary Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatusCodeSummary Methods
ProgressStatusCodeSummary Class See Also Send Feedback

The ProgressStatusCodeSummary type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProgressStatusCodeSummary Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStatusCodeSummary Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStatusCodeSummary Properties
ProgressStatusCodeSummary Class See Also Send Feedback

The ProgressStatusCodeSummary type exposes the following members.

Properties

 | Name | Description
Public property | Code | Gets or sets the code. (Inherited from ProgressStatus.)
Public property | Errors | Gets or sets the errors. (Inherited from ProgressStatus.)
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Messages | Gets or sets the messages. (Inherited from ProgressStatus.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title. (Inherited from ProgressStatus.)
Public property | Warnings | Gets or sets the warnings. (Inherited from ProgressStatus.)

See Also

ProgressStatusCodeSummary Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStep Class

ProgressStep Class
Members See Also Send Feedback
Informs about progress next step.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ProgressStep : ProgressNotification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..ProgressNotification
Autodesk.Revit.DB.CodeChecking..::..ProgressStep

See Also

ProgressStep Members
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStep Members

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStep Members
ProgressStep Class Constructors Methods Properties See Also Send Feedback

The ProgressStep type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressStep | Initializes a new instance of the ProgressStep class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | Gets or sets the code.
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title.

See Also

ProgressStep Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStep Constructor

ProgressStep Constructor
ProgressStep Class See Also Send Feedback
Initializes a new instance of the ProgressStep class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ProgressStep()

See Also

ProgressStep Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStep Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStep Methods
ProgressStep Class See Also Send Feedback

The ProgressStep type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProgressStep Class
Autodesk.Revit.DB.CodeChecking Namespace


ProgressStep Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ProgressStep Properties
ProgressStep Class See Also Send Feedback

The ProgressStep type exposes the following members.

Properties

 | Name | Description
Public property | Code | Gets or sets the code.
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title.

See Also

ProgressStep Class
Autodesk.Revit.DB.CodeChecking Namespace


Code Property

ProgressStep..::..Code Property
ProgressStep Class See Also Send Feedback
Gets or sets the code.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Code { get; set; }

Field Value

The code.

See Also

ProgressStep Class
Autodesk.Revit.DB.CodeChecking Namespace


Title Property

ProgressStep..::..Title Property
ProgressStep Class See Also Send Feedback
Gets or sets the title.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Title { get; set; }

Field Value

The title.

See Also

ProgressStep Class
Autodesk.Revit.DB.CodeChecking Namespace


Server(TCalculationParam, TLabel, TResult) Class

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Members See Also Send Feedback
Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform. It is dedicated for servers which provides one description for labels and results.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Server<TCalculationParam, TLabel, TResult> : ICodeCheckingServer,
    IExternalServer
where TCalculationParam : new(), SchemaClass
where TLabel : new(), SchemaClass
where TResult : new(), SchemaClass

Type Parameters

TCalculationParam
The class representing calculation parameters.
TLabel
The class representing labels.
TResult
The class representing results.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>
Autodesk.Revit.DB.CodeChecking.Documentation..::..Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Members
Autodesk.Revit.DB.CodeChecking Namespace


Server(TCalculationParam, TLabel, TResult) Members

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Members
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class Methods See Also Send Feedback

The Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one.
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one.
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationParamSchema | Returns schema for calculation parameters.
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity.
Public method | GetDefaultLabel | Returns default value of label entity.
Public method | GetDescription | Implement this method to return a description of the server.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSchema | Returns schema for labels.
Public method | GetName | Implement this method to return the name of the server.
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package.
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.
Public method | GetResultsSchema | Returns schema for results.
Public method | GetServerId | Implement this method to return the id of the server.
Public method | GetServiceId | Implement this method to return the id of the service.
Public method | GetSupportedCategories | Returns the list of supported categories.
Public method | GetSupportedMaterials | Returns the list of supported materials.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server.
Public method | GetVersion | Gets the version of code checking server.
Public method | IsContextSupported | Determines whether specified context is supported.
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load combinations, they will be exposed on the dialog.
Public method | ResultBuilderPackagesAsInputData | Determines whether server supports load combinations, they will be exposed on the dialog.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Runs calculation.

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


Server(TCalculationParam, TLabel, TResult) Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Methods
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback

The Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one.
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one.
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationParamSchema | Returns schema for calculation parameters.
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity.
Public method | GetDefaultLabel | Returns default value of label entity.
Public method | GetDescription | Implement this method to return a description of the server.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSchema | Returns schema for labels.
Public method | GetName | Implement this method to return the name of the server.
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package.
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.
Public method | GetResultsSchema | Returns schema for results.
Public method | GetServerId | Implement this method to return the id of the server.
Public method | GetServiceId | Implement this method to return the id of the service.
Public method | GetSupportedCategories | Returns the list of supported categories.
Public method | GetSupportedMaterials | Returns the list of supported materials.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server.
Public method | GetVersion | Gets the version of code checking server.
Public method | IsContextSupported | Determines whether specified context is supported.
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load combinations, they will be exposed on the dialog.
Public method | ResultBuilderPackagesAsInputData | Determines whether server supports load combinations, they will be exposed on the dialog.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Runs calculation.

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


ConvertCalcParamsToCurrentVersion Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..ConvertCalcParamsToCurrentVersion Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Converts old version of calculation parameters entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity ConvertCalcParamsToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version of calculation parameters entity.
document
Type: Document
The document.

Return Value

The newest version of calculation parameters entity.

Implements

ICodeCheckingServer..::..ConvertCalcParamsToCurrentVersion(Entity, Document)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


ConvertLabelToCurrentVersion Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..ConvertLabelToCurrentVersion Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Converts old version of label entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity ConvertLabelToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version of label entity.
document
Type: Document
The document.

Return Value

The newest version of label entity.

Implements

ICodeCheckingServer..::..ConvertLabelToCurrentVersion(Entity, Document)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


ConvertResultToCurrentVersion Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..ConvertResultToCurrentVersion Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Converts old version of result entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity ConvertResultToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version of result entity.
document
Type: Document
The document.

Return Value

The newest version of result entity.

Implements

ICodeCheckingServer..::..ConvertResultToCurrentVersion(Entity, Document)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetCalculationParamSchema Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetCalculationParamSchema Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Returns schema for calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Schema GetCalculationParamSchema()

Return Value

Calculation parameters schema.

Implements

ICodeCheckingServer..::..GetCalculationParamSchema()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetDefaultCalcParams Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetDefaultCalcParams Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Returns default value of calculation parameters entity.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity GetDefaultCalcParams(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

The default value.

Implements

ICodeCheckingServer..::..GetDefaultCalcParams(Document)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetDefaultLabel Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetDefaultLabel Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Returns default value of label entity.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity GetDefaultLabel(
    Document document,
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

document
Type: Document
The document.
material
Type: StructuralAssetClass
The material.
category
Type: BuiltInCategory
The category.

Return Value

The default value.

Implements

ICodeCheckingServer..::..GetDefaultLabel(Document, StructuralAssetClass, BuiltInCategory)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetDescription Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetDescription Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Implement this method to return a description of the server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string GetDescription()

Return Value

Description of the server.

Implements

IExternalServerGetDescription()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetLabelSchema Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetLabelSchema Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Returns schema for labels.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Schema GetLabelSchema(
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

material
Type: StructuralAssetClass
category
Type: BuiltInCategory

Return Value

Labels schema.

Implements

ICodeCheckingServer..::..GetLabelSchema(StructuralAssetClass, BuiltInCategory)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetName Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetName Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Implement this method to return the name of the server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string GetName()

Return Value

Name of the server.

Implements

IExternalServerGetName()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetOutputPackageResultTypes Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetOutputPackageResultTypes Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Gets the output package result types. This information is needed to create proper ResultsBuilder Package.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual ResultsPackageTypes GetOutputPackageResultTypes()

Return Value

Implements

ICodeCheckingServer..::..GetOutputPackageResultTypes()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetOutputPackageUnitSystem Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetOutputPackageUnitSystem Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual UnitsSystem GetOutputPackageUnitSystem()

Return Value

Implements

ICodeCheckingServer..::..GetOutputPackageUnitSystem()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetResultsSchema Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetResultsSchema Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Returns schema for results.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Schema GetResultsSchema(
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

material
Type: StructuralAssetClass
category
Type: BuiltInCategory

Return Value

Results schema.

Implements

ICodeCheckingServer..::..GetResultsSchema(StructuralAssetClass, BuiltInCategory)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetServerId Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetServerId Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Implement this method to return the id of the server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract Guid GetServerId()

Return Value

The id of the server.

Implements

IExternalServerGetServerId()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetServiceId Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetServiceId Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Implement this method to return the id of the service.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual ExternalServiceId GetServiceId()

Return Value

The id of the service to which the server belongs.

Implements

IExternalServerGetServiceId()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetSupportedCategories Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetSupportedCategories Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Returns the list of supported categories.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract IList<BuiltInCategory> GetSupportedCategories(
    StructuralAssetClass material
)

Parameters

material
Type: StructuralAssetClass

Return Value

List of categories.

Implements

ICodeCheckingServer..::..GetSupportedCategories(StructuralAssetClass)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetSupportedMaterials Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetSupportedMaterials Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Returns the list of supported materials.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract IList<StructuralAssetClass> GetSupportedMaterials()

Return Value

List of materials.

Implements

ICodeCheckingServer..::..GetSupportedMaterials()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetVendorId Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetVendorId Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Implement this method to return the id of the vendor of the server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string GetVendorId()

Return Value

Vendor Id of the server.

Implements

IExternalServerGetVendorId()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


GetVersion Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetVersion Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Gets the version of code checking server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual int GetVersion()

Return Value

Implements

ICodeCheckingServer..::..GetVersion()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


IsContextSupported Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..IsContextSupported Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Determines whether specified context is supported.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool IsContextSupported(
    ExecutionContext context
)

Parameters

context
Type: Autodesk.Revit.DB.CodeChecking..::..ExecutionContext
The context.

Return Value

true if context supported ; otherwise, false.

Implements

ICodeCheckingServer..::..IsContextSupported(ExecutionContext)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


LoadCasesAndCombinationsSupport Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..LoadCasesAndCombinationsSupport Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Determines whether server supports load combinations, they will be exposed on the dialog.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool LoadCasesAndCombinationsSupport()

Return Value

true if load combinations are supported; otherwise, false.

Implements

ICodeCheckingServer..::..LoadCasesAndCombinationsSupport()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


ResultBuilderPackagesAsInputData Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..ResultBuilderPackagesAsInputData Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Determines whether server supports load combinations, they will be exposed on the dialog.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool ResultBuilderPackagesAsInputData()

Return Value

true if load combinations are supported; otherwise, false.

Implements

ICodeCheckingServer..::..ResultBuilderPackagesAsInputData()()()()

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


Verify Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..Verify Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Runs calculation.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract void Verify(
    ServiceData data
)

Parameters

data
Type: Autodesk.Revit.DB.CodeChecking..::..ServiceData
The current data.

Implements

ICodeCheckingServer..::..Verify(ServiceData)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace


ServerException Class

ServerException Class
Members See Also Send Feedback
Represents server exception

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServerException : Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.DB.CodeChecking..::..ServerException

See Also

ServerException Members
Autodesk.Revit.DB.CodeChecking Namespace


ServerException Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServerException Members
ServerException Class Constructors Methods Properties See Also Send Feedback

The ServerException type exposes the following members.

Constructors

 | Name | Description
Public method | ServerException | Initializes a new instance of the ServerException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Exception | Gets or sets the exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Method | Gets or sets the method.
Public property | ServerId | Gets or sets the server id.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServerException Class
Autodesk.Revit.DB.CodeChecking Namespace


ServerException Constructor

ServerException Constructor
ServerException Class See Also Send Feedback
Initializes a new instance of the ServerException class.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerException(
    Guid server,
    string method,
    Exception exception
)

Parameters

server
Type: System..::..Guid
The server.
method
Type: System..::..String
The method.
exception
Type: System..::..Exception
The exception.

See Also

ServerException Class
Autodesk.Revit.DB.CodeChecking Namespace


ServerException Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServerException Methods
ServerException Class See Also Send Feedback

The ServerException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ServerException Class
Autodesk.Revit.DB.CodeChecking Namespace


ServerException Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServerException Properties
ServerException Class See Also Send Feedback

The ServerException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Exception | Gets or sets the exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Method | Gets or sets the method.
Public property | ServerId | Gets or sets the server id.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServerException Class
Autodesk.Revit.DB.CodeChecking Namespace


Exception Property

ServerException..::..Exception Property
ServerException Class See Also Send Feedback
Gets or sets the exception.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Exception Exception { get; set; }

Field Value

The exception.

See Also

ServerException Class
Autodesk.Revit.DB.CodeChecking Namespace


Method Property

ServerException..::..Method Property
ServerException Class See Also Send Feedback
Gets or sets the method.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Method { get; set; }

Field Value

The method.

See Also

ServerException Class
Autodesk.Revit.DB.CodeChecking Namespace


ServerId Property

ServerException..::..ServerId Property
ServerException Class See Also Send Feedback
Gets or sets the server id.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid ServerId { get; set; }

Field Value

The server id.

See Also

ServerException Class
Autodesk.Revit.DB.CodeChecking Namespace


Service Class

Service Class
Members See Also Send Feedback
Represents the main service in the Code Checking Platform. It manages all Code Checking servers.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Service : IMultiServerService, IExternalService

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Service

See Also

Service Members
Autodesk.Revit.DB.CodeChecking Namespace


Service Members

[image]

Structural Analysis and Code Checking API Reference Guide
Service Members
Service Class Constructors Methods Fields See Also Send Feedback

The Service type exposes the following members.

Constructors

 | Name | Description
Public method | Service | Initializes a new instance of the Service class

Methods

 | Name | Description
 | AddServer | Register server in CCService
 | BlockServer | Blocks the server.
Public method | CanExecute | Returns permission for executing particular server
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ServiceData) | Executes given server.
 | Execute(Document, List<(Of <<'(Element>)>>), ExecutionContext) | Executes given server.
Public method | Execute(IExternalServer, Document, IExternalData) | Executes given server.
 | Execute(Document, List<(Of <<'(Element>)>>), Guid, ExecutionContext) | Executes given server.
 | ExecuteServer | Executes given server.
 | GetActiveServers | Returns list of active servers registered in CCService
 | GetActiveServersIds | Returns list of active servers registered in CCService
Public method | GetDescription | Returns the description
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the service.
 | GetServer | Returns server of specific id.
 | GetServers | Returns servers registered in Service
Public method | GetServiceId | Returns service ID
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendor | Return vendor.
Public method | GetVendorId | Reurns vendor Id of the service.
 | IsActive | Determines whether the specified server ID is active.
 | IsBlocked | Determines whether the specified server is blocked.
Public method | IsValidServer | Validates server.
Public method | OnServersChanged | Takes action when servers changes.
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.
 | RegisterService | Registers service in Revit
 | SetActiveServers | Sets active servers
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnBlockServer | Uns the block server.

Fields

Name | Description
ID | Unique Id of the Service

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


Service Constructor

Service Constructor
Service Class See Also Send Feedback
Initializes a new instance of the Service class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Service()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


Service Fields

[image]

Structural Analysis and Code Checking API Reference Guide
Service Fields
Service Class See Also Send Feedback

The Service type exposes the following members.

Fields

Name | Description
ID | Unique Id of the Service

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


ID Field

Service..::..ID Field
Service Class See Also Send Feedback
Unique Id of the Service

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ExternalServiceId ID

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


Service Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Service Methods
Service Class See Also Send Feedback

The Service type exposes the following members.

Methods

 | Name | Description
 | AddServer | Register server in CCService
 | BlockServer | Blocks the server.
Public method | CanExecute | Returns permission for executing particular server
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ServiceData) | Executes given server.
 | Execute(Document, List<(Of <<'(Element>)>>), ExecutionContext) | Executes given server.
Public method | Execute(IExternalServer, Document, IExternalData) | Executes given server.
 | Execute(Document, List<(Of <<'(Element>)>>), Guid, ExecutionContext) | Executes given server.
 | ExecuteServer | Executes given server.
 | GetActiveServers | Returns list of active servers registered in CCService
 | GetActiveServersIds | Returns list of active servers registered in CCService
Public method | GetDescription | Returns the description
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the service.
 | GetServer | Returns server of specific id.
 | GetServers | Returns servers registered in Service
Public method | GetServiceId | Returns service ID
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendor | Return vendor.
Public method | GetVendorId | Reurns vendor Id of the service.
 | IsActive | Determines whether the specified server ID is active.
 | IsBlocked | Determines whether the specified server is blocked.
Public method | IsValidServer | Validates server.
Public method | OnServersChanged | Takes action when servers changes.
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.
 | RegisterService | Registers service in Revit
 | SetActiveServers | Sets active servers
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnBlockServer | Uns the block server.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


AddServer Method

Service..::..AddServer Method
Service Class See Also Send Feedback
Register server in CCService

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void AddServer(
    ICodeCheckingServer server
)

Parameters

server
Type: Autodesk.Revit.DB.CodeChecking..::..ICodeCheckingServer
External server

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


BlockServer Method

Service..::..BlockServer Method
Service Class See Also Send Feedback
Blocks the server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void BlockServer(
    Guid server
)

Parameters

server
Type: System..::..Guid
The server.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


CanExecute Method

Service..::..CanExecute Method
Service Class See Also Send Feedback
Returns permission for executing particular server

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool CanExecute(
    IExternalServer server,
    Document document,
    IExternalData data
)

Parameters

server
Type: IExternalServer
The server.
document
Type: Document
The document.
data
Type: IExternalData
The data.

Return Value

Permission.

Implements

IMultiServerServiceCanExecute(IExternalServer, Document, IExternalData)

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


Execute Method

[image]

Structural Analysis and Code Checking API Reference Guide
Service..::..Execute Method
Service Class See Also Send Feedback

Overload List

 | Name | Description
 | Execute(ServiceData) | Executes given server.
 | Execute(Document, List<(Of <<'(Element>)>>), ExecutionContext) | Executes given server.
Public method | Execute(IExternalServer, Document, IExternalData) | Executes given server.
 | Execute(Document, List<(Of <<'(Element>)>>), Guid, ExecutionContext) | Executes given server.

See Also

Service Class
Service Members
Autodesk.Revit.DB.CodeChecking Namespace


Execute Method (ServiceData)

Service..::..Execute Method (ServiceData)
Service Class See Also Send Feedback
Executes given server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void Execute(
    ServiceData serviceData
)

Parameters

serviceData
Type: Autodesk.Revit.DB.CodeChecking..::..ServiceData
The service data.

See Also

Service Class
Execute Overload
Autodesk.Revit.DB.CodeChecking Namespace


Execute Method (, List(), ExecutionContext)

Service..::..Execute Method (, List<(Of <(<'>)>)>, ExecutionContext)
Service Class See Also Send Feedback
Executes given server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void Execute(
    Document document,
    List<Element> elements,
    ExecutionContext context
)

Parameters

document
Type: Document
The document.
elements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>
The list of elements.
context
Type: Autodesk.Revit.DB.CodeChecking..::..ExecutionContext
The context.

See Also

Service Class
Execute Overload
Autodesk.Revit.DB.CodeChecking Namespace


Execute Method (, , )

Service..::..Execute Method (, , )
Service Class See Also Send Feedback
Executes given server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Execute(
    IExternalServer server,
    Document document,
    IExternalData data
)

Parameters

server
Type: IExternalServer
The server.
document
Type: Document
The document.
data
Type: IExternalData
The data.

Return Value

Whether execution succeded.

Implements

IExternalServiceExecute(IExternalServer, Document, IExternalData)

See Also

Service Class
Execute Overload
Autodesk.Revit.DB.CodeChecking Namespace


Execute Method (, List(), Guid, ExecutionContext)

Service..::..Execute Method (, List<(Of <(<'>)>)>, Guid, ExecutionContext)
Service Class See Also Send Feedback
Executes given server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void Execute(
    Document document,
    List<Element> elements,
    Guid session,
    ExecutionContext context
)

Parameters

document
Type: Document
The document.
elements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>
The list of elements.
session
Type: System..::..Guid
The session.
context
Type: Autodesk.Revit.DB.CodeChecking..::..ExecutionContext
The context.

See Also

Service Class
Execute Overload
Autodesk.Revit.DB.CodeChecking Namespace


ExecuteServer Method

Service..::..ExecuteServer Method
Service Class See Also Send Feedback
Executes given server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ExecuteServer(
    Document document,
    List<Element> elements,
    Guid serverId,
    ExecutionContext context
)

Parameters

document
Type: Document
The document.
elements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>
The list of elements.
serverId
Type: System..::..Guid
The server id.
context
Type: Autodesk.Revit.DB.CodeChecking..::..ExecutionContext
The context.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


GetActiveServers Method

Service..::..GetActiveServers Method
Service Class See Also Send Feedback
Returns list of active servers registered in CCService

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<ICodeCheckingServer> GetActiveServers(
    Document document,
    bool wrap
)

Parameters

document
Type: Document
The document.
wrap
Type: System..::..Boolean
if set to true [wrap].

Return Value

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


GetActiveServersIds Method

Service..::..GetActiveServersIds Method
Service Class See Also Send Feedback
Returns list of active servers registered in CCService

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<Guid> GetActiveServersIds(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


GetDescription Method

Service..::..GetDescription Method
Service Class See Also Send Feedback
Returns the description

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetDescription()

Return Value

The description

Implements

IExternalServiceGetDescription()()()()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


GetName Method

Service..::..GetName Method
Service Class See Also Send Feedback
Gets the name of the service.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetName()

Return Value

The name.

Implements

IExternalServiceGetName()()()()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


GetServer Method

Service..::..GetServer Method
Service Class See Also Send Feedback
Returns server of specific id.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ICodeCheckingServer GetServer(
    Guid id,
    bool wrap
)

Parameters

id
Type: System..::..Guid
The id of the server.
wrap
Type: System..::..Boolean
if set to true the server will be wrapped in additional object.

Return Value

Returns the server.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


GetServers Method

Service..::..GetServers Method
Service Class See Also Send Feedback
Returns servers registered in Service

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<IExternalServer> GetServers(
    bool wrap
)

Parameters

wrap
Type: System..::..Boolean

Return Value

Return the list of servers

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


GetServiceId Method

Service..::..GetServiceId Method
Service Class See Also Send Feedback
Returns service ID

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ExternalServiceId GetServiceId()

Return Value

Service id

Implements

IExternalServiceGetServiceId()()()()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


GetVendor Method

Service..::..GetVendor Method
Service Class See Also Send Feedback
Return vendor.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetVendor()

Return Value

Vendor

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


GetVendorId Method

Service..::..GetVendorId Method
Service Class See Also Send Feedback
Reurns vendor Id of the service.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetVendorId()

Return Value

Implements

IExternalServiceGetVendorId()()()()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


IsActive Method

Service..::..IsActive Method
Service Class See Also Send Feedback
Determines whether the specified server ID is active.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool IsActive(
    Guid serverID,
    Document document
)

Parameters

serverID
Type: System..::..Guid
The server ID.
document
Type: Document
The document.

Return Value

true if the specified server ID is active; otherwise, false.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


IsBlocked Method

Service..::..IsBlocked Method
Service Class See Also Send Feedback
Determines whether the specified server is blocked.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool IsBlocked(
    Guid server
)

Parameters

server
Type: System..::..Guid
The server.

Return Value

true if the specified server is blocked; otherwise, false.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


IsValidServer Method

Service..::..IsValidServer Method
Service Class See Also Send Feedback
Validates server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsValidServer(
    IExternalServer server
)

Parameters

server
Type: IExternalServer
The server.

Return Value

Implements

IExternalServiceIsValidServer(IExternalServer)

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


OnServersChanged Method

Service..::..OnServersChanged Method
Service Class See Also Send Feedback
Takes action when servers changes.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void OnServersChanged(
    Document document,
    ServerChangeCause cause,
    IList<Guid> oldServers
)

Parameters

document
Type: Document
The document.
cause
Type: ServerChangeCause
The cause.
oldServers
Type: System.Collections.Generic..::..IList <(Of <(<' Guid >)>)>
The list of old servers.

Implements

IExternalServiceOnServersChanged(Document, ServerChangeCause, IList<(Of <<'(Guid>)>>))

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


OnServersDisparity Method

Service..::..OnServersDisparity Method
Service Class See Also Send Feedback
Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisparityResponse OnServersDisparity(
    Document document,
    IList<Guid> oldServers
)

Parameters

document
Type: Document
The coresponding document
oldServers
Type: System.Collections.Generic..::..IList <(Of <(<' Guid >)>)>
Ids of servers previously used in the document. Please note that the Ids may belong to servers that are currently not registered with the service.

Return Value

Return False if you want the framework to handle the situation; return True if the situation has already been handled.

Implements

IExternalServiceOnServersDisparity(Document, IList<(Of <<'(Guid>)>>))

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


RegisterService Method

Service..::..RegisterService Method
Service Class See Also Send Feedback
Registers service in Revit

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void RegisterService()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


SetActiveServers Method

Service..::..SetActiveServers Method
Service Class See Also Send Feedback
Sets active servers

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void SetActiveServers(
    IList<Guid> serverIds,
    Document document
)

Parameters

serverIds
Type: System.Collections.Generic..::..IList <(Of <(<' Guid >)>)>
List of servers Ids
document
Type: Document
The document.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


UnBlockServer Method

Service..::..UnBlockServer Method
Service Class See Also Send Feedback
Uns the block server.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void UnBlockServer(
    Guid server
)

Parameters

server
Type: System..::..Guid
The server.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace


ServiceData Class

ServiceData Class
Members See Also Send Feedback
Represents data used for exchanging information between Service and servers.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServiceData : IExternalData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..ServiceData

See Also

ServiceData Members
Autodesk.Revit.DB.CodeChecking Namespace


ServiceData Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceData Members
ServiceData Class Constructors Methods Properties See Also Send Feedback

The ServiceData type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceData | Initializes a new instance of the ServiceData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveServersDueToSelection | Gets or sets the active servers due to selection.
Public property | Context | Gets the context of execution.
Public property | Document | The active document.
Public property | Selection | Current document selection.
Public property | Session | Gets the current session.

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking Namespace


ServiceData Constructor

ServiceData Constructor
ServiceData Class See Also Send Feedback
Initializes a new instance of the ServiceData class.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServiceData(
    Guid session,
    ExecutionContext executionContext
)

Parameters

session
Type: System..::..Guid
The session.
executionContext
Type: Autodesk.Revit.DB.CodeChecking..::..ExecutionContext
The execution context.

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking Namespace


ServiceData Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceData Methods
ServiceData Class See Also Send Feedback

The ServiceData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking Namespace


ServiceData Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceData Properties
ServiceData Class See Also Send Feedback

The ServiceData type exposes the following members.

Properties

 | Name | Description
Public property | ActiveServersDueToSelection | Gets or sets the active servers due to selection.
Public property | Context | Gets the context of execution.
Public property | Document | The active document.
Public property | Selection | Current document selection.
Public property | Session | Gets the current session.

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking Namespace


ActiveServersDueToSelection Property

ServiceData..::..ActiveServersDueToSelection Property
ServiceData Class See Also Send Feedback
Gets or sets the active servers due to selection.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<ICodeCheckingServer> ActiveServersDueToSelection { get; set; }

Field Value

The active servers due to selection.

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking Namespace


Context Property

ServiceData..::..Context Property
ServiceData Class See Also Send Feedback
Gets the context of execution.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ExecutionContext Context { get; private set; }

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking Namespace


Document Property

ServiceData..::..Document Property
ServiceData Class See Also Send Feedback
The active document.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document Document { get; set; }

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking Namespace


Selection Property

ServiceData..::..Selection Property
ServiceData Class See Also Send Feedback
Current document selection.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Element> Selection { get; set; }

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking Namespace


Session Property

ServiceData..::..Session Property
ServiceData Class See Also Send Feedback
Gets the current session.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid Session { get; private set; }

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking Namespace


Tools Class

Tools Class
Members See Also Send Feedback
Helper class for common operations

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static class Tools

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Tools

See Also

Tools Members
Autodesk.Revit.DB.CodeChecking Namespace


Tools Members

[image]

Structural Analysis and Code Checking API Reference Guide
Tools Members
Tools Class Methods Properties See Also Send Feedback

The Tools type exposes the following members.

Methods

Name | Description
CategorizeElements | Categorizes elements based on material and category.
EnumHas | Determines if the enum value intersects with other enum value.
FilterElements(Document, array<BuiltInCategory>[]()[][]) | This method filters revit's elements by BuiltInCategory
FilterElements(Document, array<Type>[]()[][]) | This method filters revit's elements by Type
FilterElements(Document, List<(Of <<'(BuiltInCategory>)>>), List<(Of <<'(Type>)>>)) | This method filters revit's elements by BuiltInCategory
GetCategoryOfElement | Returns category of element.
GetClassMaterialOfElement | Gets the material class of the element.
GetDataStorage | Gets the data storage which contains specific schema inside.
GetDataStorageList | Gets the data storage list with data saved.
GetElementsWithDataOfSchema<(Of <<'(T>)>>)(Guid, Document) | Gets the elements with data of schema stored inside.
GetElementsWithDataOfSchema<(Of <<'(T>)>>)(Type, Document) | Gets the data storage.
GetMaterialOfElement | Gets the material assigned to element.
GetPhysicalElement | Gets the physical element if the input element is of analytical model type.
GetStructuralAssetClass | Gets the structural asset class.

Properties

Name | Description
IsJournalPlayback | Gets a value indicating whether this instance is journal playback.

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


Tools Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Tools Methods
Tools Class See Also Send Feedback

The Tools type exposes the following members.

Methods

Name | Description
CategorizeElements | Categorizes elements based on material and category.
EnumHas | Determines if the enum value intersects with other enum value.
FilterElements(Document, array<BuiltInCategory>[]()[][]) | This method filters revit's elements by BuiltInCategory
FilterElements(Document, array<Type>[]()[][]) | This method filters revit's elements by Type
FilterElements(Document, List<(Of <<'(BuiltInCategory>)>>), List<(Of <<'(Type>)>>)) | This method filters revit's elements by BuiltInCategory
GetCategoryOfElement | Returns category of element.
GetClassMaterialOfElement | Gets the material class of the element.
GetDataStorage | Gets the data storage which contains specific schema inside.
GetDataStorageList | Gets the data storage list with data saved.
GetElementsWithDataOfSchema<(Of <<'(T>)>>)(Guid, Document) | Gets the elements with data of schema stored inside.
GetElementsWithDataOfSchema<(Of <<'(T>)>>)(Type, Document) | Gets the data storage.
GetMaterialOfElement | Gets the material assigned to element.
GetPhysicalElement | Gets the physical element if the input element is of analytical model type.
GetStructuralAssetClass | Gets the structural asset class.

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


CategorizeElements Method

Tools..::..CategorizeElements Method
Tools Class See Also Send Feedback
Categorizes elements based on material and category.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Dictionary<StructuralAssetClass, HashSet<BuiltInCategory>> CategorizeElements(
    List<Element> elements
)

Parameters

elements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>
The elements.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


EnumHas Method

Tools..::..EnumHas Method
Tools Class See Also Send Feedback
Determines if the enum value intersects with other enum value.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool EnumHas(
    Object value,
    Object valueToFind
)

Parameters

value
Type: System..::..Object
The value.
valueToFind
Type: System..::..Object
The value to find.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


FilterElements Method

[image]

Structural Analysis and Code Checking API Reference Guide
Tools..::..FilterElements Method
Tools Class See Also Send Feedback

Overload List

Name | Description
FilterElements(Document, array<BuiltInCategory>[]()[][]) | This method filters revit's elements by BuiltInCategory
FilterElements(Document, array<Type>[]()[][]) | This method filters revit's elements by Type
FilterElements(Document, List<(Of <<'(BuiltInCategory>)>>), List<(Of <<'(Type>)>>)) | This method filters revit's elements by BuiltInCategory

See Also

Tools Class
Tools Members
Autodesk.Revit.DB.CodeChecking Namespace


FilterElements Method (, [])

Tools..::..FilterElements Method (, array<>[]()[][])
Tools Class See Also Send Feedback
This method filters revit's elements by BuiltInCategory

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<Element> FilterElements(
    Document doc,
    params BuiltInCategory[] categories
)

Parameters

doc
Type: Document
Revit's document
categories
Type: array<BuiltInCategory>[]()[][]
Filtering categories

Return Value

Collection of revit's elements

See Also

Tools Class
FilterElements Overload
Autodesk.Revit.DB.CodeChecking Namespace


FilterElements Method (, Type[])

Tools..::..FilterElements Method (, array<Type>[]()[][])
Tools Class See Also Send Feedback
This method filters revit's elements by Type

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<Element> FilterElements(
    Document doc,
    params Type[] types
)

Parameters

doc
Type: Document
Revit's document
types
Type: array< System..::..Type >[]()[][]
Filtering types

Return Value

Collection of revit's elements

See Also

Tools Class
FilterElements Overload
Autodesk.Revit.DB.CodeChecking Namespace


FilterElements Method (, List(), List(Type))

Tools..::..FilterElements Method (, List<(Of <(<'>)>)>, List<(Of <(<'Type>)>)>)
Tools Class See Also Send Feedback
This method filters revit's elements by BuiltInCategory

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<Element> FilterElements(
    Document doc,
    List<BuiltInCategory> categories,
    List<Type> types
)

Parameters

doc
Type: Document
Revit document
categories
Type: System.Collections.Generic..::..List <(Of <(<'BuiltInCategory>)>)>
The list of categories
types
Type: System.Collections.Generic..::..List <(Of <(<' Type >)>)>
The list of types.

Return Value

Collection of revit's elements

See Also

Tools Class
FilterElements Overload
Autodesk.Revit.DB.CodeChecking Namespace


GetCategoryOfElement Method

Tools..::..GetCategoryOfElement Method
Tools Class See Also Send Feedback
Returns category of element.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static BuiltInCategory GetCategoryOfElement(
    Element elem
)

Parameters

elem
Type: Element
The elem.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


GetClassMaterialOfElement Method

Tools..::..GetClassMaterialOfElement Method
Tools Class See Also Send Feedback
Gets the material class of the element.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static StructuralAssetClass GetClassMaterialOfElement(
    Element elem
)

Parameters

elem
Type: Element
The element.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


GetDataStorage Method

Tools..::..GetDataStorage Method
Tools Class See Also Send Feedback
Gets the data storage which contains specific schema inside.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DataStorage GetDataStorage(
    Guid schemaId,
    Document document,
    bool create
)

Parameters

schemaId
Type: System..::..Guid
The schema id.
document
Type: Document
The document.
create
Type: System..::..Boolean
if set to true create new DataStorage if not exist.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


GetDataStorageList Method

Tools..::..GetDataStorageList Method
Tools Class See Also Send Feedback
Gets the data storage list with data saved.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<DataStorage> GetDataStorageList(
    Type schemaClass,
    Document document
)

Parameters

schemaClass
Type: System..::..Type
The schema class.
document
Type: Document
The document.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


GetElementsWithDataOfSchema Method

[image]

Structural Analysis and Code Checking API Reference Guide
Tools..::..GetElementsWithDataOfSchema Method
Tools Class See Also Send Feedback

Overload List

Name | Description
GetElementsWithDataOfSchema<(Of <<'(T>)>>)(Guid, Document) | Gets the elements with data of schema stored inside.
GetElementsWithDataOfSchema<(Of <<'(T>)>>)(Type, Document) | Gets the data storage.

See Also

Tools Class
Tools Members
Autodesk.Revit.DB.CodeChecking Namespace


GetElementsWithDataOfSchema(T) Method (Guid, )

Tools..::..GetElementsWithDataOfSchema<(Of <(<'T>)>)> Method (Guid, )
Tools Class See Also Send Feedback
Gets the elements with data of schema stored inside.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<T> GetElementsWithDataOfSchema<T>(
    Guid schemaId,
    Document document
)

Parameters

schemaId
Type: System..::..Guid
The schema id.
document
Type: Document
The document.

Type Parameters

T

Return Value

See Also

Tools Class
GetElementsWithDataOfSchema Overload
Autodesk.Revit.DB.CodeChecking Namespace


GetElementsWithDataOfSchema(T) Method (Type, )

Tools..::..GetElementsWithDataOfSchema<(Of <(<'T>)>)> Method (Type, )
Tools Class See Also Send Feedback
Gets the data storage.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<T> GetElementsWithDataOfSchema<T>(
    Type schemaClass,
    Document document
)

Parameters

schemaClass
Type: System..::..Type
The schema class.
document
Type: Document
The document.

Type Parameters

T

Return Value

See Also

Tools Class
GetElementsWithDataOfSchema Overload
Autodesk.Revit.DB.CodeChecking Namespace


GetMaterialOfElement Method

Tools..::..GetMaterialOfElement Method
Tools Class See Also Send Feedback
Gets the material assigned to element.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Material GetMaterialOfElement(
    Element elem
)

Parameters

elem
Type: Element
The element.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


GetPhysicalElement Method

Tools..::..GetPhysicalElement Method
Tools Class See Also Send Feedback
Gets the physical element if the input element is of analytical model type.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Element GetPhysicalElement(
    Element element
)

Parameters

element
Type: Element
The element.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


GetStructuralAssetClass Method

Tools..::..GetStructuralAssetClass Method
Tools Class See Also Send Feedback
Gets the structural asset class.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static StructuralAssetClass GetStructuralAssetClass(
    Material mat
)

Parameters

mat
Type: Material
The material.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


Tools Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Tools Properties
Tools Class See Also Send Feedback

The Tools type exposes the following members.

Properties

Name | Description
IsJournalPlayback | Gets a value indicating whether this instance is journal playback.

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


IsJournalPlayback Property

Tools..::..IsJournalPlayback Property
Tools Class See Also Send Feedback
Gets a value indicating whether this instance is journal playback.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool IsJournalPlayback { get; }

Field Value

true if this instance is journal playback; otherwise, false.

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace


Warning Class

Warning Class
Members See Also Send Feedback
Represents warning notification

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Warning : Notification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..Warning

See Also

Warning Members
Autodesk.Revit.DB.CodeChecking Namespace


Warning Members

[image]

Structural Analysis and Code Checking API Reference Guide
Warning Members
Warning Class Constructors Methods Properties See Also Send Feedback

The Warning type exposes the following members.

Constructors

 | Name | Description
Public method | Warning | Initializes a new instance of the Warning class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Overrides Notification..::..Level.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

Warning Class
Autodesk.Revit.DB.CodeChecking Namespace


Warning Constructor

Warning Constructor
Warning Class See Also Send Feedback
Initializes a new instance of the Warning class

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Warning()

See Also

Warning Class
Autodesk.Revit.DB.CodeChecking Namespace


Warning Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Warning Methods
Warning Class See Also Send Feedback

The Warning type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Warning Class
Autodesk.Revit.DB.CodeChecking Namespace


Warning Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Warning Properties
Warning Class See Also Send Feedback

The Warning type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets the level of notification. (Overrides Notification..::..Level.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)

See Also

Warning Class
Autodesk.Revit.DB.CodeChecking Namespace


Level Property

Warning..::..Level Property
Warning Class See Also Send Feedback
Gets the level of notification.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override NotificationLevel Level { get; }

See Also

Warning Class
Autodesk.Revit.DB.CodeChecking Namespace


Autodesk.Revit.DB.CodeChecking.Attributes Namespace

Autodesk.Revit.DB.CodeChecking.Attributes Namespace
Send Feedback

Classes

 | Class | Description
Public class | CalculationParamsStructureAttribute | Indicates what type should be used as CalculationParameter structure.
Public class | DataStructureAttribute | Base class for all Data Structure attributes
Public class | LabelStructureAttribute | Indicates what type should be used as Label structure.
Public class | ResultStructureAttribute | Indicates what type should be used as Result structure.
Public class | ServerVersionAttribute | Indicates version of the server.


CalculationParamsStructureAttribute Class

CalculationParamsStructureAttribute Class
Members See Also Send Feedback
Indicates what type should be used as CalculationParameter structure.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CalculationParamsStructureAttribute : DataStructureAttribute

Remarks

Used for MultiStructureServers.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..DataStructureAttribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..CalculationParamsStructureAttribute

See Also

CalculationParamsStructureAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


CalculationParamsStructureAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParamsStructureAttribute Members
CalculationParamsStructureAttribute Class Constructors Methods Properties See Also Send Feedback

The CalculationParamsStructureAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CalculationParamsStructureAttribute | Initializes a new instance of the CalculationParamsStructureAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CalculationParamsStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


CalculationParamsStructureAttribute Constructor

CalculationParamsStructureAttribute Constructor
CalculationParamsStructureAttribute Class See Also Send Feedback
Initializes a new instance of the CalculationParamsStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CalculationParamsStructureAttribute(
    Type type
)

Parameters

type
Type: System..::..Type
The type.

See Also

CalculationParamsStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


CalculationParamsStructureAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParamsStructureAttribute Methods
CalculationParamsStructureAttribute Class See Also Send Feedback

The CalculationParamsStructureAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CalculationParamsStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


CalculationParamsStructureAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParamsStructureAttribute Properties
CalculationParamsStructureAttribute Class See Also Send Feedback

The CalculationParamsStructureAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CalculationParamsStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


DataStructureAttribute Class

DataStructureAttribute Class
Members See Also Send Feedback
Base class for all Data Structure attributes

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class DataStructureAttribute : Attribute

Remarks

Used for MultiStructureServers.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..DataStructureAttribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..CalculationParamsStructureAttribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..LabelStructureAttribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..ResultStructureAttribute

See Also

DataStructureAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


DataStructureAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
DataStructureAttribute Members
DataStructureAttribute Class Constructors Methods Properties See Also Send Feedback

The DataStructureAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | DataStructureAttribute(Type) | Initializes a new instance of the DataStructureAttribute class.
Public method | DataStructureAttribute(Type, BuiltInCategory) | Initializes a new instance of the DataStructureAttribute class.
Public method | DataStructureAttribute(Type, StructuralAssetClass) | Initializes a new instance of the DataStructureAttribute class.
Public method | DataStructureAttribute(Type, BuiltInCategory, StructuralAssetClass) | Initializes a new instance of the DataStructureAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | GetDataStructure(Type, Type, Guid) | Gets the data structure type based on attributes assigned to source type.
 | GetDataStructure(Type, Type, BuiltInCategory, StructuralAssetClass) | Gets the data structure type based on attributes assigned to source type.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DataStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


DataStructureAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
DataStructureAttribute Constructor
DataStructureAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataStructureAttribute(Type) | Initializes a new instance of the DataStructureAttribute class.
Public method | DataStructureAttribute(Type, BuiltInCategory) | Initializes a new instance of the DataStructureAttribute class.
Public method | DataStructureAttribute(Type, StructuralAssetClass) | Initializes a new instance of the DataStructureAttribute class.
Public method | DataStructureAttribute(Type, BuiltInCategory, StructuralAssetClass) | Initializes a new instance of the DataStructureAttribute class.

See Also

DataStructureAttribute Class
DataStructureAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


DataStructureAttribute Constructor (Type)

DataStructureAttribute Constructor (Type)
DataStructureAttribute Class See Also Send Feedback
Initializes a new instance of the DataStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DataStructureAttribute(
    Type type
)

Parameters

type
Type: System..::..Type
The type.

See Also

DataStructureAttribute Class
DataStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


DataStructureAttribute Constructor (Type, )

DataStructureAttribute Constructor (Type, )
DataStructureAttribute Class See Also Send Feedback
Initializes a new instance of the DataStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DataStructureAttribute(
    Type type,
    BuiltInCategory category
)

Parameters

type
Type: System..::..Type
The type.
category
Type: BuiltInCategory
The category.

See Also

DataStructureAttribute Class
DataStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


DataStructureAttribute Constructor (Type, )

DataStructureAttribute Constructor (Type, )
DataStructureAttribute Class See Also Send Feedback
Initializes a new instance of the DataStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DataStructureAttribute(
    Type type,
    StructuralAssetClass material
)

Parameters

type
Type: System..::..Type
The type.
material
Type: StructuralAssetClass
The material.

See Also

DataStructureAttribute Class
DataStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


DataStructureAttribute Constructor (Type, , )

DataStructureAttribute Constructor (Type, , )
DataStructureAttribute Class See Also Send Feedback
Initializes a new instance of the DataStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DataStructureAttribute(
    Type type,
    BuiltInCategory category,
    StructuralAssetClass material
)

Parameters

type
Type: System..::..Type
The type.
category
Type: BuiltInCategory
The category.
material
Type: StructuralAssetClass
The material.

See Also

DataStructureAttribute Class
DataStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


DataStructureAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DataStructureAttribute Methods
DataStructureAttribute Class See Also Send Feedback

The DataStructureAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | GetDataStructure(Type, Type, Guid) | Gets the data structure type based on attributes assigned to source type.
 | GetDataStructure(Type, Type, BuiltInCategory, StructuralAssetClass) | Gets the data structure type based on attributes assigned to source type.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


GetDataStructure Method

[image]

Structural Analysis and Code Checking API Reference Guide
DataStructureAttribute..::..GetDataStructure Method
DataStructureAttribute Class See Also Send Feedback

Overload List

Name | Description
GetDataStructure(Type, Type, Guid) | Gets the data structure type based on attributes assigned to source type.
GetDataStructure(Type, Type, BuiltInCategory, StructuralAssetClass) | Gets the data structure type based on attributes assigned to source type.

See Also

DataStructureAttribute Class
DataStructureAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


GetDataStructure Method (Type, Type, Guid)

DataStructureAttribute..::..GetDataStructure Method (Type, Type, Guid)
DataStructureAttribute Class See Also Send Feedback
Gets the data structure type based on attributes assigned to source type.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetDataStructure(
    Type attType,
    Type sourceType,
    Guid schemaId
)

Parameters

attType
Type: System..::..Type
Type of the attribute.
sourceType
Type: System..::..Type
Type of the source.
schemaId
Type: System..::..Guid
The schema id.

Return Value

See Also

DataStructureAttribute Class
GetDataStructure Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


GetDataStructure Method (Type, Type, , )

DataStructureAttribute..::..GetDataStructure Method (Type, Type, , )
DataStructureAttribute Class See Also Send Feedback
Gets the data structure type based on attributes assigned to source type.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetDataStructure(
    Type attType,
    Type sourceType,
    BuiltInCategory category,
    StructuralAssetClass material
)

Parameters

attType
Type: System..::..Type
Type of the attribute.
sourceType
Type: System..::..Type
The source type.
category
Type: BuiltInCategory
The category.
material
Type: StructuralAssetClass
The material.

Return Value

See Also

DataStructureAttribute Class
GetDataStructure Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


DataStructureAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DataStructureAttribute Properties
DataStructureAttribute Class See Also Send Feedback

The DataStructureAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DataStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


LabelStructureAttribute Class

LabelStructureAttribute Class
Members See Also Send Feedback
Indicates what type should be used as Label structure.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LabelStructureAttribute : DataStructureAttribute

Remarks

Used for MultiStructureServers.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..DataStructureAttribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..LabelStructureAttribute

See Also

LabelStructureAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


LabelStructureAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
LabelStructureAttribute Members
LabelStructureAttribute Class Constructors Methods Properties See Also Send Feedback

The LabelStructureAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | LabelStructureAttribute(Type) | Initializes a new instance of the LabelStructureAttribute class.
Public method | LabelStructureAttribute(Type, BuiltInCategory) | Initializes a new instance of the LabelStructureAttribute class.
Public method | LabelStructureAttribute(Type, StructuralAssetClass) | Initializes a new instance of the LabelStructureAttribute class.
Public method | LabelStructureAttribute(Type, BuiltInCategory, StructuralAssetClass) | Initializes a new instance of the LabelStructureAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

LabelStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


LabelStructureAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
LabelStructureAttribute Constructor
LabelStructureAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LabelStructureAttribute(Type) | Initializes a new instance of the LabelStructureAttribute class.
Public method | LabelStructureAttribute(Type, BuiltInCategory) | Initializes a new instance of the LabelStructureAttribute class.
Public method | LabelStructureAttribute(Type, StructuralAssetClass) | Initializes a new instance of the LabelStructureAttribute class.
Public method | LabelStructureAttribute(Type, BuiltInCategory, StructuralAssetClass) | Initializes a new instance of the LabelStructureAttribute class.

See Also

LabelStructureAttribute Class
LabelStructureAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


LabelStructureAttribute Constructor (Type)

LabelStructureAttribute Constructor (Type)
LabelStructureAttribute Class See Also Send Feedback
Initializes a new instance of the LabelStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LabelStructureAttribute(
    Type type
)

Parameters

type
Type: System..::..Type
The Label type.

See Also

LabelStructureAttribute Class
LabelStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


LabelStructureAttribute Constructor (Type, )

LabelStructureAttribute Constructor (Type, )
LabelStructureAttribute Class See Also Send Feedback
Initializes a new instance of the LabelStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LabelStructureAttribute(
    Type type,
    BuiltInCategory category
)

Parameters

type
Type: System..::..Type
The label type.
category
Type: BuiltInCategory
The category for which label type is defined.

See Also

LabelStructureAttribute Class
LabelStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


LabelStructureAttribute Constructor (Type, )

LabelStructureAttribute Constructor (Type, )
LabelStructureAttribute Class See Also Send Feedback
Initializes a new instance of the LabelStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LabelStructureAttribute(
    Type type,
    StructuralAssetClass material
)

Parameters

type
Type: System..::..Type
The type.
material
Type: StructuralAssetClass
The material for which label type is defined.

See Also

LabelStructureAttribute Class
LabelStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


LabelStructureAttribute Constructor (Type, , )

LabelStructureAttribute Constructor (Type, , )
LabelStructureAttribute Class See Also Send Feedback
Initializes a new instance of the LabelStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LabelStructureAttribute(
    Type type,
    BuiltInCategory category,
    StructuralAssetClass material
)

Parameters

type
Type: System..::..Type
The label type.
category
Type: BuiltInCategory
The category for which label type is defined.
material
Type: StructuralAssetClass
The material for which label type is defined.

See Also

LabelStructureAttribute Class
LabelStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


LabelStructureAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LabelStructureAttribute Methods
LabelStructureAttribute Class See Also Send Feedback

The LabelStructureAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LabelStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


LabelStructureAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LabelStructureAttribute Properties
LabelStructureAttribute Class See Also Send Feedback

The LabelStructureAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

LabelStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ResultStructureAttribute Class

ResultStructureAttribute Class
Members See Also Send Feedback
Indicates what type should be used as Result structure.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultStructureAttribute : DataStructureAttribute

Remarks

Used for MultiStructureServers.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..DataStructureAttribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..ResultStructureAttribute

See Also

ResultStructureAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ResultStructureAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStructureAttribute Members
ResultStructureAttribute Class Constructors Methods Properties See Also Send Feedback

The ResultStructureAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ResultStructureAttribute(Type) | Initializes a new instance of the ResultStructureAttribute class.
Public method | ResultStructureAttribute(Type, BuiltInCategory) | Initializes a new instance of the ResultStructureAttribute class.
Public method | ResultStructureAttribute(Type, StructuralAssetClass) | Initializes a new instance of the ResultStructureAttribute class.
Public method | ResultStructureAttribute(Type, BuiltInCategory, StructuralAssetClass) | Initializes a new instance of the ResultStructureAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ResultStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ResultStructureAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStructureAttribute Constructor
ResultStructureAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResultStructureAttribute(Type) | Initializes a new instance of the ResultStructureAttribute class.
Public method | ResultStructureAttribute(Type, BuiltInCategory) | Initializes a new instance of the ResultStructureAttribute class.
Public method | ResultStructureAttribute(Type, StructuralAssetClass) | Initializes a new instance of the ResultStructureAttribute class.
Public method | ResultStructureAttribute(Type, BuiltInCategory, StructuralAssetClass) | Initializes a new instance of the ResultStructureAttribute class.

See Also

ResultStructureAttribute Class
ResultStructureAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ResultStructureAttribute Constructor (Type)

ResultStructureAttribute Constructor (Type)
ResultStructureAttribute Class See Also Send Feedback
Initializes a new instance of the ResultStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStructureAttribute(
    Type type
)

Parameters

type
Type: System..::..Type
The Result type.

See Also

ResultStructureAttribute Class
ResultStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ResultStructureAttribute Constructor (Type, )

ResultStructureAttribute Constructor (Type, )
ResultStructureAttribute Class See Also Send Feedback
Initializes a new instance of the ResultStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStructureAttribute(
    Type type,
    BuiltInCategory category
)

Parameters

type
Type: System..::..Type
The Result type.
category
Type: BuiltInCategory
The category for which label type is defined.

See Also

ResultStructureAttribute Class
ResultStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ResultStructureAttribute Constructor (Type, )

ResultStructureAttribute Constructor (Type, )
ResultStructureAttribute Class See Also Send Feedback
Initializes a new instance of the ResultStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStructureAttribute(
    Type type,
    StructuralAssetClass material
)

Parameters

type
Type: System..::..Type
The Result type.
material
Type: StructuralAssetClass
The material for which label type is defined.

See Also

ResultStructureAttribute Class
ResultStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ResultStructureAttribute Constructor (Type, , )

ResultStructureAttribute Constructor (Type, , )
ResultStructureAttribute Class See Also Send Feedback
Initializes a new instance of the ResultStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStructureAttribute(
    Type type,
    BuiltInCategory category,
    StructuralAssetClass material
)

Parameters

type
Type: System..::..Type
The Result type.
category
Type: BuiltInCategory
The category for which label type is defined.
material
Type: StructuralAssetClass
The materialfor which label type is defined.

See Also

ResultStructureAttribute Class
ResultStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ResultStructureAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStructureAttribute Methods
ResultStructureAttribute Class See Also Send Feedback

The ResultStructureAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ResultStructureAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStructureAttribute Properties
ResultStructureAttribute Class See Also Send Feedback

The ResultStructureAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ResultStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ServerVersionAttribute Class

ServerVersionAttribute Class
Members See Also Send Feedback
Indicates version of the server.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServerVersionAttribute : Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..ServerVersionAttribute

See Also

ServerVersionAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ServerVersionAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServerVersionAttribute Members
ServerVersionAttribute Class Constructors Methods Properties See Also Send Feedback

The ServerVersionAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ServerVersionAttribute | Initializes a new instance of the ServerVersionAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Version | Gets or sets the version.

See Also

ServerVersionAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ServerVersionAttribute Constructor

ServerVersionAttribute Constructor
ServerVersionAttribute Class See Also Send Feedback
Initializes a new instance of the ServerVersionAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerVersionAttribute(
    int version
)

Parameters

version
Type: System..::..Int32
The version.

See Also

ServerVersionAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ServerVersionAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServerVersionAttribute Methods
ServerVersionAttribute Class See Also Send Feedback

The ServerVersionAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServerVersionAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


ServerVersionAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServerVersionAttribute Properties
ServerVersionAttribute Class See Also Send Feedback

The ServerVersionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Version | Gets or sets the version.

See Also

ServerVersionAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


Version Property

ServerVersionAttribute..::..Version Property
ServerVersionAttribute Class See Also Send Feedback
Gets or sets the version.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Version { get; set; }

Field Value

The version.

See Also

ServerVersionAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace


Autodesk.Revit.DB.CodeChecking.Documentation Namespace

Autodesk.Revit.DB.CodeChecking.Documentation Namespace
Send Feedback

Classes

 | Class | Description
Public class | Composer | Base class for document composers
Public class | MultiStructureServer | The base class for all servers that support more than one category or material.
Public class | ReportSettings | Describes Report Settings
Public class | ResultComposer | Provides tool for generating Result note
Public class | Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> | Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform.
Public class | ServiceDocument | Represent service document

Interfaces

 | Interface | Description
Public interface | ICodeCheckingServerDocumentation | The base interface for all servers for documentation creation purpose.

Enumerations

 | Enumeration | Description
Public enumeration | DocumentSectionType | Describes document section type
Public enumeration | FilterStatus | Describes filter status
Public enumeration | GroupMethod | Grouping methods
Public enumeration | SelectionAction | Represents selection action
Public enumeration | SortMethod | Sorting methods


Composer Class

Composer Class
Members See Also Send Feedback
Base class for document composers

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Composer

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Documentation..::..Composer
Autodesk.Revit.DB.CodeChecking.Documentation..::..ResultComposer

See Also

Composer Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Composer Members

[image]

Structural Analysis and Code Checking API Reference Guide
Composer Members
Composer Class Constructors Methods Fields See Also Send Feedback

The Composer type exposes the following members.

Constructors

 | Name | Description
Public method | Composer | Initializes a new instance of the Composer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
ElementIdData | ElementId data key
ElementsData | ElementId data key
SectionData | Section data key
SingleSelectionData | Single Selection data key

See Also

Composer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Composer Constructor

Composer Constructor
Composer Class See Also Send Feedback
Initializes a new instance of the Composer class

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Composer()

See Also

Composer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Composer Fields

[image]

Structural Analysis and Code Checking API Reference Guide
Composer Fields
Composer Class See Also Send Feedback

The Composer type exposes the following members.

Fields

Name | Description
ElementIdData | ElementId data key
ElementsData | ElementId data key
SectionData | Section data key
SingleSelectionData | Single Selection data key

See Also

Composer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ElementIdData Field

Composer..::..ElementIdData Field
Composer Class See Also Send Feedback
ElementId data key

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string ElementIdData

See Also

Composer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ElementsData Field

Composer..::..ElementsData Field
Composer Class See Also Send Feedback
ElementId data key

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string ElementsData

See Also

Composer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


SectionData Field

Composer..::..SectionData Field
Composer Class See Also Send Feedback
Section data key

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string SectionData

See Also

Composer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


SingleSelectionData Field

Composer..::..SingleSelectionData Field
Composer Class See Also Send Feedback
Single Selection data key

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string SingleSelectionData

See Also

Composer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Composer Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Composer Methods
Composer Class See Also Send Feedback

The Composer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Composer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


DocumentSectionType Enumeration

DocumentSectionType Enumeration
See Also Send Feedback
Describes document section type

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum DocumentSectionType

Members

Member name | Value | Description
Undefined | 1 | Undefined
Code | 2 | Code
Labels | 4 | Labels
Types | 8 | Types
Elements | 16 | Elements
Materials | 32 | Materials

See Also

Autodesk.Revit.DB.CodeChecking.Documentation Namespace


FilterStatus Enumeration

FilterStatus Enumeration
See Also Send Feedback
Describes filter status

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum FilterStatus

Members

Member name | Value | Description
Undefined | 1 | Undefined status
Succeed | 2 | Succeed status
Warning | 4 | Warning status
Failed | 8 | Failed status
SucceedOutOfDate | 16 | Succeed out of date status

See Also

Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GroupMethod Enumeration

GroupMethod Enumeration
See Also Send Feedback
Grouping methods

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum GroupMethod

Members

Member name | Value | Description
Material | 0 | By material
Category | 1 | By category
Label | 2 | By label

See Also

Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ICodeCheckingServerDocumentation Interface

ICodeCheckingServerDocumentation Interface
Members See Also Send Feedback
The base interface for all servers for documentation creation purpose.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ICodeCheckingServerDocumentation : IResource

See Also

ICodeCheckingServerDocumentation Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ICodeCheckingServerDocumentation Members

[image]

Structural Analysis and Code Checking API Reference Guide
ICodeCheckingServerDocumentation Members
ICodeCheckingServerDocumentation Interface Methods See Also Send Feedback

The ICodeCheckingServerDocumentation type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamDocumentBody | Gets the document body for calculation parameters.
Public method | BuildLabelDocumentBody | Gets the document body for label.
Public method | BuildResultDocumentBody | Gets the document body for result.
Public method | GetResource | Gets the text resource. (Inherited from IResource.)
Public method | GetResourceImage | Gets the image resource. (Inherited from IResource.)

See Also

ICodeCheckingServerDocumentation Interface
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ICodeCheckingServerDocumentation Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ICodeCheckingServerDocumentation Methods
ICodeCheckingServerDocumentation Interface See Also Send Feedback

The ICodeCheckingServerDocumentation type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamDocumentBody | Gets the document body for calculation parameters.
Public method | BuildLabelDocumentBody | Gets the document body for label.
Public method | BuildResultDocumentBody | Gets the document body for result.
Public method | GetResource | Gets the text resource. (Inherited from IResource.)
Public method | GetResourceImage | Gets the image resource. (Inherited from IResource.)

See Also

ICodeCheckingServerDocumentation Interface
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


BuildCalculationParamDocumentBody Method

ICodeCheckingServerDocumentation..::..BuildCalculationParamDocumentBody Method
ICodeCheckingServerDocumentation Interface See Also Send Feedback
Gets the document body for calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
DocumentBody BuildCalculationParamDocumentBody(
    Entity calcParams,
    Document document
)

Parameters

calcParams
Type: Entity
The calculation parameters.
document
Type: Document
The document.

Return Value

See Also

ICodeCheckingServerDocumentation Interface
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


BuildLabelDocumentBody Method

ICodeCheckingServerDocumentation..::..BuildLabelDocumentBody Method
ICodeCheckingServerDocumentation Interface See Also Send Feedback
Gets the document body for label.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
DocumentBody BuildLabelDocumentBody(
    Entity label,
    Document document
)

Parameters

label
Type: Entity
The label.
document
Type: Document
The document.

Return Value

The body of the document.

See Also

ICodeCheckingServerDocumentation Interface
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


BuildResultDocumentBody Method

ICodeCheckingServerDocumentation..::..BuildResultDocumentBody Method
ICodeCheckingServerDocumentation Interface See Also Send Feedback
Gets the document body for result.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
DocumentBody BuildResultDocumentBody(
    Entity result,
    Element element,
    Document document
)

Parameters

result
Type: Entity
The result.
element
Type: Element
The element.
document
Type: Document
The document.

Return Value

The body of the document.

See Also

ICodeCheckingServerDocumentation Interface
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


MultiStructureServer Class

MultiStructureServer Class
Members See Also Send Feedback
The base class for all servers that support more than one category or material.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class MultiStructureServer : MultiStructureServer,
    ICodeCheckingServerDocumentation, IResource

Remarks

It is strongly connected with DataStructurAttributes:ResultStructureAttribute, LabelStructureAttribute, CalculationParamsStructureAttribute

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..MultiStructureServer
Autodesk.Revit.DB.CodeChecking.Documentation..::..MultiStructureServer

See Also

MultiStructureServer Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


MultiStructureServer Members

[image]

Structural Analysis and Code Checking API Reference Guide
MultiStructureServer Members
MultiStructureServer Class Methods See Also Send Feedback

The MultiStructureServer type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamDocumentBody | Gets the document body for calculation parameters.
Public method | BuildLabelDocumentBody | Gets the document body for label.
Public method | BuildResultDocumentBody | Gets the document body for result.
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one. (Inherited from MultiStructureServer.)
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one. (Inherited from MultiStructureServer.)
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one. (Inherited from MultiStructureServer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationParamSchema | Returns schema for calculation parameters. (Inherited from MultiStructureServer.)
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity. (Inherited from MultiStructureServer.)
Public method | GetDefaultLabel | Returns default value of label entity. (Inherited from MultiStructureServer.)
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from MultiStructureServer.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSchema | Returns schema for labels. (Inherited from MultiStructureServer.)
Public method | GetName | Implement this method to return the name of the server. (Inherited from MultiStructureServer.)
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package. (Inherited from MultiStructureServer.)
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package. (Inherited from MultiStructureServer.)
Public method | GetResource | Gets the resource.
Public method | GetResourceImage | Gets the resource image.
Public method | GetResultsSchema | Returns schema for results. (Inherited from MultiStructureServer.)
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from MultiStructureServer.)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from MultiStructureServer.)
Public method | GetSupportedCategories | Returns the list of supported categories. (Inherited from MultiStructureServer.)
Public method | GetSupportedMaterials | Returns the list of supported materials. (Inherited from MultiStructureServer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from MultiStructureServer.)
Public method | GetVersion | Gets the version of code checking server. (Inherited from MultiStructureServer.)
Public method | IsContextSupported | Determines whether specified context is supported. (Inherited from MultiStructureServer.)
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load combinations, they will be exposed on the dialog. (Inherited from MultiStructureServer.)
Public method | ResultBuilderPackagesAsInputData | Determines whether server supports load combinations, they will be exposed on the dialog. (Inherited from MultiStructureServer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Runs calculation. (Inherited from MultiStructureServer.)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


MultiStructureServer Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MultiStructureServer Methods
MultiStructureServer Class See Also Send Feedback

The MultiStructureServer type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamDocumentBody | Gets the document body for calculation parameters.
Public method | BuildLabelDocumentBody | Gets the document body for label.
Public method | BuildResultDocumentBody | Gets the document body for result.
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one. (Inherited from MultiStructureServer.)
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one. (Inherited from MultiStructureServer.)
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one. (Inherited from MultiStructureServer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationParamSchema | Returns schema for calculation parameters. (Inherited from MultiStructureServer.)
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity. (Inherited from MultiStructureServer.)
Public method | GetDefaultLabel | Returns default value of label entity. (Inherited from MultiStructureServer.)
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from MultiStructureServer.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSchema | Returns schema for labels. (Inherited from MultiStructureServer.)
Public method | GetName | Implement this method to return the name of the server. (Inherited from MultiStructureServer.)
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package. (Inherited from MultiStructureServer.)
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package. (Inherited from MultiStructureServer.)
Public method | GetResource | Gets the resource.
Public method | GetResourceImage | Gets the resource image.
Public method | GetResultsSchema | Returns schema for results. (Inherited from MultiStructureServer.)
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from MultiStructureServer.)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from MultiStructureServer.)
Public method | GetSupportedCategories | Returns the list of supported categories. (Inherited from MultiStructureServer.)
Public method | GetSupportedMaterials | Returns the list of supported materials. (Inherited from MultiStructureServer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from MultiStructureServer.)
Public method | GetVersion | Gets the version of code checking server. (Inherited from MultiStructureServer.)
Public method | IsContextSupported | Determines whether specified context is supported. (Inherited from MultiStructureServer.)
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load combinations, they will be exposed on the dialog. (Inherited from MultiStructureServer.)
Public method | ResultBuilderPackagesAsInputData | Determines whether server supports load combinations, they will be exposed on the dialog. (Inherited from MultiStructureServer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Runs calculation. (Inherited from MultiStructureServer.)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


BuildCalculationParamDocumentBody Method

MultiStructureServer..::..BuildCalculationParamDocumentBody Method
MultiStructureServer Class See Also Send Feedback
Gets the document body for calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual DocumentBody BuildCalculationParamDocumentBody(
    Entity calcParams,
    Document document
)

Parameters

calcParams
Type: Entity
The calculation parameters.
document
Type: Document
The document.

Return Value

Implements

ICodeCheckingServerDocumentation..::..BuildCalculationParamDocumentBody(Entity, Document)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


BuildLabelDocumentBody Method

MultiStructureServer..::..BuildLabelDocumentBody Method
MultiStructureServer Class See Also Send Feedback
Gets the document body for label.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual DocumentBody BuildLabelDocumentBody(
    Entity label,
    Document document
)

Parameters

label
Type: Entity
The label.
document
Type: Document
The document.

Return Value

The body of the document.

Implements

ICodeCheckingServerDocumentation..::..BuildLabelDocumentBody(Entity, Document)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


BuildResultDocumentBody Method

MultiStructureServer..::..BuildResultDocumentBody Method
MultiStructureServer Class See Also Send Feedback
Gets the document body for result.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual DocumentBody BuildResultDocumentBody(
    Entity result,
    Element element,
    Document document
)

Parameters

result
Type: Entity
The result.
element
Type: Element
The element.
document
Type: Document
The document.

Return Value

The body of the document.

Implements

ICodeCheckingServerDocumentation..::..BuildResultDocumentBody(Entity, Element, Document)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetResource Method

MultiStructureServer..::..GetResource Method
MultiStructureServer Class See Also Send Feedback
Gets the resource.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual string GetResource(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

The text resource.

Implements

IResource..::..GetResource(String, String)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetResourceImage Method

MultiStructureServer..::..GetResourceImage Method
MultiStructureServer Class See Also Send Feedback
Gets the resource image.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Uri GetResourceImage(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ReportSettings Class

ReportSettings Class
Members See Also Send Feedback
Describes Report Settings

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ReportSettings

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Documentation..::..ReportSettings

See Also

ReportSettings Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ReportSettings Members

[image]

Structural Analysis and Code Checking API Reference Guide
ReportSettings Members
ReportSettings Class Methods Properties See Also Send Feedback

The ReportSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportSettings | Gets the report settings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads this instance.
Public method | Save | Saves this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets or sets the action.
Public property | CollapsedDocumentSections | Gets or sets the document sections.
Public property | GroupMethods | Gets or sets the group methods.
Public property | Level | Gets or sets the level.
Public property | SaveSettings | Gets or sets a value indicating whether settings should be saved.
Public property | Sort | Gets or sets the sort.
Public property | StatusFilter | Gets or sets the result status filter.
Public property | VisibleDocumentSections | Gets or sets the document sections.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ReportSettings Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ReportSettings Methods
ReportSettings Class See Also Send Feedback

The ReportSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportSettings | Gets the report settings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads this instance.
Public method | Save | Saves this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetReportSettings Method

ReportSettings..::..GetReportSettings Method
ReportSettings Class See Also Send Feedback
Gets the report settings.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ReportSettings GetReportSettings(
    bool reload
)

Parameters

reload
Type: System..::..Boolean

Return Value

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Load Method

ReportSettings..::..Load Method
ReportSettings Class See Also Send Feedback
Loads this instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Load()

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Save Method

ReportSettings..::..Save Method
ReportSettings Class See Also Send Feedback
Saves this instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Save()

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ReportSettings Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ReportSettings Properties
ReportSettings Class See Also Send Feedback

The ReportSettings type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets or sets the action.
Public property | CollapsedDocumentSections | Gets or sets the document sections.
Public property | GroupMethods | Gets or sets the group methods.
Public property | Level | Gets or sets the level.
Public property | SaveSettings | Gets or sets a value indicating whether settings should be saved.
Public property | Sort | Gets or sets the sort.
Public property | StatusFilter | Gets or sets the result status filter.
Public property | VisibleDocumentSections | Gets or sets the document sections.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Action Property

ReportSettings..::..Action Property
ReportSettings Class See Also Send Feedback
Gets or sets the action.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SelectionAction Action { get; set; }

Field Value

The action.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


CollapsedDocumentSections Property

ReportSettings..::..CollapsedDocumentSections Property
ReportSettings Class See Also Send Feedback
Gets or sets the document sections.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSectionType CollapsedDocumentSections { get; set; }

Field Value

The document sections.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GroupMethods Property

ReportSettings..::..GroupMethods Property
ReportSettings Class See Also Send Feedback
Gets or sets the group methods.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<GroupMethod> GroupMethods { get; set; }

Field Value

The group methods.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Level Property

ReportSettings..::..Level Property
ReportSettings Class See Also Send Feedback
Gets or sets the level.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DetailLevel Level { get; set; }

Field Value

The level.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


SaveSettings Property

ReportSettings..::..SaveSettings Property
ReportSettings Class See Also Send Feedback
Gets or sets a value indicating whether settings should be saved.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool SaveSettings { get; set; }

Field Value

true if save settings; otherwise, false.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Sort Property

ReportSettings..::..Sort Property
ReportSettings Class See Also Send Feedback
Gets or sets the sort.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SortMethod Sort { get; set; }

Field Value

The sort.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


StatusFilter Property

ReportSettings..::..StatusFilter Property
ReportSettings Class See Also Send Feedback
Gets or sets the result status filter.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<FilterStatus> StatusFilter { get; set; }

Field Value

The status.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


VisibleDocumentSections Property

ReportSettings..::..VisibleDocumentSections Property
ReportSettings Class See Also Send Feedback
Gets or sets the document sections.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSectionType VisibleDocumentSections { get; set; }

Field Value

The document sections.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ResultComposer Class

ResultComposer Class
Members See Also Send Feedback
Provides tool for generating Result note

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultComposer : Composer

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Documentation..::..Composer
Autodesk.Revit.DB.CodeChecking.Documentation..::..ResultComposer

See Also

ResultComposer Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ResultComposer Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultComposer Members
ResultComposer Class Constructors Methods Fields See Also Send Feedback

The ResultComposer type exposes the following members.

Constructors

 | Name | Description
Public method | ResultComposer | Initializes a new instance of the ResultComposer class

Methods

 | Name | Description
Public method | AddCalculationParametersSection | Adds the calculation parameters section.
Public method | AddElementSection | Adds the element section.
Public method | AddElementsSection | Adds the elements section.
Public method | AddFamiliesSection | Adds the families section.
Public method | AddFamily | Adds the family.
Public method | AddHeader | Adds the header.
Public method | AddLabel | Adds the label.
Public method | AddLabelsSection | Adds the labels section.
Public method | AddMaterial | Adds the material.
Public method | AddMaterialsSection | Adds the materials section.
Public method | AddRebarCover | Adds the rebar cover.
Public method | BuildDocument | Builds the document.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillElementRegularParameters | Fills the element regular parameters.
Public method | FillElementServerResults | Fills the element section with server results.
Public method | GetCalculationParams | Gets the calculation params.
Public method | GetFamiliesSection | Gets the families section.
Public method | GetFamilySection | Gets the family section.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSection(String) | Gets the label section.
Public method | GetLabelSection(String, String) | Gets the label section.
Public method | GetLabelsSection | Gets the labels section.
Public method | GetMaterialSection | Gets the material section.
Public method | GetMaterialsSection | Gets the materials section.
 | GetResultStatus | Gets the result status of element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GroupLabels | Groups labels.
Public method | SortAndGroupElements(DocumentBody, List<(Of <<'(GroupMethod>)>>), SortMethod) | Sorts and group elements.
Public method | SortAndGroupElements(DocumentSection, List<(Of <<'(GroupMethod>)>>), SortMethod) | Sorts and group elements.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
ElementServerResultSetData | Element server data key
ElementStatusData | Element Status data key
ElementUpToDateData | UpToDate data key
GroupData | Group data key
LabelData | Label data kye
ServerIdData | Server id key

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ResultComposer Constructor

ResultComposer Constructor
ResultComposer Class See Also Send Feedback
Initializes a new instance of the ResultComposer class

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultComposer()

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ResultComposer Fields

[image]

Structural Analysis and Code Checking API Reference Guide
ResultComposer Fields
ResultComposer Class See Also Send Feedback

The ResultComposer type exposes the following members.

Fields

Name | Description
ElementServerResultSetData | Element server data key
ElementStatusData | Element Status data key
ElementUpToDateData | UpToDate data key
GroupData | Group data key
LabelData | Label data kye
ServerIdData | Server id key

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ElementServerResultSetData Field

ResultComposer..::..ElementServerResultSetData Field
ResultComposer Class See Also Send Feedback
Element server data key

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string ElementServerResultSetData

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ElementStatusData Field

ResultComposer..::..ElementStatusData Field
ResultComposer Class See Also Send Feedback
Element Status data key

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string ElementStatusData

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ElementUpToDateData Field

ResultComposer..::..ElementUpToDateData Field
ResultComposer Class See Also Send Feedback
UpToDate data key

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string ElementUpToDateData

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GroupData Field

ResultComposer..::..GroupData Field
ResultComposer Class See Also Send Feedback
Group data key

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string GroupData

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


LabelData Field

ResultComposer..::..LabelData Field
ResultComposer Class See Also Send Feedback
Label data kye

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string LabelData

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ServerIdData Field

ResultComposer..::..ServerIdData Field
ResultComposer Class See Also Send Feedback
Server id key

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string ServerIdData

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ResultComposer Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultComposer Methods
ResultComposer Class See Also Send Feedback

The ResultComposer type exposes the following members.

Methods

 | Name | Description
Public method | AddCalculationParametersSection | Adds the calculation parameters section.
Public method | AddElementSection | Adds the element section.
Public method | AddElementsSection | Adds the elements section.
Public method | AddFamiliesSection | Adds the families section.
Public method | AddFamily | Adds the family.
Public method | AddHeader | Adds the header.
Public method | AddLabel | Adds the label.
Public method | AddLabelsSection | Adds the labels section.
Public method | AddMaterial | Adds the material.
Public method | AddMaterialsSection | Adds the materials section.
Public method | AddRebarCover | Adds the rebar cover.
Public method | BuildDocument | Builds the document.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillElementRegularParameters | Fills the element regular parameters.
Public method | FillElementServerResults | Fills the element section with server results.
Public method | GetCalculationParams | Gets the calculation params.
Public method | GetFamiliesSection | Gets the families section.
Public method | GetFamilySection | Gets the family section.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSection(String) | Gets the label section.
Public method | GetLabelSection(String, String) | Gets the label section.
Public method | GetLabelsSection | Gets the labels section.
Public method | GetMaterialSection | Gets the material section.
Public method | GetMaterialsSection | Gets the materials section.
 | GetResultStatus | Gets the result status of element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GroupLabels | Groups labels.
Public method | SortAndGroupElements(DocumentBody, List<(Of <<'(GroupMethod>)>>), SortMethod) | Sorts and group elements.
Public method | SortAndGroupElements(DocumentSection, List<(Of <<'(GroupMethod>)>>), SortMethod) | Sorts and group elements.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddCalculationParametersSection Method

ResultComposer..::..AddCalculationParametersSection Method
ResultComposer Class See Also Send Feedback
Adds the calculation parameters section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddCalculationParametersSection()

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddElementSection Method

ResultComposer..::..AddElementSection Method
ResultComposer Class See Also Send Feedback
Adds the element section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddElementSection(
    Element element,
    DocumentSection section
)

Parameters

element
Type: Element
The element.
section
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentSection
The section.

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddElementsSection Method

ResultComposer..::..AddElementsSection Method
ResultComposer Class See Also Send Feedback
Adds the elements section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddElementsSection(
    List<Element> elements
)

Parameters

elements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>
The elements.

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddFamiliesSection Method

ResultComposer..::..AddFamiliesSection Method
ResultComposer Class See Also Send Feedback
Adds the families section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddFamiliesSection()

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddFamily Method

ResultComposer..::..AddFamily Method
ResultComposer Class See Also Send Feedback
Adds the family.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection AddFamily(
    Element element
)

Parameters

element
Type: Element
The element.

Return Value

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddHeader Method

ResultComposer..::..AddHeader Method
ResultComposer Class See Also Send Feedback
Adds the header.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddHeader()

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddLabel Method

ResultComposer..::..AddLabel Method
ResultComposer Class See Also Send Feedback
Adds the label.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection AddLabel(
    Label label
)

Parameters

label
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..Label
The label.

Return Value

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddLabelsSection Method

ResultComposer..::..AddLabelsSection Method
ResultComposer Class See Also Send Feedback
Adds the labels section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddLabelsSection()

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddMaterial Method

ResultComposer..::..AddMaterial Method
ResultComposer Class See Also Send Feedback
Adds the material.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection AddMaterial(
    Element element
)

Parameters

element
Type: Element
The element.

Return Value

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddMaterialsSection Method

ResultComposer..::..AddMaterialsSection Method
ResultComposer Class See Also Send Feedback
Adds the materials section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddMaterialsSection()

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


AddRebarCover Method

ResultComposer..::..AddRebarCover Method
ResultComposer Class See Also Send Feedback
Adds the rebar cover.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddRebarCover(
    Element element,
    DocumentBody body,
    BuiltInParameter coverParameter
)

Parameters

element
Type: Element
The element.
body
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBody
The body.
coverParameter
Type: BuiltInParameter
The cover parameter.

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


BuildDocument Method

ResultComposer..::..BuildDocument Method
ResultComposer Class See Also Send Feedback
Builds the document.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document BuildDocument(
    List<Element> elements,
    Document revitDocument,
    bool fillElementServerResults
)

Parameters

elements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>
The elements.
revitDocument
Type: Document
The revit document.
fillElementServerResults
Type: System..::..Boolean
if set to true element server data will be added.

Return Value

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


FillElementRegularParameters Method

ResultComposer..::..FillElementRegularParameters Method
ResultComposer Class See Also Send Feedback
Fills the element regular parameters.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void FillElementRegularParameters(
    Element element,
    DocumentBody body
)

Parameters

element
Type: Element
The element.
body
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBody
The body.

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


FillElementServerResults Method

ResultComposer..::..FillElementServerResults Method
ResultComposer Class See Also Send Feedback
Fills the element section with server results.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void FillElementServerResults(
    DocumentSection section
)

Parameters

section
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentSection
The section.

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetCalculationParams Method

ResultComposer..::..GetCalculationParams Method
ResultComposer Class See Also Send Feedback
Gets the calculation params.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection GetCalculationParams(
    string code
)

Parameters

code
Type: System..::..String
The code.

Return Value

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetFamiliesSection Method

ResultComposer..::..GetFamiliesSection Method
ResultComposer Class See Also Send Feedback
Gets the families section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection GetFamiliesSection()

Return Value

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetFamilySection Method

ResultComposer..::..GetFamilySection Method
ResultComposer Class See Also Send Feedback
Gets the family section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection GetFamilySection(
    Element family
)

Parameters

family
Type: Element
The family.

Return Value

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetLabelSection Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultComposer..::..GetLabelSection Method
ResultComposer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLabelSection(String) | Gets the label section.
Public method | GetLabelSection(String, String) | Gets the label section.

See Also

ResultComposer Class
ResultComposer Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetLabelSection Method (String)

ResultComposer..::..GetLabelSection Method (String)
ResultComposer Class See Also Send Feedback
Gets the label section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection GetLabelSection(
    string name
)

Parameters

name
Type: System..::..String
The name.

Return Value

See Also

ResultComposer Class
GetLabelSection Overload
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetLabelSection Method (String, String)

ResultComposer..::..GetLabelSection Method (String, String)
ResultComposer Class See Also Send Feedback
Gets the label section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection GetLabelSection(
    string name,
    string code
)

Parameters

name
Type: System..::..String
The name.
code
Type: System..::..String
The code.

Return Value

See Also

ResultComposer Class
GetLabelSection Overload
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetLabelsSection Method

ResultComposer..::..GetLabelsSection Method
ResultComposer Class See Also Send Feedback
Gets the labels section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection GetLabelsSection()

Return Value

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetMaterialSection Method

ResultComposer..::..GetMaterialSection Method
ResultComposer Class See Also Send Feedback
Gets the material section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection GetMaterialSection(
    Material material
)

Parameters

material
Type: Material
The material.

Return Value

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetMaterialsSection Method

ResultComposer..::..GetMaterialsSection Method
ResultComposer Class See Also Send Feedback
Gets the materials section.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection GetMaterialsSection()

Return Value

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetResultStatus Method

ResultComposer..::..GetResultStatus Method
ResultComposer Class See Also Send Feedback
Gets the result status of element.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void GetResultStatus(
    DocumentSection section,
    out ResultStatus status,
    out bool upToDate
)

Parameters

section
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentSection
The section.
status
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatus %
The status.
upToDate
Type: System..::..Boolean %
if set to true [up to date].

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GroupLabels Method

ResultComposer..::..GroupLabels Method
ResultComposer Class See Also Send Feedback
Groups labels.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void GroupLabels(
    DocumentBody document,
    List<GroupMethod> groupMethod,
    SortMethod sortMethod
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBody
The document.
groupMethod
Type: System.Collections.Generic..::..List <(Of <(<' GroupMethod >)>)>
The group method.
sortMethod
Type: Autodesk.Revit.DB.CodeChecking.Documentation..::..SortMethod
The sort method.

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


SortAndGroupElements Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultComposer..::..SortAndGroupElements Method
ResultComposer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortAndGroupElements(DocumentBody, List<(Of <<'(GroupMethod>)>>), SortMethod) | Sorts and group elements.
Public method | SortAndGroupElements(DocumentSection, List<(Of <<'(GroupMethod>)>>), SortMethod) | Sorts and group elements.

See Also

ResultComposer Class
ResultComposer Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


SortAndGroupElements Method (DocumentBody, List(GroupMethod), SortMethod)

ResultComposer..::..SortAndGroupElements Method (DocumentBody, List<(Of <(<'GroupMethod>)>)>, SortMethod)
ResultComposer Class See Also Send Feedback
Sorts and group elements.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SortAndGroupElements(
    DocumentBody document,
    List<GroupMethod> groupMethod,
    SortMethod sortMethod
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBody
The document.
groupMethod
Type: System.Collections.Generic..::..List <(Of <(<' GroupMethod >)>)>
The group method.
sortMethod
Type: Autodesk.Revit.DB.CodeChecking.Documentation..::..SortMethod
The sort method.

See Also

ResultComposer Class
SortAndGroupElements Overload
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


SortAndGroupElements Method (DocumentSection, List(GroupMethod), SortMethod)

ResultComposer..::..SortAndGroupElements Method (DocumentSection, List<(Of <(<'GroupMethod>)>)>, SortMethod)
ResultComposer Class See Also Send Feedback
Sorts and group elements.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SortAndGroupElements(
    DocumentSection elementsSection,
    List<GroupMethod> groupMethod,
    SortMethod sortMethod
)

Parameters

elementsSection
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentSection
The elements section.
groupMethod
Type: System.Collections.Generic..::..List <(Of <(<' GroupMethod >)>)>
The group method.
sortMethod
Type: Autodesk.Revit.DB.CodeChecking.Documentation..::..SortMethod
The sort method.

See Also

ResultComposer Class
SortAndGroupElements Overload
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


SelectionAction Enumeration

SelectionAction Enumeration
See Also Send Feedback
Represents selection action

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SelectionAction

Members

Member name | Value | Description
None | 1 | None
Model | 2 | Model
Clipboard | 4 | Clipboard

See Also

Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Server(TCalculationParam, TLabel, TResult) Class

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Members See Also Send Feedback
Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Server<TCalculationParam, TLabel, TResult> : Server<TCalculationParam, TLabel, TResult>,
    ICodeCheckingServerDocumentation, IResource
where TCalculationParam : new(), SchemaClass
where TLabel : new(), SchemaClass
where TResult : new(), SchemaClass

Type Parameters

TCalculationParam
The class representing calculation parameters.
TLabel
The class representing labels.
TResult
The class representing results.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Server <(Of <(<'TCalculationParam, TLabel, TResult>)>)>
Autodesk.Revit.DB.CodeChecking.Documentation..::..Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Server(TCalculationParam, TLabel, TResult) Members

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Members
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class Methods See Also Send Feedback

The Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamDocumentBody | Gets the document body for calculation parameters.
Public method | BuildLabelDocumentBody | Gets the document body for label.
Public method | BuildResultDocumentBody | Gets the document body for result.
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationParamSchema | Returns schema for calculation parameters. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetDefaultLabel | Returns default value of label entity. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSchema | Returns schema for labels. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetName | Implement this method to return the name of the server. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetResource | Gets the resource.
Public method | GetResourceImage | Gets the resource image.
Public method | GetResultsSchema | Returns schema for results. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetSupportedCategories | Returns the list of supported categories. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetSupportedMaterials | Returns the list of supported materials. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetVersion | Gets the version of code checking server. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | IsContextSupported | Determines whether specified context is supported. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load combinations, they will be exposed on the dialog. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | ResultBuilderPackagesAsInputData | Determines whether server supports load combinations, they will be exposed on the dialog. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Runs calculation. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Server(TCalculationParam, TLabel, TResult) Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Methods
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback

The Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamDocumentBody | Gets the document body for calculation parameters.
Public method | BuildLabelDocumentBody | Gets the document body for label.
Public method | BuildResultDocumentBody | Gets the document body for result.
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationParamSchema | Returns schema for calculation parameters. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetDefaultLabel | Returns default value of label entity. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSchema | Returns schema for labels. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetName | Implement this method to return the name of the server. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetResource | Gets the resource.
Public method | GetResourceImage | Gets the resource image.
Public method | GetResultsSchema | Returns schema for results. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetSupportedCategories | Returns the list of supported categories. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetSupportedMaterials | Returns the list of supported materials. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | GetVersion | Gets the version of code checking server. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | IsContextSupported | Determines whether specified context is supported. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load combinations, they will be exposed on the dialog. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | ResultBuilderPackagesAsInputData | Determines whether server supports load combinations, they will be exposed on the dialog. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Runs calculation. (Inherited from Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>.)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


BuildCalculationParamDocumentBody Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..BuildCalculationParamDocumentBody Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Gets the document body for calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual DocumentBody BuildCalculationParamDocumentBody(
    Entity calcParams,
    Document document
)

Parameters

calcParams
Type: Entity
The calculation parameters.
document
Type: Document
The document.

Return Value

Implements

ICodeCheckingServerDocumentation..::..BuildCalculationParamDocumentBody(Entity, Document)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


BuildLabelDocumentBody Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..BuildLabelDocumentBody Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Gets the document body for label.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual DocumentBody BuildLabelDocumentBody(
    Entity label,
    Document document
)

Parameters

label
Type: Entity
The label.
document
Type: Document
The document.

Return Value

The body of the document.

Implements

ICodeCheckingServerDocumentation..::..BuildLabelDocumentBody(Entity, Document)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


BuildResultDocumentBody Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..BuildResultDocumentBody Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Gets the document body for result.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual DocumentBody BuildResultDocumentBody(
    Entity result,
    Element element,
    Document document
)

Parameters

result
Type: Entity
The result.
element
Type: Element
The element.
document
Type: Document
The document.

Return Value

The body of the document.

Implements

ICodeCheckingServerDocumentation..::..BuildResultDocumentBody(Entity, Element, Document)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetResource Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetResource Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Gets the resource.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual string GetResource(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

The text resource.

Implements

IResource..::..GetResource(String, String)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetResourceImage Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetResourceImage Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Gets the resource image.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Uri GetResourceImage(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ServiceDocument Class

ServiceDocument Class
Members See Also Send Feedback
Represent service document

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServiceDocument

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Documentation..::..ServiceDocument

See Also

ServiceDocument Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ServiceDocument Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceDocument Members
ServiceDocument Class Constructors Methods See Also Send Feedback

The ServiceDocument type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceDocument | Initializes a new instance of the ServiceDocument class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetServer | Gets the server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceDocument Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ServiceDocument Constructor

ServiceDocument Constructor
ServiceDocument Class See Also Send Feedback
Initializes a new instance of the ServiceDocument class

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServiceDocument()

See Also

ServiceDocument Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


ServiceDocument Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceDocument Methods
ServiceDocument Class See Also Send Feedback

The ServiceDocument type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetServer | Gets the server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceDocument Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


GetServer Method

ServiceDocument..::..GetServer Method
ServiceDocument Class See Also Send Feedback
Gets the server.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ICodeCheckingServerDocumentation GetServer(
    Guid dbServerId
)

Parameters

dbServerId
Type: System..::..Guid
The ICodeCheckingServer id.

Return Value

See Also

ServiceDocument Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace


SortMethod Enumeration

SortMethod Enumeration
See Also Send Feedback
Sorting methods

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SortMethod

Members

Member name | Value | Description
Id | 0 | By id
Name | 1 | By name
Status | 2 | By status

See Also

Autodesk.Revit.DB.CodeChecking.Documentation Namespace


Autodesk.Revit.DB.CodeChecking.Engineering Namespace

Autodesk.Revit.DB.CodeChecking.Engineering Namespace
Send Feedback

Classes

 | Class | Description
Public class | CalcPoint | Base class for calculation point descriptor classes
Public class | CalcPointLinear | Representation of a calculation point on an element
Public class | CalcPointSurface | Representation of a calculation point on an element
Public class | CoordinateSystem | Class allows to transform points from local to global (and vice versa) coordinate system.
Public class | ElementInfo | Represents the properties of element along its length.
Public class | ElementSectionsInfo | Represents sections along element.
Public class | ElementSectionsParamsInfo | Represents the parameters of sections along element.
Public class | ElementSlabsInfo | Represents the properties of element slabs.
Public class | ElementTSectionInfo | Represents shape with plate T - section.
Public class | ElementWallsInfo | Represents the properties of element walls.
Public class | ForceCalculationDataDescriptor | Describes calculation object
Public class | ForceCalculationDataDescriptorLinear | Calculation points identifier for linear elements
Public class | ForceLoadCaseDescriptor | Representation of a load in Revit
Public class | ForceResultsPackageDescriptor | Representation of a ResultsPackage in Revit
Public class | Layer | Layer characteristics.
Public class | MaterialCharacteristics | Represents characteristics of a material.
Public class | MaterialConcreteCharacteristics | Represents characteristics of a concrete material.
Public class | MaterialInfo | Describes the material
Public class | MaterialMetalCharacteristics | Represents characteristics of a metal material.
Public class | MaterialProperties | Represents properties of the material.
Public class | MaterialTimberCharacteristics | Represents characteristics of a timber material.
Public class | RebarCoversInfo | Represents valid covers for element.
Public class | Section | Describes section contour with holes on a plane.
Public class | SectionCharacteristics | Describes characteristics of the parametric section.
Public class | SectionDimensions | Describes dimentsions of the parametric section.
Public class | SectionProfile | Represents the parameters of profile of element.
Public class | SectionsInfo | Describes sections or compound sections along element length.
Public class | SectionsParamsInfo | Describes dimensions and characteristics of the parametric section.
Public class | Shape | Describes flat shape on a plane.
Public class | SlabBaseObject | Base class for each element of the slab geometry
Public class | SlabContour | Represents Contour. Contour is a list of edges and nodes with parent characteristics.
Public class | SlabEdge | Represents edge. Edge is a lis of nodes with parent characteristics.
Public class | SlabInfo | Describes geometry of the slab and some connections with other elements. It consists of 3 characteristics elements: - nodes - (SlabNode) - edges - (SlabEdge) - contours - (SlabContour)
Public class | SlabNode | Represents node. Node is a point with parent characteristics.
Public class | WallInfo | Describes some geometry features of the Wall.

Enumerations

 | Enumeration | Description
Public enumeration | AxisDirection | Define axis direction.
Public enumeration | ElementType | Describes the type of the element
Public enumeration | ForceLimitState | Limit State( Ultimate, Serviceability, Accidental)
Public enumeration | ForceLoadCaseDescriptor..::..LoadType | Load Type (Simple load,Combination of loads)
Public enumeration | ForceType | Identificator for internal forces inside a cross-section
Public enumeration | MaterialCategory | Describes the type of material
Public enumeration | ResultType | Identificator for Reinforced Concrete section results
Public enumeration | SectionShapeType | Typ of the section.
Public enumeration | SlabAdjoiningRevitElementType | Defines type of adjoining Revit element.
Public enumeration | SlabContourType | Defines type of slab contour.
Public enumeration | SlabGeometryObjectType | Defines type of slab geometry object.
Public enumeration | TSectionNearestObjectType | Type of nearest characteristic object in the cross-section perpendicular to beam's longitudinal axis.


AxisDirection Enumeration

AxisDirection Enumeration
See Also Send Feedback
Define axis direction.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum AxisDirection

Members

Member name | Value | Description
X | 0 | Directon about x axis.
Y | 1 | Directon about y axis.
Z | 2 | Directon about z axis.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPoint Class

CalcPoint Class
Members See Also Send Feedback
Base class for calculation point descriptor classes

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class CalcPoint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..CalcPoint
Autodesk.Revit.DB.CodeChecking.Engineering..::..CalcPointLinear
Autodesk.Revit.DB.CodeChecking.Engineering..::..CalcPointSurface

See Also

CalcPoint Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPoint Members

[image]

Structural Analysis and Code Checking API Reference Guide
CalcPoint Members
CalcPoint Class Methods Properties See Also Send Feedback

The CalcPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Unique identificator of the calculation point.

See Also

CalcPoint Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPoint Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CalcPoint Methods
CalcPoint Class See Also Send Feedback

The CalcPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CalcPoint Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPoint Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CalcPoint Properties
CalcPoint Class See Also Send Feedback

The CalcPoint type exposes the following members.

Properties

 | Name | Description
Public property | Id | Unique identificator of the calculation point.

See Also

CalcPoint Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Id Property

CalcPoint..::..Id Property
CalcPoint Class See Also Send Feedback
Unique identificator of the calculation point.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Id { get; }

See Also

CalcPoint Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPointLinear Class

CalcPointLinear Class
Members See Also Send Feedback
Representation of a calculation point on an element

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CalcPointLinear : CalcPoint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..CalcPoint
Autodesk.Revit.DB.CodeChecking.Engineering..::..CalcPointLinear

See Also

CalcPointLinear Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPointLinear Members

[image]

Structural Analysis and Code Checking API Reference Guide
CalcPointLinear Members
CalcPointLinear Class Constructors Methods Properties See Also Send Feedback

The CalcPointLinear type exposes the following members.

Constructors

 | Name | Description
Public method | CalcPointLinear | Creates default CalcPointLinear

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CoordAbsolute | Absolute distance from the beginning of the element
Public property | CoordRelative | Relative distance from the beginning of the element
Public property | Id | Unique identificator of the calculation point. (Inherited from CalcPoint.)

See Also

CalcPointLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPointLinear Constructor

CalcPointLinear Constructor
CalcPointLinear Class See Also Send Feedback
Creates default CalcPointLinear

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CalcPointLinear(
    int id,
    double xAbs,
    double xRel
)

Parameters

id
Type: System..::..Int32
Unique identificator of the calculation point
xAbs
Type: System..::..Double
Points absolute distance from the begining of element
xRel
Type: System..::..Double
Points relative distance(0..1) from the begining of element

See Also

CalcPointLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPointLinear Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CalcPointLinear Methods
CalcPointLinear Class See Also Send Feedback

The CalcPointLinear type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CalcPointLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPointLinear Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CalcPointLinear Properties
CalcPointLinear Class See Also Send Feedback

The CalcPointLinear type exposes the following members.

Properties

 | Name | Description
Public property | CoordAbsolute | Absolute distance from the beginning of the element
Public property | CoordRelative | Relative distance from the beginning of the element
Public property | Id | Unique identificator of the calculation point. (Inherited from CalcPoint.)

See Also

CalcPointLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CoordAbsolute Property

CalcPointLinear..::..CoordAbsolute Property
CalcPointLinear Class See Also Send Feedback
Absolute distance from the beginning of the element

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double CoordAbsolute { get; }

See Also

CalcPointLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CoordRelative Property

CalcPointLinear..::..CoordRelative Property
CalcPointLinear Class See Also Send Feedback
Relative distance from the beginning of the element

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double CoordRelative { get; }

See Also

CalcPointLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPointSurface Class

CalcPointSurface Class
Members See Also Send Feedback
Representation of a calculation point on an element

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CalcPointSurface : CalcPoint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..CalcPoint
Autodesk.Revit.DB.CodeChecking.Engineering..::..CalcPointSurface

See Also

CalcPointSurface Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPointSurface Members

[image]

Structural Analysis and Code Checking API Reference Guide
CalcPointSurface Members
CalcPointSurface Class Constructors Methods Properties See Also Send Feedback

The CalcPointSurface type exposes the following members.

Constructors

 | Name | Description
Public method | CalcPointSurface | Creates default CalcPointSurface

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Coord | Point coordinates
Public property | Id | Unique identificator of the calculation point. (Inherited from CalcPoint.)

See Also

CalcPointSurface Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPointSurface Constructor

CalcPointSurface Constructor
CalcPointSurface Class See Also Send Feedback
Creates default CalcPointSurface

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CalcPointSurface(
    int id,
    XYZ coord
)

Parameters

id
Type: System..::..Int32
Unique identificator of the calculation point
coord
Type: XYZ
Points coordinates

See Also

CalcPointSurface Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPointSurface Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CalcPointSurface Methods
CalcPointSurface Class See Also Send Feedback

The CalcPointSurface type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CalcPointSurface Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CalcPointSurface Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CalcPointSurface Properties
CalcPointSurface Class See Also Send Feedback

The CalcPointSurface type exposes the following members.

Properties

 | Name | Description
Public property | Coord | Point coordinates
Public property | Id | Unique identificator of the calculation point. (Inherited from CalcPoint.)

See Also

CalcPointSurface Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Coord Property

CalcPointSurface..::..Coord Property
CalcPointSurface Class See Also Send Feedback
Point coordinates

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ Coord { get; }

See Also

CalcPointSurface Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CoordinateSystem Class

CoordinateSystem Class
Members See Also Send Feedback
Class allows to transform points from local to global (and vice versa) coordinate system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CoordinateSystem

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..CoordinateSystem

See Also

CoordinateSystem Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CoordinateSystem Members

[image]

Structural Analysis and Code Checking API Reference Guide
CoordinateSystem Members
CoordinateSystem Class Constructors Methods Properties See Also Send Feedback

The CoordinateSystem type exposes the following members.

Constructors

 | Name | Description
Public method | CoordinateSystem()()()() | Constructs a transform to the identity matrix.
Public method | CoordinateSystem(CoordinateSystem) | Copy constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ManyPoints2Global | Retrieves the list of points transformed from local to global coordinates system.
Public method | ManyPoints2Local | Retrieves the list of points transformed from global to local coordinates system.
Public method | Point2Global | Retrieves the point transformed from local to global coordinates system.
Public method | Point2Local | Retrieves the point transformed from global to local coordinates system.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Vector2Global | Retrieves the vector transformed from local to global coordinates system.
Public method | Vector2Local | Retrieves the vector transformed from global to local coordinates system.

Properties

 | Name | Description
Public property | BasisX | The X basis vector.
Public property | BasisY | The Y basis vector.
Public property | BasisZ | The Z basis vector.
Public property | Origin | The origin of the coordinate system.

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CoordinateSystem Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
CoordinateSystem Constructor
CoordinateSystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CoordinateSystem()()()() | Constructs a transform to the identity matrix.
Public method | CoordinateSystem(CoordinateSystem) | Copy constructor.

See Also

CoordinateSystem Class
CoordinateSystem Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CoordinateSystem Constructor

CoordinateSystem Constructor
CoordinateSystem Class See Also Send Feedback
Constructs a transform to the identity matrix.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CoordinateSystem()

See Also

CoordinateSystem Class
CoordinateSystem Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CoordinateSystem Constructor (CoordinateSystem)

CoordinateSystem Constructor (CoordinateSystem)
CoordinateSystem Class See Also Send Feedback
Copy constructor.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CoordinateSystem(
    CoordinateSystem transform
)

Parameters

transform
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..CoordinateSystem

See Also

CoordinateSystem Class
CoordinateSystem Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CoordinateSystem Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CoordinateSystem Methods
CoordinateSystem Class See Also Send Feedback

The CoordinateSystem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ManyPoints2Global | Retrieves the list of points transformed from local to global coordinates system.
Public method | ManyPoints2Local | Retrieves the list of points transformed from global to local coordinates system.
Public method | Point2Global | Retrieves the point transformed from local to global coordinates system.
Public method | Point2Local | Retrieves the point transformed from global to local coordinates system.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Vector2Global | Retrieves the vector transformed from local to global coordinates system.
Public method | Vector2Local | Retrieves the vector transformed from global to local coordinates system.

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ManyPoints2Global Method

CoordinateSystem..::..ManyPoints2Global Method
CoordinateSystem Class See Also Send Feedback
Retrieves the list of points transformed from local to global coordinates system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<XYZ> ManyPoints2Global(
    IList<XYZ> points
)

Parameters

points
Type: System.Collections.Generic..::..IList <(Of <(<'XYZ>)>)>

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ManyPoints2Local Method

CoordinateSystem..::..ManyPoints2Local Method
CoordinateSystem Class See Also Send Feedback
Retrieves the list of points transformed from global to local coordinates system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<XYZ> ManyPoints2Local(
    IList<XYZ> points
)

Parameters

points
Type: System.Collections.Generic..::..IList <(Of <(<'XYZ>)>)>

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Point2Global Method

CoordinateSystem..::..Point2Global Method
CoordinateSystem Class See Also Send Feedback
Retrieves the point transformed from local to global coordinates system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ Point2Global(
    XYZ point
)

Parameters

point
Type: XYZ

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Point2Local Method

CoordinateSystem..::..Point2Local Method
CoordinateSystem Class See Also Send Feedback
Retrieves the point transformed from global to local coordinates system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ Point2Local(
    XYZ point
)

Parameters

point
Type: XYZ

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Vector2Global Method

CoordinateSystem..::..Vector2Global Method
CoordinateSystem Class See Also Send Feedback
Retrieves the vector transformed from local to global coordinates system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ Vector2Global(
    XYZ vector
)

Parameters

vector
Type: XYZ

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Vector2Local Method

CoordinateSystem..::..Vector2Local Method
CoordinateSystem Class See Also Send Feedback
Retrieves the vector transformed from global to local coordinates system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ Vector2Local(
    XYZ vector
)

Parameters

vector
Type: XYZ

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CoordinateSystem Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CoordinateSystem Properties
CoordinateSystem Class See Also Send Feedback

The CoordinateSystem type exposes the following members.

Properties

 | Name | Description
Public property | BasisX | The X basis vector.
Public property | BasisY | The Y basis vector.
Public property | BasisZ | The Z basis vector.
Public property | Origin | The origin of the coordinate system.

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


BasisX Property

CoordinateSystem..::..BasisX Property
CoordinateSystem Class See Also Send Feedback
The X basis vector.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ BasisX { get; set; }

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


BasisY Property

CoordinateSystem..::..BasisY Property
CoordinateSystem Class See Also Send Feedback
The Y basis vector.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ BasisY { get; set; }

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


BasisZ Property

CoordinateSystem..::..BasisZ Property
CoordinateSystem Class See Also Send Feedback
The Z basis vector.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ BasisZ { get; set; }

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Origin Property

CoordinateSystem..::..Origin Property
CoordinateSystem Class See Also Send Feedback
The origin of the coordinate system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ Origin { get; set; }

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementInfo Class

ElementInfo Class
Members See Also Send Feedback
Represents the properties of element along its length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementInfo

See Also

ElementInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementInfo Members
ElementInfo Class Constructors Methods Properties See Also Send Feedback

The ElementInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ElementInfo(ElementSlabsInfo, MaterialInfo) | Creates instance for slab.
Public method | ElementInfo(ElementWallsInfo, MaterialInfo) | Creates instance for wall.
Public method | ElementInfo(ElementSectionsInfo, ElementSectionsParamsInfo, ElementSlabsInfo, MaterialInfo) | Creates instance for beam with T-Section.
Public method | ElementInfo(ElementType, ElementSectionsInfo, ElementSectionsParamsInfo, MaterialInfo) | Creates instance for beam or column.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GeomLength | Calculate the geometrical length of the element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Material | Gets parameters of material for element.
Public property | RebarCovers | Gets parameters of rebar covers for element.
Public property | Sections | Gets sections along element length.
Public property | SectionsParams | Gets parameters of sections along element length.
Public property | Slabs | Gets properties of element's slabs.
Public property | Type | Gets the type of the element.
Public property | Walls | Gets properties of element's walls.

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementInfo Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ElementInfo Constructor
ElementInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementInfo(ElementSlabsInfo, MaterialInfo) | Creates instance for slab.
Public method | ElementInfo(ElementWallsInfo, MaterialInfo) | Creates instance for wall.
Public method | ElementInfo(ElementSectionsInfo, ElementSectionsParamsInfo, ElementSlabsInfo, MaterialInfo) | Creates instance for beam with T-Section.
Public method | ElementInfo(ElementType, ElementSectionsInfo, ElementSectionsParamsInfo, MaterialInfo) | Creates instance for beam or column.

See Also

ElementInfo Class
ElementInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementInfo Constructor (ElementSlabsInfo, MaterialInfo)

ElementInfo Constructor (ElementSlabsInfo, MaterialInfo)
ElementInfo Class See Also Send Feedback
Creates instance for slab.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementInfo(
    ElementSlabsInfo slabs,
    MaterialInfo material
)

Parameters

slabs
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSlabsInfo
material
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialInfo

See Also

ElementInfo Class
ElementInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementInfo Constructor (ElementWallsInfo, MaterialInfo)

ElementInfo Constructor (ElementWallsInfo, MaterialInfo)
ElementInfo Class See Also Send Feedback
Creates instance for wall.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementInfo(
    ElementWallsInfo walls,
    MaterialInfo material
)

Parameters

walls
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementWallsInfo
material
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialInfo

See Also

ElementInfo Class
ElementInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementInfo Constructor (ElementSectionsInfo, ElementSectionsParamsInfo, ElementSlabsInfo, MaterialInfo)

ElementInfo Constructor (ElementSectionsInfo, ElementSectionsParamsInfo, ElementSlabsInfo, MaterialInfo)
ElementInfo Class See Also Send Feedback
Creates instance for beam with T-Section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementInfo(
    ElementSectionsInfo sections,
    ElementSectionsParamsInfo sectionsParams,
    ElementSlabsInfo slabs,
    MaterialInfo material
)

Parameters

sections
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsInfo
sectionsParams
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsParamsInfo
slabs
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSlabsInfo
material
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialInfo

See Also

ElementInfo Class
ElementInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementInfo Constructor (ElementType, ElementSectionsInfo, ElementSectionsParamsInfo, MaterialInfo)

ElementInfo Constructor (ElementType, ElementSectionsInfo, ElementSectionsParamsInfo, MaterialInfo)
ElementInfo Class See Also Send Feedback
Creates instance for beam or column.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementInfo(
    ElementType eType,
    ElementSectionsInfo sections,
    ElementSectionsParamsInfo sectionsParams,
    MaterialInfo material
)

Parameters

eType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementType
sections
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsInfo
sectionsParams
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsParamsInfo
material
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialInfo

See Also

ElementInfo Class
ElementInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ElementInfo Methods
ElementInfo Class See Also Send Feedback

The ElementInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GeomLength | Calculate the geometrical length of the element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GeomLength Method

ElementInfo..::..GeomLength Method
ElementInfo Class See Also Send Feedback
Calculate the geometrical length of the element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GeomLength()

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ElementInfo Properties
ElementInfo Class See Also Send Feedback

The ElementInfo type exposes the following members.

Properties

 | Name | Description
Public property | Material | Gets parameters of material for element.
Public property | RebarCovers | Gets parameters of rebar covers for element.
Public property | Sections | Gets sections along element length.
Public property | SectionsParams | Gets parameters of sections along element length.
Public property | Slabs | Gets properties of element's slabs.
Public property | Type | Gets the type of the element.
Public property | Walls | Gets properties of element's walls.

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Material Property

ElementInfo..::..Material Property
ElementInfo Class See Also Send Feedback
Gets parameters of material for element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialInfo Material { get; }

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


RebarCovers Property

ElementInfo..::..RebarCovers Property
ElementInfo Class See Also Send Feedback
Gets parameters of rebar covers for element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public RebarCoversInfo RebarCovers { get; internal set; }

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Sections Property

ElementInfo..::..Sections Property
ElementInfo Class See Also Send Feedback
Gets sections along element length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSectionsInfo Sections { get; }

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsParams Property

ElementInfo..::..SectionsParams Property
ElementInfo Class See Also Send Feedback
Gets parameters of sections along element length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSectionsParamsInfo SectionsParams { get; }

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Slabs Property

ElementInfo..::..Slabs Property
ElementInfo Class See Also Send Feedback
Gets properties of element's slabs.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSlabsInfo Slabs { get; }

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Type Property

ElementInfo..::..Type Property
ElementInfo Class See Also Send Feedback
Gets the type of the element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementType Type { get; private set; }

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Walls Property

ElementInfo..::..Walls Property
ElementInfo Class See Also Send Feedback
Gets properties of element's walls.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementWallsInfo Walls { get; }

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsInfo Class

ElementSectionsInfo Class
Members See Also Send Feedback
Represents sections along element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementSectionsInfo : ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsInfo

See Also

ElementSectionsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSectionsInfo Members
ElementSectionsInfo Class Constructors Methods Properties See Also Send Feedback

The ElementSectionsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSectionsInfo()()()() | Creates default instance.
Public method | ElementSectionsInfo(ElementSectionsInfo) | Creates instance from pattern.
Public method | ElementSectionsInfo(SectionsInfo, SectionsInfo) | Creates instance using information at the begining and at the end of section.

Methods

 | Name | Description
Public method | AtThePoint | Gets the sections at the point along element length.
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AtTheBeg | Gets the sections at the begining of the element.
Public property | AtTheEnd | Gets the sections at the end of the element.

See Also

ElementSectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsInfo Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSectionsInfo Constructor
ElementSectionsInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementSectionsInfo()()()() | Creates default instance.
Public method | ElementSectionsInfo(ElementSectionsInfo) | Creates instance from pattern.
Public method | ElementSectionsInfo(SectionsInfo, SectionsInfo) | Creates instance using information at the begining and at the end of section.

See Also

ElementSectionsInfo Class
ElementSectionsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsInfo Constructor

ElementSectionsInfo Constructor
ElementSectionsInfo Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSectionsInfo()

See Also

ElementSectionsInfo Class
ElementSectionsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsInfo Constructor (ElementSectionsInfo)

ElementSectionsInfo Constructor (ElementSectionsInfo)
ElementSectionsInfo Class See Also Send Feedback
Creates instance from pattern.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSectionsInfo(
    ElementSectionsInfo pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsInfo

See Also

ElementSectionsInfo Class
ElementSectionsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsInfo Constructor (SectionsInfo, SectionsInfo)

ElementSectionsInfo Constructor (SectionsInfo, SectionsInfo)
ElementSectionsInfo Class See Also Send Feedback
Creates instance using information at the begining and at the end of section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSectionsInfo(
    SectionsInfo sectionsBeg,
    SectionsInfo sectionsEnd
)

Parameters

sectionsBeg
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionsInfo
sectionsEnd
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionsInfo

See Also

ElementSectionsInfo Class
ElementSectionsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSectionsInfo Methods
ElementSectionsInfo Class See Also Send Feedback

The ElementSectionsInfo type exposes the following members.

Methods

 | Name | Description
Public method | AtThePoint | Gets the sections at the point along element length.
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementSectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AtThePoint Method

ElementSectionsInfo..::..AtThePoint Method
ElementSectionsInfo Class See Also Send Feedback
Gets the sections at the point along element length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsInfo AtThePoint(
    double relativePoint
)

Parameters

relativePoint
Type: System..::..Double

See Also

ElementSectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

ElementSectionsInfo..::..Clone Method
ElementSectionsInfo Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

ElementSectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSectionsInfo Properties
ElementSectionsInfo Class See Also Send Feedback

The ElementSectionsInfo type exposes the following members.

Properties

 | Name | Description
Public property | AtTheBeg | Gets the sections at the begining of the element.
Public property | AtTheEnd | Gets the sections at the end of the element.

See Also

ElementSectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AtTheBeg Property

ElementSectionsInfo..::..AtTheBeg Property
ElementSectionsInfo Class See Also Send Feedback
Gets the sections at the begining of the element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsInfo AtTheBeg { get; internal set; }

See Also

ElementSectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AtTheEnd Property

ElementSectionsInfo..::..AtTheEnd Property
ElementSectionsInfo Class See Also Send Feedback
Gets the sections at the end of the element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsInfo AtTheEnd { get; internal set; }

See Also

ElementSectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsParamsInfo Class

ElementSectionsParamsInfo Class
Members See Also Send Feedback
Represents the parameters of sections along element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementSectionsParamsInfo : SectionProfile

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionProfile
Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsParamsInfo

See Also

ElementSectionsParamsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsParamsInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSectionsParamsInfo Members
ElementSectionsParamsInfo Class Constructors Methods Properties See Also Send Feedback

The ElementSectionsParamsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSectionsParamsInfo()()()() | Creates default instance (not tapered).
Public method | ElementSectionsParamsInfo(ElementSectionsParamsInfo) | Creates instance from pattern.
Public method | ElementSectionsParamsInfo(SectionProfile, SectionsParamsInfo) | Creates not tapered instance.
Public method | ElementSectionsParamsInfo(SectionProfile, SectionsParamsInfo, SectionsParamsInfo) | Creates tapered instance.

Methods

 | Name | Description
Public method | AtThePoint | Gets the dimensions of the section at the point along element length.
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides SectionProfile..::..Clone()()()().)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Overrides SectionProfile..::..CompareTo(Object).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AtTheBeg | Gets the parameters of the section at the begining of the element.
Public property | AtTheEnd | Gets the parameters of the section at the end of the element.
Public property | ComponentsShapeType | Gets the list of components types of the shapes for double or compound section. (Inherited from SectionProfile.)
Public property | ShapeType | Gets the type of the shape of section. (Inherited from SectionProfile.)
Public property | Tapered | Gets a value indicating whether the profile is tapered. (Inherited from SectionProfile.)

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsParamsInfo Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSectionsParamsInfo Constructor
ElementSectionsParamsInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementSectionsParamsInfo()()()() | Creates default instance (not tapered).
Public method | ElementSectionsParamsInfo(ElementSectionsParamsInfo) | Creates instance from pattern.
Public method | ElementSectionsParamsInfo(SectionProfile, SectionsParamsInfo) | Creates not tapered instance.
Public method | ElementSectionsParamsInfo(SectionProfile, SectionsParamsInfo, SectionsParamsInfo) | Creates tapered instance.

See Also

ElementSectionsParamsInfo Class
ElementSectionsParamsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsParamsInfo Constructor

ElementSectionsParamsInfo Constructor
ElementSectionsParamsInfo Class See Also Send Feedback
Creates default instance (not tapered).

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSectionsParamsInfo()

See Also

ElementSectionsParamsInfo Class
ElementSectionsParamsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsParamsInfo Constructor (ElementSectionsParamsInfo)

ElementSectionsParamsInfo Constructor (ElementSectionsParamsInfo)
ElementSectionsParamsInfo Class See Also Send Feedback
Creates instance from pattern.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSectionsParamsInfo(
    ElementSectionsParamsInfo pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsParamsInfo

See Also

ElementSectionsParamsInfo Class
ElementSectionsParamsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsParamsInfo Constructor (SectionProfile, SectionsParamsInfo)

ElementSectionsParamsInfo Constructor (SectionProfile, SectionsParamsInfo)
ElementSectionsParamsInfo Class See Also Send Feedback
Creates not tapered instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSectionsParamsInfo(
    SectionProfile profile,
    SectionsParamsInfo paramsBeg
)

Parameters

profile
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionProfile
paramsBeg
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionsParamsInfo

See Also

ElementSectionsParamsInfo Class
ElementSectionsParamsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsParamsInfo Constructor (SectionProfile, SectionsParamsInfo, SectionsParamsInfo)

ElementSectionsParamsInfo Constructor (SectionProfile, SectionsParamsInfo, SectionsParamsInfo)
ElementSectionsParamsInfo Class See Also Send Feedback
Creates tapered instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSectionsParamsInfo(
    SectionProfile profile,
    SectionsParamsInfo paramsBeg,
    SectionsParamsInfo paramsEnd
)

Parameters

profile
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionProfile
paramsBeg
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionsParamsInfo
paramsEnd
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionsParamsInfo

See Also

ElementSectionsParamsInfo Class
ElementSectionsParamsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsParamsInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSectionsParamsInfo Methods
ElementSectionsParamsInfo Class See Also Send Feedback

The ElementSectionsParamsInfo type exposes the following members.

Methods

 | Name | Description
Public method | AtThePoint | Gets the dimensions of the section at the point along element length.
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides SectionProfile..::..Clone()()()().)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Overrides SectionProfile..::..CompareTo(Object).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AtThePoint Method

ElementSectionsParamsInfo..::..AtThePoint Method
ElementSectionsParamsInfo Class See Also Send Feedback
Gets the dimensions of the section at the point along element length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsParamsInfo AtThePoint(
    double relativePoint
)

Parameters

relativePoint
Type: System..::..Double

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

ElementSectionsParamsInfo..::..Clone Method
ElementSectionsParamsInfo Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override Object Clone()

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CompareTo Method

ElementSectionsParamsInfo..::..CompareTo Method
ElementSectionsParamsInfo Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override int CompareTo(
    Object obj
)

Parameters

obj
Type: System..::..Object

Implements

IComparable..::..CompareTo(Object)

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSectionsParamsInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSectionsParamsInfo Properties
ElementSectionsParamsInfo Class See Also Send Feedback

The ElementSectionsParamsInfo type exposes the following members.

Properties

 | Name | Description
Public property | AtTheBeg | Gets the parameters of the section at the begining of the element.
Public property | AtTheEnd | Gets the parameters of the section at the end of the element.
Public property | ComponentsShapeType | Gets the list of components types of the shapes for double or compound section. (Inherited from SectionProfile.)
Public property | ShapeType | Gets the type of the shape of section. (Inherited from SectionProfile.)
Public property | Tapered | Gets a value indicating whether the profile is tapered. (Inherited from SectionProfile.)

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AtTheBeg Property

ElementSectionsParamsInfo..::..AtTheBeg Property
ElementSectionsParamsInfo Class See Also Send Feedback
Gets the parameters of the section at the begining of the element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsParamsInfo AtTheBeg { get; internal set; }

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AtTheEnd Property

ElementSectionsParamsInfo..::..AtTheEnd Property
ElementSectionsParamsInfo Class See Also Send Feedback
Gets the parameters of the section at the end of the element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsParamsInfo AtTheEnd { get; internal set; }

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSlabsInfo Class

ElementSlabsInfo Class
Members See Also Send Feedback
Represents the properties of element slabs.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementSlabsInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSlabsInfo

See Also

ElementSlabsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSlabsInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSlabsInfo Members
ElementSlabsInfo Class Constructors Methods Properties See Also Send Feedback

The ElementSlabsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSlabsInfo(ElementTSectionInfo) | Creates instance for structural framing element with adjoining elements wchich are a slabs.
Public method | ElementSlabsInfo(SlabInfo) | Creates instance for element wchich is a slab.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AsElement | if element is a slab gets SlabInfo object.
Public property | TSection | if element is a beam gets T - section if possible.

See Also

ElementSlabsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSlabsInfo Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSlabsInfo Constructor
ElementSlabsInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementSlabsInfo(ElementTSectionInfo) | Creates instance for structural framing element with adjoining elements wchich are a slabs.
Public method | ElementSlabsInfo(SlabInfo) | Creates instance for element wchich is a slab.

See Also

ElementSlabsInfo Class
ElementSlabsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSlabsInfo Constructor (ElementTSectionInfo)

ElementSlabsInfo Constructor (ElementTSectionInfo)
ElementSlabsInfo Class See Also Send Feedback
Creates instance for structural framing element with adjoining elements wchich are a slabs.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSlabsInfo(
    ElementTSectionInfo tSection
)

Parameters

tSection
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementTSectionInfo

See Also

ElementSlabsInfo Class
ElementSlabsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSlabsInfo Constructor (SlabInfo)

ElementSlabsInfo Constructor (SlabInfo)
ElementSlabsInfo Class See Also Send Feedback
Creates instance for element wchich is a slab.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementSlabsInfo(
    SlabInfo element
)

Parameters

element
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabInfo

See Also

ElementSlabsInfo Class
ElementSlabsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSlabsInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSlabsInfo Methods
ElementSlabsInfo Class See Also Send Feedback

The ElementSlabsInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementSlabsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementSlabsInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSlabsInfo Properties
ElementSlabsInfo Class See Also Send Feedback

The ElementSlabsInfo type exposes the following members.

Properties

 | Name | Description
Public property | AsElement | if element is a slab gets SlabInfo object.
Public property | TSection | if element is a beam gets T - section if possible.

See Also

ElementSlabsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AsElement Property

ElementSlabsInfo..::..AsElement Property
ElementSlabsInfo Class See Also Send Feedback
if element is a slab gets SlabInfo object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabInfo AsElement { get; private set; }

See Also

ElementSlabsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


TSection Property

ElementSlabsInfo..::..TSection Property
ElementSlabsInfo Class See Also Send Feedback
if element is a beam gets T - section if possible.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementTSectionInfo TSection { get; private set; }

See Also

ElementSlabsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementTSectionInfo Class

ElementTSectionInfo Class
Members See Also Send Feedback
Represents shape with plate T - section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementTSectionInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementTSectionInfo

See Also

ElementTSectionInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementTSectionInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementTSectionInfo Members
ElementTSectionInfo Class Methods Properties See Also Send Feedback

The ElementTSectionInfo type exposes the following members.

Methods

 | Name | Description
Public method | AdjoiningSlabOnTheLeftSide | Gets the adjoining slab on the left side of the element at the point along its length.
Public method | AdjoiningSlabOnTheRightSide | Gets the adjoining slab on the right side of the element at the point along its length.
Public method | BeamWidth | Gets width of element.
Public method | DistanceToNearestObjectOnTheLeftSide | Gets the distance to nearest characteristic object on the left side of the element. Distance is calculated at the point along the element length.
Public method | DistanceToNearestObjectOnTheRightSide | Gets the distance to nearest characteristic object on the right side of the element. Distance is calculated at the point along the element length.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContour | Gets contour of the joint section including flanges
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverlappingDepthOnTheLeftSide | Gets the distance from lower slab edge to upper element edge on the left side of the element. Depth is calculated at the point along the element length.
Public method | OverlappingDepthOnTheRightSide | Gets the distance from lower slab edge to upper element edge on the right side of the element. Depth is calculated at the point along the element length.
Public method | SlabThicknessOnTheLeftSide | Gets the thickness of the slab on the left side of the element at the point along its length.
Public method | SlabThicknessOnTheRightSide | Gets the thickness of the slab on the right side of the element at the point along its length.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TypeOfNearestObjectOnTheLeftSide | Gets type of nearest characteristic object on the left side of the element.
Public method | TypeOfNearestObjectOnTheRightSide | Gets type of nearest characteristic object on the right side of the element.

Properties

 | Name | Description
Public property | Adjoinings | Gets list of SlabInfo objects represent adjoining slabs.
Public property | BeamSections | Gets beam sections.
Public property | ContextId | Gets Revit Id of beam element.
Public property | Contour | Gets contour of the joint section including flanges

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementTSectionInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ElementTSectionInfo Methods
ElementTSectionInfo Class See Also Send Feedback

The ElementTSectionInfo type exposes the following members.

Methods

 | Name | Description
Public method | AdjoiningSlabOnTheLeftSide | Gets the adjoining slab on the left side of the element at the point along its length.
Public method | AdjoiningSlabOnTheRightSide | Gets the adjoining slab on the right side of the element at the point along its length.
Public method | BeamWidth | Gets width of element.
Public method | DistanceToNearestObjectOnTheLeftSide | Gets the distance to nearest characteristic object on the left side of the element. Distance is calculated at the point along the element length.
Public method | DistanceToNearestObjectOnTheRightSide | Gets the distance to nearest characteristic object on the right side of the element. Distance is calculated at the point along the element length.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContour | Gets contour of the joint section including flanges
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverlappingDepthOnTheLeftSide | Gets the distance from lower slab edge to upper element edge on the left side of the element. Depth is calculated at the point along the element length.
Public method | OverlappingDepthOnTheRightSide | Gets the distance from lower slab edge to upper element edge on the right side of the element. Depth is calculated at the point along the element length.
Public method | SlabThicknessOnTheLeftSide | Gets the thickness of the slab on the left side of the element at the point along its length.
Public method | SlabThicknessOnTheRightSide | Gets the thickness of the slab on the right side of the element at the point along its length.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TypeOfNearestObjectOnTheLeftSide | Gets type of nearest characteristic object on the left side of the element.
Public method | TypeOfNearestObjectOnTheRightSide | Gets type of nearest characteristic object on the right side of the element.

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AdjoiningSlabOnTheLeftSide Method

ElementTSectionInfo..::..AdjoiningSlabOnTheLeftSide Method
ElementTSectionInfo Class See Also Send Feedback
Gets the adjoining slab on the left side of the element at the point along its length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabInfo AdjoiningSlabOnTheLeftSide(
    double relativePosition
)

Parameters

relativePosition
Type: System..::..Double

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AdjoiningSlabOnTheRightSide Method

ElementTSectionInfo..::..AdjoiningSlabOnTheRightSide Method
ElementTSectionInfo Class See Also Send Feedback
Gets the adjoining slab on the right side of the element at the point along its length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabInfo AdjoiningSlabOnTheRightSide(
    double relativePosition
)

Parameters

relativePosition
Type: System..::..Double

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


BeamWidth Method

ElementTSectionInfo..::..BeamWidth Method
ElementTSectionInfo Class See Also Send Feedback
Gets width of element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double BeamWidth()

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


DistanceToNearestObjectOnTheLeftSide Method

ElementTSectionInfo..::..DistanceToNearestObjectOnTheLeftSide Method
ElementTSectionInfo Class See Also Send Feedback
Gets the distance to nearest characteristic object on the left side of the element. Distance is calculated at the point along the element length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double DistanceToNearestObjectOnTheLeftSide(
    double relativePosition
)

Parameters

relativePosition
Type: System..::..Double

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


DistanceToNearestObjectOnTheRightSide Method

ElementTSectionInfo..::..DistanceToNearestObjectOnTheRightSide Method
ElementTSectionInfo Class See Also Send Feedback
Gets the distance to nearest characteristic object on the right side of the element. Distance is calculated at the point along the element length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double DistanceToNearestObjectOnTheRightSide(
    double relativePosition
)

Parameters

relativePosition
Type: System..::..Double

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetContour Method

ElementTSectionInfo..::..GetContour Method
ElementTSectionInfo Class See Also Send Feedback
Gets contour of the joint section including flanges

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Section GetContour(
    double relativePosition,
    double flangeL,
    double flangeR
)

Parameters

relativePosition
Type: System..::..Double
relative position on the bar
flangeL
Type: System..::..Double
maximum code value for left flange length
flangeR
Type: System..::..Double
maximum code value for right flange length

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


OverlappingDepthOnTheLeftSide Method

ElementTSectionInfo..::..OverlappingDepthOnTheLeftSide Method
ElementTSectionInfo Class See Also Send Feedback
Gets the distance from lower slab edge to upper element edge on the left side of the element. Depth is calculated at the point along the element length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double OverlappingDepthOnTheLeftSide(
    double relativePosition
)

Parameters

relativePosition
Type: System..::..Double

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


OverlappingDepthOnTheRightSide Method

ElementTSectionInfo..::..OverlappingDepthOnTheRightSide Method
ElementTSectionInfo Class See Also Send Feedback
Gets the distance from lower slab edge to upper element edge on the right side of the element. Depth is calculated at the point along the element length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double OverlappingDepthOnTheRightSide(
    double relativePosition
)

Parameters

relativePosition
Type: System..::..Double

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabThicknessOnTheLeftSide Method

ElementTSectionInfo..::..SlabThicknessOnTheLeftSide Method
ElementTSectionInfo Class See Also Send Feedback
Gets the thickness of the slab on the left side of the element at the point along its length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double SlabThicknessOnTheLeftSide(
    double relativePosition
)

Parameters

relativePosition
Type: System..::..Double

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabThicknessOnTheRightSide Method

ElementTSectionInfo..::..SlabThicknessOnTheRightSide Method
ElementTSectionInfo Class See Also Send Feedback
Gets the thickness of the slab on the right side of the element at the point along its length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double SlabThicknessOnTheRightSide(
    double relativePosition
)

Parameters

relativePosition
Type: System..::..Double

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


TypeOfNearestObjectOnTheLeftSide Method

ElementTSectionInfo..::..TypeOfNearestObjectOnTheLeftSide Method
ElementTSectionInfo Class See Also Send Feedback
Gets type of nearest characteristic object on the left side of the element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TSectionNearestObjectType TypeOfNearestObjectOnTheLeftSide(
    double relativePosition
)

Parameters

relativePosition
Type: System..::..Double

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


TypeOfNearestObjectOnTheRightSide Method

ElementTSectionInfo..::..TypeOfNearestObjectOnTheRightSide Method
ElementTSectionInfo Class See Also Send Feedback
Gets type of nearest characteristic object on the right side of the element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TSectionNearestObjectType TypeOfNearestObjectOnTheRightSide(
    double relativePosition
)

Parameters

relativePosition
Type: System..::..Double

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementTSectionInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ElementTSectionInfo Properties
ElementTSectionInfo Class See Also Send Feedback

The ElementTSectionInfo type exposes the following members.

Properties

 | Name | Description
Public property | Adjoinings | Gets list of SlabInfo objects represent adjoining slabs.
Public property | BeamSections | Gets beam sections.
Public property | ContextId | Gets Revit Id of beam element.
Public property | Contour | Gets contour of the joint section including flanges

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Adjoinings Property

ElementTSectionInfo..::..Adjoinings Property
ElementTSectionInfo Class See Also Send Feedback
Gets list of SlabInfo objects represent adjoining slabs.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SlabInfo> Adjoinings { get; private set; }

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


BeamSections Property

ElementTSectionInfo..::..BeamSections Property
ElementTSectionInfo Class See Also Send Feedback
Gets beam sections.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsInfo BeamSections { get; internal set; }

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ContextId Property

ElementTSectionInfo..::..ContextId Property
ElementTSectionInfo Class See Also Send Feedback
Gets Revit Id of beam element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int ContextId { get; private set; }

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Contour Property

ElementTSectionInfo..::..Contour Property
ElementTSectionInfo Class See Also Send Feedback
Gets contour of the joint section including flanges

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Section Contour { get; }

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementType Enumeration

ElementType Enumeration
See Also Send Feedback
Describes the type of the element

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ElementType

Members

Member name | Value | Description
Unknown | 0 | Unknown.
Bar | 8 | Bar
Beam | 1 | Beam.
Column | 2 | Column.
Surface | 128 | Surface
Slab | 16 | Slab.
Wall | 32 | Wall.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementWallsInfo Class

ElementWallsInfo Class
Members See Also Send Feedback
Represents the properties of element walls.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementWallsInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementWallsInfo

See Also

ElementWallsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementWallsInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementWallsInfo Members
ElementWallsInfo Class Constructors Methods Properties See Also Send Feedback

The ElementWallsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ElementWallsInfo | Creates instance for element wchich is a wall.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AsElement | if element is a wall gets WallInfo object.

See Also

ElementWallsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementWallsInfo Constructor

ElementWallsInfo Constructor
ElementWallsInfo Class See Also Send Feedback
Creates instance for element wchich is a wall.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementWallsInfo(
    WallInfo element
)

Parameters

element
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..WallInfo

See Also

ElementWallsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementWallsInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ElementWallsInfo Methods
ElementWallsInfo Class See Also Send Feedback

The ElementWallsInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementWallsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementWallsInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ElementWallsInfo Properties
ElementWallsInfo Class See Also Send Feedback

The ElementWallsInfo type exposes the following members.

Properties

 | Name | Description
Public property | AsElement | if element is a wall gets WallInfo object.

See Also

ElementWallsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AsElement Property

ElementWallsInfo..::..AsElement Property
ElementWallsInfo Class See Also Send Feedback
if element is a wall gets WallInfo object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public WallInfo AsElement { get; private set; }

See Also

ElementWallsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptor Class

ForceCalculationDataDescriptor Class
Members See Also Send Feedback
Describes calculation object

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ForceCalculationDataDescriptor

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceCalculationDataDescriptor
Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceCalculationDataDescriptorLinear

See Also

ForceCalculationDataDescriptor Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptor Members

[image]

Structural Analysis and Code Checking API Reference Guide
ForceCalculationDataDescriptor Members
ForceCalculationDataDescriptor Class Constructors Methods Properties See Also Send Feedback

The ForceCalculationDataDescriptor type exposes the following members.

Constructors

 | Name | Description
Public method | ForceCalculationDataDescriptor | Creates default ForceCalculationPointsDescriptor

Methods

 | Name | Description
Public method | AddBendingForceTypes | Adds bending forcetypes to the data
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Gets or sets Revit ElementId for element to which calculation point is assigned
Public property | ForceTypes | Gets internal force types for which calculations are to be conducted
Public property | ForceTypesHashed | Gets hashed internal force types for the whole collection

See Also

ForceCalculationDataDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptor Constructor

ForceCalculationDataDescriptor Constructor
ForceCalculationDataDescriptor Class See Also Send Feedback
Creates default ForceCalculationPointsDescriptor

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceCalculationDataDescriptor(
    ElementId elementId,
    IEnumerable<ForceType> forceTypes
)

Parameters

elementId
Type: ElementId
Revit ElementId for element to which calculation point is assigned
forceTypes
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ForceType >)>)>
Vector of force types for which calculations are to be conducted

See Also

ForceCalculationDataDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptor Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ForceCalculationDataDescriptor Methods
ForceCalculationDataDescriptor Class See Also Send Feedback

The ForceCalculationDataDescriptor type exposes the following members.

Methods

 | Name | Description
Public method | AddBendingForceTypes | Adds bending forcetypes to the data
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ForceCalculationDataDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AddBendingForceTypes Method

ForceCalculationDataDescriptor..::..AddBendingForceTypes Method
ForceCalculationDataDescriptor Class See Also Send Feedback
Adds bending forcetypes to the data

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddBendingForceTypes(
    IEnumerable<ForceType> forceTypes
)

Parameters

forceTypes
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ForceType >)>)>
Collection of force types

See Also

ForceCalculationDataDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptor Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ForceCalculationDataDescriptor Properties
ForceCalculationDataDescriptor Class See Also Send Feedback

The ForceCalculationDataDescriptor type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Gets or sets Revit ElementId for element to which calculation point is assigned
Public property | ForceTypes | Gets internal force types for which calculations are to be conducted
Public property | ForceTypesHashed | Gets hashed internal force types for the whole collection

See Also

ForceCalculationDataDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementId Property

ForceCalculationDataDescriptor..::..ElementId Property
ForceCalculationDataDescriptor Class See Also Send Feedback
Gets or sets Revit ElementId for element to which calculation point is assigned

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementId ElementId { get; set; }

See Also

ForceCalculationDataDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceTypes Property

ForceCalculationDataDescriptor..::..ForceTypes Property
ForceCalculationDataDescriptor Class See Also Send Feedback
Gets internal force types for which calculations are to be conducted

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ForceType> ForceTypes { get; }

See Also

ForceCalculationDataDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceTypesHashed Property

ForceCalculationDataDescriptor..::..ForceTypesHashed Property
ForceCalculationDataDescriptor Class See Also Send Feedback
Gets hashed internal force types for the whole collection

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string ForceTypesHashed { get; }

See Also

ForceCalculationDataDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptorLinear Class

ForceCalculationDataDescriptorLinear Class
Members See Also Send Feedback
Calculation points identifier for linear elements

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ForceCalculationDataDescriptorLinear : ForceCalculationDataDescriptor

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceCalculationDataDescriptor
Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceCalculationDataDescriptorLinear

See Also

ForceCalculationDataDescriptorLinear Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptorLinear Members

[image]

Structural Analysis and Code Checking API Reference Guide
ForceCalculationDataDescriptorLinear Members
ForceCalculationDataDescriptorLinear Class Constructors Methods Properties See Also Send Feedback

The ForceCalculationDataDescriptorLinear type exposes the following members.

Constructors

 | Name | Description
Public method | ForceCalculationDataDescriptorLinear(ElementId) | Creates default ForceCalculationPointsDescriptorLinear
Public method | ForceCalculationDataDescriptorLinear(ElementId, Double, IEnumerable<(Of <<'(Double>)>>), Boolean, List<(Of <<'(ForceType>)>>)) | Creates default ForceCalculationPointsDescriptorLinear

Methods

 | Name | Description
Public method | AddBendingForceTypes | Adds bending forcetypes to the data (Inherited from ForceCalculationDataDescriptor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Gets or sets Revit ElementId for element to which calculation point is assigned (Inherited from ForceCalculationDataDescriptor.)
Public property | ForceTypes | Gets internal force types for which calculations are to be conducted (Inherited from ForceCalculationDataDescriptor.)
Public property | ForceTypesHashed | Gets hashed internal force types for the whole collection (Inherited from ForceCalculationDataDescriptor.)
Public property | Points | Gets calculation points coordinates
Public property | PointsHashed | Gets hash string representation of division points

See Also

ForceCalculationDataDescriptorLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptorLinear Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ForceCalculationDataDescriptorLinear Constructor
ForceCalculationDataDescriptorLinear Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForceCalculationDataDescriptorLinear(ElementId) | Creates default ForceCalculationPointsDescriptorLinear
Public method | ForceCalculationDataDescriptorLinear(ElementId, Double, IEnumerable<(Of <<'(Double>)>>), Boolean, List<(Of <<'(ForceType>)>>)) | Creates default ForceCalculationPointsDescriptorLinear

See Also

ForceCalculationDataDescriptorLinear Class
ForceCalculationDataDescriptorLinear Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptorLinear Constructor ()

ForceCalculationDataDescriptorLinear Constructor ()
ForceCalculationDataDescriptorLinear Class See Also Send Feedback
Creates default ForceCalculationPointsDescriptorLinear

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceCalculationDataDescriptorLinear(
    ElementId elementId
)

Parameters

elementId
Type: ElementId
Revit ElementId for element to which calculation point is assigned

See Also

ForceCalculationDataDescriptorLinear Class
ForceCalculationDataDescriptorLinear Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptorLinear Constructor (, Double, IEnumerable(Double), Boolean, List(ForceType))

ForceCalculationDataDescriptorLinear Constructor (, Double, IEnumerable<(Of <(<'Double>)>)>, Boolean, List<(Of <(<'ForceType>)>)>)
ForceCalculationDataDescriptorLinear Class See Also Send Feedback
Creates default ForceCalculationPointsDescriptorLinear

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceCalculationDataDescriptorLinear(
    ElementId elementId,
    double elementLength,
    IEnumerable<double> points,
    bool isInputRelative,
    List<ForceType> forceTypes
)

Parameters

elementId
Type: ElementId
Revit ElementId for element to which calculation point is assigned
elementLength
Type: System..::..Double
Element length(absolute or relative)
points
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>
Calculation points coordinates
isInputRelative
Type: System..::..Boolean
Flag informing whether input values are absolute or relative
forceTypes
Type: System.Collections.Generic..::..List <(Of <(<' ForceType >)>)>
A list of ForceType elements to be taken into account during calculations

See Also

ForceCalculationDataDescriptorLinear Class
ForceCalculationDataDescriptorLinear Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptorLinear Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ForceCalculationDataDescriptorLinear Methods
ForceCalculationDataDescriptorLinear Class See Also Send Feedback

The ForceCalculationDataDescriptorLinear type exposes the following members.

Methods

 | Name | Description
Public method | AddBendingForceTypes | Adds bending forcetypes to the data (Inherited from ForceCalculationDataDescriptor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ForceCalculationDataDescriptorLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceCalculationDataDescriptorLinear Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ForceCalculationDataDescriptorLinear Properties
ForceCalculationDataDescriptorLinear Class See Also Send Feedback

The ForceCalculationDataDescriptorLinear type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Gets or sets Revit ElementId for element to which calculation point is assigned (Inherited from ForceCalculationDataDescriptor.)
Public property | ForceTypes | Gets internal force types for which calculations are to be conducted (Inherited from ForceCalculationDataDescriptor.)
Public property | ForceTypesHashed | Gets hashed internal force types for the whole collection (Inherited from ForceCalculationDataDescriptor.)
Public property | Points | Gets calculation points coordinates
Public property | PointsHashed | Gets hash string representation of division points

See Also

ForceCalculationDataDescriptorLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Points Property

ForceCalculationDataDescriptorLinear..::..Points Property
ForceCalculationDataDescriptorLinear Class See Also Send Feedback
Gets calculation points coordinates

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<double> Points { get; }

See Also

ForceCalculationDataDescriptorLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


PointsHashed Property

ForceCalculationDataDescriptorLinear..::..PointsHashed Property
ForceCalculationDataDescriptorLinear Class See Also Send Feedback
Gets hash string representation of division points

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string PointsHashed { get; }

See Also

ForceCalculationDataDescriptorLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceLimitState Enumeration

ForceLimitState Enumeration
See Also Send Feedback
Limit State( Ultimate, Serviceability, Accidental)

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ForceLimitState

Members

Member name | Value | Description
Unknown | 0 | Unknown limit state
Uls | 1 | Ultimate limit state
Sls | 2 | Serviceability limit state
Als | 3 | Accidental limit state

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceLoadCaseDescriptor Class

ForceLoadCaseDescriptor Class
Members See Also Send Feedback
Representation of a load in Revit

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ForceLoadCaseDescriptor

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceLoadCaseDescriptor

See Also

ForceLoadCaseDescriptor Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceLoadCaseDescriptor Members

[image]

Structural Analysis and Code Checking API Reference Guide
ForceLoadCaseDescriptor Members
ForceLoadCaseDescriptor Class Methods Properties See Also Send Feedback

The ForceLoadCaseDescriptor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Integer representing ElementId in Revit ///
Public property | Name | Load name
Public property | State | Load state
Public property | Type | Load type

See Also

ForceLoadCaseDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceLoadCaseDescriptor Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ForceLoadCaseDescriptor Methods
ForceLoadCaseDescriptor Class See Also Send Feedback

The ForceLoadCaseDescriptor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ForceLoadCaseDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceLoadCaseDescriptor Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ForceLoadCaseDescriptor Properties
ForceLoadCaseDescriptor Class See Also Send Feedback

The ForceLoadCaseDescriptor type exposes the following members.

Properties

 | Name | Description
Public property | Id | Integer representing ElementId in Revit ///
Public property | Name | Load name
Public property | State | Load state
Public property | Type | Load type

See Also

ForceLoadCaseDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Id Property

ForceLoadCaseDescriptor..::..Id Property
ForceLoadCaseDescriptor Class See Also Send Feedback
Integer representing ElementId in Revit ///

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Id { get; }

See Also

ForceLoadCaseDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Name Property

ForceLoadCaseDescriptor..::..Name Property
ForceLoadCaseDescriptor Class See Also Send Feedback
Load name

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; }

See Also

ForceLoadCaseDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


State Property

ForceLoadCaseDescriptor..::..State Property
ForceLoadCaseDescriptor Class See Also Send Feedback
Load state

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceLimitState State { get; }

See Also

ForceLoadCaseDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Type Property

ForceLoadCaseDescriptor..::..Type Property
ForceLoadCaseDescriptor Class See Also Send Feedback
Load type

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceLoadCaseDescriptor..::..LoadType Type { get; }

See Also

ForceLoadCaseDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceLoadCaseDescriptor.LoadType Enumeration

ForceLoadCaseDescriptor..::..LoadType Enumeration
ForceLoadCaseDescriptor Class See Also Send Feedback
Load Type (Simple load,Combination of loads)

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum LoadType

Members

Member name | Value | Description
Unknown | 0 | Unknown load type
SimpleCase | 1 | Simple case of load
Combination | 2 | Combination of loads

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceResultsPackageDescriptor Class

ForceResultsPackageDescriptor Class
Members See Also Send Feedback
Representation of a ResultsPackage in Revit

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ForceResultsPackageDescriptor

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceResultsPackageDescriptor

See Also

ForceResultsPackageDescriptor Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceResultsPackageDescriptor Members

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsPackageDescriptor Members
ForceResultsPackageDescriptor Class Methods Properties See Also Send Feedback

The ForceResultsPackageDescriptor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllResultPackageDescriptors | Returns a List of ForceResultsPackageDescriptor objects for all packages available in the current document
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetResultPackageDescriptor | Creates ForceResultsPackageDescriptor for a given document and package guid Throws exception if pack for the given guid is not found
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Guid | Gets ResultPackage guid
Public property | Name | Gets ResultPackage name

See Also

ForceResultsPackageDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceResultsPackageDescriptor Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsPackageDescriptor Methods
ForceResultsPackageDescriptor Class See Also Send Feedback

The ForceResultsPackageDescriptor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllResultPackageDescriptors | Returns a List of ForceResultsPackageDescriptor objects for all packages available in the current document
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetResultPackageDescriptor | Creates ForceResultsPackageDescriptor for a given document and package guid Throws exception if pack for the given guid is not found
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ForceResultsPackageDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetAllResultPackageDescriptors Method

ForceResultsPackageDescriptor..::..GetAllResultPackageDescriptors Method
ForceResultsPackageDescriptor Class See Also Send Feedback
Returns a List of ForceResultsPackageDescriptor objects for all packages available in the current document

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<ForceResultsPackageDescriptor> GetAllResultPackageDescriptors(
    Document document
)

Parameters

document
Type: Document
Revit Document Object

Return Value

List of ForceResultsPackageDescriptor objects

See Also

ForceResultsPackageDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetResultPackageDescriptor Method

ForceResultsPackageDescriptor..::..GetResultPackageDescriptor Method
ForceResultsPackageDescriptor Class See Also Send Feedback
Creates ForceResultsPackageDescriptor for a given document and package guid Throws exception if pack for the given guid is not found

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ForceResultsPackageDescriptor GetResultPackageDescriptor(
    Document document,
    Guid guid
)

Parameters

document
Type: Document
Revit Document object
guid
Type: System..::..Guid
Package guid

Return Value

ForceResultsPackageDescriptor object

See Also

ForceResultsPackageDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceResultsPackageDescriptor Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsPackageDescriptor Properties
ForceResultsPackageDescriptor Class See Also Send Feedback

The ForceResultsPackageDescriptor type exposes the following members.

Properties

 | Name | Description
Public property | Guid | Gets ResultPackage guid
Public property | Name | Gets ResultPackage name

See Also

ForceResultsPackageDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Guid Property

ForceResultsPackageDescriptor..::..Guid Property
ForceResultsPackageDescriptor Class See Also Send Feedback
Gets ResultPackage guid

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid Guid { get; }

See Also

ForceResultsPackageDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Name Property

ForceResultsPackageDescriptor..::..Name Property
ForceResultsPackageDescriptor Class See Also Send Feedback
Gets ResultPackage name

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; }

See Also

ForceResultsPackageDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ForceType Enumeration

ForceType Enumeration
See Also Send Feedback
Identificator for internal forces inside a cross-section

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ForceType

Members

Member name | Value | Description
Unknown | 0 | Unknown
Fx | 1 | Axial force (bar element)
Fy | 2 | Shear force y (bar element)
Fz | 3 | Shear force z (bar element)
Mx | 4 | Torsion moment (bar element)
My | 5 | Bending moment y (bar element)
Mz | 6 | Bending moment z (bar element)
Mxx | 7 | Bending moment xx (surface element)
Myy | 8 | Bending moment yy (surface element)
Mxy | 9 | Bending moment xy (surface element)
Fxx | 10 | Normal force xx (surface element)
Fyy | 11 | Normal force yy (surface element)
Fxy | 12 | Normal force xy (surface element)
Qxx | 13 | Shear force xx (surface element)
Qyy | 14 | Shear force yy (surface element)
Ux | 15 | Deflection X
Uy | 16 | Deflection Y
Uz | 17 | Deflection Z
GetLinearResultType |  | Converts ForceType into ResultBuilder LinearResultType
GetSurfaceResultType |  | Converts ForceType into ResultBuilder SurfaceResultType

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Layer Class

Layer Class
Members See Also Send Feedback
Layer characteristics.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Layer : IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..Layer

See Also

Layer Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Layer Members

[image]

Structural Analysis and Code Checking API Reference Guide
Layer Members
Layer Class Constructors Methods Properties See Also Send Feedback

The Layer type exposes the following members.

Constructors

 | Name | Description
Public method | Layer()()()() | Creates default instance.
Public method | Layer(ElementId, Double, Double, Boolean, MaterialFunctionAssignment) | Constructs object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Material | Gets material of the layer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Function | Gets material function of layer.
Public property | Offset | Layer offset from object begining.
Public property | Structure | Check if layer is structure.
Public property | Thickness | Layer thickness.

See Also

Layer Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Layer Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
Layer Constructor
Layer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Layer()()()() | Creates default instance.
Public method | Layer(ElementId, Double, Double, Boolean, MaterialFunctionAssignment) | Constructs object.

See Also

Layer Class
Layer Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Layer Constructor

Layer Constructor
Layer Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Layer()

See Also

Layer Class
Layer Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Layer Constructor (, Double, Double, Boolean, )

Layer Constructor (, Double, Double, Boolean, )
Layer Class See Also Send Feedback
Constructs object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Layer(
    ElementId materialId,
    double thickness,
    double offset,
    bool structure,
    MaterialFunctionAssignment function
)

Parameters

materialId
Type: ElementId
thickness
Type: System..::..Double
offset
Type: System..::..Double
structure
Type: System..::..Boolean
function
Type: MaterialFunctionAssignment

See Also

Layer Class
Layer Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Layer Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Layer Methods
Layer Class See Also Send Feedback

The Layer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Material | Gets material of the layer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Layer Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEnumerator Method

Layer..::..GetEnumerator Method
Layer Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IEnumerator GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

Layer Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Material Method

Layer..::..Material Method
Layer Class See Also Send Feedback
Gets material of the layer.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialInfo Material(
    Document revitDocument
)

Parameters

revitDocument
Type: Document

See Also

Layer Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Layer Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Layer Properties
Layer Class See Also Send Feedback

The Layer type exposes the following members.

Properties

 | Name | Description
Public property | Function | Gets material function of layer.
Public property | Offset | Layer offset from object begining.
Public property | Structure | Check if layer is structure.
Public property | Thickness | Layer thickness.

See Also

Layer Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Function Property

Layer..::..Function Property
Layer Class See Also Send Feedback
Gets material function of layer.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialFunctionAssignment Function { get; internal set; }

See Also

Layer Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Offset Property

Layer..::..Offset Property
Layer Class See Also Send Feedback
Layer offset from object begining.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Offset { get; internal set; }

See Also

Layer Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Structure Property

Layer..::..Structure Property
Layer Class See Also Send Feedback
Check if layer is structure.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Structure { get; internal set; }

See Also

Layer Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Thickness Property

Layer..::..Thickness Property
Layer Class See Also Send Feedback
Layer thickness.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Thickness { get; internal set; }

See Also

Layer Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialCategory Enumeration

MaterialCategory Enumeration
See Also Send Feedback
Describes the type of material

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum MaterialCategory

Members

Member name | Value | Description
Metal | 1 | Metal.
Timber | 2 | Wood.
Concrete | 3 | Concrete.
Other | 4 | Other.
Undefined | 0 | Undefined.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialCharacteristics Class

MaterialCharacteristics Class
Members See Also Send Feedback
Represents characteristics of a material.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class MaterialCharacteristics : IEnumerable,
    ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialCharacteristics

See Also

MaterialCharacteristics Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialCharacteristics Members

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialCharacteristics Members
MaterialCharacteristics Class Constructors Methods Properties See Also Send Feedback

The MaterialCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialCharacteristics()()()() | Creates default instance.
Public method | MaterialCharacteristics(MaterialCharacteristics) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DampingRatio | Gets the damping coefficient.
Public property | PoissonRatio | Gets the Poisson's ratio.
Public property | ShearModulus | Gets the shear modulus G.
Public property | Specific | Gets or sets specific characteristics (corresponding to material category) of the material.
Public property | ThermalExpansionCoefficient | Gets the thermal expansion coefficient.
Public property | UnitWeight | Gets the unit weight.
Public property | YoungModulus | Gets the Young's modulus.

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialCharacteristics Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialCharacteristics Constructor
MaterialCharacteristics Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MaterialCharacteristics()()()() | Creates default instance.
Public method | MaterialCharacteristics(MaterialCharacteristics) | Creates new instance from pattern. Copy constructor.

See Also

MaterialCharacteristics Class
MaterialCharacteristics Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialCharacteristics Constructor

MaterialCharacteristics Constructor
MaterialCharacteristics Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialCharacteristics()

See Also

MaterialCharacteristics Class
MaterialCharacteristics Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialCharacteristics Constructor (MaterialCharacteristics)

MaterialCharacteristics Constructor (MaterialCharacteristics)
MaterialCharacteristics Class See Also Send Feedback
Creates new instance from pattern. Copy constructor.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialCharacteristics(
    MaterialCharacteristics pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialCharacteristics

See Also

MaterialCharacteristics Class
MaterialCharacteristics Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialCharacteristics Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialCharacteristics Methods
MaterialCharacteristics Class See Also Send Feedback

The MaterialCharacteristics type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

MaterialCharacteristics..::..Clone Method
MaterialCharacteristics Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Implements

ICloneable..::..Clone()()()()

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEnumerator Method

MaterialCharacteristics..::..GetEnumerator Method
MaterialCharacteristics Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IEnumerator GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialCharacteristics Properties

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialCharacteristics Properties
MaterialCharacteristics Class See Also Send Feedback

The MaterialCharacteristics type exposes the following members.

Properties

 | Name | Description
Public property | DampingRatio | Gets the damping coefficient.
Public property | PoissonRatio | Gets the Poisson's ratio.
Public property | ShearModulus | Gets the shear modulus G.
Public property | Specific | Gets or sets specific characteristics (corresponding to material category) of the material.
Public property | ThermalExpansionCoefficient | Gets the thermal expansion coefficient.
Public property | UnitWeight | Gets the unit weight.
Public property | YoungModulus | Gets the Young's modulus.

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


DampingRatio Property

MaterialCharacteristics..::..DampingRatio Property
MaterialCharacteristics Class See Also Send Feedback
Gets the damping coefficient.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double DampingRatio { get; internal set; }

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


PoissonRatio Property

MaterialCharacteristics..::..PoissonRatio Property
MaterialCharacteristics Class See Also Send Feedback
Gets the Poisson's ratio.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ PoissonRatio { get; internal set; }

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ShearModulus Property

MaterialCharacteristics..::..ShearModulus Property
MaterialCharacteristics Class See Also Send Feedback
Gets the shear modulus G.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ ShearModulus { get; internal set; }

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Specific Property

MaterialCharacteristics..::..Specific Property
MaterialCharacteristics Class See Also Send Feedback
Gets or sets specific characteristics (corresponding to material category) of the material.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Specific { get; internal set; }

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ThermalExpansionCoefficient Property

MaterialCharacteristics..::..ThermalExpansionCoefficient Property
MaterialCharacteristics Class See Also Send Feedback
Gets the thermal expansion coefficient.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ ThermalExpansionCoefficient { get; internal set; }

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


UnitWeight Property

MaterialCharacteristics..::..UnitWeight Property
MaterialCharacteristics Class See Also Send Feedback
Gets the unit weight.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double UnitWeight { get; internal set; }

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


YoungModulus Property

MaterialCharacteristics..::..YoungModulus Property
MaterialCharacteristics Class See Also Send Feedback
Gets the Young's modulus.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ YoungModulus { get; internal set; }

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialConcreteCharacteristics Class

MaterialConcreteCharacteristics Class
Members See Also Send Feedback
Represents characteristics of a concrete material.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class MaterialConcreteCharacteristics : IEnumerable,
    ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialConcreteCharacteristics

See Also

MaterialConcreteCharacteristics Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialConcreteCharacteristics Members

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialConcreteCharacteristics Members
MaterialConcreteCharacteristics Class Constructors Methods Properties See Also Send Feedback

The MaterialConcreteCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialConcreteCharacteristics()()()() | Creates default instance.
Public method | MaterialConcreteCharacteristics(MaterialConcreteCharacteristics) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BendingReinforcement | Gets the bending reinforcement of the concrete.
Public property | Compression | Gets the compression of the concrete.
Public property | ShearReinforcement | Gets the shear reinforcement of the concrete.
Public property | ShearStrengthReduction | Gets the shear strength reduction of the concrete.

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialConcreteCharacteristics Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialConcreteCharacteristics Constructor
MaterialConcreteCharacteristics Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MaterialConcreteCharacteristics()()()() | Creates default instance.
Public method | MaterialConcreteCharacteristics(MaterialConcreteCharacteristics) | Creates new instance from pattern. Copy constructor.

See Also

MaterialConcreteCharacteristics Class
MaterialConcreteCharacteristics Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialConcreteCharacteristics Constructor

MaterialConcreteCharacteristics Constructor
MaterialConcreteCharacteristics Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialConcreteCharacteristics()

See Also

MaterialConcreteCharacteristics Class
MaterialConcreteCharacteristics Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialConcreteCharacteristics Constructor (MaterialConcreteCharacteristics)

MaterialConcreteCharacteristics Constructor (MaterialConcreteCharacteristics)
MaterialConcreteCharacteristics Class See Also Send Feedback
Creates new instance from pattern. Copy constructor.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialConcreteCharacteristics(
    MaterialConcreteCharacteristics pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialConcreteCharacteristics

See Also

MaterialConcreteCharacteristics Class
MaterialConcreteCharacteristics Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialConcreteCharacteristics Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialConcreteCharacteristics Methods
MaterialConcreteCharacteristics Class See Also Send Feedback

The MaterialConcreteCharacteristics type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

MaterialConcreteCharacteristics..::..Clone Method
MaterialConcreteCharacteristics Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Implements

ICloneable..::..Clone()()()()

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEnumerator Method

MaterialConcreteCharacteristics..::..GetEnumerator Method
MaterialConcreteCharacteristics Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IEnumerator GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialConcreteCharacteristics Properties

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialConcreteCharacteristics Properties
MaterialConcreteCharacteristics Class See Also Send Feedback

The MaterialConcreteCharacteristics type exposes the following members.

Properties

 | Name | Description
Public property | BendingReinforcement | Gets the bending reinforcement of the concrete.
Public property | Compression | Gets the compression of the concrete.
Public property | ShearReinforcement | Gets the shear reinforcement of the concrete.
Public property | ShearStrengthReduction | Gets the shear strength reduction of the concrete.

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


BendingReinforcement Property

MaterialConcreteCharacteristics..::..BendingReinforcement Property
MaterialConcreteCharacteristics Class See Also Send Feedback
Gets the bending reinforcement of the concrete.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double BendingReinforcement { get; internal set; }

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Compression Property

MaterialConcreteCharacteristics..::..Compression Property
MaterialConcreteCharacteristics Class See Also Send Feedback
Gets the compression of the concrete.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Compression { get; internal set; }

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ShearReinforcement Property

MaterialConcreteCharacteristics..::..ShearReinforcement Property
MaterialConcreteCharacteristics Class See Also Send Feedback
Gets the shear reinforcement of the concrete.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double ShearReinforcement { get; internal set; }

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ShearStrengthReduction Property

MaterialConcreteCharacteristics..::..ShearStrengthReduction Property
MaterialConcreteCharacteristics Class See Also Send Feedback
Gets the shear strength reduction of the concrete.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double ShearStrengthReduction { get; internal set; }

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialInfo Class

MaterialInfo Class
Members See Also Send Feedback
Describes the material

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class MaterialInfo : ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialInfo

See Also

MaterialInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialInfo Members
MaterialInfo Class Constructors Methods Properties See Also Send Feedback

The MaterialInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialInfo(MaterialCategory) | Creates new instance.
Public method | MaterialInfo(MaterialInfo) | Creates new instance from pattern. Copy constructor.
Public method | MaterialInfo(MaterialCategory, MaterialProperties, MaterialCharacteristics) | Creates new instance.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets category of the material.
Public property | Characteristics | Gets characteristics of the material.
Public property | Properties | Gets properties of the material.

See Also

MaterialInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialInfo Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialInfo Constructor
MaterialInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MaterialInfo(MaterialCategory) | Creates new instance.
Public method | MaterialInfo(MaterialInfo) | Creates new instance from pattern. Copy constructor.
Public method | MaterialInfo(MaterialCategory, MaterialProperties, MaterialCharacteristics) | Creates new instance.

See Also

MaterialInfo Class
MaterialInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialInfo Constructor (MaterialCategory)

MaterialInfo Constructor (MaterialCategory)
MaterialInfo Class See Also Send Feedback
Creates new instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialInfo(
    MaterialCategory category
)

Parameters

category
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialCategory

See Also

MaterialInfo Class
MaterialInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialInfo Constructor (MaterialInfo)

MaterialInfo Constructor (MaterialInfo)
MaterialInfo Class See Also Send Feedback
Creates new instance from pattern. Copy constructor.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialInfo(
    MaterialInfo pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialInfo

See Also

MaterialInfo Class
MaterialInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialInfo Constructor (MaterialCategory, MaterialProperties, MaterialCharacteristics)

MaterialInfo Constructor (MaterialCategory, MaterialProperties, MaterialCharacteristics)
MaterialInfo Class See Also Send Feedback
Creates new instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialInfo(
    MaterialCategory category,
    MaterialProperties properties,
    MaterialCharacteristics characteristics
)

Parameters

category
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialCategory
properties
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialProperties
characteristics
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialCharacteristics

See Also

MaterialInfo Class
MaterialInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialInfo Methods
MaterialInfo Class See Also Send Feedback

The MaterialInfo type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MaterialInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

MaterialInfo..::..Clone Method
MaterialInfo Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Implements

ICloneable..::..Clone()()()()

See Also

MaterialInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialInfo Properties
MaterialInfo Class See Also Send Feedback

The MaterialInfo type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets category of the material.
Public property | Characteristics | Gets characteristics of the material.
Public property | Properties | Gets properties of the material.

See Also

MaterialInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Category Property

MaterialInfo..::..Category Property
MaterialInfo Class See Also Send Feedback
Gets category of the material.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialCategory Category { get; internal set; }

See Also

MaterialInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Characteristics Property

MaterialInfo..::..Characteristics Property
MaterialInfo Class See Also Send Feedback
Gets characteristics of the material.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialCharacteristics Characteristics { get; }

See Also

MaterialInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Properties Property

MaterialInfo..::..Properties Property
MaterialInfo Class See Also Send Feedback
Gets properties of the material.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialProperties Properties { get; }

See Also

MaterialInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialMetalCharacteristics Class

MaterialMetalCharacteristics Class
Members See Also Send Feedback
Represents characteristics of a metal material.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class MaterialMetalCharacteristics : IEnumerable,
    ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialMetalCharacteristics

See Also

MaterialMetalCharacteristics Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialMetalCharacteristics Members

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialMetalCharacteristics Members
MaterialMetalCharacteristics Class Constructors Methods Properties See Also Send Feedback

The MaterialMetalCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialMetalCharacteristics()()()() | Creates default instance.
Public method | MaterialMetalCharacteristics(MaterialMetalCharacteristics) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MinimumTensileStrength | Gets the minimum tensile strength of the metal.
Public property | MinimumYieldStress | Gets the minimum yield stress of the metal.
Public property | ReductionFactor | Gets the reduction factor for shear of the metal.
Public property | ResistanceCalculationStrength | Gets the resistance calculation strength factor of the metal.

See Also

MaterialMetalCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialMetalCharacteristics Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialMetalCharacteristics Constructor
MaterialMetalCharacteristics Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MaterialMetalCharacteristics()()()() | Creates default instance.
Public method | MaterialMetalCharacteristics(MaterialMetalCharacteristics) | Creates new instance from pattern. Copy constructor.

See Also

MaterialMetalCharacteristics Class
MaterialMetalCharacteristics Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialMetalCharacteristics Constructor

MaterialMetalCharacteristics Constructor
MaterialMetalCharacteristics Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialMetalCharacteristics()

See Also

MaterialMetalCharacteristics Class
MaterialMetalCharacteristics Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialMetalCharacteristics Constructor (MaterialMetalCharacteristics)

MaterialMetalCharacteristics Constructor (MaterialMetalCharacteristics)
MaterialMetalCharacteristics Class See Also Send Feedback
Creates new instance from pattern. Copy constructor.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialMetalCharacteristics(
    MaterialMetalCharacteristics pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialMetalCharacteristics

See Also

MaterialMetalCharacteristics Class
MaterialMetalCharacteristics Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialMetalCharacteristics Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialMetalCharacteristics Methods
MaterialMetalCharacteristics Class See Also Send Feedback

The MaterialMetalCharacteristics type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MaterialMetalCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

MaterialMetalCharacteristics..::..Clone Method
MaterialMetalCharacteristics Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Implements

ICloneable..::..Clone()()()()

See Also

MaterialMetalCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEnumerator Method

MaterialMetalCharacteristics..::..GetEnumerator Method
MaterialMetalCharacteristics Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IEnumerator GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MaterialMetalCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialMetalCharacteristics Properties

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialMetalCharacteristics Properties
MaterialMetalCharacteristics Class See Also Send Feedback

The MaterialMetalCharacteristics type exposes the following members.

Properties

 | Name | Description
Public property | MinimumTensileStrength | Gets the minimum tensile strength of the metal.
Public property | MinimumYieldStress | Gets the minimum yield stress of the metal.
Public property | ReductionFactor | Gets the reduction factor for shear of the metal.
Public property | ResistanceCalculationStrength | Gets the resistance calculation strength factor of the metal.

See Also

MaterialMetalCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MinimumTensileStrength Property

MaterialMetalCharacteristics..::..MinimumTensileStrength Property
MaterialMetalCharacteristics Class See Also Send Feedback
Gets the minimum tensile strength of the metal.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double MinimumTensileStrength { get; internal set; }

See Also

MaterialMetalCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MinimumYieldStress Property

MaterialMetalCharacteristics..::..MinimumYieldStress Property
MaterialMetalCharacteristics Class See Also Send Feedback
Gets the minimum yield stress of the metal.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double MinimumYieldStress { get; internal set; }

See Also

MaterialMetalCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ReductionFactor Property

MaterialMetalCharacteristics..::..ReductionFactor Property
MaterialMetalCharacteristics Class See Also Send Feedback
Gets the reduction factor for shear of the metal.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double ReductionFactor { get; internal set; }

See Also

MaterialMetalCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ResistanceCalculationStrength Property

MaterialMetalCharacteristics..::..ResistanceCalculationStrength Property
MaterialMetalCharacteristics Class See Also Send Feedback
Gets the resistance calculation strength factor of the metal.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double ResistanceCalculationStrength { get; internal set; }

See Also

MaterialMetalCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialProperties Class

MaterialProperties Class
Members See Also Send Feedback
Represents properties of the material.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class MaterialProperties : IEnumerable,
    ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialProperties

See Also

MaterialProperties Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialProperties Members

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialProperties Members
MaterialProperties Class Constructors Methods Properties See Also Send Feedback

The MaterialProperties type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialProperties()()()() | Creates default instance.
Public method | MaterialProperties(MaterialProperties) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets the detailed material description.
Public property | Name | Gets the material's name.
Public property | ResistanceCode | Gets /1. a digit stands for (characteristic or design) resistance, 2. a cubic or cylindric sample).
Public property | SecondName | Gets the second material's name.
Public property | Therm | Gets the material type /for metal: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialProperties Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialProperties Constructor
MaterialProperties Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MaterialProperties()()()() | Creates default instance.
Public method | MaterialProperties(MaterialProperties) | Creates new instance from pattern. Copy constructor.

See Also

MaterialProperties Class
MaterialProperties Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialProperties Constructor

MaterialProperties Constructor
MaterialProperties Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialProperties()

See Also

MaterialProperties Class
MaterialProperties Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialProperties Constructor (MaterialProperties)

MaterialProperties Constructor (MaterialProperties)
MaterialProperties Class See Also Send Feedback
Creates new instance from pattern. Copy constructor.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialProperties(
    MaterialProperties pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialProperties

See Also

MaterialProperties Class
MaterialProperties Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialProperties Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialProperties Methods
MaterialProperties Class See Also Send Feedback

The MaterialProperties type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

MaterialProperties..::..Clone Method
MaterialProperties Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Implements

ICloneable..::..Clone()()()()

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEnumerator Method

MaterialProperties..::..GetEnumerator Method
MaterialProperties Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IEnumerator GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialProperties Properties

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialProperties Properties
MaterialProperties Class See Also Send Feedback

The MaterialProperties type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the detailed material description.
Public property | Name | Gets the material's name.
Public property | ResistanceCode | Gets /1. a digit stands for (characteristic or design) resistance, 2. a cubic or cylindric sample).
Public property | SecondName | Gets the second material's name.
Public property | Therm | Gets the material type /for metal: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Description Property

MaterialProperties..::..Description Property
MaterialProperties Class See Also Send Feedback
Gets the detailed material description.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Description { get; internal set; }

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Name Property

MaterialProperties..::..Name Property
MaterialProperties Class See Also Send Feedback
Gets the material's name.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; internal set; }

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ResistanceCode Property

MaterialProperties..::..ResistanceCode Property
MaterialProperties Class See Also Send Feedback
Gets /1. a digit stands for (characteristic or design) resistance, 2. a cubic or cylindric sample).

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int ResistanceCode { get; internal set; }

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SecondName Property

MaterialProperties..::..SecondName Property
MaterialProperties Class See Also Send Feedback
Gets the second material's name.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string SecondName { get; internal set; }

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Therm Property

MaterialProperties..::..Therm Property
MaterialProperties Class See Also Send Feedback
Gets the material type /for metal: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Therm { get; internal set; }

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialTimberCharacteristics Class

MaterialTimberCharacteristics Class
Members See Also Send Feedback
Represents characteristics of a timber material.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class MaterialTimberCharacteristics : IEnumerable,
    ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialTimberCharacteristics

See Also

MaterialTimberCharacteristics Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialTimberCharacteristics Members

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialTimberCharacteristics Members
MaterialTimberCharacteristics Class Constructors Methods Properties See Also Send Feedback

The MaterialTimberCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialTimberCharacteristics()()()() | Creates default instance.
Public method | MaterialTimberCharacteristics(MaterialTimberCharacteristics) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AverageModulusG | Gets the average modulus G.
Public property | BendingStrength | Gets the bending strength.
Public property | BurningVelocity | Gets burning velocity (mm/min).
Public property | ParallelCompressionStrength | Gets the parallel compression strength.
Public property | ParallelShearStrength | Gets the parallel shear strength.
Public property | PerpendicularCompressionStrength | Gets the perpendicular compression strength.
Public property | PerpendicularShearStrength | Gets the perpendicular shear strength.

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialTimberCharacteristics Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialTimberCharacteristics Constructor
MaterialTimberCharacteristics Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MaterialTimberCharacteristics()()()() | Creates default instance.
Public method | MaterialTimberCharacteristics(MaterialTimberCharacteristics) | Creates new instance from pattern. Copy constructor.

See Also

MaterialTimberCharacteristics Class
MaterialTimberCharacteristics Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialTimberCharacteristics Constructor

MaterialTimberCharacteristics Constructor
MaterialTimberCharacteristics Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialTimberCharacteristics()

See Also

MaterialTimberCharacteristics Class
MaterialTimberCharacteristics Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialTimberCharacteristics Constructor (MaterialTimberCharacteristics)

MaterialTimberCharacteristics Constructor (MaterialTimberCharacteristics)
MaterialTimberCharacteristics Class See Also Send Feedback
Creates new instance from pattern. Copy constructor.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialTimberCharacteristics(
    MaterialTimberCharacteristics pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialTimberCharacteristics

See Also

MaterialTimberCharacteristics Class
MaterialTimberCharacteristics Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialTimberCharacteristics Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialTimberCharacteristics Methods
MaterialTimberCharacteristics Class See Also Send Feedback

The MaterialTimberCharacteristics type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

MaterialTimberCharacteristics..::..Clone Method
MaterialTimberCharacteristics Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Implements

ICloneable..::..Clone()()()()

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEnumerator Method

MaterialTimberCharacteristics..::..GetEnumerator Method
MaterialTimberCharacteristics Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IEnumerator GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaterialTimberCharacteristics Properties

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialTimberCharacteristics Properties
MaterialTimberCharacteristics Class See Also Send Feedback

The MaterialTimberCharacteristics type exposes the following members.

Properties

 | Name | Description
Public property | AverageModulusG | Gets the average modulus G.
Public property | BendingStrength | Gets the bending strength.
Public property | BurningVelocity | Gets burning velocity (mm/min).
Public property | ParallelCompressionStrength | Gets the parallel compression strength.
Public property | ParallelShearStrength | Gets the parallel shear strength.
Public property | PerpendicularCompressionStrength | Gets the perpendicular compression strength.
Public property | PerpendicularShearStrength | Gets the perpendicular shear strength.

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AverageModulusG Property

MaterialTimberCharacteristics..::..AverageModulusG Property
MaterialTimberCharacteristics Class See Also Send Feedback
Gets the average modulus G.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double AverageModulusG { get; internal set; }

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


BendingStrength Property

MaterialTimberCharacteristics..::..BendingStrength Property
MaterialTimberCharacteristics Class See Also Send Feedback
Gets the bending strength.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double BendingStrength { get; internal set; }

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


BurningVelocity Property

MaterialTimberCharacteristics..::..BurningVelocity Property
MaterialTimberCharacteristics Class See Also Send Feedback
Gets burning velocity (mm/min).

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double BurningVelocity { get; internal set; }

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ParallelCompressionStrength Property

MaterialTimberCharacteristics..::..ParallelCompressionStrength Property
MaterialTimberCharacteristics Class See Also Send Feedback
Gets the parallel compression strength.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double ParallelCompressionStrength { get; internal set; }

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ParallelShearStrength Property

MaterialTimberCharacteristics..::..ParallelShearStrength Property
MaterialTimberCharacteristics Class See Also Send Feedback
Gets the parallel shear strength.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double ParallelShearStrength { get; internal set; }

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


PerpendicularCompressionStrength Property

MaterialTimberCharacteristics..::..PerpendicularCompressionStrength Property
MaterialTimberCharacteristics Class See Also Send Feedback
Gets the perpendicular compression strength.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double PerpendicularCompressionStrength { get; internal set; }

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


PerpendicularShearStrength Property

MaterialTimberCharacteristics..::..PerpendicularShearStrength Property
MaterialTimberCharacteristics Class See Also Send Feedback
Gets the perpendicular shear strength.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double PerpendicularShearStrength { get; internal set; }

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


RebarCoversInfo Class

RebarCoversInfo Class
Members See Also Send Feedback
Represents valid covers for element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class RebarCoversInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..RebarCoversInfo

See Also

RebarCoversInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


RebarCoversInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
RebarCoversInfo Members
RebarCoversInfo Class Methods See Also Send Feedback

The RebarCoversInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exist | Check if cover type exist in the element context.
Public method | GetDistance | Returns cover's distance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Returns cover's name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RebarCoversInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


RebarCoversInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RebarCoversInfo Methods
RebarCoversInfo Class See Also Send Feedback

The RebarCoversInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exist | Check if cover type exist in the element context.
Public method | GetDistance | Returns cover's distance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Returns cover's name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RebarCoversInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Exist Method

RebarCoversInfo..::..Exist Method
RebarCoversInfo Class See Also Send Feedback
Check if cover type exist in the element context.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Exist(
    BuiltInParameter coverType
)

Parameters

coverType
Type: BuiltInParameter

See Also

RebarCoversInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetDistance Method

RebarCoversInfo..::..GetDistance Method
RebarCoversInfo Class See Also Send Feedback
Returns cover's distance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetDistance(
    BuiltInParameter coverType
)

Parameters

coverType
Type: BuiltInParameter

See Also

RebarCoversInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetName Method

RebarCoversInfo..::..GetName Method
RebarCoversInfo Class See Also Send Feedback
Returns cover's name.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetName(
    BuiltInParameter coverType
)

Parameters

coverType
Type: BuiltInParameter

See Also

RebarCoversInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ResultType Enumeration

ResultType Enumeration
See Also Send Feedback
Identificator for Reinforced Concrete section results

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ResultType

Members

Member name | Value | Description
Unknown | 0 | Unknown
Abottom | 1 | Longitudinal reinforcement, bottom (bar element)
Atop | 2 | Longitudinal reinforcement, top (bar element)
Aleft | 3 | Longitudinal reinforcement, left (bar element)
Aright | 4 | Longitudinal reinforcement, right (bar element)
StirrSpac | 5 | Stirrup spacing (bar element)
AxxBottom | 6 | Reinforcement xx, bottom (surface element)
AxxTop | 7 | Reinforcement xx, top (surface element)
AyyBottom | 8 | Reinforcement yy, bottom (surface element)
AyyTop | 9 | Reinforcement yy, top (surface element)
UxMin | 10 | Calculated Deflection X, minimum
UyMin | 11 | Calculated Deflection Y, minimum
UzMin | 12 | Calculated Deflection Z, minimum
UxMax | 13 | Calculated Deflection X, maximum
UyMax | 14 | Calculated Deflection Y, maximum
UzMax | 15 | Calculated Deflection Z, maximum
GetLinearResultType |  | Converts ResultType into ResultBuilder LinearResultType
GetSurfaceResultType |  | Converts ResultType into ResultBuilder SurfaceResultType

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Section Class

Section Class
Members See Also Send Feedback
Describes section contour with holes on a plane.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Section

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..Section

See Also

Section Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Section Members

[image]

Structural Analysis and Code Checking API Reference Guide
Section Members
Section Class Constructors Methods Properties See Also Send Feedback

The Section type exposes the following members.

Constructors

 | Name | Description
Public method | Section()()()() | Creates default instance.
Public method | Section(List<(Of <<'(XYZ>)>>)) | Creates instance without holes using points list.
Public method | Section(Section) | Creates instance from pattern. Copy constructor.
Public method | Section(Shape) | Creates instance without holes using shape.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Contour | Gets the shape representing the contour of the section.
Public property | Holes | Gets the list of shapes that representing the holes of the section.

See Also

Section Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Section Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
Section Constructor
Section Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Section()()()() | Creates default instance.
Public method | Section(List<(Of <<'(XYZ>)>>)) | Creates instance without holes using points list.
Public method | Section(Section) | Creates instance from pattern. Copy constructor.
Public method | Section(Shape) | Creates instance without holes using shape.

See Also

Section Class
Section Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Section Constructor

Section Constructor
Section Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Section()

See Also

Section Class
Section Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Section Constructor (List())

Section Constructor (List<(Of <(<'>)>)>)
Section Class See Also Send Feedback
Creates instance without holes using points list.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Section(
    List<XYZ> contour
)

Parameters

contour
Type: System.Collections.Generic..::..List <(Of <(<'XYZ>)>)>

See Also

Section Class
Section Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Section Constructor (Section)

Section Constructor (Section)
Section Class See Also Send Feedback
Creates instance from pattern. Copy constructor.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Section(
    Section pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..Section

See Also

Section Class
Section Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Section Constructor (Shape)

Section Constructor (Shape)
Section Class See Also Send Feedback
Creates instance without holes using shape.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Section(
    Shape contour
)

Parameters

contour
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..Shape

See Also

Section Class
Section Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Section Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Section Methods
Section Class See Also Send Feedback

The Section type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Section Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetMaximumBoundary Method

Section..::..GetMaximumBoundary Method
Section Class See Also Send Feedback
Gets maximum coordinates of upper-right corner.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ GetMaximumBoundary()

See Also

Section Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetMinimumBoundary Method

Section..::..GetMinimumBoundary Method
Section Class See Also Send Feedback
Gets minimum coordinates of lower-left corner.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ GetMinimumBoundary()

See Also

Section Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Section Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Section Properties
Section Class See Also Send Feedback

The Section type exposes the following members.

Properties

 | Name | Description
Public property | Contour | Gets the shape representing the contour of the section.
Public property | Holes | Gets the list of shapes that representing the holes of the section.

See Also

Section Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Contour Property

Section..::..Contour Property
Section Class See Also Send Feedback
Gets the shape representing the contour of the section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Shape Contour { get; internal set; }

See Also

Section Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Holes Property

Section..::..Holes Property
Section Class See Also Send Feedback
Gets the list of shapes that representing the holes of the section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Shape> Holes { get; internal set; }

See Also

Section Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionCharacteristics Class

SectionCharacteristics Class
Members See Also Send Feedback
Describes characteristics of the parametric section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SectionCharacteristics : IEnumerable,
    ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionCharacteristics

See Also

SectionCharacteristics Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionCharacteristics Members

[image]

Structural Analysis and Code Checking API Reference Guide
SectionCharacteristics Members
SectionCharacteristics Class Constructors Methods Properties See Also Send Feedback

The SectionCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | SectionCharacteristics()()()() | Initializes a new instance of the SectionCharacteristics class.
Public method | SectionCharacteristics(SectionCharacteristics) | Initializes a new instance of the SectionCharacteristics class.

Methods

 | Name | Description
Public method | Clear | Sets to defaults.
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | A | Gets or sets the Cross-section area.
Public property | Iy | Gets or sets the moment of inertia about the Y axis.
Public property | Iz | Gets or sets the moment of inertia about the Z axis.
Public property | mass | Gets or sets the nominal weight per unit length.
Public property | ry | Gets or sets the radius of gyration about the Y axis.
Public property | rz | Gets or sets the radius of gyration about the Z axis.

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionCharacteristics Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SectionCharacteristics Constructor
SectionCharacteristics Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SectionCharacteristics()()()() | Initializes a new instance of the SectionCharacteristics class.
Public method | SectionCharacteristics(SectionCharacteristics) | Initializes a new instance of the SectionCharacteristics class.

See Also

SectionCharacteristics Class
SectionCharacteristics Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionCharacteristics Constructor

SectionCharacteristics Constructor
SectionCharacteristics Class See Also Send Feedback
Initializes a new instance of the SectionCharacteristics class.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionCharacteristics()

See Also

SectionCharacteristics Class
SectionCharacteristics Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionCharacteristics Constructor (SectionCharacteristics)

SectionCharacteristics Constructor (SectionCharacteristics)
SectionCharacteristics Class See Also Send Feedback
Initializes a new instance of the SectionCharacteristics class.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionCharacteristics(
    SectionCharacteristics pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionCharacteristics
The pattern.

See Also

SectionCharacteristics Class
SectionCharacteristics Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionCharacteristics Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SectionCharacteristics Methods
SectionCharacteristics Class See Also Send Feedback

The SectionCharacteristics type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Sets to defaults.
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clear Method

SectionCharacteristics..::..Clear Method
SectionCharacteristics Class See Also Send Feedback
Sets to defaults.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Clear()

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

SectionCharacteristics..::..Clone Method
SectionCharacteristics Class See Also Send Feedback
Clones this instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Return Value

New instance

Implements

ICloneable..::..Clone()()()()

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEnumerator Method

SectionCharacteristics..::..GetEnumerator Method
SectionCharacteristics Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IEnumerator GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionCharacteristics Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SectionCharacteristics Properties
SectionCharacteristics Class See Also Send Feedback

The SectionCharacteristics type exposes the following members.

Properties

 | Name | Description
Public property | A | Gets or sets the Cross-section area.
Public property | Iy | Gets or sets the moment of inertia about the Y axis.
Public property | Iz | Gets or sets the moment of inertia about the Z axis.
Public property | mass | Gets or sets the nominal weight per unit length.
Public property | ry | Gets or sets the radius of gyration about the Y axis.
Public property | rz | Gets or sets the radius of gyration about the Z axis.

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


A Property

SectionCharacteristics..::..A Property
SectionCharacteristics Class See Also Send Feedback
Gets or sets the Cross-section area.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double A { get; set; }

Field Value

The Cross-section area.

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Iy Property

SectionCharacteristics..::..Iy Property
SectionCharacteristics Class See Also Send Feedback
Gets or sets the moment of inertia about the Y axis.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Iy { get; set; }

Field Value

The moment of inertia about the Y axis.

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Iz Property

SectionCharacteristics..::..Iz Property
SectionCharacteristics Class See Also Send Feedback
Gets or sets the moment of inertia about the Z axis.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Iz { get; set; }

Field Value

The moment of inertia about the Z axis.

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


mass Property

SectionCharacteristics..::..mass Property
SectionCharacteristics Class See Also Send Feedback
Gets or sets the nominal weight per unit length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double mass { get; set; }

Field Value

The nominal weight per unit length.

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ry Property

SectionCharacteristics..::..ry Property
SectionCharacteristics Class See Also Send Feedback
Gets or sets the radius of gyration about the Y axis.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double ry { get; set; }

Field Value

The radius of gyration about the Y axis.

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


rz Property

SectionCharacteristics..::..rz Property
SectionCharacteristics Class See Also Send Feedback
Gets or sets the radius of gyration about the Z axis.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double rz { get; set; }

Field Value

The radius of gyration about the Z axis.

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionDimensions Class

SectionDimensions Class
Members See Also Send Feedback
Describes dimentsions of the parametric section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SectionDimensions : IEnumerable,
    IComparable, ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionDimensions

See Also

SectionDimensions Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionDimensions Members

[image]

Structural Analysis and Code Checking API Reference Guide
SectionDimensions Members
SectionDimensions Class Constructors Methods Properties See Also Send Feedback

The SectionDimensions type exposes the following members.

Constructors

 | Name | Description
Public method | SectionDimensions()()()() | Initializes a new instance of the SectionDimensions class.
Public method | SectionDimensions(SectionDimensions) | Initializes a new instance of the SectionDimensions class.

Methods

 | Name | Description
Public method | Clear | Sets to defaults.
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | b | Gets or sets the full width of the section or the flange(the slab) width for a symmetrical section.
Public property | bf | Gets or sets the flange width.
Public property | bf1 | Gets or sets the flange width.
Public property | bf2 | Gets or sets the flange width.
Public property | h | Gets or sets the full depth of the section.
Public property | h1 | Gets or sets the dimension of a vertical cutout.
Public property | h2 | Gets or sets the dimension of a vertical cutout.
Public property | hw | Gets or sets the height of the web.
Public property | hw1 | Gets or sets the height of the main web.
Public property | hw2 | Gets or sets the height of the secondary web.
Public property | l1 | Gets or sets the dimension of a horizontal cutout.
Public property | l2 | Gets or sets the dimension of a horizontal cutout.
Public property | s | Gets or sets the separation.
Public property | t | Gets or sets the thickness of hollow sections.
Public property | tf | Gets or sets the flange thickness or for T-concret section the slab height .
Public property | tf1 | Gets or sets the flange thickness.
Public property | tf2 | Gets or sets the flange thickness.
Public property | tw | Gets or sets the web thickness.
Public property | tw1 | Gets or sets the main web thickness.
Public property | tw2 | Gets or sets the secondary web thickness.
Public property | vpy | Gets or sets the horizontal distance of the negative edge of section to center of gravity.
Public property | vpz | Gets or sets the vertical distance of the negative edge of section to center of gravity.
Public property | vy | Gets or sets the horizontal distance of the positive edge of section to center of gravity.
Public property | vz | Gets or sets the vertical distance of the positive edge of section to center of gravity.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionDimensions Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SectionDimensions Constructor
SectionDimensions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SectionDimensions()()()() | Initializes a new instance of the SectionDimensions class.
Public method | SectionDimensions(SectionDimensions) | Initializes a new instance of the SectionDimensions class.

See Also

SectionDimensions Class
SectionDimensions Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionDimensions Constructor

SectionDimensions Constructor
SectionDimensions Class See Also Send Feedback
Initializes a new instance of the SectionDimensions class.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionDimensions()

See Also

SectionDimensions Class
SectionDimensions Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionDimensions Constructor (SectionDimensions)

SectionDimensions Constructor (SectionDimensions)
SectionDimensions Class See Also Send Feedback
Initializes a new instance of the SectionDimensions class.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionDimensions(
    SectionDimensions pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionDimensions
The pattern.

See Also

SectionDimensions Class
SectionDimensions Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionDimensions Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SectionDimensions Methods
SectionDimensions Class See Also Send Feedback

The SectionDimensions type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Sets to defaults.
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clear Method

SectionDimensions..::..Clear Method
SectionDimensions Class See Also Send Feedback
Sets to defaults.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Clear()

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

SectionDimensions..::..Clone Method
SectionDimensions Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CompareTo Method

SectionDimensions..::..CompareTo Method
SectionDimensions Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual int CompareTo(
    Object obj
)

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

Returns a result of the comparison.

Implements

IComparable..::..CompareTo(Object)

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEnumerator Method

SectionDimensions..::..GetEnumerator Method
SectionDimensions Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IEnumerator GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionDimensions Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SectionDimensions Properties
SectionDimensions Class See Also Send Feedback

The SectionDimensions type exposes the following members.

Properties

 | Name | Description
Public property | b | Gets or sets the full width of the section or the flange(the slab) width for a symmetrical section.
Public property | bf | Gets or sets the flange width.
Public property | bf1 | Gets or sets the flange width.
Public property | bf2 | Gets or sets the flange width.
Public property | h | Gets or sets the full depth of the section.
Public property | h1 | Gets or sets the dimension of a vertical cutout.
Public property | h2 | Gets or sets the dimension of a vertical cutout.
Public property | hw | Gets or sets the height of the web.
Public property | hw1 | Gets or sets the height of the main web.
Public property | hw2 | Gets or sets the height of the secondary web.
Public property | l1 | Gets or sets the dimension of a horizontal cutout.
Public property | l2 | Gets or sets the dimension of a horizontal cutout.
Public property | s | Gets or sets the separation.
Public property | t | Gets or sets the thickness of hollow sections.
Public property | tf | Gets or sets the flange thickness or for T-concret section the slab height .
Public property | tf1 | Gets or sets the flange thickness.
Public property | tf2 | Gets or sets the flange thickness.
Public property | tw | Gets or sets the web thickness.
Public property | tw1 | Gets or sets the main web thickness.
Public property | tw2 | Gets or sets the secondary web thickness.
Public property | vpy | Gets or sets the horizontal distance of the negative edge of section to center of gravity.
Public property | vpz | Gets or sets the vertical distance of the negative edge of section to center of gravity.
Public property | vy | Gets or sets the horizontal distance of the positive edge of section to center of gravity.
Public property | vz | Gets or sets the vertical distance of the positive edge of section to center of gravity.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


b Property

SectionDimensions..::..b Property
SectionDimensions Class See Also Send Feedback
Gets or sets the full width of the section or the flange(the slab) width for a symmetrical section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double b { get; set; }

Field Value

The b.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


bf Property

SectionDimensions..::..bf Property
SectionDimensions Class See Also Send Feedback
Gets or sets the flange width.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double bf { get; set; }

Field Value

The bf.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


bf1 Property

SectionDimensions..::..bf1 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the flange width.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double bf1 { get; set; }

Field Value

The bf1.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


bf2 Property

SectionDimensions..::..bf2 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the flange width.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double bf2 { get; set; }

Field Value

The bf2.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


h Property

SectionDimensions..::..h Property
SectionDimensions Class See Also Send Feedback
Gets or sets the full depth of the section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double h { get; set; }

Field Value

The h.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


h1 Property

SectionDimensions..::..h1 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the dimension of a vertical cutout.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double h1 { get; set; }

Field Value

The h1.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


h2 Property

SectionDimensions..::..h2 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the dimension of a vertical cutout.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double h2 { get; set; }

Field Value

The h2.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


hw Property

SectionDimensions..::..hw Property
SectionDimensions Class See Also Send Feedback
Gets or sets the height of the web.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double hw { get; set; }

Field Value

The hw.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


hw1 Property

SectionDimensions..::..hw1 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the height of the main web.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double hw1 { get; set; }

Field Value

The hw1.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


hw2 Property

SectionDimensions..::..hw2 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the height of the secondary web.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double hw2 { get; set; }

Field Value

The hw2.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


l1 Property

SectionDimensions..::..l1 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the dimension of a horizontal cutout.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double l1 { get; set; }

Field Value

The l1.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


l2 Property

SectionDimensions..::..l2 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the dimension of a horizontal cutout.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double l2 { get; set; }

Field Value

The l2.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


s Property

SectionDimensions..::..s Property
SectionDimensions Class See Also Send Feedback
Gets or sets the separation.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double s { get; set; }

Field Value

The s.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


t Property

SectionDimensions..::..t Property
SectionDimensions Class See Also Send Feedback
Gets or sets the thickness of hollow sections.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double t { get; set; }

Field Value

The t.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


tf Property

SectionDimensions..::..tf Property
SectionDimensions Class See Also Send Feedback
Gets or sets the flange thickness or for T-concret section the slab height .

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double tf { get; set; }

Field Value

The tf.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


tf1 Property

SectionDimensions..::..tf1 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the flange thickness.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double tf1 { get; set; }

Field Value

The tf1.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


tf2 Property

SectionDimensions..::..tf2 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the flange thickness.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double tf2 { get; set; }

Field Value

The tf2.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


tw Property

SectionDimensions..::..tw Property
SectionDimensions Class See Also Send Feedback
Gets or sets the web thickness.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double tw { get; set; }

Field Value

The tw.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


tw1 Property

SectionDimensions..::..tw1 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the main web thickness.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double tw1 { get; set; }

Field Value

The tw1.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


tw2 Property

SectionDimensions..::..tw2 Property
SectionDimensions Class See Also Send Feedback
Gets or sets the secondary web thickness.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double tw2 { get; set; }

Field Value

The tw2.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


vpy Property

SectionDimensions..::..vpy Property
SectionDimensions Class See Also Send Feedback
Gets or sets the horizontal distance of the negative edge of section to center of gravity.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double vpy { get; set; }

Field Value

The vpy.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


vpz Property

SectionDimensions..::..vpz Property
SectionDimensions Class See Also Send Feedback
Gets or sets the vertical distance of the negative edge of section to center of gravity.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double vpz { get; set; }

Field Value

The vpz.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


vy Property

SectionDimensions..::..vy Property
SectionDimensions Class See Also Send Feedback
Gets or sets the horizontal distance of the positive edge of section to center of gravity.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double vy { get; set; }

Field Value

The vy.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


vz Property

SectionDimensions..::..vz Property
SectionDimensions Class See Also Send Feedback
Gets or sets the vertical distance of the positive edge of section to center of gravity.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double vz { get; set; }

Field Value

The vz.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionProfile Class

SectionProfile Class
Members See Also Send Feedback
Represents the parameters of profile of element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SectionProfile : IComparable,
    ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionProfile
Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsParamsInfo

See Also

SectionProfile Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionProfile Members

[image]

Structural Analysis and Code Checking API Reference Guide
SectionProfile Members
SectionProfile Class Constructors Methods Properties See Also Send Feedback

The SectionProfile type exposes the following members.

Constructors

 | Name | Description
Public method | SectionProfile()()()() | Creates default instance (not tapered).
Public method | SectionProfile(SectionProfile) | Creates instance from pattern.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ComponentsShapeType | Gets the list of components types of the shapes for double or compound section.
Public property | ShapeType | Gets the type of the shape of section.
Public property | Tapered | Gets a value indicating whether the profile is tapered.

See Also

SectionProfile Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionProfile Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SectionProfile Constructor
SectionProfile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SectionProfile()()()() | Creates default instance (not tapered).
Public method | SectionProfile(SectionProfile) | Creates instance from pattern.

See Also

SectionProfile Class
SectionProfile Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionProfile Constructor

SectionProfile Constructor
SectionProfile Class See Also Send Feedback
Creates default instance (not tapered).

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionProfile()

See Also

SectionProfile Class
SectionProfile Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionProfile Constructor (SectionProfile)

SectionProfile Constructor (SectionProfile)
SectionProfile Class See Also Send Feedback
Creates instance from pattern.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionProfile(
    SectionProfile pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionProfile

See Also

SectionProfile Class
SectionProfile Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionProfile Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SectionProfile Methods
SectionProfile Class See Also Send Feedback

The SectionProfile type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SectionProfile Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

SectionProfile..::..Clone Method
SectionProfile Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

SectionProfile Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


CompareTo Method

SectionProfile..::..CompareTo Method
SectionProfile Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual int CompareTo(
    Object obj
)

Parameters

obj
Type: System..::..Object

Implements

IComparable..::..CompareTo(Object)

See Also

SectionProfile Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionProfile Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SectionProfile Properties
SectionProfile Class See Also Send Feedback

The SectionProfile type exposes the following members.

Properties

 | Name | Description
Public property | ComponentsShapeType | Gets the list of components types of the shapes for double or compound section.
Public property | ShapeType | Gets the type of the shape of section.
Public property | Tapered | Gets a value indicating whether the profile is tapered.

See Also

SectionProfile Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ComponentsShapeType Property

SectionProfile..::..ComponentsShapeType Property
SectionProfile Class See Also Send Feedback
Gets the list of components types of the shapes for double or compound section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SectionShapeType> ComponentsShapeType { get; internal set; }

See Also

SectionProfile Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ShapeType Property

SectionProfile..::..ShapeType Property
SectionProfile Class See Also Send Feedback
Gets the type of the shape of section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionShapeType ShapeType { get; internal set; }

See Also

SectionProfile Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Tapered Property

SectionProfile..::..Tapered Property
SectionProfile Class See Also Send Feedback
Gets a value indicating whether the profile is tapered.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Tapered { get; internal set; }

See Also

SectionProfile Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionShapeType Enumeration

SectionShapeType Enumeration
See Also Send Feedback
Typ of the section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SectionShapeType

Members

Member name | Value | Description
RectangularHollowConstant | 1 | Rectangular hollow tube with one thickness t
RectangularBar | 2 | Rectangular bar.
RoundTube | 3 | Round tube.
RoundBar | 4 | Round bar.
HalfRoundBar | 5 | Half round bar.
QuarterRoundBar | 6 | Quadrant round bar
RectangularHollowNotConstant | 7 | Rectangular hollow tube with 2 thicknesses tw , tf.
BoxBiSymmetrical | 8 | Bisymetrical box, flanges beyond the outline of webs.
BoxMonoSymmetrical | 9 | Monosymetrical box, flanges beyond the outline of webs.
I | 10 | I-section.
IASymmetrical | 11 | Asymmetrical I-section.
T | 12 | T-section.
C | 13 | C-section.
Z | 14 | Z-section.
CrossBiSymmetrical | 15 | Cross bisymetrical shaped section.
PolygonalBar | 16 | Polygonal bar.
PolygonalHollow | 17 | Polygonal hollow tube.
L | 18 | L type angle section
TAsymmetrical | 19 | Asymmetrical T-section.
DoubleRectangularBar | 20 | Double section.
DoubleSection | 21 | Double sections.
CompoundSection | 22 | Compound section
Unusual | 0 | Unusual section.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsInfo Class

SectionsInfo Class
Members See Also Send Feedback
Describes sections or compound sections along element length.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SectionsInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionsInfo

See Also

SectionsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
SectionsInfo Members
SectionsInfo Class Constructors Methods Properties See Also Send Feedback

The SectionsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SectionsInfo()()()() | Creates default instance.
Public method | SectionsInfo(Section) | Creates instance using Section class.
Public method | SectionsInfo(List<(Of <<'(Section>)>>)) | Creates instance using list of sections.
Public method | SectionsInfo(SectionsInfo) | Creates instance from pattern.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCenter | Gets center coordinates of sections.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Sections | Gets the list of sections.
Public property | Transform | Gets or sets class allows to transform points from local to global (and vice versa) coordinate system.

See Also

SectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsInfo Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SectionsInfo Constructor
SectionsInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SectionsInfo()()()() | Creates default instance.
Public method | SectionsInfo(Section) | Creates instance using Section class.
Public method | SectionsInfo(List<(Of <<'(Section>)>>)) | Creates instance using list of sections.
Public method | SectionsInfo(SectionsInfo) | Creates instance from pattern.

See Also

SectionsInfo Class
SectionsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsInfo Constructor

SectionsInfo Constructor
SectionsInfo Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsInfo()

See Also

SectionsInfo Class
SectionsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsInfo Constructor (Section)

SectionsInfo Constructor (Section)
SectionsInfo Class See Also Send Feedback
Creates instance using Section class.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsInfo(
    Section section
)

Parameters

section
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..Section

See Also

SectionsInfo Class
SectionsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsInfo Constructor (List(Section))

SectionsInfo Constructor (List<(Of <(<'Section>)>)>)
SectionsInfo Class See Also Send Feedback
Creates instance using list of sections.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsInfo(
    List<Section> sections
)

Parameters

sections
Type: System.Collections.Generic..::..List <(Of <(<' Section >)>)>

See Also

SectionsInfo Class
SectionsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsInfo Constructor (SectionsInfo)

SectionsInfo Constructor (SectionsInfo)
SectionsInfo Class See Also Send Feedback
Creates instance from pattern.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsInfo(
    SectionsInfo pattern
)

Parameters

pattern
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionsInfo

See Also

SectionsInfo Class
SectionsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SectionsInfo Methods
SectionsInfo Class See Also Send Feedback

The SectionsInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCenter | Gets center coordinates of sections.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetCenter Method

SectionsInfo..::..GetCenter Method
SectionsInfo Class See Also Send Feedback
Gets center coordinates of sections.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ GetCenter()

See Also

SectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetMaximumBoundary Method

SectionsInfo..::..GetMaximumBoundary Method
SectionsInfo Class See Also Send Feedback
Gets maximum coordinates of upper-right corner.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ GetMaximumBoundary()

See Also

SectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetMinimumBoundary Method

SectionsInfo..::..GetMinimumBoundary Method
SectionsInfo Class See Also Send Feedback
Gets minimum coordinates of lower-left corner.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ GetMinimumBoundary()

See Also

SectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SectionsInfo Properties
SectionsInfo Class See Also Send Feedback

The SectionsInfo type exposes the following members.

Properties

 | Name | Description
Public property | Sections | Gets the list of sections.
Public property | Transform | Gets or sets class allows to transform points from local to global (and vice versa) coordinate system.

See Also

SectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Sections Property

SectionsInfo..::..Sections Property
SectionsInfo Class See Also Send Feedback
Gets the list of sections.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Section> Sections { get; internal set; }

See Also

SectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Transform Property

SectionsInfo..::..Transform Property
SectionsInfo Class See Also Send Feedback
Gets or sets class allows to transform points from local to global (and vice versa) coordinate system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CoordinateSystem Transform { get; internal set; }

See Also

SectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsParamsInfo Class

SectionsParamsInfo Class
Members See Also Send Feedback
Describes dimensions and characteristics of the parametric section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SectionsParamsInfo : ICloneable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionsParamsInfo

See Also

SectionsParamsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsParamsInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
SectionsParamsInfo Members
SectionsParamsInfo Class Constructors Methods Properties See Also Send Feedback

The SectionsParamsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SectionsParamsInfo()()()() | Initializes a new instance of the SectionsInfo class.
Public method | SectionsParamsInfo(SectionDimensions, SectionCharacteristics) | Initializes a new instance of the SectionsInfo class.
Public method | SectionsParamsInfo(SectionDimensions, SectionCharacteristics, List<(Of <<'(SectionDimensions>)>>), List<(Of <<'(SectionCharacteristics>)>>)) | Initializes a new instance of the SectionsInfo class.

Methods

 | Name | Description
Public method | Clear | Sets to defaults.
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Characteristics | Gets the characteristics of section. For double sections or compound sections gets the characteristics for a whole section.
Public property | ComponentsCharacteristics | Gets the characteristics of section components (double sections or compound sections). In other case returns null.
Public property | ComponentsDimensions | Gets the dimensions of section components (double sections or compound sections). In other case returns null.
Public property | Dimensions | Gets the dimensions of section. For double sections or compound sections gets the dimensions for a whole section.

See Also

SectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsParamsInfo Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SectionsParamsInfo Constructor
SectionsParamsInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SectionsParamsInfo()()()() | Initializes a new instance of the SectionsInfo class.
Public method | SectionsParamsInfo(SectionDimensions, SectionCharacteristics) | Initializes a new instance of the SectionsInfo class.
Public method | SectionsParamsInfo(SectionDimensions, SectionCharacteristics, List<(Of <<'(SectionDimensions>)>>), List<(Of <<'(SectionCharacteristics>)>>)) | Initializes a new instance of the SectionsInfo class.

See Also

SectionsParamsInfo Class
SectionsParamsInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsParamsInfo Constructor

SectionsParamsInfo Constructor
SectionsParamsInfo Class See Also Send Feedback
Initializes a new instance of the SectionsInfo class.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsParamsInfo()

See Also

SectionsParamsInfo Class
SectionsParamsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsParamsInfo Constructor (SectionDimensions, SectionCharacteristics)

SectionsParamsInfo Constructor (SectionDimensions, SectionCharacteristics)
SectionsParamsInfo Class See Also Send Feedback
Initializes a new instance of the SectionsInfo class.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsParamsInfo(
    SectionDimensions dimensions,
    SectionCharacteristics characteristics
)

Parameters

dimensions
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionDimensions
characteristics
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionCharacteristics

See Also

SectionsParamsInfo Class
SectionsParamsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsParamsInfo Constructor (SectionDimensions, SectionCharacteristics, List(SectionDimensions), List(SectionCharacteristics))

SectionsParamsInfo Constructor (SectionDimensions, SectionCharacteristics, List<(Of <(<'SectionDimensions>)>)>, List<(Of <(<'SectionCharacteristics>)>)>)
SectionsParamsInfo Class See Also Send Feedback
Initializes a new instance of the SectionsInfo class.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionsParamsInfo(
    SectionDimensions dimensions,
    SectionCharacteristics characteristics,
    List<SectionDimensions> componentsDimensions,
    List<SectionCharacteristics> componentsCharacteristics
)

Parameters

dimensions
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionDimensions
characteristics
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SectionCharacteristics
componentsDimensions
Type: System.Collections.Generic..::..List <(Of <(<' SectionDimensions >)>)>
componentsCharacteristics
Type: System.Collections.Generic..::..List <(Of <(<' SectionCharacteristics >)>)>

See Also

SectionsParamsInfo Class
SectionsParamsInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsParamsInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SectionsParamsInfo Methods
SectionsParamsInfo Class See Also Send Feedback

The SectionsParamsInfo type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Sets to defaults.
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clear Method

SectionsParamsInfo..::..Clear Method
SectionsParamsInfo Class See Also Send Feedback
Sets to defaults.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Clear()

See Also

SectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Clone Method

SectionsParamsInfo..::..Clone Method
SectionsParamsInfo Class See Also Send Feedback
Clones this instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Return Value

New instance

Implements

ICloneable..::..Clone()()()()

See Also

SectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SectionsParamsInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SectionsParamsInfo Properties
SectionsParamsInfo Class See Also Send Feedback

The SectionsParamsInfo type exposes the following members.

Properties

 | Name | Description
Public property | Characteristics | Gets the characteristics of section. For double sections or compound sections gets the characteristics for a whole section.
Public property | ComponentsCharacteristics | Gets the characteristics of section components (double sections or compound sections). In other case returns null.
Public property | ComponentsDimensions | Gets the dimensions of section components (double sections or compound sections). In other case returns null.
Public property | Dimensions | Gets the dimensions of section. For double sections or compound sections gets the dimensions for a whole section.

See Also

SectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Characteristics Property

SectionsParamsInfo..::..Characteristics Property
SectionsParamsInfo Class See Also Send Feedback
Gets the characteristics of section. For double sections or compound sections gets the characteristics for a whole section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionCharacteristics Characteristics { get; }

Field Value

The characteristics of section.

See Also

SectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ComponentsCharacteristics Property

SectionsParamsInfo..::..ComponentsCharacteristics Property
SectionsParamsInfo Class See Also Send Feedback
Gets the characteristics of section components (double sections or compound sections). In other case returns null.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SectionCharacteristics> ComponentsCharacteristics { get; internal set; }

Field Value

The characteristics of section components.

See Also

SectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ComponentsDimensions Property

SectionsParamsInfo..::..ComponentsDimensions Property
SectionsParamsInfo Class See Also Send Feedback
Gets the dimensions of section components (double sections or compound sections). In other case returns null.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SectionDimensions> ComponentsDimensions { get; internal set; }

Field Value

The dimensions of section components.

See Also

SectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Dimensions Property

SectionsParamsInfo..::..Dimensions Property
SectionsParamsInfo Class See Also Send Feedback
Gets the dimensions of section. For double sections or compound sections gets the dimensions for a whole section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SectionDimensions Dimensions { get; }

Field Value

The dimensions of section.

See Also

SectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Shape Class

Shape Class
Members See Also Send Feedback
Describes flat shape on a plane.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Shape

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..Shape

See Also

Shape Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Shape Members

[image]

Structural Analysis and Code Checking API Reference Guide
Shape Members
Shape Class Constructors Methods Properties See Also Send Feedback

The Shape type exposes the following members.

Constructors

 | Name | Description
Public method | Shape()()()() | Creates default instance.
Public method | Shape(List<(Of <<'(XYZ>)>>)) | Creates instance using list of points.
Public method | Shape(Shape) | Creates instance using shape. Copy constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetTurnedPointsList | Gets list of points for this shape turned by an angle.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsContourInside | Check if a contour is inside this shape.
Public method | IsPointInside | Check if a point is inside this shape.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Points | Gets list of points describing the polygon representing the shape.

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Shape Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
Shape Constructor
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Shape()()()() | Creates default instance.
Public method | Shape(List<(Of <<'(XYZ>)>>)) | Creates instance using list of points.
Public method | Shape(Shape) | Creates instance using shape. Copy constructor.

See Also

Shape Class
Shape Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Shape Constructor

Shape Constructor
Shape Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Shape()

See Also

Shape Class
Shape Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Shape Constructor (List())

Shape Constructor (List<(Of <(<'>)>)>)
Shape Class See Also Send Feedback
Creates instance using list of points.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Shape(
    List<XYZ> points
)

Parameters

points
Type: System.Collections.Generic..::..List <(Of <(<'XYZ>)>)>

See Also

Shape Class
Shape Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Shape Constructor (Shape)

Shape Constructor (Shape)
Shape Class See Also Send Feedback
Creates instance using shape. Copy constructor.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Shape(
    Shape shape
)

Parameters

shape
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..Shape

See Also

Shape Class
Shape Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Shape Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Shape Methods
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetTurnedPointsList | Gets list of points for this shape turned by an angle.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsContourInside | Check if a contour is inside this shape.
Public method | IsPointInside | Check if a point is inside this shape.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetMaximumBoundary Method

Shape..::..GetMaximumBoundary Method
Shape Class See Also Send Feedback
Gets maximum coordinates of upper-right corner.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ GetMaximumBoundary()

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetMinimumBoundary Method

Shape..::..GetMinimumBoundary Method
Shape Class See Also Send Feedback
Gets minimum coordinates of lower-left corner.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ GetMinimumBoundary()

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetTurnedPointsList Method

Shape..::..GetTurnedPointsList Method
Shape Class See Also Send Feedback
Gets list of points for this shape turned by an angle.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<XYZ> GetTurnedPointsList(
    double angle
)

Parameters

angle
Type: System..::..Double

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsContourInside Method

Shape..::..IsContourInside Method
Shape Class See Also Send Feedback
Check if a contour is inside this shape.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsContourInside(
    List<XYZ> points
)

Parameters

points
Type: System.Collections.Generic..::..List <(Of <(<'XYZ>)>)>

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsPointInside Method

Shape..::..IsPointInside Method
Shape Class See Also Send Feedback
Check if a point is inside this shape.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsPointInside(
    XYZ pt
)

Parameters

pt
Type: XYZ

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Shape Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Shape Properties
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Properties

 | Name | Description
Public property | Points | Gets list of points describing the polygon representing the shape.

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Points Property

Shape..::..Points Property
Shape Class See Also Send Feedback
Gets list of points describing the polygon representing the shape.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<XYZ> Points { get; internal set; }

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabAdjoiningRevitElementType Enumeration

SlabAdjoiningRevitElementType Enumeration
See Also Send Feedback
Defines type of adjoining Revit element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SlabAdjoiningRevitElementType

Members

Member name | Value | Description
FamilyInstance | 0 | Structural framing element.
CrossingFamilyInstance | 1 | Structural column crossing element.
UpperFamilyInstance | 2 | Structural column element adjoining from the top.
LowerFamilyInstance | 3 | Structural column element adjoining from the bottom.
Wall | 4 | Wall adjoining the side.
UpperWall | 5 | Wall adjoining from the top.
LowerWall | 6 | Wall adjoining from the bottom.
None | 7 | None.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabBaseObject Class

SlabBaseObject Class
Members See Also Send Feedback
Base class for each element of the slab geometry

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class SlabBaseObject : IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabBaseObject
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabContour
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabEdge
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabNode

See Also

SlabBaseObject Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabBaseObject Members

[image]

Structural Analysis and Code Checking API Reference Guide
SlabBaseObject Members
SlabBaseObject Class Constructors Methods Properties See Also Send Feedback

The SlabBaseObject type exposes the following members.

Constructors

 | Name | Description
Public method | SlabBaseObject()()()() | Construct object.
Public method | SlabBaseObject(SlabInfo) | Construct object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element.
Public property | ContextId | Revit Id of element.
Public property | ElementType | Type of element.
Public property | ParentSlab | Parent slab.

See Also

SlabBaseObject Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabBaseObject Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SlabBaseObject Constructor
SlabBaseObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SlabBaseObject()()()() | Construct object.
Public method | SlabBaseObject(SlabInfo) | Construct object.

See Also

SlabBaseObject Class
SlabBaseObject Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabBaseObject Constructor

SlabBaseObject Constructor
SlabBaseObject Class See Also Send Feedback
Construct object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabBaseObject()

See Also

SlabBaseObject Class
SlabBaseObject Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabBaseObject Constructor (SlabInfo)

SlabBaseObject Constructor (SlabInfo)
SlabBaseObject Class See Also Send Feedback
Construct object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabBaseObject(
    SlabInfo parentSlab
)

Parameters

parentSlab
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabInfo

See Also

SlabBaseObject Class
SlabBaseObject Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabBaseObject Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SlabBaseObject Methods
SlabBaseObject Class See Also Send Feedback

The SlabBaseObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabBaseObject Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEnumerator Method

SlabBaseObject..::..GetEnumerator Method
SlabBaseObject Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IEnumerator GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SlabBaseObject Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabBaseObject Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SlabBaseObject Properties
SlabBaseObject Class See Also Send Feedback

The SlabBaseObject type exposes the following members.

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element.
Public property | ContextId | Revit Id of element.
Public property | ElementType | Type of element.
Public property | ParentSlab | Parent slab.

See Also

SlabBaseObject Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


AdjoiningElementType Property

SlabBaseObject..::..AdjoiningElementType Property
SlabBaseObject Class See Also Send Feedback
Type of origin Revit element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabAdjoiningRevitElementType AdjoiningElementType { get; set; }

See Also

SlabBaseObject Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ContextId Property

SlabBaseObject..::..ContextId Property
SlabBaseObject Class See Also Send Feedback
Revit Id of element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int ContextId { get; set; }

See Also

SlabBaseObject Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ElementType Property

SlabBaseObject..::..ElementType Property
SlabBaseObject Class See Also Send Feedback
Type of element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabGeometryObjectType ElementType { get; set; }

See Also

SlabBaseObject Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ParentSlab Property

SlabBaseObject..::..ParentSlab Property
SlabBaseObject Class See Also Send Feedback
Parent slab.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabInfo ParentSlab { get; set; }

See Also

SlabBaseObject Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabContour Class

SlabContour Class
Members See Also Send Feedback
Represents Contour. Contour is a list of edges and nodes with parent characteristics.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SlabContour : SlabBaseObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabBaseObject
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabContour

See Also

SlabContour Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabContour Members

[image]

Structural Analysis and Code Checking API Reference Guide
SlabContour Members
SlabContour Class Constructors Methods Properties See Also Send Feedback

The SlabContour type exposes the following members.

Constructors

 | Name | Description
Public method | SlabContour(SlabInfo) | Construct object as SlabElementType.Contour type.
Public method | SlabContour(SlabInfo, SlabContourType) | Construct object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdge | Returns edge of specific coordinates.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from SlabBaseObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsContourInside(List<(Of <<'(XYZ>)>>)) | Checks if contour is inside current one.
Public method | IsContourInside(SlabContour) | Checks if contour is inside current one.
Public method | IsCrossingLine | Checks if line is crossing current contour.
Public method | IsPointInside | Checks if point is inside contour.
Public method | IsPointOnEdge | Checks if point is on edge.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element. (Inherited from SlabBaseObject.)
Public property | ContextId | Revit Id of element. (Inherited from SlabBaseObject.)
Public property | ContourType | Type of slab contour.
Public property | Edges | List of edges.
Public property | ElementType | Type of element. (Inherited from SlabBaseObject.)
Public property | IsClockWise | Check if contour is clockwise.
Public property | IsClosed | Checks if contour is closed
Public property | Nodes | List of nodes.
Public property | ParentSlab | Parent slab. (Inherited from SlabBaseObject.)

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabContour Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SlabContour Constructor
SlabContour Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SlabContour(SlabInfo) | Construct object as SlabElementType.Contour type.
Public method | SlabContour(SlabInfo, SlabContourType) | Construct object.

See Also

SlabContour Class
SlabContour Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabContour Constructor (SlabInfo)

SlabContour Constructor (SlabInfo)
SlabContour Class See Also Send Feedback
Construct object as SlabElementType.Contour type.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabContour(
    SlabInfo slab
)

Parameters

slab
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabInfo

See Also

SlabContour Class
SlabContour Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabContour Constructor (SlabInfo, SlabContourType)

SlabContour Constructor (SlabInfo, SlabContourType)
SlabContour Class See Also Send Feedback
Construct object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabContour(
    SlabInfo slab,
    SlabContourType contourType
)

Parameters

slab
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabInfo
contourType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabContourType

See Also

SlabContour Class
SlabContour Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabContour Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SlabContour Methods
SlabContour Class See Also Send Feedback

The SlabContour type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdge | Returns edge of specific coordinates.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from SlabBaseObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsContourInside(List<(Of <<'(XYZ>)>>)) | Checks if contour is inside current one.
Public method | IsContourInside(SlabContour) | Checks if contour is inside current one.
Public method | IsCrossingLine | Checks if line is crossing current contour.
Public method | IsPointInside | Checks if point is inside contour.
Public method | IsPointOnEdge | Checks if point is on edge.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEdge Method

SlabContour..::..GetEdge Method
SlabContour Class See Also Send Feedback
Returns edge of specific coordinates.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabEdge GetEdge(
    XYZ point1,
    XYZ point2
)

Parameters

point1
Type: XYZ
point2
Type: XYZ

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsContourInside Method

[image]

Structural Analysis and Code Checking API Reference Guide
SlabContour..::..IsContourInside Method
SlabContour Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsContourInside(List<(Of <<'(XYZ>)>>)) | Checks if contour is inside current one.
Public method | IsContourInside(SlabContour) | Checks if contour is inside current one.

See Also

SlabContour Class
SlabContour Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsContourInside Method (List())

SlabContour..::..IsContourInside Method (List<(Of <(<'>)>)>)
SlabContour Class See Also Send Feedback
Checks if contour is inside current one.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsContourInside(
    List<XYZ> pointList
)

Parameters

pointList
Type: System.Collections.Generic..::..List <(Of <(<'XYZ>)>)>

See Also

SlabContour Class
IsContourInside Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsContourInside Method (SlabContour)

SlabContour..::..IsContourInside Method (SlabContour)
SlabContour Class See Also Send Feedback
Checks if contour is inside current one.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsContourInside(
    SlabContour contour
)

Parameters

contour
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabContour

See Also

SlabContour Class
IsContourInside Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsCrossingLine Method

SlabContour..::..IsCrossingLine Method
SlabContour Class See Also Send Feedback
Checks if line is crossing current contour.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsCrossingLine(
    XYZ pt1,
    XYZ pt2
)

Parameters

pt1
Type: XYZ
pt2
Type: XYZ

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsPointInside Method

SlabContour..::..IsPointInside Method
SlabContour Class See Also Send Feedback
Checks if point is inside contour.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsPointInside(
    XYZ pt
)

Parameters

pt
Type: XYZ

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsPointOnEdge Method

SlabContour..::..IsPointOnEdge Method
SlabContour Class See Also Send Feedback
Checks if point is on edge.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsPointOnEdge(
    XYZ pt
)

Parameters

pt
Type: XYZ

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabContour Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SlabContour Properties
SlabContour Class See Also Send Feedback

The SlabContour type exposes the following members.

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element. (Inherited from SlabBaseObject.)
Public property | ContextId | Revit Id of element. (Inherited from SlabBaseObject.)
Public property | ContourType | Type of slab contour.
Public property | Edges | List of edges.
Public property | ElementType | Type of element. (Inherited from SlabBaseObject.)
Public property | IsClockWise | Check if contour is clockwise.
Public property | IsClosed | Checks if contour is closed
Public property | Nodes | List of nodes.
Public property | ParentSlab | Parent slab. (Inherited from SlabBaseObject.)

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ContourType Property

SlabContour..::..ContourType Property
SlabContour Class See Also Send Feedback
Type of slab contour.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabContourType ContourType { get; internal set; }

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Edges Property

SlabContour..::..Edges Property
SlabContour Class See Also Send Feedback
List of edges.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SlabEdge> Edges { get; internal set; }

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsClockWise Property

SlabContour..::..IsClockWise Property
SlabContour Class See Also Send Feedback
Check if contour is clockwise.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsClockWise { get; }

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsClosed Property

SlabContour..::..IsClosed Property
SlabContour Class See Also Send Feedback
Checks if contour is closed

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsClosed { get; internal set; }

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Nodes Property

SlabContour..::..Nodes Property
SlabContour Class See Also Send Feedback
List of nodes.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SlabNode> Nodes { get; internal set; }

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabContourType Enumeration

SlabContourType Enumeration
See Also Send Feedback
Defines type of slab contour.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SlabContourType

Members

Member name | Value | Description
Contour | 0 | Internal arbitrary contour (e.g. area load).
Hole | 1 | Hole.
Main | 2 | Main contour.
Segment | 3 | Internal segment (e.g. beam outline).

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabEdge Class

SlabEdge Class
Members See Also Send Feedback
Represents edge. Edge is a lis of nodes with parent characteristics.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SlabEdge : SlabBaseObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabBaseObject
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabEdge

See Also

SlabEdge Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabEdge Members

[image]

Structural Analysis and Code Checking API Reference Guide
SlabEdge Members
SlabEdge Class Constructors Methods Properties See Also Send Feedback

The SlabEdge type exposes the following members.

Constructors

 | Name | Description
Public method | SlabEdge(SlabContour) | Constructs object.
Public method | SlabEdge(SlabInfo) | Constructs object.
Public method | SlabEdge(SlabContour, List<(Of <<'(SlabNode>)>>)) | Constructs object.
Public method | SlabEdge(SlabContour, SlabNode, SlabNode) | Constructs object.

Methods

 | Name | Description
Public method | ArePointsLikeNodes | Checks if points from the list has the same coordinates as current edge.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCenter | Returns center of edge.
Public method | GetDistanceFromPoint | Returns distance to specific point.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from SlabBaseObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLineCrossingThis | Checks if line is crossing current edge.
Public method | IsPointOnEdge | Checks if specific point is on edge.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element. (Inherited from SlabBaseObject.)
Public property | ContextId | Revit Id of element. (Inherited from SlabBaseObject.)
Public property | ElementType | Type of element. (Inherited from SlabBaseObject.)
Public property | NodeEnd | Gets end node.
Public property | Nodes | Gets nodes.
Public property | NodeStart | Gets start node.
Public property | ParentContour | Gets parent contour.
Public property | ParentSlab | Parent slab. (Inherited from SlabBaseObject.)

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabEdge Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SlabEdge Constructor
SlabEdge Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SlabEdge(SlabContour) | Constructs object.
Public method | SlabEdge(SlabInfo) | Constructs object.
Public method | SlabEdge(SlabContour, List<(Of <<'(SlabNode>)>>)) | Constructs object.
Public method | SlabEdge(SlabContour, SlabNode, SlabNode) | Constructs object.

See Also

SlabEdge Class
SlabEdge Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabEdge Constructor (SlabContour)

SlabEdge Constructor (SlabContour)
SlabEdge Class See Also Send Feedback
Constructs object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabEdge(
    SlabContour parentContour
)

Parameters

parentContour
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabContour

See Also

SlabEdge Class
SlabEdge Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabEdge Constructor (SlabInfo)

SlabEdge Constructor (SlabInfo)
SlabEdge Class See Also Send Feedback
Constructs object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabEdge(
    SlabInfo slab
)

Parameters

slab
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabInfo

See Also

SlabEdge Class
SlabEdge Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabEdge Constructor (SlabContour, List(SlabNode))

SlabEdge Constructor (SlabContour, List<(Of <(<'SlabNode>)>)>)
SlabEdge Class See Also Send Feedback
Constructs object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabEdge(
    SlabContour parentContour,
    List<SlabNode> Nodes
)

Parameters

parentContour
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabContour
Nodes
Type: System.Collections.Generic..::..List <(Of <(<' SlabNode >)>)>

See Also

SlabEdge Class
SlabEdge Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabEdge Constructor (SlabContour, SlabNode, SlabNode)

SlabEdge Constructor (SlabContour, SlabNode, SlabNode)
SlabEdge Class See Also Send Feedback
Constructs object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabEdge(
    SlabContour parentContour,
    SlabNode node1,
    SlabNode node2
)

Parameters

parentContour
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabContour
node1
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabNode
node2
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabNode

See Also

SlabEdge Class
SlabEdge Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabEdge Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SlabEdge Methods
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Methods

 | Name | Description
Public method | ArePointsLikeNodes | Checks if points from the list has the same coordinates as current edge.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCenter | Returns center of edge.
Public method | GetDistanceFromPoint | Returns distance to specific point.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from SlabBaseObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLineCrossingThis | Checks if line is crossing current edge.
Public method | IsPointOnEdge | Checks if specific point is on edge.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ArePointsLikeNodes Method

SlabEdge..::..ArePointsLikeNodes Method
SlabEdge Class See Also Send Feedback
Checks if points from the list has the same coordinates as current edge.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool ArePointsLikeNodes(
    List<XYZ> pointList
)

Parameters

pointList
Type: System.Collections.Generic..::..List <(Of <(<'XYZ>)>)>

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetCenter Method

SlabEdge..::..GetCenter Method
SlabEdge Class See Also Send Feedback
Returns center of edge.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ GetCenter()

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetDistanceFromPoint Method

SlabEdge..::..GetDistanceFromPoint Method
SlabEdge Class See Also Send Feedback
Returns distance to specific point.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetDistanceFromPoint(
    XYZ point
)

Parameters

point
Type: XYZ

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsLineCrossingThis Method

SlabEdge..::..IsLineCrossingThis Method
SlabEdge Class See Also Send Feedback
Checks if line is crossing current edge.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsLineCrossingThis(
    XYZ point1,
    XYZ point2
)

Parameters

point1
Type: XYZ
point2
Type: XYZ

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsPointOnEdge Method

SlabEdge..::..IsPointOnEdge Method
SlabEdge Class See Also Send Feedback
Checks if specific point is on edge.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsPointOnEdge(
    XYZ pt
)

Parameters

pt
Type: XYZ

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabEdge Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SlabEdge Properties
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element. (Inherited from SlabBaseObject.)
Public property | ContextId | Revit Id of element. (Inherited from SlabBaseObject.)
Public property | ElementType | Type of element. (Inherited from SlabBaseObject.)
Public property | NodeEnd | Gets end node.
Public property | Nodes | Gets nodes.
Public property | NodeStart | Gets start node.
Public property | ParentContour | Gets parent contour.
Public property | ParentSlab | Parent slab. (Inherited from SlabBaseObject.)

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


NodeEnd Property

SlabEdge..::..NodeEnd Property
SlabEdge Class See Also Send Feedback
Gets end node.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabNode NodeEnd { get; }

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Nodes Property

SlabEdge..::..Nodes Property
SlabEdge Class See Also Send Feedback
Gets nodes.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SlabNode> Nodes { get; internal set; }

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


NodeStart Property

SlabEdge..::..NodeStart Property
SlabEdge Class See Also Send Feedback
Gets start node.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabNode NodeStart { get; }

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ParentContour Property

SlabEdge..::..ParentContour Property
SlabEdge Class See Also Send Feedback
Gets parent contour.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabContour ParentContour { get; internal set; }

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabGeometryObjectType Enumeration

SlabGeometryObjectType Enumeration
See Also Send Feedback
Defines type of slab geometry object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SlabGeometryObjectType

Members

Member name | Value | Description
Contour | 0 | Arbitrary contour.
Segment | 1 | Segment (e.g. beam (line) or it's outline).
Hole | 2 | Hole.
Node | 3 | Node.
Edge | 4 | Edge.
None | 5 | None.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabInfo Class

SlabInfo Class
Members See Also Send Feedback
Describes geometry of the slab and some connections with other elements. It consists of 3 characteristics elements: - nodes - (SlabNode) - edges - (SlabEdge) - contours - (SlabContour)

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SlabInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabInfo

See Also

SlabInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
SlabInfo Members
SlabInfo Class Constructors Methods Properties See Also Send Feedback

The SlabInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SlabInfo | Creates default instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdge(List<(Of <<'(XYZ>)>>)) | Returns edge of specific cooridinates.
Public method | GetEdge(XYZ, XYZ) | Returns edge of specific coordinates.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMainContour | returns main contour of the slab.
Public method | GetNode | Returns node of specific coordinates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPointInDomain | Checks if point is in domain of slab (it has to be inside main contour and it can't be inside any hole)
Public method | StructuralLayer | Gets the structural layer.
Public method | Thickness | Gets the thickness of slab.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContextId | Revit Id of element.
Public property | Contours | Gets list of SlabContour objects.
Public property | Edges | Gets list of SlabEdge objects.
Public property | FamilyName | Gets family name.
Public property | IsOneWay | One way structural usage flag
Public property | Layers | Gets list of Layer objects (from Top to Bottom).
Public property | LevelName | Gets level name.
Public property | MaximumBoundary | Gets maximum coordinates (upper-right-front corner) of the boundary box.
Public property | MinimumBoundary | Gets minimum coordinates (lower-left-rear corner) of the boundary box.
Public property | Nodes | Gets list of SlabNode objects.
Public property | SpanDirectionAngle | Gets angle of span direction.
Public property | Transform | Gets class allows to transform points from local to global (and vice versa) coordinate system.
Public property | TypeName | Gets name of type.

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabInfo Constructor

SlabInfo Constructor
SlabInfo Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabInfo()

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SlabInfo Methods
SlabInfo Class See Also Send Feedback

The SlabInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdge(List<(Of <<'(XYZ>)>>)) | Returns edge of specific cooridinates.
Public method | GetEdge(XYZ, XYZ) | Returns edge of specific coordinates.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMainContour | returns main contour of the slab.
Public method | GetNode | Returns node of specific coordinates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPointInDomain | Checks if point is in domain of slab (it has to be inside main contour and it can't be inside any hole)
Public method | StructuralLayer | Gets the structural layer.
Public method | Thickness | Gets the thickness of slab.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEdge Method

[image]

Structural Analysis and Code Checking API Reference Guide
SlabInfo..::..GetEdge Method
SlabInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEdge(List<(Of <<'(XYZ>)>>)) | Returns edge of specific cooridinates.
Public method | GetEdge(XYZ, XYZ) | Returns edge of specific coordinates.

See Also

SlabInfo Class
SlabInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEdge Method (List())

SlabInfo..::..GetEdge Method (List<(Of <(<'>)>)>)
SlabInfo Class See Also Send Feedback
Returns edge of specific cooridinates.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabEdge GetEdge(
    List<XYZ> pointList
)

Parameters

pointList
Type: System.Collections.Generic..::..List <(Of <(<'XYZ>)>)>

See Also

SlabInfo Class
GetEdge Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetEdge Method (, )

SlabInfo..::..GetEdge Method (, )
SlabInfo Class See Also Send Feedback
Returns edge of specific coordinates.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabEdge GetEdge(
    XYZ point1,
    XYZ point2
)

Parameters

point1
Type: XYZ
point2
Type: XYZ

See Also

SlabInfo Class
GetEdge Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetMainContour Method

SlabInfo..::..GetMainContour Method
SlabInfo Class See Also Send Feedback
returns main contour of the slab.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabContour GetMainContour()

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetNode Method

SlabInfo..::..GetNode Method
SlabInfo Class See Also Send Feedback
Returns node of specific coordinates.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabNode GetNode(
    XYZ point
)

Parameters

point
Type: XYZ

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsPointInDomain Method

SlabInfo..::..IsPointInDomain Method
SlabInfo Class See Also Send Feedback
Checks if point is in domain of slab (it has to be inside main contour and it can't be inside any hole)

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsPointInDomain(
    XYZ pt
)

Parameters

pt
Type: XYZ

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


StructuralLayer Method

SlabInfo..::..StructuralLayer Method
SlabInfo Class See Also Send Feedback
Gets the structural layer.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Layer StructuralLayer()

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Thickness Method

SlabInfo..::..Thickness Method
SlabInfo Class See Also Send Feedback
Gets the thickness of slab.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Thickness()

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SlabInfo Properties
SlabInfo Class See Also Send Feedback

The SlabInfo type exposes the following members.

Properties

 | Name | Description
Public property | ContextId | Revit Id of element.
Public property | Contours | Gets list of SlabContour objects.
Public property | Edges | Gets list of SlabEdge objects.
Public property | FamilyName | Gets family name.
Public property | IsOneWay | One way structural usage flag
Public property | Layers | Gets list of Layer objects (from Top to Bottom).
Public property | LevelName | Gets level name.
Public property | MaximumBoundary | Gets maximum coordinates (upper-right-front corner) of the boundary box.
Public property | MinimumBoundary | Gets minimum coordinates (lower-left-rear corner) of the boundary box.
Public property | Nodes | Gets list of SlabNode objects.
Public property | SpanDirectionAngle | Gets angle of span direction.
Public property | Transform | Gets class allows to transform points from local to global (and vice versa) coordinate system.
Public property | TypeName | Gets name of type.

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ContextId Property

SlabInfo..::..ContextId Property
SlabInfo Class See Also Send Feedback
Revit Id of element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int ContextId { get; internal set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Contours Property

SlabInfo..::..Contours Property
SlabInfo Class See Also Send Feedback
Gets list of SlabContour objects.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SlabContour> Contours { get; private set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Edges Property

SlabInfo..::..Edges Property
SlabInfo Class See Also Send Feedback
Gets list of SlabEdge objects.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SlabEdge> Edges { get; private set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


FamilyName Property

SlabInfo..::..FamilyName Property
SlabInfo Class See Also Send Feedback
Gets family name.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string FamilyName { get; internal set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsOneWay Property

SlabInfo..::..IsOneWay Property
SlabInfo Class See Also Send Feedback
One way structural usage flag

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsOneWay { get; internal set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Layers Property

SlabInfo..::..Layers Property
SlabInfo Class See Also Send Feedback
Gets list of Layer objects (from Top to Bottom).

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Layer> Layers { get; internal set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


LevelName Property

SlabInfo..::..LevelName Property
SlabInfo Class See Also Send Feedback
Gets level name.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string LevelName { get; internal set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MaximumBoundary Property

SlabInfo..::..MaximumBoundary Property
SlabInfo Class See Also Send Feedback
Gets maximum coordinates (upper-right-front corner) of the boundary box.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ MaximumBoundary { get; internal set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


MinimumBoundary Property

SlabInfo..::..MinimumBoundary Property
SlabInfo Class See Also Send Feedback
Gets minimum coordinates (lower-left-rear corner) of the boundary box.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ MinimumBoundary { get; internal set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Nodes Property

SlabInfo..::..Nodes Property
SlabInfo Class See Also Send Feedback
Gets list of SlabNode objects.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SlabNode> Nodes { get; private set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SpanDirectionAngle Property

SlabInfo..::..SpanDirectionAngle Property
SlabInfo Class See Also Send Feedback
Gets angle of span direction.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double SpanDirectionAngle { get; internal set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Transform Property

SlabInfo..::..Transform Property
SlabInfo Class See Also Send Feedback
Gets class allows to transform points from local to global (and vice versa) coordinate system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CoordinateSystem Transform { get; internal set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


TypeName Property

SlabInfo..::..TypeName Property
SlabInfo Class See Also Send Feedback
Gets name of type.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string TypeName { get; internal set; }

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabNode Class

SlabNode Class
Members See Also Send Feedback
Represents node. Node is a point with parent characteristics.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SlabNode : SlabBaseObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabBaseObject
Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabNode

See Also

SlabNode Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabNode Members

[image]

Structural Analysis and Code Checking API Reference Guide
SlabNode Members
SlabNode Class Constructors Methods Properties See Also Send Feedback

The SlabNode type exposes the following members.

Constructors

 | Name | Description
Public method | SlabNode(SlabInfo) | Creates instance.
Public method | SlabNode(SlabInfo, XYZ) | Creates instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from SlabBaseObject.)
Public method | GetGlobalCoordinates | Returns cooridinates in global coordinates system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPointNode | Compares current node with specific point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element. (Inherited from SlabBaseObject.)
Public property | ContextId | Revit Id of element. (Inherited from SlabBaseObject.)
Public property | Coordinates | Gets local coordinates.
Public property | ElementType | Type of element. (Inherited from SlabBaseObject.)
Public property | ParentContours | Gets parent contours.
Public property | ParentEdges | Gets parent edges.
Public property | ParentSlab | Parent slab. (Inherited from SlabBaseObject.)

See Also

SlabNode Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabNode Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SlabNode Constructor
SlabNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SlabNode(SlabInfo) | Creates instance.
Public method | SlabNode(SlabInfo, XYZ) | Creates instance.

See Also

SlabNode Class
SlabNode Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabNode Constructor (SlabInfo)

SlabNode Constructor (SlabInfo)
SlabNode Class See Also Send Feedback
Creates instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabNode(
    SlabInfo slab
)

Parameters

slab
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabInfo

See Also

SlabNode Class
SlabNode Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabNode Constructor (SlabInfo, )

SlabNode Constructor (SlabInfo, )
SlabNode Class See Also Send Feedback
Creates instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SlabNode(
    SlabInfo slab,
    XYZ point
)

Parameters

slab
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..SlabInfo
point
Type: XYZ

See Also

SlabNode Class
SlabNode Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabNode Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SlabNode Methods
SlabNode Class See Also Send Feedback

The SlabNode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from SlabBaseObject.)
Public method | GetGlobalCoordinates | Returns cooridinates in global coordinates system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPointNode | Compares current node with specific point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabNode Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


GetGlobalCoordinates Method

SlabNode..::..GetGlobalCoordinates Method
SlabNode Class See Also Send Feedback
Returns cooridinates in global coordinates system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ GetGlobalCoordinates()

See Also

SlabNode Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


IsPointNode Method

SlabNode..::..IsPointNode Method
SlabNode Class See Also Send Feedback
Compares current node with specific point.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsPointNode(
    XYZ point
)

Parameters

point
Type: XYZ

See Also

SlabNode Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


SlabNode Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SlabNode Properties
SlabNode Class See Also Send Feedback

The SlabNode type exposes the following members.

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element. (Inherited from SlabBaseObject.)
Public property | ContextId | Revit Id of element. (Inherited from SlabBaseObject.)
Public property | Coordinates | Gets local coordinates.
Public property | ElementType | Type of element. (Inherited from SlabBaseObject.)
Public property | ParentContours | Gets parent contours.
Public property | ParentEdges | Gets parent edges.
Public property | ParentSlab | Parent slab. (Inherited from SlabBaseObject.)

See Also

SlabNode Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Coordinates Property

SlabNode..::..Coordinates Property
SlabNode Class See Also Send Feedback
Gets local coordinates.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ Coordinates { get; internal set; }

See Also

SlabNode Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ParentContours Property

SlabNode..::..ParentContours Property
SlabNode Class See Also Send Feedback
Gets parent contours.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SlabContour> ParentContours { get; internal set; }

See Also

SlabNode Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ParentEdges Property

SlabNode..::..ParentEdges Property
SlabNode Class See Also Send Feedback
Gets parent edges.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<SlabEdge> ParentEdges { get; internal set; }

See Also

SlabNode Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


TSectionNearestObjectType Enumeration

TSectionNearestObjectType Enumeration
See Also Send Feedback
Type of nearest characteristic object in the cross-section perpendicular to beam's longitudinal axis.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum TSectionNearestObjectType

Members

Member name | Value | Description
FreeEdgeOfSlab | 0 | Free edge of slab.
Beam | 1 | Neighboring beam.
UpperColumn | 2 | Upper column.
CrossingColumn | 3 | Crossing column.
LowerColumn | 4 | Lower column.
Hole | 5 | Hole.
UpperWall | 6 | Upper wall.
Wall | 7 | Crossing wall.
LowerWall | 8 | Lowwr wall.
Unknown | 9 | Unknown.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace


WallInfo Class

WallInfo Class
Members See Also Send Feedback
Describes some geometry features of the Wall.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class WallInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering..::..WallInfo

See Also

WallInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


WallInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
WallInfo Members
WallInfo Class Constructors Methods Properties See Also Send Feedback

The WallInfo type exposes the following members.

Constructors

 | Name | Description
Public method | WallInfo | Creates default instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StructuralLayer | Gets the structural layer.
Public method | Thickness | Gets the thickness of wall.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContextId | Revit Id of element.
Public property | Contour | Gets the shape representing the contour of the wall.
Public property | FamilyName | Gets family name.
Public property | Layers | Gets list of Layer objects ().
Public property | Openings | Gets the list of shapes that representing the openings.
Public property | Transform | Gets class allows to transform points from local to global (and vice versa) coordinate system.
Public property | TypeName | Gets name of type.

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


WallInfo Constructor

WallInfo Constructor
WallInfo Class See Also Send Feedback
Creates default instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public WallInfo()

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


WallInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
WallInfo Methods
WallInfo Class See Also Send Feedback

The WallInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StructuralLayer | Gets the structural layer.
Public method | Thickness | Gets the thickness of wall.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


StructuralLayer Method

WallInfo..::..StructuralLayer Method
WallInfo Class See Also Send Feedback
Gets the structural layer.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Layer StructuralLayer()

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Thickness Method

WallInfo..::..Thickness Method
WallInfo Class See Also Send Feedback
Gets the thickness of wall.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Thickness()

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


WallInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
WallInfo Properties
WallInfo Class See Also Send Feedback

The WallInfo type exposes the following members.

Properties

 | Name | Description
Public property | ContextId | Revit Id of element.
Public property | Contour | Gets the shape representing the contour of the wall.
Public property | FamilyName | Gets family name.
Public property | Layers | Gets list of Layer objects ().
Public property | Openings | Gets the list of shapes that representing the openings.
Public property | Transform | Gets class allows to transform points from local to global (and vice versa) coordinate system.
Public property | TypeName | Gets name of type.

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


ContextId Property

WallInfo..::..ContextId Property
WallInfo Class See Also Send Feedback
Revit Id of element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int ContextId { get; internal set; }

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Contour Property

WallInfo..::..Contour Property
WallInfo Class See Also Send Feedback
Gets the shape representing the contour of the wall.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Shape Contour { get; internal set; }

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


FamilyName Property

WallInfo..::..FamilyName Property
WallInfo Class See Also Send Feedback
Gets family name.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string FamilyName { get; internal set; }

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Layers Property

WallInfo..::..Layers Property
WallInfo Class See Also Send Feedback
Gets list of Layer objects ().

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Layer> Layers { get; internal set; }

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Openings Property

WallInfo..::..Openings Property
WallInfo Class See Also Send Feedback
Gets the list of shapes that representing the openings.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Shape> Openings { get; internal set; }

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Transform Property

WallInfo..::..Transform Property
WallInfo Class See Also Send Feedback
Gets class allows to transform points from local to global (and vice versa) coordinate system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CoordinateSystem Transform { get; internal set; }

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


TypeName Property

WallInfo..::..TypeName Property
WallInfo Class See Also Send Feedback
Gets name of type.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string TypeName { get; internal set; }

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace


Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace

Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace
Send Feedback

Classes

 | Class | Description
Public class | RebarUtility | Helper class dedicated to rebars


RebarUtility Class

RebarUtility Class
Members See Also Send Feedback
Helper class dedicated to rebars

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class RebarUtility

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete..::..RebarUtility

See Also

RebarUtility Members
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


RebarUtility Members

[image]

Structural Analysis and Code Checking API Reference Guide
RebarUtility Members
RebarUtility Class Constructors Methods See Also Send Feedback

The RebarUtility type exposes the following members.

Constructors

 | Name | Description
Public method | RebarUtility | Initializes a new instance of the RebarUtility class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetListMaterialOfRebars | Return the list of material ElementId assigned to rebar present in a Revit document
 | GetListRebarForMaterial | Return the list of rebar with a specific material assigned
 | GetMaterialStructuralAsset(Material) | Return the StructuralAsset of a specific material
 | GetMaterialStructuralAsset(Document, ElementId) | Return the StructuralAsset of a specific material based on his ElementId
 | GetRebarType | Return the RebarType of a specific rebar based on his ElementId
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsMaterialMetal | Return true if the material Class of the specified material is metal
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


RebarUtility Constructor

RebarUtility Constructor
RebarUtility Class See Also Send Feedback
Initializes a new instance of the RebarUtility class

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public RebarUtility()

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


RebarUtility Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RebarUtility Methods
RebarUtility Class See Also Send Feedback

The RebarUtility type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetListMaterialOfRebars | Return the list of material ElementId assigned to rebar present in a Revit document
 | GetListRebarForMaterial | Return the list of rebar with a specific material assigned
 | GetMaterialStructuralAsset(Material) | Return the StructuralAsset of a specific material
 | GetMaterialStructuralAsset(Document, ElementId) | Return the StructuralAsset of a specific material based on his ElementId
 | GetRebarType | Return the RebarType of a specific rebar based on his ElementId
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsMaterialMetal | Return true if the material Class of the specified material is metal
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


GetListMaterialOfRebars Method

RebarUtility..::..GetListMaterialOfRebars Method
RebarUtility Class See Also Send Feedback
Return the list of material ElementId assigned to rebar present in a Revit document

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<ElementId> GetListMaterialOfRebars(
    Document document
)

Parameters

document
Type: Document
Revit document

Return Value

List of material ElementIds

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


GetListRebarForMaterial Method

RebarUtility..::..GetListRebarForMaterial Method
RebarUtility Class See Also Send Feedback
Return the list of rebar with a specific material assigned

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<ElementId> GetListRebarForMaterial(
    Document document,
    ElementId materialId
)

Parameters

document
Type: Document
Revit document
materialId
Type: ElementId
Material ElementId

Return Value

List of rebar ElementIds

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


GetMaterialStructuralAsset Method

[image]

Structural Analysis and Code Checking API Reference Guide
RebarUtility..::..GetMaterialStructuralAsset Method
RebarUtility Class See Also Send Feedback

Overload List

Name | Description
GetMaterialStructuralAsset(Material) | Return the StructuralAsset of a specific material
GetMaterialStructuralAsset(Document, ElementId) | Return the StructuralAsset of a specific material based on his ElementId

See Also

RebarUtility Class
RebarUtility Members
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


GetMaterialStructuralAsset Method ()

RebarUtility..::..GetMaterialStructuralAsset Method ()
RebarUtility Class See Also Send Feedback
Return the StructuralAsset of a specific material

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static StructuralAsset GetMaterialStructuralAsset(
    Material material
)

Parameters

material
Type: Material
Revit Material

Return Value

The StructuralAsset of the material

See Also

RebarUtility Class
GetMaterialStructuralAsset Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


GetMaterialStructuralAsset Method (, )

RebarUtility..::..GetMaterialStructuralAsset Method (, )
RebarUtility Class See Also Send Feedback
Return the StructuralAsset of a specific material based on his ElementId

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static StructuralAsset GetMaterialStructuralAsset(
    Document document,
    ElementId materialId
)

Parameters

document
Type: Document
Revit document
materialId
Type: ElementId
Material ElementId

Return Value

The StructuralAsset of the material

See Also

RebarUtility Class
GetMaterialStructuralAsset Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


GetRebarType Method

RebarUtility..::..GetRebarType Method
RebarUtility Class See Also Send Feedback
Return the RebarType of a specific rebar based on his ElementId

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static RebarBarType GetRebarType(
    Document document,
    ElementId rebarId
)

Parameters

document
Type: Document
Revit document
rebarId
Type: ElementId
Rebar ElementId

Return Value

The RebarType of the rebar

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


IsMaterialMetal Method

RebarUtility..::..IsMaterialMetal Method
RebarUtility Class See Also Send Feedback
Return true if the material Class of the specified material is metal

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool IsMaterialMetal(
    Document document,
    ElementId materialId
)

Parameters

document
Type: Document
Revit document
materialId
Type: ElementId
Material ElementId

Return Value

if the MaterialClass=="Metal"

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace


Autodesk.Revit.DB.CodeChecking.Engineering.Concrete.ConcreteTypes Namespace

Autodesk.Revit.DB.CodeChecking.Engineering.Concrete.ConcreteTypes Namespace
Send Feedback

Enumerations

 | Enumeration | Description
Public enumeration | SteelSurface | Type of the surface for reinforcement steel bar.
Public enumeration | SteelType | Type of the reinforcement steel rebar.


SteelSurface Enumeration

SteelSurface Enumeration
See Also Send Feedback
Type of the surface for reinforcement steel bar.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete.ConcreteTypes
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SteelSurface

Members

Member name | Value | Description
Unknown | 0 | Unknown.
Deformed | 1 | Deformed.
Plain | 2 | Plain.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering.Concrete.ConcreteTypes Namespace


SteelType Enumeration

SteelType Enumeration
See Also Send Feedback
Type of the reinforcement steel rebar.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete.ConcreteTypes
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SteelType

Members

Member name | Value | Description
Unknown | 0 | Unknown.
Main | 1 | Main.
Trans | 2 | Transverse.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering.Concrete.ConcreteTypes Namespace


Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace

Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace
Send Feedback

Classes

 | Class | Description
Public class | ElementAnalyser | Analyser of Revit element.
Public class | ForceResultsCache | Represents a collection of internal forces for a given group of elements and loads
Public class | ForceResultsUtils | Utility class for basic operations related to results in ResultBuilder
Public class | ForceResultsWriter | Class used for saving results in Revit

Enumerations

 | Enumeration | Description
Public enumeration | ForceResultsCache..::..ElementResultsStatus |


ElementAnalyser Class

ElementAnalyser Class
Members See Also Send Feedback
Analyser of Revit element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementAnalyser

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering.Tools..::..ElementAnalyser

See Also

ElementAnalyser Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ElementAnalyser Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementAnalyser Members
ElementAnalyser Class Constructors Methods Properties See Also Send Feedback

The ElementAnalyser type exposes the following members.

Constructors

 | Name | Description
Public method | ElementAnalyser()()()() | Initializes a new instance of ElementAnalyser class. Internal Revit units are using.
Public method | ElementAnalyser(DisplayUnit) | Initializes a new instance of ElementAnalyser class with proper unit system.

Methods

 | Name | Description
Public method | Analyse | Performs analysis of Revit element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TSectionAnalysis | Turn on/off t-section analysis (if element is a beam).
Public property | UseAnalyticalModelForSlabs | Turn on/off using analitical model for slabs.

See Also

ElementAnalyser Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ElementAnalyser Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ElementAnalyser Constructor
ElementAnalyser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementAnalyser()()()() | Initializes a new instance of ElementAnalyser class. Internal Revit units are using.
Public method | ElementAnalyser(DisplayUnit) | Initializes a new instance of ElementAnalyser class with proper unit system.

See Also

ElementAnalyser Class
ElementAnalyser Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ElementAnalyser Constructor

ElementAnalyser Constructor
ElementAnalyser Class See Also Send Feedback
Initializes a new instance of ElementAnalyser class. Internal Revit units are using.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementAnalyser()

See Also

ElementAnalyser Class
ElementAnalyser Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ElementAnalyser Constructor ()

ElementAnalyser Constructor ()
ElementAnalyser Class See Also Send Feedback
Initializes a new instance of ElementAnalyser class with proper unit system.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementAnalyser(
    DisplayUnit unitSystem
)

Parameters

unitSystem
Type: DisplayUnit

See Also

ElementAnalyser Class
ElementAnalyser Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ElementAnalyser Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ElementAnalyser Methods
ElementAnalyser Class See Also Send Feedback

The ElementAnalyser type exposes the following members.

Methods

 | Name | Description
Public method | Analyse | Performs analysis of Revit element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementAnalyser Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


Analyse Method

ElementAnalyser..::..Analyse Method
ElementAnalyser Class See Also Send Feedback
Performs analysis of Revit element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementInfo Analyse(
    Element revitElement
)

Parameters

revitElement
Type: Element

Return Value

ElementInfo if success or null if failure

See Also

ElementAnalyser Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ElementAnalyser Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ElementAnalyser Properties
ElementAnalyser Class See Also Send Feedback

The ElementAnalyser type exposes the following members.

Properties

 | Name | Description
Public property | TSectionAnalysis | Turn on/off t-section analysis (if element is a beam).
Public property | UseAnalyticalModelForSlabs | Turn on/off using analitical model for slabs.

See Also

ElementAnalyser Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


TSectionAnalysis Property

ElementAnalyser..::..TSectionAnalysis Property
ElementAnalyser Class See Also Send Feedback
Turn on/off t-section analysis (if element is a beam).

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool TSectionAnalysis { get; set; }

See Also

ElementAnalyser Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


UseAnalyticalModelForSlabs Property

ElementAnalyser..::..UseAnalyticalModelForSlabs Property
ElementAnalyser Class See Also Send Feedback
Turn on/off using analitical model for slabs.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool UseAnalyticalModelForSlabs { get; set; }

See Also

ElementAnalyser Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsCache Class

ForceResultsCache Class
Members See Also Send Feedback
Represents a collection of internal forces for a given group of elements and loads

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ForceResultsCache

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering.Tools..::..ForceResultsCache

See Also

ForceResultsCache Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsCache Members

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsCache Members
ForceResultsCache Class Constructors Methods Properties See Also Send Feedback

The ForceResultsCache type exposes the following members.

Constructors

 | Name | Description
Public method | ForceResultsCache(Document, ICollection<(Of <<'(ForceCalculationDataDescriptor>)>>), ICollection<(Of <<'(ForceResultsPackageDescriptor>)>>), ICollection<(Of <<'(ElementId>)>>), DisplayUnit) | Creates ForceResultsCache
Public method | ForceResultsCache(Document, ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ForceResultsPackageDescriptor>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ForceType>)>>), DisplayUnit) | Creates ForceResultsCache

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationPoints | Gets a list of Calculation points in which internal forces can be read
Public method | GetElementResultsStatus | Gets status of element results
Public method | GetForceForCase(ElementId, ForceLoadCaseDescriptor, IEnumerable<(Of <<'(CalcPoint>)>>), ForceType) | Gets internal forces in specified calculation points in a given element for a specific load and force type
Public method | GetForceForCase(ElementId, ForceResultsPackageDescriptor, ForceLoadCaseDescriptor, IEnumerable<(Of <<'(CalcPoint>)>>), ForceType) | Gets internal forces in specified calculation points in a given element for a specific resPackage, load and force type
Public method | GetForceForPoint(ElementId, IEnumerable<(Of <<'(ForceLoadCaseDescriptor>)>>), CalcPoint, ForceType) | Gets internal forces in a specific calculation point in a given element for specified loads and force type
Public method | GetForceForPoint(ElementId, ForceResultsPackageDescriptor, IEnumerable<(Of <<'(ForceLoadCaseDescriptor>)>>), CalcPoint, ForceType) | Gets internal forces in a specific calculation point in a given element for a specific ResPackage, loads and force type
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadCaseDescriptors()()()() | Method for querrying all available loads and combinations
 | GetLoadCaseDescriptors(Document, IEnumerable<(Of <<'(ElementId>)>>)) | Creates hashset of loadDescriptors
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ResultBuilderAccessTime |
Public property | ResultsPackageDescriptors | Method for querrying all available results packages

See Also

ForceResultsCache Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsCache Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsCache Constructor
ForceResultsCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForceResultsCache(Document, ICollection<(Of <<'(ForceCalculationDataDescriptor>)>>), ICollection<(Of <<'(ForceResultsPackageDescriptor>)>>), ICollection<(Of <<'(ElementId>)>>), DisplayUnit) | Creates ForceResultsCache
Public method | ForceResultsCache(Document, ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ForceResultsPackageDescriptor>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ForceType>)>>), DisplayUnit) | Creates ForceResultsCache

See Also

ForceResultsCache Class
ForceResultsCache Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsCache Constructor (, ICollection(ForceCalculationDataDescriptor), ICollection(ForceResultsPackageDescriptor), ICollection(), )

ForceResultsCache Constructor (, ICollection<(Of <(<'ForceCalculationDataDescriptor>)>)>, ICollection<(Of <(<'ForceResultsPackageDescriptor>)>)>, ICollection<(Of <(<'>)>)>, )
ForceResultsCache Class See Also Send Feedback
Creates ForceResultsCache

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceResultsCache(
    Document document,
    ICollection<ForceCalculationDataDescriptor> elementIDs,
    ICollection<ForceResultsPackageDescriptor> resultPackDescriptors,
    ICollection<ElementId> loads,
    DisplayUnit unitSystem
)

Parameters

document
Type: Document
Revit document
elementIDs
Type: System.Collections.Generic..::..ICollection <(Of <(<' ForceCalculationDataDescriptor >)>)>
Collection of ID's for revit elements for which internal forces will be querried
resultPackDescriptors
Type: System.Collections.Generic..::..ICollection <(Of <(<' ForceResultsPackageDescriptor >)>)>
Collection of descriptors for result packages from which results will be imported. If null , all available packages will be used
loads
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
Collection of loads corresponding to the internal forces
unitSystem
Type: DisplayUnit
Unit system

See Also

ForceResultsCache Class
ForceResultsCache Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsCache Constructor (, ICollection(), ICollection(ForceResultsPackageDescriptor), ICollection(), ICollection(ForceType), )

ForceResultsCache Constructor (, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'ForceResultsPackageDescriptor>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'ForceType>)>)>, )
ForceResultsCache Class See Also Send Feedback
Creates ForceResultsCache

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceResultsCache(
    Document document,
    ICollection<ElementId> elementIDs,
    ICollection<ForceResultsPackageDescriptor> resultPackDescriptors,
    ICollection<ElementId> loads,
    ICollection<ForceType> forceTypes,
    DisplayUnit unitSystem
)

Parameters

document
Type: Document
Revit document
elementIDs
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
Collection of ID's for revit elements for which internal forces will be querried
resultPackDescriptors
Type: System.Collections.Generic..::..ICollection <(Of <(<' ForceResultsPackageDescriptor >)>)>
Collection of descriptors for result packages from which results will be imported. If null , all available packages will be used
loads
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
Collection of loads corresponding to the internal forces
forceTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' ForceType >)>)>
Specifies internal forces in element for which results are to be taken
unitSystem
Type: DisplayUnit
Unit system

See Also

ForceResultsCache Class
ForceResultsCache Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsCache Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsCache Methods
ForceResultsCache Class See Also Send Feedback

The ForceResultsCache type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationPoints | Gets a list of Calculation points in which internal forces can be read
Public method | GetElementResultsStatus | Gets status of element results
Public method | GetForceForCase(ElementId, ForceLoadCaseDescriptor, IEnumerable<(Of <<'(CalcPoint>)>>), ForceType) | Gets internal forces in specified calculation points in a given element for a specific load and force type
Public method | GetForceForCase(ElementId, ForceResultsPackageDescriptor, ForceLoadCaseDescriptor, IEnumerable<(Of <<'(CalcPoint>)>>), ForceType) | Gets internal forces in specified calculation points in a given element for a specific resPackage, load and force type
Public method | GetForceForPoint(ElementId, IEnumerable<(Of <<'(ForceLoadCaseDescriptor>)>>), CalcPoint, ForceType) | Gets internal forces in a specific calculation point in a given element for specified loads and force type
Public method | GetForceForPoint(ElementId, ForceResultsPackageDescriptor, IEnumerable<(Of <<'(ForceLoadCaseDescriptor>)>>), CalcPoint, ForceType) | Gets internal forces in a specific calculation point in a given element for a specific ResPackage, loads and force type
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadCaseDescriptors()()()() | Method for querrying all available loads and combinations
 | GetLoadCaseDescriptors(Document, IEnumerable<(Of <<'(ElementId>)>>)) | Creates hashset of loadDescriptors
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ForceResultsCache Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetCalculationPoints Method

ForceResultsCache..::..GetCalculationPoints Method
ForceResultsCache Class See Also Send Feedback
Gets a list of Calculation points in which internal forces can be read

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<CalcPoint> GetCalculationPoints(
    ElementId elementId
)

Parameters

elementId
Type: ElementId
Id of Revit element

Return Value

List of CalcPoint objects for the element

See Also

ForceResultsCache Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetElementResultsStatus Method

ForceResultsCache..::..GetElementResultsStatus Method
ForceResultsCache Class See Also Send Feedback
Gets status of element results

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceResultsCache..::..ElementResultsStatus GetElementResultsStatus(
    ElementId elementId
)

Parameters

elementId
Type: ElementId
Element id

Return Value

ElementResultsStatus object

See Also

ForceResultsCache Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetForceForCase Method

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsCache..::..GetForceForCase Method
ForceResultsCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetForceForCase(ElementId, ForceLoadCaseDescriptor, IEnumerable<(Of <<'(CalcPoint>)>>), ForceType) | Gets internal forces in specified calculation points in a given element for a specific load and force type
Public method | GetForceForCase(ElementId, ForceResultsPackageDescriptor, ForceLoadCaseDescriptor, IEnumerable<(Of <<'(CalcPoint>)>>), ForceType) | Gets internal forces in specified calculation points in a given element for a specific resPackage, load and force type

See Also

ForceResultsCache Class
ForceResultsCache Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetForceForCase Method (, ForceLoadCaseDescriptor, IEnumerable(CalcPoint), ForceType)

ForceResultsCache..::..GetForceForCase Method (, ForceLoadCaseDescriptor, IEnumerable<(Of <(<'CalcPoint>)>)>, ForceType)
ForceResultsCache Class See Also Send Feedback
Gets internal forces in specified calculation points in a given element for a specific load and force type

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<double> GetForceForCase(
    ElementId elementId,
    ForceLoadCaseDescriptor caseDescriptor,
    IEnumerable<CalcPoint> calculationPoints,
    ForceType forceType
)

Parameters

elementId
Type: ElementId
Revit ElementId
caseDescriptor
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceLoadCaseDescriptor
Load case descriptor
calculationPoints
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' CalcPoint >)>)>
List of calculation points corresponding to the returned force list
forceType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceType
Force type

Return Value

List of forces

See Also

ForceResultsCache Class
GetForceForCase Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetForceForCase Method (, ForceResultsPackageDescriptor, ForceLoadCaseDescriptor, IEnumerable(CalcPoint), ForceType)

ForceResultsCache..::..GetForceForCase Method (, ForceResultsPackageDescriptor, ForceLoadCaseDescriptor, IEnumerable<(Of <(<'CalcPoint>)>)>, ForceType)
ForceResultsCache Class See Also Send Feedback
Gets internal forces in specified calculation points in a given element for a specific resPackage, load and force type

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<double> GetForceForCase(
    ElementId elementId,
    ForceResultsPackageDescriptor resultPackageDescriptor,
    ForceLoadCaseDescriptor caseDescriptor,
    IEnumerable<CalcPoint> calculationPoints,
    ForceType forceType
)

Parameters

elementId
Type: ElementId
Revit ElementId
resultPackageDescriptor
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceResultsPackageDescriptor
Result package descriptor
caseDescriptor
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceLoadCaseDescriptor
Load case descriptor
calculationPoints
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' CalcPoint >)>)>
List of calculation points corresponding to the returned force list
forceType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceType
Force type

Return Value

List of forces

See Also

ForceResultsCache Class
GetForceForCase Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetForceForPoint Method

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsCache..::..GetForceForPoint Method
ForceResultsCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetForceForPoint(ElementId, IEnumerable<(Of <<'(ForceLoadCaseDescriptor>)>>), CalcPoint, ForceType) | Gets internal forces in a specific calculation point in a given element for specified loads and force type
Public method | GetForceForPoint(ElementId, ForceResultsPackageDescriptor, IEnumerable<(Of <<'(ForceLoadCaseDescriptor>)>>), CalcPoint, ForceType) | Gets internal forces in a specific calculation point in a given element for a specific ResPackage, loads and force type

See Also

ForceResultsCache Class
ForceResultsCache Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetForceForPoint Method (, IEnumerable(ForceLoadCaseDescriptor), CalcPoint, ForceType)

ForceResultsCache..::..GetForceForPoint Method (, IEnumerable<(Of <(<'ForceLoadCaseDescriptor>)>)>, CalcPoint, ForceType)
ForceResultsCache Class See Also Send Feedback
Gets internal forces in a specific calculation point in a given element for specified loads and force type

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<double> GetForceForPoint(
    ElementId elementId,
    IEnumerable<ForceLoadCaseDescriptor> loadCaseDescriptors,
    CalcPoint calculationPoints,
    ForceType forceType
)

Parameters

elementId
Type: ElementId
Revit ElementId
loadCaseDescriptors
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ForceLoadCaseDescriptor >)>)>
Load case descriptors
calculationPoints
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..CalcPoint
Calculation point
forceType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceType
Force type

Return Value

List of doubles representing forces of forceType for the element of ElementId

See Also

ForceResultsCache Class
GetForceForPoint Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetForceForPoint Method (, ForceResultsPackageDescriptor, IEnumerable(ForceLoadCaseDescriptor), CalcPoint, ForceType)

ForceResultsCache..::..GetForceForPoint Method (, ForceResultsPackageDescriptor, IEnumerable<(Of <(<'ForceLoadCaseDescriptor>)>)>, CalcPoint, ForceType)
ForceResultsCache Class See Also Send Feedback
Gets internal forces in a specific calculation point in a given element for a specific ResPackage, loads and force type

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<double> GetForceForPoint(
    ElementId elementId,
    ForceResultsPackageDescriptor packageDescriptor,
    IEnumerable<ForceLoadCaseDescriptor> loads,
    CalcPoint calculationPoint,
    ForceType forceType
)

Parameters

elementId
Type: ElementId
Revit ElementId
packageDescriptor
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceResultsPackageDescriptor
Result pack descriptor
loads
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ForceLoadCaseDescriptor >)>)>
Load case descriptors
calculationPoint
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..CalcPoint
Calculation point
forceType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceType
Force type

Return Value

List of doubles representing forces of forceType for the element of ElementId

See Also

ForceResultsCache Class
GetForceForPoint Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetLoadCaseDescriptors Method

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsCache..::..GetLoadCaseDescriptors Method
ForceResultsCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLoadCaseDescriptors()()()() | Method for querrying all available loads and combinations
 | GetLoadCaseDescriptors(Document, IEnumerable<(Of <<'(ElementId>)>>)) | Creates hashset of loadDescriptors

See Also

ForceResultsCache Class
ForceResultsCache Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetLoadCaseDescriptors Method

ForceResultsCache..::..GetLoadCaseDescriptors Method
ForceResultsCache Class See Also Send Feedback
Method for querrying all available loads and combinations

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ForceLoadCaseDescriptor> GetLoadCaseDescriptors()

Return Value

List of ForceLoadCaseDescriptor objects

See Also

ForceResultsCache Class
GetLoadCaseDescriptors Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetLoadCaseDescriptors Method (, IEnumerable())

ForceResultsCache..::..GetLoadCaseDescriptors Method (, IEnumerable<(Of <(<'>)>)>)
ForceResultsCache Class See Also Send Feedback
Creates hashset of loadDescriptors

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static HashSet<ForceLoadCaseDescriptor> GetLoadCaseDescriptors(
    Document document,
    IEnumerable<ElementId> loads
)

Parameters

document
Type: Document
Revit document
loads
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'ElementId>)>)>
Collection of revit load ElementId's

Return Value

hashset of loadDescriptors

See Also

ForceResultsCache Class
GetLoadCaseDescriptors Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsCache Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsCache Properties
ForceResultsCache Class See Also Send Feedback

The ForceResultsCache type exposes the following members.

Properties

 | Name | Description
Public property | ResultBuilderAccessTime |
Public property | ResultsPackageDescriptors | Method for querrying all available results packages

See Also

ForceResultsCache Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ResultBuilderAccessTime Property

ForceResultsCache..::..ResultBuilderAccessTime Property
ForceResultsCache Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public long ResultBuilderAccessTime { get; set; }

See Also

ForceResultsCache Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ResultsPackageDescriptors Property

ForceResultsCache..::..ResultsPackageDescriptors Property
ForceResultsCache Class See Also Send Feedback
Method for querrying all available results packages

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ForceResultsPackageDescriptor> ResultsPackageDescriptors { get; }

Return Value

List of ForceResultsPackageDescriptor objects

See Also

ForceResultsCache Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsCache.ElementResultsStatus Enumeration

ForceResultsCache..::..ElementResultsStatus Enumeration
ForceResultsCache Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ElementResultsStatus

Members

Member name | Value | Description
NoResults | 0 |
ResultsNotComplete | 1 |
ResultsOK | 2 |
Unknown | 3 |

See Also

Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsUtils Class

ForceResultsUtils Class
Members See Also Send Feedback
Utility class for basic operations related to results in ResultBuilder

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static class ForceResultsUtils

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering.Tools..::..ForceResultsUtils

See Also

ForceResultsUtils Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsUtils Members

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsUtils Members
ForceResultsUtils Class Methods See Also Send Feedback

The ForceResultsUtils type exposes the following members.

Methods

Name | Description
GetExtremumValueCoordinates | Gets coordinates of extreme value for given results
GetForceType | Converts ResultBuilter LinearResultType into ForceType
GetLinearResultType(ForceType) | Converts ForceType into ResultBuilder LinearResultType
GetLinearResultType(ResultType) | Converts ResultType into ResultBuilder LinearResultType
GetRBElementId | Converts ElementId to RB format ElementId
GetSurfaceResultType(ForceType) | Converts ForceType into ResultBuilder SurfaceResultType
GetSurfaceResultType(ResultType) | Converts ResultType into ResultBuilder SurfaceResultType

See Also

ForceResultsUtils Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsUtils Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsUtils Methods
ForceResultsUtils Class See Also Send Feedback

The ForceResultsUtils type exposes the following members.

Methods

Name | Description
GetExtremumValueCoordinates | Gets coordinates of extreme value for given results
GetForceType | Converts ResultBuilter LinearResultType into ForceType
GetLinearResultType(ForceType) | Converts ForceType into ResultBuilder LinearResultType
GetLinearResultType(ResultType) | Converts ResultType into ResultBuilder LinearResultType
GetRBElementId | Converts ElementId to RB format ElementId
GetSurfaceResultType(ForceType) | Converts ForceType into ResultBuilder SurfaceResultType
GetSurfaceResultType(ResultType) | Converts ResultType into ResultBuilder SurfaceResultType

See Also

ForceResultsUtils Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetExtremumValueCoordinates Method

ForceResultsUtils..::..GetExtremumValueCoordinates Method
ForceResultsUtils Class See Also Send Feedback
Gets coordinates of extreme value for given results

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<Tuple<int, int, ForceType, double>> GetExtremumValueCoordinates(
    Document document,
    ICollection<ElementId> combinations,
    ICollection<ForceType> forceTypes,
    ICollection<ElementId> elementIds
)

Parameters

document
Type: Document
Revit document
combinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
List of loads and combinations for which extremes will be selected
forceTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' ForceType >)>)>
List or resultTypes for which extremes will be searched
elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
Revit ElementID

Return Value

Collection of list elements where each element contains elementId, loadId, ForceType, and coordinate associated with extreme value

See Also

ForceResultsUtils Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetForceType Method

ForceResultsUtils..::..GetForceType Method
ForceResultsUtils Class See Also Send Feedback
Converts ResultBuilter LinearResultType into ForceType

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ForceType GetForceType(
    this LinearResultType resultType
)

Parameters

resultType
Type: Autodesk.Revit.DB.ResultsBuilder..::..LinearResultType
Revit LinearResultType object

Return Value

ForceType object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type LinearResultType. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

ForceResultsUtils Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetLinearResultType Method

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsUtils..::..GetLinearResultType Method
ForceResultsUtils Class See Also Send Feedback

Overload List

Name | Description
GetLinearResultType(ForceType) | Converts ForceType into ResultBuilder LinearResultType
GetLinearResultType(ResultType) | Converts ResultType into ResultBuilder LinearResultType

See Also

ForceResultsUtils Class
ForceResultsUtils Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetLinearResultType Method (ForceType)

ForceResultsUtils..::..GetLinearResultType Method (ForceType)
ForceResultsUtils Class See Also Send Feedback
Converts ForceType into ResultBuilder LinearResultType

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static LinearResultType GetLinearResultType(
    this ForceType forceType
)

Parameters

forceType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceType
ForceType object

Return Value

Revit LinearResultType object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ForceType. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

ForceResultsUtils Class
GetLinearResultType Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetLinearResultType Method (ResultType)

ForceResultsUtils..::..GetLinearResultType Method (ResultType)
ForceResultsUtils Class See Also Send Feedback
Converts ResultType into ResultBuilder LinearResultType

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static LinearResultType GetLinearResultType(
    this ResultType resultType
)

Parameters

resultType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ResultType
ResultType object

Return Value

LinearResultType object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ResultType. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

ForceResultsUtils Class
GetLinearResultType Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetRBElementId Method

ForceResultsUtils..::..GetRBElementId Method
ForceResultsUtils Class See Also Send Feedback
Converts ElementId to RB format ElementId

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ElementId GetRBElementId(
    this ElementId externalElementId,
    Document doc
)

Parameters

externalElementId
Type: ElementId
ElementId to be converted
doc
Type: Document
Revit document

Return Value

RB format ElementId

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ElementId. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

ForceResultsUtils Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetSurfaceResultType Method

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsUtils..::..GetSurfaceResultType Method
ForceResultsUtils Class See Also Send Feedback

Overload List

Name | Description
GetSurfaceResultType(ForceType) | Converts ForceType into ResultBuilder SurfaceResultType
GetSurfaceResultType(ResultType) | Converts ResultType into ResultBuilder SurfaceResultType

See Also

ForceResultsUtils Class
ForceResultsUtils Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetSurfaceResultType Method (ForceType)

ForceResultsUtils..::..GetSurfaceResultType Method (ForceType)
ForceResultsUtils Class See Also Send Feedback
Converts ForceType into ResultBuilder SurfaceResultType

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static SurfaceResultType GetSurfaceResultType(
    this ForceType forceType
)

Parameters

forceType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceType
ForceType object

Return Value

Revit SurfaceResultType object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ForceType. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

ForceResultsUtils Class
GetSurfaceResultType Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


GetSurfaceResultType Method (ResultType)

ForceResultsUtils..::..GetSurfaceResultType Method (ResultType)
ForceResultsUtils Class See Also Send Feedback
Converts ResultType into ResultBuilder SurfaceResultType

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static SurfaceResultType GetSurfaceResultType(
    this ResultType resultType
)

Parameters

resultType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ResultType
ResultType object

Return Value

SurfaceResultType object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ResultType. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

ForceResultsUtils Class
GetSurfaceResultType Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsWriter Class

ForceResultsWriter Class
Members See Also Send Feedback
Class used for saving results in Revit

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ForceResultsWriter

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering.Tools..::..ForceResultsWriter

See Also

ForceResultsWriter Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsWriter Members

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsWriter Members
ForceResultsWriter Class Constructors Methods See Also Send Feedback

The ForceResultsWriter type exposes the following members.

Constructors

 | Name | Description
Public method | ForceResultsWriter | Creates default ForceResultsWriter

Methods

 | Name | Description
Public method | AddResultsForElement | Adds results for a given element
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetMeasurementForElement | Sets calculation points coordinates for a given element
Public method | StoreResultsInResultsBuilder | Copies results to Revit
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ForceResultsWriter Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsWriter Constructor

ForceResultsWriter Constructor
ForceResultsWriter Class See Also Send Feedback
Creates default ForceResultsWriter

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceResultsWriter(
    Document document,
    ResultsPackageBuilder resultsBuilder,
    UnitsSystem unitSystem
)

Parameters

document
Type: Document
Revit document
resultsBuilder
Type: Autodesk.Revit.DB.ResultsBuilder.Storage..::..ResultsPackageBuilder
ResultsBuilder object where results will be stored
unitSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem
Unit system for stored results

See Also

ForceResultsWriter Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


ForceResultsWriter Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ForceResultsWriter Methods
ForceResultsWriter Class See Also Send Feedback

The ForceResultsWriter type exposes the following members.

Methods

 | Name | Description
Public method | AddResultsForElement | Adds results for a given element
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetMeasurementForElement | Sets calculation points coordinates for a given element
Public method | StoreResultsInResultsBuilder | Copies results to Revit
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ForceResultsWriter Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


AddResultsForElement Method

ForceResultsWriter..::..AddResultsForElement Method
ForceResultsWriter Class See Also Send Feedback
Adds results for a given element

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddResultsForElement(
    ElementId elementId,
    ResultType resultType,
    ICollection<double> resultsValues
)

Parameters

elementId
Type: ElementId
Revit ElementId
resultType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ResultType
Result type
resultsValues
Type: System.Collections.Generic..::..ICollection <(Of <(<' Double >)>)>
Result list

See Also

ForceResultsWriter Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


SetMeasurementForElement Method

ForceResultsWriter..::..SetMeasurementForElement Method
ForceResultsWriter Class See Also Send Feedback
Sets calculation points coordinates for a given element

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetMeasurementForElement(
    ElementId elementId,
    AxisDirection direction,
    IList<double> points
)

Parameters

elementId
Type: ElementId
Revit ElementId
direction
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..AxisDirection
Axis direction(not used for bar elements)
points
Type: System.Collections.Generic..::..IList <(Of <(<' Double >)>)>
Point coordinates list

See Also

ForceResultsWriter Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


StoreResultsInResultsBuilder Method

ForceResultsWriter..::..StoreResultsInResultsBuilder Method
ForceResultsWriter Class See Also Send Feedback
Copies results to Revit

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void StoreResultsInResultsBuilder(
    string resultsName
)

Parameters

resultsName
Type: System..::..String
Name of the analysys under which results are to be stored

See Also

ForceResultsWriter Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace


Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace

Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace
Send Feedback

Classes

 | Class | Description
Public class | LoadCombinationPreview | Represents load combination preview
Public class | LoadCombinationUtils | Helper class for Load Combination framework
Public class | RevitLoadCombination | Wraps Revit Load Combination
Public class | Server<(Of <(<'TData>)>)> | Base class for all load combination servers which are based on reflection scenario. It provides automization for most of functionality required by ILoadCombinationServer.
Public class | Service | Represents main load combination service
Public class | ServiceData | Represents data used for exchanging information between CCService and servers.

Interfaces

 | Interface | Description
Public interface | ILoadCombination | Common interface for load Combination visualization
Public interface | ILoadCombinationServer | The base interface for all Code Checking servers

Enumerations

 | Enumeration | Description
Public enumeration | LoadCombinationState | Load combination state
Public enumeration | LoadCombinationType | Load combination type


ILoadCombination Interface

ILoadCombination Interface
Members See Also Send Feedback
Common interface for load Combination visualization

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ILoadCombination

See Also

ILoadCombination Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ILoadCombination Members

[image]

Structural Analysis and Code Checking API Reference Guide
ILoadCombination Members
ILoadCombination Interface Methods See Also Send Feedback

The ILoadCombination type exposes the following members.

Methods

 | Name | Description
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetUsageName | Gets the name of the usage.

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ILoadCombination Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ILoadCombination Methods
ILoadCombination Interface See Also Send Feedback

The ILoadCombination type exposes the following members.

Methods

 | Name | Description
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetUsageName | Gets the name of the usage.

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetCombinationType Method

ILoadCombination..::..GetCombinationType Method
ILoadCombination Interface See Also Send Feedback
Gets the type of the load combination.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
LoadCombinationType GetCombinationType()

Return Value

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetComponentFactor Method

ILoadCombination..::..GetComponentFactor Method
ILoadCombination Interface See Also Send Feedback
Gets the component factor.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
double GetComponentFactor(
    int i
)

Parameters

i
Type: System..::..Int32
The index.

Return Value

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetComponentName Method

ILoadCombination..::..GetComponentName Method
ILoadCombination Interface See Also Send Feedback
Gets the name of the component.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
string GetComponentName(
    int i
)

Parameters

i
Type: System..::..Int32
The index.

Return Value

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetId Method

ILoadCombination..::..GetId Method
ILoadCombination Interface See Also Send Feedback
Gets the id.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
int GetId()

Return Value

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetName Method

ILoadCombination..::..GetName Method
ILoadCombination Interface See Also Send Feedback
Gets the name.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
string GetName()

Return Value

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetNumberOfComponents Method

ILoadCombination..::..GetNumberOfComponents Method
ILoadCombination Interface See Also Send Feedback
Gets the number of components.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
int GetNumberOfComponents()

Return Value

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetNumberOfUsages Method

ILoadCombination..::..GetNumberOfUsages Method
ILoadCombination Interface See Also Send Feedback
Gets the number of usages.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
int GetNumberOfUsages()

Return Value

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetState Method

ILoadCombination..::..GetState Method
ILoadCombination Interface See Also Send Feedback
Gets the state.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
LoadCombinationState GetState()

Return Value

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetUsageName Method

ILoadCombination..::..GetUsageName Method
ILoadCombination Interface See Also Send Feedback
Gets the name of the usage.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
string GetUsageName(
    int i
)

Parameters

i
Type: System..::..Int32
The i.

Return Value

See Also

ILoadCombination Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ILoadCombinationServer Interface

ILoadCombinationServer Interface
Members See Also Send Feedback
The base interface for all Code Checking servers

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ILoadCombinationServer : IExternalServer

See Also

ILoadCombinationServer Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ILoadCombinationServer Members

[image]

Structural Analysis and Code Checking API Reference Guide
ILoadCombinationServer Members
ILoadCombinationServer Interface Methods See Also Send Feedback

The ILoadCombinationServer type exposes the following members.

Methods

 | Name | Description
Public method | ConvertDataToCurrentVersion | Converts old version of data entity to the newest one.
Public method | Generate | Generates load combinations. Used only if the server doesn't support preview mode.
Public method | GeneratePreview | Generates load combinations preview. Used only if the server supports preview mode.
Public method | GetDataSchema | Gets the data schema.
Public method | GetDefaultData | Gets the default data.
Public method | GetDescription | (Inherited from IExternalServer.)
Public method | GetName | (Inherited from IExternalServer.)
Public method | GetServerId | (Inherited from IExternalServer.)
Public method | GetServiceId | (Inherited from IExternalServer.)
Public method | GetVendorId | (Inherited from IExternalServer.)
Public method | GetVersion | Gets the version of code checking server.
Public method | PostGeneration | Launched after Revit load combination generation (only in preview mode).
Public method | PreGeneration | Launched before Revit load combination generation (only in preview mode).
Public method | PreviewMode | Indicates if server supports preview mode.
Public method | RemoveLoadCombinations | Indicates if load combinations generated in the past should be removed before generation.

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ILoadCombinationServer Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ILoadCombinationServer Methods
ILoadCombinationServer Interface See Also Send Feedback

The ILoadCombinationServer type exposes the following members.

Methods

 | Name | Description
Public method | ConvertDataToCurrentVersion | Converts old version of data entity to the newest one.
Public method | Generate | Generates load combinations. Used only if the server doesn't support preview mode.
Public method | GeneratePreview | Generates load combinations preview. Used only if the server supports preview mode.
Public method | GetDataSchema | Gets the data schema.
Public method | GetDefaultData | Gets the default data.
Public method | GetDescription | (Inherited from IExternalServer.)
Public method | GetName | (Inherited from IExternalServer.)
Public method | GetServerId | (Inherited from IExternalServer.)
Public method | GetServiceId | (Inherited from IExternalServer.)
Public method | GetVendorId | (Inherited from IExternalServer.)
Public method | GetVersion | Gets the version of code checking server.
Public method | PostGeneration | Launched after Revit load combination generation (only in preview mode).
Public method | PreGeneration | Launched before Revit load combination generation (only in preview mode).
Public method | PreviewMode | Indicates if server supports preview mode.
Public method | RemoveLoadCombinations | Indicates if load combinations generated in the past should be removed before generation.

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ConvertDataToCurrentVersion Method

ILoadCombinationServer..::..ConvertDataToCurrentVersion Method
ILoadCombinationServer Interface See Also Send Feedback
Converts old version of data entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Entity ConvertDataToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version.
document
Type: Document
The document.

Return Value

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Generate Method

ILoadCombinationServer..::..Generate Method
ILoadCombinationServer Interface See Also Send Feedback
Generates load combinations. Used only if the server doesn't support preview mode.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void Generate(
    ServiceData data
)

Parameters

data
Type: Autodesk.Revit.DB.CodeChecking.LoadCombination..::..ServiceData
The data.

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GeneratePreview Method

ILoadCombinationServer..::..GeneratePreview Method
ILoadCombinationServer Interface See Also Send Feedback
Generates load combinations preview. Used only if the server supports preview mode.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
List<LoadCombinationPreview> GeneratePreview(
    ServiceData data
)

Parameters

data
Type: Autodesk.Revit.DB.CodeChecking.LoadCombination..::..ServiceData
The data.

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetDataSchema Method

ILoadCombinationServer..::..GetDataSchema Method
ILoadCombinationServer Interface See Also Send Feedback
Gets the data schema.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Schema GetDataSchema()

Return Value

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetDefaultData Method

ILoadCombinationServer..::..GetDefaultData Method
ILoadCombinationServer Interface See Also Send Feedback
Gets the default data.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Entity GetDefaultData(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetVersion Method

ILoadCombinationServer..::..GetVersion Method
ILoadCombinationServer Interface See Also Send Feedback
Gets the version of code checking server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
int GetVersion()

Return Value

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


PostGeneration Method

ILoadCombinationServer..::..PostGeneration Method
ILoadCombinationServer Interface See Also Send Feedback
Launched after Revit load combination generation (only in preview mode).

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void PostGeneration(
    Document document,
    List<LoadCombination> generatedCombinations
)

Parameters

document
Type: Document
The document.
generatedCombinations
Type: System.Collections.Generic..::..List <(Of <(<'LoadCombination>)>)>
The generated list of combinations.

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


PreGeneration Method

ILoadCombinationServer..::..PreGeneration Method
ILoadCombinationServer Interface See Also Send Feedback
Launched before Revit load combination generation (only in preview mode).

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void PreGeneration(
    Document document,
    List<LoadCombinationPreview> selectedCombinations
)

Parameters

document
Type: Document
The document.
selectedCombinations
Type: System.Collections.Generic..::..List <(Of <(<' LoadCombinationPreview >)>)>
Selected combinations by the user.

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


PreviewMode Method

ILoadCombinationServer..::..PreviewMode Method
ILoadCombinationServer Interface See Also Send Feedback
Indicates if server supports preview mode.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool PreviewMode()

Return Value

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


RemoveLoadCombinations Method

ILoadCombinationServer..::..RemoveLoadCombinations Method
ILoadCombinationServer Interface See Also Send Feedback
Indicates if load combinations generated in the past should be removed before generation.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool RemoveLoadCombinations()

Return Value

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationPreview Class

LoadCombinationPreview Class
Members See Also Send Feedback
Represents load combination preview

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LoadCombinationPreview : ILoadCombination

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.LoadCombination..::..LoadCombinationPreview

See Also

LoadCombinationPreview Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationPreview Members

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationPreview Members
LoadCombinationPreview Class Constructors Methods Properties See Also Send Feedback

The LoadCombinationPreview type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCombinationPreview | Initializes a new instance of the LoadCombinationPreview class.

Methods

 | Name | Description
Public method | AddComponent | Adds the component. It should be LoadCase, LoadCombination or LoadCombinationPreview
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Generate | Generates Revit LoadCombination in specified document.
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsageName | Gets the name of the usage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | State | Gets or sets the state.
Public property | Type | Gets or sets the type.
Public property | Usages | Gets the usages.

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationPreview Constructor

LoadCombinationPreview Constructor
LoadCombinationPreview Class See Also Send Feedback
Initializes a new instance of the LoadCombinationPreview class.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombinationPreview()

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationPreview Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationPreview Methods
LoadCombinationPreview Class See Also Send Feedback

The LoadCombinationPreview type exposes the following members.

Methods

 | Name | Description
Public method | AddComponent | Adds the component. It should be LoadCase, LoadCombination or LoadCombinationPreview
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Generate | Generates Revit LoadCombination in specified document.
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsageName | Gets the name of the usage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


AddComponent Method

LoadCombinationPreview..::..AddComponent Method
LoadCombinationPreview Class See Also Send Feedback
Adds the component. It should be LoadCase, LoadCombination or LoadCombinationPreview

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddComponent(
    Object component,
    double factor
)

Parameters

component
Type: System..::..Object
The component.
factor
Type: System..::..Double
The factor.

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Generate Method

LoadCombinationPreview..::..Generate Method
LoadCombinationPreview Class See Also Send Feedback
Generates Revit LoadCombination in specified document.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombination Generate(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetCombinationType Method

LoadCombinationPreview..::..GetCombinationType Method
LoadCombinationPreview Class See Also Send Feedback
Gets the type of the load combination.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombinationType GetCombinationType()

Return Value

Implements

ILoadCombination..::..GetCombinationType()()()()

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetComponentFactor Method

LoadCombinationPreview..::..GetComponentFactor Method
LoadCombinationPreview Class See Also Send Feedback
Gets the component factor.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetComponentFactor(
    int i
)

Parameters

i
Type: System..::..Int32
The index.

Return Value

Implements

ILoadCombination..::..GetComponentFactor(Int32)

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetComponentName Method

LoadCombinationPreview..::..GetComponentName Method
LoadCombinationPreview Class See Also Send Feedback
Gets the name of the component.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetComponentName(
    int i
)

Parameters

i
Type: System..::..Int32
The index.

Return Value

Implements

ILoadCombination..::..GetComponentName(Int32)

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetId Method

LoadCombinationPreview..::..GetId Method
LoadCombinationPreview Class See Also Send Feedback
Gets the id.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int GetId()

Return Value

Implements

ILoadCombination..::..GetId()()()()

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetName Method

LoadCombinationPreview..::..GetName Method
LoadCombinationPreview Class See Also Send Feedback
Gets the name.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetName()

Return Value

Implements

ILoadCombination..::..GetName()()()()

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetNumberOfComponents Method

LoadCombinationPreview..::..GetNumberOfComponents Method
LoadCombinationPreview Class See Also Send Feedback
Gets the number of components.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int GetNumberOfComponents()

Return Value

Implements

ILoadCombination..::..GetNumberOfComponents()()()()

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetNumberOfUsages Method

LoadCombinationPreview..::..GetNumberOfUsages Method
LoadCombinationPreview Class See Also Send Feedback
Gets the number of usages.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int GetNumberOfUsages()

Return Value

Implements

ILoadCombination..::..GetNumberOfUsages()()()()

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetState Method

LoadCombinationPreview..::..GetState Method
LoadCombinationPreview Class See Also Send Feedback
Gets the state.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombinationState GetState()

Return Value

Implements

ILoadCombination..::..GetState()()()()

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetUsageName Method

LoadCombinationPreview..::..GetUsageName Method
LoadCombinationPreview Class See Also Send Feedback
Gets the name of the usage.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetUsageName(
    int i
)

Parameters

i
Type: System..::..Int32
The index.

Return Value

Implements

ILoadCombination..::..GetUsageName(Int32)

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationPreview Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationPreview Properties
LoadCombinationPreview Class See Also Send Feedback

The LoadCombinationPreview type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | State | Gets or sets the state.
Public property | Type | Gets or sets the type.
Public property | Usages | Gets the usages.

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Name Property

LoadCombinationPreview..::..Name Property
LoadCombinationPreview Class See Also Send Feedback
Gets or sets the name.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

Field Value

The name.

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


State Property

LoadCombinationPreview..::..State Property
LoadCombinationPreview Class See Also Send Feedback
Gets or sets the state.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombinationState State { get; set; }

Field Value

The state.

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Type Property

LoadCombinationPreview..::..Type Property
LoadCombinationPreview Class See Also Send Feedback
Gets or sets the type.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombinationType Type { get; set; }

Field Value

The type.

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Usages Property

LoadCombinationPreview..::..Usages Property
LoadCombinationPreview Class See Also Send Feedback
Gets the usages.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadUsageArray Usages { get; private set; }

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationState Enumeration

LoadCombinationState Enumeration
See Also Send Feedback
Load combination state

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum LoadCombinationState

Members

Member name | Value | Description
Servicebility | 0 | Servicebility
Ultimate | 1 | Ultimate

See Also

Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationType Enumeration

LoadCombinationType Enumeration
See Also Send Feedback
Load combination type

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum LoadCombinationType

Members

Member name | Value | Description
Combination | 0 | Combination
Envelope | 1 | Envelope

See Also

Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationUtils Class

LoadCombinationUtils Class
Members See Also Send Feedback
Helper class for Load Combination framework

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LoadCombinationUtils

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.LoadCombination..::..LoadCombinationUtils

See Also

LoadCombinationUtils Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationUtils Members

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationUtils Members
LoadCombinationUtils Class Constructors Methods See Also Send Feedback

The LoadCombinationUtils type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCombinationUtils | Initializes a new instance of the LoadCombinationUtils class

Methods

 | Name | Description
 | CopyLoadCaseArray | Copies the load case array.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>)) | Creates load combinations.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations.
 | CreateLoadCombinations(String, List<(Of <<'(List<(Of <<'(LoadCaseArray>)>>)>)>>), List<(Of <<'(Double>)>>)) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinationSets(List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(array<Double>[]()[][]>)>>)%) | Creates load combinations.
 | CreateLoadCombinationSets(List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>), Double, List<(Of <<'(array<Double>[]()[][]>)>>)%) | Sums load combinations.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLoadCaseNature | Gets the load case nature.
 | GetLoadCases | Gets the load cases.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GroupLoadCasesDueToCategory | Groups the load cases due to nature.
 | PerformAnd | Performs the and operation.
 | PerformOrExlusive | Performs the or exlusive operation.
 | PerformOrInclusive | Performs the or inclusive operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationUtils Constructor

LoadCombinationUtils Constructor
LoadCombinationUtils Class See Also Send Feedback
Initializes a new instance of the LoadCombinationUtils class

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombinationUtils()

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


LoadCombinationUtils Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationUtils Methods
LoadCombinationUtils Class See Also Send Feedback

The LoadCombinationUtils type exposes the following members.

Methods

 | Name | Description
 | CopyLoadCaseArray | Copies the load case array.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>)) | Creates load combinations.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations.
 | CreateLoadCombinations(String, List<(Of <<'(List<(Of <<'(LoadCaseArray>)>>)>)>>), List<(Of <<'(Double>)>>)) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinationSets(List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(array<Double>[]()[][]>)>>)%) | Creates load combinations.
 | CreateLoadCombinationSets(List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>), Double, List<(Of <<'(array<Double>[]()[][]>)>>)%) | Sums load combinations.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLoadCaseNature | Gets the load case nature.
 | GetLoadCases | Gets the load cases.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GroupLoadCasesDueToCategory | Groups the load cases due to nature.
 | PerformAnd | Performs the and operation.
 | PerformOrExlusive | Performs the or exlusive operation.
 | PerformOrInclusive | Performs the or inclusive operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CopyLoadCaseArray Method

LoadCombinationUtils..::..CopyLoadCaseArray Method
LoadCombinationUtils Class See Also Send Feedback
Copies the load case array.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void CopyLoadCaseArray(
    LoadCaseArray source,
    LoadCaseArray target
)

Parameters

source
Type: LoadCaseArray
The source.
target
Type: LoadCaseArray
The target.

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CreateLoadCombinations Method

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationUtils..::..CreateLoadCombinations Method
LoadCombinationUtils Class See Also Send Feedback

Overload List

Name | Description
CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>)) | Creates load combinations.
CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations.
CreateLoadCombinations(String, List<(Of <<'(List<(Of <<'(LoadCaseArray>)>>)>)>>), List<(Of <<'(Double>)>>)) | Creates load combinations by performing sum.
CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.

See Also

LoadCombinationUtils Class
LoadCombinationUtils Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CreateLoadCombinations Method (String, List(), List(Double[]))

LoadCombinationUtils..::..CreateLoadCombinations Method (String, List<(Of <(<'>)>)>, List<(Of <(<'array<Double>[]()[][]>)>)>)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCombinationPreview> CreateLoadCombinations(
    string baseName,
    List<LoadCaseArray> loadCasesSets,
    List<double[]> factors
)

Parameters

baseName
Type: System..::..String
Base name.
loadCasesSets
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The list of load cases.
factors
Type: System.Collections.Generic..::..List <(Of <(<'array< Double >[]()[][]>)>)>
The factors.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinations Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CreateLoadCombinations Method (String, List(), Double)

LoadCombinationUtils..::..CreateLoadCombinations Method (String, List<(Of <(<'>)>)>, Double)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCombinationPreview> CreateLoadCombinations(
    string baseName,
    List<LoadCaseArray> loadCasesSets1,
    double factor1
)

Parameters

baseName
Type: System..::..String
The base name
loadCasesSets1
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 1.
factor1
Type: System..::..Double
The factor 1.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinations Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CreateLoadCombinations Method (String, List(List()), List(Double))

LoadCombinationUtils..::..CreateLoadCombinations Method (String, List<(Of <(<'List<(Of <(<'>)>)>>)>)>, List<(Of <(<'Double>)>)>)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations by performing sum.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCombinationPreview> CreateLoadCombinations(
    string baseName,
    List<List<LoadCaseArray>> loadCasesSets,
    List<double> factors
)

Parameters

baseName
Type: System..::..String
The base name
loadCasesSets
Type: System.Collections.Generic..::..List <(Of <(<' List <(Of <(<'LoadCaseArray>)>)>>)>)>
The list of load cases sets
factors
Type: System.Collections.Generic..::..List <(Of <(<' Double >)>)>
The list of factors

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinations Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CreateLoadCombinations Method (String, List(), Double, List(), Double)

LoadCombinationUtils..::..CreateLoadCombinations Method (String, List<(Of <(<'>)>)>, Double, List<(Of <(<'>)>)>, Double)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations by performing sum.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCombinationPreview> CreateLoadCombinations(
    string baseName,
    List<LoadCaseArray> loadCasesSets1,
    double factor1,
    List<LoadCaseArray> loadCasesSets2,
    double factor2
)

Parameters

baseName
Type: System..::..String
The base name
loadCasesSets1
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 1.
factor1
Type: System..::..Double
The factor 1.
loadCasesSets2
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 2.
factor2
Type: System..::..Double
The factor 2.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinations Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CreateLoadCombinations Method (String, List(), Double, List(), Double, List(), Double)

LoadCombinationUtils..::..CreateLoadCombinations Method (String, List<(Of <(<'>)>)>, Double, List<(Of <(<'>)>)>, Double, List<(Of <(<'>)>)>, Double)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations by performing sum.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCombinationPreview> CreateLoadCombinations(
    string baseName,
    List<LoadCaseArray> loadCasesSets1,
    double factor1,
    List<LoadCaseArray> loadCasesSets2,
    double factor2,
    List<LoadCaseArray> loadCasesSets3,
    double factor3
)

Parameters

baseName
Type: System..::..String
The base name
loadCasesSets1
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 1.
factor1
Type: System..::..Double
The factor 1.
loadCasesSets2
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 2.
factor2
Type: System..::..Double
The factor 2.
loadCasesSets3
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 3.
factor3
Type: System..::..Double
The factor 2.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinations Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CreateLoadCombinations Method (String, List(), Double, List(), Double, List(), Double, List(), Double)

LoadCombinationUtils..::..CreateLoadCombinations Method (String, List<(Of <(<'>)>)>, Double, List<(Of <(<'>)>)>, Double, List<(Of <(<'>)>)>, Double, List<(Of <(<'>)>)>, Double)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations by performing sum.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCombinationPreview> CreateLoadCombinations(
    string baseName,
    List<LoadCaseArray> loadCasesSets1,
    double factor1,
    List<LoadCaseArray> loadCasesSets2,
    double factor2,
    List<LoadCaseArray> loadCasesSets3,
    double factor3,
    List<LoadCaseArray> loadCasesSets4,
    double factor4
)

Parameters

baseName
Type: System..::..String
The base name
loadCasesSets1
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 1.
factor1
Type: System..::..Double
The factor 1.
loadCasesSets2
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 2.
factor2
Type: System..::..Double
The factor 2.
loadCasesSets3
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 3.
factor3
Type: System..::..Double
The factor 2.
loadCasesSets4
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 3.
factor4
Type: System..::..Double
The factor 2.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinations Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CreateLoadCombinationSets Method

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationUtils..::..CreateLoadCombinationSets Method
LoadCombinationUtils Class See Also Send Feedback

Overload List

Name | Description
CreateLoadCombinationSets(List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(array<Double>[]()[][]>)>>)%) | Creates load combinations.
CreateLoadCombinationSets(List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>), Double, List<(Of <<'(array<Double>[]()[][]>)>>)%) | Sums load combinations.

See Also

LoadCombinationUtils Class
LoadCombinationUtils Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CreateLoadCombinationSets Method (List(), Double, List(Double[]))

LoadCombinationUtils..::..CreateLoadCombinationSets Method (List<(Of <(<'>)>)>, Double, List<(Of <(<'array<Double>[]()[][]>)>)>%)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCaseArray> CreateLoadCombinationSets(
    List<LoadCaseArray> loadCasesSets,
    double factor,
    out List<double[]> factors
)

Parameters

loadCasesSets
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases sets.
factor
Type: System..::..Double
The factor1.
factors
Type: System.Collections.Generic..::..List <(Of <(<'array< Double >[]()[][]>)>)>%
The factors.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinationSets Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CreateLoadCombinationSets Method (List(), List(Double[]), Double, List(), List(Double[]), Double, List(Double[]))

LoadCombinationUtils..::..CreateLoadCombinationSets Method (List<(Of <(<'>)>)>, List<(Of <(<'array<Double>[]()[][]>)>)>, Double, List<(Of <(<'>)>)>, List<(Of <(<'array<Double>[]()[][]>)>)>, Double, List<(Of <(<'array<Double>[]()[][]>)>)>%)
LoadCombinationUtils Class See Also Send Feedback
Sums load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCaseArray> CreateLoadCombinationSets(
    List<LoadCaseArray> loadCasesSets1,
    List<double[]> factors1,
    double factor1,
    List<LoadCaseArray> loadCasesSets2,
    List<double[]> factors2,
    double factor2,
    out List<double[]> factors
)

Parameters

loadCasesSets1
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 1
factors1
Type: System.Collections.Generic..::..List <(Of <(<'array< Double >[]()[][]>)>)>
The factors 1.
factor1
Type: System..::..Double
The factor1.
loadCasesSets2
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 2.
factors2
Type: System.Collections.Generic..::..List <(Of <(<'array< Double >[]()[][]>)>)>
The factors2.
factor2
Type: System..::..Double
The factor2.
factors
Type: System.Collections.Generic..::..List <(Of <(<'array< Double >[]()[][]>)>)>%
The factors.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinationSets Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetLoadCaseNature Method

LoadCombinationUtils..::..GetLoadCaseNature Method
LoadCombinationUtils Class See Also Send Feedback
Gets the load case nature.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static BuiltInCategory GetLoadCaseNature(
    LoadCase loadCase
)

Parameters

loadCase
Type: LoadCase
The load case.

Return Value

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetLoadCases Method

LoadCombinationUtils..::..GetLoadCases Method
LoadCombinationUtils Class See Also Send Feedback
Gets the load cases.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static LoadCaseArray GetLoadCases(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GroupLoadCasesDueToCategory Method

LoadCombinationUtils..::..GroupLoadCasesDueToCategory Method
LoadCombinationUtils Class See Also Send Feedback
Groups the load cases due to nature.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Dictionary<BuiltInCategory, LoadCaseArray> GroupLoadCasesDueToCategory(
    LoadCaseArray loadCases
)

Parameters

loadCases
Type: LoadCaseArray
The load cases.

Return Value

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


PerformAnd Method

LoadCombinationUtils..::..PerformAnd Method
LoadCombinationUtils Class See Also Send Feedback
Performs the and operation.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCaseArray> PerformAnd(
    LoadCaseArray loadCases
)

Parameters

loadCases
Type: LoadCaseArray
The load cases.

Return Value

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


PerformOrExlusive Method

LoadCombinationUtils..::..PerformOrExlusive Method
LoadCombinationUtils Class See Also Send Feedback
Performs the or exlusive operation.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCaseArray> PerformOrExlusive(
    LoadCaseArray loadCases
)

Parameters

loadCases
Type: LoadCaseArray
The load cases.

Return Value

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


PerformOrInclusive Method

LoadCombinationUtils..::..PerformOrInclusive Method
LoadCombinationUtils Class See Also Send Feedback
Performs the or inclusive operation.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCaseArray> PerformOrInclusive(
    LoadCaseArray loadCases
)

Parameters

loadCases
Type: LoadCaseArray
The load cases.

Return Value

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


RevitLoadCombination Class

RevitLoadCombination Class
Members See Also Send Feedback
Wraps Revit Load Combination

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class RevitLoadCombination : ILoadCombination

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.LoadCombination..::..RevitLoadCombination

See Also

RevitLoadCombination Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


RevitLoadCombination Members

[image]

Structural Analysis and Code Checking API Reference Guide
RevitLoadCombination Members
RevitLoadCombination Class Constructors Methods Properties See Also Send Feedback

The RevitLoadCombination type exposes the following members.

Constructors

 | Name | Description
Public method | RevitLoadCombination | Initializes a new instance of the RevitLoadCombination class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsageName | Gets the name of the usage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Combination | Gets or sets the combination.

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


RevitLoadCombination Constructor

RevitLoadCombination Constructor
RevitLoadCombination Class See Also Send Feedback
Initializes a new instance of the RevitLoadCombination class.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public RevitLoadCombination(
    LoadCombination combination
)

Parameters

combination
Type: LoadCombination
The combination.

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


RevitLoadCombination Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RevitLoadCombination Methods
RevitLoadCombination Class See Also Send Feedback

The RevitLoadCombination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsageName | Gets the name of the usage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetCombinationType Method

RevitLoadCombination..::..GetCombinationType Method
RevitLoadCombination Class See Also Send Feedback
Gets the type of the load combination.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombinationType GetCombinationType()

Return Value

Implements

ILoadCombination..::..GetCombinationType()()()()

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetComponentFactor Method

RevitLoadCombination..::..GetComponentFactor Method
RevitLoadCombination Class See Also Send Feedback
Gets the component factor.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetComponentFactor(
    int i
)

Parameters

i
Type: System..::..Int32
The index.

Return Value

Implements

ILoadCombination..::..GetComponentFactor(Int32)

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetComponentName Method

RevitLoadCombination..::..GetComponentName Method
RevitLoadCombination Class See Also Send Feedback
Gets the name of the component.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetComponentName(
    int i
)

Parameters

i
Type: System..::..Int32
The index.

Return Value

Implements

ILoadCombination..::..GetComponentName(Int32)

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetId Method

RevitLoadCombination..::..GetId Method
RevitLoadCombination Class See Also Send Feedback
Gets the id.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int GetId()

Return Value

Implements

ILoadCombination..::..GetId()()()()

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetName Method

RevitLoadCombination..::..GetName Method
RevitLoadCombination Class See Also Send Feedback
Gets the name.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetName()

Return Value

Implements

ILoadCombination..::..GetName()()()()

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetNumberOfComponents Method

RevitLoadCombination..::..GetNumberOfComponents Method
RevitLoadCombination Class See Also Send Feedback
Gets the number of components.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int GetNumberOfComponents()

Return Value

Implements

ILoadCombination..::..GetNumberOfComponents()()()()

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetNumberOfUsages Method

RevitLoadCombination..::..GetNumberOfUsages Method
RevitLoadCombination Class See Also Send Feedback
Gets the number of usages.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int GetNumberOfUsages()

Return Value

Implements

ILoadCombination..::..GetNumberOfUsages()()()()

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetState Method

RevitLoadCombination..::..GetState Method
RevitLoadCombination Class See Also Send Feedback
Gets the state.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombinationState GetState()

Return Value

Implements

ILoadCombination..::..GetState()()()()

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetUsageName Method

RevitLoadCombination..::..GetUsageName Method
RevitLoadCombination Class See Also Send Feedback
Gets the name of the usage.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetUsageName(
    int i
)

Parameters

i
Type: System..::..Int32
The i.

Return Value

Implements

ILoadCombination..::..GetUsageName(Int32)

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


RevitLoadCombination Properties

[image]

Structural Analysis and Code Checking API Reference Guide
RevitLoadCombination Properties
RevitLoadCombination Class See Also Send Feedback

The RevitLoadCombination type exposes the following members.

Properties

 | Name | Description
Public property | Combination | Gets or sets the combination.

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Combination Property

RevitLoadCombination..::..Combination Property
RevitLoadCombination Class See Also Send Feedback
Gets or sets the combination.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombination Combination { get; set; }

Field Value

The combination.

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Server(TData) Class

Server<(Of <(<'TData>)>)> Class
Members See Also Send Feedback
Base class for all load combination servers which are based on reflection scenario. It provides automization for most of functionality required by ILoadCombinationServer.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Server<TData> : ILoadCombinationServer,
    IExternalServer
where TData : new(), SchemaClass

Type Parameters

TData
The type of the data.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.LoadCombination..::..Server<(Of <(<'TData>)>)>

See Also

Server<(Of <(<'TData>)>)> Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Server(TData) Members

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TData>)>)> Members
Server<(Of <(<'TData>)>)> Class Methods See Also Send Feedback

The Server<(Of <(<'TData>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ConvertDataToCurrentVersion | Converts the data to current version.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Generate | Generates load combinations. Used only if the server doesn't support preview mode.
Public method | GeneratePreview | Generates load combinations based on settings.
Public method | GetDataSchema | Gets the data schema.
Public method | GetDefaultData | Gets the default data.
Public method | GetDescription | Implement this method to return a description of the server.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Implement this method to return the name of the server.
Public method | GetServerId | Implement this method to return the id of the server.
Public method | GetServiceId | Implement this method to return the id of the service.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server.
Public method | GetVersion | Gets the version of code checking server.
Public method | PostGeneration | Launched after Revit load combination generation (only in preview mode).
Public method | PreGeneration | Launched before Revit load combination generation (only in preview mode).
Public method | PreviewMode | Indicates if server supports preview mode.
Public method | RemoveLoadCombinations | Indicates if load combinations generated in the past should be removed before generation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Server(TData) Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TData>)>)> Methods
Server<(Of <(<'TData>)>)> Class See Also Send Feedback

The Server<(Of <(<'TData>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ConvertDataToCurrentVersion | Converts the data to current version.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Generate | Generates load combinations. Used only if the server doesn't support preview mode.
Public method | GeneratePreview | Generates load combinations based on settings.
Public method | GetDataSchema | Gets the data schema.
Public method | GetDefaultData | Gets the default data.
Public method | GetDescription | Implement this method to return a description of the server.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Implement this method to return the name of the server.
Public method | GetServerId | Implement this method to return the id of the server.
Public method | GetServiceId | Implement this method to return the id of the service.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server.
Public method | GetVersion | Gets the version of code checking server.
Public method | PostGeneration | Launched after Revit load combination generation (only in preview mode).
Public method | PreGeneration | Launched before Revit load combination generation (only in preview mode).
Public method | PreviewMode | Indicates if server supports preview mode.
Public method | RemoveLoadCombinations | Indicates if load combinations generated in the past should be removed before generation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ConvertDataToCurrentVersion Method

Server<(Of <(<'TData>)>)>..::..ConvertDataToCurrentVersion Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Converts the data to current version.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity ConvertDataToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version.
document
Type: Document
The document.

Return Value

Implements

ILoadCombinationServer..::..ConvertDataToCurrentVersion(Entity, Document)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Generate Method

Server<(Of <(<'TData>)>)>..::..Generate Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Generates load combinations. Used only if the server doesn't support preview mode.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void Generate(
    ServiceData data
)

Parameters

data
Type: Autodesk.Revit.DB.CodeChecking.LoadCombination..::..ServiceData
The data.

Implements

ILoadCombinationServer..::..Generate(ServiceData)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GeneratePreview Method

Server<(Of <(<'TData>)>)>..::..GeneratePreview Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Generates load combinations based on settings.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual List<LoadCombinationPreview> GeneratePreview(
    ServiceData data
)

Parameters

data
Type: Autodesk.Revit.DB.CodeChecking.LoadCombination..::..ServiceData
The data.

Implements

ILoadCombinationServer..::..GeneratePreview(ServiceData)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetDataSchema Method

Server<(Of <(<'TData>)>)>..::..GetDataSchema Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Gets the data schema.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Schema GetDataSchema()

Return Value

Implements

ILoadCombinationServer..::..GetDataSchema()()()()

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetDefaultData Method

Server<(Of <(<'TData>)>)>..::..GetDefaultData Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Gets the default data.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity GetDefaultData(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

Implements

ILoadCombinationServer..::..GetDefaultData(Document)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetDescription Method

Server<(Of <(<'TData>)>)>..::..GetDescription Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Implement this method to return a description of the server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string GetDescription()

Return Value

Description of the server.

Implements

IExternalServerGetDescription()()()()

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetName Method

Server<(Of <(<'TData>)>)>..::..GetName Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Implement this method to return the name of the server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string GetName()

Return Value

Name of the server.

Implements

IExternalServerGetName()()()()

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetServerId Method

Server<(Of <(<'TData>)>)>..::..GetServerId Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Implement this method to return the id of the server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract Guid GetServerId()

Return Value

The id of the server.

Implements

IExternalServerGetServerId()()()()

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetServiceId Method

Server<(Of <(<'TData>)>)>..::..GetServiceId Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Implement this method to return the id of the service.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual ExternalServiceId GetServiceId()

Return Value

The id of the service to which the server belongs.

Implements

IExternalServerGetServiceId()()()()

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetVendorId Method

Server<(Of <(<'TData>)>)>..::..GetVendorId Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Implement this method to return the id of the vendor of the server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string GetVendorId()

Return Value

Vendor Id of the server.

Implements

IExternalServerGetVendorId()()()()

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetVersion Method

Server<(Of <(<'TData>)>)>..::..GetVersion Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Gets the version of code checking server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual int GetVersion()

Return Value

Implements

ILoadCombinationServer..::..GetVersion()()()()

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


PostGeneration Method

Server<(Of <(<'TData>)>)>..::..PostGeneration Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Launched after Revit load combination generation (only in preview mode).

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void PostGeneration(
    Document document,
    List<LoadCombination> generatedCombinations
)

Parameters

document
Type: Document
The document.
generatedCombinations
Type: System.Collections.Generic..::..List <(Of <(<'LoadCombination>)>)>
The generated list of combinations.

Implements

ILoadCombinationServer..::..PostGeneration(Document, List<(Of <<'(LoadCombination>)>>))

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


PreGeneration Method

Server<(Of <(<'TData>)>)>..::..PreGeneration Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Launched before Revit load combination generation (only in preview mode).

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void PreGeneration(
    Document document,
    List<LoadCombinationPreview> selectedCombinations
)

Parameters

document
Type: Document
The document.
selectedCombinations
Type: System.Collections.Generic..::..List <(Of <(<' LoadCombinationPreview >)>)>
Selected combinations by the user.

Implements

ILoadCombinationServer..::..PreGeneration(Document, List<(Of <<'(LoadCombinationPreview>)>>))

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


PreviewMode Method

Server<(Of <(<'TData>)>)>..::..PreviewMode Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Indicates if server supports preview mode.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool PreviewMode()

Return Value

Implements

ILoadCombinationServer..::..PreviewMode()()()()

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


RemoveLoadCombinations Method

Server<(Of <(<'TData>)>)>..::..RemoveLoadCombinations Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Indicates if load combinations generated in the past should be removed before generation.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool RemoveLoadCombinations()

Return Value

Implements

ILoadCombinationServer..::..RemoveLoadCombinations()()()()

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Service Class

Service Class
Members See Also Send Feedback
Represents main load combination service

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Service : ISingleServerService, IExternalService

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.LoadCombination..::..Service

See Also

Service Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Service Members

[image]

Structural Analysis and Code Checking API Reference Guide
Service Members
Service Class Constructors Methods Fields See Also Send Feedback

The Service type exposes the following members.

Constructors

 | Name | Description
Public method | Service | Initializes a new instance of the Service class

Methods

 | Name | Description
 | AddServer | Register server in Service
 | BlockServer | Blocks the server.
Public method | CanExecute | Returns permission for executing particular server
 | DocumentOpened | Inform service about document opening.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(Document, Guid) | Executes given server.
Public method | Execute(IExternalServer, Document, IExternalData) | Executes given server.
 | ExecuteServer | Executes given server.
 | GenerateCombinations | Generates the combinations.
 | GetActiveServer | Returns list of active server registered in Service
 | GetActiveServerId | Returns active server registered in Service
 | GetDataStorage | Gets the data storage element which contains particular schema.
Public method | GetDescription | Returns the description
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the service.
 | GetServer | Returns server of specific id.
 | GetServers | Returns servers registered in Service
Public method | GetServiceId | Returns service ID
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendor | Return vendor.
Public method | GetVendorId | Reurns vendor Id of the service.
 | IsActive | Determines whether the specified server ID is active.
 | IsBlocked | Determines whether the specified server is blocked.
Public method | IsValidServer | Validates server.
Public method | OnServersChanged | Takes action when servers changes.
Public method | OnServersDisparity |
 | RegisterService | Registers service in Revit
 | SetActiveServer | Sets active servers
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnBlockServer | Uns the block server.

Fields

Name | Description
ID | Unique Id of the Service

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Service Constructor

Service Constructor
Service Class See Also Send Feedback
Initializes a new instance of the Service class

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Service()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Service Fields

[image]

Structural Analysis and Code Checking API Reference Guide
Service Fields
Service Class See Also Send Feedback

The Service type exposes the following members.

Fields

Name | Description
ID | Unique Id of the Service

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ID Field

Service..::..ID Field
Service Class See Also Send Feedback
Unique Id of the Service

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ExternalServiceId ID

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Service Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Service Methods
Service Class See Also Send Feedback

The Service type exposes the following members.

Methods

 | Name | Description
 | AddServer | Register server in Service
 | BlockServer | Blocks the server.
Public method | CanExecute | Returns permission for executing particular server
 | DocumentOpened | Inform service about document opening.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(Document, Guid) | Executes given server.
Public method | Execute(IExternalServer, Document, IExternalData) | Executes given server.
 | ExecuteServer | Executes given server.
 | GenerateCombinations | Generates the combinations.
 | GetActiveServer | Returns list of active server registered in Service
 | GetActiveServerId | Returns active server registered in Service
 | GetDataStorage | Gets the data storage element which contains particular schema.
Public method | GetDescription | Returns the description
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the service.
 | GetServer | Returns server of specific id.
 | GetServers | Returns servers registered in Service
Public method | GetServiceId | Returns service ID
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendor | Return vendor.
Public method | GetVendorId | Reurns vendor Id of the service.
 | IsActive | Determines whether the specified server ID is active.
 | IsBlocked | Determines whether the specified server is blocked.
Public method | IsValidServer | Validates server.
Public method | OnServersChanged | Takes action when servers changes.
Public method | OnServersDisparity |
 | RegisterService | Registers service in Revit
 | SetActiveServer | Sets active servers
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnBlockServer | Uns the block server.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


AddServer Method

Service..::..AddServer Method
Service Class See Also Send Feedback
Register server in Service

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void AddServer(
    ILoadCombinationServer server
)

Parameters

server
Type: Autodesk.Revit.DB.CodeChecking.LoadCombination..::..ILoadCombinationServer
External server

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


BlockServer Method

Service..::..BlockServer Method
Service Class See Also Send Feedback
Blocks the server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void BlockServer(
    Guid server
)

Parameters

server
Type: System..::..Guid
The server.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


CanExecute Method

Service..::..CanExecute Method
Service Class See Also Send Feedback
Returns permission for executing particular server

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool CanExecute(
    IExternalServer server,
    Document document,
    IExternalData data
)

Parameters

server
Type: IExternalServer
The server.
document
Type: Document
The document.
data
Type: IExternalData
The data.

Return Value

Permission.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


DocumentOpened Method

Service..::..DocumentOpened Method
Service Class See Also Send Feedback
Inform service about document opening.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void DocumentOpened(
    Document document
)

Parameters

document
Type: Document
The document.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Execute Method

[image]

Structural Analysis and Code Checking API Reference Guide
Service..::..Execute Method
Service Class See Also Send Feedback

Overload List

 | Name | Description
 | Execute(Document, Guid) | Executes given server.
Public method | Execute(IExternalServer, Document, IExternalData) | Executes given server.

See Also

Service Class
Service Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Execute Method (, Guid)

Service..::..Execute Method (, Guid)
Service Class See Also Send Feedback
Executes given server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void Execute(
    Document document,
    Guid session
)

Parameters

document
Type: Document
The document.
session
Type: System..::..Guid
The session.

See Also

Service Class
Execute Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Execute Method (, , )

Service..::..Execute Method (, , )
Service Class See Also Send Feedback
Executes given server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Execute(
    IExternalServer server,
    Document document,
    IExternalData data
)

Parameters

server
Type: IExternalServer
The server.
document
Type: Document
The document.
data
Type: IExternalData
The data.

Return Value

Whether execution succeded.

Implements

IExternalServiceExecute(IExternalServer, Document, IExternalData)

See Also

Service Class
Execute Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ExecuteServer Method

Service..::..ExecuteServer Method
Service Class See Also Send Feedback
Executes given server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ExecuteServer(
    Document document,
    Guid serverId
)

Parameters

document
Type: Document
The document.
serverId
Type: System..::..Guid
The server id.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GenerateCombinations Method

Service..::..GenerateCombinations Method
Service Class See Also Send Feedback
Generates the combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCombination> GenerateCombinations(
    Document document,
    string description,
    List<LoadCombinationPreview> combinations
)

Parameters

document
Type: Document
The document.
description
Type: System..::..String
The description.
combinations
Type: System.Collections.Generic..::..List <(Of <(<' LoadCombinationPreview >)>)>
The combination list.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetActiveServer Method

Service..::..GetActiveServer Method
Service Class See Also Send Feedback
Returns list of active server registered in Service

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ILoadCombinationServer GetActiveServer(
    Document document,
    bool wrap
)

Parameters

document
Type: Document
The document.
wrap
Type: System..::..Boolean
if set to true wrap.

Return Value

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetActiveServerId Method

Service..::..GetActiveServerId Method
Service Class See Also Send Feedback
Returns active server registered in Service

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Guid GetActiveServerId(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetDataStorage Method

Service..::..GetDataStorage Method
Service Class See Also Send Feedback
Gets the data storage element which contains particular schema.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Element GetDataStorage(
    Schema schema,
    Document document,
    bool create
)

Parameters

schema
Type: Schema
The schema.
document
Type: Document
The document.
create
Type: System..::..Boolean
if set to true creates the new object if not exist.

Return Value

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetDescription Method

Service..::..GetDescription Method
Service Class See Also Send Feedback
Returns the description

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetDescription()

Return Value

The description

Implements

IExternalServiceGetDescription()()()()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetName Method

Service..::..GetName Method
Service Class See Also Send Feedback
Gets the name of the service.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetName()

Return Value

The name.

Implements

IExternalServiceGetName()()()()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetServer Method

Service..::..GetServer Method
Service Class See Also Send Feedback
Returns server of specific id.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ILoadCombinationServer GetServer(
    Guid id,
    bool wrap
)

Parameters

id
Type: System..::..Guid
The id of the server.
wrap
Type: System..::..Boolean
if set to true the server will be wrapped in additional object.

Return Value

Returns the server.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetServers Method

Service..::..GetServers Method
Service Class See Also Send Feedback
Returns servers registered in Service

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<IExternalServer> GetServers(
    bool wrap
)

Parameters

wrap
Type: System..::..Boolean

Return Value

Return the list of servers

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetServiceId Method

Service..::..GetServiceId Method
Service Class See Also Send Feedback
Returns service ID

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ExternalServiceId GetServiceId()

Return Value

Service id

Implements

IExternalServiceGetServiceId()()()()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetVendor Method

Service..::..GetVendor Method
Service Class See Also Send Feedback
Return vendor.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetVendor()

Return Value

Vendor

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


GetVendorId Method

Service..::..GetVendorId Method
Service Class See Also Send Feedback
Reurns vendor Id of the service.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetVendorId()

Return Value

Implements

IExternalServiceGetVendorId()()()()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


IsActive Method

Service..::..IsActive Method
Service Class See Also Send Feedback
Determines whether the specified server ID is active.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool IsActive(
    Guid serverID,
    Document document
)

Parameters

serverID
Type: System..::..Guid
The server ID.
document
Type: Document
The document.

Return Value

true if the specified server ID is active; otherwise, false.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


IsBlocked Method

Service..::..IsBlocked Method
Service Class See Also Send Feedback
Determines whether the specified server is blocked.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool IsBlocked(
    Guid server
)

Parameters

server
Type: System..::..Guid
The server.

Return Value

true if the specified server is blocked; otherwise, false.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


IsValidServer Method

Service..::..IsValidServer Method
Service Class See Also Send Feedback
Validates server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsValidServer(
    IExternalServer server
)

Parameters

server
Type: IExternalServer
The server.

Return Value

Implements

IExternalServiceIsValidServer(IExternalServer)

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


OnServersChanged Method

Service..::..OnServersChanged Method
Service Class See Also Send Feedback
Takes action when servers changes.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void OnServersChanged(
    Document document,
    ServerChangeCause cause,
    IList<Guid> oldServers
)

Parameters

document
Type: Document
The document.
cause
Type: ServerChangeCause
The cause.
oldServers
Type: System.Collections.Generic..::..IList <(Of <(<' Guid >)>)>
The list of old servers.

Implements

IExternalServiceOnServersChanged(Document, ServerChangeCause, IList<(Of <<'(Guid>)>>))

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


OnServersDisparity Method

Service..::..OnServersDisparity Method
Service Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool OnServersDisparity(
    Document document,
    IList<Guid> oldServers
)

Parameters

document
Type: Document
The document.
oldServers
Type: System.Collections.Generic..::..IList <(Of <(<' Guid >)>)>

Return Value

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


RegisterService Method

Service..::..RegisterService Method
Service Class See Also Send Feedback
Registers service in Revit

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void RegisterService()

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


SetActiveServer Method

Service..::..SetActiveServer Method
Service Class See Also Send Feedback
Sets active servers

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void SetActiveServer(
    Guid serverId,
    Document document,
    bool save
)

Parameters

serverId
Type: System..::..Guid
List of servers Ids
document
Type: Document
The document.
save
Type: System..::..Boolean
if set to true save.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


UnBlockServer Method

Service..::..UnBlockServer Method
Service Class See Also Send Feedback
Uns the block server.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void UnBlockServer(
    Guid server
)

Parameters

server
Type: System..::..Guid
The server.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ServiceData Class

ServiceData Class
Members See Also Send Feedback
Represents data used for exchanging information between CCService and servers.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServiceData : IExternalData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.LoadCombination..::..ServiceData

See Also

ServiceData Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ServiceData Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceData Members
ServiceData Class Constructors Methods Properties See Also Send Feedback

The ServiceData type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceData | Initializes a new instance of the ServiceData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Document | The active document.
Public property | Session | Gets the current session.

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ServiceData Constructor

ServiceData Constructor
ServiceData Class See Also Send Feedback
Initializes a new instance of the ServiceData class.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServiceData(
    Guid session,
    Document document
)

Parameters

session
Type: System..::..Guid
The session.
document
Type: Document
The document.

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ServiceData Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceData Methods
ServiceData Class See Also Send Feedback

The ServiceData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


ServiceData Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceData Properties
ServiceData Class See Also Send Feedback

The ServiceData type exposes the following members.

Properties

 | Name | Description
Public property | Document | The active document.
Public property | Session | Gets the current session.

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Document Property

ServiceData..::..Document Property
ServiceData Class See Also Send Feedback
The active document.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document Document { get; set; }

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Session Property

ServiceData..::..Session Property
ServiceData Class See Also Send Feedback
Gets the current session.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid Session { get; private set; }

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace


Autodesk.Revit.DB.CodeChecking.Storage Namespace

Autodesk.Revit.DB.CodeChecking.Storage Namespace
Send Feedback

Classes

 | Class | Description
Public class | CalculationParam | Represents calculation parameters.
Public class | CalculationParamsManager | Represents the manager for calculation parameters.
Public class | Label | Represents label.
Public class | LabelsManager | Represent the manager of labels.
Public class | Result | Represents result.
Public class | ResultBuilderManager | Manages ResultBuilder and common access to it
Public class | ResultsManager | Represents the result manager
Public class | ResultStatus | Represents result status
Public class | ResultStatusList | Represents result status list
Public class | ResultStatusMessage | Represent ResultStatus message
Public class | ResultStatusMessageItem | Represents the single item of ResultStatusMessage
Public class | ServerCalculationParam | Represents calculations parameters for specified server
Public class | ServerData | Represents server data
Public class | ServerLabel | Represents label for specific server.
Public class | ServerPackage | Represents the server package
Public class | ServerResult | Represents result for specific server
Public class | ServerStorage | Base class for all servers data
Public class | Storage<(Of <(<'T>)>)> | Base class for all storage classes.
Public class | StorageDocument | Represents the storage document which manages data for one particular Revit document.
Public class | StorageManager | Base class for all storage managers
Public class | StorageService | Represents the storage service.

Interfaces

 | Interface | Description
Public interface | IStorage | Base interface for all storage classes

Enumerations

 | Enumeration | Description
Public enumeration | Status | Represents status of result


CalculationParam Class

CalculationParam Class
Members See Also Send Feedback
Represents calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CalculationParam : Storage<ServerCalculationParam>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..Storage <(Of <(<' ServerCalculationParam >)>)>
Autodesk.Revit.DB.CodeChecking.Storage..::..CalculationParam

See Also

CalculationParam Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParam Members

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam Members
CalculationParam Class Methods Fields Properties See Also Send Feedback

The CalculationParam type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputResultPackage | Gets the input package for specific code.
Public method | GetInputResultPackageId | Gets the input package for specific code.
Public method | GetLoadCasesAndCombinations | Gets load combinations.
Public method | GetOutputResultPackage(Guid) | Gets the output package.
Public method | GetOutputResultPackage(Guid, Guid, Boolean) | Gets the output package.
Public method | GetOutputResultPackageBuilder(Guid) |
Public method | GetOutputResultPackageBuilder(Guid, Guid) | Gets the output package builder.
Public method | GetServerPackage(Guid, Boolean) |
Public method | GetServerPackage(Guid, Guid, Boolean) |
Public method | GetServerStorageSchemaBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetServerStorageServerBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetInputResultPackage | Sets the input package.
Public method | SetLoadCasesAndCombinations | Sets load combinations.
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerPackage |
Public method | SetServerStorage | Adds the server data to storage. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
CommonPackage | Common package id

Properties

 | Name | Description
Public property | Document | Gets or sets the document. (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ElementId | Gets or sets the Element (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ServersStorages | Gets or sets list of entities (for different servers) (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParam Fields

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam Fields
CalculationParam Class See Also Send Feedback

The CalculationParam type exposes the following members.

Fields

Name | Description
CommonPackage | Common package id

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CommonPackage Field

CalculationParam..::..CommonPackage Field
CalculationParam Class See Also Send Feedback
Common package id

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string CommonPackage

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParam Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam Methods
CalculationParam Class See Also Send Feedback

The CalculationParam type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputResultPackage | Gets the input package for specific code.
Public method | GetInputResultPackageId | Gets the input package for specific code.
Public method | GetLoadCasesAndCombinations | Gets load combinations.
Public method | GetOutputResultPackage(Guid) | Gets the output package.
Public method | GetOutputResultPackage(Guid, Guid, Boolean) | Gets the output package.
Public method | GetOutputResultPackageBuilder(Guid) |
Public method | GetOutputResultPackageBuilder(Guid, Guid) | Gets the output package builder.
Public method | GetServerPackage(Guid, Boolean) |
Public method | GetServerPackage(Guid, Guid, Boolean) |
Public method | GetServerStorageSchemaBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetServerStorageServerBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetInputResultPackage | Sets the input package.
Public method | SetLoadCasesAndCombinations | Sets load combinations.
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerPackage |
Public method | SetServerStorage | Adds the server data to storage. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetEntity Method

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam..::..GetEntity Method
CalculationParam Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

CalculationParam Class
CalculationParam Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetInputResultPackage Method

CalculationParam..::..GetInputResultPackage Method
CalculationParam Class See Also Send Feedback
Gets the input package for specific code.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackage GetInputResultPackage(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The server id.

Return Value

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetInputResultPackageId Method

CalculationParam..::..GetInputResultPackageId Method
CalculationParam Class See Also Send Feedback
Gets the input package for specific code.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid GetInputResultPackageId(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The server id.

Return Value

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetLoadCasesAndCombinations Method

CalculationParam..::..GetLoadCasesAndCombinations Method
CalculationParam Class See Also Send Feedback
Gets load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ElementId> GetLoadCasesAndCombinations(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The server id.

Return Value

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetOutputResultPackage Method

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam..::..GetOutputResultPackage Method
CalculationParam Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetOutputResultPackage(Guid) | Gets the output package.
Public method | GetOutputResultPackage(Guid, Guid, Boolean) | Gets the output package.

See Also

CalculationParam Class
CalculationParam Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetOutputResultPackage Method (Guid)

CalculationParam..::..GetOutputResultPackage Method (Guid)
CalculationParam Class See Also Send Feedback
Gets the output package.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackage GetOutputResultPackage(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The server id.

Return Value

See Also

CalculationParam Class
GetOutputResultPackage Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetOutputResultPackage Method (Guid, Guid, Boolean)

CalculationParam..::..GetOutputResultPackage Method (Guid, Guid, Boolean)
CalculationParam Class See Also Send Feedback
Gets the output package.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackage GetOutputResultPackage(
    Guid serverId,
    Guid analysisPackage,
    bool setAvailableState
)

Parameters

serverId
Type: System..::..Guid
The server id.
analysisPackage
Type: System..::..Guid
The analysis package.
setAvailableState
Type: System..::..Boolean
if set to true set available state.

Return Value

See Also

CalculationParam Class
GetOutputResultPackage Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetOutputResultPackageBuilder Method

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam..::..GetOutputResultPackageBuilder Method
CalculationParam Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetOutputResultPackageBuilder(Guid) |
Public method | GetOutputResultPackageBuilder(Guid, Guid) | Gets the output package builder.

See Also

CalculationParam Class
CalculationParam Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetOutputResultPackageBuilder Method (Guid)

CalculationParam..::..GetOutputResultPackageBuilder Method (Guid)
CalculationParam Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackageBuilder GetOutputResultPackageBuilder(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid

See Also

CalculationParam Class
GetOutputResultPackageBuilder Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetOutputResultPackageBuilder Method (Guid, Guid)

CalculationParam..::..GetOutputResultPackageBuilder Method (Guid, Guid)
CalculationParam Class See Also Send Feedback
Gets the output package builder.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackageBuilder GetOutputResultPackageBuilder(
    Guid serverId,
    Guid analysisPackage
)

Parameters

serverId
Type: System..::..Guid
The server id.
analysisPackage
Type: System..::..Guid
The analysis package.

Return Value

See Also

CalculationParam Class
GetOutputResultPackageBuilder Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetServerPackage Method

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam..::..GetServerPackage Method
CalculationParam Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetServerPackage(Guid, Boolean) |
Public method | GetServerPackage(Guid, Guid, Boolean) |

See Also

CalculationParam Class
CalculationParam Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetServerPackage Method (Guid, Boolean)

CalculationParam..::..GetServerPackage Method (Guid, Boolean)
CalculationParam Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerPackage GetServerPackage(
    Guid serverId,
    bool createIfNotExist
)

Parameters

serverId
Type: System..::..Guid
createIfNotExist
Type: System..::..Boolean

See Also

CalculationParam Class
GetServerPackage Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetServerPackage Method (Guid, Guid, Boolean)

CalculationParam..::..GetServerPackage Method (Guid, Guid, Boolean)
CalculationParam Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerPackage GetServerPackage(
    Guid serverId,
    Guid analysisPackage,
    bool createIfNotExist
)

Parameters

serverId
Type: System..::..Guid
analysisPackage
Type: System..::..Guid
createIfNotExist
Type: System..::..Boolean

See Also

CalculationParam Class
GetServerPackage Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Replace Method

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam..::..Replace Method
CalculationParam Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

CalculationParam Class
CalculationParam Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetEntity Method

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam..::..SetEntity Method
CalculationParam Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

CalculationParam Class
CalculationParam Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetInputResultPackage Method

CalculationParam..::..SetInputResultPackage Method
CalculationParam Class See Also Send Feedback
Sets the input package.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetInputResultPackage(
    Guid serverId,
    Guid package
)

Parameters

serverId
Type: System..::..Guid
The server id.
package
Type: System..::..Guid
The package.

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetLoadCasesAndCombinations Method

CalculationParam..::..SetLoadCasesAndCombinations Method
CalculationParam Class See Also Send Feedback
Sets load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetLoadCasesAndCombinations(
    Guid serverId,
    List<ElementId> list
)

Parameters

serverId
Type: System..::..Guid
The server id.
list
Type: System.Collections.Generic..::..List <(Of <(<'ElementId>)>)>
The list.

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetServerPackage Method

CalculationParam..::..SetServerPackage Method
CalculationParam Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetServerPackage(
    ServerPackage package,
    Guid serverId,
    bool updateRB
)

Parameters

package
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..ServerPackage
serverId
Type: System..::..Guid
updateRB
Type: System..::..Boolean

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParam Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam Properties
CalculationParam Class See Also Send Feedback

The CalculationParam type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets or sets the document. (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ElementId | Gets or sets the Element (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ServersStorages | Gets or sets list of entities (for different servers) (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParamsManager Class

CalculationParamsManager Class
Members See Also Send Feedback
Represents the manager for calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CalculationParamsManager : StorageManager

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Storage..::..StorageManager
Autodesk.Revit.DB.CodeChecking.Storage..::..CalculationParamsManager

See Also

CalculationParamsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParamsManager Members

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParamsManager Members
CalculationParamsManager Class Constructors Methods Properties See Also Send Feedback

The CalculationParamsManager type exposes the following members.

Constructors

 | Name | Description
Public method | CalculationParamsManager | Initializes a new instance of the CalculationParamsManager class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServersForSelection |
Public method | GetActiveServersIds |
Public method | GetCodesWithNotSetCombinations |
Public method | GetCodesWithNotSetInputPackages |
Public method | GetDefault |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetServersIds |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnSynchronized | (Overrides StorageManagerOnSynchronized(DocumentSynchronizedWithCentralEventArgs).)
Public method | OnSynchronizing | (Overrides StorageManagerOnSynchronizing(DocumentSynchronizingWithCentralEventArgs).)
Public method | SetActiveServers |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

Properties

 | Name | Description
Public property | CalculationParams | Returns current calculation parameters.
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParamsManager Constructor

CalculationParamsManager Constructor
CalculationParamsManager Class See Also Send Feedback
Initializes a new instance of the CalculationParamsManager class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CalculationParamsManager(
    StorageDocument storageDoc,
    bool checkDocument
)

Parameters

storageDoc
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..StorageDocument
The storage doc.
checkDocument
Type: System..::..Boolean
if set to true document will be validated.

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParamsManager Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParamsManager Methods
CalculationParamsManager Class See Also Send Feedback

The CalculationParamsManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServersForSelection |
Public method | GetActiveServersIds |
Public method | GetCodesWithNotSetCombinations |
Public method | GetCodesWithNotSetInputPackages |
Public method | GetDefault |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetServersIds |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnSynchronized | (Overrides StorageManagerOnSynchronized(DocumentSynchronizedWithCentralEventArgs).)
Public method | OnSynchronizing | (Overrides StorageManagerOnSynchronizing(DocumentSynchronizingWithCentralEventArgs).)
Public method | SetActiveServers |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetActiveServersForSelection Method

CalculationParamsManager..::..GetActiveServersForSelection Method
CalculationParamsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<ICodeCheckingServer> GetActiveServersForSelection(
    List<Element> elements
)

Parameters

elements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetActiveServersIds Method

CalculationParamsManager..::..GetActiveServersIds Method
CalculationParamsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<Guid> GetActiveServersIds()

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetCodesWithNotSetCombinations Method

CalculationParamsManager..::..GetCodesWithNotSetCombinations Method
CalculationParamsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Guid> GetCodesWithNotSetCombinations(
    IList<ICodeCheckingServer> servers
)

Parameters

servers
Type: System.Collections.Generic..::..IList <(Of <(<' ICodeCheckingServer >)>)>

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetCodesWithNotSetInputPackages Method

CalculationParamsManager..::..GetCodesWithNotSetInputPackages Method
CalculationParamsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Guid> GetCodesWithNotSetInputPackages(
    IList<ICodeCheckingServer> servers
)

Parameters

servers
Type: System.Collections.Generic..::..IList <(Of <(<' ICodeCheckingServer >)>)>

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetDefault Method

CalculationParamsManager..::..GetDefault Method
CalculationParamsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Entity GetDefault(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetServersIds Method

CalculationParamsManager..::..GetServersIds Method
CalculationParamsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<Guid> GetServersIds()

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


OnSynchronized Method

CalculationParamsManager..::..OnSynchronized Method
CalculationParamsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override void OnSynchronized(
    DocumentSynchronizedWithCentralEventArgs e
)

Parameters

e
Type: DocumentSynchronizedWithCentralEventArgs

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


OnSynchronizing Method

CalculationParamsManager..::..OnSynchronizing Method
CalculationParamsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override void OnSynchronizing(
    DocumentSynchronizingWithCentralEventArgs e
)

Parameters

e
Type: DocumentSynchronizingWithCentralEventArgs

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetActiveServers Method

CalculationParamsManager..::..SetActiveServers Method
CalculationParamsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetActiveServers(
    IList<Guid> serverIds,
    bool save
)

Parameters

serverIds
Type: System.Collections.Generic..::..IList <(Of <(<' Guid >)>)>
save
Type: System..::..Boolean

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ValidateCategory Method

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParamsManager..::..ValidateCategory Method
CalculationParamsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

See Also

CalculationParamsManager Class
CalculationParamsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParamsManager Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParamsManager Properties
CalculationParamsManager Class See Also Send Feedback

The CalculationParamsManager type exposes the following members.

Properties

 | Name | Description
Public property | CalculationParams | Returns current calculation parameters.
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParams Property

CalculationParamsManager..::..CalculationParams Property
CalculationParamsManager Class See Also Send Feedback
Returns current calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CalculationParam CalculationParams { get; }

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IStorage Interface

IStorage Interface
Members See Also Send Feedback
Base interface for all storage classes

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IStorage

See Also

IStorage Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IStorage Members

[image]

Structural Analysis and Code Checking API Reference Guide
IStorage Members
IStorage Interface Methods See Also Send Feedback

The IStorage type exposes the following members.

Methods

 | Name | Description
Public method | GetEntites | Gets entites.
Public method | GetEntity | Gets the entity of specified id.

See Also

IStorage Interface
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IStorage Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IStorage Methods
IStorage Interface See Also Send Feedback

The IStorage type exposes the following members.

Methods

 | Name | Description
Public method | GetEntites | Gets entites.
Public method | GetEntity | Gets the entity of specified id.

See Also

IStorage Interface
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetEntites Method

IStorage..::..GetEntites Method
IStorage Interface See Also Send Feedback
Gets entites.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
List<Entity> GetEntites()

Return Value

See Also

IStorage Interface
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetEntity Method

IStorage..::..GetEntity Method
IStorage Interface See Also Send Feedback
Gets the entity of specified id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Entity GetEntity(
    Guid schemaId
)

Parameters

schemaId
Type: System..::..Guid
The schema id.

Return Value

See Also

IStorage Interface
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Label Class

Label Class
Members See Also Send Feedback
Represents label.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Label : Storage<ServerLabel>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..Storage <(Of <(<' ServerLabel >)>)>
Autodesk.Revit.DB.CodeChecking.Storage..::..Label

See Also

Label Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Label Members

[image]

Structural Analysis and Code Checking API Reference Guide
Label Members
Label Class Constructors Methods Properties See Also Send Feedback

The Label type exposes the following members.

Constructors

 | Name | Description
Public method | Label | Initializes a new instance of the Label class.

Methods

 | Name | Description
Public method | Clone()()()() | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Clone(Boolean) | Duplicates current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServerStorageSchemaBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetServerStorageServerBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Overrides SchemaClass..::..Load(Element).)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets particular entity for specific server of input ID. (Overrides Storage<(Of <(<'T>)>)>..::..SetEntity(Entity, Guid).)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerStorage | Adds the server data to storage. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | Document | Gets or sets the document. (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ElementId | Gets or sets the Element (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | Id | The id of the label.
Public property | Material | Gets or sets the material.
Public property | Modified | Gets or sets a value indicating whether this Label was modified.
Public property | Name | The name of the label.
Public property | ServersStorages | Gets or sets list of entities (for different servers) (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Label Constructor

Label Constructor
Label Class See Also Send Feedback
Initializes a new instance of the Label class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Label()

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Label Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Label Methods
Label Class See Also Send Feedback

The Label type exposes the following members.

Methods

 | Name | Description
Public method | Clone()()()() | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Clone(Boolean) | Duplicates current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServerStorageSchemaBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetServerStorageServerBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Overrides SchemaClass..::..Load(Element).)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets particular entity for specific server of input ID. (Overrides Storage<(Of <(<'T>)>)>..::..SetEntity(Entity, Guid).)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerStorage | Adds the server data to storage. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Clone Method

[image]

Structural Analysis and Code Checking API Reference Guide
Label..::..Clone Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Clone(Boolean) | Duplicates current instance.

See Also

Label Class
Label Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Clone Method (Boolean)

Label..::..Clone Method (Boolean)
Label Class See Also Send Feedback
Duplicates current instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Label Clone(
    bool newId
)

Parameters

newId
Type: System..::..Boolean
Indicates whether new ID should be generated.

Return Value

The copy of current instance.

See Also

Label Class
Clone Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetEntity Method

[image]

Structural Analysis and Code Checking API Reference Guide
Label..::..GetEntity Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

Label Class
Label Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Load Method

Label..::..Load Method
Label Class See Also Send Feedback
Loads the specified element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override bool Load(
    Element element
)

Parameters

element
Type: Element
The element.

Return Value

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Replace Method

[image]

Structural Analysis and Code Checking API Reference Guide
Label..::..Replace Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

Label Class
Label Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetEntity Method

[image]

Structural Analysis and Code Checking API Reference Guide
Label..::..SetEntity Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetEntity(Entity, Guid) | Sets particular entity for specific server of input ID. (Overrides Storage<(Of <(<'T>)>)>..::..SetEntity(Entity, Guid).)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

Label Class
Label Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetEntity Method (, Guid)

Label..::..SetEntity Method (, Guid)
Label Class See Also Send Feedback
Sets particular entity for specific server of input ID.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override ServerLabel SetEntity(
    Entity entity,
    Guid serverId
)

Parameters

entity
Type: Entity
The entity.
serverId
Type: System..::..Guid
The server id.

Return Value

See Also

Label Class
SetEntity Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Label Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Label Properties
Label Class See Also Send Feedback

The Label type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | Document | Gets or sets the document. (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ElementId | Gets or sets the Element (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | Id | The id of the label.
Public property | Material | Gets or sets the material.
Public property | Modified | Gets or sets a value indicating whether this Label was modified.
Public property | Name | The name of the label.
Public property | ServersStorages | Gets or sets list of entities (for different servers) (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Category Property

Label..::..Category Property
Label Class See Also Send Feedback
Gets or sets the category.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public BuiltInCategory Category { get; set; }

Field Value

The category.

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Id Property

Label..::..Id Property
Label Class See Also Send Feedback
The id of the label.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid Id { get; set; }

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Material Property

Label..::..Material Property
Label Class See Also Send Feedback
Gets or sets the material.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public StructuralAssetClass Material { get; set; }

Field Value

The material.

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Modified Property

Label..::..Modified Property
Label Class See Also Send Feedback
Gets or sets a value indicating whether this Label was modified.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Modified { get; set; }

Field Value

true if modified; otherwise, false.

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Name Property

Label..::..Name Property
Label Class See Also Send Feedback
The name of the label.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


LabelsManager Class

LabelsManager Class
Members See Also Send Feedback
Represent the manager of labels.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LabelsManager : StorageManager

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Storage..::..StorageManager
Autodesk.Revit.DB.CodeChecking.Storage..::..LabelsManager

See Also

LabelsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


LabelsManager Members

[image]

Structural Analysis and Code Checking API Reference Guide
LabelsManager Members
LabelsManager Class Constructors Methods Properties See Also Send Feedback

The LabelsManager type exposes the following members.

Constructors

 | Name | Description
Public method | LabelsManager | Initializes a new instance of the LabelsManager class.

Methods

 | Name | Description
Public method | CreateNewLabel | Creates the new label.
Public method | DeleteLabel | Deletes the label.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategories |
Public method | GetCategoryOfSelection |
Public method | GetDefaultEntity |
Public method | GetDefaultLabel |
Public method | GetElementsOfLabel | Gets elements from input list with specific label assigned.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabel(Element) | Returns label set to particular element.
Public method | GetLabel(Guid) | Returns label set to particular element.
Public method | GetLabel(String) | Returns label set to particular element.
Public method | GetLabels |
Public method | GetMaterial |
Public method | GetMaterials |
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueLabelName | Gets the unique name for label.
Public method | IsActive |
Public method | OnSynchronized | (Overrides StorageManagerOnSynchronized(DocumentSynchronizedWithCentralEventArgs).)
Public method | RenameLabel | Renames the label.
Public method | SetLabel | Sets label to particular element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)
Public method | ValidateLabel | Validates the label and changes it to null if material doesn't fit.

Properties

 | Name | Description
Public property | Labels | Returns the list of labels.
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


LabelsManager Constructor

LabelsManager Constructor
LabelsManager Class See Also Send Feedback
Initializes a new instance of the LabelsManager class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LabelsManager(
    StorageDocument storageDoc
)

Parameters

storageDoc
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..StorageDocument
The storage document.

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


LabelsManager Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LabelsManager Methods
LabelsManager Class See Also Send Feedback

The LabelsManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateNewLabel | Creates the new label.
Public method | DeleteLabel | Deletes the label.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategories |
Public method | GetCategoryOfSelection |
Public method | GetDefaultEntity |
Public method | GetDefaultLabel |
Public method | GetElementsOfLabel | Gets elements from input list with specific label assigned.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabel(Element) | Returns label set to particular element.
Public method | GetLabel(Guid) | Returns label set to particular element.
Public method | GetLabel(String) | Returns label set to particular element.
Public method | GetLabels |
Public method | GetMaterial |
Public method | GetMaterials |
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueLabelName | Gets the unique name for label.
Public method | IsActive |
Public method | OnSynchronized | (Overrides StorageManagerOnSynchronized(DocumentSynchronizedWithCentralEventArgs).)
Public method | RenameLabel | Renames the label.
Public method | SetLabel | Sets label to particular element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)
Public method | ValidateLabel | Validates the label and changes it to null if material doesn't fit.

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CreateNewLabel Method

LabelsManager..::..CreateNewLabel Method
LabelsManager Class See Also Send Feedback
Creates the new label.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Label CreateNewLabel(
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

material
Type: StructuralAssetClass
The material.
category
Type: BuiltInCategory
The category.

Return Value

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


DeleteLabel Method

LabelsManager..::..DeleteLabel Method
LabelsManager Class See Also Send Feedback
Deletes the label.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void DeleteLabel(
    Guid id
)

Parameters

id
Type: System..::..Guid
The label id.

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetCategories Method

LabelsManager..::..GetCategories Method
LabelsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<BuiltInCategory> GetCategories()

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetCategoryOfSelection Method

LabelsManager..::..GetCategoryOfSelection Method
LabelsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public BuiltInCategory GetCategoryOfSelection(
    List<Element> selElements
)

Parameters

selElements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetDefaultEntity Method

LabelsManager..::..GetDefaultEntity Method
LabelsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Entity GetDefaultEntity(
    Guid serverId,
    StructuralAssetClass material,
    BuiltInCategory category
)

Parameters

serverId
Type: System..::..Guid
material
Type: StructuralAssetClass
category
Type: BuiltInCategory

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetDefaultLabel Method

LabelsManager..::..GetDefaultLabel Method
LabelsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Label GetDefaultLabel(
    StructuralAssetClass material,
    BuiltInCategory category,
    List<Label> existingLabels,
    bool setName
)

Parameters

material
Type: StructuralAssetClass
category
Type: BuiltInCategory
existingLabels
Type: System.Collections.Generic..::..List <(Of <(<' Label >)>)>
setName
Type: System..::..Boolean

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetElementsOfLabel Method

LabelsManager..::..GetElementsOfLabel Method
LabelsManager Class See Also Send Feedback
Gets elements from input list with specific label assigned.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Element> GetElementsOfLabel(
    string label,
    List<Element> elements
)

Parameters

label
Type: System..::..String
The label name.
elements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>
The list of elements.

Return Value

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetLabel Method

[image]

Structural Analysis and Code Checking API Reference Guide
LabelsManager..::..GetLabel Method
LabelsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLabel(Element) | Returns label set to particular element.
Public method | GetLabel(Guid) | Returns label set to particular element.
Public method | GetLabel(String) | Returns label set to particular element.

See Also

LabelsManager Class
LabelsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetLabel Method ()

LabelsManager..::..GetLabel Method ()
LabelsManager Class See Also Send Feedback
Returns label set to particular element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Label GetLabel(
    Element element
)

Parameters

element
Type: Element
The element

Return Value

The label.

See Also

LabelsManager Class
GetLabel Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetLabel Method (Guid)

LabelsManager..::..GetLabel Method (Guid)
LabelsManager Class See Also Send Feedback
Returns label set to particular element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Label GetLabel(
    Guid id
)

Parameters

id
Type: System..::..Guid
The id.

Return Value

The label.

See Also

LabelsManager Class
GetLabel Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetLabel Method (String)

LabelsManager..::..GetLabel Method (String)
LabelsManager Class See Also Send Feedback
Returns label set to particular element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Label GetLabel(
    string name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The label.

See Also

LabelsManager Class
GetLabel Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetLabels Method

LabelsManager..::..GetLabels Method
LabelsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<string> GetLabels(
    List<Element> elements
)

Parameters

elements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetMaterial Method

LabelsManager..::..GetMaterial Method
LabelsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public StructuralAssetClass GetMaterial(
    List<Element> selElements
)

Parameters

selElements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetMaterials Method

LabelsManager..::..GetMaterials Method
LabelsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<StructuralAssetClass> GetMaterials()

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetUniqueLabelName Method

LabelsManager..::..GetUniqueLabelName Method
LabelsManager Class See Also Send Feedback
Gets the unique name for label.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetUniqueLabelName(
    List<Label> existingLabels,
    string startName
)

Parameters

existingLabels
Type: System.Collections.Generic..::..List <(Of <(<' Label >)>)>
The existing labels.
startName
Type: System..::..String
The start name.

Return Value

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IsActive Method

LabelsManager..::..IsActive Method
LabelsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsActive(
    Guid storageSchema
)

Parameters

storageSchema
Type: System..::..Guid

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


OnSynchronized Method

LabelsManager..::..OnSynchronized Method
LabelsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override void OnSynchronized(
    DocumentSynchronizedWithCentralEventArgs e
)

Parameters

e
Type: DocumentSynchronizedWithCentralEventArgs

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


RenameLabel Method

LabelsManager..::..RenameLabel Method
LabelsManager Class See Also Send Feedback
Renames the label.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void RenameLabel(
    Guid id,
    string name
)

Parameters

id
Type: System..::..Guid
The label id.
name
Type: System..::..String
The new name.

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetLabel Method

LabelsManager..::..SetLabel Method
LabelsManager Class See Also Send Feedback
Sets label to particular element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool SetLabel(
    Element element,
    Label label
)

Parameters

element
Type: Element
The element.
label
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..Label
The label.

Return Value

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ValidateCategory Method

[image]

Structural Analysis and Code Checking API Reference Guide
LabelsManager..::..ValidateCategory Method
LabelsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

See Also

LabelsManager Class
LabelsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ValidateLabel Method

LabelsManager..::..ValidateLabel Method
LabelsManager Class See Also Send Feedback
Validates the label and changes it to null if material doesn't fit.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void ValidateLabel(
    Element element
)

Parameters

element
Type: Element
The element.

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


LabelsManager Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LabelsManager Properties
LabelsManager Class See Also Send Feedback

The LabelsManager type exposes the following members.

Properties

 | Name | Description
Public property | Labels | Returns the list of labels.
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Labels Property

LabelsManager..::..Labels Property
LabelsManager Class See Also Send Feedback
Returns the list of labels.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Label> Labels { get; }

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Result Class

Result Class
Members See Also Send Feedback
Represents result.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Result : Storage<ServerResult>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..Storage <(Of <(<' ServerResult >)>)>
Autodesk.Revit.DB.CodeChecking.Storage..::..Result

See Also

Result Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Result Members

[image]

Structural Analysis and Code Checking API Reference Guide
Result Members
Result Class Methods Properties See Also Send Feedback

The Result type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServerStorageSchemaBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetServerStorageServerBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | IsUpToDate | Returns whether up-to-date flag is set to true for specific server.
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerStorage | Adds the server data to storage. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Document | Gets or sets the document. (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ElementId | Gets or sets the Element (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | Package | The current package.
Public property | ServersStorages | Gets or sets list of entities (for different servers) (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

Result Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Result Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Result Methods
Result Class See Also Send Feedback

The Result type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServerStorageSchemaBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetServerStorageServerBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | IsUpToDate | Returns whether up-to-date flag is set to true for specific server.
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerStorage | Adds the server data to storage. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Result Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetEntity Method

[image]

Structural Analysis and Code Checking API Reference Guide
Result..::..GetEntity Method
Result Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

Result Class
Result Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IsUpToDate Method

Result..::..IsUpToDate Method
Result Class See Also Send Feedback
Returns whether up-to-date flag is set to true for specific server.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsUpToDate(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The id of server.

Return Value

The up-to-date flag

See Also

Result Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Replace Method

[image]

Structural Analysis and Code Checking API Reference Guide
Result..::..Replace Method
Result Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

Result Class
Result Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetEntity Method

[image]

Structural Analysis and Code Checking API Reference Guide
Result..::..SetEntity Method
Result Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

Result Class
Result Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Result Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Result Properties
Result Class See Also Send Feedback

The Result type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets or sets the document. (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ElementId | Gets or sets the Element (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | Package | The current package.
Public property | ServersStorages | Gets or sets list of entities (for different servers) (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

Result Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Package Property

Result..::..Package Property
Result Class See Also Send Feedback
The current package.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid Package { get; set; }

See Also

Result Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultBuilderManager Class

ResultBuilderManager Class
Members See Also Send Feedback
Manages ResultBuilder and common access to it

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultBuilderManager : StorageManager

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Storage..::..StorageManager
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultBuilderManager

See Also

ResultBuilderManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultBuilderManager Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultBuilderManager Members
ResultBuilderManager Class Constructors Methods Properties See Also Send Feedback

The ResultBuilderManager type exposes the following members.

Constructors

 | Name | Description
Public method | ResultBuilderManager | Initializes a new instance of the ResultBuilderManager class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPackageUpToDate | Indicates whether package is up-to-date.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateAnalysisName | Validates the name of the analysis.
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)
Public method | ValidatePackageData | Validates the package data.

Properties

 | Name | Description
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | ResultBuilderAccess | Gets the result builder access.
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

ResultBuilderManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultBuilderManager Constructor

ResultBuilderManager Constructor
ResultBuilderManager Class See Also Send Feedback
Initializes a new instance of the ResultBuilderManager class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultBuilderManager(
    StorageDocument storageDoc
)

Parameters

storageDoc
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..StorageDocument
The storage doc.

See Also

ResultBuilderManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultBuilderManager Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultBuilderManager Methods
ResultBuilderManager Class See Also Send Feedback

The ResultBuilderManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPackageUpToDate | Indicates whether package is up-to-date.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateAnalysisName | Validates the name of the analysis.
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)
Public method | ValidatePackageData | Validates the package data.

See Also

ResultBuilderManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IsPackageUpToDate Method

ResultBuilderManager..::..IsPackageUpToDate Method
ResultBuilderManager Class See Also Send Feedback
Indicates whether package is up-to-date.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsPackageUpToDate(
    Guid package
)

Parameters

package
Type: System..::..Guid
The package.

Return Value

Whether up-to-date.

See Also

ResultBuilderManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ValidateAnalysisName Method

ResultBuilderManager..::..ValidateAnalysisName Method
ResultBuilderManager Class See Also Send Feedback
Validates the name of the analysis.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string ValidateAnalysisName(
    string model,
    string analysis
)

Parameters

model
Type: System..::..String
The model.
analysis
Type: System..::..String
The analysis.

Return Value

See Also

ResultBuilderManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ValidateCategory Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultBuilderManager..::..ValidateCategory Method
ResultBuilderManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

See Also

ResultBuilderManager Class
ResultBuilderManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ValidatePackageData Method

ResultBuilderManager..::..ValidatePackageData Method
ResultBuilderManager Class See Also Send Feedback
Validates the package data.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool ValidatePackageData(
    string model,
    string analysis
)

Parameters

model
Type: System..::..String
The model.
analysis
Type: System..::..String
The analysis.

Return Value

See Also

ResultBuilderManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultBuilderManager Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ResultBuilderManager Properties
ResultBuilderManager Class See Also Send Feedback

The ResultBuilderManager type exposes the following members.

Properties

 | Name | Description
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | ResultBuilderAccess | Gets the result builder access.
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

ResultBuilderManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultBuilderAccess Property

ResultBuilderManager..::..ResultBuilderAccess Property
ResultBuilderManager Class See Also Send Feedback
Gets the result builder access.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsAccess ResultBuilderAccess { get; }

See Also

ResultBuilderManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultsManager Class

ResultsManager Class
Members See Also Send Feedback
Represents the result manager

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultsManager : StorageManager

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Storage..::..StorageManager
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultsManager

See Also

ResultsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultsManager Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsManager Members
ResultsManager Class Constructors Methods Properties See Also Send Feedback

The ResultsManager type exposes the following members.

Constructors

 | Name | Description
Public method | ResultsManager | Initializes a new instance of the ResultsManager class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResult(Element) | Gets results of specific element and package.
Public method | GetResult(Element, Guid) | Gets results of specific element and package.
Public method | GetResultStatus(Element, Guid) | Gets the result status for specific element.
Public method | GetResultStatus(Element, Guid, Guid) | Gets the result status for specific element.
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetServerResult(Element, Guid) | Gets the server result.
Public method | GetServerResult(Element, Guid, Guid) | Gets the server result.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OutDateResults | Outdate results for specific server in particular element.
Public method | SetResult(Entity, Element, ResultStatus, Boolean) | Sets result to specific element.
Public method | SetResult(Entity, Element, Guid, ResultStatus, Boolean) | Sets result to specific element.
Public method | SetResultStatus |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

Properties

 | Name | Description
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

ResultsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultsManager Constructor

ResultsManager Constructor
ResultsManager Class See Also Send Feedback
Initializes a new instance of the ResultsManager class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsManager(
    StorageDocument storageDoc
)

Parameters

storageDoc
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..StorageDocument
The storage document.

See Also

ResultsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultsManager Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsManager Methods
ResultsManager Class See Also Send Feedback

The ResultsManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResult(Element) | Gets results of specific element and package.
Public method | GetResult(Element, Guid) | Gets results of specific element and package.
Public method | GetResultStatus(Element, Guid) | Gets the result status for specific element.
Public method | GetResultStatus(Element, Guid, Guid) | Gets the result status for specific element.
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetServerResult(Element, Guid) | Gets the server result.
Public method | GetServerResult(Element, Guid, Guid) | Gets the server result.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OutDateResults | Outdate results for specific server in particular element.
Public method | SetResult(Entity, Element, ResultStatus, Boolean) | Sets result to specific element.
Public method | SetResult(Entity, Element, Guid, ResultStatus, Boolean) | Sets result to specific element.
Public method | SetResultStatus |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

See Also

ResultsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetResult Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsManager..::..GetResult Method
ResultsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetResult(Element) | Gets results of specific element and package.
Public method | GetResult(Element, Guid) | Gets results of specific element and package.

See Also

ResultsManager Class
ResultsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetResult Method ()

ResultsManager..::..GetResult Method ()
ResultsManager Class See Also Send Feedback
Gets results of specific element and package.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Result GetResult(
    Element element
)

Parameters

element
Type: Element
The element.

Return Value

The result.

See Also

ResultsManager Class
GetResult Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetResult Method (, Guid)

ResultsManager..::..GetResult Method (, Guid)
ResultsManager Class See Also Send Feedback
Gets results of specific element and package.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Result GetResult(
    Element element,
    Guid package
)

Parameters

element
Type: Element
The element.
package
Type: System..::..Guid
The package.

Return Value

The result.

See Also

ResultsManager Class
GetResult Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetResultStatus Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsManager..::..GetResultStatus Method
ResultsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetResultStatus(Element, Guid) | Gets the result status for specific element.
Public method | GetResultStatus(Element, Guid, Guid) | Gets the result status for specific element.

See Also

ResultsManager Class
ResultsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetResultStatus Method (, Guid)

ResultsManager..::..GetResultStatus Method (, Guid)
ResultsManager Class See Also Send Feedback
Gets the result status for specific element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatus GetResultStatus(
    Element element,
    Guid serverId
)

Parameters

element
Type: Element
The element.
serverId
Type: System..::..Guid
The server id.

Return Value

See Also

ResultsManager Class
GetResultStatus Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetResultStatus Method (, Guid, Guid)

ResultsManager..::..GetResultStatus Method (, Guid, Guid)
ResultsManager Class See Also Send Feedback
Gets the result status for specific element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatus GetResultStatus(
    Element element,
    Guid inputPackage,
    Guid serverId
)

Parameters

element
Type: Element
The element.
inputPackage
Type: System..::..Guid
The input package.
serverId
Type: System..::..Guid
The server id.

Return Value

See Also

ResultsManager Class
GetResultStatus Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetServerResult Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsManager..::..GetServerResult Method
ResultsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetServerResult(Element, Guid) | Gets the server result.
Public method | GetServerResult(Element, Guid, Guid) | Gets the server result.

See Also

ResultsManager Class
ResultsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetServerResult Method (, Guid)

ResultsManager..::..GetServerResult Method (, Guid)
ResultsManager Class See Also Send Feedback
Gets the server result.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerResult GetServerResult(
    Element element,
    Guid serverId
)

Parameters

element
Type: Element
The element.
serverId
Type: System..::..Guid
The server id.

Return Value

See Also

ResultsManager Class
GetServerResult Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetServerResult Method (, Guid, Guid)

ResultsManager..::..GetServerResult Method (, Guid, Guid)
ResultsManager Class See Also Send Feedback
Gets the server result.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerResult GetServerResult(
    Element element,
    Guid serverId,
    Guid package
)

Parameters

element
Type: Element
The element.
serverId
Type: System..::..Guid
The server id.
package
Type: System..::..Guid
The package.

Return Value

See Also

ResultsManager Class
GetServerResult Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


OutDateResults Method

ResultsManager..::..OutDateResults Method
ResultsManager Class See Also Send Feedback
Outdate results for specific server in particular element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void OutDateResults(
    Guid serverId,
    Element element
)

Parameters

serverId
Type: System..::..Guid
The id of the server.
element
Type: Element
The element.

See Also

ResultsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetResult Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsManager..::..SetResult Method
ResultsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetResult(Entity, Element, ResultStatus, Boolean) | Sets result to specific element.
Public method | SetResult(Entity, Element, Guid, ResultStatus, Boolean) | Sets result to specific element.

See Also

ResultsManager Class
ResultsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetResult Method (, , ResultStatus, Boolean)

ResultsManager..::..SetResult Method (, , ResultStatus, Boolean)
ResultsManager Class See Also Send Feedback
Sets result to specific element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetResult(
    Entity result,
    Element element,
    ResultStatus status,
    bool setLabel
)

Parameters

result
Type: Entity
The result.
element
Type: Element
The element.
status
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatus
The status.
setLabel
Type: System..::..Boolean
Indicates whether information about current label should be stored.

See Also

ResultsManager Class
SetResult Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetResult Method (, , Guid, ResultStatus, Boolean)

ResultsManager..::..SetResult Method (, , Guid, ResultStatus, Boolean)
ResultsManager Class See Also Send Feedback
Sets result to specific element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetResult(
    Entity result,
    Element element,
    Guid analysisPackage,
    ResultStatus status,
    bool setLabel
)

Parameters

result
Type: Entity
The result.
element
Type: Element
The element.
analysisPackage
Type: System..::..Guid
The package.
status
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatus
The status.
setLabel
Type: System..::..Boolean
Indicates whether information about current label should be stored.

See Also

ResultsManager Class
SetResult Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetResultStatus Method

ResultsManager..::..SetResultStatus Method
ResultsManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetResultStatus(
    Element element,
    ResultStatus status
)

Parameters

element
Type: Element
status
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatus

See Also

ResultsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ValidateCategory Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsManager..::..ValidateCategory Method
ResultsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

See Also

ResultsManager Class
ResultsManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultsManager Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsManager Properties
ResultsManager Class See Also Send Feedback

The ResultsManager type exposes the following members.

Properties

 | Name | Description
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

ResultsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatus Class

ResultStatus Class
Members See Also Send Feedback
Represents result status

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultStatus : SchemaClass

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatus

See Also

ResultStatus Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatus Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatus Members
ResultStatus Class Constructors Methods Properties See Also Send Feedback

The ResultStatus type exposes the following members.

Constructors

 | Name | Description
Public method | ResultStatus()()()() | Initializes a new instance of the ResultStatus class.
Public method | ResultStatus(Guid) | Initializes a new instance of the ResultStatus class.
Public method | ResultStatus(Guid, Guid) | Initializes a new instance of the ResultStatus class.

Methods

 | Name | Description
Public method | AddError(String, Boolean) | Adds the error.
Public method | AddError(ResultStatusMessage, Document, Boolean) | Adds the error.
Public method | AddInfo(String, Boolean) | Adds the info.
Public method | AddInfo(ResultStatusMessage, Document, Boolean) | Adds the info.
Public method | AddWarning(String, Boolean) | Adds the warning.
Public method | AddWarning(ResultStatusMessage, Document, Boolean) | Adds the warning.
Public method | Clear | Clears this instance.
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | IsError | Determines whether this instance is error.
Public method | IsOk | Determines whether this instance is ok.
Public method | IsWarning | Determines whether this instance is warning.
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetStatusRatioBased | Sets the status based on ratio.
Public method | SetStatusValueBased | Sets the status based on value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ErrorList | Gets or sets the error list.
Public property | InfoList | Gets or sets the info list.
Public property | Package | Gets or sets the package.
Public property | ServerId | Gets or sets the server id.
Public property | Status | Gets or sets the status.
Public property | WarningList | Gets or sets the warning list.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatus Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatus Constructor
ResultStatus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResultStatus()()()() | Initializes a new instance of the ResultStatus class.
Public method | ResultStatus(Guid) | Initializes a new instance of the ResultStatus class.
Public method | ResultStatus(Guid, Guid) | Initializes a new instance of the ResultStatus class.

See Also

ResultStatus Class
ResultStatus Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatus Constructor

ResultStatus Constructor
ResultStatus Class See Also Send Feedback
Initializes a new instance of the ResultStatus class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatus()

See Also

ResultStatus Class
ResultStatus Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatus Constructor (Guid)

ResultStatus Constructor (Guid)
ResultStatus Class See Also Send Feedback
Initializes a new instance of the ResultStatus class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatus(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The server id.

See Also

ResultStatus Class
ResultStatus Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatus Constructor (Guid, Guid)

ResultStatus Constructor (Guid, Guid)
ResultStatus Class See Also Send Feedback
Initializes a new instance of the ResultStatus class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatus(
    Guid serverId,
    Guid package
)

Parameters

serverId
Type: System..::..Guid
The server id.
package
Type: System..::..Guid
The package.

See Also

ResultStatus Class
ResultStatus Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatus Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatus Methods
ResultStatus Class See Also Send Feedback

The ResultStatus type exposes the following members.

Methods

 | Name | Description
Public method | AddError(String, Boolean) | Adds the error.
Public method | AddError(ResultStatusMessage, Document, Boolean) | Adds the error.
Public method | AddInfo(String, Boolean) | Adds the info.
Public method | AddInfo(ResultStatusMessage, Document, Boolean) | Adds the info.
Public method | AddWarning(String, Boolean) | Adds the warning.
Public method | AddWarning(ResultStatusMessage, Document, Boolean) | Adds the warning.
Public method | Clear | Clears this instance.
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | IsError | Determines whether this instance is error.
Public method | IsOk | Determines whether this instance is ok.
Public method | IsWarning | Determines whether this instance is warning.
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetStatusRatioBased | Sets the status based on ratio.
Public method | SetStatusValueBased | Sets the status based on value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


AddError Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatus..::..AddError Method
ResultStatus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddError(String, Boolean) | Adds the error.
Public method | AddError(ResultStatusMessage, Document, Boolean) | Adds the error.

See Also

ResultStatus Class
ResultStatus Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


AddError Method (String, Boolean)

ResultStatus..::..AddError Method (String, Boolean)
ResultStatus Class See Also Send Feedback
Adds the error.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddError(
    string message,
    bool notify
)

Parameters

message
Type: System..::..String
The message.
notify
Type: System..::..Boolean
if set to true [notify].

See Also

ResultStatus Class
AddError Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


AddError Method (ResultStatusMessage, , Boolean)

ResultStatus..::..AddError Method (ResultStatusMessage, , Boolean)
ResultStatus Class See Also Send Feedback
Adds the error.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddError(
    ResultStatusMessage message,
    Document document,
    bool notify
)

Parameters

message
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusMessage
The message.
document
Type: Document
The document.
notify
Type: System..::..Boolean
if set to true [notify].

See Also

ResultStatus Class
AddError Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


AddInfo Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatus..::..AddInfo Method
ResultStatus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddInfo(String, Boolean) | Adds the info.
Public method | AddInfo(ResultStatusMessage, Document, Boolean) | Adds the info.

See Also

ResultStatus Class
ResultStatus Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


AddInfo Method (String, Boolean)

ResultStatus..::..AddInfo Method (String, Boolean)
ResultStatus Class See Also Send Feedback
Adds the info.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddInfo(
    string message,
    bool notify
)

Parameters

message
Type: System..::..String
The message.
notify
Type: System..::..Boolean
if set to true [notify].

See Also

ResultStatus Class
AddInfo Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


AddInfo Method (ResultStatusMessage, , Boolean)

ResultStatus..::..AddInfo Method (ResultStatusMessage, , Boolean)
ResultStatus Class See Also Send Feedback
Adds the info.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddInfo(
    ResultStatusMessage message,
    Document document,
    bool notify
)

Parameters

message
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusMessage
The message.
document
Type: Document
The document.
notify
Type: System..::..Boolean
if set to true [notify].

See Also

ResultStatus Class
AddInfo Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


AddWarning Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatus..::..AddWarning Method
ResultStatus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddWarning(String, Boolean) | Adds the warning.
Public method | AddWarning(ResultStatusMessage, Document, Boolean) | Adds the warning.

See Also

ResultStatus Class
ResultStatus Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


AddWarning Method (String, Boolean)

ResultStatus..::..AddWarning Method (String, Boolean)
ResultStatus Class See Also Send Feedback
Adds the warning.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddWarning(
    string message,
    bool notify
)

Parameters

message
Type: System..::..String
The message.
notify
Type: System..::..Boolean
if set to true [notify].

See Also

ResultStatus Class
AddWarning Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


AddWarning Method (ResultStatusMessage, , Boolean)

ResultStatus..::..AddWarning Method (ResultStatusMessage, , Boolean)
ResultStatus Class See Also Send Feedback
Adds the warning.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddWarning(
    ResultStatusMessage message,
    Document document,
    bool notify
)

Parameters

message
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusMessage
The message.
document
Type: Document
The document.
notify
Type: System..::..Boolean
if set to true [notify].

See Also

ResultStatus Class
AddWarning Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Clear Method

ResultStatus..::..Clear Method
ResultStatus Class See Also Send Feedback
Clears this instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Clear()

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IsError Method

ResultStatus..::..IsError Method
ResultStatus Class See Also Send Feedback
Determines whether this instance is error.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsError()

Return Value

true if this instance is error; otherwise, false.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IsOk Method

ResultStatus..::..IsOk Method
ResultStatus Class See Also Send Feedback
Determines whether this instance is ok.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsOk()

Return Value

true if this instance is ok; otherwise, false.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IsWarning Method

ResultStatus..::..IsWarning Method
ResultStatus Class See Also Send Feedback
Determines whether this instance is warning.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsWarning()

Return Value

true if this instance is warning; otherwise, false.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetStatusRatioBased Method

ResultStatus..::..SetStatusRatioBased Method
ResultStatus Class See Also Send Feedback
Sets the status based on ratio.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetStatusRatioBased(
    double ratio
)

Parameters

ratio
Type: System..::..Double
The ratio.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetStatusValueBased Method

ResultStatus..::..SetStatusValueBased Method
ResultStatus Class See Also Send Feedback
Sets the status based on value.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetStatusValueBased(
    double value,
    double minValue,
    double maxValue
)

Parameters

value
Type: System..::..Double
The value.
minValue
Type: System..::..Double
The min value.
maxValue
Type: System..::..Double
The max value.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatus Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatus Properties
ResultStatus Class See Also Send Feedback

The ResultStatus type exposes the following members.

Properties

 | Name | Description
Public property | ErrorList | Gets or sets the error list.
Public property | InfoList | Gets or sets the info list.
Public property | Package | Gets or sets the package.
Public property | ServerId | Gets or sets the server id.
Public property | Status | Gets or sets the status.
Public property | WarningList | Gets or sets the warning list.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ErrorList Property

ResultStatus..::..ErrorList Property
ResultStatus Class See Also Send Feedback
Gets or sets the error list.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ResultStatusMessage> ErrorList { get; set; }

Field Value

The error list.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


InfoList Property

ResultStatus..::..InfoList Property
ResultStatus Class See Also Send Feedback
Gets or sets the info list.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ResultStatusMessage> InfoList { get; set; }

Field Value

The info list.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Package Property

ResultStatus..::..Package Property
ResultStatus Class See Also Send Feedback
Gets or sets the package.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid Package { get; set; }

Field Value

The package.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerId Property

ResultStatus..::..ServerId Property
ResultStatus Class See Also Send Feedback
Gets or sets the server id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid ServerId { get; set; }

Field Value

The server id.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Status Property

ResultStatus..::..Status Property
ResultStatus Class See Also Send Feedback
Gets or sets the status.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Status Status { get; set; }

Field Value

The status.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


WarningList Property

ResultStatus..::..WarningList Property
ResultStatus Class See Also Send Feedback
Gets or sets the warning list.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ResultStatusMessage> WarningList { get; set; }

Field Value

The warning list.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusList Class

ResultStatusList Class
Members See Also Send Feedback
Represents result status list

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultStatusList : SchemaClass

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusList

See Also

ResultStatusList Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusList Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusList Members
ResultStatusList Class Constructors Methods Properties See Also Send Feedback

The ResultStatusList type exposes the following members.

Constructors

 | Name | Description
Public method | ResultStatusList()()()() | Initializes a new instance of the ResultStatusList class.
Public method | ResultStatusList(Document) | Initializes a new instance of the ResultStatusList class.
Public method | ResultStatusList(Entity, Document) | Initializes a new instance of the ResultStatusList class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | List | Gets or sets the list.

See Also

ResultStatusList Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusList Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusList Constructor
ResultStatusList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResultStatusList()()()() | Initializes a new instance of the ResultStatusList class.
Public method | ResultStatusList(Document) | Initializes a new instance of the ResultStatusList class.
Public method | ResultStatusList(Entity, Document) | Initializes a new instance of the ResultStatusList class.

See Also

ResultStatusList Class
ResultStatusList Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusList Constructor

ResultStatusList Constructor
ResultStatusList Class See Also Send Feedback
Initializes a new instance of the ResultStatusList class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatusList()

See Also

ResultStatusList Class
ResultStatusList Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusList Constructor ()

ResultStatusList Constructor ()
ResultStatusList Class See Also Send Feedback
Initializes a new instance of the ResultStatusList class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatusList(
    Document document
)

Parameters

document
Type: Document
The document.

See Also

ResultStatusList Class
ResultStatusList Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusList Constructor (, )

ResultStatusList Constructor (, )
ResultStatusList Class See Also Send Feedback
Initializes a new instance of the ResultStatusList class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatusList(
    Entity entity,
    Document document
)

Parameters

entity
Type: Entity
The entity.
document
Type: Document
The document.

See Also

ResultStatusList Class
ResultStatusList Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusList Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusList Methods
ResultStatusList Class See Also Send Feedback

The ResultStatusList type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultStatusList Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusList Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusList Properties
ResultStatusList Class See Also Send Feedback

The ResultStatusList type exposes the following members.

Properties

 | Name | Description
Public property | List | Gets or sets the list.

See Also

ResultStatusList Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


List Property

ResultStatusList..::..List Property
ResultStatusList Class See Also Send Feedback
Gets or sets the list.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ResultStatus> List { get; set; }

Field Value

The list.

See Also

ResultStatusList Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessage Class

ResultStatusMessage Class
Members See Also Send Feedback
Represent ResultStatus message

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultStatusMessage : SchemaClass

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusMessage

See Also

ResultStatusMessage Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessage Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusMessage Members
ResultStatusMessage Class Constructors Methods Properties See Also Send Feedback

The ResultStatusMessage type exposes the following members.

Constructors

 | Name | Description
Public method | ResultStatusMessage()()()() | Initializes a new instance of the ResultStatusMessage class.
Public method | ResultStatusMessage(String) | Initializes a new instance of the ResultStatusMessage class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetFormated | Gets the formated.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Message | Gets or sets the message.

See Also

ResultStatusMessage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessage Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusMessage Constructor
ResultStatusMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResultStatusMessage()()()() | Initializes a new instance of the ResultStatusMessage class.
Public method | ResultStatusMessage(String) | Initializes a new instance of the ResultStatusMessage class.

See Also

ResultStatusMessage Class
ResultStatusMessage Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessage Constructor

ResultStatusMessage Constructor
ResultStatusMessage Class See Also Send Feedback
Initializes a new instance of the ResultStatusMessage class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatusMessage()

See Also

ResultStatusMessage Class
ResultStatusMessage Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessage Constructor (String)

ResultStatusMessage Constructor (String)
ResultStatusMessage Class See Also Send Feedback
Initializes a new instance of the ResultStatusMessage class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatusMessage(
    string msg
)

Parameters

msg
Type: System..::..String
The MSG.

See Also

ResultStatusMessage Class
ResultStatusMessage Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessage Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusMessage Methods
ResultStatusMessage Class See Also Send Feedback

The ResultStatusMessage type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetFormated | Gets the formated.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultStatusMessage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetFormated Method

ResultStatusMessage..::..GetFormated Method
ResultStatusMessage Class See Also Send Feedback
Gets the formated.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetFormated(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

See Also

ResultStatusMessage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessage Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusMessage Properties
ResultStatusMessage Class See Also Send Feedback

The ResultStatusMessage type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets or sets the message.

See Also

ResultStatusMessage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Message Property

ResultStatusMessage..::..Message Property
ResultStatusMessage Class See Also Send Feedback
Gets or sets the message.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ResultStatusMessageItem> Message { get; set; }

Field Value

The message.

See Also

ResultStatusMessage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessageItem Class

ResultStatusMessageItem Class
Members See Also Send Feedback
Represents the single item of ResultStatusMessage

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultStatusMessageItem : SchemaClass

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusMessageItem

See Also

ResultStatusMessageItem Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessageItem Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusMessageItem Members
ResultStatusMessageItem Class Constructors Methods Properties See Also Send Feedback

The ResultStatusMessageItem type exposes the following members.

Constructors

 | Name | Description
Public method | ResultStatusMessageItem()()()() | Initializes a new instance of the ResultStatusMessageItem class.
Public method | ResultStatusMessageItem(String) | Initializes a new instance of the ResultStatusMessageItem class.
Public method | ResultStatusMessageItem(UnitType, DisplayUnitType, Double) | Initializes a new instance of the ResultStatusMessageItem class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetFormated | Gets the formated message.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayUnit | Gets or sets the display unit value is defined in.
Public property | Text | Gets or sets the text.
Public property | Unit | Gets or sets the unit.
Public property | Value | Gets or sets the value.

See Also

ResultStatusMessageItem Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessageItem Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusMessageItem Constructor
ResultStatusMessageItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResultStatusMessageItem()()()() | Initializes a new instance of the ResultStatusMessageItem class.
Public method | ResultStatusMessageItem(String) | Initializes a new instance of the ResultStatusMessageItem class.
Public method | ResultStatusMessageItem(UnitType, DisplayUnitType, Double) | Initializes a new instance of the ResultStatusMessageItem class.

See Also

ResultStatusMessageItem Class
ResultStatusMessageItem Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessageItem Constructor

ResultStatusMessageItem Constructor
ResultStatusMessageItem Class See Also Send Feedback
Initializes a new instance of the ResultStatusMessageItem class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatusMessageItem()

See Also

ResultStatusMessageItem Class
ResultStatusMessageItem Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessageItem Constructor (String)

ResultStatusMessageItem Constructor (String)
ResultStatusMessageItem Class See Also Send Feedback
Initializes a new instance of the ResultStatusMessageItem class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatusMessageItem(
    string text
)

Parameters

text
Type: System..::..String
The text.

See Also

ResultStatusMessageItem Class
ResultStatusMessageItem Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessageItem Constructor (, , Double)

ResultStatusMessageItem Constructor (, , Double)
ResultStatusMessageItem Class See Also Send Feedback
Initializes a new instance of the ResultStatusMessageItem class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultStatusMessageItem(
    UnitType unit,
    DisplayUnitType displayUnit,
    double value
)

Parameters

unit
Type: UnitType
The unit.
displayUnit
Type: DisplayUnitType
The display unit the value is defined in.
value
Type: System..::..Double
The value.

See Also

ResultStatusMessageItem Class
ResultStatusMessageItem Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessageItem Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusMessageItem Methods
ResultStatusMessageItem Class See Also Send Feedback

The ResultStatusMessageItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetFormated | Gets the formated message.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultStatusMessageItem Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetFormated Method

ResultStatusMessageItem..::..GetFormated Method
ResultStatusMessageItem Class See Also Send Feedback
Gets the formated message.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetFormated(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

See Also

ResultStatusMessageItem Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultStatusMessageItem Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusMessageItem Properties
ResultStatusMessageItem Class See Also Send Feedback

The ResultStatusMessageItem type exposes the following members.

Properties

 | Name | Description
Public property | DisplayUnit | Gets or sets the display unit value is defined in.
Public property | Text | Gets or sets the text.
Public property | Unit | Gets or sets the unit.
Public property | Value | Gets or sets the value.

See Also

ResultStatusMessageItem Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


DisplayUnit Property

ResultStatusMessageItem..::..DisplayUnit Property
ResultStatusMessageItem Class See Also Send Feedback
Gets or sets the display unit value is defined in.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType DisplayUnit { get; set; }

Field Value

The display unit.

See Also

ResultStatusMessageItem Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Text Property

ResultStatusMessageItem..::..Text Property
ResultStatusMessageItem Class See Also Send Feedback
Gets or sets the text.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Text { get; set; }

Field Value

The text.

See Also

ResultStatusMessageItem Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Unit Property

ResultStatusMessageItem..::..Unit Property
ResultStatusMessageItem Class See Also Send Feedback
Gets or sets the unit.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitType Unit { get; set; }

Field Value

The unit.

See Also

ResultStatusMessageItem Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Value Property

ResultStatusMessageItem..::..Value Property
ResultStatusMessageItem Class See Also Send Feedback
Gets or sets the value.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Value { get; set; }

Field Value

The value.

See Also

ResultStatusMessageItem Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerCalculationParam Class

ServerCalculationParam Class
Members See Also Send Feedback
Represents calculations parameters for specified server

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServerCalculationParam : ServerStorage

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerStorage
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerCalculationParam

See Also

ServerCalculationParam Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerCalculationParam Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServerCalculationParam Members
ServerCalculationParam Class Constructors Methods Properties See Also Send Feedback

The ServerCalculationParam type exposes the following members.

Constructors

 | Name | Description
Public method | ServerCalculationParam | Initializes a new instance of the ServerCalculationParam class.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Inherited from ServerStorage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Inherited from ServerStorage.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element. (Inherited from ServerStorage.)

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id. (Inherited from ServerStorage.)
Public property | Entity | Gets or sets the entity. (Inherited from ServerStorage.)
Public property | InputPackage | Gets or sets the input package.
Public property | LoadCombinations | Gets or sets the load combinations list.
Public property | Modified | Gets or sets a value indicating whether this Label was modified. (Inherited from ServerStorage.)
Public property | Packages | Gets or sets the list of server packages.
Public property | SchemaId | Gets or sets the schema id. (Inherited from ServerStorage.)
Public property | ServerId | Gets or sets the server id. (Inherited from ServerStorage.)
Public property | State | Gets or sets the state - used for checking modifications. (Inherited from ServerStorage.)

See Also

ServerCalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerCalculationParam Constructor

ServerCalculationParam Constructor
ServerCalculationParam Class See Also Send Feedback
Initializes a new instance of the ServerCalculationParam class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerCalculationParam()

See Also

ServerCalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerCalculationParam Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServerCalculationParam Methods
ServerCalculationParam Class See Also Send Feedback

The ServerCalculationParam type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Inherited from ServerStorage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Inherited from ServerStorage.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element. (Inherited from ServerStorage.)

See Also

ServerCalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerCalculationParam Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServerCalculationParam Properties
ServerCalculationParam Class See Also Send Feedback

The ServerCalculationParam type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id. (Inherited from ServerStorage.)
Public property | Entity | Gets or sets the entity. (Inherited from ServerStorage.)
Public property | InputPackage | Gets or sets the input package.
Public property | LoadCombinations | Gets or sets the load combinations list.
Public property | Modified | Gets or sets a value indicating whether this Label was modified. (Inherited from ServerStorage.)
Public property | Packages | Gets or sets the list of server packages.
Public property | SchemaId | Gets or sets the schema id. (Inherited from ServerStorage.)
Public property | ServerId | Gets or sets the server id. (Inherited from ServerStorage.)
Public property | State | Gets or sets the state - used for checking modifications. (Inherited from ServerStorage.)

See Also

ServerCalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


InputPackage Property

ServerCalculationParam..::..InputPackage Property
ServerCalculationParam Class See Also Send Feedback
Gets or sets the input package.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid InputPackage { get; set; }

Field Value

The active package.

See Also

ServerCalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


LoadCombinations Property

ServerCalculationParam..::..LoadCombinations Property
ServerCalculationParam Class See Also Send Feedback
Gets or sets the load combinations list.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ElementId> LoadCombinations { get; set; }

Field Value

The load combinations.

See Also

ServerCalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Packages Property

ServerCalculationParam..::..Packages Property
ServerCalculationParam Class See Also Send Feedback
Gets or sets the list of server packages.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ServerPackage> Packages { get; set; }

Field Value

The packages.

See Also

ServerCalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerData Class

ServerData Class
Members See Also Send Feedback
Represents server data

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServerData : SchemaClass

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerData

See Also

ServerData Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerData Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServerData Members
ServerData Class Constructors Methods Properties See Also Send Feedback

The ServerData type exposes the following members.

Constructors

 | Name | Description
Public method | ServerData | Initializes a new instance of the ServerData class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | ServerId | Gets or sets the server id.
Public property | Version | Gets or sets the version.

See Also

ServerData Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerData Constructor

ServerData Constructor
ServerData Class See Also Send Feedback
Initializes a new instance of the ServerData class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerData()

See Also

ServerData Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerData Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServerData Methods
ServerData Class See Also Send Feedback

The ServerData type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServerData Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerData Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServerData Properties
ServerData Class See Also Send Feedback

The ServerData type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | ServerId | Gets or sets the server id.
Public property | Version | Gets or sets the version.

See Also

ServerData Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Name Property

ServerData..::..Name Property
ServerData Class See Also Send Feedback
Gets or sets the name.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

Field Value

The name.

See Also

ServerData Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerId Property

ServerData..::..ServerId Property
ServerData Class See Also Send Feedback
Gets or sets the server id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int ServerId { get; set; }

Field Value

The server id.

See Also

ServerData Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Version Property

ServerData..::..Version Property
ServerData Class See Also Send Feedback
Gets or sets the version.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Version { get; set; }

Field Value

The version.

See Also

ServerData Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerLabel Class

ServerLabel Class
Members See Also Send Feedback
Represents label for specific server.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServerLabel : ServerStorage

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerStorage
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerLabel

See Also

ServerLabel Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerLabel Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServerLabel Members
ServerLabel Class Constructors Methods Properties See Also Send Feedback

The ServerLabel type exposes the following members.

Constructors

 | Name | Description
Public method | ServerLabel()()()() | Initializes a new instance of the ServerLabel class.
Public method | ServerLabel(Guid, Guid, Guid, Entity) | Initializes a new instance of the ServerLabel class.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Inherited from ServerStorage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Inherited from ServerStorage.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element. (Inherited from ServerStorage.)

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id. (Inherited from ServerStorage.)
Public property | Entity | Gets or sets the entity. (Inherited from ServerStorage.)
Public property | LabelId | Gets or sets the label id.
Public property | Modified | Gets or sets a value indicating whether this Label was modified. (Inherited from ServerStorage.)
Public property | SchemaId | Gets or sets the schema id. (Inherited from ServerStorage.)
Public property | ServerId | Gets or sets the server id. (Inherited from ServerStorage.)
Public property | State | Gets or sets the state - used for checking modifications. (Inherited from ServerStorage.)

See Also

ServerLabel Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerLabel Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ServerLabel Constructor
ServerLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ServerLabel()()()() | Initializes a new instance of the ServerLabel class.
Public method | ServerLabel(Guid, Guid, Guid, Entity) | Initializes a new instance of the ServerLabel class.

See Also

ServerLabel Class
ServerLabel Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerLabel Constructor

ServerLabel Constructor
ServerLabel Class See Also Send Feedback
Initializes a new instance of the ServerLabel class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerLabel()

See Also

ServerLabel Class
ServerLabel Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerLabel Constructor (Guid, Guid, Guid, )

ServerLabel Constructor (Guid, Guid, Guid, )
ServerLabel Class See Also Send Feedback
Initializes a new instance of the ServerLabel class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerLabel(
    Guid labelId,
    Guid serverId,
    Guid schemaId,
    Entity entity
)

Parameters

labelId
Type: System..::..Guid
The label id.
serverId
Type: System..::..Guid
The server id.
schemaId
Type: System..::..Guid
The schema id.
entity
Type: Entity
The entity.

See Also

ServerLabel Class
ServerLabel Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerLabel Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServerLabel Methods
ServerLabel Class See Also Send Feedback

The ServerLabel type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Inherited from ServerStorage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Inherited from ServerStorage.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element. (Inherited from ServerStorage.)

See Also

ServerLabel Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerLabel Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServerLabel Properties
ServerLabel Class See Also Send Feedback

The ServerLabel type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id. (Inherited from ServerStorage.)
Public property | Entity | Gets or sets the entity. (Inherited from ServerStorage.)
Public property | LabelId | Gets or sets the label id.
Public property | Modified | Gets or sets a value indicating whether this Label was modified. (Inherited from ServerStorage.)
Public property | SchemaId | Gets or sets the schema id. (Inherited from ServerStorage.)
Public property | ServerId | Gets or sets the server id. (Inherited from ServerStorage.)
Public property | State | Gets or sets the state - used for checking modifications. (Inherited from ServerStorage.)

See Also

ServerLabel Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


LabelId Property

ServerLabel..::..LabelId Property
ServerLabel Class See Also Send Feedback
Gets or sets the label id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid LabelId { get; set; }

Field Value

The label id.

See Also

ServerLabel Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerPackage Class

ServerPackage Class
Members See Also Send Feedback
Represents the server package

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServerPackage : SchemaClass

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerPackage

See Also

ServerPackage Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerPackage Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServerPackage Members
ServerPackage Class Constructors Methods Properties See Also Send Feedback

The ServerPackage type exposes the following members.

Constructors

 | Name | Description
Public method | ServerPackage | Initializes a new instance of the ServerPackage class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Analysis | Gets or sets the analysis.
Public property | Description | Gets or sets the description.
Public property | InputPackageId | Gets or sets the analysis package id.
Public property | Model | Gets or sets the model.
Public property | Name | Gets or sets the name.
Public property | OutputPackageId | Gets or sets the package id.
Public property | ServerId | Gets or sets the server id.

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerPackage Constructor

ServerPackage Constructor
ServerPackage Class See Also Send Feedback
Initializes a new instance of the ServerPackage class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerPackage()

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerPackage Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServerPackage Methods
ServerPackage Class See Also Send Feedback

The ServerPackage type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerPackage Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServerPackage Properties
ServerPackage Class See Also Send Feedback

The ServerPackage type exposes the following members.

Properties

 | Name | Description
Public property | Analysis | Gets or sets the analysis.
Public property | Description | Gets or sets the description.
Public property | InputPackageId | Gets or sets the analysis package id.
Public property | Model | Gets or sets the model.
Public property | Name | Gets or sets the name.
Public property | OutputPackageId | Gets or sets the package id.
Public property | ServerId | Gets or sets the server id.

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Analysis Property

ServerPackage..::..Analysis Property
ServerPackage Class See Also Send Feedback
Gets or sets the analysis.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Analysis { get; set; }

Field Value

The analysis.

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Description Property

ServerPackage..::..Description Property
ServerPackage Class See Also Send Feedback
Gets or sets the description.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Description { get; set; }

Field Value

The description.

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


InputPackageId Property

ServerPackage..::..InputPackageId Property
ServerPackage Class See Also Send Feedback
Gets or sets the analysis package id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid InputPackageId { get; set; }

Field Value

The analysis package id.

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Model Property

ServerPackage..::..Model Property
ServerPackage Class See Also Send Feedback
Gets or sets the model.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Model { get; set; }

Field Value

The model.

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Name Property

ServerPackage..::..Name Property
ServerPackage Class See Also Send Feedback
Gets or sets the name.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

Field Value

The name.

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


OutputPackageId Property

ServerPackage..::..OutputPackageId Property
ServerPackage Class See Also Send Feedback
Gets or sets the package id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid OutputPackageId { get; set; }

Field Value

The package id.

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerId Property

ServerPackage..::..ServerId Property
ServerPackage Class See Also Send Feedback
Gets or sets the server id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid ServerId { get; set; }

Field Value

The server id.

See Also

ServerPackage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerResult Class

ServerResult Class
Members See Also Send Feedback
Represents result for specific server

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServerResult : ServerStorage

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerStorage
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerResult

See Also

ServerResult Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerResult Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServerResult Members
ServerResult Class Constructors Methods Properties See Also Send Feedback

The ServerResult type exposes the following members.

Constructors

 | Name | Description
Public method | ServerResult | Initializes a new instance of the ServerResult class

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Inherited from ServerStorage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Inherited from ServerStorage.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element. (Inherited from ServerStorage.)

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id. (Inherited from ServerStorage.)
Public property | Entity | Gets or sets the entity. (Inherited from ServerStorage.)
Public property | IsUpToDate | Gets or sets a value indicating whether this instance is up to date.
Public property | Modified | Gets or sets a value indicating whether this Label was modified. (Inherited from ServerStorage.)
Public property | SchemaId | Gets or sets the schema id. (Inherited from ServerStorage.)
Public property | ServerId | Gets or sets the server id. (Inherited from ServerStorage.)
Public property | State | Gets or sets the state - used for checking modifications. (Inherited from ServerStorage.)

See Also

ServerResult Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerResult Constructor

ServerResult Constructor
ServerResult Class See Also Send Feedback
Initializes a new instance of the ServerResult class

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerResult()

See Also

ServerResult Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerResult Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServerResult Methods
ServerResult Class See Also Send Feedback

The ServerResult type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Inherited from ServerStorage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Inherited from ServerStorage.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element. (Inherited from ServerStorage.)

See Also

ServerResult Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerResult Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServerResult Properties
ServerResult Class See Also Send Feedback

The ServerResult type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id. (Inherited from ServerStorage.)
Public property | Entity | Gets or sets the entity. (Inherited from ServerStorage.)
Public property | IsUpToDate | Gets or sets a value indicating whether this instance is up to date.
Public property | Modified | Gets or sets a value indicating whether this Label was modified. (Inherited from ServerStorage.)
Public property | SchemaId | Gets or sets the schema id. (Inherited from ServerStorage.)
Public property | ServerId | Gets or sets the server id. (Inherited from ServerStorage.)
Public property | State | Gets or sets the state - used for checking modifications. (Inherited from ServerStorage.)

See Also

ServerResult Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IsUpToDate Property

ServerResult..::..IsUpToDate Property
ServerResult Class See Also Send Feedback
Gets or sets a value indicating whether this instance is up to date.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsUpToDate { get; set; }

Field Value

true if this instance is up to date; otherwise, false.

See Also

ServerResult Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerStorage Class

ServerStorage Class
Members See Also Send Feedback
Base class for all servers data

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServerStorage : SchemaClass

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerStorage
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination..::..ServerLoadCombination
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerCalculationParam
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerLabel
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerResult

See Also

ServerStorage Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerStorage Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServerStorage Members
ServerStorage Class Constructors Methods Properties See Also Send Feedback

The ServerStorage type exposes the following members.

Constructors

 | Name | Description
Public method | ServerStorage | Initializes a new instance of the ServerStorage class.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Overrides SchemaClass..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Overrides SchemaClass..::..Load(Element).)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element.

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id.
Public property | Entity | Gets or sets the entity.
Public property | Modified | Gets or sets a value indicating whether this Label was modified.
Public property | SchemaId | Gets or sets the schema id.
Public property | ServerId | Gets or sets the server id.
Public property | State | Gets or sets the state - used for checking modifications.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerStorage Constructor

ServerStorage Constructor
ServerStorage Class See Also Send Feedback
Initializes a new instance of the ServerStorage class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerStorage()

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerStorage Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServerStorage Methods
ServerStorage Class See Also Send Feedback

The ServerStorage type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Overrides SchemaClass..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Overrides SchemaClass..::..Load(Element).)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Clone Method

ServerStorage..::..Clone Method
ServerStorage Class See Also Send Feedback
Clones this instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override Object Clone()

Return Value

Implements

ICloneable..::..Clone()()()()

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Load Method

ServerStorage..::..Load Method
ServerStorage Class See Also Send Feedback
Loads the specified element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override bool Load(
    Element element
)

Parameters

element
Type: Element
The element.

Return Value

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


UpdateState Method

ServerStorage..::..UpdateState Method
ServerStorage Class See Also Send Feedback
Updates the state of the element.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void UpdateState()

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerStorage Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServerStorage Properties
ServerStorage Class See Also Send Feedback

The ServerStorage type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id.
Public property | Entity | Gets or sets the entity.
Public property | Modified | Gets or sets a value indicating whether this Label was modified.
Public property | SchemaId | Gets or sets the schema id.
Public property | ServerId | Gets or sets the server id.
Public property | State | Gets or sets the state - used for checking modifications.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ElementId Property

ServerStorage..::..ElementId Property
ServerStorage Class See Also Send Feedback
Gets or sets the element id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementId ElementId { get; set; }

Field Value

The element id.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Entity Property

ServerStorage..::..Entity Property
ServerStorage Class See Also Send Feedback
Gets or sets the entity.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Entity Entity { get; set; }

Field Value

The entity.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Modified Property

ServerStorage..::..Modified Property
ServerStorage Class See Also Send Feedback
Gets or sets a value indicating whether this Label was modified.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Modified { get; set; }

Field Value

true if modified; otherwise, false.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SchemaId Property

ServerStorage..::..SchemaId Property
ServerStorage Class See Also Send Feedback
Gets or sets the schema id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid SchemaId { get; set; }

Field Value

The schema id.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServerId Property

ServerStorage..::..ServerId Property
ServerStorage Class See Also Send Feedback
Gets or sets the server id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid ServerId { get; set; }

Field Value

The server id.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


State Property

ServerStorage..::..State Property
ServerStorage Class See Also Send Feedback
Gets or sets the state - used for checking modifications.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid State { get; set; }

Field Value

The state.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Status Enumeration

Status Enumeration
See Also Send Feedback
Represents status of result

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum Status

Members

Member name | Value | Description
Undefined | 1 | Undefined status
Succeed | 2 | Succeed status
Warning | 4 | Warning status
Failed | 8 | Failed status

See Also

Autodesk.Revit.DB.CodeChecking.Storage Namespace


Storage(T) Class

Storage<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Base class for all storage classes.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Storage<T> : SchemaClass,
    IStorage
where T : new(), ServerStorage

Type Parameters

T

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..Storage<(Of <(<'T>)>)>
Autodesk.Revit.DB.CodeChecking.Storage..::..CalculationParam
Autodesk.Revit.DB.CodeChecking.Storage..::..Label
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination..::..LoadCombinationParameters
Autodesk.Revit.DB.CodeChecking.Storage..::..Result

See Also

Storage<(Of <(<'T>)>)> Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Storage(T) Members

[image]

Structural Analysis and Code Checking API Reference Guide
Storage<(Of <(<'T>)>)> Members
Storage<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The Storage<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Storage<(Of <(<'T>)>)>(StorageDocument) | Initializes a new instance of the Autodesk.Revit.DB.CodeChecking.Storage class.
Public method | Storage<(Of <(<'T>)>)>(ElementId, StorageDocument) | Initializes a new instance of the Autodesk.Revit.DB.CodeChecking.Storage class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites.
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema.
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServerStorageSchemaBased |
Public method | GetServerStorageServerBased |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one.
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | SetEntity(SchemaClass, Guid) | Sets the entity.
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerStorage | Adds the server data to storage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Document | Gets or sets the document.
Public property | ElementId | Gets or sets the Element
Public property | ServersStorages | Gets or sets list of entities (for different servers)

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Storage(T) Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
Storage<(Of <(<'T>)>)> Constructor
Storage<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Storage<(Of <(<'T>)>)>(StorageDocument) | Initializes a new instance of the Autodesk.Revit.DB.CodeChecking.Storage class.
Public method | Storage<(Of <(<'T>)>)>(ElementId, StorageDocument) | Initializes a new instance of the Autodesk.Revit.DB.CodeChecking.Storage class.

See Also

Storage<(Of <(<'T>)>)> Class
Storage<(Of <(<'T>)>)> Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Storage(T) Constructor (StorageDocument)

Storage<(Of <(<'T>)>)> Constructor (StorageDocument)
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the Autodesk.Revit.DB.CodeChecking.Storage class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Storage(
    StorageDocument storageDocument
)

Parameters

storageDocument
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..StorageDocument

See Also

Storage<(Of <(<'T>)>)> Class
Storage<(Of <(<'T>)>)> Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Storage(T) Constructor (, StorageDocument)

Storage<(Of <(<'T>)>)> Constructor (, StorageDocument)
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the Autodesk.Revit.DB.CodeChecking.Storage class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Storage(
    ElementId element,
    StorageDocument storageDocument
)

Parameters

element
Type: ElementId
The element.
storageDocument
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..StorageDocument
The storage document.

See Also

Storage<(Of <(<'T>)>)> Class
Storage<(Of <(<'T>)>)> Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Storage(T) Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Storage<(Of <(<'T>)>)> Methods
Storage<(Of <(<'T>)>)> Class See Also Send Feedback

The Storage<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites.
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema.
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServerStorageSchemaBased |
Public method | GetServerStorageServerBased |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one.
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | SetEntity(SchemaClass, Guid) | Sets the entity.
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerStorage | Adds the server data to storage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetEntites Method

Storage<(Of <(<'T>)>)>..::..GetEntites Method
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Gets entites.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Entity> GetEntites()

Return Value

Implements

IStorage..::..GetEntites()()()()

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetEntity Method

[image]

Structural Analysis and Code Checking API Reference Guide
Storage<(Of <(<'T>)>)>..::..GetEntity Method
Storage<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity.
Public method | GetEntity(Guid) | Returns entity of particular schema.

See Also

Storage<(Of <(<'T>)>)> Class
Storage<(Of <(<'T>)>)> Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetEntity(TClass) Method ()

Storage<(Of <(<'T>)>)>..::..GetEntity<(Of <(<'TClass>)>)> Method ()
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Returns instance of T type filled with data from particular entity.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TClass GetEntity<TClass>(
    Document document
)
where TClass : new(), SchemaClass

Parameters

document
Type: Document
The document.

Type Parameters

TClass
The type of the class.

Return Value

The instance of T type.

Remarks

The schema is taken from SchemaAttribute and the type should be derived from SchemaClass.

See Also

Storage<(Of <(<'T>)>)> Class
GetEntity Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetEntity Method (Guid)

Storage<(Of <(<'T>)>)>..::..GetEntity Method (Guid)
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Returns entity of particular schema.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Entity GetEntity(
    Guid schema
)

Parameters

schema
Type: System..::..Guid
The schema id.

Return Value

Implements

IStorage..::..GetEntity(Guid)

See Also

Storage<(Of <(<'T>)>)> Class
GetEntity Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetServerStorageSchemaBased Method

Storage<(Of <(<'T>)>)>..::..GetServerStorageSchemaBased Method
Storage<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public T GetServerStorageSchemaBased(
    Guid schemaId
)

Parameters

schemaId
Type: System..::..Guid

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetServerStorageServerBased Method

Storage<(Of <(<'T>)>)>..::..GetServerStorageServerBased Method
Storage<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public T GetServerStorageServerBased(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Replace Method

[image]

Structural Analysis and Code Checking API Reference Guide
Storage<(Of <(<'T>)>)>..::..Replace Method
Storage<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one.

See Also

Storage<(Of <(<'T>)>)> Class
Storage<(Of <(<'T>)>)> Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Replace Method ()

Storage<(Of <(<'T>)>)>..::..Replace Method ()
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Sets entity (if entity of the same schema id exist it will be replaced).

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Replace(
    Entity entity
)

Parameters

entity
Type: Entity
The entity

See Also

Storage<(Of <(<'T>)>)> Class
Replace Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Replace Method (, )

Storage<(Of <(<'T>)>)>..::..Replace Method (, )
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Replaces the old entity with newest one.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool Replace(
    Entity oldEntity,
    Entity newEntity
)

Parameters

oldEntity
Type: Entity
The old entity.
newEntity
Type: Entity
The new entity.

Return Value

See Also

Storage<(Of <(<'T>)>)> Class
Replace Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetEntity Method

[image]

Structural Analysis and Code Checking API Reference Guide
Storage<(Of <(<'T>)>)>..::..SetEntity Method
Storage<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | SetEntity(SchemaClass, Guid) | Sets the entity.

See Also

Storage<(Of <(<'T>)>)> Class
Storage<(Of <(<'T>)>)> Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetEntity Method (, Guid)

Storage<(Of <(<'T>)>)>..::..SetEntity Method (, Guid)
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Sets entity (if entity of the same schema id exist it will be replaced).

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual T SetEntity(
    Entity entity,
    Guid serverId
)

Parameters

entity
Type: Entity
The entity
serverId
Type: System..::..Guid
The server id.

Return Value

See Also

Storage<(Of <(<'T>)>)> Class
SetEntity Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetEntity Method (SchemaClass, Guid)

Storage<(Of <(<'T>)>)>..::..SetEntity Method (SchemaClass, Guid)
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Sets the entity.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void SetEntity(
    SchemaClass entity,
    Guid serverId
)

Parameters

entity
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
The entity.
serverId
Type: System..::..Guid
The server id.

See Also

Storage<(Of <(<'T>)>)> Class
SetEntity Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


SetServerStorage Method

Storage<(Of <(<'T>)>)>..::..SetServerStorage Method
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Adds the server data to storage.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void SetServerStorage(
    T storage
)

Parameters

storage
Type: T
The storage.

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Storage(T) Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Storage<(Of <(<'T>)>)> Properties
Storage<(Of <(<'T>)>)> Class See Also Send Feedback

The Storage<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets or sets the document.
Public property | ElementId | Gets or sets the Element
Public property | ServersStorages | Gets or sets list of entities (for different servers)

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Document Property

Storage<(Of <(<'T>)>)>..::..Document Property
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the document.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public StorageDocument Document { get; internal set; }

Field Value

The document.

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ElementId Property

Storage<(Of <(<'T>)>)>..::..ElementId Property
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the Element

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementId ElementId { get; set; }

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ServersStorages Property

Storage<(Of <(<'T>)>)>..::..ServersStorages Property
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets list of entities (for different servers)

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<T> ServersStorages { get; set; }

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageDocument Class

StorageDocument Class
Members See Also Send Feedback
Represents the storage document which manages data for one particular Revit document.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class StorageDocument

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Storage..::..StorageDocument

See Also

StorageDocument Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageDocument Members

[image]

Structural Analysis and Code Checking API Reference Guide
StorageDocument Members
StorageDocument Class Constructors Methods Properties See Also Send Feedback

The StorageDocument type exposes the following members.

Constructors

 | Name | Description
Public method | StorageDocument | Initializes a new instance of the StorageDocument class.

Methods

 | Name | Description
Public method | Commit | Commits this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReloaded | Determines whether this instance is reloaded.
Public method | OnSynchronized | Reacts after synchronization.
Public method | OnSynchronizing | Reacts on synchronizing.
Public method | Reload | Reloads this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CalculationParamsManager | The calculation parameters manager.
Public property | LabelsManager | The labels manager.
Public property | ResultBuilderManager | Gets the result builder manager.
Public property | ResultsManager | The results manager.
Public property | RevitDocument | The Revit document.

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageDocument Constructor

StorageDocument Constructor
StorageDocument Class See Also Send Feedback
Initializes a new instance of the StorageDocument class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public StorageDocument(
    Document doc,
    StorageService storageService,
    bool checkDocument
)

Parameters

doc
Type: Document
The doc.
storageService
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..StorageService
The storage service.
checkDocument
Type: System..::..Boolean
if set to true check document.

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageDocument Methods

[image]

Structural Analysis and Code Checking API Reference Guide
StorageDocument Methods
StorageDocument Class See Also Send Feedback

The StorageDocument type exposes the following members.

Methods

 | Name | Description
Public method | Commit | Commits this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReloaded | Determines whether this instance is reloaded.
Public method | OnSynchronized | Reacts after synchronization.
Public method | OnSynchronizing | Reacts on synchronizing.
Public method | Reload | Reloads this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Commit Method

StorageDocument..::..Commit Method
StorageDocument Class See Also Send Feedback
Commits this instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Commit()

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


IsReloaded Method

StorageDocument..::..IsReloaded Method
StorageDocument Class See Also Send Feedback
Determines whether this instance is reloaded.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsReloaded()

Return Value

true if this instance is reloaded; otherwise, false.

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


OnSynchronized Method

StorageDocument..::..OnSynchronized Method
StorageDocument Class See Also Send Feedback
Reacts after synchronization.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void OnSynchronized(
    DocumentSynchronizedWithCentralEventArgs e
)

Parameters

e
Type: DocumentSynchronizedWithCentralEventArgs
The DocumentSynchronizedWithCentralEventArgs instance containing the event data.

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


OnSynchronizing Method

StorageDocument..::..OnSynchronizing Method
StorageDocument Class See Also Send Feedback
Reacts on synchronizing.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void OnSynchronizing(
    DocumentSynchronizingWithCentralEventArgs e
)

Parameters

e
Type: DocumentSynchronizingWithCentralEventArgs
The DocumentSynchronizingWithCentralEventArgs instance containing the event data.

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Reload Method

StorageDocument..::..Reload Method
StorageDocument Class See Also Send Feedback
Reloads this instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Reload()

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageDocument Properties

[image]

Structural Analysis and Code Checking API Reference Guide
StorageDocument Properties
StorageDocument Class See Also Send Feedback

The StorageDocument type exposes the following members.

Properties

 | Name | Description
Public property | CalculationParamsManager | The calculation parameters manager.
Public property | LabelsManager | The labels manager.
Public property | ResultBuilderManager | Gets the result builder manager.
Public property | ResultsManager | The results manager.
Public property | RevitDocument | The Revit document.

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


CalculationParamsManager Property

StorageDocument..::..CalculationParamsManager Property
StorageDocument Class See Also Send Feedback
The calculation parameters manager.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CalculationParamsManager CalculationParamsManager { get; }

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


LabelsManager Property

StorageDocument..::..LabelsManager Property
StorageDocument Class See Also Send Feedback
The labels manager.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LabelsManager LabelsManager { get; }

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultBuilderManager Property

StorageDocument..::..ResultBuilderManager Property
StorageDocument Class See Also Send Feedback
Gets the result builder manager.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultBuilderManager ResultBuilderManager { get; private set; }

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ResultsManager Property

StorageDocument..::..ResultsManager Property
StorageDocument Class See Also Send Feedback
The results manager.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsManager ResultsManager { get; }

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


RevitDocument Property

StorageDocument..::..RevitDocument Property
StorageDocument Class See Also Send Feedback
The Revit document.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document RevitDocument { get; private set; }

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageManager Class

StorageManager Class
Members See Also Send Feedback
Base class for all storage managers

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class StorageManager

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Storage..::..StorageManager
Autodesk.Revit.DB.CodeChecking.Storage..::..CalculationParamsManager
Autodesk.Revit.DB.CodeChecking.Storage..::..LabelsManager
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination..::..LoadCombinationManager
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultBuilderManager
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultsManager

See Also

StorageManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageManager Members

[image]

Structural Analysis and Code Checking API Reference Guide
StorageManager Members
StorageManager Class Constructors Methods Properties See Also Send Feedback

The StorageManager type exposes the following members.

Constructors

 | Name | Description
Public method | StorageManager | Initializes a new instance of the StorageManager class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchemaId |
Public method | GetSchemaIdForServer |
Public method | GetServerIdOfStorageSchema |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) |
Public method | ValidateCategory(BuiltInCategory, String, Guid) |

Properties

 | Name | Description
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded.
Public property | RevitDocument | The Revit document.
Public property | StorageDocument | The storage manager this instance belongs to.

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageManager Constructor

StorageManager Constructor
StorageManager Class See Also Send Feedback
Initializes a new instance of the StorageManager class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public StorageManager(
    StorageDocument storageDoc
)

Parameters

storageDoc
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..StorageDocument
The storage doc.

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageManager Methods

[image]

Structural Analysis and Code Checking API Reference Guide
StorageManager Methods
StorageManager Class See Also Send Feedback

The StorageManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchemaId |
Public method | GetSchemaIdForServer |
Public method | GetServerIdOfStorageSchema |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) |
Public method | ValidateCategory(BuiltInCategory, String, Guid) |

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetSchemaId Method

StorageManager..::..GetSchemaId Method
StorageManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid GetSchemaId(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetSchemaIdForServer Method

StorageManager..::..GetSchemaIdForServer Method
StorageManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid GetSchemaIdForServer(
    IDictionary<Guid, Guid> map,
    Guid server
)

Parameters

map
Type: System.Collections.Generic..::..IDictionary <(Of <(<' Guid, Guid >)>)>
server
Type: System..::..Guid

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetServerIdOfStorageSchema Method

StorageManager..::..GetServerIdOfStorageSchema Method
StorageManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid GetServerIdOfStorageSchema(
    Guid schema
)

Parameters

schema
Type: System..::..Guid

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ValidateCategory Method

[image]

Structural Analysis and Code Checking API Reference Guide
StorageManager..::..ValidateCategory Method
StorageManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateCategory(BuiltInCategory) |
Public method | ValidateCategory(BuiltInCategory, String, Guid) |

See Also

StorageManager Class
StorageManager Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ValidateCategory Method ()

StorageManager..::..ValidateCategory Method ()
StorageManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool ValidateCategory(
    BuiltInCategory category
)

Parameters

category
Type: BuiltInCategory

See Also

StorageManager Class
ValidateCategory Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


ValidateCategory Method (, String, Guid)

StorageManager..::..ValidateCategory Method (, String, Guid)
StorageManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool ValidateCategory(
    BuiltInCategory category,
    string method,
    Guid serverId
)

Parameters

category
Type: BuiltInCategory
method
Type: System..::..String
serverId
Type: System..::..Guid

See Also

StorageManager Class
ValidateCategory Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageManager Properties

[image]

Structural Analysis and Code Checking API Reference Guide
StorageManager Properties
StorageManager Class See Also Send Feedback

The StorageManager type exposes the following members.

Properties

 | Name | Description
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded.
Public property | RevitDocument | The Revit document.
Public property | StorageDocument | The storage manager this instance belongs to.

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Reloaded Property

StorageManager..::..Reloaded Property
StorageManager Class See Also Send Feedback
Gets a value indicating whether this StorageManager is reloaded.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Reloaded { get; internal set; }

Field Value

true if reloaded; otherwise, false.

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


RevitDocument Property

StorageManager..::..RevitDocument Property
StorageManager Class See Also Send Feedback
The Revit document.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document RevitDocument { get; }

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageDocument Property

StorageManager..::..StorageDocument Property
StorageManager Class See Also Send Feedback
The storage manager this instance belongs to.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public StorageDocument StorageDocument { get; internal set; }

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageService Class

StorageService Class
Members See Also Send Feedback
Represents the storage service.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class StorageService

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Storage..::..StorageService

See Also

StorageService Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageService Members

[image]

Structural Analysis and Code Checking API Reference Guide
StorageService Members
StorageService Class Methods See Also Send Feedback

The StorageService type exposes the following members.

Methods

 | Name | Description
Public method | DocumentClosed | Reacts on document closing.
Public method | DocumentOpened | Reacts on document opening.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCommonDataStorage | Gets the common data storage.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStorageDocument | Returns storage document for particular Revit document.
 | GetStorageService | Returns instance of service.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserDataStorage | Gets the user data storage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StorageService Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


StorageService Methods

[image]

Structural Analysis and Code Checking API Reference Guide
StorageService Methods
StorageService Class See Also Send Feedback

The StorageService type exposes the following members.

Methods

 | Name | Description
Public method | DocumentClosed | Reacts on document closing.
Public method | DocumentOpened | Reacts on document opening.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCommonDataStorage | Gets the common data storage.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStorageDocument | Returns storage document for particular Revit document.
 | GetStorageService | Returns instance of service.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserDataStorage | Gets the user data storage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StorageService Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


DocumentClosed Method

StorageService..::..DocumentClosed Method
StorageService Class See Also Send Feedback
Reacts on document closing.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void DocumentClosed(
    Document doc
)

Parameters

doc
Type: Document
The document.

See Also

StorageService Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


DocumentOpened Method

StorageService..::..DocumentOpened Method
StorageService Class See Also Send Feedback
Reacts on document opening.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void DocumentOpened(
    Document doc
)

Parameters

doc
Type: Document
The document.

See Also

StorageService Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetCommonDataStorage Method

StorageService..::..GetCommonDataStorage Method
StorageService Class See Also Send Feedback
Gets the common data storage.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DataStorage GetCommonDataStorage(
    Document document,
    bool create
)

Parameters

document
Type: Document
The document.
create
Type: System..::..Boolean
if set to true [create].

Return Value

See Also

StorageService Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetStorageDocument Method

StorageService..::..GetStorageDocument Method
StorageService Class See Also Send Feedback
Returns storage document for particular Revit document.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public StorageDocument GetStorageDocument(
    Document document
)

Parameters

document
Type: Document
The docuemnt.

Return Value

The storage document.

See Also

StorageService Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetStorageService Method

StorageService..::..GetStorageService Method
StorageService Class See Also Send Feedback
Returns instance of service.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static StorageService GetStorageService()

Return Value

See Also

StorageService Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


GetUserDataStorage Method

StorageService..::..GetUserDataStorage Method
StorageService Class See Also Send Feedback
Gets the user data storage.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DataStorage GetUserDataStorage(
    Document document,
    string userName
)

Parameters

document
Type: Document
The document.
userName
Type: System..::..String
Name of the user.

Return Value

See Also

StorageService Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace


Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace

Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace
Send Feedback

Classes

 | Class | Description
Public class | LoadCombinationManager | Represent load combination manager.
Public class | LoadCombinationParameters | Represents LoadCombination parameters
Public class | ServerLoadCombination | Represents label for specific server.


LoadCombinationManager Class

LoadCombinationManager Class
Members See Also Send Feedback
Represent load combination manager.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LoadCombinationManager : StorageManager

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Storage..::..StorageManager
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination..::..LoadCombinationManager

See Also

LoadCombinationManager Members
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCombinationManager Members

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationManager Members
LoadCombinationManager Class Constructors Methods Properties See Also Send Feedback

The LoadCombinationManager type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCombinationManager | Initializes a new instance of the CalculationParamsManager class.

Methods

 | Name | Description
Public method | CommitMe | Commits this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServerId |
Public method | GetDefault | Gets the default.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLCServer | Returns server of specific id.
 | GetManager | Gets the manager.
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetServersIds |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnSynchronized | (Overrides StorageManagerOnSynchronized(DocumentSynchronizedWithCentralEventArgs).)
Public method | OnSynchronizing | (Overrides StorageManagerOnSynchronizing(DocumentSynchronizingWithCentralEventArgs).)
Public method | ReloadMe | Reloads this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

Properties

 | Name | Description
Public property | LoadCombinationParams | Returns current calculation parameters.
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCombinationManager Constructor

LoadCombinationManager Constructor
LoadCombinationManager Class See Also Send Feedback
Initializes a new instance of the CalculationParamsManager class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombinationManager(
    StorageDocument storageDoc
)

Parameters

storageDoc
Type: Autodesk.Revit.DB.CodeChecking.Storage..::..StorageDocument
The storage doc.

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCombinationManager Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationManager Methods
LoadCombinationManager Class See Also Send Feedback

The LoadCombinationManager type exposes the following members.

Methods

 | Name | Description
Public method | CommitMe | Commits this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServerId |
Public method | GetDefault | Gets the default.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLCServer | Returns server of specific id.
 | GetManager | Gets the manager.
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetServersIds |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnSynchronized | (Overrides StorageManagerOnSynchronized(DocumentSynchronizedWithCentralEventArgs).)
Public method | OnSynchronizing | (Overrides StorageManagerOnSynchronizing(DocumentSynchronizingWithCentralEventArgs).)
Public method | ReloadMe | Reloads this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


CommitMe Method

LoadCombinationManager..::..CommitMe Method
LoadCombinationManager Class See Also Send Feedback
Commits this instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void CommitMe()

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


GetActiveServerId Method

LoadCombinationManager..::..GetActiveServerId Method
LoadCombinationManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid GetActiveServerId()

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


GetDefault Method

LoadCombinationManager..::..GetDefault Method
LoadCombinationManager Class See Also Send Feedback
Gets the default.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Entity GetDefault(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The server identifier.

Return Value

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


GetLCServer Method

LoadCombinationManager..::..GetLCServer Method
LoadCombinationManager Class See Also Send Feedback
Returns server of specific id.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ILoadCombinationServer GetLCServer(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The server id.

Return Value

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


GetManager Method

LoadCombinationManager..::..GetManager Method
LoadCombinationManager Class See Also Send Feedback
Gets the manager.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static LoadCombinationManager GetManager(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


GetServersIds Method

LoadCombinationManager..::..GetServersIds Method
LoadCombinationManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<Guid> GetServersIds()

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


OnSynchronized Method

LoadCombinationManager..::..OnSynchronized Method
LoadCombinationManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override void OnSynchronized(
    DocumentSynchronizedWithCentralEventArgs e
)

Parameters

e
Type: DocumentSynchronizedWithCentralEventArgs

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


OnSynchronizing Method

LoadCombinationManager..::..OnSynchronizing Method
LoadCombinationManager Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override void OnSynchronizing(
    DocumentSynchronizingWithCentralEventArgs e
)

Parameters

e
Type: DocumentSynchronizingWithCentralEventArgs

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


ReloadMe Method

LoadCombinationManager..::..ReloadMe Method
LoadCombinationManager Class See Also Send Feedback
Reloads this instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void ReloadMe()

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


ValidateCategory Method

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationManager..::..ValidateCategory Method
LoadCombinationManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

See Also

LoadCombinationManager Class
LoadCombinationManager Members
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCombinationManager Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationManager Properties
LoadCombinationManager Class See Also Send Feedback

The LoadCombinationManager type exposes the following members.

Properties

 | Name | Description
Public property | LoadCombinationParams | Returns current calculation parameters.
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCombinationParams Property

LoadCombinationManager..::..LoadCombinationParams Property
LoadCombinationManager Class See Also Send Feedback
Returns current calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCombinationParameters LoadCombinationParams { get; }

See Also

LoadCombinationManager Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCombinationParameters Class

LoadCombinationParameters Class
Members See Also Send Feedback
Represents LoadCombination parameters

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LoadCombinationParameters : Storage<ServerLoadCombination>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..Storage <(Of <(<' ServerLoadCombination >)>)>
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination..::..LoadCombinationParameters

See Also

LoadCombinationParameters Members
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCombinationParameters Members

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationParameters Members
LoadCombinationParameters Class Methods Properties See Also Send Feedback

The LoadCombinationParameters type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadCases | Gets the load cases.
Public method | GetLoadCasesArray | Gets load cases array.
Public method | GetLoadCombinations | Gets load combinations.
Public method | GetServerStorageSchemaBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetServerStorageServerBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetLoadCases | Sets load cases.
Public method | SetLoadCombinations | Sets load combinations.
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerStorage | Adds the server data to storage. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Document | Gets or sets the document. (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ElementId | Gets or sets the Element (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ServersStorages | Gets or sets list of entities (for different servers) (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

LoadCombinationParameters Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCombinationParameters Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationParameters Methods
LoadCombinationParameters Class See Also Send Feedback

The LoadCombinationParameters type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadCases | Gets the load cases.
Public method | GetLoadCasesArray | Gets load cases array.
Public method | GetLoadCombinations | Gets load combinations.
Public method | GetServerStorageSchemaBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetServerStorageServerBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetLoadCases | Sets load cases.
Public method | SetLoadCombinations | Sets load combinations.
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerStorage | Adds the server data to storage. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LoadCombinationParameters Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


GetEntity Method

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationParameters..::..GetEntity Method
LoadCombinationParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

LoadCombinationParameters Class
LoadCombinationParameters Members
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


GetLoadCases Method

LoadCombinationParameters..::..GetLoadCases Method
LoadCombinationParameters Class See Also Send Feedback
Gets the load cases.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ElementId> GetLoadCases(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The server id.

Return Value

See Also

LoadCombinationParameters Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


GetLoadCasesArray Method

LoadCombinationParameters..::..GetLoadCasesArray Method
LoadCombinationParameters Class See Also Send Feedback
Gets load cases array.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LoadCaseArray GetLoadCasesArray(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The server id.

Return Value

See Also

LoadCombinationParameters Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


GetLoadCombinations Method

LoadCombinationParameters..::..GetLoadCombinations Method
LoadCombinationParameters Class See Also Send Feedback
Gets load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ElementId> GetLoadCombinations(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
The server id.

Return Value

See Also

LoadCombinationParameters Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


Replace Method

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationParameters..::..Replace Method
LoadCombinationParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

LoadCombinationParameters Class
LoadCombinationParameters Members
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


SetEntity Method

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationParameters..::..SetEntity Method
LoadCombinationParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

LoadCombinationParameters Class
LoadCombinationParameters Members
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


SetLoadCases Method

LoadCombinationParameters..::..SetLoadCases Method
LoadCombinationParameters Class See Also Send Feedback
Sets load cases.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetLoadCases(
    Guid serverId,
    List<ElementId> list
)

Parameters

serverId
Type: System..::..Guid
The server id.
list
Type: System.Collections.Generic..::..List <(Of <(<'ElementId>)>)>
The list.

See Also

LoadCombinationParameters Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


SetLoadCombinations Method

LoadCombinationParameters..::..SetLoadCombinations Method
LoadCombinationParameters Class See Also Send Feedback
Sets load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetLoadCombinations(
    Guid serverId,
    List<ElementId> list
)

Parameters

serverId
Type: System..::..Guid
The server id.
list
Type: System.Collections.Generic..::..List <(Of <(<'ElementId>)>)>
The list.

See Also

LoadCombinationParameters Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCombinationParameters Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationParameters Properties
LoadCombinationParameters Class See Also Send Feedback

The LoadCombinationParameters type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets or sets the document. (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ElementId | Gets or sets the Element (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ServersStorages | Gets or sets list of entities (for different servers) (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

LoadCombinationParameters Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


ServerLoadCombination Class

ServerLoadCombination Class
Members See Also Send Feedback
Represents label for specific server.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServerLoadCombination : ServerStorage

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerStorage
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination..::..ServerLoadCombination

See Also

ServerLoadCombination Members
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


ServerLoadCombination Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServerLoadCombination Members
ServerLoadCombination Class Constructors Methods Properties See Also Send Feedback

The ServerLoadCombination type exposes the following members.

Constructors

 | Name | Description
Public method | ServerLoadCombination()()()() | Initializes a new instance of the ServerLabel class.
Public method | ServerLoadCombination(Guid, Guid, Entity) | Initializes a new instance of the ServerLabel class.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Inherited from ServerStorage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Inherited from ServerStorage.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element. (Inherited from ServerStorage.)

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id. (Inherited from ServerStorage.)
Public property | Entity | Gets or sets the entity. (Inherited from ServerStorage.)
Public property | LoadCases | Load cases
Public property | LoadCombinations | Load combinations
Public property | Modified | Gets or sets a value indicating whether this Label was modified. (Inherited from ServerStorage.)
Public property | SchemaId | Gets or sets the schema id. (Inherited from ServerStorage.)
Public property | ServerId | Gets or sets the server id. (Inherited from ServerStorage.)
Public property | State | Gets or sets the state - used for checking modifications. (Inherited from ServerStorage.)

See Also

ServerLoadCombination Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


ServerLoadCombination Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ServerLoadCombination Constructor
ServerLoadCombination Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ServerLoadCombination()()()() | Initializes a new instance of the ServerLabel class.
Public method | ServerLoadCombination(Guid, Guid, Entity) | Initializes a new instance of the ServerLabel class.

See Also

ServerLoadCombination Class
ServerLoadCombination Members
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


ServerLoadCombination Constructor

ServerLoadCombination Constructor
ServerLoadCombination Class See Also Send Feedback
Initializes a new instance of the ServerLabel class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerLoadCombination()

See Also

ServerLoadCombination Class
ServerLoadCombination Overload
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


ServerLoadCombination Constructor (Guid, Guid, )

ServerLoadCombination Constructor (Guid, Guid, )
ServerLoadCombination Class See Also Send Feedback
Initializes a new instance of the ServerLabel class.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServerLoadCombination(
    Guid serverId,
    Guid schemaId,
    Entity entity
)

Parameters

serverId
Type: System..::..Guid
The server id.
schemaId
Type: System..::..Guid
The schema id.
entity
Type: Entity
The entity.

See Also

ServerLoadCombination Class
ServerLoadCombination Overload
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


ServerLoadCombination Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServerLoadCombination Methods
ServerLoadCombination Class See Also Send Feedback

The ServerLoadCombination type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Inherited from ServerStorage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Inherited from ServerStorage.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element. (Inherited from ServerStorage.)

See Also

ServerLoadCombination Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


ServerLoadCombination Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ServerLoadCombination Properties
ServerLoadCombination Class See Also Send Feedback

The ServerLoadCombination type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id. (Inherited from ServerStorage.)
Public property | Entity | Gets or sets the entity. (Inherited from ServerStorage.)
Public property | LoadCases | Load cases
Public property | LoadCombinations | Load combinations
Public property | Modified | Gets or sets a value indicating whether this Label was modified. (Inherited from ServerStorage.)
Public property | SchemaId | Gets or sets the schema id. (Inherited from ServerStorage.)
Public property | ServerId | Gets or sets the server id. (Inherited from ServerStorage.)
Public property | State | Gets or sets the state - used for checking modifications. (Inherited from ServerStorage.)

See Also

ServerLoadCombination Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCases Property

ServerLoadCombination..::..LoadCases Property
ServerLoadCombination Class See Also Send Feedback
Load cases

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ElementId> LoadCases { get; set; }

See Also

ServerLoadCombination Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


LoadCombinations Property

ServerLoadCombination..::..LoadCombinations Property
ServerLoadCombination Class See Also Send Feedback
Load combinations

Namespace: Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<ElementId> LoadCombinations { get; set; }

See Also

ServerLoadCombination Class
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination Namespace


Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace

Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace
Send Feedback

Classes

 | Class | Description
Public class | Attribute | Helper class for attributes management
Public class | DefaultFieldFormat | Provides default formating and parsing based on .NET mechanism.
Public class | DispatcherInstance | Represents dispatcher object
Public class | ElementFieldFormat | Provides formatting for Revit elements.
Public class | IntFieldFormat | Provides formating for integer numbers.
Public class | ListFieldFormat | Provides formatting for lists.
Public class | ListUnitFieldFormat | Provides formating for lists with unit dependent items.
Public class | SchemaClass | Represents the class which is a base class for all classes which definition is used to built Revit schemas.
Public class | Settings | Represents setting
Public class | UnitFieldFormat | Provides formatting for fields with unit dependent items.
Public class | UnitUtilsExt | This class provides tools for units conversion.
Public class | XYZFieldFormat | Provides formatting for XYZ structure.

Interfaces

 | Interface | Description
Public interface | IFieldFormat | Base interface for format classes.
Public interface | IFieldToPropertyConverter | Describes conversion between the field in the entity and property in the class.
Public interface | IResource | Base interface for all resource providers.


Attribute Class

Attribute Class
Members See Also Send Feedback
Helper class for attributes management

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static class Attribute

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..Attribute

See Also

Attribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Attribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
Attribute Members
Attribute Class Methods See Also Send Feedback

Methods

Name | Description
GetAttribute<(Of <<'(TAttribute>)>>)(PropertyInfo) | Gets the attribute of specific type assigned to the property.
GetAttribute<(Of <<'(TAttribute>)>>)(Type) | Gets the attribute of specific type assigned to the input type.
GetAttributes<(Of <<'(TAttribute>)>>)(PropertyInfo) | Gets the list of attributes of specific type assigned to the property.
GetAttributes<(Of <<'(TAttribute>)>>)(Type) | Gets the list of attributes of specific type assigned to the input type.

See Also

Attribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Attribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Attribute Methods
Attribute Class See Also Send Feedback

Methods

Name | Description
GetAttribute<(Of <<'(TAttribute>)>>)(PropertyInfo) | Gets the attribute of specific type assigned to the property.
GetAttribute<(Of <<'(TAttribute>)>>)(Type) | Gets the attribute of specific type assigned to the input type.
GetAttributes<(Of <<'(TAttribute>)>>)(PropertyInfo) | Gets the list of attributes of specific type assigned to the property.
GetAttributes<(Of <<'(TAttribute>)>>)(Type) | Gets the list of attributes of specific type assigned to the input type.

See Also

Attribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetAttribute Method

[image]

Structural Analysis and Code Checking API Reference Guide
Attribute..::..GetAttribute Method
Attribute Class See Also Send Feedback

Overload List

Name | Description
GetAttribute<(Of <<'(TAttribute>)>>)(PropertyInfo) | Gets the attribute of specific type assigned to the property.
GetAttribute<(Of <<'(TAttribute>)>>)(Type) | Gets the attribute of specific type assigned to the input type.

See Also

Attribute Class
Attribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetAttribute(TAttribute) Method (PropertyInfo)

Attribute..::..GetAttribute<(Of <(<'TAttribute>)>)> Method (PropertyInfo)
Attribute Class See Also Send Feedback
Gets the attribute of specific type assigned to the property.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static TAttribute GetAttribute<TAttribute>(
    PropertyInfo propertyInfo
)

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo
The property information.

Type Parameters

TAttribute
The type of the attribute.

Return Value

See Also

Attribute Class
GetAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetAttribute(TAttribute) Method (Type)

Attribute..::..GetAttribute<(Of <(<'TAttribute>)>)> Method (Type)
Attribute Class See Also Send Feedback
Gets the attribute of specific type assigned to the input type.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static TAttribute GetAttribute<TAttribute>(
    Type type
)

Parameters

type
Type: System..::..Type
The type to which the attribute is assigned to.

Type Parameters

TAttribute
The type of the attribute.

Return Value

See Also

Attribute Class
GetAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetAttributes Method

[image]

Structural Analysis and Code Checking API Reference Guide
Attribute..::..GetAttributes Method
Attribute Class See Also Send Feedback

Overload List

Name | Description
GetAttributes<(Of <<'(TAttribute>)>>)(PropertyInfo) | Gets the list of attributes of specific type assigned to the property.
GetAttributes<(Of <<'(TAttribute>)>>)(Type) | Gets the list of attributes of specific type assigned to the input type.

See Also

Attribute Class
Attribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetAttributes(TAttribute) Method (PropertyInfo)

Attribute..::..GetAttributes<(Of <(<'TAttribute>)>)> Method (PropertyInfo)
Attribute Class See Also Send Feedback
Gets the list of attributes of specific type assigned to the property.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<TAttribute> GetAttributes<TAttribute>(
    PropertyInfo propertyInfo
)

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo
The property information.

Type Parameters

TAttribute
The type of the attribute.

Return Value

See Also

Attribute Class
GetAttributes Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetAttributes(TAttribute) Method (Type)

Attribute..::..GetAttributes<(Of <(<'TAttribute>)>)> Method (Type)
Attribute Class See Also Send Feedback
Gets the list of attributes of specific type assigned to the input type.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<TAttribute> GetAttributes<TAttribute>(
    Type type
)

Parameters

type
Type: System..::..Type
The type which should have the attribute.

Type Parameters

TAttribute
The type of the attribute.

Return Value

See Also

Attribute Class
GetAttributes Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DefaultFieldFormat Class

DefaultFieldFormat Class
Members See Also Send Feedback
Provides default formating and parsing based on .NET mechanism.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public sealed class DefaultFieldFormat : IFieldFormat

Remarks

In case of formating ToString() method is used. In case of parsing ChangeType() from System.Convert class is used.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..DefaultFieldFormat

See Also

DefaultFieldFormat Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DefaultFieldFormat Members

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultFieldFormat Members
DefaultFieldFormat Class Constructors Methods Properties See Also Send Feedback

The DefaultFieldFormat type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultFieldFormat()()()() | Initializes a new instance of the DefaultFieldFormat class.
Public method | DefaultFieldFormat(Type) | Initializes a new instance of the DefaultFieldFormat class.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InputType | Gets or sets the type of the input.

See Also

DefaultFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DefaultFieldFormat Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultFieldFormat Constructor
DefaultFieldFormat Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DefaultFieldFormat()()()() | Initializes a new instance of the DefaultFieldFormat class.
Public method | DefaultFieldFormat(Type) | Initializes a new instance of the DefaultFieldFormat class.

See Also

DefaultFieldFormat Class
DefaultFieldFormat Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DefaultFieldFormat Constructor

DefaultFieldFormat Constructor
DefaultFieldFormat Class See Also Send Feedback
Initializes a new instance of the DefaultFieldFormat class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DefaultFieldFormat()

See Also

DefaultFieldFormat Class
DefaultFieldFormat Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DefaultFieldFormat Constructor (Type)

DefaultFieldFormat Constructor (Type)
DefaultFieldFormat Class See Also Send Feedback
Initializes a new instance of the DefaultFieldFormat class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DefaultFieldFormat(
    Type type
)

Parameters

type
Type: System..::..Type
The type.

See Also

DefaultFieldFormat Class
DefaultFieldFormat Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DefaultFieldFormat Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultFieldFormat Methods
DefaultFieldFormat Class See Also Send Feedback

The DefaultFieldFormat type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefaultFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Convert Method

DefaultFieldFormat..::..Convert Method
DefaultFieldFormat Class See Also Send Feedback
Converts the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Convert(
    Object value,
    UnitType unitType,
    DisplayUnitType inputUnitType,
    DisplayUnitType outputUnitType
)

Parameters

value
Type: System..::..Object
The value.
unitType
Type: UnitType
Type of the unit.
inputUnitType
Type: DisplayUnitType
Type of the input unit.
outputUnitType
Type: DisplayUnitType
Type of the output unit.

Return Value

Implements

IFieldFormat..::..Convert(Object, UnitType, DisplayUnitType, DisplayUnitType)

See Also

DefaultFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Format Method

DefaultFieldFormat..::..Format Method
DefaultFieldFormat Class See Also Send Feedback
Formats the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Format(
    Object value,
    Document document,
    UnitType unitType,
    DisplayUnitType inputDisplayUnitType,
    bool edit
)

Parameters

value
Type: System..::..Object
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
inputDisplayUnitType
Type: DisplayUnitType
Type of the input display unit.
edit
Type: System..::..Boolean
if set to true [edit].

Return Value

Implements

IFieldFormat..::..Format(Object, Document, UnitType, DisplayUnitType, Boolean)

See Also

DefaultFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Parse Method

DefaultFieldFormat..::..Parse Method
DefaultFieldFormat Class See Also Send Feedback
Parses the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Parse(
    string value,
    Document document,
    UnitType unitType,
    DisplayUnitType outputDisplayUnitType
)

Parameters

value
Type: System..::..String
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
outputDisplayUnitType
Type: DisplayUnitType
Type of the output display unit.

Return Value

Implements

IFieldFormat..::..Parse(String, Document, UnitType, DisplayUnitType)

See Also

DefaultFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DefaultFieldFormat Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultFieldFormat Properties
DefaultFieldFormat Class See Also Send Feedback

The DefaultFieldFormat type exposes the following members.

Properties

 | Name | Description
Public property | InputType | Gets or sets the type of the input.

See Also

DefaultFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


InputType Property

DefaultFieldFormat..::..InputType Property
DefaultFieldFormat Class See Also Send Feedback
Gets or sets the type of the input.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type InputType { get; set; }

Field Value

The type of the input.

See Also

DefaultFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DispatcherInstance Class

DispatcherInstance Class
Members See Also Send Feedback
Represents dispatcher object

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DispatcherInstance : DispatcherObject

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..DispatcherInstance

See Also

DispatcherInstance Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DispatcherInstance Members

[image]

Structural Analysis and Code Checking API Reference Guide
DispatcherInstance Members
DispatcherInstance Class Methods Properties See Also Send Feedback

The DispatcherInstance type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
 | DestroyDispatcherInstance | Initializes the dispatcher instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeDispatcherInstance | Initializes the dispatcher instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
 | Instance | Gets the instance of dispatcher.

See Also

DispatcherInstance Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DispatcherInstance Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DispatcherInstance Methods
DispatcherInstance Class See Also Send Feedback

The DispatcherInstance type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
 | DestroyDispatcherInstance | Initializes the dispatcher instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeDispatcherInstance | Initializes the dispatcher instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

DispatcherInstance Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DestroyDispatcherInstance Method

DispatcherInstance..::..DestroyDispatcherInstance Method
DispatcherInstance Class See Also Send Feedback
Initializes the dispatcher instance.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void DestroyDispatcherInstance()

See Also

DispatcherInstance Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


InitializeDispatcherInstance Method

DispatcherInstance..::..InitializeDispatcherInstance Method
DispatcherInstance Class See Also Send Feedback
Initializes the dispatcher instance.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void InitializeDispatcherInstance()

See Also

DispatcherInstance Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


DispatcherInstance Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DispatcherInstance Properties
DispatcherInstance Class See Also Send Feedback

The DispatcherInstance type exposes the following members.

Properties

 | Name | Description
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
 | Instance | Gets the instance of dispatcher.

See Also

DispatcherInstance Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Instance Property

DispatcherInstance..::..Instance Property
DispatcherInstance Class See Also Send Feedback
Gets the instance of dispatcher.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DispatcherInstance Instance { get; }

See Also

DispatcherInstance Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ElementFieldFormat Class

ElementFieldFormat Class
Members See Also Send Feedback
Provides formatting for Revit elements.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementFieldFormat : IFieldFormat

Remarks

The only method that matters here is Format which takes the name of the element. Parsing returns null.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..ElementFieldFormat

See Also

ElementFieldFormat Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ElementFieldFormat Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementFieldFormat Members
ElementFieldFormat Class Constructors Methods See Also Send Feedback

The ElementFieldFormat type exposes the following members.

Constructors

 | Name | Description
Public method | ElementFieldFormat | Initializes a new instance of the ElementFieldFormat class

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ElementFieldFormat Constructor

ElementFieldFormat Constructor
ElementFieldFormat Class See Also Send Feedback
Initializes a new instance of the ElementFieldFormat class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementFieldFormat()

See Also

ElementFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ElementFieldFormat Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ElementFieldFormat Methods
ElementFieldFormat Class See Also Send Feedback

The ElementFieldFormat type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Convert Method

ElementFieldFormat..::..Convert Method
ElementFieldFormat Class See Also Send Feedback
Converts the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Convert(
    Object value,
    UnitType unitType,
    DisplayUnitType inputUnitType,
    DisplayUnitType outputUnitType
)

Parameters

value
Type: System..::..Object
The value.
unitType
Type: UnitType
Type of the unit.
inputUnitType
Type: DisplayUnitType
Type of the input unit.
outputUnitType
Type: DisplayUnitType
Type of the output unit.

Return Value

Implements

IFieldFormat..::..Convert(Object, UnitType, DisplayUnitType, DisplayUnitType)

See Also

ElementFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Format Method

ElementFieldFormat..::..Format Method
ElementFieldFormat Class See Also Send Feedback
Formats the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Format(
    Object value,
    Document document,
    UnitType unitType,
    DisplayUnitType inputDisplayUnitType,
    bool edit
)

Parameters

value
Type: System..::..Object
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
inputDisplayUnitType
Type: DisplayUnitType
The input unit type.
edit
Type: System..::..Boolean
if set to true [edit].

Return Value

Implements

IFieldFormat..::..Format(Object, Document, UnitType, DisplayUnitType, Boolean)

See Also

ElementFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Parse Method

ElementFieldFormat..::..Parse Method
ElementFieldFormat Class See Also Send Feedback
Parses the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Parse(
    string value,
    Document document,
    UnitType unitType,
    DisplayUnitType outputDisplayUnitType
)

Parameters

value
Type: System..::..String
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
outputDisplayUnitType
Type: DisplayUnitType
The output unit type.

Return Value

Implements

IFieldFormat..::..Parse(String, Document, UnitType, DisplayUnitType)

Remarks

Returns null in case of elements.

See Also

ElementFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IFieldFormat Interface

IFieldFormat Interface
Members See Also Send Feedback
Base interface for format classes.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IFieldFormat

See Also

IFieldFormat Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IFieldFormat Members

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldFormat Members
IFieldFormat Interface Methods See Also Send Feedback

The IFieldFormat type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Format | Formats the specified value.
Public method | Parse | Parses the specified value.

See Also

IFieldFormat Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IFieldFormat Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldFormat Methods
IFieldFormat Interface See Also Send Feedback

The IFieldFormat type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Format | Formats the specified value.
Public method | Parse | Parses the specified value.

See Also

IFieldFormat Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Convert Method

IFieldFormat..::..Convert Method
IFieldFormat Interface See Also Send Feedback
Converts the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Object Convert(
    Object value,
    UnitType unitType,
    DisplayUnitType inputUnitType,
    DisplayUnitType outputUnitType
)

Parameters

value
Type: System..::..Object
The value.
unitType
Type: UnitType
Type of the unit.
inputUnitType
Type: DisplayUnitType
Type of the input unit.
outputUnitType
Type: DisplayUnitType
Type of the output unit.

Return Value

See Also

IFieldFormat Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Format Method

IFieldFormat..::..Format Method
IFieldFormat Interface See Also Send Feedback
Formats the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
string Format(
    Object value,
    Document document,
    UnitType unitType,
    DisplayUnitType inputDisplayUnitType,
    bool edit
)

Parameters

value
Type: System..::..Object
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
inputDisplayUnitType
Type: DisplayUnitType
Type of the input display unit.
edit
Type: System..::..Boolean
if set to true for edit purpose.

Return Value

See Also

IFieldFormat Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Parse Method

IFieldFormat..::..Parse Method
IFieldFormat Interface See Also Send Feedback
Parses the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Object Parse(
    string value,
    Document document,
    UnitType unitType,
    DisplayUnitType outputDisplayUnitType
)

Parameters

value
Type: System..::..String
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
outputDisplayUnitType
Type: DisplayUnitType
Type of the output display unit.

Return Value

See Also

IFieldFormat Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IFieldToPropertyConverter Interface

IFieldToPropertyConverter Interface
Members Example See Also Send Feedback
Describes conversion between the field in the entity and property in the class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IFieldToPropertyConverter

Examples

The example shows the converter which provides converstion between List<int> and DateTime (which is not supported by Extensible Storage)
CopyC#
 public class DateTimeConverter : IFieldToPropertyConverter
 {
     public object ConvertEntityFieldValToPropertyVal(object entityFieldValue)
     {
         IList<int> loaded = entityFieldValue as IList<int>;
         return new DateTime(loaded[0], loaded[1], loaded[2]);
     }

     public object ConvertPropertyValToEntityFieldVal(object propertyValue)
     {
         DateTime dt = (DateTime)propertyValue;
         return new List<int>() { dt.Year, dt.Month, dt.Day };
     }
}

See Also

IFieldToPropertyConverter Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IFieldToPropertyConverter Members

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldToPropertyConverter Members
IFieldToPropertyConverter Interface Methods See Also Send Feedback

The IFieldToPropertyConverter type exposes the following members.

Methods

 | Name | Description
Public method | ConvertEntityFieldValToPropertyVal | Converts value of the field in the entity to the value of the class property.
Public method | ConvertPropertyValToEntityFieldVal | Converts value of the class property to the value of the field in the entity.

See Also

IFieldToPropertyConverter Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IFieldToPropertyConverter Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldToPropertyConverter Methods
IFieldToPropertyConverter Interface See Also Send Feedback

The IFieldToPropertyConverter type exposes the following members.

Methods

 | Name | Description
Public method | ConvertEntityFieldValToPropertyVal | Converts value of the field in the entity to the value of the class property.
Public method | ConvertPropertyValToEntityFieldVal | Converts value of the class property to the value of the field in the entity.

See Also

IFieldToPropertyConverter Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ConvertEntityFieldValToPropertyVal Method

IFieldToPropertyConverter..::..ConvertEntityFieldValToPropertyVal Method
IFieldToPropertyConverter Interface See Also Send Feedback
Converts value of the field in the entity to the value of the class property.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Object ConvertEntityFieldValToPropertyVal(
    Object entityFieldValue
)

Parameters

entityFieldValue
Type: System..::..Object
The entity field value.

Return Value

The property value.

See Also

IFieldToPropertyConverter Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ConvertPropertyValToEntityFieldVal Method

IFieldToPropertyConverter..::..ConvertPropertyValToEntityFieldVal Method
IFieldToPropertyConverter Interface See Also Send Feedback
Converts value of the class property to the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Object ConvertPropertyValToEntityFieldVal(
    Object propertyValue
)

Parameters

propertyValue
Type: System..::..Object
The property value.

Return Value

The field value.

See Also

IFieldToPropertyConverter Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IntFieldFormat Class

IntFieldFormat Class
Members See Also Send Feedback
Provides formating for integer numbers.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class IntFieldFormat : IFieldFormat

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IntFieldFormat

See Also

IntFieldFormat Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IntFieldFormat Members

[image]

Structural Analysis and Code Checking API Reference Guide
IntFieldFormat Members
IntFieldFormat Class Constructors Methods See Also Send Feedback

The IntFieldFormat type exposes the following members.

Constructors

 | Name | Description
Public method | IntFieldFormat | Initializes a new instance of the IntFieldFormat class

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

IntFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IntFieldFormat Constructor

IntFieldFormat Constructor
IntFieldFormat Class See Also Send Feedback
Initializes a new instance of the IntFieldFormat class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IntFieldFormat()

See Also

IntFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IntFieldFormat Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IntFieldFormat Methods
IntFieldFormat Class See Also Send Feedback

The IntFieldFormat type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

IntFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Convert Method

IntFieldFormat..::..Convert Method
IntFieldFormat Class See Also Send Feedback
Converts the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Convert(
    Object value,
    UnitType unitType,
    DisplayUnitType inputUnitType,
    DisplayUnitType outputUnitType
)

Parameters

value
Type: System..::..Object
The value.
unitType
Type: UnitType
Type of the unit.
inputUnitType
Type: DisplayUnitType
Type of the input unit.
outputUnitType
Type: DisplayUnitType
Type of the output unit.

Return Value

Implements

IFieldFormat..::..Convert(Object, UnitType, DisplayUnitType, DisplayUnitType)

See Also

IntFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Format Method

IntFieldFormat..::..Format Method
IntFieldFormat Class See Also Send Feedback
Formats the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Format(
    Object value,
    Document document,
    UnitType unitType,
    DisplayUnitType inputDisplayUnitType,
    bool edit
)

Parameters

value
Type: System..::..Object
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
inputDisplayUnitType
Type: DisplayUnitType
Type of the input display unit.
edit
Type: System..::..Boolean
if set to true [edit].

Return Value

Implements

IFieldFormat..::..Format(Object, Document, UnitType, DisplayUnitType, Boolean)

See Also

IntFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Parse Method

IntFieldFormat..::..Parse Method
IntFieldFormat Class See Also Send Feedback
Parses the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Parse(
    string value,
    Document document,
    UnitType unitType,
    DisplayUnitType outputDisplayUnitType
)

Parameters

value
Type: System..::..String
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
outputDisplayUnitType
Type: DisplayUnitType
Type of the output display unit.

Return Value

Implements

IFieldFormat..::..Parse(String, Document, UnitType, DisplayUnitType)

See Also

IntFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IResource Interface

IResource Interface
Members See Also Send Feedback
Base interface for all resource providers.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IResource

See Also

IResource Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IResource Members

[image]

Structural Analysis and Code Checking API Reference Guide
IResource Members
IResource Interface Methods See Also Send Feedback

The IResource type exposes the following members.

Methods

 | Name | Description
Public method | GetResource | Gets the text resource.
Public method | GetResourceImage | Gets the image resource.

See Also

IResource Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


IResource Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IResource Methods
IResource Interface See Also Send Feedback

The IResource type exposes the following members.

Methods

 | Name | Description
Public method | GetResource | Gets the text resource.
Public method | GetResourceImage | Gets the image resource.

See Also

IResource Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetResource Method

IResource..::..GetResource Method
IResource Interface See Also Send Feedback
Gets the text resource.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
string GetResource(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

See Also

IResource Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetResourceImage Method

IResource..::..GetResourceImage Method
IResource Interface See Also Send Feedback
Gets the image resource.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Uri GetResourceImage(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

The image resource.

See Also

IResource Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListFieldFormat Class

ListFieldFormat Class
Members See Also Send Feedback
Provides formatting for lists.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ListFieldFormat : IFieldFormat

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..ListFieldFormat

See Also

ListFieldFormat Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListFieldFormat Members

[image]

Structural Analysis and Code Checking API Reference Guide
ListFieldFormat Members
ListFieldFormat Class Constructors Methods Properties See Also Send Feedback

The ListFieldFormat type exposes the following members.

Constructors

 | Name | Description
Public method | ListFieldFormat | Initializes a new instance of the ListFieldFormat class.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InputType | Gets or sets the type of list items.
Public property | ListSeparator | Gets or sets the list separator for formatting purpose.

See Also

ListFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListFieldFormat Constructor

ListFieldFormat Constructor
ListFieldFormat Class See Also Send Feedback
Initializes a new instance of the ListFieldFormat class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ListFieldFormat(
    Type type
)

Parameters

type
Type: System..::..Type
The type.

See Also

ListFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListFieldFormat Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ListFieldFormat Methods
ListFieldFormat Class See Also Send Feedback

The ListFieldFormat type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ListFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Convert Method

ListFieldFormat..::..Convert Method
ListFieldFormat Class See Also Send Feedback
Converts the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Convert(
    Object value,
    UnitType unitType,
    DisplayUnitType inputUnitType,
    DisplayUnitType outputUnitType
)

Parameters

value
Type: System..::..Object
The value.
unitType
Type: UnitType
Type of the unit.
inputUnitType
Type: DisplayUnitType
Type of the input unit.
outputUnitType
Type: DisplayUnitType
Type of the output unit.

Return Value

Implements

IFieldFormat..::..Convert(Object, UnitType, DisplayUnitType, DisplayUnitType)

See Also

ListFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Format Method

ListFieldFormat..::..Format Method
ListFieldFormat Class See Also Send Feedback
Formats the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Format(
    Object value,
    Document document,
    UnitType unitType,
    DisplayUnitType inputDisplayUnitType,
    bool edit
)

Parameters

value
Type: System..::..Object
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
inputDisplayUnitType
Type: DisplayUnitType
Type of the input display unit.
edit
Type: System..::..Boolean
if set to true [edit].

Return Value

Implements

IFieldFormat..::..Format(Object, Document, UnitType, DisplayUnitType, Boolean)

See Also

ListFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Parse Method

ListFieldFormat..::..Parse Method
ListFieldFormat Class See Also Send Feedback
Parses the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Parse(
    string value,
    Document document,
    UnitType unitType,
    DisplayUnitType outputDisplayUnitType
)

Parameters

value
Type: System..::..String
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
outputDisplayUnitType
Type: DisplayUnitType
Type of the output display unit.

Return Value

Implements

IFieldFormat..::..Parse(String, Document, UnitType, DisplayUnitType)

See Also

ListFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListFieldFormat Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ListFieldFormat Properties
ListFieldFormat Class See Also Send Feedback

The ListFieldFormat type exposes the following members.

Properties

 | Name | Description
Public property | InputType | Gets or sets the type of list items.
Public property | ListSeparator | Gets or sets the list separator for formatting purpose.

See Also

ListFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


InputType Property

ListFieldFormat..::..InputType Property
ListFieldFormat Class See Also Send Feedback
Gets or sets the type of list items.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type InputType { get; set; }

Field Value

The type.

See Also

ListFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListSeparator Property

ListFieldFormat..::..ListSeparator Property
ListFieldFormat Class See Also Send Feedback
Gets or sets the list separator for formatting purpose.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string ListSeparator { get; set; }

Field Value

The list separator.

Remarks

The default value is ";"

See Also

ListFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListUnitFieldFormat Class

ListUnitFieldFormat Class
Members See Also Send Feedback
Provides formating for lists with unit dependent items.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ListUnitFieldFormat : IFieldFormat

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..ListUnitFieldFormat

See Also

ListUnitFieldFormat Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListUnitFieldFormat Members

[image]

Structural Analysis and Code Checking API Reference Guide
ListUnitFieldFormat Members
ListUnitFieldFormat Class Constructors Methods Properties See Also Send Feedback

The ListUnitFieldFormat type exposes the following members.

Constructors

 | Name | Description
Public method | ListUnitFieldFormat | Initializes a new instance of the ListUnitFieldFormat class.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ListSeparator | Gets or sets the list separator.
Public property | UnitOnEnd | Gets or sets a value indicating whether unit should be added to the end of formated text.

See Also

ListUnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListUnitFieldFormat Constructor

ListUnitFieldFormat Constructor
ListUnitFieldFormat Class See Also Send Feedback
Initializes a new instance of the ListUnitFieldFormat class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ListUnitFieldFormat()

See Also

ListUnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListUnitFieldFormat Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ListUnitFieldFormat Methods
ListUnitFieldFormat Class See Also Send Feedback

The ListUnitFieldFormat type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ListUnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Convert Method

ListUnitFieldFormat..::..Convert Method
ListUnitFieldFormat Class See Also Send Feedback
Converts the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Convert(
    Object value,
    UnitType unitType,
    DisplayUnitType inputDispUnitType,
    DisplayUnitType outputDispUnitType
)

Parameters

value
Type: System..::..Object
The value.
unitType
Type: UnitType
Type of the unit.
inputDispUnitType
Type: DisplayUnitType
Type of the input disp unit.
outputDispUnitType
Type: DisplayUnitType
Type of the output disp unit.

Return Value

Implements

IFieldFormat..::..Convert(Object, UnitType, DisplayUnitType, DisplayUnitType)

See Also

ListUnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Format Method

ListUnitFieldFormat..::..Format Method
ListUnitFieldFormat Class See Also Send Feedback
Formats the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Format(
    Object value,
    Document document,
    UnitType unitType,
    DisplayUnitType inputDisplayUnitType,
    bool edit
)

Parameters

value
Type: System..::..Object
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
inputDisplayUnitType
Type: DisplayUnitType
The input unit type.
edit
Type: System..::..Boolean
if set to true [edit].

Return Value

Implements

IFieldFormat..::..Format(Object, Document, UnitType, DisplayUnitType, Boolean)

See Also

ListUnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Parse Method

ListUnitFieldFormat..::..Parse Method
ListUnitFieldFormat Class See Also Send Feedback
Parses the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Parse(
    string value,
    Document document,
    UnitType unitType,
    DisplayUnitType outputDisplayUnitType
)

Parameters

value
Type: System..::..String
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
outputDisplayUnitType
Type: DisplayUnitType
The output unit type.

Return Value

Implements

IFieldFormat..::..Parse(String, Document, UnitType, DisplayUnitType)

See Also

ListUnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListUnitFieldFormat Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ListUnitFieldFormat Properties
ListUnitFieldFormat Class See Also Send Feedback

The ListUnitFieldFormat type exposes the following members.

Properties

 | Name | Description
Public property | ListSeparator | Gets or sets the list separator.
Public property | UnitOnEnd | Gets or sets a value indicating whether unit should be added to the end of formated text.

See Also

ListUnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ListSeparator Property

ListUnitFieldFormat..::..ListSeparator Property
ListUnitFieldFormat Class See Also Send Feedback
Gets or sets the list separator.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string ListSeparator { get; set; }

Field Value

The list separator.

See Also

ListUnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


UnitOnEnd Property

ListUnitFieldFormat..::..UnitOnEnd Property
ListUnitFieldFormat Class See Also Send Feedback
Gets or sets a value indicating whether unit should be added to the end of formated text.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool UnitOnEnd { get; set; }

Field Value

true if unit on end; otherwise, false.

See Also

ListUnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SchemaClass Class

SchemaClass Class
Members Example See Also Send Feedback
Represents the class which is a base class for all classes which definition is used to built Revit schemas.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SchemaClass : ICloneable

Examples

CopyC#
[Schema("schema","1E578722-BFF5-4496-B436-CB6C659D93DF","F6F790AF-1762-441D-9AFF-9C822D346E5F")]
public class Class1:SchemaClass
{
   public double ValueNotForSchema { get; set; }

   [SchemaProperty(FieldName = "A",Unit = UnitType.UT_Length, DisplayUnit = DisplayUnitType.DUT_METERS)]
   public double ValueForSchema { get; set; }
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatus
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusList
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusMessage
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusMessageItem
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerData
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerPackage
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerStorage
Autodesk.Revit.DB.CodeChecking.Storage..::..Storage<(Of <(<'T>)>)>

See Also

SchemaClass Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SchemaClass Members

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaClass Members
SchemaClass Class Constructors Methods See Also Send Feedback

The SchemaClass type exposes the following members.

Constructors

 | Name | Description
Public method | SchemaClass()()()() | Initializes the instance of SchemaClass.
Public method | SchemaClass(Element) | Initializes the instance of SchemaClass based on the Revit element.
Public method | SchemaClass(Entity, Document) | Initializes the instance of SchemaClass based on the Entity.

Methods

 | Name | Description
 | BuildSchema | Generates schema based on class definition.
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element.
Public method | FillEntity | Fills entity based on this instance.
 | GetBaseType(PropertyInfo, ContainerType%, Type%) | Gets the base type of the property.
 | GetBaseType(Type, ContainerType%, Type%) | Gets the base type of the property.
 | GetBaseTypeForSchema(PropertyInfo, ContainerType%, Type%) | Gets the base type for schema.
 | GetBaseTypeForSchema(Type, ContainerType%, Type%) | Gets the base type for schema.
Public method | GetEntity | Returns the entity based on this instance.
 | GetFieldName | Gets the name of the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeForSchema | Gets the type for the schema.
 | GetTypeOfSchemaId | Gets the type of specific schema id.
 | GetValue(Entity, Field, DisplayUnitType) | Returns the value of specific field.
 | GetValue(Entity, String, DisplayUnitType) | Returns the value of specific field.
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute.
Public method | Load | Loads data from Revit element.
Public method | LoadField | Loads the property in a special way (otherwise returns false).
Public method | PostLoad | Called after loading the instance.
Public method | PostSave | Called after saving the instance.
Public method | PreLoad | Called before loading the instance.
Public method | PreSave | Called before saving the instance.
Public method | Remove | Removes data from element.
Public method | Save | Saves data to Revit element.
Public method | SaveField | Saves the property in a special way (otherwise returns false)
 | SetEntityParamBased | Sets values of fields in entity based on properties of the input object.
 | SetParamsEntityBased | Sets properties of the object based on fields of the entity.
Public method | SetProperties | Sets properties of this instance based on the entity.
 | SetValue(Entity, Field, Object, DisplayUnitType) | Sets the value of the specific field.
 | SetValue(Entity, String, Object, DisplayUnitType) | Sets the value of the specific field.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SchemaClass Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaClass Constructor
SchemaClass Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SchemaClass()()()() | Initializes the instance of SchemaClass.
Public method | SchemaClass(Element) | Initializes the instance of SchemaClass based on the Revit element.
Public method | SchemaClass(Entity, Document) | Initializes the instance of SchemaClass based on the Entity.

See Also

SchemaClass Class
SchemaClass Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SchemaClass Constructor

SchemaClass Constructor
SchemaClass Class See Also Send Feedback
Initializes the instance of SchemaClass.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SchemaClass()

See Also

SchemaClass Class
SchemaClass Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SchemaClass Constructor ()

SchemaClass Constructor ()
SchemaClass Class See Also Send Feedback
Initializes the instance of SchemaClass based on the Revit element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SchemaClass(
    Element element
)

Parameters

element
Type: Element
The Revit element.

See Also

SchemaClass Class
SchemaClass Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SchemaClass Constructor (, )

SchemaClass Constructor (, )
SchemaClass Class See Also Send Feedback
Initializes the instance of SchemaClass based on the Entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SchemaClass(
    Entity entity,
    Document document
)

Parameters

entity
Type: Entity
The entity.
document
Type: Document
The document.

See Also

SchemaClass Class
SchemaClass Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SchemaClass Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaClass Methods
SchemaClass Class See Also Send Feedback

The SchemaClass type exposes the following members.

Methods

 | Name | Description
 | BuildSchema | Generates schema based on class definition.
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element.
Public method | FillEntity | Fills entity based on this instance.
 | GetBaseType(PropertyInfo, ContainerType%, Type%) | Gets the base type of the property.
 | GetBaseType(Type, ContainerType%, Type%) | Gets the base type of the property.
 | GetBaseTypeForSchema(PropertyInfo, ContainerType%, Type%) | Gets the base type for schema.
 | GetBaseTypeForSchema(Type, ContainerType%, Type%) | Gets the base type for schema.
Public method | GetEntity | Returns the entity based on this instance.
 | GetFieldName | Gets the name of the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeForSchema | Gets the type for the schema.
 | GetTypeOfSchemaId | Gets the type of specific schema id.
 | GetValue(Entity, Field, DisplayUnitType) | Returns the value of specific field.
 | GetValue(Entity, String, DisplayUnitType) | Returns the value of specific field.
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute.
Public method | Load | Loads data from Revit element.
Public method | LoadField | Loads the property in a special way (otherwise returns false).
Public method | PostLoad | Called after loading the instance.
Public method | PostSave | Called after saving the instance.
Public method | PreLoad | Called before loading the instance.
Public method | PreSave | Called before saving the instance.
Public method | Remove | Removes data from element.
Public method | Save | Saves data to Revit element.
Public method | SaveField | Saves the property in a special way (otherwise returns false)
 | SetEntityParamBased | Sets values of fields in entity based on properties of the input object.
 | SetParamsEntityBased | Sets properties of the object based on fields of the entity.
Public method | SetProperties | Sets properties of this instance based on the entity.
 | SetValue(Entity, Field, Object, DisplayUnitType) | Sets the value of the specific field.
 | SetValue(Entity, String, Object, DisplayUnitType) | Sets the value of the specific field.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


BuildSchema Method

SchemaClass..::..BuildSchema Method
SchemaClass Class See Also Send Feedback
Generates schema based on class definition.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Schema BuildSchema(
    Type type
)

Parameters

type
Type: System..::..Type
The type based on which schema will be created.

Return Value

The new schema.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Clone Method

SchemaClass..::..Clone Method
SchemaClass Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Object Clone()

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Exists Method

SchemaClass..::..Exists Method
SchemaClass Class See Also Send Feedback
Checks if data of this class exists in the element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Exists(
    Element element
)

Parameters

element
Type: Element
The Revit element.

Return Value

If data exists.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


FillEntity Method

SchemaClass..::..FillEntity Method
SchemaClass Class See Also Send Feedback
Fills entity based on this instance.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void FillEntity(
    Entity entity
)

Parameters

entity
Type: Entity
The entity.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetBaseType Method

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaClass..::..GetBaseType Method
SchemaClass Class See Also Send Feedback

Overload List

Name | Description
GetBaseType(PropertyInfo, ContainerType%, Type%) | Gets the base type of the property.
GetBaseType(Type, ContainerType%, Type%) | Gets the base type of the property.

See Also

SchemaClass Class
SchemaClass Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetBaseType Method (PropertyInfo, , Type)

SchemaClass..::..GetBaseType Method (PropertyInfo, %, Type%)
SchemaClass Class See Also Send Feedback
Gets the base type of the property.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetBaseType(
    PropertyInfo propertyInfo,
    out ContainerType containerType,
    out Type keyType
)

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo
The property info.
containerType
Type: ContainerType%
Type of the container.
keyType
Type: System..::..Type %
Type of the key.

Return Value

See Also

SchemaClass Class
GetBaseType Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetBaseType Method (Type, , Type)

SchemaClass..::..GetBaseType Method (Type, %, Type%)
SchemaClass Class See Also Send Feedback
Gets the base type of the property.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetBaseType(
    Type type,
    out ContainerType containerType,
    out Type keyType
)

Parameters

type
Type: System..::..Type
The type.
containerType
Type: ContainerType%
Type of the container.
keyType
Type: System..::..Type %
Type of the key.

Return Value

See Also

SchemaClass Class
GetBaseType Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetBaseTypeForSchema Method

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaClass..::..GetBaseTypeForSchema Method
SchemaClass Class See Also Send Feedback

Overload List

Name | Description
GetBaseTypeForSchema(PropertyInfo, ContainerType%, Type%) | Gets the base type for schema.
GetBaseTypeForSchema(Type, ContainerType%, Type%) | Gets the base type for schema.

See Also

SchemaClass Class
SchemaClass Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetBaseTypeForSchema Method (PropertyInfo, , Type)

SchemaClass..::..GetBaseTypeForSchema Method (PropertyInfo, %, Type%)
SchemaClass Class See Also Send Feedback
Gets the base type for schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetBaseTypeForSchema(
    PropertyInfo propertyInfo,
    out ContainerType containerType,
    out Type keyType
)

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo
The property info.
containerType
Type: ContainerType%
Type of the container.
keyType
Type: System..::..Type %
Type of the key.

Return Value

See Also

SchemaClass Class
GetBaseTypeForSchema Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetBaseTypeForSchema Method (Type, , Type)

SchemaClass..::..GetBaseTypeForSchema Method (Type, %, Type%)
SchemaClass Class See Also Send Feedback
Gets the base type for schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetBaseTypeForSchema(
    Type type,
    out ContainerType containerType,
    out Type keyType
)

Parameters

type
Type: System..::..Type
The type.
containerType
Type: ContainerType%
Type of the container.
keyType
Type: System..::..Type %
Type of the key.

Return Value

See Also

SchemaClass Class
GetBaseTypeForSchema Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetEntity Method

SchemaClass..::..GetEntity Method
SchemaClass Class See Also Send Feedback
Returns the entity based on this instance.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Entity GetEntity()

Return Value

The entity.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetFieldName Method

SchemaClass..::..GetFieldName Method
SchemaClass Class See Also Send Feedback
Gets the name of the field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string GetFieldName(
    PropertyInfo propertyInfo,
    SchemaPropertyAttribute unitAtt
)

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo
The property info.
unitAtt
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..SchemaPropertyAttribute
The unit att.

Return Value

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetTypeForSchema Method

SchemaClass..::..GetTypeForSchema Method
SchemaClass Class See Also Send Feedback
Gets the type for the schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetTypeForSchema(
    PropertyInfo property,
    SchemaPropertyAttribute spAtt
)

Parameters

property
Type: System.Reflection..::..PropertyInfo
The property.
spAtt
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..SchemaPropertyAttribute
The schema property attribute.

Return Value

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetTypeOfSchemaId Method

SchemaClass..::..GetTypeOfSchemaId Method
SchemaClass Class See Also Send Feedback
Gets the type of specific schema id.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetTypeOfSchemaId(
    Guid schema,
    params Type[] types
)

Parameters

schema
Type: System..::..Guid
The schema id.
types
Type: array< System..::..Type >[]()[][]
The list of types.

Return Value

The type of schema id.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetValue Method

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaClass..::..GetValue Method
SchemaClass Class See Also Send Feedback

Overload List

Name | Description
GetValue(Entity, Field, DisplayUnitType) | Returns the value of specific field.
GetValue(Entity, String, DisplayUnitType) | Returns the value of specific field.

See Also

SchemaClass Class
SchemaClass Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetValue Method (, , )

SchemaClass..::..GetValue Method (, , )
SchemaClass Class See Also Send Feedback
Returns the value of specific field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Object GetValue(
    Entity entity,
    Field field,
    DisplayUnitType unitType
)

Parameters

entity
Type: Entity
The entity.
field
Type: Field
The field.
unitType
Type: DisplayUnitType
The unit the value should be returned in.

Return Value

See Also

SchemaClass Class
GetValue Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetValue Method (, String, )

SchemaClass..::..GetValue Method (, String, )
SchemaClass Class See Also Send Feedback
Returns the value of specific field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Object GetValue(
    Entity entity,
    string fieldName,
    DisplayUnitType unitType
)

Parameters

entity
Type: Entity
The entity.
fieldName
Type: System..::..String
Name of the field.
unitType
Type: DisplayUnitType
The unit the value should be returned in.

Return Value

See Also

SchemaClass Class
GetValue Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetVersion Method

SchemaClass..::..GetVersion Method
SchemaClass Class See Also Send Feedback
Returns the version of the schema based on history kept in SchemaAttribute.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int GetVersion(
    Guid id
)

Parameters

id
Type: System..::..Guid
The id of the schema.

Return Value

The version.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Load Method

SchemaClass..::..Load Method
SchemaClass Class See Also Send Feedback
Loads data from Revit element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool Load(
    Element element
)

Parameters

element
Type: Element
The Revit element.

Return Value

If loading succeeded.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


LoadField Method

SchemaClass..::..LoadField Method
SchemaClass Class See Also Send Feedback
Loads the property in a special way (otherwise returns false).

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool LoadField(
    Guid loaded,
    Entity entity,
    Field field
)

Parameters

loaded
Type: System..::..Guid
The schema id of loaded entity.
entity
Type: Entity
The entity.
field
Type: Field
The field.

Return Value

If true special action was taken; otherwise standard deserialization should be performed

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


PostLoad Method

SchemaClass..::..PostLoad Method
SchemaClass Class See Also Send Feedback
Called after loading the instance.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void PostLoad(
    Entity entity
)

Parameters

entity
Type: Entity
The entity.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


PostSave Method

SchemaClass..::..PostSave Method
SchemaClass Class See Also Send Feedback
Called after saving the instance.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void PostSave(
    Entity entity
)

Parameters

entity
Type: Entity
The entity.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


PreLoad Method

SchemaClass..::..PreLoad Method
SchemaClass Class See Also Send Feedback
Called before loading the instance.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void PreLoad(
    Entity entity
)

Parameters

entity
Type: Entity
The entity.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


PreSave Method

SchemaClass..::..PreSave Method
SchemaClass Class See Also Send Feedback
Called before saving the instance.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void PreSave(
    Entity entity
)

Parameters

entity
Type: Entity
The entity.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Remove Method

SchemaClass..::..Remove Method
SchemaClass Class See Also Send Feedback
Removes data from element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Remove(
    Element element
)

Parameters

element
Type: Element
The Revit element.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Save Method

SchemaClass..::..Save Method
SchemaClass Class See Also Send Feedback
Saves data to Revit element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool Save(
    Element element
)

Parameters

element
Type: Element
The Revit element.

Return Value

If saving succeeded.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SaveField Method

SchemaClass..::..SaveField Method
SchemaClass Class See Also Send Feedback
Saves the property in a special way (otherwise returns false)

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool SaveField(
    Entity entity,
    Field field
)

Parameters

entity
Type: Entity
The entity to which this instance is being saved.
field
Type: Field
The field.

Return Value

If true special action was taken; otherwise standard serialization should be performed.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SetEntityParamBased Method

SchemaClass..::..SetEntityParamBased Method
SchemaClass Class See Also Send Feedback
Sets values of fields in entity based on properties of the input object.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void SetEntityParamBased(
    Entity entity,
    Object obj
)

Parameters

entity
Type: Entity
The entity.
obj
Type: System..::..Object
The object.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SetParamsEntityBased Method

SchemaClass..::..SetParamsEntityBased Method
SchemaClass Class See Also Send Feedback
Sets properties of the object based on fields of the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void SetParamsEntityBased(
    Object obj,
    Entity entity,
    Document document
)

Parameters

obj
Type: System..::..Object
The object.
entity
Type: Entity
The entity.
document
Type: Document
The document.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SetProperties Method

SchemaClass..::..SetProperties Method
SchemaClass Class See Also Send Feedback
Sets properties of this instance based on the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetProperties(
    Entity entity,
    Document document
)

Parameters

entity
Type: Entity
The entity.
document
Type: Document
The document.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SetValue Method

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaClass..::..SetValue Method
SchemaClass Class See Also Send Feedback

Overload List

Name | Description
SetValue(Entity, Field, Object, DisplayUnitType) | Sets the value of the specific field.
SetValue(Entity, String, Object, DisplayUnitType) | Sets the value of the specific field.

See Also

SchemaClass Class
SchemaClass Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SetValue Method (, , Object, )

SchemaClass..::..SetValue Method (, , Object, )
SchemaClass Class See Also Send Feedback
Sets the value of the specific field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void SetValue(
    Entity entity,
    Field field,
    Object value,
    DisplayUnitType unitType
)

Parameters

entity
Type: Entity
The entity.
field
Type: Field
The field.
value
Type: System..::..Object
The value.
unitType
Type: DisplayUnitType
The type of the unit.

See Also

SchemaClass Class
SetValue Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


SetValue Method (, String, Object, )

SchemaClass..::..SetValue Method (, String, Object, )
SchemaClass Class See Also Send Feedback
Sets the value of the specific field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void SetValue(
    Entity entity,
    string name,
    Object value,
    DisplayUnitType unitType
)

Parameters

entity
Type: Entity
The entity.
name
Type: System..::..String
The name of the field.
value
Type: System..::..Object
The value.
unitType
Type: DisplayUnitType
The type of the unit.

See Also

SchemaClass Class
SetValue Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Settings Class

Settings Class
Members See Also Send Feedback
Represents setting

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Settings

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..Settings

See Also

Settings Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Settings Members

[image]

Structural Analysis and Code Checking API Reference Guide
Settings Members
Settings Class Constructors Methods See Also Send Feedback

The Settings type exposes the following members.

Constructors

 | Name | Description
Public method | Settings(Boolean) | Initializes a new instance of the Settings class.
Public method | Settings(String) | Initializes a new instance of the Settings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCommonSettings | Gets the common settings.
Public method | GetData | Gets the data of specific key.
 | GetDirectory | Gets the directory.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the specified file.
Public method | Save | Saves the specified file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Settings Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Settings Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
Settings Constructor
Settings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Settings(Boolean) | Initializes a new instance of the Settings class.
Public method | Settings(String) | Initializes a new instance of the Settings class.

See Also

Settings Class
Settings Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Settings Constructor (Boolean)

Settings Constructor (Boolean)
Settings Class See Also Send Feedback
Initializes a new instance of the Settings class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Settings(
    bool load
)

Parameters

load
Type: System..::..Boolean
if set to true [load].

See Also

Settings Class
Settings Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Settings Constructor (String)

Settings Constructor (String)
Settings Class See Also Send Feedback
Initializes a new instance of the Settings class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Settings(
    string file
)

Parameters

file
Type: System..::..String
The file.

See Also

Settings Class
Settings Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Settings Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Settings Methods
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCommonSettings | Gets the common settings.
Public method | GetData | Gets the data of specific key.
 | GetDirectory | Gets the directory.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the specified file.
Public method | Save | Saves the specified file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Settings Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetCommonSettings Method

Settings..::..GetCommonSettings Method
Settings Class See Also Send Feedback
Gets the common settings.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Settings GetCommonSettings()

Return Value

See Also

Settings Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetData Method

Settings..::..GetData Method
Settings Class See Also Send Feedback
Gets the data of specific key.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Composite GetData(
    string key
)

Parameters

key
Type: System..::..String
The key.

Return Value

See Also

Settings Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetDirectory Method

Settings..::..GetDirectory Method
Settings Class See Also Send Feedback
Gets the directory.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string GetDirectory(
    bool create
)

Parameters

create
Type: System..::..Boolean
if set to true will be created.

Return Value

See Also

Settings Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Load Method

Settings..::..Load Method
Settings Class See Also Send Feedback
Loads the specified file.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Load(
    string file
)

Parameters

file
Type: System..::..String
The file.

See Also

Settings Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Save Method

Settings..::..Save Method
Settings Class See Also Send Feedback
Saves the specified file.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Save(
    string file
)

Parameters

file
Type: System..::..String
The file.

See Also

Settings Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


UnitFieldFormat Class

UnitFieldFormat Class
Members See Also Send Feedback
Provides formatting for fields with unit dependent items.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class UnitFieldFormat : IFieldFormat

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..UnitFieldFormat

See Also

UnitFieldFormat Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


UnitFieldFormat Members

[image]

Structural Analysis and Code Checking API Reference Guide
UnitFieldFormat Members
UnitFieldFormat Class Constructors Methods See Also Send Feedback

The UnitFieldFormat type exposes the following members.

Constructors

 | Name | Description
Public method | UnitFieldFormat | Initializes a new instance of the UnitFieldFormat class

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


UnitFieldFormat Constructor

UnitFieldFormat Constructor
UnitFieldFormat Class See Also Send Feedback
Initializes a new instance of the UnitFieldFormat class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitFieldFormat()

See Also

UnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


UnitFieldFormat Methods

[image]

Structural Analysis and Code Checking API Reference Guide
UnitFieldFormat Methods
UnitFieldFormat Class See Also Send Feedback

The UnitFieldFormat type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Convert Method

UnitFieldFormat..::..Convert Method
UnitFieldFormat Class See Also Send Feedback
Converts the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Convert(
    Object value,
    UnitType unitType,
    DisplayUnitType inputDispUnitType,
    DisplayUnitType outputDispUnitType
)

Parameters

value
Type: System..::..Object
The value.
unitType
Type: UnitType
Type of the unit.
inputDispUnitType
Type: DisplayUnitType
Type of the input disp unit.
outputDispUnitType
Type: DisplayUnitType
Type of the output disp unit.

Return Value

Implements

IFieldFormat..::..Convert(Object, UnitType, DisplayUnitType, DisplayUnitType)

See Also

UnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Format Method

UnitFieldFormat..::..Format Method
UnitFieldFormat Class See Also Send Feedback
Formats the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Format(
    Object value,
    Document document,
    UnitType unitType,
    DisplayUnitType inputDisplayUnitType,
    bool edit
)

Parameters

value
Type: System..::..Object
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
inputDisplayUnitType
Type: DisplayUnitType
The input unit type.
edit
Type: System..::..Boolean
if set to true [edit].

Return Value

Implements

IFieldFormat..::..Format(Object, Document, UnitType, DisplayUnitType, Boolean)

See Also

UnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Parse Method

UnitFieldFormat..::..Parse Method
UnitFieldFormat Class See Also Send Feedback
Parses the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Parse(
    string value,
    Document document,
    UnitType unitType,
    DisplayUnitType outputDisplayUnitType
)

Parameters

value
Type: System..::..String
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
outputDisplayUnitType
Type: DisplayUnitType
The output unit type.

Return Value

Implements

IFieldFormat..::..Parse(String, Document, UnitType, DisplayUnitType)

See Also

UnitFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


UnitUtilsExt Class

UnitUtilsExt Class
Members See Also Send Feedback
This class provides tools for units conversion.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static class UnitUtilsExt

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..UnitUtilsExt

See Also

UnitUtilsExt Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


UnitUtilsExt Members

[image]

Structural Analysis and Code Checking API Reference Guide
UnitUtilsExt Members
UnitUtilsExt Class Methods See Also Send Feedback

The UnitUtilsExt type exposes the following members.

Methods

Name | Description
Convert | Converts a list of values from one unit type to another, such as square feet to square meters.
ConvertFromInternalUnits | Converts a value from Revit's internal unit type.
ConvertToInternalUnits | Converts a value to Revit's internal unit type.
FormatValueToString | Formats a value into a string based on formatting options.
GetDisplayUnitType | Gets the display type of the unit.
GetFormatOptions | Gets the format options.
GetUnitSymbol | Gets the unit symbol.
TryParse | Parses a formatted string (including units) into a value if possible.

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


UnitUtilsExt Methods

[image]

Structural Analysis and Code Checking API Reference Guide
UnitUtilsExt Methods
UnitUtilsExt Class See Also Send Feedback

The UnitUtilsExt type exposes the following members.

Methods

Name | Description
Convert | Converts a list of values from one unit type to another, such as square feet to square meters.
ConvertFromInternalUnits | Converts a value from Revit's internal unit type.
ConvertToInternalUnits | Converts a value to Revit's internal unit type.
FormatValueToString | Formats a value into a string based on formatting options.
GetDisplayUnitType | Gets the display type of the unit.
GetFormatOptions | Gets the format options.
GetUnitSymbol | Gets the unit symbol.
TryParse | Parses a formatted string (including units) into a value if possible.

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Convert Method

UnitUtilsExt..::..Convert Method
UnitUtilsExt Class See Also Send Feedback
Converts a list of values from one unit type to another, such as square feet to square meters.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<double> Convert(
    IList<double> value,
    DisplayUnitType inputDispUnitType,
    DisplayUnitType outputDispUnitType
)

Parameters

value
Type: System.Collections.Generic..::..IList <(Of <(<' Double >)>)>
The value.
inputDispUnitType
Type: DisplayUnitType
Input unit type.
outputDispUnitType
Type: DisplayUnitType
Output unit type.

Return Value

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ConvertFromInternalUnits Method

UnitUtilsExt..::..ConvertFromInternalUnits Method
UnitUtilsExt Class See Also Send Feedback
Converts a value from Revit's internal unit type.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<double> ConvertFromInternalUnits(
    IList<double> value,
    DisplayUnitType outputDispUnitType
)

Parameters

value
Type: System.Collections.Generic..::..IList <(Of <(<' Double >)>)>
The value.
outputDispUnitType
Type: DisplayUnitType
The desired display unit type.

Return Value

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


ConvertToInternalUnits Method

UnitUtilsExt..::..ConvertToInternalUnits Method
UnitUtilsExt Class See Also Send Feedback
Converts a value to Revit's internal unit type.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<double> ConvertToInternalUnits(
    IList<double> value,
    DisplayUnitType inputDispUnitType
)

Parameters

value
Type: System.Collections.Generic..::..IList <(Of <(<' Double >)>)>
The value.
inputDispUnitType
Type: DisplayUnitType
The input display unit type.

Return Value

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


FormatValueToString Method

UnitUtilsExt..::..FormatValueToString Method
UnitUtilsExt Class See Also Send Feedback
Formats a value into a string based on formatting options.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string FormatValueToString(
    Units units,
    UnitType unitType,
    string listSeparator,
    List<double> values,
    bool maxAccuracy,
    bool forEditing
)

Parameters

units
Type: Units
The units object.
unitType
Type: UnitType
Type of the unit.
listSeparator
Type: System..::..String
The list separator.
values
Type: System.Collections.Generic..::..List <(Of <(<' Double >)>)>
The values.
maxAccuracy
Type: System..::..Boolean
True if the value should be rounded to an increased accuracy level appropriate for editing or understanding the precise value stored in the model. False if the accuracy specified by the FormatOptions should be used, appropriate for printed drawings.
forEditing
Type: System..::..Boolean
True if the formatting should be modified as necessary so that the formatted string can be successfully parsed, for example by suppressing digit grouping. False if unmodified settings should be used, suitable for display only..

Return Value

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetDisplayUnitType Method

UnitUtilsExt..::..GetDisplayUnitType Method
UnitUtilsExt Class See Also Send Feedback
Gets the display type of the unit.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DisplayUnitType GetDisplayUnitType(
    Units projectUnit,
    UnitType unitType
)

Parameters

projectUnit
Type: Units
The project unit.
unitType
Type: UnitType
Type of the unit.

Return Value

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetFormatOptions Method

UnitUtilsExt..::..GetFormatOptions Method
UnitUtilsExt Class See Also Send Feedback
Gets the format options.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static FormatOptions GetFormatOptions(
    Units projectUnit,
    UnitType unitType
)

Parameters

projectUnit
Type: Units
The project unit.
unitType
Type: UnitType
Type of the unit.

Return Value

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


GetUnitSymbol Method

UnitUtilsExt..::..GetUnitSymbol Method
UnitUtilsExt Class See Also Send Feedback
Gets the unit symbol.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string GetUnitSymbol(
    Units projectUnit,
    UnitType unitType
)

Parameters

projectUnit
Type: Units
The project unit.
unitType
Type: UnitType
Type of the unit.

Return Value

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


TryParse Method

UnitUtilsExt..::..TryParse Method
UnitUtilsExt Class See Also Send Feedback
Parses a formatted string (including units) into a value if possible.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool TryParse(
    Units units,
    UnitType unitType,
    string stringToParse,
    string listSeparator,
    out List<double> values
)

Parameters

units
Type: Units
The units object.
unitType
Type: UnitType
Type of the unit.
stringToParse
Type: System..::..String
The string to parse.
listSeparator
Type: System..::..String
The list separator.
values
Type: System.Collections.Generic..::..List <(Of <(<' Double >)>)>%
The values.

Return Value

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


XYZFieldFormat Class

XYZFieldFormat Class
Members See Also Send Feedback
Provides formatting for XYZ structure.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class XYZFieldFormat : IFieldFormat

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..XYZFieldFormat

See Also

XYZFieldFormat Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


XYZFieldFormat Members

[image]

Structural Analysis and Code Checking API Reference Guide
XYZFieldFormat Members
XYZFieldFormat Class Constructors Methods See Also Send Feedback

The XYZFieldFormat type exposes the following members.

Constructors

 | Name | Description
Public method | XYZFieldFormat | Initializes a new instance of the XYZFieldFormat class

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

XYZFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


XYZFieldFormat Constructor

XYZFieldFormat Constructor
XYZFieldFormat Class See Also Send Feedback
Initializes a new instance of the XYZFieldFormat class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZFieldFormat()

See Also

XYZFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


XYZFieldFormat Methods

[image]

Structural Analysis and Code Checking API Reference Guide
XYZFieldFormat Methods
XYZFieldFormat Class See Also Send Feedback

The XYZFieldFormat type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Format | Formats the specified value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse | Parses the specified value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

XYZFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Convert Method

XYZFieldFormat..::..Convert Method
XYZFieldFormat Class See Also Send Feedback
Converts the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Convert(
    Object value,
    UnitType unitType,
    DisplayUnitType inputUnitType,
    DisplayUnitType outputUnitType
)

Parameters

value
Type: System..::..Object
The value.
unitType
Type: UnitType
Type of the unit.
inputUnitType
Type: DisplayUnitType
Type of the input unit.
outputUnitType
Type: DisplayUnitType
Type of the output unit.

Return Value

Implements

IFieldFormat..::..Convert(Object, UnitType, DisplayUnitType, DisplayUnitType)

See Also

XYZFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Format Method

XYZFieldFormat..::..Format Method
XYZFieldFormat Class See Also Send Feedback
Formats the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Format(
    Object value,
    Document document,
    UnitType unitType,
    DisplayUnitType inputDisplayUnitType,
    bool edit
)

Parameters

value
Type: System..::..Object
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
inputDisplayUnitType
Type: DisplayUnitType
Type of the input display unit.
edit
Type: System..::..Boolean
if set to true for edit.

Return Value

Implements

IFieldFormat..::..Format(Object, Document, UnitType, DisplayUnitType, Boolean)

See Also

XYZFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Parse Method

XYZFieldFormat..::..Parse Method
XYZFieldFormat Class See Also Send Feedback
Parses the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Parse(
    string value,
    Document document,
    UnitType unitType,
    DisplayUnitType outputDisplayUnitType
)

Parameters

value
Type: System..::..String
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
outputDisplayUnitType
Type: DisplayUnitType
Type of the output display unit.

Return Value

Implements

IFieldFormat..::..Parse(String, Document, UnitType, DisplayUnitType)

See Also

XYZFieldFormat Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace


Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace

Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace
Send Feedback

Classes

 | Class | Description
Public class | SchemaAttribute | Indicates that a class can be converted to the schema.
Public class | SchemaPropertyAttribute | Indicates that a property of the class should be converted to the field in schema.
Public class | UnitAttribute | Describes unit settings for property


SchemaAttribute Class

SchemaAttribute Class
Members Example See Also Send Feedback
Indicates that a class can be converted to the schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SchemaAttribute : Attribute

Remarks

The id should be changed every time when schema changes (e.g. some property is added, removed or renamed). It is also very important to remember that changing id of the class A which instance is a member of the class B should result in changing id of the class B!

Examples

The schema of Name1 name and already second version:
CopyC#
[Schema("Name1","1E578722-BFF5-4496-B436-CB6C659D93DF","F6F790AF-1762-441D-9AFF-9C822D346E5F")]
public class Class1:SchemaClass
{
}

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..SchemaAttribute

See Also

SchemaAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaAttribute Members
SchemaAttribute Class Constructors Methods Properties See Also Send Feedback

The SchemaAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SchemaAttribute | Initializes a new instance of the SchemaAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of schema id based on index in the history.
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | History | The history of schema ids.
Public property | Name | The name of the schema.
Public property | SchemaID | The id of the schema.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SchemaAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaAttribute Constructor

SchemaAttribute Constructor
SchemaAttribute Class See Also Send Feedback
Initializes a new instance of the SchemaAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SchemaAttribute(
    string name,
    string schemaId,
    params string[] schemaIdHistory
)

Parameters

name
Type: System..::..String
The name of the schema.
schemaId
Type: System..::..String
The current id of the schema.
schemaIdHistory
Type: array< System..::..String >[]()[][]
The history of schemas ids from newest to oldest (without current one).

See Also

SchemaAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaAttribute Methods
SchemaAttribute Class See Also Send Feedback

The SchemaAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of schema id based on index in the history.
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SchemaAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


GetVersion Method

SchemaAttribute..::..GetVersion Method
SchemaAttribute Class See Also Send Feedback
Returns the version of schema id based on index in the history.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int GetVersion(
    Guid id
)

Parameters

id
Type: System..::..Guid
The schema id.

Return Value

The schema version.

See Also

SchemaAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaAttribute Properties
SchemaAttribute Class See Also Send Feedback

The SchemaAttribute type exposes the following members.

Properties

 | Name | Description
Public property | History | The history of schema ids.
Public property | Name | The name of the schema.
Public property | SchemaID | The id of the schema.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SchemaAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


History Property

SchemaAttribute..::..History Property
SchemaAttribute Class See Also Send Feedback
The history of schema ids.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Guid> History { get; set; }

Remarks

The history of used ids should be kept in order to be able to deserialize old versions.

See Also

SchemaAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


Name Property

SchemaAttribute..::..Name Property
SchemaAttribute Class See Also Send Feedback
The name of the schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

See Also

SchemaAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaID Property

SchemaAttribute..::..SchemaID Property
SchemaAttribute Class See Also Send Feedback
The id of the schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid SchemaID { get; set; }

Remarks

The id of the schema has to be changed with every change of the class definition (which impacts schema definition).

See Also

SchemaAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaPropertyAttribute Class

SchemaPropertyAttribute Class
Members Example See Also Send Feedback
Indicates that a property of the class should be converted to the field in schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SchemaPropertyAttribute : UnitAttribute

Examples

The property of the string type, the name and the type taken directly from the property:
CopyC#
[SchemaProperty()]
public string A { get; set; }
 The property of the double type with category and unit defined:
CopyC#
[SchemaProperty(Unit = UnitType.UT_Length, DisplayUnit = DisplayUnitType.DUT_METERS)]
public double B { get; set; }
 The property with changed name of the field:
CopyC#
[SchemaProperty(FieldName = "C")]
public string InternalName { get; set; }
 The property with changed type of the field and defined converter:
CopyC#
[SchemaProperty(FieldType = typeof(List/<int />), ConverterType = typeof(DateTimeConverter))]
public DateTime Date { get; set; }

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..UnitAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..SchemaPropertyAttribute

See Also

SchemaPropertyAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaPropertyAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaPropertyAttribute Members
SchemaPropertyAttribute Class Constructors Methods Properties See Also Send Feedback

The SchemaPropertyAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SchemaPropertyAttribute()()()() | Initializes the instance of the SchemaPropertyAttribute.
Public method | SchemaPropertyAttribute(UnitType, DisplayUnitType) | Initializes the instance of the SchemaPropertyAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetConverter | Returns the instance of the converter.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConverterType | The converter which implements IFieldToPropertyConverter interface, necessarry when FieldType is different from property type.
Public property | DisplayUnit | The unit in which the field is defined. (Inherited from UnitAttribute.)
Public property | FieldName | The name of the field in the schema. If null the name of the property will be taken directly.
Public property | FieldType | The type of the field in the schema. If null the type of the property will be taken directly. Usefull when property type is not supported by Extensible Storage.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Unit | The unit category of the field. (Inherited from UnitAttribute.)

See Also

SchemaPropertyAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaPropertyAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaPropertyAttribute Constructor
SchemaPropertyAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SchemaPropertyAttribute()()()() | Initializes the instance of the SchemaPropertyAttribute.
Public method | SchemaPropertyAttribute(UnitType, DisplayUnitType) | Initializes the instance of the SchemaPropertyAttribute.

See Also

SchemaPropertyAttribute Class
SchemaPropertyAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaPropertyAttribute Constructor

SchemaPropertyAttribute Constructor
SchemaPropertyAttribute Class See Also Send Feedback
Initializes the instance of the SchemaPropertyAttribute.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SchemaPropertyAttribute()

See Also

SchemaPropertyAttribute Class
SchemaPropertyAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaPropertyAttribute Constructor (, )

SchemaPropertyAttribute Constructor (, )
SchemaPropertyAttribute Class See Also Send Feedback
Initializes the instance of the SchemaPropertyAttribute.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SchemaPropertyAttribute(
    UnitType unitType,
    DisplayUnitType displayUnit
)

Parameters

unitType
Type: UnitType
The category of the field.
displayUnit
Type: DisplayUnitType
The unit in which the field is defined.

See Also

SchemaPropertyAttribute Class
SchemaPropertyAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaPropertyAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaPropertyAttribute Methods
SchemaPropertyAttribute Class See Also Send Feedback

The SchemaPropertyAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetConverter | Returns the instance of the converter.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SchemaPropertyAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


GetConverter Method

SchemaPropertyAttribute..::..GetConverter Method
SchemaPropertyAttribute Class See Also Send Feedback
Returns the instance of the converter.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IFieldToPropertyConverter GetConverter()

Return Value

See Also

SchemaPropertyAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


SchemaPropertyAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaPropertyAttribute Properties
SchemaPropertyAttribute Class See Also Send Feedback

The SchemaPropertyAttribute type exposes the following members.

Properties

 | Name | Description
Public property | ConverterType | The converter which implements IFieldToPropertyConverter interface, necessarry when FieldType is different from property type.
Public property | DisplayUnit | The unit in which the field is defined. (Inherited from UnitAttribute.)
Public property | FieldName | The name of the field in the schema. If null the name of the property will be taken directly.
Public property | FieldType | The type of the field in the schema. If null the type of the property will be taken directly. Usefull when property type is not supported by Extensible Storage.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Unit | The unit category of the field. (Inherited from UnitAttribute.)

See Also

SchemaPropertyAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


ConverterType Property

SchemaPropertyAttribute..::..ConverterType Property
SchemaPropertyAttribute Class See Also Send Feedback
The converter which implements IFieldToPropertyConverter interface, necessarry when FieldType is different from property type.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type ConverterType { get; set; }

See Also

SchemaPropertyAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


FieldName Property

SchemaPropertyAttribute..::..FieldName Property
SchemaPropertyAttribute Class See Also Send Feedback
The name of the field in the schema. If null the name of the property will be taken directly.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string FieldName { get; set; }

See Also

SchemaPropertyAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


FieldType Property

SchemaPropertyAttribute..::..FieldType Property
SchemaPropertyAttribute Class See Also Send Feedback
The type of the field in the schema. If null the type of the property will be taken directly. Usefull when property type is not supported by Extensible Storage.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type FieldType { get; set; }

See Also

SchemaPropertyAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


UnitAttribute Class

UnitAttribute Class
Members See Also Send Feedback
Describes unit settings for property

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class UnitAttribute : Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..UnitAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..SchemaPropertyAttribute

See Also

UnitAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


UnitAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
UnitAttribute Members
UnitAttribute Class Constructors Methods Properties See Also Send Feedback

The UnitAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | UnitAttribute | Initializes a new instance of the UnitAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayUnit | The unit in which the field is defined.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Unit | The unit category of the field.

See Also

UnitAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


UnitAttribute Constructor

UnitAttribute Constructor
UnitAttribute Class See Also Send Feedback
Initializes a new instance of the UnitAttribute class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitAttribute()

See Also

UnitAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


UnitAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
UnitAttribute Methods
UnitAttribute Class See Also Send Feedback

The UnitAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UnitAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


UnitAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
UnitAttribute Properties
UnitAttribute Class See Also Send Feedback

The UnitAttribute type exposes the following members.

Properties

 | Name | Description
Public property | DisplayUnit | The unit in which the field is defined.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Unit | The unit category of the field.

See Also

UnitAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


DisplayUnit Property

UnitAttribute..::..DisplayUnit Property
UnitAttribute Class See Also Send Feedback
The unit in which the field is defined.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType DisplayUnit { get; set; }

See Also

UnitAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


Unit Property

UnitAttribute..::..Unit Property
UnitAttribute Class See Also Send Feedback
The unit category of the field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitType Unit { get; set; }

See Also

UnitAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace


Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace

Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace
Send Feedback

Classes

 | Class | Description
Public class | ColorRangeMapItem | contains result list, colors and min max value
Public class | Document | Represents the document
Public class | DocumentAnchor | Represents document anchor element
Public class | DocumentAnchorReference | Represents the reference to anchor
Public class | DocumentBody | Represents the body of the document
Public class | DocumentBuilder | Base class for all document builders.
Public class | DocumentContentTable | Represents table of content
Public class | DocumentDiagram | Represents the diagram
Public class | DocumentDiagramAxis | Represents the diagram axis.
Public class | DocumentDiagramAxisLabel | Represents single axis label
Public class | DocumentDiagramSeries | Describes single series of data.
Public class | DocumentElement | The base class for all document elements.
Public class | DocumentHeader | Represents document header
Public class | DocumentImage | Represents the image.
Public class | DocumentLineBreak | Represents the line break.
Public class | DocumentMap | Represents map
Public class | DocumentPageBreak | Represents the page break.
Public class | DocumentRatio | Represents ratio element
Public class | DocumentSection | Represents document section
Public class | DocumentStatus | Represents document status element
Public class | DocumentTable | Represents the table element.
Public class | DocumentTableCell | Represents the cell of the table
Public class | DocumentText | Represents the text element.
Public class | DocumentTitle | Represents the title element.
Public class | DocumentValue | Represents the value element.
Public class | DocumentValueWithDescription | Represents document value element with additional description
Public class | DocumentValueWithName | Represents document value with name
Public class | HtmlBuilder | Represents html files builder
Public class | MhtBuilder | Represents mht files builder
Public class | TextBuilder | Represents html files builder

Enumerations

 | Enumeration | Description
Public enumeration | DetailLevel | Describes detail level of element
Public enumeration | DiagramType | Describes types of diagrams


ColorRangeMapItem Class

ColorRangeMapItem Class
Members See Also Send Feedback
contains result list, colors and min max value

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ColorRangeMapItem

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..ColorRangeMapItem

See Also

ColorRangeMapItem Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


ColorRangeMapItem Members

[image]

Structural Analysis and Code Checking API Reference Guide
ColorRangeMapItem Members
ColorRangeMapItem Class Constructors Methods Properties See Also Send Feedback

The ColorRangeMapItem type exposes the following members.

Constructors

 | Name | Description
Public method | ColorRangeMapItem | Initializes a new instance of the ColorRangeMapItem class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssignedColor | Gets or sets the color of the assigned.
Public property | Contour | Gets or sets the contour.
Public property | MaxValue | Gets or sets the max value.
Public property | MinValue | Gets or sets the min value.

See Also

ColorRangeMapItem Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


ColorRangeMapItem Constructor

ColorRangeMapItem Constructor
ColorRangeMapItem Class See Also Send Feedback
Initializes a new instance of the ColorRangeMapItem class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ColorRangeMapItem()

See Also

ColorRangeMapItem Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


ColorRangeMapItem Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ColorRangeMapItem Methods
ColorRangeMapItem Class See Also Send Feedback

The ColorRangeMapItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ColorRangeMapItem Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


ColorRangeMapItem Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ColorRangeMapItem Properties
ColorRangeMapItem Class See Also Send Feedback

The ColorRangeMapItem type exposes the following members.

Properties

 | Name | Description
Public property | AssignedColor | Gets or sets the color of the assigned.
Public property | Contour | Gets or sets the contour.
Public property | MaxValue | Gets or sets the max value.
Public property | MinValue | Gets or sets the min value.

See Also

ColorRangeMapItem Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


AssignedColor Property

ColorRangeMapItem..::..AssignedColor Property
ColorRangeMapItem Class See Also Send Feedback
Gets or sets the color of the assigned.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Color AssignedColor { get; set; }

Field Value

The color of the assigned.

See Also

ColorRangeMapItem Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Contour Property

ColorRangeMapItem..::..Contour Property
ColorRangeMapItem Class See Also Send Feedback
Gets or sets the contour.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<XYZ> Contour { get; set; }

Field Value

The contour.

See Also

ColorRangeMapItem Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


MaxValue Property

ColorRangeMapItem..::..MaxValue Property
ColorRangeMapItem Class See Also Send Feedback
Gets or sets the max value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double MaxValue { get; set; }

Field Value

The max value.

See Also

ColorRangeMapItem Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


MinValue Property

ColorRangeMapItem..::..MinValue Property
ColorRangeMapItem Class See Also Send Feedback
Gets or sets the min value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double MinValue { get; set; }

Field Value

The min value.

See Also

ColorRangeMapItem Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DetailLevel Enumeration

DetailLevel Enumeration
See Also Send Feedback
Describes detail level of element

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum DetailLevel

Members

Member name | Value | Description
General | 0 | Always visible
Medium | 1 | Visible when medium and detail
Detail | 2 | Visible when detail only

See Also

Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DiagramType Enumeration

DiagramType Enumeration
See Also Send Feedback
Describes types of diagrams

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum DiagramType

Members

Member name | Value | Description
Line | 0 | Line diagram type
Point | 1 | Point diagram type
Column | 2 | Column diagram type
Bar | 3 | Bar diagram type
Area | 4 | Area diagram type

See Also

Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Document Class

Document Class
Members See Also Send Feedback
Represents the document

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Document

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document

See Also

Document Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Document Members

[image]

Structural Analysis and Code Checking API Reference Guide
Document Members
Document Class Constructors Methods Properties See Also Send Feedback

The Document type exposes the following members.

Constructors

 | Name | Description
Public method | Document | Initializes a new instance of the Document class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Footer | Gets or sets the footer.
Public property | Header | Gets or sets the header.
Public property | Main | Gets or sets the main body of the document.
Public property | Title | Gets or sets the title.

See Also

Document Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Document Constructor

Document Constructor
Document Class See Also Send Feedback
Initializes a new instance of the Document class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document()

See Also

Document Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Document Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Document Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Document Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

 | Name | Description
Public property | Footer | Gets or sets the footer.
Public property | Header | Gets or sets the header.
Public property | Main | Gets or sets the main body of the document.
Public property | Title | Gets or sets the title.

See Also

Document Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Footer Property

Document..::..Footer Property
Document Class See Also Send Feedback
Gets or sets the footer.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentBody Footer { get; set; }

Field Value

The footer.

See Also

Document Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Header Property

Document..::..Header Property
Document Class See Also Send Feedback
Gets or sets the header.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentBody Header { get; set; }

Field Value

The header.

See Also

Document Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Main Property

Document..::..Main Property
Document Class See Also Send Feedback
Gets or sets the main body of the document.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentBody Main { get; set; }

Field Value

The main body.

See Also

Document Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Title Property

Document..::..Title Property
Document Class See Also Send Feedback
Gets or sets the title.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Title { get; set; }

Field Value

The title.

See Also

Document Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentAnchor Class

DocumentAnchor Class
Members See Also Send Feedback
Represents document anchor element

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentAnchor : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentAnchor

See Also

DocumentAnchor Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentAnchor Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentAnchor Members
DocumentAnchor Class Constructors Methods Properties See Also Send Feedback

The DocumentAnchor type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentAnchor | Initializes a new instance of the DocumentAnchor class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Text | Gets or sets the text.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentAnchor Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentAnchor Constructor

DocumentAnchor Constructor
DocumentAnchor Class See Also Send Feedback
Initializes a new instance of the DocumentAnchor class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentAnchor(
    string name,
    string txt
)

Parameters

name
Type: System..::..String
The name.
txt
Type: System..::..String
The text.

See Also

DocumentAnchor Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentAnchor Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentAnchor Methods
DocumentAnchor Class See Also Send Feedback

The DocumentAnchor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentAnchor Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentAnchor Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentAnchor Properties
DocumentAnchor Class See Also Send Feedback

The DocumentAnchor type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Text | Gets or sets the text.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentAnchor Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Name Property

DocumentAnchor..::..Name Property
DocumentAnchor Class See Also Send Feedback
Gets or sets the name.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

Field Value

The name.

Remarks

Should be unique

See Also

DocumentAnchor Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Text Property

DocumentAnchor..::..Text Property
DocumentAnchor Class See Also Send Feedback
Gets or sets the text.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Text { get; set; }

Field Value

The text.

See Also

DocumentAnchor Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentAnchorReference Class

DocumentAnchorReference Class
Members See Also Send Feedback
Represents the reference to anchor

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentAnchorReference : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentAnchorReference

See Also

DocumentAnchorReference Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentAnchorReference Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentAnchorReference Members
DocumentAnchorReference Class Constructors Methods Properties See Also Send Feedback

The DocumentAnchorReference type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentAnchorReference | Initializes a new instance of the DocumentAnchorReference class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Reference | Gets or sets the reference to anchor.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Text | Gets or sets the text.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentAnchorReference Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentAnchorReference Constructor

DocumentAnchorReference Constructor
DocumentAnchorReference Class See Also Send Feedback
Initializes a new instance of the DocumentAnchorReference class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentAnchorReference(
    DocumentAnchor anchor,
    string text
)

Parameters

anchor
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentAnchor
The anchor.
text
Type: System..::..String
The text.

See Also

DocumentAnchorReference Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentAnchorReference Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentAnchorReference Methods
DocumentAnchorReference Class See Also Send Feedback

The DocumentAnchorReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentAnchorReference Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentAnchorReference Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentAnchorReference Properties
DocumentAnchorReference Class See Also Send Feedback

The DocumentAnchorReference type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Reference | Gets or sets the reference to anchor.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Text | Gets or sets the text.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentAnchorReference Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Reference Property

DocumentAnchorReference..::..Reference Property
DocumentAnchorReference Class See Also Send Feedback
Gets or sets the reference to anchor.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentAnchor Reference { get; set; }

Field Value

The reference.

See Also

DocumentAnchorReference Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Text Property

DocumentAnchorReference..::..Text Property
DocumentAnchorReference Class See Also Send Feedback
Gets or sets the text.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Text { get; set; }

Field Value

The text.

See Also

DocumentAnchorReference Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentBody Class

DocumentBody Class
Members See Also Send Feedback
Represents the body of the document

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentBody

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBody
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentTableCell

See Also

DocumentBody Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentBody Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentBody Members
DocumentBody Class Constructors Methods Properties See Also Send Feedback

The DocumentBody type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentBody | Initializes the instance of the DocumentBody.

Methods

 | Name | Description
 | Build(Entity, Document) | Creates document body based on entity.
 | Build(SchemaClass, IResource, Document) | Generates the document body based on the instance of SchemaClass.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FillBody | Fills the body of the document based on the instance of Schema class.
Public method | GetElementCount | Gets the element count.
 | GetElementList | Gets the element list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Elements | List of document elements.

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentBody Constructor

DocumentBody Constructor
DocumentBody Class See Also Send Feedback
Initializes the instance of the DocumentBody.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentBody()

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentBody Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentBody Methods
DocumentBody Class See Also Send Feedback

The DocumentBody type exposes the following members.

Methods

 | Name | Description
 | Build(Entity, Document) | Creates document body based on entity.
 | Build(SchemaClass, IResource, Document) | Generates the document body based on the instance of SchemaClass.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FillBody | Fills the body of the document based on the instance of Schema class.
Public method | GetElementCount | Gets the element count.
 | GetElementList | Gets the element list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Build Method

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentBody..::..Build Method
DocumentBody Class See Also Send Feedback

Overload List

Name | Description
Build(Entity, Document) | Creates document body based on entity.
Build(SchemaClass, IResource, Document) | Generates the document body based on the instance of SchemaClass.

See Also

DocumentBody Class
DocumentBody Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Build Method (, )

DocumentBody..::..Build Method (, )
DocumentBody Class See Also Send Feedback
Creates document body based on entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DocumentBody Build(
    Entity entity,
    Document revitDocument
)

Parameters

entity
Type: Entity
The entity.
revitDocument
Type: Document
The Revit document.

Return Value

See Also

DocumentBody Class
Build Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Build Method (SchemaClass, IResource, )

DocumentBody..::..Build Method (SchemaClass, IResource, )
DocumentBody Class See Also Send Feedback
Generates the document body based on the instance of SchemaClass.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DocumentBody Build(
    SchemaClass obj,
    IResource server,
    Document revitDocument
)

Parameters

obj
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
The object.
server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The document server.
revitDocument
Type: Document
The revit document.

See Also

DocumentBody Class
Build Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


FillBody Method

DocumentBody..::..FillBody Method
DocumentBody Class See Also Send Feedback
Fills the body of the document based on the instance of Schema class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void FillBody(
    SchemaClass obj,
    DocumentBody body,
    IResource server,
    Document revitDocument
)

Parameters

obj
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
The object.
body
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBody
The body.
server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The document server.
revitDocument
Type: Document
The Revit document.

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetElementCount Method

DocumentBody..::..GetElementCount Method
DocumentBody Class See Also Send Feedback
Gets the element count.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int GetElementCount()

Return Value

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetElementList Method

DocumentBody..::..GetElementList Method
DocumentBody Class See Also Send Feedback
Gets the element list.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<DocumentElement> GetElementList(
    SchemaClass obj,
    IResource server,
    Document revitDocument
)

Parameters

obj
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
The object.
server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The server.
revitDocument
Type: Document
The revit document.

Return Value

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentBody Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentBody Properties
DocumentBody Class See Also Send Feedback

The DocumentBody type exposes the following members.

Properties

 | Name | Description
Public property | Elements | List of document elements.

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Elements Property

DocumentBody..::..Elements Property
DocumentBody Class See Also Send Feedback
List of document elements.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<DocumentElement> Elements { get; set; }

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentBuilder Class

DocumentBuilder Class
Members See Also Send Feedback
Base class for all document builders.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class DocumentBuilder

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBuilder
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..HtmlBuilder
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..TextBuilder

See Also

DocumentBuilder Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentBuilder Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentBuilder Members
DocumentBuilder Class Methods See Also Send Feedback

The DocumentBuilder type exposes the following members.

Methods

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file.
Public method | BuildDocument(Document, Document, String, DetailLevel) | Virtual methods building document. This method is overriden by document builders.
Public method | BuildDocuments | Builds the document list splitted due to PageBreaks.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtension | Gets the extension of the file (without dot).
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTempPath | Gets the temp path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserTempPath | Gets the temp path for user.
 | RemoveTempPath | Removes the temp path.
 | RemoveUserTempPath | Removes the temp path.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentBuilder Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentBuilder Methods
DocumentBuilder Class See Also Send Feedback

The DocumentBuilder type exposes the following members.

Methods

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file.
Public method | BuildDocument(Document, Document, String, DetailLevel) | Virtual methods building document. This method is overriden by document builders.
Public method | BuildDocuments | Builds the document list splitted due to PageBreaks.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtension | Gets the extension of the file (without dot).
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTempPath | Gets the temp path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserTempPath | Gets the temp path for user.
 | RemoveTempPath | Removes the temp path.
 | RemoveUserTempPath | Removes the temp path.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocument Method

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentBuilder..::..BuildDocument Method
DocumentBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file.
Public method | BuildDocument(Document, Document, String, DetailLevel) | Virtual methods building document. This method is overriden by document builders.

See Also

DocumentBuilder Class
DocumentBuilder Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocument Method (Document, , DetailLevel)

DocumentBuilder..::..BuildDocument Method (Document, , DetailLevel)
DocumentBuilder Class See Also Send Feedback
Builds document file.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string BuildDocument(
    Document document,
    Document revitDocument,
    DetailLevel detailLevel
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document structure.
revitDocument
Type: Document
The revit document.
detailLevel
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
The detail level.

Return Value

The path of the file.

See Also

DocumentBuilder Class
BuildDocument Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocument Method (Document, , String, DetailLevel)

DocumentBuilder..::..BuildDocument Method (Document, , String, DetailLevel)
DocumentBuilder Class See Also Send Feedback
Virtual methods building document. This method is overriden by document builders.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string BuildDocument(
    Document document,
    Document revitDocument,
    string path,
    DetailLevel detailLevel
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document.
revitDocument
Type: Document
The Revit document.
path
Type: System..::..String
The path.
detailLevel
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
The detail level.

Return Value

The path to document.

See Also

DocumentBuilder Class
BuildDocument Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocuments Method

DocumentBuilder..::..BuildDocuments Method
DocumentBuilder Class See Also Send Feedback
Builds the document list splitted due to PageBreaks.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract List<string> BuildDocuments(
    Document document,
    Document revitDocument,
    DetailLevel detailLevel
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document.
revitDocument
Type: Document
The Revit document.
detailLevel
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
The detail level.

Return Value

See Also

DocumentBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetExtension Method

DocumentBuilder..::..GetExtension Method
DocumentBuilder Class See Also Send Feedback
Gets the extension of the file (without dot).

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string GetExtension()

Return Value

See Also

DocumentBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetTempPath Method

DocumentBuilder..::..GetTempPath Method
DocumentBuilder Class See Also Send Feedback
Gets the temp path.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string GetTempPath(
    bool create
)

Parameters

create
Type: System..::..Boolean
if set to true create directory.

Return Value

See Also

DocumentBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetUserTempPath Method

DocumentBuilder..::..GetUserTempPath Method
DocumentBuilder Class See Also Send Feedback
Gets the temp path for user.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string GetUserTempPath(
    bool create
)

Parameters

create
Type: System..::..Boolean
if set to true create directory.

Return Value

See Also

DocumentBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


RemoveTempPath Method

DocumentBuilder..::..RemoveTempPath Method
DocumentBuilder Class See Also Send Feedback
Removes the temp path.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void RemoveTempPath()

See Also

DocumentBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


RemoveUserTempPath Method

DocumentBuilder..::..RemoveUserTempPath Method
DocumentBuilder Class See Also Send Feedback
Removes the temp path.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void RemoveUserTempPath()

See Also

DocumentBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentContentTable Class

DocumentContentTable Class
Members See Also Send Feedback
Represents table of content

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentContentTable : DocumentSection

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentSection
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentContentTable

See Also

DocumentContentTable Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentContentTable Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentContentTable Members
DocumentContentTable Class Constructors Methods Properties See Also Send Feedback

The DocumentContentTable type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentContentTable | Initializes a new instance of the DocumentContentTable class.

Methods

 | Name | Description
Public method | Build | Builds the content table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevel | Gets the level of the section. (Inherited from DocumentSection.)
Public method | GetSectionOfName(String) | Gets the section of specific name. (Inherited from DocumentSection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetAdditionalData | Sets the additional data. (Inherited from DocumentSection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Anchor | Gets or sets the anchor. (Inherited from DocumentSection.)
Public property | Body | Gets or sets the body. (Inherited from DocumentSection.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name. (Inherited from DocumentSection.)
Public property | ParentDocument | Gets or sets the parent document. (Inherited from DocumentSection.)
Public property | ParentSection | Gets or sets the parent section. (Inherited from DocumentSection.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title. (Inherited from DocumentSection.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentContentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentContentTable Constructor

DocumentContentTable Constructor
DocumentContentTable Class See Also Send Feedback
Initializes a new instance of the DocumentContentTable class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentContentTable(
    Document document
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document.

See Also

DocumentContentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentContentTable Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentContentTable Methods
DocumentContentTable Class See Also Send Feedback

The DocumentContentTable type exposes the following members.

Methods

 | Name | Description
Public method | Build | Builds the content table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevel | Gets the level of the section. (Inherited from DocumentSection.)
Public method | GetSectionOfName(String) | Gets the section of specific name. (Inherited from DocumentSection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetAdditionalData | Sets the additional data. (Inherited from DocumentSection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentContentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Build Method

DocumentContentTable..::..Build Method
DocumentContentTable Class See Also Send Feedback
Builds the content table.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Build(
    DetailLevel level
)

Parameters

level
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
The detail level.

See Also

DocumentContentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentContentTable Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentContentTable Properties
DocumentContentTable Class See Also Send Feedback

The DocumentContentTable type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Anchor | Gets or sets the anchor. (Inherited from DocumentSection.)
Public property | Body | Gets or sets the body. (Inherited from DocumentSection.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name. (Inherited from DocumentSection.)
Public property | ParentDocument | Gets or sets the parent document. (Inherited from DocumentSection.)
Public property | ParentSection | Gets or sets the parent section. (Inherited from DocumentSection.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title. (Inherited from DocumentSection.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentContentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagram Class

DocumentDiagram Class
Members See Also Send Feedback
Represents the diagram

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentDiagram : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentDiagram

See Also

DocumentDiagram Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagram Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagram Members
DocumentDiagram Class Constructors Methods Properties See Also Send Feedback

The DocumentDiagram type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentDiagram | Initializes a new instance of the DocumentDiagram class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetLabelsX | Sets the labels X.
Public method | SetLabelsY | Sets the labels Y.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AxisX | Gets the X axis.
Public property | AxisY | Gets the Y axis.
Public property | Height | Gets or sets the height.
Public property | Legend | Gets or sets a value indicating whether legend is visible.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Series | Gets the list of series.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)
Public property | Width | Gets or sets the width.

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagram Constructor

DocumentDiagram Constructor
DocumentDiagram Class See Also Send Feedback
Initializes a new instance of the DocumentDiagram class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentDiagram(
    string title,
    string defaultSeries
)

Parameters

title
Type: System..::..String
defaultSeries
Type: System..::..String

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagram Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagram Methods
DocumentDiagram Class See Also Send Feedback

The DocumentDiagram type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetLabelsX | Sets the labels X.
Public method | SetLabelsY | Sets the labels Y.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


SetLabelsX Method

DocumentDiagram..::..SetLabelsX Method
DocumentDiagram Class See Also Send Feedback
Sets the labels X.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetLabelsX(
    UnitType unitType,
    DisplayUnitType dispUnitType,
    Document document,
    double step
)

Parameters

unitType
Type: UnitType
Type of the unit.
dispUnitType
Type: DisplayUnitType
Type of the display unit.
document
Type: Document
The document.
step
Type: System..::..Double
The step.

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


SetLabelsY Method

DocumentDiagram..::..SetLabelsY Method
DocumentDiagram Class See Also Send Feedback
Sets the labels Y.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetLabelsY(
    UnitType unitType,
    DisplayUnitType dispUnitType,
    Document document,
    double step
)

Parameters

unitType
Type: UnitType
Type of the unit.
dispUnitType
Type: DisplayUnitType
Type of the display unit.
document
Type: Document
The document.
step
Type: System..::..Double
The step.

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagram Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagram Properties
DocumentDiagram Class See Also Send Feedback

The DocumentDiagram type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AxisX | Gets the X axis.
Public property | AxisY | Gets the Y axis.
Public property | Height | Gets or sets the height.
Public property | Legend | Gets or sets a value indicating whether legend is visible.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Series | Gets the list of series.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)
Public property | Width | Gets or sets the width.

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


AxisX Property

DocumentDiagram..::..AxisX Property
DocumentDiagram Class See Also Send Feedback
Gets the X axis.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentDiagramAxis AxisX { get; private set; }

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


AxisY Property

DocumentDiagram..::..AxisY Property
DocumentDiagram Class See Also Send Feedback
Gets the Y axis.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentDiagramAxis AxisY { get; private set; }

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Height Property

DocumentDiagram..::..Height Property
DocumentDiagram Class See Also Send Feedback
Gets or sets the height.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Height { get; set; }

Field Value

The height.

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Legend Property

DocumentDiagram..::..Legend Property
DocumentDiagram Class See Also Send Feedback
Gets or sets a value indicating whether legend is visible.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Legend { get; set; }

Field Value

true if legend; otherwise, false.

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Series Property

DocumentDiagram..::..Series Property
DocumentDiagram Class See Also Send Feedback
Gets the list of series.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<DocumentDiagramSeries> Series { get; private set; }

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Title Property

DocumentDiagram..::..Title Property
DocumentDiagram Class See Also Send Feedback
Gets or sets the title.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Title { get; set; }

Field Value

The title.

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Width Property

DocumentDiagram..::..Width Property
DocumentDiagram Class See Also Send Feedback
Gets or sets the width.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Width { get; set; }

Field Value

The width.

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramAxis Class

DocumentDiagramAxis Class
Members See Also Send Feedback
Represents the diagram axis.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentDiagramAxis

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentDiagramAxis

See Also

DocumentDiagramAxis Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramAxis Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagramAxis Members
DocumentDiagramAxis Class Constructors Methods Properties See Also Send Feedback

The DocumentDiagramAxis type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentDiagramAxis | Initializes a new instance of the DocumentDiagramAxis class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtremePostion | Gets extreme postions.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Labels | Gets the labels.
Public property | Reversed | Gets or sets a value indicating whether this axis is reversed.
Public property | Title | Gets or sets the title.

See Also

DocumentDiagramAxis Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramAxis Constructor

DocumentDiagramAxis Constructor
DocumentDiagramAxis Class See Also Send Feedback
Initializes a new instance of the DocumentDiagramAxis class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentDiagramAxis()

See Also

DocumentDiagramAxis Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramAxis Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagramAxis Methods
DocumentDiagramAxis Class See Also Send Feedback

The DocumentDiagramAxis type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtremePostion | Gets extreme postions.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentDiagramAxis Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetExtremePostion Method

DocumentDiagramAxis..::..GetExtremePostion Method
DocumentDiagramAxis Class See Also Send Feedback
Gets extreme postions.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void GetExtremePostion(
    out double min,
    out double max
)

Parameters

min
Type: System..::..Double %
The min.
max
Type: System..::..Double %
The max.

See Also

DocumentDiagramAxis Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramAxis Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagramAxis Properties
DocumentDiagramAxis Class See Also Send Feedback

The DocumentDiagramAxis type exposes the following members.

Properties

 | Name | Description
Public property | Labels | Gets the labels.
Public property | Reversed | Gets or sets a value indicating whether this axis is reversed.
Public property | Title | Gets or sets the title.

See Also

DocumentDiagramAxis Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Labels Property

DocumentDiagramAxis..::..Labels Property
DocumentDiagramAxis Class See Also Send Feedback
Gets the labels.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<DocumentDiagramAxisLabel> Labels { get; private set; }

See Also

DocumentDiagramAxis Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Reversed Property

DocumentDiagramAxis..::..Reversed Property
DocumentDiagramAxis Class See Also Send Feedback
Gets or sets a value indicating whether this axis is reversed.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Reversed { get; set; }

Field Value

true if reversed; otherwise, false.

See Also

DocumentDiagramAxis Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Title Property

DocumentDiagramAxis..::..Title Property
DocumentDiagramAxis Class See Also Send Feedback
Gets or sets the title.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Title { get; set; }

Field Value

The title.

See Also

DocumentDiagramAxis Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramAxisLabel Class

DocumentDiagramAxisLabel Class
Members See Also Send Feedback
Represents single axis label

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentDiagramAxisLabel

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentDiagramAxisLabel

See Also

DocumentDiagramAxisLabel Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramAxisLabel Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagramAxisLabel Members
DocumentDiagramAxisLabel Class Constructors Methods Properties See Also Send Feedback

The DocumentDiagramAxisLabel type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentDiagramAxisLabel | Initializes a new instance of the DocumentDiagramAxisLabel class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Position | Gets or sets the position.
Public property | Text | Gets or sets the text.

See Also

DocumentDiagramAxisLabel Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramAxisLabel Constructor

DocumentDiagramAxisLabel Constructor
DocumentDiagramAxisLabel Class See Also Send Feedback
Initializes a new instance of the DocumentDiagramAxisLabel class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentDiagramAxisLabel(
    double position,
    string text
)

Parameters

position
Type: System..::..Double
The position.
text
Type: System..::..String
The text.

See Also

DocumentDiagramAxisLabel Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramAxisLabel Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagramAxisLabel Methods
DocumentDiagramAxisLabel Class See Also Send Feedback

The DocumentDiagramAxisLabel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentDiagramAxisLabel Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramAxisLabel Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagramAxisLabel Properties
DocumentDiagramAxisLabel Class See Also Send Feedback

The DocumentDiagramAxisLabel type exposes the following members.

Properties

 | Name | Description
Public property | Position | Gets or sets the position.
Public property | Text | Gets or sets the text.

See Also

DocumentDiagramAxisLabel Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Position Property

DocumentDiagramAxisLabel..::..Position Property
DocumentDiagramAxisLabel Class See Also Send Feedback
Gets or sets the position.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Position { get; set; }

Field Value

The position.

Remarks

The same unit as input points.

See Also

DocumentDiagramAxisLabel Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Text Property

DocumentDiagramAxisLabel..::..Text Property
DocumentDiagramAxisLabel Class See Also Send Feedback
Gets or sets the text.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Text { get; set; }

Field Value

The text.

See Also

DocumentDiagramAxisLabel Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramSeries Class

DocumentDiagramSeries Class
Members See Also Send Feedback
Describes single series of data.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentDiagramSeries

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentDiagramSeries

See Also

DocumentDiagramSeries Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramSeries Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagramSeries Members
DocumentDiagramSeries Class Constructors Methods Properties See Also Send Feedback

The DocumentDiagramSeries type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentDiagramSeries | Initializes a new instance of the DocumentDiagramSeries class.

Methods

 | Name | Description
Public method | AddXY | Adds the point.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX | Gets the X value.
Public method | GetY | Gets the Y value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | Gets or sets the color.
Public property | Count | Gets the number of points.
Public property | DiagramType | Gets or sets the type of the diagram.
Public property | Name | Gets or sets the name.
Public property | Width | Gets or sets the border width.

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramSeries Constructor

DocumentDiagramSeries Constructor
DocumentDiagramSeries Class See Also Send Feedback
Initializes a new instance of the DocumentDiagramSeries class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentDiagramSeries(
    string name
)

Parameters

name
Type: System..::..String
The name.

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramSeries Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagramSeries Methods
DocumentDiagramSeries Class See Also Send Feedback

The DocumentDiagramSeries type exposes the following members.

Methods

 | Name | Description
Public method | AddXY | Adds the point.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX | Gets the X value.
Public method | GetY | Gets the Y value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


AddXY Method

DocumentDiagramSeries..::..AddXY Method
DocumentDiagramSeries Class See Also Send Feedback
Adds the point.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddXY(
    double x,
    double y
)

Parameters

x
Type: System..::..Double
The x.
y
Type: System..::..Double
The y.

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetX Method

DocumentDiagramSeries..::..GetX Method
DocumentDiagramSeries Class See Also Send Feedback
Gets the X value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetX(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

Return Value

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetY Method

DocumentDiagramSeries..::..GetY Method
DocumentDiagramSeries Class See Also Send Feedback
Gets the Y value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetY(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

Return Value

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentDiagramSeries Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagramSeries Properties
DocumentDiagramSeries Class See Also Send Feedback

The DocumentDiagramSeries type exposes the following members.

Properties

 | Name | Description
Public property | Color | Gets or sets the color.
Public property | Count | Gets the number of points.
Public property | DiagramType | Gets or sets the type of the diagram.
Public property | Name | Gets or sets the name.
Public property | Width | Gets or sets the border width.

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Color Property

DocumentDiagramSeries..::..Color Property
DocumentDiagramSeries Class See Also Send Feedback
Gets or sets the color.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Color Color { get; set; }

Field Value

The color.

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Count Property

DocumentDiagramSeries..::..Count Property
DocumentDiagramSeries Class See Also Send Feedback
Gets the number of points.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Count { get; }

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DiagramType Property

DocumentDiagramSeries..::..DiagramType Property
DocumentDiagramSeries Class See Also Send Feedback
Gets or sets the type of the diagram.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DiagramType DiagramType { get; set; }

Field Value

The type of the diagram.

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Name Property

DocumentDiagramSeries..::..Name Property
DocumentDiagramSeries Class See Also Send Feedback
Gets or sets the name.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

Field Value

The name.

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Width Property

DocumentDiagramSeries..::..Width Property
DocumentDiagramSeries Class See Also Send Feedback
Gets or sets the border width.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Width { get; set; }

Field Value

The width.

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentElement Class

DocumentElement Class
Members See Also Send Feedback
The base class for all document elements.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentAnchor
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentAnchorReference
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentDiagram
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentHeader
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentImage
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentLineBreak
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentMap
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentPageBreak
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentRatio
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentSection
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentTable
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentText
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValue

See Also

DocumentElement Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentElement Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentElement Members
DocumentElement Class Constructors Methods Properties See Also Send Feedback

The DocumentElement type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentElement | Initializes a new instance of the DocumentElement class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDocumentElement(Entity, Field, Document) | Creates document element for specific field.
 | GetDocumentElement(PropertyInfo, Object, IResource, Document) | Gets the document element for specific property.
 | GetDocumentElement(String, Object, IResource, Document) | Gets the document element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data.
Public property | Level | Gets or sets the detail level of element.
Public property | Source | Gets or sets the source (e.g. name of property).
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible.

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentElement Constructor

DocumentElement Constructor
DocumentElement Class See Also Send Feedback
Initializes a new instance of the DocumentElement class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentElement()

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentElement Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentElement Methods
DocumentElement Class See Also Send Feedback

The DocumentElement type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDocumentElement(Entity, Field, Document) | Creates document element for specific field.
 | GetDocumentElement(PropertyInfo, Object, IResource, Document) | Gets the document element for specific property.
 | GetDocumentElement(String, Object, IResource, Document) | Gets the document element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetDocumentElement Method

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentElement..::..GetDocumentElement Method
DocumentElement Class See Also Send Feedback

Overload List

Name | Description
GetDocumentElement(Entity, Field, Document) | Creates document element for specific field.
GetDocumentElement(PropertyInfo, Object, IResource, Document) | Gets the document element for specific property.
GetDocumentElement(String, Object, IResource, Document) | Gets the document element.

See Also

DocumentElement Class
DocumentElement Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetDocumentElement Method (, , )

DocumentElement..::..GetDocumentElement Method (, , )
DocumentElement Class See Also Send Feedback
Creates document element for specific field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DocumentElement GetDocumentElement(
    Entity entity,
    Field field,
    Document revitDocument
)

Parameters

entity
Type: Entity
The entity.
field
Type: Field
The field.
revitDocument
Type: Document
The Revit document.

Return Value

See Also

DocumentElement Class
GetDocumentElement Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetDocumentElement Method (PropertyInfo, Object, IResource, )

DocumentElement..::..GetDocumentElement Method (PropertyInfo, Object, IResource, )
DocumentElement Class See Also Send Feedback
Gets the document element for specific property.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DocumentElement GetDocumentElement(
    PropertyInfo propertyInfo,
    Object obj,
    IResource doc,
    Document revitDocument
)

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo
The property information.
obj
Type: System..::..Object
The object.
doc
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The document.
revitDocument
Type: Document
The Revit document.

Return Value

See Also

DocumentElement Class
GetDocumentElement Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetDocumentElement Method (String, Object, IResource, )

DocumentElement..::..GetDocumentElement Method (String, Object, IResource, )
DocumentElement Class See Also Send Feedback
Gets the document element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DocumentElement GetDocumentElement(
    string propertyName,
    Object obj,
    IResource doc,
    Document revitDocument
)

Parameters

propertyName
Type: System..::..String
Name of the property.
obj
Type: System..::..Object
The object.
doc
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The document.
revitDocument
Type: Document
The Revit document.

Return Value

See Also

DocumentElement Class
GetDocumentElement Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


IsVisible Method

DocumentElement..::..IsVisible Method
DocumentElement Class See Also Send Feedback
Determines whether the specified level is visible.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsVisible(
    DetailLevel level
)

Parameters

level
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
The detail level.

Return Value

true if the specified level is visible; otherwise, false.

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentElement Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentElement Properties
DocumentElement Class See Also Send Feedback

The DocumentElement type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data.
Public property | Level | Gets or sets the detail level of element.
Public property | Source | Gets or sets the source (e.g. name of property).
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible.

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


AdditionalData Property

DocumentElement..::..AdditionalData Property
DocumentElement Class See Also Send Feedback
Gets or sets the additional data.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Dictionary<string, Object> AdditionalData { get; set; }

Field Value

The additional data.

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Level Property

DocumentElement..::..Level Property
DocumentElement Class See Also Send Feedback
Gets or sets the detail level of element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DetailLevel Level { get; set; }

Field Value

The level.

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Source Property

DocumentElement..::..Source Property
DocumentElement Class See Also Send Feedback
Gets or sets the source (e.g. name of property).

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Source { get; set; }

Field Value

The source.

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Visible Property

DocumentElement..::..Visible Property
DocumentElement Class See Also Send Feedback
Gets or sets a value indicating whether this DocumentElement is visible.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Visible { get; set; }

Field Value

true if visible; otherwise, false.

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentHeader Class

DocumentHeader Class
Members See Also Send Feedback
Represents document header

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentHeader : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentHeader

See Also

DocumentHeader Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentHeader Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentHeader Members
DocumentHeader Class Constructors Methods Properties See Also Send Feedback

The DocumentHeader type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentHeader | Initializes a new instance of the DocumentHeader class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Image | Gets or sets the image.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | SubTitle | Gets or sets the sub title.
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentHeader Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentHeader Constructor

DocumentHeader Constructor
DocumentHeader Class See Also Send Feedback
Initializes a new instance of the DocumentHeader class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentHeader(
    string title,
    string subtitle
)

Parameters

title
Type: System..::..String
The title.
subtitle
Type: System..::..String
The subtitle.

See Also

DocumentHeader Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentHeader Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentHeader Methods
DocumentHeader Class See Also Send Feedback

The DocumentHeader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentHeader Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentHeader Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentHeader Properties
DocumentHeader Class See Also Send Feedback

The DocumentHeader type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Image | Gets or sets the image.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | SubTitle | Gets or sets the sub title.
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentHeader Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Image Property

DocumentHeader..::..Image Property
DocumentHeader Class See Also Send Feedback
Gets or sets the image.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Uri Image { get; set; }

Field Value

The image.

See Also

DocumentHeader Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


SubTitle Property

DocumentHeader..::..SubTitle Property
DocumentHeader Class See Also Send Feedback
Gets or sets the sub title.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string SubTitle { get; set; }

Field Value

The sub title.

See Also

DocumentHeader Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Title Property

DocumentHeader..::..Title Property
DocumentHeader Class See Also Send Feedback
Gets or sets the title.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Title { get; set; }

Field Value

The title.

See Also

DocumentHeader Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentImage Class

DocumentImage Class
Members See Also Send Feedback
Represents the image.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentImage : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentImage

See Also

DocumentImage Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentImage Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentImage Members
DocumentImage Class Constructors Methods Properties See Also Send Feedback

The DocumentImage type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentImage | Initializes a new instance of the DocumentImage class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentImage Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentImage Constructor

DocumentImage Constructor
DocumentImage Class See Also Send Feedback
Initializes a new instance of the DocumentImage class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentImage(
    Uri source
)

Parameters

source
Type: System..::..Uri
The source.

See Also

DocumentImage Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentImage Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentImage Methods
DocumentImage Class See Also Send Feedback

The DocumentImage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentImage Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentImage Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentImage Properties
DocumentImage Class See Also Send Feedback

The DocumentImage type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentImage Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Source Property

DocumentImage..::..Source Property
DocumentImage Class See Also Send Feedback
Gets or sets the source.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Uri Source { get; set; }

Field Value

The source.

See Also

DocumentImage Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentLineBreak Class

DocumentLineBreak Class
Members See Also Send Feedback
Represents the line break.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentLineBreak : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentLineBreak

See Also

DocumentLineBreak Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentLineBreak Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentLineBreak Members
DocumentLineBreak Class Constructors Methods Properties See Also Send Feedback

The DocumentLineBreak type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentLineBreak | Initializes a new instance of the DocumentLineBreak class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Count | Number of line break repetitions.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentLineBreak Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentLineBreak Constructor

DocumentLineBreak Constructor
DocumentLineBreak Class See Also Send Feedback
Initializes a new instance of the DocumentLineBreak class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentLineBreak(
    int count
)

Parameters

count
Type: System..::..Int32

See Also

DocumentLineBreak Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentLineBreak Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentLineBreak Methods
DocumentLineBreak Class See Also Send Feedback

The DocumentLineBreak type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentLineBreak Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentLineBreak Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentLineBreak Properties
DocumentLineBreak Class See Also Send Feedback

The DocumentLineBreak type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Count | Number of line break repetitions.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentLineBreak Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Count Property

DocumentLineBreak..::..Count Property
DocumentLineBreak Class See Also Send Feedback
Number of line break repetitions.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Count { get; set; }

See Also

DocumentLineBreak Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentMap Class

DocumentMap Class
Members See Also Send Feedback
Represents map

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentMap : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentMap

See Also

DocumentMap Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentMap Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentMap Members
DocumentMap Class Constructors Methods Properties See Also Send Feedback

The DocumentMap type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentMap | Initializes a new instance of the DocumentMap class.

Methods

 | Name | Description
Public method | AddHole | Adds the hole.
Public method | AddPoint | Adds the point.
Public method | DefineContour | Defines the main polygon.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundBox | Gets the bound box.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHoles | Gets the polygon.
Public method | GetNodes | Gets the nodes.
Public method | GetPolygon | Gets the polygon.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetColors | Sets the legend colors.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | DisplayUnitType | Gets or sets the unit type data is defined in.
Public property | Legend | Gets or sets a value indicating whether this DocumentMap legend should be drawn.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | NegativeValuesColors | Gets or sets color for negative values.
Public property | PositiveValuesColors | Gets or sets colors for positive values.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | UnitType | Gets or sets the type of the unit.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)
Public property | Width | Gets or sets the width of map.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentMap Constructor

DocumentMap Constructor
DocumentMap Class See Also Send Feedback
Initializes a new instance of the DocumentMap class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentMap(
    UnitType unitType,
    DisplayUnitType valuesUnit
)

Parameters

unitType
Type: UnitType
Type of the unit.
valuesUnit
Type: DisplayUnitType
The values unit.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentMap Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentMap Methods
DocumentMap Class See Also Send Feedback

The DocumentMap type exposes the following members.

Methods

 | Name | Description
Public method | AddHole | Adds the hole.
Public method | AddPoint | Adds the point.
Public method | DefineContour | Defines the main polygon.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundBox | Gets the bound box.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHoles | Gets the polygon.
Public method | GetNodes | Gets the nodes.
Public method | GetPolygon | Gets the polygon.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetColors | Sets the legend colors.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


AddHole Method

DocumentMap..::..AddHole Method
DocumentMap Class See Also Send Feedback
Adds the hole.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddHole(
    List<int> polygon
)

Parameters

polygon
Type: System.Collections.Generic..::..List <(Of <(<' Int32 >)>)>
The polygon.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


AddPoint Method

DocumentMap..::..AddPoint Method
DocumentMap Class See Also Send Feedback
Adds the point.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int AddPoint(
    double x,
    double y,
    double value,
    bool contour
)

Parameters

x
Type: System..::..Double
The x.
y
Type: System..::..Double
The y.
value
Type: System..::..Double
The value.
contour
Type: System..::..Boolean
if set to true belongs to external contour.

Return Value

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DefineContour Method

DocumentMap..::..DefineContour Method
DocumentMap Class See Also Send Feedback
Defines the main polygon.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void DefineContour(
    List<int> polygon
)

Parameters

polygon
Type: System.Collections.Generic..::..List <(Of <(<' Int32 >)>)>
The polygon.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetBoundBox Method

DocumentMap..::..GetBoundBox Method
DocumentMap Class See Also Send Feedback
Gets the bound box.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void GetBoundBox(
    out XYZ min,
    out XYZ max
)

Parameters

min
Type: XYZ%
The min.
max
Type: XYZ%
The max.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetHoles Method

DocumentMap..::..GetHoles Method
DocumentMap Class See Also Send Feedback
Gets the polygon.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<List<int>> GetHoles()

Return Value

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetNodes Method

DocumentMap..::..GetNodes Method
DocumentMap Class See Also Send Feedback
Gets the nodes.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<XYZ> GetNodes()

Return Value

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetPolygon Method

DocumentMap..::..GetPolygon Method
DocumentMap Class See Also Send Feedback
Gets the polygon.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<int> GetPolygon()

Return Value

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


SetColors Method

DocumentMap..::..SetColors Method
DocumentMap Class See Also Send Feedback
Sets the legend colors.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetColors(
    int count
)

Parameters

count
Type: System..::..Int32
The number of colors.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentMap Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentMap Properties
DocumentMap Class See Also Send Feedback

The DocumentMap type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | DisplayUnitType | Gets or sets the unit type data is defined in.
Public property | Legend | Gets or sets a value indicating whether this DocumentMap legend should be drawn.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | NegativeValuesColors | Gets or sets color for negative values.
Public property | PositiveValuesColors | Gets or sets colors for positive values.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | UnitType | Gets or sets the type of the unit.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)
Public property | Width | Gets or sets the width of map.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DisplayUnitType Property

DocumentMap..::..DisplayUnitType Property
DocumentMap Class See Also Send Feedback
Gets or sets the unit type data is defined in.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType DisplayUnitType { get; set; }

Field Value

The display type of the unit.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Legend Property

DocumentMap..::..Legend Property
DocumentMap Class See Also Send Feedback
Gets or sets a value indicating whether this DocumentMap legend should be drawn.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Legend { get; set; }

Field Value

true if legend; otherwise, false.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


NegativeValuesColors Property

DocumentMap..::..NegativeValuesColors Property
DocumentMap Class See Also Send Feedback
Gets or sets color for negative values.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Color> NegativeValuesColors { get; set; }

Field Value

The negative values colors.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


PositiveValuesColors Property

DocumentMap..::..PositiveValuesColors Property
DocumentMap Class See Also Send Feedback
Gets or sets colors for positive values.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Color> PositiveValuesColors { get; set; }

Field Value

The positive values colors.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Title Property

DocumentMap..::..Title Property
DocumentMap Class See Also Send Feedback
Gets or sets the title.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Title { get; set; }

Field Value

The title.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


UnitType Property

DocumentMap..::..UnitType Property
DocumentMap Class See Also Send Feedback
Gets or sets the type of the unit.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitType UnitType { get; set; }

Field Value

The type of the unit.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Width Property

DocumentMap..::..Width Property
DocumentMap Class See Also Send Feedback
Gets or sets the width of map.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Width { get; set; }

Field Value

The width.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentPageBreak Class

DocumentPageBreak Class
Members See Also Send Feedback
Represents the page break.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentPageBreak : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentPageBreak

See Also

DocumentPageBreak Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentPageBreak Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentPageBreak Members
DocumentPageBreak Class Constructors Methods Properties See Also Send Feedback

The DocumentPageBreak type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentPageBreak | Initializes a new instance of the DocumentPageBreak class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentPageBreak Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentPageBreak Constructor

DocumentPageBreak Constructor
DocumentPageBreak Class See Also Send Feedback
Initializes a new instance of the DocumentPageBreak class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentPageBreak()

See Also

DocumentPageBreak Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentPageBreak Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentPageBreak Methods
DocumentPageBreak Class See Also Send Feedback

The DocumentPageBreak type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentPageBreak Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentPageBreak Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentPageBreak Properties
DocumentPageBreak Class See Also Send Feedback

The DocumentPageBreak type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentPageBreak Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentRatio Class

DocumentRatio Class
Members See Also Send Feedback
Represents ratio element

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentRatio : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentRatio

See Also

DocumentRatio Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentRatio Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentRatio Members
DocumentRatio Class Constructors Methods Properties See Also Send Feedback

The DocumentRatio type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentRatio | Initializes a new instance of the DocumentRatio class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDocumentStatus | Gets the document value representation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | FormattedValue | Gets or sets the formatted value.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Value | Gets or sets the value.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentRatio Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentRatio Constructor

DocumentRatio Constructor
DocumentRatio Class See Also Send Feedback
Initializes a new instance of the DocumentRatio class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentRatio()

See Also

DocumentRatio Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentRatio Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentRatio Methods
DocumentRatio Class See Also Send Feedback

The DocumentRatio type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDocumentStatus | Gets the document value representation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentRatio Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetDocumentStatus Method

DocumentRatio..::..GetDocumentStatus Method
DocumentRatio Class See Also Send Feedback
Gets the document value representation.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentStatus GetDocumentStatus()

Return Value

See Also

DocumentRatio Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentRatio Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentRatio Properties
DocumentRatio Class See Also Send Feedback

The DocumentRatio type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | FormattedValue | Gets or sets the formatted value.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Value | Gets or sets the value.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentRatio Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


FormattedValue Property

DocumentRatio..::..FormattedValue Property
DocumentRatio Class See Also Send Feedback
Gets or sets the formatted value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string FormattedValue { get; set; }

Field Value

The formatted value.

See Also

DocumentRatio Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Name Property

DocumentRatio..::..Name Property
DocumentRatio Class See Also Send Feedback
Gets or sets the name.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

Field Value

The name.

See Also

DocumentRatio Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Value Property

DocumentRatio..::..Value Property
DocumentRatio Class See Also Send Feedback
Gets or sets the value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Value { get; set; }

Field Value

The value.

See Also

DocumentRatio Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentSection Class

DocumentSection Class
Members See Also Send Feedback
Represents document section

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentSection : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentSection
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentContentTable

See Also

DocumentSection Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentSection Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentSection Members
DocumentSection Class Constructors Methods Properties See Also Send Feedback

The DocumentSection type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentSection()()()() | Initializes a new instance of the DocumentSection class.
Public method | DocumentSection(String, Int16) | Initializes a new instance of the DocumentSection class.
Public method | DocumentSection(DocumentSection, Document, String, Int32, Boolean) | Initializes a new instance of the DocumentSection class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevel | Gets the level of the section.
Public method | GetSectionOfName(String) | Gets the section of specific name.
 | GetSectionOfName(String, DocumentBody) | Gets the section of specific name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetAdditionalData | Sets the additional data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Anchor | Gets or sets the anchor.
Public property | Body | Gets or sets the body.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name.
Public property | ParentDocument | Gets or sets the parent document.
Public property | ParentSection | Gets or sets the parent section.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentSection Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentSection Constructor
DocumentSection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DocumentSection()()()() | Initializes a new instance of the DocumentSection class.
Public method | DocumentSection(String, Int16) | Initializes a new instance of the DocumentSection class.
Public method | DocumentSection(DocumentSection, Document, String, Int32, Boolean) | Initializes a new instance of the DocumentSection class.

See Also

DocumentSection Class
DocumentSection Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentSection Constructor

DocumentSection Constructor
DocumentSection Class See Also Send Feedback
Initializes a new instance of the DocumentSection class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection()

See Also

DocumentSection Class
DocumentSection Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentSection Constructor (String, Int16)

DocumentSection Constructor (String, Int16)
DocumentSection Class See Also Send Feedback
Initializes a new instance of the DocumentSection class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection(
    string name,
    short titleSize
)

Parameters

name
Type: System..::..String
The name.
titleSize
Type: System..::..Int16
Size of the title.

See Also

DocumentSection Class
DocumentSection Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentSection Constructor (DocumentSection, Document, String, Int32, Boolean)

DocumentSection Constructor (DocumentSection, Document, String, Int32, Boolean)
DocumentSection Class See Also Send Feedback
Initializes a new instance of the DocumentSection class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection(
    DocumentSection parentSection,
    Document parentDocument,
    string name,
    int position,
    bool addToParent
)

Parameters

parentSection
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentSection
The parent section.
parentDocument
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The parent document.
name
Type: System..::..String
The name.
position
Type: System..::..Int32
The position.
addToParent
Type: System..::..Boolean
if set to true the element will be added to parent (section or if section is null to document).

See Also

DocumentSection Class
DocumentSection Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentSection Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentSection Methods
DocumentSection Class See Also Send Feedback

The DocumentSection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevel | Gets the level of the section.
Public method | GetSectionOfName(String) | Gets the section of specific name.
 | GetSectionOfName(String, DocumentBody) | Gets the section of specific name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetAdditionalData | Sets the additional data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetLevel Method

DocumentSection..::..GetLevel Method
DocumentSection Class See Also Send Feedback
Gets the level of the section.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int GetLevel()

Return Value

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetSectionOfName Method

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentSection..::..GetSectionOfName Method
DocumentSection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSectionOfName(String) | Gets the section of specific name.
 | GetSectionOfName(String, DocumentBody) | Gets the section of specific name.

See Also

DocumentSection Class
DocumentSection Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetSectionOfName Method (String)

DocumentSection..::..GetSectionOfName Method (String)
DocumentSection Class See Also Send Feedback
Gets the section of specific name.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection GetSectionOfName(
    string name
)

Parameters

name
Type: System..::..String
The name.

Return Value

See Also

DocumentSection Class
GetSectionOfName Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetSectionOfName Method (String, DocumentBody)

DocumentSection..::..GetSectionOfName Method (String, DocumentBody)
DocumentSection Class See Also Send Feedback
Gets the section of specific name.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DocumentSection GetSectionOfName(
    string name,
    DocumentBody body
)

Parameters

name
Type: System..::..String
The name.
body
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBody
The body.

Return Value

See Also

DocumentSection Class
GetSectionOfName Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


SetAdditionalData Method

DocumentSection..::..SetAdditionalData Method
DocumentSection Class See Also Send Feedback
Sets the additional data.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetAdditionalData(
    string key,
    Object data
)

Parameters

key
Type: System..::..String
The key.
data
Type: System..::..Object
The data.

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentSection Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentSection Properties
DocumentSection Class See Also Send Feedback

The DocumentSection type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Anchor | Gets or sets the anchor.
Public property | Body | Gets or sets the body.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name.
Public property | ParentDocument | Gets or sets the parent document.
Public property | ParentSection | Gets or sets the parent section.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Anchor Property

DocumentSection..::..Anchor Property
DocumentSection Class See Also Send Feedback
Gets or sets the anchor.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentAnchor Anchor { get; set; }

Field Value

The anchor.

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Body Property

DocumentSection..::..Body Property
DocumentSection Class See Also Send Feedback
Gets or sets the body.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentBody Body { get; set; }

Field Value

The body.

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Name Property

DocumentSection..::..Name Property
DocumentSection Class See Also Send Feedback
Gets or sets the name.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

Field Value

The name.

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


ParentDocument Property

DocumentSection..::..ParentDocument Property
DocumentSection Class See Also Send Feedback
Gets or sets the parent document.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document ParentDocument { get; set; }

Field Value

The parent document.

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


ParentSection Property

DocumentSection..::..ParentSection Property
DocumentSection Class See Also Send Feedback
Gets or sets the parent section.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection ParentSection { get; set; }

Field Value

The parent section.

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Title Property

DocumentSection..::..Title Property
DocumentSection Class See Also Send Feedback
Gets or sets the title.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentTitle Title { get; set; }

Field Value

The title.

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentStatus Class

DocumentStatus Class
Members See Also Send Feedback
Represents document status element

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentStatus : DocumentValueWithName

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValue
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValueWithName
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentStatus

See Also

DocumentStatus Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentStatus Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentStatus Members
DocumentStatus Class Constructors Methods Properties See Also Send Feedback

The DocumentStatus type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentStatus | Initializes a new instance of the DocumentStatus class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNameWithPostfix | Gets the name with postfix. (Inherited from DocumentValueWithName.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element. (Inherited from DocumentValue.)
Public property | Condition | The condition.
Public property | Correct | The flag indicating if value is correct.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Message | The message.
Public property | Name | The name of the value. (Inherited from DocumentValueWithName.)
Public property | NamePostfix | The name postfix. (Inherited from DocumentValueWithName.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Value | The value. (Inherited from DocumentValue.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentStatus Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentStatus Constructor

DocumentStatus Constructor
DocumentStatus Class See Also Send Feedback
Initializes a new instance of the DocumentStatus class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentStatus(
    string name,
    string condition,
    string message,
    bool correct,
    Object value
)

Parameters

name
Type: System..::..String
The name.
condition
Type: System..::..String
The condition.
message
Type: System..::..String
The message.
correct
Type: System..::..Boolean
if set to true [correct].
value
Type: System..::..Object
The value.

See Also

DocumentStatus Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentStatus Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentStatus Methods
DocumentStatus Class See Also Send Feedback

The DocumentStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNameWithPostfix | Gets the name with postfix. (Inherited from DocumentValueWithName.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentStatus Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentStatus Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentStatus Properties
DocumentStatus Class See Also Send Feedback

The DocumentStatus type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element. (Inherited from DocumentValue.)
Public property | Condition | The condition.
Public property | Correct | The flag indicating if value is correct.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Message | The message.
Public property | Name | The name of the value. (Inherited from DocumentValueWithName.)
Public property | NamePostfix | The name postfix. (Inherited from DocumentValueWithName.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Value | The value. (Inherited from DocumentValue.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentStatus Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Condition Property

DocumentStatus..::..Condition Property
DocumentStatus Class See Also Send Feedback
The condition.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Condition { get; internal set; }

See Also

DocumentStatus Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Correct Property

DocumentStatus..::..Correct Property
DocumentStatus Class See Also Send Feedback
The flag indicating if value is correct.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Correct { get; internal set; }

See Also

DocumentStatus Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Message Property

DocumentStatus..::..Message Property
DocumentStatus Class See Also Send Feedback
The message.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Message { get; internal set; }

See Also

DocumentStatus Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTable Class

DocumentTable Class
Members See Also Send Feedback
Represents the table element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentTable : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentTable

See Also

DocumentTable Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTable Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentTable Members
DocumentTable Class Constructors Methods Properties See Also Send Feedback

The DocumentTable type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentTable | Initializes the instance of the DocumentTable class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | ColumnsCount | Number of columns.
Public property | HeaderColumnsCount | Number of header columns.
Public property | HeaderRowsCount | Number of header rows.
Public property | Item | Returns the specific cell of the table.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | PercentageColumnWidth | Gets the width of columns in procentage units.
Public property | RowsCount | Number of rows.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTable Constructor

DocumentTable Constructor
DocumentTable Class See Also Send Feedback
Initializes the instance of the DocumentTable class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentTable(
    int rowsCount,
    int columnsCount
)

Parameters

rowsCount
Type: System..::..Int32
Number of rows.
columnsCount
Type: System..::..Int32
Number of columns

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTable Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentTable Methods
DocumentTable Class See Also Send Feedback

The DocumentTable type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTable Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentTable Properties
DocumentTable Class See Also Send Feedback

The DocumentTable type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | ColumnsCount | Number of columns.
Public property | HeaderColumnsCount | Number of header columns.
Public property | HeaderRowsCount | Number of header rows.
Public property | Item | Returns the specific cell of the table.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | PercentageColumnWidth | Gets the width of columns in procentage units.
Public property | RowsCount | Number of rows.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


ColumnsCount Property

DocumentTable..::..ColumnsCount Property
DocumentTable Class See Also Send Feedback
Number of columns.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int ColumnsCount { get; private set; }

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


HeaderColumnsCount Property

DocumentTable..::..HeaderColumnsCount Property
DocumentTable Class See Also Send Feedback
Number of header columns.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int HeaderColumnsCount { get; set; }

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


HeaderRowsCount Property

DocumentTable..::..HeaderRowsCount Property
DocumentTable Class See Also Send Feedback
Number of header rows.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int HeaderRowsCount { get; set; }

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Item Property

DocumentTable..::..Item Property
DocumentTable Class See Also Send Feedback
Returns the specific cell of the table.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentTableCell this[
    int row,
    int column
] { get; }

Parameters

row
Type: System..::..Int32
The row index.
column
Type: System..::..Int32
The column index.

Return Value

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


PercentageColumnWidth Property

DocumentTable..::..PercentageColumnWidth Property
DocumentTable Class See Also Send Feedback
Gets the width of columns in procentage units.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int[] PercentageColumnWidth { get; internal set; }

Field Value

The width of the column.

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


RowsCount Property

DocumentTable..::..RowsCount Property
DocumentTable Class See Also Send Feedback
Number of rows.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int RowsCount { get; private set; }

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Title Property

DocumentTable..::..Title Property
DocumentTable Class See Also Send Feedback
Gets or sets the title.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentTitle Title { get; set; }

Field Value

The title.

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTableCell Class

DocumentTableCell Class
Members See Also Send Feedback
Represents the cell of the table

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentTableCell : DocumentBody

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBody
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentTableCell

See Also

DocumentTableCell Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTableCell Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentTableCell Members
DocumentTableCell Class Constructors Methods Properties See Also Send Feedback

The DocumentTableCell type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentTableCell | Initializes a new instance of the DocumentTableCell class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetElementCount | Gets the element count. (Inherited from DocumentBody.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Elements | List of document elements. (Inherited from DocumentBody.)

See Also

DocumentTableCell Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTableCell Constructor

DocumentTableCell Constructor
DocumentTableCell Class See Also Send Feedback
Initializes a new instance of the DocumentTableCell class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentTableCell()

See Also

DocumentTableCell Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTableCell Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentTableCell Methods
DocumentTableCell Class See Also Send Feedback

The DocumentTableCell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetElementCount | Gets the element count. (Inherited from DocumentBody.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentTableCell Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTableCell Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentTableCell Properties
DocumentTableCell Class See Also Send Feedback

The DocumentTableCell type exposes the following members.

Properties

 | Name | Description
Public property | Elements | List of document elements. (Inherited from DocumentBody.)

See Also

DocumentTableCell Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentText Class

DocumentText Class
Members See Also Send Feedback
Represents the text element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentText : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentText
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentTitle

See Also

DocumentText Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentText Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentText Members
DocumentText Class Constructors Methods Properties See Also Send Feedback

The DocumentText type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentText()()()() | Initializes a new instance of the DocumentText class.
Public method | DocumentText(String, Boolean) | Initializes a new instance of the DocumentText class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Text | The text.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentText Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentText Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentText Constructor
DocumentText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DocumentText()()()() | Initializes a new instance of the DocumentText class.
Public method | DocumentText(String, Boolean) | Initializes a new instance of the DocumentText class.

See Also

DocumentText Class
DocumentText Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentText Constructor

DocumentText Constructor
DocumentText Class See Also Send Feedback
Initializes a new instance of the DocumentText class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentText()

See Also

DocumentText Class
DocumentText Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentText Constructor (String, Boolean)

DocumentText Constructor (String, Boolean)
DocumentText Class See Also Send Feedback
Initializes a new instance of the DocumentText class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentText(
    string txt,
    bool addLineBreak
)

Parameters

txt
Type: System..::..String
The text.
addLineBreak
Type: System..::..Boolean
if set to true line break will be added after element.

See Also

DocumentText Class
DocumentText Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentText Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentText Methods
DocumentText Class See Also Send Feedback

The DocumentText type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentText Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentText Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentText Properties
DocumentText Class See Also Send Feedback

The DocumentText type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Text | The text.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentText Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


AddLineBreak Property

DocumentText..::..AddLineBreak Property
DocumentText Class See Also Send Feedback
Gets or sets a value indicating whether line break should be added after the element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AddLineBreak { get; set; }

Field Value

true if line break should be added; otherwise, false.

See Also

DocumentText Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Text Property

DocumentText..::..Text Property
DocumentText Class See Also Send Feedback
The text.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Text { get; set; }

See Also

DocumentText Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTitle Class

DocumentTitle Class
Members See Also Send Feedback
Represents the title element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentTitle : DocumentText

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentText
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentTitle

See Also

DocumentTitle Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTitle Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentTitle Members
DocumentTitle Class Constructors Methods Properties See Also Send Feedback

The DocumentTitle type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentTitle()()()() | Initializes a new instance of the DocumentTitle class.
Public method | DocumentTitle(Int16) | Initializes a new instance of the DocumentTitle class.
Public method | DocumentTitle(String, Int16) | Initializes a new instance of the DocumentTitle class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element. (Inherited from DocumentText.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Size | Gets or sets the size.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Text | The text. (Inherited from DocumentText.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentTitle Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTitle Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentTitle Constructor
DocumentTitle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DocumentTitle()()()() | Initializes a new instance of the DocumentTitle class.
Public method | DocumentTitle(Int16) | Initializes a new instance of the DocumentTitle class.
Public method | DocumentTitle(String, Int16) | Initializes a new instance of the DocumentTitle class.

See Also

DocumentTitle Class
DocumentTitle Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTitle Constructor

DocumentTitle Constructor
DocumentTitle Class See Also Send Feedback
Initializes a new instance of the DocumentTitle class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentTitle()

See Also

DocumentTitle Class
DocumentTitle Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTitle Constructor (Int16)

DocumentTitle Constructor (Int16)
DocumentTitle Class See Also Send Feedback
Initializes a new instance of the DocumentTitle class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentTitle(
    short size
)

Parameters

size
Type: System..::..Int16
The size.

See Also

DocumentTitle Class
DocumentTitle Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTitle Constructor (String, Int16)

DocumentTitle Constructor (String, Int16)
DocumentTitle Class See Also Send Feedback
Initializes a new instance of the DocumentTitle class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentTitle(
    string text,
    short size
)

Parameters

text
Type: System..::..String
The text.
size
Type: System..::..Int16
The size.

See Also

DocumentTitle Class
DocumentTitle Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTitle Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentTitle Methods
DocumentTitle Class See Also Send Feedback

The DocumentTitle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentTitle Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentTitle Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentTitle Properties
DocumentTitle Class See Also Send Feedback

The DocumentTitle type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element. (Inherited from DocumentText.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Size | Gets or sets the size.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Text | The text. (Inherited from DocumentText.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentTitle Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Size Property

DocumentTitle..::..Size Property
DocumentTitle Class See Also Send Feedback
Gets or sets the size.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public short Size { get; set; }

Field Value

The size.

See Also

DocumentTitle Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValue Class

DocumentValue Class
Members See Also Send Feedback
Represents the value element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentValue : DocumentElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValue
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValueWithName

See Also

DocumentValue Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValue Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValue Members
DocumentValue Class Constructors Methods Properties See Also Send Feedback

The DocumentValue type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentValue(Object, Boolean) | Initializes a new instance of the DocumentValue class.
Public method | DocumentValue(Double, DisplayUnitType, UnitType, Units, Boolean) | Initializes a new instance of the DocumentValue class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Value | The value.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentValue Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValue Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValue Constructor
DocumentValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DocumentValue(Object, Boolean) | Initializes a new instance of the DocumentValue class.
Public method | DocumentValue(Double, DisplayUnitType, UnitType, Units, Boolean) | Initializes a new instance of the DocumentValue class.

See Also

DocumentValue Class
DocumentValue Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValue Constructor (Object, Boolean)

DocumentValue Constructor (Object, Boolean)
DocumentValue Class See Also Send Feedback
Initializes a new instance of the DocumentValue class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentValue(
    Object value,
    bool addLineBreak
)

Parameters

value
Type: System..::..Object
The value.
addLineBreak
Type: System..::..Boolean
if set to true line break will be added after element.

See Also

DocumentValue Class
DocumentValue Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValue Constructor (Double, , , , Boolean)

DocumentValue Constructor (Double, , , , Boolean)
DocumentValue Class See Also Send Feedback
Initializes a new instance of the DocumentValue class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentValue(
    double value,
    DisplayUnitType inputDispUnit,
    UnitType unitType,
    Units units,
    bool addLineBreak
)

Parameters

value
Type: System..::..Double
The value.
inputDispUnit
Type: DisplayUnitType
The input display unit.
unitType
Type: UnitType
Type of the unit.
units
Type: Units
The units.
addLineBreak
Type: System..::..Boolean
if set to true line break will be added after element.

See Also

DocumentValue Class
DocumentValue Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValue Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValue Methods
DocumentValue Class See Also Send Feedback

The DocumentValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentValue Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValue Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValue Properties
DocumentValue Class See Also Send Feedback

The DocumentValue type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Value | The value.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentValue Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


AddLineBreak Property

DocumentValue..::..AddLineBreak Property
DocumentValue Class See Also Send Feedback
Gets or sets a value indicating whether line break should be added after the element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AddLineBreak { get; set; }

Field Value

true if line break should be added; otherwise, false.

See Also

DocumentValue Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Value Property

DocumentValue..::..Value Property
DocumentValue Class See Also Send Feedback
The value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Value { get; set; }

See Also

DocumentValue Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithDescription Class

DocumentValueWithDescription Class
Members See Also Send Feedback
Represents document value element with additional description

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentValueWithDescription : DocumentValueWithName

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValue
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValueWithName
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValueWithDescription

See Also

DocumentValueWithDescription Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithDescription Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValueWithDescription Members
DocumentValueWithDescription Class Constructors Methods Properties See Also Send Feedback

The DocumentValueWithDescription type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentValueWithDescription(String, Object, String, String, String) | Initializes a new instance of the DocumentValue class.
Public method | DocumentValueWithDescription(String, String, String, Double, DisplayUnitType, UnitType, Units, Boolean) | Initializes a new instance of the DocumentValueWithDescription class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNameWithPostfix | Gets the name with postfix. (Inherited from DocumentValueWithName.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element. (Inherited from DocumentValue.)
Public property | Description | The value description.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | The name of the value. (Inherited from DocumentValueWithName.)
Public property | NamePostfix | The name postfix. (Inherited from DocumentValueWithName.)
Public property | Note | The not.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Unit | The unit.
Public property | Value | The value. (Inherited from DocumentValue.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentValueWithDescription Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithDescription Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValueWithDescription Constructor
DocumentValueWithDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DocumentValueWithDescription(String, Object, String, String, String) | Initializes a new instance of the DocumentValue class.
Public method | DocumentValueWithDescription(String, String, String, Double, DisplayUnitType, UnitType, Units, Boolean) | Initializes a new instance of the DocumentValueWithDescription class.

See Also

DocumentValueWithDescription Class
DocumentValueWithDescription Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithDescription Constructor (String, Object, String, String, String)

DocumentValueWithDescription Constructor (String, Object, String, String, String)
DocumentValueWithDescription Class See Also Send Feedback
Initializes a new instance of the DocumentValue class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentValueWithDescription(
    string name,
    Object value,
    string unit,
    string description,
    string note
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..Object
The value.
unit
Type: System..::..String
The unit.
description
Type: System..::..String
The description.
note
Type: System..::..String
The note.

See Also

DocumentValueWithDescription Class
DocumentValueWithDescription Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithDescription Constructor (String, String, String, Double, , , , Boolean)

DocumentValueWithDescription Constructor (String, String, String, Double, , , , Boolean)
DocumentValueWithDescription Class See Also Send Feedback
Initializes a new instance of the DocumentValueWithDescription class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentValueWithDescription(
    string name,
    string description,
    string note,
    double value,
    DisplayUnitType inputDispUnit,
    UnitType unitType,
    Units units,
    bool addLineBreak
)

Parameters

name
Type: System..::..String
The name.
description
Type: System..::..String
The description.
note
Type: System..::..String
The note.
value
Type: System..::..Double
The value.
inputDispUnit
Type: DisplayUnitType
The input display unit.
unitType
Type: UnitType
Type of the unit.
units
Type: Units
The units.
addLineBreak
Type: System..::..Boolean
if set to true line break will be added after element.

See Also

DocumentValueWithDescription Class
DocumentValueWithDescription Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithDescription Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValueWithDescription Methods
DocumentValueWithDescription Class See Also Send Feedback

The DocumentValueWithDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNameWithPostfix | Gets the name with postfix. (Inherited from DocumentValueWithName.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentValueWithDescription Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithDescription Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValueWithDescription Properties
DocumentValueWithDescription Class See Also Send Feedback

The DocumentValueWithDescription type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element. (Inherited from DocumentValue.)
Public property | Description | The value description.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | The name of the value. (Inherited from DocumentValueWithName.)
Public property | NamePostfix | The name postfix. (Inherited from DocumentValueWithName.)
Public property | Note | The not.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Unit | The unit.
Public property | Value | The value. (Inherited from DocumentValue.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentValueWithDescription Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Description Property

DocumentValueWithDescription..::..Description Property
DocumentValueWithDescription Class See Also Send Feedback
The value description.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Description { get; internal set; }

See Also

DocumentValueWithDescription Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Note Property

DocumentValueWithDescription..::..Note Property
DocumentValueWithDescription Class See Also Send Feedback
The not.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Note { get; internal set; }

See Also

DocumentValueWithDescription Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Unit Property

DocumentValueWithDescription..::..Unit Property
DocumentValueWithDescription Class See Also Send Feedback
The unit.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Unit { get; internal set; }

See Also

DocumentValueWithDescription Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithName Class

DocumentValueWithName Class
Members See Also Send Feedback
Represents document value with name

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DocumentValueWithName : DocumentValue

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentElement
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValue
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValueWithName
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentStatus
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentValueWithDescription

See Also

DocumentValueWithName Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithName Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValueWithName Members
DocumentValueWithName Class Constructors Methods Properties See Also Send Feedback

The DocumentValueWithName type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentValueWithName(String, Object) | Initializes a new instance of the DocumentValue class.
Public method | DocumentValueWithName(String, Double, DisplayUnitType, UnitType, Units, Boolean) | Initializes a new instance of the DocumentValueWithName class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNameWithPostfix | Gets the name with postfix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element. (Inherited from DocumentValue.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | The name of the value.
Public property | NamePostfix | The name postfix.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Value | The value. (Inherited from DocumentValue.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentValueWithName Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithName Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValueWithName Constructor
DocumentValueWithName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DocumentValueWithName(String, Object) | Initializes a new instance of the DocumentValue class.
Public method | DocumentValueWithName(String, Double, DisplayUnitType, UnitType, Units, Boolean) | Initializes a new instance of the DocumentValueWithName class.

See Also

DocumentValueWithName Class
DocumentValueWithName Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithName Constructor (String, Object)

DocumentValueWithName Constructor (String, Object)
DocumentValueWithName Class See Also Send Feedback
Initializes a new instance of the DocumentValue class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentValueWithName(
    string name,
    Object value
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..Object
The value.

See Also

DocumentValueWithName Class
DocumentValueWithName Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithName Constructor (String, Double, , , , Boolean)

DocumentValueWithName Constructor (String, Double, , , , Boolean)
DocumentValueWithName Class See Also Send Feedback
Initializes a new instance of the DocumentValueWithName class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentValueWithName(
    string name,
    double value,
    DisplayUnitType inputDispUnit,
    UnitType unitType,
    Units units,
    bool addLineBreak
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..Double
The value.
inputDispUnit
Type: DisplayUnitType
The input display unit.
unitType
Type: UnitType
Type of the unit.
units
Type: Units
The units.
addLineBreak
Type: System..::..Boolean
if set to true line break will be added after element.

See Also

DocumentValueWithName Class
DocumentValueWithName Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithName Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValueWithName Methods
DocumentValueWithName Class See Also Send Feedback

The DocumentValueWithName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNameWithPostfix | Gets the name with postfix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentValueWithName Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetNameWithPostfix Method

DocumentValueWithName..::..GetNameWithPostfix Method
DocumentValueWithName Class See Also Send Feedback
Gets the name with postfix.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string GetNameWithPostfix()

Return Value

See Also

DocumentValueWithName Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


DocumentValueWithName Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentValueWithName Properties
DocumentValueWithName Class See Also Send Feedback

The DocumentValueWithName type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element. (Inherited from DocumentValue.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | The name of the value.
Public property | NamePostfix | The name postfix.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Value | The value. (Inherited from DocumentValue.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentValueWithName Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Name Property

DocumentValueWithName..::..Name Property
DocumentValueWithName Class See Also Send Feedback
The name of the value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

See Also

DocumentValueWithName Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


NamePostfix Property

DocumentValueWithName..::..NamePostfix Property
DocumentValueWithName Class See Also Send Feedback
The name postfix.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string NamePostfix { get; set; }

See Also

DocumentValueWithName Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


HtmlBuilder Class

HtmlBuilder Class
Members See Also Send Feedback
Represents html files builder

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class HtmlBuilder : DocumentBuilder

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBuilder
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..HtmlBuilder
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..MhtBuilder

See Also

HtmlBuilder Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


HtmlBuilder Members

[image]

Structural Analysis and Code Checking API Reference Guide
HtmlBuilder Members
HtmlBuilder Class Constructors Methods Properties See Also Send Feedback

The HtmlBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlBuilder | Initializes a new instance of the HtmlBuilder class

Methods

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file. (Inherited from DocumentBuilder.)
Public method | BuildDocument(Document, Document, String, DetailLevel) | Builds document. (Overrides DocumentBuilder..::..BuildDocument(Document, Document, String, DetailLevel).)
Public method | BuildDocuments | Builds the documents. (Overrides DocumentBuilder..::..BuildDocuments(Document, Document, DetailLevel).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetBitmapHeader | Gets the bitmap header.
Public method | GetExtension | Gets the extension of the file (without dot). (Overrides DocumentBuilder..::..GetExtension()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStyleSheet | Gets the style sheet.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
StyleSheet | Gets or sets the style sheet.

See Also

HtmlBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


HtmlBuilder Constructor

HtmlBuilder Constructor
HtmlBuilder Class See Also Send Feedback
Initializes a new instance of the HtmlBuilder class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public HtmlBuilder()

See Also

HtmlBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


HtmlBuilder Methods

[image]

Structural Analysis and Code Checking API Reference Guide
HtmlBuilder Methods
HtmlBuilder Class See Also Send Feedback

The HtmlBuilder type exposes the following members.

Methods

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file. (Inherited from DocumentBuilder.)
Public method | BuildDocument(Document, Document, String, DetailLevel) | Builds document. (Overrides DocumentBuilder..::..BuildDocument(Document, Document, String, DetailLevel).)
Public method | BuildDocuments | Builds the documents. (Overrides DocumentBuilder..::..BuildDocuments(Document, Document, DetailLevel).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetBitmapHeader | Gets the bitmap header.
Public method | GetExtension | Gets the extension of the file (without dot). (Overrides DocumentBuilder..::..GetExtension()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStyleSheet | Gets the style sheet.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HtmlBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocument Method

[image]

Structural Analysis and Code Checking API Reference Guide
HtmlBuilder..::..BuildDocument Method
HtmlBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file. (Inherited from DocumentBuilder.)
Public method | BuildDocument(Document, Document, String, DetailLevel) | Builds document. (Overrides DocumentBuilder..::..BuildDocument(Document, Document, String, DetailLevel).)

See Also

HtmlBuilder Class
HtmlBuilder Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocument Method (Document, , String, DetailLevel)

HtmlBuilder..::..BuildDocument Method (Document, , String, DetailLevel)
HtmlBuilder Class See Also Send Feedback
Builds document.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override string BuildDocument(
    Document document,
    Document revitDocument,
    string path,
    DetailLevel detailLevel
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document.
revitDocument
Type: Document
The Revit document.
path
Type: System..::..String
The path.
detailLevel
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
Detail level

Return Value

The file.

See Also

HtmlBuilder Class
BuildDocument Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocuments Method

HtmlBuilder..::..BuildDocuments Method
HtmlBuilder Class See Also Send Feedback
Builds the documents.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override List<string> BuildDocuments(
    Document document,
    Document revitDocument,
    DetailLevel detailLevel
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document.
revitDocument
Type: Document
Revit document.
detailLevel
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
The detail level.

Return Value

See Also

HtmlBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetBitmapHeader Method

HtmlBuilder..::..GetBitmapHeader Method
HtmlBuilder Class See Also Send Feedback
Gets the bitmap header.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string GetBitmapHeader()

Return Value

See Also

HtmlBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetExtension Method

HtmlBuilder..::..GetExtension Method
HtmlBuilder Class See Also Send Feedback
Gets the extension of the file (without dot).

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override string GetExtension()

Return Value

See Also

HtmlBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetStyleSheet Method

HtmlBuilder..::..GetStyleSheet Method
HtmlBuilder Class See Also Send Feedback
Gets the style sheet.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string GetStyleSheet()

Return Value

See Also

HtmlBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


HtmlBuilder Properties

[image]

Structural Analysis and Code Checking API Reference Guide
HtmlBuilder Properties
HtmlBuilder Class See Also Send Feedback

The HtmlBuilder type exposes the following members.

Properties

Name | Description
StyleSheet | Gets or sets the style sheet.

See Also

HtmlBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


StyleSheet Property

HtmlBuilder..::..StyleSheet Property
HtmlBuilder Class See Also Send Feedback
Gets or sets the style sheet.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string StyleSheet { get; set; }

Field Value

The style sheet.

See Also

HtmlBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


MhtBuilder Class

MhtBuilder Class
Members See Also Send Feedback
Represents mht files builder

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class MhtBuilder : HtmlBuilder

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBuilder
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..HtmlBuilder
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..MhtBuilder

See Also

MhtBuilder Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


MhtBuilder Members

[image]

Structural Analysis and Code Checking API Reference Guide
MhtBuilder Members
MhtBuilder Class Constructors Methods See Also Send Feedback

The MhtBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | MhtBuilder | Initializes a new instance of the MhtBuilder class

Methods

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file. (Inherited from DocumentBuilder.)
Public method | BuildDocument(Document, Document, String, DetailLevel) | Builds document. (Inherited from HtmlBuilder.)
Public method | BuildDocuments | Builds the documents. (Inherited from HtmlBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtension | Gets the extension of the file (without dot). (Overrides HtmlBuilder..::..GetExtension()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MhtBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


MhtBuilder Constructor

MhtBuilder Constructor
MhtBuilder Class See Also Send Feedback
Initializes a new instance of the MhtBuilder class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MhtBuilder()

See Also

MhtBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


MhtBuilder Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MhtBuilder Methods
MhtBuilder Class See Also Send Feedback

The MhtBuilder type exposes the following members.

Methods

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file. (Inherited from DocumentBuilder.)
Public method | BuildDocument(Document, Document, String, DetailLevel) | Builds document. (Inherited from HtmlBuilder.)
Public method | BuildDocuments | Builds the documents. (Inherited from HtmlBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtension | Gets the extension of the file (without dot). (Overrides HtmlBuilder..::..GetExtension()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MhtBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocument Method

[image]

Structural Analysis and Code Checking API Reference Guide
MhtBuilder..::..BuildDocument Method
MhtBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file. (Inherited from DocumentBuilder.)
Public method | BuildDocument(Document, Document, String, DetailLevel) | Builds document. (Inherited from HtmlBuilder.)

See Also

MhtBuilder Class
MhtBuilder Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetExtension Method

MhtBuilder..::..GetExtension Method
MhtBuilder Class See Also Send Feedback
Gets the extension of the file (without dot).

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override string GetExtension()

Return Value

See Also

MhtBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


TextBuilder Class

TextBuilder Class
Members See Also Send Feedback
Represents html files builder

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class TextBuilder : DocumentBuilder

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentBuilder
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..TextBuilder

See Also

TextBuilder Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


TextBuilder Members

[image]

Structural Analysis and Code Checking API Reference Guide
TextBuilder Members
TextBuilder Class Constructors Methods See Also Send Feedback

The TextBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | TextBuilder | Initializes a new instance of the TextBuilder class

Methods

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file. (Inherited from DocumentBuilder.)
Public method | BuildDocument(Document, Document, String, DetailLevel) | Builds document. (Overrides DocumentBuilder..::..BuildDocument(Document, Document, String, DetailLevel).)
Public method | BuildDocuments | Builds the documents. (Overrides DocumentBuilder..::..BuildDocuments(Document, Document, DetailLevel).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtension | Gets the extension of the file (without dot). (Overrides DocumentBuilder..::..GetExtension()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


TextBuilder Constructor

TextBuilder Constructor
TextBuilder Class See Also Send Feedback
Initializes a new instance of the TextBuilder class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TextBuilder()

See Also

TextBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


TextBuilder Methods

[image]

Structural Analysis and Code Checking API Reference Guide
TextBuilder Methods
TextBuilder Class See Also Send Feedback

The TextBuilder type exposes the following members.

Methods

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file. (Inherited from DocumentBuilder.)
Public method | BuildDocument(Document, Document, String, DetailLevel) | Builds document. (Overrides DocumentBuilder..::..BuildDocument(Document, Document, String, DetailLevel).)
Public method | BuildDocuments | Builds the documents. (Overrides DocumentBuilder..::..BuildDocuments(Document, Document, DetailLevel).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtension | Gets the extension of the file (without dot). (Overrides DocumentBuilder..::..GetExtension()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocument Method

[image]

Structural Analysis and Code Checking API Reference Guide
TextBuilder..::..BuildDocument Method
TextBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file. (Inherited from DocumentBuilder.)
Public method | BuildDocument(Document, Document, String, DetailLevel) | Builds document. (Overrides DocumentBuilder..::..BuildDocument(Document, Document, String, DetailLevel).)

See Also

TextBuilder Class
TextBuilder Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocument Method (Document, , String, DetailLevel)

TextBuilder..::..BuildDocument Method (Document, , String, DetailLevel)
TextBuilder Class See Also Send Feedback
Builds document.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override string BuildDocument(
    Document document,
    Document revitDocument,
    string path,
    DetailLevel detailLevel
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document.
revitDocument
Type: Document
The Revit document.
path
Type: System..::..String
The path.
detailLevel
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
Detail level

Return Value

The file.

See Also

TextBuilder Class
BuildDocument Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


BuildDocuments Method

TextBuilder..::..BuildDocuments Method
TextBuilder Class See Also Send Feedback
Builds the documents.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override List<string> BuildDocuments(
    Document document,
    Document revitDocument,
    DetailLevel detailLevel
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document.
revitDocument
Type: Document
Revit document.
detailLevel
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
The detail level.

Return Value

See Also

TextBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


GetExtension Method

TextBuilder..::..GetExtension Method
TextBuilder Class See Also Send Feedback
Gets the extension of the file (without dot).

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override string GetExtension()

Return Value

See Also

TextBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace


Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace

Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace
Send Feedback

Classes

 | Class | Description
Public class | DefaultElementAttribute | Indicates that particular property will be documented in default way by the system.
Public class | DocumentElementAttribute | Represent the attribute for document.
Public class | ListValueAttribute | Indicates that particular property will be documented as a list
Public class | RatioAttribute | Indicates that property should be presented in the document as a ratio.
Public class | SubSchemaElementAttribute | Indicates that particular property will be documented as a subschema element.
Public class | SubSchemaListTableAttribute | Indicates that particular schema list will be presented as a table.
Public class | TableAttribute | Indicates that particular property will be documented as a table.
Public class | ValueAttribute | Indicates that particular property will be documented as a value.
Public class | ValueWithDescriptionAttribute | Indicates that particular property will be documented as a value with name and description.
Public class | ValueWithNameAttribute | Indicates that particular property will be documented as a value with name.


DefaultElementAttribute Class

DefaultElementAttribute Class
Members See Also Send Feedback
Indicates that particular property will be documented in default way by the system.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DefaultElementAttribute : DocumentElementAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DefaultElementAttribute

See Also

DefaultElementAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


DefaultElementAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultElementAttribute Members
DefaultElementAttribute Class Constructors Methods Properties See Also Send Feedback

The DefaultElementAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultElementAttribute | Initializes a new instance of the DefaultElementAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DefaultElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


DefaultElementAttribute Constructor

DefaultElementAttribute Constructor
DefaultElementAttribute Class See Also Send Feedback
Initializes a new instance of the DefaultElementAttribute class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DefaultElementAttribute()

See Also

DefaultElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


DefaultElementAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultElementAttribute Methods
DefaultElementAttribute Class See Also Send Feedback

The DefaultElementAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefaultElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


DefaultElementAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultElementAttribute Properties
DefaultElementAttribute Class See Also Send Feedback

The DefaultElementAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DefaultElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


DocumentElementAttribute Class

DocumentElementAttribute Class
Members See Also Send Feedback
Represent the attribute for document.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class DocumentElementAttribute : Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DefaultElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..RatioAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueAttribute

See Also

DocumentElementAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


DocumentElementAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentElementAttribute Members
DocumentElementAttribute Class Constructors Methods Properties See Also Send Feedback

The DocumentElementAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentElementAttribute | Initializes a new instance of the DocumentElementAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document.
Public property | Level | Gets or sets the detail level of the element.
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DocumentElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


DocumentElementAttribute Constructor

DocumentElementAttribute Constructor
DocumentElementAttribute Class See Also Send Feedback
Initializes a new instance of the DocumentElementAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentElementAttribute()

See Also

DocumentElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


DocumentElementAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentElementAttribute Methods
DocumentElementAttribute Class See Also Send Feedback

The DocumentElementAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


DocumentElementAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentElementAttribute Properties
DocumentElementAttribute Class See Also Send Feedback

The DocumentElementAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document.
Public property | Level | Gets or sets the detail level of the element.
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DocumentElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


Index Property

DocumentElementAttribute..::..Index Property
DocumentElementAttribute Class See Also Send Feedback
Decides about position of the property in document.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Index { get; set; }

See Also

DocumentElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


Level Property

DocumentElementAttribute..::..Level Property
DocumentElementAttribute Class See Also Send Feedback
Gets or sets the detail level of the element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DetailLevel Level { get; set; }

Field Value

The level.

See Also

DocumentElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


Localizable Property

DocumentElementAttribute..::..Localizable Property
DocumentElementAttribute Class See Also Send Feedback
Gets or sets a value indicating whether this DocumentElementAttribute is localizable.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Localizable { get; set; }

Field Value

true if localizable; otherwise, false.

Remarks

If true GetResource method from appropriate server will be invoked for all attribute properties that may be translated.

See Also

DocumentElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ListValueAttribute Class

ListValueAttribute Class
Members See Also Send Feedback
Indicates that particular property will be documented as a list

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ListValueAttribute : ValueWithNameAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueWithNameAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ListValueAttribute

See Also

ListValueAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ListValueAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ListValueAttribute Members
ListValueAttribute Class Constructors Methods Properties See Also Send Feedback

The ListValueAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ListValueAttribute()()()() | Initializes a new instance of the ListValueAttribute class.
Public method | ListValueAttribute(String) | Initializes a new instance of the ListValueAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ListValueAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ListValueAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ListValueAttribute Constructor
ListValueAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ListValueAttribute()()()() | Initializes a new instance of the ListValueAttribute class.
Public method | ListValueAttribute(String) | Initializes a new instance of the ListValueAttribute class.

See Also

ListValueAttribute Class
ListValueAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ListValueAttribute Constructor

ListValueAttribute Constructor
ListValueAttribute Class See Also Send Feedback
Initializes a new instance of the ListValueAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ListValueAttribute()

See Also

ListValueAttribute Class
ListValueAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ListValueAttribute Constructor (String)

ListValueAttribute Constructor (String)
ListValueAttribute Class See Also Send Feedback
Initializes a new instance of the ListValueAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ListValueAttribute(
    string name
)

Parameters

name
Type: System..::..String
The name.

See Also

ListValueAttribute Class
ListValueAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ListValueAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ListValueAttribute Methods
ListValueAttribute Class See Also Send Feedback

The ListValueAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ListValueAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ListValueAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ListValueAttribute Properties
ListValueAttribute Class See Also Send Feedback

The ListValueAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ListValueAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


RatioAttribute Class

RatioAttribute Class
Members See Also Send Feedback
Indicates that property should be presented in the document as a ratio.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class RatioAttribute : DocumentElementAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..RatioAttribute

See Also

RatioAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


RatioAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
RatioAttribute Members
RatioAttribute Class Constructors Methods Properties See Also Send Feedback

The RatioAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | RatioAttribute | Initializes a new instance of the RatioAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | Name | Gets or sets the name.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

RatioAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


RatioAttribute Constructor

RatioAttribute Constructor
RatioAttribute Class See Also Send Feedback
Initializes a new instance of the RatioAttribute class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public RatioAttribute()

See Also

RatioAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


RatioAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RatioAttribute Methods
RatioAttribute Class See Also Send Feedback

The RatioAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RatioAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


RatioAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
RatioAttribute Properties
RatioAttribute Class See Also Send Feedback

The RatioAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | Name | Gets or sets the name.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

RatioAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


Name Property

RatioAttribute..::..Name Property
RatioAttribute Class See Also Send Feedback
Gets or sets the name.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

Field Value

The name.

See Also

RatioAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaElementAttribute Class

SubSchemaElementAttribute Class
Members See Also Send Feedback
Indicates that particular property will be documented as a subschema element.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SubSchemaElementAttribute : TableAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueWithNameAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..TableAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..SubSchemaElementAttribute

See Also

SubSchemaElementAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaElementAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaElementAttribute Members
SubSchemaElementAttribute Class Constructors Methods Properties See Also Send Feedback

The SubSchemaElementAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SubSchemaElementAttribute()()()() | Initializes a new instance of the SubSchemaElementAttribute class.
Public method | SubSchemaElementAttribute(String) | Initializes a new instance of the SubSchemaElementAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddHeader | Gets or sets a value indicating whether header should be added. (Inherited from TableAttribute.)
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SubSchemaElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaElementAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaElementAttribute Constructor
SubSchemaElementAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SubSchemaElementAttribute()()()() | Initializes a new instance of the SubSchemaElementAttribute class.
Public method | SubSchemaElementAttribute(String) | Initializes a new instance of the SubSchemaElementAttribute class.

See Also

SubSchemaElementAttribute Class
SubSchemaElementAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaElementAttribute Constructor

SubSchemaElementAttribute Constructor
SubSchemaElementAttribute Class See Also Send Feedback
Initializes a new instance of the SubSchemaElementAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaElementAttribute()

See Also

SubSchemaElementAttribute Class
SubSchemaElementAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaElementAttribute Constructor (String)

SubSchemaElementAttribute Constructor (String)
SubSchemaElementAttribute Class See Also Send Feedback
Initializes a new instance of the SubSchemaElementAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaElementAttribute(
    string name
)

Parameters

name
Type: System..::..String
The name.

See Also

SubSchemaElementAttribute Class
SubSchemaElementAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaElementAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaElementAttribute Methods
SubSchemaElementAttribute Class See Also Send Feedback

The SubSchemaElementAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SubSchemaElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaElementAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaElementAttribute Properties
SubSchemaElementAttribute Class See Also Send Feedback

The SubSchemaElementAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AddHeader | Gets or sets a value indicating whether header should be added. (Inherited from TableAttribute.)
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SubSchemaElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaListTableAttribute Class

SubSchemaListTableAttribute Class
Members See Also Send Feedback
Indicates that particular schema list will be presented as a table.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SubSchemaListTableAttribute : TableAttribute

Remarks

Only for arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueWithNameAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..TableAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..SubSchemaListTableAttribute

See Also

SubSchemaListTableAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaListTableAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTableAttribute Members
SubSchemaListTableAttribute Class Constructors Methods Properties See Also Send Feedback

The SubSchemaListTableAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SubSchemaListTableAttribute()()()() | Initializes a new instance of the SubSchemaListTableAttribute class.
Public method | SubSchemaListTableAttribute(array<Int32>[]()[][]) | Initializes a new instance of the SubSchemaListTableAttribute class.
Public method | SubSchemaListTableAttribute(String, array<Int32>[]()[][]) | Initializes a new instance of the SubSchemaListTableAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddHeader | Gets or sets a value indicating whether header should be added. (Inherited from TableAttribute.)
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | PercentageColumnWidth | Gets the width of columns in procentage units.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaListTableAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTableAttribute Constructor
SubSchemaListTableAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SubSchemaListTableAttribute()()()() | Initializes a new instance of the SubSchemaListTableAttribute class.
Public method | SubSchemaListTableAttribute(array<Int32>[]()[][]) | Initializes a new instance of the SubSchemaListTableAttribute class.
Public method | SubSchemaListTableAttribute(String, array<Int32>[]()[][]) | Initializes a new instance of the SubSchemaListTableAttribute class.

See Also

SubSchemaListTableAttribute Class
SubSchemaListTableAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaListTableAttribute Constructor

SubSchemaListTableAttribute Constructor
SubSchemaListTableAttribute Class See Also Send Feedback
Initializes a new instance of the SubSchemaListTableAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaListTableAttribute()

See Also

SubSchemaListTableAttribute Class
SubSchemaListTableAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaListTableAttribute Constructor (Int32[])

SubSchemaListTableAttribute Constructor (array<Int32>[]()[][])
SubSchemaListTableAttribute Class See Also Send Feedback
Initializes a new instance of the SubSchemaListTableAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaListTableAttribute(
    params int[] percentageColumnWidth
)

Parameters

percentageColumnWidth
Type: array< System..::..Int32 >[]()[][]
Width of the percentage column.

See Also

SubSchemaListTableAttribute Class
SubSchemaListTableAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaListTableAttribute Constructor (String, Int32[])

SubSchemaListTableAttribute Constructor (String, array<Int32>[]()[][])
SubSchemaListTableAttribute Class See Also Send Feedback
Initializes a new instance of the SubSchemaListTableAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaListTableAttribute(
    string name,
    params int[] percentageColumnWidth
)

Parameters

name
Type: System..::..String
The name.
percentageColumnWidth
Type: array< System..::..Int32 >[]()[][]
Width of the percentage column.

See Also

SubSchemaListTableAttribute Class
SubSchemaListTableAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaListTableAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTableAttribute Methods
SubSchemaListTableAttribute Class See Also Send Feedback

The SubSchemaListTableAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


SubSchemaListTableAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTableAttribute Properties
SubSchemaListTableAttribute Class See Also Send Feedback

The SubSchemaListTableAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AddHeader | Gets or sets a value indicating whether header should be added. (Inherited from TableAttribute.)
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | PercentageColumnWidth | Gets the width of columns in procentage units.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


PercentageColumnWidth Property

SubSchemaListTableAttribute..::..PercentageColumnWidth Property
SubSchemaListTableAttribute Class See Also Send Feedback
Gets the width of columns in procentage units.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int[] PercentageColumnWidth { get; private set; }

Field Value

The width of the column.

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


TableAttribute Class

TableAttribute Class
Members See Also Send Feedback
Indicates that particular property will be documented as a table.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class TableAttribute : ValueWithNameAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueWithNameAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..TableAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..SubSchemaElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..SubSchemaListTableAttribute

See Also

TableAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


TableAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
TableAttribute Members
TableAttribute Class Constructors Methods Properties See Also Send Feedback

The TableAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TableAttribute()()()() | Initializes a new instance of the TableAttribute class.
Public method | TableAttribute(String) | Initializes a new instance of the TableAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddHeader | Gets or sets a value indicating whether header should be added.
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TableAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


TableAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
TableAttribute Constructor
TableAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TableAttribute()()()() | Initializes a new instance of the TableAttribute class.
Public method | TableAttribute(String) | Initializes a new instance of the TableAttribute class.

See Also

TableAttribute Class
TableAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


TableAttribute Constructor

TableAttribute Constructor
TableAttribute Class See Also Send Feedback
Initializes a new instance of the TableAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TableAttribute()

See Also

TableAttribute Class
TableAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


TableAttribute Constructor (String)

TableAttribute Constructor (String)
TableAttribute Class See Also Send Feedback
Initializes a new instance of the TableAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TableAttribute(
    string name
)

Parameters

name
Type: System..::..String
The name.

See Also

TableAttribute Class
TableAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


TableAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
TableAttribute Methods
TableAttribute Class See Also Send Feedback

The TableAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TableAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


TableAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
TableAttribute Properties
TableAttribute Class See Also Send Feedback

The TableAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AddHeader | Gets or sets a value indicating whether header should be added.
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TableAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


AddHeader Property

TableAttribute..::..AddHeader Property
TableAttribute Class See Also Send Feedback
Gets or sets a value indicating whether header should be added.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AddHeader { get; set; }

Field Value

true if header will be added; otherwise, false.

See Also

TableAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueAttribute Class

ValueAttribute Class
Members See Also Send Feedback
Indicates that particular property will be documented as a value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ValueAttribute : DocumentElementAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueWithNameAttribute

See Also

ValueAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ValueAttribute Members
ValueAttribute Class Constructors Methods Properties See Also Send Feedback

The ValueAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ValueAttribute | Initializes a new instance of the ValueAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ValueAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueAttribute Constructor

ValueAttribute Constructor
ValueAttribute Class See Also Send Feedback
Initializes a new instance of the ValueAttribute class

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ValueAttribute()

See Also

ValueAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ValueAttribute Methods
ValueAttribute Class See Also Send Feedback

The ValueAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValueAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ValueAttribute Properties
ValueAttribute Class See Also Send Feedback

The ValueAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ValueAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


LocalizableValue Property

ValueAttribute..::..LocalizableValue Property
ValueAttribute Class See Also Send Feedback
Gets or sets a value indicating whether value should be localized.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool LocalizableValue { get; set; }

Field Value

true if localizable; otherwise, false.

See Also

ValueAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithDescriptionAttribute Class

ValueWithDescriptionAttribute Class
Members See Also Send Feedback
Indicates that particular property will be documented as a value with name and description.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ValueWithDescriptionAttribute : ValueWithNameAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueWithNameAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueWithDescriptionAttribute

See Also

ValueWithDescriptionAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithDescriptionAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ValueWithDescriptionAttribute Members
ValueWithDescriptionAttribute Class Constructors Methods Properties See Also Send Feedback

The ValueWithDescriptionAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ValueWithDescriptionAttribute()()()() | Initializes a new instance of the ValueWithDescriptionAttribute class.
Public method | ValueWithDescriptionAttribute(String, String, String) | Initializes a new instance of the ValueWithDescriptionAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | Note | Gets or sets the note.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ValueWithDescriptionAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithDescriptionAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ValueWithDescriptionAttribute Constructor
ValueWithDescriptionAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValueWithDescriptionAttribute()()()() | Initializes a new instance of the ValueWithDescriptionAttribute class.
Public method | ValueWithDescriptionAttribute(String, String, String) | Initializes a new instance of the ValueWithDescriptionAttribute class.

See Also

ValueWithDescriptionAttribute Class
ValueWithDescriptionAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithDescriptionAttribute Constructor

ValueWithDescriptionAttribute Constructor
ValueWithDescriptionAttribute Class See Also Send Feedback
Initializes a new instance of the ValueWithDescriptionAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ValueWithDescriptionAttribute()

See Also

ValueWithDescriptionAttribute Class
ValueWithDescriptionAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithDescriptionAttribute Constructor (String, String, String)

ValueWithDescriptionAttribute Constructor (String, String, String)
ValueWithDescriptionAttribute Class See Also Send Feedback
Initializes a new instance of the ValueWithDescriptionAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ValueWithDescriptionAttribute(
    string name,
    string description,
    string note
)

Parameters

name
Type: System..::..String
The name.
description
Type: System..::..String
The description.
note
Type: System..::..String
The note.

See Also

ValueWithDescriptionAttribute Class
ValueWithDescriptionAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithDescriptionAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ValueWithDescriptionAttribute Methods
ValueWithDescriptionAttribute Class See Also Send Feedback

The ValueWithDescriptionAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValueWithDescriptionAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithDescriptionAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ValueWithDescriptionAttribute Properties
ValueWithDescriptionAttribute Class See Also Send Feedback

The ValueWithDescriptionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | Note | Gets or sets the note.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ValueWithDescriptionAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


Description Property

ValueWithDescriptionAttribute..::..Description Property
ValueWithDescriptionAttribute Class See Also Send Feedback
Gets or sets the description.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Description { get; set; }

Field Value

The description.

See Also

ValueWithDescriptionAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


Note Property

ValueWithDescriptionAttribute..::..Note Property
ValueWithDescriptionAttribute Class See Also Send Feedback
Gets or sets the note.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Note { get; set; }

Field Value

The note.

See Also

ValueWithDescriptionAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithNameAttribute Class

ValueWithNameAttribute Class
Members See Also Send Feedback
Indicates that particular property will be documented as a value with name.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ValueWithNameAttribute : ValueAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueWithNameAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ListValueAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..TableAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..ValueWithDescriptionAttribute

See Also

ValueWithNameAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithNameAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ValueWithNameAttribute Members
ValueWithNameAttribute Class Constructors Methods Properties See Also Send Feedback

The ValueWithNameAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ValueWithNameAttribute()()()() | Initializes a new instance of the ValueWithNameAttribute class.
Public method | ValueWithNameAttribute(String) | Initializes a new instance of the ValueWithNameAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value.
Public property | NamePostfix | The name postfix.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ValueWithNameAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithNameAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ValueWithNameAttribute Constructor
ValueWithNameAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValueWithNameAttribute()()()() | Initializes a new instance of the ValueWithNameAttribute class.
Public method | ValueWithNameAttribute(String) | Initializes a new instance of the ValueWithNameAttribute class.

See Also

ValueWithNameAttribute Class
ValueWithNameAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithNameAttribute Constructor

ValueWithNameAttribute Constructor
ValueWithNameAttribute Class See Also Send Feedback
Initializes a new instance of the ValueWithNameAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ValueWithNameAttribute()

See Also

ValueWithNameAttribute Class
ValueWithNameAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithNameAttribute Constructor (String)

ValueWithNameAttribute Constructor (String)
ValueWithNameAttribute Class See Also Send Feedback
Initializes a new instance of the ValueWithNameAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ValueWithNameAttribute(
    string name
)

Parameters

name
Type: System..::..String
The name.

See Also

ValueWithNameAttribute Class
ValueWithNameAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithNameAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ValueWithNameAttribute Methods
ValueWithNameAttribute Class See Also Send Feedback

The ValueWithNameAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValueWithNameAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


ValueWithNameAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ValueWithNameAttribute Properties
ValueWithNameAttribute Class See Also Send Feedback

The ValueWithNameAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value.
Public property | NamePostfix | The name postfix.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ValueWithNameAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


Name Property

ValueWithNameAttribute..::..Name Property
ValueWithNameAttribute Class See Also Send Feedback
The name of the value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

See Also

ValueWithNameAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


NamePostfix Property

ValueWithNameAttribute..::..NamePostfix Property
ValueWithNameAttribute Class See Also Send Feedback
The name postfix.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string NamePostfix { get; set; }

See Also

ValueWithNameAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace


Autodesk.Revit.DB.ResultsBuilder Namespace

Autodesk.Revit.DB.ResultsBuilder Namespace
Send Feedback

Classes

 | Class | Description
Public class | BarNodeResult | Represents result value of specified type for given node.
Public class | BarNodeResultEnvelope | Represents result value of specified type for given node.
Public class | BaseGraph | Base class for various types of results returned by ResultsBuilder.
Public class | LineGraph | Represents two-dimensional line graph defined by the ordered set of pairs (U,V(U)).
Public class | LineGraphByCoordinatesParameters | Contains settings for calculating results on linear elements.
Public class | LineGraphByDivisionParameters | Contains settings for calculating results on linear elements.
Public class | LineGraphEnvelope | Represents envelope of line graphs.
Public class | LineGraphParameters | Base class for various types of settings used for calculating linear results.
Public class | MeasurementDescription | MeasurementDescription describes the measurement defined in the package.
Public class | NodeReactions | Defines a set of standard results in the calculation point supported on elastic ground.
Public class | NodeResult | Represents XYZ result value of specified type for given node.
Public class | NodeResultEnvelope | Represents envelope of result value for given node.
Public class | NodeResults | Defines a set of results for node.
Public class | PackagesAddedEventArgs | The event arguments used by the PackagesAdded event.
Public class | PackagesDeletedEventArgs | The event arguments used by the PackagesDeleted event.
Public class | PackagesModifiedEventArgs | The event arguments used by the PackagesModified event.
Public class | PackagesStatusChangedEventArgs | The event arguments used by the PackagesStatusChanged event.
Public class | PointResults | Defines a set of standard results in the calculation point.
Public class | ResultsAccess | ResultsAccess object is designed for storing results of various calculation analysis in the document.
Public class | ResultsPackage | Analysis class provides access to the results of analysis.
Public class | SurfaceGraph | Represents planar map of Points defined by the set of triples (valueX,valueY,values(valueX,valueY))
Public class | SurfaceGraphEnvelope | Represents envelope of surface graphs.
Public class | SurfaceGraphParameters | Class for various types of settings used for calculating results on surfaces.
Public class | SurfaceNodeResult | Represents result value of specified type for given node.
Public class | SurfaceNodeResultEnvelope | Represents result value of specified type for given node.

Enumerations

 | Enumeration | Description
Public enumeration | DomainResultType | Defines a standard types of analytical domains.
Public enumeration | LinearResultType | Defines a standard types of analytical results for linear elements like beams and columns.
Public enumeration | MeasurementDependencyType | Defines the available types of measurements dependencies.
Public enumeration | MeasurementResultType | Defines the available types of measurements stored in the package.
Public enumeration | NodeResultType | Defines a standard types of analytical results for elements defined by node. All values are measured in global coordinate system.
Public enumeration | ResultsPackageTypes | Defines types of packages.
Public enumeration | ResultsStatus | Constants defines the status of results package.
Public enumeration | SurfaceGraphDirectionType | Defines a types of methods that the surface results are calculated while querying.
Public enumeration | SurfaceResultType | Defines a standard types of analytical results for planar elements like slabs and walls.
Public enumeration | UnitsSystem | Defines the set of units that is used by default for the resuts.


BarNodeResult Class

BarNodeResult Class
Members See Also Send Feedback
Represents result value of specified type for given node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarNodeResult : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..BarNodeResult

See Also

BarNodeResult Members
Autodesk.Revit.DB.ResultsBuilder Namespace


BarNodeResult Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarNodeResult Members
BarNodeResult Class Methods Properties See Also Send Feedback

The BarNodeResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Type of result.
Public property | Value | Value for node.
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


BarNodeResult Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BarNodeResult Methods
BarNodeResult Class See Also Send Feedback

The BarNodeResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


BarNodeResult Properties

[image]

Structural Analysis and Code Checking API Reference Guide
BarNodeResult Properties
BarNodeResult Class See Also Send Feedback

The BarNodeResult type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Type of result.
Public property | Value | Value for node.
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

BarNodeResult..::..ResultType Property
BarNodeResult Class See Also Send Feedback
Type of result.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LinearResultType ResultType { get; }

See Also

BarNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Value Property

BarNodeResult..::..Value Property
BarNodeResult Class See Also Send Feedback
Value for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Value { get; }

See Also

BarNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


X Property

BarNodeResult..::..X Property
BarNodeResult Class See Also Send Feedback
X defines the coordinate (distance from the bar's start point) where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double X { get; }

See Also

BarNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


BarNodeResultEnvelope Class

BarNodeResultEnvelope Class
Members See Also Send Feedback
Represents result value of specified type for given node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarNodeResultEnvelope : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..BarNodeResultEnvelope

See Also

BarNodeResultEnvelope Members
Autodesk.Revit.DB.ResultsBuilder Namespace


BarNodeResultEnvelope Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarNodeResultEnvelope Members
BarNodeResultEnvelope Class Methods Properties See Also Send Feedback

The BarNodeResultEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | MaxValue | Maximal value for node.
Public property | MinValue | Mininmal value for node.
Public property | ResultType | Type of result.
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


BarNodeResultEnvelope Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BarNodeResultEnvelope Methods
BarNodeResultEnvelope Class See Also Send Feedback

The BarNodeResultEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


BarNodeResultEnvelope Properties

[image]

Structural Analysis and Code Checking API Reference Guide
BarNodeResultEnvelope Properties
BarNodeResultEnvelope Class See Also Send Feedback

The BarNodeResultEnvelope type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | MaxValue | Maximal value for node.
Public property | MinValue | Mininmal value for node.
Public property | ResultType | Type of result.
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


MaxValue Property

BarNodeResultEnvelope..::..MaxValue Property
BarNodeResultEnvelope Class See Also Send Feedback
Maximal value for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double MaxValue { get; }

See Also

BarNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


MinValue Property

BarNodeResultEnvelope..::..MinValue Property
BarNodeResultEnvelope Class See Also Send Feedback
Mininmal value for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double MinValue { get; }

See Also

BarNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

BarNodeResultEnvelope..::..ResultType Property
BarNodeResultEnvelope Class See Also Send Feedback
Type of result.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LinearResultType ResultType { get; }

See Also

BarNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


X Property

BarNodeResultEnvelope..::..X Property
BarNodeResultEnvelope Class See Also Send Feedback
X defines the coordinate (distance from the bar's start point) where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double X { get; }

See Also

BarNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


BaseGraph Class

BaseGraph Class
Members See Also Send Feedback
Base class for various types of results returned by ResultsBuilder.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..BarNodeResult
Autodesk.Revit.DB.ResultsBuilder..::..BarNodeResultEnvelope
Autodesk.Revit.DB.ResultsBuilder..::..LineGraph
Autodesk.Revit.DB.ResultsBuilder..::..LineGraphEnvelope
Autodesk.Revit.DB.ResultsBuilder..::..NodeResult
Autodesk.Revit.DB.ResultsBuilder..::..NodeResultEnvelope
Autodesk.Revit.DB.ResultsBuilder..::..SurfaceGraph
Autodesk.Revit.DB.ResultsBuilder..::..SurfaceGraphEnvelope
Autodesk.Revit.DB.ResultsBuilder..::..SurfaceNodeResult
Autodesk.Revit.DB.ResultsBuilder..::..SurfaceNodeResultEnvelope

See Also

BaseGraph Members
Autodesk.Revit.DB.ResultsBuilder Namespace


BaseGraph Members

[image]

Structural Analysis and Code Checking API Reference Guide
BaseGraph Members
BaseGraph Class Methods Properties See Also Send Feedback

The BaseGraph type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined.
Public property | LoadId | Returns loads's id for which the line graph is defined.

See Also

BaseGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


BaseGraph Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BaseGraph Methods
BaseGraph Class See Also Send Feedback

The BaseGraph type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BaseGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


BaseGraph Properties

[image]

Structural Analysis and Code Checking API Reference Guide
BaseGraph Properties
BaseGraph Class See Also Send Feedback

The BaseGraph type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined.
Public property | LoadId | Returns loads's id for which the line graph is defined.

See Also

BaseGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ElementId Property

BaseGraph..::..ElementId Property
BaseGraph Class See Also Send Feedback
Returns element's id for which the surface graph is defined.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementId ElementId { get; }

See Also

BaseGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LoadId Property

BaseGraph..::..LoadId Property
BaseGraph Class See Also Send Feedback
Returns loads's id for which the line graph is defined.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementId LoadId { get; }

See Also

BaseGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DomainResultType Enumeration

DomainResultType Enumeration
See Also Send Feedback
Defines a standard types of analytical domains.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum DomainResultType

Members

Member name | Value | Description
Unknown | 0 | Unknown domain result type
X | 10000 | X coordinate
Y | 10001 | Y coordinate
Z | 10002 | Z coordinate
XN | 10003 | X coordinate for nodal values
YN | 10004 | Y coordinate for nodal values
ZN | 10005 | Z coordinate for nodal values

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace


LinearResultType Enumeration

LinearResultType Enumeration
See Also Send Feedback
Defines a standard types of analytical results for linear elements like beams and columns.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum LinearResultType

Members

Member name | Value | Description
Unknown | 0 | Unknown linear result type
Mx | 1001 | Mx
My | 1002 | My
Mz | 1003 | Mz
Fx | 1004 | Fx
Fy | 1005 | Fy
Fz | 1006 | Fz
Ux | 1007 | Ux
Uy | 1008 | Uy
Uz | 1009 | Uz
Rx | 1010 | Rx
Ry | 1011 | Ry
Rz | 1012 | Rz
Ky | 1013 | Ky reaction, derivative result
Kz | 1014 | Kz reaction, derivative result
Smax | 1015 | S max, maximum normal stress
Smin | 1016 | S min, minimum normal stress
SmaxMy | 1017 | S max (My), maximum bending stress for moment My
SmaxMz | 1018 | S max (Mz), maximum bending stress for moment Mz
SminMy | 1019 | S min (My), minimum bending stress for moment My
SminMz | 1020 | S min (Mz), minimum bending stress for moment Mz
SFx | 1021 | S (Fx), axial stress
ShearY | 1022 | Shear Y, shear stress (Y-axis), derivative result
ShearZ | 1023 | Shear Z, shear stress (Z-axis), derivative result
AsTop | 1024 | Top required reinforcement
AsBottom | 1025 | Bottom required reinforcement
AsLeft | 1026 | Left required reinforcement
AsRight | 1027 | Right required reinforcement
ReactionMx | 1028 | Reaction Mx
ReactionMy | 1029 | Reaction My
ReactionMz | 1030 | Reaction Mz
ReactionFx | 1031 | Reaction Fx
ReactionFy | 1032 | Reaction Fy
ReactionFz | 1033 | Reaction Fz
GetForceType |  | Converts ResultBuilter LinearResultType into ForceType

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraph Class

LineGraph Class
Members See Also Send Feedback
Represents two-dimensional line graph defined by the ordered set of pairs (U,V(U)).

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LineGraph : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..LineGraph

See Also

LineGraph Members
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraph Members

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraph Members
LineGraph Class Methods Properties See Also Send Feedback

The LineGraph type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Calculates the value of graph in specified point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | Points | Returns the list of points thad defines the linear result. U is interpreted as domain and V as values.
Public property | ResultType | Returns the type of result of the linear graph.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.

See Also

LineGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraph Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraph Methods
LineGraph Class See Also Send Feedback

The LineGraph type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Calculates the value of graph in specified point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LineGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetValue Method

LineGraph..::..GetValue Method
LineGraph Class See Also Send Feedback
Calculates the value of graph in specified point.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetValue(
    double u
)

Parameters

u
Type: System..::..Double
Distance from the begining of the domain measured in DomainDisplayUnitType.

See Also

LineGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraph Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraph Properties
LineGraph Class See Also Send Feedback

The LineGraph type exposes the following members.

Properties

 | Name | Description
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | Points | Returns the list of points thad defines the linear result. U is interpreted as domain and V as values.
Public property | ResultType | Returns the type of result of the linear graph.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.

See Also

LineGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DomainDisplayUnitType Property

LineGraph..::..DomainDisplayUnitType Property
LineGraph Class See Also Send Feedback
Indicates the units of the domain of the linear graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType DomainDisplayUnitType { get; }

See Also

LineGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Points Property

LineGraph..::..Points Property
LineGraph Class See Also Send Feedback
Returns the list of points thad defines the linear result. U is interpreted as domain and V as values.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<UV> Points { get; }

See Also

LineGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

LineGraph..::..ResultType Property
LineGraph Class See Also Send Feedback
Returns the type of result of the linear graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LinearResultType ResultType { get; }

See Also

LineGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ValueDisplayUnitType Property

LineGraph..::..ValueDisplayUnitType Property
LineGraph Class See Also Send Feedback
Indicates the units of the values of the linear graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType ValueDisplayUnitType { get; }

See Also

LineGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByCoordinatesParameters Class

LineGraphByCoordinatesParameters Class
Members See Also Send Feedback
Contains settings for calculating results on linear elements.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LineGraphByCoordinatesParameters : LineGraphParameters

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..LineGraphParameters
Autodesk.Revit.DB.ResultsBuilder..::..LineGraphByCoordinatesParameters

See Also

LineGraphByCoordinatesParameters Members
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByCoordinatesParameters Members

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphByCoordinatesParameters Members
LineGraphByCoordinatesParameters Class Constructors Methods Properties See Also Send Feedback

The LineGraphByCoordinatesParameters type exposes the following members.

Constructors

 | Name | Description
Public method | LineGraphByCoordinatesParameters(IEnumerable<(Of <<'(Double>)>>)) | Creates the LineGraphByCoordinatesParameters with given set of relative coordinates.
Public method | LineGraphByCoordinatesParameters(IEnumerable<(Of <<'(Double>)>>), UnitsSystem) | Creates the LineGraphByCoordinatesParameters with given set of relative coordinates and unit system.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RelativeCoordinates | Returns list of defined relative coordinates.
Public property | UnitsSystem | Defines the set of units used when querying for results. (Inherited from LineGraphParameters.)

See Also

LineGraphByCoordinatesParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByCoordinatesParameters Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphByCoordinatesParameters Constructor
LineGraphByCoordinatesParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LineGraphByCoordinatesParameters(IEnumerable<(Of <<'(Double>)>>)) | Creates the LineGraphByCoordinatesParameters with given set of relative coordinates.
Public method | LineGraphByCoordinatesParameters(IEnumerable<(Of <<'(Double>)>>), UnitsSystem) | Creates the LineGraphByCoordinatesParameters with given set of relative coordinates and unit system.

See Also

LineGraphByCoordinatesParameters Class
LineGraphByCoordinatesParameters Members
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByCoordinatesParameters Constructor (IEnumerable(Double))

LineGraphByCoordinatesParameters Constructor (IEnumerable<(Of <(<'Double>)>)>)
LineGraphByCoordinatesParameters Class See Also Send Feedback
Creates the LineGraphByCoordinatesParameters with given set of relative coordinates.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LineGraphByCoordinatesParameters(
    IEnumerable<double> relativeCoordinates
)

Parameters

relativeCoordinates
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>

See Also

LineGraphByCoordinatesParameters Class
LineGraphByCoordinatesParameters Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByCoordinatesParameters Constructor (IEnumerable(Double), UnitsSystem)

LineGraphByCoordinatesParameters Constructor (IEnumerable<(Of <(<'Double>)>)>, UnitsSystem)
LineGraphByCoordinatesParameters Class See Also Send Feedback
Creates the LineGraphByCoordinatesParameters with given set of relative coordinates and unit system.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LineGraphByCoordinatesParameters(
    IEnumerable<double> relativeCoordinates,
    UnitsSystem unitSystem
)

Parameters

relativeCoordinates
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>
unitSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

See Also

LineGraphByCoordinatesParameters Class
LineGraphByCoordinatesParameters Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByCoordinatesParameters Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphByCoordinatesParameters Methods
LineGraphByCoordinatesParameters Class See Also Send Feedback

The LineGraphByCoordinatesParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LineGraphByCoordinatesParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByCoordinatesParameters Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphByCoordinatesParameters Properties
LineGraphByCoordinatesParameters Class See Also Send Feedback

The LineGraphByCoordinatesParameters type exposes the following members.

Properties

 | Name | Description
Public property | RelativeCoordinates | Returns list of defined relative coordinates.
Public property | UnitsSystem | Defines the set of units used when querying for results. (Inherited from LineGraphParameters.)

See Also

LineGraphByCoordinatesParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


RelativeCoordinates Property

LineGraphByCoordinatesParameters..::..RelativeCoordinates Property
LineGraphByCoordinatesParameters Class See Also Send Feedback
Returns list of defined relative coordinates.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<double> RelativeCoordinates { get; }

See Also

LineGraphByCoordinatesParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByDivisionParameters Class

LineGraphByDivisionParameters Class
Members See Also Send Feedback
Contains settings for calculating results on linear elements.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LineGraphByDivisionParameters : LineGraphParameters

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..LineGraphParameters
Autodesk.Revit.DB.ResultsBuilder..::..LineGraphByDivisionParameters

See Also

LineGraphByDivisionParameters Members
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByDivisionParameters Members

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphByDivisionParameters Members
LineGraphByDivisionParameters Class Constructors Methods Properties See Also Send Feedback

The LineGraphByDivisionParameters type exposes the following members.

Constructors

 | Name | Description
Public method | LineGraphByDivisionParameters(Int32) | Creates the LineGraphByDivisionParameters with given number of division points.
Public method | LineGraphByDivisionParameters(Int32, UnitsSystem) | Creates the LineGraphByDivisionParameters with given number of division points and unit system.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NumberOfDivisionPoints | Returns the number of divsion points.
Public property | UnitsSystem | Defines the set of units used when querying for results. (Inherited from LineGraphParameters.)

See Also

LineGraphByDivisionParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByDivisionParameters Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphByDivisionParameters Constructor
LineGraphByDivisionParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LineGraphByDivisionParameters(Int32) | Creates the LineGraphByDivisionParameters with given number of division points.
Public method | LineGraphByDivisionParameters(Int32, UnitsSystem) | Creates the LineGraphByDivisionParameters with given number of division points and unit system.

See Also

LineGraphByDivisionParameters Class
LineGraphByDivisionParameters Members
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByDivisionParameters Constructor (Int32)

LineGraphByDivisionParameters Constructor (Int32)
LineGraphByDivisionParameters Class See Also Send Feedback
Creates the LineGraphByDivisionParameters with given number of division points.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LineGraphByDivisionParameters(
    int numberOfDivisionPoints
)

Parameters

numberOfDivisionPoints
Type: System..::..Int32

See Also

LineGraphByDivisionParameters Class
LineGraphByDivisionParameters Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByDivisionParameters Constructor (Int32, UnitsSystem)

LineGraphByDivisionParameters Constructor (Int32, UnitsSystem)
LineGraphByDivisionParameters Class See Also Send Feedback
Creates the LineGraphByDivisionParameters with given number of division points and unit system.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LineGraphByDivisionParameters(
    int numberOfDivisionPoints,
    UnitsSystem unitSystem
)

Parameters

numberOfDivisionPoints
Type: System..::..Int32
unitSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

See Also

LineGraphByDivisionParameters Class
LineGraphByDivisionParameters Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByDivisionParameters Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphByDivisionParameters Methods
LineGraphByDivisionParameters Class See Also Send Feedback

The LineGraphByDivisionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LineGraphByDivisionParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphByDivisionParameters Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphByDivisionParameters Properties
LineGraphByDivisionParameters Class See Also Send Feedback

The LineGraphByDivisionParameters type exposes the following members.

Properties

 | Name | Description
Public property | NumberOfDivisionPoints | Returns the number of divsion points.
Public property | UnitsSystem | Defines the set of units used when querying for results. (Inherited from LineGraphParameters.)

See Also

LineGraphByDivisionParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NumberOfDivisionPoints Property

LineGraphByDivisionParameters..::..NumberOfDivisionPoints Property
LineGraphByDivisionParameters Class See Also Send Feedback
Returns the number of divsion points.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int NumberOfDivisionPoints { get; }

See Also

LineGraphByDivisionParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphEnvelope Class

LineGraphEnvelope Class
Members See Also Send Feedback
Represents envelope of line graphs.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LineGraphEnvelope : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..LineGraphEnvelope

See Also

LineGraphEnvelope Members
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphEnvelope Members

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphEnvelope Members
LineGraphEnvelope Class Methods Properties See Also Send Feedback

The LineGraphEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBottomMinValue | Calculates the minimal value of top envelope.
Public method | GetBottomValue | Calculates the value of bottom envelope in specified point.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTopMaxValue | Calculates the maximal value of top envelope.
Public method | GetTopValue | Calculates the value of top envelope in specified point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BottomPoints | Returns the list of points thad defines the bottom envelope. U is interpreted as domain and V as values.
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Returns the type of result of the linear graph.
Public property | TopPoints | Returns the list of points thad defines the top envelope. U is interpreted as domain and V as values.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphEnvelope Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphEnvelope Methods
LineGraphEnvelope Class See Also Send Feedback

The LineGraphEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBottomMinValue | Calculates the minimal value of top envelope.
Public method | GetBottomValue | Calculates the value of bottom envelope in specified point.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTopMaxValue | Calculates the maximal value of top envelope.
Public method | GetTopValue | Calculates the value of top envelope in specified point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetBottomMinValue Method

LineGraphEnvelope..::..GetBottomMinValue Method
LineGraphEnvelope Class See Also Send Feedback
Calculates the minimal value of top envelope.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetBottomMinValue()

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetBottomValue Method

LineGraphEnvelope..::..GetBottomValue Method
LineGraphEnvelope Class See Also Send Feedback
Calculates the value of bottom envelope in specified point.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetBottomValue(
    double u
)

Parameters

u
Type: System..::..Double
Distance from the begining of the domain in feets.

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetTopMaxValue Method

LineGraphEnvelope..::..GetTopMaxValue Method
LineGraphEnvelope Class See Also Send Feedback
Calculates the maximal value of top envelope.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetTopMaxValue()

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetTopValue Method

LineGraphEnvelope..::..GetTopValue Method
LineGraphEnvelope Class See Also Send Feedback
Calculates the value of top envelope in specified point.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double GetTopValue(
    double u
)

Parameters

u
Type: System..::..Double
Distance from the begining of the domain in feets.

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphEnvelope Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphEnvelope Properties
LineGraphEnvelope Class See Also Send Feedback

The LineGraphEnvelope type exposes the following members.

Properties

 | Name | Description
Public property | BottomPoints | Returns the list of points thad defines the bottom envelope. U is interpreted as domain and V as values.
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Returns the type of result of the linear graph.
Public property | TopPoints | Returns the list of points thad defines the top envelope. U is interpreted as domain and V as values.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


BottomPoints Property

LineGraphEnvelope..::..BottomPoints Property
LineGraphEnvelope Class See Also Send Feedback
Returns the list of points thad defines the bottom envelope. U is interpreted as domain and V as values.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<UV> BottomPoints { get; }

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DomainDisplayUnitType Property

LineGraphEnvelope..::..DomainDisplayUnitType Property
LineGraphEnvelope Class See Also Send Feedback
Indicates the units of the domain of the linear graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType DomainDisplayUnitType { get; }

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

LineGraphEnvelope..::..ResultType Property
LineGraphEnvelope Class See Also Send Feedback
Returns the type of result of the linear graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LinearResultType ResultType { get; }

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


TopPoints Property

LineGraphEnvelope..::..TopPoints Property
LineGraphEnvelope Class See Also Send Feedback
Returns the list of points thad defines the top envelope. U is interpreted as domain and V as values.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<UV> TopPoints { get; }

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ValueDisplayUnitType Property

LineGraphEnvelope..::..ValueDisplayUnitType Property
LineGraphEnvelope Class See Also Send Feedback
Indicates the units of the values of the linear graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType ValueDisplayUnitType { get; }

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphParameters Class

LineGraphParameters Class
Members See Also Send Feedback
Base class for various types of settings used for calculating linear results.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LineGraphParameters

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..LineGraphParameters
Autodesk.Revit.DB.ResultsBuilder..::..LineGraphByCoordinatesParameters
Autodesk.Revit.DB.ResultsBuilder..::..LineGraphByDivisionParameters

See Also

LineGraphParameters Members
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphParameters Members

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphParameters Members
LineGraphParameters Class Constructors Methods Properties See Also Send Feedback

The LineGraphParameters type exposes the following members.

Constructors

 | Name | Description
Public method | LineGraphParameters()()()() | Default constructor for LineGraphParameters class
Public method | LineGraphParameters(UnitsSystem) | Constructor for LineGraphParameters class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UnitsSystem | Defines the set of units used when querying for results.

See Also

LineGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphParameters Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphParameters Constructor
LineGraphParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LineGraphParameters()()()() | Default constructor for LineGraphParameters class
Public method | LineGraphParameters(UnitsSystem) | Constructor for LineGraphParameters class

See Also

LineGraphParameters Class
LineGraphParameters Members
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphParameters Constructor

LineGraphParameters Constructor
LineGraphParameters Class See Also Send Feedback
Default constructor for LineGraphParameters class

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LineGraphParameters()

See Also

LineGraphParameters Class
LineGraphParameters Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphParameters Constructor (UnitsSystem)

LineGraphParameters Constructor (UnitsSystem)
LineGraphParameters Class See Also Send Feedback
Constructor for LineGraphParameters class

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LineGraphParameters(
    UnitsSystem unitsSystem
)

Parameters

unitsSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem
Defines the set of units used when querying for results.

See Also

LineGraphParameters Class
LineGraphParameters Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphParameters Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphParameters Methods
LineGraphParameters Class See Also Send Feedback

The LineGraphParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LineGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LineGraphParameters Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphParameters Properties
LineGraphParameters Class See Also Send Feedback

The LineGraphParameters type exposes the following members.

Properties

 | Name | Description
Public property | UnitsSystem | Defines the set of units used when querying for results.

See Also

LineGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


UnitsSystem Property

LineGraphParameters..::..UnitsSystem Property
LineGraphParameters Class See Also Send Feedback
Defines the set of units used when querying for results.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitsSystem UnitsSystem { get; set; }

See Also

LineGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


MeasurementDependencyType Enumeration

MeasurementDependencyType Enumeration
See Also Send Feedback
Defines the available types of measurements dependencies.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum MeasurementDependencyType

Members

Member name | Value | Description
Unknown | 0 | Unknow measeurement dependency type.
LoadCaseDependent | 1 | Measeurement is load case dependent.
LoadCaseIndependent | 2 | Measeurement is load case independent.
Any | 3 | Measeurement may be both dependent and independent on load case (f.e. domain).

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace


MeasurementDescription Class

MeasurementDescription Class
Members See Also Send Feedback
MeasurementDescription describes the measurement defined in the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class MeasurementDescription

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..MeasurementDescription

See Also

MeasurementDescription Members
Autodesk.Revit.DB.ResultsBuilder Namespace


MeasurementDescription Members

[image]

Structural Analysis and Code Checking API Reference Guide
MeasurementDescription Members
MeasurementDescription Class Methods Properties See Also Send Feedback

The MeasurementDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DependencyType | Returns type of dependecy of the measurement.
Public property | DisplayUnitType | Returns the unit type of the measurement
Public property | HasResults | Returns true if package contains any results of this measurement.
Public property | Name | Returns the name of the measurement.
Public property | ResultType | Returns the result type of the measurement.
Public property | UnitType | Returns the unit type of the measurement.

See Also

MeasurementDescription Class
Autodesk.Revit.DB.ResultsBuilder Namespace


MeasurementDescription Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MeasurementDescription Methods
MeasurementDescription Class See Also Send Feedback

The MeasurementDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MeasurementDescription Class
Autodesk.Revit.DB.ResultsBuilder Namespace


MeasurementDescription Properties

[image]

Structural Analysis and Code Checking API Reference Guide
MeasurementDescription Properties
MeasurementDescription Class See Also Send Feedback

The MeasurementDescription type exposes the following members.

Properties

 | Name | Description
Public property | DependencyType | Returns type of dependecy of the measurement.
Public property | DisplayUnitType | Returns the unit type of the measurement
Public property | HasResults | Returns true if package contains any results of this measurement.
Public property | Name | Returns the name of the measurement.
Public property | ResultType | Returns the result type of the measurement.
Public property | UnitType | Returns the unit type of the measurement.

See Also

MeasurementDescription Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DependencyType Property

MeasurementDescription..::..DependencyType Property
MeasurementDescription Class See Also Send Feedback
Returns type of dependecy of the measurement.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MeasurementDependencyType DependencyType { get; }

See Also

MeasurementDescription Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DisplayUnitType Property

MeasurementDescription..::..DisplayUnitType Property
MeasurementDescription Class See Also Send Feedback
Returns the unit type of the measurement

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType DisplayUnitType { get; internal set; }

See Also

MeasurementDescription Class
Autodesk.Revit.DB.ResultsBuilder Namespace


HasResults Property

MeasurementDescription..::..HasResults Property
MeasurementDescription Class See Also Send Feedback
Returns true if package contains any results of this measurement.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool HasResults { get; internal set; }

See Also

MeasurementDescription Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Name Property

MeasurementDescription..::..Name Property
MeasurementDescription Class See Also Send Feedback
Returns the name of the measurement.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; }

See Also

MeasurementDescription Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

MeasurementDescription..::..ResultType Property
MeasurementDescription Class See Also Send Feedback
Returns the result type of the measurement.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MeasurementResultType ResultType { get; }

See Also

MeasurementDescription Class
Autodesk.Revit.DB.ResultsBuilder Namespace


UnitType Property

MeasurementDescription..::..UnitType Property
MeasurementDescription Class See Also Send Feedback
Returns the unit type of the measurement.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitType UnitType { get; }

See Also

MeasurementDescription Class
Autodesk.Revit.DB.ResultsBuilder Namespace


MeasurementResultType Enumeration

MeasurementResultType Enumeration
See Also Send Feedback
Defines the available types of measurements stored in the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum MeasurementResultType

Members

Member name | Value | Description
Unknown | 0 | Unknow measeurement type.
Scalar | 1 | Measeurement represents a numeric value that may be assigned to any element.
Bar | 2 | Measeurement defined for bars (beam, columns, etc.).
Surface | 3 | Measeurement defined for surfaces (floors, walls, etc.).
Domain | 4 | Measeurement defined for storing domain (coordinates) for the results.
Vector | 5 | Measurement defined for nodes (footings, etc.)
VectorBar | 6 | Measurement defined for nodes on bars
VectorSurface | 7 | Measurement defined for nodes on surface

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace


NodeReactions Class

NodeReactions Class
Members See Also Send Feedback
Defines a set of standard results in the calculation point supported on elastic ground.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class NodeReactions : NodeResults

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..PointResults
Autodesk.Revit.DB.ResultsBuilder..::..NodeResults
Autodesk.Revit.DB.ResultsBuilder..::..NodeReactions

See Also

NodeReactions Members
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeReactions Members

[image]

Structural Analysis and Code Checking API Reference Guide
NodeReactions Members
NodeReactions Class Constructors Methods Properties See Also Send Feedback

The NodeReactions type exposes the following members.

Constructors

 | Name | Description
Public method | NodeReactions | Initializes a new instance of the NodeReactions class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fx | Force along x-axis (Inherited from PointResults.)
Public property | Fy | Force along y-axis (Inherited from PointResults.)
Public property | Fz | Force along z-axis (Inherited from PointResults.)
Public property | Ky | Ky Elastic Ground Reaction
Public property | Kz | Kz Elastic Ground Reaction
Public property | Mx | Moment around x-axis (Inherited from PointResults.)
Public property | My | Moment around y-axis (Inherited from PointResults.)
Public property | Mz | Moment around z-axis (Inherited from PointResults.)
Public property | Rx | Rotation around x-axis (Inherited from PointResults.)
Public property | Ry | Rotation around y-axis (Inherited from PointResults.)
Public property | Rz | Rotation around z-axis (Inherited from PointResults.)
Public property | Ux | Displacement along x-axis (Inherited from PointResults.)
Public property | Uy | Displacement along y-axis (Inherited from PointResults.)
Public property | Uz | Displacement along z-axis (Inherited from PointResults.)

See Also

NodeReactions Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeReactions Constructor

NodeReactions Constructor
NodeReactions Class See Also Send Feedback
Initializes a new instance of the NodeReactions class

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public NodeReactions()

See Also

NodeReactions Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeReactions Methods

[image]

Structural Analysis and Code Checking API Reference Guide
NodeReactions Methods
NodeReactions Class See Also Send Feedback

The NodeReactions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NodeReactions Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeReactions Properties

[image]

Structural Analysis and Code Checking API Reference Guide
NodeReactions Properties
NodeReactions Class See Also Send Feedback

The NodeReactions type exposes the following members.

Properties

 | Name | Description
Public property | Fx | Force along x-axis (Inherited from PointResults.)
Public property | Fy | Force along y-axis (Inherited from PointResults.)
Public property | Fz | Force along z-axis (Inherited from PointResults.)
Public property | Ky | Ky Elastic Ground Reaction
Public property | Kz | Kz Elastic Ground Reaction
Public property | Mx | Moment around x-axis (Inherited from PointResults.)
Public property | My | Moment around y-axis (Inherited from PointResults.)
Public property | Mz | Moment around z-axis (Inherited from PointResults.)
Public property | Rx | Rotation around x-axis (Inherited from PointResults.)
Public property | Ry | Rotation around y-axis (Inherited from PointResults.)
Public property | Rz | Rotation around z-axis (Inherited from PointResults.)
Public property | Ux | Displacement along x-axis (Inherited from PointResults.)
Public property | Uy | Displacement along y-axis (Inherited from PointResults.)
Public property | Uz | Displacement along z-axis (Inherited from PointResults.)

See Also

NodeReactions Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Ky Property

NodeReactions..::..Ky Property
NodeReactions Class See Also Send Feedback
Ky Elastic Ground Reaction

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Ky { get; set; }

See Also

NodeReactions Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Kz Property

NodeReactions..::..Kz Property
NodeReactions Class See Also Send Feedback
Kz Elastic Ground Reaction

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Kz { get; set; }

See Also

NodeReactions Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResult Class

NodeResult Class
Members See Also Send Feedback
Represents XYZ result value of specified type for given node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class NodeResult : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..NodeResult

See Also

NodeResult Members
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResult Members

[image]

Structural Analysis and Code Checking API Reference Guide
NodeResult Members
NodeResult Class Methods Properties See Also Send Feedback

The NodeResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Type of result.
Public property | Value | Value for node.

See Also

NodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResult Methods

[image]

Structural Analysis and Code Checking API Reference Guide
NodeResult Methods
NodeResult Class See Also Send Feedback

The NodeResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResult Properties

[image]

Structural Analysis and Code Checking API Reference Guide
NodeResult Properties
NodeResult Class See Also Send Feedback

The NodeResult type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Type of result.
Public property | Value | Value for node.

See Also

NodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

NodeResult..::..ResultType Property
NodeResult Class See Also Send Feedback
Type of result.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public NodeResultType ResultType { get; }

See Also

NodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Value Property

NodeResult..::..Value Property
NodeResult Class See Also Send Feedback
Value for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ Value { get; }

See Also

NodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResultEnvelope Class

NodeResultEnvelope Class
Members See Also Send Feedback
Represents envelope of result value for given node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class NodeResultEnvelope : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..NodeResultEnvelope

See Also

NodeResultEnvelope Members
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResultEnvelope Members

[image]

Structural Analysis and Code Checking API Reference Guide
NodeResultEnvelope Members
NodeResultEnvelope Class Methods Properties See Also Send Feedback

The NodeResultEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BottomValue | Bottom value for node.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Type of result.
Public property | TopValue | Top value for node.

See Also

NodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResultEnvelope Methods

[image]

Structural Analysis and Code Checking API Reference Guide
NodeResultEnvelope Methods
NodeResultEnvelope Class See Also Send Feedback

The NodeResultEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResultEnvelope Properties

[image]

Structural Analysis and Code Checking API Reference Guide
NodeResultEnvelope Properties
NodeResultEnvelope Class See Also Send Feedback

The NodeResultEnvelope type exposes the following members.

Properties

 | Name | Description
Public property | BottomValue | Bottom value for node.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Type of result.
Public property | TopValue | Top value for node.

See Also

NodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


BottomValue Property

NodeResultEnvelope..::..BottomValue Property
NodeResultEnvelope Class See Also Send Feedback
Bottom value for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ BottomValue { get; }

See Also

NodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

NodeResultEnvelope..::..ResultType Property
NodeResultEnvelope Class See Also Send Feedback
Type of result.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public NodeResultType ResultType { get; }

See Also

NodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


TopValue Property

NodeResultEnvelope..::..TopValue Property
NodeResultEnvelope Class See Also Send Feedback
Top value for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ TopValue { get; }

See Also

NodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResults Class

NodeResults Class
Members See Also Send Feedback
Defines a set of results for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class NodeResults : PointResults

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..PointResults
Autodesk.Revit.DB.ResultsBuilder..::..NodeResults
Autodesk.Revit.DB.ResultsBuilder..::..NodeReactions

See Also

NodeResults Members
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResults Members

[image]

Structural Analysis and Code Checking API Reference Guide
NodeResults Members
NodeResults Class Constructors Methods Properties See Also Send Feedback

The NodeResults type exposes the following members.

Constructors

 | Name | Description
Public method | NodeResults | Initializes a new instance of the NodeResults class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fx | Force along x-axis (Inherited from PointResults.)
Public property | Fy | Force along y-axis (Inherited from PointResults.)
Public property | Fz | Force along z-axis (Inherited from PointResults.)
Public property | Mx | Moment around x-axis (Inherited from PointResults.)
Public property | My | Moment around y-axis (Inherited from PointResults.)
Public property | Mz | Moment around z-axis (Inherited from PointResults.)
Public property | Rx | Rotation around x-axis (Inherited from PointResults.)
Public property | Ry | Rotation around y-axis (Inherited from PointResults.)
Public property | Rz | Rotation around z-axis (Inherited from PointResults.)
Public property | Ux | Displacement along x-axis (Inherited from PointResults.)
Public property | Uy | Displacement along y-axis (Inherited from PointResults.)
Public property | Uz | Displacement along z-axis (Inherited from PointResults.)

See Also

NodeResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResults Constructor

NodeResults Constructor
NodeResults Class See Also Send Feedback
Initializes a new instance of the NodeResults class

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public NodeResults()

See Also

NodeResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResults Methods

[image]

Structural Analysis and Code Checking API Reference Guide
NodeResults Methods
NodeResults Class See Also Send Feedback

The NodeResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NodeResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResults Properties

[image]

Structural Analysis and Code Checking API Reference Guide
NodeResults Properties
NodeResults Class See Also Send Feedback

The NodeResults type exposes the following members.

Properties

 | Name | Description
Public property | Fx | Force along x-axis (Inherited from PointResults.)
Public property | Fy | Force along y-axis (Inherited from PointResults.)
Public property | Fz | Force along z-axis (Inherited from PointResults.)
Public property | Mx | Moment around x-axis (Inherited from PointResults.)
Public property | My | Moment around y-axis (Inherited from PointResults.)
Public property | Mz | Moment around z-axis (Inherited from PointResults.)
Public property | Rx | Rotation around x-axis (Inherited from PointResults.)
Public property | Ry | Rotation around y-axis (Inherited from PointResults.)
Public property | Rz | Rotation around z-axis (Inherited from PointResults.)
Public property | Ux | Displacement along x-axis (Inherited from PointResults.)
Public property | Uy | Displacement along y-axis (Inherited from PointResults.)
Public property | Uz | Displacement along z-axis (Inherited from PointResults.)

See Also

NodeResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


NodeResultType Enumeration

NodeResultType Enumeration
See Also Send Feedback
Defines a standard types of analytical results for elements defined by node. All values are measured in global coordinate system.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum NodeResultType

Members

Member name | Value | Description
Unknown | 0 | Unknown node result type
Moment | 2001 | Moment
Force | 2002 | Force
Displacement | 2003 | Displacement
Rotation | 2004 | Rotation

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesAddedEventArgs Class

PackagesAddedEventArgs Class
Members See Also Send Feedback
The event arguments used by the PackagesAdded event.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class PackagesAddedEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.ResultsBuilder..::..PackagesAddedEventArgs

See Also

PackagesAddedEventArgs Members
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesAddedEventArgs Members

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesAddedEventArgs Members
PackagesAddedEventArgs Class Methods Properties See Also Send Feedback

The PackagesAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddedPackages | List of GUIDs of packages that have been deleted.
Public property | Document | The document associated with this event.

See Also

PackagesAddedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesAddedEventArgs Methods

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesAddedEventArgs Methods
PackagesAddedEventArgs Class See Also Send Feedback

The PackagesAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PackagesAddedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesAddedEventArgs Properties

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesAddedEventArgs Properties
PackagesAddedEventArgs Class See Also Send Feedback

The PackagesAddedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AddedPackages | List of GUIDs of packages that have been deleted.
Public property | Document | The document associated with this event.

See Also

PackagesAddedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


AddedPackages Property

PackagesAddedEventArgs..::..AddedPackages Property
PackagesAddedEventArgs Class See Also Send Feedback
List of GUIDs of packages that have been deleted.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<Guid> AddedPackages { get; }

See Also

PackagesAddedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Document Property

PackagesAddedEventArgs..::..Document Property
PackagesAddedEventArgs Class See Also Send Feedback
The document associated with this event.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document Document { get; }

See Also

PackagesAddedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesDeletedEventArgs Class

PackagesDeletedEventArgs Class
Members See Also Send Feedback
The event arguments used by the PackagesDeleted event.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class PackagesDeletedEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.ResultsBuilder..::..PackagesDeletedEventArgs

See Also

PackagesDeletedEventArgs Members
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesDeletedEventArgs Members

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesDeletedEventArgs Members
PackagesDeletedEventArgs Class Methods Properties See Also Send Feedback

The PackagesDeletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DeletedPackages | List of GUIDs of packages that have been deleted.
Public property | Document | The document associated with this event.

See Also

PackagesDeletedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesDeletedEventArgs Methods

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesDeletedEventArgs Methods
PackagesDeletedEventArgs Class See Also Send Feedback

The PackagesDeletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PackagesDeletedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesDeletedEventArgs Properties

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesDeletedEventArgs Properties
PackagesDeletedEventArgs Class See Also Send Feedback

The PackagesDeletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DeletedPackages | List of GUIDs of packages that have been deleted.
Public property | Document | The document associated with this event.

See Also

PackagesDeletedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DeletedPackages Property

PackagesDeletedEventArgs..::..DeletedPackages Property
PackagesDeletedEventArgs Class See Also Send Feedback
List of GUIDs of packages that have been deleted.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<Guid> DeletedPackages { get; }

See Also

PackagesDeletedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Document Property

PackagesDeletedEventArgs..::..Document Property
PackagesDeletedEventArgs Class See Also Send Feedback
The document associated with this event.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document Document { get; }

See Also

PackagesDeletedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesModifiedEventArgs Class

PackagesModifiedEventArgs Class
Members See Also Send Feedback
The event arguments used by the PackagesModified event.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class PackagesModifiedEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.ResultsBuilder..::..PackagesModifiedEventArgs

See Also

PackagesModifiedEventArgs Members
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesModifiedEventArgs Members

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesModifiedEventArgs Members
PackagesModifiedEventArgs Class Methods Properties See Also Send Feedback

The PackagesModifiedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddedPackages | List of GUIDs of packages that have been deleted.
Public property | Document | The document associated with this event.

See Also

PackagesModifiedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesModifiedEventArgs Methods

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesModifiedEventArgs Methods
PackagesModifiedEventArgs Class See Also Send Feedback

The PackagesModifiedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PackagesModifiedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesModifiedEventArgs Properties

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesModifiedEventArgs Properties
PackagesModifiedEventArgs Class See Also Send Feedback

The PackagesModifiedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AddedPackages | List of GUIDs of packages that have been deleted.
Public property | Document | The document associated with this event.

See Also

PackagesModifiedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


AddedPackages Property

PackagesModifiedEventArgs..::..AddedPackages Property
PackagesModifiedEventArgs Class See Also Send Feedback
List of GUIDs of packages that have been deleted.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<Guid> AddedPackages { get; }

See Also

PackagesModifiedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Document Property

PackagesModifiedEventArgs..::..Document Property
PackagesModifiedEventArgs Class See Also Send Feedback
The document associated with this event.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document Document { get; }

See Also

PackagesModifiedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesStatusChangedEventArgs Class

PackagesStatusChangedEventArgs Class
Members See Also Send Feedback
The event arguments used by the PackagesStatusChanged event.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class PackagesStatusChangedEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.ResultsBuilder..::..PackagesStatusChangedEventArgs

See Also

PackagesStatusChangedEventArgs Members
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesStatusChangedEventArgs Members

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesStatusChangedEventArgs Members
PackagesStatusChangedEventArgs Class Methods Properties See Also Send Feedback

The PackagesStatusChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChangedPackages | Contains collection of guids of changed packages.
Public property | Document | The document associated with this event.

See Also

PackagesStatusChangedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesStatusChangedEventArgs Methods

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesStatusChangedEventArgs Methods
PackagesStatusChangedEventArgs Class See Also Send Feedback

The PackagesStatusChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PackagesStatusChangedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesStatusChangedEventArgs Properties

[image]

Structural Analysis and Code Checking API Reference Guide
PackagesStatusChangedEventArgs Properties
PackagesStatusChangedEventArgs Class See Also Send Feedback

The PackagesStatusChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ChangedPackages | Contains collection of guids of changed packages.
Public property | Document | The document associated with this event.

See Also

PackagesStatusChangedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ChangedPackages Property

PackagesStatusChangedEventArgs..::..ChangedPackages Property
PackagesStatusChangedEventArgs Class See Also Send Feedback
Contains collection of guids of changed packages.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<Guid> ChangedPackages { get; }

See Also

PackagesStatusChangedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Document Property

PackagesStatusChangedEventArgs..::..Document Property
PackagesStatusChangedEventArgs Class See Also Send Feedback
The document associated with this event.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document Document { get; }

See Also

PackagesStatusChangedEventArgs Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PointResults Class

PointResults Class
Members See Also Send Feedback
Defines a set of standard results in the calculation point.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class PointResults

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..PointResults
Autodesk.Revit.DB.ResultsBuilder..::..NodeResults
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarPointResults

See Also

PointResults Members
Autodesk.Revit.DB.ResultsBuilder Namespace


PointResults Members

[image]

Structural Analysis and Code Checking API Reference Guide
PointResults Members
PointResults Class Constructors Methods Properties See Also Send Feedback

The PointResults type exposes the following members.

Constructors

 | Name | Description
Public method | PointResults | Initializes a new instance of the PointResults class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fx | Force along x-axis
Public property | Fy | Force along y-axis
Public property | Fz | Force along z-axis
Public property | Mx | Moment around x-axis
Public property | My | Moment around y-axis
Public property | Mz | Moment around z-axis
Public property | Rx | Rotation around x-axis
Public property | Ry | Rotation around y-axis
Public property | Rz | Rotation around z-axis
Public property | Ux | Displacement along x-axis
Public property | Uy | Displacement along y-axis
Public property | Uz | Displacement along z-axis

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PointResults Constructor

PointResults Constructor
PointResults Class See Also Send Feedback
Initializes a new instance of the PointResults class

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public PointResults()

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PointResults Methods

[image]

Structural Analysis and Code Checking API Reference Guide
PointResults Methods
PointResults Class See Also Send Feedback

The PointResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PointResults Properties

[image]

Structural Analysis and Code Checking API Reference Guide
PointResults Properties
PointResults Class See Also Send Feedback

The PointResults type exposes the following members.

Properties

 | Name | Description
Public property | Fx | Force along x-axis
Public property | Fy | Force along y-axis
Public property | Fz | Force along z-axis
Public property | Mx | Moment around x-axis
Public property | My | Moment around y-axis
Public property | Mz | Moment around z-axis
Public property | Rx | Rotation around x-axis
Public property | Ry | Rotation around y-axis
Public property | Rz | Rotation around z-axis
Public property | Ux | Displacement along x-axis
Public property | Uy | Displacement along y-axis
Public property | Uz | Displacement along z-axis

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Fx Property

PointResults..::..Fx Property
PointResults Class See Also Send Feedback
Force along x-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Fx { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Fy Property

PointResults..::..Fy Property
PointResults Class See Also Send Feedback
Force along y-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Fy { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Fz Property

PointResults..::..Fz Property
PointResults Class See Also Send Feedback
Force along z-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Fz { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Mx Property

PointResults..::..Mx Property
PointResults Class See Also Send Feedback
Moment around x-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Mx { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


My Property

PointResults..::..My Property
PointResults Class See Also Send Feedback
Moment around y-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> My { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Mz Property

PointResults..::..Mz Property
PointResults Class See Also Send Feedback
Moment around z-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Mz { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Rx Property

PointResults..::..Rx Property
PointResults Class See Also Send Feedback
Rotation around x-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Rx { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Ry Property

PointResults..::..Ry Property
PointResults Class See Also Send Feedback
Rotation around y-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Ry { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Rz Property

PointResults..::..Rz Property
PointResults Class See Also Send Feedback
Rotation around z-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Rz { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Ux Property

PointResults..::..Ux Property
PointResults Class See Also Send Feedback
Displacement along x-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Ux { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Uy Property

PointResults..::..Uy Property
PointResults Class See Also Send Feedback
Displacement along y-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Uy { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Uz Property

PointResults..::..Uz Property
PointResults Class See Also Send Feedback
Displacement along z-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Uz { get; set; }

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsAccess Class

ResultsAccess Class
Members See Also Send Feedback
ResultsAccess object is designed for storing results of various calculation analysis in the document.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultsAccess

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..ResultsAccess

See Also

ResultsAccess Members
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsAccess Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsAccess Members
ResultsAccess Class Methods Properties Events See Also Send Feedback

The ResultsAccess type exposes the following members.

Methods

 | Name | Description
 | CreateResultsAccess | Creates ResultsAccess object connected to the Revit document
Public method | CreateResultsPackage(ResultsPackageDescriptor) | Creates the results package from descriptor.
Public method | CreateResultsPackage(Guid, String, UnitsSystem) | Obsolete. Create new instance of ResultsPackageBuilder.
Public method | CreateResultsPackage(Guid, String, UnitsSystem, ResultsPackageTypes) | Create new instance of ResultsPackageBuilder.
Public method | CreateResultsPackage(Guid, String, UnitsSystem, ResultsPackageTypes, String) | Create new instance of ResultsPackageBuilder. Package created by this function will be password protected. Updates of this package will require this password
Public method | DeleteResultsPackage(Guid) | Deletes results packages of given guid from the document
Public method | DeleteResultsPackage(String) | Obsolete. Deletes results packages of given Name from the document
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDocument | Gets the document.
 | GetDocumentUniqueId(Document) | Gets the unique document id.
 | GetDocumentUniqueId(Int32) | Gets the unique document id.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResultsPackage(Guid) | Returns packages of given guid or null if not exists.
Public method | GetResultsPackage(String) | Returns packages of given name or null if not exists.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateResultsPackage(Guid) | Obsolete. Update existing results package.
Public method | UpdateResultsPackage(Guid, String) | Update existing results package.

Properties

 | Name | Description
Public property | Document | Provides access to the document that ResultsAccess was created for.
Public property | ResultsDescriptors | Provides access to the packages defined in current document.
Public property | ResultsPackages | Provides access to the packages defined in current document.

Events

Name | Description
PackagesAdded | Subscribe to the PackagesAdded event to be notified that results package has been added.
PackagesDeleted | Subscribe to the PackagesDeleted event to be notified that results package has been deleted.
PackagesModified | Subscribe to the PackagesModified event to be notified that results package has been modified.
PackagesStatusChanged | Subscribe to the PackagesStatusChanged event to be notified that results package status has been changed.

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsAccess Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsAccess Methods
ResultsAccess Class See Also Send Feedback

The ResultsAccess type exposes the following members.

Methods

 | Name | Description
 | CreateResultsAccess | Creates ResultsAccess object connected to the Revit document
Public method | CreateResultsPackage(ResultsPackageDescriptor) | Creates the results package from descriptor.
Public method | CreateResultsPackage(Guid, String, UnitsSystem) | Obsolete. Create new instance of ResultsPackageBuilder.
Public method | CreateResultsPackage(Guid, String, UnitsSystem, ResultsPackageTypes) | Create new instance of ResultsPackageBuilder.
Public method | CreateResultsPackage(Guid, String, UnitsSystem, ResultsPackageTypes, String) | Create new instance of ResultsPackageBuilder. Package created by this function will be password protected. Updates of this package will require this password
Public method | DeleteResultsPackage(Guid) | Deletes results packages of given guid from the document
Public method | DeleteResultsPackage(String) | Obsolete. Deletes results packages of given Name from the document
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDocument | Gets the document.
 | GetDocumentUniqueId(Document) | Gets the unique document id.
 | GetDocumentUniqueId(Int32) | Gets the unique document id.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResultsPackage(Guid) | Returns packages of given guid or null if not exists.
Public method | GetResultsPackage(String) | Returns packages of given name or null if not exists.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateResultsPackage(Guid) | Obsolete. Update existing results package.
Public method | UpdateResultsPackage(Guid, String) | Update existing results package.

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


CreateResultsAccess Method

ResultsAccess..::..CreateResultsAccess Method
ResultsAccess Class See Also Send Feedback
Creates ResultsAccess object connected to the Revit document

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ResultsAccess CreateResultsAccess(
    Document doc
)

Parameters

doc
Type: Document

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


CreateResultsPackage Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsAccess..::..CreateResultsPackage Method
ResultsAccess Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateResultsPackage(ResultsPackageDescriptor) | Creates the results package from descriptor.
Public method | CreateResultsPackage(Guid, String, UnitsSystem) | Obsolete. Create new instance of ResultsPackageBuilder.
Public method | CreateResultsPackage(Guid, String, UnitsSystem, ResultsPackageTypes) | Create new instance of ResultsPackageBuilder.
Public method | CreateResultsPackage(Guid, String, UnitsSystem, ResultsPackageTypes, String) | Create new instance of ResultsPackageBuilder. Package created by this function will be password protected. Updates of this package will require this password

See Also

ResultsAccess Class
ResultsAccess Members
Autodesk.Revit.DB.ResultsBuilder Namespace


CreateResultsPackage Method ()

ResultsAccess..::..CreateResultsPackage Method ()
ResultsAccess Class See Also Send Feedback
Creates the results package from descriptor.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackage CreateResultsPackage(
    ResultsPackageDescriptor descriptor
)

Parameters

descriptor
Type: ResultsPackageDescriptor
The descriptor.

Return Value

Returns instance of ResultsPackage connected to specified descriptor. If package wasn't created yet, this method creates it.

See Also

ResultsAccess Class
CreateResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


CreateResultsPackage Method (Guid, String, UnitsSystem)

ResultsAccess..::..CreateResultsPackage Method (Guid, String, UnitsSystem)
ResultsAccess Class See Also Send Feedback
Create new instance of ResultsPackageBuilder.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[ObsoleteAttribute("Use CreateResultsPackage with extended parameter list")]
public ResultsPackageBuilder CreateResultsPackage(
    Guid value,
    string name,
    UnitsSystem unitSystem
)

Parameters

value
Type: System..::..Guid
name
Type: System..::..String
unitSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

Remarks

Both name and schemaGuid of the package must be unique in the document.

Exceptions

Exception | Condition
ArgumentException | Package name already exists.
ArgumentException | Package schemaGuid already exists.

See Also

ResultsAccess Class
CreateResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


CreateResultsPackage Method (Guid, String, UnitsSystem, ResultsPackageTypes)

ResultsAccess..::..CreateResultsPackage Method (Guid, String, UnitsSystem, ResultsPackageTypes)
ResultsAccess Class See Also Send Feedback
Create new instance of ResultsPackageBuilder.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackageBuilder CreateResultsPackage(
    Guid value,
    string name,
    UnitsSystem unitSystem,
    ResultsPackageTypes types
)

Parameters

value
Type: System..::..Guid
name
Type: System..::..String
unitSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem
types
Type: Autodesk.Revit.DB.ResultsBuilder..::..ResultsPackageTypes

Remarks

The package guid must be unique in the document.

Exceptions

Exception | Condition
ArgumentException | Package guid already exists.

See Also

ResultsAccess Class
CreateResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


CreateResultsPackage Method (Guid, String, UnitsSystem, ResultsPackageTypes, String)

ResultsAccess..::..CreateResultsPackage Method (Guid, String, UnitsSystem, ResultsPackageTypes, String)
ResultsAccess Class See Also Send Feedback
Create new instance of ResultsPackageBuilder. Package created by this function will be password protected. Updates of this package will require this password

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackageBuilder CreateResultsPackage(
    Guid value,
    string name,
    UnitsSystem unitSystem,
    ResultsPackageTypes types,
    string password
)

Parameters

value
Type: System..::..Guid
name
Type: System..::..String
unitSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem
types
Type: Autodesk.Revit.DB.ResultsBuilder..::..ResultsPackageTypes
password
Type: System..::..String

Remarks

The package guid must be unique in the document.

Exceptions

Exception | Condition
ArgumentException | Package guid already exists.

See Also

ResultsAccess Class
CreateResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


DeleteResultsPackage Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsAccess..::..DeleteResultsPackage Method
ResultsAccess Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DeleteResultsPackage(Guid) | Deletes results packages of given guid from the document
Public method | DeleteResultsPackage(String) | Obsolete. Deletes results packages of given Name from the document

See Also

ResultsAccess Class
ResultsAccess Members
Autodesk.Revit.DB.ResultsBuilder Namespace


DeleteResultsPackage Method (Guid)

ResultsAccess..::..DeleteResultsPackage Method (Guid)
ResultsAccess Class See Also Send Feedback
Deletes results packages of given guid from the document

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void DeleteResultsPackage(
    Guid value
)

Parameters

value
Type: System..::..Guid

Exceptions

Exception | Condition
ArgumentException | Results package of specified guid doesn't exist.

See Also

ResultsAccess Class
DeleteResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


DeleteResultsPackage Method (String)

ResultsAccess..::..DeleteResultsPackage Method (String)
ResultsAccess Class See Also Send Feedback
Deletes results packages of given Name from the document

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[ObsoleteAttribute("Use DeleteResultsPackage(Guid value) instead.")]
public void DeleteResultsPackage(
    string name
)

Parameters

name
Type: System..::..String

Exceptions

Exception | Condition
ArgumentException | Results packege of specified name doesn't exist.

See Also

ResultsAccess Class
DeleteResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetDocument Method

ResultsAccess..::..GetDocument Method
ResultsAccess Class See Also Send Feedback
Gets the document.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Document GetDocument(
    string uniqueId
)

Parameters

uniqueId
Type: System..::..String
The unique id.

Return Value

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetDocumentUniqueId Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsAccess..::..GetDocumentUniqueId Method
ResultsAccess Class See Also Send Feedback

Overload List

Name | Description
GetDocumentUniqueId(Document) | Gets the unique document id.
GetDocumentUniqueId(Int32) | Gets the unique document id.

See Also

ResultsAccess Class
ResultsAccess Members
Autodesk.Revit.DB.ResultsBuilder Namespace


GetDocumentUniqueId Method ()

ResultsAccess..::..GetDocumentUniqueId Method ()
ResultsAccess Class See Also Send Feedback
Gets the unique document id.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string GetDocumentUniqueId(
    Document document
)

Parameters

document
Type: Document
The document.

Return Value

See Also

ResultsAccess Class
GetDocumentUniqueId Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetDocumentUniqueId Method (Int32)

ResultsAccess..::..GetDocumentUniqueId Method (Int32)
ResultsAccess Class See Also Send Feedback
Gets the unique document id.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string GetDocumentUniqueId(
    int closingId
)

Parameters

closingId
Type: System..::..Int32
The closing id.

Return Value

See Also

ResultsAccess Class
GetDocumentUniqueId Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetResultsPackage Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsAccess..::..GetResultsPackage Method
ResultsAccess Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetResultsPackage(Guid) | Returns packages of given guid or null if not exists.
Public method | GetResultsPackage(String) | Returns packages of given name or null if not exists.

See Also

ResultsAccess Class
ResultsAccess Members
Autodesk.Revit.DB.ResultsBuilder Namespace


GetResultsPackage Method (Guid)

ResultsAccess..::..GetResultsPackage Method (Guid)
ResultsAccess Class See Also Send Feedback
Returns packages of given guid or null if not exists.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackage GetResultsPackage(
    Guid value
)

Parameters

value
Type: System..::..Guid

See Also

ResultsAccess Class
GetResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetResultsPackage Method (String)

ResultsAccess..::..GetResultsPackage Method (String)
ResultsAccess Class See Also Send Feedback
Returns packages of given name or null if not exists.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackage GetResultsPackage(
    string name
)

Parameters

name
Type: System..::..String

See Also

ResultsAccess Class
GetResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


UpdateResultsPackage Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsAccess..::..UpdateResultsPackage Method
ResultsAccess Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateResultsPackage(Guid) | Obsolete. Update existing results package.
Public method | UpdateResultsPackage(Guid, String) | Update existing results package.

See Also

ResultsAccess Class
ResultsAccess Members
Autodesk.Revit.DB.ResultsBuilder Namespace


UpdateResultsPackage Method (Guid)

ResultsAccess..::..UpdateResultsPackage Method (Guid)
ResultsAccess Class See Also Send Feedback
Update existing results package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[ObsoleteAttribute("Use UpdateResultsPackage(Guid value, string password) instead.")]
public ResultsPackageBuilder UpdateResultsPackage(
    Guid value
)

Parameters

value
Type: System..::..Guid

See Also

ResultsAccess Class
UpdateResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


UpdateResultsPackage Method (Guid, String)

ResultsAccess..::..UpdateResultsPackage Method (Guid, String)
ResultsAccess Class See Also Send Feedback
Update existing results package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackageBuilder UpdateResultsPackage(
    Guid value,
    string password
)

Parameters

value
Type: System..::..Guid
Guid of the package to be modified
password
Type: System..::..String
The same password that have been set on package creation. Password may be empty.

Exceptions

Exception | Condition
ArgumentException | Package of specified value doesn't exist.
ArgumentException | Package with GUID={} is not valid and cannot be updated.
ArgumentException | Invalid password.

See Also

ResultsAccess Class
UpdateResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsAccess Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsAccess Properties
ResultsAccess Class See Also Send Feedback

The ResultsAccess type exposes the following members.

Properties

 | Name | Description
Public property | Document | Provides access to the document that ResultsAccess was created for.
Public property | ResultsDescriptors | Provides access to the packages defined in current document.
Public property | ResultsPackages | Provides access to the packages defined in current document.

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Document Property

ResultsAccess..::..Document Property
ResultsAccess Class See Also Send Feedback
Provides access to the document that ResultsAccess was created for.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document Document { get; }

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsDescriptors Property

ResultsAccess..::..ResultsDescriptors Property
ResultsAccess Class See Also Send Feedback
Provides access to the packages defined in current document.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<ResultsPackageDescriptor> ResultsDescriptors { get; }

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsPackages Property

ResultsAccess..::..ResultsPackages Property
ResultsAccess Class See Also Send Feedback
Provides access to the packages defined in current document.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<ResultsPackage> ResultsPackages { get; }

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsAccess Events

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsAccess Events
ResultsAccess Class See Also Send Feedback

The ResultsAccess type exposes the following members.

Events

Name | Description
PackagesAdded | Subscribe to the PackagesAdded event to be notified that results package has been added.
PackagesDeleted | Subscribe to the PackagesDeleted event to be notified that results package has been deleted.
PackagesModified | Subscribe to the PackagesModified event to be notified that results package has been modified.
PackagesStatusChanged | Subscribe to the PackagesStatusChanged event to be notified that results package status has been changed.

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesAdded Event

ResultsAccess..::..PackagesAdded Event
ResultsAccess Class See Also Send Feedback
Subscribe to the PackagesAdded event to be notified that results package has been added.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static event EventHandler<PackagesAddedEventArgs> PackagesAdded

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesDeleted Event

ResultsAccess..::..PackagesDeleted Event
ResultsAccess Class See Also Send Feedback
Subscribe to the PackagesDeleted event to be notified that results package has been deleted.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static event EventHandler<PackagesDeletedEventArgs> PackagesDeleted

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesModified Event

ResultsAccess..::..PackagesModified Event
ResultsAccess Class See Also Send Feedback
Subscribe to the PackagesModified event to be notified that results package has been modified.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static event EventHandler<PackagesModifiedEventArgs> PackagesModified

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackagesStatusChanged Event

ResultsAccess..::..PackagesStatusChanged Event
ResultsAccess Class See Also Send Feedback
Subscribe to the PackagesStatusChanged event to be notified that results package status has been changed.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static event EventHandler<PackagesStatusChangedEventArgs> PackagesStatusChanged

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsPackage Class

ResultsPackage Class
Members See Also Send Feedback
Analysis class provides access to the results of analysis.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultsPackage

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..ResultsPackage

See Also

ResultsPackage Members
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsPackage Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage Members
ResultsPackage Class Methods Properties See Also Send Feedback

The ResultsPackage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBarNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Returns node results for linear element.
Public method | GetBarNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>), UnitsSystem) | Returns bar node results for element.
Public method | GetBarNodeResultsEnvelopes | GetBarNodeResultsEnvelopes
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>), LineGraphParameters) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), LineGraphParameters) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Return list of envelopes of linear results for given input parameters.
Public method | GetLineGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), LineGraphParameters) | Return list of envelopes of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphsExtremes | Return extremal values for given input parameters.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), NodeResultType) | Returns node results for element.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), NodeResultType, UnitsSystem) | Returns node results for element.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), String, UnitsSystem) | Returns node results for element.
Public method | GetNodeResultsEnvelope | Returns node results for element.
Public method | GetNodeResultsExtremes | Return extremal values for given input parameters.
Public method | GetReducedSurfaceResults | Returns reduced results for surface element.
Public method | GetResultsStatus | Return the status of the entire package.
Public method | GetStoreyResults | Returns results for storey.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>), SurfaceGraphParameters) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), SurfaceGraphParameters) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Return envelope of results.
Public method | GetSurfaceGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), SurfaceGraphParameters) | Return envelope of results.
Public method | GetSurfaceGraphsExtremes | Return extremal values for given input parameters.
Public method | GetSurfaceNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Returns surface node results for element.
Public method | GetSurfaceNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>), UnitsSystem) | Returns surface node results for element.
Public method | GetSurfaceNodeResultsEnvelope |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AnalysisInfo | Provides access to the Analysis Info of the package.
Public property | AnalysisName | Provides access to the Analysis Name of the package.
Public property | CreationTime | Provides access to the creation time of the package.
Public property | Description | Provides access to the Description of the package.
Public property | DesignOption | Provides access to the design option id for which the analysis was performed.
Public property | ElementIds | Returns set of elements for which results are available
Public property | GUID | Provides access to the GUID of the results package.
Public property | IsProviderPackage | Gets a value indicating whether this instance is provider package.
Public property | LoadCaseIds | Returns set of load cases for which results are available
Public property | Measurements | Returns collections of measurements defined in the package.
Public property | ModelId | Provides access to the Guid of the package.
Public property | ModelInfo | Provides access to the Model Info of the package.
Public property | ModelName | Provides access to the Model Name of the package.
Public property | Name | Provides access to the Name of the results package.
Public property | PackageSize | Returns package size in kilobytes.
Public property | Phase | Provides access to the phase id for which the analysis was performed.
Public property | ProviderDescriptor | Gets the provider descriptor. This reference is set, when the ResultsPackage was created from this ResultsPackageDescriptor.
Public property | ProviderDescriptorReference | Gets the provider descriptor reference. This reference is set, when the ResultsPackage is saved with document and it has ResultsPackageDescriptor provided by some provider.
Public property | ProviderName | Provides access to the Provider Name of the package.
Public property | ResultsPackageType | Returns type of package.
Public property | VendorDescription | Provides access to the Vendor Description of the package.
Public property | VendorId | Provides access to the Vendor Id of the package.

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsPackage Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage Methods
ResultsPackage Class See Also Send Feedback

The ResultsPackage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBarNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Returns node results for linear element.
Public method | GetBarNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>), UnitsSystem) | Returns bar node results for element.
Public method | GetBarNodeResultsEnvelopes | GetBarNodeResultsEnvelopes
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>), LineGraphParameters) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), LineGraphParameters) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Return list of envelopes of linear results for given input parameters.
Public method | GetLineGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), LineGraphParameters) | Return list of envelopes of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphsExtremes | Return extremal values for given input parameters.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), NodeResultType) | Returns node results for element.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), NodeResultType, UnitsSystem) | Returns node results for element.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), String, UnitsSystem) | Returns node results for element.
Public method | GetNodeResultsEnvelope | Returns node results for element.
Public method | GetNodeResultsExtremes | Return extremal values for given input parameters.
Public method | GetReducedSurfaceResults | Returns reduced results for surface element.
Public method | GetResultsStatus | Return the status of the entire package.
Public method | GetStoreyResults | Returns results for storey.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>), SurfaceGraphParameters) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), SurfaceGraphParameters) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Return envelope of results.
Public method | GetSurfaceGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), SurfaceGraphParameters) | Return envelope of results.
Public method | GetSurfaceGraphsExtremes | Return extremal values for given input parameters.
Public method | GetSurfaceNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Returns surface node results for element.
Public method | GetSurfaceNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>), UnitsSystem) | Returns surface node results for element.
Public method | GetSurfaceNodeResultsEnvelope |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetBarNodeResults Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage..::..GetBarNodeResults Method
ResultsPackage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBarNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Returns node results for linear element.
Public method | GetBarNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>), UnitsSystem) | Returns bar node results for element.

See Also

ResultsPackage Class
ResultsPackage Members
Autodesk.Revit.DB.ResultsBuilder Namespace


GetBarNodeResults Method (ICollection(), ICollection(), ICollection(LinearResultType))

ResultsPackage..::..GetBarNodeResults Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'LinearResultType>)>)>)
ResultsPackage Class See Also Send Feedback
Returns node results for linear element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<BarNodeResult> GetBarNodeResults(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCasesOrCombinations,
    ICollection<LinearResultType> types
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCasesOrCombinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
types
Type: System.Collections.Generic..::..ICollection <(Of <(<' LinearResultType >)>)>

See Also

ResultsPackage Class
GetBarNodeResults Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetBarNodeResults Method (ICollection(), ICollection(), ICollection(LinearResultType), UnitsSystem)

ResultsPackage..::..GetBarNodeResults Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'LinearResultType>)>)>, UnitsSystem)
ResultsPackage Class See Also Send Feedback
Returns bar node results for element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<BarNodeResult> GetBarNodeResults(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCasesOrCombinations,
    ICollection<LinearResultType> types,
    UnitsSystem unitsSystem
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCasesOrCombinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
types
Type: System.Collections.Generic..::..ICollection <(Of <(<' LinearResultType >)>)>
unitsSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

See Also

ResultsPackage Class
GetBarNodeResults Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetBarNodeResultsEnvelopes Method

ResultsPackage..::..GetBarNodeResultsEnvelopes Method
ResultsPackage Class See Also Send Feedback
GetBarNodeResultsEnvelopes

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<BarNodeResultEnvelope> GetBarNodeResultsEnvelopes(
    ICollection<ElementId> loadCases,
    ICollection<ElementId> resultsReactionTypes,
    ICollection<LinearResultType> resultsTypes
)

Parameters

loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsReactionTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' LinearResultType >)>)>

Return Value

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetLineGraphs Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage..::..GetLineGraphs Method
ResultsPackage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>), LineGraphParameters) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), LineGraphParameters) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.

See Also

ResultsPackage Class
ResultsPackage Members
Autodesk.Revit.DB.ResultsBuilder Namespace


GetLineGraphs Method (ICollection(), ICollection(), ICollection(LinearResultType))

ResultsPackage..::..GetLineGraphs Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'LinearResultType>)>)>)
ResultsPackage Class See Also Send Feedback
Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<LineGraph> GetLineGraphs(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCases,
    ICollection<LinearResultType> resultsTypes
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' LinearResultType >)>)>

See Also

ResultsPackage Class
GetLineGraphs Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetLineGraphs Method (ICollection(), ICollection(), ICollection(LinearResultType), LineGraphParameters)

ResultsPackage..::..GetLineGraphs Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'LinearResultType>)>)>, LineGraphParameters)
ResultsPackage Class See Also Send Feedback
Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<LineGraph> GetLineGraphs(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCases,
    ICollection<LinearResultType> resultsTypes,
    LineGraphParameters lineGraphMode
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' LinearResultType >)>)>
lineGraphMode
Type: Autodesk.Revit.DB.ResultsBuilder..::..LineGraphParameters

See Also

ResultsPackage Class
GetLineGraphs Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetLineGraphs Method (ICollection(), ICollection(), ICollection(String), LineGraphParameters)

ResultsPackage..::..GetLineGraphs Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'String>)>)>, LineGraphParameters)
ResultsPackage Class See Also Send Feedback
Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<LineGraph> GetLineGraphs(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCases,
    ICollection<string> resultsNames,
    LineGraphParameters lineGraphMode
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsNames
Type: System.Collections.Generic..::..ICollection <(Of <(<' String >)>)>
lineGraphMode
Type: Autodesk.Revit.DB.ResultsBuilder..::..LineGraphParameters

See Also

ResultsPackage Class
GetLineGraphs Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetLineGraphsEnvelopes Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage..::..GetLineGraphsEnvelopes Method
ResultsPackage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLineGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Return list of envelopes of linear results for given input parameters.
Public method | GetLineGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), LineGraphParameters) | Return list of envelopes of linear results for given input parameters. Values are defined in local coordinate system of analytical model.

See Also

ResultsPackage Class
ResultsPackage Members
Autodesk.Revit.DB.ResultsBuilder Namespace


GetLineGraphsEnvelopes Method (ICollection(), ICollection(), ICollection(LinearResultType))

ResultsPackage..::..GetLineGraphsEnvelopes Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'LinearResultType>)>)>)
ResultsPackage Class See Also Send Feedback
Return list of envelopes of linear results for given input parameters.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<LineGraphEnvelope> GetLineGraphsEnvelopes(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCases,
    ICollection<LinearResultType> resultsTypes
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' LinearResultType >)>)>

See Also

ResultsPackage Class
GetLineGraphsEnvelopes Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetLineGraphsEnvelopes Method (ICollection(), ICollection(), ICollection(String), LineGraphParameters)

ResultsPackage..::..GetLineGraphsEnvelopes Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'String>)>)>, LineGraphParameters)
ResultsPackage Class See Also Send Feedback
Return list of envelopes of linear results for given input parameters. Values are defined in local coordinate system of analytical model.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<LineGraphEnvelope> GetLineGraphsEnvelopes(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCases,
    ICollection<string> resultsNames,
    LineGraphParameters lineGraphMode
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsNames
Type: System.Collections.Generic..::..ICollection <(Of <(<' String >)>)>
lineGraphMode
Type: Autodesk.Revit.DB.ResultsBuilder..::..LineGraphParameters

See Also

ResultsPackage Class
GetLineGraphsEnvelopes Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetLineGraphsExtremes Method

ResultsPackage..::..GetLineGraphsExtremes Method
ResultsPackage Class See Also Send Feedback
Return extremal values for given input parameters.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool GetLineGraphsExtremes(
    ICollection<ElementId> loadCases,
    ICollection<LinearResultType> resultsTypes_,
    out double min,
    out double max
)

Parameters

loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes_
Type: System.Collections.Generic..::..ICollection <(Of <(<' LinearResultType >)>)>
min
Type: System..::..Double %
max
Type: System..::..Double %

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetNodeResults Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage..::..GetNodeResults Method
ResultsPackage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), NodeResultType) | Returns node results for element.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), NodeResultType, UnitsSystem) | Returns node results for element.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), String, UnitsSystem) | Returns node results for element.

See Also

ResultsPackage Class
ResultsPackage Members
Autodesk.Revit.DB.ResultsBuilder Namespace


GetNodeResults Method (ICollection(), ICollection(), NodeResultType)

ResultsPackage..::..GetNodeResults Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, NodeResultType)
ResultsPackage Class See Also Send Feedback
Returns node results for element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<NodeResult> GetNodeResults(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCasesOrCombinations,
    NodeResultType type
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCasesOrCombinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
type
Type: Autodesk.Revit.DB.ResultsBuilder..::..NodeResultType

See Also

ResultsPackage Class
GetNodeResults Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetNodeResults Method (ICollection(), ICollection(), NodeResultType, UnitsSystem)

ResultsPackage..::..GetNodeResults Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, NodeResultType, UnitsSystem)
ResultsPackage Class See Also Send Feedback
Returns node results for element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<NodeResult> GetNodeResults(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCasesOrCombinations,
    NodeResultType type,
    UnitsSystem unitsSystem
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCasesOrCombinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
type
Type: Autodesk.Revit.DB.ResultsBuilder..::..NodeResultType
unitsSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

See Also

ResultsPackage Class
GetNodeResults Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetNodeResults Method (ICollection(), ICollection(), String, UnitsSystem)

ResultsPackage..::..GetNodeResults Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, String, UnitsSystem)
ResultsPackage Class See Also Send Feedback
Returns node results for element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<NodeResult> GetNodeResults(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCasesOrCombinations,
    string type,
    UnitsSystem unitsSystem
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCasesOrCombinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
type
Type: System..::..String
unitsSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

See Also

ResultsPackage Class
GetNodeResults Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetNodeResultsEnvelope Method

ResultsPackage..::..GetNodeResultsEnvelope Method
ResultsPackage Class See Also Send Feedback
Returns node results for element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<NodeResultEnvelope> GetNodeResultsEnvelope(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadIds,
    NodeResultType type
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
type
Type: Autodesk.Revit.DB.ResultsBuilder..::..NodeResultType

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetNodeResultsExtremes Method

ResultsPackage..::..GetNodeResultsExtremes Method
ResultsPackage Class See Also Send Feedback
Return extremal values for given input parameters.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool GetNodeResultsExtremes(
    ICollection<ElementId> loadCases,
    NodeResultType type,
    out XYZ min,
    out XYZ max
)

Parameters

loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
type
Type: Autodesk.Revit.DB.ResultsBuilder..::..NodeResultType
min
Type: XYZ%
max
Type: XYZ%

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetReducedSurfaceResults Method

ResultsPackage..::..GetReducedSurfaceResults Method
ResultsPackage Class See Also Send Feedback
Returns reduced results for surface element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceReducedResults GetReducedSurfaceResults(
    ElementId elementId,
    ElementId loadCaseId
)

Parameters

elementId
Type: ElementId
loadCaseId
Type: ElementId

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetResultsStatus Method

ResultsPackage..::..GetResultsStatus Method
ResultsPackage Class See Also Send Feedback
Return the status of the entire package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsStatus GetResultsStatus()

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetStoreyResults Method

ResultsPackage..::..GetStoreyResults Method
ResultsPackage Class See Also Send Feedback
Returns results for storey.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public StoreyResults GetStoreyResults(
    ElementId levelId,
    ElementId loadCaseId
)

Parameters

levelId
Type: ElementId
loadCaseId
Type: ElementId

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceGraphs Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage..::..GetSurfaceGraphs Method
ResultsPackage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>), SurfaceGraphParameters) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), SurfaceGraphParameters) | Return list of planar results for given input parameters.

See Also

ResultsPackage Class
ResultsPackage Members
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceGraphs Method (ICollection(), ICollection(), ICollection(SurfaceResultType))

ResultsPackage..::..GetSurfaceGraphs Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'SurfaceResultType>)>)>)
ResultsPackage Class See Also Send Feedback
Return list of planar results for given input parameters.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceGraph> GetSurfaceGraphs(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadIds,
    ICollection<SurfaceResultType> resultsTypes
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfaceResultType >)>)>

See Also

ResultsPackage Class
GetSurfaceGraphs Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceGraphs Method (ICollection(), ICollection(), ICollection(SurfaceResultType), SurfaceGraphParameters)

ResultsPackage..::..GetSurfaceGraphs Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'SurfaceResultType>)>)>, SurfaceGraphParameters)
ResultsPackage Class See Also Send Feedback
Return list of planar results for given input parameters.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceGraph> GetSurfaceGraphs(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadIds,
    ICollection<SurfaceResultType> resultsTypes,
    SurfaceGraphParameters surfaceGraphMode
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfaceResultType >)>)>
surfaceGraphMode
Type: Autodesk.Revit.DB.ResultsBuilder..::..SurfaceGraphParameters

See Also

ResultsPackage Class
GetSurfaceGraphs Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceGraphs Method (ICollection(), ICollection(), ICollection(String), SurfaceGraphParameters)

ResultsPackage..::..GetSurfaceGraphs Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'String>)>)>, SurfaceGraphParameters)
ResultsPackage Class See Also Send Feedback
Return list of planar results for given input parameters.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceGraph> GetSurfaceGraphs(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadIds,
    ICollection<string> resultsNames,
    SurfaceGraphParameters surfaceGraphMode
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsNames
Type: System.Collections.Generic..::..ICollection <(Of <(<' String >)>)>
surfaceGraphMode
Type: Autodesk.Revit.DB.ResultsBuilder..::..SurfaceGraphParameters

See Also

ResultsPackage Class
GetSurfaceGraphs Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceGraphsEnvelopes Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage..::..GetSurfaceGraphsEnvelopes Method
ResultsPackage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSurfaceGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Return envelope of results.
Public method | GetSurfaceGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), SurfaceGraphParameters) | Return envelope of results.

See Also

ResultsPackage Class
ResultsPackage Members
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceGraphsEnvelopes Method (ICollection(), ICollection(), ICollection(SurfaceResultType))

ResultsPackage..::..GetSurfaceGraphsEnvelopes Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'SurfaceResultType>)>)>)
ResultsPackage Class See Also Send Feedback
Return envelope of results.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceGraphEnvelope> GetSurfaceGraphsEnvelopes(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadIds,
    ICollection<SurfaceResultType> resultsTypes
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfaceResultType >)>)>

See Also

ResultsPackage Class
GetSurfaceGraphsEnvelopes Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceGraphsEnvelopes Method (ICollection(), ICollection(), ICollection(String), SurfaceGraphParameters)

ResultsPackage..::..GetSurfaceGraphsEnvelopes Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'String>)>)>, SurfaceGraphParameters)
ResultsPackage Class See Also Send Feedback
Return envelope of results.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceGraphEnvelope> GetSurfaceGraphsEnvelopes(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadIds,
    ICollection<string> resultsNames,
    SurfaceGraphParameters surfaceGraphMode
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsNames
Type: System.Collections.Generic..::..ICollection <(Of <(<' String >)>)>
surfaceGraphMode
Type: Autodesk.Revit.DB.ResultsBuilder..::..SurfaceGraphParameters

See Also

ResultsPackage Class
GetSurfaceGraphsEnvelopes Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceGraphsExtremes Method

ResultsPackage..::..GetSurfaceGraphsExtremes Method
ResultsPackage Class See Also Send Feedback
Return extremal values for given input parameters.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool GetSurfaceGraphsExtremes(
    ICollection<ElementId> loadCases,
    ICollection<SurfaceResultType> resultsTypes_,
    out double min,
    out double max
)

Parameters

loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes_
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfaceResultType >)>)>
min
Type: System..::..Double %
max
Type: System..::..Double %

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceNodeResults Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage..::..GetSurfaceNodeResults Method
ResultsPackage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSurfaceNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Returns surface node results for element.
Public method | GetSurfaceNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>), UnitsSystem) | Returns surface node results for element.

See Also

ResultsPackage Class
ResultsPackage Members
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceNodeResults Method (ICollection(), ICollection(), ICollection(SurfaceResultType))

ResultsPackage..::..GetSurfaceNodeResults Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'SurfaceResultType>)>)>)
ResultsPackage Class See Also Send Feedback
Returns surface node results for element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceNodeResult> GetSurfaceNodeResults(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCasesOrCombinations,
    ICollection<SurfaceResultType> types
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCasesOrCombinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
types
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfaceResultType >)>)>

See Also

ResultsPackage Class
GetSurfaceNodeResults Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceNodeResults Method (ICollection(), ICollection(), ICollection(SurfaceResultType), UnitsSystem)

ResultsPackage..::..GetSurfaceNodeResults Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'SurfaceResultType>)>)>, UnitsSystem)
ResultsPackage Class See Also Send Feedback
Returns surface node results for element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceNodeResult> GetSurfaceNodeResults(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCasesOrCombinations,
    ICollection<SurfaceResultType> types,
    UnitsSystem unitsSystem
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCasesOrCombinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
types
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfaceResultType >)>)>
unitsSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

See Also

ResultsPackage Class
GetSurfaceNodeResults Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


GetSurfaceNodeResultsEnvelope Method

ResultsPackage..::..GetSurfaceNodeResultsEnvelope Method
ResultsPackage Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceNodeResultEnvelope> GetSurfaceNodeResultsEnvelope(
    ICollection<ElementId> elements,
    ICollection<ElementId> loadCases,
    ICollection<SurfaceResultType> resultsMapTypes
)

Parameters

elements
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsMapTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfaceResultType >)>)>

Return Value

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ToString Method

ResultsPackage..::..ToString Method
ResultsPackage Class See Also Send Feedback
Returns a String that represents this instance.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override string ToString()

Return Value

A String that represents this instance.

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsPackage Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage Properties
ResultsPackage Class See Also Send Feedback

The ResultsPackage type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisInfo | Provides access to the Analysis Info of the package.
Public property | AnalysisName | Provides access to the Analysis Name of the package.
Public property | CreationTime | Provides access to the creation time of the package.
Public property | Description | Provides access to the Description of the package.
Public property | DesignOption | Provides access to the design option id for which the analysis was performed.
Public property | ElementIds | Returns set of elements for which results are available
Public property | GUID | Provides access to the GUID of the results package.
Public property | IsProviderPackage | Gets a value indicating whether this instance is provider package.
Public property | LoadCaseIds | Returns set of load cases for which results are available
Public property | Measurements | Returns collections of measurements defined in the package.
Public property | ModelId | Provides access to the Guid of the package.
Public property | ModelInfo | Provides access to the Model Info of the package.
Public property | ModelName | Provides access to the Model Name of the package.
Public property | Name | Provides access to the Name of the results package.
Public property | PackageSize | Returns package size in kilobytes.
Public property | Phase | Provides access to the phase id for which the analysis was performed.
Public property | ProviderDescriptor | Gets the provider descriptor. This reference is set, when the ResultsPackage was created from this ResultsPackageDescriptor.
Public property | ProviderDescriptorReference | Gets the provider descriptor reference. This reference is set, when the ResultsPackage is saved with document and it has ResultsPackageDescriptor provided by some provider.
Public property | ProviderName | Provides access to the Provider Name of the package.
Public property | ResultsPackageType | Returns type of package.
Public property | VendorDescription | Provides access to the Vendor Description of the package.
Public property | VendorId | Provides access to the Vendor Id of the package.

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


AnalysisInfo Property

ResultsPackage..::..AnalysisInfo Property
ResultsPackage Class See Also Send Feedback
Provides access to the Analysis Info of the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string AnalysisInfo { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


AnalysisName Property

ResultsPackage..::..AnalysisName Property
ResultsPackage Class See Also Send Feedback
Provides access to the Analysis Name of the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string AnalysisName { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


CreationTime Property

ResultsPackage..::..CreationTime Property
ResultsPackage Class See Also Send Feedback
Provides access to the creation time of the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DateTimeOffset CreationTime { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Description Property

ResultsPackage..::..Description Property
ResultsPackage Class See Also Send Feedback
Provides access to the Description of the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Description { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DesignOption Property

ResultsPackage..::..DesignOption Property
ResultsPackage Class See Also Send Feedback
Provides access to the design option id for which the analysis was performed.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementId DesignOption { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ElementIds Property

ResultsPackage..::..ElementIds Property
ResultsPackage Class See Also Send Feedback
Returns set of elements for which results are available

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<ElementId> ElementIds { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


GUID Property

ResultsPackage..::..GUID Property
ResultsPackage Class See Also Send Feedback
Provides access to the GUID of the results package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid GUID { get; }

Remarks

GUID is stable and unique in the document. It can be use to store in external databases.

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


IsProviderPackage Property

ResultsPackage..::..IsProviderPackage Property
ResultsPackage Class See Also Send Feedback
Gets a value indicating whether this instance is provider package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsProviderPackage { get; }

Field Value

true if this instance is provider package; otherwise, false.

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LoadCaseIds Property

ResultsPackage..::..LoadCaseIds Property
ResultsPackage Class See Also Send Feedback
Returns set of load cases for which results are available

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<ElementId> LoadCaseIds { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Measurements Property

ResultsPackage..::..Measurements Property
ResultsPackage Class See Also Send Feedback
Returns collections of measurements defined in the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<MeasurementDescription> Measurements { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ModelId Property

ResultsPackage..::..ModelId Property
ResultsPackage Class See Also Send Feedback
Provides access to the Guid of the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid ModelId { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ModelInfo Property

ResultsPackage..::..ModelInfo Property
ResultsPackage Class See Also Send Feedback
Provides access to the Model Info of the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string ModelInfo { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ModelName Property

ResultsPackage..::..ModelName Property
ResultsPackage Class See Also Send Feedback
Provides access to the Model Name of the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string ModelName { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Name Property

ResultsPackage..::..Name Property
ResultsPackage Class See Also Send Feedback
Provides access to the Name of the results package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; }

Remarks

Name is unique in the document but it is not guaranteed that it won't be changed, so it shouldn't be stored in external databases for later use.

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


PackageSize Property

ResultsPackage..::..PackageSize Property
ResultsPackage Class See Also Send Feedback
Returns package size in kilobytes.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public long PackageSize { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Phase Property

ResultsPackage..::..Phase Property
ResultsPackage Class See Also Send Feedback
Provides access to the phase id for which the analysis was performed.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementId Phase { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ProviderDescriptor Property

ResultsPackage..::..ProviderDescriptor Property
ResultsPackage Class See Also Send Feedback
Gets the provider descriptor. This reference is set, when the ResultsPackage was created from this ResultsPackageDescriptor.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackageDescriptor ProviderDescriptor { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ProviderDescriptorReference Property

ResultsPackage..::..ProviderDescriptorReference Property
ResultsPackage Class See Also Send Feedback
Gets the provider descriptor reference. This reference is set, when the ResultsPackage is saved with document and it has ResultsPackageDescriptor provided by some provider.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackageDescriptor ProviderDescriptorReference { get; internal set; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ProviderName Property

ResultsPackage..::..ProviderName Property
ResultsPackage Class See Also Send Feedback
Provides access to the Provider Name of the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string ProviderName { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsPackageType Property

ResultsPackage..::..ResultsPackageType Property
ResultsPackage Class See Also Send Feedback
Returns type of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackageTypes ResultsPackageType { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


VendorDescription Property

ResultsPackage..::..VendorDescription Property
ResultsPackage Class See Also Send Feedback
Provides access to the Vendor Description of the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string VendorDescription { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


VendorId Property

ResultsPackage..::..VendorId Property
ResultsPackage Class See Also Send Feedback
Provides access to the Vendor Id of the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string VendorId { get; }

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsPackageTypes Enumeration

ResultsPackageTypes Enumeration
See Also Send Feedback
Defines types of packages.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[FlagsAttribute]
public enum ResultsPackageTypes

Members

Member name | Value | Description
None | 0 | Undefined
Static | 1 | Static
RequiredReinforcement | 2 | RequiredReinforcement
Seismic | 4 | Seismic
Energy | 8 | Energy
SteelRatio | 16 | SteelRatio
All | 31 | All possible types

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace


ResultsStatus Enumeration

ResultsStatus Enumeration
See Also Send Feedback
Constants defines the status of results package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ResultsStatus

Members

Member name | Value | Description
Unknown | 0 | ResultsStatus is unknown.
Available | 1 | Results exist.
OutOfDate | 2 | Results exist but may be out of date.
AvailableRemotely | 3 | Results exist, but may need to be downloaded.

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraph Class

SurfaceGraph Class
Members See Also Send Feedback
Represents planar map of Points defined by the set of triples (valueX,valueY,values(valueX,valueY))

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SurfaceGraph : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..SurfaceGraph

See Also

SurfaceGraph Members
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraph Members

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraph Members
SurfaceGraph Class Methods Properties See Also Send Feedback

The SurfaceGraph type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DirectionX | Obsolete. Returns Vector defining the X-axis of the coordinate system in which the results are presented.
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | LocalCoordinateSystem | Returns Transormation defining the axes of the coordinate system in which the results are presented.
Public property | Points | List of coordinates in local plane.
Public property | ResultType | Returns the type of the graph.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.
Public property | Values | List of Values over the coordinates.

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraph Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraph Methods
SurfaceGraph Class See Also Send Feedback

The SurfaceGraph type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraph Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraph Properties
SurfaceGraph Class See Also Send Feedback

The SurfaceGraph type exposes the following members.

Properties

 | Name | Description
Public property | DirectionX | Obsolete. Returns Vector defining the X-axis of the coordinate system in which the results are presented.
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | LocalCoordinateSystem | Returns Transormation defining the axes of the coordinate system in which the results are presented.
Public property | Points | List of coordinates in local plane.
Public property | ResultType | Returns the type of the graph.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.
Public property | Values | List of Values over the coordinates.

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DirectionX Property

SurfaceGraph..::..DirectionX Property
SurfaceGraph Class See Also Send Feedback
Returns Vector defining the X-axis of the coordinate system in which the results are presented.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[ObsoleteAttribute("Use LocalCoordinateSystem.BasisX")]
public XYZ DirectionX { get; }

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DomainDisplayUnitType Property

SurfaceGraph..::..DomainDisplayUnitType Property
SurfaceGraph Class See Also Send Feedback
Indicates the units of the domain of the linear graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType DomainDisplayUnitType { get; }

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LocalCoordinateSystem Property

SurfaceGraph..::..LocalCoordinateSystem Property
SurfaceGraph Class See Also Send Feedback
Returns Transormation defining the axes of the coordinate system in which the results are presented.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Transform LocalCoordinateSystem { get; }

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Points Property

SurfaceGraph..::..Points Property
SurfaceGraph Class See Also Send Feedback
List of coordinates in local plane.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<XYZ> Points { get; }

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

SurfaceGraph..::..ResultType Property
SurfaceGraph Class See Also Send Feedback
Returns the type of the graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceResultType ResultType { get; }

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ValueDisplayUnitType Property

SurfaceGraph..::..ValueDisplayUnitType Property
SurfaceGraph Class See Also Send Feedback
Indicates the units of the values of the linear graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType ValueDisplayUnitType { get; }

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Values Property

SurfaceGraph..::..Values Property
SurfaceGraph Class See Also Send Feedback
List of Values over the coordinates.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<double> Values { get; }

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphDirectionType Enumeration

SurfaceGraphDirectionType Enumeration
See Also Send Feedback
Defines a types of methods that the surface results are calculated while querying.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SurfaceGraphDirectionType

Members

Member name | Value | Description
Unknown | 0 | Unknown direction type
Default | 1 | Results will be returned in local coordinate system of analytical model.
CustomLocalPlane | 2 | Results will be returned in coordinate system defined in query parameters (in SurfaceGraphParameters).
SpecifiedDirectionX | 2 | Obsolete.

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphEnvelope Class

SurfaceGraphEnvelope Class
Members See Also Send Feedback
Represents envelope of surface graphs.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SurfaceGraphEnvelope : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..SurfaceGraphEnvelope

See Also

SurfaceGraphEnvelope Members
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphEnvelope Members

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraphEnvelope Members
SurfaceGraphEnvelope Class Methods Properties See Also Send Feedback

The SurfaceGraphEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DirectionX | Returns Vector defining the X-axis of the coordinate system in which the results are presented.
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | MaxValues | List of maximal Values over the coordinates.
Public property | MinValues | List of minimal Values over the coordinates.
Public property | Points | List of coordinates in local plane.
Public property | ResultType | Returns the type of the graph.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphEnvelope Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraphEnvelope Methods
SurfaceGraphEnvelope Class See Also Send Feedback

The SurfaceGraphEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphEnvelope Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraphEnvelope Properties
SurfaceGraphEnvelope Class See Also Send Feedback

The SurfaceGraphEnvelope type exposes the following members.

Properties

 | Name | Description
Public property | DirectionX | Returns Vector defining the X-axis of the coordinate system in which the results are presented.
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | MaxValues | List of maximal Values over the coordinates.
Public property | MinValues | List of minimal Values over the coordinates.
Public property | Points | List of coordinates in local plane.
Public property | ResultType | Returns the type of the graph.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DirectionX Property

SurfaceGraphEnvelope..::..DirectionX Property
SurfaceGraphEnvelope Class See Also Send Feedback
Returns Vector defining the X-axis of the coordinate system in which the results are presented.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ DirectionX { get; }

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DomainDisplayUnitType Property

SurfaceGraphEnvelope..::..DomainDisplayUnitType Property
SurfaceGraphEnvelope Class See Also Send Feedback
Indicates the units of the domain of the linear graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType DomainDisplayUnitType { get; }

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


MaxValues Property

SurfaceGraphEnvelope..::..MaxValues Property
SurfaceGraphEnvelope Class See Also Send Feedback
List of maximal Values over the coordinates.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<double> MaxValues { get; }

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


MinValues Property

SurfaceGraphEnvelope..::..MinValues Property
SurfaceGraphEnvelope Class See Also Send Feedback
List of minimal Values over the coordinates.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<double> MinValues { get; }

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Points Property

SurfaceGraphEnvelope..::..Points Property
SurfaceGraphEnvelope Class See Also Send Feedback
List of coordinates in local plane.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ReadOnlyCollection<XYZ> Points { get; }

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

SurfaceGraphEnvelope..::..ResultType Property
SurfaceGraphEnvelope Class See Also Send Feedback
Returns the type of the graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceResultType ResultType { get; }

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ValueDisplayUnitType Property

SurfaceGraphEnvelope..::..ValueDisplayUnitType Property
SurfaceGraphEnvelope Class See Also Send Feedback
Indicates the units of the values of the linear graph.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType ValueDisplayUnitType { get; }

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphParameters Class

SurfaceGraphParameters Class
Members See Also Send Feedback
Class for various types of settings used for calculating results on surfaces.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SurfaceGraphParameters

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..SurfaceGraphParameters

See Also

SurfaceGraphParameters Members
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphParameters Members

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraphParameters Members
SurfaceGraphParameters Class Constructors Methods Properties See Also Send Feedback

The SurfaceGraphParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SurfaceGraphParameters()()()() | Creates SurfaceGraphParameters object.
Public method | SurfaceGraphParameters(UnitsSystem) | Creates SurfaceGraphParameters object.
Public method | SurfaceGraphParameters(UnitsSystem, Transform) | Creates SurfaceGraphParameters object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DirectionType |
Public property | DirectionX | XYZ coordinates of results's main direction. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | DirectionZ | XYZ coordinates of results's normal direction. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | LocalCoordinateSystem | Transform of results's. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | UnitsSystem | Defines the set of units used when querying for results.

See Also

SurfaceGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphParameters Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraphParameters Constructor
SurfaceGraphParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SurfaceGraphParameters()()()() | Creates SurfaceGraphParameters object.
Public method | SurfaceGraphParameters(UnitsSystem) | Creates SurfaceGraphParameters object.
Public method | SurfaceGraphParameters(UnitsSystem, Transform) | Creates SurfaceGraphParameters object.

See Also

SurfaceGraphParameters Class
SurfaceGraphParameters Members
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphParameters Constructor

SurfaceGraphParameters Constructor
SurfaceGraphParameters Class See Also Send Feedback
Creates SurfaceGraphParameters object.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceGraphParameters()

See Also

SurfaceGraphParameters Class
SurfaceGraphParameters Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphParameters Constructor (UnitsSystem)

SurfaceGraphParameters Constructor (UnitsSystem)
SurfaceGraphParameters Class See Also Send Feedback
Creates SurfaceGraphParameters object.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceGraphParameters(
    UnitsSystem unitsSystem
)

Parameters

unitsSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

See Also

SurfaceGraphParameters Class
SurfaceGraphParameters Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphParameters Constructor (UnitsSystem, )

SurfaceGraphParameters Constructor (UnitsSystem, )
SurfaceGraphParameters Class See Also Send Feedback
Creates SurfaceGraphParameters object.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceGraphParameters(
    UnitsSystem unitsSystem,
    Transform localCoordinateSystem
)

Parameters

unitsSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem
localCoordinateSystem
Type: Transform

See Also

SurfaceGraphParameters Class
SurfaceGraphParameters Overload
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphParameters Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraphParameters Methods
SurfaceGraphParameters Class See Also Send Feedback

The SurfaceGraphParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SurfaceGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceGraphParameters Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraphParameters Properties
SurfaceGraphParameters Class See Also Send Feedback

The SurfaceGraphParameters type exposes the following members.

Properties

 | Name | Description
Public property | DirectionType |
Public property | DirectionX | XYZ coordinates of results's main direction. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | DirectionZ | XYZ coordinates of results's normal direction. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | LocalCoordinateSystem | Transform of results's. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | UnitsSystem | Defines the set of units used when querying for results.

See Also

SurfaceGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DirectionType Property

SurfaceGraphParameters..::..DirectionType Property
SurfaceGraphParameters Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceGraphDirectionType DirectionType { get; set; }

See Also

SurfaceGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DirectionX Property

SurfaceGraphParameters..::..DirectionX Property
SurfaceGraphParameters Class See Also Send Feedback
XYZ coordinates of results's main direction. This value is valid only with the DirectionType set to SpecifiedDirectionX

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ DirectionX { get; set; }

See Also

SurfaceGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


DirectionZ Property

SurfaceGraphParameters..::..DirectionZ Property
SurfaceGraphParameters Class See Also Send Feedback
XYZ coordinates of results's normal direction. This value is valid only with the DirectionType set to SpecifiedDirectionX

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZ DirectionZ { get; set; }

See Also

SurfaceGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


LocalCoordinateSystem Property

SurfaceGraphParameters..::..LocalCoordinateSystem Property
SurfaceGraphParameters Class See Also Send Feedback
Transform of results's. This value is valid only with the DirectionType set to SpecifiedDirectionX

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Transform LocalCoordinateSystem { get; }

See Also

SurfaceGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


UnitsSystem Property

SurfaceGraphParameters..::..UnitsSystem Property
SurfaceGraphParameters Class See Also Send Feedback
Defines the set of units used when querying for results.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitsSystem UnitsSystem { get; set; }

See Also

SurfaceGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceNodeResult Class

SurfaceNodeResult Class
Members See Also Send Feedback
Represents result value of specified type for given node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SurfaceNodeResult : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..SurfaceNodeResult

See Also

SurfaceNodeResult Members
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceNodeResult Members

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceNodeResult Members
SurfaceNodeResult Class Methods Properties See Also Send Feedback

The SurfaceNodeResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Type of result.
Public property | Value | Value for node.
Public property | X | X defines the global coordinate where the results are specified.
Public property | Y | Y defines the global coordinate where the results are specified.
Public property | Z | Z defines the global coordinate where the results are specified.

See Also

SurfaceNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceNodeResult Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceNodeResult Methods
SurfaceNodeResult Class See Also Send Feedback

The SurfaceNodeResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SurfaceNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceNodeResult Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceNodeResult Properties
SurfaceNodeResult Class See Also Send Feedback

The SurfaceNodeResult type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Type of result.
Public property | Value | Value for node.
Public property | X | X defines the global coordinate where the results are specified.
Public property | Y | Y defines the global coordinate where the results are specified.
Public property | Z | Z defines the global coordinate where the results are specified.

See Also

SurfaceNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

SurfaceNodeResult..::..ResultType Property
SurfaceNodeResult Class See Also Send Feedback
Type of result.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceResultType ResultType { get; }

See Also

SurfaceNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Value Property

SurfaceNodeResult..::..Value Property
SurfaceNodeResult Class See Also Send Feedback
Value for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Value { get; }

See Also

SurfaceNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


X Property

SurfaceNodeResult..::..X Property
SurfaceNodeResult Class See Also Send Feedback
X defines the global coordinate where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double X { get; }

See Also

SurfaceNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Y Property

SurfaceNodeResult..::..Y Property
SurfaceNodeResult Class See Also Send Feedback
Y defines the global coordinate where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Y { get; }

See Also

SurfaceNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Z Property

SurfaceNodeResult..::..Z Property
SurfaceNodeResult Class See Also Send Feedback
Z defines the global coordinate where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Z { get; }

See Also

SurfaceNodeResult Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceNodeResultEnvelope Class

SurfaceNodeResultEnvelope Class
Members See Also Send Feedback
Represents result value of specified type for given node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SurfaceNodeResultEnvelope : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..SurfaceNodeResultEnvelope

See Also

SurfaceNodeResultEnvelope Members
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceNodeResultEnvelope Members

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceNodeResultEnvelope Members
SurfaceNodeResultEnvelope Class Methods Properties See Also Send Feedback

The SurfaceNodeResultEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | MaxValue | Maximal value for node.
Public property | MinValue | Minimal value for node.
Public property | ResultType | Type of result.
Public property | X | X defines the global coordinate where the results are specified.
Public property | Y | Y defines the global coordinate where the results are specified.
Public property | Z | Z defines the global coordinate where the results are specified.

See Also

SurfaceNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceNodeResultEnvelope Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceNodeResultEnvelope Methods
SurfaceNodeResultEnvelope Class See Also Send Feedback

The SurfaceNodeResultEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SurfaceNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceNodeResultEnvelope Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceNodeResultEnvelope Properties
SurfaceNodeResultEnvelope Class See Also Send Feedback

The SurfaceNodeResultEnvelope type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | MaxValue | Maximal value for node.
Public property | MinValue | Minimal value for node.
Public property | ResultType | Type of result.
Public property | X | X defines the global coordinate where the results are specified.
Public property | Y | Y defines the global coordinate where the results are specified.
Public property | Z | Z defines the global coordinate where the results are specified.

See Also

SurfaceNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


MaxValue Property

SurfaceNodeResultEnvelope..::..MaxValue Property
SurfaceNodeResultEnvelope Class See Also Send Feedback
Maximal value for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double MaxValue { get; }

See Also

SurfaceNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


MinValue Property

SurfaceNodeResultEnvelope..::..MinValue Property
SurfaceNodeResultEnvelope Class See Also Send Feedback
Minimal value for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double MinValue { get; }

See Also

SurfaceNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


ResultType Property

SurfaceNodeResultEnvelope..::..ResultType Property
SurfaceNodeResultEnvelope Class See Also Send Feedback
Type of result.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceResultType ResultType { get; }

See Also

SurfaceNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


X Property

SurfaceNodeResultEnvelope..::..X Property
SurfaceNodeResultEnvelope Class See Also Send Feedback
X defines the global coordinate where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double X { get; }

See Also

SurfaceNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Y Property

SurfaceNodeResultEnvelope..::..Y Property
SurfaceNodeResultEnvelope Class See Also Send Feedback
Y defines the global coordinate where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Y { get; }

See Also

SurfaceNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


Z Property

SurfaceNodeResultEnvelope..::..Z Property
SurfaceNodeResultEnvelope Class See Also Send Feedback
Z defines the global coordinate where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Z { get; }

See Also

SurfaceNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace


SurfaceResultType Enumeration

SurfaceResultType Enumeration
See Also Send Feedback
Defines a standard types of analytical results for planar elements like slabs and walls.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SurfaceResultType

Members

Member name | Value | Description
Unknown | 0 | Unknown planar result type
Mxx | 1 | Mxx moment
Myy | 2 | Myy moment
Mxy | 3 | Mxy moment
Fxx | 4 | Fxx membrane force
Fyy | 5 | Fyy membrane force
Fxy | 6 | Fxy membrane force
UX | 7 | UX displacement in global coordinates
UY | 8 | UY displacement in global coordinates
UZ | 9 | UZ displacement in global coordinates
RX | 10 | RX rotation in global coordinates
RY | 11 | RY rotation in global coordinates
RZ | 12 | RZ rotation in global coordinates
Qxx | 13 | Qxx shear force
Qyy | 14 | Qyy shear force
K | 15 | K soil reaction, derivative result
AxxTop | 16 | Top required main reinforcement
AxxBottom | 17 | Bottom required main reinforcement
AyyTop | 18 | Top required perpendicular reinforcement
AyyBottom | 19 | Bottom required perpendicular reinforcement
Sxx | 20 | Sxx stress
Syy | 21 | Syy stress
Sxy | 22 | Sxy stress
Txx | 23 | Txx shear stress
Tyy | 24 | Tyy shear stress
ReactionMX | 25 | Reaction MX
ReactionMY | 26 | Reaction MY
ReactionMZ | 27 | Reaction MZ
ReactionFX | 28 | Reaction FX
ReactionFY | 29 | Reaction FY
ReactionFZ | 30 | Reaction FZ

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace


UnitsSystem Enumeration

UnitsSystem Enumeration
See Also Send Feedback
Defines the set of units that is used by default for the resuts.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum UnitsSystem

Members

Member name | Value | Description
Unknown | 0 | Unknown
Imperial | 1 | Imperial
Metric | 2 | Metric

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace


Autodesk.Revit.DB.ResultsBuilder.Storage Namespace

Autodesk.Revit.DB.ResultsBuilder.Storage Namespace
Send Feedback

Classes

 | Class | Description
Public class | BarNodeResults | Defines a set of reactions in the specified point along the linear element like beam or column.
Public class | BarPointProperties | BarPointProperties class is used to define properties of tapered sections.
Public class | BarPointResults | Defines a set of standard results in the calculation point along the linear element like beam or column.
Public class | BarProperties | Defines a set of properties that are used for calculating derivative results.
Public class | BarResultsBase | BarResultsBase is a base class for definition of results for linear elements.
Public class | BarResultsByPoints | Defines the set of analytical results for linear element that is interpreted as diagram drawn between given points. Values must be defined in local coordinate system of analytical model.
Public class | BarResultsInNodes | Defines a list of reactions on linear element. Values must be defined in local coordinate system of analytical model.
Public class | BarTaperedProperties | Set of properties of tapered section.
Public class | ResultsPackageBuilder | ResultsPackageBuilder class is used to create the Analysis object.
Public class | SurfaceNodeResults | Defines a set of reactions in the calculation point contained in the surface element like floor or wall.
Public class | SurfacePointResults | Defines a set of standard results in the calculation point contained in the surface element like floor or wall.
Public class | SurfaceProperties | Defines a set of properties that are used for calculating derivative results.
Public class | SurfaceResults | Defines a set of results for surface.


BarNodeResults Class

BarNodeResults Class
Members See Also Send Feedback
Defines a set of reactions in the specified point along the linear element like beam or column.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarNodeResults

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarNodeResults

See Also

BarNodeResults Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarNodeResults Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarNodeResults Members
BarNodeResults Class Constructors Methods Properties See Also Send Feedback

The BarNodeResults type exposes the following members.

Constructors

 | Name | Description
Public method | BarNodeResults | Initializes a new set of results for bar's calculation point.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ReactionFx | Reaction along x-axis
Public property | ReactionFy | Reaction along y-axis
Public property | ReactionFz | Reaction along z-axis
Public property | ReactionMx | Reaction around x-axis
Public property | ReactionMy | Reactionaround y-axis
Public property | ReactionMz | Reactionaround z-axis
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarNodeResults Constructor

BarNodeResults Constructor
BarNodeResults Class See Also Send Feedback
Initializes a new set of results for bar's calculation point.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public BarNodeResults(
    double x
)

Parameters

x
Type: System..::..Double
Distance from the bar's start point, where the results are specified, measured in meters.

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarNodeResults Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BarNodeResults Methods
BarNodeResults Class See Also Send Feedback

The BarNodeResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarNodeResults Properties

[image]

Structural Analysis and Code Checking API Reference Guide
BarNodeResults Properties
BarNodeResults Class See Also Send Feedback

The BarNodeResults type exposes the following members.

Properties

 | Name | Description
Public property | ReactionFx | Reaction along x-axis
Public property | ReactionFy | Reaction along y-axis
Public property | ReactionFz | Reaction along z-axis
Public property | ReactionMx | Reaction around x-axis
Public property | ReactionMy | Reactionaround y-axis
Public property | ReactionMz | Reactionaround z-axis
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionFx Property

BarNodeResults..::..ReactionFx Property
BarNodeResults Class See Also Send Feedback
Reaction along x-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionFx { get; set; }

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionFy Property

BarNodeResults..::..ReactionFy Property
BarNodeResults Class See Also Send Feedback
Reaction along y-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionFy { get; set; }

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionFz Property

BarNodeResults..::..ReactionFz Property
BarNodeResults Class See Also Send Feedback
Reaction along z-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionFz { get; set; }

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionMx Property

BarNodeResults..::..ReactionMx Property
BarNodeResults Class See Also Send Feedback
Reaction around x-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionMx { get; set; }

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionMy Property

BarNodeResults..::..ReactionMy Property
BarNodeResults Class See Also Send Feedback
Reactionaround y-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionMy { get; set; }

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionMz Property

BarNodeResults..::..ReactionMz Property
BarNodeResults Class See Also Send Feedback
Reactionaround z-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionMz { get; set; }

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


X Property

BarNodeResults..::..X Property
BarNodeResults Class See Also Send Feedback
X defines the coordinate (distance from the bar's start point) where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double X { get; }

See Also

BarNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarPointProperties Class

BarPointProperties Class
Members See Also Send Feedback
BarPointProperties class is used to define properties of tapered sections.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarPointProperties : BarProperties

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarProperties
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarPointProperties

See Also

BarPointProperties Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarPointProperties Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarPointProperties Members
BarPointProperties Class Constructors Methods Properties See Also Send Feedback

The BarPointProperties type exposes the following members.

Constructors

 | Name | Description
Public method | BarPointProperties | Initializes a new set of section properties for bar's calculation point.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Ax | Cross section area (Inherited from BarProperties.)
Public property | Iy | Moment of inertia about the Y axis (Inherited from BarProperties.)
Public property | Iz | Moment of inertia about the Z axis (Inherited from BarProperties.)
Public property | Ky | Ky elastic ground coefficient (Inherited from BarProperties.)
Public property | Kz | Kz elastic ground coefficient (Inherited from BarProperties.)
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarPointProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarPointProperties Constructor

BarPointProperties Constructor
BarPointProperties Class See Also Send Feedback
Initializes a new set of section properties for bar's calculation point.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public BarPointProperties(
    double x
)

Parameters

x
Type: System..::..Double
Distance from the bar's start point, where the properties are specified, measured in meters.

See Also

BarPointProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarPointProperties Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BarPointProperties Methods
BarPointProperties Class See Also Send Feedback

The BarPointProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarPointProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarPointProperties Properties

[image]

Structural Analysis and Code Checking API Reference Guide
BarPointProperties Properties
BarPointProperties Class See Also Send Feedback

The BarPointProperties type exposes the following members.

Properties

 | Name | Description
Public property | Ax | Cross section area (Inherited from BarProperties.)
Public property | Iy | Moment of inertia about the Y axis (Inherited from BarProperties.)
Public property | Iz | Moment of inertia about the Z axis (Inherited from BarProperties.)
Public property | Ky | Ky elastic ground coefficient (Inherited from BarProperties.)
Public property | Kz | Kz elastic ground coefficient (Inherited from BarProperties.)
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarPointProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


X Property

BarPointProperties..::..X Property
BarPointProperties Class See Also Send Feedback
X defines the coordinate (distance from the bar's start point) where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double X { get; }

See Also

BarPointProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarPointResults Class

BarPointResults Class
Members See Also Send Feedback
Defines a set of standard results in the calculation point along the linear element like beam or column.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarPointResults : PointResults

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..PointResults
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarPointResults

See Also

BarPointResults Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarPointResults Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarPointResults Members
BarPointResults Class Constructors Methods Properties See Also Send Feedback

The BarPointResults type exposes the following members.

Constructors

 | Name | Description
Public method | BarPointResults | Initializes a new set of results for bar's calculation point.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fx | Force along x-axis (Inherited from PointResults.)
Public property | Fy | Force along y-axis (Inherited from PointResults.)
Public property | Fz | Force along z-axis (Inherited from PointResults.)
Public property | Mx | Moment around x-axis (Inherited from PointResults.)
Public property | My | Moment around y-axis (Inherited from PointResults.)
Public property | Mz | Moment around z-axis (Inherited from PointResults.)
Public property | Rx | Rotation around x-axis (Inherited from PointResults.)
Public property | Ry | Rotation around y-axis (Inherited from PointResults.)
Public property | Rz | Rotation around z-axis (Inherited from PointResults.)
Public property | SFx | S (Fx), axial stress
Public property | Smax | S max, maximum normal stress
Public property | SmaxMy | S max (My), maximum bending stress for moment My
Public property | SmaxMz | S max (Mz), maximum bending stress for moment Mz
Public property | Smin | S min, minimum normal stress
Public property | SminMy | S min (My), minimum bending stress for moment My
Public property | SminMz | S min (Mz), minimum bending stress for moment Mz
Public property | Ux | Displacement along x-axis (Inherited from PointResults.)
Public property | Uy | Displacement along y-axis (Inherited from PointResults.)
Public property | Uz | Displacement along z-axis (Inherited from PointResults.)
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarPointResults Constructor

BarPointResults Constructor
BarPointResults Class See Also Send Feedback
Initializes a new set of results for bar's calculation point.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public BarPointResults(
    double x
)

Parameters

x
Type: System..::..Double
Distance from the bar's start point, where the results are specified, measured in meters.

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarPointResults Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BarPointResults Methods
BarPointResults Class See Also Send Feedback

The BarPointResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarPointResults Properties

[image]

Structural Analysis and Code Checking API Reference Guide
BarPointResults Properties
BarPointResults Class See Also Send Feedback

The BarPointResults type exposes the following members.

Properties

 | Name | Description
Public property | Fx | Force along x-axis (Inherited from PointResults.)
Public property | Fy | Force along y-axis (Inherited from PointResults.)
Public property | Fz | Force along z-axis (Inherited from PointResults.)
Public property | Mx | Moment around x-axis (Inherited from PointResults.)
Public property | My | Moment around y-axis (Inherited from PointResults.)
Public property | Mz | Moment around z-axis (Inherited from PointResults.)
Public property | Rx | Rotation around x-axis (Inherited from PointResults.)
Public property | Ry | Rotation around y-axis (Inherited from PointResults.)
Public property | Rz | Rotation around z-axis (Inherited from PointResults.)
Public property | SFx | S (Fx), axial stress
Public property | Smax | S max, maximum normal stress
Public property | SmaxMy | S max (My), maximum bending stress for moment My
Public property | SmaxMz | S max (Mz), maximum bending stress for moment Mz
Public property | Smin | S min, minimum normal stress
Public property | SminMy | S min (My), minimum bending stress for moment My
Public property | SminMz | S min (Mz), minimum bending stress for moment Mz
Public property | Ux | Displacement along x-axis (Inherited from PointResults.)
Public property | Uy | Displacement along y-axis (Inherited from PointResults.)
Public property | Uz | Displacement along z-axis (Inherited from PointResults.)
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SFx Property

BarPointResults..::..SFx Property
BarPointResults Class See Also Send Feedback
S (Fx), axial stress

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> SFx { get; set; }

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Smax Property

BarPointResults..::..Smax Property
BarPointResults Class See Also Send Feedback
S max, maximum normal stress

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Smax { get; set; }

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SmaxMy Property

BarPointResults..::..SmaxMy Property
BarPointResults Class See Also Send Feedback
S max (My), maximum bending stress for moment My

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> SmaxMy { get; set; }

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SmaxMz Property

BarPointResults..::..SmaxMz Property
BarPointResults Class See Also Send Feedback
S max (Mz), maximum bending stress for moment Mz

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> SmaxMz { get; set; }

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Smin Property

BarPointResults..::..Smin Property
BarPointResults Class See Also Send Feedback
S min, minimum normal stress

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Smin { get; set; }

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SminMy Property

BarPointResults..::..SminMy Property
BarPointResults Class See Also Send Feedback
S min (My), minimum bending stress for moment My

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> SminMy { get; set; }

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SminMz Property

BarPointResults..::..SminMz Property
BarPointResults Class See Also Send Feedback
S min (Mz), minimum bending stress for moment Mz

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> SminMz { get; set; }

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


X Property

BarPointResults..::..X Property
BarPointResults Class See Also Send Feedback
X defines the coordinate (distance from the bar's start point) where the results are specified.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double X { get; }

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarProperties Class

BarProperties Class
Members See Also Send Feedback
Defines a set of properties that are used for calculating derivative results.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarProperties

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarProperties
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarPointProperties

See Also

BarProperties Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarProperties Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarProperties Members
BarProperties Class Constructors Methods Properties See Also Send Feedback

The BarProperties type exposes the following members.

Constructors

 | Name | Description
Public method | BarProperties | Initializes a new instance of the BarProperties class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Ax | Cross section area
Public property | Iy | Moment of inertia about the Y axis
Public property | Iz | Moment of inertia about the Z axis
Public property | Ky | Ky elastic ground coefficient
Public property | Kz | Kz elastic ground coefficient

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarProperties Constructor

BarProperties Constructor
BarProperties Class See Also Send Feedback
Initializes a new instance of the BarProperties class

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public BarProperties()

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarProperties Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BarProperties Methods
BarProperties Class See Also Send Feedback

The BarProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarProperties Properties

[image]

Structural Analysis and Code Checking API Reference Guide
BarProperties Properties
BarProperties Class See Also Send Feedback

The BarProperties type exposes the following members.

Properties

 | Name | Description
Public property | Ax | Cross section area
Public property | Iy | Moment of inertia about the Y axis
Public property | Iz | Moment of inertia about the Z axis
Public property | Ky | Ky elastic ground coefficient
Public property | Kz | Kz elastic ground coefficient

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Ax Property

BarProperties..::..Ax Property
BarProperties Class See Also Send Feedback
Cross section area

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Ax { get; set; }

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Iy Property

BarProperties..::..Iy Property
BarProperties Class See Also Send Feedback
Moment of inertia about the Y axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Iy { get; set; }

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Iz Property

BarProperties..::..Iz Property
BarProperties Class See Also Send Feedback
Moment of inertia about the Z axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Iz { get; set; }

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Ky Property

BarProperties..::..Ky Property
BarProperties Class See Also Send Feedback
Ky elastic ground coefficient

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Ky { get; set; }

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Kz Property

BarProperties..::..Kz Property
BarProperties Class See Also Send Feedback
Kz elastic ground coefficient

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Kz { get; set; }

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsBase Class

BarResultsBase Class
Members See Also Send Feedback
BarResultsBase is a base class for definition of results for linear elements.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarResultsBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarResultsBase
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarResultsByPoints
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarResultsInNodes

See Also

BarResultsBase Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsBase Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarResultsBase Members
BarResultsBase Class Constructors Methods See Also Send Feedback

The BarResultsBase type exposes the following members.

Constructors

 | Name | Description
Public method | BarResultsBase | Initializes a new instance of the BarResultsBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarResultsBase Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsBase Constructor

BarResultsBase Constructor
BarResultsBase Class See Also Send Feedback
Initializes a new instance of the BarResultsBase class

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public BarResultsBase()

See Also

BarResultsBase Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsBase Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BarResultsBase Methods
BarResultsBase Class See Also Send Feedback

The BarResultsBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarResultsBase Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsByPoints Class

BarResultsByPoints Class
Members See Also Send Feedback
Defines the set of analytical results for linear element that is interpreted as diagram drawn between given points. Values must be defined in local coordinate system of analytical model.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarResultsByPoints : BarResultsBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarResultsBase
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarResultsByPoints

See Also

BarResultsByPoints Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsByPoints Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarResultsByPoints Members
BarResultsByPoints Class Constructors Methods See Also Send Feedback

The BarResultsByPoints type exposes the following members.

Constructors

 | Name | Description
Public method | BarResultsByPoints | Initializes a new instance of BarResultsByPoints that is empty and has the specified initial capacity.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarResultsByPoints Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsByPoints Constructor

BarResultsByPoints Constructor
BarResultsByPoints Class See Also Send Feedback
Initializes a new instance of BarResultsByPoints that is empty and has the specified initial capacity.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public BarResultsByPoints(
    IEnumerable<BarPointResults> resultPoints
)

Parameters

resultPoints
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BarPointResults >)>)>

See Also

BarResultsByPoints Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsByPoints Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BarResultsByPoints Methods
BarResultsByPoints Class See Also Send Feedback

The BarResultsByPoints type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarResultsByPoints Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsInNodes Class

BarResultsInNodes Class
Members See Also Send Feedback
Defines a list of reactions on linear element. Values must be defined in local coordinate system of analytical model.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarResultsInNodes : BarResultsBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarResultsBase
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarResultsInNodes

See Also

BarResultsInNodes Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsInNodes Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarResultsInNodes Members
BarResultsInNodes Class Constructors Methods See Also Send Feedback

The BarResultsInNodes type exposes the following members.

Constructors

 | Name | Description
Public method | BarResultsInNodes | Initializes a new instance of BarResultsByPoints that is empty and has the specified initial capacity.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarResultsInNodes Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsInNodes Constructor

BarResultsInNodes Constructor
BarResultsInNodes Class See Also Send Feedback
Initializes a new instance of BarResultsByPoints that is empty and has the specified initial capacity.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public BarResultsInNodes(
    IEnumerable<BarNodeResults> resultPoints
)

Parameters

resultPoints
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BarNodeResults >)>)>

See Also

BarResultsInNodes Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarResultsInNodes Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BarResultsInNodes Methods
BarResultsInNodes Class See Also Send Feedback

The BarResultsInNodes type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarResultsInNodes Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarTaperedProperties Class

BarTaperedProperties Class
Members See Also Send Feedback
Set of properties of tapered section.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarTaperedProperties

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarTaperedProperties

See Also

BarTaperedProperties Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarTaperedProperties Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarTaperedProperties Members
BarTaperedProperties Class Constructors Methods See Also Send Feedback

The BarTaperedProperties type exposes the following members.

Constructors

 | Name | Description
Public method | BarTaperedProperties | Creates properties of tapered section.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarTaperedProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarTaperedProperties Constructor

BarTaperedProperties Constructor
BarTaperedProperties Class See Also Send Feedback
Creates properties of tapered section.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public BarTaperedProperties(
    ICollection<BarPointProperties> properties
)

Parameters

properties
Type: System.Collections.Generic..::..ICollection <(Of <(<' BarPointProperties >)>)>

See Also

BarTaperedProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


BarTaperedProperties Methods

[image]

Structural Analysis and Code Checking API Reference Guide
BarTaperedProperties Methods
BarTaperedProperties Class See Also Send Feedback

The BarTaperedProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarTaperedProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ResultsPackageBuilder Class

ResultsPackageBuilder Class
Members See Also Send Feedback
ResultsPackageBuilder class is used to create the Analysis object.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ResultsPackageBuilder

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..ResultsPackageBuilder

See Also

ResultsPackageBuilder Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ResultsPackageBuilder Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackageBuilder Members
ResultsPackageBuilder Class Methods See Also Send Feedback

The ResultsPackageBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddMeasurement(String, MeasurementResultType, UnitType, DisplayUnitType) | Obsolete. Obsolete, use the same function with full parameter list.
Public method | AddMeasurement(String, MeasurementResultType, UnitType, DisplayUnitType, MeasurementDependencyType) | AddMeasurement method creates the additional type of results. It allows to define types of results that are not standard within the static analysis scope. The Name and measurementResultType pair must be unique in the package.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Finish | Finishes buildings of analyses package and returns newly created ResultsPackage object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetAnalysisInfo | Sets the Analysis Info of package.
Public method | SetAnalysisName | Sets the Analysis Name of package.
Public method | SetArbitraryResult | Function sets specified arbitrary result.
Public method | SetBarResult(ElementId, ElementId, DomainResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified bar results.
Public method | SetBarResult(ElementId, ElementId, LinearResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified bar results.
Public method | SetBarResult(ElementId, ElementId, String, IEnumerable<(Of <<'(Double>)>>)) | Obsolete. Function sets specified bar results.
Public method | SetBarResults | Function sets bar results.
Public method | SetBarSectionProperties | Sets the properties of analytical linear element, that were used for analysis. This set of properties will be used for derivative results calculations.
Public method | SetCreationTime | Sets the creation time of package.
Public method | SetDescription | Sets the Decsription of package.
Public method | SetDesignOptionId | Sets the design option id for which the analysis was performed.
Public method | SetModelId | Sets the Model Guid of package.
Public method | SetModelInfo | Sets the Model Info of package.
Public method | SetModelName | Sets the Model Name of package.
Public method | SetNodeResult | Function sets specified arbitrary result for node.
Public method | SetNodeResults | Sets node results for element.
Public method | SetPassword | Set password to protect package against modifying.
Public method | SetPhaseId | Sets the phase id for which the analysis was performed.
Public method | SetProviderName | Sets the Provider Name of package.
Public method | SetResultsStatus | Sets results status.
Public method | SetStoreyResults | Sets results for storey.
Public method | SetSurfaceResult(ElementId, ElementId, DomainResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified surface results.
Public method | SetSurfaceResult(ElementId, ElementId, SurfaceResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified surface results.
Public method | SetSurfaceResults(ElementId, ElementId, SurfaceResults) | Sets forces for surface element.
Public method | SetSurfaceResults(ElementId, ElementId, ICollection<(Of <<'(SurfaceNodeResults>)>>)) | Sets forces for surface element.
Public method | SetSurfaceSectionProperties | Sets the properties of analytical surface element, that were used for analysis. This set of properties will be used for derivative results calculations.
Public method | SetVendorDescription | Sets the Vendor Description of package.
Public method | SetVendorId | Sets the Vendor Id of package.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ResultsPackageBuilder Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackageBuilder Methods
ResultsPackageBuilder Class See Also Send Feedback

The ResultsPackageBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddMeasurement(String, MeasurementResultType, UnitType, DisplayUnitType) | Obsolete. Obsolete, use the same function with full parameter list.
Public method | AddMeasurement(String, MeasurementResultType, UnitType, DisplayUnitType, MeasurementDependencyType) | AddMeasurement method creates the additional type of results. It allows to define types of results that are not standard within the static analysis scope. The Name and measurementResultType pair must be unique in the package.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Finish | Finishes buildings of analyses package and returns newly created ResultsPackage object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetAnalysisInfo | Sets the Analysis Info of package.
Public method | SetAnalysisName | Sets the Analysis Name of package.
Public method | SetArbitraryResult | Function sets specified arbitrary result.
Public method | SetBarResult(ElementId, ElementId, DomainResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified bar results.
Public method | SetBarResult(ElementId, ElementId, LinearResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified bar results.
Public method | SetBarResult(ElementId, ElementId, String, IEnumerable<(Of <<'(Double>)>>)) | Obsolete. Function sets specified bar results.
Public method | SetBarResults | Function sets bar results.
Public method | SetBarSectionProperties | Sets the properties of analytical linear element, that were used for analysis. This set of properties will be used for derivative results calculations.
Public method | SetCreationTime | Sets the creation time of package.
Public method | SetDescription | Sets the Decsription of package.
Public method | SetDesignOptionId | Sets the design option id for which the analysis was performed.
Public method | SetModelId | Sets the Model Guid of package.
Public method | SetModelInfo | Sets the Model Info of package.
Public method | SetModelName | Sets the Model Name of package.
Public method | SetNodeResult | Function sets specified arbitrary result for node.
Public method | SetNodeResults | Sets node results for element.
Public method | SetPassword | Set password to protect package against modifying.
Public method | SetPhaseId | Sets the phase id for which the analysis was performed.
Public method | SetProviderName | Sets the Provider Name of package.
Public method | SetResultsStatus | Sets results status.
Public method | SetStoreyResults | Sets results for storey.
Public method | SetSurfaceResult(ElementId, ElementId, DomainResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified surface results.
Public method | SetSurfaceResult(ElementId, ElementId, SurfaceResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified surface results.
Public method | SetSurfaceResults(ElementId, ElementId, SurfaceResults) | Sets forces for surface element.
Public method | SetSurfaceResults(ElementId, ElementId, ICollection<(Of <<'(SurfaceNodeResults>)>>)) | Sets forces for surface element.
Public method | SetSurfaceSectionProperties | Sets the properties of analytical surface element, that were used for analysis. This set of properties will be used for derivative results calculations.
Public method | SetVendorDescription | Sets the Vendor Description of package.
Public method | SetVendorId | Sets the Vendor Id of package.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


AddMeasurement Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackageBuilder..::..AddMeasurement Method
ResultsPackageBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMeasurement(String, MeasurementResultType, UnitType, DisplayUnitType) | Obsolete. Obsolete, use the same function with full parameter list.
Public method | AddMeasurement(String, MeasurementResultType, UnitType, DisplayUnitType, MeasurementDependencyType) | AddMeasurement method creates the additional type of results. It allows to define types of results that are not standard within the static analysis scope. The Name and measurementResultType pair must be unique in the package.

See Also

ResultsPackageBuilder Class
ResultsPackageBuilder Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


AddMeasurement Method (String, MeasurementResultType, , )

ResultsPackageBuilder..::..AddMeasurement Method (String, MeasurementResultType, , )
ResultsPackageBuilder Class See Also Send Feedback
Obsolete, use the same function with full parameter list.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[ObsoleteAttribute("Use the same function with full parameter list.")]
public void AddMeasurement(
    string name,
    MeasurementResultType measurementResultType,
    UnitType unitType,
    DisplayUnitType displayUnitType
)

Parameters

name
Type: System..::..String
measurementResultType
Type: Autodesk.Revit.DB.ResultsBuilder..::..MeasurementResultType
unitType
Type: UnitType
displayUnitType
Type: DisplayUnitType

See Also

ResultsPackageBuilder Class
AddMeasurement Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


AddMeasurement Method (String, MeasurementResultType, , , MeasurementDependencyType)

ResultsPackageBuilder..::..AddMeasurement Method (String, MeasurementResultType, , , MeasurementDependencyType)
ResultsPackageBuilder Class See Also Send Feedback
AddMeasurement method creates the additional type of results. It allows to define types of results that are not standard within the static analysis scope. The Name and measurementResultType pair must be unique in the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddMeasurement(
    string name,
    MeasurementResultType measurementResultType,
    UnitType unitType,
    DisplayUnitType displayUnitType,
    MeasurementDependencyType dependencyType
)

Parameters

name
Type: System..::..String
measurementResultType
Type: Autodesk.Revit.DB.ResultsBuilder..::..MeasurementResultType
unitType
Type: UnitType
displayUnitType
Type: DisplayUnitType
dependencyType
Type: Autodesk.Revit.DB.ResultsBuilder..::..MeasurementDependencyType

Exceptions

Exception | Condition
ArgumentException | MeasurementResultType of specified Name and measurementResultType already exists.

See Also

ResultsPackageBuilder Class
AddMeasurement Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Finish Method

ResultsPackageBuilder..::..Finish Method
ResultsPackageBuilder Class See Also Send Feedback
Finishes buildings of analyses package and returns newly created ResultsPackage object.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackage Finish()

Exceptions

Exception | Condition
InvalidOperationException | Results package already finished.

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetAnalysisInfo Method

ResultsPackageBuilder..::..SetAnalysisInfo Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the Analysis Info of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetAnalysisInfo(
    string analysisInfo
)

Parameters

analysisInfo
Type: System..::..String

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetAnalysisName Method

ResultsPackageBuilder..::..SetAnalysisName Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the Analysis Name of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetAnalysisName(
    string analysisName
)

Parameters

analysisName
Type: System..::..String

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetArbitraryResult Method

ResultsPackageBuilder..::..SetArbitraryResult Method
ResultsPackageBuilder Class See Also Send Feedback
Function sets specified arbitrary result.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetArbitraryResult(
    ElementId elementId,
    ElementId loadId,
    string measurementName,
    IEnumerable<double> values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
measurementName
Type: System..::..String
values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>

Exceptions

Exception | Condition
InvalidOperationException | Domain not defined yet.
ArgumentException | Specified measurementName doesn't exist.
ArgumentException | Measurement of name 'measurementName' is load case dependent. The loadId parameter can not be null.

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetBarResult Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackageBuilder..::..SetBarResult Method
ResultsPackageBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBarResult(ElementId, ElementId, DomainResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified bar results.
Public method | SetBarResult(ElementId, ElementId, LinearResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified bar results.
Public method | SetBarResult(ElementId, ElementId, String, IEnumerable<(Of <<'(Double>)>>)) | Obsolete. Function sets specified bar results.

See Also

ResultsPackageBuilder Class
ResultsPackageBuilder Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetBarResult Method (, , DomainResultType, IEnumerable(Double))

ResultsPackageBuilder..::..SetBarResult Method (, , DomainResultType, IEnumerable<(Of <(<'Double>)>)>)
ResultsPackageBuilder Class See Also Send Feedback
Function sets specified bar results.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetBarResult(
    ElementId elementId,
    ElementId loadId,
    DomainResultType resultType,
    IEnumerable<double> values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
resultType
Type: Autodesk.Revit.DB.ResultsBuilder..::..DomainResultType
values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>

Exceptions

Exception | Condition
ArgumentException | Specified measurementName doesn't exist.

See Also

ResultsPackageBuilder Class
SetBarResult Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetBarResult Method (, , LinearResultType, IEnumerable(Double))

ResultsPackageBuilder..::..SetBarResult Method (, , LinearResultType, IEnumerable<(Of <(<'Double>)>)>)
ResultsPackageBuilder Class See Also Send Feedback
Function sets specified bar results.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetBarResult(
    ElementId elementId,
    ElementId loadId,
    LinearResultType resultType,
    IEnumerable<double> values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
resultType
Type: Autodesk.Revit.DB.ResultsBuilder..::..LinearResultType
values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>

Exceptions

Exception | Condition
InvalidOperationException | Domain not defined yet.
ArgumentException | Specified measurementName doesn't exist.

See Also

ResultsPackageBuilder Class
SetBarResult Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetBarResult Method (, , String, IEnumerable(Double))

ResultsPackageBuilder..::..SetBarResult Method (, , String, IEnumerable<(Of <(<'Double>)>)>)
ResultsPackageBuilder Class See Also Send Feedback
Function sets specified bar results.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[ObsoleteAttribute("Use SetArbitraryResult instead.")]
public void SetBarResult(
    ElementId elementId,
    ElementId loadId,
    string measurementName,
    IEnumerable<double> values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
measurementName
Type: System..::..String
values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>

Exceptions

Exception | Condition
InvalidOperationException | Domain not defined yet.
ArgumentException | Specified measurementName doesn't exist.

See Also

ResultsPackageBuilder Class
SetBarResult Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetBarResults Method

ResultsPackageBuilder..::..SetBarResults Method
ResultsPackageBuilder Class See Also Send Feedback
Function sets bar results.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetBarResults(
    ElementId elementId,
    ElementId loadId,
    BarResultsBase values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
values
Type: Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarResultsBase

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetBarSectionProperties Method

ResultsPackageBuilder..::..SetBarSectionProperties Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the properties of analytical linear element, that were used for analysis. This set of properties will be used for derivative results calculations.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetBarSectionProperties(
    ElementId elementId,
    BarProperties properties
)

Parameters

elementId
Type: ElementId
properties
Type: Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarProperties

Exceptions

Exception | Condition
[t:ArgumentException] | An element with specified elementId have already properties defined.

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetCreationTime Method

ResultsPackageBuilder..::..SetCreationTime Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the creation time of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetCreationTime(
    DateTimeOffset creationTime
)

Parameters

creationTime
Type: System..::..DateTimeOffset

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetDescription Method

ResultsPackageBuilder..::..SetDescription Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the Decsription of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetDescription(
    string description
)

Parameters

description
Type: System..::..String

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetDesignOptionId Method

ResultsPackageBuilder..::..SetDesignOptionId Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the design option id for which the analysis was performed.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetDesignOptionId(
    ElementId designOptionId
)

Parameters

designOptionId
Type: ElementId

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetModelId Method

ResultsPackageBuilder..::..SetModelId Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the Model Guid of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetModelId(
    Guid id
)

Parameters

id
Type: System..::..Guid

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetModelInfo Method

ResultsPackageBuilder..::..SetModelInfo Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the Model Info of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetModelInfo(
    string modelInfo
)

Parameters

modelInfo
Type: System..::..String

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetModelName Method

ResultsPackageBuilder..::..SetModelName Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the Model Name of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetModelName(
    string modelName
)

Parameters

modelName
Type: System..::..String

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetNodeResult Method

ResultsPackageBuilder..::..SetNodeResult Method
ResultsPackageBuilder Class See Also Send Feedback
Function sets specified arbitrary result for node.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetNodeResult(
    ElementId elementId,
    ElementId loadId,
    string measurementName,
    XYZ values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
measurementName
Type: System..::..String
values
Type: XYZ

Exceptions

Exception | Condition
ArgumentException | Specified measurementName doesn't exist.
ArgumentException | Measurement of name 'measurementName' is load case dependent. The loadId parameter can not be null.

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetNodeResults Method

ResultsPackageBuilder..::..SetNodeResults Method
ResultsPackageBuilder Class See Also Send Feedback
Sets node results for element.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetNodeResults(
    ElementId elementId,
    ElementId loadId,
    NodeResults result
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
result
Type: Autodesk.Revit.DB.ResultsBuilder..::..NodeResults

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetPassword Method

ResultsPackageBuilder..::..SetPassword Method
ResultsPackageBuilder Class See Also Send Feedback
Set password to protect package against modifying.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetPassword(
    string password
)

Parameters

password
Type: System..::..String

Exceptions

Exception | Condition
InvalidOperationException | Password cannot be changed.

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetPhaseId Method

ResultsPackageBuilder..::..SetPhaseId Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the phase id for which the analysis was performed.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetPhaseId(
    ElementId phaseId
)

Parameters

phaseId
Type: ElementId

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetProviderName Method

ResultsPackageBuilder..::..SetProviderName Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the Provider Name of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetProviderName(
    string providerName
)

Parameters

providerName
Type: System..::..String

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetResultsStatus Method

ResultsPackageBuilder..::..SetResultsStatus Method
ResultsPackageBuilder Class See Also Send Feedback
Sets results status.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetResultsStatus(
    ResultsStatus value
)

Parameters

value
Type: Autodesk.Revit.DB.ResultsBuilder..::..ResultsStatus

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetStoreyResults Method

ResultsPackageBuilder..::..SetStoreyResults Method
ResultsPackageBuilder Class See Also Send Feedback
Sets results for storey.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetStoreyResults(
    ElementId levelId,
    ElementId loadCaseId,
    StoreyResults results
)

Parameters

levelId
Type: ElementId
loadCaseId
Type: ElementId
results
Type: StoreyResults

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetSurfaceResult Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackageBuilder..::..SetSurfaceResult Method
ResultsPackageBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetSurfaceResult(ElementId, ElementId, DomainResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified surface results.
Public method | SetSurfaceResult(ElementId, ElementId, SurfaceResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified surface results.

See Also

ResultsPackageBuilder Class
ResultsPackageBuilder Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetSurfaceResult Method (, , DomainResultType, IEnumerable(Double))

ResultsPackageBuilder..::..SetSurfaceResult Method (, , DomainResultType, IEnumerable<(Of <(<'Double>)>)>)
ResultsPackageBuilder Class See Also Send Feedback
Function sets specified surface results.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetSurfaceResult(
    ElementId elementId,
    ElementId loadId,
    DomainResultType resultType,
    IEnumerable<double> values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
resultType
Type: Autodesk.Revit.DB.ResultsBuilder..::..DomainResultType
values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>

Exceptions

Exception | Condition
ArgumentException | Specified measurementName doesn't exist.

See Also

ResultsPackageBuilder Class
SetSurfaceResult Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetSurfaceResult Method (, , SurfaceResultType, IEnumerable(Double))

ResultsPackageBuilder..::..SetSurfaceResult Method (, , SurfaceResultType, IEnumerable<(Of <(<'Double>)>)>)
ResultsPackageBuilder Class See Also Send Feedback
Function sets specified surface results.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetSurfaceResult(
    ElementId elementId,
    ElementId loadId,
    SurfaceResultType resultType,
    IEnumerable<double> values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
resultType
Type: Autodesk.Revit.DB.ResultsBuilder..::..SurfaceResultType
values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>

Exceptions

Exception | Condition
InvalidOperationException | Domain not defined yet.
ArgumentException | Specified measurementName doesn't exist.

See Also

ResultsPackageBuilder Class
SetSurfaceResult Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetSurfaceResults Method

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackageBuilder..::..SetSurfaceResults Method
ResultsPackageBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetSurfaceResults(ElementId, ElementId, SurfaceResults) | Sets forces for surface element.
Public method | SetSurfaceResults(ElementId, ElementId, ICollection<(Of <<'(SurfaceNodeResults>)>>)) | Sets forces for surface element.

See Also

ResultsPackageBuilder Class
ResultsPackageBuilder Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetSurfaceResults Method (, , SurfaceResults)

ResultsPackageBuilder..::..SetSurfaceResults Method (, , SurfaceResults)
ResultsPackageBuilder Class See Also Send Feedback
Sets forces for surface element.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetSurfaceResults(
    ElementId elementId,
    ElementId loadId,
    SurfaceResults values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
values
Type: Autodesk.Revit.DB.ResultsBuilder.Storage..::..SurfaceResults

See Also

ResultsPackageBuilder Class
SetSurfaceResults Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetSurfaceResults Method (, , ICollection(SurfaceNodeResults))

ResultsPackageBuilder..::..SetSurfaceResults Method (, , ICollection<(Of <(<'SurfaceNodeResults>)>)>)
ResultsPackageBuilder Class See Also Send Feedback
Sets forces for surface element.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetSurfaceResults(
    ElementId elementId,
    ElementId loadId,
    ICollection<SurfaceNodeResults> points
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
points
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfaceNodeResults >)>)>

See Also

ResultsPackageBuilder Class
SetSurfaceResults Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetSurfaceSectionProperties Method

ResultsPackageBuilder..::..SetSurfaceSectionProperties Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the properties of analytical surface element, that were used for analysis. This set of properties will be used for derivative results calculations.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetSurfaceSectionProperties(
    ElementId elementId,
    SurfaceProperties properties
)

Parameters

elementId
Type: ElementId
properties
Type: Autodesk.Revit.DB.ResultsBuilder.Storage..::..SurfaceProperties

Exceptions

Exception | Condition
[t:ArgumentException] | An element with specified elementId have already properties defined.

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetVendorDescription Method

ResultsPackageBuilder..::..SetVendorDescription Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the Vendor Description of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetVendorDescription(
    string vendorDescription
)

Parameters

vendorDescription
Type: System..::..String

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SetVendorId Method

ResultsPackageBuilder..::..SetVendorId Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the Vendor Id of package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetVendorId(
    string vendorId
)

Parameters

vendorId
Type: System..::..String

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceNodeResults Class

SurfaceNodeResults Class
Members See Also Send Feedback
Defines a set of reactions in the calculation point contained in the surface element like floor or wall.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SurfaceNodeResults

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..SurfaceNodeResults

See Also

SurfaceNodeResults Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceNodeResults Members

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceNodeResults Members
SurfaceNodeResults Class Constructors Methods Properties See Also Send Feedback

The SurfaceNodeResults type exposes the following members.

Constructors

 | Name | Description
Public method | SurfaceNodeResults | Initializes a new set of results for surface calculation point.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ReactionFx | Reaction along x-axis
Public property | ReactionFy | Reaction along y-axis
Public property | ReactionFz | Reaction along z-axis
Public property | ReactionMx | Reaction around x-axis
Public property | ReactionMy | Reactionaround y-axis
Public property | ReactionMz | Reactionaround z-axis
Public property | X | X value in global coordinates, measured in meters
Public property | Y | Y value in global coordinates, measured in meters
Public property | Z | Z value in global coordinates, measured in meters

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceNodeResults Constructor

SurfaceNodeResults Constructor
SurfaceNodeResults Class See Also Send Feedback
Initializes a new set of results for surface calculation point.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceNodeResults(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::..Double
Coordinate of the point in global coordinates, measured in domain units.
y
Type: System..::..Double
Coordinate of the point in global coordinates, measured in domain units.
z
Type: System..::..Double
Coordinate of the point in global coordinates, measured in domain units.

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceNodeResults Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceNodeResults Methods
SurfaceNodeResults Class See Also Send Feedback

The SurfaceNodeResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceNodeResults Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceNodeResults Properties
SurfaceNodeResults Class See Also Send Feedback

The SurfaceNodeResults type exposes the following members.

Properties

 | Name | Description
Public property | ReactionFx | Reaction along x-axis
Public property | ReactionFy | Reaction along y-axis
Public property | ReactionFz | Reaction along z-axis
Public property | ReactionMx | Reaction around x-axis
Public property | ReactionMy | Reactionaround y-axis
Public property | ReactionMz | Reactionaround z-axis
Public property | X | X value in global coordinates, measured in meters
Public property | Y | Y value in global coordinates, measured in meters
Public property | Z | Z value in global coordinates, measured in meters

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionFx Property

SurfaceNodeResults..::..ReactionFx Property
SurfaceNodeResults Class See Also Send Feedback
Reaction along x-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionFx { get; set; }

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionFy Property

SurfaceNodeResults..::..ReactionFy Property
SurfaceNodeResults Class See Also Send Feedback
Reaction along y-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionFy { get; set; }

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionFz Property

SurfaceNodeResults..::..ReactionFz Property
SurfaceNodeResults Class See Also Send Feedback
Reaction along z-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionFz { get; set; }

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionMx Property

SurfaceNodeResults..::..ReactionMx Property
SurfaceNodeResults Class See Also Send Feedback
Reaction around x-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionMx { get; set; }

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionMy Property

SurfaceNodeResults..::..ReactionMy Property
SurfaceNodeResults Class See Also Send Feedback
Reactionaround y-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionMy { get; set; }

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


ReactionMz Property

SurfaceNodeResults..::..ReactionMz Property
SurfaceNodeResults Class See Also Send Feedback
Reactionaround z-axis

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> ReactionMz { get; set; }

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


X Property

SurfaceNodeResults..::..X Property
SurfaceNodeResults Class See Also Send Feedback
X value in global coordinates, measured in meters

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double X { get; }

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Y Property

SurfaceNodeResults..::..Y Property
SurfaceNodeResults Class See Also Send Feedback
Y value in global coordinates, measured in meters

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Y { get; }

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Z Property

SurfaceNodeResults..::..Z Property
SurfaceNodeResults Class See Also Send Feedback
Z value in global coordinates, measured in meters

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Z { get; }

See Also

SurfaceNodeResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfacePointResults Class

SurfacePointResults Class
Members See Also Send Feedback
Defines a set of standard results in the calculation point contained in the surface element like floor or wall.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SurfacePointResults

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..SurfacePointResults

See Also

SurfacePointResults Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfacePointResults Members

[image]

Structural Analysis and Code Checking API Reference Guide
SurfacePointResults Members
SurfacePointResults Class Constructors Methods Properties See Also Send Feedback

The SurfacePointResults type exposes the following members.

Constructors

 | Name | Description
Public method | SurfacePointResults | Initializes a new set of results for surface's calculation point.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fxx | Force Fxx
Public property | Fxy | Force Fxy
Public property | Fyy | Force Fyy
Public property | Mxx | Moment Mxx
Public property | Mxy | Moment Mxy
Public property | Myy | Moment Myy
Public property | Qxx | Qxx shear force
Public property | Qyy | Qyy shear force
Public property | RX | Rotation RX in global coordinates
Public property | RY | Rotation RY in global coordinates
Public property | RZ | Rotation RZ in global coordinates
Public property | Sxx | Sxx stress
Public property | Sxy | Sxy stress
Public property | Syy | Syy stress
Public property | Txx | Txx shear stress
Public property | Tyy | Tyy shear stress
Public property | UX | Displacement UX in global coordinates
Public property | UY | Displacement UY in global coordinates
Public property | UZ | Displacement UZ in global coordinates
Public property | X | X value in global coordinates, measured in meters
Public property | Y | Y value in global coordinates, measured in meters
Public property | Z | Z value in global coordinates, measured in meters

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfacePointResults Constructor

SurfacePointResults Constructor
SurfacePointResults Class See Also Send Feedback
Initializes a new set of results for surface's calculation point.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfacePointResults(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::..Double
Coordinate of the point in global coordinates, measured in domain units.
y
Type: System..::..Double
Coordinate of the point in global coordinates, measured in domain units.
z
Type: System..::..Double
Coordinate of the point in global coordinates, measured in domain units.

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfacePointResults Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SurfacePointResults Methods
SurfacePointResults Class See Also Send Feedback

The SurfacePointResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfacePointResults Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SurfacePointResults Properties
SurfacePointResults Class See Also Send Feedback

The SurfacePointResults type exposes the following members.

Properties

 | Name | Description
Public property | Fxx | Force Fxx
Public property | Fxy | Force Fxy
Public property | Fyy | Force Fyy
Public property | Mxx | Moment Mxx
Public property | Mxy | Moment Mxy
Public property | Myy | Moment Myy
Public property | Qxx | Qxx shear force
Public property | Qyy | Qyy shear force
Public property | RX | Rotation RX in global coordinates
Public property | RY | Rotation RY in global coordinates
Public property | RZ | Rotation RZ in global coordinates
Public property | Sxx | Sxx stress
Public property | Sxy | Sxy stress
Public property | Syy | Syy stress
Public property | Txx | Txx shear stress
Public property | Tyy | Tyy shear stress
Public property | UX | Displacement UX in global coordinates
Public property | UY | Displacement UY in global coordinates
Public property | UZ | Displacement UZ in global coordinates
Public property | X | X value in global coordinates, measured in meters
Public property | Y | Y value in global coordinates, measured in meters
Public property | Z | Z value in global coordinates, measured in meters

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Fxx Property

SurfacePointResults..::..Fxx Property
SurfacePointResults Class See Also Send Feedback
Force Fxx

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Fxx { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Fxy Property

SurfacePointResults..::..Fxy Property
SurfacePointResults Class See Also Send Feedback
Force Fxy

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Fxy { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Fyy Property

SurfacePointResults..::..Fyy Property
SurfacePointResults Class See Also Send Feedback
Force Fyy

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Fyy { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Mxx Property

SurfacePointResults..::..Mxx Property
SurfacePointResults Class See Also Send Feedback
Moment Mxx

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Mxx { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Mxy Property

SurfacePointResults..::..Mxy Property
SurfacePointResults Class See Also Send Feedback
Moment Mxy

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Mxy { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Myy Property

SurfacePointResults..::..Myy Property
SurfacePointResults Class See Also Send Feedback
Moment Myy

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Myy { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Qxx Property

SurfacePointResults..::..Qxx Property
SurfacePointResults Class See Also Send Feedback
Qxx shear force

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Qxx { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Qyy Property

SurfacePointResults..::..Qyy Property
SurfacePointResults Class See Also Send Feedback
Qyy shear force

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Qyy { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


RX Property

SurfacePointResults..::..RX Property
SurfacePointResults Class See Also Send Feedback
Rotation RX in global coordinates

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> RX { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


RY Property

SurfacePointResults..::..RY Property
SurfacePointResults Class See Also Send Feedback
Rotation RY in global coordinates

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> RY { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


RZ Property

SurfacePointResults..::..RZ Property
SurfacePointResults Class See Also Send Feedback
Rotation RZ in global coordinates

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> RZ { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Sxx Property

SurfacePointResults..::..Sxx Property
SurfacePointResults Class See Also Send Feedback
Sxx stress

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Sxx { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Sxy Property

SurfacePointResults..::..Sxy Property
SurfacePointResults Class See Also Send Feedback
Sxy stress

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Sxy { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Syy Property

SurfacePointResults..::..Syy Property
SurfacePointResults Class See Also Send Feedback
Syy stress

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Syy { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Txx Property

SurfacePointResults..::..Txx Property
SurfacePointResults Class See Also Send Feedback
Txx shear stress

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Txx { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Tyy Property

SurfacePointResults..::..Tyy Property
SurfacePointResults Class See Also Send Feedback
Tyy shear stress

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> Tyy { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


UX Property

SurfacePointResults..::..UX Property
SurfacePointResults Class See Also Send Feedback
Displacement UX in global coordinates

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> UX { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


UY Property

SurfacePointResults..::..UY Property
SurfacePointResults Class See Also Send Feedback
Displacement UY in global coordinates

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> UY { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


UZ Property

SurfacePointResults..::..UZ Property
SurfacePointResults Class See Also Send Feedback
Displacement UZ in global coordinates

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Nullable<double> UZ { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


X Property

SurfacePointResults..::..X Property
SurfacePointResults Class See Also Send Feedback
X value in global coordinates, measured in meters

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double X { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Y Property

SurfacePointResults..::..Y Property
SurfacePointResults Class See Also Send Feedback
Y value in global coordinates, measured in meters

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Y { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Z Property

SurfacePointResults..::..Z Property
SurfacePointResults Class See Also Send Feedback
Z value in global coordinates, measured in meters

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Z { get; set; }

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceProperties Class

SurfaceProperties Class
Members See Also Send Feedback
Defines a set of properties that are used for calculating derivative results.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SurfaceProperties

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..SurfaceProperties

See Also

SurfaceProperties Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceProperties Members

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceProperties Members
SurfaceProperties Class Constructors Methods Properties See Also Send Feedback

The SurfaceProperties type exposes the following members.

Constructors

 | Name | Description
Public method | SurfaceProperties | Initializes a new instance of the SurfaceProperties class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | H | H thickness
Public property | Kz | Kz elastic ground coefficient

See Also

SurfaceProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceProperties Constructor

SurfaceProperties Constructor
SurfaceProperties Class See Also Send Feedback
Initializes a new instance of the SurfaceProperties class

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceProperties()

See Also

SurfaceProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceProperties Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceProperties Methods
SurfaceProperties Class See Also Send Feedback

The SurfaceProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SurfaceProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceProperties Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceProperties Properties
SurfaceProperties Class See Also Send Feedback

The SurfaceProperties type exposes the following members.

Properties

 | Name | Description
Public property | H | H thickness
Public property | Kz | Kz elastic ground coefficient

See Also

SurfaceProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


H Property

SurfaceProperties..::..H Property
SurfaceProperties Class See Also Send Feedback
H thickness

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double H { get; set; }

See Also

SurfaceProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Kz Property

SurfaceProperties..::..Kz Property
SurfaceProperties Class See Also Send Feedback
Kz elastic ground coefficient

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double Kz { get; set; }

See Also

SurfaceProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceResults Class

SurfaceResults Class
Members See Also Send Feedback
Defines a set of results for surface.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SurfaceResults

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..SurfaceResults

See Also

SurfaceResults Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceResults Members

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceResults Members
SurfaceResults Class Constructors Methods See Also Send Feedback

The SurfaceResults type exposes the following members.

Constructors

 | Name | Description
Public method | SurfaceResults(ICollection<(Of <<'(SurfacePointResults>)>>)) | Initializes new SurfaceResults object
Public method | SurfaceResults(ICollection<(Of <<'(SurfacePointResults>)>>), Transform) | Initializes new SurfaceResults object
Public method | SurfaceResults(ICollection<(Of <<'(SurfacePointResults>)>>), XYZ) | Obsolete. Initializes new SurfaceResults object

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SurfaceResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceResults Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceResults Constructor
SurfaceResults Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SurfaceResults(ICollection<(Of <<'(SurfacePointResults>)>>)) | Initializes new SurfaceResults object
Public method | SurfaceResults(ICollection<(Of <<'(SurfacePointResults>)>>), Transform) | Initializes new SurfaceResults object
Public method | SurfaceResults(ICollection<(Of <<'(SurfacePointResults>)>>), XYZ) | Obsolete. Initializes new SurfaceResults object

See Also

SurfaceResults Class
SurfaceResults Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceResults Constructor (ICollection(SurfacePointResults))

SurfaceResults Constructor (ICollection<(Of <(<'SurfacePointResults>)>)>)
SurfaceResults Class See Also Send Feedback
Initializes new SurfaceResults object

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceResults(
    ICollection<SurfacePointResults> values
)

Parameters

values
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfacePointResults >)>)>
List of results in all points of the surface. Results must be defined in local coordinate system of analytical model.

See Also

SurfaceResults Class
SurfaceResults Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceResults Constructor (ICollection(SurfacePointResults), )

SurfaceResults Constructor (ICollection<(Of <(<'SurfacePointResults>)>)>, )
SurfaceResults Class See Also Send Feedback
Initializes new SurfaceResults object

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SurfaceResults(
    ICollection<SurfacePointResults> values,
    Transform localCoordinateSystem
)

Parameters

values
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfacePointResults >)>)>
List of results in all points of the surface.
localCoordinateSystem
Type: Transform
Transformation defining the axes of the coordinate system in which the results are presented. Origin is ignored.

See Also

SurfaceResults Class
SurfaceResults Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceResults Constructor (ICollection(SurfacePointResults), )

SurfaceResults Constructor (ICollection<(Of <(<'SurfacePointResults>)>)>, )
SurfaceResults Class See Also Send Feedback
Initializes new SurfaceResults object

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[ObsoleteAttribute("Use SurfaceResults that defines the local coordinate system")]
public SurfaceResults(
    ICollection<SurfacePointResults> values,
    XYZ directionX
)

Parameters

values
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfacePointResults >)>)>
List of results in all points of the surface.
directionX
Type: XYZ
Vector defining the X-axis of the coordinate system in which the results are presented.

See Also

SurfaceResults Class
SurfaceResults Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


SurfaceResults Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceResults Methods
SurfaceResults Class See Also Send Feedback

The SurfaceResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SurfaceResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace


Autodesk.Revit.UI.CodeChecking Namespace

Autodesk.Revit.UI.CodeChecking Namespace
Send Feedback

Classes

 | Class | Description
Public class | MultiStructureServer | The base class for all servers that support more than one category or material.
Public class | Server<(Of <(<'TCalculationParam, TLabel>)>)> | Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform.
Public class | ServiceUI | Helper service for UI layer.

Interfaces

 | Interface | Description
Public interface | ICodeCheckingServerUI | Base interface for code checking UI servers.


ICodeCheckingServerUI Interface

ICodeCheckingServerUI Interface
Members See Also Send Feedback
Base interface for code checking UI servers.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ICodeCheckingServerUI : IServerUI,
    IResource

See Also

ICodeCheckingServerUI Members
Autodesk.Revit.UI.CodeChecking Namespace


ICodeCheckingServerUI Members

[image]

Structural Analysis and Code Checking API Reference Guide
ICodeCheckingServerUI Members
ICodeCheckingServerUI Interface Methods See Also Send Feedback

The ICodeCheckingServerUI type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamsLayout | Builds the layout.
Public method | BuildLabelLayout | Builds the layout.
Public method | GetDataSource | Gets the data source of the specific key. (Inherited from IServerUI.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource. (Inherited from IResource.)
Public method | GetResourceImage | Gets the image resource. (Inherited from IResource.)
Public method | LayoutInitialized | Informs the server that layout was initialized (Inherited from IServerUI.)
Public method | ValueChanged | Informs the server that value changed. (Inherited from IServerUI.)

See Also

ICodeCheckingServerUI Interface
Autodesk.Revit.UI.CodeChecking Namespace


ICodeCheckingServerUI Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ICodeCheckingServerUI Methods
ICodeCheckingServerUI Interface See Also Send Feedback

The ICodeCheckingServerUI type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamsLayout | Builds the layout.
Public method | BuildLabelLayout | Builds the layout.
Public method | GetDataSource | Gets the data source of the specific key. (Inherited from IServerUI.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource. (Inherited from IResource.)
Public method | GetResourceImage | Gets the image resource. (Inherited from IResource.)
Public method | LayoutInitialized | Informs the server that layout was initialized (Inherited from IServerUI.)
Public method | ValueChanged | Informs the server that value changed. (Inherited from IServerUI.)

See Also

ICodeCheckingServerUI Interface
Autodesk.Revit.UI.CodeChecking Namespace


BuildCalculationParamsLayout Method

ICodeCheckingServerUI..::..BuildCalculationParamsLayout Method
ICodeCheckingServerUI Interface See Also Send Feedback
Builds the layout.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Layout BuildCalculationParamsLayout(
    Schema schema,
    Document document
)

Parameters

schema
Type: Schema
The schema.
document
Type: Document
The document.

Return Value

The structure of layout.

See Also

ICodeCheckingServerUI Interface
Autodesk.Revit.UI.CodeChecking Namespace


BuildLabelLayout Method

ICodeCheckingServerUI..::..BuildLabelLayout Method
ICodeCheckingServerUI Interface See Also Send Feedback
Builds the layout.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Layout BuildLabelLayout(
    Schema schema,
    Document document
)

Parameters

schema
Type: Schema
The schema.
document
Type: Document
The document.

Return Value

The structure of layout.

See Also

ICodeCheckingServerUI Interface
Autodesk.Revit.UI.CodeChecking Namespace


GetHelp Method

ICodeCheckingServerUI..::..GetHelp Method
ICodeCheckingServerUI Interface See Also Send Feedback
Gets the help.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
string GetHelp(
    string cultureInfo
)

Parameters

cultureInfo
Type: System..::..String
The culture info.

Return Value

See Also

ICodeCheckingServerUI Interface
Autodesk.Revit.UI.CodeChecking Namespace


MultiStructureServer Class

MultiStructureServer Class
Members See Also Send Feedback
The base class for all servers that support more than one category or material.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class MultiStructureServer : ICodeCheckingServerUI,
    IServerUI, IResource

Remarks

It is strongly connected with DataStructurAttributes:ResultStructureAttribute, LabelStructureAttribute, CalculationParamsStructureAttribute

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.CodeChecking..::..MultiStructureServer

See Also

MultiStructureServer Members
Autodesk.Revit.UI.CodeChecking Namespace


MultiStructureServer Members

[image]

Structural Analysis and Code Checking API Reference Guide
MultiStructureServer Members
MultiStructureServer Class Methods See Also Send Feedback

The MultiStructureServer type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamsLayout | Builds the layout.
Public method | BuildLabelLayout | Builds the layout.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataSource | Gets the data source of the specific key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource.
Public method | GetResourceImage | Gets the image resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutInitialized | Informs the server that layout was initialized
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValueChanged | Informs the server that value changed.

See Also

MultiStructureServer Class
Autodesk.Revit.UI.CodeChecking Namespace


MultiStructureServer Methods

[image]

Structural Analysis and Code Checking API Reference Guide
MultiStructureServer Methods
MultiStructureServer Class See Also Send Feedback

The MultiStructureServer type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamsLayout | Builds the layout.
Public method | BuildLabelLayout | Builds the layout.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataSource | Gets the data source of the specific key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource.
Public method | GetResourceImage | Gets the image resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutInitialized | Informs the server that layout was initialized
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValueChanged | Informs the server that value changed.

See Also

MultiStructureServer Class
Autodesk.Revit.UI.CodeChecking Namespace


BuildCalculationParamsLayout Method

MultiStructureServer..::..BuildCalculationParamsLayout Method
MultiStructureServer Class See Also Send Feedback
Builds the layout.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Layout BuildCalculationParamsLayout(
    Schema schema,
    Document document
)

Parameters

schema
Type: Schema
The schema.
document
Type: Document
The document.

Return Value

The structure of layout.

Implements

ICodeCheckingServerUI..::..BuildCalculationParamsLayout(Schema, Document)

See Also

MultiStructureServer Class
Autodesk.Revit.UI.CodeChecking Namespace


BuildLabelLayout Method

MultiStructureServer..::..BuildLabelLayout Method
MultiStructureServer Class See Also Send Feedback
Builds the layout.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Layout BuildLabelLayout(
    Schema schema,
    Document document
)

Parameters

schema
Type: Schema
The schema.
document
Type: Document
The document.

Return Value

The structure of layout.

Implements

ICodeCheckingServerUI..::..BuildLabelLayout(Schema, Document)

See Also

MultiStructureServer Class
Autodesk.Revit.UI.CodeChecking Namespace


GetDataSource Method

MultiStructureServer..::..GetDataSource Method
MultiStructureServer Class See Also Send Feedback
Gets the data source of the specific key.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual IList GetDataSource(
    string key,
    Document document,
    DisplayUnitType unitType
)

Parameters

key
Type: System..::..String
The key of data source.
document
Type: Document
The document.
unitType
Type: DisplayUnitType

Return Value

The data source of list type.

Implements

IServerUI..::..GetDataSource(String, Document, DisplayUnitType)

See Also

MultiStructureServer Class
Autodesk.Revit.UI.CodeChecking Namespace


GetHelp Method

MultiStructureServer..::..GetHelp Method
MultiStructureServer Class See Also Send Feedback
Gets the help.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual string GetHelp(
    string cultureInfo
)

Parameters

cultureInfo
Type: System..::..String
The culture info.

Return Value

Implements

ICodeCheckingServerUI..::..GetHelp(String)

See Also

MultiStructureServer Class
Autodesk.Revit.UI.CodeChecking Namespace


GetResource Method

MultiStructureServer..::..GetResource Method
MultiStructureServer Class See Also Send Feedback
Gets the text resource.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual string GetResource(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

The text resource.

Implements

IResource..::..GetResource(String, String)

See Also

MultiStructureServer Class
Autodesk.Revit.UI.CodeChecking Namespace


GetResourceImage Method

MultiStructureServer..::..GetResourceImage Method
MultiStructureServer Class See Also Send Feedback
Gets the image resource.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Uri GetResourceImage(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

The image resource.

See Also

MultiStructureServer Class
Autodesk.Revit.UI.CodeChecking Namespace


LayoutInitialized Method

MultiStructureServer..::..LayoutInitialized Method
MultiStructureServer Class See Also Send Feedback
Informs the server that layout was initialized

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void LayoutInitialized(
    Object sender,
    LayoutInitializedEventArgs e
)

Parameters

sender
Type: System..::..Object
e
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..LayoutInitializedEventArgs

Implements

IServerUI..::..LayoutInitialized(Object, LayoutInitializedEventArgs)

See Also

MultiStructureServer Class
Autodesk.Revit.UI.CodeChecking Namespace


ValueChanged Method

MultiStructureServer..::..ValueChanged Method
MultiStructureServer Class See Also Send Feedback
Informs the server that value changed.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void ValueChanged(
    Object sender,
    ValueChangedEventArgs e
)

Parameters

sender
Type: System..::..Object
e
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ValueChangedEventArgs

Implements

IServerUI..::..ValueChanged(Object, ValueChangedEventArgs)

See Also

MultiStructureServer Class
Autodesk.Revit.UI.CodeChecking Namespace


Server(TCalculationParam, TLabel) Class

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Members See Also Send Feedback
Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Server<TCalculationParam, TLabel> : ICodeCheckingServerUI,
    IServerUI, IResource
where TCalculationParam : new(), SchemaClass
where TLabel : new(), SchemaClass

Type Parameters

TCalculationParam
The class representing calculation parameters.
TLabel
The class representing labels.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.CodeChecking..::..Server<(Of <(<'TCalculationParam, TLabel>)>)>

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Members
Autodesk.Revit.UI.CodeChecking Namespace


Server(TCalculationParam, TLabel) Members

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TCalculationParam, TLabel>)>)> Members
Server<(Of <(<'TCalculationParam, TLabel>)>)> Class Methods See Also Send Feedback

The Server<(Of <(<'TCalculationParam, TLabel>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamsLayout | Builds the layout.
Public method | BuildLabelLayout | Builds the layout.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataSource | Gets the data source of the specific key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource.
Public method | GetResourceImage | Gets the image resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutInitialized | Informs the server that layout was initialized
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValueChanged | Informs the server that value changed.

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Autodesk.Revit.UI.CodeChecking Namespace


Server(TCalculationParam, TLabel) Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TCalculationParam, TLabel>)>)> Methods
Server<(Of <(<'TCalculationParam, TLabel>)>)> Class See Also Send Feedback

The Server<(Of <(<'TCalculationParam, TLabel>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamsLayout | Builds the layout.
Public method | BuildLabelLayout | Builds the layout.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataSource | Gets the data source of the specific key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource.
Public method | GetResourceImage | Gets the image resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutInitialized | Informs the server that layout was initialized
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValueChanged | Informs the server that value changed.

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Autodesk.Revit.UI.CodeChecking Namespace


BuildCalculationParamsLayout Method

Server<(Of <(<'TCalculationParam, TLabel>)>)>..::..BuildCalculationParamsLayout Method
Server<(Of <(<'TCalculationParam, TLabel>)>)> Class See Also Send Feedback
Builds the layout.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Layout BuildCalculationParamsLayout(
    Schema schema,
    Document document
)

Parameters

schema
Type: Schema
The schema.
document
Type: Document
The document.

Return Value

The structure of layout.

Implements

ICodeCheckingServerUI..::..BuildCalculationParamsLayout(Schema, Document)

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Autodesk.Revit.UI.CodeChecking Namespace


BuildLabelLayout Method

Server<(Of <(<'TCalculationParam, TLabel>)>)>..::..BuildLabelLayout Method
Server<(Of <(<'TCalculationParam, TLabel>)>)> Class See Also Send Feedback
Builds the layout.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Layout BuildLabelLayout(
    Schema schema,
    Document document
)

Parameters

schema
Type: Schema
The schema.
document
Type: Document
The document.

Return Value

The structure of layout.

Implements

ICodeCheckingServerUI..::..BuildLabelLayout(Schema, Document)

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Autodesk.Revit.UI.CodeChecking Namespace


GetDataSource Method

Server<(Of <(<'TCalculationParam, TLabel>)>)>..::..GetDataSource Method
Server<(Of <(<'TCalculationParam, TLabel>)>)> Class See Also Send Feedback
Gets the data source of the specific key.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual IList GetDataSource(
    string key,
    Document document,
    DisplayUnitType unitType
)

Parameters

key
Type: System..::..String
The key of data source.
document
Type: Document
The document.
unitType
Type: DisplayUnitType

Return Value

The data source of list type.

Implements

IServerUI..::..GetDataSource(String, Document, DisplayUnitType)

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Autodesk.Revit.UI.CodeChecking Namespace


GetHelp Method

Server<(Of <(<'TCalculationParam, TLabel>)>)>..::..GetHelp Method
Server<(Of <(<'TCalculationParam, TLabel>)>)> Class See Also Send Feedback
Gets the help.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual string GetHelp(
    string cultureInfo
)

Parameters

cultureInfo
Type: System..::..String
The culture info.

Return Value

Implements

ICodeCheckingServerUI..::..GetHelp(String)

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Autodesk.Revit.UI.CodeChecking Namespace


GetResource Method

Server<(Of <(<'TCalculationParam, TLabel>)>)>..::..GetResource Method
Server<(Of <(<'TCalculationParam, TLabel>)>)> Class See Also Send Feedback
Gets the text resource.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual string GetResource(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

The text resource.

Implements

IResource..::..GetResource(String, String)

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Autodesk.Revit.UI.CodeChecking Namespace


GetResourceImage Method

Server<(Of <(<'TCalculationParam, TLabel>)>)>..::..GetResourceImage Method
Server<(Of <(<'TCalculationParam, TLabel>)>)> Class See Also Send Feedback
Gets the image resource.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Uri GetResourceImage(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

The image resource.

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Autodesk.Revit.UI.CodeChecking Namespace


LayoutInitialized Method

Server<(Of <(<'TCalculationParam, TLabel>)>)>..::..LayoutInitialized Method
Server<(Of <(<'TCalculationParam, TLabel>)>)> Class See Also Send Feedback
Informs the server that layout was initialized

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void LayoutInitialized(
    Object sender,
    LayoutInitializedEventArgs e
)

Parameters

sender
Type: System..::..Object
e
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..LayoutInitializedEventArgs

Implements

IServerUI..::..LayoutInitialized(Object, LayoutInitializedEventArgs)

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Autodesk.Revit.UI.CodeChecking Namespace


ValueChanged Method

Server<(Of <(<'TCalculationParam, TLabel>)>)>..::..ValueChanged Method
Server<(Of <(<'TCalculationParam, TLabel>)>)> Class See Also Send Feedback
Informs the server that value changed.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void ValueChanged(
    Object sender,
    ValueChangedEventArgs e
)

Parameters

sender
Type: System..::..Object
e
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ValueChangedEventArgs

Implements

IServerUI..::..ValueChanged(Object, ValueChangedEventArgs)

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Autodesk.Revit.UI.CodeChecking Namespace


ServiceUI Class

ServiceUI Class
Members See Also Send Feedback
Helper service for UI layer.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServiceUI

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.CodeChecking..::..ServiceUI

See Also

ServiceUI Members
Autodesk.Revit.UI.CodeChecking Namespace


ServiceUI Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceUI Members
ServiceUI Class Constructors Methods See Also Send Feedback

The ServiceUI type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceUI | Initializes a new instance of the ServiceUI class

Methods

 | Name | Description
 | BindUIServerWithDBServer | Binds input UI server with particular DB server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetServerUI | Returns UI server assigned to particular DB server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceUI Class
Autodesk.Revit.UI.CodeChecking Namespace


ServiceUI Constructor

ServiceUI Constructor
ServiceUI Class See Also Send Feedback
Initializes a new instance of the ServiceUI class

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServiceUI()

See Also

ServiceUI Class
Autodesk.Revit.UI.CodeChecking Namespace


ServiceUI Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceUI Methods
ServiceUI Class See Also Send Feedback

The ServiceUI type exposes the following members.

Methods

 | Name | Description
 | BindUIServerWithDBServer | Binds input UI server with particular DB server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetServerUI | Returns UI server assigned to particular DB server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceUI Class
Autodesk.Revit.UI.CodeChecking Namespace


BindUIServerWithDBServer Method

ServiceUI..::..BindUIServerWithDBServer Method
ServiceUI Class See Also Send Feedback
Binds input UI server with particular DB server.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void BindUIServerWithDBServer(
    Guid dbServerId,
    ICodeCheckingServerUI uiServer
)

Parameters

dbServerId
Type: System..::..Guid
Id of DB server.
uiServer
Type: Autodesk.Revit.UI.CodeChecking..::..ICodeCheckingServerUI
The instance of UI server.

See Also

ServiceUI Class
Autodesk.Revit.UI.CodeChecking Namespace


GetServerUI Method

ServiceUI..::..GetServerUI Method
ServiceUI Class See Also Send Feedback
Returns UI server assigned to particular DB server.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ICodeCheckingServerUI GetServerUI(
    Guid dbServerId
)

Parameters

dbServerId
Type: System..::..Guid
Id of DB server.

Return Value

The instance of UI server.

See Also

ServiceUI Class
Autodesk.Revit.UI.CodeChecking Namespace


Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace

Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace
Send Feedback

Classes

 | Class | Description
Public class | Server<(Of <(<'TData>)>)> | Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by load combination system.
Public class | ServiceUI | Helper service for UI layer.

Interfaces

 | Interface | Description
Public interface | ILoadCombinationServerUI | Base interface for load combinations UI servers.


ILoadCombinationServerUI Interface

ILoadCombinationServerUI Interface
Members See Also Send Feedback
Base interface for load combinations UI servers.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ILoadCombinationServerUI : IServerUI,
    IResource

See Also

ILoadCombinationServerUI Members
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


ILoadCombinationServerUI Members

[image]

Structural Analysis and Code Checking API Reference Guide
ILoadCombinationServerUI Members
ILoadCombinationServerUI Interface Methods See Also Send Feedback

The ILoadCombinationServerUI type exposes the following members.

Methods

 | Name | Description
Public method | BuildLayout | Builds the layout.
Public method | GetDataSource | Gets the data source of the specific key. (Inherited from IServerUI.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource. (Inherited from IResource.)
Public method | GetResourceImage | Gets the image resource. (Inherited from IResource.)
Public method | LayoutInitialized | Informs the server that layout was initialized (Inherited from IServerUI.)
Public method | ValueChanged | Informs the server that value changed. (Inherited from IServerUI.)

See Also

ILoadCombinationServerUI Interface
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


ILoadCombinationServerUI Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ILoadCombinationServerUI Methods
ILoadCombinationServerUI Interface See Also Send Feedback

The ILoadCombinationServerUI type exposes the following members.

Methods

 | Name | Description
Public method | BuildLayout | Builds the layout.
Public method | GetDataSource | Gets the data source of the specific key. (Inherited from IServerUI.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource. (Inherited from IResource.)
Public method | GetResourceImage | Gets the image resource. (Inherited from IResource.)
Public method | LayoutInitialized | Informs the server that layout was initialized (Inherited from IServerUI.)
Public method | ValueChanged | Informs the server that value changed. (Inherited from IServerUI.)

See Also

ILoadCombinationServerUI Interface
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


BuildLayout Method

ILoadCombinationServerUI..::..BuildLayout Method
ILoadCombinationServerUI Interface See Also Send Feedback
Builds the layout.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Layout BuildLayout(
    Schema schema,
    Document document
)

Parameters

schema
Type: Schema
The schema.
document
Type: Document
The document.

Return Value

The structure of layout.

See Also

ILoadCombinationServerUI Interface
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


GetHelp Method

ILoadCombinationServerUI..::..GetHelp Method
ILoadCombinationServerUI Interface See Also Send Feedback
Gets the help.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
string GetHelp(
    string cultureInfo
)

Parameters

cultureInfo
Type: System..::..String
The culture info.

Return Value

See Also

ILoadCombinationServerUI Interface
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


Server(TData) Class

Server<(Of <(<'TData>)>)> Class
Members See Also Send Feedback
Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by load combination system.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Server<TData> : ILoadCombinationServerUI,
    IServerUI, IResource
where TData : new(), SchemaClass

Type Parameters

TData
The type of the data.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.CodeChecking.LoadCombination..::..Server<(Of <(<'TData>)>)>

See Also

Server<(Of <(<'TData>)>)> Members
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


Server(TData) Members

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TData>)>)> Members
Server<(Of <(<'TData>)>)> Class Methods See Also Send Feedback

The Server<(Of <(<'TData>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | BuildLayout | Builds the layout.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataSource | Gets the data source of the specific key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource.
Public method | GetResourceImage | Gets the image resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutInitialized | Informs the server that layout was initialized
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValueChanged | Informs the server that value changed.

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


Server(TData) Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TData>)>)> Methods
Server<(Of <(<'TData>)>)> Class See Also Send Feedback

The Server<(Of <(<'TData>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | BuildLayout | Builds the layout.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataSource | Gets the data source of the specific key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource.
Public method | GetResourceImage | Gets the image resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutInitialized | Informs the server that layout was initialized
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValueChanged | Informs the server that value changed.

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


BuildLayout Method

Server<(Of <(<'TData>)>)>..::..BuildLayout Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Builds the layout.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Layout BuildLayout(
    Schema schema,
    Document document
)

Parameters

schema
Type: Schema
The schema.
document
Type: Document
The document.

Return Value

The structure of layout.

Implements

ILoadCombinationServerUI..::..BuildLayout(Schema, Document)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


GetDataSource Method

Server<(Of <(<'TData>)>)>..::..GetDataSource Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Gets the data source of the specific key.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual IList GetDataSource(
    string key,
    Document document,
    DisplayUnitType unitType
)

Parameters

key
Type: System..::..String
The key of data source.
document
Type: Document
The document.
unitType
Type: DisplayUnitType

Return Value

The data source of list type.

Implements

IServerUI..::..GetDataSource(String, Document, DisplayUnitType)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


GetHelp Method

Server<(Of <(<'TData>)>)>..::..GetHelp Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Gets the help.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual string GetHelp(
    string cultureInfo
)

Parameters

cultureInfo
Type: System..::..String
The culture info.

Return Value

Implements

ILoadCombinationServerUI..::..GetHelp(String)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


GetResource Method

Server<(Of <(<'TData>)>)>..::..GetResource Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Gets the text resource.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual string GetResource(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

The text resource.

Implements

IResource..::..GetResource(String, String)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


GetResourceImage Method

Server<(Of <(<'TData>)>)>..::..GetResourceImage Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Gets the image resource.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Uri GetResourceImage(
    string key,
    string context
)

Parameters

key
Type: System..::..String
The key.
context
Type: System..::..String
The context.

Return Value

The image resource.

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


LayoutInitialized Method

Server<(Of <(<'TData>)>)>..::..LayoutInitialized Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Informs the server that layout was initialized

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void LayoutInitialized(
    Object sender,
    LayoutInitializedEventArgs e
)

Parameters

sender
Type: System..::..Object
e
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..LayoutInitializedEventArgs

Implements

IServerUI..::..LayoutInitialized(Object, LayoutInitializedEventArgs)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


ValueChanged Method

Server<(Of <(<'TData>)>)>..::..ValueChanged Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Informs the server that value changed.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void ValueChanged(
    Object sender,
    ValueChangedEventArgs e
)

Parameters

sender
Type: System..::..Object
e
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ValueChangedEventArgs

Implements

IServerUI..::..ValueChanged(Object, ValueChangedEventArgs)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


ServiceUI Class

ServiceUI Class
Members See Also Send Feedback
Helper service for UI layer.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ServiceUI

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.CodeChecking.LoadCombination..::..ServiceUI

See Also

ServiceUI Members
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


ServiceUI Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceUI Members
ServiceUI Class Constructors Methods See Also Send Feedback

The ServiceUI type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceUI | Initializes a new instance of the ServiceUI class

Methods

 | Name | Description
 | BindUIServerWithDBServer | Binds input UI server with particular DB server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetServerUI | Returns UI server assigned to particular DB server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceUI Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


ServiceUI Constructor

ServiceUI Constructor
ServiceUI Class See Also Send Feedback
Initializes a new instance of the ServiceUI class

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ServiceUI()

See Also

ServiceUI Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


ServiceUI Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceUI Methods
ServiceUI Class See Also Send Feedback

The ServiceUI type exposes the following members.

Methods

 | Name | Description
 | BindUIServerWithDBServer | Binds input UI server with particular DB server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetServerUI | Returns UI server assigned to particular DB server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceUI Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


BindUIServerWithDBServer Method

ServiceUI..::..BindUIServerWithDBServer Method
ServiceUI Class See Also Send Feedback
Binds input UI server with particular DB server.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void BindUIServerWithDBServer(
    Guid dbServerId,
    ILoadCombinationServerUI uiServer
)

Parameters

dbServerId
Type: System..::..Guid
Id of DB server.
uiServer
Type: Autodesk.Revit.UI.CodeChecking.LoadCombination..::..ILoadCombinationServerUI
The instance of UI server.

See Also

ServiceUI Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


GetServerUI Method

ServiceUI..::..GetServerUI Method
ServiceUI Class See Also Send Feedback
Returns UI server assigned to particular DB server.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ILoadCombinationServerUI GetServerUI(
    Guid dbServerId
)

Parameters

dbServerId
Type: System..::..Guid
Id of DB server.

Return Value

The instance of UI server.

See Also

ServiceUI Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace


Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace

Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace
Send Feedback

Classes

 | Class | Description
Public class | Category | Groups set of controls in one category.
Public class | Control | Base class for all controls.
Public class | DefaultValueQueryEventArgs | Represents arguments for default value query.
Public class | DictionaryItemIdentification | Represents dictionary identification.
Public class | FieldControl | Represents the control for single field.
Public class | Image | Represents image control
Public class | KeyControl | Base class for all controls identified by Key
Public class | Layout | Represents the layout control
Public class | LayoutInitializedEventArgs | Represents arguments for layout initialized event.
Public class | ListItemIdentification | Represents list identification.
Public class | SchemaEditorEventArgs | Main class for schema editor data.
Public class | SubSchemaControl | Represents the subschema control
Public class | SubSchemaListTable | Presents subschema list as table.
Public class | TableCellIdentification | Represents table identification.
Public class | TextBlock | Represents the text block control
Public class | ValueChangedEventArgs | Represents arguments for value changed event.

Interfaces

 | Interface | Description
Public interface | IDefaultValueProvider | Base interface for default value providers.
Public interface | IFieldEditor | Base interface for all field editors
Public interface | IFieldValidator | The base interface for all validation classes.
Public interface | IFieldValueChanged | Base interface for value change observers
Public interface | IFormatAttribute | Represents base interface for format attributes
Public interface | IGridAttribute | Base interface for all grid controls attributes.
Public interface | IGridValueAttribute | Base interface for all grid controls attributes
Public interface | ILayoutControl | Represents base interface for layouts controls
Public interface | ISchemaEditor | Base interface for all controls representing schemas.
Public interface | IServerUI | Base interface for code checking UI servers.
Public interface | ITableEditor | Represents table editor.
Public interface | IValidateAttribute | Base interface for attributes which supports validation

Delegates

 | Delegate | Description
Public delegate | FieldValidation | Describes field validation event.
Public delegate | ValueChangedHandler | Describes field validation event.

Enumerations

 | Enumeration | Description
Public enumeration | ImageSize | Represents standard sizes of image


Category Class

Category Class
Members See Also Send Feedback
Groups set of controls in one category.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Category : Control

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Control
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Category

See Also

Category Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Category Members

[image]

Structural Analysis and Code Checking API Reference Guide
Category Members
Category Class Constructors Methods Properties See Also Send Feedback

The Category type exposes the following members.

Constructors

 | Name | Description
Public method | Category | Initializes a new instance of the Category class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Controls | Gets the list of controls.
Public property | DisplayName | Gets or sets the display name.
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | Name | Gets or sets the name of the category.

See Also

Category Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Category Constructor

Category Constructor
Category Class See Also Send Feedback
Initializes a new instance of the Category class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Category()

See Also

Category Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Category Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Category Methods
Category Class See Also Send Feedback

The Category type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Category Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Category Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Category Properties
Category Class See Also Send Feedback

The Category type exposes the following members.

Properties

 | Name | Description
Public property | Controls | Gets the list of controls.
Public property | DisplayName | Gets or sets the display name.
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | Name | Gets or sets the name of the category.

See Also

Category Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Controls Property

Category..::..Controls Property
Category Class See Also Send Feedback
Gets the list of controls.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Control> Controls { get; private set; }

See Also

Category Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DisplayName Property

Category..::..DisplayName Property
Category Class See Also Send Feedback
Gets or sets the display name.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string DisplayName { get; set; }

Field Value

The display name.

See Also

Category Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Name Property

Category..::..Name Property
Category Class See Also Send Feedback
Gets or sets the name of the category.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Name { get; set; }

Field Value

The name.

See Also

Category Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Control Class

Control Class
Members See Also Send Feedback
Base class for all controls.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Control

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Control
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Category
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..FieldControl
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..KeyControl

See Also

Control Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Control Members

[image]

Structural Analysis and Code Checking API Reference Guide
Control Members
Control Class Methods Properties See Also Send Feedback

The Control type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Gets or sets the index.

See Also

Control Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Control Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Control Methods
Control Class See Also Send Feedback

The Control type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Control Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Control Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Control Properties
Control Class See Also Send Feedback

The Control type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets or sets the index.

See Also

Control Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Index Property

Control..::..Index Property
Control Class See Also Send Feedback
Gets or sets the index.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Index { get; set; }

Field Value

The index.

See Also

Control Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DefaultValueQueryEventArgs Class

DefaultValueQueryEventArgs Class
Members See Also Send Feedback
Represents arguments for default value query.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DefaultValueQueryEventArgs

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..DefaultValueQueryEventArgs

See Also

DefaultValueQueryEventArgs Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DefaultValueQueryEventArgs Members

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultValueQueryEventArgs Members
DefaultValueQueryEventArgs Class Constructors Methods Properties See Also Send Feedback

The DefaultValueQueryEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultValueQueryEventArgs | Initializes a new instance of the ValueChangedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Document | Gets the document.
Public property | Editor | Gets the editor.
Public property | ExpectedUnit | Gets the expected unit.
Public property | FieldEditor | Gets the field editor.
Public property | FieldName | Gets the name of the field.

See Also

DefaultValueQueryEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DefaultValueQueryEventArgs Constructor

DefaultValueQueryEventArgs Constructor
DefaultValueQueryEventArgs Class See Also Send Feedback
Initializes a new instance of the ValueChangedEventArgs class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DefaultValueQueryEventArgs(
    string fieldName,
    IFieldEditor fieldEditor,
    Document document,
    ISchemaEditor editor,
    DisplayUnitType expectedUnit
)

Parameters

fieldName
Type: System..::..String
Name of the field.
fieldEditor
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..IFieldEditor
The field editor.
document
Type: Document
The document.
editor
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ISchemaEditor
The editor.
expectedUnit
Type: DisplayUnitType
The expected unit.

See Also

DefaultValueQueryEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DefaultValueQueryEventArgs Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultValueQueryEventArgs Methods
DefaultValueQueryEventArgs Class See Also Send Feedback

The DefaultValueQueryEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefaultValueQueryEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DefaultValueQueryEventArgs Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultValueQueryEventArgs Properties
DefaultValueQueryEventArgs Class See Also Send Feedback

The DefaultValueQueryEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document.
Public property | Editor | Gets the editor.
Public property | ExpectedUnit | Gets the expected unit.
Public property | FieldEditor | Gets the field editor.
Public property | FieldName | Gets the name of the field.

See Also

DefaultValueQueryEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Document Property

DefaultValueQueryEventArgs..::..Document Property
DefaultValueQueryEventArgs Class See Also Send Feedback
Gets the document.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document Document { get; private set; }

See Also

DefaultValueQueryEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Editor Property

DefaultValueQueryEventArgs..::..Editor Property
DefaultValueQueryEventArgs Class See Also Send Feedback
Gets the editor.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ISchemaEditor Editor { get; private set; }

See Also

DefaultValueQueryEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ExpectedUnit Property

DefaultValueQueryEventArgs..::..ExpectedUnit Property
DefaultValueQueryEventArgs Class See Also Send Feedback
Gets the expected unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType ExpectedUnit { get; private set; }

See Also

DefaultValueQueryEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldEditor Property

DefaultValueQueryEventArgs..::..FieldEditor Property
DefaultValueQueryEventArgs Class See Also Send Feedback
Gets the field editor.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IFieldEditor FieldEditor { get; private set; }

See Also

DefaultValueQueryEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldName Property

DefaultValueQueryEventArgs..::..FieldName Property
DefaultValueQueryEventArgs Class See Also Send Feedback
Gets the name of the field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string FieldName { get; private set; }

Field Value

The name of the field.

See Also

DefaultValueQueryEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DictionaryItemIdentification Class

DictionaryItemIdentification Class
Members See Also Send Feedback
Represents dictionary identification.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DictionaryItemIdentification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..DictionaryItemIdentification

See Also

DictionaryItemIdentification Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DictionaryItemIdentification Members

[image]

Structural Analysis and Code Checking API Reference Guide
DictionaryItemIdentification Members
DictionaryItemIdentification Class Constructors Methods Properties See Also Send Feedback

The DictionaryItemIdentification type exposes the following members.

Constructors

 | Name | Description
Public method | DictionaryItemIdentification | Initializes a new instance of the DictionaryItemIdentification class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets or sets the index.

See Also

DictionaryItemIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DictionaryItemIdentification Constructor

DictionaryItemIdentification Constructor
DictionaryItemIdentification Class See Also Send Feedback
Initializes a new instance of the DictionaryItemIdentification class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DictionaryItemIdentification()

See Also

DictionaryItemIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DictionaryItemIdentification Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DictionaryItemIdentification Methods
DictionaryItemIdentification Class See Also Send Feedback

The DictionaryItemIdentification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DictionaryItemIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DictionaryItemIdentification Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DictionaryItemIdentification Properties
DictionaryItemIdentification Class See Also Send Feedback

The DictionaryItemIdentification type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets or sets the index.

See Also

DictionaryItemIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Key Property

DictionaryItemIdentification..::..Key Property
DictionaryItemIdentification Class See Also Send Feedback
Gets or sets the index.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Key { get; set; }

Field Value

The index.

See Also

DictionaryItemIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldControl Class

FieldControl Class
Members See Also Send Feedback
Represents the control for single field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class FieldControl : Control

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Control
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..FieldControl
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..SubSchemaControl
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..SubSchemaListTable

See Also

FieldControl Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldControl Members

[image]

Structural Analysis and Code Checking API Reference Guide
FieldControl Members
FieldControl Class Constructors Methods Properties See Also Send Feedback

The FieldControl type exposes the following members.

Constructors

 | Name | Description
Public method | FieldControl | Initializes a new instance of the FieldControl class.

Methods

 | Name | Description
 | Build(PropertyInfo, IResource, Guid) | Generates the Field Control based on property attributes.
 | Build(Type, String, IResource) | Generates the FieldControl based on property attributes.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDisplayName | Gets the display name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUIAttribute | Gets the UI attribute.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Container | Gets the container.
Public property | FieldDisplayName | Gets or sets the display name of the field.
Public property | FieldName | Gets or sets the name of the field.
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | KeyType | Gets the type of the key.
Public property | KeyVisualAttribute | Gets or sets the visual attribute.
Public property | SchemaGuid | Gets or sets the schema GUID.
Public property | UnitAttribute | Gets the unit attribute.
Public property | ValueType | Gets the type of the value.
Public property | VisualAttribute | Gets or sets the visual attribute.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldControl Constructor

FieldControl Constructor
FieldControl Class See Also Send Feedback
Initializes a new instance of the FieldControl class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public FieldControl(
    Guid schema,
    string fieldName,
    string displayName,
    FieldUIAttribute attribute,
    UnitAttribute unitAttribute,
    ContainerType container,
    Type valueType,
    Type keyType
)

Parameters

schema
Type: System..::..Guid
The schema.
fieldName
Type: System..::..String
Name of the field.
displayName
Type: System..::..String
The display name.
attribute
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
The attribute.
unitAttribute
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..UnitAttribute
The unit attribute.
container
Type: ContainerType
The container.
valueType
Type: System..::..Type
Type of the value.
keyType
Type: System..::..Type
Type of the key.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldControl Methods

[image]

Structural Analysis and Code Checking API Reference Guide
FieldControl Methods
FieldControl Class See Also Send Feedback

The FieldControl type exposes the following members.

Methods

 | Name | Description
 | Build(PropertyInfo, IResource, Guid) | Generates the Field Control based on property attributes.
 | Build(Type, String, IResource) | Generates the FieldControl based on property attributes.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDisplayName | Gets the display name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUIAttribute | Gets the UI attribute.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Build Method

[image]

Structural Analysis and Code Checking API Reference Guide
FieldControl..::..Build Method
FieldControl Class See Also Send Feedback

Overload List

Name | Description
Build(PropertyInfo, IResource, Guid) | Generates the Field Control based on property attributes.
Build(Type, String, IResource) | Generates the FieldControl based on property attributes.

See Also

FieldControl Class
FieldControl Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Build Method (PropertyInfo, IResource, Guid)

FieldControl..::..Build Method (PropertyInfo, IResource, Guid)
FieldControl Class See Also Send Feedback
Generates the Field Control based on property attributes.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static FieldControl Build(
    PropertyInfo property,
    IResource server,
    Guid schemaId
)

Parameters

property
Type: System.Reflection..::..PropertyInfo
The property.
server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The server.
schemaId
Type: System..::..Guid
The schema id.

Return Value

See Also

FieldControl Class
Build Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Build Method (Type, String, IResource)

FieldControl..::..Build Method (Type, String, IResource)
FieldControl Class See Also Send Feedback
Generates the FieldControl based on property attributes.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static FieldControl Build(
    Type type,
    string name,
    IResource server
)

Parameters

type
Type: System..::..Type
The type.
name
Type: System..::..String
The name.
server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The server.

Return Value

See Also

FieldControl Class
Build Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetDisplayName Method

FieldControl..::..GetDisplayName Method
FieldControl Class See Also Send Feedback
Gets the display name.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string GetDisplayName(
    IResource server,
    string name,
    FieldUIAttribute att
)

Parameters

server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The server.
name
Type: System..::..String
The name.
att
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
The attribute.

Return Value

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetUIAttribute Method

FieldControl..::..GetUIAttribute Method
FieldControl Class See Also Send Feedback
Gets the UI attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static FieldUIAttribute GetUIAttribute(
    ContainerType container,
    Type typeForSchema,
    DefaultFieldControlAttribute defaultControl
)

Parameters

container
Type: ContainerType
The container.
typeForSchema
Type: System..::..Type
The type for schema.
defaultControl
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DefaultFieldControlAttribute
The default control.

Return Value

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldControl Properties

[image]

Structural Analysis and Code Checking API Reference Guide
FieldControl Properties
FieldControl Class See Also Send Feedback

The FieldControl type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the container.
Public property | FieldDisplayName | Gets or sets the display name of the field.
Public property | FieldName | Gets or sets the name of the field.
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | KeyType | Gets the type of the key.
Public property | KeyVisualAttribute | Gets or sets the visual attribute.
Public property | SchemaGuid | Gets or sets the schema GUID.
Public property | UnitAttribute | Gets the unit attribute.
Public property | ValueType | Gets the type of the value.
Public property | VisualAttribute | Gets or sets the visual attribute.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Container Property

FieldControl..::..Container Property
FieldControl Class See Also Send Feedback
Gets the container.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ContainerType Container { get; private set; }

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldDisplayName Property

FieldControl..::..FieldDisplayName Property
FieldControl Class See Also Send Feedback
Gets or sets the display name of the field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string FieldDisplayName { get; set; }

Field Value

The display name of the field.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldName Property

FieldControl..::..FieldName Property
FieldControl Class See Also Send Feedback
Gets or sets the name of the field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string FieldName { get; set; }

Field Value

The name of the field.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


KeyType Property

FieldControl..::..KeyType Property
FieldControl Class See Also Send Feedback
Gets the type of the key.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type KeyType { get; private set; }

Field Value

The type of the key.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


KeyVisualAttribute Property

FieldControl..::..KeyVisualAttribute Property
FieldControl Class See Also Send Feedback
Gets or sets the visual attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public FieldUIAttribute KeyVisualAttribute { get; set; }

Field Value

The visual attribute.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SchemaGuid Property

FieldControl..::..SchemaGuid Property
FieldControl Class See Also Send Feedback
Gets or sets the schema GUID.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid SchemaGuid { get; set; }

Field Value

The schema GUID.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


UnitAttribute Property

FieldControl..::..UnitAttribute Property
FieldControl Class See Also Send Feedback
Gets the unit attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitAttribute UnitAttribute { get; private set; }

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValueType Property

FieldControl..::..ValueType Property
FieldControl Class See Also Send Feedback
Gets the type of the value.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type ValueType { get; private set; }

Field Value

The type of the value.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


VisualAttribute Property

FieldControl..::..VisualAttribute Property
FieldControl Class See Also Send Feedback
Gets or sets the visual attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public FieldUIAttribute VisualAttribute { get; set; }

Field Value

The visual attribute.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldValidation Delegate

FieldValidation Delegate
See Also Send Feedback
Describes field validation event.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public delegate bool FieldValidation(
    IFieldEditor sender,
    Object value
)

Parameters

sender
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..IFieldEditor
The sender.
value
Type: System..::..Object
The value.

Return Value

See Also

Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IDefaultValueProvider Interface

IDefaultValueProvider Interface
Members See Also Send Feedback
Base interface for default value providers.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IDefaultValueProvider

See Also

IDefaultValueProvider Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IDefaultValueProvider Members

[image]

Structural Analysis and Code Checking API Reference Guide
IDefaultValueProvider Members
IDefaultValueProvider Interface Methods See Also Send Feedback

The IDefaultValueProvider type exposes the following members.

Methods

 | Name | Description
Public method | GetDefaultValue | Gets the default value.

See Also

IDefaultValueProvider Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IDefaultValueProvider Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IDefaultValueProvider Methods
IDefaultValueProvider Interface See Also Send Feedback

The IDefaultValueProvider type exposes the following members.

Methods

 | Name | Description
Public method | GetDefaultValue | Gets the default value.

See Also

IDefaultValueProvider Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetDefaultValue Method

IDefaultValueProvider..::..GetDefaultValue Method
IDefaultValueProvider Interface See Also Send Feedback
Gets the default value.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Object GetDefaultValue(
    Object sender,
    DefaultValueQueryEventArgs e
)

Parameters

sender
Type: System..::..Object
The sender.
e
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..DefaultValueQueryEventArgs
The DefaultValueQueryEventArgs instance containing the event data.

Return Value

See Also

IDefaultValueProvider Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldEditor Interface

IFieldEditor Interface
Members See Also Send Feedback
Base interface for all field editors

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IFieldEditor

See Also

IFieldEditor Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldEditor Members

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldEditor Members
IFieldEditor Interface Methods Properties Events See Also Send Feedback

The IFieldEditor type exposes the following members.

Methods

 | Name | Description
Public method | GetUniqueId | Gets the unique id.
Public method | GetValue | Gets the value in specified display unit type.
Public method | SetAttribute(FieldUIAttribute) | Sets the attribute.
Public method | SetAttribute(String, Object, DisplayUnitType) | Sets spefified attribute.
Public method | SetDocument | Sets the Revit document.
Public method | SetName | Sets the name of control.
Public method | SetUnitType | Sets the type of the unit.
Public method | SetValue | Sets the value in specified display unit type.

Properties

 | Name | Description
Public property | BorderVisible | Gets or sets a value indicating whether border is visible.
Public property | FieldName | Gets or sets the name of the field.
Public property | IsEnabled | Gets or sets a value indicating whether this instance is enabled.

Events

 | Name | Description
Public event | ValueChanged | Occurs when value changed in the control.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldEditor Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldEditor Methods
IFieldEditor Interface See Also Send Feedback

The IFieldEditor type exposes the following members.

Methods

 | Name | Description
Public method | GetUniqueId | Gets the unique id.
Public method | GetValue | Gets the value in specified display unit type.
Public method | SetAttribute(FieldUIAttribute) | Sets the attribute.
Public method | SetAttribute(String, Object, DisplayUnitType) | Sets spefified attribute.
Public method | SetDocument | Sets the Revit document.
Public method | SetName | Sets the name of control.
Public method | SetUnitType | Sets the type of the unit.
Public method | SetValue | Sets the value in specified display unit type.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetUniqueId Method

IFieldEditor..::..GetUniqueId Method
IFieldEditor Interface See Also Send Feedback
Gets the unique id.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Guid GetUniqueId()

Return Value

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetValue Method

IFieldEditor..::..GetValue Method
IFieldEditor Interface See Also Send Feedback
Gets the value in specified display unit type.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Object GetValue(
    DisplayUnitType dispUnitType
)

Parameters

dispUnitType
Type: DisplayUnitType
Type of the display unit.

Return Value

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetAttribute Method

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldEditor..::..SetAttribute Method
IFieldEditor Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAttribute(FieldUIAttribute) | Sets the attribute.
Public method | SetAttribute(String, Object, DisplayUnitType) | Sets spefified attribute.

See Also

IFieldEditor Interface
IFieldEditor Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetAttribute Method (FieldUIAttribute)

IFieldEditor..::..SetAttribute Method (FieldUIAttribute)
IFieldEditor Interface See Also Send Feedback
Sets the attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetAttribute(
    FieldUIAttribute fieldUIAttribute
)

Parameters

fieldUIAttribute
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
The field UI attribute.

See Also

IFieldEditor Interface
SetAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetAttribute Method (String, Object, )

IFieldEditor..::..SetAttribute Method (String, Object, )
IFieldEditor Interface See Also Send Feedback
Sets spefified attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetAttribute(
    string name,
    Object value,
    DisplayUnitType dispUnitType
)

Parameters

name
Type: System..::..String
Name of the attribute.
value
Type: System..::..Object
Value of the attribute.
dispUnitType
Type: DisplayUnitType
Type of the display unit.

See Also

IFieldEditor Interface
SetAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetDocument Method

IFieldEditor..::..SetDocument Method
IFieldEditor Interface See Also Send Feedback
Sets the Revit document.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetDocument(
    Document document
)

Parameters

document
Type: Document
The document.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetName Method

IFieldEditor..::..SetName Method
IFieldEditor Interface See Also Send Feedback
Sets the name of control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetName(
    string prefix
)

Parameters

prefix
Type: System..::..String
The prefix.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetUnitType Method

IFieldEditor..::..SetUnitType Method
IFieldEditor Interface See Also Send Feedback
Sets the type of the unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetUnitType(
    UnitType unitType
)

Parameters

unitType
Type: UnitType
Type of the unit.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetValue Method

IFieldEditor..::..SetValue Method
IFieldEditor Interface See Also Send Feedback
Sets the value in specified display unit type.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetValue(
    Object value,
    DisplayUnitType dispUnitType
)

Parameters

value
Type: System..::..Object
The value.
dispUnitType
Type: DisplayUnitType
Type of the display unit.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldEditor Properties

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldEditor Properties
IFieldEditor Interface See Also Send Feedback

The IFieldEditor type exposes the following members.

Properties

 | Name | Description
Public property | BorderVisible | Gets or sets a value indicating whether border is visible.
Public property | FieldName | Gets or sets the name of the field.
Public property | IsEnabled | Gets or sets a value indicating whether this instance is enabled.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


BorderVisible Property

IFieldEditor..::..BorderVisible Property
IFieldEditor Interface See Also Send Feedback
Gets or sets a value indicating whether border is visible.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool BorderVisible { get; set; }

Field Value

true if border visible; otherwise, false.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldName Property

IFieldEditor..::..FieldName Property
IFieldEditor Interface See Also Send Feedback
Gets or sets the name of the field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
string FieldName { get; set; }

Field Value

The name of the field.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IsEnabled Property

IFieldEditor..::..IsEnabled Property
IFieldEditor Interface See Also Send Feedback
Gets or sets a value indicating whether this instance is enabled.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool IsEnabled { get; set; }

Field Value

true if this instance is enabled; otherwise, false.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldEditor Events

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldEditor Events
IFieldEditor Interface See Also Send Feedback

The IFieldEditor type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Occurs when value changed in the control.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValueChanged Event

IFieldEditor..::..ValueChanged Event
IFieldEditor Interface See Also Send Feedback
Occurs when value changed in the control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
event ValueChangedHandler ValueChanged

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldValidator Interface

IFieldValidator Interface
Members See Also Send Feedback
The base interface for all validation classes.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IFieldValidator

See Also

IFieldValidator Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldValidator Members

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldValidator Members
IFieldValidator Interface Methods See Also Send Feedback

The IFieldValidator type exposes the following members.

Methods

 | Name | Description
Public method | ValidateValue | Validates the value.

See Also

IFieldValidator Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldValidator Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldValidator Methods
IFieldValidator Interface See Also Send Feedback

The IFieldValidator type exposes the following members.

Methods

 | Name | Description
Public method | ValidateValue | Validates the value.

See Also

IFieldValidator Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValidateValue Method

IFieldValidator..::..ValidateValue Method
IFieldValidator Interface See Also Send Feedback
Validates the value.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool ValidateValue(
    Object entity,
    string field,
    Object value,
    DisplayUnitType unit
)

Parameters

entity
Type: System..::..Object
The entity.
field
Type: System..::..String
The field.
value
Type: System..::..Object
The value.
unit
Type: DisplayUnitType
The unit.

Return Value

See Also

IFieldValidator Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldValueChanged Interface

IFieldValueChanged Interface
Members See Also Send Feedback
Base interface for value change observers

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IFieldValueChanged

See Also

IFieldValueChanged Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldValueChanged Members

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldValueChanged Members
IFieldValueChanged Interface Methods See Also Send Feedback

The IFieldValueChanged type exposes the following members.

Methods

 | Name | Description
Public method | ValueChanged | Informs the user that value changed

See Also

IFieldValueChanged Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFieldValueChanged Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldValueChanged Methods
IFieldValueChanged Interface See Also Send Feedback

The IFieldValueChanged type exposes the following members.

Methods

 | Name | Description
Public method | ValueChanged | Informs the user that value changed

See Also

IFieldValueChanged Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValueChanged Method

IFieldValueChanged..::..ValueChanged Method
IFieldValueChanged Interface See Also Send Feedback
Informs the user that value changed

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void ValueChanged(
    Object sender,
    ValueChangedEventArgs e
)

Parameters

sender
Type: System..::..Object
e
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ValueChangedEventArgs

See Also

IFieldValueChanged Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFormatAttribute Interface

IFormatAttribute Interface
Members See Also Send Feedback
Represents base interface for format attributes

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IFormatAttribute

See Also

IFormatAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFormatAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
IFormatAttribute Members
IFormatAttribute Interface Methods See Also Send Feedback

The IFormatAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetFieldFormat | Gets the IFieldFormat object.

See Also

IFormatAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IFormatAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IFormatAttribute Methods
IFormatAttribute Interface See Also Send Feedback

The IFormatAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetFieldFormat | Gets the IFieldFormat object.

See Also

IFormatAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetFieldFormat Method

IFormatAttribute..::..GetFieldFormat Method
IFormatAttribute Interface See Also Send Feedback
Gets the IFieldFormat object.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
IFieldFormat GetFieldFormat()

Return Value

See Also

IFormatAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IGridAttribute Interface

IGridAttribute Interface
Members See Also Send Feedback
Base interface for all grid controls attributes.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IGridAttribute

See Also

IGridAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IGridAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
IGridAttribute Members
IGridAttribute Interface Methods Properties See Also Send Feedback

The IGridAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetDefaultValueProvider | Gets the instance of default value provider.

Properties

 | Name | Description
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).

See Also

IGridAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IGridAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IGridAttribute Methods
IGridAttribute Interface See Also Send Feedback

The IGridAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetDefaultValueProvider | Gets the instance of default value provider.

See Also

IGridAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetDefaultValueProvider Method

IGridAttribute..::..GetDefaultValueProvider Method
IGridAttribute Interface See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
IDefaultValueProvider GetDefaultValueProvider()

Return Value

See Also

IGridAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IGridAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
IGridAttribute Properties
IGridAttribute Interface See Also Send Feedback

The IGridAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).

See Also

IGridAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


AttributeUnit Property

IGridAttribute..::..AttributeUnit Property
IGridAttribute Interface See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

See Also

IGridAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DefaultValue Property

IGridAttribute..::..DefaultValue Property
IGridAttribute Interface See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Object DefaultValue { get; set; }

Field Value

The default value.

See Also

IGridAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


DefaultValueProvider Property

IGridAttribute..::..DefaultValueProvider Property
IGridAttribute Interface See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

See Also

IGridAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


MapKey Property

IGridAttribute..::..MapKey Property
IGridAttribute Interface See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

See Also

IGridAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IGridValueAttribute Interface

IGridValueAttribute Interface
Members See Also Send Feedback
Base interface for all grid controls attributes

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IGridValueAttribute : IGridAttribute

See Also

IGridValueAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IGridValueAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
IGridValueAttribute Members
IGridValueAttribute Interface Methods Properties See Also Send Feedback

The IGridValueAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetDefaultValueProvider | Gets the instance of default value provider. (Inherited from IGridAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit. (Inherited from IGridAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid). (Inherited from IGridAttribute.)
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface (Inherited from IGridAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps). (Inherited from IGridAttribute.)

See Also

IGridValueAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IGridValueAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IGridValueAttribute Methods
IGridValueAttribute Interface See Also Send Feedback

The IGridValueAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetDefaultValueProvider | Gets the instance of default value provider. (Inherited from IGridAttribute.)

See Also

IGridValueAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IGridValueAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
IGridValueAttribute Properties
IGridValueAttribute Interface See Also Send Feedback

The IGridValueAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit. (Inherited from IGridAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid). (Inherited from IGridAttribute.)
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface (Inherited from IGridAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps). (Inherited from IGridAttribute.)

See Also

IGridValueAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


AllowToAddElements Property

IGridValueAttribute..::..AllowToAddElements Property
IGridValueAttribute Interface See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

See Also

IGridValueAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


AllowToRemoveElements Property

IGridValueAttribute..::..AllowToRemoveElements Property
IGridValueAttribute Interface See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

See Also

IGridValueAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ILayoutControl Interface

ILayoutControl Interface
Members See Also Send Feedback
Represents base interface for layouts controls

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ILayoutControl : ISchemaEditor

See Also

ILayoutControl Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ILayoutControl Members

[image]

Structural Analysis and Code Checking API Reference Guide
ILayoutControl Members
ILayoutControl Interface Methods Properties See Also Send Feedback

The ILayoutControl type exposes the following members.

Methods

 | Name | Description
Public method | BuildLayout | Builds the layout control based on logic structure.
Public method | ExpandCategory | Expands the category. (Inherited from ISchemaEditor.)
Public method | GetEntity | Returns entity based on current control settings. (Inherited from ISchemaEditor.)
Public method | GetFieldEditor | Gets the field editor. (Inherited from ISchemaEditor.)
Public method | GetObject | Returns entity based on current control settings. (Inherited from ISchemaEditor.)
Public method | GetValue | Gets value of specific field (Inherited from ISchemaEditor.)
Public method | Initialize | Initializes layout with data.
Public method | OpenSubSchemaDialog | Opens the sub schema dialog. (Inherited from ISchemaEditor.)
Public method | RefreshEditor | Refreshes the control. (Inherited from ISchemaEditor.)
Public method | SetAttribute | Sets the attributes of the field. (Inherited from ISchemaEditor.)
Public method | SetCategoryAttribute | Sets the category attributes. (Inherited from ISchemaEditor.)
Public method | SetEntity | Sets entity. (Inherited from ISchemaEditor.)
Public method | SetImageSourceAttribute | Sets the image attribute. (Inherited from ISchemaEditor.)
Public method | SetObject | Sets entity. (Inherited from ISchemaEditor.)
Public method | SetTextBlockContentAttribute | Sets the text block content attribute. (Inherited from ISchemaEditor.)
Public method | SetValue | Sets value for specific field (Inherited from ISchemaEditor.)

Properties

 | Name | Description
Public property | Modified | Returns information whether any changes were made on the control. (Inherited from ISchemaEditor.)

See Also

ILayoutControl Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ILayoutControl Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ILayoutControl Methods
ILayoutControl Interface See Also Send Feedback

The ILayoutControl type exposes the following members.

Methods

 | Name | Description
Public method | BuildLayout | Builds the layout control based on logic structure.
Public method | ExpandCategory | Expands the category. (Inherited from ISchemaEditor.)
Public method | GetEntity | Returns entity based on current control settings. (Inherited from ISchemaEditor.)
Public method | GetFieldEditor | Gets the field editor. (Inherited from ISchemaEditor.)
Public method | GetObject | Returns entity based on current control settings. (Inherited from ISchemaEditor.)
Public method | GetValue | Gets value of specific field (Inherited from ISchemaEditor.)
Public method | Initialize | Initializes layout with data.
Public method | OpenSubSchemaDialog | Opens the sub schema dialog. (Inherited from ISchemaEditor.)
Public method | RefreshEditor | Refreshes the control. (Inherited from ISchemaEditor.)
Public method | SetAttribute | Sets the attributes of the field. (Inherited from ISchemaEditor.)
Public method | SetCategoryAttribute | Sets the category attributes. (Inherited from ISchemaEditor.)
Public method | SetEntity | Sets entity. (Inherited from ISchemaEditor.)
Public method | SetImageSourceAttribute | Sets the image attribute. (Inherited from ISchemaEditor.)
Public method | SetObject | Sets entity. (Inherited from ISchemaEditor.)
Public method | SetTextBlockContentAttribute | Sets the text block content attribute. (Inherited from ISchemaEditor.)
Public method | SetValue | Sets value for specific field (Inherited from ISchemaEditor.)

See Also

ILayoutControl Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


BuildLayout Method

ILayoutControl..::..BuildLayout Method
ILayoutControl Interface See Also Send Feedback
Builds the layout control based on logic structure.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void BuildLayout(
    Layout layout
)

Parameters

layout
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Layout
The layout.

See Also

ILayoutControl Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Initialize Method

ILayoutControl..::..Initialize Method
ILayoutControl Interface See Also Send Feedback
Initializes layout with data.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void Initialize(
    IServerUI server,
    Document document
)

Parameters

server
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..IServerUI
The server.
document
Type: Document
The document.

See Also

ILayoutControl Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ILayoutControl Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ILayoutControl Properties
ILayoutControl Interface See Also Send Feedback

The ILayoutControl type exposes the following members.

Properties

 | Name | Description
Public property | Modified | Returns information whether any changes were made on the control. (Inherited from ISchemaEditor.)

See Also

ILayoutControl Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Image Class

Image Class
Members See Also Send Feedback
Represents image control

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Image : KeyControl

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Control
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..KeyControl
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Image

See Also

Image Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Image Members

[image]

Structural Analysis and Code Checking API Reference Guide
Image Members
Image Class Constructors Methods Properties See Also Send Feedback

The Image type exposes the following members.

Constructors

 | Name | Description
Public method | Image | Initializes a new instance of the Image class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | Key | Gets or sets the key for image identification. (Inherited from KeyControl.)
Public property | Source | Gets or sets the source.

See Also

Image Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Image Constructor

Image Constructor
Image Class See Also Send Feedback
Initializes a new instance of the Image class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Image()

See Also

Image Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Image Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Image Methods
Image Class See Also Send Feedback

The Image type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Image Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Image Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Image Properties
Image Class See Also Send Feedback

The Image type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | Key | Gets or sets the key for image identification. (Inherited from KeyControl.)
Public property | Source | Gets or sets the source.

See Also

Image Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Source Property

Image..::..Source Property
Image Class See Also Send Feedback
Gets or sets the source.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Uri Source { get; set; }

Field Value

The source.

See Also

Image Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ImageSize Enumeration

ImageSize Enumeration
See Also Send Feedback
Represents standard sizes of image

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ImageSize

Members

Member name | Value | Description
Small | 0 | 16x16
Medium | 1 | 32x32
Large | 2 | 64x64

See Also

Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ISchemaEditor Interface

ISchemaEditor Interface
Members See Also Send Feedback
Base interface for all controls representing schemas.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ISchemaEditor

See Also

ISchemaEditor Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ISchemaEditor Members

[image]

Structural Analysis and Code Checking API Reference Guide
ISchemaEditor Members
ISchemaEditor Interface Methods Properties See Also Send Feedback

The ISchemaEditor type exposes the following members.

Methods

 | Name | Description
Public method | ExpandCategory | Expands the category.
Public method | GetEntity | Returns entity based on current control settings.
Public method | GetFieldEditor | Gets the field editor.
Public method | GetObject | Returns entity based on current control settings.
Public method | GetValue | Gets value of specific field
Public method | OpenSubSchemaDialog | Opens the sub schema dialog.
Public method | RefreshEditor | Refreshes the control.
Public method | SetAttribute | Sets the attributes of the field.
Public method | SetCategoryAttribute | Sets the category attributes.
Public method | SetEntity | Sets entity.
Public method | SetImageSourceAttribute | Sets the image attribute.
Public method | SetObject | Sets entity.
Public method | SetTextBlockContentAttribute | Sets the text block content attribute.
Public method | SetValue | Sets value for specific field

Properties

 | Name | Description
Public property | Modified | Returns information whether any changes were made on the control.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ISchemaEditor Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ISchemaEditor Methods
ISchemaEditor Interface See Also Send Feedback

The ISchemaEditor type exposes the following members.

Methods

 | Name | Description
Public method | ExpandCategory | Expands the category.
Public method | GetEntity | Returns entity based on current control settings.
Public method | GetFieldEditor | Gets the field editor.
Public method | GetObject | Returns entity based on current control settings.
Public method | GetValue | Gets value of specific field
Public method | OpenSubSchemaDialog | Opens the sub schema dialog.
Public method | RefreshEditor | Refreshes the control.
Public method | SetAttribute | Sets the attributes of the field.
Public method | SetCategoryAttribute | Sets the category attributes.
Public method | SetEntity | Sets entity.
Public method | SetImageSourceAttribute | Sets the image attribute.
Public method | SetObject | Sets entity.
Public method | SetTextBlockContentAttribute | Sets the text block content attribute.
Public method | SetValue | Sets value for specific field

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ExpandCategory Method

ISchemaEditor..::..ExpandCategory Method
ISchemaEditor Interface See Also Send Feedback
Expands the category.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void ExpandCategory(
    string category,
    bool expand
)

Parameters

category
Type: System..::..String
The category.
expand
Type: System..::..Boolean
if set to true expand category.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetEntity Method

ISchemaEditor..::..GetEntity Method
ISchemaEditor Interface See Also Send Feedback
Returns entity based on current control settings.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Entity GetEntity()

Return Value

The value.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetFieldEditor Method

ISchemaEditor..::..GetFieldEditor Method
ISchemaEditor Interface See Also Send Feedback
Gets the field editor.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
IFieldEditor GetFieldEditor(
    string fieldName
)

Parameters

fieldName
Type: System..::..String
Name of the field.

Return Value

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetObject Method

ISchemaEditor..::..GetObject Method
ISchemaEditor Interface See Also Send Feedback
Returns entity based on current control settings.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Object GetObject()

Return Value

The value.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetValue Method

ISchemaEditor..::..GetValue Method
ISchemaEditor Interface See Also Send Feedback
Gets value of specific field

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Object GetValue(
    string fieldName,
    DisplayUnitType displayUnitType
)

Parameters

fieldName
Type: System..::..String
The name of the field.
displayUnitType
Type: DisplayUnitType
Display type of the unit.

Return Value

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


OpenSubSchemaDialog Method

ISchemaEditor..::..OpenSubSchemaDialog Method
ISchemaEditor Interface See Also Send Feedback
Opens the sub schema dialog.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool OpenSubSchemaDialog(
    string fieldName
)

Parameters

fieldName
Type: System..::..String
Name of the field.

Return Value

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


RefreshEditor Method

ISchemaEditor..::..RefreshEditor Method
ISchemaEditor Interface See Also Send Feedback
Refreshes the control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void RefreshEditor()

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetAttribute Method

ISchemaEditor..::..SetAttribute Method
ISchemaEditor Interface See Also Send Feedback
Sets the attributes of the field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetAttribute(
    string fieldName,
    string attributePropertyName,
    Object value,
    DisplayUnitType dispUnitType
)

Parameters

fieldName
Type: System..::..String
Name of the field.
attributePropertyName
Type: System..::..String
Name of the attribute.
value
Type: System..::..Object
The value.
dispUnitType
Type: DisplayUnitType
Type of the display unit.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetCategoryAttribute Method

ISchemaEditor..::..SetCategoryAttribute Method
ISchemaEditor Interface See Also Send Feedback
Sets the category attributes.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetCategoryAttribute(
    string category,
    bool visible
)

Parameters

category
Type: System..::..String
The category.
visible
Type: System..::..Boolean
if set to true visible.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetEntity Method

ISchemaEditor..::..SetEntity Method
ISchemaEditor Interface See Also Send Feedback
Sets entity.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetEntity(
    Entity entity
)

Parameters

entity
Type: Entity
The entity.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetImageSourceAttribute Method

ISchemaEditor..::..SetImageSourceAttribute Method
ISchemaEditor Interface See Also Send Feedback
Sets the image attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetImageSourceAttribute(
    string key,
    Uri uri
)

Parameters

key
Type: System..::..String
The key of image.
uri
Type: System..::..Uri
The source.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetObject Method

ISchemaEditor..::..SetObject Method
ISchemaEditor Interface See Also Send Feedback
Sets entity.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetObject(
    Object obj
)

Parameters

obj
Type: System..::..Object
The obj.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetTextBlockContentAttribute Method

ISchemaEditor..::..SetTextBlockContentAttribute Method
ISchemaEditor Interface See Also Send Feedback
Sets the text block content attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetTextBlockContentAttribute(
    string key,
    string text
)

Parameters

key
Type: System..::..String
The key.
text
Type: System..::..String
The text.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetValue Method

ISchemaEditor..::..SetValue Method
ISchemaEditor Interface See Also Send Feedback
Sets value for specific field

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetValue(
    string fieldName,
    Object value,
    DisplayUnitType displayUnitType
)

Parameters

fieldName
Type: System..::..String
The name of the field.
value
Type: System..::..Object
The value.
displayUnitType
Type: DisplayUnitType
Display type of the unit.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ISchemaEditor Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ISchemaEditor Properties
ISchemaEditor Interface See Also Send Feedback

The ISchemaEditor type exposes the following members.

Properties

 | Name | Description
Public property | Modified | Returns information whether any changes were made on the control.

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Modified Property

ISchemaEditor..::..Modified Property
ISchemaEditor Interface See Also Send Feedback
Returns information whether any changes were made on the control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
bool Modified { get; set; }

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IServerUI Interface

IServerUI Interface
Members See Also Send Feedback
Base interface for code checking UI servers.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IServerUI : IResource

See Also

IServerUI Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IServerUI Members

[image]

Structural Analysis and Code Checking API Reference Guide
IServerUI Members
IServerUI Interface Methods See Also Send Feedback

The IServerUI type exposes the following members.

Methods

 | Name | Description
Public method | GetDataSource | Gets the data source of the specific key.
Public method | GetResource | Gets the text resource. (Inherited from IResource.)
Public method | GetResourceImage | Gets the image resource. (Inherited from IResource.)
Public method | LayoutInitialized | Informs the server that layout was initialized
Public method | ValueChanged | Informs the server that value changed.

See Also

IServerUI Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IServerUI Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IServerUI Methods
IServerUI Interface See Also Send Feedback

The IServerUI type exposes the following members.

Methods

 | Name | Description
Public method | GetDataSource | Gets the data source of the specific key.
Public method | GetResource | Gets the text resource. (Inherited from IResource.)
Public method | GetResourceImage | Gets the image resource. (Inherited from IResource.)
Public method | LayoutInitialized | Informs the server that layout was initialized
Public method | ValueChanged | Informs the server that value changed.

See Also

IServerUI Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetDataSource Method

IServerUI..::..GetDataSource Method
IServerUI Interface See Also Send Feedback
Gets the data source of the specific key.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
IList GetDataSource(
    string key,
    Document document,
    DisplayUnitType unitType
)

Parameters

key
Type: System..::..String
The key of data source.
document
Type: Document
The document.
unitType
Type: DisplayUnitType
Type of the unit.

Return Value

The data source of list type.

See Also

IServerUI Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


LayoutInitialized Method

IServerUI..::..LayoutInitialized Method
IServerUI Interface See Also Send Feedback
Informs the server that layout was initialized

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void LayoutInitialized(
    Object sender,
    LayoutInitializedEventArgs e
)

Parameters

sender
Type: System..::..Object
The sender.
e
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..LayoutInitializedEventArgs
The LayoutInitializedEventArgs instance containing the event data.

See Also

IServerUI Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValueChanged Method

IServerUI..::..ValueChanged Method
IServerUI Interface See Also Send Feedback
Informs the server that value changed.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void ValueChanged(
    Object sender,
    ValueChangedEventArgs e
)

Parameters

sender
Type: System..::..Object
The sender.
e
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ValueChangedEventArgs
The ValueChangedEventArgs instance containing the event data.

See Also

IServerUI Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ITableEditor Interface

ITableEditor Interface
Members See Also Send Feedback
Represents table editor.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ITableEditor : IFieldEditor

See Also

ITableEditor Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ITableEditor Members

[image]

Structural Analysis and Code Checking API Reference Guide
ITableEditor Members
ITableEditor Interface Methods Properties Events See Also Send Feedback

The ITableEditor type exposes the following members.

Methods

 | Name | Description
Public method | GetCount | Gets the count.
Public method | GetUniqueId | Gets the unique id. (Inherited from IFieldEditor.)
Public method | GetValue(DisplayUnitType) | Gets the value in specified display unit type. (Inherited from IFieldEditor.)
Public method | GetValue(String, Int32, DisplayUnitType) | Gets the value in specified display unit type.
Public method | SetAttribute(FieldUIAttribute) | Sets the attribute. (Inherited from IFieldEditor.)
Public method | SetAttribute(String, Object, DisplayUnitType) | Sets spefified attribute. (Inherited from IFieldEditor.)
Public method | SetAttribute(String, Int32, String, Object, DisplayUnitType) | Sets the attributes of the field.
Public method | SetDocument | Sets the Revit document. (Inherited from IFieldEditor.)
Public method | SetName | Sets the name of control. (Inherited from IFieldEditor.)
Public method | SetUnitType | Sets the type of the unit. (Inherited from IFieldEditor.)
Public method | SetValue(Object, DisplayUnitType) | Sets the value in specified display unit type. (Inherited from IFieldEditor.)
Public method | SetValue(Object, String, Int32, DisplayUnitType) | Sets the value in specified display unit type.

Properties

 | Name | Description
Public property | BorderVisible | Gets or sets a value indicating whether border is visible. (Inherited from IFieldEditor.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from IFieldEditor.)
Public property | IsEnabled | Gets or sets a value indicating whether this instance is enabled. (Inherited from IFieldEditor.)

Events

 | Name | Description
Public event | ValueChanged | Occurs when value changed in the control. (Inherited from IFieldEditor.)

See Also

ITableEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ITableEditor Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ITableEditor Methods
ITableEditor Interface See Also Send Feedback

The ITableEditor type exposes the following members.

Methods

 | Name | Description
Public method | GetCount | Gets the count.
Public method | GetUniqueId | Gets the unique id. (Inherited from IFieldEditor.)
Public method | GetValue(DisplayUnitType) | Gets the value in specified display unit type. (Inherited from IFieldEditor.)
Public method | GetValue(String, Int32, DisplayUnitType) | Gets the value in specified display unit type.
Public method | SetAttribute(FieldUIAttribute) | Sets the attribute. (Inherited from IFieldEditor.)
Public method | SetAttribute(String, Object, DisplayUnitType) | Sets spefified attribute. (Inherited from IFieldEditor.)
Public method | SetAttribute(String, Int32, String, Object, DisplayUnitType) | Sets the attributes of the field.
Public method | SetDocument | Sets the Revit document. (Inherited from IFieldEditor.)
Public method | SetName | Sets the name of control. (Inherited from IFieldEditor.)
Public method | SetUnitType | Sets the type of the unit. (Inherited from IFieldEditor.)
Public method | SetValue(Object, DisplayUnitType) | Sets the value in specified display unit type. (Inherited from IFieldEditor.)
Public method | SetValue(Object, String, Int32, DisplayUnitType) | Sets the value in specified display unit type.

See Also

ITableEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetCount Method

ITableEditor..::..GetCount Method
ITableEditor Interface See Also Send Feedback
Gets the count.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
int GetCount()

Return Value

See Also

ITableEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetValue Method

[image]

Structural Analysis and Code Checking API Reference Guide
ITableEditor..::..GetValue Method
ITableEditor Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue(DisplayUnitType) | Gets the value in specified display unit type. (Inherited from IFieldEditor.)
Public method | GetValue(String, Int32, DisplayUnitType) | Gets the value in specified display unit type.

See Also

ITableEditor Interface
ITableEditor Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetValue Method (String, Int32, )

ITableEditor..::..GetValue Method (String, Int32, )
ITableEditor Interface See Also Send Feedback
Gets the value in specified display unit type.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
Object GetValue(
    string column,
    int row,
    DisplayUnitType dispUnitType
)

Parameters

column
Type: System..::..String
The column.
row
Type: System..::..Int32
The row.
dispUnitType
Type: DisplayUnitType
Type of the display unit.

Return Value

See Also

ITableEditor Interface
GetValue Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetAttribute Method

[image]

Structural Analysis and Code Checking API Reference Guide
ITableEditor..::..SetAttribute Method
ITableEditor Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAttribute(FieldUIAttribute) | Sets the attribute. (Inherited from IFieldEditor.)
Public method | SetAttribute(String, Object, DisplayUnitType) | Sets spefified attribute. (Inherited from IFieldEditor.)
Public method | SetAttribute(String, Int32, String, Object, DisplayUnitType) | Sets the attributes of the field.

See Also

ITableEditor Interface
ITableEditor Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetAttribute Method (String, Int32, String, Object, )

ITableEditor..::..SetAttribute Method (String, Int32, String, Object, )
ITableEditor Interface See Also Send Feedback
Sets the attributes of the field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetAttribute(
    string column,
    int row,
    string attributePropertyName,
    Object value,
    DisplayUnitType dispUnitType
)

Parameters

column
Type: System..::..String
The column.
row
Type: System..::..Int32
The row.
attributePropertyName
Type: System..::..String
Name of the attribute.
value
Type: System..::..Object
The value.
dispUnitType
Type: DisplayUnitType
Type of the display unit.

See Also

ITableEditor Interface
SetAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetValue Method

[image]

Structural Analysis and Code Checking API Reference Guide
ITableEditor..::..SetValue Method
ITableEditor Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(Object, DisplayUnitType) | Sets the value in specified display unit type. (Inherited from IFieldEditor.)
Public method | SetValue(Object, String, Int32, DisplayUnitType) | Sets the value in specified display unit type.

See Also

ITableEditor Interface
ITableEditor Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SetValue Method (Object, String, Int32, )

ITableEditor..::..SetValue Method (Object, String, Int32, )
ITableEditor Interface See Also Send Feedback
Sets the value in specified display unit type.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void SetValue(
    Object value,
    string column,
    int row,
    DisplayUnitType dispUnitType
)

Parameters

value
Type: System..::..Object
The value.
column
Type: System..::..String
The column.
row
Type: System..::..Int32
The row.
dispUnitType
Type: DisplayUnitType
Type of the display unit.

See Also

ITableEditor Interface
SetValue Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ITableEditor Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ITableEditor Properties
ITableEditor Interface See Also Send Feedback

The ITableEditor type exposes the following members.

Properties

 | Name | Description
Public property | BorderVisible | Gets or sets a value indicating whether border is visible. (Inherited from IFieldEditor.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from IFieldEditor.)
Public property | IsEnabled | Gets or sets a value indicating whether this instance is enabled. (Inherited from IFieldEditor.)

See Also

ITableEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ITableEditor Events

[image]

Structural Analysis and Code Checking API Reference Guide
ITableEditor Events
ITableEditor Interface See Also Send Feedback

The ITableEditor type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Occurs when value changed in the control. (Inherited from IFieldEditor.)

See Also

ITableEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IValidateAttribute Interface

IValidateAttribute Interface
Members See Also Send Feedback
Base interface for attributes which supports validation

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IValidateAttribute

See Also

IValidateAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IValidateAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
IValidateAttribute Members
IValidateAttribute Interface Methods See Also Send Feedback

The IValidateAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetFieldValidator | Gets the field validator.

See Also

IValidateAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


IValidateAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IValidateAttribute Methods
IValidateAttribute Interface See Also Send Feedback

The IValidateAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetFieldValidator | Gets the field validator.

See Also

IValidateAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetFieldValidator Method

IValidateAttribute..::..GetFieldValidator Method
IValidateAttribute Interface See Also Send Feedback
Gets the field validator.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
IFieldValidator GetFieldValidator()

Return Value

See Also

IValidateAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


KeyControl Class

KeyControl Class
Members See Also Send Feedback
Base class for all controls identified by Key

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class KeyControl : Control

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Control
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..KeyControl
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Image
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..TextBlock

See Also

KeyControl Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


KeyControl Members

[image]

Structural Analysis and Code Checking API Reference Guide
KeyControl Members
KeyControl Class Methods Properties See Also Send Feedback

The KeyControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | Key | Gets or sets the key for image identification.

See Also

KeyControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


KeyControl Methods

[image]

Structural Analysis and Code Checking API Reference Guide
KeyControl Methods
KeyControl Class See Also Send Feedback

The KeyControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

KeyControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


KeyControl Properties

[image]

Structural Analysis and Code Checking API Reference Guide
KeyControl Properties
KeyControl Class See Also Send Feedback

The KeyControl type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | Key | Gets or sets the key for image identification.

See Also

KeyControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Key Property

KeyControl..::..Key Property
KeyControl Class See Also Send Feedback
Gets or sets the key for image identification.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Key { get; set; }

Field Value

The key.

See Also

KeyControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Layout Class

Layout Class
Members See Also Send Feedback
Represents the layout control

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Layout

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Layout

See Also

Layout Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Layout Members

[image]

Structural Analysis and Code Checking API Reference Guide
Layout Members
Layout Class Constructors Methods Properties See Also Send Feedback

The Layout type exposes the following members.

Constructors

 | Name | Description
Public method | Layout | Initializes a new instance of the Layout class.

Methods

 | Name | Description
 | ApplyStyle | Applies the style.
 | Build(Schema, IResource) | Generates layout based on schema.
 | Build(Type, IResource) | Generates layout based on type.
 | BuildControl(IServerUI, Document, Object) | Creates the layout control (at the moment in WPF control).
 | BuildControl(IServerUI, Document, Layout, Entity) | Creates the layout control (at the moment in WPF control).
 | BuildControl(IServerUI, Document, Layout, Object) | Creates the layout control (at the moment in WPF control).
 | BuildControls | Generates list of controls based on type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategory | Gets the category.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SortIndexBased | Sorts current layout index based.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Controls | Gets the control list.

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Layout Constructor

Layout Constructor
Layout Class See Also Send Feedback
Initializes a new instance of the Layout class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Layout()

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Layout Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Layout Methods
Layout Class See Also Send Feedback

The Layout type exposes the following members.

Methods

 | Name | Description
 | ApplyStyle | Applies the style.
 | Build(Schema, IResource) | Generates layout based on schema.
 | Build(Type, IResource) | Generates layout based on type.
 | BuildControl(IServerUI, Document, Object) | Creates the layout control (at the moment in WPF control).
 | BuildControl(IServerUI, Document, Layout, Entity) | Creates the layout control (at the moment in WPF control).
 | BuildControl(IServerUI, Document, Layout, Object) | Creates the layout control (at the moment in WPF control).
 | BuildControls | Generates list of controls based on type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategory | Gets the category.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SortIndexBased | Sorts current layout index based.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ApplyStyle Method

Layout..::..ApplyStyle Method
Layout Class See Also Send Feedback
Applies the style.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ApplyStyle(
    Object control
)

Parameters

control
Type: System..::..Object
The control.

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Build Method

[image]

Structural Analysis and Code Checking API Reference Guide
Layout..::..Build Method
Layout Class See Also Send Feedback

Overload List

Name | Description
Build(Schema, IResource) | Generates layout based on schema.
Build(Type, IResource) | Generates layout based on type.

See Also

Layout Class
Layout Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Build Method (, IResource)

Layout..::..Build Method (, IResource)
Layout Class See Also Send Feedback
Generates layout based on schema.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Layout Build(
    Schema schema,
    IResource server
)

Parameters

schema
Type: Schema
The schema.
server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The server.

Return Value

See Also

Layout Class
Build Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Build Method (Type, IResource)

Layout..::..Build Method (Type, IResource)
Layout Class See Also Send Feedback
Generates layout based on type.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Layout Build(
    Type type,
    IResource server
)

Parameters

type
Type: System..::..Type
The type.
server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The server.

Return Value

See Also

Layout Class
Build Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


BuildControl Method

[image]

Structural Analysis and Code Checking API Reference Guide
Layout..::..BuildControl Method
Layout Class See Also Send Feedback

Overload List

Name | Description
BuildControl(IServerUI, Document, Object) | Creates the layout control (at the moment in WPF control).
BuildControl(IServerUI, Document, Layout, Entity) | Creates the layout control (at the moment in WPF control).
BuildControl(IServerUI, Document, Layout, Object) | Creates the layout control (at the moment in WPF control).

See Also

Layout Class
Layout Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


BuildControl Method (IServerUI, , Object)

Layout..::..BuildControl Method (IServerUI, , Object)
Layout Class See Also Send Feedback
Creates the layout control (at the moment in WPF control).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ILayoutControl BuildControl(
    IServerUI server,
    Document document,
    Object obj
)

Parameters

server
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..IServerUI
The server.
document
Type: Document
The document.
obj
Type: System..::..Object
The object.

Return Value

See Also

Layout Class
BuildControl Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


BuildControl Method (IServerUI, , Layout, )

Layout..::..BuildControl Method (IServerUI, , Layout, )
Layout Class See Also Send Feedback
Creates the layout control (at the moment in WPF control).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ILayoutControl BuildControl(
    IServerUI server,
    Document document,
    Layout structure,
    Entity initialData
)

Parameters

server
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..IServerUI
The server.
document
Type: Document
The document.
structure
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Layout
The structure.
initialData
Type: Entity
The initial data.

Return Value

See Also

Layout Class
BuildControl Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


BuildControl Method (IServerUI, , Layout, Object)

Layout..::..BuildControl Method (IServerUI, , Layout, Object)
Layout Class See Also Send Feedback
Creates the layout control (at the moment in WPF control).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ILayoutControl BuildControl(
    IServerUI server,
    Document document,
    Layout structure,
    Object initialData
)

Parameters

server
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..IServerUI
The server.
document
Type: Document
The document.
structure
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Layout
The structure.
initialData
Type: System..::..Object
The initial data.

Return Value

See Also

Layout Class
BuildControl Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


BuildControls Method

Layout..::..BuildControls Method
Layout Class See Also Send Feedback
Generates list of controls based on type.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<Control> BuildControls(
    Type type,
    IResource server,
    bool respectCategories
)

Parameters

type
Type: System..::..Type
The type.
server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The server.
respectCategories
Type: System..::..Boolean
if set to true categories will be respected.

Return Value

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetCategory Method

Layout..::..GetCategory Method
Layout Class See Also Send Feedback
Gets the category.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Category GetCategory(
    string name
)

Parameters

name
Type: System..::..String
The name.

Return Value

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SortIndexBased Method

Layout..::..SortIndexBased Method
Layout Class See Also Send Feedback
Sorts current layout index based.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SortIndexBased()

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Layout Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Layout Properties
Layout Class See Also Send Feedback

The Layout type exposes the following members.

Properties

 | Name | Description
Public property | Controls | Gets the control list.

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Controls Property

Layout..::..Controls Property
Layout Class See Also Send Feedback
Gets the control list.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Control> Controls { get; private set; }

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


LayoutInitializedEventArgs Class

LayoutInitializedEventArgs Class
Members See Also Send Feedback
Represents arguments for layout initialized event.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class LayoutInitializedEventArgs : SchemaEditorEventArgs

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..SchemaEditorEventArgs
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..LayoutInitializedEventArgs

See Also

LayoutInitializedEventArgs Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


LayoutInitializedEventArgs Members

[image]

Structural Analysis and Code Checking API Reference Guide
LayoutInitializedEventArgs Members
LayoutInitializedEventArgs Class Constructors Methods Properties See Also Send Feedback

The LayoutInitializedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutInitializedEventArgs | Initializes a new instance of the LayoutInitializedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Document | Gets the document. (Inherited from SchemaEditorEventArgs.)
Public property | Editor | Gets the editor. (Inherited from SchemaEditorEventArgs.)
Public property | Entity | Gets the entity. (Inherited from SchemaEditorEventArgs.)

See Also

LayoutInitializedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


LayoutInitializedEventArgs Constructor

LayoutInitializedEventArgs Constructor
LayoutInitializedEventArgs Class See Also Send Feedback
Initializes a new instance of the LayoutInitializedEventArgs class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LayoutInitializedEventArgs(
    Object entity,
    Document document,
    ISchemaEditor editor
)

Parameters

entity
Type: System..::..Object
The entity.
document
Type: Document
The document.
editor
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ISchemaEditor
The editor.

See Also

LayoutInitializedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


LayoutInitializedEventArgs Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LayoutInitializedEventArgs Methods
LayoutInitializedEventArgs Class See Also Send Feedback

The LayoutInitializedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LayoutInitializedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


LayoutInitializedEventArgs Properties

[image]

Structural Analysis and Code Checking API Reference Guide
LayoutInitializedEventArgs Properties
LayoutInitializedEventArgs Class See Also Send Feedback

The LayoutInitializedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document. (Inherited from SchemaEditorEventArgs.)
Public property | Editor | Gets the editor. (Inherited from SchemaEditorEventArgs.)
Public property | Entity | Gets the entity. (Inherited from SchemaEditorEventArgs.)

See Also

LayoutInitializedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ListItemIdentification Class

ListItemIdentification Class
Members See Also Send Feedback
Represents list identification.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ListItemIdentification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ListItemIdentification

See Also

ListItemIdentification Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ListItemIdentification Members

[image]

Structural Analysis and Code Checking API Reference Guide
ListItemIdentification Members
ListItemIdentification Class Constructors Methods Properties See Also Send Feedback

The ListItemIdentification type exposes the following members.

Constructors

 | Name | Description
Public method | ListItemIdentification | Initializes a new instance of the ListItemIdentification class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Gets or sets the index.

See Also

ListItemIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ListItemIdentification Constructor

ListItemIdentification Constructor
ListItemIdentification Class See Also Send Feedback
Initializes a new instance of the ListItemIdentification class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ListItemIdentification()

See Also

ListItemIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ListItemIdentification Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ListItemIdentification Methods
ListItemIdentification Class See Also Send Feedback

The ListItemIdentification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ListItemIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ListItemIdentification Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ListItemIdentification Properties
ListItemIdentification Class See Also Send Feedback

The ListItemIdentification type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets or sets the index.

See Also

ListItemIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Index Property

ListItemIdentification..::..Index Property
ListItemIdentification Class See Also Send Feedback
Gets or sets the index.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Index { get; set; }

Field Value

The index.

See Also

ListItemIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SchemaEditorEventArgs Class

SchemaEditorEventArgs Class
Members See Also Send Feedback
Main class for schema editor data.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class SchemaEditorEventArgs

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..SchemaEditorEventArgs
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..LayoutInitializedEventArgs
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ValueChangedEventArgs

See Also

SchemaEditorEventArgs Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SchemaEditorEventArgs Members

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaEditorEventArgs Members
SchemaEditorEventArgs Class Constructors Methods Properties See Also Send Feedback

The SchemaEditorEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SchemaEditorEventArgs | Initializes a new instance of the SchemaEditorEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Document | Gets the document.
Public property | Editor | Gets the editor.
Public property | Entity | Gets the entity.

See Also

SchemaEditorEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SchemaEditorEventArgs Constructor

SchemaEditorEventArgs Constructor
SchemaEditorEventArgs Class See Also Send Feedback
Initializes a new instance of the SchemaEditorEventArgs class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SchemaEditorEventArgs(
    Object entity,
    Document document,
    ISchemaEditor editor
)

Parameters

entity
Type: System..::..Object
The entity.
document
Type: Document
The document.
editor
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ISchemaEditor
The editor.

See Also

SchemaEditorEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SchemaEditorEventArgs Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaEditorEventArgs Methods
SchemaEditorEventArgs Class See Also Send Feedback

The SchemaEditorEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SchemaEditorEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SchemaEditorEventArgs Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaEditorEventArgs Properties
SchemaEditorEventArgs Class See Also Send Feedback

The SchemaEditorEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document.
Public property | Editor | Gets the editor.
Public property | Entity | Gets the entity.

See Also

SchemaEditorEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Document Property

SchemaEditorEventArgs..::..Document Property
SchemaEditorEventArgs Class See Also Send Feedback
Gets the document.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Document Document { get; private set; }

See Also

SchemaEditorEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Editor Property

SchemaEditorEventArgs..::..Editor Property
SchemaEditorEventArgs Class See Also Send Feedback
Gets the editor.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ISchemaEditor Editor { get; private set; }

See Also

SchemaEditorEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Entity Property

SchemaEditorEventArgs..::..Entity Property
SchemaEditorEventArgs Class See Also Send Feedback
Gets the entity.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Entity { get; private set; }

See Also

SchemaEditorEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaControl Class

SubSchemaControl Class
Members See Also Send Feedback
Represents the subschema control

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SubSchemaControl : FieldControl

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Control
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..FieldControl
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..SubSchemaControl

See Also

SubSchemaControl Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaControl Members

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaControl Members
SubSchemaControl Class Constructors Methods Properties See Also Send Feedback

The SubSchemaControl type exposes the following members.

Constructors

 | Name | Description
Public method | SubSchemaControl | Initializes a new instance of the SubSchemaControl class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Container | Gets the container. (Inherited from FieldControl.)
Public property | FieldDisplayName | Gets or sets the display name of the field. (Inherited from FieldControl.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from FieldControl.)
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | KeyType | Gets the type of the key. (Inherited from FieldControl.)
Public property | KeyVisualAttribute | Gets or sets the visual attribute. (Inherited from FieldControl.)
Public property | Layout | Gets or sets the layout.
Public property | SchemaGuid | Gets or sets the schema GUID. (Inherited from FieldControl.)
Public property | SubSchemaId | Gets or sets the subschema id.
Public property | UnitAttribute | Gets the unit attribute. (Inherited from FieldControl.)
Public property | ValueType | Gets the type of the value. (Inherited from FieldControl.)
Public property | VisualAttribute | Gets or sets the visual attribute. (Inherited from FieldControl.)

See Also

SubSchemaControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaControl Constructor

SubSchemaControl Constructor
SubSchemaControl Class See Also Send Feedback
Initializes a new instance of the SubSchemaControl class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaControl(
    Guid schema,
    string fieldName,
    string displayName,
    FieldUIAttribute attribute,
    Guid subSchema,
    ContainerType container,
    Type valueType,
    Type keyType
)

Parameters

schema
Type: System..::..Guid
The schema.
fieldName
Type: System..::..String
Name of the field.
displayName
Type: System..::..String
The display name.
attribute
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
The attribute.
subSchema
Type: System..::..Guid
The sub schema.
container
Type: ContainerType
The type of container
valueType
Type: System..::..Type
Type of the value.
keyType
Type: System..::..Type
Type of the key.

See Also

SubSchemaControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaControl Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaControl Methods
SubSchemaControl Class See Also Send Feedback

The SubSchemaControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SubSchemaControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaControl Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaControl Properties
SubSchemaControl Class See Also Send Feedback

The SubSchemaControl type exposes the following members.

Properties

 | Name | Description
Public property | Container | Gets the container. (Inherited from FieldControl.)
Public property | FieldDisplayName | Gets or sets the display name of the field. (Inherited from FieldControl.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from FieldControl.)
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | KeyType | Gets the type of the key. (Inherited from FieldControl.)
Public property | KeyVisualAttribute | Gets or sets the visual attribute. (Inherited from FieldControl.)
Public property | Layout | Gets or sets the layout.
Public property | SchemaGuid | Gets or sets the schema GUID. (Inherited from FieldControl.)
Public property | SubSchemaId | Gets or sets the subschema id.
Public property | UnitAttribute | Gets the unit attribute. (Inherited from FieldControl.)
Public property | ValueType | Gets the type of the value. (Inherited from FieldControl.)
Public property | VisualAttribute | Gets or sets the visual attribute. (Inherited from FieldControl.)

See Also

SubSchemaControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Layout Property

SubSchemaControl..::..Layout Property
SubSchemaControl Class See Also Send Feedback
Gets or sets the layout.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Layout Layout { get; set; }

Field Value

The layout.

See Also

SubSchemaControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaId Property

SubSchemaControl..::..SubSchemaId Property
SubSchemaControl Class See Also Send Feedback
Gets or sets the subschema id.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid SubSchemaId { get; set; }

Field Value

The sub schema id.

See Also

SubSchemaControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaListTable Class

SubSchemaListTable Class
Members See Also Send Feedback
Presents subschema list as table.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SubSchemaListTable : FieldControl

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Control
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..FieldControl
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..SubSchemaListTable

See Also

SubSchemaListTable Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaListTable Members

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTable Members
SubSchemaListTable Class Constructors Methods Properties See Also Send Feedback

The SubSchemaListTable type exposes the following members.

Constructors

 | Name | Description
Public method | SubSchemaListTable | Initializes a new instance of the SubSchemaListTable class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetColumn | Gets the column of specific name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Columns | Gets the control list.
Public property | Container | Gets the container. (Inherited from FieldControl.)
Public property | FieldDisplayName | Gets or sets the display name of the field. (Inherited from FieldControl.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from FieldControl.)
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | KeyType | Gets the type of the key. (Inherited from FieldControl.)
Public property | KeyVisualAttribute | Gets or sets the visual attribute. (Inherited from FieldControl.)
Public property | SchemaGuid | Gets or sets the schema GUID. (Inherited from FieldControl.)
Public property | SubSchemaId | Gets or sets the subschema id.
Public property | UnitAttribute | Gets the unit attribute. (Inherited from FieldControl.)
Public property | ValueType | Gets the type of the value. (Inherited from FieldControl.)
Public property | VisualAttribute | Gets or sets the visual attribute. (Inherited from FieldControl.)

See Also

SubSchemaListTable Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaListTable Constructor

SubSchemaListTable Constructor
SubSchemaListTable Class See Also Send Feedback
Initializes a new instance of the SubSchemaListTable class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaListTable(
    Guid schema,
    string fieldName,
    string displayName,
    SubSchemaListTableAttribute attribute,
    Guid subSchema,
    ContainerType container,
    Type valueType,
    Type keyType
)

Parameters

schema
Type: System..::..Guid
The schema.
fieldName
Type: System..::..String
Name of the field.
displayName
Type: System..::..String
The display name.
attribute
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaListTableAttribute
The attribute.
subSchema
Type: System..::..Guid
The subschema id.
container
Type: ContainerType
The container.
valueType
Type: System..::..Type
Type of the value.
keyType
Type: System..::..Type
Type of the key.

See Also

SubSchemaListTable Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaListTable Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTable Methods
SubSchemaListTable Class See Also Send Feedback

The SubSchemaListTable type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetColumn | Gets the column of specific name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SubSchemaListTable Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


GetColumn Method

SubSchemaListTable..::..GetColumn Method
SubSchemaListTable Class See Also Send Feedback
Gets the column of specific name.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public FieldControl GetColumn(
    string name
)

Parameters

name
Type: System..::..String
The name.

Return Value

See Also

SubSchemaListTable Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaListTable Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTable Properties
SubSchemaListTable Class See Also Send Feedback

The SubSchemaListTable type exposes the following members.

Properties

 | Name | Description
Public property | Columns | Gets the control list.
Public property | Container | Gets the container. (Inherited from FieldControl.)
Public property | FieldDisplayName | Gets or sets the display name of the field. (Inherited from FieldControl.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from FieldControl.)
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | KeyType | Gets the type of the key. (Inherited from FieldControl.)
Public property | KeyVisualAttribute | Gets or sets the visual attribute. (Inherited from FieldControl.)
Public property | SchemaGuid | Gets or sets the schema GUID. (Inherited from FieldControl.)
Public property | SubSchemaId | Gets or sets the subschema id.
Public property | UnitAttribute | Gets the unit attribute. (Inherited from FieldControl.)
Public property | ValueType | Gets the type of the value. (Inherited from FieldControl.)
Public property | VisualAttribute | Gets or sets the visual attribute. (Inherited from FieldControl.)

See Also

SubSchemaListTable Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Columns Property

SubSchemaListTable..::..Columns Property
SubSchemaListTable Class See Also Send Feedback
Gets the control list.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<FieldControl> Columns { get; private set; }

See Also

SubSchemaListTable Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


SubSchemaId Property

SubSchemaListTable..::..SubSchemaId Property
SubSchemaListTable Class See Also Send Feedback
Gets or sets the subschema id.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Guid SubSchemaId { get; set; }

Field Value

The sub schema id.

See Also

SubSchemaListTable Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TableCellIdentification Class

TableCellIdentification Class
Members See Also Send Feedback
Represents table identification.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class TableCellIdentification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..TableCellIdentification

See Also

TableCellIdentification Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TableCellIdentification Members

[image]

Structural Analysis and Code Checking API Reference Guide
TableCellIdentification Members
TableCellIdentification Class Constructors Methods Properties See Also Send Feedback

The TableCellIdentification type exposes the following members.

Constructors

 | Name | Description
Public method | TableCellIdentification | Initializes a new instance of the TableCellIdentification class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Column | Gets or sets the column.
Public property | Row | Gets or sets the row.

See Also

TableCellIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TableCellIdentification Constructor

TableCellIdentification Constructor
TableCellIdentification Class See Also Send Feedback
Initializes a new instance of the TableCellIdentification class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TableCellIdentification()

See Also

TableCellIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TableCellIdentification Methods

[image]

Structural Analysis and Code Checking API Reference Guide
TableCellIdentification Methods
TableCellIdentification Class See Also Send Feedback

The TableCellIdentification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TableCellIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TableCellIdentification Properties

[image]

Structural Analysis and Code Checking API Reference Guide
TableCellIdentification Properties
TableCellIdentification Class See Also Send Feedback

The TableCellIdentification type exposes the following members.

Properties

 | Name | Description
Public property | Column | Gets or sets the column.
Public property | Row | Gets or sets the row.

See Also

TableCellIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Column Property

TableCellIdentification..::..Column Property
TableCellIdentification Class See Also Send Feedback
Gets or sets the column.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Column { get; set; }

Field Value

The column.

See Also

TableCellIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Row Property

TableCellIdentification..::..Row Property
TableCellIdentification Class See Also Send Feedback
Gets or sets the row.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Row { get; set; }

Field Value

The row.

See Also

TableCellIdentification Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TextBlock Class

TextBlock Class
Members See Also Send Feedback
Represents the text block control

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class TextBlock : KeyControl

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Control
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..KeyControl
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..TextBlock

See Also

TextBlock Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TextBlock Members

[image]

Structural Analysis and Code Checking API Reference Guide
TextBlock Members
TextBlock Class Constructors Methods Properties See Also Send Feedback

The TextBlock type exposes the following members.

Constructors

 | Name | Description
Public method | TextBlock()()()() | Initializes a new instance of the TextBlock class.
Public method | TextBlock(String) | Initializes a new instance of the TextBlock class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlignWithRightColumn | Gets or sets a value indicating whether text should be aligned with right column.
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | Key | Gets or sets the key for image identification. (Inherited from KeyControl.)
Public property | Text | The text.

See Also

TextBlock Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TextBlock Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
TextBlock Constructor
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TextBlock()()()() | Initializes a new instance of the TextBlock class.
Public method | TextBlock(String) | Initializes a new instance of the TextBlock class.

See Also

TextBlock Class
TextBlock Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TextBlock Constructor

TextBlock Constructor
TextBlock Class See Also Send Feedback
Initializes a new instance of the TextBlock class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TextBlock()

See Also

TextBlock Class
TextBlock Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TextBlock Constructor (String)

TextBlock Constructor (String)
TextBlock Class See Also Send Feedback
Initializes a new instance of the TextBlock class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TextBlock(
    string text
)

Parameters

text
Type: System..::..String
The text.

See Also

TextBlock Class
TextBlock Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TextBlock Methods

[image]

Structural Analysis and Code Checking API Reference Guide
TextBlock Methods
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextBlock Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


TextBlock Properties

[image]

Structural Analysis and Code Checking API Reference Guide
TextBlock Properties
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Properties

 | Name | Description
Public property | AlignWithRightColumn | Gets or sets a value indicating whether text should be aligned with right column.
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | Key | Gets or sets the key for image identification. (Inherited from KeyControl.)
Public property | Text | The text.

See Also

TextBlock Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


AlignWithRightColumn Property

TextBlock..::..AlignWithRightColumn Property
TextBlock Class See Also Send Feedback
Gets or sets a value indicating whether text should be aligned with right column.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AlignWithRightColumn { get; set; }

Field Value

true if align with right column; otherwise, false.

See Also

TextBlock Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Text Property

TextBlock..::..Text Property
TextBlock Class See Also Send Feedback
The text.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Text { get; set; }

See Also

TextBlock Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValueChangedEventArgs Class

ValueChangedEventArgs Class
Members See Also Send Feedback
Represents arguments for value changed event.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ValueChangedEventArgs : SchemaEditorEventArgs

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..SchemaEditorEventArgs
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ValueChangedEventArgs

See Also

ValueChangedEventArgs Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValueChangedEventArgs Members

[image]

Structural Analysis and Code Checking API Reference Guide
ValueChangedEventArgs Members
ValueChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ValueChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ValueChangedEventArgs | Initializes a new instance of the ValueChangedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalInfo | Gets the additional info.
Public property | Context | Gets the context.
Public property | Document | Gets the document. (Inherited from SchemaEditorEventArgs.)
Public property | Editor | Gets the editor. (Inherited from SchemaEditorEventArgs.)
Public property | Entity | Gets the entity. (Inherited from SchemaEditorEventArgs.)
Public property | FieldEditor | Gets the field editor.
Public property | FieldName | Gets the name of the field.

See Also

ValueChangedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValueChangedEventArgs Constructor

ValueChangedEventArgs Constructor
ValueChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the ValueChangedEventArgs class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ValueChangedEventArgs(
    string fieldName,
    string context,
    IFieldEditor fieldEditor,
    Object additionalInfo,
    Object entity,
    Document document,
    ISchemaEditor editor
)

Parameters

fieldName
Type: System..::..String
Name of the field.
context
Type: System..::..String
fieldEditor
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..IFieldEditor
The field editor.
additionalInfo
Type: System..::..Object
The additional information.
entity
Type: System..::..Object
The entity.
document
Type: Document
The document.
editor
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ISchemaEditor
The editor.

See Also

ValueChangedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValueChangedEventArgs Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ValueChangedEventArgs Methods
ValueChangedEventArgs Class See Also Send Feedback

The ValueChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValueChangedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValueChangedEventArgs Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ValueChangedEventArgs Properties
ValueChangedEventArgs Class See Also Send Feedback

The ValueChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalInfo | Gets the additional info.
Public property | Context | Gets the context.
Public property | Document | Gets the document. (Inherited from SchemaEditorEventArgs.)
Public property | Editor | Gets the editor. (Inherited from SchemaEditorEventArgs.)
Public property | Entity | Gets the entity. (Inherited from SchemaEditorEventArgs.)
Public property | FieldEditor | Gets the field editor.
Public property | FieldName | Gets the name of the field.

See Also

ValueChangedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


AdditionalInfo Property

ValueChangedEventArgs..::..AdditionalInfo Property
ValueChangedEventArgs Class See Also Send Feedback
Gets the additional info.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object AdditionalInfo { get; private set; }

See Also

ValueChangedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Context Property

ValueChangedEventArgs..::..Context Property
ValueChangedEventArgs Class See Also Send Feedback
Gets the context.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Context { get; private set; }

See Also

ValueChangedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldEditor Property

ValueChangedEventArgs..::..FieldEditor Property
ValueChangedEventArgs Class See Also Send Feedback
Gets the field editor.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IFieldEditor FieldEditor { get; private set; }

See Also

ValueChangedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


FieldName Property

ValueChangedEventArgs..::..FieldName Property
ValueChangedEventArgs Class See Also Send Feedback
Gets the name of the field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string FieldName { get; private set; }

Field Value

The name of the field.

See Also

ValueChangedEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


ValueChangedHandler Delegate

ValueChangedHandler Delegate
See Also Send Feedback
Describes field validation event.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public delegate void ValueChangedHandler(
    IFieldEditor sender,
    Object additionalInformation
)

Parameters

sender
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..IFieldEditor
The sender.
additionalInformation
Type: System..::..Object
The additional information.

See Also

Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace


Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace

Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace
Send Feedback

Classes

 | Class | Description
Public class | CategoriesAttribute | Describes categories description. It should be placed as the attribute of whole class.
Public class | CategoryCheckBoxAttribute | Indicates that particular property will be connected with category header and will decide about the category enable state.
Public class | CheckBoxAttribute | Indicates that particular property will be edited with the CheckBox control.
Public class | CheckedListAttribute | Indicates that particular property will be edited with the CheckedList control. Limited to arrays only.
Public class | ComboBoxAttribute | Indicates that particular property will be edited with the ComboBox control. For simple data only.
Public class | ControlAttribute | Base class for all control attributes
Public class | CustomControlAttribute | Indicates that particular field should be edited with a custom control.
Public class | DataSourceFormatFieldAttribute | Base class for all data source based control attributes.
Public class | DefaultFieldControlAttribute | Indicates that particular property be edited with the control assigned in the default way by the system.
Public class | ElementCheckedListAttribute | Indicates that particular property will be edited with the ElementCheckedList control. Limited to arrays with ElementId instances.
Public class | ElementComboBoxAttribute | Indicates that particular property will be edited with ElementComboBox control. Limited to instances of ElementId type.
Public class | EnumControlAttribute | Indicates that particular property will be edited with EnumControl control.
Public class | FieldUIAttribute | Base class for all attribute classes used for describing visualization aspect of particular fields.
Public class | FormatFieldAttribute | Base class for all formatable controls attributes
Public class | GridCheckBoxAttribute | Indicates that particular property will be edited with grid control with checkboxes.
Public class | GridComboBoxAttribute | Indicates that particular property will be edited with ComboBox grid control.
Public class | GridCustomControlAttribute | Indicates that particular field should be edited with Custom grid control.
Public class | GridElementComboBoxAttribute | Indicates that particular property will be edited with Element ComboBox grid control.
Public class | GridEnumControlAttribute | Indicates that particular property will be edited with enum grid control.
Public class | GridIntNumericUpDownAttribute | Indicates that particular property will be edited with int NumericUpDown grid control.
Public class | GridKeyComboBoxAttribute | Indicates that particular key of the property will be edited with ComboBox grid control.
Public class | GridKeyTextBoxAttribute | Indicates that particular key of the field (only for maps) should be edited with TextBox grid control.
Public class | GridTextBoxAttribute | Indicates that particular property will be edited with TextBox grid control.
Public class | GridUnitNumericUpDownAttribute | Indicates that particular property will be edited with UnitNumericUpDown grid control.
Public class | GridUnitTextBoxAttribute | Indicates that particular property will be edited with UnitTextBox grid control.
Public class | GridXYZTextBoxAttribute | Indicates that particular property will be edited with TextBox grid control.
Public class | IntNumericUpDownAttribute | Indicates that particular property will be edited with IntNumericUpDown control.
Public class | ListTextBoxAttribute | Indicates that particular property will be edited with the ListTextBox control.
Public class | ListUnitTextBoxAttribute | Indicates that particular property will be edited with the ListUnitTextBox control.
Public class | NumericUpDownAttribute | Indicates that particular property will be edited with NumericUpDown control.
Public class | SubSchemaControlAttribute | Indicates that particular field should be edited with SubSchemaControl control.
Public class | SubSchemaDefaultAttribute | Indicates default attribute which will be used to visulize subSchema data when DefaultFieldControlAttribute will be set
Public class | SubSchemaEmbeddedControlAttribute | Indicates that particular field should be edited with SubSchemaControl embedded in layout.
Public class | SubSchemaListTableAttribute | Indicates that particular schema list will be presented as table.
Public class | TextBoxAttribute | Indicates that particular property will be edited with the TextBox control.
Public class | UnitCheckedListAttribute | Indicates that particular property will be edited with UnitCheckedList control.
Public class | UnitComboBoxAttribute | Indicates that particular property will be edited with UnitComboBox control.
Public class | UnitNumericUpDownAttribute | Indicates that particular property will be edited with UnitNumericUpDown control.
Public class | UnitTextBoxAttribute | Indicates that particular property will be edited with UnitTextBox control.
Public class | XYZTextBoxAttribute | Indicates that particular property will be edited with the XYZTextBox control.

Enumerations

 | Enumeration | Description
Public enumeration | PresentationItem | Represents option of item presentation
Public enumeration | PresentationMode | Represents option of enum presentation


CategoriesAttribute Class

CategoriesAttribute Class
Members See Also Send Feedback
Describes categories description. It should be placed as the attribute of whole class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CategoriesAttribute : ControlAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CategoriesAttribute

See Also

CategoriesAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoriesAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
CategoriesAttribute Members
CategoriesAttribute Class Constructors Methods Properties See Also Send Feedback

The CategoriesAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CategoriesAttribute(array<String>[]()[][]) | Initializes a new instance of the CategoriesAttribute class.
Public method | CategoriesAttribute(array<String>[]()[][], array<Int32>[]()[][]) | Initializes a new instance of the CategoriesAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoriesIndexes | Gets or sets the categories indexes.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CategoriesAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoriesAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
CategoriesAttribute Constructor
CategoriesAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CategoriesAttribute(array<String>[]()[][]) | Initializes a new instance of the CategoriesAttribute class.
Public method | CategoriesAttribute(array<String>[]()[][], array<Int32>[]()[][]) | Initializes a new instance of the CategoriesAttribute class.

See Also

CategoriesAttribute Class
CategoriesAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoriesAttribute Constructor (String[])

CategoriesAttribute Constructor (array<String>[]()[][])
CategoriesAttribute Class See Also Send Feedback
Initializes a new instance of the CategoriesAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CategoriesAttribute(
    params string[] categories
)

Parameters

categories
Type: array< System..::..String >[]()[][]
The categories. They will be ordered as they are input into the constructor.

See Also

CategoriesAttribute Class
CategoriesAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoriesAttribute Constructor (String[], Int32[])

CategoriesAttribute Constructor (array<String>[]()[][], array<Int32>[]()[][])
CategoriesAttribute Class See Also Send Feedback
Initializes a new instance of the CategoriesAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CategoriesAttribute(
    string[] categories,
    int[] indexes
)

Parameters

categories
Type: array< System..::..String >[]()[][]
The categories.
indexes
Type: array< System..::..Int32 >[]()[][]
The indexes where appropriate categories should be placed in layout.

See Also

CategoriesAttribute Class
CategoriesAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoriesAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CategoriesAttribute Methods
CategoriesAttribute Class See Also Send Feedback

The CategoriesAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CategoriesAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoriesAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CategoriesAttribute Properties
CategoriesAttribute Class See Also Send Feedback

The CategoriesAttribute type exposes the following members.

Properties

 | Name | Description
Public property | CategoriesIndexes | Gets or sets the categories indexes.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CategoriesAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoriesIndexes Property

CategoriesAttribute..::..CategoriesIndexes Property
CategoriesAttribute Class See Also Send Feedback
Gets or sets the categories indexes.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Dictionary<string, int> CategoriesIndexes { get; set; }

Field Value

The categories indexes.

See Also

CategoriesAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoryCheckBoxAttribute Class

CategoryCheckBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be connected with category header and will decide about the category enable state.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CategoryCheckBoxAttribute : CheckBoxAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CheckBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CategoryCheckBoxAttribute

See Also

CategoryCheckBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoryCheckBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
CategoryCheckBoxAttribute Members
CategoryCheckBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The CategoryCheckBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CategoryCheckBoxAttribute()()()() | Initializes a new instance of the CategoryCheckBoxAttribute class.
Public method | CategoryCheckBoxAttribute(String) | Initializes a new instance of the CategoryCheckBoxAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

CategoryCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoryCheckBoxAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
CategoryCheckBoxAttribute Constructor
CategoryCheckBoxAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CategoryCheckBoxAttribute()()()() | Initializes a new instance of the CategoryCheckBoxAttribute class.
Public method | CategoryCheckBoxAttribute(String) | Initializes a new instance of the CategoryCheckBoxAttribute class.

See Also

CategoryCheckBoxAttribute Class
CategoryCheckBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoryCheckBoxAttribute Constructor

CategoryCheckBoxAttribute Constructor
CategoryCheckBoxAttribute Class See Also Send Feedback
Initializes a new instance of the CategoryCheckBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CategoryCheckBoxAttribute()

See Also

CategoryCheckBoxAttribute Class
CategoryCheckBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoryCheckBoxAttribute Constructor (String)

CategoryCheckBoxAttribute Constructor (String)
CategoryCheckBoxAttribute Class See Also Send Feedback
Initializes a new instance of the CategoryCheckBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CategoryCheckBoxAttribute(
    string category
)

Parameters

category
Type: System..::..String
The category.

See Also

CategoryCheckBoxAttribute Class
CategoryCheckBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoryCheckBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CategoryCheckBoxAttribute Methods
CategoryCheckBoxAttribute Class See Also Send Feedback

The CategoryCheckBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

CategoryCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CategoryCheckBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CategoryCheckBoxAttribute Properties
CategoryCheckBoxAttribute Class See Also Send Feedback

The CategoryCheckBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

CategoryCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckBoxAttribute Class

CheckBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with the CheckBox control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CheckBoxAttribute : FieldUIAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CheckBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CategoryCheckBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridCheckBoxAttribute

See Also

CheckBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
CheckBoxAttribute Members
CheckBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The CheckBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CheckBoxAttribute | Initializes a new instance of the CheckBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

CheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckBoxAttribute Constructor

CheckBoxAttribute Constructor
CheckBoxAttribute Class See Also Send Feedback
Initializes a new instance of the CheckBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CheckBoxAttribute()

See Also

CheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CheckBoxAttribute Methods
CheckBoxAttribute Class See Also Send Feedback

The CheckBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

CheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CheckBoxAttribute Properties
CheckBoxAttribute Class See Also Send Feedback

The CheckBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

CheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckedListAttribute Class

CheckedListAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with the CheckedList control. Limited to arrays only.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CheckedListAttribute : DataSourceFormatFieldAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CheckedListAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ElementCheckedListAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitCheckedListAttribute

See Also

CheckedListAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckedListAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
CheckedListAttribute Members
CheckedListAttribute Class Constructors Methods Properties See Also Send Feedback

The CheckedListAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CheckedListAttribute()()()() | Initializes a new instance of the CheckedListAttribute class.
Public method | CheckedListAttribute(array<Object>[]()[][]) | Initializes a new instance of the CheckedListAttribute class.
Public method | CheckedListAttribute(String, Type) | Initializes a new instance of the CheckedListAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

CheckedListAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckedListAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
CheckedListAttribute Constructor
CheckedListAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CheckedListAttribute()()()() | Initializes a new instance of the CheckedListAttribute class.
Public method | CheckedListAttribute(array<Object>[]()[][]) | Initializes a new instance of the CheckedListAttribute class.
Public method | CheckedListAttribute(String, Type) | Initializes a new instance of the CheckedListAttribute class.

See Also

CheckedListAttribute Class
CheckedListAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckedListAttribute Constructor

CheckedListAttribute Constructor
CheckedListAttribute Class See Also Send Feedback
Initializes a new instance of the CheckedListAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CheckedListAttribute()

See Also

CheckedListAttribute Class
CheckedListAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckedListAttribute Constructor (Object[])

CheckedListAttribute Constructor (array<Object>[]()[][])
CheckedListAttribute Class See Also Send Feedback
Initializes a new instance of the CheckedListAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CheckedListAttribute(
    params Object[] items
)

Parameters

items
Type: array< System..::..Object >[]()[][]
The list of items.

See Also

CheckedListAttribute Class
CheckedListAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckedListAttribute Constructor (String, Type)

CheckedListAttribute Constructor (String, Type)
CheckedListAttribute Class See Also Send Feedback
Initializes a new instance of the CheckedListAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CheckedListAttribute(
    string dataSourceKey,
    Type format
)

Parameters

dataSourceKey
Type: System..::..String
The data source key.
format
Type: System..::..Type
The format.

See Also

CheckedListAttribute Class
CheckedListAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckedListAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CheckedListAttribute Methods
CheckedListAttribute Class See Also Send Feedback

The CheckedListAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

CheckedListAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CheckedListAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CheckedListAttribute Properties
CheckedListAttribute Class See Also Send Feedback

The CheckedListAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

CheckedListAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ComboBoxAttribute Class

ComboBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with the ComboBox control. For simple data only.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ComboBoxAttribute : DataSourceFormatFieldAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ElementComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridKeyComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitComboBoxAttribute

See Also

ComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ComboBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ComboBoxAttribute Members
ComboBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The ComboBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBoxAttribute()()()() | Initializes a new instance of the ComboBoxAttribute class.
Public method | ComboBoxAttribute(array<Object>[]()[][]) | Initializes a new instance of the ComboBoxAttribute class.
Public method | ComboBoxAttribute(String, Type) | Initializes a new instance of the ComboBoxAttribute class.
Public method | ComboBoxAttribute(Type, array<Object>[]()[][]) | Initializes a new instance of the ComboBoxAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ComboBoxAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ComboBoxAttribute Constructor
ComboBoxAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComboBoxAttribute()()()() | Initializes a new instance of the ComboBoxAttribute class.
Public method | ComboBoxAttribute(array<Object>[]()[][]) | Initializes a new instance of the ComboBoxAttribute class.
Public method | ComboBoxAttribute(String, Type) | Initializes a new instance of the ComboBoxAttribute class.
Public method | ComboBoxAttribute(Type, array<Object>[]()[][]) | Initializes a new instance of the ComboBoxAttribute class.

See Also

ComboBoxAttribute Class
ComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ComboBoxAttribute Constructor

ComboBoxAttribute Constructor
ComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the ComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ComboBoxAttribute()

See Also

ComboBoxAttribute Class
ComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ComboBoxAttribute Constructor (Object[])

ComboBoxAttribute Constructor (array<Object>[]()[][])
ComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the ComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ComboBoxAttribute(
    params Object[] items
)

Parameters

items
Type: array< System..::..Object >[]()[][]
The list of items.

See Also

ComboBoxAttribute Class
ComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ComboBoxAttribute Constructor (String, Type)

ComboBoxAttribute Constructor (String, Type)
ComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the ComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ComboBoxAttribute(
    string dataSourceKey,
    Type format
)

Parameters

dataSourceKey
Type: System..::..String
format
Type: System..::..Type

See Also

ComboBoxAttribute Class
ComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ComboBoxAttribute Constructor (Type, Object[])

ComboBoxAttribute Constructor (Type, array<Object>[]()[][])
ComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the ComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ComboBoxAttribute(
    Type format,
    params Object[] items
)

Parameters

format
Type: System..::..Type
The format.
items
Type: array< System..::..Object >[]()[][]
The list of items.

See Also

ComboBoxAttribute Class
ComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ComboBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ComboBoxAttribute Methods
ComboBoxAttribute Class See Also Send Feedback

The ComboBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

ComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ComboBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ComboBoxAttribute Properties
ComboBoxAttribute Class See Also Send Feedback

The ComboBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ControlAttribute Class

ControlAttribute Class
Members See Also Send Feedback
Base class for all control attributes

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class ControlAttribute : Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CategoriesAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute

See Also

ControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ControlAttribute Members
ControlAttribute Class Constructors Methods Properties See Also Send Feedback

The ControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ControlAttribute | Initializes a new instance of the ControlAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category).
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ControlAttribute Constructor

ControlAttribute Constructor
ControlAttribute Class See Also Send Feedback
Initializes a new instance of the ControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ControlAttribute()

See Also

ControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ControlAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ControlAttribute Methods
ControlAttribute Class See Also Send Feedback

The ControlAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ControlAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ControlAttribute Properties
ControlAttribute Class See Also Send Feedback

The ControlAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category).
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Index Property

ControlAttribute..::..Index Property
ControlAttribute Class See Also Send Feedback
Decides about position of the property in UI container it belongs to (e.g. Category).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int Index { get; set; }

See Also

ControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Localizable Property

ControlAttribute..::..Localizable Property
ControlAttribute Class See Also Send Feedback
Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Localizable { get; set; }

See Also

ControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CustomControlAttribute Class

CustomControlAttribute Class
Members See Also Send Feedback
Indicates that particular field should be edited with a custom control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CustomControlAttribute : FieldUIAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CustomControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridCustomControlAttribute

See Also

CustomControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CustomControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
CustomControlAttribute Members
CustomControlAttribute Class Constructors Methods Properties See Also Send Feedback

The CustomControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CustomControlAttribute()()()() | Initializes a new instance of the CustomControlAttribute class.
Public method | CustomControlAttribute(Type, Boolean) | Initializes a new instance of the CustomControlAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetControlInstance | Returns custom editor of the field.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Control | The editor of the field.
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Span | Gets or sets a value indicating whether this CustomControlAttribute control should be extended for all columns of the grid.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

CustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CustomControlAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
CustomControlAttribute Constructor
CustomControlAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomControlAttribute()()()() | Initializes a new instance of the CustomControlAttribute class.
Public method | CustomControlAttribute(Type, Boolean) | Initializes a new instance of the CustomControlAttribute class.

See Also

CustomControlAttribute Class
CustomControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CustomControlAttribute Constructor

CustomControlAttribute Constructor
CustomControlAttribute Class See Also Send Feedback
Initializes a new instance of the CustomControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CustomControlAttribute()

See Also

CustomControlAttribute Class
CustomControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CustomControlAttribute Constructor (Type, Boolean)

CustomControlAttribute Constructor (Type, Boolean)
CustomControlAttribute Class See Also Send Feedback
Initializes a new instance of the CustomControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public CustomControlAttribute(
    Type control,
    bool span
)

Parameters

control
Type: System..::..Type
The control.
span
Type: System..::..Boolean
if set to true the control will be extended to all columns.

See Also

CustomControlAttribute Class
CustomControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CustomControlAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CustomControlAttribute Methods
CustomControlAttribute Class See Also Send Feedback

The CustomControlAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetControlInstance | Returns custom editor of the field.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

CustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetControlInstance Method

CustomControlAttribute..::..GetControlInstance Method
CustomControlAttribute Class See Also Send Feedback
Returns custom editor of the field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual IFieldEditor GetControlInstance()

Return Value

The editor.

See Also

CustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


CustomControlAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
CustomControlAttribute Properties
CustomControlAttribute Class See Also Send Feedback

The CustomControlAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Control | The editor of the field.
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Span | Gets or sets a value indicating whether this CustomControlAttribute control should be extended for all columns of the grid.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

CustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Control Property

CustomControlAttribute..::..Control Property
CustomControlAttribute Class See Also Send Feedback
The editor of the field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type Control { get; set; }

See Also

CustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Span Property

CustomControlAttribute..::..Span Property
CustomControlAttribute Class See Also Send Feedback
Gets or sets a value indicating whether this CustomControlAttribute control should be extended for all columns of the grid.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Span { get; set; }

Field Value

true if span; otherwise, false.

See Also

CustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DataSourceFormatFieldAttribute Class

DataSourceFormatFieldAttribute Class
Members See Also Send Feedback
Base class for all data source based control attributes.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class DataSourceFormatFieldAttribute : FormatFieldAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CheckedListAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ComboBoxAttribute

See Also

DataSourceFormatFieldAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DataSourceFormatFieldAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
DataSourceFormatFieldAttribute Members
DataSourceFormatFieldAttribute Class Constructors Methods Fields Properties See Also Send Feedback

The DataSourceFormatFieldAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | DataSourceFormatFieldAttribute()()()() | Initializes a new instance of the DataSourceFormatFieldAttribute class.
Public method | DataSourceFormatFieldAttribute(String, Type) | Initializes a new instance of the DataSourceFormatFieldAttribute class.
Public method | DataSourceFormatFieldAttribute(Type, array<Object>[]()[][]) | Initializes a new instance of the DataSourceFormatFieldAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Fields

Name | Description
PropertyDataSource | Describes attribute indicating the datasource.
PropertyDataSourceKey | Describes attribute indicating the key of datasource.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls.
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items.
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

DataSourceFormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DataSourceFormatFieldAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
DataSourceFormatFieldAttribute Constructor
DataSourceFormatFieldAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataSourceFormatFieldAttribute()()()() | Initializes a new instance of the DataSourceFormatFieldAttribute class.
Public method | DataSourceFormatFieldAttribute(String, Type) | Initializes a new instance of the DataSourceFormatFieldAttribute class.
Public method | DataSourceFormatFieldAttribute(Type, array<Object>[]()[][]) | Initializes a new instance of the DataSourceFormatFieldAttribute class.

See Also

DataSourceFormatFieldAttribute Class
DataSourceFormatFieldAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DataSourceFormatFieldAttribute Constructor

DataSourceFormatFieldAttribute Constructor
DataSourceFormatFieldAttribute Class See Also Send Feedback
Initializes a new instance of the DataSourceFormatFieldAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DataSourceFormatFieldAttribute()

See Also

DataSourceFormatFieldAttribute Class
DataSourceFormatFieldAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DataSourceFormatFieldAttribute Constructor (String, Type)

DataSourceFormatFieldAttribute Constructor (String, Type)
DataSourceFormatFieldAttribute Class See Also Send Feedback
Initializes a new instance of the DataSourceFormatFieldAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DataSourceFormatFieldAttribute(
    string dataSourceKey,
    Type format
)

Parameters

dataSourceKey
Type: System..::..String
The data source key.
format
Type: System..::..Type
The format.

See Also

DataSourceFormatFieldAttribute Class
DataSourceFormatFieldAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DataSourceFormatFieldAttribute Constructor (Type, Object[])

DataSourceFormatFieldAttribute Constructor (Type, array<Object>[]()[][])
DataSourceFormatFieldAttribute Class See Also Send Feedback
Initializes a new instance of the DataSourceFormatFieldAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DataSourceFormatFieldAttribute(
    Type format,
    params Object[] items
)

Parameters

format
Type: System..::..Type
The format.
items
Type: array< System..::..Object >[]()[][]
The items.

See Also

DataSourceFormatFieldAttribute Class
DataSourceFormatFieldAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DataSourceFormatFieldAttribute Fields

[image]

Structural Analysis and Code Checking API Reference Guide
DataSourceFormatFieldAttribute Fields
DataSourceFormatFieldAttribute Class See Also Send Feedback

The DataSourceFormatFieldAttribute type exposes the following members.

Fields

Name | Description
PropertyDataSource | Describes attribute indicating the datasource.
PropertyDataSourceKey | Describes attribute indicating the key of datasource.

See Also

DataSourceFormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyDataSource Field

DataSourceFormatFieldAttribute..::..PropertyDataSource Field
DataSourceFormatFieldAttribute Class See Also Send Feedback
Describes attribute indicating the datasource.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyDataSource

See Also

DataSourceFormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyDataSourceKey Field

DataSourceFormatFieldAttribute..::..PropertyDataSourceKey Field
DataSourceFormatFieldAttribute Class See Also Send Feedback
Describes attribute indicating the key of datasource.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyDataSourceKey

See Also

DataSourceFormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DataSourceFormatFieldAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DataSourceFormatFieldAttribute Methods
DataSourceFormatFieldAttribute Class See Also Send Feedback

The DataSourceFormatFieldAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

DataSourceFormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DataSourceFormatFieldAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DataSourceFormatFieldAttribute Properties
DataSourceFormatFieldAttribute Class See Also Send Feedback

The DataSourceFormatFieldAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls.
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items.
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

DataSourceFormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DataSourceKey Property

DataSourceFormatFieldAttribute..::..DataSourceKey Property
DataSourceFormatFieldAttribute Class See Also Send Feedback
Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string DataSourceKey { get; set; }

Field Value

The data source key.

See Also

DataSourceFormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Items Property

DataSourceFormatFieldAttribute..::..Items Property
DataSourceFormatFieldAttribute Class See Also Send Feedback
The list of items.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<Object> Items { get; set; }

See Also

DataSourceFormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultFieldControlAttribute Class

DefaultFieldControlAttribute Class
Members See Also Send Feedback
Indicates that particular property be edited with the control assigned in the default way by the system.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DefaultFieldControlAttribute : FieldUIAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DefaultFieldControlAttribute

See Also

DefaultFieldControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultFieldControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultFieldControlAttribute Members
DefaultFieldControlAttribute Class Constructors Methods Properties See Also Send Feedback

The DefaultFieldControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultFieldControlAttribute | Initializes a new instance of the DefaultFieldControlAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

DefaultFieldControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultFieldControlAttribute Constructor

DefaultFieldControlAttribute Constructor
DefaultFieldControlAttribute Class See Also Send Feedback
Initializes a new instance of the DefaultFieldControlAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DefaultFieldControlAttribute()

See Also

DefaultFieldControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultFieldControlAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultFieldControlAttribute Methods
DefaultFieldControlAttribute Class See Also Send Feedback

The DefaultFieldControlAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

DefaultFieldControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultFieldControlAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
DefaultFieldControlAttribute Properties
DefaultFieldControlAttribute Class See Also Send Feedback

The DefaultFieldControlAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

DefaultFieldControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementCheckedListAttribute Class

ElementCheckedListAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with the ElementCheckedList control. Limited to arrays with ElementId instances.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementCheckedListAttribute : CheckedListAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CheckedListAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ElementCheckedListAttribute

See Also

ElementCheckedListAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementCheckedListAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementCheckedListAttribute Members
ElementCheckedListAttribute Class Constructors Methods Properties See Also Send Feedback

The ElementCheckedListAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ElementCheckedListAttribute()()()() | Initializes a new instance of the ElementCheckedListAttribute class.
Public method | ElementCheckedListAttribute(array<Object>[]()[][]) | Initializes a new instance of the ElementCheckedListAttribute class.
Public method | ElementCheckedListAttribute(String) | Initializes a new instance of the ElementCheckedListAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ElementCheckedListAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementCheckedListAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ElementCheckedListAttribute Constructor
ElementCheckedListAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementCheckedListAttribute()()()() | Initializes a new instance of the ElementCheckedListAttribute class.
Public method | ElementCheckedListAttribute(array<Object>[]()[][]) | Initializes a new instance of the ElementCheckedListAttribute class.
Public method | ElementCheckedListAttribute(String) | Initializes a new instance of the ElementCheckedListAttribute class.

See Also

ElementCheckedListAttribute Class
ElementCheckedListAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementCheckedListAttribute Constructor

ElementCheckedListAttribute Constructor
ElementCheckedListAttribute Class See Also Send Feedback
Initializes a new instance of the ElementCheckedListAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementCheckedListAttribute()

See Also

ElementCheckedListAttribute Class
ElementCheckedListAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementCheckedListAttribute Constructor (Object[])

ElementCheckedListAttribute Constructor (array<Object>[]()[][])
ElementCheckedListAttribute Class See Also Send Feedback
Initializes a new instance of the ElementCheckedListAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementCheckedListAttribute(
    params Object[] items
)

Parameters

items
Type: array< System..::..Object >[]()[][]
The list of items.

See Also

ElementCheckedListAttribute Class
ElementCheckedListAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementCheckedListAttribute Constructor (String)

ElementCheckedListAttribute Constructor (String)
ElementCheckedListAttribute Class See Also Send Feedback
Initializes a new instance of the ElementCheckedListAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementCheckedListAttribute(
    string dataSourceKey
)

Parameters

dataSourceKey
Type: System..::..String
The data source key.

See Also

ElementCheckedListAttribute Class
ElementCheckedListAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementCheckedListAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ElementCheckedListAttribute Methods
ElementCheckedListAttribute Class See Also Send Feedback

The ElementCheckedListAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

ElementCheckedListAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementCheckedListAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ElementCheckedListAttribute Properties
ElementCheckedListAttribute Class See Also Send Feedback

The ElementCheckedListAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ElementCheckedListAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementComboBoxAttribute Class

ElementComboBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with ElementComboBox control. Limited to instances of ElementId type.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementComboBoxAttribute : ComboBoxAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ElementComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridElementComboBoxAttribute

See Also

ElementComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementComboBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementComboBoxAttribute Members
ElementComboBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The ElementComboBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ElementComboBoxAttribute()()()() | Initializes a new instance of the ElementComboBoxAttribute class.
Public method | ElementComboBoxAttribute(array<Object>[]()[][]) | Initializes a new instance of the ElementComboBoxAttribute class.
Public method | ElementComboBoxAttribute(String) | Initializes a new instance of the ElementComboBoxAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementComboBoxAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ElementComboBoxAttribute Constructor
ElementComboBoxAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementComboBoxAttribute()()()() | Initializes a new instance of the ElementComboBoxAttribute class.
Public method | ElementComboBoxAttribute(array<Object>[]()[][]) | Initializes a new instance of the ElementComboBoxAttribute class.
Public method | ElementComboBoxAttribute(String) | Initializes a new instance of the ElementComboBoxAttribute class.

See Also

ElementComboBoxAttribute Class
ElementComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementComboBoxAttribute Constructor

ElementComboBoxAttribute Constructor
ElementComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the ElementComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementComboBoxAttribute()

See Also

ElementComboBoxAttribute Class
ElementComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementComboBoxAttribute Constructor (Object[])

ElementComboBoxAttribute Constructor (array<Object>[]()[][])
ElementComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the ElementComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementComboBoxAttribute(
    params Object[] items
)

Parameters

items
Type: array< System..::..Object >[]()[][]
The items.

See Also

ElementComboBoxAttribute Class
ElementComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementComboBoxAttribute Constructor (String)

ElementComboBoxAttribute Constructor (String)
ElementComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the ElementComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementComboBoxAttribute(
    string dataSourceKey
)

Parameters

dataSourceKey
Type: System..::..String
The data source key.

See Also

ElementComboBoxAttribute Class
ElementComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementComboBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ElementComboBoxAttribute Methods
ElementComboBoxAttribute Class See Also Send Feedback

The ElementComboBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

ElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ElementComboBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ElementComboBoxAttribute Properties
ElementComboBoxAttribute Class See Also Send Feedback

The ElementComboBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


EnumControlAttribute Class

EnumControlAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with EnumControl control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class EnumControlAttribute : FieldUIAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..EnumControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridEnumControlAttribute

See Also

EnumControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


EnumControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
EnumControlAttribute Members
EnumControlAttribute Class Constructors Methods Properties See Also Send Feedback

The EnumControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | EnumControlAttribute()()()() | Initializes a new instance of the EnumControlAttribute class.
Public method | EnumControlAttribute(Type, PresentationMode, PresentationItem) | Initializes a new instance of the EnumControlAttribute class.
Public method | EnumControlAttribute(Type, PresentationMode, PresentationItem, array<String>[]()[][], array<Object>[]()[][]) | Initializes a new instance of the EnumControlAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | EnumType | Gets or sets the type of the enum.
Public property | ImageSize | Gets or sets the size of the image.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Item | Gets or sets the presentation item.
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | Presentation | Gets or sets the presentation mode.
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | SubSchemasToValues | Gets or sets the sub schemas to values map.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

EnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


EnumControlAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
EnumControlAttribute Constructor
EnumControlAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnumControlAttribute()()()() | Initializes a new instance of the EnumControlAttribute class.
Public method | EnumControlAttribute(Type, PresentationMode, PresentationItem) | Initializes a new instance of the EnumControlAttribute class.
Public method | EnumControlAttribute(Type, PresentationMode, PresentationItem, array<String>[]()[][], array<Object>[]()[][]) | Initializes a new instance of the EnumControlAttribute class.

See Also

EnumControlAttribute Class
EnumControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


EnumControlAttribute Constructor

EnumControlAttribute Constructor
EnumControlAttribute Class See Also Send Feedback
Initializes a new instance of the EnumControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public EnumControlAttribute()

See Also

EnumControlAttribute Class
EnumControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


EnumControlAttribute Constructor (Type, PresentationMode, PresentationItem)

EnumControlAttribute Constructor (Type, PresentationMode, PresentationItem)
EnumControlAttribute Class See Also Send Feedback
Initializes a new instance of the EnumControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public EnumControlAttribute(
    Type enumType,
    PresentationMode presentationMode,
    PresentationItem presentationItem
)

Parameters

enumType
Type: System..::..Type
Type of the enum.
presentationMode
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationMode
The presentation mode.
presentationItem
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationItem
The presentation item.

See Also

EnumControlAttribute Class
EnumControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


EnumControlAttribute Constructor (Type, PresentationMode, PresentationItem, String[], Object[])

EnumControlAttribute Constructor (Type, PresentationMode, PresentationItem, array<String>[]()[][], array<Object>[]()[][])
EnumControlAttribute Class See Also Send Feedback
Initializes a new instance of the EnumControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public EnumControlAttribute(
    Type enumType,
    PresentationMode presentationMode,
    PresentationItem presentationItem,
    string[] subSchemasFields,
    Object[] subSchemasAssosiatedValues
)

Parameters

enumType
Type: System..::..Type
Type of the enum.
presentationMode
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationMode
The presentation mode.
presentationItem
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationItem
The presentation item.
subSchemasFields
Type: array< System..::..String >[]()[][]
The sub schemas fields names.
subSchemasAssosiatedValues
Type: array< System..::..Object >[]()[][]
Values associated with subschemas fields defined in SubSchemasFields (it has to have the same number of items).

See Also

EnumControlAttribute Class
EnumControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


EnumControlAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
EnumControlAttribute Methods
EnumControlAttribute Class See Also Send Feedback

The EnumControlAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

EnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


EnumControlAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
EnumControlAttribute Properties
EnumControlAttribute Class See Also Send Feedback

The EnumControlAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | EnumType | Gets or sets the type of the enum.
Public property | ImageSize | Gets or sets the size of the image.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Item | Gets or sets the presentation item.
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | Presentation | Gets or sets the presentation mode.
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | SubSchemasToValues | Gets or sets the sub schemas to values map.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

EnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


EnumType Property

EnumControlAttribute..::..EnumType Property
EnumControlAttribute Class See Also Send Feedback
Gets or sets the type of the enum.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type EnumType { get; set; }

Field Value

The type of the enum.

See Also

EnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ImageSize Property

EnumControlAttribute..::..ImageSize Property
EnumControlAttribute Class See Also Send Feedback
Gets or sets the size of the image.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ImageSize ImageSize { get; set; }

Field Value

The size.

See Also

EnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Item Property

EnumControlAttribute..::..Item Property
EnumControlAttribute Class See Also Send Feedback
Gets or sets the presentation item.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public PresentationItem Item { get; set; }

Field Value

The item.

See Also

EnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Presentation Property

EnumControlAttribute..::..Presentation Property
EnumControlAttribute Class See Also Send Feedback
Gets or sets the presentation mode.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public PresentationMode Presentation { get; set; }

Field Value

The presentation.

See Also

EnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemasToValues Property

EnumControlAttribute..::..SubSchemasToValues Property
EnumControlAttribute Class See Also Send Feedback
Gets or sets the sub schemas to values map.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Dictionary<Object, string> SubSchemasToValues { get; set; }

Field Value

The sub schemas to values.

See Also

EnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FieldUIAttribute Class

FieldUIAttribute Class
Members See Also Send Feedback
Base class for all attribute classes used for describing visualization aspect of particular fields.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class FieldUIAttribute : ControlAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CheckBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CustomControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DefaultFieldControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..EnumControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaEmbeddedControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaListTableAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitTextBoxAttribute

See Also

FieldUIAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FieldUIAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
FieldUIAttribute Members
FieldUIAttribute Class Constructors Methods Fields Properties See Also Send Feedback

The FieldUIAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | FieldUIAttribute | Initializes the instance of FieldUIAttribute

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | GetFieldUIAttribute | Returns the UI attribute for specific field searched among input types.
Public method | GetFieldValueChanged | Gets the field value changed observer.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name.

Fields

Name | Description
PropertyIsEnabled | Describes attribute indicating if the field is enabled.
PropertyIsVisible | Describes attribute indicating if the field is visible.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag.
Public property | Context | Additional information used for instance by IResource interface to help user identify the field.
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled.
Public property | IsVisible | Indicates if the field is visible.
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription |
Public property | Tooltip | Gets or sets the tooltip.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FieldUIAttribute Constructor

FieldUIAttribute Constructor
FieldUIAttribute Class See Also Send Feedback
Initializes the instance of FieldUIAttribute

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public FieldUIAttribute()

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FieldUIAttribute Fields

[image]

Structural Analysis and Code Checking API Reference Guide
FieldUIAttribute Fields
FieldUIAttribute Class See Also Send Feedback

The FieldUIAttribute type exposes the following members.

Fields

Name | Description
PropertyIsEnabled | Describes attribute indicating if the field is enabled.
PropertyIsVisible | Describes attribute indicating if the field is visible.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyIsEnabled Field

FieldUIAttribute..::..PropertyIsEnabled Field
FieldUIAttribute Class See Also Send Feedback
Describes attribute indicating if the field is enabled.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyIsEnabled

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyIsVisible Field

FieldUIAttribute..::..PropertyIsVisible Field
FieldUIAttribute Class See Also Send Feedback
Describes attribute indicating if the field is visible.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyIsVisible

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FieldUIAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
FieldUIAttribute Methods
FieldUIAttribute Class See Also Send Feedback

The FieldUIAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | GetFieldUIAttribute | Returns the UI attribute for specific field searched among input types.
Public method | GetFieldValueChanged | Gets the field value changed observer.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetFieldUIAttribute Method

FieldUIAttribute..::..GetFieldUIAttribute Method
FieldUIAttribute Class See Also Send Feedback
Returns the UI attribute for specific field searched among input types.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static FieldUIAttribute GetFieldUIAttribute(
    Field field,
    params Type[] types
)

Parameters

field
Type: Field
The field.
types
Type: array< System..::..Type >[]()[][]
The list of types.

Return Value

The UI attribute.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetFieldValueChanged Method

FieldUIAttribute..::..GetFieldValueChanged Method
FieldUIAttribute Class See Also Send Feedback
Gets the field value changed observer.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual IFieldValueChanged GetFieldValueChanged()

Return Value

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SetProperties Method

FieldUIAttribute..::..SetProperties Method
FieldUIAttribute Class See Also Send Feedback
Sets the properties based on other attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void SetProperties(
    FieldUIAttribute att
)

Parameters

att
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
The att.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Validate Method

FieldUIAttribute..::..Validate Method
FieldUIAttribute Class See Also Send Feedback
Validates the specified name.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void Validate(
    string name,
    Type type,
    ContainerType container
)

Parameters

name
Type: System..::..String
The name.
type
Type: System..::..Type
The type.
container
Type: ContainerType
The container.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FieldUIAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
FieldUIAttribute Properties
FieldUIAttribute Class See Also Send Feedback

The FieldUIAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag.
Public property | Context | Additional information used for instance by IResource interface to help user identify the field.
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled.
Public property | IsVisible | Indicates if the field is visible.
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription |
Public property | Tooltip | Gets or sets the tooltip.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Category Property

FieldUIAttribute..::..Category Property
FieldUIAttribute Class See Also Send Feedback
Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Category { get; set; }

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Context Property

FieldUIAttribute..::..Context Property
FieldUIAttribute Class See Also Send Feedback
Additional information used for instance by IResource interface to help user identify the field.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Context { get; set; }

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Description Property

FieldUIAttribute..::..Description Property
FieldUIAttribute Class See Also Send Feedback
The description of the field. If null the name from the schema will be taken. Supports localizable flag.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Description { get; set; }

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


IsEnabled Property

FieldUIAttribute..::..IsEnabled Property
FieldUIAttribute Class See Also Send Feedback
Indicates if the field is enabled.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsEnabled { get; set; }

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


IsVisible Property

FieldUIAttribute..::..IsVisible Property
FieldUIAttribute Class See Also Send Feedback
Indicates if the field is visible.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool IsVisible { get; set; }

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SetDescription Property

FieldUIAttribute..::..SetDescription Property
FieldUIAttribute Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool SetDescription { get; set; }

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Tooltip Property

FieldUIAttribute..::..Tooltip Property
FieldUIAttribute Class See Also Send Feedback
Gets or sets the tooltip.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Tooltip { get; set; }

Field Value

The tooltip.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ValueChangedObserver Property

FieldUIAttribute..::..ValueChangedObserver Property
FieldUIAttribute Class See Also Send Feedback
Gets or sets the value changed observer.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type ValueChangedObserver { get; set; }

Field Value

The value changed observer.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FormatFieldAttribute Class

FormatFieldAttribute Class
Members See Also Send Feedback
Base class for all formatable controls attributes

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class FormatFieldAttribute : FieldUIAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute

See Also

FormatFieldAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FormatFieldAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
FormatFieldAttribute Members
FormatFieldAttribute Class Constructors Methods Properties See Also Send Feedback

The FormatFieldAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | FormatFieldAttribute()()()() | Initializes a new instance of the FormatFieldAttribute class.
Public method | FormatFieldAttribute(Type) | Initializes a new instance of the FormatFieldAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

FormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FormatFieldAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
FormatFieldAttribute Constructor
FormatFieldAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FormatFieldAttribute()()()() | Initializes a new instance of the FormatFieldAttribute class.
Public method | FormatFieldAttribute(Type) | Initializes a new instance of the FormatFieldAttribute class.

See Also

FormatFieldAttribute Class
FormatFieldAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FormatFieldAttribute Constructor

FormatFieldAttribute Constructor
FormatFieldAttribute Class See Also Send Feedback
Initializes a new instance of the FormatFieldAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public FormatFieldAttribute()

See Also

FormatFieldAttribute Class
FormatFieldAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FormatFieldAttribute Constructor (Type)

FormatFieldAttribute Constructor (Type)
FormatFieldAttribute Class See Also Send Feedback
Initializes a new instance of the FormatFieldAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public FormatFieldAttribute(
    Type fieldFormat
)

Parameters

fieldFormat
Type: System..::..Type
The field format.

See Also

FormatFieldAttribute Class
FormatFieldAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FormatFieldAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
FormatFieldAttribute Methods
FormatFieldAttribute Class See Also Send Feedback

The FormatFieldAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

FormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetFieldFormat Method

FormatFieldAttribute..::..GetFieldFormat Method
FormatFieldAttribute Class See Also Send Feedback
Gets the field format.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual IFieldFormat GetFieldFormat()

Return Value

See Also

FormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FormatFieldAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
FormatFieldAttribute Properties
FormatFieldAttribute Class See Also Send Feedback

The FormatFieldAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

FormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FieldFormat Property

FormatFieldAttribute..::..FieldFormat Property
FormatFieldAttribute Class See Also Send Feedback
Gets or sets the field format.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type FieldFormat { get; set; }

Field Value

The field format.

Remarks

The type has to implement IFieldFormat interface.

See Also

FormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCheckBoxAttribute Class

GridCheckBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with grid control with checkboxes.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridCheckBoxAttribute : CheckBoxAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CheckBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridCheckBoxAttribute

See Also

GridCheckBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCheckBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridCheckBoxAttribute Members
GridCheckBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The GridCheckBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridCheckBoxAttribute | Initializes a new instance of the GridCheckBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCheckBoxAttribute Constructor

GridCheckBoxAttribute Constructor
GridCheckBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridCheckBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridCheckBoxAttribute()

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCheckBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridCheckBoxAttribute Methods
GridCheckBoxAttribute Class See Also Send Feedback

The GridCheckBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridCheckBoxAttribute..::..GetDefaultValueProvider Method
GridCheckBoxAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCheckBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridCheckBoxAttribute Properties
GridCheckBoxAttribute Class See Also Send Feedback

The GridCheckBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

GridCheckBoxAttribute..::..AllowToAddElements Property
GridCheckBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToAddElements

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

GridCheckBoxAttribute..::..AllowToRemoveElements Property
GridCheckBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToRemoveElements

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

GridCheckBoxAttribute..::..AttributeUnit Property
GridCheckBoxAttribute Class See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

Implements

IGridAttribute..::..AttributeUnit

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridCheckBoxAttribute..::..DefaultValue Property
GridCheckBoxAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridCheckBoxAttribute..::..DefaultValueProvider Property
GridCheckBoxAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridCheckBoxAttribute..::..MapKey Property
GridCheckBoxAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridCheckBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridComboBoxAttribute Class

GridComboBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with ComboBox grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridComboBoxAttribute : ComboBoxAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridComboBoxAttribute

See Also

GridComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridComboBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridComboBoxAttribute Members
GridComboBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The GridComboBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridComboBoxAttribute()()()() | Initializes a new instance of the GridComboBoxAttribute class.
Public method | GridComboBoxAttribute(array<Object>[]()[][]) | Initializes a new instance of the GridComboBoxAttribute class.
Public method | GridComboBoxAttribute(String, Type) | Initializes a new instance of the GridComboBoxAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridComboBoxAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
GridComboBoxAttribute Constructor
GridComboBoxAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridComboBoxAttribute()()()() | Initializes a new instance of the GridComboBoxAttribute class.
Public method | GridComboBoxAttribute(array<Object>[]()[][]) | Initializes a new instance of the GridComboBoxAttribute class.
Public method | GridComboBoxAttribute(String, Type) | Initializes a new instance of the GridComboBoxAttribute class.

See Also

GridComboBoxAttribute Class
GridComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridComboBoxAttribute Constructor

GridComboBoxAttribute Constructor
GridComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridComboBoxAttribute()

See Also

GridComboBoxAttribute Class
GridComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridComboBoxAttribute Constructor (Object[])

GridComboBoxAttribute Constructor (array<Object>[]()[][])
GridComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridComboBoxAttribute(
    params Object[] items
)

Parameters

items
Type: array< System..::..Object >[]()[][]
The list of items.

See Also

GridComboBoxAttribute Class
GridComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridComboBoxAttribute Constructor (String, Type)

GridComboBoxAttribute Constructor (String, Type)
GridComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridComboBoxAttribute(
    string dataSourceKey,
    Type format
)

Parameters

dataSourceKey
Type: System..::..String
The data source key.
format
Type: System..::..Type
The format.

See Also

GridComboBoxAttribute Class
GridComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridComboBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridComboBoxAttribute Methods
GridComboBoxAttribute Class See Also Send Feedback

The GridComboBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridComboBoxAttribute..::..GetDefaultValueProvider Method
GridComboBoxAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridComboBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridComboBoxAttribute Properties
GridComboBoxAttribute Class See Also Send Feedback

The GridComboBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

GridComboBoxAttribute..::..AllowToAddElements Property
GridComboBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToAddElements

See Also

GridComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

GridComboBoxAttribute..::..AllowToRemoveElements Property
GridComboBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToRemoveElements

See Also

GridComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

GridComboBoxAttribute..::..AttributeUnit Property
GridComboBoxAttribute Class See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

Implements

IGridAttribute..::..AttributeUnit

See Also

GridComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridComboBoxAttribute..::..DefaultValue Property
GridComboBoxAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridComboBoxAttribute..::..DefaultValueProvider Property
GridComboBoxAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridComboBoxAttribute..::..MapKey Property
GridComboBoxAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCustomControlAttribute Class

GridCustomControlAttribute Class
Members See Also Send Feedback
Indicates that particular field should be edited with Custom grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridCustomControlAttribute : CustomControlAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CustomControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridCustomControlAttribute

See Also

GridCustomControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCustomControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridCustomControlAttribute Members
GridCustomControlAttribute Class Constructors Methods Properties See Also Send Feedback

The GridCustomControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridCustomControlAttribute()()()() | Initializes a new instance of the GridCustomControlAttribute class.
Public method | GridCustomControlAttribute(Type, Boolean) | Initializes a new instance of the GridCustomControlAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetControlInstance | Returns custom editor of the field. (Inherited from CustomControlAttribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Control | The editor of the field. (Inherited from CustomControlAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Span | Gets or sets a value indicating whether this CustomControlAttribute control should be extended for all columns of the grid. (Inherited from CustomControlAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridCustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCustomControlAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
GridCustomControlAttribute Constructor
GridCustomControlAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridCustomControlAttribute()()()() | Initializes a new instance of the GridCustomControlAttribute class.
Public method | GridCustomControlAttribute(Type, Boolean) | Initializes a new instance of the GridCustomControlAttribute class.

See Also

GridCustomControlAttribute Class
GridCustomControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCustomControlAttribute Constructor

GridCustomControlAttribute Constructor
GridCustomControlAttribute Class See Also Send Feedback
Initializes a new instance of the GridCustomControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridCustomControlAttribute()

See Also

GridCustomControlAttribute Class
GridCustomControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCustomControlAttribute Constructor (Type, Boolean)

GridCustomControlAttribute Constructor (Type, Boolean)
GridCustomControlAttribute Class See Also Send Feedback
Initializes a new instance of the GridCustomControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridCustomControlAttribute(
    Type control,
    bool span
)

Parameters

control
Type: System..::..Type
The control.
span
Type: System..::..Boolean
if set to true the control will be extended to all columns.

See Also

GridCustomControlAttribute Class
GridCustomControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCustomControlAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridCustomControlAttribute Methods
GridCustomControlAttribute Class See Also Send Feedback

The GridCustomControlAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetControlInstance | Returns custom editor of the field. (Inherited from CustomControlAttribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridCustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridCustomControlAttribute..::..GetDefaultValueProvider Method
GridCustomControlAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridCustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridCustomControlAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridCustomControlAttribute Properties
GridCustomControlAttribute Class See Also Send Feedback

The GridCustomControlAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Control | The editor of the field. (Inherited from CustomControlAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Span | Gets or sets a value indicating whether this CustomControlAttribute control should be extended for all columns of the grid. (Inherited from CustomControlAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridCustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

GridCustomControlAttribute..::..AllowToAddElements Property
GridCustomControlAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToAddElements

See Also

GridCustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

GridCustomControlAttribute..::..AllowToRemoveElements Property
GridCustomControlAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToRemoveElements

See Also

GridCustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

GridCustomControlAttribute..::..AttributeUnit Property
GridCustomControlAttribute Class See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

Implements

IGridAttribute..::..AttributeUnit

See Also

GridCustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridCustomControlAttribute..::..DefaultValue Property
GridCustomControlAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridCustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridCustomControlAttribute..::..DefaultValueProvider Property
GridCustomControlAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridCustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridCustomControlAttribute..::..MapKey Property
GridCustomControlAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridCustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridElementComboBoxAttribute Class

GridElementComboBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with Element ComboBox grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridElementComboBoxAttribute : ElementComboBoxAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ElementComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridElementComboBoxAttribute

See Also

GridElementComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridElementComboBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridElementComboBoxAttribute Members
GridElementComboBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The GridElementComboBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridElementComboBoxAttribute()()()() | Initializes a new instance of the GridElementComboBoxAttribute class.
Public method | GridElementComboBoxAttribute(array<Object>[]()[][]) | Initializes a new instance of the GridElementComboBoxAttribute class.
Public method | GridElementComboBoxAttribute(String) | Initializes a new instance of the GridElementComboBoxAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridElementComboBoxAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
GridElementComboBoxAttribute Constructor
GridElementComboBoxAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridElementComboBoxAttribute()()()() | Initializes a new instance of the GridElementComboBoxAttribute class.
Public method | GridElementComboBoxAttribute(array<Object>[]()[][]) | Initializes a new instance of the GridElementComboBoxAttribute class.
Public method | GridElementComboBoxAttribute(String) | Initializes a new instance of the GridElementComboBoxAttribute class.

See Also

GridElementComboBoxAttribute Class
GridElementComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridElementComboBoxAttribute Constructor

GridElementComboBoxAttribute Constructor
GridElementComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridElementComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridElementComboBoxAttribute()

See Also

GridElementComboBoxAttribute Class
GridElementComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridElementComboBoxAttribute Constructor (Object[])

GridElementComboBoxAttribute Constructor (array<Object>[]()[][])
GridElementComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridElementComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridElementComboBoxAttribute(
    params Object[] items
)

Parameters

items
Type: array< System..::..Object >[]()[][]
The items.

See Also

GridElementComboBoxAttribute Class
GridElementComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridElementComboBoxAttribute Constructor (String)

GridElementComboBoxAttribute Constructor (String)
GridElementComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridElementComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridElementComboBoxAttribute(
    string dataSourceKey
)

Parameters

dataSourceKey
Type: System..::..String
The data source key.

See Also

GridElementComboBoxAttribute Class
GridElementComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridElementComboBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridElementComboBoxAttribute Methods
GridElementComboBoxAttribute Class See Also Send Feedback

The GridElementComboBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridElementComboBoxAttribute..::..GetDefaultValueProvider Method
GridElementComboBoxAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridElementComboBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridElementComboBoxAttribute Properties
GridElementComboBoxAttribute Class See Also Send Feedback

The GridElementComboBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

GridElementComboBoxAttribute..::..AllowToAddElements Property
GridElementComboBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToAddElements

See Also

GridElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

GridElementComboBoxAttribute..::..AllowToRemoveElements Property
GridElementComboBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToRemoveElements

See Also

GridElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

GridElementComboBoxAttribute..::..AttributeUnit Property
GridElementComboBoxAttribute Class See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

Implements

IGridAttribute..::..AttributeUnit

See Also

GridElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridElementComboBoxAttribute..::..DefaultValue Property
GridElementComboBoxAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridElementComboBoxAttribute..::..DefaultValueProvider Property
GridElementComboBoxAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridElementComboBoxAttribute..::..MapKey Property
GridElementComboBoxAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridElementComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridEnumControlAttribute Class

GridEnumControlAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with enum grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridEnumControlAttribute : EnumControlAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..EnumControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridEnumControlAttribute

See Also

GridEnumControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridEnumControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridEnumControlAttribute Members
GridEnumControlAttribute Class Constructors Methods Properties See Also Send Feedback

The GridEnumControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridEnumControlAttribute()()()() | Initializes a new instance of the GridEnumControlAttribute class.
Public method | GridEnumControlAttribute(Type, PresentationMode, PresentationItem) | Initializes a new instance of the GridEnumControlAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | EnumType | Gets or sets the type of the enum. (Inherited from EnumControlAttribute.)
Public property | ImageSize | Gets or sets the size of the image. (Inherited from EnumControlAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Item | Gets or sets the presentation item. (Inherited from EnumControlAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | Presentation | Gets or sets the presentation mode. (Inherited from EnumControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | SubSchemasToValues | Gets or sets the sub schemas to values map. (Inherited from EnumControlAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridEnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridEnumControlAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
GridEnumControlAttribute Constructor
GridEnumControlAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridEnumControlAttribute()()()() | Initializes a new instance of the GridEnumControlAttribute class.
Public method | GridEnumControlAttribute(Type, PresentationMode, PresentationItem) | Initializes a new instance of the GridEnumControlAttribute class.

See Also

GridEnumControlAttribute Class
GridEnumControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridEnumControlAttribute Constructor

GridEnumControlAttribute Constructor
GridEnumControlAttribute Class See Also Send Feedback
Initializes a new instance of the GridEnumControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridEnumControlAttribute()

See Also

GridEnumControlAttribute Class
GridEnumControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridEnumControlAttribute Constructor (Type, PresentationMode, PresentationItem)

GridEnumControlAttribute Constructor (Type, PresentationMode, PresentationItem)
GridEnumControlAttribute Class See Also Send Feedback
Initializes a new instance of the GridEnumControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridEnumControlAttribute(
    Type enumType,
    PresentationMode presentationMode,
    PresentationItem presentationItem
)

Parameters

enumType
Type: System..::..Type
Type of the enum.
presentationMode
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationMode
The presentation mode.
presentationItem
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationItem
The presentation item.

See Also

GridEnumControlAttribute Class
GridEnumControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridEnumControlAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridEnumControlAttribute Methods
GridEnumControlAttribute Class See Also Send Feedback

The GridEnumControlAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridEnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridEnumControlAttribute..::..GetDefaultValueProvider Method
GridEnumControlAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridEnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridEnumControlAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridEnumControlAttribute Properties
GridEnumControlAttribute Class See Also Send Feedback

The GridEnumControlAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | EnumType | Gets or sets the type of the enum. (Inherited from EnumControlAttribute.)
Public property | ImageSize | Gets or sets the size of the image. (Inherited from EnumControlAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Item | Gets or sets the presentation item. (Inherited from EnumControlAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | Presentation | Gets or sets the presentation mode. (Inherited from EnumControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | SubSchemasToValues | Gets or sets the sub schemas to values map. (Inherited from EnumControlAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridEnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

GridEnumControlAttribute..::..AllowToAddElements Property
GridEnumControlAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToAddElements

See Also

GridEnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

GridEnumControlAttribute..::..AllowToRemoveElements Property
GridEnumControlAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToRemoveElements

See Also

GridEnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

GridEnumControlAttribute..::..AttributeUnit Property
GridEnumControlAttribute Class See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

Implements

IGridAttribute..::..AttributeUnit

See Also

GridEnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridEnumControlAttribute..::..DefaultValue Property
GridEnumControlAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridEnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridEnumControlAttribute..::..DefaultValueProvider Property
GridEnumControlAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridEnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridEnumControlAttribute..::..MapKey Property
GridEnumControlAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridEnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridIntNumericUpDownAttribute Class

GridIntNumericUpDownAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with int NumericUpDown grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridIntNumericUpDownAttribute : IntNumericUpDownAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..NumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..IntNumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridIntNumericUpDownAttribute

See Also

GridIntNumericUpDownAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridIntNumericUpDownAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridIntNumericUpDownAttribute Members
GridIntNumericUpDownAttribute Class Constructors Methods Properties See Also Send Feedback

The GridIntNumericUpDownAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridIntNumericUpDownAttribute()()()() | Initializes a new instance of the GridIntNumericUpDownAttribute class.
Public method | GridIntNumericUpDownAttribute(Int32, Int32, Int32) | Initializes a new instance of the GridIntNumericUpDownAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from IntNumericUpDownAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | MaximumValue | Maximum value (Inherited from NumericUpDownAttribute.)
Public property | MinimumValue | Describes minimum value that may be input into control. (Inherited from NumericUpDownAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step. (Inherited from NumericUpDownAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridIntNumericUpDownAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
GridIntNumericUpDownAttribute Constructor
GridIntNumericUpDownAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridIntNumericUpDownAttribute()()()() | Initializes a new instance of the GridIntNumericUpDownAttribute class.
Public method | GridIntNumericUpDownAttribute(Int32, Int32, Int32) | Initializes a new instance of the GridIntNumericUpDownAttribute class.

See Also

GridIntNumericUpDownAttribute Class
GridIntNumericUpDownAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridIntNumericUpDownAttribute Constructor

GridIntNumericUpDownAttribute Constructor
GridIntNumericUpDownAttribute Class See Also Send Feedback
Initializes a new instance of the GridIntNumericUpDownAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridIntNumericUpDownAttribute()

See Also

GridIntNumericUpDownAttribute Class
GridIntNumericUpDownAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridIntNumericUpDownAttribute Constructor (Int32, Int32, Int32)

GridIntNumericUpDownAttribute Constructor (Int32, Int32, Int32)
GridIntNumericUpDownAttribute Class See Also Send Feedback
Initializes a new instance of the GridIntNumericUpDownAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridIntNumericUpDownAttribute(
    int minValue,
    int maxValue,
    int step
)

Parameters

minValue
Type: System..::..Int32
The minimum value.
maxValue
Type: System..::..Int32
The maximum value.
step
Type: System..::..Int32
The step.

See Also

GridIntNumericUpDownAttribute Class
GridIntNumericUpDownAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridIntNumericUpDownAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridIntNumericUpDownAttribute Methods
GridIntNumericUpDownAttribute Class See Also Send Feedback

The GridIntNumericUpDownAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from IntNumericUpDownAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridIntNumericUpDownAttribute..::..GetDefaultValueProvider Method
GridIntNumericUpDownAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridIntNumericUpDownAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridIntNumericUpDownAttribute Properties
GridIntNumericUpDownAttribute Class See Also Send Feedback

The GridIntNumericUpDownAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | MaximumValue | Maximum value (Inherited from NumericUpDownAttribute.)
Public property | MinimumValue | Describes minimum value that may be input into control. (Inherited from NumericUpDownAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step. (Inherited from NumericUpDownAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

GridIntNumericUpDownAttribute..::..AllowToAddElements Property
GridIntNumericUpDownAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToAddElements

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

GridIntNumericUpDownAttribute..::..AllowToRemoveElements Property
GridIntNumericUpDownAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToRemoveElements

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

GridIntNumericUpDownAttribute..::..AttributeUnit Property
GridIntNumericUpDownAttribute Class See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

Implements

IGridAttribute..::..AttributeUnit

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridIntNumericUpDownAttribute..::..DefaultValue Property
GridIntNumericUpDownAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridIntNumericUpDownAttribute..::..DefaultValueProvider Property
GridIntNumericUpDownAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridIntNumericUpDownAttribute..::..MapKey Property
GridIntNumericUpDownAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyComboBoxAttribute Class

GridKeyComboBoxAttribute Class
Members See Also Send Feedback
Indicates that particular key of the property will be edited with ComboBox grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridKeyComboBoxAttribute : ComboBoxAttribute,
    IGridAttribute

Remarks

Only for maps.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridKeyComboBoxAttribute

See Also

GridKeyComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyComboBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridKeyComboBoxAttribute Members
GridKeyComboBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The GridKeyComboBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridKeyComboBoxAttribute()()()() | Initializes a new instance of the GridKeyComboBoxAttribute class.
Public method | GridKeyComboBoxAttribute(String, Type) | Initializes a new instance of the GridKeyComboBoxAttribute class.
Public method | GridKeyComboBoxAttribute(Type, array<Object>[]()[][]) | Initializes a new instance of the GridKeyComboBoxAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridKeyComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyComboBoxAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
GridKeyComboBoxAttribute Constructor
GridKeyComboBoxAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridKeyComboBoxAttribute()()()() | Initializes a new instance of the GridKeyComboBoxAttribute class.
Public method | GridKeyComboBoxAttribute(String, Type) | Initializes a new instance of the GridKeyComboBoxAttribute class.
Public method | GridKeyComboBoxAttribute(Type, array<Object>[]()[][]) | Initializes a new instance of the GridKeyComboBoxAttribute class.

See Also

GridKeyComboBoxAttribute Class
GridKeyComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyComboBoxAttribute Constructor

GridKeyComboBoxAttribute Constructor
GridKeyComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridKeyComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridKeyComboBoxAttribute()

See Also

GridKeyComboBoxAttribute Class
GridKeyComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyComboBoxAttribute Constructor (String, Type)

GridKeyComboBoxAttribute Constructor (String, Type)
GridKeyComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridKeyComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridKeyComboBoxAttribute(
    string dataSourceKey,
    Type format
)

Parameters

dataSourceKey
Type: System..::..String
The data source key.
format
Type: System..::..Type
The format.

See Also

GridKeyComboBoxAttribute Class
GridKeyComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyComboBoxAttribute Constructor (Type, Object[])

GridKeyComboBoxAttribute Constructor (Type, array<Object>[]()[][])
GridKeyComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridKeyComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridKeyComboBoxAttribute(
    Type format,
    params Object[] items
)

Parameters

format
Type: System..::..Type
items
Type: array< System..::..Object >[]()[][]
The list of items.

See Also

GridKeyComboBoxAttribute Class
GridKeyComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyComboBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridKeyComboBoxAttribute Methods
GridKeyComboBoxAttribute Class See Also Send Feedback

The GridKeyComboBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridKeyComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridKeyComboBoxAttribute..::..GetDefaultValueProvider Method
GridKeyComboBoxAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridKeyComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyComboBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridKeyComboBoxAttribute Properties
GridKeyComboBoxAttribute Class See Also Send Feedback

The GridKeyComboBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridKeyComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

GridKeyComboBoxAttribute..::..AttributeUnit Property
GridKeyComboBoxAttribute Class See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

Implements

IGridAttribute..::..AttributeUnit

See Also

GridKeyComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridKeyComboBoxAttribute..::..DefaultValue Property
GridKeyComboBoxAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridKeyComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridKeyComboBoxAttribute..::..DefaultValueProvider Property
GridKeyComboBoxAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridKeyComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridKeyComboBoxAttribute..::..MapKey Property
GridKeyComboBoxAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridKeyComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyTextBoxAttribute Class

GridKeyTextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular key of the field (only for maps) should be edited with TextBox grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridKeyTextBoxAttribute : TextBoxAttribute,
    IGridAttribute

Remarks

Only for maps.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridKeyTextBoxAttribute

See Also

GridKeyTextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyTextBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridKeyTextBoxAttribute Members
GridKeyTextBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The GridKeyTextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridKeyTextBoxAttribute | Initializes a new instance of the GridKeyTextBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridKeyTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyTextBoxAttribute Constructor

GridKeyTextBoxAttribute Constructor
GridKeyTextBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridKeyTextBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridKeyTextBoxAttribute()

See Also

GridKeyTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyTextBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridKeyTextBoxAttribute Methods
GridKeyTextBoxAttribute Class See Also Send Feedback

The GridKeyTextBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridKeyTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridKeyTextBoxAttribute..::..GetDefaultValueProvider Method
GridKeyTextBoxAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridKeyTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridKeyTextBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridKeyTextBoxAttribute Properties
GridKeyTextBoxAttribute Class See Also Send Feedback

The GridKeyTextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridKeyTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

GridKeyTextBoxAttribute..::..AttributeUnit Property
GridKeyTextBoxAttribute Class See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

Implements

IGridAttribute..::..AttributeUnit

See Also

GridKeyTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridKeyTextBoxAttribute..::..DefaultValue Property
GridKeyTextBoxAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridKeyTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridKeyTextBoxAttribute..::..DefaultValueProvider Property
GridKeyTextBoxAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridKeyTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridKeyTextBoxAttribute..::..MapKey Property
GridKeyTextBoxAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridKeyTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridTextBoxAttribute Class

GridTextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with TextBox grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridTextBoxAttribute : TextBoxAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridTextBoxAttribute

See Also

GridTextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridTextBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridTextBoxAttribute Members
GridTextBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The GridTextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridTextBoxAttribute | Initializes a new instance of the GridTextBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridTextBoxAttribute Constructor

GridTextBoxAttribute Constructor
GridTextBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridTextBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridTextBoxAttribute()

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridTextBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridTextBoxAttribute Methods
GridTextBoxAttribute Class See Also Send Feedback

The GridTextBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridTextBoxAttribute..::..GetDefaultValueProvider Method
GridTextBoxAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridTextBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridTextBoxAttribute Properties
GridTextBoxAttribute Class See Also Send Feedback

The GridTextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

GridTextBoxAttribute..::..AllowToAddElements Property
GridTextBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToAddElements

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

GridTextBoxAttribute..::..AllowToRemoveElements Property
GridTextBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToRemoveElements

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

GridTextBoxAttribute..::..AttributeUnit Property
GridTextBoxAttribute Class See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

Implements

IGridAttribute..::..AttributeUnit

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridTextBoxAttribute..::..DefaultValue Property
GridTextBoxAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridTextBoxAttribute..::..DefaultValueProvider Property
GridTextBoxAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridTextBoxAttribute..::..MapKey Property
GridTextBoxAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitNumericUpDownAttribute Class

GridUnitNumericUpDownAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with UnitNumericUpDown grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridUnitNumericUpDownAttribute : UnitNumericUpDownAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..NumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitNumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridUnitNumericUpDownAttribute

See Also

GridUnitNumericUpDownAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitNumericUpDownAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridUnitNumericUpDownAttribute Members
GridUnitNumericUpDownAttribute Class Constructors Methods Properties See Also Send Feedback

The GridUnitNumericUpDownAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridUnitNumericUpDownAttribute()()()() | Initializes a new instance of the GridUnitNumericUpDownAttribute class.
Public method | GridUnitNumericUpDownAttribute(Double, Double, Double, DisplayUnitType) | Initializes a new instance of the UnitNumericUpDownAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from UnitNumericUpDownAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Unit in which values of the attribute are described (Inherited from UnitNumericUpDownAttribute.)
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | MaximumValue | Maximum value (Inherited from NumericUpDownAttribute.)
Public property | MinimumValue | Describes minimum value that may be input into control. (Inherited from NumericUpDownAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step. (Inherited from NumericUpDownAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridUnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitNumericUpDownAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
GridUnitNumericUpDownAttribute Constructor
GridUnitNumericUpDownAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridUnitNumericUpDownAttribute()()()() | Initializes a new instance of the GridUnitNumericUpDownAttribute class.
Public method | GridUnitNumericUpDownAttribute(Double, Double, Double, DisplayUnitType) | Initializes a new instance of the UnitNumericUpDownAttribute class.

See Also

GridUnitNumericUpDownAttribute Class
GridUnitNumericUpDownAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitNumericUpDownAttribute Constructor

GridUnitNumericUpDownAttribute Constructor
GridUnitNumericUpDownAttribute Class See Also Send Feedback
Initializes a new instance of the GridUnitNumericUpDownAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridUnitNumericUpDownAttribute()

See Also

GridUnitNumericUpDownAttribute Class
GridUnitNumericUpDownAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitNumericUpDownAttribute Constructor (Double, Double, Double, )

GridUnitNumericUpDownAttribute Constructor (Double, Double, Double, )
GridUnitNumericUpDownAttribute Class See Also Send Feedback
Initializes a new instance of the UnitNumericUpDownAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridUnitNumericUpDownAttribute(
    double minValue,
    double maxValue,
    double step,
    DisplayUnitType unit
)

Parameters

minValue
Type: System..::..Double
The min value.
maxValue
Type: System..::..Double
The max value.
step
Type: System..::..Double
The step.
unit
Type: DisplayUnitType
The unit attributes values are described with.

See Also

GridUnitNumericUpDownAttribute Class
GridUnitNumericUpDownAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitNumericUpDownAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridUnitNumericUpDownAttribute Methods
GridUnitNumericUpDownAttribute Class See Also Send Feedback

The GridUnitNumericUpDownAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from UnitNumericUpDownAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridUnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridUnitNumericUpDownAttribute..::..GetDefaultValueProvider Method
GridUnitNumericUpDownAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridUnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitNumericUpDownAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridUnitNumericUpDownAttribute Properties
GridUnitNumericUpDownAttribute Class See Also Send Feedback

The GridUnitNumericUpDownAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Unit in which values of the attribute are described (Inherited from UnitNumericUpDownAttribute.)
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | MaximumValue | Maximum value (Inherited from NumericUpDownAttribute.)
Public property | MinimumValue | Describes minimum value that may be input into control. (Inherited from NumericUpDownAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step. (Inherited from NumericUpDownAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridUnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

GridUnitNumericUpDownAttribute..::..AllowToAddElements Property
GridUnitNumericUpDownAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToAddElements

See Also

GridUnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

GridUnitNumericUpDownAttribute..::..AllowToRemoveElements Property
GridUnitNumericUpDownAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToRemoveElements

See Also

GridUnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridUnitNumericUpDownAttribute..::..DefaultValue Property
GridUnitNumericUpDownAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridUnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridUnitNumericUpDownAttribute..::..DefaultValueProvider Property
GridUnitNumericUpDownAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridUnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridUnitNumericUpDownAttribute..::..MapKey Property
GridUnitNumericUpDownAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridUnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitTextBoxAttribute Class

GridUnitTextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with UnitTextBox grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridUnitTextBoxAttribute : UnitTextBoxAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridUnitTextBoxAttribute

See Also

GridUnitTextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitTextBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridUnitTextBoxAttribute Members
GridUnitTextBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The GridUnitTextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridUnitTextBoxAttribute | Initializes a new instance of the GridUnitTextBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldValidator | Gets the field validator. (Inherited from UnitTextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Unit in which values of the attribute are described (Inherited from UnitTextBoxAttribute.)
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from UnitTextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | MaximumValue | Maximum value (Inherited from UnitTextBoxAttribute.)
Public property | MinimumValue | Minimum value (Inherited from UnitTextBoxAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValidateMaximumValue | Indicates if maximum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValidateMinimumValue | Indicates if minimum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitTextBoxAttribute Constructor

GridUnitTextBoxAttribute Constructor
GridUnitTextBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridUnitTextBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridUnitTextBoxAttribute()

See Also

GridUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitTextBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridUnitTextBoxAttribute Methods
GridUnitTextBoxAttribute Class See Also Send Feedback

The GridUnitTextBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldValidator | Gets the field validator. (Inherited from UnitTextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridUnitTextBoxAttribute..::..GetDefaultValueProvider Method
GridUnitTextBoxAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridUnitTextBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridUnitTextBoxAttribute Properties
GridUnitTextBoxAttribute Class See Also Send Feedback

The GridUnitTextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Unit in which values of the attribute are described (Inherited from UnitTextBoxAttribute.)
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from UnitTextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | MaximumValue | Maximum value (Inherited from UnitTextBoxAttribute.)
Public property | MinimumValue | Minimum value (Inherited from UnitTextBoxAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValidateMaximumValue | Indicates if maximum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValidateMinimumValue | Indicates if minimum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

GridUnitTextBoxAttribute..::..AllowToAddElements Property
GridUnitTextBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToAddElements

See Also

GridUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

GridUnitTextBoxAttribute..::..AllowToRemoveElements Property
GridUnitTextBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToRemoveElements

See Also

GridUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridUnitTextBoxAttribute..::..DefaultValue Property
GridUnitTextBoxAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridUnitTextBoxAttribute..::..DefaultValueProvider Property
GridUnitTextBoxAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridUnitTextBoxAttribute..::..MapKey Property
GridUnitTextBoxAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridXYZTextBoxAttribute Class

GridXYZTextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with TextBox grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridXYZTextBoxAttribute : XYZTextBoxAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..XYZTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridXYZTextBoxAttribute

See Also

GridXYZTextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridXYZTextBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridXYZTextBoxAttribute Members
GridXYZTextBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The GridXYZTextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridXYZTextBoxAttribute | Initializes a new instance of the GridXYZTextBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from XYZTextBoxAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridXYZTextBoxAttribute Constructor

GridXYZTextBoxAttribute Constructor
GridXYZTextBoxAttribute Class See Also Send Feedback
Initializes a new instance of the GridXYZTextBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridXYZTextBoxAttribute()

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridXYZTextBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
GridXYZTextBoxAttribute Methods
GridXYZTextBoxAttribute Class See Also Send Feedback

The GridXYZTextBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetDefaultValueProvider | Gets the instance of default value provider.
Public method | GetFieldFormat | Gets the field format. (Inherited from XYZTextBoxAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetDefaultValueProvider Method

GridXYZTextBoxAttribute..::..GetDefaultValueProvider Method
GridXYZTextBoxAttribute Class See Also Send Feedback
Gets the instance of default value provider.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IDefaultValueProvider GetDefaultValueProvider()

Return Value

Implements

IGridAttribute..::..GetDefaultValueProvider()()()()

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GridXYZTextBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
GridXYZTextBoxAttribute Properties
GridXYZTextBoxAttribute Class See Also Send Feedback

The GridXYZTextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

GridXYZTextBoxAttribute..::..AllowToAddElements Property
GridXYZTextBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToAddElements

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

GridXYZTextBoxAttribute..::..AllowToRemoveElements Property
GridXYZTextBoxAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

Implements

IGridValueAttribute..::..AllowToRemoveElements

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

GridXYZTextBoxAttribute..::..AttributeUnit Property
GridXYZTextBoxAttribute Class See Also Send Feedback
Gets or sets the default value unit.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

Field Value

The default value unit.

Implements

IGridAttribute..::..AttributeUnit

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValue Property

GridXYZTextBoxAttribute..::..DefaultValue Property
GridXYZTextBoxAttribute Class See Also Send Feedback
Gets or sets the default value (when element is added to grid).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value.

Implements

IGridAttribute..::..DefaultValue

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DefaultValueProvider Property

GridXYZTextBoxAttribute..::..DefaultValueProvider Property
GridXYZTextBoxAttribute Class See Also Send Feedback
Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type DefaultValueProvider { get; set; }

Field Value

The default value provider.

Implements

IGridAttribute..::..DefaultValueProvider

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MapKey Property

GridXYZTextBoxAttribute..::..MapKey Property
GridXYZTextBoxAttribute Class See Also Send Feedback
Gets a value indicating whether this instance is for key (important only for maps).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool MapKey { get; }

Field Value

true if this instance is key; otherwise, false.

Implements

IGridAttribute..::..MapKey

See Also

GridXYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


IntNumericUpDownAttribute Class

IntNumericUpDownAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with IntNumericUpDown control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class IntNumericUpDownAttribute : NumericUpDownAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..NumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..IntNumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridIntNumericUpDownAttribute

See Also

IntNumericUpDownAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


IntNumericUpDownAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
IntNumericUpDownAttribute Members
IntNumericUpDownAttribute Class Constructors Methods Properties See Also Send Feedback

The IntNumericUpDownAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | IntNumericUpDownAttribute()()()() | Initializes a new instance of the IntNumericUpDownAttribute class.
Public method | IntNumericUpDownAttribute(Int32, Int32, Int32) | Initializes a new instance of the IntNumericUpDownAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Overrides FormatFieldAttribute..::..GetFieldFormat()()()().)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumValue | Maximum value (Inherited from NumericUpDownAttribute.)
Public property | MinimumValue | Describes minimum value that may be input into control. (Inherited from NumericUpDownAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step. (Inherited from NumericUpDownAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

IntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


IntNumericUpDownAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
IntNumericUpDownAttribute Constructor
IntNumericUpDownAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IntNumericUpDownAttribute()()()() | Initializes a new instance of the IntNumericUpDownAttribute class.
Public method | IntNumericUpDownAttribute(Int32, Int32, Int32) | Initializes a new instance of the IntNumericUpDownAttribute class.

See Also

IntNumericUpDownAttribute Class
IntNumericUpDownAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


IntNumericUpDownAttribute Constructor

IntNumericUpDownAttribute Constructor
IntNumericUpDownAttribute Class See Also Send Feedback
Initializes a new instance of the IntNumericUpDownAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IntNumericUpDownAttribute()

See Also

IntNumericUpDownAttribute Class
IntNumericUpDownAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


IntNumericUpDownAttribute Constructor (Int32, Int32, Int32)

IntNumericUpDownAttribute Constructor (Int32, Int32, Int32)
IntNumericUpDownAttribute Class See Also Send Feedback
Initializes a new instance of the IntNumericUpDownAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IntNumericUpDownAttribute(
    int minValue,
    int maxValue,
    int step
)

Parameters

minValue
Type: System..::..Int32
The minimum value.
maxValue
Type: System..::..Int32
The maximum value.
step
Type: System..::..Int32
The step.

See Also

IntNumericUpDownAttribute Class
IntNumericUpDownAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


IntNumericUpDownAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IntNumericUpDownAttribute Methods
IntNumericUpDownAttribute Class See Also Send Feedback

The IntNumericUpDownAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Overrides FormatFieldAttribute..::..GetFieldFormat()()()().)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

IntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetFieldFormat Method

IntNumericUpDownAttribute..::..GetFieldFormat Method
IntNumericUpDownAttribute Class See Also Send Feedback
Gets the field format.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override IFieldFormat GetFieldFormat()

Return Value

See Also

IntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


IntNumericUpDownAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
IntNumericUpDownAttribute Properties
IntNumericUpDownAttribute Class See Also Send Feedback

The IntNumericUpDownAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumValue | Maximum value (Inherited from NumericUpDownAttribute.)
Public property | MinimumValue | Describes minimum value that may be input into control. (Inherited from NumericUpDownAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step. (Inherited from NumericUpDownAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

IntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListTextBoxAttribute Class

ListTextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with the ListTextBox control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ListTextBoxAttribute : TextBoxAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ListTextBoxAttribute

See Also

ListTextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListTextBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ListTextBoxAttribute Members
ListTextBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The ListTextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ListTextBoxAttribute | Initializes a new instance of the ListTextBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ListTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListTextBoxAttribute Constructor

ListTextBoxAttribute Constructor
ListTextBoxAttribute Class See Also Send Feedback
Initializes a new instance of the ListTextBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ListTextBoxAttribute()

See Also

ListTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListTextBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ListTextBoxAttribute Methods
ListTextBoxAttribute Class See Also Send Feedback

The ListTextBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

ListTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListTextBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ListTextBoxAttribute Properties
ListTextBoxAttribute Class See Also Send Feedback

The ListTextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ListTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListUnitTextBoxAttribute Class

ListUnitTextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with the ListUnitTextBox control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ListUnitTextBoxAttribute : UnitTextBoxAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ListUnitTextBoxAttribute

See Also

ListUnitTextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListUnitTextBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
ListUnitTextBoxAttribute Members
ListUnitTextBoxAttribute Class Constructors Methods Fields Properties See Also Send Feedback

The ListUnitTextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ListUnitTextBoxAttribute | Initializes a new instance of the ListUnitTextBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from UnitTextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Fields

Name | Description
PropertyMaximumItemCount | Describes attribute indicating maximum number of items.
PropertyMinimumItemCount | Describes attribute indicating minimum number of items.
PropertyValidateMaximumItemCount | Describes attribute indicating whether maximum number of items should be checked.
PropertyValidateMinimumItemCount | Describes attribute indicating whether minimum number of items should be checked.

Properties

 | Name | Description
Public property | AttributeUnit | Unit in which values of the attribute are described (Inherited from UnitTextBoxAttribute.)
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from UnitTextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumItemCount | Maximum number of items in the list.
Public property | MaximumValue | Maximum value (Inherited from UnitTextBoxAttribute.)
Public property | MinimumItemCount | Minimum number of items in the list
Public property | MinimumValue | Minimum value (Inherited from UnitTextBoxAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValidateMaximumItemCount | Indicates whether maximum number of items should be validated
Public property | ValidateMaximumValue | Indicates if maximum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValidateMinimumItemCount | Indicates if minimum number of items should be checked
Public property | ValidateMinimumValue | Indicates if minimum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListUnitTextBoxAttribute Constructor

ListUnitTextBoxAttribute Constructor
ListUnitTextBoxAttribute Class See Also Send Feedback
Initializes a new instance of the ListUnitTextBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ListUnitTextBoxAttribute()

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListUnitTextBoxAttribute Fields

[image]

Structural Analysis and Code Checking API Reference Guide
ListUnitTextBoxAttribute Fields
ListUnitTextBoxAttribute Class See Also Send Feedback

The ListUnitTextBoxAttribute type exposes the following members.

Fields

Name | Description
PropertyMaximumItemCount | Describes attribute indicating maximum number of items.
PropertyMinimumItemCount | Describes attribute indicating minimum number of items.
PropertyValidateMaximumItemCount | Describes attribute indicating whether maximum number of items should be checked.
PropertyValidateMinimumItemCount | Describes attribute indicating whether minimum number of items should be checked.

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyMaximumItemCount Field

ListUnitTextBoxAttribute..::..PropertyMaximumItemCount Field
ListUnitTextBoxAttribute Class See Also Send Feedback
Describes attribute indicating maximum number of items.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyMaximumItemCount

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyMinimumItemCount Field

ListUnitTextBoxAttribute..::..PropertyMinimumItemCount Field
ListUnitTextBoxAttribute Class See Also Send Feedback
Describes attribute indicating minimum number of items.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyMinimumItemCount

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyValidateMaximumItemCount Field

ListUnitTextBoxAttribute..::..PropertyValidateMaximumItemCount Field
ListUnitTextBoxAttribute Class See Also Send Feedback
Describes attribute indicating whether maximum number of items should be checked.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyValidateMaximumItemCount

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyValidateMinimumItemCount Field

ListUnitTextBoxAttribute..::..PropertyValidateMinimumItemCount Field
ListUnitTextBoxAttribute Class See Also Send Feedback
Describes attribute indicating whether minimum number of items should be checked.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyValidateMinimumItemCount

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListUnitTextBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ListUnitTextBoxAttribute Methods
ListUnitTextBoxAttribute Class See Also Send Feedback

The ListUnitTextBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from UnitTextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ListUnitTextBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ListUnitTextBoxAttribute Properties
ListUnitTextBoxAttribute Class See Also Send Feedback

The ListUnitTextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeUnit | Unit in which values of the attribute are described (Inherited from UnitTextBoxAttribute.)
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from UnitTextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumItemCount | Maximum number of items in the list.
Public property | MaximumValue | Maximum value (Inherited from UnitTextBoxAttribute.)
Public property | MinimumItemCount | Minimum number of items in the list
Public property | MinimumValue | Minimum value (Inherited from UnitTextBoxAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValidateMaximumItemCount | Indicates whether maximum number of items should be validated
Public property | ValidateMaximumValue | Indicates if maximum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValidateMinimumItemCount | Indicates if minimum number of items should be checked
Public property | ValidateMinimumValue | Indicates if minimum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MaximumItemCount Property

ListUnitTextBoxAttribute..::..MaximumItemCount Property
ListUnitTextBoxAttribute Class See Also Send Feedback
Maximum number of items in the list.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual int MaximumItemCount { get; set; }

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MinimumItemCount Property

ListUnitTextBoxAttribute..::..MinimumItemCount Property
ListUnitTextBoxAttribute Class See Also Send Feedback
Minimum number of items in the list

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual int MinimumItemCount { get; set; }

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ValidateMaximumItemCount Property

ListUnitTextBoxAttribute..::..ValidateMaximumItemCount Property
ListUnitTextBoxAttribute Class See Also Send Feedback
Indicates whether maximum number of items should be validated

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool ValidateMaximumItemCount { get; set; }

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ValidateMinimumItemCount Property

ListUnitTextBoxAttribute..::..ValidateMinimumItemCount Property
ListUnitTextBoxAttribute Class See Also Send Feedback
Indicates if minimum number of items should be checked

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual bool ValidateMinimumItemCount { get; set; }

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


NumericUpDownAttribute Class

NumericUpDownAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with NumericUpDown control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class NumericUpDownAttribute : TextBoxAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..NumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..IntNumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitNumericUpDownAttribute

See Also

NumericUpDownAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


NumericUpDownAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
NumericUpDownAttribute Members
NumericUpDownAttribute Class Methods Fields Properties See Also Send Feedback

The NumericUpDownAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Fields

Name | Description
PropertyMaximumValue | Describes attribute indicating maximum value
PropertyMinimumValue | Describes attribute indicating minimum value
PropertyStep | Describes attribute indicating the step

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumValue | Maximum value
Public property | MinimumValue | Describes minimum value that may be input into control.
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


NumericUpDownAttribute Fields

[image]

Structural Analysis and Code Checking API Reference Guide
NumericUpDownAttribute Fields
NumericUpDownAttribute Class See Also Send Feedback

The NumericUpDownAttribute type exposes the following members.

Fields

Name | Description
PropertyMaximumValue | Describes attribute indicating maximum value
PropertyMinimumValue | Describes attribute indicating minimum value
PropertyStep | Describes attribute indicating the step

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyMaximumValue Field

NumericUpDownAttribute..::..PropertyMaximumValue Field
NumericUpDownAttribute Class See Also Send Feedback
Describes attribute indicating maximum value

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyMaximumValue

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyMinimumValue Field

NumericUpDownAttribute..::..PropertyMinimumValue Field
NumericUpDownAttribute Class See Also Send Feedback
Describes attribute indicating minimum value

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyMinimumValue

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyStep Field

NumericUpDownAttribute..::..PropertyStep Field
NumericUpDownAttribute Class See Also Send Feedback
Describes attribute indicating the step

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyStep

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


NumericUpDownAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
NumericUpDownAttribute Methods
NumericUpDownAttribute Class See Also Send Feedback

The NumericUpDownAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


NumericUpDownAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
NumericUpDownAttribute Properties
NumericUpDownAttribute Class See Also Send Feedback

The NumericUpDownAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumValue | Maximum value
Public property | MinimumValue | Describes minimum value that may be input into control.
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MaximumValue Property

NumericUpDownAttribute..::..MaximumValue Property
NumericUpDownAttribute Class See Also Send Feedback
Maximum value

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object MaximumValue { get; set; }

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MinimumValue Property

NumericUpDownAttribute..::..MinimumValue Property
NumericUpDownAttribute Class See Also Send Feedback
Describes minimum value that may be input into control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object MinimumValue { get; set; }

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Step Property

NumericUpDownAttribute..::..Step Property
NumericUpDownAttribute Class See Also Send Feedback
Gets or sets the step.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Object Step { get; set; }

Field Value

The step.

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PresentationItem Enumeration

PresentationItem Enumeration
See Also Send Feedback
Represents option of item presentation

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum PresentationItem

Members

Member name | Value | Description
Text | 0 | Text
Image | 1 | Image
ImageWithText | 2 | Image with text

See Also

Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PresentationMode Enumeration

PresentationMode Enumeration
See Also Send Feedback
Represents option of enum presentation

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum PresentationMode

Members

Member name | Value | Description
Combobox | 0 | ComboBox
OptionList | 1 | Option list
ToggleButton | 2 | Toggle button

See Also

Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaControlAttribute Class

SubSchemaControlAttribute Class
Members See Also Send Feedback
Indicates that particular field should be edited with SubSchemaControl control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SubSchemaControlAttribute : FieldUIAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaControlAttribute

See Also

SubSchemaControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaControlAttribute Members
SubSchemaControlAttribute Class Constructors Methods Fields Properties See Also Send Feedback

The SubSchemaControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SubSchemaControlAttribute | Initializes a new instance of the SubSchemaControlAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Fields

Name | Description
PropertyText | Describes attribute describing text set on button or next to it.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | DialogTitle | Gets or sets the title of dialog. If empty the name of the field will be taken.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | SizeToContent | Gets or sets a value indicating whether size to content.
Public property | Text | Gets or sets the text put on the button or next to it when SetFieldName is true.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

SubSchemaControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaControlAttribute Constructor

SubSchemaControlAttribute Constructor
SubSchemaControlAttribute Class See Also Send Feedback
Initializes a new instance of the SubSchemaControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaControlAttribute()

See Also

SubSchemaControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaControlAttribute Fields

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaControlAttribute Fields
SubSchemaControlAttribute Class See Also Send Feedback

The SubSchemaControlAttribute type exposes the following members.

Fields

Name | Description
PropertyText | Describes attribute describing text set on button or next to it.

See Also

SubSchemaControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyText Field

SubSchemaControlAttribute..::..PropertyText Field
SubSchemaControlAttribute Class See Also Send Feedback
Describes attribute describing text set on button or next to it.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyText

See Also

SubSchemaControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaControlAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaControlAttribute Methods
SubSchemaControlAttribute Class See Also Send Feedback

The SubSchemaControlAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

SubSchemaControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaControlAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaControlAttribute Properties
SubSchemaControlAttribute Class See Also Send Feedback

The SubSchemaControlAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | DialogTitle | Gets or sets the title of dialog. If empty the name of the field will be taken.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | SizeToContent | Gets or sets a value indicating whether size to content.
Public property | Text | Gets or sets the text put on the button or next to it when SetFieldName is true.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

SubSchemaControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DialogTitle Property

SubSchemaControlAttribute..::..DialogTitle Property
SubSchemaControlAttribute Class See Also Send Feedback
Gets or sets the title of dialog. If empty the name of the field will be taken.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string DialogTitle { get; set; }

Field Value

The dialog title.

See Also

SubSchemaControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SizeToContent Property

SubSchemaControlAttribute..::..SizeToContent Property
SubSchemaControlAttribute Class See Also Send Feedback
Gets or sets a value indicating whether size to content.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool SizeToContent { get; set; }

Field Value

true if [size to content]; otherwise, false.

See Also

SubSchemaControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Text Property

SubSchemaControlAttribute..::..Text Property
SubSchemaControlAttribute Class See Also Send Feedback
Gets or sets the text put on the button or next to it when SetFieldName is true.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string Text { get; set; }

Field Value

The text.

See Also

SubSchemaControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaDefaultAttribute Class

SubSchemaDefaultAttribute Class
Members See Also Send Feedback
Indicates default attribute which will be used to visulize subSchema data when DefaultFieldControlAttribute will be set

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SubSchemaDefaultAttribute : Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaDefaultAttribute

See Also

SubSchemaDefaultAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaDefaultAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaDefaultAttribute Members
SubSchemaDefaultAttribute Class Constructors Methods Properties See Also Send Feedback

The SubSchemaDefaultAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SubSchemaDefaultAttribute | Initializes a new instance of the SubSchemaDefaultAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeUI | Gets or sets the type of FieldControl attribute.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SubSchemaDefaultAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaDefaultAttribute Constructor

SubSchemaDefaultAttribute Constructor
SubSchemaDefaultAttribute Class See Also Send Feedback
Initializes a new instance of the SubSchemaDefaultAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaDefaultAttribute(
    Type uiAttribute
)

Parameters

uiAttribute
Type: System..::..Type
The UI attribute.

See Also

SubSchemaDefaultAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaDefaultAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaDefaultAttribute Methods
SubSchemaDefaultAttribute Class See Also Send Feedback

The SubSchemaDefaultAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SubSchemaDefaultAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaDefaultAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaDefaultAttribute Properties
SubSchemaDefaultAttribute Class See Also Send Feedback

The SubSchemaDefaultAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeUI | Gets or sets the type of FieldControl attribute.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SubSchemaDefaultAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUI Property

SubSchemaDefaultAttribute..::..AttributeUI Property
SubSchemaDefaultAttribute Class See Also Send Feedback
Gets or sets the type of FieldControl attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type AttributeUI { get; set; }

Field Value

The attribute UI.

See Also

SubSchemaDefaultAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaEmbeddedControlAttribute Class

SubSchemaEmbeddedControlAttribute Class
Members See Also Send Feedback
Indicates that particular field should be edited with SubSchemaControl embedded in layout.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SubSchemaEmbeddedControlAttribute : FieldUIAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaEmbeddedControlAttribute

See Also

SubSchemaEmbeddedControlAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaEmbeddedControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaEmbeddedControlAttribute Members
SubSchemaEmbeddedControlAttribute Class Constructors Methods Properties See Also Send Feedback

The SubSchemaEmbeddedControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SubSchemaEmbeddedControlAttribute | Initializes a new instance of the SubSchemaEmbeddedControlAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetServer | Gets the field value changed observer.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | DrawBorder | Gets or sets a value indicating whether border around control should be drawn.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | ServerUI | Gets or sets the type of the server UI which should be taken (if not set the main server will be taken).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | SetFieldsDescription | Gets or sets a value indicating whether description of the fields inside the control should be set.
Public property | Span | Gets or sets a value indicating whether the embedded control should be extended to whole width of layout.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

SubSchemaEmbeddedControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaEmbeddedControlAttribute Constructor

SubSchemaEmbeddedControlAttribute Constructor
SubSchemaEmbeddedControlAttribute Class See Also Send Feedback
Initializes a new instance of the SubSchemaEmbeddedControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaEmbeddedControlAttribute()

See Also

SubSchemaEmbeddedControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaEmbeddedControlAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaEmbeddedControlAttribute Methods
SubSchemaEmbeddedControlAttribute Class See Also Send Feedback

The SubSchemaEmbeddedControlAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetServer | Gets the field value changed observer.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

SubSchemaEmbeddedControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetServer Method

SubSchemaEmbeddedControlAttribute..::..GetServer Method
SubSchemaEmbeddedControlAttribute Class See Also Send Feedback
Gets the field value changed observer.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual IServerUI GetServer()

Return Value

See Also

SubSchemaEmbeddedControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaEmbeddedControlAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaEmbeddedControlAttribute Properties
SubSchemaEmbeddedControlAttribute Class See Also Send Feedback

The SubSchemaEmbeddedControlAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | DrawBorder | Gets or sets a value indicating whether border around control should be drawn.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | ServerUI | Gets or sets the type of the server UI which should be taken (if not set the main server will be taken).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | SetFieldsDescription | Gets or sets a value indicating whether description of the fields inside the control should be set.
Public property | Span | Gets or sets a value indicating whether the embedded control should be extended to whole width of layout.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

SubSchemaEmbeddedControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


DrawBorder Property

SubSchemaEmbeddedControlAttribute..::..DrawBorder Property
SubSchemaEmbeddedControlAttribute Class See Also Send Feedback
Gets or sets a value indicating whether border around control should be drawn.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool DrawBorder { get; set; }

Field Value

true if draw border; otherwise, false.

See Also

SubSchemaEmbeddedControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ServerUI Property

SubSchemaEmbeddedControlAttribute..::..ServerUI Property
SubSchemaEmbeddedControlAttribute Class See Also Send Feedback
Gets or sets the type of the server UI which should be taken (if not set the main server will be taken).

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type ServerUI { get; set; }

Field Value

The type of the server UI.

See Also

SubSchemaEmbeddedControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SetFieldsDescription Property

SubSchemaEmbeddedControlAttribute..::..SetFieldsDescription Property
SubSchemaEmbeddedControlAttribute Class See Also Send Feedback
Gets or sets a value indicating whether description of the fields inside the control should be set.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool SetFieldsDescription { get; set; }

Field Value

true if [set fields description]; otherwise, false.

See Also

SubSchemaEmbeddedControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Span Property

SubSchemaEmbeddedControlAttribute..::..Span Property
SubSchemaEmbeddedControlAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the embedded control should be extended to whole width of layout.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Span { get; set; }

Field Value

true if span; otherwise, false.

See Also

SubSchemaEmbeddedControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaListTableAttribute Class

SubSchemaListTableAttribute Class
Members See Also Send Feedback
Indicates that particular schema list will be presented as table.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SubSchemaListTableAttribute : FieldUIAttribute

Remarks

Only for arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaListTableAttribute

See Also

SubSchemaListTableAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaListTableAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTableAttribute Members
SubSchemaListTableAttribute Class Constructors Methods Properties See Also Send Feedback

The SubSchemaListTableAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SubSchemaListTableAttribute()()()() | Initializes a new instance of the SubSchemaListTableAttribute class.
Public method | SubSchemaListTableAttribute(array<Int32>[]()[][]) | Initializes a new instance of the SubSchemaListTableAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaxHeight | Gets or sets the maximum height of the control.
Public property | PercentageColumnWidth | Gets the width of columns in procentage units.
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Span | Gets or sets a value indicating whether this SubSchemaListTableAttribute is span.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaListTableAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTableAttribute Constructor
SubSchemaListTableAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SubSchemaListTableAttribute()()()() | Initializes a new instance of the SubSchemaListTableAttribute class.
Public method | SubSchemaListTableAttribute(array<Int32>[]()[][]) | Initializes a new instance of the SubSchemaListTableAttribute class.

See Also

SubSchemaListTableAttribute Class
SubSchemaListTableAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaListTableAttribute Constructor

SubSchemaListTableAttribute Constructor
SubSchemaListTableAttribute Class See Also Send Feedback
Initializes a new instance of the SubSchemaListTableAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaListTableAttribute()

See Also

SubSchemaListTableAttribute Class
SubSchemaListTableAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaListTableAttribute Constructor (Int32[])

SubSchemaListTableAttribute Constructor (array<Int32>[]()[][])
SubSchemaListTableAttribute Class See Also Send Feedback
Initializes a new instance of the SubSchemaListTableAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaListTableAttribute(
    params int[] percentageColumnWidth
)

Parameters

percentageColumnWidth
Type: array< System..::..Int32 >[]()[][]

See Also

SubSchemaListTableAttribute Class
SubSchemaListTableAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaListTableAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTableAttribute Methods
SubSchemaListTableAttribute Class See Also Send Feedback

The SubSchemaListTableAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


SubSchemaListTableAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaListTableAttribute Properties
SubSchemaListTableAttribute Class See Also Send Feedback

The SubSchemaListTableAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaxHeight | Gets or sets the maximum height of the control.
Public property | PercentageColumnWidth | Gets the width of columns in procentage units.
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Span | Gets or sets a value indicating whether this SubSchemaListTableAttribute is span.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToAddElements Property

SubSchemaListTableAttribute..::..AllowToAddElements Property
SubSchemaListTableAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to add elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToAddElements { get; set; }

Field Value

true if the user will be able to add elements; otherwise, false.

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AllowToRemoveElements Property

SubSchemaListTableAttribute..::..AllowToRemoveElements Property
SubSchemaListTableAttribute Class See Also Send Feedback
Gets or sets a value indicating whether the user will be able to remove elements.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool AllowToRemoveElements { get; set; }

Field Value

true if the user will be able to remove elements; otherwise, false.

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MaxHeight Property

SubSchemaListTableAttribute..::..MaxHeight Property
SubSchemaListTableAttribute Class See Also Send Feedback
Gets or sets the maximum height of the control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int MaxHeight { get; set; }

Field Value

The height of the max.

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PercentageColumnWidth Property

SubSchemaListTableAttribute..::..PercentageColumnWidth Property
SubSchemaListTableAttribute Class See Also Send Feedback
Gets the width of columns in procentage units.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public int[] PercentageColumnWidth { get; private set; }

Field Value

The width of the column.

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


Span Property

SubSchemaListTableAttribute..::..Span Property
SubSchemaListTableAttribute Class See Also Send Feedback
Gets or sets a value indicating whether this SubSchemaListTableAttribute is span.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool Span { get; set; }

Field Value

true if span; otherwise, false.

See Also

SubSchemaListTableAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


TextBoxAttribute Class

TextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with the TextBox control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class TextBoxAttribute : FormatFieldAttribute,
    IValidateAttribute

Remarks

TextBoxAttribute provides default formatting which is based on .NET mechanism. Please use dedicated attributes for more accurate formatting or assign specific Format type to this instance (FieldFormat property).

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridKeyTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ListTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..NumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..XYZTextBoxAttribute

See Also

TextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


TextBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
TextBoxAttribute Members
TextBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The TextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TextBoxAttribute | Initializes a new instance of the TextBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValidator | Gets the field validator.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

TextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


TextBoxAttribute Constructor

TextBoxAttribute Constructor
TextBoxAttribute Class See Also Send Feedback
Initializes a new instance of the TextBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TextBoxAttribute()

See Also

TextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


TextBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
TextBoxAttribute Methods
TextBoxAttribute Class See Also Send Feedback

The TextBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValidator | Gets the field validator.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

TextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetFieldValidator Method

TextBoxAttribute..::..GetFieldValidator Method
TextBoxAttribute Class See Also Send Feedback
Gets the field validator.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IFieldValidator GetFieldValidator()

Return Value

Implements

IValidateAttribute..::..GetFieldValidator()()()()

See Also

TextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


TextBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
TextBoxAttribute Properties
TextBoxAttribute Class See Also Send Feedback

The TextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

TextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FieldValidator Property

TextBoxAttribute..::..FieldValidator Property
TextBoxAttribute Class See Also Send Feedback
Gets or sets the field validator.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type FieldValidator { get; set; }

Field Value

The field validator.

Remarks

The type has to implement IFieldValidator interface.

See Also

TextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitCheckedListAttribute Class

UnitCheckedListAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with UnitCheckedList control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class UnitCheckedListAttribute : CheckedListAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CheckedListAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitCheckedListAttribute

See Also

UnitCheckedListAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitCheckedListAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
UnitCheckedListAttribute Members
UnitCheckedListAttribute Class Constructors Methods Properties See Also Send Feedback

The UnitCheckedListAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | UnitCheckedListAttribute()()()() | Initializes a new instance of the UnitCheckedListAttribute class.
Public method | UnitCheckedListAttribute(array<Object>[]()[][]) | Initializes a new instance of the UnitCheckedListAttribute class.
Public method | UnitCheckedListAttribute(String) | Initializes a new instance of the UnitCheckedListAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

UnitCheckedListAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitCheckedListAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
UnitCheckedListAttribute Constructor
UnitCheckedListAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnitCheckedListAttribute()()()() | Initializes a new instance of the UnitCheckedListAttribute class.
Public method | UnitCheckedListAttribute(array<Object>[]()[][]) | Initializes a new instance of the UnitCheckedListAttribute class.
Public method | UnitCheckedListAttribute(String) | Initializes a new instance of the UnitCheckedListAttribute class.

See Also

UnitCheckedListAttribute Class
UnitCheckedListAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitCheckedListAttribute Constructor

UnitCheckedListAttribute Constructor
UnitCheckedListAttribute Class See Also Send Feedback
Initializes a new instance of the UnitCheckedListAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitCheckedListAttribute()

See Also

UnitCheckedListAttribute Class
UnitCheckedListAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitCheckedListAttribute Constructor (Object[])

UnitCheckedListAttribute Constructor (array<Object>[]()[][])
UnitCheckedListAttribute Class See Also Send Feedback
Initializes a new instance of the UnitCheckedListAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitCheckedListAttribute(
    params Object[] items
)

Parameters

items
Type: array< System..::..Object >[]()[][]
The list of items.

See Also

UnitCheckedListAttribute Class
UnitCheckedListAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitCheckedListAttribute Constructor (String)

UnitCheckedListAttribute Constructor (String)
UnitCheckedListAttribute Class See Also Send Feedback
Initializes a new instance of the UnitCheckedListAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitCheckedListAttribute(
    string dataSourceKey
)

Parameters

dataSourceKey
Type: System..::..String
The data source key.

See Also

UnitCheckedListAttribute Class
UnitCheckedListAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitCheckedListAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
UnitCheckedListAttribute Methods
UnitCheckedListAttribute Class See Also Send Feedback

The UnitCheckedListAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

UnitCheckedListAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitCheckedListAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
UnitCheckedListAttribute Properties
UnitCheckedListAttribute Class See Also Send Feedback

The UnitCheckedListAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

UnitCheckedListAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitComboBoxAttribute Class

UnitComboBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with UnitComboBox control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class UnitComboBoxAttribute : ComboBoxAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitComboBoxAttribute

See Also

UnitComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitComboBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
UnitComboBoxAttribute Members
UnitComboBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The UnitComboBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | UnitComboBoxAttribute()()()() | Initializes a new instance of the UnitComboBoxAttribute class.
Public method | UnitComboBoxAttribute(array<Object>[]()[][]) | Initializes a new instance of the UnitComboBoxAttribute class.
Public method | UnitComboBoxAttribute(String) | Initializes a new instance of the UnitComboBoxAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

UnitComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitComboBoxAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
UnitComboBoxAttribute Constructor
UnitComboBoxAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnitComboBoxAttribute()()()() | Initializes a new instance of the UnitComboBoxAttribute class.
Public method | UnitComboBoxAttribute(array<Object>[]()[][]) | Initializes a new instance of the UnitComboBoxAttribute class.
Public method | UnitComboBoxAttribute(String) | Initializes a new instance of the UnitComboBoxAttribute class.

See Also

UnitComboBoxAttribute Class
UnitComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitComboBoxAttribute Constructor

UnitComboBoxAttribute Constructor
UnitComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the UnitComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitComboBoxAttribute()

See Also

UnitComboBoxAttribute Class
UnitComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitComboBoxAttribute Constructor (Object[])

UnitComboBoxAttribute Constructor (array<Object>[]()[][])
UnitComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the UnitComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitComboBoxAttribute(
    params Object[] items
)

Parameters

items
Type: array< System..::..Object >[]()[][]
The items.

See Also

UnitComboBoxAttribute Class
UnitComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitComboBoxAttribute Constructor (String)

UnitComboBoxAttribute Constructor (String)
UnitComboBoxAttribute Class See Also Send Feedback
Initializes a new instance of the UnitComboBoxAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitComboBoxAttribute(
    string dataSourceKey
)

Parameters

dataSourceKey
Type: System..::..String
The data source key.

See Also

UnitComboBoxAttribute Class
UnitComboBoxAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitComboBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
UnitComboBoxAttribute Methods
UnitComboBoxAttribute Class See Also Send Feedback

The UnitComboBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Inherited from FormatFieldAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

UnitComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitComboBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
UnitComboBoxAttribute Properties
UnitComboBoxAttribute Class See Also Send Feedback

The UnitComboBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Items | The list of items. (Inherited from DataSourceFormatFieldAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

UnitComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitNumericUpDownAttribute Class

UnitNumericUpDownAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with UnitNumericUpDown control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class UnitNumericUpDownAttribute : NumericUpDownAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..NumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitNumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridUnitNumericUpDownAttribute

See Also

UnitNumericUpDownAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitNumericUpDownAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
UnitNumericUpDownAttribute Members
UnitNumericUpDownAttribute Class Constructors Methods Properties See Also Send Feedback

The UnitNumericUpDownAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | UnitNumericUpDownAttribute()()()() | Initializes a new instance of the UnitNumericUpDownAttribute class.
Public method | UnitNumericUpDownAttribute(Double, Double, Double, DisplayUnitType) | Initializes a new instance of the UnitNumericUpDownAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Overrides FormatFieldAttribute..::..GetFieldFormat()()()().)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AttributeUnit | Unit in which values of the attribute are described
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumValue | Maximum value (Inherited from NumericUpDownAttribute.)
Public property | MinimumValue | Describes minimum value that may be input into control. (Inherited from NumericUpDownAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step. (Inherited from NumericUpDownAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

UnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitNumericUpDownAttribute Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
UnitNumericUpDownAttribute Constructor
UnitNumericUpDownAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnitNumericUpDownAttribute()()()() | Initializes a new instance of the UnitNumericUpDownAttribute class.
Public method | UnitNumericUpDownAttribute(Double, Double, Double, DisplayUnitType) | Initializes a new instance of the UnitNumericUpDownAttribute class.

See Also

UnitNumericUpDownAttribute Class
UnitNumericUpDownAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitNumericUpDownAttribute Constructor

UnitNumericUpDownAttribute Constructor
UnitNumericUpDownAttribute Class See Also Send Feedback
Initializes a new instance of the UnitNumericUpDownAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitNumericUpDownAttribute()

See Also

UnitNumericUpDownAttribute Class
UnitNumericUpDownAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitNumericUpDownAttribute Constructor (Double, Double, Double, )

UnitNumericUpDownAttribute Constructor (Double, Double, Double, )
UnitNumericUpDownAttribute Class See Also Send Feedback
Initializes a new instance of the UnitNumericUpDownAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitNumericUpDownAttribute(
    double minValue,
    double maxValue,
    double step,
    DisplayUnitType unit
)

Parameters

minValue
Type: System..::..Double
The min value.
maxValue
Type: System..::..Double
The max value.
step
Type: System..::..Double
The step.
unit
Type: DisplayUnitType
The unit attributes values are described with.

See Also

UnitNumericUpDownAttribute Class
UnitNumericUpDownAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitNumericUpDownAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
UnitNumericUpDownAttribute Methods
UnitNumericUpDownAttribute Class See Also Send Feedback

The UnitNumericUpDownAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Overrides FormatFieldAttribute..::..GetFieldFormat()()()().)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

UnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetFieldFormat Method

UnitNumericUpDownAttribute..::..GetFieldFormat Method
UnitNumericUpDownAttribute Class See Also Send Feedback
Gets the field format.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override IFieldFormat GetFieldFormat()

Return Value

See Also

UnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitNumericUpDownAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
UnitNumericUpDownAttribute Properties
UnitNumericUpDownAttribute Class See Also Send Feedback

The UnitNumericUpDownAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeUnit | Unit in which values of the attribute are described
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumValue | Maximum value (Inherited from NumericUpDownAttribute.)
Public property | MinimumValue | Describes minimum value that may be input into control. (Inherited from NumericUpDownAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step. (Inherited from NumericUpDownAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

UnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

UnitNumericUpDownAttribute..::..AttributeUnit Property
UnitNumericUpDownAttribute Class See Also Send Feedback
Unit in which values of the attribute are described

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

See Also

UnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitTextBoxAttribute Class

UnitTextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with UnitTextBox control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class UnitTextBoxAttribute : FieldUIAttribute,
    IValidateAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridUnitTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ListUnitTextBoxAttribute

See Also

UnitTextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitTextBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
UnitTextBoxAttribute Members
UnitTextBoxAttribute Class Constructors Methods Fields Properties See Also Send Feedback

The UnitTextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | UnitTextBoxAttribute | Initializes a new instance of the UnitTextBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValidator | Gets the field validator.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Fields

Name | Description
PropertyMaximumValue | Describes attribute indicating maximum value
PropertyMinimumValue | Describes attribute indicating minimum value
PropertyValidateMaximumValue | Describes attribute indicating whether maximum value should be checked
PropertyValidateMinimumValue | Describes attribute indicating whether minimum value should be checked

Properties

 | Name | Description
Public property | AttributeUnit | Unit in which values of the attribute are described
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldValidator | Gets or sets the field validator.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumValue | Maximum value
Public property | MinimumValue | Minimum value
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValidateMaximumValue | Indicates if maximum value should be checked
Public property | ValidateMinimumValue | Indicates if minimum value should be checked
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitTextBoxAttribute Constructor

UnitTextBoxAttribute Constructor
UnitTextBoxAttribute Class See Also Send Feedback
Initializes a new instance of the UnitTextBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public UnitTextBoxAttribute()

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitTextBoxAttribute Fields

[image]

Structural Analysis and Code Checking API Reference Guide
UnitTextBoxAttribute Fields
UnitTextBoxAttribute Class See Also Send Feedback

The UnitTextBoxAttribute type exposes the following members.

Fields

Name | Description
PropertyMaximumValue | Describes attribute indicating maximum value
PropertyMinimumValue | Describes attribute indicating minimum value
PropertyValidateMaximumValue | Describes attribute indicating whether maximum value should be checked
PropertyValidateMinimumValue | Describes attribute indicating whether minimum value should be checked

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyMaximumValue Field

UnitTextBoxAttribute..::..PropertyMaximumValue Field
UnitTextBoxAttribute Class See Also Send Feedback
Describes attribute indicating maximum value

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyMaximumValue

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyMinimumValue Field

UnitTextBoxAttribute..::..PropertyMinimumValue Field
UnitTextBoxAttribute Class See Also Send Feedback
Describes attribute indicating minimum value

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyMinimumValue

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyValidateMaximumValue Field

UnitTextBoxAttribute..::..PropertyValidateMaximumValue Field
UnitTextBoxAttribute Class See Also Send Feedback
Describes attribute indicating whether maximum value should be checked

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyValidateMaximumValue

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


PropertyValidateMinimumValue Field

UnitTextBoxAttribute..::..PropertyValidateMinimumValue Field
UnitTextBoxAttribute Class See Also Send Feedback
Describes attribute indicating whether minimum value should be checked

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public const string PropertyValidateMinimumValue

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitTextBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
UnitTextBoxAttribute Methods
UnitTextBoxAttribute Class See Also Send Feedback

The UnitTextBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValidator | Gets the field validator.
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetFieldValidator Method

UnitTextBoxAttribute..::..GetFieldValidator Method
UnitTextBoxAttribute Class See Also Send Feedback
Gets the field validator.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IFieldValidator GetFieldValidator()

Return Value

Implements

IValidateAttribute..::..GetFieldValidator()()()()

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


UnitTextBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
UnitTextBoxAttribute Properties
UnitTextBoxAttribute Class See Also Send Feedback

The UnitTextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeUnit | Unit in which values of the attribute are described
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldValidator | Gets or sets the field validator.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumValue | Maximum value
Public property | MinimumValue | Minimum value
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValidateMaximumValue | Indicates if maximum value should be checked
Public property | ValidateMinimumValue | Indicates if minimum value should be checked
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


AttributeUnit Property

UnitTextBoxAttribute..::..AttributeUnit Property
UnitTextBoxAttribute Class See Also Send Feedback
Unit in which values of the attribute are described

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisplayUnitType AttributeUnit { get; set; }

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


FieldValidator Property

UnitTextBoxAttribute..::..FieldValidator Property
UnitTextBoxAttribute Class See Also Send Feedback
Gets or sets the field validator.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Type FieldValidator { get; set; }

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MaximumValue Property

UnitTextBoxAttribute..::..MaximumValue Property
UnitTextBoxAttribute Class See Also Send Feedback
Maximum value

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double MaximumValue { get; set; }

Remarks

It should be defined in unit type described by AttributeUnit

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


MinimumValue Property

UnitTextBoxAttribute..::..MinimumValue Property
UnitTextBoxAttribute Class See Also Send Feedback
Minimum value

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public double MinimumValue { get; set; }

Remarks

It should be defined in unit type described by AttributeUnit

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ValidateMaximumValue Property

UnitTextBoxAttribute..::..ValidateMaximumValue Property
UnitTextBoxAttribute Class See Also Send Feedback
Indicates if maximum value should be checked

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool ValidateMaximumValue { get; set; }

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


ValidateMinimumValue Property

UnitTextBoxAttribute..::..ValidateMinimumValue Property
UnitTextBoxAttribute Class See Also Send Feedback
Indicates if minimum value should be checked

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public bool ValidateMinimumValue { get; set; }

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


XYZTextBoxAttribute Class

XYZTextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with the XYZTextBox control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class XYZTextBoxAttribute : TextBoxAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..XYZTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridXYZTextBoxAttribute

See Also

XYZTextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


XYZTextBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
XYZTextBoxAttribute Members
XYZTextBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The XYZTextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | XYZTextBoxAttribute | Initializes a new instance of the XYZTextBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Overrides FormatFieldAttribute..::..GetFieldFormat()()()().)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

XYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


XYZTextBoxAttribute Constructor

XYZTextBoxAttribute Constructor
XYZTextBoxAttribute Class See Also Send Feedback
Initializes a new instance of the XYZTextBoxAttribute class

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public XYZTextBoxAttribute()

See Also

XYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


XYZTextBoxAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
XYZTextBoxAttribute Methods
XYZTextBoxAttribute Class See Also Send Feedback

The XYZTextBoxAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Overrides FormatFieldAttribute..::..GetFieldFormat()()()().)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

See Also

XYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


GetFieldFormat Method

XYZTextBoxAttribute..::..GetFieldFormat Method
XYZTextBoxAttribute Class See Also Send Feedback
Gets the field format.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override IFieldFormat GetFieldFormat()

Return Value

See Also

XYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace


XYZTextBoxAttribute Properties

[image]

Structural Analysis and Code Checking API Reference Guide
XYZTextBoxAttribute Properties
XYZTextBoxAttribute Class See Also Send Feedback

The XYZTextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

XYZTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace