FieldUIAttribute Members

Structural Analysis and Code Checking API Reference Guide
FieldUIAttribute Members
FieldUIAttribute Class Constructors Methods Fields Properties See Also

The FieldUIAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | FieldUIAttribute | Initializes the instance of FieldUIAttribute

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | GetFieldUIAttribute | Returns the UI attribute for specific field searched among input types.
Public method | GetFieldValueChanged | Gets the field value changed observer.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name.

Fields

Name | Description
PropertyIsEnabled | Describes attribute indicating if the field is enabled.
PropertyIsVisible | Describes attribute indicating if the field is visible.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag.
Public property | Context | Additional information used for instance by IResource interface to help user identify the field.
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled.
Public property | IsVisible | Indicates if the field is visible.
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription |
Public property | Tooltip | Gets or sets the tooltip.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace