Concrete Members

Structural Analysis and Code Checking API Reference Guide
Concrete Members
Concrete Class Constructors Methods Properties See Also

The Concrete type exposes the following members.

Constructors

 | Name | Description
Public method | Concrete | The default Concrete class constructor

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Concrete
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetStrainStressModelBiLinear | Sets all appropriate parameters for a bi-linear stress-strain relationship.
Public method | SetStrainStressModelLinear | Sets all appropriate parameters for a linear stress-strain relationship.
Public method | SetStrainStressModelParabolicRectangular | Sets all appropriate parameters for a parabola-rectangle stress-strain relationship.
Public method | SetStrainStressModelPowerRectangular | Sets all appropriate parameters for a power-rectangle stress-strain relationship.
Public method | SetStrainStressModelRectangular | Sets all appropriate parameters for a simplified model with rectangular stress distribution.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DesignStrength | The DesignStrength property represents the design strenght of concrete.
Public property | EffectiveHeightReductionFactor | The EffectiveHeightReductionFactor property represents the reduction factor of the compression zone height.
Public property | ModulusOfElasticity | The ModulusOfElasticity property represents the concrete modulus of elasticity (Young modulus).
Public property | Power | The Power property represents the power for an power-linar stress-strain relationship.
Public property | StrainRelationChangeOver | The StrainRelationChangeOver property represents the strain which changes the type of stress-strain relationship.
Public property | StrainStressModel | The StrainStressModel property represents the type of stress-strain relationship.
Public property | StrainUltimateLimit | The StrainUltimateLimit property represents the value of maximum strain.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace