RCArgumentException Methods

Structural Analysis and Code Checking API Reference Guide
RCArgumentException Methods
RCArgumentException Class See Also

The RCArgumentException type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from ArgumentException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RCArgumentException Class
Autodesk.CodeChecking.Concrete Namespace