NodeResults Members

Structural Analysis and Code Checking API Reference Guide
NodeResults Members
NodeResults Class Constructors Methods Properties See Also

The NodeResults type exposes the following members.

Constructors

 | Name | Description
Public method | NodeResults | Initializes a new instance of the NodeResults class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fx | Force along x-axis (Inherited from PointResults.)
Public property | Fy | Force along y-axis (Inherited from PointResults.)
Public property | Fz | Force along z-axis (Inherited from PointResults.)
Public property | Mx | Moment around x-axis (Inherited from PointResults.)
Public property | My | Moment around y-axis (Inherited from PointResults.)
Public property | Mz | Moment around z-axis (Inherited from PointResults.)
Public property | Rx | Rotation around x-axis (Inherited from PointResults.)
Public property | Ry | Rotation around y-axis (Inherited from PointResults.)
Public property | Rz | Rotation around z-axis (Inherited from PointResults.)
Public property | Ux | Displacement along x-axis (Inherited from PointResults.)
Public property | Uy | Displacement along y-axis (Inherited from PointResults.)
Public property | Uz | Displacement along z-axis (Inherited from PointResults.)

See Also

NodeResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace