ElementInfo Members

Structural Analysis and Code Checking API Reference Guide
ElementInfo Members
ElementInfo Class Constructors Methods Properties See Also

The ElementInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ElementInfo(ElementSlabsInfo, MaterialInfo) | Creates instance for slab.
Public method | ElementInfo(ElementWallsInfo, MaterialInfo) | Creates instance for wall.
Public method | ElementInfo(ElementSectionsInfo, ElementSectionsParamsInfo, ElementSlabsInfo, MaterialInfo) | Creates instance for beam with T-Section.
Public method | ElementInfo(ElementType, ElementSectionsInfo, ElementSectionsParamsInfo, MaterialInfo) | Creates instance for beam or column.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GeomLength | Calculate the geometrical length of the element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Material | Gets parameters of material for element.
Public property | RebarCovers | Gets parameters of rebar covers for element.
Public property | Sections | Gets sections along element length.
Public property | SectionsParams | Gets parameters of sections along element length.
Public property | Slabs | Gets properties of element's slabs.
Public property | Type | Gets the type of the element.
Public property | Walls | Gets properties of element's walls.

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace