BarPointProperties Members

Structural Analysis and Code Checking API Reference Guide
BarPointProperties Members
BarPointProperties Class Constructors Methods Properties See Also

The BarPointProperties type exposes the following members.

Constructors

 | Name | Description
Public method | BarPointProperties | Initializes a new set of section properties for bar's calculation point.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Ax | Cross section area (Inherited from BarProperties.)
Public property | Iy | Moment of inertia about the Y axis (Inherited from BarProperties.)
Public property | Iz | Moment of inertia about the Z axis (Inherited from BarProperties.)
Public property | Ky | Ky elastic ground coefficient (Inherited from BarProperties.)
Public property | Kz | Kz elastic ground coefficient (Inherited from BarProperties.)
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarPointProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace