DocumentRatio Members

Structural Analysis and Code Checking API Reference Guide
DocumentRatio Members
DocumentRatio Class Constructors Methods Properties See Also

The DocumentRatio type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentRatio | Initializes a new instance of the DocumentRatio class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDocumentStatus | Gets the document value representation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | FormattedValue | Gets or sets the formatted value.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Value | Gets or sets the value.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentRatio Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace