ListUnitTextBoxAttribute Members

Structural Analysis and Code Checking API Reference Guide
ListUnitTextBoxAttribute Members
ListUnitTextBoxAttribute Class Constructors Methods Fields Properties See Also

The ListUnitTextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ListUnitTextBoxAttribute | Initializes a new instance of the ListUnitTextBoxAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldValidator | Gets the field validator. (Inherited from UnitTextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Fields

Name | Description
PropertyMaximumItemCount | Describes attribute indicating maximum number of items.
PropertyMinimumItemCount | Describes attribute indicating minimum number of items.
PropertyValidateMaximumItemCount | Describes attribute indicating whether maximum number of items should be checked.
PropertyValidateMinimumItemCount | Describes attribute indicating whether minimum number of items should be checked.

Properties

 | Name | Description
Public property | AttributeUnit | Unit in which values of the attribute are described (Inherited from UnitTextBoxAttribute.)
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from UnitTextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumItemCount | Maximum number of items in the list.
Public property | MaximumValue | Maximum value (Inherited from UnitTextBoxAttribute.)
Public property | MinimumItemCount | Minimum number of items in the list
Public property | MinimumValue | Minimum value (Inherited from UnitTextBoxAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValidateMaximumItemCount | Indicates whether maximum number of items should be validated
Public property | ValidateMaximumValue | Indicates if maximum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValidateMinimumItemCount | Indicates if minimum number of items should be checked
Public property | ValidateMinimumValue | Indicates if minimum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace