Category Members

Structural Analysis and Code Checking API Reference Guide
Category Members
Category Class Constructors Methods Properties See Also

The Category type exposes the following members.

Constructors

 | Name | Description
Public method | Category | Initializes a new instance of the Category class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Controls | Gets the list of controls.
Public property | DisplayName | Gets or sets the display name.
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | Name | Gets or sets the name of the category.

See Also

Category Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace