DocumentMap Members

Structural Analysis and Code Checking API Reference Guide
DocumentMap Members
DocumentMap Class Constructors Methods Properties See Also

The DocumentMap type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentMap | Initializes a new instance of the DocumentMap class.

Methods

 | Name | Description
Public method | AddHole | Adds the hole.
Public method | AddPoint | Adds the point.
Public method | DefineContour | Defines the main polygon.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundBox | Gets the bound box.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHoles | Gets the polygon.
Public method | GetNodes | Gets the nodes.
Public method | GetPolygon | Gets the polygon.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetColors | Sets the legend colors.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | DisplayUnitType | Gets or sets the unit type data is defined in.
Public property | Legend | Gets or sets a value indicating whether this DocumentMap legend should be drawn.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | NegativeValuesColors | Gets or sets color for negative values.
Public property | PositiveValuesColors | Gets or sets colors for positive values.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | UnitType | Gets or sets the type of the unit.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)
Public property | Width | Gets or sets the width of map.

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace