LoadCombinationUtils Members

Structural Analysis and Code Checking API Reference Guide
LoadCombinationUtils Members
LoadCombinationUtils Class Constructors Methods See Also

The LoadCombinationUtils type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCombinationUtils | Initializes a new instance of the LoadCombinationUtils class

Methods

 | Name | Description
 | CopyLoadCaseArray | Copies the load case array.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>)) | Creates load combinations.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations.
 | CreateLoadCombinations(String, List<(Of <<'(List<(Of <<'(LoadCaseArray>)>>)>)>>), List<(Of <<'(Double>)>>)) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinationSets(List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(array<Double>[]()[][]>)>>)%) | Creates load combinations.
 | CreateLoadCombinationSets(List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>), Double, List<(Of <<'(array<Double>[]()[][]>)>>)%) | Sums load combinations.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLoadCaseNature | Gets the load case nature.
 | GetLoadCases | Gets the load cases.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GroupLoadCasesDueToCategory | Groups the load cases due to nature.
 | PerformAnd | Performs the and operation.
 | PerformOrExlusive | Performs the or exlusive operation.
 | PerformOrInclusive | Performs the or inclusive operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace