DocumentContentTable Methods

Structural Analysis and Code Checking API Reference Guide
DocumentContentTable Methods
DocumentContentTable Class See Also

The DocumentContentTable type exposes the following members.

Methods

 | Name | Description
Public method | Build | Builds the content table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevel | Gets the level of the section. (Inherited from DocumentSection.)
Public method | GetSectionOfName(String) | Gets the section of specific name. (Inherited from DocumentSection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetAdditionalData | Sets the additional data. (Inherited from DocumentSection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentContentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace