FieldUIAttribute Methods

Structural Analysis and Code Checking API Reference Guide
FieldUIAttribute Methods
FieldUIAttribute Class See Also

The FieldUIAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | GetFieldUIAttribute | Returns the UI attribute for specific field searched among input types.
Public method | GetFieldValueChanged | Gets the field value changed observer.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace