ValueWithDescriptionAttribute Properties

Structural Analysis and Code Checking API Reference Guide
ValueWithDescriptionAttribute Properties
ValueWithDescriptionAttribute Class See Also

The ValueWithDescriptionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | Note | Gets or sets the note.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ValueWithDescriptionAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace