DocumentElement Methods

Structural Analysis and Code Checking API Reference Guide
DocumentElement Methods
DocumentElement Class See Also

The DocumentElement type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDocumentElement(Entity, Field, Document) | Creates document element for specific field.
 | GetDocumentElement(PropertyInfo, Object, IResource, Document) | Gets the document element for specific property.
 | GetDocumentElement(String, Object, IResource, Document) | Gets the document element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace