DocumentTitle Members

Structural Analysis and Code Checking API Reference Guide
DocumentTitle Members
DocumentTitle Class Constructors Methods Properties See Also

The DocumentTitle type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentTitle()()()() | Initializes a new instance of the DocumentTitle class.
Public method | DocumentTitle(Int16) | Initializes a new instance of the DocumentTitle class.
Public method | DocumentTitle(String, Int16) | Initializes a new instance of the DocumentTitle class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AddLineBreak | Gets or sets a value indicating whether line break should be added after the element. (Inherited from DocumentText.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Size | Gets or sets the size.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Text | The text. (Inherited from DocumentText.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentTitle Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace