Layout Members

Structural Analysis and Code Checking API Reference Guide
Layout Members
Layout Class Constructors Methods Properties See Also

The Layout type exposes the following members.

Constructors

 | Name | Description
Public method | Layout | Initializes a new instance of the Layout class.

Methods

 | Name | Description
 | ApplyStyle | Applies the style.
 | Build(Schema, IResource) | Generates layout based on schema.
 | Build(Type, IResource) | Generates layout based on type.
 | BuildControl(IServerUI, Document, Object) | Creates the layout control (at the moment in WPF control).
 | BuildControl(IServerUI, Document, Layout, Entity) | Creates the layout control (at the moment in WPF control).
 | BuildControl(IServerUI, Document, Layout, Object) | Creates the layout control (at the moment in WPF control).
 | BuildControls | Generates list of controls based on type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategory | Gets the category.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SortIndexBased | Sorts current layout index based.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Controls | Gets the control list.

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace