ElementTSectionInfo Methods

Structural Analysis and Code Checking API Reference Guide
ElementTSectionInfo Methods
ElementTSectionInfo Class See Also

The ElementTSectionInfo type exposes the following members.

Methods

 | Name | Description
Public method | AdjoiningSlabOnTheLeftSide | Gets the adjoining slab on the left side of the element at the point along its length.
Public method | AdjoiningSlabOnTheRightSide | Gets the adjoining slab on the right side of the element at the point along its length.
Public method | BeamWidth | Gets width of element.
Public method | DistanceToNearestObjectOnTheLeftSide | Gets the distance to nearest characteristic object on the left side of the element. Distance is calculated at the point along the element length.
Public method | DistanceToNearestObjectOnTheRightSide | Gets the distance to nearest characteristic object on the right side of the element. Distance is calculated at the point along the element length.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContour | Gets contour of the joint section including flanges
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverlappingDepthOnTheLeftSide | Gets the distance from lower slab edge to upper element edge on the left side of the element. Depth is calculated at the point along the element length.
Public method | OverlappingDepthOnTheRightSide | Gets the distance from lower slab edge to upper element edge on the right side of the element. Depth is calculated at the point along the element length.
Public method | SlabThicknessOnTheLeftSide | Gets the thickness of the slab on the left side of the element at the point along its length.
Public method | SlabThicknessOnTheRightSide | Gets the thickness of the slab on the right side of the element at the point along its length.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TypeOfNearestObjectOnTheLeftSide | Gets type of nearest characteristic object on the left side of the element.
Public method | TypeOfNearestObjectOnTheRightSide | Gets type of nearest characteristic object on the right side of the element.

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace