ForceResultsPackageDescriptor Members

Structural Analysis and Code Checking API Reference Guide
ForceResultsPackageDescriptor Members
ForceResultsPackageDescriptor Class Methods Properties See Also

The ForceResultsPackageDescriptor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllResultPackageDescriptors | Returns a List of ForceResultsPackageDescriptor objects for all packages available in the current document
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetResultPackageDescriptor | Creates ForceResultsPackageDescriptor for a given document and package guid Throws exception if pack for the given guid is not found
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Guid | Gets ResultPackage guid
Public property | Name | Gets ResultPackage name

See Also

ForceResultsPackageDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace