SurfaceGraphParameters Members

Structural Analysis and Code Checking API Reference Guide
SurfaceGraphParameters Members
SurfaceGraphParameters Class Constructors Methods Properties See Also

The SurfaceGraphParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SurfaceGraphParameters()()()() | Creates SurfaceGraphParameters object.
Public method | SurfaceGraphParameters(UnitsSystem) | Creates SurfaceGraphParameters object.
Public method | SurfaceGraphParameters(UnitsSystem, Transform) | Creates SurfaceGraphParameters object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DirectionType |
Public property | DirectionX | XYZ coordinates of results's main direction. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | DirectionZ | XYZ coordinates of results's normal direction. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | LocalCoordinateSystem | Transform of results's. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | UnitsSystem | Defines the set of units used when querying for results.

See Also

SurfaceGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace