GridTextBoxAttribute Properties

Structural Analysis and Code Checking API Reference Guide
GridTextBoxAttribute Properties
GridTextBoxAttribute Class See Also

The GridTextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

GridTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace