Document Members

Structural Analysis and Code Checking API Reference Guide
Document Members
Document Class Constructors Methods Properties See Also

The Document type exposes the following members.

Constructors

 | Name | Description
Public method | Document | Initializes a new instance of the Document class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Footer | Gets or sets the footer.
Public property | Header | Gets or sets the header.
Public property | Main | Gets or sets the main body of the document.
Public property | Title | Gets or sets the title.

See Also

Document Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace