ResultComposer Methods

Structural Analysis and Code Checking API Reference Guide
ResultComposer Methods
ResultComposer Class See Also

The ResultComposer type exposes the following members.

Methods

 | Name | Description
Public method | AddCalculationParametersSection | Adds the calculation parameters section.
Public method | AddElementSection | Adds the element section.
Public method | AddElementsSection | Adds the elements section.
Public method | AddFamiliesSection | Adds the families section.
Public method | AddFamily | Adds the family.
Public method | AddHeader | Adds the header.
Public method | AddLabel | Adds the label.
Public method | AddLabelsSection | Adds the labels section.
Public method | AddMaterial | Adds the material.
Public method | AddMaterialsSection | Adds the materials section.
Public method | AddRebarCover | Adds the rebar cover.
Public method | BuildDocument | Builds the document.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillElementRegularParameters | Fills the element regular parameters.
Public method | FillElementServerResults | Fills the element section with server results.
Public method | GetCalculationParams | Gets the calculation params.
Public method | GetFamiliesSection | Gets the families section.
Public method | GetFamilySection | Gets the family section.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSection(String) | Gets the label section.
Public method | GetLabelSection(String, String) | Gets the label section.
Public method | GetLabelsSection | Gets the labels section.
Public method | GetMaterialSection | Gets the material section.
Public method | GetMaterialsSection | Gets the materials section.
 | GetResultStatus | Gets the result status of element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GroupLabels | Groups labels.
Public method | SortAndGroupElements(DocumentBody, List<(Of <<'(GroupMethod>)>>), SortMethod) | Sorts and group elements.
Public method | SortAndGroupElements(DocumentSection, List<(Of <<'(GroupMethod>)>>), SortMethod) | Sorts and group elements.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace