SlabEdge Members

Structural Analysis and Code Checking API Reference Guide
SlabEdge Members
SlabEdge Class Constructors Methods Properties See Also

The SlabEdge type exposes the following members.

Constructors

 | Name | Description
Public method | SlabEdge(SlabContour) | Constructs object.
Public method | SlabEdge(SlabInfo) | Constructs object.
Public method | SlabEdge(SlabContour, List<(Of <<'(SlabNode>)>>)) | Constructs object.
Public method | SlabEdge(SlabContour, SlabNode, SlabNode) | Constructs object.

Methods

 | Name | Description
Public method | ArePointsLikeNodes | Checks if points from the list has the same coordinates as current edge.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCenter | Returns center of edge.
Public method | GetDistanceFromPoint | Returns distance to specific point.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from SlabBaseObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLineCrossingThis | Checks if line is crossing current edge.
Public method | IsPointOnEdge | Checks if specific point is on edge.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element. (Inherited from SlabBaseObject.)
Public property | ContextId | Revit Id of element. (Inherited from SlabBaseObject.)
Public property | ElementType | Type of element. (Inherited from SlabBaseObject.)
Public property | NodeEnd | Gets end node.
Public property | Nodes | Gets nodes.
Public property | NodeStart | Gets start node.
Public property | ParentContour | Gets parent contour.
Public property | ParentSlab | Parent slab. (Inherited from SlabBaseObject.)

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace