EnumControlAttribute Properties

Structural Analysis and Code Checking API Reference Guide
EnumControlAttribute Properties
EnumControlAttribute Class See Also

The EnumControlAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | EnumType | Gets or sets the type of the enum.
Public property | ImageSize | Gets or sets the size of the image.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Item | Gets or sets the presentation item.
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | Presentation | Gets or sets the presentation mode.
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | SubSchemasToValues | Gets or sets the sub schemas to values map.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

EnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace