SubSchemaElementAttribute Properties

Structural Analysis and Code Checking API Reference Guide
SubSchemaElementAttribute Properties
SubSchemaElementAttribute Class See Also

The SubSchemaElementAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AddHeader | Gets or sets a value indicating whether header should be added. (Inherited from TableAttribute.)
Public property | Index | Decides about position of the property in document. (Inherited from DocumentElementAttribute.)
Public property | Level | Gets or sets the detail level of the element. (Inherited from DocumentElementAttribute.)
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable. (Inherited from DocumentElementAttribute.)
Public property | LocalizableValue | Gets or sets a value indicating whether value should be localized. (Inherited from ValueAttribute.)
Public property | Name | The name of the value. (Inherited from ValueWithNameAttribute.)
Public property | NamePostfix | The name postfix. (Inherited from ValueWithNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SubSchemaElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace