DocumentElement Members

Structural Analysis and Code Checking API Reference Guide
DocumentElement Members
DocumentElement Class Constructors Methods Properties See Also

The DocumentElement type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentElement | Initializes a new instance of the DocumentElement class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDocumentElement(Entity, Field, Document) | Creates document element for specific field.
 | GetDocumentElement(PropertyInfo, Object, IResource, Document) | Gets the document element for specific property.
 | GetDocumentElement(String, Object, IResource, Document) | Gets the document element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data.
Public property | Level | Gets or sets the detail level of element.
Public property | Source | Gets or sets the source (e.g. name of property).
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible.

See Also

DocumentElement Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace