SlabContour Members

Structural Analysis and Code Checking API Reference Guide
SlabContour Members
SlabContour Class Constructors Methods Properties See Also

The SlabContour type exposes the following members.

Constructors

 | Name | Description
Public method | SlabContour(SlabInfo) | Construct object as SlabElementType.Contour type.
Public method | SlabContour(SlabInfo, SlabContourType) | Construct object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdge | Returns edge of specific coordinates.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from SlabBaseObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsContourInside(List<(Of <<'(XYZ>)>>)) | Checks if contour is inside current one.
Public method | IsContourInside(SlabContour) | Checks if contour is inside current one.
Public method | IsCrossingLine | Checks if line is crossing current contour.
Public method | IsPointInside | Checks if point is inside contour.
Public method | IsPointOnEdge | Checks if point is on edge.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element. (Inherited from SlabBaseObject.)
Public property | ContextId | Revit Id of element. (Inherited from SlabBaseObject.)
Public property | ContourType | Type of slab contour.
Public property | Edges | List of edges.
Public property | ElementType | Type of element. (Inherited from SlabBaseObject.)
Public property | IsClockWise | Check if contour is clockwise.
Public property | IsClosed | Checks if contour is closed
Public property | Nodes | List of nodes.
Public property | ParentSlab | Parent slab. (Inherited from SlabBaseObject.)

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace