Label Methods

Structural Analysis and Code Checking API Reference Guide
Label Methods
Label Class See Also

The Label type exposes the following members.

Methods

 | Name | Description
Public method | Clone()()()() | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Clone(Boolean) | Duplicates current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServerStorageSchemaBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetServerStorageServerBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Overrides SchemaClass..::..Load(Element).)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets particular entity for specific server of input ID. (Overrides Storage<(Of <(<'T>)>)>..::..SetEntity(Entity, Guid).)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerStorage | Adds the server data to storage. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace