CalculationParam Members

Structural Analysis and Code Checking API Reference Guide
CalculationParam Members
CalculationParam Class Methods Fields Properties See Also

The CalculationParam type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputResultPackage | Gets the input package for specific code.
Public method | GetInputResultPackageId | Gets the input package for specific code.
Public method | GetLoadCasesAndCombinations | Gets load combinations.
Public method | GetOutputResultPackage(Guid) | Gets the output package.
Public method | GetOutputResultPackage(Guid, Guid, Boolean) | Gets the output package.
Public method | GetOutputResultPackageBuilder(Guid) |
Public method | GetOutputResultPackageBuilder(Guid, Guid) | Gets the output package builder.
Public method | GetServerPackage(Guid, Boolean) |
Public method | GetServerPackage(Guid, Guid, Boolean) |
Public method | GetServerStorageSchemaBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetServerStorageServerBased | (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced). (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetEntity(SchemaClass, Guid) | Sets the entity. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | SetInputResultPackage | Sets the input package.
Public method | SetLoadCasesAndCombinations | Sets load combinations.
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerPackage |
Public method | SetServerStorage | Adds the server data to storage. (Inherited from Storage<(Of <(<'T>)>)>.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
CommonPackage | Common package id

Properties

 | Name | Description
Public property | Document | Gets or sets the document. (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ElementId | Gets or sets the Element (Inherited from Storage<(Of <(<'T>)>)>.)
Public property | ServersStorages | Gets or sets list of entities (for different servers) (Inherited from Storage<(Of <(<'T>)>)>.)

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace