MaterialConcreteCharacteristics Members

Structural Analysis and Code Checking API Reference Guide
MaterialConcreteCharacteristics Members
MaterialConcreteCharacteristics Class Constructors Methods Properties See Also

The MaterialConcreteCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialConcreteCharacteristics()()()() | Creates default instance.
Public method | MaterialConcreteCharacteristics(MaterialConcreteCharacteristics) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BendingReinforcement | Gets the bending reinforcement of the concrete.
Public property | Compression | Gets the compression of the concrete.
Public property | ShearReinforcement | Gets the shear reinforcement of the concrete.
Public property | ShearStrengthReduction | Gets the shear strength reduction of the concrete.

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace