StorageService Methods

Structural Analysis and Code Checking API Reference Guide
StorageService Methods
StorageService Class See Also

The StorageService type exposes the following members.

Methods

 | Name | Description
Public method | DocumentClosed | Reacts on document closing.
Public method | DocumentOpened | Reacts on document opening.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCommonDataStorage | Gets the common data storage.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStorageDocument | Returns storage document for particular Revit document.
 | GetStorageService | Returns instance of service.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserDataStorage | Gets the user data storage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StorageService Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace