ILayoutControl Methods

Structural Analysis and Code Checking API Reference Guide
ILayoutControl Methods
ILayoutControl Interface See Also

The ILayoutControl type exposes the following members.

Methods

 | Name | Description
Public method | BuildLayout | Builds the layout control based on logic structure.
Public method | ExpandCategory | Expands the category. (Inherited from ISchemaEditor.)
Public method | GetEntity | Returns entity based on current control settings. (Inherited from ISchemaEditor.)
Public method | GetFieldEditor | Gets the field editor. (Inherited from ISchemaEditor.)
Public method | GetObject | Returns entity based on current control settings. (Inherited from ISchemaEditor.)
Public method | GetValue | Gets value of specific field (Inherited from ISchemaEditor.)
Public method | Initialize | Initializes layout with data.
Public method | OpenSubSchemaDialog | Opens the sub schema dialog. (Inherited from ISchemaEditor.)
Public method | RefreshEditor | Refreshes the control. (Inherited from ISchemaEditor.)
Public method | SetAttribute | Sets the attributes of the field. (Inherited from ISchemaEditor.)
Public method | SetCategoryAttribute | Sets the category attributes. (Inherited from ISchemaEditor.)
Public method | SetEntity | Sets entity. (Inherited from ISchemaEditor.)
Public method | SetImageSourceAttribute | Sets the image attribute. (Inherited from ISchemaEditor.)
Public method | SetObject | Sets entity. (Inherited from ISchemaEditor.)
Public method | SetTextBlockContentAttribute | Sets the text block content attribute. (Inherited from ISchemaEditor.)
Public method | SetValue | Sets value for specific field (Inherited from ISchemaEditor.)

See Also

ILayoutControl Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace