DocumentContentTable Members

Structural Analysis and Code Checking API Reference Guide
DocumentContentTable Members
DocumentContentTable Class Constructors Methods Properties See Also

The DocumentContentTable type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentContentTable | Initializes a new instance of the DocumentContentTable class.

Methods

 | Name | Description
Public method | Build | Builds the content table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevel | Gets the level of the section. (Inherited from DocumentSection.)
Public method | GetSectionOfName(String) | Gets the section of specific name. (Inherited from DocumentSection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetAdditionalData | Sets the additional data. (Inherited from DocumentSection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Anchor | Gets or sets the anchor. (Inherited from DocumentSection.)
Public property | Body | Gets or sets the body. (Inherited from DocumentSection.)
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name. (Inherited from DocumentSection.)
Public property | ParentDocument | Gets or sets the parent document. (Inherited from DocumentSection.)
Public property | ParentSection | Gets or sets the parent section. (Inherited from DocumentSection.)
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title. (Inherited from DocumentSection.)
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentContentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace