ProgressStatusCode Members

Structural Analysis and Code Checking API Reference Guide
ProgressStatusCode Members
ProgressStatusCode Class Constructors Methods Properties See Also

The ProgressStatusCode type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressStatusCode | Initializes a new instance of the ProgressStatusCode class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | Gets or sets the code. (Inherited from ProgressStatus.)
Public property | Errors | Gets or sets the errors. (Inherited from ProgressStatus.)
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | Messages | Gets or sets the messages. (Inherited from ProgressStatus.)
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title. (Inherited from ProgressStatus.)
Public property | Warnings | Gets or sets the warnings. (Inherited from ProgressStatus.)

See Also

ProgressStatusCode Class
Autodesk.Revit.DB.CodeChecking Namespace