SlabContour Properties

Structural Analysis and Code Checking API Reference Guide
SlabContour Properties
SlabContour Class See Also

The SlabContour type exposes the following members.

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element. (Inherited from SlabBaseObject.)
Public property | ContextId | Revit Id of element. (Inherited from SlabBaseObject.)
Public property | ContourType | Type of slab contour.
Public property | Edges | List of edges.
Public property | ElementType | Type of element. (Inherited from SlabBaseObject.)
Public property | IsClockWise | Check if contour is clockwise.
Public property | IsClosed | Checks if contour is closed
Public property | Nodes | List of nodes.
Public property | ParentSlab | Parent slab. (Inherited from SlabBaseObject.)

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace