FieldControl Members

Structural Analysis and Code Checking API Reference Guide
FieldControl Members
FieldControl Class Constructors Methods Properties See Also

The FieldControl type exposes the following members.

Constructors

 | Name | Description
Public method | FieldControl | Initializes a new instance of the FieldControl class.

Methods

 | Name | Description
 | Build(PropertyInfo, IResource, Guid) | Generates the Field Control based on property attributes.
 | Build(Type, String, IResource) | Generates the FieldControl based on property attributes.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDisplayName | Gets the display name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUIAttribute | Gets the UI attribute.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Container | Gets the container.
Public property | FieldDisplayName | Gets or sets the display name of the field.
Public property | FieldName | Gets or sets the name of the field.
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | KeyType | Gets the type of the key.
Public property | KeyVisualAttribute | Gets or sets the visual attribute.
Public property | SchemaGuid | Gets or sets the schema GUID.
Public property | UnitAttribute | Gets the unit attribute.
Public property | ValueType | Gets the type of the value.
Public property | VisualAttribute | Gets or sets the visual attribute.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace