Concrete Methods

Structural Analysis and Code Checking API Reference Guide
Concrete Methods
Concrete Class See Also

The Concrete type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetStrainStressModelBiLinear | Sets all appropriate parameters for a bi-linear stress-strain relationship.
Public method | SetStrainStressModelLinear | Sets all appropriate parameters for a linear stress-strain relationship.
Public method | SetStrainStressModelParabolicRectangular | Sets all appropriate parameters for a parabola-rectangle stress-strain relationship.
Public method | SetStrainStressModelPowerRectangular | Sets all appropriate parameters for a power-rectangle stress-strain relationship.
Public method | SetStrainStressModelRectangular | Sets all appropriate parameters for a simplified model with rectangular stress distribution.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace