CategoriesAttribute Properties

Structural Analysis and Code Checking API Reference Guide
CategoriesAttribute Properties
CategoriesAttribute Class See Also

The CategoriesAttribute type exposes the following members.

Properties

 | Name | Description
Public property | CategoriesIndexes | Gets or sets the categories indexes.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CategoriesAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace