ElementSectionsParamsInfo Members

Structural Analysis and Code Checking API Reference Guide
ElementSectionsParamsInfo Members
ElementSectionsParamsInfo Class Constructors Methods Properties See Also

The ElementSectionsParamsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSectionsParamsInfo()()()() | Creates default instance (not tapered).
Public method | ElementSectionsParamsInfo(ElementSectionsParamsInfo) | Creates instance from pattern.
Public method | ElementSectionsParamsInfo(SectionProfile, SectionsParamsInfo) | Creates not tapered instance.
Public method | ElementSectionsParamsInfo(SectionProfile, SectionsParamsInfo, SectionsParamsInfo) | Creates tapered instance.

Methods

 | Name | Description
Public method | AtThePoint | Gets the dimensions of the section at the point along element length.
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides SectionProfile..::..Clone()()()().)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Overrides SectionProfile..::..CompareTo(Object).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AtTheBeg | Gets the parameters of the section at the begining of the element.
Public property | AtTheEnd | Gets the parameters of the section at the end of the element.
Public property | ComponentsShapeType | Gets the list of components types of the shapes for double or compound section. (Inherited from SectionProfile.)
Public property | ShapeType | Gets the type of the shape of section. (Inherited from SectionProfile.)
Public property | Tapered | Gets a value indicating whether the profile is tapered. (Inherited from SectionProfile.)

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace