BarPointResults Properties

Structural Analysis and Code Checking API Reference Guide
BarPointResults Properties
BarPointResults Class See Also

The BarPointResults type exposes the following members.

Properties

 | Name | Description
Public property | Fx | Force along x-axis (Inherited from PointResults.)
Public property | Fy | Force along y-axis (Inherited from PointResults.)
Public property | Fz | Force along z-axis (Inherited from PointResults.)
Public property | Mx | Moment around x-axis (Inherited from PointResults.)
Public property | My | Moment around y-axis (Inherited from PointResults.)
Public property | Mz | Moment around z-axis (Inherited from PointResults.)
Public property | Rx | Rotation around x-axis (Inherited from PointResults.)
Public property | Ry | Rotation around y-axis (Inherited from PointResults.)
Public property | Rz | Rotation around z-axis (Inherited from PointResults.)
Public property | SFx | S (Fx), axial stress
Public property | Smax | S max, maximum normal stress
Public property | SmaxMy | S max (My), maximum bending stress for moment My
Public property | SmaxMz | S max (Mz), maximum bending stress for moment Mz
Public property | Smin | S min, minimum normal stress
Public property | SminMy | S min (My), minimum bending stress for moment My
Public property | SminMz | S min (Mz), minimum bending stress for moment Mz
Public property | Ux | Displacement along x-axis (Inherited from PointResults.)
Public property | Uy | Displacement along y-axis (Inherited from PointResults.)
Public property | Uz | Displacement along z-axis (Inherited from PointResults.)
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace