ServerStorage Members

Structural Analysis and Code Checking API Reference Guide
ServerStorage Members
ServerStorage Class Constructors Methods Properties See Also

The ServerStorage type exposes the following members.

Constructors

 | Name | Description
Public method | ServerStorage | Initializes a new instance of the ServerStorage class.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Overrides SchemaClass..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads the specified element. (Overrides SchemaClass..::..Load(Element).)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateState | Updates the state of the element.

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id.
Public property | Entity | Gets or sets the entity.
Public property | Modified | Gets or sets a value indicating whether this Label was modified.
Public property | SchemaId | Gets or sets the schema id.
Public property | ServerId | Gets or sets the server id.
Public property | State | Gets or sets the state - used for checking modifications.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace