ITableEditor Members

Structural Analysis and Code Checking API Reference Guide
ITableEditor Members
ITableEditor Interface Methods Properties Events See Also

The ITableEditor type exposes the following members.

Methods

 | Name | Description
Public method | GetCount | Gets the count.
Public method | GetUniqueId | Gets the unique id. (Inherited from IFieldEditor.)
Public method | GetValue(DisplayUnitType) | Gets the value in specified display unit type. (Inherited from IFieldEditor.)
Public method | GetValue(String, Int32, DisplayUnitType) | Gets the value in specified display unit type.
Public method | SetAttribute(FieldUIAttribute) | Sets the attribute. (Inherited from IFieldEditor.)
Public method | SetAttribute(String, Object, DisplayUnitType) | Sets spefified attribute. (Inherited from IFieldEditor.)
Public method | SetAttribute(String, Int32, String, Object, DisplayUnitType) | Sets the attributes of the field.
Public method | SetDocument | Sets the Revit document. (Inherited from IFieldEditor.)
Public method | SetName | Sets the name of control. (Inherited from IFieldEditor.)
Public method | SetUnitType | Sets the type of the unit. (Inherited from IFieldEditor.)
Public method | SetValue(Object, DisplayUnitType) | Sets the value in specified display unit type. (Inherited from IFieldEditor.)
Public method | SetValue(Object, String, Int32, DisplayUnitType) | Sets the value in specified display unit type.

Properties

 | Name | Description
Public property | BorderVisible | Gets or sets a value indicating whether border is visible. (Inherited from IFieldEditor.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from IFieldEditor.)
Public property | IsEnabled | Gets or sets a value indicating whether this instance is enabled. (Inherited from IFieldEditor.)

Events

 | Name | Description
Public event | ValueChanged | Occurs when value changed in the control. (Inherited from IFieldEditor.)

See Also

ITableEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace