ControlAttribute Members

Structural Analysis and Code Checking API Reference Guide
ControlAttribute Members
ControlAttribute Class Constructors Methods Properties See Also

The ControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ControlAttribute | Initializes a new instance of the ControlAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category).
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace