LabelsManager Members

Structural Analysis and Code Checking API Reference Guide
LabelsManager Members
LabelsManager Class Constructors Methods Properties See Also

The LabelsManager type exposes the following members.

Constructors

 | Name | Description
Public method | LabelsManager | Initializes a new instance of the LabelsManager class.

Methods

 | Name | Description
Public method | CreateNewLabel | Creates the new label.
Public method | DeleteLabel | Deletes the label.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategories |
Public method | GetCategoryOfSelection |
Public method | GetDefaultEntity |
Public method | GetDefaultLabel |
Public method | GetElementsOfLabel | Gets elements from input list with specific label assigned.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabel(Element) | Returns label set to particular element.
Public method | GetLabel(Guid) | Returns label set to particular element.
Public method | GetLabel(String) | Returns label set to particular element.
Public method | GetLabels |
Public method | GetMaterial |
Public method | GetMaterials |
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueLabelName | Gets the unique name for label.
Public method | IsActive |
Public method | OnSynchronized | (Overrides StorageManagerOnSynchronized(DocumentSynchronizedWithCentralEventArgs).)
Public method | RenameLabel | Renames the label.
Public method | SetLabel | Sets label to particular element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)
Public method | ValidateLabel | Validates the label and changes it to null if material doesn't fit.

Properties

 | Name | Description
Public property | Labels | Returns the list of labels.
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace