Geometry Members

Structural Analysis and Code Checking API Reference Guide
Geometry Members
Geometry Class Constructors Methods Properties See Also

The Geometry type exposes the following members.

Constructors

 | Name | Description
Public method | Geometry()()()() | The default Geometry class constructor
Public method | Geometry(Double) | The class constructor for a circular cross section.
Public method | Geometry(Double, Double) | The class constructor for a rectangular cross section.
Public method | Geometry(Double, Double, Double, Double) | The class constructor for a T cross section.

Methods

 | Name | Description
Public method | Add | Adds a new point into the concrete cross section contour collection of points.
Public method | Clear | Remove all points from the concrete cross section contour collection of points.
Public method | Dispose | Releases all resources used by the Geometry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | IEnumerable standard implementation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | isClockwiseOrientation | Check if the contour has a clockwise orientation.
Public method | Point | Gets a specific point from the concrete cross section contour collection of points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | Gets the value of contour area.
Public property | CenterOfInertia | Gets coordinates of the center of inertia of the concrete cross section.
Public property | Count | Gets the number of points describing the concrete cross section contour.
Public property | MomentOfInertiaX | Gets the value of the moment of inertia of the concrete cross section.
Public property | MomentOfInertiaY | Gets the value of the moment of inertia of the concrete cross section.
Public property | Perimeter | Gets the value of contour perimeter.

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace