NumericUpDownAttribute Properties

Structural Analysis and Code Checking API Reference Guide
NumericUpDownAttribute Properties
NumericUpDownAttribute Class See Also

The NumericUpDownAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumValue | Maximum value
Public property | MinimumValue | Describes minimum value that may be input into control.
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step.
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

NumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace