ProgressStart Members

Structural Analysis and Code Checking API Reference Guide
ProgressStart Members
ProgressStart Class Constructors Methods Properties See Also

The ProgressStart type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressStart | Initializes a new instance of the ProgressStart class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | Gets or sets the code.
Public property | Level | Gets the level of notification. (Inherited from ProgressNotification.)
Public property | Message | Gets or sets the message. (Inherited from Notification.)
Public property | NumberOfSteps | Number of predicted steps of the process.
Public property | Session | Gets or sets the session for which notification was made. (Inherited from Notification.)
Public property | Source | Gets or sets the source of notification. (Inherited from Notification.)
Public property | Title | Gets or sets the title.

See Also

ProgressStart Class
Autodesk.Revit.DB.CodeChecking Namespace