StorageManager Members

Structural Analysis and Code Checking API Reference Guide
StorageManager Members
StorageManager Class Constructors Methods Properties See Also

The StorageManager type exposes the following members.

Constructors

 | Name | Description
Public method | StorageManager | Initializes a new instance of the StorageManager class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchemaId |
Public method | GetSchemaIdForServer |
Public method | GetServerIdOfStorageSchema |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) |
Public method | ValidateCategory(BuiltInCategory, String, Guid) |

Properties

 | Name | Description
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded.
Public property | RevitDocument | The Revit document.
Public property | StorageDocument | The storage manager this instance belongs to.

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace