IGridValueAttribute Members

Structural Analysis and Code Checking API Reference Guide
IGridValueAttribute Members
IGridValueAttribute Interface Methods Properties See Also

The IGridValueAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetDefaultValueProvider | Gets the instance of default value provider. (Inherited from IGridAttribute.)

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit. (Inherited from IGridAttribute.)
Public property | DefaultValue | Gets or sets the default value (when element is added to grid). (Inherited from IGridAttribute.)
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface (Inherited from IGridAttribute.)
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps). (Inherited from IGridAttribute.)

See Also

IGridValueAttribute Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace