UnitNumericUpDownAttribute Members

Structural Analysis and Code Checking API Reference Guide
UnitNumericUpDownAttribute Members
UnitNumericUpDownAttribute Class Constructors Methods Properties See Also

The UnitNumericUpDownAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | UnitNumericUpDownAttribute()()()() | Initializes a new instance of the UnitNumericUpDownAttribute class.
Public method | UnitNumericUpDownAttribute(Double, Double, Double, DisplayUnitType) | Initializes a new instance of the UnitNumericUpDownAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetFieldFormat | Gets the field format. (Overrides FormatFieldAttribute..::..GetFieldFormat()()()().)
Public method | GetFieldValidator | Gets the field validator. (Inherited from TextBoxAttribute.)
Public method | GetFieldValueChanged | Gets the field value changed observer. (Inherited from FieldUIAttribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | SetProperties | Sets the properties based on other attribute. (Inherited from FieldUIAttribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified name. (Inherited from FieldUIAttribute.)

Properties

 | Name | Description
Public property | AttributeUnit | Unit in which values of the attribute are described
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldFormat | Gets or sets the field format. (Inherited from FormatFieldAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from TextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumValue | Maximum value (Inherited from NumericUpDownAttribute.)
Public property | MinimumValue | Describes minimum value that may be input into control. (Inherited from NumericUpDownAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Step | Gets or sets the step. (Inherited from NumericUpDownAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

UnitNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace