ForceCalculationDataDescriptorLinear Properties

Structural Analysis and Code Checking API Reference Guide
ForceCalculationDataDescriptorLinear Properties
ForceCalculationDataDescriptorLinear Class See Also

The ForceCalculationDataDescriptorLinear type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Gets or sets Revit ElementId for element to which calculation point is assigned (Inherited from ForceCalculationDataDescriptor.)
Public property | ForceTypes | Gets internal force types for which calculations are to be conducted (Inherited from ForceCalculationDataDescriptor.)
Public property | ForceTypesHashed | Gets hashed internal force types for the whole collection (Inherited from ForceCalculationDataDescriptor.)
Public property | Points | Gets calculation points coordinates
Public property | PointsHashed | Gets hash string representation of division points

See Also

ForceCalculationDataDescriptorLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace