DocumentBody Members

Structural Analysis and Code Checking API Reference Guide
DocumentBody Members
DocumentBody Class Constructors Methods Properties See Also

The DocumentBody type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentBody | Initializes the instance of the DocumentBody.

Methods

 | Name | Description
 | Build(Entity, Document) | Creates document body based on entity.
 | Build(SchemaClass, IResource, Document) | Generates the document body based on the instance of SchemaClass.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FillBody | Fills the body of the document based on the instance of Schema class.
Public method | GetElementCount | Gets the element count.
 | GetElementList | Gets the element list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Elements | List of document elements.

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace