ElementAnalyser Members

Structural Analysis and Code Checking API Reference Guide
ElementAnalyser Members
ElementAnalyser Class Constructors Methods Properties See Also

The ElementAnalyser type exposes the following members.

Constructors

 | Name | Description
Public method | ElementAnalyser()()()() | Initializes a new instance of ElementAnalyser class. Internal Revit units are using.
Public method | ElementAnalyser(DisplayUnit) | Initializes a new instance of ElementAnalyser class with proper unit system.

Methods

 | Name | Description
Public method | Analyse | Performs analysis of Revit element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TSectionAnalysis | Turn on/off t-section analysis (if element is a beam).
Public property | UseAnalyticalModelForSlabs | Turn on/off using analitical model for slabs.

See Also

ElementAnalyser Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace