MaterialCharacteristics Members

Structural Analysis and Code Checking API Reference Guide
MaterialCharacteristics Members
MaterialCharacteristics Class Constructors Methods Properties See Also

The MaterialCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialCharacteristics()()()() | Creates default instance.
Public method | MaterialCharacteristics(MaterialCharacteristics) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DampingRatio | Gets the damping coefficient.
Public property | PoissonRatio | Gets the Poisson's ratio.
Public property | ShearModulus | Gets the shear modulus G.
Public property | Specific | Gets or sets specific characteristics (corresponding to material category) of the material.
Public property | ThermalExpansionCoefficient | Gets the thermal expansion coefficient.
Public property | UnitWeight | Gets the unit weight.
Public property | YoungModulus | Gets the Young's modulus.

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace