ElementSectionsParamsInfo Methods

Structural Analysis and Code Checking API Reference Guide
ElementSectionsParamsInfo Methods
ElementSectionsParamsInfo Class See Also

The ElementSectionsParamsInfo type exposes the following members.

Methods

 | Name | Description
Public method | AtThePoint | Gets the dimensions of the section at the point along element length.
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides SectionProfile..::..Clone()()()().)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Overrides SectionProfile..::..CompareTo(Object).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace