Rebar Members

Structural Analysis and Code Checking API Reference Guide
Rebar Members
Rebar Class Constructors Methods Properties See Also

The Rebar type exposes the following members.

Constructors

 | Name | Description
Public method | Rebar | The Rebar class constructor. Creates the rebar with coordinates x,y and area.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | The Position property represents the the area of the rebar.
Public property | Position | The Position property represents the the position of the center of rebar.
Public property | X | The X property represents the x-coordinate of the point.
Public property | Y | The Y property represents the y-coordinate of the point.

See Also

Rebar Class
Autodesk.CodeChecking.Concrete Namespace