MaterialTimberCharacteristics Members

Structural Analysis and Code Checking API Reference Guide
MaterialTimberCharacteristics Members
MaterialTimberCharacteristics Class Constructors Methods Properties See Also

The MaterialTimberCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialTimberCharacteristics()()()() | Creates default instance.
Public method | MaterialTimberCharacteristics(MaterialTimberCharacteristics) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AverageModulusG | Gets the average modulus G.
Public property | BendingStrength | Gets the bending strength.
Public property | BurningVelocity | Gets burning velocity (mm/min).
Public property | ParallelCompressionStrength | Gets the parallel compression strength.
Public property | ParallelShearStrength | Gets the parallel shear strength.
Public property | PerpendicularCompressionStrength | Gets the perpendicular compression strength.
Public property | PerpendicularShearStrength | Gets the perpendicular shear strength.

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace