Steel Methods

Structural Analysis and Code Checking API Reference Guide
Steel Methods
Steel Class See Also

The Steel type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetModelIdealElastoPlastic | Sets all appropriate parameters for steel with horizontal top branch (Ideal elasto-plactic behaviour).
Public method | SetModelWithHardening | Sets all appropriate parameters for steel with inclined top branch (plastic with hardening).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace