DocumentDiagramSeries Members

Structural Analysis and Code Checking API Reference Guide
DocumentDiagramSeries Members
DocumentDiagramSeries Class Constructors Methods Properties See Also

The DocumentDiagramSeries type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentDiagramSeries | Initializes a new instance of the DocumentDiagramSeries class.

Methods

 | Name | Description
Public method | AddXY | Adds the point.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX | Gets the X value.
Public method | GetY | Gets the Y value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | Gets or sets the color.
Public property | Count | Gets the number of points.
Public property | DiagramType | Gets or sets the type of the diagram.
Public property | Name | Gets or sets the name.
Public property | Width | Gets or sets the border width.

See Also

DocumentDiagramSeries Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace