PointResults Members

Structural Analysis and Code Checking API Reference Guide
PointResults Members
PointResults Class Constructors Methods Properties See Also

The PointResults type exposes the following members.

Constructors

 | Name | Description
Public method | PointResults | Initializes a new instance of the PointResults class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fx | Force along x-axis
Public property | Fy | Force along y-axis
Public property | Fz | Force along z-axis
Public property | Mx | Moment around x-axis
Public property | My | Moment around y-axis
Public property | Mz | Moment around z-axis
Public property | Rx | Rotation around x-axis
Public property | Ry | Rotation around y-axis
Public property | Rz | Rotation around z-axis
Public property | Ux | Displacement along x-axis
Public property | Uy | Displacement along y-axis
Public property | Uz | Displacement along z-axis

See Also

PointResults Class
Autodesk.Revit.DB.ResultsBuilder Namespace