SlabInfo Members

Structural Analysis and Code Checking API Reference Guide
SlabInfo Members
SlabInfo Class Constructors Methods Properties See Also

The SlabInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SlabInfo | Creates default instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdge(List<(Of <<'(XYZ>)>>)) | Returns edge of specific cooridinates.
Public method | GetEdge(XYZ, XYZ) | Returns edge of specific coordinates.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMainContour | returns main contour of the slab.
Public method | GetNode | Returns node of specific coordinates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPointInDomain | Checks if point is in domain of slab (it has to be inside main contour and it can't be inside any hole)
Public method | StructuralLayer | Gets the structural layer.
Public method | Thickness | Gets the thickness of slab.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContextId | Revit Id of element.
Public property | Contours | Gets list of SlabContour objects.
Public property | Edges | Gets list of SlabEdge objects.
Public property | FamilyName | Gets family name.
Public property | IsOneWay | One way structural usage flag
Public property | Layers | Gets list of Layer objects (from Top to Bottom).
Public property | LevelName | Gets level name.
Public property | MaximumBoundary | Gets maximum coordinates (upper-right-front corner) of the boundary box.
Public property | MinimumBoundary | Gets minimum coordinates (lower-left-rear corner) of the boundary box.
Public property | Nodes | Gets list of SlabNode objects.
Public property | SpanDirectionAngle | Gets angle of span direction.
Public property | Transform | Gets class allows to transform points from local to global (and vice versa) coordinate system.
Public property | TypeName | Gets name of type.

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace