SurfacePointResults Members

Structural Analysis and Code Checking API Reference Guide
SurfacePointResults Members
SurfacePointResults Class Constructors Methods Properties See Also

The SurfacePointResults type exposes the following members.

Constructors

 | Name | Description
Public method | SurfacePointResults | Initializes a new set of results for surface's calculation point.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fxx | Force Fxx
Public property | Fxy | Force Fxy
Public property | Fyy | Force Fyy
Public property | Mxx | Moment Mxx
Public property | Mxy | Moment Mxy
Public property | Myy | Moment Myy
Public property | Qxx | Qxx shear force
Public property | Qyy | Qyy shear force
Public property | RX | Rotation RX in global coordinates
Public property | RY | Rotation RY in global coordinates
Public property | RZ | Rotation RZ in global coordinates
Public property | Sxx | Sxx stress
Public property | Sxy | Sxy stress
Public property | Syy | Syy stress
Public property | Txx | Txx shear stress
Public property | Tyy | Tyy shear stress
Public property | UX | Displacement UX in global coordinates
Public property | UY | Displacement UY in global coordinates
Public property | UZ | Displacement UZ in global coordinates
Public property | X | X value in global coordinates, measured in meters
Public property | Y | Y value in global coordinates, measured in meters
Public property | Z | Z value in global coordinates, measured in meters

See Also

SurfacePointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace