Section Members

Structural Analysis and Code Checking API Reference Guide
Section Members
Section Class Constructors Methods Properties See Also

The Section type exposes the following members.

Constructors

 | Name | Description
Public method | Section()()()() | Creates default instance.
Public method | Section(List<(Of <<'(XYZ>)>>)) | Creates instance without holes using points list.
Public method | Section(Section) | Creates instance from pattern. Copy constructor.
Public method | Section(Shape) | Creates instance without holes using shape.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Contour | Gets the shape representing the contour of the section.
Public property | Holes | Gets the list of shapes that representing the holes of the section.

See Also

Section Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace