ResultsManager Members

Structural Analysis and Code Checking API Reference Guide
ResultsManager Members
ResultsManager Class Constructors Methods Properties See Also

The ResultsManager type exposes the following members.

Constructors

 | Name | Description
Public method | ResultsManager | Initializes a new instance of the ResultsManager class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResult(Element) | Gets results of specific element and package.
Public method | GetResult(Element, Guid) | Gets results of specific element and package.
Public method | GetResultStatus(Element, Guid) | Gets the result status for specific element.
Public method | GetResultStatus(Element, Guid, Guid) | Gets the result status for specific element.
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetServerResult(Element, Guid) | Gets the server result.
Public method | GetServerResult(Element, Guid, Guid) | Gets the server result.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OutDateResults | Outdate results for specific server in particular element.
Public method | SetResult(Entity, Element, ResultStatus, Boolean) | Sets result to specific element.
Public method | SetResult(Entity, Element, Guid, ResultStatus, Boolean) | Sets result to specific element.
Public method | SetResultStatus |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

Properties

 | Name | Description
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

ResultsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace