FieldControl Methods

Structural Analysis and Code Checking API Reference Guide
FieldControl Methods
FieldControl Class See Also

The FieldControl type exposes the following members.

Methods

 | Name | Description
 | Build(PropertyInfo, IResource, Guid) | Generates the Field Control based on property attributes.
 | Build(Type, String, IResource) | Generates the FieldControl based on property attributes.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDisplayName | Gets the display name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUIAttribute | Gets the UI attribute.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace