CoordinateSystem Members

Structural Analysis and Code Checking API Reference Guide
CoordinateSystem Members
CoordinateSystem Class Constructors Methods Properties See Also

The CoordinateSystem type exposes the following members.

Constructors

 | Name | Description
Public method | CoordinateSystem()()()() | Constructs a transform to the identity matrix.
Public method | CoordinateSystem(CoordinateSystem) | Copy constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ManyPoints2Global | Retrieves the list of points transformed from local to global coordinates system.
Public method | ManyPoints2Local | Retrieves the list of points transformed from global to local coordinates system.
Public method | Point2Global | Retrieves the point transformed from local to global coordinates system.
Public method | Point2Local | Retrieves the point transformed from global to local coordinates system.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Vector2Global | Retrieves the vector transformed from local to global coordinates system.
Public method | Vector2Local | Retrieves the vector transformed from global to local coordinates system.

Properties

 | Name | Description
Public property | BasisX | The X basis vector.
Public property | BasisY | The Y basis vector.
Public property | BasisZ | The Z basis vector.
Public property | Origin | The origin of the coordinate system.

See Also

CoordinateSystem Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace