CalculationParamsManager Members

Structural Analysis and Code Checking API Reference Guide
CalculationParamsManager Members
CalculationParamsManager Class Constructors Methods Properties See Also

The CalculationParamsManager type exposes the following members.

Constructors

 | Name | Description
Public method | CalculationParamsManager | Initializes a new instance of the CalculationParamsManager class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServersForSelection |
Public method | GetActiveServersIds |
Public method | GetCodesWithNotSetCombinations |
Public method | GetCodesWithNotSetInputPackages |
Public method | GetDefault |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetServersIds |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnSynchronized | (Overrides StorageManagerOnSynchronized(DocumentSynchronizedWithCentralEventArgs).)
Public method | OnSynchronizing | (Overrides StorageManagerOnSynchronizing(DocumentSynchronizingWithCentralEventArgs).)
Public method | SetActiveServers |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)

Properties

 | Name | Description
Public property | CalculationParams | Returns current calculation parameters.
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace