FieldUIAttribute Properties

Structural Analysis and Code Checking API Reference Guide
FieldUIAttribute Properties
FieldUIAttribute Class See Also

The FieldUIAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag.
Public property | Context | Additional information used for instance by IResource interface to help user identify the field.
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled.
Public property | IsVisible | Indicates if the field is visible.
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | SetDescription |
Public property | Tooltip | Gets or sets the tooltip.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace