BarNodeResultEnvelope Members

Structural Analysis and Code Checking API Reference Guide
BarNodeResultEnvelope Members
BarNodeResultEnvelope Class Methods Properties See Also

The BarNodeResultEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | MaxValue | Maximal value for node.
Public property | MinValue | Mininmal value for node.
Public property | ResultType | Type of result.
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarNodeResultEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace