SectionsInfo Members

Structural Analysis and Code Checking API Reference Guide
SectionsInfo Members
SectionsInfo Class Constructors Methods Properties See Also

The SectionsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SectionsInfo()()()() | Creates default instance.
Public method | SectionsInfo(Section) | Creates instance using Section class.
Public method | SectionsInfo(List<(Of <<'(Section>)>>)) | Creates instance using list of sections.
Public method | SectionsInfo(SectionsInfo) | Creates instance from pattern.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCenter | Gets center coordinates of sections.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Sections | Gets the list of sections.
Public property | Transform | Gets or sets class allows to transform points from local to global (and vice versa) coordinate system.

See Also

SectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace