SlabEdge Methods

Structural Analysis and Code Checking API Reference Guide
SlabEdge Methods
SlabEdge Class See Also

The SlabEdge type exposes the following members.

Methods

 | Name | Description
Public method | ArePointsLikeNodes | Checks if points from the list has the same coordinates as current edge.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCenter | Returns center of edge.
Public method | GetDistanceFromPoint | Returns distance to specific point.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from SlabBaseObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLineCrossingThis | Checks if line is crossing current edge.
Public method | IsPointOnEdge | Checks if specific point is on edge.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace