Service Methods

Structural Analysis and Code Checking API Reference Guide
Service Methods
Service Class See Also

The Service type exposes the following members.

Methods

 | Name | Description
 | AddServer | Register server in CCService
 | BlockServer | Blocks the server.
Public method | CanExecute | Returns permission for executing particular server
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ServiceData) | Executes given server.
 | Execute(Document, List<(Of <<'(Element>)>>), ExecutionContext) | Executes given server.
Public method | Execute(IExternalServer, Document, IExternalData) | Executes given server.
 | Execute(Document, List<(Of <<'(Element>)>>), Guid, ExecutionContext) | Executes given server.
 | ExecuteServer | Executes given server.
 | GetActiveServers | Returns list of active servers registered in CCService
 | GetActiveServersIds | Returns list of active servers registered in CCService
Public method | GetDescription | Returns the description
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the service.
 | GetServer | Returns server of specific id.
 | GetServers | Returns servers registered in Service
Public method | GetServiceId | Returns service ID
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendor | Return vendor.
Public method | GetVendorId | Reurns vendor Id of the service.
 | IsActive | Determines whether the specified server ID is active.
 | IsBlocked | Determines whether the specified server is blocked.
Public method | IsValidServer | Validates server.
Public method | OnServersChanged | Takes action when servers changes.
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.
 | RegisterService | Registers service in Revit
 | SetActiveServers | Sets active servers
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnBlockServer | Uns the block server.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace