ServiceData Members

Structural Analysis and Code Checking API Reference Guide
ServiceData Members
ServiceData Class Constructors Methods Properties See Also

The ServiceData type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceData | Initializes a new instance of the ServiceData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Document | The active document.
Public property | Session | Gets the current session.

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace