LabelStructureAttribute Members

Structural Analysis and Code Checking API Reference Guide
LabelStructureAttribute Members
LabelStructureAttribute Class Constructors Methods Properties See Also

The LabelStructureAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | LabelStructureAttribute(Type) | Initializes a new instance of the LabelStructureAttribute class.
Public method | LabelStructureAttribute(Type, BuiltInCategory) | Initializes a new instance of the LabelStructureAttribute class.
Public method | LabelStructureAttribute(Type, StructuralAssetClass) | Initializes a new instance of the LabelStructureAttribute class.
Public method | LabelStructureAttribute(Type, BuiltInCategory, StructuralAssetClass) | Initializes a new instance of the LabelStructureAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

LabelStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace