ICodeCheckingServerUI Members

Structural Analysis and Code Checking API Reference Guide
ICodeCheckingServerUI Members
ICodeCheckingServerUI Interface Methods See Also

The ICodeCheckingServerUI type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamsLayout | Builds the layout.
Public method | BuildLabelLayout | Builds the layout.
Public method | GetDataSource | Gets the data source of the specific key. (Inherited from IServerUI.)
Public method | GetHelp | Gets the help.
Public method | GetResource | Gets the text resource. (Inherited from IResource.)
Public method | GetResourceImage | Gets the image resource. (Inherited from IResource.)
Public method | LayoutInitialized | Informs the server that layout was initialized (Inherited from IServerUI.)
Public method | ValueChanged | Informs the server that value changed. (Inherited from IServerUI.)

See Also

ICodeCheckingServerUI Interface
Autodesk.Revit.UI.CodeChecking Namespace