ResultStatusMessage Members

Structural Analysis and Code Checking API Reference Guide
ResultStatusMessage Members
ResultStatusMessage Class Constructors Methods Properties See Also

The ResultStatusMessage type exposes the following members.

Constructors

 | Name | Description
Public method | ResultStatusMessage()()()() | Initializes a new instance of the ResultStatusMessage class.
Public method | ResultStatusMessage(String) | Initializes a new instance of the ResultStatusMessage class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetFormated | Gets the formated.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Message | Gets or sets the message.

See Also

ResultStatusMessage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace