DocumentSection Members

Structural Analysis and Code Checking API Reference Guide
DocumentSection Members
DocumentSection Class Constructors Methods Properties See Also

The DocumentSection type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentSection()()()() | Initializes a new instance of the DocumentSection class.
Public method | DocumentSection(String, Int16) | Initializes a new instance of the DocumentSection class.
Public method | DocumentSection(DocumentSection, Document, String, Int32, Boolean) | Initializes a new instance of the DocumentSection class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevel | Gets the level of the section.
Public method | GetSectionOfName(String) | Gets the section of specific name.
 | GetSectionOfName(String, DocumentBody) | Gets the section of specific name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetAdditionalData | Sets the additional data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | Anchor | Gets or sets the anchor.
Public property | Body | Gets or sets the body.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Name | Gets or sets the name.
Public property | ParentDocument | Gets or sets the parent document.
Public property | ParentSection | Gets or sets the parent section.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace