WallInfo Members

Structural Analysis and Code Checking API Reference Guide
WallInfo Members
WallInfo Class Constructors Methods Properties See Also

The WallInfo type exposes the following members.

Constructors

 | Name | Description
Public method | WallInfo | Creates default instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StructuralLayer | Gets the structural layer.
Public method | Thickness | Gets the thickness of wall.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContextId | Revit Id of element.
Public property | Contour | Gets the shape representing the contour of the wall.
Public property | FamilyName | Gets family name.
Public property | Layers | Gets list of Layer objects ().
Public property | Openings | Gets the list of shapes that representing the openings.
Public property | Transform | Gets class allows to transform points from local to global (and vice versa) coordinate system.
Public property | TypeName | Gets name of type.

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace