DocumentBuilder Methods

Structural Analysis and Code Checking API Reference Guide
DocumentBuilder Methods
DocumentBuilder Class See Also

The DocumentBuilder type exposes the following members.

Methods

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file.
Public method | BuildDocument(Document, Document, String, DetailLevel) | Virtual methods building document. This method is overriden by document builders.
Public method | BuildDocuments | Builds the document list splitted due to PageBreaks.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtension | Gets the extension of the file (without dot).
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTempPath | Gets the temp path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserTempPath | Gets the temp path for user.
 | RemoveTempPath | Removes the temp path.
 | RemoveUserTempPath | Removes the temp path.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace