SetOfForces Members

Structural Analysis and Code Checking API Reference Guide
SetOfForces Members
SetOfForces Class Constructors Methods Fields See Also

The SetOfForces type exposes the following members.

Constructors

 | Name | Description
Public method | SetOfForces()()()() | The default SetOfForces class constructor.
Public method | SetOfForces(Double, Double, Double) | The SetOfForces class constructor with AxialForce, MomentX and MomentY values set as parameter.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | AxialForce | The AxialForce field represents the axial force (N). The compresion have positive sign.
Public field | MomentX | The MomentX field represents the bending moment around x'-axis.
Public field | MomentY | The MomentY field represents the bending moment around y'-axis.

See Also

SetOfForces Class
Autodesk.CodeChecking.Concrete Namespace