SectionProfile Members

Structural Analysis and Code Checking API Reference Guide
SectionProfile Members
SectionProfile Class Constructors Methods Properties See Also

The SectionProfile type exposes the following members.

Constructors

 | Name | Description
Public method | SectionProfile()()()() | Creates default instance (not tapered).
Public method | SectionProfile(SectionProfile) | Creates instance from pattern.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ComponentsShapeType | Gets the list of components types of the shapes for double or compound section.
Public property | ShapeType | Gets the type of the shape of section.
Public property | Tapered | Gets a value indicating whether the profile is tapered.

See Also

SectionProfile Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace