SchemaAttribute Members

Structural Analysis and Code Checking API Reference Guide
SchemaAttribute Members
SchemaAttribute Class Constructors Methods Properties See Also

The SchemaAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SchemaAttribute | Initializes a new instance of the SchemaAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of schema id based on index in the history.
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | History | The history of schema ids.
Public property | Name | The name of the schema.
Public property | SchemaID | The id of the schema.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SchemaAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace