RCArgumentException Members

Structural Analysis and Code Checking API Reference Guide
RCArgumentException Members
RCArgumentException Class Constructors Methods Properties See Also

The RCArgumentException type exposes the following members.

Constructors

 | Name | Description
Public method | RCArgumentException(Object) | Initializes a new instance of the RCArgumentException class
Public method | RCArgumentException(Object, String) | Initializes a new instance of the RCArgumentException class
Public method | RCArgumentException(Object, String, String) | Initializes a new instance of the RCArgumentException class
Public method | RCArgumentException(Object, String, String, Exception) | Initializes a new instance of the RCArgumentException class

Methods

 | Name | Description
Public method | AddRecord(Enum, Enum) |
Public method | AddRecord(Enum, Double) |
Public method | AddRecord(Enum, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from ArgumentException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | MethodName |
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | RCDataRecords |
Public property | RCSolver |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RCArgumentException Class
Autodesk.CodeChecking.Concrete Namespace