ITableEditor Methods

Structural Analysis and Code Checking API Reference Guide
ITableEditor Methods
ITableEditor Interface See Also

The ITableEditor type exposes the following members.

Methods

 | Name | Description
Public method | GetCount | Gets the count.
Public method | GetUniqueId | Gets the unique id. (Inherited from IFieldEditor.)
Public method | GetValue(DisplayUnitType) | Gets the value in specified display unit type. (Inherited from IFieldEditor.)
Public method | GetValue(String, Int32, DisplayUnitType) | Gets the value in specified display unit type.
Public method | SetAttribute(FieldUIAttribute) | Sets the attribute. (Inherited from IFieldEditor.)
Public method | SetAttribute(String, Object, DisplayUnitType) | Sets spefified attribute. (Inherited from IFieldEditor.)
Public method | SetAttribute(String, Int32, String, Object, DisplayUnitType) | Sets the attributes of the field.
Public method | SetDocument | Sets the Revit document. (Inherited from IFieldEditor.)
Public method | SetName | Sets the name of control. (Inherited from IFieldEditor.)
Public method | SetUnitType | Sets the type of the unit. (Inherited from IFieldEditor.)
Public method | SetValue(Object, DisplayUnitType) | Sets the value in specified display unit type. (Inherited from IFieldEditor.)
Public method | SetValue(Object, String, Int32, DisplayUnitType) | Sets the value in specified display unit type.

See Also

ITableEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace