Shape Methods

Structural Analysis and Code Checking API Reference Guide
Shape Methods
Shape Class See Also

The Shape type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetTurnedPointsList | Gets list of points for this shape turned by an angle.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsContourInside | Check if a contour is inside this shape.
Public method | IsPointInside | Check if a point is inside this shape.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace