SlabInfo Methods

Structural Analysis and Code Checking API Reference Guide
SlabInfo Methods
SlabInfo Class See Also

The SlabInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdge(List<(Of <<'(XYZ>)>>)) | Returns edge of specific cooridinates.
Public method | GetEdge(XYZ, XYZ) | Returns edge of specific coordinates.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMainContour | returns main contour of the slab.
Public method | GetNode | Returns node of specific coordinates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPointInDomain | Checks if point is in domain of slab (it has to be inside main contour and it can't be inside any hole)
Public method | StructuralLayer | Gets the structural layer.
Public method | Thickness | Gets the thickness of slab.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace