Geometry Methods

Structural Analysis and Code Checking API Reference Guide
Geometry Methods
Geometry Class See Also

The Geometry type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a new point into the concrete cross section contour collection of points.
Public method | Clear | Remove all points from the concrete cross section contour collection of points.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | IEnumerable standard implementation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | isClockwiseOrientation | Check if the contour has a clockwise orientation.
Public method | Point | Gets a specific point from the concrete cross section contour collection of points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace