SchemaPropertyAttribute Members

Structural Analysis and Code Checking API Reference Guide
SchemaPropertyAttribute Members
SchemaPropertyAttribute Class Constructors Methods Properties See Also

The SchemaPropertyAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SchemaPropertyAttribute()()()() | Initializes the instance of the SchemaPropertyAttribute.
Public method | SchemaPropertyAttribute(UnitType, DisplayUnitType) | Initializes the instance of the SchemaPropertyAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetConverter | Returns the instance of the converter.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConverterType | The converter which implements IFieldToPropertyConverter interface, necessarry when FieldType is different from property type.
Public property | DisplayUnit | The unit in which the field is defined. (Inherited from UnitAttribute.)
Public property | FieldName | The name of the field in the schema. If null the name of the property will be taken directly.
Public property | FieldType | The type of the field in the schema. If null the type of the property will be taken directly. Usefull when property type is not supported by Extensible Storage.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Unit | The unit category of the field. (Inherited from UnitAttribute.)

See Also

SchemaPropertyAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace