CategoriesAttribute Members

Structural Analysis and Code Checking API Reference Guide
CategoriesAttribute Members
CategoriesAttribute Class Constructors Methods Properties See Also

The CategoriesAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CategoriesAttribute(array<String>[]()[][]) | Initializes a new instance of the CategoriesAttribute class.
Public method | CategoriesAttribute(array<String>[]()[][], array<Int32>[]()[][]) | Initializes a new instance of the CategoriesAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoriesIndexes | Gets or sets the categories indexes.
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CategoriesAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace