LoadCombinationPreview Methods

Structural Analysis and Code Checking API Reference Guide
LoadCombinationPreview Methods
LoadCombinationPreview Class See Also

The LoadCombinationPreview type exposes the following members.

Methods

 | Name | Description
Public method | AddComponent | Adds the component. It should be LoadCase, LoadCombination or LoadCombinationPreview
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Generate | Generates Revit LoadCombination in specified document.
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsageName | Gets the name of the usage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace