RebarUtility Members

Structural Analysis and Code Checking API Reference Guide
RebarUtility Members
RebarUtility Class Constructors Methods See Also

The RebarUtility type exposes the following members.

Constructors

 | Name | Description
Public method | RebarUtility | Initializes a new instance of the RebarUtility class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetListMaterialOfRebars | Return the list of material ElementId assigned to rebar present in a Revit document
 | GetListRebarForMaterial | Return the list of rebar with a specific material assigned
 | GetMaterialStructuralAsset(Material) | Return the StructuralAsset of a specific material
 | GetMaterialStructuralAsset(Document, ElementId) | Return the StructuralAsset of a specific material based on his ElementId
 | GetRebarType | Return the RebarType of a specific rebar based on his ElementId
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsMaterialMetal | Return true if the material Class of the specified material is metal
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace