ReportSettings Members

Structural Analysis and Code Checking API Reference Guide
ReportSettings Members
ReportSettings Class Methods Properties See Also

The ReportSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportSettings | Gets the report settings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads this instance.
Public method | Save | Saves this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets or sets the action.
Public property | CollapsedDocumentSections | Gets or sets the document sections.
Public property | GroupMethods | Gets or sets the group methods.
Public property | Level | Gets or sets the level.
Public property | SaveSettings | Gets or sets a value indicating whether settings should be saved.
Public property | Sort | Gets or sets the sort.
Public property | StatusFilter | Gets or sets the result status filter.
Public property | VisibleDocumentSections | Gets or sets the document sections.

See Also

ReportSettings Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace