DocumentDiagram Members

Structural Analysis and Code Checking API Reference Guide
DocumentDiagram Members
DocumentDiagram Class Constructors Methods Properties See Also

The DocumentDiagram type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentDiagram | Initializes a new instance of the DocumentDiagram class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetLabelsX | Sets the labels X.
Public method | SetLabelsY | Sets the labels Y.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | AxisX | Gets the X axis.
Public property | AxisY | Gets the Y axis.
Public property | Height | Gets or sets the height.
Public property | Legend | Gets or sets a value indicating whether legend is visible.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | Series | Gets the list of series.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)
Public property | Width | Gets or sets the width.

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace