SlabBaseObject Members

Structural Analysis and Code Checking API Reference Guide
SlabBaseObject Members
SlabBaseObject Class Constructors Methods Properties See Also

The SlabBaseObject type exposes the following members.

Constructors

 | Name | Description
Public method | SlabBaseObject()()()() | Construct object.
Public method | SlabBaseObject(SlabInfo) | Construct object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element.
Public property | ContextId | Revit Id of element.
Public property | ElementType | Type of element.
Public property | ParentSlab | Parent slab.

See Also

SlabBaseObject Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace