DocumentTable Members

Structural Analysis and Code Checking API Reference Guide
DocumentTable Members
DocumentTable Class Constructors Methods Properties See Also

The DocumentTable type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentTable | Initializes the instance of the DocumentTable class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalData | Gets or sets the additional data. (Inherited from DocumentElement.)
Public property | ColumnsCount | Number of columns.
Public property | HeaderColumnsCount | Number of header columns.
Public property | HeaderRowsCount | Number of header rows.
Public property | Item | Returns the specific cell of the table.
Public property | Level | Gets or sets the detail level of element. (Inherited from DocumentElement.)
Public property | PercentageColumnWidth | Gets the width of columns in procentage units.
Public property | RowsCount | Number of rows.
Public property | Source | Gets or sets the source (e.g. name of property). (Inherited from DocumentElement.)
Public property | Title | Gets or sets the title.
Public property | Visible | Gets or sets a value indicating whether this DocumentElement is visible. (Inherited from DocumentElement.)

See Also

DocumentTable Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace