ListUnitTextBoxAttribute Properties

Structural Analysis and Code Checking API Reference Guide
ListUnitTextBoxAttribute Properties
ListUnitTextBoxAttribute Class See Also

The ListUnitTextBoxAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeUnit | Unit in which values of the attribute are described (Inherited from UnitTextBoxAttribute.)
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | Context | Additional information used for instance by IResource interface to help user identify the field. (Inherited from FieldUIAttribute.)
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag. (Inherited from FieldUIAttribute.)
Public property | FieldValidator | Gets or sets the field validator. (Inherited from UnitTextBoxAttribute.)
Public property | Index | Decides about position of the property in UI container it belongs to (e.g. Category). (Inherited from ControlAttribute.)
Public property | IsEnabled | Indicates if the field is enabled. (Inherited from FieldUIAttribute.)
Public property | IsVisible | Indicates if the field is visible. (Inherited from FieldUIAttribute.)
Public property | Localizable | Indicates that the property is localizable. If true GetResource method from appropriate server will be invoked. (Inherited from ControlAttribute.)
Public property | MaximumItemCount | Maximum number of items in the list.
Public property | MaximumValue | Maximum value (Inherited from UnitTextBoxAttribute.)
Public property | MinimumItemCount | Minimum number of items in the list
Public property | MinimumValue | Minimum value (Inherited from UnitTextBoxAttribute.)
Public property | SetDescription | (Inherited from FieldUIAttribute.)
Public property | Tooltip | Gets or sets the tooltip. (Inherited from FieldUIAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | ValidateMaximumItemCount | Indicates whether maximum number of items should be validated
Public property | ValidateMaximumValue | Indicates if maximum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValidateMinimumItemCount | Indicates if minimum number of items should be checked
Public property | ValidateMinimumValue | Indicates if minimum value should be checked (Inherited from UnitTextBoxAttribute.)
Public property | ValueChangedObserver | Gets or sets the value changed observer. (Inherited from FieldUIAttribute.)

See Also

ListUnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace