SchemaPropertyAttribute Properties

Structural Analysis and Code Checking API Reference Guide
SchemaPropertyAttribute Properties
SchemaPropertyAttribute Class See Also

The SchemaPropertyAttribute type exposes the following members.

Properties

 | Name | Description
Public property | ConverterType | The converter which implements IFieldToPropertyConverter interface, necessarry when FieldType is different from property type.
Public property | DisplayUnit | The unit in which the field is defined. (Inherited from UnitAttribute.)
Public property | FieldName | The name of the field in the schema. If null the name of the property will be taken directly.
Public property | FieldType | The type of the field in the schema. If null the type of the property will be taken directly. Usefull when property type is not supported by Extensible Storage.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Unit | The unit category of the field. (Inherited from UnitAttribute.)

See Also

SchemaPropertyAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace