BarPointResults Members

Structural Analysis and Code Checking API Reference Guide
BarPointResults Members
BarPointResults Class Constructors Methods Properties See Also

The BarPointResults type exposes the following members.

Constructors

 | Name | Description
Public method | BarPointResults | Initializes a new set of results for bar's calculation point.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fx | Force along x-axis (Inherited from PointResults.)
Public property | Fy | Force along y-axis (Inherited from PointResults.)
Public property | Fz | Force along z-axis (Inherited from PointResults.)
Public property | Mx | Moment around x-axis (Inherited from PointResults.)
Public property | My | Moment around y-axis (Inherited from PointResults.)
Public property | Mz | Moment around z-axis (Inherited from PointResults.)
Public property | Rx | Rotation around x-axis (Inherited from PointResults.)
Public property | Ry | Rotation around y-axis (Inherited from PointResults.)
Public property | Rz | Rotation around z-axis (Inherited from PointResults.)
Public property | SFx | S (Fx), axial stress
Public property | Smax | S max, maximum normal stress
Public property | SmaxMy | S max (My), maximum bending stress for moment My
Public property | SmaxMz | S max (Mz), maximum bending stress for moment Mz
Public property | Smin | S min, minimum normal stress
Public property | SminMy | S min (My), minimum bending stress for moment My
Public property | SminMz | S min (Mz), minimum bending stress for moment Mz
Public property | Ux | Displacement along x-axis (Inherited from PointResults.)
Public property | Uy | Displacement along y-axis (Inherited from PointResults.)
Public property | Uz | Displacement along z-axis (Inherited from PointResults.)
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace