DocumentElementAttribute Members

Structural Analysis and Code Checking API Reference Guide
DocumentElementAttribute Members
DocumentElementAttribute Class Constructors Methods Properties See Also

The DocumentElementAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentElementAttribute | Initializes a new instance of the DocumentElementAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Decides about position of the property in document.
Public property | Level | Gets or sets the detail level of the element.
Public property | Localizable | Gets or sets a value indicating whether this DocumentElementAttribute is localizable.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DocumentElementAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace