LineGraphByCoordinatesParameters Members

Structural Analysis and Code Checking API Reference Guide
LineGraphByCoordinatesParameters Members
LineGraphByCoordinatesParameters Class Constructors Methods Properties See Also

The LineGraphByCoordinatesParameters type exposes the following members.

Constructors

 | Name | Description
Public method | LineGraphByCoordinatesParameters(IEnumerable<(Of <<'(Double>)>>)) | Creates the LineGraphByCoordinatesParameters with given set of relative coordinates.
Public method | LineGraphByCoordinatesParameters(IEnumerable<(Of <<'(Double>)>>), UnitsSystem) | Creates the LineGraphByCoordinatesParameters with given set of relative coordinates and unit system.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RelativeCoordinates | Returns list of defined relative coordinates.
Public property | UnitsSystem | Defines the set of units used when querying for results. (Inherited from LineGraphParameters.)

See Also

LineGraphByCoordinatesParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace