DocumentMap Methods

Structural Analysis and Code Checking API Reference Guide
DocumentMap Methods
DocumentMap Class See Also

The DocumentMap type exposes the following members.

Methods

 | Name | Description
Public method | AddHole | Adds the hole.
Public method | AddPoint | Adds the point.
Public method | DefineContour | Defines the main polygon.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundBox | Gets the bound box.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHoles | Gets the polygon.
Public method | GetNodes | Gets the nodes.
Public method | GetPolygon | Gets the polygon.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines whether the specified level is visible. (Inherited from DocumentElement.)
Public method | SetColors | Sets the legend colors.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentMap Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace