LineGraphEnvelope Members

Structural Analysis and Code Checking API Reference Guide
LineGraphEnvelope Members
LineGraphEnvelope Class Methods Properties See Also

The LineGraphEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBottomMinValue | Calculates the minimal value of top envelope.
Public method | GetBottomValue | Calculates the value of bottom envelope in specified point.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTopMaxValue | Calculates the maximal value of top envelope.
Public method | GetTopValue | Calculates the value of top envelope in specified point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BottomPoints | Returns the list of points thad defines the bottom envelope. U is interpreted as domain and V as values.
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | ResultType | Returns the type of result of the linear graph.
Public property | TopPoints | Returns the list of points thad defines the top envelope. U is interpreted as domain and V as values.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace