MaterialProperties Members

Structural Analysis and Code Checking API Reference Guide
MaterialProperties Members
MaterialProperties Class Constructors Methods Properties See Also

The MaterialProperties type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialProperties()()()() | Creates default instance.
Public method | MaterialProperties(MaterialProperties) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets the detailed material description.
Public property | Name | Gets the material's name.
Public property | ResistanceCode | Gets /1. a digit stands for (characteristic or design) resistance, 2. a cubic or cylindric sample).
Public property | SecondName | Gets the second material's name.
Public property | Therm | Gets the material type /for metal: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace