SurfaceGraphEnvelope Members

Structural Analysis and Code Checking API Reference Guide
SurfaceGraphEnvelope Members
SurfaceGraphEnvelope Class Methods Properties See Also

The SurfaceGraphEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DirectionX | Returns Vector defining the X-axis of the coordinate system in which the results are presented.
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ElementId | Returns element's id for which the surface graph is defined. (Inherited from BaseGraph.)
Public property | LoadId | Returns loads's id for which the line graph is defined. (Inherited from BaseGraph.)
Public property | MaxValues | List of maximal Values over the coordinates.
Public property | MinValues | List of minimal Values over the coordinates.
Public property | Points | List of coordinates in local plane.
Public property | ResultType | Returns the type of the graph.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.

See Also

SurfaceGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace