MultiStructureServer Members

Structural Analysis and Code Checking API Reference Guide
MultiStructureServer Members
MultiStructureServer Class Methods See Also

The MultiStructureServer type exposes the following members.

Methods

 | Name | Description
Public method | BuildCalculationParamDocumentBody | Gets the document body for calculation parameters.
Public method | BuildLabelDocumentBody | Gets the document body for label.
Public method | BuildResultDocumentBody | Gets the document body for result.
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one. (Inherited from MultiStructureServer.)
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one. (Inherited from MultiStructureServer.)
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one. (Inherited from MultiStructureServer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationParamSchema | Returns schema for calculation parameters. (Inherited from MultiStructureServer.)
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity. (Inherited from MultiStructureServer.)
Public method | GetDefaultLabel | Returns default value of label entity. (Inherited from MultiStructureServer.)
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from MultiStructureServer.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelSchema | Returns schema for labels. (Inherited from MultiStructureServer.)
Public method | GetName | Implement this method to return the name of the server. (Inherited from MultiStructureServer.)
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package. (Inherited from MultiStructureServer.)
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package. (Inherited from MultiStructureServer.)
Public method | GetResource | Gets the resource.
Public method | GetResourceImage | Gets the resource image.
Public method | GetResultsSchema | Returns schema for results. (Inherited from MultiStructureServer.)
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from MultiStructureServer.)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from MultiStructureServer.)
Public method | GetSupportedCategories | Returns the list of supported categories. (Inherited from MultiStructureServer.)
Public method | GetSupportedMaterials | Returns the list of supported materials. (Inherited from MultiStructureServer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from MultiStructureServer.)
Public method | GetVersion | Gets the version of code checking server. (Inherited from MultiStructureServer.)
Public method | IsContextSupported | Determines whether specified context is supported. (Inherited from MultiStructureServer.)
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load combinations, they will be exposed on the dialog. (Inherited from MultiStructureServer.)
Public method | ResultBuilderPackagesAsInputData | Determines whether server supports load combinations, they will be exposed on the dialog. (Inherited from MultiStructureServer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Runs calculation. (Inherited from MultiStructureServer.)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace