MaterialInfo Members

Structural Analysis and Code Checking API Reference Guide
MaterialInfo Members
MaterialInfo Class Constructors Methods Properties See Also

The MaterialInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialInfo(MaterialCategory) | Creates new instance.
Public method | MaterialInfo(MaterialInfo) | Creates new instance from pattern. Copy constructor.
Public method | MaterialInfo(MaterialCategory, MaterialProperties, MaterialCharacteristics) | Creates new instance.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets category of the material.
Public property | Characteristics | Gets characteristics of the material.
Public property | Properties | Gets properties of the material.

See Also

MaterialInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace