BarProperties Members

Structural Analysis and Code Checking API Reference Guide
BarProperties Members
BarProperties Class Constructors Methods Properties See Also

The BarProperties type exposes the following members.

Constructors

 | Name | Description
Public method | BarProperties | Initializes a new instance of the BarProperties class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Ax | Cross section area
Public property | Iy | Moment of inertia about the Y axis
Public property | Iz | Moment of inertia about the Z axis
Public property | Ky | Ky elastic ground coefficient
Public property | Kz | Kz elastic ground coefficient

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace