SectionsParamsInfo Members

Structural Analysis and Code Checking API Reference Guide
SectionsParamsInfo Members
SectionsParamsInfo Class Constructors Methods Properties See Also

The SectionsParamsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SectionsParamsInfo()()()() | Initializes a new instance of the SectionsInfo class.
Public method | SectionsParamsInfo(SectionDimensions, SectionCharacteristics) | Initializes a new instance of the SectionsInfo class.
Public method | SectionsParamsInfo(SectionDimensions, SectionCharacteristics, List<(Of <<'(SectionDimensions>)>>), List<(Of <<'(SectionCharacteristics>)>>)) | Initializes a new instance of the SectionsInfo class.

Methods

 | Name | Description
Public method | Clear | Sets to defaults.
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Characteristics | Gets the characteristics of section. For double sections or compound sections gets the characteristics for a whole section.
Public property | ComponentsCharacteristics | Gets the characteristics of section components (double sections or compound sections). In other case returns null.
Public property | ComponentsDimensions | Gets the dimensions of section components (double sections or compound sections). In other case returns null.
Public property | Dimensions | Gets the dimensions of section. For double sections or compound sections gets the dimensions for a whole section.

See Also

SectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace