ResultsAccess Members

Structural Analysis and Code Checking API Reference Guide
ResultsAccess Members
ResultsAccess Class Methods Properties Events See Also

The ResultsAccess type exposes the following members.

Methods

 | Name | Description
 | CreateResultsAccess | Creates ResultsAccess object connected to the Revit document
Public method | CreateResultsPackage(ResultsPackageDescriptor) | Creates the results package from descriptor.
Public method | CreateResultsPackage(Guid, String, UnitsSystem) | Obsolete. Create new instance of ResultsPackageBuilder.
Public method | CreateResultsPackage(Guid, String, UnitsSystem, ResultsPackageTypes) | Create new instance of ResultsPackageBuilder.
Public method | CreateResultsPackage(Guid, String, UnitsSystem, ResultsPackageTypes, String) | Create new instance of ResultsPackageBuilder. Package created by this function will be password protected. Updates of this package will require this password
Public method | DeleteResultsPackage(Guid) | Deletes results packages of given guid from the document
Public method | DeleteResultsPackage(String) | Obsolete. Deletes results packages of given Name from the document
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetDocument | Gets the document.
 | GetDocumentUniqueId(Document) | Gets the unique document id.
 | GetDocumentUniqueId(Int32) | Gets the unique document id.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResultsPackage(Guid) | Returns packages of given guid or null if not exists.
Public method | GetResultsPackage(String) | Returns packages of given name or null if not exists.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateResultsPackage(Guid) | Obsolete. Update existing results package.
Public method | UpdateResultsPackage(Guid, String) | Update existing results package.

Properties

 | Name | Description
Public property | Document | Provides access to the document that ResultsAccess was created for.
Public property | ResultsDescriptors | Provides access to the packages defined in current document.
Public property | ResultsPackages | Provides access to the packages defined in current document.

Events

Name | Description
PackagesAdded | Subscribe to the PackagesAdded event to be notified that results package has been added.
PackagesDeleted | Subscribe to the PackagesDeleted event to be notified that results package has been deleted.
PackagesModified | Subscribe to the PackagesModified event to be notified that results package has been modified.
PackagesStatusChanged | Subscribe to the PackagesStatusChanged event to be notified that results package status has been changed.

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace