StorageDocument Members

Structural Analysis and Code Checking API Reference Guide
StorageDocument Members
StorageDocument Class Constructors Methods Properties See Also

The StorageDocument type exposes the following members.

Constructors

 | Name | Description
Public method | StorageDocument | Initializes a new instance of the StorageDocument class.

Methods

 | Name | Description
Public method | Commit | Commits this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReloaded | Determines whether this instance is reloaded.
Public method | OnSynchronized | Reacts after synchronization.
Public method | OnSynchronizing | Reacts on synchronizing.
Public method | Reload | Reloads this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CalculationParamsManager | The calculation parameters manager.
Public property | LabelsManager | The labels manager.
Public property | ResultBuilderManager | Gets the result builder manager.
Public property | ResultsManager | The results manager.
Public property | RevitDocument | The Revit document.

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace