ResultBuilderManager Members

Structural Analysis and Code Checking API Reference Guide
ResultBuilderManager Members
ResultBuilderManager Class Constructors Methods Properties See Also

The ResultBuilderManager type exposes the following members.

Constructors

 | Name | Description
Public method | ResultBuilderManager | Initializes a new instance of the ResultBuilderManager class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPackageUpToDate | Indicates whether package is up-to-date.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateAnalysisName | Validates the name of the analysis.
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)
Public method | ValidatePackageData | Validates the package data.

Properties

 | Name | Description
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded. (Inherited from StorageManager.)
Public property | ResultBuilderAccess | Gets the result builder access.
Public property | RevitDocument | The Revit document. (Inherited from StorageManager.)
Public property | StorageDocument | The storage manager this instance belongs to. (Inherited from StorageManager.)

See Also

ResultBuilderManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace