Storage(T) Members

Structural Analysis and Code Checking API Reference Guide
Storage<(Of <(<'T>)>)> Members
Storage<(Of <(<'T>)>)> Class Constructors Methods Properties See Also

The Storage<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Storage<(Of <(<'T>)>)>(StorageDocument) | Initializes a new instance of the Autodesk.Revit.DB.CodeChecking.Storage class.
Public method | Storage<(Of <(<'T>)>)>(ElementId, StorageDocument) | Initializes a new instance of the Autodesk.Revit.DB.CodeChecking.Storage class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntites | Gets entites.
Public method | GetEntity()()()() | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity(Guid) | Returns entity of particular schema.
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServerStorageSchemaBased |
Public method | GetServerStorageServerBased |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one.
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | SetEntity(SchemaClass, Guid) | Sets the entity.
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetServerStorage | Adds the server data to storage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Document | Gets or sets the document.
Public property | ElementId | Gets or sets the Element
Public property | ServersStorages | Gets or sets list of entities (for different servers)

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace