ForceResultsCache Members

Structural Analysis and Code Checking API Reference Guide
ForceResultsCache Members
ForceResultsCache Class Constructors Methods Properties See Also

The ForceResultsCache type exposes the following members.

Constructors

 | Name | Description
Public method | ForceResultsCache(Document, ICollection<(Of <<'(ForceCalculationDataDescriptor>)>>), ICollection<(Of <<'(ForceResultsPackageDescriptor>)>>), ICollection<(Of <<'(ElementId>)>>), DisplayUnit) | Creates ForceResultsCache
Public method | ForceResultsCache(Document, ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ForceResultsPackageDescriptor>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ForceType>)>>), DisplayUnit) | Creates ForceResultsCache

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCalculationPoints | Gets a list of Calculation points in which internal forces can be read
Public method | GetElementResultsStatus | Gets status of element results
Public method | GetForceForCase(ElementId, ForceLoadCaseDescriptor, IEnumerable<(Of <<'(CalcPoint>)>>), ForceType) | Gets internal forces in specified calculation points in a given element for a specific load and force type
Public method | GetForceForCase(ElementId, ForceResultsPackageDescriptor, ForceLoadCaseDescriptor, IEnumerable<(Of <<'(CalcPoint>)>>), ForceType) | Gets internal forces in specified calculation points in a given element for a specific resPackage, load and force type
Public method | GetForceForPoint(ElementId, IEnumerable<(Of <<'(ForceLoadCaseDescriptor>)>>), CalcPoint, ForceType) | Gets internal forces in a specific calculation point in a given element for specified loads and force type
Public method | GetForceForPoint(ElementId, ForceResultsPackageDescriptor, IEnumerable<(Of <<'(ForceLoadCaseDescriptor>)>>), CalcPoint, ForceType) | Gets internal forces in a specific calculation point in a given element for a specific ResPackage, loads and force type
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadCaseDescriptors()()()() | Method for querrying all available loads and combinations
 | GetLoadCaseDescriptors(Document, IEnumerable<(Of <<'(ElementId>)>>)) | Creates hashset of loadDescriptors
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ResultBuilderAccessTime |
Public property | ResultsPackageDescriptors | Method for querrying all available results packages

See Also

ForceResultsCache Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace