SlabNode Members

Structural Analysis and Code Checking API Reference Guide
SlabNode Members
SlabNode Class Constructors Methods Properties See Also

The SlabNode type exposes the following members.

Constructors

 | Name | Description
Public method | SlabNode(SlabInfo) | Creates instance.
Public method | SlabNode(SlabInfo, XYZ) | Creates instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from SlabBaseObject.)
Public method | GetGlobalCoordinates | Returns cooridinates in global coordinates system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPointNode | Compares current node with specific point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element. (Inherited from SlabBaseObject.)
Public property | ContextId | Revit Id of element. (Inherited from SlabBaseObject.)
Public property | Coordinates | Gets local coordinates.
Public property | ElementType | Type of element. (Inherited from SlabBaseObject.)
Public property | ParentContours | Gets parent contours.
Public property | ParentEdges | Gets parent edges.
Public property | ParentSlab | Parent slab. (Inherited from SlabBaseObject.)

See Also

SlabNode Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace