ResultStatus Methods

Structural Analysis and Code Checking API Reference Guide
ResultStatus Methods
ResultStatus Class See Also

The ResultStatus type exposes the following members.

Methods

 | Name | Description
Public method | AddError(String, Boolean) | Adds the error.
Public method | AddError(ResultStatusMessage, Document, Boolean) | Adds the error.
Public method | AddInfo(String, Boolean) | Adds the info.
Public method | AddInfo(ResultStatusMessage, Document, Boolean) | Adds the info.
Public method | AddWarning(String, Boolean) | Adds the warning.
Public method | AddWarning(ResultStatusMessage, Document, Boolean) | Adds the warning.
Public method | Clear | Clears this instance.
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from SchemaClass.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Checks if data of this class exists in the element. (Inherited from SchemaClass.)
Public method | FillEntity | Fills entity based on this instance. (Inherited from SchemaClass.)
Public method | GetEntity | Returns the entity based on this instance. (Inherited from SchemaClass.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute. (Inherited from SchemaClass.)
Public method | IsError | Determines whether this instance is error.
Public method | IsOk | Determines whether this instance is ok.
Public method | IsWarning | Determines whether this instance is warning.
Public method | Load | Loads data from Revit element. (Inherited from SchemaClass.)
Public method | LoadField | Loads the property in a special way (otherwise returns false). (Inherited from SchemaClass.)
Public method | PostLoad | Called after loading the instance. (Inherited from SchemaClass.)
Public method | PostSave | Called after saving the instance. (Inherited from SchemaClass.)
Public method | PreLoad | Called before loading the instance. (Inherited from SchemaClass.)
Public method | PreSave | Called before saving the instance. (Inherited from SchemaClass.)
Public method | Remove | Removes data from element. (Inherited from SchemaClass.)
Public method | Save | Saves data to Revit element. (Inherited from SchemaClass.)
Public method | SaveField | Saves the property in a special way (otherwise returns false) (Inherited from SchemaClass.)
Public method | SetProperties | Sets properties of this instance based on the entity. (Inherited from SchemaClass.)
Public method | SetStatusRatioBased | Sets the status based on ratio.
Public method | SetStatusValueBased | Sets the status based on value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace