Autodesk.Revit.DB.ResultsBuilder Namespace

Autodesk.Revit.DB.ResultsBuilder Namespace

Classes

 | Class | Description
Public class | BarNodeResult | Represents result value of specified type for given node.
Public class | BarNodeResultEnvelope | Represents result value of specified type for given node.
Public class | BaseGraph | Base class for various types of results returned by ResultsBuilder.
Public class | LineGraph | Represents two-dimensional line graph defined by the ordered set of pairs (U,V(U)).
Public class | LineGraphByCoordinatesParameters | Contains settings for calculating results on linear elements.
Public class | LineGraphByDivisionParameters | Contains settings for calculating results on linear elements.
Public class | LineGraphEnvelope | Represents envelope of line graphs.
Public class | LineGraphParameters | Base class for various types of settings used for calculating linear results.
Public class | MeasurementDescription | MeasurementDescription describes the measurement defined in the package.
Public class | NodeReactions | Defines a set of standard results in the calculation point supported on elastic ground.
Public class | NodeResult | Represents XYZ result value of specified type for given node.
Public class | NodeResultEnvelope | Represents envelope of result value for given node.
Public class | NodeResults | Defines a set of results for node.
Public class | PackagesAddedEventArgs | The event arguments used by the PackagesAdded event.
Public class | PackagesDeletedEventArgs | The event arguments used by the PackagesDeleted event.
Public class | PackagesModifiedEventArgs | The event arguments used by the PackagesModified event.
Public class | PackagesStatusChangedEventArgs | The event arguments used by the PackagesStatusChanged event.
Public class | PointResults | Defines a set of standard results in the calculation point.
Public class | ResultsAccess | ResultsAccess object is designed for storing results of various calculation analysis in the document.
Public class | ResultsPackage | Analysis class provides access to the results of analysis.
Public class | SurfaceGraph | Represents planar map of Points defined by the set of triples (valueX,valueY,values(valueX,valueY))
Public class | SurfaceGraphEnvelope | Represents envelope of surface graphs.
Public class | SurfaceGraphParameters | Class for various types of settings used for calculating results on surfaces.
Public class | SurfaceNodeResult | Represents result value of specified type for given node.
Public class | SurfaceNodeResultEnvelope | Represents result value of specified type for given node.

Enumerations

 | Enumeration | Description
Public enumeration | DomainResultType | Defines a standard types of analytical domains.
Public enumeration | LinearResultType | Defines a standard types of analytical results for linear elements like beams and columns.
Public enumeration | MeasurementDependencyType | Defines the available types of measurements dependencies.
Public enumeration | MeasurementResultType | Defines the available types of measurements stored in the package.
Public enumeration | NodeResultType | Defines a standard types of analytical results for elements defined by node. All values are measured in global coordinate system.
Public enumeration | ResultsPackageTypes | Defines types of packages.
Public enumeration | ResultsStatus | Constants defines the status of results package.
Public enumeration | SurfaceGraphDirectionType | Defines a types of methods that the surface results are calculated while querying.
Public enumeration | SurfaceResultType | Defines a standard types of analytical results for planar elements like slabs and walls.
Public enumeration | UnitsSystem | Defines the set of units that is used by default for the resuts.

BarNodeResult Class

BarNodeResult Class
Members See Also
Represents result value of specified type for given node.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarNodeResult : BaseGraph

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder..::..BaseGraph
Autodesk.Revit.DB.ResultsBuilder..::..BarNodeResult

See Also

BarNodeResult Members
Autodesk.Revit.DB.ResultsBuilder Namespace