ForceCalculationDataDescriptorLinear Members

Structural Analysis and Code Checking API Reference Guide
ForceCalculationDataDescriptorLinear Members
ForceCalculationDataDescriptorLinear Class Constructors Methods Properties See Also

The ForceCalculationDataDescriptorLinear type exposes the following members.

Constructors

 | Name | Description
Public method | ForceCalculationDataDescriptorLinear(ElementId) | Creates default ForceCalculationPointsDescriptorLinear
Public method | ForceCalculationDataDescriptorLinear(ElementId, Double, IEnumerable<(Of <<'(Double>)>>), Boolean, List<(Of <<'(ForceType>)>>)) | Creates default ForceCalculationPointsDescriptorLinear

Methods

 | Name | Description
Public method | AddBendingForceTypes | Adds bending forcetypes to the data (Inherited from ForceCalculationDataDescriptor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Gets or sets Revit ElementId for element to which calculation point is assigned (Inherited from ForceCalculationDataDescriptor.)
Public property | ForceTypes | Gets internal force types for which calculations are to be conducted (Inherited from ForceCalculationDataDescriptor.)
Public property | ForceTypesHashed | Gets hashed internal force types for the whole collection (Inherited from ForceCalculationDataDescriptor.)
Public property | Points | Gets calculation points coordinates
Public property | PointsHashed | Gets hash string representation of division points

See Also

ForceCalculationDataDescriptorLinear Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace