MaterialMetalCharacteristics Members

Structural Analysis and Code Checking API Reference Guide
MaterialMetalCharacteristics Members
MaterialMetalCharacteristics Class Constructors Methods Properties See Also

The MaterialMetalCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialMetalCharacteristics()()()() | Creates default instance.
Public method | MaterialMetalCharacteristics(MaterialMetalCharacteristics) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MinimumTensileStrength | Gets the minimum tensile strength of the metal.
Public property | MinimumYieldStress | Gets the minimum yield stress of the metal.
Public property | ReductionFactor | Gets the reduction factor for shear of the metal.
Public property | ResistanceCalculationStrength | Gets the resistance calculation strength factor of the metal.

See Also

MaterialMetalCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace