ResultBuilderManager Methods

Structural Analysis and Code Checking API Reference Guide
ResultBuilderManager Methods
ResultBuilderManager Class See Also

The ResultBuilderManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchemaId | (Inherited from StorageManager.)
Public method | GetSchemaIdForServer | (Inherited from StorageManager.)
Public method | GetServerIdOfStorageSchema | (Inherited from StorageManager.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPackageUpToDate | Indicates whether package is up-to-date.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateAnalysisName | Validates the name of the analysis.
Public method | ValidateCategory(BuiltInCategory) | (Inherited from StorageManager.)
Public method | ValidateCategory(BuiltInCategory, String, Guid) | (Inherited from StorageManager.)
Public method | ValidatePackageData | Validates the package data.

See Also

ResultBuilderManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace