SubSchemaControl Members

Structural Analysis and Code Checking API Reference Guide
SubSchemaControl Members
SubSchemaControl Class Constructors Methods Properties See Also

The SubSchemaControl type exposes the following members.

Constructors

 | Name | Description
Public method | SubSchemaControl | Initializes a new instance of the SubSchemaControl class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Container | Gets the container. (Inherited from FieldControl.)
Public property | FieldDisplayName | Gets or sets the display name of the field. (Inherited from FieldControl.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from FieldControl.)
Public property | Index | Gets or sets the index. (Inherited from Control.)
Public property | KeyType | Gets the type of the key. (Inherited from FieldControl.)
Public property | KeyVisualAttribute | Gets or sets the visual attribute. (Inherited from FieldControl.)
Public property | Layout | Gets or sets the layout.
Public property | SchemaGuid | Gets or sets the schema GUID. (Inherited from FieldControl.)
Public property | SubSchemaId | Gets or sets the subschema id.
Public property | UnitAttribute | Gets the unit attribute. (Inherited from FieldControl.)
Public property | ValueType | Gets the type of the value. (Inherited from FieldControl.)
Public property | VisualAttribute | Gets or sets the visual attribute. (Inherited from FieldControl.)

See Also

SubSchemaControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace