RevitLoadCombination Members

Structural Analysis and Code Checking API Reference Guide
RevitLoadCombination Members
RevitLoadCombination Class Constructors Methods Properties See Also

The RevitLoadCombination type exposes the following members.

Constructors

 | Name | Description
Public method | RevitLoadCombination | Initializes a new instance of the RevitLoadCombination class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsageName | Gets the name of the usage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Combination | Gets or sets the combination.

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace