SectionShapeType Enumeration

SectionShapeType Enumeration
See Also Send Feedback
Typ of the section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SectionShapeType

Members

Member name | Value | Description
RectangularHollowConstant | 1 | Rectangular hollow tube with one thickness t
RectangularBar | 2 | Rectangular bar.
RoundTube | 3 | Round tube.
RoundBar | 4 | Round bar.
HalfRoundBar | 5 | Half round bar.
QuarterRoundBar | 6 | Quadrant round bar
RectangularHollowNotConstant | 7 | Rectangular hollow tube with 2 thicknesses tw , tf.
BoxBiSymmetrical | 8 | Bisymetrical box, flanges beyond the outline of webs.
BoxMonoSymmetrical | 9 | Monosymetrical box, flanges beyond the outline of webs.
I | 10 | I-section.
IASymmetrical | 11 | Asymmetrical I-section.
T | 12 | T-section.
C | 13 | C-section.
Z | 14 | Z-section.
CrossBiSymmetrical | 15 | Cross bisymetrical shaped section.
PolygonalBar | 16 | Polygonal bar.
PolygonalHollow | 17 | Polygonal hollow tube.
L | 18 | L type angle section
TAsymmetrical | 19 | Asymmetrical T-section.
DoubleRectangularBar | 20 | Double section.
DoubleSection | 21 | Double sections.
CompoundSection | 22 | Compound section
Unusual | 0 | Unusual section.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace