MeasurementResultType Enumeration

MeasurementResultType Enumeration
See Also Send Feedback
Defines the available types of measurements stored in the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum MeasurementResultType

Members

Member name | Value | Description
Unknown | 0 | Unknow measeurement type.
Scalar | 1 | Measeurement represents a numeric value that may be assigned to any element.
Bar | 2 | Measeurement defined for bars (beam, columns, etc.).
Surface | 3 | Measeurement defined for surfaces (floors, walls, etc.).
Domain | 4 | Measeurement defined for storing domain (coordinates) for the results.
Vector | 5 | Measurement defined for nodes (footings, etc.)
VectorBar | 6 | Measurement defined for nodes on bars
VectorSurface | 7 | Measurement defined for nodes on surface

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace