GridEnumControlAttribute Constructor (Type, PresentationMode, PresentationItem)

GridEnumControlAttribute Constructor (Type, PresentationMode, PresentationItem)
GridEnumControlAttribute Class See Also Send Feedback
Initializes a new instance of the GridEnumControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public GridEnumControlAttribute(
    Type enumType,
    PresentationMode presentationMode,
    PresentationItem presentationItem
)

Parameters

enumType
Type: System..::..Type
Type of the enum.
presentationMode
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationMode
The presentation mode.
presentationItem
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationItem
The presentation item.

See Also

GridEnumControlAttribute Class
GridEnumControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace