HardeningFactor Property

Steel..::..HardeningFactor Property
Steel Class See Also Send Feedback
The HardeningFactor property represents the value of steel hardening over the plastic behaviour.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double HardeningFactor { get; set; }

Field Value

Gets or sets the value of hardening factor between the strain equal to the design strength divided by the modulus of elasticity and the ultimate limit of steel strain.

Remarks

Unit: [dimensionless].
Typical values are in the range between 1.0 and 1.05.
Hardening factor equal to 1.0 means an ideal elasto-plastic steel with horizontal branch, greater than 1.0 an inclined top branch steel with hardening on plastic side.

Exceptions

Exception | Condition
System..::..ArgumentException | The hardening factor for inclined top branch must be greater than 1.0 , for horizontal branch must be equal 1.0

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace