GetSupportedCategories Method

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>..::..GetSupportedCategories Method
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback
Returns the list of supported categories.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract IList<BuiltInCategory> GetSupportedCategories(
    StructuralAssetClass material
)

Parameters

material
Type: StructuralAssetClass

Return Value

List of categories.

Implements

ICodeCheckingServer..::..GetSupportedCategories(StructuralAssetClass)

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace