SolveResistanceM Method

RCSolver..::..SolveResistanceM Method
RCSolver Class See Also Send Feedback
Calculates resistance moment according to acting design axial forces.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SolveResistanceM(
    double actingAxialForce,
    Axis axis,
    bool resultAsPositive
)

Parameters

actingAxialForce
Type: System..::..Double
The acting axial force.
Unit: [force].
axis
Type: Autodesk.CodeChecking.Concrete..::..Axis
Determinates which beanding moment is acting. Bending around x-axis or y-axis.
resultAsPositive
Type: System..::..Boolean
Determinates singn of result. Resistance bending moment should be calculate as negative or positive.

Remarks

The forces are described in the coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
The resistance axial force are the same as acting forces, the moment on the second direction is equal 0.0; The positive axial force gives compression. The resistance forces could be read by GetInternalForces method.
Other information about state of failure could be read using dedicated methods.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Internal error in the SolveResistanceM method

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace