CalculationParamsManager Members

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParamsManager Members
CalculationParamsManager Class Constructors Methods Properties See Also Send Feedback

The CalculationParamsManager type exposes the following members.

Constructors

 | Name | Description
Public method | CalculationParamsManager | Initializes a new instance of the CalculationParamsManager class.

Methods

 | Name | Description
Public method | GetActiveServersForSelection |
Public method | GetActiveServersIds |
Public method | GetCodesWithNotSetCombinations |
Public method | GetCodesWithNotSetInputPackages |
Public method | GetDefault |
Public method | GetServersIds |
Public method | OnSynchronized | (Overrides StorageManagerOnSynchronized(DocumentSynchronizedWithCentralEventArgs).)
Public method | OnSynchronizing | (Overrides StorageManagerOnSynchronizing(DocumentSynchronizingWithCentralEventArgs).)
Public method | SetActiveServers |

Properties

 | Name | Description
Public property | CalculationParams | Returns current calculation parameters.

See Also

CalculationParamsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace