Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace

Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace

Classes

 | Class | Description
Public class | ColorRangeMapItem | contains result list, colors and min max value
Public class | Document | Represents the document
Public class | DocumentAnchor | Represents document anchor element
Public class | DocumentAnchorReference | Represents the reference to anchor
Public class | DocumentBody | Represents the body of the document
Public class | DocumentBuilder | Base class for all document builders.
Public class | DocumentContentTable | Represents table of content
Public class | DocumentDiagram | Represents the diagram
Public class | DocumentDiagramAxis | Represents the diagram axis.
Public class | DocumentDiagramAxisLabel | Represents single axis label
Public class | DocumentDiagramSeries | Describes single series of data.
Public class | DocumentElement | The base class for all document elements.
Public class | DocumentHeader | Represents document header
Public class | DocumentImage | Represents the image.
Public class | DocumentLineBreak | Represents the line break.
Public class | DocumentMap | Represents map
Public class | DocumentPageBreak | Represents the page break.
Public class | DocumentRatio | Represents ratio element
Public class | DocumentSection | Represents document section
Public class | DocumentStatus | Represents document status element
Public class | DocumentTable | Represents the table element.
Public class | DocumentTableCell | Represents the cell of the table
Public class | DocumentText | Represents the text element.
Public class | DocumentTitle | Represents the title element.
Public class | DocumentValue | Represents the value element.
Public class | DocumentValueWithDescription | Represents document value element with additional description
Public class | DocumentValueWithName | Represents document value with name
Public class | HtmlBuilder | Represents html files builder
Public class | MhtBuilder | Represents mht files builder
Public class | TextBuilder | Represents html files builder

Enumerations

 | Enumeration | Description
Public enumeration | DetailLevel | Describes detail level of element
Public enumeration | DiagramType | Describes types of diagrams

ColorRangeMapItem Class

ColorRangeMapItem Class
Members See Also Send Feedback
contains result list, colors and min max value

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ColorRangeMapItem

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..ColorRangeMapItem

See Also

ColorRangeMapItem Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace