ForceType Enumeration

ForceType Enumeration
See Also Send Feedback
Identificator for internal forces inside a cross-section

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ForceType

Members

Member name | Value | Description
Unknown | 0 | Unknown
Fx | 1 | Axial force (bar element)
Fy | 2 | Shear force y (bar element)
Fz | 3 | Shear force z (bar element)
Mx | 4 | Torsion moment (bar element)
My | 5 | Bending moment y (bar element)
Mz | 6 | Bending moment z (bar element)
Mxx | 7 | Bending moment xx (surface element)
Myy | 8 | Bending moment yy (surface element)
Mxy | 9 | Bending moment xy (surface element)
Fxx | 10 | Normal force xx (surface element)
Fyy | 11 | Normal force yy (surface element)
Fxy | 12 | Normal force xy (surface element)
Qxx | 13 | Shear force xx (surface element)
Qyy | 14 | Shear force yy (surface element)
Ux | 15 | Deflection X
Uy | 16 | Deflection Y
Uz | 17 | Deflection Z
GetLinearResultType |  | Converts ForceType into ResultBuilder LinearResultType
GetSurfaceResultType |  | Converts ForceType into ResultBuilder SurfaceResultType

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace