Layer Members

[image]

Structural Analysis and Code Checking API Reference Guide
Layer Members
Layer Class Constructors Methods Properties See Also Send Feedback

The Layer type exposes the following members.

Constructors

 | Name | Description
Public method | Layer()()()() | Creates default instance.
Public method | Layer(ElementId, Double, Double, Boolean, MaterialFunctionAssignment) | Constructs object.

Methods

 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | Material | Gets material of the layer.

Properties

 | Name | Description
Public property | Function | Gets material function of layer.
Public property | Offset | Layer offset from object begining.
Public property | Structure | Check if layer is structure.
Public property | Thickness | Layer thickness.

See Also

Layer Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace