CreateLoadCombinationSets Method (List(), Double, List(Double[]))

LoadCombinationUtils..::..CreateLoadCombinationSets Method (List<(Of <(<'>)>)>, Double, List<(Of <(<'array<Double>[]()[][]>)>)>%)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCaseArray> CreateLoadCombinationSets(
    List<LoadCaseArray> loadCasesSets,
    double factor,
    out List<double[]> factors
)

Parameters

loadCasesSets
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases sets.
factor
Type: System..::..Double
The factor1.
factors
Type: System.Collections.Generic..::..List <(Of <(<'array< Double >[]()[][]>)>)>%
The factors.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinationSets Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace