SectionCharacteristics Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SectionCharacteristics Properties
SectionCharacteristics Class See Also Send Feedback

The SectionCharacteristics type exposes the following members.

Properties

 | Name | Description
Public property | A | Gets or sets the Cross-section area.
Public property | Iy | Gets or sets the moment of inertia about the Y axis.
Public property | Iz | Gets or sets the moment of inertia about the Z axis.
Public property | mass | Gets or sets the nominal weight per unit length.
Public property | ry | Gets or sets the radius of gyration about the Y axis.
Public property | rz | Gets or sets the radius of gyration about the Z axis.

See Also

SectionCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace