SurfaceResultType Enumeration

SurfaceResultType Enumeration
See Also Send Feedback
Defines a standard types of analytical results for planar elements like slabs and walls.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SurfaceResultType

Members

Member name | Value | Description
Unknown | 0 | Unknown planar result type
Mxx | 1 | Mxx moment
Myy | 2 | Myy moment
Mxy | 3 | Mxy moment
Fxx | 4 | Fxx membrane force
Fyy | 5 | Fyy membrane force
Fxy | 6 | Fxy membrane force
UX | 7 | UX displacement in global coordinates
UY | 8 | UY displacement in global coordinates
UZ | 9 | UZ displacement in global coordinates
RX | 10 | RX rotation in global coordinates
RY | 11 | RY rotation in global coordinates
RZ | 12 | RZ rotation in global coordinates
Qxx | 13 | Qxx shear force
Qyy | 14 | Qyy shear force
K | 15 | K soil reaction, derivative result
AxxTop | 16 | Top required main reinforcement
AxxBottom | 17 | Bottom required main reinforcement
AyyTop | 18 | Top required perpendicular reinforcement
AyyBottom | 19 | Bottom required perpendicular reinforcement
Sxx | 20 | Sxx stress
Syy | 21 | Syy stress
Sxy | 22 | Sxy stress
Txx | 23 | Txx shear stress
Tyy | 24 | Tyy shear stress
ReactionMX | 25 | Reaction MX
ReactionMY | 26 | Reaction MY
ReactionMZ | 27 | Reaction MZ
ReactionFX | 28 | Reaction FX
ReactionFY | 29 | Reaction FY
ReactionFZ | 30 | Reaction FZ

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace