GridElementComboBoxAttribute Class

GridElementComboBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with Element ComboBox grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridElementComboBoxAttribute : ElementComboBoxAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DataSourceFormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ElementComboBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridElementComboBoxAttribute

See Also

GridElementComboBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace