GetExtremumValueCoordinates Method

ForceResultsUtils..::..GetExtremumValueCoordinates Method
ForceResultsUtils Class See Also Send Feedback
Gets coordinates of extreme value for given results

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<Tuple<int, int, ForceType, double>> GetExtremumValueCoordinates(
    Document document,
    ICollection<ElementId> combinations,
    ICollection<ForceType> forceTypes,
    ICollection<ElementId> elementIds
)

Parameters

document
Type: Document
Revit document
combinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
List of loads and combinations for which extremes will be selected
forceTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' ForceType >)>)>
List or resultTypes for which extremes will be searched
elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
Revit ElementID

Return Value

Collection of list elements where each element contains elementId, loadId, ForceType, and coordinate associated with extreme value

See Also

ForceResultsUtils Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace