Storage(T) Members

[image]

Structural Analysis and Code Checking API Reference Guide
Storage<(Of <(<'T>)>)> Members
Storage<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The Storage<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Storage<(Of <(<'T>)>)>(StorageDocument) | Initializes a new instance of the Autodesk.Revit.DB.CodeChecking.Storage class.
Public method | Storage<(Of <(<'T>)>)>(ElementId, StorageDocument) | Initializes a new instance of the Autodesk.Revit.DB.CodeChecking.Storage class.

Methods

 | Name | Description
Public method | GetEntites | Gets entites.
Public method | GetEntity(Guid) | Returns entity of particular schema.
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity.
Public method | GetServerStorageSchemaBased |
Public method | GetServerStorageServerBased |
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one.
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | SetEntity(SchemaClass, Guid) | Sets the entity.
Public method | SetServerStorage | Adds the server data to storage.

Properties

 | Name | Description
Public property | Document | Gets or sets the document.
Public property | ElementId | Gets or sets the Element
Public property | ServersStorages | Gets or sets list of entities (for different servers)

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace