SchemaPropertyAttribute Class

SchemaPropertyAttribute Class
Members Example See Also Send Feedback
Indicates that a property of the class should be converted to the field in schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SchemaPropertyAttribute : UnitAttribute

Examples

The property of the string type, the name and the type taken directly from the property:
CopyC#
[SchemaProperty()]
public string A { get; set; }
 The property of the double type with category and unit defined:
CopyC#
[SchemaProperty(Unit = UnitType.UT_Length, DisplayUnit = DisplayUnitType.DUT_METERS)]
public double B { get; set; }
 The property with changed name of the field:
CopyC#
[SchemaProperty(FieldName = "C")]
public string InternalName { get; set; }
 The property with changed type of the field and defined converter:
CopyC#
[SchemaProperty(FieldType = typeof(List/<int />), ConverterType = typeof(DateTimeConverter))]
public DateTime Date { get; set; }

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..UnitAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..SchemaPropertyAttribute

See Also

SchemaPropertyAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace