FilterElements Method (, [])

Tools..::..FilterElements Method (, array<>[]()[][])
Tools Class See Also Send Feedback
This method filters revit's elements by BuiltInCategory

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<Element> FilterElements(
    Document doc,
    params BuiltInCategory[] categories
)

Parameters

doc
Type: Document
Revit's document
categories
Type: array<BuiltInCategory>[]()[][]
Filtering categories

Return Value

Collection of revit's elements

See Also

Tools Class
FilterElements Overload
Autodesk.Revit.DB.CodeChecking Namespace