FieldUIAttribute Class

FieldUIAttribute Class
Members See Also Send Feedback
Base class for all attribute classes used for describing visualization aspect of particular fields.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class FieldUIAttribute : ControlAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CheckBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CustomControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DefaultFieldControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..EnumControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaEmbeddedControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaListTableAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..UnitTextBoxAttribute

See Also

FieldUIAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace