SlabInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
SlabInfo Members
SlabInfo Class Constructors Methods Properties See Also Send Feedback

The SlabInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SlabInfo | Creates default instance.

Methods

 | Name | Description
Public method | GetEdge(List<(Of <<'(XYZ>)>>)) | Returns edge of specific cooridinates.
Public method | GetEdge(XYZ, XYZ) | Returns edge of specific coordinates.
Public method | GetMainContour | returns main contour of the slab.
Public method | GetNode | Returns node of specific coordinates.
Public method | IsPointInDomain | Checks if point is in domain of slab (it has to be inside main contour and it can't be inside any hole)
Public method | StructuralLayer | Gets the structural layer.
Public method | Thickness | Gets the thickness of slab.

Properties

 | Name | Description
Public property | ContextId | Revit Id of element.
Public property | Contours | Gets list of SlabContour objects.
Public property | Edges | Gets list of SlabEdge objects.
Public property | FamilyName | Gets family name.
Public property | IsOneWay | One way structural usage flag
Public property | Layers | Gets list of Layer objects (from Top to Bottom).
Public property | LevelName | Gets level name.
Public property | MaximumBoundary | Gets maximum coordinates (upper-right-front corner) of the boundary box.
Public property | MinimumBoundary | Gets minimum coordinates (lower-left-rear corner) of the boundary box.
Public property | Nodes | Gets list of SlabNode objects.
Public property | SpanDirectionAngle | Gets angle of span direction.
Public property | Transform | Gets class allows to transform points from local to global (and vice versa) coordinate system.
Public property | TypeName | Gets name of type.

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace