Rebar Constructor

Rebar Constructor
Rebar Class See Also Send Feedback
The Rebar class constructor. Creates the rebar with coordinates x,y and area.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Rebar(
    double x,
    double y,
    double area
)

Parameters

x
Type: System..::..Double
The x-coordinate of the center of rebar.
Unit: [length].
y
Type: System..::..Double
The y-coordinate of the center of rebar.
Unit: [length].
area
Type: System..::..Double
The area of the rebar.
Unit: [length^2]

Exceptions

Exception | Condition
System..::..ArgumentException | Rebar area must be greater than 0.0

See Also

Rebar Class
Autodesk.CodeChecking.Concrete Namespace