GridKeyTextBoxAttribute Class

GridKeyTextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular key of the field (only for maps) should be edited with TextBox grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridKeyTextBoxAttribute : TextBoxAttribute,
    IGridAttribute

Remarks

Only for maps.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridKeyTextBoxAttribute

See Also

GridKeyTextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace