Geometry Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Geometry Properties
Geometry Class See Also Send Feedback

The Geometry type exposes the following members.

Properties

 | Name | Description
Public property | Area | Gets the value of contour area.
Public property | CenterOfInertia | Gets coordinates of the center of inertia of the concrete cross section.
Public property | Count | Gets the number of points describing the concrete cross section contour.
Public property | MomentOfInertiaX | Gets the value of the moment of inertia of the concrete cross section.
Public property | MomentOfInertiaY | Gets the value of the moment of inertia of the concrete cross section.
Public property | Perimeter | Gets the value of contour perimeter.

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace