GetCenterOfInertia Method

RCSolver..::..GetCenterOfInertia Method
RCSolver Class See Also Send Feedback
Gets the coordinates of center of inertia.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Point2D GetCenterOfInertia(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of moment to be returned, repectively for rebar, concrete or equivalent section (transformed).

Return Value

Returns the center of inertia point as Point2D.

Return Value

Returns the center of inertia point as Point2D.

Remarks

Unit depends to the units used to define concrete, steel, geometry and internal forces.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace