ElementAnalyser Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementAnalyser Members
ElementAnalyser Class Constructors Methods Properties See Also Send Feedback

The ElementAnalyser type exposes the following members.

Constructors

 | Name | Description
Public method | ElementAnalyser()()()() | Initializes a new instance of ElementAnalyser class. Internal Revit units are using.
Public method | ElementAnalyser(DisplayUnit) | Initializes a new instance of ElementAnalyser class with proper unit system.

Methods

 | Name | Description
Public method | Analyse | Performs analysis of Revit element.

Properties

 | Name | Description
Public property | TSectionAnalysis | Turn on/off t-section analysis (if element is a beam).
Public property | UseAnalyticalModelForSlabs | Turn on/off using analitical model for slabs.

See Also

ElementAnalyser Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace