ResultsPackage Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage Members
ResultsPackage Class Methods Properties See Also Send Feedback

The ResultsPackage type exposes the following members.

Methods

 | Name | Description
Public method | GetBarNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Returns node results for linear element.
Public method | GetBarNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>), UnitsSystem) | Returns bar node results for element.
Public method | GetBarNodeResultsEnvelopes | GetBarNodeResultsEnvelopes
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>), LineGraphParameters) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), LineGraphParameters) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Return list of envelopes of linear results for given input parameters.
Public method | GetLineGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), LineGraphParameters) | Return list of envelopes of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphsExtremes | Return extremal values for given input parameters.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), NodeResultType) | Returns node results for element.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), NodeResultType, UnitsSystem) | Returns node results for element.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), String, UnitsSystem) | Returns node results for element.
Public method | GetNodeResultsEnvelope | Returns node results for element.
Public method | GetNodeResultsExtremes | Return extremal values for given input parameters.
Public method | GetReducedSurfaceResults | Returns reduced results for surface element.
Public method | GetResultsStatus | Return the status of the entire package.
Public method | GetStoreyResults | Returns results for storey.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>), SurfaceGraphParameters) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), SurfaceGraphParameters) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Return envelope of results.
Public method | GetSurfaceGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), SurfaceGraphParameters) | Return envelope of results.
Public method | GetSurfaceGraphsExtremes | Return extremal values for given input parameters.
Public method | GetSurfaceNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Returns surface node results for element.
Public method | GetSurfaceNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>), UnitsSystem) | Returns surface node results for element.
Public method | GetSurfaceNodeResultsEnvelope |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AnalysisInfo | Provides access to the Analysis Info of the package.
Public property | AnalysisName | Provides access to the Analysis Name of the package.
Public property | CreationTime | Provides access to the creation time of the package.
Public property | Description | Provides access to the Description of the package.
Public property | DesignOption | Provides access to the design option id for which the analysis was performed.
Public property | ElementIds | Returns set of elements for which results are available
Public property | GUID | Provides access to the GUID of the results package.
Public property | IsProviderPackage | Gets a value indicating whether this instance is provider package.
Public property | LoadCaseIds | Returns set of load cases for which results are available
Public property | Measurements | Returns collections of measurements defined in the package.
Public property | ModelId | Provides access to the Guid of the package.
Public property | ModelInfo | Provides access to the Model Info of the package.
Public property | ModelName | Provides access to the Model Name of the package.
Public property | Name | Provides access to the Name of the results package.
Public property | PackageSize | Returns package size in kilobytes.
Public property | Phase | Provides access to the phase id for which the analysis was performed.
Public property | ProviderDescriptor | Gets the provider descriptor. This reference is set, when the ResultsPackage was created from this ResultsPackageDescriptor.
Public property | ProviderDescriptorReference | Gets the provider descriptor reference. This reference is set, when the ResultsPackage is saved with document and it has ResultsPackageDescriptor provided by some provider.
Public property | ProviderName | Provides access to the Provider Name of the package.
Public property | ResultsPackageType | Returns type of package.
Public property | VendorDescription | Provides access to the Vendor Description of the package.
Public property | VendorId | Provides access to the Vendor Id of the package.

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace