GetLineGraphs Method (ICollection(), ICollection(), ICollection(String), LineGraphParameters)

ResultsPackage..::..GetLineGraphs Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'String>)>)>, LineGraphParameters)
ResultsPackage Class See Also Send Feedback
Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<LineGraph> GetLineGraphs(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCases,
    ICollection<string> resultsNames,
    LineGraphParameters lineGraphMode
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsNames
Type: System.Collections.Generic..::..ICollection <(Of <(<' String >)>)>
lineGraphMode
Type: Autodesk.Revit.DB.ResultsBuilder..::..LineGraphParameters

See Also

ResultsPackage Class
GetLineGraphs Overload
Autodesk.Revit.DB.ResultsBuilder Namespace