UnitTextBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
UnitTextBoxAttribute Members
UnitTextBoxAttribute Class Constructors Methods Fields Properties See Also Send Feedback

The UnitTextBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | UnitTextBoxAttribute | Initializes a new instance of the UnitTextBoxAttribute class

Methods

 | Name | Description
Public method | GetFieldValidator | Gets the field validator.

Fields

Name | Description
PropertyMaximumValue | Describes attribute indicating maximum value
PropertyMinimumValue | Describes attribute indicating minimum value
PropertyValidateMaximumValue | Describes attribute indicating whether maximum value should be checked
PropertyValidateMinimumValue | Describes attribute indicating whether minimum value should be checked

Properties

 | Name | Description
Public property | AttributeUnit | Unit in which values of the attribute are described
Public property | FieldValidator | Gets or sets the field validator.
Public property | MaximumValue | Maximum value
Public property | MinimumValue | Minimum value
Public property | ValidateMaximumValue | Indicates if maximum value should be checked
Public property | ValidateMinimumValue | Indicates if minimum value should be checked

See Also

UnitTextBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace