ConcreteExceptionEnum Enumeration

ConcreteExceptionEnum Enumeration
See Also Send Feedback
Classification of exceptions that could be thrown during creation of the concrete parameters.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum ConcreteExceptionEnum

Members

Member name | Value | Description
DesignStrength | 0 | The concrete design strength must be greater than 0.0.
StrainUltimateLimit | 1 | The concrete strain at failure must be greater than 0.0.
ModulusOfElasticity | 2 | The concrete Young modulus (modulus of elasticity) must greater than 0.0.
StressDiagType | 3 | Unsupported stress-strain relationship.
Power | 4 | The power should be greater than 1.0.
StrainRelationChangeOver | 5 | The relationship changeover must be less than the ultimate strain
EffectiveHeightReductionFactor | 6 | The reduction factor of the compression zone height must be in the range between 0 and 1.0.

See Also

Autodesk.CodeChecking.Concrete Namespace