GetLineGraphsEnvelopes Method (ICollection(), ICollection(), ICollection(LinearResultType))

ResultsPackage..::..GetLineGraphsEnvelopes Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'LinearResultType>)>)>)
ResultsPackage Class See Also Send Feedback
Return list of envelopes of linear results for given input parameters.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<LineGraphEnvelope> GetLineGraphsEnvelopes(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCases,
    ICollection<LinearResultType> resultsTypes
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCases
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' LinearResultType >)>)>

See Also

ResultsPackage Class
GetLineGraphsEnvelopes Overload
Autodesk.Revit.DB.ResultsBuilder Namespace