BarPointResults Properties

[image]

Structural Analysis and Code Checking API Reference Guide
BarPointResults Properties
BarPointResults Class See Also Send Feedback

The BarPointResults type exposes the following members.

Properties

 | Name | Description
Public property | SFx | S (Fx), axial stress
Public property | Smax | S max, maximum normal stress
Public property | SmaxMy | S max (My), maximum bending stress for moment My
Public property | SmaxMz | S max (Mz), maximum bending stress for moment Mz
Public property | Smin | S min, minimum normal stress
Public property | SminMy | S min (My), minimum bending stress for moment My
Public property | SminMz | S min (Mz), minimum bending stress for moment Mz
Public property | X | X defines the coordinate (distance from the bar's start point) where the results are specified.

See Also

BarPointResults Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace