SetModelWithHardening Method

Steel..::..SetModelWithHardening Method
Steel Class See Also Send Feedback
Sets all appropriate parameters for steel with inclined top branch (plastic with hardening).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetModelWithHardening(
    double designStrength,
    double strainUltimateLimit,
    double modulusOfElasticity,
    double hardeningFactor
)

Parameters

designStrength
Type: System..::..Double
The steel design strength.
Unit: [force per length^2].
strainUltimateLimit
Type: System..::..Double
The steel strain at failure.
Unit: [dimensionless].
modulusOfElasticity
Type: System..::..Double
The steel Modulus of elasticity (Young modulus).
Unit: [force per length^2]
hardeningFactor
Type: System..::..Double
Value of the hardening between strain equals to design strength divided by the modulus of elasticity and the ultimate limit of steel strain.
Unit: [dimensionless].

Remarks

The values should be in the base unit and it should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The steel design strength must be greater than 0.0.
System..::..ArgumentException | The steel strain at failure must be greater than 0.0.
System..::..ArgumentException | The steel Young modulus (modulus of elasticity) must greater than 0.0.
System..::..ArgumentException | The hardening factor for inclined top branch must be greater than 1.0 , for horizontal branch must be equal to 1.0
System..::..ArgumentException | The steel strain at failure can't be less than the design strength divided by the modulus of elasticity

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace