IsMaterialMetal Method

RebarUtility..::..IsMaterialMetal Method
RebarUtility Class See Also Send Feedback
Return true if the material Class of the specified material is metal

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool IsMaterialMetal(
    Document document,
    ElementId materialId
)

Parameters

document
Type: Document
Revit document
materialId
Type: ElementId
Material ElementId

Return Value

if the MaterialClass=="Metal"

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace