IFieldEditor Members

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldEditor Members
IFieldEditor Interface Methods Properties Events See Also Send Feedback

The IFieldEditor type exposes the following members.

Methods

 | Name | Description
Public method | GetUniqueId | Gets the unique id.
Public method | GetValue | Gets the value in specified display unit type.
Public method | SetAttribute(FieldUIAttribute) | Sets the attribute.
Public method | SetAttribute(String, Object, DisplayUnitType) | Sets spefified attribute.
Public method | SetDocument | Sets the Revit document.
Public method | SetName | Sets the name of control.
Public method | SetUnitType | Sets the type of the unit.
Public method | SetValue | Sets the value in specified display unit type.

Properties

 | Name | Description
Public property | BorderVisible | Gets or sets a value indicating whether border is visible.
Public property | FieldName | Gets or sets the name of the field.
Public property | IsEnabled | Gets or sets a value indicating whether this instance is enabled.

Events

 | Name | Description
Public event | ValueChanged | Occurs when value changed in the control.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace