Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace

Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace

Classes

 | Class | Description
Public class | LoadCombinationPreview | Represents load combination preview
Public class | LoadCombinationUtils | Helper class for Load Combination framework
Public class | RevitLoadCombination | Wraps Revit Load Combination
Public class | Server<(Of <(<'TData>)>)> | Base class for all load combination servers which are based on reflection scenario. It provides automization for most of functionality required by ILoadCombinationServer.
Public class | Service | Represents main load combination service
Public class | ServiceData | Represents data used for exchanging information between CCService and servers.

Interfaces

 | Interface | Description
Public interface | ILoadCombination | Common interface for load Combination visualization
Public interface | ILoadCombinationServer | The base interface for all Code Checking servers

Enumerations

 | Enumeration | Description
Public enumeration | LoadCombinationState | Load combination state
Public enumeration | LoadCombinationType | Load combination type

ILoadCombination Interface

ILoadCombination Interface
Members See Also Send Feedback
Common interface for load Combination visualization

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ILoadCombination

See Also

ILoadCombination Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace