TryParse Method

UnitUtilsExt..::..TryParse Method
UnitUtilsExt Class See Also Send Feedback
Parses a formatted string (including units) into a value if possible.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static bool TryParse(
    Units units,
    UnitType unitType,
    string stringToParse,
    string listSeparator,
    out List<double> values
)

Parameters

units
Type: Units
The units object.
unitType
Type: UnitType
Type of the unit.
stringToParse
Type: System..::..String
The string to parse.
listSeparator
Type: System..::..String
The list separator.
values
Type: System.Collections.Generic..::..List <(Of <(<' Double >)>)>%
The values.

Return Value

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace