SectionDimensions Members

[image]

Structural Analysis and Code Checking API Reference Guide
SectionDimensions Members
SectionDimensions Class Constructors Methods Properties See Also Send Feedback

The SectionDimensions type exposes the following members.

Constructors

 | Name | Description
Public method | SectionDimensions()()()() | Initializes a new instance of the SectionDimensions class.
Public method | SectionDimensions(SectionDimensions) | Initializes a new instance of the SectionDimensions class.

Methods

 | Name | Description
Public method | Clear | Sets to defaults.
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.

Properties

 | Name | Description
Public property | b | Gets or sets the full width of the section or the flange(the slab) width for a symmetrical section.
Public property | bf | Gets or sets the flange width.
Public property | bf1 | Gets or sets the flange width.
Public property | bf2 | Gets or sets the flange width.
Public property | h | Gets or sets the full depth of the section.
Public property | h1 | Gets or sets the dimension of a vertical cutout.
Public property | h2 | Gets or sets the dimension of a vertical cutout.
Public property | hw | Gets or sets the height of the web.
Public property | hw1 | Gets or sets the height of the main web.
Public property | hw2 | Gets or sets the height of the secondary web.
Public property | l1 | Gets or sets the dimension of a horizontal cutout.
Public property | l2 | Gets or sets the dimension of a horizontal cutout.
Public property | s | Gets or sets the separation.
Public property | t | Gets or sets the thickness of hollow sections.
Public property | tf | Gets or sets the flange thickness or for T-concret section the slab height .
Public property | tf1 | Gets or sets the flange thickness.
Public property | tf2 | Gets or sets the flange thickness.
Public property | tw | Gets or sets the web thickness.
Public property | tw1 | Gets or sets the main web thickness.
Public property | tw2 | Gets or sets the secondary web thickness.
Public property | vpy | Gets or sets the horizontal distance of the negative edge of section to center of gravity.
Public property | vpz | Gets or sets the vertical distance of the negative edge of section to center of gravity.
Public property | vy | Gets or sets the horizontal distance of the positive edge of section to center of gravity.
Public property | vz | Gets or sets the vertical distance of the positive edge of section to center of gravity.

See Also

SectionDimensions Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace