DefaultValueQueryEventArgs Constructor

DefaultValueQueryEventArgs Constructor
DefaultValueQueryEventArgs Class See Also Send Feedback
Initializes a new instance of the ValueChangedEventArgs class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DefaultValueQueryEventArgs(
    string fieldName,
    IFieldEditor fieldEditor,
    Document document,
    ISchemaEditor editor,
    DisplayUnitType expectedUnit
)

Parameters

fieldName
Type: System..::..String
Name of the field.
fieldEditor
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..IFieldEditor
The field editor.
document
Type: Document
The document.
editor
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework..::..ISchemaEditor
The editor.
expectedUnit
Type: DisplayUnitType
The expected unit.

See Also

DefaultValueQueryEventArgs Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace