Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace

Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace

Classes

 | Class | Description
Public class | CategoriesAttribute | Describes categories description. It should be placed as the attribute of whole class.
Public class | CategoryCheckBoxAttribute | Indicates that particular property will be connected with category header and will decide about the category enable state.
Public class | CheckBoxAttribute | Indicates that particular property will be edited with the CheckBox control.
Public class | CheckedListAttribute | Indicates that particular property will be edited with the CheckedList control. Limited to arrays only.
Public class | ComboBoxAttribute | Indicates that particular property will be edited with the ComboBox control. For simple data only.
Public class | ControlAttribute | Base class for all control attributes
Public class | CustomControlAttribute | Indicates that particular field should be edited with a custom control.
Public class | DataSourceFormatFieldAttribute | Base class for all data source based control attributes.
Public class | DefaultFieldControlAttribute | Indicates that particular property be edited with the control assigned in the default way by the system.
Public class | ElementCheckedListAttribute | Indicates that particular property will be edited with the ElementCheckedList control. Limited to arrays with ElementId instances.
Public class | ElementComboBoxAttribute | Indicates that particular property will be edited with ElementComboBox control. Limited to instances of ElementId type.
Public class | EnumControlAttribute | Indicates that particular property will be edited with EnumControl control.
Public class | FieldUIAttribute | Base class for all attribute classes used for describing visualization aspect of particular fields.
Public class | FormatFieldAttribute | Base class for all formatable controls attributes
Public class | GridCheckBoxAttribute | Indicates that particular property will be edited with grid control with checkboxes.
Public class | GridComboBoxAttribute | Indicates that particular property will be edited with ComboBox grid control.
Public class | GridCustomControlAttribute | Indicates that particular field should be edited with Custom grid control.
Public class | GridElementComboBoxAttribute | Indicates that particular property will be edited with Element ComboBox grid control.
Public class | GridEnumControlAttribute | Indicates that particular property will be edited with enum grid control.
Public class | GridIntNumericUpDownAttribute | Indicates that particular property will be edited with int NumericUpDown grid control.
Public class | GridKeyComboBoxAttribute | Indicates that particular key of the property will be edited with ComboBox grid control.
Public class | GridKeyTextBoxAttribute | Indicates that particular key of the field (only for maps) should be edited with TextBox grid control.
Public class | GridTextBoxAttribute | Indicates that particular property will be edited with TextBox grid control.
Public class | GridUnitNumericUpDownAttribute | Indicates that particular property will be edited with UnitNumericUpDown grid control.
Public class | GridUnitTextBoxAttribute | Indicates that particular property will be edited with UnitTextBox grid control.
Public class | GridXYZTextBoxAttribute | Indicates that particular property will be edited with TextBox grid control.
Public class | IntNumericUpDownAttribute | Indicates that particular property will be edited with IntNumericUpDown control.
Public class | ListTextBoxAttribute | Indicates that particular property will be edited with the ListTextBox control.
Public class | ListUnitTextBoxAttribute | Indicates that particular property will be edited with the ListUnitTextBox control.
Public class | NumericUpDownAttribute | Indicates that particular property will be edited with NumericUpDown control.
Public class | SubSchemaControlAttribute | Indicates that particular field should be edited with SubSchemaControl control.
Public class | SubSchemaDefaultAttribute | Indicates default attribute which will be used to visulize subSchema data when DefaultFieldControlAttribute will be set
Public class | SubSchemaEmbeddedControlAttribute | Indicates that particular field should be edited with SubSchemaControl embedded in layout.
Public class | SubSchemaListTableAttribute | Indicates that particular schema list will be presented as table.
Public class | TextBoxAttribute | Indicates that particular property will be edited with the TextBox control.
Public class | UnitCheckedListAttribute | Indicates that particular property will be edited with UnitCheckedList control.
Public class | UnitComboBoxAttribute | Indicates that particular property will be edited with UnitComboBox control.
Public class | UnitNumericUpDownAttribute | Indicates that particular property will be edited with UnitNumericUpDown control.
Public class | UnitTextBoxAttribute | Indicates that particular property will be edited with UnitTextBox control.
Public class | XYZTextBoxAttribute | Indicates that particular property will be edited with the XYZTextBox control.

Enumerations

 | Enumeration | Description
Public enumeration | PresentationItem | Represents option of item presentation
Public enumeration | PresentationMode | Represents option of enum presentation

CategoriesAttribute Class

CategoriesAttribute Class
Members See Also Send Feedback
Describes categories description. It should be placed as the attribute of whole class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CategoriesAttribute : ControlAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..CategoriesAttribute

See Also

CategoriesAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace