GridIntNumericUpDownAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridIntNumericUpDownAttribute Members
GridIntNumericUpDownAttribute Class Constructors Methods Properties See Also Send Feedback

The GridIntNumericUpDownAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridIntNumericUpDownAttribute()()()() | Initializes a new instance of the GridIntNumericUpDownAttribute class.
Public method | GridIntNumericUpDownAttribute(Int32, Int32, Int32) | Initializes a new instance of the GridIntNumericUpDownAttribute class.

Methods

 | Name | Description
Public method | GetDefaultValueProvider | Gets the instance of default value provider.

Properties

 | Name | Description
Public property | AllowToAddElements | Gets or sets a value indicating whether the user will be able to add elements.
Public property | AllowToRemoveElements | Gets or sets a value indicating whether the user will be able to remove elements.
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).

See Also

GridIntNumericUpDownAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace