SlabNode Members

[image]

Structural Analysis and Code Checking API Reference Guide
SlabNode Members
SlabNode Class Constructors Methods Properties See Also Send Feedback

The SlabNode type exposes the following members.

Constructors

 | Name | Description
Public method | SlabNode(SlabInfo) | Creates instance.
Public method | SlabNode(SlabInfo, XYZ) | Creates instance.

Methods

 | Name | Description
Public method | GetGlobalCoordinates | Returns cooridinates in global coordinates system.
Public method | IsPointNode | Compares current node with specific point.

Properties

 | Name | Description
Public property | Coordinates | Gets local coordinates.
Public property | ParentContours | Gets parent contours.
Public property | ParentEdges | Gets parent edges.

See Also

SlabNode Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace