ElementInfo Constructor

[image]

Structural Analysis and Code Checking API Reference Guide
ElementInfo Constructor
ElementInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementInfo(ElementSlabsInfo, MaterialInfo) | Creates instance for slab.
Public method | ElementInfo(ElementWallsInfo, MaterialInfo) | Creates instance for wall.
Public method | ElementInfo(ElementSectionsInfo, ElementSectionsParamsInfo, ElementSlabsInfo, MaterialInfo) | Creates instance for beam with T-Section.
Public method | ElementInfo(ElementType, ElementSectionsInfo, ElementSectionsParamsInfo, MaterialInfo) | Creates instance for beam or column.

See Also

ElementInfo Class
ElementInfo Members
Autodesk.Revit.DB.CodeChecking.Engineering Namespace