Geometry Constructor (Double, Double, Double, Double)

Geometry Constructor (Double, Double, Double, Double)
Geometry Class See Also Send Feedback
The class constructor for a T cross section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Geometry(
    double heightTotal,
    double heightFlange,
    double widthBottom,
    double widthTop
)

Parameters

heightTotal
Type: System..::..Double
The total height of the cross-section.
Unit: [length].
heightFlange
Type: System..::..Double
The height of the flange (flange thickness).
Unit: [length].
widthBottom
Type: System..::..Double
The width of the web (web thickness).
Unit: [length].
widthTop
Type: System..::..Double
The width of the flange (top of the section).
Unit: [length].

Remarks

The bottom left corner is in the center of coordinate system x=0, y=0 and the contour has a counterclockwise orientation.

See Also

Geometry Class
Geometry Overload
Autodesk.CodeChecking.Concrete Namespace