GetAttribute(TAttribute) Method (PropertyInfo)

Attribute..::..GetAttribute<(Of <(<'TAttribute>)>)> Method (PropertyInfo)
Attribute Class See Also Send Feedback
Gets the attribute of specific type assigned to the property.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static TAttribute GetAttribute<TAttribute>(
    PropertyInfo propertyInfo
)

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo
The property information.

Type Parameters

TAttribute
The type of the attribute.

Return Value

See Also

Attribute Class
GetAttribute Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace