GetEntity(TClass) Method ()

Storage<(Of <(<'T>)>)>..::..GetEntity<(Of <(<'TClass>)>)> Method ()
Storage<(Of <(<'T>)>)> Class See Also Send Feedback
Returns instance of T type filled with data from particular entity.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public TClass GetEntity<TClass>(
    Document document
)
where TClass : new(), SchemaClass

Parameters

document
Type: Document
The document.

Type Parameters

TClass
The type of the class.

Return Value

The instance of T type.

Remarks

The schema is taken from SchemaAttribute and the type should be derived from SchemaClass.

See Also

Storage<(Of <(<'T>)>)> Class
GetEntity Overload
Autodesk.Revit.DB.CodeChecking.Storage Namespace