GridKeyComboBoxAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
GridKeyComboBoxAttribute Members
GridKeyComboBoxAttribute Class Constructors Methods Properties See Also Send Feedback

The GridKeyComboBoxAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GridKeyComboBoxAttribute()()()() | Initializes a new instance of the GridKeyComboBoxAttribute class.
Public method | GridKeyComboBoxAttribute(String, Type) | Initializes a new instance of the GridKeyComboBoxAttribute class.
Public method | GridKeyComboBoxAttribute(Type, array<Object>[]()[][]) | Initializes a new instance of the GridKeyComboBoxAttribute class.

Methods

 | Name | Description
Public method | GetDefaultValueProvider | Gets the instance of default value provider.

Properties

 | Name | Description
Public property | AttributeUnit | Gets or sets the default value unit.
Public property | DefaultValue | Gets or sets the default value (when element is added to grid).
Public property | DefaultValueProvider | Gets or sets the object which provides default value. It has to implement IDefaultValueProvider interface
Public property | MapKey | Gets a value indicating whether this instance is for key (important only for maps).

See Also

GridKeyComboBoxAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace