GetContour Method

ElementTSectionInfo..::..GetContour Method
ElementTSectionInfo Class See Also Send Feedback
Gets contour of the joint section including flanges

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Section GetContour(
    double relativePosition,
    double flangeL,
    double flangeR
)

Parameters

relativePosition
Type: System..::..Double
relative position on the bar
flangeL
Type: System..::..Double
maximum code value for left flange length
flangeR
Type: System..::..Double
maximum code value for right flange length

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace