BuildDocument Method (Document, , String, DetailLevel)

TextBuilder..::..BuildDocument Method (Document, , String, DetailLevel)
TextBuilder Class See Also Send Feedback
Builds document.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public override string BuildDocument(
    Document document,
    Document revitDocument,
    string path,
    DetailLevel detailLevel
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document.
revitDocument
Type: Document
The Revit document.
path
Type: System..::..String
The path.
detailLevel
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
Detail level

Return Value

The file.

See Also

TextBuilder Class
BuildDocument Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace