ICodeCheckingServer Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ICodeCheckingServer Methods
ICodeCheckingServer Interface See Also Send Feedback

The ICodeCheckingServer type exposes the following members.

Methods

 | Name | Description
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one.
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one.
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one.
Public method | GetCalculationParamSchema | Returns schema for calculation parameters.
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity.
Public method | GetDefaultLabel | Returns default value of label entity.
Public method | GetLabelSchema | Returns schema for labels.
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package.
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.
Public method | GetResultsSchema | Returns schema for results.
Public method | GetSupportedCategories | Returns the list of supported categories.
Public method | GetSupportedMaterials | Returns the list of supported materials.
Public method | GetVersion | Gets the version of code checking server.
Public method | IsContextSupported | Determines whether specified context is supported.
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load cases and combinations, they will be exposed on the dialog.
Public method | ResultBuilderPackagesAsInputData | Determines whether Results Builder packages will be treated as input data.
Public method | Verify | Runs calculation.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace