RCSolver Members

[image]

Structural Analysis and Code Checking API Reference Guide
RCSolver Members
RCSolver Class Methods See Also Send Feedback

The RCSolver type exposes the following members.

Methods

 | Name | Description
 | CreateNewSolver | Creates a new solver according geometry and defaults parameters for the concrete and steel.
Public method | Dispose | Releases all resources used by the RCSolver
Public method | GetArea | Gets the value of the area.
Public method | GetCenterOfInertia | Gets the coordinates of center of inertia.
Public method | GetConcrete | Gets the copy of parameters describing concrete behavior.
Public method | GetConcreteStressArea | Gets area of the compressed part of the section.
Public method | GetGeometry | Gets the copy of cross-section geometry.
Public method | GetInternalForces | Gets the set of internal forces.
Public method | GetMomentFirstX | Gets the value of first moment of inertia.
Public method | GetMomentFirstY | Gets the value of first moment of inertia.
Public method | GetMomentOfInertiaX | Gets the value of moment of inertia.
Public method | GetMomentOfInertiaY | Gets the value of moment of inertia.
Public method | GetNeutralAxisAngle | Gets the angle between the neutral axis normal and the x-axis
Public method | GetNeutralAxisDistance | Gets the distance from the concrete section gravity center to neutral axis.
Public method | GetRebars | Gets the copy of set of reinforcement bars.
Public method | GetSteel | Gets the copy ofparameters describing steel behaviors.
Public method | GetStrain | Gets strain at a given point.
Public method | GetStrainMax | Gets maximum strain.
Public method | GetStrainMin | Gets minimum strain.
Public method | GetStress | Gets stress at a given point.
Public method | GetStressGravityCenter | Gets the coordinates center of inertia for stresses.
Public method | GetStressMax | Gets maximum strain.
Public method | GetStressMin | Gets minimum stress.
Public method | SetConcrete | Sets necessary parameters describing concrete behaviors.
Public method | SetGeometry | Sets the cross-section geometry.
Public method | SetRebars |
Public method | SetSteel | Sets necessary parameters describing reinforcement steel behaviors.
Public method | SolveForces(ResultType, Double, Double) | Calculates resistance forces according to acting strain
Public method | SolveForces(ResultType, Double, Double, Double) | Calculates forces according to acting strain
Public method | SolveResistance | Calculates resistance according to acting design forces
Public method | SolveResistanceF | Calculates resistance moment according to acting design moment
Public method | SolveResistanceM | Calculates resistance moment according to acting design axial forces.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace