GetBarNodeResults Method (ICollection(), ICollection(), ICollection(LinearResultType))

ResultsPackage..::..GetBarNodeResults Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'LinearResultType>)>)>)
ResultsPackage Class See Also Send Feedback
Returns node results for linear element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<BarNodeResult> GetBarNodeResults(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCasesOrCombinations,
    ICollection<LinearResultType> types
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCasesOrCombinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
types
Type: System.Collections.Generic..::..ICollection <(Of <(<' LinearResultType >)>)>

See Also

ResultsPackage Class
GetBarNodeResults Overload
Autodesk.Revit.DB.ResultsBuilder Namespace