GetDataSource Method

Server<(Of <(<'TData>)>)>..::..GetDataSource Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Gets the data source of the specific key.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual IList GetDataSource(
    string key,
    Document document,
    DisplayUnitType unitType
)

Parameters

key
Type: System..::..String
The key of data source.
document
Type: Document
The document.
unitType
Type: DisplayUnitType

Return Value

The data source of list type.

Implements

IServerUI..::..GetDataSource(String, Document, DisplayUnitType)

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace