SchemaClass Class

SchemaClass Class
Members Example See Also Send Feedback
Represents the class which is a base class for all classes which definition is used to built Revit schemas.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SchemaClass : ICloneable

Examples

CopyC#
[Schema("schema","1E578722-BFF5-4496-B436-CB6C659D93DF","F6F790AF-1762-441D-9AFF-9C822D346E5F")]
public class Class1:SchemaClass
{
   public double ValueNotForSchema { get; set; }

   [SchemaProperty(FieldName = "A",Unit = UnitType.UT_Length, DisplayUnit = DisplayUnitType.DUT_METERS)]
   public double ValueForSchema { get; set; }
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatus
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusList
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusMessage
Autodesk.Revit.DB.CodeChecking.Storage..::..ResultStatusMessageItem
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerData
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerPackage
Autodesk.Revit.DB.CodeChecking.Storage..::..ServerStorage
Autodesk.Revit.DB.CodeChecking.Storage..::..Storage<(Of <(<'T>)>)>

See Also

SchemaClass Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace