GetAttributes(TAttribute) Method (Type)

Attribute..::..GetAttributes<(Of <(<'TAttribute>)>)> Method (Type)
Attribute Class See Also Send Feedback
Gets the list of attributes of specific type assigned to the input type.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<TAttribute> GetAttributes<TAttribute>(
    Type type
)

Parameters

type
Type: System..::..Type
The type which should have the attribute.

Type Parameters

TAttribute
The type of the attribute.

Return Value

See Also

Attribute Class
GetAttributes Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace