BuildDocument Method (Document, , String, DetailLevel)

DocumentBuilder..::..BuildDocument Method (Document, , String, DetailLevel)
DocumentBuilder Class See Also Send Feedback
Virtual methods building document. This method is overriden by document builders.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract string BuildDocument(
    Document document,
    Document revitDocument,
    string path,
    DetailLevel detailLevel
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document.
revitDocument
Type: Document
The Revit document.
path
Type: System..::..String
The path.
detailLevel
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
The detail level.

Return Value

The path to document.

See Also

DocumentBuilder Class
BuildDocument Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace