EnumControlAttribute Constructor (Type, PresentationMode, PresentationItem)

EnumControlAttribute Constructor (Type, PresentationMode, PresentationItem)
EnumControlAttribute Class See Also Send Feedback
Initializes a new instance of the EnumControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public EnumControlAttribute(
    Type enumType,
    PresentationMode presentationMode,
    PresentationItem presentationItem
)

Parameters

enumType
Type: System..::..Type
Type of the enum.
presentationMode
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationMode
The presentation mode.
presentationItem
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationItem
The presentation item.

See Also

EnumControlAttribute Class
EnumControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace