DataStructureAttribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DataStructureAttribute Methods
DataStructureAttribute Class See Also Send Feedback

The DataStructureAttribute type exposes the following members.

Methods

 | Name | Description
 | GetDataStructure(Type, Type, Guid) | Gets the data structure type based on attributes assigned to source type.
 | GetDataStructure(Type, Type, BuiltInCategory, StructuralAssetClass) | Gets the data structure type based on attributes assigned to source type.

See Also

DataStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace