ForceResultsCache Constructor (, ICollection(ForceCalculationDataDescriptor), ICollection(ForceResultsPackageDescriptor), ICollection(), )

ForceResultsCache Constructor (, ICollection<(Of <(<'ForceCalculationDataDescriptor>)>)>, ICollection<(Of <(<'ForceResultsPackageDescriptor>)>)>, ICollection<(Of <(<'>)>)>, )
ForceResultsCache Class See Also Send Feedback
Creates ForceResultsCache

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceResultsCache(
    Document document,
    ICollection<ForceCalculationDataDescriptor> elementIDs,
    ICollection<ForceResultsPackageDescriptor> resultPackDescriptors,
    ICollection<ElementId> loads,
    DisplayUnit unitSystem
)

Parameters

document
Type: Document
Revit document
elementIDs
Type: System.Collections.Generic..::..ICollection <(Of <(<' ForceCalculationDataDescriptor >)>)>
Collection of ID's for revit elements for which internal forces will be querried
resultPackDescriptors
Type: System.Collections.Generic..::..ICollection <(Of <(<' ForceResultsPackageDescriptor >)>)>
Collection of descriptors for result packages from which results will be imported. If null , all available packages will be used
loads
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
Collection of loads corresponding to the internal forces
unitSystem
Type: DisplayUnit
Unit system

See Also

ForceResultsCache Class
ForceResultsCache Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace