OnServersDisparity Method

Service..::..OnServersDisparity Method
Service Class See Also Send Feedback
Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DisparityResponse OnServersDisparity(
    Document document,
    IList<Guid> oldServers
)

Parameters

document
Type: Document
The coresponding document
oldServers
Type: System.Collections.Generic..::..IList <(Of <(<' Guid >)>)>
Ids of servers previously used in the document. Please note that the Ids may belong to servers that are currently not registered with the service.

Return Value

Return False if you want the framework to handle the situation; return True if the situation has already been handled.

Implements

IExternalServiceOnServersDisparity(Document, IList<(Of <<'(Guid>)>>))

See Also

Service Class
Autodesk.Revit.DB.CodeChecking Namespace