SolveResistance Method

RCSolver..::..SolveResistance Method
RCSolver Class See Also Send Feedback
Calculates resistance according to acting design forces

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SolveResistance(
    double designAxialForce,
    double designMomentX,
    double designMomentY
)

Parameters

designAxialForce
Type: System..::..Double
The acting design axial force.
Unit: [force].
designMomentX
Type: System..::..Double
The acting design moment around x-axis.
Unit: [force*length].
designMomentY
Type: System..::..Double
The acting design moment around y-axis.
Unit: [force*length]

Remarks

The forces are described in the coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
designAxialForce - Axial force. The compresion have positive sign.
designMomentX - The bending moment around x'-axis.
designMomentY - The bending moment around y'-axis.
The resistance forces could be read by GetInternalForces method.
The resistance force has the same eccentricities than acting forces.
Other information about state of failure could be read using dedicated methods.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Internal error in the SolveResistance method

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace