GetSurfaceNodeResults Method (ICollection(), ICollection(), ICollection(SurfaceResultType), UnitsSystem)

ResultsPackage..::..GetSurfaceNodeResults Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'SurfaceResultType>)>)>, UnitsSystem)
ResultsPackage Class See Also Send Feedback
Returns surface node results for element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceNodeResult> GetSurfaceNodeResults(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCasesOrCombinations,
    ICollection<SurfaceResultType> types,
    UnitsSystem unitsSystem
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCasesOrCombinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
types
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfaceResultType >)>)>
unitsSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

See Also

ResultsPackage Class
GetSurfaceNodeResults Overload
Autodesk.Revit.DB.ResultsBuilder Namespace