CreateLoadCombinations Method (String, List(), List(Double[]))

LoadCombinationUtils..::..CreateLoadCombinations Method (String, List<(Of <(<'>)>)>, List<(Of <(<'array<Double>[]()[][]>)>)>)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCombinationPreview> CreateLoadCombinations(
    string baseName,
    List<LoadCaseArray> loadCasesSets,
    List<double[]> factors
)

Parameters

baseName
Type: System..::..String
Base name.
loadCasesSets
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The list of load cases.
factors
Type: System.Collections.Generic..::..List <(Of <(<'array< Double >[]()[][]>)>)>
The factors.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinations Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace