ResultComposer Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultComposer Members
ResultComposer Class Constructors Methods Fields See Also Send Feedback

The ResultComposer type exposes the following members.

Constructors

 | Name | Description
Public method | ResultComposer | Initializes a new instance of the ResultComposer class

Methods

 | Name | Description
Public method | AddCalculationParametersSection | Adds the calculation parameters section.
Public method | AddElementSection | Adds the element section.
Public method | AddElementsSection | Adds the elements section.
Public method | AddFamiliesSection | Adds the families section.
Public method | AddFamily | Adds the family.
Public method | AddHeader | Adds the header.
Public method | AddLabel | Adds the label.
Public method | AddLabelsSection | Adds the labels section.
Public method | AddMaterial | Adds the material.
Public method | AddMaterialsSection | Adds the materials section.
Public method | AddRebarCover | Adds the rebar cover.
Public method | BuildDocument | Builds the document.
Public method | FillElementRegularParameters | Fills the element regular parameters.
Public method | FillElementServerResults | Fills the element section with server results.
Public method | GetCalculationParams | Gets the calculation params.
Public method | GetFamiliesSection | Gets the families section.
Public method | GetFamilySection | Gets the family section.
Public method | GetLabelSection(String) | Gets the label section.
Public method | GetLabelSection(String, String) | Gets the label section.
Public method | GetLabelsSection | Gets the labels section.
Public method | GetMaterialSection | Gets the material section.
Public method | GetMaterialsSection | Gets the materials section.
 | GetResultStatus | Gets the result status of element.
Public method | GroupLabels | Groups labels.
Public method | SortAndGroupElements(DocumentBody, List<(Of <<'(GroupMethod>)>>), SortMethod) | Sorts and group elements.
Public method | SortAndGroupElements(DocumentSection, List<(Of <<'(GroupMethod>)>>), SortMethod) | Sorts and group elements.

Fields

Name | Description
ElementServerResultSetData | Element server data key
ElementStatusData | Element Status data key
ElementUpToDateData | UpToDate data key
GroupData | Group data key
LabelData | Label data kye
ServerIdData | Server id key

See Also

ResultComposer Class
Autodesk.Revit.DB.CodeChecking.Documentation Namespace