IFieldToPropertyConverter Interface

IFieldToPropertyConverter Interface
Members Example See Also Send Feedback
Describes conversion between the field in the entity and property in the class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface IFieldToPropertyConverter

Examples

The example shows the converter which provides converstion between List<int> and DateTime (which is not supported by Extensible Storage)
CopyC#
 public class DateTimeConverter : IFieldToPropertyConverter
 {
     public object ConvertEntityFieldValToPropertyVal(object entityFieldValue)
     {
         IList<int> loaded = entityFieldValue as IList<int>;
         return new DateTime(loaded[0], loaded[1], loaded[2]);
     }

     public object ConvertPropertyValToEntityFieldVal(object propertyValue)
     {
         DateTime dt = (DateTime)propertyValue;
         return new List<int>() { dt.Year, dt.Month, dt.Day };
     }
}

See Also

IFieldToPropertyConverter Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace