GetStressGravityCenter Method

RCSolver..::..GetStressGravityCenter Method
RCSolver Class See Also Send Feedback
Gets the coordinates center of inertia for stresses.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Point2D GetStressGravityCenter(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of stresses could be taken into account: for rebar, concrete or equivalent section (transformed).

Return Value

Returns the center of inertia point for stresses as aPoint2D.

Return Value

Returns the center of inertia point as Point2D.

Exceptions

Exception | Condition
 | Calculation were not performed

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace