Geometry Constructor (Double)

Geometry Constructor (Double)
Geometry Class See Also Send Feedback
The class constructor for a circular cross section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Geometry(
    double diameter
)

Parameters

diameter
Type: System..::..Double
The diameter of the circle.
Unit: [length].

Remarks

Internal representation of the circular cross-section is regular a 18-gon (octadecagon).
The area of the polygon is equal to circle (Pi()*diameter^2)/4.
The center of the circle is in the center of coordinate system x=0, y=0 and the contour has a counterclockwise orientation.

See Also

Geometry Class
Geometry Overload
Autodesk.CodeChecking.Concrete Namespace