SlabEdge Members

[image]

Structural Analysis and Code Checking API Reference Guide
SlabEdge Members
SlabEdge Class Constructors Methods Properties See Also Send Feedback

The SlabEdge type exposes the following members.

Constructors

 | Name | Description
Public method | SlabEdge(SlabContour) | Constructs object.
Public method | SlabEdge(SlabInfo) | Constructs object.
Public method | SlabEdge(SlabContour, List<(Of <<'(SlabNode>)>>)) | Constructs object.
Public method | SlabEdge(SlabContour, SlabNode, SlabNode) | Constructs object.

Methods

 | Name | Description
Public method | ArePointsLikeNodes | Checks if points from the list has the same coordinates as current edge.
Public method | GetCenter | Returns center of edge.
Public method | GetDistanceFromPoint | Returns distance to specific point.
Public method | IsLineCrossingThis | Checks if line is crossing current edge.
Public method | IsPointOnEdge | Checks if specific point is on edge.

Properties

 | Name | Description
Public property | NodeEnd | Gets end node.
Public property | Nodes | Gets nodes.
Public property | NodeStart | Gets start node.
Public property | ParentContour | Gets parent contour.

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace