FieldUIAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
FieldUIAttribute Members
FieldUIAttribute Class Constructors Methods Fields Properties See Also Send Feedback

The FieldUIAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | FieldUIAttribute | Initializes the instance of FieldUIAttribute

Methods

 | Name | Description
 | GetFieldUIAttribute | Returns the UI attribute for specific field searched among input types.
Public method | GetFieldValueChanged | Gets the field value changed observer.
Public method | SetProperties | Sets the properties based on other attribute.
Public method | Validate | Validates the specified name.

Fields

Name | Description
PropertyIsEnabled | Describes attribute indicating if the field is enabled.
PropertyIsVisible | Describes attribute indicating if the field is visible.

Properties

 | Name | Description
Public property | Category | Allows to group properties in one container (e.g. Expander). If not set Other category will be chosen. Supports localizable flag.
Public property | Context | Additional information used for instance by IResource interface to help user identify the field.
Public property | Description | The description of the field. If null the name from the schema will be taken. Supports localizable flag.
Public property | IsEnabled | Indicates if the field is enabled.
Public property | IsVisible | Indicates if the field is visible.
Public property | SetDescription |
Public property | Tooltip | Gets or sets the tooltip.
Public property | ValueChangedObserver | Gets or sets the value changed observer.

See Also

FieldUIAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace