GetRBElementId Method

ForceResultsUtils..::..GetRBElementId Method
ForceResultsUtils Class See Also Send Feedback
Converts ElementId to RB format ElementId

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static ElementId GetRBElementId(
    this ElementId externalElementId,
    Document doc
)

Parameters

externalElementId
Type: ElementId
ElementId to be converted
doc
Type: Document
Revit document

Return Value

RB format ElementId

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ElementId. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

ForceResultsUtils Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace