NotificationService Members

[image]

Structural Analysis and Code Checking API Reference Guide
NotificationService Members
NotificationService Class Methods Events See Also Send Feedback

The NotificationService type exposes the following members.

Methods

Name | Description
AddError | Adds the error.
AddInfo | Adds the info.
AddSynchronizationInfo | Adds the information about synchronization.
AddWarning | Adds the warning.
EndSession | Ends the current session.
GetNotifications()()()() | Gets the list of notifications in current session.
GetNotifications(Guid) | Gets the list of notifications in session.
ProgressAllCodes | Progresses all codes.
ProgressBreak | Break current action requirement.
ProgressBreakInvoked | Informs if there was progress break requirment invoked.
ProgressEnd | Informs that progress has ended.
ProgressNotification | Informs that there was made additional step in current progress.
ProgressStart | Informs that progress of some action has started.
ProgressStatus | Informs that there was made additional step in current progress.
ProgressStep | Informs that there was made additional step in current progress.
ProgressTitle | Informs that there was made additional step in current progress.
StartNewSession()()()() | Starts the new session.
StartNewSession(Guid) | Starts the new session.

Events

Name | Description
NotificationAdded | Occurs when notification was added.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace