Geometry Class

Geometry Class
Members See Also Send Feedback
Represents the class for a concrete cross-section geometry definition.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class Geometry : IRCSolverMember, IEnumerable,
    IDisposable

Remarks

Including the description of the geometrical contour (section shape) and properties.
The geometrical contour is based on points in a 2D space (Point2D).
Contour must be defined in the same coordinate system as rebars.

Inheritance Hierarchy

System..::..Object
IRCSolverMember
Autodesk.CodeChecking.Concrete..::..Geometry

See Also

Geometry Members
Autodesk.CodeChecking.Concrete Namespace