CreateResultsPackage Method (Guid, String, UnitsSystem)

ResultsAccess..::..CreateResultsPackage Method (Guid, String, UnitsSystem)
ResultsAccess Class See Also Send Feedback
Create new instance of ResultsPackageBuilder.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[ObsoleteAttribute("Use CreateResultsPackage with extended parameter list")]
public ResultsPackageBuilder CreateResultsPackage(
    Guid value,
    string name,
    UnitsSystem unitSystem
)

Parameters

value
Type: System..::..Guid
name
Type: System..::..String
unitSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

Remarks

Both name and schemaGuid of the package must be unique in the document.

Exceptions

Exception | Condition
ArgumentException | Package name already exists.
ArgumentException | Package schemaGuid already exists.

See Also

ResultsAccess Class
CreateResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace