MultiStructureServer Class

MultiStructureServer Class
Members See Also Send Feedback
The base class for all servers that support more than one category or material.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class MultiStructureServer : MultiStructureServer,
    ICodeCheckingServerDocumentation, IResource

Remarks

It is strongly connected with DataStructurAttributes:ResultStructureAttribute, LabelStructureAttribute, CalculationParamsStructureAttribute

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..MultiStructureServer
Autodesk.Revit.DB.CodeChecking.Documentation..::..MultiStructureServer

See Also

MultiStructureServer Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace