Add Method

Geometry..::..Add Method
Geometry Class See Also Send Feedback
Adds a new point into the concrete cross section contour collection of points.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void Add(
    double x,
    double y
)

Parameters

x
Type: System..::..Double
The x-coordinate of the contour point Point2D.
Unit: [length].
y
Type: System..::..Double
The y-coordinate of the contour point Point2D.
Unit: [length].

Remarks

Points should be described in base units for example [m] or [in] and in the same coordinate system as rebars.

See Also

Geometry Class
Autodesk.CodeChecking.Concrete Namespace