UnitUtilsExt Methods

[image]

Structural Analysis and Code Checking API Reference Guide
UnitUtilsExt Methods
UnitUtilsExt Class See Also Send Feedback

The UnitUtilsExt type exposes the following members.

Methods

Name | Description
Convert | Converts a list of values from one unit type to another, such as square feet to square meters.
ConvertFromInternalUnits | Converts a value from Revit's internal unit type.
ConvertToInternalUnits | Converts a value to Revit's internal unit type.
FormatValueToString | Formats a value into a string based on formatting options.
GetDisplayUnitType | Gets the display type of the unit.
GetFormatOptions | Gets the format options.
GetUnitSymbol | Gets the unit symbol.
TryParse | Parses a formatted string (including units) into a value if possible.

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace