GetConcreteStressArea Method

RCSolver..::..GetConcreteStressArea Method
RCSolver Class See Also Send Feedback
Gets area of the compressed part of the section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetConcreteStressArea()

Return Value

Returns area of concrete in compression.
Unit: [length*length].

Remarks

Section returned is reduced by holes due to the reinforcement in compression. Unit depends to the units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Calculation are not performed

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace