Server(TData) Class

Server<(Of <(<'TData>)>)> Class
Members See Also Send Feedback
Base class for all load combination servers which are based on reflection scenario. It provides automization for most of functionality required by ILoadCombinationServer.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Server<TData> : ILoadCombinationServer,
    IExternalServer
where TData : new(), SchemaClass

Type Parameters

TData
The type of the data.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.LoadCombination..::..Server<(Of <(<'TData>)>)>

See Also

Server<(Of <(<'TData>)>)> Members
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace