Storage(T) Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Storage<(Of <(<'T>)>)> Methods
Storage<(Of <(<'T>)>)> Class See Also Send Feedback

The Storage<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetEntites | Gets entites.
Public method | GetEntity(Guid) | Returns entity of particular schema.
Public method | GetEntity<(Of <<'(TClass>)>>)(Document) | Returns instance of T type filled with data from particular entity.
Public method | GetServerStorageSchemaBased |
Public method | GetServerStorageServerBased |
Public method | Replace(Entity) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | Replace(Entity, Entity) | Replaces the old entity with newest one.
Public method | SetEntity(Entity, Guid) | Sets entity (if entity of the same schema id exist it will be replaced).
Public method | SetEntity(SchemaClass, Guid) | Sets the entity.
Public method | SetServerStorage | Adds the server data to storage.

See Also

Storage<(Of <(<'T>)>)> Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace