Autodesk.Revit.DB.CodeChecking Namespace

Autodesk.Revit.DB.CodeChecking Namespace

Classes

 | Class | Description
Public class | Error | Represents error notification
Public class | Info | Represents information notification
Public class | MultiStructureServer | The base class for all servers that support more than one category or material.
Public class | Notification | Represents the base class for all notifications
Public class | NotificationService | The center via which it is possible to register notifications
Public class | ProgressBreak | Represents progress break requirement
Public class | ProgressBreakException | The exception used for breaking current action
Public class | ProgressEnd | Informs about end of current action
Public class | ProgressNotification | Base class for all progress notifications
Public class | ProgressStart | Informs about progress start.
Public class | ProgressStatus | Informs about progress status.
Public class | ProgressStatusAllCodes | Informs about all codes.
Public class | ProgressStatusCode | Informs about progress status.
Public class | ProgressStatusCodeSummary | Informs about progress status.
Public class | ProgressStep | Informs about progress next step.
Public class | Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> | Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform. It is dedicated for servers which provides one description for labels and results.
Public class | ServerException | Represents server exception
Public class | Service | Represents the main service in the Code Checking Platform. It manages all Code Checking servers.
Public class | ServiceData | Represents data used for exchanging information between Service and servers.
Public class | Tools | Helper class for common operations
Public class | Warning | Represents warning notification

Interfaces

 | Interface | Description
Public interface | ICodeCheckingServer | The base interface for all Code Checking servers

Delegates

 | Delegate | Description
Public delegate | NotificationAddedHandler | The delagate for notifying about new notification in the system.

Enumerations

 | Enumeration | Description
Public enumeration | ExecutionContext | Describes execution context of CodeChecking platform.
Public enumeration | NotificationLevel | Represents the level of notification

Error Class

Error Class
Members See Also Send Feedback
Represents error notification

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Error : Notification

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Notification
Autodesk.Revit.DB.CodeChecking..::..Error

See Also

Error Members
Autodesk.Revit.DB.CodeChecking Namespace