GetSupportedCategories Method

ICodeCheckingServer..::..GetSupportedCategories Method
ICodeCheckingServer Interface See Also Send Feedback
Returns the list of supported categories.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
IList<BuiltInCategory> GetSupportedCategories(
    StructuralAssetClass material
)

Parameters

material
Type: StructuralAssetClass

Return Value

List of categories.

See Also

ICodeCheckingServer Interface
Autodesk.Revit.DB.CodeChecking Namespace