LabelsManager Members

[image]

Structural Analysis and Code Checking API Reference Guide
LabelsManager Members
LabelsManager Class Constructors Methods Properties See Also Send Feedback

The LabelsManager type exposes the following members.

Constructors

 | Name | Description
Public method | LabelsManager | Initializes a new instance of the LabelsManager class.

Methods

 | Name | Description
Public method | CreateNewLabel | Creates the new label.
Public method | DeleteLabel | Deletes the label.
Public method | GetCategories |
Public method | GetCategoryOfSelection |
Public method | GetDefaultEntity |
Public method | GetDefaultLabel |
Public method | GetElementsOfLabel | Gets elements from input list with specific label assigned.
Public method | GetLabel(Element) | Returns label set to particular element.
Public method | GetLabel(Guid) | Returns label set to particular element.
Public method | GetLabel(String) | Returns label set to particular element.
Public method | GetLabels |
Public method | GetMaterial |
Public method | GetMaterials |
Public method | GetUniqueLabelName | Gets the unique name for label.
Public method | IsActive |
Public method | OnSynchronized | (Overrides StorageManagerOnSynchronized(DocumentSynchronizedWithCentralEventArgs).)
Public method | RenameLabel | Renames the label.
Public method | SetLabel | Sets label to particular element.
Public method | ValidateLabel | Validates the label and changes it to null if material doesn't fit.

Properties

 | Name | Description
Public property | Labels | Returns the list of labels.

See Also

LabelsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace