LinearResultType Enumeration

LinearResultType Enumeration
See Also Send Feedback
Defines a standard types of analytical results for linear elements like beams and columns.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum LinearResultType

Members

Member name | Value | Description
Unknown | 0 | Unknown linear result type
Mx | 1001 | Mx
My | 1002 | My
Mz | 1003 | Mz
Fx | 1004 | Fx
Fy | 1005 | Fy
Fz | 1006 | Fz
Ux | 1007 | Ux
Uy | 1008 | Uy
Uz | 1009 | Uz
Rx | 1010 | Rx
Ry | 1011 | Ry
Rz | 1012 | Rz
Ky | 1013 | Ky reaction, derivative result
Kz | 1014 | Kz reaction, derivative result
Smax | 1015 | S max, maximum normal stress
Smin | 1016 | S min, minimum normal stress
SmaxMy | 1017 | S max (My), maximum bending stress for moment My
SmaxMz | 1018 | S max (Mz), maximum bending stress for moment Mz
SminMy | 1019 | S min (My), minimum bending stress for moment My
SminMz | 1020 | S min (Mz), minimum bending stress for moment Mz
SFx | 1021 | S (Fx), axial stress
ShearY | 1022 | Shear Y, shear stress (Y-axis), derivative result
ShearZ | 1023 | Shear Z, shear stress (Z-axis), derivative result
AsTop | 1024 | Top required reinforcement
AsBottom | 1025 | Bottom required reinforcement
AsLeft | 1026 | Left required reinforcement
AsRight | 1027 | Right required reinforcement
ReactionMx | 1028 | Reaction Mx
ReactionMy | 1029 | Reaction My
ReactionMz | 1030 | Reaction Mz
ReactionFx | 1031 | Reaction Fx
ReactionFy | 1032 | Reaction Fy
ReactionFz | 1033 | Reaction Fz
GetForceType |  | Converts ResultBuilter LinearResultType into ForceType

See Also

Autodesk.Revit.DB.ResultsBuilder Namespace