Layer Constructor (, Double, Double, Boolean, )

Layer Constructor (, Double, Double, Boolean, )
Layer Class See Also Send Feedback
Constructs object.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public Layer(
    ElementId materialId,
    double thickness,
    double offset,
    bool structure,
    MaterialFunctionAssignment function
)

Parameters

materialId
Type: ElementId
thickness
Type: System..::..Double
offset
Type: System..::..Double
structure
Type: System..::..Boolean
function
Type: MaterialFunctionAssignment

See Also

Layer Class
Layer Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace