Server(TCalculationParam, TLabel, TResult) Class

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Members See Also Send Feedback
Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform.

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Server<TCalculationParam, TLabel, TResult> : Server<TCalculationParam, TLabel, TResult>,
    ICodeCheckingServerDocumentation, IResource
where TCalculationParam : new(), SchemaClass
where TLabel : new(), SchemaClass
where TResult : new(), SchemaClass

Type Parameters

TCalculationParam
The class representing calculation parameters.
TLabel
The class representing labels.
TResult
The class representing results.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking..::..Server <(Of <(<'TCalculationParam, TLabel, TResult>)>)>
Autodesk.Revit.DB.CodeChecking.Documentation..::..Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)>

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace