SlabEdge Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SlabEdge Methods
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Methods

 | Name | Description
Public method | ArePointsLikeNodes | Checks if points from the list has the same coordinates as current edge.
Public method | GetCenter | Returns center of edge.
Public method | GetDistanceFromPoint | Returns distance to specific point.
Public method | IsLineCrossingThis | Checks if line is crossing current edge.
Public method | IsPointOnEdge | Checks if specific point is on edge.

See Also

SlabEdge Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace