ResultsAccess Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsAccess Methods
ResultsAccess Class See Also Send Feedback

The ResultsAccess type exposes the following members.

Methods

 | Name | Description
 | CreateResultsAccess | Creates ResultsAccess object connected to the Revit document
Public method | CreateResultsPackage(ResultsPackageDescriptor) | Creates the results package from descriptor.
Public method | CreateResultsPackage(Guid, String, UnitsSystem) | Obsolete. Create new instance of ResultsPackageBuilder.
Public method | CreateResultsPackage(Guid, String, UnitsSystem, ResultsPackageTypes) | Create new instance of ResultsPackageBuilder.
Public method | CreateResultsPackage(Guid, String, UnitsSystem, ResultsPackageTypes, String) | Create new instance of ResultsPackageBuilder. Package created by this function will be password protected. Updates of this package will require this password
Public method | DeleteResultsPackage(Guid) | Deletes results packages of given guid from the document
Public method | DeleteResultsPackage(String) | Obsolete. Deletes results packages of given Name from the document
 | GetDocument | Gets the document.
 | GetDocumentUniqueId(Document) | Gets the unique document id.
 | GetDocumentUniqueId(Int32) | Gets the unique document id.
Public method | GetResultsPackage(Guid) | Returns packages of given guid or null if not exists.
Public method | GetResultsPackage(String) | Returns packages of given name or null if not exists.
Public method | UpdateResultsPackage(Guid) | Obsolete. Update existing results package.
Public method | UpdateResultsPackage(Guid, String) | Update existing results package.

See Also

ResultsAccess Class
Autodesk.Revit.DB.ResultsBuilder Namespace