CustomControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
CustomControlAttribute Members
CustomControlAttribute Class Constructors Methods Properties See Also Send Feedback

The CustomControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CustomControlAttribute()()()() | Initializes a new instance of the CustomControlAttribute class.
Public method | CustomControlAttribute(Type, Boolean) | Initializes a new instance of the CustomControlAttribute class.

Methods

 | Name | Description
Public method | GetControlInstance | Returns custom editor of the field.

Properties

 | Name | Description
Public property | Control | The editor of the field.
Public property | Span | Gets or sets a value indicating whether this CustomControlAttribute control should be extended for all columns of the grid.

See Also

CustomControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace