Shape Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Shape Methods
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Methods

 | Name | Description
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetTurnedPointsList | Gets list of points for this shape turned by an angle.
Public method | IsContourInside | Check if a contour is inside this shape.
Public method | IsPointInside | Check if a point is inside this shape.

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace