RebarUtility Methods

[image]

Structural Analysis and Code Checking API Reference Guide
RebarUtility Methods
RebarUtility Class See Also Send Feedback

The RebarUtility type exposes the following members.

Methods

 | Name | Description
 | GetListMaterialOfRebars | Return the list of material ElementId assigned to rebar present in a Revit document
 | GetListRebarForMaterial | Return the list of rebar with a specific material assigned
 | GetMaterialStructuralAsset(Material) | Return the StructuralAsset of a specific material
 | GetMaterialStructuralAsset(Document, ElementId) | Return the StructuralAsset of a specific material based on his ElementId
 | GetRebarType | Return the RebarType of a specific rebar based on his ElementId
 | IsMaterialMetal | Return true if the material Class of the specified material is metal

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace