SolveResistanceF Method

RCSolver..::..SolveResistanceF Method
RCSolver Class See Also Send Feedback
Calculates resistance moment according to acting design moment

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SolveResistanceF(
    double actingMoment,
    Axis axis,
    bool resultAsPositive
)

Parameters

actingMoment
Type: System..::..Double
The acting moment.
Unit: [force*length].
axis
Type: Autodesk.CodeChecking.Concrete..::..Axis
Determinates which beanding moment is acting around x-axis or y-axis.
resultAsPositive
Type: System..::..Boolean
Determinates singn of result. Resistance axial force should be calculate as negative or positive.

Remarks

The design forces are described in the coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
resistanceMoment - The bending moment. The axis around moment was calculated is determined by BendingMomentDefinition.
The resistance moment is the same as acting moment, the moment on the second direction is equal 0.0.
The resistance forces could be read by GetInternalForces method.
Other information about state of failure could be read using dedicated methods.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Internal error in the SolveResistanceF method

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace