Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace

Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace

Classes

 | Class | Description
Public class | Attribute | Helper class for attributes management
Public class | DefaultFieldFormat | Provides default formating and parsing based on .NET mechanism.
Public class | DispatcherInstance | Represents dispatcher object
Public class | ElementFieldFormat | Provides formatting for Revit elements.
Public class | IntFieldFormat | Provides formating for integer numbers.
Public class | ListFieldFormat | Provides formatting for lists.
Public class | ListUnitFieldFormat | Provides formating for lists with unit dependent items.
Public class | SchemaClass | Represents the class which is a base class for all classes which definition is used to built Revit schemas.
Public class | Settings | Represents setting
Public class | UnitFieldFormat | Provides formatting for fields with unit dependent items.
Public class | UnitUtilsExt | This class provides tools for units conversion.
Public class | XYZFieldFormat | Provides formatting for XYZ structure.

Interfaces

 | Interface | Description
Public interface | IFieldFormat | Base interface for format classes.
Public interface | IFieldToPropertyConverter | Describes conversion between the field in the entity and property in the class.
Public interface | IResource | Base interface for all resource providers.

Attribute Class

Attribute Class
Members See Also Send Feedback
Helper class for attributes management

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static class Attribute

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..Attribute

See Also

Attribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace