Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace

Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace

Classes

 | Class | Description
Public class | ElementAnalyser | Analyser of Revit element.
Public class | ForceResultsCache | Represents a collection of internal forces for a given group of elements and loads
Public class | ForceResultsUtils | Utility class for basic operations related to results in ResultBuilder
Public class | ForceResultsWriter | Class used for saving results in Revit

Enumerations

 | Enumeration | Description
Public enumeration | ForceResultsCache..::..ElementResultsStatus |

ElementAnalyser Class

ElementAnalyser Class
Members See Also Send Feedback
Analyser of Revit element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class ElementAnalyser

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Engineering.Tools..::..ElementAnalyser

See Also

ElementAnalyser Members
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace