ResultsManager Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsManager Members
ResultsManager Class Constructors Methods Properties See Also Send Feedback

The ResultsManager type exposes the following members.

Constructors

 | Name | Description
Public method | ResultsManager | Initializes a new instance of the ResultsManager class.

Methods

 | Name | Description
Public method | GetResult(Element) | Gets results of specific element and package.
Public method | GetResult(Element, Guid) | Gets results of specific element and package.
Public method | GetResultStatus(Element, Guid) | Gets the result status for specific element.
Public method | GetResultStatus(Element, Guid, Guid) | Gets the result status for specific element.
Public method | GetServerResult(Element, Guid) | Gets the server result.
Public method | GetServerResult(Element, Guid, Guid) | Gets the server result.
Public method | OutDateResults | Outdate results for specific server in particular element.
Public method | SetResult(Entity, Element, ResultStatus, Boolean) | Sets result to specific element.
Public method | SetResult(Entity, Element, Guid, ResultStatus, Boolean) | Sets result to specific element.
Public method | SetResultStatus |

Properties

 | Name | Description

See Also

ResultsManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace