DocumentBuilder Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentBuilder Members
DocumentBuilder Class Methods See Also Send Feedback

The DocumentBuilder type exposes the following members.

Methods

 | Name | Description
Public method | BuildDocument(Document, Document, DetailLevel) | Builds document file.
Public method | BuildDocument(Document, Document, String, DetailLevel) | Virtual methods building document. This method is overriden by document builders.
Public method | BuildDocuments | Builds the document list splitted due to PageBreaks.
Public method | GetExtension | Gets the extension of the file (without dot).
 | GetTempPath | Gets the temp path.
 | GetUserTempPath | Gets the temp path for user.
 | RemoveTempPath | Removes the temp path.
 | RemoveUserTempPath | Removes the temp path.

See Also

DocumentBuilder Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace