ElementSectionsInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSectionsInfo Members
ElementSectionsInfo Class Constructors Methods Properties See Also Send Feedback

The ElementSectionsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSectionsInfo()()()() | Creates default instance.
Public method | ElementSectionsInfo(ElementSectionsInfo) | Creates instance from pattern.
Public method | ElementSectionsInfo(SectionsInfo, SectionsInfo) | Creates instance using information at the begining and at the end of section.

Methods

 | Name | Description
Public method | AtThePoint | Gets the sections at the point along element length.
Public method | Clone | Creates a new object that is a copy of the current instance.

Properties

 | Name | Description
Public property | AtTheBeg | Gets the sections at the begining of the element.
Public property | AtTheEnd | Gets the sections at the end of the element.

See Also

ElementSectionsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace