GetDataStructure Method (Type, Type, , )

DataStructureAttribute..::..GetDataStructure Method (Type, Type, , )
DataStructureAttribute Class See Also Send Feedback
Gets the data structure type based on attributes assigned to source type.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetDataStructure(
    Type attType,
    Type sourceType,
    BuiltInCategory category,
    StructuralAssetClass material
)

Parameters

attType
Type: System..::..Type
Type of the attribute.
sourceType
Type: System..::..Type
The source type.
category
Type: BuiltInCategory
The category.
material
Type: StructuralAssetClass
The material.

Return Value

See Also

DataStructureAttribute Class
GetDataStructure Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace