SurfaceGraph Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraph Properties
SurfaceGraph Class See Also Send Feedback

The SurfaceGraph type exposes the following members.

Properties

 | Name | Description
Public property | DirectionX | Obsolete. Returns Vector defining the X-axis of the coordinate system in which the results are presented.
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | LocalCoordinateSystem | Returns Transormation defining the axes of the coordinate system in which the results are presented.
Public property | Points | List of coordinates in local plane.
Public property | ResultType | Returns the type of the graph.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.
Public property | Values | List of Values over the coordinates.

See Also

SurfaceGraph Class
Autodesk.Revit.DB.ResultsBuilder Namespace