GetForceForPoint Method (, ForceResultsPackageDescriptor, IEnumerable(ForceLoadCaseDescriptor), CalcPoint, ForceType)

ForceResultsCache..::..GetForceForPoint Method (, ForceResultsPackageDescriptor, IEnumerable<(Of <(<'ForceLoadCaseDescriptor>)>)>, CalcPoint, ForceType)
ForceResultsCache Class See Also Send Feedback
Gets internal forces in a specific calculation point in a given element for a specific ResPackage, loads and force type

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<double> GetForceForPoint(
    ElementId elementId,
    ForceResultsPackageDescriptor packageDescriptor,
    IEnumerable<ForceLoadCaseDescriptor> loads,
    CalcPoint calculationPoint,
    ForceType forceType
)

Parameters

elementId
Type: ElementId
Revit ElementId
packageDescriptor
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceResultsPackageDescriptor
Result pack descriptor
loads
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ForceLoadCaseDescriptor >)>)>
Load case descriptors
calculationPoint
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..CalcPoint
Calculation point
forceType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceType
Force type

Return Value

List of doubles representing forces of forceType for the element of ElementId

See Also

ForceResultsCache Class
GetForceForPoint Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace