LoadCombinationPreview Members

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationPreview Members
LoadCombinationPreview Class Constructors Methods Properties See Also Send Feedback

The LoadCombinationPreview type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCombinationPreview | Initializes a new instance of the LoadCombinationPreview class.

Methods

 | Name | Description
Public method | AddComponent | Adds the component. It should be LoadCase, LoadCombination or LoadCombinationPreview
Public method | Generate | Generates Revit LoadCombination in specified document.
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetUsageName | Gets the name of the usage.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | State | Gets or sets the state.
Public property | Type | Gets or sets the type.
Public property | Usages | Gets the usages.

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace