Steel Members

[image]

Structural Analysis and Code Checking API Reference Guide
Steel Members
Steel Class Constructors Methods Properties See Also Send Feedback

The Steel type exposes the following members.

Constructors

 | Name | Description
Public method | Steel | The default Steel class constructor

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Steel
Public method | SetModelIdealElastoPlastic | Sets all appropriate parameters for steel with horizontal top branch (Ideal elasto-plactic behaviour).
Public method | SetModelWithHardening | Sets all appropriate parameters for steel with inclined top branch (plastic with hardening).

Properties

 | Name | Description
Public property | DesignStrength | The DesignStrength property represents the design strenght of steel (design yield strength).
Public property | HardeningFactor | The HardeningFactor property represents the value of steel hardening over the plastic behaviour.
Public property | ModulusOfElasticity | The ModulusOfElasticity property represents the steel modulus of elasticity (Young modulus).
Public property | StrainUltimateLimit | The StrainUltimateLimit property represents the value of maximum steel strain.

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace