SetConcrete Method

RCSolver..::..SetConcrete Method
RCSolver Class See Also Send Feedback
Sets necessary parameters describing concrete behaviors.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetConcrete(
    Concrete concrete
)

Parameters

concrete
Type: Autodesk.CodeChecking.Concrete..::..Concrete
The Concrete object.

Exceptions

Exception | Condition
System..::..ArgumentException | The concrete strength must be greater than 0.0.
System..::..ArgumentException | The concrete strain at failure must be greater than 0.0.
System..::..ArgumentException | The concrete modulus of elasticity (Young modulus) must greater than 0.0.
System..::..ArgumentException | The power should be greater than 1.0.
System..::..ArgumentException | The reduction factor of the compression zone height must be in the range between 0 and 1.0.
System..::..ArgumentException | The power must be greater than 1.0.
System..::..ArgumentException | The relationship changeover must be less than the ultimate strain.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace