SchemaAttribute Constructor

SchemaAttribute Constructor
SchemaAttribute Class See Also Send Feedback
Initializes a new instance of the SchemaAttribute class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SchemaAttribute(
    string name,
    string schemaId,
    params string[] schemaIdHistory
)

Parameters

name
Type: System..::..String
The name of the schema.
schemaId
Type: System..::..String
The current id of the schema.
schemaIdHistory
Type: array< System..::..String >[]()[][]
The history of schemas ids from newest to oldest (without current one).

See Also

SchemaAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace