ForceResultsCache Constructor (, ICollection(), ICollection(ForceResultsPackageDescriptor), ICollection(), ICollection(ForceType), )

ForceResultsCache Constructor (, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'ForceResultsPackageDescriptor>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'ForceType>)>)>, )
ForceResultsCache Class See Also Send Feedback
Creates ForceResultsCache

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceResultsCache(
    Document document,
    ICollection<ElementId> elementIDs,
    ICollection<ForceResultsPackageDescriptor> resultPackDescriptors,
    ICollection<ElementId> loads,
    ICollection<ForceType> forceTypes,
    DisplayUnit unitSystem
)

Parameters

document
Type: Document
Revit document
elementIDs
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
Collection of ID's for revit elements for which internal forces will be querried
resultPackDescriptors
Type: System.Collections.Generic..::..ICollection <(Of <(<' ForceResultsPackageDescriptor >)>)>
Collection of descriptors for result packages from which results will be imported. If null , all available packages will be used
loads
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
Collection of loads corresponding to the internal forces
forceTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' ForceType >)>)>
Specifies internal forces in element for which results are to be taken
unitSystem
Type: DisplayUnit
Unit system

See Also

ForceResultsCache Class
ForceResultsCache Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace