DocumentSection Constructor (DocumentSection, Document, String, Int32, Boolean)

DocumentSection Constructor (DocumentSection, Document, String, Int32, Boolean)
DocumentSection Class See Also Send Feedback
Initializes a new instance of the DocumentSection class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentSection(
    DocumentSection parentSection,
    Document parentDocument,
    string name,
    int position,
    bool addToParent
)

Parameters

parentSection
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DocumentSection
The parent section.
parentDocument
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The parent document.
name
Type: System..::..String
The name.
position
Type: System..::..Int32
The position.
addToParent
Type: System..::..Boolean
if set to true the element will be added to parent (section or if section is null to document).

See Also

DocumentSection Class
DocumentSection Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace