GetStress Method

RCSolver..::..GetStress Method
RCSolver Class See Also Send Feedback
Gets stress at a given point.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetStress(
    ResultType resType,
    int id
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of stress to be returned: for rebar or concrete only.
id
Type: System..::..Int32
Id of the contour or a given rebar.

Return Value

Returns the stress in concrete or rebar at point given by contour or rebar Id.
Unit: [force per length^2]

Remarks

This method could be used only for concrete and rebars, for section, this method throws exception.
If calculation are not performed, this method throws exception as well.
Unit depends to the units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Calculation are not performed
 | This method could be used only for concrete and rebars.
System..::..ArgumentException | Index must be less than Count.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace