SubSchemaListTable Constructor

SubSchemaListTable Constructor
SubSchemaListTable Class See Also Send Feedback
Initializes a new instance of the SubSchemaListTable class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaListTable(
    Guid schema,
    string fieldName,
    string displayName,
    SubSchemaListTableAttribute attribute,
    Guid subSchema,
    ContainerType container,
    Type valueType,
    Type keyType
)

Parameters

schema
Type: System..::..Guid
The schema.
fieldName
Type: System..::..String
Name of the field.
displayName
Type: System..::..String
The display name.
attribute
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..SubSchemaListTableAttribute
The attribute.
subSchema
Type: System..::..Guid
The subschema id.
container
Type: ContainerType
The container.
valueType
Type: System..::..Type
Type of the value.
keyType
Type: System..::..Type
Type of the key.

See Also

SubSchemaListTable Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace