Server(TData) Members

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TData>)>)> Members
Server<(Of <(<'TData>)>)> Class Methods See Also Send Feedback

The Server<(Of <(<'TData>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ConvertDataToCurrentVersion | Converts the data to current version.
Public method | Generate | Generates load combinations. Used only if the server doesn't support preview mode.
Public method | GeneratePreview | Generates load combinations based on settings.
Public method | GetDataSchema | Gets the data schema.
Public method | GetDefaultData | Gets the default data.
Public method | GetDescription | Implement this method to return a description of the server.
Public method | GetName | Implement this method to return the name of the server.
Public method | GetServerId | Implement this method to return the id of the server.
Public method | GetServiceId | Implement this method to return the id of the service.
Public method | GetVendorId | Implement this method to return the id of the vendor of the server.
Public method | GetVersion | Gets the version of code checking server.
Public method | PostGeneration | Launched after Revit load combination generation (only in preview mode).
Public method | PreGeneration | Launched before Revit load combination generation (only in preview mode).
Public method | PreviewMode | Indicates if server supports preview mode.
Public method | RemoveLoadCombinations | Indicates if load combinations generated in the past should be removed before generation.

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace