LineGraphEnvelope Members

[image]

Structural Analysis and Code Checking API Reference Guide
LineGraphEnvelope Members
LineGraphEnvelope Class Methods Properties See Also Send Feedback

The LineGraphEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | GetBottomMinValue | Calculates the minimal value of top envelope.
Public method | GetBottomValue | Calculates the value of bottom envelope in specified point.
Public method | GetTopMaxValue | Calculates the maximal value of top envelope.
Public method | GetTopValue | Calculates the value of top envelope in specified point.

Properties

 | Name | Description
Public property | BottomPoints | Returns the list of points thad defines the bottom envelope. U is interpreted as domain and V as values.
Public property | DomainDisplayUnitType | Indicates the units of the domain of the linear graph.
Public property | ResultType | Returns the type of result of the linear graph.
Public property | TopPoints | Returns the list of points thad defines the top envelope. U is interpreted as domain and V as values.
Public property | ValueDisplayUnitType | Indicates the units of the values of the linear graph.

See Also

LineGraphEnvelope Class
Autodesk.Revit.DB.ResultsBuilder Namespace