MultiStructureServer Class

MultiStructureServer Class
Members See Also Send Feedback
The base class for all servers that support more than one category or material.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class MultiStructureServer : ICodeCheckingServerUI,
    IServerUI, IResource

Remarks

It is strongly connected with DataStructurAttributes:ResultStructureAttribute, LabelStructureAttribute, CalculationParamsStructureAttribute

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.CodeChecking..::..MultiStructureServer

See Also

MultiStructureServer Members
Autodesk.Revit.UI.CodeChecking Namespace