SetSteel Method

RCSolver..::..SetSteel Method
RCSolver Class See Also Send Feedback
Sets necessary parameters describing reinforcement steel behaviors.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetSteel(
    Steel steel
)

Parameters

steel
Type: Autodesk.CodeChecking.Concrete..::..Steel
The Steel object.

Exceptions

Exception | Condition
System..::..ArgumentException | The steel strength must be greater than 0.0.
System..::..ArgumentException | The steel strain at failure must be greater than 0.0.
System..::..ArgumentException | The steel modulus of elasticity (Young modulus) must greater than 0.0.
System..::..ArgumentException | The hardening factor for inclined top branch must be greater than 1.0 , for horizontal branch must be equal 1.0.
System..::..ArgumentException | The steel strain at failure can't be less than the design strength divided by modulus of elasticity.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace