Format Method

IFieldFormat..::..Format Method
IFieldFormat Interface See Also Send Feedback
Formats the specified value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
string Format(
    Object value,
    Document document,
    UnitType unitType,
    DisplayUnitType inputDisplayUnitType,
    bool edit
)

Parameters

value
Type: System..::..Object
The value.
document
Type: Document
The document.
unitType
Type: UnitType
Type of the unit.
inputDisplayUnitType
Type: DisplayUnitType
Type of the input display unit.
edit
Type: System..::..Boolean
if set to true for edit purpose.

Return Value

See Also

IFieldFormat Interface
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace