ResultsPackageBuilder Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackageBuilder Methods
ResultsPackageBuilder Class See Also Send Feedback

The ResultsPackageBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddMeasurement(String, MeasurementResultType, UnitType, DisplayUnitType) | Obsolete. Obsolete, use the same function with full parameter list.
Public method | AddMeasurement(String, MeasurementResultType, UnitType, DisplayUnitType, MeasurementDependencyType) | AddMeasurement method creates the additional type of results. It allows to define types of results that are not standard within the static analysis scope. The Name and measurementResultType pair must be unique in the package.
Public method | Finish | Finishes buildings of analyses package and returns newly created ResultsPackage object.
Public method | SetAnalysisInfo | Sets the Analysis Info of package.
Public method | SetAnalysisName | Sets the Analysis Name of package.
Public method | SetArbitraryResult | Function sets specified arbitrary result.
Public method | SetBarResult(ElementId, ElementId, DomainResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified bar results.
Public method | SetBarResult(ElementId, ElementId, LinearResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified bar results.
Public method | SetBarResult(ElementId, ElementId, String, IEnumerable<(Of <<'(Double>)>>)) | Obsolete. Function sets specified bar results.
Public method | SetBarResults | Function sets bar results.
Public method | SetBarSectionProperties | Sets the properties of analytical linear element, that were used for analysis. This set of properties will be used for derivative results calculations.
Public method | SetCreationTime | Sets the creation time of package.
Public method | SetDescription | Sets the Decsription of package.
Public method | SetDesignOptionId | Sets the design option id for which the analysis was performed.
Public method | SetModelId | Sets the Model Guid of package.
Public method | SetModelInfo | Sets the Model Info of package.
Public method | SetModelName | Sets the Model Name of package.
Public method | SetNodeResult | Function sets specified arbitrary result for node.
Public method | SetNodeResults | Sets node results for element.
Public method | SetPassword | Set password to protect package against modifying.
Public method | SetPhaseId | Sets the phase id for which the analysis was performed.
Public method | SetProviderName | Sets the Provider Name of package.
Public method | SetResultsStatus | Sets results status.
Public method | SetStoreyResults | Sets results for storey.
Public method | SetSurfaceResult(ElementId, ElementId, DomainResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified surface results.
Public method | SetSurfaceResult(ElementId, ElementId, SurfaceResultType, IEnumerable<(Of <<'(Double>)>>)) | Function sets specified surface results.
Public method | SetSurfaceResults(ElementId, ElementId, SurfaceResults) | Sets forces for surface element.
Public method | SetSurfaceResults(ElementId, ElementId, ICollection<(Of <<'(SurfaceNodeResults>)>>)) | Sets forces for surface element.
Public method | SetSurfaceSectionProperties | Sets the properties of analytical surface element, that were used for analysis. This set of properties will be used for derivative results calculations.
Public method | SetVendorDescription | Sets the Vendor Description of package.
Public method | SetVendorId | Sets the Vendor Id of package.

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace