SetOfForces Class

SetOfForces Class
Members See Also Send Feedback
Describes the set of internal forces: AxialForce(N), MomentX(Mx) and MomentY(My).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class SetOfForces

Remarks

The internal forces are described in coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
AxialForce(N) - The compresion have positive sign.
MomentX(Mx) - The bending moment around x'-axis.
MomentY(My) - The bending moment around y'-axis.

Inheritance Hierarchy

System..::..Object
Autodesk.CodeChecking.Concrete..::..SetOfForces

See Also

SetOfForces Members
Autodesk.CodeChecking.Concrete Namespace