Geometry Constructor (Double, Double)

Geometry Constructor (Double, Double)
Geometry Class See Also Send Feedback
The class constructor for a rectangular cross section.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public Geometry(
    double height,
    double width
)

Parameters

height
Type: System..::..Double
The height of the rectangular cross-section.
Unit: [length].
width
Type: System..::..Double
The width of the rectangular cross-section.
Unit: [length].

Remarks

The bottom left corner is in the center of coordinate system x=0, y=0 and the contour has a counterclockwise orientation.

See Also

Geometry Class
Geometry Overload
Autodesk.CodeChecking.Concrete Namespace