CreateResultsPackage Method (Guid, String, UnitsSystem, ResultsPackageTypes)

ResultsAccess..::..CreateResultsPackage Method (Guid, String, UnitsSystem, ResultsPackageTypes)
ResultsAccess Class See Also Send Feedback
Create new instance of ResultsPackageBuilder.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ResultsPackageBuilder CreateResultsPackage(
    Guid value,
    string name,
    UnitsSystem unitSystem,
    ResultsPackageTypes types
)

Parameters

value
Type: System..::..Guid
name
Type: System..::..String
unitSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem
types
Type: Autodesk.Revit.DB.ResultsBuilder..::..ResultsPackageTypes

Remarks

The package guid must be unique in the document.

Exceptions

Exception | Condition
ArgumentException | Package guid already exists.

See Also

ResultsAccess Class
CreateResultsPackage Overload
Autodesk.Revit.DB.ResultsBuilder Namespace