SurfaceResults Constructor (ICollection(SurfacePointResults), )

SurfaceResults Constructor (ICollection<(Of <(<'SurfacePointResults>)>)>, )
SurfaceResults Class See Also Send Feedback
Initializes new SurfaceResults object

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[ObsoleteAttribute("Use SurfaceResults that defines the local coordinate system")]
public SurfaceResults(
    ICollection<SurfacePointResults> values,
    XYZ directionX
)

Parameters

values
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfacePointResults >)>)>
List of results in all points of the surface.
directionX
Type: XYZ
Vector defining the X-axis of the coordinate system in which the results are presented.

See Also

SurfaceResults Class
SurfaceResults Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace