FieldControl Constructor

FieldControl Constructor
FieldControl Class See Also Send Feedback
Initializes a new instance of the FieldControl class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public FieldControl(
    Guid schema,
    string fieldName,
    string displayName,
    FieldUIAttribute attribute,
    UnitAttribute unitAttribute,
    ContainerType container,
    Type valueType,
    Type keyType
)

Parameters

schema
Type: System..::..Guid
The schema.
fieldName
Type: System..::..String
Name of the field.
displayName
Type: System..::..String
The display name.
attribute
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
The attribute.
unitAttribute
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..UnitAttribute
The unit attribute.
container
Type: ContainerType
The container.
valueType
Type: System..::..Type
Type of the value.
keyType
Type: System..::..Type
Type of the key.

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace