MaterialProperties Properties

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialProperties Properties
MaterialProperties Class See Also Send Feedback

The MaterialProperties type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the detailed material description.
Public property | Name | Gets the material's name.
Public property | ResistanceCode | Gets /1. a digit stands for (characteristic or design) resistance, 2. a cubic or cylindric sample).
Public property | SecondName | Gets the second material's name.
Public property | Therm | Gets the material type /for metal: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.

See Also

MaterialProperties Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace