GridXYZTextBoxAttribute Class

GridXYZTextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with TextBox grid control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class GridXYZTextBoxAttribute : XYZTextBoxAttribute,
    IGridValueAttribute, IGridAttribute

Remarks

Only for maps and arrays.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..XYZTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridXYZTextBoxAttribute

See Also

GridXYZTextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace