Label Members

[image]

Structural Analysis and Code Checking API Reference Guide
Label Members
Label Class Constructors Methods Properties See Also Send Feedback

The Label type exposes the following members.

Constructors

 | Name | Description
Public method | Label | Initializes a new instance of the Label class.

Methods

 | Name | Description
Public method | Clone(Boolean) | Duplicates current instance.
Public method | Load | Loads the specified element. (Overrides SchemaClass..::..Load(Element).)
Public method | SetEntity(Entity, Guid) | Sets particular entity for specific server of input ID. (Overrides Storage<(Of <(<'T>)>)>..::..SetEntity(Entity, Guid).)

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | Id | The id of the label.
Public property | Material | Gets or sets the material.
Public property | Modified | Gets or sets a value indicating whether this Label was modified.
Public property | Name | The name of the label.

See Also

Label Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace