ForceCalculationDataDescriptor Constructor

ForceCalculationDataDescriptor Constructor
ForceCalculationDataDescriptor Class See Also Send Feedback
Creates default ForceCalculationPointsDescriptor

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceCalculationDataDescriptor(
    ElementId elementId,
    IEnumerable<ForceType> forceTypes
)

Parameters

elementId
Type: ElementId
Revit ElementId for element to which calculation point is assigned
forceTypes
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ForceType >)>)>
Vector of force types for which calculations are to be conducted

See Also

ForceCalculationDataDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace