ElementSectionsParamsInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSectionsParamsInfo Members
ElementSectionsParamsInfo Class Constructors Methods Properties See Also Send Feedback

The ElementSectionsParamsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSectionsParamsInfo()()()() | Creates default instance (not tapered).
Public method | ElementSectionsParamsInfo(ElementSectionsParamsInfo) | Creates instance from pattern.
Public method | ElementSectionsParamsInfo(SectionProfile, SectionsParamsInfo) | Creates not tapered instance.
Public method | ElementSectionsParamsInfo(SectionProfile, SectionsParamsInfo, SectionsParamsInfo) | Creates tapered instance.

Methods

 | Name | Description
Public method | AtThePoint | Gets the dimensions of the section at the point along element length.
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides SectionProfile..::..Clone()()()().)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Overrides SectionProfile..::..CompareTo(Object).)

Properties

 | Name | Description
Public property | AtTheBeg | Gets the parameters of the section at the begining of the element.
Public property | AtTheEnd | Gets the parameters of the section at the end of the element.

See Also

ElementSectionsParamsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace