ResultsPackage Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage Methods
ResultsPackage Class See Also Send Feedback

The ResultsPackage type exposes the following members.

Methods

 | Name | Description
Public method | GetBarNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Returns node results for linear element.
Public method | GetBarNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>), UnitsSystem) | Returns bar node results for element.
Public method | GetBarNodeResultsEnvelopes | GetBarNodeResultsEnvelopes
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>), LineGraphParameters) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), LineGraphParameters) | Return list of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(LinearResultType>)>>)) | Return list of envelopes of linear results for given input parameters.
Public method | GetLineGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), LineGraphParameters) | Return list of envelopes of linear results for given input parameters. Values are defined in local coordinate system of analytical model.
Public method | GetLineGraphsExtremes | Return extremal values for given input parameters.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), NodeResultType) | Returns node results for element.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), NodeResultType, UnitsSystem) | Returns node results for element.
Public method | GetNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), String, UnitsSystem) | Returns node results for element.
Public method | GetNodeResultsEnvelope | Returns node results for element.
Public method | GetNodeResultsExtremes | Return extremal values for given input parameters.
Public method | GetReducedSurfaceResults | Returns reduced results for surface element.
Public method | GetResultsStatus | Return the status of the entire package.
Public method | GetStoreyResults | Returns results for storey.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>), SurfaceGraphParameters) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphs(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), SurfaceGraphParameters) | Return list of planar results for given input parameters.
Public method | GetSurfaceGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Return envelope of results.
Public method | GetSurfaceGraphsEnvelopes(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(String>)>>), SurfaceGraphParameters) | Return envelope of results.
Public method | GetSurfaceGraphsExtremes | Return extremal values for given input parameters.
Public method | GetSurfaceNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>)) | Returns surface node results for element.
Public method | GetSurfaceNodeResults(ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(SurfaceResultType>)>>), UnitsSystem) | Returns surface node results for element.
Public method | GetSurfaceNodeResultsEnvelope |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace