SlabInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SlabInfo Properties
SlabInfo Class See Also Send Feedback

The SlabInfo type exposes the following members.

Properties

 | Name | Description
Public property | ContextId | Revit Id of element.
Public property | Contours | Gets list of SlabContour objects.
Public property | Edges | Gets list of SlabEdge objects.
Public property | FamilyName | Gets family name.
Public property | IsOneWay | One way structural usage flag
Public property | Layers | Gets list of Layer objects (from Top to Bottom).
Public property | LevelName | Gets level name.
Public property | MaximumBoundary | Gets maximum coordinates (upper-right-front corner) of the boundary box.
Public property | MinimumBoundary | Gets minimum coordinates (lower-left-rear corner) of the boundary box.
Public property | Nodes | Gets list of SlabNode objects.
Public property | SpanDirectionAngle | Gets angle of span direction.
Public property | Transform | Gets class allows to transform points from local to global (and vice versa) coordinate system.
Public property | TypeName | Gets name of type.

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace