ResultsPackage Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ResultsPackage Properties
ResultsPackage Class See Also Send Feedback

The ResultsPackage type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisInfo | Provides access to the Analysis Info of the package.
Public property | AnalysisName | Provides access to the Analysis Name of the package.
Public property | CreationTime | Provides access to the creation time of the package.
Public property | Description | Provides access to the Description of the package.
Public property | DesignOption | Provides access to the design option id for which the analysis was performed.
Public property | ElementIds | Returns set of elements for which results are available
Public property | GUID | Provides access to the GUID of the results package.
Public property | IsProviderPackage | Gets a value indicating whether this instance is provider package.
Public property | LoadCaseIds | Returns set of load cases for which results are available
Public property | Measurements | Returns collections of measurements defined in the package.
Public property | ModelId | Provides access to the Guid of the package.
Public property | ModelInfo | Provides access to the Model Info of the package.
Public property | ModelName | Provides access to the Model Name of the package.
Public property | Name | Provides access to the Name of the results package.
Public property | PackageSize | Returns package size in kilobytes.
Public property | Phase | Provides access to the phase id for which the analysis was performed.
Public property | ProviderDescriptor | Gets the provider descriptor. This reference is set, when the ResultsPackage was created from this ResultsPackageDescriptor.
Public property | ProviderDescriptorReference | Gets the provider descriptor reference. This reference is set, when the ResultsPackage is saved with document and it has ResultsPackageDescriptor provided by some provider.
Public property | ProviderName | Provides access to the Provider Name of the package.
Public property | ResultsPackageType | Returns type of package.
Public property | VendorDescription | Provides access to the Vendor Description of the package.
Public property | VendorId | Provides access to the Vendor Id of the package.

See Also

ResultsPackage Class
Autodesk.Revit.DB.ResultsBuilder Namespace