SetBarSectionProperties Method

ResultsPackageBuilder..::..SetBarSectionProperties Method
ResultsPackageBuilder Class See Also Send Feedback
Sets the properties of analytical linear element, that were used for analysis. This set of properties will be used for derivative results calculations.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetBarSectionProperties(
    ElementId elementId,
    BarProperties properties
)

Parameters

elementId
Type: ElementId
properties
Type: Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarProperties

Exceptions

Exception | Condition
[t:ArgumentException] | An element with specified elementId have already properties defined.

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace