SchemaClass Members

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaClass Members
SchemaClass Class Constructors Methods See Also Send Feedback

The SchemaClass type exposes the following members.

Constructors

 | Name | Description
Public method | SchemaClass()()()() | Initializes the instance of SchemaClass.
Public method | SchemaClass(Element) | Initializes the instance of SchemaClass based on the Revit element.
Public method | SchemaClass(Entity, Document) | Initializes the instance of SchemaClass based on the Entity.

Methods

 | Name | Description
 | BuildSchema | Generates schema based on class definition.
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Exists | Checks if data of this class exists in the element.
Public method | FillEntity | Fills entity based on this instance.
 | GetBaseType(PropertyInfo, ContainerType%, Type%) | Gets the base type of the property.
 | GetBaseType(Type, ContainerType%, Type%) | Gets the base type of the property.
 | GetBaseTypeForSchema(PropertyInfo, ContainerType%, Type%) | Gets the base type for schema.
 | GetBaseTypeForSchema(Type, ContainerType%, Type%) | Gets the base type for schema.
Public method | GetEntity | Returns the entity based on this instance.
 | GetFieldName | Gets the name of the field.
 | GetTypeForSchema | Gets the type for the schema.
 | GetTypeOfSchemaId | Gets the type of specific schema id.
 | GetValue(Entity, Field, DisplayUnitType) | Returns the value of specific field.
 | GetValue(Entity, String, DisplayUnitType) | Returns the value of specific field.
Public method | GetVersion | Returns the version of the schema based on history kept in SchemaAttribute.
Public method | Load | Loads data from Revit element.
Public method | LoadField | Loads the property in a special way (otherwise returns false).
Public method | PostLoad | Called after loading the instance.
Public method | PostSave | Called after saving the instance.
Public method | PreLoad | Called before loading the instance.
Public method | PreSave | Called before saving the instance.
Public method | Remove | Removes data from element.
Public method | Save | Saves data to Revit element.
Public method | SaveField | Saves the property in a special way (otherwise returns false)
 | SetEntityParamBased | Sets values of fields in entity based on properties of the input object.
 | SetParamsEntityBased | Sets properties of the object based on fields of the entity.
Public method | SetProperties | Sets properties of this instance based on the entity.
 | SetValue(Entity, Field, Object, DisplayUnitType) | Sets the value of the specific field.
 | SetValue(Entity, String, Object, DisplayUnitType) | Sets the value of the specific field.

See Also

SchemaClass Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace