PreGeneration Method

ILoadCombinationServer..::..PreGeneration Method
ILoadCombinationServer Interface See Also Send Feedback
Launched before Revit load combination generation (only in preview mode).

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
void PreGeneration(
    Document document,
    List<LoadCombinationPreview> selectedCombinations
)

Parameters

document
Type: Document
The document.
selectedCombinations
Type: System.Collections.Generic..::..List <(Of <(<' LoadCombinationPreview >)>)>
Selected combinations by the user.

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace