SolveForces Method (ResultType, Double, Double)

RCSolver..::..SolveForces Method (ResultType, Double, Double)
RCSolver Class See Also Send Feedback
Calculates resistance forces according to acting strain

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public SetOfForces SolveForces(
    ResultType resType,
    double topStrain,
    double bottomStrain
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of resistance to be returned: for rebar, concrete or equivalent section (transformed).
topStrain
Type: System..::..Double
Strain at the top of the section (on the extreme point of cross-section on the positive side of y axis).
Unit: [dimensionless].
bottomStrain
Type: System..::..Double
Strain at the bottom of section (on extreme point of cross-section on the negative side of y axis).
Unit: [dimensionless].

Remarks

The resistance forces could be read by GetInternalForces method.
Top and Bottom mean points of cross section with the maximum and minimum y coordinate.
Other information about state of failure could be read using dedicated methods.

Exceptions

Exception | Condition
System..::..ArgumentException | Top strain greater than ultimate concrete strain.
System..::..ArgumentException | Bottom strain greater than ultimate concrete strain.
System..::..ArgumentException | Top strain greater than ultimate steel strain.
System..::..ArgumentException | Bottom strain greater than ultimate steel strain.

See Also

RCSolver Class
SolveForces Overload
Autodesk.CodeChecking.Concrete Namespace