ProgressStep Method

NotificationService..::..ProgressStep Method
NotificationService Class See Also Send Feedback
Informs that there was made additional step in current progress.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static void ProgressStep(
    string message,
    string source,
    bool throwProgressBreakException
)

Parameters

message
Type: System..::..String
The message.
source
Type: System..::..String
The source.
throwProgressBreakException
Type: System..::..Boolean
if set to true the ProgressBreakException will be thrown if there is such requirement on the stack.

See Also

NotificationService Class
Autodesk.Revit.DB.CodeChecking Namespace