SlabContour Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SlabContour Methods
SlabContour Class See Also Send Feedback

The SlabContour type exposes the following members.

Methods

 | Name | Description
Public method | GetEdge | Returns edge of specific coordinates.
Public method | IsContourInside(List<(Of <<'(XYZ>)>>)) | Checks if contour is inside current one.
Public method | IsContourInside(SlabContour) | Checks if contour is inside current one.
Public method | IsCrossingLine | Checks if line is crossing current contour.
Public method | IsPointInside | Checks if point is inside contour.
Public method | IsPointOnEdge | Checks if point is on edge.

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace