Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace

Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace

Classes

 | Class | Description
Public class | DefaultElementAttribute | Indicates that particular property will be documented in default way by the system.
Public class | DocumentElementAttribute | Represent the attribute for document.
Public class | ListValueAttribute | Indicates that particular property will be documented as a list
Public class | RatioAttribute | Indicates that property should be presented in the document as a ratio.
Public class | SubSchemaElementAttribute | Indicates that particular property will be documented as a subschema element.
Public class | SubSchemaListTableAttribute | Indicates that particular schema list will be presented as a table.
Public class | TableAttribute | Indicates that particular property will be documented as a table.
Public class | ValueAttribute | Indicates that particular property will be documented as a value.
Public class | ValueWithDescriptionAttribute | Indicates that particular property will be documented as a value with name and description.
Public class | ValueWithNameAttribute | Indicates that particular property will be documented as a value with name.

DefaultElementAttribute Class

DefaultElementAttribute Class
Members See Also Send Feedback
Indicates that particular property will be documented in default way by the system.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class DefaultElementAttribute : DocumentElementAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DocumentElementAttribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes..::..DefaultElementAttribute

See Also

DefaultElementAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation.Attributes Namespace