GetRebarType Method

RebarUtility..::..GetRebarType Method
RebarUtility Class See Also Send Feedback
Return the RebarType of a specific rebar based on his ElementId

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Concrete
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static RebarBarType GetRebarType(
    Document document,
    ElementId rebarId
)

Parameters

document
Type: Document
Revit document
rebarId
Type: ElementId
Rebar ElementId

Return Value

The RebarType of the rebar

See Also

RebarUtility Class
Autodesk.Revit.DB.CodeChecking.Engineering.Concrete Namespace