ElementTSectionInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementTSectionInfo Members
ElementTSectionInfo Class Methods Properties See Also Send Feedback

The ElementTSectionInfo type exposes the following members.

Methods

 | Name | Description
Public method | AdjoiningSlabOnTheLeftSide | Gets the adjoining slab on the left side of the element at the point along its length.
Public method | AdjoiningSlabOnTheRightSide | Gets the adjoining slab on the right side of the element at the point along its length.
Public method | BeamWidth | Gets width of element.
Public method | DistanceToNearestObjectOnTheLeftSide | Gets the distance to nearest characteristic object on the left side of the element. Distance is calculated at the point along the element length.
Public method | DistanceToNearestObjectOnTheRightSide | Gets the distance to nearest characteristic object on the right side of the element. Distance is calculated at the point along the element length.
Public method | GetContour | Gets contour of the joint section including flanges
Public method | OverlappingDepthOnTheLeftSide | Gets the distance from lower slab edge to upper element edge on the left side of the element. Depth is calculated at the point along the element length.
Public method | OverlappingDepthOnTheRightSide | Gets the distance from lower slab edge to upper element edge on the right side of the element. Depth is calculated at the point along the element length.
Public method | SlabThicknessOnTheLeftSide | Gets the thickness of the slab on the left side of the element at the point along its length.
Public method | SlabThicknessOnTheRightSide | Gets the thickness of the slab on the right side of the element at the point along its length.
Public method | TypeOfNearestObjectOnTheLeftSide | Gets type of nearest characteristic object on the left side of the element.
Public method | TypeOfNearestObjectOnTheRightSide | Gets type of nearest characteristic object on the right side of the element.

Properties

 | Name | Description
Public property | Adjoinings | Gets list of SlabInfo objects represent adjoining slabs.
Public property | BeamSections | Gets beam sections.
Public property | ContextId | Gets Revit Id of beam element.
Public property | Contour | Gets contour of the joint section including flanges

See Also

ElementTSectionInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace