SetMeasurementForElement Method

ForceResultsWriter..::..SetMeasurementForElement Method
ForceResultsWriter Class See Also Send Feedback
Sets calculation points coordinates for a given element

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetMeasurementForElement(
    ElementId elementId,
    AxisDirection direction,
    IList<double> points
)

Parameters

elementId
Type: ElementId
Revit ElementId
direction
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..AxisDirection
Axis direction(not used for bar elements)
points
Type: System.Collections.Generic..::..IList <(Of <(<' Double >)>)>
Point coordinates list

See Also

ForceResultsWriter Class
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace