StressDiagramType Enumeration

StressDiagramType Enumeration
See Also Send Feedback
Classification of concrete stress-strain relationships.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum StressDiagramType

Members

Member name | Value | Description
Rectangular | 0 | Simplified model with rectangular stress distribution. Usage of a constant value of stress along the reduced height.
Linear | 1 | Stress with linear relationship to strain. Usage of the typical SLS model.
Bilinear | 2 | Stress with Bi-linear relationship to strain. Linear part from 0.0 to strain relationship changeover value, constant part from strain relationship changeover to the ultimate limit of the strain.
ParabolicRectangular | 3 | Stress with Parabola-rectangle relationship to strain. Parabolic part (1.0 - strain^2) from 0.0 to strain relationship changeover value, constant part from strain relationship changeover value to the ultimate limit of the strain.
PowerRectangular | 4 | Stress with Power-rectangle relationship to strain. Power part (1.0 - strain^x) from 0.0 to strain relationship changeover value, constant part from strain relationship changeover value to the ultimate limit of the strain.

See Also

Autodesk.CodeChecking.Concrete Namespace