GetInternalForces Method

RCSolver..::..GetInternalForces Method
RCSolver Class See Also Send Feedback
Gets the set of internal forces.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public SetOfForces GetInternalForces(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of internal forces could be taken into account: for rebar, concrete or equivalent section (transformed).

Return Value

Returned set is adequate for Rebar, Concrete or Section area. Includes axial force and moments around x-axis and y-axis.

Remarks

Unit depends to the units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Calculation are not performed

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace