ConvertCalcParamsToCurrentVersion Method

MultiStructureServer..::..ConvertCalcParamsToCurrentVersion Method
MultiStructureServer Class See Also Send Feedback
Converts old version of calculation parameters entity to the newest one.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual Entity ConvertCalcParamsToCurrentVersion(
    Entity oldVersion,
    Document document
)

Parameters

oldVersion
Type: Entity
The old version of calculation parameters entity.
document
Type: Document
The document.

Return Value

The newest version of calculation parameters entity.

Implements

ICodeCheckingServer..::..ConvertCalcParamsToCurrentVersion(Entity, Document)

See Also

MultiStructureServer Class
Autodesk.Revit.DB.CodeChecking Namespace