ElementInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
ElementInfo Properties
ElementInfo Class See Also Send Feedback

The ElementInfo type exposes the following members.

Properties

 | Name | Description
Public property | Material | Gets parameters of material for element.
Public property | RebarCovers | Gets parameters of rebar covers for element.
Public property | Sections | Gets sections along element length.
Public property | SectionsParams | Gets parameters of sections along element length.
Public property | Slabs | Gets properties of element's slabs.
Public property | Type | Gets the type of the element.
Public property | Walls | Gets properties of element's walls.

See Also

ElementInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace