ForceCalculationDataDescriptor Members

[image]

Structural Analysis and Code Checking API Reference Guide
ForceCalculationDataDescriptor Members
ForceCalculationDataDescriptor Class Constructors Methods Properties See Also Send Feedback

The ForceCalculationDataDescriptor type exposes the following members.

Constructors

 | Name | Description
Public method | ForceCalculationDataDescriptor | Creates default ForceCalculationPointsDescriptor

Methods

 | Name | Description
Public method | AddBendingForceTypes | Adds bending forcetypes to the data

Properties

 | Name | Description
Public property | ElementId | Gets or sets Revit ElementId for element to which calculation point is assigned
Public property | ForceTypes | Gets internal force types for which calculations are to be conducted
Public property | ForceTypesHashed | Gets hashed internal force types for the whole collection

See Also

ForceCalculationDataDescriptor Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace