SetSurfaceResult Method (, , DomainResultType, IEnumerable(Double))

ResultsPackageBuilder..::..SetSurfaceResult Method (, , DomainResultType, IEnumerable<(Of <(<'Double>)>)>)
ResultsPackageBuilder Class See Also Send Feedback
Function sets specified surface results.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetSurfaceResult(
    ElementId elementId,
    ElementId loadId,
    DomainResultType resultType,
    IEnumerable<double> values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
resultType
Type: Autodesk.Revit.DB.ResultsBuilder..::..DomainResultType
values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>

Exceptions

Exception | Condition
ArgumentException | Specified measurementName doesn't exist.

See Also

ResultsPackageBuilder Class
SetSurfaceResult Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace