Steel Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Steel Properties
Steel Class See Also Send Feedback

The Steel type exposes the following members.

Properties

 | Name | Description
Public property | DesignStrength | The DesignStrength property represents the design strenght of steel (design yield strength).
Public property | HardeningFactor | The HardeningFactor property represents the value of steel hardening over the plastic behaviour.
Public property | ModulusOfElasticity | The ModulusOfElasticity property represents the steel modulus of elasticity (Young modulus).
Public property | StrainUltimateLimit | The StrainUltimateLimit property represents the value of maximum steel strain.

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace