IFieldEditor Methods

[image]

Structural Analysis and Code Checking API Reference Guide
IFieldEditor Methods
IFieldEditor Interface See Also Send Feedback

The IFieldEditor type exposes the following members.

Methods

 | Name | Description
Public method | GetUniqueId | Gets the unique id.
Public method | GetValue | Gets the value in specified display unit type.
Public method | SetAttribute(FieldUIAttribute) | Sets the attribute.
Public method | SetAttribute(String, Object, DisplayUnitType) | Sets spefified attribute.
Public method | SetDocument | Sets the Revit document.
Public method | SetName | Sets the name of control.
Public method | SetUnitType | Sets the type of the unit.
Public method | SetValue | Sets the value in specified display unit type.

See Also

IFieldEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace