MaterialInfo Constructor (MaterialCategory, MaterialProperties, MaterialCharacteristics)

MaterialInfo Constructor (MaterialCategory, MaterialProperties, MaterialCharacteristics)
MaterialInfo Class See Also Send Feedback
Creates new instance.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public MaterialInfo(
    MaterialCategory category,
    MaterialProperties properties,
    MaterialCharacteristics characteristics
)

Parameters

category
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialCategory
properties
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialProperties
characteristics
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialCharacteristics

See Also

MaterialInfo Class
MaterialInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace