Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace

Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace

Classes

 | Class | Description
Public class | SchemaAttribute | Indicates that a class can be converted to the schema.
Public class | SchemaPropertyAttribute | Indicates that a property of the class should be converted to the field in schema.
Public class | UnitAttribute | Describes unit settings for property

SchemaAttribute Class

SchemaAttribute Class
Members Example See Also Send Feedback
Indicates that a class can be converted to the schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class SchemaAttribute : Attribute

Remarks

The id should be changed every time when schema changes (e.g. some property is added, removed or renamed). It is also very important to remember that changing id of the class A which instance is a member of the class B should result in changing id of the class B!

Examples

The schema of Name1 name and already second version:
CopyC#
[Schema("Name1","1E578722-BFF5-4496-B436-CB6C659D93DF","F6F790AF-1762-441D-9AFF-9C822D346E5F")]
public class Class1:SchemaClass
{
}

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes..::..SchemaAttribute

See Also

SchemaAttribute Members
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace