TextBoxAttribute Class

TextBoxAttribute Class
Members See Also Send Feedback
Indicates that particular property will be edited with the TextBox control.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class TextBoxAttribute : FormatFieldAttribute,
    IValidateAttribute

Remarks

TextBoxAttribute provides default formatting which is based on .NET mechanism. Please use dedicated attributes for more accurate formatting or assign specific Format type to this instance (FieldFormat property).

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ControlAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FormatFieldAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..TextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridKeyTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..GridTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..ListTextBoxAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..NumericUpDownAttribute
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..XYZTextBoxAttribute

See Also

TextBoxAttribute Members
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace