DocumentDiagram Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentDiagram Members
DocumentDiagram Class Constructors Methods Properties See Also Send Feedback

The DocumentDiagram type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentDiagram | Initializes a new instance of the DocumentDiagram class.

Methods

 | Name | Description
Public method | SetLabelsX | Sets the labels X.
Public method | SetLabelsY | Sets the labels Y.

Properties

 | Name | Description
Public property | AxisX | Gets the X axis.
Public property | AxisY | Gets the Y axis.
Public property | Height | Gets or sets the height.
Public property | Legend | Gets or sets a value indicating whether legend is visible.
Public property | Series | Gets the list of series.
Public property | Title | Gets or sets the title.
Public property | Width | Gets or sets the width.

See Also

DocumentDiagram Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace