SubSchemaEmbeddedControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
SubSchemaEmbeddedControlAttribute Members
SubSchemaEmbeddedControlAttribute Class Constructors Methods Properties See Also Send Feedback

The SubSchemaEmbeddedControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SubSchemaEmbeddedControlAttribute | Initializes a new instance of the SubSchemaEmbeddedControlAttribute class.

Methods

 | Name | Description
Public method | GetServer | Gets the field value changed observer.

Properties

 | Name | Description
Public property | DrawBorder | Gets or sets a value indicating whether border around control should be drawn.
Public property | ServerUI | Gets or sets the type of the server UI which should be taken (if not set the main server will be taken).
Public property | SetFieldsDescription | Gets or sets a value indicating whether description of the fields inside the control should be set.
Public property | Span | Gets or sets a value indicating whether the embedded control should be extended to whole width of layout.

See Also

SubSchemaEmbeddedControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace