EnumControlAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
EnumControlAttribute Members
EnumControlAttribute Class Constructors Methods Properties See Also Send Feedback

The EnumControlAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | EnumControlAttribute()()()() | Initializes a new instance of the EnumControlAttribute class.
Public method | EnumControlAttribute(Type, PresentationMode, PresentationItem) | Initializes a new instance of the EnumControlAttribute class.
Public method | EnumControlAttribute(Type, PresentationMode, PresentationItem, array<String>[]()[][], array<Object>[]()[][]) | Initializes a new instance of the EnumControlAttribute class.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | EnumType | Gets or sets the type of the enum.
Public property | ImageSize | Gets or sets the size of the image.
Public property | Item | Gets or sets the presentation item.
Public property | Presentation | Gets or sets the presentation mode.
Public property | SubSchemasToValues | Gets or sets the sub schemas to values map.

See Also

EnumControlAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace