DocumentSection Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentSection Members
DocumentSection Class Constructors Methods Properties See Also Send Feedback

The DocumentSection type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentSection()()()() | Initializes a new instance of the DocumentSection class.
Public method | DocumentSection(String, Int16) | Initializes a new instance of the DocumentSection class.
Public method | DocumentSection(DocumentSection, Document, String, Int32, Boolean) | Initializes a new instance of the DocumentSection class.

Methods

 | Name | Description
Public method | GetLevel | Gets the level of the section.
Public method | GetSectionOfName(String) | Gets the section of specific name.
 | GetSectionOfName(String, DocumentBody) | Gets the section of specific name.
Public method | SetAdditionalData | Sets the additional data.

Properties

 | Name | Description
Public property | Anchor | Gets or sets the anchor.
Public property | Body | Gets or sets the body.
Public property | Name | Gets or sets the name.
Public property | ParentDocument | Gets or sets the parent document.
Public property | ParentSection | Gets or sets the parent section.
Public property | Title | Gets or sets the title.

See Also

DocumentSection Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace