ModulusOfElasticity Property

Steel..::..ModulusOfElasticity Property
Steel Class See Also Send Feedback
The ModulusOfElasticity property represents the steel modulus of elasticity (Young modulus).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double ModulusOfElasticity { get; set; }

Field Value

Gets or sets value of the steel modulus of elasticity (Young modulus).

Remarks

Unit: [length^4].
The steel modulus of elasticity (Young modulus) should be in base units for example [Pa],[psi].
Typical values are 200000000000[Pa] 29000000[psi].
This value is used for calculating changeover of stress-strain relationship and equivalent (transformed) characteristic of the reinforced section.
The return value will be in the same unit which has been used.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The concrete Young modulus (modulus of elasticity) must greater than 0.0.

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace