StorageDocument Members

[image]

Structural Analysis and Code Checking API Reference Guide
StorageDocument Members
StorageDocument Class Constructors Methods Properties See Also Send Feedback

The StorageDocument type exposes the following members.

Constructors

 | Name | Description
Public method | StorageDocument | Initializes a new instance of the StorageDocument class.

Methods

 | Name | Description
Public method | Commit | Commits this instance.
Public method | IsReloaded | Determines whether this instance is reloaded.
Public method | OnSynchronized | Reacts after synchronization.
Public method | OnSynchronizing | Reacts on synchronizing.
Public method | Reload | Reloads this instance.

Properties

 | Name | Description
Public property | CalculationParamsManager | The calculation parameters manager.
Public property | LabelsManager | The labels manager.
Public property | ResultBuilderManager | Gets the result builder manager.
Public property | ResultsManager | The results manager.
Public property | RevitDocument | The Revit document.

See Also

StorageDocument Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace