ElementInfo Constructor (ElementSectionsInfo, ElementSectionsParamsInfo, ElementSlabsInfo, MaterialInfo)

ElementInfo Constructor (ElementSectionsInfo, ElementSectionsParamsInfo, ElementSlabsInfo, MaterialInfo)
ElementInfo Class See Also Send Feedback
Creates instance for beam with T-Section.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementInfo(
    ElementSectionsInfo sections,
    ElementSectionsParamsInfo sectionsParams,
    ElementSlabsInfo slabs,
    MaterialInfo material
)

Parameters

sections
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsInfo
sectionsParams
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsParamsInfo
slabs
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSlabsInfo
material
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialInfo

See Also

ElementInfo Class
ElementInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace