XMLName Enumeration

XMLName Enumeration
See Also Send Feedback

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum XMLName

Members

Member name | Value | Description
Unknown | 0 |
Output | 1 |
Input | 2 |
InputSegment | 3 |
Concrete | 4 |
type | 5 |
concData | 6 |
DesignStrength | 7 |
EffectiveHeightReductionFactor | 8 |
Power | 9 |
ModulusOfElasticity | 10 |
StrainRelationChangeOver | 11 |
StrainStressModel | 12 |
StrainUltimateLimit | 13 |
Steel | 14 |
steelData | 15 |
HardeningFactor | 16 |
Geometry | 17 |
Point2D | 18 |
x | 19 |
y | 20 |
Reinforcement | 21 |
Rebar | 22 |
area | 23 |
diam | 24 |
cm | 25 |
mm | 26 |
runTest | 27 |
endTest | 28 |
testTime | 29 |
totalTestTime | 30 |
iterations | 31 |
name | 32 |
SolveForces | 33 |
SolveInternalForces | 34 |
SolveBarsForces | 35 |
topStrain | 36 |
bottomStrain | 37 |
SolveResistance | 38 |
SolveResistanceF | 39 |
SolveResistanceM | 40 |
designAxialForce | 41 |
designMomentX | 42 |
designMomentY | 43 |
resistanceMoment | 44 |
resistanceAxialForce | 45 |
axis | 46 |
direction | 47 |
X | 48 |
Y | 49 |
GetResult | 50 |
ConcreteParameters | 51 |
SteelParameters | 52 |
GeometryParameters | 53 |
ReinforcementParameters | 54 |
CrossSectionCharacteristics | 55 |
Area | 56 |
CenterOfInertia | 57 |
MomentOfInertiaX | 58 |
MomentOfInertiaY | 59 |
ResistanceResult | 60 |
ConcreteResult | 61 |
ConcreteStressArea | 62 |
ConcreteStressGravityCenter | 63 |
SteelResult | 64 |
SteelArea | 65 |
SteelCenterOfInertia | 66 |
SteelMomentOfInertiaX | 67 |
SteelMomentOfInertiaY | 68 |
RcSectionResult | 69 |
EquivalentArea | 70 |
EquivalentCenterOfInertia | 71 |
EquivalentMomentOfInertiaX | 72 |
EquivalentMomentOfInertiaY | 73 |
EquivalentGravityCenter | 74 |
InternalAxialForce | 75 |
InternalMomentX | 76 |
InternalMomentY | 77 |
NeutralAxisAngle | 78 |
NeutralAxisDist | 79 |
StrainMin | 80 |
StrainMax | 81 |
StrainSteelMax | 82 |
StrainSteelMin | 83 |
AllParameters | 84 |
SectionC | 85 |
SectionR | 86 |
SectionT | 87 |
d | 88 |
b | 89 |
h | 90 |
hf | 91 |
bf | 92 |
Error | 93 |

See Also

Autodesk.CodeChecking.Concrete Namespace