ElementType Enumeration

ElementType Enumeration
See Also Send Feedback
Describes the type of the element

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ElementType

Members

Member name | Value | Description
Unknown | 0 | Unknown.
Bar | 8 | Bar
Beam | 1 | Beam.
Column | 2 | Column.
Surface | 128 | Surface
Slab | 16 | Slab.
Wall | 32 | Wall.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace