StorageManager Members

[image]

Structural Analysis and Code Checking API Reference Guide
StorageManager Members
StorageManager Class Constructors Methods Properties See Also Send Feedback

The StorageManager type exposes the following members.

Constructors

 | Name | Description
Public method | StorageManager | Initializes a new instance of the StorageManager class.

Methods

 | Name | Description
Public method | GetSchemaId |
Public method | GetSchemaIdForServer |
Public method | GetServerIdOfStorageSchema |
Public method | ValidateCategory(BuiltInCategory) |
Public method | ValidateCategory(BuiltInCategory, String, Guid) |

Properties

 | Name | Description
Public property | Reloaded | Gets a value indicating whether this StorageManager is reloaded.
Public property | RevitDocument | The Revit document.
Public property | StorageDocument | The storage manager this instance belongs to.

See Also

StorageManager Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace