Server(TCalculationParam, TLabel, TResult) Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Methods
Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class See Also Send Feedback

The Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ConvertCalcParamsToCurrentVersion | Converts old version of calculation parameters entity to the newest one.
Public method | ConvertLabelToCurrentVersion | Converts old version of label entity to the newest one.
Public method | ConvertResultToCurrentVersion | Converts old version of result entity to the newest one.
Public method | GetCalculationParamSchema | Returns schema for calculation parameters.
Public method | GetDefaultCalcParams | Returns default value of calculation parameters entity.
Public method | GetDefaultLabel | Returns default value of label entity.
Public method | GetDescription | Implement this method to return a description of the server.
Public method | GetLabelSchema | Returns schema for labels.
Public method | GetName | Implement this method to return the name of the server.
Public method | GetOutputPackageResultTypes | Gets the output package result types. This information is needed to create proper ResultsBuilder Package.
Public method | GetOutputPackageUnitSystem | Gets the output package unit system. This information is needed to create proper ResultsBuilder Package.
Public method | GetResultsSchema | Returns schema for results.
Public method | GetServerId | Implement this method to return the id of the server.
Public method | GetServiceId | Implement this method to return the id of the service.
Public method | GetSupportedCategories | Returns the list of supported categories.
Public method | GetSupportedMaterials | Returns the list of supported materials.
Public method | GetVendorId | Implement this method to return the id of the vendor of the server.
Public method | GetVersion | Gets the version of code checking server.
Public method | IsContextSupported | Determines whether specified context is supported.
Public method | LoadCasesAndCombinationsSupport | Determines whether server supports load combinations, they will be exposed on the dialog.
Public method | ResultBuilderPackagesAsInputData | Determines whether server supports load combinations, they will be exposed on the dialog.
Public method | Verify | Runs calculation.

See Also

Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> Class
Autodesk.Revit.DB.CodeChecking Namespace