CalculationParam Methods

[image]

Structural Analysis and Code Checking API Reference Guide
CalculationParam Methods
CalculationParam Class See Also Send Feedback

The CalculationParam type exposes the following members.

Methods

 | Name | Description
Public method | GetInputResultPackage | Gets the input package for specific code.
Public method | GetInputResultPackageId | Gets the input package for specific code.
Public method | GetLoadCasesAndCombinations | Gets load combinations.
Public method | GetOutputResultPackage(Guid) | Gets the output package.
Public method | GetOutputResultPackage(Guid, Guid, Boolean) | Gets the output package.
Public method | GetOutputResultPackageBuilder(Guid) |
Public method | GetOutputResultPackageBuilder(Guid, Guid) | Gets the output package builder.
Public method | GetServerPackage(Guid, Boolean) |
Public method | GetServerPackage(Guid, Guid, Boolean) |
Public method | SetInputResultPackage | Sets the input package.
Public method | SetLoadCasesAndCombinations | Sets load combinations.
Public method | SetServerPackage |

See Also

CalculationParam Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace