GetForceForCase Method (, ForceResultsPackageDescriptor, ForceLoadCaseDescriptor, IEnumerable(CalcPoint), ForceType)

ForceResultsCache..::..GetForceForCase Method (, ForceResultsPackageDescriptor, ForceLoadCaseDescriptor, IEnumerable<(Of <(<'CalcPoint>)>)>, ForceType)
ForceResultsCache Class See Also Send Feedback
Gets internal forces in specified calculation points in a given element for a specific resPackage, load and force type

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public List<double> GetForceForCase(
    ElementId elementId,
    ForceResultsPackageDescriptor resultPackageDescriptor,
    ForceLoadCaseDescriptor caseDescriptor,
    IEnumerable<CalcPoint> calculationPoints,
    ForceType forceType
)

Parameters

elementId
Type: ElementId
Revit ElementId
resultPackageDescriptor
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceResultsPackageDescriptor
Result package descriptor
caseDescriptor
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceLoadCaseDescriptor
Load case descriptor
calculationPoints
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' CalcPoint >)>)>
List of calculation points corresponding to the returned force list
forceType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ForceType
Force type

Return Value

List of forces

See Also

ForceResultsCache Class
GetForceForCase Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace