CategorizeElements Method

Tools..::..CategorizeElements Method
Tools Class See Also Send Feedback
Categorizes elements based on material and category.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Dictionary<StructuralAssetClass, HashSet<BuiltInCategory>> CategorizeElements(
    List<Element> elements
)

Parameters

elements
Type: System.Collections.Generic..::..List <(Of <(<'Element>)>)>
The elements.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace