SetStrainStressModelBiLinear Method

Concrete..::..SetStrainStressModelBiLinear Method
Concrete Class See Also Send Feedback
Sets all appropriate parameters for a bi-linear stress-strain relationship.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetStrainStressModelBiLinear(
    double designStrength,
    double strainUltimateLimit,
    double modulusOfElasticity,
    double strainRelationChangeOver
)

Parameters

designStrength
Type: System..::..Double
The concrete design strength.
Unit: [force per length^2].
strainUltimateLimit
Type: System..::..Double
The concrete strain at failure.
Unit: [dimensionless].
modulusOfElasticity
Type: System..::..Double
The concrete modulus of elasticity (Young modulus).
Unit: [force per length^2]
strainRelationChangeOver
Type: System..::..Double
The concrete strain value which changes the type of stress-strain relationship.
Unit: [dimensionless].

Remarks

The parameters should be defined in base units for example [m],[N], or [pound],[in].
All set values for concrete, steel, geometry and internal forces should have some consistent units.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace