ElementInfo Constructor (ElementType, ElementSectionsInfo, ElementSectionsParamsInfo, MaterialInfo)

ElementInfo Constructor (ElementType, ElementSectionsInfo, ElementSectionsParamsInfo, MaterialInfo)
ElementInfo Class See Also Send Feedback
Creates instance for beam or column.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ElementInfo(
    ElementType eType,
    ElementSectionsInfo sections,
    ElementSectionsParamsInfo sectionsParams,
    MaterialInfo material
)

Parameters

eType
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementType
sections
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsInfo
sectionsParams
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..ElementSectionsParamsInfo
material
Type: Autodesk.Revit.DB.CodeChecking.Engineering..::..MaterialInfo

See Also

ElementInfo Class
ElementInfo Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace