FormatValueToString Method

UnitUtilsExt..::..FormatValueToString Method
UnitUtilsExt Class See Also Send Feedback
Formats a value into a string based on formatting options.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static string FormatValueToString(
    Units units,
    UnitType unitType,
    string listSeparator,
    List<double> values,
    bool maxAccuracy,
    bool forEditing
)

Parameters

units
Type: Units
The units object.
unitType
Type: UnitType
Type of the unit.
listSeparator
Type: System..::..String
The list separator.
values
Type: System.Collections.Generic..::..List <(Of <(<' Double >)>)>
The values.
maxAccuracy
Type: System..::..Boolean
True if the value should be rounded to an increased accuracy level appropriate for editing or understanding the precise value stored in the model. False if the accuracy specified by the FormatOptions should be used, appropriate for printed drawings.
forEditing
Type: System..::..Boolean
True if the formatting should be modified as necessary so that the formatted string can be successfully parsed, for example by suppressing digit grouping. False if unmodified settings should be used, suitable for display only..

Return Value

See Also

UnitUtilsExt Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace