Autodesk.Revit.DB.CodeChecking.Storage Namespace

Autodesk.Revit.DB.CodeChecking.Storage Namespace

Classes

 | Class | Description
Public class | CalculationParam | Represents calculation parameters.
Public class | CalculationParamsManager | Represents the manager for calculation parameters.
Public class | Label | Represents label.
Public class | LabelsManager | Represent the manager of labels.
Public class | Result | Represents result.
Public class | ResultBuilderManager | Manages ResultBuilder and common access to it
Public class | ResultsManager | Represents the result manager
Public class | ResultStatus | Represents result status
Public class | ResultStatusList | Represents result status list
Public class | ResultStatusMessage | Represent ResultStatus message
Public class | ResultStatusMessageItem | Represents the single item of ResultStatusMessage
Public class | ServerCalculationParam | Represents calculations parameters for specified server
Public class | ServerData | Represents server data
Public class | ServerLabel | Represents label for specific server.
Public class | ServerPackage | Represents the server package
Public class | ServerResult | Represents result for specific server
Public class | ServerStorage | Base class for all servers data
Public class | Storage<(Of <(<'T>)>)> | Base class for all storage classes.
Public class | StorageDocument | Represents the storage document which manages data for one particular Revit document.
Public class | StorageManager | Base class for all storage managers
Public class | StorageService | Represents the storage service.

Interfaces

 | Interface | Description
Public interface | IStorage | Base interface for all storage classes

Enumerations

 | Enumeration | Description
Public enumeration | Status | Represents status of result

CalculationParam Class

CalculationParam Class
Members See Also Send Feedback
Represents calculation parameters.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CalculationParam : Storage<ServerCalculationParam>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..Storage <(Of <(<' ServerCalculationParam >)>)>
Autodesk.Revit.DB.CodeChecking.Storage..::..CalculationParam

See Also

CalculationParam Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace