SlabContour Members

[image]

Structural Analysis and Code Checking API Reference Guide
SlabContour Members
SlabContour Class Constructors Methods Properties See Also Send Feedback

The SlabContour type exposes the following members.

Constructors

 | Name | Description
Public method | SlabContour(SlabInfo) | Construct object as SlabElementType.Contour type.
Public method | SlabContour(SlabInfo, SlabContourType) | Construct object.

Methods

 | Name | Description
Public method | GetEdge | Returns edge of specific coordinates.
Public method | IsContourInside(List<(Of <<'(XYZ>)>>)) | Checks if contour is inside current one.
Public method | IsContourInside(SlabContour) | Checks if contour is inside current one.
Public method | IsCrossingLine | Checks if line is crossing current contour.
Public method | IsPointInside | Checks if point is inside contour.
Public method | IsPointOnEdge | Checks if point is on edge.

Properties

 | Name | Description
Public property | ContourType | Type of slab contour.
Public property | Edges | List of edges.
Public property | IsClockWise | Check if contour is clockwise.
Public property | IsClosed | Checks if contour is closed
Public property | Nodes | List of nodes.

See Also

SlabContour Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace