SetBarResult Method (, , String, IEnumerable(Double))

ResultsPackageBuilder..::..SetBarResult Method (, , String, IEnumerable<(Of <(<'Double>)>)>)
ResultsPackageBuilder Class See Also Send Feedback
Function sets specified bar results.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
[ObsoleteAttribute("Use SetArbitraryResult instead.")]
public void SetBarResult(
    ElementId elementId,
    ElementId loadId,
    string measurementName,
    IEnumerable<double> values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
measurementName
Type: System..::..String
values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>

Exceptions

Exception | Condition
InvalidOperationException | Domain not defined yet.
ArgumentException | Specified measurementName doesn't exist.

See Also

ResultsPackageBuilder Class
SetBarResult Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace