ElementSlabsInfo Members

[image]

Structural Analysis and Code Checking API Reference Guide
ElementSlabsInfo Members
ElementSlabsInfo Class Constructors Methods Properties See Also Send Feedback

The ElementSlabsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSlabsInfo(ElementTSectionInfo) | Creates instance for structural framing element with adjoining elements wchich are a slabs.
Public method | ElementSlabsInfo(SlabInfo) | Creates instance for element wchich is a slab.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | AsElement | if element is a slab gets SlabInfo object.
Public property | TSection | if element is a beam gets T - section if possible.

See Also

ElementSlabsInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace