Autodesk.Revit.UI.CodeChecking Namespace

Autodesk.Revit.UI.CodeChecking Namespace

Classes

 | Class | Description
Public class | MultiStructureServer | The base class for all servers that support more than one category or material.
Public class | Server<(Of <(<'TCalculationParam, TLabel>)>)> | Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform.
Public class | ServiceUI | Helper service for UI layer.

Interfaces

 | Interface | Description
Public interface | ICodeCheckingServerUI | Base interface for code checking UI servers.

ICodeCheckingServerUI Interface

ICodeCheckingServerUI Interface
Members See Also Send Feedback
Base interface for code checking UI servers.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public interface ICodeCheckingServerUI : IServerUI,
    IResource

See Also

ICodeCheckingServerUI Members
Autodesk.Revit.UI.CodeChecking Namespace