DataSourceFormatFieldAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
DataSourceFormatFieldAttribute Members
DataSourceFormatFieldAttribute Class Constructors Methods Fields Properties See Also Send Feedback

The DataSourceFormatFieldAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | DataSourceFormatFieldAttribute()()()() | Initializes a new instance of the DataSourceFormatFieldAttribute class.
Public method | DataSourceFormatFieldAttribute(String, Type) | Initializes a new instance of the DataSourceFormatFieldAttribute class.
Public method | DataSourceFormatFieldAttribute(Type, array<Object>[]()[][]) | Initializes a new instance of the DataSourceFormatFieldAttribute class.

Methods

 | Name | Description

Fields

Name | Description
PropertyDataSource | Describes attribute indicating the datasource.
PropertyDataSourceKey | Describes attribute indicating the key of datasource.

Properties

 | Name | Description
Public property | DataSourceKey | Describes the key of the source which will be used to get data from apropriate server via GetDataSource method. The priority has Items controls.
Public property | Items | The list of items.

See Also

DataSourceFormatFieldAttribute Class
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace