BuildControls Method

Layout..::..BuildControls Method
Layout Class See Also Send Feedback
Generates list of controls based on type.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<Control> BuildControls(
    Type type,
    IResource server,
    bool respectCategories
)

Parameters

type
Type: System..::..Type
The type.
server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The server.
respectCategories
Type: System..::..Boolean
if set to true categories will be respected.

Return Value

See Also

Layout Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace