DocumentBody Members

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentBody Members
DocumentBody Class Constructors Methods Properties See Also Send Feedback

The DocumentBody type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentBody | Initializes the instance of the DocumentBody.

Methods

 | Name | Description
 | Build(Entity, Document) | Creates document body based on entity.
 | Build(SchemaClass, IResource, Document) | Generates the document body based on the instance of SchemaClass.
 | FillBody | Fills the body of the document based on the instance of Schema class.
Public method | GetElementCount | Gets the element count.
 | GetElementList | Gets the element list.

Properties

 | Name | Description
Public property | Elements | List of document elements.

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace