ResultStatusMessageItem Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatusMessageItem Members
ResultStatusMessageItem Class Constructors Methods Properties See Also Send Feedback

The ResultStatusMessageItem type exposes the following members.

Constructors

 | Name | Description
Public method | ResultStatusMessageItem()()()() | Initializes a new instance of the ResultStatusMessageItem class.
Public method | ResultStatusMessageItem(String) | Initializes a new instance of the ResultStatusMessageItem class.
Public method | ResultStatusMessageItem(UnitType, DisplayUnitType, Double) | Initializes a new instance of the ResultStatusMessageItem class.

Methods

 | Name | Description
Public method | GetFormated | Gets the formated message.

Properties

 | Name | Description
Public property | DisplayUnit | Gets or sets the display unit value is defined in.
Public property | Text | Gets or sets the text.
Public property | Unit | Gets or sets the unit.
Public property | Value | Gets or sets the value.

See Also

ResultStatusMessageItem Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace