DesignStrength Property

Concrete..::..DesignStrength Property
Concrete Class See Also Send Feedback
The DesignStrength property represents the design strenght of concrete.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double DesignStrength { get; set; }

Field Value

Gets or sets concrete design strength

Remarks

Unit: [force per length^2].
Concrete design strength should be in base units for example [Pa] or [psi].
Typical values are in the range between 1000000 and 6000000 [Pa] or 3000 and 10000 [psi].
The return value will be in the same unit which has been used for strength measurement and should be consistent with units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The concrete strength must be greater than 0.0.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace