Server(TCalculationParam, TLabel) Class

Server<(Of <(<'TCalculationParam, TLabel>)>)> Class
Members See Also Send Feedback
Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform.

Namespace: Autodesk.Revit.UI.CodeChecking
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Server<TCalculationParam, TLabel> : ICodeCheckingServerUI,
    IServerUI, IResource
where TCalculationParam : new(), SchemaClass
where TLabel : new(), SchemaClass

Type Parameters

TCalculationParam
The class representing calculation parameters.
TLabel
The class representing labels.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.CodeChecking..::..Server<(Of <(<'TCalculationParam, TLabel>)>)>

See Also

Server<(Of <(<'TCalculationParam, TLabel>)>)> Members
Autodesk.Revit.UI.CodeChecking Namespace