FilterElements Method (, List(), List(Type))

Tools..::..FilterElements Method (, List<(Of <(<'>)>)>, List<(Of <(<'Type>)>)>)
Tools Class See Also Send Feedback
This method filters revit's elements by BuiltInCategory

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static IList<Element> FilterElements(
    Document doc,
    List<BuiltInCategory> categories,
    List<Type> types
)

Parameters

doc
Type: Document
Revit document
categories
Type: System.Collections.Generic..::..List <(Of <(<'BuiltInCategory>)>)>
The list of categories
types
Type: System.Collections.Generic..::..List <(Of <(<' Type >)>)>
The list of types.

Return Value

Collection of revit's elements

See Also

Tools Class
FilterElements Overload
Autodesk.Revit.DB.CodeChecking Namespace