Steel Class

Steel Class
Members See Also Send Feedback
Represents the class for steel behaviors definition.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public class Steel : IRCSolverMember, IDisposable

Remarks

Including parameters of steel and method for calculating the stress in steel for the given strain. The parameters should be defined in base units for example [m],[N], or [pound],[in]. All set values should have consistent units. The units should be the same for concrete, steel, geometry and internal forces.

Inheritance Hierarchy

System..::..Object
IRCSolverMember
Autodesk.CodeChecking.Concrete..::..Steel

See Also

Steel Members
Autodesk.CodeChecking.Concrete Namespace