GetStrainMax Method

RCSolver..::..GetStrainMax Method
RCSolver Class See Also Send Feedback
Gets maximum strain.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetStrainMax(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of strain to be returned: for rebar or concrete only.

Return Value

Returns maximum strain in concrete or in the rebar.

Remarks

This method could be used only for concrete and rebars, for section, this method throws exception.
If calculation are not performed, this method throws exception as well.

Exceptions

Exception | Condition
 | Calculation are not performed
System..::..ArgumentException | This method could be used only for concrete and rebars.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace