SetArbitraryResult Method

ResultsPackageBuilder..::..SetArbitraryResult Method
ResultsPackageBuilder Class See Also Send Feedback
Function sets specified arbitrary result.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void SetArbitraryResult(
    ElementId elementId,
    ElementId loadId,
    string measurementName,
    IEnumerable<double> values
)

Parameters

elementId
Type: ElementId
loadId
Type: ElementId
measurementName
Type: System..::..String
values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>

Exceptions

Exception | Condition
InvalidOperationException | Domain not defined yet.
ArgumentException | Specified measurementName doesn't exist.
ArgumentException | Measurement of name 'measurementName' is load case dependent. The loadId parameter can not be null.

See Also

ResultsPackageBuilder Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace