ISchemaEditor Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ISchemaEditor Methods
ISchemaEditor Interface See Also Send Feedback

The ISchemaEditor type exposes the following members.

Methods

 | Name | Description
Public method | ExpandCategory | Expands the category.
Public method | GetEntity | Returns entity based on current control settings.
Public method | GetFieldEditor | Gets the field editor.
Public method | GetObject | Returns entity based on current control settings.
Public method | GetValue | Gets value of specific field
Public method | OpenSubSchemaDialog | Opens the sub schema dialog.
Public method | RefreshEditor | Refreshes the control.
Public method | SetAttribute | Sets the attributes of the field.
Public method | SetCategoryAttribute | Sets the category attributes.
Public method | SetEntity | Sets entity.
Public method | SetImageSourceAttribute | Sets the image attribute.
Public method | SetObject | Sets entity.
Public method | SetTextBlockContentAttribute | Sets the text block content attribute.
Public method | SetValue | Sets value for specific field

See Also

ISchemaEditor Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace