GetUIAttribute Method

FieldControl..::..GetUIAttribute Method
FieldControl Class See Also Send Feedback
Gets the UI attribute.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static FieldUIAttribute GetUIAttribute(
    ContainerType container,
    Type typeForSchema,
    DefaultFieldControlAttribute defaultControl
)

Parameters

container
Type: ContainerType
The container.
typeForSchema
Type: System..::..Type
The type for schema.
defaultControl
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..DefaultFieldControlAttribute
The default control.

Return Value

See Also

FieldControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace