Tools Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Tools Methods
Tools Class See Also Send Feedback

The Tools type exposes the following members.

Methods

Name | Description
CategorizeElements | Categorizes elements based on material and category.
EnumHas | Determines if the enum value intersects with other enum value.
FilterElements(Document, array<BuiltInCategory>[]()[][]) | This method filters revit's elements by BuiltInCategory
FilterElements(Document, array<Type>[]()[][]) | This method filters revit's elements by Type
FilterElements(Document, List<(Of <<'(BuiltInCategory>)>>), List<(Of <<'(Type>)>>)) | This method filters revit's elements by BuiltInCategory
GetCategoryOfElement | Returns category of element.
GetClassMaterialOfElement | Gets the material class of the element.
GetDataStorage | Gets the data storage which contains specific schema inside.
GetDataStorageList | Gets the data storage list with data saved.
GetElementsWithDataOfSchema<(Of <<'(T>)>>)(Guid, Document) | Gets the elements with data of schema stored inside.
GetElementsWithDataOfSchema<(Of <<'(T>)>>)(Type, Document) | Gets the data storage.
GetMaterialOfElement | Gets the material assigned to element.
GetPhysicalElement | Gets the physical element if the input element is of analytical model type.
GetStructuralAssetClass | Gets the structural asset class.

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace