SteelExceptionEnum Enumeration

SteelExceptionEnum Enumeration
See Also Send Feedback
Classification of exceptions that could be thrown in time of creation the concrete parameters.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum SteelExceptionEnum

Members

Member name | Value | Description
DesignStrength | 0 | The steel design strength must be greater than 0.0
StrainUltimateLimit | 1 | The steel strain at failure must be greater than 0.0. The steel strain at failure can't be less than the design strength divided by the modulus of elasticity.
ModulusOfElasticity | 2 | The steel modulus of elasticity (Young modulus ) must greater than 0.0
HardeningFactor | 3 | The hardening factor cannot be less than 1.0

See Also

Autodesk.CodeChecking.Concrete Namespace