CreateLoadCombinations Method (String, List(List()), List(Double))

LoadCombinationUtils..::..CreateLoadCombinations Method (String, List<(Of <(<'List<(Of <(<'>)>)>>)>)>, List<(Of <(<'Double>)>)>)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations by performing sum.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCombinationPreview> CreateLoadCombinations(
    string baseName,
    List<List<LoadCaseArray>> loadCasesSets,
    List<double> factors
)

Parameters

baseName
Type: System..::..String
The base name
loadCasesSets
Type: System.Collections.Generic..::..List <(Of <(<' List <(Of <(<'LoadCaseArray>)>)>>)>)>
The list of load cases sets
factors
Type: System.Collections.Generic..::..List <(Of <(<' Double >)>)>
The list of factors

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinations Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace