GetSurfaceGraphs Method (ICollection(), ICollection(), ICollection(SurfaceResultType))

ResultsPackage..::..GetSurfaceGraphs Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'SurfaceResultType>)>)>)
ResultsPackage Class See Also Send Feedback
Return list of planar results for given input parameters.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceGraph> GetSurfaceGraphs(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadIds,
    ICollection<SurfaceResultType> resultsTypes
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsTypes
Type: System.Collections.Generic..::..ICollection <(Of <(<' SurfaceResultType >)>)>

See Also

ResultsPackage Class
GetSurfaceGraphs Overload
Autodesk.Revit.DB.ResultsBuilder Namespace