SlabAdjoiningRevitElementType Enumeration

SlabAdjoiningRevitElementType Enumeration
See Also Send Feedback
Defines type of adjoining Revit element.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum SlabAdjoiningRevitElementType

Members

Member name | Value | Description
FamilyInstance | 0 | Structural framing element.
CrossingFamilyInstance | 1 | Structural column crossing element.
UpperFamilyInstance | 2 | Structural column element adjoining from the top.
LowerFamilyInstance | 3 | Structural column element adjoining from the bottom.
Wall | 4 | Wall adjoining the side.
UpperWall | 5 | Wall adjoining from the top.
LowerWall | 6 | Wall adjoining from the bottom.
None | 7 | None.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace