GetDataStorage Method

Tools..::..GetDataStorage Method
Tools Class See Also Send Feedback
Gets the data storage which contains specific schema inside.

Namespace: Autodesk.Revit.DB.CodeChecking
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static DataStorage GetDataStorage(
    Guid schemaId,
    Document document,
    bool create
)

Parameters

schemaId
Type: System..::..Guid
The schema id.
document
Type: Document
The document.
create
Type: System..::..Boolean
if set to true create new DataStorage if not exist.

Return Value

See Also

Tools Class
Autodesk.Revit.DB.CodeChecking Namespace