SetModelIdealElastoPlastic Method

Steel..::..SetModelIdealElastoPlastic Method
Steel Class See Also Send Feedback
Sets all appropriate parameters for steel with horizontal top branch (Ideal elasto-plactic behaviour).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public void SetModelIdealElastoPlastic(
    double designStrength,
    double strainUltimateLimit,
    double modulusOfElasticity
)

Parameters

designStrength
Type: System..::..Double
The steel design strength.
Unit: [force per length^2].
strainUltimateLimit
Type: System..::..Double
The steel strain at failure.
Unit: [dimensionless].
modulusOfElasticity
Type: System..::..Double
The steel modulus of elasticity (Young modulus).
Unit: [force per length^2]

Remarks

The values should be in the base unit and it should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The steel design strength must be greater than 0.0.
System..::..ArgumentException | The steel design strain at failure must be greater than 0.0.
System..::..ArgumentException | The steel Young modulus (modulus of elasticity) must greater than 0.0.
System..::..ArgumentException | The steel strain at failure can't be less than the design strength divided by the modulus of elasticity

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace