ResultType Enumeration

ResultType Enumeration
See Also Send Feedback
Identificator for Reinforced Concrete section results

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum ResultType

Members

Member name | Value | Description
Unknown | 0 | Unknown
Abottom | 1 | Longitudinal reinforcement, bottom (bar element)
Atop | 2 | Longitudinal reinforcement, top (bar element)
Aleft | 3 | Longitudinal reinforcement, left (bar element)
Aright | 4 | Longitudinal reinforcement, right (bar element)
StirrSpac | 5 | Stirrup spacing (bar element)
AxxBottom | 6 | Reinforcement xx, bottom (surface element)
AxxTop | 7 | Reinforcement xx, top (surface element)
AyyBottom | 8 | Reinforcement yy, bottom (surface element)
AyyTop | 9 | Reinforcement yy, top (surface element)
UxMin | 10 | Calculated Deflection X, minimum
UyMin | 11 | Calculated Deflection Y, minimum
UzMin | 12 | Calculated Deflection Z, minimum
UxMax | 13 | Calculated Deflection X, maximum
UyMax | 14 | Calculated Deflection Y, maximum
UzMax | 15 | Calculated Deflection Z, maximum
GetLinearResultType |  | Converts ResultType into ResultBuilder LinearResultType
GetSurfaceResultType |  | Converts ResultType into ResultBuilder SurfaceResultType

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace