Concrete Properties

[image]

Structural Analysis and Code Checking API Reference Guide
Concrete Properties
Concrete Class See Also Send Feedback

The Concrete type exposes the following members.

Properties

 | Name | Description
Public property | DesignStrength | The DesignStrength property represents the design strenght of concrete.
Public property | EffectiveHeightReductionFactor | The EffectiveHeightReductionFactor property represents the reduction factor of the compression zone height.
Public property | ModulusOfElasticity | The ModulusOfElasticity property represents the concrete modulus of elasticity (Young modulus).
Public property | Power | The Power property represents the power for an power-linar stress-strain relationship.
Public property | StrainRelationChangeOver | The StrainRelationChangeOver property represents the strain which changes the type of stress-strain relationship.
Public property | StrainStressModel | The StrainStressModel property represents the type of stress-strain relationship.
Public property | StrainUltimateLimit | The StrainUltimateLimit property represents the value of maximum strain.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace