DocumentBody Methods

[image]

Structural Analysis and Code Checking API Reference Guide
DocumentBody Methods
DocumentBody Class See Also Send Feedback

The DocumentBody type exposes the following members.

Methods

 | Name | Description
 | Build(Entity, Document) | Creates document body based on entity.
 | Build(SchemaClass, IResource, Document) | Generates the document body based on the instance of SchemaClass.
 | FillBody | Fills the body of the document based on the instance of Schema class.
Public method | GetElementCount | Gets the element count.
 | GetElementList | Gets the element list.

See Also

DocumentBody Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace