SetOfForces Constructor (Double, Double, Double)

SetOfForces Constructor (Double, Double, Double)
SetOfForces Class See Also Send Feedback
The SetOfForces class constructor with AxialForce, MomentX and MomentY values set as parameter.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public SetOfForces(
    double n,
    double mx,
    double my
)

Parameters

n
Type: System..::..Double
The axial force.
Unit: [force].
mx
Type: System..::..Double
The bending moment around x-axis.
Unit: [force*length].
my
Type: System..::..Double
The bending moment around y-axis.
Unit: [force*length].

Remarks

The internal forces are described in coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
AxialForce(N) - The compresion have positive sign.
MomentX(Mx) - The bending moment around x'-axis.
MomentY(My) - The bending moment around y'-axis.
The units should be consistent for concrete, steel, geometry and internal forces.

See Also

SetOfForces Class
SetOfForces Overload
Autodesk.CodeChecking.Concrete Namespace