Server(TData) Class

Server<(Of <(<'TData>)>)> Class
Members See Also Send Feedback
Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by load combination system.

Namespace: Autodesk.Revit.UI.CodeChecking.LoadCombination
Assembly: CodeChecking.UI (in CodeChecking.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Server<TData> : ILoadCombinationServerUI,
    IServerUI, IResource
where TData : new(), SchemaClass

Type Parameters

TData
The type of the data.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.CodeChecking.LoadCombination..::..Server<(Of <(<'TData>)>)>

See Also

Server<(Of <(<'TData>)>)> Members
Autodesk.Revit.UI.CodeChecking.LoadCombination Namespace