BuildDocument Method (Document, , DetailLevel)

DocumentBuilder..::..BuildDocument Method (Document, , DetailLevel)
DocumentBuilder Class See Also Send Feedback
Builds document file.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public string BuildDocument(
    Document document,
    Document revitDocument,
    DetailLevel detailLevel
)

Parameters

document
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..Document
The document structure.
revitDocument
Type: Document
The revit document.
detailLevel
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation..::..DetailLevel
The detail level.

Return Value

The path of the file.

See Also

DocumentBuilder Class
BuildDocument Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace