LoadCombinationUtils Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationUtils Methods
LoadCombinationUtils Class See Also Send Feedback

The LoadCombinationUtils type exposes the following members.

Methods

 | Name | Description
 | CopyLoadCaseArray | Copies the load case array.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>)) | Creates load combinations.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations.
 | CreateLoadCombinations(String, List<(Of <<'(List<(Of <<'(LoadCaseArray>)>>)>)>>), List<(Of <<'(Double>)>>)) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinations(String, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), Double) | Creates load combinations by performing sum.
 | CreateLoadCombinationSets(List<(Of <<'(LoadCaseArray>)>>), Double, List<(Of <<'(array<Double>[]()[][]>)>>)%) | Creates load combinations.
 | CreateLoadCombinationSets(List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>), Double, List<(Of <<'(LoadCaseArray>)>>), List<(Of <<'(array<Double>[]()[][]>)>>), Double, List<(Of <<'(array<Double>[]()[][]>)>>)%) | Sums load combinations.
 | GetLoadCaseNature | Gets the load case nature.
 | GetLoadCases | Gets the load cases.
 | GroupLoadCasesDueToCategory | Groups the load cases due to nature.
 | PerformAnd | Performs the and operation.
 | PerformOrExlusive | Performs the or exlusive operation.
 | PerformOrInclusive | Performs the or inclusive operation.

See Also

LoadCombinationUtils Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace