GetLoadCaseDescriptors Method (, IEnumerable())

ForceResultsCache..::..GetLoadCaseDescriptors Method (, IEnumerable<(Of <(<'>)>)>)
ForceResultsCache Class See Also Send Feedback
Creates hashset of loadDescriptors

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering.Tools
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static HashSet<ForceLoadCaseDescriptor> GetLoadCaseDescriptors(
    Document document,
    IEnumerable<ElementId> loads
)

Parameters

document
Type: Document
Revit document
loads
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'ElementId>)>)>
Collection of revit load ElementId's

Return Value

hashset of loadDescriptors

See Also

ForceResultsCache Class
GetLoadCaseDescriptors Overload
Autodesk.Revit.DB.CodeChecking.Engineering.Tools Namespace