CreateLoadCombinations Method (String, List(), Double, List(), Double, List(), Double, List(), Double)

LoadCombinationUtils..::..CreateLoadCombinations Method (String, List<(Of <(<'>)>)>, Double, List<(Of <(<'>)>)>, Double, List<(Of <(<'>)>)>, Double, List<(Of <(<'>)>)>, Double)
LoadCombinationUtils Class See Also Send Feedback
Creates load combinations by performing sum.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCombinationPreview> CreateLoadCombinations(
    string baseName,
    List<LoadCaseArray> loadCasesSets1,
    double factor1,
    List<LoadCaseArray> loadCasesSets2,
    double factor2,
    List<LoadCaseArray> loadCasesSets3,
    double factor3,
    List<LoadCaseArray> loadCasesSets4,
    double factor4
)

Parameters

baseName
Type: System..::..String
The base name
loadCasesSets1
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 1.
factor1
Type: System..::..Double
The factor 1.
loadCasesSets2
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 2.
factor2
Type: System..::..Double
The factor 2.
loadCasesSets3
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 3.
factor3
Type: System..::..Double
The factor 2.
loadCasesSets4
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 3.
factor4
Type: System..::..Double
The factor 2.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinations Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace