AddMeasurement Method (String, MeasurementResultType, , , MeasurementDependencyType)

ResultsPackageBuilder..::..AddMeasurement Method (String, MeasurementResultType, , , MeasurementDependencyType)
ResultsPackageBuilder Class See Also Send Feedback
AddMeasurement method creates the additional type of results. It allows to define types of results that are not standard within the static analysis scope. The Name and measurementResultType pair must be unique in the package.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public void AddMeasurement(
    string name,
    MeasurementResultType measurementResultType,
    UnitType unitType,
    DisplayUnitType displayUnitType,
    MeasurementDependencyType dependencyType
)

Parameters

name
Type: System..::..String
measurementResultType
Type: Autodesk.Revit.DB.ResultsBuilder..::..MeasurementResultType
unitType
Type: UnitType
displayUnitType
Type: DisplayUnitType
dependencyType
Type: Autodesk.Revit.DB.ResultsBuilder..::..MeasurementDependencyType

Exceptions

Exception | Condition
ArgumentException | MeasurementResultType of specified Name and measurementResultType already exists.

See Also

ResultsPackageBuilder Class
AddMeasurement Overload
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace