EnumControlAttribute Constructor (Type, PresentationMode, PresentationItem, String[], Object[])

EnumControlAttribute Constructor (Type, PresentationMode, PresentationItem, array<String>[]()[][], array<Object>[]()[][])
EnumControlAttribute Class See Also Send Feedback
Initializes a new instance of the EnumControlAttribute class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public EnumControlAttribute(
    Type enumType,
    PresentationMode presentationMode,
    PresentationItem presentationItem,
    string[] subSchemasFields,
    Object[] subSchemasAssosiatedValues
)

Parameters

enumType
Type: System..::..Type
Type of the enum.
presentationMode
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationMode
The presentation mode.
presentationItem
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..PresentationItem
The presentation item.
subSchemasFields
Type: array< System..::..String >[]()[][]
The sub schemas fields names.
subSchemasAssosiatedValues
Type: array< System..::..Object >[]()[][]
Values associated with subschemas fields defined in SubSchemasFields (it has to have the same number of items).

See Also

EnumControlAttribute Class
EnumControlAttribute Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes Namespace