CreateLoadCombinationSets Method (List(), List(Double[]), Double, List(), List(Double[]), Double, List(Double[]))

LoadCombinationUtils..::..CreateLoadCombinationSets Method (List<(Of <(<'>)>)>, List<(Of <(<'array<Double>[]()[][]>)>)>, Double, List<(Of <(<'>)>)>, List<(Of <(<'array<Double>[]()[][]>)>)>, Double, List<(Of <(<'array<Double>[]()[][]>)>)>%)
LoadCombinationUtils Class See Also Send Feedback
Sums load combinations.

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static List<LoadCaseArray> CreateLoadCombinationSets(
    List<LoadCaseArray> loadCasesSets1,
    List<double[]> factors1,
    double factor1,
    List<LoadCaseArray> loadCasesSets2,
    List<double[]> factors2,
    double factor2,
    out List<double[]> factors
)

Parameters

loadCasesSets1
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 1
factors1
Type: System.Collections.Generic..::..List <(Of <(<'array< Double >[]()[][]>)>)>
The factors 1.
factor1
Type: System..::..Double
The factor1.
loadCasesSets2
Type: System.Collections.Generic..::..List <(Of <(<'LoadCaseArray>)>)>
The load cases set 2.
factors2
Type: System.Collections.Generic..::..List <(Of <(<'array< Double >[]()[][]>)>)>
The factors2.
factor2
Type: System..::..Double
The factor2.
factors
Type: System.Collections.Generic..::..List <(Of <(<'array< Double >[]()[][]>)>)>%
The factors.

Return Value

See Also

LoadCombinationUtils Class
CreateLoadCombinationSets Overload
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace