GetDataSource Method

IServerUI..::..GetDataSource Method
IServerUI Interface See Also Send Feedback
Gets the data source of the specific key.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
IList GetDataSource(
    string key,
    Document document,
    DisplayUnitType unitType
)

Parameters

key
Type: System..::..String
The key of data source.
document
Type: Document
The document.
unitType
Type: DisplayUnitType
Type of the unit.

Return Value

The data source of list type.

See Also

IServerUI Interface
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace