RevitLoadCombination Members

[image]

Structural Analysis and Code Checking API Reference Guide
RevitLoadCombination Members
RevitLoadCombination Class Constructors Methods Properties See Also Send Feedback

The RevitLoadCombination type exposes the following members.

Constructors

 | Name | Description
Public method | RevitLoadCombination | Initializes a new instance of the RevitLoadCombination class.

Methods

 | Name | Description
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetUsageName | Gets the name of the usage.

Properties

 | Name | Description
Public property | Combination | Gets or sets the combination.

See Also

RevitLoadCombination Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace