StorageService Members

[image]

Structural Analysis and Code Checking API Reference Guide
StorageService Members
StorageService Class Methods See Also Send Feedback

The StorageService type exposes the following members.

Methods

 | Name | Description
Public method | DocumentClosed | Reacts on document closing.
Public method | DocumentOpened | Reacts on document opening.
 | GetCommonDataStorage | Gets the common data storage.
Public method | GetStorageDocument | Returns storage document for particular Revit document.
 | GetStorageService | Returns instance of service.
 | GetUserDataStorage | Gets the user data storage.

See Also

StorageService Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace