GetBaseTypeForSchema Method (Type, , Type)

SchemaClass..::..GetBaseTypeForSchema Method (Type, %, Type%)
SchemaClass Class See Also Send Feedback
Gets the base type for schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetBaseTypeForSchema(
    Type type,
    out ContainerType containerType,
    out Type keyType
)

Parameters

type
Type: System..::..Type
The type.
containerType
Type: ContainerType%
Type of the container.
keyType
Type: System..::..Type %
Type of the key.

Return Value

See Also

SchemaClass Class
GetBaseTypeForSchema Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace