Autodesk.CodeChecking.Concrete Namespace

Autodesk.CodeChecking.Concrete Namespace

Classes

 | Class | Description
Public class | Concrete | Represents the class for concrete behaviors definition.
Public class | Geometry | Represents the class for a concrete cross-section geometry definition.
Public class | Point2D | Describes a point in a two dimensional cartesian space.
Public class | RCArgumentException |
Public class | RCException |
Public class | RCExceptionData |
Public class | RCExceptionDataDoubleRecord |
Public class | RCExceptionDataRecord |
Public class | RCExceptionDataStringRecord |
Public class | RCExceptionDataXMLNameRecord |
Public class | RCSolver |
Public class | Rebar | Describes a rebar in the context of Autodesk.CodeChecking.Concrete.
Public class | SetOfForces | Describes the set of internal forces: AxialForce(N), MomentX(Mx) and MomentY(My).
Public class | Steel | Represents the class for steel behaviors definition.

Interfaces

 | Interface | Description
Public interface | IRCException |

Enumerations

 | Enumeration | Description
Public enumeration | Axis | Classification of axis.
Public enumeration | ConcreteExceptionEnum | Classification of exceptions that could be thrown during creation of the concrete parameters.
Public enumeration | ResultType | Classification of the type of results returned by the solver.
Public enumeration | SteelExceptionEnum | Classification of exceptions that could be thrown in time of creation the concrete parameters.
Public enumeration | StressDiagramType | Classification of concrete stress-strain relationships.
Public enumeration | XMLName |

Axis Enumeration

Axis Enumeration
See Also Send Feedback
Classification of axis.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public enum Axis

Members

Member name | Value | Description
x | 0 | x'-axis.
y | 1 | y'-axis.

Remarks

The internal forces are described in coordinate system x'y'.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
The x' axis is parallel to the x axis in which the Geometry and Rebars have been defined.
The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.

See Also

Autodesk.CodeChecking.Concrete Namespace