SurfaceGraphParameters Properties

[image]

Structural Analysis and Code Checking API Reference Guide
SurfaceGraphParameters Properties
SurfaceGraphParameters Class See Also Send Feedback

The SurfaceGraphParameters type exposes the following members.

Properties

 | Name | Description
Public property | DirectionType |
Public property | DirectionX | XYZ coordinates of results's main direction. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | DirectionZ | XYZ coordinates of results's normal direction. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | LocalCoordinateSystem | Transform of results's. This value is valid only with the DirectionType set to SpecifiedDirectionX
Public property | UnitsSystem | Defines the set of units used when querying for results.

See Also

SurfaceGraphParameters Class
Autodesk.Revit.DB.ResultsBuilder Namespace