DocumentValueWithDescription Constructor (String, String, String, Double, , , , Boolean)

DocumentValueWithDescription Constructor (String, String, String, Double, , , , Boolean)
DocumentValueWithDescription Class See Also Send Feedback
Initializes a new instance of the DocumentValueWithDescription class.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation
Assembly: ExtensibleStorageFramework.Documentation (in ExtensibleStorageFramework.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public DocumentValueWithDescription(
    string name,
    string description,
    string note,
    double value,
    DisplayUnitType inputDispUnit,
    UnitType unitType,
    Units units,
    bool addLineBreak
)

Parameters

name
Type: System..::..String
The name.
description
Type: System..::..String
The description.
note
Type: System..::..String
The note.
value
Type: System..::..Double
The value.
inputDispUnit
Type: DisplayUnitType
The input display unit.
unitType
Type: UnitType
Type of the unit.
units
Type: Units
The units.
addLineBreak
Type: System..::..Boolean
if set to true line break will be added after element.

See Also

DocumentValueWithDescription Class
DocumentValueWithDescription Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework.Documentation Namespace