Service Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Service Methods
Service Class See Also Send Feedback

The Service type exposes the following members.

Methods

 | Name | Description
 | AddServer | Register server in Service
 | BlockServer | Blocks the server.
Public method | CanExecute | Returns permission for executing particular server
 | DocumentOpened | Inform service about document opening.
 | Execute(Document, Guid) | Executes given server.
Public method | Execute(IExternalServer, Document, IExternalData) | Executes given server.
 | ExecuteServer | Executes given server.
 | GenerateCombinations | Generates the combinations.
 | GetActiveServer | Returns list of active server registered in Service
 | GetActiveServerId | Returns active server registered in Service
 | GetDataStorage | Gets the data storage element which contains particular schema.
Public method | GetDescription | Returns the description
Public method | GetName | Gets the name of the service.
 | GetServer | Returns server of specific id.
 | GetServers | Returns servers registered in Service
Public method | GetServiceId | Returns service ID
Public method | GetVendor | Return vendor.
Public method | GetVendorId | Reurns vendor Id of the service.
 | IsActive | Determines whether the specified server ID is active.
 | IsBlocked | Determines whether the specified server is blocked.
Public method | IsValidServer | Validates server.
Public method | OnServersChanged | Takes action when servers changes.
Public method | OnServersDisparity |
 | RegisterService | Registers service in Revit
 | SetActiveServer | Sets active servers
 | UnBlockServer | Uns the block server.

See Also

Service Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace