MaterialCharacteristics Properties

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialCharacteristics Properties
MaterialCharacteristics Class See Also Send Feedback

The MaterialCharacteristics type exposes the following members.

Properties

 | Name | Description
Public property | DampingRatio | Gets the damping coefficient.
Public property | PoissonRatio | Gets the Poisson's ratio.
Public property | ShearModulus | Gets the shear modulus G.
Public property | Specific | Gets or sets specific characteristics (corresponding to material category) of the material.
Public property | ThermalExpansionCoefficient | Gets the thermal expansion coefficient.
Public property | UnitWeight | Gets the unit weight.
Public property | YoungModulus | Gets the Young's modulus.

See Also

MaterialCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace