GetSurfaceGraphsEnvelopes Method (ICollection(), ICollection(), ICollection(String), SurfaceGraphParameters)

ResultsPackage..::..GetSurfaceGraphsEnvelopes Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'String>)>)>, SurfaceGraphParameters)
ResultsPackage Class See Also Send Feedback
Return envelope of results.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<SurfaceGraphEnvelope> GetSurfaceGraphsEnvelopes(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadIds,
    ICollection<string> resultsNames,
    SurfaceGraphParameters surfaceGraphMode
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
resultsNames
Type: System.Collections.Generic..::..ICollection <(Of <(<' String >)>)>
surfaceGraphMode
Type: Autodesk.Revit.DB.ResultsBuilder..::..SurfaceGraphParameters

See Also

ResultsPackage Class
GetSurfaceGraphsEnvelopes Overload
Autodesk.Revit.DB.ResultsBuilder Namespace