GetMomentFirstY Method

RCSolver..::..GetMomentFirstY Method
RCSolver Class See Also Send Feedback
Gets the value of first moment of inertia.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetMomentFirstY(
    ResultType resType
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of moment to be returned: for rebar, concrete or equivalent section (transformed)

Return Value

Returns the value first moment of inertia calculated around y' axis for rebar, concrete or section.
Unit: [length^3]

Remarks

The y' axis is parallel to the y axis in which the Geometry and Rebars have been defined.
The coordinate system x'y' has for origin (0,0) the gravity center of the cross section.
Unit depends to the units used to define concrete, steel, geometry and internal forces

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace