DesignStrength Property

Steel..::..DesignStrength Property
Steel Class See Also Send Feedback
The DesignStrength property represents the design strenght of steel (design yield strength).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double DesignStrength { get; set; }

Field Value

Gets or sets the steel design strength (design yield strength).

Remarks

Unit: [force per length^2].
Design strength should be in base units for example[Pa]. Typical values are in the range between 200000000 and 500000000[Pa] or 30000 and 75000 [psi].
The return value will be in the same unit which has been used.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The steel design strength must be greater than 0.0.

See Also

Steel Class
Autodesk.CodeChecking.Concrete Namespace