Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace

Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace

Classes

 | Class | Description
Public class | Category | Groups set of controls in one category.
Public class | Control | Base class for all controls.
Public class | DefaultValueQueryEventArgs | Represents arguments for default value query.
Public class | DictionaryItemIdentification | Represents dictionary identification.
Public class | FieldControl | Represents the control for single field.
Public class | Image | Represents image control
Public class | KeyControl | Base class for all controls identified by Key
Public class | Layout | Represents the layout control
Public class | LayoutInitializedEventArgs | Represents arguments for layout initialized event.
Public class | ListItemIdentification | Represents list identification.
Public class | SchemaEditorEventArgs | Main class for schema editor data.
Public class | SubSchemaControl | Represents the subschema control
Public class | SubSchemaListTable | Presents subschema list as table.
Public class | TableCellIdentification | Represents table identification.
Public class | TextBlock | Represents the text block control
Public class | ValueChangedEventArgs | Represents arguments for value changed event.

Interfaces

 | Interface | Description
Public interface | IDefaultValueProvider | Base interface for default value providers.
Public interface | IFieldEditor | Base interface for all field editors
Public interface | IFieldValidator | The base interface for all validation classes.
Public interface | IFieldValueChanged | Base interface for value change observers
Public interface | IFormatAttribute | Represents base interface for format attributes
Public interface | IGridAttribute | Base interface for all grid controls attributes.
Public interface | IGridValueAttribute | Base interface for all grid controls attributes
Public interface | ILayoutControl | Represents base interface for layouts controls
Public interface | ISchemaEditor | Base interface for all controls representing schemas.
Public interface | IServerUI | Base interface for code checking UI servers.
Public interface | ITableEditor | Represents table editor.
Public interface | IValidateAttribute | Base interface for attributes which supports validation

Delegates

 | Delegate | Description
Public delegate | FieldValidation | Describes field validation event.
Public delegate | ValueChangedHandler | Describes field validation event.

Enumerations

 | Enumeration | Description
Public enumeration | ImageSize | Represents standard sizes of image

Category Class

Category Class
Members See Also Send Feedback
Groups set of controls in one category.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Category : Control

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Control
Autodesk.Revit.UI.ExtensibleStorage.Framework..::..Category

See Also

Category Members
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace