Autodesk.Revit.DB.ResultsBuilder.Storage Namespace

Autodesk.Revit.DB.ResultsBuilder.Storage Namespace

Classes

 | Class | Description
Public class | BarNodeResults | Defines a set of reactions in the specified point along the linear element like beam or column.
Public class | BarPointProperties | BarPointProperties class is used to define properties of tapered sections.
Public class | BarPointResults | Defines a set of standard results in the calculation point along the linear element like beam or column.
Public class | BarProperties | Defines a set of properties that are used for calculating derivative results.
Public class | BarResultsBase | BarResultsBase is a base class for definition of results for linear elements.
Public class | BarResultsByPoints | Defines the set of analytical results for linear element that is interpreted as diagram drawn between given points. Values must be defined in local coordinate system of analytical model.
Public class | BarResultsInNodes | Defines a list of reactions on linear element. Values must be defined in local coordinate system of analytical model.
Public class | BarTaperedProperties | Set of properties of tapered section.
Public class | ResultsPackageBuilder | ResultsPackageBuilder class is used to create the Analysis object.
Public class | SurfaceNodeResults | Defines a set of reactions in the calculation point contained in the surface element like floor or wall.
Public class | SurfacePointResults | Defines a set of standard results in the calculation point contained in the surface element like floor or wall.
Public class | SurfaceProperties | Defines a set of properties that are used for calculating derivative results.
Public class | SurfaceResults | Defines a set of results for surface.

BarNodeResults Class

BarNodeResults Class
Members See Also Send Feedback
Defines a set of reactions in the specified point along the linear element like beam or column.

Namespace: Autodesk.Revit.DB.ResultsBuilder.Storage
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class BarNodeResults

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ResultsBuilder.Storage..::..BarNodeResults

See Also

BarNodeResults Members
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace