Build Method (PropertyInfo, IResource, Guid)

FieldControl..::..Build Method (PropertyInfo, IResource, Guid)
FieldControl Class See Also Send Feedback
Generates the Field Control based on property attributes.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static FieldControl Build(
    PropertyInfo property,
    IResource server,
    Guid schemaId
)

Parameters

property
Type: System.Reflection..::..PropertyInfo
The property.
server
Type: Autodesk.Revit.DB.ExtensibleStorage.Framework..::..IResource
The server.
schemaId
Type: System..::..Guid
The schema id.

Return Value

See Also

FieldControl Class
Build Overload
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace