GetBaseType Method (PropertyInfo, , Type)

SchemaClass..::..GetBaseType Method (PropertyInfo, %, Type%)
SchemaClass Class See Also Send Feedback
Gets the base type of the property.

Namespace: Autodesk.Revit.DB.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework (in ExtensibleStorageFramework.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public static Type GetBaseType(
    PropertyInfo propertyInfo,
    out ContainerType containerType,
    out Type keyType
)

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo
The property info.
containerType
Type: ContainerType%
Type of the container.
keyType
Type: System..::..Type %
Type of the key.

Return Value

See Also

SchemaClass Class
GetBaseType Overload
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace