DataStructureAttribute Class

DataStructureAttribute Class
Members See Also Send Feedback
Base class for all Data Structure attributes

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class DataStructureAttribute : Attribute

Remarks

Used for MultiStructureServers.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..DataStructureAttribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..CalculationParamsStructureAttribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..LabelStructureAttribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..ResultStructureAttribute

See Also

DataStructureAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace