GetBarNodeResults Method (ICollection(), ICollection(), ICollection(LinearResultType), UnitsSystem)

ResultsPackage..::..GetBarNodeResults Method (ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'>)>)>, ICollection<(Of <(<'LinearResultType>)>)>, UnitsSystem)
ResultsPackage Class See Also Send Feedback
Returns bar node results for element.

Namespace: Autodesk.Revit.DB.ResultsBuilder
Assembly: ResultsBuilder (in ResultsBuilder.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public IList<BarNodeResult> GetBarNodeResults(
    ICollection<ElementId> elementIds,
    ICollection<ElementId> loadCasesOrCombinations,
    ICollection<LinearResultType> types,
    UnitsSystem unitsSystem
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
loadCasesOrCombinations
Type: System.Collections.Generic..::..ICollection <(Of <(<'ElementId>)>)>
types
Type: System.Collections.Generic..::..ICollection <(Of <(<' LinearResultType >)>)>
unitsSystem
Type: Autodesk.Revit.DB.ResultsBuilder..::..UnitsSystem

See Also

ResultsPackage Class
GetBarNodeResults Overload
Autodesk.Revit.DB.ResultsBuilder Namespace