SubSchemaControl Constructor

SubSchemaControl Constructor
SubSchemaControl Class See Also Send Feedback
Initializes a new instance of the SubSchemaControl class.

Namespace: Autodesk.Revit.UI.ExtensibleStorage.Framework
Assembly: ExtensibleStorageFramework.UI (in ExtensibleStorageFramework.UI.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public SubSchemaControl(
    Guid schema,
    string fieldName,
    string displayName,
    FieldUIAttribute attribute,
    Guid subSchema,
    ContainerType container,
    Type valueType,
    Type keyType
)

Parameters

schema
Type: System..::..Guid
The schema.
fieldName
Type: System..::..String
Name of the field.
displayName
Type: System..::..String
The display name.
attribute
Type: Autodesk.Revit.UI.ExtensibleStorage.Framework.Attributes..::..FieldUIAttribute
The attribute.
subSchema
Type: System..::..Guid
The sub schema.
container
Type: ContainerType
The type of container
valueType
Type: System..::..Type
Type of the value.
keyType
Type: System..::..Type
Type of the key.

See Also

SubSchemaControl Class
Autodesk.Revit.UI.ExtensibleStorage.Framework Namespace