GetStrain Method

RCSolver..::..GetStrain Method
RCSolver Class See Also Send Feedback
Gets strain at a given point.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetStrain(
    ResultType resType,
    int index
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of strain to be returned: for rebar or concrete only.
index
Type: System..::..Int32
index of a point given from the contour or a given rebar.

Return Value

Returns strain in concrete or rebar at point given from the contour or rebar index.
Unit: [dimensionless]

Remarks

This method could be used only for concrete and rebars, for section, this method throws exception.
If calculation are not performed, this method throws exception as well.

Exceptions

Exception | Condition
 | Calculation are not performed
System..::..ArgumentException | This method could be used only for concrete and rebars.
System..::..ArgumentException | Index must be less than Count.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace