SolveForces Method (ResultType, Double, Double, Double)

RCSolver..::..SolveForces Method (ResultType, Double, Double, Double)
RCSolver Class See Also Send Feedback
Calculates forces according to acting strain

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public SetOfForces SolveForces(
    ResultType resType,
    double maxStrain,
    double minStrain,
    double angle
)

Parameters

resType
Type: Autodesk.CodeChecking.Concrete..::..ResultType
Determines which type of resistance to be returned: for rebar, concrete or equivalent section (transformed).
maxStrain
Type: System..::..Double
Maximum strain in the concrete section.
Unit: [dimensionless].
minStrain
Type: System..::..Double
Minimum strain in the concrete section.
Unit: [dimensionless].
angle
Type: System..::..Double
Angle between the vector perpendicular to neutral axis and the x-axis.
The sense of the vector indicate the direction to the most tensioned fiber.
Unit: [dimensionless].

Remarks

The resistance forces could be read by GetInternalForces method.
Other information about state of failure could be read using dedicated methods.
The units should be consistent for concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
Autodesk.CodeChecking.Concrete..::..IRCException | Minimum strain greater than maximum strain.
Autodesk.CodeChecking.Concrete..::..IRCException | Minimum strain greater than ultimate concrete strain.
Autodesk.CodeChecking.Concrete..::..IRCException | Maximum strain greater than ultimate steel strain.
Autodesk.CodeChecking.Concrete..::..IRCException | Minimum strain greater than ultimate steel strain.
Autodesk.CodeChecking.Concrete..::..IRCException | Rotation angle should be in the range between 0 and 2.0*Pi.

See Also

RCSolver Class
SolveForces Overload
Autodesk.CodeChecking.Concrete Namespace