ResultStatus Members

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatus Members
ResultStatus Class Constructors Methods Properties See Also Send Feedback

The ResultStatus type exposes the following members.

Constructors

 | Name | Description
Public method | ResultStatus()()()() | Initializes a new instance of the ResultStatus class.
Public method | ResultStatus(Guid) | Initializes a new instance of the ResultStatus class.
Public method | ResultStatus(Guid, Guid) | Initializes a new instance of the ResultStatus class.

Methods

 | Name | Description
Public method | AddError(String, Boolean) | Adds the error.
Public method | AddError(ResultStatusMessage, Document, Boolean) | Adds the error.
Public method | AddInfo(String, Boolean) | Adds the info.
Public method | AddInfo(ResultStatusMessage, Document, Boolean) | Adds the info.
Public method | AddWarning(String, Boolean) | Adds the warning.
Public method | AddWarning(ResultStatusMessage, Document, Boolean) | Adds the warning.
Public method | Clear | Clears this instance.
Public method | IsError | Determines whether this instance is error.
Public method | IsOk | Determines whether this instance is ok.
Public method | IsWarning | Determines whether this instance is warning.
Public method | SetStatusRatioBased | Sets the status based on ratio.
Public method | SetStatusValueBased | Sets the status based on value.

Properties

 | Name | Description
Public property | ErrorList | Gets or sets the error list.
Public property | InfoList | Gets or sets the info list.
Public property | Package | Gets or sets the package.
Public property | ServerId | Gets or sets the server id.
Public property | Status | Gets or sets the status.
Public property | WarningList | Gets or sets the warning list.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace