Storage(T) Class

Storage<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Base class for all storage classes.

Namespace: Autodesk.Revit.DB.CodeChecking.Storage
Assembly: CodeChecking.Storage (in CodeChecking.Storage.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public abstract class Storage<T> : SchemaClass,
    IStorage
where T : new(), ServerStorage

Type Parameters

T

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage.Framework..::..SchemaClass
Autodesk.Revit.DB.CodeChecking.Storage..::..Storage<(Of <(<'T>)>)>
Autodesk.Revit.DB.CodeChecking.Storage..::..CalculationParam
Autodesk.Revit.DB.CodeChecking.Storage..::..Label
Autodesk.Revit.DB.CodeChecking.Storage.LoadCombination..::..LoadCombinationParameters
Autodesk.Revit.DB.CodeChecking.Storage..::..Result

See Also

Storage<(Of <(<'T>)>)> Members
Autodesk.Revit.DB.CodeChecking.Storage Namespace