PreGeneration Method

Server<(Of <(<'TData>)>)>..::..PreGeneration Method
Server<(Of <(<'TData>)>)> Class See Also Send Feedback
Launched before Revit load combination generation (only in preview mode).

Namespace: Autodesk.Revit.DB.CodeChecking.LoadCombination
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public virtual void PreGeneration(
    Document document,
    List<LoadCombinationPreview> selectedCombinations
)

Parameters

document
Type: Document
The document.
selectedCombinations
Type: System.Collections.Generic..::..List <(Of <(<' LoadCombinationPreview >)>)>
Selected combinations by the user.

Implements

ILoadCombinationServer..::..PreGeneration(Document, List<(Of <<'(LoadCombinationPreview>)>>))

See Also

Server<(Of <(<'TData>)>)> Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace