SlabBaseObject Members

[image]

Structural Analysis and Code Checking API Reference Guide
SlabBaseObject Members
SlabBaseObject Class Constructors Methods Properties See Also Send Feedback

The SlabBaseObject type exposes the following members.

Constructors

 | Name | Description
Public method | SlabBaseObject()()()() | Construct object.
Public method | SlabBaseObject(SlabInfo) | Construct object.

Methods

 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.

Properties

 | Name | Description
Public property | AdjoiningElementType | Type of origin Revit element.
Public property | ContextId | Revit Id of element.
Public property | ElementType | Type of element.
Public property | ParentSlab | Parent slab.

See Also

SlabBaseObject Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace