Attribute Methods

[image]

Structural Analysis and Code Checking API Reference Guide
Attribute Methods
Attribute Class See Also Send Feedback

Methods

Name | Description
GetAttribute<(Of <<'(TAttribute>)>>)(PropertyInfo) | Gets the attribute of specific type assigned to the property.
GetAttribute<(Of <<'(TAttribute>)>>)(Type) | Gets the attribute of specific type assigned to the input type.
GetAttributes<(Of <<'(TAttribute>)>>)(PropertyInfo) | Gets the list of attributes of specific type assigned to the property.
GetAttributes<(Of <<'(TAttribute>)>>)(Type) | Gets the list of attributes of specific type assigned to the input type.

See Also

Attribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework Namespace