EffectiveHeightReductionFactor Property

Concrete..::..EffectiveHeightReductionFactor Property
Concrete Class See Also Send Feedback
The EffectiveHeightReductionFactor property represents the reduction factor of the compression zone height.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double EffectiveHeightReductionFactor { get; set; }

Field Value

Gets or sets the reduction factor of the compression zone height.

Remarks

Unit: [dimensionless].
This parameter is taken into account only for a simplified model with rectangular stress distribution StressDiagType.Rectangular.
Typical values are in the range between 0.8 and 1.0.

Exceptions

Exception | Condition
System..::..ArgumentException | Reduction factor of the compression zone must be in the range between 0 and 1.0.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace