BarProperties Members

[image]

Structural Analysis and Code Checking API Reference Guide
BarProperties Members
BarProperties Class Constructors Methods Properties See Also Send Feedback

The BarProperties type exposes the following members.

Constructors

 | Name | Description
Public method | BarProperties | Initializes a new instance of the BarProperties class

Methods

 | Name | Description

Properties

 | Name | Description
Public property | Ax | Cross section area
Public property | Iy | Moment of inertia about the Y axis
Public property | Iz | Moment of inertia about the Z axis
Public property | Ky | Ky elastic ground coefficient
Public property | Kz | Kz elastic ground coefficient

See Also

BarProperties Class
Autodesk.Revit.DB.ResultsBuilder.Storage Namespace