WallInfo Properties

[image]

Structural Analysis and Code Checking API Reference Guide
WallInfo Properties
WallInfo Class See Also Send Feedback

The WallInfo type exposes the following members.

Properties

 | Name | Description
Public property | ContextId | Revit Id of element.
Public property | Contour | Gets the shape representing the contour of the wall.
Public property | FamilyName | Gets family name.
Public property | Layers | Gets list of Layer objects ().
Public property | Openings | Gets the list of shapes that representing the openings.
Public property | Transform | Gets class allows to transform points from local to global (and vice versa) coordinate system.
Public property | TypeName | Gets name of type.

See Also

WallInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace