TSectionNearestObjectType Enumeration

TSectionNearestObjectType Enumeration
See Also Send Feedback
Type of nearest characteristic object in the cross-section perpendicular to beam's longitudinal axis.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum TSectionNearestObjectType

Members

Member name | Value | Description
FreeEdgeOfSlab | 0 | Free edge of slab.
Beam | 1 | Neighboring beam.
UpperColumn | 2 | Upper column.
CrossingColumn | 3 | Crossing column.
LowerColumn | 4 | Lower column.
Hole | 5 | Hole.
UpperWall | 6 | Upper wall.
Wall | 7 | Crossing wall.
LowerWall | 8 | Lowwr wall.
Unknown | 9 | Unknown.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace