ResultStatus Methods

[image]

Structural Analysis and Code Checking API Reference Guide
ResultStatus Methods
ResultStatus Class See Also Send Feedback

The ResultStatus type exposes the following members.

Methods

 | Name | Description
Public method | AddError(String, Boolean) | Adds the error.
Public method | AddError(ResultStatusMessage, Document, Boolean) | Adds the error.
Public method | AddInfo(String, Boolean) | Adds the info.
Public method | AddInfo(ResultStatusMessage, Document, Boolean) | Adds the info.
Public method | AddWarning(String, Boolean) | Adds the warning.
Public method | AddWarning(ResultStatusMessage, Document, Boolean) | Adds the warning.
Public method | Clear | Clears this instance.
Public method | IsError | Determines whether this instance is error.
Public method | IsOk | Determines whether this instance is ok.
Public method | IsWarning | Determines whether this instance is warning.
Public method | SetStatusRatioBased | Sets the status based on ratio.
Public method | SetStatusValueBased | Sets the status based on value.

See Also

ResultStatus Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace