ILoadCombinationServer Members

[image]

Structural Analysis and Code Checking API Reference Guide
ILoadCombinationServer Members
ILoadCombinationServer Interface Methods See Also Send Feedback

The ILoadCombinationServer type exposes the following members.

Methods

 | Name | Description
Public method | ConvertDataToCurrentVersion | Converts old version of data entity to the newest one.
Public method | Generate | Generates load combinations. Used only if the server doesn't support preview mode.
Public method | GeneratePreview | Generates load combinations preview. Used only if the server supports preview mode.
Public method | GetDataSchema | Gets the data schema.
Public method | GetDefaultData | Gets the default data.
Public method | GetVersion | Gets the version of code checking server.
Public method | PostGeneration | Launched after Revit load combination generation (only in preview mode).
Public method | PreGeneration | Launched before Revit load combination generation (only in preview mode).
Public method | PreviewMode | Indicates if server supports preview mode.
Public method | RemoveLoadCombinations | Indicates if load combinations generated in the past should be removed before generation.

See Also

ILoadCombinationServer Interface
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace