ModulusOfElasticity Property

Concrete..::..ModulusOfElasticity Property
Concrete Class See Also Send Feedback
The ModulusOfElasticity property represents the concrete modulus of elasticity (Young modulus).

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double ModulusOfElasticity { get; set; }

Field Value

Gets or sets the value of the concrete modulus of elasticity (Young modulus).

Remarks

Unit: [force per length^2].
Modulus of elasticity (Young modulus) should be in base units for example [Pa] or [psi].
Typical values are in the range between 25000000000 and 40000000000 [Pa] or 3000000 and 5700000 [psi].
This value is used for the calculation of equivalent (transformed) characteristic of the reinforced section.
The return value will be in the same unit which has been used for strength measurement and should be consistent with units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
System..::..ArgumentException | The concrete Young modulus (modulus of elasticity) must be greater than 0.0.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace