SchemaPropertyAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
SchemaPropertyAttribute Members
SchemaPropertyAttribute Class Constructors Methods Properties See Also Send Feedback

The SchemaPropertyAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SchemaPropertyAttribute()()()() | Initializes the instance of the SchemaPropertyAttribute.
Public method | SchemaPropertyAttribute(UnitType, DisplayUnitType) | Initializes the instance of the SchemaPropertyAttribute.

Methods

 | Name | Description
Public method | GetConverter | Returns the instance of the converter.

Properties

 | Name | Description
Public property | ConverterType | The converter which implements IFieldToPropertyConverter interface, necessarry when FieldType is different from property type.
Public property | FieldName | The name of the field in the schema. If null the name of the property will be taken directly.
Public property | FieldType | The type of the field in the schema. If null the type of the property will be taken directly. Usefull when property type is not supported by Extensible Storage.

See Also

SchemaPropertyAttribute Class
Autodesk.Revit.DB.ExtensibleStorage.Framework.Attributes Namespace