ServerStorage Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServerStorage Members
ServerStorage Class Constructors Methods Properties See Also Send Feedback

The ServerStorage type exposes the following members.

Constructors

 | Name | Description
Public method | ServerStorage | Initializes a new instance of the ServerStorage class.

Methods

 | Name | Description
Public method | Clone | Clones this instance. (Overrides SchemaClass..::..Clone()()()().)
Public method | Load | Loads the specified element. (Overrides SchemaClass..::..Load(Element).)
Public method | UpdateState | Updates the state of the element.

Properties

 | Name | Description
Public property | ElementId | Gets or sets the element id.
Public property | Entity | Gets or sets the entity.
Public property | Modified | Gets or sets a value indicating whether this Label was modified.
Public property | SchemaId | Gets or sets the schema id.
Public property | ServerId | Gets or sets the server id.
Public property | State | Gets or sets the state - used for checking modifications.

See Also

ServerStorage Class
Autodesk.Revit.DB.CodeChecking.Storage Namespace