Autodesk.Revit.DB.CodeChecking.Engineering Namespace

Autodesk.Revit.DB.CodeChecking.Engineering Namespace

Classes

 | Class | Description
Public class | CalcPoint | Base class for calculation point descriptor classes
Public class | CalcPointLinear | Representation of a calculation point on an element
Public class | CalcPointSurface | Representation of a calculation point on an element
Public class | CoordinateSystem | Class allows to transform points from local to global (and vice versa) coordinate system.
Public class | ElementInfo | Represents the properties of element along its length.
Public class | ElementSectionsInfo | Represents sections along element.
Public class | ElementSectionsParamsInfo | Represents the parameters of sections along element.
Public class | ElementSlabsInfo | Represents the properties of element slabs.
Public class | ElementTSectionInfo | Represents shape with plate T - section.
Public class | ElementWallsInfo | Represents the properties of element walls.
Public class | ForceCalculationDataDescriptor | Describes calculation object
Public class | ForceCalculationDataDescriptorLinear | Calculation points identifier for linear elements
Public class | ForceLoadCaseDescriptor | Representation of a load in Revit
Public class | ForceResultsPackageDescriptor | Representation of a ResultsPackage in Revit
Public class | Layer | Layer characteristics.
Public class | MaterialCharacteristics | Represents characteristics of a material.
Public class | MaterialConcreteCharacteristics | Represents characteristics of a concrete material.
Public class | MaterialInfo | Describes the material
Public class | MaterialMetalCharacteristics | Represents characteristics of a metal material.
Public class | MaterialProperties | Represents properties of the material.
Public class | MaterialTimberCharacteristics | Represents characteristics of a timber material.
Public class | RebarCoversInfo | Represents valid covers for element.
Public class | Section | Describes section contour with holes on a plane.
Public class | SectionCharacteristics | Describes characteristics of the parametric section.
Public class | SectionDimensions | Describes dimentsions of the parametric section.
Public class | SectionProfile | Represents the parameters of profile of element.
Public class | SectionsInfo | Describes sections or compound sections along element length.
Public class | SectionsParamsInfo | Describes dimensions and characteristics of the parametric section.
Public class | Shape | Describes flat shape on a plane.
Public class | SlabBaseObject | Base class for each element of the slab geometry
Public class | SlabContour | Represents Contour. Contour is a list of edges and nodes with parent characteristics.
Public class | SlabEdge | Represents edge. Edge is a lis of nodes with parent characteristics.
Public class | SlabInfo | Describes geometry of the slab and some connections with other elements. It consists of 3 characteristics elements: - nodes - (SlabNode) - edges - (SlabEdge) - contours - (SlabContour)
Public class | SlabNode | Represents node. Node is a point with parent characteristics.
Public class | WallInfo | Describes some geometry features of the Wall.

Enumerations

 | Enumeration | Description
Public enumeration | AxisDirection | Define axis direction.
Public enumeration | ElementType | Describes the type of the element
Public enumeration | ForceLimitState | Limit State( Ultimate, Serviceability, Accidental)
Public enumeration | ForceLoadCaseDescriptor..::..LoadType | Load Type (Simple load,Combination of loads)
Public enumeration | ForceType | Identificator for internal forces inside a cross-section
Public enumeration | MaterialCategory | Describes the type of material
Public enumeration | ResultType | Identificator for Reinforced Concrete section results
Public enumeration | SectionShapeType | Typ of the section.
Public enumeration | SlabAdjoiningRevitElementType | Defines type of adjoining Revit element.
Public enumeration | SlabContourType | Defines type of slab contour.
Public enumeration | SlabGeometryObjectType | Defines type of slab geometry object.
Public enumeration | TSectionNearestObjectType | Type of nearest characteristic object in the cross-section perpendicular to beam's longitudinal axis.

AxisDirection Enumeration

AxisDirection Enumeration
See Also Send Feedback
Define axis direction.

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public enum AxisDirection

Members

Member name | Value | Description
X | 0 | Directon about x axis.
Y | 1 | Directon about y axis.
Z | 2 | Directon about z axis.

See Also

Autodesk.Revit.DB.CodeChecking.Engineering Namespace