LabelStructureAttribute Constructor (Type, , )

LabelStructureAttribute Constructor (Type, , )
LabelStructureAttribute Class See Also Send Feedback
Initializes a new instance of the LabelStructureAttribute class.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public LabelStructureAttribute(
    Type type,
    BuiltInCategory category,
    StructuralAssetClass material
)

Parameters

type
Type: System..::..Type
The label type.
category
Type: BuiltInCategory
The category for which label type is defined.
material
Type: StructuralAssetClass
The material for which label type is defined.

See Also

LabelStructureAttribute Class
LabelStructureAttribute Overload
Autodesk.Revit.DB.CodeChecking.Attributes Namespace