MaterialTimberCharacteristics Members

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialTimberCharacteristics Members
MaterialTimberCharacteristics Class Constructors Methods Properties See Also Send Feedback

The MaterialTimberCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialTimberCharacteristics()()()() | Creates default instance.
Public method | MaterialTimberCharacteristics(MaterialTimberCharacteristics) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.

Properties

 | Name | Description
Public property | AverageModulusG | Gets the average modulus G.
Public property | BendingStrength | Gets the bending strength.
Public property | BurningVelocity | Gets burning velocity (mm/min).
Public property | ParallelCompressionStrength | Gets the parallel compression strength.
Public property | ParallelShearStrength | Gets the parallel shear strength.
Public property | PerpendicularCompressionStrength | Gets the perpendicular compression strength.
Public property | PerpendicularShearStrength | Gets the perpendicular shear strength.

See Also

MaterialTimberCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace