Shape Members

[image]

Structural Analysis and Code Checking API Reference Guide
Shape Members
Shape Class Constructors Methods Properties See Also Send Feedback

The Shape type exposes the following members.

Constructors

 | Name | Description
Public method | Shape()()()() | Creates default instance.
Public method | Shape(List<(Of <<'(XYZ>)>>)) | Creates instance using list of points.
Public method | Shape(Shape) | Creates instance using shape. Copy constructor.

Methods

 | Name | Description
Public method | GetMaximumBoundary | Gets maximum coordinates of upper-right corner.
Public method | GetMinimumBoundary | Gets minimum coordinates of lower-left corner.
Public method | GetTurnedPointsList | Gets list of points for this shape turned by an angle.
Public method | IsContourInside | Check if a contour is inside this shape.
Public method | IsPointInside | Check if a point is inside this shape.

Properties

 | Name | Description
Public property | Points | Gets list of points describing the polygon representing the shape.

See Also

Shape Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace