LoadCombinationPreview Methods

[image]

Structural Analysis and Code Checking API Reference Guide
LoadCombinationPreview Methods
LoadCombinationPreview Class See Also Send Feedback

The LoadCombinationPreview type exposes the following members.

Methods

 | Name | Description
Public method | AddComponent | Adds the component. It should be LoadCase, LoadCombination or LoadCombinationPreview
Public method | Generate | Generates Revit LoadCombination in specified document.
Public method | GetCombinationType | Gets the type of the load combination.
Public method | GetComponentFactor | Gets the component factor.
Public method | GetComponentName | Gets the name of the component.
Public method | GetId | Gets the id.
Public method | GetName | Gets the name.
Public method | GetNumberOfComponents | Gets the number of components.
Public method | GetNumberOfUsages | Gets the number of usages.
Public method | GetState | Gets the state.
Public method | GetUsageName | Gets the name of the usage.

See Also

LoadCombinationPreview Class
Autodesk.Revit.DB.CodeChecking.LoadCombination Namespace