StrainStressModel Property

Concrete..::..StrainStressModel Property
Concrete Class See Also Send Feedback
The StrainStressModel property represents the type of stress-strain relationship.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public StressDiagramType StrainStressModel { get; set; }

Field Value

Gets or sets the type of stress-strain relationship.

Remarks

Available stress-strain relationship are described by the StressDiagType enumeration.
For ULS, most common used relationships are rectangular and parabolic.
For SLS, most common used relationship is linear.
All the parameters required by the choosen relationship should be set using dedicated methods:
SetStrainStressModelRectangular
SetStrainStressModelLinear
SetStrainStressModelParabolicRectangular
SetStrainStressModelBiLinear

Exceptions

Exception | Condition
System..::..ArgumentException | Unsupported stress-strain relationship.

See Also

Concrete Class
Autodesk.CodeChecking.Concrete Namespace