MaterialConcreteCharacteristics Members

[image]

Structural Analysis and Code Checking API Reference Guide
MaterialConcreteCharacteristics Members
MaterialConcreteCharacteristics Class Constructors Methods Properties See Also Send Feedback

The MaterialConcreteCharacteristics type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialConcreteCharacteristics()()()() | Creates default instance.
Public method | MaterialConcreteCharacteristics(MaterialConcreteCharacteristics) | Creates new instance from pattern. Copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.

Properties

 | Name | Description
Public property | BendingReinforcement | Gets the bending reinforcement of the concrete.
Public property | Compression | Gets the compression of the concrete.
Public property | ShearReinforcement | Gets the shear reinforcement of the concrete.
Public property | ShearStrengthReduction | Gets the shear strength reduction of the concrete.

See Also

MaterialConcreteCharacteristics Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace