Autodesk.Revit.DB.CodeChecking.Documentation Namespace

Autodesk.Revit.DB.CodeChecking.Documentation Namespace

Classes

 | Class | Description
Public class | Composer | Base class for document composers
Public class | MultiStructureServer | The base class for all servers that support more than one category or material.
Public class | ReportSettings | Describes Report Settings
Public class | ResultComposer | Provides tool for generating Result note
Public class | Server<(Of <(<'TCalculationParam, TLabel, TResult>)>)> | Base class for all servers which are based on reflection scenario. It provides automization for most of functionality required by Code Checking Platform.
Public class | ServiceDocument | Represent service document

Interfaces

 | Interface | Description
Public interface | ICodeCheckingServerDocumentation | The base interface for all servers for documentation creation purpose.

Enumerations

 | Enumeration | Description
Public enumeration | DocumentSectionType | Describes document section type
Public enumeration | FilterStatus | Describes filter status
Public enumeration | GroupMethod | Grouping methods
Public enumeration | SelectionAction | Represents selection action
Public enumeration | SortMethod | Sorting methods

Composer Class

Composer Class
Members See Also Send Feedback
Base class for document composers

Namespace: Autodesk.Revit.DB.CodeChecking.Documentation
Assembly: CodeChecking.Documentation (in CodeChecking.Documentation.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class Composer

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.CodeChecking.Documentation..::..Composer
Autodesk.Revit.DB.CodeChecking.Documentation..::..ResultComposer

See Also

Composer Members
Autodesk.Revit.DB.CodeChecking.Documentation Namespace