GetNeutralAxisDistance Method

RCSolver..::..GetNeutralAxisDistance Method
RCSolver Class See Also Send Feedback
Gets the distance from the concrete section gravity center to neutral axis.

Namespace: Autodesk.CodeChecking.Concrete
Assembly: rcuapiNET (in rcuapiNET.dll) Version: 0.0.0.0

Syntax

C#
public double GetNeutralAxisDistance()

Return Value

Returns distance from gravity center of contour to neutral axis.
Unit: [length].

Remarks

Neutral axis divides the part of the compression from the tension.
This is line where the strain changes sign.
Unit depends to the units used to define concrete, steel, geometry and internal forces.

Exceptions

Exception | Condition
 | Calculation are not performed.

See Also

RCSolver Class
Autodesk.CodeChecking.Concrete Namespace