Autodesk.Revit.DB.CodeChecking.Attributes Namespace

Autodesk.Revit.DB.CodeChecking.Attributes Namespace

Classes

 | Class | Description
Public class | CalculationParamsStructureAttribute | Indicates what type should be used as CalculationParameter structure.
Public class | DataStructureAttribute | Base class for all Data Structure attributes
Public class | LabelStructureAttribute | Indicates what type should be used as Label structure.
Public class | ResultStructureAttribute | Indicates what type should be used as Result structure.
Public class | ServerVersionAttribute | Indicates version of the server.

CalculationParamsStructureAttribute Class

CalculationParamsStructureAttribute Class
Members See Also Send Feedback
Indicates what type should be used as CalculationParameter structure.

Namespace: Autodesk.Revit.DB.CodeChecking.Attributes
Assembly: CodeChecking (in CodeChecking.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public class CalculationParamsStructureAttribute : DataStructureAttribute

Remarks

Used for MultiStructureServers.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..DataStructureAttribute
Autodesk.Revit.DB.CodeChecking.Attributes..::..CalculationParamsStructureAttribute

See Also

CalculationParamsStructureAttribute Members
Autodesk.Revit.DB.CodeChecking.Attributes Namespace