ServiceData Members

[image]

Structural Analysis and Code Checking API Reference Guide
ServiceData Members
ServiceData Class Constructors Methods Properties See Also Send Feedback

The ServiceData type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceData | Initializes a new instance of the ServiceData class.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | ActiveServersDueToSelection | Gets or sets the active servers due to selection.
Public property | Context | Gets the context of execution.
Public property | Document | The active document.
Public property | Selection | Current document selection.
Public property | Session | Gets the current session.

See Also

ServiceData Class
Autodesk.Revit.DB.CodeChecking Namespace