ForceCalculationDataDescriptorLinear Constructor (, Double, IEnumerable(Double), Boolean, List(ForceType))

ForceCalculationDataDescriptorLinear Constructor (, Double, IEnumerable<(Of <(<'Double>)>)>, Boolean, List<(Of <(<'ForceType>)>)>)
ForceCalculationDataDescriptorLinear Class See Also Send Feedback
Creates default ForceCalculationPointsDescriptorLinear

Namespace: Autodesk.Revit.DB.CodeChecking.Engineering
Assembly: CodeChecking.Engineering (in CodeChecking.Engineering.dll) Version: 2015.0.0.0 (2015.0.0.2432)

Syntax

C#
public ForceCalculationDataDescriptorLinear(
    ElementId elementId,
    double elementLength,
    IEnumerable<double> points,
    bool isInputRelative,
    List<ForceType> forceTypes
)

Parameters

elementId
Type: ElementId
Revit ElementId for element to which calculation point is assigned
elementLength
Type: System..::..Double
Element length(absolute or relative)
points
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>
Calculation points coordinates
isInputRelative
Type: System..::..Boolean
Flag informing whether input values are absolute or relative
forceTypes
Type: System.Collections.Generic..::..List <(Of <(<' ForceType >)>)>
A list of ForceType elements to be taken into account during calculations

See Also

ForceCalculationDataDescriptorLinear Class
ForceCalculationDataDescriptorLinear Overload
Autodesk.Revit.DB.CodeChecking.Engineering Namespace