DataStructureAttribute Members

[image]

Structural Analysis and Code Checking API Reference Guide
DataStructureAttribute Members
DataStructureAttribute Class Constructors Methods Properties See Also Send Feedback

The DataStructureAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | DataStructureAttribute(Type) | Initializes a new instance of the DataStructureAttribute class.
Public method | DataStructureAttribute(Type, BuiltInCategory) | Initializes a new instance of the DataStructureAttribute class.
Public method | DataStructureAttribute(Type, StructuralAssetClass) | Initializes a new instance of the DataStructureAttribute class.
Public method | DataStructureAttribute(Type, BuiltInCategory, StructuralAssetClass) | Initializes a new instance of the DataStructureAttribute class.

Methods

 | Name | Description
 | GetDataStructure(Type, Type, Guid) | Gets the data structure type based on attributes assigned to source type.
 | GetDataStructure(Type, Type, BuiltInCategory, StructuralAssetClass) | Gets the data structure type based on attributes assigned to source type.

Properties

 | Name | Description

See Also

DataStructureAttribute Class
Autodesk.Revit.DB.CodeChecking.Attributes Namespace