SlabInfo Methods

[image]

Structural Analysis and Code Checking API Reference Guide
SlabInfo Methods
SlabInfo Class See Also Send Feedback

The SlabInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetEdge(List<(Of <<'(XYZ>)>>)) | Returns edge of specific cooridinates.
Public method | GetEdge(XYZ, XYZ) | Returns edge of specific coordinates.
Public method | GetMainContour | returns main contour of the slab.
Public method | GetNode | Returns node of specific coordinates.
Public method | IsPointInDomain | Checks if point is in domain of slab (it has to be inside main contour and it can't be inside any hole)
Public method | StructuralLayer | Gets the structural layer.
Public method | Thickness | Gets the thickness of slab.

See Also

SlabInfo Class
Autodesk.Revit.DB.CodeChecking.Engineering Namespace