Revit 2011 API
HostObjAttributes..::.CompoundStructure Property
HostObjAttributes Class See Also Send Feedback
Returns an object that represents the compound structure of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CompoundStructure CompoundStructure { get; }
Visual Basic (Declaration)
Public ReadOnly Property CompoundStructure As CompoundStructure
Visual C++
public:
property CompoundStructure^ CompoundStructure {
    CompoundStructure^ get ();
}

Remarks

From this object the layers of a compound structure can be accessed. If the element does not have a compound structure then this method will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

HostObjAttributes Class

Parameter Property

[image] [image]