Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.NonSystemPanelFamiliesCannotBeUsed Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NonSystemPanelFamiliesCannotBeUsed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NonSystemPanelFamiliesCannotBeUsed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NonSystemPanelFamiliesCannotBeUsed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class

PanelsSlightlyMalformedCorruption Property

[image]