Revit 2011 API
MEPSpaceConstruction..::.SpaceConstructions Property
MEPSpaceConstruction Class See Also Send Feedback
Return all the Space constructions of current space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPBuildingConstructionSet SpaceConstructions { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpaceConstructions As MEPBuildingConstructionSet
Visual C++
public:
property MEPBuildingConstructionSet^ SpaceConstructions {
    MEPBuildingConstructionSet^ get ();
}

Remarks

If the name is same with the existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace

OccupancyUnit Enumeration

[image]