Revit 2011 API
Document..::.NewWall Method
Document Class See Also Send Feedback
Creates a new wall within the project.

Overload List

Name | Description
NewWall(CurveArray, Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
NewWall(Curve, Level, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
NewWall(CurveArray, WallType, Level, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
NewWall(CurveArray, WallType, Level, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
NewWall(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace

NewWall Method (CurveArray, Boolean)

[image]