Revit 2011 API
RebarShapeDefinitionBySegments..::.SetSegmentAs180DegreeBend Method (Int32)
RebarShapeDefinitionBySegments Class See Also Send Feedback
Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment
)
Visual Basic (Declaration)
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
    int iSegment
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).

See Also

RebarShapeDefinitionBySegments Class
SetSegmentAs180DegreeBend Overload
Autodesk.Revit.DB.Structure Namespace

SetSegmentAs180DegreeBend Method (Int32, Parameter, Boolean)

[image]