Revit 2011 API
Material..::.CutPattern Property
Material Class See Also Send Feedback
The cut pattern of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FillPattern CutPattern { get; set; }
Visual Basic (Declaration)
Public Property CutPattern As FillPattern
Visual C++
public:
property FillPattern^ CutPattern {
    FillPattern^ get ();
    void set (FillPattern^ value);
}

Field Value

The cut pattern element, or nullNothingnullptra null reference (Nothing in Visual Basic), if the material does not have an associated cut pattern.

See Also

Material Class

CutPatternColor Property

[image]