Revit 2011 API
ApplicationEntryPoint..::.Idling Event
ApplicationEntryPoint Class See Also Send Feedback
Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<IdlingEventArgs> Idling
Visual Basic (Declaration)
Public Event Idling As EventHandler(Of IdlingEventArgs)
Visual C++
public:
 event EventHandler<IdlingEventArgs^>^ Idling {
    void add (EventHandler<IdlingEventArgs^>^ value);
    void remove (EventHandler<IdlingEventArgs^>^ value);
}

Remarks

This event is raised when it is safe for the API application to access the active document between user interactions. The event is raised only when the Revit UI is in a state where the user could successfully click on an API command button.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

In order to change a document, you must begin a new transaction for that document. This transaction will appear in the Revit undo stack and may be undone by the Revit user.

This event is invoked between user actions in the Revit UI. If the handler for this event requires a significant amount of processing time, users will perceive a slowdown in the responsiveness of Revit. If the execution for updates can be safely split across multiple calls to this event, the user perception of Revit responsiveness will be improved.

Event is not cancellable.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace

ViewActivated Event

[image]