Revit 2011 API
Outline Methods
Outline Class See Also Send Feedback

The Outline type exposes the following members.

Methods

Name | Description
AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Contains | Determine if this Outline contains the specified point to within a tolerance.
ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Dispose |
Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Scale | Scales the bounding box by given scale.

See Also

Outline Class

AddPoint Method

[image]