Revit 2011 API
DimensionSegment..::.Origin Property
DimensionSegment Class See Also Send Feedback
The segment origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

The origin will be the midpoint of the line that makes up the segment.

See Also

DimensionSegment Class

Value Property

[image]