Revit 2011 API
FailureMessageAccessor..::.HasResolutionOfType Method
FailureMessageAccessor Class See Also Send Feedback
Checks if failure has a resolution of a given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutionOfType(
    FailureResolutionType type
)
Visual Basic (Declaration)
Public Function HasResolutionOfType ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool HasResolutionOfType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
The type of resolution.

Return Value

True if failure has a resolution of a given type, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class

HasResolutions Method

[image]