Revit 2011 API
ParameterValueProvider..::.Parameter Property
ParameterValueProvider Class See Also Send Feedback
The parameter used to provide a string, integer, and double-precision, or ElementId value on request for a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId Parameter { get; set; }
Visual Basic (Declaration)
Public Property Parameter As ElementId
Visual C++
public:
property ElementId^ Parameter {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

ParameterValueProvider Class

PartType Enumeration

[image]