Revit 2011 API
Document..::.Array Method (ElementSet, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of several elements using a specified angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RadialArray Array(
    ElementSet elements,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns nullNothingnullptra null reference (Nothing in Visual Basic). If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Array Overload

Array Method (ICollection(ElementId), Int32, Boolean, XYZ)

[image]