Revit 2011 API
InstanceArray..::.Item Property
InstanceArray Class See Also Send Feedback
Gets or sets an instance at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GeometryInstance Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As GeometryInstance
Visual C++
public:
virtual property GeometryInstance^ Item[int index] {
    GeometryInstance^ get (int index);
    void set (int index, GeometryInstance^ value);
}

Parameters

index
Type: System..::.Int32
The index of the instance to be set or retrieved.

Return Value

Returns the instance at the specified index.

See Also

InstanceArray Class

Size Property

[image]