Revit 2011 API
Application..::.NewFamilySymbolProfile Method
Application Class See Also Send Feedback
Creates a new FamilySymbolProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolProfile NewFamilySymbolProfile(
    FamilySymbol familySymbol
)
Visual Basic (Declaration)
Public Function NewFamilySymbolProfile ( _
    familySymbol As FamilySymbol _
) As FamilySymbolProfile
Visual C++
public:
FamilySymbolProfile^ NewFamilySymbolProfile(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.DB..::.FamilySymbol
The family symbol of the Profile.

Return Value

The new FamilySymbolProfile object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument fmailySymbol is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewFBXExportOptions Method

[image]