Revit 2011 API
MaterialWood..::.UnitWeight Property
MaterialWood Class See Also Send Feedback
Get or set the unit weight of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double UnitWeight { get; set; }
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialWood Class

YoungModulus Property

[image]