Revit 2011 API
Document..::.Array Method
Document Class See Also Send Feedback
Creates an array of one or more elements.

Overload List

Name | Description
Array(Element, Int32, Boolean, XYZ) | Creates an array of an element using a specified number.
Array(Element, Int32, Boolean, Double) | Creates a radial array of an element using a specified angle.
Array(ElementId, Int32, Boolean, XYZ) | Creates an array of an element, specified by id, using a specified number.
Array(ElementId, Int32, Boolean, Double) | Creates a radial array of an element, specified by id, using a specified angle.
Array(ElementSet, Int32, Boolean, XYZ) | Creates an array of several elements using a specified number.
Array(ElementSet, Int32, Boolean, Double) | Creates a radial array of several elements using a specified angle.
Array(ICollection<(Of <(ElementId>)>), Int32, Boolean, XYZ) | Creates an array of several elements, specified by ids, using a specified number.
Array(ICollection<(Of <(ElementId>)>), Int32, Boolean, Double) | Creates a radial array of several elements, specified by id, using a specified angle.

See Also

Document Class
Document Members

Array Method (Element, Int32, Boolean, XYZ)

[image]