Revit 2011 API
AnalysisDisplayStyle..::.CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)
AnalysisDisplayStyle Class See Also Send Feedback
Factory method - creates analysis display style object for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic (Declaration)
Public Shared Function CreateAnalysisDisplayStyle ( _
    document As Document, _
    name As String, _
    coloredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings, _
    colorSettings As AnalysisDisplayColorSettings, _
    legendSettings As AnalysisDisplayLegendSettings _
) As AnalysisDisplayStyle
Visual C++
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayColoredSurfaceSettings^ coloredSurfaceSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
Document for which analysis display style object is created.
name
Type: System..::.String
Unique name of the analysis display style within the %document%.
coloredSurfaceSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColoredSurfaceSettings
Colored surface settings for the style to be created.
colorSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorSettings
Color settings for the style to be created.
legendSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegendSettings
Legend settings for the style to be created.

Return Value

New analysis display style object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | document is a family. -or- name is not unique in document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace

CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)

[image]