Revit 2011 API
TransactionGroup..::.Start Method (String)
TransactionGroup Class See Also Send Feedback
Starts the transaction group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Start(
    string transGroupName
)
Visual Basic (Declaration)
Public Function Start ( _
    transGroupName As String _
) As TransactionStatus
Visual C++
public:
TransactionStatus Start(
    String^ transGroupName
)

Parameters

transGroupName
Type: System..::.String
Name of the group When assimilate the group, all transactions inside the group will be merged into one undo menu item with the group's name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The TransactionGroup has already been started
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TransactionGroup Class
Start Overload

TransactionStatus Enumeration

[image]