Revit 2011 API
Element..::.Category Property
Element Class See Also Send Feedback
Retrieves a Category object that represents the category or sub category in which the element resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Category Category { get; }
Visual Basic (Declaration)
Public ReadOnly Property Category As Category
Visual C++
public:
property Category^ Category {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

See Also

Element Class

DesignOption Property

[image]