Revit 2011 API
Map Members
Map Class Constructors Methods Properties See Also Send Feedback

The Map type exposes the following members.

Constructors

Name | Description
Map | Initializes a new instance of the Map class

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
Item | Gets or sets an item at a specified key within the map.
Size | Returns the number of objects that are in the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace

Map Constructor

[image]