Revit 2011 API
Material..::.SurfacePattern Property
Material Class See Also Send Feedback
The surface pattern of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FillPattern SurfacePattern { get; set; }
Visual Basic (Declaration)
Public Property SurfacePattern As FillPattern
Visual C++
public:
property FillPattern^ SurfacePattern {
    FillPattern^ get ();
    void set (FillPattern^ value);
}

Field Value

The surface pattern element, or nullNothingnullptra null reference (Nothing in Visual Basic), if the material does not have an associated surface pattern.

See Also

Material Class

SurfacePatternColor Property

[image]