Revit 2011 API
Document..::.NewSlabEdge Method (SlabEdgeType, ReferenceArray)
Document Class See Also Send Feedback
Creates a slab edge along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    references As ReferenceArray _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge(
    SlabEdgeType^ SlabEdgeType,
    ReferenceArray^ references
)

Parameters

SlabEdgeType
Type: Autodesk.Revit.DB..::.SlabEdgeType
The type of the slab edge to create
references
Type: Autodesk.Revit.DB..::.ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the slab edge.

Return Value

If successful a new slab edge object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSlabEdge Overload
Autodesk.Revit.Creation Namespace

NewSpace Method

[image] [image]