Revit 2011 API
ConceptualConstructionRoofType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Roofs.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum ConceptualConstructionRoofType
Visual Basic (Declaration)
Public Enumeration ConceptualConstructionRoofType
Visual C++
public enum class ConceptualConstructionRoofType

Members

Member name | Description
InvalidRoofTypeConstruction | Invalid value/not set Roof Type Construction value
HighInsulationCoolRoof | High Insulation Cool Roof
HighInsulationDarkRoof | High Insualtion Dark Roof
TypicalInsulationCoolRoof | Typical Insulation Cool Roof
TypicalInsulationDarkRoof | Typical Insulation Dark Roof
LowInsulationCoolRoof | Low Insulation Cool Roof
LowInsulationDarkRoof | Low Insulation Dark Roof
NoInsulationDarkRoof | No Insulation Dark Roof
NumRoofTypeConstruction | Total Number of Roof Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace

ConceptualConstructionShadeType Enumeration

[image]