Revit 2011 API
Element Class
Members See Also Send Feedback
Base class for most persistent data within a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Element : IDisposable
Visual Basic (Declaration)
Public Class Element _
    Implements IDisposable
Visual C++
public ref class Element : IDisposable

Remarks

The data in a Revit document consists primarily of a collection of elements. An element usually corresponds to a single component of a building or drawing, such as a wall, door, or dimension, but it can also be something more abstract, like a wall type or a view. Every element in a document has a unique ID, represented by the ElementId class.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegend
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayStyle
Autodesk.Revit.DB.Analysis..::.MassEnergyAnalyticalModel
Autodesk.Revit.DB.Analysis..::.MassLevelData
Autodesk.Revit.DB.Analysis..::.MassSurfaceData
Autodesk.Revit.DB.Analysis..::.MassZone
Autodesk.Revit.DB.Analysis..::.SpatialFieldManager
Autodesk.Revit.DB..::.AreaScheme
Autodesk.Revit.DB..::.BaseArray
Autodesk.Revit.DB..::.BasePoint
Autodesk.Revit.DB..::.BeamSystem
Autodesk.Revit.DB..::.BoundaryConditions
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.ConnectorElement
Autodesk.Revit.DB..::.Control
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.DesignOption
Autodesk.Revit.DB..::.Dimension
Autodesk.Revit.DB..::.DividedSurface
Autodesk.Revit.DB.Electrical..::.CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::.ElectricalDemandFactorDefinition
Autodesk.Revit.DB.Electrical..::.ElectricalLoadClassification
Autodesk.Revit.DB.Electrical..::.PanelScheduleSheetInstance
Autodesk.Revit.DB.Electrical..::.PanelScheduleTemplate
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.Enclosure
Autodesk.Revit.DB..::.EnclosureTag
Autodesk.Revit.DB..::.FamilyBase
Autodesk.Revit.DB..::.FillPattern
Autodesk.Revit.DB..::.FilterElement
Autodesk.Revit.DB..::.GraphicsStyle
Autodesk.Revit.DB..::.Grid
Autodesk.Revit.DB..::.Group
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.ImportInstance
Autodesk.Revit.DB..::.IndependentTag
Autodesk.Revit.DB..::.Instance
Autodesk.Revit.DB..::.Level
Autodesk.Revit.DB..::.LinePattern
Autodesk.Revit.DB..::.Material
Autodesk.Revit.DB.Mechanical..::.Zone
Autodesk.Revit.DB..::.MEPSystem
Autodesk.Revit.DB..::.ModelText
Autodesk.Revit.DB..::.Opening
Autodesk.Revit.DB..::.Phase
Autodesk.Revit.DB..::.PrintSetting
Autodesk.Revit.DB..::.ProjectInfo
Autodesk.Revit.DB..::.ProjectUnit
Autodesk.Revit.DB..::.PropertyLine
Autodesk.Revit.DB..::.ReferencePlane
Autodesk.Revit.DB..::.ReferencePoint
Autodesk.Revit.DB..::.SketchBase
Autodesk.Revit.DB..::.SketchPlane
Autodesk.Revit.DB.Structure..::.AreaReinforcement
Autodesk.Revit.DB.Structure..::.LoadBase
Autodesk.Revit.DB.Structure..::.LoadCase
Autodesk.Revit.DB.Structure..::.LoadCombination
Autodesk.Revit.DB.Structure..::.LoadNature
Autodesk.Revit.DB.Structure..::.LoadUsage
Autodesk.Revit.DB.Structure..::.PathReinforcement
Autodesk.Revit.DB.Structure..::.Rebar
Autodesk.Revit.DB.Structure..::.Truss
Autodesk.Revit.DB..::.SunAndShadowSettings
Autodesk.Revit.DB..::.TextElement
Autodesk.Revit.DB..::.TopographySurface
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.ViewSheetSet

See Also

Element Members

Element Members

[image] [image]