Revit 2011 API
PushButton..::.AssemblyName Property
PushButton Class See Also Send Feedback
The assembly path of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic (Declaration)
Public Property AssemblyName As String
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Remarks

The path of the assembly which contains the corresponding external command.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting the value to a ToggleButton which is not initialized with an external command.

See Also

PushButton Class
Autodesk.Revit.UI Namespace

AvailabilityClassName Property

[image]