Revit 2011 API
RebarShapeDefinition..::.AddFormulaParameter Method
RebarShapeDefinition Class See Also Send Feedback
Add a formula-driven parameter to the shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Parameter AddFormulaParameter(
    ExternalDefinition param,
    string formula
)
Visual Basic (Declaration)
Public Function AddFormulaParameter ( _
    param As ExternalDefinition, _
    formula As String _
) As Parameter
Visual C++
public:
Parameter^ AddFormulaParameter(
    ExternalDefinition^ param,
    String^ formula
)

Parameters

param
Type: Autodesk.Revit.DB..::.ExternalDefinition
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
formula
Type: System..::.String

Return Value

The new formula-driven shape parameter.

Remarks

Like AddParameter(), this function introduces a parameter into the shape definition, but the parameter's value is driven by a formula. Formula parameters cannot be used in constraints to drive the shape. The formula is in the same format as in Revit families. The formula is allowed to refer to other parameters that are already in the definition, plus the builtin parameters REBAR_INSTANCE_BAR_DIAMETER, REBAR_INSTANCE_BEND_DIAMETER, REBAR_SHAPE_START_HOOK_LENGTH, REBAR_SHAPE_START_HOOK_OFFSET, REBAR_SHAPE_END_HOOK_LENGTH, REBAR_SHAPE_END_HOOK_OFFSET, REBAR_ELEM_LENGTH, REBAR_ELEM_TOTAL_LENGTH, and REBAR_ELEM_QUANTITY_OF_BARS.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace

AddParameter Method

[image]