Revit 2011 API
CategoryNameMap..::.Item Property
CategoryNameMap Class See Also Send Feedback
Gets or sets a category at a specified name within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Category Item[
    string key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As Category
Visual C++
public:
virtual property Category^ Item[String^ key] {
    Category^ get (String^ key);
    void set (String^ key, Category^ value);
}

Parameters

key
Type: System..::.String
The name of the category to be set or retrieved.

Return Value

Returns the category at the specified name.

See Also

CategoryNameMap Class

Size Property

[image]