Revit 2011 API
Document..::.DocumentClosing Event
Document Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic (Declaration)
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document. This document-level event precedes the application-level event of the same name.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another Revit::ApplicationServices::Application::DocumentClosed event will be raised immediately after document is closed.

See Also

Document Class

DocumentPrinted Event

[image]