Revit 2011 API
SunAndShadowSettings Class
Members See Also Send Feedback
The SunAndShadowSettings class represents the sun control.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class SunAndShadowSettings : Element
Visual Basic (Declaration)
Public Class SunAndShadowSettings _
    Inherits Element
Visual C++
public ref class SunAndShadowSettings : public Element

Remarks

The SunAndShadowSettings element represents the settings applied to a project or view regarding the position, dates, time intervals and other options for the sun control and solar studies. To differentiate between the project and view settings, test the ViewSpecific or OwnerViewId property. If the element is not view-specific this element represents a project-wide setting. If the element is associated to a view, this element represents a per view SunAndShadowSettings. When you create a new view, a new view-specific SunAndShadowSettings element is automatically created for it.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.SunAndShadowSettings

See Also

SunAndShadowSettings Members

SunAndShadowSettings Members

[image] [image]