Revit 2011 API
RebarShapeDefinitionBySegments..::.AddListeningDimensionSegmentToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddListeningDimensionSegmentToSegment(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionSegmentToSegment ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToSegment(
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::.Int32
Index of the first segment (0 to NumberOfSegments - 1).
iSegment1
Type: System..::.Int32
Index of the second segment (0 to NumberOfSegments - 1).

Remarks

RebarShapeDefinitionBySegments supports driving (read-write) dimensions only when they are associated with a single segment. Non-driving dimensions can involve multiple segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

RemoveParameterFromSegment Method

[image]