Revit 2011 API
Rebar..::.Curves Property
Rebar Class See Also Send Feedback
The centerline of the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Remarks

These curves represent the centerline of the rebar, including the hooks and bends. They are the curves shown in Revit views at the coarse detail level.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

DistributionPath Property

[image]