Revit 2011 API
MaterialConcrete..::.ConcreteCompression Property
MaterialConcrete Class See Also Send Feedback
Get or set the concrete compression of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ConcreteCompression { get; set; }
Visual Basic (Declaration)
Public Property ConcreteCompression As Double
Visual C++
public:
property double ConcreteCompression {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when trying to set the concrete compression to an invalid value.

See Also

MaterialConcrete Class

DampingRatio Property

[image]