Revit 2011 API
MaterialConcrete..::.PoissonModulusX Property
MaterialConcrete Class See Also Send Feedback
Get or set the x component of the Poisson modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusX { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class

PoissonModulusY Property

[image]