Revit 2011 API
Document..::.PathName Property
Document Class Example See Also Send Feedback
Call this function to get the fully qualified path of the document's disk file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string PathName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathName As String
Visual C++
public:
property String^ PathName {
    String^ get ();
}

Remarks

The project's fully qualified path. This string is empty if the project has not been saved or does not have a disk file associated with it.

Examples

CopyC#
string docPathName = document.PathName;
CopyVB.NET
Dim docPathName As String = document.PathName

See Also

Document Class

Phases Property

[image]