Revit 2011 API
Transaction Constructor (Document)
Transaction Class See Also Send Feedback
Instantiates an uninitialized transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transaction(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
Transaction(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which this transaction is going to be used.

Remarks

The transaction does not start by creating a transaction object. The Start(String) method will need to be called in order to start this transaction. Because this constructor does not take a name, a name must be assigned later before or during the Start method. A transaction cannot start unless is has a valid (non-empty) name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class
Transaction Overload

Transaction Constructor (Document, String)

[image]