Revit 2011 API
RebarShape..::.Definition Property
RebarShape Class See Also Send Feedback
Get the shape definition object associated with this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeDefinition Definition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definition As RebarShapeDefinition
Visual C++
public:
property RebarShapeDefinition^ Definition {
    RebarShapeDefinition^ get ();
}

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) until one of the factory methods (e.g. NewDefinitionBySegments()) is called.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

HookAngle Property

[image]