Revit 2011 API
ParameterType Enumeration
See Also Send Feedback
An enumerated type listing all of the data type interpretation that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ParameterType
Visual Basic (Declaration)
Public Enumeration ParameterType
Visual C++
public enum class ParameterType

Members

Member name | Description
Invalid | The parameter type is invalid. This value should not be used.
Text | The parameter data should be interpreted as a string of text.
Integer | The parameter data should be interpreted as a whole number, positive or negative.
Number | The parameter data should be interpreted as a real number, possibly including decimal points.
Length | The parameter data represents a length.
Area | The parameter data represents an area.
Volume | The parameter data represents a volume.
Angle | The parameter data represents an angle.
URL | A text string that represents a web address.
Material | The value of this property is considered to be a material.
YesNo | A boolean value that will be represented as Yes or No.
Force | The data value will be represented as a force.
LinearForce | The data value will be represented as a linear force.
AreaForce | The data value will be represented as an area force.
Moment | The data value will be represented as a moment.
NumberOfPoles | A parameter value that represents the number of poles, as used in electrical disciplines.
FixtureUnit | A parameter value that represents the fixture units, as used in piping disciplines.
FamilyType | A parameter used to control the type of a family nested within another family.
LoadClassification | A parameter value that represents the load classification units, as used in electrical disciplines.
HVACDensity | The data value will be represented as a HVACDensity.
HVACEnergy | The data value will be represented as a HVACEnergy.
HVACFriction | The data value will be represented as a HVACFriction.
HVACPower | The data value will be represented as a HVACPower.
HVACPowerDensity | The data value will be represented as a HVACPowerDensity.
HVACPressure | The data value will be represented as a HVACPressure.
HVACTemperature | The data value will be represented as a HVACTemperature.
HVACVelocity | The data value will be represented as a HVACVelocity.
HVACAirflow | The data value will be represented as a HVACAirflow.
HVACDuctSize | The data value will be represented as a HVACDuctSize.
HVACCrossSection | The data value will be represented as a HVACCrossSection.
HVACHeatGain | The data value will be represented as a HVACHeatGain.
ElectricalCurrent | The data value will be represented as an ElectricalCurrent.
ElectricalPotential | The data value will be represented as an ElectricalPotential.
ElectricalFrequency | The data value will be represented as an ElectricalFrequency.
ElectricalIlluminance | The data value will be represented as an ElectricalIlluminance.
ElectricalLuminousFlux | The data value will be represented as an ElectricalLuminousFlux.
ElectricalPower | The data value will be represented as an ElectricalPower.
HVACRoughness | The data value will be represented as a HVACRoughness.
ElectricalApparentPower | The data value will be represented as an ElectricalApparentPower.
ElectricalPowerDensity | The data value will be represented as an ElectricalPowerDensity.
PipingDensity | The data value will be represented as a PipingDensity.
PipingFlow | The data value will be represented as a PipingFlow.
PipingFriction | The data value will be represented as a PipingFriction.
PipingPressure | The data value will be represented as a PipingPressure.
PipingTemperature | The data value will be represented as a PipingTemperature.
PipingVelocity | The data value will be represented as a PipingVelocity.
PipingViscosity | The data value will be represented as a PipingViscosity.
PipeSize | The data value will be represented as a PipeSize.
PipingRoughness | The data value will be represented as a PipingRoughness.
Stress | The data value will be represented as a Stress.
UnitWeight | The data value will be represented as a UnitWeight.
TemperalExp | The data value will be represented as a TemperalExp.
LinearMoment | The data value will be represented as a LinearMoment.
ForcePerLength | The data value will be represented as a ForcePerLength.
ForceLengthPerAngle | The data value will be represented as a ForceLengthPerAngle.
LinearForcePerLength | The data value will be represented as a LinearForcePerLength.
LinearForceLengthPerAngle | The data value will be represented as a LinearForceLengthPerAngle.
AreaForcePerLength | The data value will be represented as an AreaForcePerLength.
PipingVolume | The data value will be represented as a PipingVolume.
HVACViscosity | The data value will be represented as a HVACViscosity.
HVACCoefficientOfHeatTransfer | The data value will be represented as a HVACCoefficientOfHeatTransfer.
HVACAirflowDensity | The data value will be represented as a HVACAirflowDensity.
Slope | The data value will be represented as a Slope.
HVACCoolingLoad | The data value will be represented as a HVACCoolingLoad.
HVACCoolingLoadDividedByArea | The data value will be represented as a HVACCoolingLoadDividedByArea.
HVACCoolingLoadDividedByVolume | The data value will be represented as a HVACCoolingLoadDividedByVolume.
HVACHeatingLoad | The data value will be represented as a HVACHeatingLoad.
HVACHeatingLoadDividedByArea | The data value will be represented as a HVACHeatingLoadDividedByArea.
HVACHeatingLoadDividedByVolume | The data value will be represented as a HVACHeatingLoadDividedByVolume.
HVACAirflowDividedByVolume | The data value will be represented as a HVACAirflowDividedByVolume.
HVACAirflowDividedByCoolingLoad | The data value will be represented as a HVACAirflowDividedByCoolingLoad.
HVACAreaDividedByCoolingLoad | The data value will be represented as a HVACAreaDividedByCoolingLoad.
WireSize | The data value will be represented as a WireSize.
HVACSlope | The data value will be represented as a HVACSlope.
PipingSlope | The data value will be represented as a PipingSlope.
Currency | The data value will be represented as a Currency.
ElectricalEfficacy | The data value will be represented as an ElectricalEfficacy.
ElectricalWattage | The data value will be represented as an ElectricalWattage.
ColorTemperature | The data value will be represented as a ColorTemperature.
ElectricalLuminousIntensity | The data value will be represented as an ElectricalLuminousIntensity.
ElectricalLuminance | The data value will be represented as an ElectricalLuminance.
HVACAreaDividedByHeatingLoad | The data value will be represented as a HVACAreaDividedByHeatingLoad.
HVACFactor | The data value will be represented as a HVACFactor.
ElectricalTemperature | The data value will be represented as a ElectricalTemperature.
ElectricalCableTraySize | The data value will be represented as a ElectricalCableTraySize.
ElectricalConduitSize | The data value will be represented as a ElectricalConduitSize.
ReinforcementVolume | The data value will be represented as a ReinforcementVolume.
ReinforcementLength | The data value will be represented as a ReinforcementLength.
ElectricalDemandFactor | The data value will be represented as a ElectricalDemandFactor.

See Also

ParameterValueProvider Class

[image]