Revit 2011 API
Document..::.Export Method (String, String, ViewSet, DWGExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWG format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWGExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWGExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWGExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::.ViewSet
Selection of views to be exported. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, only the active view will be exported.
options
Type: Autodesk.Revit.DB..::.DWGExportOptions
Various options applicable to the DWG format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Export Overload

Export Method (String, String, ViewSet, DXFExportOptions)

[image]