Revit 2011 API
Enclosure..::.Name Property
Enclosure Class See Also Send Feedback
A human readable name for the Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The Name property is a human readable name for the element, such as Wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the name of the element cannot be changed.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the element requires a unique name and a non-unique name is set.

See Also

Enclosure Class

Number Property

[image]