Revit 2011 API
Document..::.NewAreas Method
Document Class See Also Send Feedback
Creates new areas

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewAreas(
    List<AreaCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewAreas ( _
    dataList As List(Of AreaCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewAreas(
    List<AreaCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( AreaCreationData >)>)
A list of AreaCreationData which wraps the creation arguments of the areas to be created.

Return Value

If successful an Element Set which contains the areas should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | If AreaCreationData's areaPoint is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the area cannot be created successfully or the phase is invalid or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewAreaTag Method

[image]