Revit 2011 API
FamilySymbolProfile..::.Profile Property
FamilySymbolProfile Class See Also Send Feedback
Returns the family symbol of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol Profile { get; set; }
Visual Basic (Declaration)
Public Property Profile As FamilySymbol
Visual C++
public:
property FamilySymbol^ Profile {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

The symbol must of the category BuiltInCategory.OST_ProfileFamilies.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the category of argument is not BuiltInCategory.OST_ProfileFamilies.

See Also

FamilySymbolProfile Class

XOffset Property

[image]