Revit 2011 API
MassSurfaceData..::.PercentageGlazing Property
MassSurfaceData Class See Also Send Feedback
The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double PercentageGlazing { get; set; }
Visual Basic (Declaration)
Public Property PercentageGlazing As Double
Visual C++
public:
property double PercentageGlazing {
    double get ();
    void set (double value);
}

Remarks

The resulting coverage of the wall with windows is not guaranteed to match this value. It is a target.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace

PercentageSkylights Property

[image]