Revit 2011 API
AnalyticalModel..::.GetCurves Method
AnalyticalModel Class See Also Send Feedback
Retrieves all curves for the Analytical Model of a given type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<Curve> GetCurves(
    AnalyticalCurveType curveType
)
Visual Basic (Declaration)
Public Function GetCurves ( _
    curveType As AnalyticalCurveType _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetCurves(
    AnalyticalCurveType curveType
)

Parameters

curveType
Type: Autodesk.Revit.DB.Structure..::.AnalyticalCurveType
Which curve type should be returned.

Return Value

An array of curves representing analytical model.

Remarks

If the analytical model contains no curves of the given type, then the returned array may be empty.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

GetElementId Method

[image]