Revit 2011 API
Document..::.Regenerate Method
Document Class See Also Send Feedback
Updates the elements in the Revit document to reflect all changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Regenerate()
Visual Basic (Declaration)
Public Sub Regenerate
Visual C++
public:
void Regenerate()

Remarks

Use this method to force update to the document after a group of changes. Note that when a transaction is committed there is an automatic call to regenerate the document.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions..::.RegenerationFailedException Thrown when the regeneration option is automatic or the operation fails.
  • If regeneration fails, there is posted error of severity DocumentCorruption that will be delivered to the end user at the end of transaction explaining what specifically has happened.
  • If regeneration has failed, document is corrupted and even reading from it is illegal.
  • Code that called regeneration and got this exception should not catch and ignore it - instead, it should do nothing but internal cleanup and return control to the owner of currently active transaction/subtransaction, which must be aborted.

See Also

Document Class

Rotate Method

[image] [image]