Revit 2011 API
AnalyticalModelSelector Constructor (Curve)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector based on a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    Curve curve
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve _
)
Visual C++
public:
AnalyticalModelSelector(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The curve upon which this selector acts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelSelector Constructor (AnalyticalCurveSelector)

[image]