Revit 2011 API
SubTransaction..::.Commit Method
SubTransaction Class See Also Send Feedback
Commits all changes made to the model during the sub-transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Commit()
Visual Basic (Declaration)
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus::Committed

Remarks

The changes are not permanently committed to the document yet. They will be committed only when the parent transaction is committed. If the transaction is rolled back, the changes committed here will be discarded too.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction's current status is not TransactionStatus.Started, therefore it may not be committed or rolled back.

See Also

SubTransaction Class

Dispose Method

[image]