Revit 2011 API
DocumentEntryPoint..::.PromptForFamilyInstancePlacement Method
DocumentEntryPoint Class See Also Send Feedback
Prompts the user to place instances of the specified FamilySymbol.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void PromptForFamilyInstancePlacement(
    FamilySymbol familySymbol
)
Visual Basic (Declaration)
Public Sub PromptForFamilyInstancePlacement ( _
    familySymbol As FamilySymbol _
)
Visual C++
public:
void PromptForFamilyInstancePlacement(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.DB..::.FamilySymbol
The FamilySymbol.

Remarks

This method opens its own transaction, so it's not permitted to be invoked in an active transaction. In a single invocation, the user can place multiple instances of the input family type until they finish the placement (with Cancel or ESC or a click elsewhere in the UI). The user will not be permitted to change the type to be placed. Users are not permitted to change the active view during this placement operation (the operation will be completed).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this API method is invoked in an active transaction, or this document is not active, or this is a family document and the instances of this family symbol can not exist in the current family, or this family symbol has no command to create instance, or the command to create instance is disabled in active view.

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace

RefreshActiveView Method

[image]