Revit 2011 API
MaterialGeneric..::.ThermalExpansionCoefficientX Property
MaterialGeneric Class See Also Send Feedback
Get or set the x component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientX { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientX As Double
Visual C++
public:
property double ThermalExpansionCoefficientX {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the x component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then the y and z components of thermal expansion coefficient will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class

ThermalExpansionCoefficientY Property

[image]