Revit 2011 API
Transaction..::.HasStarted Method
Transaction Class See Also Send Feedback
Determines whether the transaction has been started yet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasStarted()
Visual Basic (Declaration)
Public Function HasStarted As Boolean
Visual C++
public:
bool HasStarted()

Remarks

A transaction is considered being started after the Start method was called and until the transaction is either completely committed or rolled back. HasStarted may return True even after Commit (or RollBack) was called if the method returned the Pending status. A transaction can only be Started when HasStarted returns false.

See Also

Transaction Class

RollBack Method

[image] [image]