Revit 2011 API
RebarShapeDefinitionBySegments..::.AddConstraintToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Add a constraint that helps determine the length of a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintToSegment(
    int iSegment,
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic (Declaration)
Public Sub AddConstraintToSegment ( _
    iSegment As Integer, _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    signOfZCoordOfCrossProductOfConstraintDirBySegmentDir As Integer, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintToSegment(
    int iSegment,
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
signOfZCoordOfCrossProductOfConstraintDirBySegmentDir
Type: System..::.Int32
Legal values are 1 and -1. For a fixed-direction segment, this value is ignored. For a variable-direction segment, this value is combined with the constraint length (the nonnegative value associated with 'param') to determine the direction of the segment. For example, a segment whose direction vector lies in the upper-right quadrant of the plane, and whose x-axis projected length is A and whose y-axis projected length is B, could be created by calling: AddConstraintToSegment(iSegment, paramA, 1.0, 0.0, 1, ...) AddConstraintToSegment(iSegment, paramB, 0.0, 1.0, -1, ...)
measureToOutsideOfBend0
Type: System..::.Boolean
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
measureToOutsideOfBend1
Type: System..::.Boolean
Choose between two possibilities for the second reference of the length dimension.

Remarks

The vector defined by (constraintDirCoordX, constraintDirCoordY) must have a positive dot product with the desired direction of the segment. This restriction, combined with the value of signOfZCoordOfCrossProductOfConstraintDirBySegmentDir, defines a quadrant of the plane that limits the variable-angle segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

AddListeningDimensionBendToBend Method

[image]