Revit 2011 API
MassEnergyAnalyticalModel..::.GetReferencesToAllFaces Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get References to all Faces which are meaningful for the MassEnergyAnalyticalModel. Array of References to Faces of the MassEnergyAnalyticalModel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<Reference> GetReferencesToAllFaces()
Visual Basic (Declaration)
Public Function GetReferencesToAllFaces As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferencesToAllFaces()

Remarks

The results are always references to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports them as REFERENCE_TYPE_NONE.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace

GetReferencesToAllShadingFaces Method

[image]