Revit 2011 API
FailureDefinitionAccessor Members
FailureDefinitionAccessor Class Methods See Also Send Feedback

The FailureDefinitionAccessor type exposes the following members.

Methods

Name | Description
Dispose |
GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
GetDefaultResolutionType | Retrieves the default resolution type for the failure.
GetDescriptionText | Retrieves the description text of the failure.
GetId | Retrieves the unique identifier of the FailureDefinition.
GetResolutionCaption | Retrieves the caption for a specific resolution type.
GetSeverity | Retrieves severity of the failure.
HasResolutions | Checks if the FailureDefinition has at least one resolution.
IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
SetDefaultResolutionType | Sets the default resolution type for the failure.

See Also

FailureDefinitionAccessor Class

FailureDefinitionAccessor Methods

[image] [image]