Revit 2011 API
AnalysisDisplayStyle..::.SetColorSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set color settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetColorSettings(
    AnalysisDisplayColorSettings colorSettings
)
Visual Basic (Declaration)
Public Sub SetColorSettings ( _
    colorSettings As AnalysisDisplayColorSettings _
)
Visual C++
public:
void SetColorSettings(
    AnalysisDisplayColorSettings^ colorSettings
)

Parameters

colorSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace

SetLegendSettings Method

[image]