Revit 2011 API
BuiltInFailures..::.RebarFailures..::.BarTypeDoesNotAllowHooksOfCurrentShape Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BarTypeDoesNotAllowHooksOfCurrentShape { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BarTypeDoesNotAllowHooksOfCurrentShape As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BarTypeDoesNotAllowHooksOfCurrentShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class

BendDiameterTooLarge Property

[image]