Revit 2011 API
Document..::.NewRebarHookType Method
Document Class See Also Send Feedback
Creates a new instance of Rebar Hook Type, which defines the hook style of the rebar.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarHookType NewRebarHookType(
    double angle,
    double multiplier
)
Visual Basic (Declaration)
Public Function NewRebarHookType ( _
    angle As Double, _
    multiplier As Double _
) As RebarHookType
Visual C++
public:
RebarHookType^ NewRebarHookType(
    double angle,
    double multiplier
)

Parameters

angle
Type: System..::.Double
The bending angle of rebar hook.
multiplier
Type: System..::.Double
The extension multiplier of rebar hook.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewRebarShape Method

[image]