Revit 2011 API
BuiltInFailures..::.RenderFailures..::.LightSourceInsideGeometry Property
BuiltInFailures..::.RenderFailures Class See Also Send Feedback
Light source is inside solid geometry. No light will be emitted during rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LightSourceInsideGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LightSourceInsideGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LightSourceInsideGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RenderFailures Class

ProhibitDeletionLightSource Property

[image]