Revit 2011 API
FamilyManager Members
FamilyManager Class Methods Properties See Also Send Feedback

The FamilyManager type exposes the following members.

Methods

Name | Description
AddParameter | Overloaded. Add a new parameter to the family.
AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
DeleteCurrentType | Remove the current family type.
GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
MakeInstance | Set the family parameter as an instance parameter.
MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
MakeReporting | Set the family parameter as a reporting parameter.
MakeType | Set the family parameter as a type parameter.
NewType | Add a new family type with a given name and makes it be the current type.
RemoveParameter | Remove an existing family parameter from the family.
RenameCurrentType | Rename the current family type.
RenameParameter | Rename a family parameter.
ReplaceParameter | Overloaded.
Set | Overloaded. Set the value of a family parameter of the current family type.
SetFormula | Set the formula of a family parameter.
SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
SetValueString | Set the string value of a family parameter of the current family type.

Properties

Name | Description
CurrentType | The current family type.
Parameter | Overloaded. Obtains a parameter based on an identifier.
Parameters | All family parameters in this family.
Types | All family types in the family.

See Also

FamilyManager Class

FamilyManager Methods

[image] [image]