Revit 2011 API
RebarShapeDefinitionBySegments..::.NumberOfSegments Property
RebarShapeDefinitionBySegments Class See Also Send Feedback
The number of straight segments in this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfSegments { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfSegments As Integer
Visual C++
public:
property int NumberOfSegments {
    int get ();
}

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeSet Class

[image]