Revit 2011 API
FieldDomainPointsByXYZ Constructor
FieldDomainPointsByXYZ Class See Also Send Feedback
Creates object from an array of three-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FieldDomainPointsByXYZ(
    IList<XYZ> points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As IList(Of XYZ) _
)
Visual C++
public:
FieldDomainPointsByXYZ(
    IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
Array of three-dimensional point coordinates representing domain points

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByXYZ Class
Autodesk.Revit.DB.Analysis Namespace

FieldDomainPointsByXYZ Methods

[image] [image]