Revit 2011 API
Document..::.NewSpaces Method (Phase, Int32)
Document Class See Also Send Feedback
Creates a set of new unplaced spaces on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewSpaces(
    Phase phase,
    int count
)
Visual Basic (Declaration)
Public Function NewSpaces ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
public:
ElementSet^ NewSpaces(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase
The phase in which the spaces are to exist.
count
Type: System..::.Int32

Return Value

If successful, a set if new unplaced spaces are be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSpaces Overload
Autodesk.Revit.Creation Namespace

NewSpaces Method (Level, Phase, View)

[image]