Revit 2011 API
TableSectionData Methods
TableSectionData Class See Also Send Feedback

The TableSectionData type exposes the following members.

Methods

Name | Description
Dispose |
GetCellCalculatedValue | Overloaded.
GetCellCategoryId | Overloaded.
GetCellCombinedParameters | Overloaded.
GetCellParamId | Overloaded.
GetCellText | Returns a cell's text depending on its type
GetCellType | Overloaded.
GetColumnWidth | Returns a column's width
GetMergedCell | Gets the whole merged cell that this cell is a part of.
GetRowHeight | Returns a row's height
GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
MergeCells | Merges cells for the given area.
SetCellCalculatedValue | Overloaded.
SetCellCombinedParameters | Overloaded.
SetCellParamIdAndCategoryId | Overloaded.
SetCellStyle | Overloaded.
SetCellText | Sets a cell's style
SetCellType | Overloaded.
SetColumnWidth | Sets a column's width
SetMergedCell | Sets the merged cell that this cell is a part of.
SetRowHeight | Sets a row's height

See Also

TableSectionData Class

Dispose Method

[image]