Revit 2011 API
Opening Properties
Opening Class See Also Send Feedback

The Opening type exposes the following members.

Properties

Name | Description
BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
Host | Retrieves the host element of this opening.
IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.

See Also

Opening Class

BoundaryCurves Property

[image]