Revit 2011 API
RibbonItem..::.Name Property
RibbonItem Class See Also Send Feedback
The name of the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; internal set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the text to empty or to the string contains "%".

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace

ToolTip Property

[image]