Revit 2011 API
Rebar..::.ArrayLength Property
Rebar Class See Also Send Feedback
Identifies the distribution path length of rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ArrayLength { get; set; }
Visual Basic (Declaration)
Public Property ArrayLength As Double
Visual C++
public:
property double ArrayLength {
    double get ();
    void set (double value);
}

Field Value

The distribution path length of rebar set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: the set length arrayLength isn't acceptable.
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

BarsOnNormalSide Property

[image]