Revit 2011 API
AnalyticalModel..::.IsValidAnalyticalProjectionType Method
AnalyticalModel Class See Also Send Feedback
Indicates whether a given Analytical Projection Type is valid for the given Analytical Direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic (Declaration)
Public Function IsValidAnalyticalProjectionType ( _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
) As Boolean
Visual C++
public:
bool IsValidAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which Analytical Model may be projected.
projectionType
Type: Autodesk.Revit.DB.Structure..::.AnalyticalProjectionType
Identifies Analytical Projection Type for Analytical Model Projection.

Return Value

True if Analytical Projection Type is valid; false otherwise. False if direction does not satisfy isValidDirectionForProjection().

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

IsValidDatumPlaneForProjection Method

[image]