Revit 2011 API
Face Class
Members See Also Send Feedback
A face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Face : GeometryObject
Visual Basic (Declaration)
Public Class Face _
    Inherits GeometryObject
Visual C++
public ref class Face : public GeometryObject

Remarks

Faces are defined by surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Face
Autodesk.Revit.DB..::.ConicalFace
Autodesk.Revit.DB..::.CylindricalFace
Autodesk.Revit.DB..::.HermiteFace
Autodesk.Revit.DB..::.PlanarFace
Autodesk.Revit.DB..::.RevolvedFace
Autodesk.Revit.DB..::.RuledFace

See Also

Face Members

Face Members

[image] [image]