Revit 2011 API
AnalyticalModel..::.Approximate Method
AnalyticalModel Class See Also Send Feedback
Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void Approximate(
    bool enableApproximation
)
Visual Basic (Declaration)
Public Sub Approximate ( _
    enableApproximation As Boolean _
)
Visual C++
public:
void Approximate(
    bool enableApproximation
)

Parameters

enableApproximation
Type: System..::.Boolean
Enable/disable approximated function.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support approximation.
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

CanApproximate Method

[image]