Revit 2011 API
TransactionGroup..::.Start Method
TransactionGroup Class See Also Send Feedback
Starts the transaction group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Start()
Visual Basic (Declaration)
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The TransactionGroup has already been started

See Also

TransactionGroup Class
Start Overload

Start Method (String)

[image]