Revit 2011 API
Connector Class
Members Example See Also Send Feedback
A connector in an Autodesk Revit MEP project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Connector : APIObject, IConnector
Visual Basic (Declaration)
Public Class Connector _
    Inherits APIObject _
    Implements IConnector
Visual C++
public ref class Connector : public APIObject,
    IConnector

Remarks

This connector is an item that is a part of another element (duct, pipe, fitting, or equipment). This connector does not represent the connector element that can be created inside a family; for that element, refer to DuctConnector, PipeConnector and ElectricalConnector.

Examples

CopyC#
public void GetElementAtConnector(Autodesk.Revit.DB.Connector connector)
{
    MEPSystem mepSystem = connector.MEPSystem;
    if (null != mepSystem)
    {
        string message = "Connector is owned by: " + connector.Owner.Name;

        if (connector.IsConnected == true)
        {
            ConnectorSet connectorSet = connector.AllRefs;
            ConnectorSetIterator csi = connectorSet.ForwardIterator();
            while (csi.MoveNext())
            {
                Connector connected = csi.Current as Connector;
                if (null != connected)
                {
                    // look for physical connections
                    if (connected.ConnectorType == ConnectorType.EndConn ||
                        connected.ConnectorType == ConnectorType.CurveConn ||
                        connected.ConnectorType == ConnectorType.PhysicalConn)
                    {
                        message += "\nConnector is connected to: " + connected.Owner.Name;
                        message += "\nConnection type is: " + connected.ConnectorType;
                    }
                }
            }
        }
        else
        {
            message += "\nConnector is not connected to anything.";
        }

        TaskDialog.Show("Revit", message);
    }
}
CopyVB.NET
Public Sub GetElementAtConnector(ByVal connector As Autodesk.Revit.DB.Connector)
    Dim mepSystem As MEPSystem = connector.MEPSystem
    If mepSystem IsNot Nothing Then
        Dim message As String = "Connector is owned by: " + connector.Owner.Name

        If connector.IsConnected = True Then
            Dim connectorSet As ConnectorSet = connector.AllRefs
            Dim csi As ConnectorSetIterator = connectorSet.ForwardIterator()
            While csi.MoveNext()
                Dim connected As Connector = TryCast(csi.Current, Connector)
                If connected IsNot Nothing Then
                    ' look for physical connections
                    If connected.ConnectorType = ConnectorType.EndConn OrElse connected.ConnectorType = ConnectorType.CurveConn OrElse connected.ConnectorType = ConnectorType.PhysicalConn Then
                        message += vbLf & "Connector is connected to: " + connected.Owner.Name
                        message += vbLf & "Connection type is: " + connected.ConnectorType
                    End If
                End If
            End While
        Else
            message += vbLf & "Connector is not connected to anything."
        End If

        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Connector

See Also

Connector Members

Connector Members

[image] [image]