Revit 2011 API
RebarShapeDefinitionByArc..::.Type Property
RebarShapeDefinitionByArc Class See Also Send Feedback
Among those rebar shapes defined by an arc, specify which kind.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeDefinitionByArcType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As RebarShapeDefinitionByArcType
Visual C++
public:
property RebarShapeDefinitionByArcType Type {
    RebarShapeDefinitionByArcType get ();
    void set (RebarShapeDefinitionByArcType value);
}

Remarks

This property may be explicitly set to Arc or LappedCircle. But to set the property to Spiral, you must call SetArcTypeSpiral() and provide default values for the height, pitch, and finishing turns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeDefinitionByArcType Enumeration

[image]