Revit 2011 API
FamilyInstance..::.FlipFromToRoom Method
FamilyInstance Class See Also Send Feedback
Change the room to which the door or window is opened.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void FlipFromToRoom()
Visual Basic (Declaration)
Public Sub FlipFromToRoom
Visual C++
public:
void FlipFromToRoom()

Remarks

The FromRoom and ToRoom properties of current family instance's swap after calling this method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when current family instance is neither door nor window.

See Also

FamilyInstance Class

flipHand Method

[image]