Revit 2011 API
Connector..::.AssignedDuctFlowConfiguration Property
Connector Class See Also Send Feedback
The assigned duct flow configuration of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctFlowConfigurationType AssignedDuctFlowConfiguration { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedDuctFlowConfiguration As DuctFlowConfigurationType
Visual C++
public:
property DuctFlowConfigurationType AssignedDuctFlowConfiguration {
    DuctFlowConfigurationType get ();
}

Remarks

Assigned duct flow configuration may be assigned for connectors of some family instances, for more information, refer to DuctConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get duct flow configuration.

See Also

Connector Class

AssignedDuctLossMethod Property

[image]