Revit 2011 API
SubTransaction Members
SubTransaction Class Constructors Methods See Also Send Feedback

The SubTransaction type exposes the following members.

Constructors

Name | Description
SubTransaction | Instantiates a sub-transaction object

Methods

Name | Description
Commit | Commits all changes made to the model during the sub-transaction
Dispose |
GetStatus | Returns the current status of the sub-transaction
HasEnded | Determines whether the sub-transaction has ended already
HasStarted | Determines whether the sub-transaction has been started yet
RollBack | Discards all changes made to the model during the sub-transaction
Start | Starts the sub-transaction

See Also

SubTransaction Class

SubTransaction Constructor

[image]