Revit 2011 API
ImportInstance..::.Pinned Property
ImportInstance Class See Also Send Feedback
Identifies if the element has been pinned to prevent changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Pinned { get; set; }
Visual Basic (Declaration)
Public Property Pinned As Boolean
Visual C++
public:
property bool Pinned {
    bool get ();
    void set (bool value);
}

Remarks

An element which is pinned may not be moved, and warnings will be issued when an attempt is made to delete it.

See Also

ImportInstance Class

ImportPlacement Enumeration

[image]