Revit 2011 API
Floor Members
Floor Class Methods Properties See Also Send Feedback

The Floor type exposes the following members.

Methods

Name | Description
GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.

Properties

Name | Description
FloorType | Retrieves/set an object that represents the type of the floor.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
SpanDirectionAngle | Retrieve the span direction angle of the floor
SpanDirectionSymbols | An array of span direction symbols associated with this floor.
StructuralUsage | The floors designated structural usage, such as bearing or non bearing.

See Also

Floor Class

Floor Methods

[image] [image]