Revit 2011 API
SpatialFieldManager Members
SpatialFieldManager Class Methods Properties See Also Send Feedback

The SpatialFieldManager type exposes the following members.

Methods

Name | Description
AddSpatialFieldPrimitive | Overloaded.
Clear | Clear all analysis results managed by this manager object
CreateSpatialFieldManager | Factory method - creates manager object for the given view
GetLegend | Returns legend element or NULL
GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
RemoveSpatialFieldPrimitive | Removes analysis results container (primitive) identified by the unique index
SetMeasurementNames | sets Names for all measurements
SetUnits | Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method
UpdateSpatialFieldPrimitive | Populates analysis results data (or replaces the existing data) in the existing container (primitive) identified by the unique index

Properties

Name | Description
CurrentMeasurement | Stores the currently displayed measurement
CurrentUnits | Stores the index in the array of applicable units
Description | description of the data
NumberOfMeasurements | Stores the total number of measurements
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
UseRangeForAllResults | Governs how minimum and maximum values (the data range) are calculated.

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace

SpatialFieldManager Methods

[image] [image]