Revit 2011 API
EdgeArray..::.Item Property
EdgeArray Class See Also Send Feedback
Gets or sets an edge at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Edge Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Edge
Visual C++
public:
virtual property Edge^ Item[int index] {
    Edge^ get (int index);
    void set (int index, Edge^ value);
}

Parameters

index
Type: System..::.Int32
The index of the edge to be set or retrieved.

Return Value

Returns the edge at the specified index.

See Also

EdgeArray Class

Size Property

[image]