Revit 2011 API
ElectricalSetting Members
ElectricalSetting Class Methods Properties See Also Send Feedback

The ElectricalSetting type exposes the following members.

Methods

Name | Description
AddDistributionSysType | Add a new distribution system type to project.
AddVoltageType | Add a new type definition of voltage into project.
AddWireMaterialType | Add a new type of wire material.
AddWireType | Add a new wire type to project.
RemoveDistributionSysType | Remove an existing distribution system type from the project.
RemoveVoltageType | Remove the voltage type from project.
RemoveWireMaterialType | Remove the wire material type from project.
RemoveWireType | Remove wire type definition from project.

Properties

Name | Description
DistributionSysTypes | Get all distribution system types of the project.
VoltageTypes | Get all voltage type definitions information of the project.
WireConduitTypes | Get electrical conduit types information of the project.
WireMaterialTypes | Get electrical wire material types information of the project.
WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace

ElectricalSetting Methods

[image] [image]