Revit 2011 API
FlexPipe..::.Points Property
FlexPipe Class See Also Send Feedback
The points of the flex pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> Points { get; set; }
Visual Basic (Declaration)
Public Property Points As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ Points {
    IList<XYZ^>^ get ();
    void set (IList<XYZ^>^ value);
}

Remarks

This property is used to retrieve the points of flex pipe, including the end points. If the end points are changed, the connection will be maintained by Revit automatically. The set operation will fail if the modification makes the connection invalid.

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace

FlexPipeType Class

[image]