Revit 2011 API
Wall..::.StructuralUsage Property
Wall Class See Also Send Feedback
The walls designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StructuralWallUsage StructuralUsage { get; set; }
Visual Basic (Declaration)
Public Property StructuralUsage As StructuralWallUsage
Visual C++
public:
property StructuralWallUsage StructuralUsage {
    StructuralWallUsage get ();
    void set (StructuralWallUsage value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Wall Class

WallType Property

[image]