Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.NoConstraintsInProperSketch Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoConstraintsInProperSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoConstraintsInProperSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoConstraintsInProperSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class

NoConstraintsToLinks Property

[image]