Revit 2011 API
DocumentPreviewSettings..::.PreviewViewId Property
DocumentPreviewSettings Class See Also Send Feedback
The view id that will be used to generate the preview.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_UR2

Syntax

C#
public ElementId PreviewViewId { get; set; }
Visual Basic (Declaration)
Public Property PreviewViewId As ElementId
Visual C++
public:
property ElementId^ PreviewViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

InvalidElementId signals that there is no permanent preview view for the document; where possible the active view will be used to generate the preview upon save.

Remarks

This view will always be saved as the preview view for the document. It will always be used to generate the preview, even if the active view is different, unless it is changed or removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

DocumentPreviewSettings Class

DocumentSet Class

[image]