Revit 2011 API
Options..::.DetailLevel Property
Options Class See Also Send Feedback
The detail level for the geometry extracted with these options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DetailLevels DetailLevel { get; set; }
Visual Basic (Declaration)
Public Property DetailLevel As DetailLevels
Visual C++
public:
property DetailLevels DetailLevel {
    DetailLevels get ();
    void set (DetailLevels value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting this property, if View is already set. When View is set the detail level of the view is used.

See Also

Options Class

IncludeNonVisibleObjects Property

[image]