Revit 2011 API
EnergyDataSettings..::.PercentageSkylights Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. The approximate percentage of the the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double PercentageSkylights { get; set; }
Visual Basic (Declaration)
Public Property PercentageSkylights As Double
Visual C++
public:
property double PercentageSkylights {
    double get ();
    void set (double value);
}

Remarks

This value is used to automatically model the skylights in massing instances when the Energy Analytical model is being created.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace

ProjectPhase Property

[image]