Revit 2011 API
AnalyticalModel..::.SetAnalyzeAs Method
AnalyticalModel Class See Also Send Feedback
Sets value of Analyze As parameter for this Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyzeAs(
    AnalyzeAs analyzeAs
)
Visual Basic (Declaration)
Public Sub SetAnalyzeAs ( _
    analyzeAs As AnalyzeAs _
)
Visual C++
public:
void SetAnalyzeAs(
    AnalyzeAs analyzeAs
)

Parameters

analyzeAs
Type: Autodesk.Revit.DB.Structure..::.AnalyzeAs
Indicates how Analytical Model is analyzed .

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | analyzeAs is invalid for analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

SetApproximationDeviation Method

[image]