Revit 2011 API
GeometryElement Class
Members See Also Send Feedback
Geometric representation of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GeometryElement : GeometryObject
Visual Basic (Declaration)
Public Class GeometryElement _
    Inherits GeometryObject
Visual C++
public ref class GeometryElement : public GeometryObject

Remarks

This class contains geometric primitives that are generated from the parametric description of the element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.GeometryElement

See Also

GeometryElement Members

GeometryElement Members

[image] [image]