Revit 2011 API
UIControlledApplication Members
UIControlledApplication Class Methods Properties Events See Also Send Feedback

The UIControlledApplication type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Overloaded.
GetRibbonPanels | Overloaded.

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ControlledApplication | Returns the database level ControlledApplication represented by this UI-level ControlledApplication.
LoadedApplications | Returns an array of successfully loaded external applications.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace

UIControlledApplication Methods

[image] [image]