Revit 2011 API
MaterialSteel..::.Duplicate Method
MaterialSteel Class See Also Send Feedback
Duplicate this steel material element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

MaterialSteel Class

MaterialSteel Properties

[image] [image]