Revit 2011 API
Document..::.Export Method (String, String, IFCExportOptions)
Document Class See Also Send Feedback
Exports the document to the Industry Standard Classes (IFC) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    IFCExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    options As IFCExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    IFCExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
The name of the file to be exported to. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
options
Type: Autodesk.Revit.DB..::.IFCExportOptions
Options applicable to the IFC format. If nullNothingnullptra null reference (Nothing in Visual Basic), default options will be used

Return Value

Function returns true only if the model has been exported successfully. Otherwise it return False.

Remarks

Exporting to IFC requires that document is modifiable, therefore there must be a transaction already open when this method is called.

This method may not be invoked during dynamic update, for the internal routine might need to modify the existing transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
Export Overload

Export Method (String, String, ViewSet, DGNExportOptions)

[image]