Revit 2011 API
IExternalApplication..::.OnShutdown Method
IExternalApplication Interface See Also Send Feedback
Provide an interface for the user to do some extra work when Revit closes.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
Result OnShutdown(
    UIControlledApplication application
)
Visual Basic (Declaration)
Function OnShutdown ( _
    application As UIControlledApplication _
) As Result
Visual C++
Result OnShutdown(
    UIControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit.UI..::.UIControlledApplication
The application is being shut down.

Return Value

Indicates if the external application completes its work successfully.

Remarks

If the user implements the interface for an external application, the task within OnShutdown will be executed when Revit closes.

See Also

IExternalApplication Interface
Autodesk.Revit.UI Namespace

OnStartup Method

[image]