Revit 2011 API
PipeConnector..::.LinkedConnector Property
PipeConnector Class See Also Send Feedback
The linked pipe connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeConnector LinkedConnector { get; set; }
Visual Basic (Declaration)
Public Property LinkedConnector As PipeConnector
Visual C++
public:
property PipeConnector^ LinkedConnector {
    PipeConnector^ get ();
    void set (PipeConnector^ value);
}

Remarks

Get this property to acquire the current linked pipe connector. If the property is nullNothingnullptra null reference (Nothing in Visual Basic), the connector has no link. Set this property to link this connector to another pipe connector. Set it to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace

Origin Property

[image]