Revit 2011 API
Application..::.LibraryPaths Property
Application Class Example See Also Send Feedback
Retrieves path information for where content is stored on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StringStringMap LibraryPaths { get; set; }
Visual Basic (Declaration)
Public Property LibraryPaths As StringStringMap
Visual C++
public:
property StringStringMap^ LibraryPaths {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

This property is used to control where Autodesk Revit searches for content. The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

Examples

CopyC#
string strLibPaths = "";
foreach (String path in application.LibraryPaths)
{
    strLibPaths += path + "\n";
}
CopyVB.NET
Dim strLibPaths As String = ""
For Each path As [String] In application.LibraryPaths
    strLibPaths += path + vbLf
Next

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

ObjectFactory Property

[image]