Revit 2011 API
MEPBuildingConstruction..::.BuildingConstruction Property
MEPBuildingConstruction Class See Also Send Feedback
Gets or Sets the Building Construction of the Project Information.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use MEPBuildingConstruction.GetBuidingConstruction() or MEPBuildingConstruction.SetBuidingConstruction() instead.")]
public Construction BuildingConstruction[
    ConstructionType constructionType
] { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use MEPBuildingConstruction.GetBuidingConstruction() or MEPBuildingConstruction.SetBuidingConstruction() instead.")> _
Public Property BuildingConstruction ( _
    constructionType As ConstructionType _
) As Construction
Visual C++
[ObsoleteAttribute(L"Use MEPBuildingConstruction.GetBuidingConstruction() or MEPBuildingConstruction.SetBuidingConstruction() instead.")]
public:
property Construction^ BuildingConstruction[ConstructionType constructionType] {
    Construction^ get (ConstructionType constructionType);
    void set (ConstructionType constructionType, Construction^ value);
}

Parameters

constructionType
Type: Autodesk.Revit.DB..::.ConstructionType
The Construction Type to be set the Building Construction.

Remarks

This property is used to get or set the Building Construction of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace

Constructions Property

[image]