Revit 2011 API
Blend..::.TopProfile Property
Blend Class See Also Send Feedback
The curves which make up the top profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray TopProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopProfile As CurveArrArray
Visual C++
public:
property CurveArrArray^ TopProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

Blend Class

TopSketch Property

[image]