Revit 2011 API
TaskDialog..::.Id Property
TaskDialog Class See Also Send Feedback
The Id of the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Remarks

Id is used as TaskDialogShowingEventArgs.DialogId for DialogBoxShowing events.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace

MainContent Property

[image]