Revit 2011 API
Map Methods
Map Class See Also Send Feedback

The Map type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace

Clear Method

[image]