Revit 2011 API
ExternalApplicationArrayIterator..::.Reset Method
ExternalApplicationArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace

ExternalApplicationArrayIterator Properties

[image] [image]