Revit 2011 API
DocumentClosingEventArgs..::.DocumentId Property
DocumentClosingEventArgs Class See Also Send Feedback
Id of the document that is about to be closed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string DocumentId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
}

Remarks

This Id is only used to identify the document for the duration of this event and the DocumentClosed event which follows.

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.DB.Events Namespace

DocumentCreatedEventArgs Class

[image]