Revit 2011 API
PlanTopology..::.Rooms Property
PlanTopology Class See Also Send Feedback
Retrieves rooms of the PlanTopology in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet Rooms { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rooms As ElementSet
Visual C++
public:
property ElementSet^ Rooms {
    ElementSet^ get ();
}

Remarks

The Rooms you get here is in the phase of PlanTopology and the current design option.

See Also

PlanTopology Class

PlanTopologySet Class

[image]