Revit 2011 API
SlabShapeEditor Methods
SlabShapeEditor Class See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Methods

Name | Description
DrawPoint | Adds a point to the corresponding slab, roof or floor.
DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Enable | Enables the slab shape editing functionality.
ModifySubElement | Overloaded. Manipulates an entity on the corresponding slab, roof or floor.
PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the un-modified state.

See Also

SlabShapeEditor Class

DrawPoint Method

[image]