Revit 2011 API
FamilyManager..::.MakeNonReporting Method
FamilyManager Class See Also Send Feedback
Set the reporting family parameter as a regular/driving parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MakeNonReporting(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeNonReporting ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeNonReporting(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to make a parameter which is labeled to an arc length dimension non-reporting.

See Also

FamilyManager Class

MakeReporting Method

[image]