Revit 2011 API
AnalyticalModel..::.GetAnalyticalOffset Method
AnalyticalModel Class See Also Send Feedback
Retrieves Analytical Offset in the case where the user can do that.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public XYZ GetAnalyticalOffset()
Visual Basic (Declaration)
Public Function GetAnalyticalOffset As XYZ
Visual C++
public:
XYZ^ GetAnalyticalOffset()

Return Value

Offset of Analytical Model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This AnalyticalModel does not support offset.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

GetAnalyticalProjectionDatumPlane Method

[image]