Revit 2011 API
Reference..::.ProximityParameter Property
Reference Class See Also Send Feedback
The proximity value to the ray's origin when the reference is returned by FindReferencesByDirection(XYZ, XYZ, View3D).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ProximityParameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProximityParameter As Double
Visual C++
public:
property double ProximityParameter {
    double get ();
}

Return Value

The parameter for the reference relative to the ray input.

Remarks

This value is valid only for References returned from FindReferencesByDirection(XYZ, XYZ, View3D). The value increases the further away the reference is from the origin point for the ray.

See Also

Reference Class

Transform Property

[image]