Revit 2011 API
SpatialFieldManager..::.AddSpatialFieldPrimitive Method (Reference)
SpatialFieldManager Class See Also Send Feedback
Creates empty analysis results container (primitive) associated with reference

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive(
    Reference reference
)
Visual Basic (Declaration)
Public Function AddSpatialFieldPrimitive ( _
    reference As Reference _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
Reference pointing to the curve or face to be associated with the primitive

Return Value

Unique index of primitive for future references

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | reference points to neither face nor curve
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace

AddSpatialFieldPrimitive Method (Curve, Transform)

[image]