Revit 2011 API
Curve Properties
Curve Class See Also Send Feedback

The Curve type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve.
EndParameter | The parameter of the start or the end point of the curve.
EndPoint | The start or the end point of this curve.
EndPointReference | Returns a stable reference to the start point or the end point of the curve.
IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
IsCyclic | The boolean value that indicates whether this curve is cyclic.
Length | The exact length of the curve.
Period | The period of this curve.
Reference | Returns a stable reference to the curve.
Transformed | Applies the specified transformation to this curve and returns the result.

See Also

Curve Class

ApproximateLength Property

[image]