Revit 2011 API
Document Events
Document Class See Also Send Feedback

The Document type exposes the following members.

Events

Name | Description
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save the document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class

DocumentClosing Event

[image]