Revit 2011 API
Document..::.ReactionsAreUpToDate Property
Document Class See Also Send Feedback
Reports if the analytical model has regenerated in a document with reaction loads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ReactionsAreUpToDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReactionsAreUpToDate As Boolean
Visual C++
public:
property bool ReactionsAreUpToDate {
    bool get ();
}

Remarks

Revit sets this property to False after regeneration of the analytical model if the document contains loads that have isReaction=True. This results in a user-visible warning that exists until there are no longer loads with isReaction=True.

See Also

Document Class

RebarBarTypes Property

[image]