Revit 2011 API
FilteredElementCollector..::.GetEnumerator Method
FilteredElementCollector Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator<Element> GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator(Of Element)
Visual C++
public:
virtual IEnumerator<Element^>^ GetEnumerator()

Return Value

An IEnumerator(Autodesk.Revit.DB.Element) object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

FilteredElementCollector Class

IntersectWith Method

[image]