Revit 2011 API
DuctConnector..::.Radius Property
DuctConnector Class See Also Send Feedback
the radius of the connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Radius { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Radius As Double
Visual C++
public:
virtual property double Radius {
    double get ();
}

Implements

IConnector..::.Radius

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not circular.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace

Shape Property

[image]