Revit 2011 API
MaterialSteel Properties
MaterialSteel Class See Also Send Feedback

The MaterialSteel type exposes the following members.

Properties

Name | Description
Behavior | Get or set the material behavior type of the steel material.
DampingRatio | Get or set the damping ratio of the steel material.
MinimumTensileStrength | Get or set the minimum tensile strength of the steel material.
MinimumYieldStress | Get or set the minimum yield stress of the steel material.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
PoissonModulusX | Get or set the x component of the Poisson modulus of the steel material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the steel material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the steel material.
ReductionFactor | Get or set the reduction factor for shear of the steel material.
ShearModulusX | Get or set the x component of the shear modulus of the steel material.
ShearModulusY | Get or set the y component of the shear modulus of the steel material.
ShearModulusZ | Get or set the z component of the shear modulus of the steel material.
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the steel material.
UnitWeight | Get or set the unit weight of the steel material.
YoungModulusX | Get or set the x component of the Young modulus of the steel material.
YoungModulusY | Get or set the y component of the Young modulus of the steel material.
YoungModulusZ | Get or set the z component of the Young modulus of the steel material.

See Also

MaterialSteel Class

Behavior Property

[image]