Revit 2011 API
SubTransaction..::.RollBack Method
SubTransaction Class See Also Send Feedback
Discards all changes made to the model during the sub-transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus RollBack()
Visual Basic (Declaration)
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Return Value

If finished successfully, this method returns TransactionStatus::RolledBack

Remarks

The parent transaction (or a parent sub-transaction, if any) can still be committed, but the changes rolled back by this method will not be a part of the committed transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction's current status is not TransactionStatus.Started, therefore it may not be committed or rolled back.

See Also

SubTransaction Class

Start Method

[image]