Revit 2011 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

Name | Description
NewArc | Overloaded. Creates a new geometric arc object.
NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
NewArray | Creates a new instance of a generic Array.
NewBoundingBoxUV | Overloaded. Creates a two-dimensional rectangle.
NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
NewBuildingSiteExportOptions | Creates Building Site Export options.
NewCategorySet | Creates a new instance of a set specifically for holding category objects.
NewColor | Returns a new color object.
NewCombinableElementArray | Returns an array that can hold combinable element objects.
NewCurveArrArray | Creates an empty array that can store geometric curve loops.
NewCurveArray | Creates an empty array that can store geometric curves.
NewCurveLoopsProfile | Creates a new CurveLoopsProfile object.
NewDGNExportOptions | Creates DGN Export options.
NewDoubleArray | Creates a new instance of a double array.
NewDWFExportOptions | Creates DWF Export options.
NewDWFXExportOptions | Creates DWFX Export options.
NewDWGExportOptions | Creates DWG Export options.
NewDWGImportOptions | Creates DWG Import options.
NewDXFExportOptions | Creates DXF Export options.
NewElementArray | Returns an array that can hold element objects.
NewElementId | Creates a new Autodesk::Revit::DB::ElementId^ object.
NewElementSet | Creates a new instance of a set specifically for holding elements.
NewEllipse | Creates a new geometric ellipse object.
NewFaceArray | Creates a new instance of a face array.
NewFamilyInstanceCreationData | Overloaded. Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilySymbolProfile | Creates a new FamilySymbolProfile object.
NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
NewFillPatternSet | Returns a set that can hold fill pattern objects.
NewGBXMLExportOptions | Creates Green-Building XML Export options.
NewGBXMLImportOptions | Creates Green-Building XML Import options.
NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
NewHermiteSpline | Creates a new geometric Hermite spline object.
NewImageImportOptions | Creates Image Import options.
NewInstanceBinding | Overloaded. Creates a new instance binding object.
NewIntersectionResultArray | Creates a new instance of an IntersectionResult array.
NewInventorImportOptions | Creates Inventor Import options.
NewLine | Creates a new bound or unbounded geometric line object.
NewLineBound | Creates a new bounded geometric line object.
NewLinePatternSet | Returns a set that can hold line pattern objects.
NewLineUnbound | Creates a new unbounded geometric line object.
NewLoadCaseArray | Creates a new instance of a LoadCase array.
NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
NewLoadUsageArray | Creates a new instance of a LoadUsage array.
NewMap | Creates a new instance of a generic Map.
NewMaterialSet | Create a new instance of MaterialSet.
NewNurbSpline | Creates a new geometric nurbSpline object.
NewPlane | Overloaded. Creates a new geometric plane object.
NewPoint | Creates a new geometric point object.
NewPointOnEdge | Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
NewPointOnEdgeEdgeIntersection | Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
NewPointOnEdgeFaceIntersection | Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
NewPointOnFace | Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
NewPointOnPlane | Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
NewProfiledWallCreationData | Overloaded. Creates an object which wraps the arguments of NewWall() for batch creation.
NewProjectPosition | Creates a new project position object.
NewRectangularWallCreationData | Overloaded. Creates an object which wraps the arguments of NewWall() for batch creation.
NewReferenceArray | Creates a new instance of a reference array.
NewReferencePointArray | Creates an empty array that can store ReferencePoint objects.
NewRoomCreationData | Creates an object which wraps the arguments of NewRoom() for batch creation.
NewSATExportOptions | Creates SAT Export options.
NewSet | Creates a new instance of a generic Set.
NewSpaceSet | Creates a new instance of a space set.
NewStringStringMap | Creates a new map that maps one string to another string.
NewSuspendUpdating | Creates a new instance of the SuspendUpdating object and begin suspension of consistency updates.
NewTextNoteCreationData | Overloaded. Creates an object which wraps the arguments of NewTextNote() for batch creation.
NewTypeBinding | Overloaded. Creates a new type binding object.
NewUV | Overloaded. Creates a UV object representing coordinates in 2-space.
NewVertexIndexPair | Creates a new VertexIndexPair object.
NewVertexIndexPairArray | Returns an array that can hold VertexIndexPair objects.
NewViewSet | Creates a new instance of a View set.
NewVolumeCalculationOptions | Creates options related to room volume and area computations.
NewXYZ | Overloaded. Creates a XYZ object representing coordinates in 3-space.

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewArc Method

[image] [image]