Revit 2011 API
FailuresAccessor Methods
FailuresAccessor Class See Also Send Feedback

The FailuresAccessor type exposes the following members.

Methods

Name | Description
CanCommitPendingTransaction | Checks if pending failure processing can be finished by committing a pending transaction.
CanRollBackPendingTransaction | Checks if pending failure processing can be finished by rolling back a pending transaction.
CommitPendingTransaction | Finishes pending failures processing by committing the pending transaction.
DeleteAllWarnings | Deletes all FailureMessages of severity "Warning" currently posted in a document.
DeleteElements | Resolves failures by deletion of elements related to the failures.
DeleteWarning | Deletes one specific failure message of severity "Warning".
Dispose |
GetAttemptedResolutionTypes | Returns list of the failure resolution types attempted for the failure in the current transaction.
GetDocument | Provides access to a document for which failures are being processed or preprocessed.
GetFailureHandlingOptions | Provides access to the failure handling options for the transaction currently being finished.
GetFailureMessages | Overloaded.
GetSeverity | Provides access to the current failure severity.
GetTransactionName | Retrieves the name of the transaction for which failures are being processed.
IsActive | Method allows to check if this instance of the accessor is currently active.
IsElementsDeletionPermitted | Overloaded.
IsFailureResolutionPermitted | Overloaded.
IsPending | Checks if the failure processing is pending.
IsTransactionBeingCommitted | Checks if the transaction for which failures are processed is being committed or rolled back.
JournalFailures | Allows to record information about failures in the journal.
PostFailure | Posts an additional failure message to be processed for the current transaction.
ReplaceFailures | Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.
ResolveFailure | Resolves one failure using the failure resolution type last set for it.
ResolveFailures | Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.
RollBackPendingTransaction | Finishes pending failures processing by rolling back the pending transaction.
SetFailureHandlingOptions | Sets failure handling options for the transaction currently being finished.
SetTransactionName | Changes the name of the transaction for which failures are being processed.

See Also

FailuresAccessor Class

CanCommitPendingTransaction Method

[image]