Revit 2011 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

Name | Description
Assets |
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Documents | Returns a set of documents within Revit.
FamilyTemplatePath | Default path for family template files
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the current session of Revit.
LibraryPaths | Retrieves path information for where content is stored on disk.
ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Product | The product type for the current session of Revit.
RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
VersionBuild | Returns the internal build number of the Autodesk Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

Assets Property

[image]