Revit 2011 API
MEPBuildingConstruction..::.Constructions Property
MEPBuildingConstruction Class See Also Send Feedback
Gets all the Building Constructions according to the specific Construction type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use MEPBuildingConstruction.GetConstructions() instead.")]
public Set Constructions[
    ConstructionType constructionType
] { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use MEPBuildingConstruction.GetConstructions() instead.")> _
Public ReadOnly Property Constructions ( _
    constructionType As ConstructionType _
) As Set
Visual C++
[ObsoleteAttribute(L"Use MEPBuildingConstruction.GetConstructions() instead.")]
public:
property Set^ Constructions[ConstructionType constructionType] {
    Set^ get (ConstructionType constructionType);
}

Parameters

constructionType
Type: Autodesk.Revit.DB..::.ConstructionType
The Construction Type to be set the Building Construction.

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace

Parameter Property

[image] [image]