Revit 2011 API
PartType Enumeration
See Also Send Feedback
An enumerated type listing all the possible part types for a fitting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PartType
Visual Basic (Declaration)
Public Enumeration PartType
Visual C++
public enum class PartType

Members

Member name | Description
UndefinedPartType | The part type is undefined.
Normal | The part type is normal.
DuctMounted | The part type is duct mounted.
JunctionBox | The part type is junction box.
AttachesTo | The part type is attaches to.
BreaksInto | The part type is breaks into.
Elbow | The part type is elbow.
Tee | The part type is tee.
Transition | The part type is transition.
Cross | The part type is cross.
Cap | The part type is cap.
TapPerpendicular | The part type is tap perpendicular.
TapAdjustable | The part type is tap adjustable.
Offset | The part type is offset.
Union | The part type is union.
PanelBoard | The part type is panel board.
Transformer | The part type is transformer.
SwitchBoard | The part type is switch board.
OtherPanel | The part type is other panel.
EquipmentSwitch | The part type is equipment switch.
Switch | The part type is switch.
ValveBreaksInto | The part type is valve breaks into.
SpudPerpendicular | The part type is spud perpendicular.
SpudAdjustable | The part type is spud adjustable.
Damper | The part type is damper.
Wye | The part type is wye.
LateralTee | The part type is lateral tee.
LateralCross | The part type is lateral cross.
Pants | The part type is pants.
MultiPort | The part type is multi port.
ValveNormal | The part type is valve normal.
JunctionBoxTee | The part type is junction box tee.
JunctionBoxCross | The part type is junction box cross.
PipeFlange | The part type is pipe flange.
VerticalElbow | The part type is vertical elbow for cable tray.
JunctionBoxElbow | The part type is junction box elbow.
ChannelCableTrayElbow | The part type is channel cable tray elbow.
ChannelCableTrayVerticalElbow | The part type is channel cable tray vertical elbow.
ChannelCableTrayCross | The part type is channel cable tray cross.
ChannelCableTrayTee | The part type is channel cable tray tee.
ChannelCableTrayTransition | The part type is channel cable tray transition.
ChannelCableTrayUnion | The part type is channel cable tray union.
ChannelCableTrayOffset | The part type is channel cable tray offset.
ChannelCableTrayMultiPort | The part type is channel cable tray multi-port.
LadderCableTrayElbow | The part type is ladder cable tray elbow.
LadderCableTrayVerticalElbow | The part type is ladder cable tray vertical elbow.
LadderCableTrayCross | The part type is ladder cable tray cross.
LadderCableTrayTee | The part type is ladder cable tee.
LadderCableTrayTransition | The part type is ladder cable tray transition.
LadderCableTrayUnion | The part type is ladder cable tray union.
LadderCableTrayOffset | The part type is ladder cable tray offset.
LadderCableTrayMultiPort | The part type is ladder cable tray multi-port.
InlineSensor | The part type is inline sensor.
Sensor | The part type is sensor.

See Also

Path3d Class

[image]