Revit 2011 API
Mullion Members
Mullion Class Methods Properties See Also Send Feedback

The Mullion type exposes the following members.

Methods

Name | Description
BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.

Properties

Name | Description
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
FromRoom | Overloaded. The room from which the door or window is opened.
LocationCurve | This method get the curve location of the current Mullion.
Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Lockable | Get - to get whether the Mullion can be lock or unlock.
MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Room | Overloaded. The room in which the instance is located.
Space | Overloaded. The space in which the instance is located.
ToRoom | Overloaded. The room to which the door or window is opened.

See Also

Mullion Class

Mullion Methods

[image] [image]