Revit 2011 API
Selection..::.Elements Property
Selection Class Example See Also Send Feedback
The elements that are currently selected.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public SelElementSet Elements { get; set; }
Visual Basic (Declaration)
Public Property Elements As SelElementSet
Visual C++
public:
property SelElementSet^ Elements {
    SelElementSet^ get ();
    void set (SelElementSet^ value);
}

Field Value

The set of elements that are actively selected.

Remarks

This set will contain the results after the user makes selections due to a PickOne or WindowSelect call.

Examples

CopyC#
private void ChangeSelection(Document document)
{
    // Get selected elements form current document.
    UIDocument uidoc = new UIDocument(document);
    Autodesk.Revit.UI.Selection.SelElementSet collection = uidoc.Selection.Elements;

    // Display current number of selected elements
    TaskDialog.Show("Revit","Number of selected elements: " + collection.Size.ToString());

    //Create a new SelElementSet
    SelElementSet newSelectedElementSet = SelElementSet.Create();

    // Add wall into the created element set.
    foreach (Autodesk.Revit.DB.Element elements in collection)
    {
        if (elements is Wall)
        {
            newSelectedElementSet.Add(elements);
        }
    }

    // Set the created element set as current select element set.
    uidoc.Selection.Elements = newSelectedElementSet;

    // Give the user some information.
    if (0 != newSelectedElementSet.Size)
    {
        TaskDialog.Show("Revit",uidoc.Selection.Elements.Size.ToString() + " Walls are selected!");
    }
    else
    {
        TaskDialog.Show("Revit","No Walls have been selected!");
    }
}
CopyVB.NET
Private Sub ChangeSelection(ByVal document As Document)
    ' Get selected elements form current document.
    Dim uidoc As New UIDocument(document)
    Dim collection As Autodesk.Revit.UI.Selection.SelElementSet = uidoc.Selection.Elements

    ' Display current number of selected elements
    TaskDialog.Show("Revit", "Number of selected elements: " + collection.Size.ToString())

    'Create a new SelElementSet
    Dim newSelectedElementSet As SelElementSet = SelElementSet.Create()

    ' Add wall into the created element set.
    For Each elements As Autodesk.Revit.DB.Element In collection
        If TypeOf elements Is Wall Then
            newSelectedElementSet.Add(elements)
        End If
    Next

    ' Set the created element set as current select element set.
    uidoc.Selection.Elements = newSelectedElementSet

    ' Give the user some information.
    If 0 <> newSelectedElementSet.Size Then
        TaskDialog.Show("Revit", uidoc.Selection.Elements.Size.ToString() + " Walls are selected!")
    Else
        TaskDialog.Show("Revit", "No Walls have been selected!")
    End If
End Sub

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace

StatusbarTip Property

[image]