Revit 2011 API
PointOnEdge..::.CurveParameter Property
PointOnEdge Class See Also Send Feedback
Parameter along the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CurveParameter { get; set; }
Visual Basic (Declaration)
Public Property CurveParameter As Double
Visual C++
public:
property double CurveParameter {
    double get ();
    void set (double value);
}

Remarks

Ranges from 0.0 to 1.0.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown if CurveParameter is less than 0.0 or greater than 1.0.

See Also

PointOnEdge Class

PointOnEdgeEdgeIntersection Class

[image]