Revit 2011 API
DuctConnector..::.LinkedConnector Property
DuctConnector Class See Also Send Feedback
The linked duct connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctConnector LinkedConnector { get; set; }
Visual Basic (Declaration)
Public Property LinkedConnector As DuctConnector
Visual C++
public:
property DuctConnector^ LinkedConnector {
    DuctConnector^ get ();
    void set (DuctConnector^ value);
}

Remarks

Get this property to acquire the current linked duct connector. If the property is nullNothingnullptra null reference (Nothing in Visual Basic), the connector has no link. Set this property to link this connector to another duct connector. Set it to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace

Origin Property

[image]