Revit 2011 API
ElementArray..::.Item Property
ElementArray Class See Also Send Feedback
Gets or sets an element at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Element Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Element
Visual C++
public:
virtual property Element^ Item[int index] {
    Element^ get (int index);
    void set (int index, Element^ value);
}

Parameters

index
Type: System..::.Int32
The index of the element to be set or retrieved.

Return Value

Returns the element at the specified index.

See Also

ElementArray Class

Size Property

[image]