Revit 2011 API
AnalyticalRigidLinksOption Enumeration
See Also Send Feedback
Specifies how Rigid Links will be made for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalRigidLinksOption
Visual Basic (Declaration)
Public Enumeration AnalyticalRigidLinksOption
Visual C++
public enum class AnalyticalRigidLinksOption

Members

Member name | Description
Enabled | For a structural column, enables rigid link formation, unless the neighboring structural beam overrides the setting. For a structural beam, enables rigid link formation, overriding the neighboring structural column's setting.
Disabled | For a structural column, this disables rigid Link formation, unless the neighboring structural beam overrides the setting. For a structural beam, this disables rigid Link formation, overriding the neighboring structural column's setting.
FromColumn | For a structural beam, this indicates that the structural column setting should be used to determine rigid link formation. This value is not applicable to structural columns.

Remarks

Rigid Links are curves connecting neighboring Structural Beams and Structural Columns.

See Also

Autodesk.Revit.DB.Structure Namespace

AnalyticalSupportChecking Class

[image]