Revit 2011 API
Document..::.ArrayWithoutAssociate Method (Element, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of an element using a specified number where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    Element element,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    Element^ element,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
ArrayWithoutAssociate Overload

ArrayWithoutAssociate Method (Element, Int32, Boolean, Double)

[image]