Revit 2011 API
Document..::.Save Method
Document Class See Also Send Feedback
Saves the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

False if save operation fails. Also returns False if saving is cancelled by an external application during 'DocumentSaving' event. When function succeeds, True is returned.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.Event handlers are not allowed to save document that are currently in modifiable state.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class

SaveAs Method

[image] [image]