Revit 2011 API
Element..::.Document Property
Element Class See Also Send Feedback
Returns the Document in which the Element resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

Remarks

All elements are contained within a document. An element can be retrieved from this document by using the id that is returned by the element's id property.

See Also

Element Class

Geometry Property

[image]