Revit 2011 API
PanelScheduleView..::.GetFontId Method (String, Double, Color)
PanelScheduleView Class See Also Send Feedback
gets the font id for the combination of font name, size, and color

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetFontId(
    string fontName,
    double fontSize,
    Color fontColor
)
Visual Basic (Declaration)
Public Function GetFontId ( _
    fontName As String, _
    fontSize As Double, _
    fontColor As Color _
) As ElementId
Visual C++
public:
ElementId^ GetFontId(
    String^ fontName,
    double fontSize,
    Color^ fontColor
)

Parameters

fontName
Type: System..::.String
fontSize
Type: System..::.Double
fontColor
Type: Autodesk.Revit.DB..::.Color

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
GetFontId Overload
Autodesk.Revit.DB.Electrical Namespace

GetLoadClassificationConnectedCurrent Method

[image]