Revit 2011 API
FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match families by structural material type, with the option to match all families which are not of the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType, _
    inverted As Boolean _
)
Visual C++
public:
FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::.StructuralMaterialType
The structural material type to match.
inverted
Type: System..::.Boolean
True if the filter should match all families which are not of the given structural material type.

See Also

FamilyStructuralMaterialTypeFilter Class
FamilyStructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace

FamilyStructuralMaterialTypeFilter Methods

[image] [image]