Revit 2011 API
HostObject Class
Members See Also Send Feedback
A base class that provides support for all objects that can host other objects, such as a wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class HostObject : Element
Visual Basic (Declaration)
Public Class HostObject _
    Inherits Element
Visual C++
public ref class HostObject : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.CeilingAndFloor
Autodesk.Revit.DB..::.ContFooting
Autodesk.Revit.DB..::.CurtainGridLine
Autodesk.Revit.DB..::.CurtainSystemBase
Autodesk.Revit.DB.Electrical..::.Wire
Autodesk.Revit.DB..::.FaceWall
Autodesk.Revit.DB..::.Floor
Autodesk.Revit.DB..::.HostedSweep
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB..::.RoofBase
Autodesk.Revit.DB..::.Wall

See Also

HostObject Members

HostObject Members

[image] [image]