Revit 2011 API
RebarBarType Methods
RebarBarType Class See Also Send Feedback

The RebarBarType type exposes the following members.

Methods

Name | Description
Create | Creates a new RebarBarType object
GetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
GetHookLength | Identifies the hook length for a hook type
GetHookOffsetLength | Identifies the hook offset length for a hook type
GetHookPermission | Identifies if a hook type is permitted for this bar type
SetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
SetHookLength | Identifies the hook length for a hook type
SetHookOffsetLength | Identifies the hook offset length for a hook type
SetHookPermission | Identifies if a hook type is permitted for this bar type

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

Create Method

[image]