Revit 2011 API
MaterialConcrete Members
MaterialConcrete Class Methods Properties See Also Send Feedback

The MaterialConcrete type exposes the following members.

Methods

Name | Description
Duplicate | Duplicate this concrete material element. (Overrides Material..::.Duplicate(String).)

Properties

Name | Description
Behavior | Get or set the material behavior type of the concrete material.
ConcreteCompression | Get or set the concrete compression of the concrete material.
DampingRatio | Get or set the damping ratio of the concrete material.
LightWeight | Get or set whether the concrete material is lightweight.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
PoissonModulusX | Get or set the x component of the Poisson modulus of the concrete material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the concrete material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the concrete material.
ShearModulusX | Get or set the x component of the shear modulus of the concrete material.
ShearModulusY | Get or set the y component of the shear modulus of the concrete material.
ShearModulusZ | Get or set the z component of the shear modulus of the concrete material.
ShearStrengthReduction | Get or set the shear strength reduction of the concrete material.
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the concrete material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the concrete material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the concrete material.
UnitWeight | Get or set the unit weight of the concrete material.
YoungModulusX | Get or set the x component of the Young modulus of the concrete material.
YoungModulusY | Get or set the y component of the Young modulus of the concrete material.
YoungModulusZ | Get or set the z component of the Young modulus of the concrete material.

See Also

MaterialConcrete Class

MaterialConcrete Methods

[image] [image]