Revit 2011 API
RebarShape..::.GetAllowed Method
RebarShape Class See Also Send Feedback
Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool GetAllowed(
    RebarBarType barType
)
Visual Basic (Declaration)
Public Function GetAllowed ( _
    barType As RebarBarType _
) As Boolean
Visual C++
public:
bool GetAllowed(
    RebarBarType^ barType
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::.RebarBarType
A bar type in the same document as this shape.

Return Value

True if this shape may be combined with this barType.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

GetAllRebarShapeParameters Method

[image]