Revit 2011 API
ConceptualConstructionType..::.GetOpeningConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetOpeningConstructionType(
    Document ccda,
    ConceptualConstructionOpeningType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetOpeningConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionOpeningType _
) As ElementId
Visual C++
public:
static ElementId^ GetOpeningConstructionType(
    Document^ ccda,
    ConceptualConstructionOpeningType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionOpeningType
The ConceptualConstructionOpeningType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionOpeningType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace

GetRoofConstructionType Method

[image]