Revit 2011 API
Sweep..::.IsTrajectorySegmentationEnabled Property
Sweep Class See Also Send Feedback
The trajectory segmentation option for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsTrajectorySegmentationEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsTrajectorySegmentationEnabled As Boolean
Visual C++
public:
property bool IsTrajectorySegmentationEnabled {
    bool get ();
    void set (bool value);
}

Remarks

This property is used to retrieve/set the trajectory segmentation state of the sweep. if return is true, means user can control the MaxSegmentAngle, otherwise is disable.

See Also

Sweep Class

MaxSegmentAngle Property

[image]