Revit 2011 API
ApplicationEntryPoint..::.CreateRibbonPanel Method (Tab, String)
ApplicationEntryPoint Class See Also Send Feedback
Create a new RibbonPanel on the designated standard Revit tab.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    Tab tab,
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    tab As Tab, _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    Tab tab,
    String^ panelName
)

Parameters

tab
Type: Autodesk.Revit.UI..::.Tab
The target tab, on which the new panel will be created.
panelName
Type: System..::.String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the specified tab. This method is not supported in VSTA.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | panelName is Empty or the tab is not valid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If more than 100 panels were created or the tab cannot be found.

See Also

ApplicationEntryPoint Class
CreateRibbonPanel Overload
Autodesk.Revit.VSTA Namespace

FinishInitializationEO Method

[image]