Revit 2011 API
SuspendUpdating Constructor (Document)
SuspendUpdating Class See Also Send Feedback
Creates a new instance of the SuspendUpdating object and begins suspension of consistency updates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SuspendUpdating(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
SuspendUpdating(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which updating will be suspended.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating objects have been disposed, Revit will make the document consistent again. Suspension of updates during parameter set method calls will be enabled when using this constructor.

See Also

SuspendUpdating Class
SuspendUpdating Overload

SuspendUpdating Constructor (Document, Boolean)

[image]