Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures Members
BuiltInFailures..::.AnalyticalModelFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.AnalyticalModelFailures type exposes the following members.

Properties

Name | Description
AnalyticalBeamSlabWarning | Beam and Slab Analytical Models do not have the same Analytical Projection Plane.
AnalyticalDiscrepancyWarning | Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]
AnalyticalGapWarning | Detected physical connection between Structural Elements, but did not detect Analytical intersection.
AnalyticalMemberInstability | Possible Member Instability, based on Release Conditions
AnalyticalModelInstability | Possible Model Instability
AnalyticalPhysicalCheckDone | Analytical / Physical Model Consistency check is complete.
AnalyticalSupportCycleWarning | Circular support chain detected
AnalyticalTopBottomPlanesReversed | Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.
AutoDetectIgnoreLeaderWarning | Analytical Model for Structural Element has reset to its default location.
CannotCreateAnalyticalGeometry | Can not construct Analytical Geometry.
CannotKeepAnalyticalAdjustment | Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.
CannotMakeAnalyticalGeometry | Can not construct Analytical Geometry.
LoadsMayBeNotUpToDate | Some of reactions may be not up-to-date
StructAnalyticalErrorProjection | Can't project Analytical Model to Analytical Projection Surface
StructuralElementMayNotBeSupported | Structural Element may not be supported -- verify support for Element.
StructWallAnalyticalErrorAlign | Can't align Analytical Model with joined Walls.
StructWallAnalyticalErrorConversion | Can't convert Edges to Analytical Model curves.
SupportCheckDone | Member support check is complete. No unsupported elements detected.
ZeroAreaAnalyticalModel | Zero-area Analytical Model Detected
ZeroLengthAnalyticalModel | Zero-length Analytical Model Detected

See Also

BuiltInFailures..::.AnalyticalModelFailures Class

BuiltInFailures.AnalyticalModelFailures Properties

[image] [image]