Revit 2011 API
ElementId Methods
ElementId Class See Also Send Feedback

The ElementId type exposes the following members.

Methods

Name | Description
Compare | Compares two element ids.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::.GetHashCode()()().)
ToString | Gets a String representation of the integer value of the id. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether these two ElementIds are the same.
GreaterThan | Determines whether one element id is greater than another element id.
GreaterThanOrEqual | Determines whether one element id is not less than another element id.
Inequality | Determines whether these two ElementIds are different.
LessThan | Determines whether this element id is less than another element id.
LessThanOrEqual | Determines whether one element id is not greater than another element id.

See Also

ElementId Class

Compare Method

[image]