Revit 2011 API
HostObjAttributes Class
Members See Also Send Feedback
An object that represents characteristics of several kinds of type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class HostObjAttributes : ElementType
Visual Basic (Declaration)
Public Class HostObjAttributes _
    Inherits ElementType
Visual C++
public ref class HostObjAttributes : public ElementType

Remarks

This object provides access to structural layering components for any object derived from it, such as wall types and floor types.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.ContFootingType
Autodesk.Revit.DB..::.CurtainSystemType
Autodesk.Revit.DB..::.FloorType
Autodesk.Revit.DB..::.HostedSweepType
Autodesk.Revit.DB..::.RoofType
Autodesk.Revit.DB..::.WallType

See Also

HostObjAttributes Members

HostObjAttributes Members

[image] [image]