Revit 2011 API
Parameter..::.StorageType Property
Parameter Class See Also Send Feedback
Describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StorageType StorageType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StorageType As StorageType
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

Parameter Class

ParameterFilterElement Class

[image]