Revit 2011 API
SuspendUpdating Constructor (Document, Boolean)
SuspendUpdating Class See Also Send Feedback
Creates a new instance of the SuspendUpdating object and begins suspension of consistency updates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SuspendUpdating(
    Document document,
    bool suspendForParameterSet
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    suspendForParameterSet As Boolean _
)
Visual C++
public:
SuspendUpdating(
    Document^ document,
    bool suspendForParameterSet
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which updating will be suspended.
suspendForParameterSet
Type: System..::.Boolean
True if the suspension of updates also should apply to the parameter set methods. False otherwise.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating objects have been disposed, Revit will make the document consistent again.

See Also

SuspendUpdating Class
SuspendUpdating Overload

SuspendUpdating Methods

[image] [image]