Revit 2011 API
DetailLevels Enumeration
See Also Send Feedback
Chooses the detail level of an element's representation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DetailLevels
Visual Basic (Declaration)
Public Enumeration DetailLevels
Visual C++
public enum class DetailLevels

Members

Member name | Description
Undefined | May produce all or none of the available representations.
Coarse | Corresponds to the coarse view detail setting.
Medium | Corresponds to the medium view detail setting.
Fine | Corresponds to the fine view detail setting.
MAX | The value is used to check whether the enum is the same size as the internal one.

Remarks

This corresponds to detail levels in Revit's views and families.

See Also

DetailLine Class

[image]