Revit 2011 API
Document..::.PanelTypes Property
Document Class See Also Send Feedback
Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelTypeSet PanelTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property PanelTypes As PanelTypeSet
Visual C++
public:
property PanelTypeSet^ PanelTypes {
    PanelTypeSet^ get ();
}

Remarks

This property returns a set of panelType objects. These objects can be used change the type of a panel from one type to another.

See Also

Document Class

ParameterBindings Property

[image]