Revit 2011 API
BuiltInParameterGroup Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BuiltInParameterGroup
Visual Basic (Declaration)
Public Enumeration BuiltInParameterGroup
Visual C++
public enum class BuiltInParameterGroup

Members

Member name | Description
PG_CONCEPTUAL_ENERGY_DATA_BUILDING_SERVICES |
PG_DATA |
PG_ELECTRICAL_CIRCUITING |
PG_GENERAL |
PG_FLEXIBLE |
PG_ENERGY_ANALYSIS_CONCEPTUAL_MODEL |
PG_ENERGY_ANALYSIS_DETAILED_MODEL |
PG_ENERGY_ANALYSIS_DETAILED_AND_CONCEPTUAL_MODELS |
PG_FITTING |
PG_CONCEPTUAL_ENERGY_DATA |
PG_AREA |
PG_ADSK_MODEL_PROPERTIES |
PG_PATTERN_GRID_V |
PG_PATTERN_GRID_U |
PG_DISPLAY |
PG_ANALYSIS_RESULTS |
PG_SLAB_SHAPE_EDIT |
PG_LIGHT_PHOTOMETRICS |
PG_PATTERN_APPLICATION |
PG_GREEN_BUILDING |
PG_PROFILE_2 |
PG_PROFILE_1 |
PG_PROFILE |
PG_TRUSS_FAMILY_BOTTOM_CHORD |
PG_TRUSS_FAMILY_TOP_CHORD |
PG_TRUSS_FAMILY_DIAG_WEB |
PG_TRUSS_FAMILY_VERT_WEB |
PG_TITLE |
PG_FIRE_PROTECTION |
PG_ROTATION_ABOUT |
PG_TRANSLATION_IN |
PG_ANALYTICAL_MODEL |
PG_REBAR_ARRAY |
PG_REBAR_SYSTEM_LAYERS |
PG_ORIENTATION |
PG_PATTERN_GRID |
PG_PATTERN_MULLION_2 |
PG_PATTERN_MULLION_HORIZ |
PG_PATTERN_MULLION_1 |
PG_PATTERN_MULLION_VERT |
PG_PATTERN_GRID_2 |
PG_PATTERN_GRID_HORIZ |
PG_PATTERN_GRID_1 |
PG_PATTERN_GRID_VERT |
PG_IFC |
PG_AELECTRICAL |
PG_ENERGY_ANALYSIS |
PG_STRUCTURAL_ANALYSIS |
PG_MECHANICAL_AIRFLOW |
PG_MECHANICAL_LOADS |
PG_ELECTRICAL_LOADS |
PG_ELECTRICAL_LIGHTING |
PG_TEXT |
PG_VIEW_CAMERA |
PG_VIEW_EXTENTS |
PG_PATTERN |
PG_CONSTRAINTS |
PG_PHASING |
PG_MECHANICAL |
PG_STRUCTURAL |
PG_PLUMBING |
PG_ELECTRICAL |
PG_STAIR_STRINGERS |
PG_STAIR_RISERS |
PG_STAIR_TREADS |
PG_MATERIALS |
PG_GRAPHICS |
PG_CONSTRUCTION |
PG_GEOMETRY |
PG_IDENTITY_DATA |
INVALID |

Remarks

Parameter groups are used to sort parameters within the Element Properties dialog.

See Also

CADExportOptions Class

[image]