Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RampRunTooComplex Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RampRunTooComplex { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RampRunTooComplex As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RampRunTooComplex {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class

RampStartHigherThanEnd Property

[image]