Revit 2011 API
DocumentChangedEventArgs..::.GetAddedElementIds Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns set of elements newly added to the document

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAddedElementIds()
Visual Basic (Declaration)
Public Function GetAddedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAddedElementIds()

Return Value

The set of ElementId for elements newly added to the document

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace

GetDeletedElementIds Method

[image]