Revit 2011 API
CurtainGrid Members
CurtainGrid Class Methods Properties See Also Send Feedback

The CurtainGrid type exposes the following members.

Methods

Name | Description
AddGridLine | Add a grid line to the curtain grid.
ChangePanelType | Change the type of a curtain panel.
GetCell | Get the specified cell located by the intersection of the grid lines.
GetPanel | Get the specified panel located by the intersection of the grid lines.

Properties

Name | Description
Cells | Get all the cells owned by this curtain grid.
Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Grid2Angle | The angle for V grid line pattern of the curtain grid.
Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Grid2Offset | The offset for V grid line pattern of the curtain grid.
Mullions | Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.
NumPanels | The number of panels.
NumULines | Get the number of grid lines in the U direction.
NumVLines | Get the number of grid lines in the V direction.
Panels | All the panels of the curtain grid.
UGridLines | All grid lines in the U direction.
UnlockedMullions | Get all the unlocked mullions of the curtain grid.
UnlockedPanels | Get all the unlocked panels of the curtain grid.
VGridLines | All grid lines in the V direction.

See Also

CurtainGrid Class

CurtainGrid Methods

[image] [image]