Revit 2011 API
PipingSystem Class
Members See Also Send Feedback
A piping system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PipingSystem : MEPSystem
Visual Basic (Declaration)
Public Class PipingSystem _
    Inherits MEPSystem
Visual C++
public ref class PipingSystem : public MEPSystem

Remarks

The piping system element is only available in Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.MEPSystem
Autodesk.Revit.DB.Plumbing..::.PipingSystem

See Also

PipingSystem Members
Autodesk.Revit.DB.Plumbing Namespace

PipingSystem Members

[image] [image]