Revit 2011 API
Rebar..::.SetLayoutAsMinimumClearSpacing Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to MinimumClearSpacing

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutAsMinimumClearSpacing(
    double spacing,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)
Visual Basic (Declaration)
Public Sub SetLayoutAsMinimumClearSpacing ( _
    spacing As Double, _
    arrayLength As Double, _
    barsOnNormalSide As Boolean, _
    includeFirstBar As Boolean, _
    includeLastBar As Boolean _
)
Visual C++
public:
void SetLayoutAsMinimumClearSpacing(
    double spacing,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)

Parameters

spacing
Type: System..::.Double
The maximum spacing between rebar in rebar set
arrayLength
Type: System..::.Double
The distribution length of rebar set
barsOnNormalSide
Type: System..::.Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar
Type: System..::.Boolean
Identifies if the first bar in rebar set is shown
includeLastBar
Type: System..::.Boolean
Identifies if the last bar in rebar set is shown

Remarks

When changing the layout rule to MinimumClearSpacing, you must also simultaneously set Spacing, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | The rebar is an instance of a spiral shape and does not support layouts.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The spacing isn't bigger than 0.0. -or- the set length arrayLength isn't acceptable.
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

SetLayoutAsNumberWithSpacing Method

[image]