Revit 2011 API
ExternalApplicationArrayIterator..::.Current Property
ExternalApplicationArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace

ExternalCommandData Class

[image]