Revit 2011 API
MaterialConcrete Class
Members Example See Also Send Feedback
Represents a concrete material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MaterialConcrete : Material
Visual Basic (Declaration)
Public Class MaterialConcrete _
    Inherits Material
Visual C++
public ref class MaterialConcrete : public Material

Remarks

MaterialConcrete is a child class of Material.

Examples

CopyC#
private void MaterialConcreteInformation(MaterialConcrete myConcrete)
{
    StringBuilder message = new StringBuilder("Material Concrete : " + myConcrete.Name);

    //behaviour of the material
    MaterialBehaviourType behaviour = myConcrete.Behavior;
    message.Append("Behavior: " + behaviour);
    double compression = myConcrete.ConcreteCompression;
    message.Append("Concrete Compression: " + compression);
    double dampingRatio = myConcrete.DampingRatio;
    message.Append("Damping Ratio: " + dampingRatio);
    bool lightWeight = myConcrete.LightWeight;
    string weight = lightWeight == true ? "Yes" : "No";
    message.Append("Lightweight: " + weight);

    double poissonModulusX = myConcrete.PoissonModulusX;
    message.Append("Poisson Ratio X: " + poissonModulusX);
    double poissonModulusY = myConcrete.PoissonModulusY;
    message.Append("Poisson Ratio Y: " + poissonModulusY);
    double poissonModulusZ = myConcrete.PoissonModulusZ;
    message.Append("Poisson Ratio Z: " + poissonModulusZ);

    double shearModulusX = myConcrete.ShearModulusX;
    message.Append("Shear modulus X: " + shearModulusX);
    double shearModulusY = myConcrete.ShearModulusY;
    message.Append("Shear modulus Y: " + shearModulusY);
    double shearModulusZ = myConcrete.ShearModulusZ;
    message.Append("Shear modulus Z: " + shearModulusZ);
    double shearStrengthReduction = myConcrete.ShearStrengthReduction;
    message.Append("Shear strength modification: " + shearStrengthReduction);

    double thermalExpansionCoefficientX = myConcrete.ThermalExpansionCoefficientX;
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX);
    double thermalExpansionCoefficientY = myConcrete.ThermalExpansionCoefficientY;
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY);
    double thermalExpansionCoefficientZ = myConcrete.ThermalExpansionCoefficientZ;
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ);

    double unitWeight = myConcrete.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulusX = myConcrete.YoungModulusX;
    message.Append("Young modulus X: " + youngModulusX);
    double youngModulusY = myConcrete.YoungModulusY;
    message.Append("Young modulus Y: " + youngModulusY);
    double youngModulusZ = myConcrete.YoungModulusZ;
    message.Append("Young modulus Z: " + youngModulusZ);

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Private Sub MaterialConcreteInformation(ByVal myConcrete As MaterialConcrete)
    Dim message As New StringBuilder("Material Concrete : " + myConcrete.Name)

    'behaviour of the material
    Dim behaviour As MaterialBehaviourType = myConcrete.Behavior
    message.Append("Behavior: " + behaviour)
    Dim compression As Double = myConcrete.ConcreteCompression
    message.Append("Concrete Compression: " + compression)
    Dim dampingRatio As Double = myConcrete.DampingRatio
    message.Append("Damping Ratio: " + dampingRatio)
    Dim lightWeight As Boolean = myConcrete.LightWeight
    Dim weight As String = If(lightWeight = True, "Yes", "No")
    message.Append("Lightweight: " + weight)

    Dim poissonModulusX As Double = myConcrete.PoissonModulusX
    message.Append("Poisson Ratio X: " + poissonModulusX)
    Dim poissonModulusY As Double = myConcrete.PoissonModulusY
    message.Append("Poisson Ratio Y: " + poissonModulusY)
    Dim poissonModulusZ As Double = myConcrete.PoissonModulusZ
    message.Append("Poisson Ratio Z: " + poissonModulusZ)

    Dim shearModulusX As Double = myConcrete.ShearModulusX
    message.Append("Shear modulus X: " + shearModulusX)
    Dim shearModulusY As Double = myConcrete.ShearModulusY
    message.Append("Shear modulus Y: " + shearModulusY)
    Dim shearModulusZ As Double = myConcrete.ShearModulusZ
    message.Append("Shear modulus Z: " + shearModulusZ)
    Dim shearStrengthReduction As Double = myConcrete.ShearStrengthReduction
    message.Append("Shear strength modification: " + shearStrengthReduction)

    Dim thermalExpansionCoefficientX As Double = myConcrete.ThermalExpansionCoefficientX
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX)
    Dim thermalExpansionCoefficientY As Double = myConcrete.ThermalExpansionCoefficientY
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY)
    Dim thermalExpansionCoefficientZ As Double = myConcrete.ThermalExpansionCoefficientZ
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ)

    Dim unitWeight As Double = myConcrete.UnitWeight
    message.Append("Unit Weight: " + unitWeight)

    Dim youngModulusX As Double = myConcrete.YoungModulusX
    message.Append("Young modulus X: " + youngModulusX)
    Dim youngModulusY As Double = myConcrete.YoungModulusY
    message.Append("Young modulus Y: " + youngModulusY)
    Dim youngModulusZ As Double = myConcrete.YoungModulusZ
    message.Append("Young modulus Z: " + youngModulusZ)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Material
Autodesk.Revit.DB..::.MaterialConcrete

See Also

MaterialConcrete Members

MaterialConcrete Members

[image] [image]