Revit 2011 API
ElementCategoryFilter Constructor (ElementId)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementCategoryFilter(
    ElementId categoryId
)
Visual Basic (Declaration)
Public Sub New ( _
    categoryId As ElementId _
)
Visual C++
public:
ElementCategoryFilter(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::.ElementId
The category id to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload

ElementCategoryFilter Constructor (BuiltInCategory, Boolean)

[image]