Revit 2011 API
ButtonData..::.Image Property
ButtonData Class See Also Send Feedback
The image of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button if it is a part of a stacked set, or if it is promoted to the Quick Access Toolbar. The best size is 16 x 16 pixels; if larger, the image will NOT be adjusted to fit the toolbar button.

See Also

ButtonData Class
Autodesk.Revit.UI Namespace

LargeImage Property

[image]