Revit 2011 API
RebarHostData Class
Members See Also Send Feedback
Interface to rebar-specific data stored in each valid rebar host element. The cover parameters listed below are an alternative interface to the CoverType property. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host: CLEAR_COVER_EXTERIOR (walls only) CLEAR_COVER_INTERIOR (walls only) CLEAR_COVER_OTHER (all hosts except in-place families and stairs) CLEAR_COVER (in-place families and stairs) CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs) CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs) RebarHostData can only be created by the factory function "getRebarHostData()" applied to an element that can be a rebar host.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarHostData : APIObject
Visual Basic (Declaration)
Public Class RebarHostData _
    Inherits APIObject
Visual C++
public ref class RebarHostData : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarHostData

See Also

RebarHostData Members
Autodesk.Revit.DB.Structure Namespace

RebarHostData Members

[image] [image]