Revit 2011 API
MassSurfaceData..::.ReferenceElementId Property
MassSurfaceData Class See Also Send Feedback
The ElementId of the element whose face the MassSurfaceData primarily refers to.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId ReferenceElementId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReferenceElementId As ElementId
Visual C++
public:
property ElementId^ ReferenceElementId {
    ElementId^ get ();
}

Remarks

A MassSurfaceData may represent multiple faces from the same or different elements. This generally only happens if the faces are geometrically fully coincident and logically represent a single building object. "Interior walls" of the conceptual energy building model is a common example where two different faces may be represented by a single MassSurfaceData.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace

ShadeDepth Property

[image]