Revit 2011 API
GeometryInstance..::.GetInstanceGeometry Method (Transform)
GeometryInstance Class See Also Send Feedback
Computes a transformation of the geometric representation of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryElement GetInstanceGeometry(
    Transform transform
)
Visual Basic (Declaration)
Public Function GetInstanceGeometry ( _
    transform As Transform _
) As GeometryElement
Visual C++
public:
GeometryElement^ GetInstanceGeometry(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::.Transform
The transformation to apply to the geometry.

Return Value

An element which contains the computed geometry for the transformed instance.

Remarks

The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved.

See Also

GeometryInstance Class
GetInstanceGeometry Overload

GetSymbolGeometry Method

[image] [image]