Revit 2011 API
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
DisplayUnitType | Get the display unit type of the parameter object.
Element | The element to which this parameter belongs.
GUID | The Guid for a shared parameter.
Id | The id of the parameter.
IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::.IsReadOnly.)
IsShared | Identifies if the parameter is a shared parameter.
StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter Class

Definition Property

[image]