Revit 2011 API
StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage, Boolean)
StructuralInstanceUsageFilter Class See Also Send Feedback
Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralUsage As StructuralInstanceUsage, _
    inverted As Boolean _
)
Visual C++
public:
StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage,
    bool inverted
)

Parameters

structuralUsage
Type: Autodesk.Revit.DB.Structure..::.StructuralInstanceUsage
The structural usage to match.
inverted
Type: System..::.Boolean
True if the filter should match all family instances which are not of the given structural usage.

See Also

StructuralInstanceUsageFilter Class
StructuralInstanceUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace

StructuralInstanceUsageFilter Methods

[image] [image]