Revit 2011 API
SubTransaction Class
Members See Also Send Feedback
Sub-transactions are objects that allow controlling a subset of changes in a document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class SubTransaction : IDisposable
Visual Basic (Declaration)
Public Class SubTransaction _
    Implements IDisposable
Visual C++
public ref class SubTransaction : IDisposable

Remarks

A Sub-transaction can only be active as a part of an open transaction. Sub-transactions may be nested inside each other, but with the restriction that every nested sub-transaction is entirely contained (open an closed) in the parent sub-transaction.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.SubTransaction

See Also

SubTransaction Members

SubTransaction Members

[image] [image]