Revit 2011 API
SolidSolidCutUtils..::.IsAllowedForSolidCut Method
SolidSolidCutUtils Class See Also Send Feedback
Validates that the element is eligible for a solid-solid cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsAllowedForSolidCut(
    Element Elem
)
Visual Basic (Declaration)
Public Shared Function IsAllowedForSolidCut ( _
    Elem As Element _
) As Boolean
Visual C++
public:
static bool IsAllowedForSolidCut(
    Element^ Elem
)

Parameters

Elem
Type: Autodesk.Revit.DB..::.Element
The solid to be cut or the cutting solid

Return Value

True if the input is validated False if not

Remarks

The element must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class

IsElementFromAppropriateContext Method

[image]