Revit 2011 API
FootPrintRoof..::.ExtendIntoWall Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set whether extend into wall the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ExtendIntoWall[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property ExtendIntoWall ( _
    pCurve As ModelCurve _
) As Boolean
Visual C++
public:
property bool ExtendIntoWall[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::.ModelCurve

Remarks

Only when the FootPrintRoof is created by pick walls, this property makes sense.

See Also

FootPrintRoof Class

Offset Property

[image]