Revit 2011 API
FamilyManager..::.MakeReporting Method
FamilyManager Class See Also Send Feedback
Set the family parameter as a reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MakeReporting(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeReporting ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeReporting(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the parameter can not be changed to a reporting parameter.

See Also

FamilyManager Class

MakeType Method

[image]