Revit 2011 API
Document..::.EditFamily Method
Document Class Example See Also Send Feedback
Edits a family loaded in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document EditFamily(
    Family loadedFamily
)
Visual Basic (Declaration)
Public Function EditFamily ( _
    loadedFamily As Family _
) As Document
Visual C++
public:
Document^ EditFamily(
    Family^ loadedFamily
)

Parameters

loadedFamily
Type: Autodesk.Revit.DB..::.Family
The loaded family in current document.

Return Value

Reference of the document of the family.

Remarks

This creates an independent copy of the family for editing. To apply the changes back to the family stored in the document, use the LoadFamily overload accepting IFamilyLoadOptions. Note: This method may not be called during dynamic update.

Examples

CopyC#
public void GetLoadedSymbols(Autodesk.Revit.DB.Document document, FamilyInstance familyInstance)
{
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc && familyDoc.IsFamilyDocument == true)
        {
            String loadedFamilies = "FamilySymbols in " + family.Name + ":\n";
            FilteredElementCollector collector = new FilteredElementCollector(document);
            ICollection<Element> collection =
                collector.OfClass(typeof(FamilySymbol)).ToElements();
            foreach (Element e in collection)
            {
                FamilySymbol fs = e as FamilySymbol;
                loadedFamilies += "\t" + fs.Name + "\n";
            }

            TaskDialog.Show("Revit",loadedFamilies);
        }
    }
}
CopyVB.NET
Public Sub GetLoadedSymbols(ByVal document As Autodesk.Revit.DB.Document, ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing AndAlso familyDoc.IsFamilyDocument = True Then
            Dim loadedFamilies As [String] = "FamilySymbols in " + family.Name + ":" & vbLf
            Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
            Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
            For Each e As Autodesk.Revit.DB.Element In collection
                Dim fs As FamilySymbol = TryCast(e, FamilySymbol)
                loadedFamilies += vbTab + fs.Name + vbLf
            Next

            TaskDialog.Show("Revit", loadedFamilies)
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"loadedFamily"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"loadedFamily"-is an in-place family or a non-editable family. (This can be checked with the IsInPlace and IsEditable properties of the Family class.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family is already being edited.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class

Export Method

[image] [image]