Revit 2011 API
Element..::.SimilarObjectTypes Property
Element Class See Also Send Feedback
Returns the types being similar to the current instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use Element.GetValidTypes() instead.")]
public virtual ElementSet SimilarObjectTypes { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use Element.GetValidTypes() instead.")> _
Public Overridable ReadOnly Property SimilarObjectTypes As ElementSet
Visual C++
[ObsoleteAttribute(L"Use Element.GetValidTypes() instead.")]
public:
virtual property ElementSet^ SimilarObjectTypes {
    ElementSet^ get ();
}

Remarks

The returned types include all the similar types to current instance, which means the type of the current instance can be swapped to the type included in the returned set.

See Also

Element Class

UniqueId Property

[image]