Revit 2011 API
RebarBarType..::.StirrupTieBendDiameter Property
RebarBarType Class See Also Send Feedback
Defines bar and hook bend diameter for rebar whose style is stirrup/tie

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StirrupTieBendDiameter { get; set; }
Visual Basic (Declaration)
Public Property StirrupTieBendDiameter As Double
Visual C++
public:
property double StirrupTieBendDiameter {
    double get ();
    void set (double value);
}

Field Value

The bar and hook bend diameter for rebar whose style is stirrup/tie

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: the bend diameter stirrupTieBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

RebarBarTypeSet Class

[image]