Revit 2011 API
DuctType Class
Members See Also Send Feedback
A duct type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DuctType : MEPCurveType
Visual Basic (Declaration)
Public Class DuctType _
    Inherits MEPCurveType
Visual C++
public ref class DuctType : public MEPCurveType

Remarks

The duct type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Mechanical..::.DuctType

See Also

DuctType Members
Autodesk.Revit.DB.Mechanical Namespace

DuctType Members

[image] [image]