Revit 2011 API
Connector Properties
Connector Class See Also Send Feedback

The Connector type exposes the following members.

Properties

Name | Description
AllRefs | All references of the connector.
Angle | The angle of the Connector.
AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
AssignedDuctLossMethod | The duct loss method of the connector.
AssignedFixtureUnits | The assigned fixture units of the connector.
AssignedFlow | The assigned flow of the connector.
AssignedFlowDirection | The assigned flow direction of the connector.
AssignedFlowFactor | The assigned flow factor of this connector.
AssignedKCoefficient | The assigned kCoefficient of the connector.
AssignedLossCoefficient | The assigned loss coefficient of the connector.
AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
AssignedPipeLossMethod | The pipe loss method of the connector.
AssignedPressureDrop | The assigned pressure drop of the connector.
Coefficient | The coefficient of the connector.
ConnectorManager | The connector manager of the connector.
ConnectorType | The connector type of the connector.
CoordinateSystem | The coordinate system of the connector.
Demand | The demand of the connector.
Direction | The direction of the connector.
Domain | The domain of the connector.
DuctSystemType | The duct system type of the connector.
ElectricalSystemType | The electrical system type of the connector.
Flow | The flow of the connector.
Height | The height of the connector.
IsConnected | Identifies if the connector is physically connected to a connector on another element.
IsMovable | whether the connector can be moved.
MEPSystem | The system of the connector belong to.
Origin | The location of the connector.
Owner | The host of the connector.
PipeSystemType | The pipe system type of the connector.
PressureDrop | The pressure drop of the connector.
Radius | The radius of the connector.
Shape | The shape of the connector.
VelocityPressure | The velocity pressure of the connector.
Width | The width of the connector.

See Also

Connector Class

AllRefs Property

[image]