Revit 2011 API
CompoundStructureLayerArray..::.Insert Method
CompoundStructureLayerArray Class See Also Send Feedback
Insert the specified layer into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    CompoundStructureLayer item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CompoundStructureLayer, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CompoundStructureLayer^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.CompoundStructureLayer
The layer to be inserted into the array.
index
Type: System..::.Int32
The layer will be inserted before this index.

Return Value

Returns whether the layer was inserted into the array.

See Also

CompoundStructureLayerArray Class

ReverseIterator Method

[image]