Revit 2011 API
Application..::.NewSuspendUpdating Method
Application Class See Also Send Feedback
Creates a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SuspendUpdating NewSuspendUpdating(
    Document document
)
Visual Basic (Declaration)
Public Function NewSuspendUpdating ( _
    document As Document _
) As SuspendUpdating
Visual C++
public:
SuspendUpdating^ NewSuspendUpdating(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which updating will be suspended.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating objects have been disposed, Revit will make the document consistent again.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument document is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewTextNoteCreationData Method

[image] [image]