Revit 2011 API
AnalyticalModelSelector Constructor (AnalyticalCurveSelector)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector for the analytical model geometry.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    AnalyticalCurveSelector inCurveSelector
)
Visual Basic (Declaration)
Public Sub New ( _
    inCurveSelector As AnalyticalCurveSelector _
)
Visual C++
public:
AnalyticalModelSelector(
    AnalyticalCurveSelector inCurveSelector
)

Parameters

inCurveSelector
Type: Autodesk.Revit.DB.Structure..::.AnalyticalCurveSelector
Portion of the analytical curve in which the client has interest.

Remarks

This version is useful for single-curve or single-point analytical models.

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelSelector Constructor (Curve, AnalyticalCurveSelector)

[image]