Revit 2011 API
ItemFactoryBase..::.NewFamilyInstance Method (XYZ, FamilySymbol, View)
ItemFactoryBase Class See Also Send Feedback
Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ origin,
    FamilySymbol symbol,
    View specView
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    origin As XYZ, _
    symbol As FamilySymbol, _
    specView As View _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ origin,
    FamilySymbol^ symbol,
    View^ specView
)

Parameters

origin
Type: Autodesk.Revit.DB..::.XYZ
The origin of family instance. If created on ViewPlan, the origin will be projected onto the ViewPlan.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A family symbol object that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.DB..::.View
A 2D view in which to display the family instance.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This overload applies only to 2D family symbols (detail components, annotation symbols, titleblocks, etc.). The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

The location may be different from its origin on ViewPlane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | One or more required arguments was nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::.ArgumentException | The input view or family was not 2D, or the input family is not permitted in this view.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)

[image]