Revit 2011 API
RebarBarType..::.GetHookOffsetLength Method
RebarBarType Class See Also Send Feedback
Identifies the hook offset length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GetHookOffsetLength(
    ElementId hookId
)
Visual Basic (Declaration)
Public Function GetHookOffsetLength ( _
    hookId As ElementId _
) As Double
Visual C++
public:
double GetHookOffsetLength(
    ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type

Return Value

The hook offset length for a hook type

Remarks

If the AutoCalcHookLengths property is turned off, the default hook offset length will be returned

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the rebar hook type id hookId is not valid -or- the hook specified by id hookId doesn't have valid offset length -or- The element hookId does not exist in the document containing this RebarBarType -or- the hook specified by id hookId doesn't have valid default offset length
Autodesk.Revit.Exceptions..::.InvalidOperationException | The document containing this RebarBarType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The element is a member of a loaded family. -or- The element is a member of a group type that is not being edited. -or- hookId is a member of a loaded family. -or- hookId is a member of a group type that is not being edited.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ModificationForbiddenException | The document containing this RebarBarType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this RebarBarType is being loaded, or is in the midst of another sensitive process. -or- This RebarBarType is an internal element, such as a component of a loaded family or a group type. -or- The document containing this RebarBarType is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This RebarBarType is a member of a group or sketch, and the document is not currently editing the group or sketch.
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException | The document containing this RebarBarType has no open transaction.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

GetHookPermission Method

[image]