Revit 2011 API
UIApplication Members
UIApplication Class Constructors Methods Properties Events See Also Send Feedback

The UIApplication type exposes the following members.

Constructors

Name | Description
UIApplication | Use a database level Application to construct a UI-level Application.

Methods

Name | Description
CreateRibbonPanel | Overloaded.
Dispose |
GetRibbonPanels | Overloaded.

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ActiveUIDocument | Provides access to an object that represents the currently active project.
Application | Returns the database level Application represented by this UI level Application.
DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
LoadedApplications | Returns an array of successfully loaded external applications.
MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace

UIApplication Constructor

[image]