Revit 2011 API
ExternalDefinition Members
ExternalDefinition Class Methods Properties See Also Send Feedback

The ExternalDefinition type exposes the following members.

Methods

Name | Description

Properties

Name | Description
GUID | Returns the GUID associated with the shared parameter definition.
Name | The user visible name for the parameter. (Overrides Definition..::.Name.)
OwnerGroup | Returns or change the group ID of the external parameter definition.
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)
Visible | Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

See Also

ExternalDefinition Class

ExternalDefinition Methods

[image] [image]