Revit 2011 API
RebarShapeDefinitionByArc..::.SetArcTypeSpiral Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Set the RebarShapeDefinitionByArc.Type property to Spiral.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetArcTypeSpiral(
    double height,
    double pitch,
    int baseFinishingTurns,
    int topFinishingTurns
)
Visual Basic (Declaration)
Public Sub SetArcTypeSpiral ( _
    height As Double, _
    pitch As Double, _
    baseFinishingTurns As Integer, _
    topFinishingTurns As Integer _
)
Visual C++
public:
void SetArcTypeSpiral(
    double height,
    double pitch,
    int baseFinishingTurns,
    int topFinishingTurns
)

Parameters

height
Type: System..::.Double
The height of the spiral (assuming the spiral is vertical).
pitch
Type: System..::.Double
The pitch, or vertical distance traveled in one rotation.
baseFinishingTurns
Type: System..::.Int32
The number of finishing turns at the lower end of the spiral.
topFinishingTurns
Type: System..::.Int32
The number of finishing turns at the upper end of the spiral.

Remarks

In order to create a spiral definition, you must provide default values for the spiral-specific parameters.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeDefinitionByArc Properties

[image] [image]