Revit 2011 API
PreDocEventArgs Class
Members See Also Send Feedback
The class is used as base class for the arguments of any pre-event arguments that is associated to a particular Document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PreDocEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class PreDocEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class PreDocEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentClosingEventArgs
Autodesk.Revit.DB.Events..::.DocumentPrintingEventArgs
Autodesk.Revit.DB.Events..::.DocumentSavingAsEventArgs
Autodesk.Revit.DB.Events..::.DocumentSavingEventArgs
Autodesk.Revit.DB.Events..::.DocumentSynchronizingWithCentralEventArgs
Autodesk.Revit.DB.Events..::.FileExportingEventArgs
Autodesk.Revit.DB.Events..::.FileImportingEventArgs
Autodesk.Revit.DB.Events..::.ViewPrintingEventArgs
Autodesk.Revit.UI.Events..::.ViewActivatingEventArgs

See Also

PreDocEventArgs Members
Autodesk.Revit.DB.Events Namespace

PreDocEventArgs Members

[image] [image]