Revit 2011 API
Zone Members
Zone Class Methods Properties See Also Send Feedback

The Zone type exposes the following members.

Methods

Name | Description
AddSpaces | Add a set of existing spaces to Zone element.
RemoveSpaces | Remove a set of existing spaces to the current Zone element.

Properties

Name | Description
Area | Get the Area of the Zone.
Boundary | Returns the boundary of the Zone.
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
GrossArea | Get the Gross Area of the Zone.
GrossVolume | Get the Gross Volume of the Zone.
HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
HeatingSetPoint | Get or set the Heating Set Point of the Zone.
HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
IsDefaultZone | Reports whether this zone is default or not.
Name | Get or Set the Name of the Zone. (Overrides Element..::.Name.)
OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Perimeter | Get the Perimeter of the Zone.
Phase | Get the Phase of the Zone.
ServiceType | Get or set the Service Type of the Zone.
Spaces | Get the Spaces of the Zone.
Volume | Get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace

Zone Methods

[image] [image]