Revit 2011 API
ReferencePoint..::.GetCoordinateSystem Method
ReferencePoint Class See Also Send Feedback
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform GetCoordinateSystem()
Visual Basic (Declaration)
Public Function GetCoordinateSystem As Transform
Visual C++
public:
Transform^ GetCoordinateSystem()

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ.

See Also

ReferencePoint Class

GetInterpolatingCurves Method

[image]