Revit 2011 API
BarDescription..::.Layer Property
BarDescription Class See Also Send Feedback
Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Layer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layer As Integer
Visual C++
public:
property int Layer {
    int get ();
}

Remarks

For floors, layer 0 is Top Major; layer 1 is Top Minor; layer 2 is Bottom Major; layer 3 is Bottom Minor. For walls, layer 0 is Front Major; layer 1 is Front Minor; layer 2 is Back Major; layer 3 is Back Minor.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace

Length Property

[image]