Revit 2011 API
AnalyticalModel..::.IsAutoDetectEnabled Method
AnalyticalModel Class See Also Send Feedback
Reports whether or not Analytical Auto-detect for the given direction is enabled.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsAutoDetectEnabled(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function IsAutoDetectEnabled ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsAutoDetectEnabled(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which Auto-detect behavior may be enabled.

Return Value

True if enabled in the given direction, false otherwise.

Remarks

Just because Auto-detect is enabled in one direction, that does not mean that it is enabled in a different direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for Analytical Auto-detect.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

IsElementFullySupported Method

[image]