Revit 2011 API
Binding Class
Members See Also Send Feedback
Binding objects are used to take a parameter definition and bind it to one or more categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class Binding : APIObject
Visual Basic (Declaration)
Public MustInherit Class Binding _
    Inherits APIObject
Visual C++
public ref class Binding abstract : public APIObject

Remarks

This class is a base class for all types of parameter binding within Autodesk Revit. Once the binging objects are created and added to the document parameters will be added to elements in those categories specified in the binding. There are currently two types of binding available, Instance binding and Type binding. The key difference between the two is that the instance bound parameters appear on all instances of the elements in those categories. Changing the parameter on one does not effect the other instances of the parameter. The Type bound parameters appear only on the type object and is shared by all the instances that use that type. Changing the type bound parameter affects all instances of the elements that use that type. Note, a definition can only be bound to an instance or a type and not both.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Binding
Autodesk.Revit.DB..::.ElementBinding

See Also

Binding Members

Binding Members

[image] [image]