Revit 2011 API
PipeFlowState Enumeration
See Also Send Feedback
An enumerated type listing all the pipe flow states for a pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PipeFlowState
Visual Basic (Declaration)
Public Enumeration PipeFlowState
Visual C++
public enum class PipeFlowState

Members

Member name | Description
LaminarState | The flow state is Laminar.
TransitionState | The flow state is Transition.
TurbulentState | The flow state is Turbulent.

See Also

Autodesk.Revit.DB.Plumbing Namespace

PipeLossMethodType Enumeration

[image]