Revit 2011 API
AnalysisDisplayLegendSettings..::.NumberOfSteps Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Number of steps (values between minimum and maximum) to be shown in legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int NumberOfSteps { get; set; }
Visual Basic (Declaration)
Public Property NumberOfSteps As Integer
Visual C++
public:
property int NumberOfSteps {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | When setting this property: numberOfSteps is negative or too large

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace

Rounding Property

[image]