Revit 2011 API
BoundarySegmentArray..::.Item Property
BoundarySegmentArray Class See Also Send Feedback
Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegment Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class

Size Property

[image]