Revit 2011 API
Category..::.HasMaterialQuantities Property
Category Class See Also Send Feedback
Identifies if elements of the category are able to report what materials they contain in what quantities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasMaterialQuantities { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasMaterialQuantities As Boolean
Visual C++
public:
property bool HasMaterialQuantities {
    bool get ();
}

Remarks

Get materials via the Element' property Materials; Get quantities via methods GetMaterialArea and GetMaterialVolume.

See Also

Category Class

Id Property

[image]