Revit 2011 API
FailureMessage Constructor
FailureMessage Class See Also Send Feedback
Creates a new FailureMessage related to a given FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage(
    FailureDefinitionId id
)
Visual Basic (Declaration)
Public Sub New ( _
    id As FailureDefinitionId _
)
Visual C++
public:
FailureMessage(
    FailureDefinitionId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.FailureDefinitionId
Id of FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class

FailureMessage Methods

[image] [image]