Revit 2011 API
Dimension Properties
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal.
Curve | A curve that represents the dimension line.
DimensionShape | The shape of this dimension.
DimensionType | The dimension style of this dimension.
IsLocked | Indicates if this dimension is locked.
Label | The family parameter label of the dimension.
Name | Retrieve or Change the name associated with the Dimension.
NumberOfSegments | The number of segments for the dimension.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
References | Returns an array of geometric references to which the dimension is attached.
Segments | The segments in the dimension.
Value | The value of the dimension.
ValueString | The dimension value as a user visible string.
View | Supplies the view that contains the dimension if the dimension is view specific.

See Also

Dimension Class

AreSegmentsEqual Property

[image]