Revit 2011 API
Area Class
Members See Also Send Feedback
Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Area : Enclosure
Visual Basic (Declaration)
Public Class Area _
    Inherits Enclosure
Visual C++
public ref class Area : public Enclosure

Remarks

The area object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Enclosure
Autodesk.Revit.DB..::.Area

See Also

Area Members

Area Members

[image] [image]