Revit 2011 API
BuiltInFailures..::.StairRampFailures Members
BuiltInFailures..::.StairRampFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.StairRampFailures type exposes the following members.

Properties

Name | Description
ActualRiserHeightChanged | The actual riser height for one or more stairs violates the maximum set in the type.
AntiparallelRampRisers | Riser lines are parallel but not collinear. Can't build Run between these Risers.
AntiparallelRampRisersError | Riser lines are parallel but not collinear. Can't build Run between these Risers.
ArcRunRadiusTooSmall | Can't create Run. Run radius is too small.
BadBalustersPerTread | Number of Balusters per Tread must be an integer greater than zero.
BadFillingSpacing | Spacing for Excess Length Fill is too small.
BadRailings | Can't create Railings.
BadRailingsError | Can't create Railings.
BadRailProfile | One or more Profile Loops are invalid, probably because of self-intersection.
BalustersTooClose | Baluster Separation must be equal to or greater than the Baluster widths.
BalustersTooCloseAbsolute | Baluster Separation is too small.
BalusterUpsideDown | Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.
CannotComputeRailElevation | Can't compute elevation profile for one or more Rails
CannotCreateBaluster | Can't create Balusters for given Width and Height.
CannotCreateBalusterPatterns | Can't create Baluster Patterns for Railings
CannotCreateCornerBalusters | Can't create corner Baluster
CannotCreateLandingStringer | Can't create stringer at landing.
CannotCreateMiddleStringer | Can't create one or more Middle Stringers.
CannotCreateMonolithicStairs | Can't make monolithic Stairs.
CannotCreateNosing | Can't create nosing on one or more treads.
CannotCreateOneOrMoreBaluster | Can't create one or more Balusters
CannotCreateOneOrMoreTreads | Can't create geometry for one or more treads.
CannotCreateOpenMiddleStringers | Can't cut open/middle stringers geometry.
CannotCreateRail | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRailGeom | Can't create geometry for one or more Rails
CannotCreateRailWarn | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRiser | Can't create geometry for one or more risers.
CannotCreateSideStringer | Can't create one or more Side Stringers.
CannotCreateStringers | Can't create stringers geometry.
CannotDrawStairs | Can't make stairs
CannotDrawStairsError | Can't make stairs
CannotEndWithZeroRiser | Can't end Stairs with Riser because Riser Thickness is too small.
CannotGenerateFaces | Couldn't generate surfaces for stairs.
CannotGenerateFacesError | Couldn't generate surfaces for stairs.
CannotGenerateRamp | Couldn't generate surfaces for ramp.
CannotGenerateRampError | Couldn't generate surfaces for ramp.
CannotOffsetBoundary | Can't create Boundary as an offset of Run Curve
CannotOffsetRail | Can't create one or more Rails with desired offset
CannotPlaceBalusterOffset | Can't place Balusters and/or Rails with desired offset
CannotPlaceBalusterPatterns | Can't place Baluster Patterns
InvalidBalustersPattern | Invalid Balusters Pattern
InvalidRailProfile | Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.
InvalidStartLevel | The start level and end level for this staircase must be at different elevations.
InvalidStartLevelRamp | The start level and end level for this ramp must be at different elevations.
MultistoryLevelBelowTopbottomLevel | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryStairDoesntReach | The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.
MultusegmentRampRiser | Ramp can't have multisegment Riser.
MultusegmentRampRiserError | Ramp can't have multisegment Riser.
NoCurvesInRailing | Railing Sketch has no Lines.
NoProfileForRail | Must specify Profiles for every Rail.
NoRailingsStringer | Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.
NoRisersInPureMonolithicStairs | Monolithic Stairs with zero tread thickness can't have risers
NoRunsRamp | Ramp has no Runs. Can't create Ramp.
NoRunsRampError | Ramp has no Runs. Can't create Ramp.
NotALineRiserRamp | Riser line must be a straight line for Ramps.
NotALineRiserRampError | Riser line must be a straight line for Ramps.
NotEnoughRisers | Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.
OnlyMonolithicStairs | Tread thickness can't be zero for non-monolithic stairs
OnlyOneConnectedBoundaryError | Stairs require no less than two boundaries (chains of one or more Boundary Lines).
RailCurveTooShort | Curve in rail sketch is too short for rail creation and ignored.
RailingBadOffset | An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.
RailingCurvesNotSplitRamp | The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingCurvesNotSplitStairs | The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailProfileOpen | Open Profile Loop can't be used as a Rail Profile
RampDoesntReach | The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.
RampDoesntReachOffset | The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.
RampLandingNotCreated | Beginning of run coincide with the end of previous run. Landing is not created between runs.
RampRunTooComplex | Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.
RampStartHigherThanEnd | The ramp's base (base level + base offset) must be below its top (top level + top offset).
RiserCurveTooShort | Riser curve is too short to create nosing on it.
RiserDoesntIntersectBoundry | The line representing the top of a riser does not intersect one or both of the boundary lines.
RisersAtSameLocation | The highlighted risers have the same location along the boundary line. Please move one of the two risers.
RiserThicknesssResetToZero | Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.
StairsIllegalDesNumRisers | Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.
StairsStartHigherThanEnd | The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
StairStringerCantOffset | Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.
StairsZeroDesiredRisers | The number of desired risers for a staircase cannot be 0.
StringerCurvesNotSplitStairs | The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.
StringerCurveTooShort | A piece of boundary is too short to create stringer on it.
TreadDepthBelowMin | The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.
TreadDepthFailsEq | The actual tread depth and riser height for one or more stairs of this type violates the stair equation.
TreadFrontProfileInvalid | This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.

See Also

BuiltInFailures..::.StairRampFailures Class

BuiltInFailures.StairRampFailures Properties

[image] [image]