Revit 2011 API
Face Members
Face Class Methods Properties See Also Send Feedback

The Face type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
ComputeNormal | Returns the normal vector for the face at the given point.
Evaluate | Evaluates parameters on the face.
GetBoundingBox | Returns the UV bounding box of the face.
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face.
Triangulate | Returns a triangular mesh approximation to the face.

Properties

Name | Description
Area | The area of this face.
EdgeLoops | Each edge loop is a closed boundary of the face.
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
IsTwoSided | Determines if a face is two-sided (degenerate)
MaterialElement | Element describing the material from which this face is composed.
Period | The period of this face in the specified parametric direction.
Reference | Returns a stable reference to the face.

See Also

Face Class

Face Methods

[image] [image]