Revit 2011 API
DuctConnector..::.Width Property
DuctConnector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::.Width

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace

DuctFlowConfigurationType Enumeration

[image]