Revit 2011 API
MassZone..::.GetCoincidentReferenceFromAdjacentZone Method
MassZone Class See Also Send Feedback
This method is used to get a Reference from an adjacent MassZone that is coincident to a Reference of this MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public Reference GetCoincidentReferenceFromAdjacentZone(
    Reference referenceToZoneFace
)
Visual Basic (Declaration)
Public Function GetCoincidentReferenceFromAdjacentZone ( _
    referenceToZoneFace As Reference _
) As Reference
Visual C++
public:
Reference^ GetCoincidentReferenceFromAdjacentZone(
    Reference^ referenceToZoneFace
)

Parameters

referenceToZoneFace
Type: Autodesk.Revit.DB..::.Reference
Reference to face of MassZone.

Return Value

Reference to concident face of adjacent MassZone or NULL if there is no adjacent MassZone face Reference.

Remarks

The results are always references to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports them as REFERENCE_TYPE_NONE.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input Reference is not a face Reference of this MassZone.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace

GetEquivalentReferenceFromMassOrLevel Method

[image]