Revit 2011 API
ControlledApplication..::.SharedParametersFilename Property
ControlledApplication Class See Also Send Feedback
Contains the fully qualified path to a shared parameters file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string SharedParametersFilename { get; set; }
Visual Basic (Declaration)
Public Property SharedParametersFilename As String
Visual C++
public:
property String^ SharedParametersFilename {
    String^ get ();
    void set (String^ value);
}

Remarks

This path can be read and set via this property. By default Autodesk Revit does not have a shared parameters file so this property must be set before access is made to the shared parameters file object otherwise an exception will be thrown.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

VersionBuild Property

[image]