Revit 2011 API
Transaction..::.SetName Method
Transaction Class See Also Send Feedback
Sets the transaction's name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetName(
    string name
)
Visual Basic (Declaration)
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::.String

Remarks

A transaction needs a name to be assigned before it can be started. The name will appear in the Undo menu in Revit after a transaction is successfully committed. Another ways of setting the name is either during construction or during the Start(String) method. Even though a new name can be assigned at any time, it is not going to be used until the next time the Start method is invoked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The name argument is an empty string
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class

Start Method

[image] [image]