Revit 2011 API
Opening..::.IsRectBoundary Property
Opening Class See Also Send Feedback
Retrieves the information whether the opening has a rectangular boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsRectBoundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRectBoundary As Boolean
Visual C++
public:
property bool IsRectBoundary {
    bool get ();
}

Remarks

If the opening has a rectangular boundary, we can get the geometry information from BoundaryRect property. Otherwise we should get the geometry information from BoundaryCurves property.

See Also

Opening Class

IsTransparentIn3D Property

[image]