Revit 2011 API
MassEnergyAnalyticalModel..::.GetCoincidentMassZoneFaceReferences Method
MassEnergyAnalyticalModel Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static IList<Reference> GetCoincidentMassZoneFaceReferences(
    Document document,
    Reference referenceToFace
)
Visual Basic (Declaration)
Public Shared Function GetCoincidentMassZoneFaceReferences ( _
    document As Document, _
    referenceToFace As Reference _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetCoincidentMassZoneFaceReferences(
    Document^ document,
    Reference^ referenceToFace
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
referenceToFace
Type: Autodesk.Revit.DB..::.Reference
A Reference to a Face of a MassEnergyAnalyticalModel.

Return Value

Returns References to Faces from MassZones coincident with an input Face from a MassEnergyAnalyticalModel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The Reference is not a Face of a MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace

GetJoinedMassEnergyAnalyticalModelElementIds Method

[image]