Revit 2011 API
ControlledApplication..::.DocumentSynchronizedWithCentral Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished synchronizing a document with central file. It is raised even when document synchronizing with central file failed or was cancelled (during DocumentSynchronizingWithCentral event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

DocumentSynchronizingWithCentral Event

[image]