Revit 2011 API
RebarShapeDefinitionBySegments Methods
RebarShapeDefinitionBySegments Class See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Methods

Name | Description
AddBendDefaultRadius | Specify a default-radius bend.
AddBendVariableRadius | Specify a variable-radius bend.
AddConstraintParallelToSegment | Constrain the length of a segment by parameterizing its length.
AddConstraintToSegment | Add a constraint that helps determine the length of a segment.
AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
RemoveParameterFromSegment | Remove constraints from a segment.
SetSegmentAs180DegreeBend | Overloaded. Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend.
SetSegmentFixedDirection | Fix the direction of a segment.
SetSegmentVariableDirection | Remove the fixed direction from a segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

AddBendDefaultRadius Method

[image]