Revit 2011 API
Dimension..::.Segments Property
Dimension Class See Also Send Feedback
The segments in the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DimensionSegmentArray Segments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Segments As DimensionSegmentArray
Visual C++
public:
property DimensionSegmentArray^ Segments {
    DimensionSegmentArray^ get ();
}

Remarks

Returns a read only array of segments in the dimension. The references of the dimension can be mapped to segments in order. The first segment here wrapped by first and second references; the nth segment is wrapped by nth and n+1st references.

See Also

Dimension Class

Value Property

[image]