Revit 2011 API
BuiltInFailures..::.BeamFailures..::.CannotBendBeamType Property
BuiltInFailures..::.BeamFailures Class See Also Send Feedback
Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotBendBeamType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotBendBeamType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotBendBeamType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BeamFailures Class

BuiltInFailures.BeamSystemFailures Class

[image]