Revit 2011 API
ElectricalSystemType Enumeration
See Also Send Feedback
An enumerated type listing all the possible electrical system types for an electrical connector object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ElectricalSystemType
Visual Basic (Declaration)
Public Enumeration ElectricalSystemType
Visual C++
public enum class ElectricalSystemType

Members

Member name | Description
UndefinedSystemType | Unknown system type
Data | Electrical System Type is Data.
PowerCircuit | Electrical System Type is PowerCircuit.
Telephone | Electrical System Type is Telephone.
Security | Electrical System Type is Security.
FireAlarm | Electrical System Type is FireAlarm.
NurseCall | Electrical System Type is NurseCall.
Controls | Electrical System Type is Controls.
Communication | Electrical System Type is Communication.
PowerBalanced | Electrical System Type is PowerBalanced.
PowerUnBalanced | Electrical System Type is PowerUnBalanced.

See Also

Autodesk.Revit.DB.Electrical Namespace

GroundConductorSize Class

[image]