Revit 2011 API
ExternalDefinition..::.GUID Property
ExternalDefinition Class See Also Send Feedback
Returns the GUID associated with the shared parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Guid GUID { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property GUID As Guid
Visual C++
public:
virtual property Guid GUID {
    Guid get ();
}

Remarks

Each shared parameter when created is issued a unique identifier. This identifier can then be used at a later time to retrieve the parameter from the Element ensuring that the correct parameter is always retrieved.

See Also

ExternalDefinition Class

Name Property

[image]