Revit 2011 API
PanelScheduleData Members
PanelScheduleData Class Methods Properties See Also Send Feedback

The PanelScheduleData type exposes the following members.

Methods

Name | Description
AddLoadClassification | add a Load Classification Id to the array of Load Classifications.
GetLoadClassifications | get an array of the load classifications associated with this panel schedule
GetNumberOfCircuitRows | returns the number of rows in the circuit table
IsSymmetric | returns if this panel schedule is symmetric
RemoveLoadClassification | remove a Load Classification Id from the array of Load Classifications
SetLoadClassifications | sets the Load Classifications associated with this panel schedule
UpdateCircuitTableForInstance | redraw the circuit table for the given panel with the given parameter updates
UpdateCircuitTableForTemplate | redraw the circuit table for a template with the given parameter updates
UpdateIsSectionHidden | update if this section is hidden or not
UpdateLoadSummary | update the load summary section
UpdateVerticalHeadersInSection | set if this header should have vertical text

Properties

Name | Description
BodyShowsVerticalHeaders | setting this value must go through the appropriate update function (updateVerticalHeadersInSection)
BorderAroundSchedule | places a border (GraphicStyle element) around the entire schedule, visible only on the instance and sheet
BorderAroundSections | places a border (GraphicStyle element) around each section, visible only on the instance and sheet
IsFooterSectionHidden | true if the user wishes to hide the footer section setting this value must go through the appropriate update function
IsHeaderSectionHidden | true if the user wishes to hide the header section setting this value must go through the appropriate update function
IsPanelSinglePhase | Identifies if the panel is single phase. If true, the panel is single phase. If false, the panel is 3-phase.
IsSummarySectionHidden | true if the user wishes to hide the summary section setting this value must go through the appropriate update function
IsThirdPhaseHidden | true if the user wishes to hide the 3rd phase column of a single phase panel
NumberOfSlots | number of slots in the panel schedule setting this value must go through the appropriate update function
PanelConfiguration | gets panel configuration of given panel schedule type.
PhaseLoadType | this property determines the layout of the phase load columns setting this value must go through the updateCircuitTable function
ScheduleType |
ShowCircuitNumberOnOneRowForMultiphaseCircuits | shows the circuit number broken up on each row of the multiphase circuit rows if true, all on the first row otherwise only applicable to two column formats
ShowMultipleRowsForMultiphaseCircuits | shows extra rows below multiphase circuits to indicate how many slots they take up if true, all on a single row otherwise only applicable to one column formats
SummaryShowsGroups | show groups of load classifications in the load summary section
SummaryShowsOnlyConnectedLoads | show only the connected load classifications in the summary section
SummaryShowsVerticalHeaders | setting this value must go through the appropriate update function (updateVerticalHeadersInSection)

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace

PanelScheduleData Methods

[image] [image]