Revit 2011 API
SubTransaction..::.Start Method
SubTransaction Class See Also Send Feedback
Starts the sub-transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Start()
Visual Basic (Declaration)
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Return Value

If started successfully, this method returns TransactionStatus::Started

Remarks

A sub-transaction can only be started in an open transaction. The sub-transaction must be closed (committed or rolled back) while still inside the open transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction was already started and has not finished

See Also

SubTransaction Class

SunAndShadowSettings Class

[image]