Revit 2011 API
Application..::.NewPointOnEdge Method
Application Class See Also Send Feedback
Create a PointOnEdge object which is used to define the placement of a ReferencePoint.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointOnEdge NewPointOnEdge(
    Reference edgeReference,
    double edgeParam
)
Visual Basic (Declaration)
Public Function NewPointOnEdge ( _
    edgeReference As Reference, _
    edgeParam As Double _
) As PointOnEdge
Visual C++
public:
PointOnEdge^ NewPointOnEdge(
    Reference^ edgeReference,
    double edgeParam
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference
The reference whose edge the object will be created on.
edgeParam
Type: System..::.Double
The parameter on the edge.

Return Value

If creation was successful then a new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument edgeReference is nullNothingnullptra null reference (Nothing in Visual Basic) or edgeParam is not a valid double value.

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewPointOnEdgeEdgeIntersection Method

[image]