Revit 2011 API
FilteredElementIdIterator Members
FilteredElementIdIterator Class Methods Properties See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Methods

Name | Description
Dispose |
GetCurrent | The current element id found by the iterator.
IsDone | Identifies if the iteration has completed.
MoveNext | Increments the iterator to the next element id passing the filter.
Reset | Resets the iterator to the beginning.

Properties

Name | Description
Current |
CurrentObject |

See Also

FilteredElementIdIterator Class

FilteredElementIdIterator Methods

[image] [image]