Revit 2011 API
IViewSheetSet..::.Views Property
IViewSheetSet Interface See Also Send Feedback
The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
ViewSet Views { get; set; }
Visual Basic (Declaration)
Property Views As ViewSet
Visual C++
property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

IViewSheetSet Interface

JoinType Enumeration

[image]