Revit 2011 API
RebarShape Properties
RebarShape Class See Also Send Feedback

The RebarShape type exposes the following members.

Properties

Name | Description
Definition | Get the shape definition object associated with this shape.
HookAngle | Get and set the hook angle.
HookOrientation | Get and set the hook orientation.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
RebarStyle | Access the rebar style.
SameShapeIgnoringHooks | Test whether two shapes have equivalent definitions.
SimpleArc | Check whether this shape consists of a single arc, possibly with hooks.
SimpleLine | Check whether this shape consists of a single straight segment, possibly with hooks.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

Definition Property

[image]