Revit 2011 API
BuiltInFailures..::.RebarFailures Properties
BuiltInFailures..::.RebarFailures Class See Also Send Feedback

The BuiltInFailures..::.RebarFailures type exposes the following members.

Properties

Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CoverTooLong | Rebar Cover length is too large for host thickness.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HookAngleMustBePositive | Rebar Hook angle is negative. Ignoring hook.
HookAngleMustBePositiveWarn | Rebar Hook angle is negative. Ignoring hook.
HookAngleTooBig | Rebar Hook angle is greater than 180 degrees. Ignoring hook.
HookAngleTooBigWarn | Rebar Hook angle is greater than 180 degrees. Ignoring hook.
HookLengthTooSmall | Rebar Hook Length is too small.
HookLengthTooSmallWarn | Rebar Hook Length is too small.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
MaxHookExtensionMultiplierWarn | The maximum Hook Extension Multiplier value permitted is 99.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
OutSideOfHost | Rebar is placed completely outside of its host.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1000 Bars when layout is Fixed Number or Number With Spacing
TooSmallNumberOfBars | Rebar Set must contain at least two Bars.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.

See Also

BuiltInFailures..::.RebarFailures Class

BarDiameterTooLarge Property

[image]