Revit 2011 API
Edge..::.ComputeDerivatives Method
Edge Class See Also Send Feedback
Returns the moving frame around the edge at the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    double parameter
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    parameter As Double _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    double parameter
)

Parameters

parameter
Type: System..::.Double
The parameter is the natural (or "raw") edge parameter.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation members: Origin is the point on the edge (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the normal vector (the second derivative); BasisZ is the binormal vector (tangent x normal). Normal and binormal are zero if the edge is straight at the point. None of the vectors are normalized.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when parameter is an infinite number.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failed to compute derivatives.

See Also

Edge Class

Evaluate Method

[image]