Revit 2011 API
Application..::.NewNurbSpline Method
Application Class See Also Send Feedback
Creates a new geometric nurbSpline object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public NurbSpline NewNurbSpline(
    IList<XYZ> ctrlPoints,
    DoubleArray weights,
    DoubleArray knots,
    int nDegree,
    bool bClosed,
    bool bRational
)
Visual Basic (Declaration)
Public Function NewNurbSpline ( _
    ctrlPoints As IList(Of XYZ), _
    weights As DoubleArray, _
    knots As DoubleArray, _
    nDegree As Integer, _
    bClosed As Boolean, _
    bRational As Boolean _
) As NurbSpline
Visual C++
public:
NurbSpline^ NewNurbSpline(
    IList<XYZ^>^ ctrlPoints,
    DoubleArray^ weights,
    DoubleArray^ knots,
    int nDegree,
    bool bClosed,
    bool bRational
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The control points of the nurbSpline.
weights
Type: Autodesk.Revit.DB..::.DoubleArray
The weights of the nurbSpline.
knots
Type: Autodesk.Revit.DB..::.DoubleArray
The knots of the nurbSpline.
nDegree
Type: System..::.Int32
The degree of the nurbSpline.
bClosed
Type: System..::.Boolean
The nurbSpline is closed or not.
bRational
Type: System..::.Boolean
The nurbSpline is rational or no rational.

Remarks

If bRational is true,the size of ctrlPoints must equal to weights's,otherwise throw ArgumentException. There is a rule like that the size of knots equals to the sum of nDegree, ctrlPoints.size and 1, and the first nDegree+1 elements in the knots always are zero.

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewPlane Method

[image] [image]