Revit 2011 API
Document..::.Mirror Method (ICollection<(Of <(ElementId>)>), Reference)
Document Class See Also Send Feedback
Mirrors several elements, specified by ids, about a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirror(
    ICollection<ElementId> ids,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    ids As ICollection(Of ElementId), _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ICollection<ElementId^>^ ids,
    Reference^ reference
)

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of elements that are to be mirrored.
reference
Type: Autodesk.Revit.DB..::.Reference
The reference by which the elements will mirror.

Return Value

True if the elements are mirrored successfully.

See Also

Document Class
Mirror Overload

Move Method

[image] [image]