Revit 2011 API
RebarShapeDefinition..::.Commit Method
RebarShapeDefinition Class See Also Send Feedback
Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Commit()
Visual Basic (Declaration)
Public Sub Commit
Visual C++
public:
void Commit()

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeDefinition Properties

[image] [image]