Revit 2011 API
TaskDialog Members
TaskDialog Class Constructors Methods Properties See Also Send Feedback

The TaskDialog type exposes the following members.

Constructors

Name | Description
TaskDialog | Creates a task dialog with title.

Methods

Name | Description
AddCommandLink | Overloaded. Adds a CommandLink to the TaskDialog.
Show | Overloaded. Shows a task dialog.
WasVerificationChecked | Gets the status of the verification checkbox.

Properties

Name | Description
AllowCancellation | Whether the task dialog can be cancelled if no cancel button is specified.
CommonButtons | The push buttons displayed in the task dialog.
DefaultButton | The default button for the dialog.
ExpandedContent | ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.
FooterText | FooterText is used in the footer area of the task dialog.
Id | The Id of the task dialog.
MainContent | MainContent is the smaller text that appears just below the main instructions.
MainIcon | The icon shown in the task dialog.
MainInstruction | The large primary text that appears at the top of a task dialog.
Title | Title of the task dialog.
TitleAutoPrefix | Whether the TaskDialog's title will automatically have the add-in name added as a prefix.
VerificationText | VerificationText is used to label the verification checkbox.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace

TaskDialog Constructor

[image]