Revit 2011 API
IExtension..::.Extended Property
IExtension Interface See Also Send Feedback
Retrieves or set the extension status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
bool Extended[
    int index
] { get; set; }
Visual Basic (Declaration)
Property Extended ( _
    index As Integer _
) As Boolean
Visual C++
property bool Extended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, if the beam extension status is changed, other status such as the symbolic extension status, miter status, miter locked status, and other beams extension status will be changed automatically at the same time. This change can protect that a join can have up to two extended beams, if there are two extended beams at the join, they shall be mitered.

See Also

IExtension Interface

HasMiter Property

[image]