Revit 2011 API
Document..::.NewRooms Method
Document Class See Also Send Feedback
Creates one or more rooms.

Overload List

Name | Description
NewRooms(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
NewRooms(List<(Of <(RoomCreationData>)>)) | Creates new rooms using the specified placement data.
NewRooms(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
NewRooms(Phase, Int32) | Creates new unplaced rooms in the given phase.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace

NewRooms Method (Level)

[image]