Revit 2011 API
GuidEnum Constructor
GuidEnum Class See Also Send Feedback
Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GuidEnum(
    Guid guid
)
Visual Basic (Declaration)
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
GuidEnum(
    Guid guid
)

Parameters

guid
Type: System..::.Guid
The GUID of this GUID-based enum.

See Also

GuidEnum Class

GuidEnum Methods

[image] [image]