Revit 2011 API
Document..::.PlanTopologies Property
Document Class See Also Send Feedback
Get the PlanTopologies of the current project in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanTopologySet PlanTopologies { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopologies As PlanTopologySet
Visual C++
public:
property PlanTopologySet^ PlanTopologies {
    PlanTopologySet^ get ();
}

Remarks

Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopologies Overload

PlanTopologies Property (Phase)

[image]