Revit 2011 API
Enclosure Class
Members See Also Send Feedback
Represents an enclosed area or volume in the Revit model. This is the parent class for rooms, spaces and areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Enclosure : Element
Visual Basic (Declaration)
Public Class Enclosure _
    Inherits Element
Visual C++
public ref class Enclosure : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Enclosure
Autodesk.Revit.DB.Architecture..::.Room
Autodesk.Revit.DB..::.Area
Autodesk.Revit.DB.Mechanical..::.Space

See Also

Enclosure Members

Enclosure Members

[image] [image]