Revit 2011 API
FamilyInstance..::.StructuralUsage Property
FamilyInstance Class See Also Send Feedback
Provides the primary structural usage of the instance, such as brace, girder etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StructuralInstanceUsage StructuralUsage { get; set; }
Visual Basic (Declaration)
Public Property StructuralUsage As StructuralInstanceUsage
Visual C++
public:
property StructuralInstanceUsage StructuralUsage {
    StructuralInstanceUsage get ();
    void set (StructuralInstanceUsage value);
}

See Also

FamilyInstance Class

SubComponents Property

[image]