Revit 2011 API
CurtainGridLine Methods
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Methods

Name | Description
AddAllSegments | All the segments on this grid line will be added.
AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
AddSegment | Add a segment based on the specified segment curve of the gridline.
Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
RemoveSegment | Remove the segment specified by the input curve.

See Also

CurtainGridLine Class

AddAllSegments Method

[image]