Revit 2011 API
IFCExportOptions..::.ExportBaseQuantities Property
IFCExportOptions Class See Also Send Feedback
Option to export IFC standard quantities currently supported by Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ExportBaseQuantities { get; set; }
Visual Basic (Declaration)
Public Property ExportBaseQuantities As Boolean
Visual C++
public:
property bool ExportBaseQuantities {
    bool get ();
    void set (bool value);
}

Remarks

IFC has created a list of common quantities (e.g. length, area, volume, etc.) that can optionally be exported along with the 3D representation for many element types (e.g. walls, columns, doors). Setting this option to true will cause the export procedure to include the set of IFC quantities that Revit currently supports.

See Also

IFCExportOptions Class

FamilyMappingFile Property

[image]