Revit 2011 API
MaterialSteel..::.ReductionFactor Property
MaterialSteel Class See Also Send Feedback
Get or set the reduction factor for shear of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ReductionFactor { get; set; }
Visual Basic (Declaration)
Public Property ReductionFactor As Double
Visual C++
public:
property double ReductionFactor {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the reduction factor for shear to an invalid value.

See Also

MaterialSteel Class

ShearModulusX Property

[image]