Revit 2011 API
Materials Members
Materials Class Methods Properties See Also Send Feedback

The Materials type exposes the following members.

Methods

Name | Description
AddConcrete | Add a concrete material with the given name .
AddGeneric | Add a generic material with the given name .
AddOther | Add an other material with the given name .
AddSteel | Add a steel material with the given name .
AddWood | Add a wood material with the given name .
Contains | Overloaded. Checks if the material set contains the material with the specified identifier.
Remove | Remove the material with the specified name .

Properties

Name | Description
Item | Overloaded. Gets the material with the specified identifier.

See Also

Materials Class

Materials Methods

[image] [image]