Revit 2011 API
FamilyInstance..::.MEPModel Property
FamilyInstance Class See Also Send Feedback
Retrieves the MEP model for the family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPModel MEPModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property MEPModel As MEPModel
Visual C++
public:
property MEPModel^ MEPModel {
    MEPModel^ get ();
}

Remarks

If the family instance has a MEP model it is returned by this method, otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is returned. Different types of MEP model will be returned based on the type of the instance, for example - if the instance is a lighting device then a lighting device model will be returned. This property will only function with the Autodesk Revit MEP product.

See Also

FamilyInstance Class

Mirrored Property

[image]