Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RailingCurvesNotSplitStairs Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailingCurvesNotSplitStairs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailingCurvesNotSplitStairs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailingCurvesNotSplitStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class

RailingDoublyConnected Property

[image]