Revit 2011 API
Transform Properties
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Properties

Name | Description
Basis | Defines the basis of the old coordinate system in the new coordinate system.
BasisX | The basis of the X axis of this transformation.
BasisY | The basis of the Y axis of this transformation.
BasisZ | The basis of the Z axis of this transformation.
Determinant | The determinant of this transformation.
HasReflection | The boolean value that indicates whether this transformation produces reflection.
Identity | The identity transformation.
Inverse | The inverse transformation of this transformation.
IsConformal | The boolean value that indicates whether this transformation is conformal.
IsIdentity | The boolean value that indicates whether this transformation is an identity.
IsTranslation | The boolean value that indicates whether this transformation is a translation.
Origin | Defines the origin of the old coordinate system in the new coordinate system.
Reflection | The transformation that reflects about the specified plane.
Rotation | The transformation that rotates by the specified angle about the specified axis and point.
Scale | The real number that represents the scale of the transformation.
Translation | The transformation that translates by the specified vector.

See Also

Transform Class

Basis Property

[image]