Revit 2011 API
CableTray Members
CableTray Class Methods Properties See Also Send Feedback

The CableTray type exposes the following members.

Methods

Name | Description
Create | Creates a new instance of cable tray.
GetShapeType | Returns the shape type for the cable tray.
IsValidCableTrayType | Identifies if a cable tray type is valid.
IsValidRungSpace | Identifies if the input rung space is valid.

Properties

Name | Description
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
RungSpace |

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace

CableTray Methods

[image] [image]