Revit 2011 API
BeamSystem Members
BeamSystem Class Methods Properties See Also Send Feedback

The BeamSystem type exposes the following members.

Methods

Name | Description
BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
GetAllBeams | Get all the beams of the BeamSystem.

Properties

Name | Description
BeamSystemType | Retrieve or change the type of the BeamSystem.
BeamType | Retrieve or change the Beam Type of the BeamSystem.
Direction | Retrieve or change the Direction of the BeamSystem.
Elevation | Retrieve or change the Elevation of the BeamSystem.
LayoutRule | Retrieve or change the LayoutRule of the BeamSystem.
Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Profile | Retrieve or set the profile of the BeamSystem.

See Also

BeamSystem Class

BeamSystem Methods

[image] [image]