Revit 2011 API
SiteLocation..::.Longitude Property
SiteLocation Class See Also Send Feedback
The longitude of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Longitude { get; set; }
Visual Basic (Declaration)
Public Property Longitude As Double
Visual C++
public:
property double Longitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the longitude of the site location. The value of this property is in radians between +PI and -PI.

When setting this property:

  1. Revit will attempt to match the coordinates to a city it knows about, and if a match is found, will set the name accordingly.
  2. Revit will not attempt to automatically adjust the time zone value to match the new Longitude value set. You can set the TimeZone property directly to the correct value if necessary.

See Also

SiteLocation Class

Parameter Property

[image] [image]