Revit 2011 API
SolidSolidCutUtils..::.GetSolidsBeingCut Method
SolidSolidCutUtils Class See Also Send Feedback
Get all the solids which are cut by the input element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetSolidsBeingCut(
    Element Elem
)
Visual Basic (Declaration)
Public Shared Function GetSolidsBeingCut ( _
    Elem As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetSolidsBeingCut(
    Element^ Elem
)

Parameters

Elem
Type: Autodesk.Revit.DB..::.Element

Return Value

All the solids which are cut by the input element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class

IsAllowedForSolidCut Method

[image]