Revit 2011 API
MaterialConcrete..::.ShearModulusY Property
MaterialConcrete Class See Also Send Feedback
Get or set the y component of the shear modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusY { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusY As Double
Visual C++
public:
property double ShearModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class

ShearModulusZ Property

[image]