Revit 2011 API
MaterialWood Properties
MaterialWood Class See Also Send Feedback

The MaterialWood type exposes the following members.

Properties

Name | Description
Bending | Get or set the bending of the wood material.
CompressionParallel | Get or set the compression parallel to grain of the wood material.
CompressionPerpendicular | Get or set the compression perpendicular to grain of the wood material.
Grade | Get or set the grade of the wood material.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
PoissonModulus | Get or set the Poisson modulus of the wood material.
ShearModulus | Get or set the shear modulus of the wood material.
ShearParallel | Get or set the shear parallel to grain of the wood material.
ShearPerpendicular | Get or set the tension perpendicular to grain of the wood material.
Species | Get or set the species of the wood material.
ThermalExpansionCoefficient | Get or set the thermal expansion coefficient of the wood material.
UnitWeight | Get or set the unit weight of the wood material.
YoungModulus | Get or set the Young modulus of the wood material.

See Also

MaterialWood Class

Bending Property

[image]