Revit 2011 API
Ellipse Members
Ellipse Class Methods Properties See Also Send Feedback

The Ellipse type exposes the following members.

Methods

Name | Description
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.

Properties

Name | Description
Center | Returns the center of the ellipse.
Normal | Returns the normal to the plane in which the ellipse is defined.
RadiusX | Returns the X vector radius of the ellipse.
RadiusY | Returns the Y vector radius of the ellipse.

See Also

Ellipse Class

Ellipse Methods

[image] [image]