Revit 2011 API
CurveArray..::.Item Property
CurveArray Class See Also Send Feedback
Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Curve Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Curve
Visual C++
public:
virtual property Curve^ Item[int index] {
    Curve^ get (int index);
    void set (int index, Curve^ value);
}

Parameters

index
Type: System..::.Int32
The index of the curve to be set or retrieved.

Return Value

Returns the curve at the specified index.

See Also

CurveArray Class

Size Property

[image]