Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SurfaceSelfIntersection Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceSelfIntersection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SurfaceSelfIntersection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SurfaceSelfIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class

SurfaceSplit Property

[image]