Revit 2011 API
MassInstanceUtils Members
MassInstanceUtils Class Methods See Also Send Feedback

The MassInstanceUtils type exposes the following members.

Methods

Name | Description
AddMassLevelDataToMassInstance | Create a MassLevelData to associate a Level with a mass instance.
Dispose |
GetGrossFloorArea | Get the total occupiable floor area represented by a mass instance.
GetGrossSurfaceArea | Get the total exterior building surface area represented by a mass instance.
GetGrossVolume | Get the total building volume represented by a mass instance.
GetJoinedElementIds | Get the ElementIds of Elements that are joined to a mass instance.
GetMassLevelDataIds | Get the ElementIds of the MassLevelDatas associated with a mass instance.
GetMassLevelIds | Get the ElementIds of the Levels associated with a mass instance.
RemoveMassLevelDataFromMassInstance | Delete the MassLevelData that associates a Level with a mass instance.

See Also

MassInstanceUtils Class

MassInstanceUtils Methods

[image] [image]