Revit 2011 API
ReferenceArray..::.Item Property
ReferenceArray Class See Also Send Feedback
Gets or sets a reference at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Reference Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Reference
Visual C++
public:
virtual property Reference^ Item[int index] {
    Reference^ get (int index);
    void set (int index, Reference^ value);
}

Parameters

index
Type: System..::.Int32
The index of the reference to be set or retrieved.

Return Value

Returns the reference at the specified index.

See Also

ReferenceArray Class

Size Property

[image]