Revit 2011 API
RebarShapeDefinitionBySegments..::.SetSegmentFixedDirection Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Fix the direction of a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)
Visual Basic (Declaration)
Public Sub SetSegmentFixedDirection ( _
    iSegment As Integer, _
    vecCoordX As Double, _
    vecCoordY As Double _
)
Visual C++
public:
void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
vecCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the segment direction.
vecCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the segment direction.

Remarks

The centerline of the segment will be constrained to be parallel to the vector. The line must have at least one constraint.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

SetSegmentVariableDirection Method

[image]