Revit 2011 API
PipeType Class
Members See Also Send Feedback
A pipe type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PipeType : MEPCurveType
Visual Basic (Declaration)
Public Class PipeType _
    Inherits MEPCurveType
Visual C++
public ref class PipeType : public MEPCurveType

Remarks

The pipe type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Plumbing..::.PipeType

See Also

PipeType Members
Autodesk.Revit.DB.Plumbing Namespace

PipeType Members

[image] [image]