Revit 2011 API
WireSizeSetIterator..::.MoveNext Method
WireSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace

Reset Method

[image]