Revit 2011 API
FamilyManager..::.MakeType Method
FamilyManager Class See Also Send Feedback
Set the family parameter as a type parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MakeType(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeType ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeType(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.

See Also

FamilyManager Class

NewType Method

[image]