Revit 2011 API
EnergyDataSettings..::.ExportCategory Property
EnergyDataSettings Class See Also Send Feedback
Value is a category indicating which discipline model will be used for GreenBuildingXML export.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId ExportCategory { get; set; }
Visual Basic (Declaration)
Public Property ExportCategory As ElementId
Visual C++
public:
property ElementId^ ExportCategory {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

OST_Rooms will use the architectural 3d rooms for export. OST_MEPSpaces will user the MEP 3d Spaces for export. OST_Massing will use the massing model geometries for export. invalidElementId if nothing has been set by the user.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace

ExportComplexity Property

[image]