Revit 2011 API
RebarShapeDefinitionByArc..::.AddConstraintChordLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintChordLength(
    Parameter param
)
Visual Basic (Declaration)
Public Sub AddConstraintChordLength ( _
    param As Parameter _
)
Visual C++
public:
void AddConstraintChordLength(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

Remarks

The chord length is measured on the centerline of the bar.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace

AddConstraintCircumference Method

[image]