Revit 2011 API
Definitions Class
Members See Also Send Feedback
A base class that supports the addition of new parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Definitions : DefinitionsBase
Visual Basic (Declaration)
Public Class Definitions _
    Inherits DefinitionsBase
Visual C++
public ref class Definitions : public DefinitionsBase

Remarks

There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionsBase
Autodesk.Revit.DB..::.Definitions
Autodesk.Revit.DB..::.ExternalDefinitions
Autodesk.Revit.DB..::.InternalDefinitions

See Also

Definitions Members

Definitions Members

[image] [image]