Revit 2011 API
Map..::.Insert Method
Map Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Object key,
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Object, _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Object^ key,
    Object^ item
)

Parameters

key
Type: System..::.Object
The key to be used for inserting the item into the map.
item
Type: System..::.Object
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace

ReverseIterator Method

[image]