Revit 2011 API
MassLevelData..::.MaterialType Property
MassLevelData Class See Also Send Feedback
Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassSurfaceDataMaterialType MaterialType { get; set; }
Visual Basic (Declaration)
Public Property MaterialType As MassSurfaceDataMaterialType
Visual C++
public:
property MassSurfaceDataMaterialType MaterialType {
    MassSurfaceDataMaterialType get ();
    void set (MassSurfaceDataMaterialType value);
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace

NExteriorSurfaceArea Property

[image]