Revit 2011 API
Rebar..::.IsShownInFrontOfGeometryInView Property
Rebar Class See Also Send Feedback
Control placement of the rebar graphics in the viewing planes.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use IsUnobscuredInView()/SetUnobscuredInView() instead.")]
public bool IsShownInFrontOfGeometryInView[
    View dbView
] { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use IsUnobscuredInView()/SetUnobscuredInView() instead.")> _
Public Property IsShownInFrontOfGeometryInView ( _
    dbView As View _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Use IsUnobscuredInView()/SetUnobscuredInView() instead.")]
public:
property bool IsShownInFrontOfGeometryInView[View^ dbView] {
    bool get (View^ dbView);
    void set (View^ dbView, bool value);
}

Parameters

dbView
Type: Autodesk.Revit.DB..::.View

Remarks

Control whether the graphics are shown in front of the geometry in a view.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

LayoutRule Property

[image]