Revit 2011 API
FamilyInstance..::.ToRoom Property
FamilyInstance Class See Also Send Feedback
The room to which the door is opened at the last phase of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room ToRoom { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToRoom As Room
Visual C++
public:
property Room^ ToRoom {
    Room^ get ();
}

Remarks

When current familyinstance is neither door nor window, this property will always return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyInstance Class
ToRoom Overload

ToRoom Property (Phase)

[image]