Revit 2011 API
RebarShapeDefinition Class
Members See Also Send Feedback
A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition. The definition object is created by one of the factory methods on RebarShape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarShapeDefinition : APIObject
Visual Basic (Declaration)
Public Class RebarShapeDefinition _
    Inherits APIObject
Visual C++
public ref class RebarShapeDefinition : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarShapeDefinition
Autodesk.Revit.DB.Structure..::.RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure..::.RebarShapeDefinitionBySegments

See Also

RebarShapeDefinition Members
Autodesk.Revit.DB.Structure Namespace

RebarShapeDefinition Members

[image] [image]