Revit 2011 API
StringStringMap Methods
StringStringMap Class See Also Send Feedback

The StringStringMap type exposes the following members.

Methods

Name | Description
Clear | Removes every string from the map, rendering it empty.
Contains | Tests for the existence of a string key within the map.
Erase | Removes an item with the specified string key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace

Clear Method

[image]