Revit 2011 API
FamilyManager..::.Parameter Property (BuiltInParameter)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    BuiltInParameter parameterId
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[BuiltInParameter parameterId] {
    FamilyParameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
Type: Autodesk.Revit.DB..::.BuiltInParameter

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload

Parameter Property (Definition)

[image]