Revit 2011 API
Selection..::.PickObjects Method (ObjectType, ISelectionFilter, String)
Selection Class Example See Also Send Feedback
Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType,
    ISelectionFilter pSelFilter,
    string statusPrompt
)
Visual Basic (Declaration)
Public Function PickObjects ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter, _
    statusPrompt As String _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter,
    String^ statusPrompt
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::.ISelectionFilter
The selection filter.
statusPrompt
Type: System..::.String
The message shown on the status bar.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
public void SelectPlanarFaces(Autodesk.Revit.DB.Document document)
{
    UIDocument uidoc = new UIDocument(document);
    ISelectionFilter selFilter = new PlanarFacesSelectionFilter();
    IList<Reference> faces =
        uidoc.Selection.PickObjects(ObjectType.Face, selFilter, "Select multiple planar faces");
}

public class PlanarFacesSelectionFilter : ISelectionFilter
{
    public bool AllowElement(Element element)
    {
        return true;
    }

    public bool AllowReference(Reference refer, XYZ point)
    {
        if (refer.GeometryObject is PlanarFace)
        {
            return true;
        }

        return false;
    }
}
CopyVB.NET
Public Sub SelectPlanarFaces(ByVal document As Autodesk.Revit.DB.Document)
    Dim uidoc As New UIDocument(document)
    Dim selFilter As ISelectionFilter = New PlanarFacesSelectionFilter()
    Dim faces As IList(Of Reference) = uidoc.Selection.PickObjects(Autodesk.Revit.UI.Selection.ObjectType.Face, selFilter, "Select multiple planar faces")
End Sub

Public Class PlanarFacesSelectionFilter
    Implements ISelectionFilter
    Public Function AllowElement(ByVal element As Autodesk.Revit.DB.Element) As Boolean Implements ISelectionFilter.AllowElement
        Return True
    End Function

    Public Function AllowReference(ByVal refer As Reference, ByVal point As Autodesk.Revit.DB.XYZ) As Boolean Implements ISelectionFilter.AllowReference
        If TypeOf refer.GeometryObject Is PlanarFace Then
            Return True
        End If

        Return False
    End Function
End Class

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic) or statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace

PickObjects Method (ObjectType, ISelectionFilter, String, IList(Reference))

[image]