Revit 2011 API
PanelScheduleTemplate..::.CopyFrom Method
PanelScheduleTemplate Class See Also Send Feedback
Copies all values from other element to this object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void CopyFrom(
    PanelScheduleTemplate otherElem
)
Visual Basic (Declaration)
Public Sub CopyFrom ( _
    otherElem As PanelScheduleTemplate _
)
Visual C++
public:
void CopyFrom(
    PanelScheduleTemplate^ otherElem
)

Parameters

otherElem
Type: Autodesk.Revit.DB.Electrical..::.PanelScheduleTemplate
The element being copied from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given template otherElem has different type of this element.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace

Create Method

[image]