Revit 2011 API
IExternalCommandAvailability..::.IsCommandAvailable Method
IExternalCommandAvailability Interface See Also Send Feedback
Implement this method to provide control over whether your external command is enabled or disabled.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
bool IsCommandAvailable(
    UIApplication applicationData,
    CategorySet selectedCategories
)
Visual Basic (Declaration)
Function IsCommandAvailable ( _
    applicationData As UIApplication, _
    selectedCategories As CategorySet _
) As Boolean
Visual C++
bool IsCommandAvailable(
    UIApplication^ applicationData,
    CategorySet^ selectedCategories
)

Parameters

applicationData
Type: Autodesk.Revit.UI..::.UIApplication
An ApplicationServices.Application object which contains reference to Application needed by external command.
selectedCategories
Type: Autodesk.Revit.DB..::.CategorySet
An list of categories of the elements which have been selected in Revit in the active document, or an empty set if no elements are selected or there is no active document.

Return Value

Indicates whether Revit should enable or disable the corresponding external command.

See Also

IExternalCommandAvailability Interface
Autodesk.Revit.UI Namespace

PulldownButton Class

[image]