Revit 2011 API
GenericForm..::.Name Property
GenericForm Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for GenericForm object, an InvalidOperationException will be thrown.

See Also

GenericForm Class

Parameter Property

[image] [image]