Revit 2011 API
RebarBarType..::.StandardBendDiameter Property
RebarBarType Class See Also Send Feedback
Defines bar bend diameter for rebar whose style is standard

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StandardBendDiameter { get; set; }
Visual Basic (Declaration)
Public Property StandardBendDiameter As Double
Visual C++
public:
property double StandardBendDiameter {
    double get ();
    void set (double value);
}

Field Value

The bar bend diameter for rebar whose style is standard

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: the bend diameter standardBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

StandardHookBendDiameter Property

[image]