Revit 2011 API
Face Methods
Face Class See Also Send Feedback

The Face type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
ComputeNormal | Returns the normal vector for the face at the given point.
Evaluate | Evaluates parameters on the face.
GetBoundingBox | Returns the UV bounding box of the face.
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face.
Triangulate | Returns a triangular mesh approximation to the face.

See Also

Face Class

ComputeDerivatives Method

[image]