Revit 2011 API
FamilyType..::.HasValue Method
FamilyType Class See Also Send Feedback
Indicates if this family parameter has an assigned value or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasValue(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function HasValue ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool HasValue(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class

FamilyType Properties

[image] [image]