Revit 2011 API
SpatialFieldManager..::.AddSpatialFieldPrimitive Method (Face, Transform)
SpatialFieldManager Class See Also Send Feedback
Creates empty analysis results container (primitive) associated with a face and a transform.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive(
    Face face,
    Transform trf
)
Visual Basic (Declaration)
Public Function AddSpatialFieldPrimitive ( _
    face As Face, _
    trf As Transform _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Face^ face,
    Transform^ trf
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
Face to be associated with the primitive
trf
Type: Autodesk.Revit.DB..::.Transform
Conformal Transform to be applied to %face%

Return Value

Unique index of primitive for future references

Remarks

This method accepts a reference to a model face, and a transform to be applied to that face, allowing the display of analytical results on faces which are not strictly a part of the Revit model.

This method should not be used if the transform is the identity transform, i.e. the intent is to display results on a face which is part of the Revit model. In that case, use the overload of this method which accepts a reference.

If the input face is from the geometry of a symbol, the face will be considered to be in the location specified by it's symbol geometry. If your intention is to transform the face relative to its location in the instance, your input transform must consist of the instance's transform left multiplied by the extra transform to get the results you expect.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | trf is not conformal
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace

Clear Method

[image]