Revit 2011 API
Application..::.OpenDocumentFile Method
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName
)
Visual Basic (Declaration)
Public Overridable Function OpenDocumentFile ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The file to be opened.

Remarks

It is correspond to the File->Open....

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If 'fileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the file cannot be opened.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

OpenSharedParameterFile Method

[image]