Revit 2011 API
RebarShapeDefinitionByArc..::.AddConstraintDiameter Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the diameter of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintDiameter(
    Parameter param,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintDiameter ( _
    param As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintDiameter(
    Parameter^ param,
    RebarShapeArcReferenceType arcRefType
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
arcRefType
Type: Autodesk.Revit.DB.Structure..::.RebarShapeArcReferenceType
Specify how the diameter should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace

AddConstraintRadius Method

[image]