Revit 2011 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
Array | Overloaded. Creates an array of one or more elements.
ArrayWithoutAssociate | Overloaded. Creates an array of one or more elements where the elements created will not be grouped and associated.
AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Close | Overloaded. Closes the document.
CombineElements | Combine a set of combinable elements into a geometry combination.
ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
Delete | Overloaded. Deletes one or more elements from the document.
Dispose |
EditFamily | Edits a family loaded in the document.
Export | Overloaded. Exports the document to another file format.
ExportImage | Exports a view or set of views into an image file.
FindReferencesByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
GetDocumentPreviewSettings | Returns the preview settings for the given document.
GetRoomAtPoint | Overloaded. Gets a room containing the point.
GetSpaceAtPoint | Overloaded. Gets a space containing the point.
Import | Overloaded. Imports the contents of an external file into the document.
Link | Links a DWG file into the document.
LoadFamily | Overloaded. Loads a family and all its types/symbols.
LoadFamilySymbol | Overloaded. Loads only a specified family type/symbol from a family file into the document.
Mirror | Overloaded. Mirrors one or more elements.
Move | Overloaded. Moves one or more elements within the document by a specified vector.
PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Print | Overloaded. Prints a set of views.
Regenerate | Updates the elements in the Revit document to reflect all changes.
Rotate | Overloaded. Rotates one or more elements within the document by a specified angle around a given axis.
Save | Saves the document.
SaveAs | Overloaded. Saves the document to a new file name.
SaveToProjectAsImage | Creates an image view from the currently active view.
SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.

See Also

Document Class

Array Method

[image] [image]