Revit 2011 API
TransactionGroup..::.HasEnded Method
TransactionGroup Class See Also Send Feedback
Determines whether the transaction group was ended or not

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasEnded()
Visual Basic (Declaration)
Public Function HasEnded As Boolean
Visual C++
public:
bool HasEnded()

Remarks

A simple test of whether transaction group was either Committed/Assimilated or Rolled Back. This is basically a simple way of testing if the current status is either 'TransactionStatus::Committed' or 'TransactionStatus::RolledBack'

See Also

TransactionGroup Class

HasStarted Method

[image]