Revit 2011 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
NewArea | Creates a new area
NewAreaBoundaryConditions | Overloaded. Creates a new Area BoundaryConditions element.
NewAreaBoundaryLine | Creates a new boundary line as an Area border.
NewAreaLoad | Overloaded. Creates a new area load in the project.
NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
NewAreas | Creates new areas
NewAreaTag | Creates a new area tag.
NewAreaViewPlan | Creates a new view for the new area.
NewBeamSystem | Overloaded. Creates a new BeamSystem.
NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
NewCurtainSystem | Overloaded. Creates a new CurtainSystem element.
NewDimension | Overloaded. Creates a new linear dimension object.
NewDuct | Overloaded. Adds a new duct into the document.
NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
NewElectricalSystem | Overloaded. Creates a new MEP Electrical System element.
NewExtrusionRoof | Creates a new Extrusion Roof.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFascia | Overloaded. Creates a fascia.
NewFlexDuct | Overloaded. Adds a new flexible duct into the document.
NewFlexPipe | Overloaded. Adds a new flexible pipe into the document.
NewFloor | Overloaded. Creates a floor within the project.
NewFootPrintRoof | Creates a new FootPrintRoof element.
NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
NewFoundationWall | Creates a new continuous footing object.
NewGrid | Overloaded. Creates a new grid line.
NewGrids | Creates new grid lines.
NewGutter | Overloaded. Creates a gutter.
NewLineBoundaryConditions | Overloaded. Creates a new Line BoundaryConditions element.
NewLineLoad | Overloaded. Creates a new line load within the project.
NewLoadCase | Creates a new instance of a LoadCase element within the project.
NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
NewLoadNature | Creates a new instance of a LoadNature element within the project.
NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
NewMechanicalSystem | Creates a new MEP mechanical system element.
NewOpening | Overloaded. Creates a new opening.
NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
NewPipe | Overloaded. Adds a new pipe into the document.
NewPipingSystem | Creates a new MEP piping system element.
NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
NewPointLoad | Overloaded. Creates a new point load within the project.
NewRebar | Overloaded. Creates a new instance of a Rebar element within the project.
NewRebarBarType | Creates a new instance of Rebar Bar Type, which defines the bar diameter, bar bend diameter and bar material of the rebar.
NewRebarCoverType | Create a new instance of Rebar Cover Type, which defines the cover setting of the rebar host.
NewRebarHookType | Creates a new instance of Rebar Hook Type, which defines the hook style of the rebar.
NewRebarShape | Creates a new instance of a Rebar Shape, which defines the shape of the rebar.
NewRoom | Overloaded. Creates a new room.
NewRoomBoundaryLines | Creates a new boundary line as an Room border.
NewRooms | Overloaded. Creates one or more rooms.
NewRoomTag | Creates a new RoomTag.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
NewSlabEdge | Overloaded. Creates a slab edge.
NewSpace | Overloaded. Creates a new space.
NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
NewSpaces | Overloaded. Creates one or more spaces.
NewSpaceTag | Creates a new SpaceTag.
NewSpotCoordinate | Generate a new spot coordinate object within the project.
NewSpotElevation | Generate a new spot elevation object within the project.
NewTag | Creates a new IndependentTag Element.
NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTopographySurface | Creates a new TopographySurface element in the document, and initializes it with a set of points.
NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
NewTruss | Creates a New Truss.
NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
NewViewDrafting | Creates a new drafting view.
NewViewSheet | Creates a new sheet view.
NewWall | Overloaded. Creates a new wall within the project.
NewWalls | Overloaded. Creates walls within the project.
NewWire | Creates a new wire element.
NewZone | Creates a new Zone element.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewArea Method

[image]