Revit 2011 API
TransactionGroup..::.Commit Method
TransactionGroup Class See Also Send Feedback
Commits the transaction group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Commit()
Visual Basic (Declaration)
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Remarks

Using "commit" to end the transaction group User will be able to undo/redo to the middle of the group

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The TransactionGroup is not in started status

See Also

TransactionGroup Class

Dispose Method

[image]