Revit 2011 API
Document..::.Link Method
Document Class See Also Send Feedback
Links a DWG file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Link(
    string file,
    DWGImportOptions options,
    out Element element
)
Visual Basic (Declaration)
Public Function Link ( _
    file As String, _
    options As DWGImportOptions, _
    <OutAttribute> ByRef element As Element _
) As Boolean
Visual C++
public:
bool Link(
    String^ file,
    DWGImportOptions^ options,
    [OutAttribute] Element^% element
)

Parameters

file
Type: System..::.String
Full path of the DWG file to link. File must exist.
options
Type: Autodesk.Revit.DB..::.DWGImportOptions
Various import options applicable to the DWG format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
element
Type: Autodesk.Revit.DB..::.Element %
The linked instance after a successful link. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when linking into 3D view but ThisViewOnly property is set to True in options. Thrown when the file to be linked is not an existing DWG file.

See Also

Document Class

LoadFamily Method

[image] [image]