Revit 2011 API
Document..::.SaveAs Method (String)
Document Class See Also Send Feedback
Saves the document to a given file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
File name to be saved as. Either a relative or absolute path can be provided.

Return Value

False if save operation fails. Also returns False if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, True is returned.

Remarks

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the specified fileName is null or empty in UI-less mode. Thrown if the specified fileName is invalid (for example, a string that contains the invalid characters).
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
SaveAs Overload

SaveAs Method (String, Boolean)

[image]