Revit 2011 API
FilteredElementCollector..::.FirstElement Method
FilteredElementCollector Class Example See Also Send Feedback
Returns the first element to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Element FirstElement()
Visual Basic (Declaration)
Public Function FirstElement As Element
Visual C++
public:
Element^ FirstElement()

Return Value

The first element.

Remarks

This will reset the collector to the beginning and find the first element which passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Examples

CopyC#
public FamilyInstance GetAColumn(Autodesk.Revit.DB.Document document)
{
    // Create a filter to find all columns
    StructuralInstanceUsageFilter columnFilter =
        new StructuralInstanceUsageFilter(StructuralInstanceUsage.Column);

    // Apply the filter to the elements in the active document
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.WherePasses(columnFilter);

    // Get the first column from the filtered results
    // Element will be a FamilyInstance
    FamilyInstance column = collector.FirstElement() as FamilyInstance;

    return column;
}
CopyVB.NET
Public Function GetAColumn(ByVal document As Autodesk.Revit.DB.Document) As Autodesk.Revit.DB.FamilyInstance
    ' Create a filter to find all columns
    Dim columnFilter As New Autodesk.Revit.DB.Structure.StructuralInstanceUsageFilter(Autodesk.Revit.DB.Structure.StructuralInstanceUsage.Column)

    ' Apply the filter to the elements in the active document
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    collector.WherePasses(columnFilter)

    ' Get the first column from the filtered results
    ' Element will be a FamilyInstance
    Dim column As Autodesk.Revit.DB.FamilyInstance = TryCast(collector.FirstElement(), Autodesk.Revit.DB.FamilyInstance)

    Return column
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class

FirstElementId Method

[image]