Revit 2011 API
ElementStructuralTypeFilter Constructor (StructuralType, Boolean)
ElementStructuralTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementStructuralTypeFilter(
    StructuralType structuralType,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralType As StructuralType, _
    inverted As Boolean _
)
Visual C++
public:
ElementStructuralTypeFilter(
    StructuralType structuralType,
    bool inverted
)

Parameters

structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
The structural type to match.
inverted
Type: System..::.Boolean
True if the filter should match all elements which are not of the given structural type.

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Overload

ElementStructuralTypeFilter Methods

[image] [image]