Revit 2011 API
FamilyType..::.AsString Method
FamilyType Class See Also Send Feedback
Provides access to the string contents of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string AsString(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Return Value

The string contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not string type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class

AsValueString Method

[image]