Revit 2011 API
Rebar..::.BaseFinishingTurns Property
Rebar Class See Also Send Feedback
For a spiral, the number of finishing turns at the lower end of the spiral.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int BaseFinishingTurns { get; set; }
Visual Basic (Declaration)
Public Property BaseFinishingTurns As Integer
Visual C++
public:
property int BaseFinishingTurns {
    int get ();
    void set (int value);
}

Remarks

Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The rebar is not an instance of a spiral shape.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: turns must be between 0 and 100.
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

Curves Property

[image]