Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomsInSameRegionSpaces Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsInSameRegionSpaces { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomsInSameRegionSpaces As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegionSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class

RoomsOverlapInHeight Property

[image]