Revit 2011 API
TaskDialog..::.Show Method
TaskDialog Class See Also Send Feedback
Shows the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TaskDialogResult Show()
Visual Basic (Declaration)
Public Function Show As TaskDialogResult
Visual C++
public:
TaskDialogResult Show()

Return Value

The user's response to the task dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the task dialog is shown out of main thread of Revit.

See Also

TaskDialog Class
Show Overload
Autodesk.Revit.UI Namespace

Show Method (String, String)

[image]