Revit 2011 API
IExtension..::.SymbolicExtended Property
IExtension Interface See Also Send Feedback
Retrieves or set the symbolic extension status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
bool SymbolicExtended[
    int index
] { get; set; }
Visual Basic (Declaration)
Property SymbolicExtended ( _
    index As Integer _
) As Boolean
Visual C++
property bool SymbolicExtended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, symbolic extension setting only works when the beam is extended, mitered, and miter locked at the end. Otherwise the setting is invalid

See Also

IExtension Interface

IFailuresPreprocessor Interface

[image]