Revit 2011 API
ElectricalEquipment..::.DistributionSystem Property
ElectricalEquipment Class See Also Send Feedback
get or set the Distribution System for the Electrical Equipment.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DistributionSysType DistributionSystem { get; set; }
Visual Basic (Declaration)
Public Property DistributionSystem As DistributionSysType
Visual C++
public:
property DistributionSysType^ DistributionSystem {
    DistributionSysType^ get ();
    void set (DistributionSysType^ value);
}

Remarks

This property returns a Distribution System which is assigned to the Electrical Equipment. If there are no Distribution System assigned to this Electrical Equipment, this property will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace

ElectricalLoadClassification Class

[image]