Revit 2011 API
XYZ Members
XYZ Class Constructors Methods Properties See Also Send Feedback

The XYZ type exposes the following members.

Constructors

Name | Description
XYZ | Overloaded.

Methods

Name | Description
Add | Adds the specified vector to this vector and returns the result.
AngleOnPlaneTo | Returns the angle between this vector and the specified vector projected to the specified plane.
AngleTo | Returns the angle between this vector and the specified vector.
CrossProduct | The cross product of this vector and the specified vector.
DistanceTo | Returns the distance from this point to the specified point.
Divide | Divides this vector by the specified value and returns the result.
DotProduct | The dot product of this vector and the specified vector.
GetLength | Gets the length of this vector.
IsAlmostEqualTo | Overloaded.
IsUnitLength | The boolean value that indicates whether this vector is of unit length.
IsZeroLength | The boolean value that indicates whether this vector is a zero vector.
Multiply | Multiplies this vector by the specified value and returns the result.
Negate | Negates this vector.
Normalize | Returns a new XYZ whose coordinates are the normalized values from this vector.
Subtract | Subtracts the specified vector from this vector and returns the result.
ToString | Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places. (Overrides Object..::.ToString()()().)
TripleProduct | The triple product of this vector and the two specified vectors.

Operators

Name | Description
Addition | Adds the two specified vectors and returns the result.
Division | Divides the specified vector by the specified value.
Multiply | Overloaded.
Subtraction | Subtracts the two specified vectors and returns the result.
UnaryNegation | Negates the specified vector and returns the result.

Properties

Name | Description
BasisX | The basis of the X axis.
BasisY | The basis of the Y axis.
BasisZ | The basis of the Z axis.
Item | Indexed access to coordinates.
X | Gets the first coordinate.
Y | Gets the second coordinate.
Z | Gets the third coordinate.
Zero | The coordinate origin or zero vector.

See Also

XYZ Class

XYZ Constructor

[image] [image]