Revit 2011 API
SketchPlane..::.IsSuitableForModelElements Property
SketchPlane Class See Also Send Feedback
Identifies if the sketch plane can be assigned to model elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSuitableForModelElements { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSuitableForModelElements As Boolean
Visual C++
public:
property bool IsSuitableForModelElements {
    bool get ();
}

Remarks

Sketch planes with this property set to true are suitable to be used to create model elements. Planes where this property is false will be rejected when used to create model curves, symbolic curves, generic forms, or other sketched elements.

See Also

SketchPlane Class

Parameter Property

[image] [image]