Revit 2011 API
PanelScheduleTemplate Methods
PanelScheduleTemplate Class See Also Send Feedback

The PanelScheduleTemplate type exposes the following members.

Methods

Name | Description
CopyFrom | Copies all values from other element to this object.
Create | Creates a new instance of a panel schedule template.
GetPanelScheduleType | Returns the panel schedule type.
GetSectionData | ONLY call this function when you WILL change the section data object
GetTableData | ONLY call this function when you WILL change the table data object
HasSameType | Checks if given template has the same panel schedule type with this template.
IsValidPanelConfiguration | Checks if given panel configuration is valid for given panel schedule type.
IsValidType | Overloaded.
SetTableData | Assigns table data to this template

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace

CopyFrom Method

[image]