Revit 2011 API
CompoundStructureLayerArray Members
CompoundStructureLayerArray Class Constructors Methods Properties See Also Send Feedback

The CompoundStructureLayerArray type exposes the following members.

Constructors

Name | Description
CompoundStructureLayerArray | Initializes a new instance of the CompoundStructureLayerArray class

Methods

Name | Description
Append | Add the layer to the end of the array.
Clear | Removes every layer from the array, rendering it empty.
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
Insert | Insert the specified layer into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
Item | Gets or sets a layer at a specified index within the array.
Size | Returns the number of layers that are in the array.

See Also

CompoundStructureLayerArray Class

CompoundStructureLayerArray Constructor

[image]