Revit 2011 API
RevitUIFamilyLoadOptions..::.OnFamilyFound Method
RevitUIFamilyLoadOptions Class See Also Send Feedback
Implements the interface method by using the Revit dialog box to handle this situation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool OnFamilyFound(
    bool familyInUse,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Public Overridable Function OnFamilyFound ( _
    familyInUse As Boolean, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
public:
virtual bool OnFamilyFound(
    bool familyInUse,
    bool% overwriteParameterValues
)

Parameters

familyInUse
Type: System..::.Boolean
overwriteParameterValues
Type: System..::.Boolean %

Implements

IFamilyLoadOptions..::.OnFamilyFound(Boolean, Boolean%)

Remarks

A Revit dialog box will be shown with the question about the conflict between families. The user may choose the response. If the response is to cancel the load of the family, an exception will be thrown from LoadFamily

See Also

RevitUIFamilyLoadOptions Class

OnSharedFamilyFound Method

[image]