Revit 2011 API
CurtainSystem..::.CurtainSystemType Property
CurtainSystem Class See Also Send Feedback
get or set the type of the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainSystemType CurtainSystemType { get; set; }
Visual Basic (Declaration)
Public Property CurtainSystemType As CurtainSystemType
Visual C++
public:
property CurtainSystemType^ CurtainSystemType {
    CurtainSystemType^ get ();
    void set (CurtainSystemType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified parameter curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the type of the CurtainSystem cannot be changed to the specified one.

See Also

CurtainSystem Class

Parameter Property

[image] [image]