Revit 2011 API
Document..::.NewAreaBoundaryLine Method
Document Class See Also Send Feedback
Creates a new boundary line as an Area border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurve NewAreaBoundaryLine(
    SketchPlane sketchPlane,
    Curve geometryCurve,
    ViewPlan areaView
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryLine ( _
    sketchPlane As SketchPlane, _
    geometryCurve As Curve, _
    areaView As ViewPlan _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewAreaBoundaryLine(
    SketchPlane^ sketchPlane,
    Curve^ geometryCurve,
    ViewPlan^ areaView
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane.
geometryCurve
Type: Autodesk.Revit.DB..::.Curve
The geometry curve on which the boundary line are
areaView
Type: Autodesk.Revit.DB..::.ViewPlan
The View for the new Area

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewAreaLoad Method

[image] [image]