Revit 2011 API
DefinitionFile..::.Groups Property
DefinitionFile Class See Also Send Feedback
Return a map of shared parameter definition groups contained within the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionGroups Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As DefinitionGroups
Visual C++
public:
property DefinitionGroups^ Groups {
    DefinitionGroups^ get ();
}

Remarks

A particular group can be found by Name, using the Item property on the DefinitionGroups object. A new group can be created by using the Create method on the DefinitionGroups Object. The Create method takes the name of the new group, as a string, as its input parameter, returning a reference to a new definition group object as its result.

See Also

DefinitionFile Class

DefinitionGroup Class

[image]