Revit 2011 API
Application..::.VersionNumber Property
Application Class See Also Send Feedback
Return the primary version of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string VersionNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As String
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

Application Events

[image] [image]