Revit 2011 API
Connector..::.AssignedDuctLossMethod Property
Connector Class See Also Send Feedback
The duct loss method of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctLossMethodType AssignedDuctLossMethod { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedDuctLossMethod As DuctLossMethodType
Visual C++
public:
property DuctLossMethodType AssignedDuctLossMethod {
    DuctLossMethodType get ();
}

Remarks

Assigned duct loss method may be assigned for connectors of some family instances, for more information, refer to DuctConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in family instance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get duct loss method.

See Also

Connector Class

AssignedFixtureUnits Property

[image]