Revit 2011 API
ModelCurve Members
ModelCurve Class Methods Properties See Also Send Feedback

The ModelCurve type exposes the following members.

Methods

Name | Description
ChangeToReferenceLine | Changes this curve to reference curve.
GetVisibility | Gets the visibility for the model curve in a family document.
SetVisibility | Sets the visibility for the model curve in a family document.

Properties

Name | Description
IsReferenceLine | Indicates if this curve is a reference curve.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Subcategory | The subcategory.
TrussCurveType | The truss curve type of this model curve.

See Also

ModelCurve Class

ModelCurve Methods

[image] [image]