Revit 2011 API
RevitUIFamilyLoadOptions..::.OnSharedFamilyFound Method
RevitUIFamilyLoadOptions Class See Also Send Feedback
Implements the interface method by using the Revit dialog box to handle this situation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool OnSharedFamilyFound(
    Family sharedFamily,
    bool familyInUse,
    ref FamilySource source,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Public Overridable Function OnSharedFamilyFound ( _
    sharedFamily As Family, _
    familyInUse As Boolean, _
    ByRef source As FamilySource, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
public:
virtual bool OnSharedFamilyFound(
    Family^ sharedFamily,
    bool familyInUse,
    FamilySource% source,
    bool% overwriteParameterValues
)

Parameters

sharedFamily
Type: Autodesk.Revit.DB..::.Family
familyInUse
Type: System..::.Boolean
source
Type: Autodesk.Revit.DB..::.FamilySource %
overwriteParameterValues
Type: System..::.Boolean %

Implements

IFamilyLoadOptions..::.OnSharedFamilyFound(Family, Boolean, FamilySource%, Boolean%)

Remarks

A Revit dialog box will be shown with the question about the conflict between shared families versions in target document and current family. The user may choose the response. If the response is to cancel the load of the family, an exception will be thrown from LoadFamily

See Also

RevitUIFamilyLoadOptions Class

Revolution Class

[image]