Revit 2011 API
Document..::.SaveAs Method (String, Boolean)
Document Class See Also Send Feedback
Saves the document to a given file name with the option to change the document's name in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName,
    bool changeDocumentFilename
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    changeDocumentFilename As Boolean _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName,
    bool changeDocumentFilename
)

Parameters

fileName
Type: System..::.String
File name and path to be saved as. Either a relative or absolute path can be provided.
changeDocumentFilename
Type: System..::.Boolean
Indicates if the current file name on the title bar of Revit will be changed accordingly.

Return Value

False if save operation fails. Also returns False if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, True is returned.

Remarks

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.Event handlers are not allowed to save document that are currently in modifiable state.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the specified fileName is null or empty in UI-less mode. Thrown if the specified fileName is invalid (for example, a string that contains the invalid characters).
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
SaveAs Overload

SaveToProjectAsImage Method

[image]