Revit 2011 API
PipeConnector Class
Members See Also Send Feedback
A pipe connector that is assigned to a mechanical equipment or pipe fitting family. Provides access to the pipe connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PipeConnector : ConnectorElement,
    IConnector
Visual Basic (Declaration)
Public Class PipeConnector _
    Inherits ConnectorElement _
    Implements IConnector
Visual C++
public ref class PipeConnector : public ConnectorElement,
    IConnector

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Pipe connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ConnectorElement
Autodesk.Revit.DB.Plumbing..::.PipeConnector

See Also

PipeConnector Members
Autodesk.Revit.DB.Plumbing Namespace

PipeConnector Members

[image] [image]