Revit 2011 API
PanelScheduleData..::.UpdateCircuitTableForTemplate Method
PanelScheduleData Class See Also Send Feedback
redraw the circuit table for a template with the given parameter updates

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void UpdateCircuitTableForTemplate(
    PanelSchedulePhaseLoadType newType,
    int nNumSlots
)
Visual Basic (Declaration)
Public Sub UpdateCircuitTableForTemplate ( _
    newType As PanelSchedulePhaseLoadType, _
    nNumSlots As Integer _
)
Visual C++
public:
void UpdateCircuitTableForTemplate(
    PanelSchedulePhaseLoadType newType,
    int nNumSlots
)

Parameters

newType
Type: Autodesk.Revit.DB.Electrical..::.PanelSchedulePhaseLoadType
the new phase load type of the circuit table
nNumSlots
Type: System..::.Int32
the number of circuit slots

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace

UpdateIsSectionHidden Method

[image]