Revit 2011 API
Floor..::.SlabShapeEditor Property
Floor Class See Also Send Feedback
Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeEditor SlabShapeEditor { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Only flat and horizontal floor is valid for slab shape edit.Otherwise, ShapeEditor will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Floor Class

SpanDirectionAngle Property

[image]