Revit 2011 API
CurtainGridLine Properties
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Properties

Name | Description
AllSegmentCurves | Retrieve the curves of all segments.
ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
FullCurve | Retrieve the geometry curve of the curtain grid line.
IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Lock | Retrieve or change the lock state of the curtain grid line.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.

See Also

CurtainGridLine Class

AllSegmentCurves Property

[image]