Revit 2011 API
SolidSolidCutUtils Methods
SolidSolidCutUtils Class See Also Send Feedback

The SolidSolidCutUtils type exposes the following members.

Methods

Name | Description
AddCutBetweenSolids | Add the solid-solid cut for the two elements
CanElementCutElement | Verifies if the cutting element can add a solid cut to the cut element.
Dispose |
GetCuttingSolids | Get all the solids which cut the input element
GetSolidsBeingCut | Get all the solids which are cut by the input element
IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
IsElementFromAppropriateContext | Validates that the element is in an appropriate document.
RemoveCutBetweenSolids | Remove the solid-solid cut for the two elements (uncut)

See Also

SolidSolidCutUtils Class

AddCutBetweenSolids Method

[image]