Revit 2011 API
EnergyDataSettings Properties
EnergyDataSettings Class See Also Send Feedback

The EnergyDataSettings type exposes the following members.

Properties

Name | Description
BuildingConstructionClass | Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.
BuildingHVACSystem | The type of HVAC system used by the building for conceptual model energy calculations.
BuildingOperatingSchedule | The operating schedule of the building used for conceptual model energy calculations.
BuildingType | The type of building.
CreateAnalyticalModel | If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
ExportCategory | Value is a category indicating which discipline model will be used for GreenBuildingXML export.
ExportComplexity | Value determines Export Complexity for GreenBuildingXML detailed model export.
ExportDefaults | Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.
GroundPlane | Id of level which represents ground level.
IsExportMullionsEnabled | Indicates if mullions are included in GreenBuildingXML export of the detailed model.
IsExportShadingSurfacesEnabled | Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
IsExportSimplifiedCurtainSystemsEnabled | Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
IsGlazingShaded | If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.
MassZoneCoreOffset | It defines the default behavior for the automatic generation of Mass Zones for each Mass Floor in the Project. Specifying a value here will offset the outside perimeter of a Mass Zone to create the core.
MassZoneDividePerimeter | If this is true, outward facing zones on each floor of the building will be divided based on the four compass directions.
OutsideAirChangesRatePerHour |
OutsideAirPerArea |
OutsideAirPerPerson |
PercentageGlazing | Used for the conceptual energy model. The approximate percentage of the the building exterior wall surfaces which are covered by windows or other glazing.
PercentageSkylights | Used for the conceptual energy model. The approximate percentage of the the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.
ProjectPhase | The project phase of the EnergyData information.
ProjectReportType | Report type: None, simple, standard, detailed
ServiceType | The type of heating or cooling system.
ShadeDepth | Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.
SillHeight | Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.
SkylightWidth | Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.
SliverSpaceTolerance | Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.
UseAirChangesPerHour | True if user is specifying air changes per hour, false otherwise.
UseHeatingCredits | If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.
UseOutsideAirPerArea | True is user is specifying outside air per area, false otherwise.
UseOutsideAirPerPerson | True if user is specifying outside air per person, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace

BuildingConstructionClass Property

[image]