Revit 2011 API
MassSurfaceData..::.SurfaceDataSource Property
MassSurfaceData Class See Also Send Feedback
Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassSurfaceDataSource SurfaceDataSource { get; set; }
Visual Basic (Declaration)
Public Property SurfaceDataSource As MassSurfaceDataSource
Visual C++
public:
property MassSurfaceDataSource SurfaceDataSource {
    MassSurfaceDataSource get ();
    void set (MassSurfaceDataSource value);
}

Remarks

The Construction property is not governed by this setting and has a separate value to indicate if it is to be synchronized with EnergyDataSettings.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace

MassSurfaceDataMaterialType Enumeration

[image]