Revit 2011 API
Application..::.DocumentSynchronizingWithCentral Event
Application Class See Also Send Feedback
Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to synchronize a document with central file.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central file is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

FailuresProcessing Event

[image]