Revit 2011 API
HostedSweep..::.ReferenceCurve Property
HostedSweep Class See Also Send Feedback
The curve on which the hosted sweep segment is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve ReferenceCurve[
    Reference targetRef
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReferenceCurve ( _
    targetRef As Reference _
) As Curve
Visual C++
public:
property Curve^ ReferenceCurve[Reference^ targetRef] {
    Curve^ get (Reference^ targetRef);
}

Parameters

targetRef
Type: Autodesk.Revit.DB..::.Reference
Reference of the curve that hosts the object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class

VerticalFlipped Property

[image]