Revit 2011 API
Transaction..::.HasEnded Method
Transaction Class See Also Send Feedback
Determines whether the transaction has ended already

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasEnded()
Visual Basic (Declaration)
Public Function HasEnded As Boolean
Visual C++
public:
bool HasEnded()

Remarks

A transaction is ended by completing either the Commit or RollBack method. Another way of testing whether a transaction has ended is by testing the current status (see GetStatus()()()). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'

See Also

Transaction Class

HasStarted Method

[image]