Revit 2011 API
RebarShapeDefinitionBySegments..::.SetSegmentVariableDirection Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Remove the fixed direction from a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetSegmentVariableDirection(
    int iSegment
)
Visual Basic (Declaration)
Public Sub SetSegmentVariableDirection ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentVariableDirection(
    int iSegment
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).

Remarks

The segment's angle will be allowed to vary, with a range of 90 degrees. The line must have at least two constraints.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeDefinitionBySegments Properties

[image] [image]