Revit 2011 API
UpdaterRegistry Members
UpdaterRegistry Class Methods See Also Send Feedback

The UpdaterRegistry type exposes the following members.

Methods

Name | Description
AddTrigger | Overloaded.
Dispose |
IsUpdaterRegistered | Checks whether an updater with the given id is registered
RegisterUpdater | Overloaded.
RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
UnregisterUpdater | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

See Also

UpdaterRegistry Class

UpdaterRegistry Methods

[image] [image]