Revit 2011 API
RebarShapeDefinitionByArc..::.AddConstraintArcLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the arc length of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintArcLength(
    Parameter param
)
Visual Basic (Declaration)
Public Sub AddConstraintArcLength ( _
    param As Parameter _
)
Visual C++
public:
void AddConstraintArcLength(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace

AddConstraintChordLength Method

[image]