Revit 2011 API
RebarShapeDefinitionBySegments Class
Members See Also Send Feedback
Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarShapeDefinitionBySegments : RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinitionBySegments _
    Inherits RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinitionBySegments : public RebarShapeDefinition

Remarks

The segments are numbered starting with 0, and they have a direction; so the beginning of the shape is end 0 of segment 0, and the end of the shape is end 1 of segment (n-1). Each segment must have enough constraints to determine its position. Overconstraining is allowed. The most common combinations are: (1) A fixed direction together with a parallel length constraint; (2) A parallel length constraint plus another length constraint parallel to the x-axis or y-axis; (3) A parallel length constraint plus length constraints parallel to both the x-axis and y-axis. Multiple constraints may be driven by the same parameter, even on the same segment. Length constraints may be measured in two ways. For "measured to the outside of the bend," the reference is a tangent to the exterior face of the bar; the thickness of the bar is included. For "measured to the inside," the reference is the center of the arc of the bend; this is the point where the bend begins, if the constraint is parallel to the segment. A bend may have the default radius of the bar type referenced by the Rebar element, or it may have a radius defined by a parameter. A 180-degree bend is described by introducing an extra segment in between the two straight segments, tangent to the midpoint of the bend.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarShapeDefinition
Autodesk.Revit.DB.Structure..::.RebarShapeDefinitionBySegments

See Also

RebarShapeDefinitionBySegments Members
Autodesk.Revit.DB.Structure Namespace

RebarShapeDefinitionBySegments Members

[image] [image]