Revit 2011 API
EnclosureTag..::.Name Property
EnclosureTag Class See Also Send Feedback
The name associated with the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This overrides Element.Name to allow the API to prevent modifications to the tag's name (because this is not permitted to be modified in the Autodesk Revit UI).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to set this property, as the name of the tag may not be changed.

See Also

EnclosureTag Class

Parameter Property

[image] [image]