Revit 2011 API
BoundarySegment Class
Members See Also Send Feedback
An object that represents a segment of an area boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic (Declaration)
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the exterior boundary of an area. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.BoundarySegment

See Also

BoundarySegment Members

BoundarySegment Members

[image] [image]