Revit 2011 API
LayoutRuleClearSpacing..::.Spacing Property
LayoutRuleClearSpacing Class See Also Send Feedback
Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Spacing { get; set; }
Visual Basic (Declaration)
Public Property Spacing As Double
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class

LayoutRuleFixedDistance Class

[image]