Revit 2011 API
Selection..::.WindowSelect Method
Selection Class See Also Send Feedback
Allows the user to select elements by a rectangle.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is deprecated and will be excluded in future release. Use PickElementsByRectangle instead.")]
public bool WindowSelect()
Visual Basic (Declaration)
<ObsoleteAttribute("This method is deprecated and will be excluded in future release. Use PickElementsByRectangle instead.")> _
Public Function WindowSelect As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated and will be excluded in future release. Use PickElementsByRectangle instead.")]
public:
bool WindowSelect()

Return Value

True if the user selected one or more elements, false if the user selected elsewhere in the UI

Remarks

Note that the Revit user will not be allowed to select items in the Revit user interface except for Revit elements. This restriction also prevents users from closing the active document or the Revit application.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user tried to close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace

Selection Properties

[image] [image]