Revit 2011 API
Selection Methods
Selection Class See Also Send Feedback

The Selection type exposes the following members.

Methods

Name | Description
PickElementsByRectangle | Overloaded. Prompts the user to select multiple elements by drawing a rectangle.
PickObject | Overloaded. Prompts the user to select one object.
PickObjects | Overloaded. Prompts the user to select multiple objects.
PickOne | Obsolete. Allows the user to select one element.
PickPoint | Overloaded. Prompts the user to pick a point on the active work plane.
WindowSelect | Obsolete. Allows the user to select elements by a rectangle.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace

PickElementsByRectangle Method

[image] [image]