Revit 2011 API
Document..::.NewBeamSystem Method (CurveArray, XYZ)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves and direction.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    direction As XYZ _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    XYZ^ direction
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
The profile is the profile of the BeamSystem.
direction
Type: Autodesk.Revit.DB..::.XYZ
The direction is the direction of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace

NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)

[image]