Revit 2011 API
Domain Enumeration
See Also Send Feedback
An enumerated type listing all the possible domain types that can be assigned to a connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum Domain
Visual Basic (Declaration)
Public Enumeration Domain
Visual C++
public enum class Domain

Members

Member name | Description
DomainUndefined | Domain is Undefined.
DomainHvac | Domain is Hvac.
DomainElectrical | Domain is Electrical.
DomainPiping | Domain is Piping.
DomainCableTrayConduit | Domain is cable tray/conduit.

See Also

DoubleArray Class

[image]