Revit 2011 API
Reference Members
Reference Class Constructors Methods Properties See Also Send Feedback

The Reference type exposes the following members.

Constructors

Name | Description
Reference | Creates a Reference with the supplied element.

Methods

Name | Description

Properties

Name | Description
Element | The element for this reference.
ElementReferenceType | The type of reference referred to.
GeometryObject | The geometry item referred to by this reference.
GlobalPoint | The position on which the reference is hit.
ProximityParameter | The proximity value to the ray's origin when the reference is returned by FindReferencesByDirection(XYZ, XYZ, View3D).
Transform | The transformation of the geometry item into the coordinates of the document.
UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class

Reference Constructor

[image]