Revit 2011 API
Element..::.GetChangeTypeElementAddition Method
Element Class See Also Send Feedback
Returns ChangeType associated with element addition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeElementAddition()
Visual Basic (Declaration)
Public Shared Function GetChangeTypeElementAddition As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeElementAddition()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on element addition.

Remarks

Use this change type to trigger an Updater on the addition of elements to a document. Note: This change type will not trigger on changes caused by Undo and Redo.

See Also

Element Class

GetChangeTypeElementDeletion Method

[image]