Revit 2011 API
ElementBinding..::.Categories Property
ElementBinding Class See Also Send Feedback
Retrieve or set the categories to which a parameter definition will be bound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CategorySet Categories { get; set; }
Visual Basic (Declaration)
Public Property Categories As CategorySet
Visual C++
public:
property CategorySet^ Categories {
    CategorySet^ get ();
    void set (CategorySet^ value);
}

Remarks

The Categories property is used to set the categories to which the definition will be bound when it is added to the document bindings. This property can also be read from existing bindings to interrogate to which categories a parameter has been bound.

See Also

ElementBinding Class

ElementCategoryFilter Class

[image]