Revit 2011 API
RebarShape..::.HookAngle Property
RebarShape Class See Also Send Feedback
Get and set the hook angle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int HookAngle[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Property HookAngle ( _
    index As Integer _
) As Integer
Visual C++
public:
property int HookAngle[int index] {
    int get (int index);
    void set (int index, int value);
}

Parameters

index
Type: System..::.Int32
0 for the starting hook, 1 for the ending hook.

Remarks

The hook angle is expressed as an integral number of degrees (common values are 0, 90, 135, and 180).

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

HookOrientation Property

[image]