Revit 2011 API
AnalyticalModel..::.CanDisableAutoDetect Method
AnalyticalModel Class See Also Send Feedback
Indicates whether or not Analytical Auto-detect can be disabled programmatically

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanDisableAutoDetect(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function CanDisableAutoDetect ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool CanDisableAutoDetect(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
direction in which to test whether Analytical Auto-detect can be disabled

Return Value

true if Analytical Auto-detect can be disabled, false otherwise

Remarks

This exists because certain Elements can have Auto-detect enabled (e.g., a Structural Wall), but the disabling of Auto-detect is undefined. This is because Auto-detect is actually a setting in the Analytical Projection parameter, and changing this value from Auto-detect is not well defined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for Analytical Auto-detect.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

CanHaveRigidLinks Method

[image]