Revit 2011 API
MaterialSteel..::.ShearModulusX Property
MaterialSteel Class See Also Send Feedback
Get or set the x component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusX { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class

ShearModulusY Property

[image]