Revit 2011 API
Document..::.NewRebarShape Method
Document Class See Also Send Feedback
Creates a new instance of a Rebar Shape, which defines the shape of the rebar.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShape NewRebarShape()
Visual Basic (Declaration)
Public Function NewRebarShape As RebarShape
Visual C++
public:
RebarShape^ NewRebarShape()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewRoom Method

[image] [image]