Revit 2011 API
RibbonItemData..::.Name Property
RibbonItemData Class See Also Send Feedback
The name of the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace

ToolTip Property

[image]