Revit 2011 API
PrintManager..::.PrintSetup Property
PrintManager Class See Also Send Feedback
The PrintSetup which manages the print settings of current document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PrintSetup PrintSetup { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintSetup As PrintSetup
Visual C++
public:
property PrintSetup^ PrintSetup {
    PrintSetup^ get ();
}

Remarks

PrintSetup is an interface cluster just like File->Print->Settings->Setup or File->Print Setup in UI.

See Also

PrintManager Class

PrintToFile Property

[image]