Revit 2011 API
Material Members
Material Class Methods Properties See Also Send Feedback

The Material type exposes the following members.

Methods

Name | Description
Duplicate | Duplicates the material.

Properties

Name | Description
Color | The color of the material.
CutPattern | The cut pattern of the material.
CutPatternColor | The cut pattern color of the material.
Glow | Whether the material can glow.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
RenderAppearance | The rendering appearance property of the material.
Shininess | The shininess of the material.
Smoothness | The smoothness of the material.
SurfacePattern | The surface pattern of the material.
SurfacePatternColor | The surface pattern color of the material.
Transparency | The transparency of the material.

See Also

Material Class

Material Methods

[image] [image]