Revit 2011 API
UIControlledApplication..::.LoadedApplications Property
UIControlledApplication Class See Also Send Feedback
Returns an array of successfully loaded external applications.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ExternalApplicationArray LoadedApplications { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property LoadedApplications As ExternalApplicationArray
Visual C++
public:
virtual property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

Remarks

This property can be used by your application to find all successfully loaded external applications when Revit starts.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace

UIControlledApplication Events

[image] [image]