Revit 2011 API
Extrusion..::.EndOffset Property
Extrusion Class See Also Send Feedback
The offset of the end of the extrusion relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double EndOffset { get; set; }
Visual Basic (Declaration)
Public Property EndOffset As Double
Visual C++
public:
property double EndOffset {
    double get ();
    void set (double value);
}

Remarks

The direction of the offset is based on the normal of the extrusion's sketch plane: a positive value is in the direction of the normal, a negative value is in the other direction.

See Also

Extrusion Class

Parameter Property

[image] [image]