Revit 2011 API
FamilyInstance..::.Room Property
FamilyInstance Class See Also Send Feedback
The room in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room Room { get; }
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

This property will be the first room encountered that contains the instance. If more than one room includes this point in its volume only the first one is returned. If no room is found that contains the instance, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyInstance Class
Room Overload

Room Property (Phase)

[image]