Revit 2011 API
DocumentEntryPoint Members
DocumentEntryPoint Class Constructors Methods Properties See Also Send Feedback

The DocumentEntryPoint type exposes the following members.

Constructors

Name | Description
DocumentEntryPoint | Initializes a new instance of the DocumentEntryPoint class

Methods

Name | Description
FinishInitializationEO | For Revit VSTA internal use only.
Initialize | For Revit VSTA internal use only.
OnShutdownEO | For Revit VSTA internal use only.
PromptForFamilyInstancePlacement | Prompts the user to place instances of the specified FamilySymbol.
RefreshActiveView | Refresh the display of the active view in the active document.
ShowElements | Overloaded. Shows one or more elements by zoom to fit.

Properties

Name | Description
AddinFolder | The full path to the Revit VSTA module.
Application | Retrieves an object that represents the current Application.
Document | Returns the database level document represented by this UI-level document.
Selection | Retrieve the currently selected Elements in Autodesk Revit.

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace

DocumentEntryPoint Constructor

[image]