Revit 2011 API
Room..::.Boundary Property
Room Class See Also Send Feedback
Returns the boundary of the room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the room. Each room may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Room.BoundarySegment object for more details about the segments that make up the room topology.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace

ClosedShell Property

[image]