Revit 2011 API
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

Name | Description
AsDouble | Provides access to the double precision number within the parameter.
AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
AsInteger | Provides access to the integer number within the parameter.
AsString | Provides access to the string contents of the parameter.
AsValueString | Get the parameter value as a string with unit.
Set | Overloaded. Sets the parameter to a new value.
SetValueString | Set the parameter value according to the input string.

See Also

Parameter Class

AsDouble Method

[image]