Revit 2011 API
Transaction..::.Start Method
Transaction Class See Also Send Feedback
Starts the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus Start()
Visual Basic (Declaration)
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Remarks

A transaction may be started only after if was instantiated or after it was successfully committed or rolled back. In order to start a transaction, it must have a name assigned. If the name was not specified when the transaction object was instantiated, it has to be set by calling the SetName(String) method. Be aware that every time a transaction starts, FailureHandlingOptions will be reset to their default values. If a specific failure handling is required, programmers need to use SetFailureHandlingOptions(FailureHandlingOptions) prior committing or rolling back the transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished. -or- The transaction started already and has not been completed yet. -or- Starting a new transaction is not permitted. It is either because another transaction started already and has not been completed yet, or if the document is in a state in which it cannot start a new transaction (e.g. during failure handling). -or- The transaction does not have a valid name assigned yet

See Also

Transaction Class
Start Overload

Start Method (String)

[image]