Revit 2011 API
MaterialWood..::.YoungModulus Property
MaterialWood Class See Also Send Feedback
Get or set the Young modulus of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulus { get; set; }
Visual Basic (Declaration)
Public Property YoungModulus As Double
Visual C++
public:
property double YoungModulus {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the Young modulus to an invalid value.

See Also

MaterialWood Class

MEPCurve Class

[image]