Revit 2011 API
PrintParameters..::.PaperSize Property
PrintParameters Class See Also Send Feedback
The page size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PaperSize PaperSize { get; set; }
Visual Basic (Declaration)
Public Property PaperSize As PaperSize
Visual C++
public:
property PaperSize^ PaperSize {
    PaperSize^ get ();
    void set (PaperSize^ value);
}

Remarks

User can select the candidate via PaperSizes and then set the Page source of the Print Setting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument is invalid for current printer.

See Also

PrintParameters Class

PaperSource Property

[image]