Revit 2011 API
BuiltInFailures..::.JoinElementsFailures Properties
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback

The BuiltInFailures..::.JoinElementsFailures type exposes the following members.

Properties

Name | Description
CannotCope | Can't apply Coping.
CannotCutJoinedGeometry | Element could not be cut by joined element.
CannotJoinDesignOptions | An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
CannotJoinElements | Can't keep elements joined.
CannotJoinElementsError | Can't keep elements joined.
CannotJoinElementsStructural | Can't keep elements joined.
CannotJoinElementsStructuralError | Can't keep elements joined.
CannotJoinElementsWarn | Can't keep elements joined.
CannotJoinRoof | The roof cannot be joined.
CannotJoinRoofError | The roof cannot be joined.
CannotKeepJoined | Can't keep elements joined.
CannotKeepTrussJoined | Can't keep the highlighted [Element]s joined.
CannotKeepWallJoinToRoof | Can't keep wall and [target] joined
CannotKeepWallJoinToRoofError | Can't keep wall and [target] joined
ElementWillBeDetachedFromPlane | Element will be detached from its associated plane
FootingWillMoveToBottom | An attached Structural Foundation will be moved to the bottom of the Column.
JoiningDisjoint | Highlighted elements are joined but do not intersect.
JoiningDisjointWarn | Highlighted elements are joined but do not intersect.
StructGroupMemberWillDetachFromGrid | A structural element will be detached from grid(s) due to inconsistent group membership.

See Also

BuiltInFailures..::.JoinElementsFailures Class

CannotCope Property

[image]