Revit 2011 API
AnalysisDisplayStyle..::.FindByName Method
AnalysisDisplayStyle Class See Also Send Feedback
Finds analysis display style by name.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ElementId FindByName(
    Document cda,
    string name
)
Visual Basic (Declaration)
Public Shared Function FindByName ( _
    cda As Document, _
    name As String _
) As ElementId
Visual C++
public:
static ElementId^ FindByName(
    Document^ cda,
    String^ name
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
Document in which to look for analysis display style element.
name
Type: System..::.String
Name of analysis display style to look for.

Return Value

Element id of the found analysis display style, invalidElementId if not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace

GetColoredSurfaceSettings Method

[image]