Revit 2011 API
BuiltInFailures..::.RebarShapeFailures..::.ShapeFailure Property
BuiltInFailures..::.RebarShapeFailures Class See Also Send Feedback
The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ShapeFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShapeFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ShapeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarShapeFailures Class

BuiltInFailures.RebarSystemFailures Class

[image]