Revit 2011 API
ElectricalSystem..::.Length Property
ElectricalSystem Class See Also Send Feedback
Returns the Length value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

This property is used to retrieve the Length value of the Electrical System.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the length cannot be computed, because it is zero, or because the circuit is not connected to a panel.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace

LoadClassifications Property

[image]