Revit 2011 API
StructuralSettings..::.AnalyticalModelCheckCircularReferences Property
StructuralSettings Class See Also Send Feedback
Whether to check member supports for circular references.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckCircularReferences { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelCheckCircularReferences As Boolean
Visual C++
public:
property bool AnalyticalModelCheckCircularReferences {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelCheckDiscrepancy Property

[image]