Revit 2011 API
RebarShape..::.NewDefinitionByArc Method
RebarShape Class See Also Send Feedback
Create a shape definition by arc, and associate it with this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeDefinitionByArc NewDefinitionByArc()
Visual Basic (Declaration)
Public Function NewDefinitionByArc As RebarShapeDefinitionByArc
Visual C++
public:
RebarShapeDefinitionByArc^ NewDefinitionByArc()

Remarks

The returned value of this function and the returned value from Definition::get() are references to the same object.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

NewDefinitionBySegments Method

[image]