Revit 2011 API
PipeType Members
PipeType Class Methods Properties See Also Send Feedback

The PipeType type exposes the following members.

Methods

Name | Description

Properties

Name | Description
Class | The schedule type of the pipe type.
ConnectionType | The connection type of the pipe type.
Material | The material type of the pipe type.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Roughness | The roughness of the pipe type. (Overrides MEPCurveType..::.Roughness.)

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace

PipeType Methods

[image] [image]