Revit 2011 API
StructuralMaterialType Enumeration
See Also Send Feedback
Represents the structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum StructuralMaterialType
Visual Basic (Declaration)
Public Enumeration StructuralMaterialType
Visual C++
public enum class StructuralMaterialType

Members

Member name | Description
Undefined | Structural material type is undefined.
Steel | Structural material type is steel.
Concrete | Structural material type is concrete.
Wood | Structural material type is wood.
Other | Structural material type is other.
PrecastConcrete | Structural material type is precast concrete.

See Also

Autodesk.Revit.DB.Structure Namespace

StructuralMaterialTypeFilter Class

[image]