Revit 2011 API
RebarShapeDefinitionBySegments..::.AddBendVariableRadius Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a variable-radius bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddBendVariableRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle,
    Parameter radiusParam,
    bool measureIncludingBarThickness
)
Visual Basic (Declaration)
Public Sub AddBendVariableRadius ( _
    iSegmentFollowingBend As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle, _
    radiusParam As Parameter, _
    measureIncludingBarThickness As Boolean _
)
Visual C++
public:
void AddBendVariableRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle,
    Parameter^ radiusParam,
    bool measureIncludingBarThickness
)

Parameters

iSegmentFollowingBend
Type: System..::.Int32
Index of the segment after the bend (1 to NumberOfSegments - 1).
turn
Type: System..::.Int32
Specify 1 for a left turn, -1 for a right turn.
angle
Type: Autodesk.Revit.DB.Structure..::.RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.
radiusParam
Type: Autodesk.Revit.DB..::.Parameter
A parameter defining the radius. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
measureIncludingBarThickness
Type: System..::.Boolean
If false, the radius is measured to the inside of the bend; if false, it is measured to the outside.

Remarks

You must add a bend between each two segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

AddConstraintParallelToSegment Method

[image]