Revit 2011 API
MaterialGeneric..::.ThermalExpansionCoefficientY Property
MaterialGeneric Class See Also Send Feedback
Get or set the y component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientY { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class

ThermalExpansionCoefficientZ Property

[image]