Revit 2011 API
AnalysisDisplayMarkersAndTextSettings..::.SetTextTypeId Method
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Set element id of text associated with settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetTextTypeId(
    ElementId textTypeId,
    Document doc
)
Visual Basic (Declaration)
Public Sub SetTextTypeId ( _
    textTypeId As ElementId, _
    doc As Document _
)
Visual C++
public:
void SetTextTypeId(
    ElementId^ textTypeId,
    Document^ doc
)

Parameters

textTypeId
Type: Autodesk.Revit.DB..::.ElementId
Element id of text to be associated with settings.
doc
Type: Autodesk.Revit.DB..::.Document
Document for which %textTypeId" is validated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | text type id textTypeId is invalid - it refers to either non-existent element or element of wrong type.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayMarkersAndTextSettings Properties

[image] [image]