Revit 2011 API
AnalyticalModel Members
AnalyticalModel Class Methods Properties See Also Send Feedback

The AnalyticalModel type exposes the following members.

Methods

Name | Description
Approximate | Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models
CanApproximate | Indicates whether Analytical Model can be approximated or not.
CanDisable | Reports whether the user can enable or disable the Analytical Model programmatically.
CanDisableAutoDetect | Indicates whether or not Analytical Auto-detect can be disabled programmatically
CanHaveRigidLinks | Indicates whether Analytical Model supports Rigid Links.
CanSetAnalyticalOffset | Determines whether the Analytical Model Offset can be changed.
CanUseHardPoints | Indicates whether Analytical Model can use Hard Points.
Dispose |
Enable | Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle.
EnableAutoDetect | Enable or disable Analytical Auto-detect.
GetAnalyticalModelSketchComponents | Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level.
GetAnalyticalModelSupports | Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements.
GetAnalyticalOffset | Retrieves Analytical Offset in the case where the user can do that.
GetAnalyticalProjectionDatumPlane | Retrieves analytical model projection information for a specific direction.
GetAnalyticalProjectionType | This retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.
GetAnalyzeAs | Returns value of Analyze As parameter for Analytical Model.
GetApproximationDeviation | Retrieves amount by which approximation is made.
GetAutoDetectMatchedElements | Retrieves other Element Ids that this Element is Auto-detecting against.
GetCurve | This returns the single curve of the Analytical Model, if it is only one curve.
GetCurves | Retrieves all curves for the Analytical Model of a given type.
GetElementId | Retrieves Element Id of the Analytical Model.
GetManualAdjustmentMatchedElements | Retrieves other Element Ids against which the Analytical Model has been adjusted.
GetPoint | Retrieves point of the Analytical Model.
GetReference | Returns a reference to a given curve within the analytical model.
GetRigidLink | Returns rigid link curve corresponding to selector.
GetSweptProfile | Retrieves the swept profile information for Analytical Model.
HasRigidLinksWith | Indicates whether Analytical Model has Rigid Links with specified element.
HasSweptProfile | Indicates if this Element's Analytical Model can be represented as a swept profile.
IsAnalyzeAsValid | Determines if the given Analyze As parameter is valid for this Element.
IsApproximated | Indicates whether Analytical Model is approximated or not.
IsAutoDetectEnabled | Reports whether or not Analytical Auto-detect for the given direction is enabled.
IsElementFullySupported | Indicates whether Analytical Model is fully supported.
IsEnabled | Reports whether the Analytical Model is enabled or disabled.
IsManuallyAdjusted | Indicates whether or not the Analytical Model has been manually adjusted by the user.
IsSingleCurve | This indicates whether the Analytical Model can be expressed as a single curve.
IsSinglePoint | This indicates whether the Analytical Model can be expressed as a single point.
IsValidAnalyticalProjectionType | Indicates whether a given Analytical Projection Type is valid for the given Analytical Direction.
IsValidDatumPlaneForProjection | Indicates whether a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
IsValidDirectionForAutoDetect | Tests whether or not the supplied direction is valid for Analytical Auto-detect.
IsValidDirectionForProjection | This indicates whether the input direction is valid for Analytical Model projection.
IsValidForManualAdjustment | Indicates if the identified reference is acceptable for Manual Analytical Adjustment.
IsValidManualAdjustmentSource | Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.
IsValidManualAdjustmentTarget | Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.
IsValidRigidLinksOption | Indicates whether Rigid Links option is valid for the Analytical Model.
IsValidSelector | This indicates whether the input selector is valid for the Analytical Model.
ManuallyAdjust | Perform Manual Analytical Adjustment on analytical model, with respect to another Element
ResetManualAdjustment | Resets all manual adjustments performed by the user onto the Analytical Model.
SetAnalyticalOffset | Sets Analytical Offset in the case where the user can do that.
SetAnalyticalProjectionDatumPlane | Sets analytical model projection to a Datum Plane.
SetAnalyticalProjectionType | Sets the analytical model projection to a preset value.
SetAnalyzeAs | Sets value of Analyze As parameter for this Element.
SetApproximationDeviation | Adjusts the amount by which approximation is made.
SetUsesHardPoints | Sets Hard Points for the Analytical Model.
SupportsManualAdjustment | Indicates if the Element supports Manual Analytical Adjustment.
UsesHardPoints | Indicates if the Analytical Model is using Hard Points during approximation.

Properties

Name | Description
RigidLinksOption | Indicates whether parameters indicate if Rigid Links should be formed.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModel Methods

[image] [image]