Revit 2011 API
Area..::.Boundary Property
Area Class See Also Send Feedback
Returns the boundary of the area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the area. Each area may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Area.BoundarySegment object for more details about the segments that make up the area topology.

See Also

Area Class

Parameter Property

[image] [image]