Revit 2011 API
MassSurfaceData..::.ShadeDepth Property
MassSurfaceData Class See Also Send Feedback
How far any auto-generated shades should extend from the wall surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double ShadeDepth { get; set; }
Visual Basic (Declaration)
Public Property ShadeDepth As Double
Visual C++
public:
property double ShadeDepth {
    double get ();
    void set (double value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace

SillHeight Property

[image]