Revit 2011 API
Connector..::.AssignedFixtureUnits Property
Connector Class See Also Send Feedback
The assigned fixture units of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AssignedFixtureUnits { get; set; }
Visual Basic (Declaration)
Public Property AssignedFixtureUnits As Double
Visual C++
public:
property double AssignedFixtureUnits {
    double get ();
    void set (double value);
}

Remarks

Assigned fixture units may be assigned for connectors of some family instances, for more information, refer to PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get or set assigned fixture units.

See Also

Connector Class

AssignedFlow Property

[image]