Revit 2011 API
BindingMap..::.Item Property
BindingMap Class See Also Send Feedback
The get_Item method will get the binding item related to the input key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Binding Item[
    Definition key
] { get; set; }
Visual Basic (Declaration)
Public Overrides Property Item ( _
    key As Definition _
) As Binding
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key) override;
    void set (Definition^ key, Binding^ value) override;
}

Parameters

key
Type: Autodesk.Revit.DB..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Field Value

The returned value of get_Item is an InstanceBinding or TypeBinding object that contains the set of categories to which the parameter is bound. The input item is an InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

set_Item is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown. Instead use Insert, Remove and ReInsert to modify the bindings in the document.

See Also

BindingMap Class

Blend Class

[image]