Revit 2011 API
Space Members
Space Class Methods Properties See Also Send Feedback

The Space type exposes the following members.

Methods

Name | Description
IsPointInSpace | Determines if a point lies within the volume of the Space.

Properties

Name | Description
ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
ActualLightingLoad | Get the Actual Lighting Load of the Space.
ActualOtherLoad | Get or set the Actual Other Load of the Space.
ActualPowerLoad | Get the Actual Power Load of the Space.
ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
AreaperPerson | Get the Area per Person of the Space.
AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
BaseOffset | Get or Set the Base Offset of the Space.
Boundary | Returns the boundary of the Space.
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
ClosedShell | Return the closedShell of the space.
ConditionType | Get or set the Condition type of the Space.
DesignCoolingLoad | Get the Design Cooling Load of the Space.
DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
DesignHeatingLoad | Get the Design Heating Load of the Space.
DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
DesignLightingLoad | Get or set the Design Lighting Load of the Space.
DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
DesignPowerLoad | Get or set the Design Power Load of the Space.
DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
FloorReflectance | Get or set the Floor Reflectance of the Space.
LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
LimitOffset | Get or Set the Limit Offset of the Space.
NumberofPeople | Get the Number of People of the Space.
OccupancyUnit | Get the Occupancy Unit of the Space.
Occupiable | Reports whether this zone is Occupiable or not.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Plenum | Reports whether this zone is Plenum or not.
PowerLoadUnit | Get or Set the Power Load Unit of the Space.
ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Room | Return the Room of the space.
SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
SpaceConstruction | Get the Space Construction of the Space.
SpaceType | Get or set the Space type of the Space.
UnboundedHeight | Get the Unbounded Height of the Space.
UpperLimit | Get or Set the Upper Limit of the Space.
Volume | Get the Volume of the Space.
WallReflectance | Get or set the Wall Reflectance of the Space.
Zone | Reports this space belong to which Zone.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace

Space Methods

[image] [image]