Revit 2011 API
ImageExportOptions..::.ExportRange Property
ImageExportOptions Class See Also Send Feedback
The export range, which defines which view(s) will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ExportRange ExportRange { get; set; }
Visual Basic (Declaration)
Public Property ExportRange As ExportRange
Visual C++
public:
property ExportRange ExportRange {
    ExportRange get ();
    void set (ExportRange value);
}

Remarks

The default is CurrentView. Note that SetOfViews is not an acceptable value if these options are used to save an image to a project as a new view.

See Also

ImageExportOptions Class

FilePath Property

[image]