Revit 2011 API
AnalyticalModel..::.GetAnalyticalProjectionDatumPlane Method
AnalyticalModel Class See Also Send Feedback
Retrieves analytical model projection information for a specific direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function GetAnalyticalProjectionDatumPlane ( _
    direction As AnalyticalDirection _
) As ElementId
Visual C++
public:
ElementId^ GetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which analytical model is projected.

Return Value

Datum Plane to which analytical model is projected, or invalidElementId if not projected to a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

GetAnalyticalProjectionType Method

[image]