Revit 2011 API
StructuralSettings..::.AnalyticalModelCheckSupportDistance Property
StructuralSettings Class See Also Send Feedback
Check that joins in the physical model are consistent with proximity in the analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckSupportDistance { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelCheckSupportDistance As Boolean
Visual C++
public:
property bool AnalyticalModelCheckSupportDistance {
    bool get ();
    void set (bool value);
}

Remarks

When this check is enabled, a warning will be given for physically joined members whose analytical curves are more than a certain distance apart. The distance is given by the AnalyticalModelSupportDistanceTolerance property.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelCheckZeroAreaOrLength Property

[image]