Revit 2011 API
EnergyDataSettings..::.BuildingConstructionClass Property
EnergyDataSettings Class See Also Send Feedback
Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public HVACLoadConstructionClass BuildingConstructionClass { get; set; }
Visual Basic (Declaration)
Public Property BuildingConstructionClass As HVACLoadConstructionClass
Visual C++
public:
property HVACLoadConstructionClass BuildingConstructionClass {
    HVACLoadConstructionClass get ();
    void set (HVACLoadConstructionClass value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace

BuildingHVACSystem Property

[image]