Revit 2011 API
RebarHostData..::.getRebarHostData Method
RebarHostData Class See Also Send Feedback
Gets a RebarHostData object referring to the specified rebar host element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static RebarHostData getRebarHostData(
    Element host
)
Visual Basic (Declaration)
Public Shared Function getRebarHostData ( _
    host As Element _
) As RebarHostData
Visual C++
public:
static RebarHostData^ getRebarHostData(
    Element^ host
)

Parameters

host
Type: Autodesk.Revit.DB..::.Element
An element to host rebar.

Return Value

A RebarHostData object or nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) for elements that cannot ever be rebar hosts, such as levels.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace

HasCoverTypeForReference Method

[image]