Revit 2011 API
CurtainGridLine Members
CurtainGridLine Class Methods Properties See Also Send Feedback

The CurtainGridLine type exposes the following members.

Methods

Name | Description
AddAllSegments | All the segments on this grid line will be added.
AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
AddSegment | Add a segment based on the specified segment curve of the gridline.
Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
RemoveSegment | Remove the segment specified by the input curve.

Properties

Name | Description
AllSegmentCurves | Retrieve the curves of all segments.
ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
FullCurve | Retrieve the geometry curve of the curtain grid line.
IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Lock | Retrieve or change the lock state of the curtain grid line.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.

See Also

CurtainGridLine Class

CurtainGridLine Methods

[image] [image]