Revit 2011 API
MaterialSteel..::.ThermalExpansionCoefficientZ Property
MaterialSteel Class See Also Send Feedback
Get or set the z component of the thermal expansion coefficient of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientZ { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientZ As Double
Visual C++
public:
property double ThermalExpansionCoefficientZ {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the z component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class

UnitWeight Property

[image]