Revit 2011 API
ControlledApplication..::.VersionName Property
ControlledApplication Class See Also Send Feedback
Returns the name of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string VersionName { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionName As String
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

VersionNumber Property

[image]