Revit 2011 API
MechanicalSystem..::.DuctNetwork Property
MechanicalSystem Class See Also Send Feedback
The ducts and fittings contained within the system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet DuctNetwork { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuctNetwork As ElementSet
Visual C++
public:
property ElementSet^ DuctNetwork {
    ElementSet^ get ();
}

Remarks

The return value doesn't include terminals or equipments, the ducts and fittings are returned in no particular order.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace

Flow Property

[image]