Revit 2011 API
AnalysisDisplayColorSettings..::.GetIntermediateColors Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Get intermediate color entries (other than the minimum and maximum settings).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void GetIntermediateColors(
    IList<AnalysisDisplayColorEntry> map
)
Visual Basic (Declaration)
Public Sub GetIntermediateColors ( _
    map As IList(Of AnalysisDisplayColorEntry) _
)
Visual C++
public:
void GetIntermediateColors(
    IList<AnalysisDisplayColorEntry^>^ map
)

Parameters

map
Type: System.Collections.Generic..::.IList <(Of <( AnalysisDisplayColorEntry >)>)
Array of intermediate color entries.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace

IsEqual Method

[image]