Revit 2011 API
MaterialGeneric Class
Members Example See Also Send Feedback
Represents a generic material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MaterialGeneric : Material
Visual Basic (Declaration)
Public Class MaterialGeneric _
    Inherits Material
Visual C++
public ref class MaterialGeneric : public Material

Remarks

MaterialGeneric is a child class of Material.

Examples

CopyC#
private void MaterialGenericInformation(MaterialGeneric myGeneric)
{
    StringBuilder message = new StringBuilder("Material Generic : " + myGeneric.Name);

    //behaviour of the material
    MaterialBehaviourType behaviour = myGeneric.Behavior;
    message.Append("Behavior: " + behaviour);
    double dampingRatio = myGeneric.DampingRatio;
    message.Append("Damping Ratio: " + dampingRatio);
    double minimumYieldStress = myGeneric.MinimumYieldStress;
    message.Append("Minimum yield stress: " + minimumYieldStress);

    double poissonModulusX = myGeneric.PoissonModulusX;
    message.Append("Poisson Ratio X: " + poissonModulusX);
    double poissonModulusY = myGeneric.PoissonModulusY;
    message.Append("Poisson Ratio Y: " + poissonModulusY);
    double poissonModulusZ = myGeneric.PoissonModulusZ;
    message.Append("Poisson Ratio Z: " + poissonModulusZ);

    double reductionFactor = myGeneric.ReductionFactor;
    message.Append("Reduction factor for shear: " + reductionFactor);

    double shearModulusX = myGeneric.ShearModulusX;
    message.Append("Shear modulus X: " + shearModulusX);
    double shearModulusY = myGeneric.ShearModulusY;
    message.Append("Shear modulus Y: " + shearModulusY);
    double shearModulusZ = myGeneric.ShearModulusZ;
    message.Append("Shear modulus Z: " + shearModulusZ);

    double thermalExpansionCoefficientX = myGeneric.ThermalExpansionCoefficientX;
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX);
    double thermalExpansionCoefficientY = myGeneric.ThermalExpansionCoefficientY;
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY);
    double thermalExpansionCoefficientZ = myGeneric.ThermalExpansionCoefficientZ;
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ);

    double unitWeight = myGeneric.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulusX = myGeneric.YoungModulusX;
    message.Append("Young modulus X: " + youngModulusX);
    double youngModulusY = myGeneric.YoungModulusY;
    message.Append("Young modulus Y: " + youngModulusY);
    double youngModulusZ = myGeneric.YoungModulusZ;
    message.Append("Young modulus Z: " + youngModulusZ);

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Private Sub MaterialGenericInformation(ByVal myGeneric As MaterialGeneric)
    Dim message As New StringBuilder("Material Generic : " + myGeneric.Name)

    'behaviour of the material
    Dim behaviour As MaterialBehaviourType = myGeneric.Behavior
    message.Append("Behavior: " + behaviour)
    Dim dampingRatio As Double = myGeneric.DampingRatio
    message.Append("Damping Ratio: " + dampingRatio)
    Dim minimumYieldStress As Double = myGeneric.MinimumYieldStress
    message.Append("Minimum yield stress: " + minimumYieldStress)

    Dim poissonModulusX As Double = myGeneric.PoissonModulusX
    message.Append("Poisson Ratio X: " + poissonModulusX)
    Dim poissonModulusY As Double = myGeneric.PoissonModulusY
    message.Append("Poisson Ratio Y: " + poissonModulusY)
    Dim poissonModulusZ As Double = myGeneric.PoissonModulusZ
    message.Append("Poisson Ratio Z: " + poissonModulusZ)

    Dim reductionFactor As Double = myGeneric.ReductionFactor
    message.Append("Reduction factor for shear: " + reductionFactor)

    Dim shearModulusX As Double = myGeneric.ShearModulusX
    message.Append("Shear modulus X: " + shearModulusX)
    Dim shearModulusY As Double = myGeneric.ShearModulusY
    message.Append("Shear modulus Y: " + shearModulusY)
    Dim shearModulusZ As Double = myGeneric.ShearModulusZ
    message.Append("Shear modulus Z: " + shearModulusZ)

    Dim thermalExpansionCoefficientX As Double = myGeneric.ThermalExpansionCoefficientX
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX)
    Dim thermalExpansionCoefficientY As Double = myGeneric.ThermalExpansionCoefficientY
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY)
    Dim thermalExpansionCoefficientZ As Double = myGeneric.ThermalExpansionCoefficientZ
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ)

    Dim unitWeight As Double = myGeneric.UnitWeight
    message.Append("Unit Weight: " + unitWeight)

    Dim youngModulusX As Double = myGeneric.YoungModulusX
    message.Append("Young modulus X: " + youngModulusX)
    Dim youngModulusY As Double = myGeneric.YoungModulusY
    message.Append("Young modulus Y: " + youngModulusY)
    Dim youngModulusZ As Double = myGeneric.YoungModulusZ
    message.Append("Young modulus Z: " + youngModulusZ)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Material
Autodesk.Revit.DB..::.MaterialGeneric

See Also

MaterialGeneric Members

MaterialGeneric Members

[image] [image]