Revit 2011 API
XYZ..::.Normalize Method
XYZ Class See Also Send Feedback
Returns a new XYZ whose coordinates are the normalized values from this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Normalize()
Visual Basic (Declaration)
Public Function Normalize As XYZ
Visual C++
public:
XYZ^ Normalize()

Return Value

The normalized XYZ or zero if the vector is almost Zero.

Remarks

Normalized indicates that the length of this vector equals one (a unit vector).

See Also

XYZ Class

Subtract Method

[image]