Revit 2011 API
CurveByPointsUtils..::.SetProjectionType Method
CurveByPointsUtils Class See Also Send Feedback
Sets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static void SetProjectionType(
    CurveElement curveElem,
    CurveProjectionType value
)
Visual Basic (Declaration)
Public Shared Sub SetProjectionType ( _
    curveElem As CurveElement, _
    value As CurveProjectionType _
)
Visual C++
public:
static void SetProjectionType(
    CurveElement^ curveElem,
    CurveProjectionType value
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::.CurveElement
The CurveElement.
value
Type: Autodesk.Revit.DB..::.CurveProjectionType
The input projection type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class

SetSketchOnSurface Method

[image]