Revit 2011 API
ElementRecord..::.GetCategoryId Method
ElementRecord Class See Also Send Feedback
Gets the category id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetCategoryId()
Visual Basic (Declaration)
Public Function GetCategoryId As ElementId
Visual C++
public:
ElementId^ GetCategoryId()

Return Value

The category id.

See Also

ElementRecord Class

GetDesignOptionId Method

[image]