Revit 2011 API
MassSurfaceData..::.CategoryIdForConceptualSurfaceType Property
MassSurfaceData Class See Also Send Feedback
Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId CategoryIdForConceptualSurfaceType { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryIdForConceptualSurfaceType As ElementId
Visual C++
public:
property ElementId^ CategoryIdForConceptualSurfaceType {
    ElementId^ get ();
}

Remarks

This value is determined by starting with the subcategory property and adjusting it according to properties such as "isSlab" or "isUnderground".

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace

ConceptualConstructionId Property

[image]