Revit 2011 API
SpatialFieldManager..::.AddSpatialFieldPrimitive Method (Curve, Transform)
SpatialFieldManager Class See Also Send Feedback
Creates empty analysis results container (primitive) associated with a curve and a transform.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive(
    Curve curve,
    Transform trf
)
Visual Basic (Declaration)
Public Function AddSpatialFieldPrimitive ( _
    curve As Curve, _
    trf As Transform _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Curve^ curve,
    Transform^ trf
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
Curve to be associated with the primitive. %curve% does NOT correspond to actual Revit geometry, i.e. it cannot be associated with reference; otherwise the other overload of the method must be used (taking "reference" as the input)
trf
Type: Autodesk.Revit.DB..::.Transform
Conformal Transform to be applied to %curve%.

Return Value

Unique index of primitive for future references

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | trf is not conformal
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace

AddSpatialFieldPrimitive Method (Face, Transform)

[image]