Revit 2011 API
RebarShape Members
RebarShape Class Methods Properties See Also Send Feedback

The RebarShape type exposes the following members.

Methods

Name | Description
GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

Properties

Name | Description
Definition | Get the shape definition object associated with this shape.
HookAngle | Get and set the hook angle.
HookOrientation | Get and set the hook orientation.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
RebarStyle | Access the rebar style.
SameShapeIgnoringHooks | Test whether two shapes have equivalent definitions.
SimpleArc | Check whether this shape consists of a single arc, possibly with hooks.
SimpleLine | Check whether this shape consists of a single straight segment, possibly with hooks.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

RebarShape Methods

[image] [image]