Revit 2011 API
MaterialGeneric Properties
MaterialGeneric Class See Also Send Feedback

The MaterialGeneric type exposes the following members.

Properties

Name | Description
Behavior | Get or set the material behavior type of the generic material.
DampingRatio | Get or set the damping ratio of the generic material.
MinimumYieldStress | Get or set the minimum yield stress of the generic material.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
PoissonModulusX | Get or set the x component of the Poisson modulus of the generic material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the generic material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the generic material.
ReductionFactor | Get or set the reduction factor for shear of the generic material.
ShearModulusX | Get or set the x component of the shear modulus of the generic material.
ShearModulusY | Get or set the y component of the shear modulus of the generic material.
ShearModulusZ | Get or set the z component of the shear modulus of the generic material.
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the generic material.
UnitWeight | Get or set the unit weight of the generic material.
YoungModulusX | Get or set the x component of the Young modulus of the generic material.
YoungModulusY | Get or set the y component of the Young modulus of the generic material.
YoungModulusZ | Get or set the z component of the Young modulus of the generic material.

See Also

MaterialGeneric Class

Behavior Property

[image]