Revit 2011 API
PushButtonData..::.ClassName Property
PushButtonData Class See Also Send Feedback
The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string ClassName { get; set; }
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace

RadioButtonGroup Class

[image]