Revit 2011 API
AreaReinforcement..::.Curves Property
AreaReinforcement Class See Also Send Feedback
Retrieves the array of curves forming the boundary of the Area Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As ElementArray
Visual C++
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type AreaReinforcementCurve. Each element has a Curve property to retrieve the geometric curve, together with some Parameters allowing the developer to override the clear cover side, hook type, and hook direction of each layer of bars terminating at the curve.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace

Direction Property

[image]