Revit 2011 API
AnnotationSymbol Members
AnnotationSymbol Class Methods Properties See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Methods

Name | Description
addLeader | add a leader to this annotation symbol.
duplicate | Duplicate this annotation symbol.
removeLeader | remove a leader of this annotation symbol.

Properties

Name | Description
AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
FromRoom | Overloaded. The room from which the door or window is opened.
Leaders | Get all the leaders of this annotation symbol.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Room | Overloaded. The room in which the instance is located.
Space | Overloaded. The space in which the instance is located.
ToRoom | Overloaded. The room to which the door or window is opened.

See Also

AnnotationSymbol Class

AnnotationSymbol Methods

[image] [image]