Revit 2011 API
RibbonItem..::.Enabled Property
RibbonItem Class See Also Send Feedback
Gets or sets a value indicating whether the item is enabled.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

When the Enabled property is set to false, the item cannot be clicked, and the item's appearance changes. The Image and Text assigned to the item appear grayed out. If the relevant external command cannot be executed, setting Enabled to true won't have an effect. The push button will be disabled when there is no active document unless availability class of that button returns true.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace

ItemText Property

[image]