Revit 2011 API
BuiltInFailures..::.ElementFailures..::.NotAllowedToRemoveAllElements Property
BuiltInFailures..::.ElementFailures Class See Also Send Feedback
You cannot removed all the elements from current solution. At least there should be two elements in the solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllowedToRemoveAllElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotAllowedToRemoveAllElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotAllowedToRemoveAllElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElementFailures Class

SplitElementHasTagsWithoutLeaders Property

[image]