Revit 2011 API
BindingMap Members
BindingMap Class Methods Properties See Also Send Feedback

The BindingMap type exposes the following members.

Methods

Name | Description
Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::.Clear()()().)
Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::.Contains(Definition).)
Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::.Erase(Definition).)
Insert | Overloaded. Creates a new parameter binding.
ReInsert | Overloaded. Removes an existing parameter and creates a new binding for a given parameter.
Remove | The Remove method is used to remove a parameter binding.

Properties

Name | Description
Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap..::.Item[([(Definition])]).)

See Also

BindingMap Class

BindingMap Methods

[image] [image]