Revit 2011 API
Document..::.NewRebar Method (RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, RebarHookOrientation, RebarHookOrientation, Boolean, Boolean)
Document Class Example See Also Send Feedback
Creates a new instance of a Rebar element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Rebar NewRebar(
    RebarStyle style,
    RebarBarType rebarType,
    RebarHookType startHook,
    RebarHookType endHook,
    Element host,
    XYZ norm,
    CurveArray curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)
Visual Basic (Declaration)
Public Function NewRebar ( _
    style As RebarStyle, _
    rebarType As RebarBarType, _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    host As Element, _
    norm As XYZ, _
    curves As CurveArray, _
    startHookOrient As RebarHookOrientation, _
    endHookOrient As RebarHookOrientation, _
    useExistingShapeIfPossible As Boolean, _
    createNewShape As Boolean _
) As Rebar
Visual C++
public:
Rebar^ NewRebar(
    RebarStyle style,
    RebarBarType^ rebarType,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    Element^ host,
    XYZ^ norm,
    CurveArray^ curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)

Parameters

style
Type: Autodesk.Revit.DB.Structure..::.RebarStyle
The usage of the bar, "standard" or "stirrup/tie".
rebarType
Type: Autodesk.Revit.DB.Structure..::.RebarBarType
The element of RebarBarType that defines bar diameter, bend radius and material of the rebar.
startHook
Type: Autodesk.Revit.DB.Structure..::.RebarHookType
The element of RebarHookType that defines the hook angle and radius to be inserted before the first curve of the rebar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with NONE hook type.
endHook
Type: Autodesk.Revit.DB.Structure..::.RebarHookType
The element of RebarHookType that defines the hook angle and radius to be inserted after the last curve segment of the rebar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with NONE hook type.
host
Type: Autodesk.Revit.DB..::.Element
The element to which the rebar belongs. The element must be a structural wall, floor, beam, brace, foundation or structural column.
norm
Type: Autodesk.Revit.DB..::.XYZ
The normal to the plane that the rebar curves lie on.
curves
Type: Autodesk.Revit.DB..::.CurveArray
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHookOrient
Type: Autodesk.Revit.DB.Structure..::.RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Type: Autodesk.Revit.DB.Structure..::.RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
useExistingShapeIfPossible
Type: System..::.Boolean
Attempts to assign a RebarShape from those existing in the document. If no shape matches, NewRebar returns nullNothingnullptra null reference (Nothing in Visual Basic) or creates a new shape, according to the parameter createNewShape. When both parameters are "true", the behavior is the same as sketching rebar in the UI. At least one of these parameters must be "true".
createNewShape
Type: System..::.Boolean
Creates a shape in the document to match the curves, hooks, and style specified, and assigns it to the new rebar instance. Shape creation will not succeed unless one or more other shapes already exist in the document, and these shapes have enough shape parameters to define a shape for these curves.

Return Value

If successful, NewRebar returns an object for the newly created Rebar. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Examples

CopyC#
 Rebar CreateRebar(Autodesk.Revit.DB.Document document, FamilyInstance column, RebarBarType barType, RebarHookType hookType)
{
    // Define the rebar geometry information - Line rebar
    LocationPoint location = column.Location as LocationPoint;
    XYZ origin = location.Point;
    XYZ normal = new XYZ(1, 0, 0);
    XYZ rebarLineEnd = new XYZ(origin.X, origin.Y, origin.Z + 9);
    Line rebarLine = document.Application.Create.NewLineBound(origin, rebarLineEnd);

    // Create the line rebar
    CurveArray curves = new CurveArray();
    curves.Append(rebarLine);

    Rebar rebar = document.Create.NewRebar(Autodesk.Revit.DB.Structure.RebarStyle.Standard, barType, hookType, hookType,
                        column, origin, curves, RebarHookOrientation.Right, RebarHookOrientation.Left, true, true);

    if (null != rebar)
    {
        // set specific layout for new rebar
        Parameter paramLayout = rebar.get_Parameter(BuiltInParameter.REBAR_ELEM_LAYOUT_RULE);
        paramLayout.Set(1); // 1 = Fixed Number
        Parameter paramNum = rebar.get_Parameter(BuiltInParameter.REBAR_ELEM_QUANTITY_OF_BARS);
        paramNum.Set(10);
        rebar.ArrayLength = 1.5;
    }

    return rebar;
}
CopyVB.NET
Function CreateRebar(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance, _
                     ByVal barType As Autodesk.Revit.DB.Structure.RebarBarType, _
                     ByVal hookType As Autodesk.Revit.DB.Structure.RebarHookType) _
                     As Autodesk.Revit.DB.Structure.Rebar
    ' Define the rebar geometry information - Line rebar
    Dim location As LocationPoint = TryCast(column.Location, LocationPoint)
    Dim origin As Autodesk.Revit.DB.XYZ = location.Point
    Dim normal As New Autodesk.Revit.DB.XYZ(1, 0, 0)
    Dim rebarLineEnd As New Autodesk.Revit.DB.XYZ(origin.X, origin.Y, origin.Z + 9)
    Dim rebarLine As Line = document.Application.Create.NewLineBound(origin, rebarLineEnd)

    ' Create the line rebar
    Dim curves As New CurveArray()
    curves.Append(rebarLine)

    Dim rebar As Autodesk.Revit.DB.Structure.Rebar = _
        document.Create.NewRebar(Autodesk.Revit.DB.Structure.RebarStyle.Standard, barType, _
                                 hookType, hookType, column, origin, curves, _
                                 Autodesk.Revit.DB.Structure.RebarHookOrientation.Right, _
                                 Autodesk.Revit.DB.Structure.RebarHookOrientation.Left, True, True)

    If rebar IsNot Nothing Then
        ' set specific layout for new rebar
        Dim paramLayout As Parameter = rebar.Parameter(BuiltInParameter.REBAR_ELEM_LAYOUT_RULE)
        paramLayout.[Set](1)
        ' 1 = Fixed Number
        Dim paramNum As Parameter = rebar.Parameter(BuiltInParameter.REBAR_ELEM_QUANTITY_OF_BARS)
        paramNum.[Set](10)
        rebar.ArrayLength = 1.5
    End If

    Return rebar
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewRebar Overload
Autodesk.Revit.Creation Namespace

NewRebar Method (RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ)

[image]