Revit 2011 API
Document..::.NewFascia Method (FasciaType, Reference)
Document Class See Also Send Feedback
Creates a fascia along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    reference As Reference _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    Reference^ reference
)

Parameters

FasciaType
Type: Autodesk.Revit.DB.Architecture..::.FasciaType
The type of the fascia to create
reference
Type: Autodesk.Revit.DB..::.Reference
A planar line or arc that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace

NewFascia Method (FasciaType, ReferenceArray)

[image]