Revit 2011 API
DefinitionGroupsBase Members
DefinitionGroupsBase Class Constructors Methods Properties See Also Send Feedback

The DefinitionGroupsBase type exposes the following members.

Constructors

Name | Description
DefinitionGroupsBase | Initializes a new instance of the DefinitionGroupsBase class

Methods

Name | Description
Clear | Removes every definition group from the set, rendering it empty.
Contains | Tests for the existence of a definition group within the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
Size | Returns the number of definition groups that are in the set.

See Also

DefinitionGroupsBase Class

DefinitionGroupsBase Constructor

[image]