Revit 2011 API
ElementRecord Members
ElementRecord Class Methods See Also Send Feedback

The ElementRecord type exposes the following members.

Methods

Name | Description
Dispose |
GetBoundingBox | Gets the bounding box of the element record.
GetCategoryId | Gets the category id of the element record.
GetDesignOptionId | Gets the design option id of the element record.
GetId | Gets the id of the element record.
GetOwnerViewId | Gets the element id of the owner view record.
HasBoundingBox | Determines whether this element record has a bounding box.
IsAnElementType | Identifies if the element record represents an ElementType.
IsCurveDriven | Identifies if the element is curve driven.

See Also

ElementRecord Class

ElementRecord Methods

[image] [image]