Revit 2011 API
View..::.Print Method (Boolean)
View Class See Also Send Feedback
Print this view with default print settings and view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Print(
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    bool useCurrentPrintSettings
)

Parameters

useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print settings; otherwise with the print settings of the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload

Print Method (View, Boolean)

[image]