Revit 2011 API
RebarBarType Members
RebarBarType Class Methods Properties See Also Send Feedback

The RebarBarType type exposes the following members.

Methods

Name | Description
Create | Creates a new RebarBarType object
GetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
GetHookLength | Identifies the hook length for a hook type
GetHookOffsetLength | Identifies the hook offset length for a hook type
GetHookPermission | Identifies if a hook type is permitted for this bar type
SetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
SetHookLength | Identifies the hook length for a hook type
SetHookOffsetLength | Identifies the hook offset length for a hook type
SetHookPermission | Identifies if a hook type is permitted for this bar type

Properties

Name | Description
BarDiameter | Defines bar diameter of rebar
MaximumBendRadius | Defines maximum bend radius of rebar
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
StandardBendDiameter | Defines bar bend diameter for rebar whose style is standard
StandardHookBendDiameter | Defines hook bend diameter for rebar whose style is standard
StirrupTieBendDiameter | Defines bar and hook bend diameter for rebar whose style is stirrup/tie

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

RebarBarType Methods

[image] [image]