Revit 2011 API
SpatialFieldManager..::.SetUnits Method
SpatialFieldManager Class See Also Send Feedback
Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetUnits(
    IList<string> names,
    IList<double> multipliers
)
Visual Basic (Declaration)
Public Sub SetUnits ( _
    names As IList(Of String), _
    multipliers As IList(Of Double) _
)
Visual C++
public:
void SetUnits(
    IList<String^>^ names,
    IList<double>^ multipliers
)

Parameters

names
Type: System.Collections.Generic..::.IList <(Of <( String >)>)
Unit names for all units (e.g., "Lb" and "Kg")
multipliers
Type: System.Collections.Generic..::.IList <(Of <( Double >)>)
Numerical coefficients mapped to unit names; they are used to adjust measurement values for display (e.g., 1.0 and 0.451 - if actual measurements are in Lb)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | names contains duplicate or empty names, or its lengths is zero -or- multipliers contains non-positive numbers, or its lengths is not equal to the length of names
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace

UpdateSpatialFieldPrimitive Method

[image]