Revit 2011 API
Floor Class
Members Example See Also Send Feedback
An object that represents a Floor within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Floor : HostObject
Visual Basic (Declaration)
Public Class Floor _
    Inherits HostObject
Visual C++
public ref class Floor : public HostObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Examples

CopyC#
public void ShowFloorInfo(Floor floor)
{
    string message = "Floor : ";
    // Get Floor AnalyticalModel
    message += "\nFloor AnalyticalModel is : " + floor.GetAnalyticalModel();

    // Get Floor type name
    message += "\nFloor type name is : " + floor.FloorType.Name;
    try
    {
        // Get Floor span direction angle
        message += "\nFloor span direction angle is : " + floor.SpanDirectionAngle;
    }
    catch (Exception)
    {
        // an exception is thrown if floor is non-structural
        message += "\nFloor is non-structural.";
    }

    TaskDialog.Show("Revit",message);

}
CopyVB.NET
Public Sub ShowFloorInfo(ByVal floor As Autodesk.Revit.DB.Floor)
    Dim message As String = "Floor : "
    ' Get Floor AnalyticalModel
    message += vbLf & "Floor AnalyticalModel is : " & floor.GetAnalyticalModel().ToString()

    ' Get Floor type name
    message += vbLf & "Floor type name is : " & floor.FloorType.Name.ToString()
    Try
        ' Get Floor span direction angle
        message += vbLf & "Floor span direction angle is : " + floor.SpanDirectionAngle
    Catch generatedExceptionName As Exception
        ' an exception is thrown if floor is non-structural
        message += vbLf & "Floor is non-structural."
    End Try

    TaskDialog.Show("Revit", message)

End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.Floor

See Also

Floor Members

Floor Members

[image] [image]