Revit 2011 API
RebarShapeDefinitionBySegments..::.AddBendDefaultRadius Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a default-radius bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddBendDefaultRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle
)
Visual Basic (Declaration)
Public Sub AddBendDefaultRadius ( _
    iSegmentFollowingBend As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle _
)
Visual C++
public:
void AddBendDefaultRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle
)

Parameters

iSegmentFollowingBend
Type: System..::.Int32
Index of the segment after the bend (1 to NumberOfSegments - 1).
turn
Type: System..::.Int32
Specify 1 for a left turn, -1 for a right turn.
angle
Type: Autodesk.Revit.DB.Structure..::.RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.

Remarks

You must add a bend between each two segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

AddBendVariableRadius Method

[image]