Revit 2011 API
SiteLocation..::.TimeZone Property
SiteLocation Class See Also Send Feedback
Time-zone that contains the site

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TimeZone { get; set; }
Visual Basic (Declaration)
Public Property TimeZone As Double
Visual C++
public:
property double TimeZone {
    double get ();
    void set (double value);
}

Remarks

A property that returns the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

Note that there are no restrictions preventing you from setting this to an incorrect value for the site location, and incorrect times for Solar Studies may result.

See Also

SiteLocation Class

Sketch Class

[image]