Revit 2011 API
FilteredElementCollector..::.OfCategory Method
FilteredElementCollector Class Example See Also Send Feedback
Applies an ElementCategoryFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FilteredElementCollector OfCategory(
    BuiltInCategory category
)
Visual Basic (Declaration)
Public Function OfCategory ( _
    category As BuiltInCategory _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OfCategory(
    BuiltInCategory category
)

Parameters

category
Type: Autodesk.Revit.DB..::.BuiltInCategory
The category.

Return Value

This collector.

Remarks

Only elements of this category id will pass the collector.

Examples

CopyC#
// Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> doors = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements();
CopyVB.NET
' Use OfCategory method to apply an ElementCategoryFilter and find Levels in the document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim doors As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements()

See Also

FilteredElementCollector Class

OfCategoryId Method

[image]