Revit 2011 API
RebarShapeDefinitionBySegments..::.RemoveParameterFromSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Remove constraints from a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveParameterFromSegment(
    int iSegment,
    Parameter param
)
Visual Basic (Declaration)
Public Sub RemoveParameterFromSegment ( _
    iSegment As Integer, _
    param As Parameter _
)
Visual C++
public:
void RemoveParameterFromSegment(
    int iSegment,
    Parameter^ param
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

Remarks

This reverses the effect of any AddConstraint and SetSegmentAs180DegreeBend operations involving the specified segment and parameter.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

SetSegmentAs180DegreeBend Method

[image] [image]