Revit 2011 API
RebarShapeDefinitionByArc..::.AddConstraintSagittaLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintSagittaLength(
    Parameter param
)
Visual Basic (Declaration)
Public Sub AddConstraintSagittaLength ( _
    param As Parameter _
)
Visual C++
public:
void AddConstraintSagittaLength(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

Remarks

The sagitta will be measured on the centerline of the bar.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace

SetArcTypeSpiral Method

[image]