Revit 2011 API
BoundarySegmentArrayArray..::.Item Property
BoundarySegmentArrayArray Class See Also Send Feedback
Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace

Size Property

[image]