Revit 2011 API
Document..::.NewRoomBoundaryLines Method
Document Class See Also Send Feedback
Creates a new boundary line as an Room border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArray NewRoomBoundaryLines(
    SketchPlane sketchPlane,
    CurveArray curves,
    View view
)
Visual Basic (Declaration)
Public Function NewRoomBoundaryLines ( _
    sketchPlane As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewRoomBoundaryLines(
    SketchPlane^ sketchPlane,
    CurveArray^ curves,
    View^ view
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plan
curves
Type: Autodesk.Revit.DB..::.CurveArray
The geometry curves on which the boundary lines are
view
Type: Autodesk.Revit.DB..::.View
The View for the new Room

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewRooms Method

[image] [image]