Revit 2011 API
Document..::.Move Method (Element, XYZ)
Document Class Example See Also Send Feedback
Moves an element within the document by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Move(
    Element element,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    element As Element, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    Element^ element,
    XYZ^ translationVec
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element that is to be moved.
translationVec
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the element is to be moved.

Return Value

True if the element is moved successfully, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved. For example, if the element is level, all the elements on that level will also move.

Examples

CopyC#
public void MoveColumn(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
    // get the column current location
    LocationPoint columnLocation = column.Location as LocationPoint;

    XYZ oldPlace = columnLocation.Point;

    // Move the column to new location.
    XYZ newPlace = new XYZ(10, 20, 30);
    document.Move(column, newPlace);

    // now get the column's new location
    columnLocation = column.Location as LocationPoint;
    XYZ newActual = columnLocation.Point;

    string info = "Original Z location: " + oldPlace.Z +
                  "\nNew Z location: " + newActual.Z;

    TaskDialog.Show("Revit",info);
}
CopyVB.NET
Public Sub MoveColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance)
    ' get the column current location
    Dim columnLocation As LocationPoint = TryCast(column.Location, LocationPoint)

    Dim oldPlace As Autodesk.Revit.DB.XYZ = columnLocation.Point

    ' Move the column to new location.
    Dim newPlace As New Autodesk.Revit.DB.XYZ(10, 20, 30)
    document.Move(column, newPlace)

    ' now get the column's new location
    columnLocation = TryCast(column.Location, LocationPoint)
    Dim newActual As Autodesk.Revit.DB.XYZ = columnLocation.Point

    Dim info As String = "Original Z location: " + oldPlace.Z + vbLf & "New Z location: " + newActual.Z

    TaskDialog.Show("Revit", info)
End Sub

See Also

Document Class
Move Overload

Move Method (ElementId, XYZ)

[image]