Revit 2011 API
PanelScheduleData Methods
PanelScheduleData Class See Also Send Feedback

The PanelScheduleData type exposes the following members.

Methods

Name | Description
AddLoadClassification | add a Load Classification Id to the array of Load Classifications.
GetLoadClassifications | get an array of the load classifications associated with this panel schedule
GetNumberOfCircuitRows | returns the number of rows in the circuit table
IsSymmetric | returns if this panel schedule is symmetric
RemoveLoadClassification | remove a Load Classification Id from the array of Load Classifications
SetLoadClassifications | sets the Load Classifications associated with this panel schedule
UpdateCircuitTableForInstance | redraw the circuit table for the given panel with the given parameter updates
UpdateCircuitTableForTemplate | redraw the circuit table for a template with the given parameter updates
UpdateIsSectionHidden | update if this section is hidden or not
UpdateLoadSummary | update the load summary section
UpdateVerticalHeadersInSection | set if this header should have vertical text

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace

AddLoadClassification Method

[image]