Revit 2011 API
BoundingBoxIsInsideFilter Constructor (Outline, Double)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline,
    double tolerance
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline, _
    tolerance As Double _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that are contained by it.
tolerance
Type: System..::.Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload

BoundingBoxIsInsideFilter Constructor (Outline, Double, Boolean)

[image]