Revit 2011 API
FamilyInstance..::.Host Property
FamilyInstance Class See Also Send Feedback
If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic (Declaration)
Public ReadOnly Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

Remarks

An example of an instance that is contained is a window. In this case the host property would return the wall in which the window is contained. Another example is an instance that is hosted to a planar or curved face in a Mass element will return the Mass element.

See Also

FamilyInstance Class

IsSlantedColumn Property

[image]