Revit 2011 API
StructuralSettings..::.GetStructuralSettings Method
StructuralSettings Class See Also Send Feedback
Obtains the StructuralSettings object for the specified project document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static StructuralSettings GetStructuralSettings(
    Document doc
)
Visual Basic (Declaration)
Public Shared Function GetStructuralSettings ( _
    doc As Document _
) As StructuralSettings
Visual C++
public:
static StructuralSettings^ GetStructuralSettings(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::.Document
The document.

Return Value

The StructuralSettings object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | doc is a family and does not support Structural Settings.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace

StructuralSettings Properties

[image] [image]