Revit 2011 API
PanelScheduleView..::.GetApparentLoad Method
PanelScheduleView Class See Also Send Feedback
get the apparent load for the given phase for the given slotted circuit

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GetApparentLoad(
    ElementId circuitId,
    ElementId apparentLoadParam
)
Visual Basic (Declaration)
Public Function GetApparentLoad ( _
    circuitId As ElementId, _
    apparentLoadParam As ElementId _
) As Double
Visual C++
public:
double GetApparentLoad(
    ElementId^ circuitId,
    ElementId^ apparentLoadParam
)

Parameters

circuitId
Type: Autodesk.Revit.DB..::.ElementId
apparentLoadParam
Type: Autodesk.Revit.DB..::.ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace

GetCellText Method

[image]