Revit 2011 API
AnalyzeAs Enumeration
See Also Send Feedback
Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyzeAs
Visual Basic (Declaration)
Public Enumeration AnalyzeAs
Visual C++
public enum class AnalyzeAs

Members

Member name | Description
Hanger | A hanging Element.
Gravity | Interpreted as Gravity (support going down).
Lateral | Interpreted as Lateral (support going across).
Slab | Floor interpreted as Slab.
Mat | Floor interpreted as Mat Foundation, or general foundation.
SlabOnGrade | Floor interpreted as Slab on a Grade.
NotForAnalysis | Element is not for Analysis.
NotApplicable | Analyze As is not applicable.

See Also

Autodesk.Revit.DB.Structure Namespace

AreaLoad Class

[image]