Revit 2011 API
ParameterMapIterator..::.Key Property
ParameterMapIterator Class See Also Send Feedback
Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class

ParameterSet Class

[image]