Revit 2011 API
PointOnFace..::.SetFaceReference Method
PointOnFace Class See Also Send Feedback
Change the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetFaceReference(
    Reference reference
)
Visual Basic (Declaration)
Public Sub SetFaceReference ( _
    reference As Reference _
)
Visual C++
public:
void SetFaceReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.

See Also

PointOnFace Class

PointOnFace Properties

[image] [image]