Revit 2011 API
View..::.Unhide Method
View Class See Also Send Feedback
Sets the elements to be shown in the given view if they are currently hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Unhide(
    ElementSet elemSet
)
Visual Basic (Declaration)
Public Sub Unhide ( _
    elemSet As ElementSet _
)
Visual C++
public:
void Unhide(
    ElementSet^ elemSet
)

Parameters

elemSet
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements to be unhidden.

Remarks

This change is permanent until the elements are hidden again. All elements in the set must be currently hidden. An application can check this with IsHidden(View).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the set of elements to be unhidden is empty or one of the elements can not be unhidden.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when document regeneration failed.

See Also

View Class

View Properties

[image] [image]