Revit 2011 API
ItemFactoryBase..::.NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
A face of a geometry object.
location
Type: Autodesk.Revit.DB..::.XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::.XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)

[image]