Revit 2011 API
RebarShapeDefinitionBySegments..::.AddListeningDimensionBendToBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension between two bends, measured by a read-only parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddListeningDimensionBendToBend(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionBendToBend ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iEnd0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionBendToBend(
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::.Int32
Index of the first segment.
iEnd0
Type: System..::.Int32
End (0 or 1) of the first segment.
iSegment1
Type: System..::.Int32
Index of the second segment.
iEnd1
Type: System..::.Int32
End (0 or 1) of the second segment.

Remarks

Each reference is at the outside of the bend, perpendicular to the specified segment. So the overall length of a shape with 5 segments might be defined by calling this function with iSegment0=0, iEnd0=0, iSegment1=4, iEnd1=1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

AddListeningDimensionSegmentToBend Method

[image]