Revit 2011 API
TextBox..::.Value Property
TextBox Class See Also Send Feedback
The object that supplies the text value.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Remarks

The value assigned to the TextBox can be a String or any other data type. If the type is not a String the TextBox will display the return of the ToString() method. When the text is edited in the UI, the type of Value will always be String.

See Also

TextBox Class
Autodesk.Revit.UI Namespace

Width Property

[image]