Revit 2011 API
RebarShape..::.GetCurvesForBrowser Method
RebarShape Class See Also Send Feedback
Generate curves for the shape, as used in the shape browser.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray GetCurvesForBrowser()
Visual Basic (Declaration)
Public Function GetCurvesForBrowser As CurveArray
Visual C++
public:
CurveArray^ GetCurvesForBrowser()

Return Value

An array of curves representing the shape with its default parameters.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

NewDefinitionByArc Method

[image]