Revit 2011 API
Selection Members
Selection Class Methods Properties See Also Send Feedback

The Selection type exposes the following members.

Methods

Name | Description
PickElementsByRectangle | Overloaded. Prompts the user to select multiple elements by drawing a rectangle.
PickObject | Overloaded. Prompts the user to select one object.
PickObjects | Overloaded. Prompts the user to select multiple objects.
PickOne | Obsolete. Allows the user to select one element.
PickPoint | Overloaded. Prompts the user to pick a point on the active work plane.
WindowSelect | Obsolete. Allows the user to select elements by a rectangle.

Properties

Name | Description
Elements | The elements that are currently selected.
StatusbarTip | Obsolete. The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace

Selection Methods

[image] [image]