Revit 2011 API
AnalysisDisplayLegendSettings Members
AnalysisDisplayLegendSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayLegendSettings type exposes the following members.

Constructors

Name | Description
AnalysisDisplayLegendSettings | Overloaded.

Methods

Name | Description
Dispose |
IsEqual | Compares two legend settings objects.
SetTextTypeId | Set element id of text associated with legend settings.

Properties

Name | Description
NumberOfSteps | Number of steps (values between minimum and maximum) to be shown in legend.
Rounding | Rounding increment for numeric values of analysis results.
ShowDataDescription | If set to true, data description is shown in the legend.
ShowDataName | If set to true, data name is shown in the legend.
ShowLegend | If set to true, legend is shown in the view.
ShowUnits | If set to true, units are shown in the legend.
TextTypeId | Element id of text associated with legend settings.

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayLegendSettings Constructor

[image] [image]