Revit 2011 API
TransactionGroup..::.RollBack Method
TransactionGroup Class See Also Send Feedback
Rolls back the transaction group and with it all inner transactions enclosing by this group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus RollBack()
Visual Basic (Declaration)
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Remarks

All transactions inside the transaction group will be rolled back

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The TransactionGroup is not in started status

See Also

TransactionGroup Class

SetName Method

[image]