Revit 2011 API
CompoundStructure Class
Members See Also Send Feedback
An object that describes the multi layered construction of walls or floors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CompoundStructure : APIObject
Visual Basic (Declaration)
Public Class CompoundStructure _
    Inherits APIObject
Visual C++
public ref class CompoundStructure : public APIObject

Remarks

The CompoundStructure object exposes the layers of elements, such as walls. These layers can be of varying thickness and material, each of which has a dedicated function.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CompoundStructure

See Also

CompoundStructure Members

CompoundStructure Members

[image] [image]