Revit 2011 API
ApplicationEntryPoint..::.AddinFolder Property
ApplicationEntryPoint Class See Also Send Feedback
The full path to the Revit VSTA module.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string AddinFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddinFolder As String
Visual C++
public:
virtual property String^ AddinFolder {
    String^ get () sealed;
}

Implements

IEntryPoint..::.AddinFolder

Remarks

This path should be used instead of the .NET GetExecutingAssembly() result, because the VSTA module is loaded in such a way to make that result unreliable.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace

Application Property

[image]