Revit 2011 API
ControlledApplication Members
ControlledApplication Class Methods Properties Events See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

Name | Description
GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
WriteJournalComment | Writes a comment to the Revit journal file

Properties

Name | Description
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the current session of Revit.
LibraryPaths | Retrieves path information for where content is stored on disk.
Product | The product type for the current session of Revit.
RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
VersionBuild | Returns the internal build number of the Autodesk Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

Events

Name | Description
DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
DocumentClosed | Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.
DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.
FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

ControlledApplication Methods

[image] [image]