Revit 2011 API
Rebar..::.ScaleToBoxForSpiral Method
Rebar Class See Also Send Feedback
Move and resize a spiral instance to fit within a specified box.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ScaleToBoxForSpiral(
    XYZ origin,
    XYZ xVec,
    XYZ yVec,
    double height
)
Visual Basic (Declaration)
Public Sub ScaleToBoxForSpiral ( _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ, _
    height As Double _
)
Visual C++
public:
void ScaleToBoxForSpiral(
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec,
    double height
)

Parameters

origin
Type: Autodesk.Revit.DB..::.XYZ
One corner of the rectangle.
xVec
Type: Autodesk.Revit.DB..::.XYZ
Vector representing the first edge of the rectangle. The length must be positive.
yVec
Type: Autodesk.Revit.DB..::.XYZ
Vector representing the second edge of the rectangle. Must be perpendicular to xVec.
height
Type: System..::.Double
New value for the Height parameter.

Remarks

The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The circle at one end of the spiral is inscribed in this rectangle. The other end of the spiral is placed in the parallel plane at distance given by height, in the direction of xVec cross yVec.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

SetLayoutAsFixedNumber Method

[image]