Revit 2011 API
Document..::.Rotate Method (ICollection<(Of <(ElementId>)>), Line, Double)
Document Class See Also Send Feedback
Rotates several elements, specified by a set of ids, within the document by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Rotate(
    ICollection<ElementId> ids,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    ids As ICollection(Of ElementId), _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    ICollection<ElementId^>^ ids,
    Line^ axis,
    double angle
)

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The set of ids for the elements that are to be rotated.
axis
Type: Autodesk.Revit.DB..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be rotated around the specified axis.

Return Value

True if the elements are rotated successfully, otherwise False.

Remarks

The rotate method is used to rotate several elements within the project. Other elements may also be rotated when these elements are rotated because they are dependent upon the elements being rotated. A line used as the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Rotate Overload

Save Method

[image]