Revit 2011 API
FilterableValueProvider Members
FilterableValueProvider Class Methods See Also Send Feedback

The FilterableValueProvider type exposes the following members.

Methods

Name | Description
Dispose |
GetDoubleValue | Gets a double-precision numeric value from the given element.
GetElementIdValue | Gets an ElementId value from the given element.
GetIntegerValue | Gets an integer value from the given element.
GetStringValue | Gets a string value from the given element.
IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
IsStringValueSupported | Determines whether the provide can provide a string value for the given element.

See Also

FilterableValueProvider Class

FilterableValueProvider Methods

[image] [image]