Revit 2011 API
UpdaterRegistry..::.RemoveAllTriggers Method
UpdaterRegistry Class See Also Send Feedback
Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void RemoveAllTriggers(
    UpdaterId id
)
Visual Basic (Declaration)
Public Shared Sub RemoveAllTriggers ( _
    id As UpdaterId _
)
Visual C++
public:
static void RemoveAllTriggers(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id of specified updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater's owner AddIn does not match currently active AddIn
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class

RemoveDocumentTriggers Method

[image]