Revit 2011 API
Document..::.Array Method (ElementSet, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of several elements using a specified number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinearArray Array(
    ElementSet elements,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector to which the elements will move.

Return Value

A LinearArray element if the elements are arrayed successfully and groupAndAssociate is set to True. nullNothingnullptra null reference (Nothing in Visual Basic) if the elements are arrayed successfully and groupAndAssociate is set to False. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Array Overload

Array Method (ElementSet, Int32, Boolean, Double)

[image]