Revit 2011 API
AnalyticalModelSketchComponent..::.SetAnalyticalProjectionType Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Sets the Analytical Projection to the supplied Analytical Projection Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionType(
    AnalyticalProjectionType projectionType
)
Visual Basic (Declaration)
Public Sub SetAnalyticalProjectionType ( _
    projectionType As AnalyticalProjectionType _
)
Visual C++
public:
void SetAnalyticalProjectionType(
    AnalyticalProjectionType projectionType
)

Parameters

projectionType
Type: Autodesk.Revit.DB.Structure..::.AnalyticalProjectionType
Analytical Projection Type to which the Analytical Model should project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | projectionType is not valid for this Sketch component.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelSupport Class

[image]