Revit 2011 API
ElementType Members
ElementType Class Methods Properties See Also Send Feedback

The ElementType type exposes the following members.

Methods

Name | Description
Duplicate | Duplicate this object.
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
GetSimilarTypes | Obtains a set of types that are similar to this type.
IsSimilarType | Checks if given type is similar to this type.

Properties

Name | Description
Name | Set the name for the ElementType. (Overrides Element..::.Name.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.

See Also

ElementType Class

ElementType Methods

[image] [image]