Revit 2011 API
Document..::.Import Method (String, ImageImportOptions, Element%)
Document Class See Also Send Feedback
Imports an image (a bitmap) into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Import(
    string file,
    ImageImportOptions options,
    out Element element
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As ImageImportOptions, _
    <OutAttribute> ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    ImageImportOptions^ options,
    [OutAttribute] Element^% element
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit.DB..::.ImageImportOptions
Various options applicable to an image. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
element
Type: Autodesk.Revit.DB..::.Element %
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

See Also

Document Class
Import Overload

Link Method

[image]