Revit 2011 API
DuctConnector Class
Members See Also Send Feedback
A duct connector that is assigned to a mechanical equipment or duct fitting family. Provides access to the duct connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DuctConnector : ConnectorElement,
    IConnector
Visual Basic (Declaration)
Public Class DuctConnector _
    Inherits ConnectorElement _
    Implements IConnector
Visual C++
public ref class DuctConnector : public ConnectorElement,
    IConnector

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Duct connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ConnectorElement
Autodesk.Revit.DB.Mechanical..::.DuctConnector

See Also

DuctConnector Members
Autodesk.Revit.DB.Mechanical Namespace

DuctConnector Members

[image] [image]