Revit 2011 API
Transaction Members
Transaction Class Constructors Methods See Also Send Feedback

The Transaction type exposes the following members.

Constructors

Name | Description
Transaction | Overloaded.

Methods

Name | Description
Commit | Overloaded.
Dispose |
GetFailureHandlingOptions | Returns the current failure handling options
GetName | Returns the transaction's name
GetStatus | Returns the current status of the transaction
HasEnded | Determines whether the transaction has ended already
HasStarted | Determines whether the transaction has been started yet
RollBack | Overloaded.
SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back
SetName | Sets the transaction's name
Start | Overloaded.

See Also

Transaction Class

Transaction Constructor

[image] [image]