Revit 2011 API
FamilyInstance Properties
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Properties

Name | Description
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
CanRotate | Property to test whether the family instance can be rotated by 180 degree.
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
FacingOrientation | Property to get the orientation of family instance facing.
FromRoom | Overloaded. The room from which the door or window is opened.
HandFlipped | Property to test whether the orientation of family instance hand is flipped.
HandOrientation | Property to get the orientation of family instance hand.
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
IsSlantedColumn | Indicates if the family instance is a slanted column.
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
MEPModel | Retrieves the MEP model for the family instance.
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Room | Overloaded. The room in which the instance is located.
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made.
StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
SubComponents | Property to get the sub components of current family instance.
SuperComponent | Property to get the super component of current family instance.
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
ToRoom | Overloaded. The room to which the door or window is opened.

See Also

FamilyInstance Class

CanFlipFacing Property

[image]