Revit 2011 API
MechanicalSystem Properties
MechanicalSystem Class See Also Send Feedback

The MechanicalSystem type exposes the following members.

Properties

Name | Description
BaseEquipmentConnector | The connector within the base equipment which is used to connect with the system.
DuctNetwork | The ducts and fittings contained within the system.
Flow | The system flow.
IsWellConnected | Indicates if the system is well connected or not.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
StaticPressure | The system static pressure.
SystemType | The type of this duct system.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace

BaseEquipmentConnector Property

[image]