Revit 2011 API
ConstructionType Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use Autodesk.Revit.DB.Analysis.ConstructionType instead.")]
public enum ConstructionType
Visual Basic (Declaration)
<ObsoleteAttribute("Use Autodesk.Revit.DB.Analysis.ConstructionType instead.")> _
Public Enumeration ConstructionType
Visual C++
[ObsoleteAttribute(L"Use Autodesk.Revit.DB.Analysis.ConstructionType instead.")]
public enum class ConstructionType

Members

Member name | Description
ExteriorWalls | Construction Type is ExteriorWalls.
InteriorWalls | Construction Type is InteriorWalls.
Slabs | Construction Type is Slabs.
Roofs | Construction Type is Roofs.
Floors | Construction Type is Floors.
Doors | Construction Type is Doors.
ExteriorWindows | Construction Type is ExteriorWindows.
InteriorWindows | Construction Type is InteriorWindows.
Skylights | Construction Type is Skylights.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also

ContFooting Class

[image]