Revit 2011 API
ElectricalSystem..::.NewWires Method
ElectricalSystem Class See Also Send Feedback
Create a bunch of wires for the electrical system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireSet NewWires(
    View view,
    WiringType wiringType
)
Visual Basic (Declaration)
Public Function NewWires ( _
    view As View, _
    wiringType As WiringType _
) As WireSet
Visual C++
public:
WireSet^ NewWires(
    View^ view,
    WiringType wiringType
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the wire is to be visible.
wiringType
Type: Autodesk.Revit.DB.Electrical..::.WiringType
Specify the wiring type(Arc or Chamfer) that is to be applied to all new created wires.

Return Value

New created wires

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | This method can just only be used to created a bunch of wires according to specific pairs of elements, so if there exists a nullNothingnullptra null reference (Nothing in Visual Basic) element in any pair of familyInstancePairs, the exception will be thrown.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace

RemoveFromCircuit Method

[image]