Revit 2011 API
EnergyDataSettings..::.ExportDefaults Property
EnergyDataSettings Class See Also Send Feedback
Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ExportDefaults { get; set; }
Visual Basic (Declaration)
Public Property ExportDefaults As Boolean
Visual C++
public:
property bool ExportDefaults {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace

GroundPlane Property

[image]