Revit 2011 API
MEPSpaceConstruction..::.CurrentConstruction Property
MEPSpaceConstruction Class See Also Send Feedback
Get all the Building Constructions according to the specific Construction type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPBuildingConstruction CurrentConstruction { get; set; }
Visual Basic (Declaration)
Public Property CurrentConstruction As MEPBuildingConstruction
Visual C++
public:
property MEPBuildingConstruction^ CurrentConstruction {
    MEPBuildingConstruction^ get ();
    void set (MEPBuildingConstruction^ value);
}

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace

SpaceConstructions Property

[image]