Revit 2011 API
Transaction Constructor (Document, String)
Transaction Class See Also Send Feedback
Instantiates an uninitialized transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transaction(
    Document document,
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    name As String _
)
Visual C++
public:
Transaction(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which this transaction is going to be used.
name
Type: System..::.String
The name of the transaction. This name will appear in the undo menu once the transaction is successfully committed. The name must not be empty. The name can be reset later by either calling SetName(String) or by using the name argument in the Start(String) method.

Remarks

The transaction does not start by creating a transaction object. The Start method will need to be called in order to start this transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The name argument is an empty string
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class
Transaction Overload

Transaction Methods

[image] [image]