Revit 2011 API
BuiltInFailures..::.RebarShapeFailures Members
BuiltInFailures..::.RebarShapeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RebarShapeFailures type exposes the following members.

Properties

Name | Description
CurveOverconstrained | Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
CurvesCollinear | Collinear segments are not allowed in a Rebar Shape definition.
CurvesUnlooped | Segments defining the Rebar Shape must be in a continuous loop.
CurveUnderconstrained | Segment is underconstrained. It requires additional parameterized dimensions.
DimensionLoose | This dimension cannot be used to parameterize the Rebar Shape.
DimensionWithoutParameter | Dimension has no parameter assigned to it.
FormulaDrivenDimension | Dimension can't be driven by a formula parameter.
ShapeFailure | The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.

See Also

BuiltInFailures..::.RebarShapeFailures Class

BuiltInFailures.RebarShapeFailures Properties

[image] [image]