Revit 2011 API
MassZone..::.GetReferencesToEnergyAnalysisFaces Method
MassZone Class See Also Send Feedback
Used to get References to all the faces of the MassZone that are used for Energy Analysis.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<Reference> GetReferencesToEnergyAnalysisFaces()
Visual Basic (Declaration)
Public Function GetReferencesToEnergyAnalysisFaces As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferencesToEnergyAnalysisFaces()

Return Value

Array of References to faces of MassZone.

Remarks

These are the faces and face regions that are typically visible to the user when MassZones are displayed. There are other faces in the MassZone geometry that are not visible and not used for EnergyAnalysis. The results are always references to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports them as REFERENCE_TYPE_NONE.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace

IsEmpty Method

[image]