Revit 2011 API
AnalyticalModel Class
Members See Also Send Feedback
AnalyticalModel represents the Analytical Model portion of a given Structural Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModel : IDisposable
Visual Basic (Declaration)
Public Class AnalyticalModel _
    Implements IDisposable
Visual C++
public ref class AnalyticalModel : IDisposable

Remarks

AnalyticalModel is made up of the following information:
  • Curves, representing the graphical representation of the Element with respect to analysis.
  • Support Information.
  • Adjustment Information, both Manual and Automatic.
  • Parameter Information, including projection, hard points, approximation, and rigid links.
  • Analytical Offset.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.AnalyticalModel

See Also

AnalyticalModel Members
Autodesk.Revit.DB.Structure Namespace

AnalyticalModel Members

[image] [image]