Revit 2011 API
IFCExportOptions..::.CurrentViewOnly Property
IFCExportOptions Class See Also Send Feedback
Option to export only the parts of a model that are visible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CurrentViewOnly { get; set; }
Visual Basic (Declaration)
Public Property CurrentViewOnly As Boolean
Visual C++
public:
property bool CurrentViewOnly {
    bool get ();
    void set (bool value);
}

Remarks

Visible elements include those that are hidden by hidden lines or shaded mode, any underlays in the view, and elements that are cropped from view by the crop region. Elements temporarily hidden using temporary hide/isolate will not be exported.

See Also

IFCExportOptions Class

ExportBaseQuantities Property

[image]