Revit 2011 API
Wall Members
Wall Class Methods Properties See Also Send Feedback

The Wall type exposes the following members.

Methods

Name | Description
flip | The wall orientation will be flipped.

Properties

Name | Description
CurtainGrid | Get the grid object of a curtain wall
Flipped | Property to test whether the wall orientation is flipped.
Orientation | The normal vector projected from the exterior side of the wall.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
StructuralUsage | The walls designated structural usage, such as bearing or non bearing.
WallType | Retrieve or change the type of the wall.
Width | Returns the overall thickness of the wall.

See Also

Wall Class

Wall Methods

[image] [image]