Revit 2011 API
FamilyInstanceCreationData..::.Axis Property
FamilyInstanceCreationData Class See Also Send Feedback
Get or set the axis of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Line Axis { get; set; }
Visual Basic (Declaration)
Public Property Axis As Line
Visual C++
public:
property Line^ Axis {
    Line^ get ();
    void set (Line^ value);
}

Remarks

The element property will be the axis while performing the rotation.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace

RotateAngle Property

[image]