Revit 2011 API
Path3d..::.CurveLoop Property
Path3d Class See Also Send Feedback
Get the Curve Loop of Path3d via index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray CurveLoop[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurveLoop ( _
    index As Integer _
) As CurveArray
Visual C++
public:
property CurveArray^ CurveLoop[int index] {
    CurveArray^ get (int index);
}

Parameters

index
Type: System..::.Int32

Remarks

Returns the index order Curve Loop of Path3d.

See Also

Path3d Class

NumCurveLoops Property

[image]