Revit 2011 API
AnalyticalModel..::.SetAnalyticalProjectionDatumPlane Method
AnalyticalModel Class See Also Send Feedback
Sets analytical model projection to a Datum Plane.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic (Declaration)
Public Sub SetAnalyticalProjectionDatumPlane ( _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
)
Visual C++
public:
void SetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which analytical model may be projected.
datumPlaneId
Type: Autodesk.Revit.DB..::.ElementId
Datum Plane to which analytical model may be projected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for analytical model -or- Datum Plane is invalid projection target.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

SetAnalyticalProjectionType Method

[image]