Revit 2011 API
ApplicationEntryPoint..::.ActiveUIDocument Property
ApplicationEntryPoint Class See Also Send Feedback
Provides access to an object that represents the currently active project.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual UIDocument ActiveUIDocument { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveUIDocument As UIDocument
Visual C++
public:
virtual property UIDocument^ ActiveUIDocument {
    UIDocument^ get ();
}

Remarks

External API commands can access this property in read-only mode only! The ability to modify the property is reserved for future implementations.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to modify the property.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace

AddinFolder Property

[image]