Revit 2011 API
InvalidObjectException Class
Members See Also Send Feedback
The exception that is thrown when referencing an [native] object that either no longer exists whose creation was undone (by rolling a transaction back).

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidObjectException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InvalidObjectException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class InvalidObjectException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.InvalidObjectException

See Also

InvalidObjectException Members
Autodesk.Revit.Exceptions Namespace

InvalidObjectException Members

[image] [image]