Revit 2011 API
PipingSystem Properties
PipingSystem Class See Also Send Feedback

The PipingSystem type exposes the following members.

Properties

Name | Description
BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Flow | The system flow.
FluidDensity | The system fluid density.
FluidTemperature | The system fluid temperature.
FluidType | The system fluid type.
FluidViscosity | The system fluid viscosity.
IsWellConnected | Indicates if the system is well connected or not.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
PipingNetwork | Pipes and fittings which are contained in this system.
StaticPressure | The system static pressure.
SystemType | The type of this piping system.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace

BaseEquipmentConnector Property

[image]