Revit 2011 API
SolidSolidCutUtils..::.CanElementCutElement Method
SolidSolidCutUtils Class See Also Send Feedback
Verifies if the cutting element can add a solid cut to the cut element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CanElementCutElement(
    Element cuttingElement,
    Element cutElement,
    out CutFailureReason reason
)
Visual Basic (Declaration)
Public Shared Function CanElementCutElement ( _
    cuttingElement As Element, _
    cutElement As Element, _
    <OutAttribute> ByRef reason As CutFailureReason _
) As Boolean
Visual C++
public:
static bool CanElementCutElement(
    Element^ cuttingElement,
    Element^ cutElement,
    [OutAttribute] CutFailureReason% reason
)

Parameters

cuttingElement
Type: Autodesk.Revit.DB..::.Element
The cutting element.
cutElement
Type: Autodesk.Revit.DB..::.Element
The element to be cut.
reason
Type: Autodesk.Revit.DB..::.CutFailureReason %
The reason that the cutting element can not add a solid cut to the cut element.

Return Value

True if the cutting element can add a solid cut to the cut element, False if not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class

Dispose Method

[image]