Revit 2011 API
TransactionGroup..::.Assimilate Method
TransactionGroup Class Example See Also Send Feedback
Assimilates all inner transactions, merges them into a single one, and then commits it

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Assimilate()
Visual Basic (Declaration)
Public Function Assimilate As TransactionStatus
Visual C++
public:
TransactionStatus Assimilate()

Remarks

The transactions inside this group will be merged as one single transaction (with the group's name as the transaction's name) User will not be able to undo/redo to the middle of the group, they can only undo/redo the entire group

Examples

CopyC#
TransactionStatus status = TransactionStatus.Uninitialized;
bool bAssimilate = true;
TransactionGroup transGroup = new TransactionGroup(document, "Group Change");
if (transGroup.Start() == TransactionStatus.Started)
{
    Transaction levelTransaction = new Transaction(document, "Add Level");
    try
    {
        if (levelTransaction.Start() == TransactionStatus.Started)
        {
            document.Create.NewLevel(25.0);
            levelTransaction.Commit();
        }
    }
    catch
    {
        // if either internal transaction fails, rollback group, too
        levelTransaction.RollBack();
        bAssimilate = false;
    }

    // if first transaction was successful, continue with next
    if (bAssimilate == true)
    {
        Transaction gridTransaction = new Transaction(document, "Add Grid");
        try
        {
            if (gridTransaction.Start() == TransactionStatus.Started)
            {
                XYZ Point1 = new XYZ(0, 0, 0);
                XYZ Point2 = new XYZ(10, 0, 0);

                Line gridLine = document.Application.Create.NewLine(Point1, Point2, true);
                document.Create.NewGrid(gridLine);
                gridTransaction.Commit();
            }
        }
        catch
        {
            // if either internal transaction fails, rollback group, too
            gridTransaction.RollBack();
            bAssimilate = false;
        }
    }

    // if both transactions are successful, assimilate the group
    if (bAssimilate == true)
    {
        status = transGroup.Assimilate();
    }
    else
    {
        status = transGroup.RollBack();
    }
}
CopyVB.NET
Dim status As TransactionStatus = TransactionStatus.Uninitialized
Dim bAssimilate As Boolean = True
Dim transGroup As New TransactionGroup(document, "Group Change")
If transGroup.Start() = TransactionStatus.Started Then
    Dim levelTransaction As New Transaction(document, "Add Level")
    Try
        If levelTransaction.Start() = TransactionStatus.Started Then
            document.Create.NewLevel(25)
            levelTransaction.Commit()
        End If
    Catch
        ' if either internal transaction fails, rollback group, too
        levelTransaction.RollBack()
        bAssimilate = False
    End Try

    ' if first transaction was successful, continue with next
    If bAssimilate = True Then
        Dim gridTransaction As New Transaction(document, "Add Grid")
        Try
            If gridTransaction.Start() = TransactionStatus.Started Then
                Dim Point1 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
                Dim Point2 As New Autodesk.Revit.DB.XYZ(10, 0, 0)

                Dim gridLine As Line = document.Application.Create.NewLine(Point1, Point2, True)
                document.Create.NewGrid(gridLine)
                gridTransaction.Commit()
            End If
        Catch
            ' if either internal transaction fails, rollback group, too
            gridTransaction.RollBack()
            bAssimilate = False
        End Try
    End If

    ' if both transactions are successful, assimilate the group
    If bAssimilate = True Then
        status = transGroup.Assimilate()
    Else
        status = transGroup.RollBack()
    End If
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The TransactionGroup is not in started status

See Also

TransactionGroup Class

Commit Method

[image]