Revit 2011 API
Panel Members
Panel Class Methods Properties See Also Send Feedback

The Panel type exposes the following members.

Methods

Name | Description
GetRefGridLines | This method is used to get the reference gridlines.

Properties

Name | Description
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
FromRoom | Overloaded. The room from which the door or window is opened.
Lock | This property is used to know whether a panel is locked and lock or unlock a panel.
Lockable | This property is used to know whether a panel can be locked.
PanelType | The Panel style of this Panel.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Room | Overloaded. The room in which the instance is located.
Space | Overloaded. The space in which the instance is located.
ToRoom | Overloaded. The room to which the door or window is opened.
Transform | This property is used to find the transform of a curtain panel within project.

See Also

Panel Class

Panel Methods

[image] [image]