Revit 2011 API
AnalyticalCurveSelector Enumeration
See Also Send Feedback
Specifies which portion of an Analytical Curve is of interest.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalCurveSelector
Visual Basic (Declaration)
Public Enumeration AnalyticalCurveSelector
Visual C++
public enum class AnalyticalCurveSelector

Members

Member name | Description
StartPoint | Start of curve (corresponds to param = 0).
EndPoint | End of curve (corresponds to param = 1).
WholeCurve | Entire curve.

See Also

Autodesk.Revit.DB.Structure Namespace

AnalyticalCurveType Enumeration

[image]