Revit 2011 API
Element Members
Element Class Methods Properties See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view.
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model.
CanHaveTypeAssigned | Overloaded.
ChangeTypeId | Overloaded.
Dispose |
GetAnalyticalModel | Retrieves writeable Analytical Model for Element.
GetChangeTypeAny | Returns ChangeType associated with any change in an element.
GetChangeTypeElementAddition | Returns ChangeType associated with element addition
GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
GetChangeTypeGeometry | summary: Returns ChangeType associated with a change in the geometry of an element
GetChangeTypeParameter | Overloaded.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
GetMaterialArea | Get the area of the given material on this element.
GetMaterialVolume | Get the volume of the given material on this element.
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
GetTypeId | Returns the identifier of this element's type.
GetValidTypes | Overloaded.
IsHidden | Identifies if the element has been permanently hidden in the view.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
IsValidType | Overloaded.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Category | Retrieves a Category object that represents the category or sub category in which the element resides.
DesignOption | Returns the design option to which the element belongs.
Document | Returns the Document in which the Element resides.
Geometry | Retrieves the geometric representation of the element.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic).
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Level | If the element is level based then level to which the element is assigned is returned.
Location | This property is used to find the physical location of an element within a project.
Materials | Get all materials present in the element.
Name | A human readable name for the Element.
ObjectType | Obsolete. Returns the instance type of this object.
OwnerViewId | The id of the view that owns the element.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element.
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
PhaseCreated | An object representing the phase when the element is created.
PhaseDemolished | An object representing the phase for when the element is to be demolished.
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance.
UniqueId | A stable unique identifier for an element within the document.
ViewSpecific | Identifies if the element is owned by a view.

See Also

Element Class

Element Methods

[image] [image]