Revit 2011 API
RebarBarType..::.Create Method
RebarBarType Class See Also Send Feedback
Creates a new RebarBarType object

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static RebarBarType Create(
    Document ADoc
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    ADoc As Document _
) As RebarBarType
Visual C++
public:
static RebarBarType^ Create(
    Document^ ADoc
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

GetAutoCalcHookLengths Method

[image]