Revit 2011 API
UIApplication..::.GetRibbonPanels Method (Tab)
UIApplication Class See Also Send Feedback
Get all the custom Panels on a designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    Tab tab
)
Visual Basic (Declaration)
Public Function GetRibbonPanels ( _
    tab As Tab _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    Tab tab
)

Parameters

tab
Type: Autodesk.Revit.UI..::.Tab
The tab on which the panels are located.

Remarks

Built-in panels will not be included. This method is not supported in VSTA.

See Also

UIApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace

UIApplication Properties

[image] [image]