Revit 2011 API
BarDescription Members
BarDescription Class Methods Properties See Also Send Feedback

The BarDescription type exposes the following members.

Methods

Name | Description

Properties

Name | Description
BarType | Retrieves the Rebar Bar Type property of a Bar Description.
Count | Retrieves the number of bars of this shape.
HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.
HookType | Retrieves the Rebar Hook Type property of a Bar Description.
Layer | Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Length | Retrieves the length of a Bar Description.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace

BarDescription Methods

[image] [image]