Revit 2011 API
ProductType Enumeration
See Also Send Feedback
An enumerated type containing the possible Revit product types.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ProductType
Visual Basic (Declaration)
Public Enumeration ProductType
Visual C++
public enum class ProductType

Members

Member name | Description
Architecture | Architecture.
Structure | Structure.
MEP | MEP.
Unknown | Unknown.

See Also

Autodesk.Revit.ApplicationServices Namespace

Autodesk.Revit.Attributes Namespace

[image]