Revit 2011 API
ElectricalConnector Class
Members See Also Send Feedback
An electrical connector that is assigned to an electrical equipment or device family. Provides access to the electrical connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElectricalConnector : ConnectorElement,
    IConnector
Visual Basic (Declaration)
Public Class ElectricalConnector _
    Inherits ConnectorElement _
    Implements IConnector
Visual C++
public ref class ElectricalConnector : public ConnectorElement,
    IConnector

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Electrical connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ConnectorElement
Autodesk.Revit.DB.Electrical..::.ElectricalConnector

See Also

ElectricalConnector Members
Autodesk.Revit.DB.Electrical Namespace

ElectricalConnector Members

[image] [image]