Revit 2011 API
Floor..::.SpanDirectionAngle Property
Floor Class See Also Send Feedback
Retrieve the span direction angle of the floor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double SpanDirectionAngle { get; set; }
Visual Basic (Declaration)
Public Property SpanDirectionAngle As Double
Visual C++
public:
property double SpanDirectionAngle {
    double get ();
    void set (double value);
}

Remarks

The angle returned is in radians. An exception will be thrown if the floor is non structural.

See Also

Floor Class

SpanDirectionSymbols Property

[image]