Revit 2011 API
RevitAPIPreEventArgs Class
Members See Also Send Feedback
The class is used as a base class for the arguments for any pre-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class RevitAPIPreEventArgs : RevitAPIEventArgs
Visual Basic (Declaration)
Public Class RevitAPIPreEventArgs _
    Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPIPreEventArgs : public RevitAPIEventArgs

Remarks

A pre-event is the event raised before executing the process that was related with the event.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitAPIEventArgs
Autodesk.Revit.DB.Events..::.RevitAPIPreEventArgs

See Also

RevitAPIPreEventArgs Members
Autodesk.Revit.DB.Events Namespace

RevitAPIPreEventArgs Members

[image] [image]