Revit 2011 API
PanelScheduleTemplate Members
PanelScheduleTemplate Class Methods Properties See Also Send Feedback

The PanelScheduleTemplate type exposes the following members.

Methods

Name | Description
CopyFrom | Copies all values from other element to this object.
Create | Creates a new instance of a panel schedule template.
GetPanelScheduleType | Returns the panel schedule type.
GetSectionData | ONLY call this function when you WILL change the section data object
GetTableData | ONLY call this function when you WILL change the table data object
HasSameType | Checks if given template has the same panel schedule type with this template.
IsValidPanelConfiguration | Checks if given panel configuration is valid for given panel schedule type.
IsValidType | Overloaded.
SetTableData | Assigns table data to this template

Properties

Name | Description
IsBranchPanelSchedule | Checks to see if this object is branch panel schedule template element.
IsDataPanelSchedule | Checks to see if this object is data panel schedule template element.
IsDefault | Checks to see if this is default template for the given panel schedule type.
IsSwitchboardSchedule | Checks to see if this object is switchboard schedule template element.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace

PanelScheduleTemplate Methods

[image] [image]