Revit 2011 API
ElementIsCurveDrivenFilter Constructor
ElementIsCurveDrivenFilter Class See Also Send Feedback
Constructs a new instance of a filter to match only curve driven elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementIsCurveDrivenFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementIsCurveDrivenFilter()

Remarks

The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements.

See Also

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Overload

ElementIsCurveDrivenFilter Constructor (Boolean)

[image]