Revit 2011 API
PipingSystem..::.PipingNetwork Property
PipingSystem Class See Also Send Feedback
Pipes and fittings which are contained in this system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet PipingNetwork { get; }
Visual Basic (Declaration)
Public ReadOnly Property PipingNetwork As ElementSet
Visual C++
public:
property ElementSet^ PipingNetwork {
    ElementSet^ get ();
}

Remarks

The return value doesn't include mechanical equipment elements. The pipes and fittings are not returned in any particular order.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace

StaticPressure Property

[image]