Revit 2011 API
APIObject..::.Dispose Method
APIObject Class See Also Send Feedback
Causes the object to release immediately any resources it may be utilizing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

Remarks

This method is usually called implicitly by the programming language when the object is destroyed. After calling this method the object will no longer work correctly.

See Also

APIObject Class

APIObject Properties

[image] [image]