Revit 2011 API
Arc Members
Arc Class Methods Properties See Also Send Feedback

The Arc type exposes the following members.

Methods

Name | Description
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.

Properties

Name | Description
Center | Returns the center of the arc.
Normal | Returns the normal to the plane in which the arc is defined.
Radius | Returns the radius of the arc.

See Also

Arc Class

Arc Methods

[image] [image]