Revit 2011 API
View3D..::.EyePosition Property
View3D Class See Also Send Feedback
The position of the camera.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ EyePosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property EyePosition As XYZ
Visual C++
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | The view is a template and does not have an eye position applied.

See Also

View3D Class

IsPerspective Property

[image]