Revit 2011 API
PipingSystem..::.StaticPressure Property
PipingSystem Class See Also Send Feedback
The system static pressure.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StaticPressure { get; }
Visual Basic (Declaration)
Public ReadOnly Property StaticPressure As Double
Visual C++
public:
property double StaticPressure {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Throw when the static pressure is not computed because the system is not well connected.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace

SystemType Property

[image]