Revit 2011 API
Connector..::.AssignedPipeFlowConfiguration Property
Connector Class See Also Send Feedback
The pipe flow configuration type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeFlowConfigurationType AssignedPipeFlowConfiguration { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedPipeFlowConfiguration As PipeFlowConfigurationType
Visual C++
public:
property PipeFlowConfigurationType AssignedPipeFlowConfiguration {
    PipeFlowConfigurationType get ();
}

Remarks

Assigned pipe flow configuration may be assigned for connectors of some family instances, for more information, refer to PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get pipe flow configuration.

See Also

Connector Class

AssignedPipeLossMethod Property

[image]