Revit 2011 API
RebarShapeDefinitionBySegments..::.AddConstraintParallelToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Constrain the length of a segment by parameterizing its length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintParallelToSegment(
    int iSegment,
    Parameter param,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic (Declaration)
Public Sub AddConstraintParallelToSegment ( _
    iSegment As Integer, _
    param As Parameter, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintParallelToSegment(
    int iSegment,
    Parameter^ param,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
measureToOutsideOfBend0
Type: System..::.Boolean
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
measureToOutsideOfBend1
Type: System..::.Boolean
Choose between two possibilities for the second reference of the length dimension.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

AddConstraintToSegment Method

[image]