Revit 2011 API
Settings Properties
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Properties

Name | Description
Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
FillPatterns | Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.
LinePatterns | Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.
Materials | Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.
TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings Class

Categories Property

[image]