Revit 2011 API
Document..::.Export Method
Document Class See Also Send Feedback
Exports the document to another file format.

Overload List

Name | Description
Export(String, String, MassGBXMLExportOptions) | Exports a gbXML file from a mass model document.
Export(String, String, GBXMLExportOptions) | Exports the document in Green-Building XML format.
Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Export(String, String, ViewSet, DGNExportOptions) | Exports the current view or a selection of views in DGN format.
Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Export(String, String, ViewSet, DWGExportOptions) | Exports the current view or a selection of views in DWG format.
Export(String, String, ViewSet, DXFExportOptions) | Exports the current view or a selection of views in DXF format.
Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Export(String, String, ViewSet, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) | Exports the document in the format of Civil Engineering design applications.

See Also

Document Class
Document Members

Export Method (String, String, MassGBXMLExportOptions)

[image]