Revit 2011 API
Floor Properties
Floor Class See Also Send Feedback

The Floor type exposes the following members.

Properties

Name | Description
FloorType | Retrieves/set an object that represents the type of the floor.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
SpanDirectionAngle | Retrieve the span direction angle of the floor
SpanDirectionSymbols | An array of span direction symbols associated with this floor.
StructuralUsage | The floors designated structural usage, such as bearing or non bearing.

See Also

Floor Class

FloorType Property

[image]