Revit 2011 API
CurveByPointsUtils Members
CurveByPointsUtils Class Methods See Also Send Feedback

The CurveByPointsUtils type exposes the following members.

Methods

Name | Description
AddCurvesToFaceRegion | Adds The CurveElements to one or more FaceRegions.
CreateRectangle | Creates rectangle on face or sketchplane for two given diagonal points.
Dispose |
GetFaceRegions | Gets the FaceRegions in the existing face.
GetHostFace | Gets the host face to which the CurveElement is added.
GetProjectionType | Gets the projection type of the CurveElement.
GetSketchOnSurface | Gets the relationship between the CurveElement and face.
SetProjectionType | Sets the projection type of the CurveElement.
SetSketchOnSurface | Sets the relationship between the CurveElement and face.
ValidateCurveElementIdArrayForFaceRegions | Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added the the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

See Also

CurveByPointsUtils Class

CurveByPointsUtils Methods

[image] [image]