Revit 2011 API
Document..::.Close Method
Document Class See Also Send Feedback
Closes the document with the possibility to ask the user whether or not to save.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Close()
Visual Basic (Declaration)
Public Function Close As Boolean
Visual C++
public:
bool Close()

Return Value

False if either closing procedure fails or if saving of a modified document failed. Also returns False if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, True is returned.

Remarks

This function can not be called on the active document.

If the document is modified, the user will be asked if the document should be saved.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.

See Also

Document Class
Close Overload

Close Method (Boolean)

[image]