Revit 2011 API
UIDocument Members
UIDocument Class Constructors Methods Properties See Also Send Feedback

The UIDocument type exposes the following members.

Constructors

Name | Description
UIDocument | Use a database level Document to construct a UI-level Document.

Methods

Name | Description
Dispose |
PromptForFamilyInstancePlacement | Prompts the user to place instances of the specified FamilySymbol.
RefreshActiveView | Refresh the display of the active view in the active document.
ShowElements | Overloaded. Shows one or more elements by zoom to fit.

Properties

Name | Description
Application | Retrieves an object that represents the current Application.
Document | Returns the database level document represented by this UI-level document.
Selection | Retrieve the currently selected Elements in Autodesk Revit.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace

UIDocument Constructor

[image]