Revit 2011 API
SolidSolidCutUtils..::.RemoveCutBetweenSolids Method
SolidSolidCutUtils Class See Also Send Feedback
Remove the solid-solid cut for the two elements (uncut)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void RemoveCutBetweenSolids(
    Document ADoc,
    Element First,
    Element Second
)
Visual Basic (Declaration)
Public Shared Sub RemoveCutBetweenSolids ( _
    ADoc As Document, _
    First As Element, _
    Second As Element _
)
Visual C++
public:
static void RemoveCutBetweenSolids(
    Document^ ADoc,
    Element^ First,
    Element^ Second
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
The document containing the two elements
First
Type: Autodesk.Revit.DB..::.Element
The solid being cut or the cutting solid
Second
Type: Autodesk.Revit.DB..::.Element
The solid being cut or the cutting solid

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class

SpacingRule Class

[image]