Revit 2011 API
BuiltInFailures..::.RebarSystemFailures Members
BuiltInFailures..::.RebarSystemFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RebarSystemFailures type exposes the following members.

Properties

Name | Description
AreaReinforcementOutSideOfHost | Area Reinforcement is sketched completely outside of its host.
AreaReinforcementRegenFail | Can't regenerate Area Reinforcement.
AreaReinforcementsCollision | Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
BarsTooCloseNumber | Bars are too close together. Decrease the Number Of Lines parameter.
BarsTooCloseSpacing | Bars are too close together. Increase the Maximum Spacing parameter.
BarsTooSparseSpacing | Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.
CannotPlaceAreaReinforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReinforcementWarn | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcementWarn | Can't find a host for Area Reinforcement.
CannotPlacePathReinforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReinforcementWarn | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcementWarn | Can't find a host for Path Reinforcement.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RebarSystemOffset | Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.
ThinHostFloor | Rebar Cover Top and Bottom are too large for host.
ThinHostFloorError | Rebar Cover Top and Bottom are too large for host.
ThinHostWall | Rebar Cover Interior and Exterior are too large for host.
ThinHostWallError | Rebar Cover Interior and Exterior are too large for host.

See Also

BuiltInFailures..::.RebarSystemFailures Class

BuiltInFailures.RebarSystemFailures Properties

[image] [image]