Revit 2011 API
RebarShape..::.SetAllowed Method
RebarShape Class See Also Send Feedback
Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetAllowed(
    RebarBarType barType,
    bool allowed
)
Visual Basic (Declaration)
Public Sub SetAllowed ( _
    barType As RebarBarType, _
    allowed As Boolean _
)
Visual C++
public:
void SetAllowed(
    RebarBarType^ barType,
    bool allowed
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::.RebarBarType
A bar type in the same document as this shape.
allowed
Type: System..::.Boolean
Whether this shape may be combined with barType.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

RebarShape Properties

[image] [image]