Revit 2011 API
EnergyDataSettings..::.ShadeDepth Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double ShadeDepth { get; set; }
Visual Basic (Declaration)
Public Property ShadeDepth As Double
Visual C++
public:
property double ShadeDepth {
    double get ();
    void set (double value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace

SillHeight Property

[image]