Revit 2011 API
Document..::.NewOpening Method (Level, Level, CurveArray)
Document Class See Also Send Feedback
Creates a new shaft opening between a set of levels.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Opening NewOpening(
    Level bottomLevel,
    Level topLevel,
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    bottomLevel As Level, _
    topLevel As Level, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Level^ bottomLevel,
    Level^ topLevel,
    CurveArray^ profile
)

Parameters

bottomLevel
Type: Autodesk.Revit.DB..::.Level
bottom level
topLevel
Type: Autodesk.Revit.DB..::.Level
top level
profile
Type: Autodesk.Revit.DB..::.CurveArray
profile of the opening.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace

NewOpening Method (Wall, XYZ, XYZ)

[image]