Revit 2011 API
Document..::.Mirror Method (ElementId, Reference)
Document Class See Also Send Feedback
Mirrors an element, specified by id, about a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirror(
    ElementId id,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    id As ElementId, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementId^ id,
    Reference^ reference
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The Autodesk::Revit::DB::ElementId^ for the element that is to be mirrored.
reference
Type: Autodesk.Revit.DB..::.Reference
The reference by which the elements will mirror.

Return Value

True if the elements are mirrored successfully.

See Also

Document Class
Mirror Overload

Mirror Method (ElementSet, Line)

[image]