Revit 2011 API
Rebar..::.Quantity Property
Rebar Class See Also Send Feedback
Identifies the number of bars in rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Quantity { get; }
Visual Basic (Declaration)
Public ReadOnly Property Quantity As Integer
Visual C++
public:
property int Quantity {
    int get ();
}

Field Value

The number of bars in rebar set.

Remarks

Quantity is equal to NumberOfBarPositions if IncludeFirstBar and IncludeLastBar are set. If any end bars are excluded, they are not counted in the Quantity.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

RebarShape Property

[image]