Revit 2011 API
Transform Methods
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Methods

Name | Description
AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Multiply | Multiplies this transformation by the specified transformation and returns the result.
OfPoint | Applies the transformation to the point and returns the result.
OfVector | Applies the transform to the vector
ScaleBasis | Scales the basis vectors of this transformation and returns the result.
ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

See Also

Transform Class

AlmostEqual Method

[image]