Revit 2011 API
CompoundStructure..::.Layers Property
CompoundStructure Class See Also Send Feedback
Returns the layers that make up the compound structure of the object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CompoundStructureLayerArray Layers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layers As CompoundStructureLayerArray
Visual C++
public:
property CompoundStructureLayerArray^ Layers {
    CompoundStructureLayerArray^ get ();
}

Remarks

For walls, the layers are ordered from exterior to interior. For floors, the layers are ordered from top to bottom.

See Also

CompoundStructure Class

CompoundStructureDeckUsage Enumeration

[image]