Revit 2011 API
TransactionGroup Class
Members See Also Send Feedback
This class is introduced to group a set of transactions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class TransactionGroup : IDisposable
Visual Basic (Declaration)
Public Class TransactionGroup _
    Implements IDisposable
Visual C++
public ref class TransactionGroup : IDisposable

Remarks

There are three ways to end a transaction group: commit, assimilate, and rollback It is necessary to end all transactions inside the group before ending it

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.TransactionGroup

See Also

TransactionGroup Members

TransactionGroup Members

[image] [image]