Revit 2011 API
RebarShape..::.GetAllRebarShapeParameters Method
RebarShape Class See Also Send Feedback
List all shape parameters used by all the existing RebarShapes in the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static DefinitionsBase GetAllRebarShapeParameters(
    Document doc
)
Visual Basic (Declaration)
Public Shared Function GetAllRebarShapeParameters ( _
    doc As Document _
) As DefinitionsBase
Visual C++
public:
static DefinitionsBase^ GetAllRebarShapeParameters(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::.Document
A Revit document.

Return Value

A list of parameters.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

GetCurvesForBrowser Method

[image]