Revit 2011 API
ItemFactoryBase Class
Members See Also Send Feedback
The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ItemFactoryBase : APIObject
Visual Basic (Declaration)
Public Class ItemFactoryBase _
    Inherits APIObject
Visual C++
public ref class ItemFactoryBase : public APIObject

Remarks

The ItemFactoryBase object is a utility object that is used to create new instances of elements within the Autodesk Revit document. this class hold common methods used in both project document and family document.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.Creation..::.Document
Autodesk.Revit.Creation..::.FamilyItemFactory

See Also

ItemFactoryBase Members
Autodesk.Revit.Creation Namespace

ItemFactoryBase Members

[image] [image]