Revit 2011 API
GeometryObject..::.Visibility Property
GeometryObject Class See Also Send Feedback
The visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Visibility Visibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visibility As Visibility
Visual C++
public:
property Visibility Visibility {
    Visibility get ();
}

Remarks

The visibility of this object has no effect on the visibility of objects contained within this object. For example, the visibility of a Solid may be Contextual but the faces within that solid may still be Visible.

See Also

GeometryObject Class

GeometryObjectArray Class

[image]