Revit 2011 API
AnnotationSymbol..::.AnnotationSymbolType Property
AnnotationSymbol Class See Also Send Feedback
The AnnotationSymbol style of this AnnotationSymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AnnotationSymbolType AnnotationSymbolType { get; set; }
Visual Basic (Declaration)
Public Property AnnotationSymbolType As AnnotationSymbolType
Visual C++
public:
property AnnotationSymbolType^ AnnotationSymbolType {
    AnnotationSymbolType^ get ();
    void set (AnnotationSymbolType^ value);
}

Remarks

The AnnotationSymbolType property can be used to retrieve the kind of the wall. This property can also be used to change the type of an annotation by setting it to a different type. All the annotation symbol types in the project can be found using the Document.AnnotationSymbolTypes property.

See Also

AnnotationSymbol Class

AsFamilyInstance Property

[image]