Revit 2011 API
Rebar..::.SetLayoutAsSingle Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to Single.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutAsSingle()
Visual Basic (Declaration)
Public Sub SetLayoutAsSingle
Visual C++
public:
void SetLayoutAsSingle()

Remarks

Only one bar will remain, which is at the position of rebar plane

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

SetSolidInView Method

[image]