Revit 2011 API
Rebar Members
Rebar Class Methods Properties See Also Send Feedback

The Rebar type exposes the following members.

Methods

Name | Description
IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
ScaleToBox | Move and resize the bar to fit within a specified box.
ScaleToBoxForSpiral | Move and resize a spiral instance to fit within a specified box.
SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.

Properties

Name | Description
ArrayLength | Identifies the distribution path length of rebar set.
BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
BarType | Return the type of the rebar.
BaseFinishingTurns | For a spiral, the number of finishing turns at the lower end of the spiral.
Curves | The centerline of the Rebar.
DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Height | For a spiral, the overall height.
Host | The element that contains the rebar.
IncludeFirstBar | Identifies if the first bar in rebar set is shown.
IncludeLastBar | Identifies if the last bar in rebar set is shown.
IsShownInFrontOfGeometryInView | Obsolete. Control placement of the rebar graphics in the viewing planes.
LayoutRule | Identifies the layout rule of rebar set.
MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
NumberOfBarPositions | Identifies the number of bar positions in rebar set.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Pitch | For a spiral, the pitch, or vertical distance traveled in one rotation.
Quantity | Identifies the number of bars in rebar set.
RebarShape | Get/Set the RebarShape associated with the Rebar.
TopFinishingTurns | For a spiral, the number of finishing turns at the upper end of the spiral.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

Rebar Methods

[image] [image]