Revit 2011 API
TableCellStyle Members
TableCellStyle Class Constructors Methods Properties See Also Send Feedback

The TableCellStyle type exposes the following members.

Constructors

Name | Description
TableCellStyle | Overloaded.

Methods

Name | Description
Dispose |

Properties

Name | Description
BackgroundColor | The back ground color of this cell.
BorderBottomLineStyle | The element id (GraphicsStyle element) for the bottom line of the cell border.
BorderLeftLineStyle | The element id (GraphicsStyle element) for the left line of the cell border.
BorderRightLineStyle | The element id (GraphicsStyle element) for the right line of the cell border.
BorderTopLineStyle | The element id (GraphicsStyle element) for the top line of the cell border.
FontHorizontalAlignment | The horizontal alignment style of text font.
FontName | The font used for this style
FontVerticalAlignment | The vertical alignment style of text font.
IsEnabled | Gets or sets the status whether this cell is enabled.
IsFontBold | Gets or sets whether the text font is set to bold of this cell.
IsFontItalic | Gets or sets whether the text font is set to italic of this cell.
IsFontUnderline | Gets or sets whether the text font is set to Underline of this cell.
IsInactivePhaseload | Gets or sets whether this is an inactive phase load cell.
IsReadOnly | Gets or sets whether this cell is read only.
TextColor | The text color of this cell.
TextOrientation | the orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
TextSize | The text size.

See Also

TableCellStyle Class

TableCellStyle Constructor

[image] [image]