Revit 2011 API
AnalyticalModelSelector Constructor (IList<(Of <(Curve>)>), Int32, AnalyticalCurveSelector)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector based on one portion of a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    IList<Curve> curves,
    int index,
    AnalyticalCurveSelector inCurveSelector
)
Visual Basic (Declaration)
Public Sub New ( _
    curves As IList(Of Curve), _
    index As Integer, _
    inCurveSelector As AnalyticalCurveSelector _
)
Visual C++
public:
AnalyticalModelSelector(
    IList<Curve^>^ curves,
    int index,
    AnalyticalCurveSelector inCurveSelector
)

Parameters

curves
Type: System.Collections.Generic..::.IList <(Of <( Curve >)>)
Analytical Model curves, extracted from analytical model.
index
Type: System..::.Int32
Index of the curve of interest (from within the array of curves).
inCurveSelector
Type: Autodesk.Revit.DB.Structure..::.AnalyticalCurveSelector
Portion of the analytical curve in which the client is interested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | index is not a valid item within curves.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelSelector Methods

[image] [image]