Revit 2011 API
CompoundStructureLayer Class
Members See Also Send Feedback
An object that describes a single layer of multi-layered object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CompoundStructureLayer : APIObject
Visual Basic (Declaration)
Public Class CompoundStructureLayer _
    Inherits APIObject
Visual C++
public ref class CompoundStructureLayer : public APIObject

Remarks

A wall or floor may have several layers. Each layer contains information about its thickness, intended purpose (function), and the material from which it is made.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CompoundStructureLayer

See Also

CompoundStructureLayer Members

CompoundStructureLayer Members

[image] [image]