Revit 2011 API
Materials..::.AddConcrete Method
Materials Class Example See Also Send Feedback
Add a concrete material with the given name .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialConcrete AddConcrete(
    string name
)
Visual Basic (Declaration)
Public Function AddConcrete ( _
    name As String _
) As MaterialConcrete
Visual C++
public:
MaterialConcrete^ AddConcrete(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the concrete material to be added.

Return Value

The pointer to the added concrete material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialConcrete AddConcrete(Document document)
{
    string newName = "myConcreteMaterial";
    MaterialConcrete myConcrete = document.Settings.Materials.AddConcrete(newName);

    if (document.Settings.Materials.Contains(newName) == true)
    {
        TaskDialog.Show("Revit","Concrete material added successfully!");
    }

    return myConcrete;
}
CopyVB.NET
Private Function AddConcrete(ByVal document As Document) As MaterialConcrete
    Dim newName As String = "myConcreteMaterial"
    Dim myConcrete As MaterialConcrete = document.Settings.Materials.AddConcrete(newName)

    If document.Settings.Materials.Contains(newName) = True Then
        TaskDialog.Show("Revit", "Concrete material added successfully!")
    End If

    Return myConcrete
End Function

See Also

Materials Class

AddGeneric Method

[image]