Revit 2011 API
Category Members
Category Class Methods Properties See Also Send Feedback

The Category type exposes the following members.

Methods

Name | Description
GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
SetLineWeight | Sets the line weight for the given graphics style type.

Properties

Name | Description
AllowsBoundParameters | To check if the category can have project parameters.
AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
CanAddSubcategory | Indicates if subcategories can be assigned to the category.
HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Id | Returns the category id associated with the category object.
IsCuttable | Indicates if the category is cuttable or not.
LineColor | The color of lines shown for elements of this category.
Material | Retrieve or change the material of the category.
Name | The category name.
Parent | Returns the parent category of this category.
SubCategories | Returns a map containing all of the subcategories of this category.
Visible | Retrieve or change the visibility of the category in the active view.

See Also

Category Class

Category Methods

[image] [image]