Revit 2011 API
UpdaterRegistry..::.AddTrigger Method (UpdaterId, ElementFilter, ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    ElementFilter filter,
    ChangeType change
)
Visual Basic (Declaration)
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    filter As ElementFilter, _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    ElementFilter^ filter,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id of updater that trigger should be added to
filter
Type: Autodesk.Revit.DB..::.ElementFilter
Element filter that defines elements that affect this trigger
change
Type: Autodesk.Revit.DB..::.ChangeType
ChangeType associated with this trigger

Remarks

This method only works with CategoryFilter and ParameterFilter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- id does not correspond to any registered Updaters
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class
AddTrigger Overload

AddTrigger Method (UpdaterId, Document, ElementFilter, ChangeType)

[image]