Revit 2011 API
Rebar..::.SetLayoutAsNumberWithSpacing Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to NumberWithSpacing

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutAsNumberWithSpacing(
    int numberOfBarPositions,
    double spacing,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)
Visual Basic (Declaration)
Public Sub SetLayoutAsNumberWithSpacing ( _
    numberOfBarPositions As Integer, _
    spacing As Double, _
    barsOnNormalSide As Boolean, _
    includeFirstBar As Boolean, _
    includeLastBar As Boolean _
)
Visual C++
public:
void SetLayoutAsNumberWithSpacing(
    int numberOfBarPositions,
    double spacing,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)

Parameters

numberOfBarPositions
Type: System..::.Int32
The number of bar positions in rebar set
spacing
Type: System..::.Double
The maximum spacing between rebar in rebar set
barsOnNormalSide
Type: System..::.Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar
Type: System..::.Boolean
Identifies if the first bar in rebar set is shown
includeLastBar
Type: System..::.Boolean
Identifies if the last bar in rebar set is shown

Remarks

When changing the layout rule to NumberWithSpacing, you must also simultaneously set NumberOfBarPositions, Spacing, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | The rebar is an instance of a spiral shape and does not support layouts.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | the number of bar positions numberOfBarPositions is less than 1 or more than 100000. -or- The spacing isn't bigger than 0.0.
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

SetLayoutAsSingle Method

[image]