Revit 2011 API
ConnectorType Enumeration
See Also Send Feedback
An enumerated type listing all the connector types for a connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ConnectorType
Visual Basic (Declaration)
Public Enumeration ConnectorType
Visual C++
public enum class ConnectorType

Members

Member name | Description
InvalidConnectorType | Connection Type is Invalid.
EndConn | Connection Type is End Connection.
CurveConn | Connection Type is Curve Connection.
LogicalConn | Connection Type is Logical Connection.
PhysicalConn | Connection Type is Physical Connection.
NonEndConn | Connection Type is Non End Connection.
AllConnectorModes | Connection Type is All Connector Modes.

See Also

Construction Class

[image]