Revit 2011 API
Form..::.Rehost Method (Reference, XYZ)
Form Class See Also Send Feedback
Rehost Form to edge, face or curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Rehost(
    Reference hostRef,
    XYZ location
)
Visual Basic (Declaration)
Public Sub Rehost ( _
    hostRef As Reference, _
    location As XYZ _
)
Visual C++
public:
void Rehost(
    Reference^ hostRef,
    XYZ^ location
)

Parameters

hostRef
Type: Autodesk.Revit.DB..::.Reference
The geometry reference on which to rehost the form.
location
Type: Autodesk.Revit.DB..::.XYZ
The location to which to Rehost the form.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the hostRef or location is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when rehosting Form failed.

See Also

Form Class
Rehost Overload

Rehost Method (SketchPlane, XYZ)

[image]