Revit 2011 API
Parameter Members
Parameter Class Methods Properties See Also Send Feedback

The Parameter type exposes the following members.

Methods

Name | Description
AsDouble | Provides access to the double precision number within the parameter.
AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
AsInteger | Provides access to the integer number within the parameter.
AsString | Provides access to the string contents of the parameter.
AsValueString | Get the parameter value as a string with unit.
Set | Overloaded. Sets the parameter to a new value.
SetValueString | Set the parameter value according to the input string.

Properties

Name | Description
Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
DisplayUnitType | Get the display unit type of the parameter object.
Element | The element to which this parameter belongs.
GUID | The Guid for a shared parameter.
Id | The id of the parameter.
IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::.IsReadOnly.)
IsShared | Identifies if the parameter is a shared parameter.
StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter Class

Parameter Methods

[image] [image]