Revit 2011 API
RebarShapeDefinitionBySegments..::.SetSegmentAs180DegreeBend Method (Int32, Parameter, Boolean)
RebarShapeDefinitionBySegments Class See Also Send Feedback
Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment,
    Parameter radiusParam,
    bool measureToOutsideOfBend
)
Visual Basic (Declaration)
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer, _
    radiusParam As Parameter, _
    measureToOutsideOfBend As Boolean _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
    int iSegment,
    Parameter^ radiusParam,
    bool measureToOutsideOfBend
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
radiusParam
Type: Autodesk.Revit.DB..::.Parameter
A parameter to define the radius. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
measureToOutsideOfBend
Type: System..::.Boolean
Choose between two possibilities for the references of the length dimension. If false, the references is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.

See Also

RebarShapeDefinitionBySegments Class
SetSegmentAs180DegreeBend Overload
Autodesk.Revit.DB.Structure Namespace

SetSegmentFixedDirection Method

[image]