Revit 2011 API
AnalysisDisplayStyle..::.GetElements Method
AnalysisDisplayStyle Class See Also Send Feedback
Returns set of all analysis display styles elements in the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetElements(
    Document cda
)
Visual Basic (Declaration)
Public Shared Function GetElements ( _
    cda As Document _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetElements(
    Document^ cda
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
Document from which analysis display style elements are retrieved.

Return Value

All analysis display style elements existing in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace

GetLegendSettings Method

[image]