Revit 2011 API
FamilyManager..::.Parameter Property (Definition)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    Definition definition
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[Definition^ definition] {
    FamilyParameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.DB..::.Definition

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload

Parameter Property (Guid)

[image]