Revit 2011 API
BuiltInFailures..::.EditingFailures Members
BuiltInFailures..::.EditingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.EditingFailures type exposes the following members.

Properties

Name | Description
AllInvisibleInPlanViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.
AllInvisibleInViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.
BorrowElementsAtRisk | Can't obtain permission to edit the element: The Central File is inaccessible. You can check out worksets at risk, but consider carefully!
CannotBorrowBusyContention | Can't obtain permission to edit the element. The Central File is busy.
CannotCheckoutWorksets | Can't make workset editable. User '[Borrowers]' has already checked it out.
CannotDeleteEditedElement | Can't delete element that is being edited.
CannotDeleteEditedElementError | Can't delete element that is being edited.
CannotDeletePredefinedFamilyElement | Element is a built-in part of the family definition and cannot be deleted or added to groups.
CannotDrawInCurrentView | Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.
CannotDuplicateType | Cannot Duplicate Type
CannotEditDeletedElements | Can't edit the element. It was deleted in the Central File.
CannotEditDeletedWorkset | This action has caused deletion of non-editable Workset ' [Name] '.
CannotEditEditingElements | Can't obtain permission to edit the element: The Central File is inaccessible and another user is editing the element.
CannotEditElements | Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.
CannotEditRenamedWorkset | Can't edit workset ' [Name] '.
CannotMirrorInView | Must specify Work Plane to mirror in a 3d View.
CannotMoveElement | Can't move element.
CannotMoveElementWarn | Can't move element.
CannotMoveElementWithoutWorkplane | No work plane while editing unconstrained element in 3d view.
CannotMoveInView | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveInViewError | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveLocked | Can't move pinned element.
CannotMoveTogether | Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.
CannotRotateLocked | Can't rotate pinned element.
CannotScaleInView | Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.
DeletePreventedByElemArray | Elements managed by Element Arrays can be deleted only if explicitly unlocked.
DeletePreventedByGroup | Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.
ElementNotEditable | One or more elements are not editable.
ElementReversed | Element is reversed.
ElementsDeleted | Elements were deleted.
ElementsDeletedPastedToKeep | Elements were deleted. Use Edit Pasted Elements to keep them.
ElementsNotInPlane | Elements don't lie on the same plane.
ElementsWillBeDeleted | Elements in [Design Option] will be deleted
ExtendToOtherFailure | Can't keep [Type Name] extended to [Type Name].
ExtendToOtherFailureError | Can't keep [Type Name] extended to [Type Name].
GeneratedByMassing | Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated
HaveNoPermissionToEdit | You do not have permission to edit the element.
HiddenBeamsEditingWarning | The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.
InvalidArrayObject | Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).
InvalidElemsInSelection | Can't scale elements together.
LockedByElementArray | Elements managed by Element Arrays are locked by default so that they cannot be moved or deleted inadvertently. To change or delete a managed element unlock it first.
LockedByGroup | Grouped elements are locked so that they cannot be changed inadvertently. To change a group member select the group and then click the Edit Group button on the toolbar, then make the change.
LockedByMassing | To unlock a shell element produced from the massing, change its "Constrain to Massing" property.\nTo unlock all shell elements produced from the massing, tab to the massing and delete it.\n
LockedDeleted | Pinned objects deleted.
LockedDeletedWarn | Pinned objects deleted.
MirrorProjectSuccess | [Action] command has successfully processed [Number] elements
NElementsDeleted | [Number] elements were deleted
NElementsWrongPosition | Review [Number] elements for correct position and shape
NoRotateMirrorZ | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
NoRotateMirrorZError | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
OutOfDateElements | Workset is editable, but you must Reload Latest before editing the element.
OwnedByOther | Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.
OwnElementsOutOfDate | You now own the element, but your file is out of date. You must Reload Latest before editing the element.
PressShowToSee | Press Show to see the element(s); then Ignore or Cancel
ReloadBeforeMakeEditable | You must Reload Latest before editing the element.
ReloadNoGood | You must Reload Latest before editing the element, but the Central File is inaccessible or being accessed by another user.
SourceInEditMode | Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TargetInEditMode | Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TemporaryChangesOutOfDate | You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.
TemporaryChangesTransparentPermissions | Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.
UnableFilletSpecifiedRadius | Unable to create Fillet with the specified radius.
UnableToMakeSourceWorksetEditable | Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.
UnableToTransformElement | Attempted an invalid element rotate, mirror, or move.
UnableToTransformElementError | Attempted an invalid element rotate, mirror, or move.
WorksetHasChangedInCentralFile | This workset has changed in the Central File. Please Reload Latest before making this workset editable.
WorksetNoneditableCozAdvanced | This workset has changed in the Central File. Please Reload Latest before making this workset editable.

See Also

BuiltInFailures..::.EditingFailures Class

BuiltInFailures.EditingFailures Properties

[image] [image]