Revit 2011 API
Document..::.NewTag Method
Document Class Example See Also Send Feedback
Creates a new IndependentTag Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IndependentTag NewTag(
    View dbview,
    Element elemToTag,
    bool addLeader,
    TagMode tagMode,
    TagOrientation tagOrientation,
    XYZ pnt
)
Visual Basic (Declaration)
Public Function NewTag ( _
    dbview As View, _
    elemToTag As Element, _
    addLeader As Boolean, _
    tagMode As TagMode, _
    tagOrientation As TagOrientation, _
    pnt As XYZ _
) As IndependentTag
Visual C++
public:
IndependentTag^ NewTag(
    View^ dbview,
    Element^ elemToTag,
    bool addLeader,
    TagMode tagMode,
    TagOrientation tagOrientation,
    XYZ^ pnt
)

Parameters

dbview
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
elemToTag
Type: Autodesk.Revit.DB..::.Element
The host object of tag.
addLeader
Type: System..::.Boolean
Whether there will be a leader.
tagMode
Type: Autodesk.Revit.DB..::.TagMode
The mode of the tag. Add by Category, add by Multi-Category, or add by material.
tagOrientation
Type: Autodesk.Revit.DB..::.TagOrientation
The orientation of the tag.
pnt
Type: Autodesk.Revit.DB..::.XYZ
The position of the tag.

Return Value

If successful, an IndependentTag object is returned.

Remarks

This method forms a tag relationship to the host object.

Examples

CopyC#
private IndependentTag CreateIndependentTag(Autodesk.Revit.DB.Document document, Wall wall)
{
    // make sure active view is not a 3D view
    Autodesk.Revit.DB.View view = document.ActiveView;

    // define tag mode and tag orientation for new tag
    TagMode tagMode = TagMode.TM_ADDBY_CATEGORY;
    TagOrientation tagorn = TagOrientation.TAG_HORIZONTAL;

    // Add the tag to the middle of the wall
    LocationCurve wallLoc = wall.Location as LocationCurve;
    XYZ wallStart = wallLoc.Curve.get_EndPoint(0);
    XYZ wallEnd = wallLoc.Curve.get_EndPoint(1);
    XYZ wallMid = wallLoc.Curve.Evaluate(0.5, true);

    IndependentTag newTag = document.Create.NewTag(view, wall, true, tagMode, tagorn, wallMid);
    if (null == newTag)
    {
        throw new Exception("Create IndependentTag Failed.");
    }

    // newTag.TagText is read-only, so we change the Type Mark type parameter to
    // set the tag text.  The label parameter for the tag family determines
    // what type parameter is used for the tag text.

    WallType type = wall.WallType;

    Parameter foundParameter = type.get_Parameter("Type Mark");
    bool result = foundParameter.Set("Hello");

    // set leader mode free
    // otherwise leader end point move with elbow point

    newTag.LeaderMode = LeaderEndCondition.LEC_FREE;
    XYZ elbowPnt = wallMid + new XYZ(5.0, 5.0, 0.0);
    newTag.LeaderElbow = elbowPnt;
    XYZ headerPnt = wallMid + new XYZ(10.0, 10.0, 0.0);
    newTag.TagHeadPosition = headerPnt;

    return newTag;
}
CopyVB.NET
Private Function CreateIndependentTag(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall) As IndependentTag
    ' make sure active view is not a 3D view
    Dim view As Autodesk.Revit.DB.View = document.ActiveView

    ' define tag mode and tag orientation for new tag
    Dim tagMode As TagMode = tagMode.TM_ADDBY_CATEGORY
    Dim tagorn As TagOrientation = TagOrientation.TAG_HORIZONTAL

    ' Add the tag to the middle of the wall
    Dim wallLoc As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim wallStart As Autodesk.Revit.DB.XYZ = wallLoc.Curve.EndPoint(0)
    Dim wallEnd As Autodesk.Revit.DB.XYZ = wallLoc.Curve.EndPoint(1)
    Dim wallMid As Autodesk.Revit.DB.XYZ = wallLoc.Curve.Evaluate(0.5, True)

    Dim newTag As IndependentTag = document.Create.NewTag(view, wall, True, tagMode, tagorn, wallMid)
    If newTag Is Nothing Then
        Throw New Exception("Create IndependentTag Failed.")
    End If

    ' newTag.TagText is read-only, so we change the Type Mark type parameter to
    ' set the tag text.  The label parameter for the tag family determines
    ' what type parameter is used for the tag text.

    Dim type As WallType = wall.WallType

    Dim foundParameter As Parameter = type.Parameter("Type Mark")
    Dim result As Boolean = foundParameter.[Set]("Hello")

    ' set leader mode free
    ' otherwise leader end point move with elbow point

    newTag.LeaderMode = LeaderEndCondition.LEC_FREE
    Dim elbowPnt As Autodesk.Revit.DB.XYZ = wallMid + New Autodesk.Revit.DB.XYZ(5, 5, 0)
    newTag.LeaderElbow = elbowPnt
    Dim headerPnt As Autodesk.Revit.DB.XYZ = wallMid + New Autodesk.Revit.DB.XYZ(10, 10, 0)
    newTag.TagHeadPosition = headerPnt

    Return newTag
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewTakeoffFitting Method

[image]