Revit 2011 API
GeometryInstance..::.GetSymbolGeometry Method
GeometryInstance Class See Also Send Feedback
Computes the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryElement GetSymbolGeometry()
Visual Basic (Declaration)
Public Function GetSymbolGeometry As GeometryElement
Visual C++
public:
GeometryElement^ GetSymbolGeometry()

Return Value

An element which contains the computed geometry for the symbol.

Remarks

The geometry will be in the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The results of the method and the value of the SymbolGeometry property are identical.

See Also

GeometryInstance Class
GetSymbolGeometry Overload

GetSymbolGeometry Method (Transform)

[image]