Revit 2011 API
MaterialSet Members
MaterialSet Class Constructors Methods Properties See Also Send Feedback

The MaterialSet type exposes the following members.

Constructors

Name | Description
MaterialSet | Initializes a new instance of the MaterialSet class

Methods

Name | Description
Clear | Removes every material from the set, rendering it empty.
Contains |
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
Size | Returns the number of materials that are in the set.

See Also

MaterialSet Class

MaterialSet Constructor

[image]