Revit 2011 API
ElectricalDemandFactorRule Enumeration
See Also Send Feedback
This enum describes the different demand factor rule types available to the application. Within a demand factor a rule will be referenced and the user will have to enter values corresponding to that rule.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ElectricalDemandFactorRule
Visual Basic (Declaration)
Public Enumeration ElectricalDemandFactorRule
Visual C++
public enum class ElectricalDemandFactorRule

Members

Member name | Description
Constant | This rule will apply a constant demand factor to the loads, regardless of values. It will also be the default for any newly created demand factor, and the default used if a demand factor cannot be found for a load classification.
QuantityTable | This rule will apply the demand factor for the total quantity of attached objects to a panel. It is purely a look-up table. For example, the user can specify that 0 to 2 objects get 100% and 2 to 4 objects get 85% and so on.
LoadTable | This rule will apply the demand factor for the total load of attached objects to a panel. It is purely a look-up table. For example, if there are 5000 kVA, the user can specify 125% value is applied. If there are 20,000 kVA, the user can specify 100% value is applied.
QuantityTablePerPortion | This rule will apply the demand factor differently for each row in the table. For example, the first two (largest) items will have a 125% demand factor applied and the remaining items will have a 75% factor applied.
LoadTablePerPortion | This rule will apply the demand factor differently for each row in the table. For example, the 3000kVA will have a 100% demand factor applied, the next 9000 will have a 35% factor applied, and the remaining items will have a 25% factor applied.

See Also

Autodesk.Revit.DB.Electrical Namespace

ElectricalDemandFactorValue Class

[image]