Revit 2011 API
View..::.Scale Property
View Class See Also Send Feedback
The scale of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Scale { get; set; }
Visual Basic (Declaration)
Public Property Scale As Integer
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

Remarks

The scale is the ratio of true model size to paper size. This property is meaningless for perspective views. When setting the scale if the scale corresponds to a predefined scale, the predefined item will be applied. Otherwise, a custom scale will be applied.

See Also

View Class

SketchPlane Property

[image]