Revit 2011 API
PipingSystem..::.FluidType Property
PipingSystem Class See Also Send Feedback
The system fluid type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FluidType FluidType { get; set; }
Visual Basic (Declaration)
Public Property FluidType As FluidType
Visual C++
public:
property FluidType^ FluidType {
    FluidType^ get ();
    void set (FluidType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when assigning nullNothingnullptra null reference (Nothing in Visual Basic) to fluid type.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace

FluidViscosity Property

[image]