Revit 2011 API
FilteredElementIterator..::.Reset Method
FilteredElementIterator Class See Also Send Feedback
Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class

FilteredElementIterator Properties

[image] [image]