Revit 2011 API
BoundingBoxIntersectsFilter..::.Tolerance Property
BoundingBoxIntersectsFilter Class See Also Send Feedback
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Tolerance { get; set; }
Visual Basic (Declaration)
Public Property Tolerance As Double
Visual C++
public:
property double Tolerance {
    double get ();
    void set (double value);
}

Remarks

By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate. If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.

See Also

BoundingBoxIntersectsFilter Class

BoundingBoxIsInsideFilter Class

[image]