Revit 2011 API
Materials..::.AddWood Method
Materials Class Example See Also Send Feedback
Add a wood material with the given name .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialWood AddWood(
    string name
)
Visual Basic (Declaration)
Public Function AddWood ( _
    name As String _
) As MaterialWood
Visual C++
public:
MaterialWood^ AddWood(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the wood material to be added.

Return Value

The pointer to the added wood material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialWood AddWood(Document document)
{
    string newName = "myWoodMaterial";
    MaterialWood myWood = document.Settings.Materials.AddWood(newName);

    if (null != myWood)
    {
        TaskDialog.Show("Revit","Wood material added successfully!");
    }

    return myWood;
}
CopyVB.NET
Private Function AddWood(ByVal document As Document) As MaterialWood
    Dim newName As String = "myWoodMaterial"
    Dim myWood As MaterialWood = document.Settings.Materials.AddWood(newName)

    If myWood IsNot Nothing Then
        TaskDialog.Show("Revit", "Wood material added successfully!")
    End If

    Return myWood
End Function

See Also

Materials Class

Contains Method

[image] [image]