Revit 2011 API
ParameterFilterRuleFactory Members
ParameterFilterRuleFactory Class Methods See Also Send Feedback

The ParameterFilterRuleFactory type exposes the following members.

Methods

Name | Description
CreateBeginsWithRule | Creates a filter rule that determines whether strings from the document begin with a certain string value.
CreateContainsRule | Creates a filter rule that determines whether strings from the document contain a certain string value.
CreateEndsWithRule | Creates a filter rule that determines whether strings from the document end with a certain string value.
CreateEqualsRule | Overloaded.
CreateGreaterOrEqualRule | Overloaded.
CreateGreaterRule | Overloaded.
CreateLessOrEqualRule | Overloaded.
CreateLessRule | Overloaded.
CreateNotBeginsWithRule | Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
CreateNotContainsRule | Creates a filter rule that determines whether strings from the document do not contain a certain string value.
CreateNotEndsWithRule | Creates a filter rule that determines whether strings from the document do not end with a certain string value.
CreateNotEqualsRule | Overloaded.
CreateSharedParameterApplicableRule | Creates a filter rule that tests elements for support of a shared parameter.
Dispose |

See Also

ParameterFilterRuleFactory Class

ParameterFilterRuleFactory Methods

[image] [image]