Revit 2011 API
Sweep..::.ProfileSketch Property
Sweep Class See Also Send Feedback
The profile sketch of the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sketch ProfileSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProfileSketch As Sketch
Visual C++
public:
property Sketch^ ProfileSketch {
    Sketch^ get ();
}

Remarks

If the profile is not based on sketched curves, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class

ProfileSymbol Property

[image]