Revit 2011 API
SpatialFieldManager..::.RemoveSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback
Removes analysis results container (primitive) identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void RemoveSpatialFieldPrimitive(
    int idx
)
Visual Basic (Declaration)
Public Sub RemoveSpatialFieldPrimitive ( _
    idx As Integer _
)
Visual C++
public:
void RemoveSpatialFieldPrimitive(
    int idx
)

Parameters

idx
Type: System..::.Int32
Unique index identifying the primitive

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | idx refers to non-existent primitive

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace

SetMeasurementNames Method

[image]