Revit 2011 API
SymbolicCurve..::.Subcategory Property
SymbolicCurve Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As GraphicsStyle
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

SymbolicCurve Class

SymbolicCurveArray Class

[image]