Revit 2011 API
UIApplication..::.GetRibbonPanels Method
UIApplication Class See Also Send Feedback
Get all the custom Panels on Add-Ins tab of Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels()
Visual Basic (Declaration)
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()

Remarks

The built-in panels won't be included and the panels added to tabs other than Add-Ins will not be included. This method is not supported in VSTA.

See Also

UIApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace

GetRibbonPanels Method (Tab)

[image]