Revit 2011 API
Transaction..::.RollBack Method (FailureHandlingOptions)
Transaction Class See Also Send Feedback
Rolls back all changes made to the model during the transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus RollBack(
    FailureHandlingOptions options
)
Visual Basic (Declaration)
Public Function RollBack ( _
    options As FailureHandlingOptions _
) As TransactionStatus
Visual C++
public:
TransactionStatus RollBack(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::.FailureHandlingOptions
A set of options to be used for handling eventual failures during this call.

Return Value

If finished successfully, this method returns TransactionStatus::RolledBack

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class
RollBack Overload

SetFailureHandlingOptions Method

[image]