Revit 2011 API
FamilyUtils..::.FamilyCanConvertToFaceHostBased Method
FamilyUtils Class See Also Send Feedback
Indicates whether the family can be converted to face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool FamilyCanConvertToFaceHostBased(
    Document aDoc,
    ElementId famId
)
Visual Basic (Declaration)
Public Shared Function FamilyCanConvertToFaceHostBased ( _
    aDoc As Document, _
    famId As ElementId _
) As Boolean
Visual C++
public:
static bool FamilyCanConvertToFaceHostBased(
    Document^ aDoc,
    ElementId^ famId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::.Document
famId
Type: Autodesk.Revit.DB..::.ElementId

Return Value

True will be returned if the family can be converted to face host based. Otherwise, false will be returned, for example, in the following cases: - There are some instances related to the family in the project. - The operation cannot be applied for some families of certain categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FamilyUtils Class

FBXExportOptions Class

[image]