Revit 2011 API
Document..::.Mirror Method (ElementSet, Line)
Document Class See Also Send Feedback
Mirrors several elements about an arbitrary geometric line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirror(
    ElementSet elements,
    Line line
)
Visual Basic (Declaration)
Public Function Mirror ( _
    elements As ElementSet, _
    line As Line _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementSet^ elements,
    Line^ line
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be mirrored.
line
Type: Autodesk.Revit.DB..::.Line
The line by which the elements will mirror.

Return Value

True if the elements are mirrored successfully.

See Also

Document Class
Mirror Overload

Mirror Method (ElementSet, Reference)

[image]