Revit 2011 API
BoundarySegmentArrayArrayIterator..::.Current Property
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace

BoundarySegmentArrayIterator Class

[image]