Revit 2011 API
Color..::.Red Property
Color Class See Also Send Feedback
Get or set the red channel of the color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public byte Red { get; set; }
Visual Basic (Declaration)
Public Property Red As Byte
Visual C++
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}

Remarks

If the color is read-only, InvalidOperationException will be thrown if trying to set the red channel.

See Also

Color Class

ColorDepthType Enumeration

[image]