Revit 2011 API
RebarShapeDefinition Methods
RebarShapeDefinition Class See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Methods

Name | Description
AddFormulaParameter | Add a formula-driven parameter to the shape definition.
AddParameter | Add a parameter to the shape definition.
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace

AddFormulaParameter Method

[image]