Revit 2011 API
Curve..::.Period Property
Curve Class See Also Send Feedback
The period of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Period { get; }
Visual Basic (Declaration)
Public ReadOnly Property Period As Double
Visual C++
public:
property double Period {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the curve is not cyclic.

See Also

Curve Class

Reference Property

[image]