Revit 2011 API
Solid..::.Volume Property
Solid Class See Also Send Feedback
Returns the signed volume of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Return Value

The real number equal to the signed volume of this solid.

Remarks

Calculates the solid volume by integrating tessellated representations of faces and edges. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this solid is not a valid Geometry object or the volume calculation failed.

See Also

Solid Class

SolidArray Class

[image]