Revit 2011 API
PipingSystem..::.FluidTemperature Property
PipingSystem Class See Also Send Feedback
The system fluid temperature.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double FluidTemperature { get; set; }
Visual Basic (Declaration)
Public Property FluidTemperature As Double
Visual C++
public:
property double FluidTemperature {
    double get ();
    void set (double value);
}

Remarks

Only a fixed set of possible fluid temperatures are permitted by Revit MEP for each system fluid type. Setting this property will map to the nearest appropriate value used internally for the system fluid type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when assigning a value which is not a valid positive number.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace

FluidType Property

[image]