Revit 2011 API
BoundingBoxIsInsideFilter Constructor (Outline, Boolean)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that are contained by it.
inverted
Type: System..::.Boolean
True if the filter should be inverted and match all elements with a bounding box that are not contained by the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload

BoundingBoxIsInsideFilter Constructor (Outline, Double)

[image]