Revit 2011 API
RoofBase..::.SlabShapeEditor Property
RoofBase Class See Also Send Feedback
Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeEditor SlabShapeEditor { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Roofs cannot be attached to another roof, and the roof cannot be a curtain roof. If either of these conditions is not met, the ShapeEditor will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

RoofBase Class

RoofType Class

[image]