Revit 2011 API
Transaction..::.RollBack Method
Transaction Class See Also Send Feedback
Rolls back all changes made to the model during the transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus RollBack()
Visual Basic (Declaration)
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Return Value

If finished successfully, this method returns TransactionStatus::RolledBack

Remarks

By rolling back a transaction, all changes made to the model are discarded. RollBack may only be called for a transaction that has been started. (Use the GetStatus()()() method to check the current state.) Be aware that committing may be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was rolled back successfully. Only after rolling back is completed, the transaction may be started again.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
RollBack Overload

RollBack Method (FailureHandlingOptions)

[image]