Revit 2011 API
Rebar..::.BarsOnNormalSide Property
Rebar Class See Also Send Feedback
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool BarsOnNormalSide { get; set; }
Visual Basic (Declaration)
Public Property BarsOnNormalSide As Boolean
Visual C++
public:
property bool BarsOnNormalSide {
    bool get ();
    void set (bool value);
}

Field Value

True if the bars of rebar set are on the same side of the rebar plane indicated by the normal, and false if the bars are on the opposite side.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

BarType Property

[image]