Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussIsAttachedTo Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
Revit can not attach to the chosen Roof/Slab. The truss can not project to a surface or the attachment creates an invalid profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussIsAttachedTo { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussIsAttachedTo As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussIsAttachedTo {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class

TrussLayoutNonSympleTopChord Property

[image]