Revit 2011 API
RibbonPanel Methods
RibbonPanel Class See Also Send Feedback

The RibbonPanel type exposes the following members.

Methods

Name | Description
AddItem | Adds a Ribbon item to the panel.
AddSeparator | Adds a new Separator to the panel.
AddSlideOut | Adds a slideout to the current panel.
AddStackedItems | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetItems | Gets a copy of the collection of RibbonItems assigned to the RibbonPanel.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace

AddItem Method

[image]