Revit 2011 API
Space Class
Members See Also Send Feedback
Provides access to the space topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Space : Enclosure
Visual Basic (Declaration)
Public Class Space _
    Inherits Enclosure
Visual C++
public ref class Space : public Enclosure

Remarks

The space object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Enclosure
Autodesk.Revit.DB.Mechanical..::.Space

See Also

Space Members
Autodesk.Revit.DB.Mechanical Namespace

Space Members

[image] [image]