Revit 2011 API
CurveElementType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum CurveElementType
Visual Basic (Declaration)
Public Enumeration CurveElementType
Visual C++
public enum class CurveElementType

Members

Member name | Description
Invalid | An invalid curve element type.
ModelCurve | A model curve.
DetailCurve | A detail curve.
SymbolicCurve | A symbolic curve.
ReferenceLine | A reference line.
SpaceSeparation | A space separation curve.
RoomSeparation | An room separation curve.
AreaSeparation | An area separation curve.
CurveByPoints | A curve created by connecting a set of points.
RepeatingDetail | The profile of a repeating detail set.
Insulation | A detail curve representing insulation.
Cloud | A portion of a revision cloud.

See Also

CurveLoopsProfile Class

[image]