Revit 2011 API
Document..::.DocumentSaving Event
Document Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic (Declaration)
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. This document-level event precedes the application-level event of the same name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

Document Class

DocumentSavingAs Event

[image]