Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RampDoesntReachOffset Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RampDoesntReachOffset { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RampDoesntReachOffset As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RampDoesntReachOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class

RampLandingNotCreated Property

[image]