Revit 2011 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

Name | Description
Dispose |
ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
NewProjectDocument | New project document
NewProjectTemplateDocument | New project template document
OpenDocumentFile | Opens a document from disk.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
WriteJournalComment | Writes a comment to the Revit journal file

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

Dispose Method

[image]