Revit 2011 API
Rebar Methods
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Methods

Name | Description
IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
ScaleToBox | Move and resize the bar to fit within a specified box.
ScaleToBoxForSpiral | Move and resize a spiral instance to fit within a specified box.
SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

IsSolidInView Method

[image]