Revit 2011 API
PanelScheduleView Members
PanelScheduleView Class Methods Properties See Also Send Feedback

The PanelScheduleView type exposes the following members.

Methods

Name | Description
AddFontId | adds a unique combination of font name, size, and color within the table view to the font table
CreateInstanceView | Overloaded.
GenerateInstanceFromTemplate | actually assigns the data from the template to the instance also performs any tasks specific to the instance (3rd phase, borders, etc)
GetApparentLoad | get the apparent load for the given phase for the given slotted circuit
GetCellText | gets the cell's text based on its type Row Number in the Section Column Number in the Section
GetCircuitByCell | gets the circuit element for the given slot number Row Number of the Body Section Column Number of the Body Section
GetCircuitIdByCell | gets the circuit id for the given slot number Row Number Column Number
GetCombinedParamValue | Returns the combined parameter text for instance view Row Number of the Section Column Number of the Section
GetFontId | Overloaded.
GetLoadClassificationConnectedCurrent | get the Total Current for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationConnectedLoad | get the Total Load for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandCurrent | get the Demand Current for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandFactor | get the Demand Factor for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandLoad | get the Demand Load for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationId | get the id of the associated LC at the given row Row number of Load Summary Section
GetLoadClassificationName | get the name of the Load Classification at the given row/col Row Number of the Load Summary Section Column number of Load Summary Section
GetLoadClassificationParamValue | Gets the load classification parameter value. Row Number of the Load Summary Section Column number of Load Summary Section
GetPanel | get the panel for this view
GetParamValue | gets the cell's text based on its type Row Number of the Section Column Number of the Section
GetSectionData | gets section data that can be written to
GetSlotNumberByCell | gets the slot number in the circuit table Row Number Column Number
GetTableData | gets table data that can be written to
GetTemplate | get the template for this view (to set the template, you must go through generateInstanceFromTemplate)
IsCellInPhaseLoads | is this cell in the phase loads Row Number Column Number
IsColumnInLoadSummary | is this column in the load summary
IsPanelScheduleTemplate | returns true if this is a panel schedule template, false if it is an instance
IsRowInCircuitTable | is this row in the circuit table
IsSlotGrouped | is the slot in a group? (0 = no, >0 = the group number)
IsSlotLocked | is the circuit slot in this cell locked?
IsSpace | is the selected cell space? Row Number Column Number
IsSpare | is the circuit spare? Circuit Table Row Number Circuit Table Column Number
Print | Overloaded. Print this view.
RefreshAllFontIds | Clean all existing font ids and create all font ids based on the table cell styles
SetParamValue | sets the text for the given cell, returns true if successful, false otherwise Row Number of the Section Column Number of the Section

Properties

Name | Description
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace

PanelScheduleView Methods

[image] [image]