Revit 2011 API
MaterialSteel..::.PoissonModulusY Property
MaterialSteel Class See Also Send Feedback
Get or set the y component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusY { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusY As Double
Visual C++
public:
property double PoissonModulusY {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the y component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class

PoissonModulusZ Property

[image]