Revit 2011 API
FamilyParameter..::.IsReporting Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is a reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsReporting { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReporting As Boolean
Visual C++
public:
property bool IsReporting {
    bool get ();
}

Remarks

If true, the parameter is a reporting parameter associated to a dimension value, and cannot be modified. If false, the parameter is a driving parameter and if associated to a dimension, can modify the dimension it labels.

See Also

FamilyParameter Class

StorageType Property

[image]