Revit 2011 API
IncorrectProductException Class
Members See Also Send Feedback
The exception that is thrown when the function cannot execute in the current product. The exception specifies which product(s) would let the operation succeed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class IncorrectProductException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class IncorrectProductException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class IncorrectProductException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.IncorrectProductException

See Also

IncorrectProductException Members
Autodesk.Revit.Exceptions Namespace

IncorrectProductException Members

[image] [image]