Revit 2011 API
Edge Members
Edge Class Methods Properties See Also Send Feedback

The Edge type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the edge at the parameter.
Evaluate | Evaluates a parameter on the edge.
EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Tessellate | Returns a polyline approximation to the edge.
TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.

Properties

Name | Description
ApproximateLength | Returns the approximate length of the edge.
EndPointReference | Returns a stable reference to the start or the end point of the edge.
Face | Returns one of the two faces that meet at the edge.
Reference | Returns a stable reference to the edge.

See Also

Edge Class

Edge Methods

[image] [image]