Revit 2011 API
Zone..::.Boundary Property
Zone Class See Also Send Feedback
Returns the boundary of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As CurveArray
Visual C++
public:
property CurveArray^ Boundary {
    CurveArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the Zone. Each Zone may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Zone.BoundarySegment object for more details about the segments that make up the Zone topology.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace

CalculatedCoolingLoad Property

[image]