Revit 2011 API
ViewSheet Class
Members Example See Also Send Feedback
A sheet is a view used to prepare a finished printout. It contains other views and a titleblock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewSheet : View
Visual Basic (Declaration)
Public Class ViewSheet _
    Inherits View
Visual C++
public ref class ViewSheet : public View

Examples

CopyC#
private void Getinfo_ViewSheet(ViewSheet viewSheet)
{
    string message = "ViewSheet: ";
    //Get the number of the Sheet
    string sheetNumber = viewSheet.SheetNumber;
    message += "\nSheet Number: " + sheetNumber;

    //Exception occurs when set SheetNumber to a number that isn't unique
    string TestSheetNumber = "My sheet";
    viewSheet.SheetNumber = TestSheetNumber;
    message += "\nSheet Number after set: " + sheetNumber;

    ViewSet views = viewSheet.Views;
    message += "\nNumber of views in the sheet : " + views.Size;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_ViewSheet(ByVal viewSheet As ViewSheet)
    Dim message As String = "ViewSheet: "
    'Get the number of the Sheet
    Dim sheetNumber As String = viewSheet.SheetNumber
    message += vbLf & "Sheet Number: " + sheetNumber

    'Exception occurs when set SheetNumber to a number that isn't unique
    Dim TestSheetNumber As String = "My sheet"
    viewSheet.SheetNumber = TestSheetNumber
    message += vbLf & "Sheet Number after set: " + sheetNumber

    Dim views As ViewSet = viewSheet.Views
    message += vbLf & "Number of views in the sheet : " + views.Size

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.ViewSheet

See Also

ViewSheet Members

ViewSheet Members

[image] [image]