Revit 2011 API
FamilyInstance..::.SuperComponent Property
FamilyInstance Class See Also Send Feedback
Property to get the super component of current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element SuperComponent { get; }
Visual Basic (Declaration)
Public ReadOnly Property SuperComponent As Element
Visual C++
public:
property Element^ SuperComponent {
    Element^ get ();
}

Remarks

When current familyinstance has no super component, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

FamilyInstance Class

Symbol Property

[image]