Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingSweepByElementsInAnotherDesignOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInAnotherDesignOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingSweepByElementsInAnotherDesignOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class

ConfusingSweepByElementsInAnotherDesignOptionWarn Property

[image]