Revit 2011 API
MEPSystem..::.Remove Method
MEPSystem Class See Also Send Feedback
Remove elements from system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Remove(
    ElementSet elements
)
Visual Basic (Declaration)
Public Overridable Sub Remove ( _
    elements As ElementSet _
)
Visual C++
public:
virtual void Remove(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
The elements to be removed from the system.

Remarks

It is forbidden to remove all terminal elements from system. Terminal elements will be removed from the system automatically after removing this system from document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument elements is nullNothingnullptra null reference (Nothing in Visual Basic), or any element in that collection is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when some of the elements can't be removed, or when trying to remove all elements from the system. The element which connect to the base equipment can't be removed,
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the operation failed.

See Also

MEPSystem Class

MEPSystem Properties

[image] [image]