Revit 2011 API
NurbSpline Members
NurbSpline Class Methods Properties See Also Send Feedback

The NurbSpline type exposes the following members.

Methods

Name | Description
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
SetControlPointsAndWeights | Set the control points, weights simultaneously.

Properties

Name | Description
CtrlPoints | Returns the control points of the nurb spline.
Degree | Returns the degree of the nurb spline.
isClosed | Return/set the nurb spline's isClosed property.
isRational | Returns whether the nurb spline is rational or not.
Knots | Return/set the knots of the nurb spline.
Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class

NurbSpline Methods

[image] [image]