Revit 2011 API
ApplicationEntryPoint..::.ViewActivated Event
ApplicationEntryPoint Class See Also Send Feedback
Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewActivatedEventArgs> ViewActivated
Visual Basic (Declaration)
Public Event ViewActivated As EventHandler(Of ViewActivatedEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatedEventArgs^>^ ViewActivated {
    void add (EventHandler<ViewActivatedEventArgs^>^ value);
    void remove (EventHandler<ViewActivatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished activating a view of the document. It is raised even when view activating failed or was cancelled (during ViewActivating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view activating has already been finished.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace

ViewActivating Event

[image]