Revit 2011 API
SpacingRule..::.Number Property
SpacingRule Class See Also Send Feedback
The exact number of lines in the region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Number { get; set; }
Visual Basic (Declaration)
Public Property Number As Integer
Visual C++
public:
property int Number {
    int get ();
    void set (int value);
}

Remarks

This property is only available when Layout is equal to FixedNumber. Lines will be placed exactly at the boundaries if possible, so if your region is 100' long and you specify Number = 11, your lines will be 10' apart. Must be between 1 and 200.

See Also

SpacingRule Class

Offset Property

[image]