Revit 2011 API
Rebar..::.RebarShape Property
Rebar Class See Also Send Feedback
Get/Set the RebarShape associated with the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShape RebarShape { get; set; }
Visual Basic (Declaration)
Public Property RebarShape As RebarShape
Visual C++
public:
property RebarShape^ RebarShape {
    RebarShape^ get ();
    void set (RebarShape^ value);
}

Remarks

When set, the instance will choose values for its shape parameters to try to preserve its previous shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

TopFinishingTurns Property

[image]