Revit 2011 API
RegenerationOption Enumeration
See Also Send Feedback
All regeneration options supported by Revit external commands and external applications.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum RegenerationOption
Visual Basic (Declaration)
Public Enumeration RegenerationOption
Visual C++
public enum class RegenerationOption

Members

Member name | Description
Manual | The API framework will not regenerate after every model level change. Instead, you may use the regeneration APIs to force update of the document after a group of changes. SuspendUpdating blocks are unnecessary and should not be used. Performance of multiple modifications of the Revit document should be faster than RegenerationOption.Automatic. Because this mode suspends all updates to the document, your application should not read data from the document after it has been modified until the document has been regenerated, or it runs the risk of accessing stale data. This mode will be only option in a future release.
Automatic | Obsolete. The API framework will regenerate after every model level change (equivalent behavior with Revit 2010 and earlier). Regeneration and update can be suspended using SuspendUpdating for some operations, but in general the performance of multiple modifications within the same file will be slower than RegenerationOption.Manual. This mode is provided for behavioral equivalence with Revit 2010 and earlier; it is obsolete and will be removed in a future release.

See Also

Autodesk.Revit.Attributes Namespace

TransactionAttribute Class

[image]