Revit 2011 API
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Category | Retrieves a Category object that represents the category or sub category in which the element resides.
DesignOption | Returns the design option to which the element belongs.
Document | Returns the Document in which the Element resides.
Geometry | Retrieves the geometric representation of the element.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic).
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Level | If the element is level based then level to which the element is assigned is returned.
Location | This property is used to find the physical location of an element within a project.
Materials | Get all materials present in the element.
Name | A human readable name for the Element.
ObjectType | Obsolete. Returns the instance type of this object.
OwnerViewId | The id of the view that owns the element.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element.
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
PhaseCreated | An object representing the phase when the element is created.
PhaseDemolished | An object representing the phase for when the element is to be demolished.
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance.
UniqueId | A stable unique identifier for an element within the document.
ViewSpecific | Identifies if the element is owned by a view.

See Also

Element Class

BoundingBox Property

[image]