Revit 2011 API
MassGBXMLExportOptions Constructor
MassGBXMLExportOptions Class See Also Send Feedback
Constructs a new instance of the options used to export a mass model to gbXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassGBXMLExportOptions(
    IList<ElementId> massZoneIds,
    IList<ElementId> massIds
)
Visual Basic (Declaration)
Public Sub New ( _
    massZoneIds As IList(Of ElementId), _
    massIds As IList(Of ElementId) _
)
Visual C++
public:
MassGBXMLExportOptions(
    IList<ElementId^>^ massZoneIds,
    IList<ElementId^>^ massIds
)

Parameters

massZoneIds
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
Indicates the mass zones to analyze in the exported gbXML.
massIds
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
Indicates the masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace

MassGBXMLExportOptions Methods

[image] [image]