Revit 2011 API
PipeType..::.Roughness Property
PipeType Class See Also Send Feedback
The roughness of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override double Roughness { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Roughness As Double
Visual C++
public:
virtual property double Roughness {
    void set (double value) override;
}

Remarks

set for this property will always throw an exception.

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace

PipingSystem Class

[image]