Revit 2011 API
MEPCurve..::.Diameter Property
MEPCurve Class See Also Send Feedback
The diameter of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Diameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Diameter As Double
Visual C++
public:
property double Diameter {
    double get ();
}

Remarks

This property is used to retrieve the diameter of the MEP curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the MEP curve's Shape is not round.

See Also

MEPCurve Class

Height Property

[image]