Revit 2011 API
Document..::.MassDisplayTemporaryOverride Property
Document Class See Also Send Feedback
This setting controls temporary display in views of objects with mass category or subcategories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride { get; set; }
Visual Basic (Declaration)
Public Property MassDisplayTemporaryOverride As MassDisplayTemporaryOverrideType
Visual C++
public:
property MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride {
    MassDisplayTemporaryOverrideType get ();
    void set (MassDisplayTemporaryOverrideType value);
}

Remarks

This setting is temporary and is not stored in the document. The mass display overrides allow mass category and certain mass subcategories to be displayed in all views, regardless of the visibility settings of that view. The settings that show certain mass subcategories will also force the other mass subcategories to be hidden.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: The MassDisplayTemporaryOverrideType::Enum value is not in the proper range.

See Also

Document Class

MechanicalEquipmentTypes Property

[image]