Revit 2011 API
MassSurfaceData..::.PercentageSkylights Property
MassSurfaceData Class See Also Send Feedback
The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double PercentageSkylights { get; set; }
Visual Basic (Declaration)
Public Property PercentageSkylights As Double
Visual C++
public:
property double PercentageSkylights {
    double get ();
    void set (double value);
}

Remarks

The resulting coverage of the roof with skylights is not guaranteed to match this value. It is a target.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace

ReferenceElementId Property

[image]