Revit 2011 API
Materials..::.AddGeneric Method
Materials Class Example See Also Send Feedback
Add a generic material with the given name .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialGeneric AddGeneric(
    string name
)
Visual Basic (Declaration)
Public Function AddGeneric ( _
    name As String _
) As MaterialGeneric
Visual C++
public:
MaterialGeneric^ AddGeneric(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the generic material to be added.

Return Value

The pointer to the added generic material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialGeneric AddGeneric(Document document)
{
    string newName = "myGenericMaterial";
    MaterialGeneric myGeneric = document.Settings.Materials.AddGeneric(newName);

    if (null != myGeneric)
    {
        TaskDialog.Show("Revit","Generic material added successfully!");
    }

    return myGeneric;
}
CopyVB.NET
Private Function AddGeneric(ByVal document As Document) As MaterialGeneric
    Dim newName As String = "myGenericMaterial"
    Dim myGeneric As MaterialGeneric = document.Settings.Materials.AddGeneric(newName)

    If myGeneric IsNot Nothing Then
        TaskDialog.Show("Revit", "Generic material added successfully!")
    End If

    Return myGeneric
End Function

See Also

Materials Class

AddOther Method

[image]