Revit 2011 API
RebarHookType Class
Members See Also Send Feedback
A Rebar Hook type object that is used in the generation of Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarHookType : ElementType
Visual Basic (Declaration)
Public Class RebarHookType _
    Inherits ElementType
Visual C++
public ref class RebarHookType : public ElementType

Remarks

This object contains the definition of the hooks that may be created at the ends of the rebar. The specifics of these hooks are contained within parameters that are accessible from this object. REBAR_HOOK_ANGLE - angle (range 0-PI) between first/last segment of rebar and the straight segment of the hook, REBAR_HOOK_LINE_LEN_FACTOR - a multiplier used to compute the length of the straight segment of the hook. The Length is computed as the bar diameter * the multiplier.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.RebarHookType

See Also

RebarHookType Members
Autodesk.Revit.DB.Structure Namespace

RebarHookType Members

[image] [image]