Revit 2011 API
RibbonButton..::.LargeImage Property
RibbonButton Class See Also Send Feedback
The large image shown on the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageSource LargeImage { get; set; }
Visual Basic (Declaration)
Public Property LargeImage As ImageSource
Visual C++
public:
property ImageSource^ LargeImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button in the Ribbon panel if the button is not a part of a stacked set. It will also be shown if the button is added to a pulldown button. The image should be 32 x 32 pixels. If the image is larger it will be adjusted to fit the button.

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace

RibbonItem Class

[image]