Revit 2011 API
BeamSystem..::.BeamBelongsTo Method
BeamSystem Class See Also Send Feedback
Find out the BeamSystem to which the beam belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static BeamSystem BeamBelongsTo(
    FamilyInstance beam
)
Visual Basic (Declaration)
Public Shared Function BeamBelongsTo ( _
    beam As FamilyInstance _
) As BeamSystem
Visual C++
public:
static BeamSystem^ BeamBelongsTo(
    FamilyInstance^ beam
)

Parameters

beam
Type: Autodesk.Revit.DB..::.FamilyInstance
The beam want to ask.

Return Value

The BeamSystem.

Remarks

Beam is a FamilyInstance.

See Also

BeamSystem Class

DropBeamSystem Method

[image]