Revit 2011 API
Space..::.Boundary Property
Space Class See Also Send Feedback
Returns the boundary of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the Space. Each Space may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Space.BoundarySegment object for more details about the segments that make up the Space topology.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace

CalculatedCoolingLoad Property

[image]