Revit 2011 API
FootPrintRoof..::.Overhang Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the Overhang of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Overhang[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property Overhang ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double Overhang[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::.ModelCurve

Remarks

Only when the FootPrintRoof is created by pick walls, this property makes sense.

See Also

FootPrintRoof Class

Parameter Property

[image] [image]