Revit 2011 API
InSessionViewSheetSet..::.Views Property
InSessionViewSheetSet Class See Also Send Feedback
The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ViewSet Views { get; set; }
Visual Basic (Declaration)
Public Overridable Property Views As ViewSet
Visual C++
public:
virtual property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Implements

IViewSheetSet..::.Views

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

InSessionViewSheetSet Class

Instance Class

[image]