Revit 2011 API
Sweep..::.ProfileSymbol Property
Sweep Class See Also Send Feedback
The family symbol profile details for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolProfile ProfileSymbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProfileSymbol As FamilySymbolProfile
Visual C++
public:
property FamilySymbolProfile^ ProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the profile is not based on a profile family, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class

SweepProfile Class

[image]