Revit 2011 API
Document Members
Document Class Methods Properties Events See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
Array | Overloaded. Creates an array of one or more elements.
ArrayWithoutAssociate | Overloaded. Creates an array of one or more elements where the elements created will not be grouped and associated.
AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Close | Overloaded. Closes the document.
CombineElements | Combine a set of combinable elements into a geometry combination.
ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
Delete | Overloaded. Deletes one or more elements from the document.
Dispose |
EditFamily | Edits a family loaded in the document.
Export | Overloaded. Exports the document to another file format.
ExportImage | Exports a view or set of views into an image file.
FindReferencesByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
GetDocumentPreviewSettings | Returns the preview settings for the given document.
GetRoomAtPoint | Overloaded. Gets a room containing the point.
GetSpaceAtPoint | Overloaded. Gets a space containing the point.
Import | Overloaded. Imports the contents of an external file into the document.
Link | Links a DWG file into the document.
LoadFamily | Overloaded. Loads a family and all its types/symbols.
LoadFamilySymbol | Overloaded. Loads only a specified family type/symbol from a family file into the document.
Mirror | Overloaded. Mirrors one or more elements.
Move | Overloaded. Moves one or more elements within the document by a specified vector.
PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Print | Overloaded. Prints a set of views.
Regenerate | Updates the elements in the Revit document to reflect all changes.
Rotate | Overloaded. Rotates one or more elements within the document by a specified angle around a given axis.
Save | Saves the document.
SaveAs | Overloaded. Saves the document to a new file name.
SaveToProjectAsImage | Creates an image view from the currently active view.
SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.

Properties

Name | Description
ActiveProjectLocation | Retrieve the active project location.
ActiveView | The document's active view.
AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Application | Returns the Application in which the Document resides.
BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
DeckProfiles | Returns an object that contains all of the available deck profiles currently loaded to this project.
DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
DisplayUnitSystem | Provides access to display unit type with in the document.
ElectricalEquipmentTypes | Returns an object that contains all of the available electrical equipment types currently loaded to this project.
Element | Overloaded. Retrieves an element from the document given an identifier.
FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
FamilyManager | The family manager object provides access to family types and parameters.
FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
IsFamilyDocument | Identifies if the current document is a family document.
IsModifiable | The document's state of modifiability.
IsModified | The state of changes made to the document.
IsReadOnly | Identifies if the document is read-only or can possibly be modified
IsReadOnlyFile | Signals whether the document was opened in read-only mode or not.
IsWorkshared | Identifies if worksets have been enabled in the document.
LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
LightingDeviceTypes | Returns an object that contains all of the available lighting device types currently loaded to this project.
LightingFixtureTypes | Returns an object that contains all of the available lighting fixture types currently loaded to this project.
MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
MechanicalEquipmentTypes | Returns an object that contains all of the available mechanical equipment types currently loaded to this project.
MullionTypes | This property is used to retrieve all the mullion types in current system.
OwnerFamily | Get the Family of this Family Document.
PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
PathName | Call this function to get the fully qualified path of the document's disk file.
Phases | Retrieves all the object that represent phases within the project.
PlanTopologies | Overloaded. Gets the PlanTopologies of the current project.
PlanTopology | Overloaded. Gets the PlanTopology of a given level.
PrintManager | Retrieve the PrintManager of current project.
PrintSettings | Retrieve all Print Settings of current project.
ProjectInformation | Return the Project Information of the current project.
ProjectLocations | Retrieve all the project locations associated with this project
ProjectUnit | Provides access to Project Unit Setting with in the document.
ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Settings | Provides access to general application settings, such as Categories.
SiteLocation | Returns the site location information.
SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Title | Call this function to get the project's title, which is usually derived from the project's filename.
TitleBlocks | Titleblocks currently loaded into the document.
TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
TypeOfStorage | Get the storage type of the specified BuiltInParameter.
ViewSheetSets | The view sheet sets stored in the document.
WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
WorksharingCentralFilename | The name and path of the central file name for a workshared document.

Events

Name | Description
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save the document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class

Document Methods

[image] [image]