Revit 2011 API
LocationCurve..::.ElementsAtJoin Property
LocationCurve Class See Also Send Feedback
Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArray ElementsAtJoin[
    int end
] { get; set; }
Visual Basic (Declaration)
Public Property ElementsAtJoin ( _
    end As Integer _
) As ElementArray
Visual C++
public:
property ElementArray^ ElementsAtJoin[int end] {
    ElementArray^ get (int end);
    void set (int end, ElementArray^ value);
}

Parameters

end
Type: System..::.Int32
The end at which the join occurs.

Remarks

The list of elements is expected to be a permutation of the elements already in the join at the end. It is expected that no new elements will be introduced, and existing ones will not be removed.

See Also

LocationCurve Class

JoinType Property

[image]