Revit 2011 API
ControlledApplication..::.LibraryPaths Property
ControlledApplication Class See Also Send Feedback
Retrieves path information for where content is stored on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StringStringMap LibraryPaths { get; set; }
Visual Basic (Declaration)
Public Property LibraryPaths As StringStringMap
Visual C++
public:
property StringStringMap^ LibraryPaths {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

This property is used to control where Autodesk Revit searches for content. The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

Product Property

[image]