Revit 2011 API
TransactionGroup..::.HasStarted Method
TransactionGroup Class See Also Send Feedback
Determines whether the transaction group has ever been started or not

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasStarted()
Visual Basic (Declaration)
Public Function HasStarted As Boolean
Visual C++
public:
bool HasStarted()

Remarks

A test whether a TransactionGroup object started a TransactionGroup at least once. This is set to TRUE after either single-phase construction or after 'start' was called in two-phase construction. Once set to TRUE, it remains TRUE until the object is destroyed.

See Also

TransactionGroup Class

RollBack Method

[image]