Revit 2011 API
Element..::.CanHaveAnalyticalModel Method
Element Class See Also Send Feedback
Indicates whether the Element can have an Analytical Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanHaveAnalyticalModel()
Visual Basic (Declaration)
Public Function CanHaveAnalyticalModel As Boolean
Visual C++
public:
bool CanHaveAnalyticalModel()

Return Value

True if the Element can have an Analytical Model, false otherwise.

See Also

Element Class

CanHaveTypeAssigned Method

[image] [image]