Revit 2011 API
UV Methods
UV Class See Also Send Feedback

The UV type exposes the following members.

Methods

Name | Description
Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
AngleTo | Returns the angle between this vector and the specified vector.
CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Divide | Divides this 2-D vector by the specified value and returns the result.
DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
GetLength | The length of this 2-D vector.
IsAlmostEqualTo | Overloaded.
IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Negate | Negates this 2-D vector.
Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply | Overloaded.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

See Also

UV Class

Add Method

[image]