Revit 2011 API
Element..::.GetChangeTypeElementDeletion Method
Element Class See Also Send Feedback
Returns ChangeType associated with element deletion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeElementDeletion()
Visual Basic (Declaration)
Public Shared Function GetChangeTypeElementDeletion As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeElementDeletion()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on element deletion.

Remarks

ChangeType that can be used to define a trigger for an Updater, Use this change type to trigger an Updater on the deletion of elements from a document. Note: This change type will not trigger on changes caused by Undo and Redo.

See Also

Element Class

GetChangeTypeGeometry Method

[image]