Revit 2011 API
ConnectorElement Class
Members See Also Send Feedback
A base class that provides support for all connector elements occurring in families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ConnectorElement : Element
Visual Basic (Declaration)
Public Class ConnectorElement _
    Inherits Element
Visual C++
public ref class ConnectorElement : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ConnectorElement
Autodesk.Revit.DB.Electrical..::.ElectricalConnector
Autodesk.Revit.DB.Mechanical..::.DuctConnector
Autodesk.Revit.DB.Plumbing..::.PipeConnector

See Also

ConnectorElement Members

ConnectorElement Members

[image] [image]