Revit 2011 API
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view.
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model.
CanHaveTypeAssigned | Overloaded.
ChangeTypeId | Overloaded.
Dispose |
GetAnalyticalModel | Retrieves writeable Analytical Model for Element.
GetChangeTypeAny | Returns ChangeType associated with any change in an element.
GetChangeTypeElementAddition | Returns ChangeType associated with element addition
GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
GetChangeTypeGeometry | summary: Returns ChangeType associated with a change in the geometry of an element
GetChangeTypeParameter | Overloaded.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
GetMaterialArea | Get the area of the given material on this element.
GetMaterialVolume | Get the volume of the given material on this element.
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
GetTypeId | Returns the identifier of this element's type.
GetValidTypes | Overloaded.
IsHidden | Identifies if the element has been permanently hidden in the view.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
IsValidType | Overloaded.

See Also

Element Class

CanBeHidden Method

[image]