Revit 2011 API
Document..::.NewGutter Method (GutterType, ReferenceArray)
Document Class See Also Send Feedback
Creates a gutter along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    references As ReferenceArray _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    ReferenceArray^ references
)

Parameters

GutterType
Type: Autodesk.Revit.DB.Architecture..::.GutterType
The type of the gutter to create
references
Type: Autodesk.Revit.DB..::.ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace

NewLineBoundaryConditions Method

[image] [image]