Revit 2011 API
ObjectType Enumeration
See Also Send Feedback
This enumerated type contains object types allowed to be selected during selection operations.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ObjectType
Visual Basic (Declaration)
Public Enumeration ObjectType
Visual C++
public enum class ObjectType

Members

Member name | Description
Nothing | Nothing.
Element | Whole element.
PointOnElement | Any point on an element (on a face or curve).
Edge | Any model edge.
Face | Any face.

See Also

Autodesk.Revit.UI.Selection Namespace

Selection Class

[image]