Revit 2011 API
AnalyticalModel..::.SetAnalyticalProjectionType Method
AnalyticalModel Class See Also Send Feedback
Sets the analytical model projection to a preset value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic (Declaration)
Public Sub SetAnalyticalProjectionType ( _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
)
Visual C++
public:
void SetAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction to project Analytical Model.
projectionType
Type: Autodesk.Revit.DB.Structure..::.AnalyticalProjectionType
Preset value for Analytical Model projection.

Remarks

This should be used if setting the analytical model projection to something other than a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for analytical model -or- The analytical model does not provide projectionType for the direction

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

SetAnalyzeAs Method

[image]