Revit 2011 API
AddInId Members
AddInId Class Constructors Methods See Also Send Feedback

The AddInId type exposes the following members.

Constructors

Name | Description
AddInId | creates an AddInId object with a given GUID

Methods

Name | Description
Dispose |
GetAddInName | name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
GetAddInNameFromDocument | name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
GetGUID | value of the AddInId as a GUID

See Also

AddInId Class

AddInId Constructor

[image]