Revit 2011 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

Name | Description
ActiveProjectLocation | Retrieve the active project location.
ActiveView | The document's active view.
AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Application | Returns the Application in which the Document resides.
BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
DeckProfiles | Returns an object that contains all of the available deck profiles currently loaded to this project.
DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
DisplayUnitSystem | Provides access to display unit type with in the document.
ElectricalEquipmentTypes | Returns an object that contains all of the available electrical equipment types currently loaded to this project.
Element | Overloaded. Retrieves an element from the document given an identifier.
FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
FamilyManager | The family manager object provides access to family types and parameters.
FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
IsFamilyDocument | Identifies if the current document is a family document.
IsModifiable | The document's state of modifiability.
IsModified | The state of changes made to the document.
IsReadOnly | Identifies if the document is read-only or can possibly be modified
IsReadOnlyFile | Signals whether the document was opened in read-only mode or not.
IsWorkshared | Identifies if worksets have been enabled in the document.
LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
LightingDeviceTypes | Returns an object that contains all of the available lighting device types currently loaded to this project.
LightingFixtureTypes | Returns an object that contains all of the available lighting fixture types currently loaded to this project.
MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
MechanicalEquipmentTypes | Returns an object that contains all of the available mechanical equipment types currently loaded to this project.
MullionTypes | This property is used to retrieve all the mullion types in current system.
OwnerFamily | Get the Family of this Family Document.
PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
PathName | Call this function to get the fully qualified path of the document's disk file.
Phases | Retrieves all the object that represent phases within the project.
PlanTopologies | Overloaded. Gets the PlanTopologies of the current project.
PlanTopology | Overloaded. Gets the PlanTopology of a given level.
PrintManager | Retrieve the PrintManager of current project.
PrintSettings | Retrieve all Print Settings of current project.
ProjectInformation | Return the Project Information of the current project.
ProjectLocations | Retrieve all the project locations associated with this project
ProjectUnit | Provides access to Project Unit Setting with in the document.
ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Settings | Provides access to general application settings, such as Categories.
SiteLocation | Returns the site location information.
SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Title | Call this function to get the project's title, which is usually derived from the project's filename.
TitleBlocks | Titleblocks currently loaded into the document.
TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
TypeOfStorage | Get the storage type of the specified BuiltInParameter.
ViewSheetSets | The view sheet sets stored in the document.
WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
WorksharingCentralFilename | The name and path of the central file name for a workshared document.

See Also

Document Class

ActiveProjectLocation Property

[image]