Revit 2011 API
MaterialWood..::.CompressionParallel Property
MaterialWood Class See Also Send Feedback
Get or set the compression parallel to grain of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CompressionParallel { get; set; }
Visual Basic (Declaration)
Public Property CompressionParallel As Double
Visual C++
public:
property double CompressionParallel {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the compression parallel to grain to an invalid value.

See Also

MaterialWood Class

CompressionPerpendicular Property

[image]