Revit 2011 API
ApplicationEntryPoint Properties
ApplicationEntryPoint Class See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ActiveUIDocument | Provides access to an object that represents the currently active project.
AddinFolder | The full path to the Revit VSTA module.
Application | Returns the database level Application represented by this UI level Application.
DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
LoadedApplications | Returns an array of successfully loaded external applications.
MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace

ActiveAddInId Property

[image]