Revit 2011 API
Materials..::.Item Property (String)
Materials Class Example See Also Send Feedback
Gets the material with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Material Item[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    name As String _
) As Material
Visual C++
public:
property Material^ Item[String^ name] {
    Material^ get (String^ name);
}

Parameters

name
Type: System..::.String
The name of the material to be found.

Remarks

If the material with the specified name does not exist, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

Examples

CopyC#
Materials materials = document.Settings.Materials;
Material floorMaterial = null;
string floorMaterialName = "Default Floor";
floorMaterial = materials.get_Item(floorMaterialName);
if (null != floorMaterial)
{
    TaskDialog.Show("Revit","Material found.");
}
CopyVB.NET
Dim materials As Materials = document.Settings.Materials
Dim floorMaterial As Material = Nothing
Dim floorMaterialName As String = "Default Floor"
floorMaterial = materials.Item(floorMaterialName)
If floorMaterial IsNot Nothing Then
    TaskDialog.Show("Revit", "Material found.")
End If

See Also

Materials Class
Item Overload

MaterialSet Class

[image]