Revit 2011 API
CurveElement..::.LineStyle Property
CurveElement Class See Also Send Feedback
The line style of this curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element LineStyle { get; set; }
Visual Basic (Declaration)
Public Property LineStyle As Element
Visual C++
public:
property Element^ LineStyle {
    Element^ get ();
    void set (Element^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed. Thrown when fail to get line style.

See Also

CurveElement Class

LineStyles Property

[image]