Revit 2011 API
CurtainGridLine..::.AllSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve the curves of all segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray AllSegmentCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ AllSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and then call the method AddSegment() or RemoveSegment() to add/remove specified segments. If the specified segment is already added/removed, nothing will happen.

See Also

CurtainGridLine Class

ExistingSegmentCurves Property

[image]