Revit 2011 API
RevitAPIEventArgs..::.IsCancellable Method
RevitAPIEventArgs Class See Also Send Feedback
Indicates whether an event may be cancelled by an event delegate.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsCancellable()
Visual Basic (Declaration)
Public Function IsCancellable As Boolean
Visual C++
public:
bool IsCancellable()

Remarks

If IsCancellable() returns true, event delegates may cancel the command that was announced by the event. To do so, a delegate may call the Cancel() method if it is available. Typically, single-events and post-events (e.g. DocumentPrinted) are not cancellable, while most pre-events (e.g. DocumentPrinting) are cancellable, except for special conditions and situations, such as when the Revit application is being closed or if an event is raised during another event.

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace

IsCancelled Method

[image]