Revit 2011 API
BoundaryConditions Members
BoundaryConditions Class Methods Properties See Also Send Feedback

The BoundaryConditions type exposes the following members.

Methods

Name | Description
associateWithLoad | Sets the Autodesk::Revit::DB::ElementId^ of Load to associate.

Properties

Name | Description
AssociatedLoad | Retrieve the AssociatedLoad.
Curve | Returns the geometric curve within a geometric loop that defines the area.
HostElement | Retrieve the HostElementId.
NumCurves | Returns the number of curves represent the Boundary Conditions Element.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Point | If successful, returns the point represents Boundary Conditions.

See Also

BoundaryConditions Class

BoundaryConditions Methods

[image] [image]