Revit 2011 API
Curve Members
Curve Class Methods Properties See Also Send Feedback

The Curve type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve.
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Distance | Returns the shortest distance from the specified point to this curve.
Evaluate | Evaluates a parameter on the curve.
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values.
MakeUnbound | Makes this curve unbound.
Project | Projects the specified point on this curve.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.

Properties

Name | Description
ApproximateLength | The approximate length of the curve.
EndParameter | The parameter of the start or the end point of the curve.
EndPoint | The start or the end point of this curve.
EndPointReference | Returns a stable reference to the start point or the end point of the curve.
IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
IsCyclic | The boolean value that indicates whether this curve is cyclic.
Length | The exact length of the curve.
Period | The period of this curve.
Reference | Returns a stable reference to the curve.
Transformed | Applies the specified transformation to this curve and returns the result.

See Also

Curve Class

Curve Methods

[image] [image]