Revit 2011 API
SynchronizeWithCentralOptions Properties
SynchronizeWithCentralOptions Class See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Properties

Name | Description
CompactCentralFile | Indicates whether Revit should compact the central file while synchronizing with central. This option reduces the size of the central file but many increase the time it takes to perform the save.
RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created worksets after synchronizing with central.
RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
SaveLocalFile | Indicates whether Revit should save the local file before and after synchronizing with central.

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace

CompactCentralFile Property

[image]