Revit 2011 API
Map..::.Item Property
Map Class See Also Send Feedback
Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Item[
    Object key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As Object _
) As Object
Visual C++
public:
virtual property Object^ Item[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}

Parameters

key
Type: System..::.Object
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

Map Class
Autodesk.Revit.Collections Namespace

Size Property

[image]