Revit 2011 API
Parameter..::.AsElementId Method
Parameter Class See Also Send Feedback
Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId AsElementId()
Visual Basic (Declaration)
Public Function AsElementId As ElementId
Visual C++
public:
ElementId^ AsElementId()

Return Value

The Autodesk::Revit::DB::ElementId^ contained in the parameter.

Remarks

The AsAutodesk::Revit::DB::ElementId^ method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.

See Also

Parameter Class

AsInteger Method

[image]