Revit 2011 API
Rebar..::.Pitch Property
Rebar Class See Also Send Feedback
For a spiral, the pitch, or vertical distance traveled in one rotation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Pitch { get; set; }
Visual Basic (Declaration)
Public Property Pitch As Double
Visual C++
public:
property double Pitch {
    double get ();
    void set (double value);
}

Remarks

Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The rebar is not an instance of a spiral shape.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: pitch must be positive.
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

Quantity Property

[image]