Revit 2011 API
HermiteSpline Members
HermiteSpline Class Methods Properties See Also Send Feedback

The HermiteSpline type exposes the following members.

Methods

Name | Description
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.

Properties

Name | Description
ControlPoints | The control points of the Hermite spline.
IsPeriodic | Returns whether the Hermite spline is periodic or not.
Parameters | Returns the params of the Hermite spline.
Tangents | Returns the tangents of the Hermite spline.

See Also

HermiteSpline Class

HermiteSpline Methods

[image] [image]