Revit 2011 API
Document..::.SaveAs Method
Document Class See Also Send Feedback
Saves the document to a file name obtained from the Revit user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SaveAs()
Visual Basic (Declaration)
Public Function SaveAs As Boolean
Visual C++
public:
bool SaveAs()

Return Value

False if save operation fails. Also returns False if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, True is returned.

Remarks

Because the argument list is null, a SaveAs dialog will be shown to query the file name.

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
SaveAs Overload

SaveAs Method (String)

[image]