Revit 2011 API
CurveElement..::.GeometryCurve Property
CurveElement Class See Also Send Feedback
Geometry curve of the curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve GeometryCurve { get; set; }
Visual Basic (Declaration)
Public Property GeometryCurve As Curve
Visual C++
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

Because there are no corresponding geometry curve type for HermiteSpline, for this type only general Autodesk::Revit::DB::Curve object will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when try to set a curve of different type.

See Also

CurveElement Class

LineStyle Property

[image]