Revit 2011 API
DimensionSegment..::.IsLocked Property
DimensionSegment Class See Also Send Feedback
Indicates if this segment is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic (Declaration)
Public Property IsLocked As Boolean
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Remarks

This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the segment has been labeled, or the dimension shape is a radial or spot dimension.

See Also

DimensionSegment Class

Origin Property

[image]