Revit 2011 API
MEPCurve..::.ReferenceLevel Property
MEPCurve Class See Also Send Feedback
The reference level of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Level ReferenceLevel { get; set; }
Visual Basic (Declaration)
Public Property ReferenceLevel As Level
Visual C++
public:
property Level^ ReferenceLevel {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to retrieve the reference level of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's reference level.

See Also

MEPCurve Class

Width Property

[image]