Revit 2011 API
SpatialFieldManager..::.GetSpatialFieldManager Method
SpatialFieldManager Class See Also Send Feedback
Retrieves manager object for the given view or returns NULL

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static SpatialFieldManager GetSpatialFieldManager(
    View view
)
Visual Basic (Declaration)
Public Shared Function GetSpatialFieldManager ( _
    view As View _
) As SpatialFieldManager
Visual C++
public:
static SpatialFieldManager^ GetSpatialFieldManager(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
View for which manager object is retrieved

Return Value

Manager object for the view passed in the argument

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace

RemoveSpatialFieldPrimitive Method

[image]