Revit 2011 API
Parameter..::.GUID Property
Parameter Class See Also Send Feedback
The Guid for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Guid GUID { get; }
Visual Basic (Declaration)
Public ReadOnly Property GUID As Guid
Visual C++
public:
property Guid GUID {
    Guid get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the parameter is not a shared parameter.

See Also

Parameter Class

Id Property

[image]