Revit 2011 API
IConnector..::.Shape Property
IConnector Interface See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
ReadOnly Property Shape As ConnectorProfileType
Visual C++
property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Remarks

This property is used to retrieve the shape of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Throw when this connector has no shape.

See Also

IConnector Interface

Width Property

[image]