Revit 2011 API
ConceptualConstructionFloorSlabType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Floors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum ConceptualConstructionFloorSlabType
Visual Basic (Declaration)
Public Enumeration ConceptualConstructionFloorSlabType
Visual C++
public enum class ConceptualConstructionFloorSlabType

Members

Member name | Description
InvalidFloorSlabTypeConstruction | Invalid/not set Floor or Slab Type construction value
LightweightConstructionHighInsulation | Lightweight Consruction High Insulation Floor
LightweightConstructionTypicalInsulation | Lightweight Construction Typical Insulation Floor
LightweightConstructionLowInsulation | Lightweight Construction Low Insulation Floor
LightweightConstructionNoInsulationInterior | Lighweight Construction No Insulatoin Interior Floor
HighMassConstructionFrigidClimateSlabInsulation | High Mass Construction Frigid Climate Insulation Slab
HighMassConstructionColdClimateSlabInsulation | High Mass Construction Cold Climate Insulation Slab
HighMassConstructionTypicalNoInsulation | High Mass Construction Typical No Insulation Slab
NumFloorSlabTypeConstruction | Total number of Floor/Slab Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace

ConceptualConstructionOpeningType Enumeration

[image]