Revit 2011 API
MassLevelData Properties
MassLevelData Class See Also Send Feedback

The MassLevelData type exposes the following members.

Properties

Name | Description
ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData.
ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData is synchronized with the EnergyDataSettings or if it overrides those settings.
LevelId | The ElementId of the level that the MassLevelData is associated with.
MaterialId | The ElementId of the visualization material used for the MassLevelData
MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData to the next in the mass.
NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
NVolume | The volume of from the level of this MassLevelData to the next in the mass.
OwningMassId | The ElementId of the mass that the MassLevelData is associated with.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace

ConceptualConstructionId Property

[image]