Revit 2011 API
SiteLocation..::.Latitude Property
SiteLocation Class See Also Send Feedback
The latitude of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Latitude { get; set; }
Visual Basic (Declaration)
Public Property Latitude As Double
Visual C++
public:
property double Latitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the latitude of the site location. The value of this property is in radians between +PI/2 and -PI/2.

When setting this property:

  1. Revit will attempt to match the coordinates to a city it knows about, and if a match is found, will set the name accordingly.
  2. Revit will not attempt to automatically adjust the time zone value to match the new Latitude value set. You can set the TimeZone property directly to the correct value if necessary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value out of the permitted range.

See Also

SiteLocation Class

Longitude Property

[image]