Revit 2011 API
ConnectorProfileType Enumeration
See Also Send Feedback
An enumerated type listing all the connector profile types for a connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ConnectorProfileType
Visual Basic (Declaration)
Public Enumeration ConnectorProfileType
Visual C++
public enum class ConnectorProfileType

Members

Member name | Description
InvalidProfile | Connection Profile Type is Invalid.
RoundProfile | Connection Profile Type is Round.
RectProfile | Connection Profile Type is Rect.
OvalProfile | Connection Profile Type is Oval.

See Also

ConnectorSet Class

[image]