Revit 2011 API
RebarShape Methods
RebarShape Class See Also Send Feedback

The RebarShape type exposes the following members.

Methods

Name | Description
GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

GetAllowed Method

[image]