Revit 2011 API
Document..::.NewBeamSystem Method (CurveArray)
Document Class Example See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
The profile is the profile of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

Examples

CopyC#
// Build a profile for the beam system creation
XYZ first = new XYZ(0, 0, 0);
XYZ second = new XYZ(40, 0, 0);
XYZ third = new XYZ(40, 25, 0);
XYZ fourth = new XYZ(0, 25, 0);
CurveArray profile = new CurveArray();
profile.Append(Line.get_Bound(first, second));
profile.Append(Line.get_Bound(second, third));
profile.Append(Line.get_Bound(third, fourth));
profile.Append(Line.get_Bound(fourth, first));

// Create a beam system
BeamSystem beamSystem = document.Create.NewBeamSystem(profile);
if (null != beamSystem)
{
    // Change some properties, such as elevation
    Parameter elevationPara = beamSystem.get_Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM);
    if (null != elevationPara)
    {
        elevationPara.Set(10.0);
    }
}
CopyVB.NET
' Build a profile for the beam system creation
Dim first As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim second As New Autodesk.Revit.DB.XYZ(40, 0, 0)
Dim third As New Autodesk.Revit.DB.XYZ(40, 25, 0)
Dim fourth As New Autodesk.Revit.DB.XYZ(0, 25, 0)
Dim profile As New CurveArray()
profile.Append(Line.Bound(first, second))
profile.Append(Line.Bound(second, third))
profile.Append(Line.Bound(third, fourth))
profile.Append(Line.Bound(fourth, first))

' Create a beam system
Dim beamSystem As BeamSystem = document.Create.NewBeamSystem(profile)
If beamSystem IsNot Nothing Then
    ' Change some properties, such as elevation
    Dim elevationPara As Parameter = beamSystem.Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM)
    If elevationPara IsNot Nothing Then
        elevationPara.[Set](10)
    End If
End If

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace

NewBeamSystem Method (CurveArray, XYZ)

[image]