Revit 2011 API
FilteredElementCollector Members
FilteredElementCollector Class Constructors Methods See Also Send Feedback

The FilteredElementCollector type exposes the following members.

Constructors

Name | Description
FilteredElementCollector | Overloaded.

Methods

Name | Description
ContainedInDesignOption | Applies an ElementDesignOptionFilter to the collector.
Dispose |
Excluding | Applies an ExclusionFilter to the collector.
FirstElement | Returns the first element to pass the filter(s).
FirstElementId | Returns the id of the first element to pass the filter(s).
GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
GetElementIdIterator | Returns an element id iterator to the elements passing the filters.
GetElementIterator | Returns an element iterator to the elements passing the filters.
GetEnumerator | Returns an enumerator that iterates through the collection.
IntersectWith | Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
IsViewValidForElementIteration | Identifies if the particular element is valid for iteration of drawn elements.
OfCategory | Applies an ElementCategoryFilter to the collector.
OfCategoryId | Applies an ElementCategoryFilter to the collector.
OfClass | Applies an ElementClassFilter to the collector.
OwnedByView | Applies an ElementOwnerViewFilter to the collector.
ToElementIds | Returns the complete set of element ids which pass the filter(s).
ToElements | Returns the complete set of elements which pass the filter(s).
UnionWith | Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
WhereElementIsCurveDriven | Applies an ElementIsCurveDrivenFilter to the collector.
WhereElementIsElementType | Applies an ElementIsElementTypeFilter to the collector.
WhereElementIsNotElementType | Applies an inverted ElementIsElementTypeFilter to the collector.
WhereElementIsViewIndependent | Applies an ElementOwnerViewFilter to the collector.
WherePasses | Applies an element filter to the collector.

See Also

FilteredElementCollector Class

FilteredElementCollector Constructor

[image] [image]