Revit 2011 API
MEPCurveType Class
Members See Also Send Feedback
A curve type for duct type or pipe type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MEPCurveType : ElementType
Visual Basic (Declaration)
Public Class MEPCurveType _
    Inherits ElementType
Visual C++
public ref class MEPCurveType : public ElementType

Remarks

The curve type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Electrical..::.CableTrayType
Autodesk.Revit.DB.Electrical..::.ConduitType
Autodesk.Revit.DB.Mechanical..::.DuctType
Autodesk.Revit.DB.Mechanical..::.FlexDuctType
Autodesk.Revit.DB.Plumbing..::.FlexPipeType
Autodesk.Revit.DB.Plumbing..::.PipeType

See Also

MEPCurveType Members

MEPCurveType Members

[image] [image]