Revit 2011 API
Transaction..::.Commit Method
Transaction Class See Also Send Feedback
Commits all changes made to the model during the transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus Commit()
Visual Basic (Declaration)
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus::Committed

Remarks

By committing a transaction, all changes made to the model during the transaction are accepted. A new undo item will appear in the Undo menu in Revit, which allows the user to undo the changes. The undo item will have this transaction's name. Commit may only be called for a transaction that has been started. (Use the GetStatus()()() method to check the current state.) Be aware that committing may fail or can be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was committed successfully. Only after a transaction is successfully committed (or rolled back as a result of handling transaction failures), it may be started again.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
Commit Overload

Commit Method (FailureHandlingOptions)

[image]