Revit 2011 API
DefinitionsBase Members
DefinitionsBase Class Constructors Methods Properties See Also Send Feedback

The DefinitionsBase type exposes the following members.

Constructors

Name | Description
DefinitionsBase | Initializes a new instance of the DefinitionsBase class

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty.
Contains | Tests for the existence of a definition within the set.
Erase | Removes a specified definition from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
Insert | Insert the specified definition into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
Size | Returns the number of definitions that are in the set.

See Also

DefinitionsBase Class

DefinitionsBase Constructor

[image]