Revit 2011 API
Document..::.Import Method (String, DWGImportOptions, Element%)
Document Class See Also Send Feedback
Imports a DWG file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Import(
    string file,
    DWGImportOptions options,
    out Element element
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As DWGImportOptions, _
    <OutAttribute> ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    DWGImportOptions^ options,
    [OutAttribute] Element^% element
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit.DB..::.DWGImportOptions
Various options applicable to the DWG format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
element
Type: Autodesk.Revit.DB..::.Element %
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when importing into 3D view but ThisViewOnly property is set to True in options. Thrown when the file to be imported is not an existing DWG file.

See Also

Document Class
Import Overload

Import Method (String, ImageImportOptions, Element)

[image]