Revit 2011 API
AnalyticalModelSelector..::.IsValidIndex Method
AnalyticalModelSelector Class See Also Send Feedback
Indicates whether index is valid in array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidIndex(
    IList<Curve> curves,
    int index
)
Visual Basic (Declaration)
Public Function IsValidIndex ( _
    curves As IList(Of Curve), _
    index As Integer _
) As Boolean
Visual C++
public:
bool IsValidIndex(
    IList<Curve^>^ curves,
    int index
)

Parameters

curves
Type: System.Collections.Generic..::.IList <(Of <( Curve >)>)
The analytical model curves.
index
Type: System..::.Int32
The index to check for validity.

Return Value

True if index is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelSelector Properties

[image] [image]