Revit 2011 API
IncorrectProductException..::.GetObjectData Method
IncorrectProductException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

IncorrectProductException Class
Autodesk.Revit.Exceptions Namespace

IncorrectProductException Properties

[image] [image]