Revit 2011 API
Document..::.ArrayWithoutAssociate Method (ICollection<(Of <(ElementId>)>), Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of several elements, specified by id, using a specified angle where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ICollection<ElementId> elementIds,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elementIds As ICollection(Of ElementId), _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ICollection<ElementId^>^ elementIds,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of ids for elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
ArrayWithoutAssociate Overload

AutoJoinElements Method

[image]