Revit 2011 API
ModelText..::.Text Property
ModelText Class See Also Send Feedback
The text string in the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is assigned to text.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is assigned to text.

See Also

ModelText Class

ModelTextType Class

[image]