Revit 2011 API
BeamSystem..::.DropBeamSystem Method
BeamSystem Class See Also Send Feedback
Drop beam system, it will disassociate all members from the beam system and delete the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static void DropBeamSystem(
    BeamSystem beamSystem
)
Visual Basic (Declaration)
Public Shared Sub DropBeamSystem ( _
    beamSystem As BeamSystem _
)
Visual C++
public:
static void DropBeamSystem(
    BeamSystem^ beamSystem
)

Parameters

beamSystem
Type: Autodesk.Revit.DB..::.BeamSystem
The beam system to be deleted.

See Also

BeamSystem Class

GetAllBeams Method

[image]