Revit 2011 API
Document..::.Move Method (ElementId, XYZ)
Document Class See Also Send Feedback
Moves an element, specified by id, within the document by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Move(
    ElementId id,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    id As ElementId, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ElementId^ id,
    XYZ^ translationVec
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The Autodesk::Revit::DB::ElementId^ for the element that is to be moved.
translationVec
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the element is to be moved.

Return Value

True if the element is moved successfully, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved. For example, if the element is wall and it contains windows, the windows will also move.

See Also

Document Class
Move Overload

Move Method (ElementSet, XYZ)

[image]