Revit 2011 API
ControlledApplication..::.DocumentClosed Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentClosedEventArgs> DocumentClosed
Visual Basic (Declaration)
Public Event DocumentClosed As EventHandler(Of DocumentClosedEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosedEventArgs^>^ DocumentClosed {
    void add (EventHandler<DocumentClosedEventArgs^>^ value);
    void remove (EventHandler<DocumentClosedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The closed document cannot be modified, in fact, user has no way to access it in the event handler.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

DocumentClosing Event

[image]