Revit 2011 API
MassEnergyAnalyticalModel..::.MassZoneCoreOffset Property
MassEnergyAnalyticalModel Class See Also Send Feedback
If this value is greater than 0.0, in the MassEnergyAnalytical model a building "core" geometry will be created for each solid geometry of the mass instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double MassZoneCoreOffset { get; set; }
Visual Basic (Declaration)
Public Property MassZoneCoreOffset As Double
Visual C++
public:
property double MassZoneCoreOffset {
    double get ();
    void set (double value);
}

Remarks

The resulting "core" geometry created inside the mass instance solid geometry is offset inwards at each level intersecting the mass instance solid geometry by the value of the offset. This "core" geometry is automatically cut from its parent mass instance geometry in the MassEnergyAnalyticalModel.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace

Parameter Property

[image] [image]