Revit 2011 API
ConceptualSurfaceType..::.DefaultConstructionTypeId Property
ConceptualSurfaceType Class See Also Send Feedback
The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId DefaultConstructionTypeId { get; set; }
Visual Basic (Declaration)
Public Property DefaultConstructionTypeId As ElementId
Visual C++
public:
property ElementId^ DefaultConstructionTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace

MassSubCategoryId Property

[image]