Revit 2011 API
FamilyInstance Methods
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam.
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
FlipFromToRoom | Change the room to which the door or window is opened.
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
GetCopings | Lists the elements currently used as coping cutters for this element.
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
RemoveCoping | Removes a coping (cut) from a steel beam.
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
SetCopings | Specify the set of coping cutters on this element.

See Also

FamilyInstance Class

AddCoping Method

[image]