Revit 2011 API
RebarBarType..::.BarDiameter Property
RebarBarType Class See Also Send Feedback
Defines bar diameter of rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double BarDiameter { get; set; }
Visual Basic (Declaration)
Public Property BarDiameter As Double
Visual C++
public:
property double BarDiameter {
    double get ();
    void set (double value);
}

Field Value

The bar diameter of rebar

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: the bar diameter barDiam is not positive or bigger than the smallest value of 1.0, standard bend diameter, standard hook bend diameter and stirrup/tie bend diameter
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

MaximumBendRadius Property

[image]