Revit 2011 API
FilteredElementIterator..::.GetCurrent Method
FilteredElementIterator Class See Also Send Feedback
The current element found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Element GetCurrent()
Visual Basic (Declaration)
Public Function GetCurrent As Element
Visual C++
public:
Element^ GetCurrent()

Return Value

The element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | There are no more elements in the iterator. -or- The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class

IsDone Method

[image]