Revit 2011 API
NurbSpline..::.SetControlPointsAndWeights Method
NurbSpline Class See Also Send Feedback
Set the control points, weights simultaneously.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetControlPointsAndWeights(
    IList<XYZ> ctrlPoints,
    DoubleArray weights
)
Visual Basic (Declaration)
Public Sub SetControlPointsAndWeights ( _
    ctrlPoints As IList(Of XYZ), _
    weights As DoubleArray _
)
Visual C++
public:
void SetControlPointsAndWeights(
    IList<XYZ^>^ ctrlPoints,
    DoubleArray^ weights
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
weights
Type: Autodesk.Revit.DB..::.DoubleArray

See Also

NurbSpline Class

NurbSpline Properties

[image] [image]