Revit 2011 API
SpatialFieldManager..::.CurrentUnits Property
SpatialFieldManager Class See Also Send Feedback
Stores the index in the array of applicable units

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int CurrentUnits { get; set; }
Visual Basic (Declaration)
Public Property CurrentUnits As Integer
Visual C++
public:
property int CurrentUnits {
    int get ();
    void set (int value);
}

Remarks

Must be in the range from 0 to (number of applicable units - 1)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: currentUnits is not in the range from 0 to (number of applicable units - 1)

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace

Description Property

[image]