Revit 2011 API
FailuresAccessor..::.SetTransactionName Method
FailuresAccessor Class See Also Send Feedback
Changes the name of the transaction for which failures are being processed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetTransactionName(
    string transactionName
)
Visual Basic (Declaration)
Public Sub SetTransactionName ( _
    transactionName As String _
)
Visual C++
public:
void SetTransactionName(
    String^ transactionName
)

Parameters

transactionName
Type: System..::.String
The name of the transaction to set.

Remarks

If the transaction will be committed by or after failures processing it can change its name to reflect results of processing of the failures. For example, if the original transaction name was "review warnings" and some of the warnings were resolved dy deleting of the relevant elements, failures processor may change the name of the transaction to "delete elements".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The transactionName is empty.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class

FailureSeverity Enumeration

[image]