Revit 2011 API
BuiltInFailures..::.WallJoinRoofFailures..::.NoUptoRoofForWall Property
BuiltInFailures..::.WallJoinRoofFailures Class See Also Send Feedback
Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoUptoRoofForWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoUptoRoofForWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoUptoRoofForWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallJoinRoofFailures Class

WallMeetsRoofTangentially Property

[image]