Revit 2011 API
SolidArray..::.Item Property
SolidArray Class See Also Send Feedback
Gets or sets a solid at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Solid Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Solid
Visual C++
public:
virtual property Solid^ Item[int index] {
    Solid^ get (int index);
    void set (int index, Solid^ value);
}

Parameters

index
Type: System..::.Int32
The index of the solid to be set or retrieved.

Return Value

Returns the solid at the specified index.

See Also

SolidArray Class

Size Property

[image]