Revit 2011 API
AnalyticalModel..::.GetAnalyticalProjectionType Method
AnalyticalModel Class See Also Send Feedback
This retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function GetAnalyticalProjectionType ( _
    direction As AnalyticalDirection _
) As AnalyticalProjectionType
Visual C++
public:
AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction of projection.

Return Value

Indicates whether the projection is a preset value, or refers to a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

GetAnalyzeAs Method

[image]