Revit 2011 API
RibbonItemData..::.ToolTipImage Property
RibbonItemData Class See Also Send Feedback
The image to show as a part of the button extended tooltip

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageSource ToolTipImage { get; set; }
Visual Basic (Declaration)
Public Property ToolTipImage As ImageSource
Visual C++
public:
property ImageSource^ ToolTipImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

It is shown when the mouse hovers over the command for a longer amount of time. Optional. If neither of this property and LongDescription is supplied, the button will not have an extended tooltip. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace

RibbonItemType Enumeration

[image]