Revit 2011 API
TransactionGroup Methods
TransactionGroup Class See Also Send Feedback

The TransactionGroup type exposes the following members.

Methods

Name | Description
Assimilate | Assimilates all inner transactions, merges them into a single one, and then commits it
Commit | Commits the transaction group
Dispose |
GetName |
GetStatus | Gets the current status of the transaction group
HasEnded | Determines whether the transaction group was ended or not
HasStarted | Determines whether the transaction group has ever been started or not
RollBack | Rolls back the transaction group and with it all inner transactions enclosing by this group
SetName | accessors for the transaction group name property
Start | Overloaded.

See Also

TransactionGroup Class

Assimilate Method

[image]