Revit 2011 API
ACADImportOptions..::.LineWeights Property
ACADImportOptions Class See Also Send Feedback
A Byte array of line weights for the DWG/DXF Color number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public byte[] LineWeights { get; set; }
Visual Basic (Declaration)
Public Property LineWeights As Byte()
Visual C++
public:
property array<unsigned char>^ LineWeights {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Import pen numbers from a DWG or DXF file and map them to a line weight.

See Also

ACADImportOptions Class

VisibleLayersOnly Property

[image]