Revit 2011 API
IExternalApplication..::.OnStartup Method
IExternalApplication Interface See Also Send Feedback
Provide an interface for the user to do some extra work when Revit starts.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
Result OnStartup(
    UIControlledApplication application
)
Visual Basic (Declaration)
Function OnStartup ( _
    application As UIControlledApplication _
) As Result
Visual C++
Result OnStartup(
    UIControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit.UI..::.UIControlledApplication
The application is being started.

Return Value

Indicates if the external application completes its work successfully.

Remarks

If the user implements the interface for an external application, the task within OnStartup will be executed when Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit.UI Namespace

IExternalCommand Interface

[image]