Revit 2011 API
View..::.ViewType Property
View Class Example See Also Send Feedback
The type of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewType ViewType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewType As ViewType
Visual C++
public:
property ViewType ViewType {
    ViewType get ();
}

Examples

CopyC#
public void GetViewType(Autodesk.Revit.DB.View view)
{
    // Get the view type of the given view, and format the prompt string
    String prompt = "The view is ";

    switch (view.ViewType)
    {
        case ViewType.AreaPlan:
            prompt += "an area view.";
            break;
        case ViewType.CeilingPlan:
            prompt += "a reflected ceiling plan view.";
            break;
        case ViewType.ColumnSchedule:
            prompt += "a column schedule view.";
            break;
        case ViewType.CostReport:
            prompt += "a cost report view.";
            break;
        case ViewType.Detail:
            prompt += "a detail view.";
            break;
        case ViewType.DraftingView:
            prompt += "a drafting view.";
            break;
        case ViewType.DrawingSheet:
            prompt += "a drawing sheet view.";
            break;
        case ViewType.Elevation:
            prompt += "an elevation view.";
            break;
        case ViewType.EngineeringPlan:
            prompt += "an engineering view.";
            break;
        case ViewType.FloorPlan:
            prompt += "afloor plan view.";
            break;
        case ViewType.Internal:
            prompt += "Revit's internal view.";
            break;
        case ViewType.Legend:
            prompt += "a legend view.";
            break;
        case ViewType.LoadsReport:
            prompt += "a loads report view.";
            break;
        case ViewType.PanelSchedule:
            prompt += "a panel schedule view.";
            break;
        case ViewType.PresureLossReport:
            prompt += "a pressure loss report view.";
            break;
        case ViewType.Rendering:
            prompt += "a rendering view.";
            break;
        case ViewType.Report:
            prompt += "a report view.";
            break;
        case ViewType.Schedule:
            prompt += "a schedule view.";
            break;
        case ViewType.Section:
            prompt += "a cross section view.";
            break;
        case ViewType.ThreeD:
            prompt += "a 3-D view.";
            break;
        case ViewType.Undefined:
            prompt += "an undefined/unspecified view.";
            break;
        case ViewType.Walkthrough:
            prompt += "a walkthrough view.";
            break;
        default:
            break;
    }

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Public Sub GetViewType(ByVal view As Autodesk.Revit.DB.View)
    ' Get the view type of the given view, and format the prompt string
    Dim prompt As [String] = "The view is "

    Select Case view.ViewType
        Case Autodesk.Revit.DB.ViewType.AreaPlan
            prompt += "an area view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.CeilingPlan
            prompt += "a reflected ceiling plan view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.ColumnSchedule
            prompt += "a column schedule view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.CostReport
            prompt += "a cost report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Detail
            prompt += "a detail view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.DraftingView
            prompt += "a drafting view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.DrawingSheet
            prompt += "a drawing sheet view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Elevation
            prompt += "an elevation view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.EngineeringPlan
            prompt += "an engineering view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.FloorPlan
            prompt += "afloor plan view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Internal
            prompt += "Revit's internal view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Legend
            prompt += "a legend view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.LoadsReport
            prompt += "a loads report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.PanelSchedule
            prompt += "a panel schedule view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.PresureLossReport
            prompt += "a pressure loss report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Rendering
            prompt += "a rendering view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Report
            prompt += "a report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Schedule
            prompt += "a schedule view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Section
            prompt += "a cross section view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.ThreeD
            prompt += "a 3-D view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Undefined
            prompt += "an undefined/unspecified view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Walkthrough
            prompt += "a walkthrough view."
            Exit Select
        Case Else
            Exit Select
    End Select

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

See Also

View Class

View3D Class

[image]