Revit 2011 API
PipeSystemType Enumeration
See Also Send Feedback
An enumerated type listing all the possible pipe system types for a connector object.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PipeSystemType
Visual Basic (Declaration)
Public Enumeration PipeSystemType
Visual C++
public enum class PipeSystemType

Members

Member name | Description
UndefinedSystemType | Undefined system type
SupplyHydronic | Pipe System Type is SupplyHydronic.
ReturnHydronic | Pipe System Type is ReturnHydronic.
Sanitary | Pipe System Type is Sanitary.
DomesticHotWater | Pipe System Type is DomesticHotWater.
DomesticColdWater | Pipe System Type is DomesticColdWater.
OtherPipe | Pipe System Type is OtherPipe.
FireProtectWet | Pipe System Type is FireProtectWet.
FireProtectDry | Pipe System Type is FireProtectDry.
FireProtectPreaction | Pipe System Type is FireProtectPreaction.
FireProtectOther | Pipe System Type is FireProtectOther.
Fitting | Pipe System Type is Fitting.
Global | Pipe System Type is Global.

See Also

Autodesk.Revit.DB.Plumbing Namespace

PipeType Class

[image]