Revit 2011 API
Connector..::.AssignedFlowDirection Property
Connector Class See Also Send Feedback
The assigned flow direction of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlowDirectionType AssignedFlowDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedFlowDirection As FlowDirectionType
Visual C++
public:
property FlowDirectionType AssignedFlowDirection {
    FlowDirectionType get ();
}

Remarks

Flow direction may be assigned for connectors of some family instances. For more information, seeDuctConnector, PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get assigned flow direction.

See Also

Connector Class

AssignedFlowFactor Property

[image]