Revit 2011 API
TaskDialog..::.DefaultButton Property
TaskDialog Class See Also Send Feedback
The default button for the dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TaskDialogResult DefaultButton { get; set; }
Visual Basic (Declaration)
Public Property DefaultButton As TaskDialogResult
Visual C++
public:
property TaskDialogResult DefaultButton {
    TaskDialogResult get ();
    void set (TaskDialogResult value);
}

Remarks

If DefaultButton is TaskDialogResult.None or its value does not correspond to any CommonButton or CommandLink in the dialog, then the first button in the dialog will be the default.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace

ExpandedContent Property

[image]