Revit 2011 API
RebarShapeDefinitionBySegments..::.AddListeningDimensionSegmentToBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddListeningDimensionSegmentToBend(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionSegmentToBend ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToBend(
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::.Int32
Index of the first segment, which must be perpendicular to the constraint direction.
iSegment1
Type: System..::.Int32
Index of the second segment.
iEnd1
Type: System..::.Int32
End (0 or 1) of the second segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

AddListeningDimensionSegmentToSegment Method

[image]