Revit 2011 API
CutFailureReason Enumeration
See Also Send Feedback
The reason why a solid/solid cut cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum CutFailureReason
Visual Basic (Declaration)
Public Enumeration CutFailureReason
Visual C++
public enum class CutFailureReason

Members

Member name | Description
CutAllowed | Yes, the making cut element can add cut to the getting cut element.
CutAlreadyExists | No, the making cut element has cut the getting cut element already.
OppositeCutExists | No, the getting cut element has cut the making cut element already.
CutNotAppropriateForElements | No, the cut is not appropriate for the two elements.

See Also

CylindricalFace Class

[image]