Revit 2011 API
ControlledApplication..::.VersionBuild Property
ControlledApplication Class See Also Send Feedback
Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string VersionBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionBuild As String
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Autodesk Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

VersionName Property

[image]