Revit 2011 API
RibbonItem..::.Visible Property
RibbonItem Class See Also Send Feedback
Gets or sets a value indicating whether the item is visible.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Remarks

When the Visible property is set to false, the item won't be displayed on Ribbon.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace

RibbonItemData Class

[image]