Revit 2011 API
Array..::.Insert Method
Array Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Object item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Object, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Object^ item,
    int index
)

Parameters

item
Type: System..::.Object
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace

ReverseIterator Method

[image]