Revit 2011 API
FaceArray..::.Item Property
FaceArray Class See Also Send Feedback
Gets or sets a face at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Face Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Face
Visual C++
public:
virtual property Face^ Item[int index] {
    Face^ get (int index);
    void set (int index, Face^ value);
}

Parameters

index
Type: System..::.Int32
The index of the face to be set or retrieved.

Return Value

Returns the face at the specified index.

See Also

FaceArray Class

Size Property

[image]