Revit 2011 API
Document..::.NewArea Method
Document Class See Also Send Feedback
Creates a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Area NewArea(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Function NewArea ( _
    areaView As ViewPlan, _
    point As UV _
) As Area
Visual C++
public:
Area^ NewArea(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::.ViewPlan
The view of area element.
point
Type: Autodesk.Revit.DB..::.UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewAreaBoundaryConditions Method

[image] [image]