Revit 2011 API
ControlledApplication..::.IsQuiescent Property
ControlledApplication Class See Also Send Feedback
Returns if the current application is quiescent.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsQuiescent { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsQuiescent As Boolean
Visual C++
public:
property bool IsQuiescent {
    bool get ();
}

Remarks

This property can be used check if the current application is quiescent. If any document in of the current application is in editing mode or the In-place family is being edited, it returns false. Otherwise, true will be returned.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

Language Property

[image]