Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarConstraintWarning Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarConstraintWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarConstraintWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarConstraintWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class

RebarHooksDontMatchShape Property

[image]