Revit 2011 API
PipeConnector..::.AssignAsPrimary Method
PipeConnector Class See Also Send Feedback
Assign a pipe connector as a primary pipe connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AssignAsPrimary()
Visual Basic (Declaration)
Public Sub AssignAsPrimary
Visual C++
public:
void AssignAsPrimary()

Remarks

This method is used to promote this pipe connector as primary, and the rest of connectors in this system will be assigned as secondary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when fail to assign this connector as primary.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace

PipeConnector Properties

[image] [image]