Revit 2011 API
RebarHostData..::.HasCoverTypeForReference Method
RebarHostData Class See Also Send Feedback
Checks whether the reference has an associated cover.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasCoverTypeForReference(
    Reference face
)
Visual Basic (Declaration)
Public Function HasCoverTypeForReference ( _
    face As Reference _
) As Boolean
Visual C++
public:
bool HasCoverTypeForReference(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::.Reference
Reference to a geometrical face of the host element.

Return Value

True if the face has an associated RebarCoverType; false if it does not.

Remarks

Only certain references have associated covers. The reference must be a face. Further, certain faces do not have covers, such as the top face of a beam that is joined to a slab, and the treads and risers of Stairs.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace

RebarHostData Properties

[image] [image]