Revit 2011 API
RebarHostData..::.CoverType Property
RebarHostData Class See Also Send Feedback
Gets the RebarCoverType associated with a face of the element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarCoverType CoverType[
    Reference face
] { get; set; }
Visual Basic (Declaration)
Public Property CoverType ( _
    face As Reference _
) As RebarCoverType
Visual C++
public:
property RebarCoverType^ CoverType[Reference^ face] {
    RebarCoverType^ get (Reference^ face);
    void set (Reference^ face, RebarCoverType^ value);
}

Parameters

face
Type: Autodesk.Revit.DB..::.Reference
Reference to a geometrical face of the host element.

Remarks

Only certain references have associated covers. The reference must be a face. Further, certain faces do not have covers, such as the top face of a beam that is joined to a slab, and the treads and risers of Stairs.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace

Valid Property

[image]