Revit 2011 API
FilteredElementIdIterator..::.MoveNext Method
FilteredElementIdIterator Class See Also Send Feedback
Increments the iterator to the next element id passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available element id passing the filter in this iterator. False if the iterator has completed all available element ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIdIterator Class

Reset Method

[image]