Revit 2011 API
RebarShape..::.NewDefinitionBySegments Method
RebarShape Class See Also Send Feedback
Create a shape definition by segments, and associate it with this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeDefinitionBySegments NewDefinitionBySegments(
    int numSegments
)
Visual Basic (Declaration)
Public Function NewDefinitionBySegments ( _
    numSegments As Integer _
) As RebarShapeDefinitionBySegments
Visual C++
public:
RebarShapeDefinitionBySegments^ NewDefinitionBySegments(
    int numSegments
)

Parameters

numSegments
Type: System..::.Int32
The number of straight segments in the shape definition. This cannot be changed after the definition object is created.

Remarks

The returned value of this function and the returned value from Definition::get() are references to the same object.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

SetAllowed Method

[image]