Revit 2011 API
PipeConnector Members
PipeConnector Class Methods Properties See Also Send Feedback

The PipeConnector type exposes the following members.

Methods

Name | Description
AssignAsPrimary | Assign a pipe connector as a primary pipe connector.

Properties

Name | Description
CoordinateSystem | The coordinate system of the connector.
Domain | The domain of the connector.
Height | The height of the connector.
IsPrimary | Identifies if this is the primary connector in the family.
LinkedConnector | The linked pipe connector.
Origin | The location of the connector in family document.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Radius | The radius of the connector.
Shape | The shape of the connector.
SystemType | The system type of the pipe connector.
Width | The width of the connector.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace

PipeConnector Methods

[image] [image]