Revit 2011 API
Document..::.NewRebarCoverType Method
Document Class See Also Send Feedback
Create a new instance of Rebar Cover Type, which defines the cover setting of the rebar host.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarCoverType NewRebarCoverType(
    string name,
    double length
)
Visual Basic (Declaration)
Public Function NewRebarCoverType ( _
    name As String, _
    length As Double _
) As RebarCoverType
Visual C++
public:
RebarCoverType^ NewRebarCoverType(
    String^ name,
    double length
)

Parameters

name
Type: System..::.String
The not empty name for Rebar Cover Type.
length
Type: System..::.Double
The cover length of Rebar Cover Type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewRebarHookType Method

[image]