Revit 2011 API
ControlledApplication..::.OpenSharedParameterFile Method
ControlledApplication Class See Also Send Feedback
Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionFile OpenSharedParameterFile()
Visual Basic (Declaration)
Public Function OpenSharedParameterFile As DefinitionFile
Visual C++
public:
DefinitionFile^ OpenSharedParameterFile()

Return Value

An object that represents a shared parameters file.

Remarks

This function is used to return an object that represents a Revit shared parameters file that exists on disk. Revit can use only one shared parameters file at any one time. The filename for the shared parameters file can be set in the Revit Application Options object. If the file does not exist and error will be created and an empty reference will be returned.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

RegisterFailuresProcessor Method

[image]