Revit 2011 API
CompoundStructureLayer..::.Thickness Property
CompoundStructureLayer Class See Also Send Feedback
Retrieve or modify the thickness of the layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Thickness { get; set; }
Visual Basic (Declaration)
Public Property Thickness As Double
Visual C++
public:
property double Thickness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument thickness is invalid for the layer in set method.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument thickness is less than 0 in set method.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when set operation failed.

See Also

CompoundStructureLayer Class

Variable Property

[image]