Revit 2011 API
Application..::.NewProjectTemplateDocument Method
Application Class See Also Send Feedback
New project template document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Document NewProjectTemplateDocument(
    string templateFilename
)
Visual Basic (Declaration)
Public Overridable Function NewProjectTemplateDocument ( _
    templateFilename As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectTemplateDocument(
    String^ templateFilename
)

Parameters

templateFilename
Type: System..::.String
The template file name.

Remarks

This corresponds to the New->Project->Project Template command in the user-interface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the project template document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

OpenDocumentFile Method

[image]