Revit 2011 API
MechanicalSystem Class
Members See Also Send Feedback
A mechanical system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MechanicalSystem : MEPSystem
Visual Basic (Declaration)
Public Class MechanicalSystem _
    Inherits MEPSystem
Visual C++
public ref class MechanicalSystem : public MEPSystem

Remarks

The mechanical system element is only available in Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.MEPSystem
Autodesk.Revit.DB.Mechanical..::.MechanicalSystem

See Also

MechanicalSystem Members
Autodesk.Revit.DB.Mechanical Namespace

MechanicalSystem Members

[image] [image]