Revit 2011 API
MassZone..::.MaterialType Property
MassZone Class See Also Send Feedback
Indicates how the material of MassZone faces is determined.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassZoneMaterialType MaterialType { get; set; }
Visual Basic (Declaration)
Public Property MaterialType As MassZoneMaterialType
Visual C++
public:
property MassZoneMaterialType MaterialType {
    MassZoneMaterialType get ();
    void set (MassZoneMaterialType value);
}

Remarks

The material of the MassZone faced will be determined in the following ways based on the material type. MassZoneMaterialTypeMaterialBySurfaceType: Each MassZone face will use the material defined by the object style of the subcategory of the Element returned by getMassDataElementIdForZoneFaceReference(..). MassZoneMaterialTypeNormalMaterial: If the materialId is InvalidElementId, then the material defined by the object style of the MassZone subcategory will be used for all faces of the MassZone. MassZoneMaterialTypeNormalMaterial: If the materialId is the id of a Material element, that material id will be used for all faces fo the MassZone.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace

Parameter Property

[image] [image]