Revit 2011 API
FailureHandlingOptions Methods
FailureHandlingOptions Class See Also Send Feedback

The FailureHandlingOptions type exposes the following members.

Methods

Name | Description
Dispose |
GetClearAfterRollback |
GetDelayedMiniWarnings |
GetFailuresPreprocessor |
GetForcedModalHandling |
GetTransactionFinalizer |
SetClearAfterRollback |
SetDelayedMiniWarnings |
SetFailuresPreprocessor | Setting a callback to be invoked in the beginning of failure processing
SetForcedModalHandling | Set the flag whether it pops modal error dialog if the transaction failed to finish
SetTransactionFinalizer | Setting a callback to be executed after transaction is completed

See Also

FailureHandlingOptions Class

Dispose Method

[image]