Revit 2011 API
AnalyticalModelSweptProfile Members
AnalyticalModelSweptProfile Class Methods Properties See Also Send Feedback

The AnalyticalModelSweptProfile type exposes the following members.

Methods

Name | Description
Dispose |
GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.

Properties

Name | Description
EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelSweptProfile Methods

[image] [image]