Revit 2011 API
Document..::.Move Method (ICollection<(Of <(ElementId>)>), XYZ)
Document Class See Also Send Feedback
Moves several elements, specified by a set of ids, within the document by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Move(
    ICollection<ElementId> ids,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    ids As ICollection(Of ElementId), _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ICollection<ElementId^>^ ids,
    XYZ^ translationVec
)

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of element ids specifying which elements are to be moved.
translationVec
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the elements are to be moved.

Return Value

True if the elements are moved successfully, otherwise False.

Remarks

The move method is used to move several elements within the project. Other elements may also be moved when these elements are moved. For example, if the elements are structural columns, all the beams joined to those columns will also move or resize.

See Also

Document Class
Move Overload

PostFailure Method

[image]