Revit 2011 API
Document..::.ExportImage Method
Document Class See Also Send Feedback
Exports a view or set of views into an image file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void ExportImage(
    ImageExportOptions options
)
Visual Basic (Declaration)
Public Sub ExportImage ( _
    options As ImageExportOptions _
)
Visual C++
public:
void ExportImage(
    ImageExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::.ImageExportOptions
The options which govern the image export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Failed to export image due to an error with the inputs. -or- Failed to export image due to an issue where the DirectX Device was lost.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.FileNotFoundException | The path indicated could not be found.
Autodesk.Revit.Exceptions..::.FileAccessException | The path indicated could not be accessed.

See Also

Document Class

FindReferencesByDirection Method

[image]