Revit 2011 API
Reference Properties
Reference Class See Also Send Feedback

The Reference type exposes the following members.

Properties

Name | Description
Element | The element for this reference.
ElementReferenceType | The type of reference referred to.
GeometryObject | The geometry item referred to by this reference.
GlobalPoint | The position on which the reference is hit.
ProximityParameter | The proximity value to the ray's origin when the reference is returned by FindReferencesByDirection(XYZ, XYZ, View3D).
Transform | The transformation of the geometry item into the coordinates of the document.
UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class

Element Property

[image]