Revit 2011 API
View..::.ViewDirection Property
View Class See Also Send Feedback
The direction towards the viewer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ ViewDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewDirection As XYZ
Visual C++
public:
property XYZ^ ViewDirection {
    XYZ^ get ();
}

Remarks

In orthographic views, all objects are projected onto the screen along this direction. In perspective views, the view target point is projected along this direction, but other points are projected towards the eye along different vectors.

See Also

View Class

ViewName Property

[image]