Revit 2011 API
ApplicationEntryPoint Members
ApplicationEntryPoint Class Constructors Methods Properties Events See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Constructors

Name | Description
ApplicationEntryPoint | Initializes a new instance of the ApplicationEntryPoint class

Methods

Name | Description
CreateRibbonPanel | Overloaded.
FinishInitializationEO | For Revit VSTA internal use only.
GetRibbonPanels | Overloaded.
Initialize | For Revit VSTA internal use only.
OnShutdownEO | For Revit VSTA internal use only.

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ActiveUIDocument | Provides access to an object that represents the currently active project.
AddinFolder | The full path to the Revit VSTA module.
Application | Returns the database level Application represented by this UI level Application.
DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
LoadedApplications | Returns an array of successfully loaded external applications.
MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace

ApplicationEntryPoint Constructor

[image]