Revit 2011 API
ControlledApplication..::.FailuresProcessing Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public event EventHandler<FailuresProcessingEventArgs> FailuresProcessing
Visual Basic (Declaration)
Public Event FailuresProcessing As EventHandler(Of FailuresProcessingEventArgs)
Visual C++
public:
 event EventHandler<FailuresProcessingEventArgs^>^ FailuresProcessing {
    void add (EventHandler<FailuresProcessingEventArgs^>^ value);
    void remove (EventHandler<FailuresProcessingEventArgs^>^ value);
}

Remarks

This event is raised when failures are being processed during transaction commit or rollback operations. Handlers of this event have a limited ability to modify the document and/or failures in it, using provided restricted failures accessor interface.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

FileExported Event

[image]