Revit 2011 API
TextBox..::.SelectTextOnFocus Property
TextBox Class See Also Send Feedback
A value that indicates if the text is selected when the text box gains focus.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool SelectTextOnFocus { get; set; }
Visual Basic (Declaration)
Public Property SelectTextOnFocus As Boolean
Visual C++
public:
property bool SelectTextOnFocus {
    bool get ();
    void set (bool value);
}

Remarks

If the value is true all the text in the text box will be selected when the text box gets keyboard focus. If it is false the text is not selected. The default value is false.

See Also

TextBox Class
Autodesk.Revit.UI Namespace

ShowImageAsButton Property

[image]