Revit 2011 API
ParameterFilterElement Members
ParameterFilterElement Class Methods Properties See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Methods

Name | Description
AllCategoriesFilterable | Checks that all of the given categories are filterable.
AllRuleParametersApplicable | Overloaded.
ClearRules | Removes all rules from this filter.
Create | Overloaded.
GetCategories | Gets the categories admitted by this filter.
GetRuleParameter | Returns the parameter for a given filter rule.
GetRuleParameters | Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.
GetRules | Returns the rules of this filter, in the order in which they are applied.
SetCategories | Sets the categories admitted by this filter.
SetRules | Sets the rules, all of which must be satisfied for a given element to pass this filter.

Properties

Name | Description
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.

See Also

ParameterFilterElement Class

ParameterFilterElement Methods

[image] [image]