Revit 2011 API
Rebar..::.SetSolidInView Method
Rebar Class See Also Send Feedback
Sets this rebar element to be shown solidly in a 3D view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetSolidInView(
    View3D view,
    bool solid
)
Visual Basic (Declaration)
Public Sub SetSolidInView ( _
    view As View3D, _
    solid As Boolean _
)
Visual C++
public:
void SetSolidInView(
    View3D^ view,
    bool solid
)

Parameters

view
Type: Autodesk.Revit.DB..::.View3D
The 3D view element
solid
Type: System..::.Boolean
True if rebar is shown solidly, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This rebar element doesn't have valid visibility data.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

SetUnobscuredInView Method

[image]