Revit 2011 API
IExtension..::.IsMiterLocked Property
IExtension Interface See Also Send Feedback
Retrieves or set the miter locked status at the end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
bool IsMiterLocked[
    int index
] { get; set; }
Visual Basic (Declaration)
Property IsMiterLocked ( _
    index As Integer _
) As Boolean
Visual C++
property bool IsMiterLocked[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, only if the beam is extended and is mitered with other beams at the end, it can be locked. Otherwise, the setting is invalid

See Also

IExtension Interface

SymbolicExtended Property

[image]