Revit 2011 API
Set Members
Set Class Constructors Methods Properties See Also Send Feedback

The Set type exposes the following members.

Constructors

Name | Description
Set | Initializes a new instance of the Set class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
Size | Returns the number of objects that are in the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace

Set Constructor

[image]