Revit 2011 API
MaterialWood..::.ShearModulus Property
MaterialWood Class See Also Send Feedback
Get or set the shear modulus of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulus { get; set; }
Visual Basic (Declaration)
Public Property ShearModulus As Double
Visual C++
public:
property double ShearModulus {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the shear modulus to an invalid value.

See Also

MaterialWood Class

ShearParallel Property

[image]