Revit 2011 API
MassSurfaceData..::.SillHeight Property
MassSurfaceData Class See Also Send Feedback
The height above the level where the bottoms of auto-generated windows will be located.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double SillHeight { get; set; }
Visual Basic (Declaration)
Public Property SillHeight As Double
Visual C++
public:
property double SillHeight {
    double get ();
    void set (double value);
}

Remarks

Will be accurate unless the target glazing percentage cannot be achieved using this height. In that case, the sillHeight will be ignored and windows will be created below this height.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace

SkylightWidth Property

[image]