Revit 2011 API
ConceptualSurfaceType..::.GetAllMassSubCategoryIds Method
ConceptualSurfaceType Class See Also Send Feedback
Get all the mass subcategory ids for which there are ConceptualSurfaceType's.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static IList<ElementId> GetAllMassSubCategoryIds()
Visual Basic (Declaration)
Public Shared Function GetAllMassSubCategoryIds As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetAllMassSubCategoryIds()

Return Value

Returns an array of element id of mass subcategories for which there are ConceptualSurfaceType's.

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace

GetByMassSubCategoryId Method

[image]