Revit 2011 API
MaterialGeneric..::.YoungModulusX Property
MaterialGeneric Class See Also Send Feedback
Get or set the x component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusX { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class

YoungModulusY Property

[image]