Revit 2011 API
AnnotationSymbol..::.AsFamilyInstance Property
AnnotationSymbol Class See Also Send Feedback
This property is used to get family instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is no longer needed because AnnotationSymbol now derives from FamilyInstance.")]
public FamilyInstance AsFamilyInstance { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("This property is no longer needed because AnnotationSymbol now derives from FamilyInstance.")> _
Public ReadOnly Property AsFamilyInstance As FamilyInstance
Visual C++
[ObsoleteAttribute(L"This property is no longer needed because AnnotationSymbol now derives from FamilyInstance.")]
public:
property FamilyInstance^ AsFamilyInstance {
    FamilyInstance^ get ();
}

Remarks

This property is obsolete because AnnotationSymbol now derives from FamilyInstance.

See Also

AnnotationSymbol Class

FromRoom Property

[image] [image]