Revit 2011 API
SolidSolidCutUtils..::.AddCutBetweenSolids Method
SolidSolidCutUtils Class See Also Send Feedback
Add the solid-solid cut for the two elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void AddCutBetweenSolids(
    Document ADoc,
    Element SolidToBeCut,
    Element CuttingSolid
)
Visual Basic (Declaration)
Public Shared Sub AddCutBetweenSolids ( _
    ADoc As Document, _
    SolidToBeCut As Element, _
    CuttingSolid As Element _
)
Visual C++
public:
static void AddCutBetweenSolids(
    Document^ ADoc,
    Element^ SolidToBeCut,
    Element^ CuttingSolid
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
The document containing the two elements
SolidToBeCut
Type: Autodesk.Revit.DB..::.Element
The solid to be cut
CuttingSolid
Type: Autodesk.Revit.DB..::.Element
The cutting solid

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The element must be in a conceptual model, pattern based curtain panel, or adaptive component family -or- The element does not meet the condition that it must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Failed to add solid-solid cut for the two elements
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class

CanElementCutElement Method

[image]