Revit 2011 API
SpatialFieldManager..::.UpdateSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback
Populates analysis results data (or replaces the existing data) in the existing container (primitive) identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints fieldDomainPoints,
    FieldValues fieldValues
)
Visual Basic (Declaration)
Public Sub UpdateSpatialFieldPrimitive ( _
    idx As Integer, _
    fieldDomainPoints As FieldDomainPoints, _
    fieldValues As FieldValues _
)
Visual C++
public:
void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints^ fieldDomainPoints,
    FieldValues^ fieldValues
)

Parameters

idx
Type: System..::.Int32
Unique index identifying the primitive
fieldDomainPoints
Type: Autodesk.Revit.DB.Analysis..::.FieldDomainPoints
Set of domain points. If %fieldDomainPoints% is NULL only fieldValues are updated
fieldValues
Type: Autodesk.Revit.DB.Analysis..::.FieldValues
Set of data values. Number of values in fieldValues must coincide with the number of points in fieldDomainPoints

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | idx refers to non-existent primitive -or- fieldValues has incorrect number of measurements in ValueAtPoint objects -or- fieldDomainPoints and fieldValues have inconsistent number of points
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace

SpatialFieldManager Properties

[image] [image]