Revit 2011 API
ViewSheetSetting..::.AvailableViews Property
ViewSheetSetting Class See Also Send Feedback
All views that can be printed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSet AvailableViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property AvailableViews As ViewSet
Visual C++
public:
property ViewSet^ AvailableViews {
    ViewSet^ get ();
}

Remarks

Users can select the view/sheet from this view set to printing.

See Also

ViewSheetSetting Class

CurrentViewSheetSet Property

[image]