Revit 2011 API
Map..::.Erase Method
Map Class See Also Send Feedback
Removes a object with the specified key from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Object key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As Object _
) As Integer
Visual C++
public:
virtual int Erase(
    Object^ key
)

Parameters

key
Type: System..::.Object
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace

ForwardIterator Method

[image]