Revit 2011 API
Autodesk.Revit.DB Namespace

Classes

Class Description
ACADExportOptions
Export options specific to AutoCAD file formats.
ACADImportOptions
Import options specific to AutoCAD file formats.
AddInId
Identifies an AddIn registered with Revit
AnnotationSymbol
This object represents a symbol of the Generic Annotation.
AnnotationSymbolType
An object that represents an annotation style.
AnnotationSymbolTypeSet
A set that contains AnnotationSymbol types.
AnnotationSymbolTypeSetIterator
An iterator to a AnnotationSymbol type set.
APIObject
Supports all objects in the Autodesk Revit API hierarchy.
Arc
A circular arc.
Area
Provides access to the area topology in Autodesk Revit.
AreaFilter
A filter used to match areas.
AreaScheme
The area scheme associated with a particular area plan.
AreaTag
Provides access to the area topology in Autodesk Revit.
AreaTagFilter
A filter used to match area tags.
AreaTagType
An object that represents an Area Tag style.
AreaTagTypeSet
A set that contains areatag types.
AreaTagTypeSetIterator
An iterator to a areatag type set.
BaseArray
An abstract base class that represents an array within the Revit project.
BasePoint
Represents kinds of BasePoints.
BeamSystem
An object that represents a BeamSystem within the Autodesk Revit project.
BeamSystemType
An object that specifies the type of a beam system in Autodesk Revit.
BeamSystemTypeSet
BeamSystemTypeSetIterator
Binding
Binding objects are used to take a parameter definition and bind it to one or more categories.
BindingMap
The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Blend
A blend solid or void form.
BoundaryConditions
An object that represents a force applied across an area.
BoundarySegment
An object that represents a segment of an area boundary.
BoundarySegmentArray
An array that contains boundary segments.
BoundarySegmentArrayArray
An array that contains boundary segment arrays.
BoundarySegmentArrayArrayIterator
An iterator to a array of boundary segment arrays.
BoundarySegmentArrayIterator
An iterator to a boundary segment array.
BoundingBoxContainsPointFilter
A filter used to match elements with a bounding box that contains the given point.
BoundingBoxIntersectsFilter
A filter used to match elements with a bounding box that intersects the given Outline.
BoundingBoxIsInsideFilter
A filter used to match elements with a bounding box that is contained by the given Outline.
BoundingBoxUV
A two-dimensional rectangle, parallel to the coordinate axes.
BoundingBoxXYZ
A three-dimensional rectangular box.
BuildingSiteExportOptions
Building Site Export options.
BuiltInFailures
Provides a container of all Revit built-in FailureDefinitionId instances.
BuiltInFailures..::.AnalyticalModelFailures
Failures about AnalyticalModel.
BuiltInFailures..::.ArrayFailures
Failures about Arrays.
BuiltInFailures..::.AutoJoinFailures
Failures about AutoJoin.
BuiltInFailures..::.AutoRouteFailures
Failures about AutoRoute.
BuiltInFailures..::.BeamFailures
Failures about Beams.
BuiltInFailures..::.BeamSystemFailures
Failures about BeamSystem.
BuiltInFailures..::.BendFailures
Failures about Bends.
BuiltInFailures..::.BlendFailures
Failures about Blend.
BuiltInFailures..::.ColorFillFailures
Failures about ColorFill.
BuiltInFailures..::.ColumnFailures
Failures about Columns.
BuiltInFailures..::.ColumnInsideWallFailures
Failures description ColumnInsideWall
BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures
Failures about ConceptualEnergyAnalysisDB.
BuiltInFailures..::.ConnectorFailures
Failures about Connector.
BuiltInFailures..::.ConstraintFailures
Failures about Constraint.
BuiltInFailures..::.ConversionFailures
Failures about conversion of data to a different format.
BuiltInFailures..::.CopyMonitorFailures
Failures about CopyWatch.
BuiltInFailures..::.CopyPasteFailures
Failures about CopyPasteFailures.
BuiltInFailures..::.CreationFailures
Failures about CreationFailures.
BuiltInFailures..::.CurtainGridFamilyFailures
Failures about CurtainGrid Family.
BuiltInFailures..::.CurtainWallFailures
Failures about CurtainWall.
BuiltInFailures..::.CurveByPointFailures
Failures about Curve By Point Element
BuiltInFailures..::.CurveFailures
Failures about Curves and Curve-Driven Elements.
BuiltInFailures..::.CutFailures
Failures about Cut.
BuiltInFailures..::.CutterFailures
Failures about Cutter.
BuiltInFailures..::.CuttingFailures
Failures about Cutting.
BuiltInFailures..::.DatumPlaneFailures
Failures about DatumPlane.
BuiltInFailures..::.DecalFailures
Failures about Decal.
BuiltInFailures..::.DesignOptionFailures
Failures about DesignOptionFailures.
BuiltInFailures..::.DetailFailures
Failures about Detail.
BuiltInFailures..::.DimensionFailures
Failures about DimensionFailures.
BuiltInFailures..::.DividedSurfaceFailures
Failures about DividedSurface.
BuiltInFailures..::.DocumentFailures
Failures about DocumentFailures.
BuiltInFailures..::.DuctFailures
Failures about Duct.
BuiltInFailures..::.EditingFailures
Failures about EditingFailures.
BuiltInFailures..::.ElectricalFailures
Failures about Electricity.
BuiltInFailures..::.ElectricityFailures
BuiltInFailures..::.ElementFailures
Failures about Elements.
BuiltInFailures..::.ElementTypeFailures
Failures about ElementTypeFailures.
BuiltInFailures..::.ElevationFailures
Failures about Elevation.
BuiltInFailures..::.EnergyAnalysisFailures
Failures about EnergyAnalysis.
BuiltInFailures..::.ExtrusionFailures
Failures about Extrusions.
BuiltInFailures..::.FaceSplitterFailures
Failures about FaceSplitter.
BuiltInFailures..::.FamilyFailures
Failures about FamilyFailures.
BuiltInFailures..::.FilledRegionFailures
Failures about FilledRegion.
BuiltInFailures..::.FloorFailures
BuiltInFailures..::.FluidFailures
Failures about Fluid.
BuiltInFailures..::.FormFailures
Failures about Form.
BuiltInFailures..::.GeneralFailures
Failures about GeneralFailures.
BuiltInFailures..::.GenericFailures
Generic failures that may apply to any Revit Element
BuiltInFailures..::.GenericMEPFailures
Failures applicable to different mechanical, electrical and piping Elements.
BuiltInFailures..::.GeometryFailures
Failures about GeometryFailures.
BuiltInFailures..::.GridFailures
Failures about Grid.
BuiltInFailures..::.GroupFailures
Failures related to groups and their behavior.
BuiltInFailures..::.HostFinishFailures
Failures about HostFinish.
BuiltInFailures..::.HostObjFailures
Failures about HostObj.
BuiltInFailures..::.HvacFailures
BuiltInFailures..::.IlluminationFailures
Failures about Illumination.
BuiltInFailures..::.ImageFailures
Failures about Image.
BuiltInFailures..::.ImportFailures
Failures about ImportFailures.
BuiltInFailures..::.InaccurateFailures
Failures about Inaccurate.
BuiltInFailures..::.InfillFailures
Failures about Infill.
BuiltInFailures..::.InterferenceFailures
Failures about Interference.
BuiltInFailures..::.JoinElementsFailures
Failures about JoinElements.
BuiltInFailures..::.KeynoteFailures
Failures about KeynoteFailures.
BuiltInFailures..::.LegendFailures
Failures about Legend.
BuiltInFailures..::.LevelFailures
Failures about Level.
BuiltInFailures..::.LinkFailures
Failures about LinkFailures.
BuiltInFailures..::.LoadFailures
Failures about Load.
BuiltInFailures..::.LooseDimensionFailures
Failures about LooseDemision.
BuiltInFailures..::.MassFailures
Failures about Mass.
BuiltInFailures..::.MatchlineFailures
Failures about Matchline.
BuiltInFailures..::.MechanicalFailures
Failures about Hvac.
BuiltInFailures..::.MirrorFailures
Failures about Mirror.
BuiltInFailures..::.OpeningFailures
Failures about Opening.
BuiltInFailures..::.OverlapFailure
BuiltInFailures..::.OverlapFailures
Failures detected by overlap check.
BuiltInFailures..::.PathFailures
Failures about Path.
BuiltInFailures..::.PipingFailures
Failures about Pipes.
BuiltInFailures..::.PlanRegionFailures
Failures about PlanRegion.
BuiltInFailures..::.PointFailures
Failures about Point Element.
BuiltInFailures..::.ProfileFailures
Failures about Profile.
BuiltInFailures..::.RebarFailures
Failures about Rebar.
BuiltInFailures..::.RebarShapeFailures
Failures about RebarShape.
BuiltInFailures..::.RebarSystemFailures
Failures about RebarSystem.
BuiltInFailures..::.RefPlaneFailures
Failures about RefPlane.
BuiltInFailures..::.RegenFailures
Failures about RegenFailures.
BuiltInFailures..::.RenderFailures
Failures about Render.
BuiltInFailures..::.RevisionCloudFailures
Failures about RevisionCloud.
BuiltInFailures..::.RevolutionFailures
Failures about Revolution.
BuiltInFailures..::.RoofFailures
Failures about Roof.
BuiltInFailures..::.RoomFailures
Failures about Room.
BuiltInFailures..::.ScheduleViewFailures
Failures about Schedule.
BuiltInFailures..::.SculptingFailures
Failures about Sculpting.
BuiltInFailures..::.SectionViewFailures
Failures about Section.
BuiltInFailures..::.SelectionFailures
Failures about Selections.
BuiltInFailures..::.SheetFailures
Failures about Sheet.
BuiltInFailures..::.SiteFailures
Failures about Site.
BuiltInFailures..::.SiteImportFailures
Failures about SiteImport.
BuiltInFailures..::.SketchFailures
Failures about Sketch.
BuiltInFailures..::.SkylightFailures
Failures about Skylight.
BuiltInFailures..::.SlabFailures
Failures about Slab.
BuiltInFailures..::.SlantedColumnFailures
Failures about SlantedColumn.
BuiltInFailures..::.SlapShapeFailures
Failures about SlapShape.
BuiltInFailures..::.SpanDirectionSymbolFailures
Failures about SpanDirectionSymbol.
BuiltInFailures..::.SplineFailures
Failures about Spline.
BuiltInFailures..::.StairRampFailures
Failures about StairRamp.
BuiltInFailures..::.SweepFailures
Failures about Sweep.
BuiltInFailures..::.SweptBlendFailures
Failures about SweptBlend.
BuiltInFailures..::.SystemsFailures
Failures about System.
BuiltInFailures..::.TagFailures
Failures about Tag.
BuiltInFailures..::.TextFailures
Failures about Text.
BuiltInFailures..::.TrussFailures
Failures about Truss.
BuiltInFailures..::.ViewFailures
Failures about ViewFailures.
BuiltInFailures..::.WallFailures
Failures about Wall.
BuiltInFailures..::.WallJoinRoofFailures
Failures about WallJoinRoof.
BuiltInFailures..::.WorksharingFailures
Failures about WorksharingFailures.
CADExportOptions
Generic CAD Export options.
CADImportOptions
Generic CAD Import options.
Categories
The Categories object is a map that contains all the top-level Category objects within the Document.
Category
Represents the category or subcategory to which an element belongs.
CategoryNameMap
A map that contains a mapping of category name to its category object.
CategoryNameMapIterator
An iterator to a category name map.
CategorySet
A set that can contains Category objects.
CategorySetIterator
An iterator to a category set.
CeilingAndFloor
A base class that provides support for all ceiling and floor objects.
ChangeType
City
An object that contains geographical location information for a known city.
CitySet
An set that contains cities.
CitySetIterator
An iterator to a city set.
Color
Represents a color in Autodesk Revit.
CombinableElement
An element that can be added to a geometry combination.
CombinableElementArray
An array that contains CombinableElement objects.
CombinableElementArrayIterator
An iterator to an CombinableElement array.
CompoundStructure
An object that describes the multi layered construction of walls or floors.
CompoundStructureLayer
An object that describes a single layer of multi-layered object.
CompoundStructureLayerArray
An array that contains layer objects.
CompoundStructureLayerArrayIterator
An iterator to a layer array.
ConicalFace
A cone face of a 3d solid.
Connector
A connector in an Autodesk Revit MEP project document.
ConnectorElement
A base class that provides support for all connector elements occurring in families.
ConnectorManager
Provides access to the Connector Manager in Autodesk Revit MEP.
ConnectorSet
A set that can contain any type of object.
ConnectorSetIterator
An iterator to a set.
Construction
Construction definition for Project Information.
ContFooting
An object that represents a Continuous Footing within Autodesk Revit.
ContFootingType
An object that specifies the type of a continuous footing in Autodesk Revit.
ContFootingTypeSet
A set that contains ContFooting types.
ContFootingTypeSetIterator
An iterator to a ContFooting type set.
Control
A control in Autodesk Revit family document.
CurtainCell
Represents a CurtainCell within Autodesk Revit.
CurtainCellSet
A set that can contain any type of object.
CurtainCellSetIterator
An iterator to a set.
CurtainGrid
Represents a curtain grid element within Autodesk Revit.
CurtainGridLine
Represents a CurtainGridLine within Autodesk Revit.
CurtainGridSet
A set that can contain any type of object.
CurtainGridSetIterator
An iterator to a set.
CurtainSystem
Provides access to the CurtainSystem object in Autodesk Revit.
CurtainSystemBase
Provides access to the CurtainSystemBase object in Autodesk Revit.
CurtainSystemType
An object that represents CurtainSystem type.
CurtainSystemTypeSet
A set that contains CurtainSystem types.
CurtainSystemTypeSetIterator
An iterator to a CurtainSystem type set.
Curve
A parametric curve.
CurveArrArray
An array that can contain any type of object.
CurveArrArrayIterator
An iterator to a array.
CurveArray
An array that can contain curves.
CurveArrayIterator
An iterator to a curve array.
CurveByPoints
A curve interpolating two or more points.
CurveByPointsArray
CurveByPointsArrayIterator
CurveByPointsUtils
A static class that contains methods for processing curves driven by points.
CurveElement
CurveElementFilter
CurveLoopsProfile
Represents a curve loop based profile for sweep or swept blend elements.
CylindricalFace
A cylinder face of a 3d solid.
Definition
The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
DefinitionBindingMap
A map that contains mappings of parameter definitions to parameter bindings.
DefinitionBindingMapIterator
An iterator to a parameter definition to parameter bindings map.
DefinitionFile
The DefinitionFile object represents a shared parameters file on disk.
DefinitionGroup
The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
DefinitionGroups
A specialized set of definition groups that allows creation of new groups.
DefinitionGroupsBase
A set that contains definition groups.
DefinitionGroupsBaseIterator
An iterator to a definition group set.
Definitions
A base class that supports the addition of new parameter definitions.
DefinitionsBase
A set that contains definitions.
DefinitionsBaseIterator
An iterator to a definition set.
DeleteElements
Deletes element(s) related to the failure.
DesignOption
An element that represents a design alternative.
DetailArc
Represents a DetailArc within Autodesk Revit.
DetailCurve
A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.
DetailCurveArray
An array that can contain any type of object.
DetailCurveArrayIterator
An iterator to a array.
DetailEllipse
Represents a DetailEllipse within Autodesk Revit.
DetailLine
Represents a DetailLine within Autodesk Revit.
DetailNurbSpline
Represents a DetailNurbSpline within Autodesk Revit.
DGNExportOptions
DGN Export options.
Dimension
An object that represents a dimension within the Revit project.
DimensionSegment
A segment of a dimension within the Autodesk Revit project.
DimensionSegmentArray
An array that can contain any number of DimensionSegment objects.
DimensionSegmentArrayIterator
An iterator to an array of DimensionSegment objects..
DimensionType
An object that represents a dimension style.
DimensionTypeSet
A set that contains dimension types.
DimensionTypeSetIterator
An iterator to a dimension type set.
DividedSurface
An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.
DividedSurfaceData
An interface to the divided surfaces on an element.
Document
An object that represents an open Autodesk Revit project.
DocumentPreviewSettings
Contains the settings related to the saving of preview images for a given document.
DocumentSet
A set that can contain any documents.
DocumentSetIterator
An iterator to a set of documents.
DoubleArray
An array that contains doubles.
DoubleArrayIterator
An iterator to an array of doubles.
DWFExportOptions
DWF Export options.
DWFXExportOptions
DWFX Export options.
DWGExportOptions
DWG Export options.
DWGImportOptions
Import options specific to AutoCAD's DWG file formats.
DXFExportOptions
DXF Export options.
Edge
An edge of a 3d solid.
EdgeArray
An array that contains edges.
EdgeArrayArray
An array of edge arrays.
EdgeArrayArrayIterator
An iterator to an array or edge arrays.
EdgeArrayIterator
An iterator to an edge array.
Element
Base class for most persistent data within a Revit document.
ElementArray
An array that contains element objects.
ElementArrayIterator
An iterator to an element array.
ElementBinding
A base class for all types of binding that attach to an element.
ElementCategoryFilter
A filter used to match elements by their category.
ElementClassFilter
A filter used to match elements by their class.
ElementDesignOptionFilter
A filter used to find elements contained within a particular design option.
ElementFilter
A base class for a type of filter that accepts or rejects elements based upon criteria.
ElementId
The ElementId object is used as a unique identification for an element within a single project.
ElementIsCurveDrivenFilter
A filter used to match elements which are curve driven.
ElementIsElementTypeFilter
A filter used to match elements which are ElementTypes.
ElementLevelFilter
A filter used to match elements by their associated level.
ElementLogicalFilter
A filter used to logically combine two or more filters.
ElementOwnerViewFilter
A filter used to match elements which are owned by a particular view.
ElementParameterFilter
A filter used to match elements by one or more parameter filter rules.
ElementQuickFilter
A base class for a type of filter that operates on element records.
ElementRecord
A record in the Revit database representing an element.
ElementSet
A set that contains element objects.
ElementSetIterator
An iterator to an element set.
ElementSlowFilter
A base class for a type of filter that operates on expanded elements.
ElementStructuralTypeFilter
A filter used to find elements matching a structural type.
ElementType
Base class for all Types within Autodesk Revit.
Ellipse
A whole or partial ellipse.
Enclosure
Represents an enclosed area or volume in the Revit model. This is the parent class for rooms, spaces and areas.
EnclosureTag
A tag attached to an Enclosure (room, space or area) in Autodesk Revit.
ExclusionFilter
A filter used to exclude a set of elements automatically.
ExportUtils
This class provides utilities related to document export.
ExternalDefinition
The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
ExternalDefinitions
Supports the creation of new shared parameters definitions.
Extrusion
A extrusion solid or void form.
ExtrusionRoof
Represents some kinds of Extrusion Roofs.
Face
A face of a 3d solid.
FaceArray
An array that contains faces.
FaceArrayIterator
An iterator to a face array.
FaceWall
A wall attached to a non-vertical massing face.
FailureDefinition
Defines persistent information about a failure.
FailureDefinitionAccessor
FailureDefinitionId
The unique identifier of a FailureDefinition.
FailureDefinitionRegistry
The global registry for all FailureDefinitions in the Revit session.
FailureHandlingOptions
Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended
FailureMessage
Represents a message describing a failure of an operation in Revit.
FailureMessageAccessor
Restricted accessor for FailureMessage.
FailureMessageKey
A unique key assigned to each posted failure message
FailureResolution
Defines a resolution for a failure.
FailuresAccessor
An interface class that provides access to failure information posted in a document and methods to resolve these failures.
Family
The Family object defines an entire family.
FamilyBase
A base class for all Family objects.
FamilyElementVisibility
Provides access to the visibility parameters of family elements in family document.
FamilyInstance
This object represents a single instance of a family type, such as a single I beam.
FamilyInstanceFilter
A filter used to find elements that are family instances of the given family symbol.
FamilyManager
The family manager object to manage the family types and parameters in family document.
FamilyParameter
The family parameter object.
FamilyParameterSet
A set that contains FamilyParameter objects.
FamilyParameterSetIterator
An iterator to a FamilyParameter set.
FamilyPointLocation
This object represents a data corresponding to the point locations in a certain types Family Symbols (see examples listed below).
FamilyPointPlacementReference
This object represents data corresponding to the placement references in a certain types of Family Instances (see examples listed below).
FamilySymbol
Represents a single Type within a Family.
FamilySymbolFilter
A filter used to find all family symbols of the given family.
FamilySymbolProfile
Represents a family symbol based profile for sweep or swept blend elements.
FamilySymbolSet
A set that can contain family symbols.
FamilySymbolSetIterator
An iterator to a family symbol set.
FamilyType
The family type object provides read access to the values of family parameters for this type.
FamilyTypeSet
A set that contains FamilyType objects.
FamilyTypeSetIterator
An iterator to a FamilyType set.
FamilyUtils
FBXExportOptions
3D-Studio Max (FBX) Export options.
FillPattern
Represents a fill pattern element within an Autodesk Revit project.
FillPatternSet
A set that contains FillPatterns.
FillPatternSetIterator
An iterator to a FillPattern set.
FilterableValueProvider
Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.
FilterDoubleRule
A filter rule that operates on double-precision numeric values in a Revit project.
FilteredElementCollector
This class is used to search, filter and iterate through a set of elements.
FilteredElementIdIterator
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
FilteredElementIterator
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
FilterElement
FilterElementIdRule
A filter rule that operates on ElementId values in a Revit project.
FilterIntegerRule
A filter rule that operates on integer values in a Revit project.
FilterInverseRule
A filter rule that inverts the boolean values returned by the rule it contains.
FilterNumericEquals
Tests whether numeric values from the document are equal to a certain value
FilterNumericGreater
Tests whether numeric values from the document are greater than a certain value
FilterNumericGreaterOrEqual
Tests whether numeric values from the document are greater than or equal to a certain value
FilterNumericLess
Tests whether numeric values from the document are less than a certain value
FilterNumericLessOrEqual
Tests whether numeric values from the document are less than or equal to a certain value
FilterNumericRuleEvaluator
Base for all classes that compare numeric values from Revit to a user-supplied filter value.
FilterNumericValueRule
Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons
FilterRule
Defines a boolean operation that can be used to cull elements from a document.
FilterStringBeginsWith
Tests whether string values from the document begin with a certain string.
FilterStringContains
Tests whether string values from the document contain a certain string.
FilterStringEndsWith
Tests whether string values from the document end with a certain string.
FilterStringEquals
Tests whether string values from the document match a certain string.
FilterStringGreater
Tests whether string values from the document would sort after a certain string.
FilterStringGreaterOrEqual
Tests whether string values from the document would sort after or match a certain string.
FilterStringLess
Tests whether string values from the document would sort before a certain string.
FilterStringLessOrEqual
Tests whether string values from the document would sort before or match a certain string.
FilterStringRule
A filter rule that operates on string values in a Revit project.
FilterStringRuleEvaluator
Base for all classes that compare string values from Revit to a user-supplied filter value
FilterValueRule
A rule that filters on a particular value of an element.
Floor
An object that represents a Floor within the Autodesk Revit project.
FloorType
An object that specifies the type of a floor in Autodesk Revit.
FloorTypeSet
A set that contains floor types.
FloorTypeSetIterator
An iterator to a floor type set.
FootPrintRoof
Represents kinds of FootPrintRoofs.
Form
An object that represents a Form within the Autodesk Revit Massing Family.
FormArray
An array that contains form objects.
FormArrayIterator
An iterator to a form array.
FormatOptions
Contains the Unit information of current user selection of Unit within the project.
FormUtils
Define Form utility functions
GBXMLExportOptions
Green-Building XML Export options.
GBXMLImportOptions
Import options for Green-Building XML format.
GenericForm
Provides access to the Generic Form model in Autodesk Revit.
GenericFormSet
A set that can contain any type of object.
GenericFormSetIterator
An iterator to a set.
GenericImportOptions
Generic Import options.
GeomCombination
An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.
GeomCombinationSet
A set that contains GeomCombination objects.
GeomCombinationSetIterator
An iterator to a GeomCombination set.
GeometryElement
Geometric representation of an element.
GeometryInstance
An instance of another element (symbol), specially positioned by this element.
GeometryObject
The common base class for all geometric primitives.
GeometryObjectArray
An array that contains geometry objects.
GeometryObjectArrayIterator
An iterator to a geometry object array.
GraphicsStyle
The graphics style instance in Autodesk Revit document.
Grid
Represents a single grid line within Autodesk Revit.
GridType
An object that represents a grid type.
GridTypeSet
A set that contains grid types.
GridTypeSetIterator
An iterator to a grid type set.
Group
This object represents a group of elements within the project.
GroupSet
An set that contains groups.
GroupSetIterator
An iterator to a group set.
GroupType
Represents a type of a user defined group.
GuidEnum
Base class of all GUID-based enum classes.
HermiteFace
A cubic hermite spline face of a 3d solid.
HermiteSpline
A Hermite spline.
HostedSweep
An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.
HostedSweepType
An object that represents the attributes for sweep host objects in Autodesk Revit.
HostObjAttributes
An object that represents characteristics of several kinds of type.
HostObject
A base class that provides support for all objects that can host other objects, such as a wall.
IFCExportOptions
IFC Export options.
ImageExportOptions
This class defines options for exporting views and sheets as an image.
ImageImportOptions
Import options specific image (bitmap) formats.
ImportInstance
An element created during either import or link operation in Autodesk Revit.
IndependentTag
Represents an IndependentTag within Autodesk Revit.
InsertableObject
A base class you all types that are insertable.
InSessionPrintSetting
Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
InSessionViewSheetSet
Represents the in-session ViewSheetSet.
Instance
A base class for all instance objects.
InstanceArray
An array that contains instances.
InstanceArrayIterator
An iterator to an instance array.
InstanceBinding
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
InternalDefinition
This object represents a parameter definition in Autodesk Revit.
InternalDefinitions
This object blocks attempts to create new internal definitions as they are not permitted.
IntersectionResult
This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
IntersectionResultArray
An array that can contain any type of object.
IntersectionResultArrayIterator
An iterator to a array.
InventorImportOptions
Import options for Inventor format.
LabelUtils
Used to obtain user-visible name for certain enums.
LayoutRule
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
LayoutRuleClearSpacing
This class indicate the layout rule of a Beam System is Clear-Spacing.
LayoutRuleFixedDistance
This class indicate the layout rule of a Beam System is Fixed-Distance.
LayoutRuleFixedNumber
This class indicate the layout rule of a Beam System is Fixed-Number.
LayoutRuleMaximumSpacing
This class indicate the layout rule of a Beam System is Max-Spacing.
Leader
An object that represents a Leader within the Autodesk Revit project.
LeaderArray
An array that can contain any number of leaders.
LeaderArrayIterator
An iterator to an array of leaders.
Level
Represents a Level line within Autodesk Revit.
LevelType
An object that represents a Level type.
LevelTypeSet
A set that contains level types.
LevelTypeSetIterator
An iterator to a level type set.
Line
A line in space.
LineAndTextAttrSymbol
An object that represents a dimension style.
LinearArray
An object that represents an Array created linearly within the Revit project.
LinePattern
Represents a line pattern element within an Autodesk Revit project.
LinePatternSet
A set that can contain any number of line patterns.
LinePatternSetIterator
An iterator to a set.
LinkElementId
LinkElementId represents an element in a linked document.
Location
Provides location functionality for all elements.
LocationCurve
Provides location functionality for all elements that are based upon a curve.
LocationPoint
Provides location functionality for all elements that have a single insertion point.
LogicalAndFilter
A filter that contains a set of filters. The filter passes when all filters in the set pass.
LogicalOrFilter
A filter that contains a set of filters. The filter passes when any filter in the set passes.
MassInstanceUtils
A static class that contains extra methods for processing curves driven by points.
Material
Represents a material element within an Autodesk Revit project.
MaterialConcrete
Represents a concrete material element in an Autodesk Revit project.
MaterialGeneric
Represents a generic material element in an Autodesk Revit project.
MaterialOther
Represents a material element other than concrete, generic, wood and steel in an Autodesk Revit project.
Materials
A set of materials that provides access to the materials in an Autodesk Revit project.
MaterialSet
An set that contains materials.
MaterialSetIterator
An iterator to a material set.
MaterialSteel
Represents a steel material element in an Autodesk Revit project.
MaterialWood
Represents a wood material element in an Autodesk Revit project.
MEPCurve
A curve object for duct or pipe blend elements.
MEPCurveType
A curve type for duct type or pipe type.
MEPModel
Supports all MEP models that are persistent within the Autodesk Revit project
MEPSystem
A system in the Autodesk Revit MEP product.
Mesh
A triangular mesh.
MeshArray
An array that contains meshes.
MeshArrayIterator
An iterator to a mesh array.
MeshTriangle
One triangle of a mesh.
ModelArc
Represents a ModelArc within Autodesk Revit.
ModelCurve
A model element that exists in 3D space and is visible in all views of a Revit project.
ModelCurveArrArray
An array that can contain any type of object.
ModelCurveArrArrayIterator
An iterator to a array.
ModelCurveArray
An array that contains model curves.
ModelCurveArrayIterator
An iterator to a model curve array.
ModelEllipse
Represents a ModelEllipse within Autodesk Revit.
ModelHermiteSpline
Represents a ModelHermiteSpline within Autodesk Revit.
ModelLine
Represents a ModelLine within Autodesk Revit.
ModelNurbSpline
Represents a ModelNurbSpline within Autodesk Revit.
ModelText
A model text element in an Autodesk Revit family document.
ModelTextType
A model text type symbol in the Autodesk Revit Family document.
Mullion
Represents a CurtainGrid within Autodesk Revit.
MullionType
An object that represents a mullion type.
MullionTypeSet
A set that contains mullion types.
MullionTypeSetIterator
An iterator to a mullion type set.
NurbSpline
A nurb spline.
ObjectFactory
For Internal Use Only.
Opening
An opening in an Autodesk Revit project or family document.
Options
User preferences for parsing of geometry.
Outline
Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.
Panel
This object represents a curtain panel.
PanelType
An object that represents a curtain panel type.
PanelTypeSet
A set that contains panel types.
PanelTypeSetIterator
An iterator to a panel type set.
PaperSize
An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
PaperSizeSet
A set that can contain any number of paper size objects.
PaperSizeSetIterator
An iterator to a set of paper size objects.
PaperSource
An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
PaperSourceSet
A set that can contain any number of paper source objects.
PaperSourceSetIterator
An iterator to a set of paper source objects.
Parameter
The parameter object contains the value data assigned to that parameter.
ParameterFilterElement
Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.
ParameterFilterRuleFactory
Contains functions that create appropriate FilterRule objects based on the parameters given.
ParameterFilterUtilities
Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.
ParameterMap
A map that can contain a mapping of a parameter name (a String) to a parameter.
ParameterMapIterator
An iterator to a map relating a parameter name (the key, a String) to a parameter.
ParameterSet
A set that contains parameters.
ParameterSetIterator
An iterator to a parameter set.
ParameterValueProvider
Gets the value of a parameter from any element passed to getStringValue, getDoubleValue, getIntegerValue, or getElementIdValue.
Path3d
Provides access to the Generic 3D path object in Autodesk Revit.
Phase
Represents a phase in the life of a building.
PhaseArray
An array that contains phase objects.
PhaseArrayIterator
An iterator to a phase array.
PlanarFace
A planar face of a 3d solid.
PlanCircuit
An object that represents an enclosed area in a plan view within the Autodesk Revit project.
PlanCircuitSet
A set that can contain any number of plan circuit objects.
PlanCircuitSetIterator
An iterator to a set of plan circuit objects.
Plane
Provides access to the geometry plane object.
PlanTopology
An object that represents a Plan Topology within the Autodesk Revit project.
PlanTopologySet
A set that can contain any number of plan topology objects.
PlanTopologySetIterator
An iterator to a set of plan topology objects.
Point
A 3D point.
PointElementReference
Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.
PointOnEdge
Define a ReferencePoint relative to a referenceable edge or curve on another element.
PointOnEdgeEdgeIntersection
Define a ReferencePoint at the intersection of two referenceable lines.
PointOnEdgeFaceIntersection
Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.
PointOnFace
Define a ReferencePoint relative to a Face.
PointOnPlane
Define a ReferencePoint relative to a planar reference.
PrimaryDesignOptionMemberFilter
A filter used to find elements contained in any primary design option of any design option set.
PrintManager
The PrintManager object is used to configure the global print settings.
PrintParameters
An object that contains settings used for printing the document.
PrintSetting
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
PrintSetup
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Profile
A geometric profile consisting of a loop of curves.
ProjectInfo
An object that represents a Project Information within the Autodesk Revit project.
ProjectLocation
An object that represents a named location in a project.
ProjectLocationSet
An set that contains project locations.
ProjectLocationSetIterator
An iterator to a project location set.
ProjectPosition
An object that is used to represent a geographical offset and rotation.
ProjectUnit
Provides access to the Project Unit... in Autodesk Revit.
PropertyLine
Represents kinds of PropertyLines.
RadialArray
An object that represents a Radial Array in the Revit project.
Rectangle
Stores a set of four integers that represent the left, top, right and bottom of a rectangle.
Reference
A stable reference to a geometric object in a Revit model.
ReferenceArray
ReferenceArrayArray
An array that contains ReferenceArray objects.
ReferenceArrayArrayIterator
An iterator to a ReferenceArray array.
ReferenceArrayIterator
An iterator to a reference array.
ReferencePlane
Represents a reference plane of Autodesk Revit.
ReferencePoint
A reference point in an Autodesk Revit family.
ReferencePointArray
ReferencePointArrayIterator
RevitUIFamilyLoadOptions
Allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.
Revolution
A revolution solid or void form.
RevolvedFace
A revolved face of a 3d solid.
RoofBase
Represents all kinds of Roofs.
RoofType
Represents a specific type of roof.
RoofTypeSet
A set that contains roof types.
RoofTypeSetIterator
An iterator to a roof type set.
RuledFace
A ruled face of a 3d solid.
SATExportOptions
SAT Export options.
Settings
The settings object provides access to general components of the Autodesk Revit application, such as Categories.
SharedParameterApplicableRule
Tests whether an element supports a shared parameter.
SiteLocation
Contains the geographical location information for the project's site.
Sketch
Provides access to the Sketch in Autodesk Revit.
SketchBase
Provides access to the SketchBase in Autodesk Revit.
SketchPlane
Represents a sketch plane or work plane within Autodesk Revit.
SlabEdge
An object that represents a slab edge within the Autodesk Revit project.
SlabEdgeType
An object that represents the slab edge type in Autodesk Revit.
SlabEdgeTypeSet
A set that contains slab edge types.
SlabEdgeTypeSetIterator
An iterator to a slab edge type set.
SlabShapeCrease
A crease used in Slab Shape Editing.
SlabShapeCreaseArray
An array that can contain any number of creases used in Slab Shape Editing.
SlabShapeCreaseArrayIterator
An iterator to an array of creases used for Slab Shape Editing.
SlabShapeEditor
An object used for Slab Shape Editing.
SlabShapeVertex
A vertex used in Slab Shape Editing.
SlabShapeVertexArray
An array that can contain any number of vertices used in Slab Shape Editing.
SlabShapeVertexArrayIterator
An iterator to an array of vertices used for Slab Shape Editing.
Solid
A 3d solid.
SolidArray
An array that contains solids.
SolidArrayIterator
An iterator to a solids array.
SolidSolidCutUtils
These utilities are applicable for the generic forms, geometry combinations and family instances in editor situations
SpacingRule
A rule for specifying a set of equidistant, parallel gridlines within a region.
SpotDimension
An object that represents a spot dimension within the Revit project.
SpotDimensionType
An object that specifies the type of a spot dimension in Autodesk Revit.
SpotDimensionTypeSet
A set that contains spotdimension types.
SpotDimensionTypeSetIterator
An iterator to a spotdimension type set.
SubTransaction
Sub-transactions are objects that allow controlling a subset of changes in a document
SunAndShadowSettings
The SunAndShadowSettings class represents the sun control.
SuspendUpdating
Temporarily delay Revit's automatic updating and consistency operations.
Sweep
A sweep solid or void form.
SweepProfile
Represents a profile for sweep or swept blend elements.
SweptBlend
A swept blend solid or void form.
SymbolicCurve
A curve that provides information but is not intended to represent actual geometry in an element.
SymbolicCurveArray
An array that contains model curves.
SymbolicCurveArrayIterator
An iterator to a model curve array.
TableCellCalculatedValueData
The TableCellCalculatedValueData stores the data for calculated value
TableCellCombinedParameterData
The TableCellCombinedParameterData stores the data for combined parameters
TableCellStyle
The TableCellStyle class contains the appearance settings for a given table cell, column, or table.
TableData
The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.
TableMergedCell
The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.
TableSectionData
The TableSectionData class represents a serialized version of an instance of section table data. The class holds row, column and cell data.
TableView
This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.
TextElement
Represents the TextElment.
TextElementType
An object that represents a text style.
TextNote
Provides access to the TextNote object in Autodesk Revit.
TextNoteType
An object that represents a text note style.
TextNoteTypeSet
A set that contains textnote types.
TextNoteTypeSetIterator
An iterator to a textnote type set.
TilePattern
An object representing a tile pattern that may be applied to a DividedSurface.
TilePatterns
The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.
TopographySurface
An object that is used to represent a topography surface.
Transaction
Transactions are context-like objects that guard any changes made to a Revit model
TransactionGroup
This class is introduced to group a set of transactions
Transform
A transformation of the affine 3-space.
TypeBinding
TypeBinding objects are used to bind a property to a Revit type, such as a wall type.
UpdaterData
Service class that is passed to an Updater to prove access to update execution context
UpdaterId
A unique identifier of an Updater
UpdaterRegistry
Application level singleton that stores registered Updaters Note: In order to use UpdaterRegistry functionality, add-ins must be registered using manifest files (rather than Revit.ini) UpdaterId::getAddInId() for any Updater/UpdaterId to be modified must match the addInId field in the add-in's manifest file. An add-in cannot add, remove, or modify updaters that do not belong to it.
UV
Object representing coordinates in 2-dimensional space.
VertexIndexPair
Represents a connection between vertices in the top and bottom profile of a blend.
VertexIndexPairArray
An array that contains VertexIndex pairs.
VertexIndexPairArrayIterator
An iterator to an array of VertexIndex pairs.
View
Base class for all types of views in Autodesk Revit.
View3D
A freely-oriented orthographic or perspective view of the model.
ViewDrafting
A drafting view allows the user to draw graphics without including them in the model.
ViewPlan
A plan represents for floor plan or ceiling plan.
ViewSection
A section view cuts through the model to expose its interior structure.
ViewSet
A set that contains views.
ViewSetIterator
An iterator to a view set.
ViewSheet
A sheet is a view used to prepare a finished printout. It contains other views and a titleblock.
ViewSheetSet
Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.
ViewSheetSets
A set that can contain any type of object.
ViewSheetSetsIterator
An iterator to a set.
ViewSheetSetting
Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.
VolumeCalculationOptions
This class provides access to options related to room volume and area computations.
VolumeCalculationSetting
This class provides access to settings related to room volume and area computations.
Wall
Represents all of the different kinds of walls Autodesk Revit.
WallType
Represents a specific type of wall, such as 'Generic -8" '.
WallTypeSet
A set that contains wall types.
WallTypeSetIterator
An iterator to a wall type set.
XYZ
Object representing coordinates in 3-dimensional space.

Structures

Structure | Description
GridNode |

Interfaces

Interface | Description
IConnector | An interface which provides access to connector in Autodesk Revit MEP document.
IExtension | An interface that supports the additional operation for Extension Status
IFailuresPreprocessor | An interface that may be used to perform a preprocessing step to either filter out anticipated transaction failures or to mark certain failures as non-continuable.
IFailuresProcessor | To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.
IFamilyLoadOptions | An interface class which provide the callback for family load options.
IPrintSetting | An interface which represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
ITransactionFinalizer | An interface that may be used to perform a custom action at the end of a transaction. A method of the interface will be called when a transaction is either committed or rolled back.
IUpdater | The interface used to create an updater capable of reacting to changes in the Revit model.
IViewSheetSet | This interface represents a selected set of views/sheets which will be used for printing.

Enumerations

Enumeration | Description
ACADVersion | An enumerated type listing available AutoCAD versions, into which a file may be exported.
AnalyzesAsType | This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.
AreaElemType | An enumerated type to store type of AreaElement.
BeamSystemJustifyType | Describes the justify method of beamsystem.
BorderTile | Options for controlling tiles that overlap the face boundary. See DividedSurface.
BoxPlacement | An enumerated type listing possible placement of a box (an object of rectangular shape.)
BuildingType | An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
BuiltInCategory | A list of all the built in categories within Revit.
BuiltInParameter | An enumerated type listing all of the built-in parameter ids supported by Autodesk Revit.
BuiltInParameterGroup | An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
CellType | Declares the cell data type.
ChangePriority | Enum used to specify the priority of an Updater during execution.
ColorDepthType | An enumerated type listing all Color Depth types of Print Setting.
ComponentRotation | ComponentRotation property of DividedSurface. See DividedSurface.
CompoundStructureDeckUsage | Describes how the deck relates to the surrounding layers.
CompoundStructureLayerFunction | Describes the purpose of the layer within a compound structure, such as a wall or floor.
ConnectorProfileType | An enumerated type listing all the connector profile types for a connection.
ConnectorType | An enumerated type listing all the connector types for a connection.
ConstructionType | Obsolete. An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
ControlShape | An enumerated type listing four shapes of control that Autodesk Revit supports.
CoordinatePlaneVisibility | Visibility settings for ReferencePoint element's coordinate reference planes.
CurtainGridAlignType | An enumerated to list CurtainGrid patterns.
CurveElementType |
CurveProjectionType | This attribute indicates how the curve will be projected to the surface if the curve is sketched on the surface.
CutFailureReason | The reason why a solid/solid cut cannot be created.
DecimalSymbolType | An enumerated type listing two types of the Decimal Symbol types that Autodesk Revit supports.
DetailLevels | Chooses the detail level of an element's representation.
DigitGroupingAmount | An enumerated type listing the types of the Digit Grouping Amount that Autodesk Revit supports.
DigitGroupingSymbolType | An enumerated type listing the types of the Digit Grouping Symbol types that Autodesk Revit supports.
DimensionShape | An enumerated type to list dimension type.
DimensionStyleType | An enumerated type containing possible style types of dimensions.
DisplayUnit | Describes the type of Revit display unit, metric or imperial.
DisplayUnitType | An enumerated type listing Display Unit types of the Unit types that Autodesk Revit supports.
DocumentType | Types of Revit documents.
Domain | An enumerated type listing all the possible domain types that can be assigned to a connector.
DWFImageFormat | An enumerated type listing possible image format for DWF Export.
DWFImageQuality | An enumerated type listing possible image quality for DWF Export.
EaveCutterType | An enumerated type to store type of EaveCutter.
ElementReferenceType | Element reference types.
ExportColorMode | An enumerated type listing export color mode.
ExportPaperFormat | Paper formats supported by DWF export
ExportRange | This enum is used to define what view, part of the view, or list of views will be exported.
ExportUnit | An enumerated type listing possible target units for CAD Export.
FailureProcessingResult | Enum represents result of failure processing by FailuresPreprocessor, handler of FailuresProcessing event or by FailuresProcessor.
FailureResolutionType | Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.
FailureSeverity | Enum represents severity of a failure.
FamilyElementVisibilityType | Indicates the Visibility type of generic forms.
FamilyHostingBehavior | Types of hosts into/onto which a family can be hosted. For informative purposes only. Does not affect anything in Revit!
FamilySource | Describes which version of the family to be loaded.
FitDirectionType | This enum is used to define the direction to fit the number of pixels defined by PixelSize.
FloorFace | An enumerated type listing floor face types (top or bottom)
FlowDirectionType | An enumerated type listing direction types for a connector.
GraphicsStyleType | Describes the type of graphics style.
GridNodeLocation | Location of a grid node relative to the face boundary. See DividedSurface.
GridSegmentDirection | Specify one of the four adjacent segments to a GridNode. See DividedSurface.
HiddenLineViewsType | An enumerated type listing all Hidden Line Views types of Print Setting.
HorizontalAlign | Horizontal alignment of model text.
HorizontalAlignmentStyle | Declares the horizontal alignment style of font.
IFCVersion | An enumerated type listing available IFC file versions into which a file may be exported.
ImageFileType | This enum is used to define exported file type.
ImageResolution | This enum is used to define image resolution in order to calculate the image size.
ImportColorMode | An enumerated type listing how colors are handled in an import process.
ImportExportFileFormat | Formats supported import / export
ImportPlacement | An enumerated type listing possible placement modes for imported drawings.
ImportUnit | An enumerated type listing possible target units for CAD Export.
JoinType | The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.
JunctionType | An enumerated type listing all the junction types for MEP curve types.
LeaderEndCondition | An enumerated type listing Leader End Condition which tie to the Independent Tag that Autodesk Revit supports.
LineScaling | An enumerated type listing possible LineType scaling modes.
MarginType | An enumerated type listing all Margin types of Print Setting.
MassDisplayTemporaryOverrideType | This enum identifies the mass display overrides.
MaterialBehaviourType | An enumerated type listing all the material behavior type.
PageOrientationType | An enumerated type listing all Page Orientation types of Print Setting.
PaperPlacementType | An enumerated type listing all Paper Placement types of Print Setting.
ParameterType | An enumerated type listing all of the data type interpretation that Autodesk Revit supports.
PartType | An enumerated type listing all the possible part types for a fitting.
PrintRange | An enumerated type listing all Print Range types of Print.
ProfilePlaneLocation | Indicates the location of Sweep profile plane on the path curve.
PropOverrideMode | An enumerated type listing ways how overridden object styles get exported.
RasterQualityType |
ReferenceType | Reference types of curve element.
SectionType | Declares the section data type.
ServiceType | An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
SetComparisonResult | An enumerated type listing all the relationship types between two sets of arbitrary nature.
SlabShapeCreaseType | An enumerated type listing all Crease types of Slab Shape Edit.
SlabShapeVertexType | An enumerated type listing all Vertex types of Slab Shape Edit.
SlantedOrVerticalColumnType | This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.
SolidGeometry | An enumerated type listing possible ways of exporting solids in 3D views.
SpacingRuleJustification | Justification property of a spacing rule. See SpacingRule.
SpacingRuleLayout | Rules for laying out a series of equidistant parallel lines. See SpacingRule.
StickSymbolLocation | Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.
StorageType | An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.
StructuralReleaseType | Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.
SunAndShadowType | Sun study type enum of SunAndShadowSettings.
SunStudyTimeInterval | Time interval enum for a single or multi-day sun study.
TagMode | An enumerated type listing Tag Mode when user adding tag that Autodesk Revit supports.
TagOrientation | An enumerated type listing Tag Orientation of the Independent Tag that Autodesk Revit supports.
TextAlignFlags | An enumerated type listing all the Text align flags.
TextAlignMask | An enumerated type listing all the Text align mask.
TextElementBackground | An enumerated type listing all the background mode for the built-in parameter TEXT_BACKGROUND.
TextNoteLeaderStyles | An enumerated type listing all the Leader styles.
TextNoteLeaderTypes | An enumerated type listing all the Leader types.
TilePatternsBuiltIn | Revit's built-in tile patterns. See TilePattern.
TransactionStatus |
UnitGroup | An enumerated type listing Discipline of the Unit types that Autodesk Revit supports.
UnitSymbolType | An enumerated type listing Display Unit types of the Unit types that Autodesk Revit supports.
UnitType | An enumerated type listing all the Unit types that Autodesk Revit supports.
VerticalAlignmentStyle | Declares the vertical alignment style of font.
ViewPlanType | An enumerated type listing plan view types.
ViewType | An enumerated type listing available view types.)
VirtualPrinterType | An enumerated to list Virtual Printer Types in Revit.
Visibility | Describes the visibility of a particular geometry object.
WallFunction | Indicates the function of a specified WallType, which is used for the BuiltInParameter WALL_ATTR_EXTERIOR.
WallKind | Describes the fundamental type of wall, such as curtain wall or stacked wall.
WallLocationLine | This enumerated type represents the options for alignment of a wall's location line.
ZoomFitType | This enum is used to define type of zoom.
ZoomType | An enumerated type listing all Zoom types of Print Setting.

ACADExportOptions Class

[image]