Revit 2011 API
ElectricalConnector..::.Width Property
ElectricalConnector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::.Width

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace

ElectricalDemandFactorDefinition Class

[image]