Revit 2011 API
TransactionGroup Constructor (Document, String)
TransactionGroup Class See Also Send Feedback
It constructs a transaction group object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionGroup(
    Document document,
    string transGroupName
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    transGroupName As String _
)
Visual C++
public:
TransactionGroup(
    Document^ document,
    String^ transGroupName
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document in which the changes might be made
transGroupName
Type: System..::.String
Name of the group When assimilate the group, all transactions inside the group will be merged into one undo menu item with the group's name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Unable to instantiate a TransactionGroup within an open transaction
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TransactionGroup Class
TransactionGroup Overload

TransactionGroup Methods

[image] [image]