Revit 2011 API
Document..::.Mirror Method (ElementSet, Reference)
Document Class See Also Send Feedback
Mirrors several elements about a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirror(
    ElementSet elements,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    elements As ElementSet, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementSet^ elements,
    Reference^ reference
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be mirrored.
reference
Type: Autodesk.Revit.DB..::.Reference
The reference by which the elements will mirror.

Return Value

True if the elements are mirrored successfully.

See Also

Document Class
Mirror Overload

Mirror Method (ICollection(ElementId), Reference)

[image]