Revit 2011 API
AnalyzesAsType Enumeration
See Also Send Feedback
This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyzesAsType
Visual Basic (Declaration)
Public Enumeration AnalyzesAsType
Visual C++
public enum class AnalyzesAsType

Members

Member name | Description
AA_Hanger |
AA_Gravity |
AA_Lateral |
AA_Slab |
AA_Mat |
AA_SlabOnGrade |
AA_Not_For_Analysis |

See Also

AnnotationSymbol Class

[image]