Revit 2011 API
ItemFactoryBase..::.NewFamilyInstance Method (Face, Line, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
A face of a geometry object.
position
Type: Autodesk.Revit.DB..::.Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a line on the face to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)

[image]