Revit 2011 API
RebarShape..::.HookOrientation Property
RebarShape Class See Also Send Feedback
Get and set the hook orientation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarHookOrientation HookOrientation[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Property HookOrientation ( _
    index As Integer _
) As RebarHookOrientation
Visual C++
public:
property RebarHookOrientation HookOrientation[int index] {
    RebarHookOrientation get (int index);
    void set (int index, RebarHookOrientation value);
}

Parameters

index
Type: System..::.Int32
0 for the starting hook, 1 for the ending hook.

Remarks

Orientation is 1 for the left side of the shape or -1 for the right side. For arc-driven shapes, 1 is for the inside of the arc, -1 for the outside.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

Parameter Property

[image] [image]