Revit 2011 API
FamilyManager..::.Parameters Property
FamilyManager Class See Also Send Feedback
All family parameters in this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameterSet Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As FamilyParameterSet
Visual C++
public:
property FamilyParameterSet^ Parameters {
    FamilyParameterSet^ get ();
}

Remarks

These parameters will include the 'family parameter', 'shared parameter' and 'builtIn parameter' binding to the family types. Some parameters might be created as placeholders without a currently assigned value.

See Also

FamilyManager Class

Types Property

[image]