Revit 2011 API
PanelScheduleData..::.SetLoadClassifications Method
PanelScheduleData Class See Also Send Feedback
sets the Load Classifications associated with this panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLoadClassifications(
    IList<ElementId> loadClassificaions
)
Visual Basic (Declaration)
Public Sub SetLoadClassifications ( _
    loadClassificaions As IList(Of ElementId) _
)
Visual C++
public:
void SetLoadClassifications(
    IList<ElementId^>^ loadClassificaions
)

Parameters

loadClassificaions
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace

UpdateCircuitTableForInstance Method

[image]