Revit 2011 API
FootPrintRoof..::.Offset Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the Offset of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Offset[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property Offset ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double Offset[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::.ModelCurve

See Also

FootPrintRoof Class

Overhang Property

[image]