Revit 2011 API
ControlledApplication Methods
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

Name | Description
GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
WriteJournalComment | Writes a comment to the Revit journal file

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

GetFailureDefinitionRegistry Method

[image]