Revit 2011 API
Document..::.FindReferencesByDirection Method
Document Class See Also Send Feedback
Finds the references that intersect a line extended in a certain direction from an origin point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArray FindReferencesByDirection(
    XYZ pOrigin,
    XYZ pDirection,
    View3D pView
)
Visual Basic (Declaration)
Public Function FindReferencesByDirection ( _
    pOrigin As XYZ, _
    pDirection As XYZ, _
    pView As View3D _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ FindReferencesByDirection(
    XYZ^ pOrigin,
    XYZ^ pDirection,
    View3D^ pView
)

Parameters

pOrigin
Type: Autodesk.Revit.DB..::.XYZ
The origin of the line.
pDirection
Type: Autodesk.Revit.DB..::.XYZ
The direction.
pView
Type: Autodesk.Revit.DB..::.View3D
The 3D view used to determine the geometry for intersection. If the view has specific geometry (section cuts, visibility changes due to detail level or hidden categories) this will affect the results.

Return Value

An array of references for items the line intersects.

Remarks

This method finds both elements and geometric references which intersect the ray. Some element references returned will not have a corresponding geometric object which is also intersected (for example, rays passing through openings in walls will intersect the wall and the opening element). If you are interested only in true physical intersections you should discard all references whose GeometryObject is of type Element.

References will be found and returned from either the positive or negative direction along the line. Use the reference's ProximityParameter to sort the results or exclude references found in the opposite direction to the given direction.

This method will return intersections encountered only in the main document. Intersections in linked files will not be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when pOrigin, pDirection or pView is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class

GetDocumentPreviewSettings Method

[image]