Revit 2011 API
RebarHostData..::.Valid Property
RebarHostData Class See Also Send Feedback
Returns whether the element is a valid rebar host.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Valid { get; }
Visual Basic (Declaration)
Public ReadOnly Property Valid As Boolean
Visual C++
public:
property bool Valid {
    bool get ();
}

Remarks

If getRebarHostData() returns an invalid RebarHostData, this means that the element can be made a valid rebar host, generally by setting a property like FLOOR_PARAM_IS_STRUCTURAL or by changing the element's physical material to concrete. On the other hand, if getRebarHostData() returns nullNothingnullptra null reference (Nothing in Visual Basic), the element cannot be made into a rebar host.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace

RebarLayoutRule Enumeration

[image]