Revit 2011 API
Family Properties
Family Class See Also Send Feedback

The Family type exposes the following members.

Properties

Name | Description
CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
IsEditable | Indicates if this family supports editing.
IsInPlace | Indicates if this family is an in-place family or not.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Symbols | A set of all symbols (types) that belong to a Family.

See Also

Family Class

CurtainPanelHorizontalSpacing Property

[image]