Revit 2011 API
RebarBarType..::.StandardHookBendDiameter Property
RebarBarType Class See Also Send Feedback
Defines hook bend diameter for rebar whose style is standard

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StandardHookBendDiameter { get; set; }
Visual Basic (Declaration)
Public Property StandardHookBendDiameter As Double
Visual C++
public:
property double StandardHookBendDiameter {
    double get ();
    void set (double value);
}

Field Value

The hook bend diameter for rebar whose style is standard

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: the bend diameter standardHookBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

StirrupTieBendDiameter Property

[image]