Revit 2011 API
Document..::.Mirror Method (Element, Reference)
Document Class Example See Also Send Feedback
Mirrors an element about a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirror(
    Element element,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    element As Element, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    Element^ element,
    Reference^ reference
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
A element that is to be mirrored.
reference
Type: Autodesk.Revit.DB..::.Reference
The reference by which the elements will mirror.

Return Value

True if the elements are mirrored successfully.

Examples

CopyC#
public void MirrorColumn(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
    UIDocument uidoc = new UIDocument(document);
    AnalyticalModel analytical = column.GetAnalyticalModel() as AnalyticalModel;
    Reference lineReference = analytical.GetCurve().Reference;
    document.Mirror(column, lineReference);

    //The selected element is changed after the Mirror operation.
    foreach (Autodesk.Revit.DB.FamilyInstance newColumn in uidoc.Selection.Elements)
    {
        bool isMirror = newColumn.Mirrored;

        TaskDialog.Show("Revit","Column is mirrored: " + isMirror);

        //Offset the new column
        XYZ translationVec = new XYZ(10, 20, 30);
        newColumn.Location.Move(translationVec);
    }
}
CopyVB.NET
Public Sub MirrorColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance)
    Dim uidoc As New UIDocument(document)
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    Dim lineReference As Reference = analytical.GetCurve().Reference
    document.Mirror(column, lineReference)

    'The selected element is changed after the Mirror operation.
    For Each newColumn As Autodesk.Revit.DB.FamilyInstance In uidoc.Selection.Elements
        Dim isMirror As Boolean = newColumn.Mirrored

        TaskDialog.Show("Revit", "Column is mirrored: " + isMirror)

        'Offset the new column
        Dim translationVec As New Autodesk.Revit.DB.XYZ(10, 20, 30)
        newColumn.Location.Move(translationVec)
    Next
End Sub

See Also

Document Class
Mirror Overload

Mirror Method (ElementId, Reference)

[image]