Revit 2011 API
Parameter..::.Definition Property
Parameter Class See Also Send Feedback
Returns the Definition object that describes the data type, name and other details of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Definition Definition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definition As Definition
Visual C++
public:
property Definition^ Definition {
    Definition^ get ();
}

Remarks

This will always be an InternalDefinition object. If you want the Guid for a shared parameter, use GUID.

See Also

Parameter Class

DisplayUnitType Property

[image]