Revit 2011 API
DocumentEntryPoint..::.Selection Property
DocumentEntryPoint Class See Also Send Feedback
Retrieve the currently selected Elements in Autodesk Revit.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Selection Selection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selection As Selection
Visual C++
public:
property Selection^ Selection {
    Selection^ get ();
}

Remarks

Returns an object that represents the active selection. The Selection property returns an object that represents the active selection when the command was started.

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace

IEntryPoint Interface

[image]