Revit 2011 API
MassSurfaceData..::.GetFaceReferences Method
MassSurfaceData Class See Also Send Feedback
Gets References to the faces that the MassSurfaceData provides properties for.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<Reference> GetFaceReferences()
Visual Basic (Declaration)
Public Function GetFaceReferences As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetFaceReferences()

Return Value

Returns an array of References to Faces that the MassSurfaceData provides properties for.

Remarks

The results are always references to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports them as REFERENCE_TYPE_NONE.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace

MassSurfaceData Properties

[image] [image]