Revit 2011 API
AnalysisDisplayStyle Members
AnalysisDisplayStyle Class Methods Properties See Also Send Feedback

The AnalysisDisplayStyle type exposes the following members.

Methods

Name | Description
CreateAnalysisDisplayStyle | Overloaded.
FindByName | Finds analysis display style by name.
GetColoredSurfaceSettings | Get colored surface settings object from the style.
GetColorSettings | Get color settings object from the style.
GetElements | Returns set of all analysis display styles elements in the given document.
GetLegendSettings | Get legend settings object from the style.
GetMarkersAndTextSettings | Get markers and text settings object from the style.
IsNameUnique | Verify the uniqueness of the name among all analysis display style elements of the document.
IsTextTypeIdValid | Verify if text type id is valid.
SetColoredSurfaceSettings | Set colored surface settings object for the style.
SetColorSettings | Set color settings object for the style.
SetLegendSettings | Set legend settings object for the style.
SetMarkersAndTextSettings | Set markers and text settings object for the style.
SetName | Set name of analysis display style element.

Properties

Name | Description
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayStyle Methods

[image] [image]