Revit 2011 API
FamilyItemFactory Members
FamilyItemFactory Class Methods Properties See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Methods

Name | Description
NewAngularDimension | Overloaded. Creates a new angular dimension object.
NewArcLengthDimension | Overloaded. Creates a new arc length dimension object.
NewBlend | Add a new Blend instance into the Autodesk Revit family document.
NewControl | Add a new control into the Autodesk Revit family document.
NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
NewDimension | Overloaded. Creates a new linear dimension object.
NewDividedSurface | Create a DividedSurface element on one surface of another element.
NewDuctConnector | Add a new duct connector into the Autodesk Revit family document.
NewElectricalConnector | Add a new Electrical connector into the Autodesk Revit family document.
NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
NewLinearDimension | Overloaded. Creates a new linear dimension object.
NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
NewModelText | Create a model text in the Autodesk Revit family document.
NewOpening | Create an opening to cut the wall or ceiling.
NewPipeConnector | Add a new pipe connector into the Autodesk Revit family document.
NewRadialDimension | Overloaded. Creates a new radial dimension object.
NewReferencePoint | Overloaded. Creates a reference point.
NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSweep | Overloaded. Adds a new sweep form to the family document.
NewSweptBlend | Overloaded. Adds a new swept blend into the family document.
NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
NewTextNote | Overloaded. Creates a new TextNote object.

Properties

Name | Description

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

FamilyItemFactory Methods

[image] [image]