Revit 2011 API
CompoundStructureLayer..::.Material Property
CompoundStructureLayer Class Example See Also Send Feedback
Get or set the material from which the layer is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Material Material { get; set; }
Visual Basic (Declaration)
Public Property Material As Material
Visual C++
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}

Examples

CopyC#
public void GetWallLayerMaterial(Autodesk.Revit.DB.Document document, Wall wall)
{
    // get WallType of wall
    WallType aWallType = wall.WallType;
    // Only Basic Wall has compoundStructure
    if (WallKind.Basic == aWallType.Kind)
    {
        // Get CompoundStructure
        CompoundStructure comStruct = aWallType.CompoundStructure;
        Categories allCategories = document.Settings.Categories;

        // Get the category OST_Walls default Material;
        // use if that layer's default Material is <By Category>
        Category wallCategory = allCategories.get_Item(BuiltInCategory.OST_Walls);
        Autodesk.Revit.DB.Material wallMaterial = wallCategory.Material;

        foreach (CompoundStructureLayer structLayer in comStruct.Layers)
        {
            Autodesk.Revit.DB.Material layerMaterial = structLayer.Material;
            // If CompoundStructureLayer's Material is specified, use default
            // Material of its Category
            if (null == layerMaterial)
            {
                switch (structLayer.Function)
                {
                    case CompoundStructureLayerFunction.Finish1:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsFinish1).Material;
                        break;
                    case CompoundStructureLayerFunction.Finish2:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsFinish2).Material;
                        break;
                    case CompoundStructureLayerFunction.MembraneLayer:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsMembrane).Material;
                        break;
                    case CompoundStructureLayerFunction.Structure:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsStructure).Material;
                        break;
                    case CompoundStructureLayerFunction.Substrate:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsSubstrate).Material;
                        break;
                    case CompoundStructureLayerFunction.ThermalOrAir:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsInsulation).Material;
                        break;
                    default:
                        // It is impossible to reach here
                        break;
                }
                if (null == layerMaterial)
                {
                    // CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial;
                }
            }
            TaskDialog.Show("Revit","Layer Material: " + layerMaterial);
        }
    }
}
CopyVB.NET
Public Sub GetWallLayerMaterial(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall)
    ' get WallType of wall
    Dim aWallType As Autodesk.Revit.DB.WallType = wall.WallType
    ' Only Basic Wall has compoundStructure
    If WallKind.Basic = aWallType.Kind Then
        ' Get CompoundStructure
        Dim comStruct As Autodesk.Revit.DB.CompoundStructure = aWallType.CompoundStructure
        Dim allCategories As Categories = document.Settings.Categories

        ' Get the category OST_Walls default Material;
        ' use if that layer's default Material is <By Category>
        Dim wallCategory As Autodesk.Revit.DB.Category = allCategories.Item(BuiltInCategory.OST_Walls)
        Dim wallMaterial As Autodesk.Revit.DB.Material = wallCategory.Material

        For Each structLayer As Autodesk.Revit.DB.CompoundStructureLayer In comStruct.Layers
            Dim layerMaterial As Autodesk.Revit.DB.Material = structLayer.Material
            ' If CompoundStructureLayer's Material is specified, use default
            ' Material of its Category
            If layerMaterial Is Nothing Then
                Select Case structLayer.[Function]
                    Case CompoundStructureLayerFunction.Finish1
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish1).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.Finish2
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish2).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.MembraneLayer
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsMembrane).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.[Structure]
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsStructure).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.Substrate
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsSubstrate).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.ThermalOrAir
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsInsulation).Material
                        Exit Select
                    Case Else
                        ' It is impossible to reach here
                        Exit Select
                End Select
                If layerMaterial Is Nothing Then
                    ' CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial
                End If
            End If
            TaskDialog.Show("Revit", "Layer Material: " & layerMaterial.ToString())
        Next
    End If
End Sub

See Also

CompoundStructureLayer Class

Thickness Property

[image]