Revit 2011 API
FamilyUtils..::.ConvertFamilyToFaceHostBased Method
FamilyUtils Class See Also Send Feedback
Converts a family to be face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static void ConvertFamilyToFaceHostBased(
    Document aDoc,
    ElementId famId
)
Visual Basic (Declaration)
Public Shared Sub ConvertFamilyToFaceHostBased ( _
    aDoc As Document, _
    famId As ElementId _
)
Visual C++
public:
static void ConvertFamilyToFaceHostBased(
    Document^ aDoc,
    ElementId^ famId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::.Document
The document containing the family to be converted.
famId
Type: Autodesk.Revit.DB..::.ElementId
The family id.

Remarks

This function converts an entire family (including all its types) to be face host based. There can be no instances of any of the types of the family already in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input famId cannot be converted to face host based.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The family is already unhosted. -or- Failed to convert the family to face host based.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FamilyUtils Class

Dispose Method

[image]