Revit 2011 API
Document Class
Members See Also
An object that represents an open Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Document : IDisposable
Visual Basic (Declaration)
Public Class Document _
    Implements IDisposable
Visual C++
public ref class Document : IDisposable

Remarks

The Document object represents an Autodesk Revit project. Revit can have multiple projects open and multiple views to those projects. The active or top most view will be the active project and hence the active document which is available from the Application object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Document

See Also

Document Members