Revit 2011 API
FailureDefinitionAccessor..::.GetSeverity Method
FailureDefinitionAccessor Class See Also
Retrieves severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic (Declaration)
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The severity of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class