Revit 2011 API
View..::.SunAndShadowSettings Property
View Class See Also
The sun and shadow settings assigned to the view for shadow calculation and rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public SunAndShadowSettings SunAndShadowSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property SunAndShadowSettings As SunAndShadowSettings
Visual C++
public:
property SunAndShadowSettings^ SunAndShadowSettings {
    SunAndShadowSettings^ get ();
}

Field Value

The sun and shadow settings, or null for views which don't allow this (such as schedules).

See Also

View Class