Revit 2011 API
ElementClassFilter Constructor (Type)
ElementClassFilter Class See Also
Constructs a new instance of a filter to match elements by class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementClassFilter(
    Type type
)
Visual Basic (Declaration)
Public Sub New ( _
    type As Type _
)
Visual C++
public:
ElementClassFilter(
    Type^ type
)

Parameters

type
Type: System..::.Type
The type to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementClassFilter Class
ElementClassFilter Overload