Revit 2011 API
Face..::.IsCyclic Property
Face Class See Also
The boolean value that indicates whether this face is periodic in the specified parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsCyclic[
    int paramIdx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCyclic ( _
    paramIdx As Integer _
) As Boolean
Visual C++
public:
property bool IsCyclic[int paramIdx] {
    bool get (int paramIdx);
}

Parameters

paramIdx
Type: System..::.Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

True if this face is cyclic; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.

See Also

Face Class