Revit 2011 API
Settings Members
Settings Class Methods Properties See Also

The Settings type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
FillPatterns | Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LinePatterns | Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.
Materials | Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.
TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings Class