Revit 2011 API
Element..::.Name Property
Element Class See Also
A human readable name for the Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The Name property is a human readable name for the element, such as Wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the name of the element cannot be changed.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the element requires a unique name and a non-unique name is set.

See Also

Element Class