Revit 2011 API
MassEnergyAnalyticalModel..::.GetMassSurfaceDataIdForReference Method
MassEnergyAnalyticalModel Class See Also
Get the ElementId of the MassSurfaceData corresponding to the Reference.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId GetMassSurfaceDataIdForReference(
    Reference reference
)
Visual Basic (Declaration)
Public Function GetMassSurfaceDataIdForReference ( _
    reference As Reference _
) As ElementId
Visual C++
public:
ElementId^ GetMassSurfaceDataIdForReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
A Reference to a face of this MassEnergyAnalyticalModel.

Return Value

ElementId of a MassSurfaceData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The Reference is not a Face of this MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace