Revit 2011 API
Connector..::.Direction Property
Connector Class See Also
The direction of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlowDirectionType Direction { get; }
Visual Basic (Declaration)
Public ReadOnly Property Direction As FlowDirectionType
Visual C++
public:
property FlowDirectionType Direction {
    FlowDirectionType get ();
}

Remarks

Instantaneous direction of this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get direction.

See Also

Connector Class