Revit 2011 API
TableView Methods
TableView Class See Also

The TableView type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetAvailableParameterCategories | Get all available parameter categories.
GetAvailableParameters | Get available parameters for the specified category.
GetCalculatedValueName | Returns the calculated value name for template view
GetCalculatedValueText | Returns the calculated value text for instance view
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsOkToEditParam |
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

TableView Class