Revit 2011 API
Form..::.AddProfile Method
Form Class See Also
Add a profile into the form, by a specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int AddProfile(
    Reference edgeReference,
    double param
)
Visual Basic (Declaration)
Public Function AddProfile ( _
    edgeReference As Reference, _
    param As Double _
) As Integer
Visual C++
public:
int AddProfile(
    Reference^ edgeReference,
    double param
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of edge.
param
Type: System..::.Double
The param on edge to specify the location.

Return Value

Index of newly created profile.

See Also

Form Class