Revit 2011 API
FailureDefinition Members
FailureDefinition Class Methods Properties See Also

The FailureDefinition type exposes the following members.

Methods

Name | Description
AddResolutionType | Adds a type of possible resolution for the failure.
CreateFailureDefinition | Creates an instance of a FailureDefinition.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
GetDefaultResolutionType | Retrieves the default resolution type for the failure.
GetDescriptionText | Retrieves the description text of the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResolutionCaption | Retrieves the caption for a specific resolution type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutions | Checks if the FailureDefinition has at least one resolution.
IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
SetDefaultResolutionType | Sets the default resolution type for the failure.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Severity | The severity of the failure.

See Also

FailureDefinition Class