Revit 2011 API
AnalyticalModel..::.RigidLinksOption Property
AnalyticalModel Class See Also
Indicates whether parameters indicate if Rigid Links should be formed.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalRigidLinksOption RigidLinksOption { get; set; }
Visual Basic (Declaration)
Public Property RigidLinksOption As AnalyticalRigidLinksOption
Visual C++
public:
property AnalyticalRigidLinksOption RigidLinksOption {
    AnalyticalRigidLinksOption get ();
    void set (AnalyticalRigidLinksOption value);
}

Field Value

For Structural Beams:
  • Enabled: rigid links will be formed, overriding Structural Column setting.
  • Disabled: rigid links will not be formed, overriding Structural Column setting.
  • FromColumn: rigid links may be formed, depending on Structural Column setting.
For Structural Columns:
  • Enabled: rigid links will be formed, unless Structural Beam setting overrides.
  • Disabled: rigid links will not be formed, unless Structural Beam setting overrides.
If rigid links are not applicable to this Analytical Model, this will return Disabled.

Remarks

Rigid Links are the result of an interaction between neighboring Structural Columns and Structural Beams

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: rigidLinksOption is not valid for this Analytical Model.
Autodesk.Revit.Exceptions..::.InvalidOperationException | When setting this property: This AnalyticalModel does not support Rigid Links.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace