Revit 2011 API
FailureMessage Members
FailureMessage Class Constructors Methods See Also

The FailureMessage type exposes the following members.

Constructors

Name | Description
FailureMessage | Creates a new FailureMessage related to a given FailureDefinition.

Methods

Name | Description
AddResolution | Adds a resolution for the failure.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
GetDescriptionText | Retrieves the description text of the failure.
GetFailingElements | Retrieves list of the elements that have caused the failure.
GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSeverity | Retrieves the severity of the failure.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutionOfType | Checks if failure has a resolution of a given type.
HasResolutions | Checks if the failure has any resolutions.
SetAdditionalElement | Sets the additional reference element for the failure.
SetAdditionalElements | Sets the additional reference elements for the failure.
SetFailingElement | Sets the element that has caused the failure.
SetFailingElements | Sets elements that have caused the failure.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessage Class