Revit 2011 API
Curve..::.Distance Method
Curve Class See Also
Returns the shortest distance from the specified point to this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Distance(
    XYZ point
)
Visual Basic (Declaration)
Public Function Distance ( _
    point As XYZ _
) As Double
Visual C++
public:
double Distance(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The specified point.

Return Value

The real number equal to the shortest distance.

Remarks

Returns the distance from the closest point on the curve to the specified point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class