Revit 2011 API
SplitButton Members
SplitButton Class Methods Properties See Also

The SplitButton type exposes the following members.

Methods

Name | Description
AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand. (Inherited from PulldownButton.)
AddSeparator | Adds a separator to the drop-down list. (Inherited from PulldownButton.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets a copy of the collection of buttons assigned to the pulldown button. (Inherited from PulldownButton.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentButton | Gets or sets the current PushButton of the SplitButton.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
IsSynchronizedWithCurrentItem | Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

SplitButton Class
Autodesk.Revit.UI Namespace