Revit 2011 API
UpdaterData Members
UpdaterData Class Methods See Also

The UpdaterData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddedElementIds | Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().
GetDeletedElementIds | Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
GetDocument | Returns document associated with this UpdaterData
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetModifiedElementIds | Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsChangeTriggered | Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdaterData Class