Revit 2011 API
Transaction Members
Transaction Class Constructors Methods See Also

The Transaction type exposes the following members.

Constructors

Name | Description
Transaction | Overloaded.

Methods

Name | Description
Commit | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFailureHandlingOptions | Returns the current failure handling options
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetName | Returns the transaction's name
GetStatus | Returns the current status of the transaction
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasEnded | Determines whether the transaction has ended already
HasStarted | Determines whether the transaction has been started yet
RollBack | Overloaded.
SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back
SetName | Sets the transaction's name
Start | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Transaction Class