Revit 2011 API
DWGExportOptions Members
DWGExportOptions Class Constructors Methods Properties See Also

The DWGExportOptions type exposes the following members.

Constructors

Name | Description
DWGExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Colors | Export color mode. (Inherited from ACADExportOptions.)
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from ACADExportOptions.)
ExportOfSolids | Mode of exporting solids in 3D views. (Inherited from ACADExportOptions.)
FileVersion | AutoCAD file version. (Inherited from ACADExportOptions.)
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from ACADExportOptions.)
LayerMapping | Name of a layer settings standard or filename (with custom layer settings). (Inherited from ACADExportOptions.)
LineScaling | LineType scaling mode. (Inherited from ACADExportOptions.)
MergedViews | Whether to merge all views in one file (via XRefs).
PropOverrides | How to export overridden object styles. (Inherited from ACADExportOptions.)
SharedCoords | Whether to use shared coordinate system or a project's. internal origin. (Inherited from ACADExportOptions.)
TargetUnit | Type of units in the target CAD format. (Inherited from ACADExportOptions.)

See Also

DWGExportOptions Class