Revit 2011 API
MassLevelData..::.IsMassFamilyInstance Method
MassLevelData Class See Also
Checks if the ElementId is a mass family instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool IsMassFamilyInstance(
    Document document,
    ElementId id
)
Visual Basic (Declaration)
Public Shared Function IsMassFamilyInstance ( _
    document As Document, _
    id As ElementId _
) As Boolean
Visual C++
public:
static bool IsMassFamilyInstance(
    Document^ document,
    ElementId^ id
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
id
Type: Autodesk.Revit.DB..::.ElementId
The ElementId to be checked.

Return Value

True if the ElementId is a mass family instance, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace