Revit 2011 API
RoofTypeSet..::.Erase Method
RoofTypeSet Class See Also
Removes a specified roof type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RoofType _
) As Integer
Visual C++
public:
virtual int Erase(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.RoofType
The roof type to be erased.

Return Value

The number of roof types that were erased from the set.

See Also

RoofTypeSet Class