Revit 2011 API
ArgumentOutOfRangeException Class
Members See Also
The exception that is thrown when the value of an argument is outside the allowable range of values as defined by the invoked method.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ArgumentOutOfRangeException : ArgumentException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ArgumentOutOfRangeException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class ArgumentOutOfRangeException : public ArgumentException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.ArgumentException
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException

See Also

ArgumentOutOfRangeException Members
Autodesk.Revit.Exceptions Namespace