Revit 2011 API
SunAndShadowSettings..::.GetMatchingPreset Method
SunAndShadowSettings Class See Also
Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetMatchingPreset()
Visual Basic (Declaration)
Public Function GetMatchingPreset As String
Visual C++
public:
String^ GetMatchingPreset()

Return Value

Name of the per-document SunAndShadowSettings that matches the view specific element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The SunAndShadowSettings is not view-specific.

See Also

SunAndShadowSettings Class