Revit 2011 API
Outline..::.Contains Method
Outline Class See Also
Determine if this Outline contains the specified point to within a tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Contains(
    XYZ point,
    double tolerance
)
Visual Basic (Declaration)
Public Function Contains ( _
    point As XYZ, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool Contains(
    XYZ^ point,
    double tolerance
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point to test for containment.
tolerance
Type: System..::.Double
The tolerance to use when determining whether the point is contained. Defaults to zero.

Return Value

True if this outline contains the given point, or false otherwise.

Remarks

If the tolerance is positive, the point may lie up to the tolerance amount outside the outline in each coordinate. If the tolerance is negative, the point must lie at least the tolerance amount inside the outline in each coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class