Revit 2011 API
FailuresAccessor..::.IsFailureResolutionPermitted Method (FailureMessageAccessor)
FailuresAccessor Class See Also
Checks if default resolution of the failure is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted(
    FailureMessageAccessor failure
)
Visual Basic (Declaration)
Public Function IsFailureResolutionPermitted ( _
    failure As FailureMessageAccessor _
) As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessageAccessor
The accessor to the failure to be resolved.

Return Value

True if default resolution of the failure is permitted

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload