Revit 2011 API
AnalysisDisplayStyle..::.SetName Method
AnalysisDisplayStyle Class See Also
Set name of analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetName(
    string name
)
Visual Basic (Declaration)
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::.String
Analysis display style element name to be set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | name is not unique in document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace