Revit 2011 API
Truss..::.AttachChord Method
Truss Class See Also
Attach a truss's specific chord to a specified element, the element should be a roof or floor.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AttachChord(
    Element attachToElement,
    TrussChordLocation location,
    bool forceRemoveSketch
)
Visual Basic (Declaration)
Public Sub AttachChord ( _
    attachToElement As Element, _
    location As TrussChordLocation, _
    forceRemoveSketch As Boolean _
)
Visual C++
public:
void AttachChord(
    Element^ attachToElement,
    TrussChordLocation location,
    bool forceRemoveSketch
)

Parameters

attachToElement
Type: Autodesk.Revit.DB..::.Element
The element to which the truss's chord will attach. The element should be a roof or floor.
location
Type: Autodesk.Revit.DB.Structure..::.TrussChordLocation
The chord need to be attached.
forceRemoveSketch
Type: System..::.Boolean
Whether to detach the original sketch if there is one.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace