Revit 2011 API
FilterDoubleRule Members
FilterDoubleRule Class Constructors Methods Properties See Also

The FilterDoubleRule type exposes the following members.

Constructors

Name | Description
FilterDoubleRule | Constructs an instance of FilterDoubleRule.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Epsilon | The tolerance within which two floating-point values may be considered equal.
RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterDoubleRule Class