Revit 2011 API
MassSurfaceData Properties
MassSurfaceData Class See Also

The MassSurfaceData type exposes the following members.

Properties

Name | Description
Area | Area of the references that the MassSurfaceData provides properties for.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CategoryIdForConceptualSurfaceType | Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.
ConceptualConstructionId | The id of the conceptual construction associated with the reference surface.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsConceptualConstructionByEnergyData | True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.
IsGlazingShaded | Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.
IsSlab | Indicates if a floor is a slab.
IsUnderground | Indicates if the roof, floor, slab, or wall surface reference is underground.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MassLevelDataId | The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.
MaterialId | The visualization material used for the surface for displaying the energy analytical model.
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | material type of mass zone
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PercentageGlazing | The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.
PercentageSkylights | The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceElementId | The ElementId of the element whose face the MassSurfaceData primarily refers to.
ShadeDepth | How far any auto-generated shades should extend from the wall surface.
SillHeight | The height above the level where the bottoms of auto-generated windows will be located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SkylightWidth | The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.
SurfaceDataSource | Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace