Revit 2011 API
Dimension..::.AreSegmentsEqual Property
Dimension Class See Also
Indicates if all segments are forced to be equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AreSegmentsEqual { get; set; }
Visual Basic (Declaration)
Public Property AreSegmentsEqual As Boolean
Visual C++
public:
property bool AreSegmentsEqual {
    bool get ();
    void set (bool value);
}

Remarks

This property is usable only for linear dimensions with more than one segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the dimension is non-linear or has only one segment.

See Also

Dimension Class