Revit 2011 API
ElementRecord..::.GetDesignOptionId Method
ElementRecord Class See Also
Gets the design option id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetDesignOptionId()
Visual Basic (Declaration)
Public Function GetDesignOptionId As ElementId
Visual C++
public:
ElementId^ GetDesignOptionId()

Return Value

The design option id.

See Also

ElementRecord Class