Revit 2011 API
ViewDrafting Properties
ViewDrafting Class See Also

The ViewDrafting type exposes the following members.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewDrafting Class