Revit 2011 API
MaterialGeneric..::.YoungModulusY Property
MaterialGeneric Class See Also
Get or set the y component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusY { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusY As Double
Visual C++
public:
property double YoungModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class