Revit 2011 API
FamilyInstanceCreationData Constructor (Face, XYZ, XYZ, FamilySymbol)
FamilyInstanceCreationData Class See Also
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Sub New ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
)
Visual C++
public:
FamilyInstanceCreationData(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
A face of a geometry object.
location
Type: Autodesk.Revit.DB..::.XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::.XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace