Revit 2011 API
Categories Members
Categories Class Methods Properties See Also

The Categories type exposes the following members.

Methods

Name | Description
Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMap..::.Contains(String).)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.ForwardIterator()()().)
GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMap..::.Insert(String, Category).)
NewSubcategory | Add a new subcategory into the Autodesk Revit document.
ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMap..::.ReverseIterator()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMap..::.IsEmpty.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Retrieves a category object matching an identifier.
Size | The total number of top-level categories in the document. (Overrides CategoryNameMap..::.Size.)

See Also

Categories Class