Revit 2011 API
PointOnEdgeEdgeIntersection Class
Members See Also
Define a ReferencePoint at the intersection of two referenceable lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointOnEdgeEdgeIntersection : PointElementReference
Visual Basic (Declaration)
Public Class PointOnEdgeEdgeIntersection _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdgeEdgeIntersection : public PointElementReference

Remarks

The ReferencePoint is actually placed on the first line (Edge1) at the closest point to the second line (Edge2). Its X basis vector is constrained to be parallel to the first line.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.PointElementReference
Autodesk.Revit.DB..::.PointOnEdgeEdgeIntersection

See Also

PointOnEdgeEdgeIntersection Members