Revit 2011 API
BoxPlacement Enumeration
See Also
An enumerated type listing possible placement of a box (an object of rectangular shape.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BoxPlacement
Visual Basic (Declaration)
Public Enumeration BoxPlacement
Visual C++
public enum class BoxPlacement

Members

Member name | Description
Center | Placement of a box by its center point.
TopLeft | Placement of a box by its top left corner.
TopRight | Placement of a box by its top right corner.
BottomRight | Placement of a box by its bottom right corner.
BottomLeft | Placement of a box by its bottom left corner.

See Also