Revit 2011 API
AnalysisDisplayLegendSettings Class
Members Example See Also
Contains legend settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayLegendSettings : IDisposable
Visual Basic (Declaration)
Public Class AnalysisDisplayLegendSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayLegendSettings : IDisposable

Examples

CopyC#
AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
legendSettings.NumberOfSteps = 10;
legendSettings.Rounding = 0.05;
legendSettings.ShowDataDescription = false;
legendSettings.ShowLegend = true;

FilteredElementCollector collector2 = new FilteredElementCollector(doc);
ICollection<Element> elementCollection = collector2.OfClass(typeof(TextNoteType)).ToElements();
var textElements = from element in collector2 where element.Name == "LegendText" select element;
if (textElements.Count() > 0) // if LegendText exists, use it for this Display Style
{
    TextNoteType textType = textElements.Cast<TextNoteType>().ElementAt<TextNoteType>(0);
    legendSettings.SetTextTypeId(textType.Id, doc);
}
CopyVB.NET
Dim legendSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayLegendSettings()
legendSettings.NumberOfSteps = 10
legendSettings.Rounding = 0.05
legendSettings.ShowDataDescription = False
legendSettings.ShowLegend = True

Dim collector2 As New Autodesk.Revit.DB.FilteredElementCollector(doc)
Dim elementCollection As ICollection(Of Autodesk.Revit.DB.Element) = collector2.OfClass(GetType(TextNoteType)).ToElements()
Dim textElements As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
textElements = From element In collector2 _
 Where element.Name = "LegendText" _
 Select element
If textElements.Count() > 0 Then
    ' if LegendText exists, use it for this Display Style
    Dim textType As TextNoteType = textElements.Cast(Of TextNoteType)().ElementAt(0)
    legendSettings.SetTextTypeId(textType.Id, doc)
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegendSettings

See Also

AnalysisDisplayLegendSettings Members
Autodesk.Revit.DB.Analysis Namespace