Revit 2011 API
FailureMessageAccessor..::.GetFailureDefinitionId Method
FailureMessageAccessor Class See Also
Retrieves the Id of the FailureDefinition of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionId GetFailureDefinitionId()
Visual Basic (Declaration)
Public Function GetFailureDefinitionId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetFailureDefinitionId()

Return Value

The Id of the FailureDefinition of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class