Revit 2011 API
FailureMessageKey Methods
FailureMessageKey Class See Also

The FailureMessageKey type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Checks it this key is equal to the other.
IsValid | Checks if the failure message key is valid
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two FailureMessageKeys are the same.
Inequality | Determines whether two FailureMessageKeys are different.

See Also

FailureMessageKey Class