Revit 2011 API
FailuresAccessor..::.GetAttemptedResolutionTypes Method
FailuresAccessor Class See Also
Returns list of the failure resolution types attempted for the failure in the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetAttemptedResolutionTypes(
    FailureMessageAccessor failure
)
Visual Basic (Declaration)
Public Function GetAttemptedResolutionTypes ( _
    failure As FailureMessageAccessor _
) As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetAttemptedResolutionTypes(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessageAccessor
The failure.

Return Value

The list of the types of failure resolutions attempted for the failure.

Remarks

In some cases attempt to resolve a failure has no impact or failure gets reposted during next round of the end of transaction checks after being resolved. Knowing if any failure resolutions were attempted for the failure allows failures processor to prevent infinite loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class