Revit 2011 API
FamilyManager..::.AddParameter Method
FamilyManager Class See Also
Add a new parameter to the family.

Overload List

Name | Description
AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Add a new shared parameter to the family.
AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
AddParameter(String, BuiltInParameterGroup, ParameterType, Boolean) | Add a new family parameter with a given name.

See Also

FamilyManager Class
FamilyManager Members