Revit 2011 API
ISelectionFilter..::.AllowReference Method
ISelectionFilter Interface See Also
Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
bool AllowReference(
    Reference reference,
    XYZ position
)
Visual Basic (Declaration)
Function AllowReference ( _
    reference As Reference, _
    position As XYZ _
) As Boolean
Visual C++
bool AllowReference(
    Reference^ reference,
    XYZ^ position
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
A candidate reference in selection operation.
position
Type: Autodesk.Revit.DB..::.XYZ
The 3D position of the mouse on the candidate reference.

Return Value

Return true to allow the user to select this candidate reference. Return false to prevent selection of this candidate.

Remarks

If an exception is thrown from this method, the element will not be permitted to be selected.

See Also

ISelectionFilter Interface
Autodesk.Revit.UI.Selection Namespace