Revit 2011 API
StringStringMap Members
StringStringMap Class Constructors Methods Properties See Also

The StringStringMap type exposes the following members.

Constructors

Name | Description
StringStringMap | Initializes a new instance of the StringStringMap class

Methods

Name | Description
Clear | Removes every string from the map, rendering it empty.
Contains | Tests for the existence of a string key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes an item with the specified string key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a string item at a specified string key within the map.
Size | Returns the number of strings that are in the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace