Revit 2011 API
APIObject Class
Members See Also
Supports all objects in the Autodesk Revit API hierarchy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class APIObject : IDisposable
Visual Basic (Declaration)
Public Class APIObject _
    Implements IDisposable
Visual C++
public ref class APIObject : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Collections..::.Array
Autodesk.Revit.Collections..::.ArrayIterator
Autodesk.Revit.Collections..::.Map
Autodesk.Revit.Collections..::.MapIterator
Autodesk.Revit.Collections..::.Set
Autodesk.Revit.Collections..::.SetIterator
Autodesk.Revit.Collections..::.StringStringMap
Autodesk.Revit.Collections..::.StringStringMapIterator
Autodesk.Revit.Creation..::.Application
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.DB..::.AnnotationSymbolTypeSet
Autodesk.Revit.DB..::.AnnotationSymbolTypeSetIterator
Autodesk.Revit.DB.Architecture..::.BoundarySegment
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArray
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArrayArray
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArrayIterator
Autodesk.Revit.DB.Architecture..::.FasciaTypeSet
Autodesk.Revit.DB.Architecture..::.FasciaTypeSetIterator
Autodesk.Revit.DB.Architecture..::.GutterTypeSet
Autodesk.Revit.DB.Architecture..::.GutterTypeSetIterator
Autodesk.Revit.DB.Architecture..::.RoomTagTypeSet
Autodesk.Revit.DB.Architecture..::.RoomTagTypeSetIterator
Autodesk.Revit.DB..::.AreaTagTypeSet
Autodesk.Revit.DB..::.AreaTagTypeSetIterator
Autodesk.Revit.DB..::.BeamSystemTypeSet
Autodesk.Revit.DB..::.BeamSystemTypeSetIterator
Autodesk.Revit.DB..::.Binding
Autodesk.Revit.DB..::.BoundarySegment
Autodesk.Revit.DB..::.BoundarySegmentArray
Autodesk.Revit.DB..::.BoundarySegmentArrayArray
Autodesk.Revit.DB..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.DB..::.BoundarySegmentArrayIterator
Autodesk.Revit.DB..::.BoundingBoxXYZ
Autodesk.Revit.DB..::.Category
Autodesk.Revit.DB..::.CategoryNameMap
Autodesk.Revit.DB..::.CategoryNameMapIterator
Autodesk.Revit.DB..::.CategorySet
Autodesk.Revit.DB..::.CategorySetIterator
Autodesk.Revit.DB..::.City
Autodesk.Revit.DB..::.CitySet
Autodesk.Revit.DB..::.CitySetIterator
Autodesk.Revit.DB..::.Color
Autodesk.Revit.DB..::.CombinableElementArray
Autodesk.Revit.DB..::.CombinableElementArrayIterator
Autodesk.Revit.DB..::.CompoundStructure
Autodesk.Revit.DB..::.CompoundStructureLayer
Autodesk.Revit.DB..::.CompoundStructureLayerArray
Autodesk.Revit.DB..::.CompoundStructureLayerArrayIterator
Autodesk.Revit.DB..::.Connector
Autodesk.Revit.DB..::.ConnectorManager
Autodesk.Revit.DB..::.ConnectorSet
Autodesk.Revit.DB..::.ConnectorSetIterator
Autodesk.Revit.DB..::.ContFootingTypeSet
Autodesk.Revit.DB..::.ContFootingTypeSetIterator
Autodesk.Revit.DB..::.CurtainCell
Autodesk.Revit.DB..::.CurtainCellSet
Autodesk.Revit.DB..::.CurtainCellSetIterator
Autodesk.Revit.DB..::.CurtainGrid
Autodesk.Revit.DB..::.CurtainGridSet
Autodesk.Revit.DB..::.CurtainGridSetIterator
Autodesk.Revit.DB..::.CurtainSystemTypeSet
Autodesk.Revit.DB..::.CurtainSystemTypeSetIterator
Autodesk.Revit.DB..::.CurveArrArray
Autodesk.Revit.DB..::.CurveArrArrayIterator
Autodesk.Revit.DB..::.CurveArray
Autodesk.Revit.DB..::.CurveArrayIterator
Autodesk.Revit.DB..::.CurveByPointsArray
Autodesk.Revit.DB..::.CurveByPointsArrayIterator
Autodesk.Revit.DB..::.Definition
Autodesk.Revit.DB..::.DefinitionBindingMap
Autodesk.Revit.DB..::.DefinitionBindingMapIterator
Autodesk.Revit.DB..::.DefinitionFile
Autodesk.Revit.DB..::.DefinitionGroup
Autodesk.Revit.DB..::.DefinitionGroupsBase
Autodesk.Revit.DB..::.DefinitionGroupsBaseIterator
Autodesk.Revit.DB..::.DefinitionsBase
Autodesk.Revit.DB..::.DefinitionsBaseIterator
Autodesk.Revit.DB..::.DetailCurveArray
Autodesk.Revit.DB..::.DetailCurveArrayIterator
Autodesk.Revit.DB..::.DimensionSegment
Autodesk.Revit.DB..::.DimensionSegmentArray
Autodesk.Revit.DB..::.DimensionSegmentArrayIterator
Autodesk.Revit.DB..::.DimensionTypeSet
Autodesk.Revit.DB..::.DimensionTypeSetIterator
Autodesk.Revit.DB..::.DividedSurfaceData
Autodesk.Revit.DB..::.DocumentSet
Autodesk.Revit.DB..::.DocumentSetIterator
Autodesk.Revit.DB..::.DoubleArray
Autodesk.Revit.DB..::.DoubleArrayIterator
Autodesk.Revit.DB..::.EdgeArray
Autodesk.Revit.DB..::.EdgeArrayArray
Autodesk.Revit.DB..::.EdgeArrayArrayIterator
Autodesk.Revit.DB..::.EdgeArrayIterator
Autodesk.Revit.DB.Electrical..::.CorrectionFactor
Autodesk.Revit.DB.Electrical..::.CorrectionFactorSet
Autodesk.Revit.DB.Electrical..::.CorrectionFactorSetIterator
Autodesk.Revit.DB.Electrical..::.DistributionSysTypeSet
Autodesk.Revit.DB.Electrical..::.DistributionSysTypeSetIterator
Autodesk.Revit.DB.Electrical..::.ElectricalSetting
Autodesk.Revit.DB.Electrical..::.ElectricalSystemSet
Autodesk.Revit.DB.Electrical..::.ElectricalSystemSetIterator
Autodesk.Revit.DB.Electrical..::.GroundConductorSize
Autodesk.Revit.DB.Electrical..::.GroundConductorSizeSet
Autodesk.Revit.DB.Electrical..::.GroundConductorSizeSetIterator
Autodesk.Revit.DB.Electrical..::.InsulationTypeSet
Autodesk.Revit.DB.Electrical..::.InsulationTypeSetIterator
Autodesk.Revit.DB.Electrical..::.TemperatureRatingTypeSet
Autodesk.Revit.DB.Electrical..::.TemperatureRatingTypeSetIterator
Autodesk.Revit.DB.Electrical..::.VoltageTypeSet
Autodesk.Revit.DB.Electrical..::.VoltageTypeSetIterator
Autodesk.Revit.DB.Electrical..::.WireConduitType
Autodesk.Revit.DB.Electrical..::.WireConduitTypeSet
Autodesk.Revit.DB.Electrical..::.WireConduitTypeSetIterator
Autodesk.Revit.DB.Electrical..::.WireMaterialTypeSet
Autodesk.Revit.DB.Electrical..::.WireMaterialTypeSetIterator
Autodesk.Revit.DB.Electrical..::.WireSet
Autodesk.Revit.DB.Electrical..::.WireSetIterator
Autodesk.Revit.DB.Electrical..::.WireSize
Autodesk.Revit.DB.Electrical..::.WireSizeSet
Autodesk.Revit.DB.Electrical..::.WireSizeSetIterator
Autodesk.Revit.DB.Electrical..::.WireTypeSet
Autodesk.Revit.DB.Electrical..::.WireTypeSetIterator
Autodesk.Revit.DB..::.ElementArray
Autodesk.Revit.DB..::.ElementArrayIterator
Autodesk.Revit.DB..::.ElementSet
Autodesk.Revit.DB..::.ElementSetIterator
Autodesk.Revit.DB..::.FaceArray
Autodesk.Revit.DB..::.FaceArrayIterator
Autodesk.Revit.DB..::.FamilyElementVisibility
Autodesk.Revit.DB..::.FamilyManager
Autodesk.Revit.DB..::.FamilyParameter
Autodesk.Revit.DB..::.FamilyParameterSet
Autodesk.Revit.DB..::.FamilyParameterSetIterator
Autodesk.Revit.DB..::.FamilyPointLocation
Autodesk.Revit.DB..::.FamilyPointPlacementReference
Autodesk.Revit.DB..::.FamilySymbolSet
Autodesk.Revit.DB..::.FamilySymbolSetIterator
Autodesk.Revit.DB..::.FamilyType
Autodesk.Revit.DB..::.FamilyTypeSet
Autodesk.Revit.DB..::.FamilyTypeSetIterator
Autodesk.Revit.DB..::.FillPatternSet
Autodesk.Revit.DB..::.FillPatternSetIterator
Autodesk.Revit.DB..::.FloorTypeSet
Autodesk.Revit.DB..::.FloorTypeSetIterator
Autodesk.Revit.DB..::.FormArray
Autodesk.Revit.DB..::.FormArrayIterator
Autodesk.Revit.DB..::.FormatOptions
Autodesk.Revit.DB..::.GenericFormSet
Autodesk.Revit.DB..::.GenericFormSetIterator
Autodesk.Revit.DB..::.GeomCombinationSet
Autodesk.Revit.DB..::.GeomCombinationSetIterator
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.GeometryObjectArray
Autodesk.Revit.DB..::.GeometryObjectArrayIterator
Autodesk.Revit.DB..::.GridTypeSet
Autodesk.Revit.DB..::.GridTypeSetIterator
Autodesk.Revit.DB..::.GroupSet
Autodesk.Revit.DB..::.GroupSetIterator
Autodesk.Revit.DB..::.InstanceArray
Autodesk.Revit.DB..::.InstanceArrayIterator
Autodesk.Revit.DB..::.IntersectionResult
Autodesk.Revit.DB..::.IntersectionResultArray
Autodesk.Revit.DB..::.IntersectionResultArrayIterator
Autodesk.Revit.DB..::.LayoutRule
Autodesk.Revit.DB..::.Leader
Autodesk.Revit.DB..::.LeaderArray
Autodesk.Revit.DB..::.LeaderArrayIterator
Autodesk.Revit.DB..::.LevelTypeSet
Autodesk.Revit.DB..::.LevelTypeSetIterator
Autodesk.Revit.DB..::.LinePatternSet
Autodesk.Revit.DB..::.LinePatternSetIterator
Autodesk.Revit.DB..::.Location
Autodesk.Revit.DB..::.MaterialSet
Autodesk.Revit.DB..::.MaterialSetIterator
Autodesk.Revit.DB.Mechanical..::.BoundarySegment
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArray
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArrayArray
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArrayIterator
Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstructionSet
Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstructionSetIterator
Autodesk.Revit.DB.Mechanical..::.SpaceSet
Autodesk.Revit.DB.Mechanical..::.SpaceSetIterator
Autodesk.Revit.DB.Mechanical..::.SpaceTagTypeSet
Autodesk.Revit.DB.Mechanical..::.SpaceTagTypeSetIterator
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB..::.MeshArray
Autodesk.Revit.DB..::.MeshArrayIterator
Autodesk.Revit.DB..::.MeshTriangle
Autodesk.Revit.DB..::.ModelCurveArrArray
Autodesk.Revit.DB..::.ModelCurveArrArrayIterator
Autodesk.Revit.DB..::.ModelCurveArray
Autodesk.Revit.DB..::.ModelCurveArrayIterator
Autodesk.Revit.DB..::.MullionTypeSet
Autodesk.Revit.DB..::.MullionTypeSetIterator
Autodesk.Revit.DB..::.Options
Autodesk.Revit.DB..::.PanelTypeSet
Autodesk.Revit.DB..::.PanelTypeSetIterator
Autodesk.Revit.DB..::.PaperSize
Autodesk.Revit.DB..::.PaperSizeSet
Autodesk.Revit.DB..::.PaperSizeSetIterator
Autodesk.Revit.DB..::.PaperSource
Autodesk.Revit.DB..::.PaperSourceSet
Autodesk.Revit.DB..::.PaperSourceSetIterator
Autodesk.Revit.DB..::.Parameter
Autodesk.Revit.DB..::.ParameterMap
Autodesk.Revit.DB..::.ParameterMapIterator
Autodesk.Revit.DB..::.ParameterSet
Autodesk.Revit.DB..::.ParameterSetIterator
Autodesk.Revit.DB..::.PhaseArray
Autodesk.Revit.DB..::.PhaseArrayIterator
Autodesk.Revit.DB..::.PlanCircuit
Autodesk.Revit.DB..::.PlanCircuitSet
Autodesk.Revit.DB..::.PlanCircuitSetIterator
Autodesk.Revit.DB..::.Plane
Autodesk.Revit.DB..::.PlanTopology
Autodesk.Revit.DB..::.PlanTopologySet
Autodesk.Revit.DB..::.PlanTopologySetIterator
Autodesk.Revit.DB..::.PrintManager
Autodesk.Revit.DB..::.PrintParameters
Autodesk.Revit.DB..::.PrintSetup
Autodesk.Revit.DB..::.ProjectLocationSet
Autodesk.Revit.DB..::.ProjectLocationSetIterator
Autodesk.Revit.DB..::.ProjectPosition
Autodesk.Revit.DB..::.Reference
Autodesk.Revit.DB..::.ReferenceArray
Autodesk.Revit.DB..::.ReferenceArrayArray
Autodesk.Revit.DB..::.ReferenceArrayArrayIterator
Autodesk.Revit.DB..::.ReferenceArrayIterator
Autodesk.Revit.DB..::.ReferencePointArray
Autodesk.Revit.DB..::.ReferencePointArrayIterator
Autodesk.Revit.DB..::.RoofTypeSet
Autodesk.Revit.DB..::.RoofTypeSetIterator
Autodesk.Revit.DB..::.Settings
Autodesk.Revit.DB..::.SlabEdgeTypeSet
Autodesk.Revit.DB..::.SlabEdgeTypeSetIterator
Autodesk.Revit.DB..::.SlabShapeCreaseArray
Autodesk.Revit.DB..::.SlabShapeCreaseArrayIterator
Autodesk.Revit.DB..::.SlabShapeVertexArray
Autodesk.Revit.DB..::.SlabShapeVertexArrayIterator
Autodesk.Revit.DB..::.SolidArray
Autodesk.Revit.DB..::.SolidArrayIterator
Autodesk.Revit.DB..::.SpacingRule
Autodesk.Revit.DB..::.SpotDimensionTypeSet
Autodesk.Revit.DB..::.SpotDimensionTypeSetIterator
Autodesk.Revit.DB.Structure..::.AreaLoadTypeSet
Autodesk.Revit.DB.Structure..::.AreaLoadTypeSetIterator
Autodesk.Revit.DB.Structure..::.BarDescription
Autodesk.Revit.DB.Structure..::.LineLoadTypeSet
Autodesk.Revit.DB.Structure..::.LineLoadTypeSetIterator
Autodesk.Revit.DB.Structure..::.LoadCaseArray
Autodesk.Revit.DB.Structure..::.LoadCaseArrayIterator
Autodesk.Revit.DB.Structure..::.LoadCaseSet
Autodesk.Revit.DB.Structure..::.LoadCaseSetIterator
Autodesk.Revit.DB.Structure..::.LoadCombinationArray
Autodesk.Revit.DB.Structure..::.LoadCombinationArrayIterator
Autodesk.Revit.DB.Structure..::.LoadTypeBaseSet
Autodesk.Revit.DB.Structure..::.LoadTypeBaseSetIterator
Autodesk.Revit.DB.Structure..::.LoadUsageArray
Autodesk.Revit.DB.Structure..::.LoadUsageArrayIterator
Autodesk.Revit.DB.Structure..::.PointLoadTypeSet
Autodesk.Revit.DB.Structure..::.PointLoadTypeSetIterator
Autodesk.Revit.DB.Structure..::.RebarBarTypeSet
Autodesk.Revit.DB.Structure..::.RebarBarTypeSetIterator
Autodesk.Revit.DB.Structure..::.RebarCoverTypeSet
Autodesk.Revit.DB.Structure..::.RebarCoverTypeSetIterator
Autodesk.Revit.DB.Structure..::.RebarHookTypeSet
Autodesk.Revit.DB.Structure..::.RebarHookTypeSetIterator
Autodesk.Revit.DB.Structure..::.RebarHostData
Autodesk.Revit.DB.Structure..::.RebarShapeDefinition
Autodesk.Revit.DB.Structure..::.RebarShapeSet
Autodesk.Revit.DB.Structure..::.RebarShapeSetIterator
Autodesk.Revit.DB.Structure..::.TrussTypeSet
Autodesk.Revit.DB.Structure..::.TrussTypeSetIterator
Autodesk.Revit.DB..::.SuspendUpdating
Autodesk.Revit.DB..::.SweepProfile
Autodesk.Revit.DB..::.SymbolicCurveArray
Autodesk.Revit.DB..::.SymbolicCurveArrayIterator
Autodesk.Revit.DB..::.TextNoteTypeSet
Autodesk.Revit.DB..::.TextNoteTypeSetIterator
Autodesk.Revit.DB..::.TilePatterns
Autodesk.Revit.DB..::.Transform
Autodesk.Revit.DB..::.VertexIndexPairArray
Autodesk.Revit.DB..::.VertexIndexPairArrayIterator
Autodesk.Revit.DB..::.ViewSet
Autodesk.Revit.DB..::.ViewSetIterator
Autodesk.Revit.DB..::.ViewSheetSets
Autodesk.Revit.DB..::.ViewSheetSetsIterator
Autodesk.Revit.DB..::.ViewSheetSetting
Autodesk.Revit.DB..::.WallTypeSet
Autodesk.Revit.DB..::.WallTypeSetIterator
Autodesk.Revit.UI.Events..::.DialogBoxData
Autodesk.Revit.UI..::.ExternalApplicationArray
Autodesk.Revit.UI..::.ExternalApplicationArrayIterator
Autodesk.Revit.UI..::.ExternalCommandData
Autodesk.Revit.UI.Selection..::.Selection
Autodesk.Revit.UI..::.TaskDialog
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetSet
Autodesk.Revit.Utility..::.AssetSetIterator

See Also

APIObject Members