Revit 2011 API
RibbonItem Members
RibbonItem Class Methods Properties See Also

The RibbonItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled.
ItemText | Gets or sets the text displayed on the item.
ItemType | Gets the item type.
LongDescription | Long description of the command tooltip
Name | The name of the item.
ToolTip | The description that appears as a ToolTip for the item.
ToolTipImage | The image to show as a part of the button extended tooltip
Visible | Gets or sets a value indicating whether the item is visible.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace