Revit 2011 API
AnalyticalModelSupport..::.GetCurve Method
AnalyticalModelSupport Class See Also
Retrieves the curve providing support.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Curve GetCurve()
Visual Basic (Declaration)
Public Function GetCurve As Curve
Visual C++
public:
Curve^ GetCurve()

Return Value

Represents the curve providing support, if the Support Type is Curve Support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | Thrown when the Support Type is not Curve Support.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace