Revit 2011 API
ParameterFilterUtilities..::.RemoveUnfilterableCategories Method
ParameterFilterUtilities Class See Also
Removes from the given set the categories that are not filterable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> RemoveUnfilterableCategories(
    ICollection<ElementId> categories
)
Visual Basic (Declaration)
Public Shared Function RemoveUnfilterableCategories ( _
    categories As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ RemoveUnfilterableCategories(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The set of categories to check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterUtilities Class