Revit 2011 API
ConceptualConstructionType Members
ConceptualConstructionType Class Methods Properties See Also

The ConceptualConstructionType type exposes the following members.

Methods

Name | Description
CanBeHidden
Indicates if the element can be hidden in the view.
(Inherited from Element.)
CanHaveAnalyticalModel
Indicates whether the Element can have an Analytical Model.
(Inherited from Element.)
CanHaveTypeAssigned
Identifies if the element can have a type assigned.
(Inherited from Element.)
ChangeTypeId
Changes type of the element.
(Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate
Duplicate this object.
(Inherited from ElementType.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetAllConceptualConstructionsForCategory
Get all the ids of constructions applicable to the input massSubCategory
GetAnalyticalModel
Retrieves writeable Analytical Model for Element.
(Inherited from Element.)
GetDividedSurfaceData
Get an interface to the divided surfaces on this element.
(Inherited from Element.)
GetFloorOrSlabConstructionType
Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.
GetGBSId
Gets the Green Building Studio identifier associated with the construction.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMaterialArea
Get the area of the given material on this element.
(Inherited from Element.)
GetMaterialVolume
Get the volume of the given material on this element.
(Inherited from Element.)
GetMonitoredLinkElementIds
Provides the link instance IDs when the element is monitoring.
(Inherited from Element.)
GetMonitoredLocalElementIds
Provides the local element IDs when the element is monitoring.
(Inherited from Element.)
GetOpeningConstructionType
Get a Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
GetPreviewImage
Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
(Inherited from ElementType.)
GetRoofConstructionType
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
GetShadeConstructionType
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
GetSimilarTypes
Obtains a set of types that are similar to this type.
(Inherited from ElementType.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
GetTypeId
Returns the identifier of this element's type.
(Inherited from Element.)
GetValidTypes
Obtains a set of types that are valid for this element.
(Inherited from Element.)
GetWallConstructionType
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
GetWindowOrSkylightConstructionType
Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
IsHidden
Identifies if the element has been permanently hidden in the view.
(Inherited from Element.)
IsMonitoringLinkElement
Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element.)
IsMonitoringLocalElement
Indicate whether an element is monitoring other local elements.
(Inherited from Element.)
IsSimilarType
Checks if given type is similar to this type.
(Inherited from ElementType.)
IsValidConceptualConstructionId
Indicates if the ElementId is an id of a ConceptualConstructionType.
IsValidConceptualConstructionIdForCategory
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
IsValidSubcategoryForMassSurfaceDatas
Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassWindow
  9. OST_MassSkylights
  10. OST_MassOpening
IsValidSurfaceSubcategoryForConstruction
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
IsValidType
Checks if given type is valid for this element.
(Inherited from Element.)
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MassSurfaceSubCategoryId | The surface type subcategory element id associated with the ConceptualConstructionType.
MaterialId | Material used for visualization of this construction.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace