Revit 2011 API
FieldDomainPointsByParameter Constructor
FieldDomainPointsByParameter Class See Also
Creates object from an array of one-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FieldDomainPointsByParameter(
    IList<double> points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As IList(Of Double) _
)
Visual C++
public:
FieldDomainPointsByParameter(
    IList<double>^ points
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( Double >)>)
Array of one-dimensional point coordinates representing domain points (using raw parameters when on a curve)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByParameter Class
Autodesk.Revit.DB.Analysis Namespace