Revit 2011 API
FilteredElementCollector..::.WhereElementIsElementType Method
FilteredElementCollector Class See Also
Applies an ElementIsElementTypeFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsElementType()
Visual Basic (Declaration)
Public Function WhereElementIsElementType As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsElementType()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements which are ElementTypes will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class