Revit 2011 API
FilterableValueProvider..::.IsIntegerValueSupported Method
FilterableValueProvider Class See Also
Determines whether the provide can provide an integer value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsIntegerValueSupported(
    Element element
)
Visual Basic (Declaration)
Public Function IsIntegerValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsIntegerValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query.

Return Value

True if the provider can return an integer value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class