Revit 2011 API
FilteredElementCollector..::.ToElementIds Method
FilteredElementCollector Class See Also
Returns the complete set of element ids which pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> ToElementIds()
Visual Basic (Declaration)
Public Function ToElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ ToElementIds()

Return Value

The complete set of element ids.

Remarks

This will reset the collector to the beginning and extract all elements which pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class