Revit 2011 API
Element..::.GetChangeTypeGeometry Method
Element Class See Also
summary: Returns ChangeType associated with a change in the geometry of an element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeGeometry()
Visual Basic (Declaration)
Public Shared Function GetChangeTypeGeometry As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeGeometry()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on a geometry change in an element

Remarks

Use this change type to trigger an Updater when the geometry of an element changes. Only physical changes to shape of the element(s) will trigger the updater. For example, changes like cutting a hole in a wall or adjusting its height are considered to be geometric changes. However, moving a wall to a different location without modifying its shape is not considered to be a change in geometry and will not trigger the Updater. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

See Also

Element Class