Revit 2011 API
Edge Class
Members See Also
An edge of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Edge : GeometryObject
Visual Basic (Declaration)
Public Class Edge _
    Inherits GeometryObject
Visual C++
public ref class Edge : public GeometryObject

Remarks

Edges are defined by intersections of surfaces that form faces of the solid. They have arbitrary parameterization that is normalized to [0,1].

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Edge

See Also

Edge Members