Revit 2011 API
FailureMessageAccessor..::.GetFailingElementIds Method
FailureMessageAccessor Class See Also
Retrieves Ids of Elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetFailingElementIds()
Visual Basic (Declaration)
Public Function GetFailingElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetFailingElementIds()

Return Value

Ids of Elements that have caused the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class