Revit 2011 API
IUpdater Members
IUpdater Interface Methods See Also

The IUpdater type exposes the following members.

Methods

Name | Description
Execute | The method that Revit will invoke to perform an update.
GetAdditionalInformation | Auxiliary text that Revit will use to inform the end user when the Updater is not loaded
GetChangePriority | Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater
GetUpdaterId | Returns globally unique updater id - used to identify the Updater Called once during registration of the updater
GetUpdaterName | Returns a name that the Updater can be identified by to the user

See Also

IUpdater Interface