Revit 2011 API
PrintParameters Members
PrintParameters Class Methods Properties See Also

The PrintParameters type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorDepth | The color depth type.
HiddenLineViews | The hidden line views type.
HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
HideReforWorkPlanes | Indicates whether to hide referenc/work planes when printing.
HideScopeBoxes | Indicates whether to hide scope boxes when printing.
HideUnreferencedViewTages | Indicates whether to hide unreferenced view tags when printing.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MarginType | The print margin type.
PageOrientation | The Page Orientation of the Print Setting.
PaperPlacement | The paper placement type.
PaperSize | The page size.
PaperSource | The page source.
RasterQuality | The raster quality type.
ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
UserDefinedMarginX | The User defined X value of offset from left bottom corner.
UserDefinedMarginY | The User defined Y value of offset from left bottom corner
ViewLinksinBlue | Indicates whether to view links in blue when printing.
Zoom | The zoom value to a percentage of the original size.
ZoomType | The zoom type.

See Also

PrintParameters Class