Revit 2011 API
AnalysisDisplayStyle..::.IsNameUnique Method
AnalysisDisplayStyle Class See Also
Verify the uniqueness of the name among all analysis display style elements of the document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsNameUnique(
    Document cda,
    string name,
    AnalysisDisplayStyle excludedElement
)
Visual Basic (Declaration)
Public Shared Function IsNameUnique ( _
    cda As Document, _
    name As String, _
    excludedElement As AnalysisDisplayStyle _
) As Boolean
Visual C++
public:
static bool IsNameUnique(
    Document^ cda,
    String^ name,
    AnalysisDisplayStyle^ excludedElement
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
Document in which name uniqueness is verified.
name
Type: System..::.String
Name to verify uniqueness of.
excludedElement
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayStyle
Element to be excluded from uniqueness verification (for renaming of an existing element).

Return Value

True if name is unique, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace