Revit 2011 API
WallType Class
Members Example See Also
Represents a specific type of wall, such as 'Generic -8" '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WallType : HostObjAttributes
Visual Basic (Declaration)
Public Class WallType _
    Inherits HostObjAttributes
Visual C++
public ref class WallType : public HostObjAttributes

Remarks

All wall type objects available in the project can be retrieved from the Document object via the WallTypes property. Every Wall object has a WallType property that returns the a WallType object representing the type. This same WallType property can also be used to change the type of the wall by setting it to a different type.

Examples

CopyC#
public void GetInfo_WallType(WallType wallType)
{
    string message;
    // Reports the nature of the wall
    message = "The wall type kind is : " + wallType.Kind.ToString();

    // Get the overall thickness of this type of wall.
    message += "\nThe wall type Width is : " + wallType.Width.ToString();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_WallType(ByVal wallType As WallType)
    Dim message As String
    ' Reports the nature of the wall
    message = "The wall type kind is : " + wallType.Kind.ToString()

    ' Get the overall thickness of this type of wall.
    message += vbLf & "The wall type Width is : " + wallType.Width.ToString()

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.WallType

See Also

WallType Members