Revit 2011 API
AnalyticalModel..::.IsValidSelector Method
AnalyticalModel Class See Also
This indicates whether the input selector is valid for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidSelector(
    AnalyticalModelSelector selector
)
Visual Basic (Declaration)
Public Function IsValidSelector ( _
    selector As AnalyticalModelSelector _
) As Boolean
Visual C++
public:
bool IsValidSelector(
    AnalyticalModelSelector^ selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::.AnalyticalModelSelector
Identifies a portion of the analytical model geometry.

Return Value

True if selector is valid for this Analytical Model, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace