Revit 2011 API
DividedSurface..::.ComponentRotation Property
DividedSurface Class See Also
The rotation of the pattern by a multiple of 90 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ComponentRotation ComponentRotation { get; set; }
Visual Basic (Declaration)
Public Property ComponentRotation As ComponentRotation
Visual C++
public:
property ComponentRotation ComponentRotation {
    ComponentRotation get ();
    void set (ComponentRotation value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not nullNothingnullptra null reference (Nothing in Visual Basic)).

See Also

DividedSurface Class