Revit 2011 API
BuiltInFailures..::.RegenFailures Members
BuiltInFailures..::.RegenFailures Class Properties See Also

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RegenFailures type exposes the following members.

Properties

Name | Description
CannotRegenFamily | Can't regenerate Family [Family Name]. Edit Family to modify it.
CircularDependency | There is a circular chain of references among the highlighted elements.
CircularDependencyAssocProp | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyAssocPropError | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyConstraint | Highlighted constraints cause a circular chain of references.
CircularDependencyConstraintError | Highlighted constraints cause a circular chain of references.
CircularDependencyError | There is a circular chain of references among the highlighted elements.
CircularDependencySketch | Constraints in sketches of highlighted elements cause a circular chain of references.
CircularDependencySketchError | There is a circular chain of references among the highlighted elements.
CircularDependencyUncut | There is a circular chain of references among the highlighted elements.
CircularDependencyUncutError | There is a circular chain of references among the highlighted elements.
CircularDependencyWall | There is a circular chain of references among the highlighted elements.
CircularDependencyWallError | There is a circular chain of references among the highlighted elements.
ForceRegenSketch | Regen Sketch
GeomStepFailed | Can't rebuild geometry.
GeomStepFailedError | Can't rebuild geometry.
RegenElements | Regenerating elements.
RegeneratedElements | Elements regenerated in pass [Regen Index]
RegenFailure | Regeneration Failure.
UserCancelled | Operation is cancelled by the user.
UserCancelledError | Operation is cancelled by the user.

See Also

BuiltInFailures..::.RegenFailures Class