Revit 2011 API
CurveLoopsProfile Class
Members See Also
Represents a curve loop based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurveLoopsProfile : SweepProfile
Visual Basic (Declaration)
Public Class CurveLoopsProfile _
    Inherits SweepProfile
Visual C++
public ref class CurveLoopsProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SweepProfile
Autodesk.Revit.DB..::.CurveLoopsProfile

See Also

CurveLoopsProfile Members