Revit 2011 API
PrintParameters..::.PageOrientation Property
PrintParameters Class See Also
The Page Orientation of the Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PageOrientationType PageOrientation { get; set; }
Visual Basic (Declaration)
Public Property PageOrientation As PageOrientationType
Visual C++
public:
property PageOrientationType PageOrientation {
    PageOrientationType get ();
    void set (PageOrientationType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class