Revit 2011 API
FailureHandlingOptions Methods
FailureHandlingOptions Class See Also

The FailureHandlingOptions type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetClearAfterRollback |
GetDelayedMiniWarnings |
GetFailuresPreprocessor |
GetForcedModalHandling |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTransactionFinalizer |
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetClearAfterRollback |
SetDelayedMiniWarnings |
SetFailuresPreprocessor | Setting a callback to be invoked in the beginning of failure processing
SetForcedModalHandling | Set the flag whether it pops modal error dialog if the transaction failed to finish
SetTransactionFinalizer | Setting a callback to be executed after transaction is completed
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureHandlingOptions Class