Revit 2011 API
TaskDialog..::.MainInstruction Property
TaskDialog Class See Also
The large primary text that appears at the top of a task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string MainInstruction { get; set; }
Visual Basic (Declaration)
Public Property MainInstruction As String
Visual C++
public:
property String^ MainInstruction {
    String^ get ();
    void set (String^ value);
}

Remarks

It should concisely sum up the problem or situation that is causing the message to display. Follow these guidelines:

  • Every task dialog includes a main instruction.
  • Text should not exceed three lines.
  • Text should use plain language and be jargon free.
  • Main instructions should be written in sentence format – normal capitalization and punctuation.
  • Address the user directly as “you” when appropriate.
  • When presented with multiple command link options the standard final line for the main instructions should be, "What do you want to do?”

Revit will automatically break lines to make the message fit well. "\n" also breaks down to the next line. For a paragraph break, use "\n\n".

Hyperlinks added to the main instructions will not be enabled when the dialog is shown on Vista.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace