Revit 2011 API
ElectricalSystem Methods
ElectricalSystem Class See Also

The ElectricalSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
AddToCircuit | Add a set of exist components to the Electrical System.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
DisconnectPanel | Disconnect the panel for the Electrical System.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
NewWires | Create a bunch of wires for the electrical system.
Remove | Remove elements from system. (Inherited from MEPSystem.)
RemoveFromCircuit | remove a set of exist components from the Electrical System.
SelectPanel | Set the panel for the Electrical System.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace