Revit 2011 API
BuiltInFailures..::.ElectricalFailures Members
BuiltInFailures..::.ElectricalFailures Class Properties See Also

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ElectricalFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToCircuit | You have selected elements that are connected to other elements. These elements will also be added to the Circuit.
AllSlotsOnPanelOccupied | All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.
BankDistanceSmallerThanDiameter | The distance value is smaller than the conduit diameter, please enter a larger value
CableTrayModified | The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.
CannotAssignSecondaryDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].
CannotConnectDifferentDesignOptsObjects | Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.
CannotRemoveMembersInCircuitHavingParent | You have selected elements that are connected to a Panel object in a Circuit. These elements can not be removed from the Circuit.
CircuitOverload | Total connected load for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).
ConduitModified | The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.
ElementsBelongToOtherCircuit | You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected can not be added to this Circuit.
FamilyMismatchCircuit | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
InvalidNumwiresSinglephase | Invalid number of wires for single phase, only 2 and 3 are valid.
InvalidPathOfParallelConduits | Invalid path of parallel conduits
MismatchConnectorDistSysToCircuit | Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.
MismatchNmbAssignedDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].
MismatchNmbOfPolesToCircuit | Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.
MismatchPoleBrakesSlotsNumbers | The number of pole breakers may not be less than the number of occupied slots.
MismatchVoltageLineToLine | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).
MismatchVoltageToCircuit | Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.
MissingOrInvalidWireSizeTable | Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.
NoAvailableMatchingConnector | Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.
NotAllowedCableTrayConduitRotation | Don't allow to rotate a horizontal cable tray/conduit like this
NotEnoughAvailSlotsOnPanel | There are not enough slots available on panel: [Panel Name] for a circuit to be added. Please increase the maximum number of single pole breakers to be greater than [Number] or set it to 0.
ObjsDemolished | Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.
PanelMismatchCircuitType | Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.
SelectedElementsArePartOfOtherCircuit | You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.
UnsignedCircuit | Circuit is not assigned to a panel
VoltageIsOutOfRange | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."

See Also

BuiltInFailures..::.ElectricalFailures Class