Revit 2011 API
ModificationOutsideTransactionException Class
Members See Also
The exception that is thrown by the undo transaction framework when the modification operation to the model is outside of a transaction.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ModificationOutsideTransactionException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ModificationOutsideTransactionException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ModificationOutsideTransactionException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException

See Also

ModificationOutsideTransactionException Members
Autodesk.Revit.Exceptions Namespace