Revit 2011 API
CableTray Class
Members See Also
This class represents a cable tray in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CableTray : CableTrayConduitBase
Visual Basic (Declaration)
Public Class CableTray _
    Inherits CableTrayConduitBase
Visual C++
public ref class CableTray : public CableTrayConduitBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Electrical..::.CableTrayConduitBase
Autodesk.Revit.DB.Electrical..::.CableTray

See Also

CableTray Members
Autodesk.Revit.DB.Electrical Namespace