Revit 2011 API
PrintManager Members
PrintManager Class Methods Properties See Also

The PrintManager type exposes the following members.

Methods

Name | Description
Apply | Apply the local print settings to global for all documents.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SelectNewPrintDriver | Select a new printer.
SubmitPrint | Overloaded. Print with the current PrintManager settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Collate | Indicates whether to collate of the current print.
CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
CopyNumber | The copy number.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsVirtual | The virtual type in Autodesk Revit.
PaperSizes | Get all print sizes of current printer.
PaperSources | Get all print sources of current printer.
PrinterName | The name of the current printer.
PrintOrderReverse | Indicates whether to reverse the print order of the current print.
PrintRange | The print range.
PrintSetup | The PrintSetup which manages the print settings of current document.
PrintToFile | Indicates whether to print to file.
PrintToFileName | The file name when printing to file.
ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class