Revit 2011 API
FamilyItemFactory..::.NewSweep Method
FamilyItemFactory Class See Also
Adds a new sweep form to the family document.

Overload List

Name | Description
NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace