Revit 2011 API
TextBoxData Constructor
TextBoxData Class See Also
Constructs a new instance of TextBoxData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TextBoxData(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
TextBoxData(
    String^ name
)

Parameters

name
Type: System..::.String
The internal name of the TextBoxData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for name.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for name.

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace