Revit 2011 API
LayoutRuleFixedDistance Constructor
LayoutRuleFixedDistance Class See Also
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Type: System..::.Double
The value of spacing must be between 0 and 30000.
justifyType
Type: Autodesk.Revit.DB..::.BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

See Also

LayoutRuleFixedDistance Class