Revit 2011 API
Connector..::.CoordinateSystem Property
Connector Class See Also
The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CoordinateSystem As Transform
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::.CoordinateSystem

Remarks

The coordinate system's origin is the location of the connector and the Z-axis is normal to the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector is of logical type.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get coordinate system.

See Also

Connector Class