Revit 2011 API
WallKind Enumeration
See Also
Describes the fundamental type of wall, such as curtain wall or stacked wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum WallKind
Visual Basic (Declaration)
Public Enumeration WallKind
Visual C++
public enum class WallKind

Members

Member name | Description
Unknown | The basic type is not known.
Basic | A standard wall.
Curtain | A curtain wall.
Stacked | A stacked wall of several wall types.

See Also