Revit 2011 API
GuidEnum Members
GuidEnum Class Constructors Methods Properties See Also

The GuidEnum type exposes the following members.

Constructors

Name | Description
GuidEnum | Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Guid | The Guid of GUID-based enum object.

See Also

GuidEnum Class