Revit 2011 API
AnalysisDisplayColorSettings Class
Members Example See Also
Contains color settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayColorSettings : IDisposable
Visual Basic (Declaration)
Public Class AnalysisDisplayColorSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayColorSettings : IDisposable

Examples

CopyC#
AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
Color orange = new Color(255, 205, 0);
Color purple = new Color(200, 0, 200);
colorSettings.MaxColor = orange;
colorSettings.MinColor = purple;
CopyVB.NET
Dim colorSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColorSettings()
Dim orange As New Color(255, 205, 0)
Dim purple As New Color(200, 0, 200)
colorSettings.MaxColor = orange
colorSettings.MinColor = purple

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorSettings

See Also

AnalysisDisplayColorSettings Members
Autodesk.Revit.DB.Analysis Namespace