Revit 2011 API
BuiltInFailures..::.RoomFailures Members
BuiltInFailures..::.RoomFailures Class Properties See Also

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RoomFailures type exposes the following members.

Properties

Name | Description
AreaTagBadViewType | Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.
AreaUnplaceWarning | A Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.
CannotCopyLinkedRooms | Linked Rooms may not be pasted
CannotMakeRoomsGeometry | Could not create geometry for [Room].
ExtensionsOverlapWarning | Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.
InvalidReflectivityPercentage | The value for Reflectivity must be between 0 and 1.
InvisibleRoomBoundElemement | [Room] Bounding element is invisible in current view.
OptionConflictBoundariesVaryMainAddToOptionSet | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictBoundariesVaryMainSeparate | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictBoundariesVaryOptionSeparate | Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictRoomOverlapMain | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictRoomOverlapOption | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.
RoomBaseAboveComputationHeight | [RoomBase]'s lower offset is above the Computation Height
RoomBelowCompHeight | [Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.
RoomBoundaryMisalignment | [Room] bounding element might be misaligned.
RoomHeightNegative | [Room] must have a height greater than 0.
RoomLevelElevs | A [Room]s Upper Limit must be above its Base Level.
RoomNotEnclosed | [Room] is not in a properly enclosed region
RoomNotEnclosedAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedRooms | [Room] is not in a properly enclosed region
RoomNotEnclosedSpaces | [Room] is not in a properly enclosed region
RoomsCreatedAutomatically | [Room] [Room] created automatically.
RoomsFailed | [Room] computations only succeeded without considering the following elements.
RoomsInSameRegion | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionRooms | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionSpaces | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsOverlapInHeight | [Room] Volumes Overlap, adjust Upper Limit and Upper Offset.
RoomsReallyFailed | [Room] computations failed. Try to modify the following elements.
RoomTagBadViewType | [Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.
RoomTagDeleted | A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.
RoomTagNotInRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToArea | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToSpace | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagVolumeNotComputed | [Room] Tag is displaying volume that can't be computed.
RoomTooShort | [Room] is very short. If this is not intended, change its Upper Limit and Offset.
RoomUnplaceWarning | A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.
ShowRoomBoundingElements | [Room] Bounding elements are highlighted.
SpaceUnplaceWarning | A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.

See Also

BuiltInFailures..::.RoomFailures Class