Revit 2011 API
AnalyticalModel..::.IsValidForManualAdjustment Method
AnalyticalModel Class See Also
Indicates if the identified reference is acceptable for Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidForManualAdjustment(
    Reference reference
)
Visual Basic (Declaration)
Public Function IsValidForManualAdjustment ( _
    reference As Reference _
) As Boolean
Visual C++
public:
bool IsValidForManualAdjustment(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
Reference that will be examined.

Return Value

True if reference can be used, false otherwise.

Remarks

This method is useful to determine if a reference is acceptable for Manual Analytical Adjustment in general. This looks briefly at the reference, without looking at the specific context.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace