Revit 2011 API
GeometryInstance Members
GeometryInstance Class Methods Properties See Also

The GeometryInstance type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInstanceGeometry | Overloaded.
GetSymbolGeometry | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Symbol | The symbol element that this object is referring to.
SymbolGeometry | The geometric representation of the symbol which generates this instance.
Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryInstance Class