Revit 2011 API
MassInstanceUtils..::.AddMassLevelDataToMassInstance Method
MassInstanceUtils Class See Also
Create a MassLevelData to associate a Level with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId AddMassLevelDataToMassInstance(
    Document document,
    ElementId massInstanceId,
    ElementId levelId
)
Visual Basic (Declaration)
Public Shared Function AddMassLevelDataToMassInstance ( _
    document As Document, _
    massInstanceId As ElementId, _
    levelId As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ AddMassLevelDataToMassInstance(
    Document^ document,
    ElementId^ massInstanceId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.
levelId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the Level to associate with the mass instance.

Return Value

The ElementId of the MassLevelData that was created, or the existing ElementId if it was already in added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class