Revit 2011 API
ViewPrintingEventArgs Properties
ViewPrintingEventArgs Class See Also

The ViewPrintingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Settings | Print Settings of current project.
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | The view to be printed.

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace