Revit 2011 API
MassLevelData Members
MassLevelData Class Methods Properties See Also

The MassLevelData type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsEmpty | Indicates if the MassLevelData has a geometrical representation. May not if the level does not intersect the mass geometry.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMassFamilyInstance | Checks if the ElementId is a mass family instance.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidConceptualConstructionTypeElement | Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData.
ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData is synchronized with the EnergyDataSettings or if it overrides those settings.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelId | The ElementId of the level that the MassLevelData is associated with.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MaterialId | The ElementId of the visualization material used for the MassLevelData
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Name | A human readable name for the Element. (Inherited from Element.)
NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData to the next in the mass.
NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
NVolume | The volume of from the level of this MassLevelData to the next in the mass.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
OwningMassId | The ElementId of the mass that the MassLevelData is associated with.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace