Revit 2011 API
RibbonItemEventArgs Class
Members See Also
The base class of the RibbonItem event arguments which have UIApplication property.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class RibbonItemEventArgs : EventArgs
Visual Basic (Declaration)
Public Class RibbonItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class RibbonItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.UI.Events..::.RibbonItemEventArgs
Autodesk.Revit.UI.Events..::.ComboBoxCurrentChangedEventArgs
Autodesk.Revit.UI.Events..::.ComboBoxDropDownClosedEventArgs
Autodesk.Revit.UI.Events..::.ComboBoxDropDownOpenedEventArgs
Autodesk.Revit.UI.Events..::.TextBoxEnterPressedEventArgs

See Also

RibbonItemEventArgs Members
Autodesk.Revit.UI.Events Namespace