Revit 2011 API
AnalyticalModelSweptProfile Class
Members See Also
Represents an extruded profile swept along a driving curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModelSweptProfile : IDisposable
Visual Basic (Declaration)
Public Class AnalyticalModelSweptProfile _
    Implements IDisposable
Visual C++
public ref class AnalyticalModelSweptProfile : IDisposable

Remarks

Elements such as beams may be formed from a profile that has been swept along a curve. This analytical model represents such a form and is used to access the cross section and the underlying curve that make up the Element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.AnalyticalModelSweptProfile

See Also

AnalyticalModelSweptProfile Members
Autodesk.Revit.DB.Structure Namespace