Revit 2011 API
FilterElementIdRule Members
FilterElementIdRule Class Constructors Methods Properties See Also

The FilterElementIdRule type exposes the following members.

Constructors

Name | Description
FilterElementIdRule | Constructs an instance of FilterElementIdRule.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterElementIdRule Class