Revit 2011 API
ElementCategoryFilter Constructor (BuiltInCategory, Boolean)
ElementCategoryFilter Class See Also
Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementCategoryFilter(
    BuiltInCategory category,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    category As BuiltInCategory, _
    inverted As Boolean _
)
Visual C++
public:
ElementCategoryFilter(
    BuiltInCategory category,
    bool inverted
)

Parameters

category
Type: Autodesk.Revit.DB..::.BuiltInCategory
The category to match.
inverted
Type: System..::.Boolean
True if the filter should match all elements which are not of the given category.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload