Revit 2011 API
RebarBarType..::.SetHookOffsetLength Method
RebarBarType Class See Also
Identifies the hook offset length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetHookOffsetLength(
    ElementId hookId,
    double newLength
)
Visual Basic (Declaration)
Public Sub SetHookOffsetLength ( _
    hookId As ElementId, _
    newLength As Double _
)
Visual C++
public:
void SetHookOffsetLength(
    ElementId^ hookId,
    double newLength
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type
newLength
Type: System..::.Double
The hook offset length for a hook type

Remarks

AutoCalcHookLengths is ignored when this property is set

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the rebar hook type id hookId is not valid -or- the hook specified by id hookId doesn't have valid offset length
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace