Revit 2011 API
FunctionId..::.GetObjectData Method
FunctionId Class See Also
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace