Revit 2011 API
Form Properties
Form Class See Also

The Form type exposes the following members.

Properties

Name | Description
AreProfilesConstrained | Get/set if the form's profiles are constrained.
BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
HasOpenGeometry | Tell if the form has an open geometry.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInXRayMode | Get/set if the form is in X-Ray mode.
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathCurveCount | The number of curves in the form path.
PathCurveReference | The curve reference in the path, specified by curve index.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileCount | The number of profiles in the form.
ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Form Class