Revit 2011 API
View..::.CropBox Property
View Class See Also
The crop box applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxXYZ CropBox { get; set; }
Visual Basic (Declaration)
Public Property CropBox As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ CropBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Field Value

nullNothingnullptra null reference (Nothing in Visual Basic) if the view is a template.

Remarks

The X direction of the box is right on screen; Y, up; Z, towards the user.

See Also

View Class