Revit 2011 API
Document..::.IsModifiable Property
Document Class See Also
The document's state of modifiability.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsModifiable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsModifiable As Boolean
Visual C++
public:
property bool IsModifiable {
    bool get ();
}

Remarks

This is not a permanent state such as, for example IsReadOnlyFile. Value of this property changes dynamically multiple times within the life-time of an open document. Regardless of the mode a document is opened with, the model can only be modified inside an open transaction. Furthermore, even with a transaction open, the model is not always modifiable. Though this is rather a rare situation, it can happen, most likely during model regeneration, failure processing, or some events. An attempt to modify a non-modifiable document will result in throwing a ModificationOutsideTransactionException. See also IsReadOnly

See Also

Document Class