Revit 2011 API
FailureDefinitionAccessor..::.HasResolutions Method
FailureDefinitionAccessor Class See Also
Checks if the FailureDefinition has at least one resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic (Declaration)
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if at least one resolution is defined in the FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class