Revit 2011 API
AnalysisDisplayMarkersAndTextSettings Members
AnalysisDisplayMarkersAndTextSettings Class Constructors Methods Properties See Also

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Constructors

Name | Description
AnalysisDisplayMarkersAndTextSettings | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two colored surface settings objects.
SetTextTypeId | Set element id of text associated with settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MarkerSize | Size of marker.
MarkerType | Type of marker to use in the analysis display.
Rounding | Increment to which numeric values of analysis results are to be rounded in legend.
ShowText | If set to true, show text in the analysis display.
TextTypeId | Element id of text associated with the settings.

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace