Revit 2011 API
DefinitionsBase Members
DefinitionsBase Class Constructors Methods Properties See Also

The DefinitionsBase type exposes the following members.

Constructors

Name | Description
DefinitionsBase | Initializes a new instance of the DefinitionsBase class

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty.
Contains | Tests for the existence of a definition within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of definitions that are in the set.

See Also

DefinitionsBase Class