Revit 2011 API
MassInstanceUtils..::.RemoveMassLevelDataFromMassInstance Method
MassInstanceUtils Class See Also
Delete the MassLevelData that associates a Level with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static void RemoveMassLevelDataFromMassInstance(
    Document document,
    ElementId massInstanceId,
    ElementId levelId
)
Visual Basic (Declaration)
Public Shared Sub RemoveMassLevelDataFromMassInstance ( _
    document As Document, _
    massInstanceId As ElementId, _
    levelId As ElementId _
)
Visual C++
public:
static void RemoveMassLevelDataFromMassInstance(
    Document^ document,
    ElementId^ massInstanceId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.
levelId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the Level to disassociate from the mass instance.

Remarks

Alternatively, you could just delete the MassLevelData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class