Revit 2011 API
AnalysisDisplayStyle..::.SetMarkersAndTextSettings Method
AnalysisDisplayStyle Class See Also
Set markers and text settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings markersAndTextSettings
)
Visual Basic (Declaration)
Public Sub SetMarkersAndTextSettings ( _
    markersAndTextSettings As AnalysisDisplayMarkersAndTextSettings _
)
Visual C++
public:
void SetMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings^ markersAndTextSettings
)

Parameters

markersAndTextSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayMarkersAndTextSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | markers and text settings were not created with the object.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace