Revit 2011 API
ElementCategoryFilter Constructor (BuiltInCategory)
ElementCategoryFilter Class See Also
Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementCategoryFilter(
    BuiltInCategory category
)
Visual Basic (Declaration)
Public Sub New ( _
    category As BuiltInCategory _
)
Visual C++
public:
ElementCategoryFilter(
    BuiltInCategory category
)

Parameters

category
Type: Autodesk.Revit.DB..::.BuiltInCategory
The category to match.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload