Revit 2011 API
ConceptualConstructionType..::.IsValidConceptualConstructionId Method
ConceptualConstructionType Class See Also
Indicates if the ElementId is an id of a ConceptualConstructionType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool IsValidConceptualConstructionId(
    Document ccda,
    ElementId constructionTypeId
)
Visual Basic (Declaration)
Public Shared Function IsValidConceptualConstructionId ( _
    ccda As Document, _
    constructionTypeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidConceptualConstructionId(
    Document^ ccda,
    ElementId^ constructionTypeId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The document.
constructionTypeId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the ConceptualConstructionType.

Return Value

Returns true if is an id of a ConceptualConstructionType, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace