Revit 2011 API
JoinType Enumeration
See Also
The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum JoinType
Visual Basic (Declaration)
Public Enumeration JoinType
Visual C++
public enum class JoinType

Members

Member name | Description
None | No join type
Abut | Abut Join
Miter | Miter Join
SquareOff | Square-off Join
Extension | Extension Join

See Also