Revit 2011 API
Mesh Members
Mesh Class Methods Properties See Also

The Mesh type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumTriangles | The number of triangles that the mesh contains.
Transformed | Transforms this mesh and returns the result.
Triangle | Retrieves a specific triangle.
Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Mesh Class