Revit 2011 API
TaskDialog..::.Title Property
TaskDialog Class See Also
Title of the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Remarks

Titles of task dialogs should be unique. Do not reuse the same title for multiple task dialogs.

Newline characters are not allowed in Title.

When the dialogs is shown, Revit will put “External Command Name –“ or “External Application –“ in the front of the value by default. Examples:

  • Plug-in Name – No Rooms to Calculate
  • Plug-in Name – Invalid Value for Length
You can suppress it by setting TitleAutoPrefix to false.

Titles should describe the nature of the problem or state the situation that currently exists. The title tells the user why they are getting the message, not what they are supposed to do.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string or string contains newline characters.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace