Revit 2011 API
Category..::.GetGraphicsStyle Method
Category Class See Also
Gets the graphics style associated with this category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GraphicsStyle GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Function GetGraphicsStyle ( _
    graphicsStyleType As GraphicsStyleType _
) As GraphicsStyle
Visual C++
public:
GraphicsStyle^ GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.DB..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class