Revit 2011 API
CompoundStructureLayer Members
CompoundStructureLayer Class Methods Properties See Also

The CompoundStructureLayer type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeckProfile | Returns or sets the family symbol of the deck profile of the layer within the structure.
DeckUsage | Returns usage of the deck layer within the structure.
Function | Returns the purpose/function of the layer within the structure.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Material | Get or set the material from which the layer is made.
Thickness | Retrieve or modify the thickness of the layer.
Variable | Returns or sets the variability of the layer's thickness.

See Also

CompoundStructureLayer Class