Revit 2011 API
SpatialFieldManager..::.SetMeasurementNames Method
SpatialFieldManager Class See Also
sets Names for all measurements

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetMeasurementNames(
    IList<string> measurementNames
)
Visual Basic (Declaration)
Public Sub SetMeasurementNames ( _
    measurementNames As IList(Of String) _
)
Visual C++
public:
void SetMeasurementNames(
    IList<String^>^ measurementNames
)

Parameters

measurementNames
Type: System.Collections.Generic..::.IList <(Of <( String >)>)
Array of measurement names. All names in the array must be unique. The lengths of the array must be equal to the number of measurements set during creation of SpatialFieldManager.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | measurementNames contains duplicate names or its lengths is not equal to the number of measurements set during creation of SpatialFieldManager
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace