Revit 2011 API
AnalyticalSupportPriority Enumeration
See Also
Defines how "highly" another Element is giving support for one Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalSupportPriority
Visual Basic (Declaration)
Public Enumeration AnalyticalSupportPriority
Visual C++
public enum class AnalyticalSupportPriority

Members

Member name | Description
UnknownPriority | Priority has not been determined.
HighestPriority |
SecondHighestPriority |
ThirdHighestPriority |
FourthHigestPriority |

Remarks

For instance, a Column may be a higher priority for a Beam than another Beam. This is useful to find the best supports for a given Element.

See Also

Autodesk.Revit.DB.Structure Namespace