Revit 2011 API
FootPrintRoof Members
FootPrintRoof Class Methods Properties See Also

The FootPrintRoof type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
DefinesSlope | Retrieve or set the DefinesSlope of the curve.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
ExtendIntoWall | Retrieve or set whether extend into wall the curve.
FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Offset | Retrieve or set the Offset of the curve.
Overhang | Retrieve or set the Overhang of the curve.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
SlopeAngle | Retrieve or set the SlopeAngle of the curve.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FootPrintRoof Class