Revit 2011 API
FamilySymbol..::.GetFamilyPointLocations Method
FamilySymbol Class See Also
Returns the Point Locations for the Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<FamilyPointLocation> GetFamilyPointLocations()
Visual Basic (Declaration)
Public Function GetFamilyPointLocations As IList(Of FamilyPointLocation)
Visual C++
public:
IList<FamilyPointLocation^>^ GetFamilyPointLocations()

Remarks

If a family symbol has point references then their locations are returned by this method, otherwise an empty collection is returned. Examples of FamilySymbol objects that contain point location are Panels and Flexible Components.

See Also

FamilySymbol Class