Revit 2011 API
Truss Methods
Truss Class See Also

The Truss type exposes the following members.

Methods

Name | Description
AttachChord | Attach a truss's specific chord to a specified element, the element should be a roof or floor.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
DetachChord | Detach a truss's specific chord from the element to which it is attached.
Dispose | (Inherited from Element.)
DropTruss | Drop truss Family, it will disassociate all members from the truss and delete the truss.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveProfile | Remove the profile of a truss.
SetProfile | Add or modify the profile of a truss.
TogglePinMember | Pin/Unpin a truss member.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace