Revit 2011 API
BoundingBoxContainsPointFilter Members
BoundingBoxContainsPointFilter Class Constructors Methods Properties See Also

The BoundingBoxContainsPointFilter type exposes the following members.

Constructors

Name | Description
BoundingBoxContainsPointFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Point | The XYZ point to use when matching element bounding boxes.
Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxContainsPointFilter Class