Revit 2011 API
MechanicalEquipment Class
Members See Also
Provides access to the Mechanical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MechanicalEquipment : MEPModel
Visual Basic (Declaration)
Public Class MechanicalEquipment _
    Inherits MEPModel
Visual C++
public ref class MechanicalEquipment : public MEPModel

Remarks

The Mechanical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB.Mechanical..::.MechanicalEquipment

See Also

MechanicalEquipment Members
Autodesk.Revit.DB.Mechanical Namespace