Revit 2011 API
DimensionStyleType Enumeration
See Also
An enumerated type containing possible style types of dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DimensionStyleType
Visual Basic (Declaration)
Public Enumeration DimensionStyleType
Visual C++
public enum class DimensionStyleType

Members

Member name | Description
Linear | Linear dimension.
Angular | Angular dimension.
Radial | Radial dimension.
ArcLength | ArcLength dimension.
SpotElevation | SpotElevation
SpotCoordinate | SpotCoordinate
LinearFixed | LinearFixed dimension, which is linear dimension whose direction is parallel to X or Y.
SpotSlope | SpotSlope

See Also