Revit 2011 API
ControlledApplication Class
Members See Also
Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.ApplicationServices..::.ControlledApplication

See Also

ControlledApplication Members
Autodesk.Revit.ApplicationServices Namespace