Revit 2011 API
FailuresAccessor..::.ReplaceFailures Method
FailuresAccessor Class See Also
Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void ReplaceFailures(
    FailureMessage failure
)
Visual Basic (Declaration)
Public Sub ReplaceFailures ( _
    failure As FailureMessage _
)
Visual C++
public:
void ReplaceFailures(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessage
FailureMessage that should replace all currently posted messages. It must have severity DocumentCorruption.

Remarks

If analysis done by Failures Processing code concludes that in a given context delivering of the posted failures to the user makes no sense, this method can be used to discard all posted failures and substitute one "generic" one, that will be delivered to the user and then transaction forced to be aborted. After the call, (pre)processing of failures should return ProceedWithRollback.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Severity of failure must be FailureSeverity::DocumentCorruption.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class