Revit 2011 API
BuiltInFailures..::.TrussFailures Properties
BuiltInFailures..::.TrussFailures Class See Also

The BuiltInFailures..::.TrussFailures type exposes the following members.

Properties

Name | Description
IncorrectWallUsageWithAttachedStruct | A structural framing element is attached to a wall whose Structural Usage is set to [Usage].
InvalidWorkplaneForStructuralFraming | Workplane not valid for Structural Framing component "[Family Name]"
RemoveTrussSketch | Remove Sketch
TrussBadTransformation | Revit can not transform the truss Layout Family to the Truss as oriented in the project.
TrussChordUntransformable | Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.
TrussDuplicateEngineeringType | Elements have duplicate 'Engineering Type' values.
TrussInvalidSymbolGeom | Truss is unable to generate any members due to layout family error.
TrussIsAttachedTo | Revit can not attach to the chosen Roof/Slab. The truss can not project to a surface or the attachment creates an invalid profile.
TrussLayoutNonSympleTopChord | This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.
TrussLayoutOverlapedCurves | The current transformation of this specific truss layout will some sub members to overlap.
TrussNotJoinedWebs | The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.
TrussUserDefinedMemberDeleted | A user-defined structural member was deleted due to missing or deleted references.
TrussUserDefinedMemberNotJoined | Both start and end of web must intersect the truss.

See Also

BuiltInFailures..::.TrussFailures Class