Revit 2011 API
ConceptualSurfaceType Members
ConceptualSurfaceType Class Methods Properties See Also

The ConceptualSurfaceType type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllMassSubCategoryIds | Get all the mass subcategory ids for which there are ConceptualSurfaceType's.
GetByMassSubCategoryId | Get the ConceptualSurfaceType by its mass subcategory id.
GetConstructionTypeIds | The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultConstructionTypeId | The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.
MassSubCategoryId | The mass subcategory id of the ConceptualSurfaceType.

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace