Revit 2011 API
MessageBoxShowingEventArgs Members
MessageBoxShowingEventArgs Class Methods Properties See Also

The MessageBoxShowingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DialogType | An integer that describes the standard Windows type of the dialog box.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Message | The message that has been displayed in the dialog box.

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace