Revit 2011 API
AnalyticalModel..::.SetUsesHardPoints Method
AnalyticalModel Class See Also
Sets Hard Points for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetUsesHardPoints(
    bool hardPoints
)
Visual Basic (Declaration)
Public Sub SetUsesHardPoints ( _
    hardPoints As Boolean _
)
Visual C++
public:
void SetUsesHardPoints(
    bool hardPoints
)

Parameters

hardPoints
Type: System..::.Boolean
Enable/disable Hard Points (true = enable).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel cannot use Hard Points.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace