Revit 2011 API
AssetProperties Members
AssetProperties Class Methods Properties See Also

The AssetProperties type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object.
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace