Revit 2011 API
AnalyticalModelSketchComponent..::.GetAnalyticalProjectionDatumPlane Method
AnalyticalModelSketchComponent Class See Also
Retrieves Datum Plane ElementId for Analytical Projection

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetAnalyticalProjectionDatumPlane()
Visual Basic (Declaration)
Public Function GetAnalyticalProjectionDatumPlane As ElementId
Visual C++
public:
ElementId^ GetAnalyticalProjectionDatumPlane()

Return Value

Represents Datum used for Analytical Projection, if Analytical Projection Type indicates that a Datum Plane is to be used. Otherwise, invalidElementId is returned.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace