Revit 2011 API
SpatialFieldManager..::.AddSpatialFieldPrimitive Method
SpatialFieldManager Class See Also
Creates empty analysis results container (primitive) not associated with any geometry element

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive()
Visual Basic (Declaration)
Public Function AddSpatialFieldPrimitive As Integer
Visual C++
public:
int AddSpatialFieldPrimitive()

Return Value

Unique index of primitive for future references

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace