Revit 2011 API
ModelNurbSpline Class
Members See Also
Represents a ModelNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelNurbSpline : ModelCurve
Visual Basic (Declaration)
Public Class ModelNurbSpline _
    Inherits ModelCurve
Visual C++
public ref class ModelNurbSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.ModelCurve
Autodesk.Revit.DB..::.ModelNurbSpline

See Also

ModelNurbSpline Members