Revit 2011 API
NurbSpline Properties
NurbSpline Class See Also

The NurbSpline type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
CtrlPoints | Returns the control points of the nurb spline.
Degree | Returns the degree of the nurb spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
isClosed | Return/set the nurb spline's isClosed property.
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
isRational | Returns whether the nurb spline is rational or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Knots | Return/set the knots of the nurb spline.
Length | The exact length of the curve. (Inherited from Curve.)
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)
Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class