Revit 2011 API
FilteredElementCollector..::.OwnedByView Method
FilteredElementCollector Class See Also
Applies an ElementOwnerViewFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector OwnedByView(
    ElementId viewId
)
Visual Basic (Declaration)
Public Function OwnedByView ( _
    viewId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OwnedByView(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::.ElementId
The view id of the owner view.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements which are owned by this particular view will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class