Revit 2011 API
RibbonItem..::.ItemText Property
RibbonItem Class See Also
Gets or sets the text displayed on the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual string ItemText { get; set; }
Visual Basic (Declaration)
Public Overridable Property ItemText As String
Visual C++
public:
virtual property String^ ItemText {
    String^ get ();
    void set (String^ value);
}

Remarks

The text can be changed at run time. nullNothingnullptra null reference (Nothing in Visual Basic) or empty string is not allowed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the text to empty or to the string contains "%".
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the text to nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace