Revit 2011 API
AddInId Members
AddInId Class Constructors Methods See Also

The AddInId type exposes the following members.

Constructors

Name | Description
AddInId | creates an AddInId object with a given GUID

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddInName | name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
GetAddInNameFromDocument | name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
GetGUID | value of the AddInId as a GUID
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInId Class