Revit 2011 API
ConduitRun Class
Members See Also
This class represents a conduit run in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ConduitRun : CableTrayConduitRunBase
Visual Basic (Declaration)
Public Class ConduitRun _
    Inherits CableTrayConduitRunBase
Visual C++
public ref class ConduitRun : public CableTrayConduitRunBase

Remarks

This class is mainly for calculating length of a conduit run. A conduit run contains connected straight conduit segments and bends between the straight segments with same type and size.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Electrical..::.CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::.ConduitRun

See Also

ConduitRun Members
Autodesk.Revit.DB.Electrical Namespace