Revit 2011 API
PrintSetup..::.Rename Method
PrintSetup Class See Also
Rename the current print setting with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename(
    String^ newName
)

Parameters

newName
Type: System..::.String
print setting name to be renamed as.

Return Value

False if Rename operation fails, otherwise true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class