Revit 2011 API
Options Members
Options Class Constructors Methods Properties See Also

The Options type exposes the following members.

Constructors

Name | Description
Options | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ComputeReferences | Determines whether or not references to geometric objects are computed.
DetailLevel | The detail level for the geometry extracted with these options.
IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | The view used for geometry extraction.

See Also

Options Class