Revit 2011 API
Document..::.LoadFamily Method (Document)
Document Class See Also
Loads the contents of this family document into another document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Family LoadFamily(
    Document targetDocument
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    targetDocument As Document _
) As Family
Visual C++
public:
Family^ LoadFamily(
    Document^ targetDocument
)

Parameters

targetDocument
Type: Autodesk.Revit.DB..::.Document
The target document where the family will be loaded.

Return Value

Reference of the family in the target document.

Remarks

If you are reloading an edited family back into the source document from which it was extracted, this method will always fail. This is because this method automatically suppresses the prompts Revit typically uses to deal with conflicts between families, and assumes that any such conflict should prevent the loading. If you want to be able to reload the same family into the source document, you should use the LoadFamily overload accepting IFamilyLoadOptions.

Note: this method may not be called during dynamic update.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"targetDocument"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current document is not a family document, or when the target document doesn't support load of this family, or when this family was found in the target document already and the conflict caused an automatic abort of the load operation, or when a shared family in this family was found in the target document already and the conflict caused an automatic abort of the load operation.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
LoadFamily Overload