Revit 2011 API
HostedSweep Class
Members See Also
An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class HostedSweep : HostObject
Visual Basic (Declaration)
Public MustInherit Class HostedSweep _
    Inherits HostObject
Visual C++
public ref class HostedSweep abstract : public HostObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.HostedSweep
Autodesk.Revit.DB.Architecture..::.Fascia
Autodesk.Revit.DB.Architecture..::.Gutter
Autodesk.Revit.DB..::.SlabEdge

See Also

HostedSweep Members