Revit 2011 API
EnergyDataSettings..::.MassZoneDividePerimeter Property
EnergyDataSettings Class See Also
If this is true, outward facing zones on each floor of the building will be divided based on the four compass directions.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool MassZoneDividePerimeter { get; set; }
Visual Basic (Declaration)
Public Property MassZoneDividePerimeter As Boolean
Visual C++
public:
property bool MassZoneDividePerimeter {
    bool get ();
    void set (bool value);
}

Remarks

The quadrants will be True N, S, E, and W. The division of the quadrants will be along the axis of True NW to SE and True SW to NE. The intersection of the quadrants will be placed at the centroid of the zone. The purpose of the these divisions is to ensure that auto-generated zoning is appropriate for thermal loads generated by the relative position of the building to the sun path.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace