Revit 2011 API
ElectricalSystem..::.VoltageDrop Property
ElectricalSystem Class See Also
Returns the VoltageDrop value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double VoltageDrop { get; }
Visual Basic (Declaration)
Public ReadOnly Property VoltageDrop As Double
Visual C++
public:
property double VoltageDrop {
    double get ();
}

Remarks

This property is used to retrieve the VoltageDrop value of the Electrical System.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the voltage drop cannot be computed, because it is zero, or because the circuit is not connected to a panel.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace