Revit 2011 API
Application..::.NewAreaCreationData Method
Application Class See Also
Creates an object which wraps the arguments of Area for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaCreationData NewAreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Function NewAreaCreationData ( _
    areaView As ViewPlan, _
    point As UV _
) As AreaCreationData
Visual C++
public:
AreaCreationData^ NewAreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::.ViewPlan
The view of area element.
point
Type: Autodesk.Revit.DB..::.UV
A point which lies in an enclosed region of area boundary where the new area will reside.

Return Value

The object containing the data needed for area creation.

See Also

Application Class
Autodesk.Revit.Creation Namespace