Revit 2011 API
FailuresAccessor..::.PostFailure Method
FailuresAccessor Class See Also
Posts an additional failure message to be processed for the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void PostFailure(
    FailureMessage failure
)
Visual Basic (Declaration)
Public Sub PostFailure ( _
    failure As FailureMessage _
)
Visual C++
public:
void PostFailure(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessage
Failure message to post.

Remarks

Should be used during failures processing instead of a similar method in a document class. Using method of the document class with the same name during failures processing is prohibited.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class