Revit 2011 API
FailureDefinitionAccessor..::.GetApplicableResolutionTypes Method
FailureDefinitionAccessor Class See Also
Retrieves a list of resolution types applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetApplicableResolutionTypes()
Visual Basic (Declaration)
Public Function GetApplicableResolutionTypes As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetApplicableResolutionTypes()

Return Value

The list of resolution types applicable to the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class