Revit 2011 API
ComboBoxMemberData Members
ComboBoxMemberData Class Constructors Methods Properties See Also

The ComboBoxMemberData type exposes the following members.

Constructors

Name | Description
ComboBoxMemberData | Constructs a new instance of ComboBoxMemberData.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GroupName | Gets or sets a group name for the ComboBoxMember.
Image | The image shown on the ComboBoxMember.
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the ComboBoxMember.
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace