Revit 2011 API
ControlledApplication..::.FileExporting Event
ControlledApplication Class See Also
Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<FileExportingEventArgs> FileExporting
Visual Basic (Declaration)
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
Visual C++
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace