Revit 2011 API
ElectricalDemandFactorDefinition..::.SetValues Method
ElectricalDemandFactorDefinition Class See Also
Sets the value set to the demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetValues(
    ICollection<ElectricalDemandFactorValue> values
)
Visual Basic (Declaration)
Public Sub SetValues ( _
    values As ICollection(Of ElectricalDemandFactorValue) _
)
Visual C++
public:
void SetValues(
    ICollection<ElectricalDemandFactorValue^>^ values
)

Parameters

values
Type: System.Collections.Generic..::.ICollection <(Of <( ElectricalDemandFactorValue >)>)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace