Revit 2011 API
Application..::.NewElementId Method
Application Class See Also
Creates a new Autodesk::Revit::DB::ElementId^ object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId NewElementId()
Visual Basic (Declaration)
Public Function NewElementId As ElementId
Visual C++
public:
ElementId^ NewElementId()

Return Value

The new Autodesk::Revit::DB::ElementId^ object.

See Also

Application Class
Autodesk.Revit.Creation Namespace