Revit 2011 API
AnalysisDisplayLegendSettings Constructor (AnalysisDisplayLegendSettings)
AnalysisDisplayLegendSettings Class See Also
Constructs a copy of legend settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayLegendSettings(
    AnalysisDisplayLegendSettings other
)
Visual Basic (Declaration)
Public Sub New ( _
    other As AnalysisDisplayLegendSettings _
)
Visual C++
public:
AnalysisDisplayLegendSettings(
    AnalysisDisplayLegendSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegendSettings
Legend settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayLegendSettings Class
AnalysisDisplayLegendSettings Overload
Autodesk.Revit.DB.Analysis Namespace