Revit 2011 API
AnalyticalModelSupport..::.GetFace Method
AnalyticalModelSupport Class See Also
Retrieves surface providing support,

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Face GetFace()
Visual Basic (Declaration)
Public Function GetFace As Face
Visual C++
public:
Face^ GetFace()

Return Value

Surface representing the surface providing support, if the Support Type is Surface Support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | Thrown when the Support Type is not Surface Support.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace