Revit 2011 API
Document..::.NewElectricalSystem Method (ElementSet, ElectricalSystemType)
Document Class See Also
Creates a new MEP Electrical System element from a set of electrical components.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    ElementSet electComponents,
    ElectricalSystemType elecSysType
)
Visual Basic (Declaration)
Public Function NewElectricalSystem ( _
    electComponents As ElementSet, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem(
    ElementSet^ electComponents,
    ElectricalSystemType elecSysType
)

Parameters

electComponents
Type: Autodesk.Revit.DB..::.ElementSet
The electrical components in this system.
elecSysType
Type: Autodesk.Revit.DB.Electrical..::.ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the electrical system cannot be created by these input electrical components.

See Also

Document Class
NewElectricalSystem Overload
Autodesk.Revit.Creation Namespace