Revit 2011 API
CurveByPointsUtils..::.SetSketchOnSurface Method
CurveByPointsUtils Class See Also
Sets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static void SetSketchOnSurface(
    CurveElement curveElem,
    bool sketchOnSurface
)
Visual Basic (Declaration)
Public Shared Sub SetSketchOnSurface ( _
    curveElem As CurveElement, _
    sketchOnSurface As Boolean _
)
Visual C++
public:
static void SetSketchOnSurface(
    CurveElement^ curveElem,
    bool sketchOnSurface
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::.CurveElement
The CurveElement.
sketchOnSurface
Type: System..::.Boolean
Whether or not the CurveElement should lie on the face and be able to be added to the face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class