Revit 2011 API
Element..::.GetTypeId Method
Element Class Example See Also
Returns the identifier of this element's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetTypeId()
Visual Basic (Declaration)
Public Function GetTypeId As ElementId
Visual C++
public:
ElementId^ GetTypeId()

Return Value

The id of the element's type, or invalid element id if the element can not have type assigned.

Remarks

Some elements can not have type assigned, in which case this method returns invalid element id.

Examples

CopyC#
void GetStairType(Autodesk.Revit.DB.Document document)
{
   FilteredElementCollector collector = new FilteredElementCollector(document);
   ICollection<Element> stairs = collector.OfClass(typeof(FamilyInstance)).OfCategory(BuiltInCategory.OST_Stairs).ToElements();
   foreach (Element stair in stairs)
    {
        if (null == stair.GetTypeId())
        {
            TaskDialog.Show("Revit","No symbol found in stair element: " + stair.Name);
        }
        else
        {
            Element elemType = document.get_Element(stair.GetTypeId());
            string info = "Stair type is: " + elemType.Name;
            TaskDialog.Show("Revit",info);
        }
    }
}
CopyVB.NET
Sub GetStairType(ByVal document As Autodesk.Revit.DB.Document)
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim stairs As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilyInstance)).OfCategory(BuiltInCategory.OST_Stairs).ToElements()
    For Each stair As Autodesk.Revit.DB.Element In stairs
        If stair.GetTypeId() Is Nothing Then
            TaskDialog.Show("Revit", "No symbol found in stair element: " + stair.Name)
        Else
            Dim elemType As Autodesk.Revit.DB.Element = document.Element(stair.GetTypeId())
            Dim info As String = "Stair type is: " + elemType.Name
            TaskDialog.Show("Revit", info)
        End If
    Next
End Sub

See Also

Element Class