Revit 2011 API
TaskDialog..::.AllowCancellation Property
TaskDialog Class See Also
Whether the task dialog can be cancelled if no cancel button is specified.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AllowCancellation { get; set; }
Visual Basic (Declaration)
Public Property AllowCancellation As Boolean
Visual C++
public:
property bool AllowCancellation {
    bool get ();
    void set (bool value);
}

Remarks

The default value is true. If there is a cancel button in the task dialog, the it always can be cancelled.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace