Revit 2011 API
InternalDefinition Properties
InternalDefinition Class See Also

The InternalDefinition type exposes the following members.

Properties

Name | Description
BuiltInParameter | Identifies if the parameter is a BuiltIn parameter.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user-visible name for the parameter. (Overrides Definition..::.Name.)
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user-visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)

See Also

InternalDefinition Class