Revit 2011 API
Edge Methods
Edge Class See Also

The Edge type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the edge at the parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the edge.
EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Tessellate | Returns a polyline approximation to the edge.
TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Edge Class