Revit 2011 API
WallLocationLine Enumeration
See Also
This enumerated type represents the options for alignment of a wall's location line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum WallLocationLine
Visual Basic (Declaration)
Public Enumeration WallLocationLine
Visual C++
public enum class WallLocationLine

Members

Member name | Description
WallCenterline | The wall location line is aligned to the center of the wall.
CoreCenterline | The wall location line is aligned to the center of the core.
FinishFaceExterior | The wall location line is aligned to the exterior face of the wall.
FinishFaceInterior | The wall location line is aligned to the interior face of the wall.
CoreExterior | The wall location line is aligned to the exterior face of the core.
CoreInterior | The wall location line is aligned to the exterior face of the core.

See Also