Revit 2011 API
TransactionGroup Members
TransactionGroup Class Constructors Methods See Also

The TransactionGroup type exposes the following members.

Constructors

Name | Description
TransactionGroup | Overloaded.

Methods

Name | Description
Assimilate | Assimilates all inner transactions, merges them into a single one, and then commits it
Commit | Commits the transaction group
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetName |
GetStatus | Gets the current status of the transaction group
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasEnded | Determines whether the transaction group was ended or not
HasStarted | Determines whether the transaction group has ever been started or not
RollBack | Rolls back the transaction group and with it all inner transactions enclosing by this group
SetName | accessors for the transaction group name property
Start | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionGroup Class