Revit 2011 API
Curve..::.ComputeRawParameter Method
Curve Class See Also
Computes the raw parameter from the normalized parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ComputeRawParameter(
    double normalizedParameter
)
Visual Basic (Declaration)
Public Function ComputeRawParameter ( _
    normalizedParameter As Double _
) As Double
Visual C++
public:
double ComputeRawParameter(
    double normalizedParameter
)

Parameters

normalizedParameter
Type: System..::.Double
The normalized parameter.

Return Value

The real number equal to the raw curve parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when normalizedParameter is infinite.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class