Revit 2011 API
PointOnFace Class
Members See Also
Define a ReferencePoint relative to a Face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointOnFace : PointElementReference
Visual Basic (Declaration)
Public Class PointOnFace _
    Inherits PointElementReference
Visual C++
public ref class PointOnFace : public PointElementReference

Remarks

A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.PointElementReference
Autodesk.Revit.DB..::.PointOnFace

See Also

PointOnFace Members