Revit 2011 API
EnergyDataSettings..::.CheckExportComplexity Method
EnergyDataSettings Class See Also
Checks that the export complexity falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckExportComplexity(
    gbXMLExportComplexity exportComplexity
)
Visual Basic (Declaration)
Public Shared Function CheckExportComplexity ( _
    exportComplexity As gbXMLExportComplexity _
) As Boolean
Visual C++
public:
static bool CheckExportComplexity(
    gbXMLExportComplexity exportComplexity
)

Parameters

exportComplexity
Type: Autodesk.Revit.DB.Analysis..::.gbXMLExportComplexity
The export complexity to be checked.

Return Value

True if the export complexity falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace