Revit 2011 API
Map Members
Map Class Constructors Methods Properties See Also

The Map type exposes the following members.

Constructors

Name | Description
Map | Initializes a new instance of the Map class

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified key within the map.
Size | Returns the number of objects that are in the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace