Revit 2011 API
RoofBase Class
Members See Also
Represents all kinds of Roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoofBase : HostObject
Visual Basic (Declaration)
Public Class RoofBase _
    Inherits HostObject
Visual C++
public ref class RoofBase : public HostObject

Remarks

The RoofBase object represents all kinds of roof in Revit.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.RoofBase
Autodesk.Revit.DB..::.ExtrusionRoof
Autodesk.Revit.DB..::.FootPrintRoof

See Also

RoofBase Members