Revit 2011 API
Outline Members
Outline Class Constructors Methods Properties See Also

The Outline type exposes the following members.

Constructors

Name | Description
Outline | Overloaded.

Methods

Name | Description
AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Contains | Determine if this Outline contains the specified point to within a tolerance.
ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Scale | Scales the bounding box by given scale.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MaximumPoint | The maximum point of the bounding box.
MinimumPoint | The minimum point of the bounding box.

See Also

Outline Class