Revit 2011 API
MEPBuildingConstruction..::.GetBuildingConstruction Method
MEPBuildingConstruction Class See Also
Gets the current Building Construction from the project information.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Construction GetBuildingConstruction(
    ConstructionType constructionType
)
Visual Basic (Declaration)
Public Function GetBuildingConstruction ( _
    constructionType As ConstructionType _
) As Construction
Visual C++
public:
Construction^ GetBuildingConstruction(
    ConstructionType constructionType
)

Parameters

constructionType
Type: Autodesk.Revit.DB.Analysis..::.ConstructionType
The Construction Type of Building Construction.

Return Value

The Building Construction of the Project Information.

Remarks

This function is used to get the Building Construction of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace