Revit 2011 API
FailureDefinitionRegistry..::.ListAllFailureDefinitions Method
FailureDefinitionRegistry Class See Also
Retrieves all the registered FailureDefinitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FailureDefinitionAccessor> ListAllFailureDefinitions()
Visual Basic (Declaration)
Public Function ListAllFailureDefinitions As IList(Of FailureDefinitionAccessor)
Visual C++
public:
IList<FailureDefinitionAccessor^>^ ListAllFailureDefinitions()

Return Value

All the registered FailureDefinitions.

See Also

FailureDefinitionRegistry Class