Revit 2011 API
MassInstanceUtils Methods
MassInstanceUtils Class See Also

The MassInstanceUtils type exposes the following members.

Methods

Name | Description
AddMassLevelDataToMassInstance | Create a MassLevelData to associate a Level with a mass instance.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetGrossFloorArea | Get the total occupiable floor area represented by a mass instance.
GetGrossSurfaceArea | Get the total exterior building surface area represented by a mass instance.
GetGrossVolume | Get the total building volume represented by a mass instance.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetJoinedElementIds | Get the ElementIds of Elements that are joined to a mass instance.
GetMassLevelDataIds | Get the ElementIds of the MassLevelDatas associated with a mass instance.
GetMassLevelIds | Get the ElementIds of the Levels associated with a mass instance.
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveMassLevelDataFromMassInstance | Delete the MassLevelData that associates a Level with a mass instance.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassInstanceUtils Class