Revit 2011 API
ElementLogicalFilter Class
Members See Also
A filter used to logically combine two or more filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementLogicalFilter : ElementFilter
Visual Basic (Declaration)
Public Class ElementLogicalFilter _
    Inherits ElementFilter
Visual C++
public ref class ElementLogicalFilter : public ElementFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementLogicalFilter
Autodesk.Revit.DB..::.LogicalAndFilter
Autodesk.Revit.DB..::.LogicalOrFilter

See Also

ElementLogicalFilter Members