Revit 2011 API
ConceptualConstructionType..::.GetShadeConstructionType Method
ConceptualConstructionType Class See Also
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetShadeConstructionType(
    Document ccda,
    ConceptualConstructionShadeType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetShadeConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionShadeType _
) As ElementId
Visual C++
public:
static ElementId^ GetShadeConstructionType(
    Document^ ccda,
    ConceptualConstructionShadeType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionShadeType
The ConceptualConstructionShadeType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionShadeType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace