Revit 2011 API
DocumentCreatingEventArgs Properties
DocumentCreatingEventArgs Class See Also

The DocumentCreatingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentType | Type of the document which is about to be created, e.g. Project or Template.
Template | The template file path to be used for creating the new document.

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace