Revit 2011 API
Parameter Methods
Parameter Class See Also

The Parameter type exposes the following members.

Methods

Name | Description
AsDouble | Provides access to the double precision number within the parameter.
AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
AsInteger | Provides access to the integer number within the parameter.
AsString | Provides access to the string contents of the parameter.
AsValueString | Get the parameter value as a string with unit.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Set | Overloaded. Sets the parameter to a new value.
SetValueString | Set the parameter value according to the input string.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parameter Class