Revit 2011 API
ParameterFilterUtilities Methods
ParameterFilterUtilities Class See Also

The ParameterFilterUtilities type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsParameterApplicable | Used to determine whether the element supports the given parameter.
RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterUtilities Class