Revit 2011 API
Selection..::.PickObject Method (ObjectType, String)
Selection Class See Also
Prompts the user to select one object while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference PickObject(
    ObjectType objectType,
    string statusPrompt
)
Visual Basic (Declaration)
Public Function PickObject ( _
    objectType As ObjectType, _
    statusPrompt As String _
) As Reference
Visual C++
public:
Reference^ PickObject(
    ObjectType objectType,
    String^ statusPrompt
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.
statusPrompt
Type: System..::.String
The message shown on the status bar.

Return Value

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObject Overload
Autodesk.Revit.UI.Selection Namespace