Revit 2011 API
FilterInverseRule Class
Members See Also
A filter rule that inverts the boolean values returned by the rule it contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterInverseRule : FilterRule
Visual Basic (Declaration)
Public Class FilterInverseRule _
    Inherits FilterRule
Visual C++
public ref class FilterInverseRule : public FilterRule

Remarks

FilterInverse rule performs a logical "not" operation on its inner rule's "elementPasses()" method.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterRule
Autodesk.Revit.DB..::.FilterInverseRule

See Also

FilterInverseRule Members