Revit 2011 API
Application Class
Members Example See Also
Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Application : IDisposable
Visual Basic (Declaration)
Public Class Application _
    Implements IDisposable
Visual C++
public ref class Application : IDisposable

Examples

CopyC#
string versionInfo = application.VersionBuild + "\n"
                    + application.VersionName + "\n"
                    + application.VersionNumber;
CopyVB.NET
Dim versionInfo As String = application.VersionBuild + vbLf + application.VersionName + vbLf + application.VersionNumber

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.ApplicationServices..::.Application

See Also

Application Members
Autodesk.Revit.ApplicationServices Namespace