Revit 2011 API
Document..::.UnpostFailure Method
Document Class See Also
Deletes the posted failure message associated with a given FailureMessageKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void UnpostFailure(
    FailureMessageKey messageKey
)
Visual Basic (Declaration)
Public Sub UnpostFailure ( _
    messageKey As FailureMessageKey _
)
Visual C++
public:
void UnpostFailure(
    FailureMessageKey^ messageKey
)

Parameters

messageKey
Type: Autodesk.Revit.DB..::.FailureMessageKey
The key of the FailureMessage to be deleted.

Remarks

If code that previously has posted a failure is executed again or otherwise detects that failure conditions do not exist any more and the failure is not longer relevant, it should delete a failure message in order to let transaction to be committed. In order to delete the failure, it should invoke this method with a message key that was returned when the failure was posted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | messageKey is invalid
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class