Revit 2011 API
MassZone..::.SpaceType Property
MassZone Class See Also
The gbXMLSpaceType of the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public gbXMLSpaceType SpaceType { get; set; }
Visual Basic (Declaration)
Public Property SpaceType As gbXMLSpaceType
Visual C++
public:
property gbXMLSpaceType SpaceType {
    gbXMLSpaceType get ();
    void set (gbXMLSpaceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: The space type does not fall within an appropriate range.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace