Revit 2011 API
LogicalOrFilter Class
Members See Also
A filter that contains a set of filters. The filter passes when any filter in the set passes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class LogicalOrFilter : ElementLogicalFilter
Visual Basic (Declaration)
Public Class LogicalOrFilter _
    Inherits ElementLogicalFilter
Visual C++
public ref class LogicalOrFilter : public ElementLogicalFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementLogicalFilter
Autodesk.Revit.DB..::.LogicalOrFilter

See Also

LogicalOrFilter Members