Revit 2011 API
ConceptualConstructionType..::.GetWallConstructionType Method
ConceptualConstructionType Class See Also
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetWallConstructionType(
    Document ccda,
    ConceptualConstructionWallType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetWallConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionWallType _
) As ElementId
Visual C++
public:
static ElementId^ GetWallConstructionType(
    Document^ ccda,
    ConceptualConstructionWallType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionWallType
The ConceptualConstructionWallType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionWallType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace