Revit 2011 API
Sweep Properties
Sweep Class See Also

The Sweep type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Path3d | The selected curves used for the sweep path.
PathSketch | The sketched path for the sweep.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileSketch | The profile sketch of the sweep.
ProfileSymbol | The family symbol profile details for the sweep.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Sweep Class