Revit 2011 API
View..::.CropBoxActive Property
View Class See Also
Whether or not the Crop Box/Region is active for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CropBoxActive { get; set; }
Visual Basic (Declaration)
Public Property CropBoxActive As Boolean
Visual C++
public:
property bool CropBoxActive {
    bool get ();
    void set (bool value);
}

Remarks

Identifies whether the crop region modifies the graphical appearance of elements in the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | Thrown when getting this property, if the view is a template and cannot have a crop box applied.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a crop box applied.

See Also

View Class