Revit 2011 API
ConceptualConstructionType..::.GetWindowOrSkylightConstructionType Method
ConceptualConstructionType Class See Also
Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetWindowOrSkylightConstructionType(
    Document ccda,
    ConceptualConstructionWindowSkylightType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetWindowOrSkylightConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionWindowSkylightType _
) As ElementId
Visual C++
public:
static ElementId^ GetWindowOrSkylightConstructionType(
    Document^ ccda,
    ConceptualConstructionWindowSkylightType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionWindowSkylightType
The ConceptualConstructionWindowSkylightType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionWindowSkylightType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace