Revit 2011 API
Rebar..::.SetUnobscuredInView Method
Rebar Class See Also
Sets this rebar element to be shown unobscured in a view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetUnobscuredInView(
    View view,
    bool unobscured
)
Visual Basic (Declaration)
Public Sub SetUnobscuredInView ( _
    view As View, _
    unobscured As Boolean _
)
Visual C++
public:
void SetUnobscuredInView(
    View^ view,
    bool unobscured
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view element
unobscured
Type: System..::.Boolean
True if rebar is shown unobscured, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This rebar element doesn't have valid visibility data.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace