Revit 2011 API
Selection..::.PickPoint Method
Selection Class See Also
Prompts the user to pick a point on the active work plane.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ PickPoint()
Visual Basic (Declaration)
Public Function PickPoint As XYZ
Visual C++
public:
XYZ^ PickPoint()

Return Value

The point picked by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when no work plane set in current view.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickPoint Overload
Autodesk.Revit.UI.Selection Namespace