Revit 2011 API
Truss..::.GetTrussMemberInfo Method
Truss Class See Also
Query if a given element is a member of a truss,its lock status and its usage,etc.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TrussMemberInfo GetTrussMemberInfo(
    ElementId elemId
)
Visual Basic (Declaration)
Public Function GetTrussMemberInfo ( _
    elemId As ElementId _
) As TrussMemberInfo
Visual C++
public:
TrussMemberInfo^ GetTrussMemberInfo(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::.ElementId
The querying element.

Return Value

A struct TrussMemberInfo that contains the querying element's host truss,whether lock to the truss,usage type,etc.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace