Revit 2011 API
MassLevelData..::.IsValidConceptualConstructionTypeElement Method
MassLevelData Class See Also
Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsValidConceptualConstructionTypeElement(
    ElementId id
)
Visual Basic (Declaration)
Public Function IsValidConceptualConstructionTypeElement ( _
    id As ElementId _
) As Boolean
Visual C++
public:
bool IsValidConceptualConstructionTypeElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The ElementId to be checked.

Return Value

True if the ElementId is an acceptable conceptual construction type ElementId, false otherwise.

Remarks

In the case that 'conceptualConstructionIsByEnergyData' is true, invalidElementId is also acceptable input.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace