Revit 2011 API
ParameterFilterElement..::.AllCategoriesFilterable Method
ParameterFilterElement Class See Also
Checks that all of the given categories are filterable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool AllCategoriesFilterable(
    ICollection<ElementId> categories
)
Visual Basic (Declaration)
Public Shared Function AllCategoriesFilterable ( _
    categories As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool AllCategoriesFilterable(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The set of categories to check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class