Revit 2011 API
Form Methods
Form Class See Also

The Form type exposes the following members.

Methods

Name | Description
AddEdge | Overloaded.
AddProfile | Add a profile into the form, by a specified edge/param.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ConstrainProfiles | Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.
DeleteProfile | Delete a profile of the form.
DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
IsBeginningFace | Given a face, tell if it is a beginning cap face.
IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
IsCurveReference | Tell if the pick is the reference to a curve of the form.
IsEdgeReference | Tell if the pick is the reference to an edge of the form.
IsEndFace | Given a face, tell if it is an end cap face.
IsFaceReference | Tell if the pick is the reference to a face of the form.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsProfileEdge | Tell if an edge or curve is generated from a profile.
IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
IsSideFace | Given a face, tell if it is a side face.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsVertexReference | Tell if the pick is the reference to a vertex of the form.
MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Rehost | Overloaded.
RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Form Class