Revit 2011 API
FilteredElementCollector..::.ToElements Method
FilteredElementCollector Class See Also
Returns the complete set of elements which pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<Element> ToElements()
Visual Basic (Declaration)
Public Function ToElements As IList(Of Element)
Visual C++
public:
IList<Element^>^ ToElements()

Return Value

The complete set of element ids.

Remarks

This will reset the collector to the beginning and extract all elements which pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class