Revit 2011 API
Element..::.GetValidTypes Method (Document, ICollection<(Of <(ElementId>)>))
Element Class See Also
Obtains a set of types that are valid for all given elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetValidTypes(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic (Declaration)
Public Shared Function GetValidTypes ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidTypes(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A collection of element IDs.

Return Value

A set of element IDs of types that are valid for these elements.

Remarks

Returns an empty set if any element can not have a type assigned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
GetValidTypes Overload