Revit 2011 API
ControlledApplication..::.FileImporting Event
ControlledApplication Class See Also
Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<FileImportingEventArgs> FileImporting
Visual Basic (Declaration)
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
Visual C++
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace