Revit 2011 API
FilteredElementIdIterator..::.GetCurrent Method
FilteredElementIdIterator Class See Also
The current element id found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetCurrent()
Visual Basic (Declaration)
Public Function GetCurrent As ElementId
Visual C++
public:
ElementId^ GetCurrent()

Return Value

The element id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | There are no more element ids in the iterator. -or- The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIdIterator Class