Revit 2011 API
Document..::.NewFamilyInstance Method
Document Class See Also
Inserts a new instance of a family into the document.

Overload List

Name | Description
NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol and a base level.
NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace