Revit 2011 API
BuiltInFailures..::.DuctFailures Members
BuiltInFailures..::.DuctFailures Class Properties See Also

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.DuctFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
InvalidDuctFittingKfactorDatabase | Invalid Duct Fitting K-Factor Database
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.

See Also

BuiltInFailures..::.DuctFailures Class