Revit 2011 API
ElementParameterFilter Constructor (FilterRule)
ElementParameterFilter Class See Also
Constructs a new instance of an ElementParameterFilter from a single rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementParameterFilter(
    FilterRule filterRule
)
Visual Basic (Declaration)
Public Sub New ( _
    filterRule As FilterRule _
)
Visual C++
public:
ElementParameterFilter(
    FilterRule^ filterRule
)

Parameters

filterRule
Type: Autodesk.Revit.DB..::.FilterRule
The rule applied to test if the element passes this filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementParameterFilter Class
ElementParameterFilter Overload