Revit 2011 API
SunAndShadowSettings..::.GetFrameAltitude Method
SunAndShadowSettings Class See Also
Identifies the altitude of the sun (angle in radians) for a specific frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double GetFrameAltitude(
    double frame
)
Visual Basic (Declaration)
Public Function GetFrameAltitude ( _
    frame As Double _
) As Double
Visual C++
public:
double GetFrameAltitude(
    double frame
)

Parameters

frame
Type: System..::.Double
Frame for which time is requested

Return Value

Altitude angle (radians)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the frame value frame is not valid.

See Also

SunAndShadowSettings Class