Revit 2011 API
Application..::.Create Property
Application Class See Also
Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Application Create { get; }
Visual Basic (Declaration)
Public ReadOnly Property Create As Application
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace