Revit 2011 API
Edge..::.TessellateOnFace Method
Edge Class See Also
Returns a polyline approximation to the edge in UV parameters of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<UV> TessellateOnFace(
    Face face
)
Visual Basic (Declaration)
Public Function TessellateOnFace ( _
    face As Face _
) As IList(Of UV)
Visual C++
public:
IList<UV^>^ TessellateOnFace(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
The face on which to perform the tessellation. Must belong to the edge.

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class