Revit 2011 API
Application..::.NewProjectDocument Method
Application Class See Also
New project document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Document NewProjectDocument(
    string templateFileName
)
Visual Basic (Declaration)
Public Overridable Function NewProjectDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::.String
The template file name.

Remarks

This command corresponds to the New->Project command in the user-interface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the new project document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace