Revit 2011 API
PushButtonData Class
Members See Also
This class contains information necessary to construct a push button in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class PushButtonData : ButtonData
Visual Basic (Declaration)
Public Class PushButtonData _
    Inherits ButtonData
Visual C++
public ref class PushButtonData : public ButtonData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ButtonData
Autodesk.Revit.UI..::.PushButtonData
Autodesk.Revit.UI..::.ToggleButtonData

See Also

PushButtonData Members
Autodesk.Revit.UI Namespace