Revit 2011 API
AnalyticalModel..::.SetApproximationDeviation Method
AnalyticalModel Class See Also
Adjusts the amount by which approximation is made.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetApproximationDeviation(
    double deviation
)
Visual Basic (Declaration)
Public Sub SetApproximationDeviation ( _
    deviation As Double _
)
Visual C++
public:
void SetApproximationDeviation(
    double deviation
)

Parameters

deviation
Type: System..::.Double
Maximum distance from line to actual curve

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support approximation.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace