Revit 2011 API
Document..::.RebarBarTypes Property
Document Class See Also
Retrieves an object that contains all the rebar bar types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarBarTypeSet RebarBarTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RebarBarTypes As RebarBarTypeSet
Visual C++
public:
property RebarBarTypeSet^ RebarBarTypes {
    RebarBarTypeSet^ get ();
}

Remarks

This property returns a set of rebarbartype objects. These objects can be used change the type of a rebar from one type to another.

See Also

Document Class