Revit 2011 API
DialogBoxData..::.OverrideResult Method
DialogBoxData Class See Also
Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public bool OverrideResult(
    int result
)
Visual Basic (Declaration)
Public Function OverrideResult ( _
    result As Integer _
) As Boolean
Visual C++
public:
bool OverrideResult(
    int result
)

Parameters

result
Type: System..::.Int32
The result code you wish the Revit dialog to return.

Return Value

Returns true if the result code was accepted.

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace