Revit 2011 API
Document..::.NewRebarBarType Method
Document Class See Also
Creates a new instance of Rebar Bar Type, which defines the bar diameter, bar bend diameter and bar material of the rebar.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarBarType NewRebarBarType()
Visual Basic (Declaration)
Public Function NewRebarBarType As RebarBarType
Visual C++
public:
RebarBarType^ NewRebarBarType()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace