Revit 2011 API
Connector..::.ElectricalSystemType Property
Connector Class See Also
The electrical system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystemType ElectricalSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSystemType As ElectricalSystemType
Visual C++
public:
property ElectricalSystemType ElectricalSystemType {
    ElectricalSystemType get ();
}

Remarks

Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not of DomainElectrical.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get electrical system type.

See Also

Connector Class