Revit 2011 API
AnalysisDisplayStyle..::.SetColoredSurfaceSettings Method
AnalysisDisplayStyle Class See Also
Set colored surface settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings
)
Visual Basic (Declaration)
Public Sub SetColoredSurfaceSettings ( _
    coloredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings _
)
Visual C++
public:
void SetColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings^ coloredSurfaceSettings
)

Parameters

coloredSurfaceSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColoredSurfaceSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | colored surface settings were not created with the object.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace