Revit 2011 API
FailureResolutionType Enumeration
See Also
Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum FailureResolutionType
Visual Basic (Declaration)
Public Enumeration FailureResolutionType
Visual C++
public enum class FailureResolutionType

Members

Member name | Description
Invalid | Special (reserved) type. This should be non-initialized value of any variable of FailureResolutionType, end user should not see this value, API programmer could use this in initialization and comparison.
Default | Special (reserved) type. It can not be used as a type when defining a resolution, but can be used as a key to query default resolution from FailureMessage or FailureDefinition.
CreateElements | Defines a resolution of a failure where Revit will add new Element(s) in place of missing one(s).
DeleteElements | Defnes a resolution of a failure by deleting Element(s) that caused the failure.
SkipElements | Defines a resolution of a failure by skipping Element(s) for which operation has failed and proceeding with the rest of Elements.
MoveElements | Defines a resolution of a failure by moving Element(s) to an appropriate location.
FixElements | Defines a resolution of a failure by changing failing Element(s) - specific change may vary depending in type of failure and type of Element(s).
DetachElements | Defines a resolution of a failure by removing invalid relationships between elements such as joined walls and roofs, grouped elements, and associated curves.
QuitEditMode | Defines a resolution of a failure by quitting an Edit Mode instead of committing changes. Changes made in edit mode will be rolled back.
UnlockConstraints | Defines a resolution of a failure by unconstraining Element(s).
SetValue | Defines a resolution of a failure by setting an appropriate value in place of invalid value.
SaveDocument | Save the current document to avoid losing more if something serious occurs.
ShowElements | The standard "Show" may fail in some context, special resolution could be added in this condition to show failing element(s).
Others | Resolution type does not match any of the above.

See Also