Revit 2011 API
AnalyticalSupportType Enumeration
See Also
Indicates what kind of support another Element provides -- Point, Surface, or Curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalSupportType
Visual Basic (Declaration)
Public Enumeration AnalyticalSupportType
Visual C++
public enum class AnalyticalSupportType

Members

Member name | Description
UnknownSupport | Support has not been determined.
PointSupport | Support at just one point.
CurveSupport | Support along a curve.
SurfaceSupport | Support along a surface.

See Also

Autodesk.Revit.DB.Structure Namespace