Revit 2011 API
ToggleButton Members
ToggleButton Class Methods Properties See Also

The ToggleButton type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyName | The assembly path of the button. (Inherited from PushButton.)
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButton.)
ClassName | The name of the class containing the implementation for the command. (Inherited from PushButton.)
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ToggleButton Class
Autodesk.Revit.UI Namespace