Revit 2011 API
FailureMessage Class
Members See Also
Represents a message describing a failure of an operation in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureMessage : IDisposable
Visual Basic (Declaration)
Public Class FailureMessage _
    Implements IDisposable
Visual C++
public ref class FailureMessage : IDisposable

Remarks

Failure messages are typically shown to the user in the Revit error dialog. This class contains the following information about the failures:
  1. The basic description of the failure (retrieved from the FailureDefinition)
  2. The available resolutions for the failure.
  3. The elements related to the failure.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureMessage

See Also

FailureMessage Members