Revit 2011 API
SlabShapeEditor Methods
SlabShapeEditor Class See Also

The SlabShapeEditor type exposes the following members.

Methods

Name | Description
DrawPoint | Adds a point to the corresponding slab, roof or floor.
DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Enable | Enables the slab shape editing functionality.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ModifySubElement | Overloaded. Manipulates an entity on the corresponding slab, roof or floor.
PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the un-modified state.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeEditor Class