Revit 2011 API
Family..::.ExtractPartAtom Method
Family Class See Also
Writes a PartAtom XML from the contents of a family object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ExtractPartAtom(
    string xmlFilePath
)
Visual Basic (Declaration)
Public Sub ExtractPartAtom ( _
    xmlFilePath As String _
)
Visual C++
public:
void ExtractPartAtom(
    String^ xmlFilePath
)

Parameters

xmlFilePath
Type: System..::.String
The xml file to be saved.

Remarks

This method is designed for a family loaded into a document in session. So it will skip the type catalog file. To extract the PartAtom XML from a family file on disk, use Application.ExtractPartAtomFromFamilyFile()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If 'xmlFilePath' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.

See Also

Family Class