Revit 2011 API
AnalyticalModel..::.GetAnalyticalModelSupports Method
AnalyticalModel Class See Also
Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<AnalyticalModelSupport> GetAnalyticalModelSupports()
Visual Basic (Declaration)
Public Function GetAnalyticalModelSupports As IList(Of AnalyticalModelSupport)
Visual C++
public:
IList<AnalyticalModelSupport^>^ GetAnalyticalModelSupports()

Return Value

Array of AnalyticalModelSupport objects, each one representing a support.

Remarks

If an Element is not supported by anything, the array returned should be empty.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace