Revit 2011 API
PrintManager..::.Collate Property
PrintManager Class See Also
Indicates whether to collate of the current print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Collate { get; set; }
Visual Basic (Declaration)
Public Property Collate As Boolean
Visual C++
public:
property bool Collate {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when there is only one view or only one copy in the current settings.

See Also

PrintManager Class