Revit 2011 API
MassEnergyAnalyticalModel..::.GetCoincidentEnergyAnalyticalModelFaceReference Method
MassEnergyAnalyticalModel Class See Also

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static Reference GetCoincidentEnergyAnalyticalModelFaceReference(
    Document document,
    Reference referenceToFace
)
Visual Basic (Declaration)
Public Shared Function GetCoincidentEnergyAnalyticalModelFaceReference ( _
    document As Document, _
    referenceToFace As Reference _
) As Reference
Visual C++
public:
static Reference^ GetCoincidentEnergyAnalyticalModelFaceReference(
    Document^ document,
    Reference^ referenceToFace
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
referenceToFace
Type: Autodesk.Revit.DB..::.Reference
A Reference to a Face of a MassEnergyAnalyticalModel.

Return Value

Returns a Reference to a Face from the same or a different MassEnergyAnalyticalModel that is coincident with the input Face.

Remarks

The result is always a Reference to a Face. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The Reference is not a Face of a MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace