Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessOrEqualRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also
Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic (Declaration)
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::.Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::.Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values greater than the user-supplied value but within epsilon are considered equal; therefore, such values satisfy the condition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload