Revit 2011 API
ArgumentException Class
Members See Also
The exception that is thrown when one of the arguments provided to a method is not valid.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ArgumentException : ApplicationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ArgumentException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class ArgumentException : public ApplicationException

Remarks

This is the base class for exceptions that are thrown while validating the arguments to a function.

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.ArgumentException
Autodesk.Revit.Exceptions..::.ArgumentNullException
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException
Autodesk.Revit.Exceptions..::.FileArgumentNotFoundException
Autodesk.Revit.Exceptions..::.InvalidPathArgumentException

See Also

ArgumentException Members
Autodesk.Revit.Exceptions Namespace