Revit 2011 API
SubTransaction Constructor
SubTransaction Class See Also
Instantiates a sub-transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public SubTransaction(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
SubTransaction(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which this sub-transaction is going to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SubTransaction Class