Revit 2011 API
Space Properties
Space Class See Also

The Space type exposes the following members.

Properties

Name | Description
ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
ActualLightingLoad | Get the Actual Lighting Load of the Space.
ActualOtherLoad | Get or set the Actual Other Load of the Space.
ActualPowerLoad | Get the Actual Power Load of the Space.
ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Area | The area. (Inherited from Enclosure.)
AreaperPerson | Get the Area per Person of the Space.
AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
BaseOffset | Get or Set the Base Offset of the Space.
Boundary | Returns the boundary of the Space.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
ClosedShell | Return the closedShell of the space.
ConditionType | Get or set the Condition type of the Space.
DesignCoolingLoad | Get the Design Cooling Load of the Space.
DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
DesignHeatingLoad | Get the Design Heating Load of the Space.
DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
DesignLightingLoad | Get or set the Design Lighting Load of the Space.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
DesignPowerLoad | Get or set the Design Power Load of the Space.
DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorReflectance | Get or set the Floor Reflectance of the Space.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
LimitOffset | Get or Set the Limit Offset of the Space.
Location | The location of the element. (Inherited from Enclosure.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Enclosure.)
Number | The number. (Inherited from Enclosure.)
NumberofPeople | Get the Number of People of the Space.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OccupancyUnit | Get the Occupancy Unit of the Space.
Occupiable | Reports whether this zone is Occupiable or not.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | The perimeter. (Inherited from Enclosure.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plenum | Reports whether this zone is Plenum or not.
PowerLoadUnit | Get or Set the Power Load Unit of the Space.
ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Room | Return the Room of the space.
SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
SpaceConstruction | Get the Space Construction of the Space.
SpaceType | Get or set the Space type of the Space.
UnboundedHeight | Get the Unbounded Height of the Space.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLimit | Get or Set the Upper Limit of the Space.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | Get the Volume of the Space.
WallReflectance | Get or set the Wall Reflectance of the Space.
Zone | Reports this space belong to which Zone.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace