Revit 2011 API
FailuresAccessor..::.GetTransactionName Method
FailuresAccessor Class See Also
Retrieves the name of the transaction for which failures are being processed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetTransactionName()
Visual Basic (Declaration)
Public Function GetTransactionName As String
Visual C++
public:
String^ GetTransactionName()

Return Value

The name of the transaction for which failures are being processed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class