Revit 2011 API
LightingFixture Class
Members See Also
Provides access to the Lighting Fixture in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LightingFixture : MEPModel
Visual Basic (Declaration)
Public Class LightingFixture _
    Inherits MEPModel
Visual C++
public ref class LightingFixture : public MEPModel

Remarks

The Lighting Fixture object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB.Electrical..::.LightingFixture

See Also

LightingFixture Members
Autodesk.Revit.DB.Electrical Namespace