Revit 2011 API
Element Methods
Element Class See Also

The Element type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view.
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model.
CanHaveTypeAssigned | Overloaded.
ChangeTypeId | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element.
GetChangeTypeAny | Returns ChangeType associated with any change in an element.
GetChangeTypeElementAddition | Returns ChangeType associated with element addition
GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
GetChangeTypeGeometry | summary: Returns ChangeType associated with a change in the geometry of an element
GetChangeTypeParameter | Overloaded.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element.
GetMaterialVolume | Get the volume of the given material on this element.
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type.
GetValidTypes | Overloaded.
IsHidden | Identifies if the element has been permanently hidden in the view.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
IsValidType | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Element Class