Revit 2011 API
AnalyticalModelSweptProfile Methods
AnalyticalModelSweptProfile Class See Also

The AnalyticalModelSweptProfile type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace