Revit 2011 API
Grid..::.ExtendToAllLevels Method
Grid Class See Also
Adjust the grid to cut all levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ExtendToAllLevels()
Visual Basic (Declaration)
Public Sub ExtendToAllLevels
Visual C++
public:
void ExtendToAllLevels()

Remarks

Requires that at least one plan view exists in the document. If not, this will throw a Autodesk::Revit::Exceptions::InvalidOperationException.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | There is no plan view in the document.

See Also

Grid Class