Revit 2011 API
FilterStringRule Members
FilterStringRule Class Constructors Methods Properties See Also

The FilterStringRule type exposes the following members.

Constructors

Name | Description
FilterStringRule | Constructs an instance of FilterStringRule.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | The boolean flag that determines whether or not the filter rule respects case when comparing strings.
RuleString | The user-supplied string against which strings from a Revit document will be tested.

See Also

FilterStringRule Class