Revit 2011 API
FileImportedEventArgs..::.ImportedInstance Property
FileImportedEventArgs Class See Also
The instance of the element that represents the imported object(s) after a successful import. It could be used for further manipulating of that instance.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element ImportedInstance { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImportedInstance As Element
Visual C++
public:
property Element^ ImportedInstance {
    Element^ get ();
}

Remarks

This property is nullNothingnullptra null reference (Nothing in Visual Basic) when the event is invoked due to import of GBXML and Inventor files.

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace