Revit 2011 API
IOException Class
Members See Also
The exception that is thrown when an I/O error occurs.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class IOException : ApplicationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class IOException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class IOException : public ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.IOException
Autodesk.Revit.Exceptions..::.DirectoryNotFoundException
Autodesk.Revit.Exceptions..::.FileAccessException
Autodesk.Revit.Exceptions..::.FileNotFoundException
Autodesk.Revit.Exceptions..::.InvalidDataStreamException

See Also

IOException Members
Autodesk.Revit.Exceptions Namespace