Revit 2011 API
FailureMessage..::.SetAdditionalElement Method
FailureMessage Class See Also
Sets the additional reference element for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetAdditionalElement(
    ElementId additionalElement
)
Visual Basic (Declaration)
Public Function SetAdditionalElement ( _
    additionalElement As ElementId _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetAdditionalElement(
    ElementId^ additionalElement
)

Parameters

additionalElement
Type: Autodesk.Revit.DB..::.ElementId
The additional element.

Return Value

The FailureMessage.

Remarks

Additional elements are used to highlight additional information to the user. They are not considered as causing the failure, but are related to it. User can not delete them in extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessage is already posted to a document
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class