Revit 2011 API
ApplicationException Class
Members See Also
The exception that is thrown when a non-fatal application error occurs.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ApplicationException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ApplicationException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ApplicationException : public Exception

Remarks

This class is the base class of all Revit specified exceptions.

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.ArgumentException
Autodesk.Revit.Exceptions..::.InternalException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.IOException
Autodesk.Revit.Exceptions..::.OperationCanceledException

See Also

ApplicationException Members
Autodesk.Revit.Exceptions Namespace