Revit 2011 API
ParameterFilterElement..::.Create Method (Document, String, ICollection<(Of <(ElementId>)>))
ParameterFilterElement Class See Also
Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ParameterFilterElement Create(
    Document aDocument,
    string name,
    ICollection<ElementId> categories
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    aDocument As Document, _
    name As String, _
    categories As ICollection(Of ElementId) _
) As ParameterFilterElement
Visual C++
public:
static ParameterFilterElement^ Create(
    Document^ aDocument,
    String^ name,
    ICollection<ElementId^>^ categories
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::.Document
The document in which to create the ParameterFilterElement.
name
Type: System..::.String
The user-visible name for the new ParameterFilterElement.
categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The categories for the new ParameterFilterElement.

Return Value

A pointer to the new ParameterFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for name is an empty string -or- The given value for name is already in use as a filter element name -or- One of the given categories is not filterable
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
Create Overload