Revit 2011 API
UpdaterRegistry..::.UnregisterUpdater Method
UpdaterRegistry Class See Also
Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void UnregisterUpdater(
    UpdaterId id
)
Visual Basic (Declaration)
Public Shared Sub UnregisterUpdater ( _
    id As UpdaterId _
)
Visual C++
public:
static void UnregisterUpdater(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id of updater to be removed

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Updater has not been registered -or- updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class