Revit 2011 API
View..::.ProjLineWeightOverrideByElement Property
View Class See Also
Override the projection lines' weight by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int ProjLineWeightOverrideByElement[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic (Declaration)
Public Property ProjLineWeightOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As Integer
Visual C++
public:
property int ProjLineWeightOverrideByElement[ICollection<ElementId^>^ ids] {
    int get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, int value);
}

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. A negative value indicates that no override should be applied.

See Also

View Class