Revit 2011 API
MassEnergyAnalyticalModel Methods
MassEnergyAnalyticalModel Class See Also

The MassEnergyAnalyticalModel type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCoincidentEnergyAnalyticalModelFaceReference |
GetCoincidentMassZoneFaceReferences |
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetJoinedMassEnergyAnalyticalModelElementIds | The ElementIds of other MassEnergyAnalyticalModels that are "joined" to this one.
GetMassEnergyAnalyticalModelIdForMassInstance | Get the ElementId of the MassEnergyAnalyticalModel for a mass instance.
GetMassSurfaceDataIdForReference | Get the ElementId of the MassSurfaceData corresponding to the Reference.
GetMassZoneIds | Get the MassZone ElementIds that are created from this MassEnergyAnalyticalModel.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetReferencesToAllFaces | Get References to all Faces which are meaningful for the MassEnergyAnalyticalModel. Array of References to Faces of the MassEnergyAnalyticalModel.
GetReferencesToAllShadingFaces | Get References to all Faces of the MassEnergyAnalyticalModel which are of Mass Shade subcategory.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidSurfaceCategoryIdsForReference | The Mass surface subcategory ids that are appropriate values for the input Reference.
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace