Revit 2011 API
SunAndShadowSettings..::.GetActiveSunAndShadowSettings Method
SunAndShadowSettings Class See Also
Returns the currently SunAndShadowSettings element assigned to the active view for the supplied document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static Element GetActiveSunAndShadowSettings(
    Document aDocument
)
Visual Basic (Declaration)
Public Shared Function GetActiveSunAndShadowSettings ( _
    aDocument As Document _
) As Element
Visual C++
public:
static Element^ GetActiveSunAndShadowSettings(
    Document^ aDocument
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::.Document
The document.

Return Value

The active SunAndShadowSettings element for the supplied document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SunAndShadowSettings Class