Revit 2011 API
PointOnEdgeEdgeIntersection..::.SetEdgeReference2 Method
PointOnEdgeEdgeIntersection Class See Also
Change the second edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetEdgeReference2(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Sub SetEdgeReference2 ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference2(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.

See Also

PointOnEdgeEdgeIntersection Class