Revit 2011 API
Category..::.SetLineWeight Method
Category Class See Also
Sets the line weight for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Sub SetLineWeight ( _
    lineWeight As Integer, _
    graphicsStyleType As GraphicsStyleType _
)
Visual C++
public:
void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)

Parameters

lineWeight
Type: System..::.Int32
graphicsStyleType
Type: Autodesk.Revit.DB..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"lineWeigh" or "graphicsStyleType"-is out of range.

See Also

Category Class