Revit 2011 API
Transform Methods
Transform Class See Also

The Transform type exposes the following members.

Methods

Name | Description
AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Multiply | Multiplies this transformation by the specified transformation and returns the result.
OfPoint | Applies the transformation to the point and returns the result.
OfVector | Applies the transform to the vector
ScaleBasis | Scales the basis vectors of this transformation and returns the result.
ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

See Also

Transform Class