Revit 2011 API
AnnotationSymbol Properties
AnnotationSymbol Class See Also

The AnnotationSymbol type exposes the following members.

Properties

Name | Description
AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
CanRotate | Property to test whether the family instance can be rotated by 180 degree. (Inherited from FamilyInstance.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Leaders | Get all the leaders of this annotation symbol.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
SubComponents | Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AnnotationSymbol Class