Revit 2011 API
UIApplication Properties
UIApplication Class See Also

The UIApplication type exposes the following members.

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ActiveUIDocument | Provides access to an object that represents the currently active project.
Application | Returns the database level Application represented by this UI level Application.
DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
LoadedApplications | Returns an array of successfully loaded external applications.
MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace