Revit 2011 API
Mullion Methods
Mullion Class See Also

The Mullion type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
FlipFromToRoom | Change the room to which the door or window is opened. (Inherited from FamilyInstance.)
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCopings | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
SetCopings | Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Mullion Class