Revit 2011 API
AnalyticalModel..::.ResetManualAdjustment Method
AnalyticalModel Class See Also
Resets all manual adjustments performed by the user onto the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ResetManualAdjustment()
Visual Basic (Declaration)
Public Function ResetManualAdjustment As Boolean
Visual C++
public:
bool ResetManualAdjustment()

Return Value

Indicates the successful reset of all manual adjustment. True if reset succeeds, false otherwise.

Remarks

This resets all manual adjustment. Therefore, if Analytical Offset is applicable, that will reset as well. Success, in this context, is achieved only when the Source resets itself to its original position.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace