Revit 2011 API
GeometryObjectArray..::.Insert Method
GeometryObjectArray Class See Also
Insert the specified geometry object into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    GeometryObject item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As GeometryObject, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    GeometryObject^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.GeometryObject
The geometry object to be inserted into the array.
index
Type: System..::.Int32
The geometry object will be inserted before this index.

Return Value

Returns whether the geometry object was inserted into the array.

See Also

GeometryObjectArray Class