Revit 2011 API
SpaceTag Properties
SpaceTag Class See Also

The SpaceTag type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasLeader | Identifies if a leader is displayed for the tag. (Inherited from EnclosureTag.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the tag. (Inherited from EnclosureTag.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the tag. (Inherited from EnclosureTag.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | The space that the tag is associated with.
SpaceTagType | The tag type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view in which the tag was placed. (Inherited from EnclosureTag.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace