Revit 2011 API
Dimension..::.Label Property
Dimension Class See Also
The family parameter label of the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter Label { get; set; }
Visual Basic (Declaration)
Public Property Label As FamilyParameter
Visual C++
public:
property FamilyParameter^ Label {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}

Remarks

A dimension only can be labeled in a family document. Multi-segmented linear dimensions cannot be labeled. To unbind the family parameter, set this property to nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the family parameter's ParameterType is not suitable for this dimension.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when dimension can not be labeled.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failed to get the BuiltInParameter DIM_LABEL.

See Also

Dimension Class