Revit 2011 API
MassInstanceUtils..::.GetMassLevelIds Method
MassInstanceUtils Class See Also
Get the ElementIds of the Levels associated with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static IList<ElementId> GetMassLevelIds(
    Document document,
    ElementId massInstanceId
)
Visual Basic (Declaration)
Public Shared Function GetMassLevelIds ( _
    document As Document, _
    massInstanceId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetMassLevelIds(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.

Return Value

The ElementIds of the Levels

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class