Revit 2011 API
ItemFactoryBase Methods
ItemFactoryBase Class See Also

The ItemFactoryBase type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document.
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed.
NewDetailCurve | Creates a new detail curve element.
NewDetailCurveArray | Creates an array of new detail curve elements.
NewDimension | Overloaded. Creates a new linear dimension object.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document.
NewGroup | Creates a new type of group.
NewLevel | Creates a new level.
NewModelCurve | Creates a new model line element.
NewModelCurveArray | Creates an array of new model line elements.
NewReferencePlane | Creates a new instance of ReferencePlane.
NewReferencePlane2 | Creates a new instance of ReferencePlane.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data.
NewView3D | Creates a new 3D view.
NewViewPlan | Creates a plan view based on the specified level.
NewViewSection | Creates a new section view.
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace