Revit 2011 API
Profile Properties
Profile Class See Also

The Profile type exposes the following members.

Properties

Name | Description
Curves | Retrieve the curves that make up the boundary of the profile.
Filled | Get or set whether the profile is filled.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Transformed | Transforms this profile and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Profile Class