Revit 2011 API
ElectricalSystem Class
Members See Also
Provides access to the Electrical System in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElectricalSystem : MEPSystem
Visual Basic (Declaration)
Public Class ElectricalSystem _
    Inherits MEPSystem
Visual C++
public ref class ElectricalSystem : public MEPSystem

Remarks

The Electrical System object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.MEPSystem
Autodesk.Revit.DB.Electrical..::.ElectricalSystem

See Also

ElectricalSystem Members
Autodesk.Revit.DB.Electrical Namespace