Revit 2011 API
Color Members
Color Class Constructors Methods Properties See Also

The Color type exposes the following members.

Constructors

Name | Description
Color | Constructor that takes the red, green and blue channels of the color.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Blue | Get or set the blue channel of the color.
Green | Get or set the green channel of the color.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Red | Get or set the red channel of the color.

See Also

Color Class