Revit 2011 API
APIObject..::.IsReadOnly Property
APIObject Class Example See Also
Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

If true, the object may not be modified. If false, the object's contents may be modified.

Examples

CopyC#
Document project = uiApplication.ActiveUIDocument.Document;
Settings settings = project.Settings;
TaskDialog.Show("Revit","Categories: " + settings.Categories.IsReadOnly.ToString());
TaskDialog.Show("Revit","Materials: " + settings.Materials.IsReadOnly.ToString());
CopyVB.NET
Dim project As Document = uiApplication.ActiveUIDocument.Document
Dim settings As Settings = project.Settings
TaskDialog.Show("Revit", "Categories: " + settings.Categories.IsReadOnly.ToString())
TaskDialog.Show("Revit", "Materials: " + settings.Materials.IsReadOnly.ToString())

See Also

APIObject Class