Revit 2011 API
FailuresAccessor..::.GetFailureHandlingOptions Method
FailuresAccessor Class See Also
Provides access to the failure handling options for the transaction currently being finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions GetFailureHandlingOptions()
Visual Basic (Declaration)
Public Function GetFailureHandlingOptions As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ GetFailureHandlingOptions()

Return Value

The failure handling options for transaction currently being finished.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class