Revit 2011 API
ImageExportOptions Properties
ImageExportOptions Class See Also

The ImageExportOptions type exposes the following members.

Properties

Name | Description
ExportRange | The export range, which defines which view(s) will be exported.
FilePath | The file name and path for the exported file.
FitDirection | The fit direction. Used only if ZoomType is FitToPage.
HLRandWFViewsFileType | File type for exported HLR and wireframe views.
ImageResolution | The image resolution in dots per inch.
PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
ShadowViewsFileType | The file type for exported shadow views.
ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
ViewName | The name of the view to be created.
Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
ZoomType | The zoom type, which defines how the image size is determined.

See Also

ImageExportOptions Class