Revit 2011 API
FileImportedEventArgs Properties
FileImportedEventArgs Class See Also

The FileImportedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Format | Identifies the import format, e.g. DWG or image.
ImportedInstance | The instance of the element that represents the imported object(s) after a successful import. It could be used for further manipulating of that instance.
Path | Path of the source file that was imported.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace