Revit 2011 API
RoomTagFilter Class
Members See Also
A filter used to match room tags.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoomTagFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class RoomTagFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class RoomTagFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Architecture..::.RoomTagFilter

See Also

RoomTagFilter Members
Autodesk.Revit.DB.Architecture Namespace