Revit 2011 API
RebarShapeDefinitionBySegments Methods
RebarShapeDefinitionBySegments Class See Also

The RebarShapeDefinitionBySegments type exposes the following members.

Methods

Name | Description
AddBendDefaultRadius | Specify a default-radius bend.
AddBendVariableRadius | Specify a variable-radius bend.
AddConstraintParallelToSegment | Constrain the length of a segment by parameterizing its length.
AddConstraintToSegment | Add a constraint that helps determine the length of a segment.
AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveParameterFromSegment | Remove constraints from a segment.
SetSegmentAs180DegreeBend | Overloaded. Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend.
SetSegmentFixedDirection | Fix the direction of a segment.
SetSegmentVariableDirection | Remove the fixed direction from a segment.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace