Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ClosedProfileRoof Property
BuiltInFailures..::.SketchFailures Class See Also
Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ClosedProfileRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ClosedProfileRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ClosedProfileRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class