Revit 2011 API
SunStudyTimeInterval Enumeration
See Also
Time interval enum for a single or multi-day sun study.
Enum of sun study time interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum SunStudyTimeInterval
Visual Basic (Declaration)
Public Enumeration SunStudyTimeInterval
Visual C++
public enum class SunStudyTimeInterval

Members

Member name | Description
Minutes15 | Interval occurs every 15 minutes.
Minutes30 | Interval occurs every 30 minutes.
Minutes45 | Interval occurs every 45 minutes.
Hour | Interval occurs every hour.
Day | Interval occurs every day.
Week | Interval occurs once a week.
Month | Interval occurs once a month.

See Also