Revit 2011 API
LinkElementId Constructor (ElementId, ElementId)
LinkElementId Class See Also
Creates a new LinkElementId representing an element in a linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public LinkElementId(
    ElementId linkInstanceId,
    ElementId elementId
)
Visual Basic (Declaration)
Public Sub New ( _
    linkInstanceId As ElementId, _
    elementId As ElementId _
)
Visual C++
public:
LinkElementId(
    ElementId^ linkInstanceId,
    ElementId^ elementId
)

Parameters

linkInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The id of the linked model element in the host document.
elementId
Type: Autodesk.Revit.DB..::.ElementId
The id of the element in the linked model document.

See Also

LinkElementId Class
LinkElementId Overload