Revit 2011 API
TaskDialog..::.ExpandedContent Property
TaskDialog Class See Also
ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string ExpandedContent { get; set; }
Visual Basic (Declaration)
Public Property ExpandedContent As String
Visual C++
public:
property String^ ExpandedContent {
    String^ get ();
    void set (String^ value);
}

Remarks

If added to a dialog, a Show/Hide toggle button displays at the bottom of the task dialog. The Expanded Content is hidden by default. This area is used when even more information needs to be relayed to the user than space allows. It is rarely used, but can be used for showing technical information passed through in a variable, for example back-end error information, lists of files, etc. Variable information should always be introduced with a lead-in sentence.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace