Revit 2011 API
EnergyDataSettings..::.IsExportShadingSurfacesEnabled Property
EnergyDataSettings Class See Also
Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsExportShadingSurfacesEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExportShadingSurfacesEnabled As Boolean
Visual C++
public:
property bool IsExportShadingSurfacesEnabled {
    bool get ();
}

Remarks

Result is based on the ExportComplexity setting. The method described by gbs/gbxml.org to calculate the shading surfaces is to take all surfaces from the MEP spaces, subtract them from the surfaces from all building elements, and then the remaining surfaces are considered to be the shading surfaces.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace