Revit 2011 API
AnalyticalSupportChecking..::.CheckMemberSupports Method
AnalyticalSupportChecking Class See Also
Check if the document contains unsupported Structural Elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool CheckMemberSupports(
    Document document,
    string progressIndicatorText
)
Visual Basic (Declaration)
Public Shared Function CheckMemberSupports ( _
    document As Document, _
    progressIndicatorText As String _
) As Boolean
Visual C++
public:
static bool CheckMemberSupports(
    Document^ document,
    String^ progressIndicatorText
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
Document in which to perform Analytical Support Check.
progressIndicatorText
Type: System..::.String
Text to display on progress indicator.

Return Value

True if the support check succeeded, false otherwise.

Remarks

Existence of unsupported Elements will not affect the return value. Reporting of unsupported Structural Elements will be done via Warnings. This should be run from within a transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalSupportChecking Class
Autodesk.Revit.DB.Structure Namespace