Revit 2011 API
PanelScheduleView..::.GenerateInstanceFromTemplate Method
PanelScheduleView Class See Also
actually assigns the data from the template to the instance also performs any tasks specific to the instance (3rd phase, borders, etc)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void GenerateInstanceFromTemplate(
    ElementId templateId
)
Visual Basic (Declaration)
Public Sub GenerateInstanceFromTemplate ( _
    templateId As ElementId _
)
Visual C++
public:
void GenerateInstanceFromTemplate(
    ElementId^ templateId
)

Parameters

templateId
Type: Autodesk.Revit.DB..::.ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace