Revit 2011 API
IFCExportOptions Members
IFCExportOptions Class Constructors Methods Properties See Also

The IFCExportOptions type exposes the following members.

Constructors

Name | Description
IFCExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentViewOnly | Option to export only the parts of a model that are visible in the current view.
ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
FamilyMappingFile | Path to a file containing family mapping.
FileVersion | IFC file version.
WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.

See Also

IFCExportOptions Class