Revit 2011 API
ConceptualConstructionType..::.IsValidSurfaceSubcategoryForConstruction Method
ConceptualConstructionType Class See Also
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsValidSurfaceSubcategoryForConstruction(
    ElementId massSurfaceSubcategoryId
)
Visual Basic (Declaration)
Public Function IsValidSurfaceSubcategoryForConstruction ( _
    massSurfaceSubcategoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidSurfaceSubcategoryForConstruction(
    ElementId^ massSurfaceSubcategoryId
)

Parameters

massSurfaceSubcategoryId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of a Mass subcategory of a MassSurfaceData.

Return Value

Returns true if appropriate for the input subcategory, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input Element massSurfaceSubcategoryId is not a valid subcategory value for MassSurfaceData.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace