Revit 2011 API
BaseArray..::.Label Property
BaseArray Class See Also
The family parameter label of the BaseArray.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter Label { get; set; }
Visual Basic (Declaration)
Public Property Label As FamilyParameter
Visual C++
public:
property FamilyParameter^ Label {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}

Remarks

The label associates the number of members of the array with a family parameter. A BaseArray only can be labeled in a family document and only can be labeled to a integer FamilyParameter. To unbind the family parameter, set this property to nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the family parameter's ParameterType is not ParameterType.Integer.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when trying to label the BaseArray out of family document.

See Also

BaseArray Class