Revit 2011 API
ConceptualConstructionType..::.GetFloorOrSlabConstructionType Method
ConceptualConstructionType Class See Also
Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetFloorOrSlabConstructionType(
    Document ccda,
    ConceptualConstructionFloorSlabType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetFloorOrSlabConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionFloorSlabType _
) As ElementId
Visual C++
public:
static ElementId^ GetFloorOrSlabConstructionType(
    Document^ ccda,
    ConceptualConstructionFloorSlabType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionFloorSlabType
The ConceptualConstructionFloorSlabType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionFloorSlabType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace