Revit 2011 API
TableSectionData Methods
TableSectionData Class See Also

The TableSectionData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCellCalculatedValue | Overloaded.
GetCellCategoryId | Overloaded.
GetCellCombinedParameters | Overloaded.
GetCellParamId | Overloaded.
GetCellText | Returns a cell's text depending on its type
GetCellType | Overloaded.
GetColumnWidth | Returns a column's width
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMergedCell | Gets the whole merged cell that this cell is a part of.
GetRowHeight | Returns a row's height
GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
GetType | Gets the Type of the current instance. (Inherited from Object.)
MergeCells | Merges cells for the given area.
SetCellCalculatedValue | Overloaded.
SetCellCombinedParameters | Overloaded.
SetCellParamIdAndCategoryId | Overloaded.
SetCellStyle | Overloaded.
SetCellText | Sets a cell's style
SetCellType | Overloaded.
SetColumnWidth | Sets a column's width
SetMergedCell | Sets the merged cell that this cell is a part of.
SetRowHeight | Sets a row's height
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableSectionData Class