Revit 2011 API
Application..::.NewTypeBinding Method
Application Class See Also
Creates a new empty type binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TypeBinding NewTypeBinding()
Visual Basic (Declaration)
Public Function NewTypeBinding As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding()

Return Value

A new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace