Revit 2011 API
CableTrayConduitBase Class
Members See Also
The CableTrayConduitBase class is implemented as the base class for cable tray or conduit

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CableTrayConduitBase : MEPCurve
Visual Basic (Declaration)
Public Class CableTrayConduitBase _
    Inherits MEPCurve
Visual C++
public ref class CableTrayConduitBase : public MEPCurve

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Electrical..::.CableTrayConduitBase
Autodesk.Revit.DB.Electrical..::.CableTray
Autodesk.Revit.DB.Electrical..::.Conduit

See Also

CableTrayConduitBase Members
Autodesk.Revit.DB.Electrical Namespace