Revit 2011 API
ElementIsElementTypeFilter Class
Members See Also
A filter used to match elements which are ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementIsElementTypeFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class ElementIsElementTypeFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementIsElementTypeFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ElementIsElementTypeFilter

See Also

ElementIsElementTypeFilter Members