Revit 2011 API
XYZ..::.Multiply Method
XYZ Class See Also
Multiplies this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Multiply(
    double value
)
Visual Basic (Declaration)
Public Function Multiply ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Multiply(
    double value
)

Parameters

value
Type: System..::.Double
The value to multiply with this vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.

See Also

XYZ Class