Revit 2011 API
Connector..::.Demand Property
Connector Class See Also
The demand of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Demand { get; }
Visual Basic (Declaration)
Public ReadOnly Property Demand As Double
Visual C++
public:
property double Demand {
    double get ();
}

Remarks

Instantaneous demand at this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get demand.

See Also

Connector Class