Revit 2011 API
MassZone Properties
MassZone Class See Also

The MassZone type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConditionType | The gbXMLConditionType of the MassZone.
CutByLowerLevel | Indicates the relationship between the MassZone and its lower level.
CutByUpperLevel | Indicates the relationship between the MassZone and its upper level.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorArea | The floor area of the MassZone.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsZoneOccupiable | A MassZone must have a level as its bottom to be occupiable; If it does not, it is still a MassZone, but it is not occupiable
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
LowerLevelId | The bottom level defining the MassZone.
MassEnergyAnalyticalModelId | The ElementId of the MassEnergyAnalyticalModel that the MassZone is derived from.
MaterialId | The visualization material for the MassZone. Will be InvalidElementId if material is by category or the material type is by MassZoneMaterialTypeMaterialBySurfaceType.
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Indicates how the material of MassZone faces is determined.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpaceType | The gbXMLSpaceType of the MassZone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLevelId | The upper level defining the MassZone.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | The volume of the MassZone.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace