Revit 2011 API
Profile Members
Profile Class Methods Properties See Also

The Profile type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this profile.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curves | Retrieve the curves that make up the boundary of the profile.
Filled | Get or set whether the profile is filled.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Transformed | Transforms this profile and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Profile Class