Revit 2011 API
Curve Members
Curve Class Methods Properties See Also

The Curve type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve.
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values.
MakeUnbound | Makes this curve unbound.
Project | Projects the specified point on this curve.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve.
EndParameter | The parameter of the start or the end point of the curve.
EndPoint | The start or the end point of this curve.
EndPointReference | Returns a stable reference to the start point or the end point of the curve.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
IsCyclic | The boolean value that indicates whether this curve is cyclic.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve.
Period | The period of this curve.
Reference | Returns a stable reference to the curve.
Transformed | Applies the specified transformation to this curve and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Curve Class