Revit 2011 API
Face Methods
Face Class See Also

The Face type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
ComputeNormal | Returns the normal vector for the face at the given point.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face.
GetBoundingBox | Returns the UV bounding box of the face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face.

See Also

Face Class