Revit 2011 API
FamilyParameter Members
FamilyParameter Class Methods Properties See Also

The FamilyParameter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
CanAssignFormula | Indicates if this parameter can be assigned a formula.
Definition | The definition.
DisplayUnitType | The display unit type.
Formula | The formula.
Id | The id of the family parameter.
IsDeterminedByFormula | Indicates if the parameter is determined by formula.
IsInstance | Indicates if the parameter is instance or type.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReporting | Indicates if the parameter is a reporting parameter.
StorageType | The storage type describes the type that is used internally within the parameter to store its value.

See Also

FamilyParameter Class