Revit 2011 API
DetailNurbSpline Class
Members See Also
Represents a DetailNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DetailNurbSpline : DetailCurve
Visual Basic (Declaration)
Public Class DetailNurbSpline _
    Inherits DetailCurve
Visual C++
public ref class DetailNurbSpline : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.DetailCurve
Autodesk.Revit.DB..::.DetailNurbSpline

See Also

DetailNurbSpline Members