Revit 2011 API
DesignOption Class
Members See Also
An element that represents a design alternative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DesignOption : Element
Visual Basic (Declaration)
Public Class DesignOption _
    Inherits Element
Visual C++
public ref class DesignOption : public Element

Remarks

Design options enable the user to add alternative designs within the same project. Each element can either be in a design option or not at all, in which case it is considered to be part of the main model and have no design alternatives.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.DesignOption

See Also

DesignOption Members