Revit 2011 API
InternalDefinitions Methods
InternalDefinitions Class See Also

The InternalDefinitions type exposes the following members.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InternalDefinitions Class