Revit 2011 API
AnalyticalCurveType Enumeration
See Also
Identifies what type of Analytical Model curves should be extracted.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalCurveType
Visual Basic (Declaration)
Public Enumeration AnalyticalCurveType
Visual C++
public enum class AnalyticalCurveType

Members

Member name | Description
RawCurves | Base Analytical Model curves generated.
RigidLinkHead | Rigid Link at end 0 (head) of the Beam.
RigidLinkTail | Rigid Link at end 1 (tail) of the Beam.
ActiveCurves | Curves displayed on screen (not including Rigid Links).
ApproximatedCurves | Curves approximated using linear segments.
AllRigidLinks | All Rigid Link curves. Rigid Link at end 0 (head) will be in the first entry. Rigid Link at end 1 (tail) will be in the last entry.

See Also

Autodesk.Revit.DB.Structure Namespace