Revit 2011 API
ExtrusionRoof Class
Members See Also
Represents some kinds of Extrusion Roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ExtrusionRoof : RoofBase
Visual Basic (Declaration)
Public Class ExtrusionRoof _
    Inherits RoofBase
Visual C++
public ref class ExtrusionRoof : public RoofBase

Remarks

The ExtrusionRoof object represents some kinds of extruded roofs in Revit.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.RoofBase
Autodesk.Revit.DB..::.ExtrusionRoof

See Also

ExtrusionRoof Members