Revit 2011 API
TextBox Members
TextBox Class Methods Properties Events See Also

The TextBox type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the TextBox.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
PromptText | The prompt text for the text box.
SelectTextOnFocus | A value that indicates if the text is selected when the text box gains focus.
ShowImageAsButton | Gets or sets a value that indicates if the Image set in the text box should be displayed as a clickable button.
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Value | The object that supplies the text value.
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)
Width | Gets or sets the width of the TextBox.

Events

Name | Description
EnterPressed | Subscribe to this event to be notified when the Enter button is pressed in the text box.

See Also

TextBox Class
Autodesk.Revit.UI Namespace