Revit 2011 API
UIControlledApplication Class
Members See Also
Represents the Autodesk Revit user interface, providing access to UI customization methods and events.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class UIControlledApplication
Visual Basic (Declaration)
Public Class UIControlledApplication
Visual C++
public ref class UIControlledApplication

Remarks

This class does not provide access to documents because it is provided to you through the ExternalApplication OnStartup()/OnShutdown() methods, and those methods are when it is not possible to work with Revit documents. You can work with documents by getting them from the UIApplication class; that class is obtained from events and ExternalCommand callbacks.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.UIControlledApplication

See Also

UIControlledApplication Members
Autodesk.Revit.UI Namespace