Revit 2011 API
StructuralMaterialTypeFilter Constructor (StructuralMaterialType)
StructuralMaterialTypeFilter Class See Also
Constructs a new instance of a filter to match family instances that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType _
)
Visual C++
public:
StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::.StructuralMaterialType
The structural material type to match.

See Also

StructuralMaterialTypeFilter Class
StructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace