Revit 2011 API
StructuralMaterialTypeFilter Class
Members See Also
A filter used to match family instances that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class StructuralMaterialTypeFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class StructuralMaterialTypeFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class StructuralMaterialTypeFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Structure..::.StructuralMaterialTypeFilter

See Also

StructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace