Revit 2011 API
CableTrayConduitBase Properties
CableTrayConduitBase Class See Also

The CableTrayConduitBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
RunId | The id of the run to which this element belongs.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace