Revit 2011 API
PushButton Properties
PushButton Class See Also

The PushButton type exposes the following members.

Properties

Name | Description
AssemblyName | The assembly path of the button.
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
ClassName | The name of the class containing the implementation for the command.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

PushButton Class
Autodesk.Revit.UI Namespace