Revit 2011 API
Connector..::.Height Property
Connector Class See Also
The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Height { get; set; }
Visual Basic (Declaration)
Public Overridable Property Height As Double
Visual C++
public:
virtual property double Height {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Height

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to set height.

See Also

Connector Class