Revit 2011 API
FailureDefinition..::.GetDefaultResolutionType Method
FailureDefinition Class See Also
Retrieves the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureResolutionType GetDefaultResolutionType()
Visual Basic (Declaration)
Public Function GetDefaultResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetDefaultResolutionType()

Return Value

The Default resolution type for the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | FailureDefinition does not have any resolutions.

See Also

FailureDefinition Class