Revit 2011 API
Curve..::.ComputeNormalizedParameter Method
Curve Class See Also
Computes the normalized curve parameter from the raw parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ComputeNormalizedParameter(
    double rawParameter
)
Visual Basic (Declaration)
Public Function ComputeNormalizedParameter ( _
    rawParameter As Double _
) As Double
Visual C++
public:
double ComputeNormalizedParameter(
    double rawParameter
)

Parameters

rawParameter
Type: System..::.Double
The raw parameter.

Return Value

The real number equal to the normalized curve parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when rawParameter is infinite.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class