Revit 2011 API
Element..::.ObjectType Property
Element Class See Also
Returns the instance type of this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use Element.GetTypeId() and Element.ChangeTypeId() instead.")]
public ElementType ObjectType { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use Element.GetTypeId() and Element.ChangeTypeId() instead.")> _
Public Property ObjectType As ElementType
Visual C++
[ObsoleteAttribute(L"Use Element.GetTypeId() and Element.ChangeTypeId() instead.")]
public:
property ElementType^ ObjectType {
    ElementType^ get ();
    void set (ElementType^ value);
}

Remarks

The type of the object returned by this method depends upon the type of this instance, for example - if this object is a wall then a wall type object will be returned. Not all objects have an instance type in which case nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

See Also

Element Class