Revit 2011 API
FailuresAccessor..::.GetDocument Method
FailuresAccessor Class See Also
Provides access to a document for which failures are being processed or preprocessed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Document GetDocument()
Visual Basic (Declaration)
Public Function GetDocument As Document
Visual C++
public:
Document^ GetDocument()

Return Value

The document for which failures preprocessing or processing is being performed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class