Revit 2011 API
RibbonItemData Class
Members See Also
Base class used to contain information necessary to construct a RibbonItem in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class RibbonItemData
Visual Basic (Declaration)
Public Class RibbonItemData
Visual C++
public ref class RibbonItemData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ButtonData
Autodesk.Revit.UI..::.ComboBoxData
Autodesk.Revit.UI..::.ComboBoxMemberData
Autodesk.Revit.UI..::.RadioButtonGroupData
Autodesk.Revit.UI..::.TextBoxData

See Also

RibbonItemData Members
Autodesk.Revit.UI Namespace