Revit 2011 API
Form Class
Members See Also
An object that represents a Form within the Autodesk Revit Massing Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Form : GenericForm
Visual Basic (Declaration)
Public Class Form _
    Inherits GenericForm
Visual C++
public ref class Form : public GenericForm

Remarks

For any reference returned from a Form method, its GeometryObject will become invalid after a form modification method, e.g. MoveSubElement. Call the method on the Form object to retrieve the new reference if it is needed after the modification.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.GenericForm
Autodesk.Revit.DB..::.Form

See Also

Form Members