Revit 2011 API
Document..::.Create Property
Document Class See Also
An object that can be used to create new instances of Autodesk Revit API elements within a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Create { get; }
Visual Basic (Declaration)
Public ReadOnly Property Create As Document
Visual C++
public:
property Document^ Create {
    Document^ get ();
}

Field Value

This object is used to create new instances of project elements within the Autodesk Revit API, such as FamilyInstances or groups.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current document is family document.

See Also

Document Class