Revit 2011 API
Connector..::.AssignedFlow Property
Connector Class See Also
The assigned flow of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AssignedFlow { get; set; }
Visual Basic (Declaration)
Public Property AssignedFlow As Double
Visual C++
public:
property double AssignedFlow {
    double get ();
    void set (double value);
}

Remarks

Assigned flow may be assigned for connectors of some family instances, for more information, refer to PipeConnector, DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping or DomainHvac. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get or set assigned flow.

See Also

Connector Class