Revit 2011 API
Connector..::.Angle Property
Connector Class See Also
The angle of the Connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

Angle may be assigned for connectors of some family instances, for more information, refer to PipeConnector or DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition. For a connector obtained from a non-family instance (for example not a fitting, but instead a pipe, duct, or cable tray), the value will always be zero. Non-zero angles are only valid for family instance fitting connectors.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac, DomainPiping, or DomainCableTrayConduit. Thrown when set value for the connector not in family instance.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to set angle.

See Also

Connector Class