Revit 2011 API
Options Properties
Options Class See Also

The Options type exposes the following members.

Properties

Name | Description
ComputeReferences | Determines whether or not references to geometric objects are computed.
DetailLevel | The detail level for the geometry extracted with these options.
IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | The view used for geometry extraction.

See Also

Options Class