Revit 2011 API
FailureDefinitionRegistry Class
Members See Also
The global registry for all FailureDefinitions in the Revit session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinitionRegistry : IDisposable
Visual Basic (Declaration)
Public Class FailureDefinitionRegistry _
    Implements IDisposable
Visual C++
public ref class FailureDefinitionRegistry : IDisposable

Remarks

When a FailureDefinition is created, it will be registered in this registry automatically. Registration is allowed only during Revit Application startup - after that FailureDefinitionRegistry is locked and creation of new FailureDefinitions is not allowed. There is only one instance of FailureDefinitionRegistry in session. GetFailureDefinitionRegistry()()()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureDefinitionRegistry

See Also

FailureDefinitionRegistry Members