Revit 2011 API
ElementOwnerViewFilter Constructor (ElementId)
ElementOwnerViewFilter Class See Also
Constructs a new instance of a filter to match elements which are owned by a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementOwnerViewFilter(
    ElementId viewId
)
Visual Basic (Declaration)
Public Sub New ( _
    viewId As ElementId _
)
Visual C++
public:
ElementOwnerViewFilter(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::.ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Overload