Revit 2011 API
RebarShapeBendAngle Enumeration
See Also
A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum RebarShapeBendAngle
Visual Basic (Declaration)
Public Enumeration RebarShapeBendAngle
Visual C++
public enum class RebarShapeBendAngle

Members

Member name | Description
Acute | The angle is less than 90 degrees.
Right | The angle is 90 degrees.
Obtuse | The angle is between 90 and 180 degrees.
Reversal | The angle is 180 degrees; the bar bends back on itself.

See Also

Autodesk.Revit.DB.Structure Namespace