Revit 2011 API
AnalysisDisplayStyle Methods
AnalysisDisplayStyle Class See Also

The AnalysisDisplayStyle type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
CreateAnalysisDisplayStyle | Overloaded.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FindByName | Finds analysis display style by name.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetColoredSurfaceSettings | Get colored surface settings object from the style.
GetColorSettings | Get color settings object from the style.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetElements | Returns set of all analysis display styles elements in the given document.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLegendSettings | Get legend settings object from the style.
GetMarkersAndTextSettings | Get markers and text settings object from the style.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsNameUnique | Verify the uniqueness of the name among all analysis display style elements of the document.
IsTextTypeIdValid | Verify if text type id is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetColoredSurfaceSettings | Set colored surface settings object for the style.
SetColorSettings | Set color settings object for the style.
SetLegendSettings | Set legend settings object for the style.
SetMarkersAndTextSettings | Set markers and text settings object for the style.
SetName | Set name of analysis display style element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace