Revit 2011 API
FootPrintRoof Class
Members See Also
Represents kinds of FootPrintRoofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FootPrintRoof : RoofBase
Visual Basic (Declaration)
Public Class FootPrintRoof _
    Inherits RoofBase
Visual C++
public ref class FootPrintRoof : public RoofBase

Remarks

The FootPrintRoof object represents some kinds of FootPrintRoof in Revit. The RoofType property is used to distinguish the type of the roof.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.RoofBase
Autodesk.Revit.DB..::.FootPrintRoof

See Also

FootPrintRoof Members