Revit 2011 API
UpdaterRegistry Methods
UpdaterRegistry Class See Also

The UpdaterRegistry type exposes the following members.

Methods

Name | Description
AddTrigger | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsUpdaterRegistered | Checks whether an updater with the given id is registered
RegisterUpdater | Overloaded.
RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnregisterUpdater | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

See Also

UpdaterRegistry Class