Revit 2011 API
Wire Class
Members See Also
An object to represent electrical wire in Revit MEP product.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Wire : HostObject
Visual Basic (Declaration)
Public Class Wire _
    Inherits HostObject
Visual C++
public ref class Wire : public HostObject

Remarks

Adding wiring to a project is optional. you can create circuits and maintain the information associated with them without adding wiring to the project.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB.Electrical..::.Wire

See Also

Wire Members
Autodesk.Revit.DB.Electrical Namespace