Revit 2011 API
Form..::.GetPathCurveIndexByCurveReference Method
Form Class See Also
Given a reference to certain curve in the path, return its index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int GetPathCurveIndexByCurveReference(
    Reference curveReference
)
Visual Basic (Declaration)
Public Function GetPathCurveIndexByCurveReference ( _
    curveReference As Reference _
) As Integer
Visual C++
public:
int GetPathCurveIndexByCurveReference(
    Reference^ curveReference
)

Parameters

curveReference
Type: Autodesk.Revit.DB..::.Reference
Reference to the curve in path

See Also

Form Class