Revit 2011 API
PointOnPlane Class
Members See Also
Define a ReferencePoint relative to a planar reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointOnPlane : PointElementReference
Visual Basic (Declaration)
Public Class PointOnPlane _
    Inherits PointElementReference
Visual C++
public ref class PointOnPlane : public PointElementReference

Remarks

A ReferencePoint on a plane has its X and Y basis vectors parallel to the plane, but is free to rotate around its Z basis vector. It can lie on the plane or have an offset.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.PointElementReference
Autodesk.Revit.DB..::.PointOnPlane

See Also

PointOnPlane Members