Revit 2011 API
FailureMessageAccessor..::.ShouldMergeWithMessage Method
FailureMessageAccessor Class See Also
Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShouldMergeWithMessage(
    FailureMessageAccessor messageToMergeWith
)
Visual Basic (Declaration)
Public Function ShouldMergeWithMessage ( _
    messageToMergeWith As FailureMessageAccessor _
) As Boolean
Visual C++
public:
bool ShouldMergeWithMessage(
    FailureMessageAccessor^ messageToMergeWith
)

Parameters

messageToMergeWith
Type: Autodesk.Revit.DB..::.FailureMessageAccessor

Return Value

True if messages should be merged

Remarks

Messages should be merged if all user-visible information except failing elements is the same, failure resolution types are the same and merging lists of failing elements keeps message text applicable to all of them equally. Method is used by the Revit UI to display multiple messages as one.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | messageToMergeWith has not been properly initialized.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessageAccessor Class