Revit 2011 API
FilteredElementCollector..::.WhereElementIsCurveDriven Method
FilteredElementCollector Class See Also
Applies an ElementIsCurveDrivenFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsCurveDriven()
Visual Basic (Declaration)
Public Function WhereElementIsCurveDriven As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsCurveDriven()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements which are curve driven will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class