Revit 2011 API
Element..::.GetValidTypes Method
Element Class See Also
Obtains a set of types that are valid for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetValidTypes()
Visual Basic (Declaration)
Public Function GetValidTypes As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetValidTypes()

Return Value

A set of element IDs of types that are valid for this element.

Remarks

Returns an empty set if element can not have type assigned.

See Also

Element Class
GetValidTypes Overload