Revit 2011 API
MassSurfaceDataSource Enumeration
See Also
Indicates whether values for the properties of the MassSurfaceData are synchronized with the EnergyDataSettings of the document or instead, serve as overrides of those settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum MassSurfaceDataSource
Visual Basic (Declaration)
Public Enumeration MassSurfaceDataSource
Visual C++
public enum class MassSurfaceDataSource

Members

Member name | Description
Invalid | This value indicates that the parameter has not been properly set.
EnergyData | Synchronize with the EnergyDataSettings.
Surface | Override the EnergyDataSettings values for the surface.

See Also

Autodesk.Revit.DB.Analysis Namespace