Revit 2011 API
CompoundStructureLayerFunction Enumeration
See Also
Describes the purpose of the layer within a compound structure, such as a wall or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum CompoundStructureLayerFunction
Visual Basic (Declaration)
Public Enumeration CompoundStructureLayerFunction
Visual C++
public enum class CompoundStructureLayerFunction

Members

Member name | Description
Structure | A structural layer.
Substrate | A substrate layer.
ThermalOrAir | A thermal or air insulating layer.
Finish1 | A finish layer.
Finish2 | A finish layer.
MembraneLayer | A membrane layer.
StructuralDeck | A special layer considered to be structural decking.

See Also