Revit 2011 API
TextBox..::.ShowImageAsButton Property
TextBox Class See Also
Gets or sets a value that indicates if the Image set in the text box should be displayed as a clickable button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShowImageAsButton { get; set; }
Visual Basic (Declaration)
Public Property ShowImageAsButton As Boolean
Visual C++
public:
property bool ShowImageAsButton {
    bool get ();
    void set (bool value);
}

Remarks

If this property is true, the image will shown as a button inside the textbox. Clicking this button will trigger the EnterPressed event. The default value is false.

See Also

TextBox Class
Autodesk.Revit.UI Namespace