Revit 2011 API
RebarBarType..::.SetAutoCalcHookLengths Method
RebarBarType Class See Also
Identifies if the hook lengths of a hook type are automatically calculated for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetAutoCalcHookLengths(
    ElementId hookId,
    bool autoCalculated
)
Visual Basic (Declaration)
Public Sub SetAutoCalcHookLengths ( _
    hookId As ElementId, _
    autoCalculated As Boolean _
)
Visual C++
public:
void SetAutoCalcHookLengths(
    ElementId^ hookId,
    bool autoCalculated
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type
autoCalculated
Type: System..::.Boolean
True if the hook lengths should be automatically calculated, otherwise false When it is false, default hook length and default hook offset length will be reported

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace