Revit 2011 API
DuctSystemType Enumeration
See Also
An enumerated type listing all the possible duct system types for a duct connector object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DuctSystemType
Visual Basic (Declaration)
Public Enumeration DuctSystemType
Visual C++
public enum class DuctSystemType

Members

Member name | Description
UndefinedSystemType | Undefined system type
SupplyAir | Duct System Type is SupplyAir.
ReturnAir | Duct System Type is ReturnAir.
ExhaustAir | Duct System Type is ExhaustAir.
OtherAir | Duct System Type is OtherAir.
Fitting | Duct System Type is Fitting.
Global | Duct System Type is Global.

See Also

Autodesk.Revit.DB.Mechanical Namespace