Revit 2011 API
View Properties
View Class See Also

The View type exposes the following members.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view.
CropBoxActive | Whether or not the Crop Box/Region is active for the view.
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
CutColorOverrideByElement | Override the cut lines' color by Element in this view.
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen.
Outline | The bounds of the view in paper space (in inches).
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
RightDirection | The direction towards the right side of the screen.
Scale | The scale of the view.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation.
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen.
ViewDirection | The direction towards the viewer.
ViewName | The name of the view.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view.

See Also

View Class