Revit 2011 API
AnalysisDisplayColorSettings Members
AnalysisDisplayColorSettings Class Constructors Methods Properties See Also

The AnalysisDisplayColorSettings type exposes the following members.

Constructors

Name | Description
AnalysisDisplayColorSettings | Overloaded.

Methods

Name | Description
AreIntermediateColorsValid | Verify intermediate color entries
Colors | Get number of colors, including min, max and intermediate.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntermediateColors | Get intermediate color entries (other than the minimum and maximum settings).
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two color settings objects.
SetIntermediateColors | Set intermediate color entries (other than the minimum and maximum settings).
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorSettingsType | Stores type of color settings
MaxColor | Color assigned to the maximum value.
MinColor | Color assigned to the minimum value.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace