Revit 2011 API
Rectangle Members
Rectangle Class Constructors Methods Properties See Also

The Rectangle type exposes the following members.

Constructors

Name | Description
Rectangle | Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bottom | Gets y-coordinate of the bottom-right corner of the rectangle.
Left | Gets x-coordinate of the top-left corner of the rectangle.
Right | Gets x-coordinate of the bottom-right corner of the rectangle.
Top | Gets y-coordinate of the top-left corner of the rectangle.

See Also

Rectangle Class