Revit 2011 API
ReferencePoint Class
Members See Also
A reference point in an Autodesk Revit family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ReferencePoint : Element
Visual Basic (Declaration)
Public Class ReferencePoint _
    Inherits Element
Visual C++
public ref class ReferencePoint : public Element

Remarks

A ReferencePoint represents a point in space together with a local coordinate system. ReferencePoints can be free, or constrained to other elements in several ways. When the point is constrained, the coordinate system is also constrained in certain ways.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ReferencePoint

See Also

ReferencePoint Members