Revit 2011 API
UIApplication..::.DrawingAreaExtents Property
UIApplication Class See Also
Get the rectangle that represents the screen pixel coordinates of drawing area.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Rectangle DrawingAreaExtents { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property DrawingAreaExtents As Rectangle
Visual C++
public:
virtual property Rectangle^ DrawingAreaExtents {
    Rectangle^ get ();
}

Remarks

The drawing area of the Revit window displays views (and sheets and schedules) of the current project. The size of drawing area restricts the max size of the view windows. If there is no project opened, null will be returned.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace