Revit 2011 API
StorageType Enumeration
See Also
An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum StorageType
Visual Basic (Declaration)
Public Enumeration StorageType
Visual C++
public enum class StorageType

Members

Member name | Description
None | None represents an invalid storage type. This value should not be used.
Integer | The internal data is stored in the form of a signed 32 bit integer.
Double | The data will be stored internally in the form of an 8 byte floating point number.
String | The internal data will be stored in the form of a string of characters.
ElementId | The data type represents an element and is stored as the id of the element.

See Also