Revit 2011 API
TemperatureRatingType Class
Members See Also
Represents temperature rating type definition information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TemperatureRatingType : ElementType
Visual Basic (Declaration)
Public Class TemperatureRatingType _
    Inherits ElementType
Visual C++
public ref class TemperatureRatingType : public ElementType

Remarks

Temperature rating type is defined based on corresponding wire material type. It includes type information such as wire size, insulation type, correction factor, etc. Only the temperature rating types which are retrieved from WireMaterialType can work well, so don't retrieve it from Revit document directly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Electrical..::.TemperatureRatingType

See Also

TemperatureRatingType Members
Autodesk.Revit.DB.Electrical Namespace