Revit 2011 API
RadioButtonGroup..::.Current Property
RadioButtonGroup Class See Also
Gets or sets the current checked ToggleButton of the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ToggleButton Current { get; set; }
Visual Basic (Declaration)
Public Property Current As ToggleButton
Visual C++
public:
property ToggleButton^ Current {
    ToggleButton^ get ();
    void set (ToggleButton^ value);
}

Remarks

The default value is the first ToggleButton added to the group. When using this property to set the current ToggleButton, the external command of that button will not be called.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when trying to set this property to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when trying to set this property to a button not in this group.

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace