Revit 2011 API
FailuresAccessor Class
Members See Also
An interface class that provides access to failure information posted in a document and methods to resolve these failures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailuresAccessor : IDisposable
Visual Basic (Declaration)
Public Class FailuresAccessor _
    Implements IDisposable
Visual C++
public ref class FailuresAccessor : IDisposable

Remarks

An instance of this class can be obtained only as an argument passed to interfaces used in the process of failure resolution and is the only available interface to fetch information about failures in a document. While reading from a document during failure processing is allowed, the only way to modify document during failure resolution is via methods provided by this class. After returning from failure processing,the instance of the class is deactivated and cannot be used any longer.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailuresAccessor

See Also

FailuresAccessor Members