Revit 2011 API
Document..::.IsReadOnlyFile Property
Document Class See Also
Signals whether the document was opened in read-only mode or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsReadOnlyFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnlyFile As Boolean
Visual C++
public:
property bool IsReadOnlyFile {
    bool get ();
}

Remarks

A document would be opened in read-only mode when, for example, at the time of opening it was already being used by another Revit user.

Although it is still possible to modify documents opened in read-only mode, any attempt to save them would naturally fail. Therefore any changes to the document would have to be saved using the SaveAs method.

See Also

Document Class