Revit 2011 API
FailureMessageAccessor Members
FailureMessageAccessor Class Methods See Also

The FailureMessageAccessor type exposes the following members.

Methods

Name | Description
CloneFailureMessage | Creates a copy of the FailureMessage.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAdditionalElementIds | Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.
GetCurrentResolutionType | Retrieves the type of resolution to be used to resolve the failure.
GetDefaultResolutionCaption | Retrieves the caption of default resolution of the failure.
GetDescriptionText | Retrieves the description of the failure.
GetFailingElementIds | Retrieves Ids of Elements that have caused the failure.
GetFailureDefinitionId | Retrieves the Id of the FailureDefinition of the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNumberOfResolutions | Retrieves number of resolutions that can be used to resolve failure.
GetSeverity | Retrieves the severity of the failure.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutionOfType | Checks if failure has a resolution of a given type.
HasResolutions | Checks if the failure has any resolutions.
SetCurrentResolutionType | Sets the type of a resolution to be used to resolve the failure.
ShouldMergeWithMessage | Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessageAccessor Class