Revit 2011 API
ElementId Constructor (BuiltInCategory)
ElementId Class See Also
Create an ElementId handle with the given BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId(
    BuiltInCategory categoryId
)
Visual Basic (Declaration)
Public Sub New ( _
    categoryId As BuiltInCategory _
)
Visual C++
public:
ElementId(
    BuiltInCategory categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::.BuiltInCategory
The id.

See Also

ElementId Class
ElementId Overload