Revit 2011 API
DetailCurve Class
Members See Also
A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DetailCurve : CurveElement
Visual Basic (Declaration)
Public Class DetailCurve _
    Inherits CurveElement
Visual C++
public ref class DetailCurve : public CurveElement

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.DetailCurve
Autodesk.Revit.DB..::.DetailArc
Autodesk.Revit.DB..::.DetailEllipse
Autodesk.Revit.DB..::.DetailLine
Autodesk.Revit.DB..::.DetailNurbSpline

See Also

DetailCurve Members