Revit 2011 API
ElementBinding Class
Members See Also
A base class for all types of binding that attach to an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ElementBinding : Binding
Visual Basic (Declaration)
Public MustInherit Class ElementBinding _
    Inherits Binding
Visual C++
public ref class ElementBinding abstract : public Binding

Remarks

This base class provides methods that are common to all types of binding that work with elements.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Binding
Autodesk.Revit.DB..::.ElementBinding
Autodesk.Revit.DB..::.InstanceBinding
Autodesk.Revit.DB..::.TypeBinding

See Also

ElementBinding Members