Revit 2011 API
ConceptualConstructionWallType Enumeration
See Also
ConceptualConstructionType values for Walls.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum ConceptualConstructionWallType
Visual Basic (Declaration)
Public Enumeration ConceptualConstructionWallType
Visual C++
public enum class ConceptualConstructionWallType

Members

Member name | Description
InvalidExteriorWallTypeConstruction | Invalid value/not set Roof Type Construction value
LightweightConstructionHighInsulation | Lightweight Construction High Insulation Wall
LightweightConstructionTypicalColdClimateInsulation | Lightweight Construction Typical Cold Climate Insulation Wall
LightweightConstructionTypicalMildClimateInsulation | Lightweight Construction Typical Mild Climate Insulation Wall
LightweightConstructionLowInsulation | Lightweight Construction Low Insulation Wall
LightweightConstructionNoInsulationInterior | Lightweight Construction No Insulation Interior Wall
HighMassConstructionHighInsulation | High Mass Construction High Insulation Wall
HighMassConstructionTypicalColdClimateInsulation | High Mass Construction Typical Cold Climate Insulation Wall
HighMassConstructionTypicalMildClimateInsulation | High Mass Construction Typical Mild Climate Insulation Wall
HighMassConstructionNoInsulationInterior | High Mass Construction No Insulation Interior Wall
NumWallTypeConstruction | Total Number of Wall Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace