Revit 2011 API
RibbonButton Class
Members See Also
This class is the base class of PushButton and PulldownButton.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class RibbonButton : RibbonItem
Visual Basic (Declaration)
Public Class RibbonButton _
    Inherits RibbonItem
Visual C++
public ref class RibbonButton : public RibbonItem

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.RibbonButton
Autodesk.Revit.UI..::.PulldownButton
Autodesk.Revit.UI..::.PushButton

See Also

RibbonButton Members
Autodesk.Revit.UI Namespace