Revit 2011 API
BuiltInFailures..::.GeneralFailures Properties
BuiltInFailures..::.GeneralFailures Class See Also

The BuiltInFailures..::.GeneralFailures type exposes the following members.

Properties

Name | Description
ActionCancelled | A serious error has occurred. The current action has been cancelled.
CannotFixProblem | Failed to fix problem. Action has to be cancelled.
CannotSetParameter | Cant set parameter
CharactersNotAllowed | Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
ConvertingOldAxisToNormal | This operation will convert the existing axis of revolution to a normal line.
DuplicateValue | Elements have duplicate '[Value]' values.
EnterValidRealGreaterThan | Enter a number greater than [Value].
EnterValueBetween | Please enter a value between [Value] and [Value].
ErrorResolved | Error "[Text]" was automatically resolved by "[Resolution]"
FailedToOpenFile | Failed to open file.
FailedToReadLine | Failed to read line.
GenericCorruption | A generic error has occurred.
GenericError | Error.
GenericErrorNone | None.
GenericFatalError | A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
GenericNonFatalError | A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
GenericWarning | A generic error has occurred.
InaccuracyDetected | A geometric inaccuracy was found in the element.
InternalProblemsParameter | Parameter cannot be changed due to internal problems.
InvalidInput | Invalid Input
InvalidInputWarn | Invalid Input
InvalidValue | Invalid value.
LicenseLostFatalError | The connection to your network license server has been lost and the 2 hour grace period for your network license has expired. The application will be closed. You have the opportunity to save recovery files for all of your changed projects. Choose “SaveAs and Exit” to save a recovery file of the open project(s), or choose “Exit Program” to proceed without saving any files.
NameInUse | The name "[Name]" is already in use.
NameIsEmpty | Name is empty
NameNotUnique | The name entered is already in use. Enter a unique name.
NewElementInvisibleInCurrentView | The newly created object is not visible in the current view.
NoRelatedWarnings | Document doesn't contain any warnings related to these elements.
ParameterValueNotInRange | The value for [Parameter Name] must be between [Value] and [Value].
SeriousElementReferenceCorruption | Element references are seriously corrupt.
TransactionFailed | [Description]
TransactionFailedWarn | [Description]
UnspecifiedError | Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
ValueOutOfRange | Value is out of range ! Please enter a number between [Value] and [Value].

See Also

BuiltInFailures..::.GeneralFailures Class