Revit 2011 API
ConceptualConstructionType Methods
ConceptualConstructionType Class See Also

The ConceptualConstructionType type exposes the following members.

Methods

Name | Description
CanBeHidden
Indicates if the element can be hidden in the view.
(Inherited from Element.)
CanHaveAnalyticalModel
Indicates whether the Element can have an Analytical Model.
(Inherited from Element.)
CanHaveTypeAssigned
Identifies if the element can have a type assigned.
(Inherited from Element.)
ChangeTypeId
Changes type of the element.
(Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate
Duplicate this object.
(Inherited from ElementType.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetAllConceptualConstructionsForCategory
Get all the ids of constructions applicable to the input massSubCategory
GetAnalyticalModel
Retrieves writeable Analytical Model for Element.
(Inherited from Element.)
GetDividedSurfaceData
Get an interface to the divided surfaces on this element.
(Inherited from Element.)
GetFloorOrSlabConstructionType
Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.
GetGBSId
Gets the Green Building Studio identifier associated with the construction.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMaterialArea
Get the area of the given material on this element.
(Inherited from Element.)
GetMaterialVolume
Get the volume of the given material on this element.
(Inherited from Element.)
GetMonitoredLinkElementIds
Provides the link instance IDs when the element is monitoring.
(Inherited from Element.)
GetMonitoredLocalElementIds
Provides the local element IDs when the element is monitoring.
(Inherited from Element.)
GetOpeningConstructionType
Get a Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
GetPreviewImage
Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
(Inherited from ElementType.)
GetRoofConstructionType
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
GetShadeConstructionType
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
GetSimilarTypes
Obtains a set of types that are similar to this type.
(Inherited from ElementType.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
GetTypeId
Returns the identifier of this element's type.
(Inherited from Element.)
GetValidTypes
Obtains a set of types that are valid for this element.
(Inherited from Element.)
GetWallConstructionType
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
GetWindowOrSkylightConstructionType
Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
IsHidden
Identifies if the element has been permanently hidden in the view.
(Inherited from Element.)
IsMonitoringLinkElement
Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element.)
IsMonitoringLocalElement
Indicate whether an element is monitoring other local elements.
(Inherited from Element.)
IsSimilarType
Checks if given type is similar to this type.
(Inherited from ElementType.)
IsValidConceptualConstructionId
Indicates if the ElementId is an id of a ConceptualConstructionType.
IsValidConceptualConstructionIdForCategory
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
IsValidSubcategoryForMassSurfaceDatas
Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassWindow
  9. OST_MassSkylights
  10. OST_MassOpening
IsValidSurfaceSubcategoryForConstruction
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
IsValidType
Checks if given type is valid for this element.
(Inherited from Element.)
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace