Revit 2011 API
MassZone Members
MassZone Class Methods Properties See Also

The MassZone type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCoincidentReferenceFromAdjacentZone | This method is used to get a Reference from an adjacent MassZone that is coincident to a Reference of this MassZone.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEquivalentReferenceFromMassOrLevel | Returns a Reference to a face of a MassEnergyAnalyticalModel element or an element Reference to a MassLevelData element. This Reference represents what the MassZone face was "cut from" when making the MassZone for the level.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMassDataElementIdForZoneFaceReference | MassZone faces come from faces of MassEnergyAnalyticalModel, and those faces have MassSurfaceData or MassLevelData elements associated with them.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetReferencesToEnergyAnalysisFaces | Used to get References to all the faces of the MassZone that are used for Energy Analysis.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsEmpty | Indicates if MassZone has no geometry. Such zones should not be shown to the user.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConditionType | The gbXMLConditionType of the MassZone.
CutByLowerLevel | Indicates the relationship between the MassZone and its lower level.
CutByUpperLevel | Indicates the relationship between the MassZone and its upper level.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorArea | The floor area of the MassZone.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsZoneOccupiable | A MassZone must have a level as its bottom to be occupiable; If it does not, it is still a MassZone, but it is not occupiable
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
LowerLevelId | The bottom level defining the MassZone.
MassEnergyAnalyticalModelId | The ElementId of the MassEnergyAnalyticalModel that the MassZone is derived from.
MaterialId | The visualization material for the MassZone. Will be InvalidElementId if material is by category or the material type is by MassZoneMaterialTypeMaterialBySurfaceType.
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Indicates how the material of MassZone faces is determined.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpaceType | The gbXMLSpaceType of the MassZone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLevelId | The upper level defining the MassZone.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | The volume of the MassZone.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace