Revit 2011 API
ParameterValueProvider Constructor
ParameterValueProvider Class See Also
Constructs an instance of ParameterValueProvider.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ParameterValueProvider(
    ElementId parameter
)
Visual Basic (Declaration)
Public Sub New ( _
    parameter As ElementId _
)
Visual C++
public:
ParameterValueProvider(
    ElementId^ parameter
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
The parameter used to provide a string, integer, and double-precision, or ElementId value on request for a given element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterValueProvider Class