Revit 2011 API
ComboBox Members
ComboBox Class Methods Properties Events See Also

The ComboBox type exposes the following members.

Methods

Name | Description
AddItem | Adds a new item to the ComboBox.
AddItems | Adds a new items to the ComboBox.
AddSeparator | Adds a separator to the drop-down list.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Gets or sets the current checked ComboBox member of the ComboBox.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image shown on the ComboBox.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

Events

Name | Description
CurrentChanged | Subscribe to this event to be notified when the current item of the ComboBox is changed.
DropDownClosed | Subscribe to this event to be notified when the drop-down of the ComboBox is closed.
DropDownOpened | Subscribe to this event to be notified when the drop-down of the ComboBox is opened.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace