Revit 2011 API
Document..::.SeparateElements Method
Document Class See Also
Separate a set of combinable elements out of combinations they currently belong to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SeparateElements(
    CombinableElementArray members
)
Visual Basic (Declaration)
Public Sub SeparateElements ( _
    members As CombinableElementArray _
)
Visual C++
public:
void SeparateElements(
    CombinableElementArray^ members
)

Parameters

members
Type: Autodesk.Revit.DB..::.CombinableElementArray
A list of combinable elements to be separated.

Remarks

If geometry combination elements are passed as input, they will be completely separated and deleted. If generic forms that happen to belong to combination elements are passed, these forms will be removed from their geometry combination. The handles of geometry combinations completely removed by this operation are no longer valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when members is empty. Thrown when members contains nullNothingnullptra null reference (Nothing in Visual Basic) elements.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when separation failed.

See Also

Document Class