Revit 2011 API
Connector..::.AssignedFlowFactor Property
Connector Class See Also
The assigned flow factor of this connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AssignedFlowFactor { get; set; }
Visual Basic (Declaration)
Public Property AssignedFlowFactor As Double
Visual C++
public:
property double AssignedFlowFactor {
    double get ();
    void set (double value);
}

Remarks

Assigned flow factor may be assigned for connectors of some family instances, for more information, refer to DuctConnector, PipeConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when get assigned flow factor from a connector not in family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::.ArgumentException | Throw when set an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get or set assigned flow factor.

See Also

Connector Class