Revit 2011 API
MassSurfaceDataMaterialType Enumeration
See Also
Indicates how the visualization material for the MassSurfaceData is calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum MassSurfaceDataMaterialType
Visual Basic (Declaration)
Public Enumeration MassSurfaceDataMaterialType
Visual C++
public enum class MassSurfaceDataMaterialType

Members

Member name | Description
MaterialByConstruction | The visualization material for the MassSurfaceData will be taken from the material assigned to the ConceptualConstructionType which is assigned to the MassSurfaceData.
NormalMaterial | The visualization material for the MassSurfaceData will be taken from the material associated with the object style of the subcategory of the MassSurfaceData if the materialId is InvalidElementId, or the MassSurfaceData will use the specific material indicated by the materialId property if its value is an ElementId of a MaterialElement.

See Also

Autodesk.Revit.DB.Analysis Namespace