Revit 2011 API
FlexPipeType Class
Members See Also
A flex pipe type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FlexPipeType : MEPCurveType
Visual Basic (Declaration)
Public Class FlexPipeType _
    Inherits MEPCurveType
Visual C++
public ref class FlexPipeType : public MEPCurveType

Remarks

The flex pipe type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Plumbing..::.FlexPipeType

See Also

FlexPipeType Members
Autodesk.Revit.DB.Plumbing Namespace