Revit 2011 API
AnalyticalModel..::.GetAnalyticalModelSketchComponents Method
AnalyticalModel Class See Also
Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<AnalyticalModelSketchComponent> GetAnalyticalModelSketchComponents()
Visual Basic (Declaration)
Public Function GetAnalyticalModelSketchComponents As IList(Of AnalyticalModelSketchComponent)
Visual C++
public:
IList<AnalyticalModelSketchComponent^>^ GetAnalyticalModelSketchComponents()

Return Value

If the Analytical Model supports Sketch-based adjustment of the Analytical Model, then this will return an array of AnalyticalModelSketchComponents. Otherwise, it will return an empty array.

Remarks

The AnalyticalModelSketchComponent abstraction is necessary for the those Elements (currently only Slab) consisting of a Sketch, and each Sketch line has the potential to have Analytical Model specific items associated with it. These Analytical Model artifacts are components of the Slab, not of the individual curves (which have no Analytical Model). This form results in writable AnalyticalModelSketchComponents.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace