Revit 2011 API
CurtainGridLine..::.RemoveSegment Method
CurtainGridLine Class See Also
Remove the segment specified by the input curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveSegment(
    Curve curve
)
Visual Basic (Declaration)
Public Sub RemoveSegment ( _
    curve As Curve _
)
Visual C++
public:
void RemoveSegment(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The curve used to locate the segment to be removed.

Remarks

When a segment is removed, the neighboring two panels will be merged into one panel.

See Also

CurtainGridLine Class