Revit 2011 API
ElementParameterFilter Constructor (FilterRule, Boolean)
ElementParameterFilter Class See Also
Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementParameterFilter(
    FilterRule filterRule,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    filterRule As FilterRule, _
    inverted As Boolean _
)
Visual C++
public:
ElementParameterFilter(
    FilterRule^ filterRule,
    bool inverted
)

Parameters

filterRule
Type: Autodesk.Revit.DB..::.FilterRule
The rule applied to test if the element passes this filter.
inverted
Type: System..::.Boolean
True if the filter should match all elements which do not pass the filter rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementParameterFilter Class
ElementParameterFilter Overload