Revit 2011 API
FilterableValueProvider..::.GetElementIdValue Method
FilterableValueProvider Class See Also
Gets an ElementId value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetElementIdValue(
    Element element
)
Visual Basic (Declaration)
Public Function GetElementIdValue ( _
    element As Element _
) As ElementId
Visual C++
public:
ElementId^ GetElementIdValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query.

Return Value

The ElementId value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class