Revit 2011 API
AnalysisDisplayLegendSettings Members
AnalysisDisplayLegendSettings Class Constructors Methods Properties See Also

The AnalysisDisplayLegendSettings type exposes the following members.

Constructors

Name | Description
AnalysisDisplayLegendSettings | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two legend settings objects.
SetTextTypeId | Set element id of text associated with legend settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NumberOfSteps | Number of steps (values between minimum and maximum) to be shown in legend.
Rounding | Rounding increment for numeric values of analysis results.
ShowDataDescription | If set to true, data description is shown in the legend.
ShowDataName | If set to true, data name is shown in the legend.
ShowLegend | If set to true, legend is shown in the view.
ShowUnits | If set to true, units are shown in the legend.
TextTypeId | Element id of text associated with legend settings.

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace