Revit 2011 API
UpdaterId Constructor
UpdaterId Class See Also
creates an instance of UpdaterId for given AddInId and a given GUID value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public UpdaterId(
    AddInId addInId,
    Guid val
)
Visual Basic (Declaration)
Public Sub New ( _
    addInId As AddInId, _
    val As Guid _
)
Visual C++
public:
UpdaterId(
    AddInId^ addInId,
    Guid val
)

Parameters

addInId
Type: Autodesk.Revit.DB..::.AddInId
Id of addin that registers an Updater
val
Type: System..::.Guid
a GUID identifying the Updater within addin

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterId Class