Revit 2011 API
MassEnergyAnalyticalModel..::.GetValidSurfaceCategoryIdsForReference Method
MassEnergyAnalyticalModel Class See Also
The Mass surface subcategory ids that are appropriate values for the input Reference.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<ElementId> GetValidSurfaceCategoryIdsForReference(
    Reference reference,
    out ElementId recommendedDefaultSubcategoryId
)
Visual Basic (Declaration)
Public Function GetValidSurfaceCategoryIdsForReference ( _
    reference As Reference, _
    <OutAttribute> ByRef recommendedDefaultSubcategoryId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetValidSurfaceCategoryIdsForReference(
    Reference^ reference,
    [OutAttribute] ElementId^% recommendedDefaultSubcategoryId
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
A Reference to a Face of this MassEnergyAnalyticalModel.
recommendedDefaultSubcategoryId
Type: Autodesk.Revit.DB..::.ElementId %
The ElementId that is recommended as the default setting for this pick.

Return Value

Returns the ElementIds of appropriate values for input Reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The Reference is not a Face of this MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace