Revit 2011 API
SunAndShadowSettings Methods
SunAndShadowSettings Class See Also

The SunAndShadowSettings type exposes the following members.

Methods

Name | Description
CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
GetActiveSunAndShadowSettings | Returns the currently SunAndShadowSettings element assigned to the active view for the supplied document.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsAfterStartDateAndTime | Checks whether the end date and time is valid.
IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsLevelValid | Checks whether the element represents a valid level.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SunAndShadowSettings Class