Revit 2011 API
Definition Members
Definition Class Methods Properties See Also

The Definition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user visible name for the parameter.
ParameterGroup | Returns the group ID of the parameter definition.
ParameterType | Returns the user visible interpretation of the parameter data.

See Also

Definition Class