Revit 2011 API
CADImportOptions Members
CADImportOptions Class Methods Properties See Also

The CADImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorMode | Color mode for the import.
CustomScale | Scaling the import.
OrientToView | Place the import at the same orientation as the current view.
Placement | Where to place the import.
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only.
Unit | The unit of measure for imported geometry.
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

CADImportOptions Class