Revit 2011 API
Transaction Class
Members Example See Also
Transactions are context-like objects that guard any changes made to a Revit model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Transaction : IDisposable
Visual Basic (Declaration)
Public Class Transaction _
    Implements IDisposable
Visual C++
public ref class Transaction : IDisposable

Remarks

Any change to a document can only be made while there is an active transaction open for that document. Changes do not become a part of the model until the active transaction is committed. Consequently, all changes made in a transaction can be rolled back either explicitly or implicitly (by the destructor). Only one transaction per document can be open at any given time.

Examples

CopyC#
// Get the document
Autodesk.Revit.DB.Document document = uiApplication.ActiveUIDocument.Document;

// Create a geometry line in Revit application
XYZ Point1 = new XYZ(0, 0, 0);
XYZ Point2 = new XYZ(10, 0, 0);
XYZ Point3 = new XYZ(10, 10, 0);
XYZ Point4 = new XYZ(0, 10, 0);

// Transient Elements,so they are not managed by transactions
Line geomLine1 = application.Create.NewLine(Point1, Point2, true);
Line geomLine2 = application.Create.NewLine(Point4, Point3, true);
Line geomLine3 = application.Create.NewLine(Point1, Point4, true);

// Create a geometry plane in Revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(0, 0, 1);
Plane geomPlane = application.Create.NewPlane(normal, origin);

// non-transient elements,so they are grouped into transaction as atomic user actions
Transaction transaction = new Transaction(document);
if (transaction.Start("Create new curves") == TransactionStatus.Started)
{
    // Create a sketch plane in current document
    SketchPlane sketch = document.Create.NewSketchPlane(geomPlane);

    // Create a ModelLine element using the created geometry line and sketch plane
    ModelLine line1 = document.Create.NewModelCurve(geomLine1, sketch) as ModelLine;
    ModelLine line2 = document.Create.NewModelCurve(geomLine2, sketch) as ModelLine;
    ModelLine line3 = document.Create.NewModelCurve(geomLine3, sketch) as ModelLine;

    TaskDialog taskDialog = new TaskDialog("Revit");
    taskDialog.MainContent = "Click OK to call Transaction.Commit(), otherwise Transaction.Rollback().";
    TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Ok | TaskDialogCommonButtons.Cancel;
    taskDialog.CommonButtons = buttons;
    TaskDialogResult result = taskDialog.Show();

    if (TaskDialogResult.Ok == result)
    {
        transaction.Commit();
    }
    else
    {
        transaction.RollBack();
    }
}
CopyVB.NET
' Get the document
Dim document As Autodesk.Revit.DB.Document = uiApplication.ActiveUIDocument.Document

' Create a geometry line in Revit application
Dim Point1 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim Point2 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
Dim Point3 As New Autodesk.Revit.DB.XYZ(10, 10, 0)
Dim Point4 As New Autodesk.Revit.DB.XYZ(0, 10, 0)

' Transient Elements,so they are not managed by transactions
Dim geomLine1 As Line = application.Create.NewLine(Point1, Point2, True)
Dim geomLine2 As Line = application.Create.NewLine(Point4, Point3, True)
Dim geomLine3 As Line = application.Create.NewLine(Point1, Point4, True)

' Create a geometry plane in Revit application
Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim normal As New Autodesk.Revit.DB.XYZ(0, 0, 1)
Dim geomPlane As Plane = application.Create.NewPlane(normal, origin)

' non-transient elements,so they are grouped into transaction as atomic user actions
Dim transaction As New Transaction(document)
If transaction.Start("Create new curves") = TransactionStatus.Started Then
    ' Create a sketch plane in current document
    Dim sketch As SketchPlane = document.Create.NewSketchPlane(geomPlane)

    ' Create a ModelLine element using the created geometry line and sketch plane
    Dim line1 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine1, sketch), ModelLine)
    Dim line2 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine2, sketch), ModelLine)
    Dim line3 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine3, sketch), ModelLine)

    Dim taskDialog As New TaskDialog("Revit")
    taskDialog.MainContent = "Click OK to call Transaction.Commit(), otherwise Transaction.Rollback()."
    Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Ok Or TaskDialogCommonButtons.Cancel
    taskDialog.CommonButtons = buttons
    Dim result As TaskDialogResult = taskDialog.Show()

    If TaskDialogResult.Ok = result Then
        transaction.Commit()
    Else
        transaction.RollBack()
    End If
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Transaction

See Also

Transaction Members