Revit 2011 API
MassLevelData Class
Members See Also
MassLevelData is a conceptual representation of an occupiable floor in a conceptual building model. It is defined by associating a particular level with a particular mass element in a Revit project.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class MassLevelData : Element
Visual Basic (Declaration)
Public Class MassLevelData _
    Inherits Element
Visual C++
public ref class MassLevelData : public Element

Remarks

MassLevelData reports metrics, such as floor areas, related to conceptual space planning. MassLevelData contains information, such as ConceptualConstructionType, used as part of the Conceptual Energy Analytical model. The MassLevel data geometry is determined by combining all the geometry of a mass into a single geometry, and then taking the area of intersection with the level of the MassLevelData.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.MassLevelData

See Also

MassLevelData Members
Autodesk.Revit.DB.Analysis Namespace