Revit 2011 API
SharedParameterApplicableRule Constructor
SharedParameterApplicableRule Class See Also
Constructs an instance of SharedParameterApplicableRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public SharedParameterApplicableRule(
    string parameterName
)
Visual Basic (Declaration)
Public Sub New ( _
    parameterName As String _
)
Visual C++
public:
SharedParameterApplicableRule(
    String^ parameterName
)

Parameters

parameterName
Type: System..::.String
The name of the parameter that an element must support to pass this rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SharedParameterApplicableRule Class