Revit 2011 API
CableTrayRun Class
Members See Also
This class represents a cable tray run in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CableTrayRun : CableTrayConduitRunBase
Visual Basic (Declaration)
Public Class CableTrayRun _
    Inherits CableTrayConduitRunBase
Visual C++
public ref class CableTrayRun : public CableTrayConduitRunBase

Remarks

This class is mainly for calculating length of a cable tray run. A cable tray run contains connected straight cable tray segments and bends between the straight segments with same type and size.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Electrical..::.CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::.CableTrayRun

See Also

CableTrayRun Members
Autodesk.Revit.DB.Electrical Namespace