Revit 2011 API
ViewSheet..::.ConvertToRealSheet Method
ViewSheet Class See Also
Convert a placeholder sheet to a real one with an optional titleblock

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ConvertToRealSheet(
    ElementId titleblockElementId
)
Visual Basic (Declaration)
Public Sub ConvertToRealSheet ( _
    titleblockElementId As ElementId _
)
Visual C++
public:
void ConvertToRealSheet(
    ElementId^ titleblockElementId
)

Parameters

titleblockElementId
Type: Autodesk.Revit.DB..::.ElementId
The element id of titleblock for the real sheet. If it is a nullptr or an invalid element id, no titleblock will be created.

Remarks

This method should only be called on a placeholder sheet, otherwise exception will occur.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If titleblockElementId is a valid element id but not a titleblock symbol id.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the method is not called on a placeholder sheet or the input titleblock could not be applied.

See Also

ViewSheet Class