Revit 2011 API
AnalyticalModelSketchComponent..::.GetAutoDetectMatchedElements Method
AnalyticalModelSketchComponent Class See Also
Retrieves ElementIds that Sketch Component is Auto-detecting against.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAutoDetectMatchedElements()
Visual Basic (Declaration)
Public Function GetAutoDetectMatchedElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAutoDetectMatchedElements()

Return Value

Set of ElementIds that Sketch Component is auto-detecting against.

Remarks

An empty set indicates that the Sketch Component is just not Auto-detecting against anything.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace