Revit 2011 API
ConceptualSurfaceType..::.GetByMassSubCategoryId Method
ConceptualSurfaceType Class See Also
Get the ConceptualSurfaceType by its mass subcategory id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ConceptualSurfaceType GetByMassSubCategoryId(
    Document cda,
    ElementId massSubCategoryId
)
Visual Basic (Declaration)
Public Shared Function GetByMassSubCategoryId ( _
    cda As Document, _
    massSubCategoryId As ElementId _
) As ConceptualSurfaceType
Visual C++
public:
static ConceptualSurfaceType^ GetByMassSubCategoryId(
    Document^ cda,
    ElementId^ massSubCategoryId
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
The document.
massSubCategoryId
Type: Autodesk.Revit.DB..::.ElementId
The mass subcategory id to get the ConceptualSurfaceType for.

Return Value

Returns ConceptualSurfaceType associated with input id or NULL.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassShade, OST_MassWindow, OST_MassSkylights, or OST_MassOpening.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace