Revit 2011 API
FilteredElementIterator Methods
FilteredElementIterator Class See Also

The FilteredElementIterator type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCurrent | The current element found by the iterator.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDone | Identifies if the iteration has completed.
MoveNext | Increments the iterator to the next element passing the filter.
Reset | Resets the iterator to the beginning.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredElementIterator Class