Revit 2011 API
Document..::.NewOpening Method (Element, CurveArray, eRefFace)
Document Class See Also
Creates a new opening in a beam, brace and column.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Opening NewOpening(
    Element famInstElement,
    CurveArray profile,
    eRefFace iFace
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    famInstElement As Element, _
    profile As CurveArray, _
    iFace As eRefFace _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ famInstElement,
    CurveArray^ profile,
    eRefFace iFace
)

Parameters

famInstElement
Type: Autodesk.Revit.DB..::.Element
host element of the opening, can be a beam, brace and column.
profile
Type: Autodesk.Revit.DB..::.CurveArray
profile of the opening.
iFace
Type: Autodesk.Revit.Creation..::.eRefFace
face on which opening is based on.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on a beam, brace and column.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace