Revit 2011 API
FailureMessage..::.SetFailingElement Method
FailureMessage Class See Also
Sets the element that has caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetFailingElement(
    ElementId id
)
Visual Basic (Declaration)
Public Function SetFailingElement ( _
    id As ElementId _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetFailingElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The element that has caused the failure.

Return Value

The FailureMessage.

Remarks

In Revit error dialog this element will be highlighted to the user and can be deleted by user via extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessage is already posted to a document
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class