Revit 2011 API
EnergyDataSettings..::.SetCreateAnalyticalModel Method
EnergyDataSettings Class See Also
If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetCreateAnalyticalModel(
    bool createAnalyticalModel
)
Visual Basic (Declaration)
Public Sub SetCreateAnalyticalModel ( _
    createAnalyticalModel As Boolean _
)
Visual C++
public:
void SetCreateAnalyticalModel(
    bool createAnalyticalModel
)

Parameters

createAnalyticalModel
Type: System..::.Boolean
True to enable the Energy Analytical Model otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace