Revit 2011 API
FamilySymbolFilter Constructor
FamilySymbolFilter Class See Also
Constructs a new instance of a filter to find all family symbols of the given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FamilySymbolFilter(
    ElementId familyId
)
Visual Basic (Declaration)
Public Sub New ( _
    familyId As ElementId _
)
Visual C++
public:
FamilySymbolFilter(
    ElementId^ familyId
)

Parameters

familyId
Type: Autodesk.Revit.DB..::.ElementId
The family id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The familyId is invalid.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FamilySymbolFilter Class