Revit 2011 API
GeometryInstance Properties
GeometryInstance Class See Also

The GeometryInstance type exposes the following members.

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Symbol | The symbol element that this object is referring to.
SymbolGeometry | The geometric representation of the symbol which generates this instance.
Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryInstance Class