Revit 2011 API
PrintParameters..::.Zoom Property
PrintParameters Class See Also
The zoom value to a percentage of the original size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Integer
Visual C++
public:
property int Zoom {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if current ZoomType is not Zoom type.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown if input zoom value less than 1.

See Also

PrintParameters Class