Revit 2011 API
MechanicalSystem..::.BaseEquipmentConnector Property
MechanicalSystem Class See Also
The connector within the base equipment which is used to connect with the system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; set; }
Visual Basic (Declaration)
Public Property BaseEquipmentConnector As Connector
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
    void set (Connector^ value);
}

Remarks

Assigning nullNothingnullptra null reference (Nothing in Visual Basic) to the base equipment connector will disconnect the base equipment from the system.

Remarks

Setting this property will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when assigning a connector which is used in a system, or when the connector's owner is not of type 'mechanical equipment'.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the set operation failed.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace