Revit 2011 API
ElementRecord Members
ElementRecord Class Methods See Also

The ElementRecord type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBoundingBox | Gets the bounding box of the element record.
GetCategoryId | Gets the category id of the element record.
GetDesignOptionId | Gets the design option id of the element record.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetId | Gets the id of the element record.
GetOwnerViewId | Gets the element id of the owner view record.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasBoundingBox | Determines whether this element record has a bounding box.
IsAnElementType | Identifies if the element record represents an ElementType.
IsCurveDriven | Identifies if the element is curve driven.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementRecord Class