Revit 2011 API
Application Methods
Application Class See Also

The Application type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
NewProjectDocument | New project document
NewProjectTemplateDocument | New project template document
OpenDocumentFile | Opens a document from disk.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteJournalComment | Writes a comment to the Revit journal file

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace