Revit 2011 API
FailuresAccessor..::.GetSeverity Method
FailuresAccessor Class See Also
Provides access to the current failure severity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic (Declaration)
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The highest severity of a failure message currently posted in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class