Revit 2011 API
UpdaterRegistry..::.RegisterUpdater Method (IUpdater, Document)
UpdaterRegistry Class See Also
Registers the updater for the specified document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater,
    Document doc
)
Visual Basic (Declaration)
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater, _
    doc As Document _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater,
    Document^ doc
)

Parameters

updater
Type: Autodesk.Revit.DB..::.IUpdater
Updater to be registered
doc
Type: Autodesk.Revit.DB..::.Document
Document for which this updater is registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | updater's updaterId is not valid
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater is already registered for this document or on the application level -or- updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class
RegisterUpdater Overload