Revit 2011 API
AnalyticalModel..::.IsEnabled Method
AnalyticalModel Class See Also
Reports whether the Analytical Model is enabled or disabled.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsEnabled()
Visual Basic (Declaration)
Public Function IsEnabled As Boolean
Visual C++
public:
bool IsEnabled()

Return Value

True if Analytical Model is enabled, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support enabling or disabling the analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace