Revit 2011 API
AnalysisDisplayStyle..::.SetLegendSettings Method
AnalysisDisplayStyle Class See Also
Set legend settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetLegendSettings(
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic (Declaration)
Public Sub SetLegendSettings ( _
    legendSettings As AnalysisDisplayLegendSettings _
)
Visual C++
public:
void SetLegendSettings(
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

legendSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegendSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace