Revit 2011 API
Rebar Methods
Rebar Class See Also

The Rebar type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ScaleToBox | Move and resize the bar to fit within a specified box.
ScaleToBoxForSpiral | Move and resize a spiral instance to fit within a specified box.
SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace