Revit 2011 API
RibbonItemData Members
RibbonItemData Class Methods Properties See Also

The RibbonItemData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LongDescription | Long description of the command tooltip
Name | The name of the item.
ToolTip | The description that appears as a ToolTip for the item.
ToolTipImage | The image to show as a part of the button extended tooltip

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace