Revit 2011 API
TextBoxData Class
Members See Also
This class contains information necessary to construct a text box in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class TextBoxData : RibbonItemData
Visual Basic (Declaration)
Public Class TextBoxData _
    Inherits RibbonItemData
Visual C++
public ref class TextBoxData : public RibbonItemData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.TextBoxData

See Also

TextBoxData Members
Autodesk.Revit.UI Namespace