Revit 2011 API
MassZoneMaterialType Enumeration
See Also
MassZone material type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum MassZoneMaterialType
Visual Basic (Declaration)
Public Enumeration MassZoneMaterialType
Visual C++
public enum class MassZoneMaterialType

Members

Member name | Description
MaterialBySurfaceType | Material for a given face of a MassZone comes from the category of the face of the MassEnergyAnalyticalModel that the MassZone face is created from.
NormalMaterial | If materialId is InvalidElementId, all faces of the MassZone will use the material from the MassZone category object style. If materialId is a valid material, all faces of the MassZone will use that specific material.

Remarks

Indicates how MassZone material is calculated.

See Also

Autodesk.Revit.DB.Analysis Namespace