Revit 2011 API
StructuralWallUsage Enumeration
See Also
Represents the structural usage of a wall.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum StructuralWallUsage
Visual Basic (Declaration)
Public Enumeration StructuralWallUsage
Visual C++
public enum class StructuralWallUsage

Members

Member name | Description
NonBearing | Structural usage is non-bearing.
Bearing | Structural usage is bearing.
Shear | Structural usage is shear.
Combined | Structural usage is combined.

See Also

Autodesk.Revit.DB.Structure Namespace