Revit 2011 API
FamilyInstance..::.ExtensionUtility Property
FamilyInstance Class See Also
Property to check whether the instance can be extended and return the interface for extension operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IExtension ExtensionUtility { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtensionUtility As IExtension
Visual C++
public:
property IExtension^ ExtensionUtility {
    IExtension^ get ();
}

Remarks

If the family instance can not support extension operation, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

FamilyInstance Class