Revit 2011 API
DocumentChangedEventArgs Methods
DocumentChangedEventArgs Class See Also

The DocumentChangedEventArgs type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddedElementIds | Returns set of elements newly added to the document
GetDeletedElementIds | Returns set of elements that were deleted from the document
GetDocument | Returns document associated with this event
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetModifiedElementIds | Returns set of elements that were modified
GetTransactionNames | Returns names of the transactions associated with this event
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace