Revit 2011 API
FilterableValueProvider Members
FilterableValueProvider Class Methods See Also

The FilterableValueProvider type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDoubleValue | Gets a double-precision numeric value from the given element.
GetElementIdValue | Gets an ElementId value from the given element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntegerValue | Gets an integer value from the given element.
GetStringValue | Gets a string value from the given element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
IsStringValueSupported | Determines whether the provide can provide a string value for the given element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterableValueProvider Class