Revit 2011 API
GeometryElement Members
GeometryElement Class Methods Properties See Also

The GeometryElement type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MaterialElement | Element describing the material from which this element is composed.
Objects | All geometric primitives contained in the element.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryElement Class