Revit 2011 API
DocumentChangedEventArgs..::.GetTransactionNames Method
DocumentChangedEventArgs Class See Also
Returns names of the transactions associated with this event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<string> GetTransactionNames()
Visual Basic (Declaration)
Public Function GetTransactionNames As IList(Of String)
Visual C++
public:
IList<String^>^ GetTransactionNames()

Return Value

The names of the transactions associated with this event

Remarks

Typically, there will be only one name in the array, because document changes mostly involve just one transaction

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace