Revit 2011 API
ConceptualConstructionType..::.IsValidSubcategoryForMassSurfaceDatas Method
ConceptualConstructionType Class See Also
Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassWindow
  9. OST_MassSkylights
  10. OST_MassOpening

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool IsValidSubcategoryForMassSurfaceDatas(
    ElementId massSubCategoryId
)
Visual Basic (Declaration)
Public Shared Function IsValidSubcategoryForMassSurfaceDatas ( _
    massSubCategoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidSubcategoryForMassSurfaceDatas(
    ElementId^ massSubCategoryId
)

Parameters

massSubCategoryId
Type: Autodesk.Revit.DB..::.ElementId
The mass sub-category to be checked.

Return Value

True if the mass sub-category falls within the list, false otherwise.

Remarks

This excludes sub-categories which are not actually sub-categories that can be assigned to surfaces, such as OST_MassWallsAll for example.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace