Revit 2011 API
MassSurfaceData Class
Members See Also
Holds properties and other data about a face in the MassEnergyAnalyticalModel element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class MassSurfaceData : Element
Visual Basic (Declaration)
Public Class MassSurfaceData _
    Inherits Element
Visual C++
public ref class MassSurfaceData : public Element

Remarks

Properties stored in the MassSurfaceData can be used in regeneration by the MassEnergyAnalyticalModel. For example, faces of the MassEnergyAnalyticalModel take their material values from the settings in the MassSurfaceData.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.MassSurfaceData

See Also

MassSurfaceData Members
Autodesk.Revit.DB.Analysis Namespace