Revit 2011 API
Conduit Class
Members See Also
This class represents a conduit in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Conduit : CableTrayConduitBase
Visual Basic (Declaration)
Public Class Conduit _
    Inherits CableTrayConduitBase
Visual C++
public ref class Conduit : public CableTrayConduitBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Electrical..::.CableTrayConduitBase
Autodesk.Revit.DB.Electrical..::.Conduit

See Also

Conduit Members
Autodesk.Revit.DB.Electrical Namespace