Revit 2011 API
ElementCategoryFilter Constructor (ElementId, Boolean)
ElementCategoryFilter Class See Also
Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementCategoryFilter(
    ElementId categoryId,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    categoryId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementCategoryFilter(
    ElementId^ categoryId,
    bool inverted
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::.ElementId
The category id to match.
inverted
Type: System..::.Boolean
True if the filter should match all elements which are not of the given category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload