Revit 2011 API
TextBox Class
Members See Also
The TextBox object represents text-based control that allows the user to enter text.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class TextBox : RibbonItem
Visual Basic (Declaration)
Public Class TextBox _
    Inherits RibbonItem
Visual C++
public ref class TextBox : public RibbonItem

Remarks

The ItemText property inherited from RibbonItem has no effect. The text entered in the TextBox is edited by the UI user is accepted only if the user presses the Enter key or click the image button when ShowImageAsButton is true. If the user clicks off of this component without pressing Enter or click the image button; then the text will be reverted to the previous value. Use of this class is not supported in Revit VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.TextBox

See Also

TextBox Members
Autodesk.Revit.UI Namespace