Revit 2011 API
View3D..::.IsPerspective Property
View3D Class See Also
Identifies whether this is a perspective view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPerspective { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPerspective As Boolean
Visual C++
public:
property bool IsPerspective {
    bool get ();
}

Remarks

If this is false, the view is orthographic - the view direction is constant. In a perspective view, view direction is variable - it is the direction that connects a particular point on the model with the eye position. The view direction property becomes less meaningful - it only describes the general orientation of the camera.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | The view is a template and does not have a perspective setting applied.

See Also

View3D Class