Revit 2011 API
FamilyInstance..::.GetFamilyPointPlacementReferences Method
FamilyInstance Class See Also
Returns the Point Placement References for the Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<FamilyPointPlacementReference> GetFamilyPointPlacementReferences()
Visual Basic (Declaration)
Public Function GetFamilyPointPlacementReferences As IList(Of FamilyPointPlacementReference)
Visual C++
public:
IList<FamilyPointPlacementReference^>^ GetFamilyPointPlacementReferences()

Remarks

If a family instance has point placement references then they are returned by this method, otherwise an empty collection is returned. Examples of FamilyInstance objects that contain placement references are Panels and Flexible Components.

See Also

FamilyInstance Class