Revit 2011 API
ConceptualConstructionType..::.IsValidConceptualConstructionIdForCategory Method
ConceptualConstructionType Class See Also
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool IsValidConceptualConstructionIdForCategory(
    Document ccda,
    ElementId constructionTypeId,
    ElementId massSubcategoryId
)
Visual Basic (Declaration)
Public Shared Function IsValidConceptualConstructionIdForCategory ( _
    ccda As Document, _
    constructionTypeId As ElementId, _
    massSubcategoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidConceptualConstructionIdForCategory(
    Document^ ccda,
    ElementId^ constructionTypeId,
    ElementId^ massSubcategoryId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The document.
constructionTypeId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the ConceptualConstructionType.
massSubcategoryId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the Mass subcategory.

Return Value

Returns true if valid, false otherwise

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId constructionTypeId is not an id of a ConceptualConstructionType. -or- The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassWindow, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace