Revit 2011 API
Arc Properties
Arc Class See Also

The Arc type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Center | Returns the center of the arc.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Normal | Returns the normal to the plane in which the arc is defined.
Period | The period of this curve. (Inherited from Curve.)
Radius | Returns the radius of the arc.
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Arc Class