Revit 2011 API
AnnotationSymbol Members
AnnotationSymbol Class Methods Properties See Also

The AnnotationSymbol type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
addLeader | add a leader to this annotation symbol.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
duplicate | Duplicate this annotation symbol.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
FlipFromToRoom | Change the room to which the door or window is opened. (Inherited from FamilyInstance.)
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCopings | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
removeLeader | remove a leader of this annotation symbol.
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
SetCopings | Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
CanRotate | Property to test whether the family instance can be rotated by 180 degree. (Inherited from FamilyInstance.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Leaders | Get all the leaders of this annotation symbol.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
SubComponents | Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AnnotationSymbol Class