Revit 2011 API
SymbolicCurve Class
Members See Also
A curve that provides information but is not intended to represent actual geometry in an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SymbolicCurve : CurveElement
Visual Basic (Declaration)
Public Class SymbolicCurve _
    Inherits CurveElement
Visual C++
public ref class SymbolicCurve : public CurveElement

Remarks

For example, when creating a door family, you might sketch symbolic lines in an elevation view to represent a door swing. Symbolic curves are visible parallel to the view in which you sketch them.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.SymbolicCurve

See Also

SymbolicCurve Members