Revit 2011 API
InternalException Class
Members See Also
The exception that is thrown when an issue in the Revit code resulted in an unexpected error.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class InternalException : ApplicationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InternalException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class InternalException : public ApplicationException

Remarks

Please contact Autodesk Developer Support with the information about what led to this exception.

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InternalException

See Also

InternalException Members
Autodesk.Revit.Exceptions Namespace