Revit 2011 API
ConceptualConstructionType..::.GetGBSId Method
ConceptualConstructionType Class See Also
Gets the Green Building Studio identifier associated with the construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public int GetGBSId(
    ElementId massSurfaceSubCategoryId
)
Visual Basic (Declaration)
Public Function GetGBSId ( _
    massSurfaceSubCategoryId As ElementId _
) As Integer
Visual C++
public:
int GetGBSId(
    ElementId^ massSurfaceSubCategoryId
)

Parameters

massSurfaceSubCategoryId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of a valid Mass subcategory of a MassSurfaceData.

Return Value

Returns the integer id used to represent the ConceptualConstructionType.

Remarks

Sometimes the GBSId is different for the same ConceptualConstructionType depending on the mass subcategory it is related to. This is usually the case, for example, for window and skylight constructions, which do not share GBSid's even when they share ConceptualConstructionTypes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input Element massSurfaceSubCategoryId is not a valid subcategory value for MassSurfaceData. -or- The ElementId massSurfaceSubCategoryId is not appropriate for this ConceptualConstructionType.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace