Revit 2011 API
MassEnergyAnalyticalModel..::.GetMassEnergyAnalyticalModelIdForMassInstance Method
MassEnergyAnalyticalModel Class See Also
Get the ElementId of the MassEnergyAnalyticalModel for a mass instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetMassEnergyAnalyticalModelIdForMassInstance(
    Document document,
    ElementId massInstanceId
)
Visual Basic (Declaration)
Public Shared Function GetMassEnergyAnalyticalModelIdForMassInstance ( _
    document As Document, _
    massInstanceId As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ GetMassEnergyAnalyticalModelIdForMassInstance(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
ElementId of a mass instance.

Return Value

ElementId of a MassEnergyAnalyticalModel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace