Revit 2011 API
SharedParameterApplicableRule Members
SharedParameterApplicableRule Class Constructors Methods Properties See Also

The SharedParameterApplicableRule type exposes the following members.

Constructors

Name | Description
SharedParameterApplicableRule | Constructs an instance of SharedParameterApplicableRule.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ParameterName | The name of the parameter that an element must support to pass this rule.

See Also

SharedParameterApplicableRule Class