Revit 2011 API
Rebar Members
Rebar Class Methods Properties See Also

The Rebar type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ScaleToBox | Move and resize the bar to fit within a specified box.
ScaleToBoxForSpiral | Move and resize a spiral instance to fit within a specified box.
SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ArrayLength | Identifies the distribution path length of rebar set.
BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
BarType | Return the type of the rebar.
BaseFinishingTurns | For a spiral, the number of finishing turns at the lower end of the spiral.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | The centerline of the Rebar.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | For a spiral, the overall height.
Host | The element that contains the rebar.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IncludeFirstBar | Identifies if the first bar in rebar set is shown.
IncludeLastBar | Identifies if the last bar in rebar set is shown.
IsShownInFrontOfGeometryInView | Obsolete. Control placement of the rebar graphics in the viewing planes.
LayoutRule | Identifies the layout rule of rebar set.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfBarPositions | Identifies the number of bar positions in rebar set.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Pitch | For a spiral, the pitch, or vertical distance traveled in one rotation.
Quantity | Identifies the number of bars in rebar set.
RebarShape | Get/Set the RebarShape associated with the Rebar.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TopFinishingTurns | For a spiral, the number of finishing turns at the upper end of the spiral.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace