Revit 2011 API
GeometryObject Class
Members See Also
The common base class for all geometric primitives.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GeometryObject : APIObject
Visual Basic (Declaration)
Public Class GeometryObject _
    Inherits APIObject
Visual C++
public ref class GeometryObject : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Curve
Autodesk.Revit.DB..::.Edge
Autodesk.Revit.DB..::.Face
Autodesk.Revit.DB..::.GeometryElement
Autodesk.Revit.DB..::.GeometryInstance
Autodesk.Revit.DB..::.Mesh
Autodesk.Revit.DB..::.Point
Autodesk.Revit.DB..::.Profile
Autodesk.Revit.DB..::.Solid

See Also

GeometryObject Members