Revit 2011 API
AnalyticalModel..::.IsValidManualAdjustmentTarget Method
AnalyticalModel Class See Also
Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidManualAdjustmentTarget(
    Reference target,
    Reference source,
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function IsValidManualAdjustmentTarget ( _
    target As Reference, _
    source As Reference, _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidManualAdjustmentTarget(
    Reference^ target,
    Reference^ source,
    AnalyticalDirection direction
)

Parameters

target
Type: Autodesk.Revit.DB..::.Reference
Identifies target reference.
source
Type: Autodesk.Revit.DB..::.Reference
Identifies source reference. This is necessary to avoid illegal conditions. For instance if Element A is manually adjusted against Element B, Element B cannot in general be adjusted against Element A.
direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which source Element can be adjusted against target Element.

Return Value

True if reference can be used, false otherwise.

Remarks

This method is useful for determining if a reference is acceptable for a target. In other words, if the reference identifies an Analytical Model portion that can be adjusted against.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace