Revit 2011 API
ComboBox Class
Members See Also
This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ComboBox : RibbonItem
Visual Basic (Declaration)
Public Class ComboBox _
    Inherits RibbonItem
Visual C++
public ref class ComboBox : public RibbonItem

Remarks

The order of items shown in the ComboBox depends upon the order which they were added, unless the ComboBoxMembers have been assigned to groups. If the members have been assigned groups, they will be sorted to fall under their groups regardless of the order in which they were added. Use of this class is not supported in Revit VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.ComboBox

See Also

ComboBox Members
Autodesk.Revit.UI Namespace