Revit 2011 API
MassZone..::.GetMassDataElementIdForZoneFaceReference Method
MassZone Class See Also
MassZone faces come from faces of MassEnergyAnalyticalModel, and those faces have MassSurfaceData or MassLevelData elements associated with them.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId GetMassDataElementIdForZoneFaceReference(
    Reference referenceOfZone
)
Visual Basic (Declaration)
Public Function GetMassDataElementIdForZoneFaceReference ( _
    referenceOfZone As Reference _
) As ElementId
Visual C++
public:
ElementId^ GetMassDataElementIdForZoneFaceReference(
    Reference^ referenceOfZone
)

Parameters

referenceOfZone
Type: Autodesk.Revit.DB..::.Reference
Reference to face of the MassZone to get data element for.

Return Value

Id of MassSurfaceData or MassLevelData element.

Remarks

This element will contain the properties associated with the MassEnergyAnalyticalModel face or MassLevelData that the MassZone Face is derived from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input Reference is not a face Reference of this MassZone.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace