Revit 2011 API
FamilyManager..::.CurrentType Property
FamilyManager Class See Also
The current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyType CurrentType { get; set; }
Visual Basic (Declaration)
Public Property CurrentType As FamilyType
Visual C++
public:
property FamilyType^ CurrentType {
    FamilyType^ get ();
    void set (FamilyType^ value);
}

Remarks

Only the current family type is editable using the methods in FamilyManager. If you want to modify the properties of any family type, it must be set to be the current type first. This value will be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no type in the family. In order to modify parameter values, you will need to create one using NewType(String).

See Also

FamilyManager Class