Revit 2011 API
CurveByPointsUtils..::.GetFaceRegions Method
CurveByPointsUtils Class See Also
Gets the FaceRegions in the existing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static IList<Reference> GetFaceRegions(
    Document cda,
    Reference referenceOfFace
)
Visual Basic (Declaration)
Public Shared Function GetFaceRegions ( _
    cda As Document, _
    referenceOfFace As Reference _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetFaceRegions(
    Document^ cda,
    Reference^ referenceOfFace
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
The Document.
referenceOfFace
Type: Autodesk.Revit.DB..::.Reference
The Reference of the existing face.

Return Value

The FaceRegions in the existing face, or an empty collection if no FaceRegions are found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The Reference is not a Face Reference.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class