Revit 2011 API
FamilyItemFactory Members
FamilyItemFactory Class Methods Properties See Also

The FamilyItemFactory type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
NewAngularDimension | Overloaded. Creates a new angular dimension object.
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
NewArcLengthDimension | Overloaded. Creates a new arc length dimension object.
NewBlend | Add a new Blend instance into the Autodesk Revit family document.
NewControl | Add a new control into the Autodesk Revit family document.
NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
NewDimension | Overloaded. Creates a new linear dimension object.
NewDividedSurface | Create a DividedSurface element on one surface of another element.
NewDuctConnector | Add a new duct connector into the Autodesk Revit family document.
NewElectricalConnector | Add a new Electrical connector into the Autodesk Revit family document.
NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
NewLinearDimension | Overloaded. Creates a new linear dimension object.
NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
NewModelText | Create a model text in the Autodesk Revit family document.
NewOpening | Create an opening to cut the wall or ceiling.
NewPipeConnector | Add a new pipe connector into the Autodesk Revit family document.
NewRadialDimension | Overloaded. Creates a new radial dimension object.
NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePoint | Overloaded. Creates a reference point.
NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSweep | Overloaded. Adds a new sweep form to the family document.
NewSweptBlend | Overloaded. Adds a new swept blend into the family document.
NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
NewView3D | Creates a new 3D view. (Inherited from ItemFactoryBase.)
NewViewPlan | Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
NewViewSection | Creates a new section view. (Inherited from ItemFactoryBase.)
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace