Revit 2011 API
Application Class
Members See Also
The Application Creation object is used to create new instances of utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Application : APIObject
Visual Basic (Declaration)
Public Class Application _
    Inherits APIObject
Visual C++
public ref class Application : public APIObject

Remarks

General purpose objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Creation..::.Application

See Also

Application Members
Autodesk.Revit.Creation Namespace