Revit 2011 API
SolidSolidCutUtils Members
SolidSolidCutUtils Class Methods See Also

The SolidSolidCutUtils type exposes the following members.

Methods

Name | Description
AddCutBetweenSolids | Add the solid-solid cut for the two elements
CanElementCutElement | Verifies if the cutting element can add a solid cut to the cut element.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCuttingSolids | Get all the solids which cut the input element
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSolidsBeingCut | Get all the solids which are cut by the input element
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
IsElementFromAppropriateContext | Validates that the element is in an appropriate document.
RemoveCutBetweenSolids | Remove the solid-solid cut for the two elements (uncut)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidSolidCutUtils Class