Revit 2011 API
FailureDefinition Class
Members See Also
Defines persistent information about a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinition : IDisposable
Visual Basic (Declaration)
Public Class FailureDefinition _
    Implements IDisposable
Visual C++
public ref class FailureDefinition : IDisposable

Remarks

Each failure that can be potentially posted in Revit must be based on a FailureDefinition object that contains some persistent information about failure such as identity, severity, basic description text, types of resolution and default resolution. Each FailureMessage, which contains variable part of the information for a specific failure when it occurs, is created with a reference to a registered FailureDefinition. In order to be able to post a failure, one must define and register it via FailureDefinition object during Revit Application startup.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureDefinition

See Also

FailureDefinition Members