Revit 2011 API
XYZ..::.Divide Method
XYZ Class See Also
Divides this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Divide(
    double value
)
Visual Basic (Declaration)
Public Function Divide ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Divide(
    double value
)

Parameters

value
Type: System..::.Double
The value to divide this vector by.

Return Value

The divided vector.

Remarks

The divided vector is obtained by dividing each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number or zero.

See Also

XYZ Class