Revit 2011 API
FailuresAccessor..::.JournalFailures Method
FailuresAccessor Class See Also
Allows to record information about failures in the journal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void JournalFailures(
    IList<FailureMessageAccessor> failures
)
Visual Basic (Declaration)
Public Sub JournalFailures ( _
    failures As IList(Of FailureMessageAccessor) _
)
Visual C++
public:
void JournalFailures(
    IList<FailureMessageAccessor^>^ failures
)

Parameters

failures
Type: System.Collections.Generic..::.IList <(Of <( FailureMessageAccessor >)>)
Accessors to the failures to journal.

Remarks

Records information about failure messages and elements involved in the failures. If this method not invoked, journal does not contain any information about failures resolved by (pre)processing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class