Revit 2011 API
ViewPrintedEventArgs Properties
ViewPrintedEventArgs Class See Also

The ViewPrintedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | View that was printed.

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace