Revit 2011 API
MassZone Class
Members See Also
MassZones are created from the MassEnergyAnalyticalModel. They are conceptual representions of individually heated and cooled sub-volumes of a building.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class MassZone : Element
Visual Basic (Declaration)
Public Class MassZone _
    Inherits Element
Visual C++
public ref class MassZone : public Element

Remarks

MassZones are created by dividing a MassEnergyAnalyticalModel into pieces by intersecting MassLevelDatas associated with a Mass FamilyInstance with the geometries of the MassEnergyAnalyticalModel associated with the same Mass FamilyInstance.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.MassZone

See Also

MassZone Members
Autodesk.Revit.DB.Analysis Namespace