Revit 2011 API
ConditionType Enumeration
See Also
An enumerated type listing all the possible condition types for a space object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ConditionType
Visual Basic (Declaration)
Public Enumeration ConditionType
Visual C++
public enum class ConditionType

Members

Member name | Description
Heated | Condition Type is Heated.
Cooled | Condition Type is Cooled.
HeatedAndCooled | Condition Type is HeatedAndCooled.
Unconditioned | Condition Type is Unconditioned.
Vented | Condition Type is Vented.
NaturallyVentedOnly | Condition Type is NaturallyVentedOnly.
NoOfConditionTypes | Condition Type is NoOfConditionTypes.

See Also

Autodesk.Revit.DB.Mechanical Namespace