Revit 2011 API
BuiltInFailures..::.SketchFailures Members
BuiltInFailures..::.SketchFailures Class Properties See Also

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SketchFailures type exposes the following members.

Properties

Name | Description
AreaLoadNoForce | Area Load can't have all force components equal to zero.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
AxisNotSpecified | Axis of revolution not specified.
BadNosingProfile | Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.
BadRailingsProfile | Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.
BeamDirectionNotSpecified | Beam direction not specified.
BeamDirectionNotSpecifiedError | Beam direction not specified.
BuildingPadNoSurface | A Pad can't extend beyond the edge of a Toposurface.
BuildingPadNoSurfaceError | A Pad can't extend beyond the edge of a Toposurface.
CannotChangeUserSketchPlane | Can't change plane of [Element Name] Sketch.
CannotChangeUserSketchPlaneError | Can't change plane of [Element Name] Sketch.
CannotChangeWorkplaneVisibility | Can't change Work Plane Visibility.
CannotComputeRailingsElevation | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationError | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationWarn | Can't compute Railings Elevation Profile
CannotConvertSketch | Can't convert Sketch to Rebar Shape.
CannotDrawExtrusionRoof | Can't make extruded roof.
CannotDrawProfileRoof | Can't make footprint roof.
CannotGetSketchReferences | Cannot find references to dimension sketch.
CannotHaveArcs | Sorry, we can't use arcs here.
CannotHaveArcsPath3d | Sorry, we can't use arcs here.
ClosedProfileRoof | Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.
ConstantHeightNotParallel | Constant-height-defining lines must be parallel.
ConstantHeightNotParallelError | Constant-height-defining lines must be parallel.
ContainedInOtherLoops | When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.
ConvertSplineToLineFailed | Failed to convert spline to straight line
CurveFromPickedFailed | Can't create boundary from pick.
CurveIntersectsCutFace | The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.
CurveIntersectsSplitFace | The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.
CurveTooShort | Line is too short.
DifferentOffsets | Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.
ElementsSketchTooLarge | The sketch defining the highlighted element is too large.
EndsNotOnCutFace | Ends of the sketched loop do not lie on the boundary of the face being modified.
EndsNotOnEdge | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
FloorCannotAddDirectionCurve | Cannot add the direction curve in the floor sketch.
FloorCannotAddDirectionCurveError | Cannot add the direction curve in the floor sketch.
FloorDirectionNotSpecified | Structural floor span direction not specified.
FloorManyDirectionCurves | More than one span direction curve specified.
HostFinishOverlapOld | Host Finish overlapped.
InvalidAreaLoadSketch | Area Load has invalid Sketch.
InvalidAreaLoadSketchError | Area Load has invalid Sketch.
InvalidElevationSketch | Elevation Profile sketch is invalid.
InvalidElevationSketchError | Elevation Profile sketch is invalid.
InvalidProfile | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidProfileError | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidRoofCurveloop | Base sketch for roof is invalid.
InvalidRoofCurveloopError | Base sketch for roof is invalid
InvalidRoofCurveloopFailure | Base sketch for roof is invalid
InvalidSketch | Sketch is invalid.
InvalidSketchError | Sketch is invalid.
InvalidSketchForBuildingpad | Pad sketch is invalid.
InvalidSketchForBuildingpadError | Pad sketch is invalid.
InvalidSketchForCeiling | Ceiling sketch is invalid.
InvalidSketchForFloor | Floor sketch is invalid.
InvalidSketchForRoofsoffit | Roof Soffit sketch is invalid.
InvalidSketchPath3d | Sketch is invalid.
LinesOverlap | Cannot have overlapping lines.
LinesOverlapError | Cannot have overlapping lines.
LinesOverlapPath3d | Cannot have overlapping lines.
LoopIntersect | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectError | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectPath3d | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopsOutsideFaceSplit | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
LoopsOutsideFaceSplitterTooShort | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
ManyCCWLoops | Area defined by sketch must be connected.
ManyCCWLoopsError | Area defined by sketch must be connected.
ManyDirectionCurves | More than one direction curve specified.
ManyDirectionCurvesError | More than one direction curve specified.
MoreThanOneAxis | More than one axes of revolution.
NestedLoops | Cannot have nested loops.
NoLoops | Sketch is empty.
NoLoopsError | Sketch is empty.
NoLoopsPath3d | Sketch is empty.
NonMonotoneRoof | All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.
NoPlane | Highlighted geometry no longer determines a plane
NotOneCCWLoop | This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.
NotOneCurve | More than one curve not allowed.
NotOneCurveError | More than one curve not allowed.
NotOneCurvePath3d | More than one curve not allowed.
NotOneLoop | More than one loop not allowed.
NotOneLoopPath3d | More than one loop not allowed.
OpenAreaLoadLoop | Area Load Sketch can't contain open loops.
OpenAreaLoadLoopError | Area Load Sketch can't contain open loops.
OpenLoop | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopError | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopPath3d | Lines must be in closed loops. The highlighted lines are open on one end.
PathCannotBeClosedLoop | Path can not be a closed loop.
PathCannotBeClosedLoopPath3d | Path can not be a closed loop.
PathReinforcementClosedLoop | Sketch contains a closed loop. Can't create Path Reinforcement.
PathReinforcementEmptySketch | Sketch is empty. Can't create Path Reinforcement.
PathReinforcementManyLoops | Sketch contains more than one chain. Can't create Path Reinforcement.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingDoublyConnectedError | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailingNotConnectedError | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RebarEmptySketch | Rebar Sketch is empty. Can't create Rebar.
RebarEmptySketchError | Rebar Sketch is empty. Can't create Rebar.
RebarManyLoops | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarManyLoopsError | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarSystemDirectionNotSpecified | Major direction not specified.
RebarSystemDirectionNotSpecifiedError | Major direction not specified.
SculptingCurvesCannotFormClosedLoop | Curves cannot form a closed loop.
SculptingCurvesCrossAxis | The highlighted curves cross the axis.
SculptingCurvesTouchAxis | The highlighted curves touch the axis.
SculptingLoopsOnBothSidesOfAxis | All curves must be on the same side of the axis.
SculptingSingleLineLoopLiesOnAxis | The highlighted lines lie on the axis.
ShortCurveInSketch | The sketch contains an extremely short line.
ShortCurveInSketchRoof | The sketch contains an extremely short line.
SiteCannotDrawSurfaceBoundary | Cannot make surface with specified boundary.
SketchFailurePlanes | Sketch is no longer parallel to its defining plane
SketchingInTheWrongView | Detail sketch is only editable in [View Type].
SketchingInWrongView | Detail sketch is not editable in this view.
SketchOverconstrained | Sketch is overconstrained.
SketchOverconstrainedError | Sketch is overconstrained.
SketchOverconstrainedWarn | Sketch is overconstrained.
SketchTooLarge | Sketch is too large.
SketchWasDeleted | Sketch was deleted.
StairClosedBoundaries | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairClosedBoundariesError | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairNotEnoughBoundaryCurves | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughBoundaryCurvesError | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughRiserCurves | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairNotEnoughRiserCurvesError | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairOnlyOneConnectedBoundary | Stairs require no less than two boundaries (chains of one or more Boundary Lines)."
StairRiserDoesntIntersectBoundary | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairTooManyConnectedBoundaries | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
StairTooManyConnectedBoundariesError | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
SuggestMakingFamilyNonParametric | Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.
SuspendedSketchWarn | Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem
TooFewParamsForSketch | The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.
TooManyElementsInSketch | This sketch is large. Performance will improve if constructed as several independent sketches.
TooManySlopes | There is more than one slope defined.
TooManySlopesError | There is more than one slope defined.
TrussClosedReference | Truss references (chains of one or more reference lines) should not form closed loops."
TrussCrossingReferences | Truss top and bottom references cannot cross.
TrussMissingReference | Trusses require both a top and a bottom chord reference (chain of one or more reference lines).
TrussOverlappingReference | Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.
TrussSegmentedReference | Truss reference must form a continuous chain of one or more sketch lines.
TrussShiftedReferences | Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.
TrussSwappedReferences | Truss top reference must be above the bottom reference.
UnsatisfiedSupportAssocProp | Constraint between a Line created with Pick Support and the Support is not satisfied.
UnsatisfiedWallAssocProp | Constraint between a Line created with Pick Wall and the Wall is not satisfied.
VarSketchFailure | Constraints defined by highlighted Lines and Dimensions can't be satisfied.
VarSketchInElementFailure | The constraints of the sketch defining the highlighted element cannot be satisfied.
WrongCutBoundaryLoops | Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.
WrongFaceSplitterLoopTypesNum | Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.

See Also

BuiltInFailures..::.SketchFailures Class