Revit 2011 API
FailuresAccessor..::.IsFailureResolutionPermitted Method (FailureMessageAccessor, FailureResolutionType)
FailuresAccessor Class See Also
Checks if resolution of the failure using given resolution type is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted(
    FailureMessageAccessor failure,
    FailureResolutionType resolutionType
)
Visual Basic (Declaration)
Public Function IsFailureResolutionPermitted ( _
    failure As FailureMessageAccessor, _
    resolutionType As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted(
    FailureMessageAccessor^ failure,
    FailureResolutionType resolutionType
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessageAccessor
Accessor to the failure to be resolved.
resolutionType
Type: Autodesk.Revit.DB..::.FailureResolutionType
Type of the failure resolution to be used.

Return Value

True if resolution of the failure using given resolution type is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload