Revit 2011 API
PanelScheduleData Methods
PanelScheduleData Class See Also

The PanelScheduleData type exposes the following members.

Methods

Name | Description
AddLoadClassification | add a Load Classification Id to the array of Load Classifications.
Dispose | (Inherited from TableData.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLoadClassifications | get an array of the load classifications associated with this panel schedule
GetNumberOfCircuitRows | returns the number of rows in the circuit table
GetSectionData | Returns the section data array element at the specified index. (Inherited from TableData.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Checks if this element is equal in value to the other element. (Inherited from TableData.)
IsSymmetric | returns if this panel schedule is symmetric
RemoveLoadClassification | remove a Load Classification Id from the array of Load Classifications
SetLoadClassifications | sets the Load Classifications associated with this panel schedule
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCircuitTableForInstance | redraw the circuit table for the given panel with the given parameter updates
UpdateCircuitTableForTemplate | redraw the circuit table for a template with the given parameter updates
UpdateIsSectionHidden | update if this section is hidden or not
UpdateLoadSummary | update the load summary section
UpdateVerticalHeadersInSection | set if this header should have vertical text

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace