Revit 2011 API
ParameterFilterUtilities..::.GetAllFilterableCategories Method
ParameterFilterUtilities Class See Also
Returns the set of categories that may be used in a ParameterFilterElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetAllFilterableCategories()
Visual Basic (Declaration)
Public Shared Function GetAllFilterableCategories As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAllFilterableCategories()

Return Value

The set of all filterable categories.

See Also

ParameterFilterUtilities Class