Revit 2011 API
InvalidDataStreamException Members
InvalidDataStreamException Class Methods Properties See Also

The InvalidDataStreamException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidDataStreamException Class
Autodesk.Revit.Exceptions Namespace