Revit 2011 API
SplitButton..::.IsSynchronizedWithCurrentItem Property
SplitButton Class See Also
Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsSynchronizedWithCurrentItem { get; set; }
Visual Basic (Declaration)
Public Property IsSynchronizedWithCurrentItem As Boolean
Visual C++
public:
property bool IsSynchronizedWithCurrentItem {
    bool get ();
    void set (bool value);
}

Remarks

If this property is true the SplitButton uses the current PushButton's properties to display the image, text, tooltip, etc. and executes the current item when clicked. If it is false the first listed PushButton in the GetItems() return is shown, and executes this PushButton when clicked. If it is false the items in drop down list can only be executed by opening the drop down list and clicking an item in the list. The default value is true.

See Also

SplitButton Class
Autodesk.Revit.UI Namespace