Revit 2011 API
ToggleButtonData Members
ToggleButtonData Class Constructors Methods Properties See Also

The ToggleButtonData type exposes the following members.

Constructors

Name | Description
ToggleButtonData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyName | The assembly path of the button. (Inherited from PushButtonData.)
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButtonData.)
ClassName | The name of the class containing the implementation for the command. (Inherited from PushButtonData.)
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

ToggleButtonData Class
Autodesk.Revit.UI Namespace