Revit 2011 API
CompoundStructureLayerArray Members
CompoundStructureLayerArray Class Constructors Methods Properties See Also

The CompoundStructureLayerArray type exposes the following members.

Constructors

Name | Description
CompoundStructureLayerArray | Initializes a new instance of the CompoundStructureLayerArray class

Methods

Name | Description
Append | Add the layer to the end of the array.
Clear | Removes every layer from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified layer into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a layer at a specified index within the array.
Size | Returns the number of layers that are in the array.

See Also

CompoundStructureLayerArray Class