Revit 2011 API
AnalyticalModel..::.IsValidManualAdjustmentSource Method
AnalyticalModel Class See Also
Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidManualAdjustmentSource(
    Reference source,
    AnalyticalDirection adjustmentDirection
)
Visual Basic (Declaration)
Public Function IsValidManualAdjustmentSource ( _
    source As Reference, _
    adjustmentDirection As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidManualAdjustmentSource(
    Reference^ source,
    AnalyticalDirection adjustmentDirection
)

Parameters

source
Type: Autodesk.Revit.DB..::.Reference
Reference to be examined.
adjustmentDirection
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which adjustment will occur.

Return Value

True if reference can be used as source; false otherwise.

Remarks

This method is useful for determining if a reference is acceptable for usage as a "Source". In other words, if the reference identifies an Analytical Model portion that can be adjusted by the user.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace