Revit 2011 API
FamilyItemFactory Class
Members See Also
The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyItemFactory : ItemFactoryBase
Visual Basic (Declaration)
Public Class FamilyItemFactory _
    Inherits ItemFactoryBase
Visual C++
public ref class FamilyItemFactory : public ItemFactoryBase

Remarks

The Family Item Factory object is a utility object that is used to create new instances of elements within the Autodesk Revit Family Document. This object should be used to create elements instead of using New. This object ensures that the elements created are added to the family document correctly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.Creation..::.FamilyItemFactory

See Also

FamilyItemFactory Members
Autodesk.Revit.Creation Namespace