Revit 2011 API
ComboBoxData Constructor
ComboBoxData Class See Also
Constructs a new instance of ComboBoxData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ComboBoxData(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
ComboBoxData(
    String^ name
)

Parameters

name
Type: System..::.String
The internal name of the ComboBoxMember.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for name.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for name.

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace