Revit 2011 API
StructuralType Enumeration
See Also
Represents the structural type of a family instance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum StructuralType
Visual Basic (Declaration)
Public Enumeration StructuralType
Visual C++
public enum class StructuralType

Members

Member name | Description
NonStructural | Non-Structural
Beam | Structural Beam
Brace | Structural Brace
Column | Structural Column
Footing | Structural Footing
UnknownFraming | Unknown Framing

See Also

Autodesk.Revit.DB.Structure Namespace