Revit 2011 API
ParameterFilterElement..::.GetRuleParameters Method
ParameterFilterElement Class See Also
Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<ElementId> GetRuleParameters()
Visual Basic (Declaration)
Public Function GetRuleParameters As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetRuleParameters()

Return Value

An array of parameter identifiers.

See Also

ParameterFilterElement Class