Revit 2011 API
LogicalOrFilter Constructor (ElementFilter, ElementFilter)
LogicalOrFilter Class See Also
Constructs a new instance of the logical filter with two input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public LogicalOrFilter(
    ElementFilter filter1,
    ElementFilter filter2
)
Visual Basic (Declaration)
Public Sub New ( _
    filter1 As ElementFilter, _
    filter2 As ElementFilter _
)
Visual C++
public:
LogicalOrFilter(
    ElementFilter^ filter1,
    ElementFilter^ filter2
)

Parameters

filter1
Type: Autodesk.Revit.DB..::.ElementFilter
The first filter.
filter2
Type: Autodesk.Revit.DB..::.ElementFilter
The second filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

LogicalOrFilter Class
LogicalOrFilter Overload