Revit 2011 API
DWFXExportOptions Members
DWFXExportOptions Class Constructors Methods Properties See Also

The DWFXExportOptions type exposes the following members.

Constructors

Name | Description
DWFXExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
ImageFormat | Controls the compression level of images embedded. (Inherited from DWFExportOptions.)
ImageQuality | Image quality level when compressed raster format(JPEG) is used. (Inherited from DWFExportOptions.)
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
PaperFormat | Standard paper format. (Inherited from DWFExportOptions.)
PortraitLayout | Paper orientation - Portrait/Landscape. (Inherited from DWFExportOptions.)
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWFXExportOptions Class