Revit 2011 API
Form..::.ConstrainProfiles Method
Form Class See Also
Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ConstrainProfiles(
    int masterProfileIndex
)
Visual Basic (Declaration)
Public Sub ConstrainProfiles ( _
    masterProfileIndex As Integer _
)
Visual C++
public:
void ConstrainProfiles(
    int masterProfileIndex
)

Parameters

masterProfileIndex
Type: System..::.Int32
Index to specify the profile used as master profile.

See Also

Form Class