Revit 2011 API
Line..::.Bound Property
Line Class See Also
Returns the bounded line between the specified points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static Line Bound[
    XYZ startPoint,
    XYZ endPoint
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Bound ( _
    startPoint As XYZ, _
    endPoint As XYZ _
) As Line
Visual C++
public:
static property Line^ Bound[XYZ^ startPoint, XYZ^ endPoint] {
    Line^ get (XYZ^ startPoint, XYZ^ endPoint);
}

Parameters

startPoint
Type: Autodesk.Revit.DB..::.XYZ
The start point of the line.
endPoint
Type: Autodesk.Revit.DB..::.XYZ
The end point of the line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified points are almost equal.

See Also

Line Class