Revit 2011 API
LocationCurve Class
Members See Also
Provides location functionality for all elements that are based upon a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LocationCurve : Location
Visual Basic (Declaration)
Public Class LocationCurve _
    Inherits Location
Visual C++
public ref class LocationCurve : public Location

Remarks

The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Location
Autodesk.Revit.DB..::.LocationCurve

See Also

LocationCurve Members