Revit 2011 API
Outline Constructor (XYZ, XYZ)
Outline Class See Also
Constructor that uses a minimum and maximum XYZ point to initialize the outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Outline(
    XYZ minimumPoint,
    XYZ maximumPoint
)
Visual Basic (Declaration)
Public Sub New ( _
    minimumPoint As XYZ, _
    maximumPoint As XYZ _
)
Visual C++
public:
Outline(
    XYZ^ minimumPoint,
    XYZ^ maximumPoint
)

Parameters

minimumPoint
Type: Autodesk.Revit.DB..::.XYZ
The minimum point
maximumPoint
Type: Autodesk.Revit.DB..::.XYZ
The maximum point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class
Outline Overload