Revit 2011 API
MechanicalFitting Class
Members See Also
A mechanical fitting in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MechanicalFitting : MEPModel
Visual Basic (Declaration)
Public Class MechanicalFitting _
    Inherits MEPModel
Visual C++
public ref class MechanicalFitting : public MEPModel

Remarks

The mechanical fitting is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB.Mechanical..::.MechanicalFitting

See Also

MechanicalFitting Members
Autodesk.Revit.DB.Mechanical Namespace