Revit 2011 API
EnergyDataSettings..::.CheckBuildingHVACSystem Method
EnergyDataSettings Class See Also
Checks that the building HVAC system falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingHVACSystem(
    gbXMLBuildingHVACSystem buildingHVACSystem
)
Visual Basic (Declaration)
Public Shared Function CheckBuildingHVACSystem ( _
    buildingHVACSystem As gbXMLBuildingHVACSystem _
) As Boolean
Visual C++
public:
static bool CheckBuildingHVACSystem(
    gbXMLBuildingHVACSystem buildingHVACSystem
)

Parameters

buildingHVACSystem
Type: Autodesk.Revit.DB.Analysis..::.gbXMLBuildingHVACSystem
The building HVAC system to be checked.

Return Value

True if the building HVAC system falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace