Revit 2011 API
ACADImportOptions Properties
ACADImportOptions Class See Also

The ACADImportOptions type exposes the following members.

Properties

Name | Description
ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
CustomScale | Scaling the import. (Inherited from CADImportOptions.)
LayerSelection | The layers collection for import.
LineWeights | A Byte array of line weights for the DWG/DXF Color number.
OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Placement | Where to place the import. (Inherited from CADImportOptions.)
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
VisibleLayersOnly | Only import the visible layers.

See Also

ACADImportOptions Class