Revit 2011 API
FailureDefinitionAccessor Members
FailureDefinitionAccessor Class Methods See Also

The FailureDefinitionAccessor type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
GetDefaultResolutionType | Retrieves the default resolution type for the failure.
GetDescriptionText | Retrieves the description text of the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetId | Retrieves the unique identifier of the FailureDefinition.
GetResolutionCaption | Retrieves the caption for a specific resolution type.
GetSeverity | Retrieves severity of the failure.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutions | Checks if the FailureDefinition has at least one resolution.
IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
SetDefaultResolutionType | Sets the default resolution type for the failure.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionAccessor Class