Revit 2011 API
Application..::.NewReferencePointArray Method
Application Class See Also
Creates an empty array that can store ReferencePoint objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferencePointArray NewReferencePointArray()
Visual Basic (Declaration)
Public Function NewReferencePointArray As ReferencePointArray
Visual C++
public:
ReferencePointArray^ NewReferencePointArray()

Return Value

An empty array that can hold ReferencePoint objects.

Remarks

This method can be used to create an array that can hold ReferencePoint objects. This array can be then passed to methods, such as NewCurveByPoints, to represent two or more PointElements.

See Also

Application Class
Autodesk.Revit.Creation Namespace