Revit 2011 API
AssetProperty..::.GetTypeName Method
AssetProperty Class See Also
Get the name of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static string GetTypeName(
    AssetPropertyType type
)
Visual Basic (Declaration)
Public Shared Function GetTypeName ( _
    type As AssetPropertyType _
) As String
Visual C++
public:
static String^ GetTypeName(
    AssetPropertyType type
)

Parameters

type
Type: Autodesk.Revit.Utility..::.AssetPropertyType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when type is AssetPropertyType::APT_Unknown or AssetPropertyType::APT_Last.

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace