Revit 2011 API
Zone Members
Zone Class Methods Properties See Also

The Zone type exposes the following members.

Methods

Name | Description
AddSpaces | Add a set of existing spaces to Zone element.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSpaces | Remove a set of existing spaces to the current Zone element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | Get the Area of the Zone.
Boundary | Returns the boundary of the Zone.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GrossArea | Get the Gross Area of the Zone.
GrossVolume | Get the Gross Volume of the Zone.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
HeatingSetPoint | Get or set the Heating Set Point of the Zone.
HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultZone | Reports whether this zone is default or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the Zone. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | Get the Perimeter of the Zone.
Phase | Get the Phase of the Zone.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ServiceType | Get or set the Service Type of the Zone.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Spaces | Get the Spaces of the Zone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | Get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace