Revit 2011 API
MaterialSteel Properties
MaterialSteel Class See Also

The MaterialSteel type exposes the following members.

Properties

Name | Description
Behavior | Get or set the material behavior type of the steel material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the steel material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumTensileStrength | Get or set the minimum tensile strength of the steel material.
MinimumYieldStress | Get or set the minimum yield stress of the steel material.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the steel material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the steel material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the steel material.
ReductionFactor | Get or set the reduction factor for shear of the steel material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the steel material.
ShearModulusY | Get or set the y component of the shear modulus of the steel material.
ShearModulusZ | Get or set the z component of the shear modulus of the steel material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the steel material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the steel material.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
YoungModulusX | Get or set the x component of the Young modulus of the steel material.
YoungModulusY | Get or set the y component of the Young modulus of the steel material.
YoungModulusZ | Get or set the z component of the Young modulus of the steel material.

See Also

MaterialSteel Class