Revit 2011 API
Form..::.BaseOffset Property
Form Class See Also
Retrieve/set the base offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double BaseOffset { get; set; }
Visual Basic (Declaration)
Public Property BaseOffset As Double
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this is not a locked form.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the value is invalid.
Autodesk.Revit.Exceptions..::.ApplicationException | Thrown when it fail to get/set BaseOffset.

See Also

Form Class