Revit 2011 API
MassGBXMLExportOptions Members
MassGBXMLExportOptions Class Constructors Methods See Also

The MassGBXMLExportOptions type exposes the following members.

Constructors

Name | Description
MassGBXMLExportOptions | Constructs a new instance of the options used to export a mass model to gbXML.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMassIds | Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
GetMassZoneIds | Gets a list of mass zones to analyze in the exported gbXML.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace