Revit 2011 API
ExclusionFilter Constructor
ExclusionFilter Class See Also
Constructs a new instance of a filter to exclude elements automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ExclusionFilter(
    ICollection<ElementId> idsToExclude
)
Visual Basic (Declaration)
Public Sub New ( _
    idsToExclude As ICollection(Of ElementId) _
)
Visual C++
public:
ExclusionFilter(
    ICollection<ElementId^>^ idsToExclude
)

Parameters

idsToExclude
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The ids to exclude from the results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ExclusionFilter Class