Revit 2011 API
AnalyticalModel..::.IsValidDirectionForAutoDetect Method
AnalyticalModel Class See Also
Tests whether or not the supplied direction is valid for Analytical Auto-detect.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidDirectionForAutoDetect(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function IsValidDirectionForAutoDetect ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidDirectionForAutoDetect(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which Auto-detect behavior may be valid.

Return Value

True if direction is valid, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace