Revit 2011 API
RevolvedFace Properties
RevolvedFace Class See Also

The RevolvedFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
Curve | Profile curve of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radius of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RevolvedFace Class