Revit 2011 API
gbXMLBuildingType Enumeration
See Also
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
This enumeration corresponds to the buildingType attribute in gbXML and is used to specify the most predominant building use type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLBuildingType
Visual Basic (Declaration)
Public Enumeration gbXMLBuildingType
Visual C++
public enum class gbXMLBuildingType

Members

Member name | Description
NoBuildingType |
AutomotiveFacility |
ConventionCenter |
Courthouse |
DiningBarLoungeOrLeisure |
DiningCafeteriaFastFood |
DiningFamily |
Dormitory |
ExerciseCenter |
FireStation |
Gymnasium |
HospitalOrHealthcare |
Hotel |
Library |
Manufacturing |
Motel |
MotionPictureTheatre |
MultiFamily |
Museum |
Office |
ParkingGarage |
Penitentiary |
PerformingArtsTheater |
PoliceStation |
PostOffice |
ReligiousBuilding |
Retail |
SchoolOrUniversity |
SingleFamily |
SportsArena |
TownHall |
Transportation |
Warehouse |
Workshop |
NoOfBuildingTypes |

See Also

Autodesk.Revit.DB.Analysis Namespace