Revit 2011 API
SpatialFieldManager..::.CreateSpatialFieldManager Method
SpatialFieldManager Class See Also
Factory method - creates manager object for the given view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static SpatialFieldManager CreateSpatialFieldManager(
    View view,
    int numberOfMeasurements
)
Visual Basic (Declaration)
Public Shared Function CreateSpatialFieldManager ( _
    view As View, _
    numberOfMeasurements As Integer _
) As SpatialFieldManager
Visual C++
public:
static SpatialFieldManager^ CreateSpatialFieldManager(
    View^ view,
    int numberOfMeasurements
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
View for which manager object is created or retrieved
numberOfMeasurements
Type: System..::.Int32
Total number of measurements in the calculated results. This number defines the length of value arrays in ValueAtPoint objects

Return Value

Manager object for the view passed in the argument

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | numberOfMeasurements is less than one
Autodesk.Revit.Exceptions..::.InvalidOperationException | view is not allowed to display analysis results or a manager object for this view already exists
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace