Revit 2011 API
ImageExportOptions Members
ImageExportOptions Class Constructors Methods Properties See Also

The ImageExportOptions type exposes the following members.

Constructors

Name | Description
ImageExportOptions | Constructs a new instance of the options class used to produce images.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportRange | The export range, which defines which view(s) will be exported.
FilePath | The file name and path for the exported file.
FitDirection | The fit direction. Used only if ZoomType is FitToPage.
HLRandWFViewsFileType | File type for exported HLR and wireframe views.
ImageResolution | The image resolution in dots per inch.
PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
ShadowViewsFileType | The file type for exported shadow views.
ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
ViewName | The name of the view to be created.
Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
ZoomType | The zoom type, which defines how the image size is determined.

See Also

ImageExportOptions Class