Revit 2011 API
EnergyDataSettings..::.CheckRangeOfShadeDepth Method
EnergyDataSettings Class See Also
Checks that the shade depth is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfShadeDepth(
    double shadeDepth
)
Visual Basic (Declaration)
Public Shared Function CheckRangeOfShadeDepth ( _
    shadeDepth As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfShadeDepth(
    double shadeDepth
)

Parameters

shadeDepth
Type: System..::.Double
The shade depth to be checked.

Return Value

True if the shade depth is greater than or equal to zero, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace