Revit 2011 API
FilteredElementCollector..::.UnionWith Method
FilteredElementCollector Class See Also
Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector UnionWith(
    FilteredElementCollector other
)
Visual Basic (Declaration)
Public Function UnionWith ( _
    other As FilteredElementCollector _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ UnionWith(
    FilteredElementCollector^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::.FilteredElementCollector
The other collector

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The result will be the same as using a LogicalOrFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class