Revit 2011 API
BindingMap Methods
BindingMap Class See Also

The BindingMap type exposes the following members.

Methods

Name | Description
Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::.Clear()()().)
Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::.Contains(Definition).)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::.Erase(Definition).)
ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Overloaded. Creates a new parameter binding.
ReInsert | Overloaded. Removes an existing parameter and creates a new binding for a given parameter.
Remove | The Remove method is used to remove a parameter binding.
ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BindingMap Class