Revit 2011 API
SpatialFieldManager Methods
SpatialFieldManager Class See Also

The SpatialFieldManager type exposes the following members.

Methods

Name | Description
AddSpatialFieldPrimitive | Overloaded.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Clear | Clear all analysis results managed by this manager object
CreateSpatialFieldManager | Factory method - creates manager object for the given view
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLegend | Returns legend element or NULL
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSpatialFieldPrimitive | Removes analysis results container (primitive) identified by the unique index
SetMeasurementNames | sets Names for all measurements
SetUnits | Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSpatialFieldPrimitive | Populates analysis results data (or replaces the existing data) in the existing container (primitive) identified by the unique index

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace