Revit 2011 API
Solid Properties
Solid Class See Also

The Solid type exposes the following members.

Properties

Name | Description
Edges | The edges that belong to the solid.
Faces | The faces that belong to the solid.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SurfaceArea | Returns the total surface area of this solid.
Visibility | The visibility. (Inherited from GeometryObject.)
Volume | Returns the signed volume of this solid.

See Also

Solid Class