Revit 2011 API
FormatOptions Class
Members See Also
Contains the Unit information of current user selection of Unit within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FormatOptions : APIObject
Visual Basic (Declaration)
Public Class FormatOptions _
    Inherits APIObject
Visual C++
public ref class FormatOptions : public APIObject

Remarks

The FormatOptions contains 5 item. Rounding and UnitSymbol properties depend on the Units propery.All these three properties provided set function, but it is more rigid on input.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FormatOptions

See Also

FormatOptions Members