Revit 2011 API
CurveByPointsUtils..::.ValidateCurveElementIdArrayForFaceRegions Method
CurveByPointsUtils Class See Also
Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added the the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool ValidateCurveElementIdArrayForFaceRegions(
    Document document,
    IList<ElementId> curveElemIds
)
Visual Basic (Declaration)
Public Shared Function ValidateCurveElementIdArrayForFaceRegions ( _
    document As Document, _
    curveElemIds As IList(Of ElementId) _
) As Boolean
Visual C++
public:
static bool ValidateCurveElementIdArrayForFaceRegions(
    Document^ document,
    IList<ElementId^>^ curveElemIds
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
curveElemIds
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
The CurveElements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class