Revit 2011 API
RadioButtonGroup Class
Members Example See Also
Represents a group of related buttons in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class RadioButtonGroup : RibbonItem
Visual Basic (Declaration)
Public Class RadioButtonGroup _
    Inherits RibbonItem
Visual C++
public ref class RadioButtonGroup : public RibbonItem

Remarks

This class contains a collection of ToggleButtons. Only one of the ToggleButtons will appear active at a given time. When a different button is clicked in the UI the current ToggleButton will be changed, and the ToggleButton's external command will be invoked. Use of this class is not supported in Revit VSTA.

Examples

CopyC#
private void AddRadioGroup(RibbonPanel panel)
{
    // add radio button group
    RadioButtonGroupData radioData = new RadioButtonGroupData("radioGroup");
    RadioButtonGroup radioButtonGroup = panel.AddItem(radioData) as RadioButtonGroup;

    // create toggle buttons and add to radio button group
    ToggleButtonData tb1 = new ToggleButtonData("toggleButton1", "Red");
    tb1.ToolTip = "Red Option";
    tb1.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Red.bmp"));
    ToggleButtonData tb2 = new ToggleButtonData("toggleButton2", "Green");
    tb2.ToolTip = "Green Option";
    tb2.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Green.bmp"));
    ToggleButtonData tb3 = new ToggleButtonData("toggleButton3", "Blue");
    tb3.ToolTip = "Blue Option";
    tb3.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Blue.bmp"));
    radioButtonGroup.AddItem(tb1);
    radioButtonGroup.AddItem(tb2);
    radioButtonGroup.AddItem(tb3);
}
CopyVB.NET
Private Sub AddRadioGroup(ByVal panel As RibbonPanel)
    ' add radio button group
    Dim radioData As New RadioButtonGroupData("radioGroup")
    Dim radioButtonGroup As RadioButtonGroup = TryCast(panel.AddItem(radioData), RadioButtonGroup)

    ' create toggle buttons and add to radio button group
    Dim tb1 As New ToggleButtonData("toggleButton1", "Red")
    tb1.ToolTip = "Red Option"
    tb1.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Red.bmp"))
    Dim tb2 As New ToggleButtonData("toggleButton2", "Green")
    tb2.ToolTip = "Green Option"
    tb2.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Green.bmp"))
    Dim tb3 As New ToggleButtonData("toggleButton3", "Blue")
    tb3.ToolTip = "Blue Option"
    tb3.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Blue.bmp"))
    radioButtonGroup.AddItem(tb1)
    radioButtonGroup.AddItem(tb2)
    radioButtonGroup.AddItem(tb3)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.RadioButtonGroup

See Also

RadioButtonGroup Members
Autodesk.Revit.UI Namespace