Revit 2011 API
FilterElementIdRule Constructor
FilterElementIdRule Class See Also
Constructs an instance of FilterElementIdRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterElementIdRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    ElementId ruleValue
)
Visual Basic (Declaration)
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As ElementId _
)
Visual C++
public:
FilterElementIdRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    ElementId^ ruleValue
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::.FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: Autodesk.Revit.DB..::.ElementId
The user-supplied value against which values from a Revit document will be tested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterElementIdRule Class