Revit 2011 API
Opening..::.BoundaryCurves Property
Opening Class See Also
The geometry information for non-rectangular openings in project documents, or for all openings in family documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray BoundaryCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoundaryCurves As CurveArray
Visual C++
public:
property CurveArray^ BoundaryCurves {
    CurveArray^ get ();
}

Remarks

If IsRectBoundary is true, this value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Opening Class