Revit 2011 API
AnalyticalModel..::.IsValidDirectionForProjection Method
AnalyticalModel Class See Also
This indicates whether the input direction is valid for Analytical Model projection.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidDirectionForProjection(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function IsValidDirectionForProjection ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidDirectionForProjection(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which the Analytical Model may be projected.

Return Value

True if AnalyticalDirection is valid for Element, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace