Revit 2011 API
Gutter Methods
Gutter Class See Also

The Gutter type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the gutter. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace