Revit 2011 API
FailureMessageKey Class
Members See Also
A unique key assigned to each posted failure message

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureMessageKey : IDisposable
Visual Basic (Declaration)
Public Class FailureMessageKey _
    Implements IDisposable
Visual C++
public ref class FailureMessageKey : IDisposable

Remarks

When a failure message is posted, it gets a unique key assigned and returned to the caller. The key is guaranteed to be unique in the Revit session. The key can be used to unpost (delete) previously posted failure message if it is no longer valid.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureMessageKey

See Also

FailureMessageKey Members