Revit 2011 API
AnalyticalModelSketchComponent Members
AnalyticalModelSketchComponent Class Methods See Also

The AnalyticalModelSketchComponent type exposes the following members.

Methods

Name | Description
Dispose |
EnableAutoDetect | Enables Auto-detect on Sketch Component.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalProjectionDatumPlane | Retrieves Datum Plane ElementId for Analytical Projection
GetAnalyticalProjectionType | Retrieves Analytical Projection Type preset for Sketch Component.
GetAutoDetectMatchedElements | Retrieves ElementIds that Sketch Component is Auto-detecting against.
GetComponentElementId | Retrieves ElementId of Sketch Component, if such an operation makes sense.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsAutoDetectEnabled | Indicates whether Auto-detect is enabled on the given Sketch component.
IsValidAnalyticalProjectionType | Indicates whether Analytical Projection Type is valid for Sketch Component.
IsValidDatumPlaneForProjection | Indicates whether Datum Plane is valid Analytical Projection of Sketch Component.
SetAnalyticalProjectionDatumPlane | Sets the Analytical Projection to supplied Datum Plane.
SetAnalyticalProjectionType | Sets the Analytical Projection to the supplied Analytical Projection Type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace