Revit 2011 API
Edge Properties
Edge Class See Also

The Edge type exposes the following members.

Properties

Name | Description
ApproximateLength | Returns the approximate length of the edge.
EndPointReference | Returns a stable reference to the start or the end point of the edge.
Face | Returns one of the two faces that meet at the edge.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Reference | Returns a stable reference to the edge.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Edge Class