Revit 2011 API
Pipe Class
Members See Also
A pipe in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Pipe : MEPCurve
Visual Basic (Declaration)
Public Class Pipe _
    Inherits MEPCurve
Visual C++
public ref class Pipe : public MEPCurve

Remarks

The pipe is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Plumbing..::.Pipe

See Also

Pipe Members
Autodesk.Revit.DB.Plumbing Namespace