Revit 2011 API
FilterDoubleRule Constructor
FilterDoubleRule Class See Also
Constructs an instance of FilterDoubleRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterDoubleRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    double ruleValue,
    double epsilon
)
Visual Basic (Declaration)
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As Double, _
    epsilon As Double _
)
Visual C++
public:
FilterDoubleRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    double ruleValue,
    double epsilon
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::.FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: System..::.Double
The user-supplied value against which values from a Revit document will be tested.
epsilon
Type: System..::.Double
The tolerance within which two floating-point values may be considered equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for ruleValue is not finite -or- The given value for ruleValue is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterDoubleRule Class