Revit 2011 API
NurbSpline Class
Members See Also
A nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class NurbSpline : Curve
Visual Basic (Declaration)
Public Class NurbSpline _
    Inherits Curve
Visual C++
public ref class NurbSpline : public Curve

Remarks

The nurb spline lies in the plane defined by control point, weight,knots,degree.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Curve
Autodesk.Revit.DB..::.NurbSpline

See Also

NurbSpline Members