Revit 2011 API
FailuresAccessor..::.RollBackPendingTransaction Method
FailuresAccessor Class See Also
Finishes pending failures processing by rolling back the pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus RollBackPendingTransaction()
Visual Basic (Declaration)
Public Function RollBackPendingTransaction As TransactionStatus
Visual C++
public:
TransactionStatus RollBackPendingTransaction()

Return Value

Result of attempt to roll back the pending transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- The processing of the failures is not in the pending state.

See Also

FailuresAccessor Class