Revit 2011 API
UndoOperation Enumeration
See Also
The operation associated with DocumentChanged event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum UndoOperation
Visual Basic (Declaration)
Public Enumeration UndoOperation
Visual C++
public enum class UndoOperation

Members

Member name | Description
TransactionCommitted | A transaction was committed
TransactionRolledBack | A transaction was rolled back
TransactionGroupRolledBack | A transaction group was rolled back
TransactionUndone | A transaction was undone
TransactionRedone | A transaction was redone

See Also

Autodesk.Revit.DB.Events Namespace