Revit 2011 API
PanelScheduleView Methods
PanelScheduleView Class See Also

The PanelScheduleView type exposes the following members.

Methods

Name | Description
AddFontId | adds a unique combination of font name, size, and color within the table view to the font table
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
CreateInstanceView | Overloaded.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GenerateInstanceFromTemplate | actually assigns the data from the template to the instance also performs any tasks specific to the instance (3rd phase, borders, etc)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetApparentLoad | get the apparent load for the given phase for the given slotted circuit
GetAvailableParameterCategories | Get all available parameter categories. (Inherited from TableView.)
GetAvailableParameters | Get available parameters for the specified category. (Inherited from TableView.)
GetCalculatedValueName | Returns the calculated value name for template view (Inherited from TableView.)
GetCalculatedValueText | Returns the calculated value text for instance view (Inherited from TableView.)
GetCellText | gets the cell's text based on its type Row Number in the Section Column Number in the Section
GetCircuitByCell | gets the circuit element for the given slot number Row Number of the Body Section Column Number of the Body Section
GetCircuitIdByCell | gets the circuit id for the given slot number Row Number Column Number
GetCombinedParamValue | Returns the combined parameter text for instance view Row Number of the Section Column Number of the Section
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFontId | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLoadClassificationConnectedCurrent | get the Total Current for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationConnectedLoad | get the Total Load for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandCurrent | get the Demand Current for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandFactor | get the Demand Factor for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandLoad | get the Demand Load for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationId | get the id of the associated LC at the given row Row number of Load Summary Section
GetLoadClassificationName | get the name of the Load Classification at the given row/col Row Number of the Load Summary Section Column number of Load Summary Section
GetLoadClassificationParamValue | Gets the load classification parameter value. Row Number of the Load Summary Section Column number of Load Summary Section
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPanel | get the panel for this view
GetParamValue | gets the cell's text based on its type Row Number of the Section Column Number of the Section
GetSectionData | gets section data that can be written to
GetSlotNumberByCell | gets the slot number in the circuit table Row Number Column Number
GetTableData | gets table data that can be written to
GetTemplate | get the template for this view (to set the template, you must go through generateInstanceFromTemplate)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsCellInPhaseLoads | is this cell in the phase loads Row Number Column Number
IsColumnInLoadSummary | is this column in the load summary
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsOkToEditParam | (Inherited from TableView.)
IsPanelScheduleTemplate | returns true if this is a panel schedule template, false if it is an instance
IsRowInCircuitTable | is this row in the circuit table
IsSlotGrouped | is the slot in a group? (0 = no, >0 = the group number)
IsSlotLocked | is the circuit slot in this cell locked?
IsSpace | is the selected cell space? Row Number Column Number
IsSpare | is the circuit spare? Circuit Table Row Number Circuit Table Column Number
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
RefreshAllFontIds | Clean all existing font ids and create all font ids based on the table cell styles
SetParamValue | sets the text for the given cell, returns true if successful, false otherwise Row Number of the Section Column Number of the Section
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace