Revit 2011 API
ParameterValueProvider Members
ParameterValueProvider Class Constructors Methods Properties See Also

The ParameterValueProvider type exposes the following members.

Constructors

Name | Description
ParameterValueProvider | Constructs an instance of ParameterValueProvider.

Methods

Name | Description
Dispose | (Inherited from FilterableValueProvider.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDoubleValue | Gets a double-precision numeric value from the given element. (Inherited from FilterableValueProvider.)
GetElementIdValue | Gets an ElementId value from the given element. (Inherited from FilterableValueProvider.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntegerValue | Gets an integer value from the given element. (Inherited from FilterableValueProvider.)
GetStringValue | Gets a string value from the given element. (Inherited from FilterableValueProvider.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element. (Inherited from FilterableValueProvider.)
IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element. (Inherited from FilterableValueProvider.)
IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element. (Inherited from FilterableValueProvider.)
IsStringValueSupported | Determines whether the provide can provide a string value for the given element. (Inherited from FilterableValueProvider.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Parameter | The parameter used to provide a string, integer, and double-precision, or ElementId value on request for a given element.

See Also

ParameterValueProvider Class