Revit 2011 API
ModelArc Class
Members See Also
Represents a ModelArc within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelArc : ModelCurve
Visual Basic (Declaration)
Public Class ModelArc _
    Inherits ModelCurve
Visual C++
public ref class ModelArc : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.ModelCurve
Autodesk.Revit.DB..::.ModelArc

See Also

ModelArc Members