Revit 2011 API
EnergyDataSettings..::.IsExportSimplifiedCurtainSystemsEnabled Property
EnergyDataSettings Class See Also
Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsExportSimplifiedCurtainSystemsEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExportSimplifiedCurtainSystemsEnabled As Boolean
Visual C++
public:
property bool IsExportSimplifiedCurtainSystemsEnabled {
    bool get ();
}

Remarks

Result is based on the ExportComplexity setting. Curtain Walls and Curtain Systems are normally exported as multiple openings, panel by panel, while for energy analysis this can be more simply represented as a single glass surface as large as the entire curtain wall/system. Normally, a curtain wall with 50 panels would be exported as 50 openings. Often, exporting a single opening with the total curtain system area is more appropriate. When this setting is on, one "large" window/opening will be exported for a curtain wall/system.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace