Revit 2011 API
ConstructionType Enumeration
See Also
This enumeration specifies the available analytical construction types like external walls, windows etc. for use in the detailed analytical energy model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ConstructionType
Visual Basic (Declaration)
Public Enumeration ConstructionType
Visual C++
public enum class ConstructionType

Members

Member name | Description
ExteriorWall | An exterior wall surrounding the space
InteriorWall | An interior wall surrounding the space
Slab | A slab below the space
Roof | A roof over the space
Ceiling | A ceiling over the space
Floor | A floor below the space
Door | A door in a wall in the space
ExteriorWindow | A window in an exterior wall in the space
InteriorWindow | A window in an interior wall in the space
Skylight | A window in a roof in the space
NoOfConstructionTypes | The number of construction types

See Also

Autodesk.Revit.DB.Analysis Namespace