Revit 2011 API
MassEnergyAnalyticalModel Class
Members See Also
This class associates a mass instance with an energy analytical model data and geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class MassEnergyAnalyticalModel : Element
Visual Basic (Declaration)
Public Class MassEnergyAnalyticalModel _
    Inherits Element
Visual C++
public ref class MassEnergyAnalyticalModel : public Element

Remarks

The geometry begins as a copy of its associated mass instance geometry and is modified according to the requirements of the energy analytical model. MassZones are created from the MassEnergyAnalyticalModel and MassLevelDatas associated with a common mass instance.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.MassEnergyAnalyticalModel

See Also

MassEnergyAnalyticalModel Members
Autodesk.Revit.DB.Analysis Namespace