Revit 2011 API
ModificationForbiddenException Class
Members See Also
The exception that is thrown by the undo transaction framework when a modification operation is not allowed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ModificationForbiddenException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ModificationForbiddenException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ModificationForbiddenException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.ModificationForbiddenException

See Also

ModificationForbiddenException Members
Autodesk.Revit.Exceptions Namespace