Revit 2011 API
Line Properties
Line Class See Also

The Line type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Bound | Returns the bounded line between the specified points.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Line Class