Revit 2011 API
Transform..::.BasisY Property
Transform Class See Also
The basis of the Y axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ BasisY { get; set; }
Visual Basic (Declaration)
Public Property BasisY As XYZ
Visual C++
public:
property XYZ^ BasisY {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Y axis of the old coordinate system in the new coordinate system, or the 2nd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class