Revit 2011 API
UpdaterData..::.IsChangeTriggered Method
UpdaterData Class See Also
Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsChangeTriggered(
    ElementId id,
    ChangeType type
)
Visual Basic (Declaration)
Public Function IsChangeTriggered ( _
    id As ElementId, _
    type As ChangeType _
) As Boolean
Visual C++
public:
bool IsChangeTriggered(
    ElementId^ id,
    ChangeType^ type
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
Id of element to check
type
Type: Autodesk.Revit.DB..::.ChangeType
ChangeType to check

Return Value

True if ChangeType happened to specified element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterData Class