Revit 2011 API
Rebar Properties
Rebar Class See Also

The Rebar type exposes the following members.

Properties

Name | Description
ArrayLength | Identifies the distribution path length of rebar set.
BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
BarType | Return the type of the rebar.
BaseFinishingTurns | For a spiral, the number of finishing turns at the lower end of the spiral.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | The centerline of the Rebar.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | For a spiral, the overall height.
Host | The element that contains the rebar.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IncludeFirstBar | Identifies if the first bar in rebar set is shown.
IncludeLastBar | Identifies if the last bar in rebar set is shown.
IsShownInFrontOfGeometryInView | Obsolete. Control placement of the rebar graphics in the viewing planes.
LayoutRule | Identifies the layout rule of rebar set.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfBarPositions | Identifies the number of bar positions in rebar set.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Pitch | For a spiral, the pitch, or vertical distance traveled in one rotation.
Quantity | Identifies the number of bars in rebar set.
RebarShape | Get/Set the RebarShape associated with the Rebar.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TopFinishingTurns | For a spiral, the number of finishing turns at the upper end of the spiral.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace