Revit 2011 API
ConceptualConstructionWindowSkylightType Enumeration
See Also
ConceptualConstructionType values for Windows and Skylights

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum ConceptualConstructionWindowSkylightType
Visual Basic (Declaration)
Public Enumeration ConceptualConstructionWindowSkylightType
Visual C++
public enum class ConceptualConstructionWindowSkylightType

Members

Member name | Description
InvalidWindowSkylightTypeConstruction | Invalid value/not set Window or Skylight Type Construction
SinglePaneClearNoCoating | Single Pane Clear No Coating Window or Skylight
SinglePaneTinted | Single Pane Tinted Window or Skylight
SinglePaneReflective | Single Pane Reflective Window or Skylight
DoublePaneClearNoCoating | Double Pane Clear No Coating Window or Skylight
DoublePaneTinted | Double Pane Tinted Window or Skylight
DoublePaneReflective | Double Pane Reflective Window or Skylight
DoublePaneClearLowEColdClimateHighSHGC | Double Pane Clear Low Energy Cold Climate High Solar Heat Gain Coefficient Window or Skylight
DoublePaneClearLowEHotClimateLowSHGC | Double Pane Clear Low Energy Hot Climate Low Solar Heat Gain Coefficient Window or Skylight
DoublePaneClearHighestPerformanceLowEHighVisTransLowSHGC | Double Pane Clear Highest Performance Low Window or Skylight
TriplePaneClearLowEHotOrColdClimate | Triple Pane Clear Low Energy Hot or Cold Climate Window or Skylight
QuadPaneClearLowEHotOrColdClimate | Quad Pane Clear Low Energy Hot Or Cold Climate Window or Skylight
NumWindowSkylightTypeConstruction | Total Number of Window or Skylight Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace