Revit 2011 API
RibbonItem Class
Members See Also
The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class RibbonItem
Visual Basic (Declaration)
Public Class RibbonItem
Visual C++
public ref class RibbonItem

Remarks

This class is not supported in Revit VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.ComboBox
Autodesk.Revit.UI..::.ComboBoxMember
Autodesk.Revit.UI..::.RadioButtonGroup
Autodesk.Revit.UI..::.RibbonButton
Autodesk.Revit.UI..::.TextBox

See Also

RibbonItem Members
Autodesk.Revit.UI Namespace