Revit 2011 API
Connector..::.DuctSystemType Property
Connector Class See Also
The duct system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctSystemType DuctSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuctSystemType As DuctSystemType
Visual C++
public:
property DuctSystemType DuctSystemType {
    DuctSystemType get ();
}

Remarks

This is the instantaneous system type at this connector, calculated according to system. For unconnected connectors, the system type is undefined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get duct system type.

See Also

Connector Class