Revit 2011 API
UpdaterRegistry..::.RemoveDocumentTriggers Method
UpdaterRegistry Class See Also
Removes all triggers associated with specified document and Updater Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void RemoveDocumentTriggers(
    UpdaterId id,
    Document doc
)
Visual Basic (Declaration)
Public Shared Sub RemoveDocumentTriggers ( _
    id As UpdaterId, _
    doc As Document _
)
Visual C++
public:
static void RemoveDocumentTriggers(
    UpdaterId^ id,
    Document^ doc
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id of specified updater
doc
Type: Autodesk.Revit.DB..::.Document
Document for which to remove triggers

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater's owner AddIn does not match currently active AddIn
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class