Revit 2011 API
PanelScheduleTemplate Methods
PanelScheduleTemplate Class See Also

The PanelScheduleTemplate type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
CopyFrom | Copies all values from other element to this object.
Create | Creates a new instance of a panel schedule template.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPanelScheduleType | Returns the panel schedule type.
GetSectionData | ONLY call this function when you WILL change the section data object
GetTableData | ONLY call this function when you WILL change the table data object
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HasSameType | Checks if given template has the same panel schedule type with this template.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidPanelConfiguration | Checks if given panel configuration is valid for given panel schedule type.
IsValidType | Overloaded.
SetTableData | Assigns table data to this template
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace