Revit 2011 API
Document..::.PlanTopologies Property (Phase)
Document Class See Also
Gets the PlanTopologies of the current project in a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanTopologySet PlanTopologies[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopologies ( _
    phase As Phase _
) As PlanTopologySet
Visual C++
public:
property PlanTopologySet^ PlanTopologies[Phase^ phase] {
    PlanTopologySet^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase
The phase of the Plan Topology.

Remarks

Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopologies Overload