Revit 2011 API
RebarShapeDefinitionByArc Class
Members See Also
Definition of a shape whose size and position can determined by a single arc.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarShapeDefinitionByArc : RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinitionByArc _
    Inherits RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinitionByArc : public RebarShapeDefinition

Remarks

In this shape definition, all dimensions are allowed to be driving dimensions.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarShapeDefinition
Autodesk.Revit.DB.Structure..::.RebarShapeDefinitionByArc

See Also

RebarShapeDefinitionByArc Members
Autodesk.Revit.DB.Structure Namespace