Revit 2011 API
ModelEllipse Class
Members See Also
Represents a ModelEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelEllipse : ModelCurve
Visual Basic (Declaration)
Public Class ModelEllipse _
    Inherits ModelCurve
Visual C++
public ref class ModelEllipse : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.ModelCurve
Autodesk.Revit.DB..::.ModelEllipse

See Also

ModelEllipse Members