Revit 2011 API
ElectricalSystem Members
ElectricalSystem Class Methods Properties See Also

The ElectricalSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
AddToCircuit | Add a set of exist components to the Electrical System.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
DisconnectPanel | Disconnect the panel for the Electrical System.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
NewWires | Create a bunch of wires for the electrical system.
Remove | Remove elements from system. (Inherited from MEPSystem.)
RemoveFromCircuit | remove a set of exist components from the Electrical System.
SelectPanel | Set the panel for the Electrical System.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
ApparentLoad | Returns the ApparentLoad value of the Electrical System.
ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
BalancedLoad | Reports whether the BalancedLoad is on or off.
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within base equipment which is used to connect with system. (Inherited from MEPSystem.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CircuitNumber | Returns the CircuitNumber of the Electrical System.
CircuitType | Get the circuit type of the Electrical System.
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
Length | Returns the Length value of the Electrical System.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadClassifications | Returns the LoadClassifications used in the Electrical System.
LoadName | Get/Set the LoadName of the Electrical System.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns the Name of the Electrical System. (Overrides Element..::.Name.)
NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
PanelName | Returns the Panel name of the Electrical System.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PolesNumber | Returns the Poles Number of the Electrical System.
PowerFactor | Returns the PowerFactor value of the Electrical System.
PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Rating | Get/Set the Rating value of the Electrical System.
RunsNumber | Returns the Runs Number of the Electrical System.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | Returns the Electrical System Type of the Electrical System.
TrueCurrent | Returns the TrueCurrent value of the Electrical System.
TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
TrueLoad | Returns the TrueLoad value of the Electrical System.
TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Voltage | Returns the Voltage value of the Electrical System.
VoltageDrop | Returns the VoltageDrop value of the Electrical System.
WireSizeString | Returns the WireSize as a String of the Electrical System.
WireType | Get/Set the wire type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace