Revit 2011 API
StructuralSettings Properties
StructuralSettings Class See Also

The StructuralSettings type exposes the following members.

Properties

Name | Description
AnalyticalModelAdjustmentTolerance | Tolerance for the analytical adjustment distance.
AnalyticalModelAutoCheckConsistency | Whether to check automatically for consistency between the analytical and physical models.
AnalyticalModelAutoCheckMemberSupports | Whether to check automatically for member supports.
AnalyticalModelCheckAdjustment | Whether to check for analytical model distance from default location is larger than the tolerance defined by the property AnalyticalModelAdjustmentTolerance.
AnalyticalModelCheckBeamSlabDistance | Whether to check the analytical model distance between beam and slab for a level.
AnalyticalModelCheckCircularReferences | Whether to check member supports for circular references.
AnalyticalModelCheckDiscrepancy | Whether to check for distance between analytical and physical models greater than a tolerance defined by AnalyticalModelDiscrepancyTolerance.
AnalyticalModelCheckInstability | Whether to check for possible instability based on release conditions.
AnalyticalModelCheckSupportDistance | Check that joins in the physical model are consistent with proximity in the analytical model.
AnalyticalModelCheckZeroAreaOrLength | Whether to check that analytical model has zero area or length.
AnalyticalModelDiscrepancyTolerance | Tolerance for the analytical-to-physical model distance.
AnalyticalModelHorizontalAutofixTolerance | Tolerance for horizontal auto-detect for the analytical model.
AnalyticalModelSupportDistanceTolerance | The maximum distance between two structural elements, where analytical model support rules still apply.
AnalyticalModelVerticalAutofixTolerance | Tolerance for vertical auto-detect for the analytical model.
BoundaryConditionAreaAndLineSymbolSpacing | Symbol spacing for boundary conditions.
BoundaryConditionFamilySymbolFixed | The id of the FamilySymbol to represent a fixed boundary condition.
BoundaryConditionFamilySymbolPinned | The id of the FamilySymbol to represent a pinned boundary condition.
BoundaryConditionFamilySymbolRoller | The id of the FamilySymbol to represent a roller boundary condition.
BoundaryConditionFamilySymbolUserDefined | The id of the FamilySymbol to represent a user-defined boundary condition.
BraceAboveSymbol | The id of the ElementType to represent a brace above a beam in plan view.
BraceBelowSymbol | The id of the ElementType to represent a brace below a beam in plan view.
BraceParallelLineOffset | The distance by which brace symbols in plan views will be offset.
KickerBraceSymbol | The id of the ElementType to represent a kicker brace.
ShowBraceAbove | Whether to show brace symbols above beams in plan views.
ShowBraceBelow | Whether to show brace symbols below beams in plan views.
SymbolicCutbackForBeamAndTruss | Symbolic cutback distance to be applied to all beams and trusses.
SymbolicCutbackForBrace | Symbolic cutback distance to be applied to all braces.
SymbolicCutbackForColumn | Symbolic cutback distance to be applied to all columns.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace