Revit 2011 API
CurveByPoints..::.ReferenceType Property
CurveByPoints Class See Also
Indicates the type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic (Declaration)
Public Property ReferenceType As ReferenceType
Visual C++
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when argument is out of range.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed.

See Also

CurveByPoints Class