Revit 2011 API
HostedSweep..::.RemoveSegment Method
HostedSweep Class See Also
Remove segments from the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Sub RemoveSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void RemoveSegment(
    Reference^ targetRef
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::.Reference
Segment's reference which want to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class