Revit 2011 API
FlexPipe Class
Members See Also
A flex pipe in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FlexPipe : MEPCurve
Visual Basic (Declaration)
Public Class FlexPipe _
    Inherits MEPCurve
Visual C++
public ref class FlexPipe : public MEPCurve

Remarks

The flex pipe is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Plumbing..::.FlexPipe

See Also

FlexPipe Members
Autodesk.Revit.DB.Plumbing Namespace