Revit 2011 API
Solid..::.SurfaceArea Property
Solid Class See Also
Returns the total surface area of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double SurfaceArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property SurfaceArea As Double
Visual C++
public:
property double SurfaceArea {
    double get ();
}

Return Value

The real number equal to the total area of this solid.

Remarks

Calculates the surface area by adding together the areas of faces comprising this solid. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this solid is not a valid Geometry object.

See Also

Solid Class