Revit 2011 API
ObjectAccessException Class
Members See Also
The exception that is thrown when an operation is denied, e.g. an attempt was made to set a read-only property.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ObjectAccessException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ObjectAccessException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ObjectAccessException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.ObjectAccessException

See Also

ObjectAccessException Members
Autodesk.Revit.Exceptions Namespace