Revit 2011 API
Element..::.GetAnalyticalModel Method
Element Class See Also
Retrieves writeable Analytical Model for Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModel GetAnalyticalModel()
Visual Basic (Declaration)
Public Function GetAnalyticalModel As AnalyticalModel
Visual C++
public:
AnalyticalModel^ GetAnalyticalModel()

Return Value

Writeable Analytical Model.

Remarks

If the Element does not have an Analytical Model, the returned value will be NULL. This may occur even if the Element can have an Analytical Model, but does not for some reason.

See Also

Element Class