Revit 2011 API
Transform..::.Origin Property
Transform Class See Also
Defines the origin of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic (Declaration)
Public Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This corresponds to the fourth column vector of the conventional 3x4 matrix representation. Also, this is the translation component of the transformation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class