Revit 2011 API
LightingDevice Class
Members See Also
Provides access to the Lighting Device in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LightingDevice : MEPModel
Visual Basic (Declaration)
Public Class LightingDevice _
    Inherits MEPModel
Visual C++
public ref class LightingDevice : public MEPModel

Remarks

The Lighting Device object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB.Electrical..::.LightingDevice

See Also

LightingDevice Members
Autodesk.Revit.DB.Electrical Namespace