Revit 2011 API
Plane Members
Plane Class Constructors Methods Properties See Also

The Plane type exposes the following members.

Constructors

Name | Description
Plane | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Normal | Get the Normal of the plane.
Origin | Get the Origin of the plane.
XVec | Get the XVec of the plane.
YVec | Get the YVec of the plane.

See Also

Plane Class