Revit 2011 API
ACADImportOptions Members
ACADImportOptions Class Methods Properties See Also

The ACADImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
CustomScale | Scaling the import. (Inherited from CADImportOptions.)
LayerSelection | The layers collection for import.
LineWeights | A Byte array of line weights for the DWG/DXF Color number.
OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Placement | Where to place the import. (Inherited from CADImportOptions.)
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
VisibleLayersOnly | Only import the visible layers.

See Also

ACADImportOptions Class