Revit 2011 API
Truss Class
Members See Also
Represents all kinds of Trusses.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Truss : Element
Visual Basic (Declaration)
Public Class Truss _
    Inherits Element
Visual C++
public ref class Truss : public Element

Remarks

The Truss object represents all the kinds of Trusses in Revit. The TrussType property is used to distinguish the type of the Truss.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.Truss

See Also

Truss Members
Autodesk.Revit.DB.Structure Namespace