Revit 2011 API
AnalyticalModel..::.IsValidRigidLinksOption Method
AnalyticalModel Class See Also
Indicates whether Rigid Links option is valid for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidRigidLinksOption(
    AnalyticalRigidLinksOption rigidLinksOption
)
Visual Basic (Declaration)
Public Function IsValidRigidLinksOption ( _
    rigidLinksOption As AnalyticalRigidLinksOption _
) As Boolean
Visual C++
public:
bool IsValidRigidLinksOption(
    AnalyticalRigidLinksOption rigidLinksOption
)

Parameters

rigidLinksOption
Type: Autodesk.Revit.DB.Structure..::.AnalyticalRigidLinksOption
Rigid Links option to validate.

Return Value

True if option is valid, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace