Revit 2011 API
AnalyticalModel..::.IsManuallyAdjusted Method
AnalyticalModel Class See Also
Indicates whether or not the Analytical Model has been manually adjusted by the user.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsManuallyAdjusted()
Visual Basic (Declaration)
Public Function IsManuallyAdjusted As Boolean
Visual C++
public:
bool IsManuallyAdjusted()

Return Value

True if user has manually adjusted the Analytical Model; false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace