Revit 2011 API
Asset Properties
Asset Class See Also

The Asset type exposes the following members.

Properties

Name | Description
AssetType | Get the object's AssetPropertyType
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
LibraryName | Get the library name
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Title | Get the asset's title
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace