Revit 2011 API
Application..::.RegisterFailuresProcessor Method
Application Class See Also
Registers Revit application-wide instance of Failures Processor.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static void RegisterFailuresProcessor(
    IFailuresProcessor processor
)
Visual Basic (Declaration)
Public Shared Sub RegisterFailuresProcessor ( _
    processor As IFailuresProcessor _
)
Visual C++
public:
static void RegisterFailuresProcessor(
    IFailuresProcessor^ processor
)

Parameters

processor
Type: Autodesk.Revit.DB..::.IFailuresProcessor
Instance of Failures Processor to be used by the Revit Application.

Remarks

If there is previously registered Failures Processor, it gets discarded. If you opt to register a FailuresProcessor for Revit, your processor will become the default error handler for all Revit errors for the session. The standard Revit error dialog will not appear. If you want to handle only specific failures but not all types of failures in your application, subscribe to the FailuresProcessing event instead, or use FailuresPreprocessor interface for the specific transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace