Revit 2011 API
UpdaterData..::.GetModifiedElementIds Method
UpdaterData Class See Also
Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetModifiedElementIds()
Visual Basic (Declaration)
Public Function GetModifiedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetModifiedElementIds()

Return Value

Set of elements that were modified in the document and triggered the call to execute() Note: This set only contains modified elements (i.e. it is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds()). It does not contain any elements that were added to or deleted from the document during the current transaction. Newly added/deleted elements will be reported by getAddedElementIds()/getDeletedElementIds(), even if they were also modified during the same transaction, but only if ChangeTypeElementAddition/Deletion is registered as a trigger for the current Updater. I.e. Element creation and modification in the same transaction is considered to be "creation" only. Newly created elements are not considered to be "modified" and are therefore not returned as part of getModifiedElementIds()

See Also

UpdaterData Class