Revit 2011 API
SubTransaction Members
SubTransaction Class Constructors Methods See Also

The SubTransaction type exposes the following members.

Constructors

Name | Description
SubTransaction | Instantiates a sub-transaction object

Methods

Name | Description
Commit | Commits all changes made to the model during the sub-transaction
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatus | Returns the current status of the sub-transaction
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasEnded | Determines whether the sub-transaction has ended already
HasStarted | Determines whether the sub-transaction has been started yet
RollBack | Discards all changes made to the model during the sub-transaction
Start | Starts the sub-transaction
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubTransaction Class