Revit 2011 API
FailureMessage..::.SetFailingElements Method
FailureMessage Class See Also
Sets elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetFailingElements(
    ICollection<ElementId> idsToShow
)
Visual Basic (Declaration)
Public Function SetFailingElements ( _
    idsToShow As ICollection(Of ElementId) _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetFailingElements(
    ICollection<ElementId^>^ idsToShow
)

Parameters

idsToShow
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The elements that have caused the failure.

Return Value

The FailureMessage.

Remarks

In the Revit error dialog these elements will be highlighted to the user and can be deleted by user via extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessage is already posted to a document
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class