Revit 2011 API
RevitAPISingleEventArgs Class
Members See Also
The class is used as a base class for arguments of any single-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class RevitAPISingleEventArgs : RevitAPIEventArgs
Visual Basic (Declaration)
Public Class RevitAPISingleEventArgs _
    Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPISingleEventArgs : public RevitAPIEventArgs

Remarks

A single event is an event that is not directly related to another event, meaning that there is no corresponding pre-event or post-event surrounding a single event.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitAPIEventArgs
Autodesk.Revit.DB.Events..::.RevitAPISingleEventArgs
Autodesk.Revit.DB.Events..::.DocumentChangedEventArgs
Autodesk.Revit.DB.Events..::.FailuresProcessingEventArgs

See Also

RevitAPISingleEventArgs Members
Autodesk.Revit.DB.Events Namespace