Revit 2011 API
Selection Members
Selection Class Methods Properties See Also

The Selection type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
PickElementsByRectangle | Overloaded. Prompts the user to select multiple elements by drawing a rectangle.
PickObject | Overloaded. Prompts the user to select one object.
PickObjects | Overloaded. Prompts the user to select multiple objects.
PickOne | Obsolete. Allows the user to select one element.
PickPoint | Overloaded. Prompts the user to pick a point on the active work plane.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WindowSelect | Obsolete. Allows the user to select elements by a rectangle.

Properties

Name | Description
Elements | The elements that are currently selected.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StatusbarTip | Obsolete. The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace