Revit 2011 API
MassLevelData Properties
MassLevelData Class See Also

The MassLevelData type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData.
ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData is synchronized with the EnergyDataSettings or if it overrides those settings.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelId | The ElementId of the level that the MassLevelData is associated with.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MaterialId | The ElementId of the visualization material used for the MassLevelData
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Name | A human readable name for the Element. (Inherited from Element.)
NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData to the next in the mass.
NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
NVolume | The volume of from the level of this MassLevelData to the next in the mass.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
OwningMassId | The ElementId of the mass that the MassLevelData is associated with.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace