Revit 2011 API
Element..::.GetChangeTypeParameter Method (ElementId)
Element Class See Also
Returns ChangeType associated with a change in a parameter's value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeParameter(
    ElementId parameterId
)
Visual Basic (Declaration)
Public Shared Function GetChangeTypeParameter ( _
    parameterId As ElementId _
) As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeParameter(
    ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::.ElementId
ElementId of parameter for the ChangeType to trigger on.

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on parameter value change.

Remarks

remarks: Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
GetChangeTypeParameter Overload