Revit 2011 API
HermiteSpline Methods
HermiteSpline Class See Also

The HermiteSpline type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HermiteSpline Class