Revit 2011 API
SelElementSet..::.Add Method
SelElementSet Class See Also
Add an element into the selected element set.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Add(
    Element element
)
Visual Basic (Declaration)
Public Overridable Sub Add ( _
    element As Element _
)
Visual C++
public:
virtual void Add(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to be added.

Remarks

This function will add the specified element to the selected element set, just like the element is picked from the UI.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace