Revit 2011 API
FailuresAccessor..::.DeleteElements Method
FailuresAccessor Class See Also
Resolves failures by deletion of elements related to the failures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void DeleteElements(
    IList<ElementId> idsToDelete
)
Visual Basic (Declaration)
Public Sub DeleteElements ( _
    idsToDelete As IList(Of ElementId) _
)
Visual C++
public:
void DeleteElements(
    IList<ElementId^>^ idsToDelete
)

Parameters

idsToDelete
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
Ids of elements to be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Resolution of the failures by deleting idsToDelete is not permitted
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class