Revit 2011 API
FailureDefinitionId Class
Members See Also
The unique identifier of a FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinitionId : GuidEnum
Visual Basic (Declaration)
Public Class FailureDefinitionId _
    Inherits GuidEnum
Visual C++
public ref class FailureDefinitionId : public GuidEnum

Remarks

Each possible failure in Revit must be defined and registered during Revit application startup by creating a FailureDefinition object. Unique FailureDefinitionId must be used as a key to register FailureDefinition. Those unique FailureDefinitionId should be created using GUID generation tool. Later FailureDefinitionId can be used to lookup FailureDefinition in FailureDefinitionRegistry, and create and post FailureMessages.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.GuidEnum
Autodesk.Revit.DB..::.FailureDefinitionId

See Also

FailureDefinitionId Members