Revit 2011 API
ACADExportOptions Members
ACADExportOptions Class Methods Properties See Also

The ACADExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Colors | Export color mode.
ExportingAreas | Whether to also export areas and rooms' geometry.
ExportOfSolids | Mode of exporting solids in 3D views.
FileVersion | AutoCAD file version.
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views.
LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
LineScaling | LineType scaling mode.
PropOverrides | How to export overridden object styles.
SharedCoords | Whether to use shared coordinate system or a project's. internal origin.
TargetUnit | Type of units in the target CAD format.

See Also

ACADExportOptions Class