Revit 2011 API
SunAndShadowSettings Members
SunAndShadowSettings Class Methods Properties See Also

The SunAndShadowSettings type exposes the following members.

Methods

Name | Description
CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
GetActiveSunAndShadowSettings | Returns the currently SunAndShadowSettings element assigned to the active view for the supplied document.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsAfterStartDateAndTime | Checks whether the end date and time is valid.
IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsLevelValid | Checks whether the element represents a valid level.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndDateAndTime | Identifies the end date and time.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundPlaneHeight | Identifies the ground plane height.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
SharesSettings | Identifies whether settings a shared globally.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StartDateAndTime | Identifies the start or current date and time.
SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
TimeInterval | Identifies the time interval between animation frames.
TimeZone | Identifies the time zone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | Visibility in current view for a per-view SunAndShadowSettings element.

See Also

SunAndShadowSettings Class