Revit 2011 API
FailuresAccessor..::.DeleteWarning Method
FailuresAccessor Class See Also
Deletes one specific failure message of severity "Warning".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void DeleteWarning(
    FailureMessageAccessor failure
)
Visual Basic (Declaration)
Public Sub DeleteWarning ( _
    failure As FailureMessageAccessor _
)
Visual C++
public:
void DeleteWarning(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessageAccessor
The accessor to the warning to be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | failure has not been properly initialized. -or- Severity of failure is not FailureSeverity::Warning.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class