Revit 2011 API
ControlledApplication Methods
ControlledApplication Class See Also

The ControlledApplication type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteJournalComment | Writes a comment to the Revit journal file

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace