Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NonMonotoneRoof Property
BuiltInFailures..::.SketchFailures Class See Also
All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NonMonotoneRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NonMonotoneRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NonMonotoneRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class