Revit 2011 API
SpotDimension Properties
SpotDimension Class See Also

The SpotDimension type exposes the following members.

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | A curve that represents the dimension line. (Inherited from Dimension.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DimensionShape | The shape of this dimension. (Inherited from Dimension.)
DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
Label | The family parameter label of the dimension. (Inherited from Dimension.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | Get a location point object. This is the location of the spot dimension. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the Dimension. (Inherited from Dimension.)
NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Segments | The segments in the dimension. (Inherited from Dimension.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpotDimensionType | The dimension style of this dimension.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Value | The value of the dimension. (Inherited from Dimension.)
ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpotDimension Class