Revit 2011 API
FailuresAccessor..::.DeleteAllWarnings Method
FailuresAccessor Class See Also
Deletes all FailureMessages of severity "Warning" currently posted in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void DeleteAllWarnings()
Visual Basic (Declaration)
Public Sub DeleteAllWarnings
Visual C++
public:
void DeleteAllWarnings()

Remarks

Warnings are deleted immediately and will not be accessible by any further failures processing. Any accessors for these failure messages become invalid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class