Revit 2011 API
DialogBoxData Class
Members See Also
An object that is passed to your application when a dialog is displayed in Revit.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class DialogBoxData : APIObject
Visual Basic (Declaration)
Public Class DialogBoxData _
    Inherits APIObject
Visual C++
public ref class DialogBoxData : public APIObject

Remarks

When the application receives this object, a dialog has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.UI.Events..::.DialogBoxData
Autodesk.Revit.UI.Events..::.MessageBoxData

See Also

DialogBoxData Members
Autodesk.Revit.UI.Events Namespace