Revit 2011 API
FlexDuctType Class
Members See Also
A flex duct type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FlexDuctType : MEPCurveType
Visual Basic (Declaration)
Public Class FlexDuctType _
    Inherits MEPCurveType
Visual C++
public ref class FlexDuctType : public MEPCurveType

Remarks

The flex duct type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Mechanical..::.FlexDuctType

See Also

FlexDuctType Members
Autodesk.Revit.DB.Mechanical Namespace