Revit 2011 API
FilteredElementCollector Constructor (Document)
FilteredElementCollector Class See Also
Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class
FilteredElementCollector Overload