Revit 2011 API
Material..::.RenderAppearance Property
Material Class See Also
The rendering appearance property of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Asset RenderAppearance { get; set; }
Visual Basic (Declaration)
Public Property RenderAppearance As Asset
Visual C++
public:
property Asset^ RenderAppearance {
    Asset^ get ();
    void set (Asset^ value);
}

Field Value

The rendering appearance property, or nullNothingnullptra null reference (Nothing in Visual Basic), if the render library isn't available.

See Also

Material Class