Revit 2011 API
TaskDialog..::.MainContent Property
TaskDialog Class See Also
MainContent is the smaller text that appears just below the main instructions.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string MainContent { get; set; }
Visual Basic (Declaration)
Public Property MainContent As String
Visual C++
public:
property String^ MainContent {
    String^ get ();
    void set (String^ value);
}

Remarks

The Main Content is optional. It should be used to give further explanation to the user, such as how to correct the problem or work around the situation. It displays in a smaller black font below the main instructions. Follow these guidelines:
  • Text should be clear and jargon free.
  • Main content should not simply restate the main instructions in a different way, they should contain additional information that builds upon or reinforces the main instructions.
  • Main content should be written in sentence format (normal capitalization and punctuation).
  • Address the user directly as “you” when needed.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace