Revit 2011 API
CurveByPointsUtils..::.GetProjectionType Method
CurveByPointsUtils Class See Also
Gets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static CurveProjectionType GetProjectionType(
    CurveElement curveElem
)
Visual Basic (Declaration)
Public Shared Function GetProjectionType ( _
    curveElem As CurveElement _
) As CurveProjectionType
Visual C++
public:
static CurveProjectionType GetProjectionType(
    CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::.CurveElement
The CurveElement.

Return Value

The projection type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class