Revit 2011 API
FamilySymbolProfile Class
Members See Also
Represents a family symbol based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilySymbolProfile : SweepProfile
Visual Basic (Declaration)
Public Class FamilySymbolProfile _
    Inherits SweepProfile
Visual C++
public ref class FamilySymbolProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SweepProfile
Autodesk.Revit.DB..::.FamilySymbolProfile

See Also

FamilySymbolProfile Members