Revit 2011 API
MEPCurve Class
Members See Also
A curve object for duct or pipe blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MEPCurve : HostObject
Visual Basic (Declaration)
Public Class MEPCurve _
    Inherits HostObject
Visual C++
public ref class MEPCurve : public HostObject

Remarks

The curve object is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Electrical..::.CableTrayConduitBase
Autodesk.Revit.DB.Mechanical..::.Duct
Autodesk.Revit.DB.Mechanical..::.FlexDuct
Autodesk.Revit.DB.Plumbing..::.FlexPipe
Autodesk.Revit.DB.Plumbing..::.Pipe

See Also

MEPCurve Members