Revit 2011 API
Application..::.NewInstanceBinding Method
Application Class See Also
Creates a new empty instance binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InstanceBinding NewInstanceBinding()
Visual Basic (Declaration)
Public Function NewInstanceBinding As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding()

Return Value

A new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace