Revit 2011 API
StructuralMaterialTypeFilter Members
StructuralMaterialTypeFilter Class Constructors Methods Properties See Also

The StructuralMaterialTypeFilter type exposes the following members.

Constructors

Name | Description
StructuralMaterialTypeFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralMaterialType | The structural material type.

See Also

StructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace