Revit 2011 API
ElementStructuralTypeFilter Class
Members See Also
A filter used to find elements matching a structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementStructuralTypeFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class ElementStructuralTypeFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementStructuralTypeFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ElementStructuralTypeFilter

See Also

ElementStructuralTypeFilter Members