Revit 2011 API
FilterRule..::.ElementPasses Method
FilterRule Class See Also
Derived classes override this method to implement the test that determines whether the given element passes this rule or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ElementPasses(
    Element element
)
Visual Basic (Declaration)
Public Function ElementPasses ( _
    element As Element _
) As Boolean
Visual C++
public:
bool ElementPasses(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to test against the rule.

Return Value

True if the element satisfies the rule, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterRule Class