Revit 2011 API
FilteredElementCollector..::.IsViewValidForElementIteration Method
FilteredElementCollector Class See Also
Identifies if the particular element is valid for iteration of drawn elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsViewValidForElementIteration(
    Document document,
    ElementId viewId
)
Visual Basic (Declaration)
Public Shared Function IsViewValidForElementIteration ( _
    document As Document, _
    viewId As ElementId _
) As Boolean
Visual C++
public:
static bool IsViewValidForElementIteration(
    Document^ document,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
viewId
Type: Autodesk.Revit.DB..::.ElementId
The view id.

Return Value

True if the element is valid for iteration.

Remarks

Views which have no way of representing drawn elements, such as many view templates, fail this check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class