Revit 2011 API
FilteredElementCollector..::.ContainedInDesignOption Method
FilteredElementCollector Class See Also
Applies an ElementDesignOptionFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector ContainedInDesignOption(
    ElementId designOptionId
)
Visual Basic (Declaration)
Public Function ContainedInDesignOption ( _
    designOptionId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ ContainedInDesignOption(
    ElementId^ designOptionId
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::.ElementId
The design option id.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements which are contained by this particular design option will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class