Revit 2011 API
TableView..::.GetAvailableParameters Method
TableView Class See Also
Get available parameters for the specified category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<ElementId> GetAvailableParameters(
    int categoryId
)
Visual Basic (Declaration)
Public Function GetAvailableParameters ( _
    categoryId As Integer _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetAvailableParameters(
    int categoryId
)

Parameters

categoryId
Type: System..::.Int32

See Also

TableView Class