Revit 2011 API
FailureMessage..::.GetFailureDefinitionId Method
FailureMessage Class See Also
Retrieves the id of the failure definition for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionId GetFailureDefinitionId()
Visual Basic (Declaration)
Public Function GetFailureDefinitionId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetFailureDefinitionId()

Return Value

The id of the FailureDefinition for the failure.

See Also

FailureMessage Class