Revit 2011 API
PanelScheduleData..::.AddLoadClassification Method
PanelScheduleData Class See Also
add a Load Classification Id to the array of Load Classifications.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AddLoadClassification(
    ElementId loadClassficationId
)
Visual Basic (Declaration)
Public Function AddLoadClassification ( _
    loadClassficationId As ElementId _
) As Boolean
Visual C++
public:
bool AddLoadClassification(
    ElementId^ loadClassficationId
)

Parameters

loadClassficationId
Type: Autodesk.Revit.DB..::.ElementId

Return Value

true if success; false if the given Id has already existed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace