Revit 2011 API
Connector..::.Width Property
Connector Class See Also
The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Width { get; set; }
Visual Basic (Declaration)
Public Overridable Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Width

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to set width.

See Also

Connector Class