Revit 2011 API
DefinitionGroups Methods
DefinitionGroups Class See Also

The DefinitionGroups type exposes the following members.

Methods

Name | Description
Clear | Removes every definition group from the set, rendering it empty. (Inherited from DefinitionGroupsBase.)
Contains | Tests for the existence of a definition group within the set. (Inherited from DefinitionGroupsBase.)
Create | Create a new parameter definition group using the name provided.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroups Class