Revit 2011 API
ElementDesignOptionFilter Constructor (ElementId)
ElementDesignOptionFilter Class See Also
Constructs a new instance of a filter to match elements contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementDesignOptionFilter(
    ElementId designOptionId
)
Visual Basic (Declaration)
Public Sub New ( _
    designOptionId As ElementId _
)
Visual C++
public:
ElementDesignOptionFilter(
    ElementId^ designOptionId
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::.ElementId
The design option id to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Overload