Revit 2011 API
BarDescription..::.HookType Property
BarDescription Class See Also
Retrieves the Rebar Hook Type property of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarHookType HookType[
    int end
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property HookType ( _
    end As Integer _
) As RebarHookType
Visual C++
public:
property RebarHookType^ HookType[int end] {
    RebarHookType^ get (int end);
}

Parameters

end
Type: System..::.Int32
Which end of the bar: 0 or 1.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace