Revit 2011 API
StructuralInstanceUsageFilter Class
Members See Also
A filter used to find elements that are structural family instances (typically columns, beams or braces) of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class StructuralInstanceUsageFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class StructuralInstanceUsageFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class StructuralInstanceUsageFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Structure..::.StructuralInstanceUsageFilter

See Also

StructuralInstanceUsageFilter Members
Autodesk.Revit.DB.Structure Namespace