Revit 2011 API
StructuralConnectionType..::.SetFamilySymbolId Method
StructuralConnectionType Class See Also
FamilySymbol of the annotation to use for this connection type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetFamilySymbolId(
    ElementId familySymbolId
)
Visual Basic (Declaration)
Public Sub SetFamilySymbolId ( _
    familySymbolId As ElementId _
)
Visual C++
public:
void SetFamilySymbolId(
    ElementId^ familySymbolId
)

Parameters

familySymbolId
Type: Autodesk.Revit.DB..::.ElementId

Remarks

The FamilySymbol must be of category "Connection Symbols" (OST_StructConnectionSymbols) and have its "Apply To" parameter set to match the applyTo property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when familySymbolId is the id of some element that is not a FamilySymbol, is not of the category "Connection Symbols" (OST_StructConnectionSymbols), or has its "Apply To" parameter not equal to this type's applyTo property.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace