Revit 2011 API
SunAndShadowType Enumeration
See Also
Sun study type enum of SunAndShadowSettings.
Enum of sun study type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum SunAndShadowType
Visual Basic (Declaration)
Public Enumeration SunAndShadowType
Visual C++
public enum class SunAndShadowType

Members

Member name | Description
StillImage | Still image study type (single point in time).
OneDayStudy | Single day study type (time range over a specific day).
MultiDayStudy | Multi day study type (range over date and time).
Lighting | Lighting study type (fixed sun position regardless of date and time).

See Also