Revit 2011 API
FailureDefinitionRegistry Methods
FailureDefinitionRegistry Class See Also

The FailureDefinitionRegistry type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionRegistry Class