Revit 2011 API
SunAndShadowSettings..::.Visible Property
SunAndShadowSettings Class See Also
Visibility in current view for a per-view SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Field Value

Visibility

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The element is not view specific (in which case visibility is not relevant) or if internally its view is not accessible.

See Also

SunAndShadowSettings Class