Revit 2011 API
PipingSystem..::.BaseEquipmentConnector Property
PipingSystem Class See Also
The connector within base equipment which is used to connect with system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; set; }
Visual Basic (Declaration)
Public Property BaseEquipmentConnector As Connector
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
    void set (Connector^ value);
}

Remarks

Setting this property to nullNothingnullptra null reference (Nothing in Visual Basic) will disconnect base equipment from system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when assigning a connector which is used in a system, or when the connector's owner is not of type 'mechanical equipment'.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the set operation failed.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace