Revit 2011 API
CompoundStructureLayer Properties
CompoundStructureLayer Class See Also

The CompoundStructureLayer type exposes the following members.

Properties

Name | Description
DeckProfile | Returns or sets the family symbol of the deck profile of the layer within the structure.
DeckUsage | Returns usage of the deck layer within the structure.
Function | Returns the purpose/function of the layer within the structure.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Material | Get or set the material from which the layer is made.
Thickness | Retrieve or modify the thickness of the layer.
Variable | Returns or sets the variability of the layer's thickness.

See Also

CompoundStructureLayer Class