Revit 2011 API
ReferencePoint Methods
ReferencePoint Class See Also

The ReferencePoint type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
GetCoordinateSystem | The position and orientation of the ReferencePoint.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the point.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetCoordinateSystem | The position and orientation of the ReferencePoint.
SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
SetVisibility | Sets the visibility for the point.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePoint Class