Revit 2011 API
AnalyticalDirection Enumeration
See Also
Specifies a direction for manipulating analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalDirection
Visual Basic (Declaration)
Public Enumeration AnalyticalDirection
Visual C++
public enum class AnalyticalDirection

Members

Member name | Description
Vertical | Change in vertical direction only.
VerticalTop | Vertical change, for top of Element's analytical model.
VerticalBottom | Vertical change, for bottom of Element's analytical model.
Horizontal | Change in horizontal direction only (no elevation change).
HorizontalStart | Horizontal change, corresponding to start of Curve Driver.
HorizontalEnd | Horizontal change, corresponding to end of Curve Driver.
Any | Any change, including vertical and horizontal.

See Also

Autodesk.Revit.DB.Structure Namespace