Revit 2011 API
RadioButtonGroup Members
RadioButtonGroup Class Methods Properties See Also

The RadioButtonGroup type exposes the following members.

Methods

Name | Description
AddItem | Adds a new ToggleButton to the RadioButtonGroup.
AddItems | Adds new ToggleButtons to the RadioButtonGroup.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets the collection of ToggleButtons assigned to the RadioButtonGroup.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Gets or sets the current checked ToggleButton of the RadioButtonGroup.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace