Revit 2011 API
AnalyticalModel..::.HasRigidLinksWith Method
AnalyticalModel Class See Also
Indicates whether Analytical Model has Rigid Links with specified element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasRigidLinksWith(
    ElementId neighborId
)
Visual Basic (Declaration)
Public Function HasRigidLinksWith ( _
    neighborId As ElementId _
) As Boolean
Visual C++
public:
bool HasRigidLinksWith(
    ElementId^ neighborId
)

Parameters

neighborId
Type: Autodesk.Revit.DB..::.ElementId
neighboring Element, to which Rigid Links may exist.

Return Value

true if Rigid Links exist, false otherwise.

Remarks

This is bidirectional, so this can be used to see if Rigid Links exist from Column to Beam.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace