Revit 2011 API
BoundingBoxIntersectsFilter Constructor (Outline, Double, Boolean)
BoundingBoxIntersectsFilter Class See Also
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline,
    double tolerance,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline, _
    tolerance As Double, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    double tolerance,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance
Type: System..::.Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted
Type: System..::.Boolean
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload