Revit 2011 API
Curve Methods
Curve Class See Also

The Curve type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve.
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values.
MakeUnbound | Makes this curve unbound.
Project | Projects the specified point on this curve.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Curve Class