Revit 2011 API
ElementId..::.Compare Method
ElementId Class See Also
Compares two element ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Compare(
    ElementId id
)
Visual Basic (Declaration)
Public Function Compare ( _
    id As ElementId _
) As Integer
Visual C++
public:
int Compare(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The ElementId to be compared with this ElementId.

Return Value

-1 if this element id is less than id, 0 if equal, 1 if greater.

See Also

ElementId Class