Revit 2011 API
AreaTagFilter Class
Members See Also
A filter used to match area tags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaTagFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class AreaTagFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class AreaTagFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB..::.AreaTagFilter

See Also

AreaTagFilter Members