Revit 2011 API
ButtonData Class
Members See Also
Base class used to contain information necessary to construct a button in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class ButtonData : RibbonItemData
Visual Basic (Declaration)
Public Class ButtonData _
    Inherits RibbonItemData
Visual C++
public ref class ButtonData : public RibbonItemData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ButtonData
Autodesk.Revit.UI..::.PulldownButtonData
Autodesk.Revit.UI..::.PushButtonData

See Also

ButtonData Members
Autodesk.Revit.UI Namespace