Revit 2011 API
ModelCurve..::.TrussCurveType Property
ModelCurve Class See Also
The truss curve type of this model curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TrussCurveType TrussCurveType { get; set; }
Visual Basic (Declaration)
Public Property TrussCurveType As TrussCurveType
Visual C++
public:
property TrussCurveType TrussCurveType {
    TrussCurveType get ();
    void set (TrussCurveType value);
}

Remarks

This property is applicable only to curves in Truss families.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the assigned value for TrussCurveType is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to set this property to a curve not in a truss family.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to change truss curves to NonTrussCurve, or when the truss curve type may not be applied to curves of this shape (webs must be linear, and chords must be linear or arc).

See Also

ModelCurve Class