Revit 2011 API
SketchBase Class
Members See Also
Provides access to the SketchBase in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SketchBase : Element
Visual Basic (Declaration)
Public Class SketchBase _
    Inherits Element
Visual C++
public ref class SketchBase : public Element

Remarks

SketchBase is the base class of Sketch.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.SketchBase
Autodesk.Revit.DB..::.Path3d
Autodesk.Revit.DB..::.Sketch

See Also

SketchBase Members