Revit 2011 API
MassEnergyAnalyticalModel..::.GetReferencesToAllShadingFaces Method
MassEnergyAnalyticalModel Class See Also
Get References to all Faces of the MassEnergyAnalyticalModel which are of Mass Shade subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<Reference> GetReferencesToAllShadingFaces()
Visual Basic (Declaration)
Public Function GetReferencesToAllShadingFaces As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferencesToAllShadingFaces()

Return Value

Array of Reference to Faces that represent Mass Shades.

Remarks

Called out as a separate convenience method because often it is more useful to obtain information about non-shading faces from the zones, and only get information about shading faces from the MassEnergyAnalyticalModel.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace