Revit 2011 API
UpdaterRegistry..::.RegisterUpdater Method (IUpdater)
UpdaterRegistry Class See Also
Registers an updater on an application level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater
)
Visual Basic (Declaration)
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater
)

Parameters

updater
Type: Autodesk.Revit.DB..::.IUpdater
Updater to be registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | updater's updaterId is not valid
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file -or- updater is already registered on the application level
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class
RegisterUpdater Overload