Revit 2011 API
ParameterFilterElement Methods
ParameterFilterElement Class See Also

The ParameterFilterElement type exposes the following members.

Methods

Name | Description
AllCategoriesFilterable | Checks that all of the given categories are filterable.
AllRuleParametersApplicable | Overloaded.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ClearRules | Removes all rules from this filter.
Create | Overloaded.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCategories | Gets the categories admitted by this filter.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetRuleParameter | Returns the parameter for a given filter rule.
GetRuleParameters | Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.
GetRules | Returns the rules of this filter, in the order in which they are applied.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsNameUnique | Determines whether a potential filter element name is unique. (Inherited from FilterElement.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetCategories | Sets the categories admitted by this filter.
SetRules | Sets the rules, all of which must be satisfied for a given element to pass this filter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterElement Class