Revit 2011 API
FailureDefinitionAccessor..::.GetId Method
FailureDefinitionAccessor Class See Also
Retrieves the unique identifier of the FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionId GetId()
Visual Basic (Declaration)
Public Function GetId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetId()

Return Value

The unique identifier of the FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class