Revit 2011 API
Duct Class
Members See Also
A duct in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Duct : MEPCurve
Visual Basic (Declaration)
Public Class Duct _
    Inherits MEPCurve
Visual C++
public ref class Duct : public MEPCurve

Remarks

The duct is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Mechanical..::.Duct

See Also

Duct Members
Autodesk.Revit.DB.Mechanical Namespace