Revit 2011 API
SymbolicCurveArray..::.Insert Method
SymbolicCurveArray Class See Also
Insert the specified model curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    SymbolicCurve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As SymbolicCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SymbolicCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.SymbolicCurve
The model curve to be inserted into the array.
index
Type: System..::.Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.

See Also

SymbolicCurveArray Class