Revit 2011 API
Outline..::.Scale Method
Outline Class See Also
Scales the bounding box by given scale.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void Scale(
    double scale
)
Visual Basic (Declaration)
Public Sub Scale ( _
    scale As Double _
)
Visual C++
public:
void Scale(
    double scale
)

Parameters

scale
Type: System..::.Double
The scale value. It should be greater than zero.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The scale is invalid.

See Also

Outline Class