Revit 2011 API
SiteLocation..::.ConvertFromProjectTime Method
SiteLocation Class See Also
Converts project time to UTC time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DateTime ConvertFromProjectTime(
    DateTime projectTime
)
Visual Basic (Declaration)
Public Function ConvertFromProjectTime ( _
    projectTime As DateTime _
) As DateTime
Visual C++
public:
DateTime ConvertFromProjectTime(
    DateTime projectTime
)

Parameters

projectTime
Type: System..::.DateTime
The project time.

Remarks

Daylight savings time is not considered during this conversion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the projectTime's kind is not Unspecified.

See Also

SiteLocation Class