Revit 2011 API
Opening..::.BoundaryRect Property
Opening Class See Also
Retrieves the geometry information if the opening boundary is a rect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> BoundaryRect { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoundaryRect As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ BoundaryRect {
    IList<XYZ^>^ get ();
}

Remarks

If IsRectBoundary is false, this value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Opening Class