Revit 2011 API
ElectricalSetting Members
ElectricalSetting Class Methods Properties See Also

The ElectricalSetting type exposes the following members.

Methods

Name | Description
AddDistributionSysType | Add a new distribution system type to project.
AddVoltageType | Add a new type definition of voltage into project.
AddWireMaterialType | Add a new type of wire material.
AddWireType | Add a new wire type to project.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveDistributionSysType | Remove an existing distribution system type from the project.
RemoveVoltageType | Remove the voltage type from project.
RemoveWireMaterialType | Remove the wire material type from project.
RemoveWireType | Remove wire type definition from project.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DistributionSysTypes | Get all distribution system types of the project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
VoltageTypes | Get all voltage type definitions information of the project.
WireConduitTypes | Get electrical conduit types information of the project.
WireMaterialTypes | Get electrical wire material types information of the project.
WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace