Revit 2011 API
MassZone..::.ConditionType Property
MassZone Class See Also
The gbXMLConditionType of the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public gbXMLConditionType ConditionType { get; set; }
Visual Basic (Declaration)
Public Property ConditionType As gbXMLConditionType
Visual C++
public:
property gbXMLConditionType ConditionType {
    gbXMLConditionType get ();
    void set (gbXMLConditionType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: The condition type does not fall within an appropriate range.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace