Revit 2011 API
MEPSystem Class
Members See Also
A system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MEPSystem : Element
Visual Basic (Declaration)
Public Class MEPSystem _
    Inherits Element
Visual C++
public ref class MEPSystem : public Element

Remarks

This is the base class for electrical, mechanical and piping systems, available only in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.MEPSystem
Autodesk.Revit.DB.Electrical..::.ElectricalSystem
Autodesk.Revit.DB.Mechanical..::.MechanicalSystem
Autodesk.Revit.DB.Plumbing..::.PipingSystem

See Also

MEPSystem Members