Revit 2011 API
ConceptualConstructionType..::.GetRoofConstructionType Method
ConceptualConstructionType Class See Also
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetRoofConstructionType(
    Document ccda,
    ConceptualConstructionRoofType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetRoofConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionRoofType _
) As ElementId
Visual C++
public:
static ElementId^ GetRoofConstructionType(
    Document^ ccda,
    ConceptualConstructionRoofType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionRoofType
The ConceptualConstructionRoofType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionRoofType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace