Revit 2011 API
FailureMessageAccessor..::.GetNumberOfResolutions Method
FailureMessageAccessor Class See Also
Retrieves number of resolutions that can be used to resolve failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int GetNumberOfResolutions()
Visual Basic (Declaration)
Public Function GetNumberOfResolutions As Integer
Visual C++
public:
int GetNumberOfResolutions()

Return Value

Number of resolutions that can be used to resolve failure

Remarks

If number of resolutions is zero, the failure can not be resolved. If severity of the failure is Warning, it can be deleted. Otherwise, the only option is to cancel current operation and roll back the transaction

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class