Revit 2011 API
ElementId Class
Members See Also
The ElementId object is used as a unique identification for an element within a single project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElementId
Visual Basic (Declaration)
Public Class ElementId
Visual C++
public ref class ElementId

Remarks

The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementId

See Also

ElementId Members