Revit 2011 API
ElectricalConnector..::.SystemType Property
ElectricalConnector Class See Also
The system type of the connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystemType SystemType { get; set; }
Visual Basic (Declaration)
Public Property SystemType As ElectricalSystemType
Visual C++
public:
property ElectricalSystemType SystemType {
    ElectricalSystemType get ();
    void set (ElectricalSystemType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the system type is out of the permitted range of values.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace