Revit 2024 API
DirectShapeTypeOptions Members
DirectShapeTypeOptions Class Constructors Methods Properties See Also Send Feedback

The DirectShapeTypeOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DirectShapeTypeOptions | Constructs a new DirectShapeTypeOptions instance with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DirectShapeTypeOptions
Public method | IsEqualTo | Compare this object with the one supplied as argument. Return true if the options specified by both objects are the same.
Public method | IsValid | Determines whether a DirectShapeTypeOptions is internally consistent (valid).

Properties

 | Name | Description
Public property | AllowDuplicateNames | Determines whether or not duplicate DirectShapeType names are allowed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DirectShapeTypeOptions Class

DirectShapeTypeOptions Methods

[image] [image]