Revit 2024 API
Mesh Properties
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Properties

 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated mesh surface.
Public property | IsClosed | Indicates whether the mesh is closed.
Public property | MaterialElementId | Element ID of the material from which this mesh is composed.
Public property | NumberOfNormals | The number of normals associated with the mesh.
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.

See Also

Mesh Class

DistributionOfNormals Property

[image]