Revit 2024 API
TemporaryGraphicsManager Methods
TemporaryGraphicsManager Class See Also Send Feedback

The TemporaryGraphicsManager type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | Creates an in-canvas control.
Public method | Clear | Clear all temporary graphics objects managed by this manager.
Public method | Dispose |
Public method | GetAll | Returns all temporary graphics object indexes managed by this manager.
 | GetTemporaryGraphicsManager | Gets a TemporaryGraphicsManager reference of the document.
Public method | RemoveControl | Deletes the existing control identified by the unique index.
Public method | SetVisibility | Changes the visibility of temporary graphics object.
Public method | UpdateControl | Updates the in-canvas control identified by the unique index.

See Also

TemporaryGraphicsManager Class

Dispose Method

[image]