Revit 2024 API
ViewDisplayModel Properties
ViewDisplayModel Class See Also Send Feedback

The ViewDisplayModel type exposes the following members.

Properties

 | Name | Description
Public property | EnableSilhouettes | True to show silhouettes edges. False to disable showing them.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowHiddenLines | True to enable hidden lines. False to disable showing them.
Public property | SilhouetteEdgesGStyleId | Style ID for silhouette edges
Public property | SmoothEdges | True to enable "smooth edge" (anti-aliasing) effect. False to disable it.
Public property | Transparency | The percentage (0..100) of surface transparency 0 means the surfaces are opaque, 100 means they are fully transparent

See Also

ViewDisplayModel Class

EnableSilhouettes Property

[image]