Revit 2024 API
IndependentTag Properties
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Properties

 | Name | Description
Public property | HasLeader | Identifies if a tag has at least one visible leader, or if all leaders are hidden.
Public property | IsMaterialTag | Identifies if it is a material tag or not.
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not.
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | LeaderEndCondition | The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.
Public property | LeadersPresentationMode | Identifies the Presentation Mode that is applied to tag leaders.
Public property | MergeElbows | Identifies if the leaders' elbows are merged or not. If they are are merged, all elbows are in the same point and they move together.
Public property | MultiLeader | Returns if the tag if referencing multiple elements and/or sub-elements.
Public property | MultiReferenceAnnotationId | The multi-reference annotation which owns this tag.
Public property | RotationAngle | The rotation angle of the tag relative to its view
Public property | TagHeadPosition | The position of the head of tag in model coordinates.
Public property | TagOrientation | The tag orientation of the tag's head, such as horizontal or vertical.
Public property | TagText | The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated.

See Also

IndependentTag Class

IsMaterialTag Property

[image]