Revit 2024 API
ImageTypeOptions Members
ImageTypeOptions Class Constructors Methods Properties See Also Send Feedback

The ImageTypeOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ImageTypeOptions(ExternalResourceReference, ImageTypeSource) | Constructs a new instance of the ImageTypeOptions object.
Public method | ImageTypeOptions(String, Boolean, ImageTypeSource) | Constructs a new instance of the ImageTypeOptions object. The provided string path must specify a local file. The path can be absolute or relative to the project's location. This constructor saves an additional setting that indicates whether the imagetype will be a link or an import.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ImageTypeOptions
Public method | IsValid | If true the ImageTypeOptions can be used to create or reload an ImageType.
Public method | SetExternalResourceReference | Update the external resource reference to an image.
Public method | SetPath(String) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.
Public method | SetPath(String, Boolean) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. Additionally, indicate whether the path used by ImageType should be absolute or relative.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PageNumber | The page in the file to be used for the image
Public property | Path | The path of the file that specifies the image to be used.
Public property | Resolution | The Resolution of the image is expressed in dots-per-inch and hence determines the size of a pixel in the image.
Public property | SourceType | Indicates whether the image type is a link or an import.

See Also

ImageTypeOptions Class

ImageTypeOptions Constructor

[image] [image]