Revit 2024 API
DefinitionBindingMap Members
DefinitionBindingMap Class Constructors Methods Properties See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Constructors

 | Name | Description
Public method | DefinitionBindingMap | Initializes a new instance of the DefinitionBindingMap class

Methods

 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains |
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | Item |
Public property | Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class

DefinitionBindingMap Constructor

[image]