Revit 2024 API
BasicFileInfo Properties
BasicFileInfo Class See Also Send Feedback

The BasicFileInfo type exposes the following members.

Properties

 | Name | Description
Public property | AllLocalChangesSavedToCentral | Are all local changes saved to the central file?
Public property | CentralPath | Returns the central model path.
Public property | Format | The file format indicator (currently, the major release version such as "2019") used for saving the file.
Public property | IsCentral | Checks if the file is workshared and Central.
Public property | IsCreatedLocal | Checks if the file is local and created by RevitServerTool.exe.
Public property | IsInProgress | Checks if the file is workshared and is in process of becoming Central.
Public property | IsLocal | Checks if the file is workshared and Local.
Public property | IsSavedInCurrentVersion | Checks if the file is saved in the current version.
Public property | IsSavedInLaterVersion | Checks if the file is saved in a later version of Revit than the running Revit.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsWorkshared | Checks if the file is workshared.
Public property | LanguageWhenSaved | Return the language active for the last save
Public property | LatestCentralEpisodeGUID | This is the central model's episode GUID corresponding to the last reload latest done for this model.
Public property | LatestCentralVersion | This is the central model's version number corresponding to the last reload latest done for this model.
Public property | Username | Returns the username.

See Also

BasicFileInfo Class

AllLocalChangesSavedToCentral Property

[image]