Revit 2024 API
TextNoteOptions Properties
TextNoteOptions Class See Also Send Feedback

The TextNoteOptions type exposes the following members.

Properties

 | Name | Description
Public property | HorizontalAlignment | Horizontal alignment of the text.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | KeepRotatedTextReadable | Flag controling whether a rotate text is to stay oriented to be always readable.
Public property | Rotation | Base line angle of a text note, in radians.
Public property | TypeId | Id of a text type that defines the style of a text note.
Public property | VerticalAlignment | Vertical alignment of the text.

See Also

TextNoteOptions Class

HorizontalAlignment Property

[image]