Revit 2024 API
TableSectionData Properties
TableSectionData Class See Also Send Feedback

The TableSectionData type exposes the following members.

Properties

 | Name | Description
Public property | FirstColumnNumber | The first column in this section of the table.
Public property | FirstRowNumber | The first row in this section of the table.
Public property | HideSection | Whether or not the section is hidden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LastColumnNumber | The last column in this section of the table.
Public property | LastRowNumber | The last row in this section of the table.
Public property | NeedsRefresh | Indicates if the table data need to refresh.
Public property | NumberOfColumns | Gets or sets the number of items in column data array.
Public property | NumberOfRows | Gets or sets the number of items in row data array.

See Also

TableSectionData Class

FirstColumnNumber Property

[image]