Revit 2024 API
SweptProfile Members
SweptProfile Class Methods Properties See Also Send Feedback

The SweptProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SweptProfile
Public method | GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public method | GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.

Properties

 | Name | Description
Public property | EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.

See Also

SweptProfile Class

SweptProfile Methods

[image] [image]