Revit 2024 API
FormatValueOptions..::..GetFormatOptions Method
FormatValueOptions Class See Also Send Feedback
Gets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions GetFormatOptions()
Visual Basic
Public Function GetFormatOptions As FormatOptions
Visual C++
public:
FormatOptions^ GetFormatOptions()

Return Value

A copy of the FormatOptions.

Remarks

By default, the FormatOptions represents default formatting (UseDefault is true) and the FormatOptions in the Units class will be used.

See Also

FormatValueOptions Class

SetFormatOptions Method

[image]