Revit 2024 API
Face Members
Face Class Methods Properties See Also Send Feedback

The Face type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point.
Public method | ComputeNormal | Returns the normal vector for the face at the given point.
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point.
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.
Public method | GetBoundingBox | Returns the UV bounding box of the face.
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face.
Public method | GetSurface | Returns a copy of this face's surface.
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location.
Public method | Project | Projects the specified point on the face.
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.

Properties

 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face.
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command).
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction.
Public property | IsTwoSided | Determines if a face is two-sided (degenerate).
Public property | MaterialElementId | The element ID of the material from which this face is composed.
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.
Public property | Period | The period of the underlying surface in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.

See Also

Face Class

Face Methods

[image] [image]