Revit 2024 API
DividedPath Members
DividedPath Class Methods Properties See Also Send Feedback

The DividedPath type exposes the following members.

Methods

 | Name | Description
 | AreCurveReferencesConnected | This checks if the references represent a connected set of curves as required by the divided path.
 | Create(Document, IList<(Of <<'(Reference>)>>)) | Creates a new instance of a divided path with a default layout.
 | Create(Document, IList<(Of <<'(Reference>)>>), ICollection<(Of <<'(ElementId>)>>)) | Creates a new instance of a divided path whose points are determined by the intersecting elements.
Public method | Flip | Toggle the flipped value
Public method | GetIntersectingElements | Get the elements whose intersection with path produces points.
 | IsCurveReferenceValid | This returns true if the reference represents a curve or edge that can be used to create a divided path.
 | IsIntersectorValidForCreation | This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public method | IsIntersectorValidForDividedPath | This returns true if the intersector is an element that can be used to intersect with the divided path.
Public method | IsValidBeginningIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public method | IsValidEndIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
 | IsValidFixedNumberOfPoints | Identifies if the indicated number of points is valid for assignment to a DividedPath with a layout type 'FixedNumber'.
Public method | IsValidMeasurementType | Checks that the measurement type enumeration value is valid
Public method | IsValidSpacingRuleJustification | Checks that the justification enumeration value is valid
Public method | IsValidSpacingRuleLayout | Checks that the spacing rule layout enumeration value is valid
 | SeparateReferencesIntoConnectedReferences | This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.
Public method | SetIntersectingElements | Set the elements whose intersection with path produces points.

Properties

 | Name | Description
Public property | BeginningIndent | The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | DisplayNodeNumbers | Controls whether the node numbers are shown when the divided path is selected
Public property | DisplayNodes | Controls whether the points of the divided path are visible
Public property | DisplayReferenceCurves | Controls whether the curves in the path are visible
Public property | Distance | The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public property | EndIndent | The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | FixedNumberOfPoints | The number of points used when the layout is set to 'FixedNumber'.
Public property | Flipped | If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
Public property | IsClosedLoop | Whether or not the path forms a closed loop.
Public property | IsCyclical | True if the first and last point coincide False otherwise.
Public property | MaximumDistance | The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public property | MeasurementType | The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public property | MinimumDistance | The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public property | NumberOfPoints | The total number of points of the divided surface. This combines the layout points and the intersection points.
Public property | SpacingRuleJustification | When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public property | SpacingRuleLayout | The layout determines how points are distributed along the path.
Public property | TotalPathLength | The sum of the curve lengths.

See Also

DividedPath Class

DividedPath Methods

[image] [image]