Revit 2024 API
Arc Members
Arc Class Methods Properties See Also Send Feedback

The Arc type exposes the following members.

Methods

 | Name | Description
 | Create(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
 | Create(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
 | Create(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.

Properties

 | Name | Description
Public property | Center | Returns the center of the arc.
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Radius | Returns the radius of the arc.
Public property | XDirection | Returns the X direction.
Public property | YDirection | Returns the Y direction.

See Also

Arc Class

Arc Methods

[image] [image]