Revit 2024 API
GeomCombinationSet Members
GeomCombinationSet Class Constructors Methods Properties See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Constructors

 | Name | Description
Public method | GeomCombinationSet | Initializes a new instance of the GeomCombinationSet class

Methods

 | Name | Description
Public method | Clear | Removes every item GeomCombination the set, rendering it empty.
Public method | Contains | Tests for the existence of an GeomCombination within the set.
Public method | Erase | Removes a specified GeomCombination from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of GeomCombinations that are in the set.

See Also

GeomCombinationSet Class

GeomCombinationSet Constructor

[image]