Revit 2024 API
BarTypeDiameterOptions Properties
BarTypeDiameterOptions Class See Also Send Feedback

The BarTypeDiameterOptions type exposes the following members.

Properties

 | Name | Description
Public property | BarModelDiameter | Represents the bar model diameter of the RebarBarType.
Public property | BarNominalDiameter | Represents the bar nominal diameter of the RebarBarType.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardBendDiameter | Represents the standard bar bend diameter of the RebarBarType.
Public property | StandardHookBendDiameter | Represents the standard hook bend diameter of the RebarBarType.
Public property | StirrupTieBendDiameter | Represents the stirrup/tie bar and hook bend diameter of the RebarBarType.

See Also

BarTypeDiameterOptions Class

BarModelDiameter Property

[image]