Revit 2024 API
RenderingQualitySettings Members
RenderingQualitySettings Class Methods Properties See Also Send Feedback

The RenderingQualitySettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingQualitySettings
Public method | IsCustomQuality | Checks if the current rendering quality is custom or not.
Public method | IsValidRenderLevel | Validate the render level is between 1 and 40
Public method | IsValidRenderTime | Validate the render time is between 1 and 32768.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LightAndMaterialAccuracyMode | A value that controls light and material accuracy mode.
Public property | RenderDuration | A value that controls render duration.
Public property | RenderingQuality | The quality applied for rendering.
Public property | RenderLevel | The render target level as a numerical value between 1 and 40.
Public property | RenderTime | The render target time as a numerical value between 1 and 32768.

See Also

RenderingQualitySettings Class

RenderingQualitySettings Methods

[image] [image]