Revit 2024 API
IModelExportContext Methods
IModelExportContext Interface See Also Send Feedback

The IModelExportContext type exposes the following members.

Methods

Name Description
Public method OnLineSegment
This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline
Public method OnPoint
This method is called when a Point is being output.
Public method OnPolylineSegments
This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

See Also

IModelExportContext Interface

OnPoint Method

[image]