Revit 2024 API
FabricationServiceButton Methods
FabricationServiceButton Class See Also Send Feedback

The FabricationServiceButton type exposes the following members.

Methods

 | Name | Description
Public method | ContainsFabricationPartType | Checks to see if the fabrication part type exists on one of the button conditions.
Public method | Dispose |
Public method | GetConditionDescription | Gets the description for the condition size range.
Public method | GetConditionImage | Gets the image for the specified fabrication service button condition.
Public method | GetConditionLowerValue | Gets the condition lower value (valid if greater or equal) for a given condition index.
Public method | GetConditionName | Gets the name of the specified condition on the fabrication service button.
Public method | GetConditionUpperValue | Gets the condition upper value (valid if less) for a given condition index.
Public method | GetImage | Gets the image for fabrication service button.
Public method | IsExcluded | Gets if the button's fabrication part content associated with the button is to be excluded from Route and Fill, Design to Fabrication, or Multi-Point Routing commands.
Public method | IsUnrestrictedCondition | Checks if the condition is unrestricted.
Public method | IsValid | Checks if the button contains only valid fittings.
 | IsValidConditionIndex | Validates if the given condition index is valid or not.

See Also

FabricationServiceButton Class

ContainsFabricationPartType Method

[image]