Revit 2024 API
CurveElement Properties
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Properties

 | Name | Description
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.
Public property | CurveElementType | Type of the curve element.
Public property | GeometryCurve | Geometry curve of the curve element.
Public property | LineStyle | The line style of this curve element.
Public property | SketchPlane | The sketch plane the curve element lies in.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element.

See Also

CurveElement Class

CenterPointReference Property

[image]