Revit 2024 API
GlobalParameter Methods
GlobalParameter Class See Also Send Feedback

The GlobalParameter type exposes the following members.

Methods

 | Name | Description
Public method | CanChangeReporting | Tests whether the global parameter permits a change of its current value of the IsReporting attribute.
Public method | CanLabelDimension | Tests whether a dimension can be labeled by the global parameter.
 | Create | Creates a new Global Parameter in the given document.
Public method | GetAffectedElements | Returns all elements of which properties are driven by this global parameter.
Public method | GetAffectedGlobalParameters | Returns all other global parameters which refer to this global parameter in their formulas.
Public method | GetFormula | Returns the parameter's expression in form of a string.
Public method | GetLabeledDimensions | Returns all dimension elements that are currently labeled by this global parameter.
Public method | GetLabelName | Returns the name of this parameter's label, which is used to label dimension elements.
Public method | GetValue | Obtains the curent value of the global parameter.
Public method | HasValidTypeForReporting | Tests that the global parameter has data of a type that supports reporting.
Public method | IsValidFormula | Tests that the given expression is a valid as formula for this parameter.
Public method | LabelDimension | Labels a dimension with this global parameter.
Public method | SetDrivingDimension | Set a dimension to drive the value of this parameter.
Public method | SetFormula | Sets a formula expression for this parameter.
Public method | SetValue | Sets a new value of the global parameter.
Public method | UnlabelDimension | Unlabels a dimension that is currently labeled by this global parameter.

See Also

GlobalParameter Class

CanChangeReporting Method

[image]