Revit 2024 API
ElevationMarker Members
ElevationMarker Class Methods Properties See Also Send Feedback

The ElevationMarker type exposes the following members.

Methods

 | Name | Description
Public method | CreateElevation | Creates a new elevation ViewSection on the ElevationMarker at the desired index.
 | CreateElevationMarker | Creates a new ElevationMarker.
Public method | CreateReferenceElevation | Creates a reference elevation on the ElevationMarker at the desired index.
 | CreateReferenceElevationMarker | Creates a new ElevationMarker.
Public method | GetViewId | Returns the ViewSection id for the index of the ElevationMarker.
Public method | HasElevations | Returns true if the ElevationMarker has at least one elevation view, false otherwise.
Public method | IsAvailableIndex | Returns true if a new elevation ViewSection can be placed at %index%, returns false otherwise.

Properties

 | Name | Description
Public property | CurrentViewCount | The current number of views hosted by this ElevationMarker.
Public property | IsReference | Indicates if this is a reference ElevationMarker. Only reference elevations can be hosted by reference ElevationMarkers.
Public property | MaximumViewCount | The maximum number of views that can be hosted by this ElevationMarker.

See Also

ElevationMarker Class

CreateElevationMarker Method

[image]