Revit 2024 API
Ellipse Members
Ellipse Class Methods Properties See Also Send Feedback

The Ellipse type exposes the following members.

Methods

 | Name | Description
 | CreateCurve | Creates a new geometric ellipse or elliptical arc object.

Properties

 | Name | Description
Public property | Center | Returns the center of the ellipse.
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | XDirection | The X direction.
Public property | YDirection | The Y direction.

See Also

Ellipse Class

Ellipse Methods

[image] [image]