Revit 2024 API
NurbSpline..::..Knots Property
NurbSpline Class See Also Send Feedback
Return/set the knots of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DoubleArray Knots { get; set; }
Visual Basic
Public Property Knots As DoubleArray
    Get
    Set
Visual C++
public:
property DoubleArray^ Knots {
    DoubleArray^ get ();
    void set (DoubleArray^ value);
}

See Also

NurbSpline Class

Weights Property

[image]