Revit 2024 API
ModelCurve Members
ModelCurve Class Methods Properties See Also Send Feedback

The ModelCurve type exposes the following members.

Methods

 | Name | Description
Public method | ChangeToReferenceLine | Changes this curve to a reference curve.
Public method | GetVisibility | Gets the visibility for the model curve in a family document.
Public method | SetVisibility | Sets the visibility for the model curve in a family document.

Properties

 | Name | Description
Public property | IsReferenceLine | Indicates if this curve is a reference curve.
Public property | Subcategory | The subcategory.
Public property | TrussCurveType | The truss curve type of this model curve.

See Also

ModelCurve Class

ModelCurve Methods

[image] [image]