Revit 2024 API
DoubleArray Members
DoubleArray Class Constructors Methods Properties See Also Send Feedback

The DoubleArray type exposes the following members.

Constructors

 | Name | Description
Public method | DoubleArray | Initializes a new instance of the DoubleArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every double from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a double at a specified index within the array.
Public property | Size | Returns the number of doubles that are in the array.

See Also

DoubleArray Class

DoubleArray Constructor

[image]