Revit 2024 API
TextNode Members
TextNode Class Methods Properties See Also Send Feedback

The TextNode type exposes the following members.

Methods

 | Name | Description
Public method | GetFormattedText | Returns an FormattedText object that contains text and associated formatting of this TextNode.

Properties

 | Name | Description
Public property | BaseDirection | Direction of the base line of the text object in model space.
Public property | Color | The color of the text.
Public property | FontHeight | Height [ft] of the text font, in model space.
Public property | FontName | The name of the text font.
Public property | Height | Height [ft] of the area of the text content in model space.
Public property | HorizontalAlignment | Indicates default horizontal alignment of the text.
Public property | IsBold | Indicates whether the default formatting is set to bold text.
Public property | IsItalic | Indicates whether the default formatting is set to italic text.
Public property | IsKeptReadable | Indicates text behavior inside a rotated text object.
Public property | IsTransparent | Indicates whether the text background is transparent or opaque.
Public property | IsUnderlined | Indicates whether the default formatting is set to underlined text.
Public property | Position | Position of the text in model coordinates.
Public property | TabSize | The size [ft] of the interval between tab stops, in model space.
Public property | Text | The content of the text annotation as a plain string stripped of all formatting.
Public property | UpDirection | Direction along the vertical axis of letters of the text object in model space.
Public property | VerticalAlignment | Indicates default vertical alignment of the text.
Public property | Width | Width [ft] of the area of the text content in model space.
Public property | WidthScale | Scale applied to the width of the text.

See Also

TextNode Class

TextNode Methods

[image] [image]