Revit 2024 API
ViewScheduleExportOptions Members
ViewScheduleExportOptions Class Constructors Methods Properties See Also Send Feedback

The ViewScheduleExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ViewScheduleExportOptions()()()() | Constructs a new instance of the ViewScheduleExportOptions class
Public method | ViewScheduleExportOptions(ViewScheduleExportOptions) | Constructs a new copy of the input ViewScheduleExportOptions object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ViewScheduleExportOptions

Properties

 | Name | Description
Public property | ColumnHeaders | How to export column headers. Default is MultipleRows.
Public property | FieldDelimiter | How to delimit fields. Default is Tab.
Public property | HeadersFootersBlanks | Whether to export group headers, footers, and blank lines. Default is true.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TextQualifier | How to qualify text fields. Default is DoubleQuote.
Public property | Title | Whether or not to export the schedule title. Default is true.

See Also

ViewScheduleExportOptions Class

ViewScheduleExportOptions Constructor

[image] [image]