Revit 2024 API
Form Properties
Form Class See Also Send Feedback

The Form type exposes the following members.

Properties

 | Name | Description
Public property | AreProfilesConstrained | Get/set if the form's profiles are constrained.
Public property | BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
Public property | CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
Public property | HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
Public property | HasOpenGeometry | Tell if the form has an open geometry.
Public property | IsInXRayMode | Get/set if the form is in X-Ray mode.
Public property | PathCurveCount | The number of curves in the form path.
Public property | PathCurveReference | The curve reference in the path, specified by curve index.
Public property | ProfileCount | The number of profiles in the form.
Public property | ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
Public property | TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.

See Also

Form Class

AreProfilesConstrained Property

[image]