Revit 2024 API
FamilyInstanceCreationData Constructor (FamilySymbol, IList<(Of <(<'XYZ>)>)>)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData(
    FamilySymbol symbol,
    IList<XYZ> adaptivePoints
)
Visual Basic
Public Sub New ( _
    symbol As FamilySymbol, _
    adaptivePoints As IList(Of XYZ) _
)
Visual C++
public:
FamilyInstanceCreationData(
    FamilySymbol^ symbol,
    IList<XYZ^>^ adaptivePoints
)

Parameters

symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
adaptivePoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The adaptive points where the adaptive instance is to be initialized.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace

FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)

[image]