Revit 2024 API
OverrideGraphicSettings Methods
OverrideGraphicSettings Class See Also Send Feedback

The OverrideGraphicSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | SetCutBackgroundPatternColor | Sets the override color of the background pattern of cut faces.
Public method | SetCutBackgroundPatternId | Sets the ElementId of the cut face background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutBackgroundPatternVisible | Sets the visibility of the cut face background fill pattern.
Public method | SetCutForegroundPatternColor | Sets the override color of the foreground pattern of cut faces.
Public method | SetCutForegroundPatternId | Sets the ElementId of the cut face foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutForegroundPatternVisible | Sets the visibility of the cut face foreground fill pattern.
Public method | SetCutLineColor | Sets the cut surface line color.
Public method | SetCutLinePatternId | Sets the ElementId of the cut surface line pattern.
Public method | SetCutLineWeight | Sets the cut surface line weight.
Public method | SetDetailLevel | Sets the detail level.
Public method | SetHalftone | Sets the halftone value.
Public method | SetProjectionLineColor | Sets the projection surface line color.
Public method | SetProjectionLinePatternId | Sets the ElementId of the projection surface line pattern.
Public method | SetProjectionLineWeight | Sets the projection surface line weight.
Public method | SetSurfaceBackgroundPatternColor | Sets the override color of the surface background pattern.
Public method | SetSurfaceBackgroundPatternId | Sets the ElementId of the surface background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceBackgroundPatternVisible | Sets the visibility of the surface background fill pattern.
Public method | SetSurfaceForegroundPatternColor | Sets the override color of the surface foreground pattern.
Public method | SetSurfaceForegroundPatternId | Sets the ElementId of the surface foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceForegroundPatternVisible | Sets the visibility of the surface foreground fill pattern.
Public method | SetSurfaceTransparency | Sets the projection surface transparency.

See Also

OverrideGraphicSettings Class

Dispose Method

[image]