Revit 2024 API
Edge Members
Edge Class Methods Properties See Also Send Feedback

The Edge type exposes the following members.

Methods

 | Name | Description
Public method | AsCurve | Returns a curve that corresponds to the edge's parametric orientation.
Public method | AsCurveFollowingFace | Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Public method | ComputeDerivatives | Returns the vectors describing the edge at the specified parameter.
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | GetCurveUV(Int32) | Calculate a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method | GetCurveUV(Int32, Transform2D) | Calculate and transform a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method | GetEndPointReference | Returns a stable reference to the start or the end point of the edge.
Public method | GetFace | Returns one of the two faces that meet at the edge.
Public method | IsFlippedOnFace(Int32) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method | IsFlippedOnFace(Face) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.

Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | Reference | Returns a stable reference to the edge.

See Also

Edge Class

AsCurve Method

[image]