Revit 2024 API
CurtainGridLine Members
CurtainGridLine Class Methods Properties See Also Send Feedback

The CurtainGridLine type exposes the following members.

Methods

 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | RemoveSegment | Remove the segment specified by the input curve.

Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | Lock | Retrieves or changes the lock state of the curtain grid line.
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.

See Also

CurtainGridLine Class

CurtainGridLine Methods

[image] [image]