Revit 2024 API
Revision Members
Revision Class Methods Properties See Also Send Feedback

The Revision type exposes the following members.

Methods

 | Name | Description
 | CombineWithNext | Combines the specified Revision with the next Revision.
 | CombineWithPrevious | Combines the specified Revision with the previous Revision.
 | Create | Creates a new Revision in the project.
 | GetAllRevisionIds | Returns the ids of all Revisions in the project ordered by sequence number.
 | ReorderRevisionSequence | Reorders the sequence of Revisions in the project.

Properties

 | Name | Description
Public property | Description | The description of this Revision.
Public property | Issued | Indicates whether this Revision has been issued.
Public property | IssuedBy | Indicates who has issued or will issue this Revision.
Public property | IssuedTo | Indicates to whom this Revision was or will be issued.
Public property | RevisionDate | The date of this Revision.
Public property | RevisionNumber | The Revision number of this revision.
Public property | RevisionNumberingSequenceId | The id of the revision numbering sequence which controls this revision's numbering.
Public property | SequenceNumber | The Sequence Number of this Revision.
Public property | Visibility | Controls the visibility of revision clouds and revision tags related to this Revision.

See Also

Revision Class

Revision Methods

[image] [image]