Revit 2024 API
PDFExportOptions Properties
PDFExportOptions Class See Also Send Feedback

The PDFExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AlwaysUseRaster | If true completely use raster processing for graphics, otherwise use vector processing as much as possible.
Public property | ColorDepth | Color depth of either black/white, gray scale or color.
Public property | Combine | Whether export all views and sheets into one PDF file or multiple files.
Public property | ExportQuality | The preferred export quality (DPI).
Public property | FileName | File name of the PDF when Combine is trueTruetruetrue (True in Visual Basic).
Public property | HideCropBoundaries | Whether to hide crop boundaries.
Public property | HideReferencePlane | Whether to hide reference/work planes.
Public property | HideScopeBoxes | Whether to hide scope boxes.
Public property | HideUnreferencedViewTags | Whether to hide unreferenced view tags.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaskCoincidentLines | Whether to mask coincident lines.
Public property | OriginOffsetX | Offset between left sides of pdf content and paper. Always stored in unit of Feet.
Public property | OriginOffsetY | Offset between bottom sides of pdf content and paper. Always stored in unit of Feet.
Public property | PaperFormat | Paper format.
Public property | PaperOrientation | Paper orientation - Portrait/Landscape/Auto
Public property | PaperPlacement | Paper placement of either center or offset from corner.
Public property | RasterQuality | The preferred raster quality (DPI).
Public property | ReplaceHalftoneWithThinLines | Whether to replace halftone with thin lines.
Public property | StopOnError | Whether export process should stop when a view fails to export
Public property | ViewLinksInBlue | Whether set view links blue.
Public property | ZoomPercentage | Percentage of the zoom for the view.
Public property | ZoomType | Zoom type of either fit to page or on a specific percentage.

See Also

PDFExportOptions Class

AlwaysUseRaster Property

[image]