Revit 2024 API
CurtainGridLine Properties
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | Lock | Retrieves or changes the lock state of the curtain grid line.
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.

See Also

CurtainGridLine Class

AllSegmentCurves Property

[image]