Revit 2024 API
ReferencePoint Members
ReferencePoint Class Methods Properties See Also Send Feedback

The ReferencePoint type exposes the following members.

Methods

 | Name | Description
Public method | GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
Public method | GetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | GetHubId | Id of associated Hub.
Public method | GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
Public method | GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
Public method | GetVisibility | Gets the visibility for the point.
Public method | SetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
Public method | SetVisibility | Sets the visibility for the point.

Properties

 | Name | Description
Public property | CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
Public property | Name | (Overrides Element..::..Name.)
Public property | Position | The position of the ReferencePoint.
Public property | ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
Public property | Visible | Whether the point is visible when the family is loaded into a project.

See Also

ReferencePoint Class

ReferencePoint Methods

[image] [image]