Revit 2024 API
PartMakerMethodToDivideVolumes Methods
PartMakerMethodToDivideVolumes Class See Also Send Feedback

The PartMakerMethodToDivideVolumes type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectingReference | Adds intersecting reference with an offset.
Public method | AreElementsValidIntersectingReferences(ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.
Public method | Dispose |
Public method | GetOffsetForIntersectingReference | Gets offset for the intersecting reference.
Public method | GetPlaneOfSketch | Gets the plane of the sketch.
Public method | GetSketchCurves | Populates the array with copies of curves in the sketch.
Public method | GetSplitRefsOffsets | Returns offsets for plane-defining splitters.
Public method | IsElementValidIntersectingReference(ElementId) | Identifies if the provided member is valid.
 | IsElementValidIntersectingReference(Document, ElementId) | Identifies if the provided member is valid.
 | IsValidSketchPlane | Identifies if provided sketch plane is valid.
Public method | RemoveIntersectingReference | Removed intersecting reference.
Public method | SetOffsetForIntersectingReference | Sets offset for the intersecting reference.
Public method | UsesReference | Identifies if the PartMaker uses the intersecting reference.

See Also

PartMakerMethodToDivideVolumes Class

AreElementsValidIntersectingReferences Method

[image] [image]