Revit 2024 API
ComponentRepeater Members
ComponentRepeater Class Methods Properties See Also Send Feedback

The ComponentRepeater type exposes the following members.

Methods

 | Name | Description
 | CanElementBeRepeated | Determines whether an element can be repeated using the RepeatElements method.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | IsTypeValidForRepeater | Determines whether given family type can be used as the default type for the repeater.
 | RemoveRepeaters | Removes component repeaters from the document, but leaves the individual repeated components in their respective locations and hosted on their original hosts.
 | RepeatElements | Repeats a set of adaptive component hosted on one or more repeating references.

Properties

 | Name | Description
Public property | DefaultFamilyType | The default family type for the component repeater.
Public property | DimensionCount | The dimension count of the component repeater.

See Also

ComponentRepeater Class

ComponentRepeater Methods

[image] [image]