Revit 2024 API
TextElement Members
TextElement Class Methods Properties See Also Send Feedback

The TextElement type exposes the following members.

Methods

 | Name | Description
Public method | GetMaximumAllowedWidth()()()() | Returns the maximum width the text element can be assigned.
 | GetMaximumAllowedWidth(Document, ElementId) | Returns the maximum width the text element can be created with.
Public method | GetMinimumAllowedWidth()()()() | Returns the minimum width the text element can be assigned.
 | GetMinimumAllowedWidth(Document, ElementId) | Returns the minimum width a text element can be created with.

Properties

 | Name | Description
Public property | BaseDirection | Direction of the base line of the text element.
Public property | Coord | Position of the text (in model coordinates.)
Public property | Height | Height of the area of the text content.
Public property | HorizontalAlignment | Horizontal alignment of the text content within the text area of the element.
Public property | IsTextWrappingActive | A flag identifying whether text-wrapping is currently active in this text element or not. If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text. If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment
Public property | KeepRotatedTextReadable | A flag to control how text behaves inside a rotated text element.
Public property | Symbol | Get the type of the TextElement object.
Public property | Text | The content of the element as a plain string stripped of all formating.
Public property | UpDirection | Direction along the vertical axis of letters of the text note.
Public property | VerticalAlignment | Vertical alignment of the text.
Public property | Width | Width of the area of the text content.

See Also

TextElement Class

TextElement Methods

[image] [image]