Revit 2024 API
SaveAsOptions Members
SaveAsOptions Class Constructors Methods Properties See Also Send Feedback

The SaveAsOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SaveAsOptions | Default constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SaveAsOptions
Public method | GetWorksharingOptions | Gets Worksharing options for SaveAs.
Public method | SetWorksharingOptions | Sets Worksharing options for SaveAs.

Properties

 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumBackups | The maximum number of backups to keep on disk.
Public property | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

See Also

SaveAsOptions Class

SaveAsOptions Constructor

[image]