Revit 2024 API
Edge..::..AsCurve Method
Edge Class See Also Send Feedback
Returns a curve that corresponds to the edge's parametric orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve AsCurve()
Visual Basic
Public Function AsCurve As Curve
Visual C++
public:
Curve^ AsCurve()

Return Value

It can be an Arc, Line, or HermiteSpline.

See Also

Edge Class

AsCurveFollowingFace Method

[image]