Revit 2024 API
InCanvasControlData Members
InCanvasControlData Class Constructors Methods Properties See Also Send Feedback

The InCanvasControlData type exposes the following members.

Constructors

 | Name | Description
Public method | InCanvasControlData(String) | Constructs an InCanvasControlData with specific values assigned.
Public method | InCanvasControlData(String, XYZ) | Constructs an InCanvasControlData with specific values assigned.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the InCanvasControlData

Properties

 | Name | Description
Public property | ImagePath | The path to the image file to be used. This must be an absolute path to a location on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Position | The position of the in-canvas control in model coordinates.

See Also

InCanvasControlData Class

InCanvasControlData Constructor

[image] [image]