Revit 2024 API
ElementId Members
ElementId Class Constructors Methods Operators Properties See Also Send Feedback

The ElementId type exposes the following members.

Constructors

 | Name | Description
Public method | ElementId(Int32) | Obsolete. Create an ElementId handle with the given 32-bit integer id.
Public method | ElementId(Int64) | Create an ElementId handle with the given 64-bit integer id.
Public method | ElementId(BuiltInCategory) | Create an ElementId handle with the given BuiltInCategory id.
Public method | ElementId(BuiltInParameter) | Create an ElementId handle with the given BuiltInParameter id.

Methods

 | Name | Description
Public method | Compare | Compares two element ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
 | Parse | Parse the string representation of the id into a corresponding ElementId.
Public method | ToString | Gets a String representation of the value of the id. (Overrides Object..::..ToString()()()().)
 | TryParse | Parse the string representation of the id into a corresponding ElementId.

Operators

Name | Description
Equality | Determines whether these two ElementIds are the same.
GreaterThan | Determines whether one element id is greater than another element id.
GreaterThanOrEqual | Determines whether one element id is not less than another element id.
Inequality | Determines whether these two ElementIds are different.
LessThan | Determines whether this element id is less than another element id.
LessThanOrEqual | Determines whether one element id is not greater than another element id.

Properties

 | Name | Description
Public property | IntegerValue | Obsolete. Provides the value of the element id as a 32-bit integer.
 | InvalidElementId | Get the invalid ElementId whose value is -1.
Public property | Value | Provides the value of the element id as a 64-bit integer.

See Also

ElementId Class

ElementId Constructor (Int32)

[image]