Revit 2024 API
ConicalSurface Members
ConicalSurface Class Methods Properties See Also Send Feedback

The ConicalSurface type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a conical surface defined by a local reference frame and a half angle.
Public method | GetFrameOfReference | Returns frame of reference associated with this ConicalSurface.
 | IsValidConeAngle | Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2.

Properties

 | Name | Description
Public property | Axis | Axis of the cone. This is the Z axis of the local coordinate system associated with this cone.
Public property | HalfAngle | Cone angle.
Public property | Origin | Apex of the cone. This is the origin of the local coordinate system associated with this cone.
Public property | XDir | X axis of the local coordinate system associated with this cone.
Public property | YDir | X axis of the local coordinate system associated with this cone.

See Also

ConicalSurface Class

ConicalSurface Methods

[image] [image]