Revit 2024 API
DirectShapeType..::..SetShape Method (IList<(Of <(<'GeometryObject>)>)>)
DirectShapeType Class See Also Send Feedback
Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetShape(
    IList<GeometryObject> pGeomArr
)
Visual Basic
Public Sub SetShape ( _
    pGeomArr As IList(Of GeometryObject) _
)
Visual C++
public:
void SetShape(
    IList<GeometryObject^>^ pGeomArr
)

Parameters

pGeomArr
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Shape of this object expressed as a collection of GeometryObjects. These will be copied. Shape and Category should be consistent: geometry supplied as shape should be valid for the Category the type object is associated with. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
SetShape Overload

SetShape Method (ShapeBuilder)

[image]