Revit 2024 API
DetailElementOrderUtils..::..SendBackward Method (Document, View, ICollection<(Of <(<'ElementId>)>)>)
DetailElementOrderUtils Class See Also Send Feedback
Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static void SendBackward(
    Document document,
    View view,
    ICollection<ElementId> detailElementIds
)
Visual Basic
Public Shared Sub SendBackward ( _
    document As Document, _
    view As View, _
    detailElementIds As ICollection(Of ElementId) _
)
Visual C++
public:
static void SendBackward(
    Document^ document,
    View^ view,
    ICollection<ElementId^>^ detailElementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
view
Type: Autodesk.Revit.DB..::..View
The view in which the details appear.
detailElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The details to move backward.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailElementIds is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DetailElementOrderUtils Class
SendBackward Overload

SendToBack Method (Document, View, ElementId)

[image]