Revit 2024 API
LinearArray..::..Create Method (Document, View, ICollection<(Of <(<'ElementId>)>)>, Int32, XYZ, ArrayAnchorMember)
LinearArray Class See Also Send Feedback
Creates a new linear array element from a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static LinearArray Create(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    dBView As View, _
    ids As ICollection(Of ElementId), _
    count As Integer, _
    translationToAnchorMember As XYZ, _
    anchorMember As ArrayAnchorMember _
) As LinearArray
Visual C++
public:
static LinearArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements to array.
count
Type: System..::..Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
translationToAnchorMember
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the array.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The new linear array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the linear array.

See Also

LinearArray Class
Create Overload

GetCopiedMemberIds Method

[image]