Revit 2024 API
ExportFontTable Members
ExportFontTable Class Constructors Methods Properties See Also Send Feedback

The ExportFontTable type exposes the following members.

Constructors

 | Name | Description
Public method | ExportFontTable | Constructs a new ExportFontTable with default values.

Methods

 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export font table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a font key exists in the table.
Public method | Dispose | Releases all resources used by the ExportFontTable
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportFontInfo | Gets a copy of the font info associated to the input font key.
Public method | GetFontTableIterator | Returns a FontTableIterator that iterates through the collection.
Public method | GetKeys | Returns a collection of the keys stored in this table.
Public method | GetValues | Returns a collection of the values stored in this table.
Public method | Remove | Removes the pair (key, info) by font key.

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportFontInfo for the font's ExportFontKey.

See Also

ExportFontTable Class

ExportFontTable Constructor

[image]