Revit 2024 API
SketchEditScope Methods
SketchEditScope Class See Also Send Feedback

The SketchEditScope type exposes the following members.

Methods

 | Name | Description
Public method | IsElementWithoutSketch | Validates if an element can have a sketch but currently does not.
Public method | IsSketchEditingSupported | Checks whether sketch can be edited.
Public method | IsSketchEditingSupportedForSketchBasedElement | Checks whether the element supports sketch editing.
Public method | Start | Starts a sketch edit mode.
Public method | StartWithNewSketch | Starts a sketch edit mode for an element which, at this moment, doesn't have a sketch.

See Also

SketchEditScope Class

IsSketchEditingSupported Method

[image]