Revit 2024 API
DirectShape..::..AppendShape Method (IList<(Of <(<'GeometryObject>)>)>)
DirectShape Class See Also Send Feedback
Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void AppendShape(
    IList<GeometryObject> pGeomArr
)
Visual Basic
Public Sub AppendShape ( _
    pGeomArr As IList(Of GeometryObject) _
)
Visual C++
public:
void AppendShape(
    IList<GeometryObject^>^ pGeomArr
)

Parameters

pGeomArr
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Shape expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Remarks

The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AppendShape Overload

AppendShape Method (ShapeBuilder)

[image]