Revit 2024 API
BuiltInFailures..::..SiteImportFailures Properties
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback

The BuiltInFailures..::..SiteImportFailures type exposes the following members.

Properties

Name | Description
BoundaryDetectError | A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.
ContoursNoncontours | The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.
DifferentEntityTypes | Can't auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.
InvalidBoundaryError | Failed to get a valid boundary.
NoPoints | No points were found in the file.
NoViewSpecificSiteImports | Can't make Toposurface from View Specific Imports.
SurfaceExists | You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.
TooFarAway | Imported Toposolid Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.
TooFewPoints | The toposolid must have at least three distinct points
TooLarge | There are too many points on the selected layers of this dataset to place into the toposolid. Try selecting fewer layers to create the toposolid
TooManyMeshes | The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.
UnusedPoints | Some rows from the file could not be used.

See Also

BuiltInFailures..::..SiteImportFailures Class

BoundaryDetectError Property

[image]