Revit 2024 API
CADLinkOptions Members
CADLinkOptions Class Constructors Methods Properties See Also Send Feedback

The CADLinkOptions type exposes the following members.

Constructors

 | Name | Description
Public method | CADLinkOptions(CADLinkOptions) | Constructs a new copy of the input CADLinkOptions object.
Public method | CADLinkOptions(Boolean, ElementId) | Creates a CADLinkOptions object, specifying whether to preserve graphic overrides, and what view to use if the link's view has been deleted.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CADLinkOptions

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreserveOverrides | Whether Revit should preserve the link's graphic overrides on reload.
Public property | ViewId | The id of the view to use as the link's reference view, if the reference view has been deleted.

See Also

CADLinkOptions Class

CADLinkOptions Constructor

[image] [image]