Revit 2024 API
ImageExportOptions Methods
ImageExportOptions Class See Also Send Feedback

The ImageExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
 | GetFileName | Gets the file name that will be produced when exporting a view to an image.
Public method | GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
 | IsValidFileName | Verify if File name is valid
 | IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
Public method | SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.

See Also

ImageExportOptions Class

Dispose Method

[image]