Revit 2024 API
BuiltInFailures..::..GenericMEPFailures Properties
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback

The BuiltInFailures..::..GenericMEPFailures type exposes the following members.

Properties

Name | Description
CapsWereAddedWarning | X caps were added.
CapWasAddedWarning | 1 cap was added.
FailedToPlaceCapWarning | Failed to place cap on the open connector.
FlowConfigMismatch | [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
FlowDirectionMismatch | [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
InlineEndoflineMismatch | [Element Name]: It is not possible to calculate the flow since there is inline equipment that is configured as end of line. Please check equipment in this system and make sure that the equipment connectors used inline have a global system classification and a calculated flow configuration. Global equipment connectors used inline should always be linked to each other.
MaxWidthAndHeightReached | Maximum width and height reached during sizing
SegmentIsTooShort | The segment is too short.
SizingFailedZeroFlow | Sizing failed. Flow for section is 0.
SplitElementDeletionWarning | The value specified for the Joint Gap exceeds the length of the split segment, so the segment will be deleted.
ValidatePHSegmentConnWarning | The placeholder curve will not be able to connect to the required fittings for placeholder convert
ValidatePHSegmentLengthWarning | The placeholder curve is not long enough to support the required fittings for placeholder convert

See Also

BuiltInFailures..::..GenericMEPFailures Class

CapsWereAddedWarning Property

[image]