Revit 2024 API
OverrideGraphicSettings Members
OverrideGraphicSettings Class Constructors Methods Properties See Also Send Feedback

The OverrideGraphicSettings type exposes the following members.

Constructors

 | Name | Description
Public method | OverrideGraphicSettings()()()() | Creates a new instance of an OverrideGraphicSettings object.
Public method | OverrideGraphicSettings(OverrideGraphicSettings) | Creates a new instance of an OverrideGraphicSettings object based on an existing OverrideGraphicSettings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the OverrideGraphicSettings
Public method | SetCutBackgroundPatternColor | Sets the override color of the background pattern of cut faces.
Public method | SetCutBackgroundPatternId | Sets the ElementId of the cut face background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutBackgroundPatternVisible | Sets the visibility of the cut face background fill pattern.
Public method | SetCutForegroundPatternColor | Sets the override color of the foreground pattern of cut faces.
Public method | SetCutForegroundPatternId | Sets the ElementId of the cut face foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutForegroundPatternVisible | Sets the visibility of the cut face foreground fill pattern.
Public method | SetCutLineColor | Sets the cut surface line color.
Public method | SetCutLinePatternId | Sets the ElementId of the cut surface line pattern.
Public method | SetCutLineWeight | Sets the cut surface line weight.
Public method | SetDetailLevel | Sets the detail level.
Public method | SetHalftone | Sets the halftone value.
Public method | SetProjectionLineColor | Sets the projection surface line color.
Public method | SetProjectionLinePatternId | Sets the ElementId of the projection surface line pattern.
Public method | SetProjectionLineWeight | Sets the projection surface line weight.
Public method | SetSurfaceBackgroundPatternColor | Sets the override color of the surface background pattern.
Public method | SetSurfaceBackgroundPatternId | Sets the ElementId of the surface background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceBackgroundPatternVisible | Sets the visibility of the surface background fill pattern.
Public method | SetSurfaceForegroundPatternColor | Sets the override color of the surface foreground pattern.
Public method | SetSurfaceForegroundPatternId | Sets the ElementId of the surface foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceForegroundPatternVisible | Sets the visibility of the surface foreground fill pattern.
Public method | SetSurfaceTransparency | Sets the projection surface transparency.

Properties

 | Name | Description
Public property | CutBackgroundPatternColor | The override color of the background pattern of cut faces.
Public property | CutBackgroundPatternId | The ElementId of the cut face background fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutForegroundPatternColor | The override color of the foreground pattern of cut faces.
Public property | CutForegroundPatternId | The ElementId of the cut face foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutLineColor | Cut surface line color.
Public property | CutLinePatternId | ElementId of the cut surface line pattern.
Public property | CutLineWeight | Cut surface line weight.
Public property | DetailLevel | The detail level.
Public property | Halftone | Value of the halftone override.
 | InvalidPenNumber | The invalidPenNumber for clearing line weight overrides.
Public property | IsCutBackgroundPatternVisible | The visibility of the cut face background fill pattern.
Public property | IsCutForegroundPatternVisible | The visibility of the cut face foreground fill pattern.
Public property | IsSurfaceBackgroundPatternVisible | The visibility of the surface background fill pattern.
Public property | IsSurfaceForegroundPatternVisible | The visibility of the surface foreground fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProjectionLineColor | Projection surface line color.
Public property | ProjectionLinePatternId | Id of the projection surface line pattern.
Public property | ProjectionLineWeight | The projection surface line weight.
Public property | SurfaceBackgroundPatternColor | The override color of the surface background pattern.
Public property | SurfaceBackgroundPatternId | The ElementId of the surface background fill pattern override. A value of InvalidElementId means no override is set.
Public property | SurfaceForegroundPatternColor | The override color of the surface foreground pattern.
Public property | SurfaceForegroundPatternId | The ElementId of the surface foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | Transparency | Transparency of surfaces.

See Also

OverrideGraphicSettings Class

OverrideGraphicSettings Constructor

[image] [image]