Revit 2024 API
ExportLayerInfo Members
ExportLayerInfo Class Constructors Methods Properties See Also Send Feedback

The ExportLayerInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLayerInfo | Constructs a new ExportLayerInfo with default values.

Methods

 | Name | Description
Public method | AddCutLayerModifier | Adds a cut layer modifier to the layer info.
Public method | AddLayerModifier | Adds a project layer modifier to the layer info.
Public method | ClearCutLayerModifiers | Clears all the cut layer modifiers stored in the layer info.
Public method | ClearLayerModifiers | Clears all the project layer modifiers stored in the layer info.
Public method | Dispose | Releases all resources used by the ExportLayerInfo
Public method | GetCutLayerModifiers | Gets all the cut layer modifiers from the layer info.
Public method | GetLayerModifiers | Gets all the project layer modifiers from the layer info.
Public method | RemoveCutLayerModifier | Removes a cut layer modifier from the layer info.
Public method | RemoveLayerModifier | Removes a project layer modifier from the layer info.
Public method | SetCutLayerModifiers | Sets a cut layer modifier array to the layer info.
Public method | SetLayerModifiers | Sets a project layer modifier array to the layer info.

Properties

 | Name | Description
Public property | CategoryType | The category type which this layer belongs to.
Public property | ColorName | The color name stored in value. For IFC export, the naming is to match the "colornumber" setting -- really, this stores a string that generates the colorNumber (for formats that don't use the color but need a second entry.)
Public property | ColorNumber | The color number stored in value.
Public property | CutColorNumber | The cut color number stored in value.
Public property | CutLayerName | The cut layer name stored in value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerName | The layer name stored in value.

See Also

ExportLayerInfo Class

ExportLayerInfo Constructor

[image]