Revit 2024 API
FillGrid Members
FillGrid Class Constructors Methods Properties See Also Send Feedback

The FillGrid type exposes the following members.

Constructors

 | Name | Description
Public method | FillGrid()()()() | Creates a simple fill grid.
Public method | FillGrid(FillGrid) | Constructs a new FillGrid with default settings.
Public method | FillGrid(Double, Double) | Creates a simple fill grid with given angle and offset.

Methods

 | Name | Description
Public method | CalculateLengthPerArea | Calculates length of the pattern per unit area.
Public method | CalculateLinesPerLength | Calculates the number of solid lines of the pattern per unit length.
Public method | CalculateStrokesPerArea | Calculates the number of the segments of the pattern per unit area.
Public method | Dispose | Releases all resources used by the FillGrid
Public method | GetHatchingDirection | Provides the hatching propagation. Hatching is inverted.
Public method | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point.
Public method | GetPointLineZone(UV, UV%) | Gets the index of fill grid line and the point on the grid line nearest to the input point.
Public method | GetSegmentDirection | Provides the segment direction.
Public method | GetSegments | Gets the segments of the fill grid.
Public method | IsEqual | Check if two fill grids are equal.
Public method | SetSegments | Sets the segments to the fill grid.

Properties

 | Name | Description
Public property | Angle | Gets and sets the angle of the fill grid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Offset | Gets and sets the offset of the fill grid.
Public property | Origin | Gets and sets the origin of the fill grid.
Public property | Shift | Gets and sets the shift of the fill grid.

See Also

FillGrid Class

FillGrid Constructor

[image] [image]