Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes Properties
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback

The ExternalResourceTypes..::..BuiltInExternalResourceTypes type exposes the following members.

Properties

Name | Description
AssemblyCodeTable | An external resource type representing assembly code data.
CADLink | An external resource type representing CAD Links data.
DecalBumpMap | An external resource type representing Decal linked data for bump map. This type is reserved for future expansion but not yet implemented.
DecalCutOut | An external resource type representing Decal linked data for cut out opacity. This type is reserved for future expansion but not yet implemented.
DecalImage | An external resource type representing decal images.
DecalMap | An external resource type representing Decal linked data for diffuse. This type is reserved for future expansion but not yet implemented.
DWFMarkup | An external resource type representing DWF markups data. This type is reserved for future expansion but not yet implemented.
FabricationConfiguration | An external resource type representing an MEP fabrication configuration.
IFCLink | An external resource type representing IFC links.
Image | An external resource type representing images.
KeynoteTable | An external resource type representing keynote data.
MaterialTexture | An external resource type representing material texture images.
PointCloud | An external resource type representing Point Clouds. This type is reserved for future expansion but not yet implemented.
RevitLink | An external resource type representing Revit Links data.
SystemsAnalysisReport | An external resource type representing systems analysis report path.
TopographyLink | An external resource type representing Topography Links.

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class

AssemblyCodeTable Property

[image]