Revit 2024 API
ModelCurveArray Methods
ModelCurveArray Class See Also Send Feedback

The ModelCurveArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

See Also

ModelCurveArray Class

Append Method

[image]