Revit 2024 API
ViewSchedule Properties
ViewSchedule Class See Also Send Feedback

The ViewSchedule type exposes the following members.

Properties

 | Name | Description
Public property | BodyTextTypeId | Defines the default text style used for the data section of the schedule.
Public property | Definition | The primary ScheduleDefinition.
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | HasStripedRows | Indicates whether this schedule has striped rows.
Public property | HeaderTextTypeId | Defines the default text style used in the column headers in the body section of the schedule.
Public property | ImageRowHeight | Obsolete. Defines the image row height in the schedule.
 | IsHeaderFrozen | A static property defining if the schedule header frozen setting is turned on or off in current Revit Application Session.
Public property | IsInternalKeynoteSchedule | Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.
Public property | IsTitleblockRevisionSchedule | Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.
Public property | KeyScheduleParameterName | In a key schedule, the name of the parameter for choosing one of the keys.
Public property | RowHeight | Defines the schedule body rows height.
Public property | RowHeightOverride | Defines the override that is applied to the row height.
Public property | TitleTextTypeId | Defines the default text style used in the header section of the schedule.
Public property | UseStripedRowsOnSheets | Indicates whether a property setting of true will also change the display of this schedule to show striped rows on a sheet. If true, setting that property to true will also change the display. If false, striped rows will not display for this schedule on a sheet no matter what value is set for HasStripedRows.

See Also

ViewSchedule Class

BodyTextTypeId Property

[image]