Revit 2024 API
FamilyParameter Properties
FamilyParameter Class See Also Send Feedback

The FamilyParameter type exposes the following members.

Properties

 | Name | Description
Public property | AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
Public property | CanAssignFormula | Indicates if this parameter can be assigned a formula.
Public property | Definition | The definition.
Public property | Formula | The formula.
Public property | GUID | The globally unique identifier
Public property | Id | The id of the family parameter.
Public property | IsDeterminedByFormula | Indicates if the parameter is determined by formula.
Public property | IsInstance | Indicates if the parameter is instance or type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Overrides APIObject..::..IsReadOnly.)
Public property | IsReporting | Indicates if the parameter is a reporting parameter.
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.
Public property | UserModifiable | Indicates whether the interactive user can modify the value of this parameter.

See Also

FamilyParameter Class

AssociatedParameters Property

[image]