Revit 2024 API
LinkLoadResult Methods
LinkLoadResult Class See Also Send Feedback

The LinkLoadResult type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetCentralModelName | Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.
Public method | GetExternalResourceReference | Gets a copy of the ExternalResourceReference corresponding to the link.
Public method | GetExternalResourceReferencesFromFailedLoads | Searches this and all nested LinkLoadResults, and returns a list of ExternalResourceReferences for the links that failed to load.
Public method | GetLinkLoadResult | Searches this LinkLoadResult and all nested LinkLoadResults for the load operation results of a specified ExternalResourceReference.
Public method | GetModelName | Gets the name of the model.
Public method | GetNestedLinkLoadResults | Gets the results for this link's nested links.
Public method | GetParentModelName | Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.
 | IsCodeSuccess | Check if load result code signifies success.

See Also

LinkLoadResult Class

GetCentralModelName Method

[image]