Revit 2024 API
PolyLine Members
PolyLine Class Methods Properties See Also Send Feedback

The PolyLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this polyline.
 | Create | Creates a polyline with coordinate points provided.
Public method | Evaluate | Evaluates a parameter on the polyline.
Public method | GetCoordinate | Gets the coordinate point of the specified index.
Public method | GetCoordinates | Gets the coordinate points of the polyline.
Public method | GetOutline | Gets the outline of the polyline.
Public method | GetTransformed | Gets the copy of the polyline which is applied the specified transformation.

Properties

 | Name | Description
Public property | NumberOfCoordinates | Gets the number of the coordinate points.

See Also

PolyLine Class

PolyLine Methods

[image] [image]