Revit 2024 API
RoutingPreferenceRule Properties
RoutingPreferenceRule Class See Also Send Feedback

The RoutingPreferenceRule type exposes the following members.

Properties

 | Name | Description
Public property | Description | The description of the routing preference rule.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPPartId | The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
Public property | NumberOfCriteria | Gets the number of routing criteria.
Public property | RoutingPreferenceManager | Gets the routing preference manager that owns this rule.

See Also

RoutingPreferenceRule Class

Description Property

[image]