Revit 2024 API
TessellatedShapeBuilderResult Properties
TessellatedShapeBuilderResult Class See Also Send Feedback

The TessellatedShapeBuilderResult type exposes the following members.

Properties

 | Name | Description
Public property | AreObjectsAvailable | Shows whether 'issues' still contains the original data or whether these data have already been relinquished by 'getGeometricalObjects'. The former is true, the later is false.
Public property | HasInvalidData | Whether there were any inconsistencies in the face sets, stored in the tessellated shape builder while building geometrical objects.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Outcome | What kinds of geometrical objects were built.

See Also

TessellatedShapeBuilderResult Class

HasInvalidData Property

[image]