Revit 2024 API
ElementDesignOptionFilter Members
ElementDesignOptionFilter Class Constructors Methods Properties See Also Send Feedback

The ElementDesignOptionFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementDesignOptionFilter(ElementId) | Constructs a new instance of a filter to match elements contained within a particular design option.
Public method | ElementDesignOptionFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | DesignOptionId | The design option id.

See Also

ElementDesignOptionFilter Class

ElementDesignOptionFilter Constructor

[image] [image]