Revit 2024 API
Surface Members
Surface Class Methods Properties See Also Send Feedback

The Surface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Surface
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.

See Also

Surface Class

Surface Methods

[image] [image]