Revit 2024 API
SpatialElement Members
SpatialElement Class Methods Properties See Also Send Feedback

The SpatialElement type exposes the following members.

Methods

 | Name | Description
Public method | GetBoundarySegments | Returns the boundary segments.
Public method | GetSpatialElementDomainData | Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data.

Properties

 | Name | Description
Public property | Area | The area.
Public property | Level | Gets the level of the room.
Public property | Location | The location of the element. (Overrides Element..::..Location.)
Public property | Name | A human readable name for the Element. (Overrides Element..::..Name.)
Public property | Number | The number.
Public property | Perimeter | The perimeter.
Public property | SpatialElementType | The spatial element type.

See Also

SpatialElement Class

SpatialElement Methods

[image] [image]