Revit 2024 API
CompoundStructure Properties
CompoundStructure Class See Also Send Feedback

The CompoundStructure type exposes the following members.

Properties

 | Name | Description
Public property | CutoffHeight | Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.
Public property | EndCap | Indicates the end cap condition defining which shell layers will participate in end wrapping.
Public property | HasStructuralDeck | Checks if the compound structure has a structural deck.
Public property | IsEmpty | Checks whether this CompoundStructure is empty.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVerticallyCompound | Identifies if this CompoundStructure represents a layout that is more complicated than a simple set of parallel layers.
Public property | LayerCount | Returns the number of layers contained in this CompoundStructure.
Public property | MinimumSampleHeight | The minimum sample height determined by the current sample height and the horizontal segments.
Public property | OpeningWrapping | Indicates the opening wrapping condition defining which shell layers of a wall, in plan view, wrap at inserts and openings.
Public property | SampleHeight | The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.
Public property | StructuralMaterialIndex | Indicates the layer whose material defines the structural properties of the type for the purposes of analysis.
Public property | VariableLayerIndex | Indicates the index of the layer which is designated as variable.

See Also

CompoundStructure Class

CutoffHeight Property

[image]