Revit 2024 API
Color Members
Color Class Constructors Methods Properties See Also Send Feedback

The Color type exposes the following members.

Constructors

 | Name | Description
Public method | Color | Constructor that takes the red, green and blue channels of the color.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | Blue | Get the blue channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
Public property | Green | Get the green channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
 | InvalidColorValue | Get the invalid Color whose IntegerValue is -1.
Public property | IsValid | Identifies if the color represents a valid color, or an uninitialized/invalid value.
Public property | Red | Get the red channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.

See Also

Color Class

Color Methods

[image] [image]