Revit 2024 API
ReferencePlane Members
ReferencePlane Class Methods Properties See Also Send Feedback

The ReferencePlane type exposes the following members.

Methods

 | Name | Description
Public method | Flip | Flips the orientation of the reference plane.
Public method | GetPlane | Returns the geometry plane to which the reference plane is assigned.
Public method | GetReference | Returns the geometry reference of the reference plane.

Properties

 | Name | Description
Public property | BubbleEnd | The bubble end of the reference plane.
Public property | Direction | The direction of the reference plane.
Public property | FreeEnd | The free end of the reference plane.
Public property | Name | The name property of the reference plane.
Public property | Normal | The normal vector of the reference plane.

See Also

ReferencePlane Class

ReferencePlane Methods

[image] [image]