Revit 2024 API
FamilyManager Methods
FamilyManager Class See Also Send Feedback

The FamilyManager type exposes the following members.

Methods

 | Name | Description
Public method | AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Obsolete. Add a new shared parameter to the family.
Public method | AddParameter(ExternalDefinition, ForgeTypeId, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Obsolete. Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, ForgeTypeId, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, ForgeTypeId, ForgeTypeId, Boolean) | Add a new family parameter with a given name.
Public method | AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
Public method | CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
Public method | DeleteCurrentType | Remove the current family type.
Public method | GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
Public method | GetParameter | Obtains the family parameter with the given built-in parameter identifier.
Public method | GetParameters | Gets the parameters associated to family types in order.
Public method | IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
Public method | IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
Public method | IsUserAssignableParameterGroup(BuiltInParameterGroup) | Obsolete. Checks if the given parameter group can be assigned to new parameters.
Public method | IsUserAssignableParameterGroup(ForgeTypeId) | Checks if the given parameter group can be assigned to new parameters.
Public method | MakeInstance | Set the family parameter as an instance parameter.
Public method | MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
Public method | MakeReporting | Set the family parameter as a reporting parameter.
Public method | MakeType | Set the family parameter as a type parameter.
Public method | NewType | Add a new family type with a given name and makes it be the current type.
Public method | RemoveParameter | Remove an existing family parameter from the family.
Public method | RenameCurrentType | Rename the current family type.
Public method | RenameParameter | Rename a family parameter.
Public method | ReorderParameters | Reorders the family parameters by the specified parameters order.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean) | Obsolete. Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean) | Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, String, BuiltInParameterGroup, Boolean) | Obsolete. Replace a shared family parameter with a new non-shared family parameter.
Public method | ReplaceParameter(FamilyParameter, String, ForgeTypeId, Boolean) | Replace a shared family parameter with a new non-shared family parameter.
Public method | Set(FamilyParameter, ElementId) | Set the ElementId value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.
Public method | SetDescription | Set the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public method | SetFormula | Set the formula of a family parameter.
Public method | SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
Public method | SetValueString | Set the string value of a family parameter of the current family type.
Public method | SortParameters | Sorts the family parameters according to the desired sort order.

See Also

FamilyManager Class

AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)

[image]