Revit 2024 API
ContourSetting Members
ContourSetting Class Methods Properties See Also Send Feedback

The ContourSetting type exposes the following members.

Methods

 | Name | Description
Public method | AddContourRange | Add a set of contours as a contour setting item to the current contour setting.
Public method | AddSingleContour | Add a single contour as a contour setting item to the current contour setting.
Public method | DisableItem | Disable a contour setting item of the current contour setting so that the item will not be used to draw contours.
Public method | Dispose | Releases all resources used by the ContourSetting
Public method | EnableItem | Enable a contour setting item of the current contour setting so that the item will be used to draw contours.
Public method | GetContourSettingItems | Get all contour setting items.
Public method | GetItemIndex | Get the index of a contour setting item of the current contour setting
Public method | RemoveItem | Remove a contour setting item from the current contour setting.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ContourSetting Class

AddContourRange Method

[image]