Revit 2024 API
Transform1D Methods
Transform1D Class See Also Send Feedback

The Transform1D type exposes the following members.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
Public method | Dispose |
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the 1-dimensional point and returns the result.
Public method | OfVector | Applies the transformation to the 1-dimensional vector (a "tangent vector" on the real line) and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform
Public method | TransformParameterDomain | Performs a transform of the parameter range defined by domain, and ensures that the domain is ordered correctly.

See Also

Transform1D Class

AlmostEqual Method

[image]