Revit 2024 API
TemporaryViewModes Properties
TemporaryViewModes Class See Also Send Feedback

The TemporaryViewModes type exposes the following members.

Properties

 | Name | Description
Public property | CustomColor | Custom color for the TemporaryViewProperties mode.
Public property | CustomTitle | Custom title for the TemporaryViewProperties mode.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreviewFamilyVisibility | The current state of the PreviewFamilyVisibility mode in the associated view.
 | PreviewFamilyVisibilityDefaultOnState | Controls the default state of the PreviewFamilyVisibility mode in all views.
 | PreviewFamilyVisibilityDefaultUncutState | Controls the default type of the On state of the PreviewFamilyVisibility mode in cut-able views.
Public property | RevealConstraints | The current state of the RevealConstraints mode in the associated view.
Public property | RevealHiddenElements | The current state of the RevealHiddenElements mode in the associated view.
Public property | WorksharingDisplay | The current state of the WorksharingDisplay mode in the associated view.

See Also

TemporaryViewModes Class

CustomColor Property

[image]