Revit 2024 API
MultiReferenceAnnotationType Methods
MultiReferenceAnnotationType Class See Also Send Feedback

The MultiReferenceAnnotationType type exposes the following members.

Methods

 | Name | Description
 | CreateDefault | Creates the first MultiReferenceAnnotationType element and adds it to the document.
Public method | GetAllowedTagCategory | Returns the category ID for the tag types which can be used by this multi-reference annotation type.
Public method | IsAllowedDimensionStyle | Checks if the dimension style can be used with multi-reference annotations.
Public method | IsAllowedReferenceCategory | Checks if the reference category can be used with multi-reference annotations.
 | IsAllowedTagCategory | Returns true if tag types belonging to this category can be used with multi-reference annotation types.
Public method | IsAllowedTagType | Checks if the tag type can be assigned to this multi-reference annotation type.

See Also

MultiReferenceAnnotationType Class

CreateDefault Method

[image]