Revit 2024 API
BuiltInFailures..::..PipingFailures Properties
BuiltInFailures..::..PipingFailures Class See Also Send Feedback

The BuiltInFailures..::..PipingFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForPipe | Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.
CircularLoopInPipeSizing | Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.
DuctPipeModified | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
DuctPipeSizeMismatch | The duct/pipe size is invalid for the service definition
FabFittingFailed | The Fabrication Fitting was invalid
InvalidPipeSize | Pipe Size Table "[File Name]" is missing or invalid.
MaxPipeSizeReached | Maximum pipe size diameter reached during sizing
PartNotFoundDueToNoPipeConnectedError | "In order to find a matching part, the fitting has to be connected to a pipe."
PartNotFoundDueToNoPipeConnectedWarning | "In order to find a matching part, the fitting has to be connected to a pipe."
PartNotFoundInRoutingPreferenceError | "%1s is not found. Please review the routing preference of %2s."
PartNotFoundInRoutingPreferenceWarning | "%1s is not found. Please review the routing preference of %2s."

See Also

BuiltInFailures..::..PipingFailures Class

CannotCreateGeometryForPipe Property

[image]