Revit 2024 API
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished.
Public property | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
Public property | Geometry | Retrieves the geometric representation of the element.
Public property | GroupId | The id of the group to which an element belongs.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project.
Public property | IsModifiable | Identifies if the element is modifiable.
Public property | IsTransient | Indicates whether an element is transient or permanent.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LevelId | The id of the level associated with the element.
Public property | Location | This property is used to find the physical location of an element within a project.
Public property | Name | A human readable name for the Element.
Public property | OwnerViewId | The id of the view that owns the element.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter.
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id.
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | Pinned | Identifies if the element has been pinned to prevent changes.
Public property | UniqueId | A stable unique identifier for an element within the document.
Public property | VersionGuid | Get the element version Guid.
Public property | ViewSpecific | Identifies if the element is owned by a view.
Public property | WorksetId | Get Id of the Workset which owns the element.

See Also

Element Class

AssemblyInstanceId Property

[image]