Revit 2024 API
CombinableElementArray Members
CombinableElementArray Class Constructors Methods Properties See Also Send Feedback

The CombinableElementArray type exposes the following members.

Constructors

 | Name | Description
Public method | CombinableElementArray | Initializes a new instance of the CombinableElementArray class

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every CombinableElement from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a CombinableElement at a specified index within the array.
Public property | Size | Returns the number of CombinableElements that are in the array.

See Also

CombinableElementArray Class

CombinableElementArray Constructor

[image]