Revit 2024 API
ParameterDownloadOptions Members
ParameterDownloadOptions Class Constructors Methods Properties See Also Send Feedback

The ParameterDownloadOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterDownloadOptions()()()() | Default constructor.
Public method | ParameterDownloadOptions(ISet<(Of <<'(ElementId>)>>), Boolean, Boolean, ForgeTypeId) | Creates a new ParameterDownloadOptions instance. Category bindings are represented by an ElementIdSet populated with category identifiers.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ParameterDownloadOptions
Public method | GetCategories | Get categories for binding.
Public method | GetGroupTypeId | Get properties palette group identifier.
Public method | SetCategories | Set categories for binding.
Public method | SetGroupTypeId | Set properties palette group identifier.

Properties

 | Name | Description
Public property | IsInstance | True if binding to Element instances, false if binding to Element types.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Visible | True if the parameter is visible to the user, false if it is hidden and accessible only via the API.

See Also

ParameterDownloadOptions Class

ParameterDownloadOptions Constructor

[image]