Revit 2024 API
ExternalResourceBrowserData..::..AddResource Method (String, String, IDictionary<(Of <(<'String, String>)>)>)
ExternalResourceBrowserData Class See Also Send Feedback
Adds an external resource to the folder path by supplying the resource name, version and reference information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddResource(
    string resourceName,
    string version,
    IDictionary<string, string> referenceInformation
)
Visual Basic
Public Sub AddResource ( _
    resourceName As String, _
    version As String, _
    referenceInformation As IDictionary(Of String, String) _
)
Visual C++
public:
void AddResource(
    String^ resourceName,
    String^ version,
    IDictionary<String^, String^>^ referenceInformation
)

Parameters

resourceName
Type: System..::..String
The unique short name of external resource.
version
Type: System..::..String
The version of external resource.
referenceInformation
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The (String, String) map containing reference or lookup information that will be stored in Revit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceBrowserData Class
AddResource Overload

AddSubFolder Method (String)

[image]