Revit 2024 API
ExternalResourceLoadContext Members
ExternalResourceLoadContext Class Methods Properties See Also Send Feedback

The ExternalResourceLoadContext type exposes the following members.

Methods

 | Name | Description
Public method | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource has a defined ModelPath.
Public method | Dispose | Releases all resources used by the ExternalResourceLoadContext
Public method | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource.
Public method | GetCurrentlyLoadedReference | Returns a copy of the ExternalResourceReference currently in use by the containing element.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadOperationType | An enum value indicating whether the resource load was triggered by an automatic event (such as file open) or an explicit user action.

See Also

ExternalResourceLoadContext Class

CallingDocumentHasModelPath Method

[image]