Revit 2024 API
DirectShape..::..AppendShape Method
DirectShape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>)) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.

See Also

DirectShape Class
DirectShape Members

AppendShape Method (IList(GeometryObject))

[image]