Revit 2024 API
Element..::..CanHaveTypeAssigned Method (Document, ICollection<(Of <(<'ElementId>)>)>)
Element Class See Also Send Feedback
Checks if all elements in the set can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool CanHaveTypeAssigned(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function CanHaveTypeAssigned ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanHaveTypeAssigned(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A collection of element IDs.

Return Value

True if all elements in the set can have a type assigned, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class
CanHaveTypeAssigned Overload

ChangeTypeId Method

[image] [image]