Revit 2024 API
CurveByPointsArray Members
CurveByPointsArray Class Constructors Methods Properties See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Constructors

 | Name | Description
Public method | CurveByPointsArray | Initializes a new instance of the CurveByPointsArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.

See Also

CurveByPointsArray Class

CurveByPointsArray Constructor

[image]