Revit 2024 API
BuiltInFailures..::..RebarShapeFailures Properties
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback

The BuiltInFailures..::..RebarShapeFailures type exposes the following members.

Properties

Name | Description
CircleMultiPlanarShape | A circle can't be converted to multiplanar shape.
CircleUnbounded | An unbounded circle can only be used to construct a spiral shape.
CurveOverconstrained | Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
CurvesCollinear | Collinear segments are not allowed in a Rebar Shape definition.
CurvesUnlooped | Segments defining the Rebar Shape must be in a continuous loop.
CurveUnderconstrained | Segment is underconstrained. It requires additional parameterized dimensions.
DefaultParamaterValuesIncorrect | Default parameters have incorrect values. One reason for failure might be an edge length that is too short (it's smaller than bent radius).
DepthDimensionNotExisted | Multi-planar shape's depth dimension has been deleted. Please assign a new one to multi-planar depth.
DiagonalEdgesAreUnderconstrained | Shape is underconstrained. Please add additional dimension constraints to the shape's diagonal edges. (Diagonal segments with only one dimension constraint are automatically given a second constraint to lie at an angle of exactly 45 degrees, regardless of how they are drawn. The current shape has more than one such segment in sequence, and the resulting constrained edges are co-linear.)
DimensionLoose | This dimension cannot be used to parameterize the Rebar Shape.
DimensionWithCommonLengthUnit | A shape dimension is labelled with a parameter that uses the Common Length unit.
DimensionWithoutParameter | Dimension has no parameter assigned to it.
FormulaDrivenDimension | Dimension can't be driven by a formula parameter.
HooksAndEndTreatmentAtTheSameEnd | Cannot add hooks and end treatments at the same end.
MultiPlanarDepth | Multi-planar depth of Rebar Shape can't be too small.
MultipleArcsMustOverlap | Multiple arcs are supported only if they are concentric and form a circle with an overlap.
ParameterValueNotDefined | Parameter assigned to the dimension has no value defined.
PlanarMultiPlanarShape | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
ShapeFailure | The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.
WrongDepthDimensionLabel | Multi-planar depth dimension label is already used for one of the planar shape parameters.

See Also

BuiltInFailures..::..RebarShapeFailures Class

CircleMultiPlanarShape Property

[image]