Revit 2024 API
BaseExportOptions Methods
BaseExportOptions Class See Also Send Feedback

The BaseExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetExportFontTable | Gets font table.
Public method | GetExportLayerTable | Gets the layer table.
Public method | GetExportLinetypeTable | Gets a copy of the line type table.
Public method | GetExportPatternTable | Gets a copy of the pattern table.
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of export options.
Public method | SetExportFontTable | Sets font table to option.
Public method | SetExportLayerTable | Sets layer table back to option
Public method | SetExportLinetypeTable | Sets the line type table to use during export.
Public method | SetExportPatternTable | Sets the pattern table to use during export.

See Also

BaseExportOptions Class

Dispose Method

[image]