Revit 2024 API
ExternalResourceReference Methods
ExternalResourceReference Class See Also Send Feedback

The ExternalResourceReference type exposes the following members.

Methods

 | Name | Description
 | CreateLocalResource | Creates an ExternalResourceReference representing a local file managed by Revit's built-in server.
Public method | Dispose |
Public method | GetReferenceInformation | Returns a copy of an object containing previously-stored reference or lookup information about the specific resource provided by the server.
Public method | GetResourceShortDisplayName | Gets the short display name of the external resource.
Public method | GetResourceVersionStatus | Checks whether this ExternalResourceReference corresponds to the current version of the resource.
Public method | HasValidDisplayPath | Checks whether this external Resource has a valid display path.
Public method | IsValidReference | Checks whether the reference is in a valid format.

See Also

ExternalResourceReference Class

CreateLocalResource Method

[image]