Revit 2024 API
FabricationAncillaryUsage Members
FabricationAncillaryUsage Class Methods Properties See Also Send Feedback

The FabricationAncillaryUsage type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationAncillaryUsage

Properties

 | Name | Description
Public property | AncillaryDepth | Depth of required ancillary if it isn't round.
Public property | AncillaryId | Fabrication ancillary database identifier.
Public property | AncillaryWidthOrDiameter | Width or diameter of required ancillary.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Length of required ancillaries.
Public property | ProductCode | A unique string code that idnenifies the ancillary in the fabriction database in order to purchase it.
Public property | Quantity | Quantity of required ancillaries.
Public property | Type | Fabrication ancillary type.
Public property | UsageType | Fabrication ancillary usage type.

See Also

FabricationAncillaryUsage Class

FabricationAncillaryUsage Methods

[image] [image]