Revit 2024 API
ElementType Members
ElementType Class Methods Properties See Also Send Feedback

The ElementType type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate | Duplicates an existing element type and assigns it a new name.
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type.
Public method | IsSimilarType | Checks if given type is similar to this type.
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id.

Properties

 | Name | Description
Public property | CanBeCopied | Determine if this ElementType can create a copy
Public property | CanBeDeleted | Determine if this ElementType can be deleted
Public property | CanBeRenamed | Determine if this ElementType can be renamed
Public property | FamilyName | Gets the family name of this element type.
Public property | Name | Set the name for the ElementType. (Overrides Element..::..Name.)

See Also

ElementType Class

ElementType Methods

[image] [image]