Revit 2024 API
ExternalResourceBrowserData Members
ExternalResourceBrowserData Class Constructors Methods Properties See Also Send Feedback

The ExternalResourceBrowserData type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalResourceBrowserData | Constructs a new ExternalResourceBrowserData using the given document(optional), server id, folder path and match options.

Methods

 | Name | Description
Public method | AddResource(String) | Adds an external resource to the folder path by supplying the resource name.
Public method | AddResource(String, IDictionary<(Of <<'(String, String>)>>)) | Adds an external resource to the folder path by supplying the resource name and reference information.
Public method | AddResource(String, String) | Adds an external resource to the folder path by supplying the resource name and version.
Public method | AddResource(String, String, IDictionary<(Of <<'(String, String>)>>)) | Adds an external resource to the folder path by supplying the resource name, version and reference information.
Public method | AddSubFolder(String) | Adds a subfolder to the folder path with the given name.
Public method | AddSubFolder(String, String) | Adds a subfolder to the folder path with the given name and icon type.
Public method | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource browser data has a defined ModelPath.
Public method | Dispose | Releases all resources used by the ExternalResourceBrowserData
Public method | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource browser data.
Public method | GetMatchOptions | Gets the match options used to filter external resources.
Public method | GetResources | Gets the external resources under the folder path of the browser data.
Public method | GetSubFoldersData | Gets the subfolders data under the folder path of the browser data.
Public method | IsValidFolderName | Checks whether the folder name is valid.
Public method | IsValidResourceName | Checks whether the resource name is valid.

Properties

 | Name | Description
Public property | FolderPath | The current folder path to which the new resources and subfolder belong.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ServerId | The Id of IExternalResourceServer which handles the external resource load.

See Also

ExternalResourceBrowserData Class

ExternalResourceBrowserData Methods

[image] [image]