Revit 2024 API
ReferenceIntersector Methods
ReferenceIntersector Class See Also Send Feedback

The ReferenceIntersector type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Find | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector's criteria.
Public method | FindNearest | Projects a ray from the origin along the given direction, and returns the nearest reference from intersected elements which match the ReferenceIntersector's criteria.
Public method | GetFilter | Gets the ElementFilter used in intersection testing.
Public method | GetTargetElementIds | Gets the set of ElementIds to test from in intersection testing.
Public method | SetFilter | Sets the ElementFilter used in intersection testing.
Public method | SetTargetElementIds | Sets the set of ElementIds to test from in intersection testing.

See Also

ReferenceIntersector Class

Dispose Method

[image]