Revit 2024 API
FabricationRodInfo Methods
FabricationRodInfo Class See Also Send Feedback

The FabricationRodInfo type exposes the following members.

Methods

 | Name | Description
Public method | AttachToHanger | Attaches the hanger rod to another bearer hanger.
Public method | AttachToStructure | Attaches to the nearest structural element.
Public method | Dispose |
Public method | GetBearerExtension | Gets the bearer extension. The method is applicable only for bearer hanger.
Public method | GetRodAttachedElementId | Gets the identifier of the attached component for the specified rod.
Public method | GetRodEndPosition | Gets the position of the rod end.
Public method | GetRodLength | Get the current rod length. If the rod is the length will include structural extension.
Public method | GetRodStructureExtension | Gets the length of the rod's top extension into structure.
Public method | IsRodLockedWithHost | Checks if the rod is locked with the host. The method is applicable only for bearer hanger.
Public method | SetBearerExtension | Sets the bearer extension. The method is applicable only for bearer hanger.
Public method | SetRodEndPosition | Sets the position of the rod end. The method is applicable only for bearer hanger.
Public method | SetRodLength | Set the rod length of the hanger for the specified rod index, excluding top extension. The hanger must not be set to be auto-hosted.
Public method | SetRodLockedWithHost | Locks the rod with the host. The method is applicable only for bearer hanger.
Public method | SetRodStructureExtension | Set the length of the rod's top extension into structure. The rod must be attached to structure.

See Also

FabricationRodInfo Class

AttachToHanger Method

[image]