Revit 2024 API
TessellatedShapeBuilderResult Members
TessellatedShapeBuilderResult Class Methods Properties See Also Send Feedback

The TessellatedShapeBuilderResult type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TessellatedShapeBuilderResult
Public method | GetGeometricalObjects | When called the first time, returns geometrical objects which were built. Later calls will throw exceptions.
Public method | GetIssuesForFaceSet | Returns the array of issues encountered while processing a face set with index 'setIndex'.
Public method | GetNumberOfFaceSets | Gets number of face sets for which 'this' result was obtained.

Properties

 | Name | Description
Public property | AreObjectsAvailable | Shows whether 'issues' still contains the original data or whether these data have already been relinquished by 'getGeometricalObjects'. The former is true, the later is false.
Public property | HasInvalidData | Whether there were any inconsistencies in the face sets, stored in the tessellated shape builder while building geometrical objects.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Outcome | What kinds of geometrical objects were built.

See Also

TessellatedShapeBuilderResult Class

TessellatedShapeBuilderResult Methods

[image] [image]