Revit 2024 API
Outline Members
Outline Class Constructors Methods Properties See Also Send Feedback

The Outline type exposes the following members.

Constructors

 | Name | Description
Public method | Outline(Outline) | Constructs a new copy of the input Outline object.
Public method | Outline(XYZ, XYZ) | Constructor that uses a minimum and maximum XYZ point to initialize the outline.

Methods

 | Name | Description
Public method | AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Public method | Contains | Determine if this Outline contains the specified point to within a tolerance.
Public method | ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Public method | Dispose | Releases all resources used by the Outline
Public method | GetDiagonalLength | Get the length of outline's diagonal. If called on empty outline, 0. is returned
Public method | Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
Public method | IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Public method | Scale | Scales the bounding box by given scale.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the outline represents an empty outline.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumPoint | The maximum point of the bounding box.
Public property | MinimumPoint | The minimum point of the bounding box.

See Also

Outline Class

Outline Constructor

[image] [image]