Revit 2024 API
DividedPath Properties
DividedPath Class See Also Send Feedback

The DividedPath type exposes the following members.

Properties

 | Name | Description
Public property | BeginningIndent | The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | DisplayNodeNumbers | Controls whether the node numbers are shown when the divided path is selected
Public property | DisplayNodes | Controls whether the points of the divided path are visible
Public property | DisplayReferenceCurves | Controls whether the curves in the path are visible
Public property | Distance | The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public property | EndIndent | The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | FixedNumberOfPoints | The number of points used when the layout is set to 'FixedNumber'.
Public property | Flipped | If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
Public property | IsClosedLoop | Whether or not the path forms a closed loop.
Public property | IsCyclical | True if the first and last point coincide False otherwise.
Public property | MaximumDistance | The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public property | MeasurementType | The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public property | MinimumDistance | The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public property | NumberOfPoints | The total number of points of the divided surface. This combines the layout points and the intersection points.
Public property | SpacingRuleJustification | When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public property | SpacingRuleLayout | The layout determines how points are distributed along the path.
Public property | TotalPathLength | The sum of the curve lengths.

See Also

DividedPath Class

BeginningIndent Property

[image]