Revit 2024 API
CitySet Members
CitySet Class Constructors Methods Properties See Also Send Feedback

The CitySet type exposes the following members.

Constructors

 | Name | Description
Public method | CitySet | Initializes a new instance of the CitySet class

Methods

 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of cities that are in the set.

See Also

CitySet Class

CitySet Constructor

[image]