Revit 2024 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Retrieve the id of the element that produces this boundary segment. If the segment is created from an element in a link, this is the id of the RevitLinkInstance.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkElementId | Retrieve the element id of the element in a link instance that forms this boundary.

See Also

BoundarySegment Class

IsValidObject Property

[image]