Revit 2024 API
ExportDWGSettings Members
ExportDWGSettings Class Methods Properties See Also Send Feedback

The ExportDWGSettings type exposes the following members.

Methods

 | Name | Description
 | Create(Document, String) | Create a DWG export settings with default values.
 | Create(Document, String, DWGExportOptions) | Create a DWG export settings with default values.
 | Create(Document, String, DXFExportOptions) | Create a DWG export settings with default values.
 | FindByName | Returns the pre-defined non-in-session exporting settings for DWG in the given document with the specified name.
 | GetActivePredefinedSettings | Returns the active pre-defined non-in-session exporting settings for DWG in the given document.
Public method | GetDWGExportOptions | Gets the options stored in the these settings.
Public method | GetDXFExportOptions | Gets the options stored in the these settings.
 | ListNames | Returns a list of names of dwg/dxf export settings.
Public method | SetDWGExportOptions | Sets the options stored in these settings.
Public method | SetDXFExportOptions | Sets the options stored in these settings.

Properties

 | Name | Description

See Also

ExportDWGSettings Class

Create Method

[image] [image]