Revit 2024 API
GeometryElement Members
GeometryElement Class Methods Properties See Also Send Feedback

The GeometryElement type exposes the following members.

Methods

 | Name | Description
Public method | GetBoundingBox | Retrieves a box that encloses the geometry element.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Protected method | GetEnumeratorNG | Returns an enumerator that iterates through the collection.
Public method | GetTransformed | Returns a transformed copy of the geometry in this element.

Properties

 | Name | Description
Public property | MaterialElement | Element describing the material from which this element is composed.

See Also

GeometryElement Class

GetBoundingBox Method

[image]