Revit 2024 API
ElementMulticlassFilter Constructor (IList<(Of <(<'Type>)>)>, Boolean)
ElementMulticlassFilter Class See Also Send Feedback
Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes, with an option to instead match elements whose Element subclass does not match the list of input classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementMulticlassFilter(
    IList<Type> typeList,
    bool inverted
)
Visual Basic
Public Sub New ( _
    typeList As IList(Of Type), _
    inverted As Boolean _
)
Visual C++
public:
ElementMulticlassFilter(
    IList<Type^>^ typeList,
    bool inverted
)

Parameters

typeList
Type: System.Collections.Generic..::..IList<(Of <(<'Type>)>)>
The list of Element subclass types to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given Element subclass.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more input types are not valid subclasses of Element for this filter. -or- One or more of the types do not exist in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementMulticlassFilter Class
ElementMulticlassFilter Overload

PassesFilter Method

[image] [image]