Revit 2024 API
ElementParameterFilter Constructor (IList<(Of <(<'FilterRule>)>)>, Boolean)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementParameterFilter(
    IList<FilterRule> filterRules,
    bool inverted
)
Visual Basic
Public Sub New ( _
    filterRules As IList(Of FilterRule), _
    inverted As Boolean _
)
Visual C++
public:
ElementParameterFilter(
    IList<FilterRule^>^ filterRules,
    bool inverted
)

Parameters

filterRules
Type: System.Collections.Generic..::..IList<(Of <(<' FilterRule >)>)>
The rules applied to test if the element passes this filter.
inverted
Type: System..::..Boolean
True if the filter should match all elements which do not pass the filter rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filterRules array is empty or invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementParameterFilter Class
ElementParameterFilter Overload

GetRules Method

[image]