Revit 2024 API
FilterRule Members
FilterRule Class Methods Properties See Also Send Feedback

The FilterRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilterRule
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilterRule Class

Dispose Method

[image]