Revit 2024 API
DWFExportOptions Members
DWFExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWFExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DWFExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | CropBoxVisible | Whether to export crop box.
Public property | ExportingAreas | Whether to also export areas and rooms' geometry.
Public property | ExportObjectData | Whether to include properties associated with elements.
Public property | ExportOnlyViewId | Only export the specified view.
Public property | ExportTexture | Whether to export texture.
Public property | ImageFormat | Controls the compression level of images embedded.
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used.
Public property | MergedViews | Whether to merge all views in one file.
Public property | PaperFormat | Standard paper format.
Public property | PortraitLayout | Paper orientation - Portrait/Landscape.
Public property | StopOnError | Whether export process should stop when a view fails to export.

See Also

DWFExportOptions Class

DWFExportOptions Constructor

[image]