Revit 2024 API
ClassificationEntry Members
ClassificationEntry Class Constructors Methods Properties See Also Send Feedback

The ClassificationEntry type exposes the following members.

Constructors

 | Name | Description
Public method | ClassificationEntry | Constructs a ClassificationEntry object

Methods

 | Name | Description
Public method | HasBadCategoryId | Checks if the category id is Revit BuiltInCategory id.
Public method | HasBadLevel | Checks if the level is an integer in range between 1 and 5 inclusive.
Public method | HasInvalidKey | Checks if the key matches the level and parent key.

Properties

 | Name | Description
Public property | CategoryId | The id of the category associated with this entry.
Public property | Description | The description associated with this entry.
Public property | Level | The entry level in the classification table. The expected range is between 1 and 5 inclusive.

See Also

ClassificationEntry Class

ClassificationEntry Constructor

[image]