Revit 2024 API
CADLinkType Methods
CADLinkType Class See Also Send Feedback

The CADLinkType type exposes the following members.

Methods

 | Name | Description
Public method | LoadFrom(String) | Loads or reloads the DWG link from the given file path.
Public method | LoadFrom(ExternalResourceReference) | Loads or reloads the DWG link from the given external resource reference.
Public method | Reload()()()() | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | Reload(CADLinkOptions) | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.

See Also

CADLinkType Class

LoadFrom Method

[image] [image]