Revit 2024 API
TessellatedFace Members
TessellatedFace Class Constructors Methods Properties See Also Send Feedback

The TessellatedFace type exposes the following members.

Constructors

 | Name | Description
Public method | TessellatedFace(IList<(Of <<'(XYZ>)>>), ElementId) | Constructs a tessellated face without holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.
Public method | TessellatedFace(IList<(Of <<'(IList<(Of <<'(XYZ>)>>)>)>>), ElementId) | Constructs a tessellated face, which, may be, have holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TessellatedFace
Public method | GetBoundaryLoops | Get loops bounding the face.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Material of the face.

See Also

TessellatedFace Class

TessellatedFace Constructor

[image] [image]