Revit 2024 API
OffsetSurface Methods
OffsetSurface Class See Also Send Feedback

The OffsetSurface type exposes the following members.

Methods

 | Name | Description
Public method | GetBasisSurface | Returns a copy of basis surface of this OffsetSurface.
Public method | GetOffsetDistance | Returns offset distance of this OffsetSurface.
Public method | IsOrientationSameAsBasisSurface | Indicates whether the orientation of the OffsetSurface is same as that of its basis surface, in the sense that their oriented normals at any (u, v) have the same direction.

See Also

OffsetSurface Class

GetBasisSurface Method

[image]