Revit 2024 API
NurbSpline..::..CreateCurve Method
NurbSpline Class See Also Send Feedback

Overload List

Name | Description
CreateCurve(HermiteSpline) | Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
CreateCurve(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
CreateCurve(Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>)) | Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
CreateCurve(Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.

See Also

NurbSpline Class
NurbSpline Members

CreateCurve Method (HermiteSpline)

[image]