Revit 2024 API
SiteLocation Members
SiteLocation Class Methods Properties See Also Send Feedback

The SiteLocation type exposes the following members.

Methods

 | Name | Description
Public method | ConvertFromProjectTime | Converts project time to UTC time.
Public method | ConvertToProjectTime | Converts local time or UTC time to project time.
Public method | IsCompatibleWith | Checks whether the geographic coordinate system of this site is compatible with the given site . True if he geographic coordinate system of this site is compatible with the given site, false otherwise.
Public method | SetGeoCoordinateSystem | Set the geographic coordinate system for this site. Similar to acquire coordinate system from a link in the UI.

Properties

 | Name | Description
Public property | Elevation | The elevation of the site location.
Public property | GeoCoordinateSystemDefinition | The XML string which describes the geographic coordinate system.
Public property | GeoCoordinateSystemId | The geographic coordinate system ID, such as "AMG-50" and "Beijing1954/a.GK3d-40".
Public property | Latitude | The latitude of the site location.
Public property | Longitude | The longitude of the site location.
Public property | PlaceName | The place name of the site.
Public property | TimeZone | The time-zone for the site.
Public property | WeatherStationName | The name of the weather station at the site location.

See Also

SiteLocation Class

SiteLocation Methods

[image] [image]