Revit 2024 API
Transaction Members
Transaction Class Constructors Methods Properties See Also Send Feedback

The Transaction type exposes the following members.

Constructors

 | Name | Description
Public method | Transaction(Document) | Instantiates a transaction object.
Public method | Transaction(Document, String) | Instantiates a transaction object

Methods

 | Name | Description
Public method | Commit()()()() | Commits all changes made to the model during the transaction.
Public method | Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.
Public method | Dispose | Releases all resources used by the Transaction
Public method | GetFailureHandlingOptions | Returns the current failure handling options.
Public method | GetName | Returns the transaction's name.
Public method | GetStatus | Returns the current status of the transaction.
Public method | HasEnded | Determines whether the transaction has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack()()()() | Rolls back all changes made to the model during the transaction.
Public method | RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.
Public method | SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back.
Public method | SetName | Sets the transaction's name.
Public method | Start()()()() | Starts the transaction.
Public method | Start(String) | Starts the transaction with an assigned name.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

Transaction Class

Transaction Constructor

[image] [image]