Revit 2024 API
OrdinateDimensionSetting Properties
OrdinateDimensionSetting Class See Also Send Feedback

The OrdinateDimensionSetting type exposes the following members.

Properties

 | Name | Description
Public property | DimensionLineLength | Specifies the dimension line segment length. This setting is enabled when Dimension Line Style is Segmented.
Public property | DimensionLineStyle | Specifies the dimension line style.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginTickMarkId | Specifies the id of the tick mark element to use for the dimension origin.
Public property | OriginVisibility | Specifies thevisibility of the origin witness line for the ordinate dimension (this is the first witness line in the string).
Public property | TextOrientation | Specifies where to align the dimension text.
Public property | TextPosition | Specifies the dimension text position.

See Also

OrdinateDimensionSetting Class

DimensionLineLength Property

[image]