Revit 2024 API
UV Members
UV Class Constructors Methods Operators Properties See Also Send Feedback

The UV type exposes the following members.

Constructors

 | Name | Description
Public method | UV()()()() | Creates a default UV with the values (0, 0).
Public method | UV(Double, Double) | Creates a UV with the supplied coordinates.

Methods

 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
Public method | DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
Public method | GetLength | The length of this 2-D vector.
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Public method | IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
Public method | IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Public method | Negate | Negates this 2-D vector.
Public method | Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
Public method | ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

Properties

 | Name | Description
 | BasisU | The basis of the U axis.
 | BasisV | The basis of the V axis.
Public property | Item |
Public property | U | Gets the first coordinate.
Public property | V | Gets the second coordinate.
 | Zero | The coordinate origin or zero 2-D vector.

See Also

UV Class

UV Constructor

[image] [image]