Revit 2024 API
PropertySetElement Methods
PropertySetElement Class See Also Send Feedback

The PropertySetElement type exposes the following members.

Methods

 | Name | Description
 | Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
 | Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.
Public method | Duplicate | Creates a duplicate of this PropertySetElement.
Public method | GetStructuralAsset | Gets a copy of the StructuralAsset.
Public method | GetThermalAsset | Gets a copy of the ThermalAsset.
Public method | SetStructuralAsset | Sets a copy of the given StucturalAsset to be used in the PropertySetElement.
Public method | SetThermalAsset | Sets a copy of the given ThermalAsset to be used in the PropertySetElement.

See Also

PropertySetElement Class

Create Method

[image] [image]