Revit 2024 API
KeyBasedTreeEntries..::..GetBasicIEnumerator Method
KeyBasedTreeEntries Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

KeyBasedTreeEntries Class

GetKeyBasedTreeEntriesIterator Method

[image]