Revit 2024 API
ScheduleFieldId Members
ScheduleFieldId Class Constructors Methods Operators Properties See Also Send Feedback

The ScheduleFieldId type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleFieldId | Initializes a new instance of the ScheduleFieldId class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two ScheduleFieldIds are the same.
Inequality | Determines whether two ScheduleFieldId are different.

Properties

 | Name | Description
Public property | IntegerValue | Provides the value of the ScheduleFieldId as an integer.
 | InvalidScheduleFieldId | Get the invalid ScheduleFieldId whose IntegerValue is -1.

See Also

ScheduleFieldId Class

ScheduleFieldId Constructor

[image]