Revit 2024 API
DisplacementPath Members
DisplacementPath Class Methods Properties See Also Send Feedback

The DisplacementPath type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.
 | IsValidParam | Is the specified value a valid edge or curve parameter.
 | IsValidReference | Does the specified pick represent an edge or a curve belonging to one of the displaced elements.
Public method | SetAnchorPoint | Sets the reference that determines the origin of this DisplacementPath.

Properties

 | Name | Description
Public property | AncestorIdx | Specifies the end point of the path.
Public property | PathStyle | Specifies the style of the path.

See Also

DisplacementPath Class

DisplacementPath Methods

[image] [image]