Revit 2024 API
SchedulableField Members
SchedulableField Class Constructors Methods Operators Properties See Also Send Feedback

The SchedulableField type exposes the following members.

Constructors

 | Name | Description
Public method | SchedulableField()()()() | Creates a new SchedulableField.
Public method | SchedulableField(Guid) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType, ElementId) | Creates a new SchedulableField.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SchedulableField
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return nullNothingnullptra null reference (Nothing in Visual Basic).
Public method | GetHashCode | Gets the integer value of the SchedulableField as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetName | Gets the name of the field.

Operators

Name | Description
Equality | Determines whether two SchedulableField are the same.
Inequality | Determines whether two SchedulableField are different.

Properties

 | Name | Description
Public property | FieldType | The type of data displayed by the field.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParameterId | The ID of the parameter displayed by the field.

See Also

SchedulableField Class

SchedulableField Constructor

[image] [image]