Revit 2024 API
IPerformanceAdviserRule Members
IPerformanceAdviserRule Interface Methods See Also Send Feedback

The IPerformanceAdviserRule type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteElementCheck | Invoked by performance advisor for each element to be checked.
Public method | FinalizeCheck | Invoked by performance advisor once in the end of the check.
Public method | GetDescription | Retrieves the description of the rule.
Public method | GetElementFilter | Retrieves a filter to restrict elements to be checked.
Public method | GetName | Retrieves the name of the rule.
Public method | InitCheck | Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.
Public method | WillCheckElements | Reports if rule needs to be executed on individual elements.

See Also

IPerformanceAdviserRule Interface

IPerformanceAdviserRule Methods

[image] [image]