Revit 2024 API
ExternalFileReference Methods
ExternalFileReference Class See Also Send Feedback

The ExternalFileReference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetAbsolutePath | Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.
Public method | GetLinkedFileStatus | Returns a LinkedFileStatus.Enum corresponding to the load status of the referenced file.
Public method | GetPath | Gets the path of the link, relative or absolute according to the link's settings
Public method | GetReferencingId | Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.
 | IsValidExternalFileReference | Checks an ExternalFileReference to see if it is properly created.
Public method | IsValidPathTypeForExternalFileReference | Checks whether a PathType enum value will be valid to use with this ExternalFileReference.

See Also

ExternalFileReference Class

Dispose Method

[image]