Revit 2024 API
LinkLoadResult Members
LinkLoadResult Class Constructors Methods Properties See Also Send Feedback

The LinkLoadResult type exposes the following members.

Constructors

 | Name | Description
Public method | LinkLoadResult()()()() | Constructs a new uninitialized LinkLoadResult object.
Public method | LinkLoadResult(LinkLoadResult) | Constructs a new copy of the input LinkLoadResult object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinkLoadResult
Public method | GetCentralModelName | Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.
Public method | GetExternalResourceReference | Gets a copy of the ExternalResourceReference corresponding to the link.
Public method | GetExternalResourceReferencesFromFailedLoads | Searches this and all nested LinkLoadResults, and returns a list of ExternalResourceReferences for the links that failed to load.
Public method | GetLinkLoadResult | Searches this LinkLoadResult and all nested LinkLoadResults for the load operation results of a specified ExternalResourceReference.
Public method | GetModelName | Gets the name of the model.
Public method | GetNestedLinkLoadResults | Gets the results for this link's nested links.
Public method | GetParentModelName | Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.
 | IsCodeSuccess | Check if load result code signifies success.

Properties

 | Name | Description
Public property | ElementId | The id of the created or loaded linked model.
Public property | IsCircularLink | True if these results are part of a link cycle.
Public property | IsNested | True if these results represent a nested link; false otherwise.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadResult | Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.

See Also

LinkLoadResult Class

LinkLoadResult Constructor

[image] [image]