Revit 2024 API
NumberSystem Members
NumberSystem Class Methods Properties See Also Send Feedback

The NumberSystem type exposes the following members.

Methods

 | Name | Description
 | Create(Document, ElementId, LinkElementId, Reference) | Creates a new instance of a NumberSystem associated to a host element and a view.
 | Create(Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId) | Creates a new instance of a NumberSystem associated to a host element, a view, and a reference level of stairs if in a multistory stairs.
Public method | GetReferencePick | Gets the reference curve.
Public method | SetReferencePick | Sets the reference pick.

Properties

 | Name | Description
Public property | JustifyOffset | The offset to the justification curve.
Public property | JustifyOption | The number justify option of number system.
Public property | NumberDisplayRule | The display rule of the number system.
Public property | NumberedElementId | The LinkElementId of the numbered host element.
Public property | NumberOrientation | The number orientation of number system.
Public property | PlacementLevelId | The id of the base level of stairs on which the NumberSystem is placed.
Public property | ReferenceOffset | The offset to the reference curve.

See Also

NumberSystem Class

NumberSystem Methods

[image] [image]