Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..OnlyMonolithicStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Tread thickness can't be zero for non-monolithic stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OnlyMonolithicStairs { get; }
Visual Basic
Public Shared ReadOnly Property OnlyMonolithicStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OnlyMonolithicStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class

PartOfRiserLiesOnBoundaryFailure Property

[image]