Revit 2024 API
Floor..::..Create Method (Document, IList<(Of <(<'CurveLoop>)>)>, ElementId, ElementId, Boolean, Line, Double)
Floor Class Example See Also Send Feedback
Creates a new instance of floor within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static Floor Create(
    Document document,
    IList<CurveLoop> profile,
    ElementId floorTypeId,
    ElementId levelId,
    bool isStructural,
    Line slopeArrow,
    double slope
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of CurveLoop), _
    floorTypeId As ElementId, _
    levelId As ElementId, _
    isStructural As Boolean, _
    slopeArrow As Line, _
    slope As Double _
) As Floor
Visual C++
public:
static Floor^ Create(
    Document^ document,
    IList<CurveLoop^>^ profile,
    ElementId^ floorTypeId,
    ElementId^ levelId,
    bool isStructural,
    Line^ slopeArrow,
    double slope
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new floor is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
An array of planar curve loops that represent the profile of the floor.
floorTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the floor type to be used by the new Floor.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the floor is to be placed.
isStructural
Type: System..::..Boolean
True if new floor should be structural, false if architectural.
slopeArrow
Type: Autodesk.Revit.DB..::..Line
A line used to control the slope angle of the Floor. It must be horizontal. If slopeArrow is nullNothingnullptra null reference (Nothing in Visual Basic), the horizontal floor will be created.
slope
Type: System..::..Double
The slope angle. If slopeArrow is nullNothingnullptra null reference (Nothing in Visual Basic), this parameter will be ignored.

Return Value

If successful a new floor object within the project.

Remarks

To validate curve loop profile use BoundaryValidation. To get default floor type use GetDefaultFloorType(Document, Boolean).

Examples

CopyC#
/// The example below shows how to use Floor.Create method to create a new slopped floor on one level
/// using a geometry profile and a floor type.
/// In this sample, the geometry profile is a CurveLoop of lines, you can also use arcs, ellipses and splines.
Floor CreateSlopedFloor(Document document, Level level)
{
   // Get a floor type for floor creation
   ElementId floorTypeId = Floor.GetDefaultFloorType(document, false);

   // Build a floor profile for the floor creation
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 20, 0);
   XYZ fourth = new XYZ(0, 20, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   Line slopeArrow = Line.CreateBound(new XYZ(10, 10, 0), new XYZ(11, 10, 0));
   return Floor.Create(document, new List<CurveLoop> { profile }, floorTypeId, level.Id, true, slopeArrow, Math.PI / 2);
}
CopyVB.NET
Private Function CreateSlopedFloor(ByVal document As Document, ByVal level As Level) As Floor
   Dim floorTypeId As ElementId = Floor.GetDefaultFloorType(document, False)
   Dim first As XYZ = New XYZ(0, 0, 0)
   Dim second As XYZ = New XYZ(20, 0, 0)
   Dim third As XYZ = New XYZ(20, 20, 0)
   Dim fourth As XYZ = New XYZ(0, 20, 0)
   Dim profile As CurveLoop = New CurveLoop()
   profile.Append(Line.CreateBound(first, second))
   profile.Append(Line.CreateBound(second, third))
   profile.Append(Line.CreateBound(third, fourth))
   profile.Append(Line.CreateBound(fourth, first))
   Dim slopeArrow As Line = Line.CreateBound(New XYZ(10, 10, 0), New XYZ(11, 10, 0))
   Return Floor.Create(document, New List(Of CurveLoop) From {
          profile
      }, floorTypeId, level.Id, True, slopeArrow, Math.PI / 2)
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId levelId is not a Level. -or- The floorTypeId does not correspond to a FloorType. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- The slopeArrow must be a horizontal line. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Floor Class
Create Overload

GetDefaultFloorType Method

[image]