Revit 2024 API
ViewSheetSetting Members
ViewSheetSetting Class Methods Properties See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Public method | Rename | Rename the current view sheet set.
Public method | Revert | Revert the current view sheet set.
Public method | Save | Save the changes for the current view sheet set.
Public method | SaveAs | Save the current view sheet set to another view sheet set with the specified name.

Properties

 | Name | Description
Public property | AvailableViews | All views that can be printed.
Public property | CurrentViewSheetSet | The current view sheet set of PrintSetup.
Public property | InSession | The in-session view sheet set of Print Setup.

See Also

ViewSheetSetting Class

ViewSheetSetting Methods

[image] [image]