Revit 2024 API
ExternalResourceSubFolder Members
ExternalResourceSubFolder Class Constructors Methods Properties See Also Send Feedback

The ExternalResourceSubFolder type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalResourceSubFolder()()()() | Constructs a new ExternalResourceSubFolder with default values for folder name and icon path.
Public method | ExternalResourceSubFolder(String, String) | Constructs a new ExternalResourceSubFolder with custom values for folder name and icon path.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceSubFolder

Properties

 | Name | Description
Public property | FolderName | Folder displayed name.
Public property | IconPath | The path of the resource icon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExternalResourceSubFolder Class

ExternalResourceSubFolder Constructor

[image]