Revit 2024 API
HomeCamera Properties
HomeCamera Class See Also Send Feedback

The HomeCamera type exposes the following members.

Properties

 | Name | Description
Public property | BottomAngleOfFieldOfView | The bottom angle of the field of view.
Public property | Center | The zoom or orbit center.
Public property | EyePosition | The eye position point.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeftAngleOfFieldOfView | The left angle of the field of view.
Public property | OrthogonalProjectionHeight | The height of orthogonal projection view volume.
Public property | OrthogonalProjectionWidth | The width of orthogonal projection view volume.
Public property | Pivot | The pivot point.
Public property | RightAngleOfFieldOfView | The right angle of the field of view.
Public property | TopAngleOfFieldOfView | The top angle of the field of view.
Public property | UpDirection | The up direction vector.
Public property | ViewId | The id of the view which is associated to this document's Home view orientation.

See Also

HomeCamera Class

Center Property

[image]