Revit 2024 API
ThermalProperties Members
ThermalProperties Class Methods Properties See Also Send Feedback

The ThermalProperties type exposes the following members.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | Absorptance | Value of absorptance.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Roughness | Value of roughness.
Public property | ThermalMass | The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).

See Also

ThermalProperties Class

ThermalProperties Methods

[image] [image]