Revit 2024 API
Mesh Members
Mesh Class Methods Properties See Also Send Feedback

The Mesh type exposes the following members.

Methods

 | Name | Description
Public method | ComputeSurfaceArea | Computes and returns the surface area of the mesh. The surface area is the sum of the areas of the constituent facets of the mesh.
Public method | GetNormal | Returns a normal unit vector at the given index.
Public method | GetNormals | Returns all normals assigned to the mesh.

Properties

 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated mesh surface.
Public property | IsClosed | Indicates whether the mesh is closed.
Public property | MaterialElementId | Element ID of the material from which this mesh is composed.
Public property | NumberOfNormals | The number of normals associated with the mesh.
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.

See Also

Mesh Class

Mesh Methods

[image] [image]