Revit 2024 API
PolymeshTopology Members
PolymeshTopology Class Methods Properties See Also Send Feedback

The PolymeshTopology type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PolymeshTopology
Public method | GetFacet | Returns a definition of one facet
Public method | GetFacets | Returns a definitions of all facets of the polymesh
Public method | GetNormal | Returns a normal vector at the given index
Public method | GetNormals | Returns all normals assigned to the polymesh
Public method | GetPoint | Returns one point at the given index.
Public method | GetPoints | Returns all points of the polymesh.
Public method | GetUV | Returns one UV coordinate at the given index.
Public method | GetUVs | Returns all UV coordinates assigned to the polymesh

Properties

 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated polymesh surface.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfFacets | The number of facet in the polymesh.
Public property | NumberOfNormals | The number of normals associated with the polymesh
Public property | NumberOfPoints | The number of points in the polymesh
Public property | NumberOfUVs | The number of UV coordinates available for the polymesh.

See Also

PolymeshTopology Class

PolymeshTopology Methods

[image] [image]