Revit 2024 API
Document..::..NewFlexDuct Method (Connector, IList<(Of <(<'XYZ>)>)>, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using a connector, point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector,
    IList<XYZ> points,
    FlexDuctType ductType
)
Visual Basic
Public Function NewFlexDuct ( _
    connector As Connector, _
    points As IList(Of XYZ), _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector,
    IList<XYZ^>^ points,
    FlexDuctType^ ductType
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The connector to be connected to the duct, including the end points.
points
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The point array indicating the path of the flexible duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector's direction matches the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector or points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the flexible duct type does not exist in the given document.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace

NewFlexPipe Method (IList(XYZ), FlexPipeType)

[image]