Revit 2024 API
ExportLayerInfo Properties
ExportLayerInfo Class See Also Send Feedback

The ExportLayerInfo type exposes the following members.

Properties

 | Name | Description
Public property | CategoryType | The category type which this layer belongs to.
Public property | ColorName | The color name stored in value. For IFC export, the naming is to match the "colornumber" setting -- really, this stores a string that generates the colorNumber (for formats that don't use the color but need a second entry.)
Public property | ColorNumber | The color number stored in value.
Public property | CutColorNumber | The cut color number stored in value.
Public property | CutLayerName | The cut layer name stored in value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerName | The layer name stored in value.

See Also

ExportLayerInfo Class

ColorName Property

[image]