Revit 2024 API
Profile..::..Curves Property
Profile Class See Also Send Feedback
Retrieve the curves that make up the boundary of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArray Curves { get; }
Visual Basic
Public ReadOnly Property Curves As CurveArray
    Get
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

See Also

Profile Class

Filled Property

[image]