Revit 2024 API
KeyBasedTreeEntries Members
KeyBasedTreeEntries Class Methods Properties See Also Send Feedback

The KeyBasedTreeEntries type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntries
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

KeyBasedTreeEntries Class

Dispose Method

[image]