Revit 2024 API
Viewport Methods
Viewport Class See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
 | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet.
 | Create | Creates a new Viewport at a given location on a sheet.
Public method | GetBoxCenter | Returns the center of the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetLabelOutline | Gets the outline viewport's label on the sheet.
Public method | GetProjectionToSheetTransform | Returns the transform from the view's projection space to the sheet space.
Public method | HasViewportTransforms | Indicates if the viewport has transforms.
Public method | IsViewIdValidForViewport | Verifies that the Viewport can change it's view id to the input %viewId%.
Public method | SetBoxCenter | Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point.

See Also

Viewport Class

CanAddViewToSheet Method

[image]