Revit 2024 API
BoundingBoxContainsPointFilter Constructor
BoundingBoxContainsPointFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BoundingBoxContainsPointFilter(XYZ) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.
Public method | BoundingBoxContainsPointFilter(XYZ, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria. This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Members

BoundingBoxContainsPointFilter Constructor (XYZ)

[image]