Revit 2024 API
Segment Members
Segment Class Methods Properties See Also Send Feedback

The Segment type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Adds a new MEPSize to the segment.
Public method | GetSizes | Gets the defined sizes of the segment.
Public method | RemoveSize | Remove the existing MEPSize with this nominal diameter from the segment.

Properties

 | Name | Description
Public property | Description | The description of the segment.
Public property | MaterialId | The ElementId of the MaterialElem.
Public property | Roughness | The roughness value for given material.
Public property | SizeCount | The number of size objects in the segment.

See Also

Segment Class

AddSize Method

[image]