Revit 2024 API
PartMakerMethodToDivideVolumes Properties
PartMakerMethodToDivideVolumes Class See Also Send Feedback

The PartMakerMethodToDivideVolumes type exposes the following members.

Properties

 | Name | Description
Public property | DivisionGap | The gap which is created between matching profiles of parts.
Public property | DivisionPatternMirror | Whether pattern defined by the division rule should be mirrored before application Mirroring is similar to changing indices of u-const gridlines.
Public property | DivisionRotationAngle | Angle by which both u- and v- gridlines of the division are rotated with respect to the natural u/v-const directions of the sketch plane.
Public property | DivisionRuleId | Id of the 'DivisionRule' which is used to augment the cutting sketch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProfileFlipAcross | True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileFlipAlong | True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileMatch | Determines how two profiles match.
Public property | ProfileOffset | The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.
Public property | ProfileType | The id of the profile family applied to boundaries between parts.
Public property | UConstDivisionIndent | Indentation for the application of division rule's pattern across u-const gridlines (i.e., similar to changing indices of u-const gridlines).
Public property | VConstDivisionIndent | Indentation for the application of division rule's pattern across v-const gridlines (i.e., similar to changing indices of v-const gridlines).

See Also

PartMakerMethodToDivideVolumes Class

DivisionGap Property

[image]