Revit 2024 API
ExportLinetypeTable Methods
ExportLinetypeTable Class See Also Send Feedback

The ExportLinetypeTable type exposes the following members.

Methods

 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line type table.
Public method | Clear | Removes all contents stored in Export line type table.
Public method | ContainsKey | Checks whether a pattern key exists in the table.
Public method | Dispose |
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLinetypeInfo | Gets a copy of the ExportLinetypeInfo corresponding to the given ExportLinetypeKey.
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLinetypeTableIterator | Returns a ExportLinetypeTableIterator that iterates through the collection.
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLinetypeKey.

See Also

ExportLinetypeTable Class

Add Method

[image]