Revit 2024 API
ViewDisplayBackground Members
ViewDisplayBackground Class Methods Properties See Also Send Feedback

The ViewDisplayBackground type exposes the following members.

Methods

 | Name | Description
 | CreateGradient | Creates an object that can be passed to View.SetBackground method to set the background of the Gradient type.
 | CreateImage | Creates an object that can be passed to View.SetBackground method to set the background of the Image type.
 | CreateSky | Creates an object that can be passed to View.SetBackground method to set the background of the SunAndClouds type.
Public method | Dispose | Releases all resources used by the ViewDisplayBackground

Properties

 | Name | Description
Public property | BackgroundColor | The color of the horizon when the type is 'Gradient'.
Public property | GroundColor | The color of the ground when the type is 'Gradient' or 'SunAndClouds'.
Public property | HorizontalImageOffset | The distance between the left viewport boundary and the left edge of the background image.
Public property | HorizontalImageScale | The horizontal scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.
Public property | ImageFlags | The image alignment indicators when the type is 'Image'.
Public property | ImagePath | The path to the image file when the type is 'Image'.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SkyColor | The color of the sky when the type is 'Gradient'.
Public property | Type | The type of the background.
Public property | VerticalImageOffset | The distance between the bottom viewport boundary and the bottom edge of the background image.
Public property | VerticalImageScale | The vertical scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.

See Also

ViewDisplayBackground Class

ViewDisplayBackground Methods

[image] [image]