Revit 2024 API
ExternalDefinitionCreationOptions Properties
ExternalDefinitionCreationOptions Class See Also Send Feedback

The ExternalDefinitionCreationOptions type exposes the following members.

Properties

 | Name | Description
Public property | Description | The description of the parameter definition to be created. The description will be used as tooltip in the Revit UI including in the properties palette. The default is an empty string.
Public property | GUID | The GUID to use for this parameter definition. If not explicitly set, a random GUID is used.
Public property | HideWhenNoValue | This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the parameter definition to be created.
Public property | UserModifiable | This property indicates whether this parameter can be modified by UI user or not.
Public property | Visible | True if the parameter is visible to the user, false if it is hidden and accessible only via the API. The default is true.

See Also

ExternalDefinitionCreationOptions Class

Description Property

[image]