Revit 2024 API
DefinitionGroups Members
DefinitionGroups Class Methods Properties See Also Send Feedback

The DefinitionGroups type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition group within the collection.
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Dispose | Releases all resources used by the DefinitionGroups
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definition groups collection is empty.
Public property | Item | Retrieve a definition group by name.
Public property | Size | The number of definition groups in the collection.

See Also

DefinitionGroups Class

DefinitionGroups Methods

[image] [image]