Revit 2024 API
Document..::..Import Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, AXMImportOptions, View) | Imports an AXM file into the document.
Public method | Import(String, ImportOptions3DM, View) | Imports a 3DM file into the document.
Public method | Import(String, OBJImportOptions, View) | Imports an OBJ file into the document.
Public method | Import(String, SATImportOptions, View) | Imports an SAT file into the document.
Public method | Import(String, SKPImportOptions, View) | Imports a SKP file into the document.
Public method | Import(String, STLImportOptions, View) | Imports an STL file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId%) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId%) | Imports a DWG or DXF file to the document.

See Also

Document Class
Document Members

Import Method (String, GBXMLImportOptions)

[image]