Revit 2024 API
Surface Methods
Surface Class See Also Send Feedback

The Surface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.

See Also

Surface Class

Dispose Method

[image]