Revit 2024 API
ImageInstance Members
ImageInstance Class Methods Properties See Also Send Feedback

The ImageInstance type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new ImageInstance element placed in a view.
Public method | GetLocation | Returns the location of one of the points of the ImageInstance
 | IsValidView | Check that the view is a valid view for ImageInstance elements
Public method | SetLocation | Moves the ImageInstance to the specified location

Properties

 | Name | Description
Public property | CanHaveSnaps | When true the ImageInstance has snaps that can be enabled with the EnableSnaps property
Public property | DrawLayer | The layer the ImageInstance will be drawn in.
Public property | EnableSnaps | When true the ImageInstance will have its snaps enabled, but only if CanHaveSnaps is true
Public property | Height | The height of the ImageInstance.
Public property | HeightScale | The factor applied to the ImageType to calculate the Height of the ImageInstance.
Public property | LockProportions | When true the proportion of Width to Height will be maintained
Public property | Width | The width of the ImageInstance.
Public property | WidthScale | The factor applied to the width of the ImageType to calculate the Width of the ImageInstance.

See Also

ImageInstance Class

ImageInstance Methods

[image] [image]