Revit 2024 API
FabricationItemFile Members
FabricationItemFile Class Methods Properties See Also Send Feedback

The FabricationItemFile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationItemFile
Public method | GetImage | Gets the image for the fabrication item file.
Public method | IsLoaded | Checks to see if the item file has been loaded into the configuration.
Public method | IsValid | Checks to see if the item file is valid.

Properties

 | Name | Description
Public property | Identifier | The string identifier for the item file. This string is unique and can be used to compare whether fabrication item files are the same file.
Public property | IsUsed | Checks to see if the item file is already in use in the project.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FabricationItemFile Class

FabricationItemFile Methods

[image] [image]