Revit 2024 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | Application | Returns the Application in which the Document resides.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CreationGUID | A unique identifier generated when the Document was first created.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
Public property | FamilyManager | The family manager object provides access to family types and parameters.
Public property | IsDetached | Identifies if a workshared document is detached. Also, see IsWorkshared
Public property | IsFamilyDocument | Identifies if the current document is a family document.
Public property | IsLinked | Identifies if a document is a linked RVT.
Public property | IsModelInCloud | Identifies if document is stored on Autodesk cloud services.
Public property | IsModifiable | Identifies if the document is modifiable.
Public property | IsModified | The state of changes made to the document.
Public property | IsReadOnly | Identifies if the document is read-only or can possibly be modified.
Public property | IsReadOnlyFile | Signals whether the document was opened from a read-only file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsWorkshared | Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document. Also, see IsDetached
Public property | MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | OwnerFamily | Get the Family of this Family Document.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | The fully qualified path of the document's disk file.
Public property | Phases | Retrieves all of the phases in the document.
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologies[([( Phase])]) | Gets the PlanTopologies of the current project in a given phase.
Public property | PlanTopology[([( Level])]) | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopology[([( Level, Phase])]) | Get the PlanTopology of a given level in a given phase.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | Title | The document's title.
Public property | TypeOfStorage | Get the storage type of the specified BuiltInParameter.
Public property | WorksharingCentralGUID | The central GUID of the server-based model.

See Also

Document Class

ActiveView Property

[image]