Revit 2024 API
MEPSystemType Properties
MEPSystemType Class See Also Send Feedback

The MEPSystemType type exposes the following members.

Properties

 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type
Public property | CalculationLevel | Identifies the calculation level for the system type.
Public property | FillColor | Indicates the color that should override the fill color for all components in the system.
Public property | FillPatternId | Indicates the fill pattern id that should override the fill pattern id for all components in the system.
Public property | FillVisible | Indicates the visibility of the fill pattern for all components in the system.
Public property | LineColor | Indicates the color that should override the line color for all components in the system.
Public property | LinePatternId | Indicates the line pattern id that should override the line pattern id for all components in the system.
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system.
Public property | MaterialId | Indicates the material id that should override the material for all components in the system.
Public property | SystemClassification | Identifies the classification for the system type

See Also

MEPSystemType Class

Abbreviation Property

[image]