Revit 2024 API
Grid Members
Grid Class Methods Properties See Also Send Feedback

The Grid type exposes the following members.

Methods

 | Name | Description
 | Create(Document, Arc) | Creates a new radial grid line.
 | Create(Document, Line) | Creates a new grid line.
Public method | GetExtents | Gets the extents of the grid in the model.
Public method | SetVerticalExtents | Adjusts the grid to extend through only the vertical range between bottom and top.

Properties

 | Name | Description
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
Public property | IsCurved | Identifies if the grid line is curved or straight.

See Also

Grid Class

Create Method

[image] [image]