Revit 2024 API
BoundingBoxContainsPointFilter Members
BoundingBoxContainsPointFilter Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxContainsPointFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxContainsPointFilter(XYZ) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.
Public method | BoundingBoxContainsPointFilter(XYZ, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria. This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | Point | The XYZ point to use when matching element bounding boxes.
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxContainsPointFilter Class

BoundingBoxContainsPointFilter Constructor

[image] [image]