Revit 2024 API
TableSectionData Methods
TableSectionData Class See Also Send Feedback

The TableSectionData type exposes the following members.

Methods

 | Name | Description
Public method | AllowOverrideCellStyle | Identifies if the style can be overridden in the given cell.
Public method | CanInsertColumn | Verifies if a new column can be inserted at the given index.
Public method | CanInsertRow | Verifies if a new row can be inserted at the given index.
Public method | CanRemoveColumn | Verifies that if the column at the given index can be removed.
Public method | CanRemoveRow | Verifies that if the row at the given index can be removed..
Public method | ClearCell | Deletes text or image, or removes parameter of this cell.
Public method | Dispose |
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell
Public method | GetCellFormatOptions(Int32, Document) | Returns a column's cell FormatOptions and if no FormatOptions exists for this column, it would come from the section.
Public method | GetCellFormatOptions(Int32, Int32, Document) | Returns a cell's FormatOptions and if no FormatOptions exists for this cell, it would come from the column, or the row, or the section.
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column
Public method | GetCellSpec | Gets the spec describing values of a cell, if applicable.
Public method | GetCellText | Returns the text shown by this cell, if the cell's type is CellType.Text or CellType.ParameterText or CellType.CustomField.
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section
Public method | GetColumnWidth | Returns a column's width in feet
Public method | GetColumnWidthInPixels | This returns a column's width in logical pixels
Public method | GetCustomFieldId | Gets custom field id from the cell.
Public method | GetMergedCell | Gets the whole merged cell that this cell is a part of.
Public method | GetRowHeight | Returns a row's height in feet
Public method | GetRowHeightInPixels | This returns a row's height in logical pixels
Public method | GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
Public method | InsertColumn | Inserts a new column at the specified index relative to the current set of columns.
Public method | InsertImage | Inserts a image in the given cell.
Public method | InsertRow | Inserts a row data at a specified index.
Public method | IsAcceptableParamIdAndCategoryId(ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in this table.
Public method | IsAcceptableParamIdAndCategoryId(Int32, ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in the given row in this table.
Public method | IsCellFormattable | Determines whether the cell is formattable or not
Public method | IsCellOverridden(Int32) | Indicates if the column is overridden or not.
Public method | IsCellOverridden(Int32, Int32) | Indicates if the cell is overridden or not.
Public method | IsDataOutOfDate | Indicates whether the data in this section is out of date.
Public method | IsValidColumnNumber | Verifies if the column number is valid.
Public method | IsValidImageSymbolId | Identifies if the element id represents a valid ImageSymbol element.
Public method | IsValidRowNumber | Verifies if the row number is valid.
Public method | MergeCells | Merges cells for the given area.
Public method | RefreshData | Rebuilds the data in this section if it is out of date.
Public method | RemoveColumn | Removes a column data at a specified index.
Public method | RemoveRow | Removes a row data at a specified index.
Public method | ResetCellOverride(Int32) | Resets the override of the column.
Public method | ResetCellOverride(Int32, Int32) | Resets the override of the cell.
Public method | SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
Public method | SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell
Public method | SetCellCombinedParameters(Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified column
Public method | SetCellCombinedParameters(Int32, Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified cell
Public method | SetCellFormatOptions | Sets a cell's FormatOptions.
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style.
Public method | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style
Public method | SetCellText | Sets a cell's to display the specified text.
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type
Public method | SetColumnWidth | Sets a column's width in feet
Public method | SetColumnWidthInPixels | This sets a column's width in logical pixels
Public method | SetMergedCell | Sets the merged cell that this cell is a part of.
Public method | SetRowHeight | Sets a row's height in feet
Public method | SetRowHeightInPixels | This sets a row's height in logical pixels

See Also

TableSectionData Class

AllowOverrideCellStyle Method

[image]