Revit 2024 API
PanelTypeSet Members
PanelTypeSet Class Constructors Methods Properties See Also Send Feedback

The PanelTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | PanelTypeSet | Initializes a new instance of the PanelTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every panel type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a panel type within the set.
Public method | Erase | Removes a specified panel type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified panel type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet Class

PanelTypeSet Methods

[image] [image]