Revit 2024 API
FormatOptions Members
FormatOptions Class Constructors Methods Properties See Also Send Feedback

The FormatOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FormatOptions()()()() | Creates a new FormatOptions object that represents default formatting.
Public method | FormatOptions(ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.
Public method | FormatOptions(FormatOptions) | Creates a copy of a FormatOptions object.
Public method | FormatOptions(ForgeTypeId, ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.

Methods

 | Name | Description
Public method | CanHaveSymbol()()()() | Checks whether a symbol can be specified to display the unit in this FormatOptions.
 | CanHaveSymbol(ForgeTypeId) | Checks whether a symbol can be specified to display a given unit.
Public method | CanSuppressLeadingZeros()()()() | Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressLeadingZeros(ForgeTypeId) | Checks whether leading zeros can be suppressed for a given unit.
Public method | CanSuppressSpaces()()()() | Checks whether spaces can be suppressed for the display unit in this FormatOptions.
 | CanSuppressSpaces(ForgeTypeId) | Checks whether spaces can be suppressed for a given unit.
Public method | CanSuppressTrailingZeros()()()() | Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressTrailingZeros(ForgeTypeId) | Checks whether trailing zeros can be suppressed for a given unit.
Public method | CanUsePlusPrefix()()()() | Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.
 | CanUsePlusPrefix(ForgeTypeId) | Checks whether a plus prefix can be displayed for a given unit.
Public method | Dispose | Releases all resources used by the FormatOptions
Public method | GetSymbolTypeId | Gets the identifier of the symbol indicating the unit quantifying the value.
Public method | GetUnitTypeId | Gets the identifier of the unit used to quantify values.
Public method | GetValidSymbols()()()() | Gets the identifiers of all valid symbols for the unit in this FormatOptions.
 | GetValidSymbols(ForgeTypeId) | Gets the identifiers of all valid symbols for a given unit.
Public method | IsValidAccuracy(Double) | Checks whether an accuracy is valid for the display unit in this FormatOptions.
 | IsValidAccuracy(ForgeTypeId, Double) | Checks whether an accuracy is valid for a given unit.
Public method | IsValidForSpec | Checks whether this FormatOptions is valid for a given spec.
Public method | IsValidSymbol(ForgeTypeId) | Checks whether a symbol is valid for the unit in this FormatOptions.
 | IsValidSymbol(ForgeTypeId, ForgeTypeId) | Checks whether a symbol is valid for a given unit.
Public method | SetSymbolTypeId | Sets the symbol that should be displayed to indicate the unit quantifying the value.
Public method | SetUnitTypeId | Sets the unit used to quantify values.

Properties

 | Name | Description
Public property | Accuracy | The accuracy to which values will be rounded.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RoundingMethod | The method used to round values: round to nearest, round up, or round down.
Public property | SuppressLeadingZeros | Indicates if leading zeros should be suppressed in feet and fractional inches.
Public property | SuppressSpaces | Indicates if spaces around the dash should be suppressed in feet and fractional inches.
Public property | SuppressTrailingZeros | Indicates if trailing zeros after the decimal point should be suppressed.
Public property | UseDefault | Indicates whether default or custom formatting should be used.
Public property | UseDigitGrouping | Indicates if digit grouping symbols should be displayed.
Public property | UsePlusPrefix | Indicates if a plus sign prefix should be displayed for positive and zero values.

See Also

FormatOptions Class

FormatOptions Constructor

[image] [image]