Revit 2024 API
NurbsSurfaceData Methods
NurbsSurfaceData Class See Also Send Feedback

The NurbsSurfaceData type exposes the following members.

Methods

 | Name | Description
 | Create | Construct NurbsSurfaceData based on NURBS surface data, where the weights are supplied. The NURBS surface will be (piecewise) polynomial if all the weights are equal, rational if not. Note: A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1.
Public method | Dispose |
Public method | GetControlPoints | Get the list of control points.
Public method | GetKnotsU | Get the list of knots in the u-direction.
Public method | GetKnotsV | Get the list of knots in the v-direction.
Public method | GetWeights | Get the list of weights.
Public method | IsValid | Check if the object contains a valid NurbsSurfaceData.

See Also

NurbsSurfaceData Class

Create Method

[image]