Revit 2024 API
BaseExportOptions Properties
BaseExportOptions Class See Also Send Feedback

The BaseExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name.
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false.
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false.
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity.

See Also

BaseExportOptions Class

Colors Property

[image]