Revit 2024 API
Element..::..GetValidTypes Method (Document, ICollection<(Of <(<'ElementId>)>)>)
Element Class See Also Send Feedback
Obtains a set of types that are valid for all given elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetValidTypes(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function GetValidTypes ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidTypes(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A collection of element IDs.

Return Value

A set of element IDs of types that are valid for these elements or an empty set if any element cannot have a type assigned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class
GetValidTypes Overload

HasPhases Method

[image]