Revit 2024 API
KeyBasedTreeEntriesLoadResults Members
KeyBasedTreeEntriesLoadResults Class Constructors Methods Properties See Also Send Feedback

The KeyBasedTreeEntriesLoadResults type exposes the following members.

Constructors

 | Name | Description
Public method | KeyBasedTreeEntriesLoadResults | Creates an empty KeyBasedTreeEntriesLoadResults.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntriesLoadResults
Public method | GetFailureMessages | Get all error or warnings created while attempting to load KeyBasedTreeEntries.
Public method | GetFileReadErrors | Gets the names of any files which could not be read due to access errors.
Public method | GetFileSyntaxErrors | Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries.
Public method | GetKeyBasedTreeEntryErrors()()()() | Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.
Public method | GetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) | Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

KeyBasedTreeEntriesLoadResults Class

KeyBasedTreeEntriesLoadResults Constructor

[image]