Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures Properties
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback

The BuiltInFailures..::..DividedSurfaceFailures type exposes the following members.

Properties

Name | Description
DividedSurfaceCannotApplyDivideSettings | Default Divide settings were not applied to Divided Surface. Please adjust grid spacing values manually.
DividedSurfaceCoincidingSplittingWorkplanes | Coinciding splitting workplanes are encountered
DividedSurfaceCurveChainBelongsToMultipleBeltIntervals | A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored
DividedSurfaceCurveChainBothUandV | A chain formed by these curve elements is trying to be both U- and V- splitter
DividedSurfaceCurveChainDoesNotEngageUorV | A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored
DividedSurfaceCurveChainGeneralProblem | The chain formed by these curve elements cannot be processed and will be ignored.
DividedSurfaceCurveChainIntersection | A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored
DividedSurfaceCurveChainIsTooClosedToGridlines | A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored
DividedSurfaceCurveChainMultipleSeqIntersWithDivLine | The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored
DividedSurfaceCurveChainNonSeqIntersWithDivLines | The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored
DividedSurfaceCurveChainUnsortableBucket | The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored
DividedSurfaceCurveFromChainMultipleIntersWithDivLine | A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored
DividedSurfaceCurveLoopChainIntersectedByExtensions | Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.
DividedSurfaceCuttingSurfaceDoesNotCutMeshFace | The surface-based splitter does not intersect a face to be divided and will be ignored
DividedSurfaceCuttingSurfaceGeneralProblem | Cannot process a surface-based splitter
DividedSurfaceCuttingSurfaceMakesMultipleCuts | The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported
DividedSurfaceDidNotRegenerateProperly | Divided Surface gridlines could not be generated.
DividedSurfaceDiscardedSplittersWarning | Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface
DividedSurfaceIgnoresSplitters | Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.
DividedSurfaceInvalidSpacing | Constraints not satisfied, cannot generate gridlines.
DividedSurfaceLoopsOfSplittingCurves | Curve elements forming a closed loop currently cannot be used as splitters and are ignored.
DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids | There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored
DividedSurfaceSelfIntersectingCurveLoopChain | Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveLoopsAsSplitters | Curve elements forming a single curve loop cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids | There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored
DividedSurfaceSplitManagerProblem1dNonWPCurve | Divided Surface cannot be split by a one dimensional curve without workplane
DividedSurfaceSplitManagerProblemClosedArcOrEllipse | Divided Surface cannot be split by a closed arc or ellipse.
DividedSurfaceSplitRefInvisible | Some of the splitting references of this Divided Surface are invisible in the current view.
DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors | Curve elements which form chains connecting points shared by more than two curve elements are ignored.
DividedSurfaceSplittingCurvesWithMultipleNeighbors | A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.
DividedSurfaceZeroLengthSplittingCurve | Curve element with zero length cannot be used as a splitter and ignored.
MeshTopologicalSortFailed | Splitters and grids do not define a consistent rectangular mesh on the face.

See Also

BuiltInFailures..::..DividedSurfaceFailures Class

DividedSurfaceCannotApplyDivideSettings Property

[image]