Revit 2024 API
ElementSet Members
ElementSet Class Constructors Methods Properties See Also Send Feedback

The ElementSet type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSet | Initializes a new instance of the ElementSet class

Methods

 | Name | Description
Public method | Clear | Removes every item element the set, rendering it empty.
Public method | Contains | Tests for the existence of an element within the set.
Public method | Erase | Removes a specified element from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of elements that are in the set.

See Also

ElementSet Class

ElementSet Constructor

[image]