Revit 2024 API
MultiReferenceAnnotationOptions Methods
MultiReferenceAnnotationOptions Class See Also Send Feedback

The MultiReferenceAnnotationOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | ElementsMatchReferenceCategory | Verifies that all of the elements match the reference category required by the MultiReferenceAnnotationType.
Public method | GetAdditionalReferencesToDimension | Gets the additional references which the dimension will witness.
Public method | GetElementsToDimension | Gets the elements which the dimension will witness.
Public method | IsAllowedDimensionStyleType | Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.
Public method | ReferencesDontMatchReferenceCategory | Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.
Public method | SetAdditionalReferencesToDimension | Sets the additional references which the dimension will witness.
Public method | SetElementsToDimension | Sets the elements which the dimension will witness.

See Also

MultiReferenceAnnotationOptions Class

Dispose Method

[image]