Revit 2024 API
ParameterFilterElement..::..Create Method (Document, String, ICollection<(Of <(<'ElementId>)>)>)
ParameterFilterElement Class See Also Send Feedback
Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ParameterFilterElement Create(
    Document aDocument,
    string name,
    ICollection<ElementId> categories
)
Visual Basic
Public Shared Function Create ( _
    aDocument As Document, _
    name As String, _
    categories As ICollection(Of ElementId) _
) As ParameterFilterElement
Visual C++
public:
static ParameterFilterElement^ Create(
    Document^ aDocument,
    String^ name,
    ICollection<ElementId^>^ categories
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document in which to create the ParameterFilterElement.
name
Type: System..::..String
The user-visible name for the new ParameterFilterElement.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The categories for the new ParameterFilterElement.

Return Value

A pointer to the new ParameterFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a filter element name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterElement Class
Create Overload

Create Method (Document, String, ICollection(ElementId), ElementFilter)

[image]