Revit 2024 API
ElementStructuralTypeFilter Members
ElementStructuralTypeFilter Class Constructors Methods Properties See Also Send Feedback

The ElementStructuralTypeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementStructuralTypeFilter(StructuralType) | Constructs a new instance of a filter to match elements by structural type.
Public method | ElementStructuralTypeFilter(StructuralType, Boolean) | Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | StructuralType | The structural type.

See Also

ElementStructuralTypeFilter Class

ElementStructuralTypeFilter Constructor

[image] [image]