Revit 2024 API
Parameter Members
Parameter Class Methods Properties See Also Send Feedback

The Parameter type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AssociateWithGlobalParameter | Associates this parameter with a global parameter in the same document.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString()()()() | Get the parameter value as a string with units.
Public method | AsValueString(FormatOptions) | Get the parameter value as a string with units.
Public method | CanBeAssociatedWithGlobalParameter | Tests whether this parameter can be associated with the given global parameter.
Public method | CanBeAssociatedWithGlobalParameters | Tests whether this parameter can be associated with any global parameter.
Public method | ClearValue | Clears the parameter to its initial value.
Public method | DissociateFromGlobalParameter | Dissociates this parameter from a global parameter.
Public method | GetAssociatedGlobalParameter | Returns a global parameter, if any, currently associated with this parameter.
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying the parameter value.
Public method | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(Int32) | Sets the parameter to a new integer value.
Public method | Set(String) | Sets the parameter to a new string of text.
Public method | Set(ElementId) | Sets the parameter to a new element id.
Public method | SetValueString | Set the parameter value according to the input string.

Properties

 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | Element | The element to which this parameter belongs.
Public property | GUID | The Guid for a shared parameter.
Public property | HasValue | Identifies if the parameter has an assigned value.
Public property | Id | The id of the parameter.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::..IsReadOnly.)
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.
Public property | UserModifiable | Indicates whether the interactive user can modify the value of this parameter.

See Also

Parameter Class

Parameter Methods

[image] [image]