Revit 2024 API
SelectionFilterElement Methods
SelectionFilterElement Class See Also Send Feedback

The SelectionFilterElement type exposes the following members.

Methods

 | Name | Description
Public method | AddSet | Adds a set of ElementIds to the filter's set.
Public method | AddSingle | Adds a single ElementId to the filter's set.
Public method | Clear | Removes all ElementIds from the filter.
Public method | Contains | Returns true if the given ElementId is a member of this filter's set.
 | Create | Creates a new SelectionFilterElement in the given document.
Public method | GetElementIds | Returns the set of ElementIds contained by this filter.
Public method | IsEmpty | Determines whether this filter's set is empty or not.
Public method | RemoveSet | Removes a set of ElementIds from the filter's set.
Public method | RemoveSingle | Removes a single ElementId from the filter's set.
Public method | SetElementIds | Replaces the set of ElementIds contained by this filter.

See Also

SelectionFilterElement Class

AddSet Method

[image]