Revit 2024 API
FamilyInstance..::..StructuralMaterialId Property
FamilyInstance Class See Also Send Feedback
Identifies the material that defines the instance's structural analysis properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId StructuralMaterialId { get; set; }
Visual Basic
Public Property StructuralMaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ StructuralMaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

FamilyInstance Class

StructuralMaterialType Property

[image]