Revit 2024 API
FilteredElementCollector Constructor
FilteredElementCollector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FilteredElementCollector(Document) | Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.
Public method | FilteredElementCollector(Document, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.
Public method | FilteredElementCollector(Document, ICollection<(Of <<'(ElementId>)>>)) | Constructs a new FilteredElementCollector that will search and filter a specified set of elements.
Public method | FilteredElementCollector(Document, ElementId, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements from a Revit link in a host document view.

See Also

FilteredElementCollector Class
FilteredElementCollector Members

FilteredElementCollector Constructor (Document)

[image]