Revit 2024 API
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

 | Name | Description
Public property | Center | Returns the center of the ellipse.
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | XDirection | The X direction.
Public property | YDirection | The Y direction.

See Also

Ellipse Class

Center Property

[image]