Revit 2024 API
Toposolid Members
Toposolid Class Methods Properties See Also Send Feedback

The Toposolid type exposes the following members.

Methods

 | Name | Description
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IList<(Of <<'(XYZ>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(XYZ>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | CreateFromTopographySurface | Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.
Public method | CreateSubDivision | Create a toposolid subdivision element with the current toposolid as its host.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Toposolid.
Public method | GetSubDivisionIds | Get all element ids of toposolid subdivisions with the current toposolid as its host.
Public method | Simplify | Simplifies the toposolid by reducing the number of inner vertices to the given percentage.
Public method | Split | Split the toposolid by the given curve loops.

Properties

 | Name | Description
Public property | HostTopoId | The host toposolid id of the current toposolid subdivision. If the object is not a toposolid subdivision, hostTopoId will be InvalidElementId.
Public property | SketchId | Returns id of the sketch.

See Also

Toposolid Class

Toposolid Methods

[image] [image]