Revit 2024 API
Group Members
Group Class Methods Properties See Also Send Feedback

The Group type exposes the following members.

Methods

 | Name | Description
Public method | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this group type.
Public method | GetMemberIds | Retrieves all the member ElementIds of the group.
Public method | GetShownAttachedDetailGroupTypeIds | Returns the attached detail groups which have displayed instances for this group type in the input view.
Public method | HideAllAttachedDetailGroups | Hides all the available attached detail groups for this element group type that are compatible with the input view type.
Public method | HideAttachedDetailGroups | Hides the element group's attached detail groups of the input group type that are compatible with the input view.
Public method | IsCompatibleAttachedDetailGroupType | Checks if the orientation of the input attached detail group matches the input view's orientation.
Public method | ShowAllAttachedDetailGroups | Shows all the available attached detail groups for this element group type that are compatible with the input view type.
Public method | ShowAttachedDetailGroups | Shows the element group's attached detail groups of the input group type that are compatible with the input view.
Public method | UngroupMembers | Ungroups the group.

Properties

 | Name | Description
Public property | AttachedParentId | Indicates the Id of the parent group this group is attached to.
Public property | GroupType | Get or set the type of the group.
Public property | IsAttached | Indicates wether or not this group is attached to a parent group.
Public property | Location | This property is used to find the physical location of a group within project. (Overrides Element..::..Location.)

See Also

Group Class

Group Methods

[image] [image]