Revit 2024 API
MaterialNode Members
MaterialNode Class Methods Properties See Also Send Feedback

The MaterialNode type exposes the following members.

Methods

 | Name | Description
Public method | GetAppearance | Appearance properties associated with the material.
Public method | GetAppearanceOverride | Returns appearance properties that override the preset appearance of the material.

Properties

 | Name | Description
Public property | Color | The color the material is being rendered at
Public property | Glossiness | The level of glossiness of the material
Public property | HasOverriddenAppearance | Identifies if the default rendering appearance the material has is being overridden.
Public property | MaterialId | The Id of the element assocated with this material in the model.
Public property | Smoothness | The level of smoothness of the material.
Public property | ThumbnailFile | The path if a file that contains a thumbnail image of the material.
Public property | Transparency | The value of transparency the material is being rendered with

See Also

MaterialNode Class

MaterialNode Methods

[image] [image]