Revit 2024 API
TriOrQuadFacet Members
TriOrQuadFacet Class Methods Properties See Also Send Feedback

The TriOrQuadFacet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriOrQuadFacet
Public method | GetVertexIndex | Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Normal | A unit normal vector for this facet.
Public property | NumberOfVertices | The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).

See Also

TriOrQuadFacet Class

TriOrQuadFacet Methods

[image] [image]