Revit 2024 API
VertexIndexPairArray Members
VertexIndexPairArray Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Constructors

 | Name | Description
Public method | VertexIndexPairArray | Initializes a new instance of the VertexIndexPairArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every VertexIndex pair from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a VertexIndex pair at a specified index within the array.
Public property | Size | Returns the number of VertexIndex pairs that are in the array.

See Also

VertexIndexPairArray Class

VertexIndexPairArray Constructor

[image]