Revit 2024 API
BuiltInFailures..::..AssemblyFailures Properties
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback

The BuiltInFailures..::..AssemblyFailures type exposes the following members.

Properties

Name | Description
AddedElementsNotSamePhaseAsAssembly | Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.
AssemblyDeleteTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyDidNotMatchRequestedTypeWarn | Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.
AssemblyDisassembleInstanceWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyInheritTypeWarn | Edits to these assemblies do not match existing types, new type will be created.
AssemblyInvalidMember | Some elements became ineligible to be included in an assembly and were removed.
AssemblyNewTypeWarn | Edits to these assemblies match existing type and will inherit that name.
AssemblyRenameTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
CouldNotAcquireAssemblyViews | The assembly instance could not acquire the assembly views.
CouldNotChangeTypeOfAssembly | Assembly cannot be changed to selected type.
DeleteAssemblyInstWithViewsWarn | Deleting this assembly will remove the assembly from the project and any views associated with that assembly.
DeleteShopDrawingsWarn | The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!
ElementsNotAllowedAreNotAddedToAssembly | Elements not allowed in Assembly were not added to it, but only in the document
IneligibleElementsInAssembly | Ineligible elements in assembly.
MixedPhasesInAssembly | Assembly cannot be created. All elements must have the same phases to be included in an assembly.
NoElementsAddedtoNewAssembly | No elements were added to the assembly. No assembly will be created.
NoElementsLeftInExistingAssembly | There are no elements left in the assembly. It will be disassembled.
NoEligibleElementsInAssembly | No eligible elements in assembly.
SomeElementsPreventAssemblyTypeChange | Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.

See Also

BuiltInFailures..::..AssemblyFailures Class

AddedElementsNotSamePhaseAsAssembly Property

[image]