Revit 2024 API
TextRange Members
TextRange Class Constructors Methods Properties See Also Send Feedback

The TextRange type exposes the following members.

Constructors

 | Name | Description
Public method | TextRange()()()() | Constructs a TextRange with default values for start and length.
Public method | TextRange(TextRange) | Constructs a copy of the input TextRange object.
Public method | TextRange(Int32, Int32) | Constructs a TextRange with input start and length.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TextRange

Properties

 | Name | Description
Public property | End | The index of the first character after the end of the range
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | The length of the range.
Public property | Start | The start index of a range within the FormattedText.

See Also

TextRange Class

TextRange Constructor

[image] [image]