Revit 2024 API
Sketch Members
Sketch Class Methods Properties See Also Send Feedback

The Sketch type exposes the following members.

Methods

 | Name | Description
Public method | GetAllElements | Returns all elements which belong to the sketch.

Properties

 | Name | Description
Public property | OwnerId | Returns id of the sketch owner element or invalidElementId if sketch does not build a geometry.
Public property | Profile | Returns the Profile of the Sketch.
Public property | SketchPlane | Returns the Sketch Plane of the Sketch.

See Also

Sketch Class

Sketch Methods

[image] [image]