Revit 2024 API
DimensionEqualityLabelFormatting Members
DimensionEqualityLabelFormatting Class Constructors Methods Properties See Also Send Feedback

The DimensionEqualityLabelFormatting type exposes the following members.

Constructors

 | Name | Description
Public method | DimensionEqualityLabelFormatting | Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DimensionEqualityLabelFormatting
Public method | GetFormatOptions | Gets the format options used to show the parameter value.
Public method | IsValidFormatOptions | Checks whether a FormatOptions object is valid for the LabelType.
Public method | SetFormatOptions | Sets the format options used to show the parameter value.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LabelType | The parameter value to be shown.
Public property | LeadingSpaces | The number of spaces to include before the parameter value.
Public property | Prefix | The prefix to include before the parameter value.
Public property | Suffix | The suffix to include after the parameter value.

See Also

DimensionEqualityLabelFormatting Class

DimensionEqualityLabelFormatting Constructor

[image]