Revit 2024 API
TessellatedShapeBuilder Methods
TessellatedShapeBuilder Class See Also Send Feedback

The TessellatedShapeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddFace | Adds a face to the currently open connected face set.
Public method | AreTargetAndFallbackCompatible | Checks whether this combination of fallback and target parameters can be used as a valid combination of inputs.
Public method | Build | Builds the designated geometrical objects from the stored face sets. Stores the result in this TessellatedShapeBuilder object.
Public method | CancelConnectedFaceSet | Cancels the current face set - i.e., all data from it will be lost and the builder will have no open connected face set anymore.
Public method | Clear | Erases all face set and clears the logs, if any.
Public method | CloseConnectedFaceSet | Closes the currently open connected face set.
 | CreateMeshByExtrusion | Builds a mesh by extruding curve loop(s) along extrusion distance.
Public method | DoesFaceHaveEnoughLoopsAndVertices | Checks whether 'face' has enough loops and vertcies to be valid.
Public method | GetBuildResult | Get the built geometry, build status and other data stored in TessellatedShapeBuilderResult. Clears the stored data.
Public method | OpenConnectedFaceSet | Opens a new connected face set.

See Also

TessellatedShapeBuilder Class

AddFace Method

[image]