Revit 2024 API
CustomFieldData Members
CustomFieldData Class Methods Properties See Also Send Feedback

The CustomFieldData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CustomFieldData
Public method | GetCustomFieldId | Gets an unique identifier of the custom field.
Public method | GetCustomFieldProperties | Gets an instance of ICustomFieldProperties which represents the properties of this field.
Public method | SetCustomFieldProperties | Sets an instance of ICustomFieldProperties which represents the properties of this field.
Public method | ValidateCustomFieldProperties | Validates the custom field properties.

Properties

 | Name | Description
Public property | DefaultRowHeightOnSheet | Identifies the default row height for this field.
Public property | FieldName | The name of this custom field.
Public property | FieldTooltip | The tooltip that will be shown in the schedule properties dialog for this custom field.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CustomFieldData Class

Dispose Method

[image]