Revit 2024 API
InternalDefinition Methods
InternalDefinition Class See Also Send Feedback

The InternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetGroupTypeId | Gets the identifier of the built-in parameter group to which the parameter defined by this definition belongs. (Overrides Definition..::..GetGroupTypeId()()()().)
Public method | GetParameterTypeId | Tests whether this definition identifies a built-in parameter or not.
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | SetAllowVaryBetweenGroups | Whether or not the parameter values can vary across group members.
Public method | SetGroupTypeId | Sets the built-in parameter group to which the parameter defined by this definition belongs.

See Also

InternalDefinition Class

Dispose Method

[image]