Revit 2024 API
ViewCropRegionShapeManager Methods
ViewCropRegionShapeManager Class See Also Send Feedback

The ViewCropRegionShapeManager type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetAnnotationCropShape | Gets the annotation crop box assigned to the view.
Public method | GetCropShape | Gets the crop boundaries that are curently active.
Public method | GetSplitRegionMaximum | Returns the proportional location of the maximum boundary of the specified split crop region.
Public method | GetSplitRegionMinimum | Returns the proportional location of the minimum boundary of the specified split crop region.
Public method | GetSplitRegionOffset | Returns the offset for the specified split crop region.
Public method | IsCropRegionShapeValid | Verifies that boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Public method | RemoveCropRegionShape | Removes any non-rectangular boundary of the view's crop.
Public method | RemoveSplit | Removes any split applied to the view's crop.
Public method | RemoveSplitRegion | Removes one region in split crop.
Public method | SetCropShape | Sets the boundary of the view's crop to the specified shape.
Public method | SplitRegionHorizontally | Splits horizontally one region in split crop.
Public method | SplitRegionVertically | Splits vertically one region in split crop.

See Also

ViewCropRegionShapeManager Class

Dispose Method

[image]