Revit 2024 API
FormatOptions Methods
FormatOptions Class See Also Send Feedback

The FormatOptions type exposes the following members.

Methods

 | Name | Description
Public method | CanHaveSymbol()()()() | Checks whether a symbol can be specified to display the unit in this FormatOptions.
 | CanHaveSymbol(ForgeTypeId) | Checks whether a symbol can be specified to display a given unit.
Public method | CanSuppressLeadingZeros()()()() | Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressLeadingZeros(ForgeTypeId) | Checks whether leading zeros can be suppressed for a given unit.
Public method | CanSuppressSpaces()()()() | Checks whether spaces can be suppressed for the display unit in this FormatOptions.
 | CanSuppressSpaces(ForgeTypeId) | Checks whether spaces can be suppressed for a given unit.
Public method | CanSuppressTrailingZeros()()()() | Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressTrailingZeros(ForgeTypeId) | Checks whether trailing zeros can be suppressed for a given unit.
Public method | CanUsePlusPrefix()()()() | Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.
 | CanUsePlusPrefix(ForgeTypeId) | Checks whether a plus prefix can be displayed for a given unit.
Public method | Dispose |
Public method | GetSymbolTypeId | Gets the identifier of the symbol indicating the unit quantifying the value.
Public method | GetUnitTypeId | Gets the identifier of the unit used to quantify values.
Public method | GetValidSymbols()()()() | Gets the identifiers of all valid symbols for the unit in this FormatOptions.
 | GetValidSymbols(ForgeTypeId) | Gets the identifiers of all valid symbols for a given unit.
Public method | IsValidAccuracy(Double) | Checks whether an accuracy is valid for the display unit in this FormatOptions.
 | IsValidAccuracy(ForgeTypeId, Double) | Checks whether an accuracy is valid for a given unit.
Public method | IsValidForSpec | Checks whether this FormatOptions is valid for a given spec.
Public method | IsValidSymbol(ForgeTypeId) | Checks whether a symbol is valid for the unit in this FormatOptions.
 | IsValidSymbol(ForgeTypeId, ForgeTypeId) | Checks whether a symbol is valid for a given unit.
Public method | SetSymbolTypeId | Sets the symbol that should be displayed to indicate the unit quantifying the value.
Public method | SetUnitTypeId | Sets the unit used to quantify values.

See Also

FormatOptions Class

CanHaveSymbol Method

[image] [image]