Revit 2024 API
Options Members
Options Class Constructors Methods Properties See Also Send Feedback

The Options type exposes the following members.

Constructors

 | Name | Description
Public method | Options()()()() | Creates a default Options object.
Public method | Options(Options) | Copy constructor.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | ComputeReferences | Determines whether or not references to geometric objects are computed.
Public property | DetailLevel | The detail level for the geometry extracted with these options.
Public property | IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
Public property | View | The view used for geometry extraction.

See Also

Options Class

Options Constructor

[image] [image]