Revit 2024 API
ShapeImporter Methods
ShapeImporter Class See Also Send Feedback

The ShapeImporter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the geometry stored in the external format into a collection of Revit geometry objects.
Public method | Dispose |
 | IsServiceAvailable | Checks whether the data conversion service is available.
Public method | SetDefaultLengthUnit | Sets the length unit to be used when the input is a unitless SAT file.

See Also

ShapeImporter Class

Convert Method

[image]