Revit 2024 API
ElementArray Methods
ElementArray Class See Also Send Feedback

The ElementArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every element from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

See Also

ElementArray Class

Append Method

[image]