Revit 2024 API
RoofBase Members
RoofBase Class Methods Properties See Also Send Feedback

The RoofBase type exposes the following members.

Methods

 | Name | Description
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase.

Properties

 | Name | Description
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
Public property | RoofType | Retrieve or set the Type.
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing.

See Also

RoofBase Class

RoofBase Methods

[image] [image]