Revit 2024 API
CurveByPoints Methods
CurveByPoints Class See Also Send Feedback

The CurveByPoints type exposes the following members.

Methods

 | Name | Description
Public method | GetPoints | Get the sequence of points interpolated by this curve.
Public method | GetVisibility | Gets the visibility.
Public method | SetPoints | Change the sequence of points interpolated by this curve.
Public method | SetVisibility | Sets the visibility.
 | SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.

See Also

CurveByPoints Class

GetPoints Method

[image]