Revit 2024 API
View Properties
View Class See Also Send Feedback

The View type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view.
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view.
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view.
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view.
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view.
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view.
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view.
Public property | CanBePrinted | Test whether the view can be printed.
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view.
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
Public property | DetailLevel | The detail level of this view.
Public property | Discipline | The Discipline of the view.
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
Public property | GenLevel | The level for the view.
Public property | IsAssemblyView | Indicates if the view is assembly view.
Public property | IsCallout | Indicates if the view is a callout view.
Public property | IsTemplate | Test whether the view is a view template.
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in feet).
Public property | PartsVisibility | The visibility setting for parts in this view.
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation.
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100.
Public property | TemporaryViewModes | Data of temporary view modes associated with this view.
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view.
Public property | UpDirection | The direction towards the top of the screen.
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewTemplateId | The id of the template view that controls this view's parameters.
Public property | ViewType | The type of the view.

See Also

View Class

AnalysisDisplayStyleId Property

[image]