Revit 2024 API
ViewSheet Members
ViewSheet Class Methods Properties See Also Send Feedback

The ViewSheet type exposes the following members.

Methods

 | Name | Description
Public method | CanBeDuplicated | Identifies if this sheet can be duplicated.
Public method | ConvertToRealSheet | Converts a placeholder sheet to a real one with an optional titleblock.
 | Create | Creates a new ViewSheet.
 | CreatePlaceholder | Creates a placeholder sheet in a document.
Public method | DeleteViewport | Removes a viewport from the sheet by deleting it from the document.
Public method | Duplicate(SheetDuplicateOption) | Duplicates this sheet to generate a new one.
Public method | GetAdditionalRevisionIds | Gets the Revisions that are additionally included in the sheet's revision schedules.
Public method | GetAllPlacedViews | Returns the ElementIds of Views placed on this sheet.
Public method | GetAllRevisionCloudIds | Gets the ids of the revision clouds which appear on the sheet's revision schedules.
Public method | GetAllRevisionIds | Gets the ordered array of Revisions which participate in the sheet's revision schedules.
Public method | GetAllViewports | Returns the ElementIds of Viewports on this sheet.
Public method | GetCurrentRevision | Returns the most recent numbered Revision shown on this ViewSheet.
Public method | GetRevisionCloudNumberOnSheet | Gets the Revision Number for a RevisionCloud on this sheet.
Public method | GetRevisionNumberOnSheet | Gets the Revision Number for a particular Revision as it will appear on this sheet.
Public method | SetAdditionalRevisionIds | Sets the Revisions to additionally include in the sheet's revision schedules.

Properties

 | Name | Description
Public property | IsPlaceholder | Identifies whether or not the view sheet represents a placeholder sheet.
Public property | SheetNumber | The sheet number of the document.

See Also

ViewSheet Class

CanBeDuplicated Method

[image]