Revit 2024 API
SpatialElementGeometryCalculator Methods
SpatialElementGeometryCalculator Class See Also Send Feedback

The SpatialElementGeometryCalculator type exposes the following members.

Methods

 | Name | Description
Public method | CalculateSpatialElementGeometry | Compute the spatial element geometry and returns the boundary face information.
 | CanCalculateGeometry | This indicates whether the input spatial element is a valid one.
Public method | Dispose |
Public method | GetOptions | The options that control the calculation.
 | IsRoomOrSpace | This indicates whether the input spatial element is a room or a space.

See Also

SpatialElementGeometryCalculator Class

CalculateSpatialElementGeometry Method

[image]