Revit 2024 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

 | Name | Description
Public method | CopyModel | Copies an existing model to a new file. Overwriting a file of the same name is allowed.
Public method | Dispose |
Public method | ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
Public method | GetAssets | Gets all the Assets of the specified type.
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetRevitServerNetworkHosts | Gets the list of all Revit Server Network hosts in current session.
Public method | GetSystemsAnalysisWorkflowNames | Returns names for systems analysis workflows.
Public method | GetSystemsAnalysisWorkflows | Returns name and path information identifying systems analysis workflow files.
Public method | GetWorksharingCentralGUID | Gets the worksharing central GUID of the given server-based model.
Public method | IsJournalPlaying | Determines if the application is currently in journal playback mode.
 | IsValidThickness | Checks if the input value is valid to be supplied as a thickness (for an extrusion, or blend, or wall layer, or similar geometric construct).
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument(String) | New project document
Public method | NewProjectDocument(UnitSystem) | Creates a new project document with no template file specified.
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenDocumentFile(String) | Opens a document from disk.
Public method | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk or cloud.
Public method | OpenDocumentFile(ModelPath, OpenOptions, IOpenFromCloudCallback) | Opens a document from disk or cloud.
Public method | OpenIFCDocument(String) | Opens an IFC document from disk using default options.
Public method | OpenIFCDocument(String, IFCImportOptions) | Opens an IFC document from disk using custom options.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | PurgeReleasedAPIObjects | Explicitly purges all API objects that have been released but are still awaiting to be finalized
 | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | SetSystemsAnalysisWorkflows | Sets name and path information identifying systems analysis workflow files.
Public method | UpdateRenderAppearanceLibrary | Updates the stored render appearance library, giving the Revit session access to any new RPC content.
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

CopyModel Method

[image]