Revit 2024 API
MEPSize Members
MEPSize Class Constructors Methods Properties See Also Send Feedback

The MEPSize type exposes the following members.

Constructors

 | Name | Description
Public method | MEPSize | Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MEPSize

Properties

 | Name | Description
Public property | InnerDiameter | Inner diameter
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NominalDiameter | Nominal diameter
Public property | OuterDiameter | Outer diameter
Public property | UsedInSizeLists | Whether it is used in size lists.
Public property | UsedInSizing | Whether is used in sizing.

See Also

MEPSize Class

MEPSize Constructor

[image]