Revit 2024 API
StructuralAsset Methods
StructuralAsset Class See Also Send Feedback

The StructuralAsset type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose |
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.
Public method | SetPoissonRatio | Sets the Poisson ratio of the asset.
Public method | SetShearModulus | Sets the shear modulus of the asset.
Public method | SetThermalExpansionCoefficient | Sets the thermal expansion coefficient of the asset.
Public method | SetYoungModulus | Sets the Young's modulus of the asset.

See Also

StructuralAsset Class

Copy Method

[image]