Revit 2024 API
HermiteSpline..::..ControlPoints Property
HermiteSpline Class See Also Send Feedback
The control points of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<XYZ> ControlPoints { get; set; }
Visual Basic
Public Property ControlPoints As IList(Of XYZ)
    Get
    Set
Visual C++
public:
property IList<XYZ^>^ ControlPoints {
    IList<XYZ^>^ get ();
    void set (IList<XYZ^>^ value);
}

See Also

HermiteSpline Class

IsPeriodic Property

[image]