Revit 2024 API
DimensionType Members
DimensionType Class Methods Properties See Also Send Feedback

The DimensionType type exposes the following members.

Methods

 | Name | Description
Public method | CanHaveEqualityFormula | Checks whether this DimensionType can have an equality formula.
Public method | CanHaveOrdinateDimensionSetting | Checks whether this DimensionType can have an ordinate dimension settings.
Public method | GetAlternateUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | GetEqualityFormula | Gets an ordered list of the entries in the equality formula definition.
Public method | GetOrdinateDimensionSetting | Gets the ordinate dimension settings for this DimensionType.
Public method | GetSpecTypeId | Gets the spec of this dimension style.
Public method | GetUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the units value.
Public method | SetAlternateUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | SetEqualityFormula | Sets an ordered list of the entries to use in the equality formula definition.
Public method | SetOrdinateDimensionSetting | Sets the ordinate dimension settings for this DimensionType.
Public method | SetUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the units value.

Properties

 | Name | Description
Public property | AlternateUnits | The alternate units display mode for this DimensionType.
Public property | AlternateUnitsPrefix | The prefix text for the alternate units value.
Public property | AlternateUnitsSuffix | The suffix text for the alternate units value.
Public property | Prefix | The prefix text for the dimension value.
Public property | StyleType | The dimension style type of this DimensionType.
Public property | Suffix | The suffix text for the dimension value.

See Also

DimensionType Class

DimensionType Methods

[image] [image]