Revit 2024 API
Frame Methods
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Methods

 | Name | Description
 | CanDefineRevitGeometry | Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
Public method | Dispose |
Public method | IsOrthogonal | Determines if this frame's basis vectors are orthogonal.
Public method | IsOrthonormal | Determines if this frame's basis vectors are orthonormal.
Public method | IsRightHanded | Determine if this frame's basis is right-handed.
Public method | Transform | Applies the input transform to this frame.

See Also

Frame Class

CanDefineRevitGeometry Method

[image]