Revit 2024 API
CameraInfo Members
CameraInfo Class Methods Properties See Also Send Feedback

The CameraInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CameraInfo

Properties

 | Name | Description
Public property | FarDistance | Distance from eye point to far plane of view frustum along the view direction.
Public property | HorizontalExtent | Distance between left and right planes on the target plane.
Public property | IsPerspective | Identifies whether the projection is orthographic or perspective
Public property | IsPespective | Identifies whether the projection is orthographic or perspective
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NearDistance | Distance from eye point to near plane of view frustum along the view direction.
Public property | RightOffset | Distance that the target plane is offset towards the right where right is normal to both Up direction and View direction. This offset shifts both left and right planes.
Public property | TargetDistance | Distance from eye point along view direction to target plane.
Public property | UpOffset | Distance that the target plane is offset in the direction of the Up direction. This offset shifts both top and bottom planes.
Public property | VerticalExtent | Distance between top and bottom planes on the target plane.

See Also

CameraInfo Class

CameraInfo Methods

[image] [image]