Revit 2024 API
RevisionNumberingSequence Members
RevisionNumberingSequence Class Methods Properties See Also Send Feedback

The RevisionNumberingSequence type exposes the following members.

Methods

 | Name | Description
 | CreateAlphanumericSequence | Creates a new alphanumeric revision numbering sequence in the document.
 | CreateNumericSequence | Creates a new numeric revision numbering sequence in the document.
 | GetAllRevisionNumberingSequences | Gets all of the revision numbering sequences from the document.
Public method | GetAlphanumericRevisionSettings | Returns a copy of the AlphanumericRevisionSettings owned by this revision numbering sequence.
Public method | GetNumericRevisionSettings | Returns a copy of the NumericRevisionSettings owned by this revision numbering sequence.
Public method | HasValidAlphanumericRevisionSettings | Checks whether the revision numbering sequence owns a valid alphanumeric revision settings.
Public method | HasValidNumericRevisionSettings | Checks whether the revision numbering sequence owns a valid numeric revision settings.
Public method | HasValidRevisionSettingsForNumberType | Checks whether the revision numbering sequence owns a valid revision settings for number type.
Public method | SetAlphanumericRevisionSettings | Replaces the current alphanumeric revision numbering settings with the provided settings.
Public method | SetNumericRevisionSettings | Replaces the current numeric revision numbering settings with the provided settings.

Properties

 | Name | Description
Public property | NumberType | Indicates the revision number type of the revision numbering sequence.
Public property | SequenceName | The name of this revision numbering sequence.

See Also

RevisionNumberingSequence Class

CreateAlphanumericSequence Method

[image]