Revit 2024 API
BRepBuilderSurfaceGeometry..::..CreateNURBSSurface Method
BRepBuilderSurfaceGeometry Class See Also Send Feedback

Overload List

Name | Description
CreateNURBSSurface(Int32, Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), Boolean, BoundingBoxUV) | Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.
CreateNURBSSurface(Int32, Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>), Boolean, BoundingBoxUV) | Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.

See Also

BRepBuilderSurfaceGeometry Class
BRepBuilderSurfaceGeometry Members

CreateNURBSSurface Method (Int32, Int32, IList(Double), IList(Double), IList(XYZ), Boolean, BoundingBoxUV)

[image]