Revit 2024 API
CurveElementFilter Members
CurveElementFilter Class Constructors Methods Properties See Also Send Feedback

The CurveElementFilter type exposes the following members.

Constructors

 | Name | Description
Public method | CurveElementFilter(CurveElementType) | Constructs a new instance of a filter to match specific types of curve elements.
Public method | CurveElementFilter(CurveElementType, Boolean) | Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | CurveElementType | The curve element type.

See Also

CurveElementFilter Class

CurveElementFilter Constructor

[image] [image]