Revit 2024 API
LinePatternSegment Members
LinePatternSegment Class Constructors Methods Properties See Also Send Feedback

The LinePatternSegment type exposes the following members.

Constructors

 | Name | Description
Public method | LinePatternSegment()()()() | Creates a line pattern segment.
Public method | LinePatternSegment(LinePatternSegmentType, Double) | Creates a line pattern segment with given type and length.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinePatternSegment

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Gets and sets the length of the segment.
Public property | Type | Gets and sets the type of the segment.

See Also

LinePatternSegment Class

LinePatternSegment Constructor

[image] [image]