Revit 2024 API
BoundaryValidation Methods
BoundaryValidation Class See Also Send Feedback

The BoundaryValidation type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
 | IsValidBoundaryOnSketchPlane | Indicates if the given curve loops compose a valid boundary on the sketch plane.
 | IsValidBoundaryOnView | Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.
 | IsValidHorizontalBoundary | Identifies whether the given curve loops compose a valid horizontal boundary.

See Also

BoundaryValidation Class

Dispose Method

[image]