Revit 2024 API
ExportLineweightTable Members
ExportLineweightTable Class Constructors Methods Properties See Also Send Feedback

The ExportLineweightTable type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLineweightTable | Constructs a new ExportLineweightTable with default settings.

Methods

 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line weight table.
Public method | Clear | Removes all contents stored in Export line weight table.
Public method | ContainsKey | Checks whether a line weight key exists in the table.
Public method | Dispose | Releases all resources used by the ExportLineweightTable
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLineweightInfo | Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLineweightTableIterator | Returns a ExportLineweightTableIterator that iterates through the collection.
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLineweightKey.

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLineweightInfo for the line weight's ExportLineweightKey.

See Also

ExportLineweightTable Class

ExportLineweightTable Constructor

[image]