Revit 2024 API
ViewSet Members
ViewSet Class Constructors Methods Properties See Also Send Feedback

The ViewSet type exposes the following members.

Constructors

 | Name | Description
Public method | ViewSet | Initializes a new instance of the ViewSet class

Methods

 | Name | Description
Public method | Clear | Removes every view from the set, rendering it empty.
Public method | Contains | Tests for the existence of a view within the set.
Public method | Erase | Removes a specified view from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified view into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of views that are in the set.

See Also

ViewSet Class

Clear Method

[image]