Revit 2024 API
TemporaryViewModes Methods
TemporaryViewModes Class See Also Send Feedback

The TemporaryViewModes type exposes the following members.

Methods

 | Name | Description
Public method | DeactivateAllModes | Deactivates all temporary modes that are currently active.
Public method | DeactivateMode | Deactivates the given temporary mode.
Public method | GetCaption | A text caption to use for the given mode.
Public method | IsCustomized | Identifies if a custom temporary view mode is currently active. A custom mode is active if there is a non-empty string set for CustomTitle.
Public method | IsModeActive | Tests whether a given mode is currently active or not.
Public method | IsModeAvailable | Tests whether a temporary view mode is currently available in the associated view.
Public method | IsModeEnabled | Tests whether a temporary view mode is currently enabled in the associated view.
Public method | IsValidState | Tests whether the given state is valid for the associated view and the context the view is currently in.
Public method | RemoveCustomization | Removes all customized values for the TemporaryViewProperties mode.

See Also

TemporaryViewModes Class

DeactivateMode Method

[image]