Revit 2024 API
FabricationServiceButton Members
FabricationServiceButton Class Methods Properties See Also Send Feedback

The FabricationServiceButton type exposes the following members.

Methods

 | Name | Description
Public method | ContainsFabricationPartType | Checks to see if the fabrication part type exists on one of the button conditions.
Public method | Dispose | Releases all resources used by the FabricationServiceButton
Public method | GetConditionDescription | Gets the description for the condition size range.
Public method | GetConditionImage | Gets the image for the specified fabrication service button condition.
Public method | GetConditionLowerValue | Gets the condition lower value (valid if greater or equal) for a given condition index.
Public method | GetConditionName | Gets the name of the specified condition on the fabrication service button.
Public method | GetConditionUpperValue | Gets the condition upper value (valid if less) for a given condition index.
Public method | GetImage | Gets the image for fabrication service button.
Public method | IsExcluded | Gets if the button's fabrication part content associated with the button is to be excluded from Route and Fill, Design to Fabrication, or Multi-Point Routing commands.
Public method | IsUnrestrictedCondition | Checks if the condition is unrestricted.
Public method | IsValid | Checks if the button contains only valid fittings.
 | IsValidConditionIndex | Validates if the given condition index is valid or not.

Properties

 | Name | Description
Public property | ButtonIndex | The button index for this button.
Public property | Code | The code of the button.
Public property | ConditionCount | The number of conditions.
Public property | IsAHanger | Checks if the fabrication service button is hanger.
Public property | IsStraight | Checks if all of the fabrication service button conditions are straights.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the button.
Public property | PaletteIndex | The palette index for this button.
Public property | ServiceId | The fabrication service identifier for the fabrication service this button belongs to.

See Also

FabricationServiceButton Class

FabricationServiceButton Methods

[image] [image]