Revit 2024 API
TransactionGroup Methods
TransactionGroup Class See Also Send Feedback

The TransactionGroup type exposes the following members.

Methods

 | Name | Description
Public method | Assimilate | Assimilates all inner transactions by merging them into a single undo item.
Public method | Commit | Commits the transaction group.
Public method | Dispose |
Public method | GetName | Returns the transaction group's name. It could be an empty string.
Public method | GetStatus | Gets the current status of the transaction group.
Public method | HasEnded | Determines whether the transaction group has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack | Rolls back the transaction group, which effectively undoes all transactions committed inside the group.
Public method | SetName | Sets the transaction group's name.
Public method | Start()()()() | Starts the transaction group
Public method | Start(String) | Starts the transaction group with an assigned name.

See Also

TransactionGroup Class

Assimilate Method

[image]