Revit 2024 API
ExtrusionAnalyzer Methods
ExtrusionAnalyzer Class See Also Send Feedback

The ExtrusionAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | CalculateFaceAlignment | Calculates the alignment status of each face of the solid.
 | Create | Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public method | Dispose |
Public method | GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis.

See Also

ExtrusionAnalyzer Class

CalculateFaceAlignment Method

[image]