Revit 2024 API
Toposolid Methods
Toposolid Class See Also Send Feedback

The Toposolid type exposes the following members.

Methods

 | Name | Description
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IList<(Of <<'(XYZ>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(XYZ>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | CreateFromTopographySurface | Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.
Public method | CreateSubDivision | Create a toposolid subdivision element with the current toposolid as its host.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Toposolid.
Public method | GetSubDivisionIds | Get all element ids of toposolid subdivisions with the current toposolid as its host.
Public method | Simplify | Simplifies the toposolid by reducing the number of inner vertices to the given percentage.
Public method | Split | Split the toposolid by the given curve loops.

See Also

Toposolid Class

Create Method

[image] [image]