Revit 2024 API
TableCellStyle Properties
TableCellStyle Class See Also Send Feedback

The TableCellStyle type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | The background color of this cell in the grid view.
Public property | BorderBottomLineStyle | The element id (GraphicsStyle element) for the bottom line of the cell border.
Public property | BorderLeftLineStyle | The element id (GraphicsStyle element) for the left line of the cell border.
Public property | BorderRightLineStyle | The element id (GraphicsStyle element) for the right line of the cell border.
Public property | BorderTopLineStyle | The element id (GraphicsStyle element) for the top line of the cell border.
Public property | FontHorizontalAlignment | The horizontal alignment style of text font.
Public property | FontName | The font used for this style
Public property | FontVerticalAlignment | The vertical alignment style of text font.
Public property | IsEnabled | Gets or sets the status whether this cell is enabled.
Public property | IsFontBold | Gets or sets whether the text font is set to bold of this cell.
Public property | IsFontItalic | Gets or sets whether the text font is set to italic of this cell.
Public property | IsFontUnderline | Gets or sets whether the text font is set to Underline of this cell.
Public property | IsInactivePhaseload | Gets or sets whether this is an inactive phase load cell.
Public property | IsOverridden | Indicates if the cell is overridden or not.
Public property | IsReadOnly | Gets or sets whether this cell is read only.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SheetBackgroundColor | The background color of this cell in the sheet view.
Public property | TextColor | The text color of this cell.
Public property | TextOrientation | The orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
Public property | TextSize | The text size.

See Also

TableCellStyle Class

BackgroundColor Property

[image]