Revit 2024 API
ElementPhaseStatusFilter Constructor (ElementId, ICollection<(Of <(<'ElementOnPhaseStatus>)>)>)
ElementPhaseStatusFilter Class See Also Send Feedback
Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ICollection<ElementOnPhaseStatus> phaseStatuses
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatuses As ICollection(Of ElementOnPhaseStatus) _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ICollection<ElementOnPhaseStatus>^ phaseStatuses
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatuses
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementOnPhaseStatus >)>)>
Target statuses.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload

ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus, Boolean)

[image]