Revit 2024 API
DimensionSegment Properties
DimensionSegment Class See Also Send Feedback

The DimensionSegment type exposes the following members.

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | Below | The text shown below the segment's value.
Public property | IsLocked | Indicates if this segment is locked.
Public property | LeaderEndPosition | The position of the dimension leader end point.
Public property | Origin | The segment origin.
Public property | Prefix | The text shown before the segment's value.
Public property | Suffix | The text shown after the segment's value.
Public property | TextPosition | The position of the dimension text's drag point.
Public property | Value | The length of the segment.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class

Above Property

[image]