Revit 2024 API
Transform1D Members
Transform1D Class Constructors Methods Properties See Also Send Feedback

The Transform1D type exposes the following members.

Constructors

 | Name | Description
Public method | Transform1D(Double) | Constructs the transformation by specifying the scale only.
Public method | Transform1D(Transform1D) | The copy constructor.
Public method | Transform1D(Double, Double) | Constructs the transformation by specifying the scale and the translation.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
Public method | Dispose | Releases all resources used by the Transform1D
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the 1-dimensional point and returns the result.
Public method | OfVector | Applies the transformation to the 1-dimensional vector (a "tangent vector" on the real line) and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform
Public method | TransformParameterDomain | Performs a transform of the parameter range defined by domain, and ensures that the domain is ordered correctly.

Properties

 | Name | Description
Public property | Determinant | The determinant of this transformation.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Scale | The real number that represents the scale of this transformation.
Public property | Translation | The translational part of this transformation.

See Also

Transform1D Class

Transform1D Constructor

[image] [image]