Revit 2024 API
ParameterMap Methods
ParameterMap Class See Also Send Feedback

The ParameterMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.

See Also

ParameterMap Class

Clear Method

[image]