Revit 2024 API
GBXMLExportOptions Members
GBXMLExportOptions Class Constructors Methods Properties See Also Send Feedback

The GBXMLExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GBXMLExportOptions | Constructs a new instance of the options used to export a model in gbXML (green-building) format.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the GBXMLExportOptions

Properties

 | Name | Description
Public property | Encoding | The encoding options to go into the processing instruction for the exported gbXML file.
Public property | ExportAnalyticalSystems | Indicates if the gbXML should contain analytical system elements (e.g., Water Loop, Air System, and Zone Equipment).
Public property | ExportEnergyModelType | The energy model type from which gbXML will be exported.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

GBXMLExportOptions Class

GBXMLExportOptions Constructor

[image]