Revit 2024 API
DimensionSegment Members
DimensionSegment Class Methods Properties See Also Send Feedback

The DimensionSegment type exposes the following members.

Methods

 | Name | Description
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderPosition.
Public method | ResetTextPosition | Resets the text position of the segment to the initial position determined by its type and parameters.

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | Below | The text shown below the segment's value.
Public property | IsLocked | Indicates if this segment is locked.
Public property | LeaderEndPosition | The position of the dimension leader end point.
Public property | Origin | The segment origin.
Public property | Prefix | The text shown before the segment's value.
Public property | Suffix | The text shown after the segment's value.
Public property | TextPosition | The position of the dimension text's drag point.
Public property | Value | The length of the segment.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class

DimensionSegment Methods

[image] [image]