Revit 2024 API
ElementPhaseStatusFilter Constructor (ElementId, ICollection<(Of <(<'ElementOnPhaseStatus>)>)>, Boolean)
ElementPhaseStatusFilter Class See Also Send Feedback
Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ICollection<ElementOnPhaseStatus> phaseStatuses,
    bool inverted
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatuses As ICollection(Of ElementOnPhaseStatus), _
    inverted As Boolean _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ICollection<ElementOnPhaseStatus>^ phaseStatuses,
    bool inverted
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatuses
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementOnPhaseStatus >)>)>
Target statuses.
inverted
Type: System..::..Boolean
True to match all phase statuses other than the input statuses.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload

GetPhaseStatuses Method

[image]