Revit 2024 API
CurveUV Methods
CurveUV Class See Also Send Feedback

The CurveUV type exposes the following members.

Methods

 | Name | Description
Public method | As3DCurveInXYPlane | Returns a 3D curve lying in the XY plane in XYZ coordinates, representing the 2D curve with its UV coordinates identified with XY coordinates.
Public method | ComputeDerivatives | Computes the first derivative, the second derivative and the unit tangent vector at the specified parameter along the curve.
 | Create | Create a CurveUV from a bounded 3D Curve lying in the XY plane.
Public method | Dispose |
Public method | Evaluate | Evaluates and returns the point at the specified parameter along the curve.
Public method | GetEndParameter | Gets the raw parameter value at the start or end of this curve.
Public method | Transform | Transform this CurveUV by the given 2D affine transform if possible.

See Also

CurveUV Class

Create Method

[image]