Revit 2024 API
DatumPlane Methods
DatumPlane Class See Also Send Feedback

The DatumPlane type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view.
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view.
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated.
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not.
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes.
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view.
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane.
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders).
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents.
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views.
Public method | SetCurveInView | Sets the extents to match the curve.
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting.
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes.

See Also

DatumPlane Class

AddLeader Method

[image]