Revit 2024 API
RelinquishOptions Members
RelinquishOptions Class Constructors Methods Properties See Also Send Feedback

The RelinquishOptions type exposes the following members.

Constructors

 | Name | Description
Public method | RelinquishOptions | Constructs a new instance of RelinquishOptions.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RelinquishOptions

Properties

 | Name | Description
Public property | CheckedOutElements | True means all elements checked out by the current user should be relinquished. False means none of these are relinquished.
Public property | FamilyWorksets | True means all family worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardWorksets | True means all project standards worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | UserWorksets | True means all user-created worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | ViewWorksets | True means all view worksets owned by the current user should be relinquished. False means none of these are relinquished.

See Also

RelinquishOptions Class

RelinquishOptions Constructor

[image]