Revit 2024 API
BeamSystem Members
BeamSystem Class Methods Properties See Also Send Feedback

The BeamSystem type exposes the following members.

Methods

 | Name | Description
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
 | Create(Document, IList<(Of <<'(Curve>)>>), SketchPlane, Int32) | Creates a 2D BeamSystem with specified profile curves.
 | Create(Document, IList<(Of <<'(Curve>)>>), Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IList<(Of <<'(Curve>)>>), Level, Int32, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IList<(Of <<'(Curve>)>>), SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
 | DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Public method | GetBeamIds | Gets all the beams of the BeamSystem.

Properties

 | Name | Description
Public property | BeamSystemType | Retrieves or changes the type of the BeamSystem.
Public property | BeamType | Retrieves or changes the Beam Type of the BeamSystem.
Public property | Direction | The Direction of the BeamSystem.
Public property | Elevation | Retrieves or changes the Elevation of the BeamSystem.
Public property | LayoutRule | Retrieves or changes the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | Profile | Retrieve or set the profile of the BeamSystem.

See Also

BeamSystem Class

BeamBelongsTo Method

[image]