Revit 2024 API
NumericRevisionSettings Members
NumericRevisionSettings Class Constructors Methods Properties See Also Send Feedback

The NumericRevisionSettings type exposes the following members.

Constructors

 | Name | Description
Public method | NumericRevisionSettings()()()() | Constructs a NumericRevisionSettings with a simple, default numbering sequence.
Public method | NumericRevisionSettings(NumericRevisionSettings) | Constructs a new copy of the input NumericRevisionSettings object.
Public method | NumericRevisionSettings(Int32, String, String) | Constructs a NumericRevisionSettings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the NumericRevisionSettings
Public method | IsEqual | Determines whether a specified NumericRevisionSettings is the same as 'this'.
Public method | IsValid | Determines whether the NumericRevisionSettings object is in a valid state.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MinimumDigits | Controls the minimum number of digits for a revision number.
Public property | Prefix | The prefix string that will be prepended to the number of each revision with Numeric RevisionNumberingType.
Public property | StartNumber | The start number for the sequence.
Public property | Suffix | The suffix string that will be appended to the number of each revision with Numeric RevisionNumberingType.

See Also

NumericRevisionSettings Class

NumericRevisionSettings Constructor

[image] [image]