Revit 2024 API
NurbsSurfaceData Members
NurbsSurfaceData Class Constructors Methods Properties See Also Send Feedback

The NurbsSurfaceData type exposes the following members.

Constructors

 | Name | Description
Public method | NurbsSurfaceData | Copy constructor.

Methods

 | Name | Description
 | Create | Construct NurbsSurfaceData based on NURBS surface data, where the weights are supplied. The NURBS surface will be (piecewise) polynomial if all the weights are equal, rational if not. Note: A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1.
Public method | Dispose | Releases all resources used by the NurbsSurfaceData
Public method | GetControlPoints | Get the list of control points.
Public method | GetKnotsU | Get the list of knots in the u-direction.
Public method | GetKnotsV | Get the list of knots in the v-direction.
Public method | GetWeights | Get the list of weights.
Public method | IsValid | Check if the object contains a valid NurbsSurfaceData.

Properties

 | Name | Description
Public property | DegreeU | The degree of the spline in the u-direction.
Public property | DegreeV | The degree of the spline in the v-direction.
Public property | IsRational | Tells if the spline is rational or not. If it is true (rational), then the NURBS is a piecewise rational polynomial function. If it is false (non-rational), then the NURBS is a piecewise polynomial function.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReverseOrientation | If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.

See Also

NurbsSurfaceData Class

NurbsSurfaceData Constructor

[image]