Revit 2024 API
ImageType Methods
ImageType Class See Also Send Feedback

The ImageType type exposes the following members.

Methods

 | Name | Description
Public method | CanReload | Check whether the ImageType can be reloaded from file.
 | Create | Creates a new ImageType element and loads the image into it.
Public method | GetImage | Get the bitmap image stored in the image symbol.
Public method | Reload | Reloads the ImageType from the file found at the location specified by the Path property, using the same PageNumber and resolution.
Public method | ReloadFrom | Reloads the image in the ImageType from a new image file, and for a new PageNumber.
Public method | Unload | Unload the linked image.

See Also

ImageType Class

CanReload Method

[image]