Revit 2024 API
ExternalResourceLoadData Members
ExternalResourceLoadData Class Methods Properties See Also Send Feedback

The ExternalResourceLoadData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceLoadData
Public method | GetExternalResourceReference | Returns the ExternalResourceReference that identifies which resource should be loaded.
Public method | GetLoadContent | Returns the ExternalResourceLoadContent resulting from this load operation.
Public method | GetLoadContext | Returns an object containing information about the context of the load operation.
Public method | GetLoadRequestId | Returns the load operation GUID.

Properties

 | Name | Description
Public property | ErrorsReported | Indicates whether the IExternalResourceUIServer has reported errors for this ExternalResourceLoadData. This value can be set by the IExternalResourceUIServer in HandleLoadResourceResults().
Public property | ExternalResourceType | The ExternalResourceType for which Revit is requesting data from the server.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadStatus | The success or failure status of the load attempt.

See Also

ExternalResourceLoadData Class

ExternalResourceLoadData Methods

[image] [image]