Revit 2024 API
DefaultDivideSettings Methods
DefaultDivideSettings Class See Also Send Feedback

The DefaultDivideSettings type exposes the following members.

Methods

 | Name | Description
 | GetDefaultDivideSettings | Obtains the DefaultDivideSettings object for the specified document.
Public method | GetSurfaceDistance | Gets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.
Public method | GetSurfaceLayout | Gets the default Divided Surface layout for U or V gridlines.
Public method | GetSurfaceNumber | Gets the default Divided Surface number for a fixed number layout for U or V gridlines.
Public method | SetSurfaceDistance | Sets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.
Public method | SetSurfaceLayout | Sets the default Divided Surface layout for U or V gridlines.
Public method | SetSurfaceNumber | Sets the default Divided Surface number for a fixed number layout for U or V gridlines.

See Also

DefaultDivideSettings Class

GetDefaultDivideSettings Method

[image]