Revit 2024 API
FabricationServiceSettings Methods
FabricationServiceSettings Class See Also Send Feedback

The FabricationServiceSettings type exposes the following members.

Methods

 | Name | Description
 | GetFabricationServiceSettings | Gets the settings element in the document.
Public method | GetFluidTemperature | Gets the fluid temperature of the specified service.
Public method | GetFluidType | Gets the fluid type of the specified service.
Public method | HasValidFluidSetting | Is the service associated with a fluid type and temperature?
Public method | RemoveFluidSetting | Clears the fluid setting of the specified service if found.
Public method | SetFluidTypeAndTemperature | Sets the fluid type and temperature of the specified service.

See Also

FabricationServiceSettings Class

GetFluidTemperature Method

[image]