Revit 2024 API
Element..::..Parameter Property (Guid)
Element Class See Also Send Feedback
Retrieves a parameter from the element given a GUID for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Parameter this[
    Guid guid
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As Parameter
    Get
Visual C++
public:
property Parameter^ Parameter[Guid guid] {
    Parameter^ get (Guid guid);
}

Parameters

guid
Type: System..::..Guid
The unique id associated with the shared parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method is used to retrieve a parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

Element Class
Parameter Overload

Parameter Property (BuiltInParameter)

[image]