Revit 2024 API
CurtainGrid Members
CurtainGrid Class Methods Properties See Also Send Feedback

The CurtainGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddGridLine | Add a grid line to the curtain grid.
Public method | ChangePanelType | Change the type of a curtain panel.
Public method | GetCell | Get the specified cell located by the intersection of the grid lines.
Public method | GetCurtainCells | Gets the CurtainCells owned by this curtain grid.
Public method | GetMullionIds | Gets all ElementIds of the mullions of the curtain grid.
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.
Public method | GetPanelIds | Gets all ElementIds of the panels of the curtain grid.
Public method | GetUGridLineIds | Gets all ElementIds of grid lines in the U direction.
Public method | GetUnlockedMullionIds | Gets all ElementIds of the unlocked mullions of the curtain grid.
Public method | GetUnlockedPanelIds | Gets all ElementIds of the unlocked panels of the curtain grid.
Public method | GetVGridLineIds | Gets all ElementIds of grid lines in the V direction.

Properties

 | Name | Description
Public property | Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Public property | Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Public property | Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Public property | Grid2Angle | The angle for V grid line pattern of the curtain grid.
Public property | Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Public property | Grid2Offset | The offset for V grid line pattern of the curtain grid.
Public property | NumPanels | The number of panels.
Public property | NumULines | Get the number of grid lines in the U direction.
Public property | NumVLines | Get the number of grid lines in the V direction.

See Also

CurtainGrid Class

AddGridLine Method

[image]