Revit 2024 API
BuiltInFailures..::..DimensionFailures Properties
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback

The BuiltInFailures..::..DimensionFailures type exposes the following members.

Properties

Name | Description
AngularDimensionRegenFailed | Can't form Angular Dimension.
ArcAlignmentRegenFailed | Can't form arc alignment.
ArcLengthDimensionNoReferencesOnArc | None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.
ArcLengthDimensionReferencesNotIntersect | One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.
AssocpropNeedJog | Need to add jog in order to satisfy constraints
CannotConstrainBasePointAlignments | Alignments to base points cannot be constrained.
CannotConstrainBasePointDimensions | Dimensions to base points cannot be constrained.
CannotCreateDimensionNotParallel | Can't create dimension. Highlighted references are not parallel to first selection.
CannotDragWitnessLine | Moving the Witness Line conflicts with other Constraints in the Sketch.
CannotLockThisDimension | Can't lock this Dimension because it breaks formulas
CannotToggleDimensionEquality | Toggling the dimension's equality constraint would overconstrain the sketch.
ChangeDimensionSegmentFailed | Can't change dimension segment to this value.
ChangeSpotElevationFailed | Can't change Spot Elevation to the desired value.
DifferentLabelsInMultiSegmentDim | All segments of a multi-segment dimension must be labeled the same.
DimensionOverconstrained | The Dimension would overconstrain the Sketch.
DimensionOverconstrainedError | The Dimension would overconstrain the Sketch.
DimensionOverrideNearByIsLost | The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]
DimensionPerpendicularToView | The Dimension is perpendicular to the current view, and no longer valid.
DimensionReferencesInvalid | One or more dimension references are or have become invalid.
DimensionUnequaled | Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.
DimensionUnlocked | Dimension had to be un-EQed in order to remove sketch over-constraining.
DimensionUnlockedAndUnequaled | Dimension had to be unlocked in order to remove sketch over-constraining.
EqualityConstraintsUnsatisfied | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
EqualityConstraintsUnsatisfiedWarn | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
ForbiddenGroupConstraint | You may not create sketch or family constraints between group members and elements which are not members of the same group.
LabelingDimWithGroupReferences | Labeled constraints cannot participate in groups.
LabelingMultiSegmentWithReporting | Cannot label multi-segment dimensions with reporting parameters.
LabelOverconstrained | Labeling this dimension would overconstrain the sketch.
LinearConstraintBadDirection | Bad direction vector in dimension element.
LinearConstraintNotParallel | The References of the highlighted Dimension are no longer parallel.
LinearDimensionReferenceNotOrthogonalToView | The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.
LockOverconstrained | Locking this dimension would overconstrain the sketch.
LockOverconstrainedAlignment | Locking this alignment would overconstrain the sketch.
LooseLabeledDimensionRegenFailure | Failed to Regenerate Family
MoreThanOneDimsLabelToOneReportingParameter | Reporting parameters can only exist on a single dimension/constraint.
NoConstraintsInProperSketch | You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.
NoConstraintsToLinks | Constraints may not be created to linked instances using Shared Locations.
RadialDimensionCannotProjectToArc | Cannot form radial dimension.
RadialDimensionChangeRadiusFailed | Can't change radius.
RegenConstraintUnsatisfied | Constraints are not satisfied
RegenConstraintUnsatisfiedWarn | Constraints are not satisfied
ReportingParamAlreadyLabelsToAnotherDim | Cannot label multi-dimensions to one reporting parameter.
SomeDimensionsLostOnPaste | Some Dimensions were not copied because some References were lost.
SomeDimensionsLostWitnessLines | Some Dimensions lost some of their References on paste.
SomeSpotDimensionsLostOnPaste | Some Spot Dimensions were not copied because some References were lost.
SpotDimensionFloatingPointError | Some spot dimensions contain invalid floating-point values.
SpotDimensionFormerSetMoribundCall | One or more Spot Dimension references are no longer valid.
SpotDimensionReferencesNoLongerHorizontal | One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.
SpotElevationLostEdgeReferences | Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.
SpotElevationMissesReference | Spot Dimension does not lie on its reference.
SpotSlopeReferenceIsVertical | The highlighted Spot Slope references an element that is vertical.
SpotSlopeReferencePointIsSingular | The highlighted Spot Slope references an element point that is singular.
UnavailableDimensionHostReference | A dimension reference could not be resolved on the host element.
UnstableConstraintInFamily | Constraints between geometry in the family can behave unpredictably on parameter modification. To make the family reliable, constrain geometry to levels, reference planes, or reference lines.
WrongConstraintInGridChainSketch | Curve in a GridChain sketch cannot be constrained to a sub-grid
WrongConstraintInJoistSystemSketch | Structural Beam System sketch can't be constrained to its beam.
WrongConstraintInSkeletonSketch | Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.
WrongConstraintInTrussSketch | Structural Truss sketch can't be constrained to its members.

See Also

BuiltInFailures..::..DimensionFailures Class

AngularDimensionRegenFailed Property

[image]