Revit 2024 API
GenericForm Members
GenericForm Class Methods Properties See Also Send Feedback

The GenericForm type exposes the following members.

Methods

 | Name | Description
Public method | GetVisibility | Gets the visibility for the generic form.
Public method | SetVisibility | Sets the visibility for the generic form.

Properties

 | Name | Description
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | Name | Get and Set the Name property (Overrides Element..::..Name.)
Public property | Subcategory | The subcategory.
Public property | Visible | The visibility of the GenericForm.

See Also

GenericForm Class

GenericForm Methods

[image] [image]