Revit 2024 API
FabricationPart Methods
FabricationPart Class See Also Send Feedback

The FabricationPart type exposes the following members.

Methods

 | Name | Description
Public method | AddPartCustomData | Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.
Public method | AdjustEndLength | Adjusts the length for the specified connector.
 | AlignPartByConnector | Align the part by its connector to a point and rotation in free space.
 | AlignPartByConnectors | Moves fabrication part by one of its connectors and aligns it to another connector.
 | AlignPartByConnectorToConnector | Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method.
 | AlignPartByInsertionPoint | Align the part by its insertion point to a point and rotation in free space.
 | AlignPartByInsertionPointAndCutInToStraight | Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.
Public method | CanAdjustEndLength | Checks if the end of fabrication part can be adjusted.
Public method | CanASlopeBeApplied | This will test if a slope can be applied to the part and maintain connections with any connected parts.
Public method | CanFlipPart | Validates if the fabrication part is one of the supported fabrication part types that can be flipped.
Public method | CanSplitStraight | Validates if the straight can be split into two at the passed in point.
 | ConnectAndCouple | Makes a connection between the specified connectors and adds coupling if necessary.
 | Create(Document, FabricationItemFile, ElementId) | Creates a fabrication part element from a fabrication item file.
 | Create(Document, FabricationServiceButton, Int32, ElementId) | Creates a fabrication part element based on button.
 | Create(Document, FabricationServiceButton, Double, Double, ElementId) | Creates a fabrication part element based on button and size.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId) | Creates a free placed hanger.
 | CreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
Public method | Flip | Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.
Public method | GetCalculatedDimensionValue | Gets the calculated dimension value.
Public method | GetDimensionCalculatedOptions | Gets the calculated options of the fabrication dimension.
Public method | GetDimensions | Gets all fabrication dimensions.
Public method | GetDimensionValue | Gets the value of the fabrication dimension, returns value in Revit internal units.
Public method | GetHostedInfo | Gets the fabrication hosted element information.
Public method | GetInsulationLiningGeometry | Gets insulation and lining geometry for this fabrication part.
Public method | GetPartAncillaryUsage | Gets a list of all ancillary usage information for the part.
Public method | GetPartCustomDataInteger | Get custom data integer value for the specified custom data.
Public method | GetPartCustomDataReal | Get custom data real value for the specified custom data.
Public method | GetPartCustomDataText | Get custom data text for the specified custom data.
Public method | GetProductListEntryCount | Gets the number of product entries for this part.
Public method | GetProductListEntryName | Gets the specified product list entry name.
Public method | GetRodInfo | Gets the fabrication rod information.
Public method | GetTransform | Gets the transformation matrix of the fabrication part element.
Public method | GetVersionHistory | Gets a history of version change information about the current part.
Public method | HasCustomData | Check if fabrication part contains custom data already.
Public method | HasNoConnections | Checks to see if all the fabrication part's connectors are open.
Public method | IsAHanger | Checks whether it is a hanger.
Public method | IsAStraight | Checks whether it is a straight part.
Public method | IsATap | Checks if it is any sort of tap.
Public method | IsDimensionCalculated | Checks if the fabrication dimension is calculated.
Public method | IsProductList | Gets whether or not the fabrication part is a product list.
Public method | IsProductListEntryCompatibleSize | Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.
Public method | IsSameAs | Compare this fabrication part with the part passed and checks the pattern dimensions and options. A list of fields that can be ignored in the comparison check can be specified.
 | OptimizeLengths | Optimizes the length fabrication straight parts.
 | PlaceAsTap | Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector.
 | PlaceFittingAsCutIn | Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.
Public method | RemovePartCustomData | Remove custom data from the fabrication part.
 | Reposition | Repositions the fabrication straight part to another end of the run.
 | RotateConnectedPartByConnector | Rotates a connected fabrication part around the axis of the specified connector.
 | RotateConnectedTap | Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.
 | SaveAsFabricationJob | Save fabrication parts to an MEP job that can be opened in the fabrication software.
Public method | SetCalculatedDimensionValue | Sets the calculated dimension value.
Public method | SetDimensionValue | Sets the fabrication dimension value. The value is in Revit internal units.
Public method | SetPartCustomDataInteger | Set the custom data integer value for the specified custom data.
Public method | SetPartCustomDataReal | Set the custom data real value for the specified custom data.
Public method | SetPartCustomDataText | Set the custom data real value for the specified custom data.
Public method | SetPositionByEnd | Positions the connector of the fabrication part element by the passed point.
Public method | SplitStraight(XYZ) | Splits the straight into two at the passed in point.
Public method | SplitStraight(Document, ElementId, XYZ) | Splits the straight into two at the passed in point.
 | StretchAndFit | Stretch the fabrication part from the specified connector and fit to the target routing end.

See Also

FabricationPart Class

AddPartCustomData Method

[image]