Revit 2024 API
DirectShapeLibrary..::..AddDefinition Method
DirectShapeLibrary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddDefinition(String, GeometryObject) | Add a definition to be reused by instances. A definition is a single geometry object.
Public method | AddDefinition(String, IList<(Of <<'(GeometryObject>)>>)) | Add a definition to be reused by instances. A definition is a collection of geometry objects.

See Also

DirectShapeLibrary Class
DirectShapeLibrary Members

AddDefinition Method (String, GeometryObject)

[image]