Revit 2024 API
ViewSheet..::..SheetNumber Property
ViewSheet Class See Also Send Feedback
The sheet number of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string SheetNumber { get; set; }
Visual Basic
Public Property SheetNumber As String
    Get
    Set
Visual C++
public:
property String^ SheetNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: sheetNumber is an empty string or contains only whitespace. -or- When setting this property: sheetNumber cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- When setting this property: Sheet number is already in use.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ViewSheet Class

ViewSheetSet Class

[image]