Revit 2024 API
BuiltInFailures..::..SweepFailures Properties
BuiltInFailures..::..SweepFailures Class See Also Send Feedback

The BuiltInFailures..::..SweepFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.
WallSweepInconsistent | The model contains corrupt elements. Delete the corrupt elements to proceed or cancel the action without deleting the elements.

See Also

BuiltInFailures..::..SweepFailures Class

CannotDrawSweep Property

[image]