Revit 2024 API
FamilySymbolProfile Members
FamilySymbolProfile Class Methods Properties See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | Angle | The angle of the rotation of the profile in radians.
Public property | IsFlipped | Indicates if the symbol profile is flipped or not.
Public property | Profile | Returns the family symbol of the profile.
Public property | XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
Public property | YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.

See Also

FamilySymbolProfile Class

FamilySymbolProfile Methods

[image] [image]