Revit 2024 API
FamilyThermalProperties Properties
FamilyThermalProperties Class See Also Send Feedback

The FamilyThermalProperties type exposes the following members.

Properties

 | Name | Description
Public property | AnalyticConstructionName | The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public property | AnalyticConstructionTypeId | The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The units are watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient.
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The units are meter-squared kelvin per watt ((m^2*K)/Watt).
Public property | VisualLightTransmittance | The visual light transmittance.

See Also

FamilyThermalProperties Class

AnalyticConstructionName Property

[image]