Revit 2024 API
LogicalOrFilter Constructor (IList<(Of <(<'ElementFilter>)>)>)
LogicalOrFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public LogicalOrFilter(
    IList<ElementFilter> filters
)
Visual Basic
Public Sub New ( _
    filters As IList(Of ElementFilter) _
)
Visual C++
public:
LogicalOrFilter(
    IList<ElementFilter^>^ filters
)

Parameters

filters
Type: System.Collections.Generic..::..IList<(Of <(<' ElementFilter >)>)>
A collection of input filters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filter collection is empty, or contains invalid inputs.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LogicalOrFilter Class
LogicalOrFilter Overload

LogicalOrFilter Constructor (ElementFilter, ElementFilter)

[image]