Revit 2024 API
CategorySet Members
CategorySet Class Constructors Methods Properties See Also Send Feedback

The CategorySet type exposes the following members.

Constructors

 | Name | Description
Public method | CategorySet | Initializes a new instance of the CategorySet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of a category within the set.
Public method | Erase | Removes a specified category from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified category into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of categories that are in the set.

See Also

CategorySet Class

CategorySet Constructor

[image]