Revit 2024 API
IndependentTag Methods
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Methods

 | Name | Description
Public method | AddReferences | Adds the provided list of references to the tag's list of references.
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be changed.
 | Create(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) | Places a tag on an element or subelement.
 | Create(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) | Places a tag on an element or subelement.
Public method | GetLeaderElbow | Returns the position of the elbow of the tag's leader that points to specified reference. Position of leader's elbow.
Public method | GetLeaderEnd | Returns the end position of the tag's leader that points to specified reference.
Public method | GetTaggedElementIds | Returns a set of LinkElementId for all tagged elements, if any. A LinkElementId will be provided for each subelement that is being referenced by the tag.
Public method | GetTaggedLocalElementIds | Returns a set of IDs for all tagged local elements, if any. A local element ID will be provided for each subelement that is being referenced by the tag. Set of all the element ids in the local file. For each subelement a local element id will be provided.
Public method | GetTaggedLocalElements | Get the tagged local elements, if any. An Element will be provided for each subelement that is being referenced by the tag.
Public method | GetTaggedReferences | Get the host references of the tag. An array of all the tagged references.
Public method | HasLeaderElbow | Whether the tag's leader that points to the reference has an elbow point or not.
Public method | HasTagBehavior | Checks if the IndependentTag has a tag behavior.
Public method | IsLeaderVisible | Returns if leader that points to specified reference is visible or not.
Public method | IsTaggedOnSubelement | Returns true if the any of the tagged references is a subelement.
Public method | RemoveReferences | Removes the provided list of references from the tag's list of references.
Public method | SetIsLeaderVisible | Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders.
Public method | SetLeaderElbow | Set the position of the elbow of the tag's leader that points to specified reference. If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders.
Public method | SetLeaderEnd | Set the end position of the tag's leader that points to specified reference.

See Also

IndependentTag Class

AddReferences Method

[image]