Revit 2024 API
BuiltInFailures..::..ArrayFailures Properties
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback

The BuiltInFailures..::..ArrayFailures type exposes the following members.

Properties

Name | Description
ArrayingNotSupportedForElements | Arraying is not currently supported for the selected elements.
ArrayMixedModAndViewSpecElemsCorruption | Unable to array this mixture of modeling and view specific elements.
ArrayMixedModAndViewSpecElemsWarning | You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.
CannotCreateArraySelectionIsGrouped | Can't create an array because the selection cannot be grouped.
ConstraintsNotSatisfied | Constraints are not satisfied
CouldntFindNewHostsForElements | Couldn't find new hosts for elements in array.
IdenticalGeometryCopiesInArray | This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.
RadiusTooSmall | Radius is too small.

See Also

BuiltInFailures..::..ArrayFailures Class

ArrayingNotSupportedForElements Property

[image]