Revit 2024 API
FilteredWorksetCollector Members
FilteredWorksetCollector Class Constructors Methods Properties See Also Send Feedback

The FilteredWorksetCollector type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredWorksetCollector | Constructs a new FilteredWorksetCollector that will search and filter the set of worksets in a document.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetCollector
Public method | FirstWorkset | Returns the first workset to pass the filter(s).
Public method | FirstWorksetId | Returns the id of the first workset to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetWorksetIdIterator | Returns a FilteredWorksetIdIterator to the worksets passing the current filter.
Public method | GetWorksetIterator | Returns a FilteredWorksetIterator to the worksets passing the current filter.
Public method | OfKind | Applies a WorksetKindFilter to the collector.
Public method | ToWorksetIds | Returns the complete set of workset ids that pass the filter(s).
Public method | ToWorksets | Returns the complete set of worksets that pass the filter(s).
Public method | WherePasses | Applies a workset filter to the collector.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredWorksetCollector Class

FilteredWorksetCollector Constructor

[image]