Revit 2024 API
TransmissionData Methods
TransmissionData Class See Also Send Feedback

The TransmissionData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
 | DocumentIsNotTransmitted | Determines whether the document at a given file location is not transmitted.
Public method | GetAllExternalFileReferenceIds | Gets the ids of all ExternalFileReferences.
Public method | GetDesiredReferenceData | Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.
Public method | GetLastSavedReferenceData | Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.
 | IsDocumentTransmitted | Determines whether the document at a given file location is transmitted.
 | ReadTransmissionData | Reads the TransmissionData associated with the file at the given location.
Public method | SetDesiredReferenceData | Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.
 | WriteTransmissionData | Writes the given TransmissionData into the Revit file at the given location.

See Also

TransmissionData Class

Dispose Method

[image]