Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures Properties
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback

The BuiltInFailures..::..StructuralConnectionFailures type exposes the following members.

Properties

Name | Description
StructuralConnectionCannotGenerate | Could not create Structural Connection Handler
StructuralConnectionCannotReplaceRefs | Structural Connection cannot replace elements
StructuralConnectionForbiddenElementInGroup | Fabrication element can not be a group member.
StructuralConnectionNoSingleRef | Summary: Structural Connection Handler lost connected element.
StructuralConnectionNotEnoughRefs | Structural Connection Handler cannot connect fewer than two elements.
StructuralConnectionSetOfRefsChanged | The set of input elements was changed and the connection has been adjusted.
StructuralConnectionTooFarNotEnoughRefs | Structural Connection Handler cannot connect too far elements
StructuralConnectionTooFarRefs | Structural Connection Handler cannot connect too far elements
StructuralConnectionTypeChangedToGeneric | Structural Connection had an inappropriate type, which has been changed to 'Generic Connection'.
StructuralConnectionTypeInfoNotAvailable | There is no add-on installed which supports Structural Connection type.
StructuralConnectionWrongType | Structural Connection has an inappropriate type assigned.
StructuralSectionHasIncompleteDefinition | Structural Section has incomplete definition

See Also

BuiltInFailures..::..StructuralConnectionFailures Class

StructuralConnectionCannotGenerate Property

[image]