Revit 2024 API
BuiltInFailures..::..WallFailures Properties
BuiltInFailures..::..WallFailures Class See Also Send Feedback

The BuiltInFailures..::..WallFailures type exposes the following members.

Properties

Name | Description
CannotChangeSubwall | Changing the type of a subwall is not allowed. Edit the stacked wall type instead.
CannotChangeTypeOfOldCurtainPanel | Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.
CannotMaintainKeyReference | Can't maintain the position of the Location Line in this Wall.
CannotMirrorWallPanel | Cannot mirror wall panels.
CannotRedoFaceBased | Faces defining this Element cannot be reacquired.
CannotRedoFaceBasedWarn | Faces defining this Element cannot be reacquired.
CannotRedoFaceRoof | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotSlantStackedWallError | Cannot slant a stacked wall with rectangular openings. Please delete the openings first.
CannotSplitJoinHostsInplaceFamilies | Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.
CannotSplitVerticallyCompoundWall | Can't divide Wall's face to assign different materials to a vertically compound Wall.
CannotToSplitWallPanels | Unable to split wall panel(s).
CannotUpdateWallPanel | Unable to update wall panel.
ChangingWallsweepType | This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.
ConstrainedToWall | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ConstrainedToWallError | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ContFootingCannotJoin | Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.
ContFootingRadiusTooSmall | Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.
CurtainOrStackedWallDisallowedForCrossSectionType | Curtain wall types and Stacked wall types are not allowed for this wall's cross-section type.
DisallowedPathCurve | Cannot create stacked elliptical wall with offsets.
EmbeddedButShouldNotBe | Conditions for wall embedding are no longer satisfied.
ExtrudedWallDisallowedForCrossSectionType | Edited profiles are not allowed for this wall's cross-section type.
FaceBecameVertical | Face defining this non-vertical Wall is vertical.
FaceIsNoGoodForWall | Defining face is not suitable for walls.
FaceIsNoLongerVertical | Face defining this vertical Wall is no longer vertical.
FaceWallBadType | Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.
FaceWallComplexType | Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.
FaceWallFailedToMake | Can't make Face Wall shape.
FaceWallMissingFace | No picked face found.
FailedConvertWallToPanel | Unable to convert wall to panel.
FailedToChangeInstSymbol | Failed to change symbol of instance.
FailedToStoreSideFace | Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.
InvalidBaseConstraintForLevel | Base Constraint is invalid for the Level.
InvalidCompoundStructure | Invalid compound structure.
InvalidTargetPosition | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTargetPositionError | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTopConstraintForLevel | Top Constraint is invalid for the Level.
LostEditsJoinsRedoFaceBased | Previous edits and /or wall joins will not be preserved on this operation.
ParameterChangeNotAffectingGeometry | Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.
RecursionParameterIgnored | Parameter-defined type of curtain panels defined in a circular way and will be ignored.
RemapConstrainLocationLine | Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press "Unconstrain" to remove the constraint rather than transferring it.
ShorterThanMinWall | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallError | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallFailure | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShouldAdjustWallParameters | The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.
StackedWallNeedsUnjoin | A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.
SubwallOfStackedWallDeleted | This stacked wall will be deleted because a subwall could not be created.
TaperedWallAnglesControlledByType | Cannot set angles on a tapered wall which has angles controlled by the type.
TooShortStackedWall | Stacked wall instance is too short.
UnableToCreateWallForPanel | Unable to create wall for curtain wall panel.
UnableToDeleteWallForPanel | Unable to delete curtain panel wall.
UnjoinOnEditWallChange | Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]
VerticalLayerExtensionFailure | Cannot extend layer(s) of the highlighted vertically compound wall.
VerticalLayerExtensionFailureError | Cannot extend layer(s) of the highlighted vertically compound wall.
WallCutoutForInsertionFailure | Can't cut wall for inserted objects
WallLacksCurve | Wall does not have both a curve driver and a curve!!!!
WallNegativeHeight | The top of the Wall is lower than the base of the Wall.
WallSettingsChanged | Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])
WallTypeIncompatibleWithTapered | This wall's type is not compatible with the Tapered cross-section. Tapered walls require a variable thickness layer.

See Also

BuiltInFailures..::..WallFailures Class

CannotChangeSubwall Property

[image]