Revit 2024 API
MEPCalculationServerInfo Members
MEPCalculationServerInfo Class Constructors Methods Properties See Also Send Feedback

The MEPCalculationServerInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MEPCalculationServerInfo()()()() | Constructs a new MEPCalculationServerInfo with default settings.
Public method | MEPCalculationServerInfo(IExternalServer) | Create a new MEPCalculationServerInfo by an external server.
Public method | MEPCalculationServerInfo(MEPCalculationServerInfo) | Constructs a new copy of the input MEPCalculationServerInfo object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MEPCalculationServerInfo
 | GetMEPCalculationServerInfo | Gets a MEPCalculationServerInfo by family instance.

Properties

 | Name | Description
Public property | Description | The Description of the server.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | PipeUseDefinitionOnTypeGUID | The guid value ("3BF616F9-6B98-4A21-80FF-DA1120C8F6D6") of Use Definition On Type. It is not a server id, but a guid to tell if the loss method is "Use Definition On Type" or not. If the loss method is "Use Definition On Type", we use the loss method of the family type to calculate.
Public property | ServerId | The Id of the server.
Public property | ServerName | The Name of the server.

See Also

MEPCalculationServerInfo Class

MEPCalculationServerInfo Constructor

[image] [image]