Revit 2024 API
SpatialElementFromToCalculationPoints Members
SpatialElementFromToCalculationPoints Class Methods Properties See Also Send Feedback

The SpatialElementFromToCalculationPoints type exposes the following members.

Methods

 | Name | Description
Public method | Flip | flip the direction of the "from" and "to" points
Public method | IsAcceptableFromPosition | Checks whether a given "from" position is valid.
Public method | IsAcceptableToPosition | Checks whether a given "to" position is valid.
Public method | MakeFromPositionAcceptable | This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.
Public method | MakeToPositionAcceptable | This function takes a potential "to" point and converts it to be a similar point on the opposite side of the family's host from the "from" point if necessary.

Properties

 | Name | Description
Public property | FromPosition | The "from" position of spatial element connecting calculation point.
Public property | ToPosition | The "to" position of spatial element connecting calculation point.

See Also

SpatialElementFromToCalculationPoints Class

SpatialElementFromToCalculationPoints Methods

[image] [image]