Revit 2024 API
Face Methods
Face Class See Also Send Feedback

The Face type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point.
Public method | ComputeNormal | Returns the normal vector for the face at the given point.
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point.
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.
Public method | GetBoundingBox | Returns the UV bounding box of the face.
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face.
Public method | GetSurface | Returns a copy of this face's surface.
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location.
Public method | Project | Projects the specified point on the face.
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.

See Also

Face Class

ComputeDerivatives Method

[image]