Revit 2024 API
ElementParameterFilter Members
ElementParameterFilter Class Constructors Methods Properties See Also Send Feedback

The ElementParameterFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementParameterFilter(FilterRule) | Constructs a new instance of an ElementParameterFilter from a single rule.
Public method | ElementParameterFilter(IList<(Of <<'(FilterRule>)>>)) | Constructs a new instance of an ElementParameterFilter from a set of rules.
Public method | ElementParameterFilter(FilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public method | ElementParameterFilter(IList<(Of <<'(FilterRule>)>>), Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

Methods

 | Name | Description
Public method | GetRules | Returns the set of rules contained in this filter.

Properties

 | Name | Description

See Also

ElementParameterFilter Class

ElementParameterFilter Constructor

[image] [image]