Revit 2024 API
ElementFilter Members
ElementFilter Class Methods Properties See Also Send Feedback

The ElementFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ElementFilter
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ElementFilter Class

ElementFilter Methods

[image] [image]