Revit 2024 API
BaseExportOptions Members
BaseExportOptions Class Methods Properties See Also Send Feedback

The BaseExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BaseExportOptions
Public method | GetExportFontTable | Gets font table.
Public method | GetExportLayerTable | Gets the layer table.
Public method | GetExportLinetypeTable | Gets a copy of the line type table.
Public method | GetExportPatternTable | Gets a copy of the pattern table.
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of export options.
Public method | SetExportFontTable | Sets font table to option.
Public method | SetExportLayerTable | Sets layer table back to option
Public method | SetExportLinetypeTable | Sets the line type table to use during export.
Public method | SetExportPatternTable | Sets the pattern table to use during export.

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name.
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false.
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false.
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity.

See Also

BaseExportOptions Class

BaseExportOptions Methods

[image] [image]