Revit 2024 API
Solid Methods
Solid Class See Also Send Feedback

The Solid type exposes the following members.

Methods

 | Name | Description
Public method | ComputeCentroid | Returns the Centroid of this solid.
Public method | GetBoundingBox | Retrieves a box that circumscribes the solid geometry.
Public method | IntersectWithCurve | Calculates and returns the intersection between a curve and this solid.

See Also

Solid Class

ComputeCentroid Method

[image]