Revit 2024 API
ProjectLocation Methods
ProjectLocation Class See Also Send Feedback

The ProjectLocation type exposes the following members.

Methods

 | Name | Description
 | Create | Create an instance of ProjectLocation in the document.
Public method | Duplicate | Generate a copy of this project location with the specified name.
Public method | GetProjectPosition | Gets the coordinates of a point in the ProjectLocation's coordinate system.
Public method | GetSiteLocation | Gets the site location to which this project location refers.
 | IsProjectLocationNameUnique | Verifies that there is no existing ProjectLocation with the given name belonging to the given SiteLocation.
Public method | SetProjectPosition | Sets the coordinates of a point in the ProjectLocation's coordinate system.

See Also

ProjectLocation Class

Create Method

[image]