Revit 2024 API
BuiltInFailures..::..ElectricalFailures Properties
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback

The BuiltInFailures..::..ElectricalFailures type exposes the following members.

Properties

Name | Description
AllSlotsOnPanelOccupied | All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.
BankDistanceSmallerThanDiameter | The distance value is smaller than the conduit diameter, please enter a larger value
CableTrayModified | The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.
CannotAddMorePolesToCircuit | Empty slots are unavailable to hold the number of poles you specified for this spare. \nTo add more poles to this spare, you must free up slots by moving the circuits below the spare.
CannotAssignSecondaryDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].
CannotConnectDifferentDesignOptsObjects | Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.
CannotCreatePanelScheduleDuetoNoDefaultTemplate | A panel schedule cannot be created for these panels. A default panel schedule template must be assigned for this template type.
CannotRemoveMembersInCircuitHavingParent | You have selected elements that are connected to a Panel object in a Circuit. These elements cannot be removed from the Circuit.
CircuitOverload | Total connected load for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).
CircuitsOverlapAndDeleteSpareSpace | More than one Spare/Space falls onto the same slot. These Spares/Spaces will be deleted.
CircuitsOverlapDisconnectCircuits | More than one circuit falls onto the same slot. These circuits will be disconnected.
ConduitModified | The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.
ElementsBelongToOtherCircuit | You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected cannot be added to this Circuit.
FamilyMismatchCircuit | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
FeedThroughLugsIsDisabled | The feed through lugs option is unchecked.
FeedThroughLugsIsNotEnabledAndBindFormulaInFamily | Can't change connection type to Feed Through Lugs because Feed Through Lugs is unchecked. Enable Feed Through Lugs with related formula in family editor the Feed Through Lugs is mapped to. Select the panel -> Edit Family -> Family Types.
FeedThroughLugsIsNotEnabledAndBindGlobalParam | Can't change connection type to Feed Through Lugs because Feed Through Lugs is not enabled. Enable Feed Through Lugs by enabling the global parameter that Feed Through Lugs is mapping. Click Manage tab -> Settings panel -> Global Parameters.
FeedThroughLugsIsOccupied | The feed through lugs is in use by circuit [Element].
FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits | The feed through lugs is occupied, so other circuits connected with feed through lugs will be disconnected from this panel [Panel Name].
InvalidApparentPowerDensity | The Apparent Power Density is invalid. Edit the Power Density and/or Power Factor to recalculate the Apparent Power Density.
InvalidNumberOfCircuitValueForSwitchPanel | The number of circuits on the switchboard currently exceeds the value you entered. Reduce the number of circuits on the equipment before changing this value.
InvalidNumwiresSinglephase | Invalid number of wires for single phase, only 2 and 3 are valid.
InvalidPathOfParallelConduits | Invalid path of parallel conduits
InvalidSpareSpace | The number of poles for a spare/space in a single phase, [wire] wires panel cannot exceed [value].
MaximumNumberOfPolesExceeded | You cannot add more poles to this spare, as doing so would exceed the maximum number of poles set for this equipment.
MismatchConnectorDistSysToCircuit | Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.
MismatchNmbAssignedDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].
MismatchNmbOfPolesToCircuit | Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.
MismatchPoleBrakesSlotsNumbers | The number of pole breakers may not be less than the number of occupied slots.
MismatchVoltageLineToLine | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).
MismatchVoltageToCircuit | Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.
MissingOrInvalidWireSizeTable | Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.
NoAvailableMatchingConnector | Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.
NotAllowedCableTrayConduitRotation | Don't allow to rotate a horizontal cable tray/conduit like this
NotEnoughAvailSlotsAndLugsOnPanel | You can't connect to panel [Panel Name] because there aren't enough slots and Feed Through Lugs is occupied. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or you can disconnect existing Feed Through Lugs connection.
NotEnoughAvailSlotsAndLugsOnSwitchPanel | You can't connect to switchboard [Panel Name] because there aren't enough space and circuit [Circuit Name] is set to Feed Through Lugs. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers or you can disconnect circuit and select Feed Through Lugs again.
NotEnoughAvailSlotsOnPanel | You can't change the connection type to Breakers connect to panel [Panel Name] because there aren't enough slots. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or open the panel schedule and manually reshuffle non - consecutive slots.
NotEnoughRoomForParallelConduits | Due to changes in elevation, there is not enough room to generate all of the parallel conduits. As a result, some conduit segments have not been generated.
NotEnoughRoomForParallelPipes | Due to changes in elevation, there is not enough room to generate all of the parallel pipes. As a result, some pipe segments have not been generated.
NotEnoughSlotsOnlyLugAvailable | There aren't enough slots on panel [Panel Name], so the circuit will connect through Feed Through Lugs.
NotEnoughSlotsOnlyLugAvailableForSwitchPanel | There aren't enough space on switchboard [Panel Name], so the circuit will connect through Feed Through Lugs.
NotPositiveBendRadius | The value you entered for the bend radius is zero or a negative value. Enter a positive value.
NotSupportConcentricBend | Conduit with Fittings do not support Concentric Bend Radius, the bend radius of the conduit fittings will be same.
NumberOfCircuitFullOnSwitchPanel | You can't change the connection type to Breakers and connect to switchboard [Panel Name] because there aren't enough space. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers.
ObjsDemolished | Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.
PanelMismatchCircuitType | Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.
PanelMismatchDistSysWhenCircuitAssigned | The selected circuit was added to panel [Element], but the distribution system for the panel does not match the power connector definition on the panel.
ReplaceSpareSpaceOnPanelBoard | Need to replace spare or space on panelboard.
ReplaceSpareSpaceOnSwitchBoard | Need to replace spare or space on switchboard.
SelectedElementsArePartOfOtherCircuit | You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.
SmallBendRadius | The value you entered for the bend radius for conduit is too small. Enter a larger value.
UnsignedCircuit | Circuit is not assigned to a panel
VoltageIsOutOfRange | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."
WireMaxSizeNonexistent | Cannot find max size in current wire type's material table.

See Also

BuiltInFailures..::..ElectricalFailures Class

AllSlotsOnPanelOccupied Property

[image]