Revit 2024 API
SolidOptions Members
SolidOptions Class Constructors Methods Properties See Also Send Feedback

The SolidOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SolidOptions | Creates a new SolidOptions class with material and graphics style settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SolidOptions

Properties

 | Name | Description
Public property | ExtraFaceAndEdgeHistoryKey | Optional extra key used to create face and edge histories for the Solid. If extraFaceAndEdgeHistoryKey is higher than -1, the Solid's face and edge histories will be created depending on the geometry generation of the Solid.
Public property | GraphicsStyleId | Defines the graphics style id for the Solid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Defines the material id for the Solid.

See Also

SolidOptions Class

SolidOptions Constructor

[image]