Revit 2024 API
ReferenceIntersector..::..GetFilter Method
ReferenceIntersector Class See Also Send Feedback
Gets the ElementFilter used in intersection testing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementFilter GetFilter()
Visual Basic
Public Function GetFilter As ElementFilter
Visual C++
public:
ElementFilter^ GetFilter()

Return Value

The ElementFilter, or nullNothingnullptra null reference (Nothing in Visual Basic) if no filter is set.

See Also

ReferenceIntersector Class

SetTargetElementIds Method

[image]