Revit 2024 API
ShapeImporter Members
ShapeImporter Class Constructors Methods Properties See Also Send Feedback

The ShapeImporter type exposes the following members.

Constructors

 | Name | Description
Public method | ShapeImporter | Default constructor. Initializes an instance of ShapeImporter that will automatically recognize the file format from its extension (ShapeImporterSourceFormat.Auto).

Methods

 | Name | Description
Public method | Convert | Converts the geometry stored in the external format into a collection of Revit geometry objects.
Public method | Dispose | Releases all resources used by the ShapeImporter
 | IsServiceAvailable | Checks whether the data conversion service is available.
Public method | SetDefaultLengthUnit | Sets the length unit to be used when the input is a unitless SAT file.

Properties

 | Name | Description
Public property | DefaultLengthUnit | The length unit to be used if not specified when the input is a unitless SAT file.
Public property | InputFormat | The format of the incoming data.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ShapeImporter Class

ShapeImporter Constructor

[image]