Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures Properties
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback

The BuiltInFailures..::..CurtainGridFamilyFailures type exposes the following members.

Properties

Name | Description
AllMullionsAreTooShort | The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.
CannotCreateCornerMullionDueAngle | Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.
CannotCreateCurtainPanelCorruption | Can't create Curtain Panel. A Panel or a Mullion is probably too small.
CannotCreateCurtainPanelError |
CannotCreateCurtainPanelInOpeningCorruption | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateCurtainPanelInOpeningWarning |
CannotGenerateAllNecessaryElements | Unable to regenerate all necessary elements.
CannotPlaceSystemMullionFamilyOnCurtainWall | Can't place System Mullion Family on this Curtain Wall.
CannotPlaceSystemPanelsInOldArcedCurtainWalls | Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.
CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion | Corner Mullion overlaps Mullion placed on neighboring Curtain region.
CornerMullionsNeighborsMustBeTangent | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainPanelNotBelongsToElement | Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.
CurtainPanelsParamDefinedTypeDefinedCirculary | Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.
CurtainSystemCouldnotReacquireFaces | Curtain System could not reacquire [Number] faces out of [Number].
InvalidCurtainPanelInModel | There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.
MullionProfileContainsMoreThanOneOrOpenLoop | The selected mullion profile either contains more than one profile loop or an open profile loop and cannot be used. Valid profiles can only have a single continuous closed profile loop.
NonSystemPanelFamiliesCannotBeUsed | Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.
PanelsSlightlyMalformedCorruption | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
PanelsSlightlyMalformedWarning | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
SomeMullionsAreTooShort | Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class

AllMullionsAreTooShort Property

[image]