Revit 2024 API
MultiReferenceAnnotationType Members
MultiReferenceAnnotationType Class Methods Properties See Also Send Feedback

The MultiReferenceAnnotationType type exposes the following members.

Methods

 | Name | Description
 | CreateDefault | Creates the first MultiReferenceAnnotationType element and adds it to the document.
Public method | GetAllowedTagCategory | Returns the category ID for the tag types which can be used by this multi-reference annotation type.
Public method | IsAllowedDimensionStyle | Checks if the dimension style can be used with multi-reference annotations.
Public method | IsAllowedReferenceCategory | Checks if the reference category can be used with multi-reference annotations.
 | IsAllowedTagCategory | Returns true if tag types belonging to this category can be used with multi-reference annotation types.
Public method | IsAllowedTagType | Checks if the tag type can be assigned to this multi-reference annotation type.

Properties

 | Name | Description
Public property | DimensionStyleId | The dimension style which will be used by the child dimension of the multi-reference annotation.
Public property | GroupTagHeads | Controls if parameter values for the annotation's references will be reported in one grouped tag head or if every reference will get its own tag head.
Public property | ReferenceCategoryId | The category of elements to which this annotation applies.
Public property | ShowDimensionText | Controls if text from the multi-reference annotation's dimension will be shown.
Public property | TagTypeId | The tag type which will be used by the child tag the multi-reference annotation.

See Also

MultiReferenceAnnotationType Class

MultiReferenceAnnotationType Methods

[image] [image]