Revit 2024 API
ScheduleFilter Members
ScheduleFilter Class Constructors Methods Properties See Also Send Feedback

The ScheduleFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleFilter()()()() | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, ElementId) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Double) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Int32) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, String) | Creates a new ScheduleFilter.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ScheduleFilter
Public method | GetDoubleValue | Gets the filter value for a filter using a double value.
Public method | GetElementIdValue | Gets the filter value for a filter using an ElementId value.
Public method | GetIntegerValue | Gets the filter value for a filter using an integer value.
Public method | GetStringValue | Gets the filter value for a filter using a string value.
Public method | SetNullValue | Sets the filter to have no specified value (used for HasParameter filters).
Public method | SetValue(Double) | Set the filter value to a double.
Public method | SetValue(Int32) | Set the filter value to an integer.
Public method | SetValue(String) | Set the filter value to a string.
Public method | SetValue(ElementId) | Set the filter value to an ElementId.

Properties

 | Name | Description
Public property | FieldId | The ID of the field used to filter the schedule.
Public property | FilterType | The filter type.
Public property | IsDoubleValue | Indicates if the filter has a double value.
Public property | IsElementIdValue | Indicates if the filter has an ElementId value.
Public property | IsIntegerValue | Indicates if the filter has an integer value.
Public property | IsNullValue | Indicates if the filter has no specified value.
Public property | IsStringValue | Indicates if the filter has a string value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ScheduleFilter Class

ScheduleFilter Constructor

[image]