Revit 2024 API
FamilyManager Properties
FamilyManager Class See Also Send Feedback

The FamilyManager type exposes the following members.

Properties

 | Name | Description
Public property | CurrentType | The current family type.
Public property | Parameter[([( Guid])]) | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | Parameter[([( String])]) | Obtains the parameter of this type with a given name.
Public property | Parameter[([( BuiltInParameter])]) | Obtains the parameter of this type with a given parameter id.
Public property | Parameter[([( Definition])]) | Obtains the parameter of this type with a given definition.
Public property | Parameters | All family parameters in this family.
Public property | Types | All family types in the family.

See Also

FamilyManager Class

CurrentType Property

[image]