Revit 2024 API
TessellatedShapeBuilder Members
TessellatedShapeBuilder Class Constructors Methods Properties See Also Send Feedback

The TessellatedShapeBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | TessellatedShapeBuilder | Constructs a new instance of a TessellatedShapeBuilder.

Methods

 | Name | Description
Public method | AddFace | Adds a face to the currently open connected face set.
Public method | AreTargetAndFallbackCompatible | Checks whether this combination of fallback and target parameters can be used as a valid combination of inputs.
Public method | Build | Builds the designated geometrical objects from the stored face sets. Stores the result in this TessellatedShapeBuilder object.
Public method | CancelConnectedFaceSet | Cancels the current face set - i.e., all data from it will be lost and the builder will have no open connected face set anymore.
Public method | Clear | Erases all face set and clears the logs, if any.
Public method | CloseConnectedFaceSet | Closes the currently open connected face set.
 | CreateMeshByExtrusion | Builds a mesh by extruding curve loop(s) along extrusion distance.
Public method | DoesFaceHaveEnoughLoopsAndVertices | Checks whether 'face' has enough loops and vertcies to be valid.
Public method | GetBuildResult | Get the built geometry, build status and other data stored in TessellatedShapeBuilderResult. Clears the stored data.
Public method | OpenConnectedFaceSet | Opens a new connected face set.

Properties

 | Name | Description
Public property | Fallback | Defines acceptable fallback if the desired type of geometry can't be built.
Public property | GraphicsStyleId | Optional - if set, the built geometry will use that graphics style.
Public property | IsFaceSetOpen | Flag whether the current set of connected faces is open and additional tessellation faces can be added to it.
Public property | LogInteger | Integer value used for logging, if it is performed. Usually the number of the face set(s) in the IFC file, from which they are imported. Any value is acceptable.
Public property | LogString | String used for logging, if any. Usually the name of the file from which face sets were imported.
Public property | NumberOfCompletedFaceSets | Number of completed face sets.
Public property | OwnerInfo | String used for logging, if any. Usually describes the element or object, which either defined or will own the geoemtrical objects to be built.
Public property | Target | Requests the type of geometry to be built.

See Also

TessellatedShapeBuilder Class

TessellatedShapeBuilder Constructor

[image]