Revit 2024 API
BuiltInFailures..::..DesignOptionFailures Properties
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback

The BuiltInFailures..::..DesignOptionFailures type exposes the following members.

Properties

Name | Description
AreaTagLineCannotBeInDesignOption | Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.
BadReferenceBetweenOptions | An element may not reference an element in another Option of the same Option Set.
BadReferenceBetweenOptionsWarn | An element may not reference an element in another Option of the same Option Set.
BadReferenceToSecondary | No element in a secondary Option can be referenced by an element outside that Option.
BadReferenceToSecondaryWarn | No element in a secondary Option can be referenced by an element outside that Option.
CannotAddToOptions | Elements can't be added to Option Set
CannotAddToOptionsWarn | Elements can't be added to Option Set
CannotPutELAInOption | Electrical Load Areas must be in the Main Model.
CannotPutELZInOption | Area Based Loads must be in the Main Model.
CannotPutSpaceInOption | MEP space must be in the Main Model
CannotPutZoneInOption | HVAC Zones must be in the Main Model.
ConfusingHostByElementsInAnotherDesignOption | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInAnotherDesignOptionWarn | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOption | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOptionWarn | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModel | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModelWarn | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOption | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOptionWarn | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOption | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOptionWarn | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModel | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModelWarn | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOption | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOptionWarn | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOption | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOptionWarn | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModel | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModelWarn | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
DebugLevelsInOptionsError | This is an internal diagnostic message.
DebugLevelsInOptionsWarn | This is an internal diagnostic message.
ElementsWillBeDeletedNoOption | Elements will be deleted
FabricationCannotBeInDesignOption | Structural steel connections or individual structural steel fabrication elements are not allowed in Design Options.
KingNeverInOption | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
KingNeverInOptionWarn | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
MustAddKing | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustAddKingWarn | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustBeInMainModel | Element must be in Main Model
NeverInOption | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NeverInOptionWarn | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NoSelectedInOption | None of the selected elements can be added to this Option Set. The following warnings provide additional information.
OptionElementsDeleted | Elements in [option] were deleted
SelectionIncludesOptionItems | Elements that were already in a Design Option were selected. These will not be added to the Option Set.

See Also

BuiltInFailures..::..DesignOptionFailures Class

AreaTagLineCannotBeInDesignOption Property

[image]