Revit 2024 API
Outline Methods
Outline Class See Also Send Feedback

The Outline type exposes the following members.

Methods

 | Name | Description
Public method | AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Public method | Contains | Determine if this Outline contains the specified point to within a tolerance.
Public method | ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Public method | Dispose |
Public method | GetDiagonalLength | Get the length of outline's diagonal. If called on empty outline, 0. is returned
Public method | Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
Public method | IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Public method | Scale | Scales the bounding box by given scale.

See Also

Outline Class

AddPoint Method

[image]