Revit 2024 API
ConnectorElement Methods
ConnectorElement Class See Also Send Feedback

The ConnectorElement type exposes the following members.

Methods

 | Name | Description
Public method | AssignAsPrimary | Assign a connector as a primary connector.
Public method | ChangeHostReference(Reference) | Changes the connector host reference to a new planar face.
Public method | ChangeHostReference(Reference, Edge) | Changes the connector host reference to a new planar face and a new edge loop.
 | CreateCableTrayConnector(Document, Reference) | Create a new cable tray ConnectorElement.
 | CreateCableTrayConnector(Document, Reference, Edge) | Create a new cable tray ConnectorElement.
 | CreateConduitConnector(Document, Reference) | Create a new conduit ConnectorElement.
 | CreateConduitConnector(Document, Reference, Edge) | Create a new conduit ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference) | Create a new duct ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference, Edge) | Create a new duct ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference) | Create a new electrical ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference, Edge) | Create a new electrical ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference) | Create a new pipe ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference, Edge) | Create a new pipe ConnectorElement with a face and an edge.
Public method | FlipDirection | Reverses the direction of the connector element.
Public method | GetLinkedConnectorElement | Get the linked connector element.
Public method | IsSystemClassificationValid | Checks that the MEPSystemType is valid for the domain of connector.
Public method | SetLinkedConnectorElement | Set the linked connector element.

See Also

ConnectorElement Class

AssignAsPrimary Method

[image]