Revit 2024 API
FabricationConfigurationInfo Members
FabricationConfigurationInfo Class Methods Properties See Also Send Feedback

The FabricationConfigurationInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationConfigurationInfo
 | FindSourceFabricationConfiguration | Finds the source fabrication configuration on disk which matches the input fabrication configuration.
 | GetAllFabricationConfigurations | Gets all added fabrication configurations.
Public method | GetProfiles | Return the profiles in the fabrication configuration.
Public method | IsValid | Checks if the fabrication configuration is valid.

Properties

 | Name | Description
Public property | CloudId | The identifier of the cloud configuration.
Public property | Description | The description of the fabrication configuration.
Public property | GUID | The unique identification of the fabrication configuration.
Public property | IsCloudConfiguration | Whether the cloud configuration is a remote cloud one.
Public property | IsLocked | Checks whether the fabrication configuration is locked. If true, the configuration is locked and cannot be removed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the fabrication configuration.
Public property | Path | The path where the fabrication configuration is located. To populate this property, you may need to call FindSourceFabricationConfiguration first.
Public property | UnitSystem | The unit system of the fabrication configuration. Units can be UnitSystem.Metric or UnitSystem.Imperial.
Public property | Version | The version of the fabrication configuration.

See Also

FabricationConfigurationInfo Class

Dispose Method

[image]