Revit 2024 API
FormatOptions Properties
FormatOptions Class See Also Send Feedback

The FormatOptions type exposes the following members.

Properties

 | Name | Description
Public property | Accuracy | The accuracy to which values will be rounded.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RoundingMethod | The method used to round values: round to nearest, round up, or round down.
Public property | SuppressLeadingZeros | Indicates if leading zeros should be suppressed in feet and fractional inches.
Public property | SuppressSpaces | Indicates if spaces around the dash should be suppressed in feet and fractional inches.
Public property | SuppressTrailingZeros | Indicates if trailing zeros after the decimal point should be suppressed.
Public property | UseDefault | Indicates whether default or custom formatting should be used.
Public property | UseDigitGrouping | Indicates if digit grouping symbols should be displayed.
Public property | UsePlusPrefix | Indicates if a plus sign prefix should be displayed for positive and zero values.

See Also

FormatOptions Class

Accuracy Property

[image]