Revit 2024 API
ImageExportOptions Properties
ImageExportOptions Class See Also Send Feedback

The ImageExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ExportRange | The export range defining which view(s) will be exported.
Public property | FilePath | The file name and path for the exported file.
Public property | FitDirection | The fit direction. Used only if ZoomType is FitToPage.
Public property | HLRandWFViewsFileType | File type for exported HLR and wireframe views.
Public property | ImageResolution | The image resolution in dots per inch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
Public property | ShadowViewsFileType | The file type for exported shadow views.
Public property | ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
Public property | ViewName | The name of the view to be created.
Public property | Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
Public property | ZoomType | The zoom type, which defines how the image size is determined.

See Also

ImageExportOptions Class

ExportRange Property

[image]