Revit 2024 API
BoundarySegment Members
BoundarySegment Class Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BoundarySegment
Public method | GetCurve | Get a copy of the curve that is formed along this boundary.

Properties

 | Name | Description
Public property | ElementId | Retrieve the id of the element that produces this boundary segment. If the segment is created from an element in a link, this is the id of the RevitLinkInstance.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkElementId | Retrieve the element id of the element in a link instance that forms this boundary.

See Also

BoundarySegment Class

BoundarySegment Methods

[image] [image]