Revit 2024 API
GeometryObject Members
GeometryObject Class Methods Operators Properties See Also Send Feedback

The GeometryObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Overrides Object..::..GetHashCode()()()().)

Operators

Name | Description
Equality | Determines whether two GeometryObjects are the same.
Inequality | Determines whether two GeometryObjects are different.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element.
Public property | Visibility | The visibility.

See Also

GeometryObject Class

GeometryObject Methods

[image] [image]