Revit 2024 API
RepeaterBounds Methods
RepeaterBounds Class See Also Send Feedback

The RepeaterBounds type exposes the following members.

Methods

 | Name | Description
Public method | AdjustForCyclicalBounds | Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.
Public method | AreCoordinatesInBounds | Determines whether given coordinates are within the bounds.
Public method | Dispose |
Public method | GetLowerBound | Returns the smallest index of the array in the given dimension.
Public method | GetUpperBound | Returns the highest index of the array in the given dimension.
Public method | IsCyclical | True if the array doesn't have finite bounds in the given dimension. Cyclical bounds indicate that the array forms a closed loop in the given dimension.

See Also

RepeaterBounds Class

AdjustForCyclicalBounds Method

[image]