Revit 2024 API
SketchPlane Methods
SketchPlane Class See Also Send Feedback

The SketchPlane type exposes the following members.

Methods

 | Name | Description
 | Create(Document, ElementId) | Creates a sketch plane from a grid, reference plane, or level.
 | Create(Document, Plane) | Creates a new sketch plane from a geometric plane.
 | Create(Document, Reference) | Creates a new sketch plane from a reference to a planar face.
Public method | GetPlane | Returns the corresponding Plane.
Public method | GetPlaneReference | Returns a reference to this element as a plane.

See Also

SketchPlane Class

Create Method

[image] [image]