Revit 2024 API
FamilyInstance..::..HostParameter Property
FamilyInstance Class See Also Send Feedback
If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double HostParameter { get; }
Visual Basic
Public ReadOnly Property HostParameter As Double
    Get
Visual C++
public:
property double HostParameter {
    double get ();
}

Remarks

This works for instances with a host element that is of type Wall or is in the OST_Walls category only, including in-place ones.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Only hosted instances whose family is not work plane based can support this functionality.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Only hosted instances of type Wall or in-place elements of category OST_Walls can support this functionality.

See Also

FamilyInstance Class

Invisible Property

[image]