Revit 2024 API
CurveByPoints Members
CurveByPoints Class Methods Properties See Also Send Feedback

The CurveByPoints type exposes the following members.

Methods

 | Name | Description
Public method | GetPoints | Get the sequence of points interpolated by this curve.
Public method | GetVisibility | Gets the visibility.
Public method | SetPoints | Change the sequence of points interpolated by this curve.
Public method | SetVisibility | Sets the visibility.
 | SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.

Properties

 | Name | Description
Public property | IsReferenceLine |
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElement..::..SketchPlane.)
Public property | Subcategory | The subcategory, or graphics style, of the CurveByPoints.
Public property | Visible | Whether the point is visible when the family is loaded into a project.

See Also

CurveByPoints Class

CurveByPoints Methods

[image] [image]