Revit 2024 API
CurveArray Members
CurveArray Class Constructors Methods Properties See Also Send Feedback

The CurveArray type exposes the following members.

Constructors

 | Name | Description
Public method | CurveArray | Initializes a new instance of the CurveArray class

Methods

 | Name | Description
Public method | Append | Add the curve to the end of the array.
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.

See Also

CurveArray Class

CurveArray Constructor

[image]