Revit 2024 API
DirectShapeTypeUserAssignability Enumeration
See Also Send Feedback
Options for a DirectShapeType which affect whether or not it can be assigned as the type of a DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023
Since: 2023

Syntax

C#
public enum DirectShapeTypeUserAssignability
Visual Basic
Public Enumeration DirectShapeTypeUserAssignability
Visual C++
public enum class DirectShapeTypeUserAssignability

Members

Member name | Description
Assignable | The DirectShapeType can be used to replace the type of an existing DirectShape.
Nonassignable | The DirectShapeType cannot be used to replace the type of an existing DirectShape.

Remarks

Only DirectShapeTypes which permit assignability will be shown in the type selector dialog. A DirectShape which uses a DirectShapeType which is not assignable can be copied.

See Also

Autodesk.Revit.DB Namespace

DisableAnalyticalModelCB Class

[image]