Revit 2024 API
IExportContext Members
IExportContext Interface Methods See Also Send Feedback

The IExportContext type exposes the following members.

Methods

 | Name | Description
Public method | Finish | This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).
Public method | IsCanceled | This method is queried at the beginning of every element.
Public method | OnElementBegin | This method marks the beginning of an element to be exported.
Public method | OnElementEnd | This method marks the end of an element being exported.
Public method | OnFaceBegin | This method marks the beginning of a Face to be exported.
Public method | OnFaceEnd | This method marks the end of the current face being exported.
Public method | OnInstanceBegin | This method marks the start of processing of an instance node (e.g. a family instance).
Public method | OnInstanceEnd | This method marks the end of processing of an Instance Node (e.g. a family instance).
Public method | OnLight | This method marks the beginning of export of a light which is enabled for rendering.
Public method | OnLinkBegin | This method marks the beginning of a link instance to be exported.
Public method | OnLinkEnd | This method marks the end of a link instance being exported.
Public method | OnMaterial | This method marks a change of the material.
Public method | OnPolymesh | This method is called when a tessellated polymesh of a 3d face is being output.
Public method | OnRPC | This method marks the beginning of export of an RPC object.
Public method | OnViewBegin | This method marks the beginning of a 3D view to be exported.
Public method | OnViewEnd | This method marks the end of a 3D view being exported.
Public method | Start | This method is called at the very start of the export process, still before the first entity of the model was send out.

See Also

IExportContext Interface

Finish Method

[image]