Revit 2024 API
FilteredElementIterator Members
FilteredElementIterator Class Methods Properties See Also Send Feedback

The FilteredElementIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredElementIterator
Public method | GetCurrent | The current element found by the iterator.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element passing the filter.
Public method | Reset | Resets the iterator to the beginning.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredElementIterator Class

Dispose Method

[image]