Revit 2024 API
Document..::..NewFlexDuct Method (IList<(Of <(<'XYZ>)>)>, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using a point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlexDuct NewFlexDuct(
    IList<XYZ> points,
    FlexDuctType ductType
)
Visual Basic
Public Function NewFlexDuct ( _
    points As IList(Of XYZ), _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    IList<XYZ^>^ points,
    FlexDuctType^ ductType
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The point array indicating the path of the flexible duct, including the end points.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the flexible duct type does not exist in the given document.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace

NewFlexDuct Method (Connector, Connector, FlexDuctType)

[image]