Revit 2024 API
DirectShapeType..::..IsValidShape Method
DirectShapeType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>)) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.

See Also

DirectShapeType Class
DirectShapeType Members

IsValidShape Method (ExternallyTaggedGeometryObject)

[image]