Revit 2024 API
Material Members
Material Class Methods Properties See Also Send Feedback

The Material type exposes the following members.

Methods

 | Name | Description
Public method | ClearMaterialAspect | Removes an aspect from the material.
 | Create | Creates a new material.
Public method | Duplicate | Duplicates the material
 | IsMaterialOrValidDefault | Validates whether the specified element id is a material element.
 | IsNameUnique | Validates whether the material name is unique in document.
Public method | SetMaterialAspectByPropertySet | Sets an aspect of the material to a shared property set.

Properties

 | Name | Description
Public property | AppearanceAssetId | The ElementId of the AppearanceAssetElement.
Public property | Color | The color of the material.
Public property | CutBackgroundPatternColor | The color of the material cut background pattern.
Public property | CutBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in cut views.
Public property | CutForegroundPatternColor | The color of the material cut foreground pattern.
Public property | CutForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in cut views.
Public property | MaterialCategory | The name of the material category, e.g. 'Wood'
Public property | MaterialClass | The name of the general material type, e.g. 'Wood.'
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | StructuralAssetId | The ElementId of the structural PropertySetElement.
Public property | SurfaceBackgroundPatternColor | The color of the material surface background pattern.
Public property | SurfaceBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in normal views.
Public property | SurfaceForegroundPatternColor | The color of the material surface foreground pattern.
Public property | SurfaceForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in normal views.
Public property | ThermalAssetId | The ElementId of the thermal PropertySetElement.
Public property | Transparency | The transparency of the material.
Public property | UseRenderAppearanceForShading | True to use the render appearance settings for shaded view appearance; false to use the material's color and transparency value for shaded view appearance.

See Also

Material Class

Create Method

[image]