Revit 2024 API
NurbSpline..::..CtrlPoints Property
NurbSpline Class See Also Send Feedback
Returns the control points of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<XYZ> CtrlPoints { get; }
Visual Basic
Public ReadOnly Property CtrlPoints As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ CtrlPoints {
    IList<XYZ^>^ get ();
}

See Also

NurbSpline Class

Degree Property

[image]