Revit 2024 API
UV Methods
UV Class See Also Send Feedback

The UV type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
Public method | DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
Public method | GetLength | The length of this 2-D vector.
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Public method | IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
Public method | IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Public method | Negate | Negates this 2-D vector.
Public method | Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
Public method | ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides Object..::..ToString()()()().)

See Also

UV Class

Add Method

[image]