Revit 2024 API
OverrideGraphicSettings Properties
OverrideGraphicSettings Class See Also Send Feedback

The OverrideGraphicSettings type exposes the following members.

Properties

 | Name | Description
Public property | CutBackgroundPatternColor | The override color of the background pattern of cut faces.
Public property | CutBackgroundPatternId | The ElementId of the cut face background fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutForegroundPatternColor | The override color of the foreground pattern of cut faces.
Public property | CutForegroundPatternId | The ElementId of the cut face foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutLineColor | Cut surface line color.
Public property | CutLinePatternId | ElementId of the cut surface line pattern.
Public property | CutLineWeight | Cut surface line weight.
Public property | DetailLevel | The detail level.
Public property | Halftone | Value of the halftone override.
 | InvalidPenNumber | The invalidPenNumber for clearing line weight overrides.
Public property | IsCutBackgroundPatternVisible | The visibility of the cut face background fill pattern.
Public property | IsCutForegroundPatternVisible | The visibility of the cut face foreground fill pattern.
Public property | IsSurfaceBackgroundPatternVisible | The visibility of the surface background fill pattern.
Public property | IsSurfaceForegroundPatternVisible | The visibility of the surface foreground fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProjectionLineColor | Projection surface line color.
Public property | ProjectionLinePatternId | Id of the projection surface line pattern.
Public property | ProjectionLineWeight | The projection surface line weight.
Public property | SurfaceBackgroundPatternColor | The override color of the surface background pattern.
Public property | SurfaceBackgroundPatternId | The ElementId of the surface background fill pattern override. A value of InvalidElementId means no override is set.
Public property | SurfaceForegroundPatternColor | The override color of the surface foreground pattern.
Public property | SurfaceForegroundPatternId | The ElementId of the surface foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | Transparency | Transparency of surfaces.

See Also

OverrideGraphicSettings Class

CutBackgroundPatternColor Property

[image]