Revit 2024 API
BoundingBoxIntersectsFilter Members
BoundingBoxIntersectsFilter Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxIntersectsFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxIntersectsFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Methods

 | Name | Description
Public method | GetBoundingBox | Gets the outline being used for this filter.

Properties

 | Name | Description
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIntersectsFilter Class

BoundingBoxIntersectsFilter Constructor

[image] [image]