Revit 2024 API
GeometryCreationUtilities..::..CreateBlendGeometry Method (CurveLoop, CurveLoop, ICollection<(Of <(<'VertexPair>)>)>)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by blending two closed curve loops lying in non-coincident planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static Solid CreateBlendGeometry(
    CurveLoop firstLoop,
    CurveLoop secondLoop,
    ICollection<VertexPair> vertexPairs
)
Visual Basic
Public Shared Function CreateBlendGeometry ( _
    firstLoop As CurveLoop, _
    secondLoop As CurveLoop, _
    vertexPairs As ICollection(Of VertexPair) _
) As Solid
Visual C++
public:
static Solid^ CreateBlendGeometry(
    CurveLoop^ firstLoop,
    CurveLoop^ secondLoop,
    ICollection<VertexPair^>^ vertexPairs
)

Parameters

firstLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The first curve loop. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop may not contain just one closed curve - split such a loop into two or more curves beforehand.
secondLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The second curve loop, satisfying the same conditions as the first loop. The planes of the first and second loops must not be coincident, but they need not be parallel.
vertexPairs
Type: System.Collections.Generic..::..ICollection<(Of <(<' VertexPair >)>)>
This input specifies how the two profile loops should be connected. If null, the function chooses vertex connections that will result in a geometrically reasonable blend.

Return Value

The requested solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The first profile CurveLoop do not satisfy the input requirements. -or- The second profile CurveLoop do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GeometryCreationUtilities Class
CreateBlendGeometry Overload

CreateBlendGeometry Method (CurveLoop, CurveLoop, ICollection(VertexPair), SolidOptions)

[image]