Revit 2024 API
TableSectionData..::..SetCellCombinedParameters Method (Int32, Int32, IList<(Of <(<'TableCellCombinedParameterData>)>)>)
TableSectionData Class See Also Send Feedback
Allows the caller to set combined parameter for a specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellCombinedParameters(
    int nRow,
    int nCol,
    IList<TableCellCombinedParameterData> paramData
)
Visual Basic
Public Sub SetCellCombinedParameters ( _
    nRow As Integer, _
    nCol As Integer, _
    paramData As IList(Of TableCellCombinedParameterData) _
)
Visual C++
public:
void SetCellCombinedParameters(
    int nRow,
    int nCol,
    IList<TableCellCombinedParameterData^>^ paramData
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
paramData
Type: System.Collections.Generic..::..IList<(Of <(<' TableCellCombinedParameterData >)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class
SetCellCombinedParameters Overload

SetCellFormatOptions Method

[image]