Revit 2024 API
ExportLineweightTable Methods
ExportLineweightTable Class See Also Send Feedback

The ExportLineweightTable type exposes the following members.

Methods

 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line weight table.
Public method | Clear | Removes all contents stored in Export line weight table.
Public method | ContainsKey | Checks whether a line weight key exists in the table.
Public method | Dispose |
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLineweightInfo | Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLineweightTableIterator | Returns a ExportLineweightTableIterator that iterates through the collection.
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLineweightKey.

See Also

ExportLineweightTable Class

Add Method

[image]