Revit 2024 API
AssemblyInstance Properties
AssemblyInstance Class See Also Send Feedback

The AssemblyInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyTypeName | The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.
Public property | Location | This property is used to find the physical location of the assembly instance within project. (Overrides Element..::..Location.)
Public property | NamingCategoryId | Id of the category that drives the default naming scheme for the assembly instance.

See Also

AssemblyInstance Class

AssemblyTypeName Property

[image]