Revit 2024 API
UnitFormatUtils Methods
UnitFormatUtils Class See Also Send Feedback

Methods

Name | Description
Format(Units, ForgeTypeId, Double, Boolean) | Formats a number with units into a string.
Format(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) | Formats a number with units into a string.
TryParse(Units, ForgeTypeId, String, Double%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, Double%, String%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double%, String%) | Parses a formatted string into a number with units if possible.

See Also

UnitFormatUtils Class

Format Method

[image] [image]