Revit 2024 API
CopyPasteOptions Members
CopyPasteOptions Class Constructors Methods Properties See Also Send Feedback

The CopyPasteOptions type exposes the following members.

Constructors

 | Name | Description
Public method | CopyPasteOptions | Creates a new instance of a CopyPasteOptions object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CopyPasteOptions
Public method | GetDuplicateTypeNamesHandler | Returns current duplicate type names handler or nullNothingnullptra null reference (Nothing in Visual Basic) if none is set.
Public method | SetDuplicateTypeNamesHandler | Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CopyPasteOptions Class

Dispose Method

[image]