Revit 2024 API
ConfigurationReloadInfo Members
ConfigurationReloadInfo Class Constructors Methods Properties See Also Send Feedback

The ConfigurationReloadInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigurationReloadInfo | Constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ConfigurationReloadInfo
Public method | GetConnectivityValidation | Returns information about the post-reload connectivity validation.
Public method | GetCustomDataChangedElements | Gets a list of ElementIds of fabrication parts that had custom data updated during the reload.
Public method | GetOutOfDatePartStatus | Access reload information for out of date part.

Properties

 | Name | Description
Public property | Disconnects | The number of disconnections caused by the reload.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutOfDatePartCount | The number of fabrication part instances that had newer versions and were out of date.
Public property | ProfileNotAvailable | The current profile is not available in the disk configuration.

See Also

ConfigurationReloadInfo Class

Dispose Method

[image]