Revit 2024 API
SpatialElementGeometryCalculator Members
SpatialElementGeometryCalculator Class Constructors Methods Properties See Also Send Feedback

The SpatialElementGeometryCalculator type exposes the following members.

Constructors

 | Name | Description
Public method | SpatialElementGeometryCalculator(Document) | Constructs a new calculator with default options for the geometry of spatial elements.
Public method | SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) | Constructs a new calculator for the geometry of spatial elements.

Methods

 | Name | Description
Public method | CalculateSpatialElementGeometry | Compute the spatial element geometry and returns the boundary face information.
 | CanCalculateGeometry | This indicates whether the input spatial element is a valid one.
Public method | Dispose | Releases all resources used by the SpatialElementGeometryCalculator
Public method | GetOptions | The options that control the calculation.
 | IsRoomOrSpace | This indicates whether the input spatial element is a room or a space.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SpatialElementGeometryCalculator Class

SpatialElementGeometryCalculator Constructor

[image] [image]