Revit 2024 API
FailureMessageAccessor Members
FailureMessageAccessor Class Methods Properties See Also Send Feedback

The FailureMessageAccessor type exposes the following members.

Methods

 | Name | Description
Public method | CloneFailureMessage | Creates a copy of the FailureMessage.
Public method | Dispose | Releases all resources used by the FailureMessageAccessor
Public method | GetAdditionalElementIds | Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.
Public method | GetCurrentResolutionType | Retrieves the type of resolution to be used to resolve the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description of the failure.
Public method | GetFailingElementIds | Retrieves Ids of Elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the Id of the FailureDefinition of the failure.
Public method | GetNumberOfResolutions | Retrieves number of resolutions that can be used to resolve failure.
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetCurrentResolutionType | Sets the type of a resolution to be used to resolve the failure.
Public method | ShouldMergeWithMessage | Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureMessageAccessor Class

CloneFailureMessage Method

[image]