Revit 2024 API
TableData Members
TableData Class Methods Properties See Also Send Feedback

The TableData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableData
Public method | GetSectionData(Int32) | Returns the section data array element at the specified index.
Public method | GetSectionData(SectionType) | Returns the pointer to the section data array element at the specified section type.
Public method | IsEqual | Checks if this element is equal in value to the other element.
Public method | IsValidZoomLevel | Verifies if the value of zoom level is valid.

Properties

 | Name | Description
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSections | Gets the number of items in section data array.
Public property | Width | Gets or sets the table width in feet
Public property | WidthInPixels | Gets the width of the panel schedule in logical pixels
Public property | ZoomLevel | The value of zoom level for corresponding TableView.

See Also

TableData Class

TableData Methods

[image] [image]