Revit 2024 API
BuiltInFailures..::..GeometryFailures Properties
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback

The BuiltInFailures..::..GeometryFailures type exposes the following members.

Properties

Name | Description
CannotFindClosest | Cannot find closest points within lines.
ConvertFaceRegionsToFacesCrashed | Failed to replace an instance face with its face regions.
ConvertFaceRegionsToFacesFailed | Failed to replace an instance face with its face regions.
CurveAndSurfaceDoNotIntersect | Curve and Surface do not intersect.
CurveDriverError | Element's internal join data is corrupt.
CurveProjectTooShort | The projection of the line in this view is too short to create a new Line
ElementIsTooThin | [Element] is too thin.
ElementTooSmall | Element is too small on screen
FailedReplaceCurveElemCurveDriver | Failed to replace curve elem curve driver.
FailedUpdateCurveChain | Failed to update curve chain.
FailToConvertLine | Unable to convert lines
LineArcTangentFailure | Can't keep arc element and straight line element tangent.
OffsetFaceFailed | Failed to offset the face.
PolygonSegmentTooShort | Polygon segment too short
SiteInvisible | Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics.
SuccessToConvertLine | Success to convert lines
SymbolicLineInvalidPlane | Symbolic Element refers to a Work Plane with unacceptable normal.
TooManyFacesEdges | This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

See Also

BuiltInFailures..::..GeometryFailures Class

ConvertFaceRegionsToFacesCrashed Property

[image]