Revit 2024 API
Element..::..WorksetId Property
Element Class See Also Send Feedback
Get Id of the Workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public WorksetId WorksetId { get; }
Visual Basic
Public ReadOnly Property WorksetId As WorksetId
    Get
Visual C++
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
}

Remarks

Each element belongs to one and only one workset.

See Also

Element Class

ElementArray Class

[image]