Revit 2024 API
ExternalResourceReference Constructor (Guid, IDictionary<(Of <(<'String, String>)>)>, String, String)
ExternalResourceReference Class See Also Send Feedback
Creates a new ExternalResourceReference from the given data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceReference(
    Guid serverId,
    IDictionary<string, string> referenceInformation,
    string version,
    string inSessionPath
)
Visual Basic
Public Sub New ( _
    serverId As Guid, _
    referenceInformation As IDictionary(Of String, String), _
    version As String, _
    inSessionPath As String _
)
Visual C++
public:
ExternalResourceReference(
    Guid serverId,
    IDictionary<String^, String^>^ referenceInformation,
    String^ version,
    String^ inSessionPath
)

Parameters

serverId
Type: System..::..Guid
The id of the server associated with this ExternalResourceReference. The server must implement IExternalResourceServer.
referenceInformation
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The (String, String) map containing reference or lookup information that will be stored in Revit.
version
Type: System..::..String
The version of the external data.
inSessionPath
Type: System..::..String
The path that identifies a resource in server. ExternalResourceServer must provide this path which should not contain the server name. Revit internally will construct and store the full display path which includes the server name plus this path at the time a resource is loaded into the model for use if the server is missing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The file is not allowed to access.

See Also

ExternalResourceReference Class
ExternalResourceReference Overload

ExternalResourceReference Methods

[image] [image]