Revit 2024 API
RenderingSettings Methods
RenderingSettings Class See Also Send Feedback

The RenderingSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetBackgroundSettings | Returns an object that represents the rendering background settings.
Public method | GetRenderingImageExposureSettings | Returns an object that represents the rendering image exposure settings.
Public method | GetRenderingQualitySettings | Returns an object that represents the rendering quality settings.
Public method | GetRenderingRegionOutline | Returns the outline of the rendering region.
Public method | SetBackgroundSettings | Changes the rendering background settings details for the current background style.
Public method | SetRenderingImageExposureSettings | Changes the rendering image exposure settings.
Public method | SetRenderingQualitySettings | Change rendering quality settings.

See Also

RenderingSettings Class

GetBackgroundSettings Method

[image]