Revit 2024 API
FormatValueOptions Members
FormatValueOptions Class Constructors Methods Properties See Also Send Feedback

The FormatValueOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FormatValueOptions | Creates a new FormatValueOptions object with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FormatValueOptions
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.

Properties

 | Name | Description
Public property | AppendUnitSymbol | Indicates if a unit symbol should be appended regardless of the settings in the FormatOptions.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FormatValueOptions Class

FormatValueOptions Constructor

[image]