Revit 2024 API
TriangleInShellComponent Members
TriangleInShellComponent Class Constructors Methods Properties See Also Send Feedback

The TriangleInShellComponent type exposes the following members.

Constructors

 | Name | Description
Public method | TriangleInShellComponent | Creates a copy of the given TriangleInShellComponent

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriangleInShellComponent

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | VertexIndex0 | Index of the triangle's first vertex in the TriangulatedShellComponent's array of vertices.
Public property | VertexIndex1 | Index of the triangle's second vertex in the TriangulatedShellComponent's array of vertices.
Public property | VertexIndex2 | Index of the triangle's third vertex in the TriangulatedShellComponent's array of vertices.

See Also

TriangleInShellComponent Class

Dispose Method

[image]