Revit 2024 API
FillPattern Constructor
FillPattern Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillPattern()()()() | Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.
Public method | FillPattern(FillPattern) | Constructs a new copy of the input FillPattern object.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation) | Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) | Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) | Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

See Also

FillPattern Class
FillPattern Members

FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation)

[image]