Revit 2024 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures Properties
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback

The BuiltInFailures..::..PartMakerMethodForMergePartFailures type exposes the following members.

Properties

Name | Description
MergedPartHasDisConnectedGeometries | A merged part geometry has dis-connected components.
NeedTwoPartsToMerge | Attempt to merge fewer than two parts. There must be at least two. No part will be produced.
PartNotIncludedInMerge | This part is not geometrically coincident with another part of the same material. No merge possible.
PartsCannotBeMerged | This PartMaker refers to parts which cannot be merged.
UnableToIncludePartInMerge | Attempt to merge this Part results in failure of boolean operation. Cannot compute combined geometry.

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class

MergedPartHasDisConnectedGeometries Property

[image]