Revit 2024 API
HostedSweep Members
HostedSweep Class Methods Properties See Also Send Feedback

The HostedSweep type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the hosted sweep object.
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created.
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.

See Also

HostedSweep Class

HostedSweep Methods

[image] [image]