Revit 2024 API
Part Methods
Part Class See Also Send Feedback

The Part type exposes the following members.

Methods

 | Name | Description
Public method | CanOffsetFace | Checks if it is possible to offset the given face.
Public method | GetFaceOffset | Get face offset of the given part face.
Public method | GetSourceElementIds | Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.
Public method | GetSourceElementOriginalCategoryIds | Gets the category ids of the source elements which were used to form this part.
Public method | ResetFaceOffset | Resets the offset applied to the given part face.
Public method | ResetPartShape | Resets all face offsets applied to part faces.
Public method | SetFaceOffset | Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.

See Also

Part Class

GetFaceOffset Method

[image]