Revit 2024 API
Reference Members
Reference Class Constructors Methods Properties See Also Send Feedback

The Reference type exposes the following members.

Constructors

 | Name | Description
Public method | Reference | Creates a Reference with the supplied element.

Methods

 | Name | Description
Public method | Contains | Checks if given reference identifies part of object identified by this reference.
Public method | ConvertToStableRepresentation | Converts the reference to a stable String representation.
Public method | CreateLinkReference | Creates a Reference from a Reference in an RVT Link.
Public method | CreateReferenceInLink | Creates a Reference in an RVT Link from a Reference in the RVT host file.
Public method | EqualTo | Checks if given reference is equal to this reference.
 | ParseFromStableRepresentation | Converts a stable String representation of a reference to a Reference object.

Properties

 | Name | Description
Public property | ElementId | The element id for this reference.
Public property | ElementReferenceType | The type of reference.
Public property | GlobalPoint | The position on which the reference is hit.
Public property | LinkedElementId | The id of the top-level element in the linked document that is referred to by this reference.
Public property | UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class

Reference Methods

[image] [image]