Revit 2024 API
FamilyElementVisibility Properties
FamilyElementVisibility Class See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Properties

 | Name | Description
Public property | IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
Public property | IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
Public property | IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
Public property | IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
Public property | IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
Public property | IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
Public property | IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
Public property | IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
Public property | VisibilityType | Indicates if the instance is Model or View specific.

See Also

FamilyElementVisibility Class

IsShownInCoarse Property

[image]