Revit 2024 API
IFCExportOptions Properties
IFCExportOptions Class See Also Send Feedback

The IFCExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
Public property | FamilyMappingFile | Path to a file containing family mapping.
Public property | FileVersion | IFC file version.
Public property | FilterViewId | Id of the view whose visibility settings will govern the contents in the exported IFC file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpaceBoundaryLevel | Level of space boundaries exported in IFC file.
Public property | WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.

See Also

IFCExportOptions Class

ExportBaseQuantities Property

[image]