Revit 2024 API
FillPattern Members
FillPattern Class Constructors Methods Properties See Also Send Feedback

The FillPattern type exposes the following members.

Constructors

 | Name | Description
Public method | FillPattern()()()() | Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.
Public method | FillPattern(FillPattern) | Constructs a new copy of the input FillPattern object.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation) | Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) | Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) | Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FillPattern
Public method | ExpandDots | Corrects pattern dots to make them be drawn properly for Revit.
Public method | GetFillGrid | Gets the specified fill grid.
Public method | GetFillGrids | Gets all fill grids in this fill pattern
Public method | IsEqual | Check if the contents and the name of the fill pattern is the same as the name and contents of this fill pattern.
Public method | SetFillGrid | Sets the fill grid.
Public method | SetFillGrids | Set the fill grids in this fill pattern.

Properties

 | Name | Description
Public property | GridCount | Gets the count of the fill grids in this fill pattern.
Public property | HostOrientation | Orientation to host layer.
Public property | IsSolidFill | Check if the fill pattern is a solid fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LengthPerArea | Gets length of all lines that placed on unit area.
Public property | LinesPerLength | Gets the number of solid lines that placed in unit length.
Public property | Name | The name of the fill pattern.
Public property | StrokesPerArea | Gets the number of strokes that placed on unit area.
Public property | Target | Target of this fill pattern applied to.

See Also

FillPattern Class

FillPattern Constructor

[image] [image]