Revit 2024 API
Document Members
Document Class Methods Properties Events See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | AcquireCoordinates | Acquires coordinates from the specified link instance.
Public method | AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Public method | CanEnableCloudWorksharing | Checks if cloud worksharing can be enabled for the cloud model.
Public method | CanEnableWorksharing | Checks if worksharing can be enabled in the document.
Public method | Close()()()() | Closes the document, save the changes if there are.
Public method | Close(Boolean) | Closes the document with the option to save.
Public method | CombineElements | Combine a set of combinable elements into a geometry combination.
Public method | ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
Public method | ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
Public method | ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
Public method | ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
Public method | Delete(ElementId) | Deletes an element from the document given the id of that element.
Public method | Delete(ICollection<(Of <<'(ElementId>)>>)) | Deletes a set of elements from the document.
Public method | Dispose | Releases all resources used by the Document
Public method | EditFamily | Gets the document of a loaded family to edit.
Public method | EnableCloudWorksharing | Enables cloud worksharing for a cloud model
Public method | EnableWorksharing | Enables worksharing in the document.
Public method | Equals | Determines whether the specified Object equals to this Object. (Overrides Object..::..Equals(Object).)
Public method | EraseSchemaAndAllEntities | Erases Schema and all its Entities from the document.
Public method | Export(String, IList<(Of <<'(ElementId>)>>), PDFExportOptions) | Exports a selection of views in PDF format.
Public method | Export(String, String, GBXMLExportOptions) | Export the model in gbXML (green-building) format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, NavisworksExportOptions) | Exports a Revit project to the Navisworks .nwc format.
Public method | Export(String, String, OBJExportOptions) | Exports a view specified in the export options to the OBJ format.
Public method | Export(String, String, STLExportOptions) | Exports a view specified in the export options to the STL format.
Public method | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DGNExportOptions) | Exports a selection of views in DGN format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), SATExportOptions) | Exports the current view or a selection of views in SAT format.
Public method | ExportImage | Exports a view or set of views into an image file.
Public method | GetAllUnusedElements | Returns the list of element ids that are not used. The list of unused element ids may include elements that can't be deleted.
Public method | GetChangedElements | Extracts a collection containing the ids of elements that have been created, modified or deleted between the input baseVersion and the document's current version.
Public method | GetCloudFolderId | Gets ForgeDM folder id where the model locates.
Public method | GetCloudModelPath | Gets the cloud model path of the cloud model.
Public method | GetCloudModelUrn | A ForgeDM Urn identifying the model.
Public method | GetDefaultElementTypeId | Gets the default element type id with the given DefaultElementType id.
Public method | GetDefaultFamilyTypeId | Gets the default family type id with the given family category id.
Public method | GetDocumentPreviewSettings | Returns the preview settings for the given document.
 | GetDocumentVersion | Gets the DocumentVersion that corresponds to a document.
Public method | GetElement(String) | Gets the Element referenced by a unique id string.
Public method | GetElement(ElementId) | Gets the Element referenced by the input ElementId.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.
Public method | GetHashCode | Gets the hash code of this document instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHubId | Gets ForgeDM hub id where the model locates. It is cached in session.
Public method | GetPaintedMaterial | Get the material painted on the element's face. Returns invalidElementId if the face is not painted.
Public method | GetPrintSettingIds | Retrieves all Print Settings of current project.
Public method | GetProjectId | Gets ForgeDM project id where the model locates.
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.
Public method | GetSubelement(String) | Gets the subelement referenced by a unique id string.
Public method | GetSubelement(Reference) | Gets the subelement referenced by the input reference.
Public method | GetSubelement(ElementId, Int32) | Gets the subelement referenced by a parent id and subelement id.
Public method | GetTypeOfStorage | Get the storage type of the identified built-in parameter.
Public method | GetUnits | Gets the Units object.
Public method | GetUnusedElements | Returns the list of element ids that are not used and can be deleted from the document.
Public method | GetWarnings | Returns list of failure messages generated from persistent (reviewable) warnings accumulated in the document.
Public method | GetWorksetId | Get Id of the Workset which owns the element.
Public method | GetWorksetTable | Get the WorksetTable of this document.
Public method | GetWorksharingCentralModelPath | Gets the central model path of the worksharing model.
Public method | HasAllChangesFromCentral | Returns whether the model in the current session is up to date with central.
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, AXMImportOptions, View) | Imports an AXM file into the document.
Public method | Import(String, ImportOptions3DM, View) | Imports a 3DM file into the document.
Public method | Import(String, OBJImportOptions, View) | Imports an OBJ file into the document.
Public method | Import(String, SATImportOptions, View) | Imports an SAT file into the document.
Public method | Import(String, SKPImportOptions, View) | Imports a SKP file into the document.
Public method | Import(String, STLImportOptions, View) | Imports an STL file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId%) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId%) | Imports a DWG or DXF file to the document.
Public method | IsBackgroundCalculationInProgress | Indicates whether there are any background calculations in progress for this document.
Public method | IsDefaultElementTypeIdValid | Checks whether the element type id is valid for the give DefaultElmentType id.
Public method | IsDefaultFamilyTypeIdValid | Checks whether the family type id is valid for the give family category.
Public method | IsPainted | Checks if the element's face is painted with a material.
 | IsValidVersionGUID | Checks whether the GUID is valid for the given document. Empty GUID is allowed.
Public method | Link(String, DWFImportOptions) | Links Markups in a DWF file into the project document.
Public method | Link(String, ImportOptions3DM, View) | Links a 3DM file into the project document.
Public method | Link(String, OBJImportOptions, View) | Links an OBJ file into the project document.
Public method | Link(String, SATImportOptions, View) | Links an SAT file into the project document.
Public method | Link(String, SKPImportOptions, View) | Links a SKP file into the project document.
Public method | Link(String, STLImportOptions, View) | Links an STL file into the project document.
Public method | Link(String, DGNImportOptions, View, ElementId%) | Links a DGN file into the project document.
Public method | Link(String, DWGImportOptions, View, ElementId%) | Links a DWG or DXF file into the project document.
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, IFamilyLoadOptions, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | MakeTransientElements | This method encapsulates the process of creating transient elements in the document.
Public method | Paint(ElementId, Face, ElementId) | Paint the element's face with specified material.
Public method | Paint(ElementId, Face, FamilyParameter) | Paint the element's face with specified material.
Public method | PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Public method | Print(ViewSet) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.
Public method | PublishCoordinates | Publish coordinates to the specified ProjectLocation of the link instance.
Public method | Regenerate | Updates the elements in the Revit document to reflect all changes.
Public method | ReloadLatest | Fetches changes from central (due to one or more synchronizations with central) and merges them into the current session.
Public method | RemovePaint | Remove the material painted on the element's face. If the face is currently not painted,it will do nothing.
Public method | ResetSharedCoordinates | Reset shared coordinates for the host model/file.
Public method | Save()()()() | Saves the document.
Public method | Save(SaveOptions) | Saves the document.
Public method | SaveAs(String) | Saves the document to a given file path.
Public method | SaveAs(String, SaveAsOptions) | Saves the document to a given file path.
Public method | SaveAs(ModelPath, SaveAsOptions) | Saves the document to a given path.
Public method | SaveAsCloudModel | Saves current non-workshared or workshared model as a cloud model or workshared cloud model in BIM 360 Docs or Autodesk Docs.
Public method | SaveCloudModel | Saves cloud model.
Public method | SaveToProjectAsImage | Creates an image view from the currently active view.
Public method | SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
Public method | SetDefaultElementTypeId | Sets the default element type id of the given DefaultElementType id.
Public method | SetDefaultFamilyTypeId | Sets the default family type id for the given family category.
Public method | SetUnits | Sets the units.
Public method | SynchronizeWithCentral | Performs reload latest until the model in the current session is up to date and then saves changes back to central. A save to central is performed even if no changes were made.
Public method | UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.

Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | Application | Returns the Application in which the Document resides.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CreationGUID | A unique identifier generated when the Document was first created.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
Public property | FamilyManager | The family manager object provides access to family types and parameters.
Public property | IsDetached | Identifies if a workshared document is detached. Also, see IsWorkshared
Public property | IsFamilyDocument | Identifies if the current document is a family document.
Public property | IsLinked | Identifies if a document is a linked RVT.
Public property | IsModelInCloud | Identifies if document is stored on Autodesk cloud services.
Public property | IsModifiable | Identifies if the document is modifiable.
Public property | IsModified | The state of changes made to the document.
Public property | IsReadOnly | Identifies if the document is read-only or can possibly be modified.
Public property | IsReadOnlyFile | Signals whether the document was opened from a read-only file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsWorkshared | Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document. Also, see IsDetached
Public property | MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | OwnerFamily | Get the Family of this Family Document.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | The fully qualified path of the document's disk file.
Public property | Phases | Retrieves all of the phases in the document.
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologies[([( Phase])]) | Gets the PlanTopologies of the current project in a given phase.
Public property | PlanTopology[([( Level])]) | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopology[([( Level, Phase])]) | Get the PlanTopology of a given level in a given phase.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | Title | The document's title.
Public property | TypeOfStorage | Get the storage type of the specified BuiltInParameter.
Public property | WorksharingCentralGUID | The central GUID of the server-based model.

Events

 | Name | Description
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class

AutoJoinElements Method

[image]