Revit 2024 API
KeyBasedTreeEntriesLoadContent Members
KeyBasedTreeEntriesLoadContent Class Methods Properties See Also Send Feedback

The KeyBasedTreeEntriesLoadContent type exposes the following members.

Methods

 | Name | Description
Public method | AddEntry | Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.
Public method | BuildEntries | Builds a KeyBasedTreeEntries object.
Public method | CanAddEntry | Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.
Public method | GetEntries | Gets a copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.
Public method | GetLoadResults | Returns a copy of the KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.
 | IsEntriesBuilt | Verifies that the KeyBasedTreeEntries object owned by a KeyBasedTreeEntriesLoadContent object is built.
Public method | Reset | Clears KeyBasedTreeEntriesLoadContent object, including KeyBasedTreeEntries and KeyBasedTreeEntriesLoadResults, owned by this KeyBasedTreeEntriesLoadContent object.

Properties

 | Name | Description

See Also

KeyBasedTreeEntriesLoadContent Class

KeyBasedTreeEntriesLoadContent Methods

[image] [image]