Revit 2024 API
CylindricalSurface Members
CylindricalSurface Class Methods Properties See Also Send Feedback

The CylindricalSurface type exposes the following members.

Methods

 | Name | Description
 | Create | Construct a cylindrical surface defined by a local coordinate system and a radius.
Public method | GetFrameOfReference | Returns frame of reference associated with this CylindricalSurface.

Properties

 | Name | Description
Public property | Axis | Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder.
Public property | Origin | Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder.
Public property | Radius | Radius of the circle that defines the base of this cylinder.
Public property | XDir | X axis of the local coordinate system associated with this cylinder.
Public property | YDir | Y axis of the local coordinate system associated with this cylinder.

See Also

CylindricalSurface Class

CylindricalSurface Methods

[image] [image]