Revit 2024 API
TessellatedBuildIssue Members
TessellatedBuildIssue Class Methods Properties See Also Send Feedback

The TessellatedBuildIssue type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TessellatedBuildIssue
Public method | GetIssueDescription | Gets a string describing the issue. If the issue does not present a problem, then an empty string is returned.
Public method | IsValidIssue | Reports whether the issue is well-formed, valid and does describe a real problem.
Public method | MakesDataUnusable | Reports whether this issue makes some data unusable ('true') or is only shows that data format conventions were broken, but the data are still usable (false).
Public method | ReportIssueToDataSource | Reports whether this issue should be reported to the company which wrote the software which produced the face set data (true), or to Autodesk (false).

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberEncountered | How many times this issue was encountered in its face set during the face set processing. This number can be less than the total number of such issues in the face set, as the face set processing could be aborted due to the presence of the issues which could not be handled.

See Also

TessellatedBuildIssue Class

TessellatedBuildIssue Methods

[image] [image]