Revit 2024 API
ComponentRepeaterIterator Methods
ComponentRepeaterIterator Class See Also Send Feedback

The ComponentRepeaterIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetCurrent | Returns the current repeater slot.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.

See Also

ComponentRepeaterIterator Class

Dispose Method

[image]