Revit 2024 API
ColorFillSchemeEntry Methods
ColorFillSchemeEntry Class See Also Send Feedback

The ColorFillSchemeEntry type exposes the following members.

Methods

 | Name | Description
Public method | CanSetValue(Double) | Checks whether StorageType of entry is Double and the value is no less than 0.0.
Public method | CanSetValue(Int32) | Checks whether StorageType of entry is Integer.
Public method | CanSetValue(ElementId) | Checks whether StorageType of entry is ElementId.
Public method | Dispose |
Public method | GetDoubleValue | Gets the Double value stored within the entry.
Public method | GetElementIdValue | Gets the ElementId value stored within the entry.
Public method | GetIntegerValue | Gets the Integer value stored within the entry.
Public method | GetStringValue | Gets the String value stored within the entry.
Public method | SetDoubleValue | Sets new Double value of entry.
Public method | SetElementIdValue | Sets new ElementId value of entry.
Public method | SetIntegerValue | Sets new Integer value of entry.
Public method | SetStringValue | Sets new String value of entry.

See Also

ColorFillSchemeEntry Class

CanSetValue Method

[image] [image]