Revit 2024 API
Toposolid..::..Create Method (Document, IList<(Of <(<'CurveLoop>)>)>, ElementId, ElementId)
Toposolid Class See Also Send Feedback
Creates a new instance of toposolid within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static Toposolid Create(
    Document document,
    IList<CurveLoop> profiles,
    ElementId topoTypeId,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profiles As IList(Of CurveLoop), _
    topoTypeId As ElementId, _
    levelId As ElementId _
) As Toposolid
Visual C++
public:
static Toposolid^ Create(
    Document^ document,
    IList<CurveLoop^>^ profiles,
    ElementId^ topoTypeId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new toposolid is created.
profiles
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
An array of planar curve loops that represent the profiles of the toposolid.
topoTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the toposolid type to be used by the new toposolid.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the toposolid is to be placed.

Return Value

A new toposolid object within the project if successful.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- The ElementId levelId is not a Level. -or- Toposolid type is not valid for this toposolid. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Toposolid Class
Create Overload

Create Method (Document, IList(CurveLoop), IList(XYZ), ElementId, ElementId)

[image]