Revit 2024 API
Transform Members
Transform Class Constructors Methods Operators Properties See Also Send Feedback

The Transform type exposes the following members.

Constructors

 | Name | Description
Public method | Transform | The copy constructor.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
 | CreateReflection | Creates a transform that represents a reflection across the given plane.
 | CreateRotation | Creates a transform that represents a rotation about the given axis at (0, 0, 0).
 | CreateRotationAtPoint | Creates a transform that represents a rotation about the given axis at the specified point.
 | CreateTranslation | Creates a transform that represents a translation via the specified vector.
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

Properties

 | Name | Description
Public property | Basis | Defines the basis of the old coordinate system in the new coordinate system.
Public property | BasisX | The basis of the X axis of this transformation.
Public property | BasisY | The basis of the Y axis of this transformation.
Public property | BasisZ | The basis of the Z axis of this transformation.
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection.
 | Identity | The identity transformation.
Public property | Inverse | The inverse transformation of this transformation.
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | Origin | Defines the origin of the old coordinate system in the new coordinate system.
Public property | Scale | The real number that represents the scale of the transformation.

See Also

Transform Class

Transform Constructor

[image]