Revit 2024 API
NurbSpline Members
NurbSpline Class Methods Properties See Also Send Feedback

The NurbSpline type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new geometric NurbSpline object from a HermiteSpline.
 | CreateCurve(HermiteSpline) | Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>)) | Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.

Properties

 | Name | Description
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
Public property | isRational | Returns whether the nurb spline is rational or not.
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class

Create Method

[image]