Revit 2024 API
Family Properties
Family Class See Also Send Feedback

The Family type exposes the following members.

Properties

 | Name | Description
Public property | CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
Public property | CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
Public property | CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
Public property | FamilyCategory | Retrieves or sets a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Public property | FamilyCategoryId | The id of the category or sub category in which the elements that this family could generate reside.
Public property | FamilyPlacementType | Identifies the type of placement required by a given family.
Public property | IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
Public property | IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
Public property | IsEditable | True if the family supports editing, false otherwise.
Public property | IsInPlace | True if the family is an in-place family, false if the family is a loadable family.
Public property | IsOwnerFamily | True if the family is the owner family for its own editable document, false otherwise.
Public property | IsParametric | Identifies whether the family contains parametric relations between some of its elements.
Public property | IsUserCreated | Determine whether the family has been defined by the user.
Public property | ShowSpatialElementCalculationPoint | For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.
Public property | StructuralCodeName | The family's structural code name.
Public property | StructuralFamilyNameKey | The family's structural section shape name key.
Public property | StructuralMaterialType | The family's structural material type.
Public property | StructuralSectionShape | The family's structural section shape.

See Also

Family Class

CurtainPanelHorizontalSpacing Property

[image]