Revit 2024 API
MEPModel Members
MEPModel Class Methods Properties See Also Send Feedback

The MEPModel type exposes the following members.

Methods

 | Name | Description
Public method | GetAssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to.
Public method | GetElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.

Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

MEPModel Class

MEPModel Methods

[image] [image]