Revit 2024 API
AlphanumericRevisionSettings Members
AlphanumericRevisionSettings Class Constructors Methods Properties See Also Send Feedback

The AlphanumericRevisionSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AlphanumericRevisionSettings()()()() | Constructs an AlphanumericRevisionSettings with a simple, default sequence.
Public method | AlphanumericRevisionSettings(AlphanumericRevisionSettings) | Constructs a new copy of the input AlphanumericRevisionSettings object.
Public method | AlphanumericRevisionSettings(IList<(Of <<'(String>)>>), String, String) | Constructs an AlphanumericRevisionSettings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AlphanumericRevisionSettings
Public method | GetSequence | Gets a list containing the strings to be used as the numbering sequence for revisions with the Alphanumeric RevisionNumberType.
Public method | IsEqual | Determines whether a specified AlphanumericRevisionSettings is the same as 'this'.
Public method | IsValid | Determines whether the AlphanumericRevisionSettings object is in a valid state.
Public method | SetSequence | Sets the sequence of strings to be used as numbers for revisions with the Alphanumeric RevisionNumberType.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Prefix | The prefix string that will be prepended to the number of each revision with Alphanumeric RevisionNumberingType.
Public property | Suffix | The suffix string that will be appended to the number of each revision with Alphanumeric RevisionNumberingType.

See Also

AlphanumericRevisionSettings Class

AlphanumericRevisionSettings Constructor

[image] [image]