Revit 2024 API
SlabShapeEditor Methods
SlabShapeEditor Class See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Methods

 | Name | Description
Public method | CreateCreasesFromFoldingLines | Convert selected folding lines to split lines
Public method | Dispose |
Public method | DrawPoint | Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
Public method | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the unmodified state.

See Also

SlabShapeEditor Class

CreateCreasesFromFoldingLines Method

[image]