Revit 2024 API
ConnectionValidationWarning Members
ConnectionValidationWarning Class Constructors Methods Properties See Also Send Feedback

The ConnectionValidationWarning type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionValidationWarning | Constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ConnectionValidationWarning
Public method | GetParts | Get ElementIds of affected parts.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Reason | Enumeration for reason of warning.
Public property | Resolution | Enumeration for resolution that was applied.

See Also

ConnectionValidationWarning Class

ConnectionValidationWarning Constructor

[image]