Revit 2024 API
FailureMessage Methods
FailureMessage Class See Also Send Feedback

The FailureMessage type exposes the following members.

Methods

 | Name | Description
Public method | AddResolution | Adds a resolution for the failure.
Public method | Dispose |
Public method | GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetFailingElements | Retrieves list of the elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetAdditionalElement | Sets the additional reference element for the failure.
Public method | SetAdditionalElements | Sets the additional reference elements for the failure.
Public method | SetFailingElement | Sets the element that has caused the failure.
Public method | SetFailingElements | Sets elements that have caused the failure.

See Also

FailureMessage Class

AddResolution Method

[image]