Revit 2024 API
IExportContext2D Members
IExportContext2D Interface Methods See Also Send Feedback

The IExportContext2D type exposes the following members.

Methods

Name Description
Public method OnElementBegin2D
This method marks the beginning of an element to be exported.
Public method OnElementEnd2D
This method marks the end of an element being exported.
Public method OnFaceEdge2D
This method is called when a Face edge is being output.
Public method OnFaceSilhouette2D
This method is called when a Face silhouette is being output.
Public method OnLineSegment
This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline
Public method OnPolylineSegments
This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

See Also

IExportContext2D Interface

IExportContext2D Methods

[image] [image]