Revit 2024 API
ElementArray Members
ElementArray Class Constructors Methods Properties See Also Send Feedback

The ElementArray type exposes the following members.

Constructors

 | Name | Description
Public method | ElementArray | Initializes a new instance of the ElementArray class

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every element from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets an element at a specified index within the array.
Public property | Size | Returns the number of elements that are in the array.

See Also

ElementArray Class

ElementArray Methods

[image] [image]