Revit 2024 API
CurtainSystem Members
CurtainSystem Class Methods Properties See Also Send Feedback

The CurtainSystem type exposes the following members.

Methods

 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.

Properties

 | Name | Description
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.

See Also

CurtainSystem Class

CurtainSystem Methods

[image] [image]