Revit 2024 API
RevitLinkGraphicsSettings Members
RevitLinkGraphicsSettings Class Constructors Methods Properties See Also Send Feedback

The RevitLinkGraphicsSettings type exposes the following members.

Constructors

 | Name | Description
Public method | RevitLinkGraphicsSettings | Creates a new RevitLinkGraphicsSettings instance.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RevitLinkGraphicsSettings

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkedViewId | The id of the linked view associated with this RevitLinkGraphicsSettings, or InvalidElementId if no view is selected. If the LinkVisibilityType is set to ByLinkView, then there must be a valid LinkedViewId.
Public property | LinkVisibilityType | The visibility type of RevitLinkGraphicsSettings. If the type is set to ByHostView or ByLinkView, then the dependent properties of RevitLinkGraphicsSettings will be reset to their default state. The state of dependent properties can be changed later.

See Also

RevitLinkGraphicsSettings Class

Dispose Method

[image]