Revit 2024 API
Level Members
Level Class Methods Properties See Also Send Feedback

The Level type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of level based on an input elevation.
Public method | FindAssociatedPlanViewId | Finds the id of the first available associated floor or structural plan view associated with this level.
 | GetNearestLevelId(Document, Double) | Returns id of the Level which is closest to the specified elevation.
 | GetNearestLevelId(Document, Double, Double%) | Returns id of the Level which is closest to the specified elevation.
Public method | GetPlaneReference | Returns a reference to this element as a plane.

Properties

 | Name | Description
Public property | Elevation | Retrieves or changes the elevation above or below the ground level.
Public property | ProjectElevation | Retrieves the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.

See Also

Level Class

Level Methods

[image] [image]