Revit 2024 API
DimensionType..::..GetSpecTypeId Method
DimensionType Class See Also Send Feedback
Gets the spec of this dimension style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ForgeTypeId GetSpecTypeId()
Visual Basic
Public Function GetSpecTypeId As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetSpecTypeId()

Return Value

Identifier of the spec.

Remarks

The spec will represent either length, angle or slope.

See Also

DimensionType Class

GetUnitsFormatOptions Method

[image]