Revit 2024 API
ExportLayerTable Members
ExportLayerTable Class Constructors Methods Properties See Also Send Feedback

The ExportLayerTable type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLayerTable | Constructs a new ExportLayerTable with default values.

Methods

 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export layer table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a layer key exists in the table.
Public method | Dispose | Releases all resources used by the ExportLayerTable
 | GetAvaliableLayerModifierTypes | Gets all the avaliable layer modifier types for the layer key.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLayerInfo | Gets a copy of the layer info associated to the input pattern key.
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLayerTableIterator | Returns a LayerTableIterator that iterates through the collection.
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) by pattern key.

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLayerInfo item that corresponds to the layer's ExportLayerKey.

See Also

ExportLayerTable Class

ExportLayerTable Constructor

[image]