Revit 2024 API
DirectShapeTypeOptions Properties
DirectShapeTypeOptions Class See Also Send Feedback

The DirectShapeTypeOptions type exposes the following members.

Properties

 | Name | Description
Public property | AllowDuplicateNames | Determines whether or not duplicate DirectShapeType names are allowed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DirectShapeTypeOptions Class

IsValidObject Property

[image]