Revit 2024 API
BuiltInFailures..::..DuctFailures Properties
BuiltInFailures..::..DuctFailures Class See Also Send Feedback

The BuiltInFailures..::..DuctFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.
PartNotFoundDueToNoDuctConnectedError | "In order to find a matching part, the fitting has to be connected to a duct."
PartNotFoundDueToNoDuctConnectedWarning | "In order to find a matching part, the fitting has to be connected to a duct."

See Also

BuiltInFailures..::..DuctFailures Class

CannotCreateGeometryForDuct Property

[image]