Revit 2024 API
SiteLocation Methods
SiteLocation Class See Also Send Feedback

The SiteLocation type exposes the following members.

Methods

 | Name | Description
Public method | ConvertFromProjectTime | Converts project time to UTC time.
Public method | ConvertToProjectTime | Converts local time or UTC time to project time.
Public method | IsCompatibleWith | Checks whether the geographic coordinate system of this site is compatible with the given site . True if he geographic coordinate system of this site is compatible with the given site, false otherwise.
Public method | SetGeoCoordinateSystem | Set the geographic coordinate system for this site. Similar to acquire coordinate system from a link in the UI.

See Also

SiteLocation Class

ConvertFromProjectTime Method

[image]