Revit 2024 API
BuiltInFailures..::..PerformanceFailures Properties
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback

The BuiltInFailures..::..PerformanceFailures type exposes the following members.

Properties

Name | Description
ClippingIsDisabled | View has clipping disabled. It causes view to draw too many elements.
DisjoinedSolidsInInPlaceFamily | In-place family contains multiple disjoined solids. Consider splitting in several in-place families.
DuplicateInstances | There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.
FamilyContainsViewSpecificImports | Family definition contains view-specific imports. Such imports are inaccessible in the project - consider removal.
HostHasTooManyInserts | Host object contains too many cutting inserts - it may take long time to update. Consider splitting host object into smaller pieces or using stacked walls.
InteriorCategoriesEnabledInLargeView | Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.
LargeFamilyFile | Family occupies XXX kilobytes of memory. Consider simplification of the family.
ManyElementInFamily | Family definition contains too many elements. Consider simplification of the family.
ManyUnusedNestedFamilies | Family contains other families loaded into it but not used. Consider purging family document from unused families and types.
MultipleLoopsInSketch | Sketch of <element> contains multiple independent loops - splitting it in few independent elements might improve performance.
TooLargeSketch | Sketch of <element> has large area - it may slow down selection, drawing and geometric computations.
TooManyAreaBoundaryLinesFound | There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.
TooManyElementsInSketch | Sketch of <element> contains too many objects - it may take long time to solve.
UnjoinedRoomSeparationLinesFound | Room Separation of <element> is not joined, might cause performance issue with room boundaries computations.
UnusedTypesInTheProject | Project contains unused families and/or types. Consider purging them out.
ViewDetailLevelIsHighInLargeView | A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.
WallsOverlap | Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.

See Also

BuiltInFailures..::..PerformanceFailures Class

ClippingIsDisabled Property

[image]