Revit 2024 API
SunAndShadowSettings Properties
SunAndShadowSettings Class See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Properties

 | Name | Description
Public property | ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
Public property | ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Public property | Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | EndDateAndTime | Identifies the end date and time.
Public property | GroundPlaneHeight | Identifies the ground plane height.
Public property | GroundPlaneLevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Public property | Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Public property | Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Public property | NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
Public property | ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
Public property | ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
Public property | RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
Public property | SharesSettings | Identifies whether settings are shared globally.
Public property | StartDateAndTime | Identifies the start or current date and time.
Public property | SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
Public property | SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
Public property | TimeInterval | Identifies the time interval between animation frames.
Public property | TimeZone | Identifies the time zone.
Public property | UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
Public property | UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
Public property | Visible | Visibility in current view for a per-view SunAndShadowSettings element.

See Also

SunAndShadowSettings Class

ActiveFrameTime Property

[image]