Revit 2024 API
PointCloudInstance Members
PointCloudInstance Class Methods Properties See Also Send Feedback

The PointCloudInstance type exposes the following members.

Methods

 | Name | Description
Public method | ContainsScan | Identifies whether the instance contains a scan.
 | Create | Creates a new instance of a point cloud based on an input point cloud type and transformation.
Public method | GetPoints | Extracts a collection of points based on a filter.
Public method | GetRegions | Returns array of region names.
Public method | GetScanOrigin | Returns the origin point of a scan in model coordinates.
Public method | GetScans | Returns array of scan names.
Public method | GetSelectionFilter | Returns the currently active selection filter for this point cloud.
Public method | HasColor | Returns true if at least one scan of the element have color, false otherwise.
Public method | SetSelectionFilter | Sets active selection filter by cloning of the one passed to it.

Properties

 | Name | Description
Public property | FilterAction | The action taken based on the results of the selection filter applied to this point cloud.
Public property | SupportsOverrides | Identifies whether the instance can have graphic overrides.

See Also

PointCloudInstance Class

PointCloudInstance Methods

[image] [image]