Revit 2024 API
FaceArray Members
FaceArray Class Constructors Methods Properties See Also Send Feedback

The FaceArray type exposes the following members.

Constructors

 | Name | Description
Public method | FaceArray | Initializes a new instance of the FaceArray class

Methods

 | Name | Description
Public method | Append | Add the face to the end of the array.
Public method | Clear | Removes every face from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified face into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a face at a specified index within the array.
Public property | Size | Returns the number of faces that are in the array.

See Also

FaceArray Class

FaceArray Methods

[image] [image]