Revit 2024 API
DirectShapeLibrary..::..AddDefinition Method (String, IList<(Of <(<'GeometryObject>)>)>)
DirectShapeLibrary Class See Also Send Feedback
Add a definition to be reused by instances. A definition is a collection of geometry objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddDefinition(
    string id,
    IList<GeometryObject> GNodes
)
Visual Basic
Public Sub AddDefinition ( _
    id As String, _
    GNodes As IList(Of GeometryObject) _
)
Visual C++
public:
void AddDefinition(
    String^ id,
    IList<GeometryObject^>^ GNodes
)

Parameters

id
Type: System..::..String
ID of the definition to be added. Must be unique.
GNodes
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Definition as a list of Geometry objects

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeLibrary Class
AddDefinition Overload

AddDefinitionType Method

[image]