Revit 2024 API
DividedPath Methods
DividedPath Class See Also Send Feedback

The DividedPath type exposes the following members.

Methods

 | Name | Description
 | AreCurveReferencesConnected | This checks if the references represent a connected set of curves as required by the divided path.
 | Create(Document, IList<(Of <<'(Reference>)>>)) | Creates a new instance of a divided path with a default layout.
 | Create(Document, IList<(Of <<'(Reference>)>>), ICollection<(Of <<'(ElementId>)>>)) | Creates a new instance of a divided path whose points are determined by the intersecting elements.
Public method | Flip | Toggle the flipped value
Public method | GetIntersectingElements | Get the elements whose intersection with path produces points.
 | IsCurveReferenceValid | This returns true if the reference represents a curve or edge that can be used to create a divided path.
 | IsIntersectorValidForCreation | This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public method | IsIntersectorValidForDividedPath | This returns true if the intersector is an element that can be used to intersect with the divided path.
Public method | IsValidBeginningIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public method | IsValidEndIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
 | IsValidFixedNumberOfPoints | Identifies if the indicated number of points is valid for assignment to a DividedPath with a layout type 'FixedNumber'.
Public method | IsValidMeasurementType | Checks that the measurement type enumeration value is valid
Public method | IsValidSpacingRuleJustification | Checks that the justification enumeration value is valid
Public method | IsValidSpacingRuleLayout | Checks that the spacing rule layout enumeration value is valid
 | SeparateReferencesIntoConnectedReferences | This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.
Public method | SetIntersectingElements | Set the elements whose intersection with path produces points.

See Also

DividedPath Class

AreCurveReferencesConnected Method

[image]