Revit 2024 API
FamilyInstance Methods
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element.
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family.
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference.
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance.
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance.
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance.
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance.
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default.
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile.
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
Public method | SetCopingIds | Specifies the set of coping cutters on this element.
Public method | Split | Splits the family instance element at a point on its defining curve.

See Also

FamilyInstance Class

AddCoping Method

[image]