Revit 2024 API
IExternalResourceServer Members
IExternalResourceServer Interface Methods See Also Send Feedback

The IExternalResourceServer type exposes the following members.

Methods

 | Name | Description
Public method | AreSameResources | Implement this method to indicate whether two given resources are the same.
Public method | GetIconPath | Implement this method to return the path to an icon file which will be displayed in Revit user interfaces associated to this server.
Public method | GetInformationLink | The method that Revit will invoke to obtain a URL address which provides more information about the server.
Public method | GetInSessionPath | Implement this method to provide the path that should be used for display and browsing to a given ExternalResourceReference during this Revit session.
Public method | GetResourceVersionStatus | Implement this method to indicate whether the given version of a resource is the most current version of the data.
Public method | GetShortName | Implement this method to return the short name of the server.
Public method | GetTypeSpecificServerOperations | Implement this method to get operations supported by the external server for a particular type of external resource.
Public method | IsResourceWellFormed | Implement this method to check whether the given ExternalResourceReference is formatted correctly for this server.
Public method | LoadResource | Implement this method to load the requested resource.
Public method | SetupBrowserData | Implement this method to setup external resource browser data which will be accessed in Revit external resource browser UI.
Public method | SupportsExternalResourceType | Implement this method to indicate whether the server can provide data for a specified type of external resource.

See Also

IExternalResourceServer Interface

IExternalResourceServer Methods

[image] [image]