Revit 2024 API
CurveElement Methods
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Methods

 | Name | Description
 | CreateAreaBasedLoadBoundaryLine | Creates an area based load boundary line.
 | CreateAreaBasedLoadBoundaryLines | Creates area based load boundary lines.
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point.
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable.
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element.
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point.
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point.
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point.
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end.
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry.
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement.
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point.

See Also

CurveElement Class

CreateAreaBasedLoadBoundaryLine Method

[image]