Revit 2024 API
FailureDefinition Members
FailureDefinition Class Methods Properties See Also Send Feedback

The FailureDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddResolutionType | Adds a type of possible resolution for the failure.
 | CreateFailureDefinition | Creates an instance of a FailureDefinition.
Public method | Dispose | Releases all resources used by the FailureDefinition
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Severity | The severity of the failure.

See Also

FailureDefinition Class

FailureDefinition Methods

[image] [image]