Revit 2024 API
ThermalAsset Members
ThermalAsset Class Constructors Methods Properties See Also Send Feedback

The ThermalAsset type exposes the following members.

Constructors

 | Name | Description
Public method | ThermalAsset | Constructs an instance of ThermalAsset.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose | Releases all resources used by the ThermalAsset
Public method | Equals(ThermalAsset) | Determines whether this thermal asset is equal to another.
Public method | EqualsThermalOnly | Determines whether this thermal asset is equal to another, but ignore data from base class.

Properties

 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | Compressibility | The compressibility of the asset.
Public property | Density | The density of the asset.
Public property | ElectricalResistivity | The electrical resistivity of the asset.
Public property | Emissivity | The emissivity of the asset.
Public property | GasViscosity | The gas viscosity of the asset.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LiquidViscosity | The liquid viscosity of the asset.
Public property | Name | The name of the thermal asset.
Public property | Permeability | The permeability of the asset.
Public property | Porosity | The porosity of the asset.
Public property | Reflectivity | The reflectivity of the asset.
Public property | SpecificHeat | The specific heat of the asset.
Public property | SpecificHeatOfVaporization | The specific heat of vaporization of the asset.
Public property | ThermalConductivity | The thermal conductivity of the asset.
Public property | ThermalMaterialType | The type of material that this thermal asset describes (e.g. solid, liquid, gas.)
Public property | TransmitsLight | A boolean flag that indicates whether or not the asset transmits light.
Public property | VaporPressure | The vapor pressure of the asset.

See Also

ThermalAsset Class

ThermalAsset Constructor

[image]