Revit 2024 API
DGNExportOptions Members
DGNExportOptions Class Constructors Methods Properties See Also Send Feedback

The DGNExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DGNExportOptions()()()() | Constructs a new instance of DGNExportOptions with default values of all properties.
Public method | DGNExportOptions(DGNExportOptions) | Constructs a new instance of DGNExportOptions as a copy of the export options.

Methods

 | Name | Description
Public method | GetExportLineweightTable | Gets a copy of the line weight table.
 | GetPredefinedOptions | Returns an instance DGNExportOptions containing settings from a predefined export setup.
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of DGN export options.
Public method | SetExportLineweightTable | Sets the line weight table to use during export.

Properties

 | Name | Description
Public property | FileVersion | The DGN file version. Default value of fileVersion is DGNFileFormat.Default.
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.
Public property | SeedName | The name of the DGN seed. Default value of seedName is empty.
Public property | WorkingUnits | If true, Main Units will be used. If false, Sub Units will be used. Default value of WorkingUnits is true.

See Also

DGNExportOptions Class

DGNExportOptions Constructor

[image] [image]