Revit 2024 API
ConicalSurface Properties
ConicalSurface Class See Also Send Feedback

The ConicalSurface type exposes the following members.

Properties

 | Name | Description
Public property | Axis | Axis of the cone. This is the Z axis of the local coordinate system associated with this cone.
Public property | HalfAngle | Cone angle.
Public property | Origin | Apex of the cone. This is the origin of the local coordinate system associated with this cone.
Public property | XDir | X axis of the local coordinate system associated with this cone.
Public property | YDir | X axis of the local coordinate system associated with this cone.

See Also

ConicalSurface Class

Axis Property

[image]