Revit 2024 API
ElementPhaseStatusFilter Members
ElementPhaseStatusFilter Class Constructors Methods Properties See Also Send Feedback

The ElementPhaseStatusFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) | Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>)) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) | Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>), Boolean) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

Methods

 | Name | Description
Public method | GetPhaseStatuses | Returns the phase statuses assigned to this filter.

Properties

 | Name | Description
Public property | PhaseId | The phase id.

See Also

ElementPhaseStatusFilter Class

ElementPhaseStatusFilter Constructor

[image] [image]