Revit 2024 API
BRepBuilderPersistentIds Methods
BRepBuilderPersistentIds Class See Also Send Feedback

The BRepBuilderPersistentIds type exposes the following members.

Methods

 | Name | Description
Public method | AddSubTag | Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId. Note that an existing correspondence in the map cannot be updated and that a particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.
Public method | Dispose |
Public method | IsAssociatedBRepBuilderValid | Validates the associated (in the constructor) BRepBuilder for this BRepBuilderPersistentIds.
Public method | IsBRepBuilderGeometryIdFaceOrEdge | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.
Public method | IsValidBRepBuilderGeometryIdForNewCorrespondence | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.
Public method | IsValidExternalGeometryIdForNewCorrespondence | Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.

See Also

BRepBuilderPersistentIds Class

AddSubTag Method

[image]