Revit 2024 API
DirectShapeReferenceOptions Members
DirectShapeReferenceOptions Class Constructors Methods Properties See Also Send Feedback

The DirectShapeReferenceOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DirectShapeReferenceOptions()()()() | Constructs a new DirectShapeRefOptions instance with default settings.
Public method | DirectShapeReferenceOptions(DirectShapeReferenceOptions) | Constructs a new copy of the input DirectShapeRefOptions object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DirectShapeReferenceOptions
Public method | GetExternalGeometryId | Retrieves the ExternalGeometryId associated with the reference object.
 | IsValidExternalGeometryId | Validates that the input ExternalGeometryId can be assigned to a direct shape reference.
 | IsValidReferenceName | Validates that the input name can be assigned to a direct shape reference.
Public method | SetExternalGeometryId | Sets the ExternalGeometryId associated with the reference object. The ID must be non-empty.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name associated with the reference object. The name does not need to be unique. The name must not be empty and must contain valid characters.

See Also

DirectShapeReferenceOptions Class

DirectShapeReferenceOptions Constructor

[image]