Revit 2024 API
ColorFillSchemeEntry Members
ColorFillSchemeEntry Class Constructors Methods Properties See Also Send Feedback

The ColorFillSchemeEntry type exposes the following members.

Constructors

 | Name | Description
Public method | ColorFillSchemeEntry | Creates new ColorFillSchemeEntry.

Methods

 | Name | Description
Public method | CanSetValue(Double) | Checks whether StorageType of entry is Double and the value is no less than 0.0.
Public method | CanSetValue(Int32) | Checks whether StorageType of entry is Integer.
Public method | CanSetValue(ElementId) | Checks whether StorageType of entry is ElementId.
Public method | Dispose | Releases all resources used by the ColorFillSchemeEntry
Public method | GetDoubleValue | Gets the Double value stored within the entry.
Public method | GetElementIdValue | Gets the ElementId value stored within the entry.
Public method | GetIntegerValue | Gets the Integer value stored within the entry.
Public method | GetStringValue | Gets the String value stored within the entry.
Public method | SetDoubleValue | Sets new Double value of entry.
Public method | SetElementIdValue | Sets new ElementId value of entry.
Public method | SetIntegerValue | Sets new Integer value of entry.
Public method | SetStringValue | Sets new String value of entry.

Properties

 | Name | Description
Public property | Caption | The text displayed in [!:Autodesk::Revit::DB::ColorFillLegend] for this entry.
Public property | Color | The filling color of this entry.
Public property | FillPatternId | The id of fill pattern element of this entry.
Public property | IsInUse | Represents if there exists at least one element colored based on this entry in the document.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVisible | Represents if the element colored based on this entry is visible in views.
Public property | StorageType | The storage type of the value stored in this entry.

See Also

ColorFillSchemeEntry Class

ColorFillSchemeEntry Constructor

[image]