Revit 2024 API
ElementMulticlassFilter Constructor (IList<(Of <(<'Type>)>)>)
ElementMulticlassFilter Class See Also Send Feedback
Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementMulticlassFilter(
    IList<Type> typeList
)
Visual Basic
Public Sub New ( _
    typeList As IList(Of Type) _
)
Visual C++
public:
ElementMulticlassFilter(
    IList<Type^>^ typeList
)

Parameters

typeList
Type: System.Collections.Generic..::..IList<(Of <(<'Type>)>)>
The list of Element subclass types to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more input types are not valid subclasses of Element for this filter. -or- One or more of the types do not exist in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementMulticlassFilter Class
ElementMulticlassFilter Overload

ElementMulticlassFilter Constructor (IList(Type), Boolean)

[image]