Revit 2024 API
DocumentDifference Members
DocumentDifference Class Methods Properties See Also Send Feedback

The DocumentDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentDifference
Public method | GetCreatedElementIds | Created element id collection.
Public method | GetDeletedElementIds | Deleted element id collection. For non-worksharing models, this will always be an empty collection.
Public method | GetModifiedElementIds | Modified element id collection.

Properties

 | Name | Description
Public property | AreDeletedElementIdsAvailable | Whether or the deleted elements were retrieved.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DocumentDifference Class

Dispose Method

[image]