Revit 2024 API
Reference Methods
Reference Class See Also Send Feedback

The Reference type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Checks if given reference identifies part of object identified by this reference.
Public method | ConvertToStableRepresentation | Converts the reference to a stable String representation.
Public method | CreateLinkReference | Creates a Reference from a Reference in an RVT Link.
Public method | CreateReferenceInLink | Creates a Reference in an RVT Link from a Reference in the RVT host file.
Public method | EqualTo | Checks if given reference is equal to this reference.
 | ParseFromStableRepresentation | Converts a stable String representation of a reference to a Reference object.

See Also

Reference Class

Contains Method

[image]