Revit 2024 API
DirectShapeType..::..SetShape Method
DirectShapeType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetShape(IList<(Of <<'(GeometryObject>)>>)) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.

See Also

DirectShapeType Class
DirectShapeType Members

SetShape Method (IList(GeometryObject))

[image]