Revit 2024 API
SaveAsOptions Properties
SaveAsOptions Class See Also Send Feedback

The SaveAsOptions type exposes the following members.

Properties

 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumBackups | The maximum number of backups to keep on disk.
Public property | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

See Also

SaveAsOptions Class

Compact Property

[image]