Revit 2024 API
FormArray Members
FormArray Class Constructors Methods Properties See Also Send Feedback

The FormArray type exposes the following members.

Constructors

 | Name | Description
Public method | FormArray | Initializes a new instance of the FormArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every form from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a form at a specified index within the array.
Public property | Size | Returns the number of forms that are in the array.

See Also

FormArray Class

FormArray Constructor

[image]