Revit 2024 API
ViewShapeBuilder..::..ValidateCurve Method
ViewShapeBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateCurve(Curve) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.
 | ValidateCurve(Curve, DirectShapeTargetViewType) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException

See Also

ViewShapeBuilder Class
ViewShapeBuilder Members

ValidateCurve Method (Curve)

[image]