Revit 2024 API
ControlledApplication Properties
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | AllUsersAddinsLocation | The folder location for .addin files for all users.
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentUserAddinsLocation | The folder location for .addin files for the current user.
Public property | CurrentUsersAddinsDataFolderPath | Path to AddinsData folder for the current user.
Public property | CurrentUsersDataFolderPath | Path to data folder for the current user.
Public property | IsLateAddinLoading | Indicates whether this add-in is loaded on the fly or not. If it is loaded when is Revit starting up, it is false, otherwise it should be true.
Public property | Language | The language used in the current session of Revit.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | SubVersionNumber | The minor version number of Revit
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

ActiveAddInId Property

[image]