Revit 2024 API
ElementMulticategoryFilter Constructor
ElementMulticategoryFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>)) | Constructs a new instance of a filter to match elements by built-in category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>)) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>), Boolean) | Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>), Boolean) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Members

ElementMulticategoryFilter Constructor (ICollection(BuiltInCategory), Boolean)

[image]