Revit 2024 API
TableCellStyleOverrideOptions Properties
TableCellStyleOverrideOptions Class See Also Send Feedback

The TableCellStyleOverrideOptions type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | Indicates if the background color characteristic is overridden.
Public property | Bold | Indicates if the bold characteristic is overridden.
Public property | BorderBottomLineStyle | Indicates if the border bottom line style characteristic is overridden.
Public property | BorderLeftLineStyle | Indicates if the border left line style characteristic is overridden.
Public property | BorderLineStyle | Indicates if the border line style characteristic is overridden.
Public property | BorderRightLineStyle | Indicates if the border right line style characteristic is overridden.
Public property | BorderTopLineStyle | Indicates if the border top line style characteristic is overridden.
Public property | Font | Indicates if the font name characteristic is overridden.
Public property | FontColor | Indicates if the font color characteristic is overridden.
Public property | FontSize | Indicates if the font size characteristic is overridden.
Public property | HorizontalAlignment | Indicates if the horizontal alignment characteristic is overridden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Italics | Indicates if the italics characteristic is overridden.
Public property | TextOrientation | Indicates if the text orientation characteristic is overridden.
Public property | Underline | Indicates if the underline characteristic is overridden.
Public property | VerticalAlignment | Indicates if the vertical alignment characteristic is overridden.

See Also

TableCellStyleOverrideOptions Class

BackgroundColor Property

[image]