Revit 2024 API
BuiltInFailures..::..LoadFailures Properties
BuiltInFailures..::..LoadFailures Class See Also Send Feedback

The BuiltInFailures..::..LoadFailures type exposes the following members.

Properties

Name | Description
AreaLoadNotOverlappingHost | Area load is not overlapping with its entire distribution its host.
CannotCopyHostedLoad | Can't copy Load based on the Host Element.
CannotMirrorHostedLoad | Can't mirror Load based on the Host Element.
CannotMirrorLoad | Can't mirror Load because mirror plane is not perpendicular to sketch plane.
CannotMoveHostedLoad | Can't move Load based on the Host Element.
CannotRotateLoad | Can't rotate Load because rotation axis is not perpendicular to sketch plane.
InvalidAreaLoadSketchError | Area Load has invalid Sketch.
LineLoadAllZero | Line Load can't have all force components and moment components to be zero.
LineLoadNotOverlappingHost | Line load is not overlapping with its entire distribution its host.
OpenAreaLoadLoopError | Area Load Sketch can't contain open loops.
PointLoadAllZero | Point Load can't have all force components and moment components to be zero.
PointLoadNotOverlappingHost | Point load is not overlapping with its entire distribution its host.

See Also

BuiltInFailures..::..LoadFailures Class

AreaLoadNotOverlappingHost Property

[image]