Revit 2024 API
GroupSet Members
GroupSet Class Constructors Methods Properties See Also Send Feedback

The GroupSet type exposes the following members.

Constructors

 | Name | Description
Public method | GroupSet | Initializes a new instance of the GroupSet class

Methods

 | Name | Description
Public method | Clear | Removes every group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a group within the set.
Public method | Erase | Removes a specified group from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified group into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of groups that are in the set.

See Also

GroupSet Class

GroupSet Constructor

[image]