Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

 | Name | Description
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (Face, Line, FamilySymbol)

[image]