Revit 2024 API
ScheduleField Properties
ScheduleField Class See Also Send Feedback

The ScheduleField type exposes the following members.

Properties

 | Name | Description
Public property | ColumnHeading | The column heading text.
Public property | Definition | The ScheduleDefinition that this field belongs to.
Public property | DisplayType | Indicates the chosen display type for the field.
Public property | FieldId | The ID of the field in the containing ScheduleDefinition.
Public property | FieldIndex | The index of the field in the containing ScheduleDefinition.
Public property | FieldType | The type of data displayed by the field.
Public property | GridColumnWidth | The width of the column in the editable grid view, measured in feet.
Public property | HasSchedulableField | Identifies if this ScheduleField object has access to a SchedulableField. Calculated and combined parameter fields will not have the access.
Public property | HeadingOrientation | The orientation of the column heading text.
Public property | HorizontalAlignment | The horizontal alignment of the column's data.
Public property | IsCalculatedField | Indicates if the field is a calculated field (Formula or Percentage).
Public property | IsCombinedParameterField | Indicates if the field is a combined parameter field.
Public property | IsHidden | Indicates if the field is hidden in the schedule.
Public property | IsOverridden | Indicates if the field is overridden or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultipleValuesCustomText | The custom multiple values text to be used when the schedule field displays multiple element values, used when MultipleValuesDisplayType is set to Custom.
Public property | MultipleValuesDisplayType | Determines the type of multiple value indication to be used when the schedule field displays multiple element values.
Public property | MultipleValuesText | The multiple values text to be used when the schedule field displays multiple element values, as specified by the display type MultipleValuesDisplayType.
Public property | ParameterId | The ID of the parameter displayed by the field.
Public property | PercentageBy | The ID of the grouped schedule field used to calculate percentage totals.
Public property | PercentageOf | The ID of the field to calculate percentages of.
Public property | Schedule | The schedule that this field belongs to.
Public property | SheetColumnWidth | The width of the column on a sheet, measured in feet.
Public property | TotalByAssemblyType | In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.
Public property | VerticalAlignment | The vertical alignment of the column's data.

See Also

ScheduleField Class

ColumnHeading Property

[image]