Revit 2024 API
ParameterFilterElement..::..AllRuleParametersApplicable Method (Document, ICollection<(Of <(<'ElementId>)>)>, ElementFilter)
ParameterFilterElement Class See Also Send Feedback
Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public static bool AllRuleParametersApplicable(
    Document aDocument,
    ICollection<ElementId> categories,
    ElementFilter elementFilter
)
Visual Basic
Public Shared Function AllRuleParametersApplicable ( _
    aDocument As Document, _
    categories As ICollection(Of ElementId), _
    elementFilter As ElementFilter _
) As Boolean
Visual C++
public:
static bool AllRuleParametersApplicable(
    Document^ aDocument,
    ICollection<ElementId^>^ categories,
    ElementFilter^ elementFilter
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document containing the filter, categories, and parameters involved in this validation.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of categories against which to check the rule parameters.
elementFilter
Type: Autodesk.Revit.DB..::..ElementFilter
The ElementFilter representing the combination of rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterElement Class
AllRuleParametersApplicable Overload

ClearRules Method

[image]