Revit 2024 API
ExtrusionAnalyzer Members
ExtrusionAnalyzer Class Methods Properties See Also Send Feedback

The ExtrusionAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | CalculateFaceAlignment | Calculates the alignment status of each face of the solid.
 | Create | Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public method | Dispose | Releases all resources used by the ExtrusionAnalyzer
Public method | GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis.

Properties

 | Name | Description
Public property | EndParameter | The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Public property | ExtrusionDirection | The direction of extrusion specified for the extrusion analysis.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartParameter | The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

See Also

ExtrusionAnalyzer Class

ExtrusionAnalyzer Methods

[image] [image]