Revit 2024 API
FilteredElementIdIterator Methods
FilteredElementIdIterator Class See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetCurrent | The current element id found by the iterator.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element id passing the filter.
Public method | Reset | Resets the iterator to the beginning.

See Also

FilteredElementIdIterator Class

Dispose Method

[image]