Revit 2024 API
ViewSchedule Methods
ViewSchedule Class See Also Send Feedback

The ViewSchedule type exposes the following members.

Methods

 | Name | Description
Public method | CanGroupHeaders | Indicates if selected headers can be grouped for this schedule.
Public method | CanUngroupHeaders | Indicates if selected headers can be ungrouped.
 | CreateKeynoteLegend | Creates a keynote legend.
 | CreateKeySchedule | Create a key schedule.
 | CreateMaterialTakeoff | Creates a material takeoff.
 | CreateNoteBlock | Creates a note block.
 | CreateRevisionSchedule | Creates a revision schedule.
 | CreateSchedule(Document, ElementId) | Creates a regular schedule.
 | CreateSchedule(Document, ElementId, ElementId) | Creates a regular schedule that can relate to a specific area scheme.
 | CreateSheetList | Creates a sheet list.
 | CreateViewList | Creates a view list.
Public method | DeleteSegment | Deletes a schedule segment.
Public method | Export | Exports the schedule data to a text file.
 | GetDefaultNameForKeynoteLegend | Gets the default view name that will be used when creating a keynote legend.
 | GetDefaultNameForKeySchedule | Gets the default view name that will be used when creating a key schedule.
 | GetDefaultNameForMaterialTakeoff | Gets the default view name that will be used when creating a material takeoff.
 | GetDefaultNameForNoteBlock | Gets the default view name that will be used when creating a note block.
 | GetDefaultNameForRevisionSchedule | Gets the default view name that will be used when creating a revision schedule.
 | GetDefaultNameForSchedule(Document, ElementId) | Gets the default view name that will be used when creating a regular schedule.
 | GetDefaultNameForSchedule(Document, ElementId, ElementId) | Gets the default view name that will be used when creating a schedule.
 | GetDefaultNameForSheetList | Gets the default view name that will be used when creating a sheet list.
 | GetDefaultNameForViewList | Gets the default view name that will be used when creating a view list.
 | GetDefaultParameterNameForKeySchedule | Gets the default parameter name that will be used when creating a key schedule.
Public method | GetScheduleHeightsOnSheet | Gets the heights of schedule title, column header and each schedule body row.
Public method | GetScheduleInstances | Gets the instances ids of schedule or schedule segment.
Public method | GetSegmentCount | Gets the total count of schedule segments.
Public method | GetSegmentHeight | Gets the segment height.
Public method | GetStripedRowsColor | Gets the color applied to part of the pattern for a schedule with striped rows.
Public method | GetTableData | Gets the writable table data object.
 | GetValidCategoriesForKeySchedule | Gets a list of categories that can be used for a key schedule.
 | GetValidCategoriesForMaterialTakeoff | Gets a list of categories that can be used for a material takeoff.
 | GetValidCategoriesForSchedule | Gets a list of categories that can be used for a regular schedule.
 | GetValidFamiliesForNoteBlock | Gets a list of families that can be used for a note block.
Public method | GroupHeaders | Groups schedule header cells.
Public method | HasImageField | Checks whether the schedule definition includes any image-related fields and if any elements in the schedule actually have images in those fields.
Public method | IsDataOutOfDate | Indicates whether the schedule data is out of date.
Public method | IsSplit | Checks if the schedule is split.
 | IsValidCategoryForKeySchedule | Checks whether a category can be used for a key schedule.
 | IsValidCategoryForMaterialTakeoff | Checks whether a category can be used for a material takeoff.
 | IsValidCategoryForSchedule | Checks whether a category can be used for a regular schedule.
 | IsValidFamilyForNoteBlock | Checks whether a family can be used for a note block.
Public method | IsValidTextTypeId | Identifies if the input id represents a valid text type id for use in the schedule properties.
Public method | MergeSegments | Merges two adjacent segments into one.
Public method | RefreshData | Rebuilds the schedule data if it is out of date.
Public method | RestoreImageSize | Restores all images to their original sizes.
Public method | SetSegmentHeight | Sets the segment height.
Public method | SetStripedRowsColor | Sets the color applied to part of the pattern for a schedule with striped rows.
Public method | Split(IList<(Of <<'(Double>)>>)) | Splits the schedule into several segments by given height of each segment.
Public method | Split(Int32) | Splits the schedule into several segments by given segment number.
Public method | SplitSegment | Splits the schedule segment by the given heights of new segments.
Public method | UngroupHeaders | Ungroups selected headers of schedule.

See Also

ViewSchedule Class

CanGroupHeaders Method

[image]