Revit 2024 API
LinePattern Members
LinePattern Class Constructors Methods Properties See Also Send Feedback

The LinePattern type exposes the following members.

Constructors

 | Name | Description
Public method | LinePattern()()()() | Creates a simple line pattern.
Public method | LinePattern(String) | Creates a line pattern with given name.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinePattern
Public method | GetSegments | Gets the sequence of segments that defines this line pattern.
Public method | SetSegments | Sets the sequence of segments that defines this line pattern.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Line pattern name.

See Also

LinePattern Class

LinePattern Constructor

[image]