Revit 2024 API
ElementMulticategoryFilter Constructor (ICollection<(Of <(<'BuiltInCategory>)>)>, Boolean)
ElementMulticategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementMulticategoryFilter(
    ICollection<BuiltInCategory> categories,
    bool inverted
)
Visual Basic
Public Sub New ( _
    categories As ICollection(Of BuiltInCategory), _
    inverted As Boolean _
)
Visual C++
public:
ElementMulticategoryFilter(
    ICollection<BuiltInCategory>^ categories,
    bool inverted
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' BuiltInCategory >)>)>
The built-in categories to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given built-in categories.

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload

ElementMulticategoryFilter Constructor (ICollection(ElementId), Boolean)

[image]