Revit 2024 API
Mesh..::..MaterialElementId Property
Mesh Class See Also Send Feedback
Element ID of the material from which this mesh is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId MaterialElementId { get; }
Visual Basic
Public ReadOnly Property MaterialElementId As ElementId
    Get
Visual C++
public:
property ElementId^ MaterialElementId {
    ElementId^ get ();
}

See Also

Mesh Class

NumberOfNormals Property

[image]