Revit 2024 API
ProjectPosition Members
ProjectPosition Class Constructors Methods Properties See Also Send Feedback

The ProjectPosition type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectPosition(ProjectPosition) | Creates a copy of the ProjectPosition.
Public method | ProjectPosition(Double, Double, Double, Double) | Construct a new ProjectPosition with the specified East/West offset, North/South offset, elevation offset, and angle of rotation.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ProjectPosition

Properties

 | Name | Description
Public property | Angle | Angle from True North.
Public property | EastWest | East/West offset.
Public property | Elevation | Elevation above ground level.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NorthSouth | North/South offset

See Also

ProjectPosition Class

ProjectPosition Constructor

[image] [image]