Revit 2024 API
Document..::..NewFlexPipe Method (Connector, IList<(Of <(<'XYZ>)>)>, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flexible pipe into the document, using a connector, point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector,
    IList<XYZ> points,
    FlexPipeType pipeType
)
Visual Basic
Public Function NewFlexPipe ( _
    connector As Connector, _
    points As IList(Of XYZ), _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector,
    IList<XYZ^>^ points,
    FlexPipeType^ pipeType
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The connector to be connected to the flexible pipe, including the end points.
points
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The point array indicating the path of the flexible pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector's direction matches the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector or points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the flexible pipe type does not exist in the given document.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace

NewFootPrintRoof Method

[image]