Revit 2024 API
Document..::..Export Method (String, String, ICollection<(Of <(<'ElementId>)>)>, DGNExportOptions)
Document Class Example See Also Send Feedback
Exports a selection of views in DGN format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    DGNExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ICollection(Of ElementId), _
    options As DGNExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    DGNExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used. If nullNothingnullptra null reference (Nothing in Visual Basic), throw ArgumentException.
views
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Selection of views to be exported. The set must contain at least one valid view.
options
Type: Autodesk.Revit.DB..::..DGNExportOptions
Various options applicable to the DGN format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Examples

CopyC#
public bool ExportDGN(Document document, View view)
{
    bool exported = false;
    // Get predefined setups and use the first one
    IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
    if (setupNames.Count > 0)
    {
        // Get predefined options for first predefined setup
        DGNExportOptions dgnOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames[0]);

        // export the active view if it is printable
        if (view.CanBePrinted == true)
        {
            ICollection<ElementId> views = new List<ElementId>();
            views.Add(view.Id);
            exported = document.Export(Path.GetDirectoryName(document.PathName),
                Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions);
        }
    }

    return exported;
}
CopyVB.NET
Public Function ExportDGN(document As Document, view As View) As Boolean
   Dim exported As Boolean = False
   ' Get predefined setups and use the first one
   Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
   If setupNames.Count > 0 Then
      ' Get predefined options for first predefined setup
      Dim dgnOptions As DGNExportOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames(0))

      ' export the active view if it is printable
      If view.CanBePrinted = True Then
         Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
         views.Add(view.Id)
         exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions)
      End If
   End If

   Return exported
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- some of the views are not printable (exportable). -or- Thrown when the options in DGNExportOptions is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the directory does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DWG module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.

See Also

Document Class
Export Overload

Export Method (String, String, ICollection(ElementId), DWGExportOptions)

[image]