Revit 2024 API
FamilyItemFactory Members
FamilyItemFactory Class Methods Properties See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Methods

 | Name | Description
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.
Public method | NewBlend | Add a new Blend instance into the Autodesk Revit family document.
Public method | NewControl | Add a new control into the Autodesk Revit family document.
Public method | NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
Public method | NewDiameterDimension | Creates a new diameter dimension object using the default dimension type.
Public method | NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
Public method | NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
Public method | NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Public method | NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Public method | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.
Public method | NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
Public method | NewModelText | Create a model text in the Autodesk Revit family document.
Public method | NewOpening | Create an opening to cut the wall or ceiling.
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.
Public method | NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
Public method | NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
Public method | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
Public method | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.
Public method | NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Public method | NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.

Properties

 | Name | Description

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

FamilyItemFactory Methods

[image] [image]