Revit 2024 API
Viewport Properties
Viewport Class See Also Send Feedback

The Viewport type exposes the following members.

Properties

 | Name | Description
Public property | LabelLineLength | The length of the viewport label line in sheet space, measured in feet.
Public property | LabelOffset | The offset is a two-dimensional vector from left bottom corner of the viewport with Rotation set to None to the left end of the viewport label line. The Z coordinate is ignored.
Public property | Rotation | The rotation of the viewport on the sheet.
Public property | SheetId | The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.
Public property | ViewId | The element id of the associated View.
Public property | ViewportPositioning | Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter.

See Also

Viewport Class

LabelLineLength Property

[image]