Revit 2024 API
DirectShapeType Methods
DirectShapeType Class See Also Send Feedback

The DirectShapeType type exposes the following members.

Methods

 | Name | Description
Public method | AddExternallyTaggedGeometry | Adds the externally tagged geometry object to the DirectShapeType.
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShapeType.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShapeType.
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShapeType.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShapeType.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>)) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeTypeOptions are allowed for this particular DirectShapeType.
Public method | AreValidDirectShapeReferenceOptions | Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShapeType.
Public method | CanChangeFamilyName | Checks whether the DirectShapeType supports a custom family name.
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShapeType element.
 | Create(Document, String, ElementId) | Creates a DirectShapeType element.
 | Create(Document, String, ElementId, DirectShapeTypeOptions) | Creates a DirectShapeType element.
Public method | GetExternallyTaggedGeometry | Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.
Public method | GetExternallyTaggedReference | Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.
Public method | GetOptions | Gets a copy of the current options for this DirectShapeType.
Public method | HasExternalGeometry | Checks whether the externally tagged geometry is already present in this DirectShapeType.
Public method | HasExternallyTaggedReference | Checks if the externally tagged reference is already present in this DirectShapeType.
 | IsValidReferenceCurve | Validates that the input curve is suitable for creating a direct shape type reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
 | IsValidReferencePlaneBoundingBoxUV | Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>)) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.
Public method | IsValidUsage | Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShapeType.
Public method | RemoveAllReferenceObjects | Removes all reference objects (if any) from the DirectShapeType.
Public method | RemoveExternallyTaggedGeometry | Removes the externally tagged geometry object by its external ID from this DirectShapeType.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | ResetExternallyTaggedGeometry | Removes all of the externally tagged geometry in this DirectShapeType.
Public method | SetFamilyName | Sets the family name for the DirectShapeType.
Public method | SetOptions | Sets the options to use for this DirectShapeType.
Public method | SetShape(IList<(Of <<'(GeometryObject>)>>)) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | UpdateExternallyTaggedGeometry | Updates the externally tagged geometry object in the DirectShapeType.

See Also

DirectShapeType Class

AddExternallyTaggedGeometry Method

[image]