Revit 2024 API
BRepBuilderPersistentIds Members
BRepBuilderPersistentIds Class Constructors Methods Properties See Also Send Feedback

The BRepBuilderPersistentIds type exposes the following members.

Constructors

 | Name | Description
Public method | BRepBuilderPersistentIds | Constructs a new BRepBuilderPersistentIds and associates the existing BRepBuilder to it.

Methods

 | Name | Description
Public method | AddSubTag | Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId. Note that an existing correspondence in the map cannot be updated and that a particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.
Public method | Dispose | Releases all resources used by the BRepBuilderPersistentIds
Public method | IsAssociatedBRepBuilderValid | Validates the associated (in the constructor) BRepBuilder for this BRepBuilderPersistentIds.
Public method | IsBRepBuilderGeometryIdFaceOrEdge | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.
Public method | IsValidBRepBuilderGeometryIdForNewCorrespondence | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.
Public method | IsValidExternalGeometryIdForNewCorrespondence | Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BRepBuilderPersistentIds Class

BRepBuilderPersistentIds Constructor

[image]