Revit 2024 API
Application..::..NewFamilyInstanceCreationData Method
Application Class See Also Send Feedback
Creates an adaptive component which wraps the arguments of NewFamilyInstance() for batch creation.
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Overload List

 | Name | Description
Public method | NewFamilyInstanceCreationData(FamilySymbol, IList<(Of <<'(XYZ>)>>)) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace

NewFamilyInstanceCreationData Method (FamilySymbol, IList(XYZ))

[image]