Revit 2024 API
LinePatternElement Methods
LinePatternElement Class See Also Send Feedback

The LinePatternElement type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new LinePatternElement.
Public method | GetLinePattern()()()() | Gets the LinePattern associated to this element.
 | GetLinePattern(Document, ElementId) | Gets the LinePattern associated to an element or from a built-in line pattern.
 | GetLinePatternElementByName | Retrieves the LinePatternElement by its name.
 | GetSolidPatternId | Gets the solid line pattern element id.
Public method | SetLinePattern | Sets the LinePattern associated to this element.

See Also

LinePatternElement Class

Create Method

[image]