Revit 2024 API
DocumentPreviewSettings Members
DocumentPreviewSettings Class Methods Properties See Also Send Feedback

The DocumentPreviewSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentPreviewSettings
Public method | ForceViewUpdate | Sets Revit to update the preview view if necessary.
Public method | IsViewIdValidForPreview | Identifies if the view id is valid as a preview view id.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsViewUpdateForced | Identifies if Revit will update the preview view if necessary.
Public property | PreviewViewId | The view id that will be used to generate the preview.

See Also

DocumentPreviewSettings Class

DocumentPreviewSettings Methods

[image] [image]