Revit 2024 API
SymbolicCurveArray Members
SymbolicCurveArray Class Constructors Methods Properties See Also Send Feedback

The SymbolicCurveArray type exposes the following members.

Constructors

 | Name | Description
Public method | SymbolicCurveArray | Initializes a new instance of the SymbolicCurveArray class

Methods

 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.

See Also

SymbolicCurveArray Class

SymbolicCurveArray Constructor

[image]