Revit 2024 API
TessellatedShapeBuilder Properties
TessellatedShapeBuilder Class See Also Send Feedback

The TessellatedShapeBuilder type exposes the following members.

Properties

 | Name | Description
Public property | Fallback | Defines acceptable fallback if the desired type of geometry can't be built.
Public property | GraphicsStyleId | Optional - if set, the built geometry will use that graphics style.
Public property | IsFaceSetOpen | Flag whether the current set of connected faces is open and additional tessellation faces can be added to it.
Public property | LogInteger | Integer value used for logging, if it is performed. Usually the number of the face set(s) in the IFC file, from which they are imported. Any value is acceptable.
Public property | LogString | String used for logging, if any. Usually the name of the file from which face sets were imported.
Public property | NumberOfCompletedFaceSets | Number of completed face sets.
Public property | OwnerInfo | String used for logging, if any. Usually describes the element or object, which either defined or will own the geoemtrical objects to be built.
Public property | Target | Requests the type of geometry to be built.

See Also

TessellatedShapeBuilder Class

Fallback Property

[image]