Revit 2024 API
InternalDefinition Members
InternalDefinition Class Methods Properties See Also Send Feedback

The InternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the InternalDefinition
Public method | GetGroupTypeId | Gets the identifier of the built-in parameter group to which the parameter defined by this definition belongs. (Overrides Definition..::..GetGroupTypeId()()()().)
Public method | GetParameterTypeId | Tests whether this definition identifies a built-in parameter or not.
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | SetAllowVaryBetweenGroups | Whether or not the parameter values can vary across group members.
Public method | SetGroupTypeId | Sets the built-in parameter group to which the parameter defined by this definition belongs.

Properties

 | Name | Description
Public property | BuiltInParameter | Tests whether this definition identifies a built-in parameter or not.
Public property | Id | The id of the parameter.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The user-visible name for the parameter. (Overrides Definition..::..Name.)
Public property | ParameterGroup | Obsolete. Id of a built-in parameter group to which the parameter defined by this definition belongs. (Overrides Definition..::..ParameterGroup.)
Public property | VariesAcrossGroups | Whether or not the parameter values can vary across group members.
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

InternalDefinition Class

InternalDefinition Methods

[image] [image]