Revit 2024 API
Face..::..MaterialElementId Property
Face Class See Also Send Feedback
The element ID of the material from which this face is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId MaterialElementId { get; }
Visual Basic
Public ReadOnly Property MaterialElementId As ElementId
    Get
Visual C++
public:
property ElementId^ MaterialElementId {
    ElementId^ get ();
}

See Also

Face Class

OrientationMatchesSurfaceOrientation Property

[image]