Revit 2024 API
ElementMulticategoryFilter Members
ElementMulticategoryFilter Class Constructors Methods Properties See Also Send Feedback

The ElementMulticategoryFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>)) | Constructs a new instance of a filter to match elements by built-in category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>)) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>), Boolean) | Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>), Boolean) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.

Methods

 | Name | Description
Public method | GetCategoryIds | Gets the category ids assigned to this filter.

Properties

 | Name | Description

See Also

ElementMulticategoryFilter Class

ElementMulticategoryFilter Constructor

[image] [image]