Revit 2024 API
FabricationPart Properties
FabricationPart Class See Also Send Feedback

The FabricationPart type exposes the following members.

Properties

 | Name | Description
Public property | Alias | The alias of the fabrication part.
Public property | BottomOfPartElevation | The associated elevation to the bottom of fabrication part off of the current level.
Public property | CenterlineLength | The centerline length of the fabrication part.
Public property | ConnectorManager | The connector manager of the fabrication part.
Public property | CutType | The cut type of the fabrication part.
Public property | DomainType | The domain type for the fabrication part.
Public property | DoubleWallMaterial | The double wall material identifier of the fabrication part.
Public property | DoubleWallMaterialArea | The double wall material area of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | DoubleWallMaterialThickness | The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | FreeSize | The inner size of the fabrication part.
Public property | GeometryChecksum | Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position.
Public property | HangerRodKit | Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used.
Public property | HasDoubleWall | True if the fabrication part is double walled.
Public property | HasInsulation | True if the fabrication part is insulated.
Public property | HasLining | True if the fabrication part is lined.
Public property | InsulationArea | The insulation area of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationSpecification | The fabrication part insulation specification identifier.
Public property | InsulationThickness | The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationType | The insulation type of the fabrication part.
Public property | IsBoughtOut | True if the fabrication part is bought out.
Public property | ItemCustomId | The item custom identifier for the fabrication part.
Public property | ItemNumber | The item number that is used for identification, re-ordering from shop.
Public property | LevelOffset | The associated level offset that indicates the distance from the center of the fabrication part to the current level.
Public property | LiningArea | The lining area of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningThickness | The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningType | The lining type of the fabrication part.
Public property | Material | The fabrication material identifier.
Public property | MaterialGauge | The fabrication material gauge identifier.
Public property | MaterialThickness | The material thickness of the fabrication part.
Public property | Notes | The notes of the fabrication part.
Public property | Origin | The origin of the fabrication part element.
Public property | OverallSize | The overall size of the fabrication part.
Public property | PartGuid | The fabrication part's globally unique identifier.
Public property | PartStatus | The status identifier for the fabrication part.
Public property | ProductCode | The current database id of the part within the fabrication database.
Public property | ProductDataRange | The product data range of the fabrication part.
Public property | ProductFinishDescription | The product finish description of the fabrication part.
Public property | ProductInstallType | The product install type of the fabrication part.
Public property | ProductListEntry | The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list.
Public property | ProductLongDescription | The product long description of the fabrication part.
Public property | ProductMaterialDescription | The product material description of the fabrication part.
Public property | ProductName | The product name of the fabrication part.
Public property | ProductOriginalEquipmentManufacture | The product original equipment manufacture (OEM) of the fabrication part.
Public property | ProductShortDescription | The product short description of the fabrication part.
Public property | ProductSizeDescription | The product size description of the fabrication part.
Public property | ProductSpecificationDescription | The product specification description of the fabrication part.
Public property | ServiceAbbreviation | The associated service abbreviation for the fabrication service.
Public property | ServiceId | The fabrication part service identifier. The service can only be changed to compatible services.
Public property | ServiceName | The name of the service associated with the fabrication part.
Public property | ServiceType | The service type identifier of the fabrication part.
Public property | SheetMetalArea | The sheet metal area of the fabrication part.
Public property | Size | The size of the fabrication part.
Public property | Slope | The slope for the straight fabrication part.
Public property | Specification | The fabrication part specification identifier.
Public property | SpoolName | The spool name of the fabrication part.
Public property | TopOfPartElevation | The associated elevation to the top of fabrication part off of the current level.
Public property | ValidationStatus | The validation status of the fabrication part.
Public property | Vendor | The vendor of the fabrication part.
Public property | VendorCode | The vendor code of the fabrication part.
Public property | Weight | The weight of the fabrication part.

See Also

FabricationPart Class

Alias Property

[image]