Revit 2024 API
SubTransaction Methods
SubTransaction Class See Also Send Feedback

The SubTransaction type exposes the following members.

Methods

 | Name | Description
Public method | Commit | Commits all changes made to the model made during the sub-transaction.
Public method | Dispose |
Public method | GetStatus | Returns the current status of the sub-transaction.
Public method | HasEnded | Determines whether the sub-transaction has ended already.
Public method | HasStarted | Determines whether the sub-transaction has been started yet.
Public method | RollBack | Discards all changes made to the model during the sub-transaction.
Public method | Start | Starts the sub-transaction.

See Also

SubTransaction Class

Commit Method

[image]