Revit 2024 API
ElementParameterFilter Constructor (IList<(Of <(<'FilterRule>)>)>)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter from a set of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementParameterFilter(
    IList<FilterRule> filterRules
)
Visual Basic
Public Sub New ( _
    filterRules As IList(Of FilterRule) _
)
Visual C++
public:
ElementParameterFilter(
    IList<FilterRule^>^ filterRules
)

Parameters

filterRules
Type: System.Collections.Generic..::..IList<(Of <(<' FilterRule >)>)>
The rules applied to test if the element passes this filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filterRules array is empty or invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementParameterFilter Class
ElementParameterFilter Overload

ElementParameterFilter Constructor (FilterRule, Boolean)

[image]