Revit 2024 API
TessellatedFace Constructor (IList<(Of <(<'IList<(Of <(<'XYZ>)>)>>)>)>, ElementId)
TessellatedFace Class See Also Send Feedback
Constructs a tessellated face, which, may be, have holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public TessellatedFace(
    IList<IList<XYZ>> allLoopVertices,
    ElementId materialId
)
Visual Basic
Public Sub New ( _
    allLoopVertices As IList(Of IList(Of XYZ)), _
    materialId As ElementId _
)
Visual C++
public:
TessellatedFace(
    IList<IList<XYZ^>^>^ allLoopVertices,
    ElementId^ materialId
)

Parameters

allLoopVertices
Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<' XYZ >)>)>>)>)>
Boundary vertices without duplication of the ends - i.e., a boundary of a triangular face consists of 3 (and NOT 4) vertices. The first array describes the outer loop, the following arrays, if any - inner loops. It is expected that vertices of outer boundary are listed in CCW order with respect to the face normal in the solid, while the vertices of inner loops - in CW order. The vertices listed in the wrong order will still be handled by TessellatedShapeBuilder, but performance may deteriorate. Contents of this parameter will be changed while constructing the face.
materialId
Type: Autodesk.Revit.DB..::..ElementId
Material of the face to be used when the result is a Solid or a Sheet. If the result is a Mesh, a material will be assigned to the entire Mesh.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TessellatedFace Class
TessellatedFace Overload

TessellatedFace Methods

[image] [image]