Revit 2024 API
ForgeTypeId Members
ForgeTypeId Class Constructors Methods Operators Properties See Also Send Feedback

The ForgeTypeId type exposes the following members.

Constructors

 | Name | Description
Public method | ForgeTypeId()()()() | Constructs a ForgeTypeId holding an empty schema identifier.
Public method | ForgeTypeId(String) | Constructs a ForgeTypeId holding the given schema identifier.

Methods

 | Name | Description
Public method | Clear | Sets the typeId to an empty string
Public method | Dispose | Releases all resources used by the ForgeTypeId
Public method | Empty | Checks if the typeId is an empty string
Public method | Equals | Determines whether this ForgeTypeId is equal to another. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Returns the hash code for this ForgeTypeId (Overrides Object..::..GetHashCode()()()().)
Public method | NameEquals | Returns true if the typeid string held by this ForgeTypeId is equal to that held by the given ForgeTypeId, excluding the version number. The version number of a typeid string follows a hyphen character. This function compares the typeid strings up to the first hyphen. This is the default equality comparison method for the ForgeTypeId class, used by the equality operator (==).
Public method | StrictlyEquals | Returns true if the entire typeid string held by this ForgeTypeId is exactly equal to that held by the given ForgeTypeId. For the default equality comparison used by the equality operator (==), see NameEquals(ForgeTypeId).

Operators

Name | Description
Equality |
Inequality |
LessThan |

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TypeId | The schema identifier.

See Also

ForgeTypeId Class

ForgeTypeId Constructor

[image] [image]