Revit 2024 API
IFCExportOptions Members
IFCExportOptions Class Constructors Methods Properties See Also Send Feedback

The IFCExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExportOptions()()()() | Default constructor. Initializes FileVersion to Default. WallAndColumnSplitting and ExportBaseQuantities are set to false. FamilyMappingFile is set to empty.
Public method | IFCExportOptions(IFCExportOptions) | Creates a copy of an IFCExportOptions.

Methods

 | Name | Description
Public method | AddOption | Adds a new named option to the options structure.
Public method | Assign | Assigns the values of the IFCExportOptions to this options object.
Public method | Dispose | Releases all resources used by the IFCExportOptions

Properties

 | Name | Description
Public property | ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
Public property | FamilyMappingFile | Path to a file containing family mapping.
Public property | FileVersion | IFC file version.
Public property | FilterViewId | Id of the view whose visibility settings will govern the contents in the exported IFC file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpaceBoundaryLevel | Level of space boundaries exported in IFC file.
Public property | WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.

See Also

IFCExportOptions Class

IFCExportOptions Constructor (IFCExportOptions)

[image]