Revit 2024 API
Document..::..NewFlexPipe Method (IList<(Of <(<'XYZ>)>)>, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flexible pipe into the document, using a point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlexPipe NewFlexPipe(
    IList<XYZ> points,
    FlexPipeType pipeType
)
Visual Basic
Public Function NewFlexPipe ( _
    points As IList(Of XYZ), _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    IList<XYZ^>^ points,
    FlexPipeType^ pipeType
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The point array indicating the path of the flexible pipe, including the end points.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the flexible pipe type does not exist in the given document.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace

NewFlexPipe Method (Connector, IList(XYZ), FlexPipeType)

[image]