Revit 2024 API
BuiltInFailures..::..ConstraintFailures Properties
BuiltInFailures..::..ConstraintFailures Class See Also Send Feedback

The BuiltInFailures..::..ConstraintFailures type exposes the following members.

Properties

Name | Description
UndeletedConstraints | A dimension that has lock constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
UndeletedConstraintsEQ | A dimension that has EQ constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
UndeletedConstraintsInGroup | A labeled dimension is being deleted, but the corresponding constraint belongs to a group and will not be changed. You can change it in group edit mode later.
UndeletedConstraintsLabel | A dimension labeled by a parameter is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..

See Also

BuiltInFailures..::..ConstraintFailures Class

UndeletedConstraints Property

[image]