Revit 2024 API
ComponentRepeaterSlot Members
ComponentRepeaterSlot Class Methods Properties See Also Send Feedback

The ComponentRepeaterSlot type exposes the following members.

Methods

 | Name | Description
Public method | IsTypeValidForSlot | Determines whether instance of given family type can be used in the component repeater slot.
Public method | MakeDefault | Populates the slot with an instance of the default family type of the component repeater.
Public method | MakeEmpty | Makes the slot empty by removing the instance currently held by the slot.

Properties

 | Name | Description
Public property | FamilyType | The id of the family type of the component in the slot, or invalid id if the slot is empty.
Public property | IsDefault | A flag indicating whether the slot currently holds an instance of the default family type of the component repeater.
Public property | IsEmpty | A flag indicating whether the slot is currently empty.

See Also

ComponentRepeaterSlot Class

ComponentRepeaterSlot Methods

[image] [image]