Revit 2024 API
RepeatingReferenceSource Methods
RepeatingReferenceSource Class See Also Send Feedback

The RepeatingReferenceSource type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetBounds | Returns information about the boundaries of the repeating reference array.
 | GetDefaultRepeatingReferenceSource | Returns the default repeating reference source for a given element.
Public method | GetReference | Returns an individual repeating reference given by coordinates in the array, or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no reference at the coordinates (for example if there is a hole in a divided surface.)
 | HasRepeatingReferenceSource | Determines whether an element has any repeating reference sources that can be used when creating component repeaters.

See Also

RepeatingReferenceSource Class

Dispose Method

[image]