Revit 2024 API
DirectShape..::..SetShape Method (IList<(Of <(<'GeometryObject>)>)>)
DirectShape Class See Also Send Feedback
Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetShape(
    IList<GeometryObject> pGeomArr
)
Visual Basic
Public Sub SetShape ( _
    pGeomArr As IList(Of GeometryObject) _
)
Visual C++
public:
void SetShape(
    IList<GeometryObject^>^ pGeomArr
)

Parameters

pGeomArr
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Shape of this object expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
SetShape Overload

SetShape Method (ShapeBuilder)

[image]