Revit 2024 API
ShapeImporter Properties
ShapeImporter Class See Also Send Feedback

The ShapeImporter type exposes the following members.

Properties

 | Name | Description
Public property | DefaultLengthUnit | The length unit to be used if not specified when the input is a unitless SAT file.
Public property | InputFormat | The format of the incoming data.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ShapeImporter Class

ShapeImporterSourceFormat Enumeration

[image]