Revit 2024 API
LineSegment Properties
LineSegment Class See Also Send Feedback

The LineSegment type exposes the following members.

Properties

 | Name | Description
Public property | EndParameter | Parameter associated with the end point.
Public property | EndPoint | End point of the line segment.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineProperties | Access to the line (pen) properties of the line
Public property | StartParameter | Parameter associated with the start point.
Public property | StartPoint | Start point of the line segment.

See Also

LineSegment Class

EndParameter Property

[image]