Revit 2024 API
BindingMap Members
BindingMap Class Methods Properties See Also Send Feedback

The BindingMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::..Clear()()()().)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::..Contains(Definition).)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::..Erase(Definition).)
Public method | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMap..::..Insert(Definition, Binding).)
Public method | Insert(Definition, Binding, BuiltInParameterGroup) | Obsolete. Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | Insert(Definition, Binding, ForgeTypeId) | Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
Public method | ReInsert(Definition, Binding, BuiltInParameterGroup) | Obsolete. Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | ReInsert(Definition, Binding, ForgeTypeId) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | Remove | The Remove method is used to remove a parameter binding.

Properties

 | Name | Description
Public property | Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap..::..Item[([( Definition])]) .)

See Also

BindingMap Class

BindingMap Methods

[image] [image]