Revit 2024 API
ScheduleField Methods
ScheduleField Class See Also Send Feedback

The ScheduleField type exposes the following members.

Methods

 | Name | Description
Public method | CanDisplayMinMax | Indicates if this field can display minimum and maximum values.
Public method | CanTotal | Indicates if totals can be enabled for this field.
Public method | CanTotalByAssemblyType | Indicates if totals by assembly type can be enabled for this field.
Public method | CreatesCircularReferences | Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.
Public method | Dispose |
Public method | GetCombinedParameters | Gets this field's combine parameter array if applicable
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return nullNothingnullptra null reference (Nothing in Visual Basic).
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetName | Gets the name of the field.
Public method | GetSchedulableField | Gets a SchedulableField object representing this field.
Public method | GetSpecTypeId | The spec describing values of this field, if applicable.
Public method | GetStyle | Gets the style of this field.
Public method | IsValidCombinedParameters | Checks if data is valid for combined parameters
Public method | ResetOverride | Resets the override of this field.
Public method | SetCombinedParameters | Sets this field's combine parameter array if applicable
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | SetStyle | Sets the style of this field.

See Also

ScheduleField Class

CanDisplayMinMax Method

[image]