Revit 2024 API
SpacingRule Properties
SpacingRule Class See Also Send Feedback

The SpacingRule type exposes the following members.

Properties

 | Name | Description
Public property | BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Public property | Distance | The exact distance between layout lines.
Public property | GridlinesRotation | An additional rotation to be applied to this set of grid lines.
Public property | HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
Public property | Justification | The justification of the lines within the region.
Public property | Layout | A choice of several gridline layout rules.
Public property | Number | The exact number of lines in the region.
Public property | Offset | An additional offset applied to the first gridline.

See Also

SpacingRule Class

BeltMeasurement Property

[image]