Revit 2024 API
BuiltInFailures..::..AutoRouteFailures Properties
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback

The BuiltInFailures..::..AutoRouteFailures type exposes the following members.

Properties

Name | Description
AttemptToConnectNonSlopingElementToSlopedPipeError | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
AttemptToConnectNonSlopingElementToSlopedPipeWarning | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
DesignOptionConflictError | The solution is failing to do the elements are not in the same Design Option.
DesignOptionConflictWarning | The solution is failing to do the elements are not in the same Design Option.
DistributionTypeInvalid | Selected distribution system type is invalid!
ElementHasFlowCalculation | This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.
ElementHasOpenConnection | This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.
FailedDowngradeCrossToElbow | Failed to downgrade tee type to elbow type.
FailedDowngradeCrossToTee | Failed to downgrade cross type to tee type.
FailedDowngradeTeeToCross | Failed to upgrade tee type to cross type.
FailToDoCompatiblePhaseError | The solution is failing to do the elements Phases are compatible.
FailToDoCompatiblePhaseWarning | The solution is failing to do the elements Phases are compatible.
FailToIntersectParallelSegmentsError | The solution is failing to do segments which are parallel and should intersect.
FailToIntersectParallelSegmentsWarning | The solution is failing to do segments which are parallel and should intersect.
FittingParamsCauseGeometryToFailError | The one of parameters for the fitting is causing the geometry to fail.
FittingParamsCauseGeometryToFailWarning | The one of parameters for the fitting is causing the geometry to fail.
HighlightedElementDisconnected | The highlighted element has been disconnected.
InappropriateSlopeForPipe | The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.
MismatchedSystemClassificationHasSystemWarning | The selected fixture is part of a system with different classification. System calculations (e.g. flow analysis) are not possible between systems with different classifications.
MismatchedSystemClassificationNoSystemWarning | The selected fixture is assigned to a system with different classification.
MismatchedSystemTypeWarning | The selected fixture is part of a different system. You may want to edit the system type and merge two systems.
NoAutoRouteSolutionFoundError | No auto-route solution was found.
NoAutoRouteSolutionFoundWarning | No auto-route solution was found.
NoFittingInProjectError | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInProjectWarning | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInRoutingError | The fitting that is converted to was not defined. Please assign one in the routing preference.
NoFittingLoadedInProjectError | The fitting that is converted to was not defined. Please load one fitting family and assign it in the routing preference.
NoSolutionInView | There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.
NotAllPartsWereConvertedCannotAddPlaceholderWarning | Not all parts were converted. Placeholders could not be added to fill the gap (the gap was too small). Check the fabrication service definition for the system.
NotAllPartsWereConvertedPlaceholdersWereAddedWarning | Not all parts were converted. Placeholders were added to fill the gaps. Check the fabrication service definition for the system.
NotEnoughRoomForFittingsError | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NotEnoughRoomForFittingsWarning | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NoValidSolutionAtSelectedPoint | No valid auto-route solution at selected point.
OverrideFabricationPartFailed | The fabrication part cannot be overridden. The button code you specified does not match the fabrication service. Please specify a different button code or check the fabrication service and try again.
SegmentDrawnFromWrongSideError | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentDrawnFromWrongSideWarning | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentsAngleTooGreatError | The resulting angle between the segments is too great.
SegmentsAngleTooGreatWarning | The resulting angle between the segments is too great.
SolutionIsOppositeToConnectionError | The solution is in the opposite direction of the connection direction.
SolutionIsOppositeToConnectionWarning | The solution is in the opposite direction of the connection direction.
SpecifiedAnglesNotCompatibleWithLayoutError | The specified angles are not compatible with current layout.
SpecifiedAnglesNotCompatibleWithLayoutWarning | The specified angles are not compatible with current layout.
UnableToMakeConnectionInDirection | The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.
UtilizationCoefficientOutOfRange | The value for Coefficient of Utilization must be between 0 and 1.
ZeroLengthSegmentError | The solution is failing to do segments which are zero length.
ZeroLengthSegmentWarning | The solution is failing to do segments which are zero length.

See Also

BuiltInFailures..::..AutoRouteFailures Class

AttemptToConnectNonSlopingElementToSlopedPipeWarning Property

[image]