Revit 2024 API
ElementPhaseStatusFilter Constructor
ElementPhaseStatusFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) | Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>)) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) | Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>), Boolean) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Members

ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus)

[image]