Revit 2024 API
DividedSurface Members
DividedSurface Class Methods Properties See Also Send Feedback

The DividedSurface type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectionElement | Adds an intersection element to the divided surface.
 | CanBeDivided | This returns true if the reference represents a face that can be used to create a divided surface.
Public method | CanBeIntersectionElement | Checks if the element can be an intersection reference.
 | Create | Creates a new instance of a divided surface with a default layout.
Public method | GetAllIntersectionElements | Gets all intersection elements which produce division lines.
 | GetDividedSurfaceForReference | Get a divided surface for a given reference. Returns null if the reference does not host a divided surface.
Public method | GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
Public method | GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
Public method | GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
Public method | GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
 | GetReferencesWithDividedSurfaces | For a given host element get references to all the faces that host a divided surface
Public method | GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
Public method | GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
Public method | IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
Public method | RemoveAllIntersectionElements | Removes all the intersection elements from a divided surface.
Public method | RemoveIntersectionElement | Removes an intersection element from a divided surface.

Properties

 | Name | Description
Public property | AllGridRotation | Angle of rotation applied to the U- and V- directions together.
Public property | BorderTile | Determines the handling of tiles that overlap the surface's boundary.
Public property | ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
Public property | Host | The element whose surface has been divided.
Public property | HostReference | A reference to the divided face on the host.
Public property | IsComponentFlipped | Whether the pattern is flipped.
Public property | IsComponentMirrored | Whether the pattern is mirror-imaged.
Public property | NumberOfUGridlines | Get the number of U-gridlines used on the surface.
Public property | NumberOfVGridlines | Get the number of V-gridlines used on the surface.
Public property | UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
Public property | USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
Public property | VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
Public property | VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.

See Also

DividedSurface Class

DividedSurface Methods

[image] [image]