Revit 2024 API
ElementCategoryFilter Members
ElementCategoryFilter Class Constructors Methods Properties See Also Send Feedback

The ElementCategoryFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementCategoryFilter(BuiltInCategory) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(ElementId) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(BuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Public method | ElementCategoryFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | CategoryId | The category id.

See Also

ElementCategoryFilter Class

ElementCategoryFilter Constructor

[image] [image]