Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures Properties
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback

The BuiltInFailures..::..MEPFabricationFailures type exposes the following members.

Properties

Name | Description
AdditionalPartNotLoaded | An additional part was not loaded.
CannotConvertFlexPipeToPart | Cannot convert flex pipe to fabrication part.
CannotMatchFabricationHangerSizeToHost | The hanger cannot be re-sized to match the re-sized host.
FabDbChangeConn | Fabrication Database changes altered connectivity
FabDbOpenJobConn | Fabrication job imported had bad connectivity
FabDbSwapOut | Fabrication Database reload could not swap out for newer parts.
FabricationConfigurationCorrupted | It looks that the Fabrication Configuration %1!s! was corrupted, please check it at %2!s!.
FabricationHangerCannotBeSloped | A hanger cannot be sloped or placed on a sloped element.
FabricationHangerHostNotFound | The hanger will disconnect because we can't find the suitable host.
FabricationHangerNotConnectToHost | Fabrication Hanger didn't connect to the %s host.
FabricationHangerOutOfHost | The hanger is out of its host and will be disconnected.
FabricationHangerSizeNotMatch | The hanger size does not match the size of the host, so it can not be connected.
FabricationOutOfSizeCondition | The fabrication part size is not within the correct size range for the service button condition.
FabricationOverSizedCheck | Fabrication part is too large to fit on the sheet metal. Replace the part with multiple smaller parts, or notify the CAM operator.
FabricationPartCannotBeMirrored |
FabricationPartCannotChangeServiceSizeWarning | The selected fitting(s) cannot successfully change service or change size. You must disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeSlopeError | The connected fitting(s) cannot successfully change to the new slope value. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeBadDimError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions or be constrained due to connected fitting(s). You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeBadDimUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions, resulting in bad geometry.
FabricationPartCannotChangeTypeError | The selected fitting(s) cannot successfully change the type. You must disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeIncompatError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeIncompatUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry.
FabricationPartCannotChangeTypeMisalignedError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeMisalignedUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry.
FabricationPartCannotChangeTypeUnConnError | The selected fitting(s) cannot successfully change the type.
FabricationPartCannotChangeTypeWarning | The selected fitting(s) cannot maintain connections to existing fabrication parts due to size, direction or angle differences. You must manually reconnect the open connections.
FabricationPartExceededAngleFlexToleranceWarning | The angle flex is greater than the maximum angle flex tolerance defined by the fabrication part. Connections with this part may not be properly aligned and may appear to be skewed.
FabricationPartExcludedPartWarning | There were fabrication parts needed to the make the connection that were excluded from the fabrication service causing the connection to fail. You may try to inlcude these fitting(s) and try again.
FabricationPartFitFailure | Fabrication Part Fitting Failed to Fit
FabricationPartFitFailWarning | Fabrication Part Fitting Failed to Fit
FabricationPartHasInvalidGeometry | The fabrication part either has no material or has badly configured dimensions, resulting in bad geometry.
FabricationPartInvalidConnection | Fabrication Part connection invalid and could not be automatically coupled.
FabricationPartInvalidSpecification | The part specification is invalid.
FabricationPartNoPartTypeFound | There are no fabrication part types found for the current Configuration and Service. Please select settings and reload the service to create the fabrication part types.
FabricationPartNotAttachedToStraight | The part must be attached to straight.
FabricationPartOptimizeInvalidConnection | No available couplings to connect standard lengths for this instance of straight.
FabricationRodDetachFromHangerError | The rod need to be detached from hanger.
FabricationRodsConnectionChangedWarning | The structural component that the hanger is attached to has changed to a different element.
FabricationRodsDisconnectedError | The hanger rod was disconnected because there is no structural component above.
FabricationRodsDisconnectedWarning | The hanger rod was disconnected because there is no structural component above.
FabricationServiceMismatch | Attempting to connect fabrication parts from different services.
FabricationStraigtLengthOversized | Fabrication straight exceeds the standard length. Use the Optimize Length command to adjust the length.
FixedFabricationPartNotChangeLength | Failed to change length of fixed part.
GroupedFabricationPartNotReposition | Failed to reposition part.
HangerProfileNotMatchWithHost | The defined hanger profile does not match with the host.
HangerWidthOutOfRange | The hanger width is too large to show.
InvalidConnectionsHaveBeenDisconnected | Invalid connections have been disconnected. Please reconnect them manually or use different fittings.
InvalidSelectionThereCannotBeOpenConnectors | Invalid selection there cannot be any open connectors for the design to fabrication part tool.
NoStructuralHostToAttachWarning | There is no structural component to attach the hanger rod to.
NotAllPartsWereConvertedUnsuportedFittingOffsets | Not all parts were converted. Eccentric transitions and taps that have offsets from the center line are unsupported and cannot be converted.
PinnedFabricationPartNotChangeExtension | Failed to change extension of part.
PinnedFabricationPartNotReposition | Failed to reposition part.
PlaceCutinFittingFailed | Failed to insert part.
SizeNotAvailableInFabricationService | Sizes:%1!s! in system %2!s! are not available in fabrication service:%3!s!, All available sizes are:\n%4!s!.
UneditableFabricationPartNotReposition | Failed to reposition part.

See Also

BuiltInFailures..::..MEPFabricationFailures Class

AdditionalPartNotLoaded Property

[image]