Revit 2024 API
ExportLayerInfo Methods
ExportLayerInfo Class See Also Send Feedback

The ExportLayerInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddCutLayerModifier | Adds a cut layer modifier to the layer info.
Public method | AddLayerModifier | Adds a project layer modifier to the layer info.
Public method | ClearCutLayerModifiers | Clears all the cut layer modifiers stored in the layer info.
Public method | ClearLayerModifiers | Clears all the project layer modifiers stored in the layer info.
Public method | Dispose |
Public method | GetCutLayerModifiers | Gets all the cut layer modifiers from the layer info.
Public method | GetLayerModifiers | Gets all the project layer modifiers from the layer info.
Public method | RemoveCutLayerModifier | Removes a cut layer modifier from the layer info.
Public method | RemoveLayerModifier | Removes a project layer modifier from the layer info.
Public method | SetCutLayerModifiers | Sets a cut layer modifier array to the layer info.
Public method | SetLayerModifiers | Sets a project layer modifier array to the layer info.

See Also

ExportLayerInfo Class

AddCutLayerModifier Method

[image]