Revit 2024 API
EdgeArrayArray Members
EdgeArrayArray Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeArrayArray | Initializes a new instance of the EdgeArrayArray class

Methods

 | Name | Description
Public method | Append | Add the edge array to the end of the array.
Public method | Clear | Removes every edge array from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified edge array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets an edge array at a specified index within the array.
Public property | Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray Class

Append Method

[image]