Revit 2024 API
FailureMessageKey Members
FailureMessageKey Class Constructors Methods Operators Properties See Also Send Feedback

The FailureMessageKey type exposes the following members.

Constructors

 | Name | Description
Public method | FailureMessageKey | Constructs a new FailureMessageKey with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureMessageKey
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | IsEqual | Checks it this key is equal to the other.
Public method | IsValid | Checks if the failure message key is valid

Operators

Name | Description
Equality | Determines whether two FailureMessageKeys are the same.
Inequality | Determines whether two FailureMessageKeys are different.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureMessageKey Class

FailureMessageKey Constructor

[image]