Revit 2024 API
ViewPlan Members
ViewPlan Class Methods Properties See Also Send Feedback

The ViewPlan type exposes the following members.

Methods

 | Name | Description
Public method | CheckPlanViewRangeValidity | Checks if the plan view range is valid.
 | Create | Creates a new ViewPlan.
 | CreateAreaPlan | Creates a new area plan ViewPlan.
Public method | GetUnderlayBaseLevel | Returns the element id of the level that defines the bottom of the underlay range.
Public method | GetUnderlayOrientation | Returns the underlay orientation of this view.
Public method | GetUnderlayTopLevel | Returns the element id of the level that defines the top of the underlay range.
Public method | GetViewRange | Gets the view range.
Public method | SetUnderlayBaseLevel | Sets the level whose elevation will determine the bottom of the underlay range. The elevation of the next highest level will be used to determine the top of the underlay range.
Public method | SetUnderlayOrientation | Sets the underlay orientation for this view.
Public method | SetUnderlayRange | Sets the underlay base and underlay top to the specified levels.
Public method | SetViewRange | Sets the view range.

Properties

 | Name | Description
Public property | AreaScheme | The area scheme.

See Also

ViewPlan Class

ViewPlan Methods

[image] [image]