Revit 2024 API
FabricationConnectorInfo Members
FabricationConnectorInfo Class Methods Properties See Also Send Feedback

The FabricationConnectorInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationConnectorInfo
Public method | HasDoubleWallConnector | Checks if there are any double wall connectors fabricated.
Public method | IsValid | Checks if the connector has fabrication parameters associated with it that can be set.

Properties

 | Name | Description
Public property | BodyConnectorId | Fabrication body connector Id.
Public property | DoubleWallConnectorId | Fabrication double wall connector Id.
Public property | FabricationIndex | The index of the connector shown within the fabrication software.
Public property | IsBodyConnectorLocked | Fabrication body connector lock.
Public property | IsDoubleWallConnectorLocked | Fabrication double wall connector lock.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FabricationConnectorInfo Class

FabricationConnectorInfo Methods

[image] [image]