Revit 2024 API
RuledSurface Members
RuledSurface Class Methods Properties See Also Send Feedback

The RuledSurface type exposes the following members.

Methods

 | Name | Description
 | Create(Curve, Curve) | Creates a Surface object coincident with the ruled surface joining two bounded generating curves.
 | Create(Curve, XYZ) | Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.
Public method | GetFirstProfileCurve | Returns a copy of the first profile curve if it is set.
Public method | GetFirstProfilePoint | If a point was used to define the first profile, returns a copy of that point.
Public method | GetSecondProfileCurve | Returns a copy of the second profile curve if it is set.
Public method | GetSecondProfilePoint | If a point was used to define the second profile, returns a copy of that point.
Public method | HasFirstProfilePoint | Checks if a point was used to define the first profile.
Public method | HasSecondProfilePoint | Checks if a point was used to define the second profile.

Properties

 | Name | Description

See Also

RuledSurface Class

RuledSurface Methods

[image] [image]