Revit 2024 API
SpatialElementBoundarySubface Members
SpatialElementBoundarySubface Class Methods Properties See Also Send Feedback

The SpatialElementBoundarySubface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementBoundarySubface
Public method | GetBoundingElementFace | Returns the face of the bounding element.
Public method | GetSpatialElementFace | Returns the face of the spatial element's 3D geometry.
Public method | GetSubface | Returns a face that represents the portion of the room face bounded by the boundary element.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpatialBoundaryElement | Element that gave rise to this room face.
Public property | SubfaceArisesFromElementFace | Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.
Public property | SubfaceType | Type of the subface.
Public property | Valid | Indicates if the subface instance is valid and can be used.

See Also

SpatialElementBoundarySubface Class

SpatialElementBoundarySubface Methods

[image] [image]