Revit 2024 API
TransactWithCentralOptions Members
TransactWithCentralOptions Class Constructors Methods Properties See Also Send Feedback

The TransactWithCentralOptions type exposes the following members.

Constructors

 | Name | Description
Public method | TransactWithCentralOptions | Constructs a new TransactWithCentralOptions.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TransactWithCentralOptions
Public method | GetLockCallback | Gets the callback object that changes Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public method | SetLockCallback | Sets or resets a callback object that would allow an external application to change Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TransactWithCentralOptions Class

TransactWithCentralOptions Constructor

[image]