Revit 2024 API
BuiltInFailures..::..RebarSystemFailures Properties
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback

The BuiltInFailures..::..RebarSystemFailures type exposes the following members.

Properties

Name | Description
AreaReinforcementOutSideOfHost | Area Reinforcement is sketched completely outside of its host.
AreaReinforcementRegenFail | Can't regenerate Area Reinforcement.
AreaReinforcementsCollision | Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
BarsTooCloseNumber | Bars are too close together. Decrease the Number Of Lines parameter.
BarsTooCloseSpacing | Bars are too close together. Increase the Maximum Spacing parameter.
BarsTooSparseSpacing | Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.
CannotPlaceAreaReinforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReinforcementWarn | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcementWarn | Can't find a host for Area Reinforcement.
CannotPlacePathReinforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReinforcementWarn | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcementWarn | Can't find a host for Path Reinforcement.
CannotUseAreaReinforcementHookTypeStyle | At least one of the bars in the Area Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.
CannotUsePathReinforcementHookTypeStyle | At least one of the bars in the Path Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.
DPartReinfDeletedEditDivision | Edits to the model will cause some Reinforcement hosted on Parts to be deleted.
DPartReinforcementDeleted | Reinforcement hosted on highlighted Parts will be deleted.
HostFlagAreaOff |
HostFlagAreaOn | The Area Reinforcement element was created in a document with the Host Structural Rebar setting on, and cannot be transferred into this document, which has the setting off.
HostFlagPathOff |
HostFlagPathOn |
LessThanTwoBars | Each reinforcement direction requires at least 2 bars. Please increase the number of bars.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RebarSystemOffset | Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.
ThinHostFloor | Rebar Cover Top and Bottom are too large for host.
ThinHostFloorError | Rebar Cover Top and Bottom are too large for host.
ThinHostWall | Rebar Cover Interior and Exterior are too large for host.
ThinHostWallError | Rebar Cover Interior and Exterior are too large for host.

See Also

BuiltInFailures..::..RebarSystemFailures Class

AreaReinforcementOutSideOfHost Property

[image]