Revit 2024 API
FamilySizeTableManager Members
FamilySizeTableManager Class Methods Properties See Also Send Feedback

The FamilySizeTableManager type exposes the following members.

Methods

 | Name | Description
 | CreateFamilySizeTableManager | Adds FamilySizeTableManager to a Family. A FamilySizeTableManager and FamilySizeTables are only needed when importing, exporting, or removing size data previously stored in CSV files.
Public method | Dispose | Releases all resources used by the FamilySizeTableManager
Public method | ExportSizeTable | Exports the size table to aCSV file.
Public method | GetAllSizeTableNames | Get the FamilySizeTable names in a family.
 | GetFamilySizeTableManager | Gets a FamilySizeTableManager from a Family
Public method | GetSizeTable | Get a FamilySizeTable by name.
Public method | HasSizeTable | Checks if a FamilySizeTable of a given name exists.
Public method | ImportSizeTable | Imports a FamilySizeTable from a CSV file.
Public method | RemoveSizeTable | Removes the FamilySizeTable of a given name.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSizeTables | The number of FamilySizeTables in a family.

See Also

FamilySizeTableManager Class

FamilySizeTableManager Methods

[image] [image]