Revit 2024 API
MEPSystem Properties
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Properties

 | Name | Description
Public property | BaseEquipment | The base panel or equipment of the system.
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | ConnectorManager | Connector manager of the system.
Public property | Elements | Terminal elements in the system.
Public property | HasDesignParts | Indicates if the system has one or more design parts.
Public property | HasFabricationParts | Indicates if the system has one or more fabrication parts.
Public property | HasPlaceholders | Indicates if the system has one or more placeholders.
Public property | IsEmpty | Indicates if the system is empty or not.
Public property | IsMultipleNetwork | Indicates if the system is well connected or not. The flag will enable the "Divide System" button.
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path.
Public property | SectionsCount | The number of sections.

See Also

MEPSystem Class

BaseEquipment Property

[image]