Revit 2024 API
Sweep Properties
Sweep Class See Also Send Feedback

The Sweep type exposes the following members.

Properties

 | Name | Description
Public property | IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Public property | MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Public property | Path3d | The selected curves used for the sweep path.
Public property | PathSketch | The sketched path for the sweep.
Public property | ProfileSketch | The profile sketch of the sweep.
Public property | ProfileSymbol | The family symbol profile details for the sweep.

See Also

Sweep Class

MaxSegmentAngle Property

[image]