Revit 2024 API
FilteredWorksetIterator Members
FilteredWorksetIterator Class Methods Properties See Also Send Feedback

The FilteredWorksetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetIterator
Public method | GetCurrent | The current workset found by the iterator.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset passing the filter.
Public method | Reset | Resets the iterator to the beginning.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredWorksetIterator Class

FilteredWorksetIterator Methods

[image] [image]