Revit 2024 API
SaveOptions Properties
SaveOptions Class See Also Send Feedback

The SaveOptions type exposes the following members.

Properties

 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

See Also

SaveOptions Class

Compact Property

[image]