Revit 2024 API
Wall Properties
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Properties

 | Name | Description
Public property | CrossSection | Obtain the Wall Cross-section for this wall.
Public property | CurtainGrid | Get the grid object of a curtain wall
Public property | Flipped | Property to test whether the wall orientation is flipped.
Public property | IsStackedWall | Identifies if the wall is a stacked wall.
Public property | IsStackedWallMember | Identifies if the wall is a member of a stacked wall.
Public property | Orientation | The normal vector projected from the exterior side of the wall.
Public property | SketchId | Returns id of the profile sketch, or invalidElementId if sketch does not exist.
Public property | StackedWallOwnerId | Gets the stacked wall which contains this stacked wall member.
Public property | StructuralUsage | Retrieves or changes the wall's designated structural usage.
Public property | WallType | Retrieves or changes the type of the wall.
Public property | Width | Get the overall thickness of the wall.

See Also

Wall Class

CrossSection Property

[image]