Revit 2024 API
CompoundStructure..::..HasStructuralDeck Property
CompoundStructure Class See Also Send Feedback
Checks if the compound structure has a structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasStructuralDeck { get; }
Visual Basic
Public ReadOnly Property HasStructuralDeck As Boolean
    Get
Visual C++
public:
property bool HasStructuralDeck {
    bool get ();
}

See Also

CompoundStructure Class

IsEmpty Property

[image]