Revit 2024 API
Viewport Members
Viewport Class Methods Properties See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
 | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet.
 | Create | Creates a new Viewport at a given location on a sheet.
Public method | GetBoxCenter | Returns the center of the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetLabelOutline | Gets the outline viewport's label on the sheet.
Public method | GetProjectionToSheetTransform | Returns the transform from the view's projection space to the sheet space.
Public method | HasViewportTransforms | Indicates if the viewport has transforms.
Public method | IsViewIdValidForViewport | Verifies that the Viewport can change it's view id to the input %viewId%.
Public method | SetBoxCenter | Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point.

Properties

 | Name | Description
Public property | LabelLineLength | The length of the viewport label line in sheet space, measured in feet.
Public property | LabelOffset | The offset is a two-dimensional vector from left bottom corner of the viewport with Rotation set to None to the left end of the viewport label line. The Z coordinate is ignored.
Public property | Rotation | The rotation of the viewport on the sheet.
Public property | SheetId | The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.
Public property | ViewId | The element id of the associated View.
Public property | ViewportPositioning | Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter.

See Also

Viewport Class

Viewport Methods

[image] [image]