Revit 2024 API
PlanViewRange Members
PlanViewRange Class Methods Properties See Also Send Feedback

The PlanViewRange type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PlanViewRange
Public method | GetLevelId | Get the element id of the level for a View Depth plane
Public method | GetOffset | Get the offset value associated with a View Depth plane
Public method | SetLevelId | Set the level for a View Depth plane
Public method | SetOffset | Set the offset value associated with a View Depth plane

Properties

 | Name | Description
 | Current | View range for the current plane
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | LevelAbove | View range for the level above the specified plane
 | LevelBelow | View range for the level below the specified plane
 | Unlimited | View range is unlimited

See Also

PlanViewRange Class

PlanViewRange Methods

[image] [image]