Revit 2024 API
SunAndShadowSettings Methods
SunAndShadowSettings Class See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Methods

 | Name | Description
 | CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Public method | FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
 | GetActiveSunAndShadowSettings | Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.
Public method | GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
Public method | GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
Public method | GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
Public method | GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
Public method | GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
Public method | IsAfterStartDateAndTime | Checks whether the end date and time is valid.
Public method | IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
Public method | IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
Public method | IsGroundPlaneLevelValid | Checks whether the element represents a valid Ground Plane level.
Public method | IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.

See Also

SunAndShadowSettings Class

CalculateTimeZone Method

[image]