Revit 2024 API
FilledRegionType Properties
FilledRegionType Class See Also Send Feedback

The FilledRegionType type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundPatternColor | The background fill pattern color.
Public property | BackgroundPatternId | The background fill pattern Id.
Public property | ForegroundPatternColor | The foreground fill pattern color.
Public property | ForegroundPatternId | The foreground fill pattern Id.
Public property | IsMasking | If true then the FilledRegion will cover the lines and edges of objects behind it. If false then lines and edges will remain visible.
Public property | LineWeight | The line weight of the fill pattern.

See Also

FilledRegionType Class

BackgroundPatternColor Property

[image]