Revit 2024 API
BuiltInFailures..::..FaceSplitterFailures Properties
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback

The BuiltInFailures..::..FaceSplitterFailures type exposes the following members.

Properties

Name | Description
CannotUseCurvesForFaceSplit | The sketch cannot split the face of the highlighted element.
EndsNotOnEdgeError | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
InvalidClosedLoopsForFaceSplit | The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.
InvalidOpenLoopsForFaceSplit | The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.
LoopsDoNotSubdivideFace | Sketched loops must sub-divide the face into two or more completely enclosed regions.
LoopsOutsideFaceSplitError | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
NoFaceForSplit | The highlighted element no longer contains a face that has been split by highlighted sketch.

See Also

BuiltInFailures..::..FaceSplitterFailures Class

CannotUseCurvesForFaceSplit Property

[image]