Revit 2024 API
PointOnPlane Members
PointOnPlane Class Methods Properties See Also Send Feedback

The PointOnPlane type exposes the following members.

Methods

 | Name | Description
Public method | GetPlaneReference | The geometric plane reference.
 | IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
 | NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
Public method | SetPlaneReference | Change the geometric plane reference.

Properties

 | Name | Description
Public property | Offset | Signed offset from the plane.
Public property | Position | The coordinates of the point (or its projection) on the plane.
Public property | XVec | The X-coordinate vector of the point, in the plane's coordinate system.

See Also

PointOnPlane Class

PointOnPlane Methods

[image] [image]