Revit 2024 API
FilterableValueProvider Members
FilterableValueProvider Class Methods Properties See Also Send Feedback

The FilterableValueProvider type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilterableValueProvider
Public method | GetAssociatedGlobalParameterValue | Gets a global parameter value associated with a parameter from the given element.
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element.
Public method | GetElementIdValue | Gets an ElementId value from the given element.
Public method | GetIntegerValue | Gets an integer value from the given element.
Public method | GetStringValue | Gets a string value from the given element.
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilterableValueProvider Class

FilterableValueProvider Methods

[image] [image]