Revit 2024 API
FabricationPart Members
FabricationPart Class Methods Properties See Also Send Feedback

The FabricationPart type exposes the following members.

Methods

 | Name | Description
Public method | AddPartCustomData | Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.
Public method | AdjustEndLength | Adjusts the length for the specified connector.
 | AlignPartByConnector | Align the part by its connector to a point and rotation in free space.
 | AlignPartByConnectors | Moves fabrication part by one of its connectors and aligns it to another connector.
 | AlignPartByConnectorToConnector | Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method.
 | AlignPartByInsertionPoint | Align the part by its insertion point to a point and rotation in free space.
 | AlignPartByInsertionPointAndCutInToStraight | Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.
Public method | CanAdjustEndLength | Checks if the end of fabrication part can be adjusted.
Public method | CanASlopeBeApplied | This will test if a slope can be applied to the part and maintain connections with any connected parts.
Public method | CanFlipPart | Validates if the fabrication part is one of the supported fabrication part types that can be flipped.
Public method | CanSplitStraight | Validates if the straight can be split into two at the passed in point.
 | ConnectAndCouple | Makes a connection between the specified connectors and adds coupling if necessary.
 | Create(Document, FabricationItemFile, ElementId) | Creates a fabrication part element from a fabrication item file.
 | Create(Document, FabricationServiceButton, Int32, ElementId) | Creates a fabrication part element based on button.
 | Create(Document, FabricationServiceButton, Double, Double, ElementId) | Creates a fabrication part element based on button and size.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId) | Creates a free placed hanger.
 | CreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
Public method | Flip | Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.
Public method | GetCalculatedDimensionValue | Gets the calculated dimension value.
Public method | GetDimensionCalculatedOptions | Gets the calculated options of the fabrication dimension.
Public method | GetDimensions | Gets all fabrication dimensions.
Public method | GetDimensionValue | Gets the value of the fabrication dimension, returns value in Revit internal units.
Public method | GetHostedInfo | Gets the fabrication hosted element information.
Public method | GetInsulationLiningGeometry | Gets insulation and lining geometry for this fabrication part.
Public method | GetPartAncillaryUsage | Gets a list of all ancillary usage information for the part.
Public method | GetPartCustomDataInteger | Get custom data integer value for the specified custom data.
Public method | GetPartCustomDataReal | Get custom data real value for the specified custom data.
Public method | GetPartCustomDataText | Get custom data text for the specified custom data.
Public method | GetProductListEntryCount | Gets the number of product entries for this part.
Public method | GetProductListEntryName | Gets the specified product list entry name.
Public method | GetRodInfo | Gets the fabrication rod information.
Public method | GetTransform | Gets the transformation matrix of the fabrication part element.
Public method | GetVersionHistory | Gets a history of version change information about the current part.
Public method | HasCustomData | Check if fabrication part contains custom data already.
Public method | HasNoConnections | Checks to see if all the fabrication part's connectors are open.
Public method | IsAHanger | Checks whether it is a hanger.
Public method | IsAStraight | Checks whether it is a straight part.
Public method | IsATap | Checks if it is any sort of tap.
Public method | IsDimensionCalculated | Checks if the fabrication dimension is calculated.
Public method | IsProductList | Gets whether or not the fabrication part is a product list.
Public method | IsProductListEntryCompatibleSize | Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.
Public method | IsSameAs | Compare this fabrication part with the part passed and checks the pattern dimensions and options. A list of fields that can be ignored in the comparison check can be specified.
 | OptimizeLengths | Optimizes the length fabrication straight parts.
 | PlaceAsTap | Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector.
 | PlaceFittingAsCutIn | Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.
Public method | RemovePartCustomData | Remove custom data from the fabrication part.
 | Reposition | Repositions the fabrication straight part to another end of the run.
 | RotateConnectedPartByConnector | Rotates a connected fabrication part around the axis of the specified connector.
 | RotateConnectedTap | Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.
 | SaveAsFabricationJob | Save fabrication parts to an MEP job that can be opened in the fabrication software.
Public method | SetCalculatedDimensionValue | Sets the calculated dimension value.
Public method | SetDimensionValue | Sets the fabrication dimension value. The value is in Revit internal units.
Public method | SetPartCustomDataInteger | Set the custom data integer value for the specified custom data.
Public method | SetPartCustomDataReal | Set the custom data real value for the specified custom data.
Public method | SetPartCustomDataText | Set the custom data real value for the specified custom data.
Public method | SetPositionByEnd | Positions the connector of the fabrication part element by the passed point.
Public method | SplitStraight(XYZ) | Splits the straight into two at the passed in point.
Public method | SplitStraight(Document, ElementId, XYZ) | Splits the straight into two at the passed in point.
 | StretchAndFit | Stretch the fabrication part from the specified connector and fit to the target routing end.

Properties

 | Name | Description
Public property | Alias | The alias of the fabrication part.
Public property | BottomOfPartElevation | The associated elevation to the bottom of fabrication part off of the current level.
Public property | CenterlineLength | The centerline length of the fabrication part.
Public property | ConnectorManager | The connector manager of the fabrication part.
Public property | CutType | The cut type of the fabrication part.
Public property | DomainType | The domain type for the fabrication part.
Public property | DoubleWallMaterial | The double wall material identifier of the fabrication part.
Public property | DoubleWallMaterialArea | The double wall material area of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | DoubleWallMaterialThickness | The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | FreeSize | The inner size of the fabrication part.
Public property | GeometryChecksum | Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position.
Public property | HangerRodKit | Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used.
Public property | HasDoubleWall | True if the fabrication part is double walled.
Public property | HasInsulation | True if the fabrication part is insulated.
Public property | HasLining | True if the fabrication part is lined.
Public property | InsulationArea | The insulation area of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationSpecification | The fabrication part insulation specification identifier.
Public property | InsulationThickness | The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationType | The insulation type of the fabrication part.
Public property | IsBoughtOut | True if the fabrication part is bought out.
Public property | ItemCustomId | The item custom identifier for the fabrication part.
Public property | ItemNumber | The item number that is used for identification, re-ordering from shop.
Public property | LevelOffset | The associated level offset that indicates the distance from the center of the fabrication part to the current level.
Public property | LiningArea | The lining area of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningThickness | The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningType | The lining type of the fabrication part.
Public property | Material | The fabrication material identifier.
Public property | MaterialGauge | The fabrication material gauge identifier.
Public property | MaterialThickness | The material thickness of the fabrication part.
Public property | Notes | The notes of the fabrication part.
Public property | Origin | The origin of the fabrication part element.
Public property | OverallSize | The overall size of the fabrication part.
Public property | PartGuid | The fabrication part's globally unique identifier.
Public property | PartStatus | The status identifier for the fabrication part.
Public property | ProductCode | The current database id of the part within the fabrication database.
Public property | ProductDataRange | The product data range of the fabrication part.
Public property | ProductFinishDescription | The product finish description of the fabrication part.
Public property | ProductInstallType | The product install type of the fabrication part.
Public property | ProductListEntry | The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list.
Public property | ProductLongDescription | The product long description of the fabrication part.
Public property | ProductMaterialDescription | The product material description of the fabrication part.
Public property | ProductName | The product name of the fabrication part.
Public property | ProductOriginalEquipmentManufacture | The product original equipment manufacture (OEM) of the fabrication part.
Public property | ProductShortDescription | The product short description of the fabrication part.
Public property | ProductSizeDescription | The product size description of the fabrication part.
Public property | ProductSpecificationDescription | The product specification description of the fabrication part.
Public property | ServiceAbbreviation | The associated service abbreviation for the fabrication service.
Public property | ServiceId | The fabrication part service identifier. The service can only be changed to compatible services.
Public property | ServiceName | The name of the service associated with the fabrication part.
Public property | ServiceType | The service type identifier of the fabrication part.
Public property | SheetMetalArea | The sheet metal area of the fabrication part.
Public property | Size | The size of the fabrication part.
Public property | Slope | The slope for the straight fabrication part.
Public property | Specification | The fabrication part specification identifier.
Public property | SpoolName | The spool name of the fabrication part.
Public property | TopOfPartElevation | The associated elevation to the top of fabrication part off of the current level.
Public property | ValidationStatus | The validation status of the fabrication part.
Public property | Vendor | The vendor of the fabrication part.
Public property | VendorCode | The vendor code of the fabrication part.
Public property | Weight | The weight of the fabrication part.

See Also

FabricationPart Class

FabricationPart Methods

[image] [image]