Revit 2024 API
TextNote Methods
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a leader to the text note.
 | Create(Document, ElementId, XYZ, String, ElementId) | Creates a new unwrapped TextNote element with the given properties.
 | Create(Document, ElementId, XYZ, String, TextNoteOptions) | Creates a new unwrapped text note element with the given properties.
 | Create(Document, ElementId, XYZ, Double, String, ElementId) | Creates a new line-wrapping text note element of the given width and properties.
 | Create(Document, ElementId, XYZ, Double, String, TextNoteOptions) | Creates a new line-wrapping text note element of the given width and properties.
Public method | GetFormattedText | Returns an object that contains text and associated formatting of this note.
Public method | GetLeaders | Returns a collection of leaders currently attached to the text note.
Public method | RemoveLeaders | Removes all leaders currently attached to the text note.
Public method | SetFormattedText | Sets the text and associated formatting of the text of in this text note with a given FormattedText object.

See Also

TextNote Class

AddLeader Method

[image]