Revit 2024 API
Opening Members
Opening Class Methods Properties See Also Send Feedback

The Opening type exposes the following members.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
Public property | Host | Retrieves the host element of this opening.
Public property | IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
Public property | IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
Public property | IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Public property | SketchId | Returns id of the Sketch or invalidElementId if element deon't own the Sketch.

See Also

Opening Class

Opening Methods

[image] [image]