Revit 2024 API
ReferenceArray Methods
ReferenceArray Class See Also Send Feedback

The ReferenceArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the reference to the end of the array.
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified reference into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

See Also

ReferenceArray Class

Append Method

[image]