Revit 2024 API
Document..::..NewFamilyInstance Method
Document Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

 | Name | Description
Public method | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]