Revit 2024 API
TriangulatedSolidOrShell Members
TriangulatedSolidOrShell Class Methods Properties See Also Send Feedback

The TriangulatedSolidOrShell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriangulatedSolidOrShell
Public method | GetShellComponent | Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShellComponentCount | The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.

See Also

TriangulatedSolidOrShell Class

Dispose Method

[image]