Revit 2024 API
Document..::..LoadFamily Method
Document Class See Also Send Feedback
Loads a family and all its types/symbols into the document.

Overload List

 | Name | Description
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, IFamilyLoadOptions, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

See Also

Document Class
Document Members

LoadFamily Method (String)

[image]