Revit 2024 API
ColorFillScheme Methods
ColorFillScheme Class See Also Send Feedback

The ColorFillScheme type exposes the following members.

Methods

 | Name | Description
Public method | AddEntry | Adds new entry to the scheme.
Public method | AreEntriesConsistentWithScheme | Checks whether the entries can be set to the scheme or not.
Public method | CanDefineByRange | Checks whether the scheme entries can be explained by range.
Public method | CanRemoveEntry | Checks whether entry can be removed from the scheme.
Public method | CanUpdateEntry | Checks whether entry exists in the scheme and not the same as input one.
Public method | Duplicate | Generates a copy of current scheme.
Public method | GetEntries | Retrieves copies of all entries.
Public method | GetFormatOptions | Returns the FormatOptions of the scheme.
Public method | GetSupportedParameterIds | Retrieves collection of all parameters supported by the scheme.
Public method | IsEntryConsistentWithScheme | Checks whether an entry can be added to the scheme or not.
Public method | IsValidParameterDefinitionId | Checks whether the input parameter id can be applied to the scheme.
Public method | IsValidSchemeName | Checks whether the name is valid for new generated scheme.
Public method | RemoveEntry | Removes an entry whose parameter value is the same as the input from the scheme
Public method | SetEntries | Update scheme entries in batch mode.
Public method | SetFormatOptions | Sets the FormatOptions of the scheme.
Public method | SortEntries | Sorts the scheme entries ascending.
Public method | UpdateEntry | Updates the scheme entry with the same parameter value as the input entry.

See Also

ColorFillScheme Class

AddEntry Method

[image]