Revit 2024 API
ParameterTypeId..::..AnalyticalElementStructuralRole Property
ParameterTypeId Class See Also Send Feedback
"Structural Role": Used for Analytical Elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalElementStructuralRole { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalElementStructuralRole As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalElementStructuralRole {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class

AnalyticalGeometryIsValid Property

[image]