Revit 2024 API
RoutingPreferenceRule Members
RoutingPreferenceRule Class Constructors Methods Properties See Also Send Feedback

The RoutingPreferenceRule type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingPreferenceRule | Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.

Methods

 | Name | Description
Public method | AddCriterion | Adds a new routing criterion.
Public method | Dispose | Releases all resources used by the RoutingPreferenceRule
Public method | GetCriterion | Gets the specified criteria.
Public method | RemoveCriteron | Removes an existing criterion.

Properties

 | Name | Description
Public property | Description | The description of the routing preference rule.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPPartId | The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
Public property | NumberOfCriteria | Gets the number of routing criteria.
Public property | RoutingPreferenceManager | Gets the routing preference manager that owns this rule.

See Also

RoutingPreferenceRule Class

RoutingPreferenceRule Constructor

[image]