Revit 2024 API
ViewCropRegionShapeManager Properties
ViewCropRegionShapeManager Class See Also Send Feedback

The ViewCropRegionShapeManager type exposes the following members.

Properties

 | Name | Description
Public property | BottomAnnotationCropOffset | The offset from the bottom of the view crop that determines the location of the annotation crop bottom boundary.
Public property | CanBeSplit | Verifies that the crop of the associated view is permitted to have multiple regions.
Public property | CanHaveAnnotationCrop | Verifies that the view is allowed to have an annotation crop.
Public property | CanHaveShape | Verifies that the crop of the associated view is permitted to have a non-rectangular shape.
Public property | IsSplitHorizontally | Whether or not the view's crop is split (and the split is horizontal).
Public property | IsSplitVertically | Whether or not the view's crop is split (and the split is vertical).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeftAnnotationCropOffset | The offset from the left of the view crop that determines the location of the annotation crop left boundary.
Public property | NumberOfSplitRegions | The number of split crop regions (1 if the crop is not currently split).
Public property | RightAnnotationCropOffset | The offset from the right of the view crop that determines the location of the annotation crop right boundary.
Public property | ShapeSet | Whether or not the view crop has a non-rectangular shape set.
Public property | Split | Whether or not the view crop is split.
Public property | TopAnnotationCropOffset | The offset from the top of the view crop that determines the location of the annotation crop top boundary.

See Also

ViewCropRegionShapeManager Class

BottomAnnotationCropOffset Property

[image]