Revit 2024 API
CategoryNameMap Methods
CategoryNameMap Class See Also Send Feedback

The CategoryNameMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.

See Also

CategoryNameMap Class

Clear Method

[image]