Revit 2024 API
PartMakerMethodToDivideVolumes..::..AreElementsValidIntersectingReferences Method (ICollection<(Of <(<'ElementId>)>)>)
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if provided members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool AreElementsValidIntersectingReferences(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Function AreElementsValidIntersectingReferences ( _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool AreElementsValidIntersectingReferences(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Element ids to be tested for validity for intersecting references.

Return Value

True if all references are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartMakerMethodToDivideVolumes Class
AreElementsValidIntersectingReferences Overload

AreElementsValidIntersectingReferences Method (Document, ICollection(ElementId))

[image]