Revit 2024 API
Material Properties
Material Class See Also Send Feedback

The Material type exposes the following members.

Properties

 | Name | Description
Public property | AppearanceAssetId | The ElementId of the AppearanceAssetElement.
Public property | Color | The color of the material.
Public property | CutBackgroundPatternColor | The color of the material cut background pattern.
Public property | CutBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in cut views.
Public property | CutForegroundPatternColor | The color of the material cut foreground pattern.
Public property | CutForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in cut views.
Public property | MaterialCategory | The name of the material category, e.g. 'Wood'
Public property | MaterialClass | The name of the general material type, e.g. 'Wood.'
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | StructuralAssetId | The ElementId of the structural PropertySetElement.
Public property | SurfaceBackgroundPatternColor | The color of the material surface background pattern.
Public property | SurfaceBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in normal views.
Public property | SurfaceForegroundPatternColor | The color of the material surface foreground pattern.
Public property | SurfaceForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in normal views.
Public property | ThermalAssetId | The ElementId of the thermal PropertySetElement.
Public property | Transparency | The transparency of the material.
Public property | UseRenderAppearanceForShading | True to use the render appearance settings for shaded view appearance; false to use the material's color and transparency value for shaded view appearance.

See Also

Material Class

Color Property

[image]