Revit 2024 API
OrdinateDimensionSetting Members
OrdinateDimensionSetting Class Constructors Methods Properties See Also Send Feedback

The OrdinateDimensionSetting type exposes the following members.

Constructors

 | Name | Description
Public method | OrdinateDimensionSetting | Constructs a new OrdinateDimensionSetting object with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the OrdinateDimensionSetting

Properties

 | Name | Description
Public property | DimensionLineLength | Specifies the dimension line segment length. This setting is enabled when Dimension Line Style is Segmented.
Public property | DimensionLineStyle | Specifies the dimension line style.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginTickMarkId | Specifies the id of the tick mark element to use for the dimension origin.
Public property | OriginVisibility | Specifies thevisibility of the origin witness line for the ordinate dimension (this is the first witness line in the string).
Public property | TextOrientation | Specifies where to align the dimension text.
Public property | TextPosition | Specifies the dimension text position.

See Also

OrdinateDimensionSetting Class

OrdinateDimensionSetting Methods

[image] [image]