Revit 2024 API
Floor Methods
Floor Class See Also Send Feedback

The Floor type exposes the following members.

Methods

 | Name | Description
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId) | Creates a new instance of architectural floor within the project.
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId, Boolean, Line, Double) | Creates a new instance of floor within the project.
 | GetDefaultFloorType | Returns id of default floor type.
Public method | GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Floor.
Public method | GetSpanDirectionSymbolIds | Retrieves span direction symbol ElementIds.
Public method | GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.

See Also

Floor Class

Create Method (Document, IList(CurveLoop), ElementId, ElementId)

[image]