Revit 2024 API
ValueParsingOptions Members
ValueParsingOptions Class Constructors Methods Properties See Also Send Feedback

The ValueParsingOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ValueParsingOptions | Creates a new ValueParsingOptions object with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ValueParsingOptions
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.

Properties

 | Name | Description
Public property | AllowedValues | The allowable range of values to be parsed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ValueParsingOptions Class

ValueParsingOptions Constructor

[image]