Revit 2024 API
ClosestPointsPairBetweenTwoCurves Properties
ClosestPointsPairBetweenTwoCurves Class See Also Send Feedback

The ClosestPointsPairBetweenTwoCurves type exposes the following members.

Properties

 | Name | Description
Public property | Distance | Distance from point on first curve to the point on second curve.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParameterOnFirstCurve | 1d raw (not normalized) parameter of the point on the first curve.
Public property | ParameterOnSecondCurve | 1d raw (not normalized) parameter of the point on the second curve.
Public property | XYZPointOnFirstCurve | Point on the first curve in 3d coordinates.
Public property | XYZPointOnSecondCurve | Point on the second curve in 3d coordinates.

See Also

ClosestPointsPairBetweenTwoCurves Class

Distance Property

[image]