Revit 2024 API
Document..::..Export Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Export(String, IList<(Of <<'(ElementId>)>>), PDFExportOptions) | Exports a selection of views in PDF format.
Public method | Export(String, String, GBXMLExportOptions) | Export the model in gbXML (green-building) format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, NavisworksExportOptions) | Exports a Revit project to the Navisworks .nwc format.
Public method | Export(String, String, OBJExportOptions) | Exports a view specified in the export options to the OBJ format.
Public method | Export(String, String, STLExportOptions) | Exports a view specified in the export options to the STL format.
Public method | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DGNExportOptions) | Exports a selection of views in DGN format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), SATExportOptions) | Exports the current view or a selection of views in SAT format.

See Also

Document Class
Document Members

Export Method (String, IList(ElementId), PDFExportOptions)

[image]