Revit 2024 API
BuiltInFailures..::..GeneralFailures Properties
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback

The BuiltInFailures..::..GeneralFailures type exposes the following members.

Properties

Name | Description
CannotFixProblem | Failed to fix problem. Action has to be cancelled.
CannotSetParameter | Cant set parameter
CharactersNotAllowed | Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
ContentDocTreeCorruption | Problems with the Content Doc Tree structure - e.g. orphaned Content Docs, Families w/o docs, missing Owner Fam, what-not
ConvertingOldAxisToNormal | This operation will convert the existing axis of revolution to a normal line.
CoreElemTestingError | Core element testing error (internal).
DuplicateValue | Elements have duplicate '[Value]' values.
EnterNonNegativeValue | Enter a non-negative value.
EnterValidRealGreaterThan | Enter a number greater than [Value].
EnterValueBetween | Please enter a value between [Value] and [Value].
ErrorInFamilyResolved | An error occurred in family "[Name]" and was automatically resolved. Please review changes made to the family.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
ErrorInSymbolFamilyResolved | An error occurred in family "[Name]" and was automatically resolved, but may require review by the family creator.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
ErrorResolved | Error "[Text]" was automatically resolved by "[Resolution]"
FailedToOpenFile | Failed to open file.
FailedToReadLine | Failed to read line.
FamilySeparationTestingError | Family separation testing error (internal).
GenericCorruption | A generic error has occurred.
GenericError | Error.
GenericErrorNone | None.
GenericFatalError | A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
GenericNonFatalError | A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
GenericWarning | A generic error has occurred.
InaccuracyDetected | A geometric inaccuracy was found in the element.
InternalProblemsParameter | Parameter cannot be changed due to internal problems.
InvalidInput | Invalid Input
InvalidInputWarn | Invalid Input
InvalidOrderOfPhases | Invalid order of phases: [Type Name] cannot be demolished before it was created.
InvalidValue | Invalid value.
NameInUse | The name "[Name]" is already in use.
NameIsEmpty | Name is empty
NameNotUnique | The name entered is already in use. Enter a unique name.
NoRelatedWarnings | Document doesn't contain any warnings related to these elements.
ParameterValueNotInRange | The value for [Parameter Name] must be between [Value] and [Value].
ParameterValuesConflict | The value for [Parameter Name] must be at least [Value] below the value for [Parameter Name].
SeriousElementReferenceCorruption | Element references are seriously corrupt.
TransactionFailed | [Description]
TransactionFailedWarn | [Description]
UnresolvableErrorInFamily | An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
UnresolvableErrorInFamilyWarn | An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
UnspecifiedError | Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
ValueOutOfRange | Value is out of range ! Please enter a number between [Value] and [Value].
WarningInFamilyDismissed | A warning in family "[Name]" was dismissed. Please review warning information to determine if any changes are necessary\nWarning Information:\n"[Text]"

See Also

BuiltInFailures..::..GeneralFailures Class

CannotFixProblem Property

[image]