Revit 2024 API
SolidCurveIntersection Members
SolidCurveIntersection Class Methods Properties See Also Send Feedback

The SolidCurveIntersection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SolidCurveIntersection
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveSegment | Gets the curve segment generated by intersection.
Public method | GetCurveSegmentExtents | Gets the extents for the given curve segment generated by intersection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResultType | The result type used to calculate the intersections.
Public property | SegmentCount | The number of segments in the results.

See Also

SolidCurveIntersection Class

SolidCurveIntersection Methods

[image] [image]