Revit 2024 API
Curve..::..IsCyclic Property
Curve Class See Also Send Feedback
The boolean value that indicates whether this curve is cyclic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsCyclic { get; }
Visual Basic
Public ReadOnly Property IsCyclic As Boolean
    Get
Visual C++
public:
property bool IsCyclic {
    bool get ();
}

Return Value

True if this curve is cyclic; otherwise, false.

See Also

Curve Class

Length Property

[image]