Revit 2024 API
ElementRecord Methods
ElementRecord Class See Also Send Feedback

The ElementRecord type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetBoundingBox | Gets the bounding box of the element record.
Public method | GetCategoryId | Gets the category id of the element record.
Public method | GetDesignOptionId | Gets the design option id of the element record.
Public method | GetId | Gets the id of the element record.
Public method | GetOwnerViewId | Gets the element id of the owner view record.
Public method | HasBoundingBox | Determines whether this element record has a bounding box.
Public method | IsAnElementType | Identifies if the element record represents an ElementType.
Public method | IsCurveDriven | Identifies if the element is curve driven.

See Also

ElementRecord Class

Dispose Method

[image]