Revit 2024 API
OBJExportOptions Methods
OBJExportOptions Class See Also Send Feedback

The OBJExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | IsGridAspectRatioSet | Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public method | IsMaxEdgeLengthSet | Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public method | IsNormalToleranceSet | Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public method | IsSurfaceToleranceSet | Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
 | IsValidForGridAspectRatio | Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
 | IsValidForMaxEdgeLength | Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
 | IsValidForNormalTolerance | Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
 | IsValidForSurfaceTolerance | Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public method | SetTessellationSettings | Sets all the tessellation parameters to its predefined values for the given resolution type.

See Also

OBJExportOptions Class

IsGridAspectRatioSet Method

[image]