Revit 2024 API
FabricationServiceButton Properties
FabricationServiceButton Class See Also Send Feedback

The FabricationServiceButton type exposes the following members.

Properties

 | Name | Description
Public property | ButtonIndex | The button index for this button.
Public property | Code | The code of the button.
Public property | ConditionCount | The number of conditions.
Public property | IsAHanger | Checks if the fabrication service button is hanger.
Public property | IsStraight | Checks if all of the fabrication service button conditions are straights.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the button.
Public property | PaletteIndex | The palette index for this button.
Public property | ServiceId | The fabrication service identifier for the fabrication service this button belongs to.

See Also

FabricationServiceButton Class

ButtonIndex Property

[image]