Revit 2024 API
Family Methods
Family Class See Also Send Feedback

The Family type exposes the following members.

Methods

 | Name | Description
Public method | CanHaveStructuralSection | Identifies if this Family can have a structural section.
 | CanLoadFamilies | Checks whether the document is in a state that allows the loading of families.
Public method | ExtractPartAtom | Writes a PartAtom XML from the contents of a family object.
Public method | GetFamilySymbolIds | Gets the ids of the FamilySymbols owned by this Family.
Public method | GetFamilyTypeParameterValues | Returns all applicable values for a FamilyType parameter of this family.
Public method | HasLargeSketches | Checks whether the family contains sketches with a large number of elements.
Public method | IsAppropriateCategoryId | Identifies if the input category id can be assigned as the new category for this family.

See Also

Family Class

CanHaveStructuralSection Method

[image]