Revit 2024 API
MeshFromGeometryOperationResult Members
MeshFromGeometryOperationResult Class Methods Properties See Also Send Feedback

The MeshFromGeometryOperationResult type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MeshFromGeometryOperationResult
Public method | GetIssues | Returns the array of issues encountered while building a mesh.
Public method | GetMesh | This returns a valid mesh only for the first call. Later calls will throw an exception as the mesh is no longer valid in this object.

Properties

 | Name | Description
Public property | HasInvalidData | Whether the provided data for which this result was obtained were internally inconsistent and could not be used in its entirety. For example, for extrusion operation, profile loops were degenerate or improperly oriented with respect to the extrsuion direction.
Public property | IsMeshAvailable | Shows whether the result still contains the mesh which was constructed, if any, or whether it has been relinquished by 'getMesh'. The former is true, the later is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Tessellated | Whether while constructing a mesh, it was necessary to extrude polylines instead of non-linear curves from the profile loops.

See Also

MeshFromGeometryOperationResult Class

MeshFromGeometryOperationResult Methods

[image] [image]