Revit 2024 API
ElementId Methods
ElementId Class See Also Send Feedback

The ElementId type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two element ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
 | Parse | Parse the string representation of the id into a corresponding ElementId.
Public method | ToString | Gets a String representation of the value of the id. (Overrides Object..::..ToString()()()().)
 | TryParse | Parse the string representation of the id into a corresponding ElementId.

See Also

ElementId Class

Compare Method

[image]