Revit 2024 API
FabricationService Members
FabricationService Class Methods Properties See Also Send Feedback

The FabricationService type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationService
Public method | GetButton | Gets the service button for a given palette index and button index from the service.
Public method | GetButtonCount | Gets the number of buttons for a given palette in the service.
Public method | GetPaletteName | Gets the name of a palette based on palette index.
Public method | IsCompatibleWith | Check whether the service is broadly interchangable with another one without affecting part geometry. The services must have the same fabrication system template and specification.
Public method | IsPaletteExcluded | Get whether a service palette is excluded from being used by the Route and Fill, Design to Fabrication, or Multi Point Routing commands. The default configuration values may be overridden by SetServicePaletteExclusions.
Public method | IsValidButtonIndex | Validates the button index.
Public method | IsValidPaletteIndex | Validates the palette index.
Public method | OverrideServiceButtonExclusion | Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.
Public method | ResetServiceExclusionOverrides | Resets the overridden service palette and button exclusions back to default, as defined by the configuration.
Public method | SetServicePaletteExclusions | Sets the service palette exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those palettes passed.

Properties

 | Name | Description
Public property | Abbreviation | The short name of service.
Public property | FabricationSystemName | The fabrication system name of the service.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the service.
Public property | PaletteCount | The number of palettes in the service.
Public property | ServiceId | The service identifier of the service.

See Also

FabricationService Class

FabricationService Methods

[image] [image]