Revit 2024 API
FamilyInstanceCreationData Members
FamilyInstanceCreationData Class Constructors Methods Properties See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyInstanceCreationData(Object) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(FamilySymbol, IList<(Of <<'(XYZ>)>>)) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, Line, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class

Methods

 | Name | Description

Properties

 | Name | Description
Public property | Axis | Get or set the axis of the FamilyInstance
Public property | RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace

FamilyInstanceCreationData Constructor

[image] [image]