Revit 2024 API
BRepBuilderSurfaceGeometry Methods
BRepBuilderSurfaceGeometry Class See Also Send Feedback

The BRepBuilderSurfaceGeometry type exposes the following members.

Methods

 | Name | Description
 | Create | Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface, including Plane and CylSurf.
 | CreateNURBSSurface(Int32, Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), Boolean, BoundingBoxUV) | Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.
 | CreateNURBSSurface(Int32, Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>), Boolean, BoundingBoxUV) | Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.
Public method | Dispose |

See Also

BRepBuilderSurfaceGeometry Class

Create Method

[image]