Revit 2024 API
NavisworksExportOptions Members
NavisworksExportOptions Class Constructors Methods Properties See Also Send Feedback

The NavisworksExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | NavisworksExportOptions | Create an instance of Navisworks Export Options set with default values.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the NavisworksExportOptions
Public method | GetSelectedElementIds | Returns the element ids of the elements to export. Empty by default.
Public method | SetSelectedElementIds | Sets the element ids of the elements to export. Used only when ExportScope = SelectedElements.

Properties

 | Name | Description
Public property | ConvertElementProperties | True to convert element properties, false otherwise. Default value is false.
Public property | ConvertLights | True to convert lights, false otherwise. Default value is false.
Public property | ConvertLinkedCADFormats | True to convert linked CAD formats, false otherwise. Default value is true.
Public property | Coordinates | Options which specifies the coordinates of Navisworks Exporter. Default value is Shared.
Public property | DivideFileIntoLevels | True to divide file into levels, false otherwise. Default value is true.
Public property | ExportElementIds | True to export Revit element ids, false to skip these values. Default value is true.
Public property | ExportLinks | True to export Revit links found in the main model, false to skip links. Default value is false.
Public property | ExportParts | True to export Revit part elements, false to export the original parent elements. Default value is false.
Public property | ExportRoomAsAttribute | True to export data for each room converts into a single shared room attribute, false otherwise. Default value is true.
Public property | ExportRoomGeometry | True to export Revit room geometry, false otherwise. Default value is true.
Public property | ExportScope | Options which specifies the export scope of Navisworks Exporter. Default value is Model.
Public property | ExportUrls | True to export URL parameters, false otherwise. Default value is true.
Public property | FacetingFactor | Faceting factor. Default value is 1.0.
Public property | FindMissingMaterials | True if the file exporter looks for a match for the materials missing from the export, false otherwise. Default value is true.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Parameters | Options which specifies the parameter conversion of Navisworks Exporter. Default value is All.
Public property | ViewId | The element id of the view to export. InvalidElementId by default. Used only when ExportScope = View.

See Also

NavisworksExportOptions Class

NavisworksExportOptions Constructor

[image]