Revit 2024 API
FilteredWorksetCollector Methods
FilteredWorksetCollector Class See Also Send Feedback

The FilteredWorksetCollector type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | FirstWorkset | Returns the first workset to pass the filter(s).
Public method | FirstWorksetId | Returns the id of the first workset to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetWorksetIdIterator | Returns a FilteredWorksetIdIterator to the worksets passing the current filter.
Public method | GetWorksetIterator | Returns a FilteredWorksetIterator to the worksets passing the current filter.
Public method | OfKind | Applies a WorksetKindFilter to the collector.
Public method | ToWorksetIds | Returns the complete set of workset ids that pass the filter(s).
Public method | ToWorksets | Returns the complete set of worksets that pass the filter(s).
Public method | WherePasses | Applies a workset filter to the collector.

See Also

FilteredWorksetCollector Class

Dispose Method

[image]