Revit 2024 API
DividedSurface Properties
DividedSurface Class See Also Send Feedback

The DividedSurface type exposes the following members.

Properties

 | Name | Description
Public property | AllGridRotation | Angle of rotation applied to the U- and V- directions together.
Public property | BorderTile | Determines the handling of tiles that overlap the surface's boundary.
Public property | ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
Public property | Host | The element whose surface has been divided.
Public property | HostReference | A reference to the divided face on the host.
Public property | IsComponentFlipped | Whether the pattern is flipped.
Public property | IsComponentMirrored | Whether the pattern is mirror-imaged.
Public property | NumberOfUGridlines | Get the number of U-gridlines used on the surface.
Public property | NumberOfVGridlines | Get the number of V-gridlines used on the surface.
Public property | UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
Public property | USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
Public property | VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
Public property | VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.

See Also

DividedSurface Class

AllGridRotation Property

[image]