Revit 2024 API
PrintManager Members
PrintManager Class Methods Properties See Also Send Feedback

The PrintManager type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Apply the local print settings to global for all documents.
Public method | SelectNewPrintDriver | Select a new printer.
Public method | SubmitPrint()()()() | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.

Properties

 | Name | Description
Public property | Collate | Indicates whether to collate of the current print.
Public property | CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
Public property | CopyNumber | The copy number.
Public property | IsVirtual | The virtual type in Autodesk Revit.
Public property | PaperSizes | Get all print sizes of current printer.
Public property | PaperSources | Get all print sources of current printer.
Public property | PrinterName | The name of the current printer.
Public property | PrintOrderReverse | Indicates whether to reverse the print order of the current print.
Public property | PrintRange | The print range.
Public property | PrintSetup | The PrintSetup which manages the print settings of current document.
Public property | PrintToFile | Indicates whether to print to file.
Public property | PrintToFileName | The file name when printing to file.
Public property | ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class

PrintManager Methods

[image] [image]