Revit 2024 API
HostedSweep Methods
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the hosted sweep object.
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.

See Also

HostedSweep Class

AddSegment Method

[image]