Revit 2024 API
MultiReferenceAnnotationOptions Members
MultiReferenceAnnotationOptions Class Constructors Methods Properties See Also Send Feedback

The MultiReferenceAnnotationOptions type exposes the following members.

Constructors

 | Name | Description
Public method | MultiReferenceAnnotationOptions | Create an instance of Multi-Reference Annotation Options set with default values.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MultiReferenceAnnotationOptions
Public method | ElementsMatchReferenceCategory | Verifies that all of the elements match the reference category required by the MultiReferenceAnnotationType.
Public method | GetAdditionalReferencesToDimension | Gets the additional references which the dimension will witness.
Public method | GetElementsToDimension | Gets the elements which the dimension will witness.
Public method | IsAllowedDimensionStyleType | Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.
Public method | ReferencesDontMatchReferenceCategory | Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.
Public method | SetAdditionalReferencesToDimension | Sets the additional references which the dimension will witness.
Public method | SetElementsToDimension | Sets the elements which the dimension will witness.

Properties

 | Name | Description
Public property | DimensionLineDirection | The direction vector of the dimension line.
Public property | DimensionLineOrigin | The origin point for the dimension line.
Public property | DimensionPlaneNormal | The normal vector to the dimension plane.
Public property | DimensionStyleType | The dimension style type to be used by the new MultiReferenceAnnotation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultiReferenceAnnotationType | The MultiReferenceAnnotationType to be used by the new MultiReferenceAnnotation.
Public property | TagHasLeader | When true the tag will be created with an attached leader. When false the tag will be created without a leader.
Public property | TagHeadPosition | The position for the tag's head.

See Also

MultiReferenceAnnotationOptions Class

MultiReferenceAnnotationOptions Constructor

[image]