Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailingNotConnected Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailingNotConnected { get; }
Visual Basic
Public Shared ReadOnly Property RailingNotConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class

RailPathCloseLoopForExtensionWarning Property

[image]