Revit 2024 API
PhaseArray Methods
PhaseArray Class See Also Send Feedback

The PhaseArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the phase to the end of the array.
Public method | Clear | Removes every phase from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified phase into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

See Also

PhaseArray Class

Append Method

[image]