Revit 2024 API
DirectShape Properties
DirectShape Class See Also Send Feedback

The DirectShape type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationDataId | A text string that identifies the data to the creating application.
Public property | ApplicationId | A text string that identifies the creating application.
Public property | TypeId | Element id of a DirectShapeType object that holds properties to be shared by this element. Optional.

See Also

DirectShape Class

Parameter Property

[image] [image]