Revit 2024 API
CylindricalHelix Properties
CylindricalHelix Class See Also Send Feedback

The CylindricalHelix type exposes the following members.

Properties

 | Name | Description
Public property | BasePoint | The base point of the axis of the cylindrical helix.
Public property | Height | Height of the cylindrical helix.
Public property | IsRightHanded | True if the helix is right handed, false if the helix is left handed.
Public property | Pitch | The pitch of the cylindrical helix.
Public property | Radius | The radius of the cylindrical helix.
Public property | XVector | The X direction vector.
Public property | YVector | The Y direction vector.
Public property | ZVector | The Z direction vector, which is same as the axis direction vector.

See Also

CylindricalHelix Class

BasePoint Property

[image]