Revit 2024 API
BuiltInFailures..::..GroupFailures Properties
BuiltInFailures..::..GroupFailures Class See Also Send Feedback

The BuiltInFailures..::..GroupFailures type exposes the following members.

Properties

Name | Description
AdditionalElementsRequired | Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.
AdditionalElementsRequiredRemove | To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]
AllElementsRemovedFromGroup | Group "[Type Name]" is now empty and will be deleted.
AtomTouchedNotAllowed | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomTouchedNotAllowedDelete | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomViolationWhenMultiPlacedInstances | Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.
AtomViolationWhenOnePlaceInstance | A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.
AttachedGroupNoMirror | Attached detail groups cannot be mirrored without also mirroring their parent group.
AttachedGroupNoPasteToView | An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.
BadProblemWithGroup | The operation performed affects groups in an unacceptable manner.
BadViewForAttachedGroup | Attached groups can only be created for view specific elements belonging to non-3d model views.
BadViewForAttachedGroupWarn | Attached groups can only be created for view specific elements belonging to non-3d model views.
CannotAddAlreadyMemberToDiffGroup | Elements that are already members of one group cannot be added to another group.
CannotAddToGroupFormat | [Element] cannot be added to the instance of [Group]
CannotAddToGroupFormatWarn | [Element] cannot be added to the instance of [Group]
CannotCopyGroup | Unable to copy the selected group.
CannotCreateGroup | Cannot create group of these elements.
CannotCreateGroupWithInvalidReferences | The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.
CannotFinishGroupInSketchMode | Can't Finish Group while in Sketch Mode.
CannotLinkAnnotationsForSomeViews | Annotations for some views cannot be displayed from linked file.
CannotPlaceGroup | Can't place Group from browser. Try copy/pasting existing copy of the Group instead.
CannotReloadWithFile | Group [Type Name] cannot be reloaded from file [File Name].
CannotRemoveGroupMemberConstraint | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveGroupMemberConstraintWarn | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveSubordFromGroup | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotRemoveSubordFromGroupWarn | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotSaveGroup | Can't save Group.
CannotSwapNestedGroups | Can't replace because one Group is contained in the other.
ChildrenDeletedOnGroupSwap | Some dependent elements were deleted by changing group type and cannot be retained.
ChildrenLostOnGroupSwap | Some elements could not find new hosts after changing group type and will be deleted.
DetailsOfNestedGroupsLost | Details will be deleted if they reference group members being ungrouped in other instances of this containing group.
DimensionsOrTagsReferecedRemoved | Dimensions or Tags that reference non-group members have been removed from group [Name].
DimRefsGroupMemberSketch | A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.
DontEditNestedGroup | Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.
ElementChangedMoreThanAllowed | The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.
ElementsContainsFabricationData | Unable to load models containing elements with fabrication data as group.
ExcludedElementsRestoredInLink | Excluded elements restored in the link.
FailedToChangeGroupLevelRef | Unable to change group level ref.
FailedToSetLeaderGroupId | Unable to set id of group type.
FailedToTransformAttachedGroup | Attached group could not be properly relocated.
GroupAmongstLoadedRenamed | A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.
GroupCannotMixBackAndForegroundDetail | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotSave | The group cannot be saved at this time because one of its instances is being edited.
GroupCannotSaveWarn | The group cannot be saved at this time because one of its instances is being edited.
GroupChangeNoPlaceElements | Elements cannot be placed as a result of changes to groups.
GroupEditModeNoDuplicates | Can't create duplicates in Edit Group mode.
GroupedModelElemHasViewSpecificSubordinates | Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.
GroupHadFailedElementsWhileUpdating | Group members failed while updating group.
GroupPropagationFailedSketch | Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.
GroupPropagationFailedUngroup | Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.
GroupPropagationUserCancelled | Changes to Group "[Type Name]" have been cancelled.
GroupsHasCycle | Can't create Group because it contains multiple copies of same Group.
GroupsHaveDifferentMembers | Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]
GroupsNotCompatibleForTypeChange | Some of the selected groups are not compatible with the new group type that was chosen.
GroupViewSpecificDiffViews | You may not create a detail group with view specific elements from different views.
InvalidGroup | This group is invalid.
LastCopyOfGroupDeleted | Last copy of Group "[Name]" deleted. Group type removed from project.
LastGroupMemberExcluded | Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.
LinkVisibilityLost | Link visibility overrides will be lost.
LoadOfGroupAbortedByUser | You have aborted loading file '[File Name]' as a group.
MembersAlignWarn | User parameter values for group members have been aligned.
MembersExcluded | Group members have been excluded from this group instance.
MembersExcludedWarn | Group members have been excluded from this group instance.
MembersMovedToProjectToMakeConsistent | Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.
ModifyingMultiGroups | Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.
MoveElemFailed | Unable to move element.
NoAppropriateGroup | There is no Group that can be placed in the current view.
NoDetailGroups | There are no Detail Groups in this Project or Family.
NoModelGroups | There are no Model Groups in this Project or Family.
NoneOfSelElemsGroupable | None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.
NoSwapGroupBeingEdited | You may not change the type of the group that is currently being edited.
NotAGroupFile | This is not a Group File.
NotAllGroupsFullyRestored | Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.
PlaceGroupFailed | Unable to place group instances.
ProblemRegeneratingInGroupUpdate | Unable to regenerate while updating groups at end of transaction.
ReferencesOutsideGroupAreNotAllowed | The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.
RemoveGroupSketchConstraintParent | You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.
RemovingElemCannotBeGrouped | Elements that cannot be grouped were removed from groups of type '[Type Name]'.
RemovingReferencesFromGroupedCurve | References to elements outside the group were removed from a grouped curve element.
RevitUnableToUpadateGroups | Unable to update groups for changes.
SomeGroupInstsBecameEmpty | Group instances have had all their group members deleted and will also be deleted.
SomeMembersNotRestored | Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.
UnableToBindLink | Unable to bind the selected links.
UnableToBindLinkInstances | Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.
UnableToConvertGroupsToLinks | Unable to convert the selected groups to links.
UnableToCreateAttachedGroup | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToDetachGroup | Unable to detach the selected attached detail group(s).
UnableToExcludeElems | Unable to exclude the selected group members.
UnableToGroupElems | Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.
UnableToLoadAttachedGroup | Unable to load attached detail group '[Type Name]'.
UnableToLoadDetailGroup | Unable to load detail group '[Type Name]'.
UnableToLoadGroup | Unable to load file '[File Name]' as a group.
UnableToMaintainExclusions | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMaintainExclusionsWarn | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMoveElemsToProject | Revit is unable to move the selected group members to the project.
UnableToRemapDetails | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToReplaceSelectedGroups | Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.
UnableToRestoreAllMembersOfGroups | Revit is unable to restore the members of the selected groups.
UnableToSaveGroupType | Unable to save group type.
UnableToTransferAttachedGroup | Unable to load attached group [Type Name] of model group [Type Name].

See Also

BuiltInFailures..::..GroupFailures Class

AdditionalElementsRequired Property

[image]