Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures Properties
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback

The BuiltInFailures..::..MEPCalculationFailures type exposes the following members.

Properties

Name | Description
AtLeastOneEquipmentOnDuty | There should be at least one equipment on duty.
ClassificationNotSetInFamily | A calculation did not complete because the Classification parameter in the Mechanical Equipment family is not set.
DemandFlowAndPressureLossNotSetInLossFamily | A calculation did not complete because the pressure loss value for element is not set. Select the element and enter a value for the Pressure Loss.
DemandFlowNotSetInLossFamily | A calculation did not complete because the Demand Flow for the element is not set.
DuctFittingAndAccessoryPressureDropCalculatorNotAvailable | Duct Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
DuctPressureDropCalculatorNotAvailable | Duct Pressure Drop Calculator Not Available: [Calculator Name]
ExtraPumpSet | More than one parallel pump set defined for the same loop. Verify the flow distribution and delete the extra set, if desired.
FlowAndPressureCalculationMethodHasBeenImproved | During upgrade pressure drop calculations for hydronic piping systems using Simplified Colebrook or Custom Calculation methods have been recalculated using the Colebrook equation.
HydraulicSeparationAmbiguity | Unable to hydraulically separate until the system has flow.
HydraulicSeparationOfOneSystem | Unable to hydraulically separate the loop when both supply and return are assigned to the same system. Try again with both start and end selected.
InvalidFluidProperty | Some network components may have a flow value of 0 (zero), due to invalid value settings for fluid Dynamic Viscosity or Density. \nVerify that you have selected the correct fluid type and that the fluid Dynamic Viscosity and Density values are set correctly in the Mechanical Settings dialog.
InvalidNumberOfMechanicalEquipmentOnDuty | The number of on duty equipment must be less than or equal to the number of available equipments.
LoopSeparationNotCompleted | The loop separation is not completed yet. Only one side of the secondary/tertiary loop is separated. In order to correctly calculate the flow and pressure loss, please check and separate the other end of the loop.
MechanicalEquipmentSetBeingDeleted | The mechanical equipment set was deleted because it no longer contained any members.
Network_ElementNodeIsNotPartOfNetwork | The calculation could not be executed as configured. At least one of the elements in this network uses a node that is not part of the network.
Network_NodePropertyNotSet | The calculation could not be executed as configured. Specify a constraint property set for the following input or output node(s).
Network_NoInputNode | The calculation could not be executed as configured. Select an input node before analyzing this network.
Network_NoOutputNode | The calculation could not be executed as configured. Select an output node before analyzing this network.
Network_NoPressureConstraint | The calculation could not be executed as configured. Each network requires at least 1 pressure constraint. Specify the pressure constraint.
Network_NotEnoughElements | The calculation could not be executed as configured. Specify at least 3 elements before analyzing this network.
Network_NotEnoughNodes | The calculation could not be executed as configured. Specify at least 4 elements before analyzing this network.
Network_NotFullyConnected | The network is not well connected. Some elements may have unexpected flow and pressure loss values.
Network_OverConstrained | The calculation could not be executed as configured. The Pressure and Flow Rate combined constraint requires at least 2 other pressure or flow constraints. Specify additional constraints.
NetworkCanNotDeterminCriticalPath | The calculation has completed, but there may be an error in determining the critical path. Verify that demand flow is specified for all required elements.
NetworkDefaultToPressure | The network uses the default pressure.
NetworkDefaultToReynolds | The network uses the default Reynolds number.
NetworkEnergyEquationNotConverge | The energy calculation could not be performed.
NetworkErrorCalculatingPressure | The pressure calculation could not be performed.
NetworkErrorElementWithDownUpStreamNode | The network needs an input or output element to perform the calculation.
NetworkErrorExtractCurveData | The calculation could not be performed. Verify the pump curve data.
NetworkErrorModelTooBig | The size of the network exceeds the current limit for flow/pressure analysis. In the Mechanical Settings dialog, under Pipe Settings - Calculation, disable the option to Use analysis for closed loop hydronic networks.
NetworkErrorOverConstrained | The calculation could not be performed due to overconstrained flow condition in the network.
NetworkExtraPumpOutsideSet | Flow calculations do not calculate this pump together with the other pumps as one equipment set. Verify the flow distribution and add the pump to the equipment set, if desired.
NetworkInconsistentDemandFlow | The specified flow on this equipment is inconsistent with the other equipment in this branch. The branch flow is calculated based on the maximum specified value.
NetworkMinorLossNotConverge | The minor loss calculation could not be performed.
NetworkPressureNotConverge | The calculation could not be performed. Verify the pressure on the input element.
NetworkUnderConstrained | The network is under constrained. You may specify the design flow value in the missing branches, or cap the open ends.
PipeConnectorsAreNotLined | A calculation did not complete because the connectors used by this family to connect to the network are not linked.
PipeFittingAndAccessoryPressureDropCalculatorNotAvailable | Pipe Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
PipePressureDropCalculatorNotAvailable | Pipe Pressure Drop Calculator Not Available: [Calculator Name]
PlumbingFlowCalculatorNotAvailable | Plumbing Flow Calculator Not Available: [Calculator Name]
PressureLossNotSetInLossFamily | A calculation did not complete because the pressure loss value for the source equipment is not set for the network.
PumpPressureNotComputed | The calculated pressure drop of this pump is not computed because the critical path is not a closed loop. Check to see if there are other pumps intended for use within a secondary/tertiary loop. Use the Add Separation tool to define the secondary/tertiary loop.
SeparationNotAtJunction | This hydraulic loop is not separated at any junction. Use the Remove Separation tool to clean up undesired hydraulic separations.
SeparationWithOddJunction | Hydraulic separation requires an even number of junctions on the header pipe for accurate calculations. Add or remove junctions to complete the separation.

See Also

BuiltInFailures..::..MEPCalculationFailures Class

AtLeastOneEquipmentOnDuty Property

[image]