Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures Properties
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback

The BuiltInFailures..::..ScheduleViewFailures type exposes the following members.

Properties

Name | Description
BadViewType | Schedules can only be placed on Sheets.
CannotResizeColumn | Can't resize column.
ColumnsExceedSegment | Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.
ColumnsExcluded | Some columns in the project are excluded from the graphical column schedule view.
CustomFieldNecessaryIdDeleted | An element that is needed to compute the field [field name] from [schedule name] schedule was deleted.
DuplicateFieldRemovedFromKeySchedule | Duplicate fields across key schedules will be removed after paste.
NoColumnsJoinedToGridLines | No columns are joined to grid lines, or view parameters exclude all columns.
NotGridName | '[Text]' is not a Grid line name
PanelScheduleLoadClassInconsistency | You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.
PanelScheduleSlotInconsistency | The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.
PanelScheduleSwitchboardSlotInconsistency | The template applied to this panel schedule is set to display fewer space than what is needed to display the max number of circuits set on the equipment.
SchedulesCanBePlacedOnSheetsOnly | Schedules can only be placed on Sheets.
SegmentsStartIsGreaterThanSegmentsEnd | Change values so Segments End is greater than or equal to Segments Start.

See Also

BuiltInFailures..::..ScheduleViewFailures Class

BadViewType Property

[image]