Revit 2024 API
BuiltInFailures..::..BendFailures Properties
BuiltInFailures..::..BendFailures Class See Also Send Feedback

The BuiltInFailures..::..BendFailures type exposes the following members.

Properties

Name | Description
BendAngleIsUnacceptable | The angle of the bend/elbow is unacceptable
DeleteMiddleBendNotAllowed | Delete a middle bend in a bank is not allowed
DeleteSegmentInBankNotAllowed | Delete a segment in a bank is not allowed
NotBentControl | While making curved beam type "[Type Name]" some Control elements were not created
NotBentDetailComponent | While making curved beam type "[Type Name]" 2D Detail Component elements were not created
NotBentFilledRegion | While making curved beam type "[Type Name]" Filled Region elements were not created
NotBentImage | While making curved beam type "[Type Name]" Image elements were not created
NotBentImport | While making curved beam type "[Type Name]" CAD File elements were not created
NotBentMaskingRegion | While making curved beam type "[Type Name]" Masking Region elements were not created
NotBentModelLine | While making curved beam type "[Type Name]" some Model Line elements were not created
NotBentOpening | While making curved beam type "[Type Name]" Opening elements were not created
NotBentRefLine | While making curved beam type "[Type Name]" some Reference Line elements were not created
NotBentRefPlane | While making curved beam type "[Type Name]" some Reference Plane elements were not created
NotBentSharedFamily | While making curved beam type "[Type Name]" Shared Family Instances were not created
NotBentSymbol | While making curved beam type "[Type Name]" Symbol elements were not created
NotBentSymbolicLine | While making curved beam type "[Type Name]" some Symbolic Line elements were not created

See Also

BuiltInFailures..::..BendFailures Class

BendAngleIsUnacceptable Property

[image]