Revit 2024 API
MEPSystem Methods
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors.
Public method | DivideSystem | Divide the phyisical networks in the system and create a new system for each network.
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers.
Public method | GetPhysicalNetworksNumber | Get the physical networks number in the system.
Public method | GetSectionByIndex | Get the section from the index.
Public method | GetSectionByNumber | Get the Section from section number
Public method | IsSystemDividable | Checks if the system is dividable. The system is dividable if there is more than one physical network in the system. Currently, only HVAC and piping systems support dividing.
Public method | Remove(ConnectorSet) | Removes connectors from system.
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system.

See Also

MEPSystem Class

DivideSystem Method

[image]