Revit 2024 API
HostedSweep Properties
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created.
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.

See Also

HostedSweep Class

Angle Property

[image]