Revit 2024 API
ControlledApplication Methods
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

 | Name | Description
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | IsJournalPlaying | Determines if the application is currently in journal playback mode.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
 | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

GetFailureDefinitionRegistry Method

[image]