Revit 2024 API
LineProperties Properties
LineProperties Class See Also Send Feedback

The LineProperties type exposes the following members.

Properties

 | Name | Description
Public property | Color | The current color used when drawing lines/curves.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineWidth | The current width (thickness) of the pen stroke when drawing lines/curves.
Public property | PatternId | Id of the current Line pattern element used when drawing lines/curves.
Public property | Transparency | The current transparency level to be applied to the current color.

See Also

LineProperties Class

Color Property

[image]