DetailEllipse Class

DetailLine Class

Represents a DetailLine within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBDetailCurve
Autodesk.Revit.DBDetailLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DetailLine : DetailCurve
Public Class DetailLine
    Inherits DetailCurve
public ref class DetailLine : public DetailCurve
type DetailLine =
    class
        inherit DetailCurve
    end

The DetailLine type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace