SpanDirectionSymbol Class

SpatialElement Class

Represents an enclosed area or volume in the Revit model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElement
Autodesk.Revit.DB.ArchitectureRoom
Autodesk.Revit.DBArea
Autodesk.Revit.DB.MechanicalSpace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElement : Element
Public Class SpatialElement
    Inherits Element
public ref class SpatialElement : public Element
type SpatialElement =
    class
        inherit Element
    end

The SpatialElement type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area.
Public property | Level | Gets the level of the room.
Public property | Location | The location of the element. (Overrides ElementLocation)
Public property | Name | A human readable name for the Element. (Overrides ElementName)
Public property | Number | The number.
Public property | Perimeter | The perimeter.
Public property | SpatialElementType | The spatial element type.
Top
Methods
 | Name | Description
Public method | GetBoundarySegments | Returns the boundary segments.
Public method | GetSpatialElementDomainData | Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data.
Top
See Also

Reference

Autodesk.Revit.DB Namespace