BuiltInFailuresSystemNavigatorFailures Class

BuiltInFailures.SystemsFailures Class

BuiltInFailuresSystemsFailures Class

Failures about System.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSystemsFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SystemsFailures
Public NotInheritable Class SystemsFailures
public ref class SystemsFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SystemsFailures = class end

The BuiltInFailuresSystemsFailures type exposes the following members.

Properties
Name | Description
AddingOtherConnectedMembersToSystem | "You have selected elements that are connected to other elements. These elements will also be added to the System."
CircuitWorksetClosedWarning | The workset of the circuit is closed so the circuit path will not be displayed.
CreatePartsWithInvalidService | Parts were not created because a system's service is undefined.
CreatePartsWithInvalidSystem | Parts were not created because the element does not have a valid system.
CreatePartsWithoutDabasebase | Parts were not created because fabrication configuration is not available.
DefaultSystemOver50Elems | The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
ElementsBelongToOtherSystem | You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.
FamilyDoesntMatchSystemProperties | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyDoesntMatchSystemPropertiesWasDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
MismatchSystemType | Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
PastePartsWithInvalidService | Parts were not pasted because fabrication configuration is not available or service is not valid in the type properties for the system.
SelectedElementsArePartOfOtherSystem | You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.
Top
See Also

Reference

Autodesk.Revit.DB Namespace