ReferencePlane Class

ReferencePoint Class

A reference point in an Autodesk Revit family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBReferencePoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReferencePoint : Element
Public Class ReferencePoint
    Inherits Element
public ref class ReferencePoint : public Element
type ReferencePoint =
    class
        inherit Element
    end

The ReferencePoint type exposes the following members.

Properties
 | Name | Description
Public property | CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
Public property | Name | (Overrides ElementName)
Public property | Position | The position of the ReferencePoint.
Public property | ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Top
Methods
 | Name | Description
Public method | GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
Public method | GetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | GetHubId | Id of associated Hub.
Public method | GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
Public method | GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
Public method | GetVisibility | Gets the visibility for the point.
Public method | SetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
Public method | SetVisibility | Sets the visibility for the point.
Top
Remarks
A ReferencePoint represents a point in space together with a local coordinate system. ReferencePoints can be free, or constrained to other elements in several ways. When the point is constrained, the coordinate system is also constrained in certain ways.
See Also

Reference

Autodesk.Revit.DB Namespace