PointCloudInstance Class

Represents a single instance of a point cloud in the Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBPointCloudInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointCloudInstance : Instance
Public Class PointCloudInstance
    Inherits Instance
public ref class PointCloudInstance : public Instance
type PointCloudInstance =
    class
        inherit Instance
    end

The PointCloudInstance type exposes the following members.

Properties
 | Name | Description
Public property | FilterAction | The action taken based on the results of the selection filter applied to this point cloud.
Public property | SupportsOverrides | Identifies whether the instance can have graphic overrides.
Top
Methods
 | Name | Description
Public method | ContainsScan | Identifies whether the instance contains a scan.
 | Create | Creates a new instance of a point cloud based on an input point cloud type and transformation.
 | GetPoints | Extracts a collection of points based on a filter.
Public method | GetRegions | Returns array of region names.
Public method | GetScanOrigin | Returns the origin point of a scan in model coordinates.
Public method | GetScans | Returns array of scan names.
Public method | GetSelectionFilter | Returns the currently active selection filter for this point cloud.
Public method | HasColor | Returns true if at least one scan of the element have color, false otherwise.
Public method | SetSelectionFilter | Sets active selection filter by cloning of the one passed to it.
Top
See Also

Reference

Autodesk.Revit.DB Namespace