ElementMulticategoryFilter Class

ElementMulticlassFilter Class

A filter used to match elements by their class, where more than one class of element may be passed.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementMulticlassFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementMulticlassFilter : ElementQuickFilter
Public Class ElementMulticlassFilter
    Inherits ElementQuickFilter
public ref class ElementMulticlassFilter : public ElementQuickFilter
type ElementMulticlassFilter =
    class
        inherit ElementQuickFilter
    end

The ElementMulticlassFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementMulticlassFilter(IListType) | Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes.
Public method | ElementMulticlassFilter(IListType, Boolean) | Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes, with an option to instead match elements whose Element subclass does not match the list of input classes.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Only elements whose class is an exact match to one of the input classes, or elements whose type is derived from the input class will pass the collector.

There is a small subset of Element subclasses in the API that are not supported by this filter. These classes exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subclass. For a list of subclasses affected by this restriction, consult the documentation for [!:Autodesk::Revit::DB::ElementClassFilter].

See Also

Reference

Autodesk.Revit.DB Namespace