MEPAnalyticalSegment Properties

The MEPAnalyticalSegment type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of the segment profile.
Public property | DemandFlow | The designed flow value, in ft^3/s.
Public property | DomainType | The connector domain type of this segment.
Public property | EndNode | The id of the end analytical node.
Public property | Id | The identity of this segment.
Public property | InnerDiameter | The inner diameter of this segment, in ft. For rectangular or oval profile, this may be the hydraulic diameter.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RevitElementId | The id of the owning Revit element.
Public property | Roughness | The roughness of this segment, in ft.
Public property | SegmentType | The analytical segment type.
Public property | StartNode | The id of the start analytical node.
Top
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace