BuiltInFailuresDisplacementElementFailures Class

BuiltInFailures.DividedPathFailures Class

BuiltInFailuresDividedPathFailures Class

Failures related to divided path operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDividedPathFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DividedPathFailures
Public NotInheritable Class DividedPathFailures
public ref class DividedPathFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DividedPathFailures = class end

The BuiltInFailuresDividedPathFailures type exposes the following members.

Properties
Name | Description
DividedPathCannotApplyDivideSettings | Default Divide settings cannot be applied to Divided Path.
DividedPathCannotBeMirroredWithoutItsCurves | Divided path cannot be mirrored without its curves.
DividedPathCannotCreateFromGeometry | Highlighted geometry contains a path or edge that could not be divided.
DividedPathDistanceTooSmall | Distance is too small.
DividedPathIndentsOverlap | Beginning indent and end indent overlap.
DividedPathIntersectionPolycurveParamsStepFailed | Intersection failed.
DividedPathInvalidNumberOfPoints | End indent is too large.
DividedPathLayoutStepFailed | Layout algorithm failed.
DividedPathUpdateMergedPointKeysStepFailed | Merging failed.
Top
See Also

Reference

Autodesk.Revit.DB Namespace