Construction Class

ContentNode Class

This class represents a generic content node in a model-exporting process.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBContentNode
Autodesk.Revit.DBLightNode
Autodesk.Revit.DBRPCNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ContentNode : RenderNode
Public Class ContentNode
    Inherits RenderNode
public ref class ContentNode : public RenderNode
type ContentNode =
    class
        inherit RenderNode
    end

The ContentNode type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node.
Public method | GetTransform | A transformation matrix associated with the node.
Top
Remarks
Members of this class implement properties and methods common to all content classes, such as RPC and Light nodes. Attributes of a content note can be accessed via an Asset object.
See Also

Reference

Autodesk.Revit.DB Namespace