DocumentSetIterator Class

DocumentType Enumeration

Types of Revit documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DocumentType
Public Enumeration DocumentType
public enum class DocumentType
type DocumentType
Members
Member name | Value | Description
Project | 0 | Project document.
Family | 1 | Family document.
Template | 2 | Template document.
IFC | 3 | IFC document.
BuildingComponent | 4 | Building Component document.
Other | 100 | Document of another type.
See Also

Reference

Autodesk.Revit.DB Namespace