ReferenceArray Class

ReferenceArrayArray Class

An array that contains ReferenceArray objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBReferenceArrayArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReferenceArrayArray : APIObject,
    IEnumerable
Public Class ReferenceArrayArray
    Inherits APIObject
    Implements IEnumerable
public ref class ReferenceArrayArray : public APIObject,
    IEnumerable
type ReferenceArrayArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The ReferenceArrayArray type exposes the following members.

Constructors
 | Name | Description
Public method | ReferenceArrayArray | Initializes a new instance of the ReferenceArrayArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a ReferenceArray at a specified index within the array.
Public property | Size | Returns the number of ReferenceArrays that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every ReferenceArray from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace