KeynoteEntries Class

KeynoteEntry Class

Represents an entry in the keynote table, containing the key value, keynote text, and parent key (if applicable).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntry
Autodesk.Revit.DBKeynoteEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeynoteEntry : KeyBasedTreeEntry
Public Class KeynoteEntry
    Inherits KeyBasedTreeEntry
public ref class KeynoteEntry : public KeyBasedTreeEntry
type KeynoteEntry =
    class
        inherit KeyBasedTreeEntry
    end

The KeynoteEntry type exposes the following members.

Constructors
 | Name | Description
Public method | KeynoteEntry(String, String) | Constructs a new KeynoteEntry from the given key name and keynote text. KeynoteEntry objects created from this constructor will not have parents.
Public method | KeynoteEntry(String, String, String) | Constructs a new KeynoteEntry from the given key name, parent key name, and keynote text.
Top
Properties
 | Name | Description
Public property | KeynoteText | The text associated with this KeynoteEntry.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace