FilterElementIdRule Class

FilterGlobalParameterAssociationRule Class

A filter rule that operates on global parameters ElementId values in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterGlobalParameterAssociationRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterGlobalParameterAssociationRule : FilterNumericValueRule
Public Class FilterGlobalParameterAssociationRule
    Inherits FilterNumericValueRule
public ref class FilterGlobalParameterAssociationRule : public FilterNumericValueRule
type FilterGlobalParameterAssociationRule =
    class
        inherit FilterNumericValueRule
    end

The FilterGlobalParameterAssociationRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterGlobalParameterAssociationRule | Constructs an instance of FilterGlobalParameterAssociationRule.
Top
Properties
 | Name | Description
Public property | RuleValue | The user-supplied global parameter value against which values from a Revit document will be tested.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace