BuiltInFailuresDirectContext3DFailures Class

BuiltInFailures.DirectShapeFailures Class

BuiltInFailuresDirectShapeFailures Class

Failure definitions related to DirectShapes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDirectShapeFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DirectShapeFailures
Public NotInheritable Class DirectShapeFailures
public ref class DirectShapeFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DirectShapeFailures = class end

The BuiltInFailuresDirectShapeFailures type exposes the following members.

Properties
Name | Description
CannotCreateDirectShapeOrTypeDocumentCorruption | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeOrTypeError | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeOrTypeWarning | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeRefsWarning | Cannot create reference objects for a DirectShape.
CannotCreateDirectShapeTypeRefsWarning | Cannot create reference objects for a DirectShapeType.
Top
See Also

Reference

Autodesk.Revit.DB Namespace