FormatValueOptions Class

FormulaManager Class

A class to access and query information about formula engine in Revit models.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFormulaManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormulaManager : IDisposable
Public Class FormulaManager
    Implements IDisposable
public ref class FormulaManager : IDisposable
type FormulaManager =
    class
        interface IDisposable
    end

The FormulaManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FormulaManager
 | Evaluate | Evaluates value of the formula
 | GetFunctions | Gets list of function names supported by formula engine
 | GetOperators | Gets list of operator names supported by formula engine
 | Validate | Validates the formuls
Top
Remarks
Formula manager
See Also

Reference

Autodesk.Revit.DB Namespace