GeomCombinationSetIterator Class

GeometryCreationUtilities Class

A utility that allows construction of basic solid shapes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGeometryCreationUtilities

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GeometryCreationUtilities
Public NotInheritable Class GeometryCreationUtilities
public ref class GeometryCreationUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GeometryCreationUtilities = class end

The GeometryCreationUtilities type exposes the following members.

Methods
Name | Description
CreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair, SolidOptions) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateExtrusionGeometry(IListCurveLoop, XYZ, Double) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateExtrusionGeometry(IListCurveLoop, XYZ, Double, SolidOptions) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateLoftGeometry | Creates a solid or open shell geometry by lofting between a sequence of curve loops.
CreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double, SolidOptions) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair, SolidOptions) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
CreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
Top
Remarks
The shapes created by these utilities are not a part of any Revit document, but can be used in conjunction with other geometric utilities from within API applications.
See Also

Reference

Autodesk.Revit.DB Namespace