WorksharingDisplaySettings Class

WorksharingSaveAsOptions Class

This class contains options specific to worksharing SaveAs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksharingSaveAsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksharingSaveAsOptions : IDisposable
Public Class WorksharingSaveAsOptions
    Implements IDisposable
public ref class WorksharingSaveAsOptions : IDisposable
type WorksharingSaveAsOptions =
    class
        interface IDisposable
    end

The WorksharingSaveAsOptions type exposes the following members.

Constructors
 | Name | Description
Public method | WorksharingSaveAsOptions | Constructs a new WorksharingSaveAsOptions with default settings.
Top
Properties
 | Name | Description
Public property | ClearTransmitted | For a transmitted model opened with DetachAndPreserveWorksets, clear its transmitted flag in the Save/SaveAs operation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OpenWorksetsDefault | The default set of user-worksets to open when opening the model in the UI. Default is AskUserToSpecify.
Public property | SaveAsCentral | Whether to save the new model as a central instead of local model. True: save as a central model. Default is false: save as a local model.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorksharingSaveAsOptions
Top
See Also

Reference

Autodesk.Revit.DB Namespace