LinePatternElement Class

LinePatternSegment Class

Represents a segment in a line pattern.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLinePatternSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinePatternSegment : IDisposable
Public Class LinePatternSegment
    Implements IDisposable
public ref class LinePatternSegment : IDisposable
type LinePatternSegment =
    class
        interface IDisposable
    end

The LinePatternSegment type exposes the following members.

Constructors
 | Name | Description
Public method | LinePatternSegment | Creates a line pattern segment.
Public method | LinePatternSegment(LinePatternSegmentType, Double) | Creates a line pattern segment with given type and length.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Gets and sets the length of the segment.
Public property | Type | Gets and sets the type of the segment.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LinePatternSegment
Top
See Also

Reference

Autodesk.Revit.DB Namespace