DimensionType Class

An object that represents a dimension style.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBDimensionType
Autodesk.Revit.DBSpotDimensionType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DimensionType : ElementType
Public Class DimensionType
    Inherits ElementType
public ref class DimensionType : public ElementType
type DimensionType =
    class
        inherit ElementType
    end

The DimensionType type exposes the following members.

Properties
 | Name | Description
Public property | AlternateUnits | The alternate units display mode for this DimensionType.
Public property | AlternateUnitsPrefix | The prefix text for the alternate units value.
Public property | AlternateUnitsSuffix | The suffix text for the alternate units value.
Public property | Prefix | The prefix text for the dimension value.
Public property | StyleType | The dimension style type of this DimensionType.
Public property | Suffix | The suffix text for the dimension value.
Top
Methods
 | Name | Description
Public method | CanHaveEqualityFormula | Checks whether this DimensionType can have an equality formula.
Public method | CanHaveOrdinateDimensionSetting | Checks whether this DimensionType can have an ordinate dimension settings.
Public method | GetAlternateUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | GetEqualityFormula | Gets an ordered list of the entries in the equality formula definition.
Public method | GetOrdinateDimensionSetting | Gets the ordinate dimension settings for this DimensionType.
Public method | GetSpecTypeId | Gets the spec of this dimension style.
Public method | GetUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the units value.
Public method | SetAlternateUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | SetEqualityFormula | Sets an ordered list of the entries to use in the equality formula definition.
Public method | SetOrdinateDimensionSetting | Sets the ordinate dimension settings for this DimensionType.
Public method | SetUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the units value.
Top
See Also

Reference

Autodesk.Revit.DB Namespace