SATImportOptions Class

SaveAsOptions Class

This class contains options available for saving a document to disk with a new filename.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSaveAsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SaveAsOptions : IDisposable
Public Class SaveAsOptions
    Implements IDisposable
public ref class SaveAsOptions : IDisposable
type SaveAsOptions =
    class
        interface IDisposable
    end

The SaveAsOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SaveAsOptions | Default constructor.
Top
Properties
 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumBackups | The maximum number of backups to keep on disk.
Public property | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SaveAsOptions
Public method | GetWorksharingOptions | Gets Worksharing options for SaveAs.
Public method | SetWorksharingOptions | Sets Worksharing options for SaveAs.
Top
See Also

Reference

Autodesk.Revit.DB Namespace