ImageInstance Class

An element that represents an instance of an image placed in a view
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBImageInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageInstance : Element
Public Class ImageInstance
    Inherits Element
public ref class ImageInstance : public Element
type ImageInstance =
    class
        inherit Element
    end

The ImageInstance type exposes the following members.

Properties
 | Name | Description
Public property | CanHaveSnaps | When true the ImageInstance has snaps that can be enabled with the EnableSnaps property
Public property | DrawLayer | The layer the ImageInstance will be drawn in.
Public property | EnableSnaps | When true the ImageInstance will have its snaps enabled, but only if CanHaveSnaps is true
Public property | Height | The height of the ImageInstance.
Public property | HeightScale | The factor applied to the ImageType to calculate the Height of the ImageInstance.
Public property | LockProportions | When true the proportion of Width to Height will be maintained
Public property | Width | The width of the ImageInstance.
Public property | WidthScale | The factor applied to the width of the ImageType to calculate the Width of the ImageInstance.
Top
Methods
 | Name | Description
 | Create | Creates a new ImageInstance element placed in a view.
Public method | GetLocation | Returns the location of one of the points of the ImageInstance
 | IsValidView | Check that the view is a valid view for ImageInstance elements
Public method | SetLocation | Moves the ImageInstance to the specified location
Top
See Also

Reference

Autodesk.Revit.DB Namespace