ElementCategoryFilter Class

ElementClassFilter Class

A filter used to match elements by their class.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementClassFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementClassFilter : ElementQuickFilter
Public Class ElementClassFilter
    Inherits ElementQuickFilter
public ref class ElementClassFilter : public ElementQuickFilter
type ElementClassFilter =
    class
        inherit ElementQuickFilter
    end

The ElementClassFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementClassFilter(Type) | Constructs a new instance of a filter to match elements by class.
Public method | ElementClassFilter(Type, Boolean) | Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetElementClass | The class for the filter.
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

This filter will match elements whose class is an exact match to the input class, or elements whose class is derived from the input class.

There is a small subset of Element subclasses in the API which are not supported by this filter. These types exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subtype. The following types are affected by this restriction:

  • Subclasses of Autodesk.Revit.DB.Material
  • Subclasses of Autodesk.Revit.DB.CurveElement
  • Subclasses of Autodesk.Revit.DB.ConnectorElement
  • Subclasses of Autodesk.Revit.DB.HostedSweep
  • Autodesk.Revit.DB.Architecture.Room
  • Autodesk.Revit.DB.Mechanical.Space
  • Autodesk.Revit.DB.Area
  • Autodesk.Revit.DB.Architecture.RoomTag
  • Autodesk.Revit.DB.Mechanical.SpaceTag
  • Autodesk.Revit.DB.AreaTag
  • Autodesk.Revit.DB.CombinableElement
  • Autodesk.Revit.DB.Mullion
  • Autodesk.Revit.DB.Panel
  • Autodesk.Revit.DB.AnnotationSymbol
  • Autodesk.Revit.DB.Structure.AreaReinforcementType
  • Autodesk.Revit.DB.Structure.PathReinforcementType
  • Autodesk.Revit.DB.AnnotationSymbolType
  • Autodesk.Revit.DB.Architecture.RoomTagType
  • Autodesk.Revit.DB.Mechanical.SpaceTagType
  • Autodesk.Revit.DB.AreaTagType
  • Autodesk.Revit.DB.Structure.TrussType

Example
C#
VB
C++
F#
Copy
// Use ElementClassFilter to find family instances whose name is 60" x 30" Student
ElementClassFilter filter = new ElementClassFilter(typeof(FamilyInstance));

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(filter);

// Use Linq query to find family instances whose name is 60" x 30" Student
var query = from element in collector
            where element.Name == "60\" x 30\" Student"
            select element;

// Cast found elements to family instances,
// this cast to FamilyInstance is safe because ElementClassFilter for FamilyInstance was used
List<FamilyInstance> familyInstances = query.Cast<FamilyInstance>().ToList<FamilyInstance>();
' Use ElementClassFilter to find family instances whose name is 60" x 30" Student
Dim filter As New ElementClassFilter(GetType(FamilyInstance))

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
collector.WherePasses(filter)

' Use Linq query to find family instances whose name is 60" x 30" Student
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "60"" x 30"" Student" _
 Select element

' Cast found elements to family instances,
' this cast to FamilyInstance is safe because ElementClassFilter for FamilyInstance was used
Dim familyInstances As List(Of FamilyInstance) = query.Cast(Of FamilyInstance)().ToList()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace