RoutingPreferenceManager Class

RoutingPreferenceRule Class

A class representing a rule set in MEP routing preferences.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRoutingPreferenceRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoutingPreferenceRule : IDisposable
Public Class RoutingPreferenceRule
    Implements IDisposable
public ref class RoutingPreferenceRule : IDisposable
type RoutingPreferenceRule =
    class
        interface IDisposable
    end

The RoutingPreferenceRule type exposes the following members.

Constructors
 | Name | Description
Public method | RoutingPreferenceRule | Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.
Top
Properties
 | Name | Description
Public property | Description | The description of the routing preference rule.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPPartId | The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
Public property | NumberOfCriteria | Gets the number of routing criteria.
Public property | RoutingPreferenceManager | Gets the routing preference manager that owns this rule.
Top
Methods
 | Name | Description
Public method | AddCriterion | Adds a new routing criterion.
Public method | Dispose | Releases all resources used by the RoutingPreferenceRule
Public method | GetCriterion | Gets the specified criteria.
Public method | RemoveCriteron | Removes an existing criterion.
Top
See Also

Reference

Autodesk.Revit.DB Namespace