BuiltInFailuresAssemblyFailures Class

BuiltInFailures.AutoJoinFailures Class

BuiltInFailuresAutoJoinFailures Class

Failures about AutoJoin.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresAutoJoinFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AutoJoinFailures
Public NotInheritable Class AutoJoinFailures
public ref class AutoJoinFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AutoJoinFailures = class end

The BuiltInFailuresAutoJoinFailures type exposes the following members.

Properties
Name | Description
DesignOptionAndWorksetViolation | Can't make the expected join because of editability and design option restrictions.
DesignOptionCannotReference | Design Option ' [Name] ' cannot reference Design Option ' [Name] '.
OtherNonEditJoinFailure | Two elements were not automatically joined because other elements at join are not editable.
UnexpectedJoinFailure | Join failure caused by editability or design option related problem.
Unknown | Unknown
WorksetJoinWarn | Two elements were not automatically joined because one or both is not editable.
Top
See Also

Reference

Autodesk.Revit.DB Namespace