SlabEdgeType Class

SlabShapeCrease Class

Represents a crease of a slab shape edited element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSlabShapeCrease

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SlabShapeCrease : IDisposable
Public Class SlabShapeCrease
    Implements IDisposable
public ref class SlabShapeCrease : IDisposable
type SlabShapeCrease =
    class
        interface IDisposable
    end

The SlabShapeCrease type exposes the following members.

Properties
 | Name | Description
Public property | CreaseType | The type of the crease.
Public property | Curve | The geometry of the crease.
Public property | EndPoints | The vertices of the crease.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SlabShapeCrease
Top
See Also

Reference

Autodesk.Revit.DB Namespace