ElementTransformUtils Class

ElementTransformUtils.MoveElement Method

ElementTransformUtilsMoveElement Method

Moves one element by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void MoveElement(
    Document document,
    ElementId elementToMove,
    XYZ translation
)
Public Shared Sub MoveElement (
    document As Document,
    elementToMove As ElementId,
    translation As XYZ
)
public:
static void MoveElement(
    Document^ document,
    ElementId^ elementToMove,
    XYZ^ translation
)
static member MoveElement :
        document : Document *
        elementToMove : ElementId *
        translation : XYZ -> unit

Parameters

document Document
The document that owns the elements.
elementToMove ElementId
The id of the element to move.
translation XYZ
The translation vector for the elements.
Exceptions
Exception | Condition
ArgumentException | The element elementToMove does not exist in the document
ArgumentNullException | A non-optional argument was null
InvalidOperationException | If we are not able to move the element (for example, if it is pinned). -or- Move operation failed.
Example
C#
VB
C++
F#
Copy
public void MoveColumn(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
    // get the column current location
    LocationPoint columnLocation = column.Location as LocationPoint;

    XYZ oldPlace = columnLocation.Point;

    // Move the column to new location.
    XYZ newPlace = new XYZ(10, 20, 30);
    ElementTransformUtils.MoveElement(document, column.Id, newPlace);

    // now get the column's new location
    columnLocation = column.Location as LocationPoint;
    XYZ newActual = columnLocation.Point;

    string info = "Original Z location: " + oldPlace.Z +
                  "\nNew Z location: " + newActual.Z;

    TaskDialog.Show("Revit",info);
}
Public Sub MoveColumn(document As Autodesk.Revit.DB.Document, column As FamilyInstance)
    ' get the column current location
    Dim columnLocation As LocationPoint = TryCast(column.Location, LocationPoint)

    Dim oldPlace As XYZ = columnLocation.Point

    ' Move the column to new location.
    Dim newPlace As New XYZ(10, 20, 30)
    ElementTransformUtils.MoveElement(document, column.Id, newPlace)

    ' now get the column's new location
    columnLocation = TryCast(column.Location, LocationPoint)
    Dim newActual As XYZ = columnLocation.Point

    Dim info As String = ("Original Z location: " + oldPlace.Z & vbLf & "New Z location: ") + newActual.Z

    TaskDialog.Show("Revit", info)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference