RevisionNumberingSequence Class

Defines the sequences by which numbers are assigned to Revisions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBRevisionNumberingSequence

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevisionNumberingSequence : Element
Public Class RevisionNumberingSequence
    Inherits Element
public ref class RevisionNumberingSequence : public Element
type RevisionNumberingSequence =
    class
        inherit Element
    end

The RevisionNumberingSequence type exposes the following members.

Properties
 | Name | Description
Public property | NumberType | Indicates the revision number type of the revision numbering sequence.
Public property | SequenceName | The name of this revision numbering sequence.
Top
Methods
 | Name | Description
 | CreateAlphanumericSequence | Creates a new alphanumeric revision numbering sequence in the document.
 | CreateNumericSequence | Creates a new numeric revision numbering sequence in the document.
 | GetAllRevisionNumberingSequences | Gets all of the revision numbering sequences from the document.
Public method | GetAlphanumericRevisionSettings | Returns a copy of the AlphanumericRevisionSettings owned by this revision numbering sequence.
Public method | GetNumericRevisionSettings | Returns a copy of the NumericRevisionSettings owned by this revision numbering sequence.
Public method | HasValidAlphanumericRevisionSettings | Checks whether the revision numbering sequence owns a valid alphanumeric revision settings.
Public method | HasValidNumericRevisionSettings | Checks whether the revision numbering sequence owns a valid numeric revision settings.
Public method | HasValidRevisionSettingsForNumberType | Checks whether the revision numbering sequence owns a valid revision settings for number type.
Public method | SetAlphanumericRevisionSettings | Replaces the current alphanumeric revision numbering settings with the provided settings.
Public method | SetNumericRevisionSettings | Replaces the current numeric revision numbering settings with the provided settings.
Top
Remarks
Revision numbering is numeric or alphanumeric. Revision numbering is assigned to Revisions to control the numbering scheme of that Revision.
See Also

Reference

Autodesk.Revit.DB Namespace