DefinitionGroups Class

Definitions Class

A base class that supports the addition of new parameter definitions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDefinitions
Autodesk.Revit.DBExternalDefinitions
Autodesk.Revit.DBInternalDefinitions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Definitions : IEnumerable<Definition>,
    IDisposable
Public Class Definitions
    Implements IEnumerable(Of Definition), IDisposable
public ref class Definitions : IEnumerable<Definition^>,
    IDisposable
type Definitions =
    class
        interface IEnumerable<Definition>
        interface IDisposable
    end

The Definitions type exposes the following members.

Constructors
 | Name | Description
Public method | Definitions | Constructs an empty set of parameter definitions.
Top
Properties
 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty.
Public property | Item | Retrieves a definition by a given name.
Public property | Size | The number of definitions in the collection.
Top
Methods
 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set.
Public method | Create | Creates a new parameter definition using specified options.
Public method | Dispose | Releases all resources used by the Definitions
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Top
Remarks
There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.
See Also

Reference

Autodesk.Revit.DB Namespace