ValidateCurveLoopsOptions Class

ValueAtPointBase Class

A base class representing storage of values at a given point.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBValueAtPointBase
Autodesk.Revit.DB.AnalysisValueAtPoint
Autodesk.Revit.DB.AnalysisVectorAtPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValueAtPointBase : IDisposable
Public Class ValueAtPointBase
    Implements IDisposable
public ref class ValueAtPointBase : IDisposable
type ValueAtPointBase =
    class
        interface IDisposable
    end

The ValueAtPointBase type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | ClearAllFlags | Sets flags for all measurements to ValueAtPointFlags::None.
Public method | ClearFlagsAt | Sets flags for the given measurement to ValueAtPointFlags::None.
Public method | Dispose | Releases all resources used by the ValueAtPointBase
Public method | GetFlags | Returns flags for the given measurement.
Public method | SetFlags(IListInt32) | Independently sets the flags associated to all measurements.
Public method | SetFlags(Int32) | Sets the flags associated to all measurements to the same value.
Public method | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement.
Top
Remarks
This class stores a set of measurements and corresponding mapped flags. The flags are defined in the enumerated type ValueAtPointFlags.
See Also

Reference

Autodesk.Revit.DB Namespace