BRepBuilderPersistentIds Class

BRepBuilderState Enumeration

This class defines an enumerative type used to specify the state of a BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BRepBuilderState
Public Enumeration BRepBuilderState
public enum class BRepBuilderState
type BRepBuilderState
Members
Member name | Value | Description
InvalidState | 0 | BRepBuilder is in an invalid state. No further productive use is possible.
AcceptingData | 1 | BRepBuilder is accumulating data. New b-rep components such as edges or faces may be added.
Completed | 2 | Finish() successfully created a valid Geometry object. No new data may be added.The built object may be retrieved via GetResult().
See Also

Reference

Autodesk.Revit.DB Namespace