BuiltInFailuresLevelAssociationFailures Class

BuiltInFailures.LevelFailures Class

BuiltInFailuresLevelFailures Class

Failures about Level.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresLevelFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LevelFailures
Public NotInheritable Class LevelFailures
public ref class LevelFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LevelFailures = class end

The BuiltInFailuresLevelFailures type exposes the following members.

Properties
Name | Description
NoLevelsLeft | There are no levels or plan views remaining in the project.
NoLevelsLeftReloading | As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
StoryAboveDeleted | The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.
StoryAboveMoved | The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.
StoryAboveNonStoryLevel | The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.
Top
See Also

Reference

Autodesk.Revit.DB Namespace