RevolvedSurface Class
IsValidProfileCurve Overload

RoofBase Class

Represents all kinds of Roofs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBRoofBase
Autodesk.Revit.DBExtrusionRoof
Autodesk.Revit.DBFootPrintRoof

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoofBase : HostObject
Public Class RoofBase
    Inherits HostObject
public ref class RoofBase : public HostObject
type RoofBase =
    class
        inherit HostObject
    end

The RoofBase type exposes the following members.

Properties
 | Name | Description
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
Public property | RoofType | Retrieve or set the Type.
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing.
Top
Methods
 | Name | Description
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase.
Top
Remarks
The RoofBase object represents all kinds of roof in Revit.
See Also

Reference

Autodesk.Revit.DB Namespace