ModelNurbSpline Class

ModelPath Class

A path to a file stored on a disk or on a server.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBModelPath
Autodesk.Revit.DBFilePath
Autodesk.Revit.DBServerPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelPath : IDisposable
Public Class ModelPath
    Implements IDisposable
public ref class ModelPath : IDisposable
type ModelPath =
    class
        interface IDisposable
    end

The ModelPath type exposes the following members.

Properties
 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud.
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360.
Public property | Empty | Whether this path is empty
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model.
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path)
Top
Methods
 | Name | Description
Public method | Compare | Compares this ModelPath with another
Public method | Dispose | Releases all resources used by the ModelPath
Public method | GetModelGUID | A GUID identifying the Revit cloud model.
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated.
Top
Remarks
ModelPaths are paths to another file. They can refer to Revit models, or to any of Revit's external file references (DWG links, for example.) Paths can be relative or absolute, but they must include an extension indicating what kind of file it is. Relative paths are generally relative to the currently opened document. If the current document is workshared, paths will be treated as relative to the central model. To create a ModelPath, use the derived classes FilePath , ServerPath, or use [!:Autodesk::Revit::DB::ModelPathUtils::ConvertCloudGUIDsToCloudPath(System::Guid, System::Guid)] for a cloud model path. The class ModelPathUtils contains utility functions for converting ModelPaths to and from strings.
See Also

Reference

Autodesk.Revit.DB Namespace