CancellationListener Class

Categories Class

The Categories object is a map that contains all the top-level Category objects within the Document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCategoryNameMap
Autodesk.Revit.DBCategories

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Categories : CategoryNameMap
Public Class Categories
    Inherits CategoryNameMap
public ref class Categories : public CategoryNameMap
type Categories =
    class
        inherit CategoryNameMap
    end

The Categories type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMapIsEmpty)
Public property | ItemBuiltInCategory | Retrieves a category object corresponding to a BuiltInCategory id.
Public property | ItemString | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMapItemString)
Public property | Size | The total number of top-level categories in the document. (Overrides CategoryNameMapSize)
Top
Methods
 | Name | Description
Public method | Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMapContains(String))
Public method | ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMapForwardIterator)
Public method | GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMapGetEnumerator)
Public method | Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMapInsert(String, Category))
 | NewSubcategory | Add a new subcategory into the Autodesk Revit document.
Public method | ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMapReverseIterator)
Top
Remarks
Use this object to retrieve categories by name or by BuiltInCategory id.
Example
C#
VB
C++
F#
Copy
// Get settings of current document
Settings documentSettings = document.Settings;

// Get all categories of current document
Categories groups = documentSettings.Categories;

// Show the number of all the categories to the user
String prompt = "Number of all categories in current Revit document:" + groups.Size;

// get Floor category according to OST_Floors and show its name
Category floorCategory = groups.get_Item(BuiltInCategory.OST_Floors);
prompt += floorCategory.Name;

// Give the user some information
TaskDialog.Show("Revit",prompt);
' Get settings of current document
Dim documentSettings As Settings = document.Settings

' Get all categories of current document
Dim groups As Categories = documentSettings.Categories

' Show the number of all the categories to the user
Dim prompt As [String] = "Number of all categories in current Revit document:" + groups.Size

' get Floor category according to OST_Floors and show its name
Dim floorCategory As Category = groups.Item(BuiltInCategory.OST_Floors)
prompt += floorCategory.Name

' Give the user some information
TaskDialog.Show("Revit", prompt)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace