DocumentPreviewSettings Class

DocumentSet Class

A set that can contain any documents.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDocumentSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocumentSet : APIObject,
    IEnumerable
Public Class DocumentSet
    Inherits APIObject
    Implements IEnumerable
public ref class DocumentSet : public APIObject,
    IEnumerable
type DocumentSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The DocumentSet type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentSet | Initializes a new instance of the DocumentSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace