PlanCircuitSetIterator Class

Plane Class

A Planar surface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBPlane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Plane : Surface
Public Class Plane
    Inherits Surface
public ref class Plane : public Surface
type Plane =
    class
        inherit Surface
    end

The Plane type exposes the following members.

Properties
 | Name | Description
Public property | Normal | Plane normal.
Public property | Origin | Plane origin.
Public property | XVec | Axis defining the first parametric direction of the plane.
Public property | YVec | Axis defining the second parametric direction of the plane.
Top
Methods
 | Name | Description
 | Create | Creates a Plane object defined by a local frame of reference.
 | CreateByNormalAndOrigin | Constructs a Plane object from a normal and an origin represented as XYZ objects. Follows the standard conventions for a planar surface. The constructed Plane object will pass through origin and be perpendicular to normal. The X and Y axes of the plane will be defined arbitrarily.
 | CreateByOriginAndBasis | Creates a Plane object defined by the two orthogonal unit vectors and passing through the origin point supplied as arguments.
 | CreateByThreePoints | Creates a Plane object passing through three points supplied as arguments.
Top
Remarks
The parametric equation of the plane is S(u, v) = origin + u*xVec + v*yVec.
Example
C#
VB
C++
F#
Copy
public void GetPlaneInfo(Plane plane)
{
    XYZ origin = plane.Origin;
    XYZ normal = plane.Normal;
    XYZ xVec = plane.XVec;
    XYZ yVec = plane.YVec;

    StringBuilder info = new StringBuilder();
    info.AppendLine("Plane Data:");
    info.AppendLine(string.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z));
    info.AppendLine(string.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z));
    info.AppendLine(string.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z));
    info.AppendLine(string.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z));

    TaskDialog.Show("Revit",info.ToString());
}
Public Sub GetPlaneInfo(plane As Plane)
    Dim origin As XYZ = plane.Origin
    Dim normal As XYZ = plane.Normal
    Dim xVec As XYZ = plane.XVec
    Dim yVec As XYZ = plane.YVec

    Dim info As New StringBuilder()
    info.AppendLine("Plane Data:")
    info.AppendLine(String.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z))
    info.AppendLine(String.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z))
    info.AppendLine(String.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z))
    info.AppendLine(String.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z))

    TaskDialog.Show("Revit", info.ToString())
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace