BoundingBoxContainsPointFilter Class

BoundingBoxIntersectsFilter Class

A filter used to match elements with a bounding box that intersects the given Outline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBBoundingBoxIntersectsFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BoundingBoxIntersectsFilter : ElementQuickFilter
Public Class BoundingBoxIntersectsFilter
    Inherits ElementQuickFilter
public ref class BoundingBoxIntersectsFilter : public ElementQuickFilter
type BoundingBoxIntersectsFilter =
    class
        inherit ElementQuickFilter
    end

The BoundingBoxIntersectsFilter type exposes the following members.

Constructors
 | Name | Description
Public method | BoundingBoxIntersectsFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Top
Properties
 | Name | Description
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Top
Methods
 | Name | Description
Public method | GetBoundingBox | Gets the outline being used for this filter.
Top
Remarks
This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Use BoundingBoxIntersects filter to find elements with a bounding box that intersects the
// given Outline in the document.

// Create a Outline, uses a minimum and maximum XYZ point to initialize the outline.
Outline myOutLn = new Outline(new XYZ(0, 0, 0), new XYZ(100, 100, 100));

// Create a BoundingBoxIntersects filter with this Outline
BoundingBoxIntersectsFilter filter = new BoundingBoxIntersectsFilter(myOutLn);

// Apply the filter to the elements in the active document
// This filter excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find all walls which don't intersect with BoundingBox: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxIntersectsFilter invertFilter = new BoundingBoxIntersectsFilter(myOutLn, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> notIntersectWalls =
    collector.OfClass(typeof(Wall)).WherePasses(invertFilter).ToElements();
' Use BoundingBoxIntersects filter to find elements with a bounding box that intersects the
' given Outline in the document.

' Create a Outline, uses a minimum and maximum XYZ point to initialize the outline.
Dim myOutLn As New Outline(New XYZ(0, 0, 0), New XYZ(100, 100, 100))

' Create a BoundingBoxIntersects filter with this Outline
Dim filter As New BoundingBoxIntersectsFilter(myOutLn)

' Apply the filter to the elements in the active document
' This filter excludes all objects derived from View and objects derived from ElementType
Dim collector As New FilteredElementCollector(document)
Dim elements As IList(Of Element) = collector.WherePasses(filter).ToElements()

' Find all walls which don't intersect with BoundingBox: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim invertFilter As New BoundingBoxIntersectsFilter(myOutLn, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notIntersectWalls As IList(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(invertFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace