Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DBModelArc
Autodesk.Revit.DBModelEllipse
Autodesk.Revit.DBModelHermiteSpline
Autodesk.Revit.DBModelLine
Autodesk.Revit.DBModelNurbSpline

ModelCurve Properties

The ModelCurve type exposes the following members.

Properties
 | Name | Description
Public property | IsReferenceLine | Indicates if this curve is a reference curve.
Public property | Subcategory | The subcategory.
Public property | TrussCurveType | The truss curve type of this model curve.
Top
See Also

Reference