WorksetKindFilter Class

WorksetPreview Class

Represents an accessor for workset data which can be obtained from an unopened document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksetPreview
Autodesk.Revit.DBWorkset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksetPreview : IDisposable
Public Class WorksetPreview
    Implements IDisposable
public ref class WorksetPreview : IDisposable
type WorksetPreview =
    class
        interface IDisposable
    end

The WorksetPreview type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id of the workset.
Public property | IsDefaultWorkset | Whether the workset is the default one.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Name of the workset.
Public property | Owner | User name of the workset.
Public property | UniqueId | UniqueId of the workset.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorksetPreview
Top
Remarks
As a base class of Workset, this class has limited access to data. WorksetPreviews are obtained from WorksharingUtils.GetUserWorksetInfo() from an unopened document.
See Also

Reference

Autodesk.Revit.DB Namespace