SpatialElementCalculationLocation Class

SpatialElementCalculationPoint Class

SpatialElementCalculationPoint is used as the search point for family instances placement inside rooms and spaces.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElementCalculationLocation
Autodesk.Revit.DBSpatialElementCalculationPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementCalculationPoint : SpatialElementCalculationLocation
Public Class SpatialElementCalculationPoint
    Inherits SpatialElementCalculationLocation
public ref class SpatialElementCalculationPoint : public SpatialElementCalculationLocation
type SpatialElementCalculationPoint =
    class
        inherit SpatialElementCalculationLocation
    end

The SpatialElementCalculationPoint type exposes the following members.

Properties
 | Name | Description
Public property | Position | The position of the "in" spatial element calculation point.
Top
Methods
 | Name | Description
Top
Remarks
The Spatial Element Calculation Point is graphically showed as a location point marker with a "snake" line from the origin of the family. If the Spatial Element Calculation Point is turned on, this point will be used as a search point for room and space relations for all instances of this family.
See Also

Reference

Autodesk.Revit.DB Namespace