DocumentDifference Class

DocumentPreviewSettings Class

Contains the settings related to the saving of preview images for a given document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDocumentPreviewSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocumentPreviewSettings : IDisposable
Public Class DocumentPreviewSettings
    Implements IDisposable
public ref class DocumentPreviewSettings : IDisposable
type DocumentPreviewSettings =
    class
        interface IDisposable
    end

The DocumentPreviewSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsViewUpdateForced | Identifies if Revit will update the preview view if necessary.
Public property | PreviewViewId | The view id that will be used to generate the preview.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentPreviewSettings
Public method | ForceViewUpdate | Sets Revit to update the preview view if necessary.
Public method | IsViewIdValidForPreview | Identifies if the view id is valid as a preview view id.
Top
Example
C#
VB
C++
F#
Copy
// Get the document's preview settings
DocumentPreviewSettings settings = document.GetDocumentPreviewSettings();

// Find a candidate 3D view
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(View3D));

Func<View3D, bool> isValidForPreview = v => settings.IsViewIdValidForPreview(v.Id);

View3D viewForPreview = collector.OfType<View3D>().First<View3D>(isValidForPreview);

// Set the preview settings
using (Transaction setTransaction = new Transaction(document, "Set preview view id"))
{
   setTransaction.Start();
   settings.PreviewViewId = viewForPreview.Id;
   setTransaction.Commit();
}

// Save the document
document.Save();
' Get the document's preview settings
Dim settings As DocumentPreviewSettings = document.GetDocumentPreviewSettings()

' Find a candidate 3D view
Dim collector As New FilteredElementCollector(document)
collector.OfClass(GetType(View3D))

Dim isValidForPreview As Func(Of View3D, Boolean) = Function(v) settings.IsViewIdValidForPreview(v.Id)

Dim viewForPreview As View3D = collector.OfType(Of View3D)().First(isValidForPreview)

' Set the preview settings
Using setTransaction As New Transaction(document, "Set preview view id")
    setTransaction.Start()
    settings.PreviewViewId = viewForPreview.Id
    setTransaction.Commit()
End Using

' Save the document
document.Save()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace