RoofBase Class

RoofType Class

Represents a specific type of roof.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBRoofType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoofType : HostObjAttributes
Public Class RoofType
    Inherits HostObjAttributes
public ref class RoofType : public HostObjAttributes
type RoofType =
    class
        inherit HostObjAttributes
    end

The RoofType type exposes the following members.

Properties
 | Name | Description
Public property | ThermalProperties | The calculated and settable thermal properties of the RoofType
Top
Methods
 | Name | Description
Top
Remarks
All roof type objects available in the project can be retrieved from the Document object via the RoofTypes property. Every Roof object has a RoofType property that returns a RoofType object representing the type. This same RoofType property can also be used to change the type of the roof by setting it to a different type.
See Also

Reference

Autodesk.Revit.DB Namespace