RPCNode Class

RuledFace Class

A ruled face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBRuledFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RuledFace : Face
Public Class RuledFace
    Inherits Face
public ref class RuledFace : public Face
type RuledFace =
    class
        inherit Face
    end

The RuledFace type exposes the following members.

Properties
 | Name | Description
Public property | Curve | Profile curves of the surface.
Public property | IsExtruded | Determines if this is an extruded ruled surface.
Public property | Point | Profile points of the surface.
Public property | RulingsAreParallel | Determines if the rulings of this ruled surface are parallel.
Top
Methods
 | Name | Description
Top
Remarks
A ruled surface is created by sweeping a line between two profile curves or between a curve and a point (a point and a curve). For details on the parameterization, refer to the documentation for RuledSurface.
Example
C#
VB
C++
F#
Copy
private void GetRuledFaceInfo(Face face)
{
    RuledFace ruledFace = face as RuledFace;
    if (null != ruledFace)
    {
        Curve curve = ruledFace.get_Curve(0);
        XYZ point = ruledFace.get_Point(0);
    }
}
Private Sub GetRuledFaceInfo(face As Face)
    Dim ruledFace As RuledFace = TryCast(face, RuledFace)
    If ruledFace IsNot Nothing Then
        Dim curve As Curve = ruledFace.Curve(0)
        Dim point As XYZ = ruledFace.Point(0)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace