ViewSystemsAnalysisReport Class

Represents a report instance of the systems analysis.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DB.AnalysisViewSystemsAnalysisReport

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSystemsAnalysisReport : View
Public Class ViewSystemsAnalysisReport
    Inherits View
public ref class ViewSystemsAnalysisReport : public View
type ViewSystemsAnalysisReport =
    class
        inherit View
    end

The ViewSystemsAnalysisReport type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDateAndTime | Identifies the analysis date and time when it was requested.
Public property | ReportStyle | The report style that specifies the display content.
Public property | SystemsAnalysisOutputFolder | The full path of the output folder for systems analysis
Public property | SystemsAnalysisWorkflowFile | The full path name of the original system analysis workflow file.
Public property | WeatherFile | The full path name of the weather file used for the systems analysis.
Top
Methods
 | Name | Description
 | CancelSystemsAnalysis | Cancels the systems analysis based on the report element id.
 | Create | Creates a new view for the systems analysis report.
 | GetLatestSystemsAnalysisReport | Gets the latest report of systems analysis.
Public method | GetReportContent | Gets the report content in this view.
Public method | IsAnalysisCompleted | Indicates if the background systems analysis has completed or not.
 | RequestSystemsAnalysis | Requests a new systems analysis in the background.
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace