LogicalAndFilter Class

LogicalOrFilter Class

A filter that contains a set of filters. The filter passes when any filter in the set passes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBLogicalOrFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LogicalOrFilter : ElementLogicalFilter
Public Class LogicalOrFilter
    Inherits ElementLogicalFilter
public ref class LogicalOrFilter : public ElementLogicalFilter
type LogicalOrFilter =
    class
        inherit ElementLogicalFilter
    end

The LogicalOrFilter type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalOrFilter(IListElementFilter) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalOrFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.
See Also

Reference

Autodesk.Revit.DB Namespace