DimensionSegmentArrayIterator Class

DimensionShape Enumeration

An enumerated type to list dimension type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DimensionShape
Public Enumeration DimensionShape
public enum class DimensionShape
type DimensionShape
Members
Member name | Value | Description
Linear | 0 | Linear dimension.
Angular | 1 | Angular dimension.
Radial | 2 | Radial dimension.
ArcLength | 3 | ArcLength dimension.
Spot | 4 | Spot dimension.
Diameter | 5 | Diameter dimension.
Unknown | 6 | Unknown type dimension.
See Also

Reference

Autodesk.Revit.DB Namespace