IFCCategoryTemplate Class

IFCCategoryTemplate.GetActiveTemplate Method

IFCCategoryTemplateGetActiveTemplate Method

Gets the active mapping template element in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IFCCategoryTemplate GetActiveTemplate(
    Document document
)
Public Shared Function GetActiveTemplate (
    document As Document
) As IFCCategoryTemplate
public:
static IFCCategoryTemplate^ GetActiveTemplate(
    Document^ document
)
static member GetActiveTemplate :
        document : Document -> IFCCategoryTemplate

Parameters

document Document
The document to find the active mapping template.

Return Value

IFCCategoryTemplate
The active mapping template, or if none.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference