ReferenceIntersector Class

ReferencePlane Class

Represents a reference plane of Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDatumPlane
Autodesk.Revit.DBReferencePlane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReferencePlane : DatumPlane
Public Class ReferencePlane
    Inherits DatumPlane
public ref class ReferencePlane : public DatumPlane
type ReferencePlane =
    class
        inherit DatumPlane
    end

The ReferencePlane type exposes the following members.

Properties
 | Name | Description
Public property | BubbleEnd | The bubble end of the reference plane.
Public property | Direction | The direction of the reference plane.
Public property | FreeEnd | The free end of the reference plane.
Public property | Name | The name property of the reference plane.
Public property | Normal | The normal vector of the reference plane.
Top
Methods
 | Name | Description
Public method | Flip | Flips the orientation of the reference plane.
Public method | GetPlane | Returns the geometry plane to which the reference plane is assigned.
Public method | GetReference | Returns the geometry reference of the reference plane.
Top
Example
C#
VB
C++
F#
Copy
private void Getinfo_ReferencePlane(ReferencePlane refPlane)
{
    string message = "Reference Plane: ";
    //get the bubble end of the reference plane
    XYZ bubbleEnd = refPlane.BubbleEnd;
    message += "\nBubble end: (" + bubbleEnd.X + ", "
                       + bubbleEnd.Y + ", " + bubbleEnd.Z + ")";

    //get the direction of the reference plane
    XYZ direction = refPlane.Direction;
    message += "\nDirection: (" + direction.X + ", "
                    + direction.Y + ", " + direction.Z + ")";

    //get the freeEnd of the reference plane
    XYZ freeEnd = refPlane.FreeEnd;
    message += "\nFree End: (" + freeEnd.X + ", "
                    + freeEnd.Y + ", " + freeEnd.Z + ")";

    //get the name of the reference plane
    message += "\nName: " + refPlane.Name;

    //get the normal vector of the reference plane
    XYZ normal = refPlane.Normal;
    message += "\nNormal vector: (" + normal.X + ", "
                    + normal.Y + ", " + normal.Z + ")";

    //get the geometry plane to which the reference plane assigned
    Autodesk.Revit.DB.Plane plane = refPlane.GetPlane();
    message += "\norigin of the plane: (" + plane.Origin.X + ", "
                    + plane.Origin.Y + ", " + plane.Origin.Z + ")";

    message += "\nnormal of the plane: (" + plane.Normal.X + ", "
                    + plane.Normal.Y + ", " + plane.Normal.Z + ")";

    message += "\nXvec of the plane: (" + plane.XVec.X + ", "
                    + plane.XVec.Y + ", " + plane.XVec.Z + ")";

    message += "\nYvec of the plane: (" + plane.YVec.X + ", "
                    + plane.YVec.Y + ", " + plane.YVec.Z + ")";

    TaskDialog.Show("Revit",message);
}
Private Sub Getinfo_ReferencePlane(refPlane As ReferencePlane)
    Dim message As String = "Reference Plane: "
    'get the bubble end of the reference plane
    Dim bubbleEnd As XYZ = refPlane.BubbleEnd
    message += ((vbLf & "Bubble end: (" + bubbleEnd.X & ", ") + bubbleEnd.Y & ", ") + bubbleEnd.Z & ")"

    'get the direction of the reference plane
    Dim direction As XYZ = refPlane.Direction
    message += ((vbLf & "Direction: (" + direction.X & ", ") + direction.Y & ", ") + direction.Z & ")"

    'get the freeEnd of the reference plane
    Dim freeEnd As XYZ = refPlane.FreeEnd
    message += ((vbLf & "Free End: (" + freeEnd.X & ", ") + freeEnd.Y & ", ") + freeEnd.Z & ")"

    'get the name of the reference plane
    message += vbLf & "Name: " & Convert.ToString(refPlane.Name)

    'get the normal vector of the reference plane
    Dim normal As XYZ = refPlane.Normal
    message += ((vbLf & "Normal vector: (" + normal.X & ", ") + normal.Y & ", ") + normal.Z & ")"

    'get the geometry plane to which the reference plane assigned
 Dim plane As Autodesk.Revit.DB.Plane = refPlane.GetPlane()
    message += ((vbLf & "origin of the plane: (" + plane.Origin.X & ", ") + plane.Origin.Y & ", ") + plane.Origin.Z & ")"

    message += ((vbLf & "normal of the plane: (" + plane.Normal.X & ", ") + plane.Normal.Y & ", ") + plane.Normal.Z & ")"

    message += ((vbLf & "Xvec of the plane: (" + plane.XVec.X & ", ") + plane.XVec.Y & ", ") + plane.XVec.Z & ")"

    message += ((vbLf & "Yvec of the plane: (" + plane.YVec.X & ", ") + plane.YVec.Y & ", ") + plane.YVec.Z & ")"

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace