DetailElementOrderUtils Class
SendToBack Overload

DetailEllipse Class

Represents a DetailEllipse within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBDetailCurve
Autodesk.Revit.DBDetailEllipse

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DetailEllipse : DetailCurve
Public Class DetailEllipse
    Inherits DetailCurve
public ref class DetailEllipse : public DetailCurve
type DetailEllipse =
    class
        inherit DetailCurve
    end

The DetailEllipse type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace