UpdaterData Class

UpdaterId Class

A unique identifier of an Updater
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UpdaterId : IDisposable
Public Class UpdaterId
    Implements IDisposable
public ref class UpdaterId : IDisposable
type UpdaterId =
    class
        interface IDisposable
    end

The UpdaterId type exposes the following members.

Constructors
 | Name | Description
Public method | UpdaterId | creates an instance of UpdaterId for given AddInId and a given GUID value
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the UpdaterId
Public method | GetAddInId | AddInId of the UpdaterId
Public method | GetGUID | GUID value of the UpdaterId
Top
Remarks
UpdaterID used as a key to register and unregister Updaters and UpdateTriggers in Revit application
See Also

Reference

Autodesk.Revit.DB Namespace