FilterOperatorAndTextString Class

FilterRule Class

Defines a boolean operation that can be used to cull elements from a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterRule : IDisposable
Public Class FilterRule
    Implements IDisposable
public ref class FilterRule : IDisposable
type FilterRule =
    class
        interface IDisposable
    end

The FilterRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilterRule
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
Top
See Also

Reference

Autodesk.Revit.DB Namespace