PointOnEdgeFaceIntersection Class

PointOnFace Class

Define a ReferencePoint relative to a Face.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointElementReference
Autodesk.Revit.DBPointOnFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointOnFace : PointElementReference
Public Class PointOnFace
    Inherits PointElementReference
public ref class PointOnFace : public PointElementReference
type PointOnFace =
    class
        inherit PointElementReference
    end

The PointOnFace type exposes the following members.

Properties
 | Name | Description
Public property | UV | The location of the point in the surface's coordinate system.
Top
Methods
 | Name | Description
Public method | GetFaceReference | Get a copy of the face reference.
Public method | SetFaceReference | Change the face reference.
Top
Remarks
A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).
See Also

Reference

Autodesk.Revit.DB Namespace