NurbsSurfaceData Class

NurbsSurfaceData Properties

The NurbsSurfaceData type exposes the following members.

Properties
 | Name | Description
Public property | DegreeU | The degree of the spline in the u-direction.
Public property | DegreeV | The degree of the spline in the v-direction.
Public property | IsRational | Tells if the spline is rational or not. If it is true (rational), then the NURBS is a piecewise rational polynomial function. If it is false (non-rational), then the NURBS is a piecewise polynomial function.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReverseOrientation | If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.
Top
See Also

Reference