InternalOrigin Class

IntersectingElementData Class

Stores information of an element that intersects with another element
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBIntersectingElementData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IntersectingElementData : IDisposable
Public Class IntersectingElementData
    Implements IDisposable
public ref class IntersectingElementData : IDisposable
type IntersectingElementData =
    class
        interface IDisposable
    end

The IntersectingElementData type exposes the following members.

Properties
 | Name | Description
Public property | IntersectedElementId | Id of the intersected element.
Public property | IntersectingElementId | Id of the intersecting element.
Public property | IntersectionType | The intersection type.
Public property | IntersectionVolume | The intersection volume.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the IntersectingElementData
Top
See Also

Reference

Autodesk.Revit.DB Namespace