ModelHermiteSpline Class

ModelLine Class

Represents a ModelLine within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DBModelLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelLine : ModelCurve
Public Class ModelLine
    Inherits ModelCurve
public ref class ModelLine : public ModelCurve
type ModelLine =
    class
        inherit ModelCurve
    end

The ModelLine type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
Geometry-related functionality is provided by the geometry curve object from the ModelCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace