ParameterFilterRuleFactory Class

ParameterFilterRuleFactory.CreateContainsRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateContainsRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateContainsRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateContainsRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateContainsRule(
    ElementId^ parameter,
    String^ value
)
static member CreateContainsRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference