UnitTypeId Class

UnitUtils Class

A utility class of functions related to units.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUnitUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class UnitUtils
Public NotInheritable Class UnitUtils
public ref class UnitUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type UnitUtils = class end

The UnitUtils type exposes the following members.

Methods
Name | Description
Convert | Converts a value from one unit to another, such as square feet to square meters.
ConvertFromInternalUnits | Converts a value from Revit's internal units to a given unit.
ConvertToInternalUnits | Converts a value from a given unit to Revit's internal units.
GetAllDisciplines | Gets the identifiers of all available disciplines.
GetAllMeasurableSpecs | Gets the identifiers of all available measurable specs.
GetAllUnits | Gets the identifiers of all available units.
GetDiscipline | Gets the discipline for a given measurable spec.
GetTypeCatalogStringForSpec | Gets the string used in type catalogs to identify a given measurable spec.
GetTypeCatalogStringForUnit | Gets the string used in type catalogs to identify a given unit.
GetValidUnits | Gets the identifiers of all valid units for a given measurable spec.
IsMeasurableSpec | Checks whether a ForgeTypeId identifies a spec associated with units of measurement.
IsSymbol | Checks whether a ForgeTypeId identifies a symbol.
IsUnit | Checks whether a ForgeTypeId identifies a unit.
IsValidUnit | Checks whether a unit is valid for a given measurable spec.
Top
See Also

Reference

Autodesk.Revit.DB Namespace