DefinitionBindingMapIterator Class

DefinitionFile Class

The DefinitionFile object represents a shared parameters file on disk.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDefinitionFile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DefinitionFile : APIObject
Public Class DefinitionFile
    Inherits APIObject
public ref class DefinitionFile : public APIObject
type DefinitionFile =
    class
        inherit APIObject
    end

The DefinitionFile type exposes the following members.

Properties
 | Name | Description
Public property | Filename | This property returns the physical filename of the shared parameters file on disk.
Public property | Groups | Return a map of shared parameter definition groups contained within the file.
Top
Methods
 | Name | Description
Top
Remarks
Shared Parameters are parameter definitions that are stored in a text file external to the Autodesk Revit project. These definitions can be used in multiple projects and are identifiable by a unique identifier generated when they are created. API access to shared parameters consist of a number of objects, the first of which is an object that represents the shared parameters file on disk. That object then contains a number of Group objects. Shared parameters are grouped for easier management. These groups then contain the shared parameter definitions. The groups support the ability to create new shared parameter definitions. The DefinitionFile object can be retrieved by the Application.OpenSharedParameterFile method.
Example
C#
VB
C++
F#
Copy
private void ShowDefinitionFileInfo(DefinitionFile myDefinitionFile)
{
    StringBuilder fileInformation = new StringBuilder(500);

    // get the file name
    fileInformation.AppendLine("File Name: " + myDefinitionFile.Filename);

    // iterate the Definition groups of this file
    foreach (DefinitionGroup myGroup in myDefinitionFile.Groups)
    {
        // get the group name
        fileInformation.AppendLine("Group Name: " + myGroup.Name);

        // iterate the difinitions
        foreach (Definition definition in myGroup.Definitions)
        {
            // get definition name
            fileInformation.AppendLine("Definition Name: " + definition.Name);
        }
    }
    TaskDialog.Show("Revit",fileInformation.ToString());
}
Private Sub ShowDefinitionFileInfo(myDefinitionFile As DefinitionFile)
   Dim fileInformation As New StringBuilder(500)

   ' get the file name
   fileInformation.AppendLine("File Name: " & Convert.ToString(myDefinitionFile.Filename))

   ' iterate the Definition groups of this file
   For Each myGroup As DefinitionGroup In myDefinitionFile.Groups
      ' get the group name
      fileInformation.AppendLine("Group Name: " + myGroup.Name)

      ' iterate the difinitions
      For Each definition As Definition In myGroup.Definitions
         ' get definition name
         fileInformation.AppendLine("Definition Name: " + definition.Name)
      Next
   Next
   TaskDialog.Show("Revit", fileInformation.ToString())
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace