FailureMessageAccessor Class

FailureMessageKey Class

A unique key assigned to each posted failure message
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureMessageKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureMessageKey : IDisposable
Public Class FailureMessageKey
    Implements IDisposable
public ref class FailureMessageKey : IDisposable
type FailureMessageKey =
    class
        interface IDisposable
    end

The FailureMessageKey type exposes the following members.

Constructors
 | Name | Description
Public method | FailureMessageKey | Constructs a new FailureMessageKey with default settings.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FailureMessageKey
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides ObjectGetHashCode)
Public method | IsEqual | Checks it this key is equal to the other.
Public method | IsValid | Checks if the failure message key is valid
Top
Operators
Name | Description
Equality(FailureMessageKey, FailureMessageKey) | Determines whether two FailureMessageKeys are the same.
Inequality(FailureMessageKey, FailureMessageKey) | Determines whether two FailureMessageKeys are different.
Top
Remarks
When a failure message is posted, it gets a unique key assigned and returned to the caller. The key is guaranteed to be unique in the Revit session. The key can be used to unpost (delete) previously posted failure message if it is no longer valid.
See Also

Reference

Autodesk.Revit.DB Namespace