SpatialElementCalculationPoint Class

SpatialElementDomainData Class

A base class for specific domain requirements for a spatial element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpatialElementDomainData
Autodesk.Revit.DB.ElectricalElectricalLoadAreaData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementDomainData : IDisposable
Public Class SpatialElementDomainData
    Implements IDisposable
public ref class SpatialElementDomainData : IDisposable
type SpatialElementDomainData =
    class
        interface IDisposable
    end

The SpatialElementDomainData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementDomainData
Top
See Also

Reference

Autodesk.Revit.DB Namespace