Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBConicalSurface
Autodesk.Revit.DBCylindricalSurface
Autodesk.Revit.DBHermiteSurface
Autodesk.Revit.DBOffsetSurface
Autodesk.Revit.DBPlane
Autodesk.Revit.DBRevolvedSurface
Autodesk.Revit.DBRuledSurface

Surface Properties

The Surface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.
Top
See Also

Reference