HostedSweepType Class

HostObjAttributes Class

An object that represents characteristics of several kinds of type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HostObjAttributes : ElementType
Public Class HostObjAttributes
    Inherits ElementType
public ref class HostObjAttributes : public ElementType
type HostObjAttributes =
    class
        inherit ElementType
    end

The HostObjAttributes type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element.
Public method | SetCompoundStructure | Sets the compound structure of the element.
Top
Remarks
This object provides access to structural layering components for any object derived from it, such as wall types and floor types.
See Also

Reference

Autodesk.Revit.DB Namespace