HVACLoadType Class

The base class for building type and space type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisHVACLoadType
Autodesk.Revit.DB.AnalysisHVACLoadBuildingType
Autodesk.Revit.DB.AnalysisHVACLoadSpaceType

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HVACLoadType : Element
Public Class HVACLoadType
    Inherits Element
public ref class HVACLoadType : public Element
type HVACLoadType =
    class
        inherit Element
    end

The HVACLoadType type exposes the following members.

Properties
 | Name | Description
Public property | AirChangesPerHour | The air changes per hour.
Public property | AreaPerPerson | The area per person.
Public property | CoolingSetPoint | The cooling temperature set point in unit Kelvin (K).
Public property | DehumidificationSetPoint | The dehumidification set point as a number between 0 and 1.
Public property | HeatingSetPoint | The heating temperature set point in unit Kelvin (K).
Public property | HumidificationSetPoint | The humidification set point as a number between 0 and 1.
Public property | LatentHeatGainPerPerson | The latent heat gain per person.
Public property | LightingLoadDensity | The lighting load density.
Public property | OutdoorAirFlowStandard | The outdoor airflow standard.
Public property | OutdoorAirPerArea | The outdoor air per area.
Public property | OutdoorAirPerPerson | The outdoor air per person.
Public property | PlenumLighting | The percentage of plenum lighting contribution.
Public property | PowerLoadDensity | The power load density.
Public property | SensibleHeatGainPerPerson | The sensible heat gain per person.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace