STEPExportOptions Class

STEPImportOptions Class

The import options used to import STEP format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBSTEPImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class STEPImportOptions : BaseImportOptions
Public Class STEPImportOptions
    Inherits BaseImportOptions
public ref class STEPImportOptions : public BaseImportOptions
type STEPImportOptions =
    class
        inherit BaseImportOptions
    end

The STEPImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | STEPImportOptions | Constructs a new instance of STEPImportOptions with default values of all properties.
Public method | STEPImportOptions(STEPImportOptions) | Constructs a new instance of STEPImportOptions as a copy of the import options.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace