Wall Class

Wall Methods

The Wall type exposes the following members.

Methods
 | Name | Description
Public method | AllowWrappingAtLocation | Allow end wrapping at the location.
Public method | CanHaveProfileSketch | Checks whether this wall has or can have a profile sketch.
 | Create(Document, IListCurve, Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
 | Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
 | Create(Document, IListCurve, ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
 | Create(Document, IListCurve, ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
 | Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | CreateProfileSketch | Creates a new Wall profile Sketch.
Public method | DisallowWrappingAtLocation | Disallow end wrapping at the location.
Public method | Flip | The wall orientation will be flipped.
Public method | GetStackedWallMemberIds | Get the sub walls which belongs to the wall.
Public method | GetValidWrappingLocationIndices | Gets all valid locations for end wrapping.
Public method | GetWrappingLocationAsCurveParameter | Gets the non-normalized (actual) curve parameter of the location.
Public method | GetWrappingLocationAsReferences | Gets an array of references to faces at the location.
Public method | IsWallCrossSectionValid | Checks whether the desired cross section is valid for the current wall.
Public method | IsWrappingAtLocationAllowed | If end wrapping is allowed at the location.
Public method | RemoveProfileSketch | Reverts an edited wall to its original shape.
Top
See Also

Reference