FilterStringRule Class

FilterStringRuleEvaluator Class

Base for all classes that compare string values from Revit to a user-supplied filter value
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringRuleEvaluator : IDisposable
Public Class FilterStringRuleEvaluator
    Implements IDisposable
public ref class FilterStringRuleEvaluator : IDisposable
type FilterStringRuleEvaluator =
    class
        interface IDisposable
    end

The FilterStringRuleEvaluator type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilterStringRuleEvaluator
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
Top
See Also

Reference

Autodesk.Revit.DB Namespace