SolidOptions Class

SolidOptions Properties

The SolidOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtraFaceAndEdgeHistoryKey | Optional extra key used to create face and edge histories for the Solid. If extraFaceAndEdgeHistoryKey is higher than -1, the Solid's face and edge histories will be created depending on the geometry generation of the Solid.
Public property | GraphicsStyleId | Defines the graphics style id for the Solid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Defines the material id for the Solid.
Top
See Also

Reference