DetailNurbSpline Class

DGNExportOptions Class

The export options used by exporting DGN format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseExportOptions
Autodesk.Revit.DBDGNExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DGNExportOptions : BaseExportOptions
Public Class DGNExportOptions
    Inherits BaseExportOptions
public ref class DGNExportOptions : public BaseExportOptions
type DGNExportOptions =
    class
        inherit BaseExportOptions
    end

The DGNExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DGNExportOptions | Constructs a new instance of DGNExportOptions with default values of all properties.
Public method | DGNExportOptions(DGNExportOptions) | Constructs a new instance of DGNExportOptions as a copy of the export options.
Top
Properties
 | Name | Description
Public property | FileVersion | The DGN file version. Default value of fileVersion is DGNFileFormat.Default.
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.
Public property | SeedName | The name of the DGN seed. Default value of seedName is empty.
Public property | WorkingUnits | If true, Main Units will be used. If false, Sub Units will be used. Default value of WorkingUnits is true.
Top
Methods
 | Name | Description
Public method | GetExportLineweightTable | Gets a copy of the line weight table.
 | GetPredefinedOptions | Returns an instance DGNExportOptions containing settings from a predefined export setup.
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of DGN export options.
Public method | SetExportLineweightTable | Sets the line weight table to use during export.
Top
See Also

Reference

Autodesk.Revit.DB Namespace