MultiSegmentGrid Class

NamingUtils Class

A collection of utilities related to element naming.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBNamingUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class NamingUtils
Public NotInheritable Class NamingUtils
public ref class NamingUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NamingUtils = class end

The NamingUtils type exposes the following members.

Methods
Name | Description
CompareNames | Compares two object name strings using Revit's comparison rules.
IsValidName | Identifies if the input string is valid for use as an object name in Revit.
Top
See Also

Reference

Autodesk.Revit.DB Namespace