Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBBlend
Autodesk.Revit.DBExtrusion
Autodesk.Revit.DBForm
Autodesk.Revit.DBFreeFormElement
Autodesk.Revit.DBRevolution
Autodesk.Revit.DBSweep
Autodesk.Revit.DBSweptBlend

GenericForm Properties

The GenericForm type exposes the following members.

Properties
 | Name | Description
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | Name | Get and Set the Name property (Overrides ElementName)
Public property | Subcategory | The subcategory.
Public property | Visible | The visibility of the GenericForm.
Top
See Also

Reference