Autodesk.Revit.Attributes Namespace

Classes
 | Class | Description
Public class | JournalingAttribute | The custom journaling attribute to control the journaling behavior of the external command.
Public class | RegenerationAttribute | The custom regeneration attribute to control the regeneration behavior of the external command or external application.
Public class | TransactionAttribute | The custom transaction attribute to control the transaction behavior of the external command.
Enumerations
 | Enumeration | Description
Public enumeration | JournalingMode | All journaling modes supported by Revit external commands.
Public enumeration | RegenerationOption | All regeneration options supported by Revit external commands and external applications.
Public enumeration | TransactionMode | All transaction modes supported by Revit external commands.

JournalingAttribute Class

The custom journaling attribute to control the journaling behavior of the external command.
Inheritance Hierarchy
SystemObject
SystemAttribute
Autodesk.Revit.AttributesJournalingAttribute

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JournalingAttribute : Attribute
Public Class JournalingAttribute
    Inherits Attribute
public ref class JournalingAttribute : public Attribute
type JournalingAttribute =
    class
        inherit Attribute
    end

The JournalingAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | JournalingAttribute | Constructs a new JournalingAttribute.
Top
Properties
 | Name | Description
Public property | Mode | Journaling mode.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.Attributes Namespace