ExternalResourceUtils Class
GetAllExternalResourceReferences Overload

Extrusion Class

A extrusion solid or void form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBExtrusion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Extrusion : GenericForm
Public Class Extrusion
    Inherits GenericForm
public ref class Extrusion : public GenericForm
type Extrusion =
    class
        inherit GenericForm
    end

The Extrusion type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | The offset of the end of the extrusion relative to the sketch plane.
Public property | Sketch | Returns the Sketch of the Extrusion.
Public property | StartOffset | The offset of the start of the extrusion relative to the sketch plane.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace