BuiltInFailuresRevolutionFailures Class

BuiltInFailures.RoofFailures Class

BuiltInFailuresRoofFailures Class

Failures about Roof.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRoofFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RoofFailures
Public NotInheritable Class RoofFailures
public ref class RoofFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RoofFailures = class end

The BuiltInFailuresRoofFailures type exposes the following members.

Properties
Name | Description
CurveRoofSkippedLoops | Some loops were skipped
CurveRoofSkippedLoopsError | Some loops were skipped
CurveRoofSkippedLoopsWarn | Some loops were skipped
ExtrudedRoofCutBySketch | Entire extruded Roof is cut by cut Sketch.
HadToAlignEaves | Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.
HoleInRoofFailed | Hole(s) could not be cut in roof.
InvalidArcSegmentation | A segmented slope-defining arc has too few segments.
JoinedRoofMissesTarget | Part of the roof to be joined misses the target face.
JoinedRoofMissesTargetError | Part of the roof to be joined misses the target face.
NoFlatCurtainRoofs | A Sloped Glazing with no slope is not allowed.
OnlyOneSlopeCurtainRoof | Only one slope in curtain roof.
OnlyUpwardFacesUsed | The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.
RoofCutoffRemoved | The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.
RoofExceedsMaxHeight | Roof exceeds user-specified maximum height
RoofMeetsRoofTangentially | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofMeetsRoofTangentiallyError | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofSlopeExceedsThreshold | Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
RoofToRefPlanes | Roof cannot be joined to more than one reference plane.
RoofToRefPlanesError | Roof cannot be joined to more than one reference plane.
UnusedSlopeArrow | The tails of all slope arrows must lie on the roof boundary.
UptoHeightTooLow | Cutoff Level cannot be below bottom of roof.
UserCancelledRoof | Cancelled.
WorkplaneShouldBeLevel | Can't use Workplane that is not a Level. Set the desired Level as current Workplane.
Top
See Also

Reference

Autodesk.Revit.DB Namespace