FamilyTypeSetIterator Class

FamilyUtils Class

Contains utilities related to family operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFamilyUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FamilyUtils
Public NotInheritable Class FamilyUtils
public ref class FamilyUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FamilyUtils = class end

The FamilyUtils type exposes the following members.

Methods
Name | Description
ConvertFamilyToFaceHostBased | Converts a family to be face host based.
FamilyCanConvertToFaceHostBased | Indicates whether the family can be converted to face host based.
GetProfileSymbols | Gets the profile Family Symbols of the document.
Top
See Also

Reference

Autodesk.Revit.DB Namespace