WorksharingDisplayGraphicSettings Class

Represents the graphical settings that can be assigned to elements in the worksharing display modes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksharingDisplayGraphicSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksharingDisplayGraphicSettings : IDisposable
Public Class WorksharingDisplayGraphicSettings
    Implements IDisposable
public ref class WorksharingDisplayGraphicSettings : IDisposable
type WorksharingDisplayGraphicSettings =
    class
        interface IDisposable
    end

The WorksharingDisplayGraphicSettings type exposes the following members.

Constructors
 | Name | Description
Public method | WorksharingDisplayGraphicSettings | Creates a new instance.
Top
Properties
 | Name | Description
Public property | FillColor | The fill color that will be applied to elements when these settings are applied. Note that this is automatically set by increasing the luma of the specified line color by 65%.
Public property | IsApplied | Indicates whether this set of graphic overrides will be applied.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineColor | The line color that will be applied to elements when these settings are applied.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorksharingDisplayGraphicSettings
Top
Example
C#
VB
C++
F#
Copy
public WorksharingDisplayGraphicSettings GetWorksharingDisplaySettings(Document doc, String userName, WorksetId worksetId, bool ownedbyCurrentUser)
{
    WorksharingDisplayGraphicSettings graphicSettings;

    // get or create a WorksharingDisplaySettings current active document
    WorksharingDisplaySettings displaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc);

    // get graphic settings for a user, if specified
    if (!String.IsNullOrEmpty(userName))
        graphicSettings = displaySettings.GetGraphicOverrides(userName);

    // get graphicSettings for a workset, if specified
    else if (worksetId != WorksetId.InvalidWorksetId)
        graphicSettings = displaySettings.GetGraphicOverrides(worksetId);

    // get graphic settings for the OwnedByCurrentUser status
    else if (ownedbyCurrentUser)
        graphicSettings = displaySettings.GetGraphicOverrides(CheckoutStatus.OwnedByCurrentUser);

    // otherwise get graphic settings for the CurrentWithCentral status
    else
        graphicSettings = displaySettings.GetGraphicOverrides(ModelUpdatesStatus.CurrentWithCentral);

    return graphicSettings;
}
Public Function GetWorksharingDisplaySettings(doc As Document, userName As [String], worksetId__1 As WorksetId, ownedbyCurrentUser As Boolean) As WorksharingDisplayGraphicSettings
    Dim graphicSettings As WorksharingDisplayGraphicSettings

    ' get or create a WorksharingDisplaySettings current active document
    Dim displaySettings As WorksharingDisplaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc)

    ' get graphic settings for a user, if specified
    If Not [String].IsNullOrEmpty(userName) Then
        graphicSettings = displaySettings.GetGraphicOverrides(userName)

    ' get graphicSettings for a workset, if specified
    ElseIf worksetId__1 <> WorksetId.InvalidWorksetId Then
        graphicSettings = displaySettings.GetGraphicOverrides(worksetId__1)

    ' get graphic settings for the OwnedByCurrentUser status
    ElseIf ownedbyCurrentUser Then
        graphicSettings = displaySettings.GetGraphicOverrides(CheckoutStatus.OwnedByCurrentUser)
    Else

        ' otherwise get graphic settings for the CurrentWithCentral status
        graphicSettings = displaySettings.GetGraphicOverrides(ModelUpdatesStatus.CurrentWithCentral)
    End If

    Return graphicSettings
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace