ICentralLockedCallback Interface

IConnector Interface

An interface which provides access to connector in Autodesk Revit MEP document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnector
Public Interface IConnector
public interface class IConnector
type IConnector = interface end

The IConnector type exposes the following members.

Properties
 | Name | Description
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Domain | The domain of the connector.
Public property | Height | The height of the connector.
Public property | Origin | The location of the connector in family document.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Width | The width of the connector.
Top
Remarks
This interface is shared by Connector, ConnectorElement.
See Also

Reference

Autodesk.Revit.DB Namespace