MeshTriangle Class

ModelArc Class

Represents a ModelArc within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DBModelArc

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelArc : ModelCurve
Public Class ModelArc
    Inherits ModelCurve
public ref class ModelArc : public ModelCurve
type ModelArc =
    class
        inherit ModelCurve
    end

The ModelArc type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace