BarTypeDiameterOptions Class

BaseArray Class

An abstract base class that represents an array within the Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBBaseArray
Autodesk.Revit.DBLinearArray
Autodesk.Revit.DBRadialArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class BaseArray : Element
Public MustInherit Class BaseArray
    Inherits Element
public ref class BaseArray abstract : public Element
[<AbstractClassAttribute>]
type BaseArray =
    class
        inherit Element
    end

The BaseArray type exposes the following members.

Properties
 | Name | Description
Public property | Label | The family parameter label of the BaseArray.
Public property | Name | Get and Set the Name property (Overrides ElementName)
Public property | NumMembers | Retrieves or changes the number of the arrayed members.
Top
Methods
 | Name | Description
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array.
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace