WorksharingSaveAsOptions Class

WorksharingTooltipInfo Class

Worksharing information about a single element suitable for display in an in-canvas tooltip.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksharingTooltipInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksharingTooltipInfo : IDisposable
Public Class WorksharingTooltipInfo
    Implements IDisposable
public ref class WorksharingTooltipInfo : IDisposable
type WorksharingTooltipInfo =
    class
        interface IDisposable
    end

The WorksharingTooltipInfo type exposes the following members.

Properties
 | Name | Description
Public property | Creator | The user name of the user who created the element.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LastChangedBy | The user name of the most recent user who saved a user change of this element to the central model.
Public property | Owner | The current owner of the element or empty string if no one owns the element.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorksharingTooltipInfo
Public method | GetRequesters | The ordered list of unique user names of users who have outstanding editing requests for the specified element.
Top
Remarks
Some or all of the strings may be empty.
See Also

Reference

Autodesk.Revit.DB Namespace