FilteredWorksetCollector Class

FilteredWorksetIdIterator Class

An iterator to a set of workset ids filtered by the settings of a FilteredWorksetCollector.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilteredWorksetIdIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilteredWorksetIdIterator : IEnumerator<WorksetId>
Public Class FilteredWorksetIdIterator
    Implements IEnumerator(Of WorksetId)
public ref class FilteredWorksetIdIterator : IEnumerator<WorksetId^>
type FilteredWorksetIdIterator =
    class
        interface IEnumerator<WorksetId>
    end

The FilteredWorksetIdIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetIdIterator
Public method | GetCurrent | The current workset id found by the iterator.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Top
See Also

Reference

Autodesk.Revit.DB Namespace