EnergyAnalysisOpening Class

Analytical opening.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisOpening

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisOpening : Element
Public Class EnergyAnalysisOpening
    Inherits Element
public ref class EnergyAnalysisOpening : public Element
type EnergyAnalysisOpening =
    class
        inherit Element
    end

The EnergyAnalysisOpening type exposes the following members.

Properties
 | Name | Description
Public property | CADLinkUniqueId | The unique id of the originating CAD object's link (linked document) associated with this opening.
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this opening.
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | OpeningId | The unique identifier for the opening.
Public property | OpeningName | The unique name identifier for the opening.
Public property | OpeningType | The analytical opening type.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | OriginatingElementName | The name for the originating Revit element.
Public property | Type | The gbXML opening type attribute.
Public property | Width | The width of the analytical rectangular geometry.
Top
Methods
 | Name | Description
Public method | GetAnalyticalSurface | Gets the associative analytical parent surface element.
Public method | GetConstruction | Gets the analytic construction this surface is associated with. Null when this surface is a window.
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.
Public method | GetPolyloops | Gets the collection of planar polygons describing the opening geometry.
Public method | GetWindowType | Gets the analytic window type this surface is associated with. Null when this surface is not a window.
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace