TextElement Class

Base class representing text elements in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBTextElement
Autodesk.Revit.DBTextNote

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextElement : Element
Public Class TextElement
    Inherits Element
public ref class TextElement : public Element
type TextElement =
    class
        inherit Element
    end

The TextElement type exposes the following members.

Properties
Name | Description
Public property | Height | Height of the area of the text content.
Public property IsTextWrappingActive

A flag identifying whether text-wrapping is currently active in this text element or not.

If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text.

If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment

Public property | KeepRotatedTextReadable | A flag to control how text behaves inside a rotated text element.
Public property | Symbol | Get the type of the TextElement object.
Public property | UpDirection | Direction along the vertical axis of letters of the text note.
Public property | VerticalAlignment | Vertical alignment of the text.
Public property | Width | Width of the area of the text content.
Top
Methods
 | Name | Description
Public method | GetMaximumAllowedWidth | Returns the maximum width the text element can be assigned.
 | GetMaximumAllowedWidth(Document, ElementId) | Returns the maximum width the text element can be created with.
Public method | GetMinimumAllowedWidth | Returns the minimum width the text element can be assigned.
 | GetMinimumAllowedWidth(Document, ElementId) | Returns the minimum width a text element can be created with.
Top
Remarks
TextElement is a base class for other annotation classes, like TextNote, which have additional, more specific functionality.
See Also

Reference

Autodesk.Revit.DB Namespace