ViewNode Class

ViewOrientation3D Class

Container for the point and vectors which define View3D's orientation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBViewOrientation3D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewOrientation3D : IDisposable
Public Class ViewOrientation3D
    Implements IDisposable
public ref class ViewOrientation3D : IDisposable
type ViewOrientation3D =
    class
        interface IDisposable
    end

The ViewOrientation3D type exposes the following members.

Constructors
 | Name | Description
Public method | ViewOrientation3D | Constructs a new ViewOrientation3D using the input eye position, up and forward directions.
Top
Properties
 | Name | Description
Public property | EyePosition | The eye position point
Public property | ForwardDirection | The forward direction vector
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UpDirection | The up direction vector
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ViewOrientation3D
Top
See Also

Reference

Autodesk.Revit.DB Namespace