BasicFileInfo Class

BeamSystem Class

An object that represents a BeamSystem within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBBeamSystem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BeamSystem : Element
Public Class BeamSystem
    Inherits Element
public ref class BeamSystem : public Element
type BeamSystem =
    class
        inherit Element
    end

The BeamSystem type exposes the following members.

Properties
 | Name | Description
 | BeamSystemType | Retrieves or changes the type of the BeamSystem.
 | BeamType | Retrieves or changes the Beam Type of the BeamSystem.
Public property | Direction | The Direction of the BeamSystem.
Public property | Elevation | Retrieves or changes the Elevation of the BeamSystem.
Public property | LayoutRule | Retrieves or changes the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | Profile | Retrieve or set the profile of the BeamSystem.
Top
Methods
 | Name | Description
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
 | Create(Document, IListCurve, SketchPlane, Int32) | Creates a 2D BeamSystem with specified profile curves.
 | Create(Document, IListCurve, Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IListCurve, Level, Int32, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IListCurve, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
 | DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Public method | GetBeamIds | Gets all the beams of the BeamSystem.
Top
Remarks
This object is derived from the Element base object. It can be used to access properties of a BeamSystem, such as elevation, level, etc. It also provides access to the beams (FamilyInstances) that are created by this BeamSystem.
Example
C#
VB
C++
F#
Copy
public void GetInfo_BeamSystem(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem family name
    message += "\nBeamSystem Direction is:(" + beamSystem.Direction.X + ", "
        + beamSystem.Direction.Y + ", " + beamSystem.Direction.Z + ")";

    // Get BeamSystem elevation
    message += "\nBeamSystem elevation is: " + beamSystem.Elevation;

    Document document = beamSystem.Document;
    ICollection<ElementId> beamIds = beamSystem.GetBeamIds();
    foreach (ElementId beamId in beamIds)
    {
        Element beam = document.GetElement(beamId);
        // Get Beam name
        message += "\nBeam name: " + beam.Name;
    }

    // Get BeamSystem layout rule
    message += "\nBeamSystem layout rule is: " + beamSystem.LayoutRule;

    // Get BeamSystem level name
    message += "\nBeamSystem level name is: " + beamSystem.Level.Name;

    message += "\nBeamSystem Profile: " + beamSystem.Level.Name;
    foreach (Autodesk.Revit.DB.Curve curve in beamSystem.Profile)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.GetEndPoint(0).X + ", "
             + curve.GetEndPoint(0).Y + ", " + curve.GetEndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.GetEndPoint(1).X + ", "
             + curve.GetEndPoint(1).Y + ", " + curve.GetEndPoint(1).Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_BeamSystem(beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem family name
    message += vbLf & "BeamSystem Direction is:(" & Convert.ToString(beamSystem.Direction.X) & ", " & Convert.ToString(beamSystem.Direction.Y) & ", " & Convert.ToString(beamSystem.Direction.Z) & ")"

    ' Get BeamSystem elevation
    message += vbLf & "BeamSystem elevation is: " & Convert.ToString(beamSystem.Elevation)

    Dim document As Document = beamSystem.Document
    Dim beamIds As ICollection(Of ElementId) = beamSystem.GetBeamIds()
    For Each beamId As ElementId In beamIds
        Dim beam As Element = document.GetElement(beamId)
        ' Get Beam name
        message += vbLf & "Beam name: " + beam.Name
    Next

    ' Get BeamSystem layout rule
    message += vbLf & "BeamSystem layout rule is: " & Convert.ToString(beamSystem.LayoutRule)

    ' Get BeamSystem level name
    message += vbLf & "BeamSystem level name is: " & Convert.ToString(beamSystem.Level.Name)

    message += vbLf & "BeamSystem Profile: " & Convert.ToString(beamSystem.Level.Name)
    For Each curve As Autodesk.Revit.DB.Curve In beamSystem.Profile
        ' Get curve start point
        message += ((vbLf & "Curve start point:(" + curve.GetEndPoint(0).X & ", ") + curve.GetEndPoint(0).Y & ", ") + curve.GetEndPoint(0).Z & ")"
        ' Get curve end point
        message += (("; Curve end point:(" + curve.GetEndPoint(1).X & ", ") + curve.GetEndPoint(1).Y & ", ") + curve.GetEndPoint(1).Z & ")"
    Next

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace