ImageBackgroundSettings Class

ImageExportOptions Class

This class defines options for exporting views and sheets as an image.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBImageExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageExportOptions : IDisposable
Public Class ImageExportOptions
    Implements IDisposable
public ref class ImageExportOptions : IDisposable
type ImageExportOptions =
    class
        interface IDisposable
    end

The ImageExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ImageExportOptions | Constructs a new instance of the options class used to produce images.
Top
Properties
 | Name | Description
Public property | ExportRange | The export range defining which view(s) will be exported.
Public property | FilePath | The file name and path for the exported file.
Public property | FitDirection | The fit direction. Used only if ZoomType is FitToPage.
Public property | HLRandWFViewsFileType | File type for exported HLR and wireframe views.
Public property | ImageResolution | The image resolution in dots per inch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
Public property | ShadowViewsFileType | The file type for exported shadow views.
Public property | ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
Public property | ViewName | The name of the view to be created.
Public property | Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
Public property | ZoomType | The zoom type, which defines how the image size is determined.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ImageExportOptions
 | GetFileName | Gets the file name that will be produced when exporting a view to an image.
Public method | GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
 | IsValidFileName | Verify if File name is valid
 | IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
Public method | SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
Top
See Also

Reference

Autodesk.Revit.DB Namespace