AnalysisDisplayStyle Class

Exposes API for manipulation of analysis display style.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisAnalysisDisplayStyle

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayStyle : Element
Public Class AnalysisDisplayStyle
    Inherits Element
public ref class AnalysisDisplayStyle : public Element
type AnalysisDisplayStyle =
    class
        inherit Element
    end

The AnalysisDisplayStyle type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Colored Surface for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Deformed Shape for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Diagram for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Markers and Text for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Vectors for the given document.
 | FindByName | Finds analysis display style by name.
Public method | GetColoredSurfaceSettings | Get colored surface settings object from the style.
Public method | GetColorSettings | Get color settings object from the style.
Public method | GetDeformedShapeSettings | Get deformed shape settings object from the style.
Public method | GetDiagramSettings | Get diagram settings object from the style.
 | GetElements | Returns set of all analysis display styles elements in the given document.
Public method | GetLegendSettings | Get legend settings object from the style.
Public method | GetMarkersAndTextSettings | Get markers and text settings object from the style.
Public method | GetVectorSettings | Get vector settings object from the style.
Public method | HasColoredSurfaceSettings | If true style has colored surface settings.
Public method | HasDeformedShapeSettings | If true style has deformed shape settings.
Public method | HasDiagramSettings | If true style has diagram settings.
Public method | HasMarkersAndTextSettings | If true style has markers and text settings.
Public method | HasVectorSettings | If true style has vector settings.
 | IsNameUnique | Verify the uniqueness of the name among all analysis display style elements of the document.
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | SetColoredSurfaceSettings | Set colored surface settings object for the style.
Public method | SetColorSettings | Set color settings object for the style.
Public method | SetDeformedShapeSettings | Set deformed shape settings object for the style.
Public method | SetDiagramSettings | Set diagram settings object for the style.
Public method | SetLegendSettings | Set legend settings object for the style.
Public method | SetMarkersAndTextSettings | Set markers and text settings object for the style.
Public method | SetName | Set name of analysis display style element.
Public method | SetVectorSettings | Set vector settings object for the style.
Top
Example
C#
VB
C++
F#
Copy
Document doc = commandData.Application.ActiveUIDocument.Document;

AnalysisDisplayStyle analysisDisplayStyle = null;
// Look for an existing analysis display style with a specific name
FilteredElementCollector collector1 = new FilteredElementCollector(doc);
ICollection<Element> collection = collector1.OfClass(typeof(AnalysisDisplayStyle)).ToElements();
var displayStyle = from element in collection
                   where element.Name == "Display Style 1"
                   select element;

// If display style does not already exist in the document, create it
if (displayStyle.Count() == 0)
{
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings =
        new AnalysisDisplayColoredSurfaceSettings();
    coloredSurfaceSettings.ShowGridLines = true;

    AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
    Color orange = new Color(255, 205, 0);
    Color purple = new Color(200, 0, 200);
    colorSettings.MaxColor = orange;
    colorSettings.MinColor = purple;

    AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
    legendSettings.NumberOfSteps = 10;
    legendSettings.Rounding = 0.05;
    legendSettings.ShowDataDescription = false;
    legendSettings.ShowLegend = true;

    analysisDisplayStyle = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc,
        "Display Style 1", coloredSurfaceSettings, colorSettings, legendSettings);
}
else
{
    analysisDisplayStyle = displayStyle.Cast<AnalysisDisplayStyle>().ElementAt<AnalysisDisplayStyle>(0);
}

// now assign the display style to the view
doc.ActiveView.AnalysisDisplayStyleId = analysisDisplayStyle.Id;
Dim doc As Document = commandData.Application.ActiveUIDocument.Document

Dim analysisDisplayStyle__1 As AnalysisDisplayStyle = Nothing
' Look for an existing analysis display style with a specific name
Dim collector1 As New FilteredElementCollector(doc)
Dim collection As ICollection(Of Element) = collector1.OfClass(GetType(AnalysisDisplayStyle)).ToElements()
Dim displayStyle As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
displayStyle = From element In collector1 _
 Where element.Name = "Display Style 1" _
 Select element

' If display style does not already exist in the document, create it
If displayStyle.Count() = 0 Then
   Dim coloredSurfaceSettings As New AnalysisDisplayColoredSurfaceSettings()
   coloredSurfaceSettings.ShowGridLines = True

   Dim colorSettings As New AnalysisDisplayColorSettings()
   Dim orange As New Color(255, 205, 0)
   Dim purple As New Color(200, 0, 200)
   colorSettings.MaxColor = orange
   colorSettings.MinColor = purple

   Dim legendSettings As New AnalysisDisplayLegendSettings()
   legendSettings.NumberOfSteps = 10
   legendSettings.Rounding = 0.05
   legendSettings.ShowDataDescription = False
   legendSettings.ShowLegend = True

   analysisDisplayStyle__1 = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Display Style 1", coloredSurfaceSettings, colorSettings, legendSettings)
Else
   analysisDisplayStyle__1 = displayStyle.Cast(Of AnalysisDisplayStyle)().ElementAt(0)
End If

' now assign the display style to the view
doc.ActiveView.AnalysisDisplayStyleId = analysisDisplayStyle__1.Id

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace