AnnotationMultipleAlignmentUtils Class

AnnotationSymbol Class

This object represents a symbol of the Generic Annotation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBFamilyInstance
Autodesk.Revit.DBAnnotationSymbol

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnnotationSymbol : FamilyInstance
Public Class AnnotationSymbol
    Inherits FamilyInstance
public ref class AnnotationSymbol : public FamilyInstance
type AnnotationSymbol =
    class
        inherit FamilyInstance
    end

The AnnotationSymbol type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
Top
Methods
 | Name | Description
Public method | addLeader | add a leader to this annotation symbol.
Public method | duplicate | Duplicate this annotation symbol.
Public method | GetLeaders | Returns a collection of leaders currently attached to the annotation.
Public method | removeLeader | remove a leader of this annotation symbol.
Top
See Also

Reference

Autodesk.Revit.DB Namespace