UnitFormatUtils Class
TryParse Overload

Units Class

A document's default settings for formatting numbers with units.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUnits

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Units : IDisposable
Public Class Units
    Implements IDisposable
public ref class Units : IDisposable
type Units =
    class
        interface IDisposable
    end

The Units type exposes the following members.

Constructors
 | Name | Description
Public method | Units | Creates a new Units object with default settings for Metric or Imperial units.
Top
Properties
 | Name | Description
Public property | DecimalSymbol | The symbol used to separate the integer and fractional parts of a number.
Public property | DigitGroupingAmount | The number of digits in each group when numbers are formatted with digit grouping.
Public property | DigitGroupingSymbol | The symbol used to separate groups of digits when numbers are formatted with digit grouping.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Units
Public method | GetFormatOptions | Gets the default FormatOptions for a spec.
 | GetModifiableSpecs | Gets all specs for which the default FormatOptions can be modified.
 | IsModifiableSpec | Checks whether the default FormatOptions can be modified for a given spec.
Public method | SetFormatOptions | Sets the default FormatOptions for a spec.
Top
Remarks

The Units class represents a document's default settings for formatting numbers with units as strings. It contains a FormatOptions object for each unit type as well as settings related to decimal symbol and digit grouping.

The Units class stores a FormatOptions object for every valid unit type, but not all of them can be directly modified. Some, like UT_Number and UT_SiteAngle, have fixed definitions. Others have definitions which are automatically derived from other unit types. For example, UT_SheetLength is derived from UT_Length and UT_ForceScale is derived from UT_Force. See IsModifiableUnitType() and GetModifiableUnitTypes().

See Also

Reference

Autodesk.Revit.DB Namespace