WallType Class

Represents a specific type of wall, such as 'Generic - 8"'.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBWallType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WallType : HostObjAttributes
Public Class WallType
    Inherits HostObjAttributes
public ref class WallType : public HostObjAttributes
type WallType =
    class
        inherit HostObjAttributes
    end

The WallType type exposes the following members.

Properties
 | Name | Description
Public property | Function | The wall function.
Public property | Kind | The nature of the wall.
Public property | ThermalProperties | The calculated and settable thermal properties of the WallType
Public property | Width | The overall thickness of this type of wall.
Top
Methods
 | Name | Description
Top
Remarks
All wall type objects available in the project can be retrieved from the Document object via the WallTypes property. Every Wall object has a WallType property that returns the a WallType object representing the type. This same WallType property can also be used to change the type of the wall by setting it to a different type.
Example
C#
VB
C++
F#
Copy
public void GetInfo_WallType(WallType wallType)
{
    string message;
    // Reports the nature of the wall
    message = "The wall type kind is : " + wallType.Kind.ToString();

    // Get the overall thickness of this type of wall.
    message += "\nThe wall type Width is : " + wallType.Width.ToString();

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_WallType(wallType As WallType)
    Dim message As String
    ' Reports the nature of the wall
    message = "The wall type kind is : " & wallType.Kind.ToString()

    ' Get the overall thickness of this type of wall.
    message += vbLf & "The wall type Width is : " & wallType.Width.ToString()

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace