BuiltInFailuresCurtainGridFamilyFailures Class

BuiltInFailures.CurtainWallFailures Class

BuiltInFailuresCurtainWallFailures Class

Failures about CurtainWall.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCurtainWallFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CurtainWallFailures
Public NotInheritable Class CurtainWallFailures
public ref class CurtainWallFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CurtainWallFailures = class end

The BuiltInFailuresCurtainWallFailures type exposes the following members.

Properties
Name | Description
AdjustEndCurtainWallParameterNoCorners | Can't put Corner Mullion at end joined to non-Curtain Wall.
AllGridSegmentsRemoved | Curtain grid lines must have at least one segment.
CannotApplyGridSpecification | It is not possible to apply the host family's grid specification to this instance.
CannotDivideCurtainGrid | Can't divide Curtain Grid by Grid Line.
CannotGroupCurtainGridHost | Curtain grid based elements cannot be grouped.
CannotHaveIndependentOverlappingGrids | Overlapping independent type associated gridlines are not allowed.
CannotPlaceSplitMullions | Could not determine how to place the highlighted mullions after the wall was split.
CannotSplitOldMullions | Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.
CannotSwitchToCurtainWall | Can't switch type to Curtain Wall after Edit Elevation Profile.
CannotUseCornerMullion | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainGridFaceCannotBeReparamForGridRotation | Curtain grids cannot be rotated exactly as requested. Push "Adjust Grids" to get the nearest valid rotation.
CurtainGridOffHost | Curtain grid has left its host.
CurtainSystemHostInvisible | Element defining the Curtain System is invisible in the current view.
DanglingCurtainWallCorner | A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.
DeletingCurtainSystemFaceGridLines | Deleting Grid Lines residing on faces that no longer are part of a Curtain System.
DependentGridlineMayBeDeleted | Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.
ExceedMaxDrivenGridlines | Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.
ExessiveBeltDistance | The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.
GridlinesOutOfBounds | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutOfBoundsWarn | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutsideWillBeRedependent | Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.
GridlinesOverlap | Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.
GridlinesWerePushed | Panels and mullions created by a curtain grid were created with slight inaccuracies.
GridOutOfOrder | Curtain wall grid lines have changed order.
GridOutOfOrderError | Curtain wall grid lines have changed order.
GridOutsideWall | Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.
InvalidSkipSegments | A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.
MullionLostRefReorder | Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.
MullionsWillBeDeleted | The Mullions between the Panels being joined will be deleted.
MultipleDominatingMullions | Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.
MultipleIdsInCurtainSystem | A Curtain System cannot be based on faces from multiple elements.
MustReplacePanels | Missing Curtain Panels will be replaced with System Panels to complete command.
NegativeBeltDistance | Measurement Line Offset cannot be negative.
NonSupportedCurtainWall | Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.
NoPanelsLoaded | No Curtain Panel Families loaded. Can't make arced Curtain Wall.
RequestOrphanMullionDeletion | Due to the changes in parameters of their hosts some mullions became non-type driven.
RuledCurtainElementLostCurves | Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.
TypePanelsFronNonRectCellsUnlocked | Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.
Top
See Also

Reference

Autodesk.Revit.DB Namespace