VisibleInViewFilter Class

Wall Class

Represents a wall in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBWall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Wall : HostObject
Public Class Wall
    Inherits HostObject
public ref class Wall : public HostObject
type Wall =
    class
        inherit HostObject
    end

The Wall type exposes the following members.

Properties
 | Name | Description
Public property | CrossSection | Gets or sets the Cross-section for this wall.
Public property | CurtainGrid | Get the grid object of a curtain wall
Public property | Flipped | Property to test whether the wall orientation is flipped.
Public property | IsStackedWall | Identifies if the wall is a stacked wall.
Public property | IsStackedWallMember | Identifies if the wall is a member of a stacked wall.
Public property | Orientation | The outward-facing normal vector of the exterior side face at the starting point of the wall.
Public property | SketchId | Returns id of the profile sketch, or invalidElementId if sketch does not exist.
Public property | StackedWallOwnerId | Gets the stacked wall which contains this stacked wall member.
Public property | StructuralUsage | Retrieves or changes the wall's designated structural usage.
Public property | WallType | Retrieves or changes the type of the wall.
Public property | Width | Get the overall thickness of the wall.
Top
Methods
 | Name | Description
Public method | AllowWrappingAtLocation | Allow end wrapping at the location.
Public method | CanHaveProfileSketch | Checks whether this wall has or can have a profile sketch.
 | Create(Document, IListCurve, Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
 | Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
 | Create(Document, IListCurve, ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
 | Create(Document, IListCurve, ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
 | Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | CreateProfileSketch | Creates a new Wall profile Sketch.
Public method | DisallowWrappingAtLocation | Disallow end wrapping at the location.
Public method | Flip | The wall orientation will be flipped.
Public method | GetStackedWallMemberIds | Get the sub walls which belongs to the wall.
Public method | GetValidWrappingLocationIndices | Gets all valid locations for end wrapping.
Public method | GetWrappingLocationAsCurveParameter | Gets the non-normalized (actual) curve parameter of the location.
Public method | GetWrappingLocationAsReferences | Gets an array of references to faces at the location.
Public method | IsWallCrossSectionValid | Checks whether the desired cross section is valid for the current wall.
Public method | IsWrappingAtLocationAllowed | If end wrapping is allowed at the location.
Public method | RemoveProfileSketch | Reverts an edited wall to its original shape.
Top
Remarks
The wall object represents all the different kinds of walls in Revit.
Example
C#
VB
C++
F#
Copy
public void GetInfo_Wall(Wall wall)
{
    string message = "Wall : ";

    wall.Flip();
    message += "\nIf wall Flipped : " + wall.Flipped;
    // Get curve start point
    message += "\nWall orientation point is :(" + wall.Orientation.X + ", "
        + wall.Orientation.Y + ", " + wall.Orientation.Z + ")";
    // Get wall StructuralUsage
    message += "\nWall StructuralUsage is : " + wall.StructuralUsage;
    // Get wall type name
    message += "\nWall type name is : " + wall.WallType.Name;
    // Get wall width
    message += "\nWall width is : " + wall.Width;

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_Wall(wall As Wall)
 Dim message As String = "Wall : "
 wall.Flip()
    message += vbLf & "If wall Flipped : " & Convert.ToString(wall.Flipped)
    ' Get curve start point
    message += vbLf & "Wall orientation point is :(" & Convert.ToString(wall.Orientation.X) & ", " & Convert.ToString(wall.Orientation.Y) & ", " & Convert.ToString(wall.Orientation.Z) & ")"
    ' Get wall StructuralUsage
    message += vbLf & "Wall StructuralUsage is : " & Convert.ToString(wall.StructuralUsage)
    ' Get wall type name
    message += vbLf & "Wall type name is : " & Convert.ToString(wall.WallType.Name)
    ' Get wall width
    message += vbLf & "Wall width is : " & Convert.ToString(wall.Width)

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace