Application Properties

The Application type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | AllowNavigationDuringRedraw | Checks whether or not the navigation during redraw is enabled, and enable or disable it.
Public property | AllUsersAddinsLocation | The folder location for .addin files for all users.
Public property | AngleTolerance | Angle tolerance.
Public property | BackgroundColor | The background color to use for model views in this session.
 | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentRevitServerAccelerator | Current Revit Server accelerator.
Public property | CurrentUserAddinsLocation | The folder location for .addin files for the current user.
Public property | CurrentUsersAddinsDataFolderPath | Path to AddinsData folder for the current user.
Public property | CurrentUsersDataFolderPath | Path to data folder for the current user.
Public property | DefaultIFCProjectTemplate | Full path to the default template file for new IFC project documents. It may be empty, in which case the DefaultProjectTemplate should be used.
Public property | DefaultProjectTemplate | Full path to the default template file for new project documents.
Public property | DefaultViewDiscipline | The view discipline that will be applied to new views by default.
Public property | Documents | Returns a set of documents within Revit.
Public property | ExportIFCCategoryTable | Full path to the file that defines Revit category to IFC entity mappings for IFC export.
Public property | FamilyTemplatePath | Default path for family template files.
Public property | ImportIFCCategoryTable | Full path to the file that defines IFC entity to Revit category mappings for IFC import.
Public property | IsArchitectureEnabled | Checks whether or not the architecture discipline is enabled, and enable or disable it.
Public property | IsElectricalAnalysisEnabled | Checks whether or not electrical analysis is enabled, and enable or disable it.
Public property | IsElectricalEnabled | Checks whether or not the electrical discipline is enabled, and enable or disable it.
Public property | IsEnergyAnalysisEnabled | Checks whether or not energy analysis is enabled, and enable or disable it.
Public property | IsInfrastructureEnabled | Checks whether or not infrastructure discipline is enabled, and enable or disable it.
 | IsLoggedIn | Checks if the user is logged in from this session to their Autodesk account.
Public property | IsMassingEnabled | Checks whether or not the massing and site tools are enabled, and enable or disable them.
Public property | IsMechanicalAnalysisEnabled | Checks whether or not mechanical analysis is enabled, and enable or disable it.
Public property | IsMechanicalEnabled | Checks whether or not the mechanical discipline is enabled, and enable or disable it.
Public property | IsPipingAnalysisEnabled | Checks whether or not piping analysis is enabled, and enable or disable it.
Public property | IsPipingEnabled | Checks whether or not the piping discipline is enabled, and enable or disable it.
Public property | IsRouteAnalysisEnabled | Checks whether or not route analysis is enabled, and enable or disable it.
Public property | IsStructuralAnalysisEnabled | Checks whether or not the structural analysis is enabled, and enable or disable it.
Public property | IsStructureEnabled | Checks whether or not the structure discipline is enabled, and enable or disable it.
Public property | IsSystemsEnabled | Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Language | The language used in the current session of Revit.
Public property | LoginUserId | The user id of the user currently logged in. The user id will be empty if the user is not logged in.
 | MinimumThickness | The minimum thickness allowed in Revit for a variety of geometric constructs. These include blends, extrusions, and wall layers.
Public property | PointCloudsRootPath | Root path for point cloud files.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | ShortCurveTolerance | The enforced minimum length for any curve created by Revit.
Public property | ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects | Whether or not to show the graphical open ends for Area Based Load Boundary disconnects.
Public property | ShowGraphicalWarningCableTrayConduitDisconnects | Whether or not to show the graphical warnings for CTC disconnects.
Public property | ShowGraphicalWarningDuctDisconnects | Whether or not to show the graphical warnings for duct disconnects.
Public property | ShowGraphicalWarningElectricalDisconnects | Whether or not to show the graphical warnings for Electrical disconnects.
Public property | ShowGraphicalWarningHangerDisconnects | Whether or not to show the graphical warnings for Fabrication Hanger disconnects.
Public property | ShowGraphicalWarningPipeDisconnects | Whether or not to show the graphical warnings for Pipe disconnects.
Public property | SubVersionNumber | The minor version number of Revit
Public property | SystemsAnalysisWorkfilesRootPath | Root path for systems analysis workfiles
Public property | Username | Gets the user name for the current Revit session.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.
Public property | VertexTolerance | Vertex tolerance.
Top
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace