PlanTopologySet Class

PlanTopologySetIterator Class

An iterator to a set of plan topology objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPlanTopologySetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PlanTopologySetIterator : APIObject,
    IEnumerator
Public MustInherit Class PlanTopologySetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class PlanTopologySetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type PlanTopologySetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The PlanTopologySetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | PlanTopologySetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Top
Methods
 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace