BuiltInFailuresForeignFileFailures Class

BuiltInFailures.FormFailures Class

BuiltInFailuresFormFailures Class

Failures about Form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFormFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FormFailures
Public NotInheritable Class FormFailures
public ref class FormFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FormFailures = class end

The BuiltInFailuresFormFailures type exposes the following members.

Properties
Name | Description
AddProfileFailure | Failed to Add Profile
DissolveNoValidInputs | No form elements selected to dissolve.
DissolveUnableToDissolveForm | Unable to dissolve form element.
FormCreationInvalidGeomCombination | Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
FormElemRegenFailure | Unable to create form element
FormElemRegenFailureError | Unable to create form element
FormElemRegenSelfIntersection | Unable to create form element: self-intersecting or singular geometry would result.
FormElemRegenSelfIntersectionReorderProfiles | This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
FormElemRegenSelfIntersectionResetConnections | This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
OpenProfileMultiSegmentSweepsNotSupported | An open profile cannot be swept along a multi-segment path.
VoidFormsNotUsed | Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.
Top
See Also

Reference

Autodesk.Revit.DB Namespace