ElementTransformUtils Class

ElementType Class

Base class for all Types within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementType : Element
Public Class ElementType
    Inherits Element
public ref class ElementType : public Element
type ElementType =
    class
        inherit Element
    end

The ElementType type exposes the following members.

Properties
 | Name | Description
Public property | CanBeCopied | Determine if this ElementType can create a copy
Public property | CanBeDeleted | Determine if this ElementType can be deleted
Public property | CanBeRenamed | Determine if this ElementType can be renamed
Public property | FamilyName | Gets the family name of this element type.
Public property | Name | Set the name for the ElementType. (Overrides ElementName)
Top
Methods
 | Name | Description
Public method | Duplicate | Duplicates an existing element type and assigns it a new name.
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type.
Public method | IsSimilarType | Checks if given type is similar to this type.
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id.
Top
Remarks
Element types are usually non user visible elements that define instances. For example a wall type is a type that is not visible until an instance of the wall is created.
See Also

Reference

Autodesk.Revit.DB Namespace