PropertyLine Class

PropertySetElement Class

An element that groups together a set of related parameters.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBPropertySetElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PropertySetElement : Element
Public Class PropertySetElement
    Inherits Element
public ref class PropertySetElement : public Element
type PropertySetElement =
    class
        inherit Element
    end

The PropertySetElement type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
 | Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
 | Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.
Public method | Duplicate | Creates a duplicate of this PropertySetElement.
 | GetStructuralAsset | Gets a copy of the StructuralAsset.
 | GetThermalAsset | Gets a copy of the ThermalAsset.
Public method | SetStructuralAsset | Sets a copy of the given StucturalAsset to be used in the PropertySetElement.
Public method | SetThermalAsset | Sets a copy of the given ThermalAsset to be used in the PropertySetElement.
Top
See Also

Reference

Autodesk.Revit.DB Namespace