TableCellStyleOverrideOptions Class

TableData Class

The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTableData
Autodesk.Revit.DB.ElectricalPanelScheduleData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TableData : IDisposable
Public Class TableData
    Implements IDisposable
public ref class TableData : IDisposable
type TableData =
    class
        interface IDisposable
    end

The TableData type exposes the following members.

Properties
 | Name | Description
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSections | Gets the number of items in section data array.
Public property | Width | Gets or sets the table width in feet
Public property | WidthInPixels | Gets the width of the panel schedule in logical pixels
Public property | ZoomLevel | The value of zoom level for corresponding TableView.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TableData
Public method | GetSectionData(Int32) | Returns the section data array element at the specified index.
Public method | GetSectionData(SectionType) | Returns the pointer to the section data array element at the specified section type.
Public method | IsEqual | Checks if this element is equal in value to the other element.
Public method | IsValidZoomLevel | Verifies if the value of zoom level is valid.
Top
See Also

Reference

Autodesk.Revit.DB Namespace