ConnectorElement Class

A base class that provides support for all connector elements occurring in families.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBConnectorElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConnectorElement : Element,
    IConnector
Public Class ConnectorElement
    Inherits Element
    Implements IConnector
public ref class ConnectorElement : public Element,
    IConnector
type ConnectorElement =
    class
        inherit Element
        interface IConnector
    end

The ConnectorElement type exposes the following members.

Properties
 | Name | Description
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Direction | Gets the direction of the connector element.
Public property | Domain | The domain of the connector.
Public property | Height | The height of the connector.
Public property | IsPrimary | Identifies if this is the primary connector in the family.
Public property | Origin | The location of the connector in family document.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | SystemClassification | The system classification of the connector.
Public property | Width | The width of the connector.
Top
Methods
 | Name | Description
Public method | AssignAsPrimary | Assign a connector as a primary connector.
Public method | ChangeHostReference(Reference) | Changes the connector host reference to a new planar face.
Public method | ChangeHostReference(Reference, Edge) | Changes the connector host reference to a new planar face and a new edge loop.
 | CreateCableTrayConnector(Document, Reference) | Create a new cable tray ConnectorElement.
 | CreateCableTrayConnector(Document, Reference, Edge) | Create a new cable tray ConnectorElement.
 | CreateConduitConnector(Document, Reference) | Create a new conduit ConnectorElement.
 | CreateConduitConnector(Document, Reference, Edge) | Create a new conduit ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference) | Create a new duct ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference, Edge) | Create a new duct ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference) | Create a new electrical ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference, Edge) | Create a new electrical ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference) | Create a new pipe ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference, Edge) | Create a new pipe ConnectorElement with a face and an edge.
Public method | FlipDirection | Reverses the direction of the connector element.
Public method | GetLinkedConnectorElement | Get the linked connector element.
Public method | IsSystemClassificationValid | Checks that the MEPSystemType is valid for the domain of connector.
Public method | SetLinkedConnectorElement | Set the linked connector element.
Top
See Also

Reference

Autodesk.Revit.DB Namespace