GlobalParametersManager Class

GradientBackgroundSettings Class

Represents the view gradient background settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBackgroundSettings
Autodesk.Revit.DBGradientBackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GradientBackgroundSettings : BackgroundSettings
Public Class GradientBackgroundSettings
    Inherits BackgroundSettings
public ref class GradientBackgroundSettings : public BackgroundSettings
type GradientBackgroundSettings =
    class
        inherit BackgroundSettings
    end

The GradientBackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | GroundColor | The color of the ground.
Public property | HorizonColor | The color of the horizon.
Public property | SkyColor | The color of the top of the sky.
Top
Methods
 | Name | Description
Top
Remarks
The colors of the background are interpolated for the pixels corresponding to the sky - from the "sky color" (top) to the "horizon color" (bottom). The ground is represented with a solid color ("ground color").
See Also

Reference

Autodesk.Revit.DB Namespace