DisplacementElement Class

DisplacementPath Class

A view-specific annotation related to a DisplacementElement.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDisplacementPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DisplacementPath : Element
Public Class DisplacementPath
    Inherits Element
public ref class DisplacementPath : public Element
type DisplacementPath =
    class
        inherit Element
    end

The DisplacementPath type exposes the following members.

Properties
 | Name | Description
Public property | AncestorIdx | Specifies the end point of the path.
Public property | PathStyle | Specifies the style of the path.
Top
Methods
 | Name | Description
 | Create | Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.
 | IsValidParam | Is the specified value a valid edge or curve parameter.
 | IsValidReference | Does the specified pick represent an edge or a curve belonging to one of the displaced elements.
Public method | SetAnchorPoint | Sets the reference that determines the origin of this DisplacementPath.
Top
Remarks
The DisplacementPath is anchored to the DisplacementElement by a reference to a point on an edge of a source element of the DisplacementElement. It is represented by a single line, or a series of jogged lines, originating at the specified point on the displaced element.

The associated DisplacementElement may have a parent DisplacementElement and this parent may have its own parent DisplacementElement, producing a series of ancestors. The terminal point may be the point's original (un-displaced) location, or the corresponding point on any of the intermediate displaced locations corresponding to these ancestor DisplacementElements.

See Also

Reference

Autodesk.Revit.DB Namespace