INavisworksExporter Interface

InCanvasControlData Class

Represents a collection of data which is used by [!:Autodesk::Revit::DB::TemporaryGraphicsManager] to create and update an in-canvas control.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBInCanvasControlData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InCanvasControlData : IDisposable
Public Class InCanvasControlData
    Implements IDisposable
public ref class InCanvasControlData : IDisposable
type InCanvasControlData =
    class
        interface IDisposable
    end

The InCanvasControlData type exposes the following members.

Constructors
 | Name | Description
Public method | InCanvasControlData(String) | Constructs an InCanvasControlData with specific values assigned.
Public method | InCanvasControlData(String, XYZ) | Constructs an InCanvasControlData with specific values assigned.
Top
Properties
 | Name | Description
Public property | ImagePath | The path to the image file to be used. This must be an absolute path to a location on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Position | The position of the in-canvas control in model coordinates.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the InCanvasControlData
Top
Remarks

So far, only bitmap file is supported for ImagePath. The rendered image is the same size in pixel dimensions as the original one. To get a better result, the caller should prepare the image with proper size, for exmaple: 32x32 or 64x64 in pixels, before use. To achive a "transparent" backgound color effect over the provided bitmap, the bitmap should use color RGB(0, 128, 128) as its background and it will be cleared during rendering by Revit.

See Also

Reference

Autodesk.Revit.DB Namespace