Opening Class

An opening in an Autodesk Revit project or family document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBOpening

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Opening : Element
Public Class Opening
    Inherits Element
public ref class Opening : public Element
type Opening =
    class
        inherit Element
    end

The Opening type exposes the following members.

Properties
 | Name | Description
Public property | BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
Public property | Host | Retrieves the host element of this opening.
Public property | IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
Public property | IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
Public property | IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Public property | SketchId | Returns id of the Sketch or invalidElementId if element deon't own the Sketch.
Top
Methods
 | Name | Description
Top
Remarks
The object represents a variety of different types of openings:
  • A rectangular opening in a wall created by two boundary points in a revit project.
  • An opening created by a set of curves applied to a roof, floor, ceiling, beam, brace or column.
  • A vertical shaft opening extending one or more levels.
  • A simple opening created on a wall or ceiling in a family document.
Depending upon the type of opening, some of the properties of this class will not be available. This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.
Example
C#
VB
C++
F#
Copy
private void Getinfo_Opening(Opening opening)
{
    string message = "Opening:";

    //get the host element of this opening
    message += "\nThe id of the opening's host element is : " + opening.Host.Id.ToString();

    //get the information whether the opening has a rect boundary
    //If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    //Otherwise we should get the geometry information from BoundaryCurves property
    if (opening.IsRectBoundary)
    {
        message += "\nThe opening has a rectangular boundary.";
        //array contains two XYZ objects: the max and min coords of boundary
        IList<XYZ> boundaryRect = opening.BoundaryRect;

        //get the coordinate value of the min coordinate point
        XYZ point = opening.BoundaryRect[0];
        message += "\nMin coordinate point:(" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";

        //get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect[1];
        message += "\nMax coordinate point: (" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";
    }
    else
    {
        message += "\nThe opening doesn't have a rectangular boundary.";
        // Get curve number
        int curves = opening.BoundaryCurves.Size;
        message += "\nNumber of curves is : " + curves;
        for (int i = 0; i < curves; i++)
        {
            Autodesk.Revit.DB.Curve curve = opening.BoundaryCurves.get_Item(i);
            // Get curve start point
            message += "\nCurve start point: " + XYZToString(curve.GetEndPoint(0));
            // Get curve end point
            message += "; Curve end point: " + XYZToString(curve.GetEndPoint(1));
        }
    }
    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
Private Sub Getinfo_Opening(opening As Opening)
    Dim message As String = "Opening:"

    'get the host element of this opening
    message += vbLf & "The id of the opening's host element is : " & opening.Host.Id.ToString()

    'get the information whether the opening has a rect boundary
    'If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    'Otherwise we should get the geometry information from BoundaryCurves property
    If opening.IsRectBoundary Then
        message += vbLf & "The opening has a rectangular boundary."
        'array contains two XYZ objects: the max and min coords of boundary
        Dim boundaryRect As IList(Of XYZ) = opening.BoundaryRect

        'get the coordinate value of the min coordinate point
        Dim point As XYZ = opening.BoundaryRect(0)
        message += ((vbLf & "Min coordinate point:(" + point.X & ", ") + point.Y & ", ") + point.Z & ")"

        'get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect(1)
        message += ((vbLf & "Max coordinate point: (" + point.X & ", ") + point.Y & ", ") + point.Z & ")"
    Else
        message += vbLf & "The opening doesn't have a rectangular boundary."
        ' Get curve number
        Dim curves As Integer = opening.BoundaryCurves.Size
        message += vbLf & "Number of curves is : " & curves
        For i As Integer = 0 To curves - 1
            Dim curve As Autodesk.Revit.DB.Curve = opening.BoundaryCurves.Item(i)
            ' Get curve start point
            message += vbLf & "Curve start point: " & XYZToString(curve.GetEndPoint(0))
            ' Get curve end point
            message += "; Curve end point: " & XYZToString(curve.GetEndPoint(1))
        Next
    End If
    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Private Function XYZToString(point As XYZ) As String
    Return "(" & Convert.ToString(point.X) & ", " & Convert.ToString(point.Y) & ", " & Convert.ToString(point.Z) & ")"
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace