DeleteWorksetSettings Class

DesignOption Class

An element that represents a design alternative.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDesignOption

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DesignOption : Element
Public Class DesignOption
    Inherits Element
public ref class DesignOption : public Element
type DesignOption =
    class
        inherit Element
    end

The DesignOption type exposes the following members.

Properties
 | Name | Description
Public property | IsPrimary | Determines whether this is a primary design option.
Top
Methods
 | Name | Description
 | GetActiveDesignOptionId | Gets the active design option id for the current design option set.
Top
Remarks
Design options enable the user to add alternative designs within the same project. Each element can either be in a design option or not at all, in which case it is considered to be part of the main model and have no design alternatives.
See Also

Reference

Autodesk.Revit.DB Namespace