EnergyAnalysisSpace Class

Analytical space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisSpace

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisSpace : Element
Public Class EnergyAnalysisSpace
    Inherits Element
public ref class EnergyAnalysisSpace : public Element
type EnergyAnalysisSpace =
    class
        inherit Element
    end

The EnergyAnalysisSpace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area for this space.
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this space.
Public property | ComposedName | The composed name for this space.
Public property | Description | The description.
Public property | Number | The number to identify the space.
Public property | SpaceName | The name.
Public property | Volume | The volume for this space.
Top
Methods
 | Name | Description
Public method | GetAnalyticalSurfaces | Provides a way to access the collection of analytical surfaces for a space. Geometry data defining an analytical space volume. Through an analytical surface you can connect a source element with each polygon in a space. The analytical surfaces defines an enclosed volume bounded by the center plane of walls and the top plane of roofs and floors.
Public method | GetBoundary | Gets the collection of polygons that form the 2D boundary. This method returns a collection of polyloops (planar polygons) that defines an enclosed area measured by interior bounding surfaces.
Public method | GetClosedShell | Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces.
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace