BuiltInFailuresGenericMEPFailures Class

BuiltInFailures.GeometryFailures Class

BuiltInFailuresGeometryFailures Class

Failures about GeometryFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGeometryFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GeometryFailures
Public NotInheritable Class GeometryFailures
public ref class GeometryFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GeometryFailures = class end

The BuiltInFailuresGeometryFailures type exposes the following members.

Properties
Name | Description
CannotFindClosest | Cannot find closest points within lines.
ConvertFaceRegionsToFacesCrashed | Failed to replace an instance face with its face regions.
ConvertFaceRegionsToFacesFailed | Failed to replace an instance face with its face regions.
CurveAndSurfaceDoNotIntersect | Curve and Surface do not intersect.
CurveDriverError | Element's internal join data is corrupt.
CurveProjectTooShort | The projection of the line in this view is too short to create a new Line
ElementIsTooThin | [Element] is too thin.
ElementTooSmall | Element is too small on screen
FailedReplaceCurveElemCurveDriver | Failed to replace curve elem curve driver.
FailedUpdateCurveChain | Failed to update curve chain.
FailToConvertLine | Unable to convert lines
LineArcTangentFailure | Can't keep arc element and straight line element tangent.
OffsetFaceFailed | Failed to offset the face.
PolygonSegmentTooShort | Polygon segment too short
SiteInvisible | Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics.
SuccessToConvertLine | Success to convert lines
SymbolicLineInvalidPlane | Symbolic Element refers to a Work Plane with unacceptable normal.
TooManyFacesEdges | This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.
Top
See Also

Reference

Autodesk.Revit.DB Namespace