ElevationMarker Class

Ellipse Class

A whole or partial ellipse.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBEllipse

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Ellipse : Curve
Public Class Ellipse
    Inherits Curve
public ref class Ellipse : public Curve
type Ellipse =
    class
        inherit Curve
    end

The Ellipse type exposes the following members.

Properties
 | Name | Description
Public property | Center | Returns the center of the ellipse.
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | XDirection | The X direction.
Public property | YDirection | The Y direction.
Top
Methods
 | Name | Description
 | CreateCurve | Creates a new geometric ellipse or elliptical arc object.
Top
See Also

Reference

Autodesk.Revit.DB Namespace