ExportLineweightTable Class

ExportLineweightTableIterator Class

An iterator to a set of line weight table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLineweightTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLineweightTableIterator : IEnumerator<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>
Public Class ExportLineweightTableIterator
    Implements IEnumerator(Of KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo))
public ref class ExportLineweightTableIterator : IEnumerator<KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^>>
type ExportLineweightTableIterator =
    class
        interface IEnumerator<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>
    end

The ExportLineweightTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLineweightTableIterator
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Top
See Also

Reference

Autodesk.Revit.DB Namespace