GeometryObject Class

GeometryObject.Inequality Operator

GeometryObjectInequality Operator

Determines whether two GeometryObjects are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    GeometryObject first,
    GeometryObject second
)
Public Shared Operator <> (
    first As GeometryObject,
    second As GeometryObject
) As Boolean
public:
static bool operator !=(
    GeometryObject^ first,
    GeometryObject^ second
)
static let inline (<>)
        first : GeometryObject *
        second : GeometryObject  : bool

Parameters

first GeometryObject
The first GeometryObject.
second GeometryObject
The second GeometryObject.

Return Value

Boolean
True if the GeometryObjects are different; otherwise, false.
Remarks
This compares the internal identifiers of the geometry, and doesn't compare them geometrically.
See Also

Reference