ShapeImporter Class

ShapeImporter.IsServiceAvailable Method

ShapeImporterIsServiceAvailable Method

Checks whether the data conversion service is available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsServiceAvailable()
Public Shared Function IsServiceAvailable As Boolean
public:
static bool IsServiceAvailable()
static member IsServiceAvailable : unit -> bool

Return Value

Boolean
True if the data conversion service is available, false otherwise.
Remarks
ShapeImporter relies on optional data conversion functionality. This function checks whether it is available.
See Also

Reference