FamilyType Class

FamilyTypeSet Class

A set that contains FamilyType objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyTypeSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyTypeSet : APIObject,
    IEnumerable
Public Class FamilyTypeSet
    Inherits APIObject
    Implements IEnumerable
public ref class FamilyTypeSet : public APIObject,
    IEnumerable
type FamilyTypeSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The FamilyTypeSet type exposes the following members.

Constructors
 | Name | Description
Public method | FamilyTypeSet | Initializes a new instance of the FamilyTypeSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace