RevitLinkGraphicsSettings Class

RevitLinkGraphicsSettings Methods

The RevitLinkGraphicsSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | GetDiscipline | The linked document discipline of RevitLinkGraphicsSettings.
Public method | GetDisciplineType | The discipline type of RevitLinkGraphicsSettings.
Public method | GetPhaseFilterId | The linked document phase filter id of RevitLinkGraphicsSettings, or InvalidElementId if there is no phase filter explicitly assigned.
Public method | GetPhaseFilterType | The phase filter type of RevitLinkGraphicsSettings.
Public method | GetPhaseId | The linked document phase id of RevitLinkGraphicsSettings, or InvalidElementId if there is no phase explicitly assigned.
Public method | GetPhaseType | The phase type of RevitLinkGraphicsSettings.
Public method | GetViewDetailLevel | The linked document view detail level of RevitLinkGraphicsSettings.
Public method | GetViewDetailLevelType | The view detail level type of RevitLinkGraphicsSettings.
 | IsViewRangeSupported | Returns true if the input view supports ViewRange settings of RevitLinkGraphicsSettings, false otherwise.
Public method | SetDiscipline | Sets discipline and discipline type of RevitLinkGraphicsSettings.
Public method | SetPhase | Sets phase id and phase type of RevitLinkGraphicsSettings.
Public method | SetPhaseFilter | Sets phase filter id and phase filter type of RevitLinkGraphicsSettings.
Public method | SetViewDetailLevel | Sets view detail level and detail level type of RevitLinkGraphicsSettings.
Top
See Also

Reference