Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBCurveByPoints
Autodesk.Revit.DBDetailCurve
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DB.StructureAreaReinforcementCurve
Autodesk.Revit.DBSymbolicCurve

CurveElement Properties

The CurveElement type exposes the following members.

Properties
 | Name | Description
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.
Public property | CurveElementType | Type of the curve element.
Public property | GeometryCurve | Geometry curve of the curve element.
Public property | LineStyle | The line style of this curve element.
Public property | SketchPlane | The sketch plane the curve element lies in.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element.
Top
See Also

Reference