SelectionFilterElement Class

ServerPath Class

This class represents a path to a Revit Server location, rather than a location on disk or a network drive.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBModelPath
Autodesk.Revit.DBServerPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ServerPath : ModelPath
Public Class ServerPath
    Inherits ModelPath
public ref class ServerPath : public ModelPath
type ServerPath =
    class
        inherit ModelPath
    end

The ServerPath type exposes the following members.

Constructors
 | Name | Description
Public method | ServerPath | Constructs a ServerPath
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks

ServerPaths must refer to Revit models.

ServerPaths are relative to the central server location, and are of the form "RSN://{HostNodeName}/{model_path}".

The {model_path} portion is a relative path to a Revit model. For example, the following are valid server paths:

  • RSN://EXS/hospital.rvt
  • RSN://EXS.autodesk.com/Old Files/hotel2.rvt
  • RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
The following would not be valid server paths:
  • //EXS/Old Files/.rvt
  • EXS/hospital
See Also

Reference

Autodesk.Revit.DB Namespace