LayoutRuleFixedDistance Class

LayoutRuleFixedNumber Class

This class indicate the layout rule of a Beam System is Fixed-Number.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLayoutRule
Autodesk.Revit.DBLayoutRuleFixedNumber

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LayoutRuleFixedNumber : LayoutRule
Public Class LayoutRuleFixedNumber
    Inherits LayoutRule
public ref class LayoutRuleFixedNumber : public LayoutRule
type LayoutRuleFixedNumber =
    class
        inherit LayoutRule
    end

The LayoutRuleFixedNumber type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutRuleFixedNumber | Constructor of LayoutRuleFixedNumber.
Top
Properties
 | Name | Description
Public property | NumberOfLines | Get or set the number of the beams in a beam system.
Top
Methods
 | Name | Description
Top
Remarks
To use this type of LayoutRule, only the number of the beams must be set.
Example
C#
VB
C++
F#
Copy
private bool LayoutRuleFixedNumberInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedNumber myLayoutRuleFixedNumber =
                        new LayoutRuleFixedNumber(8);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber;

    LayoutRuleFixedNumber fixedNumber = beamSystem.LayoutRule as LayoutRuleFixedNumber;

    if (null == fixedNumber)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    int numberOfLines = fixedNumber.NumberOfLines;

    message += "\nNew BeamSystem layout rule: " + fixedNumber;
    message += "\nNew BeamSystem number of beams: " + numberOfLines;

    TaskDialog.Show("Revit",message);

    return true;
}
Private Function LayoutRuleFixedNumberInformation(beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedNumber As New LayoutRuleFixedNumber(8)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber

    Dim fixedNumber As LayoutRuleFixedNumber = TryCast(beamSystem.LayoutRule, LayoutRuleFixedNumber)

    If fixedNumber Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim numberOfLines As Integer = fixedNumber.NumberOfLines

    message += vbLf & "New BeamSystem layout rule: " & fixedNumber.ToString()
    message += vbLf & "New BeamSystem number of beams: " & numberOfLines

    TaskDialog.Show("Revit", message)

    Return True
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace