IGetLocalPathForOpenCallback Interface

ImageBackgroundSettings Class

Represents the rendering image background settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBackgroundSettings
Autodesk.Revit.DBImageBackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageBackgroundSettings : BackgroundSettings
Public Class ImageBackgroundSettings
    Inherits BackgroundSettings
public ref class ImageBackgroundSettings : public BackgroundSettings
type ImageBackgroundSettings =
    class
        inherit BackgroundSettings
    end

The ImageBackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundImageFit | The background image fit type.
Public property | FilePath | File path of the image for the rendering background.
Public property | OffsetHeight | The vertical offset of the rendering image to the rendering region.
Public property | OffsetWidth | The horizontal offset of the rendering image to the rendering region.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace