Edge Class

EdgeArray Class

An array that contains edges.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBEdgeArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EdgeArray : APIObject, IEnumerable
Public Class EdgeArray
    Inherits APIObject
    Implements IEnumerable
public ref class EdgeArray : public APIObject,
    IEnumerable
type EdgeArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The EdgeArray type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeArray | Initializes a new instance of the EdgeArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets an edge at a specified index within the array.
Public property | Size | Returns the number of edges that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the edge to the end of the array.
Public method | Clear | Removes every edge from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified edge into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace