EditScope Class

Element Class

Base class for most persistent data within a Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Element : IDisposable
Public Class Element
    Implements IDisposable
public ref class Element : IDisposable
type Element =
    class
        interface IDisposable
    end

The Element type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
 | CreatedPhaseId | Id of a Phase at which the Element was created.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished.
 | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
 | Geometry | Retrieves the geometric representation of the element.
Public property | GroupId | The id of the group to which an element belongs.
 | Id | A unique identifier for an Element in an Autodesk Revit project.
Public property | IsModifiable | Identifies if the element is modifiable.
Public property | IsTransient | Indicates whether an element is transient or permanent.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LevelId | The id of the level associated with the element.
 | Location | This property is used to find the physical location of an element within a project.
Public property | Name | A human readable name for the Element.
Public property | OwnerViewId | The id of the view that owns the element.
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id.
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition.
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter.
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | Pinned | Identifies if the element has been pinned to prevent changes.
 | UniqueId | A stable unique identifier for an element within the document.
Public property | VersionGuid | Get the element version Guid.
Public property | ViewSpecific | Identifies if the element is owned by a view.
Public property | WorksetId | Get Id of the Workset which owns the element.
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view.
Public method | CanBeLocked | Identifies if the element can be locked.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollectionElementId) | Checks if all elements in the set can have a type assigned.
Public method | ChangeTypeId(ElementId) | Changes the type of the element.
 | ChangeTypeId(Document, ICollectionElementId, ElementId) | Changes the type of all elements in the given set.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element
Public method | DeleteSubelement | Removes a subelement from the element.
Public method | DeleteSubelements | Removes the subelements from the element.
Public method | Dispose | Releases all resources used by the Element
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element.
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set.
 | GetChangeTypeAny | Returns ChangeType associated with any change in an element.
 | GetChangeTypeElementAddition | Returns ChangeType associated with element addition
 | GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
 | GetChangeTypeGeometry | Returns ChangeType associated with a change in the geometry of an element
 | GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
 | GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element.
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type.
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type.
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element.
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object.
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference.
Public method | GetMaterialArea | Gets the area of the material with the given id.
Public method | GetMaterialIds | Gets the element ids of all materials present in the element.
Public method | GetMaterialVolume | Gets the volume of the material with the given id.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order.
Public method | GetParameter | Retrieves a parameter from the element given identifier.
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
Public method | GetParameters | Retrieves the parameters from the element via the given name.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase
Public method | GetSubelements | Returns the collection of element subelements.
 | GetTypeId | Returns the identifier of this element's type.
Public method | GetValidTypes | Obtains a set of types that are valid for this element.
 | GetValidTypes(Document, ICollectionElementId) | Obtains a set of types that are valid for all given elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order.
Public method | IsExternalFileReference | Determines whether this Element represents an external file.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollectionElementId, ElementId) | Checks if given type is valid for the set of elements.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type.
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
Top
Remarks
The data in a Revit document consists primarily of a collection of elements. An element usually corresponds to a single component of a building or drawing, such as a wall, door, or dimension, but it can also be something more abstract, like a wall type or a view. Every element in a document has a unique ID, represented by the ElementId class.
See Also

Reference

Autodesk.Revit.DB Namespace