AnnotationSymbolType Class

APIObject Class

Supports all objects in the Autodesk Revit API hierarchy.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class APIObject : IDisposable
Public Class APIObject
    Implements IDisposable
public ref class APIObject : IDisposable
type APIObject =
    class
        interface IDisposable
    end

The APIObject type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing.
Top
See Also

Reference

Autodesk.Revit.DB Namespace