BuiltInFailuresMEPFabricationFailures Class

BuiltInFailures.MEPSupportFailures Class

BuiltInFailuresMEPSupportFailures Class

Failures about MEP suppor.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMEPSupportFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MEPSupportFailures
Public NotInheritable Class MEPSupportFailures
public ref class MEPSupportFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MEPSupportFailures = class end

The BuiltInFailuresMEPSupportFailures type exposes the following members.

Properties
Name | Description
CannotMatchInstanceSizeToHostError | The instance of [Symbol] cannot be re-sized to match the host.
InstanceOutOfHostError | The instance of [Symbol] lost its host and will be deleted.
InstanceProfileNotMatchWithHostError | The [Symbol]'s profile does not match the host. Instances of [Symbol] will be deleted.
TypeSizeNotMatchWithHostError | The [Symbol] does not match the size of the host.
Top
See Also

Reference

Autodesk.Revit.DB Namespace