GroupSetIterator Class

GroupType Class

An element representing a group of elements that may be placed many times in a project or family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBGroupType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GroupType : ElementType
Public Class GroupType
    Inherits ElementType
public ref class GroupType : public ElementType
type GroupType =
    class
        inherit ElementType
    end

The GroupType type exposes the following members.

Properties
 | Name | Description
Public property | Groups | Retrieve a set of all the groups that have this type.
Top
Methods
 | Name | Description
Public method | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this element group type.
 | LoadFrom | Replaces the group with the contents of the input file.
Top
Remarks
Grouping elements is useful when you need to create entities that represent repeating layouts or are common to many building projects, such as hotel rooms, apartments, or repeating floors.
Example
C#
VB
C++
F#
Copy
public void GetInfo_GroupType(GroupType groupType)
{
    string message = "GroupType";
    //Retrieve a set of all the groups that have this type.
    foreach (Group group in groupType.Groups)
    {
        // Get GroupType group name
        message = "\nThe group type name is : " + groupType.Name;
        //Returns all the members of the group.
        message += "\nThe types and ids of the group members are : ";
        IList<ElementId> groupMembers = group.GetMemberIds();
        foreach (ElementId memberId in groupMembers)
        {
            Element element = group.Document.GetElement(memberId);
            // Get GroupType group element id
            message += "\n\t" + element.GetType().Name + " : " + memberId.ToString();
        }
    }
    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_GroupType(groupType As GroupType)
    Dim message As String = "GroupType"
    'Retrieve a set of all the groups that have this type.
    For Each group As Group In groupType.Groups
        ' Get GroupType group name
        message = vbLf & "The group type name is : " & Convert.ToString(groupType.Name)
        'Returns all the members of the group.
        message += vbLf & "The types and ids of the group members are : "
        Dim groupMembers As IList(Of ElementId) = group.GetMemberIds()
        For Each memberId As ElementId In groupMembers
            Dim element As Element = group.Document.GetElement(memberId)
            ' Get GroupType group element id
            message += (vbLf & vbTab + element.[GetType]().Name & " : ") + memberId.Value
        Next
    Next
    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace