Family Class

FamilyElementVisibility Class

Provides access to the visibility parameters of family elements in family document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyElementVisibility

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyElementVisibility : APIObject
Public Class FamilyElementVisibility
    Inherits APIObject
public ref class FamilyElementVisibility : public APIObject
type FamilyElementVisibility =
    class
        inherit APIObject
    end

The FamilyElementVisibility type exposes the following members.

Constructors
 | Name | Description
Public method | FamilyElementVisibility | Initializes a new instance of the FamilyElementVisibility class
Top
Properties
 | Name | Description
Public property | IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
Public property | IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
Public property | IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
Public property | IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
Public property | IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
Public property | IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
Public property | IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
Public property | IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
Public property | VisibilityType | Indicates if the instance is Model or View specific.
Top
Methods
 | Name | Description
Top
Example
C#
VB
C++
F#
Copy
public void CreateAndSetVisibility(Autodesk.Revit.DB.Document familyDocument, SketchPlane sketchPlane)
{
    // create a new ModelCurve in the family document
    XYZ p0 = new XYZ(1, 1, 0);
    XYZ p1 = new XYZ(5, 1, 0);
    Line line1 = Line.CreateBound(p0, p1);

    ModelCurve modelCurve1 = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane);

    // create a new ModelText along ModelCurve line
    ModelText text = familyDocument.FamilyCreate.NewModelText("Hello World", null, sketchPlane, p0, HorizontalAlign.Center, 0.1);

    // set visibility for text
    FamilyElementVisibility textVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    textVisibility.IsShownInTopBottom = false;
    text.SetVisibility(textVisibility);

    // set visibility for line
    FamilyElementVisibility curveVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    curveVisibility.IsShownInCoarse = false;
    modelCurve1.SetVisibility(curveVisibility);

}
Public Sub CreateAndSetVisibility(familyDocument As Autodesk.Revit.DB.Document, sketchPlane As SketchPlane)
    ' create a new ModelCurve in the family document
    Dim p0 As New XYZ(1, 1, 0)
    Dim p1 As New XYZ(5, 1, 0)
    Dim line1 As Line = Line.CreateBound(p0, p1)

    Dim modelCurve1 As ModelCurve = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane)

    ' create a new ModelText along ModelCurve line
    Dim text As ModelText = familyDocument.FamilyCreate.NewModelText("Hello World", Nothing, sketchPlane, p0, HorizontalAlign.Center, 0.1)

    ' set visibility for text
    Dim textVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    textVisibility.IsShownInTopBottom = False
    text.SetVisibility(textVisibility)

    ' set visibility for line
    Dim curveVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    curveVisibility.IsShownInCoarse = False
    modelCurve1.SetVisibility(curveVisibility)

End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace