FormArrayIterator Class

FormatOptions Class

Options for formatting numbers with units.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFormatOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormatOptions : IDisposable
Public Class FormatOptions
    Implements IDisposable
public ref class FormatOptions : IDisposable
type FormatOptions =
    class
        interface IDisposable
    end

The FormatOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FormatOptions | Creates a new FormatOptions object that represents default formatting.
Public method | FormatOptions(ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.
Public method | FormatOptions(FormatOptions) | Creates a copy of a FormatOptions object.
Public method | FormatOptions(ForgeTypeId, ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.
Top
Properties
 | Name | Description
Public property | Accuracy | The accuracy to which values will be rounded.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RoundingMethod | The method used to round values: round to nearest, round up, or round down.
Public property | SuppressLeadingZeros | Indicates if leading zeros should be suppressed in feet and fractional inches.
Public property | SuppressSpaces | Indicates if spaces around the dash should be suppressed in feet and fractional inches.
Public property | SuppressTrailingZeros | Indicates if trailing zeros after the decimal point should be suppressed.
Public property | UseDefault | Indicates whether default or custom formatting should be used.
Public property | UseDigitGrouping | Indicates if digit grouping symbols should be displayed.
Public property | UsePlusPrefix | Indicates if a plus sign prefix should be displayed for positive and zero values.
Top
Methods
 | Name | Description
Public method | CanHaveSymbol | Checks whether a symbol can be specified to display the unit in this FormatOptions.
 | CanHaveSymbol(ForgeTypeId) | Checks whether a symbol can be specified to display a given unit.
Public method | CanSuppressLeadingZeros | Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressLeadingZeros(ForgeTypeId) | Checks whether leading zeros can be suppressed for a given unit.
Public method | CanSuppressSpaces | Checks whether spaces can be suppressed for the display unit in this FormatOptions.
 | CanSuppressSpaces(ForgeTypeId) | Checks whether spaces can be suppressed for a given unit.
Public method | CanSuppressTrailingZeros | Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressTrailingZeros(ForgeTypeId) | Checks whether trailing zeros can be suppressed for a given unit.
Public method | CanUsePlusPrefix | Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.
 | CanUsePlusPrefix(ForgeTypeId) | Checks whether a plus prefix can be displayed for a given unit.
Public method | Dispose | Releases all resources used by the FormatOptions
Public method | GetSymbolTypeId | Gets the identifier of the symbol indicating the unit quantifying the value.
Public method | GetUnitTypeId | Gets the identifier of the unit used to quantify values.
Public method | GetValidSymbols | Gets the identifiers of all valid symbols for the unit in this FormatOptions.
 | GetValidSymbols(ForgeTypeId) | Gets the identifiers of all valid symbols for a given unit.
Public method | IsValidAccuracy(Double) | Checks whether an accuracy is valid for the display unit in this FormatOptions.
 | IsValidAccuracy(ForgeTypeId, Double) | Checks whether an accuracy is valid for a given unit.
Public method | IsValidForSpec | Checks whether this FormatOptions is valid for a given spec.
Public method | IsValidSymbol(ForgeTypeId) | Checks whether a symbol is valid for the unit in this FormatOptions.
 | IsValidSymbol(ForgeTypeId, ForgeTypeId) | Checks whether a symbol is valid for a given unit.
Public method | SetSymbolTypeId | Sets the symbol that should be displayed to indicate the unit quantifying the value.
Public method | SetUnitTypeId | Sets the unit used to quantify values.
Top
Remarks

The FormatOptions class contains settings that control how to format numbers with units as strings. It contains those settings that are typically chosen by an end user in the Format dialog and stored in the document.

The FormatOptions class is used in two different ways. A FormatOptions object in the Units class represents the default settings for the document. A FormatOptions object used elsewhere represents settings that may optionally override the default settings.

The UseDefault property controls whether a FormatOptions object represents default or custom formatting. If UseDefault is true, formatting will be according to the default settings in the Units class, and none of the other settings in the object are meaningful. If UseDefault is false, the object contains custom settings that override the default settings in the Units class. UseDefault is always false for FormatOptions objects in the Units class.

See Also

Reference

Autodesk.Revit.DB Namespace