BRepBuilderSurfaceGeometry Class

BRepType Enumeration

This class defines an enumerative type used to specify the type of output geometry expected from a BRepBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BRepType
Public Enumeration BRepType
public enum class BRepType
type BRepType
Members
Member name | Value | Description
OpenShell | 0 | The output geometry is expected to represent an open shell.
Solid | 1 | The output geometry is expected to represent a (possibly disconnected) solid.
Void | 2 | The output geometry is expected to represent a (possibly disconnected) void (i.e., an inverted solid).
See Also

Reference

Autodesk.Revit.DB Namespace