ImportIFCOptions Class

ImportInstance Class

An element created during either import or link operation. It is an instance of CADLinkType.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBImportInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImportInstance : Instance
Public Class ImportInstance
    Inherits Instance
public ref class ImportInstance : public Instance
type ImportInstance =
    class
        inherit Instance
    end

The ImportInstance type exposes the following members.

Properties
 | Name | Description
Public property | IsLinked | Identifies whether this instance is a linked object rather than imported one.
Top
Methods
 | Name | Description
 | Create(Document, ElementId, View) | Creates a new instance of an existing DWG link type.
 | Create(Document, View, ExternalResourceReference, DGNImportOptions, LinkLoadResult) | Creates a new instance of DGN link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, DWGImportOptions, LinkLoadResult) | Creates a new instance of DWG link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, ImportOptions3DM, LinkLoadResult) | Creates a new instance of 3DM link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, OBJImportOptions, LinkLoadResult) | Creates a new instance of OBJ link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, SATImportOptions, LinkLoadResult) | Creates a new instance of SAT link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, SKPImportOptions, LinkLoadResult) | Creates a new instance of SKP link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, STEPImportOptions, LinkLoadResult) | Creates a new instance of STEP link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, STLImportOptions, LinkLoadResult) | Creates a new instance of STL link type from an external resource reference and loads the linked file.
 | Create(Document, View, String, DWGImportOptions, LinkLoadResult) | Creates a new instance of DWG or DXF link type from a file path and loads the linked file.
Public method | GetVisibility | Gets the visibility for the import instance in a family document.
Public method | SetVisibility | Sets the visibility for the import instance in a family document.
Top
See Also

Reference

Autodesk.Revit.DB Namespace