LoadedFamilyIntegrityCheck Class

LoadOperationType Enumeration

An enum indicating whether a resource load operation was triggered by a user action or an automatic process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LoadOperationType
Public Enumeration LoadOperationType
public enum class LoadOperationType
type LoadOperationType
Members
Member name | Value | Description
Automatic | 0 | The load operation was triggered automatically by another operation.
Explicit | 1 | The load operation was triggered by an explicit reload action on the part of the user.
Remarks

This enum is provided so that an external resource server can decide how much feedback it wishes to provide to the user.

For example, Revit automatically loads all resources on file open. This may cause many external resources to load at once. The server may wish to provide truncated error messages.

Reload() and LoadFrom() operations from the API are considered to be LoadOperationType.Explicit.

See Also

Reference

Autodesk.Revit.DB Namespace