GeometryInstance Class

GeometryInstance Methods

The GeometryInstance type exposes the following members.

Methods
 | Name | Description
Public method | GetDocument | Gets the document that contains the symbol of this instance.
Public method | GetInstanceGeometry | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.
Public method | GetSymbolGeometry | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometryId | Gets the SymbolGeometryId that contains data about the symbol of this instance.
Top
See Also

Reference