DirectShapeLibrary Class

DirectShapeOptions Class

This class is used to control behavior of a DirectShape object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDirectShapeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectShapeOptions : IDisposable
Public Class DirectShapeOptions
    Implements IDisposable
public ref class DirectShapeOptions : IDisposable
type DirectShapeOptions =
    class
        interface IDisposable
    end

The DirectShapeOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReferencingOption | Whether or not the geometry stored in a DirectShape object may be referenced.
Public property | RoomBoundingOption | Identifies whether the DirectShape supports an option for the "Room Bounding" parameter to permit participation in room boundary calculations.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DirectShapeOptions
Top
Remarks
Use Enable/Disable functions to change the default behavior. Use DirectShape.SetOptions to modify that object's behavior.
See Also

Reference

Autodesk.Revit.DB Namespace