IOnLocalLinkSharedCoordinatesSavedCallback Interface

IOpenFromCloudCallback Interface

An interface that may be used to control Revit's behavior when opening a cloud model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IOpenFromCloudCallback
Public Interface IOpenFromCloudCallback
public interface class IOpenFromCloudCallback
type IOpenFromCloudCallback = interface end

The IOpenFromCloudCallback type exposes the following members.

Methods
 | Name | Description
Public method | OnOpenConflict | A method called when the conflict is happen during the model opening.
Top
Example
C#
Copy
class OpenFromCloudCallback : IOpenFromCloudCallback
{
   public OpenConflictResult OnOpenConflict(OpenConflictScenario scenario)
   {
      switch (scenario)
      {
         case OpenConflictScenario.OutOfDate:
            // Continue to open the model so that I can save my local changes to the central model
            return OpenConflictResult.KeepLocalChanges;

         case OpenConflictScenario.VersionArchived:
            // My local model is far behind the central model, so discard my local changes regardless what they are
            return OpenConflictResult.DiscardLocalChangesAndOpenLatestVersion;

         case OpenConflictScenario.Relinquished:
         case OpenConflictScenario.Rollback:
            // Detach the loal model from its central model, to examine local changes
            return OpenConflictResult.DetachFromCentral;
      }

      return OpenConflictResult.Cancel;
   }
}

static Document OpenCloudModelWithCallback(Application application, ModelPath modelPath)
{
   OpenOptions options = new OpenOptions();
   OpenFromCloudCallback callback = new OpenFromCloudCallback();

   return application.OpenDocumentFile(modelPath, options, callback);
}
See Also

Reference

Autodesk.Revit.DB Namespace