BuiltInFailuresSubRegionFailures Class

BuiltInFailures.SweepFailures Class

BuiltInFailuresSweepFailures Class

Failures about Sweep.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSweepFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SweepFailures
Public NotInheritable Class SweepFailures
public ref class SweepFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SweepFailures = class end

The BuiltInFailuresSweepFailures type exposes the following members.

Properties
Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.
WallSweepInconsistent | The model contains corrupt elements. Delete the corrupt elements to proceed or cancel the action without deleting the elements.
Top
See Also

Reference

Autodesk.Revit.DB Namespace