EdgeEndPoint Class

EditScope Class

The base class for a scope object that provides special access and limitations related to editing certain elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBEditScope
Autodesk.Revit.DB.ArchitectureTopographyEditScope
Autodesk.Revit.DBSketchEditScope
Autodesk.Revit.DBStairsEditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditScope : IDisposable
Public Class EditScope
    Implements IDisposable
public ref class EditScope : IDisposable
type EditScope =
    class
        interface IDisposable
    end

The EditScope type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.
Public property | IsPermitted | Tells if the edit scope is permitted to start.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Cancel | Cancels the edit scope.
Public method | Commit | Finishes the edit scope.
Public method | Dispose | Releases all resources used by the EditScope
Top
Remarks
Derivations of this class provide specific functionality to manage edit modes for specific purposes.
See Also

Reference

Autodesk.Revit.DB Namespace