BuiltInFailuresOpeningFailures Class

BuiltInFailures.OverlapFailures Class

BuiltInFailuresOverlapFailures Class

Failures detected by overlap check.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresOverlapFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class OverlapFailures
Public NotInheritable Class OverlapFailures
public ref class OverlapFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type OverlapFailures = class end

The BuiltInFailuresOverlapFailures type exposes the following members.

Properties
Name | Description
AreaBoundaryLinesOverlap | Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
CurvesOverlap | Highlighted lines overlap. Lines may not form closed loops.
DivisionSketchOverlap | Curves in the sketch of the Division overlap.
DuplicateFabricSheet | There are identical Fabric sheets in the same place. This will result in double counting in schedules.
DuplicateInstances | There are identical instances in the same place. This will result in double counting in schedules.
DuplicatePoints | There are identical points in the same place. Lines created from points may not work as expected.
DuplicateRebar | There are identical rebar in the same place. This will result in double counting in schedules.
ELASeparationLinesOverlap | Highlighted area based load boundary lines overlap. One of them may be ignored when Revit finds load area boundaries. Delete one of the lines.
FloorsOverlap | Highlighted floors overlap.
LevelsOverlap | Highlighted levels overlap.
OverlappingElementsTest | There are overlapping structural framing elements of the same type in the project found by Dynamic Update.
RoomSeparationLinesOverlap | Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
SpaceSeparationLinesOverlap | Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
SubregionOverlap | Highlighted sub-division overlap.
ToposolidFloorOverlap | Highlighted toposolid and floor overlap.
ToposolidOverlap | Highlighted toposolid overlap.
ToposolidSubregionOverlap | Highlighted toposolid and sub-division overlap.
WallAreaBoundaryOverlap | Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
WallRoomSeparationOverlap | A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
WallsOverlap | Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
WallSpaceSeparationOverlap | A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.
Top
See Also

Reference

Autodesk.Revit.DB Namespace