BuiltInFailuresElectricityFailures Class

BuiltInFailures.ElementFailures Class

BuiltInFailuresElementFailures Class

Failures about Elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresElementFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ElementFailures
Public NotInheritable Class ElementFailures
public ref class ElementFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElementFailures = class end

The BuiltInFailuresElementFailures type exposes the following members.

Properties
Name | Description
FailedToRemoveElement | Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.
NotAllowedToRemoveAllElements | You cannot removed all the elements from current solution. At least there should be two elements in the solution.
SplitElementHasTagsWithoutLeaders | The split element has one or more Tags without Leaders enabled and needs to be checked.
Top
See Also

Reference

Autodesk.Revit.DB Namespace