BuiltInFailuresStructuralCustomConnectionFailures Class

BuiltInFailures.StructuralLoadFailures Class

BuiltInFailuresStructuralLoadFailures Class

Failures about Load.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresStructuralLoadFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StructuralLoadFailures
Public NotInheritable Class StructuralLoadFailures
public ref class StructuralLoadFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StructuralLoadFailures = class end

The BuiltInFailuresStructuralLoadFailures type exposes the following members.

Properties
Name | Description
CannotMirrorBoundaryCondition | Can't mirror Boundary Conditions
CannotMoveBoundaryCondition | Can't move Boundary Conditions
CannotPlaceBoundaryConditions | A boundary condition is already created on the selected element. Duplicate boundary conditions are not allowed. Click the Replace button to delete previous definition of boundary condition or cancel the operation.
HostChangeDisallowsLoadOrBoundaryConditions | Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.
Top
See Also

Reference

Autodesk.Revit.DB Namespace