IndependentTag Class

InsertableObject Class

A base class you all types that are insertable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBFamilySymbol

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InsertableObject : ElementType
Public Class InsertableObject
    Inherits ElementType
public ref class InsertableObject : public ElementType
type InsertableObject =
    class
        inherit ElementType
    end

The InsertableObject type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace