AppearanceAssetElement Class

Arc Class

A circular arc.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBArc

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Arc : Curve
Public Class Arc
    Inherits Curve
public ref class Arc : public Curve
type Arc =
    class
        inherit Curve
    end

The Arc type exposes the following members.

Properties
 | Name | Description
Public property | Center | Returns the center of the arc.
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Radius | Returns the radius of the arc.
Public property | XDirection | Returns the X direction.
Public property | YDirection | Returns the Y direction.
Top
Methods
 | Name | Description
 | Create(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
 | Create(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
 | Create(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Top
Remarks
The arc lies in the plane defined by center and normal.
See Also

Reference

Autodesk.Revit.DB Namespace