ExternalFileUtils Class

ExternalGeometryId Class

This class represents an identifier for geometry from external sources.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalGeometryId : IDisposable
Public Class ExternalGeometryId
    Implements IDisposable
public ref class ExternalGeometryId : IDisposable
type ExternalGeometryId =
    class
        interface IDisposable
    end

The ExternalGeometryId type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalGeometryId | Constructs an ExternalGeometryId object holding the given external geometry identifier.
Top
Properties
 | Name | Description
Public property | Id | External geometry identifier.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalGeometryId
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the hash code. (Overrides ObjectGetHashCode)
 | IsValidExternalGeometryId | Checks whether a given string represents a valid ExternalGeometryId or not.
Top
Operators
Name | Description
Equality(ExternalGeometryId, ExternalGeometryId) | Determines whether two ExternalGeometryIds are the same.
Inequality(ExternalGeometryId, ExternalGeometryId) | Determines whether two ExternalGeometryIds are different.
Top
See Also

Reference

Autodesk.Revit.DB Namespace