ReloadLatestOptions Class

ReloadSwapOutInfo Class

This object contains information about fabrication parts swapped out during reload.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBReloadSwapOutInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReloadSwapOutInfo : IDisposable
Public Class ReloadSwapOutInfo
    Implements IDisposable
public ref class ReloadSwapOutInfo : IDisposable
type ReloadSwapOutInfo =
    class
        interface IDisposable
    end

The ReloadSwapOutInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentVersion | New version.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Part | The ElementId of part being swapped.
Public property | PreviousVersion | Previous version.
Public property | WasSwapped | Whether the swap out was successful.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ReloadSwapOutInfo
Top
See Also

Reference

Autodesk.Revit.DB Namespace