FabricationAncillaryUsage Class

FabricationConfiguration Class

This element contains the information about the fabrication configuration settings used by the project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFabricationConfiguration

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationConfiguration : Element
Public Class FabricationConfiguration
    Inherits Element
public ref class FabricationConfiguration : public Element
type FabricationConfiguration =
    class
        inherit Element
    end

The FabricationConfiguration type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | AncillaryExists | Checks to see if the specified ancillary exists.
Public method | AreItemFilesLoaded | Checks if the fabrication item files have been loaded.
Public method | CanBeSwapped | Checks if the fabrication configuration can be swapped.
Public method | CanUnloadItemFiles | Checks if the fabrication item files are already in use and should not be unloaded.
Public method | CheckConnectionsForAllFabricationParts | Checks the connections for all fabrication parts in the current project. It will create reviewable warnings for all bad connections found. The checks are looking for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Public method | CustomDataExists | Checks to see if the specified custom data exists.
Public method | DamperExists | Checks to see if the specified damper exists.
Public method | GetAllDampers | Gets all damper identifiers in the fabrication configuration.
Public method | GetAllFabricationConnectorDefinitions | Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Public method | GetAllInsulationSpecifications | Gets all insulation specification identifiers in the fabrication configuration.
Public method | GetAllLoadedItemFiles | Get list of all loaded fabrication item files.
Public method | GetAllLoadedServices | Returns all the loaded fabrication services.
Public method | GetAllMaterials | Gets all material identifiers in the fabrication configuration.
Public method | GetAllPartCustomData | Gets all possible fabrication part custom data identifiers.
Public method | GetAllPartStatuses | Gets all possible fabrication part status identifiers.
Public method | GetAllServices | Returns all fabrication services in the fabrication configuration.
Public method | GetAllSpecifications | Gets all specification identifiers in the fabrication configuration.
Public method | GetAllUsedItemFiles | Returns all the used fabrication item files. A fabrication item file is used if any fabrication parts in the model were created from it.
Public method | GetAllUsedServices | Returns all the used fabrication services. A service is used if any fabrication part in the service is created by user.
Public method | GetAncillaries | Gets fabrication ancillaries of the specified type.
Public method | GetAncillaryGroup | Gets the fabrication ancillary group of the specified fabrication ancillary identifier.
Public method | GetAncillaryGroupName | Gets the fabrication ancillary group and name for the specified fabrication ancillary identifier.
Public method | GetAncillaryName | Gets the fabrication ancillary name for the specified fabrication ancillary identifier.
Public method | GetDamperName | Gets the damper name from its identifier.
 | GetFabricationConfiguration | Gets the fabrication configuration element in the document.
Public method | GetFabricationConfigurationInfo | Gets the information about the fabrication configuration of the project.
Public method | GetFabricationConnectorDomain | Gets the fabrication connector domain from its identifier.
Public method | GetFabricationConnectorGroup | Gets the fabrication connector group from its identifier.
Public method | GetFabricationConnectorName | Gets the fabrication connector name from its identifier.
Public method | GetFabricationConnectorShape | Gets the fabrication connector shape from its identifier.
Public method | GetInsulationSpecificationAbbreviation | Gets insulation specification abbreviation.
Public method | GetInsulationSpecificationGroup | Gets the insulation specification group from its identifier.
Public method | GetInsulationSpecificationName | Gets the insulation specification name from its identifier.
Public method | GetItemFolders | Gets a list of fabrication item folders in the fabrication item folder structure.
Public method | GetMaterialAbbreviation | Gets the abreviation of the material or the insulation or the double wall material.
Public method | GetMaterialByGUID | Gets the material identifier by its GUID.
Public method | GetMaterialGaugeByGUID | Gets the material gauge identifier by its GUID and material identifier.
Public method | GetMaterialGaugeGUID | Gets the material gauge GUID by its material/gauge identifiers.
Public method | GetMaterialGroup | Gets material group from its identifier.
Public method | GetMaterialGUID | Gets the material GUID by its identifier.
Public method | GetMaterialName | Gets material name from its identifier.
Public method | GetPartCustomDataName | Gets the custom data name from its identifier.
Public method | GetPartCustomDataType | Gets the custom data type from its identifier. See FabricationCustomDataType enumerator.
Public method | GetPartStatusDescription | Gets the status description from its identifier.
Public method | GetProfile | Return the profile of the loaded fabrication configuration. Return empty string for global profile.
Public method | GetService | Get the service based on the service identifier from the fabrication configuration in the current document.
Public method | GetServiceByGUID | Gets the service identifier by its GUID.
Public method | GetServiceGUID | Gets the service GUID by its identifier.
Public method | GetServiceTypeName | Gets the service type name.
Public method | GetSpecificationAbbreviation | Gets specification abbreviation.
Public method | GetSpecificationByGUID | Gets the specification identifier by its GUID.
Public method | GetSpecificationGroup | Gets the specification group from its identifier.
Public method | GetSpecificationGUID | Gets the specification GUID by its identifier.
Public method | GetSpecificationName | Gets the specification name from its identifier.
Public method | GetUpdatedStraightsFromValidateConnections | Get the set of element identifiers of fabrication part straights that were previously updated. If there were no straights were updated it will return an empty set of element identifiers.
Public method | HasValidConfiguration | Checks whether a valid fabrication configuration has been set for the project.
Public method | IsAncillaryKit | Gets whether the specified fabrication ancillary identifier is an ancillary kit or not.
Public method | LoadItemFiles | Loads the specified fabrication item files into the project.
Public method | LoadServices | Loads the specified fabrication services into the project.
Public method | LocateFabricationConnector | Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Public method | LocateInsulationSpecification | Gets the insulation specification by group and name.
Public method | LocateMaterial | Gets material by group and name.
Public method | LocateSpecification | Gets the specification identifier by group and name.
Public method | PostReviewableWarningsForBadConnections | Reviewable warnings are created for all entries contained in the connection validation information.
Public method | ReloadConfiguration | Reloads the fabrication configuration from its source fabrication configuration.
Public method | SetConfiguration(FabricationConfigurationInfo) | Set the fabrication configuration with global profile.
Public method | SetConfiguration(FabricationConfigurationInfo, String) | Set the fabrication configuration with specific profile.
Public method | SetServicesToLoad | Sets the services which are to be loaded or not next time reloadConfiguration is called. If a service is not included but is currently loaded then it will be unloaded then.
Public method | UnloadItemFiles | Unload the specified fabrication item files from the project.
Public method | UnloadServices | Unload the specified fabrication services from the project.
Public method | ValidateConnectionsForAllFabricationParts | Validates all fabrication part connections in the current project. Invalid connections found will be added to the connection validation information class. The validation checks for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Top
Remarks
The element provides information about the location of the fabrication database, its properties, and settings related to fabrication items.
See Also

Reference

Autodesk.Revit.DB Namespace