BuiltInFailuresLevelFailures Class

BuiltInFailures.LinkFailures Class

BuiltInFailuresLinkFailures Class

Failures about LinkFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresLinkFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LinkFailures
Public NotInheritable Class LinkFailures
public ref class LinkFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LinkFailures = class end

The BuiltInFailuresLinkFailures type exposes the following members.

Properties
Name | Description
CannotModifyLinkedFile | Shared Sites in the link ""%1!s!"" cannot be modified.
CannotOpenLinkedFileServerFound | Cannot open the linked model using Open and Unload because the plugin [name] provided by [vendor] experienced an error. For more information please contact [vendor].
CannotOpenLinkedFileServerNotFound | Cannot open the linked model using Open and Unload because the plugin [name] cannot be accessed. Please check plugin [name], which has server Id [serverId]
CannotPublishSharedCoordinatesToMirroredNonRevitLinks | Shared coordinates cannot be published to mirrored, non Revit, links.
CannotReloadFile | Can't reload file.
CannotUnlinkFile | Can't unlink file.
DataDictionaryDifferentInLink | Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.
DeleteLinkSymbolPrompt | All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.
LinkedFileOpenInOtherDoc | Linked file cannot be reloaded because it is loaded into another open document.
LinkInstanceNeedsReconcile | Instance of linked .rvt file needs Coordination Review
ModifiedLinkedFile | Shared Sites in the link have been modified, use move instance to reset the change.
ModifyingLinkedFile | Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.
MultipleLinks | Can't complete operation. Linked Files have the same name.
NoConstraintsToLinks1 | Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.
SourceFileDrivenByOtherTarget | Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.
WatchedLinkMoved | Monitored Link moved.
Top
See Also

Reference

Autodesk.Revit.DB Namespace