PaperSource Class

PaperSourceSet Class

A set that can contain any number of paper source objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPaperSourceSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PaperSourceSet : APIObject,
    IEnumerable
Public Class PaperSourceSet
    Inherits APIObject
    Implements IEnumerable
public ref class PaperSourceSet : public APIObject,
    IEnumerable
type PaperSourceSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The PaperSourceSet type exposes the following members.

Constructors
 | Name | Description
Public method | PaperSourceSet | Initializes a new instance of the PaperSourceSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace