MultipleValuesIndicationSettings Class

MultiReferenceAnnotation Class

Multi-reference annotations are annotations pointing to more than one reference, consisting of a dimension and associated tag.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBMultiReferenceAnnotation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MultiReferenceAnnotation : Element
Public Class MultiReferenceAnnotation
    Inherits Element
public ref class MultiReferenceAnnotation : public Element
type MultiReferenceAnnotation =
    class
        inherit Element
    end

The MultiReferenceAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | DimensionId | The child dimension owned by this multi-reference annotation.
Public property | TagId | The child IndependentTag owned by this multi-reference annotation.
Top
Methods
 | Name | Description
 | AreElementsValidForMultiReferenceAnnotation | The method validates if the input elements match the element category id for the MultiReferenceAnnotationType.
 | AreReferencesValidForLinearDimension | If the DimensionStyleType is Linear, validates that the references are valid for an aligned multi-reference annotation.
 | AreReferencesValidForLinearFixedDimension | If the DimensionStyleType is LinearFixed, validates that the references are valid for an aligned multi-reference annotation.
 | Create | Creates a new MultiReferenceAnnotation.
 | Is3DViewValidForDimension | If the DimensionStyle is LinearFixed, it cannot be created in a 3D View. If the DimensionStyle is Linear, it cannot be created in a 3D View if the view direction is perpendicular to the current work plane normal. Returns true if the ownerViewId is not a 3D view.
 | IsLinearFixedDimensionDirectionValid | If the DimensionStyleType is LinearFixed, this function verifies that the dimension line direction matches either the view's vertical or horizontal direction.
Top
Remarks
Multi-reference annotations can be used to label and dimension Rebar elements, and are labeled in the user interface as "Multi-rebar annotations". MultiReferenceAnnotation is the annotation object instance. This class includes a reference to the associated dimension and tag element.
See Also

Reference

Autodesk.Revit.DB Namespace