HasValueFilterRule Class

HermiteFace Class

A cubic hermite spline face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBHermiteFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HermiteFace : Face
Public Class HermiteFace
    Inherits Face
public ref class HermiteFace : public Face
type HermiteFace =
    class
        inherit Face
    end

The HermiteFace type exposes the following members.

Properties
 | Name | Description
Public property | MixedDerivs | Mixed derivatives of the surface.
Public property | Params | Parameters of the surface.
Public property | Points | Interpolation points of the surface.
Public property | Tangents | Tangents of the surface.
Top
Methods
 | Name | Description
Top
Remarks
Hermite faces are defined by cubic hermite spline surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.
Example
C#
VB
C++
F#
Copy
private void GetHermiteFaceInfo(Face face)
{
    HermiteFace hermiteFace = face as HermiteFace;
    if (null != hermiteFace)
    {
        IList<XYZ> points = hermiteFace.Points;
        IList<XYZ> derivs = hermiteFace.MixedDerivs;
        DoubleArray faceParams = hermiteFace.get_Params(0);
        IList<XYZ> tangents = hermiteFace.get_Tangents(0);
    }
}
Private Sub GetHermiteFaceInfo(face As Face)
    Dim hermiteFace As HermiteFace = TryCast(face, HermiteFace)
    If hermiteFace IsNot Nothing Then
        Dim points As IList(Of XYZ) = hermiteFace.Points
        Dim derivs As IList(Of XYZ) = hermiteFace.MixedDerivs
        Dim faceParams As DoubleArray = hermiteFace.Params(0)
        Dim tangents As IList(Of XYZ) = hermiteFace.Tangents(0)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace