NumberingSchemaTypesStructuralNumberingSchemas Class

NumberSystem Class

An annotation that consists of a series of numeric tags attached to and describing a host element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBNumberSystem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NumberSystem : Element
Public Class NumberSystem
    Inherits Element
public ref class NumberSystem : public Element
type NumberSystem =
    class
        inherit Element
    end

The NumberSystem type exposes the following members.

Properties
 | Name | Description
Public property | JustifyOffset | The offset to the justification curve.
Public property | JustifyOption | The number justify option of number system.
Public property | NumberDisplayRule | The display rule of the number system.
Public property | NumberedElementId | The LinkElementId of the numbered host element.
Public property | NumberOrientation | The number orientation of number system.
Public property | PlacementLevelId | The id of the base level of stairs on which the NumberSystem is placed.
Public property | ReferenceOffset | The offset to the reference curve.
Top
Methods
 | Name | Description
 | Create(Document, ElementId, LinkElementId, Reference) | Creates a new instance of a NumberSystem associated to a host element and a view.
 | Create(Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId) | Creates a new instance of a NumberSystem associated to a host element, a view, and a reference level of stairs if in a multistory stairs.
Public method | GetReferencePick | Gets the reference curve.
Public method | SetReferencePick | Sets the reference pick.
Top
Remarks
For a component-based stair, you can display tread/riser numbers for a run in plan, elevation, or section view. Sketch-based stair is not supported.
See Also

Reference

Autodesk.Revit.DB Namespace