MultiReferenceAnnotationType Class

MultiSegmentGrid Class

This element acts as a multi-segmented Grid. The individual grids associated to the MultiSegmentGrid behave as a single unit and all share the same text. They inherit their type (GridType) from the MultiSegmentGrid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBMultiSegmentGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MultiSegmentGrid : Element
Public Class MultiSegmentGrid
    Inherits Element
public ref class MultiSegmentGrid : public Element
type MultiSegmentGrid =
    class
        inherit Element
    end

The MultiSegmentGrid type exposes the following members.

Properties
 | Name | Description
Public property | Text | name shared by grids in this MultiSegmentGrid
Top
Methods
 | Name | Description
 | AreGridsInSameMultiSegmentGrid | Determine whether two Grids are members of the same GridChain.
 | Create | Create a MultiSegmentGrid element from the specified curve loop.
Public method | GetGridIds | Get the element ids of the Grids that make up this MultiSegmentGrid.
 | GetMultiSegementGridId | Retrieve the element id of the MultiSegmentGrid of which the specified Grid is a member.
 | IsValidCurveLoop | Identifies whether the specified curve loop is valid for creation of a MultiSegmentGrid.
 | IsValidSketchPlaneId | Identifies whether provided element id corresponds to a SketchPlane that is valid for GridChain creation.
Top
See Also

Reference

Autodesk.Revit.DB Namespace