BuiltInFailuresImportExportFailures Class

BuiltInFailures.ImportFailures Class

BuiltInFailuresImportFailures Class

Failures about ImportFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresImportFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ImportFailures
Public NotInheritable Class ImportFailures
public ref class ImportFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ImportFailures = class end

The BuiltInFailuresImportFailures type exposes the following members.

Properties
Name | Description
ATFContainedUnsupportedGeometricData | The original model contains unsupported geometric data.
ATFNonUniformScalingTransform | The imported geometry contains non-uniform scaling transformations which Revit does not support. Some objects may be displaced or distorted.
BadFaceFoundInDwg | One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.
CannotChangeImportSymbol | Can't change an imported or linked element's symbol type.
CannotExplodeElement | Can't explode the imported object.
CannotImportFile | Can't import file.
ElementRenamedOnImport | There were duplicate names between the active model and the imported element. To avoid duplicate names, the imported element has been renamed.
FailedToSetWorkplane | Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.
IFCCantUpdateLinkedFile | The cached version of this IFC file is already loaded into another document in this session, and can't be updated. To update the IFC file, please close all other documents containing the link, and then update.
IFCGenericImportWarning | The following problems were encountered in the IFC file: [Description]
IFCGenericRevitImportWarning | Revit had the following problems importing the IFC file: [Description]
IFCPartialSchemaSupport | IFC versions 4 and above are only partially supported by Open IFC. Consider using Link IFC instead.
ImportedModelIsEmpty | Imported model is empty.
ImportedModelWithDifferentLengthUnits | The imported model uses different length units, Revit will default to auto-detect.
ImportModelOutOfRange | The imported model is out of range.
ImportModelTooLarge | The imported model is too large.
ImportScaleTooLarge | This scale factor would make the imported object too large. Reverting to the previous scale factor.
ImportSymbolBaseLevelInvalid |
ImportTooFarAway | Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.
ImportTooManyElmentsToExplode | Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.
LevelRenamedOnImport | This level has been renamed from [SourceLevelName] to avoid duplication.
LostAcisObjectsOnImport | Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.
SomeObjectsNotExploded | Import contained some 3D data or points which can't be exploded.
TextNotImported | Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.
TooManyPickFaces | Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.
ViewDoesNotSupportCenterToCenter | The "Center to Center" option is not supported by this view because it is empty. "Origin to Internal Origin" has been used instead.
WorksetCreatedForLinkWarning | Newly created link types and instances were placed in new workset [workset name]
Top
See Also

Reference

Autodesk.Revit.DB Namespace