Settings Class

The settings object provides access to general components of the Autodesk Revit application, such as Categories.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Settings : APIObject
Public Class Settings
    Inherits APIObject
public ref class Settings : public APIObject
type Settings =
    class
        inherit APIObject
    end

The Settings type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property | TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
Top
Methods
 | Name | Description
Top
Example
C#
VB
C++
F#
Copy
// Get some of the settings information, including categories and FillPatterns
Settings settings = document.Settings;

// Format the prompt information string
String prompt = "Setting information: ";
prompt += "\nNumber of Categories: " + settings.Categories.Size;
FilteredElementCollector fillPatternCollector = new FilteredElementCollector(document);
prompt += "\nNumber of Fill Patterns: " + fillPatternCollector.OfClass(typeof(FillPatternElement)).Count();
FilteredElementCollector linePatternCollector = new FilteredElementCollector(document);
prompt += "\nNumber of Line Patterns: " + linePatternCollector.OfClass(typeof(LinePatternElement)).Count();

// Give the user some information
TaskDialog.Show("Revit",prompt);
' Get some of the settings information, including categories and FillPatterns
Dim settings As Settings = document.Settings

' Format the prompt information string
Dim prompt As [String] = "Setting information: "
prompt += vbLf & "Number of Categories: " + settings.Categories.Size
Dim fillPatternCollector As New FilteredElementCollector(document)
prompt += vbLf & "Number of Fill Patterns: " & fillPatternCollector.OfClass(GetType(FillPatternElement)).Count()
Dim linePatternCollector As New FilteredElementCollector(document)
prompt += vbLf & "Number of Line Patterns: " & linePatternCollector.OfClass(GetType(LinePatternElement)).Count()

' Give the user some information
TaskDialog.Show("Revit", prompt)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace