ExternalResourceServerExtensions Class

ExternalResourceServerUtils Class

Contains utilities related to external resource server.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceServerUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExternalResourceServerUtils
Public NotInheritable Class ExternalResourceServerUtils
public ref class ExternalResourceServerUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExternalResourceServerUtils = class end

The ExternalResourceServerUtils type exposes the following members.

Methods
Name | Description
IsValidShortName | Checks whether the name is a valid short name for the external resource server.
ServerSupportsAssemblyCodeData | Checks that the server referenced by the given ExternalResourceReference supports AssemblyCodeData.
ServerSupportsCADLinks | Checks that the server referenced by the given ExternalResourceReference supports CAD links.
ServerSupportsIFCLinks | Checks that the server referenced by the given ExternalResourceReference supports IFC links.
ServerSupportsKeynotes | Checks that the server referenced by the given ExternalResourceReference supports KeynoteTable data.
ServerSupportsRevitLinks | Checks that the server referenced by the given ExternalResourceReference supports Revit links.
Top
See Also

Reference

Autodesk.Revit.DB Namespace