ElementPhaseStatusFilter Class

ElementQuickFilter Class

A base class for a type of filter that operates on element records.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementQuickFilter : ElementFilter
Public Class ElementQuickFilter
    Inherits ElementFilter
public ref class ElementQuickFilter : public ElementFilter
type ElementQuickFilter =
    class
        inherit ElementFilter
    end

The ElementQuickFilter type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also

Reference

Autodesk.Revit.DB Namespace