Document Class

Document.Phases Property

DocumentPhases Property

Retrieves all of the phases in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhaseArray Phases { get; }
Public ReadOnly Property Phases As PhaseArray
    Get
public:
property PhaseArray^ Phases {
    PhaseArray^ get ();
}
member Phases : PhaseArray with get

Property Value

PhaseArray
Remarks

The phases are returned in order from earliest phase to latest phase.

When Revit is running with UI activated, the default created phase for newly created elements is inherited from the phase of the currently active view.

When Revit is running without its UI, such as when Revit runs on Autodesk Forge Design Automation API for Revit, the default phase for newly created elements is the latest phase in the document.

Example
C#
VB
C++
F#
Copy
void Getinfo_Phase(Document doc)
{
    // Get the phase array which contains all the phases.
    PhaseArray phases = doc.Phases;
    // Format the prompt string which identifies all supported phases in the current document.
    String prompt = null;
    if (0 != phases.Size)
    {
        prompt = "All the phases in current document list as follow:";
        foreach (Phase ii in phases)
        {
            prompt += "\n\t" + ii.Name;
        }
    }
    else
    {
        prompt = "There are no phases in current document.";
    }
    // Give the user the information.
    TaskDialog.Show("Revit",prompt);
}
Private Sub Getinfo_Phase(doc As Document)
    ' Get the phase array which contains all the phases.
    Dim phases As PhaseArray = doc.Phases
    ' Format the prompt string which identifies all supported phases in the current document.
    Dim prompt As [String] = Nothing
    If 0 <> phases.Size Then
        prompt = "All the phases in current document list as follow:"
        For Each ii As Phase In phases
            prompt += vbLf & vbTab + ii.Name
        Next
    Else
        prompt = "There are no phases in current document."
    End If
    ' Give the user the information.
    TaskDialog.Show("Revit", prompt)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference