ViewNavigationToolSettings Class

ViewNode Class

A render node that represents a view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBViewNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewNode : RenderNode
Public Class ViewNode
    Inherits RenderNode
public ref class ViewNode : public RenderNode
type ViewNode =
    class
        inherit RenderNode
    end

The ViewNode type exposes the following members.

Properties
 | Name | Description
Public property | LevelOfDetail | The level of detail the view is going to be rendered at.
Public property | ViewId | The Id of the view element.
Top
Methods
 | Name | Description
Public method | GetCameraInfo | Information about the observation point (the camera) of the view.
Top
Remarks
See also: OnViewBegin(ViewNode).
See Also

Reference

Autodesk.Revit.DB Namespace