Toposolid Class

Toposolid Methods

The Toposolid type exposes the following members.

Methods
 | Name | Description
Public method | CanBeExcavatedBy | Checks if the given element can be used to excavate the toposolid.
 | Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IListXYZ, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IListCurveLoop, IListXYZ, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | CreateFromTopographySurface | Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.
Public method | CreateSubDivision | Create a toposolid subdivision element with the current toposolid as its host.
Public method | ExcavateBy | Excavates the toposolid by a given element.
Public method | GetIntersectingElementData | Gets intersection data of all intersecting elements.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Toposolid.
Public method | GetSubDivisionIds | Get all element ids of toposolid subdivisions with the current toposolid as its host.
 | IsSmoothedSurfaceEnabled | Get smoothed surface setting of Toposolid.
Public method | RemoveExcavationBy | Remove the excavation between the given element and the toposolid.
 | SetSmoothedSurface | Set smoothed surface setting of Toposolid.
Public method | Simplify | Simplifies the toposolid by reducing the number of inner vertices to the given percentage.
Public method | Split | Split the toposolid by the given curve loops.
Top
See Also

Reference