Panel Class

This object represents a curtain panel.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBFamilyInstance
Autodesk.Revit.DBPanel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Panel : FamilyInstance
Public Class Panel
    Inherits FamilyInstance
public ref class Panel : public FamilyInstance
type Panel =
    class
        inherit FamilyInstance
    end

The Panel type exposes the following members.

Properties
 | Name | Description
Public property | Lockable | This property is used to know whether a panel can be locked.
Public property | PanelType | The Panel style of this Panel.
Public property | Transform | This property is used to find the transform of a curtain panel within project.
Top
Methods
 | Name | Description
Public method | FindHostPanel | Finds the id of the host panel (i.e., wall) associated with this panel. If a host panel is present, then it is displayed instead of the curtain panel.
Public method | GetRefGridLines | This method is used to get the reference gridlines.
Top
See Also

Reference

Autodesk.Revit.DB Namespace