FabricationConfigurationInfo Class

FabricationConnectorInfo Class

Fabrication connector information.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationConnectorInfo : IDisposable
Public Class FabricationConnectorInfo
    Implements IDisposable
public ref class FabricationConnectorInfo : IDisposable
type FabricationConnectorInfo =
    class
        interface IDisposable
    end

The FabricationConnectorInfo type exposes the following members.

Properties
 | Name | Description
Public property | BodyConnectorId | Fabrication body connector Id.
Public property | DoubleWallConnectorId | Fabrication double wall connector Id.
Public property | FabricationIndex | The index of the connector shown within the fabrication software.
Public property | IsBodyConnectorLocked | Fabrication body connector lock.
Public property | IsDoubleWallConnectorLocked | Fabrication double wall connector lock.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationConnectorInfo
Public method | HasDoubleWallConnector | Checks if there are any double wall connectors fabricated.
Public method | IsValid | Checks if the connector has fabrication parameters associated with it that can be set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace