MEPConnectorInfo Class

MEPCurve Class

A curve object for duct or pipe blend elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBMEPCurve
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPCurve : HostObject
Public Class MEPCurve
    Inherits HostObject
public ref class MEPCurve : public HostObject
type MEPCurve =
    class
        inherit HostObject
    end

The MEPCurve type exposes the following members.

Properties
 | Name | Description
Public property | ConnectorManager | The connector manager of this MEP curve.
Public property | Diameter | The diameter of the MEP curve.
Public property | Height | The height of the MEP curve.
Public property | LevelOffset | The offset of the MEP curve.
Public property | MEPSystem | The system of the MEP curve.
Public property | ReferenceLevel | The reference level of the MEP curve.
Public property | Width | The width of the MEP curve.
Top
Methods
 | Name | Description
Top
Remarks
The curve object is only available in the Autodesk Revit MEP product.
See Also

Reference

Autodesk.Revit.DB Namespace