ControlledApplication Events

The ControlledApplication type exposes the following members.

Events
 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
 | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
 | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
 | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentReloadedLatest | Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.
Public event | DocumentReloadingLatest | Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
 | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | ElementTypeDuplicated | Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.
Public event | ElementTypeDuplicating | Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.
 | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FamilyLoadedIntoDocument | Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.
Public event | FamilyLoadingIntoDocument | Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | LinkedResourceOpened | Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.
Public event | LinkedResourceOpening | Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
 | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
 | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Public event | WorksharedOperationProgressChanged | Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.
Top
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace