ExportLayerTableIterator Class

ExportLinetypeInfo Class

A value used to represent the info stored in the ExportLinetypeTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLinetypeInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLinetypeInfo : IDisposable
Public Class ExportLinetypeInfo
    Implements IDisposable
public ref class ExportLinetypeInfo : IDisposable
type ExportLinetypeInfo =
    class
        interface IDisposable
    end

The ExportLinetypeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLinetypeInfo | Constructs a new default ExportLinetypeInfo.
Public method | ExportLinetypeInfo(ExportLinetypeInfo) | Constructs a new copy of the input ExportLinetypeInfo object.
Public method | ExportLinetypeInfo(String) | Constructs a new ExportLinetypeInfo using the destination linetype name as input.
Top
Properties
 | Name | Description
Public property | DestinationLinetypeName | The destination linetype name (the name of the linetype in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLinetypeInfo
Top
See Also

Reference

Autodesk.Revit.DB Namespace