ComponentRepeaterIterator Class

ComponentRepeaterSlot Class

Represents a slot that holds one repeated component in a component repeater.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBComponentRepeaterSlot

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ComponentRepeaterSlot : Element
Public Class ComponentRepeaterSlot
    Inherits Element
public ref class ComponentRepeaterSlot : public Element
type ComponentRepeaterSlot =
    class
        inherit Element
    end

The ComponentRepeaterSlot type exposes the following members.

Properties
 | Name | Description
Public property | FamilyType | The id of the family type of the component in the slot, or invalid id if the slot is empty.
Public property | IsDefault | A flag indicating whether the slot currently holds an instance of the default family type of the component repeater.
Public property | IsEmpty | A flag indicating whether the slot is currently empty.
Top
Methods
 | Name | Description
Public method | IsTypeValidForSlot | Determines whether instance of given family type can be used in the component repeater slot.
Public method | MakeDefault | Populates the slot with an instance of the default family type of the component repeater.
Public method | MakeEmpty | Makes the slot empty by removing the instance currently held by the slot.
Top
Remarks

Each slot can be in one of the following states:

  • Empty.
  • Occupied by an instance of the default family of the repeater that contains the slot.
  • Occupied by an instance of another family.
Initially, every occupied slot holds an instance of the default family of the repeater, based on the original element that was repeated.

See Also

Reference

Autodesk.Revit.DB Namespace