ParameterElement Class

ParameterFilterElement Class

Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFilterElement
Autodesk.Revit.DBParameterFilterElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterFilterElement : FilterElement
Public Class ParameterFilterElement
    Inherits FilterElement
public ref class ParameterFilterElement : public FilterElement
type ParameterFilterElement =
    class
        inherit FilterElement
    end

The ParameterFilterElement type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | AllRuleParametersApplicable(ElementFilter) | Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.
 | AllRuleParametersApplicable(Document, ICollectionElementId, ElementFilter) | Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.
Public method | ClearRules | Removes all rules from this filter.
 | Create(Document, String, ICollectionElementId) | Creates a new ParameterFilterElement in the given document.
 | Create(Document, String, ICollectionElementId, ElementFilter) | Creates a new ParameterFilterElement in the given document.
Public method | ElementFilterIsAcceptableForParameterFilterElement(ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a ParameterFilterElement (i.e., for view filtering).
 | ElementFilterIsAcceptableForParameterFilterElement(Document, ISetElementId, ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a given list of categories (i.e., for view filtering).
Public method | GetCategories | Gets the categories admitted by this filter.
Public method | GetElementFilter | Returns an ElementFilter representing the combination of rules used by this filter.
Public method | GetElementFilterParameters | Retrieves a list of the parameters associated with each rule in the filter.
Public method | GetElementFilterParametersForCategory | Retrieves a list of the parameters associated with all rules in the filter that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.
Public method | SetCategories | Sets the categories admitted by this filter.
Public method | SetElementFilter | Sets the rules that must be satisfied for a given element to pass this filter.
Top
Example
C#
VB
C++
F#
Copy
/// <summary>
/// Create an ElementFilter representing a conjunction ("ANDing together") of FilterRules.
/// </summary>
/// <param name="filterRules">A list of FilterRules</param>
/// <returns>The ElementFilter.</returns>
private static ElementFilter CreateElementFilterFromFilterRules(IList<FilterRule> filterRules)
{
   // We use a LogicalAndFilter containing one ElementParameterFilter
   // for each FilterRule. We could alternatively create a single
   // ElementParameterFilter containing the entire list of FilterRules.
   IList<ElementFilter> elemFilters = new List<ElementFilter>();
   foreach (FilterRule filterRule in filterRules)
   {
      ElementParameterFilter elemParamFilter = new ElementParameterFilter(filterRule);
      elemFilters.Add(elemParamFilter);
   }
   LogicalAndFilter elemFilter = new LogicalAndFilter(elemFilters);

   return elemFilter;
}

/// <summary>
/// Creates a new view filter matching multiple criteria.
/// </summary>
/// <param name="doc"></param>
/// <param name="view"></param>
public static void CreateViewFilter(Document doc, View view)
  {
      List<ElementId> categories = new List<ElementId>();
      categories.Add(new ElementId(BuiltInCategory.OST_Walls));
      List<FilterRule> filterRules = new List<FilterRule>();

      using (Transaction t = new Transaction(doc, "Add view filter"))
      {
          t.Start();

          // Create filter element assocated to the input categories
          ParameterFilterElement parameterFilterElement = ParameterFilterElement.Create(doc, "Example view filter", categories);

          // Criterion 1 - wall type Function is "Exterior"
          ElementId exteriorParamId = new ElementId(BuiltInParameter.FUNCTION_PARAM);
          filterRules.Add(ParameterFilterRuleFactory.CreateEqualsRule(exteriorParamId, (int)WallFunction.Exterior));

          // Criterion 2 - wall height > some number
          ElementId lengthId = new ElementId(BuiltInParameter.CURVE_ELEM_LENGTH);
          filterRules.Add(ParameterFilterRuleFactory.CreateGreaterOrEqualRule(lengthId, 28.0, 0.0001));

          // Criterion 3 - custom shared parameter value matches string pattern
          // Get the id for the shared parameter - the ElementId is not hardcoded, so we need to get an instance of this type to find it
          Guid spGuid = new Guid("96b00b61-7f5a-4f36-a828-5cd07890a02a");
          FilteredElementCollector collector = new FilteredElementCollector(doc);
          collector.OfClass(typeof(Wall));
          Wall wall = collector.FirstElement() as Wall;

          if (wall != null)
          {
              Parameter sharedParam = wall.get_Parameter(spGuid);
              ElementId sharedParamId = sharedParam.Id;

              filterRules.Add(ParameterFilterRuleFactory.CreateBeginsWithRule(sharedParamId, "15."));
          }

          ElementFilter elemFilter = CreateElementFilterFromFilterRules(filterRules);
          parameterFilterElement.SetElementFilter(elemFilter);

          // Apply filter to view
          view.AddFilter(parameterFilterElement.Id);
          view.SetFilterVisibility(parameterFilterElement.Id, false);
          t.Commit();
      }
  }
Public Shared Sub CreateViewFilter(doc As Document, view As View)
      Dim categories As New List(Of ElementId)()
      categories.Add(New ElementId(BuiltInCategory.OST_Walls))
      Dim filterRules As New List(Of FilterRule)()

      Using t As New Transaction(doc, "Add view filter")
          t.Start()

          ' Create filter element assocated to the input categories
          Dim parameterFilterElement__1 As ParameterFilterElement = ParameterFilterElement.Create(doc, "Example view filter", categories)

          ' Criterion 1 - wall type Function is "Exterior"
          Dim exteriorParamId As New ElementId(BuiltInParameter.FUNCTION_PARAM)
          filterRules.Add(ParameterFilterRuleFactory.CreateEqualsRule(exteriorParamId, CInt(WallFunction.Exterior)))

          ' Criterion 2 - wall height > some number
          Dim lengthId As New ElementId(BuiltInParameter.CURVE_ELEM_LENGTH)
          filterRules.Add(ParameterFilterRuleFactory.CreateGreaterOrEqualRule(lengthId, 28.0, 0.0001))

          ' Criterion 3 - custom shared parameter value matches string pattern
          ' Get the id for the shared parameter - the ElementId is not hardcoded, so we need to get an instance of this type to find it
          Dim spGuid As New Guid("96b00b61-7f5a-4f36-a828-5cd07890a02a")
          Dim collector As New FilteredElementCollector(doc)
          collector.OfClass(GetType(Wall))
          Dim wall As Wall = TryCast(collector.FirstElement(), Wall)

          If wall IsNot Nothing Then
              Dim sharedParam As Parameter = wall.Parameter(spGuid)
              Dim sharedParamId As ElementId = sharedParam.Id

              filterRules.Add(ParameterFilterRuleFactory.CreateBeginsWithRule(sharedParamId, "15."))
          End If

      ' We use a LogicalAndFilter containing one ElementParameterFilter
      ' for each FilterRule. We could alternatively create a single
      ' ElementParameterFilter containing the entire list of FilterRules.
      Dim elemFilters As New List(Of ElementFilter)()
      For Each filterRule As FilterRule In filterRules
         Dim elemParamFilter As New ElementParameterFilter(filterRule)
         elemFilters.Add(elemParamFilter)
      Next
      Dim elemFilter As New LogicalAndFilter(elemFilters)
      parameterFilterElement__1.SetElementFilter(elemFilter)

      ' Apply filter to view
      view.AddFilter(parameterFilterElement__1.Id)
          view.SetFilterVisibility(parameterFilterElement__1.Id, False)
          t.Commit()
      End Using
  End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace