BuiltInFailuresExternalResourceReferenceFailures Class

BuiltInFailures.ExtrusionFailures Class

BuiltInFailuresExtrusionFailures Class

Failures about Extrusions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresExtrusionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExtrusionFailures
Public NotInheritable Class ExtrusionFailures
public ref class ExtrusionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExtrusionFailures = class end

The BuiltInFailuresExtrusionFailures type exposes the following members.

Properties
Name | Description
CannotDrawExtrusions | Can't make Extrusion.
CannotDrawExtrusionsError | Can't make Extrusion.
ExtrusionTooThin | Extrusion is too thin.
InvalidExtrusionCurveloop | Base sketch for extrusion is invalid.
InvalidExtrusionCurveloopError | Base sketch for extrusion is invalid.
Top
See Also

Reference

Autodesk.Revit.DB Namespace