BuiltInFailuresRefPlaneFailures Class

BuiltInFailures.RegenFailures Class

BuiltInFailuresRegenFailures Class

Failures about RegenFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRegenFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RegenFailures
Public NotInheritable Class RegenFailures
public ref class RegenFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RegenFailures = class end

The BuiltInFailuresRegenFailures type exposes the following members.

Properties
Name | Description
CannotRegenFamily | Can't regenerate Family [Family Name]. Edit Family to modify it.
CircularDependency | There is a circular chain of references among the highlighted elements.
CircularDependencyAssocProp | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyAssocPropError | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyConstraint | Highlighted constraints cause a circular chain of references.
CircularDependencyConstraintError | Highlighted constraints cause a circular chain of references.
CircularDependencyError | There is a circular chain of references among the highlighted elements.
CircularDependencyResolved | There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.
CircularDependencySketch | Constraints in sketches of highlighted elements cause a circular chain of references.
CircularDependencySketchError | There is a circular chain of references among the highlighted elements.
CircularDependencyUncut | There is a circular chain of references among the highlighted elements.
CircularDependencyUncutError | There is a circular chain of references among the highlighted elements.
CircularDependencyWall | There is a circular chain of references among the highlighted elements.
CircularDependencyWallError | There is a circular chain of references among the highlighted elements.
ForceRegenSketch | Regen Sketch
GeomStepFailed | Can't rebuild geometry.
GeomStepFailedError | Can't rebuild geometry.
RegenElements | Regenerating elements.
RegeneratedElements | Elements regenerated in pass [Regen Index]
RegenFailure | Regeneration Failure.
UserCancelled | Operation is cancelled by the user.
UserCancelledError | Operation is cancelled by the user.
Top
See Also

Reference

Autodesk.Revit.DB Namespace