RevitLinkType Class
UpdateFromIFC Overload

Revolution Class

A revolution solid or void form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBRevolution

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Revolution : GenericForm
Public Class Revolution
    Inherits GenericForm
public ref class Revolution : public GenericForm
type Revolution =
    class
        inherit GenericForm
    end

The Revolution type exposes the following members.

Properties
 | Name | Description
Public property | Axis | Returns the Axis of the Revolution.
Public property | EndAngle | The end angle of the revolution relative to the sketch plane.
Public property | Sketch | Returns the Sketch of the Revolution.
Public property | StartAngle | The start angle of the revolution relative to the sketch plane.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace