IPerformanceAdviserRule Interface

IPhotoRenderContext Interface

An interface that is used in custom export to render 3D views of a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPhotoRenderContext : IExportContext
Public Interface IPhotoRenderContext
    Inherits IExportContext
public interface class IPhotoRenderContext : IExportContext
type IPhotoRenderContext =
    interface
        interface IExportContext
    end

The IPhotoRenderContext type exposes the following members.

Methods
 | Name | Description
Top
Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The interface methods are then called at times of rendering entities that are currently visible in the view being rendered.

With this type of export context used to perform a custom export, Revit will traverse the model and output the model's geometry as if processing the Render command invoked via the UI. It means that only such elements that have actual geometry and are suitable to appear in a rendered view will be processed and output.

See Also

Reference

Autodesk.Revit.DB Namespace