ConnectorSetIterator Class

ConnectorType Enumeration

An enumerated type listing all connector types for a connection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectorType
Public Enumeration ConnectorType
public enum class ConnectorType
type ConnectorType
Members
Member name | Value | Description
Invalid | 0 | Invalid connection type
End | 1 | End connection type
Curve | 2 | Curve connection type
Logical | 4 | Logical connection type
Reference | 8 | Reference connection type
Surface | 16 | Surface connection type
EndSurface | 17 | End or Surface connection type
Physical | 19 | Physical connection type
NonEnd | 30 | Not end connection type
MasterSurface | 32 | This value is deprecated and will be removed in a future version of Revit. Please use MainSurface instead.
MainSurface | 32 | Main surface connection type
Family | 49 | Family connection type
NodeReference | 64 | Reference to the layout node type
BlankEnd | 128 | Blank End type
AnyEnd | 129 | Any end connection type
Super | 256 | Connection between a sub-system and a super-system, such as a connection between supply and return sub-systems and a main hydronic piping system or an air system.
AllModes | 16,777,215 | All connection modes
See Also

Reference

Autodesk.Revit.DB Namespace