PrintManager Class

The PrintManager object is used to configure the global print settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPrintManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PrintManager : APIObject
Public Class PrintManager
    Inherits APIObject
public ref class PrintManager : public APIObject
type PrintManager =
    class
        inherit APIObject
    end

The PrintManager type exposes the following members.

Properties
 | Name | Description
Public property | Collate | Indicates whether to collate of the current print.
Public property | CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
Public property | CopyNumber | The copy number.
Public property | IsVirtual | The virtual type in Autodesk Revit.
Public property | PaperSizes | Get all print sizes of current printer.
Public property | PaperSources | Get all print sources of current printer.
Public property | PrinterName | The name of the current printer.
Public property | PrintOrderReverse | Indicates whether to reverse the print order of the current print.
Public property | PrintRange | The print range.
Public property | PrintSetup | The PrintSetup which manages the print settings of current document.
Public property | PrintToFile | Indicates whether to print to file.
Public property | PrintToFileName | The file name when printing to file.
Public property | ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.
Top
Methods
 | Name | Description
Public method | Apply | Apply the local print settings to global for all documents.
Public method | SelectNewPrintDriver | Select a new printer.
Public method | SubmitPrint | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.
Top
Remarks
Global print settings include PrintToFile, CombinedFile, PrintToFileName, PrintRange, CopyNumber, PrintOrderReverse, Collate. Once PrintManager is acquired from a document, changes of its global print setting properties are not automatically applied toward the global print setting. Should the local setting be used, the user needs to call the Apply method. If the user calls SubmitPrint methods, not only that printing will use the current state of properties of the (local) print manager, but the setting will also be applied to the global settings.
Example
C#
VB
C++
F#
Copy
private void CreateAndPrintViewSet(Document document, ViewSet viewSet)
{
    PrintManager printManager = document.PrintManager;
    printManager.PrintRange = PrintRange.Select;
    ViewSheetSetting viewSheetSetting = printManager.ViewSheetSetting;
    viewSheetSetting.CurrentViewSheetSet.Views = viewSet;
    viewSheetSetting.SaveAs("MyViewSet");
    printManager.CombinedFile = true;
    printManager.SubmitPrint();
}
Private Sub CreateAndPrintViewSet(document As Document, viewSet As ViewSet)
    Dim printManager As PrintManager = document.PrintManager
    printManager.PrintRange = PrintRange.[Select]
    Dim viewSheetSetting As ViewSheetSetting = printManager.ViewSheetSetting
    viewSheetSetting.CurrentViewSheetSet.Views = viewSet
    viewSheetSetting.SaveAs("MyViewSet")
    printManager.CombinedFile = True
    printManager.SubmitPrint()
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace