PointLocationOnCurve Class

PointNode Class

An output node that represents a 3D point.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBModelCurveNode
Autodesk.Revit.DBPointNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointNode : ModelCurveNode
Public Class PointNode
    Inherits ModelCurveNode
public ref class PointNode : public ModelCurveNode
type PointNode =
    class
        inherit ModelCurveNode
    end

The PointNode type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetPoint | Returns the point object corresponding to the node.
Top
Remarks
See also: OnPoint(PointNode).
See Also

Reference

Autodesk.Revit.DB Namespace