IntersectionResult Class

IntersectionResultArray Class

An array that can contain any type of object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBIntersectionResultArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IntersectionResultArray : APIObject,
    IEnumerable
Public Class IntersectionResultArray
    Inherits APIObject
    Implements IEnumerable
public ref class IntersectionResultArray : public APIObject,
    IEnumerable
type IntersectionResultArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The IntersectionResultArray type exposes the following members.

Constructors
 | Name | Description
Public method | IntersectionResultArray | Initializes a new instance of the IntersectionResultArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace