BuiltInFailuresUniqueElementFailures Class

BuiltInFailures.ViewFailures Class

BuiltInFailuresViewFailures Class

Failures about ViewFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresViewFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ViewFailures
Public NotInheritable Class ViewFailures
public ref class ViewFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ViewFailures = class end

The BuiltInFailuresViewFailures type exposes the following members.

Properties
Name | Description
BadViewDirectionSetting | Plan view DBViewType has invalid view direction parameter.
CanNotDeleteLastOpenView | Deleting of all open views in a project is not allowed.
CannotPasteViewReferences | Cannot paste view references into the view they reference or into unrelated views
CannotToggleToPerspective | Cannot toggle to perspective view because the view contains annotations.
DetailNumberDuplicate | Detail Number is already in use. Enter a unique number.
DetailNumberEmpty | Detail Number is empty
InitialViewDeleted | The starting view for the project has been deleted.
InsertColumnViewError | Column cannot be placed in Elevation or Section view
InsertColumnViewFailure | Column cannot be placed in Elevation or Section view
InsertComponentViewError | This type of Component cannot be placed in Elevation or Section view
InsertComponentViewFailure | This type of Component cannot be placed in Elevation or Section view
InvalidDBviewScopeBox | The scope box and view must have parallel vertical axes.
NoTargetsForDependentViewPropagation | There are no valid views. Only views without dependents can be used.
NothingToApplyError | Start and end elevations are the same, nothing to Apply.
NothingToApplyWarning | Start and end elevations are the same, nothing to Apply.
ReloadLatestDeletedLastOpenView | The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.
TurnCropRegionOffRemovesViewBreaks | Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
ViewPublishFailed | The following views could not be published.
ZeroLengthViewBreaksRemoved | Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
ZeroLengthViewRegionsRemoved | Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.
Top
See Also

Reference

Autodesk.Revit.DB Namespace