BRepBuilderEdgeGeometry Class

BRepBuilderGeometryId Class

This class is used by the BRepBuilder class to identify objects it creates (faces, edges, etc.).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBRepBuilderGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BRepBuilderGeometryId : IDisposable
Public Class BRepBuilderGeometryId
    Implements IDisposable
public ref class BRepBuilderGeometryId : IDisposable
type BRepBuilderGeometryId =
    class
        interface IDisposable
    end

The BRepBuilderGeometryId type exposes the following members.

Constructors
 | Name | Description
Public method | BRepBuilderGeometryId | Copy constructor
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BRepBuilderGeometryId
 | InvalidGeometryId | Returns an invalid BRepBuilderGeometryId, used as a return value to indicate an error.
Top
Remarks
The user should use these ids to organize the calls to BRepBuilder methods (e.g., addLoop() takes a face id as input, referring to a face that was previously added by a call to AddFace()). The ids are only valid while the BRepBuilder is in use.
See Also

Reference

Autodesk.Revit.DB Namespace