PlanCircuitSet Class

PlanCircuitSetIterator Class

An iterator to a set of plan circuit objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPlanCircuitSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PlanCircuitSetIterator : APIObject,
    IEnumerator
Public MustInherit Class PlanCircuitSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class PlanCircuitSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type PlanCircuitSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The PlanCircuitSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | PlanCircuitSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Top
Methods
 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace