DefaultDivideSettings Class

Provides access to project-wide divide settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDefaultDivideSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DefaultDivideSettings : Element
Public Class DefaultDivideSettings
    Inherits Element
public ref class DefaultDivideSettings : public Element
type DefaultDivideSettings =
    class
        inherit Element
    end

The DefaultDivideSettings type exposes the following members.

Properties
 | Name | Description
Public property | PathDistance | A default Divided Path distance for a fixed, minimum, or maximum distance layout.
Public property | PathLayout | A default Divided Path layout.
Public property | PathMeasurementType | A default Divided Path measurement type for distance layouts.
Public property | PathNumber | A default Divided Path number for a fixed number layout.
Top
Methods
 | Name | Description
 | GetDefaultDivideSettings | Obtains the DefaultDivideSettings object for the specified document.
Public method | GetSurfaceDistance | Gets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.
Public method | GetSurfaceLayout | Gets the default Divided Surface layout for U or V gridlines.
Public method | GetSurfaceNumber | Gets the default Divided Surface number for a fixed number layout for U or V gridlines.
Public method | SetSurfaceDistance | Sets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.
Public method | SetSurfaceLayout | Sets the default Divided Surface layout for U or V gridlines.
Public method | SetSurfaceNumber | Sets the default Divided Surface number for a fixed number layout for U or V gridlines.
Top
See Also

Reference

Autodesk.Revit.DB Namespace