TriangulationInterfaceForTriangulatedShellComponent Class

TriangulationInterfaceForTriangulatedSolidOrShell Class

This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedSolidOrShell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTriangulationInterface
Autodesk.Revit.DBTriangulationInterfaceForTriangulatedSolidOrShell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TriangulationInterfaceForTriangulatedSolidOrShell : TriangulationInterface
Public Class TriangulationInterfaceForTriangulatedSolidOrShell
    Inherits TriangulationInterface
public ref class TriangulationInterfaceForTriangulatedSolidOrShell : public TriangulationInterface
type TriangulationInterfaceForTriangulatedSolidOrShell =
    class
        inherit TriangulationInterface
    end

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Constructors
 | Name | Description
Public method | TriangulationInterfaceForTriangulatedSolidOrShell | Construct an interface object for a TriangulatedSolidOrShell.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
The vertex and triangle indices used by this class treat the triangulated solid or shell as if all the vertices and triangles of the different shell components were collected into single sets of vertices and triangles, respectively. For example, if a solid has two shell components and the first has ten vertices while the second has five vertices, vertexIndex 6 refers to vertex[6] of the first shell component, and vertexIndex 12 refers to vertex[2] of the second shell component. You can use the class TriangulationInterfaceForTriangulatedShellComponent to get a faceting of an individual shell component.
See Also

Reference

Autodesk.Revit.DB Namespace