ExternalDefinition Class

The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDefinition
Autodesk.Revit.DBExternalDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalDefinition : Definition,
    IDisposable
Public Class ExternalDefinition
    Inherits Definition
    Implements IDisposable
public ref class ExternalDefinition : public Definition,
    IDisposable
type ExternalDefinition =
    class
        inherit Definition
        interface IDisposable
    end

The ExternalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Description | The description of the parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | HideWhenNoValue | Indicates whether this parameter should be hidden from the properties palette when it has no value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The user visible name for the parameter. (Overrides DefinitionName)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | UserModifiable | Indicates whether the parameter can be modified by the user interface.
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalDefinition
Public method | GetGroupTypeId | Returns the identifier of the parameter definition's parameter group. (Overrides DefinitionGetGroupTypeId)
Top
Remarks

The ExternalDefinition object can be created by a definition Group object from a shared parameters file. External parameter definition must belong to a Group which is nothing more than a collection of shared parameter definitions. The following process should be followed to add a parameter to an element: Open the shared parameters file, via the Application.OpenSharedParameterFile() method. Access an existing or create a new group, via the DefinitionFile.Groups property. Access an existing or create a new external parameter definition, via the DefinitionGroup.Definitions property. Create a new Binding object with the categories to which the parameter will be bound using an InstanceBinding or a TypeBinding object. Finally add the binding and definition to the document using the Document.ParameterBindings object.

Shared parameters added to elements are typically visible to interactive users. To add data to elements that is never visible to interactive users, use Extensible Storage to construct and populate the needed structured data.

Example
C#
VB
C++
F#
Copy
private void ReadEditExternalParam(DefinitionFile file)
{
    // get ExternalDefinition from shared parameter file
    DefinitionGroups myGroups = file.Groups;
    DefinitionGroup myGroup = myGroups.get_Item("MyGroup");
    if (myGroup != null)
    {
         ExternalDefinition myExtDef = myGroup.Definitions.get_Item("MyParam") as ExternalDefinition;
         if (myExtDef != null)
         {
             DefinitionGroup newGroup = myGroups.get_Item("AnotherGroup");
             if (newGroup != null)
             {
                 // change the OwnerGroup of the ExternalDefinition
                 myExtDef.OwnerGroup = newGroup;
             }
         }
    }
}
Private Sub ReadEditExternalParam(file As DefinitionFile)
   ' get ExternalDefinition from shared parameter file
   Dim myGroups As DefinitionGroups = file.Groups
   Dim myGroup As DefinitionGroup = myGroups.Item("MyGroup")
   If myGroup IsNot Nothing Then
      Dim myExtDef As ExternalDefinition = TryCast(myGroup.Definitions.Item("MyParam"), ExternalDefinition)
      If myExtDef IsNot Nothing Then
         Dim newGroup As DefinitionGroup = myGroups.Item("AnotherGroup")
         If newGroup IsNot Nothing Then
            ' change the OwnerGroup of the ExternalDefinition
            myExtDef.OwnerGroup = newGroup
         End If
      End If
   End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace