ExportPatternTable Class

ExportPatternTableIterator Class

An iterator to a set of Pattern table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportPatternTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportPatternTableIterator : IEnumerator<KeyValuePair<ExportPatternKey, ExportPatternInfo>>
Public Class ExportPatternTableIterator
    Implements IEnumerator(Of KeyValuePair(Of ExportPatternKey, ExportPatternInfo))
public ref class ExportPatternTableIterator : IEnumerator<KeyValuePair<ExportPatternKey^, ExportPatternInfo^>>
type ExportPatternTableIterator =
    class
        interface IEnumerator<KeyValuePair<ExportPatternKey, ExportPatternInfo>>
    end

The ExportPatternTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportPatternTableIterator
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Top
See Also

Reference

Autodesk.Revit.DB Namespace