TextNode Class

TextNote Class

A class representing text note annotations in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBTextElement
Autodesk.Revit.DBTextNote

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextNote : TextElement
Public Class TextNote
    Inherits TextElement
public ref class TextNote : public TextElement
type TextNote =
    class
        inherit TextElement
    end

The TextNote type exposes the following members.

Properties
Name | Description
Public property IsTextWrappingActive

A flag identifying whether text-wrapping is currently active in this text element or not.

If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text.

If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment
Public property | LeaderCount | Number of leader objects currently attached to the text note.
Public property | LeaderLeftAttachment | Attachment position of leaders on the left side of the text note.
Public property | LeaderRightAttachment | Attachment position of leaders on the right side of the text note.
Top
Methods
 | Name | Description
Public method | AddLeader | Adds a leader to the text note.
 | Create(Document, ElementId, XYZ, String, ElementId) | Creates a new unwrapped TextNote element with the given properties.
 | Create(Document, ElementId, XYZ, String, TextNoteOptions) | Creates a new unwrapped text note element with the given properties.
 | Create(Document, ElementId, XYZ, Double, String, ElementId) | Creates a new line-wrapping text note element of the given width and properties.
 | Create(Document, ElementId, XYZ, Double, String, TextNoteOptions) | Creates a new line-wrapping text note element of the given width and properties.
 | GetFormattedText | Returns an object that contains text and associated formatting of this note.
Public method | GetLeaders | Returns a collection of leaders currently attached to the text note.
Public method | RemoveLeaders | Removes all leaders currently attached to the text note.
 | SetFormattedText | Sets the text and associated formatting of the text of in this text note with a given FormattedText object.
Top
See Also

Reference

Autodesk.Revit.DB Namespace