ColorWithTransparency Class

ColumnAttachment Class

An object representing the attachment of the top or bottom of a column to some target: a floor, roof, ceiling, beam, or brace.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBColumnAttachment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColumnAttachment : IDisposable
Public Class ColumnAttachment
    Implements IDisposable
public ref class ColumnAttachment : IDisposable
type ColumnAttachment =
    class
        interface IDisposable
    end

The ColumnAttachment type exposes the following members.

Properties
 | Name | Description
Public property | AttachOffset | The offset of the column attachment.
Public property | BaseOrTop | Identifies if this ColumnAttachment is at the base or top of the column.
Public property | CutStyle | Identifies whether the column, or the attached element should be cut (or if neither should be cut).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Justification | Identifies the type of justification to apply to this ColumnAttachment.
Public property | TargetId | The id of the element that is attached to the column and is described by this ColumnAttachment.
Top
Methods
 | Name | Description
 | AddColumnAttachment | Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.
Public method | Dispose | Releases all resources used by the ColumnAttachment
 | GetColumnAttachment(FamilyInstance, ElementId) | Look up a column attachment by specifying the target id.
 | GetColumnAttachment(FamilyInstance, Int32) | Look up a column attachment. There is at most one attachment on the base and one on the top.
 | IsValidColumn | Says whether a FamilyInstance supports column attachments.
 | IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
 | IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.
 | RemoveColumnAttachment(FamilyInstance, ElementId) | Removes any attachment of the column to the specified target.
 | RemoveColumnAttachment(FamilyInstance, Int32) | Removes an attachment at the top or base of a column, if there is one.
Public method | SetJustification | Setter of ColumnAttachmentJustification
Top
Remarks
Call IsValidColumn() and IsValidTarget() to verify that specific elements support column attachments. A column has at most one top attachment and one bottom attachment.
See Also

Reference

Autodesk.Revit.DB Namespace