PhaseArrayIterator Class

PhaseFilter Class

Represents an phase filter within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBPhaseFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PhaseFilter : Element
Public Class PhaseFilter
    Inherits Element
public ref class PhaseFilter : public Element
type PhaseFilter =
    class
        inherit Element
    end

The PhaseFilter type exposes the following members.

Properties
 | Name | Description
Public property | IsDefault | Indicates whether this filter is the default one.
Top
Methods
 | Name | Description
 | Create | Creates a new phase filter with default status presentation.
Public method | GetPhaseStatusPresentation | Gets the phase status presentation.
Public method | SetPhaseStatusPresentation | Sets the phase status presentation.
Top
See Also

Reference

Autodesk.Revit.DB Namespace