FamilySymbol Class

An element that represents a single type with a Family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBFamilySymbol
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilySymbol : InsertableObject
Public Class FamilySymbol
    Inherits InsertableObject
public ref class FamilySymbol : public InsertableObject
type FamilySymbol =
    class
        inherit InsertableObject
    end

The FamilySymbol type exposes the following members.

Properties
 | Name | Description
Public property | Family | The Family object to which the symbol belongs.
Public property | IsActive | Identifies whether the symbol is active.
Public property | StructuralMaterialType | This property returns the physical material from which the type is made.
Top
Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible.
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section.
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol.
Public method | GetStructuralSection | Gets the structural section from element.
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol.
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties.
Public method | SetStructuralSection | Sets the structural section in element.
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol.
Top
Remarks
Custom families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of families. The Family element represents the entire family that consists of a collection of types, such as an 'I Beam'. You can think of that object as representing the entire family file. The Family object contains a number of FamilySymbol elements. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that type placed the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project.
Example
C#
VB
C++
F#
Copy
public void GetInfo_FamilySymbol(FamilySymbol familySymbol)
{
    string message;
    // Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name;

    // Get FamilySymbol material
    message += "\nFamilySymbol materials are :";
    foreach (ElementId matid in familySymbol.GetMaterialIds(true))
    {
       Material material = familySymbol.Document.GetElement(matid) as Material;
       if (null != material)
       {
          message += "\n" + material.Name;
       }
    }

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_FamilySymbol(familySymbol As FamilySymbol)
   Dim message As String
   ' Get FamilySymbol family name
   message = "Family name is : " & Convert.ToString(familySymbol.Family.Name)

   ' Get FamilySymbol material
   message += vbLf & "FamilySymbol materials are :"
   For Each matid As ElementId In familySymbol.GetMaterialIds(True)
      Dim material As Material = TryCast(familySymbol.Document.GetElement(matid), Material)
      If material IsNot Nothing Then
         message += vbLf + material.Name
      End If
   Next

   TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace