HasNoValueFilterRule Class

HasValueFilterRule Class

Tests whether an element's parameter has a value.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBParameterValuePresenceRule
Autodesk.Revit.DBHasValueFilterRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HasValueFilterRule : ParameterValuePresenceRule
Public Class HasValueFilterRule
    Inherits ParameterValuePresenceRule
public ref class HasValueFilterRule : public ParameterValuePresenceRule
type HasValueFilterRule =
    class
        inherit ParameterValuePresenceRule
    end

The HasValueFilterRule type exposes the following members.

Constructors
 | Name | Description
Public method | HasValueFilterRule | constructs an instance of HasValueFilterRule.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace