SelectionFilterElement Class

A filter element that stores an explicit list of ElementIds. Only elements whose ElementIds are in this list will pass the filter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFilterElement
Autodesk.Revit.DBSelectionFilterElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SelectionFilterElement : FilterElement
Public Class SelectionFilterElement
    Inherits FilterElement
public ref class SelectionFilterElement : public FilterElement
type SelectionFilterElement =
    class
        inherit FilterElement
    end

The SelectionFilterElement type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | AddSet | Adds a set of ElementIds to the filter's set.
Public method | AddSingle | Adds a single ElementId to the filter's set.
Public method | Clear | Removes all ElementIds from the filter.
Public method | Contains | Returns true if the given ElementId is a member of this filter's set.
 | Create | Creates a new SelectionFilterElement in the given document.
Public method | GetElementIds | Returns the set of ElementIds contained by this filter.
Public method | IsEmpty | Determines whether this filter's set is empty or not.
Public method | RemoveSet | Removes a set of ElementIds from the filter's set.
Public method | RemoveSingle | Removes a single ElementId from the filter's set.
Public method | SetElementIds | Replaces the set of ElementIds contained by this filter.
Top
Example
C#
VB
C++
F#
Copy
public static void CreateSelectionFilter(Document doc, View view)
{
    // find room tags in this view
    FilteredElementCollector collector = new FilteredElementCollector(doc, view.Id);
    collector.WherePasses(new RoomTagFilter());

    // collect tags whose room number matches criteria
    List<ElementId> tagIds = new List<ElementId>();

    foreach (RoomTag tag in collector.Cast<RoomTag>())
    {
        int number = Int32.Parse(tag.Room.Number);
        if (number % 3 == 0)
        {
            tagIds.Add(tag.Id);
        }
    }

    using (Transaction t = new Transaction(doc, "Create SelectionFilterElement"))
    {
        t.Start();

        // Create selection filter and assign ids
        SelectionFilterElement filterElement = SelectionFilterElement.Create(doc, "Room tags filter");
        filterElement.SetElementIds(tagIds);

        ElementId filterId = filterElement.Id;

        // Add the filter to the view
        view.AddFilter(filterId);

        doc.Regenerate();

        // Use the existing graphics settings, and change the color to Blue
        OverrideGraphicSettings overrideSettings = view.GetFilterOverrides(filterId);

        overrideSettings.SetProjectionLineColor(new Color(0x00, 0x00, 0xFF));

        view.SetFilterOverrides(filterId, overrideSettings);

        t.Commit();
    }
}
Public Shared Sub CreateSelectionFilter(doc As Document, view As View)
    ' find room tags in this view
    Dim collector As New FilteredElementCollector(doc, view.Id)
    collector.WherePasses(New RoomTagFilter())

    ' collect tags whose room number matches criteria
    Dim tagIds As New List(Of ElementId)()

    For Each tag As RoomTag In collector.Cast(Of RoomTag)()
        Dim number As Integer = Int32.Parse(tag.Room.Number)
        If number Mod 3 = 0 Then
            tagIds.Add(tag.Id)
        End If
    Next

    Using t As New Transaction(doc, "Create SelectionFilterElement")
        t.Start()

        ' Create selection filter and assign ids
        Dim filterElement As SelectionFilterElement = SelectionFilterElement.Create(doc, "Room tags filter")
        filterElement.SetElementIds(tagIds)

        Dim filterId As ElementId = filterElement.Id

        ' Add the filter to the view
        view.AddFilter(filterId)

        doc.Regenerate()

        ' Use the existing graphics settings, and change the color to Blue
        Dim overrideSettings As OverrideGraphicSettings = view.GetFilterOverrides(filterId)

        overrideSettings.SetProjectionLineColor(New Color(&H0, &H0, &Hff))

        view.SetFilterOverrides(filterId, overrideSettings)

        t.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace