ColorFillSchemeEntry Class

ColorOptions Class

A class providing access to color settings which affect the colors applied to specific views.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBColorOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColorOptions : IDisposable
Public Class ColorOptions
    Implements IDisposable
public ref class ColorOptions : IDisposable
type ColorOptions =
    class
        interface IDisposable
    end

The ColorOptions type exposes the following members.

Properties
 | Name | Description
Public property | AlertColor | The color of the current canvas theme used to highlight elements when a special alert is required.
Public property | BackgroundColor | The background color of the current canvas theme applied to views.
Public property | CalculatingColor | The color of the current canvas theme used to render elements when some aspect of their properties is currently being recalculated.
Public property | EditingColor | The color of the current canvas theme used to render elements when editing.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreselectionColor | The color of the current canvas theme used to highlight candidates for selection before they are selected.
Public property | SelectionColor | The color of the current canvas theme used to highlight selected elements.
Public property | SelectionSemitransparent | Indicates whether or not selections will be shown in a semi-transparent manner in current canvas theme.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ColorOptions
 | GetColorOptions | Returns the current Revit instance's ColorOptions.
Top
Remarks
ColorOptions are managed and stored along with other global application options and thus impact the application as a whole.
See Also

Reference

Autodesk.Revit.DB Namespace