PerformanceAdviser Class

The tool to report performance problems in a given document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPerformanceAdviser

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PerformanceAdviser : IDisposable
Public Class PerformanceAdviser
    Implements IDisposable
public ref class PerformanceAdviser : IDisposable
type PerformanceAdviser =
    class
        interface IDisposable
    end

The PerformanceAdviser type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | AddRule | Adds a performance adviser rule to the list of rules.
Public method | DeleteRule | Deletes a performance adviser rule from the list of rules.
Public method | Dispose | Releases all resources used by the PerformanceAdviser
Public method | ExecuteAllRules | Executes all rules in the list on a given document.
Public method | ExecuteRules(Document, IListPerformanceAdviserRuleId) | Executes selected rules on a given document.
Public method | ExecuteRules(Document, IListInt32) | Executes selected rules on a given document.
Public method | GetAllRuleIds | Retrieves an enumeration of rule Ids.
Public method | GetElementFilterFromRule(Int32, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetElementFilterFromRule(PerformanceAdviserRuleId, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetNumberOfRules | Retrieves number of performance adviser rules in the list.
 | GetPerformanceAdviser | Returns the only instance of PerformanceAdviser in the Application.
Public method | GetRuleDescription(Int32) | Retrieves the description of the rule.
Public method | GetRuleDescription(PerformanceAdviserRuleId) | Retrieves the description of the rule.
Public method | GetRuleId | Retrieves an id of a rule for a given index in the list.
Public method | GetRuleName(Int32) | Retrieves the name of the rule.
Public method | GetRuleName(PerformanceAdviserRuleId) | Retrieves the name of the rule.
Public method | IsRuleEnabled(Int32) | Retrieves an enabled/disabled status for the given rule.
Public method | IsRuleEnabled(PerformanceAdviserRuleId) | Retrieves an enabled/disabled status for the given rule.
Public method | PostWarning | Reports a problem detected during execution of a rule.
Public method | SetRuleEnabled(Int32, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | SetRuleEnabled(PerformanceAdviserRuleId, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | WillRuleCheckElements(Int32) | Reports if rule needs to be executed on individual elements.
Public method | WillRuleCheckElements(PerformanceAdviserRuleId) | Reports if rule needs to be executed on individual elements.
Top
Remarks
Class is an application-wide singleton that performs a dual role: it is a repository of rules to run in order to detect potential performance problems as well as an access point to execute checks.
Example
C#
VB
C++
F#
Copy
//Get the name of each registered PerformanceRule and then execute all of them.
foreach (PerformanceAdviserRuleId id in PerformanceAdviser.GetPerformanceAdviser().GetAllRuleIds())
{
    string ruleName = PerformanceAdviser.GetPerformanceAdviser().GetRuleName(id);
}
PerformanceAdviser.GetPerformanceAdviser().ExecuteAllRules(document);
'Get the name of each registered PerformanceRule and then execute all of them.
For Each id As PerformanceAdviserRuleId In PerformanceAdviser.GetPerformanceAdviser().GetAllRuleIds()
    Dim ruleName As String = PerformanceAdviser.GetPerformanceAdviser().GetRuleName(id)
Next
PerformanceAdviser.GetPerformanceAdviser().ExecuteAllRules(document)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace