CurveLoopsProfile Class

CurveNode Class

An output node that represents a model curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBModelCurveNode
Autodesk.Revit.DBCurveNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveNode : ModelCurveNode
Public Class CurveNode
    Inherits ModelCurveNode
public ref class CurveNode : public ModelCurveNode
type CurveNode =
    class
        inherit ModelCurveNode
    end

The CurveNode type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetCurve | Returns the geometric curve object corresponding to the node.
Top
Remarks
See also: OnCurve(CurveNode).
See Also

Reference

Autodesk.Revit.DB Namespace