BuiltInFailuresGlobalParameterFailures Class

BuiltInFailures.GridChainSketchFailures Class

BuiltInFailuresGridChainSketchFailures Class

Failures related to the GridChain sketch.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGridChainSketchFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GridChainSketchFailures
Public NotInheritable Class GridChainSketchFailures
public ref class GridChainSketchFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GridChainSketchFailures = class end

The BuiltInFailuresGridChainSketchFailures type exposes the following members.

Properties
Name | Description
ClosedLoop | GridChain sketch contains a closed loop.
InvalidSketch | Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.
MoreThanOneLoop | GridChain sketch contains more than one loop.
OverlappingLines | GridChain sketch contains lines which overlap.
Top
See Also

Reference

Autodesk.Revit.DB Namespace