BuiltInFailuresPlanRegionFailures Class

BuiltInFailures.PointFailures Class

BuiltInFailuresPointFailures Class

Failures about Point Element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPointFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PointFailures
Public NotInheritable Class PointFailures
public ref class PointFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PointFailures = class end

The BuiltInFailuresPointFailures type exposes the following members.

Properties
Name | Description
CannotMakePointHostedByIntersection | Cannot make point hosted by intersection.
CantChangeParamFlip | Can't flip Element.
CantChangeParamMirror | Can't mirror Element.
CantChangeParamRotate | Can't rotate Element.
EdgeHostedPointToBeUnhosted | A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
HostMeasurementError | Invalid host curve measurement type or value or justification
HostParameterRangeError | Hosted Parameter must be between 0 and 1
RegenFailure | Regeneration Failure.
Top
See Also

Reference

Autodesk.Revit.DB Namespace