GroupNode Class

GroupSet Class

An set that contains groups.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGroupSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GroupSet : APIObject, IEnumerable
Public Class GroupSet
    Inherits APIObject
    Implements IEnumerable
public ref class GroupSet : public APIObject,
    IEnumerable
type GroupSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The GroupSet type exposes the following members.

Constructors
 | Name | Description
Public method | GroupSet | Initializes a new instance of the GroupSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of groups that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a group within the set.
Public method | Erase | Removes a specified group from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified group into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace