JoinGeometryUtils Class

JoinType Enumeration

The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum JoinType
Public Enumeration JoinType
public enum class JoinType
type JoinType
Members
Member name | Value | Description
Abut | 0 | Abut Join
Miter | 1 | Miter Join
SquareOff | 2 | Square-off Join
Extension | 3 | Extension Join
None | -1 | No join type
See Also

Reference

Autodesk.Revit.DB Namespace