RevitLinkOptions Class

RevitLinkType Class

This class represents another Revit Document ("link") brought into the current one ("host").
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBRevitLinkType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitLinkType : ElementType
Public Class RevitLinkType
    Inherits ElementType
public ref class RevitLinkType : public ElementType
type RevitLinkType =
    class
        inherit ElementType
    end

The RevitLinkType type exposes the following members.

Properties
 | Name | Description
Public property | AttachmentType | The attachment/overlay status of this link.
Public property | IsNestedLink | Indicates whether this link is a nested or top-level link.
Public property | LocallyUnloaded | Checks whether a Revit link in a local model is unloaded only for the current user.
Public property | PathType | The type of path the link uses.
Top
Methods
 | Name | Description
 | Create(Document, ExternalResourceReference, RevitLinkOptions) | Creates a new Revit link type from an external resource reference and loads the linked document.
 | Create(Document, ModelPath, RevitLinkOptions) | Creates a new Revit link type and loads the linked document.
 | CreateFromIFC(Document, ExternalResourceReference, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
 | CreateFromIFC(Document, String, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
Public method | GetChildIds | Gets the ids of the immediate children of this link.
Public method | GetConversionData | Returns the optional data that is necessary to generate the Revit file for this link.
Public method | GetLinkedFileStatus | Returns the LinkedFileStatus of this link.
Public method | GetParentId | Gets the id of this link's immediate parent.
Public method | GetPhaseMap | Returns a mapping between phases in the host document and phases in the linked document.
Public method | GetRootId | Gets the id of the top-level link which this link is linked into.
 | GetTopLevelLink(Document, ExternalResourceReference) | Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.
 | GetTopLevelLink(Document, ModelPath) | Returns the ElementId of the (top-level) linked model with the given path.
Public method | HasSaveablePositions | Determines whether the link has changes to shared positioning that could be saved.
Public method | IsFromLocalPath | Checks whether the Revit link uses a local path, such as a hard drive.
Public method | IsFromRevitServer | Checks whether the Revit link is located on Revit Server.
 | IsLoaded | Checks whether the link with this id is loaded.
Public method | IsNotLoadedIntoMultipleOpenDocuments | Checks whether the link is loaded into more than one open document in this session of Revit. If the link is loaded into multiple open documents, reload will be disabled.
Public method | Load | Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | LoadFrom(ExternalResourceReference, WorksetConfiguration) | Loads or reloads the Revit link. The link will be loaded from the location given in the input ExternalResourceReference.
Public method | LoadFrom(ModelPath, WorksetConfiguration) | Loads or reloads the Revit link from disk or cloud. The link will be loaded from the input path.
Public method | Reload | Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | RevertLocalUnloadStatus | Restores the workshared load status of a link that has been unloaded only for the current user, in a local copy of a workshared model.
Public method | SavePositions | Saves shared coordinates changes back to the linked document.
Public method | Unload | Unloads the Revit link.
Public method | UnloadLocally | Unloads a Revit link for the current user only.
Public method | UpdateFromIFC(Document, ExternalResourceReference, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Public method | UpdateFromIFC(Document, String, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Top
Remarks
Revit links can be nested - There can exist linked files which themselves contain links. A "top-level" link is one linked directly into the host, while a "nested" link is linked into some parent link. This can go through arbitrarily many layers. Some functions give the example "A -> B -> C". This means that there is a host file, A, which has a top-level link, B, and a nested link C which has been linked into B as an attachment.
See Also

Reference

Autodesk.Revit.DB Namespace