DirectShapeReferenceOptions Class

DirectShapeReferenceOptions Methods

The DirectShapeReferenceOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | GetExternalGeometryId | Retrieves the ExternalGeometryId associated with the reference object.
 | IsValidExternalGeometryId | Validates that the input ExternalGeometryId can be assigned to a direct shape reference.
 | IsValidReferenceName | Validates that the input name can be assigned to a direct shape reference.
Public method | SetExternalGeometryId | Sets the ExternalGeometryId associated with the reference object. The ID must be non-empty.
Top
See Also

Reference