GeometryCreationUtilities Class
CreateSweptGeometry Overload

GeometryElement Class

Geometric representation of an element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBGeometryElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GeometryElement : GeometryObject,
    IEnumerable<GeometryObject>
Public Class GeometryElement
    Inherits GeometryObject
    Implements IEnumerable(Of GeometryObject)
public ref class GeometryElement : public GeometryObject,
    IEnumerable<GeometryObject^>
type GeometryElement =
    class
        inherit GeometryObject
        interface IEnumerable<GeometryObject>
    end

The GeometryElement type exposes the following members.

Properties
 | Name | Description
Public property | MaterialElement | Element describing the material from which this element is composed.
Top
Methods
 | Name | Description
Public method | GetBoundingBox | Retrieves a box that encloses the geometry element.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Protected method | GetEnumeratorNG | Returns an enumerator that iterates through the collection.
Public method | GetTransformed | Returns a transformed copy of the geometry in this element.
Top
Remarks
This class contains geometric primitives that are generated from the parametric description of the element. The member geometric primitives can be obtained directly from this object using the capabilities of IEnumerable.
See Also

Reference

Autodesk.Revit.DB Namespace