PointCloudInstance Class

PointCloudType Class

Represents a type of point cloud loaded into a Revit document. Each PointCloudType maps to a single file or identifier (depending upon the type of Point Cloud Engine which governs it).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBPointCloudType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointCloudType : ElementType
Public Class PointCloudType
    Inherits ElementType
public ref class PointCloudType : public ElementType
type PointCloudType =
    class
        inherit ElementType
    end

The PointCloudType type exposes the following members.

Properties
 | Name | Description
Public property | ColorEncoding | The color encoding used by points extracted from instances of this point cloud.
Public property | EngineIdentifier | The identifier of the engine responsible for handling of the point cloud.
Public property | FoundStatus | Shows whether the Point Cloud external file could be found.
Public property | Offset | Returns the offset stored in the point cloud.
Public property | Scale | The multiplier applied to the points in all instances of this point cloud.
Top
Methods
 | Name | Description
 | Create | Creates a new point cloud type for a given point cloud engine.
Public method | GetPath | Gets the path of the link source from which the points are loaded.
 | GetReCapProject | This method provides a direct entry point to get access to an object from the ReCap SDK (ReCapWrapper.RCProject) from Revit. This object represents the point cloud from the RC file path stored in PointCloudType. The ReCap assembly AdskRcManaged.dll will need to be included into code using this method.
Top
See Also

Reference

Autodesk.Revit.DB Namespace