ElementOwnerViewFilter Class

A filter used to match elements which are owned by a particular view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementOwnerViewFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementOwnerViewFilter : ElementQuickFilter
Public Class ElementOwnerViewFilter
    Inherits ElementQuickFilter
public ref class ElementOwnerViewFilter : public ElementQuickFilter
type ElementOwnerViewFilter =
    class
        inherit ElementQuickFilter
    end

The ElementOwnerViewFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementOwnerViewFilter(ElementId) | Constructs a new instance of a filter to match elements which are owned by a particular view.
Public method | ElementOwnerViewFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.
Top
Properties
 | Name | Description
Public property | ViewId | The view id.
Top
Methods
 | Name | Description
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Use ElementOwnerView filter to find TextNotes in the active view

// Create an ElementOwnerView filter with id of active view
ElementOwnerViewFilter elementOwnerViewFilter = new ElementOwnerViewFilter(document.ActiveView.Id);

// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find TextNotes only
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> textNotesOfActiveView =
    collector.WherePasses(elementOwnerViewFilter).OfClass(typeof(TextNote)).ToElements();

// Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
ElementOwnerViewFilter notOwnedFilter = new ElementOwnerViewFilter(document.ActiveView.Id, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notOwnedByViewFounds =
    collector.WherePasses(notOwnedFilter).OfClass(typeof(TextNote)).ToElements();
' Use ElementOwnerView filter to find TextNotes in the active view

' Create an ElementOwnerView filter with id of active view
Dim elementOwnerViewFilter As New ElementOwnerViewFilter(document.ActiveView.Id)

' Apply the filter to the elements in the active document,
' Use shortcut method OfClass() to find TextNotes only
Dim collector As New FilteredElementCollector(document)
Dim textNotesOfActiveView As ICollection(Of Element) = collector.WherePasses(elementOwnerViewFilter).OfClass(GetType(TextNote)).ToElements()

' Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
Dim notOwnedFilter As New ElementOwnerViewFilter(document.ActiveView.Id, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notOwnedByViewFounds As ICollection(Of Element) = collector.WherePasses(notOwnedFilter).OfClass(GetType(TextNote)).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace