Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBConicalFace
Autodesk.Revit.DBCylindricalFace
Autodesk.Revit.DBHermiteFace
Autodesk.Revit.DBPlanarFace
Autodesk.Revit.DBRevolvedFace
Autodesk.Revit.DBRuledFace

Face Properties

The Face type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face.
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command).
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction.
Public property | IsTwoSided | Determines if a face is two-sided (degenerate).
Public property | MaterialElementId | The element ID of the material from which this face is composed.
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.
Public property | Period | The period of the underlying surface in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.
Top
See Also

Reference