DocumentVersion Class

Domain Enumeration

Type of connector domain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Domain
Public Enumeration Domain
public enum class Domain
type Domain
Members
Member name | Value | Description
DomainUndefined | 0 | Domain is undefined
DomainHvac | 1 | HVAC (duct) connector
DomainElectrical | 2 | Electrical connector
DomainPiping | 3 | Connector of cable trays or conduits
DomainCableTrayConduit | 4 | Connector of Structural Analytical Model
See Also

Reference

Autodesk.Revit.DB Namespace