BrowserOrganization Class

The organization settings for grouping, sorting, and filtering of items in the project browser.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBBrowserOrganization

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BrowserOrganization : ElementType
Public Class BrowserOrganization
    Inherits ElementType
public ref class BrowserOrganization : public ElementType
type BrowserOrganization =
    class
        inherit ElementType
    end

The BrowserOrganization type exposes the following members.

Properties
 | Name | Description
Public property | SortingOrder | The sorting order if sorting of items is applicable in the browser.
Public property | SortingParameterId | The Id of the parameter used to determine the sorting order of items in the browser.
Public property | Type | Get BrowserOrganizationType.
Top
Methods
 | Name | Description
Public method | AreFiltersSatisfied | Determines if the given element satisfies the filters defined by the browser organization.
 | GetCurrentBrowserOrganizationForSchedules | Gets the BrowserOrganization that applies to the Schedules section of the project browser.
 | GetCurrentBrowserOrganizationForSheets | Gets the BrowserOrganization that applies to the Sheets section of the project browser.
 | GetCurrentBrowserOrganizationForViews | Gets the BrowserOrganization that applies to the Views section of the project browser.
Public method | GetFolderItems | Returns a collection of leaf FolderItemInfo objects each containing the given element Id.
Top
See Also

Reference

Autodesk.Revit.DB Namespace