ModelPathUtils Class

ModelText Class

A model text element in an Autodesk Revit family document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBModelText

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelText : Element
Public Class ModelText
    Inherits Element
public ref class ModelText : public Element
type ModelText =
    class
        inherit Element
    end

The ModelText type exposes the following members.

Properties
 | Name | Description
Public property | Depth | The depth of the model text.
Public property | HorizontalAlignment | The horizontal alignment.
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides ElementLocation)
Public property | ModelTextType | The type for the model text.
Public property | Subcategory | The subcategory.
Public property | Text | The text string in the model text.
Top
Methods
 | Name | Description
Public method | GetVisibility | Gets the visibility for the model text in a family document.
Public method | SetVisibility | Sets the visibility for the model text in a family document.
Top
See Also

Reference

Autodesk.Revit.DB Namespace