Autodesk.Revit.DB Namespace

Classes
Class | Description
Public class | ACADExportOptions | The base class for options used to export DWG and DXF format files.
AdaptiveComponentFamilyUtils | An interface for Adaptive Component Instances.
AdaptiveComponentInstanceUtils | An interface for Adaptive Component Instances.
Public class | AddInId | Identifies an AddIn registered with Revit
Public class | AlphanumericRevisionSettings | Contains settings that apply to Revisions with the Alphanumeric RevisionNumberType.
Public class | AngularDimension | An object that represents an Angular Dimension within the Revit project.
Public class | AnnotationMultipleAlignmentUtils | A helper providing functionality related to elements that can be aligned to one another. An element that wants to be able to align to other alignable elements using the Multiple Alignment buttons should implement this helper class.
Public class | AnnotationSymbol | This object represents a symbol of the Generic Annotation.
Public class | AnnotationSymbolType | An object that represents an annotation style.
Public class | APIObject | Supports all objects in the Autodesk Revit API hierarchy.
Public class | AppearanceAssetElement | An element that contains a rendering asset used as a portion of a material definition.
Public class | Arc | A circular arc.
Public class | ArcLengthDimension | An object that represents an ArcLengthDimension within the Revit Project.
Public class | Area | Provides access to the area topology in Autodesk Revit.
AreaFilter | A filter used to match areas.
Public class | AreaScheme | The area scheme associated with a particular area plan.
Public class | AreaTag | Provides access to the area topology in Autodesk Revit.
Public class | AreaTagFilter | A filter used to match area tags.
Public class | AreaTagType | An object that represents an Area Tag style.
Public class | AreaVolumeSettings | This class provides access to settings related to volume and area computations.
Public class | AssemblyCodeTable | AssemblyCodeTable represents the collection of ClassificationEntries for a document.
Public class | AssemblyDifference | Class that describes difference between two assemblies.
Public class | AssemblyDifferenceConfiguration | The two assemblies being compared have different spatial configuration
Public class | AssemblyDifferenceMemberCount | The two assemblies being compared have different number of members
Public class | AssemblyDifferenceMemberDifference | The two assemblies being compared have different members
Public class | AssemblyDifferenceNamingCategory | The two assemblies being compared have different naming categories
Public class | AssemblyDifferenceNone | The two assemblies being compared are identical
AssemblyInstance | Combines multiple elements for tagging, filtering, scheduling and creating isolated assembly views.
Public class | AssemblyMemberDifference | Class that describes difference between two assembly members
Public class | AssemblyMemberDifferentCategory | The two assembly members being compared have different category
Public class | AssemblyMemberDifferentGeometry | The two assembly members being compared have different geometry
Public class | AssemblyMemberDifferentParameters | The two assembly members being compared have different parameters
Public class | AssemblyMemberDifferentType | The two assembly members being compared have different type
Public class | AssemblyType | Type for construction assembly elements.
AssemblyViewUtils | Utilities that provide capabilities related to assembly view creation and validation.
Public class | AXMImportOptions | The import options used to import AXM format files.
Public class | BackgroundSettings | Represents the rendering background settings.
Public class | BarTypeDiameterOptions | This class stores the diameter information from the RebarBarType.
Public class | BaseArray | An abstract base class that represents an array within the Revit project.
Public class | BaseExportOptions | The base class for options used to export DWG, DXF and DGN format files.
Public class | BaseImportOptions | A base class containing import options used during import of several formats.
Public class | BasePoint | A class representing the Project Base Point and Survey Point. Each Revit project contains one project base point and one survey point. The project base point represents the origin of the project coordinate system. The survey point represents the origin of the shared coordinate system.
Public class | BasicFileInfo | Encapsulates basic information about a Revit file, including worksharing status, Revit version, username and central path.
BeamSystem | An object that represents a BeamSystem within the Autodesk Revit project.
Public class | BeamSystemType | An object that specifies the type of a beam system in Autodesk Revit.
Public class | BIMExportOptions | The base class for options used to export using ATF.
Public class | Binding | Binding objects are used to take a parameter definition and bind it to one or more categories.
Public class | BindingMap | The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Public class | Blend | A blend solid or void form.
Public class | BooleanOperationsUtils | These utilities are applicable for the geometry created by GeometryCreationUtilities and the geometry of Revit model.
BoundarySegment | An object that represents a segment of an area boundary.
Public class | BoundaryValidation | Curve loop validators.
BoundingBoxContainsPointFilter | A filter used to match elements with a bounding box that contains the given point.
BoundingBoxIntersectsFilter | A filter used to match elements with a bounding box that intersects the given Outline.
BoundingBoxIsInsideFilter | A filter used to match elements with a bounding box that is contained by the given Outline.
BoundingBoxUV | A two-dimensional rectangle, parallel to the coordinate axes.
BoundingBoxXYZ | A three-dimensional rectangular box at an arbitrary location and orientation within the Revit model.
BRepBuilder | A class that allows direct construction of geometry objects (solids, open shells, etc.).
Public class | BRepBuilderEdgeGeometry | An abstract class used by BRepBuilder to represent the geometry of an edge. Specific edge-geometry representations are represented by subclasses.
Public class | BRepBuilderGeometryId | This class is used by the BRepBuilder class to identify objects it creates (faces, edges, etc.).
Public class | BRepBuilderPersistentIds | This class stores a map from ExternalGeometryIds to BRepBuilderGeometryIds.
Public class | BRepBuilderSurfaceGeometry | An abstract class used by BRepBuilder to represent the geometry of a surface. Specific surface-geometry representations are represented by subclasses.
Public class | BrowserOrganization | The organization settings for grouping, sorting, and filtering of items in the project browser.
Public class | BuildingPadType | Represents a specific type of Building Pad.
Public class | BuiltInFailures | Provides a container of all Revit built-in FailureDefinitionId instances.
Public class | BuiltInFailuresAlignmentFailures | Failures related to alignment elements and annotations.
Public class | BuiltInFailuresAnalyticalModelFailures | Failures about AnalyticalModel.
Public class | BuiltInFailuresArrayFailures | Failures about Arrays.
Public class | BuiltInFailuresAssemblyFailures | Failures related to Assemblies.
Public class | BuiltInFailuresAutoJoinFailures | Failures about AutoJoin.
Public class | BuiltInFailuresAutoRouteFailures | Failures about AutoRoute.
Public class | BuiltInFailuresBeamFailures | Failures about Beams.
Public class | BuiltInFailuresBeamSystemFailures | Failures about BeamSystem.
Public class | BuiltInFailuresBendFailures | Failures about Bends.
Public class | BuiltInFailuresBlendFailures | Failures about Blend.
Public class | BuiltInFailuresColorFillFailures | Failures about ColorFill.
Public class | BuiltInFailuresColumnFailures | Failures about Columns.
Public class | BuiltInFailuresColumnInsideWallFailures | Failures description ColumnInsideWall
Public class | BuiltInFailuresComponentRepeaterFailures | Failures related to component repeaters.
Public class | BuiltInFailuresComponentRepeaterSlotFailures | Failures related to component repeater slots.
Public class | BuiltInFailuresConnectorFailures | Failures about Connector.
Public class | BuiltInFailuresConstraintFailures | Failures about Constraint.
Public class | BuiltInFailuresConversionFailures | Failures about conversion of data to a different format.
Public class | BuiltInFailuresCopyMonitorFailures | Failures about CopyWatch.
Public class | BuiltInFailuresCopyPasteFailures | Failures about CopyPasteFailures.
Public class | BuiltInFailuresCreationFailures | Failures about CreationFailures.
Public class | BuiltInFailuresCurtainGridFamilyFailures | Failures about CurtainGrid Family.
Public class | BuiltInFailuresCurtainWallFailures | Failures about CurtainWall.
Public class | BuiltInFailuresCurveByPointFailures | Failures about Curve By Point Element
Public class | BuiltInFailuresCurveFailures | Failures about Curves and Curve-Driven Elements.
Public class | BuiltInFailuresCutFailures | Failures about Cut.
Public class | BuiltInFailuresCutterFailures | Failures about Cutter.
Public class | BuiltInFailuresCuttingFailures | Failures about Cutting.
Public class | BuiltInFailuresDatumPlaneFailures | Failures about DatumPlane.
Public class | BuiltInFailuresDebugTabBindingFailures | Failures related to binding framework demo panel on Ribbon Debug Tab.
Public class | BuiltInFailuresDecalFailures | Failures about Decal.
Public class | BuiltInFailuresDesignOptionFailures | Failures about DesignOptionFailures.
Public class | BuiltInFailuresDetailFailures | Failures about Detail.
Public class | BuiltInFailuresDimensionFailures | Failures about DimensionFailures.
Public class | BuiltInFailuresDirectContext3DFailures
Public class | BuiltInFailuresDirectShapeFailures | Failure definitions related to DirectShapes.
Public class | BuiltInFailuresDisplacementElementFailures | Error messages related to the DisplacementElement.
Public class | BuiltInFailuresDividedPathFailures | Failures related to divided path operations.
Public class | BuiltInFailuresDividedSurfaceFailures | Failures about DividedSurface.
Public class | BuiltInFailuresDocumentFailures | Failures about DocumentFailures.
Public class | BuiltInFailuresDPartFailures | Failures related to parts.
Public class | BuiltInFailuresDuctFailures | Failures about Duct.
Public class | BuiltInFailuresEditingFailures | Failures related to editing operations.
Public class | BuiltInFailuresElectricalFailures | Failures about Electricity.
Public class | BuiltInFailuresElectricityFailures | Failures related to electrical system and circuits.
Public class | BuiltInFailuresElementFailures | Failures about Elements.
Public class | BuiltInFailuresElementTypeFailures | Failures about ElementTypeFailures.
Public class | BuiltInFailuresElevationFailures | Failures about Elevation.
Public class | BuiltInFailuresEnergyAnalysisFailures | Failures about EnergyAnalysis.
Public class | BuiltInFailuresEnergyAnalysisUtilitiesDBFailures | Failures about EnergyAnalysisUtilitiesDBFailures.
Public class | BuiltInFailuresExportFailures | Failures about ExportFailures.
Public class | BuiltInFailuresExternalResourceReferenceFailures
Public class | BuiltInFailuresExtrusionFailures | Failures about Extrusions.
Public class | BuiltInFailuresFabricAreaFailures | Failures related to fabric area elements.
Public class | BuiltInFailuresFabricFailures | Failures about Fabric.
Public class | BuiltInFailuresFabricSheetFailures | Failures related to fabric sheet elements.
Public class | BuiltInFailuresFaceSplitterFailures | Failures about FaceSplitter.
Public class | BuiltInFailuresFamilyFailures | Failures related to families.
Public class | BuiltInFailuresFilledRegionFailures | Failures about FilledRegion.
Public class | BuiltInFailuresFloorFailures | Failures related to floors and slabs.
Public class | BuiltInFailuresFluidFailures | Failures about Fluid.
Public class | BuiltInFailuresForeignFileFailures | Failures about files saved by applications that were not developed or licensed by Autodesk.
Public class | BuiltInFailuresFormFailures | Failures about Form.
Public class | BuiltInFailuresGeneralFailures | Failures about GeneralFailures.
Public class | BuiltInFailuresGenericFailures | Generic failures that may apply to any Revit Element
Public class | BuiltInFailuresGenericMEPFailures | Failures applicable to different mechanical, electrical and piping Elements.
Public class | BuiltInFailuresGeometryFailures | Failures about GeometryFailures.
Public class | BuiltInFailuresGlobalParameterFailures
Public class | BuiltInFailuresGridChainSketchFailures | Failures related to the GridChain sketch.
Public class | BuiltInFailuresGridFailures | Failures about Grid.
Public class | BuiltInFailuresGroupFailures | Failures related to groups and their behavior.
Public class | BuiltInFailuresHostObjFailures | Failures about HostObj.
Public class | BuiltInFailuresHvacFailures | Failures related to HVAC in MEP.
Public class | BuiltInFailuresIlluminationFailures | Failures about Illumination.
Public class | BuiltInFailuresImageFailures | Failures about Image.
Public class | BuiltInFailuresImportExportFailures | Failures about Import and Export.
Public class | BuiltInFailuresImportFailures | Failures about ImportFailures.
Public class | BuiltInFailuresInaccurateFailures | Failures about Inaccurate.
Public class | BuiltInFailuresInfillFailures | Failures about Infill.
Public class | BuiltInFailuresInterferenceFailures | Failures about Interference.
Public class | BuiltInFailuresJoinElementsFailures | Failures about JoinElements.
Public class | BuiltInFailuresKeyBasedTreeEntryFailures | Failures about KeyBasedTreeEntry.
Public class | BuiltInFailuresKeyBasedTreeFileFailures | Failures occurred when reading key based tree text file.
Public class | BuiltInFailuresKeynoteFailures
Public class | BuiltInFailuresKeynoteTagFailures | Failures related to keynote tags.
Public class | BuiltInFailuresLegendFailures | Failures about Legend.
Public class | BuiltInFailuresLevelAssociationFailures | Failures about Level association of Analytical Node.
Public class | BuiltInFailuresLevelFailures | Failures about Level.
Public class | BuiltInFailuresLinkFailures | Failures about LinkFailures.
Public class | BuiltInFailuresLoadFailures | Failures about Load.
Public class | BuiltInFailuresLooseDimensionFailures | Failures about LooseDimension.
Public class | BuiltInFailuresMacroFailures | Failures about module with duplicate name found during reload latest.
Public class | BuiltInFailuresMassFailures | Failures about Mass.
Public class | BuiltInFailuresMatchlineFailures | Failures about Matchline.
Public class | BuiltInFailuresMechanicalFailures | Failures about HVAC.
Public class | BuiltInFailuresMEPCalculationFailures | Failures about Fluid.
Public class | BuiltInFailuresMEPFabricationFailures | Failures about MEP fabrication.
Public class | BuiltInFailuresMEPSupportFailures | Failures about MEP suppor.
Public class | BuiltInFailuresMirrorFailures | Failures about Mirror.
Public class | BuiltInFailuresMultiReferenceAnnotationFailures | Failures about MultiReferenceAnnotations.
Public class | BuiltInFailuresNumberingFailures | Failures related to object numbering operations.
Public class | BuiltInFailuresOffsetFacesCellLegacyFailures | Failures related to offset faces operations.
Public class | BuiltInFailuresOpeningFailures | Failures about Opening.
Public class | BuiltInFailuresOverlapFailures | Failures detected by overlap check.
Public class | BuiltInFailuresParameterFailures | Failures related to parameters and parameter operations.
Public class | BuiltInFailuresPartMakerMethodForMergePartFailures | Failures related to part merge operations.
Public class | BuiltInFailuresPartMakerMethodForWallFailures | Failures related to parts related to walls.
Public class | BuiltInFailuresPathFailures | Failures about Path.
Public class | BuiltInFailuresPathOfTravelFailures | Failures about PathOfTravel.
Public class | BuiltInFailuresPerformanceFailures | Failures which give hints pointing to situations where performance could be improved.
Public class | BuiltInFailuresPipingFailures | Failures about Pipes.
Public class | BuiltInFailuresPlanRegionFailures | Failures about PlanRegion.
Public class | BuiltInFailuresPointFailures | Failures about Point Element.
Public class | BuiltInFailuresProfileFailures | Failures about Profile.
Public class | BuiltInFailuresPropertySetElementFailures | Failures related to property set elements.
Public class | BuiltInFailuresRebarBendingDetailFailures | Failures concerning rebar bending details.
Public class | BuiltInFailuresRebarCouplerFailures | Failures concerning couplers
Public class | BuiltInFailuresRebarFailures | Failures about Rebar.
Public class | BuiltInFailuresRebarShapeFailures | Failures about RebarShape.
Public class | BuiltInFailuresRebarSystemFailures | Failures related to rebar systems.
Public class | BuiltInFailuresRefPlaneFailures | Failures about RefPlane.
Public class | BuiltInFailuresRegenFailures | Failures about RegenFailures.
Public class | BuiltInFailuresRenderFailures | Failures related to rendering.
Public class | BuiltInFailuresRevisionCloudFailures | Failures about RevisionCloud.
Public class | BuiltInFailuresRevisionFailures | Failures about Revision Settings.
Public class | BuiltInFailuresRevolutionFailures | Failures about Revolution.
Public class | BuiltInFailuresRoofFailures | Failures about Roof.
Public class | BuiltInFailuresRoomFailures | Failures about Room.
Public class | BuiltInFailuresScaleFailures | Failures about Scale.
Public class | BuiltInFailuresScheduleViewFailures | Failures about Schedule.
Public class | BuiltInFailuresSculptingFailures | Failures about Sculpting.
Public class | BuiltInFailuresSectionViewFailures | Failures about Section.
Public class | BuiltInFailuresSelectionFailures | Failures about Selections.
Public class | BuiltInFailuresSharedCoordinatesFailures | Failures about shared coordinates.
Public class | BuiltInFailuresSheetCollectionFailures | Failures about SheetCollection.
Public class | BuiltInFailuresSheetFailures | Failures about Sheet.
Public class | BuiltInFailuresSiteFailures | Failures about Site.
Public class | BuiltInFailuresSiteImportFailures | Failures about SiteImport.
Public class | BuiltInFailuresSketchFailures | Failures about Sketch.
Public class | BuiltInFailuresSkylightFailures | Failures about Skylight.
Public class | BuiltInFailuresSlabFailures | Failures about Slab.
Public class | BuiltInFailuresSlabShapeFailures | Failures about SlabShape.
Public class | BuiltInFailuresSlantedColumnFailures | Failures about SlantedColumn.
Public class | BuiltInFailuresSpanDirectionSymbolFailures | Failures about SpanDirectionSymbol.
Public class | BuiltInFailuresSplineFailures | Failures about Spline.
Public class | BuiltInFailuresSplitSketchBasedElementFailures | Failures related to the split sketched based element.
Public class | BuiltInFailuresSplitToposolidFailures
Public class | BuiltInFailuresStairRampFailures | Failures about StairRamp.
Public class | BuiltInFailuresSteelElementFailures | Failures about steel elements
Public class | BuiltInFailuresSteelElementsFailures | Failures about SteelElement module
Public class | BuiltInFailuresStructuralAssetFailures | Failures related to structural materials.
Public class | BuiltInFailuresStructuralConnectionFailures | Failures about StructuralConnectionHandler.
Public class | BuiltInFailuresStructuralCustomConnectionFailures | Failures about StructuralConnectionHandler.
Public class | BuiltInFailuresStructuralLoadFailures | Failures about Load.
Public class | BuiltInFailuresSubRegionFailures
Public class | BuiltInFailuresSweepFailures | Failures about Sweep.
Public class | BuiltInFailuresSweptBlendFailures | Failures about SweptBlend.
Public class | BuiltInFailuresSystemNavigatorFailures | Failures related with the system browser.
Public class | BuiltInFailuresSystemsFailures | Failures about System.
Public class | BuiltInFailuresTagFailures | Failures about Tag.
Public class | BuiltInFailuresTextFailures | Failures about Text.
Public class | BuiltInFailuresTilePatternTileFailures | Failures related to tile pattern tile.
Public class | BuiltInFailuresToggleViewFailures | Failures about ToggleView.
Public class | BuiltInFailuresTrussFailures | Failures about Truss.
Public class | BuiltInFailuresUniqueElementFailures
Public class | BuiltInFailuresViewFailures | Failures about ViewFailures.
Public class | BuiltInFailuresViewSheetFailures | Failures about placing viewports on sheets.
Public class | BuiltInFailuresWallFailures | Failures about Wall.
Public class | BuiltInFailuresWallJoinFailures | Failures about WallJoin.
Public class | BuiltInFailuresWallJoinRoofFailures | Failures about WallJoinRoof.
Public class | BuiltInFailuresWorksharingFailures | Failures about WorksharingFailures.
Public class | BuiltInFailuresZoneFailures | Failures about Zone.
Public class | CADExportOptions | Generic CAD Export options.
Public class | CADLinkOperations | This class is used to extend the IExternalResourceServer interface with methods to support operations specifically related to DWG links.
Public class | CADLinkOptions | This class contains the options in use when or reloading a CAD link type (DWG, DXF, etc.)
Public class | CADLinkType | CADLinkType represents both CAD links and CAD imports. The function IsLink can be used to distinguish between the two. CAD imports are not ExternalFileReferences; they are brought completely into the document and maintain no connection to their original file.
Public class | CameraInfo | An object holding information about the projection mapping of a 3D view.
Public class | CancellationListener | Allows clients to poll the cancellation status of a background operation. Revit instantiates CancellationListener objects for internal background operation implementations only. As such, third-party developers are not expected to instantiate or handle CancellationListener objects.
Categories | The Categories object is a map that contains all the top-level Category objects within the Document.
Category | Represents the category or subcategory to which an element belongs.
Public class | CategoryNameMap | A map that contains a mapping of category name to its category object.
Public class | CategoryNameMapIterator | An iterator to a category name map.
Public class | CategorySet | A set that can contains Category objects.
Public class | CategorySetIterator | An iterator to a category set.
Public class | Ceiling | Represents a ceiling in Autodesk Revit.
Public class | CeilingAndFloor | A base class that provides support for all ceiling and floor objects.
Public class | CeilingType | Represents a ceiling type in Autodesk Revit.
Public class | ChangeType | A class representing a change that can be detected and tracked during Dynamic Update.
City | An object that contains geographical location information for a known city.
Public class | CitySet | An set that contains cities.
Public class | CitySetIterator | An iterator to a city set.
Public class | ClassificationEntries | A collection of ClassificationEntry objects that make up the classification table.
Public class | ClassificationEntry | Represents an entry in the classification table.
Public class | ClosestPointsPairBetweenTwoCurves | This class captures results of computation of closest points between two generic curves.
Public class | Color | Represents a color in Autodesk Revit.
Public class | ColorBackgroundSettings | Represents the rendering color background settings.
Public class | ColorFillLegend | Represents color fill legend.
Public class | ColorFillScheme | Represents a color scheme could be used to colorfy elements in floor plan views and section views.
Public class | ColorFillSchemeEntry | Represents an entry of a [!:Autodesk::Revit::DB::ColorFillScheme].
Public class | ColorOptions | A class providing access to color settings which affect the colors applied to specific views.
Public class | ColorWithTransparency | Color with transparency
Public class | ColumnAttachment | An object representing the attachment of the top or bottom of a column to some target: a floor, roof, ceiling, beam, or brace.
Public class | CombinableElement | An element that can be added to a geometry combination.
Public class | CombinableElementArray | An array that contains CombinableElement objects.
Public class | CombinableElementArrayIterator | An iterator to an CombinableElement array.
Public class | ComponentRepeater | An element that contains and manages a set of repeated components.
Public class | ComponentRepeaterIterator | A slot iterator for ComponentRepeater.
Public class | ComponentRepeaterSlot | Represents a slot that holds one repeated component in a component repeater.
Public class | CompoundStructure | Describes the internal structure of a wall, floor, roof or ceiling.
Public class | CompoundStructureLayer | Describes a single layer in a CompoundStructure.
Public class | ConfigurationReloadInfo | This object contains information returned by a reload of the fabrication configuration.
ConicalFace | A conical face of a 3d solid or open shell.
Public class | ConicalSurface | A Conical Surface.
Public class | ConnectionValidationInfo | This object contains information about fabrication connection validations.
Public class | ConnectionValidationWarning | Contains information about a specific connection validation problem.
Connector | A connector in an Autodesk Revit MEP project document.
Public class | ConnectorElement | A base class that provides support for all connector elements occurring in families.
Public class | ConnectorManager | Provides access to the Connector Manager
Public class | ConnectorSet | A set that can contain any type of object.
Public class | ConnectorSetIterator | An iterator to a set.
Public class | Construction | Construction definition for Project Information.
Public class | ContentNode | This class represents a generic content node in a model-exporting process.
Public class | ContourSetting | Contour setting object that handles the contour information used to draw contours on elements.
Public class | ContourSettingItem | Contour setting item that stores the information of a single contour or a set of contours.
Public class | Control | A control in Autodesk Revit family document.
Public class | CopyPasteOptions | Settings to control the behavior of a copy-paste operation.
Public class | CurtainCell | Represents a CurtainCell within Autodesk Revit.
Public class | CurtainGrid | Represents a curtain grid element within Autodesk Revit.
Public class | CurtainGridLine | Represents a CurtainGridLine within Autodesk Revit.
Public class | CurtainGridSet | A set that can contain any type of object.
Public class | CurtainGridSetIterator | An iterator to a set.
Public class | CurtainSystem | Provides access to the CurtainSystem object in Autodesk Revit.
Public class | CurtainSystemBase | Provides access to the CurtainSystemBase object in Autodesk Revit.
Public class | CurtainSystemType | An object that represents CurtainSystem type.
Public class | Curve | A parametric curve.
Public class | CurveArrArray | An array that can contain any type of object.
Public class | CurveArrArrayIterator | An iterator to a array.
Public class | CurveArray | An array that can contain curves.
Public class | CurveArrayIterator | An iterator to a curve array.
Public class | CurveByPoints | A curve interpolating two or more points.
Public class | CurveByPointsArray | An array that can contain CurveByPoints elements.
Public class | CurveByPointsArrayIterator | An iterator to a CurveByPoints array.
Public class | CurveByPointsUtils | A static class that contains methods for processing curves driven by points.
Public class | CurveElement | Class representing curve elements.
CurveElementFilter | A filter used to pass curve elements which are of a specific type.
Public class | CurveExtents | Represents the start and end parameters for a curve segment.
Public class | CurveLoop | A class that represents a chain of curves.
Public class | CurveLoopIterator | An iterator to a curve loop.
Public class | CurveLoopsProfile | Represents a curve loop based profile for sweep or swept blend elements.
Public class | CurveNode | An output node that represents a model curve.
Public class | CurveUV | A class that encapsulates the notion of a curve in the 2D parameter space of a surface in 3D space.
CustomExporter | A class that allows exporting 3D or 2D views via an export context.
Public class | CustomFieldData | A class that offer access to the information about a custom field.
CylindricalFace | A cylindrical face of a 3d solid or open shell.
Public class | CylindricalHelix | A cylindrical helix.
Public class | CylindricalSurface | A cylindrical surface.
Public class | DataConversionMonitorScope | This class is used to regsiter an application-supplied object that implements IDataConversionMonitor. Creating the object registers an implementation of IDataConversionMonitor supplied as constructor argument. When the scope object is destroyed, that object is unregistered.
Public class | DatumPlane | A base class representing a datum surface (level, grid or reference plane) in Autodesk Revit.
Public class | DefaultDivideSettings | Provides access to project-wide divide settings.
Public class | DefaultOpenFromCloudCallback | A default callback that may be used to control Revit's behavior when opening a model.
Public class | Definition | The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
Public class | DefinitionBindingMap | A map that contains mappings of parameter definitions to parameter bindings.
Public class | DefinitionBindingMapIterator | An iterator to a parameter definition to parameter bindings map.
DefinitionFile | The DefinitionFile object represents a shared parameters file on disk.
Public class | DefinitionGroup | The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
Public class | DefinitionGroups | A specialized set of definition groups that allows creation of new groups.
Public class | Definitions | A base class that supports the addition of new parameter definitions.
Public class | DeleteElements | Deletes element(s) related to the failure.
Public class | DeleteWorksetSettings | This class represents the settings used to delete a workset.
Public class | DesignOption | An element that represents a design alternative.
Public class | DetailArc | Represents a DetailArc within Autodesk Revit.
Public class | DetailCurve | A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.
Public class | DetailCurveArray | An array that can contain any type of object.
Public class | DetailCurveArrayIterator | An iterator to a array.
Public class | DetailElementOrderUtils | A utility class that arranges the draw order of the detail elements.
Public class | DetailEllipse | Represents a DetailEllipse within Autodesk Revit.
Public class | DetailLine | Represents a DetailLine within Autodesk Revit.
Public class | DetailNurbSpline | Represents a DetailNurbSpline within Autodesk Revit.
Public class | DGNExportOptions | The export options used by exporting DGN format file.
Public class | DGNImportOptions | The import options used to import DGN format files.
Dimension | An object that represents a dimension within the Revit project.
Public class | DimensionEqualityLabelFormatting | Instances of this class represent individual parameters used to make up a dimension equality formula for continuous linear or angular dimensions.
Public class | DimensionSegment | A segment of a dimension within the Autodesk Revit project.
Public class | DimensionSegmentArray | An array that can contain any number of DimensionSegment objects.
Public class | DimensionSegmentArrayIterator | An iterator to an array of DimensionSegment objects..
Public class | DimensionType | An object that represents a dimension style.
DirectShape | This class is used to store externally created geometric shapes. Primary intended use is for importing shapes from other data formats such as IFC or STEP. A DirectShape object may be assigned a category. That will affect how that object is displayed in Revit.
Public class | DirectShapeLibrary | DirectShapeLibrary is used to store pre-created geometry for further referencing via the definition/instance mechanism. It is not persistent: the scope of a library object is usually a single data creation session. DirectShape::createGeometryInstance and DirectShape::CreateElementInstance will use the current DirectShapeLibrary to look up the definitions. store a collection of GNodes as definition end class DirectShapeDefinition
Public class | DirectShapeOptions | This class is used to control behavior of a DirectShape object.
Public class | DirectShapeReferenceOptions | This class is used to control the behavior of DirectShape and DirectShapeType reference objects.
Public class | DirectShapeType | The type element associated with a DirectShape element. This element includes data reused by DirectShape elements of the same type.
Public class | DirectShapeTypeOptions | This class is used to control behavior of a DirectShapeType object.
Public class | DisableAnalyticalModelCB | Disable the analytical model for a structural wall.
Public class | DisciplineTypeId | This class contains constants identifying disciplines.
Public class | DisplacementElement | A view-specific element that causes other elements to appear to be displaced from their actual locations.
Public class | DisplacementPath | A view-specific annotation related to a DisplacementElement.
Public class | DividedPath | An element that consists of a set of points distributed along a path which consists of a connected set of curves and edges.
DividedSurface | An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.
Public class | Document | An object that represents an open Autodesk Revit project.
Public class | DocumentDifference | DocumentDifference represents the difference (including added elements, modified elements and deleted elements) of a Revit model between different DocumentVersion of the model.
DocumentPreviewSettings | Contains the settings related to the saving of preview images for a given document.
Public class | DocumentSet | A set that can contain any documents.
Public class | DocumentSetIterator | An iterator to a set of documents.
Public class | DocumentValidation | Utility functions with document validation
Public class | DocumentVersion | This class uniquely identifies an edition of a given document.
Public class | DoubleArray | An array that contains doubles.
Public class | DoubleArrayIterator | An iterator to an array of doubles.
Public class | DoubleParameterValue | A class that holds a Double value of a parameter element.
Public class | DuplicateTypeNamesHandlerArgs | A structure that provides information about an attempt to copy types with names that already exist in the destination document.
Public class | DWFExportOptions | DWF Export options.
Public class | DWFImportOptions | The import options used by importing DWF or DWFx format file.
Public class | DWFXExportOptions | DWFX Export options.
Public class | DWGExportOptions | The export options used by exporting DWG format file.
Public class | DWGImportOptions | The import options used by importing DWG or DXF format file.
Public class | DXFExportOptions | The export options used by exporting DXF format file.
Public class | Edge | An edge of a 3d solid.
Public class | EdgeArray | An array that contains edges.
EdgeArrayArray | An array of edge arrays.
Public class | EdgeArrayArrayIterator | An iterator to an array or edge arrays.
Public class | EdgeArrayIterator | An iterator to an edge array.
Public class | EdgeEndPoint | Represents the start or the end point of an Edge.
Public class | EditScope | The base class for a scope object that provides special access and limitations related to editing certain elements.
Public class | Element | Base class for most persistent data within a Revit document.
Public class | ElementArray | An array that contains element objects.
Public class | ElementArrayIterator | An iterator to an element array.
Public class | ElementBinding | A base class for all types of binding that attach to an element.
ElementCategoryFilter | A filter used to match elements by their category.
ElementClassFilter | A filter used to match elements by their class.
ElementDesignOptionFilter | A filter used to find elements contained within a particular design option.
Public class | ElementFilter | A base class for a type of filter that accepts or rejects elements based upon criteria.
Public class | ElementId | The ElementId object is used as a unique identification for an element within a single project.
Public class | ElementIdParameterValue | A class that holds a ElementId value of a parameter element.
Public class | ElementIdSetFilter | A filter wrapping a set of elements.
Public class | ElementIntersectsElementFilter | A filter to find elements that intersect the solid geometry of a given element.
Public class | ElementIntersectsFilter | A base class for filters used to match elements which intersect with geometry.
ElementIntersectsSolidFilter | A filter to find elements that intersect the given solid geometry.
ElementIsCurveDrivenFilter | A filter used to match elements which are curve driven.
Public class | ElementIsElementTypeFilter | A filter used to match elements which are ElementTypes.
ElementLevelFilter | A filter used to match elements by their associated level.
Public class | ElementLogicalFilter | A filter used to logically combine two or more filters.
Public class | ElementMulticategoryFilter | A filter used to find elements whose category matches any of a given set of categories.
Public class | ElementMulticlassFilter | A filter used to match elements by their class, where more than one class of element may be passed.
Public class | ElementNode | A render node that represents an element, including the host document containing the element.
ElementOwnerViewFilter | A filter used to match elements which are owned by a particular view.
ElementParameterFilter | A filter used to match elements by one or more parameter filter rules.
Public class | ElementPhaseStatusFilter | A filter used to match elements that have a given phase status on a given phase.
Public class | ElementQuickFilter | A base class for a type of filter that operates on element records.
Public class | ElementRecord | A record in the Revit database representing an element.
ElementSet | A set that contains element objects.
Public class | ElementSetIterator | An iterator to an element set.
Public class | ElementSlowFilter | A base class for a type of filter that operates on expanded elements.
Public class | ElementStructuralTypeFilter | A filter used to find elements matching a structural type.
Public class | ElementTransformUtils | A collection of utilities allowing transformation of elements (e.g. move, rotate, mirror and copy).
Public class | ElementType | Base class for all Types within Autodesk Revit.
ElementWorksetFilter | A filter used to match elements which reside in a given workset.
Public class | ElevationMarker | ElevationMarkers either host elevation ViewSection views or view references.
Public class | Ellipse | A whole or partial ellipse.
Public class | EvaluatedParameter | Hold the evaluated ParameterValue and Definition of a parameter.
ExclusionFilter | A filter used to exclude a set of elements automatically.
Public class | ExportDGNSettings | This element contains DGN export settings which are saved in a Revit document.
Public class | ExportDWGSettings | This element contains DWG/DXF export settings which are saved in a Revit document.
Public class | ExportFontInfo | A value used to represent the info stored in an ExportFontTable.
Public class | ExportFontKey | A key used to represent an item stored in an ExportFontTable.
Public class | ExportFontTable | A table supporting a mapping of Revit font names to font names that will be set in the target export format.
Public class | ExportFontTableIterator | An iterator to a set of font table.
Public class | ExportIFCCategoryInfo | Represents the mapped IFC information stored in the template.
Public class | ExportIFCCategoryKey | Represents a Revit category item stored in a template.
ExportLayerInfo | A value used to represent the info stored in the ExportLayerTable.
Public class | ExportLayerKey | A key used to represent an item stored in an ExportLayerTable.
Public class | ExportLayerTable | A table supporting a mapping of category and subcategory to layer name and other layer properties that will be set in the target export format.
Public class | ExportLayerTableIterator | An iterator to a set of Layer table.
Public class | ExportLinetypeInfo | A value used to represent the info stored in the ExportLinetypeTable.
Public class | ExportLinetypeKey | A key used to represent an item stored in an ExportLinetypeTable.
Public class | ExportLinetypeTable | A table supporting a mapping of linetypes in Revit to linetype names that will be set in the target export format.
Public class | ExportLinetypeTableIterator | An iterator to a set of line type table.
Public class | ExportLineweightInfo | A value used to represent the info stored in the ExportLineweightTable.
Public class | ExportLineweightKey | A key used to represent an item stored in an ExportLineweightTable.
Public class | ExportLineweightTable | A table supporting a mapping of line weights in Revit to line weight names that will be set in the target export format.
Public class | ExportLineweightTableIterator | An iterator to a set of line weight table.
Public class | ExportPatternInfo | A value used to represent the info stored in the ExportPatternTable.
Public class | ExportPatternKey | A key used to represent an item stored in an ExportPatternTable.
Public class | ExportPatternTable | A table supporting a mapping of FillPatterns in Revit to pattern names that will be set in the target export format.
Public class | ExportPatternTableIterator | An iterator to a set of Pattern table.
Public class | ExportPDFSettings | Settings for PDF export
Public class | ExportUtils | This class provides utilities related to document export.
ExternalDefinition | The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
Public class | ExternalDefinitionCreationOptions | An option class used for creating a new shared parameter definition, including options such as name, type, visibility, Guid description and modifiable flag.
Public class | ExternalDefinitions | Supports the creation of new shared parameters definitions.
Public class | ExternalFileReference | A class that contains the details of a reference to a file outside of a given document.
Public class | ExternalFileUtils | A utility class containing functions related to external file references.
Public class | ExternalGeometryId | This class represents an identifier for geometry from external sources.
Public class | ExternallyTaggedBRep | An ExternallyTaggedSolid can hold any shape created by BRepBuilder.
Public class | ExternallyTaggedGeometryObject | Base class for ExternallyTaggedGeometryObject and ExternallyTaggedSolid.
Public class | ExternallyTaggedGeometryValidation | Provides validation for geometry to be stored in an ExternallyTaggedGeometry.
Public class | ExternallyTaggedNonBRep | This class is used to create an externally tagged geometry object.
Public class | ExternallyTaggedNonBReps | Holds a collection of ExternallyTaggedNonBRep instances.
Public class | ExternalResourceBrowserData | Represents a collection of external resources and external resource folders to be presented as the content of a folder in the file browser in Revit.
Public class | ExternalResourceLoadContent | This class contains the actual content data and other results of an external resource load operation that are returned by an IExternalResourceServer to Revit.
Public class | ExternalResourceLoadContext | This class contains data describing the context related to an external resource load operation.
Public class ExternalResourceLoadData

This class contains the input and output data resulting from invoking an IExternalResourceServer's LoadResource method.

After the call to LoadResource, the resulting ExternalResourceLoadData will be passed into IExternalResourceServer.HandleLoadResourceResults() so that appropriate UI can be displayed.

Server providers can inspect the ExternalResourceLoadData to get an ExternalResourceLoadContent object of the subclass appropriate to the external resource. The class also contains a copy of the ExternalResourceReference, and information about the context of the load operation.

Public class | ExternalResourceMatchOptions | Represents match options used to filter external resources when listing them from external resource server.
Public class | ExternalResourceReference | This class identifies an external resource provided by an IExternalResourceServer.
Public class | ExternalResourceServerExtensions | An object that contains overrides for external resource-specific methods.
Public class | ExternalResourceServerUtils | Contains utilities related to external resource server.
Public class | ExternalResourceServiceUtils | Contains utilities related to external resource service.
Public class | ExternalResourceSubFolder | Data that describes a remote folder to be shown in the file browser dialog
Public class | ExternalResourceType | A type class used to distinguish between different kinds of external resource.
Public class | ExternalResourceTypes | Provides a container of all Revit built-in ExternalResourceType instances.
Public class | ExternalResourceTypesBuiltInExternalResourceTypes | A collection of ids of the ExternalResourceTypes provided by Revit.
Public class | ExternalResourceUtils | A utility class containing functions related to external resource references.
Public class | Extrusion | A extrusion solid or void form.
Public class | ExtrusionAnalyzer | This geometry utility allows you to attempt to "fit" a given piece of geometry into the shape of an extrusion.
Public class | ExtrusionRoof | Represents some kinds of Extrusion Roofs.
Public class | FabricationAncillaryUsage | Structure that holds information about the usage of a fabrication ancillary
Public class | FabricationConfiguration | This element contains the information about the fabrication configuration settings used by the project.
Public class | FabricationConfigurationInfo | Represents an MEP object that holds the properties of an MEP fabrication configuration.
Public class | FabricationConnectorInfo | Fabrication connector information.
Public class | FabricationDimensionDefinition | Represents the definition of a single fabrication pattern dimension. Together all dimensions represent the parametric definition of the fabrication part.
Public class | FabricationHostedInfo | The fabrication hosted element information.
Public class | FabricationItemFile | This class holds information about the item file, including whether it is already loaded from disk into Revit.
Public class | FabricationItemFolder | A fabrication item folder that can contain sub folders and access to the FabricationItemFiles contained within.
Public class | FabricationPart | Represents a fabrication component in the Autodesk Revit MEP product.
Public class | FabricationPartType | Represents a fabrication component type in the Autodesk Revit MEP product.
Public class | FabricationRodInfo | The rod information of the fabrication part.
Public class | FabricationService | This object contains information about a fabrication service.
Public class | FabricationServiceButton | The object contains information about a fabricaton button.
Public class | FabricationServiceSettings | Represents the settings related to the fabrication services.
Public class | FabricationVersionInfo | The object contains versioning information about fabrication data.
Public class | Face | A bounded face of a 3d solid or open shell.
Public class | FaceArray | An array that contains faces.
Public class | FaceArrayIterator | An iterator to a face array.
Public class | FaceDetailNode | A base class of output nodes that represent face edges and face silhouettes.
Public class | FaceEdgeNode | An output node that represents a Face edge.
Public class | FaceNode | An output node that represents a Face.
Public class | FaceSecondDerivatives | Contains second partial derivatives of a face at a specified point.
Public class | FaceSilhouetteNode | An output node that represents a Face edge.
Public class | FaceSplitter | Represents an element that splits a face.
Public class | FacetingUtils | This class is used to convertTrianglesToQuads a triangulated structure into a structure in which some of the triangles have been consolidated into quadrilaterals.
Public class | FaceToposolid | An object that represents a face-based Toposolid within the Autodesk Revit project.
Public class | FaceWall | A wall attached to a non-vertical massing face.
Public class | FailureDefinition | Defines persistent information about a failure.
Public class | FailureDefinitionAccessor | A class that provides access to the details of a FailureDefinition after the definition has been defined.
Public class | FailureDefinitionId | The unique identifier of a FailureDefinition.
Public class | FailureDefinitionRegistry | The global registry for all FailureDefinitions in the Revit session.
Public class | FailureHandlingOptions | Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended.
Public class | FailureMessage | Represents a message describing a failure of an operation in Revit.
Public class | FailureMessageAccessor | Restricted accessor for FailureMessage.
Public class | FailureMessageKey | A unique key assigned to each posted failure message
Public class | FailureResolution | Defines a resolution for a failure.
Public class | FailuresAccessor | An interface class that provides access to failure information posted in a document and methods to resolve these failures.
Family | An element that represents a custom family (not a system family) in Autodesk Revit.
FamilyElementVisibility | Provides access to the visibility parameters of family elements in family document.
FamilyInstance | This object represents a single instance of a family type, such as a single I beam.
FamilyInstanceFilter | A filter used to find elements that are family instances of the given family symbol.
Public class | FamilyManager | The family manager object to manage the family types and parameters in family document.
Public class | FamilyParameter | The family parameter object.
Public class | FamilyParameterSet | A set that contains FamilyParameter objects.
Public class | FamilyParameterSetIterator | An iterator to a FamilyParameter set.
Public class | FamilyPointLocation | Data corresponding to the point locations in certain types of Family Symbols.
Public class | FamilyPointPlacementReference | This object represents data corresponding to the placement references in a certain types of Family Instances (see examples listed below).
Public class | FamilySizeTable | Contains size information for a family.
Public class | FamilySizeTableColumn | Contains column information for a FamilySizeTable.
Public class | FamilySizeTableErrorInfo | Error information generated from the CSV file import of a FamilySizeTable.
Public class | FamilySizeTableManager | Manages importing, exporting, and querying size data through the FamilySizeTable class.
FamilySymbol | An element that represents a single type with a Family.
Public class | FamilySymbolFilter | A filter used to find all family symbols of the given family.
Public class | FamilySymbolProfile | Represents a family symbol based profile for sweep or swept blend elements.
Public class | FamilyThermalProperties | A class that contains thermal properties for specific types of families (doors, windows, and curtain wall panels).
Public class | FamilyType | The family type object provides read access to the values of family parameters for this type.
Public class | FamilyTypeSet | A set that contains FamilyType objects.
Public class | FamilyTypeSetIterator | An iterator to a FamilyType set.
Public class | FamilyUtils | Contains utilities related to family operations.
Public class | FBXExportOptions | 3D-Studio Max (FBX) Export options.
Public class | FilePath | This class represents a path on a disk or network location, but not a path to a Revit server location.
Public class | FilledRegion | A filled region element.
Public class | FilledRegionType | A filled region attributes element. Note, the forground pattern color is stored in the parent class
Public class | FillGrid | Represents a grid line in a fill pattern.
Public class | FillPattern | Represents a fill pattern object.
Public class | FillPatternElement | An element that represents a fill pattern.
Public class | FilterableValueProvider | Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.
Public class | FilterCategoryRule | A filter rule that matches elements of a set of categories.
Public class | FilterDoubleRule | A filter rule that operates on double-precision numeric values in a Revit project.
Public class | FilteredElementCollector | This class is used to search, filter and iterate through a set of elements.
Public class | FilteredElementIdIterator | An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
Public class | FilteredElementIterator | An iterator to a set of elements filtered by the settings of a FilteredElementCollector.
Public class | FilteredWorksetCollector | This class is used to search, filter and iterate through a set of worksets.
Public class | FilteredWorksetIdIterator | An iterator to a set of workset ids filtered by the settings of a FilteredWorksetCollector.
Public class | FilteredWorksetIterator | An iterator to a set of worksets filtered by the settings of a FilteredWorksetCollector.
Public class | FilterElement | The base class for filter elements in the document.
Public class | FilterElementIdRule | A filter rule that operates on ElementId values in a Revit project.
Public class | FilterGlobalParameterAssociationRule | A filter rule that operates on global parameters ElementId values in a Revit project.
Public class | FilterIntegerRule | A filter rule that operates on integer values in a Revit project.
Public class | FilterInverseRule | A filter rule that inverts the boolean values returned by the rule it contains.
Public class | FilterNumericEquals | Tests whether numeric values from the document are equal to a certain value
Public class | FilterNumericGreater | Tests whether numeric values from the document are greater than a certain value
Public class | FilterNumericGreaterOrEqual | Tests whether numeric values from the document are greater than or equal to a certain value
Public class | FilterNumericLess | Tests whether numeric values from the document are less than a certain value
Public class | FilterNumericLessOrEqual | Tests whether numeric values from the document are less than or equal to a certain value
Public class | FilterNumericRuleEvaluator | Base for all classes that compare numeric values from Revit to a user-supplied filter value.
Public class | FilterNumericValueRule | Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons
Public class | FilterOperatorAndTextString | An instance of this class holds a filter operator and a text string that denotes the operator in a particular context. For example, the text string for ScheduleFilterType::LessThan may be "is less than" for a filter rule based on a parameter with numerical values or "is below" for a filter rule based on a parameter representing a Level.
Public class | FilterRule | Defines a boolean operation that can be used to cull elements from a document.
Public class | FilterStringBeginsWith | Tests whether string values from the document begin with a certain string.
Public class | FilterStringContains | Tests whether string values from the document contain a certain string.
Public class | FilterStringEndsWith | Tests whether string values from the document end with a certain string.
Public class | FilterStringEquals | Tests whether string values from the document match a certain string.
Public class | FilterStringGreater | Tests whether string values from the document would sort after a certain string.
Public class | FilterStringGreaterOrEqual | Tests whether string values from the document would sort after or match a certain string.
Public class | FilterStringLess | Tests whether string values from the document would sort before a certain string.
Public class | FilterStringLessOrEqual | Tests whether string values from the document would sort before or match a certain string.
Public class | FilterStringRule | A filter rule that operates on string values in a Revit project.
Public class | FilterStringRuleEvaluator | Base for all classes that compare string values from Revit to a user-supplied filter value
Public class | FilterValueRule | A rule that filters on a particular value of an element.
Floor | An object that represents a Floor within the Autodesk Revit project.
FloorType | An object that specifies the type of a floor in Autodesk Revit.
Public class | FolderItemInfo | Contains data for each folder item in the organization settings of the project browser including folder parameter Id and folder name.
Public class | FootPrintRoof | Represents kinds of FootPrintRoofs.
Public class | ForgeTypeId | This class holds a string that uniquely identifies a Forge schema.
Public class | Form | An object that represents a Form within the Autodesk Revit Massing Family.
Public class | FormArray | An array that contains form objects.
Public class | FormArrayIterator | An iterator to a form array.
Public class | FormatOptions | Options for formatting numbers with units.
FormattedText | FormattedText is used to create, edit and format text in a TextNote or to query the text and format properties of a TextNode
Public class | FormatValueOptions | Options for formatting numbers with units into strings.
Public class | FormulaManager | A class to access and query information about formula engine in Revit models.
Public class | FormUtils | Define Form utility functions
Public class | Frame | A Frame comprises three vectors at a base point in 3D space.
Public class | FreeFormElement | A Free Form Element that contains non-parametric geometry created from an input solid outline.
Public class | GBXMLExportOptions | Green-Building XML Export options.
Public class | GBXMLImportOptions | Import options for Green-Building XML format.
Public class | GenericForm | Provides access to the Generic Form model in Autodesk Revit.
Public class | GenericImportOptions | Generic Import options.
Public class | GeomCombination | An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.
Public class | GeomCombinationSet | A set that contains GeomCombination objects.
Public class | GeomCombinationSetIterator | An iterator to a GeomCombination set.
Public class | GeometryCreationUtilities | A utility that allows construction of basic solid shapes.
Public class | GeometryElement | Geometric representation of an element.
Public class | GeometryInstance | An instance of another element (symbol), specially positioned by this element.
Public class | GeometryObject | The common base class for all geometric primitives.
Public class | GlobalParameter | This class represents a GlobalParameter element in Revit.
GlobalParametersManager | A class to access and query information about global parameters in Revit models.
Public class | GradientBackgroundSettings | Represents the view gradient background settings.
Public class | GraphicsStyle | The graphics style instance in Autodesk Revit document.
Grid | Represents a single grid line within Autodesk Revit.
Public class | GridType | An object that represents a grid type.
Group | An element representing a single instance of a group of elements that may be placed many times in a project or family.
Public class | GroupLoadOptions | A class containing options for loading a group from a file.
Public class | GroupNode | A node that represents set of individual elements grouped together in some form, such as an instance of a family or linked Revit file, or an instance of a part of symbol's geometry.
Public class | GroupSet | An set that contains groups.
Public class | GroupSetIterator | An iterator to a group set.
GroupType | An element representing a group of elements that may be placed many times in a project or family.
Public class | GroupTypeId | This class contains constants identifying parameter groups.
Public class | GuidEnum | Base class of all GUID-based enum classes.
Public class | HasNoValueFilterRule | Tests whether an element's parameter doesn't have a value.
Public class | HasValueFilterRule | Tests whether an element's parameter has a value.
HermiteFace | A cubic hermite spline face of a 3d solid or open shell.
Public class | HermiteSpline | A Hermite spline.
Public class | HermiteSplineTangents | This class indicates tangency at the start, the end, or both ends of the curve.
Public class | HermiteSurface | A Hermite Surface.
Public class | HomeCamera | A structure that contains information about the camera and view for the Home view orientation stored in the model.
Public class | HostedSweep | An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.
Public class | HostedSweepType | An object that represents the attributes for sweep host objects in Autodesk Revit.
Public class | HostObjAttributes | An object that represents characteristics of several kinds of type.
Public class | HostObject | A base class that provides support for all objects that can host other objects, such as walls roofs, and floors.
Public class | HostObjectUtils | These are generic host object utilities.
Public class | IFCBuiltInCategoryKey | A key used to represent an item stored in a template.
Public class | IFCCategoryTemplate | Represents an element that contains an IFC category mapping template stored in a Revit document.
Public class | IFCExportOptions | IFC Export options.
Public class | ImageBackgroundSettings | Represents the rendering image background settings.
Public class | ImageExportOptions | This class defines options for exporting views and sheets as an image.
Public class | ImageInstance | An element that represents an instance of an image placed in a view
Public class | ImagePlacementOptions | ImagePlacementOptions are used to describe where an ImageInstance should be placed in a view
Public class | ImageType | Represents a type containing a raster based image. ImageInstances of this type can be placed in 2D views, sheets, and schedules.
Public class | ImageTypeOptions | Represents the options used in ImageType::Create(Document, ImageTypeOptions) and ImageType.ReloadFrom(ImageTypeOptions) methods.
Public class | ImageView | Class for ImageView views
Public class | ImportIFCOptions | Provides access to settings that control linking and opening IFC files.
Public class | ImportInstance | An element created during either import or link operation. It is an instance of CADLinkType.
Public class | ImportOptions3DM | The import options used to import 3DM format files.
Public class | InCanvasControlData | Represents a collection of data which is used by [!:Autodesk::Revit::DB::TemporaryGraphicsManager] to create and update an in-canvas control.
Public class | IndependentTag | Represents tag annotations in Revit. getBBoxCorers in MultipleAlignmentHelper needs access to some protected members.
Public class | InsertableObject | A base class you all types that are insertable.
Public class | InSessionPrintSetting | Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public class | InSessionViewSheetSet | Represents the in-session ViewSheetSet.
Public class | Instance | The base class for all instance objects.
InstanceBinding | The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
Public class | InstanceNode | An output node that represents an instance of a geometry. It can be an instance of FamilyInstance, or it can be and instance of a part of symbol's geometry.
Public class | InstanceVoidCutUtils | Utilities for cutting elements by unattached voids in family instances.
Public class | InsulationLiningBase | Acts as the base class for duct insulation, pipe insulation and duct lining elements.
Public class | IntegerParameterValue | A class that holds an Integer value of a parameter element.
Public class | IntegerRange | A class to define a range of a sequence of consecutive integer numbers
Public class | InternalDefinition | This object represents a parameter definition in an Autodesk Revit model.
Public class | InternalDefinitions | This object blocks attempts to create new internal definitions as they are not permitted.
Public class | InternalOrigin | A class representing the origin of internal coordinate system. Each Revit project contains one InternalOrigin.
Public class | IntersectingElementData | Stores information of an element that intersects with another element
Public class | IntersectionResult | This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
Public class | IntersectionResultArray | An array that can contain any type of object.
Public class | IntersectionResultArrayIterator | An iterator to a array.
Public class | JoinGeometryUtils | Utilities for joining and unjoining elements, and for managing the order in which elements are joined.
Public class | KeyBasedTreeEntries | A collection of KeyBasedTreeEntry objects that make up the key-based tree.
Public class | KeyBasedTreeEntriesIterator | An iterator to a set of KeyBasedTreeEntry objects.
Public class | KeyBasedTreeEntriesLoadContent | This class is used by IExternalResourceServers to return KeyBasedTreeEntries data to Revit when their LoadResource method is invoked.
Public class | KeyBasedTreeEntriesLoadResults | This class contains the results and status information regarding an attempt to load the KeyBasedTreeEntries from an External Resource.
Public class | KeyBasedTreeEntry | A key-based tree entry, containing the key, parent key, and children keys (if applicable).
Public class | KeyBasedTreeEntryError | This class contains information about a problem encountered while creating a KeyBasedTreeEntries object.
Public class | KeyBasedTreeEntryTable | KeyBasedTreeEntryTable represents the collection of key-based tree entries for a document.
Public class | KeynoteEntries | A collection of KeynoteEntry objects that make up the keynote table.
Public class | KeynoteEntry | Represents an entry in the keynote table, containing the key value, keynote text, and parent key (if applicable).
Public class | KeynoteTable | KeynoteTable represents the collection of keynotes (KeynoteEntries) for a document.
Public class | LabelUtils | Used to obtain user-visible names for enums.
Public class | LayerModifier | A modifier used to designate extra strings to appear in the exported layer name.
Public class | LayoutRule | The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
LayoutRuleClearSpacing | This class indicate the layout rule of a Beam System is Clear-Spacing.
LayoutRuleFixedDistance | This class indicate the layout rule of a Beam System is Fixed-Distance.
LayoutRuleFixedNumber | This class indicate the layout rule of a Beam System is Fixed-Number.
LayoutRuleMaximumSpacing | This class indicate the layout rule of a Beam System is Max-Spacing.
Public class | Leader | A leader object that can be attached to annotation elements such as text notes.
Public class | LeaderArray | An array that can contain any number of leaders.
Public class | LeaderArrayIterator | An iterator to an array of leaders.
Level | Represents a Level within Autodesk Revit.
Public class | LevelAssociationData | This class holds information related to Level.
Public class | LevelType | An object that represents a Level type.
Public class | LightNode | This class represents a Light element in a model-exporting process.
Public class | Line | A line in space.
Public class | LineAndTextAttrSymbol | An object that represents a dimension style.
Public class | LinearArray | An object that represents an Array created linearly within the Revit project.
Public class | LinearDimension | LinearDimString
Public class | LinePattern | Represents a line pattern definition.
Public class | LinePatternElement | An element that represents a line pattern.
Public class | LinePatternSegment | Represents a segment in a line pattern.
Public class | LineProperties | A structure that has access to the pen properties of lines/curves that are currently being drawn/exported via an export context during a custom export process.
Public class | LineSegment | An output node that represents a tessellated line segment.
Public class | LinkConversionData | This class contains the information necessary to re-create a Revit document from an external source.
Public class | LinkElementId | LinkElementId represents an element in a linked document.
Public class | LinkLoadContent | This class is used by IExternalResourceServers to return Link data to Revit when their LoadResource method is invoked. It also contains additional information used by IExternalResourceUIServers to display link load status results to the user.
Public class | LinkLoadResult | This class stores the results of trying to load a single linked model.
Public class | LinkNode | An output node that represents a linked Revit document.
Public class | LinkOperations | This class is used to extend the IExternalResourceServer interface with methods to support operations for elements that are LinkTypes.
Public class | LoadedFamilyIntegrityCheck | Functions for checking the integrity of loaded families.
Location | Provides location functionality for all elements.
Public class | LocationCurve | Provides location functionality for all elements that are based upon a curve.
LocationPoint | Provides location functionality for all elements that have a single insertion point.
LogicalAndFilter | A filter that contains a set of filters. The filter passes when all filters in the set pass.
Public class | LogicalOrFilter | A filter that contains a set of filters. The filter passes when any filter in the set passes.
Public class | MassInstanceUtils | A static class that contains methods for processing curves driven by points.
Material | Represents a material element within an Autodesk Revit project.
Public class | MaterialNode | This class represents a change of material during a model-exporting process.
Public class | MathComparisonUtils | This class contains a set of mathematical utilities to compare doubles, using the internal tolerance.
Public class | MEPAnalyticalConnection | Represents an analytical element that connects mechanical equipment to piping network.
Public class | MEPAnalyticalConnectionType | Represents an analytical connection type between mechanical equipment and piping network.
Public class | MEPCalculationServerInfo | a struct to hold the information about a MEP calucation servers
Public class | MEPConnectorInfo | MEP connector information.
Public class | MEPCurve | A curve object for duct or pipe blend elements.
Public class | MEPCurveType | The base type class for MEP curves, such as ducts, pipes, cable trays and conduits.
Public class | MEPFamilyConnectorInfo | MEP family connector information.
Public class | MEPModel | Supports all MEP models that are persistent within the Autodesk Revit project.
Public class | MEPSize | Stores the basic size information for an MEP duct, pipe, cable tray, or conduit.
Public class | MEPSupportUtils | General utility methods for the Autodesk Revit MEP Supporting components.
Public class | MEPSystem | A system in the Autodesk Revit MEP product.
Public class | MEPSystemType | A system type in the Autodesk Revit MEP product.
Public class | Mesh | A triangular mesh.
Public class | MeshFromGeometryOperationResult | Describes what TessellatedShapeBuilder has built.
Public class | MeshTriangle | One triangle of a mesh.
Public class | ModelArc | Represents a ModelArc within Autodesk Revit.
Public class | ModelCurve | A model element that exists in 3D space and is visible in all views of a Revit project.
Public class | ModelCurveArrArray | An array that can contain any type of object.
Public class | ModelCurveArrArrayIterator | An iterator to a array.
Public class | ModelCurveArray | An array that contains model curves.
Public class | ModelCurveArrayIterator | An iterator to a model curve array.
Public class | ModelCurveNode | A base class of output nodes that represent various model curves.
Public class | ModelEllipse | Represents a ModelEllipse within Autodesk Revit.
Public class | ModelHermiteSpline | Represents a ModelHermiteSpline within Autodesk Revit.
Public class | ModelLine | Represents a ModelLine within Autodesk Revit.
Public class | ModelNurbSpline | Represents a ModelNurbSpline within Autodesk Revit.
Public class | ModelPath | A path to a file stored on a disk or on a server.
Public class | ModelPathUtils | Utility functions using ModelPaths
Public class | ModelText | A model text element in an Autodesk Revit family document.
Public class | ModelTextType | A model text type symbol in the Autodesk Revit Family document.
Public class | Mullion | Represents a CurtainGrid within Autodesk Revit.
Public class | MullionType | An object that represents a mullion type.
Public class | MullionTypeSet | A set that contains mullion types.
Public class | MullionTypeSetIterator | An iterator to a mullion type set.
Public class | MultipleValuesIndicationSettings | MultipleValuesIndicationSettings is an element which contains project-wide settings for multiple values indication in Properties Palette and schedules.
Public class | MultiReferenceAnnotation | Multi-reference annotations are annotations pointing to more than one reference, consisting of a dimension and associated tag.
Public class | MultiReferenceAnnotationOptions | Options which control the creation of MultiReferenceAnnotations.
Public class | MultiReferenceAnnotationType | The type for MultiReferenceAnnotation.
Public class | MultiSegmentGrid | This element acts as a multi-segmented Grid. The individual grids associated to the MultiSegmentGrid behave as a single unit and all share the same text. They inherit their type (GridType) from the MultiSegmentGrid.
Public class | NamingUtils | A collection of utilities related to element naming.
Public class | NavisworksExportOptions | Options which controls the Navisworks export.
Public class | NestedFamilyTypeReference | A proxy element representing a nested family type.
Public class | NullParameterValue | A class that represent an empty (null) value of a parameter element.
NumberingSchema | A class to support assigning numbers to elements of a particular kind for the purpose of tagging and scheduling them.
Public class | NumberingSchemaType | A type for identifying a NumberingSchema of a particular kind.
Public class | NumberingSchemaTypes | Provides a container of all Revit built-in NumberingSchemaType instances.
Public class | NumberingSchemaTypesStructuralNumberingSchemas | A collection of types of built-in Numbering Schemas that are used for numbering structure elements.
Public class | NumberSystem | An annotation that consists of a series of numeric tags attached to and describing a host element.
Public class | NumericRevisionSettings | Contains settings that apply to Revisions with the Numeric RevisionNumberType.
Public class | NurbSpline | A nurb spline.
Public class | NurbsSurfaceData | A class used to represent the definition of a NURBS surface.
Public class | OBJExportOptions | The export options used by exporting to OBJ file format.
Public class | OBJImportOptions | The import options used to import OBJ format files.
Public class OffsetSurface A mathematical representation of an offset surface.

Definition of offset surface, quoted from the STEP manual ISO 10303-42:2000(E): This is a procedural definition of a simple offset surface at a normal distance from the originating surface. Distance may be positive, negative, or zero to indicate the preferred side of the surface. The offset surface takes its parametrization directly from that of its basis surface, corresponding points having identical parameter values. The offset surface is parametrized as O(u, v) = S(u, v) + d*N(u, v), where N(u, v) is the oriented unit normal vector of the basis surface S at parameter value (u, v), and d is the signed offset distance.

In Revit, we restrict the types of basis surfaces for which an OffsetSurf can be created for the following reasons:

  • The offsets of Plane, CylindricalSurface, ConicalSurface and RevolvedSurface are of the same type as the original surface and they have closed form solutions. So those surfaces are not taken as basis surfaces of the OffsetSurface class. That leaves HermiteSurface and RuledSurface.
  • As a Revit surface, we require the OffsetSurface to be C2 continuous. That implies that the basis surface should be C3 continuous. That is because the OffsetSurface evaluation involves the normal of the basis surface and the order of continuity of the normal is one less than that of the surface.
  • HermiteSurfaces in general are not C3 continuous, even though some of them can be. A RuledSurface will be C3 continuous if its parametric curves are C3 continuous. So we don't allow a HermiteSurface to be a basis surface and allow only RuledSurfaces whose parametric curves are C3 continuous as basis surfaces of the OffsetSurface class.

The OffsetSurface class will own a copy of the basis surface and use it for many of its methods, which may implicitly assume that the OffsetSurface and the basis surface have the same envelope. So we keep the envelopes of the OffsetSurf and its basis surface in sync.

Opening | An opening in an Autodesk Revit project or family document.
Public class | OpenOptions | This class contains options available for opening a document from disk.
Public class | OptionalFunctionalityUtils | A collection of utilities that can be used to determine if a particular set of functionality is installed and available.
Public class | Options | User preferences for parsing of geometry.
Public class | OrdinateDimensionSetting | Represents a collection of Ordinate Dimension settings that can be associated to an ordinate DimensionType.
Public class | Outline | Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.
Public class | OverrideGraphicSettings | Settings to override display of elements in a view.
Public class | Panel | This object represents a curtain panel.
Public class | PanelType | An object that represents a curtain panel type.
Public class | PanelTypeSet | A set that contains panel types.
Public class | PanelTypeSetIterator | An iterator to a panel type set.
Public class | PaperSize | An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
Public class | PaperSizeSet | A set that can contain any number of paper size objects.
Public class | PaperSizeSetIterator | An iterator to a set of paper size objects.
Public class | PaperSource | An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
Public class | PaperSourceSet | A set that can contain any number of paper source objects.
Public class | PaperSourceSetIterator | An iterator to a set of paper source objects.
Public class | Parameter | The parameter object contains the value data assigned to that parameter.
Public class | ParameterDownloadOptions | An option class used for downloading parameters from the Parameters Service.
Public class | ParameterElement | An Element that stores a user-defined parameter.
ParameterFilterElement Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.
Public class | ParameterFilterRuleFactory | Contains functions that create appropriate FilterRule objects based on the parameters given.
Public class | ParameterFilterUtilities | Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.
Public class | ParameterMap | A map that can contain a mapping of a parameter name (a String) to a parameter.
Public class | ParameterMapIterator | An iterator to a map relating a parameter name (the key, a String) to a parameter.
Public class | ParameterSet | A set that contains parameters.
Public class | ParameterSetIterator | An iterator to a parameter set.
Public class | ParameterTypeId
Public class | ParameterUtils | A utility class of functions related to parameters.
Public class | ParameterValue | A class that holds a value of a parameter element.
Public class | ParameterValuePresenceRule | Tests whether an element's parameter has a value or not.
Public class | ParameterValueProvider | Gets the value of a parameter from any element passed to GetStringValue, GetDoubleValue, GetIntegerValue, or GetElementIdValue.
Public class | Part | This element represents a part of another element.
Public class | PartMaker | PartMaker is an element which takes some source elements (e.g., a wall with all its layers) and creates one or more Parts out of it. The logic according to which these Parts are created is non-trivial and PartMaker uses various PartMakerMethods which represents these logics. This element manages the strategy to make Part elements for one or more original elements.
Public class | PartMakerMethodToDivideVolumes | By-References dividing strategy used by PartMaker element. TODO_REFACTOR("LegacyMechanismOfMovingElements") returns true if - the Host Elements are not floors or walls - OR - the Host Elements that are referenced by this PartMaker are floors or walls - transformation has already been applied on those Host Elements
Public class | PartUtils | General Part utility methods
Public class | Path3d | Provides access to the Generic 3D path object in Autodesk Revit.
Public class | PDFExportOptions | Options for PDF export
PerformanceAdviser | The tool to report performance problems in a given document.
Public class | PerformanceAdviserRuleId | The unique identifier of a PerformanceAdviserRule
Public class | PerformanceAdviserRules | Provides a container of all Revit built-in PerformanceAdviserRuleId instances.
Public class | Phase | Represents a phase in the life of a building.
Public class | PhaseArray | An array that contains phase objects.
Public class | PhaseArrayIterator | An iterator to a phase array.
Public class | PhaseFilter | Represents an phase filter within Autodesk Revit.
PlanarFace | A bounded face of a 3d solid or open shell.
Public class | PlanCircuit | An object that represents an enclosed area in a plan view within the Autodesk Revit project.
Public class | PlanCircuitSet | A set that can contain any number of plan circuit objects.
Public class | PlanCircuitSetIterator | An iterator to a set of plan circuit objects.
Plane | A Planar surface.
Public class | PlanTopology | An object that represents a Plan Topology within the Autodesk Revit project.
Public class | PlanTopologySet | A set that can contain any number of plan topology objects.
Public class | PlanTopologySetIterator | An iterator to a set of plan topology objects.
PlanViewRange | This class represents the view range of a plan view or a plan region. It records the element ids of the levels which a plane is relative to and the offset of each plane from that level.
Public class | Point | A 3D point.
Public class | PointCloudInstance | Represents a single instance of a point cloud in the Revit document.
Public class | PointCloudType | Represents a type of point cloud loaded into a Revit document. Each PointCloudType maps to a single file or identifier (depending upon the type of Point Cloud Engine which governs it).
Public class | PointElementReference | Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.
Public class | PointLocationOnCurve | Defines the measurement parameters necessary to create a point at a specific location on a curve.
Public class | PointNode | An output node that represents a 3D point.
Public class | PointOnEdge | Define a ReferencePoint relative to a referenceable edge or curve on another element.
Public class | PointOnEdgeEdgeIntersection | Define a ReferencePoint at the intersection of two referenceable lines.
Public class | PointOnEdgeFaceIntersection | Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.
Public class | PointOnFace | Define a ReferencePoint relative to a Face.
Public class | PointOnPlane | Define a ReferencePoint relative to a planar reference.
Public class | PointRelativeToPoint | Represents a point placed relative to another point.
Public class | PolyLine | A polyline.
Public class | PolylineNode | An output node that represents a 3D polyline.
Public class | PolylineSegments | An output node that represents a tessellated polyline segments.
Public class | PolymeshFacet | A class representing one triangular piece - a facet - in a polymesh topology.
Public class | PolymeshTopology | A class representing topology of a polymesh.
PrimaryDesignOptionMemberFilter | A filter used to find elements contained in any primary design option of any design option set.
Public class | PrimarySizeCriterion | This class contains a size criterion for a RoutingPreferenceRule.
PrintManager | The PrintManager object is used to configure the global print settings.
Public class | PrintParameters | An object that contains settings used for printing the document.
Public class | PrintSetting | Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public class | PrintSetup | Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Profile | A geometric profile consisting of a loop of curves.
ProjectInfo | An object that represents a Project Information within the Autodesk Revit project.
ProjectLocation | A representation of a specific instance and location of the current project.
Public class | ProjectLocationSet | An set that contains project locations.
Public class | ProjectLocationSetIterator | An iterator to a project location set.
Public class | ProjectPosition | ProjectPosition is a class used to represent a geographical offset and rotation. It can be used to represent the position of a project.
Public class | PropertyLine | Represents kinds of PropertyLines.
Public class | PropertySetElement | An element that groups together a set of related parameters.
Public class | RadialArray | An object that represents an Array created along a circle arc within the Revit project.
Public class | RadialDimension | An object that represents an Radial Dimension within the Revit project.
Public class | Rectangle | Stores a set of four integers that represent the left, top, right and bottom of a rectangle.
Public class | Reference | A stable reference to a geometric object in a Revit model.
Public class | ReferenceableViewUtils | Utilities related to reference views such as reference sections and reference callouts.
Public class | ReferenceArray | An array that contains reference objects.
Public class | ReferenceArrayArray | An array that contains ReferenceArray objects.
Public class | ReferenceArrayArrayIterator | An iterator to a ReferenceArray array.
Public class | ReferenceArrayIterator | An iterator to a reference array.
ReferenceIntersector | A class used to find and return elements that intersect a ray created from an origin point and direction.
ReferencePlane | Represents a reference plane of Autodesk Revit.
Public class | ReferencePoint | A reference point in an Autodesk Revit family.
Public class | ReferencePointArray | An array that contains reference objects.
Public class | ReferencePointArrayIterator | An iterator to a reference array.
Public class | ReferenceWithContext | An object including a reference to a geometric object and related context, as instance transform etc.
Public class | RelinquishedItems | List of elements and worksets that were relinquished by the current user.
Public class | RelinquishOptions | Options to control behavior of relinquishing ownership of elements and worksets.
Public class | ReloadLatestOptions | Options to control behavior of pure reload latest (not part of synchronize with central).
Public class | ReloadSwapOutInfo | This object contains information about fabrication parts swapped out during reload.
Public class | RenderingImageExposureSettings | Represents the exposure settings of rendering.
Public class | RenderingQualitySettings | Represents the quality settings of rendering.
RenderingSettings | Represents the rendering settings for a 3d view.
Public class | RenderNode | This is the base class of all render nodes in a model-exporting process.
Public class | RepeaterBounds | Represents bounds of the array of repeating references in 0, 1, or 2 dimensions. (See RepeatingReferenceSource).
Public class | RepeaterCoordinates | Represents coordinates in the array of repeating references in 0, 1, or 2 dimensions.
Public class | RepeatingReferenceSource | Represents a collection of repeating references.
Public class | Revision | Represents a single revision in the project.
Public class | RevisionCloud | A RevisionCloud is a graphical "cloud" that can be displayed on a view or sheet to indicate where revisions in the model have occurred.
Public class | RevisionNumberingSequence | Defines the sequences by which numbers are assigned to Revisions.
Public class | RevisionSettings | Provides access to project-wide settings related to revisions.
Public class | RevitLinkGraphicsSettings | Settings to override display of Revit link in a view.
Public class | RevitLinkInstance | Represents an instance of a RevitLinkType.
Public class | RevitLinkOperations | This class is used to extend the IExternalResourceServer interface with methods to support operations specifically related to Revit links.
Public class | RevitLinkOptions | This class contains the options in use when creating or loading a Revit link.
Public class | RevitLinkType | This class represents another Revit Document ("link") brought into the current one ("host").
Public class | Revolution | A revolution solid or void form.
RevolvedFace | A revolved face of a 3d solid or open shell.
Public class | RevolvedSurface | A surface of revolution defined by a profile curve and a local coordinate system. The surface is obtained by rotating the curve around Z axis of the local coordinate system.
Public class | RoofBase | Represents all kinds of Roofs.
Public class | RoofType | Represents a specific type of roof.
Public class | RoutingCondition | RoutingCondition represents routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.
Public class | RoutingConditions | RoutingConditions contain routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.
Public class | RoutingCriterionBase | RoutingCriteriaBase is the base class for all routing criteria.
Public class | RoutingPreferenceManager | Manages default pipe segments, fittings, and selection criteria for a given MEPCurveType
Public class | RoutingPreferenceRule | A class representing a rule set in MEP routing preferences.
Public class | RPCNode | This class represents an RPC content in a model-exporting process.
RuledFace | A ruled face of a 3d solid or open shell.
Public class | RuledSurface | A ruled surface is created by sweeping a line between two profile curves or between a curve and a point (a point and a curve). Input curve(s) must be bounded or have natural bounds.
Public class | SATExportOptions | The export options used by exporting SAT format file. So far, there is no option in it.
Public class | SATImportOptions | The import options used to import SAT format files.
Public class | SaveAsOptions | This class contains options available for saving a document to disk with a new filename.
Public class | SaveOptions | This class contains options available for saving a document to disk.
Public class | SchedulableField | A non-calculated field eligible to be included in a schedule.
Public class | ScheduleDefinition | Settings that define the contents of a schedule.
Public class | ScheduleField | A field in a schedule.
Public class | ScheduleFieldId | The ScheduleFieldId object is used as a unique identification for a field in a schedule.
Public class | ScheduleFilter | A filter in a schedule.
Public class | ScheduleHeightsOnSheet | Heights information of a schedule on sheet.
Public class | ScheduleSheetInstance | An element that represents a particular placement of a schedule on a sheet.
Public class | ScheduleSortGroupField | A field that is used for sorting and/or grouping in a schedule.
Segment | This element represents a segment of an MEP curve object.
SelectionFilterElement | A filter element that stores an explicit list of ElementIds. Only elements whose ElementIds are in this list will pass the filter.
Public class | ServerPath | This class represents a path to a Revit Server location, rather than a location on disk or a network drive.
Settings | The settings object provides access to general components of the Autodesk Revit application, such as Categories.
Public class | ShapeBuilder | The base class for geometry builder classes.
ShapeImporter | A utility class that supports conversion of geometry stored in an external format into a Revit geometry objects.
Public class | SharedParameterApplicableRule | Tests whether an element supports a shared parameter.
Public class | SharedParameterElement | An element that stores the definition of a shared parameter which is loaded into the document.
Public class | SheetCollection | This class represents a sheet collection in Autodesk Revit.
SiteLocation | Contains the geographical location information for the project's site.
Public class | Sketch | Provides access to the Sketch in Autodesk Revit.
Public class | SketchBase | Provides access to the SketchBase in Autodesk Revit.
SketchEditScope | A SketchEditScope allows an application to create and maintain an editing session for a Sketch.
Public class | SketchedStairsCurveData | Sketched run/landing curves overrides with height and slope
SketchPlane | Represents a sketch plane or work plane.
Public class | SKPImportOptions | The import options used to import SKP format files.
Public class | SkyBackgroundSettings | Represents the rendering sky background settings.
Public class | SlabEdge | An object that represents a slab edge within the Autodesk Revit project.
Public class | SlabEdgeType | An object that represents the slab edge type in Autodesk Revit.
Public class | SlabShapeCrease | Represents a crease of a slab shape edited element.
Public class | SlabShapeCreaseArray | An array that can contain any number of creases used in Slab Shape Editing.
Public class | SlabShapeCreaseArrayIterator | An iterator to an array of creases used for Slab Shape Editing.
Public class | SlabShapeEditor | An object used for Slab Shape Editing.
Public class | SlabShapeVertex | Represents a vertex of a slab shape edited element.
Public class | SlabShapeVertexArray | An array that can contain any number of vertices used in Slab Shape Editing.
Public class | SlabShapeVertexArrayIterator | An iterator to an array of vertices used for Slab Shape Editing.
Solid | A 3d solid.
Public class | SolidCurveIntersection | This class represents the results of a calculation of intersection between a solid volume and a curve.
Public class | SolidCurveIntersectionOptions | This class contains the options used to calculate the intersection between a solid and a curve.
Public class | SolidGeometryOptions | A class containing optional information to control the geometry generation of the Solid by the SolidUtils routines.
Public class | SolidOptions | A class containing optional information to control the properties of the Solid generated by the GeometryCreationUtilities routines.
Public class | SolidOrShellTessellationControls | Controls various aspects of the triangulation produced by [!:SolidUtils::tessellateSolidOrShell()] method.
Public class | SolidSolidCutUtils | Exposes utilities which can cause one solid to cut another.
Public class | SolidUtils | Contains utility functions for solid operations.
Public class | SpacingRule | A rule for specifying a set of equidistant, parallel gridlines within a region.
Public class | SpanDirectionSymbol | Represents an instance of a Span Direction Symbol in Autodesk Revit.
Public class | SpatialElement | Represents an enclosed area or volume in the Revit model.
Public class | SpatialElementBoundaryOptions | Options that can be passed to a SpatialElementBoundaryCalculator to influence the results of the calculation.
Public class | SpatialElementBoundarySubface | SpatialElementBoundarySubface represents the geometry boundary information of spatial element.
Public class | SpatialElementCalculationLocation | The Spatial Element Calculation Location is used to specify the room/space where an element should be considered as placed.
Public class | SpatialElementCalculationPoint | SpatialElementCalculationPoint is used as the search point for family instances placement inside rooms and spaces.
Public class | SpatialElementDomainData | A base class for specific domain requirements for a spatial element.
Public class | SpatialElementFromToCalculationPoints | SpatialElementFromToCalculationPoints is used to specify the search points for a family instance which connects two rooms or spaces, such as a door or window. The points determine which room or space is considered the "from" and which is considered the "to".
SpatialElementGeometryCalculator | Use this class to calculate the geometry of a spatial element and obtain the relationships between the geometry and the element's boundary elements.
Public class | SpatialElementGeometryResults | The results of spatial element geometry calculation.
Public class | SpatialElementTag | A tag attached to a SpatialElement (room, space or area) in Autodesk Revit.
Public class | SpecTypeId | This class contains constants identifying specs.
Public class | SpecTypeIdBoolean | This class contains constants identifying Boolean specs.
Public class | SpecTypeIdInt | This class contains constants identifying integer specs.
Public class | SpecTypeIdReference | This class contains constants identifying reference specs.
Public class | SpecTypeIdString | This class contains constants identifying string specs.
Public class | SpecUtils | A utility class of functions related to specs. A spec describes a data type that parameters can hold.
SpotDimension | Object representing various types of SpotDimension
Public class | SpotDimensionType | A type element containing the properties of a spot elevation.
Public class | SSEPointVisibilitySettings | Represents the settings contained in the document associated to the point display of Floor, Roof and Toposolid. for serialization public api methods
StairsEditScope | StairsEditScope allows user to maintain a stairs-editing session.
Public class | StartingViewSettings | The initial view settings for a document dictate which view will initially be open when this model is opened. These settings are available for all Revit project documents.
Public class | StdPostedWarning | Support for Reviewable Warnings sent from AddOn.
Public class | STEPExportOptions | The export options used by exporting STEP format file.
Public class | STEPImportOptions | The import options used to import STEP format files.
Public class | STLExportOptions | The export options used by exporting STL format file.
Public class | STLImportOptions | The import options used to import STL format files.
Public class | StringParameterValue | A class that holds a String value of a parameter element.
Public class | StructuralAsset | Represents the properties of a material pertinent to structural analysis.
Public class | Subelement | An object that represents an element or a subelement within the Autodesk Revit project.
Public class | SubTransaction | Sub-transactions are objects that provide control over a subset of changes in a document.
SunAndShadowSettings | The SunAndShadowSettings class represents the sun control.
Public class | Surface | A mathematical representation of a surface.
Public class | Sweep | A sweep solid or void form.
Public class | SweepProfile | Represents a profile for sweep or swept blend elements.
Public class | SweptBlend | A swept blend solid or void form.
Public class | SweptProfile | Represents an extruded profile swept along a driving curve.
Public class | SymbolGeometryId | This class is used to identify a piece of geometry managed by a symbol element.
Public class | SymbolicCurve | A curve that provides information but is not intended to represent actual geometry in an element.
Public class | SymbolicCurveArray | An array that contains model curves.
Public class | SymbolicCurveArrayIterator | An iterator to a model curve array.
Public class | SymbolTypeId | This class contains constants identifying symbols.
Public class | SynchronizeWithCentralOptions | Options to control behavior of synchronization with central.
Public class | TableCellCalculatedValueData | The TableCellCalculatedValueData stores the data for calculated value
Public class | TableCellCombinedParameterData | The TableCellCombinedParameterData stores the data for combined parameters
Public class | TableCellStyle | The TableCellStyle class contains the appearance settings for a given table cell, column, or table.
Public class | TableCellStyleOverrideOptions | This helper class represents the overridden characteristics of the associated cell.
Public class | TableData | The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.
Public class | TableMergedCell | The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.
Public class | TableSectionData | The TableSectionData class represents a serialized version of an instance of section table data. The class holds row, column and cell data.
Public class | TableView | This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.
Public class | TemporaryGraphicsManager | A class that provides functionality to create temporary graphics in a Revit model.
TemporaryViewModes | A data structure containing data related to temporary view modes.
Public class | TessellatedBuildIssue | Types of issues encountered while constructing geometrical objects from the tessellated face sets.
Public class | TessellatedFace | Defines a planar face bounded by a polyline in 3d space. A face consists of a single connected component and can have holes.
TessellatedShapeBuilder | A class that permits structured building of geometry or a mesh from a collection of connected faces. Contains all closed face sets and custom precisions.
Public class | TessellatedShapeBuilderResult | Describes what TessellatedShapeBuilder has construct.
Public class | TextElement | Base class representing text elements in Revit.
Public class | TextElementType | An object that represents a text style.
Public class | TextNode | This class represents a text annotation object in a model-exporting process.
Public class | TextNote | A class representing text note annotations in Revit.
TextNoteOptions | Options to use when creating a new text note element.
Public class | TextNoteType | An object that represents a text note style.
Public class | TextRange | An object that is used to identify a range of characters in a FormattedText.
Public class | ThermalAsset | Represents the properties of a material pertinent to energy analysis.
Public class | ThermalProperties | Class specific to thermal properties for assembly types, such as Wall, Floor, Ceiling, Roof and Building Pad.
Public class | TilePattern | An object representing a tile pattern that may be applied to a DividedSurface.
Public class | TilePatterns | The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.
Public class | Toposolid | An object that represents a Toposolid within the Autodesk Revit project.
Public class | ToposolidType | An object that specifies the type of a Toposolid in Autodesk Revit.
Transaction | Transactions are context-like objects that guard any changes made to a Revit model
Public class | TransactionGroup | Transaction groups aggregate a number of transactions.
TransactWithCentralOptions | Options to customize Revit behavior when accessing the central model.
Transform | A transformation of the affine 3-space.
Public class | Transform1D | An affine transform of 1D Euclidean space.
Public class | Transform2D | An affine transform of 2D Euclidean space.
Public class | TransformWithBoundary | This class contains the transform from model space to projection space for a view and the boundary in model space in which the transform is valid.
TransmissionData | A class representing information on all external file references in a document.
Public class | TriangleInShellComponent | This class represents a triangle in a TriangulatedShellComponent object. The triangle is defined by its vertices, which are specified by their indices in the TriangulatedShellComponent's array of vertices.
Public class | TriangulatedShellComponent | This class represents a triangulated boundary component of a solid or a triangulated connected component of a shell.
Public class | TriangulatedSolidOrShell | This class represents a triangulated solid or shell.
Public class | TriangulationInterface | This abstract class provides an interface for querying a triangulation structure (vertices and triangles).
Public class | TriangulationInterfaceForTriangulatedShellComponent | This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedShellComponent.
Public class | TriangulationInterfaceForTriangulatedSolidOrShell | This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedSolidOrShell.
Public class | TriOrQuadFacet | This class represents a triangle or quadrilateral in a faceted structure.
TypeBinding | TypeBinding objects are used to bind a property to a Revit type, such as a wall type.
Public class | UnitFormatUtils | A utility class for formatting and parsing numbers with units.
Public class | Units | A document's default settings for formatting numbers with units.
Public class | UnitTypeId | This class contains constants identifying units of measurement.
Public class | UnitUtils | A utility class of functions related to units.
Public class | UpdaterData | Service class that is passed to an Updater to prove access to update execution context
Public class | UpdaterId | A unique identifier of an Updater
Public class | UpdaterInfo | Information of an updater, such as: Name, AdditionalInformation, name of the application that owns the updater, etc.
Public class | UpdaterRegistry | An object that stores and manages all updaters registered in the current session.
Public class | UV | Object representing coordinates in 2-dimensional space.
Public class | ValidateCurveLoopsOptions | Options for array of curve loops validation.
Public class | ValueAtPointBase | A base class representing storage of values at a given point.
Public class | ValueParsingOptions | Options for parsing strings into numbers with units.
Public class | VertexIndexPair | Represents a connection between vertices in the top and bottom profile of a blend.
Public class | VertexIndexPairArray | An array that contains VertexIndex pairs.
Public class | VertexIndexPairArrayIterator | An iterator to an array of VertexIndex pairs.
Public class | VertexPair | Indices of a pair of vertices in two CurveLoops(one vertex in each loop).
View | Base class for all types of views in Autodesk Revit.
View3D | Class for 3D views
ViewCropRegionShapeManager | A class that provides access to settings related to the crop assigned to a view or a reference callout.
Public class | ViewDisplayBackground | Set of values that control how background is drawn in a view. Background can only be set for a 3d view or for a section or elevation view.
ViewDisplayDepthCueing | Represents the settings for depth cueing.
Public class | ViewDisplayModel | Represents the settings for displaying model graphics. version 2: m_showHiddenLines type changed bool -> ShowHiddenLinesValues::Enum
Public class | ViewDisplaySketchyLines | Represents the settings for sketchy lines.
Public class | ViewDrafting | ViewDrafting represents a drafting view within the model.
Public class | ViewFamilyType | Represents a type of a Revit view.
Public class | ViewNavigationToolSettings | Represents the settings contained in the document associated to the View Navigation tools (such as the View Cube).
Public class | ViewNode | A render node that represents a view.
Public class | ViewOrientation3D | Container for the point and vectors which define View3D's orientation.
Public class | ViewPlan | Represents floor plan, area plan, ceiling plan, and structural plan views in Revit.
Public class | Viewport | An element that establishes the placement of a view on a sheet.
Public class | ViewSchedule | A schedule view.
Public class | ViewScheduleExportOptions | The export options used to export schedule views.
Public class | ViewSection | ViewSection covers sections, details, elevations, and callouts, all in their reference and non-reference variations.
Public class | ViewSet | A set that contains views.
Public class | ViewSetIterator | An iterator to a view set.
Public class | ViewShapeBuilder | Builds and verifies a view-specific shape representation that would typically be stored in a DirectShape object. Currently limited to curve-based representations for plan and elevation views.
ViewSheet | Class for ViewSheet
Public class | ViewSheetSet | Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.
Public class | ViewSheetSetting | Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.
Public class | VisibleInViewFilter | A quick filter that passes elements that are most likely visible in the given view.
Wall | Represents a wall in Autodesk Revit.
WallFoundation | An object that represents a wall foundation element.
Public class | WallFoundationType | An object that represents the type of a wall foundation in Autodesk Revit.
Public class | WallSweep | Represents a wall sweep or reveal.
Public class | WallSweepInfo | Represents a wall sweep or reveal of a vertically compound structure.
WallType | Represents a specific type of wall, such as 'Generic - 8"'.
Public class | WallUtils | General Wall utility methods
Public class | WireframeBuilder | Constructs a shape representation consisting of points and curves. That shape would typically be stored in a DirectShape or a DirectShapeType object.
Workset | Represents a workset in the document.
Public class | WorksetConfiguration | A configuration class that is passed in to methods that open Revit documents to specify which user-created worksets are opened/closed.
Public class | WorksetDefaultVisibilitySettings | An object that manages default visibility of worksets in a document.
Public class | WorksetFilter | A base class for a type of filter that accepts or rejects worksets based upon criteria.
Public class | WorksetId | WorksetId identifies a workset within a single document.
Public class | WorksetKindFilter | A filter used to match worksets of the given WorksetKind.
Public class | WorksetPreview | Represents an accessor for workset data which can be obtained from an unopened document.
Public class | WorksetTable | A table containing references to all the worksets contained in a document.
WorksharingDisplayGraphicSettings | Represents the graphical settings that can be assigned to elements in the worksharing display modes.
Public class | WorksharingDisplaySettings | WorksharingDisplaySettings controls how elements will appear when they are displayed in any of the worksharing display modes.
Public class | WorksharingSaveAsOptions | This class contains options specific to worksharing SaveAs.
Public class | WorksharingTooltipInfo | Worksharing information about a single element suitable for display in an in-canvas tooltip.
WorksharingUtils | A static class that contains utility functions related to worksharing.
Public class | XYZ | Object representing coordinates in 3-dimensional space.
Structures
 | Structure | Description
Public structure | GridNode | A structure that represents a particular location in (U,V) from a grid.
Interfaces
 | Interface | Description
Public interface | ICentralLockedCallback | An interface that may be used to control Revit's behavior when it tries to lock central and is blocked because another user already has locked central.
Public interface | IConnector | An interface which provides access to connector in Autodesk Revit MEP document.
Public interface | ICustomFieldProperties | Represents the base class for the properties of a custom field.
Public interface | IDataConversionMonitor | A base class for an application-specific logger. It should be used to track errors during conversion and/or , track conversion progress, cancel a conversion process if necessary. Implementing a logger class is optional, but highly recommended for all but most basic data converters. The base class is UI- and language-independent. It is up to the using app to implement UI. Language-specifc data may be used to communicate information to application users. English should be used to communicate data of interest to Revit development.
Public interface | IDuplicateTypeNamesHandler | An interface for custom handlers of duplicate type names encountered during a paste operation. When the destination document contains types that have the same names as the types being copied, but different internals, a decision must be made on how to proceed - whether to cancel the operation or continue, but only copy types with unique names.
Public interface | IExportContext | An interface that is used in custom export to process a Revit model.
Public interface | IExportContext2D | An interface that is used in custom export to export 2D views of a Revit model.
Public interface | IExportContextBase | An interface that as common base for IModelExportContext and IExportContext2D.
Public interface | IExtension | An interface that supports the additional operation for Extension Status
Public interface | IExternalDBApplication | An interface that supports addition of DB-level external applications to Revit, to subscribe to DB-level events and updaters.
Public interface | IExternalResourceServer | The interface used to provide custom implementation to provide access to external resources (such as linked files) from arbitrary locations.
 | IFailuresPreprocessor | An interface that may be used to perform a preprocessing step to either filter out anticipated transaction failures or to mark certain failures as non-continuable.
 | IFailuresProcessor | To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.
Public interface | IFamilyLoadOptions | An interface class which provide the callback for family load options.
Public interface | IGetLocalPathForOpenCallback | The interface used to provide custom support for the "Open (and Unload)" command for Revit Links obtained as external resources.
Public interface | IModelExportContext | An interface that is used in custom export to export 3D views of a Revit model.
Public interface | INavisworksExporter | The interface used to implement a Navisworks exporter.
Public interface | IOnLocalLinkSharedCoordinatesSavedCallback | A callback for notifying an IExternalResourceServer that shared coordinates changes have been saved back to one of the Revit or DWG links provided by that server.
 | IOpenFromCloudCallback | An interface that may be used to control Revit's behavior when opening a cloud model.
Public interface | IPerformanceAdviserRule | Base class to derive specific performance adviser rules from.
Public interface | IPhotoRenderContext | An interface that is used in custom export to render 3D views of a Revit model.
Public interface | IPrintSetting | An interface which represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public interface | ISaveSharedCoordinatesCallback | An interface that may be used to control Revit when trying to unload or reload a Revit link with changes in shared coordinates.
Public interface | ISaveSharedCoordinatesCallbackForUnloadLocally | An interface that is used to control Revit when trying to unload locally a Revit link with changes in shared coordinates.
Public interface | ITransactionFinalizer | An interface that may be used to perform a custom action at the end of a transaction. A method of the interface will be called when a transaction is either committed or rolled back.
Public interface | ITransientElementMaker | The interface to be implemented by an application that creates transient element(s) in Revit.
 | IUpdater | The interface used to create an updater capable of reacting to changes in the Revit model.
 | IViewSheetSet | This interface represents a selected set of views/sheets which will be used for printing.
Enumerations
 | Enumeration | Description
Public enumeration | ACADVersion | An enumerated type listing available AutoCAD versions, into which a file may be exported.
Public enumeration | ACAObjectPreference | An enumerated type listing possible ways to generate geometry of an ACA object Revit object parameters used to generate geometry of the exported ACA object. Revit object geometry is used to generate geometry of the exported ACA object. That may produce better geometric fidelity in some cases.
Public enumeration | AdaptivePointConstraintType | An enumerated type containing possible constraint types for Adaptive Points.
Public enumeration | AdaptivePointOrientationType | An enumerated type containing possible orientation types for Adaptive Points.
Public enumeration | AdaptivePointType | An enumerated type containing possible types for Adaptive Points.
Public enumeration | AllowedValues | A range of allowed values.
Public enumeration | AlternateUnits | An enumerated type listing the locations where Alternate units may be displayed in dimensions.
Public enumeration | AnalyzesAsType | This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.
Public enumeration | AreaElemType | An enumerated type to store type of AreaElement.
Public enumeration | ArrayAnchorMember | Represents the possible choices for how the translation or rotation is used to place each member of the array.
Public enumeration | AssemblyDetailViewOrientation | Orientation of the Assembly Detail View.
Public enumeration | AttachmentType | Enum determining whether a link is an attachment or an overlay
Public enumeration | AutomaticConnectionBehaviorType | Defines behavior of connector with respect to automatic creation of connections
Public enumeration | BackClippingParam | The allowed values for the VIEW_BACK_CLIPPING and VIEWER_BOUND_FAR_CLIPPING parameters.
Public enumeration | BackgroundImageFit | Indicates the background image fit type in rendering settings.
Public enumeration | BackgroundStyle | Indicates the background style in rendering settings.
Public enumeration | BaseLoadOn | An enumerated type listing all the possible power load use types for a space object.
Public enumeration | BeamSystemJustifyType | Describes the justify method of beamsystem.
Public enumeration | BehaviorType | An enumerated type listing all the behavior type for MEP Components.
Public enumeration | BendingDetailPositionOptions | An enumerated type listing the bending detail position options supported by the Bending Detail.
Public enumeration | BooleanOperationsType | An enumerated type listing boolean types that are supported for boolean operation.
Public enumeration | BorderTile | Options for controlling tiles that overlap the face boundary. See DividedSurface.
Public enumeration | BoxPlacement | An enumerated type containing possible constraint types for Adaptive Points.
Public enumeration | BRepBuilderOutcome | This class defines possible outcomes returned by BRepBuilder functions that need to report outcome via a return value.
Public enumeration | BRepBuilderState | This class defines an enumerative type used to specify the state of a BRepBuilder object.
Public enumeration | BRepType | This class defines an enumerative type used to specify the type of output geometry expected from a BRepBuilder.
Public enumeration | BrowserOrganizationType | Enumerated type representing the type of browser organization.
Public enumeration | BuildingType | This enumeration is used for specifying the most predominant building use type.
Public enumeration | BuiltInCategory | A list of all the built in categories within Revit.
Public enumeration | BuiltInParameter | An enumerated type listing all of the built-in parameter IDs supported by Autodesk Revit.
Public enumeration | CategoryType | The type of category.
Public enumeration | CellType | Declares the cell data type.
Public enumeration | ChangePriority | Enum used to specify the priority of an Updater during execution.
Public enumeration | CheckoutStatus | Indicates the ownership status of an element
Public enumeration | ColorDepthType | An enumerated type listing all Color Depth types of Print Setting.
Public enumeration | ColumnAttachmentCutStyle | Control the handling of columns that intersect their targets.
Public enumeration | ColumnAttachmentJustification | Control the column extent in cases where the target is not a uniform height.
Public enumeration | ComponentRotation | ComponentRotation property of DividedSurface. See DividedSurface.
Public enumeration | CompoundStructureError | When CompoundStructure::isValid() returns false, it uses these values to indicate precise nature of defect.
Public enumeration | ConnectionResolution | An enumerated type listing all the possible resolutions for connectivity validation.
Public enumeration | ConnectionWarning | An enumerated type listing all the reasons for connectivity failure.
Public enumeration | ConnectorDomainType | Type of connector domain.
Public enumeration | ConnectorGenderType | Connector gender type enum
Public enumeration | ConnectorJointType | Connector joint type enum
Public enumeration | ConnectorProfileType | An enumerated type listing all connector profile types
Public enumeration | ConnectorType | An enumerated type listing all connector types for a connection
Public enumeration | ContourSettingItemType | The type of a ContourSettingItem
Public enumeration | ControlShape | An enumerated type listing four shapes of control that Autodesk Revit supports.
Public enumeration | CoordinatePlaneVisibility | Visibility settings for ReferencePoint element's coordinate reference planes.
Public enumeration | CurtainGridAlignType | An enumerated to list CurtainGrid patterns.
Public enumeration | CurvedEdgeConditionParam | The allowed values for the HOST_SSE_CURVED_EDGE_CONDITION_PARAM parameter.
Public enumeration | CurveElementType | An enumerated type listing the curve element types that can be used when filtering elements (via CurveElementFilter).
Public enumeration | CurveProjectionType | This attribute indicates how the curve will be projected to the surface if the curve is sketched on the surface.
Public enumeration | CustomSubCategoryId | An enumerated type listing pseudo sub-categories that can appear in a mapping template. These types do not represent an independent category in Revit, but can be mapped to specific IFC entity.
Public enumeration | CutFailureReason | The reason why a solid-solid cut cannot be created.
Public enumeration | DataExchangeMessageId | Predefined message ids for DataExchangeLog.
Public enumeration | DataExchangeMessageSeverity | Error levels for DataExchangeLog
Public enumeration | DataExchangeMessageVerbosity | Predefined verbosity levels for DataExchangeLog
Public enumeration | DatumEnds | An enumerated type representing ends of a datum plane.
Public enumeration | DatumExtentType | Represents the type of datum extent that is displayed in a particular view.
Public enumeration | DecimalSymbol | The symbol used to separate the integer and fractional parts of a number.
Public enumeration | DeleteWorksetOption | This class defines an enumerative type used to specify the option to delete a workset.
Public enumeration | DetachFromCentralOption | Options for workset detachment behavior.
Public enumeration | DGNFileFormat | An enumerated type listing available Microstation versions into which a file may be exported.
Public enumeration | DigitGroupingAmount | The number of digits in each group when numbers are formatted with digit grouping.
Public enumeration | DigitGroupingSymbol | The symbol used to separate groups of digits when numbers are formatted with digit grouping.
Public enumeration | DimensionShape | An enumerated type to list dimension type.
Public enumeration | DimensionStyleType | An enumerated type containing possible style types of dimensions.
Public enumeration | DirectShapeReferencingOption | An enumerated type containing possible referencing options for DirectShapes.
Public enumeration | DirectShapeRoomBoundingOption | An enumerated type containing possible room bounding settings for DirectShapes.
Public enumeration | DirectShapeTargetViewType | View types for which DirectShape objects are allowed to have alternative shape representations
Public enumeration | DirectShapeTypeUserAssignability | Options for a DirectShapeType which affect whether or not it can be assigned as the type of a DirectShape.
Public enumeration | DisplacementPathStyle | Used to control the graphical representation of a DisplacementPath element.
Public enumeration | DisplayStyle | Display type of the view.
Public enumeration | DisplayUnit | Describes the type of Revit display unit, metric or imperial.
Public enumeration | DistanceMeasuredFrom | Indicates if the distance is measured from the top or bottom of the wall.
Public enumeration | DistributionOfNormals | An enumeration containing the choices of how normal vectors are assigned and distributed along the surface of a polymesh. Planar faces would typically have only normal vector associated, but curved faces can have a different normal either for each facet (triangle) or each point of the tessellated polymesh.
Public enumeration | DividedPathMeasurementType | DividedPath measurement type.
Public enumeration | DocumentType | Types of Revit documents.
Public enumeration | Domain | Type of connector domain.
Public enumeration | DoorEvacuationExitType | An enumerated type listing the possible door evacuation types
Public enumeration | DrawLayer | An enumerated type containing possible DrawLayer options.
Public enumeration | DuplicateTypeAction | This enumerated type defines the action to be taken when there are types with the same name being pasted.
Public enumeration | DWFImageFormat | An enumerated type listing possible image format for DWF Export.
Public enumeration | DWFImageQuality | An enumerated type listing possible image quality for DWF Export.
Public enumeration | EaveCutterType | An enumerated type to store type of EaveCutter.
Public enumeration | ElementOnPhaseStatus | The statuses that an element can have with respect to a given phase.
Public enumeration | ElementReferenceType | Element reference types.
Public enumeration | ElementTypeGroup | The element type group.
Public enumeration | EndCapCondition | Used by CompoundStructure to describe which shell layers participate in end wrapping.
Public enumeration | EntryAndSchemeConsistency | Enumeration used to specify why an entry is inconsistent with a scheme or another entry.
Public enumeration | ExportColorMode | An enumerated type listing export color mode.
Public enumeration | ExportColumnHeaders | Options for exporting column headers in schedule view export.
Public enumeration | ExportEnergyModelType | This enum is used to define if energy model used for gbXML export should be based on rooms/spaces, building elements or analysis mode in EnergyDataSettings.
Public enumeration | ExportPaperFormat | Paper formats supported by export
Public enumeration | ExportRange | This enum is used to define what view, part of the view, or list of views will be exported.
Public enumeration | ExportResolution | An enumerated type listing possible options to control the tessellation quality.
Public enumeration | ExportSheetType | An enumerated type listing possible Sheet type.
Public enumeration | ExportTextQualifier | Options for the text qualifier character in schedule view export.
Public enumeration | ExportUnit | An enumerated type listing possible target units for CAD Export.
Public enumeration | ExternalDBApplicationResult | Informs Autodesk Revit of the status of your external db application after execution.
Public enumeration | ExternalFileReferenceType | Enum class indicating kinds of external file references
Public enumeration | ExternallyTaggedNonBRepUsage | The ways in which an ExternallyTaggedNonBRep can be used in Revit.
Public enumeration | ExternalResourceLoadStatus | A flag to indicate the status of an ExternalResource load request.
Public enumeration | ExternalResourceUIBrowseResultType | Describes the type of external resource browsing result.
Public enumeration | ExtrusionAnalyzerFaceAlignment | Indicates whether a face of the solid analyzed by ExtrusionAnalyzer is fully aligned, partially aligned, or unaligned with faces of the extrusion.
Public enumeration | FabricationDimensionType | Fabrication dimension type.
Public enumeration | FabricationDimensionUnitType | Fabrication dimension unit type.
Public enumeration | FabricationMaterialType | An enumerated type listing all fabrication material types.
Public enumeration | FaceIntersectionFaceResult | An enumerated type listing the possible results of a face-face intersection calculation.
Public enumeration | FailureProcessingResult | An enumerated type representing the result achieved by any of the available types of failure handlers: FailuresPreprocessor, the handler of FailuresProcessing event or a FailuresProcessor.
Public enumeration | FailureResolutionType | Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.
Public enumeration | FailureSeverity | Enum represents severity of a failure.
Public enumeration | FamilyElementVisibilityType | Indicates the Visibility type of generic forms.
Public enumeration | FamilyHostingBehavior | Types of hosts into/onto which a family can be hosted. For informative purposes only. Does not affect anything in Revit!
Public enumeration | FamilyInstanceReferenceType | Corresponds to the possible values of parameter "Is Reference" of reference planes and parameter "Reference" of reference lines in families. This enum is used to identify references of family instances corresponding to reference planes and reference lines in the family.
Public enumeration | FamilyNestingBehavior | This attribute describes the family nesting behavior.
Public enumeration | FamilyPlacementType | The type of placement required for a given family.
Public enumeration | FamilySizeTableErrorType | The set of errors that can be returned when importing a FamilySizeTable from a CSV file.
Public enumeration | FamilySource | Describes which version of the family to be loaded.
Public enumeration | FillPatternHostOrientation | The types of orientations for fill patterns.
Public enumeration | FillPatternTarget | The type of the fill pattern.
Public enumeration | FindReferenceTarget | The type of reference to find from a ReferenceIntersector.
Public enumeration | FitDirectionType | This enum is used to define the direction to fit the number of pixels defined by PixelSize.
Public enumeration | FittingAndAccessoryCalculationType | The MEP fitting and accessory pressure drop calculation type.
Public enumeration | FittingAngleUsage | An enumerated type representing the options for how to limit the angle values applicable to fitting content.
Public enumeration | FloorFace | An enumerated type listing floor face types (top or bottom)
Public enumeration | FlowDirectionType | An enumerated type listing direction types for a connector.
Public enumeration | FormatStatus | An enumerated type indicating the formatting status of a range of characters in FormattedText
Public enumeration | FramingShapeClassification | This enumeration is used to classify MEP Ancillary Framing shape.
Public enumeration | GraphicsStyleType | Describes the type of graphics style.
Public enumeration | GridNodeLocation | Location of a grid node relative to the face boundary. See DividedSurface.
Public enumeration | GridSegmentDirection | Specify one of the four adjacent segments to a GridNode. See DividedSurface.
Public enumeration | HiddenLineViewsType | An enumerated type listing all Hidden Line Views types of Print Setting.
Public enumeration | HorizontalAlign | Horizontal alignment of model text.
Public enumeration | HorizontalAlignmentStyle | Declares the horizontal alignment style of font.
Public enumeration | HorizontalTextAlignment | Supported types of horizontal alignment of a text element and text justification within the text containing box.
Public enumeration | IFCExportElement | An enumerated type defining if an element is exported to IFC or not.
Public enumeration | IFCExportElementType | An enumerated type defining if an element type is exported to IFC or not.
Public enumeration | IFCVersion | An enumerated type listing available IFC file versions into which a file may be exported.
Public enumeration | ImageFileType | This enum is used to define exported file type.
Public enumeration | ImageResolution | This enum is used to define image resolution in order to calculate the image size.
Public enumeration | ImageTypeSource | The source of the data used to generate the image.
Public enumeration | ImageTypeStatus | Indicates the current state of the contents of the ImageType.
Public enumeration | ImportColorMode | An enumerated type listing how colors are handled in an import process.
Public enumeration | ImportExportFileFormat | Describes formats supported by import / export.
Public enumeration | ImportPlacement | An enumerated type listing possible placement modes for imported drawings.
Public enumeration | ImportUnit | An enumerated type listing possible target units for CAD Import.
Public enumeration | InsertOrientation | The allowed values for the INSERT_ORIENTATION parameter.
Public enumeration | IntersectionType | Intersection type.
Public enumeration | JoinType | The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.
Public enumeration | JunctionType | An enumerated type listing all the junction types for MEP curve types.
Public enumeration | KeyBasedTreeEntryErrorType | An Enum indicating the type of error associated with a KeyBasedTreeEntry.
Public enumeration | LabelType | The label type in dimension equality formats.
Public enumeration | LayerCategoryType | An enumerated type listing category types supported in an ExportLayerTable.
Public enumeration | LeaderAtachement | Supported types of vertical attachments of a leader to a text note.
Public enumeration | LeaderEndCondition | An enumerated type listing Leader end conditions that are supported for IndependentTags.
Public enumeration | LeaderShape | Supported geometric shapes of annotation leaders.
Public enumeration | LeadersPresentationMode | Leaders Presentation Mode.
Public enumeration | LightAndMaterialAccuracyMode | An enumerated type containing possible Light and Material Accuracy modes for Raytracer render.
Public enumeration | LightingSource | Indicates the lighting scheme type in rendering settings.
Public enumeration | LinePatternSegmentType | Represents the type of a line pattern segment.
Public enumeration | LineScaling | An enumerated type listing possible LineType scaling modes.
Public enumeration | LinkedFileStatus | Enum displaying the loaded status of a linked file
Public enumeration | LinkLoadResultType | Enum listing the possible results after loading a linked model.
Public enumeration | LinkOriginFileType | Enum determining whether the source type of a temporary rvt link is an ifc.
Public enumeration | LinkVisibility | Link visibility types.
Public enumeration | ListType | An enumerated type indicating the style of list item for paragraphs that are part of ordered or unordered lists in FormattedText.
Public enumeration | LoadOperationType | An enum indicating whether a resource load operation was triggered by a user action or an automatic process.
Public enumeration | MarginType | An enumerated type listing all Margin types of Print Setting.
Public enumeration | MassDisplayTemporaryOverrideType | This enum identifies the mass display overrides.
Public enumeration | MaterialAspect | A list of all material aspects that a material can store PropertySetElements for.
Public enumeration | MaterialFunctionAssignment | Used in class CompoundStructure to specify the function of a layer.
Public enumeration | MaterialPropertyPathType | Enum class indicating kinds of paths which ExternalFileReferenceType.Material references can have.
Public enumeration | MEPSystemClassification | This enumeration is used to classify MEP connectors and systems and drives certain behavior for a particular system type
Public enumeration | MeshFromGeometryOperationIssue | Issues encountered while constructing meshes as fallbacks for geometrical operations.
Public enumeration | ModelUpdatesStatus | Indicates whether an element in the current model has additional user changes in the central model.
Public enumeration | ModifierType | An enumerated type listing options to appear in the exported layer name.
Public enumeration | NavisworksCoordinates | An enumerated type listing possible Coordinates of Navisworks Exporter.
Public enumeration | NavisworksExportScope | An enumerated type listing possible "Element Scopes" of Navisworks Exporter.
Public enumeration | NavisworksParameters | An enumerated type listing possible "Parameter conversions" of Navisworks Exporter.
Public enumeration | NumberSystemDisplayRule | The available options for display of numeric values in the number system.
Public enumeration | NumberSystemJustifyOption | The available options for justification of the numbers in a number system.
Public enumeration | OpenConflictResult | The result of the open conflict.
Public enumeration | OpenConflictScenario | The kinds of conflicts happened during open.
Public enumeration | OpenForeignOption | Options for opening files saved by an application that was not developed or licensed by Autodesk.
Public enumeration | OpeningWrappingCondition | Used by CompoundStructure to describe which shell layers participate in wrapping at openings.
Public enumeration | OrdinateDimensionLineStyle | The ordinate dimension line style.
Public enumeration | OrdinateOriginVisibility | The ordinate origin visibility.
Public enumeration | OrdinateTextOrientation | The ordinate dimension text orientation.
Public enumeration | OrdinateTextPosition | The ordinate dimension text position.
Public enumeration | OverridePermissions | Types of overrides that can be applied to a category.
Public enumeration | PageOrientationType | An enumerated type listing all Page Orientation types of Print Setting
Public enumeration | PaperPlacementType | An enumerated type listing all Paper Placement types of Print Setting.
Public enumeration | ParametersOrder | The order of the parameters.
Public enumeration | PartEdgeConditionOrientation | Relative orientation of the right/lower and left/upper edge condition profiles.
Public enumeration | PartsVisibility | Indicates the visibility of parts for the view.
Public enumeration | PartType | An enumerated type listing all MEP family part types. A part type typically provides one unique set of type parameters that defines this part.
Public enumeration | PathType | Enum determining what kind of path a given external file reference path is. Paths are valid for all types of external file references unless otherwise specified.
Public enumeration | PDFExportQualityType | An enumerated type listing the options for PDF export quality.
Public enumeration | PhaseStatusPresentation | An enumerated type listing the options for element display in a phase filter.
Public enumeration | PlanViewDirection | This enumerated type represents the possible directions for a plan view.
Public enumeration | PlanViewPlane | Locations where view range offsets can be specified.
Public enumeration | PlanViewRangeError | Describes errors in the location of planes in a PlanViewRange object.
Public enumeration | PlanViewRangeLevel | An enumerated type representing the options for setting the range for a plan view.
Public enumeration | PointCloudColorMode | Color mode of a point cloud or part of a point cloud
Public enumeration | PointCloudFoundStatus | Enumerated type representing the possible states related to searching for a point cloud file.
Public enumeration | PointOnCurveMeasureFrom | Point on curve MeasureFrom - It tells from which end of the host curve the point location is measured.
Public enumeration | PointOnCurveMeasurementType | Point on curve measurement type Defines the types of measurements that may be used when placing a point at a designated distance along a curve.
Public enumeration | PreferredJunctionType | Enumerated type representing the possible options for the preferred junction for a routine preference rule.
Public enumeration | PreviewFamilyVisibilityMode | Modes that control visibility of family elements depending on the currently applied Element Visibility Settings of a view.
Public enumeration | PrinterResolution | Controls the resolution level in rendering settings.
Public enumeration | PrintRange | An enumerated type listing all Print Range types of Print.
Public enumeration | ProfileFamilyUsage | An enumerated type listing all types of profile families.
Public enumeration | ProfilePlaneLocation | Indicates the location of Sweep profile plane on the path curve.
Public enumeration | PropOverrideMode | An enumerated type listing ways how overridden object styles get exported.
Public enumeration | RasterQualityType | An enumerated type listing the options for raster quality.
Public enumeration | RectangularGridSegmentOrientation | The orientation type of rectangular grid segment.
Public enumeration | ReferenceBaseOnHostType | This enumeration is used to classify the Reference Base on Host type .
Public enumeration | ReferenceType | Reference types of curve element.
Public enumeration | RenderDuration | An enumerated type containing possible duration types to do Raytracer render.
Public enumeration | RenderingQuality | Indicates the rendering quality in rendering settings.
Public enumeration | RenderNodeAction | Enumerated actions for processing a render node during custom export.
Public enumeration | ResolutionTarget | Indicates the resolution target(Screen or Printer) used for rendering settings.
Public enumeration | ResourceVersionStatus | An enum indicating whether a resource is current or out of date.
Public enumeration | RevisionNumbering | The options for how revision numbers should be displayed on sheets within a project.
Public enumeration | RevisionNumberType | Determines how a particular revision will be numbered.
Public enumeration | RevisionVisibility | Determines whether Revision Clouds and Revision Tags will be visible in the project.
Public enumeration | RoundingMethod | Rounding methods
Public enumeration | RoutingPreferenceErrorLevel | An enumerated type listing the options for posting errors or warnings when routing preferences are not satisfied.
Public enumeration | RoutingPreferenceRuleGroupType | Add more rule group type here.
Public enumeration | RowHeightOverrideOptions | Describes the options for overriding schedule body row heights (applied when viewed as a ScheduleSheetInstance on a ViewSheet).
Public enumeration | SaveModifiedLinksOptions | Class giving options when saving linked files which have been modified in-memory by shared coordinates operations.
Public enumeration | SaveModifiedLinksOptionsForUnloadLocally | Class giving options when saving linked files which are unloaded locally and have been modified in-memory by shared coordinates operations.
Public enumeration | ScheduleFieldDisplayType | Display type of schedule field.
Public enumeration | ScheduleFieldMultipleValuesDisplayType | Define how the schedule field's multiple value is displayed.
Public enumeration | ScheduleFieldType | The type of data displayed in a schedule field.
Public enumeration | ScheduleFilterType | Type of schedule filter.
Public enumeration | ScheduleHeadingOrientation | Orientation of schedule heading.
Public enumeration | ScheduleHorizontalAlignment | Horizontal alignment of data in a schedule.
Public enumeration | ScheduleSortOrder | Options for sort order of rows in a schedule.
Public enumeration | ScheduleVerticalAlignment | Vertical alignment of data in a schedule.
Public enumeration | SectionType | Declares the section data type.
Public enumeration | SelectionFilterAction | An enumerated type containing the type of actions that may be taken with a selection filter applied to a point cloud.
Public enumeration | ServiceType | This enumeration is used for specifying the most predominant service for the building or space.
Public enumeration | SetComparisonResult | An enumerated type listing all the relationship types between two sets of arbitrary nature.
Public enumeration | ShapeImporterSourceFormat | An enumerated type listing the possible formats supported by the Shapeimporter.
Public enumeration | SheetDuplicateOption | Options for duplicating sheets
Public enumeration | ShellLayerType | Used to distinguish exterior and interior shell layers.
Public enumeration | ShowHiddenLinesValues | Provides options for display of hidden lines in a given view.
Public enumeration | SimpleWorksetConfiguration | Indicates the set of user-created worksets to open in memory
Public enumeration | SlabShapeCreaseType | The type of a SlabShapeCrease
Public enumeration | SlabShapeVertexType | The type of a SlabShapeVertex
Public enumeration | SlantedOrVerticalColumnType | This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.
Public enumeration | SolidCurveIntersectionMode | Represents the types of results available for calculating the intersection between a solid and a curve.
Public enumeration | SolidGeometry | An enumerated type listing possible ways of exporting solids in 3D views.
Public enumeration | SortingOrder | Enumerated type representing the sorting order of a collection of objects.
Public enumeration | SpacingRuleJustification | Justification property of spacing rule
Public enumeration | SpacingRuleLayout | Rules for laying out a series of equidistant points or parallel lines
Public enumeration | SpatialElementBoundaryLocation | An enumerated type listing boundary options of spatial element geometry calculation.
Public enumeration | SpatialElementTagOrientation | An enumerated type listing tag orientation options that are supported by SpatialElementTags.
Public enumeration | SpatialElementType | An enumerated type listing types of spaces.
Public enumeration | SpecialType | An enumerated type listing special types that can appear in an ExportLayerTable. These types do not represent an independent category in Revit, but can be mapped to specific layers on export.
Public enumeration | STEPApplicationProtocol | An enumeration for STEP Application Protocols.
Public enumeration | StickSymbolLocation | Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.
Public enumeration | StiffenerClassification | This enumeration is used to classify the stiffener.
Public enumeration | StorageType | An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.
Public enumeration | StripedRowPattern | An enumerated type representing the possible sets of rows of a striped row schedule.
Public enumeration | StructDeckEmbeddingType | Used in class CompoundStructure to specify the usage of a layer whose function is StructuralDeck.
Public enumeration | StructuralAssetClass | Represents the type of material described by a structural asset. This enum value is returned by Autodesk::Revit::DB::StructuralAsset::StructuralAssetClass.
Public enumeration | StructuralBehavior | Specifies whether structural elements behave orthotropically, isotropically, or transverse-isotropically.
Public enumeration | StructuralReleaseType | Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.
Public enumeration | SubfaceType | Meaning of a subface's type.
Public enumeration | SunAndShadowType | Sun study type enum of SunAndShadowSettings.
Public enumeration | SunStudyTimeInterval | Time interval enum for a single or multi-day sun study.
Public enumeration | TagHeadAlignment | An enumerated type listing the tag-head alignment options supported by the Bending Detail.
Public enumeration | TagHeadPositionOptions | An enumerated type listing the tag-head position options supported by the Bending Detail.
Public enumeration | TagMode | The modes of tag creation that are supported for IndependentTags.
Public enumeration | TagOrientation | An enumerated type listing tag orientation options that are supported by IndependentTags.
Public enumeration | TagOrientationBehavior | This attribute describes the family orientation behavior.
Public enumeration | TemporaryViewMode | Enumeration to represent the various temporary view modes a view can be in.
Public enumeration | TessellatedBuildIssueType | Types of issues encountered while constructing geometrical objects from the tessellatted face sets.
Public enumeration | TessellatedShapeBuilderFallback | Describes what TessellatedShapeBuilder function should do, if it cannot build a requested TessellatedShapeBuilderTarget.
Public enumeration | TessellatedShapeBuilderOutcome | Describes the outcome of TessellatedShapeBuilder attempt to build geometrical objects.
Public enumeration | TessellatedShapeBuilderTarget | Describes what TessellatedShapeBuilder should generate, if possible.
Public enumeration | TextAlignFlags | An enumerated type listing all the Text align flags.
Public enumeration | TextAlignMask | An enumerated type listing all the Text align mask.
Public enumeration | TextBaselineStyle | Supported styles of text position relative to the normal baseline.
Public enumeration | TextElementBackground | An enumerated type listing all the background mode for the built-in parameter TEXT_BACKGROUND.
Public enumeration | TextListStyle | Supported styles of text list paragraphs.
Public enumeration | TextNoteLeaderStyles | An enumerated type listing all the Leader styles.
Public enumeration | TextNoteLeaderTypes | Types of text-note leaders
Public enumeration | TextTreatment | An enumerated type listing possible text treatment modes.
Public enumeration | ThermalMaterialType | Represents the thermal material type.
Public enumeration | TilePatternsBuiltIn | Revit's built-in tile patterns. See TilePattern.
Public enumeration | TransactionStatus | An enumerated type listing the possible statuses associated with a Transaction, TransactionGroup, or SubTransaction, or the result of a particular method call on one of those objects.
Public enumeration | TransmittedModelOptions | Enum giving desired behavior when opening or saving a transmitted workshared model.
Public enumeration | UnderlayOrientation | Indicates how elements in the underlay are viewed.
Public enumeration | UnitSystem | A system of measurement: Metric or Imperial units.
Public enumeration | UVGridlineType | A choice between U-gridlines or V-gridlines of a divided surface U Gridlines V Gridlines
Public enumeration | ValueAtPointFlags | Enumerated type containing flags related to the display on particular points. Enumerated type that stores bit values of flags that can be set at any domain point.
Public enumeration | VerticalAlignmentStyle | Declares the vertical alignment style of font.
Public enumeration | VerticalTextAlignment | Supported types of vertical alignment of a text element.
Public enumeration | ViewDetailLevel | Detail level of the view
Public enumeration | ViewDiscipline | Discipline of the view
Public enumeration | ViewDisplayBackgroundImageFlags | A collection of bit flags that control how the background image is positioned in relation to the crop region (or the view boundary).
Public enumeration | ViewDisplayBackgroundType | A collection of settings defining the type of the view background
Public enumeration | ViewDisplayEdges | A collection of settings defining how visible edges are displayed
Public enumeration | ViewDuplicateOption | Options for duplicating views
Public enumeration | ViewFamily | An enumerated type that corresponds to the type of a Revit view.
Public enumeration | ViewPlacementOnSheetStatus | Indicates whether the View is placed on a Sheet.
Public enumeration | ViewPlanType | An enumerated type listing plan view types.
Public enumeration | ViewportPositioning | An enumerated type listing of viewport positioning options on the sheet when swapped to another view.
Public enumeration | ViewportRotation | Rotation of the viewport
Public enumeration | ViewTemplateApplicationOption | Options for applying view templates
Public enumeration | ViewType | An enumerated type listing available view types.
Public enumeration | VirtualPrinterType | An enumerated to list Virtual Printer Types in Revit.
Public enumeration | Visibility | Describes the visibility of a particular geometry object.
Public enumeration | WallCrossSection | The allowed values for the WALL_CROSS_SECTION parameter.
Public enumeration | WallFunction | Indicates the function of a specified WallType, as specified in the parameter FUNCTION_PARAM on the WallType.
Public enumeration | WallKind | Describes the fundamental type of wall, such as curtain wall or stacked wall.
Public enumeration | WallLocationLine | This enumerated type represents the options for alignment of a wall's location line.
Public enumeration | WallSide | Represents the possible sides of a wall where a sweep or reveal may be attached.
Public enumeration | WallSweepOrientation | Represents the orientation of horizonally placed sweep's profile relative to the wall side face.
Public enumeration | WallSweepType | Represents the possible types for methods affecting wall sweeps or reveals.
Public enumeration | WidthMeasuredAt | The allowed values for the WALL_TYPE_WIDTH_MEASURED_AT parameter.
Public enumeration | WorksetConfigurationOption | A collection of options used to initialize a WorksetConfiguration.
Public enumeration | WorksetKind | Indicates one of the standard kinds of workset (as available in the UI).
Public enumeration | WorksetVisibility | Indicates the visibility settings of a workset in a particular view.
 | WorksharingDisplayMode | Indicates which worksharing display mode a view is in.
Public enumeration | ZoomFitType | This enum is used to define type of zoom.
Public enumeration | ZoomType | An enumerated type listing all Zoom types of Print Setting.

ACADExportOptions Class

The base class for options used to export DWG and DXF format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseExportOptions
Autodesk.Revit.DBACADExportOptions
Autodesk.Revit.DBDWGExportOptions
Autodesk.Revit.DBDXFExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ACADExportOptions : BaseExportOptions
Public Class ACADExportOptions
    Inherits BaseExportOptions
public ref class ACADExportOptions : public BaseExportOptions
type ACADExportOptions =
    class
        inherit BaseExportOptions
    end

The ACADExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object.
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false.
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh.
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default.
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale.
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty.
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty.
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false.
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default.
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact.
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace