CriticalPathCollector Methods

The CriticalPathCollector type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCalculatedFlow | Gets the calculated flow of the network.
Public method | GetCalculatedPressureDrop | Gets the calculated pressure drop of the network.
Public method | GetCriticalPathCollectorIterator | Gets the critical path iterator to traverse individual segment.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | ToNetworkSegmentIds | Returns the list of analytical segment ids on the network critical path.
Top
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace