PartUtils Class

Path3d Class

Provides access to the Generic 3D path object in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSketchBase
Autodesk.Revit.DBPath3d

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Path3d : SketchBase
Public Class Path3d
    Inherits SketchBase
public ref class Path3d : public SketchBase
type Path3d =
    class
        inherit SketchBase
    end

The Path3d type exposes the following members.

Properties
 | Name | Description
Public property | AllCurveLoops | Get all the Curve Loops of Path3d.
Public property | CurveLoop | Get the Curve Loop of Path3d via index.
Public property | NumCurveLoops | Get the Number of Curve Loops of Path3d.
Top
Methods
 | Name | Description
Top
Remarks
This object represents a 3D path sketch of Sweep.
See Also

Reference

Autodesk.Revit.DB Namespace