ElementMulticlassFilter Class

ElementNode Class

A render node that represents an element, including the host document containing the element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBElementNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementNode : RenderNode
Public Class ElementNode
    Inherits RenderNode
public ref class ElementNode : public RenderNode
type ElementNode =
    class
        inherit RenderNode
    end

The ElementNode type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document associated with the element.
Public property | ElementId | The Id of the element.
Public property | LinkInstanceId | The Id of the link instance for the element.
Top
Methods
 | Name | Description
Top
Remarks
See also: OnElementBegin2D(ElementNode). See also: OnElementEnd2D(ElementNode).
See Also

Reference

Autodesk.Revit.DB Namespace