Parameter Class
Set Overload

Parameter.Set(String) Method

ParameterSet(String) Method

Sets the parameter to a new string of text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    string value
)
Public Function Set (
    value As String
) As Boolean
public:
bool Set(
    String^ value
)
member Set :
        value : string -> bool

Parameters

value String
The new text value to which the parameter is to be set.

Return Value

Boolean
The Set method will return True if the parameter was successfully set to the new value, otherwise false.
Exceptions
Exception | Condition
InvalidOperationException | The parameter is read-only.
Remarks
You should only use this method if the StorageType property reports the type of the parameter as a String.
Example
C#
VB
C++
F#
Copy
void AddInstanceComment(Wall wall)
{
    // Get the comment parameter of the element instance
    Parameter commentPara = wall.get_Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS);
    if (null != commentPara)
    {
        // Add a greeting string to the comment
        commentPara.Set("Hello Everyone.");
    }
}
Private Sub AddInstanceComment(wall As Wall)
    ' Get the comment parameter of the element instance
    Dim commentPara As Parameter = wall.Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS)
    If commentPara IsNot Nothing Then
        ' Add a greeting string to the comment
        commentPara.[Set]("Hello Everyone.")
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference