InternalDefinitions Class

InternalOrigin Class

A class representing the origin of internal coordinate system. Each Revit project contains one InternalOrigin.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInternalOrigin

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InternalOrigin : Element
Public Class InternalOrigin
    Inherits Element
public ref class InternalOrigin : public Element
type InternalOrigin =
    class
        inherit Element
    end

The InternalOrigin type exposes the following members.

Properties
 | Name | Description
Public property | Position | The position of the InternalOrigin.
Public property | SharedPosition | The position of the InternalOrigin relative to the active ProjectLocation set for the document.
Top
Methods
 | Name | Description
 | Get | Gets the internal origin for the document.
Top
Remarks
The internal origin cannot be selected (e.g. as a reference) nor can it be modified.
See Also

Reference

Autodesk.Revit.DB Namespace