Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBAXMImportOptions
Autodesk.Revit.DBDGNImportOptions
Autodesk.Revit.DBDWGImportOptions
Autodesk.Revit.DBImportOptions3DM
Autodesk.Revit.DBOBJImportOptions
Autodesk.Revit.DBSATImportOptions
Autodesk.Revit.DBSKPImportOptions
Autodesk.Revit.DBSTEPImportOptions
Autodesk.Revit.DBSTLImportOptions

BaseImportOptions Properties

The BaseImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
Public property | Unit | The unit of measure for imported geometry.
Public property | VisibleLayersOnly | Only import the visible layers.
Top
See Also

Reference