BuiltInFailuresCurveFailures Class

BuiltInFailures.CutFailures Class

BuiltInFailuresCutFailures Class

Failures about Cut.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCutFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CutFailures
Public NotInheritable Class CutFailures
public ref class CutFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CutFailures = class end

The BuiltInFailuresCutFailures type exposes the following members.

Properties
Name | Description
CannotCutGeometry | Elements do not intersect.
CannotCutGeometryWarn | Elements do not intersect.
CannotCutInstanceOut | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutError | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutGen | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenError | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenWarn | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutWarn | Can't cut instance of [Symbol] out of Wall.
CannotCutJoinedElement | Can't cut joined element.
CannotCutRoof | The roof couldn't be cut.
CannotCutRoofError | The roof couldn't be cut.
CantCutHostWithInstance | Can't cut host with instance.
CutExactlyHalf | Can't cut in half. Move plane towards either end.
CutoutNotCuttingAnything | Opening not cutting anything.
CutoutNotCuttingAnythingDeleteOpening | Opening not cutting anything.
DormerCutProblem | Dormer Opening Cut is not fully defined. Cut was not performed.
DormerCutProblemWarn | Dormer Opening Cut is not fully defined. Cut was not performed.
HostCutoutForInsertionFailure | Can't cut host for inserted objects
InstanceNotCuttingAnything | Instance(s) of [Symbol] not cutting anything.
Top
See Also

Reference

Autodesk.Revit.DB Namespace