LightNode Class

Line Class

A line in space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Line : Curve
Public Class Line
    Inherits Curve
public ref class Line : public Curve
type Line =
    class
        inherit Curve
    end

The Line type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Returns the direction of the line.
Public property | Origin | Returns the origin of the line.
Top
Methods
 | Name | Description
 | CreateBound | Creates a new instance of a bound linear curve.
 | CreateUnbound | Creates a new instance of an unbound linear curve.
Top
See Also

Reference

Autodesk.Revit.DB Namespace