SunAndShadowSettings Class

SunAndShadowType Enumeration

Sun study type enum of SunAndShadowSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SunAndShadowType
Public Enumeration SunAndShadowType
public enum class SunAndShadowType
type SunAndShadowType
Members
Member name | Value | Description
StillImage | 0 | Still image study type (single point in time).
OneDayStudy | 1 | Single day study type (time range over a specific day).
MultiDayStudy | 2 | Multi day study type (range over date and time).
Lighting | 3 | Lighting study type (fixed sun position regardless of date and time).
See Also

Reference

Autodesk.Revit.DB Namespace