Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisAnalysisDisplayLegend
Autodesk.Revit.DB.AnalysisAnalysisDisplayStyle
Autodesk.Revit.DB.AnalysisBuildingOperatingDaySchedule
Autodesk.Revit.DB.AnalysisBuildingOperatingYearSchedule
Autodesk.Revit.DB.AnalysisConceptualSurfaceType
Autodesk.Revit.DB.AnalysisEnergyAnalysisConstruction
Autodesk.Revit.DB.AnalysisEnergyAnalysisDetailModel
Autodesk.Revit.DB.AnalysisEnergyAnalysisMaterial
Autodesk.Revit.DB.AnalysisEnergyAnalysisOpening
Autodesk.Revit.DB.AnalysisEnergyAnalysisSpace
Autodesk.Revit.DB.AnalysisEnergyAnalysisSurface
Autodesk.Revit.DB.AnalysisEnergyAnalysisWindowType
Autodesk.Revit.DB.AnalysisEnergyAnalysisZone
Autodesk.Revit.DB.AnalysisEnergyDataSettings
Autodesk.Revit.DB.AnalysisGenericZone
Autodesk.Revit.DB.AnalysisHVACLoadType
Autodesk.Revit.DB.AnalysisMassLevelData
Autodesk.Revit.DB.AnalysisMassSurfaceData
Autodesk.Revit.DB.AnalysisPathOfTravel
Autodesk.Revit.DB.AnalysisRouteAnalysisSettings
Autodesk.Revit.DB.AnalysisSpatialFieldManager
Autodesk.Revit.DBAppearanceAssetElement
Autodesk.Revit.DB.ArchitectureContinuousRail
Autodesk.Revit.DB.ArchitectureMultistoryStairs
Autodesk.Revit.DB.ArchitectureRailing
Autodesk.Revit.DB.ArchitectureStairs
Autodesk.Revit.DB.ArchitectureStairsLanding
Autodesk.Revit.DB.ArchitectureStairsPath
Autodesk.Revit.DB.ArchitectureStairsRun
Autodesk.Revit.DB.ArchitectureTopographySurface
Autodesk.Revit.DBAreaScheme
Autodesk.Revit.DBAreaVolumeSettings
Autodesk.Revit.DBAssemblyInstance
Autodesk.Revit.DBBaseArray
Autodesk.Revit.DBBasePoint
Autodesk.Revit.DBBeamSystem
Autodesk.Revit.DBColorFillLegend
Autodesk.Revit.DBColorFillScheme
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBComponentRepeater
Autodesk.Revit.DBComponentRepeaterSlot
Autodesk.Revit.DBConnectorElement
Autodesk.Revit.DBControl
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBDatumPlane
Autodesk.Revit.DBDefaultDivideSettings
Autodesk.Revit.DBDesignOption
Autodesk.Revit.DBDimension
Autodesk.Revit.DBDirectShape
Autodesk.Revit.DBDisplacementElement
Autodesk.Revit.DBDisplacementPath
Autodesk.Revit.DBDividedPath
Autodesk.Revit.DBDividedSurface
Autodesk.Revit.DB.ElectricalAreaBasedLoadType
Autodesk.Revit.DB.ElectricalCableTrayConduitRunBase
Autodesk.Revit.DB.ElectricalCableTraySettings
Autodesk.Revit.DB.ElectricalCableTraySizes
Autodesk.Revit.DB.ElectricalCircuitNamingScheme
Autodesk.Revit.DB.ElectricalCircuitNamingSchemeSettings
Autodesk.Revit.DB.ElectricalConduitSettings
Autodesk.Revit.DB.ElectricalConduitSizeSettings
Autodesk.Revit.DB.ElectricalElectricalAnalyticalLoadSet
Autodesk.Revit.DB.ElectricalElectricalAnalyticalNode
Autodesk.Revit.DB.ElectricalElectricalDemandFactorDefinition
Autodesk.Revit.DB.ElectricalElectricalLoadClassification
Autodesk.Revit.DB.ElectricalElectricalSetting
Autodesk.Revit.DB.ElectricalPanelScheduleSheetInstance
Autodesk.Revit.DB.ElectricalPanelScheduleTemplate
Autodesk.Revit.DBElementType
Autodesk.Revit.DBElevationMarker
Autodesk.Revit.DBExportDGNSettings
Autodesk.Revit.DBExportDWGSettings
Autodesk.Revit.DBExportPDFSettings
Autodesk.Revit.DB.ExtensibleStorageDataStorage
Autodesk.Revit.DBFabricationConfiguration
Autodesk.Revit.DBFabricationPart
Autodesk.Revit.DBFabricationServiceSettings
Autodesk.Revit.DBFaceSplitter
Autodesk.Revit.DBFamily
Autodesk.Revit.DBFilledRegion
Autodesk.Revit.DBFillPatternElement
Autodesk.Revit.DBFilterElement
Autodesk.Revit.DBGraphicsStyle
Autodesk.Revit.DBGroup
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBIFCCategoryTemplate
Autodesk.Revit.DBImageInstance
Autodesk.Revit.DBIndependentTag
Autodesk.Revit.DBInstance
Autodesk.Revit.DBInternalOrigin
Autodesk.Revit.DBKeyBasedTreeEntryTable
Autodesk.Revit.DBLinePatternElement
Autodesk.Revit.DBMaterial
Autodesk.Revit.DB.MechanicalDuctSettings
Autodesk.Revit.DB.MechanicalDuctSizeSettings
Autodesk.Revit.DB.MechanicalMechanicalEquipmentSet
Autodesk.Revit.DB.MechanicalMEPAnalyticalSystem
Autodesk.Revit.DB.MechanicalMEPHiddenLineSettings
Autodesk.Revit.DB.MechanicalZone
Autodesk.Revit.DB.MechanicalZoneEquipment
Autodesk.Revit.DBMEPSystem
Autodesk.Revit.DBModelText
Autodesk.Revit.DBMultipleValuesIndicationSettings
Autodesk.Revit.DBMultiReferenceAnnotation
Autodesk.Revit.DBMultiSegmentGrid
Autodesk.Revit.DBNestedFamilyTypeReference
Autodesk.Revit.DBNumberingSchema
Autodesk.Revit.DBNumberSystem
Autodesk.Revit.DBOpening
Autodesk.Revit.DBParameterElement
Autodesk.Revit.DBPart
Autodesk.Revit.DBPartMaker
Autodesk.Revit.DBPhase
Autodesk.Revit.DBPhaseFilter
Autodesk.Revit.DB.PlumbingPipeSettings
Autodesk.Revit.DBPrintSetting
Autodesk.Revit.DBProjectInfo
Autodesk.Revit.DBPropertyLine
Autodesk.Revit.DBPropertySetElement
Autodesk.Revit.DBReferencePoint
Autodesk.Revit.DBRevision
Autodesk.Revit.DBRevisionCloud
Autodesk.Revit.DBRevisionNumberingSequence
Autodesk.Revit.DBRevisionSettings
Autodesk.Revit.DBScheduleSheetInstance
Autodesk.Revit.DBSegment
Autodesk.Revit.DBSheetCollection
Autodesk.Revit.DBSketchBase
Autodesk.Revit.DBSketchPlane
Autodesk.Revit.DBSpatialElement
Autodesk.Revit.DBSpatialElementCalculationLocation
Autodesk.Revit.DBSpatialElementTag
Autodesk.Revit.DBSSEPointVisibilitySettings
Autodesk.Revit.DBStartingViewSettings
Autodesk.Revit.DB.StructureAnalyticalElement
Autodesk.Revit.DB.StructureAnalyticalLink
Autodesk.Revit.DB.StructureAnalyticalToPhysicalAssociationManager
Autodesk.Revit.DB.StructureAreaReinforcement
Autodesk.Revit.DB.StructureBoundaryConditions
Autodesk.Revit.DB.StructureFabricArea
Autodesk.Revit.DB.StructureFabricSheet
Autodesk.Revit.DB.StructureHub
Autodesk.Revit.DB.StructureLoadBase
Autodesk.Revit.DB.StructureLoadCase
Autodesk.Revit.DB.StructureLoadCombination
Autodesk.Revit.DB.StructureLoadNature
Autodesk.Revit.DB.StructureLoadUsage
Autodesk.Revit.DB.StructurePathReinforcement
Autodesk.Revit.DB.StructureRebar
Autodesk.Revit.DB.StructureRebarContainer
Autodesk.Revit.DB.StructureRebarCoupler
Autodesk.Revit.DB.StructureRebarInSystem
Autodesk.Revit.DB.StructureReinforcementSettings
Autodesk.Revit.DB.StructureStructuralConnectionHandler
Autodesk.Revit.DB.StructureStructuralConnectionSettings
Autodesk.Revit.DB.StructureStructuralSettings
Autodesk.Revit.DB.StructureTruss
Autodesk.Revit.DBSunAndShadowSettings
Autodesk.Revit.DBTextElement
Autodesk.Revit.DBView
Autodesk.Revit.DBViewNavigationToolSettings
Autodesk.Revit.DBViewport
Autodesk.Revit.DBViewSheetSet
Autodesk.Revit.DBWorksetDefaultVisibilitySettings
Autodesk.Revit.DBWorksharingDisplaySettings

Element Properties

The Element type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
 | CreatedPhaseId | Id of a Phase at which the Element was created.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished.
 | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
 | Geometry | Retrieves the geometric representation of the element.
Public property | GroupId | The id of the group to which an element belongs.
 | Id | A unique identifier for an Element in an Autodesk Revit project.
Public property | IsModifiable | Identifies if the element is modifiable.
Public property | IsTransient | Indicates whether an element is transient or permanent.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LevelId | The id of the level associated with the element.
 | Location | This property is used to find the physical location of an element within a project.
Public property | Name | A human readable name for the Element.
Public property | OwnerViewId | The id of the view that owns the element.
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id.
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition.
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter.
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | Pinned | Identifies if the element has been pinned to prevent changes.
 | UniqueId | A stable unique identifier for an element within the document.
Public property | VersionGuid | Get the element version Guid.
Public property | ViewSpecific | Identifies if the element is owned by a view.
Public property | WorksetId | Get Id of the Workset which owns the element.
Top
See Also

Reference