PointOnEdgeEdgeIntersection Class

PointOnEdgeFaceIntersection Class

Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointElementReference
Autodesk.Revit.DBPointOnEdgeFaceIntersection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointOnEdgeFaceIntersection : PointElementReference
Public Class PointOnEdgeFaceIntersection
    Inherits PointElementReference
public ref class PointOnEdgeFaceIntersection : public PointElementReference
type PointOnEdgeFaceIntersection =
    class
        inherit PointElementReference
    end

The PointOnEdgeFaceIntersection type exposes the following members.

Properties
 | Name | Description
Public property | OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.
Top
Methods
 | Name | Description
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetFaceReference | Get a copy of the face reference.
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | SetFaceReference | Change the face reference.
Top
Remarks
The ReferencePoint's orientation is partially constrained either to the edge (in the manner of PointOnEdge) or to the face (in the manner of PointOnFace).
See Also

Reference

Autodesk.Revit.DB Namespace