BuiltInFailuresStructuralLoadFailures Class

BuiltInFailures.SubRegionFailures Class

BuiltInFailuresSubRegionFailures Class

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSubRegionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SubRegionFailures
Public NotInheritable Class SubRegionFailures
public ref class SubRegionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SubRegionFailures = class end

The BuiltInFailuresSubRegionFailures type exposes the following members.

Properties
Name | Description
CreateSubRegionFailed | Create sub-division failed.
NoHostForToposolidSubregion | This sub-division now does not appear to overlap any Toposolid with an appropriate Phase and Design Option.
SubDivisionPhaseMismatch | Sub-division must have the same Phase Created parameter and Phase Demolished parameter as the host Toposolid. Sub-division phase will be set to match the Toposolid.
Top
See Also

Reference

Autodesk.Revit.DB Namespace