SolidGeometryOptions Class

SolidOptions Class

A class containing optional information to control the properties of the Solid generated by the GeometryCreationUtilities routines.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSolidOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SolidOptions : IDisposable
Public Class SolidOptions
    Implements IDisposable
public ref class SolidOptions : IDisposable
type SolidOptions =
    class
        interface IDisposable
    end

The SolidOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SolidOptions | Creates a new SolidOptions class with material and graphics style settings.
Top
Properties
 | Name | Description
Public property | ExtraFaceAndEdgeHistoryKey | Optional extra key used to create face and edge histories for the Solid. If extraFaceAndEdgeHistoryKey is higher than -1, the Solid's face and edge histories will be created depending on the geometry generation of the Solid.
Public property | GraphicsStyleId | Defines the graphics style id for the Solid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Defines the material id for the Solid.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SolidOptions
Top
See Also

Reference

Autodesk.Revit.DB Namespace