Point Class

A 3D point.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Point : GeometryObject
Public Class Point
    Inherits GeometryObject
public ref class Point : public GeometryObject
type Point =
    class
        inherit GeometryObject
    end

The Point type exposes the following members.

Properties
 | Name | Description
Public property | Coord | Returns the coordinates of the point.
Public property | Reference | Returns a stable reference to the point.
Top
Methods
 | Name | Description
 | Create(XYZ) | Creates a point at the given coordinates.
 | Create(XYZ, ElementId) | Creates a point at the given coordinates and assigns it the specified GraphicsStyle.
Top
Remarks
The point lies at a given XYZ coordinate location.
See Also

Reference

Autodesk.Revit.DB Namespace