Ceiling Class

Represents a ceiling in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCeilingAndFloor
Autodesk.Revit.DBCeiling

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Ceiling : CeilingAndFloor
Public Class Ceiling
    Inherits CeilingAndFloor
public ref class Ceiling : public CeilingAndFloor
type Ceiling =
    class
        inherit CeilingAndFloor
    end

The Ceiling type exposes the following members.

Properties
 | Name | Description
Public property | SketchId | Returns id of the sketch.
Top
Methods
 | Name | Description
 | Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of ceiling within the project.
 | Create(Document, IListCurveLoop, ElementId, ElementId, Line, Double) | Creates a new instance of ceiling within the project.
Top
See Also

Reference

Autodesk.Revit.DB Namespace