ParameterMapIterator Class

ParameterSet Class

A set that contains parameters.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBParameterSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterSet : APIObject,
    IEnumerable
Public Class ParameterSet
    Inherits APIObject
    Implements IEnumerable
public ref class ParameterSet : public APIObject,
    IEnumerable
type ParameterSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The ParameterSet type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterSet | Initializes a new instance of the ParameterSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of parameters that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every parameter from the set, rendering it empty.
Public method | Contains | Tests for the existence of a parameter within the set.
Public method | Erase | Removes a specified parameter from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified parameter into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace