InSessionViewSheetSet Class

Instance Class

The base class for all instance objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Instance : Element
Public Class Instance
    Inherits Element
public ref class Instance : public Element
type Instance =
    class
        inherit Element
    end

The Instance type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances.
Public method | GetTransform | Gets the transform of the instance.
Top
See Also

Reference

Autodesk.Revit.DB Namespace