FilteredWorksetIdIterator Class

FilteredWorksetIterator Class

An iterator to a set of worksets filtered by the settings of a FilteredWorksetCollector.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilteredWorksetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilteredWorksetIterator : IEnumerator<Workset>
Public Class FilteredWorksetIterator
    Implements IEnumerator(Of Workset)
public ref class FilteredWorksetIterator : IEnumerator<Workset^>
type FilteredWorksetIterator =
    class
        interface IEnumerator<Workset>
    end

The FilteredWorksetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetIterator
Public method | GetCurrent | The current workset found by the iterator.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Top
See Also

Reference

Autodesk.Revit.DB Namespace