FolderItemInfo Class

FootPrintRoof Class

Represents kinds of FootPrintRoofs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBRoofBase
Autodesk.Revit.DBFootPrintRoof

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FootPrintRoof : RoofBase
Public Class FootPrintRoof
    Inherits RoofBase
public ref class FootPrintRoof : public RoofBase
type FootPrintRoof =
    class
        inherit RoofBase
    end

The FootPrintRoof type exposes the following members.

Properties
 | Name | Description
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
Public property | DefinesSlope | Retrieve or set the DefinesSlope of the curve.
Public property | ExtendIntoWall | Retrieve or set whether extend into wall the curve.
Public property | Offset | Retrieve or set the Offset of the curve.
Public property | Overhang | Retrieve or set the Overhang of the curve.
Public property | SlopeAngle | Retrieve or set the SlopeAngle of the curve.
Top
Methods
 | Name | Description
Public method | GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
Top
Remarks
The FootPrintRoof object represents some kinds of FootPrintRoof in Revit. The RoofType property is used to distinguish the type of the roof.
See Also

Reference

Autodesk.Revit.DB Namespace