SkyBackgroundSettings Class

SlabEdge Class

An object that represents a slab edge within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBHostedSweep
Autodesk.Revit.DBSlabEdge

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SlabEdge : HostedSweep
Public Class SlabEdge
    Inherits HostedSweep
public ref class SlabEdge : public HostedSweep
type SlabEdge =
    class
        inherit HostedSweep
    end

The SlabEdge type exposes the following members.

Properties
 | Name | Description
Public property | SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
Top
Methods
 | Name | Description
Public method | AddSegment | Add segments to the slab edge. (Overrides HostedSweepAddSegment(Reference))
Top
Remarks
This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.
See Also

Reference

Autodesk.Revit.DB Namespace