EdgeArrayArrayIterator Class

EdgeArrayIterator Class

An iterator to an edge array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBEdgeArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class EdgeArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class EdgeArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class EdgeArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type EdgeArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The EdgeArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Top
Methods
 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace