ViewPlan Class

Represents floor plan, area plan, ceiling plan, and structural plan views in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBViewPlan

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewPlan : View
Public Class ViewPlan
    Inherits View
public ref class ViewPlan : public View
type ViewPlan =
    class
        inherit View
    end

The ViewPlan type exposes the following members.

Properties
 | Name | Description
Public property | AreaScheme | The area scheme.
Top
Methods
 | Name | Description
Public method | CheckPlanViewRangeValidity | Checks if the plan view range is valid.
 | Create | Creates a new ViewPlan.
 | CreateAreaPlan | Creates a new area plan ViewPlan.
Public method | GetUnderlayBaseLevel | Returns the element id of the level that defines the bottom of the underlay range.
Public method | GetUnderlayOrientation | Returns the underlay orientation of this view.
Public method | GetUnderlayTopLevel | Returns the element id of the level that defines the top of the underlay range.
Public method | GetViewRange | Gets the view range.
Public method | SetUnderlayBaseLevel | Sets the level whose elevation will determine the bottom of the underlay range. The elevation of the next highest level will be used to determine the top of the underlay range.
Public method | SetUnderlayOrientation | Sets the underlay orientation for this view.
 | SetUnderlayRange | Sets the underlay base and underlay top to the specified levels.
Public method | SetViewRange | Sets the view range.
Top
Remarks
In a plan view, the model is viewed as if cut by the cut plane and viewed from above, looking down. In ceiling plan views and structural plan views which look up, the model is viewed as if cut by the cut plane, and viewed as if looking down at a mirror.
See Also

Reference

Autodesk.Revit.DB Namespace