FailureHandlingOptions Class

FailureMessage Class

Represents a message describing a failure of an operation in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureMessage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureMessage : IDisposable
Public Class FailureMessage
    Implements IDisposable
public ref class FailureMessage : IDisposable
type FailureMessage =
    class
        interface IDisposable
    end

The FailureMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FailureMessage | Creates a new FailureMessage related to a given FailureDefinition.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | AddResolution | Adds a resolution for the failure.
Public method | Dispose | Releases all resources used by the FailureMessage
Public method | GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetFailingElements | Retrieves list of the elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetAdditionalElement | Sets the additional reference element for the failure.
Public method | SetAdditionalElements | Sets the additional reference elements for the failure.
Public method | SetFailingElement | Sets the element that has caused the failure.
Public method | SetFailingElements | Sets elements that have caused the failure.
Top
Remarks
Failure messages are typically shown to the user in the Revit error dialog. This class contains the following information about the failures:
  1. The basic description of the failure (retrieved from the FailureDefinition)
  2. The available resolutions for the failure.
  3. The elements related to the failure.
See Also

Reference

Autodesk.Revit.DB Namespace