BuiltInFailuresColorFillFailures Class

BuiltInFailures.ColumnFailures Class

BuiltInFailuresColumnFailures Class

Failures about Columns.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresColumnFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ColumnFailures
Public NotInheritable Class ColumnFailures
public ref class ColumnFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ColumnFailures = class end

The BuiltInFailuresColumnFailures type exposes the following members.

Properties
Name | Description
ColumnAndTargetAreConcrete | Column and target are both concrete. Geometries have been joined.
ColumnBaseAboveTopError | The column base can't be moved above its top.
ColumnBaseAboveTopFailure | The column base can't be moved above its top.
ColumnJoinNonhitFailure | The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.
ColumnTopBelowBaseError | The column top can't be moved below its base.
ColumnTopBelowBaseFailure | The column top can't be moved below its base.
ColumnZeroHeightError | The column can't have zero height
ColumnZeroHeightFailure | The column can't have zero height
Top
See Also

Reference

Autodesk.Revit.DB Namespace