RoutingConditions Class

RoutingCriterionBase Class

RoutingCriteriaBase is the base class for all routing criteria.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRoutingCriterionBase
Autodesk.Revit.DBPrimarySizeCriterion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoutingCriterionBase : IDisposable
Public Class RoutingCriterionBase
    Implements IDisposable
public ref class RoutingCriterionBase : IDisposable
type RoutingCriterionBase =
    class
        interface IDisposable
    end

The RoutingCriterionBase type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RoutingCriterionBase
Public method | IsEqual | Verify if two criteria are the same.
Top
See Also

Reference

Autodesk.Revit.DB Namespace