Settings Class

ShapeBuilder Class

The base class for geometry builder classes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBShapeBuilder
Autodesk.Revit.DBBRepBuilder
Autodesk.Revit.DBTessellatedShapeBuilder
Autodesk.Revit.DBViewShapeBuilder
Autodesk.Revit.DBWireframeBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ShapeBuilder : IDisposable
Public Class ShapeBuilder
    Implements IDisposable
public ref class ShapeBuilder : IDisposable
type ShapeBuilder =
    class
        interface IDisposable
    end

The ShapeBuilder type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ShapeBuilder
Top
See Also

Reference

Autodesk.Revit.DB Namespace