TriangulatedShellComponent Class

TriangulatedSolidOrShell Class

This class represents a triangulated solid or shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTriangulatedSolidOrShell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TriangulatedSolidOrShell : IDisposable
Public Class TriangulatedSolidOrShell
    Implements IDisposable
public ref class TriangulatedSolidOrShell : IDisposable
type TriangulatedSolidOrShell =
    class
        interface IDisposable
    end

The TriangulatedSolidOrShell type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShellComponentCount | The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TriangulatedSolidOrShell
Public method | GetShellComponent | Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.
Top
Remarks

The triangulation consists of a number of TriangulatedShellComponents. For a solid, there will be one TriangulatedShellComponent for each component of the solid's boundary. For example, a solid cube has just one boundary component (containing six faces), so there will be just one TriangulatedShellComponent. A solid consisting of two disjoint cubes has two boundary components (the boundaries of the two cubes), so there will be two TriangulatedShellComponents. A solid consisting of a sphere with a round void (or hole) inside it also has two boundary components (the outer sphere and the inner sphere), so there will be two TriangulatedShellComponents.

For a shell, there will be one TriangulatedShellComponent for each component of the shell.

Note that this class does not contain information on the containment structure of the boundary components of a solid.

Be careful not to confuse the components of a solid with the solid's boundary components. This class deals only with the boundary components.

See Also

Reference

Autodesk.Revit.DB Namespace