InSessionPrintSetting Class

InSessionViewSheetSet Class

Represents the in-session ViewSheetSet.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBInSessionViewSheetSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InSessionViewSheetSet : IViewSheetSet,
    IDisposable
Public Class InSessionViewSheetSet
    Implements IViewSheetSet, IDisposable
public ref class InSessionViewSheetSet : IViewSheetSet,
    IDisposable
type InSessionViewSheetSet =
    class
        interface IViewSheetSet
        interface IDisposable
    end

The InSessionViewSheetSet type exposes the following members.

Properties
 | Name | Description
Public property | IsAutomatic | Automatic order or manual order.
Public property | OrderedViewList | Ordered views.
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the InSessionViewSheetSet
Top
Remarks
The in-session ViewSheetSet can't be stored in document.
See Also

Reference

Autodesk.Revit.DB Namespace