Transaction Class

Transaction Methods

The Transaction type exposes the following members.

Methods
 | Name | Description
 | Commit | Commits all changes made to the model during the transaction.
 | Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.
Public method | Dispose |
Public method | GetFailureHandlingOptions | Returns the current failure handling options.
Public method | GetName | Returns the transaction's name.
Public method | GetStatus | Returns the current status of the transaction.
Public method | HasEnded | Determines whether the transaction has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
 | RollBack | Rolls back all changes made to the model during the transaction.
 | RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.
 | SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back.
 | SetName | Sets the transaction's name.
 | Start | Starts the transaction.
 | Start(String) | Starts the transaction with an assigned name.
Top
See Also

Reference