FaceToposolid Class

FaceWall Class

A wall attached to a non-vertical massing face.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBFaceWall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceWall : HostObject
Public Class FaceWall
    Inherits HostObject
public ref class FaceWall : public HostObject
type FaceWall =
    class
        inherit HostObject
    end

The FaceWall type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
 | Create | Creates a new instance of a wall attached to a non-vertical massing face.
 | IsValidFaceReferenceForFaceWall | Identifies if a reference may be used as the parent of a face wall.
 | IsWallTypeValidForFaceWall | Identifies if a wall type may be applied to a face wall.
Top
See Also

Reference

Autodesk.Revit.DB Namespace