InstanceBinding Class

InstanceNode Class

An output node that represents an instance of a geometry. It can be an instance of FamilyInstance, or it can be and instance of a part of symbol's geometry.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBGroupNode
Autodesk.Revit.DBInstanceNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InstanceNode : GroupNode
Public Class InstanceNode
    Inherits GroupNode
public ref class InstanceNode : public GroupNode
type InstanceNode =
    class
        inherit GroupNode
    end

The InstanceNode type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetSymbolGeometryId | Gets the SymbolGeometryId associated with the node.
Top
Remarks
See also: OnInstanceBegin(InstanceNode). The SymbolGeometryId. contains the data for comparing if two InstanceNode points to the same geometry.
See Also

Reference

Autodesk.Revit.DB Namespace