ElementStructuralTypeFilter Class

ElementTransformUtils Class

A collection of utilities allowing transformation of elements (e.g. move, rotate, mirror and copy).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementTransformUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ElementTransformUtils
Public NotInheritable Class ElementTransformUtils
public ref class ElementTransformUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElementTransformUtils = class end

The ElementTransformUtils type exposes the following members.

Methods
Name | Description
CanMirrorElement | Determines whether element can be mirrored.
CanMirrorElements | Determines whether elements can be mirrored.
CopyElement | Copies an element and places the copy at a location indicated by a given transformation.
CopyElements(Document, ICollectionElementId, XYZ) | Copies a set of elements and places the copies at a location indicated by a given translation.
CopyElements(Document, ICollectionElementId, Document, Transform, CopyPasteOptions) | Copies a set of elements from source document to destination document.
CopyElements(View, ICollectionElementId, View, Transform, CopyPasteOptions) | Copies a set of elements from source view to destination view.
GetTransformFromViewToView | Returns a transformation that is applied to elements when copying from one view to another view.
MirrorElement | Creates a mirrored copy of an element about a given plane.
MirrorElements | Mirrors a set of elements about a given plane.
MoveElement | Moves one element by a given transformation.
MoveElements | Moves a set of elements by a given transformation.
RotateElement | Rotates an element about the given axis and angle.
RotateElements | Rotates a set of elements about the given axis and angle.
Top
See Also

Reference

Autodesk.Revit.DB Namespace