Plane Class

PlanTopology Class

An object that represents a Plan Topology within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPlanTopology

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PlanTopology : APIObject
Public Class PlanTopology
    Inherits APIObject
public ref class PlanTopology : public APIObject
type PlanTopology =
    class
        inherit APIObject
    end

The PlanTopology type exposes the following members.

Properties
 | Name | Description
Public property | Circuits | The Circuits of the PlanTopology.
Public property | Level | The Level of the PlanTopology.
Public property | Phase | The phase of the PlanTopology.
Top
Methods
 | Name | Description
Public method | GetRoomIds | Retrieves room ElementIds of the PlanTopology in the last phase.
Top
Remarks
This object derived from the APIObject base object. It can be used access the properties of a Plan Topology.
See Also

Reference

Autodesk.Revit.DB Namespace