ElementSet Class

A set that contains element objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBElementSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementSet : APIObject, IEnumerable
Public Class ElementSet
    Inherits APIObject
    Implements IEnumerable
public ref class ElementSet : public APIObject,
    IEnumerable
type ElementSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The ElementSet type exposes the following members.

Constructors
 | Name | Description
Public method | ElementSet | Initializes a new instance of the ElementSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of elements that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item element the set, rendering it empty.
Public method | Contains | Tests for the existence of an element within the set.
Public method | Erase | Removes a specified element from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Top
Example
C#
VB
C++
F#
Copy
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();

string info = "Selected elements:\n";
foreach (ElementId id in selectedIds)
{
    Element elem = document.GetElement(id);
    info += elem.Name + "\n";
}

TaskDialog.Show("Revit",info);
Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()

Dim info As String = "Selected elements:" & vbLf
For Each id As ElementId In selectedIds
    Dim elem As Element = document.GetElement(id)
    info += elem.Name + vbLf
Next

TaskDialog.Show("Revit", info)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace