AreaFilter Class

A filter used to match areas.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBAreaFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AreaFilter : ElementSlowFilter
Public Class AreaFilter
    Inherits ElementSlowFilter
public ref class AreaFilter : public ElementSlowFilter
type AreaFilter =
    class
        inherit ElementSlowFilter
    end

The AreaFilter type exposes the following members.

Constructors
 | Name | Description
Public method | AreaFilter | Constructs a filter which matches only areas.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.
Example
C#
VB
C++
F#
Copy
// Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter,
// and not an ElementClassFilter or the shortcut method OfClass() because the area class is not
// supported by those methods.
AreaFilter filter = new AreaFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> areas = collector.WherePasses(filter).ToElements();
' Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter,
' and not an ElementClassFilter or the shortcut method OfClass() because the area class is not
' supported by those methods.
Dim filter As New AreaFilter()

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim areas As IList(Of Element) = collector.WherePasses(filter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace