ExtrusionRoof Class

Represents some kinds of Extrusion Roofs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBRoofBase
Autodesk.Revit.DBExtrusionRoof

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExtrusionRoof : RoofBase
Public Class ExtrusionRoof
    Inherits RoofBase
public ref class ExtrusionRoof : public RoofBase
type ExtrusionRoof =
    class
        inherit RoofBase
    end

The ExtrusionRoof type exposes the following members.

Properties
 | Name | Description
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
Top
Methods
 | Name | Description
Public method | GetProfile | Retrieve the Profile of ExtrusionRoof.
Top
Remarks
The ExtrusionRoof object represents some kinds of extruded roofs in Revit.
See Also

Reference

Autodesk.Revit.DB Namespace