ModelCurveArrayIterator Class

ModelCurveNode Class

A base class of output nodes that represent various model curves.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBModelCurveNode
Autodesk.Revit.DBCurveNode
Autodesk.Revit.DBPointNode
Autodesk.Revit.DBPolylineNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelCurveNode : RenderNode
Public Class ModelCurveNode
    Inherits RenderNode
public ref class ModelCurveNode : public RenderNode
type ModelCurveNode =
    class
        inherit RenderNode
    end

The ModelCurveNode type exposes the following members.

Properties
 | Name | Description
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace