Connector Class

A connector in an Autodesk Revit MEP project document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBConnector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Connector : IConnector, IDisposable
Public Class Connector
    Implements IConnector, IDisposable
public ref class Connector : IConnector,
    IDisposable
type Connector =
    class
        interface IConnector
        interface IDisposable
    end

The Connector type exposes the following members.

Properties
 | Name | Description
Public property | AllowsSlopeAdjustments | Indicates if the connector allows the slope adjustment.
Public property | AllRefs | All references of the connector.
Public property | Angle | The angle of the Connector.
Public property | AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
Public property | AssignedDuctLossMethod | The duct loss method of the connector.
Public property | AssignedFixtureUnits | The assigned fixture units of the connector.
Public property | AssignedFlow | The assigned flow of the connector.
Public property | AssignedFlowDirection | The assigned flow direction of the connector.
Public property | AssignedFlowFactor | The assigned flow factor of this connector.
Public property | AssignedKCoefficient | The assigned kCoefficient of the connector.
Public property | AssignedLossCoefficient | The assigned loss coefficient of the connector.
Public property | AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
Public property | AssignedPipeLossMethod | The pipe loss method of the connector.
Public property | AssignedPressureDrop | The assigned pressure drop of the connector.
Public property | Coefficient | The coefficient of the connector.
Public property | ConnectorManager | The connector manager of the connector.
Public property | ConnectorType | The connector type of the connector.
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Demand | The demand of the connector.
Public property | Description | The description.
Public property | Direction | The direction of the connector.
Public property | Domain | The domain of the connector.
Public property | DuctSystemType | The duct system type of the connector.
Public property | ElectricalSystemType | The electrical system type of the connector.
Public property | EngagementLength | Connector engagement length. When applicable, it represents the inset distance to the end of the fabrication part from the connection point. Otherwise it returns zero.
Public property | Flow | The flow of the connector.
Public property | GasketLength | Connector gasket length. When applicable, it represents the distance from the end of the fabrication part to the center of the gasket. Otherwise it returns zero.
Public property | Height | The height of the connector.
Public property | Id | A unique identifier to identify this connector.
Public property | IsConnected | Identifies if the connector is physically connected to a connector on another element.
Public property | IsMovable | whether the connector can be moved.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPSystem | The system of the connector belong to.
Public property | Origin | The location of the connector.
Public property | Owner | The host of the connector.
Public property | PipeSystemType | The pipe system type of the connector.
Public property | PressureDrop | The pressure drop of the connector.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Utility | Indicates if the connector is a utility connector.
Public property | VelocityPressure | The velocity pressure of the connector.
Public property | Width | The width of the connector.
Top
Methods
 | Name | Description
Public method | ConnectTo | Make connection between two connectors.
Public method | DisconnectFrom | Remove connection between two connectors.
Public method | Dispose | Releases all resources used by the Connector
Public method | GetFabricationConnectorInfo | Gets fabrication connectivity information.
Public method | GetMEPConnectorInfo | Gets MEP connector information.
Public method | IsConnectedTo | Identifies if the connector is connected to the specified connector.
Top
Remarks
This connector is an item that is a part of another element (duct, pipe, fitting, or equipment etc.). This connector does not represent the connector element that can be created inside a family; for that element, refer to ConnectorElement.
Example
C#
VB
C++
F#
Copy
public void GetElementAtConnector(Autodesk.Revit.DB.Connector connector)
{
    MEPSystem mepSystem = connector.MEPSystem;
    if (null != mepSystem)
    {
        string message = "Connector is owned by: " + connector.Owner.Name;

        if (connector.IsConnected == true)
        {
            ConnectorSet connectorSet = connector.AllRefs;
            ConnectorSetIterator csi = connectorSet.ForwardIterator();
            while (csi.MoveNext())
            {
                Connector connected = csi.Current as Connector;
                if (null != connected)
                {
                    // look for physical connections
                    if (connected.ConnectorType == ConnectorType.End ||
                        connected.ConnectorType == ConnectorType.Curve ||
                        connected.ConnectorType == ConnectorType.Physical)
                    {
                        message += "\nConnector is connected to: " + connected.Owner.Name;
                        message += "\nConnection type is: " + connected.ConnectorType;
                    }
                }
            }
        }
        else
        {
            message += "\nConnector is not connected to anything.";
        }

        Autodesk.Revit.UI.TaskDialog.Show("Revit", message);
    }
}
Public Sub GetElementAtConnector(connector As Autodesk.Revit.DB.Connector)
    Dim mepSystem As MEPSystem = connector.MEPSystem
    If mepSystem IsNot Nothing Then
        Dim message As String = "Connector is owned by: " + connector.Owner.Name

        If connector.IsConnected = True Then
            Dim connectorSet As ConnectorSet = connector.AllRefs
            Dim csi As ConnectorSetIterator = connectorSet.ForwardIterator()
            While csi.MoveNext()
                Dim connected As Connector = TryCast(csi.Current, Connector)
                If connected IsNot Nothing Then
                    ' look for physical connections
                    If connected.ConnectorType = ConnectorType.[End] OrElse connected.ConnectorType = ConnectorType.Curve OrElse connected.ConnectorType = ConnectorType.Physical Then
                        message += vbLf & "Connector is connected to: " + connected.Owner.Name
                        message += vbLf & "Connection type is: " + connected.ConnectorType
                    End If
                End If
            End While
        Else
            message += vbLf & "Connector is not connected to anything."
        End If

        UI.TaskDialog.Show("Revit", message)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace