CADLinkType Class
Reload Overload

CameraInfo Class

An object holding information about the projection mapping of a 3D view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCameraInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CameraInfo : IDisposable
Public Class CameraInfo
    Implements IDisposable
public ref class CameraInfo : IDisposable
type CameraInfo =
    class
        interface IDisposable
    end

The CameraInfo type exposes the following members.

Properties
 | Name | Description
Public property | FarDistance | Distance from eye point to far plane of view frustum along the view direction.
Public property | HorizontalExtent | Distance between left and right planes on the target plane.
Public property | IsPerspective | Identifies whether the projection is orthographic or perspective
Public property | IsPespective | Identifies whether the projection is orthographic or perspective
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NearDistance | Distance from eye point to near plane of view frustum along the view direction.
Public property | RightOffset | Distance that the target plane is offset towards the right where right is normal to both Up direction and View direction. This offset shifts both left and right planes.
Public property | TargetDistance | Distance from eye point along view direction to target plane.
Public property | UpOffset | Distance that the target plane is offset in the direction of the Up direction. This offset shifts both top and bottom planes.
Public property | VerticalExtent | Distance between top and bottom planes on the target plane.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CameraInfo
Top
Remarks

CameraInfo can be obtained directly from a ViewNode If camera info is not available, an orthographic view should be assumed.

See also: OnViewBegin(ViewNode).

See Also

Reference

Autodesk.Revit.DB Namespace