ValueParsingOptions Class

VertexIndexPair Class

Represents a connection between vertices in the top and bottom profile of a blend.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBVertexIndexPair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VertexIndexPair
Public Class VertexIndexPair
public ref class VertexIndexPair
type VertexIndexPair = class end

The VertexIndexPair type exposes the following members.

Constructors
 | Name | Description
Public method | VertexIndexPair | Initializes a new instance of the VertexIndexPair class
Top
Properties
 | Name | Description
Public property | Bottom | The index of the vertex pair from the bottom profile.
Public property | Top | The index of the vertex pair from the top profile.
Top
Methods
 | Name | Description
Top
Remarks
Use objects of this type in GetVertexConnectionMap, SetVertexConnectionMap(VertexIndexPairArray), GetVertexConnectionMap and SetVertexConnectionMap(VertexIndexPairArray) to get/set the vertex connection map.
See Also

Reference

Autodesk.Revit.DB Namespace