ComponentRepeater Class

ComponentRepeaterIterator Class

A slot iterator for ComponentRepeater.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBComponentRepeaterIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ComponentRepeaterIterator : IEnumerator<ComponentRepeaterSlot>
Public Class ComponentRepeaterIterator
    Implements IEnumerator(Of ComponentRepeaterSlot)
public ref class ComponentRepeaterIterator : IEnumerator<ComponentRepeaterSlot^>
type ComponentRepeaterIterator =
    class
        interface IEnumerator<ComponentRepeaterSlot>
    end

The ComponentRepeaterIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ComponentRepeaterIterator
Public method | GetCurrent | Returns the current repeater slot.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Top
See Also

Reference

Autodesk.Revit.DB Namespace