ConfigurationReloadInfo Class

ConicalFace Class

A conical face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBConicalFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConicalFace : Face
Public Class ConicalFace
    Inherits Face
public ref class ConicalFace : public Face
type ConicalFace =
    class
        inherit Face
    end

The ConicalFace type exposes the following members.

Properties
 | Name | Description
Public property | Axis | Axis of the surface.
Public property | HalfAngle | Half angle of the surface.
Public property | Origin | Origin of the surface.
Public property | Radius | Radii of the surface.
Top
Methods
 | Name | Description
Top
Remarks
For details on the parameterization, refer to the documentation for ConicalSurface.
Example
C#
VB
C++
F#
Copy
private void GetConicalFaceInfo(Face face)
{
    ConicalFace conicalFace = face as ConicalFace;
    if (null != conicalFace)
    {
       XYZ axis = conicalFace.Axis;
       XYZ origin = conicalFace.Origin;
        double halfAngle = conicalFace.HalfAngle;
        XYZ radius = conicalFace.get_Radius(0);
    }
}
Private Sub GetConicalFaceInfo(face As Face)
    Dim conicalFace As ConicalFace = TryCast(face, ConicalFace)
    If conicalFace IsNot Nothing Then
        Dim axis As XYZ = conicalFace.Axis
        Dim origin As XYZ = conicalFace.Origin
        Dim halfAngle As Double = conicalFace.HalfAngle
        Dim radius As XYZ = conicalFace.Radius(0)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace