WallFoundation Class

WallFoundationType Class

An object that represents the type of a wall foundation in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBWallFoundationType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WallFoundationType : HostObjAttributes
Public Class WallFoundationType
    Inherits HostObjAttributes
public ref class WallFoundationType : public HostObjAttributes
type WallFoundationType =
    class
        inherit HostObjAttributes
    end

The WallFoundationType type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace