CriticalPathIterator Methods

The CriticalPathIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | GetCurrent | Gets the analytical segment id at the current iterating position.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next downstream segment on the critical path.
Public method | Reset | Resets the iterator to the beginning segment.
Top
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace