ViewScheduleExportOptions Class

ViewSection Class

ViewSection covers sections, details, elevations, and callouts, all in their reference and non-reference variations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBViewSection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSection : View
Public Class ViewSection
    Inherits View
public ref class ViewSection : public View
type ViewSection =
    class
        inherit View
    end

The ViewSection type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
 | CreateCallout | Creates a new callout view.
 | CreateDetail | Returns a new detail ViewSection.
 | CreateReferenceCallout | Creates a new reference callout.
 | CreateReferenceSection | Creates a new reference section.
 | CreateSection | Returns a new section ViewSection.
 | IsParentViewValidForCallout | This validator checks that the parent view is appropriate for callout views.
Public method | IsSplitSection | Sections can be split (jog) so that they cut at >1 plane.
 | IsViewFamilyTypeValidForCallout | This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.
Top
Remarks
The creation functions for elevations can be found in the ElevationMarker class.
See Also

Reference

Autodesk.Revit.DB Namespace