Mullion Class

Represents a CurtainGrid within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBFamilyInstance
Autodesk.Revit.DBMullion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Mullion : FamilyInstance
Public Class Mullion
    Inherits FamilyInstance
public ref class Mullion : public FamilyInstance
type Mullion =
    class
        inherit FamilyInstance
    end

The Mullion type exposes the following members.

Properties
 | Name | Description
Public property | LocationCurve | This method get the curve location of the current Mullion.
Public property | Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Public property | Lockable | Get - to get whether the Mullion can be lock or unlock.
Public property | MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Top
Methods
 | Name | Description
Public method | BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
Public method | JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
Top
See Also

Reference

Autodesk.Revit.DB Namespace