City Class

CitySet Class

An set that contains cities.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCitySet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CitySet : APIObject, IEnumerable
Public Class CitySet
    Inherits APIObject
    Implements IEnumerable
public ref class CitySet : public APIObject,
    IEnumerable
type CitySet =
    class
        inherit APIObject
        interface IEnumerable
    end

The CitySet type exposes the following members.

Constructors
 | Name | Description
Public method | CitySet | Initializes a new instance of the CitySet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of cities that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace