ElementIntersectsElementFilter Class

ElementIntersectsFilter Class

A base class for filters used to match elements which intersect with geometry.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementIntersectsFilter
Autodesk.Revit.DBElementIntersectsElementFilter
Autodesk.Revit.DBElementIntersectsSolidFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementIntersectsFilter : ElementSlowFilter
Public Class ElementIntersectsFilter
    Inherits ElementSlowFilter
public ref class ElementIntersectsFilter : public ElementSlowFilter
type ElementIntersectsFilter =
    class
        inherit ElementSlowFilter
    end

The ElementIntersectsFilter type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
 | IsCategorySupported | Identifies if the input element is of a category supported by element intersection filters.
 | IsElementSupported | Identifies if the input element is supported by element intersection filters.
Top
See Also

Reference

Autodesk.Revit.DB Namespace