Transform1D Class

Transform2D Class

An affine transform of 2D Euclidean space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTransform2D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Transform2D : IDisposable
Public Class Transform2D
    Implements IDisposable
public ref class Transform2D : IDisposable
type Transform2D =
    class
        interface IDisposable
    end

The Transform2D type exposes the following members.

Constructors
 | Name | Description
Public method | Transform2D(Transform2D) | The copy constructor.
Public method | Transform2D(UV, UV, UV) | Constructs the transformation by specifying the vectors and the origin.
Top
Properties
 | Name | Description
Public property | BasisU | The image of (1, 0) under OfVector(UV).
Public property | BasisV | The image of (0, 1) under OfVector(UV).
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection (i.e., is orientation-reversing).
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Origin | The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.
Public property | Scale | The real number that represents the scale of the conformal transformation.
Top
Methods
 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
 | CreateIdentity | Creates the identity transformation.
Public method | Dispose | Releases all resources used by the Transform2D
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transformation to the vector and returns the result.
Public method | PostScale | Scales both the linear and translational parts of this transformation and returns the result.
Public method | PreScale | Scales the linear part of this transformation and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform.
Public method | TransformUVDomainIfPossible | Transforms an envelope (BoundingBoxUV) for one surface to an envelope for a coincident but differently parameterized surface.
Top
Remarks
An affine transform is a linear transform plus a translation (which may be zero). Some functions only accept certain kinds of transform (e.g., rigid motion, conformal, non-singular, etc.).
See Also

Reference

Autodesk.Revit.DB Namespace