NumericRevisionSettings Class

NurbSpline Class

A nurb spline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBNurbSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NurbSpline : Curve
Public Class NurbSpline
    Inherits Curve
public ref class NurbSpline : public Curve
type NurbSpline =
    class
        inherit Curve
    end

The NurbSpline type exposes the following members.

Properties
 | Name | Description
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
Public property | isRational | Returns whether the nurb spline is rational or not.
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Weights | Returns the weights of the nurb spline.
Top
Methods
 | Name | Description
 | Create | Creates a new geometric NurbSpline object from a HermiteSpline.
 | CreateCurve(HermiteSpline) | Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(IListXYZ, IListDouble) | Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(Int32, IListDouble, IListXYZ) | Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(Int32, IListDouble, IListXYZ, IListDouble) | Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.
Top
Remarks
The nurb spline lies in the plane defined by control point, weight,knots,degree.
See Also

Reference

Autodesk.Revit.DB Namespace