RelinquishedItems Class

RelinquishOptions Class

Options to control behavior of relinquishing ownership of elements and worksets.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRelinquishOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RelinquishOptions : IDisposable
Public Class RelinquishOptions
    Implements IDisposable
public ref class RelinquishOptions : IDisposable
type RelinquishOptions =
    class
        interface IDisposable
    end

The RelinquishOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RelinquishOptions | Constructs a new instance of RelinquishOptions.
Top
Properties
 | Name | Description
Public property | CheckedOutElements | True means all elements checked out by the current user should be relinquished. False means none of these are relinquished.
Public property | FamilyWorksets | True means all family worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardWorksets | True means all project standards worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | UserWorksets | True means all user-created worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | ViewWorksets | True means all view worksets owned by the current user should be relinquished. False means none of these are relinquished.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RelinquishOptions
Top
Remarks

The settings correspond to the checkboxes in the Synchronize with Central dialog in the section "After synchronizing, relinquish the following worksets and elements:".

An element can be owned (reflected in the "Edited By" parameter) either by being checked out ("borrowed") or by belonging to a checked out workset.

Relinquishing a workset will relinquish all its unmodified elements that the current user owns.

The subtle interactions between checking out elements and checking out worksets are beyond the scope of the documentation for this class. But as an example, if a wall is borrowed (explicitly checked out) and then its workset is checked out, then the wall is no longer considered borrowed because the workset ownership implicitly grants ownership of all elements in the workset (except elements borrowed by other users).

See Also

Reference

Autodesk.Revit.DB Namespace