TextNoteOptions Class

Options to use when creating a new text note element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTextNoteOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextNoteOptions : IDisposable
Public Class TextNoteOptions
    Implements IDisposable
public ref class TextNoteOptions : IDisposable
type TextNoteOptions =
    class
        interface IDisposable
    end

The TextNoteOptions type exposes the following members.

Constructors
 | Name | Description
Public method | TextNoteOptions | Default constructor; populates the options with their respective default values.
Public method | TextNoteOptions(ElementId) | Constructs text options to create text of the given type.
Top
Properties
 | Name | Description
Public property | HorizontalAlignment | Horizontal alignment of the text.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | KeepRotatedTextReadable | Flag controling whether a rotate text is to stay oriented to be always readable.
Public property | Rotation | Base line angle of a text note, in radians.
Public property | TypeId | Id of a text type that defines the style of a text note.
Public property | VerticalAlignment | Vertical alignment of the text.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TextNoteOptions
Top
Remarks
Use an instance of this class as an argument in the TextNote.Create methods.
Example
C#
VB
C++
F#
Copy
#region Autodesk.Revit.DB.TextNote.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.XYZ, double, System.String, Autodesk.Revit.DB.TextNoteOptions)
#region Autodesk.Revit.DB.TextElement.GetMinimumAllowedWidth(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId)
public TextNote AddNewTextNote(UIDocument uiDoc)
{
    Document doc = uiDoc.Document;
    XYZ textLoc = uiDoc.Selection.PickPoint("Pick a point for sample text.");
    ElementId defaultTextTypeId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType);
    double noteWidth = .2;

    // make sure note width works for the text type
    double minWidth = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId);
    double maxWidth = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId);
    if (noteWidth < minWidth)
    {
        noteWidth = minWidth;
    }
    else if (noteWidth > maxWidth)
    {
        noteWidth = maxWidth;
    }

    TextNoteOptions opts = new TextNoteOptions(defaultTextTypeId);
    opts.HorizontalAlignment = HorizontalTextAlignment.Left;
    opts.Rotation = Math.PI / 4;

    TextNote textNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts);

    return textNote;
}
#endregion
#endregion
#Region "Autodesk.Revit.DB.TextNote.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.XYZ, double, System.String, Autodesk.Revit.DB.TextNoteOptions)"
#Region "Autodesk.Revit.DB.TextElement.GetMinimumAllowedWidth(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId)"
        Public Function AddNewTextNote(uiDoc As UIDocument) As TextNote
            Dim doc As Document = uiDoc.Document
            Dim textLoc As XYZ = uiDoc.Selection.PickPoint("Pick a point for sample text.")
            Dim defaultTextTypeId As ElementId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType)
            Dim noteWidth As Double = 0.2

            ' make sure note width works for the text type
            Dim minWidth As Double = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId)
            Dim maxWidth As Double = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId)
            If noteWidth < minWidth Then
                noteWidth = minWidth
            ElseIf noteWidth > maxWidth Then
                noteWidth = maxWidth
            End If

            Dim opts As New TextNoteOptions(defaultTextTypeId)
            opts.HorizontalAlignment = HorizontalTextAlignment.Left
            opts.Rotation = Math.PI / 4

            Dim textNote__1 As TextNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts)

            Return textNote__1
        End Function
#End Region
#End Region

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace