FailureDefinitionAccessor Class

FailureDefinitionId Class

The unique identifier of a FailureDefinition.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGuidEnum
Autodesk.Revit.DBFailureDefinitionId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureDefinitionId : GuidEnum
Public Class FailureDefinitionId
    Inherits GuidEnum
public ref class FailureDefinitionId : public GuidEnum
type FailureDefinitionId =
    class
        inherit GuidEnum
    end

The FailureDefinitionId type exposes the following members.

Constructors
 | Name | Description
Public method | FailureDefinitionId | Creates a new FailureDefinitionId instance.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Operators
Name | Description
Equality(FailureDefinitionId, FailureDefinitionId) | Compares two FailureDefinitionId instances.
Inequality(FailureDefinitionId, FailureDefinitionId) | Compares two FailureDefinitionId instances.
Top
Remarks
Each possible failure in Revit must be defined and registered during Revit application startup by creating a FailureDefinition object. Unique FailureDefinitionId must be used as a key to register FailureDefinition. Those unique FailureDefinitionId should be created using GUID generation tool. Later FailureDefinitionId can be used to lookup FailureDefinition in FailureDefinitionRegistry, and create and post FailureMessages.
See Also

Reference

Autodesk.Revit.DB Namespace