BuiltInFailuresOffsetFacesCellLegacyFailures Class

BuiltInFailures.OpeningFailures Class

BuiltInFailuresOpeningFailures Class

Failures about Opening.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresOpeningFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class OpeningFailures
Public NotInheritable Class OpeningFailures
public ref class OpeningFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type OpeningFailures = class end

The BuiltInFailuresOpeningFailures type exposes the following members.

Properties
Name | Description
HostForCutHasNoGeometry | Host can't be cut because it has no geometry.
HostForCutHasNoGeometryWarn | Host can't be cut because it has no geometry.
InvalidComplexCut | The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.
ModelAlreadyCheckedOutByUser | The Cloud WorkSharing Model is already checked out by the current user.
OpeningCutAll | Opening completely removes its host
OpeningDoesnotCutHost | Opening does not cut its host.
OpeningDoesnotCutHostDelete | Opening does not cut its host.
OpeningNegativeHeight | The top of the Opening is lower than the bottom of the Opening or coincident with it.
OpeningPartiallyCutsHost | Opening partially cuts its host.
OpeningRectDoesnotCutHost | Rectangular opening doesn't cut its host.
OpeningRemovesHost | Opening completely removes its host.
OpenStringerConflictNosing | Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.
PropertyNotClosed | Property lines do not form a closed loop. Area will not be computed.
Top
See Also

Reference

Autodesk.Revit.DB Namespace