FilterCategoryRule Class

FilterDoubleRule Class

A filter rule that operates on double-precision numeric values in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterDoubleRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterDoubleRule : FilterNumericValueRule
Public Class FilterDoubleRule
    Inherits FilterNumericValueRule
public ref class FilterDoubleRule : public FilterNumericValueRule
type FilterDoubleRule =
    class
        inherit FilterNumericValueRule
    end

The FilterDoubleRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterDoubleRule | Constructs an instance of FilterDoubleRule.
Top
Properties
 | Name | Description
Public property | Epsilon | The tolerance within which two floating-point values may be considered equal.
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace