MEPSupportUtils Class

MEPSystem Class

A system in the Autodesk Revit MEP product.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBMEPSystem
Autodesk.Revit.DB.ElectricalElectricalSystem
Autodesk.Revit.DB.MechanicalMechanicalSystem
Autodesk.Revit.DB.PlumbingPipingSystem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPSystem : Element
Public Class MEPSystem
    Inherits Element
public ref class MEPSystem : public Element
type MEPSystem =
    class
        inherit Element
    end

The MEPSystem type exposes the following members.

Properties
 | Name | Description
Public property | BaseEquipment | The base panel or equipment of the system.
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | ConnectorManager | Connector manager of the system.
Public property | Elements | Terminal elements in the system.
Public property | HasDesignParts | Indicates if the system has one or more design parts.
Public property | HasFabricationParts | Indicates if the system has one or more fabrication parts.
Public property | HasPlaceholders | Indicates if the system has one or more placeholders.
Public property | IsEmpty | Indicates if the system is empty or not.
Public property | IsMultipleNetwork | Indicates if the system is well connected or not. The flag will enable the "Divide System" button.
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path.
Public property | SectionsCount | The number of sections.
Top
Methods
 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors.
Public method | DivideSystem | Divide the phyisical networks in the system and create a new system for each network.
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers.
Public method | GetPhysicalNetworksNumber | Get the physical networks number in the system.
Public method | GetSectionByIndex | Get the section from the index.
Public method | GetSectionByNumber | Get the Section from section number
Public method | IsSystemDividable | Checks if the system is dividable. The system is dividable if there is more than one physical network in the system. Currently, only HVAC and piping systems support dividing.
Public method | Remove(ConnectorSet) | Removes connectors from system.
Public method | Remove(ICollectionElementId) | Remove elements from system.
Top
Remarks
This is the base class for electrical, mechanical and piping systems, available only in the Autodesk Revit MEP product.
See Also

Reference

Autodesk.Revit.DB Namespace