ExportFontTable Class

ExportFontTableIterator Class

An iterator to a set of font table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportFontTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportFontTableIterator : IEnumerator<KeyValuePair<ExportFontKey, ExportFontInfo>>
Public Class ExportFontTableIterator
    Implements IEnumerator(Of KeyValuePair(Of ExportFontKey, ExportFontInfo))
public ref class ExportFontTableIterator : IEnumerator<KeyValuePair<ExportFontKey^, ExportFontInfo^>>
type ExportFontTableIterator =
    class
        interface IEnumerator<KeyValuePair<ExportFontKey, ExportFontInfo>>
    end

The ExportFontTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportFontTableIterator
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Top
See Also

Reference

Autodesk.Revit.DB Namespace