ParameterFilterRuleFactory Class

ParameterFilterUtilities Class

Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterFilterUtilities

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ParameterFilterUtilities
Public NotInheritable Class ParameterFilterUtilities
public ref class ParameterFilterUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ParameterFilterUtilities = class end

The ParameterFilterUtilities type exposes the following members.

Methods
Name | Description
GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
IsParameterApplicable | Used to determine whether the element supports the given parameter.
RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.
Top
See Also

Reference

Autodesk.Revit.DB Namespace