GroupTypeId Class

GuidEnum Class

Base class of all GUID-based enum classes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGuidEnum
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GuidEnum
Public Class GuidEnum
public ref class GuidEnum
type GuidEnum = class end

The GuidEnum type exposes the following members.

Constructors
 | Name | Description
Public method | GuidEnum | Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.
Top
Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object.
Top
Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Overrides ObjectGetHashCode)
Top
See Also

Reference

Autodesk.Revit.DB Namespace