FloorType Class

An object that specifies the type of a floor in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBFloorType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FloorType : HostObjAttributes
Public Class FloorType
    Inherits HostObjAttributes
public ref class FloorType : public HostObjAttributes
type FloorType =
    class
        inherit HostObjAttributes
    end

The FloorType type exposes the following members.

Properties
 | Name | Description
Public property | IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Public property | StructuralMaterialId | Returns the identifier of the material that defines the element's structural analysis properties.
Public property | ThermalProperties | The calculated and settable thermal properties of the FloorType
Top
Methods
 | Name | Description
Top
Remarks
The structural layers of the floor can be accessed via this object.
Example
C#
VB
C++
F#
Copy
public void GetInfo_FloorType(FloorType floorType)
{
    string message;
    // Get whether FloorType is a foundation slab
    message = "If is foundation slab : " + floorType.IsFoundationSlab;
    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_FloorType(floorType As FloorType)
    Dim message As String
    ' Get whether FloorType is a foundation slab
    message = "If is foundation slab : " & Convert.ToString(floorType.IsFoundationSlab)
    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace