ExportLinetypeTableIterator Class

ExportLineweightInfo Class

A value used to represent the info stored in the ExportLineweightTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLineweightInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLineweightInfo : IDisposable
Public Class ExportLineweightInfo
    Implements IDisposable
public ref class ExportLineweightInfo : IDisposable
type ExportLineweightInfo =
    class
        interface IDisposable
    end

The ExportLineweightInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLineweightInfo | Constructs a new default ExportLineweightInfo.
Public method | ExportLineweightInfo(ExportLineweightInfo) | Constructs a new copy of the input ExportLineweightInfo object.
Public method | ExportLineweightInfo(String) | Constructs a new ExportLineweightInfo using the destination line weight name as input.
Top
Properties
 | Name | Description
Public property | DestinationLineweightName | The destination lineweight name (the name of the line weight in the exported format)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLineweightInfo
Top
See Also

Reference

Autodesk.Revit.DB Namespace