Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBMEPCurveType
Autodesk.Revit.DB.ElectricalCableTrayType
Autodesk.Revit.DB.ElectricalConduitType
Autodesk.Revit.DB.MechanicalDuctType
Autodesk.Revit.DB.MechanicalFlexDuctType
Autodesk.Revit.DB.PlumbingFlexPipeType
Autodesk.Revit.DB.PlumbingPipeType

MEPCurveType Properties

The MEPCurveType type exposes the following members.

Properties
 | Name | Description
Public property | Cross | The default cross fitting of the MEP curve type.
Public property | Elbow | The default elbow fitting of the MEP curve type.
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type.
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType
Public property | Shape | The shape of the profile.
Public property | Tap | The default tap fitting of the MEP curve type.
Public property | Tee | The default tee fitting of the MEP curve type.
Public property | Transition | The default transition fitting of the MEP curve type.
Public property | Union | The default union fitting of the MEP curve type.
Top
See Also

Reference