WorksharingDisplayGraphicSettings Class

WorksharingDisplayMode Enumeration

Indicates which worksharing display mode a view is in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WorksharingDisplayMode
Public Enumeration WorksharingDisplayMode
public enum class WorksharingDisplayMode
type WorksharingDisplayMode
Members
Member name | Value | Description
Off | 0 | No active worksharing display mode.
CheckoutStatus | 1 | The view is displaying the checkout status of elements.
Owners | 2 | The view is displaying the specific owners of elements.
ModelUpdates | 3 | The view is displaying model updates.
Worksets | 4 | The view is displaying which workset each element is assigned to.
Example
C#
VB
C++
F#
Copy
public void GetWorksharingDisplayMode(View view)
{
    // Get and Set worksharingDisplayMode of a given view
    WorksharingDisplayMode displayMode = view.GetWorksharingDisplayMode();
    Autodesk.Revit.UI.TaskDialog.Show("GetWorksharingDisplayMode", "WorksharingDisplayMode : " + displayMode);

    view.SetWorksharingDisplayMode(WorksharingDisplayMode.CheckoutStatus);
    Autodesk.Revit.UI.TaskDialog.Show("SetWorksharingDisplayMode", "CheckoutStatus was set for View: " + view.Name);
}
Public Sub GetWorksharingDisplayMode(view As View)
    ' Get and Set worksharingDisplayMode of a given view
    Dim displayMode As WorksharingDisplayMode = view.GetWorksharingDisplayMode()
    Autodesk.Revit.UI.TaskDialog.Show("GetWorksharingDisplayMode", "WorksharingDisplayMode : " + displayMode)

    view.SetWorksharingDisplayMode(WorksharingDisplayMode.CheckoutStatus)
    Autodesk.Revit.UI.TaskDialog.Show("SetWorksharingDisplayMode", "CheckoutStatus was set for View: " + view.Name)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace