BuiltInFailuresRebarBendingDetailFailures Class

BuiltInFailures.RebarCouplerFailures Class

BuiltInFailuresRebarCouplerFailures Class

Failures concerning couplers
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRebarCouplerFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RebarCouplerFailures
Public NotInheritable Class RebarCouplerFailures
public ref class RebarCouplerFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RebarCouplerFailures = class end

The BuiltInFailuresRebarCouplerFailures type exposes the following members.

Properties
Name | Description
CantKeepConstraintsToBars | The constraints between the coupler and the two connected bars are no longer satisfied. Post error to delete the coupler.
CouplerRequiredRemoveFromGroup | The coupler is invalid in group.
CouplerTypeInvalid | This coupler type does not fit on the selected bar(s). Post error to delete the coupler.
DisconnectElements | Disconnect the coupler from the connected bar.
DistanceBetweenBarsError | This is used to post error. The distance between the connected ends of the bars exceeds 10 bar diameters.
DistanceBetweenBarsWarning | This is used to post warning. The distance between the connected ends of the bars exceeds 10 bar diameters.
EngagementBiggerThanLengthError | This is used to post error. The sum of bar engagements is greater than the total coupler length.
EngagementBiggerThanLengthWarning | This is used to post warning. The sum of bar engagements is greater than the total coupler length.
LengthParameterError | This is used to post error. The "Total Length" parameter must be set to a strictly positive value.
LengthParameterWarning | This is used to post warning. The "Total Length" parameter must be set to a strictly positive value.
MainEngagementParameterError | This is used to post error. "Bar Engagement 1" has an incorrect value.
MainEngagementParameterWarning | This is used to post warning. "Bar Engagement 1" has an incorrect value.
NewCouplerTypeCreated | A new coupler type was automatically created to fit the bar diameters.
NoBarSizeError | This is used to post error. At least Bar Size 1 or Bar Size 2 should have another value than "None".
NoBarSizeWarning | This is used to post warning. At least Bar Size 1 or Bar Size 2 should have a value other than "None".
NoTypeParamsDefinedWarning | The parameters of the default type have no values.
SecondaryEngagementParameterError | This is used to post error. "Bar Engagement 2" has an incorrect value.
SecondaryEngagementParameterWarning | This is used to post warning. "Bar Engagement 2" has an incorrect value.
WidthParameterError | This is used to post error.The "External Diameter" parameter must be set to a strictly positive value.
WidthParameterWarning | This is used to post warning. The "External Diameter" parameter must be set to a strictly positive value.
Top
See Also

Reference

Autodesk.Revit.DB Namespace