RevitLinkGraphicsSettings Class

RevitLinkInstance Class

Represents an instance of a RevitLinkType.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBRevitLinkInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitLinkInstance : Instance
Public Class RevitLinkInstance
    Inherits Instance
public ref class RevitLinkInstance : public Instance
type RevitLinkInstance =
    class
        inherit Instance
    end

The RevitLinkInstance type exposes the following members.

Properties
 | Name | Description
Top
Methods
Name | Description
Create(Document, ElementId) | Creates a new instance of a linked Revit project (RevitLinkType).
Create(Document, ElementId, ImportPlacement) | Creates a new instance of a linked Revit project (RevitLinkType).
Public method | GetLinkDocument | The document associated with the Revit link.
Public method MoveBasePointToHostBasePoint

Moves this link instance so that the base point in the linked document is aligned to the base point in the host document. This is a one-time movement and does not set up any shared coordinates relationship.

If the rotation angle of this link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.

Public method MoveOriginToHostOrigin

Moves this link instance so that the internal origin of the linked document is aligned to the internal origin of the host document. This is a one-time movement and does not set up any shared coordinates relationship.

If the rotation angle of the link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.

Top
See Also

Reference

Autodesk.Revit.DB Namespace