CylindricalFace Class

CylindricalHelix Class

A cylindrical helix.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBCylindricalHelix

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CylindricalHelix : Curve
Public Class CylindricalHelix
    Inherits Curve
public ref class CylindricalHelix : public Curve
type CylindricalHelix =
    class
        inherit Curve
    end

The CylindricalHelix type exposes the following members.

Properties
 | Name | Description
Public property | BasePoint | The base point of the axis of the cylindrical helix.
Public property | Height | Height of the cylindrical helix.
Public property | IsRightHanded | True if the helix is right handed, false if the helix is left handed.
Public property | Pitch | The pitch of the cylindrical helix.
Public property | Radius | The radius of the cylindrical helix.
Public property | XVector | The X direction vector.
Public property | YVector | The Y direction vector.
Public property | ZVector | The Z direction vector, which is same as the axis direction vector.
Top
Methods
 | Name | Description
 | Create | Create a cylindrical helix.
Top
Remarks
The helix winds around a cylinder making constant angle with the axis of the cylinder. In this release, CylindricalHelix curves are used only in specific applications in stairs and railings, and should not be used or encountered when accessing curves of other Revit elements and geometry.
See Also

Reference

Autodesk.Revit.DB Namespace