ForgeTypeId Class

Form Class

An object that represents a Form within the Autodesk Revit Massing Family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBForm

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Form : GenericForm
Public Class Form
    Inherits GenericForm
public ref class Form : public GenericForm
type Form =
    class
        inherit GenericForm
    end

The Form type exposes the following members.

Properties
 | Name | Description
Public property | AreProfilesConstrained | Get/set if the form's profiles are constrained.
Public property | BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
Public property | CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
Public property | HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
Public property | HasOpenGeometry | Tell if the form has an open geometry.
Public property | IsInXRayMode | Get/set if the form is in X-Ray mode.
Public property | PathCurveCount | The number of curves in the form path.
Public property | PathCurveReference | The curve reference in the path, specified by curve index.
Public property | ProfileCount | The number of profiles in the form.
Public property | ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
Public property | TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
Top
Methods
 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Public method | AddProfile | Add a profile into the form, by a specified edge/param.
Public method | CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
Public method | CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
Public method | ConstrainProfiles | Constrain form profiles using the specified profile as primary. This is an advanced version of property "AreProfilesConstrained", allowing specify the primary profile.
Public method | DeleteProfile | Delete a profile of the form.
Public method | DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Public method | GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
Public method | GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
Public method | GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
Public method | GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
Public method | IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
Public method | IsBeginningFace | Given a face, tell if it is a beginning cap face.
Public method | IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
Public method | IsCurveReference | Tell if the pick is the reference to a curve of the form.
Public method | IsEdgeReference | Tell if the pick is the reference to an edge of the form.
Public method | IsEndFace | Given a face, tell if it is an end cap face.
Public method | IsFaceReference | Tell if the pick is the reference to a face of the form.
Public method | IsProfileEdge | Tell if an edge or curve is generated from a profile.
Public method | IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
Public method | IsSideFace | Given a face, tell if it is a side face.
Public method | IsVertexReference | Tell if the pick is the reference to a vertex of the form.
 | MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
 | MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane
Public method | RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
Public method | RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Public method | ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
Public method | ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
Top
Remarks
For any reference returned from a Form method, its GeometryObject will become invalid after a form modification method, e.g. MoveSubElement. Call the method on the Form object to retrieve the new reference if it is needed after the modification.
See Also

Reference

Autodesk.Revit.DB Namespace