ElementIsCurveDrivenFilter Class

ElementIsElementTypeFilter Class

A filter used to match elements which are ElementTypes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementIsElementTypeFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementIsElementTypeFilter : ElementQuickFilter
Public Class ElementIsElementTypeFilter
    Inherits ElementQuickFilter
public ref class ElementIsElementTypeFilter : public ElementQuickFilter
type ElementIsElementTypeFilter =
    class
        inherit ElementQuickFilter
    end

The ElementIsElementTypeFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementIsElementTypeFilter | Constructs a new instance of a filter to match only ElementTypes.
Public method | ElementIsElementTypeFilter(Boolean) | Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also

Reference

Autodesk.Revit.DB Namespace