CurveByPoints Class

CurveByPointsArray Class

An array that can contain CurveByPoints elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurveByPointsArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveByPointsArray : APIObject,
    IEnumerable
Public Class CurveByPointsArray
    Inherits APIObject
    Implements IEnumerable
public ref class CurveByPointsArray : public APIObject,
    IEnumerable
type CurveByPointsArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The CurveByPointsArray type exposes the following members.

Constructors
 | Name | Description
Public method | CurveByPointsArray | Initializes a new instance of the CurveByPointsArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace