IDuplicateTypeNamesHandler Interface

IExportContext Interface

An interface that is used in custom export to process a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExportContext
Public Interface IExportContext
public interface class IExportContext
type IExportContext = interface end

The IExportContext type exposes the following members.

Methods
 | Name | Description
Public method | Finish | This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).
Public method | IsCanceled | This method is queried at the beginning of every element.
 | OnElementBegin | This method marks the beginning of an element to be exported.
Public method | OnElementEnd | This method marks the end of an element being exported.
 | OnFaceBegin | This method marks the beginning of a Face to be exported.
Public method | OnFaceEnd | This method marks the end of the current face being exported.
 | OnInstanceBegin | This method marks the start of processing of an instance node (e.g. a family instance).
Public method | OnInstanceEnd | This method marks the end of processing of an Instance Node (e.g. a family instance).
 | OnLight | This method marks the beginning of export of a light which is enabled for rendering.
 | OnLinkBegin | This method marks the beginning of a link instance to be exported.
Public method | OnLinkEnd | This method marks the end of a link instance being exported.
 | OnMaterial | This method marks a change of the material.
 | OnPolymesh | This method is called when a tessellated polymesh of a 3d face is being output.
Public method | OnRPC | This method marks the beginning of export of an RPC object.
 | OnViewBegin | This method marks the beginning of a 3D view to be exported.
Public method | OnViewEnd | This method marks the end of a 3D view being exported.
 | Start | This method is called at the very start of the export process, still before the first entity of the model was send out.
Top
Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The methods of the context are then called at times of exporting entities of the model.

This is a base class for two other interfaces derived from it: IPhotoRenderContext and IModelExportContext. This base class contains methods that are common to both the leaf interfaces. Although it is still possible to use classes deriving directly from this base interface (for backward compatibility), future applications should implement the new leaf interfaces only.

See Also

Reference

Autodesk.Revit.DB Namespace