TriOrQuadFacet Class

TypeBinding Class

TypeBinding objects are used to bind a property to a Revit type, such as a wall type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBBinding
Autodesk.Revit.DBElementBinding
Autodesk.Revit.DBTypeBinding

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TypeBinding : ElementBinding
Public Class TypeBinding
    Inherits ElementBinding
public ref class TypeBinding : public ElementBinding
type TypeBinding =
    class
        inherit ElementBinding
    end

The TypeBinding type exposes the following members.

Constructors
 | Name | Description
Public method | TypeBinding | Constructs an empty type binding.
Public method | TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.
Example
C#
VB
C++
F#
Copy
public bool SetNewParameterToTypeWall(UIApplication app, DefinitionFile myDefinitionFile)
{
    // Create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters");

    // Create a type definition
    ExternalDefinitionCreationOptions option = new ExternalDefinitionCreationOptions("CompanyName", SpecTypeId.String.Text);
    Definition myDefinition_CompanyName = myGroup.Definitions.Create(option);

    // Create a category set and insert category of wall to it
    CategorySet myCategories = app.Application.Create.NewCategorySet();
    // Use BuiltInCategory to get category of wall
    Category myCategory = Category.GetCategory(app.ActiveUIDocument.Document, BuiltInCategory.OST_Walls);

    myCategories.Insert(myCategory);

    //Create an object of TypeBinding according to the Categories
    TypeBinding typeBinding = app.Application.Create.NewTypeBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveUIDocument.Document.ParameterBindings;

    // Bind the definitions to the document
    bool typeBindOK = bindingMap.Insert(myDefinition_CompanyName, typeBinding,
      GroupTypeId.Text);
    return typeBindOK;
}
Public Function SetNewParameterToTypeWall(app As UIApplication, myDefinitionFile As DefinitionFile) As Boolean
   ' Create a new group in the shared parameters file
   Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
   Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters")

   ' Create a type definition
   Dim [option] As New ExternalDefinitionCreationOptions("CompanyName", SpecTypeId.String.Text)
   Dim myDefinition_CompanyName As Definition = myGroup.Definitions.Create([option])

   ' Create a category set and insert category of wall to it
   Dim myCategories As CategorySet = app.Application.Create.NewCategorySet()
   ' Use BuiltInCategory to get category of wall
   Dim myCategory As Category = Category.GetCategory(app.ActiveUIDocument.Document, BuiltInCategory.OST_Walls)

   myCategories.Insert(myCategory)

   'Create an object of TypeBinding according to the Categories
   Dim typeBinding As TypeBinding = app.Application.Create.NewTypeBinding(myCategories)

   ' Get the BingdingMap of current document.
   Dim bindingMap As BindingMap = app.ActiveUIDocument.Document.ParameterBindings

      ' Bind the definitions to the document
      Dim typeBindOK As Boolean = bindingMap.Insert(myDefinition_CompanyName, typeBinding, GroupTypeId.Text)
      Return typeBindOK
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace