BIMExportOptions Class

The base class for options used to export using ATF.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBIMExportOptions
Autodesk.Revit.DBOBJExportOptions
Autodesk.Revit.DBSTEPExportOptions
Autodesk.Revit.DBSTLExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BIMExportOptions : IDisposable
Public Class BIMExportOptions
    Implements IDisposable
public ref class BIMExportOptions : IDisposable
type BIMExportOptions =
    class
        interface IDisposable
    end

The BIMExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BIMExportOptions
Top
See Also

Reference

Autodesk.Revit.DB Namespace