ParameterValue Class

ParameterValuePresenceRule Class

Tests whether an element's parameter has a value or not.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBParameterValuePresenceRule
Autodesk.Revit.DBHasNoValueFilterRule
Autodesk.Revit.DBHasValueFilterRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterValuePresenceRule : FilterRule
Public Class ParameterValuePresenceRule
    Inherits FilterRule
public ref class ParameterValuePresenceRule : public FilterRule
type ParameterValuePresenceRule =
    class
        inherit FilterRule
    end

The ParameterValuePresenceRule type exposes the following members.

Properties
 | Name | Description
Public property | Parameter | The parameter which will be evaluated to pass this rule.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace