LayerModifier Class

LayoutRule Class

The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLayoutRule
Autodesk.Revit.DBLayoutRuleClearSpacing
Autodesk.Revit.DBLayoutRuleFixedDistance
Autodesk.Revit.DBLayoutRuleFixedNumber
Autodesk.Revit.DBLayoutRuleMaximumSpacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class LayoutRule : APIObject
Public MustInherit Class LayoutRule
    Inherits APIObject
public ref class LayoutRule abstract : public APIObject
[<AbstractClassAttribute>]
type LayoutRule =
    class
        inherit APIObject
    end

The LayoutRule type exposes the following members.

Properties
Name | Description
Top
Methods
 | Name | Description
Top
Remarks
This class just used as the base class of those concrete LayoutRule classes.
See Also

Reference

Autodesk.Revit.DB Namespace