HostedSweep Class

An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBHostedSweep
Autodesk.Revit.DB.ArchitectureFascia
Autodesk.Revit.DB.ArchitectureGutter
Autodesk.Revit.DBSlabEdge

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class HostedSweep : HostObject
Public MustInherit Class HostedSweep
    Inherits HostObject
public ref class HostedSweep abstract : public HostObject
[<AbstractClassAttribute>]
type HostedSweep =
    class
        inherit HostObject
    end

The HostedSweep type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created.
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.
Top
Methods
 | Name | Description
Public method | AddSegment | Add segments to the hosted sweep object.
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.
Top
See Also

Reference

Autodesk.Revit.DB Namespace