SlabShapeCrease Class

SlabShapeCreaseArray Class

An array that can contain any number of creases used in Slab Shape Editing.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSlabShapeCreaseArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SlabShapeCreaseArray : APIObject,
    IEnumerable
Public Class SlabShapeCreaseArray
    Inherits APIObject
    Implements IEnumerable
public ref class SlabShapeCreaseArray : public APIObject,
    IEnumerable
type SlabShapeCreaseArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The SlabShapeCreaseArray type exposes the following members.

Constructors
 | Name | Description
Public method | SlabShapeCreaseArray | Initializes a new instance of the SlabShapeCreaseArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace