MEPSystemType Class

A system type in the Autodesk Revit MEP product.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBMEPSystemType
Autodesk.Revit.DB.MechanicalMechanicalSystemType
Autodesk.Revit.DB.PlumbingPipingSystemType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPSystemType : ElementType
Public Class MEPSystemType
    Inherits ElementType
public ref class MEPSystemType : public ElementType
type MEPSystemType =
    class
        inherit ElementType
    end

The MEPSystemType type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type
Public property | CalculationLevel | Identifies the calculation level for the system type.
Public property | FillColor | Indicates the color that should override the fill color for all components in the system.
Public property | FillPatternId | Indicates the fill pattern id that should override the fill pattern id for all components in the system.
Public property | FillVisible | Indicates the visibility of the fill pattern for all components in the system.
Public property | LineColor | Indicates the color that should override the line color for all components in the system.
Public property | LinePatternId | Indicates the line pattern id that should override the line pattern id for all components in the system.
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system.
Public property | MaterialId | Indicates the material id that should override the material for all components in the system.
Public property | SystemClassification | Identifies the classification for the system type
Top
Methods
 | Name | Description
Top
Remarks
This is the base class for mechanical and piping system types, available only in the Autodesk Revit MEP product.
See Also

Reference

Autodesk.Revit.DB Namespace