AnalysisDisplayColoredSurfaceSettings Class

Contains colored surface settings for analysis display style element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisAnalysisDisplayColoredSurfaceSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayColoredSurfaceSettings : IDisposable
Public Class AnalysisDisplayColoredSurfaceSettings
    Implements IDisposable
public ref class AnalysisDisplayColoredSurfaceSettings : IDisposable
type AnalysisDisplayColoredSurfaceSettings =
    class
        interface IDisposable
    end

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AnalysisDisplayColoredSurfaceSettings | Constructs a default instance of colored surface settings.
Public method | AnalysisDisplayColoredSurfaceSettings(AnalysisDisplayColoredSurfaceSettings) | Constructs a new copy of the input AnalysisDisplayColoredSurfaceSettings object.
Top
Properties
 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.
Public property | Transparency | Transparency percentage of colored surface
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayColoredSurfaceSettings
Public method | IsEqual | Compares two colored surface settings objects.
Top
Example
C#
VB
C++
F#
Copy
AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings = new AnalysisDisplayColoredSurfaceSettings();
coloredSurfaceSettings.ShowGridLines = true;
Dim coloredSurfaceSettings As New AnalysisDisplayColoredSurfaceSettings()
coloredSurfaceSettings.ShowGridLines = True

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace