HermiteFace Class

HermiteSpline Class

A Hermite spline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBHermiteSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HermiteSpline : Curve
Public Class HermiteSpline
    Inherits Curve
public ref class HermiteSpline : public Curve
type HermiteSpline =
    class
        inherit Curve
    end

The HermiteSpline type exposes the following members.

Properties
 | Name | Description
Public property | ControlPoints | The control points of the Hermite spline.
Public property | IsPeriodic | Returns whether the Hermite spline is periodic or not.
Public property | Parameters | Returns the params of the Hermite spline.
Public property | Tangents | Returns the tangents of the Hermite spline.
Top
Methods
 | Name | Description
 | Create(IListXYZ, Boolean) | Creates a Hermite spline with default tangency at its endpoints.
 | Create(IListXYZ, Boolean, HermiteSplineTangents) | Creates a Hermite spline with specified tangency at its endpoints.
Top
Remarks
The Hermite spline lies in the plane defined by control points.
See Also

Reference

Autodesk.Revit.DB Namespace