BuiltInFailuresAutoRouteFailures Class

BuiltInFailures.BeamFailures Class

BuiltInFailuresBeamFailures Class

Failures about Beams.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresBeamFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class BeamFailures
Public NotInheritable Class BeamFailures
public ref class BeamFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BeamFailures = class end

The BuiltInFailuresBeamFailures type exposes the following members.

Properties
Name | Description
CannotBendBeamType | Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.
Top
See Also

Reference

Autodesk.Revit.DB Namespace