InstanceVoidCutUtils Class

InsulationLiningBase Class

Acts as the base class for duct insulation, pipe insulation and duct lining elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBMEPCurve
Autodesk.Revit.DBInsulationLiningBase
Autodesk.Revit.DB.MechanicalDuctInsulation
Autodesk.Revit.DB.MechanicalDuctLining
Autodesk.Revit.DB.PlumbingPipeInsulation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InsulationLiningBase : MEPCurve
Public Class InsulationLiningBase
    Inherits MEPCurve
public ref class InsulationLiningBase : public MEPCurve
type InsulationLiningBase =
    class
        inherit MEPCurve
    end

The InsulationLiningBase type exposes the following members.

Properties
 | Name | Description
Public property | HostElementId | The id of the host element for the insulation or lining element.
Public property | Thickness | Thickness of the insulation or lining element.
Top
Methods
 | Name | Description
 | GetInsulationIds | Returns the ids of the insulation elements associated to a given element.
 | GetLiningIds | Returns the ids of the lining elements associated to a given element.
 | IsValidThickness | Identifies if the given thickness value is valid for assignment to insulation or lining elements.
Top
See Also

Reference

Autodesk.Revit.DB Namespace