TriangulatedSolidOrShell Class

TriangulationInterface Class

This abstract class provides an interface for querying a triangulation structure (vertices and triangles).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTriangulationInterface
Autodesk.Revit.DBTriangulationInterfaceForTriangulatedShellComponent
Autodesk.Revit.DBTriangulationInterfaceForTriangulatedSolidOrShell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TriangulationInterface : IDisposable
Public Class TriangulationInterface
    Implements IDisposable
public ref class TriangulationInterface : IDisposable
type TriangulationInterface =
    class
        interface IDisposable
    end

The TriangulationInterface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TriangulationInterface
Top
See Also

Reference

Autodesk.Revit.DB Namespace