CurveArrArrayIterator Class

CurveArray Class

An array that can contain curves.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurveArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveArray : APIObject, IEnumerable
Public Class CurveArray
    Inherits APIObject
    Implements IEnumerable
public ref class CurveArray : public APIObject,
    IEnumerable
type CurveArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The CurveArray type exposes the following members.

Constructors
 | Name | Description
Public method | CurveArray | Initializes a new instance of the CurveArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the curve to the end of the array.
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace