MEPCurveType Class

MEPFamilyConnectorInfo Class

MEP family connector information.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMEPConnectorInfo
Autodesk.Revit.DBMEPFamilyConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPFamilyConnectorInfo : MEPConnectorInfo
Public Class MEPFamilyConnectorInfo
    Inherits MEPConnectorInfo
public ref class MEPFamilyConnectorInfo : public MEPConnectorInfo
type MEPFamilyConnectorInfo =
    class
        inherit MEPConnectorInfo
    end

The MEPFamilyConnectorInfo type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetAssociateFamilyParameterId | Gets the associate family parameter id of the specified connector parameter id.
Public method | GetConnectorParameterValue | Gets the parameter value of the specified connector parameter id.
Top
See Also

Reference

Autodesk.Revit.DB Namespace