ConnectionValidationInfo Class

ConnectionValidationWarning Class

Contains information about a specific connection validation problem.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBConnectionValidationWarning

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConnectionValidationWarning : IDisposable
Public Class ConnectionValidationWarning
    Implements IDisposable
public ref class ConnectionValidationWarning : IDisposable
type ConnectionValidationWarning =
    class
        interface IDisposable
    end

The ConnectionValidationWarning type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionValidationWarning | Constructor.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Reason | Enumeration for reason of warning.
Public property | Resolution | Enumeration for resolution that was applied.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ConnectionValidationWarning
Public method | GetParts | Get ElementIds of affected parts.
Top
See Also

Reference

Autodesk.Revit.DB Namespace