SiteLocation Class

Sketch Class

Provides access to the Sketch in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSketchBase
Autodesk.Revit.DBSketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Sketch : SketchBase
Public Class Sketch
    Inherits SketchBase
public ref class Sketch : public SketchBase
type Sketch =
    class
        inherit SketchBase
    end

The Sketch type exposes the following members.

Properties
 | Name | Description
Public property | OwnerId | Returns id of the sketch owner element or invalidElementId if sketch does not build a geometry.
Public property | Profile | Returns the Profile of the Sketch.
Public property | SketchPlane | Returns the Sketch Plane of the Sketch.
Top
Methods
 | Name | Description
Public method | GetAllElements | Returns all elements which belong to the sketch.
Top
See Also

Reference

Autodesk.Revit.DB Namespace