LocationPoint Class

LogicalAndFilter Class

A filter that contains a set of filters. The filter passes when all filters in the set pass.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBLogicalAndFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LogicalAndFilter : ElementLogicalFilter
Public Class LogicalAndFilter
    Inherits ElementLogicalFilter
public ref class LogicalAndFilter : public ElementLogicalFilter
type LogicalAndFilter =
    class
        inherit ElementLogicalFilter
    end

The LogicalAndFilter type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalAndFilter(IListElementFilter) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalAndFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.
Example
C#
VB
C++
F#
Copy
// Find all door instances in the project by finding all elements that both belong to the door
// category and are family instances.
ElementClassFilter familyInstanceFilter = new ElementClassFilter(typeof(FamilyInstance));

// Create a category filter for Doors
ElementCategoryFilter doorsCategoryfilter = new ElementCategoryFilter(BuiltInCategory.OST_Doors);

// Create a logic And filter for all Door FamilyInstances
LogicalAndFilter doorInstancesFilter = new LogicalAndFilter(familyInstanceFilter, doorsCategoryfilter);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> doors = collector.WherePasses(doorInstancesFilter).ToElements();
' Find all door instances in the project by finding all elements that both belong to the door
' category and are family instances.
Dim familyInstanceFilter As New ElementClassFilter(GetType(FamilyInstance))

' Create a category filter for Doors
Dim doorsCategoryfilter As New ElementCategoryFilter(BuiltInCategory.OST_Doors)

' Create a logic And filter for all Door FamilyInstances
Dim doorInstancesFilter As New LogicalAndFilter(familyInstanceFilter, doorsCategoryfilter)

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim doors As IList(Of Element) = collector.WherePasses(doorInstancesFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace