PointRelativeToPoint Class

PolyLine Class

A polyline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBPolyLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolyLine : GeometryObject
Public Class PolyLine
    Inherits GeometryObject
public ref class PolyLine : public GeometryObject
type PolyLine =
    class
        inherit GeometryObject
    end

The PolyLine type exposes the following members.

Properties
 | Name | Description
Public property | NumberOfCoordinates | Gets the number of the coordinate points.
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this polyline.
 | Create | Creates a polyline with coordinate points provided.
Public method | Evaluate | Evaluates a parameter on the polyline.
Public method | GetCoordinate | Gets the coordinate point of the specified index.
Public method | GetCoordinates | Gets the coordinate points of the polyline.
Public method | GetOutline | Gets the outline of the polyline.
Public method | GetTransformed | Gets the copy of the polyline which is applied the specified transformation.
Top
Remarks
A polyline in space is defined by a set of coordinate points.
See Also

Reference

Autodesk.Revit.DB Namespace