ExportLayerTable Class

ExportLayerTableIterator Class

An iterator to a set of Layer table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLayerTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLayerTableIterator : IEnumerator<KeyValuePair<ExportLayerKey, ExportLayerInfo>>
Public Class ExportLayerTableIterator
    Implements IEnumerator(Of KeyValuePair(Of ExportLayerKey, ExportLayerInfo))
public ref class ExportLayerTableIterator : IEnumerator<KeyValuePair<ExportLayerKey^, ExportLayerInfo^>>
type ExportLayerTableIterator =
    class
        interface IEnumerator<KeyValuePair<ExportLayerKey, ExportLayerInfo>>
    end

The ExportLayerTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLayerTableIterator
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Top
See Also

Reference

Autodesk.Revit.DB Namespace