ViewSection Class

ViewSet Class

A set that contains views.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBViewSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSet : APIObject, IEnumerable
Public Class ViewSet
    Inherits APIObject
    Implements IEnumerable
public ref class ViewSet : public APIObject,
    IEnumerable
type ViewSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The ViewSet type exposes the following members.

Constructors
 | Name | Description
Public method | ViewSet | Initializes a new instance of the ViewSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of views that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every view from the set, rendering it empty.
Public method | Contains | Tests for the existence of a view within the set.
Public method | Erase | Removes a specified view from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified view into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace