FilterStringLessOrEqual Class

FilterStringRule Class

A filter rule that operates on string values in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterStringRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringRule : FilterValueRule
Public Class FilterStringRule
    Inherits FilterValueRule
public ref class FilterStringRule : public FilterValueRule
type FilterStringRule =
    class
        inherit FilterValueRule
    end

The FilterStringRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterStringRule | Constructs an instance of FilterStringRule.
Top
Properties
 | Name | Description
Public property | RuleString | The user-supplied string against which strings from a Revit document will be tested.
Top
Methods
 | Name | Description
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also

Reference

Autodesk.Revit.DB Namespace