Toposolid Class

An object that represents a Toposolid within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCeilingAndFloor
Autodesk.Revit.DBToposolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Toposolid : CeilingAndFloor
Public Class Toposolid
    Inherits CeilingAndFloor
public ref class Toposolid : public CeilingAndFloor
type Toposolid =
    class
        inherit CeilingAndFloor
    end

The Toposolid type exposes the following members.

Properties
 | Name | Description
Public property | HostTopoId | The host toposolid id of the current toposolid subdivision. If the object is not a toposolid subdivision, hostTopoId will be InvalidElementId.
Public property | SketchId | Returns id of the sketch.
Top
Methods
 | Name | Description
Public method | CanBeExcavatedBy | Checks if the given element can be used to excavate the toposolid.
 | Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IListXYZ, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IListCurveLoop, IListXYZ, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | CreateFromTopographySurface | Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.
Public method | CreateSubDivision | Create a toposolid subdivision element with the current toposolid as its host.
Public method | ExcavateBy | Excavates the toposolid by a given element.
Public method | GetIntersectingElementData | Gets intersection data of all intersecting elements.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Toposolid.
Public method | GetSubDivisionIds | Get all element ids of toposolid subdivisions with the current toposolid as its host.
 | IsSmoothedSurfaceEnabled | Get smoothed surface setting of Toposolid.
Public method | RemoveExcavationBy | Remove the excavation between the given element and the toposolid.
 | SetSmoothedSurface | Set smoothed surface setting of Toposolid.
Public method | Simplify | Simplifies the toposolid by reducing the number of inner vertices to the given percentage.
Public method | Split | Split the toposolid by the given curve loops.
Top
See Also

Reference

Autodesk.Revit.DB Namespace