TextElement Class
GetMinimumAllowedWidth Overload

TextElement.GetMinimumAllowedWidth(Document, ElementId) Method

TextElementGetMinimumAllowedWidth(Document, ElementId) Method

Returns the minimum width a text element can be created with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double GetMinimumAllowedWidth(
    Document cdda,
    ElementId typeId
)
Public Shared Function GetMinimumAllowedWidth (
    cdda As Document,
    typeId As ElementId
) As Double
public:
static double GetMinimumAllowedWidth(
    Document^ cdda,
    ElementId^ typeId
)
static member GetMinimumAllowedWidth :
        cdda : Document *
        typeId : ElementId -> float

Parameters

cdda Document
A document containing the new text element's type
typeId ElementId
Id of the text type

Return Value

Double
The minimum allowed width in paper space [ft].
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Note that it is not necessarily a constant; it can be affected by properties of the text type, such as the width factor.
Example
C#
VB
C++
F#
Copy
public TextNote AddNewTextNote(UIDocument uiDoc)
{
    Document doc = uiDoc.Document;
    XYZ textLoc = uiDoc.Selection.PickPoint("Pick a point for sample text.");
    ElementId defaultTextTypeId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType);
    double noteWidth = .2;

    // make sure note width works for the text type
    double minWidth = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId);
    double maxWidth = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId);
    if (noteWidth < minWidth)
    {
        noteWidth = minWidth;
    }
    else if (noteWidth > maxWidth)
    {
        noteWidth = maxWidth;
    }

    TextNoteOptions opts = new TextNoteOptions(defaultTextTypeId);
    opts.HorizontalAlignment = HorizontalTextAlignment.Left;
    opts.Rotation = Math.PI / 4;

    TextNote textNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts);

    return textNote;
}
Public Function AddNewTextNote(uiDoc As UIDocument) As TextNote
    Dim doc As Document = uiDoc.Document
    Dim textLoc As XYZ = uiDoc.Selection.PickPoint("Pick a point for sample text.")
    Dim defaultTextTypeId As ElementId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType)
    Dim noteWidth As Double = 0.2

    ' make sure note width works for the text type
    Dim minWidth As Double = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId)
    Dim maxWidth As Double = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId)
    If noteWidth < minWidth Then
        noteWidth = minWidth
    ElseIf noteWidth > maxWidth Then
        noteWidth = maxWidth
    End If

    Dim opts As New TextNoteOptions(defaultTextTypeId)
    opts.HorizontalAlignment = HorizontalTextAlignment.Left
    opts.Rotation = Math.PI / 4

    Dim textNote__1 As TextNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts)

    Return textNote__1
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference