DetailArc Class

DetailCurve Class

A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBDetailCurve
Autodesk.Revit.DBDetailArc
Autodesk.Revit.DBDetailEllipse
Autodesk.Revit.DBDetailLine
Autodesk.Revit.DBDetailNurbSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DetailCurve : CurveElement
Public Class DetailCurve
    Inherits CurveElement
public ref class DetailCurve : public CurveElement
type DetailCurve =
    class
        inherit CurveElement
    end

The DetailCurve type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace