SymbolGeometryId Class

SymbolicCurve Class

A curve that provides information but is not intended to represent actual geometry in an element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBSymbolicCurve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SymbolicCurve : CurveElement
Public Class SymbolicCurve
    Inherits CurveElement
public ref class SymbolicCurve : public CurveElement
type SymbolicCurve =
    class
        inherit CurveElement
    end

The SymbolicCurve type exposes the following members.

Properties
 | Name | Description
Public property | IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
Public property | ReferenceType | Indicates the type of reference.
Public property | Subcategory | The subcategory.
Top
Methods
 | Name | Description
Public method | GetVisibility | Gets the visibility for the symbolic curve.
Public method | SetVisibility | Sets the visibility for the symbolic curve.
Top
Remarks
For example, when creating a door family, you might sketch symbolic lines in an elevation view to represent a door swing. Symbolic curves are visible parallel to the view in which you sketch them.
See Also

Reference

Autodesk.Revit.DB Namespace