ExportPatternTableIterator Class

ExportPDFSettings Class

Settings for PDF export
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBExportPDFSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportPDFSettings : Element
Public Class ExportPDFSettings
    Inherits Element
public ref class ExportPDFSettings : public Element
type ExportPDFSettings =
    class
        inherit Element
    end

The ExportPDFSettings type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
 | Create | Returns an new created ExportPDFSettings element in the document with specified settings.
 | FindByName | Returns settings element by name.
 | GetActivePredefinedSettings | Gets the active settings element in the document.
Public method | GetOptions | Gets a copy of options from settings for exporting. Modification on this options would not change the element.
 | IsValidName | Returns result that the proposed name is valid and not exist in the specified document.
 | ListNames | Returns all the names of the settings instances in the document.
Public method | SetOptions | Sets options for exporting.
Top
See Also

Reference

Autodesk.Revit.DB Namespace