LineSegment Class

An output node that represents a tessellated line segment.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLineSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LineSegment : IDisposable
Public Class LineSegment
    Implements IDisposable
public ref class LineSegment : IDisposable
type LineSegment =
    class
        interface IDisposable
    end

The LineSegment type exposes the following members.

Properties
 | Name | Description
Public property | EndParameter | Parameter associated with the end point.
Public property | EndPoint | End point of the line segment.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineProperties | Access to the line (pen) properties of the line
Public property | StartParameter | Parameter associated with the start point.
Public property | StartPoint | Start point of the line segment.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LineSegment
Top
Remarks
See also: OnLineSegment(LineSegment).
See Also

Reference

Autodesk.Revit.DB Namespace