ClosestPointsPairBetweenTwoCurves Class

Color Class

Represents a color in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBColor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Color : APIObject
Public Class Color
    Inherits APIObject
public ref class Color : public APIObject
type Color =
    class
        inherit APIObject
    end

The Color type exposes the following members.

Constructors
 | Name | Description
Public method | Color | Constructor that takes the red, green and blue channels of the color.
Top
Properties
 | Name | Description
Public property | Blue | Get the blue channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
Public property | Green | Get the green channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
 | InvalidColorValue | Get the invalid Color whose IntegerValue is -1.
Public property | IsValid | Identifies if the color represents a valid color, or an uninitialized/invalid value.
Public property | Red | Get the red channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
Top
Methods
 | Name | Description
Top
Remarks
Colors obtained from some API methods may represent an uninitialized/invalid color. You can identify these using the IsValid property.
See Also

Reference

Autodesk.Revit.DB Namespace