ScheduleDefinition Class

ScheduleField Class

A field in a schedule.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBScheduleField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScheduleField : IDisposable
Public Class ScheduleField
    Implements IDisposable
public ref class ScheduleField : IDisposable
type ScheduleField =
    class
        interface IDisposable
    end

The ScheduleField type exposes the following members.

Properties
 | Name | Description
Public property | ColumnHeading | The column heading text.
Public property | Definition | The ScheduleDefinition that this field belongs to.
Public property | DisplayType | Indicates the chosen display type for the field.
Public property | FieldId | The ID of the field in the containing ScheduleDefinition.
Public property | FieldIndex | The index of the field in the containing ScheduleDefinition.
Public property | FieldType | The type of data displayed by the field.
Public property | GridColumnWidth | The width of the column in the editable grid view, measured in feet.
Public property | HasSchedulableField | Identifies if this ScheduleField object has access to a SchedulableField. Calculated and combined parameter fields will not have the access.
Public property | HeadingOrientation | The orientation of the column heading text.
Public property | HorizontalAlignment | The horizontal alignment of the column's data.
Public property | IsCalculatedField | Indicates if the field is a calculated field (Formula or Percentage).
Public property | IsCombinedParameterField | Indicates if the field is a combined parameter field.
Public property | IsHidden | Indicates if the field is hidden in the schedule.
Public property | IsOverridden | Indicates if the field is overridden or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultipleValuesCustomText | The custom multiple values text to be used when the schedule field displays multiple element values, used when MultipleValuesDisplayType is set to Custom.
Public property | MultipleValuesDisplayType | Determines the type of multiple value indication to be used when the schedule field displays multiple element values.
Public property | MultipleValuesText | The multiple values text to be used when the schedule field displays multiple element values, as specified by the display type MultipleValuesDisplayType.
Public property | ParameterId | The ID of the parameter displayed by the field.
Public property | PercentageBy | The ID of the grouped schedule field used to calculate percentage totals.
Public property | PercentageOf | The ID of the field to calculate percentages of.
Public property | Schedule | The schedule that this field belongs to.
Public property | SheetColumnWidth | The width of the column on a sheet, measured in feet.
Public property | TotalByAssemblyType | In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.
Public property | VerticalAlignment | The vertical alignment of the column's data.
Top
Methods
 | Name | Description
Public method | CanDisplayMinMax | Indicates if this field can display minimum and maximum values.
Public method | CanTotal | Indicates if totals can be enabled for this field.
Public method | CanTotalByAssemblyType | Indicates if totals by assembly type can be enabled for this field.
Public method | CreatesCircularReferences | Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.
Public method | Dispose | Releases all resources used by the ScheduleField
Public method | GetCombinedParameters | Gets this field's combine parameter array if applicable
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return .
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetName | Gets the name of the field.
Public method | GetSchedulableField | Gets a SchedulableField object representing this field.
Public method | GetSpecTypeId | The spec describing values of this field, if applicable.
Public method | GetStyle | Gets the style of this field.
Public method | IsValidCombinedParameters | Checks if data is valid for combined parameters
Public method | ResetOverride | Resets the override of this field.
Public method | SetCombinedParameters | Sets this field's combine parameter array if applicable
 | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | SetStyle | Sets the style of this field.
Top
Remarks

The ScheduleField class represents a single field in a ScheduleDefinition's list of fields. Each (non-hidden) field becomes a column in the schedule.

Most commonly, a field represents an instance or type parameter of elements appearing in the schedule. Some fields represent parameters of other related elements, like the room that a scheduled element belongs to. Fields can also represent data calculated from other fields in the schedule, specifically Formula and Percentage fields. Another type of field is Custom Field. For this one, the value for each row is computed based on the (sub)elements that are grouped on that row and can have a graphic representation when the schedule is placed on a sheet.

See Also

Reference

Autodesk.Revit.DB Namespace