SpatialFieldManager Class

Exposes all API for an external analysis application. Its primary role is creation, deletion and modification of SpatialFieldElement elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisSpatialFieldManager

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialFieldManager : Element
Public Class SpatialFieldManager
    Inherits Element
public ref class SpatialFieldManager : public Element
type SpatialFieldManager =
    class
        inherit Element
    end

The SpatialFieldManager type exposes the following members.

Properties
 | Name | Description
Public property | AllowInteractiveSettings | If true interactive settings dialog and pick deletion are allowed.
Public property | CurrentMeasurement | Stores the currently displayed measurement
Public property | LegendPosition | Stores current position of analysis results legend element in view
Public property | LegendShowConfigurationName | If true legend contains analysis configuration name.
Public property | LegendShowDescription | If true legend contains analysis description.
Public property | LegendTextTypeId | Stores element id of text associated with common (result-independent) part of legend in view.
Public property | NumberOfMeasurements | Stores the total number of measurements
Public property | ResultsVisibleInView | Enables analysis results visibility in the view.
Public property | UseRangeForAllMeasurements | Governs how minimum and maximum values (the data range) are calculated.
Top
Methods
 | Name | Description
Public method | AddSpatialFieldPrimitive | Creates empty analysis results primitive not associated with any geometry element
Public method | AddSpatialFieldPrimitive(Reference) | Creates an empty analysis results primitive associated with a reference.
Public method | AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results primitive associated with a curve and a transform.
 | AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results primitive associated with a face and a transform.
Public method | AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) | Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.
Public method | Clear | Clear all analysis results managed by this manager object
 | CreateSpatialFieldManager | Factory method - creates manager object for the given view
Public method | GetLegend | Returns legend element or NULL
Public method | GetMaximum | Calculates the maximum value for all primitives
Public method | GetMinimum | Calculates the minimum value for all primitives
Public method | GetRegisteredResults | Returns an array of indices of all registered results
Public method | GetResultSchema | Returns result schema by index
 | GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
Public method | IsResultSchemaNameUnique | Verify the uniqueness of the name among all registered result schemas.
 | IsTextTypeIdValid | Verify if text type id is valid.
 | RegisterResult | Registers result and assigns it a unique result index
Public method | RemoveSpatialFieldPrimitive | Removes analysis results primitive identified by the unique index
Public method | SetMeasurementDescriptions | Sets Descriptions for all measurements
Public method | SetMeasurementNames | Sets Names for all measurements
Public method | SetResultSchema | Sets a new value for an existing result schema in the result registry
Public method | UpdateSpatialFieldPrimitive | Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Top
Example
C#
VB
C++
F#
Copy
Document doc = commandData.Application.ActiveUIDocument.Document;
UIDocument uiDoc = commandData.Application.ActiveUIDocument;

SpatialFieldManager sfm = SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView);
if (null == sfm)
{
    sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1);
}
Reference reference = uiDoc.Selection.PickObject(ObjectType.Face, "Select a face");
int idx = sfm.AddSpatialFieldPrimitive(reference);

Face face = doc.GetElement(reference).GetGeometryObjectFromReference(reference) as Face;

IList<UV> uvPts = new List<UV>();
BoundingBoxUV bb = face.GetBoundingBox();
UV min = bb.Min;
UV max = bb.Max;
uvPts.Add(new UV(min.U,min.V));
uvPts.Add(new UV(max.U,max.V));

FieldDomainPointsByUV pnts = new FieldDomainPointsByUV(uvPts);

List<double> doubleList = new List<double>();
IList<ValueAtPoint> valList = new List<ValueAtPoint>();
doubleList.Add(0);
valList.Add(new ValueAtPoint(doubleList));
doubleList.Clear();
doubleList.Add(10);
valList.Add(new ValueAtPoint(doubleList));

FieldValues vals = new FieldValues(valList);
AnalysisResultSchema resultSchema = new AnalysisResultSchema("Schema Name", "Description");
int schemaIndex = sfm.RegisterResult(resultSchema);
sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals, schemaIndex);
Dim doc As Document = commandData.Application.ActiveUIDocument.Document
Dim uiDoc As UIDocument = commandData.Application.ActiveUIDocument

Dim sfm As SpatialFieldManager = SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView)
If sfm Is Nothing Then
   sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1)
End If
Dim reference As Reference = uiDoc.Selection.PickObject(ObjectType.Face, "Select a face")
Dim idx As Integer = sfm.AddSpatialFieldPrimitive(reference)

Dim face As Face = TryCast(doc.GetElement(reference).GetGeometryObjectFromReference(reference), Face)

Dim uvPts As IList(Of UV) = New List(Of UV)()
Dim bb As BoundingBoxUV = face.GetBoundingBox()
Dim min As UV = bb.Min
Dim max As UV = bb.Max
uvPts.Add(New UV(min.U, min.V))
uvPts.Add(New UV(max.U, max.V))

Dim pnts As New FieldDomainPointsByUV(uvPts)

Dim doubleList As New List(Of Double)()
Dim valList As IList(Of ValueAtPoint) = New List(Of ValueAtPoint)()
doubleList.Add(0)
valList.Add(New ValueAtPoint(doubleList))
doubleList.Clear()
doubleList.Add(10)
valList.Add(New ValueAtPoint(doubleList))

Dim vals As New FieldValues(valList)
Dim resultSchema As New AnalysisResultSchema("Schema Name", "Description")
Dim schemaIndex As Integer = sfm.RegisterResult(resultSchema)
sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals, schemaIndex)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace