SolidOrShellTessellationControls Class

SolidSolidCutUtils Class

Exposes utilities which can cause one solid to cut another.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSolidSolidCutUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SolidSolidCutUtils
Public NotInheritable Class SolidSolidCutUtils
public ref class SolidSolidCutUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SolidSolidCutUtils = class end

The SolidSolidCutUtils type exposes the following members.

Methods
Name | Description
AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
CanElementCutElement | Verifies if the cutting element can add a solid cut to the target element.
CutExistsBetweenElements | Checks that if there is a solid-solid cut between two elements.
GetCuttingSolids | Gets all the solids which cut the input element.
GetSolidsBeingCut | Get all the solids which are cut by the input element.
IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
IsElementFromAppropriateContext | Validates that the element is from an appropriate document.
RemoveCutBetweenSolids | Removes the solid-solid cut between the two elements if it exists.
SplitFacesOfCuttingSolid | Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.
Top
Remarks
These utilities are applicable for the generic forms, geometry combinations and family instances in conceptual model, pattern based curtain panel, or adaptive component families, and family instances which are permitted to participate in joining in projects. Thus, for example, a beam cannot cut a wall (as the wall is not a family instance) in projects. Nor can a steel beam participate in cutting another family (because steel beams do not participate in joining).
See Also

Reference

Autodesk.Revit.DB Namespace