FilterGlobalParameterAssociationRule Class

FilterIntegerRule Class

A filter rule that operates on integer values in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterIntegerRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterIntegerRule : FilterNumericValueRule
Public Class FilterIntegerRule
    Inherits FilterNumericValueRule
public ref class FilterIntegerRule : public FilterNumericValueRule
type FilterIntegerRule =
    class
        inherit FilterNumericValueRule
    end

The FilterIntegerRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterIntegerRule | Constructs an instance of FilterIntegerRule.
Top
Properties
 | Name | Description
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace