ImportInstance Class

ImportOptions3DM Class

The import options used to import 3DM format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBImportOptions3DM

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImportOptions3DM : BaseImportOptions
Public Class ImportOptions3DM
    Inherits BaseImportOptions
public ref class ImportOptions3DM : public BaseImportOptions
type ImportOptions3DM =
    class
        inherit BaseImportOptions
    end

The ImportOptions3DM type exposes the following members.

Constructors
 | Name | Description
Public method | ImportOptions3DM | Constructs a new instance of ImportOptions3DM with default values of all properties.
Public method | ImportOptions3DM(ImportOptions3DM) | Constructs a new instance of ImportOptions3DM as a copy of the provided import options.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace