DisableAnalyticalModelCB Class

DisciplineTypeId Class

This class contains constants identifying disciplines.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDisciplineTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DisciplineTypeId
Public NotInheritable Class DisciplineTypeId
public ref class DisciplineTypeId abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DisciplineTypeId = class end

The DisciplineTypeId type exposes the following members.

Properties
Name | Description
Architecture | Architecture.
Common | Common.
Electrical | Electrical.
Energy | Energy.
Hvac | HVAC.
Infrastructure | Infrastructure.
Piping | Piping.
Structural | Structural.
Top
See Also

Reference

Autodesk.Revit.DB Namespace