CombinableElement Class

CombinableElementArray Class

An array that contains CombinableElement objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCombinableElementArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CombinableElementArray : APIObject,
    IEnumerable
Public Class CombinableElementArray
    Inherits APIObject
    Implements IEnumerable
public ref class CombinableElementArray : public APIObject,
    IEnumerable
type CombinableElementArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The CombinableElementArray type exposes the following members.

Constructors
 | Name | Description
Public method | CombinableElementArray | Initializes a new instance of the CombinableElementArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a CombinableElement at a specified index within the array.
Public property | Size | Returns the number of CombinableElements that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every CombinableElement from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace