DirectShapeType Class
AddReferencePoint Overload

DirectShapeType.AppendShape Method

DirectShapeTypeAppendShape Method

Overload List
 | Name | Description
Public method | AppendShape(IListGeometryObject) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IListGeometryObject, DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Top
See Also

Reference