ModelArc Class

ModelCurve Class

A model element that exists in 3D space and is visible in all views of a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelCurve : CurveElement
Public Class ModelCurve
    Inherits CurveElement
public ref class ModelCurve : public CurveElement
type ModelCurve =
    class
        inherit CurveElement
    end

The ModelCurve type exposes the following members.

Properties
 | Name | Description
Public property | IsReferenceLine | Indicates if this curve is a reference curve.
Public property | Subcategory | The subcategory.
Public property | TrussCurveType | The truss curve type of this model curve.
Top
Methods
 | Name | Description
Public method | ChangeToReferenceLine | Changes this curve to a reference curve.
Public method | GetVisibility | Gets the visibility for the model curve in a family document.
Public method | SetVisibility | Sets the visibility for the model curve in a family document.
Top
See Also

Reference

Autodesk.Revit.DB Namespace