SpatialElementGeometryResults Class

SpatialElementTag Class

A tag attached to a SpatialElement (room, space or area) in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElementTag
Autodesk.Revit.DB.ArchitectureRoomTag
Autodesk.Revit.DBAreaTag
Autodesk.Revit.DB.MechanicalSpaceTag

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementTag : Element
Public Class SpatialElementTag
    Inherits Element
public ref class SpatialElementTag : public Element
type SpatialElementTag =
    class
        inherit Element
    end

The SpatialElementTag type exposes the following members.

Properties
 | Name | Description
Public property | HasElbow | Identifies if the tag's leader has an elbow point or not.
Public property | HasLeader | Identifies if a leader is displayed for the tag or not.
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | IsTaggingLink | Identifies if the tag has reference to a spatial element in a linked document or not.
Public property | LeaderElbow | The position of the leader's elbow (middle point).
Public property | LeaderEnd | The position of the leader's end.
Public property | Location | The location of the tag. (Overrides ElementLocation)
Public property | RotationAngle | The rotation angle of the tag relative to its view
Public property | TagHeadPosition | The position of the tag's head.
Public property | TagOrientation | The orientation of the tag.
Public property | TagText | The text displayed by the tag.
Public property | View | The view in which the tag was placed.
Top
Methods
 | Name | Description
Top
Remarks
SpatialElementTag is the base class for RoomTag, SpaceTag and AreaTag. Zone tag is not derived from SpatialElementTag. See [!:Autodesk::Revit::DB::IndependentTag] for more information.
See Also

Reference

Autodesk.Revit.DB Namespace