ParameterValuePresenceRule Class

ParameterValueProvider Class

Gets the value of a parameter from any element passed to GetStringValue, GetDoubleValue, GetIntegerValue, or GetElementIdValue.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterableValueProvider
Autodesk.Revit.DBParameterValueProvider

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterValueProvider : FilterableValueProvider
Public Class ParameterValueProvider
    Inherits FilterableValueProvider
public ref class ParameterValueProvider : public FilterableValueProvider
type ParameterValueProvider =
    class
        inherit FilterableValueProvider
    end

The ParameterValueProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterValueProvider | Constructs an instance of ParameterValueProvider.
Top
Properties
 | Name | Description
Public property | Parameter | The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.
Top
Methods
 | Name | Description
Top
Remarks

For any parameter, only one of isStringValueSupported, isDoubleValueSupported, isIntegerValueSupported, isElementIdValueSupported will return true. No attempt to convert between types is made. For example, calling GetStringValue, passing the identifier of a numeric-typed parameter will give an empty string. No exception will be thrown, and ParameterValueProvider will not attempt to convert the numeric value to a string.

If an element doesn't have the requested parameter or the element's parameter doesn't have a valid value, ParameterValueProvider will attempt to get the parameter value from the element's type - see GetTypeId.

See Also

Reference

Autodesk.Revit.DB Namespace