KeyBasedTreeEntryError Class

KeyBasedTreeEntryErrorType Enumeration

An Enum indicating the type of error associated with a KeyBasedTreeEntry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum KeyBasedTreeEntryErrorType
Public Enumeration KeyBasedTreeEntryErrorType
public enum class KeyBasedTreeEntryErrorType
type KeyBasedTreeEntryErrorType
Members
Member name | Value | Description
DuplicateEntry | 0 | The same entry appears more than once in the KeyBasedTreeEntries object.
MissingParent | 1 | The parent specified for a entry does not exist in the KeyBasedTreeEntires object.
CircularParentage | 2 | A sub-node has been specified as a parent of one of its ancestors.
InvalidClassificationCode | 3 | The classification code does not match the level and parent code.
BadClassificationLevel | 4 | The classification level is not an integer in range between 1 and 5 inclusive.
BadClassificationCategoryId | 5 | The classification category id is not Revit BuiltInCategory id.
See Also

Reference

Autodesk.Revit.DB Namespace