ExportPDFSettings Class

ExportRange Enumeration

This enum is used to define what view, part of the view, or list of views will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportRange
Public Enumeration ExportRange
public enum class ExportRange
type ExportRange
Members
Member name | Value | Description
CurrentView | 0 | Export the current view only (zoom to fit of the current view).
VisibleRegionOfCurrentView | 1 | Export the visible region of the current view.
SetOfViews | 2 | Export a set of views (set in ViewsAndSheets).
See Also

Reference

Autodesk.Revit.DB Namespace