MultiReferenceAnnotationOptions Class

MultiReferenceAnnotationType Class

The type for MultiReferenceAnnotation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBMultiReferenceAnnotationType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MultiReferenceAnnotationType : ElementType
Public Class MultiReferenceAnnotationType
    Inherits ElementType
public ref class MultiReferenceAnnotationType : public ElementType
type MultiReferenceAnnotationType =
    class
        inherit ElementType
    end

The MultiReferenceAnnotationType type exposes the following members.

Properties
 | Name | Description
Public property | DimensionStyleId | The dimension style which will be used by the child dimension of the multi-reference annotation.
Public property | GroupTagHeads | Controls if parameter values for the annotation's references will be reported in one grouped tag head or if every reference will get its own tag head.
Public property | ReferenceCategoryId | The category of elements to which this annotation applies.
Public property | ShowDimensionText | Controls if text from the multi-reference annotation's dimension will be shown.
Public property | TagTypeId | The tag type which will be used by the child tag the multi-reference annotation.
Top
Methods
 | Name | Description
 | CreateDefault | Creates the first MultiReferenceAnnotationType element and adds it to the document.
Public method | GetAllowedTagCategory | Returns the category ID for the tag types which can be used by this multi-reference annotation type.
Public method | IsAllowedDimensionStyle | Checks if the dimension style can be used with multi-reference annotations.
Public method | IsAllowedReferenceCategory | Checks if the reference category can be used with multi-reference annotations.
 | IsAllowedTagCategory | Returns true if tag types belonging to this category can be used with multi-reference annotation types.
Public method | IsAllowedTagType | Checks if the tag type can be assigned to this multi-reference annotation type.
Top
Remarks
Multi-reference annotations can be used to label and dimension Rebar elements, and are labeled in the user interface as "Multi-rebar annotations". The type specifies the tag and dimension types to be used in the multi-reference annotation, as well as associated display settings.
See Also

Reference

Autodesk.Revit.DB Namespace