FacetingUtils Class

FaceToposolid Class

An object that represents a face-based Toposolid within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBFaceToposolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceToposolid : HostObject
Public Class FaceToposolid
    Inherits HostObject
public ref class FaceToposolid : public HostObject
type FaceToposolid =
    class
        inherit HostObject
    end

The FaceToposolid type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
 | Create | Creates a new instance of a face toposolid attached to a non-vertical massing face.
Public method | GetReferencedFaces | Gets the referenced faces of the face toposolid
Public method | SetFaceReferences | Sets the referenced faces of the face toposolid
Public method | UpdateToFace | Resets the face toposolid to its defining faces.
Top
See Also

Reference

Autodesk.Revit.DB Namespace