FaceSecondDerivatives Class

FaceSilhouetteNode Class

An output node that represents a Face edge.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBFaceDetailNode
Autodesk.Revit.DBFaceSilhouetteNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceSilhouetteNode : FaceDetailNode
Public Class FaceSilhouetteNode
    Inherits FaceDetailNode
public ref class FaceSilhouetteNode : public FaceDetailNode
type FaceSilhouetteNode =
    class
        inherit FaceDetailNode
    end

The FaceSilhouetteNode type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetFace | Returns the Face object corresponding to the node.
Top
Remarks
See also: OnFaceSilhouette2D(FaceSilhouetteNode).
See Also

Reference

Autodesk.Revit.DB Namespace