FilteredWorksetIterator Class

FilterElement Class

The base class for filter elements in the document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFilterElement
Autodesk.Revit.DBParameterFilterElement
Autodesk.Revit.DBSelectionFilterElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterElement : Element
Public Class FilterElement
    Inherits Element
public ref class FilterElement : public Element
type FilterElement =
    class
        inherit Element
    end

The FilterElement type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique.
 | IsNameUnique(Document, String) | Determines whether the given name could be applied to a new FilterElement, or if it could not be applied because the name is already in use.
Top
See Also

Reference

Autodesk.Revit.DB Namespace