FilterIntegerRule Class

FilterInverseRule Class

A filter rule that inverts the boolean values returned by the rule it contains.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterInverseRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterInverseRule : FilterRule
Public Class FilterInverseRule
    Inherits FilterRule
public ref class FilterInverseRule : public FilterRule
type FilterInverseRule =
    class
        inherit FilterRule
    end

The FilterInverseRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterInverseRule | Constructs a new instance of FilterInverseRule.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetInnerRule | Gets the rule being inverted.
Public method | SetInnerRule | Gets the rule being inverted.
Top
Remarks
FilterInverse rule performs a logical "not" operation on its inner rule's "elementPasses()" method.
See Also

Reference

Autodesk.Revit.DB Namespace