HermiteSplineTangents Class

HermiteSurface Class

A Hermite Surface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBHermiteSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HermiteSurface : Surface
Public Class HermiteSurface
    Inherits Surface
public ref class HermiteSurface : public Surface
type HermiteSurface =
    class
        inherit Surface
    end

The HermiteSurface type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
 | Create(Int32, Int32, IListXYZ) | Create a non-periodic Hermite surface using a net of 3D points as input.
 | Create(Int32, Int32, IListXYZ, Boolean, Boolean) | Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.
Public method | IsValid | Checks whether this HermiteSurface object is valid.
Top
See Also

Reference

Autodesk.Revit.DB Namespace