KeyBasedTreeEntriesLoadResults Class
GetKeyBasedTreeEntryErrors Overload

KeyBasedTreeEntry Class

A key-based tree entry, containing the key, parent key, and children keys (if applicable).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntry
Autodesk.Revit.DBClassificationEntry
Autodesk.Revit.DBKeynoteEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntry : IDisposable
Public Class KeyBasedTreeEntry
    Implements IDisposable
public ref class KeyBasedTreeEntry : IDisposable
type KeyBasedTreeEntry =
    class
        interface IDisposable
    end

The KeyBasedTreeEntry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Key | The key of this entry.
Public property | ParentKey | The parent key of this entry.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntry
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry.
Top
See Also

Reference

Autodesk.Revit.DB Namespace