PlanViewRange Class

This class represents the view range of a plan view or a plan region. It records the element ids of the levels which a plane is relative to and the offset of each plane from that level.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPlanViewRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PlanViewRange : IDisposable
Public Class PlanViewRange
    Implements IDisposable
public ref class PlanViewRange : IDisposable
type PlanViewRange =
    class
        interface IDisposable
    end

The PlanViewRange type exposes the following members.

Properties
 | Name | Description
 | Current | View range for the current plane
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | LevelAbove | View range for the level above the specified plane
 | LevelBelow | View range for the level below the specified plane
 | Unlimited | View range is unlimited
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PlanViewRange
Public method | GetLevelId | Get the element id of the level for a View Depth plane
Public method | GetOffset | Get the offset value associated with a View Depth plane
Public method | SetLevelId | Set the level for a View Depth plane
Public method | SetOffset | Set the offset value associated with a View Depth plane
Top
Example
C#
VB
C++
F#
Copy
private ElementId GetViewRangeTopClipPlane(Document doc, View view)
{
    ElementId topClipPlane = ElementId.InvalidElementId;

    if (view is ViewPlan)
    {
        ViewPlan viewPlan = view as ViewPlan;
        PlanViewRange viewRange = viewPlan.GetViewRange();

        topClipPlane = viewRange.GetLevelId(PlanViewPlane.TopClipPlane);
        double dOffset = viewRange.GetOffset(PlanViewPlane.TopClipPlane);

        if (topClipPlane != ElementId.InvalidElementId)
        {
            Element levelAbove = doc.GetElement(topClipPlane);
            TaskDialog.Show(view.Name, "Top Clip Plane: " + levelAbove.Name + "\r\nTop Offset: " + dOffset + " ft");
        }
    }

    return topClipPlane;
}
Private Function GetViewRangeTopClipPlane(doc As Document, view As View) As ElementId
    Dim topClipPlane As ElementId = ElementId.InvalidElementId

    If TypeOf view Is ViewPlan Then
        Dim viewPlan As ViewPlan = TryCast(view, ViewPlan)
        Dim viewRange As PlanViewRange = viewPlan.GetViewRange()

        topClipPlane = viewRange.GetLevelId(PlanViewPlane.TopClipPlane)
        Dim dOffset As Double = viewRange.GetOffset(PlanViewPlane.TopClipPlane)

        If topClipPlane.Value > 0 Then
            Dim levelAbove As Element = doc.GetElement(topClipPlane)
            TaskDialog.Show(view.Name, "Top Clip Plane: " + levelAbove.Name + vbCr & vbLf & "Top Offset: " + dOffset + " ft")
        End If
    End If

    Return topClipPlane
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace