ConceptualConstructionType Class

This element is used to describe the conceptual physical, construction, and energy properties in a manner that can be understood by both the Revit BIM model and Green Building Studio/Green Building XML. For serialization
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DB.AnalysisConceptualConstructionType

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConceptualConstructionType : ElementType
Public Class ConceptualConstructionType
    Inherits ElementType
public ref class ConceptualConstructionType : public ElementType
type ConceptualConstructionType =
    class
        inherit ElementType
    end

The ConceptualConstructionType type exposes the following members.

Properties
 | Name | Description
Public property | MassSurfaceSubCategoryId | The surface type subcategory element id associated with the ConceptualConstructionType.
Public property | MaterialId | Material used for visualization of this construction.
Top
Methods
Name | Description
GetAllConceptualConstructionsForCategory | Get all the ids of constructions applicable to the input massSubCategory
GetFloorOrSlabConstructionType | Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.
GetOpeningConstructionType | Get an Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
GetRoofConstructionType | Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
GetShadeConstructionType | Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
GetWallConstructionType | Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
GetWindowOrSkylightConstructionType | Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
IsValidConceptualConstructionId | Indicates if the ElementId is an id of a ConceptualConstructionType.
IsValidConceptualConstructionIdForCategory | Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
IsValidSubcategoryForMassSurfaceDatas Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassGlazing
  9. OST_MassSkylights
  10. OST_MassOpening
Public method | IsValidSurfaceSubcategoryForConstruction | Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace