TransactWithCentralOptions Class

Transform Class

A transformation of the affine 3-space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBTransform

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Transform : APIObject
Public Class Transform
    Inherits APIObject
public ref class Transform : public APIObject
type Transform =
    class
        inherit APIObject
    end

The Transform type exposes the following members.

Constructors
 | Name | Description
Public method | Transform | The copy constructor.
Top
Properties
 | Name | Description
Public property | Basis | Defines the basis of the old coordinate system in the new coordinate system.
Public property | BasisX | The basis of the X axis of this transformation.
Public property | BasisY | The basis of the Y axis of this transformation.
Public property | BasisZ | The basis of the Z axis of this transformation.
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection.
 | Identity | The identity transformation.
Public property | Inverse | The inverse transformation of this transformation.
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | Origin | Defines the origin of the old coordinate system in the new coordinate system.
Public property | Scale | The real number that represents the scale of the transformation.
Top
Methods
 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
 | CreateReflection | Creates a transform that represents a reflection across the given plane.
 | CreateRotation | Creates a transform that represents a rotation about the given axis at (0, 0, 0).
 | CreateRotationAtPoint | Creates a transform that represents a rotation about the given axis at the specified point.
 | CreateTranslation | Creates a transform that represents a translation via the specified vector.
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
Top
Operators
Name | Description
Multiply(Transform, Transform) | Multiplies the two specified transforms.
Top
Example
C#
VB
C++
F#
Copy
public static XYZ TransformPoint(XYZ point, Transform transform)
{
    double x = point.X;
    double y = point.Y;
    double z = point.Z;

    //transform basis of the old coordinate system in the new coordinate // system
    XYZ b0 = transform.get_Basis(0);
    XYZ b1 = transform.get_Basis(1);
    XYZ b2 = transform.get_Basis(2);
    XYZ origin = transform.Origin;

    //transform the origin of the old coordinate system in the new
    //coordinate system
    double xTemp = x * b0.X + y * b1.X + z * b2.X + origin.X;
    double yTemp = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y;
    double zTemp = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z;

    return new XYZ(xTemp, yTemp, zTemp);
}
Public Shared Function TransformPoint(point As XYZ, transform As Transform) As XYZ
    Dim x As Double = point.X
    Dim y As Double = point.Y
    Dim z As Double = point.Z

    'transform basis of the old coordinate system in the new coordinate // system
    Dim b0 As XYZ = transform.Basis(0)
    Dim b1 As XYZ = transform.Basis(1)
    Dim b2 As XYZ = transform.Basis(2)
    Dim origin As XYZ = transform.Origin

    'transform the origin of the old coordinate system in the new
    'coordinate system
    Dim xTemp As Double = x * b0.X + y * b1.X + z * b2.X + origin.X
    Dim yTemp As Double = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y
    Dim zTemp As Double = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z

    Return New XYZ(xTemp, yTemp, zTemp)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace