CompoundStructure Class

CompoundStructure.CanLayerWidthBeNonZero Method

CompoundStructureCanLayerWidthBeNonZero Method

Identifies if changing the width of an existing layer from zero to a positive value will create a rectangular region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanLayerWidthBeNonZero(
    int layerIdx
)
Public Function CanLayerWidthBeNonZero (
    layerIdx As Integer
) As Boolean
public:
bool CanLayerWidthBeNonZero(
    int layerIdx
)
member CanLayerWidthBeNonZero :
        layerIdx : int -> bool

Parameters

layerIdx Int32
The index of a CompoundStructureLayer.

Return Value

Boolean
Remarks
This is only allowed if there is a vertical line such that all regions to the left are assigned to layers with index < layerIdx, and all regions to the right are assigned to layers with index > layerIdx.
See Also

Reference