TemporaryViewModes Class

A data structure containing data related to temporary view modes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBTemporaryViewModes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TemporaryViewModes : APIObject
Public Class TemporaryViewModes
    Inherits APIObject
public ref class TemporaryViewModes : public APIObject
type TemporaryViewModes =
    class
        inherit APIObject
    end

The TemporaryViewModes type exposes the following members.

Properties
 | Name | Description
Public property | CustomColor | Custom color for the TemporaryViewProperties mode.
Public property | CustomTitle | Custom title for the TemporaryViewProperties mode.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | PreviewFamilyVisibility | The current state of the PreviewFamilyVisibility mode in the associated view.
 | PreviewFamilyVisibilityDefaultOnState | Controls the default state of the PreviewFamilyVisibility mode in all views.
 | PreviewFamilyVisibilityDefaultUncutState | Controls the default type of the On state of the PreviewFamilyVisibility mode in cut-able views.
Public property | RevealConstraints | The current state of the RevealConstraints mode in the associated view.
Public property | RevealHiddenElements | The current state of the RevealHiddenElements mode in the associated view.
Public property | WorksharingDisplay | The current state of the WorksharingDisplay mode in the associated view.
Top
Methods
 | Name | Description
Public method | DeactivateAllModes | Deactivates all temporary modes that are currently active.
Public method | DeactivateMode | Deactivates the given temporary mode.
Public method | GetCaption | A text caption to use for the given mode.
Public method | IsCustomized | Identifies if a custom temporary view mode is currently active. A custom mode is active if there is a non-empty string set for CustomTitle.
Public method | IsModeActive | Tests whether a given mode is currently active or not.
Public method | IsModeAvailable | Tests whether a temporary view mode is currently available in the associated view.
Public method | IsModeEnabled | Tests whether a temporary view mode is currently enabled in the associated view.
Public method | IsValidState | Tests whether the given state is valid for the associated view and the context the view is currently in.
Public method | RemoveCustomization | Removes all customized values for the TemporaryViewProperties mode.
Top
Remarks

The class contains methods and properties to manipulate states of various temporary view modes that may or may not be avilable in any of visible views of a Revit document. The temporary modes are enumerated in the TemporaryViewMode class.

Every view that supports temporary view modes owns an instance of this TemporaryViewModes class, which can be obtained by accessing the TemporaryViewModes property of the View class. Note that views which do not support temporary modes will have that property's value be Null.

Multiple temporary view modes can coexist. Also, TemporaryViewProperties mode can be customized to display custom title and custom color. Setting custom title and color affects only TemporaryViewProperties mode for the specific view.

  • CustomTitle
  • CustomColor
  • IsCustomized
  • RemoveCustomization

Example
C#
VB
C++
F#
Copy
public bool RevealHiddenElementsInView(View view)
{
    bool hiddenRevealed = false;
    TemporaryViewModes viewModes = view.TemporaryViewModes;

    if (viewModes == null)
    {
        TaskDialog.Show("Invalid View", "This view does not support temporary view modes.");
    }
    else
    {
        // Mode must be available and enabled to be activated
        if (viewModes.IsModeEnabled(TemporaryViewMode.RevealHiddenElements) && viewModes.IsModeAvailable(TemporaryViewMode.RevealHiddenElements))
        {
            viewModes.RevealHiddenElements = true;
            hiddenRevealed = viewModes.RevealHiddenElements;
        }
    }

    return hiddenRevealed;
}
Public Function RevealHiddenElementsInView(view As View) As Boolean
    Dim hiddenRevealed As Boolean = False
    Dim viewModes As TemporaryViewModes = view.TemporaryViewModes

    If viewModes Is Nothing Then
        TaskDialog.Show("Invalid View", "This view does not support temporary view modes.")
    Else
        ' Mode must be available and enabled to be activated
        If viewModes.IsModeEnabled(TemporaryViewMode.RevealHiddenElements) AndAlso viewModes.IsModeAvailable(TemporaryViewMode.RevealHiddenElements) Then
            viewModes.RevealHiddenElements = True
            hiddenRevealed = viewModes.RevealHiddenElements
        End If
    End If

    Return hiddenRevealed
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace