ThermalProperties Class

TilePattern Class

An object representing a tile pattern that may be applied to a DividedSurface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBTilePattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TilePattern : ElementType
Public Class TilePattern
    Inherits ElementType
public ref class TilePattern : public ElementType
type TilePattern =
    class
        inherit ElementType
    end

The TilePattern type exposes the following members.

Properties
 | Name | Description
Public property | TilePatternType | The built-in system tile pattern specified by this object.
Public property | TilesPerSeedNode | Get the number of tiles located at each seed node.
Top
Methods
 | Name | Description
Top
Remarks
TilePatterns cannot be created. A fixed selection is built into each Conceptual Mass family. TilePatterns can be retrieved by key from the Revit::DB::Document::Settings::TilePatternTable object.
See Also

Reference

Autodesk.Revit.DB Namespace