ElementArray Class

ElementArrayIterator Class

An iterator to an element array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBElementArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ElementArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class ElementArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ElementArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ElementArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ElementArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ElementArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Top
Methods
 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace