MassSurfaceData Class

Note: This API is now obsolete.

Holds properties and other data about a face in the MassEnergyAnalyticalModel element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisMassSurfaceData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This class is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use the 'EnergyAnalyticalDetailModel' and 'EnergyAnalysisSurface' classes instead.")]
public class MassSurfaceData : Element
<ObsoleteAttribute("This class is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use the 'EnergyAnalyticalDetailModel' and 'EnergyAnalysisSurface' classes instead.")>
Public Class MassSurfaceData
    Inherits Element
[ObsoleteAttribute(L"This class is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use the 'EnergyAnalyticalDetailModel' and 'EnergyAnalysisSurface' classes instead.")]
public ref class MassSurfaceData : public Element
[<ObsoleteAttribute("This class is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use the 'EnergyAnalyticalDetailModel' and 'EnergyAnalysisSurface' classes instead.")>]
type MassSurfaceData =
    class
        inherit Element
    end

The MassSurfaceData type exposes the following members.

Properties
 | Name | Description
Public property | Area | Area of the references that the MassSurfaceData provides properties for.
Public property | CategoryIdForConceptualSurfaceType | Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.
Public property | ConceptualConstructionId | The id of the conceptual construction associated with the reference surface.
Public property | IsConceptualConstructionByEnergyData | True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.
Public property | IsGlazingShaded | Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.
Public property | IsSlab | Indicates if a floor is a slab.
Public property | IsUnderground | Indicates if the roof, floor, slab, or wall surface reference is underground.
Public property | MassLevelDataId | The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.
Public property | MaterialId | The visualization material used for the surface for displaying the energy analytical model.
Public property | MaterialType | material type of mass zone
Public property | PercentageGlazing | The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.
Public property | PercentageSkylights | The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.
Public property | ReferenceElementId | The ElementId of the element whose face the MassSurfaceData primarily refers to.
Public property | ShadeDepth | How far any auto-generated shades should extend from the wall surface.
Public property | SillHeight | The height above the level where the bottoms of auto-generated windows will be located.
Public property | SkylightWidth | The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.
Public property | SurfaceDataSource | Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.
Top
Methods
 | Name | Description
Public method | GetFaceReferences | Gets References to the faces that the MassSurfaceData provides properties for.
Top
Remarks
Properties stored in the MassSurfaceData can be used in regeneration by the MassEnergyAnalyticalModel. For example, faces of the MassEnergyAnalyticalModel take their material values from the settings in the MassSurfaceData.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace