ParameterFilterUtilities Class

ParameterMap Class

A map that can contain a mapping of a parameter name (a String) to a parameter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBParameterMap

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterMap : APIObject,
    IEnumerable
Public Class ParameterMap
    Inherits APIObject
    Implements IEnumerable
public ref class ParameterMap : public APIObject,
    IEnumerable
type ParameterMap =
    class
        inherit APIObject
        interface IEnumerable
    end

The ParameterMap type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterMap | Initializes a new instance of the ParameterMap class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Top
See Also

Reference

Autodesk.Revit.DB Namespace