FilteredElementIdIterator Class

FilteredElementIterator Class

An iterator to a set of elements filtered by the settings of a FilteredElementCollector.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilteredElementIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilteredElementIterator : IEnumerator<Element>
Public Class FilteredElementIterator
    Implements IEnumerator(Of Element)
public ref class FilteredElementIterator : IEnumerator<Element^>
type FilteredElementIterator =
    class
        interface IEnumerator<Element>
    end

The FilteredElementIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredElementIterator
Public method | GetCurrent | The current element found by the iterator.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Top
See Also

Reference

Autodesk.Revit.DB Namespace