Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DB.AnalysisConceptualConstructionType
Autodesk.Revit.DB.ArchitectureContinuousRailType
Autodesk.Revit.DB.ArchitectureCutMarkType
Autodesk.Revit.DB.ArchitectureRailingType
Autodesk.Revit.DB.ArchitectureStairsLandingType
Autodesk.Revit.DB.ArchitectureStairsPathType
Autodesk.Revit.DB.ArchitectureStairsRunType
Autodesk.Revit.DB.ArchitectureStairsType
Autodesk.Revit.DB.ArchitectureTopographyLinkType
Autodesk.Revit.DBAssemblyType
Autodesk.Revit.DBBeamSystemType
Autodesk.Revit.DBBrowserOrganization
Autodesk.Revit.DBCADLinkType
Autodesk.Revit.DBDimensionType
Autodesk.Revit.DBDirectShapeType
Autodesk.Revit.DB.ElectricalDistributionSysType
Autodesk.Revit.DB.ElectricalInsulationType
Autodesk.Revit.DB.ElectricalTemperatureRatingType
Autodesk.Revit.DB.ElectricalVoltageType
Autodesk.Revit.DB.ElectricalWireMaterialType
Autodesk.Revit.DB.ElectricalWireType
Autodesk.Revit.DBFabricationPartType
Autodesk.Revit.DBGroupType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBImageType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBLineAndTextAttrSymbol
Autodesk.Revit.DB.MechanicalDuctInsulationType
Autodesk.Revit.DB.MechanicalDuctLiningType
Autodesk.Revit.DB.MechanicalMechanicalEquipmentSetType
Autodesk.Revit.DB.MechanicalMEPBuildingConstruction
Autodesk.Revit.DBMEPAnalyticalConnectionType
Autodesk.Revit.DBMEPSystemType
Autodesk.Revit.DBModelTextType
Autodesk.Revit.DBMultiReferenceAnnotationType
Autodesk.Revit.DB.PlumbingFluidType
Autodesk.Revit.DB.PlumbingPipeInsulationType
Autodesk.Revit.DB.PlumbingPipeScheduleType
Autodesk.Revit.DBPointCloudType
Autodesk.Revit.DBRevitLinkType
Autodesk.Revit.DBSiteLocation
Autodesk.Revit.DB.StructureAnalyticalLinkType
Autodesk.Revit.DB.StructureAreaReinforcementType
Autodesk.Revit.DB.StructureEndTreatmentType
Autodesk.Revit.DB.StructureFabricAreaType
Autodesk.Revit.DB.StructureFabricSheetType
Autodesk.Revit.DB.StructureFabricWireType
Autodesk.Revit.DB.StructureLoadTypeBase
Autodesk.Revit.DB.StructurePathReinforcementType
Autodesk.Revit.DB.StructureRebarBarType
Autodesk.Revit.DB.StructureRebarBendingDetailType
Autodesk.Revit.DB.StructureRebarContainerType
Autodesk.Revit.DB.StructureRebarCoverType
Autodesk.Revit.DB.StructureRebarHookType
Autodesk.Revit.DB.StructureRebarShape
Autodesk.Revit.DB.StructureStructuralConnectionApprovalType
Autodesk.Revit.DB.StructureStructuralConnectionHandlerType
Autodesk.Revit.DB.StructureStructuralConnectionType
Autodesk.Revit.DBTilePattern
Autodesk.Revit.DBViewFamilyType

ElementType Properties

The ElementType type exposes the following members.

Properties
 | Name | Description
Public property | CanBeCopied | Determine if this ElementType can create a copy
Public property | CanBeDeleted | Determine if this ElementType can be deleted
Public property | CanBeRenamed | Determine if this ElementType can be renamed
Public property | FamilyName | Gets the family name of this element type.
Public property | Name | Set the name for the ElementType. (Overrides ElementName)
Top
See Also

Reference