WorksetFilter Class

WorksetId Class

WorksetId identifies a workset within a single document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksetId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksetId
Public Class WorksetId
public ref class WorksetId
type WorksetId = class end

The WorksetId type exposes the following members.

Constructors
 | Name | Description
Public method | WorksetId | Create an WorksetId handle with the given integer id.
Top
Properties
 | Name | Description
Public property | IntegerValue | Provides the value of the WorksetId as an integer.
 | InvalidWorksetId | Get the invalid WorksetId whose IntegerValue is -1.
Top
Methods
 | Name | Description
Public method | Compare | Compares two WorksetIds.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides ObjectGetHashCode)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides ObjectToString)
Top
Operators
Name | Description
Equality(WorksetId, WorksetId) | Determines whether these two WorksetIds are the same.
GreaterThan(WorksetId, WorksetId) | Determines whether one WorksetId is greater than another WorksetId.
GreaterThanOrEqual(WorksetId, WorksetId) | Determines whether one WorksetId is not less than another WorksetId.
Inequality(WorksetId, WorksetId) | Determines whether these two WorksetIds are different.
LessThan(WorksetId, WorksetId) | Determines whether this WorksetId is less than another WorksetId.
LessThanOrEqual(WorksetId, WorksetId) | Determines whether one WorksetId is not greater than another WorksetId.
Top
Remarks
WorksetId is not guaranteed to be unique. It is only valid within one model and its value may change when the model is synchronized with central. If unique identification of a workset is needed, the workset's GUID should be used instead.
See Also

Reference

Autodesk.Revit.DB Namespace