BuildingPadType Class

Represents a specific type of Building Pad.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBBuildingPadType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BuildingPadType : HostObjAttributes
Public Class BuildingPadType
    Inherits HostObjAttributes
public ref class BuildingPadType : public HostObjAttributes
type BuildingPadType =
    class
        inherit HostObjAttributes
    end

The BuildingPadType type exposes the following members.

Properties
 | Name | Description
Public property | ThermalProperties | The calculated and settable thermal properties of the BuildingPadType
Top
Methods
 | Name | Description
 | CreateDefault | Creates a BuildingPadType element and adds it to the document.
Top
See Also

Reference

Autodesk.Revit.DB Namespace