FilledRegion Class

FilledRegionType Class

A filled region attributes element. Note, the forground pattern color is stored in the parent class
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBLineAndTextAttrSymbol
Autodesk.Revit.DBFilledRegionType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilledRegionType : LineAndTextAttrSymbol
Public Class FilledRegionType
    Inherits LineAndTextAttrSymbol
public ref class FilledRegionType : public LineAndTextAttrSymbol
type FilledRegionType =
    class
        inherit LineAndTextAttrSymbol
    end

The FilledRegionType type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundPatternColor | The background fill pattern color.
Public property | BackgroundPatternId | The background fill pattern Id.
Public property | ForegroundPatternColor | The foreground fill pattern color.
Public property | ForegroundPatternId | The foreground fill pattern Id.
Public property | IsMasking | If true then the FilledRegion will cover the lines and edges of objects behind it. If false then lines and edges will remain visible.
Public property | LineWeight | The line weight of the fill pattern.
Top
Methods
 | Name | Description
Public method | IsValidBackgroundPatternId | Check if the id is valid for a background pattern
Public method | IsValidFillPatternId | Check if the id is a FillPatternElement or an invalidElementId
Public method | IsValidForegroundPatternId | Check if the id is valid for a foreground pattern
 | IsValidLineWeight | Indicates whether the given line weight value is valid.
Public method | IsValidMasking | Check that in a family the FillRegionType is always masking.
Public method | IsValidSolidFillPatternId | Checks if the id is valid for a background pattern
Top
See Also

Reference

Autodesk.Revit.DB Namespace