DWGExportOptions Class

DWGImportOptions Class

The import options used by importing DWG or DXF format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBDWGImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DWGImportOptions : BaseImportOptions
Public Class DWGImportOptions
    Inherits BaseImportOptions
public ref class DWGImportOptions : public BaseImportOptions
type DWGImportOptions =
    class
        inherit BaseImportOptions
    end

The DWGImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DWGImportOptions | Constructs a new instance of DWGImportOptions with default values of all properties.
Public method | DWGImportOptions(DWGImportOptions) | Constructs a new instance of DWGImportOptions as a copy of the import options.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetLineWeights | Gets array of line weights.
Public method | SetLineWeights | Set array of line weights.
Top
See Also

Reference

Autodesk.Revit.DB Namespace