BuiltInFailuresMacroFailures Class

BuiltInFailures.MassFailures Class

BuiltInFailuresMassFailures Class

Failures about Mass.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMassFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MassFailures
Public NotInheritable Class MassFailures
public ref class MassFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MassFailures = class end

The BuiltInFailuresMassFailures type exposes the following members.

Properties
Name | Description
AutoGlazingFailed | Failure in Auto-Glazing region computation.
AutoGlazingFailedError | Failure in Auto-Glazing region computation.
BooleanUnionFailed | Failed to merge overlapping solids
CannotIntegrate | In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.
CannotMergeGeometry | The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won't be computed.
CannotMoveMassing | Can't move whole Massing. Move the elements within the Massing instead.
CreateCoreGeometryFailed | Failed to create core geometries.
DividePerimeterZoneFailed | Failed to divide perimeter zone.
FaceRegionCreationFailed | Failure in face region creation.
FaceSplitFailed | A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.
FloorAreaFaceFailed | Failed to create a Mass Floor.
FloorMightLookWrong | Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.
FloorRecreateFailed | The floor cannot be created.
FloorRecreateFailedWarning | The floor cannot be created because no suitable level in the target document can be found.
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.
MultipleMassing | Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Models.
NoCurtainRoofsInMassing | Massing cannot be created with a curtain roof. Please change the default roof type and try again.
NonOccupiableMassZone | For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.
NoSolidInMass | Mass contains no solid geometry. Mass Floors, volume, and surface area, won't be computed.
OpenAndSolidGeometry | Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.
OpenGeometryOnly | Mass contains only mesh geometry, which can't be used to compute Mass Floors, volume, or surface area.
OverlappingSolids | Found volumetric overlap between solids. They will be merged into one
SketchCurveNotModelable | This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.
SplitFacesByGroundPlaneCrashed | Failed to split face by ground plane.
SplitFacesByGroundPlaneFailed | Failed to split face by ground plane.
SplitOverlappingFacesFailed | Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.
TooManyGeometries | The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.
UpgradedMassingWarning | Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.
Top
See Also

Reference

Autodesk.Revit.DB Namespace