Sketch Class

SketchBase Class

Provides access to the SketchBase in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSketchBase
Autodesk.Revit.DBPath3d
Autodesk.Revit.DBSketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SketchBase : Element
Public Class SketchBase
    Inherits Element
public ref class SketchBase : public Element
type SketchBase =
    class
        inherit Element
    end

The SketchBase type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
SketchBase is the base class of Sketch.
See Also

Reference

Autodesk.Revit.DB Namespace