BuiltInFailuresDesignOptionFailures Class

BuiltInFailures.DetailFailures Class

BuiltInFailuresDetailFailures Class

Failures about Detail.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDetailFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DetailFailures
Public NotInheritable Class DetailFailures
public ref class DetailFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DetailFailures = class end

The BuiltInFailuresDetailFailures type exposes the following members.

Properties
Name | Description
EavesAreAligned | All eaves are already aligned.
NeedsTwoToAlignEaves | At least two Slope Defining Lines are needed to perform Align Eaves.
RepeatingDetailSpacingZeroError | Spacing must be greater than 0
Top
See Also

Reference

Autodesk.Revit.DB Namespace