ExportLinetypeInfo Class

ExportLinetypeKey Class

A key used to represent an item stored in an ExportLinetypeTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLinetypeKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLinetypeKey : IDisposable
Public Class ExportLinetypeKey
    Implements IDisposable
public ref class ExportLinetypeKey : IDisposable
type ExportLinetypeKey =
    class
        interface IDisposable
    end

The ExportLinetypeKey type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLinetypeKey | Constructs a new default ExportLinetypeKey.
Public method | ExportLinetypeKey(ExportLinetypeKey) | Constructs a new copy of the input ExportLinetypeKey object.
Public method | ExportLinetypeKey(String) | Constructs a new default ExportLinetypeKey using the original line type name as input.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalLinetypeName | The original linetype name.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLinetypeKey
Top
See Also

Reference

Autodesk.Revit.DB Namespace