CategorySetIterator Class

CategoryType Enumeration

The type of category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CategoryType
Public Enumeration CategoryType
public enum class CategoryType
type CategoryType
Members
Member name | Value | Description
Invalid | 0 | The category type is invalid.
Model | 1 | A model element category.
Annotation | 2 | An annotation element category.
Internal | 4 | The category is for internal usage.
AnalyticalModel | 5 | An analytical model element category.
See Also

Reference

Autodesk.Revit.DB Namespace