CurtainSystemType Class

Curve Class

A parametric curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Curve : GeometryObject
Public Class Curve
    Inherits GeometryObject
public ref class Curve : public GeometryObject
type Curve =
    class
        inherit GeometryObject
    end

The Curve type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsClosed | Describes whether the curve is closed.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance.
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve.
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve.
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve.
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve.
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve.
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve.
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results.
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
Top
Remarks
The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parameterization. Otherwise, it is defined for all values of the parameter.
See Also

Reference

Autodesk.Revit.DB Namespace