MEPNetworkIterator Methods

The MEPNetworkIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | End | Checks if the network iteration has completed.
Public method | GetAnalyticalModelData | Gets the analytical model data at the current iteration step.
Public method | GetAnalyticalNode | Gets the analytical node at the current iteration step.
Public method | GetAnalyticalSegment | Gets the analytical segment at the current iteration step.
Public method | GetOtherAnalyticalNode | Gets the other analytical node at the current iteration step.
Public method | Next | Moves this iterator to the next step of network iteration.
Public method | Start | Gets the first step of network iteration.
Top
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace