View3D Class

View3D Methods

The View3D type exposes the following members.

Methods
 | Name | Description
Public method | CanResetCameraTarget | Checks whether the camera target can be reset for this view.
Public method | CanSaveOrientation | Returns true if the View3D's orientation can be saved, false otherwise.
Public method | CanToggleBetweenPerspectiveAndIsometric | Checks whether this view can toggle between perspective and isometric.
 | CreateIsometric | Returns a new isometric View3D.
 | CreatePerspective | Returns a new perspective View3D.
Public method | GetLevelsThatShowGrids | Returns the list of levels ids where grids are displayed in this 3D view.
Public method | GetOrientation | Gets the current non-saved orientation of the View3D.
 | GetRenderingSettings | Returns the current rendering settings for this 3d view.
Public method | GetSavedOrientation | Gets the saved orientation of the View3D.
Public method | GetSectionBox | Gets a copy of the section box for this 3D view.
Public method | HasBeenLocked | Identifies if the view has ever been locked.
Public method | HideGridsOnLevel | This method hides the grid lines in this 3D view on the given Level.
Public method | OrientTo | Reorients the view to align with the forward direction.
Public method | ResetCameraTarget | Resets the camera target to the center of the field of view.
Public method | RestoreOrientationAndLock | Locks the view and restores its orientation.
Public method | SaveOrientation | Converts the temporary orientation of the View3D into its saved orientation.
Public method | SaveOrientationAndLock | Locks the view and saves its orientation
Public method | ScalePerspectiveCropBox | Scale an existing crop box of the perspective view.
Public method | SetOrientation | Sets the temporary orientation of the View3D. The new orientation is not saved in the document.
Public method | SetRenderingSettings | Changes the rendering settings for this 3d view.
 | SetSectionBox | Sets the section box for this 3D view.
Public method | ShowGridsOnLevel | This method displays the grid lines in this 3DView on the given Level.
Public method | ShowGridsOnLevels | This method displays the grid lines in this 3D view on the given Levels.
Public method | ToggleToIsometric | Toggles this view to isometric.
Public method | ToggleToPerspective | Toggles this view to perspective.
Public method | Unlock | Unlocks the view. Has no effect if the view is already unlocked.
Top
See Also

Reference