AreaScheme Class

AreaTag Class

Provides access to the area topology in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElementTag
Autodesk.Revit.DBAreaTag

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AreaTag : SpatialElementTag
Public Class AreaTag
    Inherits SpatialElementTag
public ref class AreaTag : public SpatialElementTag
type AreaTag =
    class
        inherit SpatialElementTag
    end

The AreaTag type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area that the tag is associated with.
Public property | AreaTagType | The tag type.
Top
Methods
 | Name | Description
Top
Remarks
The areaTag object can be queried for its boundary for use in space planning tools.
See Also

Reference

Autodesk.Revit.DB Namespace