XYZ Class

XYZ.UnaryNegation Operator

XYZUnaryNegation Operator

Negates the specified vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ operator -(
    XYZ source
)
Public Shared Operator - (
    source As XYZ
) As XYZ
public:
static XYZ^ operator -(
    XYZ^ source
)
static let inline (-)
        source : XYZ  : XYZ

Parameters

source XYZ

Return Value

XYZ
The vector opposite to the specified vector.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The negated vector is obtained by changing the sign of each coordinate of the specified vector.
See Also

Reference