BuiltInFailuresRebarCouplerFailures Class

BuiltInFailures.RebarFailures Class

BuiltInFailuresRebarFailures Class

Failures about Rebar.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRebarFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RebarFailures
Public NotInheritable Class RebarFailures
public ref class RebarFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RebarFailures = class end

The BuiltInFailuresRebarFailures type exposes the following members.

Properties
Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotCreateFreeFormSetDueToShortBar | Cannot create the rebar set using the current references because at least one bar is below the minimum allowed length. Edit the covers and extents of the set and try the desired layout options again.
CannotKeepVariabilityOfRebarInGroup | Modifications to the rebar set might cause it to revert to a uniform distribution and reset all disabled constraints. This can occur for layout changes as well as modifications to the geometry.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CannotSolveRebarShapeUsingDataFromDimension | Cannot solve rebar shape using the current constraints.
CannotSolveRebarWithDelayedConstraints | There are rebar handles with invalid selected targets to constrain. The bar preview corresponds to latest valid constraints.
CantMakeFillets | The bar cannot be bent in that shape. Check the bending diameter and the bar type.
ChangeUnitsFormatWarn | The modification of the unit will cause the change of the Reinforcement rounding format. Do you want to continue?
ClearPresentationForAllBarsInRebarSet | All Bars in a Free Form Rebar Set have been hidden.
ConstraintForHandleIsDisabled | The constriant for current handle is disabled.
CoverTooLong | Rebar Cover length is too large for host thickness.
DelayedConstraintForHandle | The selected constraint targets do not satisfy a valid constraint. The rebar preview corresponds to latest valid rebar constraints.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostFamilyCanHostRebarParam | Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
Inverted3dShape | The Rebar Shape XX cannot be inverted.
MaxHookExtensionMultiplierWarn | The allowable range of values for the Rebar Hook Extension Multiplier is from 0.01 to 99.0.
MissingCurrentConstraintForHandle | The current handle has no constraint. Please select a valid target to apply a new constraint.
NoRebarSelected | At least one Rebar should be selected.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
NoVisibleRebarHandle | Editing of the constraints for the selected rebar with free form geometry is not available. However, the default automatic constraints may still work.
NoVisibleTargetsForCurrentConstraint | There are no visible constraint targets in the current view. Please switch to another view.
OutOfPlaneBendDiameterTooSmall | The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.
OutSideOfHost | Rebar is placed completely outside of its host.
PathShapeFailure | Can't solve Rebar Shape in Path Reinforcement.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarContainerOutSideOfHostWarning | Rebar Container is placed completely outside of its host.
RebarDimensionalConstraintLost | Dimensional constraint on Rebar element was lost on upgrade.
RebarEndTreatmentOverHook | Cannot set end treatment at an end that has hook.
RebarHookOverEndTreatment | Cannot set hook at an end that has end treatment.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarInvalidDiameterRemoved | Invalid RebarBarType was removed on upgrade.
RebarMovedBarsOverlapped | There are identical overlapping bars in the rebar set. This will result in double counting in schedules.
RebarNoConstraints | The constraints for the rebar with free form geometry are not set or modifications have caused the automatic constraints to be deleted. You can use Edit Constraints to assign new bar constraints.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarShapeFailureCustomError | '[ErrorMessage]'
RebarShapeFailureCustomWarning | '[ErrorMessage]'
RebarShapeFailureDueToStaggerOffset | Can't solve Rebar Shape using the exisintg stagger offsets.
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
RemoveSpliceBetweenBars | Splice cannot be maintained.
SketchDimensionsRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.
SketchDimsBWFRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed bend profile definition.
SketchFreeFormSet | Sketching of a free form set produces only a single bar.
SketchNonPlanarFreeForm | The selected free form rebar is not planar. Sketching it will discard the current geometry.
SpliceTypeWasDeleted | Splice type was deleted.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1002 bar locations.
TooSmallNumberOfBars | Rebar Set must contain at least two bar locations.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.
UnconstrainableRebarHandle | The rebar handle does not have any constraint targets.
Top
See Also

Reference

Autodesk.Revit.DB Namespace