Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBArc
Autodesk.Revit.DBCylindricalHelix
Autodesk.Revit.DBEllipse
Autodesk.Revit.DBHermiteSpline
Autodesk.Revit.DBLine
Autodesk.Revit.DBNurbSpline

Curve Properties

The Curve type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsClosed | Describes whether the curve is closed.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Top
See Also

Reference