SharedParameterApplicableRule Class

SharedParameterElement Class

An element that stores the definition of a shared parameter which is loaded into the document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBParameterElement
Autodesk.Revit.DBSharedParameterElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SharedParameterElement : ParameterElement
Public Class SharedParameterElement
    Inherits ParameterElement
public ref class SharedParameterElement : public ParameterElement
type SharedParameterElement =
    class
        inherit ParameterElement
    end

The SharedParameterElement type exposes the following members.

Properties
 | Name | Description
Public property | GuidValue | The Guid that identifies this shared parameter.
Top
Methods
 | Name | Description
 | Create | Creates a new shared parameter element in the document representing the parameter stored in the input ExternalDefinition.
 | Lookup | Finds the shared parameter element that corresponds to the given Guid.
Public method | ShouldHideWhenNoValue | Indicates whether the parameter should be hidden from the properties palette if it has no value.
Top
Remarks
Shared parameters are user-defined parameters that can be shared by multiple Revit documents. A shared parameter is identified by a GUID. Basic information of the shared parameter are accessed through GetDefinition().
See Also

Reference

Autodesk.Revit.DB Namespace