BuiltInFailuresSystemsFailures Class

BuiltInFailures.TagFailures Class

BuiltInFailuresTagFailures Class

Failures about Tag.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresTagFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class TagFailures
Public NotInheritable Class TagFailures
public ref class TagFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TagFailures = class end

The BuiltInFailuresTagFailures type exposes the following members.

Properties
Name | Description
CannotCopyTag | A tag cannot be arrayed without copying the associated element.
CannotCopyTagWarn | A tag cannot be arrayed without copying the associated element.
CannotPasteAssociate | Can't find new associated element. Element won't be copied.
CannotPasteOrphanTags | Orphaned tags cannot be pasted.
CannotPasteOrphanTagsWarn | Orphaned tags cannot be pasted.
CannotPasteTag | Can't find new element to tag. Tag won't be copied.
CannotRemapTagReference | The tag reference was not remapped.
ElementCategoryChangeInvalidatesTag | Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.
ElementCategoryChangeInvalidatesTagUpgrade | During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.
MultiCategoryTagFilterParamNotFoundInElement | The filter specified by Multi-Category Tag can't be used with the tagged object.
RemoveTagWithNoLeaders | The Tag was deleted because it was no longer pointing to any elements.
TagsCannotBePlacedInUnlocked3dViews | Tags can't be pasted into Unlocked 3D views.
Top
See Also

Reference

Autodesk.Revit.DB Namespace