PrimaryDesignOptionMemberFilter Class

PrimarySizeCriterion Class

This class contains a size criterion for a RoutingPreferenceRule.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRoutingCriterionBase
Autodesk.Revit.DBPrimarySizeCriterion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PrimarySizeCriterion : RoutingCriterionBase
Public Class PrimarySizeCriterion
    Inherits RoutingCriterionBase
public ref class PrimarySizeCriterion : public RoutingCriterionBase
type PrimarySizeCriterion =
    class
        inherit RoutingCriterionBase
    end

The PrimarySizeCriterion type exposes the following members.

Constructors
 | Name | Description
Public method | PrimarySizeCriterion | Constructs a PrimarySizeCriterion with a minimum and maximum size.
Top
Properties
 | Name | Description
Public property | MaximumSize | The maximum size of this criterion.
Public property | MinimumSize | The minimum size of this criterion.
Top
Methods
 | Name | Description
 | All | Creates a criterion with a range of all sizes.
 | None | Creates a criterion with a range of no sizes.
Top
See Also

Reference

Autodesk.Revit.DB Namespace