XYZ Class

XYZ.Addition Operator

XYZAddition Operator

Adds the two specified vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ operator +(
    XYZ left,
    XYZ right
)
Public Shared Operator + (
    left As XYZ,
    right As XYZ
) As XYZ
public:
static XYZ^ operator +(
    XYZ^ left,
    XYZ^ right
)
static let inline (+)
        left : XYZ *
        right : XYZ  : XYZ

Parameters

left XYZ
The first vector.
right XYZ
The second vector.

Return Value

XYZ
The vector equal to the sum of the two source vectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when left or right is .
Remarks
The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.
See Also

Reference