ExportLineweightTableIterator Class

ExportPaperFormat Enumeration

Paper formats supported by export

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportPaperFormat
Public Enumeration ExportPaperFormat
public enum class ExportPaperFormat
type ExportPaperFormat
Members
Member name | Value | Description
Default | 0 | Default paper format.
ANSI_A | 1 | ANSI A, 8.5 x 11 in
ANSI_B | 2 | ANSI B, 11 x 17 in
ANSI_C | 3 | ANSI C, 17 x 22 in
ANSI_D | 4 | ANSI D, 22 x 34 in
ANSI_E | 5 | ANSI E, 34 x 44 in
ISO_A4 | 6 | ISO A4, 210 x 297 mm
ISO_A3 | 7 | ISO A3, 297 x 420 mm
ISO_A2 | 8 | ISO A2, 420 x 594 mm
ISO_A1 | 9 | ISO A1, 594 x 841 mm
ISO_A0 | 10 | ISO A0, 841 x 1189 mm
ISO_B4 | 11 | ISO B4, 250 x 353 mm
ISO_B3 | 12 | ISO B3, 353 x 500 mm
ISO_B2 | 13 | ISO B2, 500 x 707 mm
ISO_B1 | 14 | ISO B1, 707 x 1000 mm
ARCH_A | 15 | ARCH A, 9 x 12 in
ARCH_B | 16 | ARCH B, 12 x 18 in
ARCH_C | 17 | ARCH C, 18 x 24 in
ARCH_D | 18 | ARCH D, 24 x 36 in
ARCH_E | 19 | ARCH E, 36 x 48 in
ARCH_E1 | 20 | ARCH E1, 30 x 42 in
ARCH_E2 | 21 | ARCH E2, 26 x 38 in
ARCH_E3 | 22 | ARCH E3, 27 x 39 in
See Also

Reference

Autodesk.Revit.DB Namespace