Ceiling Class
Create Overload

CeilingAndFloor Class

A base class that provides support for all ceiling and floor objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCeilingAndFloor
Autodesk.Revit.DB.ArchitectureBuildingPad
Autodesk.Revit.DBCeiling
Autodesk.Revit.DBFloor
Autodesk.Revit.DBToposolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CeilingAndFloor : HostObject
Public Class CeilingAndFloor
    Inherits HostObject
public ref class CeilingAndFloor : public HostObject
type CeilingAndFloor =
    class
        inherit HostObject
    end

The CeilingAndFloor type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace