FilterableValueProvider Class

FilterCategoryRule Class

A filter rule that matches elements of a set of categories.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterCategoryRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterCategoryRule : FilterRule
Public Class FilterCategoryRule
    Inherits FilterRule
public ref class FilterCategoryRule : public FilterRule
type FilterCategoryRule =
    class
        inherit FilterRule
    end

The FilterCategoryRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterCategoryRule | Constructs a new instance of FilterCategoryRule.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
 | AllCategoriesFilterable | Checks that all of the given categories are filterable.
Public method | GetCategories | Gets the rule's categories.
Public method | SetCategories | Sets the rule's categories.
Top
See Also

Reference

Autodesk.Revit.DB Namespace