Surface Class

Sweep Class

A sweep solid or void form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBSweep

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Sweep : GenericForm
Public Class Sweep
    Inherits GenericForm
public ref class Sweep : public GenericForm
type Sweep =
    class
        inherit GenericForm
    end

The Sweep type exposes the following members.

Properties
 | Name | Description
Public property | IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Public property | MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Public property | Path3d | The selected curves used for the sweep path.
Public property | PathSketch | The sketched path for the sweep.
Public property | ProfileSketch | The profile sketch of the sweep.
Public property | ProfileSymbol | The family symbol profile details for the sweep.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace