ParameterTypeId Class

ParameterUtils Class

A utility class of functions related to parameters.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ParameterUtils
Public NotInheritable Class ParameterUtils
public ref class ParameterUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ParameterUtils = class end

The ParameterUtils type exposes the following members.

Methods
Name | Description
DownloadCompanyName | Downloads the name of the given parameter's owning account and records it in the given document. If the owning account's name is already recorded in the given document, this method returns the name without downloading it again.
DownloadParameter | Create a shared parameter element in the given document according to a parameter definition downloaded from the Parameters Service.
DownloadParameterOptions | Retrieves settings associated with the given parameter from the Parameters Service.
GetAllBuiltInGroups | Gets the identifiers of all built-in parameter groups.
GetAllBuiltInParameters | Gets the identifiers of all built-in parameters.
GetBuiltInParameter | Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.
GetParameterTypeId | Gets the ForgeTypeId identifying the built-in parameter corresponding to the given BuiltInParameter value.
IsBuiltInGroup | Checks whether a ForgeTypeId identifies a built-in parameter group.
IsBuiltInParameter(ElementId) | Checks whether an ElementId identifies a built-in parameter.
IsBuiltInParameter(ForgeTypeId) | Checks whether a ForgeTypeId identifies a built-in parameter.
Top
See Also

Reference

Autodesk.Revit.DB Namespace