NavisworksExportOptions Class

NavisworksExportScope Enumeration

An enumerated type listing possible "Element Scopes" of Navisworks Exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum NavisworksExportScope
Public Enumeration NavisworksExportScope
public enum class NavisworksExportScope
type NavisworksExportScope
Members
Member name | Value | Description
Model | 0 | Export all elements in the document.
View | 1 | Export the elements in a view.
SelectedElements | 2 | Export the selected elements.
See Also

Reference

Autodesk.Revit.DB Namespace