MEPNetworkSegmentData Properties

The MEPNetworkSegmentData type exposes the following members.

Properties
 | Name | Description
Public property | Coefficient | The calculated coefficient of this segment, dimensionless.
Public property | Flow | The calculated flow of this segment, in ft^3/s. The positive value means the flow is from the start to the end node, the negative value means opposite direction.
Public property | FlowState | The calculated flow state of this segment.
Public property | FrictionFactor | The calculated friction factor of this segment, dimensionless.
Public property | IsCriticalPath | Verifies if the segment is on the critical path.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PressureDrop | The calculated pressure drop of this segment, in kg/(ft*s^2).
Public property | RelativeRoughness | The relative roughness of this segment, dimensionless.
Public property | ReynoldsNumber | The Reynolds number of this segment, dimensionless.
Public property | SectionNumber | The section this segment belongs to.
Public property | Velocity | The calculated velocity of this segment, in ft/s.
Public property | VelocityPressure | The calculated velocity pressure of this segment, in kg/(ft*s^2).
Top
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace