FilteredElementCollector Class

FilteredElementCollector.OfCategory Method

FilteredElementCollectorOfCategory Method

Applies an ElementCategoryFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector OfCategory(
    BuiltInCategory category
)
Public Function OfCategory (
    category As BuiltInCategory
) As FilteredElementCollector
public:
FilteredElementCollector^ OfCategory(
    BuiltInCategory category
)
member OfCategory :
        category : BuiltInCategory -> FilteredElementCollector

Parameters

category BuiltInCategory
The category.

Return Value

FilteredElementCollector
This collector.
Remarks
Only elements of this category id will pass the collector.
Example
C#
VB
C++
F#
Copy
// Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> doors = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements();
' Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
Dim collector As New FilteredElementCollector(document)
Dim doors As ICollection(Of Element) = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference