FamilySymbol Class

FamilySymbol Methods

The FamilySymbol type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible.
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section.
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol.
Public method | GetStructuralSection | Gets the structural section from element.
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol.
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties.
Public method | SetStructuralSection | Sets the structural section in element.
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol.
Top
See Also

Reference