CylindricalHelix Class

CylindricalSurface Class

A cylindrical surface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBCylindricalSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CylindricalSurface : Surface
Public Class CylindricalSurface
    Inherits Surface
public ref class CylindricalSurface : public Surface
type CylindricalSurface =
    class
        inherit Surface
    end

The CylindricalSurface type exposes the following members.

Properties
 | Name | Description
Public property | Axis | Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder.
Public property | Origin | Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder.
Public property | Radius | Radius of the circle that defines the base of this cylinder.
Public property | XDir | X axis of the local coordinate system associated with this cylinder.
Public property | YDir | Y axis of the local coordinate system associated with this cylinder.
Top
Methods
 | Name | Description
 | Create | Construct a cylindrical surface defined by a local coordinate system and a radius.
Public method | GetFrameOfReference | Returns frame of reference associated with this CylindricalSurface.
Top
Remarks
The parametric equation of the cylinder is S(u, v) = center + radius*cos(u)*xVec + radius*sin(u)*yVec + v*zVec.
See Also

Reference

Autodesk.Revit.DB Namespace