EnergyAnalysisSurface Class

Analytical surface. The collection of analytic openings belonging to this analytical parent surface
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisSurface

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisSurface : Element
Public Class EnergyAnalysisSurface
    Inherits Element
public ref class EnergyAnalysisSurface : public Element
type EnergyAnalysisSurface =
    class
        inherit Element
    end

The EnergyAnalysisSurface type exposes the following members.

Properties
 | Name | Description
Public property | Azimuth | The azimuth angle for this surface.
Public property | CADLinkUniqueId | The unique id of the originating CAD object's link (linked document) associated with this surface.
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this surface.
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | Normal | The outward normal for this surface.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | OriginatingElementName | The name for the originating Revit element.
Public property | SurfaceId | The unique identifier for the surface.
Public property | SurfaceName | The unique name identifier for this surface.
Public property | SurfaceType | The analytical surface type.
Public property | Tilt | The tilt angle for this surface.
Public property | Type | The gbXML surface type attribute.
Public property | Width | The width of the analytical rectangular geometry.
Top
Methods
 | Name | Description
Public method | GetAdjacentAnalyticalSpace | Gets the secondary adjacent analytical space this surface is associated with.
Public method | GetAnalyticalOpenings | Returns the analytical openings of the analytical surface.
Public method | GetAnalyticalSpace | Gets the primary analytical space this surface is associated with.
Public method | GetConstruction | Gets the analytic construction this surface is associated with.
Public method | GetPolyloop | Gets the planar polygon describing the surface geometry.
Public method | GetPolyloops | Gets the collection of planar polygons describing the surface geometry.
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace