VertexIndexPairArrayIterator Class

VertexPair Class

Indices of a pair of vertices in two CurveLoops(one vertex in each loop).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBVertexPair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VertexPair : IDisposable
Public Class VertexPair
    Implements IDisposable
public ref class VertexPair : IDisposable
type VertexPair =
    class
        interface IDisposable
    end

The VertexPair type exposes the following members.

Constructors
 | Name | Description
Public method | VertexPair | Constructs a new VertexPair from a pair of indices in the curve loops.
Top
Properties
 | Name | Description
Public property | First | Identifies the first index of VertexPair.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Second | Identifies the second index of VertexPair.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the VertexPair
Top
Remarks
A vertex is specified by the index in the CurveLoop of the curve having that vertex as its start point. Indexes start at 0.
See Also

Reference

Autodesk.Revit.DB Namespace