WallFoundationType Class

WallFunction Enumeration

Indicates the function of a specified WallType, as specified in the parameter FUNCTION_PARAM on the WallType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WallFunction
Public Enumeration WallFunction
public enum class WallFunction
type WallFunction
Members
Member name | Value | Description
Interior | 0 | An interior wall.
Exterior | 1 | An exterior wall.
Foundation | 2 | A foundation wall.
Retaining | 3 | A retaining wall.
Soffit | 4 | A soffit wall.
Coreshaft | 5 | A coreshaft wall.
See Also

Reference

Autodesk.Revit.DB Namespace