SpatialElementBoundaryOptions Class

SpatialElementBoundarySubface Class

SpatialElementBoundarySubface represents the geometry boundary information of spatial element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpatialElementBoundarySubface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementBoundarySubface : IDisposable
Public Class SpatialElementBoundarySubface
    Implements IDisposable
public ref class SpatialElementBoundarySubface : IDisposable
type SpatialElementBoundarySubface =
    class
        interface IDisposable
    end

The SpatialElementBoundarySubface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpatialBoundaryElement | Element that gave rise to this room face.
Public property | SubfaceArisesFromElementFace | Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.
Public property | SubfaceType | Type of the subface.
Public property | Valid | Indicates if the subface instance is valid and can be used.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementBoundarySubface
Public method | GetBoundingElementFace | Returns the face of the bounding element.
Public method | GetSpatialElementFace | Returns the face of the spatial element's 3D geometry.
Public method | GetSubface | Returns a face that represents the portion of the room face bounded by the boundary element.
Top
See Also

Reference

Autodesk.Revit.DB Namespace