BIMExportOptions Class

Binding Class

Binding objects are used to take a parameter definition and bind it to one or more categories.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBBinding
Autodesk.Revit.DBElementBinding

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class Binding : APIObject
Public MustInherit Class Binding
    Inherits APIObject
public ref class Binding abstract : public APIObject
[<AbstractClassAttribute>]
type Binding =
    class
        inherit APIObject
    end

The Binding type exposes the following members.

Properties
Name | Description
Top
Methods
 | Name | Description
Top
Remarks
This class is a base class for all types of parameter binding within Autodesk Revit. Once the binding objects are created and added to the document parameters will be added to elements in those categories specified in the binding. There are currently two types of binding available, Instance binding and Type binding. The key difference between the two is that the instance bound parameters appear on all instances of the elements in those categories. Changing the parameter on one does not affect the other instances of the parameter. The Type bound parameters appear only on the type object and is shared by all the instances that use that type. Changing the type bound parameter affects all instances of the elements that use that type. Note, a definition can only be bound to an instance or a type and not both.
See Also

Reference

Autodesk.Revit.DB Namespace