ModelCurveNode Class

ModelEllipse Class

Represents a ModelEllipse within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DBModelEllipse

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelEllipse : ModelCurve
Public Class ModelEllipse
    Inherits ModelCurve
public ref class ModelEllipse : public ModelCurve
type ModelEllipse =
    class
        inherit ModelCurve
    end

The ModelEllipse type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace