ExternalResourceSubFolder Class

ExternalResourceType Class

A type class used to distinguish between different kinds of external resource.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGuidEnum
Autodesk.Revit.DBExternalResourceType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalResourceType : GuidEnum
Public Class ExternalResourceType
    Inherits GuidEnum
public ref class ExternalResourceType : public GuidEnum
type ExternalResourceType =
    class
        inherit GuidEnum
    end

The ExternalResourceType type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalResourceType | Creates a new ExternalResourceType instance.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Operators
Name | Description
Equality(ExternalResourceType, ExternalResourceType) | Compares two ExternalResourceType instances.
Inequality(ExternalResourceType, ExternalResourceType) | Compares two ExternalResourceType instances.
Top
Remarks
Revit elements can consume multiple types of external resource data, provided by one or more external servers. Conversely, external servers can support one, or more than one, type of external resource.
See Also

Reference

Autodesk.Revit.DB Namespace