BuiltInFailuresInaccurateFailures Class

BuiltInFailures.InfillFailures Class

BuiltInFailuresInfillFailures Class

Failures about Infill.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresInfillFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class InfillFailures
Public NotInheritable Class InfillFailures
public ref class InfillFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type InfillFailures = class end

The BuiltInFailuresInfillFailures type exposes the following members.

Properties
Name | Description
CannotDeleteInfill | Can't delete infilling element without deleting its insert or host.
FamilyInstanceIsNotCuttingHost | Instance is not cutting host.
InfillCannotChangeType | Infilling element replaced by a later phase insert must be the same type as the insert's host.
InfillCannotHaveDiffThickness | This infilling element must have the same thickness as its host.
InfillDifferentPhase | Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.
InfillLost | Standalone infilling Wall is separated from its insert.
InfillNoSlopeGlazing | Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.
InfillNoThicknessCeiling | Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.
InfillNoThicknessMultiface | Highlighted infilling element could not have thickness different from its host because it spans multiple faces.
InPlaceFamilyNotCuttingHost | Instance of in-place family is not cutting host.
InsertJoinedWall | Insert conflicts with joined Wall.
InsertOverlapsOrOut | Highlighted inserts overlap with other inserts or completely miss their hosts.
MovedInfillToHost | Infilling element was automatically moved to keep it aligned to host.
Top
See Also

Reference

Autodesk.Revit.DB Namespace