CategoryNameMap Class

CategoryNameMapIterator Class

An iterator to a category name map.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCategoryNameMapIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class CategoryNameMapIterator : APIObject,
    IEnumerator
Public MustInherit Class CategoryNameMapIterator
    Inherits APIObject
    Implements IEnumerator
public ref class CategoryNameMapIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type CategoryNameMapIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The CategoryNameMapIterator type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryNameMapIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the category that is the current focus of the iterator.
Public property | Key | Retrieves the category name that is the current focus of the iterator.
Top
Methods
 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Top
See Also

Reference

Autodesk.Revit.DB Namespace