CopyPasteOptions Class

CurtainCell Class

Represents a CurtainCell within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurtainCell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurtainCell : APIObject
Public Class CurtainCell
    Inherits APIObject
public ref class CurtainCell : public APIObject
type CurtainCell =
    class
        inherit APIObject
    end

The CurtainCell type exposes the following members.

Properties
 | Name | Description
Public property | CurveLoops | The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Public property | PlanarizedCurveLoops | The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace