STLExportOptions Class

STLImportOptions Class

The import options used to import STL format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBSTLImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class STLImportOptions : BaseImportOptions
Public Class STLImportOptions
    Inherits BaseImportOptions
public ref class STLImportOptions : public BaseImportOptions
type STLImportOptions =
    class
        inherit BaseImportOptions
    end

The STLImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | STLImportOptions | Constructs a new instance of STLImportOptions with default values of all properties.
Public method | STLImportOptions(STLImportOptions) | Constructs a new instance of STLImportOptions as a copy of the import options.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace