CategoryNameMapIterator Class

CategorySet Class

A set that can contains Category objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCategorySet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CategorySet : APIObject,
    IEnumerable
Public Class CategorySet
    Inherits APIObject
    Implements IEnumerable
public ref class CategorySet : public APIObject,
    IEnumerable
type CategorySet =
    class
        inherit APIObject
        interface IEnumerable
    end

The CategorySet type exposes the following members.

Constructors
 | Name | Description
Public method | CategorySet | Initializes a new instance of the CategorySet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of categories that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of a category within the set.
Public method | Erase | Removes a specified category from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified category into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace