ElementIsElementTypeFilter Class

ElementLevelFilter Class

A filter used to match elements by their associated level.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementLevelFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementLevelFilter : ElementSlowFilter
Public Class ElementLevelFilter
    Inherits ElementSlowFilter
public ref class ElementLevelFilter : public ElementSlowFilter
type ElementLevelFilter =
    class
        inherit ElementSlowFilter
    end

The ElementLevelFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementLevelFilter(ElementId) | Constructs a new instance of an ElementLevelFilter.
Public method | ElementLevelFilter(ElementId, Boolean) | Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.
Top
Properties
 | Name | Description
Public property | LevelId | The id of the level that will be matched to elements' associated level.
Top
Methods
 | Name | Description
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
Example
C#
VB
C++
F#
Copy
// Use ElementLevel filter to find elements by their associated level in the document

// Find the level whose Name is "Level 1"
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> levels = collector.OfClass(typeof(Level)).ToElements();
var query = from element in collector where element.Name == "Level 1" select element;// Linq query

// Get the level id which will be used to match elements
List<Element> level1 = query.ToList<Element>();
ElementId levelId = level1[0].Id;

// Find all walls on level one
ElementLevelFilter level1Filter = new ElementLevelFilter(levelId);
collector = new FilteredElementCollector(document);
ICollection<Element> allWallsOnLevel1 = collector.OfClass(typeof(Wall)).WherePasses(level1Filter).ToElements();

// Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
ElementLevelFilter notOnLevel1Filter = new ElementLevelFilter(levelId, true); // Inverted filter
collector = new FilteredElementCollector(document);
IList<Element> allRoomsNotOnLevel1 = collector.WherePasses(new RoomFilter()).WherePasses(notOnLevel1Filter).ToElements();
' Use ElementLevel filter to find elements by their associated level in the document

' Find the level whose Name is "Level 1"
Dim collector As New FilteredElementCollector(document)
Dim levels As ICollection(Of Element) = collector.OfClass(GetType(Level)).ToElements()
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "Level 1" _
 Select element

' Linq query
' Get the level id which will be used to match elements
Dim level1 As List(Of Element) = query.ToList()
Dim levelId As ElementId = level1(0).Id

' Find all walls on level one
Dim level1Filter As New ElementLevelFilter(levelId)
collector = New FilteredElementCollector(document)
Dim allWallsOnLevel1 As ICollection(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(level1Filter).ToElements()

' Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
Dim notOnLevel1Filter As New ElementLevelFilter(levelId, True)
' Inverted filter
collector = New FilteredElementCollector(document)
Dim allRoomsNotOnLevel1 As IList(Of Element) = collector.WherePasses(New RoomFilter()).WherePasses(notOnLevel1Filter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace