XYZ Class

XYZ.Multiply(Double, XYZ) Operator

XYZMultiply(Double, XYZ) Operator

Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ operator *(
    double value,
    XYZ right
)
Public Shared Operator * (
    value As Double,
    right As XYZ
) As XYZ
public:
static XYZ^ operator *(
    double value,
    XYZ^ right
)
static let inline (*)
        value : float *
        right : XYZ  : XYZ

Parameters

value Double
The value to multiply with the specified vector.
right XYZ
The vector to multiply with the value.

Return Value

XYZ
The multiplied vector.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when right is .
ArgumentException | Thrown when the specified value is an infinite number.
Remarks
The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.
See Also

Reference