BuiltInFailuresDPartFailures Class

BuiltInFailures.DuctFailures Class

BuiltInFailuresDuctFailures Class

Failures about Duct.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDuctFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DuctFailures
Public NotInheritable Class DuctFailures
public ref class DuctFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DuctFailures = class end

The BuiltInFailuresDuctFailures type exposes the following members.

Properties
Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.
PartNotFoundDueToNoDuctConnectedError | "In order to find a matching part, the fitting has to be connected to a duct."
PartNotFoundDueToNoDuctConnectedWarning | "In order to find a matching part, the fitting has to be connected to a duct."
Top
See Also

Reference

Autodesk.Revit.DB Namespace