BuiltInFailuresFaceSplitterFailures Class

BuiltInFailures.FamilyFailures Class

BuiltInFailuresFamilyFailures Class

Failures related to families.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFamilyFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FamilyFailures
Public NotInheritable Class FamilyFailures
public ref class FamilyFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FamilyFailures = class end

The BuiltInFailuresFamilyFailures type exposes the following members.

Properties
Name | Description
CannotAddParameterToFamily | Parameter '[Parameter]' cannot be added to the family.
CannotApplySplitWithGap | Can't make structural element.
CannotChangeCategory | Can't change category of Family Instance
CannotChangeInstFam | Can't change Instance's Family. Try changing Instance's Host to a Level first.
CannotConvertInstHostToWorkPlane | Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.
CannotConvertInstWorkPlaneToHost | Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.
CannotCopyByPatternFamilies | Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.
CannotCopyInplaceFamily | In-place family groups cannot be copied between in-place families of the same project.
CannotCopyWatchCurveBasedFixture |
CannotCutRefPlane | Can't cut reference plane.
CannotFindHost | Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.
CannotLoadImperialFamilyToMetricProject | Can't load an imperial Family into a metric Project.
CannotLoadMetricFamilyToImperialProject | Can't load a metric Family into an imperial Project.
CannotMakeType |
CannotMakeTypeCB | Can't make type "[Family Name]".
CannotMakeTypeFamilySaved | Can't make type "[Family Name]". Failing family has been saved to "[File Name]"
CannotPasteLabelsAcrossFamilies | Can't paste Labels across Families of different Categories.
CannotPasteObject | Can't paste some or all of the selected objects.
CannotRegenerateCorruptFamily | Family [Family Name] is corrupt and its instances cannot be updated. Please reload the family to repair the project..
CannotRotateElement | Can't rotate element into this position.
CannotSetFamilyTypeToNone | Cannot set Family Type to 'None';.
CannotSplitElement | Can't split structural element
CannotSplitWhileBackgroundTasksAreInProgress | Cannot split element while background tasks are in progress.
CannotUnlockFamilyTemplate | Can't unlock alignments from Family Template.
CantCopySelectionToNonStory | Can't copy this selection to a non-story Level.
CantEditWhileGrouped | You may not edit this parameter while the element is grouped.
CantMirrorInstWoHost | Can't mirror an instance without its host.
CantMoveFrozenInstance | A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.
CantPasteSelection | Can't paste selection.
CantPlaceATOnDuctError | The air terminal cannot be placed in an elevation or section view unless it is attached to a duct.
CantPlaceInsertsError | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInsertsWarning | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInstanceError | Can't place instance of [Symbol]
CantPlaceInstanceWarning | Can't place instance of [Symbol]
CantSetSlantedColumnEndPlane | Unable to determine slanted column end cut plane.
CantSolve | Can't find solution for formulas for Type '[Type Name]'.
CircularRefsForInstParams | "Instance parameter '%1!s!' generates circular references."
ColumnAlreadyAttachedWillBeReattached | The column is already attached. It will be detached and attached to the new target.
ColumnAndTargetAlreadyJoined | The column and target are joined, remove that join before attaching them.
ColumnHeightZeroBecauseOfInvalidOffset | Change Offset Value so that Column height is not 0.0.
ColumnTooLong | This column is too long. Maximum length is 30,000 ft.
ContainsSharedSameNameFamily | Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!
CouldNotGenerateReferencesForFamilyInstance | Could not generate references for Family Instance.
CouldNotPlaceAdaptiveFamInst | Could not place Adaptive Family Instance.
CustomFittingCreated | Custom fitting was created.
DeletingBadFamElemCorruption | Family contains invalid elements. They will be deleted.
DeletingBadFamElemError | Family contains invalid elements. They will be deleted.
DeletingBadFamType | Can't make type "[Family Name]". It will be deleted.
DeletingBadFamTypeDumped | Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"
DummyHostMustBePerpendicularToXY | Dummy host must be perpendicular to Z or Y axis.
DuplicateFamilyParameterNameWithSharedParameter | Parameter '[Parameter]' has the same name with an existing shared parameter.
DuplicateParamName | Family parameters have duplicate names.
DuplicateTypeName | "Ignoring attempt to add family type '%1!s!' for a second time."
ElementTypeParameterized | The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.
FailedToBecomeNonParametric | Family failed to become non-parametric!
FailedToSetParameters | Failed to apply family parameters.
FailedWhenLoadingFamily | Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.
FamilyBadUnattachedVoids | Family '[Family Name]' contains unattached voids that can't be combined for cutting. Try fixing the voids or unset the Cut with Voids parameter in the family.
FamilyCannotBeUpgraded | "Family '[Name]' cannot be upgraded and must be deleted. To fix the file in the older version of Revit, try loading newer versions of these families: [Names]."
FamilyConnectorDeletedError | The family Connector has been modified so the connection is invalid.
FamilyConnectorDeletedWarning | The family Connector has been modified so the connection is invalid.
FamilyDoesntMatchSystemPropertiesDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyIsCorruptError | Some families have become unusable. Reload the families, or delete them from the model.
FamilyIsCorruptWarning | Some families have become unusable. Reload the families, or delete them from the model.
FamilyMembersReferToOutsideFamily | Memebrs of Family '[Name]' or a nested family thereof illegally refer to Elements outside the family.
FamilyNoExternalParametersError | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersWarning | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNotFitHostShape | The host shape has changed and the family is no longer appropriate.
FamilyOverconstraint | Dimension overconstrains the Family. Cannot set Family Type to <None>.
FamilyOverconstraintCB | Dimension overconstrains the Family.
FamilyParameterNoExist | The parameter [Name] doesn't exist in the Family. It will be ignored.
FamilyValidationResult | Family Validation Warning(s): [Description]
FormulaBasedParameterCannotBeChanged | Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'
FormulasFailedForType | "Can't satisfy formulas for type [Family Symbol].
FrozenBecauseFaceGone | This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.
FrozenBecauseMonitorRelationshipGone | The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.
HighlightedElementFamRefsInvalidError | One or more references of the highlighted element have become invalid.
HighlightedElementFamRefsInvalidWarning | One or more references of the highlighted element have become invalid.
InstMayCutMoreOrFewerHosts | Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.
InstOutsideFaceBoundary | Instance origin does not lie on host face. Instance will lose association to host.
InvalidContextForAdaptivePlacement | The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.
InvalidFamilyType | Invalid family type "[Type Name]".
InvalidFormularFoundInParameter | Invalid formular found in parameter '[Param Name]' in type '[Type Name]'.
InvalidInsertOrientation | The insert orientation is incompatible with the wall's cross-section.
InvalidParameterValue | Parameter [Caption] has an invalid value.
InvalidSlantedColumnOffsets | The column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
InvalidSlantedColumnOffsetsInNestedFamily | Instance of family [Family Name] can't be updated because in nested family the column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
MightntPlaceInsertsWarning | There exist geometry collision. These elements might not be copied.
NoInstparamFormulas | Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]
NonGenericAnnotationsOutsideLegend | Only Generic Annotations may be copied between Legends and other Views
NotFamilyFile | The selected file is not a Family File.
ProfileContainsNoLoops | Profile type '[Family Symbol]' contains no loops.
ReferencePlanesOverconstrained | Reference Planes are overconstrained.
SetbackTooLarge | Setback computations are too large for this element.
SharedParameterReplacedByBuiltInOne | Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!
SizeLookupTableIsNotAvailableForType | Size Lookup Table is not available for type [Family Symbol].
SketchCannotBeAutomaticallyDimensioned | Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.
SlantedColumnEndCutPlaneIsParallelToGeometry | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnEndPlanesHaveFlipped | Position of end cut planes has resulted in a slanted column without any geometry.
StructuralColumnAttachedToNonStructuralTarget | The structural column is attached to a non-structural target.
TitleblockBadViewType | Titleblocks can only be placed on sheets.
TryingToAttachWhenJoined | The column and target are joined. The attachment has been removed.
TypeRecursiveElementIdParameter | Type's parameter cannot recursively point to the type itself.
UnableGenerateTrussByFamilyAndOrientation | Revit is unable to generate a truss using the current Layout Family and Truss orientation.
UnableToUpgradeDueToCorruptFamilies | Some families have become unusable. Reload the families, or delete them from the model.
UnexpectedFamilyChangeResultsError | Changing the family for a MEP fitting might cause unexpected results.
UnexpectedFamilyChangeResultsWarning | Changing the family for a MEP fitting might cause unexpected results.
ValueOutOfRange | The value must be from 0.0 to 1.0
WhileLoadingFamily | While loading family '[Family Name]': [Description]
WhileLoadingFamilyShared | While loading shared family '[Family Name]' from family '[Family Name]': [Description]
WhileScanningParametersForType | While loading Type '[Name]', parameter '[Name]': [Description]
Top
See Also

Reference

Autodesk.Revit.DB Namespace