CADLinkOptions Class

CADLinkType Class

CADLinkType represents both CAD links and CAD imports. The function IsLink can be used to distinguish between the two. CAD imports are not ExternalFileReferences; they are brought completely into the document and maintain no connection to their original file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBCADLinkType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CADLinkType : ElementType
Public Class CADLinkType
    Inherits ElementType
public ref class CADLinkType : public ElementType
type CADLinkType =
    class
        inherit ElementType
    end

The CADLinkType type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | LoadFrom(ExternalResourceReference) | Loads or reloads the DWG link from the given external resource reference.
Public method | LoadFrom(String) | Loads or reloads the DWG link from the given file path.
Public method | Reload | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | Reload(CADLinkOptions) | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Top
See Also

Reference

Autodesk.Revit.DB Namespace