SpatialElementDomainData Class

SpatialElementFromToCalculationPoints Class

SpatialElementFromToCalculationPoints is used to specify the search points for a family instance which connects two rooms or spaces, such as a door or window. The points determine which room or space is considered the "from" and which is considered the "to".
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElementCalculationLocation
Autodesk.Revit.DBSpatialElementFromToCalculationPoints

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementFromToCalculationPoints : SpatialElementCalculationLocation
Public Class SpatialElementFromToCalculationPoints
    Inherits SpatialElementCalculationLocation
public ref class SpatialElementFromToCalculationPoints : public SpatialElementCalculationLocation
type SpatialElementFromToCalculationPoints =
    class
        inherit SpatialElementCalculationLocation
    end

The SpatialElementFromToCalculationPoints type exposes the following members.

Properties
 | Name | Description
Public property | FromPosition | The "from" position of spatial element connecting calculation point.
Public property | ToPosition | The "to" position of spatial element connecting calculation point.
Top
Methods
 | Name | Description
Public method | Flip | flip the direction of the "from" and "to" points
Public method | IsAcceptableFromPosition | Checks whether a given "from" position is valid.
Public method | IsAcceptableToPosition | Checks whether a given "to" position is valid.
Public method | MakeFromPositionAcceptable | This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.
Public method | MakeToPositionAcceptable | This function takes a potential "to" point and converts it to be a similar point on the opposite side of the family's host from the "from" point if necessary.
Top
See Also

Reference

Autodesk.Revit.DB Namespace