DWGImportOptions Class

DXFExportOptions Class

The export options used by exporting DXF format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseExportOptions
Autodesk.Revit.DBACADExportOptions
Autodesk.Revit.DBDXFExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DXFExportOptions : ACADExportOptions
Public Class DXFExportOptions
    Inherits ACADExportOptions
public ref class DXFExportOptions : public ACADExportOptions
type DXFExportOptions =
    class
        inherit ACADExportOptions
    end

The DXFExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DXFExportOptions | Constructs a new instance of DXFImportOptions with default values of all properties.
Public method | DXFExportOptions(DXFExportOptions) | Constructs a new instance of DXFImportOptions as a copy of the export options.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
 | GetPredefinedOptions | Returns an instance DXFExportOptions containing settings from a predefined export setup.
Top
See Also

Reference

Autodesk.Revit.DB Namespace