FormulaManager Class

FormUtils Class

Define Form utility functions
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFormUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FormUtils
Public NotInheritable Class FormUtils
public ref class FormUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FormUtils = class end

The FormUtils type exposes the following members.

Methods
Name | Description
CanBeDissolved | Validates that input contains one or more form elements or geom combinations containing form elements.
DissolveForms(Document, ICollectionElementId) | Dissolves a collection of form elements into their defining elements.
DissolveForms(Document, ICollectionElementId, ICollectionElementId) | Dissolves a collection of form elements into their defining elements.
Top
See Also

Reference

Autodesk.Revit.DB Namespace