Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.CreationApplication
Autodesk.Revit.CreationItemFactoryBase
Autodesk.Revit.DBBinding
Autodesk.Revit.DBBoundingBoxXYZ
Autodesk.Revit.DBCategory
Autodesk.Revit.DBCategoryNameMap
Autodesk.Revit.DBCategoryNameMapIterator
Autodesk.Revit.DBCategorySet
Autodesk.Revit.DBCategorySetIterator
Autodesk.Revit.DBCity
Autodesk.Revit.DBCitySet
Autodesk.Revit.DBCitySetIterator
Autodesk.Revit.DBColor
Autodesk.Revit.DBCombinableElementArray
Autodesk.Revit.DBCombinableElementArrayIterator
Autodesk.Revit.DBConnectorSet
Autodesk.Revit.DBConnectorSetIterator
Autodesk.Revit.DBCurtainCell
Autodesk.Revit.DBCurtainGrid
Autodesk.Revit.DBCurtainGridSet
Autodesk.Revit.DBCurtainGridSetIterator
Autodesk.Revit.DBCurveArrArray
Autodesk.Revit.DBCurveArrArrayIterator
Autodesk.Revit.DBCurveArray
Autodesk.Revit.DBCurveArrayIterator
Autodesk.Revit.DBCurveByPointsArray
Autodesk.Revit.DBCurveByPointsArrayIterator
Autodesk.Revit.DBDefinitionBindingMap
Autodesk.Revit.DBDefinitionBindingMapIterator
Autodesk.Revit.DBDefinitionFile
Autodesk.Revit.DBDefinitionGroup
Autodesk.Revit.DBDetailCurveArray
Autodesk.Revit.DBDetailCurveArrayIterator
Autodesk.Revit.DBDimensionSegment
Autodesk.Revit.DBDimensionSegmentArray
Autodesk.Revit.DBDimensionSegmentArrayIterator
Autodesk.Revit.DBDocumentSet
Autodesk.Revit.DBDocumentSetIterator
Autodesk.Revit.DBDoubleArray
Autodesk.Revit.DBDoubleArrayIterator
Autodesk.Revit.DBEdgeArray
Autodesk.Revit.DBEdgeArrayArray
Autodesk.Revit.DBEdgeArrayArrayIterator
Autodesk.Revit.DBEdgeArrayIterator
Autodesk.Revit.DB.ElectricalCorrectionFactor
Autodesk.Revit.DB.ElectricalCorrectionFactorSet
Autodesk.Revit.DB.ElectricalCorrectionFactorSetIterator
Autodesk.Revit.DB.ElectricalDistributionSysTypeSet
Autodesk.Revit.DB.ElectricalDistributionSysTypeSetIterator
Autodesk.Revit.DB.ElectricalGroundConductorSize
Autodesk.Revit.DB.ElectricalGroundConductorSizeSet
Autodesk.Revit.DB.ElectricalGroundConductorSizeSetIterator
Autodesk.Revit.DB.ElectricalInsulationTypeSet
Autodesk.Revit.DB.ElectricalInsulationTypeSetIterator
Autodesk.Revit.DB.ElectricalTemperatureRatingTypeSet
Autodesk.Revit.DB.ElectricalTemperatureRatingTypeSetIterator
Autodesk.Revit.DB.ElectricalVoltageTypeSet
Autodesk.Revit.DB.ElectricalVoltageTypeSetIterator
Autodesk.Revit.DB.ElectricalWireConduitType
Autodesk.Revit.DB.ElectricalWireConduitTypeSet
Autodesk.Revit.DB.ElectricalWireConduitTypeSetIterator
Autodesk.Revit.DB.ElectricalWireMaterialTypeSet
Autodesk.Revit.DB.ElectricalWireMaterialTypeSetIterator
Autodesk.Revit.DB.ElectricalWireSet
Autodesk.Revit.DB.ElectricalWireSetIterator
Autodesk.Revit.DB.ElectricalWireSize
Autodesk.Revit.DB.ElectricalWireSizeSet
Autodesk.Revit.DB.ElectricalWireSizeSetIterator
Autodesk.Revit.DB.ElectricalWireTypeSet
Autodesk.Revit.DB.ElectricalWireTypeSetIterator
Autodesk.Revit.DBElementArray
Autodesk.Revit.DBElementArrayIterator
Autodesk.Revit.DBElementSet
Autodesk.Revit.DBElementSetIterator
Autodesk.Revit.DBFaceArray
Autodesk.Revit.DBFaceArrayIterator
Autodesk.Revit.DBFamilyElementVisibility
Autodesk.Revit.DBFamilyManager
Autodesk.Revit.DBFamilyParameter
Autodesk.Revit.DBFamilyParameterSet
Autodesk.Revit.DBFamilyParameterSetIterator
Autodesk.Revit.DBFamilyPointLocation
Autodesk.Revit.DBFamilyPointPlacementReference
Autodesk.Revit.DBFamilyType
Autodesk.Revit.DBFamilyTypeSet
Autodesk.Revit.DBFamilyTypeSetIterator
Autodesk.Revit.DBFormArray
Autodesk.Revit.DBFormArrayIterator
Autodesk.Revit.DBGeomCombinationSet
Autodesk.Revit.DBGeomCombinationSetIterator
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBGroupSet
Autodesk.Revit.DBGroupSetIterator
Autodesk.Revit.DBIntersectionResult
Autodesk.Revit.DBIntersectionResultArray
Autodesk.Revit.DBIntersectionResultArrayIterator
Autodesk.Revit.DBLayoutRule
Autodesk.Revit.DBLeader
Autodesk.Revit.DBLeaderArray
Autodesk.Revit.DBLeaderArrayIterator
Autodesk.Revit.DBLocation
Autodesk.Revit.DB.MechanicalMEPBuildingConstructionSet
Autodesk.Revit.DB.MechanicalMEPBuildingConstructionSetIterator
Autodesk.Revit.DB.MechanicalSpaceSet
Autodesk.Revit.DB.MechanicalSpaceSetIterator
Autodesk.Revit.DBMEPModel
Autodesk.Revit.DBModelCurveArrArray
Autodesk.Revit.DBModelCurveArrArrayIterator
Autodesk.Revit.DBModelCurveArray
Autodesk.Revit.DBModelCurveArrayIterator
Autodesk.Revit.DBMullionTypeSet
Autodesk.Revit.DBMullionTypeSetIterator
Autodesk.Revit.DBOptions
Autodesk.Revit.DBPanelTypeSet
Autodesk.Revit.DBPanelTypeSetIterator
Autodesk.Revit.DBPaperSize
Autodesk.Revit.DBPaperSizeSet
Autodesk.Revit.DBPaperSizeSetIterator
Autodesk.Revit.DBPaperSource
Autodesk.Revit.DBPaperSourceSet
Autodesk.Revit.DBPaperSourceSetIterator
Autodesk.Revit.DBParameter
Autodesk.Revit.DBParameterMap
Autodesk.Revit.DBParameterMapIterator
Autodesk.Revit.DBParameterSet
Autodesk.Revit.DBParameterSetIterator
Autodesk.Revit.DBPhaseArray
Autodesk.Revit.DBPhaseArrayIterator
Autodesk.Revit.DBPlanCircuit
Autodesk.Revit.DBPlanCircuitSet
Autodesk.Revit.DBPlanCircuitSetIterator
Autodesk.Revit.DBPlanTopology
Autodesk.Revit.DBPlanTopologySet
Autodesk.Revit.DBPlanTopologySetIterator
Autodesk.Revit.DBPrintManager
Autodesk.Revit.DBPrintParameters
Autodesk.Revit.DBPrintSetup
Autodesk.Revit.DBProjectLocationSet
Autodesk.Revit.DBProjectLocationSetIterator
Autodesk.Revit.DBReference
Autodesk.Revit.DBReferenceArray
Autodesk.Revit.DBReferenceArrayArray
Autodesk.Revit.DBReferenceArrayArrayIterator
Autodesk.Revit.DBReferenceArrayIterator
Autodesk.Revit.DBReferencePointArray
Autodesk.Revit.DBReferencePointArrayIterator
Autodesk.Revit.DBSettings
Autodesk.Revit.DBSlabShapeCreaseArray
Autodesk.Revit.DBSlabShapeCreaseArrayIterator
Autodesk.Revit.DBSlabShapeVertexArray
Autodesk.Revit.DBSlabShapeVertexArrayIterator
Autodesk.Revit.DBSpacingRule
Autodesk.Revit.DB.SteelSteelElementProperties
Autodesk.Revit.DBSweepProfile
Autodesk.Revit.DBSymbolicCurveArray
Autodesk.Revit.DBSymbolicCurveArrayIterator
Autodesk.Revit.DBTemporaryViewModes
Autodesk.Revit.DBThermalProperties
Autodesk.Revit.DBTilePatterns
Autodesk.Revit.DBTransform
Autodesk.Revit.DBVertexIndexPairArray
Autodesk.Revit.DBVertexIndexPairArrayIterator
Autodesk.Revit.DBViewSet
Autodesk.Revit.DBViewSetIterator
Autodesk.Revit.DBViewSheetSetting
Autodesk.Revit.DB.VisualAssetSet
Autodesk.Revit.DB.VisualAssetSetIterator
Autodesk.Revit.UI.EventsDialogBoxData
Autodesk.Revit.UIExternalApplicationArray
Autodesk.Revit.UIExternalApplicationArrayIterator
Autodesk.Revit.UIExternalCommandData
Autodesk.Revit.UITaskDialog

APIObject Properties

The APIObject type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable.
Top
See Also

Reference