ElementWorksetFilter Class

ElevationMarker Class

ElevationMarkers either host elevation ViewSection views or view references.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElevationMarker

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElevationMarker : Element
Public Class ElevationMarker
    Inherits Element
public ref class ElevationMarker : public Element
type ElevationMarker =
    class
        inherit Element
    end

The ElevationMarker type exposes the following members.

Properties
 | Name | Description
Public property | CurrentViewCount | The current number of views hosted by this ElevationMarker.
Public property | IsReference | Indicates if this is a reference ElevationMarker. Only reference elevations can be hosted by reference ElevationMarkers.
Public property | MaximumViewCount | The maximum number of views that can be hosted by this ElevationMarker.
Top
Methods
 | Name | Description
Public method | CreateElevation | Creates a new elevation ViewSection on the ElevationMarker at the desired index.
 | CreateElevationMarker | Creates a new ElevationMarker.
Public method | CreateReferenceElevation | Creates a reference elevation on the ElevationMarker at the desired index.
 | CreateReferenceElevationMarker | Creates a new ElevationMarker.
Public method | GetViewId | Returns the ViewSection id for the index of the ElevationMarker.
Public method | HasElevations | Returns true if the ElevationMarker has at least one elevation view, false otherwise.
Public method | IsAvailableIndex | Returns true if a new elevation ViewSection can be placed at %index%, returns false otherwise.
Top
Remarks
ElevationMarkers store the ViewFamilyType which will be used by all elevations hosted on the ElevationMarker. The orientation of an ElevationMarker is determined by the orientation of the views it hosts. You can check the orientation of any view by getting View.ViewDirection. To reorient the ElevationMarker and all of the views it hosts, call ElementTransformUtils.RotateElement with the ElevationMarker as an argument.
See Also

Reference

Autodesk.Revit.DB Namespace