DimensionType Class

DirectShape Class

This class is used to store externally created geometric shapes. Primary intended use is for importing shapes from other data formats such as IFC or STEP. A DirectShape object may be assigned a category. That will affect how that object is displayed in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDirectShape

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectShape : Element
Public Class DirectShape
    Inherits Element
public ref class DirectShape : public Element
type DirectShape =
    class
        inherit Element
    end

The DirectShape type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationDataId | A text string that identifies the data to the creating application.
Public property | ApplicationId | A text string that identifies the creating application.
Public property | TypeId | Element id of a DirectShapeType object that holds properties to be shared by this element. Optional.
Top
Methods
Name | Description
Public method | AddExternallyTaggedGeometry | Adds the externally tagged geometry object to the DirectShape.
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShape.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShape.
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShape.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShape.
Public method | AppendShape(IListGeometryObject) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IListGeometryObject, DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeOptions are allowed for this particular DirectShape.
Public method | AreOptionsValidForTransientDirectShape | Validates that the given DirectShapeOptions are allowed if this DirectShape is transient.
Public method | AreValidDirectShapeReferenceOptions | Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShape.
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShape element.
CreateElement | Creates a DirectShape object and adds it to document.
CreateElementInstance | Creates a DirectShape object and adds it to document.
CreateGeometryInstance | Creates a copy of a definition shape that was created earlier.
Public method | GetExternallyTaggedGeometry | Gets the externally tagged geometry by its external ID that is stored in this DirectShape.
Public method | GetExternallyTaggedReference | Retrieve a Reference to reference geometry of the DirectShape that is associated with a particular ExternalGeometryId.
Public method | GetOptions | Gets a copy of the current options for this DirectShape.
Public method | HasExternalGeometry | Checks whether the externally tagged geometry is already present in this DirectShape.
Public method | HasExternallyTaggedReference | Checks if the externally tagged reference is already present in this DirectShape.
IsSupportedDocument | Tests whether a DirectShape or a DirectShapeType may be created in this document.
IsValidCategoryId | Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.
Public method | IsValidGeometry | Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry must make sense as a shape representation for the category assigned to this DirectShape object.
IsValidReferenceCurve | Validates that the input curve is suitable for creating a direct shape reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
IsValidReferencePlaneBoundingBoxUV | Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShape.
Public method | IsValidShape(IListGeometryObject) | Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().
Public method | IsValidShape(IListGeometryObject, DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShape. Expects a non-default view type.
Public method IsValidTypeId Tests the type id to make sure it satisfies the following conditions
  • It is a valid element id.
  • It corresponds to a valid DirectShapeType.
  • The DirectShapeType has the same category assigned.
Additionally, this functions tests that the current type id in this DirectShape is invalid. The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.
Public method | IsValidUsage | Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShape.
Public method | RemoveAllReferenceObjects | Removes all reference objects (if any) from the DirectShape.
Public method | RemoveExternallyTaggedGeometry | Removes the externally tagged geometry object by its external ID from this DirectShape.
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShape. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShape. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method | ResetExternallyTaggedGeometry | Removes all of the externally tagged geometry in this DirectShape.
Public method | SetName | Sets the name for the DirectShape element.
Public method | SetOptions | Sets the options to use for this DirectShape.
Public method | SetShape(IListGeometryObject) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(IListGeometryObject, DirectShapeTargetViewType) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetTypeId | Sets the DirectShapeType for the DirectShape element.
Public method | UpdateExternallyTaggedGeometry | Updates the externally tagged geometry object in the DirectShape.
Top
Remarks
DirectShape is not a replacement for "real" Wall, Roof, Window, etc. It would typically be used where there is not enough information to create, e.g., a Wall, or full functionality of a Wall object is not needed. Some category-specific functionality may be available. If you need to modify a shape held by a DirectShape object, use Revit Geometry API, and then store the modified shape back to the DirectShape object.
Example
C#
VB
C++
F#
Copy
// Create a DirectShape Sphere
public void CreateSphereDirectShape(Document doc)
{
    List<Curve> profile = new List<Curve>();

    // first create sphere with 2' radius
    XYZ center = XYZ.Zero;
    double radius = 2.0;
    XYZ profile00 = center;
    XYZ profilePlus = center + new XYZ(0, radius, 0);
    XYZ profileMinus = center - new XYZ(0, radius, 0);

    profile.Add(Line.CreateBound(profilePlus, profileMinus));
    profile.Add(Arc.Create(profileMinus, profilePlus, center + new XYZ(radius, 0, 0)));

    CurveLoop curveLoop = CurveLoop.Create(profile);
    SolidOptions options = new SolidOptions(ElementId.InvalidElementId, ElementId.InvalidElementId);

    Frame frame = new Frame(center, XYZ.BasisX, -XYZ.BasisZ, XYZ.BasisY);
    if (Frame.CanDefineRevitGeometry(frame) == true)
    {
        Solid sphere = GeometryCreationUtilities.CreateRevolvedGeometry(frame, new CurveLoop[] { curveLoop }, 0, 2 * Math.PI, options);
        using (Transaction t = new Transaction(doc, "Create sphere direct shape"))
        {
            t.Start();
            // create direct shape and assign the sphere shape
            DirectShape ds = DirectShape.CreateElement(doc, new ElementId(BuiltInCategory.OST_GenericModel));

            ds.ApplicationId = "Application id";
            ds.ApplicationDataId = "Geometry object id";
            ds.SetShape(new GeometryObject[] { sphere });
            t.Commit();
        }
    }
}
' Create a DirectShape Sphere
Public Sub CreateSphereDirectShape(doc As Document)
    Dim profile As New List(Of Curve)()

    ' first create sphere with 2' radius
    Dim center As XYZ = XYZ.Zero
    Dim radius As Double = 2.0
    Dim profile00 As XYZ = center
    Dim profilePlus As XYZ = center + New XYZ(0, radius, 0)
    Dim profileMinus As XYZ = center - New XYZ(0, radius, 0)

    profile.Add(Line.CreateBound(profilePlus, profileMinus))
    profile.Add(Arc.Create(profileMinus, profilePlus, center + New XYZ(radius, 0, 0)))

    Dim curveLoop__1 As CurveLoop = CurveLoop.Create(profile)
    Dim options As New SolidOptions(ElementId.InvalidElementId, ElementId.InvalidElementId)

    Dim frame__2 As New Frame(center, XYZ.BasisX, -XYZ.BasisZ, XYZ.BasisY)
    If Frame.CanDefineRevitGeometry(frame__2) = True Then
        Dim sphere As Solid = GeometryCreationUtilities.CreateRevolvedGeometry(frame__2, New CurveLoop() {curveLoop__1}, 0, 2 * Math.PI, options)
        Using t As New Transaction(doc, "Create sphere direct shape")
            t.Start()
            ' create direct shape and assign the sphere shape
            Dim ds As DirectShape = DirectShape.CreateElement(doc, New ElementId(BuiltInCategory.OST_GenericModel))

            ds.ApplicationId = "Application id"
            ds.ApplicationDataId = "Geometry object id"
            ds.SetShape(New GeometryObject() {sphere})
            t.Commit()
        End Using
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace