ParameterUtils Class
IsBuiltInParameter Overload

ParameterValue Class

A class that holds a value of a parameter element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterValue
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterValue : IDisposable
Public Class ParameterValue
    Implements IDisposable
public ref class ParameterValue : IDisposable
type ParameterValue =
    class
        interface IDisposable
    end

The ParameterValue type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value.
Public method | Dispose | Releases all resources used by the ParameterValue
Public method | IsEqual | Tests equality with another instance of the same class.
Public method | IsSameType | Tests another instance is of the same value type.
Top
Remarks
This is a non-instantiable base class. Classes that actually store a value of a certain type are all derived from this base class, once class per each value type.
See Also

Reference

Autodesk.Revit.DB Namespace