SlabShapeFailures Properties

The BuiltInFailuresSlabShapeFailures type exposes the following members.

Properties
Name | Description
SlabShapeEditFailed | Slab Shape Edit failed. [Description]
SlabShapeEditFailedError | Slab Shape Edit failed. [Description]
SlabShapeFailedNotHorz | The Floor or Roof or Toposolid is no longer horizontal.
SlabShapeFailedNotOnlyLines | The Floor or Roof or Toposolid may only contain straight lines.
SlabShapeFailedTooThin | The Floor or Roof or Toposolid is too thin for its given type.
SlabShapeWarnVerticesCoincident | Some slab shape edit vertices were too close to each other or too close to an edge.
SlabShapeWarnVerticesDeleted | Some slab shape edit vertices were deleted because the Floor or Roof or Toposolid has changed its shape.
SlopedInnerEdge | Inner loops of a footprint sketch may not have slope-defining lines.
SlopeTailInsideSlopeLine | The tails of slope arrows must not lie in interior of slope defining lines.
SlopeZero | Adjusting this Line's Overhang will not affect its height because its slope is zero.
Top
See Also

Reference