HostObjAttributes Class

HostObject Class

A base class that provides support for all objects that can host other objects, such as walls roofs, and floors.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HostObject : Element
Public Class HostObject
    Inherits Element
public ref class HostObject : public Element
type HostObject =
    class
        inherit Element
    end

The HostObject type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | FindInserts | Gets the ids of the instances inserted into this host object.
Top
See Also

Reference

Autodesk.Revit.DB Namespace