MEPAnalyticalModelData Methods

The MEPAnalyticalModelData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
 | GetMEPAnalyticalModelData | Gets the MEP analytical model data of the specified element.
Public method | GetNodeById | Gets the analytical node with the specified id.
Public method | GetNodeByIndex | Gets the specified analytical node.
Public method | GetNumberOfNodes | Returns the number of analytical nodes.
Public method | GetNumberOfSegments | Returns the number of analytical segments.
Public method | GetSegmentById | Gets the analytical segment with the specified id.
Public method | GetSegmentByIndex | Gets the analytical segment at the specified position.
Public method | GetSegmentData | Gets the analysis data on the specified segment.
Public method | IsValidNodeId | Verifies if a valid analytical node id.
Public method | IsValidSegmentId | Verifies if a valid segment id.
Top
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace