ExportFontInfo Class

ExportFontKey Class

A key used to represent an item stored in an ExportFontTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportFontKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportFontKey : IDisposable
Public Class ExportFontKey
    Implements IDisposable
public ref class ExportFontKey : IDisposable
type ExportFontKey =
    class
        interface IDisposable
    end

The ExportFontKey type exposes the following members.

Constructors
 | Name | Description
Public method | ExportFontKey | Constructs a new default ExportFontKey.
Public method | ExportFontKey(ExportFontKey) | Constructs a new copy of the input ExportFontKey object.
Public method | ExportFontKey(String) | Constructs a new ExportFontKey using an input font name.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalFontName | The original font name.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportFontKey
Top
See Also

Reference

Autodesk.Revit.DB Namespace