LayoutRuleMaximumSpacing Class

Leader Class

A leader object that can be attached to annotation elements such as text notes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLeader

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Leader : APIObject
Public Class Leader
    Inherits APIObject
public ref class Leader : public APIObject
type Leader =
    class
        inherit APIObject
    end

The Leader type exposes the following members.

Properties
 | Name | Description
Public property | Anchor | Anchor point of the Leader
Public property | Elbow | Elbow point of the Leader.
Public property | End | End point of the Leader.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeaderShape | Geometric style of the leader
Top
Methods
 | Name | Description
Top
Remarks
For information on how to attach or get leaders to/from a text annotation refer to corresponding methods of TextNote class.
See Also

Reference

Autodesk.Revit.DB Namespace