DetailCurveArrayIterator Class

DetailElementOrderUtils Class

A utility class that arranges the draw order of the detail elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDetailElementOrderUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DetailElementOrderUtils
Public NotInheritable Class DetailElementOrderUtils
public ref class DetailElementOrderUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DetailElementOrderUtils = class end

The DetailElementOrderUtils type exposes the following members.

Methods
Name | Description
AreDetailElements | Indicates if the elements are all detail elements that participate in detail draw ordering in the view.
BringForward(Document, View, ElementId) | Moves the given detail instance one step closer to the front of all other detail instances in the view.
BringForward(Document, View, ICollectionElementId) | Moves the given detail instances one step closer to the front of all other detail instances in the view, while keeping the order of the given ones.
BringToFront(Document, View, ElementId) | Places the given detail instance in the front of all other detail instances in the view.
BringToFront(Document, View, ICollectionElementId) | Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.
GetDrawOrderForDetails | Returns the given detail elements according to the currently specified draw order for the detail elements in a given view.
IsDetailElement | Indicates if the element is a detail element that participates in detail draw ordering in the view.
SendBackward(Document, View, ElementId) | Moves the given detail instance one step closer to the back of all other detail instances in the view.
SendBackward(Document, View, ICollectionElementId) | Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.
SendToBack(Document, View, ElementId) | Places the given detail instance behind all detail instances in the view.
SendToBack(Document, View, ICollectionElementId) | Places the given detail instances behind all other detail instances in the view, while keeping the order of the given ones.
Top
See Also

Reference

Autodesk.Revit.DB Namespace