BaseExportOptions Class

BaseImportOptions Class

A base class containing import options used during import of several formats.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseImportOptions : IDisposable
Public Class BaseImportOptions
    Implements IDisposable
public ref class BaseImportOptions : IDisposable
type BaseImportOptions =
    class
        interface IDisposable
    end

The BaseImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
Public property | Unit | The unit of measure for imported geometry.
Public property | VisibleLayersOnly | Only import the visible layers.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BaseImportOptions
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files.
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit.
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files.
Public method | SetLayerSelection | Set the layers name which user want to import into Revit.
Top
See Also

Reference

Autodesk.Revit.DB Namespace