SpatialElementGeometryCalculator Class

SpatialElementGeometryResults Class

The results of spatial element geometry calculation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpatialElementGeometryResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementGeometryResults : IDisposable
Public Class SpatialElementGeometryResults
    Implements IDisposable
public ref class SpatialElementGeometryResults : IDisposable
type SpatialElementGeometryResults =
    class
        interface IDisposable
    end

The SpatialElementGeometryResults type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementGeometryResults
Public method | GetBoundaryFaceInfo | Query the spatial element boundary face information with the given face.
Public method | GetGeometry | The solid from the spatial element.
Top
Remarks
The subfaces of a SpatialElement at the base height and top height are not associated with floors, roofs, and ceilings at the same height.
See Also

Reference

Autodesk.Revit.DB Namespace