Revision Class

Represents a single revision in the project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBRevision

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Revision : Element
Public Class Revision
    Inherits Element
public ref class Revision : public Element
type Revision =
    class
        inherit Element
    end

The Revision type exposes the following members.

Properties
 | Name | Description
Public property | Description | The description of this Revision.
Public property | Issued | Indicates whether this Revision has been issued.
Public property | IssuedBy | Indicates who has issued or will issue this Revision.
Public property | IssuedTo | Indicates to whom this Revision was or will be issued.
Public property | RevisionDate | The date of this Revision.
Public property | RevisionNumber | The Revision number of this revision.
Public property | RevisionNumberingSequenceId | The id of the revision numbering sequence which controls this revision's numbering.
Public property | SequenceNumber | The Sequence Number of this Revision.
Public property | Visibility | Controls the visibility of revision clouds and revision tags related to this Revision.
Top
Methods
 | Name | Description
 | CombineWithNext | Combines the specified Revision with the next Revision.
 | CombineWithPrevious | Combines the specified Revision with the previous Revision.
 | Create | Creates a new Revision in the project.
 | GetAllRevisionIds | Returns the ids of all Revisions in the project ordered by sequence number.
 | ReorderRevisionSequence | Reorders the sequence of Revisions in the project.
Top
Remarks
The Revision object represents the data related to a single revision in the project. Revision clouds and tags can be associated with a particular Revision object to display its properties on sheets.

The revisions in the project are stored in a specific order called the revision sequence. The revision sequence represents the conceptual sequence in which revisions will be issued.

See Also

Reference

Autodesk.Revit.DB Namespace