ReferenceArrayArrayIterator Class

ReferenceArrayIterator Class

An iterator to a reference array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBReferenceArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ReferenceArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class ReferenceArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ReferenceArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ReferenceArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ReferenceArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ReferenceArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Top
Methods
 | Name | Description
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Top
See Also

Reference

Autodesk.Revit.DB Namespace