IFCCategoryTemplate Class

IFCCategoryTemplate Methods

The IFCCategoryTemplate type exposes the following members.

Methods
 | Name | Description
Public method | CopyTemplate | Create copy of mapping template with new name.
 | Create | Create a IFC category mapping template with default values.
Public method | ExportToFile | Export mapping template to a text file.
 | FindByName | Returns mapping template element by name.
 | GetActiveTemplate | Gets the active mapping template element in the document.
Public method | GetCategoryMappingTable | Gets the table that contains a mapping from Revit categories to IFC entities.
Public method | GetMappingInfoById | Gets a copy of ifc mapping info by category id.
 | GetOrCreateInSessionTemplate | Gets the in-session non-serializable template or create new.
 | ImportFromFile | Import mapping template from a text file.
 | IsValidName | Returns result that the proposed name is valid and not exist in the specified document.
 | ListNames | Returns a list of names of ifc export mapping templates.
 | ResetActiveTemplate | Sets the mapping template element to be the active mapping template in the document.
Public method | ResetCategoryToDefault | Reset one category, sub-category, or special category in the current mapping table to the default values defined in Revit
Public method | SetActiveTemplate | Sets the mapping template element to be the active mapping template in the document.
Public method | SetMappingInfo(IDictionaryExportIFCCategoryKey, ExportIFCCategoryInfo) | Set the mapping info for multiple keys.
Public method | SetMappingInfo(ExportIFCCategoryKey, ExportIFCCategoryInfo) | Set the mapping info for the key.
Public method | UpdateCategoryList | Updates the mapping table with the categories from the document.
Top
See Also

Reference