CurveArrayIterator Class

CurveByPoints Class

A curve interpolating two or more points.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBCurveByPoints

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveByPoints : CurveElement
Public Class CurveByPoints
    Inherits CurveElement
public ref class CurveByPoints : public CurveElement
type CurveByPoints =
    class
        inherit CurveElement
    end

The CurveByPoints type exposes the following members.

Properties
 | Name | Description
Public property | IsReferenceLine |
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElementSketchPlane)
Public property | Subcategory | The subcategory, or graphics style, of the CurveByPoints.
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Top
Methods
 | Name | Description
Public method | GetPoints | Get the sequence of points interpolated by this curve.
Public method | GetVisibility | Gets the visibility.
Public method | SetPoints | Change the sequence of points interpolated by this curve.
Public method | SetVisibility | Sets the visibility.
 | SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
Top
Remarks
The points to be interpolated are represented as ReferencePoints, which must already exist in the document. In terms of appearance and graphics control, CurveByPoints behaves similarly to ModelCurve. The main difference being that a ModelCurve refers to a SketchPlane, while a CurveByPoints does not. For more methods capable of accessing data from CurveByPoints elements, see the static class CurveByPointsUtils.
See Also

Reference

Autodesk.Revit.DB Namespace