KeyBasedTreeEntries Class

A collection of KeyBasedTreeEntry objects that make up the key-based tree.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntries
Autodesk.Revit.DBClassificationEntries
Autodesk.Revit.DBKeynoteEntries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntries : IEnumerable<KeyBasedTreeEntry>,
    IDisposable
Public Class KeyBasedTreeEntries
    Implements IEnumerable(Of KeyBasedTreeEntry), IDisposable
public ref class KeyBasedTreeEntries : IEnumerable<KeyBasedTreeEntry^>,
    IDisposable
type KeyBasedTreeEntries =
    class
        interface IEnumerable<KeyBasedTreeEntry>
        interface IDisposable
    end

The KeyBasedTreeEntries type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntries
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection.
Top
See Also

Reference

Autodesk.Revit.DB Namespace