EnergyAnalysisWindowType Class

The EnergyAnalysisWindowType class contains the thermal properties (e.g., heat transfer coefficient) of the window-type analytical openings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisWindowType

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisWindowType : Element
Public Class EnergyAnalysisWindowType
    Inherits Element
public ref class EnergyAnalysisWindowType : public Element
type EnergyAnalysisWindowType =
    class
        inherit Element
    end

The EnergyAnalysisWindowType type exposes the following members.

Properties
 | Name | Description
Public property | Description | The description of the window type.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-value) of the window type, in W/(m^2*K) (equivalent to kg/(k*s^3)).
Public property | IsSchematic | Indicates if this originates from a schematic or analytical construction.
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient (SHGC-value) for the window type, from 0.0 to 1.0.
Public property | Transmittance | The visual light transmittance value (VLT-value) for the window type, from 0.0 to 1.0.
Public property | WindowTypeName | The name of the window type.
Top
Methods
 | Name | Description
Public method | GetSolarHeatGainCoefficientsForSolarIndicientAngles | Returns a map with solar heat gain coefficients (SHGC-values) for specific incident angles for the window type.
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace