Toposolid Class

ToposolidType Class

An object that specifies the type of a Toposolid in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBToposolidType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToposolidType : HostObjAttributes
Public Class ToposolidType
    Inherits HostObjAttributes
public ref class ToposolidType : public HostObjAttributes
type ToposolidType =
    class
        inherit HostObjAttributes
    end

The ToposolidType type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetContourSetting | Get the contour setting object from the current toposolid type.
Public method | SetContourSettting | Set the contour setting for the current toposolid type by copying from an existing contour setting object.
Top
See Also

Reference

Autodesk.Revit.DB Namespace