AssemblyDifferenceNone Class

AssemblyInstance Class

Combines multiple elements for tagging, filtering, scheduling and creating isolated assembly views.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBAssemblyInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyInstance : Element
Public Class AssemblyInstance
    Inherits Element
public ref class AssemblyInstance : public Element
type AssemblyInstance =
    class
        inherit Element
    end

The AssemblyInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyTypeName | The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.
Public property | Location | This property is used to find the physical location of the assembly instance within project. (Overrides ElementLocation)
Public property | NamingCategoryId | Id of the category that drives the default naming scheme for the assembly instance.
Top
Methods
 | Name | Description
Public method | AddMemberIds | Adds member element ids for the assembly instance.
Public method | AllowsAssemblyViewCreation | Returns true if assembly views can be created for this Assembly Instance.
 | AreElementsValidForAssembly | Identifies if provided assembly members are valid.
 | CanRemoveElementsFromAssembly | Identifies if provided assembly members can be removed from the assembly instance.
 | CompareAssemblyInstances | Compares two assembly instances and returns a result with details about the differences
 | Create | Creates a new assembly instance.
Public method | Disassemble | Removes the assembly instance and releases the member elements.
Public method | GetCenter | Returns the center of the bounding box for the assembly instance. This is the default position for placed assembly instances.
Public method | GetMemberIds | Gets member element ids for the assembly instance.
Public method | GetTransform | Gets the origin of the assembly instance.
Public method | IsMember | Determines whether the given ElementId is a member of this assembly
 | IsValidNamingCategory | Identifies if the naming category is valid for an assembly instance.
 | PlaceInstance | Places an assembly instance of a given assembly type at the specified location.
Public method | RemoveMemberIds | Removes member element ids from the assembly instance.
Public method | SetMemberIds | Sets member element ids for the assembly instance. All existing members are cleared.
Public method | SetTransform | Sets the origin of the assembly instance.
Top
Example
C#
VB
C++
F#
Copy
// Create assembly instance, name the assembly, and create views of the assembly
AssemblyInstance CreateAssemblyAndViews(Autodesk.Revit.DB.Document doc, ICollection<ElementId> elementIds)
{
    AssemblyInstance assemblyInstance = null;
    using (Transaction transaction = new Transaction(doc))
    {
        ElementId categoryId = doc.GetElement(elementIds.First()).Category.Id; // use category of one of the assembly elements
        if (AssemblyInstance.IsValidNamingCategory(doc, categoryId, elementIds))
        {
            transaction.Start("Create Assembly Instance");
            assemblyInstance = AssemblyInstance.Create(doc, elementIds, categoryId);
            transaction.Commit(); // commit the transaction that creates the assembly instance before modifying the instance's name

            if (transaction.GetStatus() == TransactionStatus.Committed)
            {
                transaction.Start("Set Assembly Name");
                assemblyInstance.AssemblyTypeName = "My Assembly Name";
                transaction.Commit();
            }

            if (assemblyInstance.AllowsAssemblyViewCreation()) // create assembly views for this assembly instance
            {
                if (transaction.GetStatus() == TransactionStatus.Committed)
                {
                    transaction.Start("View Creation");
                    View3D view3d = AssemblyViewUtils.Create3DOrthographic(doc, assemblyInstance.Id);
                    ViewSchedule partList = AssemblyViewUtils.CreatePartList(doc, assemblyInstance.Id);
                    transaction.Commit();
                }
            }
        }
    }

    return assemblyInstance;
}
' Create assembly instance, name the assembly, and create views of the assembly
Private Function CreateAssemblyAndViews(doc As Autodesk.Revit.DB.Document, elementIds As ICollection(Of ElementId)) As AssemblyInstance
    Dim assemblyInstance__1 As AssemblyInstance = Nothing
    Using transaction As New Transaction(doc)
        Dim categoryId As ElementId = doc.GetElement(elementIds.First()).Category.Id
        ' use category of one of the assembly elements
        If AssemblyInstance.IsValidNamingCategory(doc, categoryId, elementIds) Then
            transaction.Start("Create Assembly Instance")
            assemblyInstance__1 = AssemblyInstance.Create(doc, elementIds, categoryId)
            transaction.Commit()
            ' commit the transaction that creates the assembly instance before modifying the instance's name
            If transaction.GetStatus() = TransactionStatus.Committed Then
                transaction.Start("Set Assembly Name")
                assemblyInstance__1.AssemblyTypeName = "My Assembly Name"
                transaction.Commit()
            End If

            If assemblyInstance__1.AllowsAssemblyViewCreation() Then
                ' create assembly views for this assembly instance
                If transaction.GetStatus() = TransactionStatus.Committed Then
                    transaction.Start("View Creation")
                    Dim view3d As View3D = AssemblyViewUtils.Create3DOrthographic(doc, assemblyInstance__1.Id)
                    Dim partList As ViewSchedule = AssemblyViewUtils.CreatePartList(doc, assemblyInstance__1.Id)
                    transaction.Commit()
                End If
            End If
        End If
    End Using

    Return assemblyInstance__1
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace