Document Class

Document.Export Method

DocumentExport Method

Overload List
 | Name | Description
Public method | Export(String, IListElementId, PDFExportOptions) | Exports a selection of views in PDF format.
Public method | Export(String, String, GBXMLExportOptions) | Export the model in gbXML (green-building) format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, NavisworksExportOptions) | Exports a Revit project to the Navisworks .nwc format.
Public method | Export(String, String, OBJExportOptions) | Exports a view specified in the export options to the OBJ format.
Public method | Export(String, String, STEPExportOptions) | Exports the current view or a selection of views in STEP format.
Public method | Export(String, String, STLExportOptions) | Exports a view specified in the export options to the STL format.
 | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
 | Export(String, String, ICollectionElementId, DGNExportOptions) | Exports a selection of views in DGN format.
 | Export(String, String, ICollectionElementId, DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollectionElementId, DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, ICollectionElementId, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Top
See Also

Reference