Segment Class

This element represents a segment of an MEP curve object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSegment
Autodesk.Revit.DB.PlumbingPipeSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Segment : Element
Public Class Segment
    Inherits Element
public ref class Segment : public Element
type Segment =
    class
        inherit Element
    end

The Segment type exposes the following members.

Properties
 | Name | Description
Public property | Description | The description of the segment.
Public property | MaterialId | The ElementId of the MaterialElem.
Public property | Roughness | The roughness value for given material.
Public property | SizeCount | The number of size objects in the segment.
Top
Methods
 | Name | Description
Public method | AddSize | Adds a new MEPSize to the segment.
Public method | GetSizes | Gets the defined sizes of the segment.
Public method | RemoveSize | Remove the existing MEPSize with this nominal diameter from the segment.
Top
Remarks
Currently, only pipe curves can be broken into separate segment elements.
Example
C#
VB
C++
F#
Copy
private void GetPipeSegmentSizesFromDocument(Document document)
{
    FilteredElementCollector collectorPipeType = new FilteredElementCollector(document);
    collectorPipeType.OfClass(typeof(Segment));

    IEnumerable<Segment> segments = collectorPipeType.ToElements().Cast<Segment>();
    foreach (Segment segment in segments)
    {
        StringBuilder strPipeInfo = new StringBuilder();
        strPipeInfo.AppendLine("Segment: " + segment.Name);

        strPipeInfo.AppendLine("Roughness: " + segment.Roughness);

        strPipeInfo.AppendLine("Pipe Sizes:");
        double dLengthFac = 304.8;  // used to convert stored units from ft to mm for display
        foreach (MEPSize size in segment.GetSizes())
        {
            strPipeInfo.AppendLine(string.Format("Nominal: {0:F3}, ID: {1:F3}, OD: {2:F3}",
                                        size.NominalDiameter * dLengthFac, size.InnerDiameter * dLengthFac, size.OuterDiameter * dLengthFac));
        }

        Autodesk.Revit.UI.TaskDialog.Show("PipeSetting Data", strPipeInfo.ToString());
        break;
    }
}
Private Sub GetPipeSegmentSizesFromDocument(document As Document)
   Dim collectorPipeType As New FilteredElementCollector(document)
   collectorPipeType.OfClass(GetType(Segment))

   Dim segments As IEnumerable(Of Segment) = collectorPipeType.ToElements().Cast(Of Segment)()
   For Each segment As Segment In segments
      Dim strPipeInfo As New StringBuilder()
      strPipeInfo.AppendLine("Segment: " + segment.Name)

      strPipeInfo.AppendLine("Roughness: " + segment.Roughness)

      strPipeInfo.AppendLine("Pipe Sizes:")
      Dim dLengthFac As Double = 304.8
      ' used to convert stored units from ft to mm for display
      For Each size As MEPSize In segment.GetSizes()
         strPipeInfo.AppendLine(String.Format("Nominal: {0:F3}, ID: {1:F3}, OD: {2:F3}", size.NominalDiameter * dLengthFac, size.InnerDiameter * dLengthFac, size.OuterDiameter * dLengthFac))
      Next

      Autodesk.Revit.UI.TaskDialog.Show("PipeSetting Data", strPipeInfo.ToString())
      Exit For
   Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace