SolidSolidCutUtils Class

SolidUtils Class

Contains utility functions for solid operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSolidUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SolidUtils
Public NotInheritable Class SolidUtils
public ref class SolidUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SolidUtils = class end

The SolidUtils type exposes the following members.

Methods
Name | Description
Clone | Creates a new Solid which is a copy of the input Solid.
CreateTransformed | Creates a new Solid which is the transformation of the input Solid.
FindAllEdgeEndPointsAtVertex | Find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.
IsValidForTessellation | Tests if the input solid or shell is valid for tessellation.
SplitVolumes | Splits a solid geometry into several separate solids.
TessellateSolidOrShell | This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.
Top
See Also

Reference

Autodesk.Revit.DB Namespace