ElementArrayIterator Class

ElementBinding Class

A base class for all types of binding that attach to an element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBBinding
Autodesk.Revit.DBElementBinding
Autodesk.Revit.DBInstanceBinding
Autodesk.Revit.DBTypeBinding

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ElementBinding : Binding
Public MustInherit Class ElementBinding
    Inherits Binding
public ref class ElementBinding abstract : public Binding
[<AbstractClassAttribute>]
type ElementBinding =
    class
        inherit Binding
    end

The ElementBinding type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound.
Top
Methods
 | Name | Description
Top
Remarks
This base class provides methods that are common to all types of binding that work with elements.
See Also

Reference

Autodesk.Revit.DB Namespace