ElementOwnerViewFilter Class

ElementParameterFilter Class

A filter used to match elements by one or more parameter filter rules.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementParameterFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementParameterFilter : ElementSlowFilter
Public Class ElementParameterFilter
    Inherits ElementSlowFilter
public ref class ElementParameterFilter : public ElementSlowFilter
type ElementParameterFilter =
    class
        inherit ElementSlowFilter
    end

The ElementParameterFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementParameterFilter(FilterRule) | Constructs a new instance of an ElementParameterFilter from a single rule.
Public method | ElementParameterFilter(IListFilterRule) | Constructs a new instance of an ElementParameterFilter from a set of rules.
Public method | ElementParameterFilter(FilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public method | ElementParameterFilter(IListFilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetRules | Returns the set of rules contained in this filter.
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
Example
C#
VB
C++
F#
Copy
// Creates an ElementParameter filter to find rooms whose area is
// greater than specified value
// Create filter by provider and evaluator
// provider
ParameterValueProvider pvp = new ParameterValueProvider(new ElementId(BuiltInParameter.ROOM_AREA));
// evaluator
FilterNumericRuleEvaluator fnrv = new FilterNumericGreater();
// rule value
double ruleValue = 100.0f; // filter room whose area is greater than 100 SF
// rule
FilterRule fRule = new FilterDoubleRule(pvp, fnrv, ruleValue, 1E-6);

// Create an ElementParameter filter
ElementParameterFilter filter = new ElementParameterFilter(fRule);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> rooms = collector.WherePasses(filter).ToElements();

// Find rooms whose area is less than or equal to 100:
// Use inverted filter to match elements
ElementParameterFilter lessOrEqualFilter = new ElementParameterFilter(fRule, true);
collector = new FilteredElementCollector(document);
IList<Element> lessOrEqualFounds = collector.WherePasses(lessOrEqualFilter).ToElements();
' Creates an ElementParameter filter to find rooms whose area is
' greater than specified value
' Create filter by provider and evaluator
' provider
Dim pvp As New ParameterValueProvider(New ElementId(BuiltInParameter.ROOM_AREA))
' evaluator
Dim fnrv As FilterNumericRuleEvaluator = New FilterNumericGreater()
' rule value
Dim ruleValue As Double = 100.0F
' filter room whose area is greater than 100 SF
' rule
Dim fRule As FilterRule = New FilterDoubleRule(pvp, fnrv, ruleValue, 0.000001)

' Create an ElementParameter filter
Dim filter As New ElementParameterFilter(fRule)

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim rooms As IList(Of Element) = collector.WherePasses(filter).ToElements()

' Find rooms whose area is less than or equal to 100:
' Use inverted filter to match elements
Dim lessOrEqualFilter As New ElementParameterFilter(fRule, True)
collector = New FilteredElementCollector(document)
Dim lessOrEqualFounds As IList(Of Element) = collector.WherePasses(lessOrEqualFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace