BindingMap Class

Blend Class

A blend solid or void form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBBlend

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Blend : GenericForm
Public Class Blend
    Inherits GenericForm
public ref class Blend : public GenericForm
type Blend =
    class
        inherit GenericForm
    end

The Blend type exposes the following members.

Properties
 | Name | Description
Public property | BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomSketch | Returns the Bottom Sketch of the Blend.
Public property | TopOffset | The offset of the top end of the blend relative to the sketch plane.
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopSketch | Returns the Top Sketch of the Blend.
Top
Methods
 | Name | Description
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Top
See Also

Reference

Autodesk.Revit.DB Namespace