MEPFamilyConnectorInfo Class

MEPModel Class

Supports all MEP models that are persistent within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBMEPModel
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPModel : APIObject
Public Class MEPModel
    Inherits APIObject
public ref class MEPModel : public APIObject
type MEPModel =
    class
        inherit APIObject
    end

The MEPModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | GetAssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to.
Public method | GetElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
Top
See Also

Reference

Autodesk.Revit.DB Namespace