IFailuresProcessor Interface

IFamilyLoadOptions Interface

An interface class which provide the callback for family load options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFamilyLoadOptions
Public Interface IFamilyLoadOptions
public interface class IFamilyLoadOptions
type IFamilyLoadOptions = interface end

The IFamilyLoadOptions type exposes the following members.

Methods
 | Name | Description
Public method | OnFamilyFound | A method called when the family was found in the target document.
Public method | OnSharedFamilyFound | A method called when the shared family was found in the target document.
Top
Remarks

If the family is not loaded, or if the family is loaded but unchanged, the situation will never trigger and OnFamilyFound(Boolean, Boolean) and OnSharedFamilyFound(Family, Boolean, FamilySource, Boolean) will not be called. Only if the family is loaded and changed should the interface methods be called.

See Also

Reference

Autodesk.Revit.DB Namespace