CurtainGridSetIterator Class

CurtainSystem Class

Provides access to the CurtainSystem object in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCurtainSystemBase
Autodesk.Revit.DBCurtainSystem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurtainSystem : CurtainSystemBase
Public Class CurtainSystem
    Inherits CurtainSystemBase
public ref class CurtainSystem : public CurtainSystemBase
type CurtainSystem =
    class
        inherit CurtainSystemBase
    end

The CurtainSystem type exposes the following members.

Properties
 | Name | Description
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.
Top
Methods
 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
Top
Remarks
The user can create CurtainSystem object and change the internal properties.
See Also

Reference

Autodesk.Revit.DB Namespace