ArcLengthDimension Class

Area Class

Provides access to the area topology in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElement
Autodesk.Revit.DBArea

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Area : SpatialElement
Public Class Area
    Inherits SpatialElement
public ref class Area : public SpatialElement
type Area =
    class
        inherit SpatialElement
    end

The Area type exposes the following members.

Properties
 | Name | Description
Public property | AreaScheme | The area scheme.
Public property | IsGrossInterior | The boolean value that indicates whether the area is gross interior.
Top
Methods
 | Name | Description
Top
Remarks
The area object can be queried for its boundary for use in space planning tools.
See Also

Reference

Autodesk.Revit.DB Namespace