KeyBasedTreeEntryTable Class

KeyBasedTreeEntryTable represents the collection of key-based tree entries for a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBKeyBasedTreeEntryTable
Autodesk.Revit.DBAssemblyCodeTable
Autodesk.Revit.DBKeynoteTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntryTable : Element
Public Class KeyBasedTreeEntryTable
    Inherits Element
public ref class KeyBasedTreeEntryTable : public Element
type KeyBasedTreeEntryTable =
    class
        inherit Element
    end

The KeyBasedTreeEntryTable type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table.
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable.
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable.
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable.
Top
See Also

Reference

Autodesk.Revit.DB Namespace