SiteLocation Class

Contains the geographical location information for the project's site.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBSiteLocation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SiteLocation : ElementType
Public Class SiteLocation
    Inherits ElementType
public ref class SiteLocation : public ElementType
type SiteLocation =
    class
        inherit ElementType
    end

The SiteLocation type exposes the following members.

Properties
 | Name | Description
Public property | Elevation | The elevation of the site location.
Public property | GeoCoordinateSystemDefinition | The XML string which describes the geographic coordinate system.
Public property | GeoCoordinateSystemId | The geographic coordinate system ID, such as "AMG-50" and "Beijing1954/a.GK3d-40".
Public property | Latitude | The latitude of the site location.
Public property | Longitude | The longitude of the site location.
Public property | PlaceName | The place name of the site.
Public property | TimeZone | The time-zone for the site.
Public property | WeatherStationName | The name of the weather station at the site location.
Top
Methods
 | Name | Description
Public method | ConvertFromProjectTime | Converts project time to UTC time.
Public method | ConvertToProjectTime | Converts local time or UTC time to project time.
Public method | IsCompatibleWith | Checks whether the geographic coordinate system of this site is compatible with the given site . True if he geographic coordinate system of this site is compatible with the given site, false otherwise.
Public method | SetGeoCoordinateSystem | Set the geographic coordinate system for this site. Similar to acquire coordinate system from a link in the UI.
Top
Remarks
Each project may have one site which dictates where in the world the project is based. On this site there may be several locations of the same project. These are represented by ProjectLocation objects. The site location object can be found by using the SiteLocation property on the Document object. The properties of this object can be changed such that it represents any location on the planet or to a known city. Cities already programmed into Revit can be found from the Cities property on the Application object.
Example
C#
VB
C++
F#
Copy
// Get the SiteLocation instance.
Autodesk.Revit.DB.SiteLocation site = document.SiteLocation;

// Angles are in radians when coming from Revit API, so we
// convert to degrees for display
const double angleRatio = Math.PI / 180;   // angle conversion factor

// Format the prompt information.
String prompt = "Current project's Site location information:";
prompt += "\n\t" + "Latitude: " + site.Latitude / angleRatio + " degrees";
prompt += "\n\t" + "Longitude: " + site.Longitude / angleRatio + " degrees";
// Give the user some information.
TaskDialog.Show("Revit",prompt);

// Change the SiteLocation property data.
site.Latitude = 0.5;    // latitude information
site.Longitude = 0.5;   // longitude information
site.TimeZone = -5;     // TimeZone information
' Get the SiteLocation instance.
Dim site As Autodesk.Revit.DB.SiteLocation = document.SiteLocation

' Angles are in radians when coming from Revit API, so we
' convert to degrees for display
Const  angleRatio As Double = Math.PI / 180
' angle conversion factor
' Format the prompt information.
Dim prompt As [String] = "Current project's Site location information:"
prompt += vbLf & vbTab & "Latitude: " & site.Latitude / angleRatio & "°"
prompt += vbLf & vbTab & "Longitude: " & site.Longitude / angleRatio & "°"
prompt += (vbLf & vbTab & "TimeZone: ") + site.TimeZone

' Give the user some information.
TaskDialog.Show("Revit", prompt)

' Change the SiteLocation property data.
site.Latitude = 0.5
' latitude information
site.Longitude = 0.5
' longitude information
site.TimeZone = -5
' TimeZone information

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace