DWFXExportOptions Class

DWGExportOptions Class

The export options used by exporting DWG format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseExportOptions
Autodesk.Revit.DBACADExportOptions
Autodesk.Revit.DBDWGExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DWGExportOptions : ACADExportOptions
Public Class DWGExportOptions
    Inherits ACADExportOptions
public ref class DWGExportOptions : public ACADExportOptions
type DWGExportOptions =
    class
        inherit ACADExportOptions
    end

The DWGExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DWGExportOptions | Constructs a new instance of DWGExportOptions with default values of all properties.
Public method | DWGExportOptions(DWGExportOptions) | Constructs a new instance of DWGExportOptions as a copy of the export options.
Top
Properties
 | Name | Description
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.
Top
Methods
 | Name | Description
 | GetPredefinedOptions | Returns an instance DWGExportOptions containing settings from a predefined export setup.
Top
See Also

Reference

Autodesk.Revit.DB Namespace