PartUtils Class
GetSplittingCurves Overload

PartUtils.GetSplittingElements Method

PartUtilsGetSplittingElements Method

Identifies the elements ( reference planes, levels, grids ) that were used to create the part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> GetSplittingElements(
    Document document,
    ElementId partId
)
Public Shared Function GetSplittingElements (
    document As Document,
    partId As ElementId
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ GetSplittingElements(
    Document^ document,
    ElementId^ partId
)
static member GetSplittingElements :
        document : Document *
        partId : ElementId -> ISet<ElementId>

Parameters

document Document
The source document of the part.
partId ElementId
The part id.

Return Value

ISet ElementId
The elements that created the part. Empty if partId is not a Part or Part is not divided.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
public void GetElementDividers(Part part)
{
   StringBuilder message = new StringBuilder();

   // Get Element dividers.
   ISet<ElementId> divisionElements = PartUtils.GetSplittingElements(part.Document, part.Id);

   if (divisionElements.Count == 0)
      message.AppendLine("Part is not divided.");
   else
   {
      message.AppendLine("The dividers are : ");
      foreach (var reference in divisionElements)
      {
         Element element = part.Document.GetElement(reference);
         message.AppendLine(element.GetType().Name + " " + element.Id.ToString() + " ");
      }
   }

   TaskDialog.Show("Revit", message.ToString());
}
Private Sub GetElementDividers(ByVal part As Part)
    Dim message As StringBuilder = New StringBuilder
    ' Get Element dividers.
    Dim divisionElements As ISet(Of ElementId) = PartUtils.GetSplittingElements(part.Document, part.Id)
    If (divisionElements.Count = 0) Then
        message.AppendLine("Part is not divided.")
    Else
        message.AppendLine("The dividers are : ")
        For Each reference In divisionElements
            Dim element As Element = part.Document.GetElement(reference)
            message.AppendLine(element.GetType.Name + " " + element.Id.ToString)
        Next
    End If

    TaskDialog.Show("Revit", message.ToString)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference