LineAndTextAttrSymbol Class

LinearArray Class

An object that represents an Array created linearly within the Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBBaseArray
Autodesk.Revit.DBLinearArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinearArray : BaseArray
Public Class LinearArray
    Inherits BaseArray
public ref class LinearArray : public BaseArray
type LinearArray =
    class
        inherit BaseArray
    end

The LinearArray type exposes the following members.

Properties
 | Name | Description
Public property | NumMembers | Retrieves or changes the number of arrayed members. Array placeholder members in the family environment are not counted. (Overrides BaseArrayNumMembers)
Top
Methods
 | Name | Description
 | ArrayElementsWithoutAssociation | Creates a new linear array from a set of elements.
 | ArrayElementWithoutAssociation | Creates a new linear array from a single element.
 | Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a single element.
 | Create(Document, View, ICollectionElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a set of elements.
Public method | GetCopiedMemberIds | Retrieves the copied member ids from the array. The first item in an array contains the original elements from which the array was created. All other items in the array are copies. (Overrides BaseArrayGetCopiedMemberIds)
 | GetMinimumSize | Returns the minimum size for a linear array based on the document.
Public method | GetNumberOfMembersIncludingPlaceholders | Returns the number of items in an array, including placeholder items in families.
Public method | GetOriginalMemberIds | Retrieves the ids for the original elements from which the array was created. These elements form the first item in the array. (Overrides BaseArrayGetOriginalMemberIds)
 | IsElementArrayable | Indicates whether the input element is arrayable.
 | IsValidArraySize | Obsolete. This indicates whether the input count is valid in the project environment.
 | IsValidNumberOfMembers | This indicates whether the input count is a valid size for an array based on the document.
Top
See Also

Reference

Autodesk.Revit.DB Namespace