CurveExtents Class

Represents the start and end parameters for a curve segment.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCurveExtents

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveExtents : IDisposable
Public Class CurveExtents
    Implements IDisposable
public ref class CurveExtents : IDisposable
type CurveExtents =
    class
        interface IDisposable
    end

The CurveExtents type exposes the following members.

Properties
 | Name | Description
Public property | EndParameter | The end parameter of the curve extents.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartParameter | The start parameter of the curve extents.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CurveExtents
Top
See Also

Reference

Autodesk.Revit.DB Namespace