IViewSheetSet Interface

JoinGeometryUtils Class

Utilities for joining and unjoining elements, and for managing the order in which elements are joined.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBJoinGeometryUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class JoinGeometryUtils
Public NotInheritable Class JoinGeometryUtils
public ref class JoinGeometryUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JoinGeometryUtils = class end

The JoinGeometryUtils type exposes the following members.

Methods
Name | Description
AreElementsJoined | Determines whether two elements are joined.
GetJoinedElements | Returns all elements joined to given element.
IsCuttingElementInJoin | Determines whether the first of two joined elements is cutting the second element.
JoinGeometry | Creates clean joins between two elements that share a common face.
SwitchJoinOrder | Reverses the order in which two elements are joined.
UnjoinGeometry | Removes a join between two elements.
Top
See Also

Reference

Autodesk.Revit.DB Namespace