Floor Class

An object that represents a Floor within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCeilingAndFloor
Autodesk.Revit.DBFloor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Floor : CeilingAndFloor
Public Class Floor
    Inherits CeilingAndFloor
public ref class Floor : public CeilingAndFloor
type Floor =
    class
        inherit CeilingAndFloor
    end

The Floor type exposes the following members.

Properties
 | Name | Description
Public property | FloorType | Retrieves/sets an object that represents the type of the floor.
Public property | SketchId | Returns id of the sketch.
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor.
Top
Methods
 | Name | Description
 | Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of architectural floor within the project.
 | Create(Document, IListCurveLoop, ElementId, ElementId, Boolean, Line, Double) | Creates a new instance of floor within the project.
 | GetDefaultFloorType | Returns id of default floor type.
Public method | GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Floor.
Public method | GetSpanDirectionSymbolIds | Retrieves span direction symbol ElementIds.
Public method | GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.
Top
Remarks
This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.
Example
C#
VB
C++
F#
Copy
public void ShowFloorInfo(Floor floor)
{
    string message = "Floor : ";
    // Get Floor type name
    message += "\nFloor type name is : " + floor.FloorType.Name;
    try
    {
        // Get Floor span direction angle
        message += "\nFloor span direction angle is : " + floor.SpanDirectionAngle;
    }
    catch (Exception)
    {
        // an exception is thrown if floor is non-structural
        message += "\nFloor is non-structural.";
    }

    TaskDialog.Show("Revit",message);

}
Public Sub ShowFloorInfo(floor As Floor)
 Dim message As String = "Floor : "
 ' Get Floor type name
 message += vbLf & "Floor type name is : " & Convert.ToString(floor.FloorType.Name)
    Try
        ' Get Floor span direction angle
        message += vbLf & "Floor span direction angle is : " & Convert.ToString(floor.SpanDirectionAngle)
    Catch generatedExceptionName As Exception
        ' an exception is thrown if floor is non-structural
        message += vbLf & "Floor is non-structural."
    End Try

    TaskDialog.Show("Revit", message)

End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace