PointElementReference Class

PointLocationOnCurve Class

Defines the measurement parameters necessary to create a point at a specific location on a curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointLocationOnCurve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointLocationOnCurve : IDisposable
Public Class PointLocationOnCurve
    Implements IDisposable
public ref class PointLocationOnCurve : IDisposable
type PointLocationOnCurve =
    class
        interface IDisposable
    end

The PointLocationOnCurve type exposes the following members.

Constructors
 | Name | Description
Public method | PointLocationOnCurve | Constructs a new instance of a class, with given or default values, to place a point on a curve.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MeasureFrom | The location on the curve from which the measurement is taken.
Public property | MeasurementType | The measurement type.
Public property | MeasurementValue | The measurement value.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PointLocationOnCurve
Top
Remarks
The class will store the following and provides functions to deal with them:
  • The user visible Measurement Type (driving parameter type).
  • The corresponding measurement value (driving parameter).
  • MeasureFrom that tells from where the (driving parameter) measurement is calculated.
See Also

Reference

Autodesk.Revit.DB Namespace