IFCExportOptions Class

IFCVersion Enumeration

An enumerated type listing available IFC file versions into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum IFCVersion
Public Enumeration IFCVersion
public enum class IFCVersion
type IFCVersion
Members
Member name | Value | Description
Default | 0 | The Autodesk Revit application's default export format. Note that this may change as the defaults change in the Revit user interface.
IFCBCA | 8 | IFC BCA file format. This is a certified variant of IFC 2x2 used for submitting files to the Singapore BCA ePlan Check Server.
IFC2x2 | 9 | IFC 2x2 file format.
IFC2x3 | 10 | IFC 2x3 file format.
IFCCOBIE | 17 | IFC GSA COBIE 2010 file format. This is a variant of IFC 2x3 used for submitting files that are COBIE 2010-complaint.
IFC2x3CV2 | 21 | IFC 2x3 Coordination View 2.0 file format. This is a variant of IFC 2x3 used for exporting files using the Coordination View 2.0 model view.
IFC4 | 23 | IFC 4 file format.
IFC2x3FM | 24 | IFC2x3 Extended FM Handover View
IFC4RV | 25 | IFC4 Reference View
IFC4DTV | 26 | IFC4 Design Transfer View
IFC2x3BFM | 27 | IFC2x3 Basic FM Handover View
IFC4x3 | 29 | IFC4x3 file format
IFCSG | 30 | IFC-SG MVD based on IFC4
See Also

Reference

Autodesk.Revit.DB Namespace