PolyLine Class

PolylineNode Class

An output node that represents a 3D polyline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBModelCurveNode
Autodesk.Revit.DBPolylineNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolylineNode : ModelCurveNode
Public Class PolylineNode
    Inherits ModelCurveNode
public ref class PolylineNode : public ModelCurveNode
type PolylineNode =
    class
        inherit ModelCurveNode
    end

The PolylineNode type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetPolyline | Returns the polyline object corresponding to the node.
Top
Remarks
See also: OnPolyline(PolylineNode).
See Also

Reference

Autodesk.Revit.DB Namespace