BuiltInFailuresInterferenceFailures Class

BuiltInFailures.JoinElementsFailures Class

BuiltInFailuresJoinElementsFailures Class

Failures about JoinElements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresJoinElementsFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class JoinElementsFailures
Public NotInheritable Class JoinElementsFailures
public ref class JoinElementsFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JoinElementsFailures = class end

The BuiltInFailuresJoinElementsFailures type exposes the following members.

Properties
Name | Description
CannotCope | Can't apply Coping.
CannotCutJoinedGeometry | Element could not be cut by joined element.
CannotJoinDesignOptions | An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
CannotJoinElements | Can't keep elements joined.
CannotJoinElementsError | Can't keep elements joined.
CannotJoinElementsMultiPlaneError | Can't keep elements joined.
CannotJoinElementsStructural | Can't keep elements joined.
CannotJoinElementsStructuralError | Can't keep elements joined.
CannotJoinElementsWarn | Can't keep elements joined.
CannotJoinRoof | The roof cannot be joined.
CannotJoinRoofError | The roof cannot be joined.
CannotKeepJoined | Can't keep elements joined.
CannotKeepReferenceOfJoinedElement | Can't keep reference of joined element.
CannotKeepReferenceOfJoinedElementWarning | Can't keep reference of joined element.
CannotKeepTrussJoined | Can't keep the highlighted [Element]s joined.
CannotKeepWallJoinToRoof | Can't keep wall and [target] joined
CannotKeepWallJoinToRoofError | Can't keep wall and [target] joined
ElementWillBeDetachedFromPlane | Element will be detached from its associated plane
FootingWillMoveToBottom | An attached Structural Foundation will be moved to the bottom of the Column.
JoiningDisjoint | Highlighted elements are joined but do not intersect.
JoiningDisjointWarn | Highlighted elements are joined but do not intersect.
StairsComponentTypeUnsupportedError | The selected stair type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.
StructGroupMemberWillDetachFromGrid | A structural element will be detached from grid(s) due to inconsistent group membership.
WallTypeUnsupportedError | The selected wall type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.
Top
See Also

Reference

Autodesk.Revit.DB Namespace