GBXMLImportOptions Class

GenericForm Class

Provides access to the Generic Form model in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GenericForm : CombinableElement
Public Class GenericForm
    Inherits CombinableElement
public ref class GenericForm : public CombinableElement
type GenericForm =
    class
        inherit CombinableElement
    end

The GenericForm type exposes the following members.

Properties
 | Name | Description
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | Name | Get and Set the Name property (Overrides ElementName)
Public property | Subcategory | The subcategory.
Public property | Visible | The visibility of the GenericForm.
Top
Methods
 | Name | Description
Public method | GetVisibility | Gets the visibility for the generic form.
Public method | SetVisibility | Sets the visibility for the generic form.
Top
Remarks
The Generic Form object can be queried for a generic form for use in family modeling and massing. It is the base class of Sweep, Blend, Extrusion, Revolution.
See Also

Reference

Autodesk.Revit.DB Namespace