EnergyAnalysisOpening Methods

The EnergyAnalysisOpening type exposes the following members.

Methods
 | Name | Description
Public method | GetAnalyticalSurface | Gets the associative analytical parent surface element.
Public method | GetConstruction | Gets the analytic construction this surface is associated with. Null when this surface is a window.
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.
Public method | GetPolyloops | Gets the collection of planar polygons describing the opening geometry.
Public method | GetWindowType | Gets the analytic window type this surface is associated with. Null when this surface is not a window.
Top
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace