FilterNumericRuleEvaluator Class
Evaluate Overload

FilterNumericValueRule Class

Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterDoubleRule
Autodesk.Revit.DBFilterElementIdRule
Autodesk.Revit.DBFilterGlobalParameterAssociationRule
Autodesk.Revit.DBFilterIntegerRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterNumericValueRule : FilterValueRule
Public Class FilterNumericValueRule
    Inherits FilterValueRule
public ref class FilterNumericValueRule : public FilterValueRule
type FilterNumericValueRule =
    class
        inherit FilterValueRule
    end

The FilterNumericValueRule type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Top
See Also

Reference

Autodesk.Revit.DB Namespace