SweepProfile Class

SweptBlend Class

A swept blend solid or void form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBSweptBlend

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SweptBlend : GenericForm
Public Class SweptBlend
    Inherits GenericForm
public ref class SweptBlend : public GenericForm
type SweptBlend =
    class
        inherit GenericForm
    end

The SweptBlend type exposes the following members.

Properties
 | Name | Description
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomProfileSymbol | The bottom family symbol profile of the swept blend.
Public property | BottomSketch | The bottom profile sketch of the swept blend.
Public property | PathSketch | The sketched path for the swept blend.
Public property | SelectedPath | The selected curve used for the swept blend path.
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopProfileSymbol | The top family symbol profile of the swept blend.
Public property | TopSketch | The top profile sketch of the swept blend.
Top
Methods
 | Name | Description
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Top
See Also

Reference

Autodesk.Revit.DB Namespace