LinkNode Class

LinkOperations Class

This class is used to extend the IExternalResourceServer interface with methods to support operations for elements that are LinkTypes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLinkOperations
Autodesk.Revit.DBCADLinkOperations
Autodesk.Revit.DBRevitLinkOperations

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinkOperations : IDisposable
Public Class LinkOperations
    Implements IDisposable
public ref class LinkOperations : IDisposable
type LinkOperations =
    class
        interface IDisposable
    end

The LinkOperations type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LinkOperations
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer.
Top
See Also

Reference

Autodesk.Revit.DB Namespace