WorksetDefaultVisibilitySettings Class

WorksetFilter Class

A base class for a type of filter that accepts or rejects worksets based upon criteria.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksetFilter
Autodesk.Revit.DBWorksetKindFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksetFilter : IDisposable
Public Class WorksetFilter
    Implements IDisposable
public ref class WorksetFilter : IDisposable
type WorksetFilter =
    class
        interface IDisposable
    end

The WorksetFilter type exposes the following members.

Properties
 | Name | Description
Public property | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected.
Public property | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorksetFilter
Top
See Also

Reference

Autodesk.Revit.DB Namespace