ViewShapeBuilder Class

ViewSheet Class

Class for ViewSheet
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBViewSheet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSheet : View
Public Class ViewSheet
    Inherits View
public ref class ViewSheet : public View
type ViewSheet =
    class
        inherit View
    end

The ViewSheet type exposes the following members.

Properties
 | Name | Description
Public property | IsPlaceholder | Identifies whether or not the view sheet represents a placeholder sheet.
Public property | SheetCollectionId | The ID of the sheet collection this sheet is associated with.
Public property | SheetNumber | The sheet number of the document.
Top
Methods
 | Name | Description
Public method | CanBeDuplicated | Identifies if this sheet can be duplicated.
Public method | ConvertToRealSheet | Converts a placeholder sheet to a real one with an optional titleblock.
 | Create | Creates a new ViewSheet.
 | CreatePlaceholder | Creates a placeholder sheet in a document.
Public method | DeleteViewport | Removes a viewport from the sheet by deleting it from the document.
Public method | Duplicate(SheetDuplicateOption) | Duplicates this sheet to generate a new one.
Public method | GetAdditionalRevisionIds | Gets the Revisions that are additionally included in the sheet's revision schedules.
Public method | GetAllPlacedViews | Returns the ElementIds of Views placed on this sheet.
Public method | GetAllRevisionCloudIds | Gets the ids of the revision clouds which appear on the sheet's revision schedules.
Public method | GetAllRevisionIds | Gets the ordered array of Revisions which participate in the sheet's revision schedules.
Public method | GetAllViewports | Returns the ElementIds of Viewports on this sheet.
Public method | GetCurrentRevision | Returns the most recent numbered Revision shown on this ViewSheet.
Public method | GetRevisionCloudNumberOnSheet | Gets the Revision Number for a RevisionCloud on this sheet.
Public method | GetRevisionNumberOnSheet | Gets the Revision Number for a particular Revision as it will appear on this sheet.
 | SetAdditionalRevisionIds | Sets the Revisions to additionally include in the sheet's revision schedules.
Top
Example
C#
VB
C++
F#
Copy
private void Getinfo_ViewSheet(ViewSheet viewSheet)
{
    string message = "ViewSheet: ";
    //Get the number of the Sheet
    string sheetNumber = viewSheet.SheetNumber;
    message += "\nSheet Number: " + sheetNumber;

    //Exception occurs when set SheetNumber to a number that isn't unique
    string TestSheetNumber = "My sheet";
    viewSheet.SheetNumber = TestSheetNumber;
    message += "\nSheet Number after set: " + sheetNumber;

    ICollection<ElementId> views = viewSheet.GetAllPlacedViews();
    message += "\nNumber of views in the sheet : " + views.Count;

    TaskDialog.Show("Revit",message);
}
Private Sub Getinfo_ViewSheet(viewSheet As ViewSheet)
    Dim message As String = "ViewSheet: "
    'Get the number of the Sheet
    Dim sheetNumber As String = viewSheet.SheetNumber
    message += vbLf & "Sheet Number: " & sheetNumber

    'Exception occurs when set SheetNumber to a number that isn't unique
    Dim TestSheetNumber As String = "My sheet"
    viewSheet.SheetNumber = TestSheetNumber
    message += vbLf & "Sheet Number after set: " & sheetNumber

    Dim views As ICollection(Of ElementId) = viewSheet.GetAllPlacedViews()
    message += vbLf & "Number of views in the sheet : " & views.Count

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace