RenderingSettings Class

RenderNode Class

This is the base class of all render nodes in a model-exporting process.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RenderNode : IDisposable
Public Class RenderNode
    Implements IDisposable
public ref class RenderNode : IDisposable
type RenderNode =
    class
        interface IDisposable
    end

The RenderNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NodeName | A readable name of the output node.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RenderNode
Top
Remarks
A node can be both geometric (such as an element, light, etc.) or non-geometric (e.g. material). Some types of nodes are container modes, which include other render nodes.
See Also

Reference

Autodesk.Revit.DB Namespace