ExportDGNSettings Class

ExportDWGSettings Class

This element contains DWG/DXF export settings which are saved in a Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBExportDWGSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportDWGSettings : Element
Public Class ExportDWGSettings
    Inherits Element
public ref class ExportDWGSettings : public Element
type ExportDWGSettings =
    class
        inherit Element
    end

The ExportDWGSettings type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
 | Create(Document, String) | Create a DWG export settings with default values.
 | Create(Document, String, DWGExportOptions) | Create a DWG export settings with default values.
 | Create(Document, String, DXFExportOptions) | Create a DWG export settings with default values.
 | FindByName | Returns the pre-defined non-in-session exporting settings for DWG in the given document with the specified name.
 | GetActivePredefinedSettings | Returns the active pre-defined non-in-session exporting settings for DWG in the given document.
Public method | GetDWGExportOptions | Gets the options stored in the these settings.
Public method | GetDXFExportOptions | Gets the options stored in the these settings.
 | ListNames | Returns a list of names of dwg/dxf export settings.
Public method | SetDWGExportOptions | Sets the options stored in these settings.
Public method | SetDXFExportOptions | Sets the options stored in these settings.
Top
See Also

Reference

Autodesk.Revit.DB Namespace