FilterStringRuleEvaluator Class

FilterValueRule Class

A rule that filters on a particular value of an element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterStringRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterValueRule : FilterRule
Public Class FilterValueRule
    Inherits FilterRule
public ref class FilterValueRule : public FilterRule
type FilterValueRule =
    class
        inherit FilterRule
    end

The FilterValueRule type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB Namespace