EnergyAnalysisMaterial Class

A description of a material with thermal properties in a composite construction.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisMaterial

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisMaterial : Element
Public Class EnergyAnalysisMaterial
    Inherits Element
public ref class EnergyAnalysisMaterial : public Element
type EnergyAnalysisMaterial =
    class
        inherit Element
    end

The EnergyAnalysisMaterial type exposes the following members.

Properties
 | Name | Description
Public property | Density | The density of the material, in kg/(ft^3).
Public property | Description | The description of the material.
Public property | MaterialName | The name of the material.
Public property | SpecificHeatCapacity | The specific heat capacity of the material, in ft^2/(k*s^2).
Public property | ThermalConductivity | The thermal conductivity of the material, kg*ft/(k*s^3).
Public property | ThermalResistance | The thermal resistance (R-value) of the material, in m^2*K/W (eqivelent to K*s^3/kg).
Public property | Thickness | The thickness of the material, in ft.
Top
Methods
 | Name | Description
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace