CurveByPointsArrayIterator Class

CurveByPointsUtils Class

A static class that contains methods for processing curves driven by points.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCurveByPointsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveByPointsUtils : IDisposable
Public Class CurveByPointsUtils
    Implements IDisposable
public ref class CurveByPointsUtils : IDisposable
type CurveByPointsUtils =
    class
        interface IDisposable
    end

The CurveByPointsUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | AddCurvesToFaceRegion | Adds The CurveElements to one or more FaceRegions.
 | CreateArcThroughPoints | Creates an arc through the given reference points.
 | CreateRectangle | Creates rectangle on face or sketchplane for two given diagonal points.
Public method | Dispose | Releases all resources used by the CurveByPointsUtils
 | GetFaceRegions | Gets the FaceRegions in the existing face.
 | GetHostFace | Gets the host face to which the CurveElement is added.
 | GetProjectionType | Gets the projection type of the CurveElement.
 | GetSketchOnSurface | Gets the relationship between the CurveElement and face.
 | SetProjectionType | Sets the projection type of the CurveElement.
 | SetSketchOnSurface | Sets the relationship between the CurveElement and face.
 | ValidateCurveElementIdArrayForFaceRegions | Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace