ColorOptions Class

ColorWithTransparency Class

Color with transparency
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBColorWithTransparency

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColorWithTransparency : IDisposable
Public Class ColorWithTransparency
    Implements IDisposable
public ref class ColorWithTransparency : IDisposable
type ColorWithTransparency =
    class
        interface IDisposable
    end

The ColorWithTransparency type exposes the following members.

Constructors
 | Name | Description
Public method | ColorWithTransparency | color
Public method | ColorWithTransparency(UInt32, UInt32, UInt32, UInt32) | color
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ColorWithTransparency
Public method | GetBlue | get blue
Public method | GetColor | get color
Public method | GetGreen | get green
Public method | GetRed | get red
Public method | GetTransparency | get transparency
Public method | SetBlue | set blue
Public method | SetColor | set color
Public method | SetGreen | set green
Public method | SetRed | set red
Public method | SetTransparency | set transparency
Top
See Also

Reference

Autodesk.Revit.DB Namespace