ParameterDownloadOptions Class

ParameterElement Class

An Element that stores a user-defined parameter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBParameterElement
Autodesk.Revit.DBGlobalParameter
Autodesk.Revit.DBSharedParameterElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterElement : Element
Public Class ParameterElement
    Inherits Element
public ref class ParameterElement : public Element
type ParameterElement =
    class
        inherit Element
    end

The ParameterElement type exposes the following members.

Properties
 | Name | Description
Top
Methods
 | Name | Description
 | GetDefinition | Get the definition representing this parameter element.
Top
Remarks
Revit supports both built-in and user-defined parameters. Built-in parameters ship with the application, and they are not stored in Revit documents. User-defined parameters are dynamically created, and they are stored in the documents that use them, wrapped in ParameterElement objects. Different subclasses of ParemeterElement represent different kinds of user-defined parameters.
See Also

Reference

Autodesk.Revit.DB Namespace