Definition Class

DefinitionBindingMap Class

A map that contains mappings of parameter definitions to parameter bindings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDefinitionBindingMap
Autodesk.Revit.DBBindingMap

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DefinitionBindingMap : APIObject,
    IEnumerable
Public Class DefinitionBindingMap
    Inherits APIObject
    Implements IEnumerable
public ref class DefinitionBindingMap : public APIObject,
    IEnumerable
type DefinitionBindingMap =
    class
        inherit APIObject
        interface IEnumerable
    end

The DefinitionBindingMap type exposes the following members.

Constructors
 | Name | Description
Public method | DefinitionBindingMap | Initializes a new instance of the DefinitionBindingMap class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | Item |
Public property | Size | Returns the number of bindings that are in the map.
Top
Methods
 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains |
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Top
See Also

Reference

Autodesk.Revit.DB Namespace