ElementIntersectsSolidFilter Class

ElementIsCurveDrivenFilter Class

A filter used to match elements which are curve driven.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementIsCurveDrivenFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementIsCurveDrivenFilter : ElementQuickFilter
Public Class ElementIsCurveDrivenFilter
    Inherits ElementQuickFilter
public ref class ElementIsCurveDrivenFilter : public ElementQuickFilter
type ElementIsCurveDrivenFilter =
    class
        inherit ElementQuickFilter
    end

The ElementIsCurveDrivenFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementIsCurveDrivenFilter | Constructs a new instance of a filter to match only curve driven elements.
Public method | ElementIsCurveDrivenFilter(Boolean) | Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.
Top
Properties
 | Name | Description
Top
Methods
 | Name | Description
Top
Remarks
The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Create an ElementIsCurveDriven filter to find slanted columns(which is curve-driven) in the document,
// The term "curve driven" indicates that the element's Location property is a LocationCurve
ElementIsCurveDrivenFilter filter = new ElementIsCurveDrivenFilter();

// Apply the filter to the elements in the active document,
// Use the ElementIsCurveDrivenFilter on columns to find only slanted columns (vertical columns
// are placed at a single point).
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> slantColumns = collector
    .WherePasses(filter).OfCategory(BuiltInCategory.OST_StructuralColumns).ToElements();

// Find elements of not curve driven: use inverted filter to match elements
ElementIsCurveDrivenFilter notCurveDrivenFilter = new ElementIsCurveDrivenFilter(true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notCurveDrivenFounds = collector.WherePasses(notCurveDrivenFilter).ToElements();
' Create an ElementIsCurveDriven filter to find slanted columns(which is curve-driven) in the document,
' The term "curve driven" indicates that the element's Location property is a LocationCurve
Dim filter As New ElementIsCurveDrivenFilter()

' Apply the filter to the elements in the active document,
' Use the ElementIsCurveDrivenFilter on columns to find only slanted columns (vertical columns
' are placed at a single point).
Dim collector As New FilteredElementCollector(document)
Dim slantColumns As ICollection(Of Element) = collector.WherePasses(filter).OfCategory(BuiltInCategory.OST_StructuralColumns).ToElements()

' Find elements of not curve driven: use inverted filter to match elements
Dim notCurveDrivenFilter As New ElementIsCurveDrivenFilter(True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notCurveDrivenFounds As ICollection(Of Element) = collector.WherePasses(notCurveDrivenFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace