FabricationServiceButton Class

FabricationServiceSettings Class

Represents the settings related to the fabrication services.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFabricationServiceSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationServiceSettings : Element
Public Class FabricationServiceSettings
    Inherits Element
public ref class FabricationServiceSettings : public Element
type FabricationServiceSettings =
    class
        inherit Element
    end

The FabricationServiceSettings type exposes the following members.

Properties
 | Name | Description
 | AirFluidType | A special fluid type for fabrication HVAC services.
Top
Methods
 | Name | Description
 | GetFabricationServiceSettings | Gets the settings element in the document.
Public method | GetFluidTemperature | Gets the fluid temperature of the specified service.
Public method | GetFluidType | Gets the fluid type of the specified service.
Public method | HasValidFluidSetting | Is the service associated with a fluid type and temperature?
Public method | RemoveFluidSetting | Clears the fluid setting of the specified service if found.
Public method | SetFluidTypeAndTemperature | Sets the fluid type and temperature of the specified service.
Top
See Also

Reference

Autodesk.Revit.DB Namespace