ViewSheet Class

ViewSheetSet Class

Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBViewSheetSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSheetSet : Element,
    IViewSheetSet
Public Class ViewSheetSet
    Inherits Element
    Implements IViewSheetSet
public ref class ViewSheetSet : public Element,
    IViewSheetSet
type ViewSheetSet =
    class
        inherit Element
        interface IViewSheetSet
    end

The ViewSheetSet type exposes the following members.

Properties
 | Name | Description
Public property | IsAutomatic | Automatic order or manual order.
Public property | Name | The view sheet set name. (Overrides ElementName)
Public property | OrderedViewList | Ordered views.
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.
Top
Methods
 | Name | Description
Top
Remarks
For the in-session ViewSheetSet, see the class InSessionViewSheetSet. Changes of ViewSheetSet would be effiective after [!:Autodesk::Revit::DB::ViewSheetSetting::Save]
See Also

Reference

Autodesk.Revit.DB Namespace