CompoundStructure Class

CompoundStructure.ParticipatesInWrapping Method

CompoundStructureParticipatesInWrapping Method

Identifies if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ParticipatesInWrapping(
    int layerIdx
)
Public Function ParticipatesInWrapping (
    layerIdx As Integer
) As Boolean
public:
bool ParticipatesInWrapping(
    int layerIdx
)
member ParticipatesInWrapping :
        layerIdx : int -> bool

Parameters

layerIdx Int32
The index of the layer.

Return Value

Boolean
If true, then the layer participates in wrapping at inserts and openings. If false, the layer will not participate in wrapping.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
Remarks
This method applies only to interior and exterior shell layers.
See Also

Reference