ExportLineweightInfo Class

ExportLineweightKey Class

A key used to represent an item stored in an ExportLineweightTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLineweightKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLineweightKey : IDisposable
Public Class ExportLineweightKey
    Implements IDisposable
public ref class ExportLineweightKey : IDisposable
type ExportLineweightKey =
    class
        interface IDisposable
    end

The ExportLineweightKey type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLineweightKey | Constructs a new default ExportLineweightKey.
Public method | ExportLineweightKey(ExportLineweightKey) | Constructs a new copy of the input ExportLineweightKey object.
Public method | ExportLineweightKey(Int32) | Constructs a new default ExportLineweightKey using the original line weight as input.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalLineweight | The original line weight.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLineweightKey
Top
See Also

Reference

Autodesk.Revit.DB Namespace