NurbsSurfaceData Class

OBJExportOptions Class

The export options used by exporting to OBJ file format.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBIMExportOptions
Autodesk.Revit.DBOBJExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OBJExportOptions : BIMExportOptions
Public Class OBJExportOptions
    Inherits BIMExportOptions
public ref class OBJExportOptions : public BIMExportOptions
type OBJExportOptions =
    class
        inherit BIMExportOptions
    end

The OBJExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | OBJExportOptions | Constructs a new instance of OBJExportOptions with default values of all properties.
Public method | OBJExportOptions(ExportResolution) | Constructs a new instance of OBJExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.
Top
Properties
 | Name | Description
Public property | GridAspectRatio | The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public property | MaxEdgeLength | The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public property | NormalTolerance | The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public property | SurfaceTolerance | The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public property | TargetUnit | The unit type of geometry in the resultant OBJ file. Default value is ExportUnit::Default.
Top
Methods
 | Name | Description
Public method | IsGridAspectRatioSet | Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public method | IsMaxEdgeLengthSet | Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public method | IsNormalToleranceSet | Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public method | IsSurfaceToleranceSet | Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
 | IsValidForGridAspectRatio | Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
 | IsValidForMaxEdgeLength | Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
 | IsValidForNormalTolerance | Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
 | IsValidForSurfaceTolerance | Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public method | SetTessellationSettings | Sets all the tessellation parameters to its predefined values for the given resolution type.
Top
See Also

Reference

Autodesk.Revit.DB Namespace