ParameterValueProvider Class

Part Class

This element represents a part of another element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBPart

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Part : Element
Public Class Part
    Inherits Element
public ref class Part : public Element
type Part =
    class
        inherit Element
    end

The Part type exposes the following members.

Properties
 | Name | Description
Public property | Excluded | True if the part is excluded, false otherwise
Public property | OriginalCategoryId | The category Id of the original element corresponding to this Part.
Public property | PartMaker | The PartMaker that created this Part.
Top
Methods
 | Name | Description
Public method | CanOffsetFace | Checks if it is possible to offset the given face.
Public method | GetFaceOffset | Get face offset of the given part face.
Public method | GetSourceElementIds | Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.
Public method | GetSourceElementOriginalCategoryIds | Gets the category ids of the source elements which were used to form this part.
Public method | ResetFaceOffset | Resets the offset applied to the given part face.
Public method | ResetPartShape | Resets all face offsets applied to part faces.
Public method | SetFaceOffset | Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.
Top
Remarks
A part is associated with a PartMaker element that creates it.
See Also

Reference

Autodesk.Revit.DB Namespace