ExternallyTaggedBRep Class

ExternallyTaggedGeometryObject Class

Base class for ExternallyTaggedGeometryObject and ExternallyTaggedSolid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternallyTaggedGeometryObject
Autodesk.Revit.DBExternallyTaggedBRep
Autodesk.Revit.DBExternallyTaggedNonBRep

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternallyTaggedGeometryObject : IDisposable
Public Class ExternallyTaggedGeometryObject
    Implements IDisposable
public ref class ExternallyTaggedGeometryObject : IDisposable
type ExternallyTaggedGeometryObject =
    class
        interface IDisposable
    end

The ExternallyTaggedGeometryObject type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | The external Id of the geometry object.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternallyTaggedGeometryObject
Top
See Also

Reference

Autodesk.Revit.DB Namespace