ElementDesignOptionFilter Class

ElementFilter Class

A base class for a type of filter that accepts or rejects elements based upon criteria.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementSlowFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementFilter : IDisposable
Public Class ElementFilter
    Implements IDisposable
public ref class ElementFilter : IDisposable
type ElementFilter =
    class
        interface IDisposable
    end

The ElementFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ElementFilter
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.
Top
See Also

Reference

Autodesk.Revit.DB Namespace