CompoundStructure Class

CompoundStructure.GetLayerWidth Method

CompoundStructureGetLayerWidth Method

Retrieves the width of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetLayerWidth(
    int layerIdx
)
Public Function GetLayerWidth (
    layerIdx As Integer
) As Double
public:
double GetLayerWidth(
    int layerIdx
)
member GetLayerWidth :
        layerIdx : int -> float

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.

Return Value

Double
The width of the specified layer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
See Also

Reference