GeometryInstance Class

GeometryObject Class

The common base class for all geometric primitives.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GeometryObject : APIObject
Public Class GeometryObject
    Inherits APIObject
public ref class GeometryObject : public APIObject
type GeometryObject =
    class
        inherit APIObject
    end

The GeometryObject type exposes the following members.

Properties
 | Name | Description
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element.
Public property | Visibility | The visibility.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Overrides ObjectGetHashCode)
Top
Operators
Name | Description
Equality(GeometryObject, GeometryObject) | Determines whether two GeometryObjects are the same.
Inequality(GeometryObject, GeometryObject) | Determines whether two GeometryObjects are different.
Top
See Also

Reference

Autodesk.Revit.DB Namespace