BuiltInFailuresGridChainSketchFailures Class

BuiltInFailures.GridFailures Class

BuiltInFailuresGridFailures Class

Failures about Grid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGridFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GridFailures
Public NotInheritable Class GridFailures
public ref class GridFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GridFailures = class end

The BuiltInFailuresGridFailures type exposes the following members.

Properties
Name | Description
GridEndSegmentsLengthTooShort | The end segment length for a grid must be at least [Length Value]
GridInGridChainCannotMirror | A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.
GridlineAxisTooClose | Axis of gridlines should not change order or be closer than [Value] to each other.
GridlineAxisTooFar | Axis of gridlines should not be further than [Value] to each other.
Top
See Also

Reference

Autodesk.Revit.DB Namespace