SlabShapeEditor Class

SlabShapeEditor Methods

The SlabShapeEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddPoint | Add a point to the element.
Public method | AddPoints | Add an array of points to the element.
Public method | AddSplitLine | Add a split line to the element.
Public method | CreateCreasesFromFoldingLines | Convert selected folding lines to split lines
Public method | DeletePoint | Delete a SlabShapeVertex from the element.
Public method | Dispose |
Public method | DrawPoint | Obsolete. Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Obsolete. Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
 | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the unmodified state.
Top
See Also

Reference