EnergyAnalysisConstruction Class

Represent an analytical construction as a composite of layered materials.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisConstruction

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisConstruction : Element
Public Class EnergyAnalysisConstruction
    Inherits Element
public ref class EnergyAnalysisConstruction : public Element
type EnergyAnalysisConstruction =
    class
        inherit Element
    end

The EnergyAnalysisConstruction type exposes the following members.

Properties
 | Name | Description
Public property | Absorptance | The absorptance value of the construction.
Public property | ConstructionName | The name of the construction
Public property | Description | The description of the construction.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-value) of the construction, in W/(m^2*K) (equivalent to kg/(k*s^3)).
Public property | IsSchematic | Indicates if this originates from a schematic or analytical construction.
Public property | Roughness | The roughness value of the construction, from 1 (Very Rough) to 6 (Very Smooth) and -1 when unset.
Public property | ThermalMass | The thermal mass value (Cth-value) of the construction, in J/(m^2*k) (equivalent to kg/(k*s^2)).
Public property | ThermalResistance | The thermal resistance value (R-value) of the construction, in K*s^3/kg.
Top
Methods
 | Name | Description
Public method | GetMaterialIds | Returns a list of ids of the associated materials to analytical construction.
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace