EdgeArrayIterator Class

EdgeEndPoint Class

Represents the start or the end point of an Edge.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBEdgeEndPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EdgeEndPoint : IDisposable
Public Class EdgeEndPoint
    Implements IDisposable
public ref class EdgeEndPoint : IDisposable
type EdgeEndPoint =
    class
        interface IDisposable
    end

The EdgeEndPoint type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeEndPoint | Constructs an instance of EdgeEndPoint.
Top
Properties
 | Name | Description
Public property | Edge | The Edge.
Public property | Index | The index of the start or the end point of an Edge: 0 is the start point, 1 is the end point.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the EdgeEndPoint
Public method | Equals(EdgeEndPoint) | Determines whether this EdgeEndPoint is equal to another.
Public method | Evaluate | Evaluate the end point of the edge in 3d coordinates.
Top
See Also

Reference

Autodesk.Revit.DB Namespace