BuiltInFailuresPartMakerMethodForMergePartFailures Class

BuiltInFailures.PartMakerMethodForWallFailures Class

BuiltInFailuresPartMakerMethodForWallFailures Class

Failures related to parts related to walls.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPartMakerMethodForWallFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PartMakerMethodForWallFailures
Public NotInheritable Class PartMakerMethodForWallFailures
public ref class PartMakerMethodForWallFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PartMakerMethodForWallFailures = class end

The BuiltInFailuresPartMakerMethodForWallFailures type exposes the following members.

Properties
Name | Description
CouldNotAdjustWallPartsAtJoin | Failed to extend or trim some layer at an end join
CouldNotCreateWallPart | Failed to create basic layer geometry. Probably a failure either to create the cutter or to intersect the cutter with the wall geometry.
CouldNotCreateWallPartDueToWallJoin | Failed to create basic layer geometry due to an excessively short edge created by wall join.
Top
See Also

Reference

Autodesk.Revit.DB Namespace