MEPModel Class

MEPSize Class

Stores the basic size information for an MEP duct, pipe, cable tray, or conduit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMEPSize

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPSize : IDisposable
Public Class MEPSize
    Implements IDisposable
public ref class MEPSize : IDisposable
type MEPSize =
    class
        interface IDisposable
    end

The MEPSize type exposes the following members.

Constructors
 | Name | Description
Public method | MEPSize | Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.
Top
Properties
 | Name | Description
Public property | InnerDiameter | Inner diameter
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NominalDiameter | Nominal diameter
Public property | OuterDiameter | Outer diameter
Public property | UsedInSizeLists | Whether it is used in size lists.
Public property | UsedInSizing | Whether is used in sizing.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MEPSize
Top
See Also

Reference

Autodesk.Revit.DB Namespace