MassLevelData Class

MassLevelData is a conceptual representation of an occupiable floor (Mass Floor) in a conceptual building model. It is defined by associating a particular level with a particular mass element in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisMassLevelData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MassLevelData : Element
Public Class MassLevelData
    Inherits Element
public ref class MassLevelData : public Element
type MassLevelData =
    class
        inherit Element
    end

The MassLevelData type exposes the following members.

Properties
 | Name | Description
Public property | ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData (Mass Floor).
Public property | ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData (Mass Floor) is synchronized with the EnergyDataSettings or if it overrides those settings.
Public property | MaterialId | The ElementId of the visualization material used for the MassLevelData (Mass Floor)
Public property | MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Public property | NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
Public property | NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
Public property | NVolume | The volume of from the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | OwningMassId | The ElementId of the mass that the MassLevelData (Mass Floor) is associated with.
Public property | StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.
Top
Methods
 | Name | Description
Public method | IsEmpty | Indicates if the MassLevelData (Mass Floor) has a geometrical representation. May not if the level does not intersect the mass geometry.
 | IsMassFamilyInstance | Checks if the ElementId is a mass family instance.
Public method | IsValidConceptualConstructionTypeElement | Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).
Top
Remarks
MassLevelData reports metrics, such as floor areas, related to conceptual space planning. MassLevelData contains information, such as ConceptualConstructionType, used as part of the Conceptual Energy Analytical model. The MassLevel data geometry is determined by combining all the geometry of a mass into a single geometry, and then taking the area of intersection with the level of the MassLevelData.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace