KeyBasedTreeEntriesLoadContent Class

KeyBasedTreeEntriesLoadResults Class

This class contains the results and status information regarding an attempt to load the KeyBasedTreeEntries from an External Resource.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntriesLoadResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntriesLoadResults : IDisposable
Public Class KeyBasedTreeEntriesLoadResults
    Implements IDisposable
public ref class KeyBasedTreeEntriesLoadResults : IDisposable
type KeyBasedTreeEntriesLoadResults =
    class
        interface IDisposable
    end

The KeyBasedTreeEntriesLoadResults type exposes the following members.

Constructors
 | Name | Description
Public method | KeyBasedTreeEntriesLoadResults | Creates an empty KeyBasedTreeEntriesLoadResults.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntriesLoadResults
Public method | GetFailureMessages | Get all error or warnings created while attempting to load KeyBasedTreeEntries.
Public method | GetFileReadErrors | Gets the names of any files which could not be read due to access errors.
Public method | GetFileSyntaxErrors | Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries.
Public method | GetKeyBasedTreeEntryErrors | Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.
Public method | GetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) | Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.
Top
Remarks

A KeyBasedTreeEntriesLoadResults object is returned by the KeynoteTable or AssemblyCodeTable API methods LoadFrom() and Reload() so that callers can determine whether the KeynoteTable or AssemblyCodeTable was updated successfully and what, if any, errors occurred.

See Also

Reference

Autodesk.Revit.DB Namespace