ElementFilter Class
PassesFilter Overload

ElementId Class

The ElementId object is used as a unique identification for an element within a single project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementId
Public Class ElementId
public ref class ElementId
type ElementId = class end

The ElementId type exposes the following members.

Constructors
 | Name | Description
Public method | ElementId(BuiltInCategory) | Create an ElementId handle with the given BuiltInCategory id.
Public method | ElementId(BuiltInParameter) | Create an ElementId handle with the given BuiltInParameter id.
Public method | ElementId(Int32) | Obsolete. Create an ElementId handle with the given 32-bit integer id.
Public method | ElementId(Int64) | Create an ElementId handle with the given 64-bit integer id.
Top
Properties
 | Name | Description
Public property | IntegerValue | Obsolete. Provides the value of the element id as a 32-bit integer.
 | InvalidElementId | Get the invalid ElementId whose value is -1.
Public property | Value | Provides the value of the element id as a 64-bit integer.
Top
Methods
 | Name | Description
Public method | Compare | Compares two element ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the value of the id as hash code (Overrides ObjectGetHashCode)
 | Parse | Parse the string representation of the id into a corresponding ElementId.
Public method | ToString | Gets a String representation of the value of the id. (Overrides ObjectToString)
 | TryParse | Parse the string representation of the id into a corresponding ElementId.
Top
Operators
Name | Description
Equality(ElementId, ElementId) | Determines whether these two ElementIds are the same.
GreaterThan(ElementId, ElementId) | Determines whether one element id is greater than another element id.
GreaterThanOrEqual(ElementId, ElementId) | Determines whether one element id is not less than another element id.
Inequality(ElementId, ElementId) | Determines whether these two ElementIds are different.
LessThan(ElementId, ElementId) | Determines whether this element id is less than another element id.
LessThanOrEqual(ElementId, ElementId) | Determines whether one element id is not greater than another element id.
Top
Remarks
The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.
See Also

Reference

Autodesk.Revit.DB Namespace