Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBEdge
Autodesk.Revit.DBFace
Autodesk.Revit.DBGeometryElement
Autodesk.Revit.DBGeometryInstance
Autodesk.Revit.DBMesh
Autodesk.Revit.DBPoint
Autodesk.Revit.DBPolyLine
Autodesk.Revit.DBProfile
Autodesk.Revit.DBSolid

GeometryObject Properties

The GeometryObject type exposes the following members.

Properties
 | Name | Description
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element.
Public property | Visibility | The visibility.
Top
See Also

Reference