FamilyThermalProperties Class

FamilyType Class

The family type object provides read access to the values of family parameters for this type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyType : APIObject
Public Class FamilyType
    Inherits APIObject
public ref class FamilyType : public APIObject
type FamilyType =
    class
        inherit APIObject
    end

The FamilyType type exposes the following members.

Properties
 | Name | Description
Public property | Name | The name of the family type.
Top
Methods
 | Name | Description
Public method | AsDouble | Provides access to the double precision number of the given family parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Public method | AsInteger | Provides access to the integer number of the given family parameter.
Public method | AsString | Provides access to the string contents of the given family parameter.
Public method | AsValueString | Provides access to value as a string with unit in the given family parameter.
Public method | HasValue | Indicates if this family parameter has an assigned value or not.
Top
See Also

Reference

Autodesk.Revit.DB Namespace