XYZ Class
Multiply Overload

XYZ.Multiply(XYZ, Double) Operator

XYZMultiply(XYZ, Double) Operator

Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ operator *(
    XYZ left,
    double value
)
Public Shared Operator * (
    left As XYZ,
    value As Double
) As XYZ
public:
static XYZ^ operator *(
    XYZ^ left,
    double value
)
static let inline (*)
        left : XYZ *
        value : float  : XYZ

Parameters

left XYZ
The vector to multiply with the value.
value Double
The value to multiply with the specified vector.

Return Value

XYZ
The multiplied vector.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
ArgumentException | Thrown when the specified value is an infinite number.
Remarks
The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.
See Also

Reference